Toolkit Pro: XTPTreeBase.h Source File

Toolkit Pro v24.3.0
for Visual C++ ( MFC )
  • Source
  • Controls
  • Tree
XTPTreeBase.h
Go to the documentation of this file.
1
23#if !defined(__XTTREEBASE_H__)
24# define __XTTREEBASE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTreeTheme;
34class CXTPWinThemeWrapper;
35
42class _XTP_EXT_CLASS CXTPTreeBase
43{
44protected:
53 struct CLRFONT
54 {
59 CLRFONT();
60
61 LOGFONT logfont;
62 COLORREF color;
63 COLORREF colorBack;
65 };
66
77 typedef CMap<void*, void*, CLRFONT, CLRFONT&> CColorFontMap;
78
79protected:
85 CXTPTreeBase();
86
91 virtual ~CXTPTreeBase();
92
93public:
102 virtual HTREEITEM GetNextItem(HTREEITEM hItem) const;
103
133 virtual HTREEITEM GetNextItem(HTREEITEM hItem, UINT nCode) const;
134
143 virtual HTREEITEM GetPrevItem(HTREEITEM hItem) const;
144
153 virtual HTREEITEM GetLastItem(HTREEITEM hItem) const;
154
170 virtual HTREEITEM FindItem(LPCTSTR lpszSearch, BOOL bCaseSensitive = FALSE,
171 BOOL bDownDir = TRUE, BOOL bWholeWord = FALSE,
172 HTREEITEM hItem = NULL);
173
188 virtual HTREEITEM FindItemExact(LPCTSTR lpszSearch, BOOL bCaseSensitive = FALSE,
189 BOOL bDownDir = TRUE, HTREEITEM hItem = NULL);
190
205 virtual HTREEITEM FindItemInBranch(LPCTSTR lpszSearch, BOOL bCaseSensitive /*= FALSE*/,
206 BOOL bWholeWord /*= FALSE*/, HTREEITEM htiItem /*= NULL*/);
207
214 virtual void SetItemFont(HTREEITEM hItem, LOGFONT& logfont);
215
225 virtual BOOL GetItemFont(HTREEITEM hItem, LOGFONT* plogfont);
226
233 virtual void SetItemBold(HTREEITEM hItem, BOOL bBold = TRUE);
234
242 virtual BOOL GetItemBold(HTREEITEM hItem);
243
250 virtual void SetItemColor(HTREEITEM hItem, COLORREF color);
251
258 virtual void SetItemBackColor(HTREEITEM hItem, COLORREF color);
259
269 virtual COLORREF GetItemColor(HTREEITEM hItem);
270
280 virtual COLORREF GetItemBackColor(HTREEITEM hItem);
281
290 virtual BOOL EnableMultiSelect(BOOL bMultiSelect = TRUE);
291
300 virtual HTREEITEM GetPrevSelectedItem(HTREEITEM hItem) const;
301
310 virtual HTREEITEM GetNextSelectedItem(HTREEITEM hItem) const;
311
319 virtual HTREEITEM GetFirstSelectedItem() const;
320
327 virtual UINT GetSelectedCount() const;
328
346 BOOL SetItemState(HTREEITEM hItem, UINT nState, UINT nStateMask);
347
361 UINT GetItemState(HTREEITEM hItem, UINT nStateMask) const;
362
373 BOOL SelectItem(HTREEITEM hItem);
374
382 HTREEITEM GetFocusedItem() const;
383
392 BOOL FocusItem(HTREEITEM hItem);
393
402 virtual void SelectAll(BOOL bSelect = TRUE, HTREEITEM htItem = NULL);
403
415 virtual void SelectItems(HTREEITEM hItemFrom, HTREEITEM hItemTo, BOOL bOnly = TRUE);
416
424 virtual BOOL IsSelected(HTREEITEM hItem) const;
425
438 BOOL SelectChildren(HTREEITEM hParent, BOOL bSelect = TRUE, BOOL bRecurse = TRUE);
439
446 void GetSelectedList(CTypedPtrList<CPtrList, HTREEITEM>& list) const;
447
455 BOOL IsMultiSelect() const;
456
464 BOOL IsExplorerTheme() const;
465
471 void SetExplorerTheme(BOOL bSet);
472
486 BOOL SetBandingHit(BOOL bLabel);
487
496 BOOL IsDefaultItemDrawingEnabled() const;
497
505 void EnableDefaultItemDrawing(BOOL bEnable = TRUE);
506
514 int SetIconIndent(int iconIndent);
515
522 int GetIconIndent() const;
523
524protected:
532 virtual bool Init();
533
549 virtual LRESULT SendNotify(LPNMHDR pNMHDR);
550
561 virtual void SelectAllIgnore(BOOL bSelect, HTREEITEM hIgnore);
562
580 virtual BOOL OnButtonDown(BOOL bLeft, UINT nFlags, CPoint point);
581
597 virtual void DoPreSelection(HTREEITEM hItem, BOOL bLeft, UINT nFlags);
598
615 virtual void DoAction(HTREEITEM hItem, BOOL bLeft, UINT nFlags, CPoint point);
616
631 virtual void DoBanding(UINT nFlags, CPoint point);
632
650 virtual void UpdateSelectionForRect(LPCRECT pRect, UINT nFlags,
651 CTypedPtrList<CPtrList, HTREEITEM>& list);
652
667 virtual BOOL IsFindValid(HTREEITEM hti);
668
680 virtual void DoPaint(CDC& dc, BOOL bInternal = TRUE);
681
691 virtual COLORREF GetTreeBackColor() const;
692
702 virtual COLORREF GetTreeTextColor() const;
703
712 virtual CRect GetItemIconRect(HTREEITEM hItem) const;
713
723 virtual CRect GetItemStateIconRect(HTREEITEM hItem, const CRect& rcIcon) const;
724
736 virtual CRect GetItemExpanderRect(HTREEITEM hItem, CDC* pDC, const CRect& rcIcon,
737 const CRect& rcStateIcon) const;
738
746 void DrawItem(CDC* pDC, HTREEITEM hItem, const COLORREF crBack);
748 _XTP_DEPRECATED_IN_FAVOR_("DrawItem(CDC *pDC, HTREEITEM hItem, const COLORREF crBack)")
749 void DrawItem(CDC* pDC, HTREEITEM hItem);
761 void DrawDarkThemeExpander(CDC* pDC, COLORREF crBack, CRect rcItem, CRect rcExpander, int nPart,
762 int nState) const;
763
784 virtual COLORREF GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle,
785 COLORREF crBack) const;
786
807 virtual COLORREF GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle,
808 COLORREF crText) const;
809
816 bool HasEditLabels() const;
817
836 virtual HTREEITEM FindItemImpl(LPCTSTR lpszSearch, BOOL bCaseSensitive = FALSE,
837 BOOL bDownDir = TRUE, BOOL bWholeWord = FALSE,
838 HTREEITEM hItem = NULL, BOOL bExactlySameStr = FALSE);
839
846 virtual BOOL IsFullRowSelectionEnabled();
847
858 BOOL SetInsertMark(HTREEITEM hItem, BOOL fAfter);
859
866 COLORREF GetInsertMarkColor() const;
867
875 COLORREF SetInsertMarkColor(COLORREF clrNew);
876
877public:
878 void SetTheme(int nTheme); /* XTPControlTheme */
879
880 void RefreshMetrics();
881
882 CTreeCtrl* GetSelfTreeCtrl() const;
883
884 int GetTheme() const;
885
886protected:
888 //{{AFX_VIRTUAL(CXTPTreeBase)
889 virtual BOOL PreTranslateMessage(MSG* pMsg);
890 virtual BOOL OnNotify(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
891 //}}AFX_VIRTUAL
892
893 //{{AFX_MSG(CXTPTreeBase)
894 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
895 afx_msg void OnSetFocus(CWnd* pOldWnd);
896 afx_msg void OnKillFocus(CWnd* pNewWnd);
897 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
898 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
899 afx_msg void OnSize(UINT nType, int cx, int cy);
900 afx_msg BOOL OnDeleteItem(NMHDR* pNMHDR, LRESULT* pResult);
901 afx_msg BOOL OnItemExpanding(NMHDR* pNMHDR, LRESULT* pResult);
902 afx_msg BOOL OnBeginLabelEdit(NMHDR* pNMHDR, LRESULT* pResult);
903 afx_msg BOOL OnEndLabelEdit(NMHDR* pNMHDR, LRESULT* pResult);
904 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
905 afx_msg void OnTimer(UINT_PTR nIDEvent);
906 afx_msg void OnNcMouseMove(UINT nHitTest, CPoint point);
907 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
908 //}}AFX_MSG
909
910private:
911 void DrawDottedLine(CDC* pDC, const CPoint& ptStart, const CPoint& ptEnd);
912
926 HTREEITEM FindVisibleItem(UINT nChar, UINT nFlags);
927
930protected:
932 // Needed in order to access protected functions.
933 class CTreeCtrl_Friendly : public CTreeCtrl
934 {
935 friend class CXTPTreeBase;
936 };
939protected:
940 BOOL m_bMultiSelect;
941 BOOL m_bBandLabel;
942 BOOL m_bExplorerTheme;
943 HTREEITEM m_hSelect;
944 HTREEITEM m_htiEdit;
945 HTREEITEM m_htiLast;
946 CColorFontMap m_mapColorFont;
948 CTreeCtrl_Friendly* m_pTreeCtrl;
950 int m_nTheme;
952 CXTPTreeTheme* m_pTheme;
953
954 CXTPWinThemeWrapper* m_pWindowsTreeTheme;
955
956 BOOL m_bDoDefaultItemDrawing;
959 int m_iconIndent;
961 HTREEITEM m_hInsertMark;
962 BOOL m_InsertMarkAfter;
963 COLORREF m_InsertMarkColor;
965private:
966 CPen m_penLines;
967 bool m_bActionDone;
968 bool m_bOkToEdit;
969};
970
972
973AFX_INLINE HTREEITEM CXTPTreeBase::GetNextItem(HTREEITEM hItem, UINT nCode) const
974{
975 _ASSERTE(::IsWindow(m_pTreeCtrl->m_hWnd));
976 return m_pTreeCtrl->GetNextItem(hItem, nCode);
977}
978AFX_INLINE HTREEITEM CXTPTreeBase::GetFocusedItem() const
979{
980 _ASSERTE(m_bMultiSelect);
981 return m_pTreeCtrl->GetSelectedItem();
982}
983AFX_INLINE BOOL CXTPTreeBase::IsSelected(HTREEITEM hItem) const
984{
985 return !!(TVIS_SELECTED & m_pTreeCtrl->GetItemState(hItem, TVIS_SELECTED));
986}
987AFX_INLINE BOOL CXTPTreeBase::IsMultiSelect() const
988{
989 return m_bMultiSelect;
990}
991AFX_INLINE BOOL CXTPTreeBase::IsExplorerTheme() const
992{
993 return m_bExplorerTheme;
994}
995AFX_INLINE BOOL CXTPTreeBase::SetBandingHit(BOOL bLabel)
996{
997 BOOL bReturn = m_bBandLabel;
998 m_bBandLabel = bLabel;
999 return bReturn;
1000}
1001AFX_INLINE CXTPTreeBase::CLRFONT::CLRFONT()
1002 : color((COLORREF)-1)
1003 , colorBack((COLORREF)-1)
1004{
1005 ::ZeroMemory(&logfont, sizeof(LOGFONT));
1006}
1007
1008AFX_INLINE CTreeCtrl* CXTPTreeBase::GetSelfTreeCtrl() const
1009{
1010 return m_pTreeCtrl;
1011}
1012
1013AFX_INLINE int CXTPTreeBase::GetTheme() const
1014{
1015 return m_nTheme;
1016}
1017
1018AFX_INLINE BOOL CXTPTreeBase::IsDefaultItemDrawingEnabled() const
1019{
1020 return m_bDoDefaultItemDrawing;
1021}
1022
1023AFX_INLINE void CXTPTreeBase::EnableDefaultItemDrawing(BOOL bEnable /*= TRUE*/)
1024{
1025 m_bDoDefaultItemDrawing = bEnable;
1026}
1029# define DECLARE_TREE_BASE(ClassName, Tree, Base) \
1030 class _XTP_EXT_CLASS ClassName \
1031 : public Tree \
1032 , public Base \
1033 { \
1034 public: \
1035 ClassName() \
1036 { \
1037 m_bPreSubclassInit = true; \
1038 } \
1039 virtual UINT GetItemState(HTREEITEM hItem, UINT nStateMask) const \
1040 { \
1041 return Base::GetItemState(hItem, nStateMask); \
1042 } \
1043 virtual BOOL SelectItem(HTREEITEM hItem) \
1044 { \
1045 return Base::SelectItem(hItem); \
1046 } \
1047 virtual BOOL SetItemState(HTREEITEM hItem, UINT nState, UINT nStateMask) \
1048 { \
1049 return Base::SetItemState(hItem, nState, nStateMask); \
1050 } \
1051 virtual HTREEITEM GetNextItem(HTREEITEM hItem, UINT nCode) const \
1052 { \
1053 return Base::GetNextItem(hItem, nCode); \
1054 } \
1055 virtual HTREEITEM GetNextItem(HTREEITEM hItem) const \
1056 { \
1057 return Base::GetNextItem(hItem); \
1058 } \
1059 UINT GetSelectedCount() const \
1060 { \
1061 return Base::GetSelectedCount(); \
1062 } \
1063 BOOL SetInsertMark(HTREEITEM hItem, BOOL fAfter = TRUE) \
1064 { \
1065 return Base::SetInsertMark(hItem, fAfter); \
1066 } \
1067 COLORREF GetInsertMarkColor() const \
1068 { \
1069 return Base::GetInsertMarkColor(); \
1070 } \
1071 COLORREF SetInsertMarkColor(COLORREF clrNew) \
1072 { \
1073 return Base::SetInsertMarkColor(clrNew); \
1074 } \
1075 \
1076 protected: \
1077 virtual BOOL OnNotify(WPARAM wParam, LPARAM lParam, LRESULT* pResult) \
1078 { \
1079 return Base::OnNotify(wParam, lParam, pResult); \
1080 } \
1081 virtual BOOL PreTranslateMessage(MSG* pMsg) \
1082 { \
1083 return Base::PreTranslateMessage(pMsg); \
1084 } \
1085 virtual bool Init() \
1086 { \
1087 return Base::Init(); \
1088 } \
1089 virtual void PreSubclassWindow() \
1090 { \
1091 Tree::PreSubclassWindow(); \
1092 if (m_bPreSubclassInit) \
1093 Init(); \
1094 } \
1095 virtual BOOL PreCreateWindow(CREATESTRUCT& cs) \
1096 { \
1097 if (!Tree::PreCreateWindow(cs)) \
1098 return FALSE; \
1099 m_bPreSubclassInit = false; \
1100 return TRUE; \
1101 } \
1102 bool m_bPreSubclassInit; \
1103 afx_msg void OnLButtonDown(UINT nFlags, CPoint point) \
1104 { \
1105 Base::OnLButtonDown(nFlags, point); \
1106 } \
1107 afx_msg void OnRButtonDown(UINT nFlags, CPoint point) \
1108 { \
1109 Base::OnRButtonDown(nFlags, point); \
1110 } \
1111 afx_msg void OnSetFocus(CWnd* pOldWnd) \
1112 { \
1113 Base::OnSetFocus(pOldWnd); \
1114 } \
1115 afx_msg void OnKillFocus(CWnd* pNewWnd) \
1116 { \
1117 Base::OnKillFocus(pNewWnd); \
1118 } \
1119 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) \
1120 { \
1121 Base::OnKeyDown(nChar, nRepCnt, nFlags); \
1122 } \
1123 afx_msg BOOL OnBeginLabelEdit(NMHDR* pNMHDR, LRESULT* pResult) \
1124 { \
1125 return Base::OnBeginLabelEdit(pNMHDR, pResult); \
1126 } \
1127 afx_msg BOOL OnEndLabelEdit(NMHDR* pNMHDR, LRESULT* pResult) \
1128 { \
1129 return Base::OnEndLabelEdit(pNMHDR, pResult); \
1130 } \
1131 afx_msg BOOL OnItemExpanding(NMHDR* pNMHDR, LRESULT* pResult) \
1132 { \
1133 return Base::OnItemExpanding(pNMHDR, pResult); \
1134 } \
1135 afx_msg BOOL OnDeleteItem(NMHDR* pNMHDR, LRESULT* pResult) \
1136 { \
1137 return Base::OnDeleteItem(pNMHDR, pResult); \
1138 } \
1139 afx_msg void OnSize(UINT nType, int cx, int cy) \
1140 { \
1141 Base::OnSize(nType, cx, cy); \
1142 } \
1143 afx_msg void OnMouseMove(UINT nFlags, CPoint point) \
1144 { \
1145 Base::OnMouseMove(nFlags, point); \
1146 } \
1147 afx_msg void OnTimer(UINT_PTR nIDEvent) \
1148 { \
1149 Base::OnTimer(nIDEvent); \
1150 } \
1151 afx_msg void OnNcMouseMove(UINT nHitTest, CPoint point) \
1152 { \
1153 Base::OnNcMouseMove(nHitTest, point); \
1154 } \
1155 afx_msg BOOL OnEraseBkgnd(CDC*) \
1156 { \
1157 return TRUE; \
1158 } \
1159 afx_msg void OnPaint() \
1160 { \
1161 CPaintDC dc(this); \
1162 DoPaint(dc); \
1163 } \
1164 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct) \
1165 { \
1166 if (Tree::OnCreate(lpCreateStruct) == -1) \
1167 return -1; \
1168 Init(); \
1169 return 0; \
1170 } \
1171 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam) \
1172 { \
1173 return Base::OnSetTheme(wParam, lParam); \
1174 } \
1175 };
1176
1177# define ON_TREECTRL_REFLECT \
1178 ON_MESSAGE(WM_XTP_SETCONTROLTHEME, OnSetTheme) \
1179 ON_WM_LBUTTONDOWN() \
1180 ON_WM_SETFOCUS() \
1181 ON_WM_KILLFOCUS() \
1182 ON_WM_RBUTTONDOWN() \
1183 ON_WM_KEYDOWN() \
1184 ON_WM_ERASEBKGND() \
1185 ON_WM_PAINT() \
1186 ON_WM_SIZE() \
1187 ON_NOTIFY_REFLECT_EX(TVN_DELETEITEM, OnDeleteItem) \
1188 ON_NOTIFY_REFLECT_EX(TVN_ITEMEXPANDING, OnItemExpanding) \
1189 ON_NOTIFY_REFLECT_EX(TVN_BEGINLABELEDIT, OnBeginLabelEdit) \
1190 ON_NOTIFY_REFLECT_EX(TVN_ENDLABELEDIT, OnEndLabelEdit) \
1191 ON_WM_MOUSEMOVE() \
1192 ON_WM_TIMER() \
1193 ON_WM_NCMOUSEMOVE() \
1194 ON_WM_CREATE
1195
1198const DWORD TVIS_FOCUSED = 0x0001;
1200# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1202#endif // !defined(__XTTREEBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
TVIS_FOCUSED
const DWORD TVIS_FOCUSED
Definition XTPTreeBase.h:1198
CXTPTreeBase
CXTPTreeBase is a CTreeView derived class.
Definition XTPTreeBase.h:43
CXTPTreeBase::FocusItem
BOOL FocusItem(HTREEITEM hItem)
This member function will set the focus for the tree item specified by 'hItem'.
CXTPTreeBase::m_mapColorFont
CColorFontMap m_mapColorFont
Maps HTREEITEM handles with CLRFONT structures that contains the color and logfont information for th...
Definition XTPTreeBase.h:946
CXTPTreeBase::GetSelectedCount
virtual UINT GetSelectedCount() const
This member function retrieves the number of tree items that are selected.
CXTPTreeBase::FindItemInBranch
virtual HTREEITEM FindItemInBranch(LPCTSTR lpszSearch, BOOL bCaseSensitive, BOOL bWholeWord, HTREEITEM htiItem)
This member function searches the entire branch specified by 'htiItem' for an item label that contain...
CXTPTreeBase::m_bMultiSelect
BOOL m_bMultiSelect
TRUE for a multi-selection tree control.
Definition XTPTreeBase.h:940
CXTPTreeBase::SetItemState
BOOL SetItemState(HTREEITEM hItem, UINT nState, UINT nStateMask)
This member function is a replacement for the base class function of the same name,...
CXTPTreeBase::m_hSelect
HTREEITEM m_hSelect
For shift selection.
Definition XTPTreeBase.h:943
CXTPTreeBase::GetItemIconRect
virtual CRect GetItemIconRect(HTREEITEM hItem) const
Computes an item icon rectangle.
CXTPTreeBase::EnableDefaultItemDrawing
void EnableDefaultItemDrawing(BOOL bEnable=TRUE)
Enables/disables default item drawing method.
CXTPTreeBase::GetItemColor
virtual COLORREF GetItemColor(HTREEITEM hItem)
This member function returns the RGB value for the specified tree item text color,...
CXTPTreeBase::SetItemBackColor
virtual void SetItemBackColor(HTREEITEM hItem, COLORREF color)
This member function sets the tree item background color.
CXTPTreeBase::GetNextItem
virtual HTREEITEM GetNextItem(HTREEITEM hItem) const
This member function will retrieve the tree view item that has the specified relationship,...
CXTPTreeBase::SendNotify
virtual LRESULT SendNotify(LPNMHDR pNMHDR)
Sends a WM_NOTIFY message to the tree control owner window.
CXTPTreeBase::CXTPTreeBase
CXTPTreeBase()
Protected constructor used by dynamic creation.
CXTPTreeBase::GetItemExpanderRect
virtual CRect GetItemExpanderRect(HTREEITEM hItem, CDC *pDC, const CRect &rcIcon, const CRect &rcStateIcon) const
Computes an item expander rectangle.
CXTPTreeBase::m_iconIndent
int m_iconIndent
Indent between icon/text/expander.
Definition XTPTreeBase.h:959
CXTPTreeBase::DrawItem
void DrawItem(CDC *pDC, HTREEITEM hItem, const COLORREF crBack)
Custom drawing of an item along with its icon and lines if necessary.
CXTPTreeBase::SetItemFont
virtual void SetItemFont(HTREEITEM hItem, LOGFONT &logfont)
This member function sets the font for the reference tree item.
CXTPTreeBase::m_hInsertMark
HTREEITEM m_hInsertMark
Tree item the insertion mark will be placed.
Definition XTPTreeBase.h:961
CXTPTreeBase::m_bBandLabel
BOOL m_bBandLabel
TRUE to include the label when selecting tree items.
Definition XTPTreeBase.h:941
CXTPTreeBase::GetNextSelectedItem
virtual HTREEITEM GetNextSelectedItem(HTREEITEM hItem) const
This member function retrieves the next selected item in a multi-selection tree control.
CXTPTreeBase::FindItem
virtual HTREEITEM FindItem(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL)
This member function searches the entire tree for an item label that contains the search string.
CXTPTreeBase::GetFocusedItem
HTREEITEM GetFocusedItem() const
This member function retrieves the handle to the tree item that currently has focus.
CXTPTreeBase::SetIconIndent
int SetIconIndent(int iconIndent)
Sets the indent between the icon/text/expander.
CXTPTreeBase::OnButtonDown
virtual BOOL OnButtonDown(BOOL bLeft, UINT nFlags, CPoint point)
Called when a mouse button click event occurs.
CXTPTreeBase::GetFirstSelectedItem
virtual HTREEITEM GetFirstSelectedItem() const
This member function retrieves the first selected item in a multi-selection tree control.
CXTPTreeBase::DoBanding
virtual void DoBanding(UINT nFlags, CPoint point)
Draws a selection rectangle during item selection.
CXTPTreeBase::CColorFontMap
CMap< void *, void *, CLRFONT, CLRFONT & > CColorFontMap
Map for maintaining HTREEITEM to CLRFONT structure relationships.
Definition XTPTreeBase.h:77
CXTPTreeBase::DoPreSelection
virtual void DoPreSelection(HTREEITEM hItem, BOOL bLeft, UINT nFlags)
Called during item selection in a multi-selection tree control.
CXTPTreeBase::GetTreeTextColor
virtual COLORREF GetTreeTextColor() const
Retrieves the tree control's text color.
CXTPTreeBase::UpdateSelectionForRect
virtual void UpdateSelectionForRect(LPCRECT pRect, UINT nFlags, CTypedPtrList< CPtrList, HTREEITEM > &list)
Updates tree item selection.
CXTPTreeBase::IsDefaultItemDrawingEnabled
BOOL IsDefaultItemDrawingEnabled() const
This member function checks if the tree control uses default (system specific) item drawing method.
CXTPTreeBase::m_htiLast
HTREEITEM m_htiLast
Tree item that last had the mouse over.
Definition XTPTreeBase.h:945
CXTPTreeBase::DoPaint
virtual void DoPaint(CDC &dc, BOOL bInternal=TRUE)
Called to render the tree control.
CXTPTreeBase::SetItemBold
virtual void SetItemBold(HTREEITEM hItem, BOOL bBold=TRUE)
This member function sets the reference tree item font to bold.
CXTPTreeBase::GetPrevItem
virtual HTREEITEM GetPrevItem(HTREEITEM hItem) const
This member function gets the previous item as if the outline was completely expanded.
CXTPTreeBase::GetLastItem
virtual HTREEITEM GetLastItem(HTREEITEM hItem) const
This member function retrieves the last item in the branch.
CXTPTreeBase::~CXTPTreeBase
virtual ~CXTPTreeBase()
Destroys a CXTPTreeBase object, handles cleanup and deallocation.
CXTPTreeBase::m_InsertMarkColor
COLORREF m_InsertMarkColor
Insertion mark color.
Definition XTPTreeBase.h:963
CXTPTreeBase::GetItemBold
virtual BOOL GetItemBold(HTREEITEM hItem)
This member function checks whether or not a tree item has a bold font.
CXTPTreeBase::IsMultiSelect
BOOL IsMultiSelect() const
This member function checks to see if the tree control is a multi-selection tree.
CXTPTreeBase::SelectChildren
BOOL SelectChildren(HTREEITEM hParent, BOOL bSelect=TRUE, BOOL bRecurse=TRUE)
This member function will cause all of the children of the specified tree item to be selected or dese...
CXTPTreeBase::IsExplorerTheme
BOOL IsExplorerTheme() const
This member function checks to see if the tree control has Explorer theme applied.
CXTPTreeBase::SelectItem
BOOL SelectItem(HTREEITEM hItem)
This member function is a replacement for the base class function of the same name,...
CXTPTreeBase::IsFindValid
virtual BOOL IsFindValid(HTREEITEM hti)
Member override to determine if a tree item is valid.
CXTPTreeBase::GetItemState
UINT GetItemState(HTREEITEM hItem, UINT nStateMask) const
This member function is a replacement for the base class function of the same name,...
CXTPTreeBase::SetBandingHit
BOOL SetBandingHit(BOOL bLabel)
This member function sets the banding mode for a multi-selection tree control.
CXTPTreeBase::SelectAllIgnore
virtual void SelectAllIgnore(BOOL bSelect, HTREEITEM hIgnore)
Toggles selection for all items in a multi-selection tree control.
CXTPTreeBase::SelectItems
virtual void SelectItems(HTREEITEM hItemFrom, HTREEITEM hItemTo, BOOL bOnly=TRUE)
This member function selects items from 'hItemFrom' to 'hItemTo' in a multi-selection tree control.
CXTPTreeBase::SetExplorerTheme
void SetExplorerTheme(BOOL bSet)
This member function sets the Explorer theme applied (Vista+).
CXTPTreeBase::SetItemColor
virtual void SetItemColor(HTREEITEM hItem, COLORREF color)
This member function sets the tree item text color.
CXTPTreeBase::m_bDoDefaultItemDrawing
BOOL m_bDoDefaultItemDrawing
FALSE by default, which means an item will be drawn by the framework.
Definition XTPTreeBase.h:956
CXTPTreeBase::DoAction
virtual void DoAction(HTREEITEM hItem, BOOL bLeft, UINT nFlags, CPoint point)
Called during item selection in a multi-selection tree control.
CXTPTreeBase::IsSelected
virtual BOOL IsSelected(HTREEITEM hItem) const
This member function checks whether or not the specified item is selected.
CXTPTreeBase::GetItemFont
virtual BOOL GetItemFont(HTREEITEM hItem, LOGFONT *plogfont)
This member function retrieves the current LOGFONT font used by the tree item.
CXTPTreeBase::m_InsertMarkAfter
BOOL m_InsertMarkAfter
Insertion mark is placed before or after.
Definition XTPTreeBase.h:962
CXTPTreeBase::GetIconIndent
int GetIconIndent() const
Gets the current indent between the icon/text/expander.
CXTPTreeBase::m_htiEdit
HTREEITEM m_htiEdit
Tree item that is currently edited.
Definition XTPTreeBase.h:944
CXTPTreeBase::GetItemBackColor
virtual COLORREF GetItemBackColor(HTREEITEM hItem)
This member function returns the RGB value for the specified tree item background color,...
CXTPTreeBase::m_bExplorerTheme
BOOL m_bExplorerTheme
TRUE if Explorer theme is On for tree control (Windows Vista+)
Definition XTPTreeBase.h:942
CXTPTreeBase::GetPrevSelectedItem
virtual HTREEITEM GetPrevSelectedItem(HTREEITEM hItem) const
This member function retrieves the previously selected tree item in a multi-selection tree control.
CXTPTreeBase::GetNextItem
virtual HTREEITEM GetNextItem(HTREEITEM hItem, UINT nCode) const
This member function will retrieve the tree view item that has the specified relationship,...
CXTPTreeBase::FindItemExact
virtual HTREEITEM FindItemExact(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, HTREEITEM hItem=NULL)
This member function searches the entire tree for an item label that contains exactly the same text a...
CXTPTreeBase::GetTreeBackColor
virtual COLORREF GetTreeBackColor() const
Retrieves the tree control's background color.
CXTPTreeBase::GetSelectedList
void GetSelectedList(CTypedPtrList< CPtrList, HTREEITEM > &list) const
This member function will retrieve a reference to the typed pointer array that contains the items sel...
CXTPTreeBase::Init
virtual bool Init()
This member function is called by the CXTPTreeBase class to perform initialization when the window is...
CXTPTreeBase::EnableMultiSelect
virtual BOOL EnableMultiSelect(BOOL bMultiSelect=TRUE)
This member function enables/disables multi-selection for the tree control.
CXTPTreeBase::GetItemStateIconRect
virtual CRect GetItemStateIconRect(HTREEITEM hItem, const CRect &rcIcon) const
Computes an item state icon rectangle.
CXTPTreeBase::SelectAll
virtual void SelectAll(BOOL bSelect=TRUE, HTREEITEM htItem=NULL)
Call this member function to clear, or select, all of the visible items in the tree control.
CXTPTreeBase::m_nTheme
int m_nTheme
Self tree pointer.
Definition XTPTreeBase.h:950
CXTPTreeTheme
CXTPTreeTheme is a class used to perform tree control theme drawing tasks.
Definition XTPTreeTheme.h:41
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
CXTPTreeBase::CLRFONT
CLRFONT structure is used to by the CXTPShellTreeCtrl and CXTPShellTreeView classes to maintain font ...
Definition XTPTreeBase.h:54
CXTPTreeBase::CLRFONT::CLRFONT
CLRFONT()
Constructs a CLRFONT struct and initializes member data.
CXTPTreeBase::CLRFONT::logfont
LOGFONT logfont
A LOGFONT object that represents the tree item font.
Definition XTPTreeBase.h:61
CXTPTreeBase::CLRFONT::colorBack
COLORREF colorBack
An RGB value that represents the background color for a tree item.
Definition XTPTreeBase.h:63
CXTPTreeBase::CLRFONT::color
COLORREF color
An RGB value that represents the text color for a tree item.
Definition XTPTreeBase.h:62


Toolkit Pro: XTPTabColorSetVisualStudio2012Dark.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2012Dark.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2012DARK_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2012DARK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2012Dark : public CXTPTabColorSetVisualStudio2012
38{
39public:
40 CXTPTabColorSetVisualStudio2012Dark();
41
49 virtual void RefreshMetrics();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2012DARK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetVisualStudio2012Dark
CXTPTabColorSetVisualStudio2012Dark implements a Visual Studio 2012 Dark tab color set.
Definition XTPTabColorSetVisualStudio2012Dark.h:38
CXTPTabColorSetVisualStudio2012Dark::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetVisualStudio2012
CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set.
Definition XTPTabColorSetVisualStudio2012.h:38


Toolkit Pro: Member List

CXTPChartElementView Member List

This is the complete list of members for CXTPChartElementView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


CXTPDockingPaneTabTheme2012 Member List

This is the complete list of members for CXTPDockingPaneTabTheme2012, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2012() | CXTPDockingPaneTabTheme2012 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPDockingPaneTabTheme2012 | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


CXTPSingleton< T, Dependencies > Member List

This is the complete list of members for CXTPSingleton< T, Dependencies >, including all inherited members.

Instance() CXTPSingleton< T, Dependencies > inlinestatic


CXTPCalendarViewEventSubjectEditorColored Member List

This is the complete list of members for CXTPCalendarViewEventSubjectEditorColored, including all inherited members.

CXTPCalendarViewEventSubjectEditor(CXTPCalendarControl *pOwner) | CXTPCalendarViewEventSubjectEditor |
CXTPCalendarViewEventSubjectEditorColored(CXTPCalendarControl *pOwner, CXTPCalendarViewEvent *pViewEvent, COLORREF clrBackground) | CXTPCalendarViewEventSubjectEditorColored |
m_grclrBk | CXTPCalendarViewEventSubjectEditorColored | protected
m_pOwner | CXTPCalendarViewEventSubjectEditor | protected
m_pViewEvent | CXTPCalendarViewEventSubjectEditorColored | protected
~CXTPCalendarViewEventSubjectEditor() | CXTPCalendarViewEventSubjectEditor | virtual
~CXTPCalendarViewEventSubjectEditorColored() | CXTPCalendarViewEventSubjectEditorColored | virtual


Toolkit Pro: XTPGridRecordItemText.h Source File

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemText.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMTEXT_H__)
24# define __XTPGRIDRECORDITEMTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPGridRecordItemText : public CXTPGridRecordItem
44{
46 DECLARE_SERIAL(CXTPGridRecordItemText)
48public:
54 CXTPGridRecordItemText(LPCTSTR szText = _T(""));
55
65 CString GetCaption(CXTPGridColumn* pColumn);
66
67 using CXTPGridRecordItem::GetCaption;
68
74 void SetValue(LPCTSTR szText);
75
83 virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText);
84
91 CString GetValue();
92
99 virtual void DoPropExchange(CXTPPropExchange* pPX);
100
101protected:
102 CString m_strText;
103};
104
105AFX_INLINE CString CXTPGridRecordItemText::GetValue()
106{
107 if (IsChildOfMerge())
108 {
109 if (GetMergeItem()->IsKindOf(RUNTIME_CLASS(CXTPGridRecordItemText)))
110 return ((CXTPGridRecordItemText*)GetMergeItem())->m_strText;
111 else
112 return GetMergeItem()->GetCaption();
113 }
114
115 return m_strText;
116}
118# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
119#endif //#if !defined(__XTPGRIDRECORDITEMTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::GetCaption
virtual CString GetCaption()
Gets the text caption of the item.
CXTPGridRecordItem::IsChildOfMerge
BOOL IsChildOfMerge() const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item ...
CXTPGridRecordItemText
This class represents a text-only cell and inherits basic functionality from the CXTPGridRecordItem c...
Definition XTPGridRecordItemText.h:44
CXTPGridRecordItemText::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPGridRecordItemText::m_strText
CString m_strText
Item text value.
Definition XTPGridRecordItemText.h:102
CXTPGridRecordItemText::OnEditChanged
virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CXTPGridRecordItemText::SetValue
void SetValue(LPCTSTR szText)
Sets the value for the item.
CXTPGridRecordItemText::CXTPGridRecordItemText
CXTPGridRecordItemText(LPCTSTR szText=_T(""))
Creates a record text item.
CXTPGridRecordItemText::GetCaption
CString GetCaption(CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
CXTPGridRecordItemText::GetValue
CString GetValue()
Gets the value of the item.
Definition XTPGridRecordItemText.h:105
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69


CXTPPopupToolBar Member List

This is the complete list of members for CXTPPopupToolBar, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPPopupToolBar | protectedvirtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CreatePopupToolBar(CXTPCommandBars *pCommandBars) | CXTPPopupToolBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPPopupBar | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPPopupBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPPopupBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


Toolkit Pro: XTPDockingPaneSplitterContainer.h Source File

  • Source
  • DockingPane
XTPDockingPaneSplitterContainer.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANESPLITTERCONTAINER_H__)
24# define __XTPDOCKINGPANESPLITTERCONTAINER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPaneSplitterContainer;
34class CXTPDockingPaneLayout;
35
41class _XTP_EXT_CLASS CXTPDockingPaneSplitterWnd : public CWnd
42{
43protected:
48 CXTPDockingPaneSplitterWnd();
49
54 ~CXTPDockingPaneSplitterWnd();
55
56public:
63 BOOL IsHorizontal() const;
64
72 void Create(CXTPDockingPaneSplitterContainer* pContainer, CXTPDockingPaneBase* pFirst,
73 CXTPDockingPaneBase* pSecond);
74
81 void Create(CXTPDockingPaneManager* pManager, BOOL bHoriz);
82
89 CXTPDockingPaneSplitterContainer* GetContainer() const;
90
97 CXTPDockingPaneManager* GetDockingPaneManager() const;
98
108 CXTPDockingPaneBase* GetPaneBase(BOOL bFirst = TRUE);
109
116 XTPDockingPaneDirection GetPaneDirection() const
117 {
118 return m_iDirection;
119 }
120
121protected:
123 DECLARE_MESSAGE_MAP()
124
125 //{{AFX_MSG(CXTPDockingPaneSplitterWnd)
126 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
127 afx_msg void OnPaint();
128 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
129 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
130 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
131 //}}AFX_MSG
134private:
135 void Reposition(CRect rc, CRect rcAvail);
136 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
137 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
138 BOOL GetAvailableRect(CRect& rcAvail, CRect& rcUnion);
139
140private:
141 CXTPDockingPaneSplitterContainer* m_pContainer;
142 CXTPDockingPaneBase* m_pFirst;
143 CXTPDockingPaneBase* m_pSecond;
144 CXTPDockingPaneManager* m_pManager;
145 HCURSOR m_hCursor;
146 BOOL m_bHoriz;
147 XTPDockingPaneDirection m_iDirection;
148
149private:
150 friend class CXTPDockingPaneSplitterContainer;
151 friend class CXTPDockingPaneLayout;
152};
153
154AFX_INLINE CXTPDockingPaneSplitterContainer* CXTPDockingPaneSplitterWnd::GetContainer() const
155{
156 return m_pContainer;
157}
158
165class _XTP_EXT_CLASS CXTPDockingPaneSplitterContainer
166 : public CXTPCmdTarget
167 , public CXTPDockingPaneBaseContainer
168{
169protected:
175 CXTPDockingPaneSplitterContainer(CXTPDockingPaneLayout* pLayout);
176
182 virtual ~CXTPDockingPaneSplitterContainer();
183
184public:
192 virtual void OnSizeParent(CWnd* pParent, CRect rect, LPVOID lParam);
193
202 void FindChildPane(XTPDockingPaneType type, CXTPDockingPaneBaseList* pList) const;
203
211 BOOL IsHoriz() const
212 {
213 return m_bHoriz;
214 }
215
225 void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const;
226
227protected:
236 void Init(CXTPDockingPaneBase* pPane, BOOL bHoriz, CWnd* pFrame);
237
247 void Copy(CXTPDockingPaneBase* pClone, CXTPPaneToPaneMap* pMap, DWORD dwIgnoredOptions);
248
256 virtual CXTPDockingPaneSplitterWnd* OnCreateSplitter();
257
258protected:
264 virtual void RemovePane(CXTPDockingPaneBase* pPane);
265
271 virtual void OnChildContainerChanged(CXTPDockingPaneBase* pContainer);
272
278 virtual void OnParentContainerChanged(CXTPDockingPaneBase* pContainer);
279
287 virtual BOOL DoPropExchange(CXTPPropExchange* pPX);
288
296 void NormalizeDockingSize();
297
302 void DeletePane();
303
304# ifdef _XTP_ACTIVEX
306private:
307 DECLARE_DISPATCH_MAP()
308 DECLARE_OLETYPELIB_EX(CXTPDockingPaneSplitterContainer);
309 DECLARE_ENUM_VARIANT(CXTPDockingPaneSplitterContainer);
310 DECLARE_INTERFACE_MAP()
311
312 LPDISPATCH OleGetDispatch(BOOL /*bAddRef*/);
313 afx_msg LPDISPATCH OleGetItem(int nIndex);
314 afx_msg int OleGetItemCount();
315 afx_msg LPDISPATCH OleGetContainer();
316 afx_msg int OleGetType();
317 afx_msg LPDISPATCH OleGetPane(int nIndex);
318 afx_msg HWND OleGetHwnd();
319 afx_msg BOOL OleIsEmpty();
320 afx_msg int OleGetPosition();
322# endif
323
324private:
325 void _Replace(CXTPDockingPaneBase* pPane, CXTPDockingPaneBase* pReplace);
326 void _InsertPane(CXTPDockingPaneBase* pPane, CXTPDockingPaneBase* pNeighbour = NULL,
327 BOOL bAfter = TRUE);
328 void _UpdateSplitters();
329 BOOL _Before(const CXTPDockingPaneBase* pPane, POSITION pos) const;
330 CRect _CalculateResultDockingRectSelf(CXTPDockingPaneBase* pPane,
331 XTPDockingPaneDirection direction,
332 CXTPDockingPaneBase* pNeighbour);
333 static CRect AFX_CDECL _CalculateResultDockingRectChild(CXTPDockingPaneBase* pSplitter,
334 CXTPDockingPaneBase* pPane,
335 XTPDockingPaneDirection direction);
336 static CRect AFX_CDECL _CalculateResultDockingRect(BOOL bHoriz, CXTPDockingPaneBaseList& lst,
337 CRect rect, CXTPDockingPaneBase* pPaneI);
338 static void AFX_CDECL _AdjustPanesLength(CXTPDockingPaneManager* pManager,
339 CXTPDockingPaneBaseList& lst, CRect rect, BOOL bHoriz,
340 BOOL bApply, int& nTotalLength, int& nLengthAvail);
341 static LONG& AFX_CDECL GetMinSize(LPMINMAXINFO pMinMaxInfo, BOOL bHoriz);
342 static LONG& AFX_CDECL GetMaxSize(LPMINMAXINFO pMinMaxInfo, BOOL bHoriz);
343
344protected:
345 CList<CXTPDockingPaneSplitterWnd*, CXTPDockingPaneSplitterWnd*> m_lstSpliters;
348 BOOL m_bHoriz;
349 BOOL m_bRecalcLayout;
351private:
352 friend class CXTPDockingPaneManager;
353 friend class CXTPDockingPaneSplitterWnd;
354 friend class CXTPDockingPaneMiniWnd;
355 friend class CXTPDockingPaneLayout;
356};
357
358AFX_INLINE BOOL CXTPDockingPaneSplitterWnd::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
359 DWORD dwStyle, const RECT& rect,
360 CWnd* pParentWnd, UINT nID,
361 CCreateContext* pContext)
362{
363 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
364}
365AFX_INLINE LONG& CXTPDockingPaneSplitterContainer::GetMinSize(LPMINMAXINFO pMinMaxInfo, BOOL bHoriz)
366{
367 return bHoriz ? pMinMaxInfo->ptMinTrackSize.x : pMinMaxInfo->ptMinTrackSize.y;
368}
369AFX_INLINE LONG& CXTPDockingPaneSplitterContainer::GetMaxSize(LPMINMAXINFO pMinMaxInfo, BOOL bHoriz)
370{
371 return bHoriz ? pMinMaxInfo->ptMaxTrackSize.x : pMinMaxInfo->ptMaxTrackSize.y;
372}
374# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
375#endif // #if !defined(__XTPDOCKINGPANESPLITTERCONTAINER_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneType
XTPDockingPaneType
Docking pane type.
Definition XTPDockingPaneDefines.h:77
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
CXTPDockingPaneBaseList
CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
Definition XTPDockingPaneDefines.h:482
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneBaseContainer.h:39
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneSplitterContainer.h:168
CXTPDockingPaneSplitterContainer::IsHoriz
BOOL IsHoriz() const
Call this member to determine if the splitter orientation is horizontal.
Definition XTPDockingPaneSplitterContainer.h:211
CXTPDockingPaneSplitterContainer::RemovePane
virtual void RemovePane(CXTPDockingPaneBase *pPane)
This member is called to remove a pane from the collection.
CXTPDockingPaneSplitterContainer::OnChildContainerChanged
virtual void OnChildContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
CXTPDockingPaneSplitterContainer::OnParentContainerChanged
virtual void OnParentContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
CXTPDockingPaneSplitterContainer::m_bHoriz
BOOL m_bHoriz
TRUE if the splitter orientation is horizontal.
Definition XTPDockingPaneSplitterContainer.h:348
CXTPDockingPaneSplitterContainer::DoPropExchange
virtual BOOL DoPropExchange(CXTPPropExchange *pPX)
This member is called to save/restore the settings of the pane.
CXTPDockingPaneSplitterContainer::GetMinMaxInfo
void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of t...
CXTPDockingPaneSplitterContainer::DeletePane
void DeletePane()
This method is called to the destroy the pane.
CXTPDockingPaneSplitterContainer::m_bRecalcLayout
BOOL m_bRecalcLayout
TRUE if RecalcLayout method currently executed.
Definition XTPDockingPaneSplitterContainer.h:349
CXTPDockingPaneSplitterContainer::OnCreateSplitter
virtual CXTPDockingPaneSplitterWnd * OnCreateSplitter()
This member is called by the framework when a splitter container is created.
CXTPDockingPaneSplitterContainer::~CXTPDockingPaneSplitterContainer
virtual ~CXTPDockingPaneSplitterContainer()
Destroys a CXTPDockingPaneSplitterContainer object, handles cleanup and deallocation.
CXTPDockingPaneSplitterContainer::m_lstSpliters
CList< CXTPDockingPaneSplitterWnd *, CXTPDockingPaneSplitterWnd * > m_lstSpliters
List of splitter windows.
Definition XTPDockingPaneSplitterContainer.h:345
CXTPDockingPaneSplitterContainer::CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterContainer(CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneSplitterContainer object.
CXTPDockingPaneSplitterContainer::NormalizeDockingSize
void NormalizeDockingSize()
This member is called to normalize the size of docking panes in the splitter container.
CXTPDockingPaneSplitterContainer::Copy
void Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies a CXTPDockingPaneSplitterContainer object.
CXTPDockingPaneSplitterContainer::Init
void Init(CXTPDockingPaneBase *pPane, BOOL bHoriz, CWnd *pFrame)
Constructs a CXTPDockingPaneSplitterContainer object Protected constructor.
CXTPDockingPaneSplitterContainer::FindChildPane
void FindChildPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to retrieve a collection of the panes with a specified type within the splitter cont...
CXTPDockingPaneSplitterContainer::OnSizeParent
virtual void OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneSplitterWnd::GetPaneBase
CXTPDockingPaneBase * GetPaneBase(BOOL bFirst=TRUE)
Call this member function to retrieve a pointer to the docking splitter base pane.
CXTPDockingPaneSplitterWnd::GetPaneDirection
XTPDockingPaneDirection GetPaneDirection() const
Call this member to determine the XTPDockingPaneDirection of the splitter.
Definition XTPDockingPaneSplitterContainer.h:116
CXTPDockingPaneSplitterWnd::Create
void Create(CXTPDockingPaneSplitterContainer *pContainer, CXTPDockingPaneBase *pFirst, CXTPDockingPaneBase *pSecond)
Creates a CXTPDockingPaneSplitterWnd window.
CXTPDockingPaneSplitterWnd::~CXTPDockingPaneSplitterWnd
~CXTPDockingPaneSplitterWnd()
Destroys a CXTPDockingPaneSplitterWnd object, handles cleanup and deallocation.
CXTPDockingPaneSplitterWnd::IsHorizontal
BOOL IsHorizontal() const
Determines if the splitter orientation is horizontal.
CXTPDockingPaneSplitterWnd::GetDockingPaneManager
CXTPDockingPaneManager * GetDockingPaneManager() const
Retrieves a pointer to the docking pane manager.
CXTPDockingPaneSplitterWnd::Create
void Create(CXTPDockingPaneManager *pManager, BOOL bHoriz)
Creates a CXTPDockingPaneSplitterWnd window.
CXTPDockingPaneSplitterWnd::CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd()
Constructs a CXTPDockingPaneSplitterWnd object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPShortcutBarOfficeXPTheme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarOfficeXPTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBAROFFICEXPTHEME_H__)
24# define __XTPSHORTCUTBAROFFICEXPTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarOfficeXPTheme : public CXTPShortcutBarPaintManager
39{
40public:
47 void FillShortcutBar(CDC* pDC, CXTPShortcutBar* pShortcutBar);
48
57 void DrawShortcutBarFrame(CDC* pDC, CXTPShortcutBar* pShortcutBar);
58
65 void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
66
77 int DrawGripper(CDC* pDC, CXTPShortcutBar* pShortcutBar, BOOL bDraw);
78
98 void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage, BOOL bSelected,
99 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
100};
101
102# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
104#endif // !defined(__XTPSHORTCUTBAROFFICEXPTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOfficeXPTheme
CXTPShortcutBarOfficeXPTheme is a CXTPShortcutBarPaintManager derived class that represents an Office...
Definition XTPShortcutBarOfficeXPTheme.h:39
CXTPShortcutBarOfficeXPTheme::FillShortcutItemEntry
void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarOfficeXPTheme::DrawShortcutBarFrame
void DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
CXTPShortcutBarOfficeXPTheme::FillShortcutBar
void FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
CXTPShortcutBarOfficeXPTheme::DrawGripper
int DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
CXTPShortcutBarOfficeXPTheme::DrawImage
void DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control.
Definition XTPShortcutBarPaintManager.h:79


CXTPChartRadarAxisXView Member List

This is the complete list of members for CXTPChartRadarAxisXView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalcSize(CXTPChartDeviceContext *pDC, CRect rcDiagram) | CXTPChartRadarAxisXView |
CreateConstantLinesDeviceCommand(CXTPChartDeviceContext *pDC, BOOL bBehind) | CXTPChartRadarAxisXView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView | virtual
CreateGridLinesDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView | virtual
CreateInterlacedDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView | virtual
CreateLabelsDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView | virtual
CreateStripsDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView | virtual
CreateTickMarks(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView | protected
CreateTickMarksDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartRadarAxisXView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAxisView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView) | CXTPChartRadarAxisView |
CXTPChartRadarAxisXView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView) | CXTPChartRadarAxisXView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetSize() const | CXTPChartRadarAxisXView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_arrTicks | CXTPChartRadarAxisXView |
m_nSize | CXTPChartRadarAxisXView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartRadarAxisXView | protected
SetBounds(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarAxisXView |
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartRadarAxisView() | CXTPChartRadarAxisView |
~CXTPChartRadarAxisXView() | CXTPChartRadarAxisXView |


CXTPChartRadarSplineAreaSeriesStyle Member List

This is the complete list of members for CXTPChartRadarSplineAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartRadarDiagramSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarSplineAreaSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarAreaSeriesStyle() | CXTPChartRadarAreaSeriesStyle |
CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle |
CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle |
CXTPChartRadarSplineAreaSeriesStyle() | CXTPChartRadarSplineAreaSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarAreaSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartRadarAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartRadarPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartRadarAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartRadarDiagramSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartRadarAreaSeriesStyle | protected
m_pBorder | CXTPChartRadarAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartRadarAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartRadarAreaSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRadarAreaSeriesStyle() | CXTPChartRadarAreaSeriesStyle | virtual
~CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle | virtual
~CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle | virtual
~CXTPChartRadarSplineAreaSeriesStyle() | CXTPChartRadarSplineAreaSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


  • CXTPColorHex
  • CRgnCell
  • CTX_DATA
CXTPColorHex::CRgnCell::CTX_DATA Member List

This is the complete list of members for CXTPColorHex::CRgnCell::CTX_DATA, including all inherited members.

lg | CXTPColorHex::CRgnCell::CTX_DATA
sm | CXTPColorHex::CRgnCell::CTX_DATA


CXTPChartFillStyle Member List

This is the complete list of members for CXTPChartFillStyle, including all inherited members.

CreateCircleDeviceCommand(const CXTPChartPointF &center, double radius, const CXTPChartColor &color, const CXTPChartColor &color2) | CXTPChartFillStyle | virtual
CreateDeviceCommand(const CXTPChartRectF &bounds, const CXTPChartColor &color, const CXTPChartColor &color2) | CXTPChartFillStyle | virtual
CreateDeviceCommand(const CXTPChartPoints &arrPoints, const CXTPChartColor &color, const CXTPChartColor &color2) | CXTPChartFillStyle | virtual
CreateSplineDeviceCommand(const CXTPChartPoints &arrPoints, const CXTPChartColor &color, const CXTPChartColor &color2, BOOL bTwoSides=FALSE) | CXTPChartFillStyle | virtual
CXTPChartFillStyle(CXTPChartElement *pOwner) | CXTPChartFillStyle |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFillStyle |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetFillMode() const | CXTPChartFillStyle |
GetGradientAngle() const | CXTPChartFillStyle |
GetHatchStyle() const | CXTPChartFillStyle |
m_nFillMode | CXTPChartFillStyle | protected
m_nGradientAngle | CXTPChartFillStyle | protected
m_nHatchStyle | CXTPChartFillStyle | protected
m_pOwner | CXTPChartFillStyle | protected
Release() | CXTPChartFillStyle |
SetFillMode(XTPChartFillMode nFillMode) | CXTPChartFillStyle |
SetGradientAngle(XTPChartGradientAngle nAngle) | CXTPChartFillStyle |
SetHatchStyle(XTPChartHatchStyle nStyle) | CXTPChartFillStyle |


Toolkit Pro: XTPCommandBarsOffice2003Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsOffice2003Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSOFFICE2003THEME_H__)
24# define __XTPCOMMANDBARSOFFICE2003THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsOffice2003Theme : public CXTPCommandBarsOfficeXPTheme
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsOffice2003Theme)
45public:
50 CXTPCommandBarsOffice2003Theme();
51
57 virtual ~CXTPCommandBarsOffice2003Theme();
58
66 static HBITMAP AFX_CDECL GetModernBitmap(UINT nIDResource);
67
77 static BOOL AFX_CDECL LoadModernToolbarIcons(UINT nIDResource);
78
91 static BOOL AFX_CDECL LoadModernToolbarIcons(UINT nIDResource, UINT* pCommands, int nCount,
92 CSize szIcon = CSize(16, 15));
93
101 void ExcludeCorners(CDC* pDC, CRect rc);
102
103protected:
108 virtual void RefreshMetrics();
109
122 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy,
123 BOOL bExpanded = FALSE);
124
131 virtual void FillDockBar(CDC* pDC, CXTPDockBar* pBar);
132
139 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
140
151 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
152 BOOL bDraw = TRUE);
153
163 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
164
178 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
179 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
180 XTPBarPosition barPosition);
181
196 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
197 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
198 XTPBarPosition barPosition, int nID);
199
208 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
209
225 virtual CSize DrawSpecialControl(CDC* pDC, XTPSpecialControl controlType, CXTPControl* pButton,
226 CXTPCommandBar* pBar, BOOL bDraw, LPVOID lpParam);
227
235 virtual CRect GetCommandBarBorders(CXTPCommandBar* pBar);
236
247 virtual CSize DrawTearOffGripper(CDC* pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw);
248
258 virtual CSize DrawDialogBarGripper(CDC* pDC, CXTPDialogBar* pBar, BOOL bDraw);
259
266 virtual XTPPaintTheme BaseTheme()
267 {
268 return xtpThemeOffice2003;
269 }
270
275 void CreateGradientCircle();
276
284 virtual BOOL HasFloatingBarGradientEntry(CXTPCommandBar* pBar);
285
286protected:
288 void DrawExpandSymbols(CDC* pDC, BOOL bVertical, CRect rc, BOOL bHiddenExists, COLORREF clr);
289 void RectangleEx(CDC* pDC, CRect rc, int nColorBorder, BOOL bHoriz,
290 CXTPPaintManagerColorGradient& color);
293public:
294 CXTPPaintManagerColorGradient m_clrDockBar;
295 CXTPPaintManagerColorGradient m_clrCommandBar;
296 CXTPPaintManagerColorGradient m_clrToolbarExpand;
297 CXTPPaintManagerColorGradient m_clrMenuExpand;
298 CXTPPaintManagerColorGradient m_clrMenuExpandedGripper;
299 CXTPPaintManagerColorGradient m_clrMenuGripper;
300 CXTPPaintManagerColorGradient m_clrPopupControl;
302 CXTPPaintManagerColor m_clrToolbarShadow;
303 CXTPPaintManagerColor m_clrTearOffGripper;
305 BOOL m_bLunaTheme;
306 BOOL m_bPlainSeparators;
308 BOOL m_bFlatGripper;
309
310 int m_nToolbarSeparatorMargin;
311
312 CImageList m_ilGradientCircle;
313 CXTPPaintManagerColorGradient m_grcLunaChecked;
314 CXTPPaintManagerColorGradient m_grcLunaPushed;
315 CXTPPaintManagerColorGradient m_grcLunaSelected;
316};
317
318# define CXTPOffice2003Theme CXTPCommandBarsOffice2003Theme
320# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
321#endif // #if !defined(__XTPCOMMANDBARSOFFICE2003THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeOffice2003
@ xtpThemeOffice2003
Office 2003 theme.
Definition XTPCommandBarsDefines.h:237
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSpecialControl
XTPSpecialControl
Special control with extended drawing.
Definition XTPPaintManager.h:80
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarsOffice2003Theme
The CXTPCommandBarsOffice2003Theme class is used to enable an Office 2003 style theme for Command Bar...
Definition XTPCommandBarsOffice2003Theme.h:41
CXTPCommandBarsOffice2003Theme::m_clrPopupControl
CXTPPaintManagerColorGradient m_clrPopupControl
color of pop-up control
Definition XTPCommandBarsOffice2003Theme.h:300
CXTPCommandBarsOffice2003Theme::DrawSpecialControl
virtual CSize DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
CXTPCommandBarsOffice2003Theme::m_bLunaTheme
BOOL m_bLunaTheme
TRUE if luna theme is active.
Definition XTPCommandBarsOffice2003Theme.h:305
CXTPCommandBarsOffice2003Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsOffice2003Theme::GetCommandBarBorders
virtual CRect GetCommandBarBorders(CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
CXTPCommandBarsOffice2003Theme::CXTPCommandBarsOffice2003Theme
CXTPCommandBarsOffice2003Theme()
Constructs a CXTPCommandBarsOffice2003Theme object.
CXTPCommandBarsOffice2003Theme::m_bPlainSeparators
BOOL m_bPlainSeparators
TRUE to draw plain separators.
Definition XTPCommandBarsOffice2003Theme.h:306
CXTPCommandBarsOffice2003Theme::m_clrMenuGripper
CXTPPaintManagerColorGradient m_clrMenuGripper
Color of the pop-up menu gripper.
Definition XTPCommandBarsOffice2003Theme.h:299
CXTPCommandBarsOffice2003Theme::HasFloatingBarGradientEntry
virtual BOOL HasFloatingBarGradientEntry(CXTPCommandBar *pBar)
Returns TRUE if a floating toolbar is drawn with a gradient background.
CXTPCommandBarsOffice2003Theme::m_clrToolbarShadow
CXTPPaintManagerColor m_clrToolbarShadow
Toolbar bottom shadow color.
Definition XTPCommandBarsOffice2003Theme.h:302
CXTPCommandBarsOffice2003Theme::m_clrToolbarExpand
CXTPPaintManagerColorGradient m_clrToolbarExpand
Toolbar Expand button color.
Definition XTPCommandBarsOffice2003Theme.h:296
CXTPCommandBarsOffice2003Theme::LoadModernToolbarIcons
static BOOL AFX_CDECL LoadModernToolbarIcons(UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15))
Loads bitmap specified by nIDResource and adds it to ImageManager.
CXTPCommandBarsOffice2003Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsOffice2003Theme::~CXTPCommandBarsOffice2003Theme
virtual ~CXTPCommandBarsOffice2003Theme()
Destroys a CXTPCommandBarsOffice2003Theme object, handles cleanup and deallocation.
CXTPCommandBarsOffice2003Theme::m_clrTearOffGripper
CXTPPaintManagerColor m_clrTearOffGripper
TearOff gripper color.
Definition XTPCommandBarsOffice2003Theme.h:303
CXTPCommandBarsOffice2003Theme::CreateGradientCircle
void CreateGradientCircle()
Generates an expanded bitmap used for CXTPPopupBar.
CXTPCommandBarsOffice2003Theme::LoadModernToolbarIcons
static BOOL AFX_CDECL LoadModernToolbarIcons(UINT nIDResource)
Loads bitmap specified by nIDResource and adds it to ImageManager.
CXTPCommandBarsOffice2003Theme::DrawTearOffGripper
virtual CSize DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw the tear-off gripper of a pop-up bar.
CXTPCommandBarsOffice2003Theme::m_grcLunaChecked
CXTPPaintManagerColorGradient m_grcLunaChecked
Background color of checked button.
Definition XTPCommandBarsOffice2003Theme.h:313
CXTPCommandBarsOffice2003Theme::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
CXTPCommandBarsOffice2003Theme::GetModernBitmap
static HBITMAP AFX_CDECL GetModernBitmap(UINT nIDResource)
Loads bitmap specified by nIDResource and converts its colors.
CXTPCommandBarsOffice2003Theme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPCommandBarsOffice2003Theme::m_ilGradientCircle
CImageList m_ilGradientCircle
Gradient circle holder.
Definition XTPCommandBarsOffice2003Theme.h:312
CXTPCommandBarsOffice2003Theme::m_clrMenuExpand
CXTPPaintManagerColorGradient m_clrMenuExpand
MenuBar Expand button color.
Definition XTPCommandBarsOffice2003Theme.h:297
CXTPCommandBarsOffice2003Theme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsOffice2003Theme.h:266
CXTPCommandBarsOffice2003Theme::m_grcLunaPushed
CXTPPaintManagerColorGradient m_grcLunaPushed
Background color of pushed button.
Definition XTPCommandBarsOffice2003Theme.h:314
CXTPCommandBarsOffice2003Theme::ExcludeCorners
void ExcludeCorners(CDC *pDC, CRect rc)
This method creates a new clipping region that consists of the existing clipping region minus the cor...
CXTPCommandBarsOffice2003Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPCommandBarsOffice2003Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsOffice2003Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID)
This method is called to fill the control's face.
CXTPCommandBarsOffice2003Theme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
CXTPCommandBarsOffice2003Theme::m_grcLunaSelected
CXTPPaintManagerColorGradient m_grcLunaSelected
Background color of selected button.
Definition XTPCommandBarsOffice2003Theme.h:315
CXTPCommandBarsOffice2003Theme::m_clrDockBar
CXTPPaintManagerColorGradient m_clrDockBar
Color of dockbar face.
Definition XTPCommandBarsOffice2003Theme.h:294
CXTPCommandBarsOffice2003Theme::m_clrCommandBar
CXTPPaintManagerColorGradient m_clrCommandBar
Color of commandbar face.
Definition XTPCommandBarsOffice2003Theme.h:295
CXTPCommandBarsOffice2003Theme::m_clrMenuExpandedGripper
CXTPPaintManagerColorGradient m_clrMenuExpandedGripper
Color of pop-up bar gripper.
Definition XTPCommandBarsOffice2003Theme.h:298
CXTPCommandBarsOffice2003Theme::DrawDialogBarGripper
virtual CSize DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
CXTPCommandBarsOffice2003Theme::FillDockBar
virtual void FillDockBar(CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dockbar.
CXTPCommandBarsOfficeXPTheme
The CXTPCommandBarsOfficeXPTheme class is used to enable an Office XP style theme for Command Bars.
Definition XTPCommandBarsOfficeXPTheme.h:41
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPDialogBar
CXTPDialogBar is a CXTPToolBar derived class.
Definition XTPDialogBar.h:41
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


CXTPCalendarCaptionBarNativeWindows10Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarNativeWindows10Theme, including all inherited members.

CXTPCalendarCaptionBarNativeWindows10Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarNativeWindows10Theme |
CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarNativeWindows10Theme() | CXTPCalendarCaptionBarNativeWindows10Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual


CXTPCustomizeCommandsPage Member List

This is the complete list of members for CXTPCustomizeCommandsPage, including all inherited members.

AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE) | CXTPCustomizeCommandsPage |
AddCategories(CXTPControls *pControls) | CXTPCustomizeCommandsPage |
AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE) | CXTPCustomizeCommandsPage |
AddToolbarCategory(LPCTSTR strCategory, UINT nIDResource) | CXTPCustomizeCommandsPage |
AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPCustomizeCommandsPage(CXTPCustomizeSheet *pSheet=NULL) | CXTPCustomizeCommandsPage |
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
FindCategory(LPCTSTR strCategory) const | CXTPCustomizeCommandsPage |
GetCaption() const | CXTPPropertyPage |
GetCategoryInfo(int nIndex) const | CXTPCustomizeCommandsPage |
GetControls(LPCTSTR strCategory) | CXTPCustomizeCommandsPage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
Init() | CXTPResize | protectedvirtual
InsertAllCommandsCategory(UINT nIDResource=XTP_IDS_ALLCOMMANDS, int nIndex=-1, BOOL bSortCommands=TRUE) | CXTPCustomizeCommandsPage |
InsertBuiltInMenus(UINT nIDResourceMenu, UINT nIDResourceCategory=XTP_IDS_BUILTINMENUS, int nIndex=-1) | CXTPCustomizeCommandsPage |
InsertCategory(LPCTSTR strCategory, int nIndex=-1) | CXTPCustomizeCommandsPage |
InsertNewMenuCategory(UINT nIDResource=XTP_IDS_NEWMENU, int nIndex=-1) | CXTPCustomizeCommandsPage |
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrCategories | CXTPCustomizeCommandsPage | protected
m_arrItems | CXTPResize | protected
m_bModified | CXTPPropertyPage | protected
m_dwData | CXTPPropertyPage |
m_lstCategories | CXTPCustomizeCommandsPage | protected
m_lstCommands | CXTPCustomizeCommandsPage | protected
m_nFlagsXX | CXTPResize | protected
m_pSheet | CXTPCustomizeCommandsPage | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPPropertyPage | virtual
~CXTPCustomizeCommandsPage() | CXTPCustomizeCommandsPage |
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual


CXTPTreeView Member List

This is the complete list of members for CXTPTreeView, including all inherited members.

CXTPTreeView() | CXTPTreeView | protected
~CXTPTreeView() | CXTPTreeView | protectedvirtual


Toolkit Pro: XTPCaptionTheme.h Source File

  • Source
  • Controls
  • Static
XTPCaptionTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCAPTIONTHEME_H__)
24# define __XTPCAPTIONTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCaption;
34class CXTPButtonTheme;
35
41class _XTP_EXT_CLASS CXTPCaptionTheme : public CXTPControlTheme
42{
43public:
48 CXTPCaptionTheme();
49
57 virtual void RefreshMetrics(CXTPCaption* pCaption);
58
68 virtual void DrawCaptionBack(CDC* pDC, CXTPCaption* pCaption, CRect& rcItem);
69
77 virtual void DrawCaptionText(CDC* pDC, CXTPCaption* pCaption);
78
90 virtual void DrawCaptionIcon(CDC* pDC, CXTPCaption* pCaption, CRect& rcItem);
91
92public:
93 CXTPPaintManagerColor m_clrEdgeShadow;
95 CXTPPaintManagerColor m_clrEdgeLight;
96};
97
103class _XTP_EXT_CLASS CXTPCaptionThemeOfficeXP : public CXTPCaptionTheme
104{
105public:
110 CXTPCaptionThemeOfficeXP();
111
112protected:
122 virtual void DrawCaptionBack(CDC* pDC, CXTPCaption* pCaption, CRect& rcItem);
123};
124
130class _XTP_EXT_CLASS CXTPCaptionThemeOffice2003 : public CXTPCaptionTheme
131{
132public:
137 CXTPCaptionThemeOffice2003();
138
140 CXTPCaptionThemeOffice2003(BOOL bPrimaryCaption);
142protected:
152 virtual void DrawCaptionBack(CDC* pDC, CXTPCaption* pCaption, CRect& rcItem);
153};
154
160class _XTP_EXT_CLASS CXTPCaptionButtonTheme : public CXTPButtonTheme
161{
162public:
167 CXTPCaptionButtonTheme();
168
169protected:
176 virtual void DrawButtonText(CDC* pDC, CXTPButton* pButton);
177
185 virtual COLORREF GetTextColor(CXTPButton* pButton);
186
193 virtual void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
194};
195
196# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
198#endif // !defined(__XTPCAPTIONTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks.
Definition XTPButtonTheme.h:51
CXTPCaptionButtonTheme
CXTPCaptionButtonTheme is derived from CXTPButtonTheme.
Definition XTPCaptionTheme.h:161
CXTPCaptionButtonTheme::GetTextColor
virtual COLORREF GetTextColor(CXTPButton *pButton)
Call this member function to get the text color of the button caption.
CXTPCaptionButtonTheme::DrawButtonText
virtual void DrawButtonText(CDC *pDC, CXTPButton *pButton)
Call this member function to draw the button caption text.
CXTPCaptionButtonTheme::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPCaptionButtonTheme::CXTPCaptionButtonTheme
CXTPCaptionButtonTheme()
Default class constructor.
CXTPCaption
CXTPCaption is a CStatic derived class.
Definition XTPCaption.h:92
CXTPCaptionTheme
CXTPCaptionTheme is a CXTPControlTheme derived class used to control caption themes.
Definition XTPCaptionTheme.h:42
CXTPCaptionTheme::CXTPCaptionTheme
CXTPCaptionTheme()
Constructs a CXTPCaptionTheme object.
CXTPCaptionTheme::DrawCaptionIcon
virtual void DrawCaptionIcon(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Called by CXTPCaption to draw the caption icon.
CXTPCaptionTheme::DrawCaptionText
virtual void DrawCaptionText(CDC *pDC, CXTPCaption *pCaption)
Called by CXTPCaption to draw the caption text.
CXTPCaptionTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPCaption *pCaption)
This function is called to set the edges of a caption to the system default colors for edge shadow an...
CXTPCaptionTheme::DrawCaptionBack
virtual void DrawCaptionBack(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Call this function to draw the background of the caption at the location specified in the rcItem rect...
CXTPCaptionTheme::m_clrEdgeLight
CXTPPaintManagerColor m_clrEdgeLight
The color of the edge light for the current theme.
Definition XTPCaptionTheme.h:95
CXTPCaptionTheme::m_clrEdgeShadow
CXTPPaintManagerColor m_clrEdgeShadow
The color of the edge shadow for the current theme.
Definition XTPCaptionTheme.h:93
CXTPCaptionThemeOffice2003
CXTPCaptionThemeOffice2003 is derived from CXTPCaptionTheme.
Definition XTPCaptionTheme.h:131
CXTPCaptionThemeOffice2003::DrawCaptionBack
virtual void DrawCaptionBack(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Call this function to draw the background of the caption.
CXTPCaptionThemeOffice2003::CXTPCaptionThemeOffice2003
CXTPCaptionThemeOffice2003()
Constructs a CXTPCaptionThemeOffice2003 object.
CXTPCaptionThemeOfficeXP
CXTPCaptionThemeOfficeXP is derived from CXTPCaptionTheme.
Definition XTPCaptionTheme.h:104
CXTPCaptionThemeOfficeXP::DrawCaptionBack
virtual void DrawCaptionBack(CDC *pDC, CXTPCaption *pCaption, CRect &rcItem)
Call this function to draw the background of the caption.
CXTPCaptionThemeOfficeXP::CXTPCaptionThemeOfficeXP
CXTPCaptionThemeOfficeXP()
Constructs a CXTPCaptionThemeOfficeXP object.
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPProgressThemeVisualStudio2015.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2015_H__)
24# define __XTPPROGRESSTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressThemeVisualStudio2015 : public CXTPProgressThemeOffice2013
41{
42public:
48 CXTPProgressThemeVisualStudio2015(CXTPPaintManager* pPaintManager);
49
55 virtual ~CXTPProgressThemeVisualStudio2015();
56};
57
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif // !defined(__XTPPROGRESSTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object.
Definition XTPProgressThemeOffice2013.h:41
CXTPProgressThemeVisualStudio2015
CXTPProgressThemeVisualStudio2015 object.
Definition XTPProgressThemeVisualStudio2015.h:41
CXTPProgressThemeVisualStudio2015::~CXTPProgressThemeVisualStudio2015
virtual ~CXTPProgressThemeVisualStudio2015()
Destroys a CXTPProgressThemeVisualStudio2015 object, handles cleanup and deallocation.
CXTPProgressThemeVisualStudio2015::CXTPProgressThemeVisualStudio2015
CXTPProgressThemeVisualStudio2015(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeVisualStudio2015 object.


CXTPSkinObjectSpin Member List

This is the complete list of members for CXTPSkinObjectSpin, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectSpin() | CXTPSkinObjectSpin |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectSpin() | CXTPSkinObjectSpin | virtual


Toolkit Pro: XTPRibbonBackstageTab.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageTab.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGETAB_H__)
24# define __XTPRIBBONBACKSTAGETAB_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageTab : public CXTPControl
34{
36 DECLARE_XTP_CONTROL(CXTPRibbonBackstageTab)
38public:
39 CWnd* GetControlPane() const;
40
47 void CheckKeyboardTips();
48
57 int GetKeyboardTipsCount() const;
58
69 TCHAR GetKeyboardTipChar(int index) const;
70
79 void ClickControlWithKeyboardTip(int index);
80
86 void ShowKeyboardTips(BOOL bShow);
87
88 void SetControlPaneMinSize(CSize sz);
89
90protected:
91 CXTPRibbonBackstageTab(HWND hwndControl = 0);
92
93protected:
94# ifdef _XTP_COMMANDBARS_ACTIVEX
97 DECLARE_DISPATCH_MAP()
98 DECLARE_INTERFACE_MAP()
99 DECLARE_OLETYPELIB_EX(CXTPRibbonBackstageTab);
100
102# endif
103protected:
104 HWND m_hwndControl;
105 CSize m_szControlPaneMinSize;
106 CArray<TCHAR, TCHAR> m_arrKeyboardTips;
107 CArray<HWND, HWND> m_arrKeyboardTipsIds;
109 friend class CXTPRibbonBackstageView;
110};
111
112AFX_INLINE void CXTPRibbonBackstageTab::SetControlPaneMinSize(CSize sz)
113{
114 m_szControlPaneMinSize = sz;
115}
116
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
119#endif // !defined(__XTPRIBBONBACKSTAGETAB_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87


Toolkit Pro: XTPSkinObjectListView.h Source File

  • Source
  • SkinFramework
XTPSkinObjectListView.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTLISTVIEW_H__)
24# define __XTPSKINOBJECTLISTVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectListView : public CXTPSkinObjectComCtl32Control
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectListView)
43public:
48 CXTPSkinObjectListView();
49
54 virtual ~CXTPSkinObjectListView();
55
56protected:
58 DECLARE_MESSAGE_MAP()
59
60 //{{AFX_VIRTUAL(CXTPSkinObjectListView)
61 void OnSkinChanged(BOOL bPrevState, BOOL bNewState);
62 //}}AFX_VIRTUAL
63
64 //{{AFX_MSG(CXTPSkinObjectListView)
65 void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
66 void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
67 int OnCreate(LPCREATESTRUCT lpCreateStruct);
68 //}}AFX_MSG
69
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
75#endif // !defined(__XTPSKINOBJECTLISTVIEW_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectComCtl32Control
CXTPSkinObjectComCtl32Control is a CXTPSkinObjectUser32Control derived class.
Definition XTPSkinObjectFrame.h:444
CXTPSkinObjectListView
CXTPSkinObjectListView is a CXTPSkinObjectComCtl32Control derived class.
Definition XTPSkinObjectListView.h:39
CXTPSkinObjectListView::~CXTPSkinObjectListView
virtual ~CXTPSkinObjectListView()
Destroys a CXTPSkinObjectListView object, handles cleanup and deallocation.
CXTPSkinObjectListView::CXTPSkinObjectListView
CXTPSkinObjectListView()
Constructs a CXTPSkinObjectListView object.


CXTPDatePickerThemeVisualStudio2022 Member List

This is the complete list of members for CXTPDatePickerThemeVisualStudio2022, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 |
CXTPDatePickerThemeVisualStudio2022() | CXTPDatePickerThemeVisualStudio2022 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerThemeOffice2013 | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerThemeOffice2013 | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2013 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerThemeOffice2013 | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2013 | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayBackColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayBorderColor() | CXTPDatePickerThemeOffice2013 | virtual
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetHighlightTodayTextColor() | CXTPDatePickerThemeOffice2013 | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrBackground | CXTPDatePickerThemeOffice2013 | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2013 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOffice2013() | CXTPDatePickerThemeOffice2013 | virtual
~CXTPDatePickerThemeVisualStudio2022() | CXTPDatePickerThemeVisualStudio2022 | virtual


CXTPSubscriptionList< Observable, Observer > Member List

This is the complete list of members for CXTPSubscriptionList< Observable, Observer >, including all inherited members.

CXTPSubscriptionList(Observer &observer) | CXTPSubscriptionList< Observable, Observer > | explicit
GetSubscriptionCount() const | CXTPSubscriptionList< Observable, Observer > |
~CXTPSubscriptionList() | CXTPSubscriptionList< Observable, Observer > |


CXTPTabColorSetOffice2013 Member List

This is the complete list of members for CXTPTabColorSetOffice2013, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2013 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetOffice2013 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetOffice2013 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetOffice2013 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetOffice2013 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabColorSetOffice2013 | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPTaskPanelVisualStudio2019Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelVisualStudio2019Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELVISUALSTUDIO2019THEME_H__)
24# define __XTPTASKPANELVISUALSTUDIO2019THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelVisualStudio2019Theme : public CXTPTaskPanelVisualStudio2012Theme
40{
41protected:
42 void Triangle(CDC* pDC, POINT* pPoints, COLORREF clr, BOOL bFilled);
43
44public:
49 CXTPTaskPanelVisualStudio2019Theme();
50
56 virtual ~CXTPTaskPanelVisualStudio2019Theme();
57
62 virtual void RefreshMetrics();
63};
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // __XTPTASKPANELVISUALSTUDIO2019THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40
CXTPTaskPanelVisualStudio2019Theme
CXTPTaskPanelVisualStudio2019Theme represents a Visutal Studio 2019 style theme.
Definition XTPTaskPanelVisualStudio2019Theme.h:40
CXTPTaskPanelVisualStudio2019Theme::~CXTPTaskPanelVisualStudio2019Theme
virtual ~CXTPTaskPanelVisualStudio2019Theme()
Destroys a CXTPTaskPanelVisualStudio2019Theme object, handles cleanup and deallocation.
CXTPTaskPanelVisualStudio2019Theme::CXTPTaskPanelVisualStudio2019Theme
CXTPTaskPanelVisualStudio2019Theme()
Constructs a CXTPTaskPanelVisualStudio2019Theme object.
CXTPTaskPanelVisualStudio2019Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.


CXTPChartPieSeriesPointView Member List

This is the complete list of members for CXTPChartPieSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLayout(double &dAngle) | CXTPChartPieSeriesPointView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPieSeriesPointView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPieSeriesPointView | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPieSeriesPointView |
CXTPChartPieSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPieSeriesPointView |
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPieSeriesPointViewBase | protected
CXTPChartPieSeriesPointViewBase(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartPieSeriesPointViewBase | protected
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBasePoint() const | CXTPChartPieSeriesPointViewBase |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPie() const | CXTPChartPieSeriesPointViewBase |
GetPoint() const | CXTPChartSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual
~CXTPChartPieSeriesPointViewBase() | CXTPChartPieSeriesPointViewBase | virtual


CXTPMarkupContext Member List

This is the complete list of members for CXTPMarkupContext, including all inherited members.

AddCustomScriptItem(LPCWSTR lpName, LPDISPATCH pDisp) | CXTPMarkupContext |
AddHandler(CXTPMarkupRoutedEvent *pEvent, CXTPMarkupDelegate *pDelegate) | CXTPMarkupContext |
CXTPMarkupContext() | CXTPMarkupContext |
EnableGdiPlus(BOOL bEnable) | CXTPMarkupContext |
GetClientSite() const | CXTPMarkupContext |
GetContextWindow() const | CXTPMarkupContext |
GetCustomToolTipPosition() const | CXTPMarkupContext |
GetDefaultForeground() | CXTPMarkupContext |
GetDefaultLogFont() | CXTPMarkupContext |
GetDefaultSmoothingMode() const | CXTPMarkupContext |
GetDefaultTextSmoothing() const | CXTPMarkupContext |
GetExtensionRoot() | CXTPMarkupContext |
GetImageColorKey() const | CXTPMarkupContext |
GetImageManager() const | CXTPMarkupContext |
GetScriptEngine() | CXTPMarkupContext |
GetToolTipContext() const | CXTPMarkupContext |
GetUseCustomToolTipPosition() const | CXTPMarkupContext |
IsDpiAware() const | CXTPMarkupContext |
IsGdiPlusEnabled() const | CXTPMarkupContext |
LoadScriptCodeChunk(CXTPMarkupBuilder *pBuilder, LPCWSTR lpszLanguage, LPCWSTR lpszCode, LPCWSTR lpszRequires=NULL) | CXTPMarkupContext |
Parse(LPCSTR lpszBuffer) | CXTPMarkupContext |
Parse(LPCWSTR lpszBuffer) | CXTPMarkupContext |
RemoveCustomScriptItem(LPCWSTR lpName) | CXTPMarkupContext |
RunScriptEngine(CXTPMarkupBuilder *pBuilder) | CXTPMarkupContext |
Scale(const SIZE &size) const | CXTPMarkupContext |
ScaleX(int x) const | CXTPMarkupContext |
ScaleX(float x) const | CXTPMarkupContext |
ScaleX(double x) const | CXTPMarkupContext |
ScaleY(int y) const | CXTPMarkupContext |
ScaleY(float y) const | CXTPMarkupContext |
ScaleY(double y) const | CXTPMarkupContext |
SetClientSite(IXTPMarkupClientSite *pSite) | CXTPMarkupContext |
SetContextWindow(HWND hWnd, LPCRECT pUpdateRect=NULL) | CXTPMarkupContext |
SetDefaultFont(HFONT font) | CXTPMarkupContext |
SetDefaultFont(LOGFONT *font) | CXTPMarkupContext |
SetDefaultSmoothingMode(XTPMarkupSmoothingMode smoothingMode) | CXTPMarkupContext |
SetDefaultTextColor(COLORREF clr) | CXTPMarkupContext |
SetDefaultTextSmoothing(BOOL bEnableTextSmoothing) | CXTPMarkupContext |
SetDelegate(LPCWSTR lpszDelegate, CXTPMarkupDelegate *pDelegate) | CXTPMarkupContext |
SetDpiAware(BOOL bSet=TRUE) | CXTPMarkupContext |
SetDpiAware(BOOL bSet, HWND hWnd) | CXTPMarkupContext |
SetDpiAware(BOOL bSet, HDC hDC) | CXTPMarkupContext |
SetImageColorKey(COLORREF crColorKey) | CXTPMarkupContext |
SetImageManager(CXTPImageManager *pImageManager) | CXTPMarkupContext |
SetUseCustomToolTipPosition(BOOL bUse, CPoint ptPos=CPoint(0, 0)) | CXTPMarkupContext |
Shutdown() | CXTPMarkupContext |
ValidateXML(LPCSTR lpszBuffer) | CXTPMarkupContext |
ValidateXML(LPCWSTR lpszBuffer) | CXTPMarkupContext |
~CXTPMarkupContext() | CXTPMarkupContext | protectedvirtual


CXTPMenuBarMDIMenus Member List

This is the complete list of members for CXTPMenuBarMDIMenus, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMenuBarMDIMenus(CXTPMenuBar *pMenuBar) | CXTPMenuBarMDIMenus |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCount() const | CXTPMenuBarMDIMenus |
m_mapMenus | CXTPMenuBarMDIMenus | protected
m_pMenuBar | CXTPMenuBarMDIMenus | protected
~CXTPMenuBarMDIMenus() | CXTPMenuBarMDIMenus |


Toolkit Pro: XTPMarkupContext.h Source File

  • Source
  • Markup
XTPMarkupContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCONTEXT_H__)
24# define __XTPMARKUPCONTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32# include <ActivScp.h>
33# include <atlbase.h>
34# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
35
36# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
37
38class CXTPDpi;
39class CXTPMarkupObject;
40class CXTPImageManager;
41class CXTPMarkupUIElement;
42class CXTPMarkupInputElement;
43class CXTPMarkupContext;
44class CXTPMarkupEventHandlerMap;
45class CXTPMarkupRoutedEventArgs;
46class CXTPMarkupRoutedEvent;
47class CXTPMarkupDelegate;
48class CXTPMarkupFont;
49class CXTPMarkupType;
50class CXTPMarkupKeyboardNavigation;
51class CXTPToolTipContext;
52class CXTPMarkupParser;
53class CXTPMarkupBuilder;
54class CXTPActiveScriptEngine;
55class CXTPActiveScriptStdRuntime;
56class CXTPMarkupDelegateMap;
57class CXTPMarkupStaticExtension;
58template<class TYPE>
59class CXTPMarkupTypedSimpleStack;
60class CXTPMarkupDeviceDependentImage;
61class CXTPMarkupDeviceContext;
62struct IXTPMarkupDeviceDependentImageSite;
63
68enum XTPMarkupSmoothingMode
69{
70 xtpMarkupSmoothingDefault,
71 xtpMarkupSmoothingNone,
72 xtpMarkupSmoothingHighSpeed,
74 xtpMarkupSmoothingHighQuality,
75 xtpMarkupSmoothingAntiAlias,
76};
77
84struct IXTPMarkupClientSite
85{
90 virtual ~IXTPMarkupClientSite()
91 {
92 }
93
105 virtual LPWSTR PrepareCodeChunk(LPCWSTR pCode, const CList<LPCWSTR, LPCWSTR>& requirements)
106 {
107 XTP_UNUSED_PARAMETER(pCode);
108 XTP_UNUSED_PARAMETER(requirements);
109 return NULL;
110 }
111};
112
113# ifdef _XTP_ACTIVEX
114class _XTP_EXT_CLASS CXTPMarkupContext : public CXTPCmdTarget
115# else
116
118class CXTPMarkupContextInternalDispatch;
126class _XTP_EXT_CLASS CXTPMarkupContext
127# endif
128{
129protected:
130 class CInputElementCollection;
131
132public:
137 CXTPMarkupContext();
138
139protected:
144 virtual ~CXTPMarkupContext();
145
146public:
154 IXTPMarkupClientSite* GetClientSite() const;
160 void SetClientSite(IXTPMarkupClientSite* pSite);
161
169 void Shutdown();
170
177 LOGFONT* GetDefaultLogFont();
178
185 COLORREF GetDefaultForeground();
186
192 void SetDefaultTextColor(COLORREF clr);
193
199 void SetDefaultFont(HFONT font);
200
206 void SetDefaultFont(LOGFONT* font);
207
220 XTPMarkupSmoothingMode GetDefaultSmoothingMode() const;
221
236 XTPMarkupSmoothingMode SetDefaultSmoothingMode(XTPMarkupSmoothingMode smoothingMode);
237
249 BOOL GetDefaultTextSmoothing() const;
250
264 BOOL SetDefaultTextSmoothing(BOOL bEnableTextSmoothing);
265
273 CXTPMarkupUIElement* Parse(LPCSTR lpszBuffer);
274
282 CXTPMarkupUIElement* Parse(LPCWSTR lpszBuffer);
283
291 CString ValidateXML(LPCSTR lpszBuffer);
292
300 CString ValidateXML(LPCWSTR lpszBuffer);
301
314 void AddHandler(CXTPMarkupRoutedEvent* pEvent, CXTPMarkupDelegate* pDelegate);
315
328 void SetDelegate(LPCWSTR lpszDelegate, CXTPMarkupDelegate* pDelegate);
329
335 void EnableGdiPlus(BOOL bEnable);
336
344 BOOL IsGdiPlusEnabled() const;
345
352 CXTPToolTipContext* GetToolTipContext() const;
353
363 BOOL GetUseCustomToolTipPosition() const;
364
378 void SetUseCustomToolTipPosition(BOOL bUse, CPoint ptPos = CPoint(0, 0));
379
389 CPoint GetCustomToolTipPosition() const;
390
399 void SetImageManager(CXTPImageManager* pImageManager);
400
410 CXTPImageManager* GetImageManager() const;
411
423 void SetImageColorKey(COLORREF crColorKey);
424
436 COLORREF GetImageColorKey() const;
437
445 CXTPMarkupStaticExtension* GetExtensionRoot();
446
454 BOOL IsDpiAware() const;
455
462 void SetDpiAware(BOOL bSet = TRUE);
463
472 void SetDpiAware(BOOL bSet, HWND hWnd);
473
482 void SetDpiAware(BOOL bSet, HDC hDC);
483
495 int ScaleX(int x) const;
496
508 int ScaleY(int y) const;
509
521 float ScaleX(float x) const;
522
534 float ScaleY(float y) const;
535
547 double ScaleX(double x) const;
548
560 double ScaleY(double y) const;
561
573 CSize Scale(const SIZE& size) const;
574
575 double UnscaleX(double x) const;
576 double UnscaleY(double y) const;
577
586 void LoadScriptCodeChunk(CXTPMarkupBuilder* pBuilder, LPCWSTR lpszLanguage, LPCWSTR lpszCode,
587 LPCWSTR lpszRequires = NULL);
588
594 void RunScriptEngine(CXTPMarkupBuilder* pBuilder);
595
606 CXTPActiveScriptEngine* GetScriptEngine();
607
619 void AddCustomScriptItem(LPCWSTR lpName, LPDISPATCH pDisp);
620
628 void RemoveCustomScriptItem(LPCWSTR lpName);
629
637 HWND GetContextWindow() const;
638
646 void SetContextWindow(HWND hWnd, LPCRECT pUpdateRect = NULL);
647
649 // Internal methods
650 void ResetScriptEngine(BOOL bFinal = FALSE);
651 void RegisterScriptNamedObjects(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject);
652 void ThrowScriptEngineException(CXTPMarkupBuilder* pBuilder, HRESULT hr);
653
654 CXTPMarkupFont* GetFont(LOGFONT* pLogFont);
655
656 static BOOL AFX_CDECL CompareFont(LOGFONT* pLogFont1, LOGFONT* pLogFont2);
657
658 virtual BOOL OnWndMsg(CXTPMarkupUIElement* pUIElement, UINT message, WPARAM wParam,
659 LPARAM lParam, LRESULT* pResult);
660
661 void RaiseEvent(CXTPMarkupObject* pSource, CXTPMarkupRoutedEventArgs* pEventArgs);
662
663 CXTPMarkupDelegate* LookupDelegate(LPCWSTR lpszDelegate) const;
664
665 void CaptureMouse(CXTPMarkupInputElement* pUIElement);
666 void ReleaseMouseCapture(CXTPMarkupInputElement* pUIElement);
667 CXTPMarkupInputElement* GetMouseCapture() const;
668
669 CXTPMarkupKeyboardNavigation* GetKeyboardNavigation() const;
670
671 ULONG AddRef();
672 ULONG Release();
673 INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pToolInfo);
674
675 CXTPMarkupDeviceDependentImage* LoadImage(const CString& strSource, CSize size,
676 CXTPMarkupDeviceContext* pDC,
677 IXTPMarkupDeviceDependentImageSite* pSite);
678
679public:
680 void FreeCachedImages();
681
682public:
683 CRect GetClientBoundingRect(CXTPMarkupInputElement* pUIElement) const;
684 CRect GetUpdateRect(CXTPMarkupInputElement* pUIElement) const;
685 BOOL IsVisualChild(CXTPMarkupObject* pParent, CXTPMarkupObject* pChild) const;
686
687private:
688 void HandleMouseMove(CXTPMarkupUIElement* pUIElement, CPoint point);
689 void HandleMouseEnter(CXTPMarkupInputElement* pUIElement, CPoint point);
690 BOOL HandleSetCursor();
691 BOOL HandleMouseWheel(int nDelta);
692 BOOL HandleMouseUpDown(UINT message, WPARAM wParam, LPARAM lParam);
693
694 void BuildInputList(CXTPMarkupObject* pUIElement, CInputElementCollection* list);
695
696 void Cleanup();
697
698 void Redraw(LPCRECT pRect = NULL, BOOL bPending = FALSE);
699
700public:
701 virtual void OnInvalidateVisual(CXTPMarkupUIElement* pUIElement);
702 virtual void OnInvalidateArrange(CXTPMarkupUIElement* pUIElement);
703
704public:
705 CXTPMarkupObject* CreateMarkupObject(CXTPMarkupType* pRuntimeClass);
706 void FinalizeMarkupObject(CXTPMarkupObject* pObject);
707 static void AFX_CDECL RegisterClasses();
708 static void AFX_CDECL UnregisterClasses();
709
710protected:
711 virtual void GetScriptNamedItemNames(CList<LPCWSTR, LPCWSTR>& names);
712 virtual HRESULT GetScriptNamedItem(LPCWSTR lpszName, IUnknown** ppiunkItem);
713
714protected:
715 COLORREF m_clrForeground;
716 COLORREF m_clrImgColorKey;
717 LOGFONT m_logFont;
718 XTPMarkupSmoothingMode m_DefaultSmoothingMode;
719 BOOL m_bDefaultTextSmoothing;
720
721 CXTPMarkupInputElement* m_pMouseOver;
722 CXTPMarkupInputElement* m_pMouseCapture;
723 CXTPMarkupUIElement* m_pActiveElement;
724
725 CXTPMarkupTypedSimpleStack<CXTPMarkupFont>* m_pFonts;
726
727 CXTPMarkupEventHandlerMap* m_pHandlers;
728 CXTPMarkupDelegateMap* m_pDelegates;
729
730 CXTPMarkupKeyboardNavigation* m_pKeyboardNavigation;
731
732 CXTPToolTipContext* m_pToolTipContext;
733 BOOL m_bUseCustomToolTipPos;
734 CPoint m_ptCustomToolTipPos;
735
736 friend class CXTPMarkupFont;
737 class CTooltipContext;
738
739# ifndef _XTP_ACTIVEX
740 LONG m_dwRef;
741# endif
742
743 class _XTP_EXT_CLASS CCodeChunk
744 {
745 public:
746 CCodeChunk(LPCWSTR pCode, LPCWSTR pRequirements = NULL);
747 ~CCodeChunk();
748
749 LPCWSTR GetCode() const;
750 const CList<LPCWSTR, LPCWSTR>& GetRequirements() const;
751
752 private:
753 CComBSTR m_code;
754 CList<LPCWSTR, LPCWSTR> m_req;
755
756 CCodeChunk& operator=(const CCodeChunk& rhs);
757 };
758
759 class _XTP_EXT_CLASS CCustomScriptItem
760 {
761 public:
762 CCustomScriptItem(LPCWSTR pName, LPDISPATCH pDisp);
763 ~CCustomScriptItem();
764
765 LPCWSTR GetName() const;
766 LPDISPATCH GetDispatch() const;
767
768 private:
769 CComBSTR m_name;
770 LPDISPATCH m_pDisp;
771
772 CCustomScriptItem& operator=(const CCustomScriptItem& rhs);
773 };
774
775 CXTPImageManager* m_pImageManager;
776 CXTPMarkupStaticExtension* m_pExtensionRoot;
777
778 LPWSTR m_lpszScriptEngineLanguage;
779 CXTPActiveScriptEngine* m_pScriptEngine;
780 CList<CCodeChunk*, CCodeChunk*> m_ScriptCodeChunks;
781 CXTPActiveScriptStdRuntime* m_pScriptEngineStdRuntime;
782
783 CMap<CString, LPCTSTR, CCustomScriptItem*, CCustomScriptItem*> m_CustomScriptItems;
784
785 BOOL m_bEnableGdiPlus;
786 CXTPDpi* m_pDpi;
787 int m_nFreezeUpdatesCounter;
788
789private:
790 HWND m_hContextWnd;
791 CRect m_rcContextUpdateRect;
792 static BOOL m_bClassesRegistered;
793 BOOL m_bContainsPendingUpdates;
794 IXTPMarkupClientSite* m_pSite;
795
796 struct CachedImageData
797 {
798 CXTPMarkupDeviceDependentImage* pImage;
799 CSize size;
800 CRuntimeClass* pDCClass;
801 IXTPMarkupDeviceDependentImageSite* pSite;
802 };
803
804 CMap<CString, LPCTSTR, CList<CachedImageData*, CachedImageData*>*,
805 CList<CachedImageData*, CachedImageData*>*>
806 m_CachedImages;
807
808protected:
809# ifdef _XTP_ACTIVEX
810 DECLARE_INTERFACE_MAP()
811# endif
812
813# pragma warning(push)
814// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
815// C4619: #pragma warning : there is no warning number 'number'
816// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
817// of objects derived from this class may not be destructed correctly
818# pragma warning(disable : 4616 4619 5204)
819 BEGIN_INTERFACE_PART(ActiveScriptSite, IActiveScriptSite)
820 STDMETHOD(GetLCID)(LCID* plcid);
821 STDMETHOD(GetItemInfo)
822 (LPCOLESTR pstrName, DWORD dwReturnMask, IUnknown** ppiunkItem, ITypeInfo** ppti);
823 STDMETHOD(GetDocVersionString)(BSTR* pbstrVersion);
824 STDMETHOD(OnScriptTerminate)(const VARIANT* pvarResult, const EXCEPINFO* pexcepinfo);
825 STDMETHOD(OnStateChange)(SCRIPTSTATE ssScriptState);
826 STDMETHOD(OnScriptError)(IActiveScriptError* pScriptError);
827 STDMETHOD(OnEnterScript)();
828 STDMETHOD(OnLeaveScript)();
829
830# ifndef _XTP_ACTIVEX
831 CXTPMarkupContext* pThis;
832# endif
833 END_INTERFACE_PART(ActiveScriptSite);
834# pragma warning(pop)
835
836# ifndef _XTP_ACTIVEX
837 friend class XActiveScriptSite;
838# endif
839
840# ifdef _XTP_ACTIVEX
841public:
842 DECLARE_DISPATCH_MAP()
843
844 DECLARE_OLETYPELIB_EX(CXTPMarkupContext);
845
846# else
847protected:
848 friend class CXTPMarkupContextInternalDispatch;
849 CCmdTarget* m_pInternalDispatch;
850# endif
851
852 CCmdTarget* AccessInternalDispatch();
853
854protected:
855 void OleSetMethod(LPDISPATCH lpHandler, LPCOLESTR lpName);
856 void OleSetHandler(LPDISPATCH lpHandler);
857
858 LPDISPATCH OleCreateObject(LPCOLESTR lpName);
859 LPDISPATCH OleCreateSolidBrush(const VARIANT& clr);
860 LPDISPATCH OleCreateThickness(long nLeft, long nTop, long nRight, long nBottom);
861 LPDISPATCH OleParse(LPCTSTR lpText);
862 BOOL OleIsDpiAware();
863 void OleSetDpiAware(BOOL bNewValue);
864 LPDISPATCH OleGetToolTipContext();
865 void OleSetIcons(LPDISPATCH lpDisp);
866 LPDISPATCH OleGetIcons();
867
868 BSTR OleValidateXML(LPCTSTR lpText);
869
870 void OleFreezeUpdates();
871 void OleUnfreezeUpdates();
872
873 long OleGetDefaultSmoothingMode();
874 void OleSetDefaultSmoothingMode(long lMode);
875
876 BOOL OleGetDefaultTextSmoothing();
877 void OleSetDefaultTextSmoothing(BOOL bEnableTextSmoothing);
878
881 friend class CXTPMarkupInputElement;
882};
883
884AFX_INLINE IXTPMarkupClientSite* CXTPMarkupContext::GetClientSite() const
885{
886 return m_pSite;
887}
888
889AFX_INLINE void CXTPMarkupContext::SetClientSite(IXTPMarkupClientSite* pSite)
890{
891 m_pSite = pSite;
892}
893
894AFX_INLINE LOGFONT* CXTPMarkupContext::GetDefaultLogFont()
895{
896 return &m_logFont;
897}
898
899AFX_INLINE COLORREF CXTPMarkupContext::GetDefaultForeground()
900{
901 return m_clrForeground;
902}
903
904AFX_INLINE void CXTPMarkupContext::SetDefaultTextColor(COLORREF clr)
905{
906 m_clrForeground = clr;
907}
908
909AFX_INLINE void CXTPMarkupContext::SetDefaultFont(HFONT font)
910{
911 LOGFONT lf;
912 GetObject(font, sizeof(LOGFONT), &lf);
913 m_logFont = lf;
914}
915
916AFX_INLINE void CXTPMarkupContext::SetDefaultFont(LOGFONT* pLogFont)
917{
918 m_logFont = *pLogFont;
919}
920
921AFX_INLINE XTPMarkupSmoothingMode CXTPMarkupContext::GetDefaultSmoothingMode() const
922{
923 return m_DefaultSmoothingMode;
924}
925
926AFX_INLINE XTPMarkupSmoothingMode
927 CXTPMarkupContext::SetDefaultSmoothingMode(XTPMarkupSmoothingMode smoothingMode)
928{
929 XTPMarkupSmoothingMode oldMode = m_DefaultSmoothingMode;
930 m_DefaultSmoothingMode = smoothingMode;
931 return oldMode;
932}
933
934AFX_INLINE BOOL CXTPMarkupContext::GetDefaultTextSmoothing() const
935{
936 return m_bDefaultTextSmoothing;
937}
938
939AFX_INLINE BOOL CXTPMarkupContext::SetDefaultTextSmoothing(BOOL bEnableTextSmoothing)
940{
941 BOOL bOldState = m_bDefaultTextSmoothing;
942 m_bDefaultTextSmoothing = bEnableTextSmoothing;
943 return bOldState;
944}
945
946AFX_INLINE void CXTPMarkupContext::SetImageColorKey(COLORREF crColorKey)
947{
948 m_clrImgColorKey = crColorKey;
949}
951AFX_INLINE CXTPMarkupKeyboardNavigation* CXTPMarkupContext::GetKeyboardNavigation() const
952{
953 return m_pKeyboardNavigation;
954}
955
956AFX_INLINE CXTPMarkupInputElement* CXTPMarkupContext::GetMouseCapture() const
957{
958 return m_pMouseCapture;
959}
961AFX_INLINE BOOL CXTPMarkupContext::IsGdiPlusEnabled() const
962{
963 return m_bEnableGdiPlus;
964}
965
966AFX_INLINE void CXTPMarkupContext::EnableGdiPlus(BOOL bEnable)
967{
968 m_bEnableGdiPlus = bEnable;
969}
970
971AFX_INLINE CXTPToolTipContext* CXTPMarkupContext::GetToolTipContext() const
972{
973 return m_pToolTipContext;
974}
975
976AFX_INLINE BOOL CXTPMarkupContext::GetUseCustomToolTipPosition() const
977{
978 return m_bUseCustomToolTipPos;
979}
980
981AFX_INLINE void CXTPMarkupContext::SetUseCustomToolTipPosition(BOOL bUse,
982 CPoint ptPos /*= CPoint(0, 0)*/)
983{
984 m_bUseCustomToolTipPos = bUse;
985 m_ptCustomToolTipPos = ptPos;
986}
987
988AFX_INLINE CPoint CXTPMarkupContext::GetCustomToolTipPosition() const
989{
990 return m_ptCustomToolTipPos;
991}
992
993AFX_INLINE BOOL CXTPMarkupContext::IsDpiAware() const
994{
995 return NULL != m_pDpi;
996}
997
998AFX_INLINE void CXTPMarkupContext::SetDpiAware(BOOL bSet /*= TRUE*/)
999{
1000 SetDpiAware(bSet, HWND_DESKTOP);
1001}
1002
1003AFX_INLINE CXTPActiveScriptEngine* CXTPMarkupContext::GetScriptEngine()
1004{
1005 return m_pScriptEngine;
1006}
1007
1008AFX_INLINE HWND CXTPMarkupContext::GetContextWindow() const
1009{
1010 return m_hContextWnd;
1011}
1012
1013# define MARKUP_CREATE(object_class, context) \
1014 ((object_class*)context->CreateMarkupObject(MARKUP_TYPE(object_class)))
1015
1016# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1018#endif // !defined(__XTPMARKUPCONTEXT_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTP_UNUSED_PARAMETER
#define XTP_UNUSED_PARAMETER(name)
The macro should be used instead of UNUSED and UNREFERENCED_PARAMETER in order to address cross versi...
Definition XTPMacros.h:957
XTPMarkupSmoothingMode
XTPMarkupSmoothingMode
Defines markup smoothing mode.
Definition XTPMarkupContext.h:69
xtpMarkupSmoothingHighSpeed
@ xtpMarkupSmoothingHighSpeed
Smoothing is enabled but with trade-offs for better performance.
Definition XTPMarkupContext.h:72
xtpMarkupSmoothingDefault
@ xtpMarkupSmoothingDefault
Default implementation defined smoothing.
Definition XTPMarkupContext.h:70
xtpMarkupSmoothingAntiAlias
@ xtpMarkupSmoothingAntiAlias
Anti-aliasing smoothing is enabled.
Definition XTPMarkupContext.h:75
xtpMarkupSmoothingNone
@ xtpMarkupSmoothingNone
Smoothing is disabled for best performance.
Definition XTPMarkupContext.h:71
xtpMarkupSmoothingHighQuality
@ xtpMarkupSmoothingHighQuality
High quality smoothing is enabled.
Definition XTPMarkupContext.h:74
CXTPActiveScriptEngine
Implements ActiveScript engine component.
Definition XTPActiveScriptEngine.h:287
CXTPActiveScriptStdRuntime
Implements standard scripting runtime library.
Definition XTPActiveScriptEngine.h:461
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupContext::IsGdiPlusEnabled
BOOL IsGdiPlusEnabled() const
Determines if GDI+ is enabled/disabled.
Definition XTPMarkupContext.h:961
CXTPMarkupContext::GetContextWindow
HWND GetContextWindow() const
Gets a window handle associated with markup context.
Definition XTPMarkupContext.h:1008
CXTPMarkupContext::GetDefaultLogFont
LOGFONT * GetDefaultLogFont()
Gets the default font properties of markup objects.
Definition XTPMarkupContext.h:894
CXTPMarkupContext::ScaleX
int ScaleX(int x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI a...
CXTPMarkupContext::ScaleY
int ScaleY(int y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI a...
CXTPMarkupContext::ScaleX
float ScaleX(float x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI a...
CXTPMarkupContext::LoadScriptCodeChunk
void LoadScriptCodeChunk(CXTPMarkupBuilder *pBuilder, LPCWSTR lpszLanguage, LPCWSTR lpszCode, LPCWSTR lpszRequires=NULL)
Loads a chunk of script code in a specified language.
CXTPMarkupContext::IsDpiAware
BOOL IsDpiAware() const
Determines if context DPI awareness is enabled (i.e.
Definition XTPMarkupContext.h:993
CXTPMarkupContext::ScaleY
double ScaleY(double y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI a...
CXTPMarkupContext::AddCustomScriptItem
void AddCustomScriptItem(LPCWSTR lpName, LPDISPATCH pDisp)
Adds a custom scripting named item to the associated scripting context.
CXTPMarkupContext::SetDefaultSmoothingMode
XTPMarkupSmoothingMode SetDefaultSmoothingMode(XTPMarkupSmoothingMode smoothingMode)
Sets the default smoothing mode to be used for any drawing context that uses the context.
Definition XTPMarkupContext.h:927
CXTPMarkupContext::ScaleY
float ScaleY(float y) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI a...
CXTPMarkupContext::GetDefaultForeground
COLORREF GetDefaultForeground()
Gets the default text color of TextBlock objects.
Definition XTPMarkupContext.h:899
CXTPMarkupContext::GetImageColorKey
COLORREF GetImageColorKey() const
Gets the context specific color key for an image element.
CXTPMarkupContext::SetDefaultTextSmoothing
BOOL SetDefaultTextSmoothing(BOOL bEnableTextSmoothing)
Determines/specifies if text smoothing is enabled for any drawing context that uses the context.
Definition XTPMarkupContext.h:939
CXTPMarkupContext::SetDpiAware
void SetDpiAware(BOOL bSet, HDC hDC)
Enables/disables context DPI awareness.
CXTPMarkupContext::ValidateXML
CString ValidateXML(LPCWSTR lpszBuffer)
Validates XML correctness.
CXTPMarkupContext::SetContextWindow
void SetContextWindow(HWND hWnd, LPCRECT pUpdateRect=NULL)
Sets a window handle associated with markup context.
CXTPMarkupContext::~CXTPMarkupContext
virtual ~CXTPMarkupContext()
Destroys a CXTPMarkupContext object, handles cleanup and deallocation.
CXTPMarkupContext::GetCustomToolTipPosition
CPoint GetCustomToolTipPosition() const
Gets the custom x- and y- coordinates of the tooltip window.
Definition XTPMarkupContext.h:988
CXTPMarkupContext::GetScriptEngine
CXTPActiveScriptEngine * GetScriptEngine()
Obtains the associated ActiveScript engine object pointer if there is a scripting context assigned to...
Definition XTPMarkupContext.h:1003
CXTPMarkupContext::ScaleX
double ScaleX(double x) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI a...
CXTPMarkupContext::ValidateXML
CString ValidateXML(LPCSTR lpszBuffer)
Validates XML correctness.
CXTPMarkupContext::GetUseCustomToolTipPosition
BOOL GetUseCustomToolTipPosition() const
Determines if custom positioning for tooltips is enabled/disabled.
Definition XTPMarkupContext.h:976
CXTPMarkupContext::SetDelegate
void SetDelegate(LPCWSTR lpszDelegate, CXTPMarkupDelegate *pDelegate)
Sets a delegate for a Markup text event.
CXTPMarkupContext::SetDpiAware
void SetDpiAware(BOOL bSet, HWND hWnd)
Enables/disables context DPI awareness.
CXTPMarkupContext::RunScriptEngine
void RunScriptEngine(CXTPMarkupBuilder *pBuilder)
Runs script engine.
CXTPMarkupContext::SetDefaultTextColor
void SetDefaultTextColor(COLORREF clr)
Sets the default text color for TextBlock objects.
Definition XTPMarkupContext.h:904
CXTPMarkupContext::GetExtensionRoot
CXTPMarkupStaticExtension * GetExtensionRoot()
Gets a pointer to the extension root object used to add custom Markup extensions.
CXTPMarkupContext::SetDpiAware
void SetDpiAware(BOOL bSet=TRUE)
Enables/disables context DPI awareness.
Definition XTPMarkupContext.h:998
CXTPMarkupContext::GetImageManager
CXTPImageManager * GetImageManager() const
Gets the isolated image manager for elements inside the Markup context.
CXTPMarkupContext::RemoveCustomScriptItem
void RemoveCustomScriptItem(LPCWSTR lpName)
Removes a previously added named sciripting item from the context.
CXTPMarkupContext::Shutdown
void Shutdown()
Performs internal cleanup necessary for the final release.
CXTPMarkupContext::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
Definition XTPMarkupContext.h:971
CXTPMarkupContext::GetDefaultSmoothingMode
XTPMarkupSmoothingMode GetDefaultSmoothingMode() const
Gets the default smoothing mode to be used for any drawing context that uses the context.
Definition XTPMarkupContext.h:921
CXTPMarkupContext::GetDefaultTextSmoothing
BOOL GetDefaultTextSmoothing() const
Determines/specifies if text smoothing is enabled for any drawing context that uses the context.
Definition XTPMarkupContext.h:934
CXTPMarkupContext::CXTPMarkupContext
CXTPMarkupContext()
Constructs a CXTPMarkupContext object.
CXTPMarkupContext::AddHandler
void AddHandler(CXTPMarkupRoutedEvent *pEvent, CXTPMarkupDelegate *pDelegate)
Connects a Markup event with a class member or static method delegate.
CXTPMarkupContext::Parse
CXTPMarkupUIElement * Parse(LPCWSTR lpszBuffer)
Creates a Markup tree from its XML string.
CXTPMarkupContext::SetDefaultFont
void SetDefaultFont(HFONT font)
Sets the default font for TextBlock objects.
Definition XTPMarkupContext.h:909
CXTPMarkupContext::Parse
CXTPMarkupUIElement * Parse(LPCSTR lpszBuffer)
Creates a Markup tree from its XML string.
CXTPMarkupContext::GetClientSite
IXTPMarkupClientSite * GetClientSite() const
Gets a client site pointer.
Definition XTPMarkupContext.h:884
CXTPMarkupContext::SetUseCustomToolTipPosition
void SetUseCustomToolTipPosition(BOOL bUse, CPoint ptPos=CPoint(0, 0))
Enables/disables custom positioning for tooltips.
Definition XTPMarkupContext.h:981
CXTPMarkupContext::SetClientSite
void SetClientSite(IXTPMarkupClientSite *pSite)
Sets a client site pointer.
Definition XTPMarkupContext.h:889
CXTPMarkupContext::Scale
CSize Scale(const SIZE &size) const
Performs x- and y- coordinate scaling according to active DPI settings if the Markup context is DPI a...
CXTPMarkupContext::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Sets the isolated image manager for elements inside the Markup context.
CXTPMarkupContext::SetImageColorKey
void SetImageColorKey(COLORREF crColorKey)
Sets the context specific color key for an image element.
Definition XTPMarkupContext.h:946
CXTPMarkupContext::EnableGdiPlus
void EnableGdiPlus(BOOL bEnable)
Enables/disables GDI+ usage.
Definition XTPMarkupContext.h:966
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupStaticExtension
A base class for a markup static extension composite object.
Definition XTPMarkupStaticExtension.h:41
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291
IXTPMarkupClientSite
Defines default implementation of the markup client site interface.
Definition XTPMarkupContext.h:85
IXTPMarkupClientSite::PrepareCodeChunk
virtual LPWSTR PrepareCodeChunk(LPCWSTR pCode, const CList< LPCWSTR, LPCWSTR > &requirements)
Gets called by the markup context before executing script code chunk.
Definition XTPMarkupContext.h:105
IXTPMarkupClientSite::~IXTPMarkupClientSite
virtual ~IXTPMarkupClientSite()
Handles object destruction.
Definition XTPMarkupContext.h:90
IXTPMarkupDeviceDependentImageSite
Describes an image site interface.
Definition XTPMarkupDeviceDependentImage.h:40


XTP_NM_GRIDRECORDITEM Member List

This is the complete list of members for XTP_NM_GRIDRECORDITEM, including all inherited members.

hdr | XTP_NM_GRIDRECORDITEM
nHyperlink | XTP_NM_GRIDRECORDITEM
pColumn | XTP_NM_GRIDRECORDITEM
pItem | XTP_NM_GRIDRECORDITEM
pRow | XTP_NM_GRIDRECORDITEM
pt | XTP_NM_GRIDRECORDITEM


CXTPNotifySinkBase Member List

This is the complete list of members for CXTPNotifySinkBase, including all inherited members.

Advise(CXTPNotifyConnection *pConnection, XTP_NOTIFY_CODE dwNotifyCode) | CXTPNotifySinkBase | protected
CXTPNotifySinkBase() | CXTPNotifySinkBase |
m_mapAdviseData | CXTPNotifySinkBase | protected
OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags)=0 | CXTPNotifySinkBase | pure virtual
Unadvise(XTP_CONNECTION_ID id) | CXTPNotifySinkBase |
UnadviseAll() | CXTPNotifySinkBase |
~CXTPNotifySinkBase() | CXTPNotifySinkBase | protectedvirtual


CXTPButtonThemeUltraFlat Member List

This is the complete list of members for CXTPButtonThemeUltraFlat, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


CXTPChartStepAreaSeriesView Member List

This is the complete list of members for CXTPChartStepAreaSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartStepAreaSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartAreaSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartAreaSeriesView | protected
CXTPChartAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartAreaSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartStepAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartStepAreaSeriesView |
GetActualColor() const | CXTPChartAreaSeriesView | protected
GetActualColor2() const | CXTPChartAreaSeriesView | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBorderActualColor() const | CXTPChartAreaSeriesView | protected
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPComboBoxEditCtrl.h Source File

  • Source
  • Controls
  • Combo
XTPComboBoxEditCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXEDITCTRL_H__)
24# define __XTPCOMBOBOXEDITCTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPComboBoxEditCtrl : public CEdit
38{
39protected:
42 //{{AFX_VIRTUAL(CXTPComboBoxEditCtrl)
43 virtual void OnMouseLeave();
44 virtual void OnMouseMove(UINT nFlags, CPoint point);
45 //}}AFX_VIRTUAL
46
47 //{{AFX_MSG(CXTPComboBoxEditCtrl)
48 afx_msg void OnSetFocus(CWnd* pOldWnd);
49 afx_msg void OnKillFocus(CWnd* pNewWnd);
50 //}}AFX_MSG
51
52 DECLARE_MESSAGE_MAP()
53
54
55};
56
57# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // __XTPCOMBOBOXEDITCTRL_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBoxEditCtrl
Used by the CXTPComboBox object to subclass the edit-box portion of the control.
Definition XTPComboBoxEditCtrl.h:38


CXTPProgressThemeNativeWindows11 Member List

This is the complete list of members for CXTPProgressThemeNativeWindows11, including all inherited members.

CXTPProgressPaintManager(CXTPPaintManager *pPaintManager) | CXTPProgressPaintManager |
CXTPProgressThemeNativeWindows11(CXTPPaintManager *pPaintManager) | CXTPProgressThemeNativeWindows11 |
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPProgressThemeOffice2013 |
DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar) | CXTPProgressThemeOffice2013 | virtual
GetPaintManager() const | CXTPProgressPaintManager |
m_clrBack | CXTPProgressThemeOffice2013 | protected
m_clrBar | CXTPProgressThemeOffice2013 | protected
m_clrBorder | CXTPProgressThemeOffice2013 | protected
m_cyProgress | CXTPProgressPaintManager |
m_pPaintManager | CXTPProgressPaintManager | protected
RefreshMetrics() | CXTPProgressThemeOffice2013 | virtual
~CXTPProgressPaintManager() | CXTPProgressPaintManager | virtual
~CXTPProgressThemeNativeWindows11() | CXTPProgressThemeNativeWindows11 | virtual
~CXTPProgressThemeOffice2013() | CXTPProgressThemeOffice2013 | virtual


Toolkit Pro: XTPCalendarTheme.h Source File

  • Source
  • Calendar
XTPCalendarTheme.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_THEME_H__)
23# define _XTP_CALENDAR_THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# if (_MSC_VER > 1100)
32# pragma warning(push)
33# endif
34
35# pragma warning(disable : 4250)
36
37# pragma warning(disable : 4100) // TODO: remove when themes will be finished
38
40class CXTPCalendarControl;
41class CXTPCalendarViewDay;
42class CXTPCalendarDayView;
43class CXTPCalendarDayViewDay;
44class CXTPCalendarDayViewGroup;
45class CXTPCalendarMonthView;
46class CXTPCalendarWeekView;
47class CXTPCalendarDayViewEvent;
48class CXTPCalendarMonthViewEvent;
49class CXTPCalendarWeekViewEvent;
50class CXTPCalendarViewEvent;
51class XTPCalendarTimeLineView;
52class CXTPCalendarDayViewTimeScale;
53class CXTPCalendarTimeLineViewTimeScale;
54class CXTPImageManager;
55class CXTPResourceImage;
56class CXTPResourceImages;
57class CXTPResourceImageList;
58class CXTPCalendarWeekViewDay;
59class CXTPCalendarEvent;
60class CXTPCalendarViewGroup;
61class CXTPCalendarTheme;
62class CXTPCalendarViewEventSubjectEditor;
63class CXTPPropExchange;
64class CXTPCalendarFlagsSet_imp;
65
66struct XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS;
67struct XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS;
68struct XTP_LC_TIMEFORMAT;
69
71
77# if (_MSC_VER == 1310)
78# define XTP_SAFE_CALL_BASE(_TBase, memberFunc) ((_TBase*)this)->_TBase::memberFunc
79# else
80# define XTP_SAFE_CALL_BASE(_TBase, memberFunc) _TBase::memberFunc
81# endif
82
83# define DECLARE_THEMEPART_MEMBER_BASE
84# undef DECLARE_THEMEPART_MEMBER_BASE
85# define DECLARE_THEMEPART_MEMBER_BASE(cClassBase, memberName) \
86 public: \
87 virtual cClassBase* Get##memberName##Part() const \
88 { \
89 _ASSERTE(FALSE); \
90 return NULL; \
91 }
92
93# define DECLARE_THEMEPART_MEMBER_BASE2
94# undef DECLARE_THEMEPART_MEMBER_BASE2
95# define DECLARE_THEMEPART_MEMBER_BASE2(cClassBase, memberName) \
96 public: \
97 virtual cClassBase* Get##memberName##Part() const \
98 { \
99 return NULL; \
100 }
101
102//=============================================================
103# define DECLARE_THEMEPART
104# undef DECLARE_THEMEPART
105
106# define DECLARE_THEMEPART_CUSTOM
107# undef DECLARE_THEMEPART_CUSTOM
108
109# define DECLARE_THEMEPART2
110# undef DECLARE_THEMEPART2
111
112# if (_MSC_VER <= 1200) // Using Visual C++ 5.0, 6.0
113# define DECLARE_THEMEPART(cClass, cClassBase) \
114 class _XTP_EXT_CLASS cClass##_Base : virtual public cClassBase \
115 { \
116 }; /* To access base class members (in VC 6 compiler) */ \
117 class _XTP_EXT_CLASS cClass : virtual public cClass##_Base \
118 { \
119 public: \
120 typedef cClass##_Base TBase; \
121 \
122 public:
123
124# define DECLARE_THEMEPART_CUSTOM(cClass, cClassBase) \
125 class cClass##_Base : virtual public cClassBase \
126 { \
127 }; /* To access base class members (in VC 6 compiler) */ \
128 class cClass : virtual public cClass##_Base \
129 { \
130 public: \
131 typedef cClass##_Base TBase; \
132 \
133 public:
134
135# define DECLARE_THEMEPART2(cClass, cClassBase, cClassBase2) \
136 class _XTP_EXT_CLASS cClass##_Base : virtual public cClassBase \
137 { \
138 }; /* To access base class members (in VC 6 compiler) */ \
139 class _XTP_EXT_CLASS cClass##_Base2 : virtual public cClassBase2 \
140 { \
141 }; /* To access base class members (in VC 6 compiler) */ \
142 class _XTP_EXT_CLASS cClass \
143 : virtual public cClass##_Base \
144 , virtual public cClass##_Base2 \
145 { \
146 public: \
147 typedef cClass##_Base TBase; \
148 typedef cClass##_Base2 TBase2; \
149 \
150 public:
151
152# else
153# define DECLARE_THEMEPART(cClass, cClassBase) \
154 class _XTP_EXT_CLASS cClass : virtual public cClassBase \
155 { \
156 public: \
157 typedef cClassBase TBase; \
158 \
159 public:
160
161# define DECLARE_THEMEPART_CUSTOM(cClass, cClassBase) \
162 class cClass : virtual public cClassBase \
163 { \
164 public: \
165 typedef cClassBase TBase; \
166 \
167 public:
168
169# define DECLARE_THEMEPART2(cClass, cClassBase, cClassBase2) \
170 class _XTP_EXT_CLASS cClass \
171 : virtual public cClassBase \
172 , virtual public cClassBase2 \
173 { \
174 public: \
175 typedef cClassBase TBase; \
176 typedef cClassBase2 TBase2; \
177 \
178 public:
179
180# endif
181
182//=============================================================
183
184// TODO: custom via defines...
185# define DECLARE_THEMEPART2_CUSTOM
186# undef DECLARE_THEMEPART2_CUSTOM
187# define DECLARE_THEMEPART2_CUSTOM(cClass, cClassBase, cClassBase2) \
188 class cClass##_Base : virtual public cClassBase \
189 { \
190 }; /* To access base class members (in VC 6 compiler) */ \
191 class cClass##_Base2 : virtual public cClassBase2 \
192 { \
193 }; /* To access base class members (in VC 6 compiler) */ \
194 class cClass \
195 : virtual public cClass##_Base \
196 , virtual public cClass##_Base2 \
197 { \
198 public: \
199 typedef cClass##_Base TBase; \
200 typedef cClass##_Base2 TBase2; \
201 \
202 public:
203
204//=============================================================
205# define DECLARE_THEMEPART_MEMBER_
206# undef DECLARE_THEMEPART_MEMBER_
207# define DECLARE_THEMEPART_MEMBER_(nIndex, cClass, memberName, cClassBase) \
208 protected: \
209 virtual CXTPCalendarThemePart* CreateMember##nIndex() \
210 { \
211 _ASSERTE(TBase::CreateMember##nIndex() == NULL); \
212 m_p##memberName = new cClass(); \
213 if (m_p##memberName) \
214 m_p##memberName->SetInstanceName(_T(#memberName)); \
215 return m_p##memberName; \
216 } \
217 \
218 public: \
219 cClass* m_p##memberName; \
220 \
221 public: \
222 virtual cClassBase* Get##memberName##Part() const \
223 { \
224 return m_p##memberName; \
225 } \
226 virtual cClass* Get##memberName##PartX() const \
227 { \
228 return m_p##memberName; \
229 } \
230 virtual void Set##memberName##Part(cClass* pPart) \
231 { \
232 if (pPart) \
233 { \
234 if (!pPart->IsCreated()) \
235 pPart->Create(GetTheme(), this); \
236 pPart->SetInstanceName(_T(#memberName)); \
237 } \
238 m_p##memberName = pPart; \
239 m_arMembers.SetAt(nIndex, pPart); \
240 }
241
242//=============================================================
243# define DECLARE_THEMEPART_MEMBER
244# undef DECLARE_THEMEPART_MEMBER
245# define DECLARE_THEMEPART_MEMBER(nIndex, cClass, memberName) \
246 DECLARE_THEMEPART_MEMBER_(nIndex, cClass, memberName, CXTPCalendarTheme::##cClass)
247// }}AFX_CODEJOCK_PRIVATE
248
249// {{AFX_CODEJOCK_PRIVATE
251# ifdef _XTP_ACTIVEX
252// {{ AFX_CODEJOCK_PRIVATE
253
254// TODO: Remove unused class....
255class CXTPCalendarThemeAxPart : public CXTPCmdTarget
256{
257public:
258protected:
259};
260# endif
261
262//=============================================================================
263class _XTP_EXT_CLASS CXTPCalendarThemePart : public CXTPCmdTarget
264{
266 DECLARE_DYNAMIC(CXTPCalendarThemePart)
268public:
269 CXTPCalendarThemePart();
270 virtual ~CXTPCalendarThemePart();
271
272 virtual CXTPCalendarThemePart* GetOwner();
273 virtual CXTPCalendarTheme* GetTheme() const;
274 CXTPCalendarControl* GetCalendarControl() const;
275
276 virtual LPCTSTR GetInstanceName();
277 virtual void SetInstanceName(LPCTSTR pcszInstanceName);
278
279 virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
280
281 virtual void DoPropExchange(CXTPPropExchange* pPX);
282 virtual void Serialize(CArchive& ar);
283
284 //****************
285 virtual void Draw(CCmdTarget* pObject, CDC* pDC){};
286
287public:
288 virtual UINT_PTR SetTimer(UINT uTimeOut_ms);
289 virtual void KillTimer(UINT_PTR uTimerID);
290
291 // messages handlers
292 virtual void OnMouseMove(CCmdTarget* pObject, UINT nFlags, CPoint point){};
293 virtual BOOL OnLButtonDown(CCmdTarget* pObject, UINT nFlags, CPoint point)
294 {
295 return FALSE;
296 };
297
298 virtual BOOL OnTimer(UINT_PTR uTimerID);
299 virtual void OnDetachCalendar();
300
301protected:
302 CXTPCalendarTheme* m_pTheme;
303 CXTPCalendarThemePart* m_pOwner;
304 CString m_strInstanceName;
305
306protected:
307 typedef CXTPCalendarPtrCollectionT<CXTPCalendarThemePart> CThemePartsArray;
308 CThemePartsArray m_arMembers;
309
310public:
311 virtual BOOL IsCreated();
312 virtual void Create(CXTPCalendarTheme* pTheme, CXTPCalendarThemePart* pOwner);
313
314protected:
315 virtual void _CreateMembers();
316
317 virtual CXTPCalendarThemePart* CreateMember0()
318 {
319 return NULL;
320 };
321 virtual CXTPCalendarThemePart* CreateMember1()
322 {
323 return NULL;
324 };
325 virtual CXTPCalendarThemePart* CreateMember2()
326 {
327 return NULL;
328 };
329 virtual CXTPCalendarThemePart* CreateMember3()
330 {
331 return NULL;
332 };
333 virtual CXTPCalendarThemePart* CreateMember4()
334 {
335 return NULL;
336 };
337 virtual CXTPCalendarThemePart* CreateMember5()
338 {
339 return NULL;
340 };
341 virtual CXTPCalendarThemePart* CreateMember6()
342 {
343 return NULL;
344 };
345 virtual CXTPCalendarThemePart* CreateMember7()
346 {
347 return NULL;
348 };
349 virtual CXTPCalendarThemePart* CreateMember8()
350 {
351 return NULL;
352 };
353 virtual CXTPCalendarThemePart* CreateMember9()
354 {
355 return NULL;
356 };
357
358protected:
359 class _XTP_EXT_CLASS CXTPPropsState
360 {
361 public:
362 CXTPPropsState();
363 virtual ~CXTPPropsState();
364
365 void SaveState();
366 void RestoreState(BOOL bClearData);
367 void ClearLastState();
368
369 void ClearAll();
370
371# ifdef _DEBUG
372 static int s_dbg_nActiveStates;
373# endif
374
375 protected:
376 CXTPCalendarTypedPtrAutoDeleteArray<CPtrArray, CMemFile*> m_arStates;
377
378 static BOOL s_bUseSerialize;
379 };
380 friend class CXTPPropsState;
381 //---------------------------------------------
382 class _XTP_EXT_CLASS CXTPPropsStateContext
383 {
384 CXTPCalendarThemePart* m_pPart;
385 int m_eBeroreDrawFlag;
386
387 // BOOL m_bAttached;
388 public:
389 CXTPPropsStateContext(CXTPCalendarThemePart* pPart = NULL, int eBDFlag = 0,
390 BOOL bClearAll = FALSE);
391 virtual ~CXTPPropsStateContext();
392
393 BOOL IsActive()
394 {
395 return !!m_pPart;
396 }
397
398 void SetData(CXTPCalendarThemePart* pPart, int eBDFlag = 0, BOOL bClearAll = FALSE);
399 void Clear();
400
401 // void Attach(CXTPCalendarThemePart* pPart, int eBDFlag = 0);
402
403 void RestoreState();
404 void SendBeforeDrawThemeObject(LPARAM lParam, int eBDFlag = 0);
405 };
406 friend class CXTPPropsStateContext;
407
408 virtual void SendNotificationAlways(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam);
409
410 CXTPPropsState m_xPropsState;
411 BOOL m_bSendBeforeDrawThemeObjectEnabled;
412};
413
415// Initial version. Will be expanded in the future.
416class _XTP_EXT_CLASS CXTPCalendarTheme : public CXTPCalendarThemePart
417{
418 friend class CXTPCalendarControl;
419 DECLARE_DYNAMIC(CXTPCalendarTheme)
420
421 typedef CXTPCalendarThemePart TBase;
422
423protected:
424 CXTPCalendarControl* m_pCalendar;
425 CMap<UINT, UINT, UINT, UINT&> m_mapEventIdEventSlotId;
427 virtual void SetCalendarControl(CXTPCalendarControl* pCalendar);
428
429 virtual void Init();
430
431public:
441 CMap<UINT, UINT, UINT, UINT&>& GetEventSlotMap();
442
443 CXTPCalendarTheme();
444 virtual ~CXTPCalendarTheme();
445
446 virtual CXTPCalendarControl* GetCalendarControl() const;
447
448 //=======================================================================
449 class _XTP_EXT_CLASS CThemeFontColorSet
450 {
451 public:
452 virtual ~CThemeFontColorSet()
453 {
454 }
455
456 virtual CFont* Font() const = 0;
457 virtual COLORREF Color() const = 0;
458 };
459
460 //=======================================================================
461 class _XTP_EXT_CLASS CThemeFontColorSetValue : public CThemeFontColorSet
462 {
463 public:
464 CXTPPaintManagerColor clrColor;
465 CXTPCalendarThemeFontValue fntFont;
466
467 void SetStandardValue(const CThemeFontColorSet& fcsetValue)
468 {
469 clrColor.SetStandardValue(fcsetValue.Color());
470 fntFont.SetStandardValue(fcsetValue.Font());
471 }
472
473 void CopySettings(const CThemeFontColorSetValue& refSrc)
474 {
475 CXTPCalendarTheme::CopySettings(clrColor, refSrc.clrColor);
476 fntFont.CopySettings(refSrc.fntFont);
477 }
478 //--------------------------------------------
479 virtual CFont* Font() const
480 {
481 return fntFont;
482 }
483 virtual COLORREF Color() const
484 {
485 return clrColor;
486 }
487
488 virtual void doPX(CXTPPropExchange* pPX, LPCTSTR pcszPropName, CXTPCalendarTheme* pTheme);
489 virtual void Serialize(CArchive& ar);
490 };
491
492 //=======================================================================
493 class _XTP_EXT_CLASS CTOFormula_MulDivC : virtual public CXTPCalendarThemePart
494 {
495 public:
496 CTOFormula_MulDivC();
497
498 virtual void RefreshFromParent(CTOFormula_MulDivC* pParentSrc);
499
500 virtual void SetStandardValue(int nMul, int nDiv, int nC);
501 virtual int Calculate(int nY) const;
502
503 virtual void DoPropExchange(CXTPPropExchange* pPX);
504 virtual void Serialize(CArchive& ar);
505 //------------------------------------------------------------
506
507 CXTPCalendarThemeIntValue m_Multiplier;
508 CXTPCalendarThemeIntValue m_Divisor;
509 CXTPCalendarThemeIntValue m_Constant;
510 };
511 friend class CTOFormula_MulDivC;
512
513 //=======================================================================
514 class _XTP_EXT_CLASS CTOEventIconsToDraw : virtual public CXTPCalendarThemePart
515 {
516 public:
517 CXTPCalendarThemeBOOLValue m_ShowReminder;
518 CXTPCalendarThemeBOOLValue m_ShowOccurrence;
519 CXTPCalendarThemeBOOLValue m_ShowException;
520 CXTPCalendarThemeBOOLValue m_ShowMeeting;
521 CXTPCalendarThemeBOOLValue m_ShowPrivate;
522
523 virtual void RefreshFromParent(CTOEventIconsToDraw* pParentSrc);
524 virtual void SetStandardValue(BOOL bRmd, BOOL bOcc, BOOL bExc, BOOL bMee, BOOL bPrv);
525
526 virtual void DoPropExchange(CXTPPropExchange* pPX);
527 virtual void Serialize(CArchive& ar);
528
529 CTOEventIconsToDraw();
530 virtual void FillIconIDs(CUIntArray& rarGlyphIDs, CUIntArray& rarGlyphIndex,
531 CXTPCalendarEvent* pEvent);
532 };
533 friend class CTOEventIconsToDraw;
534
535 //=======================================================================
536 struct _XTP_EXT_CLASS XTP_BUSY_STATUS_CONTEXT
537 {
538 COLORREF clrBkAllDayEvents;
539 COLORREF clrBkWorkCell;
540 COLORREF clrBkNonWorkCell;
541 COLORREF clrCellBorder;
542
543 // BOOL IsNull()
544 // {
545 // return clrBkAllDayEvents == 0 && clrBkWorkCell == 0 &&
546 // clrBkNonWorkCell == 0 && clrCellBorder == 0;
547 // }
548 };
549
550 //=======================================================================
551 class _XTP_EXT_CLASS CTOHeader : virtual public CXTPCalendarThemePart
552 {
553 public:
554 enum XTPEnumCalendarItemState
555 {
556 xtpCalendarItemState_Normal = 0,
557 xtpCalendarItemState_Selected = 0x001,
558 xtpCalendarItemState_Today = 0x002,
559 xtpCalendarItemState_Hot = 0x004,
560 xtpCalendarItemState_mask = 0x00F,
561
562 xtpCalendarItemFirst = 0x010,
563 xtpCalendarItemLast = 0x020,
564 };
565
566 struct _XTP_EXT_CLASS CHeaderText
567 {
568 virtual ~CHeaderText()
569 {
570 }
571
572 CThemeFontColorSetValue fcsetNormal;
573 CThemeFontColorSetValue fcsetSelected;
574 CThemeFontColorSetValue fcsetToday;
575 CThemeFontColorSetValue fcsetTodaySelected;
576
577 virtual CThemeFontColorSet* GetFontColor(int nItemState);
578
579 virtual void CopySettings(const CHeaderText& rSrc);
580
581 virtual void doPX(CXTPPropExchange* pPX, LPCTSTR pcszPropName,
582 CXTPCalendarTheme* pTheme);
583 virtual void Serialize(CArchive& ar);
584 };
585
586 struct _XTP_EXT_CLASS CHeaderBackground
587 {
588 virtual ~CHeaderBackground()
589 {
590 }
591
592 CXTPCalendarThemeIntValue nBitmapID;
593 CXTPCalendarThemeRectValue rcBitmapBorder;
594
595 // effects ...
596 // CXTPCalendarThemeIntValue eDrawOptions;
597 //
598 // CXTPCalendarThemeBOOLValue bFillBySelectedColorBeforeDraw;
599 // CXTPCalendarThemeBOOLValue bFillTextBySelectedColorAfterDraw;
600
601 virtual void CopySettings(const CHeaderBackground& rSrc)
602 {
603 nBitmapID.CopySettings(rSrc.nBitmapID);
604 rcBitmapBorder.CopySettings(rSrc.rcBitmapBorder);
605 }
606
607 virtual void doPX(CXTPPropExchange* pPX, LPCTSTR pcszPropName,
608 CXTPCalendarTheme* pTheme);
609 virtual void Serialize(CArchive& ar);
610 };
611
612 //===========================================
613 CXTPPaintManagerColor m_clrBaseColor;
614 CXTPPaintManagerColor m_clrTodayBaseColor;
615
616 CHeaderBackground m_bkNormal;
617 CHeaderBackground m_bkSelected;
618 CHeaderBackground m_bkToday;
619 CHeaderBackground m_bkTodaySelected;
620
621 CHeaderText m_TextLeftRight;
622 CHeaderText m_TextCenter;
623
624 virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
625 virtual void RefreshFromParent(CTOHeader* pParentSrc);
626
627 virtual void DoPropExchange(CXTPPropExchange* pPX);
628 virtual void Serialize(CArchive& ar);
629
630 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect){};
631 virtual int CalcHeight(CDC* pDC, int nCellWidth);
632
633 //-------------------------------------------------------------------
634 virtual BOOL IsToday(CXTPCalendarViewDay* pViewDay);
635 virtual BOOL IsSelected(CXTPCalendarViewDay* pViewDay);
636 virtual BOOL IsSelected(CXTPCalendarViewGroup* pViewGroup);
637 //-------------------------------------------------------------------
638 virtual void Draw_Header(CDC* pDC, const CRect& rcRect, int nFlags, LPCTSTR pcszLeftText,
639 LPCTSTR pcszCenterText = NULL, LPCTSTR pcszRightText = NULL,
640 BOOL bMultiCase = FALSE);
641
642 virtual void Draw_Background(CDC* pDC, const CRect& rcRect, int nState);
643
644 virtual void Draw_TextLR(CDC* pDC, const CRect& rcRect, int nFlags, LPCTSTR pcszText,
645 UINT uFormat, int* pnWidth = NULL);
646
647 virtual void Draw_TextCenter(CDC* pDC, const CRect& rcRect, int nState,
648 LPCTSTR pcszCenterText, int* pnWidth = NULL);
649
650 DECLARE_THEMEPART_MEMBER_BASE(CTOFormula_MulDivC, HeightFormula)
651
652 protected:
653 };
654
655 class _XTP_EXT_CLASS CTOEvent : virtual public CXTPCalendarThemePart
656 {
657 public:
658 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
659 int nEventPlaceNumber){};
660 virtual int CalcMinEventHeight(CDC* pDC)
661 {
662 return 19;
663 };
664
665 virtual CBrush* GetBusyStatusBrush(int nBusyStatus);
666 virtual void SetBusyStatusBrush(int nBusyStatus, CBrush* pBrush, BOOL bAutodeleteBrush);
667
668 DECLARE_THEMEPART_MEMBER_BASE2(CTOFormula_MulDivC, HeightFormula)
669 DECLARE_THEMEPART_MEMBER_BASE2(CTOEventIconsToDraw, EventIconsToDraw)
670
671 protected:
672 virtual void InitBusyStatusDefaultColors();
673
674 virtual CXTPCalendarViewPartBrushValue* _GetBusyStatusBrushValue(int nBusyStatus,
675 BOOL bCreateIfNotExist);
676 CXTPCalendarTypedPtrAutoDeleteMap<int, CXTPCalendarViewPartBrushValue*>
677 m_mapBusyStatusBrushes;
678
679 CBitmap m_bmpElsewherePattern;
681 CXTPBrush m_xtpBrushElsewhere;
683 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushElsewhere, m_xtpBrushElsewhere,
684 GetBrushElsewhereHandle);
685
686 CBitmap m_bmpTentativePattern;
688 CXTPBrush m_xtpBrushTentative;
690 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushTentative, m_xtpBrushTentative,
691 GetBrushTentativeHandle);
692 };
693
694 class _XTP_EXT_CLASS CTODay : virtual public CXTPCalendarThemePart
695 {
696 public:
697 virtual int GetExpandButtonHeight();
698 virtual int HitTestExpandDayButton(
699 const CXTPCalendarViewDay* pViewDay,
700 const CPoint* pPoint = NULL);
701 protected:
702 virtual int _HitTestExpandDayButton(
703 const CXTPCalendarViewDay* pViewDay, const CRect& rc,
704 const CPoint* pPoint = NULL);
705 };
706
708 //
709 // *** DayView theme parts ***
710 //
711 // Parts Hierarchy:
712 // *Theme CXTPCalendarTheme
713 // *--Header* CTOHeader
714 // *--Event* CTOEvent
715 //
716 // *--DayView CTODayView
717 // *----Event* CTODayViewEvent
718 // *----Header CTOHeader
719 // *----TimeScale CTODayViewTimeScale
720 // *----Day CTODayViewDay
721 // *------Header CTODayViewDayHeader
722 // *------Group CTODayViewDayGroup
723 // *--------Header CTODayViewDayGroupHeader
724 // *--------AllDayEvents CTODayViewDayGroupAllDayEvents
725 // *--------Cell CTODayViewDayGroupCell
726 // *--------MultiDayEvent CTODayViewEvent_MultiDay
727 // *--------SingleDayEvent CTODayViewEvent_SingleDay
728 //
730
732 // DayView Time Scale
733 class _XTP_EXT_CLASS CTODayViewTimeScale : virtual public CXTPCalendarThemePart
734 {
735 public:
736 CXTPPaintManagerColor m_clrBackground;
737 CXTPPaintManagerColor m_clrLine;
738 CThemeFontColorSetValue m_fcsetCaption;
739
740 CThemeFontColorSetValue m_fcsetAMPM;
741
742 CThemeFontColorSetValue m_fcsetSmall;
743 CThemeFontColorSetValue m_fcsetBigBase;
744
745 CXTPPaintManagerColorGradient m_grclrNowLineBk;
746 CXTPPaintManagerColor m_clrNowLine;
747
748 CXTPCalendarThemeBOOLValue m_ShowMinutes;
749
750 DECLARE_THEMEPART_MEMBER_BASE(CTOFormula_MulDivC, HeightFormula)
751
752 virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
753
754 virtual void DoPropExchange(CXTPPropExchange* pPX);
755 virtual void Serialize(CArchive& ar);
756
757 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
758 virtual void Draw(CCmdTarget* pObject, CDC* pDC);
759
760 virtual int CalcMinRowHeight(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale);
761 virtual int CalcWidth(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale, int nRowHeight);
762 virtual int CalcWidth_AmPmMinutesPart(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale,
763 int* pnCharWidth = NULL);
764
765 virtual int GetRightOffsetX(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale);
766
767 public:
768 virtual void Draw_SmallHourCell(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale,
769 const CRect& rcCell, const CString& strPart1,
770 const CString& strPart2,
771 CThemeFontColorSetValue* pfcsetPart1,
772 CThemeFontColorSetValue* pfcsetPart2,
773 CXTPPropsStateContext& autoStateCnt,
774 XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS* tsCell);
775
776 virtual void Draw_BigHourCell(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale,
777 const CRect& rcCell, int nRowPerHour, const CString& strHour,
778 const CString& strMinAmPm,
779 CThemeFontColorSetValue* pfcsetHour,
780 CThemeFontColorSetValue* pfcsetMinAmPm,
781 CXTPPropsStateContext& autoStateCnt,
782 XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS* tsCell);
783
784 virtual void Draw_Caption(CDC* pDC, const CRect& rcRect, const CString& strCaption,
785 CThemeFontColorSetValue* pfcsetCaption);
786
787 virtual CRect Calc_NowLineRect(CDC* pDC, CXTPCalendarDayViewTimeScale* pTimeScale);
788
789 virtual void Draw_NowLineBk(CDC* pDC, const CRect& rcRect);
790 virtual void Draw_NowLine(CDC* pDC, const CRect& rcRect);
791
792 virtual BOOL IsDrawNowLine(CDC* pDC, CXTPCalendarDayViewTimeScale* pTS);
793
794 CTODayViewTimeScale()
795 {
796 m_nWidthAmPmMinutesPart_ = 0;
797 m_nCharWidthAmPmMinutesPart_ = 0;
798 }
799
800 protected:
801 CThemeFontColorSetValue m_fcsetBigHour_;
802 int m_nWidthAmPmMinutesPart_;
803 int m_nCharWidthAmPmMinutesPart_;
804
805 CTOFormula_MulDivC m_hflaBigHourFont;
806 virtual void AdjustBigHourFont(CDC* pDC, const CRect& rcRowCell);
807 virtual void RefreshBigHourFontIfNeed(BOOL bRefreshToStandard);
808
809 CString FormatTime(const XTP_LC_TIMEFORMAT& lcTimeFormat, COleDateTime dtTime,
810 BOOL bAmPmEnshure, CString& rstrHour, CString& rstrMin,
811 CString& rstrAmPm);
812
813 void DrawTimescaleRTL(CCmdTarget* pObject, CDC* pDC);
814 void DrawTimescaleLTR(CCmdTarget* pObject, CDC* pDC);
815 };
816 friend class CTODayViewTimeScale;
817
819 // Day View Events (different types)
820 class _XTP_EXT_CLASS CTODayViewEvent : virtual public CTOEvent
821 {
822 public:
823 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
824 int nEventPlaceNumber);
825 };
826 friend class CTODayViewEvent;
827
828 //==========================================================================
829 class _XTP_EXT_CLASS CTODayViewEvent_MultiDay : virtual public CTODayViewEvent
830 {
831 public:
832 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
833 int nEventPlaceNumber);
834
835 virtual void CalcEventYs(CRect& rcRect, int nEventPlaceNumber){};
836 };
837 friend class CTODayViewEvent_MultiDay;
838
839 //==========================================================================
840 class _XTP_EXT_CLASS CTODayViewEvent_SingleDay : virtual public CTODayViewEvent
841 {
842 public:
843 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect,
844 int nEventPlaceNumber);
845
846 virtual void DrawShadow(CDC* pDC, CXTPCalendarDayViewEvent* pViewEvent){};
847
848 protected:
849 };
850 friend class CTODayViewEvent_SingleDay;
851
853 // DayView Resource Group
854 class _XTP_EXT_CLASS CTODayViewDayGroupHeader : virtual public CTOHeader
855 {
856 public:
857 };
858 friend class CTODayViewDayGroupHeader;
859
860 //=======================================================================
861 class _XTP_EXT_CLASS CTODayViewDayGroupAllDayEvents : virtual public CXTPCalendarThemePart
862 {
863 public:
864 CXTPPaintManagerColor m_clrBackground;
865 CXTPPaintManagerColor m_clrBackgroundSelected;
866 CXTPPaintManagerColor m_clrBottomBorder;
867
868 virtual void DoPropExchange(CXTPPropExchange* pPX);
869 virtual void Serialize(CArchive& ar);
870
871 virtual void Draw(CCmdTarget* pObject, CDC* pDC);
872
873 virtual void SetDynColors(CXTPCalendarDayViewGroup* pViewGroup){};
874 };
875 friend class CTODayViewDayGroupAllDayEvents;
876
877 //=======================================================================
878 class _XTP_EXT_CLASS CTODayViewDayGroupCell : virtual public CXTPCalendarThemePart
879 {
880 public:
881 struct XTP_GROUP_CELL_COLOR_SET
882 {
883 virtual ~XTP_GROUP_CELL_COLOR_SET()
884 {
885 }
886
887 CXTPPaintManagerColor clrBackground;
888 CXTPPaintManagerColor clrBorderBottomInHour;
889 CXTPPaintManagerColor clrBorderBottomHour;
890 CXTPPaintManagerColor clrSelected;
891
892 void doPX(CXTPPropExchange* pPX, LPCTSTR pcszPropName, CXTPCalendarTheme* pTheme);
893 virtual void Serialize(CArchive& ar);
894 };
895
896 XTP_GROUP_CELL_COLOR_SET m_clrsetWorkCell;
897 XTP_GROUP_CELL_COLOR_SET m_clrsetNonWorkCell;
898
899 virtual void DoPropExchange(CXTPPropExchange* pPX);
900 virtual void Serialize(CArchive& ar);
901
902 virtual void Draw(CDC* pDC, const CRect& rcRect,
903 const XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS& cellParams,
904 CXTPPropsStateContext* pStateCnt = NULL);
905 using CXTPCalendarThemePart::Draw;
906
907 virtual int CalcHeight(CDC* pDC, int nCellWidth)
908 {
909 return 19;
910 } // pDayView->CalculateHeaderFormatAndHeight(pDC, nCellWidth);
911 };
912 friend class CTODayViewDayGroupCell;
913
914 //=======================================================================
915 class _XTP_EXT_CLASS CTODayViewDayGroup : public CXTPCalendarThemePart
916 {
917 public:
918 CXTPPaintManagerColor m_clrBorderLeft;
919
920 virtual void DoPropExchange(CXTPPropExchange* pPX);
921 virtual void Serialize(CArchive& ar);
922
923 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
924 virtual void Draw(CCmdTarget* pObject, CDC* pDC);
925 virtual void DrawAllDayAreaScrollIcons(CCmdTarget* pObject, CDC* pDC);
926 virtual BOOL IsSelected(CXTPCalendarViewGroup* pViewGroup)
927 {
928 return FALSE;
929 };
930
931 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewDayGroupHeader, Header)
932 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewDayGroupAllDayEvents, AllDayEvents)
933 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewDayGroupCell, Cell)
934 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewEvent_MultiDay, MultiDayEvent)
935 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewEvent_SingleDay, SingleDayEvent)
936
937 virtual int HitTestScrollButton(const CXTPCalendarDayViewGroup* pViewGroup,
938 const CPoint* pPoint = NULL); // return 0 or ... flag
939 virtual CRect GetScrollButtonRect(const XTP_DAY_VIEW_GROUP_LAYOUT& groupLayout,
940 int nButton) = 0;
941
942 protected:
943 virtual void AdjustDayEvents(CXTPCalendarDayViewGroup* pDayViewGroup, CDC* pDC);
944 };
945 friend class CTODayViewDayGroup;
946
948 // DayView day theme part
949 class _XTP_EXT_CLASS CTODayViewDayHeader : virtual public CTOHeader
950 {
951 public:
952 virtual void Draw(CCmdTarget* pObject, CDC* pDC){};
953 };
954 friend class CTODayViewDayHeader;
955
956 //==========================================================================
957 class _XTP_EXT_CLASS CTODayViewDay : virtual public CXTPCalendarThemePart
958 {
959 public:
960 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
961 virtual void Draw(CCmdTarget* pObject, CDC* pDC);
962 virtual void DrawTopmostLayer(CCmdTarget* pObject, CDC* pDC);
963
964 virtual CRect ExcludeDayBorder(CXTPCalendarDayViewDay* pDayViewDay, const CRect& rcDay)
965 {
966 return rcDay;
967 };
968 virtual void Draw_DayBorder(CXTPCalendarDayViewDay* pDayViewDay, CDC* pDC){};
969
970 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewDayHeader, Header)
971 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewDayGroup, Group)
972 };
973 friend class CTODayViewDay;
974
976 // DayView theme part object
977 class _XTP_EXT_CLASS CTODayView : virtual public CXTPCalendarThemePart
978 {
979 public:
980 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect);
981 virtual void OnPostAdjustLayout();
982 virtual void Draw(CDC* pDC);
983 using CXTPCalendarThemePart::Draw;
984
985 DECLARE_THEMEPART_MEMBER_BASE(CTOHeader, Header)
986 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewEvent, Event)
987 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewTimeScale, TimeScale)
988
989 DECLARE_THEMEPART_MEMBER_BASE(CTODayViewDay, Day)
990
991 // theme specific control options
992 virtual BOOL IsUseCellAlignedDraggingInTimeArea() const
993 {
994 return FALSE;
995 };
996
997 protected:
998 virtual int CalcMinCellHeight(CDC* pDC, CXTPCalendarDayView* pDayView);
999 };
1000 friend class CTODayView;
1001
1003 //
1004 // *** MonthView theme parts ***
1005 //
1006 // Parts Hierarchy:
1007 // *Theme CXTPCalendarTheme
1008 // *--Header* CTOHeader
1009 // *--Event* CTOEvent
1010 //
1011 // *--MonthView CTOMonthView
1012 // *----Event* CTOMonthViewEvent
1013 // *----Header* CTOHeader
1014 // *----WeekDayHeader CTOMonthViewWeekDayHeader
1015 // *----Day CTOMonthViewDay
1016 // *------Header CTOMonthViewDayHeader
1017 // *------MultiDayEvent CTOMonthViewEvent_MultiDay
1018 // *------SingleDayEvent CTOMonthViewEvent_SingleDay
1019 //
1021
1022 class _XTP_EXT_CLASS CTOMonthViewEvent : virtual public CTOEvent
1023 {
1024 public:
1025 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1026 // virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1027 };
1028 friend class CTOMonthViewEvent;
1029
1030 //------------------------------------------
1031 class _XTP_EXT_CLASS CTOMonthViewEvent_SingleDay : virtual public CTOMonthViewEvent
1032 {
1033 public:
1034 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect, int
1035 // nEventPlaceNumber); virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1036 };
1037 friend class CTOMonthViewEvent_SingleDay;
1038
1039 //------------------------------------------
1040 class _XTP_EXT_CLASS CTOMonthViewEvent_MultiDay : virtual public CTOMonthViewEvent
1041 {
1042 public:
1043 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1044 // virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1045 };
1046 friend class CTOMonthViewEvent_MultiDay;
1047
1048 //==========================================================================
1049 class _XTP_EXT_CLASS CTOMonthViewDayHeader : virtual public CTOHeader
1050 {
1051 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1052 // virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1053 };
1054 friend class CTOMonthViewDayHeader;
1055
1056 //==========================================================================
1057 class _XTP_EXT_CLASS CTOMonthViewDay
1058 : virtual public CTODay // virtual public CXTPCalendarThemePart
1059 {
1060 public:
1061 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1062 // virtual void Draw(CCmdTarget* pObject, CDC* pDC){};
1063
1064 DECLARE_THEMEPART_MEMBER_BASE(CTOMonthViewDayHeader, Header);
1065 DECLARE_THEMEPART_MEMBER_BASE(CTOMonthViewEvent_MultiDay, MultiDayEvent);
1066 DECLARE_THEMEPART_MEMBER_BASE(CTOMonthViewEvent_SingleDay, SingleDayEvent);
1067 };
1068 friend class CTOMonthViewDay;
1069
1070 //==========================================================================
1071 class _XTP_EXT_CLASS CTOMonthViewWeekDayHeader : virtual public CTOHeader
1072 {
1073 public:
1074 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1075 // virtual void Draw(CCmdTarget* pObject, CDC* pDC){};
1076 };
1077 friend class CTOMonthViewWeekDayHeader;
1078
1080 // MonthView theme part object
1081 class _XTP_EXT_CLASS CTOMonthView : virtual public CXTPCalendarThemePart
1082 {
1083 public:
1084 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect, BOOL bCallPostAdjustLayout);
1085 virtual void Draw(CDC* pDC);
1086 using CXTPCalendarThemePart::Draw;
1087
1088 DECLARE_THEMEPART_MEMBER_BASE(CTOHeader, Header);
1089 DECLARE_THEMEPART_MEMBER_BASE(CTOMonthViewEvent, Event);
1090 DECLARE_THEMEPART_MEMBER_BASE(CTOMonthViewWeekDayHeader, WeekDayHeader);
1091 DECLARE_THEMEPART_MEMBER_BASE(CTOMonthViewDay, Day);
1092 };
1093 friend class CTOMonthView;
1094
1096 //
1097 // *** WeekView theme parts ***
1098 //
1099 // Parts Hierarchy:
1100 // *Theme CXTPCalendarTheme
1101 // *--Event* CTOEvent
1102 //
1103 // *--WeekView CTOWeekView
1104 // *----Event* CTOWeekViewEvent
1105 // *----Day CTOWeekViewDay
1106 // *------DayHeader CTOWeekViewDayHeader
1107 // *------MultiDayEvent CTOWeekViewEvent_MultiDay
1108 // *------SingleDayEvent CTOWeekViewEvent_SingleDay
1109 //
1111
1112 // === WeekViewEvent ===
1113 class _XTP_EXT_CLASS CTOWeekViewEvent : virtual public CTOEvent
1114 {
1115 public:
1116 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect, int
1117 // nEventPlaceNumber); virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1118 };
1119 friend class CTOWeekViewEvent;
1120
1121 // --- WeekViewEvent_SingleDay ---
1122 class _XTP_EXT_CLASS CTOWeekViewEvent_SingleDay : virtual public CTOWeekViewEvent
1123 {
1124 public:
1125 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1126 // virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1127 };
1128 friend class CTOWeekViewEvent_SingleDay;
1129
1130 // --- WeekViewEvent_MultiDay ---
1131 class _XTP_EXT_CLASS CTOWeekViewEvent_MultiDay : virtual public CTOWeekViewEvent
1132 {
1133 public:
1134 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1135 // virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1136 };
1137 friend class CTOWeekViewEvent_MultiDay;
1138
1139 // === WeekViewDayHeader ===
1140 class _XTP_EXT_CLASS CTOWeekViewDayHeader : virtual public CTOHeader
1141 {
1142 // virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1143 // virtual void Draw(CCmdTarget* pObject, CDC* pDC);
1144 };
1145 friend class CTOWeekViewDayHeader;
1146
1147 // === WeekViewDay ===
1148 class _XTP_EXT_CLASS CTOWeekViewDay : virtual public CTODay
1149 {
1150 public:
1151 virtual void AdjustLayout(CCmdTarget* pObject, CDC* pDC, const CRect& rcRect);
1152 // virtual void Draw(CCmdTarget* pObject, CDC* pDC){};
1153
1154 DECLARE_THEMEPART_MEMBER_BASE(CTOWeekViewDayHeader, Header);
1155 DECLARE_THEMEPART_MEMBER_BASE(CTOWeekViewEvent_MultiDay, MultiDayEvent);
1156 DECLARE_THEMEPART_MEMBER_BASE(CTOWeekViewEvent_SingleDay, SingleDayEvent);
1157
1158 virtual int GetDayCol(CXTPCalendarWeekViewDay* pWVDay); // returns {0, 1}
1159
1160 virtual void SetDynColors(CXTPCalendarWeekViewDay* pWViewDay){};
1161 };
1162 friend class CTOWeekViewDay;
1163
1164 // ===== WeekView theme part object =====
1165 class _XTP_EXT_CLASS CTOWeekView : virtual public CXTPCalendarThemePart
1166 {
1167 public:
1168 virtual void AdjustLayout(CDC* pDC, const CRect& rcRect, BOOL bCallPostAdjustLayout);
1169 virtual void Draw(CDC* pDC);
1170 using CXTPCalendarThemePart::Draw;
1171
1172 // DECLARE_THEMEPART_MEMBER_BASE(CTOHeader, Header);
1173 DECLARE_THEMEPART_MEMBER_BASE(CTOWeekViewEvent, Event);
1174 DECLARE_THEMEPART_MEMBER_BASE(CTOWeekViewDay, Day);
1175 };
1176 friend class CTOWeekView;
1177
1178 //=======================================================================
1179
1181 class _XTP_EXT_CLASS CTOColorsSet : virtual public CXTPCalendarThemePart
1182 {
1183 public:
1184 CTOColorsSet();
1185 virtual void RefreshMetrics(BOOL bRefreshChildren = TRUE);
1186
1187 virtual COLORREF GetColor(int nColorID, COLORREF clrBase = (COLORREF)-1);
1188 virtual int GetScale(int nColorID); //, BOOL& rbHSL);
1189 virtual CString GetName(int nColorID);
1190
1191 virtual void SetColor(int nColorID, LPCTSTR pcszName, int nScale);
1192 virtual void SetCLR_DarkenOffset(int nCLR_DarkenOffset);
1193
1194 // virtual void SetColorEx(int eCLR, COLORREF clrColor);
1195 // virtual void CrearColorsEx();
1196
1197 // virtual void SetColorHSL(int eCLR, int nLshift);
1198 protected:
1199 COLORREF m_clrBase;
1200 int m_nCLR_DarkenOffset;
1201
1202 struct _XTP_EXT_CLASS SColorInfo
1203 {
1204 int nID;
1205 TCHAR szName[128];
1206
1207 int nScale;
1208 // COLORREF rgbColor;
1209 };
1210
1211 // typedef CMap<int, int, int, int> CScalesMap;
1212 typedef CMap<int, int, SColorInfo, SColorInfo&> CColorInfoMap;
1213
1214 CColorInfoMap m_mapColors;
1215
1216 // CScalesMap m_mapScale;
1217
1218 // CScalesMap m_mapHSLShift;
1219 };
1220
1222 //
1223 // *** Common Theme members ***
1224 //
1226
1227 // This base settings which used to initialize other settings by default.
1228 CXTPPaintManagerColor m_clrBaseColor;
1229 CXTPCalendarThemeFontValue m_fntBaseFont;
1230 CXTPCalendarThemeFontValue m_fntBaseFontBold;
1231
1232 DECLARE_THEMEPART_MEMBER_BASE(CTOColorsSet, ColorsSet)
1233 virtual COLORREF GetColor(int eCLR, COLORREF clrBase = (COLORREF)-1)
1234 {
1235 _ASSERTE(FALSE);
1236 return 0;
1237 };
1238 virtual COLORREF GetColor2(LPCTSTR pcszColorName, COLORREF clrDefault)
1239 {
1240 _ASSERTE(FALSE);
1241 return 0;
1242 };
1243
1244 virtual CXTPResourceImage* GetBitmap(LPCTSTR pcszStdBmpName);
1245
1246 DECLARE_THEMEPART_MEMBER_BASE(CTOHeader, Header)
1247 DECLARE_THEMEPART_MEMBER_BASE(CTOEvent, Event)
1248 //==========================================================================
1249 DECLARE_THEMEPART_MEMBER_BASE(CTODayView, DayView)
1250 DECLARE_THEMEPART_MEMBER_BASE(CTOWeekView, WeekView)
1251 DECLARE_THEMEPART_MEMBER_BASE(CTOMonthView, MonthView)
1252
1253 virtual void RefreshMetrics();
1254 virtual void DoPropExchange(CXTPPropExchange* pPX);
1255
1256 virtual CXTPImageManager* GetCustomIconsList() const;
1257 virtual CXTPResourceImageList* GetImageList() const;
1258
1259 virtual DWORD GetBeforeDrawFlags() const;
1260 virtual void SetBeforeDrawFlags(DWORD dwBeforeDrawFlags);
1261 virtual BOOL IsBeforeDraw(int eFlag) const;
1262
1263 virtual DWORD GetAskItemTextFlags() const;
1264 virtual void SetAskItemTextFlags(DWORD dwFlags);
1265
1266 virtual XTPCalendarTheme GetPaintTheme() const;
1267 virtual void SetPaintTheme(XTPCalendarTheme ePaintTheme);
1268
1269 virtual void SetTipWindowRgn(CWnd* pTip);
1270
1271public:
1272 static BOOL AFX_CDECL IsXPTheme();
1273
1281 static CSize AFX_CDECL DrawLine_CenterLR(CDC* pDC, LPCTSTR pcszText, CRect& rcRect,
1282 UINT nFormat);
1283
1290 static CSize AFX_CDECL DrawLine2_CenterLR(CDC* pDC, LPCTSTR pcszText1, LPCTSTR pcszText2,
1291 CThemeFontColorSet* pFontColor1,
1292 CThemeFontColorSet* pFontColor2, CRect& rcRect,
1293 UINT nShortAlign = DT_VCENTER | DT_LEFT,
1294 UINT nFullAlign = DT_VCENTER | DT_CENTER);
1295
1297 static void AFX_CDECL DrawRoundRect(CDC* pDC, const CRect& rcRect, COLORREF clrBorder,
1298 BOOL bBoldBorder, CXTPPaintManagerColorGradient& grclrBk);
1299
1300 static void AFX_CDECL DrawRoundRect(CDC* pDC, const CRect& rcRect, COLORREF clrBorder,
1301 BOOL bBoldBorder, CBrush* pBrushBk);
1302
1307 static void AFX_CDECL DrawRectPartly(CDC* pDC, const CRect& rcRect, COLORREF clrBorder,
1308 int nBorderWidth, CRect isBorders);
1309
1310 static void AFX_CDECL DrawRectPartly(CDC* pDC, const CRect& rcRect, COLORREF clrBorder,
1311 BOOL bBoldBorder, CXTPPaintManagerColorGradient& grclrBk,
1312 CRect isBorders);
1313 // const CRect& isBorders);
1314
1315 static const int cnCornerSize;
1316
1317public:
1318 static XTP_VIEW_LAYOUT& AFX_CDECL GetViewLayout(CXTPCalendarView* pView);
1319 static XTP_VIEW_DAY_LAYOUT& AFX_CDECL GetViewDayLayout(CXTPCalendarViewDay* pViewDay);
1320
1321 static XTP_DAY_VIEW_LAYOUT& AFX_CDECL GetDayViewLayout(CXTPCalendarDayView* pDayView);
1322 static XTP_TIMESCALE_LAYOUT& AFX_CDECL
1323 GetTimeScaleLayout(CXTPCalendarDayViewTimeScale* pTimeScale);
1324
1325 static XTP_VIEW_GROUP_LAYOUT& AFX_CDECL GetViewGroupLayout(CXTPCalendarViewGroup* pViewGroup);
1326 static XTP_DAY_VIEW_GROUP_LAYOUT& AFX_CDECL
1327 GetDayViewGroupLayout(CXTPCalendarDayViewGroup* pDayViewGroup);
1328
1329 static XTP_WEEK_VIEW_LAYOUT& AFX_CDECL GetWeekViewLayout(CXTPCalendarWeekView* pWeekView);
1330
1340 static void AFX_CDECL CopySettings(CXTPPaintManagerColor& refDest,
1341 const CXTPPaintManagerColor& refSrc);
1342
1352 static void AFX_CDECL CopySettings(CXTPPaintManagerColorGradient& refDest,
1353 const CXTPPaintManagerColorGradient& refSrc);
1354
1355 static CFont* AFX_CDECL GetMaxHeightFont(CArray<CFont*, CFont*>& arFonts, CDC* pDC = NULL,
1356 int* pnMaxHeight = NULL);
1357
1358public:
1359 virtual CXTPCalendarViewEventSubjectEditor* StartEditSubject(CXTPCalendarViewEvent* pViewEvent)
1360 {
1361 return NULL;
1362 };
1363 virtual void RemoveBoldAttrFromStd(CXTPCalendarThemeFontValue& rFont);
1364
1365 // for internal usage
1366 enum XTPEnumThemeStdImages
1367 {
1368 xtpIMG_DayViewHeader = -100,
1369 xtpIMG_DayViewHeaderTooday = -101,
1370 xtpIMG_DayViewGroupHeader = -102,
1371
1372 xtpIMG_MonthViewDayHeader = -120,
1373 xtpIMG_MonthViewDayHeaderToday = -121,
1374
1375 // xtpIMG_MonthViewWeekDayHeader = 0, //-122, // the base color is enough for default
1376 // WeekDay header
1377 xtpIMG_MonthViewWeekHeader = -123,
1378
1379 xtpIMG_WeekViewDayHeader = -130,
1380
1381 xtpIMG_ExpandDayButtons = -140,
1382 xtpIMG_PrevNextEventButtons = -150,
1383 };
1384
1385protected:
1386 virtual void RefreshMetrics(BOOL bRefreshChildren);
1387 virtual void _DoPropExchange(CXTPPropExchange* pPX, BOOL bExchangeChildren);
1388
1389 static void AFX_CDECL _DrawRoundRect(CDC* pDC, const CRect& rcRect, COLORREF clrBorder,
1390 BOOL bBoldBorder, CXTPPaintManagerColorGradient* pgrclrBk,
1391 CBrush* pBrushBk);
1392
1393 virtual BOOL _LoadStdBitmap(int nBmpID, LPCTSTR pcszStdBmpName);
1394
1395public:
1396 static void AFX_CDECL DrawRect(CDC* pDC, const CRect& rcRect, COLORREF clrBorder,
1397 BOOL bBoldBorder, CXTPPaintManagerColorGradient& grclrBk);
1398
1399 static void AFX_CDECL DrawRect(CDC* pDC, const CRect& rcRect, COLORREF clrBorder,
1400 BOOL bBoldBorder, CBrush* pBrushBk);
1401
1402 virtual CRect DrawExpandDayButton(CDC* pDC, const CRect& rc, BOOL bUp, BOOL bHot);
1403
1404 virtual BOOL ExpandDayButton_HitTest(const CPoint& pt, const CRect& rc, BOOL bUp);
1405 virtual CSize GetExpandDayButtonSize();
1406
1407protected:
1408 CXTPImageManager* m_pCustomIcons;
1409 CXTPResourceImageList* m_pImageList;
1410
1411 CXTPResourceImages* m_pImagesStd;
1412
1413 DWORD m_dwBeforeDrawFlags;
1414 DWORD m_dwAskItemTextFlags;
1415
1416 XTPCalendarTheme m_nPaintTheme;
1417
1418protected:
1419# ifdef _XTP_ACTIVEX
1421 DECLARE_DISPATCH_MAP()
1422
1423 virtual void OleRefreshMetrics();
1424
1425 virtual COLORREF OleGetBaseColor();
1426 virtual void OleSetBaseColor(COLORREF clrColor);
1427
1428 LPFONTDISP OleGetBaseFont();
1429 void OleSetBaseFont(LPFONTDISP pFontDisp);
1430
1431 LPFONTDISP OleGetBaseFontBold();
1432 void OleSetBaseFontBold(LPFONTDISP pFontDisp);
1433
1434 LPDISPATCH OleGetCustomIcons();
1435 void OleSetCustomIcons(LPDISPATCH newValue);
1436 void OleSetCustomIconsImageList(LPDISPATCH pImageList);
1437
1438 LPDISPATCH OleGetImageList();
1439
1440 void OleDoPropExchange(LPDISPATCH pDispPXctrl);
1441
1442 friend class CCalendarControlCtrl;
1443 CXTPCalendarFlagsSet_imp* AxGetAskItemTextFlags();
1444 CXTPCalendarFlagsSet_imp* AxGetBeforeDrawThemeObjectFlags();
1446# endif
1447};
1448
1450
1451AFX_INLINE CMap<UINT, UINT, UINT, UINT&>& CXTPCalendarTheme::GetEventSlotMap()
1452{
1453 return m_mapEventIdEventSlotId;
1454}
1455
1456AFX_INLINE BOOL CXTPCalendarThemePart::IsCreated()
1457{
1458 return !!m_pTheme;
1459}
1460
1461AFX_INLINE CXTPCalendarControl* CXTPCalendarThemePart::GetCalendarControl() const
1462{
1463 return XTP_SAFE_GET1(GetTheme(), GetCalendarControl(), NULL);
1464}
1465
1466AFX_INLINE CXTPCalendarControl* CXTPCalendarTheme::GetCalendarControl() const
1467{
1468 return m_pCalendar;
1469}
1470
1471AFX_INLINE void CXTPCalendarTheme::SetCalendarControl(CXTPCalendarControl* pCalendar)
1472{
1473 if (!pCalendar && m_pCalendar)
1474 OnDetachCalendar();
1475
1476 m_pCalendar = pCalendar;
1477}
1478
1479AFX_INLINE void CXTPCalendarTheme::RefreshMetrics()
1480{
1481 RefreshMetrics(TRUE);
1482}
1483
1484AFX_INLINE void CXTPCalendarTheme::CTOColorsSet::SetCLR_DarkenOffset(int nCLR_DarkenOffset)
1485{
1486 m_nCLR_DarkenOffset = nCLR_DarkenOffset;
1487}
1488
1489AFX_INLINE DWORD CXTPCalendarTheme::GetBeforeDrawFlags() const
1490{
1491 return m_dwBeforeDrawFlags;
1492}
1493
1494AFX_INLINE BOOL CXTPCalendarTheme::IsBeforeDraw(int eFlag) const
1495{
1496 return 0 != (m_dwBeforeDrawFlags & eFlag);
1497}
1498
1499AFX_INLINE void CXTPCalendarTheme::SetBeforeDrawFlags(DWORD dwBeforeDrawFlags)
1500{
1501 m_dwBeforeDrawFlags = dwBeforeDrawFlags;
1502}
1503
1504AFX_INLINE DWORD CXTPCalendarTheme::GetAskItemTextFlags() const
1505{
1506 return m_dwAskItemTextFlags;
1507}
1508
1509AFX_INLINE void CXTPCalendarTheme::SetAskItemTextFlags(DWORD dwFlags)
1510{
1511 m_dwAskItemTextFlags = dwFlags;
1512}
1513
1514AFX_INLINE BOOL AFX_CDECL CXTPCalendarTheme::IsXPTheme()
1515{
1516 return XTPColorManager()->GetCurrentSystemTheme() != xtpSystemThemeUnknown;
1517}
1518
1519AFX_INLINE CXTPImageManager* CXTPCalendarTheme::GetCustomIconsList() const
1520{
1521 return m_pCustomIcons;
1522}
1523
1524AFX_INLINE CXTPResourceImageList* CXTPCalendarTheme::GetImageList() const
1525{
1526 return m_pImageList;
1527}
1528
1529AFX_INLINE XTPCalendarTheme CXTPCalendarTheme::GetPaintTheme() const
1530{
1531 return m_nPaintTheme;
1532}
1533
1534AFX_INLINE void CXTPCalendarTheme::SetPaintTheme(XTPCalendarTheme ePaintTheme)
1535{
1536 m_nPaintTheme = ePaintTheme;
1537 RefreshMetrics();
1538}
1539
1540//*********************************
1541# if (_MSC_VER > 1100)
1542# pragma warning(pop)
1543# endif
1544
1545# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1546#endif // !defined(_XTP_CALENDAR_THEME_H__)
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPColorManager
_XTP_EXT_CLASS CXTPColorManager *AFX_CDECL XTPColorManager()
Call this function to access CXTPColorManager members.
xtpSystemThemeUnknown
@ xtpSystemThemeUnknown
No known theme in use.
Definition XTPColorManager.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:726
CXTPCalendarDayViewEvent
This class represents an event view portion of the CalendarDayViewDay.
Definition XTPCalendarDayViewEvent.h:56
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
Definition XTPCalendarDayView.h:62
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
Definition XTPCalendarDayViewTimeScale.h:75
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
Definition XTPCalendarMonthView.h:74
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects.
Definition XTPCalendarViewPart.h:1123
CXTPCalendarThemeCustomizableXValueT::CopySettings
void CopySettings(const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > &refSrc)
This member function is used to set the standard value using the current value from the specified obj...
Definition XTPCalendarViewPart.h:442
CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects.
Definition XTPCalendarViewPart.h:868
CXTPCalendarThemeFontValue::CopySettings
void CopySettings(const CXTPCalendarThemeFontValue &refSrc)
This member function is use to set the standard value using the current value from the specified obje...
CXTPCalendarThemeFontValue::SetStandardValue
virtual void SetStandardValue(LOGFONT *pLogFont)
This member function is used to set the value for the standard font.
CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects.
Definition XTPCalendarViewPart.h:1070
CXTPCalendarThemeRectValue
Helper class provides functionality to manage customized CRect value objects.
Definition XTPCalendarViewPart.h:1176
CXTPCalendarTimeLineViewTimeScale
This class implements a specific view portion of the Calendar control called Timeline view scale.
Definition XTPCalendarTimeLineViewTimeScale.h:70
CXTPCalendarTypedPtrAutoDeleteArray
This class represents a simple array collection of objects pointers.
Definition XTPCalendarPtrCollectionT.h:472
CXTPCalendarTypedPtrAutoDeleteMap
This class represents a simple map of typed keys to typed objects pointers.
Definition XTPCalendarPtrCollectionT.h:544
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEventSubjectEditor
This class is used to edit an event subject.
Definition XTPCalendarViewEvent.h:1157
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarViewPartBrushValue
Helper class provides functionality to manage brush value objects.
Definition XTPCalendarViewPart.h:849
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
Definition XTPCalendarWeekViewDay.h:131
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
Definition XTPCalendarWeekViewEvent.h:58
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
Definition XTPCalendarWeekView.h:54
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPColorManager::GetCurrentSystemTheme
XTPCurrentSystemTheme GetCurrentSystemTheme() const
Call this member function to determine the current Windows XP theme in use.
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerColor::SetStandardValue
void SetStandardValue(COLORREF clr)
This member function will sets the default color for the CXTPPaintManagerColor class.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT noti...
Definition XTPCalendarNotifications.h:672
XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_THEMEOBJECT noti...
Definition XTPCalendarNotifications.h:693
XTP_LC_TIMEFORMAT
Time format structure.
Definition XTPCalendarDayViewTimeScale.h:40
XTP_WEEK_VIEW_LAYOUT
This struct store a Week View layout.
Definition XTPCalendarDefines.h:1238


Toolkit Pro: XTPChartPyramidSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
XTPChartPyramidSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESLABEL_H__)
24# define __XTPCHARTPYRAMIDSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pyramid/Base/XTPChartPyramidSeriesLabelBase.h"
32# include "Chart/Styles/Pyramid/2D/XTPChart2dPyramidSeriesLabel.h"
33
35typedef CXTPChartPyramidSeriesLabel CXTPChart2dPyramidSeriesLabel;
36
38typedef CXTPChartPyramidSeriesLabelView CXTPChart2dPyramidSeriesLabelView;
40#endif //#if !defined(__XTPCHARTPYRAMIDSERIESLABEL_H__)
XTPChart2dPyramidSeriesLabel.h
CXTPChart2dPyramidSeriesLabelView
CXTPChartPyramidSeriesLabelView CXTPChart2dPyramidSeriesLabelView
CXTPChart2dPyramidSeriesLabelView alias is necessary for naming consistency.
Definition XTPChartPyramidSeriesLabel.h:38
CXTPChart2dPyramidSeriesLabel
CXTPChartPyramidSeriesLabel CXTPChart2dPyramidSeriesLabel
CXTPChart2dPyramidSeriesLabel alias is necessary for naming consistency.
Definition XTPChartPyramidSeriesLabel.h:35
XTPChartPyramidSeriesLabelBase.h
CXTPChartPyramidSeriesLabel
CXTPChartPyramidSeriesLabel is a kind of CXTPChartSeriesLabel.
Definition XTPChart2dPyramidSeriesLabel.h:44
CXTPChartPyramidSeriesLabelView
Defines 2D series label view.
Definition XTPChart2dPyramidSeriesLabel.h:78


Toolkit Pro: XTPCalendarEventRecurrenceDlg.h Source File

  • Source
  • Calendar
XTPCalendarEventRecurrenceDlg.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_EVENT_RECURRENCE_DLG_H__)
23# define _XTP_CALENDAR_EVENT_RECURRENCE_DLG_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
39static const int XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE = 103;
40
47class _XTP_EXT_CLASS CXTPCalendarEventRecurrenceDlg : public CDialog
48{
50 DECLARE_DYNAMIC(CXTPCalendarEventRecurrenceDlg)
52public:
53 enum
54 {
55 IDD = XTP_IDD_CALENDAR_RECURRENCE_PROPERTIES
56 };
57
68 CXTPCalendarEventRecurrenceDlg(CXTPCalendarEvent* pMasterEvent, CWnd* pParent = NULL,
69 UINT nIDTemplate = CXTPCalendarEventRecurrenceDlg::IDD);
70
75 virtual ~CXTPCalendarEventRecurrenceDlg();
76
77 BOOL m_bDisableRemove;
78 int nWorkWeekMask;
81protected:
89 virtual void InitStartEndCB();
90
98 virtual void InitDurationCB();
99
109 virtual void InitDayOfWeekCBs(CComboBox& wndCB);
110
120 virtual void InitMonthCBs(CComboBox& wndCB);
121
131 virtual void InitWhichDayCBs(CComboBox& wndCB);
132
142 virtual void MsgBox_WrongValue(CWnd* pWnd);
143
155 virtual void MsgBox_WrongValueRange(UINT nCtrlID, int nMin, int nMax);
156
157 virtual BOOL OnInitDialog();
158 virtual void DoDataExchange(CDataExchange* pDX);
159 virtual void OnOK();
160
161 afx_msg void OnStartComboChanged();
162 afx_msg void OnEndComboChanged();
163 afx_msg void OnDurationComboChanged();
164
165 afx_msg void OnStartComboEdited();
166 afx_msg void OnEndComboEdited();
167 afx_msg void OnDurationComboEdited();
168
169 afx_msg void OnBnClickedButtonRemoveRecurrence();
170
171 // Update visible state of controls, according to the selected mode:
172 // day/week/month/year. wparam - ID of the selected radio
173 afx_msg void OnBnClickedRadioDailyYearly(UINT wparam);
174
175 afx_msg void OnTimer(UINT_PTR nIDEvent);
176
177 virtual void _MoveControlsBy_Y();
178 virtual int _AddString(CComboBox& wndCB, UINT nStrResID, DWORD_PTR dwItemData);
179 virtual int _AddLocaleString(CComboBox& wndCB, LCTYPE lcidStr, DWORD_PTR dwItemData);
180
181 virtual void OnStartChanged();
182 virtual void _OnStartChanged();
183
184 virtual void OnEndChanged();
185 virtual void _OnEndChanged();
186
187 virtual void OnDurationChanged();
188 virtual void _OnDurationChanged();
189
190 // Gets Time in Minutes, shown in ComboBox
191 virtual int GetChangedComboTimeInMin(CComboBox& wndCb);
192 virtual int GetDurationComboInMin();
193
194 // Shows or hides control on the dialog with specified id
195 virtual void ShowWindow(int nID, BOOL bShow = TRUE);
196 virtual void MoveWindow_Y(int nID, int nYOffset);
197 virtual CRect GetCtrlRect(int nID);
199 DECLARE_MESSAGE_MAP()
202protected:
203 CXTPCalendarEventPtr m_ptrMasterEvent;
204 CXTPCalendarRecurrencePatternPtr m_ptrPattern;
206 COleDateTime m_dtStart;
207 COleDateTime m_dtEnd;
208 COleDateTime m_dtStartDate;
210 COleDateTime m_dtEndDate;
213 CComboBox m_wndCbStart;
214 CComboBox m_wndCbEnd;
215 CComboBox m_wndCbDuration;
217 int m_nOccurNum;
221 int m_nDayInterval;
225 int m_nWeeklyInterval;
228 BOOL m_bMonday;
230 BOOL m_bTuesday;
232 BOOL m_bWednesday;
234 BOOL m_bThursday;
236 BOOL m_bFriday;
238 BOOL m_bSaturday;
240 BOOL m_bSunday;
244 int m_MonthDate;
246 int m_nMonthInterval;
248 int m_nMonthInterval2;
251 CComboBox m_wndCbMonthDay;
252 CComboBox m_wndCbMonthWhich;
255 int m_nDayOfMonth;
258 CComboBox m_wndYearMonth;
259 CComboBox m_wndComboYearMonth2;
261 CComboBox m_wndCbYearWhich;
262 CComboBox m_wndCbYearDay;
263};
264
266AFX_INLINE void CXTPCalendarEventRecurrenceDlg::ShowWindow(int nID, BOOL bShow)
267{
268 if (GetDlgItem(nID))
269 GetDlgItem(nID)->ShowWindow(bShow ? SW_SHOW : SW_HIDE);
270}
271
272# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
273#endif // !defined(_XTP_CALENDAR_EVENT_RECURRENCE_DLG_H__)
XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE
static const int XTP_CALENDAR_DLGRESULT_REMOVE_RECURRENCE
This constant defines a value which returned from CXTPCalendarEventRecurrenceDlg::DoModal() when the ...
Definition XTPCalendarEventRecurrenceDlg.h:39
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEventRecurrenceDlg
This class is used for manipulations with recurrence state of the events.
Definition XTPCalendarEventRecurrenceDlg.h:48
CXTPCalendarEventRecurrenceDlg::nWorkWeekMask
int nWorkWeekMask
This structure member represents week working days using XTPCalendarWeekDay enumeration.
Definition XTPCalendarEventRecurrenceDlg.h:78
CXTPCalendarEventRecurrenceDlg::CXTPCalendarEventRecurrenceDlg
CXTPCalendarEventRecurrenceDlg(CXTPCalendarEvent *pMasterEvent, CWnd *pParent=NULL, UINT nIDTemplate=CXTPCalendarEventRecurrenceDlg::IDD)
Dialog class constructor.
CXTPCalendarEventRecurrenceDlg::MsgBox_WrongValueRange
virtual void MsgBox_WrongValueRange(UINT nCtrlID, int nMin, int nMax)
Shows error message if the user's input is incorrect.
CXTPCalendarEventRecurrenceDlg::MsgBox_WrongValue
virtual void MsgBox_WrongValue(CWnd *pWnd)
Shows error message if the user's input is incorrect.
CXTPCalendarEventRecurrenceDlg::InitWhichDayCBs
virtual void InitWhichDayCBs(CComboBox &wndCB)
Initialize data for which day (First, Second, ...).
CXTPCalendarEventRecurrenceDlg::InitDayOfWeekCBs
virtual void InitDayOfWeekCBs(CComboBox &wndCB)
Initialize data for days of week names.
CXTPCalendarEventRecurrenceDlg::~CXTPCalendarEventRecurrenceDlg
virtual ~CXTPCalendarEventRecurrenceDlg()
Default collection destructor.
CXTPCalendarEventRecurrenceDlg::InitStartEndCB
virtual void InitStartEndCB()
Initialize data for Start and End combobox controls.
CXTPCalendarEventRecurrenceDlg::InitDurationCB
virtual void InitDurationCB()
Initialize data for Duration combobox control.
CXTPCalendarEventRecurrenceDlg::m_bDisableRemove
BOOL m_bDisableRemove
Set TRUE to disable button remove recurrence.
Definition XTPCalendarEventRecurrenceDlg.h:77
CXTPCalendarEventRecurrenceDlg::InitMonthCBs
virtual void InitMonthCBs(CComboBox &wndCB)
Initialize data for months names.


Toolkit Pro: XTPRibbonCustomizeQuickAccessPage.h Source File

  • Source
  • Ribbon
  • Customize
XTPRibbonCustomizeQuickAccessPage.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONCUSTOMIZEQUICKACCESSPAGE_H__)
24# define __XTPRIBBONCUSTOMIZEQUICKACCESSPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCustomizeSheet;
34class CXTPCommandBars;
35class CXTPRibbonBar;
36struct XTP_COMMANDBARS_CATEGORYINFO;
37
43class _XTP_EXT_CLASS CXTPRibbonCustomizeQuickAccessPage : public CXTPPropertyPage
44{
45 // Construction
46public:
54 CXTPRibbonCustomizeQuickAccessPage(CXTPCustomizeSheet* pSheet, UINT nIDTemplate = (UINT)-1);
60 CXTPRibbonCustomizeQuickAccessPage(CXTPCommandBars* pCommandBars);
61
67 ~CXTPRibbonCustomizeQuickAccessPage();
68
69public:
76 CXTPRibbonBar* GetRibbonBar();
77
78public:
87 BOOL AddCategories(UINT nIDResource, BOOL bListSubItems = FALSE);
88
96 BOOL AddCategories(CXTPControls* pControls);
97
107 BOOL AddCategory(LPCTSTR strCategory, CMenu* pMenu, BOOL bListSubItems = FALSE);
108
117 CXTPControls* InsertCategory(LPCTSTR strCategory, int nIndex = -1);
118
126 CXTPControls* GetControls(LPCTSTR strCategory);
127
133 virtual void UpdatePage(void);
134
135protected:
140 void RefreshQuickAccessList();
141
142 // Implementation
143protected:
145 DECLARE_MESSAGE_MAP()
147 //{{AFX_VIRTUAL(CXTPRibbonCustomizeQuickAccessPage)
148protected:
149 virtual void DoDataExchange(CDataExchange* pDX);
150 //}}AFX_VIRTUAL
151
152 //{{AFX_MSG(CXTPRibbonCustomizeQuickAccessPage)
153 afx_msg void OnCheckShowQuickAccessBelow();
154 virtual BOOL OnInitDialog();
155 afx_msg void OnCategoriesSelectionChanged();
156 afx_msg void OnDblclkListQuickAccess();
157 afx_msg void OnDblclkListCommands();
158 afx_msg void OnButtonAdd();
159 afx_msg void OnButtonRemove();
160 afx_msg void OnButtonReset();
161 afx_msg void OnCommandsSelectionChanged();
162 afx_msg void OnQuickAccessSelectionChanged();
163 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
164 //}}AFX_MSG
165
166private:
167 XTP_COMMANDBARS_CATEGORYINFO* FindCategory(LPCTSTR strCategory) const;
168 XTP_COMMANDBARS_CATEGORYINFO* GetCategoryInfo(int nIndex);
169
170public:
171# ifdef _XTP_INCLUDE_CONTROLS
172 COLORREF m_clrText;
173 CXTPButton m_btnAdd;
174 CXTPButton m_btnRemove;
175 CXTPButton m_btnReset;
176 CXTPComboBox m_lstCategories;
177 CXTPButton m_btnShowQuickAccessBelow;
178# else
179 CButton m_btnAdd;
180 CButton m_btnRemove;
181 CButton m_btnReset;
182 CComboBox m_lstCategories;
183 CButton m_btnShowQuickAccessBelow;
184# endif
185 CXTPCustomizeCommandsListBox m_lstQuickAccess;
186 CXTPCustomizeCommandsListBox m_lstCommands;
187 BOOL m_bShowQuickAccessBelow;
189protected:
190 CXTPCustomizeSheet* m_pSheet;
191 CXTPCommandBars* m_pCommandBars;
192 CXTPCommandBarsCategoryArray m_arrCategories;
194# ifdef _XTP_INCLUDE_MARKUP
195 CXTPMarkupStatic& m_wndTitleIcon;
196 CXTPMarkupStatic& m_wndTitle;
197# else
198 CStatic& m_wndTitleIcon;
199 CStatic& m_wndTitle;
200# endif
201};
202
203# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
205#endif // !defined(__XTPRIBBONCUSTOMIZEQUICKACCESSPAGE_H__)
CXTPCommandBarsCategoryArray
CArray< XTP_COMMANDBARS_CATEGORYINFO *, XTP_COMMANDBARS_CATEGORYINFO * > CXTPCommandBarsCategoryArray
This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_C...
Definition XTPCustomizePageCommands.h:78
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeCommandsListBox
List of the commands.
Definition XTPCustomizePageCommands.h:92
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonCustomizeQuickAccessPage
CXTPRibbonCustomizeQuickAccessPage is a CPropertyPage derived class.
Definition XTPRibbonCustomizeQuickAccessPage.h:44
CXTPRibbonCustomizeQuickAccessPage::RefreshQuickAccessList
void RefreshQuickAccessList()
Refills the list of Quick Access controls.
CXTPRibbonCustomizeQuickAccessPage::CXTPRibbonCustomizeQuickAccessPage
CXTPRibbonCustomizeQuickAccessPage(CXTPCustomizeSheet *pSheet, UINT nIDTemplate=(UINT) -1)
Constructs a CXTPRibbonCustomizeQuickAccessPage object.
CXTPRibbonCustomizeQuickAccessPage::m_lstCommands
CXTPCustomizeCommandsListBox m_lstCommands
Commands list.
Definition XTPRibbonCustomizeQuickAccessPage.h:186
CXTPRibbonCustomizeQuickAccessPage::GetControls
CXTPControls * GetControls(LPCTSTR strCategory)
Retrieves the control list for a specified category.
CXTPRibbonCustomizeQuickAccessPage::AddCategories
BOOL AddCategories(CXTPControls *pControls)
Adds a categories branch from Controls.
CXTPRibbonCustomizeQuickAccessPage::m_pSheet
CXTPCustomizeSheet * m_pSheet
Parent Sheet window.
Definition XTPRibbonCustomizeQuickAccessPage.h:190
CXTPRibbonCustomizeQuickAccessPage::AddCategories
BOOL AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE)
Adds a categories branch from a menu resource.
CXTPRibbonCustomizeQuickAccessPage::~CXTPRibbonCustomizeQuickAccessPage
~CXTPRibbonCustomizeQuickAccessPage()
Destroys a CXTPRibbonCustomizeQuickAccessPage object, handles cleanup and deallocation.
CXTPRibbonCustomizeQuickAccessPage::UpdatePage
virtual void UpdatePage(void)
Forces a page to update its internal data as this data is supposed to be changed from outside the pag...
CXTPRibbonCustomizeQuickAccessPage::m_bShowQuickAccessBelow
BOOL m_bShowQuickAccessBelow
TRUE to show Quick Access below ribbon.
Definition XTPRibbonCustomizeQuickAccessPage.h:187
CXTPRibbonCustomizeQuickAccessPage::InsertCategory
CXTPControls * InsertCategory(LPCTSTR strCategory, int nIndex=-1)
Adds a new empty category at a specified index.
CXTPRibbonCustomizeQuickAccessPage::m_arrCategories
CXTPCommandBarsCategoryArray m_arrCategories
Array of categories.
Definition XTPRibbonCustomizeQuickAccessPage.h:192
CXTPRibbonCustomizeQuickAccessPage::m_pCommandBars
CXTPCommandBars * m_pCommandBars
Parent CommandBars object.
Definition XTPRibbonCustomizeQuickAccessPage.h:191
CXTPRibbonCustomizeQuickAccessPage::GetRibbonBar
CXTPRibbonBar * GetRibbonBar()
Gets the ribbon bar to customize.
CXTPRibbonCustomizeQuickAccessPage::AddCategory
BOOL AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
CXTPRibbonCustomizeQuickAccessPage::CXTPRibbonCustomizeQuickAccessPage
CXTPRibbonCustomizeQuickAccessPage(CXTPCommandBars *pCommandBars)
Constructs a CXTPRibbonCustomizeQuickAccessPage object.
CXTPRibbonCustomizeQuickAccessPage::m_lstQuickAccess
CXTPCustomizeCommandsListBox m_lstQuickAccess
Quick Access list.
Definition XTPRibbonCustomizeQuickAccessPage.h:185
CXTPRibbonCustomizeQuickAccessPage::m_lstCategories
CComboBox m_lstCategories
Categories list.
Definition XTPRibbonCustomizeQuickAccessPage.h:182
XTP_COMMANDBARS_CATEGORYINFO
This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option p...
Definition XTPCustomizePageCommands.h:46


CXTPPopupThemeOffice2003 Member List

This is the complete list of members for CXTPPopupThemeOffice2003, including all inherited members.

CXTPPopupPaintManager() | CXTPPopupPaintManager |
CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 |
CXTPPopupThemeOffice2003() | CXTPPopupThemeOffice2003 |
CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP |
DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient) | CXTPPopupThemeOffice2003 | virtual
DrawButton(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
DrawItem(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager |
DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
m_clrBackground | CXTPPopupPaintManager |
m_clrButtonPressed | CXTPPopupPaintManager |
m_clrButtonPressedBorder | CXTPPopupPaintManager |
m_clrButtonSelected | CXTPPopupPaintManager |
m_clrButtonSelectedBorder | CXTPPopupPaintManager |
m_clrFrame | CXTPPopupPaintManager |
m_clrGripper | CXTPPopupThemeOffice2003 |
m_clrText | CXTPPopupPaintManager |
m_xtpFontText | CXTPPopupPaintManager |
RefreshMetrics() | CXTPPopupThemeOffice2003 | virtual
SetFont(HFONT hFont) | CXTPPopupPaintManager |
~CXTPPopupPaintManager() | CXTPPopupPaintManager | virtual
~CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 | virtual
~CXTPPopupThemeOffice2003() | CXTPPopupThemeOffice2003 | virtual
~CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP | virtual


CXTPRibbonThemeVisualStudio2017 Member List

This is the complete list of members for CXTPRibbonThemeVisualStudio2017, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPRibbonOffice2013Theme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeVisualStudio2017(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeVisualStudio2017 |
DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | protectedvirtual
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonOffice2013Theme | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonMarkupTheme | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackImageName() | CXTPRibbonOffice2013Theme | protectedvirtual
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonOffice2013Theme | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonOffice2013Theme | protectedvirtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrHeader | CXTPRibbonOffice2013Theme | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFaceState | CXTPRibbonOffice2013Theme | protected
m_clrRibbonTabDelimeter | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageLeft | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageRight | CXTPRibbonOffice2013Theme | protected
m_clrTabBackInactiveState | CXTPRibbonOffice2013Theme | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonOffice2013Theme | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetBackImage(int nImage) | CXTPRibbonOffice2013Theme | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonOffice2013Theme() | CXTPRibbonOffice2013Theme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeVisualStudio2017() | CXTPRibbonThemeVisualStudio2017 | virtual


CXTPTreeTheme Member List

This is the complete list of members for CXTPTreeTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeTheme() | CXTPTreeTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: XTPListBoxThemeDefault.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeDefault.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEDEFAULT_H__)
24# define __XTPLISTBOXTHEMEDEFAULT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeDefault : public CXTPListBoxTheme
39{
40public:
50 virtual void DrawItem(CDC* pDC, CXTPListBox* pListBox, LPDRAWITEMSTRUCT lpDIS);
51
57 virtual void RefreshMetrics();
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPLISTBOXTHEMEDEFAULT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPListBoxThemeDefault
CXTPListBoxThemeDefault is used by CXTPListBox to draw a default style list box.
Definition XTPListBoxThemeDefault.h:39
CXTPListBoxThemeDefault::DrawItem
virtual void DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
CXTPListBoxThemeDefault::RefreshMetrics
virtual void RefreshMetrics()
Called to update the colors and metrics used to draw the CXTPListBox object.
CXTPListBoxTheme
CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control.
Definition XTPListBox.h:61


CXTPListBoxThemeVisualStudio2017 Member List

This is the complete list of members for CXTPListBoxThemeVisualStudio2017, including all inherited members.

CXTPListBoxThemeOffice2013() | CXTPListBoxThemeOffice2013 |
CXTPListBoxThemeVisualStudio2017() | CXTPListBoxThemeVisualStudio2017 |
DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2013 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxThemeOffice2013 | virtual
GetBackColor() | CXTPListBoxThemeOffice2013 | virtual
m_clrBack | CXTPListBoxThemeOffice2013 |
m_clrBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBack | CXTPListBoxThemeOffice2013 |
m_clrItemBackHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBackSelected | CXTPListBoxThemeOffice2013 |
m_clrItemBorder | CXTPListBoxThemeOffice2013 |
m_clrItemBorderHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemBorderSelected | CXTPListBoxThemeOffice2013 |
m_clrItemText | CXTPListBoxThemeOffice2013 |
m_clrItemTextHighlight | CXTPListBoxThemeOffice2013 |
m_clrItemTextSelected | CXTPListBoxThemeOffice2013 |
RefreshMetrics() | CXTPListBoxThemeOffice2013 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


CXTPChartAxisTickMarks Member List

This is the complete list of members for CXTPChartAxisTickMarks, including all inherited members.

CXTPChartAxisTickMarks(CXTPChartAxis *pAxis) | CXTPChartAxisTickMarks |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisTickMarks | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartAxisTickMarks |
GetContent() const | CXTPChartElement |
GetLength() const | CXTPChartAxisTickMarks |
GetMinorLength() const | CXTPChartAxisTickMarks |
GetMinorThickness() const | CXTPChartAxisTickMarks |
GetOwner() const | CXTPChartElement |
GetThickness() const | CXTPChartAxisTickMarks |
Is3D() const | CXTPChartObject |
IsCrossAxis() const | CXTPChartAxisTickMarks |
IsMinorVisible() const | CXTPChartAxisTickMarks |
IsVisible() const | CXTPChartAxisTickMarks |
m_bCrossAxis | CXTPChartAxisTickMarks | protected
m_bMinorVisible | CXTPChartAxisTickMarks | protected
m_bVisible | CXTPChartAxisTickMarks | protected
m_nLength | CXTPChartAxisTickMarks | protected
m_nMinorLength | CXTPChartAxisTickMarks | protected
m_nMinorThickness | CXTPChartAxisTickMarks | protected
m_nThickness | CXTPChartAxisTickMarks | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetCrossAxis(BOOL bCrossAxis) | CXTPChartAxisTickMarks |
SetLength(int nLength) | CXTPChartAxisTickMarks |
SetMinorLength(int nLength) | CXTPChartAxisTickMarks |
SetMinorThickness(int nThickness) | CXTPChartAxisTickMarks |
SetMinorVisible(BOOL bVisible) | CXTPChartAxisTickMarks |
SetThickness(int nThickness) | CXTPChartAxisTickMarks |
SetVisible(BOOL bVisible) | CXTPChartAxisTickMarks |
~CXTPChartAxisTickMarks() | CXTPChartAxisTickMarks | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: XTPProgressThemeOffice2013.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSTHEMEOFFICE2013_H__)
24# define __XTPPROGRESSTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressThemeOffice2013 : public CXTPProgressPaintManager
41{
42public:
48 CXTPProgressThemeOffice2013(CXTPPaintManager* pPaintManager);
49
55 virtual ~CXTPProgressThemeOffice2013();
56
63 virtual void DrawProgress(CDC* pDC, CXTPProgressBase* pProgressBar);
64
69 virtual void RefreshMetrics();
70
71protected:
72 CXTPPaintManagerColor m_clrBorder;
73 CXTPPaintManagerColor m_clrBar;
74 CXTPPaintManagerColor m_clrBack;
75};
76
78# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif // !defined(__XTPPROGRESSTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41
CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013 object.
Definition XTPProgressThemeOffice2013.h:41
CXTPProgressThemeOffice2013::CXTPProgressThemeOffice2013
CXTPProgressThemeOffice2013(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressThemeOffice2013 object.
CXTPProgressThemeOffice2013::~CXTPProgressThemeOffice2013
virtual ~CXTPProgressThemeOffice2013()
Destroys a CXTPProgressThemeOffice2013 object, handles cleanup and deallocation.
CXTPProgressThemeOffice2013::m_clrBorder
CXTPPaintManagerColor m_clrBorder
RGB value representing border color.
Definition XTPProgressThemeOffice2013.h:72
CXTPProgressThemeOffice2013::m_clrBar
CXTPPaintManagerColor m_clrBar
RGB value representing bar color.
Definition XTPProgressThemeOffice2013.h:73
CXTPProgressThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics()
Recalculates metrics.
CXTPProgressThemeOffice2013::m_clrBack
CXTPPaintManagerColor m_clrBack
RGB value representing back color.
Definition XTPProgressThemeOffice2013.h:74
CXTPProgressThemeOffice2013::DrawProgress
virtual void DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.


CXTPTabColorSetVisualStudio2010 Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2010, including all inherited members.

CXTPTabColorSetVisualStudio2008() | CXTPTabColorSetVisualStudio2008 |
CXTPTabColorSetVisualStudio2010(BOOL bPaneColor=FALSE) | CXTPTabColorSetVisualStudio2010 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2010 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2010 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2010 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bGradientButton | CXTPTabColorSetVisualStudio2010 | protected
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPTabColorSetVisualStudio2010 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2010 | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


CXTPFlowGraphUndoSetNodePositionCommand Member List

This is the complete list of members for CXTPFlowGraphUndoSetNodePositionCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoSetNodePositionCommand(CXTPFlowGraphNode *pNode, CPoint ptOldPosition) | CXTPFlowGraphUndoSetNodePositionCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pNode | CXTPFlowGraphUndoSetNodePositionCommand | protected
m_ptOldPosition | CXTPFlowGraphUndoSetNodePositionCommand | protected
Undo() | CXTPFlowGraphUndoSetNodePositionCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoSetNodePositionCommand() | CXTPFlowGraphUndoSetNodePositionCommand | virtual


CXTPChartBubbleSeriesLabel Member List

This is the complete list of members for CXTPChartBubbleSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartBubbleSeriesLabel | virtual
CXTPChartBubbleSeriesLabel() | CXTPChartBubbleSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartSeriesLabel | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartBubbleSeriesLabel() | CXTPChartBubbleSeriesLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


CXTPSkinObjectStatusBar Member List

This is the complete list of members for CXTPSkinObjectStatusBar, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectStatusBar() | CXTPSkinObjectStatusBar |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectStatusBar() | CXTPSkinObjectStatusBar | virtual


CXTPPropertyGridVisualStudio2017Theme Member List

This is the complete list of members for CXTPPropertyGridVisualStudio2017Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2010Theme |
CXTPPropertyGridVisualStudio2017Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2017Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridVisualStudio2017Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridVisualStudio2017Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridVisualStudio2017Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridVisualStudio2010Theme() | CXTPPropertyGridVisualStudio2010Theme |


CXTPPropertyGridInplaceList Member List

This is the complete list of members for CXTPPropertyGridInplaceList, including all inherited members.

Apply() | CXTPPropertyGridInplaceList | protectedvirtual
Cancel() | CXTPPropertyGridInplaceList | protectedvirtual
Create(CXTPPropertyGridItem *pItem, CRect rect) | CXTPPropertyGridInplaceList | virtual
CXTPPropertyGridInplaceList() | CXTPPropertyGridInplaceList |
DestroyItem() | CXTPPropertyGridInplaceList | virtual
m_bShowShadow | CXTPPropertyGridInplaceList | static
m_bTrackSelection | CXTPPropertyGridInplaceList | static
~CXTPPropertyGridInplaceList() | CXTPPropertyGridInplaceList | virtual


XTP_PROPERTYGRID_NOTIFYEDIT Member List

This is the complete list of members for XTP_PROPERTYGRID_NOTIFYEDIT, including all inherited members.

bCancel | XTP_PROPERTYGRID_NOTIFYEDIT
pItem | XTP_PROPERTYGRID_NOTIFYEDIT
strValue | XTP_PROPERTYGRID_NOTIFYEDIT


XTPGridInputState Member List

This is the complete list of members for XTPGridInputState, including all inherited members.

bKeyControl | XTPGridInputState
bKeyShift | XTPGridInputState
bSelected | XTPGridInputState
nRow | XTPGridInputState
ptMouse | XTPGridInputState


CXTPGridInplaceList Member List

This is the complete list of members for CXTPGridInplaceList, including all inherited members.

Apply() | CXTPGridInplaceList |
Cancel() | CXTPGridInplaceList |
Create(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraints *pConstraints) | CXTPGridInplaceList |
CXTPGridInplaceControl() | CXTPGridInplaceControl |
CXTPGridInplaceList() | CXTPGridInplaceList |
GetDropListItemNumber() const | CXTPGridInplaceList |
OnSelectionChanged(int nLBIndex) | CXTPGridInplaceList | protectedvirtual
pColumn | XTP_GRIDRECORDITEM_ARGS |
pControl | XTP_GRIDRECORDITEM_ARGS |
pItem | XTP_GRIDRECORDITEM_ARGS |
pRow | XTP_GRIDRECORDITEM_ARGS |
rcItem | XTP_GRIDRECORDITEM_ARGS |
SetDropListItemNumber(int nNumber) | CXTPGridInplaceList |
SetItemArgs(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridInplaceList | protectedvirtual
~CXTPGridInplaceControl() | CXTPGridInplaceControl | virtual


Toolkit Pro: XTPDockingPaneBase.h Source File

  • Source
  • DockingPane
XTPDockingPaneBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEBASE_H__)
24# define __XTPDOCKINGPANEBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPaneBase;
34class CXTPDockingPane;
35class CXTPDockingPaneTabbedContainer;
36class CXTPDockingPaneLayout;
37class CXTPDockingPaneManager;
38class CXTPDockingPanePaintManager;
39class CXTPDockingPaneCaptionButton;
40class CXTPPropExchange;
41
47class _XTP_EXT_CLASS CXTPDockingPaneCaptionButtons
48 : public CArray<CXTPDockingPaneCaptionButton*, CXTPDockingPaneCaptionButton*>
49{
50public:
60 BOOL CheckForMouseOver(CPoint pt);
61};
62
68class _XTP_EXT_CLASS CXTPDockingPaneBase
69{
70protected:
91 CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout* pLayout);
92
98 virtual ~CXTPDockingPaneBase();
99
100public:
107 virtual BOOL IsActive() const;
108
115 virtual BOOL IsCaptionVertical() const;
116
124 virtual CString GetTitle() const;
125
126public:
144 XTPDockingPaneType GetType() const;
145
153 CRect GetPaneWindowRect() const;
154
162 CXTPDockingPaneBase* GetContainer() const;
163
170 CXTPDockingPaneManager* GetDockingPaneManager() const;
171
178 CXTPDockingPanePaintManager* GetPaintManager() const;
179
187 CXTPDockingPaneCaptionButton* FindCaptionButton(int nID) const;
188
195 CXTPDockingPaneCaptionButtons* GetCaptionButtons() const;
196
201 virtual void RedrawPane();
202
212 virtual POSITION ContainPane(CXTPDockingPaneBase* pPane) const;
213
224 virtual void FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList* pList) const;
225
235 virtual void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const;
236
243 virtual BOOL IsEmpty() const;
244
251 virtual CWnd* GetDockingSite() const;
252
259 virtual BOOL IsHidden() const;
260
268 virtual HWND GetPaneHwnd() const;
269
275 virtual void InvalidatePane(BOOL bSelectionChanged);
276
277protected:
285 virtual void OnSizeParent(CWnd* pParent, CRect rect, LPVOID lParam);
286
291 virtual void OnFocusChanged();
292
298 virtual void SetDockingSite(CWnd* pFrame);
299
305 virtual void SetParentContainer(CXTPDockingPaneBase* pContainer);
306
312 virtual void OnChildContainerChanged(CXTPDockingPaneBase* pContainer);
313
319 virtual void OnParentContainerChanged(CXTPDockingPaneBase* pContainer);
320
328 virtual BOOL DoPropExchange(CXTPPropExchange* pPX);
329
341 virtual CXTPDockingPaneBase* Clone(CXTPDockingPaneLayout* pLayout, CXTPPaneToPaneMap* pMap,
342 DWORD dwIgnoredOptions = 0);
343
353 virtual void Copy(CXTPDockingPaneBase* pClone, CXTPPaneToPaneMap* pMap, DWORD dwIgnoredOptions);
354
360 virtual void RemovePane(CXTPDockingPaneBase* pPane);
361
368 virtual void OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton* pButton);
369
377 virtual BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton* pButton);
378
383 virtual void DeletePane() = 0;
384
389 virtual void CreateContainer();
390
391# ifdef _XTP_ACTIVEX
393public:
394 virtual LPDISPATCH OleGetDispatch(BOOL bAddRef) = 0;
395
397# endif
398
399protected:
400 CSize m_szDocking;
401 CXTPDockingPaneLayout* m_pLayout;
403 CXTPDockingPaneBase* m_pParentContainer;
404 CWnd* m_pDockingSite;
405 XTPDockingPaneType m_type;
406 CRect m_rcWindow;
407 CXTPDockingPaneCaptionButtons* m_pCaptionButtons;
409private:
410 int m_nLength;
411 int m_nIndex;
412
413private:
414 friend class CXTPDockingPaneManager;
415 friend class CXTPDockingPaneSplitterContainer;
416 friend class CXTPDockingPaneTabbedContainer;
417 friend class CXTPDockingPaneMiniWnd;
418 friend class CXTPDockingPaneSplitterWnd;
419 friend class CXTPDockingPaneContext;
420 friend class CXTPDockingPane;
421 friend class CXTPDockingPaneLayout;
422 friend class CXTPDockingPaneAutoHidePanel;
423 friend class CXTPDockingPaneAutoHideWnd;
424 friend class CXTPDockingPaneCaptionButton;
425 friend class CXTPDockingPaneSidePanel;
426};
427
429class _XTP_EXT_CLASS CXTPDockingPaneClientContainer
430 : public CXTPCmdTarget
431 , public CXTPDockingPaneBase
432{
433public:
434 CXTPDockingPaneClientContainer(CXTPDockingPaneLayout* pLayout);
435
436protected:
437 virtual void DeletePane();
438
439# ifdef _XTP_ACTIVEX
440private:
441 DECLARE_DISPATCH_MAP()
442 DECLARE_OLETYPELIB_EX(CXTPDockingPaneClientContainer);
443 DECLARE_INTERFACE_MAP()
444
445 LPDISPATCH OleGetDispatch(BOOL /*bAddRef*/);
446 afx_msg LPDISPATCH OleGetItem(int nIndex);
447 afx_msg int OleGetItemCount();
448 afx_msg LPDISPATCH OleGetContainer();
449 afx_msg int OleGetType();
450 afx_msg LPDISPATCH OleGetPane(int nIndex);
451 afx_msg HWND OleGetHwnd();
452 afx_msg BOOL OleIsEmpty();
453 afx_msg int OleGetPosition();
454# endif
455};
458AFX_INLINE BOOL CXTPDockingPaneBase::IsActive() const
459{
460 return FALSE;
461}
462
463AFX_INLINE BOOL CXTPDockingPaneBase::IsCaptionVertical() const
464{
465 return FALSE;
466}
467
468AFX_INLINE CString CXTPDockingPaneBase::GetTitle() const
469{
470 return CString(_T(""));
471}
472
473AFX_INLINE XTPDockingPaneType CXTPDockingPaneBase::GetType() const
474{
475 return m_type;
476}
477
478AFX_INLINE CXTPDockingPaneBase* CXTPDockingPaneBase::GetContainer() const
479{
480 return m_pParentContainer;
481}
482
483AFX_INLINE void CXTPDockingPaneBase::SetDockingSite(CWnd* pFrame)
484{
485 m_pDockingSite = pFrame;
486}
487
488AFX_INLINE void CXTPDockingPaneBase::SetParentContainer(CXTPDockingPaneBase* pContainer)
489{
490 m_pParentContainer = pContainer;
491}
492
493AFX_INLINE void CXTPDockingPaneBase::OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton*)
494{
495}
496
497AFX_INLINE BOOL
498 CXTPDockingPaneBase::IsCaptionButtonVisible(CXTPDockingPaneCaptionButton* /*pButton*/)
499{
500 return TRUE;
501}
502
503AFX_INLINE CWnd* CXTPDockingPaneBase::GetDockingSite() const
504{
505 return m_pDockingSite;
506}
507
508AFX_INLINE HWND CXTPDockingPaneBase::GetPaneHwnd() const
509{
510 return 0;
511}
512
513AFX_INLINE CXTPDockingPaneCaptionButtons* CXTPDockingPaneBase::GetCaptionButtons() const
514{
515 return m_pCaptionButtons;
516}
518# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
519#endif // #if !defined(__XTPDOCKINGPANEBASE_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneType
XTPDockingPaneType
Docking pane type.
Definition XTPDockingPaneDefines.h:77
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
CXTPDockingPaneBaseList
CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
Definition XTPDockingPaneDefines.h:482
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBas...
Definition XTPDockingPaneAutoHidePanel.h:121
CXTPDockingPaneAutoHideWnd
CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class.
Definition XTPDockingPaneAutoHidePanel.h:43
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneBase::ContainPane
virtual POSITION ContainPane(CXTPDockingPaneBase *pPane) const
Call this member to determine if one pane is contained in the collection of another.
CXTPDockingPaneBase::GetTitle
virtual CString GetTitle() const
Call this member to get the text in the caption for the tabbed container (group of panes).
Definition XTPDockingPaneBase.h:468
CXTPDockingPaneBase::OnFocusChanged
virtual void OnFocusChanged()
This method is called to update the state of the pane.
CXTPDockingPaneBase::RemovePane
virtual void RemovePane(CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
CXTPDockingPaneBase::m_pParentContainer
CXTPDockingPaneBase * m_pParentContainer
Parent container.
Definition XTPDockingPaneBase.h:403
CXTPDockingPaneBase::SetParentContainer
virtual void SetParentContainer(CXTPDockingPaneBase *pContainer)
Call this method to set the parent container of the pane.
Definition XTPDockingPaneBase.h:488
CXTPDockingPaneBase::OnChildContainerChanged
virtual void OnChildContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
CXTPDockingPaneBase::IsHidden
virtual BOOL IsHidden() const
Call this member to check if the pane is hidden.
CXTPDockingPaneBase::OnParentContainerChanged
virtual void OnParentContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
CXTPDockingPaneBase::SetDockingSite
virtual void SetDockingSite(CWnd *pFrame)
Call this member to set the parent frame of the pane.
Definition XTPDockingPaneBase.h:483
CXTPDockingPaneBase::DoPropExchange
virtual BOOL DoPropExchange(CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
CXTPDockingPaneBase::GetCaptionButtons
CXTPDockingPaneCaptionButtons * GetCaptionButtons() const
Call this member to get a reference to the caption's close/pop-up button.
Definition XTPDockingPaneBase.h:513
CXTPDockingPaneBase::InvalidatePane
virtual void InvalidatePane(BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
CXTPDockingPaneBase::Clone
virtual CXTPDockingPaneBase * Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0)
This member is called to clone the pane.
CXTPDockingPaneBase::m_pDockingSite
CWnd * m_pDockingSite
Parent frame.
Definition XTPDockingPaneBase.h:404
CXTPDockingPaneBase::FindPane
virtual void FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const
Call this member to retrieve a collection of the panes with a specified type.
CXTPDockingPaneBase::m_pLayout
CXTPDockingPaneLayout * m_pLayout
Parent layout.
Definition XTPDockingPaneBase.h:401
CXTPDockingPaneBase::m_pCaptionButtons
CXTPDockingPaneCaptionButtons * m_pCaptionButtons
Collection of caption buttons.
Definition XTPDockingPaneBase.h:407
CXTPDockingPaneBase::m_szDocking
CSize m_szDocking
Size of the pane.
Definition XTPDockingPaneBase.h:400
CXTPDockingPaneBase::GetContainer
CXTPDockingPaneBase * GetContainer() const
Call this member function to retrieve the parent container of the pane.
Definition XTPDockingPaneBase.h:478
CXTPDockingPaneBase::DeletePane
virtual void DeletePane()=0
This method is called to destroy a pane.
CXTPDockingPaneBase::GetMinMaxInfo
virtual void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of t...
CXTPDockingPaneBase::CXTPDockingPaneBase
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
Protected constructor.
CXTPDockingPaneBase::OnCaptionButtonRectChanged
virtual void OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton)
This member is called when the dimensions of the caption button are changed.
Definition XTPDockingPaneBase.h:493
CXTPDockingPaneBase::GetPaneHwnd
virtual HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneBase.h:508
CXTPDockingPaneBase::IsActive
virtual BOOL IsActive() const
Determines if the frame is active.
Definition XTPDockingPaneBase.h:458
CXTPDockingPaneBase::GetPaintManager
CXTPDockingPanePaintManager * GetPaintManager() const
Call this member function to retrieve the paint manager.
CXTPDockingPaneBase::IsCaptionVertical
virtual BOOL IsCaptionVertical() const
Determines if the caption is drawn vertically.
Definition XTPDockingPaneBase.h:463
CXTPDockingPaneBase::GetType
XTPDockingPaneType GetType() const
Call this member to determine the type of the pane.
Definition XTPDockingPaneBase.h:473
CXTPDockingPaneBase::CreateContainer
virtual void CreateContainer()
This member is called to create a pane.
CXTPDockingPaneBase::FindCaptionButton
CXTPDockingPaneCaptionButton * FindCaptionButton(int nID) const
Call this member to find the specified caption button.
CXTPDockingPaneBase::m_type
XTPDockingPaneType m_type
Type of the pane.
Definition XTPDockingPaneBase.h:405
CXTPDockingPaneBase::m_rcWindow
CRect m_rcWindow
Position of the pane.
Definition XTPDockingPaneBase.h:406
CXTPDockingPaneBase::GetDockingSite
virtual CWnd * GetDockingSite() const
Call this member function to retrieve the parent window for the pane.
Definition XTPDockingPaneBase.h:503
CXTPDockingPaneBase::Copy
virtual void Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
This member is called to copy a pane.
CXTPDockingPaneBase::IsCaptionButtonVisible
virtual BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
Definition XTPDockingPaneBase.h:498
CXTPDockingPaneBase::GetDockingPaneManager
CXTPDockingPaneManager * GetDockingPaneManager() const
Call this member function to retrieve the pane manager.
CXTPDockingPaneBase::IsEmpty
virtual BOOL IsEmpty() const
Call this member to determine if there are no children panes.
CXTPDockingPaneBase::RedrawPane
virtual void RedrawPane()
Call this member to redraw the pane.
CXTPDockingPaneBase::OnSizeParent
virtual void OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
CXTPDockingPaneBase::GetPaneWindowRect
CRect GetPaneWindowRect() const
The GetPaneWindowRect function retrieves the dimensions of the bounding rectangle of the pane.
CXTPDockingPaneBase::~CXTPDockingPaneBase
virtual ~CXTPDockingPaneBase()
Destroys a CXTPDockingPaneBase object, handles cleanup and deallocation.
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPaneCaptionButtons
CXTPDockingPaneCaptionButtons is a CArray derived class used to manipulate Caption Buttons.
Definition XTPDockingPaneBase.h:49
CXTPDockingPaneCaptionButtons::CheckForMouseOver
BOOL CheckForMouseOver(CPoint pt)
Call this member to determine if the mouse pointer is positioned over one of the buttons in the pane ...
CXTPDockingPaneContext
CXTPDockingPaneContext is a standalone class.
Definition XTPDockingPaneContext.h:185
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPanePaintManager
CXTPDockingPanePaintManager is a standalone class.
Definition XTPDockingPanePaintManager.h:196
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneSplitterContainer.h:168
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPRibbonControlSystemPopupBarPinableListItem Member List

This is the complete list of members for CXTPRibbonControlSystemPopupBarPinableListItem, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPRibbonControlSystemPopupBarListItem() | CXTPRibbonControlSystemPopupBarListItem |
CXTPRibbonControlSystemPopupBarPinableListItem() | CXTPRibbonControlSystemPopupBarPinableListItem |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPRibbonControlSystemPopupBarPinableListItem | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPRibbonControlSystemPopupBarListItem | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bAlignShortcut | CXTPRibbonControlSystemPopupBarListItem | protected
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pIcons | CXTPRibbonControlSystemPopupBarPinableListItem | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPRibbonControlSystemPopupBarPinableListItem | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPRibbonControlSystemPopupBarPinableListItem | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPRibbonControlSystemPopupBarPinableListItem | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPRibbonControlSystemPopupBarPinableListItem() | CXTPRibbonControlSystemPopupBarPinableListItem |


CXTPTaskPanelOffice2013Theme Member List

This is the complete list of members for CXTPTaskPanelOffice2013Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelOffice2013Theme() | CXTPTaskPanelOffice2013Theme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelOffice2013Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelOffice2013Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelOffice2013Theme() | CXTPTaskPanelOffice2013Theme | virtual
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual


Toolkit Pro: XTPTabColorSetVisualStudio2010.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2010.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2010_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2010_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
47class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2010 : public CXTPTabColorSetVisualStudio2008
48{
49public:
55 CXTPTabColorSetVisualStudio2010(BOOL bPaneColor = FALSE);
56
57public:
65 void RefreshMetrics();
66
82 COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
83
100 void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
101
108 void SetTextColor(CDC* pDC, CXTPTabManagerItem* pItem);
109
124 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
125
126protected:
127 BOOL m_bGradientButton;
130 BOOL m_bPaneColor;
131
132 CXTPBrush m_xtpBrushHeader;
133 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushHeader, m_xtpBrushHeader,
134 GetHeaderBrushHandle);
135};
136
137# define CColorSetVisualStudio2010 CXTPTabColorSetVisualStudio2010
138
139# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
141#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2010_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPTabColorSetVisualStudio2008
CXTPTabColorSetVisualStudio2008 implements a Visual Studio 2008 tab color set.
Definition XTPTabColorSetVisualStudio2008.h:48
CXTPTabColorSetVisualStudio2010
CXTPTabColorSetVisualStudio2010 implements a Visual Studio 2010 tab color set.
Definition XTPTabColorSetVisualStudio2010.h:48
CXTPTabColorSetVisualStudio2010::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
Fills the header of the tab client of a specified tab manager.
CXTPTabColorSetVisualStudio2010::m_bGradientButton
BOOL m_bGradientButton
TRUE if luna colors are enabled.
Definition XTPTabColorSetVisualStudio2010.h:127
CXTPTabColorSetVisualStudio2010::FillNavigateButton
void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CXTPTabColorSetVisualStudio2010::FillPropertyButton
COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CXTPTabColorSetVisualStudio2010::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetVisualStudio2010::CXTPTabColorSetVisualStudio2010
CXTPTabColorSetVisualStudio2010(BOOL bPaneColor=FALSE)
Constructs a CXTPTabColorSetVisualStudio2010 object.
CXTPTabColorSetVisualStudio2010::SetTextColor
void SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for a specified tab.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74


Toolkit Pro: XTPMarkupQueryCursorEventArgs.h Source File

  • Source
  • Markup
XTPMarkupQueryCursorEventArgs.h
Go to the documentation of this file.
1
23#if !defined(__XTPMMARKUPQUERYCURSOREVENTARGS_H__)
24# define __XTPMMARKUPQUERYCURSOREVENTARGS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMarkupQueryCursorEventArgs : public CXTPMarkupMouseEventArgs
34{
35public:
36 CXTPMarkupQueryCursorEventArgs();
37
38public:
39 HCURSOR m_hCursor;
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPMMARKUPQUERYCURSOREVENTARGS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPEditTheme.h Source File

  • Source
  • Controls
  • Edit
XTPEditTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEME_H__)
24# define __XTPEDITTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34class CXTPEdit;
35
41class _XTP_EXT_CLASS CXTPEditTheme : public CXTPControlTheme
42{
43public:
48 CXTPEditTheme();
49
54 virtual ~CXTPEditTheme();
55
62 virtual void RefreshMetrics(CXTPEdit* pEdit) = 0;
63
72 virtual void DrawNcBorders(CDC* pDC, CRect rcWnd, CXTPEdit* pEdit) = 0;
73
82 virtual void DrawNcScrollBack(CDC* pDC, CRect rcWnd, CXTPEdit* pEdit) = 0;
83
96 virtual void FillRect(CDC* pDC, int x, int y, int cx, int cy, CBrush* pBrush);
97
108 virtual void DrawFrame(CDC* pDC, CRect rc, int nSize, CBrush* pBrush);
109
119 virtual CBrush* GetClientBrush(CDC* pDC, CXTPEdit* pEdit);
120
131 virtual CBrush* CtlColor(CDC* pDC, UINT nCtlColor, CXTPEdit* pEdit) = 0;
132
144 virtual BOOL AdjustBuddyRect(CWnd* pBuddy, CRect& rcUpDown, int nAlignment);
145
157 virtual void DrawBuddyBorders(CWnd* pBuddy, CDC* pDC, CRect rc, int nAlignment,
158 CXTPEdit* pEdit) = 0;
159
168 virtual BOOL RedrawFocusedFrame() const;
169
177 BOOL IsFlatStyle() const;
178
184 void SetFlatStyle(BOOL bFlatStyle);
185
193 XTPControlTheme GetThemeID() const;
194
201 void UseWinTheme(BOOL bUseWinTheme);
202
203 CXTPBrush m_xtpBrushBack;
204 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brBack, m_xtpBrushBack, GetBackBrushHandle);
205
206 CXTPPaintManagerColor m_clrBack;
207 CXTPPaintManagerColor m_clrText;
208 CXTPPaintManagerColor m_clrTextReadOnly;
209 CXTPPaintManagerColor m_clrBackNonClient;
210 CXTPPaintManagerColorGradient m_clrBorder;
212protected:
213 BOOL m_bFlatStyle;
214 BOOL m_bUseWinTheme;
215 XTPControlTheme m_nTheme;
216 CXTPWinThemeWrapper m_winTheme;
218private:
219 friend class CXTPEdit;
220};
221
223
224AFX_INLINE XTPControlTheme CXTPEditTheme::GetThemeID() const
225{
226 return m_nTheme;
227}
228AFX_INLINE void CXTPEditTheme::UseWinTheme(BOOL bUseWinTheme)
229{
230 m_bUseWinTheme = bUseWinTheme;
231}
232AFX_INLINE BOOL CXTPEditTheme::IsFlatStyle() const
233{
234 return m_bFlatStyle;
235}
236AFX_INLINE void CXTPEditTheme::SetFlatStyle(BOOL bFlatStyle)
237{
238 m_bFlatStyle = bFlatStyle;
239}
241# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
243#endif // __XTPEDITTHEME_H__
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditTheme
CXTPEditTheme is the base class for all edit themes used to perform drawing tasks.
Definition XTPEditTheme.h:42
CXTPEditTheme::CtlColor
virtual CBrush * CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)=0
Called by the framework to handle setting the text and background colors for the edit control.
CXTPEditTheme::FillRect
virtual void FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush)
Called by the edit control to fill a rectangle using the brush specifed by pBrush.
CXTPEditTheme::DrawFrame
virtual void DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush)
Called by the edit control to draw a frame rectangle using the brush specified by pBrush.
CXTPEditTheme::UseWinTheme
void UseWinTheme(BOOL bUseWinTheme)
Call this member function to enable Windows themes for the edit control.
CXTPEditTheme::CXTPEditTheme
CXTPEditTheme()
Constructs a CXTPEditThemeDefault object.
CXTPEditTheme::AdjustBuddyRect
virtual BOOL AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
CXTPEditTheme::DrawNcScrollBack
virtual void DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)=0
Called by the framework to draw the non-client background for the combobox scrollbar area.
CXTPEditTheme::m_bFlatStyle
BOOL m_bFlatStyle
TRUE when drawing flat borders.
Definition XTPEditTheme.h:213
CXTPEditTheme::IsFlatStyle
BOOL IsFlatStyle() const
Call this member function to determine if the m_bFlatStyle flag has be set.
CXTPEditTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)=0
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPEditTheme::m_clrText
CXTPPaintManagerColor m_clrText
Text color.
Definition XTPEditTheme.h:207
CXTPEditTheme::m_xtpBrushBack
CXTPBrush m_xtpBrushBack
Background brush color.
Definition XTPEditTheme.h:203
CXTPEditTheme::~CXTPEditTheme
virtual ~CXTPEditTheme()
Destructor, handles cleanup and deallocation.
CXTPEditTheme::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)=0
Called by the framework to draw the borders for the associated buddy window.
CXTPEditTheme::m_clrBorder
CXTPPaintManagerColorGradient m_clrBorder
Dark and light border colors.
Definition XTPEditTheme.h:210
CXTPEditTheme::RedrawFocusedFrame
virtual BOOL RedrawFocusedFrame() const
Called by the framework to redraw the focus rectangle for the edit control.
CXTPEditTheme::m_nTheme
XTPControlTheme m_nTheme
Specifies the Theme ID used by the paint manager.
Definition XTPEditTheme.h:215
CXTPEditTheme::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)=0
This member function is called by the theme manager to draw non-client borders for the edit control.
CXTPEditTheme::GetThemeID
XTPControlTheme GetThemeID() const
Call this member function to get the style for the theme.
CXTPEditTheme::SetFlatStyle
void SetFlatStyle(BOOL bFlatStyle)
Call this member function to set a value for m_bFlatStyle.
CXTPEditTheme::m_winTheme
CXTPWinThemeWrapper m_winTheme
Windows theme wrapper.
Definition XTPEditTheme.h:216
CXTPEditTheme::m_clrBackNonClient
CXTPPaintManagerColor m_clrBackNonClient
Non-client area background color.
Definition XTPEditTheme.h:209
CXTPEditTheme::m_clrTextReadOnly
CXTPPaintManagerColor m_clrTextReadOnly
Read-only text color.
Definition XTPEditTheme.h:208
CXTPEditTheme::GetClientBrush
virtual CBrush * GetClientBrush(CDC *pDC, CXTPEdit *pEdit)
Call this member function to retrieve a pointer to the client background brush.
CXTPEditTheme::m_bUseWinTheme
BOOL m_bUseWinTheme
TRUE to use windows themes.
Definition XTPEditTheme.h:214
CXTPEditTheme::m_clrBack
CXTPPaintManagerColor m_clrBack
Background color.
Definition XTPEditTheme.h:206
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


CXTPRibbonThemeNativeWindows11 Member List

This is the complete list of members for CXTPRibbonThemeNativeWindows11, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPRibbonOffice2013Theme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeNativeWindows11(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeNativeWindows11 |
DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | protectedvirtual
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonThemeNativeWindows11 | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonThemeNativeWindows11 | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonThemeNativeWindows11 | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackImageName() | CXTPRibbonOffice2013Theme | protectedvirtual
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonOffice2013Theme | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonOffice2013Theme | protectedvirtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrHeader | CXTPRibbonOffice2013Theme | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFaceState | CXTPRibbonOffice2013Theme | protected
m_clrRibbonTabDelimeter | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageLeft | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageRight | CXTPRibbonOffice2013Theme | protected
m_clrTabBackInactiveState | CXTPRibbonOffice2013Theme | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonThemeNativeWindows11 | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetBackImage(int nImage) | CXTPRibbonOffice2013Theme | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonOffice2013Theme() | CXTPRibbonOffice2013Theme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeNativeWindows11() | CXTPRibbonThemeNativeWindows11 | virtual


CXTPChartSplineSeriesView Member List

This is the complete list of members for CXTPChartSplineSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartSplineSeriesView | protectedvirtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartLineSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSplineSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView, BOOL bSortPoints=TRUE) | CXTPChartLineSeriesView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSplineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartSplineSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


CXTPPropertyGridSimpleTheme Member List

This is the complete list of members for CXTPPropertyGridSimpleTheme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridSimpleTheme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridSimpleTheme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridSimpleTheme | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridSimpleTheme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridSimpleTheme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


Toolkit Pro: XTPGridRecordItem.h Source File

  • Source
  • GridControl
XTPGridRecordItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEM_H__)
24# define __XTPGRIDRECORDITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupContext;
35class CXTPGridControl;
36class CXTPGridRow;
37class CXTPGridRecordItem;
38class CXTPGridHyperlink;
39class CXTPGridHyperlinks;
40class CXTPGridColumn;
41class CXTPGridPaintManager;
42class CXTPGridRecord;
43class CXTPGridInplaceButton;
44class CXTPPropExchange;
45class CXTPGridRecordItemConstraint;
46class CXTPGridRecordItemConstraints;
47class CXTPGridRecordItemControlHookWnd;
48class CXTPGridRecordItemControl;
49class CXTPGridRecordItemControls;
50class CXTPGridBorder;
51class CXTPGridGroupRow;
52
68struct _XTP_EXT_CLASS XTP_GRIDRECORDITEM_ARGS
69{
75 XTP_GRIDRECORDITEM_ARGS();
83 XTP_GRIDRECORDITEM_ARGS(CXTPGridControl* pControl, CXTPGridRow* pRow, CXTPGridColumn* pColumn);
84
89 virtual ~XTP_GRIDRECORDITEM_ARGS();
90
91 void AddRef();
92 void Release();
93
94 const XTP_GRIDRECORDITEM_ARGS& operator=(const XTP_GRIDRECORDITEM_ARGS& src);
97 CXTPGridControl* pControl;
98 CXTPGridRow* pRow;
99 CXTPGridColumn* pColumn;
100 CXTPGridRecordItem* pItem;
101 CRect rcItem;
102};
103
124struct _XTP_EXT_CLASS XTP_GRIDRECORDITEM_DRAWARGS : public XTP_GRIDRECORDITEM_ARGS
125{
127 XTP_GRIDRECORDITEM_DRAWARGS()
128 {
129 nTextAlign = DT_LEFT;
130 pDC = NULL;
131 }
134 CDC* pDC;
135 int nTextAlign;
136};
137
148struct _XTP_EXT_CLASS XTP_GRIDRECORDITEM_CLICKARGS : public XTP_GRIDRECORDITEM_ARGS
149{
150 CPoint ptClient;
151};
152
178struct XTP_NM_GRIDRECORDITEM
179{
180 NMHDR hdr;
181 CXTPGridRow* pRow;
182 CXTPGridRecordItem* pItem;
183 CXTPGridColumn* pColumn;
184 int nHyperlink;
185 POINT pt;
186};
187
196struct XTP_NM_GRIDREQUESTEDIT : public XTP_NM_GRIDRECORDITEM
197{
198 BOOL bCancel;
199};
200
201# ifdef _XTP_ACTIVEX
203struct XTP_NM_GRIDVALUECHANGING : public XTP_NM_GRIDRECORDITEM
204{
205 BOOL bCancel;
206 LPVARIANT lpNewValue;
207};
209# endif
210
222struct XTP_NM_GRIDINPLACEBUTTON : public XTP_NM_GRIDRECORDITEM
223{
224 CXTPGridInplaceButton* pButton;
225};
226
240struct XTP_NM_GRID_BEFORE_COPYPASTE
241{
242 NMHDR hdr;
244 CXTPGridRecord** ppRecord;
245 CStringArray* parStrings;
247};
248
259struct XTP_NM_GRIDCONSTRAINTSELECTING : public XTP_NM_GRIDRECORDITEM
260{
261 CXTPGridRecordItemConstraint* pConstraint;
265};
266
277struct XTP_NM_GRIDTOOLTIPINFO : public XTP_NM_GRIDRECORDITEM
278{
279 CString* pstrText;
280};
281
286enum XTPGridColumnIconAlignment
287{
288 xtpColumnTextLeft = DT_LEFT,
289 xtpColumnTextCenter = DT_CENTER,
290 xtpColumnTextRight = DT_RIGHT,
291 xtpColumnTextVCenter = DT_VCENTER,
292 xtpColumnTextWordBreak = DT_WORDBREAK,
297 xtpColumnTextMask = 0xFF,
299 xtpColumnIconLeft = 0x00100000,
300 xtpColumnIconCenter = 0x00200000,
301 xtpColumnIconRight = 0x00400000,
303 xtpColumnIconTop = 0x01000000,
304 xtpColumnIconVCenter = 0x02000000,
305 xtpColumnIconBottom = 0x04000000,
307 xtpColumnIconMask = 0x0FF00000
308};
309
316enum XTPGridGroupRowIconAlignment
317{
318 xtpGroupRowIconUnknown = 0,
320 xtpGroupRowIconLeft = 0x001,
321 xtpGroupRowIconBeforeText = 0x002,
323 xtpGroupRowIconAfterText = 0x004,
324 xtpGroupRowIconRight = 0x008,
326 xtpGroupRowIconHmask = 0x00F,
328 xtpGroupRowIconVTop = 0x100,
329 xtpGroupRowIconVCenter = 0x200,
330 xtpGroupRowIconVCenterToText = 0x400,
331 xtpGroupRowIconVBottom = 0x800,
333 xtpGroupRowIconVmask = 0xF00,
334};
335
342enum XTPGridVirtualRowFlags
343{
344 xtpVirtRowUnknown = 0,
345 xtpVirtRowHasChildren = 0x001,
346 xtpVirtRowLastChild = 0x002
347};
348
355struct XTP_GRIDRECORDITEM_METRICS : public CXTPCmdTarget
356{
357 CFont* pFont;
358 COLORREF clrForeground;
359 COLORREF clrBackground;
360 CString strText;
362 int nGroupRowIcon;
363 int nGroupRowIconAlignment;
364 int nColumnAlignment;
365 int nItemIcon;
366 int nVirtRowLevel;
367 int nVirtRowFlags;
369# ifdef _XTP_ACTIVEX
371 CXTPFont m_xtpFontMetrics;
372 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntMetrics, m_xtpFontMetrics,
373 GetMetricsFontHandle);
375# endif
376
382 XTP_GRIDRECORDITEM_METRICS()
383 {
384 Reset();
385
386# ifdef _XTP_ACTIVEX
387 EnableAutomation();
388# endif
389 }
390
391 void Reset()
392 {
393 pFont = NULL;
394 clrForeground = XTP_GRID_COLOR_DEFAULT;
395 clrBackground = XTP_GRID_COLOR_DEFAULT;
396
397 nGroupRowIcon = XTP_GRID_NOICON;
398 nGroupRowIconAlignment = xtpGroupRowIconRight | xtpGroupRowIconVCenter;
399 nColumnAlignment = xtpColumnTextLeft;
400 nItemIcon = XTP_GRID_NOICON;
401 nVirtRowLevel = 0;
402 nVirtRowFlags = 0;
403 }
406# ifdef _XTP_ACTIVEX
408 ~XTP_GRIDRECORDITEM_METRICS()
409 {
410 }
411
412 DECLARE_DISPATCH_MAP()
413 DECLARE_INTERFACE_MAP()
414
415 LPFONTDISP OleGetFont();
416 void OleSetFont(LPFONTDISP pFontDisp);
417
419# endif
420};
421
427class _XTP_EXT_CLASS CXTPGridInplaceButtons
428 : public CArray<CXTPGridInplaceButton*, CXTPGridInplaceButton*>
429{
430public:
435 CXTPGridInplaceButtons();
436};
437
442class _XTP_EXT_CLASS CXTPGridRecordItemEditOptions : public CXTPCmdTarget
443{
444public:
449 CXTPGridRecordItemEditOptions();
450
456 ~CXTPGridRecordItemEditOptions();
457
458public:
467 CXTPGridRecordItemConstraint* AddConstraint(LPCTSTR lpszConstraint, DWORD_PTR dwData = 0);
468
476 CXTPGridRecordItemConstraint* FindConstraint(DWORD_PTR dwData);
477
485 CXTPGridRecordItemConstraint* FindConstraint(LPCTSTR lpszConstraint);
486
493 CXTPGridRecordItemConstraints* GetConstraints()
494 {
495 return m_pConstraints;
496 }
497
510 CXTPGridInplaceButton* AddComboButton(BOOL bInside = FALSE);
511
523 CXTPGridInplaceButton* AddExpandButton(BOOL bInside = FALSE);
524
536 CXTPGridInplaceButton* AddSpinButton(BOOL bInside = FALSE);
537
545 CXTPGridInplaceButton* GetButton(int nIndex);
546
551 void RemoveButtons();
552
553public:
554 BOOL m_bAllowEdit;
556 BOOL m_bConstraintEdit;
558 CXTPGridRecordItemConstraints* m_pConstraints;
559 CXTPGridInplaceButtons arrInplaceButtons;
560 BOOL m_bSelectTextOnEdit;
561 BOOL m_bScrollTextOnEdit;
562 BOOL m_bExpandOnSelect;
563 DWORD m_dwEditStyle;
564 int m_nMaxLength;
567# ifdef _XTP_ACTIVEX
569 DECLARE_DISPATCH_MAP()
570 DECLARE_INTERFACE_MAP()
571
572 DECLARE_OLETYPELIB_EX(CXTPGridRecordItemEditOptions);
573
574 afx_msg LPDISPATCH OleGetConstraints();
575 afx_msg LPDISPATCH OleGetInplaceButton(long nIndex);
576 afx_msg long OleInplaceButtonsCount();
577
578 afx_msg LPDISPATCH OleAddComboButton(const VARIANT& bInside);
579 afx_msg LPDISPATCH OleAddExpandButton(const VARIANT& bInside);
580 afx_msg LPDISPATCH OleAddSpinButton(const VARIANT& bInside);
581
583# endif
584};
585
598class _XTP_EXT_CLASS CXTPGridRecordItem
599 : public CXTPHeapObjectT<CXTPCmdTarget, CXTPGridDataAllocator>
600{
602 DECLARE_SERIAL(CXTPGridRecordItem)
604public:
609 CXTPGridRecordItem();
610
615 virtual ~CXTPGridRecordItem();
616
644 virtual int Draw(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs);
645
654 virtual void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
655 XTP_GRIDRECORDITEM_METRICS* pMetrics);
656
664 virtual void OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs, CRect& rcItem);
665
677 CXTPGridRecordItemControl* HitTest(CPoint ptPoint);
678
686 virtual int HitTestHyperlink(CPoint ptClick);
687
701 virtual BOOL OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
702
716 virtual BOOL OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
717
728 virtual void OnClick(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
729
740 virtual void OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
741
751 virtual void OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl* pControl = NULL);
752
761 virtual CString GetCaption();
762
770 CString GetColumnCaptionPrefix(CXTPGridColumn* pColumn) const;
771
782 virtual CString GetCaption(CXTPGridColumn* pColumn);
783
792 virtual void GetCaptionRect(XTP_GRIDRECORDITEM_ARGS* pDrawArgs, CRect& rcItem);
793
801 virtual CString GetGroupCaption(CXTPGridColumn* pColumn);
802
810 virtual COleVariant GetGroupCaptionValue(CXTPGridColumn* pColumn);
811
819 virtual int GetGroupCaptionID(CXTPGridColumn* pColumn);
820
836 virtual int CompareGroupCaption(CXTPGridColumn* pColumn, CXTPGridRecordItem* pItem);
837
853 virtual int CompareGroupCaption(CXTPGridColumn* pColumn, CXTPGridGroupRow* pGroupRow);
854
866 virtual int Compare(CXTPGridColumn* pColumn, CXTPGridRecordItem* pItem);
867
873 virtual void SetFont(CFont* pFont);
874
881 virtual CFont* GetFont();
882
889 virtual CString GetTooltip() const;
890
896 virtual void SetTooltip(LPCTSTR lpszTooltip);
897
903 virtual void SetTextColor(COLORREF clrText);
904
911 virtual COLORREF GetTextColor();
912
919 virtual void SetBold(BOOL bBold = TRUE);
920
927 virtual BOOL IsBold() const;
928
934 virtual void SetBackgroundColor(COLORREF clrBackground);
935
942 virtual COLORREF GetBackgroundColor();
943
950 virtual CString GetFormula() const;
951
957 virtual void SetFormula(LPCTSTR sFormula);
958
965 virtual CString GetFormatString() const;
966
977 virtual void SetFormatString(LPCTSTR strFormat);
978
985 virtual BOOL IsEditable() const;
986
994 virtual BOOL SetEditable(BOOL bEditable = TRUE);
995
1012 virtual int AddHyperlink(CXTPGridHyperlink* pHyperlink);
1013
1024 virtual int GetHyperlinksCount() const;
1025
1050 virtual CXTPGridHyperlink* GetHyperlinkAt(int nHyperlink) const;
1051
1057 virtual void RemoveHyperlinkAt(int nHyperlink);
1058
1070 virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
1071 XTP_GRIDRECORDITEM_METRICS* pItemMetrics);
1072
1079 virtual BOOL IsPreviewItem() const;
1080
1087 int GetIndex() const;
1088
1095 virtual int GetIconIndex() const;
1096
1104 virtual int SetIconIndex(int nIconIndex);
1105
1113 int GetAlignment() const;
1114
1124 int SetAlignment(int nAlignment);
1125
1134 virtual int GetSortPriority() const;
1135
1143 virtual void SetSortPriority(int nSortPriority);
1144
1153 virtual int GetGroupPriority() const;
1154
1162 virtual void SetGroupPriority(int nGroupPriority);
1163
1169 virtual void SetGroupCaption(LPCTSTR strCaption);
1170
1176 virtual void SetCaption(LPCTSTR strCaption);
1177
1182 void UpdateValue();
1183
1191 virtual void SetChecked(BOOL bChecked);
1192
1201 virtual BOOL IsChecked() const;
1202
1212 void SetCheckedState(int iState);
1213
1223 int GetCheckedState() const;
1224
1233 virtual void HasCheckbox(BOOL bHasCheckbox, BOOL bTristate = FALSE);
1234
1243 virtual BOOL GetHasCheckbox() const;
1244
1251 BOOL GetCanEditCheckboxItem() const;
1252
1258 void SetCanEditCheckboxItem(BOOL bSet);
1259
1265 void SetRecord(CXTPGridRecord* pGridRecord);
1266
1273 CXTPGridRecord* GetRecord() const;
1274
1282 virtual DWORD_PTR GetItemData() const;
1283
1289 virtual void SetItemData(DWORD_PTR dwData);
1290
1297 virtual BOOL IsFocusable() const;
1298
1310 virtual void SetFocusable(BOOL bFocusable);
1311
1318 virtual void DoPropExchange(CXTPPropExchange* pPX);
1319
1326 CXTPMarkupUIElement* GetMarkupUIElement() const;
1327
1334 virtual void ResetMarkupUIElement();
1335
1347 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI);
1348
1349 // GRID
1350
1351 void Merge(CXTPGridRecordItem* pMergeItem);
1352
1353 BOOL IsMerged() const;
1354
1367 BOOL IsChildOfMerge() const;
1368
1369 CXTPGridRecordItem* GetMergeItem() const;
1370
1371 // Pointer to the top-left item in the merged group; may point to itself if it is the
1372 // top-left item in the merge group. NULL if the item does not belong to merged cells.
1373 CXTPGridRecordItem* m_pMergeItem;
1374 // GRID
1375protected:
1376 virtual void ParseBBCode(CString& strText);
1377
1385 virtual void DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs, CRect& rcItem);
1386
1393 CXTPGridHyperlinks* GetHyperlinks();
1394
1395protected:
1396 virtual BOOL IsAllowEdit(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
1397
1408 virtual BOOL OnRequestEdit(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
1409
1416 virtual void OnBeginEdit(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
1417
1427 virtual BOOL OnChar(XTP_GRIDRECORDITEM_ARGS* pItemArgs, UINT nChar);
1428
1429public:
1436 virtual void OnCancelEdit(CXTPGridControl* pControl, BOOL bApply);
1437
1444 virtual void OnValidateEdit(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
1445
1458 virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs, LPCTSTR szText);
1459
1476 virtual BOOL OnEditChanging(XTP_GRIDRECORDITEM_ARGS* pItemArgs, CString& rstrNewText);
1477
1485 virtual void OnEditCanceled(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
1486
1495 virtual void OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS* pItemArgs,
1496 CXTPGridRecordItemConstraint* pConstraint);
1497
1506 virtual DWORD GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS* pItemArgs);
1507
1513 virtual void OnInplaceButtonDown(CXTPGridInplaceButton* pButton);
1514
1522 CXTPGridRecordItemEditOptions* GetEditOptions(CXTPGridColumn* pColumn);
1523
1530 CXTPGridRecordItemControls* GetItemControls();
1531
1532 double StringToDouble(CString strText);
1533
1539 BOOL CreateBorder();
1540
1546 BOOL DestroyBorder();
1547
1554 CXTPGridBorder* GetBorder() const;
1555
1561 void SetGridControl(CXTPGridControl* pControl);
1562
1563protected:
1570 virtual CXTPGridColumn* GetColumn();
1571 virtual void DoMouseButtonClick();
1574protected:
1575 CXTPGridControl* m_pControl;
1576 CXTPGridRecord* m_pRecord;
1577 CXTPGridBorder* m_pBorder;
1579 CFont* m_pFontCaption;
1581 COLORREF m_clrText;
1582 COLORREF m_clrBackground;
1583 BOOL m_bBoldText;
1585 CString m_strFormatString;
1586 CString m_strFormula;
1588 BOOL m_bEditable;
1589 CXTPGridHyperlinks* m_pHyperlinks;
1591 int m_nIconIndex;
1593 int m_nSortPriority;
1594 int m_nGroupPriority;
1596 CString m_strGroupCaption;
1597 CString m_strCaption;
1598 BOOL m_bFocusable;
1600 int m_checkState;
1601 BOOL m_bHasCheckbox;
1602 BOOL m_bCanEditCheckboxItem;
1604 BOOL m_bTristateCheckbox;
1605 DWORD_PTR m_dwData;
1606 CString m_strTooltip;
1608 CXTPGridRecordItemEditOptions* m_pEditOptions;
1610 XTPGridColumnIconAlignment m_Alignment;
1612 CXTPGridRecordItemControls* m_pItemControls;
1613 CXTPGridRecordItemControl* m_pFocusedItemControl;
1614 BOOL m_bItemControlUnderMouse;
1615 CXTPGridRecordItemControlHookWnd* m_pItemControlHookWnd;
1616 CRect m_rcGlyph;
1618 CXTPMarkupUIElement* m_pMarkupUIElement;
1620# ifdef _XTP_ACTIVEX
1622 DECLARE_DISPATCH_MAP()
1623 DECLARE_INTERFACE_MAP()
1624
1625 DECLARE_OLETYPELIB_EX(CXTPGridRecordItem);
1626
1627 afx_msg LPDISPATCH OleGetRecord();
1628 afx_msg LPDISPATCH OleGetEditOptions();
1629 afx_msg void OleCreateEditOptions();
1630 afx_msg LPDISPATCH OleGetHyperlinks();
1631
1632 afx_msg BSTR OleGetFormat();
1633 afx_msg void OleSetFormat(LPCTSTR pcszFormat);
1634
1635 afx_msg BSTR OleGetFormula();
1636 afx_msg void OleSetFormula(LPCTSTR pcszFormula);
1637
1638 afx_msg BSTR OleGetCaption();
1639 afx_msg void OleSetCaption(LPCTSTR pcszCaption);
1640
1641 afx_msg BSTR OleGetGroupCaption();
1642 afx_msg void OleSetGroupCaption(LPCTSTR pcszGroupCaption);
1643
1644 afx_msg BSTR OleGetTooltip();
1645 afx_msg void OleSetTooltip(LPCTSTR pcszTooltip);
1646
1647 afx_msg LPDISPATCH OleGetItemControls();
1648 afx_msg LPDISPATCH OleGetMarkupUIElement();
1649
1650 COleVariant m_oleTag;
1651
1653# endif
1654
1655 friend class CXTPGridRecord;
1656 friend class CXTPGridControl;
1657 friend class CXTPGridNavigator;
1658 friend class CXTPGridIconNavigator;
1659 friend class CXTPGridRecordItemControls;
1660};
1661
1662AFX_INLINE CString CXTPGridRecordItem::GetFormula() const
1663{
1664 return m_strFormula;
1665}
1666
1667AFX_INLINE void CXTPGridRecordItem::SetFormula(LPCTSTR sFormula)
1668{
1669 m_strFormula = sFormula;
1670}
1671
1672AFX_INLINE CString CXTPGridRecordItem::GetFormatString() const
1673{
1674 return m_strFormatString;
1675}
1676
1677AFX_INLINE void CXTPGridRecordItem::SetFormatString(LPCTSTR strFormat)
1678{
1679 m_strFormatString = strFormat;
1680}
1681
1682AFX_INLINE BOOL CXTPGridRecordItem::SetEditable(BOOL bEditable)
1683{
1684 BOOL bOldEditable = m_bEditable;
1685 m_bEditable = bEditable;
1686 return bOldEditable;
1687}
1688
1689AFX_INLINE BOOL CXTPGridRecordItem::IsPreviewItem() const
1690{
1691 return FALSE;
1692}
1693
1694AFX_INLINE int CXTPGridRecordItem::GetIconIndex() const
1695{
1696 return m_nIconIndex;
1697}
1698
1699AFX_INLINE int CXTPGridRecordItem::SetIconIndex(int nIconIndex)
1700{
1701 int nOldID = GetIconIndex();
1702 m_nIconIndex = nIconIndex;
1703 return nOldID;
1704}
1705
1706AFX_INLINE int CXTPGridRecordItem::GetAlignment() const
1707{
1708 return m_Alignment;
1709}
1710
1711AFX_INLINE int CXTPGridRecordItem::SetAlignment(int nAlignment)
1712{
1713 int nOld = m_Alignment;
1714 m_Alignment = (XTPGridColumnIconAlignment)nAlignment;
1715 return nOld;
1716}
1717
1718AFX_INLINE int CXTPGridRecordItem::GetSortPriority() const
1719{
1720 return m_nSortPriority;
1721}
1722
1723AFX_INLINE void CXTPGridRecordItem::SetSortPriority(int nSortPriority)
1724{
1725 m_nSortPriority = nSortPriority;
1726}
1727
1728AFX_INLINE int CXTPGridRecordItem::GetGroupPriority() const
1729{
1730 return m_nGroupPriority;
1731}
1732
1733AFX_INLINE void CXTPGridRecordItem::SetGroupPriority(int nGroupPriority)
1734{
1735 m_nGroupPriority = nGroupPriority;
1736}
1737
1738AFX_INLINE void CXTPGridRecordItem::SetGroupCaption(LPCTSTR strCaption)
1739{
1740 m_strGroupCaption = strCaption;
1741}
1742
1743AFX_INLINE void CXTPGridRecordItem::SetChecked(BOOL bChecked)
1744{
1745 if (bChecked)
1746 {
1747 m_checkState = xtpGridCheckStateChecked;
1748 }
1749 else
1750 {
1751 m_checkState = xtpGridCheckStateUnchecked;
1752 }
1753}
1754
1755AFX_INLINE BOOL CXTPGridRecordItem::IsChecked() const
1756{
1757 return xtpGridCheckStateChecked == m_checkState;
1758}
1759
1760AFX_INLINE void CXTPGridRecordItem::SetCheckedState(int iState)
1761{
1762 if (m_bTristateCheckbox)
1763 {
1764 m_checkState = XTPGridCheckState(iState);
1765 }
1766 else
1767 {
1768 m_checkState = iState ? xtpGridCheckStateChecked : xtpGridCheckStateUnchecked;
1769 }
1770}
1771
1772AFX_INLINE int CXTPGridRecordItem::GetCheckedState() const
1773{
1774 if (m_bTristateCheckbox)
1775 {
1776 return m_checkState;
1777 }
1778 else
1779 {
1780 return m_checkState ? xtpGridCheckStateChecked : xtpGridCheckStateUnchecked;
1781 }
1782}
1783
1784AFX_INLINE void CXTPGridRecordItem::HasCheckbox(BOOL bHasCheckbox, BOOL bTristate)
1785{
1786 m_bHasCheckbox = bHasCheckbox;
1787 m_bTristateCheckbox = bTristate;
1788}
1789
1790AFX_INLINE BOOL CXTPGridRecordItem::GetHasCheckbox() const
1791{
1792 return m_bHasCheckbox;
1793}
1794
1795AFX_INLINE void CXTPGridRecordItem::SetRecord(CXTPGridRecord* pGridRecord)
1796{
1797 m_pRecord = pGridRecord;
1798 ResetMarkupUIElement();
1799}
1800
1801AFX_INLINE CXTPGridRecord* CXTPGridRecordItem::GetRecord() const
1802{
1803 return m_pRecord;
1804}
1805
1806AFX_INLINE void CXTPGridRecordItem::SetFocusable(BOOL bFocusable)
1807{
1808 m_bFocusable = bFocusable;
1809}
1810
1811AFX_INLINE DWORD_PTR CXTPGridRecordItem::GetItemData() const
1812{
1813 return m_dwData;
1814}
1815
1816AFX_INLINE void CXTPGridRecordItem::SetItemData(DWORD_PTR dwData)
1817{
1818 m_dwData = dwData;
1819}
1820
1821AFX_INLINE DWORD
1822 CXTPGridRecordItem::GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS* /*pItemArgs*/)
1823{
1824 return DWORD(-1);
1825}
1826
1827AFX_INLINE CString CXTPGridRecordItem::GetTooltip() const
1828{
1829 if (IsChildOfMerge())
1830 {
1831 return GetMergeItem()->m_strTooltip;
1832 }
1833 return m_strTooltip;
1834}
1835
1836AFX_INLINE void CXTPGridRecordItem::SetTooltip(LPCTSTR lpszTooltip)
1837{
1838 m_strTooltip = lpszTooltip;
1839}
1840
1841AFX_INLINE BOOL CXTPGridRecordItem::IsBold() const
1842{
1843 return m_bBoldText;
1844}
1845
1846AFX_INLINE CXTPMarkupUIElement* CXTPGridRecordItem::GetMarkupUIElement() const
1847{
1848 return m_pMarkupUIElement;
1849}
1850
1851AFX_INLINE void CXTPGridRecordItem::OnEditCanceled(XTP_GRIDRECORDITEM_ARGS* pItemArgs)
1852{
1853 UNREFERENCED_PARAMETER(pItemArgs);
1854}
1855
1856AFX_INLINE void CXTPGridRecordItem::SetGridControl(CXTPGridControl* pControl)
1857{
1858 m_pControl = pControl;
1859}
1861# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1862#endif //#if !defined(__XTPGRIDRECORDITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_GRID_NOICON
const int XTP_GRID_NOICON
This constant indicates that an icon ID is not defined.
Definition XTPGridDefines.h:409
XTP_GRID_COLOR_DEFAULT
const COLORREF XTP_GRID_COLOR_DEFAULT
This constant indicates that a COLORREF is not defined.
Definition XTPGridDefines.h:395
XTPGridCheckState
XTPGridCheckState
This enum defines the possible checkbox states.
Definition XTPGridDefines.h:79
xtpGridCheckStateUnchecked
@ xtpGridCheckStateUnchecked
The checkbox is in an unchecked state.
Definition XTPGridDefines.h:81
xtpGridCheckStateChecked
@ xtpGridCheckStateChecked
The checkbox is in a checked state.
Definition XTPGridDefines.h:82
XTPGridGroupRowIconAlignment
XTPGridGroupRowIconAlignment
This enum defines alignment style for the group row custom icon.
Definition XTPGridRecordItem.h:317
xtpGroupRowIconHmask
@ xtpGroupRowIconHmask
A mask for horizontal alignment flags.
Definition XTPGridRecordItem.h:326
xtpGroupRowIconUnknown
@ xtpGroupRowIconUnknown
Unknown (empty) value.
Definition XTPGridRecordItem.h:318
xtpGroupRowIconVCenterToText
@ xtpGroupRowIconVCenterToText
Vertical alignment: center of caption text rect.
Definition XTPGridRecordItem.h:330
xtpGroupRowIconAfterText
@ xtpGroupRowIconAfterText
Draw icon after caption text.
Definition XTPGridRecordItem.h:323
xtpGroupRowIconVCenter
@ xtpGroupRowIconVCenter
Vertical alignment: center of group row rect.
Definition XTPGridRecordItem.h:329
xtpGroupRowIconBeforeText
@ xtpGroupRowIconBeforeText
Draw icon before caption text (between Expand/Collapse icon and text).
Definition XTPGridRecordItem.h:321
xtpGroupRowIconRight
@ xtpGroupRowIconRight
Draw icon at the right side of group row rect.
Definition XTPGridRecordItem.h:324
xtpGroupRowIconLeft
@ xtpGroupRowIconLeft
Draw icon at the left side of group row rect.
Definition XTPGridRecordItem.h:320
xtpGroupRowIconVTop
@ xtpGroupRowIconVTop
Vertical alignment: top of group row rect.
Definition XTPGridRecordItem.h:328
xtpGroupRowIconVmask
@ xtpGroupRowIconVmask
A mask for vertical alignment flags.
Definition XTPGridRecordItem.h:333
xtpGroupRowIconVBottom
@ xtpGroupRowIconVBottom
Vertical alignment: bottom of group row rect.
Definition XTPGridRecordItem.h:331
XTPGridVirtualRowFlags
XTPGridVirtualRowFlags
This enum defines flags for virtual row metrics.
Definition XTPGridRecordItem.h:343
xtpVirtRowHasChildren
@ xtpVirtRowHasChildren
A row has children.
Definition XTPGridRecordItem.h:345
xtpVirtRowLastChild
@ xtpVirtRowLastChild
A row is the last child of its parent.
Definition XTPGridRecordItem.h:346
xtpVirtRowUnknown
@ xtpVirtRowUnknown
Unknown (empty) value.
Definition XTPGridRecordItem.h:344
XTPGridColumnIconAlignment
XTPGridColumnIconAlignment
This enum defines the alignment style for the column icon and text.
Definition XTPGridRecordItem.h:287
xtpColumnTextVCenter
@ xtpColumnTextVCenter
Centers text vertically.
Definition XTPGridRecordItem.h:291
xtpColumnIconRight
@ xtpColumnIconRight
Aligns icon to the right.
Definition XTPGridRecordItem.h:301
xtpColumnIconMask
@ xtpColumnIconMask
A mask for icon alignment styles.
Definition XTPGridRecordItem.h:307
xtpColumnTextRight
@ xtpColumnTextRight
Aligns text to the right.
Definition XTPGridRecordItem.h:290
xtpColumnIconCenter
@ xtpColumnIconCenter
Centers icon horizontally in the column.
Definition XTPGridRecordItem.h:300
xtpColumnIconLeft
@ xtpColumnIconLeft
Aligns icon to the left.
Definition XTPGridRecordItem.h:299
xtpColumnIconTop
@ xtpColumnIconTop
Aligns icon to the top.
Definition XTPGridRecordItem.h:303
xtpColumnTextMask
@ xtpColumnTextMask
A mask for text alignment styles.
Definition XTPGridRecordItem.h:297
xtpColumnTextCenter
@ xtpColumnTextCenter
Centers text horizontally in the column.
Definition XTPGridRecordItem.h:289
xtpColumnTextWordBreak
@ xtpColumnTextWordBreak
Breaks words.
Definition XTPGridRecordItem.h:292
xtpColumnIconBottom
@ xtpColumnIconBottom
Aligns icon to the bottom.
Definition XTPGridRecordItem.h:305
xtpColumnTextLeft
@ xtpColumnTextLeft
Aligns text to the left.
Definition XTPGridRecordItem.h:288
xtpColumnIconVCenter
@ xtpColumnIconVCenter
Aligns icon to the center.
Definition XTPGridRecordItem.h:304
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridHyperlink
This class represents hyperlinks.
Definition XTPGridHyperlink.h:112
CXTPGridHyperlinks
This class represents an array of pointers to CXTPGridHyperlink objects.
Definition XTPGridHyperlink.h:172
CXTPGridIconNavigator
Utility class, handles Grid control icon navigation.
Definition XTPGridNavigator.h:369
CXTPGridInplaceButton
CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and ex...
Definition XTPGridInplaceControls.h:220
CXTPGridInplaceButtons
This class represents a collection of in-place buttons for a single item of the Grid control.
Definition XTPGridRecordItem.h:429
CXTPGridInplaceButtons::CXTPGridInplaceButtons
CXTPGridInplaceButtons()
Constructs a CXTPGridInplaceButtons object.
CXTPGridNavigator
Utility class, handles Grid control item navigation.
Definition XTPGridNavigator.h:45
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItemConstraint
CXTPGridRecordItemConstraint is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:39
CXTPGridRecordItemConstraints
CXTPGridRecordItemConstraints is a CXTPCmdTarget derived class.
Definition XTPGridRecordItemConstraint.h:85
CXTPGridRecordItemControlHookWnd
This class represents an item control hook window.
Definition XTPGridRecordItemControls.h:763
CXTPGridRecordItemControl
This class represents a generic item control and handles control's behaviour, common for all derived ...
Definition XTPGridRecordItemControls.h:85
CXTPGridRecordItemControls
This class represents the inplace controls of a single item.
Definition XTPGridRecordItemControls.h:634
CXTPGridRecordItemEditOptions
This class represents edit options for a single item or column.
Definition XTPGridRecordItem.h:443
CXTPGridRecordItemEditOptions::m_bExpandOnSelect
BOOL m_bExpandOnSelect
TRUE to expand expandable contents on edit.
Definition XTPGridRecordItem.h:562
CXTPGridRecordItemEditOptions::AddConstraint
CXTPGridRecordItemConstraint * AddConstraint(LPCTSTR lpszConstraint, DWORD_PTR dwData=0)
Adds a new constraint to the constraint list.
CXTPGridRecordItemEditOptions::m_dwEditStyle
DWORD m_dwEditStyle
Edit Style (ES_MULTILINE, ES_NUMBER...).
Definition XTPGridRecordItem.h:563
CXTPGridRecordItemEditOptions::m_nMaxLength
int m_nMaxLength
Maximum number of characters that can be entered into an editable item (Edit limit).
Definition XTPGridRecordItem.h:564
CXTPGridRecordItemEditOptions::m_bSelectTextOnEdit
BOOL m_bSelectTextOnEdit
Select all text on edit.
Definition XTPGridRecordItem.h:560
CXTPGridRecordItemEditOptions::arrInplaceButtons
CXTPGridInplaceButtons arrInplaceButtons
Array of in-place buttons.
Definition XTPGridRecordItem.h:559
CXTPGridRecordItemEditOptions::GetButton
CXTPGridInplaceButton * GetButton(int nIndex)
Retrieves a button by its index.
CXTPGridRecordItemEditOptions::m_bScrollTextOnEdit
BOOL m_bScrollTextOnEdit
Scroll text on edit.
Definition XTPGridRecordItem.h:561
CXTPGridRecordItemEditOptions::FindConstraint
CXTPGridRecordItemConstraint * FindConstraint(DWORD_PTR dwData)
Finds a constraint by its value.
CXTPGridRecordItemEditOptions::AddSpinButton
CXTPGridInplaceButton * AddSpinButton(BOOL bInside=FALSE)
Adds a spin button to the CXTPGridRecordItem.
CXTPGridRecordItemEditOptions::RemoveButtons
void RemoveButtons()
Removes all buttons of the CXTPGridRecordItem.
CXTPGridRecordItemEditOptions::GetConstraints
CXTPGridRecordItemConstraints * GetConstraints()
Gets the constraints list.
Definition XTPGridRecordItem.h:493
CXTPGridRecordItemEditOptions::~CXTPGridRecordItemEditOptions
~CXTPGridRecordItemEditOptions()
Destroys a CXTPGridRecordItemEditOptions object, handles cleanup and deallocation.
CXTPGridRecordItemEditOptions::CXTPGridRecordItemEditOptions
CXTPGridRecordItemEditOptions()
Constructs a CXTPGridRecordItemEditOptions object.
CXTPGridRecordItemEditOptions::AddExpandButton
CXTPGridInplaceButton * AddExpandButton(BOOL bInside=FALSE)
Adds an expand button to the CXTPGridRecordItem.
CXTPGridRecordItemEditOptions::m_bConstraintEdit
BOOL m_bConstraintEdit
TRUE to prevent possibility to type in a custom value in the edit box if applicable.
Definition XTPGridRecordItem.h:556
CXTPGridRecordItemEditOptions::AddComboButton
CXTPGridInplaceButton * AddComboButton(BOOL bInside=FALSE)
Adds a drop-down combo button to the CXTPGridRecordItem.
CXTPGridRecordItemEditOptions::FindConstraint
CXTPGridRecordItemConstraint * FindConstraint(LPCTSTR lpszConstraint)
Finds a constraint by its caption.
CXTPGridRecordItemEditOptions::m_pConstraints
CXTPGridRecordItemConstraints * m_pConstraints
Constraint list.
Definition XTPGridRecordItem.h:558
CXTPGridRecordItemEditOptions::m_bAllowEdit
BOOL m_bAllowEdit
TRUE to enable changing the value of the field, FALSE to enable read-mode.
Definition XTPGridRecordItem.h:554
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::GetHasCheckbox
virtual BOOL GetHasCheckbox() const
Determines if item has check box area.
Definition XTPGridRecordItem.h:1790
CXTPGridRecordItem::GetCheckedState
int GetCheckedState() const
Gets the checked state of the record item.
Definition XTPGridRecordItem.h:1772
CXTPGridRecordItem::m_pBorder
CXTPGridBorder * m_pBorder
Item border.
Definition XTPGridRecordItem.h:1577
CXTPGridRecordItem::OnDrawControls
virtual void OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItem::~CXTPGridRecordItem
virtual ~CXTPGridRecordItem()
CXTPGridRecordItem default destructor.
CXTPGridRecordItem::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPGridRecordItem::GetSelectedConstraintData
virtual DWORD GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
Gets the value associated with a selected constraint.
Definition XTPGridRecordItem.h:1822
CXTPGridRecordItem::ResetMarkupUIElement
virtual void ResetMarkupUIElement()
Resets the Markup element.
CXTPGridRecordItem::m_strTooltip
CString m_strTooltip
Tooltip of the item.
Definition XTPGridRecordItem.h:1606
CXTPGridRecordItem::GetFormatString
virtual CString GetFormatString() const
Gets the record item caption format string.
Definition XTPGridRecordItem.h:1672
CXTPGridRecordItem::GetHyperlinkAt
virtual CXTPGridHyperlink * GetHyperlinkAt(int nHyperlink) const
Retrieves the hyperlink at a specified index.
CXTPGridRecordItem::Compare
virtual int Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the current record item with a provided record item.
CXTPGridRecordItem::OnEditChanging
virtual BOOL OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText)
This method is called before the value of the in-place editor is changed by the user.
CXTPGridRecordItem::OnEditCanceled
virtual void OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when in-place editing has been canceled and the value has not changed.
Definition XTPGridRecordItem.h:1851
CXTPGridRecordItem::SetTooltip
virtual void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip text for the record item.
Definition XTPGridRecordItem.h:1836
CXTPGridRecordItem::m_Alignment
XTPGridColumnIconAlignment m_Alignment
Alignment style for item.
Definition XTPGridRecordItem.h:1610
CXTPGridRecordItem::SetGridControl
void SetGridControl(CXTPGridControl *pControl)
Sets the parent grid object.
Definition XTPGridRecordItem.h:1856
CXTPGridRecordItem::OnRequestEdit
virtual BOOL OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when an editable item enters edit mode.
CXTPGridRecordItem::GetBorder
CXTPGridBorder * GetBorder() const
Gets the border of this item.
CXTPGridRecordItem::IsChecked
virtual BOOL IsChecked() const
Determines if the record item is checked.
Definition XTPGridRecordItem.h:1755
CXTPGridRecordItem::AddHyperlink
virtual int AddHyperlink(CXTPGridHyperlink *pHyperlink)
Adds a new hyperlink to the record item.
CXTPGridRecordItem::m_bItemControlUnderMouse
BOOL m_bItemControlUnderMouse
TRUE if an item control is under the mouse pointer.
Definition XTPGridRecordItem.h:1614
CXTPGridRecordItem::OnEditChanged
virtual void OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText)
This method is called when the value of the in-place edit control is changed.
CXTPGridRecordItem::m_rcGlyph
CRect m_rcGlyph
Coordinates of drawn glyph.
Definition XTPGridRecordItem.h:1616
CXTPGridRecordItem::m_pFocusedItemControl
CXTPGridRecordItemControl * m_pFocusedItemControl
Focused record item control.
Definition XTPGridRecordItem.h:1613
CXTPGridRecordItem::SetCanEditCheckboxItem
void SetCanEditCheckboxItem(BOOL bSet)
Specifies whether items with a check box will go into edit mode on click.
CXTPGridRecordItem::GetItemControls
CXTPGridRecordItemControls * GetItemControls()
Gets the item controls list.
CXTPGridRecordItem::OnChar
virtual BOOL OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar)
This method is called when the user presses a key.
CXTPGridRecordItem::HasCheckbox
virtual void HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE)
Adds check box area for item.
Definition XTPGridRecordItem.h:1784
CXTPGridRecordItem::m_pItemControls
CXTPGridRecordItemControls * m_pItemControls
Record item control list.
Definition XTPGridRecordItem.h:1612
CXTPGridRecordItem::m_bBoldText
BOOL m_bBoldText
TRUE if bold text.
Definition XTPGridRecordItem.h:1583
CXTPGridRecordItem::IsEditable
virtual BOOL IsEditable() const
Determines the editable state of the record item.
CXTPGridRecordItem::m_strFormatString
CString m_strFormatString
Stores string for extra formatting of item caption.
Definition XTPGridRecordItem.h:1585
CXTPGridRecordItem::GetFormula
virtual CString GetFormula() const
Gets the record item formula.
Definition XTPGridRecordItem.h:1662
CXTPGridRecordItem::SetSortPriority
virtual void SetSortPriority(int nSortPriority)
Sets the sort priority for the record item.
Definition XTPGridRecordItem.h:1723
CXTPGridRecordItem::m_strFormula
CString m_strFormula
Stores Formula with simple algorithm to calculate.
Definition XTPGridRecordItem.h:1586
CXTPGridRecordItem::m_bHasCheckbox
BOOL m_bHasCheckbox
TRUE if item has check box.
Definition XTPGridRecordItem.h:1601
CXTPGridRecordItem::HitTestHyperlink
virtual int HitTestHyperlink(CPoint ptClick)
Determines if a mouse click occurred on a hyperlink.
CXTPGridRecordItem::IsBold
virtual BOOL IsBold() const
Determines the bold state of the record item font.
Definition XTPGridRecordItem.h:1841
CXTPGridRecordItem::GetItemData
virtual DWORD_PTR GetItemData() const
Retrieves the application-supplied, 32-bit value associated with the record item.
Definition XTPGridRecordItem.h:1811
CXTPGridRecordItem::SetFormula
virtual void SetFormula(LPCTSTR sFormula)
Sets the record item formula.
Definition XTPGridRecordItem.h:1667
CXTPGridRecordItem::GetCaption
virtual CString GetCaption()
Gets the text caption of the item.
CXTPGridRecordItem::GetIconIndex
virtual int GetIconIndex() const
Gets the ID of the associated resource bitmap.
Definition XTPGridRecordItem.h:1694
CXTPGridRecordItem::GetItemMetrics
virtual void GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics)
Calculates preview item metrics based on specified draw arguments.
CXTPGridRecordItem::SetFormatString
virtual void SetFormatString(LPCTSTR strFormat)
Sets the record item caption format string.
Definition XTPGridRecordItem.h:1677
CXTPGridRecordItem::GetCanEditCheckboxItem
BOOL GetCanEditCheckboxItem() const
Returns whether items with a check box will go into edit mode on click.
CXTPGridRecordItem::GetRecord
CXTPGridRecord * GetRecord() const
Gets the parent record object.
Definition XTPGridRecordItem.h:1801
CXTPGridRecordItem::SetIconIndex
virtual int SetIconIndex(int nIconIndex)
Sets the ID for the associated resource bitmap.
Definition XTPGridRecordItem.h:1699
CXTPGridRecordItem::m_bCanEditCheckboxItem
BOOL m_bCanEditCheckboxItem
TRUE if an item with a check box will get an edit control (only useful if column is wide)
Definition XTPGridRecordItem.h:1602
CXTPGridRecordItem::RemoveHyperlinkAt
virtual void RemoveHyperlinkAt(int nHyperlink)
Removes the hyperlink at a specified index.
CXTPGridRecordItem::HitTest
CXTPGridRecordItemControl * HitTest(CPoint ptPoint)
Determines which grid record item control, if any, is at a specified point.
CXTPGridRecordItem::m_bEditable
BOOL m_bEditable
Stores editable flag.
Definition XTPGridRecordItem.h:1588
CXTPGridRecordItem::m_pEditOptions
CXTPGridRecordItemEditOptions * m_pEditOptions
Edit options of the item.
Definition XTPGridRecordItem.h:1608
CXTPGridRecordItem::GetSortPriority
virtual int GetSortPriority() const
Gets the sort priority of the record item.
Definition XTPGridRecordItem.h:1718
CXTPGridRecordItem::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI)
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPGridRecordItem::GetBackgroundColor
virtual COLORREF GetBackgroundColor()
Gets the record item text background color.
CXTPGridRecordItem::SetAlignment
int SetAlignment(int nAlignment)
Sets the alignment value for the record item.
Definition XTPGridRecordItem.h:1711
CXTPGridRecordItem::m_nGroupPriority
int m_nGroupPriority
Group priority.
Definition XTPGridRecordItem.h:1594
CXTPGridRecordItem::GetHyperlinks
CXTPGridHyperlinks * GetHyperlinks()
Gets the hyperlinks collection.
CXTPGridRecordItem::SetItemData
virtual void SetItemData(DWORD_PTR dwData)
Sets the 32-bit value associated with the record item.
Definition XTPGridRecordItem.h:1816
CXTPGridRecordItem::GetColumnCaptionPrefix
CString GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const
Gets the caption prefix of a specified column.
CXTPGridRecordItem::UpdateValue
void UpdateValue()
Causes formula computed value to be updated.
CXTPGridRecordItem::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CXTPGridRecordItem::CXTPGridRecordItem
CXTPGridRecordItem()
CXTPGridRecordItem default constructor.
CXTPGridRecordItem::m_checkState
int m_checkState
TRUE if item checked.
Definition XTPGridRecordItem.h:1600
CXTPGridRecordItem::OnInplaceButtonDown
virtual void OnInplaceButtonDown(CXTPGridInplaceButton *pButton)
This method is called when the user presses the in-place button of the item.
CXTPGridRecordItem::m_pHyperlinks
CXTPGridHyperlinks * m_pHyperlinks
Array of the Item's hyperlinks.
Definition XTPGridRecordItem.h:1589
CXTPGridRecordItem::SetEditable
virtual BOOL SetEditable(BOOL bEditable=TRUE)
Sets the editable state for the record item.
Definition XTPGridRecordItem.h:1682
CXTPGridRecordItem::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup element.
Definition XTPGridRecordItem.h:1618
CXTPGridRecordItem::SetBold
virtual void SetBold(BOOL bBold=TRUE)
Sets the bold state of the record item font.
CXTPGridRecordItem::SetBackgroundColor
virtual void SetBackgroundColor(COLORREF clrBackground)
Sets the record item text background color.
CXTPGridRecordItem::GetAlignment
int GetAlignment() const
Gets the alignment value of the record item.
Definition XTPGridRecordItem.h:1706
CXTPGridRecordItem::GetGroupCaption
virtual CString GetGroupCaption(CXTPGridColumn *pColumn)
Gets the group caption text.
CXTPGridRecordItem::GetFont
virtual CFont * GetFont()
Gets the record item text font.
CXTPGridRecordItem::SetGroupPriority
virtual void SetGroupPriority(int nGroupPriority)
Sets the group priority for the record item.
Definition XTPGridRecordItem.h:1733
CXTPGridRecordItem::m_pControl
CXTPGridControl * m_pControl
Parent Grid control.
Definition XTPGridRecordItem.h:1575
CXTPGridRecordItem::GetTextColor
virtual COLORREF GetTextColor()
Gets the record item text color.
CXTPGridRecordItem::GetCaptionRect
virtual void GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem)
Retrieves the caption text bounding rectangle.
CXTPGridRecordItem::SetTextColor
virtual void SetTextColor(COLORREF clrText)
Sets the record item text color.
CXTPGridRecordItem::OnDblClick
virtual void OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
CXTPGridRecordItem::m_pRecord
CXTPGridRecord * m_pRecord
Pointer to the associated record.
Definition XTPGridRecordItem.h:1576
CXTPGridRecordItem::SetChecked
virtual void SetChecked(BOOL bChecked)
Sets if the record item is checked.
Definition XTPGridRecordItem.h:1743
CXTPGridRecordItem::OnConstraintChanged
virtual void OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint)
This method is called when the value of the selected contraint of the in-place list is changed by the...
CXTPGridRecordItem::m_clrBackground
COLORREF m_clrBackground
Storage for item background color.
Definition XTPGridRecordItem.h:1582
CXTPGridRecordItem::GetGroupPriority
virtual int GetGroupPriority() const
Gets the group priority of the record item.
Definition XTPGridRecordItem.h:1728
CXTPGridRecordItem::m_strGroupCaption
CString m_strGroupCaption
Caption of the group.
Definition XTPGridRecordItem.h:1596
CXTPGridRecordItem::m_nSortPriority
int m_nSortPriority
Sort priority.
Definition XTPGridRecordItem.h:1593
CXTPGridRecordItem::SetCheckedState
void SetCheckedState(int iState)
Sets the checked state for the record item.
Definition XTPGridRecordItem.h:1760
CXTPGridRecordItem::OnLButtonUp
virtual BOOL OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
CXTPGridRecordItem::Draw
virtual int Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItem::SetGroupCaption
virtual void SetGroupCaption(LPCTSTR strCaption)
Sets the group caption for the record item.
Definition XTPGridRecordItem.h:1738
CXTPGridRecordItem::IsFocusable
virtual BOOL IsFocusable() const
Determines if the record item can receive focus.
CXTPGridRecordItem::CreateBorder
BOOL CreateBorder()
Creates a border for this item.
CXTPGridRecordItem::OnLButtonDown
virtual BOOL OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
CXTPGridRecordItem::m_nIconIndex
int m_nIconIndex
ID of the bitmap from the application resources.
Definition XTPGridRecordItem.h:1591
CXTPGridRecordItem::GetEditOptions
CXTPGridRecordItemEditOptions * GetEditOptions(CXTPGridColumn *pColumn)
Gets the edit options of the item.
CXTPGridRecordItem::OnClick
virtual void OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
CXTPGridRecordItem::DestroyBorder
BOOL DestroyBorder()
Destroys the border of this item.
CXTPGridRecordItem::GetGroupCaptionID
virtual int GetGroupCaptionID(CXTPGridColumn *pColumn)
Gets the group caption ID.
CXTPGridRecordItem::m_pFontCaption
CFont * m_pFontCaption
Storage for item caption font.
Definition XTPGridRecordItem.h:1579
CXTPGridRecordItem::SetFont
virtual void SetFont(CFont *pFont)
Sets the record item text font.
CXTPGridRecordItem::m_dwData
DWORD_PTR m_dwData
The 32-bit value associated with the item.
Definition XTPGridRecordItem.h:1605
CXTPGridRecordItem::m_bFocusable
BOOL m_bFocusable
TRUE if item accept focus.
Definition XTPGridRecordItem.h:1598
CXTPGridRecordItem::OnBeginEdit
virtual void OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called when the user begins to edit an item.
CXTPGridRecordItem::m_pItemControlHookWnd
CXTPGridRecordItemControlHookWnd * m_pItemControlHookWnd
Item control hook window.
Definition XTPGridRecordItem.h:1615
CXTPGridRecordItem::m_clrText
COLORREF m_clrText
Storage for item text color.
Definition XTPGridRecordItem.h:1581
CXTPGridRecordItem::GetTooltip
virtual CString GetTooltip() const
Gets the tooltip text of the record item.
Definition XTPGridRecordItem.h:1827
CXTPGridRecordItem::SetFocusable
virtual void SetFocusable(BOOL bFocusable)
Specifies if the record item can receive focus.
Definition XTPGridRecordItem.h:1806
CXTPGridRecordItem::DrawCheckBox
virtual void DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem)
Draws the check box bitmap.
CXTPGridRecordItem::SetCaption
virtual void SetCaption(LPCTSTR strCaption)
Sets the caption for the record item.
CXTPGridRecordItem::IsChildOfMerge
BOOL IsChildOfMerge() const
Determines if the current item is in a merge group and, if so, if it is not the left-top (main) item ...
CXTPGridRecordItem::m_bTristateCheckbox
BOOL m_bTristateCheckbox
TRUE if the check box is tri-state.
Definition XTPGridRecordItem.h:1604
CXTPGridRecordItem::IsPreviewItem
virtual BOOL IsPreviewItem() const
Determines if the record item is a preview item.
Definition XTPGridRecordItem.h:1689
CXTPGridRecordItem::GetCaption
virtual CString GetCaption(CXTPGridColumn *pColumn)
Retrieves the text caption of the record item.
CXTPGridRecordItem::SetRecord
void SetRecord(CXTPGridRecord *pGridRecord)
Sets the parent record object.
Definition XTPGridRecordItem.h:1795
CXTPGridRecordItem::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow)
Compares the group caption of the current record item with the group caption of a provided record ite...
CXTPGridRecordItem::GetGroupCaptionValue
virtual COleVariant GetGroupCaptionValue(CXTPGridColumn *pColumn)
Gets the group caption native value.
CXTPGridRecordItem::GetIndex
int GetIndex() const
Gets the index of the record item.
CXTPGridRecordItem::OnCancelEdit
virtual void OnCancelEdit(CXTPGridControl *pControl, BOOL bApply)
This method is called when the user cancels editing an item.
CXTPGridRecordItem::OnValidateEdit
virtual void OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs)
This method is called to save the value from an in-place edit.
CXTPGridRecordItem::CompareGroupCaption
virtual int CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem)
Compares the group caption of the current record item with the group caption of a provided record ite...
CXTPGridRecordItem::OnDrawCaption
virtual void OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Should be overridden by descendants for drawing itself.
CXTPGridRecordItem::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
Gets the Markup element that renders the item.
Definition XTPGridRecordItem.h:1846
CXTPGridRecordItem::m_strCaption
CString m_strCaption
Caption of the item.
Definition XTPGridRecordItem.h:1597
CXTPGridRecordItem::GetHyperlinksCount
virtual int GetHyperlinksCount() const
Gets the number of hyperlinks in the record item.
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPHeapObjectT
This template class used as a helper class to override new/delete operators and use custom heap alloc...
Definition XTPCustomHeap.h:335
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_GRIDRECORDITEM_ARGS
Basic set of parameters transferred to item handlers.
Definition XTPGridRecordItem.h:69
XTP_GRIDRECORDITEM_ARGS::pColumn
CXTPGridColumn * pColumn
Grid column at click position, if any, NULL otherwise.
Definition XTPGridRecordItem.h:99
XTP_GRIDRECORDITEM_ARGS::rcItem
CRect rcItem
Item position in control client coordinates.
Definition XTPGridRecordItem.h:101
XTP_GRIDRECORDITEM_ARGS::pRow
CXTPGridRow * pRow
Pointer to the associated row.
Definition XTPGridRecordItem.h:98
XTP_GRIDRECORDITEM_ARGS::pControl
CXTPGridControl * pControl
Pointer to the main Grid control.
Definition XTPGridRecordItem.h:97
XTP_GRIDRECORDITEM_ARGS::pItem
CXTPGridRecordItem * pItem
Pointer to the associated item.
Definition XTPGridRecordItem.h:100
XTP_GRIDRECORDITEM_CLICKARGS
A set of parameters transferred to mouse click item handlers.
Definition XTPGridRecordItem.h:149
XTP_GRIDRECORDITEM_CLICKARGS::ptClient
CPoint ptClient
Coordinates of the mouse click point.
Definition XTPGridRecordItem.h:150
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_DRAWARGS::nTextAlign
int nTextAlign
Text alignment mode (DT_LEFT || DT_RIGHT || DT_CENTER).
Definition XTPGridRecordItem.h:135
XTP_GRIDRECORDITEM_DRAWARGS::pDC
CDC * pDC
Pointer to control drawing context.
Definition XTPGridRecordItem.h:134
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356
XTP_GRIDRECORDITEM_METRICS::pFont
CFont * pFont
Drawing font.
Definition XTPGridRecordItem.h:357
XTP_GRIDRECORDITEM_METRICS::nVirtRowFlags
int nVirtRowFlags
Virtual row flags.
Definition XTPGridRecordItem.h:367
XTP_GRIDRECORDITEM_METRICS::clrForeground
COLORREF clrForeground
Item foreground color.
Definition XTPGridRecordItem.h:358
XTP_GRIDRECORDITEM_METRICS::nVirtRowLevel
int nVirtRowLevel
Virtual row level.
Definition XTPGridRecordItem.h:366
XTP_GRIDRECORDITEM_METRICS::clrBackground
COLORREF clrBackground
Item background color.
Definition XTPGridRecordItem.h:359
XTP_GRIDRECORDITEM_METRICS::nGroupRowIcon
int nGroupRowIcon
Group row icon ID.
Definition XTPGridRecordItem.h:362
XTP_GRIDRECORDITEM_METRICS::nColumnAlignment
int nColumnAlignment
Column alignment.
Definition XTPGridRecordItem.h:364
XTP_GRIDRECORDITEM_METRICS::nGroupRowIconAlignment
int nGroupRowIconAlignment
Group row icon alignment.
Definition XTPGridRecordItem.h:363
XTP_GRIDRECORDITEM_METRICS::strText
CString strText
Item text.
Definition XTPGridRecordItem.h:360
XTP_GRIDRECORDITEM_METRICS::nItemIcon
int nItemIcon
Item icon ID.
Definition XTPGridRecordItem.h:365
XTP_NM_GRID_BEFORE_COPYPASTE
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:241
XTP_NM_GRID_BEFORE_COPYPASTE::parStrings
CStringArray * parStrings
[in/out] A pointer to a strings array with record items values.
Definition XTPGridRecordItem.h:245
XTP_NM_GRID_BEFORE_COPYPASTE::hdr
NMHDR hdr
Standard structure; contains information about a notification message.
Definition XTPGridRecordItem.h:242
XTP_NM_GRID_BEFORE_COPYPASTE::ppRecord
CXTPGridRecord ** ppRecord
[in/out] A pointer to a record pointer.
Definition XTPGridRecordItem.h:244
XTP_NM_GRIDCONSTRAINTSELECTING
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:260
XTP_NM_GRIDCONSTRAINTSELECTING::pConstraint
CXTPGridRecordItemConstraint * pConstraint
Pointer to the constraint associated with the.
Definition XTPGridRecordItem.h:261
XTP_NM_GRIDINPLACEBUTTON
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:223
XTP_NM_GRIDINPLACEBUTTON::pButton
CXTPGridInplaceButton * pButton
Pointer to in-place button.
Definition XTPGridRecordItem.h:224
XTP_NM_GRIDRECORDITEM
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:179
XTP_NM_GRIDRECORDITEM::pColumn
CXTPGridColumn * pColumn
Pointer to the column associated with the notification.
Definition XTPGridRecordItem.h:183
XTP_NM_GRIDRECORDITEM::nHyperlink
int nHyperlink
Index of clicked Hyperlink, if any, or -1 otherwise.
Definition XTPGridRecordItem.h:184
XTP_NM_GRIDRECORDITEM::pRow
CXTPGridRow * pRow
Pointer to the row associated with the notification.
Definition XTPGridRecordItem.h:181
XTP_NM_GRIDRECORDITEM::hdr
NMHDR hdr
Standard structure; contains information about a notification message.
Definition XTPGridRecordItem.h:180
XTP_NM_GRIDRECORDITEM::pt
POINT pt
Point where the message ocurred.
Definition XTPGridRecordItem.h:185
XTP_NM_GRIDRECORDITEM::pItem
CXTPGridRecordItem * pItem
Pointer to the record item associated with the notification.
Definition XTPGridRecordItem.h:182
XTP_NM_GRIDREQUESTEDIT
A set of parameters transferred with an XTP_NM_GRID_REQUESTEDIT message.
Definition XTPGridRecordItem.h:197
XTP_NM_GRIDREQUESTEDIT::bCancel
BOOL bCancel
TRUE to cancel operation.
Definition XTPGridRecordItem.h:198
XTP_NM_GRIDTOOLTIPINFO
This structure is sent to the Main window in a WM_NOTIFY message from Item and provides all parameter...
Definition XTPGridRecordItem.h:278
XTP_NM_GRIDTOOLTIPINFO::pstrText
CString * pstrText
Pointer to a CString object with Tooltip text.
Definition XTPGridRecordItem.h:279


CXTPChartRadarLineSeriesStyle Member List

This is the complete list of members for CXTPChartRadarLineSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartRadarDiagramSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarLineSeriesStyle | protectedvirtual
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle |
CXTPChartRadarLineSeriesStyle() | CXTPChartRadarLineSeriesStyle |
CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarLineSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineStyle() const | CXTPChartRadarLineSeriesStyle |
GetMarker() const | CXTPChartRadarPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartRadarDiagramSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRadarDiagramSeriesStyle() | CXTPChartRadarDiagramSeriesStyle | virtual
~CXTPChartRadarLineSeriesStyle() | CXTPChartRadarLineSeriesStyle | virtual
~CXTPChartRadarPointSeriesStyle() | CXTPChartRadarPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


CXTPSkinManagerSchemaProperty Member List

This is the complete list of members for CXTPSkinManagerSchemaProperty, including all inherited members.

bVal | CXTPSkinManagerSchemaProperty |
ClearProperty() | CXTPSkinManagerSchemaProperty |
clrVal | CXTPSkinManagerSchemaProperty |
CXTPSkinManagerSchemaProperty() | CXTPSkinManagerSchemaProperty |
GetAccessCriticalSection() const | CXTPSynchronized | inline
iVal | CXTPSkinManagerSchemaProperty |
lfVal | CXTPSkinManagerSchemaProperty |
lpszVal | CXTPSkinManagerSchemaProperty |
nPropertyCode | CXTPSkinManagerSchemaProperty |
propType | CXTPSkinManagerSchemaProperty |
rcVal | CXTPSkinManagerSchemaProperty |
SetPropertyBool(LPCTSTR lpszValue) | CXTPSkinManagerSchemaProperty |
SetPropertyColor(LPCTSTR lpszValue) | CXTPSkinManagerSchemaProperty |
SetPropertyEnum(int nEnumValue) | CXTPSkinManagerSchemaProperty |
SetPropertyFont(LPCTSTR lpszValue) | CXTPSkinManagerSchemaProperty |
SetPropertyInt(LPCTSTR lpszValue) | CXTPSkinManagerSchemaProperty |
SetPropertyRect(LPCTSTR lpszValue) | CXTPSkinManagerSchemaProperty |
SetPropertySize(LPCTSTR lpszValue) | CXTPSkinManagerSchemaProperty |
SetPropertyString(LPCTSTR lpszValue) | CXTPSkinManagerSchemaProperty |
szVal | CXTPSkinManagerSchemaProperty |
~CXTPSkinManagerSchemaProperty() | CXTPSkinManagerSchemaProperty |


Toolkit Pro: XTPRibbonBackstageButtonThemeResource.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMERESOURCE_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
32# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
35class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeResource : public CXTPButtonThemeResource
36{
37public:
38 CXTPRibbonBackstageButtonThemeResource();
39
40public:
41 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
42 virtual void DrawButton(CDC* pDC, CXTPButton* pButton);
43
44protected:
45 friend class CBackstageButtonCtrl;
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonTheme::DrawButton
virtual void DrawButton(CDC *pDC, CXTPButton *pButton)
This member function is called to the button.
CXTPButtonThemeResource
CXTPButtonThemeResource is a class used to perform Office 2007 Theme drawing tasks.
Definition XTPButtonThemeResource.h:39
CXTPButtonThemeResource::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.


CXTPCalendarView Member List

This is the complete list of members for CXTPCalendarView, including all inherited members.

_CalculateEventTimeFormat() | CXTPCalendarView | protectedvirtual
_CanSubjectEditor(UINT idEditCmd) const | CXTPCalendarView | protectedvirtual
_CopySelectedEvents(DWORD dwCopyFlags=0) | CXTPCalendarView | protectedvirtual
_GetDayHeaderFormat(int nLevel) const | CXTPCalendarView | protectedvirtual
_GetMaxWidth(CDC *pDC, CString strFormat) const | CXTPCalendarView | protectedvirtual
_GetMaxWidthFormat(CDC *pDC, CString strFormat, BOOL bMonth) const | CXTPCalendarView | protectedvirtual
_GetSubjectEditorWnd() const | CXTPCalendarView | protectedvirtual
_GetViewDay(const COleDateTime &dtDay) const | CXTPCalendarView | virtual
_IsDragModeCopyMove(int eDragMode) const | CXTPCalendarView | protected
_ReadDefaultHeaderFormats() | CXTPCalendarView | protectedvirtual
_ReadEventsFromClipboard(COleDataObject *pData, DWORD *pdwCopyFlags=NULL) | CXTPCalendarView | protectedvirtual
_RemoveYearPart(CString &strFormat) | CXTPCalendarView | protectedvirtual
_Undo(CXTPCalendarEvent *pEvent=NULL) | CXTPCalendarView | protectedvirtual
AddToDiscreteSelection(UINT id) | CXTPCalendarView |
AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarView | virtual
AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarView | virtual
CalculateHeaderFormat(CDC *pDC, int nWidth, CFont *pTextFont) | CXTPCalendarView | virtual
CancelDraggingEvent() | CXTPCalendarView | virtual
CanCopy() const | CXTPCalendarView | virtual
CanCut() const | CXTPCalendarView | virtual
CanPaste() const | CXTPCalendarView | virtual
CanRedo() const | CXTPCalendarView | virtual
CanUndo() const | CXTPCalendarView | virtual
ClearDiscreteSelection() | CXTPCalendarView |
CommitDraggingEvent() | CXTPCalendarView | virtual
Copy() | CXTPCalendarView | virtual
Cut() | CXTPCalendarView | virtual
CXTPCalendarView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarView |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarView | inlinevirtual
Draw2(CDC *pDC) | CXTPCalendarView | inlinevirtual
EmptyUndoBuffer() | CXTPCalendarView | virtual
EnableHScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EnableVScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EndEditSubject(XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE) | CXTPCalendarView | virtual
FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL) | CXTPCalendarView | virtual
FindLastSelectedDay() const | CXTPCalendarView |
FindViewEvent(CXTPCalendarEvent *pEvent, COleDateTime dtDay) const | CXTPCalendarView | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarView | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarView |
GetCalendarOptions() const | CXTPCalendarView |
GetChildHandlerAt(int nIndex) const | CXTPCalendarView | virtual
GetChildHandlersCount() const | CXTPCalendarView | virtual
GetDayHeaderFormat() const | CXTPCalendarView | virtual
GetDiscreteSelectionCount() const | CXTPCalendarView |
GetDiscreteSelectionValue(UINT id) const | CXTPCalendarView |
GetDraggingEventNew() const | CXTPCalendarView | virtual
GetDraggingEventOrig() const | CXTPCalendarView | virtual
GetDraggingMode() const | CXTPCalendarView | virtual
GetEventDurationMin() const | CXTPCalendarView | protectedvirtual
GetItemTextEventTimeMax() const | CXTPCalendarView | virtual
GetLastSelectedDate() const | CXTPCalendarView |
GetLastSelectedViewEvent() const | CXTPCalendarView |
GetNextTimeEditByTAB() const | CXTPCalendarView | virtual
GetPaintManager() const | CXTPCalendarView | virtual
GetResources() const | CXTPCalendarView | virtual
GetRowHeight() const | CXTPCalendarView | virtual
GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const | CXTPCalendarView | inlinevirtual
GetScrollBarInfoV(SCROLLINFO *pSI) const | CXTPCalendarView | inlinevirtual
GetSelectedEvents() const | CXTPCalendarView | virtual
GetSelectedViewEvents() const | CXTPCalendarView | virtual
GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const | CXTPCalendarView | virtual
GetShowToolTipTimeOut() const | CXTPCalendarView | virtual
GetStartEditSubjectTimeOut() const | CXTPCalendarView | virtual
GetSubjectEditorRect() const | CXTPCalendarView | virtual
GetTheme() const | CXTPCalendarView | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarView | virtual
GetViewDay_(int nIndex) const | CXTPCalendarView | virtual
GetViewDayCount() const | CXTPCalendarView | virtual
GetViewDayDate(int nIndex) const =0 | CXTPCalendarView | pure virtual
GetViewRect() const | CXTPCalendarView |
GetViewType() const =0 | CXTPCalendarView | pure virtual
HasSelectedViewEvent() const | CXTPCalendarView | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
IsEditingSubject() const | CXTPCalendarView | virtual
IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const | CXTPCalendarView | protected
IsHScrollEnabled() const | CXTPCalendarView | virtual
IsInDiscreteSelection(UINT id) const | CXTPCalendarView |
IsSingleEventSelected() const | CXTPCalendarView |
IsTodayVisible() const | CXTPCalendarView | virtual
IsVScrollEnabled() const | CXTPCalendarView | virtual
KillTimer(UINT uTimerID) | CXTPCalendarView | protectedvirtual
m_arDays | CXTPCalendarView | mutableprotected
m_bResetUndoBuffer | CXTPCalendarView | protected
m_bScrollH_Disabled | CXTPCalendarView | protected
m_bScrollV_Disabled | CXTPCalendarView | protected
m_bStartedClickInside | CXTPCalendarView | protected
m_cntSelChanged | CXTPCalendarView | protected
m_eDraggingMode | CXTPCalendarView | protected
m_eUndoMode | CXTPCalendarView | protected
m_EventTimeFormat | CXTPCalendarView | protected
m_LastHitInfo | CXTPCalendarView | protected
m_Layout | CXTPCalendarView | protected
m_nKeyStateTimerID | CXTPCalendarView | protected
m_nTimerID_ShowToolTip | CXTPCalendarView | protected
m_nTimerID_StartEditSubject | CXTPCalendarView | protected
m_pControl | CXTPCalendarView | protected
m_pLastEvent | CXTPCalendarView | protected
m_pPrevUndoBuffer | CXTPCalendarView | protected
m_pResources | CXTPCalendarView | protected
m_pSelectedEvents | CXTPCalendarView | protected
m_ptrDraggingEventNew | CXTPCalendarView | protected
m_ptrDraggingEventOrig | CXTPCalendarView | protected
m_ptrEditingViewEvent | CXTPCalendarView | protected
m_ptStartDragging | CXTPCalendarView | protected
m_pUndoBuffer | CXTPCalendarView | protected
m_rcTooltip | CXTPCalendarView | protected
m_rcView | CXTPCalendarView | protected
m_selectedBlock | CXTPCalendarView | protected
m_spDraggingStartOffset | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultLong | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShort | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShortest | CXTPCalendarView | protected
m_strDayHeaderFormatLong | CXTPCalendarView | protected
m_strDayHeaderFormatMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatShort | CXTPCalendarView | protected
m_strDayHeaderFormatShortest | CXTPCalendarView | protected
m_strHeaderFormat | CXTPCalendarView | protected
OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView) | CXTPCalendarView | protectedvirtual
OnBeforeDestroy() | CXTPCalendarView | protectedvirtual
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) | CXTPCalendarView | protected
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews) | CXTPCalendarView | protected
OnBeforePasteNotify(CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent) | CXTPCalendarView | protected
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnDraw(CDC *pDC) | CXTPCalendarView | virtual
OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo) | CXTPCalendarView | virtual
OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent) | CXTPCalendarView | protectedvirtual
OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject) | CXTPCalendarView | protected
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnScrollEnd(int nBar) | CXTPCalendarView | inlinevirtual
OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarView | protectedvirtual
OnUpdateEditingSubject(CString strNewSubject) | CXTPCalendarView | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Paste() | CXTPCalendarView | virtual
Populate() | CXTPCalendarView | virtual
ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
ProcessEventSelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
Redo() | CXTPCalendarView | virtual
RedrawControl() | CXTPCalendarView | virtual
ResetCustomTimeFormat() | CXTPCalendarView |
ResetSelection() | CXTPCalendarView |
RetrieveDayEvents(CXTPCalendarResource *pRC, COleDateTime dtDay) | CXTPCalendarView | virtual
ScrollH(int nPos, int nPos_raw) | CXTPCalendarView | inlinevirtual
ScrollV(int nPos, int nPos_raw) | CXTPCalendarView | inlinevirtual
SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDay(COleDateTime dtSelDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDays(COleDateTime dtNewSel) | CXTPCalendarView | virtual
SelectEvent(CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE) | CXTPCalendarView | virtual
SelectionContains(COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL) | CXTPCalendarView |
SelectViewEvent(CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE) | CXTPCalendarView |
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0) | CXTPCalendarView | protectedvirtual
SetCustomTimeFormat(const CString &strFormat) | CXTPCalendarView |
SetDayHeaderFormat(LPCTSTR sFmt) | CXTPCalendarView | virtual
SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDraggingEvent(CXTPCalendarEvent *pEventOrig) | CXTPCalendarView | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarView | virtual
SetSelection(const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0) | CXTPCalendarView |
SetTimer(UINT uTimeOut_ms) | CXTPCalendarView | protectedvirtual
ShowDay(const COleDateTime &date, BOOL bSelect=TRUE)=0 | CXTPCalendarView | pure virtual
ShowToolTip(BOOL bShow=TRUE) | CXTPCalendarView | virtual
StartEditNewEventInplace(LPCTSTR pcszInitialSubject) | CXTPCalendarView | virtual
StartEditSubject(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarView | virtual
Undo() | CXTPCalendarView | virtual
UnselectAllEvents() | CXTPCalendarView | virtual
UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE) | CXTPCalendarView | virtual
~CXTPCalendarView() | CXTPCalendarView | virtual


CXTPCalendarVisualStudio2019Theme Member List

This is the complete list of members for CXTPCalendarVisualStudio2019Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCalendarVisualStudio2019Theme() | CXTPCalendarVisualStudio2019Theme |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
CXTPCalendarOffice2000Theme::GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetEventEdgeColor(CXTPCalendarEvent *pEvent) | CXTPCalendarOffice2013Theme | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2013Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarOffice2013Theme | virtual
UpdateGlyphs() | CXTPCalendarOffice2013Theme | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2013Theme() | CXTPCalendarOffice2013Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual
~CXTPCalendarVisualStudio2019Theme() | CXTPCalendarVisualStudio2019Theme | virtual


CXTPFlowGraphNodeGroup Member List

This is the complete list of members for CXTPFlowGraphNodeGroup, including all inherited members.

AddNode(CXTPFlowGraphNode *pNode) | CXTPFlowGraphNodeGroup |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphElement() | CXTPFlowGraphElement |
CXTPFlowGraphNodeGroup() | CXTPFlowGraphNodeGroup |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphNodeGroup |
GetCaption() const | CXTPFlowGraphNodeGroup | virtual
GetControl() const | CXTPFlowGraphNodeGroup | virtual
GetCount() const | CXTPFlowGraphNodeGroup |
GetPage() const | CXTPFlowGraphNodeGroup | virtual
GetWorkRect() const | CXTPFlowGraphNodeGroup |
IsSelected() const | CXTPFlowGraphElement |
m_arrNodes | CXTPFlowGraphNodeGroup | protected
m_bDirty | CXTPFlowGraphElement |
m_bSelected | CXTPFlowGraphElement | protected
m_pGroups | CXTPFlowGraphNodeGroup | protected
m_rcWorkRect | CXTPFlowGraphNodeGroup | protected
OnGraphChanged() | CXTPFlowGraphElement |
OnRemoved() | CXTPFlowGraphElement | virtual
Remove() | CXTPFlowGraphNodeGroup |
RemoveAll() | CXTPFlowGraphNodeGroup |
RemoveNode(CXTPFlowGraphNode *pNode) | CXTPFlowGraphNodeGroup |
SetCaption(LPCTSTR lpszCaption) | CXTPFlowGraphNodeGroup | virtual
~CXTPFlowGraphElement() | CXTPFlowGraphElement | virtual
~CXTPFlowGraphNodeGroup() | CXTPFlowGraphNodeGroup | virtual


CXTPChartRangeBarSeriesStyle Member List

This is the complete list of members for CXTPChartRangeBarSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartBarSeriesStyle | protectedvirtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRangeBarSeriesStyle | protectedvirtual
CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesStyle() | CXTPChartRangeBarSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRangeBarSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBarWidth() const | CXTPChartBarSeriesStyle |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetBarWidth(double dWidth) | CXTPChartBarSeriesStyle |
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartBarSeriesStyle() | CXTPChartBarSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRangeBarSeriesStyle() | CXTPChartRangeBarSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPExcelTabCtrlTheme.h Source File

  • Source
  • Controls
  • Tab
XTPExcelTabCtrlTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPEXCELTABCTRLTHEME_H__)
24# define __XTPEXCELTABCTRLTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTcbItem;
34class CXTPExcelTabCtrl;
35class CXTPExcelTabCtrlButtonState;
36
42class _XTP_EXT_CLASS CXTPExcelTabCtrlTheme : public CXTPControlTheme
43{
44public:
49 CXTPExcelTabCtrlTheme();
50
55 ~CXTPExcelTabCtrlTheme();
56
57public:
65 virtual void RefreshMetrics(CXTPExcelTabCtrl* pTab);
66
67public:
82 virtual int DrawTab(CDC* pDC, CXTPExcelTabCtrl* pTabCtrl, const CPoint& pt, bool bSelected,
83 CXTPTcbItem* pTcbItem);
84
94 virtual void DrawButton(CDC* pDC, CXTPExcelTabCtrl* pTabCtrl,
95 const CXTPExcelTabCtrlButtonState& state);
96
106 virtual void DrawButtonBack(CDC* pDC, CRect& rect, const CXTPExcelTabCtrlButtonState& state);
107
118 virtual void FillBackground(CDC* pDC, CRect& rect, BOOL bBottom);
119
128 virtual void FillTabsBackground(CDC* pDC, int cx, int cy);
129
137 virtual void DrawGripper(CDC* pDC, CRect rect);
138
148 virtual COLORREF GetTabBackColor(CXTPTcbItem* pTcbItem) const;
149
159 virtual COLORREF GetTabTextColor(CXTPTcbItem* pTcbItem) const;
160
170 virtual COLORREF GetSelTabBackColor(CXTPTcbItem* pTcbItem) const;
171
181 virtual COLORREF GetSelTabTextColor(CXTPTcbItem* pTcbItem) const;
182
183 CXTPPaintManagerColor m_clr3DFace;
185 CXTPPaintManagerColor m_clr3DFacePushed;
186 CXTPPaintManagerColor m_clr3DFaceHilite;
187 CXTPPaintManagerColor m_clrBtnText;
188 CXTPPaintManagerColor m_clrBtnTextGray;
189 CXTPPaintManagerColor m_clrBtnTextPushed;
190 CXTPPaintManagerColor m_clrBtnTextHilite;
191 CXTPPaintManagerColor m_clrWindow;
193 CXTPPaintManagerColor m_clrWindowText;
194 CXTPPaintManagerColor m_clr3DHilight;
196 CXTPPaintManagerColor m_clr3DShadow;
197 CXTPPaintManagerColor m_clrBorder3DHilite;
198 CXTPPaintManagerColor m_clrBorder3DShadow;
199};
200
205class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeOfficeXP : public CXTPExcelTabCtrlTheme
206{
207public:
212 CXTPExcelTabCtrlThemeOfficeXP();
213
220 virtual void RefreshMetrics(CXTPExcelTabCtrl* pTab);
221
231 virtual void DrawButtonBack(CDC* pDC, CRect& rect, const CXTPExcelTabCtrlButtonState& state);
232};
233
238class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeOffice2003 : public CXTPExcelTabCtrlThemeOfficeXP
239{
240public:
245 CXTPExcelTabCtrlThemeOffice2003();
246
253 virtual void RefreshMetrics(CXTPExcelTabCtrl* pTab);
254
264 virtual void DrawButtonBack(CDC* pDC, CRect& rect, const CXTPExcelTabCtrlButtonState& state);
265};
266
271class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeOffice2013 : public CXTPExcelTabCtrlTheme
272{
273public:
278 CXTPExcelTabCtrlThemeOffice2013();
279
287 virtual void RefreshMetrics(CXTPExcelTabCtrl* pTab);
288
303 virtual int DrawTab(CDC* pDC, CXTPExcelTabCtrl* pTabCtrl, const CPoint& pt, bool bSelected,
304 CXTPTcbItem* pTcbItem);
305
315 virtual void DrawButtonBack(CDC* pDC, CRect& rect, const CXTPExcelTabCtrlButtonState& state);
316
326 virtual void DrawButton(CDC* pDC, CXTPExcelTabCtrl* pTabCtrl,
327 const CXTPExcelTabCtrlButtonState& state);
328
339 virtual void FillBackground(CDC* pDC, CRect& rect, BOOL bBottom);
340
349 virtual void FillTabsBackground(CDC* pDC, int cx, int cy);
350
358 virtual void DrawGripper(CDC* pDC, CRect rect);
359};
360
366class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeVisualStudio2015 : public CXTPExcelTabCtrlThemeOffice2013
367{
368public:
373 CXTPExcelTabCtrlThemeVisualStudio2015();
374};
375
381class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeVisualStudio2017 : public CXTPExcelTabCtrlThemeOffice2013
382{
383public:
388 CXTPExcelTabCtrlThemeVisualStudio2017();
389};
390
396class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeVisualStudio2019 : public CXTPExcelTabCtrlThemeOffice2013
397{
398public:
403 CXTPExcelTabCtrlThemeVisualStudio2019();
404};
405
411class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeVisualStudio2022 : public CXTPExcelTabCtrlThemeOffice2013
412{
413public:
418 CXTPExcelTabCtrlThemeVisualStudio2022();
419};
420
425class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeNativeWindows10 : public CXTPExcelTabCtrlThemeOffice2013
426{
427public:
432 CXTPExcelTabCtrlThemeNativeWindows10();
433};
434
439class _XTP_EXT_CLASS CXTPExcelTabCtrlThemeNativeWindows11 : public CXTPExcelTabCtrlThemeOffice2013
440{
441public:
446 CXTPExcelTabCtrlThemeNativeWindows11();
447};
448
450
451# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
453#endif // !defined(__XTPEXCELTABCTRLTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPExcelTabCtrlButtonState
The CXTPExcelTabCtrlButtonState class is used by the CXTPExcelTabCtrl class to manage navigation butt...
Definition XTPExcelTabCtrl.h:62
CXTPExcelTabCtrl
CXTPExcelTabCtrl is a CWnd derived class.
Definition XTPExcelTabCtrl.h:101
CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme is used to draw the CXTPExcelTabCtrl object.
Definition XTPExcelTabCtrlTheme.h:43
CXTPExcelTabCtrlTheme::CXTPExcelTabCtrlTheme
CXTPExcelTabCtrlTheme()
Constructs a CXTPExcelTabCtrlTheme object.
CXTPExcelTabCtrlTheme::m_clr3DFace
CXTPPaintManagerColor m_clr3DFace
An RGB value that represents the normal tab face color.
Definition XTPExcelTabCtrlTheme.h:183
CXTPExcelTabCtrlTheme::GetTabBackColor
virtual COLORREF GetTabBackColor(CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color of the tab.
CXTPExcelTabCtrlTheme::m_clrBtnTextHilite
CXTPPaintManagerColor m_clrBtnTextHilite
An RGB value for pushed text color.
Definition XTPExcelTabCtrlTheme.h:190
CXTPExcelTabCtrlTheme::~CXTPExcelTabCtrlTheme
~CXTPExcelTabCtrlTheme()
Destroys a CXTPExcelTabCtrlTheme object, handles cleanup and deallocation.
CXTPExcelTabCtrlTheme::FillBackground
virtual void FillBackground(CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
CXTPExcelTabCtrlTheme::m_clrBorder3DHilite
CXTPPaintManagerColor m_clrBorder3DHilite
An RGB value for 3D border highlight color.
Definition XTPExcelTabCtrlTheme.h:197
CXTPExcelTabCtrlTheme::DrawButtonBack
virtual void DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
CXTPExcelTabCtrlTheme::m_clr3DFaceHilite
CXTPPaintManagerColor m_clr3DFaceHilite
An RGB value for highlighted background color.
Definition XTPExcelTabCtrlTheme.h:186
CXTPExcelTabCtrlTheme::GetSelTabTextColor
virtual COLORREF GetSelTabTextColor(CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color for selected tabs.
CXTPExcelTabCtrlTheme::RefreshMetrics
virtual void RefreshMetrics(CXTPExcelTabCtrl *pTab)
Call this function to refresh the flat tab control colors, position any scroll bars to their default ...
CXTPExcelTabCtrlTheme::m_clr3DShadow
CXTPPaintManagerColor m_clr3DShadow
An RGB value that represents the tab shadow color.
Definition XTPExcelTabCtrlTheme.h:196
CXTPExcelTabCtrlTheme::m_clrWindowText
CXTPPaintManagerColor m_clrWindowText
An RGB value that represents the tab text color.
Definition XTPExcelTabCtrlTheme.h:193
CXTPExcelTabCtrlTheme::m_clr3DFacePushed
CXTPPaintManagerColor m_clr3DFacePushed
An RGB value for pushed background color.
Definition XTPExcelTabCtrlTheme.h:185
CXTPExcelTabCtrlTheme::m_clrBtnTextGray
CXTPPaintManagerColor m_clrBtnTextGray
An RGB value for disabled text color.
Definition XTPExcelTabCtrlTheme.h:188
CXTPExcelTabCtrlTheme::DrawTab
virtual int DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
CXTPExcelTabCtrlTheme::DrawButton
virtual void DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context sp...
CXTPExcelTabCtrlTheme::m_clrBtnText
CXTPPaintManagerColor m_clrBtnText
An RGB value that represents the tab outline color.
Definition XTPExcelTabCtrlTheme.h:187
CXTPExcelTabCtrlTheme::GetSelTabBackColor
virtual COLORREF GetSelTabBackColor(CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the background color for selected tabs.
CXTPExcelTabCtrlTheme::m_clr3DHilight
CXTPPaintManagerColor m_clr3DHilight
An RGB value that represents the tab highlight color.
Definition XTPExcelTabCtrlTheme.h:194
CXTPExcelTabCtrlTheme::FillTabsBackground
virtual void FillTabsBackground(CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
CXTPExcelTabCtrlTheme::m_clrBtnTextPushed
CXTPPaintManagerColor m_clrBtnTextPushed
An RGB value for highlighted text color.
Definition XTPExcelTabCtrlTheme.h:189
CXTPExcelTabCtrlTheme::m_clrWindow
CXTPPaintManagerColor m_clrWindow
An RGB value that represents the selected tab face color.
Definition XTPExcelTabCtrlTheme.h:191
CXTPExcelTabCtrlTheme::GetTabTextColor
virtual COLORREF GetTabTextColor(CXTPTcbItem *pTcbItem) const
This member function gets an RGB value that represents the text color of the tab.
CXTPExcelTabCtrlTheme::DrawGripper
virtual void DrawGripper(CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
CXTPExcelTabCtrlTheme::m_clrBorder3DShadow
CXTPPaintManagerColor m_clrBorder3DShadow
An RGB value for 3D border shadow color.
Definition XTPExcelTabCtrlTheme.h:198
CXTPExcelTabCtrlThemeNativeWindows10
This class is used to draw a CXTPTabCtrl object using Excel Native Windows 10 theme.
Definition XTPExcelTabCtrlTheme.h:426
CXTPExcelTabCtrlThemeNativeWindows10::CXTPExcelTabCtrlThemeNativeWindows10
CXTPExcelTabCtrlThemeNativeWindows10()
Constructs a CXTPExcelTabCtrlThemeNativeWindows10 object.
CXTPExcelTabCtrlThemeNativeWindows11
This class is used to draw a CXTPTabCtrl object using Excel Native Windows 11 theme.
Definition XTPExcelTabCtrlTheme.h:440
CXTPExcelTabCtrlThemeNativeWindows11::CXTPExcelTabCtrlThemeNativeWindows11
CXTPExcelTabCtrlThemeNativeWindows11()
Constructs a CXTPExcelTabCtrlThemeNativeWindows10 object.
CXTPExcelTabCtrlThemeOffice2003
This class is used to draw a CXTPTabCtrl object using Excel Office 2003 theme.
Definition XTPExcelTabCtrlTheme.h:239
CXTPExcelTabCtrlThemeOffice2003::DrawButtonBack
virtual void DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
CXTPExcelTabCtrlThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics(CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPExcelTabCtrlThemeOffice2003::CXTPExcelTabCtrlThemeOffice2003
CXTPExcelTabCtrlThemeOffice2003()
Constructs a CXTPExcelTabCtrlThemeOffice2003 object.
CXTPExcelTabCtrlThemeOffice2013
This class is used to draw a CXTPTabCtrl object using Excel Office 2013 theme.
Definition XTPExcelTabCtrlTheme.h:272
CXTPExcelTabCtrlThemeOffice2013::FillBackground
virtual void FillBackground(CDC *pDC, CRect &rect, BOOL bBottom)
This member function is called to fill the background area for the tab control.
CXTPExcelTabCtrlThemeOffice2013::DrawButtonBack
virtual void DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
CXTPExcelTabCtrlThemeOffice2013::RefreshMetrics
virtual void RefreshMetrics(CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPExcelTabCtrlThemeOffice2013::DrawTab
virtual int DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem)
This member function will draw a tab to the device context specified by 'pDC'.
CXTPExcelTabCtrlThemeOffice2013::DrawButton
virtual void DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state)
This member function is used by the flat tab control to draw an arrow button to the device context sp...
CXTPExcelTabCtrlThemeOffice2013::FillTabsBackground
virtual void FillTabsBackground(CDC *pDC, int cx, int cy)
This member function is called to fill the background area that is occupied by the tab strip.
CXTPExcelTabCtrlThemeOffice2013::CXTPExcelTabCtrlThemeOffice2013
CXTPExcelTabCtrlThemeOffice2013()
Constructs a CXTPExcelTabCtrlThemeOffice2013 object.
CXTPExcelTabCtrlThemeOffice2013::DrawGripper
virtual void DrawGripper(CDC *pDC, CRect rect)
This member function will draw the horizontal sizing gripper at a specified location.
CXTPExcelTabCtrlThemeOfficeXP
This class is used to draw a CXTPTabCtrl object using Excel Office XP theme.
Definition XTPExcelTabCtrlTheme.h:206
CXTPExcelTabCtrlThemeOfficeXP::DrawButtonBack
virtual void DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state)
Call this member function to draw the background of the button.
CXTPExcelTabCtrlThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics(CXTPExcelTabCtrl *pTab)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPExcelTabCtrlThemeOfficeXP::CXTPExcelTabCtrlThemeOfficeXP
CXTPExcelTabCtrlThemeOfficeXP()
Constructs a CXTPExcelTabCtrlThemeOfficeXP object.
CXTPExcelTabCtrlThemeVisualStudio2015
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2015 object using Excel Visual Studio 2...
Definition XTPExcelTabCtrlTheme.h:367
CXTPExcelTabCtrlThemeVisualStudio2015::CXTPExcelTabCtrlThemeVisualStudio2015
CXTPExcelTabCtrlThemeVisualStudio2015()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2015 object.
CXTPExcelTabCtrlThemeVisualStudio2017
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2017 object using Excel Visual Studio 2...
Definition XTPExcelTabCtrlTheme.h:382
CXTPExcelTabCtrlThemeVisualStudio2017::CXTPExcelTabCtrlThemeVisualStudio2017
CXTPExcelTabCtrlThemeVisualStudio2017()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2017 object.
CXTPExcelTabCtrlThemeVisualStudio2019
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2019 object using Excel Visual Studio 2...
Definition XTPExcelTabCtrlTheme.h:397
CXTPExcelTabCtrlThemeVisualStudio2019::CXTPExcelTabCtrlThemeVisualStudio2019
CXTPExcelTabCtrlThemeVisualStudio2019()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2019 object.
CXTPExcelTabCtrlThemeVisualStudio2022
This class is used to draw a CXTPExcelTabCtrlThemeVisualStudio2022 object using Excel Visual Studio 2...
Definition XTPExcelTabCtrlTheme.h:412
CXTPExcelTabCtrlThemeVisualStudio2022::CXTPExcelTabCtrlThemeVisualStudio2022
CXTPExcelTabCtrlThemeVisualStudio2022()
Constructs a CXTPExcelTabCtrlThemeVisualStudio2022 object.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTcbItem
The CXTPTcbItem class is used to maintain information for a particular tab item in a CXTPExcelTabCtrl...
Definition XTPGlobal.h:41


CXTPMatrix< T > Member List

This is the complete list of members for CXTPMatrix< T >, including all inherited members.

Add(const CXTPMatrix< T > &m) | CXTPMatrix< T >
Clone() const | CXTPMatrix< T >
CXTPMatrix(UINT nWidth, UINT nHeight) | CXTPMatrix< T >
Equals(const CXTPMatrix< T > &m) const | CXTPMatrix< T >
GetAt(UINT nCol, UINT nRow) const | CXTPMatrix< T >
GetData() | CXTPMatrix< T >
GetData() const | CXTPMatrix< T >
GetHeight() const | CXTPMatrix< T >
GetWidth() const | CXTPMatrix< T >
Multiply(const CXTPMatrix< T > &m) const | CXTPMatrix< T >
Rotate(T xQuat, T yQuat, T zQuat, T wQuat) | CXTPMatrix< T >
Set(const CXTPMatrix< T > &m) | CXTPMatrix< T >
SetAt(UINT nCol, UINT nRow, T value) | CXTPMatrix< T >
SetIdentity() | CXTPMatrix< T >
SetZero() | CXTPMatrix< T >
Subtract(const CXTPMatrix< T > &m) | CXTPMatrix< T >
Transpose() const | CXTPMatrix< T >
~CXTPMatrix() | CXTPMatrix< T >


CXTPKeyboardManager Member List

This is the complete list of members for CXTPKeyboardManager, including all inherited members.

_xtpKeyboardThreadState | CXTPKeyboardManager | protectedstatic
CXTPKeyboardManager() | CXTPKeyboardManager |
HookKeyboard(CXTPHookManagerHookAble *pHook) | CXTPKeyboardManager |
IsInputLocked() const | CXTPKeyboardManager |
IsKeyboardHooked() const | CXTPKeyboardManager |
LockInput() | CXTPKeyboardManager |
m_hHookCallWndProc | CXTPKeyboardManager | protected
m_hHookGetMessage | CXTPKeyboardManager | protected
m_hHookKeyboard | CXTPKeyboardManager | protected
m_lstKeyboardHooks | CXTPKeyboardManager | protected
m_nInputLockCount | CXTPKeyboardManager | protected
ProcessKeyboardHooks(UINT nMessage, WPARAM wParam, LPARAM lParam=0) | CXTPKeyboardManager |
SetupCallWndProcHook(BOOL bSetup=TRUE) | CXTPKeyboardManager |
SetupKeyboardHook(BOOL bSetup=TRUE) | CXTPKeyboardManager |
UnhookKeyboard(CXTPHookManagerHookAble *pHook) | CXTPKeyboardManager |
UnlockInput() | CXTPKeyboardManager |
~CXTPKeyboardManager() | CXTPKeyboardManager |


Toolkit Pro: XTPTipOfTheDay.h Source File

  • Source
  • Controls
  • Dialog
XTPTipOfTheDay.h
Go to the documentation of this file.
1
23#if !defined(__XTPTIPOFTHEDAY_H__)
24# define __XTPTIPOFTHEDAY_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34class CXTPMarkupUIElement;
35class CXTPImageManagerIcon;
36
44class _XTP_EXT_CLASS CXTPTipOfTheDay : public CDialog
45{
47 DECLARE_DYNAMIC(CXTPTipOfTheDay)
49public:
58 CXTPTipOfTheDay(LPCTSTR lpszTipFile = NULL, CWnd* pParent = NULL);
59
64 virtual ~CXTPTipOfTheDay();
65
66public:
76 virtual void SetDefaultFonts(CFont* pFontTitle, CFont* pFontTip);
77
85 virtual void GetNextTipString(CString& strNext);
86
95 virtual void SetDefaultTitle(LPCTSTR lpszTitle);
96
104 virtual void SetTipsFilePath(LPCTSTR lpszTipFile);
105
111 void AddTip(LPCTSTR lpszTip);
112
119 void SetTipText(LPCTSTR lpszText);
120
126 void EnableMarkup(BOOL bEnable);
127
134 CXTPMarkupContext* GetMarkupContext() const;
135
136protected:
138 DECLARE_MESSAGE_MAP()
139
140 //{{AFX_VIRTUAL(CXTPTipOfTheDay)
141 virtual void DoDataExchange(CDataExchange* pDX);
142 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
143 //}}AFX_VIRTUAL
144
145 //{{AFX_MSG(CXTPTipOfTheDay)
146 afx_msg void OnPaint();
147 virtual BOOL OnInitDialog();
148 virtual void OnOK();
149 afx_msg void OnDaytipNext();
150 //}}AFX_MSG
153public:
155 //{{AFX_DATA(CXTPTipOfTheDay)
156 enum
157 {
158 IDD = XTP_IDD_TIPOFTHEDAY
159 };
160 CButton m_ok;
161 CButton m_showTips;
162 CButton m_btnNextTip;
163 CStatic m_staticBorder;
164 BOOL m_bStartup;
165 //}}AFX_DATA
168 BOOL m_bClassicStyle;
170protected:
171 FILE* m_pStream;
172 CRect m_rcBorder;
173 CRect m_rcTipText;
175 CXTPFont m_xtpFontTitle;
176 CXTPFont m_xtpFontTip;
177 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontTitle, m_xtpFontTitle, GetTitleFontHandle);
178 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontTip, m_xtpFontTip, GetTipFontHandle);
179
180 CFont* m_pFontTitle;
181 CFont* m_pFontTip;
182 CString m_strTipTitle;
183 CString m_strTipText;
184 CString m_strTipFile;
185 CXTPImageManagerIcon* m_pLightBulbIcon;
187 CXTPMarkupContext* m_pMarkupContext;
188 CXTPMarkupUIElement* m_pMarkupTipText;
190 CStringArray m_arrTips;
191 UINT m_nNextTip;
192};
193
195
196AFX_INLINE void CXTPTipOfTheDay::SetDefaultTitle(LPCTSTR lpszTitle)
197{
198 m_strTipTitle = lpszTitle;
199}
200AFX_INLINE void CXTPTipOfTheDay::AddTip(LPCTSTR lpszTip)
201{
202 m_arrTips.Add(lpszTip);
203}
204AFX_INLINE CXTPMarkupContext* CXTPTipOfTheDay::GetMarkupContext() const
205{
206 return m_pMarkupContext;
207}
209# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
211#endif // #if !defined(__XTPTIPOFTHEDAY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPTipOfTheDay
CXTPTipOfTheDay is a CDialog derived class.
Definition XTPTipOfTheDay.h:45
CXTPTipOfTheDay::GetNextTipString
virtual void GetNextTipString(CString &strNext)
This member function will retrieve the next string to be displayed as the Tip Of The Day.
CXTPTipOfTheDay::m_strTipTitle
CString m_strTipTitle
Represents the "Did you know" text.
Definition XTPTipOfTheDay.h:182
CXTPTipOfTheDay::m_pFontTip
CFont * m_pFontTip
User-defined font for tips.
Definition XTPTipOfTheDay.h:181
CXTPTipOfTheDay::EnableMarkup
void EnableMarkup(BOOL bEnable)
Call this method to enable markup for tab captions.
CXTPTipOfTheDay::m_pStream
FILE * m_pStream
A pointer to the open file stream.
Definition XTPTipOfTheDay.h:171
CXTPTipOfTheDay::m_xtpFontTip
CXTPFont m_xtpFontTip
Default font used for tips.
Definition XTPTipOfTheDay.h:176
CXTPTipOfTheDay::SetTipsFilePath
virtual void SetTipsFilePath(LPCTSTR lpszTipFile)
This member function will set the path to where the tips file is located.
CXTPTipOfTheDay::m_arrTips
CStringArray m_arrTips
Array of tips to display.
Definition XTPTipOfTheDay.h:190
CXTPTipOfTheDay::m_xtpFontTitle
CXTPFont m_xtpFontTitle
Default font used for "Did you know..." text.
Definition XTPTipOfTheDay.h:175
CXTPTipOfTheDay::m_strTipText
CString m_strTipText
Represents the Tip Of The Day text.
Definition XTPTipOfTheDay.h:183
CXTPTipOfTheDay::SetDefaultFonts
virtual void SetDefaultFonts(CFont *pFontTitle, CFont *pFontTip)
This member function will set the fonts to be used by the "Did youknow..." and the Tip Of The Day tex...
CXTPTipOfTheDay::m_nNextTip
UINT m_nNextTip
Index of next tip to display.
Definition XTPTipOfTheDay.h:191
CXTPTipOfTheDay::m_rcTipText
CRect m_rcTipText
Size of the display area for tip text.
Definition XTPTipOfTheDay.h:173
CXTPTipOfTheDay::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup Context.
Definition XTPTipOfTheDay.h:187
CXTPTipOfTheDay::m_rcBorder
CRect m_rcBorder
Size of the total display area.
Definition XTPTipOfTheDay.h:172
CXTPTipOfTheDay::m_bClassicStyle
BOOL m_bClassicStyle
Classic Style.
Definition XTPTipOfTheDay.h:168
CXTPTipOfTheDay::CXTPTipOfTheDay
CXTPTipOfTheDay(LPCTSTR lpszTipFile=NULL, CWnd *pParent=NULL)
Constructs a CXTPTipOfTheDay object.
CXTPTipOfTheDay::SetDefaultTitle
virtual void SetDefaultTitle(LPCTSTR lpszTitle)
This member function will set the text that is to be displayed in place of the "Did you know....
CXTPTipOfTheDay::m_pMarkupTipText
CXTPMarkupUIElement * m_pMarkupTipText
Markup element.
Definition XTPTipOfTheDay.h:188
CXTPTipOfTheDay::~CXTPTipOfTheDay
virtual ~CXTPTipOfTheDay()
Destroys a CXTPTipOfTheDay object, handles cleanup and deallocation.
CXTPTipOfTheDay::m_strTipFile
CString m_strTipFile
Represents the file name and path for the tips file.
Definition XTPTipOfTheDay.h:184
CXTPTipOfTheDay::SetTipText
void SetTipText(LPCTSTR lpszText)
Call this member function to set the tip text.
CXTPTipOfTheDay::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Call this method to get the Markup element that renders the item.
CXTPTipOfTheDay::AddTip
void AddTip(LPCTSTR lpszTip)
Call this method to add all tips manually.
CXTPTipOfTheDay::m_pLightBulbIcon
CXTPImageManagerIcon * m_pLightBulbIcon
Bulb bitmap.
Definition XTPTipOfTheDay.h:185
CXTPTipOfTheDay::m_pFontTitle
CFont * m_pFontTitle
User-defined font for "Did you know..." text.
Definition XTPTipOfTheDay.h:180


Toolkit Pro: XTPShellListBase.h Source File

  • Source
  • Controls
  • Shell
XTPShellListBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHELLLISTBASE_H__)
24# define __XTPSHELLLISTBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDirWatcher;
34
40class _XTP_EXT_CLASS CXTPShellListBase
41 : public CXTPListBase
42 , public CXTPShellPidl
43{
44public:
49 CXTPShellListBase();
50
55 virtual ~CXTPShellListBase();
56
57public:
64 virtual void EnableContextMenu(BOOL bEnable);
65
94 virtual void SetEnumFlags(UINT uFlags);
95
103 virtual BOOL InitSystemImageLists();
104
113 virtual BOOL PopulateListView(XTP_TVITEMDATA* lptvid, LPSHELLFOLDER lpsf);
114
123 virtual int GetDoubleClickedItem();
124
131 virtual void ShowShellContextMenu(CPoint pos);
132
141 virtual bool ShellOpenItem(int iItem);
142
151 virtual bool ShellOpenItem(XTP_LVITEMDATA* lplvid);
152
162 virtual BOOL GetItemPath(int iItem, CString& strItemPath);
163
168 virtual void BuildDefaultColumns();
169
179 virtual bool SortList(int nCol, bool bAscending);
180
186 virtual void OnDragDrop(NM_LISTVIEW* pNMListView);
187
199 virtual TCHAR* InsertCommas(LONGLONG value, TCHAR* szBuffer, UINT nSize);
200
214 virtual void SetIncludeExtensions(LPCTSTR lpszFilters = NULL);
215
223 BOOL RefreshRowColors();
224
229 void SetExplorerStyle();
230
231protected:
239 virtual bool Init();
240
249 virtual BOOL InitListViewItems(XTP_TVITEMDATA* lptvid, LPSHELLFOLDER lpsf);
250
258 virtual void GetNormalAndSelectedIcons(LPITEMIDLIST lpifq, LPTV_ITEM lptvitem);
259
267 virtual void SetAttributes(int iItem, DWORD dwAttributes);
268
278 virtual BOOL IsItemFiltered(LPCTSTR lpszItemName, ULONG ulItemAttrs);
279
280protected:
282 //{{AFX_VIRTUAL(CXTPShellListBase)
283 virtual void UpdateList(int nMessage, XTP_TVITEMDATA* pItemData);
284 //}}AFX_VIRTUAL
285
286 //{{AFX_MSG(CXTPShellListBase)
287 afx_msg void OnDeleteListItem(NMHDR* pNMHDR, LRESULT* pResult);
288 //}}AFX_MSG
291private:
292 static void InitLocaleFormats();
293
294protected:
295 int m_nNameColumnWidth;
296 UINT m_uFlags;
297 BOOL m_bContextMenu;
298 LPITEMIDLIST m_pidlINet;
299 CString m_csIncludeEXT;
300 CXTPDirWatcher* m_pDirThread;
301 CXTPShellSettings m_shSettings;
302 LPSHELLFOLDER m_lpsfFolder;
304private:
305 static CString m_strDateFormat;
306 static CString m_strTimeFormat;
307};
308
310
311AFX_INLINE void CXTPShellListBase::SetEnumFlags(UINT uFlags)
312{
313 m_uFlags = uFlags;
314}
315AFX_INLINE void CXTPShellListBase::EnableContextMenu(BOOL bEnable)
316{
317 m_bContextMenu = bEnable;
318}
319AFX_INLINE void CXTPShellListBase::SetIncludeExtensions(LPCTSTR lpszFilters)
320{
321 m_csIncludeEXT = lpszFilters;
322}
325# define DECLARE_SHELLLIST_BASE(ClassName, List, Base) \
326 DECLARE_LIST_BASE(Base##List, List, Base) \
327 class _XTP_EXT_CLASS ClassName : public Base##List \
328 { \
329 protected: \
330 void OnBeginDrag(NMHDR* pNMHDR, LRESULT* pResult) \
331 { \
332 NM_LISTVIEW* pNMListView = (NM_LISTVIEW*)pNMHDR; \
333 OnDragDrop(pNMListView); \
334 *pResult = 0; \
335 } \
336 void OnDeleteListItem(NMHDR* pNMHDR, LRESULT* pResult) \
337 { \
338 Base::OnDeleteListItem(pNMHDR, pResult); \
339 } \
340 void OnContextMenu(CWnd* pWnd, CPoint pos) \
341 { \
342 if (m_bContextMenu) \
343 ShowShellContextMenu(pos); \
344 else \
345 List::OnContextMenu(pWnd, pos); \
346 } \
347 };
348
349# define ON_SHELLLIST_REFLECT \
350 ON_NOTIFY_REFLECT(NM_DBLCLK, OnDblclk) \
351 ON_NOTIFY_REFLECT(LVN_BEGINDRAG, OnBeginDrag) \
352 ON_NOTIFY_REFLECT(LVN_BEGINRDRAG, OnBeginDrag) \
353 ON_NOTIFY_REFLECT(LVN_DELETEITEM, OnDeleteListItem) \
354 ON_WM_CONTEXTMENU() \
355 ON_LISTCTRL_REFLECT
357# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
359#endif // __XTPSHELLLISTBASE_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDirWatcher
The CXTPDirWatcher is a thread class that will monitor a specified path for file and directory change...
Definition XTPDirWatcher.h:115
CXTPListBase
CXTPListBase is a non-inherited class.
Definition XTPListBase.h:39
CXTPShellListBase
CXTPShellListBase is a multiple inheritance class derived from CXTPListView and CXTPShellPidl.
Definition XTPShellListBase.h:43
CXTPShellListBase::m_uFlags
UINT m_uFlags
Flags indicating which items to include in the enumeration.
Definition XTPShellListBase.h:296
CXTPShellListBase::BuildDefaultColumns
virtual void BuildDefaultColumns()
This member function creates default columns for the list view.
CXTPShellListBase::m_bContextMenu
BOOL m_bContextMenu
TRUE to display the shell context menu on right item click.
Definition XTPShellListBase.h:297
CXTPShellListBase::m_csIncludeEXT
CString m_csIncludeEXT
Comma delimited string of extensions to include in file display.
Definition XTPShellListBase.h:299
CXTPShellListBase::EnableContextMenu
virtual void EnableContextMenu(BOOL bEnable)
Call this member function to enable/disable the display of the shell context menu on the right click ...
CXTPShellListBase::ShowShellContextMenu
virtual void ShowShellContextMenu(CPoint pos)
This member function displays the system pop-up menu for the selected item or folder.
CXTPShellListBase::m_nNameColumnWidth
int m_nNameColumnWidth
Size in pixels for the name column width.
Definition XTPShellListBase.h:295
CXTPShellListBase::m_shSettings
CXTPShellSettings m_shSettings
Contains SHELLFLAGSTATE info.
Definition XTPShellListBase.h:301
CXTPShellListBase::SortList
virtual bool SortList(int nCol, bool bAscending)
Override this member function in your derived class to perform custom sort routines.
CXTPShellListBase::SetEnumFlags
virtual void SetEnumFlags(UINT uFlags)
Call this member function to determine the type of items included in the shell enumeration.
CXTPShellListBase::RefreshRowColors
BOOL RefreshRowColors()
Call this member function to refresh the values for the shell settings and compressed colors that are...
CXTPShellListBase::IsItemFiltered
virtual BOOL IsItemFiltered(LPCTSTR lpszItemName, ULONG ulItemAttrs)
This member function determines if an item is filtered.
CXTPShellListBase::ShellOpenItem
virtual bool ShellOpenItem(XTP_LVITEMDATA *lplvid)
This member function executes the item clicked on in the list control via the Shell.
CXTPShellListBase::CXTPShellListBase
CXTPShellListBase()
Constructs a CXTPShellListBase object.
CXTPShellListBase::OnDragDrop
virtual void OnDragDrop(NM_LISTVIEW *pNMListView)
Used by the shell list control to handle a drag drop event.
CXTPShellListBase::GetNormalAndSelectedIcons
virtual void GetNormalAndSelectedIcons(LPITEMIDLIST lpifq, LPTV_ITEM lptvitem)
This member function gets the index for the normal and selected icons of the current item.
CXTPShellListBase::InsertCommas
virtual TCHAR * InsertCommas(LONGLONG value, TCHAR *szBuffer, UINT nSize)
Called by the shell list control to insert commas into the specified numeric value.
CXTPShellListBase::SetAttributes
virtual void SetAttributes(int iItem, DWORD dwAttributes)
This member function sets the shell attribute flags for the specified list item.
CXTPShellListBase::GetItemPath
virtual BOOL GetItemPath(int iItem, CString &strItemPath)
This member function retrieves the path for the specified list view item.
CXTPShellListBase::SetExplorerStyle
void SetExplorerStyle()
Call this member function to enable explorer style for the list.
CXTPShellListBase::GetDoubleClickedItem
virtual int GetDoubleClickedItem()
This member function returns the index of the list view item that was double clicked on.
CXTPShellListBase::m_pidlINet
LPITEMIDLIST m_pidlINet
Pointer to the CSIDL_INTERNET folder location.
Definition XTPShellListBase.h:298
CXTPShellListBase::PopulateListView
virtual BOOL PopulateListView(XTP_TVITEMDATA *lptvid, LPSHELLFOLDER lpsf)
This member function populates the list view control.
CXTPShellListBase::InitListViewItems
virtual BOOL InitListViewItems(XTP_TVITEMDATA *lptvid, LPSHELLFOLDER lpsf)
This member function adds items to the list view.
CXTPShellListBase::m_lpsfFolder
LPSHELLFOLDER m_lpsfFolder
Represents the parent IShellFolder interface.
Definition XTPShellListBase.h:302
CXTPShellListBase::InitSystemImageLists
virtual BOOL InitSystemImageLists()
This member function associates the system image list with the list control.
CXTPShellListBase::~CXTPShellListBase
virtual ~CXTPShellListBase()
Destroys a CXTPShellListBase object, handles cleanup and deallocation.
CXTPShellListBase::ShellOpenItem
virtual bool ShellOpenItem(int iItem)
This member function executes the item clicked on in the list control via the Shell.
CXTPShellListBase::Init
virtual bool Init()
This member function is called by the CXTPShellListBase class to perform initialization when the wind...
CXTPShellListBase::SetIncludeExtensions
virtual void SetIncludeExtensions(LPCTSTR lpszFilters=NULL)
Call this member function to define a file filter for the files displayed.
CXTPShellListBase::m_pDirThread
CXTPDirWatcher * m_pDirThread
Thread used to monitor directory activity.
Definition XTPShellListBase.h:300
CXTPShellPidl
CXTPShellPidl is a standalone base class.
Definition XTPShellPidl.h:69
CXTPShellSettings
CXTPShellSettings is a SHELLFLAGSTATE struct derived class.
Definition XTPShellSettings.h:40
XTP_LVITEMDATA
The XTP_LVITEMDATA structure is used to maintain information for a particular list item in a CXTPShel...
Definition XTPShellPidl.h:42
XTP_TVITEMDATA
The XTP_TVITEMDATA structure is used to maintain information for a particular tree item in a CXTPShel...
Definition XTPShellPidl.h:57


Toolkit Pro: XTPKeyboardManager.h Source File

  • Source
  • CommandBars
XTPKeyboardManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPKEYBOARDMANAGER_H__)
24# define __XTPKEYBOARDMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPKeyboardManager : public CNoTrackObject
38{
39public:
44 CXTPKeyboardManager();
45
50 ~CXTPKeyboardManager();
51
52public:
60 void SetupKeyboardHook(BOOL bSetup = TRUE);
61
69 void SetupCallWndProcHook(BOOL bSetup = TRUE);
70
78 void HookKeyboard(CXTPHookManagerHookAble* pHook);
79
87 void UnhookKeyboard(CXTPHookManagerHookAble* pHook);
88
95 BOOL IsKeyboardHooked() const;
96
106 BOOL ProcessKeyboardHooks(UINT nMessage, WPARAM wParam, LPARAM lParam = 0);
107
115 void LockInput();
116
124 void UnlockInput();
125
134 BOOL IsInputLocked() const;
135
136protected:
138 static LRESULT CALLBACK KeyboardProc(int code, WPARAM wParam, LPARAM lParam);
139 static LRESULT CALLBACK CallWndProc(int code, WPARAM wParam, LPARAM lParam);
140 static LRESULT CALLBACK GetMessageProc(int code, WPARAM wParam, LPARAM lParam);
141
142# ifdef _XTP_COMMANDBARS_ACTIVEX
143public:
144 void SetupGetMessageHook(BOOL bSetup = TRUE);
145# endif
148protected:
149 HHOOK m_hHookKeyboard;
150 HHOOK m_hHookCallWndProc;
151 HHOOK m_hHookGetMessage;
152 LONG m_nInputLockCount;
154# ifdef _AFXDLL
155 AFX_MODULE_STATE* m_pModuleState;
156# endif
157
158 static CThreadLocal<CXTPKeyboardManager> _xtpKeyboardThreadState;
160 CList<CXTPHookManagerHookAble*, CXTPHookManagerHookAble*> m_lstKeyboardHooks;
164private:
165 friend CXTPKeyboardManager* XTPKeyboardManager();
166 friend class CXTPCommandBars;
167};
168
169AFX_INLINE BOOL CXTPKeyboardManager::IsKeyboardHooked() const
170{
171 return m_lstKeyboardHooks.GetCount() > 0;
172}
173
174AFX_INLINE BOOL CXTPKeyboardManager::IsInputLocked() const
175{
176 return 0 < m_nInputLockCount;
177}
178
179AFX_INLINE CXTPKeyboardManager* XTPKeyboardManager()
180{
181 return CXTPKeyboardManager::_xtpKeyboardThreadState.GetData();
182}
184# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
185#endif //#if !defined(__XTPKEYBOARDMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBars::GetCount
int GetCount() const
Call this member to get the toolbar count.
Definition XTPCommandBars.h:1592
CXTPHookManagerHookAble
HookAble interface.
Definition XTPHookManager.h:42
CXTPKeyboardManager
CXTPKeyboardManager class used to handle keyboard hooks.
Definition XTPKeyboardManager.h:38
CXTPKeyboardManager::SetupCallWndProcHook
void SetupCallWndProcHook(BOOL bSetup=TRUE)
This method is called to start/end message hooks.
CXTPKeyboardManager::UnhookKeyboard
void UnhookKeyboard(CXTPHookManagerHookAble *pHook)
Call this method to unhook keyboard notifications.
CXTPKeyboardManager::ProcessKeyboardHooks
BOOL ProcessKeyboardHooks(UINT nMessage, WPARAM wParam, LPARAM lParam=0)
This method is called to process keyboard hooks.
CXTPKeyboardManager::~CXTPKeyboardManager
~CXTPKeyboardManager()
Destroys a CXTPKeyboardManager object, handles cleanup and deallocation.
CXTPKeyboardManager::IsInputLocked
BOOL IsInputLocked() const
Determines if there is at least one input lock.
Definition XTPKeyboardManager.h:174
CXTPKeyboardManager::UnlockInput
void UnlockInput()
Increments/decrements input lock counter.
CXTPKeyboardManager::m_hHookCallWndProc
HHOOK m_hHookCallWndProc
Message hook.
Definition XTPKeyboardManager.h:150
CXTPKeyboardManager::m_lstKeyboardHooks
CList< CXTPHookManagerHookAble *, CXTPHookManagerHookAble * > m_lstKeyboardHooks
List of keyboard hooks.
Definition XTPKeyboardManager.h:160
CXTPKeyboardManager::m_nInputLockCount
LONG m_nInputLockCount
Number of input locks.
Definition XTPKeyboardManager.h:152
CXTPKeyboardManager::m_hHookKeyboard
HHOOK m_hHookKeyboard
Keyboard hook.
Definition XTPKeyboardManager.h:149
CXTPKeyboardManager::LockInput
void LockInput()
Increments/decrements input lock counter.
CXTPKeyboardManager::HookKeyboard
void HookKeyboard(CXTPHookManagerHookAble *pHook)
Call this method to hook keyboard notifications.
CXTPKeyboardManager::m_hHookGetMessage
HHOOK m_hHookGetMessage
Message hook.
Definition XTPKeyboardManager.h:151
CXTPKeyboardManager::CXTPKeyboardManager
CXTPKeyboardManager()
Constructs a CXTPKeyboardManager object.
CXTPKeyboardManager::SetupKeyboardHook
void SetupKeyboardHook(BOOL bSetup=TRUE)
This method is called to start/end keyboard hooks.
CXTPKeyboardManager::IsKeyboardHooked
BOOL IsKeyboardHooked() const
Determines if the keyboard is hooked.
Definition XTPKeyboardManager.h:169
CXTPKeyboardManager::_xtpKeyboardThreadState
static CThreadLocal< CXTPKeyboardManager > _xtpKeyboardThreadState
Instance of Keyboard hook.
Definition XTPKeyboardManager.h:158


CXTPCalendarCustomProperties Member List

This is the complete list of members for CXTPCalendarCustomProperties, including all inherited members.

_Load(CXTPPropExchange *pPX) | CXTPCalendarCustomProperties | protected
_Save(CXTPPropExchange *pPX) | CXTPCalendarCustomProperties | protected
CopyTo(CXTPCalendarCustomProperties *pDest) | CXTPCalendarCustomProperties |
CXTPCalendarCustomProperties(BOOL bNameIgnoreCase=TRUE) | CXTPCalendarCustomProperties |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarCustomProperties | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCount() | CXTPCalendarCustomProperties | virtual
GetNextProperty(POSITION &rPos, CString &rStrName, COleVariant &rVarValue) const | CXTPCalendarCustomProperties |
GetProperty(LPCTSTR pcszName, COleVariant &rVarValue) const | CXTPCalendarCustomProperties | virtual
GetStartPosition() const | CXTPCalendarCustomProperties |
LoadFromXML(LPCTSTR pcszXMLData) | CXTPCalendarCustomProperties |
m_bNameIgnoreCase | CXTPCalendarCustomProperties | protected
m_mapProperties | CXTPCalendarCustomProperties | protected
PrepareName(LPCTSTR pcszName) const | CXTPCalendarCustomProperties | protected
RemoveAll() | CXTPCalendarCustomProperties | virtual
RemoveProperty(LPCTSTR pcszName) | CXTPCalendarCustomProperties | virtual
SaveToXML(CString &rstrXMLData) | CXTPCalendarCustomProperties |
SetProperty(LPCTSTR pcszName, const COleVariant &varValue) | CXTPCalendarCustomProperties | virtual
~CXTPCalendarCustomProperties() | CXTPCalendarCustomProperties | virtual


Toolkit Pro: XTPGdiPlus.h Source File

  • Source
  • GraphicLibrary
  • GdiPlus
GraphicLibrary/GdiPlus/XTPGdiPlus.h
Go to the documentation of this file.
1
23#ifndef _XTP_GDIPLUS_H
24#define _XTP_GDIPLUS_H
27#include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
28#include "GdiPlus.h"
29#include "GdiPlusFlat.h"
30#pragma comment(lib, "GdiPlus.lib")
31#include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
32
33#ifndef GdipCreateFontFromLogfont
34#ifdef _UNICODE
35#define GdipCreateFontFromLogfont GdipCreateFontFromLogfontW
36#else
37#define GdipCreateFontFromLogfont GdipCreateFontFromLogfontA
38#endif
39#endif
40
42#endif /*_XTP_GDIPLUS_H*/
XTPDisableAdvancedWarnings.h
XTPEnableAdvancedWarnings.h


CXTPShellTreeBase Member List

This is the complete list of members for CXTPShellTreeBase, including all inherited members.

AssociateCombo(CWnd *pWnd) | CXTPShellTreeBase | virtual
BeginDrag(NM_TREEVIEW *pNMTreeView) | CXTPShellTreeBase | virtual
CColorFontMap typedef | CXTPTreeBase | protected
ComparePidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder=NULL) | CXTPShellPidl |
ConcatPidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2) | CXTPShellPidl |
ConcatPidls(LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2) | CXTPShellPidl |
CopyIDList(LPITEMIDLIST pidl) | CXTPShellPidl |
CopyPidlItem(LPITEMIDLIST pidl, UINT nItem) | CXTPShellPidl |
CreatePidl(LPMALLOC lpMalloc, UINT cbSize) | CXTPShellPidl |
CXTPShellPidl() | CXTPShellPidl |
CXTPShellTreeBase() | CXTPShellTreeBase |
CXTPTreeBase() | CXTPTreeBase | protected
DoAction(HTREEITEM hItem, BOOL bLeft, UINT nFlags, CPoint point) | CXTPTreeBase | protectedvirtual
DoBanding(UINT nFlags, CPoint point) | CXTPTreeBase | protectedvirtual
DoPaint(CDC &dc, BOOL bInternal=TRUE) | CXTPTreeBase | protectedvirtual
DoPreSelection(HTREEITEM hItem, BOOL bLeft, UINT nFlags) | CXTPTreeBase | protectedvirtual
DrawDarkThemeExpander(CDC *pDC, COLORREF crBack, CRect rcItem, CRect rcExpander, int nPart, int nState) const | CXTPTreeBase | protected
DrawItem(CDC *pDC, HTREEITEM hItem, const COLORREF crBack) | CXTPTreeBase | protected
DuplicateItem(LPMALLOC lpMalloc, LPITEMIDLIST lpi) | CXTPShellPidl |
EnableContextMenu(BOOL bEnable) | CXTPShellTreeBase |
EnableDefaultItemDrawing(BOOL bEnable=TRUE) | CXTPTreeBase |
EnableMultiSelect(BOOL bMultiSelect=TRUE) | CXTPTreeBase | virtual
FindItem(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL) | CXTPTreeBase | virtual
FindItemExact(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, HTREEITEM hItem=NULL) | CXTPTreeBase | virtual
FindItemImpl(LPCTSTR lpszSearch, BOOL bCaseSensitive=FALSE, BOOL bDownDir=TRUE, BOOL bWholeWord=FALSE, HTREEITEM hItem=NULL, BOOL bExactlySameStr=FALSE) | CXTPTreeBase | protectedvirtual
FindItemInBranch(LPCTSTR lpszSearch, BOOL bCaseSensitive, BOOL bWholeWord, HTREEITEM htiItem) | CXTPTreeBase | virtual
FindTreeItem(HTREEITEM hItem, XTP_LVITEMDATA *lplvid, BOOL bRecursively=TRUE) | CXTPShellTreeBase | virtual
FocusItem(HTREEITEM hItem) | CXTPTreeBase |
FreePidl(LPITEMIDLIST pidl) | CXTPShellPidl |
GetAttributes(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const | CXTPShellPidl |
GetContextMenu() | CXTPShellTreeBase | virtual
GetFirstSelectedItem() const | CXTPTreeBase | virtual
GetFocusedItem() const | CXTPTreeBase |
GetFolderItemPath(HTREEITEM hItem, CString &strFolderPath) | CXTPShellTreeBase | virtual
GetFullyQualPidl(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi) | CXTPShellPidl |
GetIconIndent() const | CXTPTreeBase |
GetInsertMarkColor() const | CXTPTreeBase | protected
GetItemBackColor(HTREEITEM hItem) | CXTPTreeBase | virtual
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBack) const | CXTPTreeBase | protectedvirtual
GetItemBold(HTREEITEM hItem) | CXTPTreeBase | virtual
GetItemColor(HTREEITEM hItem) | CXTPTreeBase | virtual
GetItemExpanderRect(HTREEITEM hItem, CDC *pDC, const CRect &rcIcon, const CRect &rcStateIcon) const | CXTPTreeBase | protectedvirtual
GetItemFont(HTREEITEM hItem, LOGFONT *plogfont) | CXTPTreeBase | virtual
GetItemIcon(LPITEMIDLIST lpi, UINT uFlags) const | CXTPShellPidl |
GetItemIconRect(HTREEITEM hItem) const | CXTPTreeBase | protectedvirtual
GetItemState(HTREEITEM hItem, UINT nStateMask) const | CXTPTreeBase |
GetItemStateIconRect(HTREEITEM hItem, const CRect &rcIcon) const | CXTPTreeBase | protectedvirtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crText) const | CXTPTreeBase | protectedvirtual
GetLastITEM(LPITEMIDLIST pidl) | CXTPShellPidl |
GetLastItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetName(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString &lpFriendlyName) | CXTPShellPidl |
GetNextItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetNextItem(HTREEITEM hItem, UINT nCode) const | CXTPTreeBase | virtual
GetNextPidlItem(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetNextSelectedItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetNormalAndSelectedIcons(LPITEMIDLIST lpifq, LPTV_ITEM lptvitem) | CXTPShellTreeBase | protectedvirtual
GetPidlCount(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetPidlItemCount(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetPrevItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetPrevSelectedItem(HTREEITEM hItem) const | CXTPTreeBase | virtual
GetSelectedCount() const | CXTPTreeBase | virtual
GetSelectedFolderPath(CString &strFolderPath) | CXTPShellTreeBase | virtual
GetSelectedList(CTypedPtrList< CPtrList, HTREEITEM > &list) const | CXTPTreeBase |
GetSHContextMenu(LPSHELLFOLDER psfFolder, LPCITEMIDLIST *localPidl, int nCount, void **ppCM, int *pcmType) | CXTPShellPidl |
GetSystemImageList(UINT uFlags) const | CXTPShellPidl |
GetTreeBackColor() const | CXTPTreeBase | protectedvirtual
GetTreeTextColor() const | CXTPTreeBase | protectedvirtual
HasEditLabels() const | CXTPTreeBase | protected
IDLFromPath(LPCTSTR path) | CXTPShellPidl |
Init() | CXTPTreeBase | protectedvirtual
InitializeTree(DWORD dwStyle=TVS_HASBUTTONS|TVS_HASLINES|TVS_LINESATROOT) | CXTPShellTreeBase | virtual
InitSystemImageLists() | CXTPShellTreeBase | virtual
InitTreeNode(HTREEITEM hItem, XTP_TVITEMDATA *lptvid) | CXTPShellTreeBase | virtual
InitTreeViewItems(LPSHELLFOLDER lpsf, LPITEMIDLIST lpifq, HTREEITEM hParent) | CXTPShellTreeBase | protectedvirtual
InsertDesktopItem(int nFolder=CSIDL_DESKTOP) | CXTPShellTreeBase | virtual
IsDefaultItemDrawingEnabled() const | CXTPTreeBase |
IsExplorerTheme() const | CXTPTreeBase |
IsFindValid(HTREEITEM hti) | CXTPTreeBase | protectedvirtual
IsFullRowSelectionEnabled() | CXTPTreeBase | protectedvirtual
IsMultiSelect() const | CXTPTreeBase |
IsSelected(HTREEITEM hItem) const | CXTPTreeBase | virtual
ListViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort) | CXTPShellPidl | static
m_bBandLabel | CXTPTreeBase | protected
m_bContextMenu | CXTPShellTreeBase | protected
m_bDoDefaultItemDrawing | CXTPTreeBase | protected
m_bExplorerStyle | CXTPShellTreeBase | protected
m_bExplorerTheme | CXTPTreeBase | protected
m_bMultiSelect | CXTPTreeBase | protected
m_bShowFiles | CXTPShellTreeBase | protected
m_bShowShellLinkIcons | CXTPShellPidl | protected
m_bTunneling | CXTPShellTreeBase | protected
m_hInsertMark | CXTPTreeBase | protected
m_hSelect | CXTPTreeBase | protected
m_htiEdit | CXTPTreeBase | protected
m_htiLast | CXTPTreeBase | protected
m_iconIndent | CXTPTreeBase | protected
m_InsertMarkAfter | CXTPTreeBase | protected
m_InsertMarkColor | CXTPTreeBase | protected
m_mapColorFont | CXTPTreeBase | protected
m_nRootFolder | CXTPShellTreeBase | protected
m_nTheme | CXTPTreeBase | protected
m_pComboBox | CXTPShellTreeBase | protected
m_shSettings | CXTPShellTreeBase | protected
m_uFlags | CXTPShellTreeBase | protected
m_ulSFGAOFlags | CXTPShellPidl | protected
MapShellFlagsToItemAttributes(CListCtrl *pListCtrl, int iItem, DWORD dwAttributes) | CXTPShellPidl | protectedvirtual
MapShellFlagsToItemAttributes(CTreeCtrl *pTreeCtrl, HTREEITEM hItem, DWORD dwAttributes) | CXTPShellPidl | protectedvirtual
OnButtonDown(BOOL bLeft, UINT nFlags, CPoint point) | CXTPTreeBase | protectedvirtual
OneUpPATH(const CString &path) | CXTPShellPidl |
OneUpPIDL(LPITEMIDLIST pidlPath) | CXTPShellPidl |
OnFolderExpanding(NM_TREEVIEW *pNMTreeView) | CXTPShellTreeBase | virtual
OnFolderSelected(NM_TREEVIEW *pNMTreeView, CString &strFolderPath) | CXTPShellTreeBase | virtual
OnShowContextMenu(int idCmd, CMINVOKECOMMANDINFO &cmi) | CXTPShellPidl | protectedvirtual
PathFindNextComponent(const CString &pszPath) | CXTPShellTreeBase | protected
PopulateTree(LPCTSTR lpszPath) | CXTPShellTreeBase | virtual
PopulateTreeView() | CXTPShellTreeBase | virtual
SearchTree(HTREEITEM hItem, LPCITEMIDLIST pABSPidl) | CXTPShellTreeBase | virtual
SelectAll(BOOL bSelect=TRUE, HTREEITEM htItem=NULL) | CXTPTreeBase | virtual
SelectAllIgnore(BOOL bSelect, HTREEITEM hIgnore) | CXTPTreeBase | protectedvirtual
SelectChildren(HTREEITEM hParent, BOOL bSelect=TRUE, BOOL bRecurse=TRUE) | CXTPTreeBase |
SelectionChanged(HTREEITEM hItem, CString strFolderPath) | CXTPShellTreeBase | virtual
SelectItem(HTREEITEM hItem) | CXTPTreeBase |
SelectItems(HTREEITEM hItemFrom, HTREEITEM hItemTo, BOOL bOnly=TRUE) | CXTPTreeBase | virtual
SendNotify(LPNMHDR pNMHDR) | CXTPTreeBase | protectedvirtual
SetAttributes(HTREEITEM hItem, DWORD dwAttributes) | CXTPShellTreeBase | protected
SetBandingHit(BOOL bLabel) | CXTPTreeBase |
SetEnumFlags(UINT uFlags) | CXTPShellTreeBase |
SetExplorerStyle() | CXTPShellTreeBase |
SetExplorerTheme(BOOL bSet) | CXTPTreeBase |
SetIconIndent(int iconIndent) | CXTPTreeBase |
SetInsertMark(HTREEITEM hItem, BOOL fAfter) | CXTPTreeBase | protected
SetInsertMarkColor(COLORREF clrNew) | CXTPTreeBase | protected
SetItemBackColor(HTREEITEM hItem, COLORREF color) | CXTPTreeBase | virtual
SetItemBold(HTREEITEM hItem, BOOL bBold=TRUE) | CXTPTreeBase | virtual
SetItemColor(HTREEITEM hItem, COLORREF color) | CXTPTreeBase | virtual
SetItemFont(HTREEITEM hItem, LOGFONT &logfont) | CXTPTreeBase | virtual
SetItemState(HTREEITEM hItem, UINT nState, UINT nStateMask) | CXTPTreeBase |
SetRootFolder(int nRootFolder=CSIDL_DESKTOP) | CXTPShellTreeBase |
ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt) | CXTPShellPidl |
ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST *lppi, int nCount, LPPOINT lppt) | CXTPShellPidl |
ShowFiles(BOOL bShowFiles=TRUE) | CXTPShellTreeBase |
ShowShellLinkIcons(BOOL bShowLinkIcons=TRUE) | CXTPShellPidl |
SortChildren(HTREEITEM hParent) | CXTPShellTreeBase | protectedvirtual
TreeViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort) | CXTPShellPidl | static
TunnelTree(CString strFindPath) | CXTPShellTreeBase | virtual
UpdateSelectionForRect(LPCRECT pRect, UINT nFlags, CTypedPtrList< CPtrList, HTREEITEM > &list) | CXTPTreeBase | protectedvirtual
~CXTPShellPidl() | CXTPShellPidl | virtual
~CXTPShellTreeBase() | CXTPShellTreeBase | virtual
~CXTPTreeBase() | CXTPTreeBase | protectedvirtual


CXTPToolBar Member List

This is the complete list of members for CXTPToolBar, including all inherited members.

CalcDockingLayout(int nLength, DWORD dwMode, int nWidth=0) | CXTPToolBar | virtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPToolBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPToolBar | protectedvirtual
Create(CWnd *pParentWnd, BOOL bFloat) | CXTPToolBar | protectedvirtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateToolBar(DWORD dwStyle, CWnd *pParentWnd, UINT nID=AFX_IDW_TOOLBAR) | CXTPToolBar |
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPToolBar() | CXTPToolBar |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPCommandBar | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPToolBar | protectedvirtual
DoUpdateCustomizeMenuControl(CXTPControl *pControl, CCmdTarget *pTarget) | CXTPToolBar | static
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPCommandBar | virtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDocking(DWORD dwFlags=xtpFlagAlignAny|xtpFlagFloating|xtpFlagHideWrap) | CXTPToolBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
GetBorders() | CXTPToolBar | protectedvirtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDockBar() const | CXTPToolBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPCommandBar | virtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsBuiltIn() const | CXTPToolBar |
IsCloseable() const | CXTPToolBar |
IsContextMenuPresent() const | CXTPToolBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPToolBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPCommandBar | virtual
IsResizable() const | CXTPCommandBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTemporary() const | CXTPToolBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPToolBar | inlinevirtual
IsWindowVisible() const | CXTPToolBar |
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPToolBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bBuiltIn | CXTPToolBar | protected
m_bCloseable | CXTPCommandBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenuPresent | CXTPToolBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bInRecalcLayout | CXTPToolBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bPreviewMode | CXTPToolBar | protected
m_bPreviewVisible | CXTPToolBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bShowExpandButton | CXTPToolBar | protected
m_bTearOff | CXTPToolBar | protected
m_bTemporary | CXTPToolBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_bVisible | CXTPToolBar | protected
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControls | CXTPCommandBar | protected
m_pDockBar | CXTPToolBar | protected
m_pDockContext | CXTPToolBar | protected
m_pImageManager | CXTPCommandBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_rcMarker | CXTPCommandBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent) | CXTPToolBar | protectedvirtual
MergeToolBar(CXTPCommandBar *pCommandBar, BOOL bSilent, int nDefaultConfirmationChoice) | CXTPToolBar | protectedvirtual
ModifyBarStyle(DWORD dwRemove, DWORD dwAdd) | CXTPToolBar |
OnControlsChanged() | CXTPCommandBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPToolBar | virtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPaintManagerChanged() | CXTPToolBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPToolBar | virtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnSetPreviewMode(BOOL bPreview) | CXTPToolBar |
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPCommandBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
Reset(BOOL bShowWarningMessage) | CXTPToolBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBarInfo(CToolBarInfo *pInfo) | CXTPToolBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCloseable(BOOL bCloseable) | CXTPToolBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetContextMenuPresent(BOOL bPresent) | CXTPToolBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetCustomizeDialogPresent(BOOL bPresent) | CXTPToolBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPosition(XTPBarPosition barPosition) | CXTPToolBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTemporary(BOOL bTemporary) | CXTPToolBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPCommandBar | virtual
SetVisible(BOOL bVisible) | CXTPToolBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShouldSerializeBar() | CXTPToolBar | protectedvirtual
ShowExpandButton(BOOL bShowExpandButton) | CXTPToolBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPToolBar() | CXTPToolBar |


Toolkit Pro: XTPChartLegendItem.h Source File

  • Source
  • Chart
XTPChartLegendItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLEGENDITEM_H__)
24# define __XTPCHARTLEGENDITEM_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPChartLegendItemView
39{
40public:
44 virtual ~CXTPChartLegendItemView()
45 {
46 }
47
56 virtual CXTPChartString GetLegendName() const = 0;
57
69 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
70 CRect rcBounds) = 0;
71};
72
73class _XTP_EXT_CLASS CXTPChartLegendItem : public CXTPChartElement
74{
75private:
76 enum
77 {
78 UseDefaultLineThickness = -1,
79 };
80
81public:
82 CXTPChartLegendItem();
83
84 void SetLineThickness(int nLineThickness);
85
86 int GetActualLineThickness() const;
87
94 void SetDashStyle(XTPChartDashStyle nDashStyle);
95
103 XTPChartDashStyle GetDashStyle() const;
104
105protected:
106 int m_nLineThickness;
107 XTPChartDashStyle m_nDashStyle;
109# ifdef _XTP_ACTIVEX
110public:
112 DECLARE_DISPATCH_MAP()
113 DECLARE_INTERFACE_MAP()
114 DECLARE_OLETYPELIB_EX(CXTPChartLegendItem);
116# endif
117
118 friend class CXTPChartSeries;
119};
121# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
122#endif //#if !defined(__XTPCHARTLEGENDITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartLegendItemView
CXTPChartLegendItemView is an abstract base class which represents a chart legend item.
Definition XTPChartLegendItem.h:39
CXTPChartLegendItemView::GetLegendName
virtual CXTPChartString GetLegendName() const =0
This function returns the legend name.
CXTPChartLegendItemView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a lege...
CXTPChartLegendItemView::~CXTPChartLegendItemView
virtual ~CXTPChartLegendItemView()
Handles object destruction.
Definition XTPChartLegendItem.h:44
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50


Toolkit Pro: XTPSyntaxEditLexPtrs.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditLexPtrs.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITLEXPTRS_H__)
24# define __XTPSYNTAXEDITLEXPTRS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditTextIterator;
34
36
37namespace XTPSyntaxEditLexAnalyser
39{
40typedef CXTPSyntaxEditTextIterator CTextIter;
41
42class CXTPSyntaxEditLexVariant;
43class CXTPSyntaxEditLexTextSchema;
44class CXTPSyntaxEditLexParser;
45class CXTPSyntaxEditLexParserSchemaOptions;
46class CXTPSyntaxEditLexClass;
47class CXTPSyntaxEditLexClass_file;
48class CXTPSyntaxEditLexTextBlock;
49
50typedef CXTPSmartPtrInternalT<CXTPSyntaxEditLexVariant> CXTPSyntaxEditLexVariantPtr;
51typedef CXTPSmartPtrInternalT<CXTPSyntaxEditLexClass> CXTPSyntaxEditLexClassPtr;
52typedef CXTPSmartPtrInternalT<CXTPSyntaxEditLexTextBlock> CXTPSyntaxEditLexTextBlockPtr;
53typedef CXTPSmartPtrInternalT<CXTPSyntaxEditLexParser> CXTPSyntaxEditLexParserPtr;
54
55typedef CXTPInternalCollectionT<CXTPSyntaxEditLexTextBlock> CXTPSyntaxEditLexTextBlockPtrArray;
56typedef CXTPInternalCollectionT<CXTPSyntaxEditLexVariant> CXTPSyntaxEditLexVariantPtrArray;
57typedef CXTPInternalCollectionT<CXTPSyntaxEditLexClass> CXTPSyntaxEditLexClassPtrArray;
58
59typedef CXTPSmartPtrInternalT<CXTPSyntaxEditLexVariantPtrArray> CXTPSyntaxEditLexVariantPtrArrayPtr;
60
61} // END namespace XTPSyntaxEditLexAnalyser
62
64
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
67#endif // !defined(__XTPSYNTAXEDITLEXPTRS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPInternalCollectionT
Definition XTPSmartPtrInternalT.h:387
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72
CXTPSyntaxEditLexClass
CXTPSyntaxEditLexClass class is used to represent lexical block of text definition and to parse text.
Definition XTPSyntaxEditLexClass.h:633
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in a separate thread.
Definition XTPSyntaxEditLexParser.h:861
CXTPSyntaxEditLexParserSchemaOptions
This class is designed to easily manipulate parser options.
Definition XTPSyntaxEditLexParser.h:163
CXTPSyntaxEditLexTextBlock
The CXTPSyntaxEditLexTextBlock class represents a block of text which corresponds to a lex class in a...
Definition XTPSyntaxEditLexParser.h:266
CXTPSyntaxEditLexTextSchema
The CXTPSyntaxEditLexTextSchema class is used to store data which is necessary to parse a text and pa...
Definition XTPSyntaxEditLexParser.h:428
CXTPSyntaxEditLexVariant
CXTPSyntaxEditLexVariant provides functionality to manipulate Lexical Analyzer's related variant type...
Definition XTPSyntaxEditLexClass.h:230
CXTPSyntaxEditTextIterator
This class provides functionality to navigate text in the data buffer, seek forward/backward,...
Definition XTPSyntaxEditTextIterator.h:47


CXTPTrayIcon Member List

This is the complete list of members for CXTPTrayIcon, including all inherited members.

AddIcon() | CXTPTrayIcon |
Create(LPCTSTR lpszCaption, CWnd *pParentWnd, UINT nIconID, UINT uMenuID=0, UINT uDefMenuItemID=0, bool bDefMenuItemByPos=false) | CXTPTrayIcon | virtual
CreateMinimizeWnd(CWnd *pWndApp) | CXTPTrayIcon | virtual
CXTPTrayIcon() | CXTPTrayIcon |
GetCallbackMessage() | CXTPTrayIcon |
GetDefaultMenuItem(UINT &uItem, bool &bByPos) | CXTPTrayIcon |
GetIcon() const | CXTPTrayIcon |
GetNotificationWnd() | CXTPTrayIcon |
GetTooltipText() const | CXTPTrayIcon |
HideIcon() | CXTPTrayIcon |
InstallIconPending() | CXTPTrayIcon | virtual
IsShellVersion5() const | CXTPTrayIcon |
KillTimer() | CXTPTrayIcon | virtual
m_arTrayIcons | CXTPTrayIcon | protected
m_bDefMenuItemByPos | CXTPTrayIcon | protected
m_bHidden | CXTPTrayIcon | protected
m_bRemoved | CXTPTrayIcon | protected
m_bShowPending | CXTPTrayIcon | protected
m_hIcon | CXTPTrayIcon | protected
m_hWndNotify | CXTPTrayIcon | protected
m_iMaxTipSize | CXTPTrayIcon | protected
m_nCounter | CXTPTrayIcon | protected
m_nIconID | CXTPTrayIcon | protected
m_niData | CXTPTrayIcon | protected
m_nIDEvent | CXTPTrayIcon | protected
m_strToolTip | CXTPTrayIcon | protected
m_uDefMenuItemID | CXTPTrayIcon | protected
m_uFlags | CXTPTrayIcon | protected
m_wndMinimize | CXTPTrayIcon | protected
MaximizeFromTray(CWnd *pWnd) | CXTPTrayIcon |
MinimizeToTray(CWnd *pWnd) | CXTPTrayIcon |
RemoveAnimationIcons() | CXTPTrayIcon | virtual
RemoveIcon() | CXTPTrayIcon |
SetAnimationIcons(const UINT *lpIDArray, const CString *lpStrTipArray, int nIDCount) | CXTPTrayIcon | virtual
SetAnimationIcons(const UINT *lpIDArray, int nIDCount, const CString *lpStrTipArray=NULL) | CXTPTrayIcon | virtual
SetCallbackMessage(UINT uNewCallbackMessage) | CXTPTrayIcon |
SetDefaultMenuItem(UINT uItem, bool bByPos) | CXTPTrayIcon |
SetDefaultValues() | CXTPTrayIcon |
SetIcon(HICON hIcon) | CXTPTrayIcon |
SetIcon(LPCTSTR lpszIconName) | CXTPTrayIcon |
SetIcon(UINT nIDResource) | CXTPTrayIcon |
SetNotificationWnd(CWnd *pWndNotify) | CXTPTrayIcon |
SetTimer(UINT nIDEvent, UINT uElapse) | CXTPTrayIcon | virtual
SetTooltip(LPCTSTR strToolTip) | CXTPTrayIcon | virtual
SetTooltipText(UINT nTipText) | CXTPTrayIcon |
SetTooltipText(LPCTSTR lpszTipText) | CXTPTrayIcon |
SetTrayIcon(UINT nIcon, DWORD dwMessage=NIM_ADD) | CXTPTrayIcon | virtual
ShellNotify(DWORD dwMessage) | CXTPTrayIcon |
ShowBalloonTip(LPCTSTR lpszInfo=NULL, LPCTSTR lpszInfoTitle=NULL, DWORD dwInfoFlags=NIIF_NONE, UINT uTimeout=10, HICON hBaloonIcon=NULL) | CXTPTrayIcon |
ShowIcon() | CXTPTrayIcon |
ShowIcon(BOOL bShow) | CXTPTrayIcon |
StartAnimation(UINT uElapse=500) | CXTPTrayIcon | virtual
StopAnimation() | CXTPTrayIcon | virtual
~CXTPTrayIcon() | CXTPTrayIcon | virtual


CXTPEdit Member List

This is the complete list of members for CXTPEdit, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEdit |
CanOverType() const | CXTPMaskEditT< CEdit > | inline
CanPaste() | CXTPEdit | virtual
CanUseMask() const | CXTPMaskEditT< CEdit > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< CEdit > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< CEdit > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< CEdit > | inline
CXTPEdit() | CXTPEdit |
CXTPMaskEditT() | CXTPMaskEditT< CEdit > | inline
DeleteCharAt(int iPos) | CXTPMaskEditT< CEdit > | inline
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment) | CXTPEdit |
GetClientBrush(CDC *pDC) | CXTPEdit | protected
GetFlatStyle() const | CXTPEdit |
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< CEdit > | inline
GetPromptChar() const | CXTPMaskEditT< CEdit > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< CEdit > | inline
GetTheme() | CXTPEdit |
GetThemeID() | CXTPEdit |
GetUseVisualStyle() const | CXTPEdit |
HasSelection() const | CXTPEdit |
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< CEdit > | inline
IsFlatStyle() const | CXTPEdit |
IsFocused() const | CXTPEdit |
IsHighlighted() const | CXTPEdit |
IsModified() const | CXTPMaskEditT< CEdit > | inline
IsPatternValid() | CXTPEdit |
m_bFocused | CXTPEdit | protected
m_bHighlighted | CXTPEdit | protected
m_bModified | CXTPMaskEditT< CEdit > | protected
m_bOverType | CXTPMaskEditT< CEdit > | protected
m_bPreSubclassInit | CXTPEdit | protected
m_bRedo | CXTPMaskEditT< CEdit > | protected
m_bShowBorder | CXTPEdit | protected
m_bUpdateUndo | CXTPMaskEditT< CEdit > | protected
m_bUseMask | CXTPMaskEditT< CEdit > | protected
m_chPrompt | CXTPMaskEditT< CEdit > | protected
m_nEndChar | CXTPMaskEditT< CEdit > | protected
m_nStartChar | CXTPMaskEditT< CEdit > | protected
m_pRegExp | CXTPEdit | protected
m_pTheme | CXTPEdit | protected
m_strDefault | CXTPMaskEditT< CEdit > | protected
m_strLiteral | CXTPMaskEditT< CEdit > | protected
m_strMask | CXTPMaskEditT< CEdit > | protected
m_strRedoBuffer | CXTPMaskEditT< CEdit > | protected
m_strUndoBuffer | CXTPMaskEditT< CEdit > | protected
m_strWindowText | CXTPMaskEditT< CEdit > | protected
MaskClear() | CXTPMaskEditT< CEdit > | inline
MaskCopy() | CXTPMaskEditT< CEdit > | inline
MaskCut() | CXTPMaskEditT< CEdit > | inline
MaskDeleteSel() | CXTPMaskEditT< CEdit > | inline
MaskPaste() | CXTPMaskEditT< CEdit > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< CEdit > | inline
MaskSelectAll() | CXTPMaskEditT< CEdit > | inline
MaskUndo() | CXTPMaskEditT< CEdit > | inline
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< CEdit > | inlineprotectedvirtual
PosInRange(int iPos) const | CXTPMaskEditT< CEdit > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< CEdit > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< CEdit > | inlinevirtual
RedrawEdit() | CXTPEdit | protected
RedrawFocusedFrame() | CXTPEdit | protected
RefreshMetrics() | CXTPEdit | virtual
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPEdit | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPEdit |
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< CEdit > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< CEdit > | inline
SetPattern(LPCTSTR lpszPattern) | CXTPEdit |
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< CEdit > | inline
SetTheme(XTPControlTheme nTheme) | CXTPEdit | virtual
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< CEdit > | inline
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPEdit |
ShowBorder() const | CXTPEdit |
ShowThemedBorder(BOOL bShowThemedBorder) | CXTPEdit |
~CXTPEdit() | CXTPEdit | virtual


Toolkit Pro: XTPChartAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAREASERIESSTYLE_H__)
24# define __XTPCHARTAREASERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartAreaSeriesStyle : public CXTPChartPointSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartAreaSeriesStyle)
52public:
57 CXTPChartAreaSeriesStyle();
58
63 virtual ~CXTPChartAreaSeriesStyle();
64
65public:
73 CXTPChartFillStyle* GetFillStyle() const;
74
75 CXTPChartBorder* GetBorder() const;
76
77public:
78 void DoPropExchange(CXTPPropExchange* pPX);
79
80public:
91 int GetTransparency() const;
92
103 void SetTransparency(int nTransparency);
104
115 BOOL GetFillAcrossXAxis() const;
116
127 void SetFillAcrossXAxis(BOOL nFillAcrossXAxis);
128
129protected:
142 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
143 CXTPChartDiagramView* pDiagramView);
144
145# ifdef _XTP_ACTIVEX
146public:
148 DECLARE_DISPATCH_MAP()
149 DECLARE_INTERFACE_MAP()
150 DECLARE_OLETYPELIB_EX(CXTPChartAreaSeriesStyle);
151 DECLARE_OLECREATE_EX(CXTPChartAreaSeriesStyle)
152
153 LPDISPATCH OleGetFillStyle();
154 LPDISPATCH OleGetBorder();
156# endif
157
158protected:
159 int m_nTransparency;
160 CXTPChartBorder* m_pBorder;
162 CXTPChartFillStyle* m_pFillStyle;
164 BOOL m_nFillAcrossXAxis;
165};
166
167AFX_INLINE int CXTPChartAreaSeriesStyle::GetTransparency() const
168{
169 return m_nTransparency;
170}
171AFX_INLINE void CXTPChartAreaSeriesStyle::SetTransparency(int nTransparency)
172{
173 m_nTransparency = nTransparency;
174 OnChartChanged();
175}
176AFX_INLINE CXTPChartFillStyle* CXTPChartAreaSeriesStyle::GetFillStyle() const
177{
178 return m_pFillStyle;
179}
180AFX_INLINE CXTPChartBorder* CXTPChartAreaSeriesStyle::GetBorder() const
181{
182 return m_pBorder;
183}
184AFX_INLINE BOOL CXTPChartAreaSeriesStyle::GetFillAcrossXAxis() const
185{
186 return m_nFillAcrossXAxis;
187}
188AFX_INLINE void CXTPChartAreaSeriesStyle::SetFillAcrossXAxis(BOOL nFillAcrossXAxis)
189{
190 m_nFillAcrossXAxis = nFillAcrossXAxis;
191 OnChartChanged();
192}
194# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
195#endif //#if !defined(__XTPCHARTAREASERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle is a CXTPChartPointSeriesStyle derived class which represents the area serie...
Definition XTPChartAreaSeriesStyle.h:48
CXTPChartAreaSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAreaSeriesStyle::~CXTPChartAreaSeriesStyle
virtual ~CXTPChartAreaSeriesStyle()
Destroys a CXTPChartAreaSeriesStyle object, handles cleanup.
CXTPChartAreaSeriesStyle::SetFillAcrossXAxis
void SetFillAcrossXAxis(BOOL nFillAcrossXAxis)
Call this function to set the fill chart area indicator with respect to the background.
Definition XTPChartAreaSeriesStyle.h:188
CXTPChartAreaSeriesStyle::m_nTransparency
int m_nTransparency
The transparency values range from 0 to 255.
Definition XTPChartAreaSeriesStyle.h:159
CXTPChartAreaSeriesStyle::SetTransparency
void SetTransparency(int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
Definition XTPChartAreaSeriesStyle.h:171
CXTPChartAreaSeriesStyle::CXTPChartAreaSeriesStyle
CXTPChartAreaSeriesStyle()
Constructs a CXTPChartAreaSeriesStyle object.
CXTPChartAreaSeriesStyle::GetFillStyle
CXTPChartFillStyle * GetFillStyle() const
Call this function to get the background fill style.
Definition XTPChartAreaSeriesStyle.h:176
CXTPChartAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
CXTPChartAreaSeriesStyle::m_pBorder
CXTPChartBorder * m_pBorder
The chart border object pointer.
Definition XTPChartAreaSeriesStyle.h:160
CXTPChartAreaSeriesStyle::GetTransparency
int GetTransparency() const
Call this function to get the transparency of the filled area with respect to the background.
Definition XTPChartAreaSeriesStyle.h:167
CXTPChartAreaSeriesStyle::m_pFillStyle
CXTPChartFillStyle * m_pFillStyle
The chart background fill style.
Definition XTPChartAreaSeriesStyle.h:162
CXTPChartAreaSeriesStyle::m_nFillAcrossXAxis
BOOL m_nFillAcrossXAxis
Fill chart area across X axis (under and over X axis)
Definition XTPChartAreaSeriesStyle.h:164
CXTPChartAreaSeriesStyle::GetFillAcrossXAxis
BOOL GetFillAcrossXAxis() const
Call this function to get the fill chart area indicator with respect to the background.
Definition XTPChartAreaSeriesStyle.h:184
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartPointSeriesStyle.h:47
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesStyle::SetTransparency
virtual void SetTransparency(int nTransparency)
Call this function to sets the transparency of the chart if it is supported by the chart type.
Definition XTPChartSeriesStyle.h:405
CXTPChartSeriesStyle::GetTransparency
virtual int GetTransparency() const
Call this function to gets the transparency of the chart if it is supported by the chart type.
Definition XTPChartSeriesStyle.h:400
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPFlowGraphMessages.h Source File

  • Source
  • FlowGraph
XTPFlowGraphMessages.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHMESSAGES_H__)
24# define __XTPFLOWGRAPHMESSAGES_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphNode;
34
39struct XTP_NM_FLOWGRAPH_ENDLABELEDIT
40{
41 NMHDR hdr;
43 CXTPFlowGraphElement* pItem;
44 CString strNewString;
45};
46
53const UINT XTP_FGN_ENDLABELEDIT = (NM_FIRST - 61);
54
59const UINT XTP_FGN_ACTIVEPAGECHANGED = (NM_FIRST - 62);
60
65struct XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
66{
67 NMHDR hdr;
69 CXTPFlowGraphConnection* pConnection;
70 int nAction;
71};
72
79const UINT XTP_FGN_CONNECTIONCHANGED = (NM_FIRST - 63);
80
86const UINT XTP_FGN_SELECTIONCHANGED = (NM_FIRST - 64);
87
92const UINT XTP_FGN_PAGEZOOMLEVELCHANGED = (NM_FIRST - 65);
93
98struct XTP_NM_FLOWGRAPH_NODECHANGED
99{
100 NMHDR hdr;
102 CXTPFlowGraphNode* pNode;
103};
104
111const UINT XTP_FGN_NODELOCATIONCHANGED = (NM_FIRST - 66);
112
120const UINT XTP_FGN_PAGESCROLLOFFSETCHANGED = (NM_FIRST - 67);
121
126struct XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
127{
128 NMHDR hdr;
130 CXTPFlowGraphConnection* pConnection;
131 CXTPFlowGraphConnectionPoint* pInputConnectionPoint;
132};
140const UINT XTP_FGN_CONNECTIONCHANGING = (NM_FIRST - 68);
142# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
143#endif //#if !defined(__XTPFLOWGRAPHMESSAGES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_FGN_CONNECTIONCHANGING
const UINT XTP_FGN_CONNECTIONCHANGING
This notification is sent when a connection is changing.
Definition XTPFlowGraphMessages.h:140
XTP_FGN_PAGEZOOMLEVELCHANGED
const UINT XTP_FGN_PAGEZOOMLEVELCHANGED
This notification is sent when the page zoom level is changed.
Definition XTPFlowGraphMessages.h:92
XTP_FGN_ENDLABELEDIT
const UINT XTP_FGN_ENDLABELEDIT
This notification is sent when editing is ended for a label.
Definition XTPFlowGraphMessages.h:53
XTP_FGN_PAGESCROLLOFFSETCHANGED
const UINT XTP_FGN_PAGESCROLLOFFSETCHANGED
This notification is sent when the offset of the page is changed.
Definition XTPFlowGraphMessages.h:120
XTP_FGN_ACTIVEPAGECHANGED
const UINT XTP_FGN_ACTIVEPAGECHANGED
This notification is sent when a page is set to active.
Definition XTPFlowGraphMessages.h:59
XTP_FGN_NODELOCATIONCHANGED
const UINT XTP_FGN_NODELOCATIONCHANGED
This notification is sent when the location of a node is changed.
Definition XTPFlowGraphMessages.h:111
XTP_FGN_SELECTIONCHANGED
const UINT XTP_FGN_SELECTIONCHANGED
This notification is sent when the selection is changed.
Definition XTPFlowGraphMessages.h:86
XTP_FGN_CONNECTIONCHANGED
const UINT XTP_FGN_CONNECTIONCHANGED
This notification is sent when a connection is added or removed.
Definition XTPFlowGraphMessages.h:79
CXTPFlowGraphConnection
Represents a connection.
Definition XTPFlowGraphConnection.h:49
CXTPFlowGraphConnectionPoint
Represents a connection point for a node.
Definition XTPFlowGraphConnectionPoint.h:46
CXTPFlowGraphElement
Base class for all elements in the flow graph.
Definition XTPFlowGraphElement.h:46
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
XTP_NM_FLOWGRAPH_CONNECTIONCHANGED
Information about the connection that has changed.
Definition XTPFlowGraphMessages.h:66
XTP_NM_FLOWGRAPH_CONNECTIONCHANGED::pConnection
CXTPFlowGraphConnection * pConnection
Connection.
Definition XTPFlowGraphMessages.h:69
XTP_NM_FLOWGRAPH_CONNECTIONCHANGED::hdr
NMHDR hdr
Standard structure containing information about a notification message.
Definition XTPFlowGraphMessages.h:67
XTP_NM_FLOWGRAPH_CONNECTIONCHANGED::nAction
int nAction
0 - Added, 1 - Removed.
Definition XTPFlowGraphMessages.h:70
XTP_NM_FLOWGRAPH_CONNECTIONCHANGING
Information about the connection that is currently changing.
Definition XTPFlowGraphMessages.h:127
XTP_NM_FLOWGRAPH_CONNECTIONCHANGING::pConnection
CXTPFlowGraphConnection * pConnection
Connection.
Definition XTPFlowGraphMessages.h:130
XTP_NM_FLOWGRAPH_CONNECTIONCHANGING::hdr
NMHDR hdr
Standard structure containing information about a notification message.
Definition XTPFlowGraphMessages.h:128
XTP_NM_FLOWGRAPH_CONNECTIONCHANGING::pInputConnectionPoint
CXTPFlowGraphConnectionPoint * pInputConnectionPoint
Connection point.
Definition XTPFlowGraphMessages.h:131
XTP_NM_FLOWGRAPH_ENDLABELEDIT
Information about the label whose editing has ended.
Definition XTPFlowGraphMessages.h:40
XTP_NM_FLOWGRAPH_ENDLABELEDIT::pItem
CXTPFlowGraphElement * pItem
Item whose caption will be changed.
Definition XTPFlowGraphMessages.h:43
XTP_NM_FLOWGRAPH_ENDLABELEDIT::hdr
NMHDR hdr
Standard structure containing information about a notification message.
Definition XTPFlowGraphMessages.h:41
XTP_NM_FLOWGRAPH_ENDLABELEDIT::strNewString
CString strNewString
New caption for the item.
Definition XTPFlowGraphMessages.h:44
XTP_NM_FLOWGRAPH_NODECHANGED
Information about the node that has changed.
Definition XTPFlowGraphMessages.h:99
XTP_NM_FLOWGRAPH_NODECHANGED::hdr
NMHDR hdr
Standard structure containing information about a notification message.
Definition XTPFlowGraphMessages.h:100
XTP_NM_FLOWGRAPH_NODECHANGED::pNode
CXTPFlowGraphNode * pNode
Node.
Definition XTPFlowGraphMessages.h:102


CXTPChartRotateDeviceCommand Member List

This is the complete list of members for CXTPChartRotateDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRotateDeviceCommand(float fAngle) | CXTPChartRotateDeviceCommand | protected
CXTPChartRotateDeviceCommand(float fAngle, const CXTPPoint3d &rotateVector) | CXTPChartRotateDeviceCommand | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartRotateDeviceCommand | protectedvirtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_fAngle | CXTPChartRotateDeviceCommand | protected
m_ptRotateVector | CXTPChartRotateDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


CXTPCalendarEventColorListBox Member List

This is the complete list of members for CXTPCalendarEventColorListBox, including all inherited members.

AddItem() | CXTPCalendarEventColorListBox | virtual
BeginEdit() | CXTPCalendarEventColorListBox | virtual
CalcColorRect(CRect rItem) | CXTPCalendarEventColorListBox | protected
CXTPCalendarEventColorListBox() | CXTPCalendarEventColorListBox |
DeleteItem(int nItem=LB_ERR) | CXTPCalendarEventColorListBox | virtual
EndEdit(BOOL bUpdate=TRUE) | CXTPCalendarEventColorListBox | virtual
GetCategory(int nIndex) | CXTPCalendarEventColorListBox |
GetEdit() | CXTPCalendarEventColorListBox |
GetLabel(int nIndex) | CXTPCalendarEventColorListBox |
Init(CXTPCalendarData *pData, CXTPCalendarEvent *pEvent, BOOL bCategories) | CXTPCalendarEventColorListBox | virtual
IsModified() | CXTPCalendarEventColorListBox |
m_arChecked | CXTPCalendarEventColorListBox | protected
m_bCategories | CXTPCalendarEventColorListBox | protected
m_bModified | CXTPCalendarEventColorListBox | protected
m_pData | CXTPCalendarEventColorListBox | protected
m_pEvent | CXTPCalendarEventColorListBox | protected
m_pWndEdit | CXTPCalendarEventColorListBox | protected
m_sizeColor | CXTPCalendarEventColorListBox | protected
SetItemColor(COLORREF crItem, int nItem=LB_ERR) | CXTPCalendarEventColorListBox | virtual
SetModified(BOOL bModified) | CXTPCalendarEventColorListBox |
ToggleCheck(int nItem) | CXTPCalendarEventColorListBox |
UpdateCategories(CXTPCalendarData *pData) | CXTPCalendarEventColorListBox |
UpdateLabels(CXTPCalendarData *pData) | CXTPCalendarEventColorListBox |
~CXTPCalendarEventColorListBox() | CXTPCalendarEventColorListBox | virtual


CXTPChartGanttSeriesView Member List

This is the complete list of members for CXTPChartGanttSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
BeforeUpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartBarSeriesView | protected
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartGanttSeriesView | protected
CXTPChartBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartBarSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartGanttSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartGanttSeriesView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRangeBarSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_nBarCount | CXTPChartBarSeriesView | protected
m_nBarIndex | CXTPChartBarSeriesView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


CXTPDockingPanePanelColorSet2013 Member List

This is the complete list of members for CXTPDockingPanePanelColorSet2013, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPDockingPanePanelColorSet2013() | CXTPDockingPanePanelColorSet2013 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSet2013 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


CXTPShortcutBarVisualStudio2017Theme Member List

This is the complete list of members for CXTPShortcutBarVisualStudio2017Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
CXTPShortcutBarVisualStudio2017Theme() | CXTPShortcutBarVisualStudio2017Theme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarOffice2013Theme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarVisualStudio2017Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2017Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2017Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bHiliteBorders | CXTPShortcutBarVisualStudio2017Theme | protected
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrBackHiliteSelected | CXTPShortcutBarVisualStudio2017Theme | protected
m_clrBorderHilite | CXTPShortcutBarVisualStudio2017Theme | protected
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrGlyph | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphExpanded | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphFill | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphPushed | CXTPShortcutBarOffice2013Theme | protected
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarVisualStudio2017Theme | virtual
~CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual
~CXTPShortcutBarVisualStudio2017Theme() | CXTPShortcutBarVisualStudio2017Theme | virtual


Toolkit Pro: XTPSkinObjectTrackBar.h Source File

  • Source
  • SkinFramework
XTPSkinObjectTrackBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTTRACKBAR_H__)
24# define __XTPSKINOBJECTTRACKBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectTrackBar : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectTrackBar)
43private:
44 struct DRAWRECT
45 {
46 RECT rc;
47 int iThumbWidth;
48 int iThumbHeight;
49 int iSizePhys;
50 DWORD dwStyle;
51 };
52
53public:
58 CXTPSkinObjectTrackBar();
59
64 virtual ~CXTPSkinObjectTrackBar();
65
66protected:
68 void DrawTics(CDC* pDC);
69 void DrawTicsOneLine(CDC* pDC, int dir, int yTic);
70 void DrawTic(CDC* pDC, int x, int y, int dir, COLORREF clr);
71 int LogToPhys(DWORD dwPos);
72 void FillDrawRect();
73 void DrawChannel(CDC* pDC);
74 void DrawThumb(CDC* pDC);
75 void OnDraw(CDC* pDC);
76
77protected:
78 DECLARE_MESSAGE_MAP()
79
80 //{{AFX_VIRTUAL(CXTPSkinObjectTrackBar)
81 //}}AFX_VIRTUAL
82
83 //{{AFX_MSG(CXTPSkinObjectTrackBar)
84 BOOL OnEraseBkgnd(CDC* pDC);
85 void OnPaint();
86 LRESULT OnSetTicFreq(WPARAM, LPARAM);
87 void OnMouseMove(UINT nFlags, CPoint point);
88 void OnMouseLeave();
89 void OnLButtonDown(UINT nFlags, CPoint point);
90 void OnLButtonUp(UINT nFlags, CPoint point);
91 LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
92 //}}AFX_MSG
93
94protected:
95 int m_nTickFreq;
96 DRAWRECT m_drawRect;
97 BOOL m_bHotThumb;
99};
100
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
103#endif // !defined(__XTPSKINOBJECTTRACKBAR_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectTrackBar
CXTPSkinObjectTrackBar is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectTrackBar.h:39
CXTPSkinObjectTrackBar::~CXTPSkinObjectTrackBar
virtual ~CXTPSkinObjectTrackBar()
Destroys a CXTPSkinObjectTrackBar object, handles cleanup and deallocation.
CXTPSkinObjectTrackBar::CXTPSkinObjectTrackBar
CXTPSkinObjectTrackBar()
Constructs a CXTPSkinObjectTrackBar object.


Toolkit Pro: XTPSyntaxEditGoToLineDlg.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditGoToLineDlg.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITGOTOLINEDLG_H__)
24# define __XTPSYNTAXEDITGOTOLINEDLG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPSyntaxEditGoToLineDlg : public CDialog
38{
39public:
45 CXTPSyntaxEditGoToLineDlg(CWnd* pParent = NULL);
46
48 enum
49 {
50 IDD = XTP_IDD_EDIT_GOTOLINE
51 };
52 CEdit m_wndEditLineNo;
53 int m_iLineNo;
54 CString m_csLineNo;
70 BOOL ShowDialog(CXTPSyntaxEditCtrl* pEditCtrl, BOOL bSelectLine = FALSE,
71 BOOL bHideOnFind = FALSE);
72
74public:
75 virtual BOOL PreTranslateMessage(MSG* pMsg);
76
77protected:
78 virtual void DoDataExchange(CDataExchange* pDX);
81protected:
88 virtual BOOL LoadPos();
89
96 virtual BOOL SavePos();
97
99 afx_msg void OnChangeEditLineNo();
100 virtual BOOL OnInitDialog();
101 afx_msg void OnBtnGoTo();
102 virtual void OnCancel();
103
104 DECLARE_MESSAGE_MAP()
107 int m_iMaxLineNo;
108 BOOL m_bHideOnFind;
109 BOOL m_bSelectLine;
110 CPoint m_ptWndPos;
111 CXTPSyntaxEditCtrl* m_pEditCtrl;
112};
113
115
116//{{AFX_INSERT_LOCATION}}
117// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
118
119# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
121#endif // !defined(__XTPSYNTAXEDITGOTOLINEDLG_H__)
XTPDisableNoisyWarnings.h
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditGoToLineDlg
This class implements the "GoToLine" dialog for a SyntaxEdit control.
Definition XTPSyntaxEditGoToLineDlg.h:38
CXTPSyntaxEditGoToLineDlg::CXTPSyntaxEditGoToLineDlg
CXTPSyntaxEditGoToLineDlg(CWnd *pParent=NULL)
Default object constructor.
CXTPSyntaxEditGoToLineDlg::LoadPos
virtual BOOL LoadPos()
Loads window position from the application profile.
CXTPSyntaxEditGoToLineDlg::ShowDialog
BOOL ShowDialog(CXTPSyntaxEditCtrl *pEditCtrl, BOOL bSelectLine=FALSE, BOOL bHideOnFind=FALSE)
Shows the "GoToLine" dialog.
CXTPSyntaxEditGoToLineDlg::SavePos
virtual BOOL SavePos()
Saves window position to the application profile.


CXTPListBase Member List

This is the complete list of members for CXTPListBase, including all inherited members.

_xtGetHeaderCtrl() const | CXTPListBase |
AddColumn(LPCTSTR lpszColHeading, int nWidth=-1, int nFormat=LVCFMT_LEFT) | CXTPListBase | virtual
AutoSaveColumns(LPCTSTR lpszSection=NULL, LPCTSTR lpszEntry=NULL, LPCTSTR lpszDefault=NULL) | CXTPListBase | virtual
AutoSizeColumn(int nCol=-1) | CXTPListBase | virtual
AutoSizeColumn(int nCol, BOOL bUseHeader) | CXTPListBase | virtual
BuildColumns(int nCols, int *nWidth, int *nColString) | CXTPListBase | virtual
BuildColumns(int nCols, int *nWidth, CString *strColString) | CXTPListBase | virtual
CopyRow(int nFrom, int nTo) | CXTPListBase | virtual
CRowColorList typedef | CXTPListBase |
CXTPListBase() | CXTPListBase |
DisableColumnSizing(bool bDisable) | CXTPListBase | virtual
EnableUserListColor(bool bEnable) | CXTPListBase |
EnableUserRowColor(bool bEnable) | CXTPListBase |
EnableUserSortColor(bool bEnable) | CXTPListBase |
GetColumnCount() | CXTPListBase | virtual
GetExtendedStyle() | CXTPListBase | virtual
GetListBackColor() const | CXTPListBase |
GetListTextColor() const | CXTPListBase |
GetMaximumColSize() | CXTPListBase |
GetMinimumColSize() | CXTPListBase |
GetSortBackColor() const | CXTPListBase |
GetSortTextColor() const | CXTPListBase |
GetStoredWidth(int nCol) | CXTPListBase | virtual
HitTestEx(CPoint &point, int *col) const | CXTPListBase | virtual
ImplAttach(CListCtrl *pListCtrl) | CXTPListBase | protected
Init() | CXTPListBase | protectedvirtual
IsUserListColor() const | CXTPListBase |
IsUserRowColor() const | CXTPListBase |
IsUserSortColor() const | CXTPListBase |
LoadColumnWidths() | CXTPListBase | virtual
Lookup(int iRow) | CXTPListBase | virtual
m_arRowColor | CXTPListBase | protected
m_bAscending | CXTPListBase | protected
m_bAutoFont | CXTPListBase | protected
m_bAutoSave | CXTPListBase | protected
m_bListColor | CXTPListBase | protected
m_bNoColSizing | CXTPListBase | protected
m_bRowColor | CXTPListBase | protected
m_bSortColor | CXTPListBase | protected
m_crListBack | CXTPListBase | protected
m_crListText | CXTPListBase | protected
m_crSortBack | CXTPListBase | protected
m_crSortText | CXTPListBase | protected
m_nMaxColWidth | CXTPListBase | protected
m_nMinColWidth | CXTPListBase | protected
m_nSortedCol | CXTPListBase | protected
m_pListCtrl | CXTPListBase | protected
m_strDefault | CXTPListBase | protected
m_strEntry | CXTPListBase | protected
m_strSection | CXTPListBase | protected
m_wndHeader | CXTPListBase | protected
ModifyExtendedStyle(DWORD dwRemove, DWORD dwAdd) | CXTPListBase | virtual
MoveRow(int nFrom, int nTo) | CXTPListBase | virtual
OnNotify(WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPListBase | protectedvirtual
RefreshMetrics() | CXTPListBase | protected
RemoveRowColors() | CXTPListBase |
SaveColumnWidths() | CXTPListBase | virtual
SetAutoFont(bool bAutoFont) | CXTPListBase |
SetExtendedStyle(DWORD dwExStyle) | CXTPListBase | virtual
SetListBackColor(COLORREF crListBack) | CXTPListBase |
SetListTextColor(COLORREF crListText) | CXTPListBase |
SetMinimumColSize(int nSize) | CXTPListBase |
SetRowColor(ROWCOLOR *lpRowColor, BOOL bRedraw=TRUE) | CXTPListBase |
SetRowColor(int iRow, COLORREF crText, COLORREF crBack, BOOL bRedraw=TRUE) | CXTPListBase |
SetRowColors(COLORREF clrText, COLORREF clrTextBk) | CXTPListBase |
SetSortBackColor(COLORREF crSortBack) | CXTPListBase |
SetSortImage(int nCol, BOOL bAsc) | CXTPListBase | virtual
SetSortTextColor(COLORREF crSortText) | CXTPListBase |
SetStoredWidth(int nCol) | CXTPListBase | virtual
SortList(int nCol, bool bAscending) | CXTPListBase | virtual
SubclassHeader(bool bBoldFont=false) | CXTPListBase | virtual
XTPGetHeaderCtrl() const | CXTPListBase |
~CXTPListBase() | CXTPListBase | virtual


Toolkit Pro: XTPEdit.h Source File

  • Source
  • Controls
  • Edit
XTPEdit.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDIT_H__)
24# define __XTPEDIT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRegExp;
34class CXTPWinThemeWrapper;
35class CXTPEditTheme;
36
37// afx_msg void memberFxn();
128class _XTP_EXT_CLASS CXTPEdit : public CXTPMaskEditT<CEdit>
129{
130 DECLARE_DYNAMIC(CXTPEdit)
131
132 typedef CXTPMaskEditT<CEdit> TBase;
133
134public:
139 CXTPEdit();
140
145 virtual ~CXTPEdit();
146
186 BOOL SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault = NULL);
187
193 void SetPattern(LPCTSTR lpszPattern);
194
203 virtual BOOL CanPaste();
204
211 BOOL HasSelection() const;
212
222 void AdjustBuddyRect(CWnd* pBuddy, CRect& rcUpDown, int nAlignment);
223
234 void DrawBuddyBorders(CWnd* pBuddy, CDC* pDC, CRect rc, int nAlignment);
235
241 virtual void RefreshMetrics();
242
259 virtual void SetTheme(XTPControlTheme nTheme);
260
267 XTPControlTheme GetThemeID();
268
275 CXTPEditTheme* GetTheme();
276
286 BOOL GetFlatStyle() const;
287
296 void SetFlatStyle(BOOL bFlatStyle = TRUE);
297
317 BOOL GetUseVisualStyle() const;
318
338 void SetUseVisualStyle(BOOL bUseVisualStyle = TRUE);
339
347 BOOL IsPatternValid();
348
355 void ShowThemedBorder(BOOL bShowThemedBorder);
356
364 BOOL IsHighlighted() const;
365
372 BOOL IsFocused() const;
373
383 BOOL IsFlatStyle() const;
384
391 BOOL ShowBorder() const;
392
394 virtual bool Initialize(CWnd* pParentWnd);
397protected:
405 HBRUSH GetClientBrush(CDC* pDC);
406
411 void RedrawEdit();
412
417 void RedrawFocusedFrame();
418
419 CXTPEditTheme* m_pTheme;
423 BOOL PreCreateWindow(CREATESTRUCT& cs);
424 void PreSubclassWindow();
425 void Init();
426
427 //{{AFX_MSG(CXTPEdit)
428 afx_msg void OnContextMenu(CWnd*, CPoint point);
429 afx_msg void OnEditUndo();
430 afx_msg void OnUpdateEditUndo(CCmdUI* pCmdUI);
431 afx_msg void OnEditCut();
432 afx_msg void OnUpdateEditCut(CCmdUI* pCmdUI);
433 afx_msg void OnEditCopy();
434 afx_msg void OnUpdateEditCopy(CCmdUI* pCmdUI);
435 afx_msg void OnEditPaste();
436 afx_msg void OnUpdateEditPaste(CCmdUI* pCmdUI);
437 afx_msg void OnEditClear();
438 afx_msg void OnUpdateEditClear(CCmdUI* pCmdUI);
439 afx_msg void OnEditSelectAll();
440 afx_msg void OnUpdateEditSelectAll(CCmdUI* pCmdUI);
441 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
442 afx_msg void OnPaint();
443 afx_msg void OnInitMenuPopup(CMenu* pPopupMenu, UINT nIndex, BOOL bSysMenu);
444 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
445 afx_msg void OnNcPaint();
446 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS FAR* lpncsp);
447 afx_msg void OnMouseLeave();
448 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
449 afx_msg void OnKillFocus(CWnd* pNewWnd);
450 afx_msg void OnSetFocus(CWnd* pOldWnd);
451 afx_msg BOOL OnChange();
452 afx_msg void OnSysColorChange();
453 afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
454 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
455
456 DECLARE_MESSAGE_MAP()
457
458 //}}AFX_MSG
461 BOOL m_bPreSubclassInit;
462 BOOL m_bShowBorder;
463 BOOL m_bHighlighted;
464 BOOL m_bFocused;
465 CXTPRegExp* m_pRegExp;
466};
468AFX_INLINE BOOL CXTPEdit::IsHighlighted() const
469{
470 return m_bHighlighted;
471}
472
473AFX_INLINE BOOL CXTPEdit::IsFocused() const
474{
475 return m_bFocused;
476}
477
478AFX_INLINE BOOL CXTPEdit::GetFlatStyle() const
479{
480 return IsFlatStyle();
481}
482
483AFX_INLINE BOOL CXTPEdit::ShowBorder() const
484{
485 return m_bShowBorder;
486}
487
488AFX_INLINE void CXTPEdit::ShowThemedBorder(BOOL bShowThemedBorder)
489{
490 m_bShowBorder = bShowThemedBorder;
491}
494// CXTPScrollableEditT
495
504template<class EditBase>
505class CXTPScrollableEditT : public CXTPScrollable<EditBase>
506{
507public:
512 CXTPScrollableEditT();
513
514 using CXTPScrollable<EditBase>::ModifyStyle;
515 using CXTPScrollable<EditBase>::ModifyStyleEx;
516 using CXTPScrollable<EditBase>::GetRuntimeClass;
517
518protected:
520 virtual void DisableScrollbars();
521 virtual void DisableScrollbars(CWnd& wnd);
523};
524
529typedef CXTPScrollableEditT<CXTPEdit> CXTPScrollableEdit;
531template<class EditBase>
532AFX_INLINE CXTPScrollableEditT<EditBase>::CXTPScrollableEditT()
533{
534 _ASSERTE(GetRuntimeClass()->IsDerivedFrom(RUNTIME_CLASS(CEdit)));
535}
536
537template<class EditBase>
538AFX_INLINE void CXTPScrollableEditT<EditBase>::DisableScrollbars()
539{
540 ModifyStyle(WS_VSCROLL | WS_HSCROLL, 0);
541 ModifyStyleEx(WS_EX_LEFTSCROLLBAR, 0);
542}
543
544template<class EditBase>
545AFX_INLINE void CXTPScrollableEditT<EditBase>::DisableScrollbars(CWnd& wnd)
546{
547 UNREFERENCED_PARAMETER(wnd);
548 // Do nothing as EDIT behaves improperly if scrollbars gets disabled repeatedly.
549}
552class _XTP_EXT_CLASS CXTPEditor_Deprecated : public CXTPEdit
553{
554 DECLARE_DYNAMIC(CXTPEditor_Deprecated)
555
556public:
562 virtual void RefreshMetrics();
563};
564
565_XTP_DEPRECATED_IN_FAVOR(CXTPEdit)
566typedef CXTPEditor_Deprecated CXTPEditor;
567
570# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
572#endif // #if !defined(__XTPEDIT_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
CXTPScrollableEdit
CXTPScrollableEditT< CXTPEdit > CXTPScrollableEdit
Type alias for a CXTPEdit derived scrollable control.
Definition XTPEdit.h:529
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEdit::AdjustBuddyRect
void AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
CXTPEdit::IsPatternValid
BOOL IsPatternValid()
Called by the framework to determine if the pattern set using SetPattern() is valid.
CXTPEdit::IsHighlighted
BOOL IsHighlighted() const
Call this member function to determine if the edit state is highlighted, meaning that the mouse curso...
CXTPEdit::GetTheme
CXTPEditTheme * GetTheme()
Call this member to retrieve a pointer to the current theme.
CXTPEdit::SetUseVisualStyle
void SetUseVisualStyle(BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
CXTPEdit::CanPaste
virtual BOOL CanPaste()
Call this member function to determine if the Clipboard contains information that can be pasted into ...
CXTPEdit::m_pTheme
CXTPEditTheme * m_pTheme
Pointer to the current edit theme.
Definition XTPEdit.h:419
CXTPEdit::DrawBuddyBorders
void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment)
Called by the framework to draw the borders for the associated buddy window.
CXTPEdit::GetFlatStyle
BOOL GetFlatStyle() const
Gets the flat style appearance of the button control.
CXTPEdit::IsFlatStyle
BOOL IsFlatStyle() const
Gets the flat style appearance of the edit control.
CXTPEdit::GetClientBrush
HBRUSH GetClientBrush(CDC *pDC)
Retrieves a handle to the client background brush.
CXTPEdit::CXTPEdit
CXTPEdit()
Constructs a CXTPEdit object.
CXTPEdit::~CXTPEdit
virtual ~CXTPEdit()
Destroys a CXTPEdit object, handles cleanup and deallocation.
CXTPEdit::SetPattern
void SetPattern(LPCTSTR lpszPattern)
Call this member function to set the pattern for the edit mask.
CXTPEdit::HasSelection
BOOL HasSelection() const
Call this member function to determine if a selection has been made.
CXTPEdit::SetFlatStyle
void SetFlatStyle(BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
CXTPEdit::SetTheme
virtual void SetTheme(XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
CXTPEdit::RedrawEdit
void RedrawEdit()
Called by the framework to redraw the edit control.
CXTPEdit::SetEditMask
BOOL SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL)
This member function will set the mask for the edit control.
CXTPEdit::GetUseVisualStyle
BOOL GetUseVisualStyle() const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
CXTPEdit::ShowThemedBorder
void ShowThemedBorder(BOOL bShowThemedBorder)
Call this member function to enable/disable theme border display.
CXTPEdit::ShowBorder
BOOL ShowBorder() const
Call this member to determine if non-client borders are displayed.
CXTPEdit::RefreshMetrics
virtual void RefreshMetrics()
This member is called to update the color, text and other visual elements of the control.
CXTPEdit::RedrawFocusedFrame
void RedrawFocusedFrame()
Called by the framework to redraw the focus rectangle for the edit control.
CXTPEdit::IsFocused
BOOL IsFocused() const
Call this member function to determine if the edit-box has input focus.
CXTPEdit::GetThemeID
XTPControlTheme GetThemeID()
Call this member function to get the style for the theme.
CXTPEditTheme
CXTPEditTheme is the base class for all edit themes used to perform drawing tasks.
Definition XTPEditTheme.h:42
CXTPMaskEditT
CXTPMaskEditT is a template class.
Definition XTPMaskEditT.h:45
CXTPScrollableEditT
An adaptor for any CEdit derived control that overrides standard scrollbars with custom scrollbars.
Definition XTPEdit.h:506
CXTPScrollableEditT::CXTPScrollableEditT
CXTPScrollableEditT()
Initializes scrollable control instance.
CXTPScrollable
The adaptor class for a scrollable control for which standard scroll bars have to be overriden.
Definition XTPScrollable.h:249
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
IXTPScrollable::DisableScrollbars
virtual void DisableScrollbars()=0
Disables/removes standard scroll bars so that custom scroll bars created via this interface could be ...


Toolkit Pro: XTPMarkupStackPanel.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupStackPanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSTACKPANEL_H__)
24# define __XTPMARKUPSTACKPANEL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDrawingContext;
34
40class _XTP_EXT_CLASS CXTPMarkupStackPanel : public CXTPMarkupPanel
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupStackPanel)
45protected:
50 CXTPMarkupStackPanel();
51
56 virtual ~CXTPMarkupStackPanel();
57
58public:
66 void SetOrientation(XTPMarkupOrientation orientation);
67
76 XTPMarkupOrientation GetOrientation() const;
77
78protected:
80 // Implementation
81 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
82 virtual CSize ArrangeOverride(CSize szFinalSize);
83
84public:
85 static CXTPMarkupDependencyProperty* m_pOrientationProperty;
89public:
90 DECLARE_DISPATCH_MAP()
91# ifdef _XTP_ACTIVEX
92 DECLARE_INTERFACE_MAP()
93 DECLARE_OLETYPELIB_EX(CXTPMarkupStackPanel);
94# endif
95
96 afx_msg long OleGetOrientation();
97 afx_msg void OleSetOrientation(long nValue);
99};
100
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
103#endif // !defined(__XTPMARKUPSTACKPANEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPanel.h:48
CXTPMarkupStackPanel
CXTPMarkupStackPanel is a CXTPMarkupPanel derived class.
Definition XTPMarkupStackPanel.h:41
CXTPMarkupStackPanel::CXTPMarkupStackPanel
CXTPMarkupStackPanel()
Constructs a CXTPMarkupStackPanel object.
CXTPMarkupStackPanel::GetOrientation
XTPMarkupOrientation GetOrientation() const
Retrieves the current orientation of child elements inside StackPanel.
CXTPMarkupStackPanel::SetOrientation
void SetOrientation(XTPMarkupOrientation orientation)
Sets the orientation of child elements inside StackPanel.
CXTPMarkupStackPanel::~CXTPMarkupStackPanel
virtual ~CXTPMarkupStackPanel()
Destroys a CXTPMarkupStackPanel object, handles cleanup and deallocation.


  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_YEARLY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY Member List

This is the complete list of members for XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY, including all inherited members.

nDayOfMonth | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY
nMonthOfYear | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_YEARLY


CXTPChartPyramidDiagram Member List

This is the complete list of members for CXTPChartPyramidDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartPyramidDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartPyramidDiagram | virtual
CXTPChartPyramidDiagram() | CXTPChartPyramidDiagram |
CXTPChartPyramidDiagramBase() | CXTPChartPyramidDiagramBase< BaseDiagram > | protected


Toolkit Pro: XTPListBase.h Source File

  • Source
  • Controls
  • List
XTPListBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBASE_H__)
24# define __XTPLISTBASE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBase
39{
40public:
49 struct ROWCOLOR
50 {
51 int iRow;
52 COLORREF crBack;
53 COLORREF crText;
54 LPARAM lParam;
55 };
56
67 typedef CList<ROWCOLOR, ROWCOLOR&> CRowColorList;
68
69public:
74 CXTPListBase();
75
80 virtual ~CXTPListBase();
81
82public:
89 CXTPHeaderCtrl* XTPGetHeaderCtrl() const;
90
99 virtual int SetSortImage(int nCol, BOOL bAsc);
100
109 virtual int GetStoredWidth(int nCol);
110
117 virtual void SetStoredWidth(int nCol);
118
123 virtual void LoadColumnWidths();
124
129 virtual void SaveColumnWidths();
130
136 virtual void AutoSizeColumn(int nCol = -1);
137
146 virtual void AutoSizeColumn(int nCol, BOOL bUseHeader);
147
162 virtual void AutoSaveColumns(LPCTSTR lpszSection = NULL, LPCTSTR lpszEntry = NULL,
163 LPCTSTR lpszDefault = NULL);
164
171 virtual bool SubclassHeader(bool bBoldFont = false);
172
182 virtual bool SortList(int nCol, bool bAscending);
183
193 virtual void SetExtendedStyle(DWORD dwExStyle);
194
202 virtual DWORD GetExtendedStyle();
203
209 virtual void DisableColumnSizing(bool bDisable);
210
216 void SetMinimumColSize(int nSize);
217
225 int GetMinimumColSize();
226
233 int GetMaximumColSize();
234
244 virtual int HitTestEx(CPoint& point, int* col) const;
245
257 virtual int AddColumn(LPCTSTR lpszColHeading, int nWidth = -1, int nFormat = LVCFMT_LEFT);
258
297 virtual bool BuildColumns(int nCols, int* nWidth, int* nColString);
298
337 virtual bool BuildColumns(int nCols, int* nWidth, CString* strColString);
338
345 virtual int GetColumnCount();
346
355 virtual int CopyRow(int nFrom, int nTo);
356
365 virtual bool MoveRow(int nFrom, int nTo);
366
374 CHeaderCtrl* _xtGetHeaderCtrl() const;
375
386 void SetRowColors(COLORREF clrText, COLORREF clrTextBk);
387
396 void SetRowColor(ROWCOLOR* lpRowColor, BOOL bRedraw = TRUE);
397
407 void SetRowColor(int iRow, COLORREF crText, COLORREF crBack, BOOL bRedraw = TRUE);
408
414 void RemoveRowColors();
415
424 virtual ROWCOLOR* Lookup(int iRow);
425
437 virtual BOOL ModifyExtendedStyle(DWORD dwRemove, DWORD dwAdd);
438
446 COLORREF GetListBackColor() const;
447
454 void SetListBackColor(COLORREF crListBack);
455
463 COLORREF GetListTextColor() const;
464
471 void SetListTextColor(COLORREF crListText);
472
480 COLORREF GetSortBackColor() const;
481
488 void SetSortBackColor(COLORREF crSortBack);
489
497 COLORREF GetSortTextColor() const;
498
505 void SetSortTextColor(COLORREF crSortText);
506
512 void EnableUserSortColor(bool bEnable);
513
521 bool IsUserSortColor() const;
522
528 void EnableUserListColor(bool bEnable);
529
537 bool IsUserListColor() const;
538
544 void EnableUserRowColor(bool bEnable);
545
553 bool IsUserRowColor() const;
554
563 void SetAutoFont(bool bAutoFont);
564
565protected:
573 virtual bool Init();
574
583 void ImplAttach(CListCtrl* pListCtrl);
584
604 virtual BOOL OnNotify(WPARAM wParam, LPARAM lParam, LRESULT* pResult);
605
615 void RefreshMetrics();
616
617protected:
619 //{{AFX_MSG
620 afx_msg void OnCustomDraw(NMHDR* pNMHDR, LRESULT* pResult);
621 afx_msg void OnDestroy();
622 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
623 afx_msg void OnPaint();
624 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
625 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection);
626 //}}AFX_MSG
629protected:
631 // Needed in order to access protected functions.
632 class CListCtrl_Friendly : public CListCtrl
633 {
634 friend class CXTPListBase;
635 };
638 int m_nMinColWidth;
639 int m_nMaxColWidth;
640 int m_nSortedCol;
641 bool m_bAutoFont;
642 bool m_bAutoSave;
643 bool m_bListColor;
644 bool m_bRowColor;
645 bool m_bSortColor;
646 bool m_bAscending;
647 bool m_bNoColSizing;
648 CString m_strSection;
649 CString m_strEntry;
650 CString m_strDefault;
651 COLORREF m_crListText;
652 COLORREF m_crListBack;
653 COLORREF m_crSortText;
654 COLORREF m_crSortBack;
655 CRowColorList m_arRowColor;
656 CXTPHeaderCtrl m_wndHeader;
657 CListCtrl_Friendly* m_pListCtrl;
658};
659
661AFX_INLINE int CXTPListBase::GetMinimumColSize()
662{
663 return m_nMinColWidth;
664}
665AFX_INLINE int CXTPListBase::GetMaximumColSize()
666{
667 return m_nMaxColWidth;
668}
669AFX_INLINE void CXTPListBase::DisableColumnSizing(bool bDisable)
670{
671 m_bNoColSizing = bDisable;
672}
673AFX_INLINE void CXTPListBase::SetListBackColor(COLORREF crListBack)
674{
675 m_crListBack = crListBack;
676}
677AFX_INLINE void CXTPListBase::SetListTextColor(COLORREF crListText)
678{
679 m_crListText = crListText;
680}
681AFX_INLINE void CXTPListBase::EnableUserListColor(bool bEnable)
682{
683 m_bListColor = bEnable;
684}
685AFX_INLINE void CXTPListBase::SetSortBackColor(COLORREF crSortBack)
686{
687 m_crSortBack = crSortBack;
688}
689AFX_INLINE void CXTPListBase::SetSortTextColor(COLORREF crSortText)
690{
691 m_crSortText = crSortText;
692}
693AFX_INLINE void CXTPListBase::EnableUserSortColor(bool bEnable)
694{
695 m_bSortColor = bEnable;
696}
697AFX_INLINE bool CXTPListBase::IsUserSortColor() const
698{
699 return m_bSortColor;
700}
701AFX_INLINE bool CXTPListBase::IsUserListColor() const
702{
703 return m_bListColor;
704}
705AFX_INLINE void CXTPListBase::EnableUserRowColor(bool bEnable)
706{
707 m_bRowColor = bEnable;
708}
709AFX_INLINE bool CXTPListBase::IsUserRowColor() const
710{
711 return m_bRowColor;
712}
713AFX_INLINE void CXTPListBase::SetAutoFont(bool bAutoFont)
714{
715 m_bAutoFont = bAutoFont;
716}
717
718# define DECLARE_LIST_BASE(ClassName, List, Base) \
719 class _XTP_EXT_CLASS ClassName \
720 : public List \
721 , public Base \
722 { \
723 public: \
724 ClassName() \
725 { \
726 m_bPreSubclassInit = true; \
727 } \
728 virtual DWORD GetExtendedStyle() \
729 { \
730 return Base::GetExtendedStyle(); \
731 } \
732 virtual void SetExtendedStyle(DWORD dwExStyle) \
733 { \
734 Base::SetExtendedStyle(dwExStyle); \
735 } \
736 \
737 protected: \
738 virtual BOOL OnNotify(WPARAM wParam, LPARAM lParam, LRESULT* pResult) \
739 { \
740 return Base::OnNotify(wParam, lParam, pResult); \
741 } \
742 virtual bool Init() \
743 { \
744 return Base::Init(); \
745 } \
746 virtual void PreSubclassWindow() \
747 { \
748 List::PreSubclassWindow(); \
749 if (m_bPreSubclassInit) \
750 Init(); \
751 } \
752 virtual BOOL PreCreateWindow(CREATESTRUCT& cs) \
753 { \
754 if (!List::PreCreateWindow(cs)) \
755 return FALSE; \
756 m_bPreSubclassInit = false; \
757 return TRUE; \
758 } \
759 bool m_bPreSubclassInit; \
760 afx_msg void OnCustomDraw(NMHDR* pNMHDR, LRESULT* pResult) \
761 { \
762 Base::OnCustomDraw(pNMHDR, pResult); \
763 } \
764 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection) \
765 { \
766 List::OnSettingChange(uFlags, lpszSection); \
767 Base::OnSettingChange(uFlags, lpszSection); \
768 } \
769 afx_msg void OnDestroy() \
770 { \
771 Base::OnDestroy(); \
772 List::OnDestroy(); \
773 } \
774 afx_msg BOOL OnEraseBkgnd(CDC* pDC) \
775 { \
776 return Base::OnEraseBkgnd(pDC); \
777 } \
778 afx_msg void OnPaint() \
779 { \
780 Base::OnPaint(); \
781 } \
782 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam) \
783 { \
784 return Base::OnPrintClient(wParam, lParam); \
785 } \
786 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct) \
787 { \
788 if (List::OnCreate(lpCreateStruct) == -1) \
789 return -1; \
790 Init(); \
791 return 0; \
792 } \
793 };
794
795# define ON_LISTCTRL_REFLECT \
796 ON_NOTIFY_REFLECT(NM_CUSTOMDRAW, OnCustomDraw) \
797 ON_WM_DESTROY() \
798 ON_WM_ERASEBKGND() \
799 ON_WM_PAINT() \
800 ON_MESSAGE(WM_PRINTCLIENT, OnPrintClient) \
801 ON_WM_CREATE() \
802 ON_WM_SETTINGCHANGE
805# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
807#endif // #if !defined(__XTPLISTBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPHeaderCtrl
CXTPHeaderCtrl is a CHeaderCtrl derived class.
Definition XTPHeaderCtrl.h:56
CXTPListBase
CXTPListBase is a non-inherited class.
Definition XTPListBase.h:39
CXTPListBase::BuildColumns
virtual bool BuildColumns(int nCols, int *nWidth, int *nColString)
This member function will build the columns for the list control.
CXTPListBase::AddColumn
virtual int AddColumn(LPCTSTR lpszColHeading, int nWidth=-1, int nFormat=LVCFMT_LEFT)
Call this member function to add a column after the right most column.
CXTPListBase::IsUserListColor
bool IsUserListColor() const
Call this member function to determine if user-defined colors are enabled.
CXTPListBase::HitTestEx
virtual int HitTestEx(CPoint &point, int *col) const
Call this member function to determine the row index and column index for a 'point'.
CXTPListBase::SetSortImage
virtual int SetSortImage(int nCol, BOOL bAsc)
This member function will set the sort image for the specified column.
CXTPListBase::SubclassHeader
virtual bool SubclassHeader(bool bBoldFont=false)
Call this member function to subclass the flat header control.
CXTPListBase::GetColumnCount
virtual int GetColumnCount()
This member function gets the number of columns in the list.
CXTPListBase::IsUserSortColor
bool IsUserSortColor() const
Call this member function to determine if sorted column colors are enabled.
CXTPListBase::m_crListText
COLORREF m_crListText
RGB value representing the row text color.
Definition XTPListBase.h:651
CXTPListBase::SetMinimumColSize
void SetMinimumColSize(int nSize)
Call this member function to set a minimum column size.
CXTPListBase::SetAutoFont
void SetAutoFont(bool bAutoFont)
Call this member function to automatically set the font for the list control when the control is init...
CXTPListBase::SetStoredWidth
virtual void SetStoredWidth(int nCol)
This member function will set the column width from the registry settings.
CXTPListBase::m_arRowColor
CRowColorList m_arRowColor
List of user-defined text and background row colors.
Definition XTPListBase.h:655
CXTPListBase::m_strDefault
CString m_strDefault
Registry default value.
Definition XTPListBase.h:650
CXTPListBase::m_wndHeader
CXTPHeaderCtrl m_wndHeader
Subclassed flat header control.
Definition XTPListBase.h:656
CXTPListBase::IsUserRowColor
bool IsUserRowColor() const
Call this member function to determine if user-defined row colors are enabled.
CXTPListBase::SetSortBackColor
void SetSortBackColor(COLORREF crSortBack)
Call this member function to set the RGB color value used for the sorted column background color.
CXTPListBase::m_bListColor
bool m_bListColor
true if user-defined colors are used for background and text.
Definition XTPListBase.h:643
CXTPListBase::m_crSortText
COLORREF m_crSortText
RGB value for sort column text color.
Definition XTPListBase.h:653
CXTPListBase::m_bAscending
bool m_bAscending
Flag to determine the sorting order.
Definition XTPListBase.h:646
CXTPListBase::Lookup
virtual ROWCOLOR * Lookup(int iRow)
Call this member function to determine if the specified row contains user-defined color attributes.
CXTPListBase::m_bAutoSave
bool m_bAutoSave
true if saving the column widths.
Definition XTPListBase.h:642
CXTPListBase::XTPGetHeaderCtrl
CXTPHeaderCtrl * XTPGetHeaderCtrl() const
Call this member function to get a pointer to the flat header control.
CXTPListBase::SortList
virtual bool SortList(int nCol, bool bAscending)
Override this member function in your derived class to perform custom sort routines.
CXTPListBase::MoveRow
virtual bool MoveRow(int nFrom, int nTo)
This member function moves a row to a new location.
CXTPListBase::RemoveRowColors
void RemoveRowColors()
Call this member function to remove all user-defined row colors from the list control.
CXTPListBase::m_bAutoFont
bool m_bAutoFont
If true, then the font will automatically be set for the control.
Definition XTPListBase.h:641
CXTPListBase::~CXTPListBase
virtual ~CXTPListBase()
Destroys a CXTPListBase object, handles cleanup and deallocation.
CXTPListBase::GetStoredWidth
virtual int GetStoredWidth(int nCol)
This member function will return the column width stored in the registry.
CXTPListBase::SetRowColors
void SetRowColors(COLORREF clrText, COLORREF clrTextBk)
This member function sets the row, text, and background colors for the list control.
CXTPListBase::CRowColorList
CList< ROWCOLOR, ROWCOLOR & > CRowColorList
List for maintaining ROWCOLOR structures.
Definition XTPListBase.h:67
CXTPListBase::AutoSizeColumn
virtual void AutoSizeColumn(int nCol, BOOL bUseHeader)
Automatically sizes a specified column.
CXTPListBase::CopyRow
virtual int CopyRow(int nFrom, int nTo)
This member function copies a row to a new location.
CXTPListBase::GetListTextColor
COLORREF GetListTextColor() const
Call this member function to retrieve the RGB color value used for the column text color.
CXTPListBase::SetExtendedStyle
virtual void SetExtendedStyle(DWORD dwExStyle)
This member function is called to set extended styles for the list control, ie: LVS_EX_FULLROWSELECT,...
CXTPListBase::AutoSizeColumn
virtual void AutoSizeColumn(int nCol=-1)
Automatically sizes a specified column.
CXTPListBase::_xtGetHeaderCtrl
CHeaderCtrl * _xtGetHeaderCtrl() const
This member function is a utility function to retrieve the associated header control.
CXTPListBase::SetSortTextColor
void SetSortTextColor(COLORREF crSortText)
Call this member function to set the RGB color value used for the sorted column text color.
CXTPListBase::SetListTextColor
void SetListTextColor(COLORREF crListText)
Call this member function to set the RGB color value used for the list text color.
CXTPListBase::SetRowColor
void SetRowColor(int iRow, COLORREF crText, COLORREF crBack, BOOL bRedraw=TRUE)
This member function sets the text and background colors for the specified row in the list control.
CXTPListBase::m_nMinColWidth
int m_nMinColWidth
Minimum width for columns.
Definition XTPListBase.h:638
CXTPListBase::GetMinimumColSize
int GetMinimumColSize()
Call this member function to get the minimum column size for the list control.
CXTPListBase::GetMaximumColSize
int GetMaximumColSize()
Call this member function to get the maximum column size for the list control.
CXTPListBase::DisableColumnSizing
virtual void DisableColumnSizing(bool bDisable)
Call this member function to disable/enable column sizing.
CXTPListBase::SetRowColor
void SetRowColor(ROWCOLOR *lpRowColor, BOOL bRedraw=TRUE)
This member function sets the text and background colors for the specified row in the list control.
CXTPListBase::m_crListBack
COLORREF m_crListBack
RGB value representing the row text background color.
Definition XTPListBase.h:652
CXTPListBase::BuildColumns
virtual bool BuildColumns(int nCols, int *nWidth, CString *strColString)
This member function will build the columns for the list control.
CXTPListBase::m_nSortedCol
int m_nSortedCol
Index of the currently selected column.
Definition XTPListBase.h:640
CXTPListBase::CXTPListBase
CXTPListBase()
Constructs a CXTPListBase object.
CXTPListBase::SetListBackColor
void SetListBackColor(COLORREF crListBack)
Call this member function to set the RGB color value used for the list background color.
CXTPListBase::GetSortBackColor
COLORREF GetSortBackColor() const
Call this member function to retrieve the RGB color value used for the sorted column background color...
CXTPListBase::LoadColumnWidths
virtual void LoadColumnWidths()
This member function loads the column widths from the registry.
CXTPListBase::m_crSortBack
COLORREF m_crSortBack
RGB value for sort column background color.
Definition XTPListBase.h:654
CXTPListBase::ModifyExtendedStyle
virtual BOOL ModifyExtendedStyle(DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the extended style for the list control.
CXTPListBase::EnableUserRowColor
void EnableUserRowColor(bool bEnable)
Call this member function to enable/disable user-defined row colors.
CXTPListBase::SaveColumnWidths
virtual void SaveColumnWidths()
This member function saves the column widths to the registry.
CXTPListBase::m_pListCtrl
CListCtrl_Friendly * m_pListCtrl
List control instance.
Definition XTPListBase.h:657
CXTPListBase::OnNotify
virtual BOOL OnNotify(WPARAM wParam, LPARAM lParam, LRESULT *pResult)
Called from the derived class OnNotify method.
CXTPListBase::GetListBackColor
COLORREF GetListBackColor() const
Call this member function to retrieve the RGB color value used for the column background color.
CXTPListBase::AutoSaveColumns
virtual void AutoSaveColumns(LPCTSTR lpszSection=NULL, LPCTSTR lpszEntry=NULL, LPCTSTR lpszDefault=NULL)
Initializes the auto save feature.
CXTPListBase::m_bNoColSizing
bool m_bNoColSizing
If true, then column sizing is disabled.
Definition XTPListBase.h:647
CXTPListBase::EnableUserListColor
void EnableUserListColor(bool bEnable)
Call this member function to enable/disable user-defined colors.
CXTPListBase::m_nMaxColWidth
int m_nMaxColWidth
Maximum width for columns.
Definition XTPListBase.h:639
CXTPListBase::RefreshMetrics
void RefreshMetrics()
Updates colors and size values.
CXTPListBase::ImplAttach
void ImplAttach(CListCtrl *pListCtrl)
Sets the list control pointer.
CXTPListBase::EnableUserSortColor
void EnableUserSortColor(bool bEnable)
Call this member function to enable/disable sorted column colors.
CXTPListBase::m_strEntry
CString m_strEntry
Registry entry name.
Definition XTPListBase.h:649
CXTPListBase::m_bSortColor
bool m_bSortColor
true if the sorted column is drawn in color.
Definition XTPListBase.h:645
CXTPListBase::GetSortTextColor
COLORREF GetSortTextColor() const
Call this member function to retrieve the RGB color value used for the sorted column text color.
CXTPListBase::Init
virtual bool Init()
This member function is called by the CXTPListBase class to perform initialization when the window is...
CXTPListBase::m_strSection
CString m_strSection
Registry section name.
Definition XTPListBase.h:648
CXTPListBase::m_bRowColor
bool m_bRowColor
true if rows are drawn with user-defined colors.
Definition XTPListBase.h:644
CXTPListBase::GetExtendedStyle
virtual DWORD GetExtendedStyle()
This member function is called to retrieve the list control extended style.
CXTPListBase::ROWCOLOR
ROWCOLOR structure is used by the CXTPListBase class to store user-defined background and text color ...
Definition XTPListBase.h:50
CXTPListBase::ROWCOLOR::iRow
int iRow
List control row index.
Definition XTPListBase.h:51
CXTPListBase::ROWCOLOR::lParam
LPARAM lParam
User-defined data.
Definition XTPListBase.h:54
CXTPListBase::ROWCOLOR::crText
COLORREF crText
RGB value for text foreground color.
Definition XTPListBase.h:53
CXTPListBase::ROWCOLOR::crBack
COLORREF crBack
RGB value for text background color.
Definition XTPListBase.h:52


Toolkit Pro: XTPMsgPreviewProvider.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • MSG
XTPMsgPreviewProvider.h
Go to the documentation of this file.
1
23#if !defined(__XTPMSGPREVIEWPROVIDER_H__)
24# define __XTPMSGPREVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPMsgPreviewProvider : public CXTPPreviewProviderBase
41{
42private:
43 virtual LPCTSTR GetDefaultFileAssociations() const;
44 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent);
45 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName, HWND hwndParent);
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // #if !defined(__XTPMSGPREVIEWPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMsgPreviewProvider
Provides a preview handler for the Outlook Message (MSG) file type.
Definition XTPMsgPreviewProvider.h:41
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


Toolkit Pro: XTPTabManagerDefines.h Source File

  • Source
  • TabManager
XTPTabManagerDefines.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABMANAGERDEFINES_H__)
24# define __XTPTABMANAGERDEFINES_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
67enum XTPTabNavigateButtonFlags
68{
69 xtpTabNavigateButtonNone,
70 xtpTabNavigateButtonAutomatic,
71 xtpTabNavigateButtonAlways
72};
73
83enum XTPTabAppearanceStyle
84{
85 xtpTabAppearancePropertyPage = 0,
86 xtpTabAppearancePropertyPageSelected = 1,
88 xtpTabAppearancePropertyPageFlat = 2,
89 xtpTabAppearancePropertyPage2003 = 3,
90 xtpTabAppearanceStateButtons = 4,
91 xtpTabAppearanceFlat = 6,
92 xtpTabAppearanceExcel2003 = 7,
93 xtpTabAppearanceVisio = 8,
94 xtpTabAppearancePropertyPage2007 = 10,
95 xtpTabAppearancePropertyPageAccess2007 = 11,
97 xtpTabAppearanceVisualStudio2003 = 5,
98 xtpTabAppearanceVisualStudio2005 = 9,
99 xtpTabAppearanceVisualStudio2010 = 12,
100 xtpTabAppearanceVisualStudio2012 = 13,
101 xtpTabAppearanceVisualStudio2015 = 15,
102 xtpTabAppearanceVisualStudio2017 = 17,
103 xtpTabAppearanceVisualStudio2019 = 18,
104 xtpTabAppearanceVisualStudio2022 = 19,
106 xtpTabAppearanceOffice2013 = 14,
107 xtpTabAppearanceOffice2016 = xtpTabAppearanceOffice2013,
109 xtpTabAppearanceNativeWindows10 = 16,
110 xtpTabAppearanceNativeWindows11 = 20,
111};
112
114# define xtpTabThemeExcel2003 xtpTabAppearanceExcel2003 // Old names
115# define xtpTabThemeVisualStudio2003 xtpTabAppearanceVisualStudio2003
116# define xtpTabThemeVisualStudio2005 xtpTabAppearanceVisualStudio2005
117# define xtpTabThemeVisualStudio2010 xtpTabAppearanceVisualStudio2010
118# define xtpTabThemeVisualStudio2012 xtpTabAppearanceVisualStudio2012
119# define xtpTabThemeVisualStudio2015 xtpTabAppearanceVisualStudio2015
120# define xtpTabThemeVisualStudio2017 xtpTabAppearanceVisualStudio2017
121# define xtpTabThemeVisualStudio2019 xtpTabAppearanceVisualStudio2019
122# define xtpTabThemeVisualStudio2022 xtpTabAppearanceVisualStudio2022
123# define xtpTabThemeOffice2013 xtpTabAppearanceOffice2013
124# define xtpTabAppearanceVisualStudio xtpTabAppearanceVisualStudio2003
125# define xtpTabAppearanceExcel xtpTabAppearanceExcel2003
138enum XTPTabColorStyle
139{
140 xtpTabColorDefault = 0x0001,
142 xtpTabColorOffice2003 = 0x0004,
144 xtpTabColorWinNative = 0x0008,
146 xtpTabColorResource = 0x0020,
148 xtpTabColorOffice2007Access = 0x0080,
150 xtpTabColorVisualStudio2003 = 0x0002,
152 xtpTabColorVisualStudio2005 = 0x0010,
154 xtpTabColorVisualStudio2008 = 0x0040,
156 xtpTabColorVisualStudio2010 = 0x0100,
158 xtpTabColorVisualStudio2012 = 0x0200,
160 xtpTabColorVisualStudio2012Dark = 0x0400,
162 xtpTabColorOffice2013 = 0x0800,
164 xtpTabColorOffice2016 = xtpTabColorOffice2013,
166 xtpTabColorVisualStudio2015 = 0x1000,
168 xtpTabColorNativeWindows10 = 0x2000,
170 xtpTabColorVisualStudio2017 = 0x4000,
172 xtpTabColorVisualStudio2019 = 0x8000,
174 xtpTabColorVisualStudio2022 = 0x00010000,
176 xtpTabColorNativeWindows11 = 0x00020000,
178 xtpTabColorAll = 0xFFFFFFFF,
179};
180
182# define xtpTabColorVisualStudio \
183 xtpTabColorVisualStudio2003 // obsolete names, for backward compatibility only.
184# define xtpTabColorWinXP xtpTabColorWinNative
185# define xtpTabColorWhidbey xtpTabColorVisualStudio2005
186# define xtpTabColorAccess2007 xtpTabColorOffice2007Access
187# define xtpTabColorOffice2007 xtpTabColorResource
199enum XTPTabPosition
200{
201 xtpTabPositionTop,
202 xtpTabPositionLeft,
203 xtpTabPositionBottom,
204 xtpTabPositionRight
205};
206
216enum XTPTabLayoutStyle
217{
218 xtpTabLayoutAutoSize,
220 xtpTabLayoutSizeToFit,
222 xtpTabLayoutFixed,
223 xtpTabLayoutCompressed,
226 xtpTabLayoutMultiRow,
227 xtpTabLayoutRotated
228};
229
239enum XTPTabToolTipBehaviour
240{
241 xtpTabToolTipNever,
242 xtpTabToolTipAlways,
243 xtpTabToolTipShrinkedOnly
245};
246
261enum XTPTabOneNoteColor
262{
263 xtpTabColorBlue = 0x1000000,
264 xtpTabColorYellow = 0x1000001,
265 xtpTabColorGreen = 0x1000002,
266 xtpTabColorRed = 0x1000003,
267 xtpTabColorPurple = 0x1000004,
268 xtpTabColorCyan = 0x1000005,
269 xtpTabColorOrange = 0x1000006,
270 xtpTabColorMagenta = 0x1000007
271};
272
283enum XTPTabWorkspacePart
284{
285 xtpTabWorkspacePartBorder,
287 xtpTabWorkspacePartWidth,
290 xtpTabWorkspacePartVSplitter,
292 xtpTabWorkspacePartHSplitter,
294 xtpTabWorkspacePartBack
296};
297
308enum XTPTabClientFrame
309{
310 xtpTabFrameBorder,
311 xtpTabFrameSingleLine,
313 xtpTabFrameNone
314};
315
329enum XTPTabNavigateButton
330{
331 xtpTabNavigateButtonLeft,
332 xtpTabNavigateButtonRight,
333 xtpTabNavigateButtonClose,
334 xtpTabNavigateButtonActiveFiles
335};
336
351const COLORREF XTP_TABMANAGER_COLOR_NONE = (COLORREF)(-1);
352
371const COLORREF XTP_TABMANAGER_COLOR_SHADED = (COLORREF)(-2);
372
373# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
375#endif //#if !defined(__XTPTABMANAGERDEFINES_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed...
Definition XTPTabManagerDefines.h:68
xtpTabNavigateButtonAutomatic
@ xtpTabNavigateButtonAutomatic
Automatically display the navigate button.
Definition XTPTabManagerDefines.h:70
xtpTabNavigateButtonAlways
@ xtpTabNavigateButtonAlways
Always display the navigate button.
Definition XTPTabManagerDefines.h:71
xtpTabNavigateButtonNone
@ xtpTabNavigateButtonNone
Never display the navigate button.
Definition XTPTabManagerDefines.h:69
XTPTabAppearanceStyle
XTPTabAppearanceStyle
XTPTabAppearanceStyle is an enumeration used to set the appearance of tabs.
Definition XTPTabManagerDefines.h:84
xtpTabAppearancePropertyPageAccess2007
@ xtpTabAppearancePropertyPageAccess2007
Gives your tabs an Office 2007 appearance.
Definition XTPTabManagerDefines.h:95
xtpTabAppearancePropertyPageSelected
@ xtpTabAppearancePropertyPageSelected
Gives your tabs an Office 2000 selected appearance.
Definition XTPTabManagerDefines.h:86
xtpTabAppearanceVisio
@ xtpTabAppearanceVisio
Gives your tabs a Visio appearance.
Definition XTPTabManagerDefines.h:93
xtpTabAppearancePropertyPage
@ xtpTabAppearancePropertyPage
Gives your tabs an Office 2000 appearance.
Definition XTPTabManagerDefines.h:85
xtpTabAppearanceNativeWindows10
@ xtpTabAppearanceNativeWindows10
Gives your tabs a Native Windows 10 appearance.
Definition XTPTabManagerDefines.h:109
xtpTabAppearanceVisualStudio2019
@ xtpTabAppearanceVisualStudio2019
Gives your tabs a Visual Studio 2019 appearance.
Definition XTPTabManagerDefines.h:103
xtpTabAppearancePropertyPage2007
@ xtpTabAppearancePropertyPage2007
Gives your tabs an Office 2007 appearance.
Definition XTPTabManagerDefines.h:94
xtpTabAppearanceOffice2013
@ xtpTabAppearanceOffice2013
Office 2013 appearance.
Definition XTPTabManagerDefines.h:106
xtpTabAppearanceVisualStudio2017
@ xtpTabAppearanceVisualStudio2017
Gives your tabs a Visual Studio 2017 appearance.
Definition XTPTabManagerDefines.h:102
xtpTabAppearanceVisualStudio2015
@ xtpTabAppearanceVisualStudio2015
Gives your tabs a Visual Studio 2015 appearance.
Definition XTPTabManagerDefines.h:101
xtpTabAppearanceFlat
@ xtpTabAppearanceFlat
Gives your tabs a Flat appearance.
Definition XTPTabManagerDefines.h:91
xtpTabAppearanceVisualStudio2005
@ xtpTabAppearanceVisualStudio2005
Gives your tabs a Visual Studio 2005 appearance.
Definition XTPTabManagerDefines.h:98
xtpTabAppearanceVisualStudio2010
@ xtpTabAppearanceVisualStudio2010
Gives your tabs a Visual Studio 2010 appearance.
Definition XTPTabManagerDefines.h:99
xtpTabAppearancePropertyPage2003
@ xtpTabAppearancePropertyPage2003
Gives your tabs an Office 2003 appearance.
Definition XTPTabManagerDefines.h:89
xtpTabAppearanceNativeWindows11
@ xtpTabAppearanceNativeWindows11
Gives your tabs a Native Windows 11 appearance.
Definition XTPTabManagerDefines.h:110
xtpTabAppearancePropertyPageFlat
@ xtpTabAppearancePropertyPageFlat
Gives your tabs an Office 2000 Flat appearance.
Definition XTPTabManagerDefines.h:88
xtpTabAppearanceOffice2016
@ xtpTabAppearanceOffice2016
Office 2016 appearance.
Definition XTPTabManagerDefines.h:107
xtpTabAppearanceVisualStudio2012
@ xtpTabAppearanceVisualStudio2012
Gives your tabs a Visual Studio 2012 appearance.
Definition XTPTabManagerDefines.h:100
xtpTabAppearanceVisualStudio2003
@ xtpTabAppearanceVisualStudio2003
Gives your tabs a Visual Studio 2003 appearance.
Definition XTPTabManagerDefines.h:97
xtpTabAppearanceVisualStudio2022
@ xtpTabAppearanceVisualStudio2022
Gives your tabs a Visual Studio 2022 appearance.
Definition XTPTabManagerDefines.h:104
xtpTabAppearanceExcel2003
@ xtpTabAppearanceExcel2003
Gives your tabs an Excel 2003 appearance.
Definition XTPTabManagerDefines.h:92
xtpTabAppearanceStateButtons
@ xtpTabAppearanceStateButtons
Gives your tabs a State Button appearance.
Definition XTPTabManagerDefines.h:90
XTP_TABMANAGER_COLOR_SHADED
const COLORREF XTP_TABMANAGER_COLOR_SHADED
Indicates a special "shaded" fill type.
Definition XTPTabManagerDefines.h:371
XTPTabNavigateButton
XTPTabNavigateButton
XTPTabNavigateButton is an enumeration used to identify navigation buttons within a tab control.
Definition XTPTabManagerDefines.h:330
xtpTabNavigateButtonLeft
@ xtpTabNavigateButtonLeft
Left tab navigation button.
Definition XTPTabManagerDefines.h:331
xtpTabNavigateButtonClose
@ xtpTabNavigateButtonClose
Close tab navigation button.
Definition XTPTabManagerDefines.h:333
xtpTabNavigateButtonActiveFiles
@ xtpTabNavigateButtonActiveFiles
Active Files button (used in XTPTabClientWnd only).
Definition XTPTabManagerDefines.h:334
xtpTabNavigateButtonRight
@ xtpTabNavigateButtonRight
Right tab navigation button.
Definition XTPTabManagerDefines.h:332
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
xtpTabPositionLeft
@ xtpTabPositionLeft
Tabs will be drawn on the Left.
Definition XTPTabManagerDefines.h:202
xtpTabPositionTop
@ xtpTabPositionTop
Tabs will be drawn on the Top.
Definition XTPTabManagerDefines.h:201
xtpTabPositionRight
@ xtpTabPositionRight
Tabs will be drawn on the Right.
Definition XTPTabManagerDefines.h:204
xtpTabPositionBottom
@ xtpTabPositionBottom
Tabs will be drawn on the Bottom.
Definition XTPTabManagerDefines.h:203
XTPTabLayoutStyle
XTPTabLayoutStyle
XTPTabLayoutStyle is an enumeration used to set the layout of tabs.
Definition XTPTabManagerDefines.h:217
xtpTabLayoutCompressed
@ xtpTabLayoutCompressed
Tabs will be compressed within the tab panel.
Definition XTPTabManagerDefines.h:223
xtpTabLayoutMultiRow
@ xtpTabLayoutMultiRow
Causes a tab control to display multiple rows of tabs.
Definition XTPTabManagerDefines.h:226
xtpTabLayoutAutoSize
@ xtpTabLayoutAutoSize
Tabs will be automatically sized based on the caption and image size.
Definition XTPTabManagerDefines.h:218
xtpTabLayoutRotated
@ xtpTabLayoutRotated
Rotated tab layout (i.e.
Definition XTPTabManagerDefines.h:227
xtpTabLayoutSizeToFit
@ xtpTabLayoutSizeToFit
Tabs are sized to fit within the tab panel.
Definition XTPTabManagerDefines.h:220
xtpTabLayoutFixed
@ xtpTabLayoutFixed
All tabs will be set to a fixed size within the tab panel.
Definition XTPTabManagerDefines.h:222
XTPTabColorStyle
XTPTabColorStyle
XTPTabColorStyle is an enumeration used to set the color style of tabs.
Definition XTPTabManagerDefines.h:139
xtpTabColorOffice2003
@ xtpTabColorOffice2003
Tabs will use the Office 2003 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:142
xtpTabColorDefault
@ xtpTabColorDefault
Tabs will use the default color for the currently set Appearance.
Definition XTPTabManagerDefines.h:140
xtpTabColorOffice2007Access
@ xtpTabColorOffice2007Access
Tabs will use the Office 2007 Access color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:148
xtpTabColorVisualStudio2008
@ xtpTabColorVisualStudio2008
Tabs will use the Visual Studio 2008 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:154
xtpTabColorAll
@ xtpTabColorAll
A mask for all tab colors.
Definition XTPTabManagerDefines.h:178
xtpTabColorVisualStudio2012
@ xtpTabColorVisualStudio2012
Tabs will use the Visual Studio 2012 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:158
xtpTabColorVisualStudio2003
@ xtpTabColorVisualStudio2003
Tabs will use the Visual Studio 2003 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:150
xtpTabColorVisualStudio2010
@ xtpTabColorVisualStudio2010
Tabs will use the Visual Studio 2010 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:156
xtpTabColorVisualStudio2022
@ xtpTabColorVisualStudio2022
Tabs will use the Visual Studio 2022 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:174
xtpTabColorVisualStudio2019
@ xtpTabColorVisualStudio2019
Tabs will use the Visual Studio 2019 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:172
xtpTabColorNativeWindows10
@ xtpTabColorNativeWindows10
Tabs will use the Native Windows 10 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:168
xtpTabColorVisualStudio2017
@ xtpTabColorVisualStudio2017
Tabs will use the Visual Studio 2017 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:170
xtpTabColorOffice2016
@ xtpTabColorOffice2016
Tabs will use the Office 2016 style for the currently set Appearance.
Definition XTPTabManagerDefines.h:164
xtpTabColorOffice2013
@ xtpTabColorOffice2013
Tabs will use the Office 2013 style for the currently set Appearance.
Definition XTPTabManagerDefines.h:162
xtpTabColorVisualStudio2015
@ xtpTabColorVisualStudio2015
Tabs will use the Visual Studio 2015 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:166
xtpTabColorVisualStudio2012Dark
@ xtpTabColorVisualStudio2012Dark
Tabs will use the Visual Studio 2012 Dark color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:160
xtpTabColorVisualStudio2005
@ xtpTabColorVisualStudio2005
Tabs will use the Visual Studio 2005 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:152
xtpTabColorWinNative
@ xtpTabColorWinNative
Tabs will use the Windows XP color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:144
xtpTabColorResource
@ xtpTabColorResource
Tabs will use the Office 2007 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:146
xtpTabColorNativeWindows11
@ xtpTabColorNativeWindows11
Tabs will use the Native Windows 11 color style for the currently set Appearance.
Definition XTPTabManagerDefines.h:176
XTPTabClientFrame
XTPTabClientFrame
XTPTabClientFrame is an enumeration used to set the client frame style drawn around the client of tab...
Definition XTPTabManagerDefines.h:309
xtpTabFrameBorder
@ xtpTabFrameBorder
With this flag set, a border will appear around the client area.
Definition XTPTabManagerDefines.h:310
xtpTabFrameNone
@ xtpTabFrameNone
With this flag set, no border will appear around the client area.
Definition XTPTabManagerDefines.h:313
xtpTabFrameSingleLine
@ xtpTabFrameSingleLine
With this flag set, only a single line is used as a border around the client area.
Definition XTPTabManagerDefines.h:311
XTPTabOneNoteColor
XTPTabOneNoteColor
XTPTabOneNoteColor is an enumeration used to indicate which OneNote RGB color value to retrieve.
Definition XTPTabManagerDefines.h:262
xtpTabColorPurple
@ xtpTabColorPurple
Purple tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:267
xtpTabColorRed
@ xtpTabColorRed
Red tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:266
xtpTabColorYellow
@ xtpTabColorYellow
Yellow tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:264
xtpTabColorGreen
@ xtpTabColorGreen
Green tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:265
xtpTabColorOrange
@ xtpTabColorOrange
Orange tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:269
xtpTabColorCyan
@ xtpTabColorCyan
Cyan tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:268
xtpTabColorMagenta
@ xtpTabColorMagenta
Magenta tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:270
xtpTabColorBlue
@ xtpTabColorBlue
Blue tab color used when OneNote colors enabled.
Definition XTPTabManagerDefines.h:263
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour
XTPTabToolTipBehaviour is an enumeration used to set the tooltip behaviour for tabs.
Definition XTPTabManagerDefines.h:240
xtpTabToolTipAlways
@ xtpTabToolTipAlways
Always show tooltips for tabs.
Definition XTPTabManagerDefines.h:242
xtpTabToolTipShrinkedOnly
@ xtpTabToolTipShrinkedOnly
Only show tooltips if the tab was shrinked (see xtpTabLayoutSizeToFit layout).
Definition XTPTabManagerDefines.h:243
xtpTabToolTipNever
@ xtpTabToolTipNever
Never show tooltips for tabs.
Definition XTPTabManagerDefines.h:241
XTPTabWorkspacePart
XTPTabWorkspacePart
XTPTabWorkspacePart is an enumeration used to indicate which part of the MDI TabWorkspace must be red...
Definition XTPTabManagerDefines.h:284
xtpTabWorkspacePartHSplitter
@ xtpTabWorkspacePartHSplitter
Indicates the horizontal splitter of the MDITabClient TabWorkspace should be drawn.
Definition XTPTabManagerDefines.h:292
xtpTabWorkspacePartWidth
@ xtpTabWorkspacePartWidth
Indicates the border width of the MDITabClient TabWorkspace should be recalculated (i....
Definition XTPTabManagerDefines.h:287
xtpTabWorkspacePartVSplitter
@ xtpTabWorkspacePartVSplitter
Indicates the vertical splitter of the MDITabClient TabWorkspace should be drawn.
Definition XTPTabManagerDefines.h:290
xtpTabWorkspacePartBack
@ xtpTabWorkspacePartBack
Indicates the background of the MDITabClient TabWorkspace should be drawn.
Definition XTPTabManagerDefines.h:294
xtpTabWorkspacePartBorder
@ xtpTabWorkspacePartBorder
Indicates the border of the MDITabClient TabWorkspace should be drawn.
Definition XTPTabManagerDefines.h:285
XTP_TABMANAGER_COLOR_NONE
const COLORREF XTP_TABMANAGER_COLOR_NONE
Indicates that a transparent color should be used.
Definition XTPTabManagerDefines.h:351


CXTPChartPieDiagramView Member List

This is the complete list of members for CXTPChartPieDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | protectedvirtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChartPieDiagramView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


CXTPControlComboBox Member List

This is the complete list of members for CXTPControlComboBox, including all inherited members.

AddString(LPCTSTR lpsz) | CXTPControlComboBox |
AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPControlPopup | virtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlComboBox | virtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlComboBox | protectedvirtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CreateEditControl() | CXTPControlComboBox | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlComboBox(CXTPCommandBars *pCommandBars=NULL) | CXTPControlComboBox |
CXTPControlPopup() | CXTPControlPopup |
DeflateEditRect(CRect &rcControl) | CXTPControlComboBox | protectedvirtual
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DeleteItem(long nIndex) | CXTPControlComboBox |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlComboBox | virtual
Draw(CDC *pDC) | CXTPControl | virtual
DrawEditText(CDC *pDC, CRect rcText) | CXTPControlComboBox | virtual
EnableAutoComplete(BOOL bAutoComplete=TRUE) | CXTPControlComboBox |
EnableShellAutoComplete(DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL) | CXTPControlComboBox |
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FindString(int nStartAfter, LPCTSTR lpszItem) const | CXTPControlComboBox |
FindStringExact(int nIndexStart, LPCTSTR lpsz) const | CXTPControlComboBox |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControlPopup | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetComboBoxPopupBar() const | CXTPControlComboBox |
GetCommandBar() const | CXTPControlPopup | virtual
GetControls() const | CXTPControl |
GetCount() const | CXTPControlComboBox |
GetCurSel() const | CXTPControlComboBox |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControlComboBox | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDefaultCharFormat() | CXTPControlComboBox | virtual
GetDescription() const | CXTPControl | virtual
GetDropDownListStyle() const | CXTPControlComboBox |
GetDropDownWidth() const | CXTPControlComboBox |
GetDroppedState() const | CXTPControlComboBox |
GetEditCtrl() const | CXTPControlComboBox |
GetEditHint() const | CXTPControlComboBox |
GetEditIconId() const | CXTPControlComboBox |
GetEditStyle() const | CXTPControlComboBox |
GetEditText() const | CXTPControlComboBox |
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetItemData(int nIndex) const | CXTPControlComboBox |
GetKeyboardTip() const | CXTPControl |
GetLabelWidth() const | CXTPControlComboBox |
GetLBText(int nIndex, CString &str) const | CXTPControlComboBox |
GetListBoxCtrl() const | CXTPControlComboBox |
GetListBoxText() const | CXTPControlComboBox | virtual
GetListIconId() const | CXTPControlComboBox |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControlPopup | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTextLimit() const | CXTPControlComboBox |
GetThumbWidth() const | CXTPControlComboBox |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
HasFocus() const | CXTPControlComboBox |
InsertString(int nIndex, LPCTSTR lpsz) | CXTPControlComboBox |
IsCaptionVisible() const | CXTPControlComboBox | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControlComboBox | protectedvirtual
IsFocusable() const | CXTPControlComboBox | protectedvirtual
IsFocused() const | CXTPControlComboBox | virtual
IsImageVisible() const | CXTPControlComboBox |
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bAutoComplete | CXTPControlComboBox | protected
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bDelayDestroy | CXTPControlComboBox | protected
m_bDelayReposition | CXTPControlComboBox | protected
m_bDropDown | CXTPControlComboBox | protected
m_bEditChanged | CXTPControlComboBox | mutableprotected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bFocused | CXTPControlComboBox | protected
m_bIgnoreAutoComplete | CXTPControlComboBox | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bSelEndOk | CXTPControlComboBox | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_comboStyle | CXTPControlComboBox | protected
m_controlType | CXTPControl | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwEditStyle | CXTPControlComboBox | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_dwShellAutoCompleteFlags | CXTPControlComboBox | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nDropDownItemCount | CXTPControlComboBox | protected
m_nEditIconId | CXTPControlComboBox | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nLabelWidth | CXTPControlComboBox | protected
m_nLastSel | CXTPControlComboBox | protected
m_nTag | CXTPControl | protected
m_nTextLimit | CXTPControlComboBox | protected
m_nThumbWidth | CXTPControlComboBox | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pAutoCompleteWnd | CXTPControlComboBox | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pEdit | CXTPControlComboBox | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strEditHint | CXTPControlComboBox | protected
m_strEditText | CXTPControlComboBox | mutableprotected
m_strKeyboardTip | CXTPControl | protected
m_strLastText | CXTPControlComboBox | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
ModifyListBoxStyle(DWORD dwRemove, DWORD dwAdd) | CXTPControlComboBox |
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControlComboBox | virtual
OnActionChanging(int nProperty) | CXTPControlComboBox | virtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlComboBox | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlComboBox | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEditChanged() | CXTPControlComboBox | virtual
OnEnabledChanged() | CXTPControlComboBox | virtual
OnExecute() | CXTPControlComboBox | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlComboBox | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnKillFocus() | CXTPControlComboBox | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControlPopup | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlComboBox | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlComboBox | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControlComboBox | protectedvirtual
OnSelChanged() | CXTPControlComboBox | virtual
OnSetFocus(CWnd *pOldWnd) | CXTPControlComboBox | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControlComboBox | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlComboBox | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlComboBox | protectedvirtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
ResetContent() | CXTPControlComboBox |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetCurSel(int nIndex) | CXTPControlComboBox |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetDropDownItemCount(int nDropDownItemCount) | CXTPControlComboBox |
SetDropDownListStyle(BOOL bSet=TRUE) | CXTPControlComboBox |
SetDropDownWidth(int nWidth) | CXTPControlComboBox |
SetEditHint(LPCTSTR lpszEditHint) | CXTPControlComboBox |
SetEditIconId(int nId) | CXTPControlComboBox |
SetEditStyle(DWORD dwStyle) | CXTPControlComboBox |
SetEditText(const CString &lpszText) | CXTPControlComboBox |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControlComboBox | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControlComboBox | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemData(int nIndex, DWORD_PTR dwItemData) | CXTPControlComboBox |
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetLabelWidth(int nLabelWidth) | CXTPControlComboBox |
SetListIconId(int nId) | CXTPControlComboBox |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControlComboBox | protectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControlComboBox | protectedvirtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTextLimit(int nTextLimit) | CXTPControlComboBox |
SetThumbWidth(int nThumbWidth) | CXTPControlComboBox |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlComboBox() | CXTPControlComboBox | virtual
~CXTPControlPopup() | CXTPControlPopup | virtual


CXTPTrackMarker Member List

This is the complete list of members for CXTPTrackMarker, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPTrackMarker() | CXTPTrackMarker |
DoPropExchange(CXTPPropExchange *pPX) | CXTPTrackMarker |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPTrackMarker |
GetControl() const | CXTPTrackMarker |
GetPosition() const | CXTPTrackMarker |
GetRect() const | CXTPTrackMarker |
m_nPosition | CXTPTrackMarker | protected
m_pControl | CXTPTrackMarker | protected
m_rcMarker | CXTPTrackMarker | protected
m_strCaption | CXTPTrackMarker | protected
Remove() | CXTPTrackMarker |
SetCaption(LPCTSTR lpszCaption) | CXTPTrackMarker |
SetPosition(int nPosition) | CXTPTrackMarker |


Toolkit Pro: XTPShortcutBarPaintManager.h Source File

  • Source
  • ShortcutBar
XTPShortcutBarPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARPAINTMANAGER_H__)
24# define __XTPSHORTCUTBARPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34
48enum XTPShortcutBarPaintTheme
49{
50 xtpShortcutThemeResource = 3,
51 xtpShortcutThemeOffice2000 = 0,
52 xtpShortcutThemeOfficeXP = 1,
53 xtpShortcutThemeOffice2003 = 2,
54 xtpShortcutThemeOffice2007 = 3,
55 xtpShortcutThemeOffice2010 = 3,
56 xtpShortcutThemeNativeWinXP = 4,
57 xtpShortcutThemeOffice2013 = 5,
58 xtpShortcutThemeOffice2016 = xtpShortcutThemeOffice2013,
59 xtpShortcutThemeVisualStudio2015 = 6,
60 xtpShortcutThemeNativeWindows10 = 7,
61 xtpShortcutThemeVisualStudio2017 = 8,
62 xtpShortcutThemeVisualStudio2019 = 9,
63 xtpShortcutThemeVisualStudio2022 = 10,
64 xtpShortcutThemeNativeWindows11 = 11,
65};
66
67class CXTPShortcutBar;
68class CXTPShortcutBarItem;
69class CXTPShortcutBarPane;
70class CXTPShortcutBarPaneItem;
71class CXTPImageManagerIcon;
72
78class _XTP_EXT_CLASS CXTPShortcutBarPaintManager : public CXTPCmdTarget
79{
80public:
85 CXTPShortcutBarPaintManager();
86
91 virtual ~CXTPShortcutBarPaintManager();
92
93public:
101 virtual void RefreshMetrics();
102
109 virtual void DrawShortcutItem(CDC* pDC, CXTPShortcutBarItem* pItem);
110
117 virtual void FillShortcutBar(CDC* pDC, CXTPShortcutBar* pShortcutBar) = 0;
118
127 virtual void DrawShortcutBarFrame(CDC* pDC, CXTPShortcutBar* pShortcutBar) = 0;
128
135 virtual void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem) = 0;
136
147 virtual int DrawGripper(CDC* pDC, CXTPShortcutBar* pShortcutBar, BOOL bDraw) = 0;
148
174 virtual int DrawPaneCaption(CDC* pDC, CXTPShortcutBarPane* pPane, BOOL bDraw);
175
197 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
198
205 virtual void DrawNavigationItem(CDC* pDC, CXTPShortcutBarItem* pItem);
206
213 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
214
221 virtual void DrawExpandButton(CDC* pDC, CRect rc);
222
223 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
224
244 virtual void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage,
245 BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) = 0;
246
247public:
259 void Rectangle(CDC* pDC, CRect rc, int nPen, int nBrush);
260
271 void Line(CDC* pDC, int x0, int y0, int x1, int y1, int nPen);
272
289 BOOL IsShortcutItemTruncated(CDC* pDC, CXTPShortcutBarItem* pItem);
290
291 virtual void FillPopupBack(CDC* pDC, CRect rc, CSize szGap);
292
293 virtual void CreateFonts();
294
295 virtual void EnableOfficeFont(BOOL bEnable = TRUE);
296
297public:
298 CXTPFont m_xtpFontText;
299 CXTPFont m_xtpFontPaneCaption;
300 CXTPFont m_xtpFontPaneItemCaption;
301 CXTPFont m_xtpFontVerticalText;
303 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntText, m_xtpFontText, GetTextFontHandle);
304 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntPaneCaption, m_xtpFontPaneCaption,
305 GetPaneCaptionFontHandle);
306 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntPaneItemCaption, m_xtpFontPaneItemCaption,
307 GetPaneItemCaptionFontHandle);
308 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntVerticalText, m_xtpFontVerticalText,
309 GetVerticalTextFontHandle);
310
311 int m_nPaneItemHeight;
312 CXTPImageManagerIcon* m_pExpandIcon;
313 CXTPImageManager* m_pImageManager;
314 BOOL m_bNavigationButton;
316 int m_nNormalIconWidth;
317 int m_nExpandedIconWidth;
318 BOOL m_bBoldItemCaptionFont;
319 BOOL m_bClearTypeTextQuality;
320 BOOL m_bUseStandardFont;
322 CRect m_rcCaptionPadding;
323 CRect m_rcItemCaptionPadding;
324 CString m_strOfficeFont;
325 BOOL m_bShowBorder;
326
327 BOOL m_bDrawTextNoPrefix;
328
329public:
330 CXTPPaintManagerColor m_clrPushedText;
332 CXTPPaintManagerColor m_clrSelectedText;
335 CXTPPaintManagerColor m_clrHotText;
337 CXTPPaintManagerColor m_clrNormalText;
339 CXTPPaintManagerColor m_clrDisabledText;
342 CXTPPaintManagerColorGradient m_grcSelected;
343 CXTPPaintManagerColorGradient m_grcHot;
345 CXTPPaintManagerColorGradient m_grcPushed;
349 CXTPPaintManagerColorGradient m_grcShortcutItem;
350 CXTPPaintManagerColor m_clrShortcutItemShadow;
352 CXTPPaintManagerColorGradient m_grcShortcutBarGripper;
355 CXTPPaintManagerColor m_clrPopupFrame;
356 CXTPPaintManagerColor m_clrPopupBackground;
357
358 COLORREF m_clrFlatBackground;
359 COLORREF m_clrFlatTextColor;
360 COLORREF m_clrAppSplitterFace;
361
362# ifdef _XTP_ACTIVEX
365 DECLARE_DISPATCH_MAP()
366 DECLARE_OLETYPELIB_EX(CXTPShortcutBarPaintManager);
367 DECLARE_INTERFACE_MAP()
368 afx_msg void OleRefreshMetrics();
369 afx_msg LPFONTDISP OleGetFont();
370 afx_msg void OleSetFont(LPFONTDISP pFontDisp);
371 afx_msg OLE_COLOR OleGetFlatBackgroundColor();
372 afx_msg OLE_COLOR OleGetFlatTextColor();
373 afx_msg OLE_COLOR OleGetSplitterColor();
375# endif
376};
377
378# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
380#endif // !defined(__XTPSHORTCUTBARPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPShortcutBarPaintTheme
XTPShortcutBarPaintTheme
XTPShortcutBarPaintTheme is an enumeration used by CXTPShortcutBar to set the theme of the control.
Definition XTPShortcutBarPaintManager.h:49
xtpShortcutThemeVisualStudio2017
@ xtpShortcutThemeVisualStudio2017
Visual Studio 2017 style theme.
Definition XTPShortcutBarPaintManager.h:61
xtpShortcutThemeOffice2003
@ xtpShortcutThemeOffice2003
Office 2003 style theme.
Definition XTPShortcutBarPaintManager.h:53
xtpShortcutThemeOfficeXP
@ xtpShortcutThemeOfficeXP
Office XP style theme.
Definition XTPShortcutBarPaintManager.h:52
xtpShortcutThemeOffice2000
@ xtpShortcutThemeOffice2000
Office 2000 style theme.
Definition XTPShortcutBarPaintManager.h:51
xtpShortcutThemeNativeWindows11
@ xtpShortcutThemeNativeWindows11
Native Windows 11 theme.
Definition XTPShortcutBarPaintManager.h:64
xtpShortcutThemeResource
@ xtpShortcutThemeResource
Office 2007/2010 style theme.
Definition XTPShortcutBarPaintManager.h:50
xtpShortcutThemeNativeWindows10
@ xtpShortcutThemeNativeWindows10
Native Windows 10 theme.
Definition XTPShortcutBarPaintManager.h:60
xtpShortcutThemeOffice2007
@ xtpShortcutThemeOffice2007
Office 2007 style theme.
Definition XTPShortcutBarPaintManager.h:54
xtpShortcutThemeVisualStudio2022
@ xtpShortcutThemeVisualStudio2022
Visual Studio 2022 style theme.
Definition XTPShortcutBarPaintManager.h:63
xtpShortcutThemeVisualStudio2015
@ xtpShortcutThemeVisualStudio2015
Visual Studio 2015 style theme.
Definition XTPShortcutBarPaintManager.h:59
xtpShortcutThemeVisualStudio2019
@ xtpShortcutThemeVisualStudio2019
Visual Studio 2019 style theme.
Definition XTPShortcutBarPaintManager.h:62
xtpShortcutThemeOffice2016
@ xtpShortcutThemeOffice2016
Office 2016 style theme.
Definition XTPShortcutBarPaintManager.h:58
xtpShortcutThemeOffice2013
@ xtpShortcutThemeOffice2013
Office 2013 style theme.
Definition XTPShortcutBarPaintManager.h:57
xtpShortcutThemeNativeWinXP
@ xtpShortcutThemeNativeWinXP
Native Windows XP theme.
Definition XTPShortcutBarPaintManager.h:56
xtpShortcutThemeOffice2010
@ xtpShortcutThemeOffice2010
Office 2010 style theme.
Definition XTPShortcutBarPaintManager.h:55
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control.
Definition XTPShortcutBarPaintManager.h:79
CXTPShortcutBarPaintManager::m_grcHot
CXTPPaintManagerColorGradient m_grcHot
Color gradient of "hot" items.
Definition XTPShortcutBarPaintManager.h:343
CXTPShortcutBarPaintManager::m_xtpFontPaneCaption
CXTPFont m_xtpFontPaneCaption
Caption font.
Definition XTPShortcutBarPaintManager.h:299
CXTPShortcutBarPaintManager::FillShortcutBar
virtual void FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)=0
Fills the client area of the shortcut bar control.
CXTPShortcutBarPaintManager::m_clrPushedText
CXTPPaintManagerColor m_clrPushedText
Color of caption text when an CXTPShortcutBarItem is pressed.
Definition XTPShortcutBarPaintManager.h:330
CXTPShortcutBarPaintManager::DrawGripper
virtual int DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)=0
Draws the gripper for the shortcut bar control.
CXTPShortcutBarPaintManager::DrawExpandButton
virtual void DrawExpandButton(CDC *pDC, CRect rc)
Draws the expand button.
CXTPShortcutBarPaintManager::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarPaintManager::CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager()
Constructs a CXTPShortcutBarPaintManager object.
CXTPShortcutBarPaintManager::IsShortcutItemTruncated
BOOL IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem)
Determines if the caption text of a specified expanded shortcut bar item has been truncated.
CXTPShortcutBarPaintManager::m_clrShortcutItemShadow
CXTPPaintManagerColor m_clrShortcutItemShadow
Color of line border that goes around each item.
Definition XTPShortcutBarPaintManager.h:350
CXTPShortcutBarPaintManager::m_clrDisabledText
CXTPPaintManagerColor m_clrDisabledText
Color of caption text when an CXTPShortcutBarItem is disabled.
Definition XTPShortcutBarPaintManager.h:339
CXTPShortcutBarPaintManager::m_nNormalIconWidth
int m_nNormalIconWidth
Width of the icons.
Definition XTPShortcutBarPaintManager.h:316
CXTPShortcutBarPaintManager::m_rcItemCaptionPadding
CRect m_rcItemCaptionPadding
Padding of item caption.
Definition XTPShortcutBarPaintManager.h:323
CXTPShortcutBarPaintManager::m_grcPushed
CXTPPaintManagerColorGradient m_grcPushed
Color gradient of item when clicked on.
Definition XTPShortcutBarPaintManager.h:345
CXTPShortcutBarPaintManager::m_pExpandIcon
CXTPImageManagerIcon * m_pExpandIcon
Pointer to expand icon.
Definition XTPShortcutBarPaintManager.h:312
CXTPShortcutBarPaintManager::Rectangle
void Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush)
Draws the rectangle to be used to draw the shortcut bar items.
CXTPShortcutBarPaintManager::DrawImage
virtual void DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)=0
Draws the image of a shortcut bar item.
CXTPShortcutBarPaintManager::m_xtpFontVerticalText
CXTPFont m_xtpFontVerticalText
Navigation button text font.
Definition XTPShortcutBarPaintManager.h:301
CXTPShortcutBarPaintManager::m_strOfficeFont
CString m_strOfficeFont
TRUE to use Office Tahoma font.
Definition XTPShortcutBarPaintManager.h:324
CXTPShortcutBarPaintManager::Line
void Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen)
Draws the "gripper" lines in the gripper.
CXTPShortcutBarPaintManager::m_nPaneItemHeight
int m_nPaneItemHeight
Height of sub-pane caption.
Definition XTPShortcutBarPaintManager.h:311
CXTPShortcutBarPaintManager::m_nExpandedIconWidth
int m_nExpandedIconWidth
Width of the expanded icons.
Definition XTPShortcutBarPaintManager.h:317
CXTPShortcutBarPaintManager::m_bClearTypeTextQuality
BOOL m_bClearTypeTextQuality
TRUE to use ClearType font.
Definition XTPShortcutBarPaintManager.h:319
CXTPShortcutBarPaintManager::m_bNavigationButton
BOOL m_bNavigationButton
TRUE if navigation button small.
Definition XTPShortcutBarPaintManager.h:314
CXTPShortcutBarPaintManager::m_grcShortcutBarGripper
CXTPPaintManagerColorGradient m_grcShortcutBarGripper
Color gradient used to draw the shortcut bar gripper.
Definition XTPShortcutBarPaintManager.h:352
CXTPShortcutBarPaintManager::m_bBoldItemCaptionFont
BOOL m_bBoldItemCaptionFont
TRUE to draw item with bold font.
Definition XTPShortcutBarPaintManager.h:318
CXTPShortcutBarPaintManager::m_clrHotText
CXTPPaintManagerColor m_clrHotText
Color of caption text when the mouse cursor is positioned over an CXTPShortcutBarItem.
Definition XTPShortcutBarPaintManager.h:335
CXTPShortcutBarPaintManager::m_bUseStandardFont
BOOL m_bUseStandardFont
TRUE to use standard font.
Definition XTPShortcutBarPaintManager.h:320
CXTPShortcutBarPaintManager::DrawShortcutBarFrame
virtual void DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar)=0
Draws the frame for the shortcut bar control.
CXTPShortcutBarPaintManager::~CXTPShortcutBarPaintManager
virtual ~CXTPShortcutBarPaintManager()
Destroys a CXTPShortcutBarPaintManager object, handles cleanup and deallocation.
CXTPShortcutBarPaintManager::m_clrNormalText
CXTPPaintManagerColor m_clrNormalText
Color of caption text when an CXTPShortcutBarItem is displayed normally.
Definition XTPShortcutBarPaintManager.h:337
CXTPShortcutBarPaintManager::m_xtpFontPaneItemCaption
CXTPFont m_xtpFontPaneItemCaption
Sub-caption font.
Definition XTPShortcutBarPaintManager.h:300
CXTPShortcutBarPaintManager::DrawNavigationItem
virtual void DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarPaintManager::m_rcCaptionPadding
CRect m_rcCaptionPadding
Padding of pane caption.
Definition XTPShortcutBarPaintManager.h:322
CXTPShortcutBarPaintManager::DrawShortcutItem
virtual void DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem)
Draws a specified item for the shortcut bar control.
CXTPShortcutBarPaintManager::m_grcShortcutItem
CXTPPaintManagerColorGradient m_grcShortcutItem
Color gradient of shortcut bar items.
Definition XTPShortcutBarPaintManager.h:349
CXTPShortcutBarPaintManager::m_grcSelected
CXTPPaintManagerColorGradient m_grcSelected
Color gradient of currently selected item.
Definition XTPShortcutBarPaintManager.h:342
CXTPShortcutBarPaintManager::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarPaintManager::DrawPaneCaption
virtual int DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
CXTPShortcutBarPaintManager::FillShortcutItemEntry
virtual void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)=0
Fills a specified item for the shortcut bar control.
CXTPShortcutBarPaintManager::m_clrSelectedText
CXTPPaintManagerColor m_clrSelectedText
Color of caption text when an CXTPShortcutBarItem is selected (this happens after the item is clicked...
Definition XTPShortcutBarPaintManager.h:332
CXTPShortcutBarPaintManager::m_xtpFontText
CXTPFont m_xtpFontText
Text font.
Definition XTPShortcutBarPaintManager.h:298
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


CXTPTrackThemeExplorer Member List

This is the complete list of members for CXTPTrackThemeExplorer, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeExplorer() | CXTPTrackThemeExplorer |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeExplorer | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPTrackThemeExplorer | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPTrackThemeExplorer |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth=0) | CXTPTrackThemeExplorer | virtual
CXTPTrackPaintManager::DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPTrackThemeExplorer | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


CXTPColorWnd Member List

This is the complete list of members for CXTPColorWnd, including all inherited members.

CXTPColorBase() | CXTPColorBase |
CXTPColorWnd() | CXTPColorWnd |
DrawCrossHair(CDC *pDC) | CXTPColorWnd |
focusColorWheel enum value | CXTPColorBase |
FocusedControl enum name | CXTPColorBase |
focusLumination enum value | CXTPColorBase |
focusNone enum value | CXTPColorBase |
HLStoRGB(double h, double l, double s) | CXTPColorBase | static
Init() | CXTPColorBase | protectedvirtual
m_bmpPicker | CXTPColorWnd | protected
m_bPreSubclassInit | CXTPColorBase | protected
m_eHasFocus | CXTPColorBase | protectedstatic
m_nHue | CXTPColorBase |
m_nLum | CXTPColorBase |
m_nSat | CXTPColorBase |
m_ptMousePos | CXTPColorBase |
RGBtoHSL(COLORREF color, double *h, double *s, double *l) | CXTPColorBase | static
SetColor(double nHue, double nSat) | CXTPColorWnd | virtual
SetHue(double h) | CXTPColorWnd |
SetSaturation(double s) | CXTPColorWnd |
UpdateCursorPos(CPoint point) | CXTPColorWnd | virtual
~CXTPColorBase() | CXTPColorBase | virtual
~CXTPColorWnd() | CXTPColorWnd | virtual


CXTPSyntaxEditLexTextBlock Member List

This is the complete list of members for CXTPSyntaxEditLexTextBlock, including all inherited members.

Close() | CXTPSyntaxEditLexTextBlock | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditLexTextBlock() | CXTPSyntaxEditLexTextBlock |
EndChildren(CXTPSyntaxEditLexTextSchema *pTxtSch=NULL, BOOL bEndByParent=TRUE) | CXTPSyntaxEditLexTextBlock | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetEndTagBeginXLC() | CXTPSyntaxEditLexTextBlock |
GetEndTagEndXLC() | CXTPSyntaxEditLexTextBlock |
GetPosEndLC(BOOL bMaxIfInvalid=TRUE) | CXTPSyntaxEditLexTextBlock |
GetPrevChild(CXTPSyntaxEditLexTextBlock *pChild, BOOL bWithAddRef) | CXTPSyntaxEditLexTextBlock | virtual
GetStartTagEndXLC() | CXTPSyntaxEditLexTextBlock |
IsEqualLexClasses(CXTPSyntaxEditLexTextBlock *pTB2) const | CXTPSyntaxEditLexTextBlock | virtual
IsInclude(CXTPSyntaxEditLexTextBlock *pTB2) const | CXTPSyntaxEditLexTextBlock | virtual
IsLookLikeClosed() const | CXTPSyntaxEditLexTextBlock | virtual
m_bEndByParent | CXTPSyntaxEditLexTextBlock |
m_nEndTagXLCLen | CXTPSyntaxEditLexTextBlock | protected
m_nStartTagLen | CXTPSyntaxEditLexTextBlock | protected
m_PosEndLC | CXTPSyntaxEditLexTextBlock |
m_PosStartLC | CXTPSyntaxEditLexTextBlock |
m_ptrLastChild | CXTPSyntaxEditLexTextBlock | protected
m_ptrLexClass | CXTPSyntaxEditLexTextBlock |
m_ptrNext | CXTPSyntaxEditLexTextBlock |
m_ptrParent | CXTPSyntaxEditLexTextBlock |
m_ptrPrev | CXTPSyntaxEditLexTextBlock |
~CXTPSyntaxEditLexTextBlock() | CXTPSyntaxEditLexTextBlock | virtual


CXTPShortcutBarVisualStudio2015Theme Member List

This is the complete list of members for CXTPShortcutBarVisualStudio2015Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
CXTPShortcutBarResourceTheme() | CXTPShortcutBarResourceTheme |
CXTPShortcutBarVisualStudio2015Theme() | CXTPShortcutBarVisualStudio2015Theme |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarOffice2013Theme | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2013Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarResourceTheme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarVisualStudio2015Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2015Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2013Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarVisualStudio2015Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bHiliteBorders | CXTPShortcutBarVisualStudio2015Theme | protected
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrBackHiliteSelected | CXTPShortcutBarVisualStudio2015Theme | protected
m_clrBorderHilite | CXTPShortcutBarVisualStudio2015Theme | protected
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrGlyph | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphExpanded | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphFill | CXTPShortcutBarOffice2013Theme | protected
m_clrGlyphPushed | CXTPShortcutBarOffice2013Theme | protected
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarVisualStudio2015Theme | virtual
~CXTPShortcutBarOffice2013Theme() | CXTPShortcutBarOffice2013Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual
~CXTPShortcutBarVisualStudio2015Theme() | CXTPShortcutBarVisualStudio2015Theme | virtual


Toolkit Pro: XTPDockingPaneThemeNativeWindows11.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMENATIVEWINDOWS11_H__)
24# define __XTPDOCKINGPANETHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneNativeWindows11Theme
39 : public CXTPDockingPaneVisualStudio2012Theme
40{
41public:
46 CXTPDockingPaneNativeWindows11Theme();
47
53 virtual ~CXTPDockingPaneNativeWindows11Theme();
54
60 virtual void RefreshMetrics();
61
68 virtual void DrawSplitter(CDC* pDC, CXTPDockingPaneSplitterWnd* pSplitter);
69
79 virtual void DrawAutoHidePanel(CDC* pDC, CRect rc, XTPDockingPaneDirection direction);
80
81protected:
91 virtual void DrawTitleBar(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rc, BOOL bVertical);
92
93 COLORREF m_clrCaptionBorder;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPDOCKINGPANETHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneNativeWindows11Theme
CXTPDockingPaneNativeWindows11Theme is used to define drawing routines specific to a Native Windows 1...
Definition XTPDockingPaneThemeNativeWindows11.h:40
CXTPDockingPaneNativeWindows11Theme::DrawTitleBar
virtual void DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical)
This member function is called to draw a title bar for the docking pane.
CXTPDockingPaneNativeWindows11Theme::DrawSplitter
virtual void DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter)
Override this method to draw a splitter.
CXTPDockingPaneNativeWindows11Theme::CXTPDockingPaneNativeWindows11Theme
CXTPDockingPaneNativeWindows11Theme()
Constructs a CXTPDockingPaneNativeWindows11Theme object.
CXTPDockingPaneNativeWindows11Theme::DrawAutoHidePanel
virtual void DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction)
This method is called by the framework to draw the docking pane auto-hide panel background and splitt...
CXTPDockingPaneNativeWindows11Theme::~CXTPDockingPaneNativeWindows11Theme
virtual ~CXTPDockingPaneNativeWindows11Theme()
Destroys a CXTPDockingPaneNativeWindows11Theme object, handles cleanup and deallocation.
CXTPDockingPaneNativeWindows11Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneNativeWindows11Theme::m_clrCaptionBorder
COLORREF m_clrCaptionBorder
Caption border color.
Definition XTPDockingPaneThemeNativeWindows11.h:93
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneVisualStudio2012Theme
CXTPDockingPaneVisualStudio2012Theme is used to define drawing routines specific to a Visual Studio 2...
Definition XTPDockingPaneThemeVisualStudio2012.h:41


CXTPTabManagerAtom Member List

This is the complete list of members for CXTPTabManagerAtom, including all inherited members.

OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
Reposition()=0 | CXTPTabManagerAtom | pure virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual


XTP_NM_GRID_BEFORE_COPYPASTE Member List

This is the complete list of members for XTP_NM_GRID_BEFORE_COPYPASTE, including all inherited members.

hdr | XTP_NM_GRID_BEFORE_COPYPASTE
parStrings | XTP_NM_GRID_BEFORE_COPYPASTE
ppRecord | XTP_NM_GRID_BEFORE_COPYPASTE


CXTPGridSubListControl Member List

This is the complete list of members for CXTPGridSubListControl, including all inherited members.

BeginDrag(int nItem) | CXTPGridSubListControl | protected
CancelDrag() | CXTPGridSubListControl | protected
CXTPGridSubListControl() | CXTPGridSubListControl |
Disable(int iSubItem) | CXTPGridSubListControl | virtual
Dragging(CPoint pt) | CXTPGridSubListControl | protected
Dropped(CPoint pt) | CXTPGridSubListControl | protected
FindItemData(int nItemData) | CXTPGridSubListControl | protected
GetGridCtrl() | CXTPGridSubListControl |
GetItemCaption(int nIndex) | CXTPGridSubListControl |
GetItemColumn(int nIndex) | CXTPGridSubListControl |
Include(int iSubItem) | CXTPGridSubListControl | virtual
m_bSortAscending | CXTPGridSubListControl | protected
m_nDropIndex | CXTPGridSubListControl | protected
m_pDragWnd | CXTPGridSubListControl | protected
m_pGridCtrl | CXTPGridSubListControl | protected
m_rcDragWnd | CXTPGridSubListControl | protected
m_rcDropTarget1 | CXTPGridSubListControl | protected
m_rcDropTarget2 | CXTPGridSubListControl | protected
SetGridCtrl(CXTPGridControl *pGridCtrl) | CXTPGridSubListControl |
SortAscending(BOOL bSort) | CXTPGridSubListControl |
UpdateList() | CXTPGridSubListControl |
~CXTPGridSubListControl() | CXTPGridSubListControl |


CXTPGridIconNavigator Member List

This is the complete list of members for CXTPGridIconNavigator, including all inherited members.

BeginEdit() | CXTPGridIconNavigator | virtual
CheckDeadEnd(BOOL bMoveDown) | CXTPGridNavigator | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridIconNavigator(CXTPGridControl *pGridControl) | CXTPGridIconNavigator |
CXTPGridNavigator(CXTPGridControl *pGridControl) | CXTPGridNavigator |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCurrentFocusInFootersRows() | CXTPGridNavigator |
GetCurrentFocusInHeadersRows() | CXTPGridNavigator |
m_pGridControl | CXTPGridNavigator | protected
MoveDown(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridIconNavigator | virtual
MoveDownStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridIconNavigator | virtual
MoveFirstColumn() | CXTPGridNavigator |
MoveFirstRow(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveFirstVisibleRow(XTPGridRowType RowType) | CXTPGridNavigator | protected
MoveLastColumn() | CXTPGridNavigator |
MoveLastRow(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveLastVisibleRow(XTPGridRowType RowType) | CXTPGridNavigator | protected
MoveLeft(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveLeftRight(BOOL bBack, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridIconNavigator | virtual
MovePageDown(BOOL bShiftKey, BOOL bControlKey) | CXTPGridIconNavigator | virtual
MovePageUp(BOOL bShiftKey, BOOL bControlKey) | CXTPGridIconNavigator | virtual
MoveRight(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveToColumn(int nColumnIndex, BOOL bClearIfNonFocusable=FALSE) | CXTPGridNavigator |
MoveToRow(int nRowIndex, BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridNavigator |
MoveUp(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridIconNavigator | virtual
MoveUpStep(BOOL bShiftKey=FALSE, BOOL bControlKey=FALSE) | CXTPGridIconNavigator | virtual
SetCurrentFocusInFootersRows(BOOL bCurrentFocusInFootersRows) | CXTPGridNavigator |
SetCurrentFocusInHeadersRows(BOOL bCurrentFocusInHeadersRows) | CXTPGridNavigator |
~CXTPGridIconNavigator() | CXTPGridIconNavigator | virtual
~CXTPGridNavigator() | CXTPGridNavigator | virtual


CXTPChartAreaSeriesStyle Member List

This is the complete list of members for CXTPChartAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartAreaSeriesStyle | protectedvirtual
CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAreaSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillAcrossXAxis() const | CXTPChartAreaSeriesStyle |
GetFillStyle() const | CXTPChartAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nFillAcrossXAxis | CXTPChartAreaSeriesStyle | protected
m_nTransparency | CXTPChartAreaSeriesStyle | protected
m_pBorder | CXTPChartAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetFillAcrossXAxis(BOOL nFillAcrossXAxis) | CXTPChartAreaSeriesStyle |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartAreaSeriesStyle | virtual
~CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPChart2dPieSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
XTPChart2dPieSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPIESERIESLABEL_H__)
24# define __XTPCHART2DPIESERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartPieSeriesPointViewBase;
35class CXTPChartPieSeriesStyleBase;
36
42class _XTP_EXT_CLASS CXTPChartPieSeriesLabel : public CXTPChartPieSeriesLabelBase
43{
44 DECLARE_SERIAL(CXTPChartPieSeriesLabel);
45
46public:
51 CXTPChartPieSeriesLabel();
52
53protected:
65 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
66 CXTPChartSeriesPointView* pPointView,
67 CXTPChartElementView* pParentView);
68
69public:
82 CXTPChartPointF CalculateAnchorPointAndAngles(CXTPChartPieSeriesPointViewBase* pPointView,
83 int borderThickness, double& lineAngle);
84};
85
90class _XTP_EXT_CLASS CXTPChartPieSeriesLabelView : public CXTPChartPieSeriesLabelViewBase
91{
92public:
101 CXTPChartPieSeriesLabelView(CXTPChartSeriesLabel* pLabel, CXTPChartSeriesPointView* pPointView,
102 CXTPChartElementView* pParentView);
103
104public:
111 void CalculateLayout(CXTPChartDeviceContext* pDC);
112
123 virtual CXTPChartDeviceCommand* CreateConnectorDeviceCommand(CXTPChartDeviceContext* pDC);
124
135 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
136
137protected:
138 CXTPChartRectF m_rcBounds;
139 CXTPChartPointF m_ptStartPoint;
140 double m_dLineAngle;
142 friend class CXTPChartPieSeriesLabelsView;
143};
144
149class _XTP_EXT_CLASS CXTPChartPieSeriesLabelsView : public CXTPChartPieSeriesLabelsViewBase
150{
151public:
158 CXTPChartPieSeriesLabelsView(CXTPChartElementView* pParentView);
159
160public:
171 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
172
177 virtual void ResolveOverlapping();
178
179protected:
186 void ResolveOverlappingColumn(
187 CArray<CXTPChartPieSeriesLabelView*, CXTPChartPieSeriesLabelView*>& arrColumn);
188};
190# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
191#endif //#if !defined(__XTPCHART2DPIESERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesLabelBase
CXTPChartPieSeriesLabelBase is a kind of CXTPChartSeriesLabel.
Definition XTPChartPieSeriesLabelBase.h:56
CXTPChartPieSeriesLabel
CXTPChartPieSeriesLabelBase is a kind of CXTPChartPieSeriesLabel.
Definition XTPChart2dPieSeriesLabel.h:43
CXTPChartPieSeriesLabel::CalculateAnchorPointAndAngles
CXTPChartPointF CalculateAnchorPointAndAngles(CXTPChartPieSeriesPointViewBase *pPointView, int borderThickness, double &lineAngle)
Call this function to calculate the anchor points and angles of the pie label stem.
CXTPChartPieSeriesLabel::CXTPChartPieSeriesLabel
CXTPChartPieSeriesLabel()
Constructs a CXTPChartPieSeriesLabel object.
CXTPChartPieSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the pie series.
CXTPChartPieSeriesLabelViewBase
Defines a base class interface for series label view.
Definition XTPChartPieSeriesLabelBase.h:157
CXTPChartPieSeriesLabelView
Defines 2D series label view.
Definition XTPChart2dPieSeriesLabel.h:91
CXTPChartPieSeriesLabelView::m_rcBounds
CXTPChartRectF m_rcBounds
The determined boundary rectange.
Definition XTPChart2dPieSeriesLabel.h:138
CXTPChartPieSeriesLabelView::m_dLineAngle
double m_dLineAngle
The determined connector line angle.
Definition XTPChart2dPieSeriesLabel.h:140
CXTPChartPieSeriesLabelView::m_ptStartPoint
CXTPChartPointF m_ptStartPoint
The determined connector start point.
Definition XTPChart2dPieSeriesLabel.h:139
CXTPChartPieSeriesLabelView::CreateConnectorDeviceCommand
virtual CXTPChartDeviceCommand * CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC)
Creates connector drawing device command for the device context specified.
CXTPChartPieSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates view drawing device command for the device context specified.
CXTPChartPieSeriesLabelView::CalculateLayout
void CalculateLayout(CXTPChartDeviceContext *pDC)
Calculates label and connector layout for the device context specified.
CXTPChartPieSeriesLabelView::CXTPChartPieSeriesLabelView
CXTPChartPieSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelView object.
CXTPChartPieSeriesLabelsViewBase
Defines a base class interface for series label collection view.
Definition XTPChartPieSeriesLabelBase.h:213
CXTPChartPieSeriesLabelsView
Defines 2D series label collection view.
Definition XTPChart2dPieSeriesLabel.h:150
CXTPChartPieSeriesLabelsView::ResolveOverlapping
virtual void ResolveOverlapping()
Resolves label overlapping in an implementation specific way.
CXTPChartPieSeriesLabelsView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Creates a view drawing device command for the device context specified.
CXTPChartPieSeriesLabelsView::ResolveOverlappingColumn
void ResolveOverlappingColumn(CArray< CXTPChartPieSeriesLabelView *, CXTPChartPieSeriesLabelView * > &arrColumn)
Resolves label overlapping for column mode.
CXTPChartPieSeriesLabelsView::CXTPChartPieSeriesLabelsView
CXTPChartPieSeriesLabelsView(CXTPChartElementView *pParentView)
Constructs a CXTPChartPieSeriesLabelsView object.
CXTPChartPieSeriesPointViewBase
This class abstracts the view of a pie series point.
Definition XTPChartPieSeriesPointViewBase.h:50
CXTPChartPieSeriesStyleBase
This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartPieSeriesStyleBase.h:48
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >
CXTPRectT< float >


Toolkit Pro: XTPFlowGraphDrawContextGdiPlus.h Source File

  • Source
  • FlowGraph
XTPFlowGraphDrawContextGdiPlus.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHDRAWCONTEXTGDIPLUS_H__)
24# define __XTPFLOWGRAPHDRAWCONTEXTGDIPLUS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphImage;
35
36namespace Gdiplus
37{
38class Brush;
39class Pen;
40class Graphics;
41class GraphicsPath;
42} // namespace Gdiplus
43
44class _XTP_EXT_CLASS CXTPFlowGraphDrawContextGdiPlus : public CXTPFlowGraphDrawContext
45{
46public:
51 CXTPFlowGraphDrawContextGdiPlus(HDC hDC, HDC hAttribDC = NULL, BOOL bPrinting = FALSE);
57 virtual ~CXTPFlowGraphDrawContextGdiPlus();
58
59public:
64 static void AFX_CDECL Register(BOOL bReserved);
65
66public:
73 virtual Gdiplus::Graphics* GetGraphics() const;
74
75public:
76 virtual CSize MeasureMarkupElement(CXTPMarkupUIElement* pMarkupUIElement);
77 virtual void DrawMarkupElement(CXTPMarkupUIElement* pMarkupUIElement, LPCRECT lpRect,
78 UINT uFormat);
79
80 virtual CSize MeasureString(const CString& str);
81
82 virtual void SetClipRect(CRect rc);
83 virtual CRect GetClipRect() const;
84
85 virtual void DrawGrid(CRect rc, CPoint ptScrollOffset, double dZoomLevel,
86 COLORREF clrGridColor);
87
88 virtual void SetSmoothingMode(int nMode);
89
90public:
91 virtual void FillSolidRect(LPCRECT lpRect, COLORREF clr);
92 virtual void FillSolidRect(int x, int y, int cx, int cy, COLORREF clr);
93
94 virtual void GradientFill(CRect rc, COLORREF clrFrom, COLORREF clrTo, BOOL bHoriz);
95
96 virtual void Draw3dRect(int x, int y, int cx, int cy, COLORREF clrTopLeft,
97 COLORREF clrBottomRight);
98 virtual void Draw3dRect(LPCRECT lpRect, COLORREF clrTopLeft, COLORREF clrBottomRight);
99
100 virtual void DrawFrame(int x, int y, int cx, int cy, int sz, COLORREF clr);
101
102 virtual void DrawText(LPCTSTR lpszText, LPCRECT lpRect, UINT uFormat);
103
104 virtual void DrawCurve(Gdiplus::GraphicsPath* pPath);
105
106 virtual void Clear(COLORREF clr);
107
108 using CXTPFlowGraphDrawContext::Line;
109
110 virtual void Line(float x1, float y1, float x2, float y2);
111
112 virtual void Ellipse(LPCRECT lpRect);
113
114 virtual void SetWorldTransform(CPoint ptOffset, double dZoomLevel);
115
116 virtual void SetBrush(COLORREF clr);
117 virtual void SetPen(COLORREF clrPen, int nWidth, BOOL bDashed = FALSE);
118 virtual void SetFont(LOGFONT* lf);
119 virtual void SetTextColor(COLORREF clr);
120
121 virtual void DrawImage(CXTPFlowGraphImage* pImage, CRect rc);
122 virtual void FillPolygon(const POINT* pts, int nCount);
123
124public:
125 Gdiplus::Brush* CreateBrush(COLORREF clr);
126 static DWORD AFX_CDECL ColorRefToARGB(COLORREF clr);
127
128# ifdef _XTP_DEMOMODE
129 virtual void CXTPFlowGraphDrawContextGdiPlus::DrawWatermarkBackground(CRect rc);
130# endif
131
132protected:
133 Gdiplus::Brush* m_pActiveBrush;
134 Gdiplus::Brush* m_pActiveTextBrush;
135 Gdiplus::Pen* m_pActivePen;
136 Gdiplus::Font* m_pActiveFont;
137 LOGFONT m_lfActiveFont;
138 COLORREF m_clrTextColor;
139 Gdiplus::Graphics* m_pGraphics;
140
141 struct BRUSHREC
142 {
143 COLORREF clr;
144 Gdiplus::Brush* pBrush;
145 };
146
147 enum
148 {
149 MAX_BRUSH = 6
150 };
151
152 int m_nBrushCount;
153 BRUSHREC m_arrBrushes[MAX_BRUSH];
154};
155
156AFX_INLINE Gdiplus::Graphics* CXTPFlowGraphDrawContextGdiPlus::GetGraphics() const
157{
158 return m_pGraphics;
159}
161# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
162#endif //#if !defined(__XTPFLOWGRAPHDRAWCONTEXTGDIPLUS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphImage
Object used to represent an image displayed in a Node or connection point.
Definition XTPFlowGraphImage.h:49
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPSkinManagerSchema.h Source File

  • Source
  • SkinFramework
XTPSkinManagerSchema.h
Go to the documentation of this file.
1
23#if !defined(_XTPSKINMANAGERSCHEMA_H__)
24# define _XTPSKINMANAGERSCHEMA_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSkinManagerResourceFile;
34class CXTPSkinManagerClass;
35class CXTPSkinManager;
36class CXTPSkinObjectFrame;
37class CXTPSkinImage;
38class CXTPSkinManagerMetrics;
39class CXTPSkinManagerSchema;
40struct XTP_SKINSCROLLBAR_POSINFO;
41
42// #define _OLD_METHOD_GET_TMS_CODES_VERIFY
43
49class _XTP_EXT_CLASS CXTPSkinManagerSchemaProperty : public CXTPSynchronized
50{
51public:
56 CXTPSkinManagerSchemaProperty();
57
62 ~CXTPSkinManagerSchemaProperty();
63
64public:
72 void SetPropertyColor(LPCTSTR lpszValue);
73
79 void SetPropertyString(LPCTSTR lpszValue);
80
88 void SetPropertyBool(LPCTSTR lpszValue);
89
97 void SetPropertyInt(LPCTSTR lpszValue);
98
104 void SetPropertyEnum(int nEnumValue);
105
113 void SetPropertySize(LPCTSTR lpszValue);
114
122 void SetPropertyRect(LPCTSTR lpszValue);
123
131 void SetPropertyFont(LPCTSTR lpszValue);
132
137 void ClearProperty();
138
139 BOOL operator==(const CXTPSkinManagerSchemaProperty& obj) const;
140
141public:
142 XTPSkinManagerProperty propType;
143 int nPropertyCode;
145 union {
146 COLORREF clrVal;
147 LPTSTR lpszVal;
148 BOOL bVal;
149 int iVal;
150 RECT rcVal;
151 SIZE szVal;
152 PLOGFONT lfVal;
153 };
154};
155
161class _XTP_EXT_CLASS CXTPSkinManagerSchema
162 : public CXTPCmdTarget
163 , public CXTPSynchronized
164{
166 DECLARE_DYNAMIC(CXTPSkinManagerSchema)
168public:
174 CXTPSkinManagerSchema(CXTPSkinManagerResourceFile* pResourceFile);
175
180 virtual ~CXTPSkinManagerSchema();
181
182public:
189 HRESULT ReadProperties();
190
198 static UINT AFX_CDECL GetClassCode(LPCTSTR strClass);
199
200# ifdef _OLD_METHOD_GET_TMS_CODES_VERIFY
201 static UINT AFX_CDECL GetClassCodeOld(LPCTSTR strClass);
202# endif
203
204public:
217 HRESULT GetStringProperty(UINT iClassId, int iPartId, int iStateId, int iPropId,
218 CString& strVal);
219
232 HRESULT GetRectProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CRect& rcVal);
233
246 HRESULT GetIntProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, int& iVal);
247
260 HRESULT GetBoolProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, BOOL& bVal);
261
274 HRESULT GetColorProperty(UINT iClassId, int iPartId, int iStateId, int iPropId,
275 COLORREF& clrVal);
276
289 HRESULT GetEnumProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, int& nVal);
290
303 HRESULT GetFontProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, LOGFONT& lfVal);
304
317 HRESULT GetSizeProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CSize& szVal);
318
325 CString GetSchemaName() const;
326
333 CXTPSkinManager* GetSkinManager() const;
334
341 CXTPSkinManagerResourceFile* GetResourceFile() const;
342
349 CXTPSkinManagerMetrics* GetMetrics() const;
350
353 void RefreshAllClasses();
354 CXTPSkinManagerSchemaProperty* GetProperty(UINT iClassId, int iPartId, int iStateId,
355 int iPropId);
356 CXTPSkinManagerClass* GetClass(const CString& strClassList);
357
358protected:
359 enum FRAMEPART
360 {
361 frameLeft,
362 frameTop,
363 frameRight,
364 frameBottom
365 };
366
367 struct FRAMEREGIONPART
368 {
369 FRAMEREGIONPART()
370 {
371 nCenter = 0;
372 rcSizingMargins.SetRectEmpty();
373 }
374
375 CRgn rgnLeft;
376 CRgn rgnRight;
377 CRect rcSizingMargins;
378 int nCenter;
379 };
380
381 struct FRAMEREGION
382 {
383 int nCaptionHeight;
384 int nBorderHeight;
385 BOOL bToolWindow;
386 BOOL bAutoDelete;
387
388 FRAMEREGIONPART Part[4];
389 };
390
391public:
392 HICON GetFrameSmIcon(HWND hWnd, BOOL bCheckStyle = TRUE) const;
393
394public:
395 static UINT AFX_CDECL GetSchemaPartCode(CString strSchemaPart);
396 static UINT AFX_CDECL GetClassPartCode(LPCTSTR lpszClass, LPCTSTR lpszClassPart);
397
398# ifdef _OLD_METHOD_GET_TMS_CODES_VERIFY
399
400 static UINT AFX_CDECL GetClassPartCodeOld(LPCTSTR lpszClass, LPCTSTR lpszClassPart);
401
402# endif // _OLD_METHOD_GET_TMS_CODES_VERIFY
403
404 static UINT AFX_CDECL GetStateCode(LPCTSTR lpszClassPart, LPCTSTR lpszState);
405 static int AFX_CDECL GetEnumCode(LPCTSTR lpszProperty, LPCTSTR lpszValue);
406
407# ifdef _OLD_METHOD_GET_TMS_CODES_VERIFY
408 static UINT AFX_CDECL GetStateCodeOld(LPCTSTR lpszClassPart, LPCTSTR lpszState);
409 static int AFX_CDECL GetEnumCodeOld(LPCTSTR lpszProperty, LPCTSTR lpszValue);
410 static UINT AFX_CDECL GetPropertyCodeOld(LPCTSTR lpszProperty,
411 XTPSkinManagerProperty& nPropertyType);
412# endif // _OLD_METHOD_GET_TMS_CODES_VERIFY
413
414 static UINT AFX_CDECL GetPropertyCode(LPCTSTR lpszProperty,
415 XTPSkinManagerProperty& nPropertyType);
416 static CXTPSkinManagerSchemaProperty* AFX_CDECL CreateProperty(
417 LPCTSTR lpszProperty, XTPSkinManagerProperty nPropertyType, LPCTSTR lpszValue);
418 static UINT AFX_CDECL CalculatePropertyCode(UINT iClassId, int iPartId, int iStateId,
419 int iPropId);
420
421protected:
422 void RemoveAllProperties();
423 COLORREF GetColor(int nIndex) const;
426public:
428 virtual BOOL DrawThemeBackground(CDC* pDC, CXTPSkinManagerClass* pClass, int iPartId,
429 int iStateId, const RECT* pRect);
430 virtual void DrawThemeFrame(CDC* pDC, CXTPSkinObjectFrame* pFrame);
431 virtual CRect CalcFrameBorders(CXTPSkinObjectFrame* pFrame);
432 virtual CRect CalcFrameBorders(DWORD dwStyle, DWORD dwExStyle);
433 virtual HRGN CalcFrameRegion(CXTPSkinObjectFrame* pFrame, CSize sz);
434 virtual void RefreshMetrcis();
435 void DrawNonClientRect(CDC* pDC, CRect rcFrame, CXTPSkinObjectFrame* pFrame);
436 void DrawClientEdge(CDC* pDC, const CRect& rcFrame, CXTPSkinObjectFrame* pFrame);
437 virtual void DrawThemeScrollBar(CDC* pDC, CXTPSkinObjectFrame* pFrame,
438 XTP_SKINSCROLLBAR_POSINFO* pSBInfo);
439 virtual COLORREF GetScrollBarSizeBoxColor(CXTPSkinObjectFrame* pFrame);
442protected:
444 BOOL DrawThemeBackgroundGlyph(CDC* pDC, CXTPSkinManagerClass* pClass, int iPartId, int iStateId,
445 const RECT* pRect);
446 BOOL DrawThemeBackgroundBorder(CDC* pDC, CXTPSkinManagerClass* pClass, int iPartId,
447 int iStateId, const RECT* pRect);
448 int FindBestImageGlyphSize(CXTPSkinManagerClass* pClass, int iPartId, int iStateId,
449 const CRect& rcDest, int nImageCount, BOOL bHorizontalImageLayout);
450
451# ifdef _XTP_ACTIVEX
452 COLORREF OleGetColor(long Index);
453 DECLARE_DISPATCH_MAP()
454 DECLARE_INTERFACE_MAP()
455 DECLARE_OLETYPELIB_EX(CXTPSkinManagerSchema);
456# endif
459private:
460 int GetWindowBorders(LONG lStyle, DWORD dwExStyle, BOOL fWindow);
461 void FreeFrameRegions();
462 void RegionFromBitmap(CBitmap* pBitmap, FRAMEPART nAlign, FRAMEREGIONPART* pPart,
463 const CRect& rc, COLORREF clrTransparent);
464
465 FRAMEREGION* CreateFrameRegion(CXTPSkinObjectFrame* pFrame, CSize sz);
466 CSize GetCaptionButtonSize(CXTPSkinManagerClass* pClass, int yButton);
467 BOOL DrawWindowPart(CXTPSkinObjectFrame* pFrame, CBitmap& bmp, int iPartId, BOOL bVertical,
468 int nBorderHeight, CRect& rcDest, CRect& rcSizingMargins,
469 COLORREF& clrTransparent);
470 int DrawThemeFrameButtons(CDC* pDC, CXTPSkinObjectFrame* pFrame);
471
472 CRect CalcFrameBorders(DWORD dwStyle, DWORD dwExStyle, CXTPSkinObjectFrame* pFrame);
473
474public:
475 BOOL m_bPreMultiplyImages;
476
477protected:
478 CMap<UINT, UINT, CXTPSkinManagerSchemaProperty*, CXTPSkinManagerSchemaProperty*>
479 m_mapProperties;
481 CXTPSkinManager* m_pManager;
482 CXTPSkinManagerResourceFile* m_pResourceFile;
483 CXTPSkinManagerMetrics* m_pMetrics;
485 CString m_strSchemaName;
486 CRITICAL_SECTION m_csDraw;
487
488 CArray<FRAMEREGION*, FRAMEREGION*> m_arrFrameRegions;
490protected:
491 int m_nGlobalClassId;
492 int m_nWindowClassId;
493
494 CMapStringToPtr m_mapClasses;
495};
496
497AFX_INLINE CString CXTPSkinManagerSchema::GetSchemaName() const
498{
499 return m_strSchemaName;
500}
501AFX_INLINE CXTPSkinManager* CXTPSkinManagerSchema::GetSkinManager() const
502{
503 return m_pManager;
504}
505AFX_INLINE CXTPSkinManagerResourceFile* CXTPSkinManagerSchema::GetResourceFile() const
506{
507 return m_pResourceFile;
508}
509AFX_INLINE CXTPSkinManagerMetrics* CXTPSkinManagerSchema::GetMetrics() const
510{
511 return m_pMetrics;
512}
513
514# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
516#endif // !defined(AFX_SKINMANAGERSCHEMA_H__44A8B96F_B15B_43F7_A734_39C649784B29__INCLUDED_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSkinManagerProperty
XTPSkinManagerProperty
Available properties for the CXTPSkinManagerSchemaProperty class.
Definition XTPSkinManager.h:83
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSkinImage
The CXTPSkinImage class represents a simple bitmap holder and draw operations for Skin Framework.
Definition XTPSkinImage.h:41
CXTPSkinManagerClass
CXTPSkinManagerClass is a standalone class that represents a single visual class of the skin manager.
Definition XTPSkinManager.h:110
CXTPSkinManager
CXTPSkinManager is a standalone class that represents a global object that manages skins.
Definition XTPSkinManager.h:541
CXTPSkinManagerMetrics
CXTPSkinManagerMetrics is a standalone class that represents a collection of metrics of the current s...
Definition XTPSkinManager.h:403
CXTPSkinManagerResourceFile
CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources...
Definition XTPSkinManagerResource.h:45
CXTPSkinManagerSchema
CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file.
Definition XTPSkinManagerSchema.h:164
CXTPSkinManagerSchema::GetMetrics
CXTPSkinManagerMetrics * GetMetrics() const
Gets the metrics object.
Definition XTPSkinManagerSchema.h:509
CXTPSkinManagerSchema::GetStringProperty
HRESULT GetStringProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CString &strVal)
Gets the value of a specified string property.
CXTPSkinManagerSchema::GetClassCode
static UINT AFX_CDECL GetClassCode(LPCTSTR strClass)
Gets the hash code of a specified class.
CXTPSkinManagerSchema::ReadProperties
HRESULT ReadProperties()
Reads all properties from a specified resource file.
CXTPSkinManagerSchema::GetSkinManager
CXTPSkinManager * GetSkinManager() const
Gets the parent skin manager object.
Definition XTPSkinManagerSchema.h:501
CXTPSkinManagerSchema::GetEnumProperty
HRESULT GetEnumProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, int &nVal)
Gets the value of a specified enum property.
CXTPSkinManagerSchema::GetColorProperty
HRESULT GetColorProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, COLORREF &clrVal)
Gets the value of a specified COLORREF property.
CXTPSkinManagerSchema::GetFontProperty
HRESULT GetFontProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, LOGFONT &lfVal)
Gets the value of a specified LOGFONT property.
CXTPSkinManagerSchema::m_pManager
CXTPSkinManager * m_pManager
Parent CXTPSkinManager class.
Definition XTPSkinManagerSchema.h:481
CXTPSkinManagerSchema::m_mapClasses
CMapStringToPtr m_mapClasses
Classes collection.
Definition XTPSkinManagerSchema.h:494
CXTPSkinManagerSchema::m_mapProperties
CMap< UINT, UINT, CXTPSkinManagerSchemaProperty *, CXTPSkinManagerSchemaProperty * > m_mapProperties
Properties collection.
Definition XTPSkinManagerSchema.h:479
CXTPSkinManagerSchema::m_pResourceFile
CXTPSkinManagerResourceFile * m_pResourceFile
Resources.
Definition XTPSkinManagerSchema.h:482
CXTPSkinManagerSchema::m_pMetrics
CXTPSkinManagerMetrics * m_pMetrics
Skin metrics.
Definition XTPSkinManagerSchema.h:483
CXTPSkinManagerSchema::GetSchemaName
CString GetSchemaName() const
Gets the schema name.
Definition XTPSkinManagerSchema.h:497
CXTPSkinManagerSchema::GetSizeProperty
HRESULT GetSizeProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CSize &szVal)
Gets the value of a specified CSize property.
CXTPSkinManagerSchema::m_arrFrameRegions
CArray< FRAMEREGION *, FRAMEREGION * > m_arrFrameRegions
Frame region.
Definition XTPSkinManagerSchema.h:488
CXTPSkinManagerSchema::GetBoolProperty
HRESULT GetBoolProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, BOOL &bVal)
Gets the value of a specified BOOL property.
CXTPSkinManagerSchema::m_strSchemaName
CString m_strSchemaName
Schema name.
Definition XTPSkinManagerSchema.h:485
CXTPSkinManagerSchema::GetResourceFile
CXTPSkinManagerResourceFile * GetResourceFile() const
Gets the resource file object.
Definition XTPSkinManagerSchema.h:505
CXTPSkinManagerSchema::GetRectProperty
HRESULT GetRectProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CRect &rcVal)
Gets the value of a specified RECT property.
CXTPSkinManagerSchema::GetIntProperty
HRESULT GetIntProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, int &iVal)
Gets the value of a specified int property.
CXTPSkinManagerSchema::~CXTPSkinManagerSchema
virtual ~CXTPSkinManagerSchema()
Destroys a CXTPSkinManagerSchema object, handles cleanup and deallocation.
CXTPSkinManagerSchema::CXTPSkinManagerSchema
CXTPSkinManagerSchema(CXTPSkinManagerResourceFile *pResourceFile)
Constructs a CXTPSkinManagerSchema object.
CXTPSkinManagerSchemaProperty
CXTPSkinManagerSchemaProperty is a standalone class representing a single property of a visual styles...
Definition XTPSkinManagerSchema.h:50
CXTPSkinManagerSchemaProperty::SetPropertyColor
void SetPropertyColor(LPCTSTR lpszValue)
Sets the color value of the property.
CXTPSkinManagerSchemaProperty::lfVal
PLOGFONT lfVal
LOGFONT value of the property.
Definition XTPSkinManagerSchema.h:152
CXTPSkinManagerSchemaProperty::SetPropertyInt
void SetPropertyInt(LPCTSTR lpszValue)
Sets the int value of the property.
CXTPSkinManagerSchemaProperty::nPropertyCode
int nPropertyCode
Property code.
Definition XTPSkinManagerSchema.h:143
CXTPSkinManagerSchemaProperty::SetPropertyFont
void SetPropertyFont(LPCTSTR lpszValue)
Sets the LOGFONT value of the property.
CXTPSkinManagerSchemaProperty::CXTPSkinManagerSchemaProperty
CXTPSkinManagerSchemaProperty()
Constructs a CXTPSkinManagerSchemaProperty object.
CXTPSkinManagerSchemaProperty::rcVal
RECT rcVal
Rect value of the property.
Definition XTPSkinManagerSchema.h:150
CXTPSkinManagerSchemaProperty::SetPropertyString
void SetPropertyString(LPCTSTR lpszValue)
Sets the string value of the property.
CXTPSkinManagerSchemaProperty::bVal
BOOL bVal
BOOL value of the property.
Definition XTPSkinManagerSchema.h:148
CXTPSkinManagerSchemaProperty::SetPropertyBool
void SetPropertyBool(LPCTSTR lpszValue)
Sets the BOOL value of the property.
CXTPSkinManagerSchemaProperty::ClearProperty
void ClearProperty()
Clears the property value.
CXTPSkinManagerSchemaProperty::iVal
int iVal
Integer value of the property.
Definition XTPSkinManagerSchema.h:149
CXTPSkinManagerSchemaProperty::SetPropertyRect
void SetPropertyRect(LPCTSTR lpszValue)
Sets the RECT value of the property.
CXTPSkinManagerSchemaProperty::szVal
SIZE szVal
SIZE value of the property.
Definition XTPSkinManagerSchema.h:151
CXTPSkinManagerSchemaProperty::clrVal
COLORREF clrVal
Color value of the property.
Definition XTPSkinManagerSchema.h:146
CXTPSkinManagerSchemaProperty::propType
XTPSkinManagerProperty propType
Property type.
Definition XTPSkinManagerSchema.h:142
CXTPSkinManagerSchemaProperty::SetPropertySize
void SetPropertySize(LPCTSTR lpszValue)
Sets the size value of the property.
CXTPSkinManagerSchemaProperty::SetPropertyEnum
void SetPropertyEnum(int nEnumValue)
Sets the enum value of the property.
CXTPSkinManagerSchemaProperty::~CXTPSkinManagerSchemaProperty
~CXTPSkinManagerSchemaProperty()
Destroys a CXTPSkinManagerSchemaProperty object, handles cleanup and deallocation.
CXTPSkinManagerSchemaProperty::lpszVal
LPTSTR lpszVal
LPCTSTR value of the property.
Definition XTPSkinManagerSchema.h:147
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602


CXTPRibbonSystemPopupBarPage Member List

This is the complete list of members for CXTPRibbonSystemPopupBarPage, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPRibbonSystemPopupBarPage | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPRibbonSystemPopupBarPage | protectedvirtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPPopupBar | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
CXTPRibbonSystemPopupBarPage() | CXTPRibbonSystemPopupBarPage |
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPPopupBar | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPPopupBar | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPCommandBar | virtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPPopupBar | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPCommandBar | virtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPPopupBar | virtual
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE) | CXTPPopupBar | virtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


CXTPTrackThemeOffice2003 Member List

This is the complete list of members for CXTPTrackThemeOffice2003, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPTrackPaintManager() | CXTPTrackPaintManager |
CXTPTrackThemeOffice2003() | CXTPTrackThemeOffice2003 |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPTrackThemeOffice2003 | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPTrackThemeOffice2003 | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMarkers(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPTrackThemeOffice2003 |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTimeLine(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTrackHeader(CDC *pDC) | CXTPTrackPaintManager | virtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FormatTime(int nPosition) | CXTPTrackPaintManager | virtual
FormatTimeLineTick(int nPosition, COLORREF &clrTick, int &nTickLength) | CXTPTrackPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrMarker | CXTPTrackPaintManager |
m_clrMarkerBack | CXTPTrackPaintManager |
m_clrMarkerBorder | CXTPTrackPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrScrollBarBorderDark | CXTPTrackPaintManager |
m_clrScrollBarBorderLight | CXTPTrackPaintManager |
m_clrScrollBarDark | CXTPTrackPaintManager |
m_clrScrollBarLight | CXTPTrackPaintManager |
m_clrSelectedArea | CXTPTrackPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrTimeHeaderBorder | CXTPTrackPaintManager |
m_clrTimeHeaderDark | CXTPTrackPaintManager |
m_clrTimeHeaderDarkDark | CXTPTrackPaintManager |
m_clrTimeHeaderDivider | CXTPTrackPaintManager |
m_clrTimeLinePosition | CXTPTrackPaintManager |
m_clrTimeLineTick | CXTPTrackPaintManager |
m_clrTimeSliderBackground | CXTPTrackPaintManager |
m_clrTrackHeader | CXTPTrackPaintManager |
m_clrTrackMarkerBorder | CXTPTrackPaintManager |
m_clrTrackMarkerText | CXTPTrackPaintManager |
m_clrTrackMarkerTextBack | CXTPTrackPaintManager |
m_clrTrackMarkerTextBorder | CXTPTrackPaintManager |
m_clrTrackTimeArea | CXTPTrackPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_clrWorkArea | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarBorder | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarDark | CXTPTrackPaintManager |
m_clrWorkAreaScrollBarLight | CXTPTrackPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPTrackPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual
~CXTPTrackPaintManager() | CXTPTrackPaintManager |


CXTPImageManagerIconHandle Member List

This is the complete list of members for CXTPImageManagerIconHandle, including all inherited members.

Attach(HICON hIcon, BOOL bSharedHandle) | CXTPImageManagerIconHandle |
Attach(HBITMAP hBitmap, BOOL bSharedHandle) | CXTPImageManagerIconHandle |
Clear() | CXTPImageManagerIconHandle |
CopyHandle(HBITMAP hBitmap) | CXTPImageManagerIconHandle |
CopyHandle(const CXTPImageManagerIconHandle &handle) | CXTPImageManagerIconHandle |
CreateIconFromResource(LPCTSTR lpszResourceName, CSize szIcon, BOOL bGroupResource=TRUE, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact) | CXTPImageManagerIconHandle |
CreateIconFromResource(HINSTANCE hInst, LPCTSTR lpszResourceName, CSize szIcon, BOOL bGroupResource, XTPIconSizeMatching nSizeMatching=xtpIconSizeExact) | CXTPImageManagerIconHandle |
CXTPImageManagerIconHandle() | CXTPImageManagerIconHandle |
CXTPImageManagerIconHandle(HICON hIcon, BOOL bUseResources=TRUE, BOOL bSharedHandle=TRUE) | CXTPImageManagerIconHandle |
CXTPImageManagerIconHandle(HBITMAP hBitmap, BOOL bSharedHandle=TRUE) | CXTPImageManagerIconHandle |
CXTPImageManagerIconHandle(const CXTPImageManagerIconHandle &hHandle) | CXTPImageManagerIconHandle |
Detach() | CXTPImageManagerIconHandle |
Draw(CDC *pDC, CPoint pt, CSize szIcon, BOOL bDrawComposited=FALSE) | CXTPImageManagerIconHandle |
GetBitmap() const | CXTPImageManagerIconHandle |
GetDpiScaled(int nDpi=0) const | CXTPImageManagerIconHandle |
GetExtent() const | CXTPImageManagerIconHandle |
GetIcon() const | CXTPImageManagerIconHandle |
Init() | CXTPImageManagerIconHandle | protected
IsAlpha() const | CXTPImageManagerIconHandle |
IsEmpty() const | CXTPImageManagerIconHandle |
m_bClearHandles | CXTPImageManagerIconHandle | protected
m_bUseResources | CXTPImageManagerIconHandle | protected
m_hBitmap | CXTPImageManagerIconHandle | protected
m_hIcon | CXTPImageManagerIconHandle | protected
m_pBits | CXTPImageManagerIconHandle | protected
m_pImageManager | CXTPImageManagerIconHandle | protected
m_pRInfo | CXTPImageManagerIconHandle | protected
m_szIcon | CXTPImageManagerIconHandle | protected
operator HICON() const | CXTPImageManagerIconHandle |
PreMultiply() | CXTPImageManagerIconHandle |
~CXTPImageManagerIconHandle() | CXTPImageManagerIconHandle |


CXTPControlFontComboBoxList Member List

This is the complete list of members for CXTPControlFontComboBoxList, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPPopupBar | protectedvirtual
Animate() | CXTPPopupBar | protectedvirtual
CalcDynamicLayout(int nLength, DWORD dwMode) | CXTPPopupBar | virtual
CalculatePopupRect(CPoint ptPopup, CSize sz) | CXTPPopupBar | virtual
Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE) | CXTPControlFontComboBoxList | protectedvirtual
Create() | CXTPPopupBar | virtual
CreateKeyboardTips() | CXTPCommandBar | virtual
CreateListBox() | CXTPControlFontComboBoxList | protectedvirtual
CreatePopupBar(CXTPCommandBars *pCommandBars) | CXTPPopupBar | static
CXTPCommandBar() | CXTPCommandBar | protected
CXTPControlComboBoxList() | CXTPControlComboBoxList |
CXTPControlComboBoxPopupBar() | CXTPControlComboBoxPopupBar |
CXTPHookManagerHookAble() | CXTPHookManagerHookAble |
CXTPPopupBar() | CXTPPopupBar | protected
DelayLayout() | CXTPCommandBar |
DelayRedraw() | CXTPPopupBar | inlineprotectedvirtual
DestroyWindow() | CXTPPopupBar |
DisableShadow() | CXTPPopupBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlFontComboBoxList | protectedvirtual
DrawCommandBar(CDC *pDC, CRect rcClipBox) | CXTPControlComboBoxList | protectedvirtual
DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) | CXTPControlComboBoxList | protectedvirtual
EnableAnimation(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableCustomization(BOOL bEnable=TRUE) | CXTPCommandBar |
EnableDoubleBuffer(BOOL bEnable=TRUE) | CXTPCommandBar |
EnsureVisible(CXTPControl *pControl) | CXTPCommandBar | virtual
EnumFontFamiliesEx(BOOL dwStyleListBox=1) | CXTPControlFontComboBoxList |
ExpandBar() | CXTPPopupBar |
FillCommandBarEntry(CDC *pDC) | CXTPCommandBar | virtual
FindAccel(TCHAR chAccel) const | CXTPCommandBar |
FindAccelEx(UINT chAccel, BOOL &bSelectOnly) const | CXTPCommandBar |
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPCommandBar | protectedvirtual
GetActiveDocTemplate() const | CXTPCommandBar | protected
GetBarID() const | CXTPCommandBar |
GetBorders() | CXTPPopupBar | virtual
GetButtonSize() const | CXTPCommandBar | virtual
GetCommandBarData() const | CXTPCommandBar |
GetCommandBars() const | CXTPCommandBar |
GetControl(int nIndex) const | CXTPCommandBar |
GetControlCount() const | CXTPCommandBar |
GetControlPopup() const | CXTPPopupBar |
GetControls() const | CXTPCommandBar |
GetDefaultButtonStyle() const | CXTPCommandBar |
GetDefaultItem(UINT gmdiFlags, BOOL fByPos=FALSE) | CXTPPopupBar |
GetFlags() const | CXTPCommandBar |
GetFrameSite() const | CXTPCommandBar |
GetIconSize() const | CXTPCommandBar | virtual
GetImageManager() const | CXTPCommandBar |
GetLargeIconSize(BOOL bAutoSize) const | CXTPCommandBar |
GetListBoxCtrl() const | CXTPControlComboBoxList |
GetOwnerSite() const | CXTPCommandBar |
GetPaintManager() const | CXTPCommandBar |
GetParentCommandBar() const | CXTPPopupBar | protectedvirtual
GetPosition() const | CXTPCommandBar |
GetRootParent() const | CXTPCommandBar |
GetSelected() const | CXTPCommandBar |
GetShowGripper() const | CXTPCommandBar |
GetSite() const | CXTPCommandBar |
GetTextOrientation() const | CXTPCommandBar |
GetTitle() const | CXTPCommandBar |
GetTrackFocus() const | CXTPCommandBar |
GetType() const | CXTPCommandBar |
GetWidth() const | CXTPCommandBar |
HideKeyboardTips() | CXTPCommandBar |
InvalidateParents() | CXTPCommandBar |
IsAnimationEnabled() const | CXTPCommandBar |
IsContextMenu() const | CXTPPopupBar |
IsCustomizable() const | CXTPControlComboBoxList | inlineprotectedvirtual
IsCustomizeDialogPresent() const | CXTPCommandBar |
IsCustomizeMode() const | CXTPCommandBar |
IsDialogBar() const | CXTPCommandBar | virtual
IsDoubleGripper() const | CXTPPopupBar |
IsHelpMode() const | CXTPCommandBar | protected
IsKeyboardCuesVisible() const | CXTPCommandBar | virtual
IsKeyboardTipsVisible() const | CXTPCommandBar |
IsLayoutRTL() const | CXTPCommandBar |
IsMenuTitleBar() const | CXTPCommandBar | virtual
IsPopupBar() const | CXTPPopupBar | virtual
IsResizable() const | CXTPPopupBar | virtual
IsRibbonBar() const | CXTPCommandBar | virtual
IsTearOffPopup(CString &strCaption, UINT &nID, int &nWidth) | CXTPPopupBar |
IsTextBelowIcons() const | CXTPCommandBar |
IsTrackingMode() const | CXTPCommandBar |
IsVisible() const | CXTPPopupBar | virtual
LoadMenu(CMenu *pMenu, BOOL bRemoveControls=TRUE) | CXTPCommandBar | virtual
LoadToolBar(UINT nIDResource, BOOL bLoadIcons=TRUE) | CXTPCommandBar | virtual
LockMouseMove(CXTPControl *pControl) | CXTPCommandBar |
LockRedraw() | CXTPCommandBar |
m_bAnimatePopup | CXTPCommandBar | protected
m_barPosition | CXTPCommandBar | protected
m_barType | CXTPCommandBar | protected
m_bAutoDestroy | CXTPHookManagerHookAble |
m_bCloseable | CXTPCommandBar | protected
m_bCollapsed | CXTPPopupBar | protected
m_bComboBar | CXTPCommandBar |
m_bContextMenu | CXTPPopupBar | protected
m_bCustomizable | CXTPCommandBar | protected
m_bCustomizeDialogPresent | CXTPCommandBar | protected
m_bDoubleGripper | CXTPPopupBar | protected
m_bDynamicLayout | CXTPPopupBar | protected
m_bExecOnRButton | CXTPCommandBar | protected
m_bExpanded | CXTPPopupBar | protected
m_bExpanding | CXTPPopupBar | protected
m_bGrabFocus | CXTPCommandBar | protected
m_bIgnoreUpdateHandler | CXTPCommandBar | protected
m_bKeyboardSelect | CXTPCommandBar | protected
m_bMultiLine | CXTPCommandBar | protected
m_bRecursePopup | CXTPCommandBar | protected
m_bResizable | CXTPPopupBar | protected
m_bShowShadow | CXTPPopupBar | protected
m_bTearOffPopup | CXTPPopupBar | protected
m_bTearOffSelected | CXTPPopupBar | protected
m_bTearOffTracking | CXTPPopupBar | protected
m_bTextBelow | CXTPCommandBar | protected
m_bTracking | CXTPCommandBar | protected
m_bTrackOnHover | CXTPCommandBar |
m_buttonStyle | CXTPCommandBar | protected
m_bVerticalMarker | CXTPCommandBar | protected
m_dMaxWidthDivisor | CXTPPopupBar | static
m_dwData | CXTPCommandBar | protected
m_dwFlags | CXTPCommandBar | protected
m_dwStyle | CXTPCommandBar | protected
m_dwStyleListBox | CXTPControlFontComboBoxList | protected
m_hwndFocus | CXTPCommandBar | protected
m_nBarID | CXTPCommandBar | protected
m_nIdleFlags | CXTPCommandBar | protected
m_nLockRedraw | CXTPCommandBar | protected
m_nMaxHeight | CXTPPopupBar | protected
m_nMRUWidth | CXTPCommandBar | protected
m_nPopuped | CXTPCommandBar | protected
m_nSelected | CXTPCommandBar | protected
m_nStateFlags | CXTPCommandBar |
m_nTearOffID | CXTPPopupBar | protected
m_nTearOffTimer | CXTPPopupBar | protected
m_nTearOffWidth | CXTPPopupBar | protected
m_nTextOrientation | CXTPCommandBar | protected
m_pAnimation | CXTPCommandBar | protected
m_pCommandBars | CXTPCommandBar | protected
m_pControlPopup | CXTPPopupBar | protected
m_pControls | CXTPCommandBar | protected
m_pImageManager | CXTPCommandBar | protected
m_popupFlags | CXTPPopupBar | protected
m_pOwner | CXTPCommandBar | protected
m_pPaintManager | CXTPCommandBar | protected
m_pReturnCmd | CXTPCommandBar | protected
m_pSite | CXTPCommandBar | protected
m_pTearOffBar | CXTPPopupBar | protected
m_pToolTipContext | CXTPCommandBar | protected
m_ptPopup | CXTPPopupBar | protected
m_rcBorders | CXTPPopupBar | protected
m_rcExclude | CXTPPopupBar | protected
m_rcMarker | CXTPCommandBar | protected
m_rcResizeGripper | CXTPPopupBar | protected
m_rcTearOffGripper | CXTPPopupBar | protected
m_strTearOffCaption | CXTPPopupBar | protected
m_strTitle | CXTPCommandBar | protected
m_szButtons | CXTPCommandBar | protected
m_szButtonSpacing | CXTPCommandBar | protected
m_szIcons | CXTPCommandBar | protected
m_szTearOffBar | CXTPPopupBar | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPControlComboBoxList | protectedvirtual
OnControlsChanged() | CXTPPopupBar | protectedvirtual
OnControlSelected(BOOL bSelected, CXTPControl *pControl) | CXTPCommandBar | virtual
OnCustomizeDragEnter(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDragLeave() | CXTPCommandBar | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point) | CXTPCommandBar | virtual
OnCustomizeDrop(CXTPControl *pDataObject, DROPEFFECT &dropEffect, CPoint ptDrop, CPoint ptDrag) | CXTPCommandBar | virtual
OnHookAttached(HWND hWnd) | CXTPHookManagerHookAble | virtual
OnHookDetached() | CXTPHookManagerHookAble | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlComboBoxList | protectedvirtual
OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPControlComboBoxList | protectedvirtual
OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip) | CXTPCommandBar | virtual
OnKeyboardTipChar(UINT chAccel) | CXTPCommandBar |
OnMouseHitTest(CPoint pt) | CXTPCommandBar | protectedvirtual
OnPostHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult) | CXTPHookManagerHookAble | virtual
OnRecalcLayout() | CXTPPopupBar | protectedvirtual
OnRemoved() | CXTPCommandBar | protectedvirtual
OnTrackEnter() | CXTPCommandBar | virtual
OnTrackLost() | CXTPCommandBar | virtual
Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE) | CXTPControlComboBoxList | protectedvirtual
CXTPControlComboBoxPopupBar::Popup(int xPos, int yPos, LPCRECT rcExclude) | CXTPPopupBar |
ProcessHookKeyDown(CXTPControlComboBox *pComboBox, UINT nChar, LPARAM lParam) | CXTPControlComboBoxList | protected
ProcessSpecialKey(XTPSpecialKey key) | CXTPCommandBar | protectedvirtual
PumpMessage() | CXTPPopupBar |
Redraw(LPCRECT lpRect=0, BOOL bAnimate=TRUE) | CXTPCommandBar | virtual
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPCommandBar | protectedvirtual
s_nExpandDelay | CXTPCommandBar | static
s_nExpandHoverDelay | CXTPCommandBar | static
s_nHoverDelay | CXTPCommandBar | static
SetBarID(UINT nID) | CXTPCommandBar |
SetBorders(CRect rcBorders) | CXTPPopupBar |
SetButtons(UINT *pButtons, int nCount) | CXTPCommandBar |
SetButtonSize(CSize size) | CXTPCommandBar |
SetCommandBarData(DWORD_PTR dwData) | CXTPCommandBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBar |
SetControls(CXTPControls *pControls) | CXTPCommandBar |
SetDefaultButtonStyle(XTPButtonStyle buttonStyle) | CXTPCommandBar |
SetDefaultItem(UINT uItem, BOOL fByPos=FALSE) | CXTPPopupBar |
SetDoubleGripper(BOOL bDoubleGripper=TRUE) | CXTPPopupBar |
SetFlags(DWORD dwFlagsAdd, DWORD dwFlagsRemove=0) | CXTPCommandBar |
SetGrabFocus(BOOL bGrabFocus) | CXTPCommandBar |
SetIconSize(CSize size) | CXTPCommandBar |
SetImageManager(CXTPImageManager *pImageManager) | CXTPCommandBar |
SetPaintManager(CXTPPaintManager *pPaintManager) | CXTPCommandBar |
SetPopuped(int nPopuped, BOOL bKeyboard=FALSE) | CXTPCommandBar |
SetPopupFlags(DWORD dwPopupFlags) | CXTPPopupBar |
SetPopupToolBar(BOOL bToolBarType) | CXTPPopupBar |
SetPosition(XTPBarPosition barPosition) | CXTPCommandBar | virtual
SetSelected(int nSelected, BOOL bKeyboard=FALSE) | CXTPPopupBar | protectedvirtual
SetShowGripper(BOOL bShow) | CXTPCommandBar |
SetStatusText(const CString &strDescription) | CXTPCommandBar |
SetTearOffPopup(LPCTSTR lpszCaption, UINT nID, int nWidth=400) | CXTPPopupBar |
SetTextOrientation(XTPBarTextOrientation nTextOrientation) | CXTPCommandBar |
SetTitle(LPCTSTR lpszTitle) | CXTPCommandBar |
SetTrackFocus(HWND hwnd) | CXTPCommandBar |
SetTrackingMode(int bMode, BOOL bSelectFirst, BOOL bKeyboard=FALSE) | CXTPControlComboBoxList | protectedvirtual
SetVisible(BOOL bVisible) | CXTPCommandBar | virtual
SetWidth(int nWidth) | CXTPCommandBar |
ShowTextBelowIcons(BOOL bTextBelow=TRUE) | CXTPCommandBar |
UnlockMouseMove() | CXTPCommandBar |
UnlockRedraw() | CXTPCommandBar |
UpdateExpandingState() | CXTPPopupBar | protected
UpdateFlags() | CXTPPopupBar | protectedvirtual
UpdateLocation(CSize sz) | CXTPPopupBar | protected
UpdateShortcuts() | CXTPCommandBar | protectedvirtual
~CXTPCommandBar() | CXTPCommandBar | protectedvirtual
~CXTPHookManagerHookAble() | CXTPHookManagerHookAble | virtual
~CXTPPopupBar() | CXTPPopupBar | protectedvirtual


CXTPTextPreviewProvider Member List

This is the complete list of members for CXTPTextPreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: XTPChartScaleTypeMap.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartScaleTypeMap.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSCALETYPEMAP_H__)
24# define __XTPCHARTSCALETYPEMAP_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartSeries;
35class CXTPChartSeriesPoint;
36class CXTPChartAxisView;
37class CXTPChartNumberFormat;
38
44class _XTP_EXT_CLASS CXTPChartScaleTypeMap : public CXTPChartElement
45{
46public:
53 CXTPChartScaleTypeMap(CXTPChartAxis* pAxis);
54
59 virtual ~CXTPChartScaleTypeMap();
60
61public:
69 CXTPChartAxis* GetAxis() const;
70
78 virtual void UpdateSeries(CXTPChartAxisView* pAxisView);
79
87 virtual void UpdateSeries(CXTPChartSeries* pSeries);
88
96 virtual void UpdateSeriesPointArgument(CXTPChartSeriesPoint* pPoint);
97
106 virtual CXTPChartString InternalToValue(CXTPChartNumberFormat* pFromat,
107 double dValue) const = 0;
108
115 virtual double ValueToInternal(const CXTPChartString& strValue) const = 0;
116
117public:
128 static CXTPChartScaleTypeMap* AFX_CDECL Create(CXTPChartAxis* pAxis);
129
130protected:
131};
132
138class _XTP_EXT_CLASS CXTPChartNumericalScaleTypeMap : public CXTPChartScaleTypeMap
139{
140public:
147 CXTPChartNumericalScaleTypeMap(CXTPChartAxis* pAxis);
148
149public:
158 virtual CXTPChartString InternalToValue(CXTPChartNumberFormat* pFromat, double dValue) const;
159
166 virtual double ValueToInternal(const CXTPChartString& strValue) const;
167
168protected:
169 void UpdateSeriesPointArgument(CXTPChartSeriesPoint* pPoint);
170
171protected:
172 double m_dMinValue;
173 double m_dMaxValue;
174};
175
176class _XTP_EXT_CLASS CXTPChartTime
177{
178 enum
179 {
180 Seconds = 1000,
181 Minutes = Seconds * 60,
182 Hours = Minutes * 60
183 };
184
185public:
186 CXTPChartTime(double dTime);
187
188 CXTPChartTime(int nHours, int nMinutes, int nSeconds, int nMilliseconds);
189
190 int GetHours() const;
191
192 int GetMinutes() const;
193
194 int GetSeconds() const;
195
196 int GetMilliseconds() const;
197
198 double m_dTime;
199};
200
206class _XTP_EXT_CLASS CXTPChartDateTimeScaleTypeMap : public CXTPChartScaleTypeMap
207{
208public:
209 CXTPChartDateTimeScaleTypeMap(CXTPChartAxis* pAxis);
210
211public:
220 virtual CXTPChartString InternalToValue(CXTPChartNumberFormat* pFromat, double dValue) const;
221
228 virtual double ValueToInternal(const CXTPChartString& strValue) const;
229
230protected:
237 void UpdateSeriesPointArgument(CXTPChartSeriesPoint* pPoint);
238
239private:
240 double DateToInternal(DATE dValue) const;
241 DATE DoubleToDate(double dValue) const;
242};
243
249class _XTP_EXT_CLASS CXTPChartTimeScaleTypeMap : public CXTPChartScaleTypeMap
250{
251public:
252 CXTPChartTimeScaleTypeMap(CXTPChartAxis* pAxis);
253
254public:
263 virtual CXTPChartString InternalToValue(CXTPChartNumberFormat* pFromat, double dValue) const;
264
271 virtual double ValueToInternal(const CXTPChartString& strValue) const;
272
273protected:
280 void UpdateSeriesPointArgument(CXTPChartSeriesPoint* pPoint);
281
282private:
283 double DateToInternal(DATE dValue) const;
284 DATE DoubleToDate(double dValue) const;
285};
286
292class _XTP_EXT_CLASS CXTPChartStrings : public CArray<CXTPChartString, const CXTPChartString&>
293{
294public:
303 int IndexOf(const CXTPChartString& strValue) const;
304};
305
311class _XTP_EXT_CLASS CXTPChartQualitativeScaleTypeMap : public CXTPChartScaleTypeMap
312{
313public:
320 CXTPChartQualitativeScaleTypeMap(CXTPChartAxis* pAxis);
325 virtual ~CXTPChartQualitativeScaleTypeMap();
326
327public:
336 virtual CXTPChartString InternalToValue(CXTPChartNumberFormat* pFromat, double dValue) const;
337
344 virtual double ValueToInternal(const CXTPChartString& strValue) const;
345
346 using CXTPChartScaleTypeMap::UpdateSeries;
347
348protected:
356 void UpdateSeries(CXTPChartSeries* pSeries);
357
364 void UpdateSeriesPointArgument(CXTPChartSeriesPoint* pPoint);
365
366 int FillNextsList(CXTPChartSeries* pSeries, int i, CXTPChartStrings& nexts,
367 const CXTPChartString& argument_i);
368
369protected:
370 double m_dMinValue;
371 double m_dMaxValue;
373protected:
374 class CStorage;
375 CStorage* m_pStorage;
376};
377
378AFX_INLINE CXTPChartAxis* CXTPChartScaleTypeMap::GetAxis() const
379{
380 return (CXTPChartAxis*)m_pOwner;
381}
383# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
384#endif //#if !defined(__XTPCHARTSCALETYPEMAP_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartDateTimeScaleTypeMap
This class is a kind of CXTPChartScaleTypeMap, which abstracts a date-time scale type for an axis.
Definition XTPChartScaleTypeMap.h:207
CXTPChartDateTimeScaleTypeMap::ValueToInternal
virtual double ValueToInternal(const CXTPChartString &strValue) const
Use this function to convert a value string to to an internal type.
CXTPChartDateTimeScaleTypeMap::UpdateSeriesPointArgument
void UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint)
Call this function to update a point argument in a series point.
CXTPChartDateTimeScaleTypeMap::InternalToValue
virtual CXTPChartString InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartNumberFormat
This class helper is used to format number to string.
Definition XTPChartNumberFormat.h:72
CXTPChartNumericalScaleTypeMap
This class is a kind of CXTPChartScaleTypeMap, which abstracts a numeric scale type for an axis.
Definition XTPChartScaleTypeMap.h:139
CXTPChartNumericalScaleTypeMap::ValueToInternal
virtual double ValueToInternal(const CXTPChartString &strValue) const
Use this function to convert a value string to an internal type.
CXTPChartNumericalScaleTypeMap::CXTPChartNumericalScaleTypeMap
CXTPChartNumericalScaleTypeMap(CXTPChartAxis *pAxis)
Constructs a CXTPChartNumericalScaleTypeMap object.
CXTPChartNumericalScaleTypeMap::m_dMinValue
double m_dMinValue
The minimum value.
Definition XTPChartScaleTypeMap.h:172
CXTPChartNumericalScaleTypeMap::UpdateSeriesPointArgument
void UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint)
Call this function when there is a change in the values of the series or a change in the scale.
CXTPChartNumericalScaleTypeMap::InternalToValue
virtual CXTPChartString InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.
CXTPChartNumericalScaleTypeMap::m_dMaxValue
double m_dMaxValue
The maximum value.
Definition XTPChartScaleTypeMap.h:173
CXTPChartQualitativeScaleTypeMap
This class abstracts a scale type map, which represents qualitative values.
Definition XTPChartScaleTypeMap.h:312
CXTPChartQualitativeScaleTypeMap::ValueToInternal
virtual double ValueToInternal(const CXTPChartString &strValue) const
Use this function to convert a value string to an internal type.
CXTPChartQualitativeScaleTypeMap::m_pStorage
CStorage * m_pStorage
The storage.
Definition XTPChartScaleTypeMap.h:375
CXTPChartQualitativeScaleTypeMap::m_dMinValue
double m_dMinValue
The minimum value.
Definition XTPChartScaleTypeMap.h:370
CXTPChartQualitativeScaleTypeMap::CXTPChartQualitativeScaleTypeMap
CXTPChartQualitativeScaleTypeMap(CXTPChartAxis *pAxis)
Constructs a CXTPChartQualitativeScaleTypeMap object.
CXTPChartQualitativeScaleTypeMap::UpdateSeriesPointArgument
void UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint)
Call this function to update a point argument in a series point.
CXTPChartQualitativeScaleTypeMap::~CXTPChartQualitativeScaleTypeMap
virtual ~CXTPChartQualitativeScaleTypeMap()
Destroys a CXTPChartQualitativeScaleTypeMap object, handles cleanup.
CXTPChartQualitativeScaleTypeMap::InternalToValue
virtual CXTPChartString InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.
CXTPChartQualitativeScaleTypeMap::m_dMaxValue
double m_dMaxValue
The maximum value.
Definition XTPChartScaleTypeMap.h:371
CXTPChartQualitativeScaleTypeMap::UpdateSeries
void UpdateSeries(CXTPChartSeries *pSeries)
Call this function when there is a change in the values of the series or a change in the scale.
CXTPChartScaleTypeMap
This class abstracts a scale type map.
Definition XTPChartScaleTypeMap.h:45
CXTPChartScaleTypeMap::GetAxis
CXTPChartAxis * GetAxis() const
Call this function to get the axis object to which this object is associated with.
Definition XTPChartScaleTypeMap.h:378
CXTPChartScaleTypeMap::UpdateSeries
virtual void UpdateSeries(CXTPChartAxisView *pAxisView)
Call this function when there is a change in the values of the series or a change in the scale.
CXTPChartScaleTypeMap::UpdateSeriesPointArgument
virtual void UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint)
Call this function when there is a change in the values of the series or a change in the scale.
CXTPChartScaleTypeMap::InternalToValue
virtual CXTPChartString InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const =0
Use this function to convert a double value to a string.
CXTPChartScaleTypeMap::Create
static CXTPChartScaleTypeMap *AFX_CDECL Create(CXTPChartAxis *pAxis)
Call this function to create a scale type map object.
CXTPChartScaleTypeMap::~CXTPChartScaleTypeMap
virtual ~CXTPChartScaleTypeMap()
Destroys a CXTPChartScaleTypeMap object, handles cleanup.
CXTPChartScaleTypeMap::CXTPChartScaleTypeMap
CXTPChartScaleTypeMap(CXTPChartAxis *pAxis)
Constructs a CXTPChartScaleTypeMap object.
CXTPChartScaleTypeMap::UpdateSeries
virtual void UpdateSeries(CXTPChartSeries *pSeries)
Call this function when there is a change in the values of the series or a change in the scale.
CXTPChartScaleTypeMap::ValueToInternal
virtual double ValueToInternal(const CXTPChartString &strValue) const =0
Use this function to convert a value string to an internal type.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartStrings
This class is a collection class of strings.
Definition XTPChartScaleTypeMap.h:293
CXTPChartStrings::IndexOf
int IndexOf(const CXTPChartString &strValue) const
Use this function to get the zero-based index of an arbitrary string in the collection.
CXTPChartTimeScaleTypeMap
This class is a kind of CXTPChartScaleTypeMap, which abstracts a time scale type for an axis.
Definition XTPChartScaleTypeMap.h:250
CXTPChartTimeScaleTypeMap::ValueToInternal
virtual double ValueToInternal(const CXTPChartString &strValue) const
Use this function to convert a value string to to an internal type.
CXTPChartTimeScaleTypeMap::UpdateSeriesPointArgument
void UpdateSeriesPointArgument(CXTPChartSeriesPoint *pPoint)
Call this function to update a point argument in a series point.
CXTPChartTimeScaleTypeMap::InternalToValue
virtual CXTPChartString InternalToValue(CXTPChartNumberFormat *pFromat, double dValue) const
Use this function to convert a double value to a string.


Toolkit Pro: XTPRibbonBackstageSeparatorThemeVisualStudio2015.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeVisualStudio2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2015_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeVisualStudio2015
36 : public CXTPRibbonBackstageSeparatorThemeOffice2013
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeVisualStudio2015();
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEVISUALSTUDIO2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPTabManagerItem.h Source File

  • Source
  • TabManager
XTPTabManagerItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABMANAGERITEM_H__)
24# define __XTPTABMANAGERITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPImageManagerIcon;
35class CXTPTabManagerNavigateButtons;
36class CXTPTabManager;
37
43class _XTP_EXT_CLASS CXTPTabManagerItem : public CXTPCmdTarget
44{
46 DECLARE_DYNAMIC(CXTPTabManagerItem)
49protected:
54 CXTPTabManagerItem();
55
60 virtual ~CXTPTabManagerItem();
61
62public:
72 void SetCaption(LPCTSTR lpszCaption);
73
84 virtual CString GetCaption() const;
85
96 void SetTooltip(LPCTSTR lpszTooltip);
97
109 CString GetTooltip() const;
110
119 COLORREF GetColor();
120
130 void SetColor(COLORREF clr);
131
140 CRect GetRect() const;
141
153 int GetButtonLength() const;
154
166 int GetContentLength() const;
167
176 int GetIndex() const;
177
192 int GetImageIndex() const;
193
207 void SetImageIndex(int nImage);
208
226 DWORD_PTR GetData() const;
227
242 void SetData(DWORD_PTR dwData);
243
252 void SetHandle(HWND hWnd);
253
264 HWND GetHandle() const;
265
273 void SetRect(CRect rcItem);
274
285 BOOL IsVisible() const;
286
294 virtual void SetVisible(BOOL bVisible);
295
304 BOOL IsEnabled() const;
305
316 void SetEnabled(BOOL bEnabled);
317
324 int GetItemRow() const;
325
332 BOOL IsItemShrinked() const;
333
342 CXTPTabManagerNavigateButtons* GetNavigateButtons();
343
344public:
352 BOOL IsSelected() const;
353
360 BOOL IsFocused() const;
361
374 BOOL IsHighlighted() const;
375
384 BOOL IsPressed() const;
385
390 void Remove();
391
400 void Select();
401
407 void Move(int nIndex);
408
415 BOOL IsClosable() const;
416
423 void SetClosable(BOOL bClosable);
424
431 CXTPMarkupUIElement* GetMarkupUIElement() const;
432
439 BOOL IsNewWindowTab();
440
445 void SetNewWindowTab();
446
447public:
456 CXTPTabManager* GetTabManager() const;
457
467 void DrawImage(CDC* pDC, CRect rcIcon, CXTPImageManagerIcon* pImage);
468
469protected:
474 void Reposition();
475
481 virtual void OnRemoved();
482
483private:
484 BOOL DrawRotatedImage(CDC* pDC, CRect rcItem, CXTPImageManagerIcon* pImage);
485
486protected:
487 int m_nButtonLength;
488 int m_nContentLength;
489 int m_nImage;
491 int m_nIndex;
492 BOOL m_bEnabled;
493 BOOL m_bVisible;
494 HWND m_hWnd;
495 HICON m_hIcon;
496 DWORD_PTR m_dwData;
497 CRect m_rcItem;
498 CString m_strCaption;
499 CString m_strToolTip;
500 COLORREF m_clrItem;
501 CXTPTabManager* m_pTabManager;
502 int m_nItemRow;
503 BOOL m_bClosable;
504 BOOL m_bNewWindowTab;
506 CXTPTabManagerNavigateButtons m_arrNavigateButtons;
507 CXTPMarkupUIElement* m_pMarkupUIElement;
509private:
510 BOOL m_bFound;
511
512 friend class CXTPTabManager;
513 friend class CXTPTabPaintManager;
514 friend class CXTPTabWorkspace;
515 friend class CXTPTabClientWnd;
516 friend class CXTPGroupClientWnd;
517
518# ifdef _XTP_ACTIVEX
520 afx_msg BSTR OleGetCaption();
521 afx_msg void OleSetCaption(LPCTSTR lpszNewValue);
522 afx_msg long OleGetIndex();
523 afx_msg long OleGetTag();
524 afx_msg void OleSetTag(long nNewValue);
525 afx_msg BOOL OleGetSelected();
526 afx_msg void OleSetSelected(BOOL bNewValue);
527 afx_msg long OleGetImage();
528 afx_msg void OleSetImage(long nNewValue);
529 afx_msg void OleSetHandle(long hWnd);
530 afx_msg void OleSetVisible(BOOL bVisible);
531 afx_msg void OleGetRect(long* Left, long* Top, long* Right, long* Botton);
532 afx_msg void OleEnsureVisible();
533 DECLARE_DISPATCH_MAP();
534 DECLARE_INTERFACE_MAP()
535
536 DECLARE_OLETYPELIB_EX(CXTPTabManagerItem)
537 COleVariant m_oleTag;
539# endif
540};
541
543// CXTPTabManagerItem
544
545AFX_INLINE CXTPTabManager* CXTPTabManagerItem::GetTabManager() const
546{
547 return m_pTabManager;
548}
549AFX_INLINE CRect CXTPTabManagerItem::GetRect() const
550{
551 return m_rcItem;
552}
553AFX_INLINE int CXTPTabManagerItem::GetIndex() const
554{
555 return m_nIndex;
556}
557AFX_INLINE DWORD_PTR CXTPTabManagerItem::GetData() const
558{
559 return m_dwData;
560}
561AFX_INLINE void CXTPTabManagerItem::SetData(DWORD_PTR dwData)
562{
563 m_dwData = dwData;
564}
565AFX_INLINE int CXTPTabManagerItem::GetImageIndex() const
566{
567 return m_nImage;
568}
569AFX_INLINE BOOL CXTPTabManagerItem::IsClosable() const
570{
571 return m_bClosable;
572}
573AFX_INLINE int CXTPTabManagerItem::GetButtonLength() const
574{
575 return m_nButtonLength;
576}
577AFX_INLINE int CXTPTabManagerItem::GetContentLength() const
578{
579 return m_nContentLength;
580}
581AFX_INLINE void CXTPTabManagerItem::SetTooltip(LPCTSTR lpszTooltip)
582{
583 m_strToolTip = lpszTooltip;
584}
585AFX_INLINE int CXTPTabManagerItem::GetItemRow() const
586{
587 return m_nItemRow;
588}
589AFX_INLINE BOOL CXTPTabManagerItem::IsItemShrinked() const
590{
591 return m_nButtonLength < m_nContentLength;
592}
593AFX_INLINE CXTPTabManagerNavigateButtons* CXTPTabManagerItem::GetNavigateButtons()
594{
595 return &m_arrNavigateButtons;
596}
597AFX_INLINE void CXTPTabManagerItem::SetNewWindowTab()
598{
599 m_bNewWindowTab = TRUE;
600}
601AFX_INLINE BOOL CXTPTabManagerItem::IsNewWindowTab()
602{
603 return m_bNewWindowTab;
604}
605
606# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
608#endif // !defined(__XTPTABMANAGERITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerItem::IsVisible
BOOL IsVisible() const
Determines if this tab is shown/hidden.
CXTPTabManagerItem::SetNewWindowTab
void SetNewWindowTab()
Specifies if this tab is new window.
Definition XTPTabManagerItem.h:597
CXTPTabManagerItem::Remove
void Remove()
Deletes this tab.
CXTPTabManagerItem::IsHighlighted
BOOL IsHighlighted() const
Determines the highlighted state of this tab.
CXTPTabManagerItem::IsSelected
BOOL IsSelected() const
Determines the selected state of this tab (i.e.
CXTPTabManagerItem::m_strToolTip
CString m_strToolTip
Tooltip text for this tab.
Definition XTPTabManagerItem.h:499
CXTPTabManagerItem::IsItemShrinked
BOOL IsItemShrinked() const
Determines if this item has shrinked.
Definition XTPTabManagerItem.h:589
CXTPTabManagerItem::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip for this tab.
Definition XTPTabManagerItem.h:581
CXTPTabManagerItem::GetIndex
int GetIndex() const
Gets the index of this tab within the collection of tabs.
Definition XTPTabManagerItem.h:553
CXTPTabManagerItem::m_nButtonLength
int m_nButtonLength
Width of the tab button.
Definition XTPTabManagerItem.h:487
CXTPTabManagerItem::OnRemoved
virtual void OnRemoved()
This method is called when an item is removed from the tab manager collection.
CXTPTabManagerItem::m_nItemRow
int m_nItemRow
Row of this item.
Definition XTPTabManagerItem.h:502
CXTPTabManagerItem::GetData
DWORD_PTR GetData() const
Gets the application-supplied, 32-bit value associated with the tab item.
Definition XTPTabManagerItem.h:557
CXTPTabManagerItem::GetContentLength
int GetContentLength() const
Gets the width of the content of the tab button.
Definition XTPTabManagerItem.h:577
CXTPTabManagerItem::m_hWnd
HWND m_hWnd
CWnd pointer to the window associated with this tab.
Definition XTPTabManagerItem.h:494
CXTPTabManagerItem::GetColor
COLORREF GetColor()
Gets the color of the tab button.
CXTPTabManagerItem::m_nImage
int m_nImage
Image index; this is the index of the image within a CXTPImageManger or CImageList object.
Definition XTPTabManagerItem.h:489
CXTPTabManagerItem::IsNewWindowTab
BOOL IsNewWindowTab()
Determines if this tab is new window.
Definition XTPTabManagerItem.h:601
CXTPTabManagerItem::m_bNewWindowTab
BOOL m_bNewWindowTab
TRUE if this item is new window tab.
Definition XTPTabManagerItem.h:504
CXTPTabManagerItem::SetVisible
virtual void SetVisible(BOOL bVisible)
Shows/hides this tab.
CXTPTabManagerItem::m_nIndex
int m_nIndex
Index of this tab within the collection of tabs.
Definition XTPTabManagerItem.h:491
CXTPTabManagerItem::Reposition
void Reposition()
Updates the position of the tab manager.
CXTPTabManagerItem::m_nContentLength
int m_nContentLength
Width of the content of the tab button.
Definition XTPTabManagerItem.h:488
CXTPTabManagerItem::IsClosable
BOOL IsClosable() const
Determines if this tab is closable.
Definition XTPTabManagerItem.h:569
CXTPTabManagerItem::GetCaption
virtual CString GetCaption() const
Gets the text caption of this tab.
CXTPTabManagerItem::GetItemRow
int GetItemRow() const
Gets the row of this item.
Definition XTPTabManagerItem.h:585
CXTPTabManagerItem::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the text caption for this tab.
CXTPTabManagerItem::IsPressed
BOOL IsPressed() const
Determines the pressed state of this tab.
CXTPTabManagerItem::SetEnabled
void SetEnabled(BOOL bEnabled)
Enables/disables this tab.
CXTPTabManagerItem::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup element pointer.
Definition XTPTabManagerItem.h:507
CXTPTabManagerItem::DrawImage
void DrawImage(CDC *pDC, CRect rcIcon, CXTPImageManagerIcon *pImage)
Draws the icon of a tab.
CXTPTabManagerItem::m_pTabManager
CXTPTabManager * m_pTabManager
Pointer to the parent item.
Definition XTPTabManagerItem.h:501
CXTPTabManagerItem::GetHandle
HWND GetHandle() const
Gets the handle of the object displayed in the tab client area when this tab is selected.
CXTPTabManagerItem::SetColor
void SetColor(COLORREF clr)
Sets the color for the tab button.
CXTPTabManagerItem::m_rcItem
CRect m_rcItem
Rectangle of this tab.
Definition XTPTabManagerItem.h:497
CXTPTabManagerItem::GetImageIndex
int GetImageIndex() const
Gets the index of the image displayed in the tab button.
Definition XTPTabManagerItem.h:565
CXTPTabManagerItem::GetTabManager
CXTPTabManager * GetTabManager() const
Gets the tab manager.
Definition XTPTabManagerItem.h:545
CXTPTabManagerItem::SetData
void SetData(DWORD_PTR dwData)
Sets the 32-bit value associated with the tab item.
Definition XTPTabManagerItem.h:561
CXTPTabManagerItem::m_hIcon
HICON m_hIcon
Icon associated with this tab.
Definition XTPTabManagerItem.h:495
CXTPTabManagerItem::SetRect
void SetRect(CRect rcItem)
Sets the bounding rectangle for this tab.
CXTPTabManagerItem::Select
void Select()
Selects this tab.
CXTPTabManagerItem::SetImageIndex
void SetImageIndex(int nImage)
Sets the index for the image displayed in the tab button.
CXTPTabManagerItem::m_bVisible
BOOL m_bVisible
TRUE if this tab is visible.
Definition XTPTabManagerItem.h:493
CXTPTabManagerItem::CXTPTabManagerItem
CXTPTabManagerItem()
Constructs a CXTPTabManagerItem object.
CXTPTabManagerItem::SetClosable
void SetClosable(BOOL bClosable)
Specifies if this tab should be closable.
CXTPTabManagerItem::GetNavigateButtons
CXTPTabManagerNavigateButtons * GetNavigateButtons()
Gets the collection of navigate buttons.
Definition XTPTabManagerItem.h:593
CXTPTabManagerItem::m_dwData
DWORD_PTR m_dwData
Developer specific data.
Definition XTPTabManagerItem.h:496
CXTPTabManagerItem::SetHandle
void SetHandle(HWND hWnd)
Sets the handle for the object displayed in the tab client area when this tab is selected.
CXTPTabManagerItem::GetRect
CRect GetRect() const
Gets the bounding rectangle of the tab button.
Definition XTPTabManagerItem.h:549
CXTPTabManagerItem::m_arrNavigateButtons
CXTPTabManagerNavigateButtons m_arrNavigateButtons
Array of navigate buttons.
Definition XTPTabManagerItem.h:506
CXTPTabManagerItem::m_clrItem
COLORREF m_clrItem
Color of the tab button.
Definition XTPTabManagerItem.h:500
CXTPTabManagerItem::m_bClosable
BOOL m_bClosable
TRUE if this item can be closed.
Definition XTPTabManagerItem.h:503
CXTPTabManagerItem::GetTooltip
CString GetTooltip() const
Gets the tooltip of this tab.
CXTPTabManagerItem::IsEnabled
BOOL IsEnabled() const
Determines if this tab is enabled/disabled.
CXTPTabManagerItem::m_bEnabled
BOOL m_bEnabled
TRUE if this tab is enabled.
Definition XTPTabManagerItem.h:492
CXTPTabManagerItem::~CXTPTabManagerItem
virtual ~CXTPTabManagerItem()
Destroys a CXTPTabManagerItem object, handles cleanup and deallocation.
CXTPTabManagerItem::Move
void Move(int nIndex)
Sets the position for this item.
CXTPTabManagerItem::m_strCaption
CString m_strCaption
User specified label for this tab.
Definition XTPTabManagerItem.h:498
CXTPTabManagerItem::GetButtonLength
int GetButtonLength() const
Gets the width of the tab button.
Definition XTPTabManagerItem.h:573
CXTPTabManagerNavigateButtons
CXTPTabManagerNavigateButtons is a class used to represent a collection of tab navigation buttons.
Definition XTPTabManagerNavigateButtons.h:39
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48


CXTPFlowGraphUndoSetNodeSizeCommand Member List

This is the complete list of members for CXTPFlowGraphUndoSetNodeSizeCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoSetNodeSizeCommand(CXTPFlowGraphNode *pNode, CSize szOldSize) | CXTPFlowGraphUndoSetNodeSizeCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pNode | CXTPFlowGraphUndoSetNodeSizeCommand | protected
m_szOldSize | CXTPFlowGraphUndoSetNodeSizeCommand | protected
Undo() | CXTPFlowGraphUndoSetNodeSizeCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoSetNodeSizeCommand() | CXTPFlowGraphUndoSetNodeSizeCommand | virtual


Toolkit Pro: XTPSkinImage.h Source File

  • Source
  • SkinFramework
XTPSkinImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINIMAGE_H__)
24# define __XTPSKINIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSkinManagerResourceFile;
34
40class _XTP_EXT_CLASS CXTPSkinImage : public CXTPSynchronized
41{
42private:
43 struct SOLIDRECT
44 {
45 RECT rc;
46 COLORREF clr;
47 };
48
49public:
54 CXTPSkinImage();
55
60 virtual ~CXTPSkinImage();
61
62public:
70 BOOL LoadFile(LPCTSTR lpszFileName);
79 BOOL LoadFile(HMODULE hModule, LPCTSTR lpszBitmapFileName);
80
87 void SetBitmap(HBITMAP hBitmap, BOOL bAlpha = FALSE);
88
99 void DrawImage(CDC* pDC, const CRect& rcDest, const CRect& rcSrc, const CRect& rcSizingMargins,
100 int nSizingType, BOOL bBorderOnly);
101
113 void DrawImage(CDC* pDC, const CRect& rcDest, const CRect& rcSrc, const CRect& rcSizingMargins,
114 COLORREF clrTransparent, int nSizingType, BOOL bBorderOnly);
115
122 DWORD GetHeight() const;
123
130 DWORD GetWidth() const;
131
138 CSize GetExtent() const;
139
146 BOOL IsAlphaImage() const;
147
156 CRect GetSource(int nState = 0, int nCount = 1) const;
157
165 void CreateSolidRectArray(int nBitmaps, BOOL bHorizontalImage, const CRect& rcSizingMargins);
166
167private:
168 void DrawImageInternal(CDC* pDC, const CRect& rcDest, const CRect& rcSrc,
169 const CRect& rcSizingMargins, int nSizingType, BOOL bBorderOnly,
170 COLORREF clrTransparent = COLORREF_NULL);
171 BOOL DrawImagePart(CDC* pDCDest, const CRect& rcDest, CDC* pDCSrc, const CRect& rcSrc) const;
172
173 BOOL DrawImageTile(CDC* pDCDest, const CRect& rcDest, CDC* pDCSrc, const CRect& rcSrc,
174 BOOL bTile, COLORREF clrTransparent = COLORREF_NULL) const;
175
176 void FilterImage(COLORREF clrTransparent);
177 void InvertBitmap();
178 BOOL FindSolidRect(const CRect& rcSrc, SOLIDRECT& sr) const;
179 CSize _GetExtent() const;
180 BOOL CheckBitmapRect(LPBYTE pBits, CRect rcCheck, CSize sz, SOLIDRECT& sr);
181
182public:
183 BOOL m_bMirrorImage;
185protected:
186 HBITMAP m_hBitmap;
187 BOOL m_bAlpha;
188 BOOL m_bFiltered;
189 BOOL m_bInvert;
190 BOOL m_bOptimized;
191 CSize m_szBitmap;
192 CArray<SOLIDRECT, SOLIDRECT&> m_arrSolidRects;
193};
194
199class _XTP_EXT_CLASS CXTPSkinImages : public CXTPSynchronized
200{
201public:
206 CXTPSkinImages();
207
212 ~CXTPSkinImages();
213
214public:
219 void RemoveAll();
220
230 CXTPSkinImage* LoadFile(CXTPSkinManagerResourceFile* pResourceFile, LPCTSTR lpszImageFile);
231
240 CSize GetExtent(CXTPSkinManagerResourceFile* pResourceFile, LPCTSTR lpszImageFile);
241
242protected:
243 CMapStringToPtr m_mapImages;
244};
245
246# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
248#endif // !defined(__XTPSKINIMAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSkinImage
The CXTPSkinImage class represents a simple bitmap holder and draw operations for Skin Framework.
Definition XTPSkinImage.h:41
CXTPSkinImage::m_bFiltered
BOOL m_bFiltered
TRUE if the image is filtered.
Definition XTPSkinImage.h:188
CXTPSkinImage::LoadFile
BOOL LoadFile(HMODULE hModule, LPCTSTR lpszBitmapFileName)
Loads a specified bitmap from a .dll using its name identifier.
CXTPSkinImage::~CXTPSkinImage
virtual ~CXTPSkinImage()
Destroys a CXTPSkinImage object, handles cleanup and deallocation.
CXTPSkinImage::m_bMirrorImage
BOOL m_bMirrorImage
TRUE to invert image in RTL mode.
Definition XTPSkinImage.h:183
CXTPSkinImage::CXTPSkinImage
CXTPSkinImage()
Constructs a CXTPSkinImage object.
CXTPSkinImage::m_hBitmap
HBITMAP m_hBitmap
Bitmap handle.
Definition XTPSkinImage.h:186
CXTPSkinImage::DrawImage
void DrawImage(CDC *pDC, const CRect &rcDest, const CRect &rcSrc, const CRect &rcSizingMargins, COLORREF clrTransparent, int nSizingType, BOOL bBorderOnly)
Draws the image in a specified location.
CXTPSkinImage::DrawImage
void DrawImage(CDC *pDC, const CRect &rcDest, const CRect &rcSrc, const CRect &rcSizingMargins, int nSizingType, BOOL bBorderOnly)
Draws the image in a specified location.
CXTPSkinImage::GetExtent
CSize GetExtent() const
Gets the extent of the bitmap.
CXTPSkinImage::m_bInvert
BOOL m_bInvert
TRUE if the image is inverted for RTL mode.
Definition XTPSkinImage.h:189
CXTPSkinImage::m_bAlpha
BOOL m_bAlpha
TRUE if the bitmap has alpha pixels.
Definition XTPSkinImage.h:187
CXTPSkinImage::m_szBitmap
CSize m_szBitmap
Bitmap size of the image.
Definition XTPSkinImage.h:191
CXTPSkinImage::m_bOptimized
BOOL m_bOptimized
TRUE if the image is split into solid rectangles.
Definition XTPSkinImage.h:190
CXTPSkinImage::CreateSolidRectArray
void CreateSolidRectArray(int nBitmaps, BOOL bHorizontalImage, const CRect &rcSizingMargins)
Helper method that splits an image into solid rectangles for faster drawing.
CXTPSkinImage::GetSource
CRect GetSource(int nState=0, int nCount=1) const
Calculates the position of a specified image.
CXTPSkinImage::m_arrSolidRects
CArray< SOLIDRECT, SOLIDRECT & > m_arrSolidRects
Solid rectangles of the image.
Definition XTPSkinImage.h:192
CXTPSkinImage::SetBitmap
void SetBitmap(HBITMAP hBitmap, BOOL bAlpha=FALSE)
Assigns a bitmap handle to the CXTPSkinImage class.
CXTPSkinImage::GetHeight
DWORD GetHeight() const
Gets the height of the bitmap.
CXTPSkinImage::IsAlphaImage
BOOL IsAlphaImage() const
Determines if the bitmap has alpha pixels.
CXTPSkinImage::GetWidth
DWORD GetWidth() const
Gets the width of the bitmap.
CXTPSkinImage::LoadFile
BOOL LoadFile(LPCTSTR lpszFileName)
Loads a specified bitmap from a .dll using its name identifier.
CXTPSkinImages
CXTPSkinImages represents a cached collection of CXTPSkinImage classes.
Definition XTPSkinImage.h:200
CXTPSkinImages::~CXTPSkinImages
~CXTPSkinImages()
Destroys a CXTPSkinImages object, handles cleanup and deallocation.
CXTPSkinImages::GetExtent
CSize GetExtent(CXTPSkinManagerResourceFile *pResourceFile, LPCTSTR lpszImageFile)
Gets the extent of a specified image located within a resource file.
CXTPSkinImages::CXTPSkinImages
CXTPSkinImages()
Constructs a CXTPSkinImages object.
CXTPSkinImages::LoadFile
CXTPSkinImage * LoadFile(CXTPSkinManagerResourceFile *pResourceFile, LPCTSTR lpszImageFile)
Loads a specified image from a resource file.
CXTPSkinImages::RemoveAll
void RemoveAll()
Removes all images from the collection.
CXTPSkinImages::m_mapImages
CMapStringToPtr m_mapImages
Collection of images.
Definition XTPSkinImage.h:243
CXTPSkinManagerResourceFile
CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources...
Definition XTPSkinManagerResource.h:45
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602


CXTPFlowGraphUndoDeleteConnectionCommand Member List

This is the complete list of members for CXTPFlowGraphUndoDeleteConnectionCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoDeleteConnectionCommand(CXTPFlowGraphConnection *pConnection) | CXTPFlowGraphUndoDeleteConnectionCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pConnection | CXTPFlowGraphUndoDeleteConnectionCommand | protected
m_pPage | CXTPFlowGraphUndoDeleteConnectionCommand | protected
Undo() | CXTPFlowGraphUndoDeleteConnectionCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoDeleteConnectionCommand() | CXTPFlowGraphUndoDeleteConnectionCommand | virtual


CXTPGlobalAtom Member List

This is the complete list of members for CXTPGlobalAtom, including all inherited members.

CXTPGlobalAtom(LPCTSTR lpAtomName) | CXTPGlobalAtom | explicit
GetAtom() const | CXTPGlobalAtom |
GetAtomString() const | CXTPGlobalAtom |
GetName() const | CXTPGlobalAtom |
~CXTPGlobalAtom() | CXTPGlobalAtom |


CXTPChartColor Member List

This is the complete list of members for CXTPChartColor, including all inherited members.

AlphaMask enum value | CXTPChartColor |
AlphaShift enum value | CXTPChartColor |
Argb | CXTPChartColor | protected
BlueMask enum value | CXTPChartColor |
BlueShift enum value | CXTPChartColor |
ClampA() const | CXTPChartColor | inline
ClampB() const | CXTPChartColor | inline
ClampG() const | CXTPChartColor | inline
ClampR() const | CXTPChartColor | inline
CXTPChartColor() | CXTPChartColor | inline
CXTPChartColor(BYTE r, BYTE g, BYTE b) | CXTPChartColor | inline
CXTPChartColor(BYTE a, BYTE r, BYTE g, BYTE b) | CXTPChartColor | inline
CXTPChartColor(ARGB argb) | CXTPChartColor | inline
GetA() const | CXTPChartColor | inline
GetAlpha() const | CXTPChartColor | inline
GetB() const | CXTPChartColor | inline
GetBlue() const | CXTPChartColor | inline
GetDarkColor() const | CXTPChartColor |
GetG() const | CXTPChartColor | inline
GetGreen() const | CXTPChartColor | inline
GetR() const | CXTPChartColor | inline
GetRed() const | CXTPChartColor | inline
GetValue() const | CXTPChartColor | inline
GreenMask enum value | CXTPChartColor |
GreenShift enum value | CXTPChartColor |
IsEmpty() const | CXTPChartColor | inline
MakeARGB(BYTE a, BYTE r, BYTE g, BYTE b) | CXTPChartColor | inlinestatic
RedMask enum value | CXTPChartColor |
RedShift enum value | CXTPChartColor |
SetFromCOLORREF(COLORREF rgb) | CXTPChartColor | inline
SetFromString(LPCTSTR lpsz) | CXTPChartColor |
SetValue(ARGB argb) | CXTPChartColor | inline
ToCOLORREF() const | CXTPChartColor | inline


  • CXTPControlToolbars
  • CXTPControlToolbar
CXTPControlToolbars::CXTPControlToolbar Member List

This is the complete list of members for CXTPControlToolbars::CXTPControlToolbar, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


Toolkit Pro: XTPMarkupSpan.h Source File

  • Source
  • Markup
  • Text
XTPMarkupSpan.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSPAN_H__)
24# define __XTPMARKUPSPAN_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupInlineCollection;
34class CXTPMarkupInline;
35class CXTPMarkupBuilder;
36class CXTPMarkupObject;
37class CXTPMarkupInlineCollection;
38
39class _XTP_EXT_CLASS CXTPMarkupSpan : public CXTPMarkupInline
40{
42 DECLARE_MARKUPCLASS(CXTPMarkupSpan)
44protected:
45 CXTPMarkupSpan();
46 virtual ~CXTPMarkupSpan();
47
48public:
49 CXTPMarkupInlineCollection* GetInlines() const;
50
51public:
52 virtual CXTPMarkupInline* GetFirstInline() const;
53
54protected:
55 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
56 virtual BOOL HasContentObject() const;
57 virtual BOOL AllowWhiteSpaceContent() const;
58 virtual int GetLogicalChildrenCount() const;
59 virtual CXTPMarkupObject* GetLogicalChild(int nIndex) const;
60
62public:
63 DECLARE_DISPATCH_MAP()
64# ifdef _XTP_ACTIVEX
65 DECLARE_INTERFACE_MAP()
66 DECLARE_OLETYPELIB_EX(CXTPMarkupSpan);
67# endif
68
69 afx_msg LPDISPATCH OleGetInlines();
70
73protected:
74 CXTPMarkupInlineCollection* m_pInlines;
75};
76
77AFX_INLINE int CXTPMarkupSpan::GetLogicalChildrenCount() const
78{
79 return m_pInlines ? 1 : 0;
80}
81
82AFX_INLINE CXTPMarkupObject* CXTPMarkupSpan::GetLogicalChild(int nIndex) const
83{
84 return nIndex == 0 ? (CXTPMarkupObject*)m_pInlines : NULL;
85}
86
87AFX_INLINE CXTPMarkupInlineCollection* CXTPMarkupSpan::GetInlines() const
88{
89 return m_pInlines;
90}
91
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPMARKUPSPAN_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


CXTPDockingPaneTabColorSet2012 Member List

This is the complete list of members for CXTPDockingPaneTabColorSet2012, including all inherited members.

CXTPDockingPaneTabColorSet2012() | CXTPDockingPaneTabColorSet2012 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSet2012 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPCalendarRemindersDialog.h Source File

  • Source
  • Calendar
XTPCalendarRemindersDialog.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_REMINDERS_DIALOG_H__)
23# define _XTP_CALENDAR_REMINDERS_DIALOG_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarRemindersManager;
32class CXTPCalendarControl;
33class CXTPNotifySink;
35
43class _XTP_EXT_CLASS CXTPCalendarRemindersDialog : public CDialog
44{
45 // Construction
46public:
47 enum
48 {
49 IDD = XTP_IDD_CALENDAR_REMINDERS
50 };
51
59 CXTPCalendarRemindersDialog(CWnd* pParent = NULL,
60 UINT nIDTemplate = CXTPCalendarRemindersDialog::IDD);
61
66 virtual ~CXTPCalendarRemindersDialog();
67
76 virtual BOOL Create(CWnd* pParent = NULL);
77
84 virtual void SetRemindersManager(CXTPCalendarControl* pCalendar);
85
91 virtual void UpdateFromManager();
92
98 virtual void Detach();
99
107 virtual BOOL IsShowInTaskBar();
108
116 virtual void SetShowInTaskBar(BOOL bShow = TRUE);
117
125 BOOL IsAutoPopup() const;
126
134 void SetAutoPopup(BOOL bAutoPopup = TRUE);
135
136private:
137 virtual BOOL Create(LPCTSTR lpszTemplateName, CWnd* pParentWnd = NULL)
138 {
139 return CDialog::Create(lpszTemplateName, pParentWnd);
140 }
141 virtual BOOL Create(UINT nIDTemplate, CWnd* pParentWnd = NULL)
142 {
143 return CDialog::Create(nIDTemplate, pParentWnd);
144 }
145 virtual BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
146 const RECT& rect, CWnd* pParentWnd, UINT nID,
147 CCreateContext* pContext = NULL)
148 {
149 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID,
150 pContext);
151 }
152
153protected:
154 CXTPCalendarRemindersManager* m_pRemindersMan;
155 CXTPCalendarReminders m_arActiveReminders;
157 CXTPCalendarControl* m_pCalendar;
159 int m_nNextRefreshIndex;
162 CXTPNotifySink* m_pSink;
163
164 virtual void OnReminders(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
165
166protected:
167 virtual void DoDataExchange(CDataExchange* pDX); // DDX/DDV support
168 virtual BOOL OnInitDialog();
169 virtual void InitSnoozeComboBox();
170
171 virtual void UpdateControlsBySelection();
172 virtual void SelectItem(int nSelItemIndex);
173 virtual void UpdateTitle();
174 virtual BOOL _RemoveReminderInfo(CXTPCalendarReminder* pReminder);
175
176 virtual void OnOK();
177 afx_msg void OnDismiss();
178 afx_msg void OnDismissAll();
179 afx_msg void OnOpenItem();
180 afx_msg void OnSnooze();
181 afx_msg void OnRemindersList_ItemChanged(NMHDR* pNMHDR, LRESULT* pResult);
182 afx_msg void OnRemindersList_DblClick(NMHDR* pNMHDR, LRESULT* pResult);
183
184 afx_msg void OnTimer(UINT_PTR nIDEvent);
186 DECLARE_MESSAGE_MAP()
189protected:
190 CListCtrl m_ctrlRemindersList;
191 CStatic m_ctrlDescription;
193 CComboBox m_ctrlSnoozeTimeCB;
194 CButton m_ctrlSnoozeBtn;
196 CButton m_ctrlDismissBtn;
197 CButton m_ctrlDismissAllBtn;
198 CButton m_ctrlOpenItemBtn;
200 BOOL m_bShowInTaskBar;
201 BOOL m_bAutoPopup;
202};
203
205AFX_INLINE void CXTPCalendarRemindersDialog::Detach()
206{
207 SetRemindersManager(NULL);
208}
209
210AFX_INLINE BOOL CXTPCalendarRemindersDialog::IsAutoPopup() const
211{
212 return m_bAutoPopup;
213}
214
215AFX_INLINE void CXTPCalendarRemindersDialog::SetAutoPopup(BOOL bAutoPopup)
216{
217 m_bAutoPopup = bAutoPopup;
218}
219
220# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
221#endif // !defined(_XTP_CALENDAR_REMINDERS_DIALOG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarReminder
This class describes a reminder for a calendar event and implements base properties for and operation...
Definition XTPCalendarRemindersManager.h:49
CXTPCalendarRemindersDialog
This class used to display calendar reminders.
Definition XTPCalendarRemindersDialog.h:44
CXTPCalendarRemindersDialog::IsShowInTaskBar
virtual BOOL IsShowInTaskBar()
This method is used to determine if the dialog window is displayed in the Microsoft Windows taskbar.
CXTPCalendarRemindersDialog::SetRemindersManager
virtual void SetRemindersManager(CXTPCalendarControl *pCalendar)
Use this method to attach dialog to calendar control (and reminders manager).
CXTPCalendarRemindersDialog::IsAutoPopup
BOOL IsAutoPopup() const
This method is used to determine if the dialog window pops up automatically when new reminders arrive...
Definition XTPCalendarRemindersDialog.h:210
CXTPCalendarRemindersDialog::m_arActiveReminders
CXTPCalendarReminders m_arActiveReminders
Store active reminders list.
Definition XTPCalendarRemindersDialog.h:155
CXTPCalendarRemindersDialog::~CXTPCalendarRemindersDialog
virtual ~CXTPCalendarRemindersDialog()
Default object destructor.
CXTPCalendarRemindersDialog::CXTPCalendarRemindersDialog
CXTPCalendarRemindersDialog(CWnd *pParent=NULL, UINT nIDTemplate=CXTPCalendarRemindersDialog::IDD)
Dialog class constructor.
CXTPCalendarRemindersDialog::m_nNextRefreshIndex
int m_nNextRefreshIndex
Store next reminder item index for automatic refresh by timer or -1 to refresh all.
Definition XTPCalendarRemindersDialog.h:159
CXTPCalendarRemindersDialog::m_pCalendar
CXTPCalendarControl * m_pCalendar
Store pointer to calendar control.
Definition XTPCalendarRemindersDialog.h:157
CXTPCalendarRemindersDialog::Create
virtual BOOL Create(CWnd *pParent=NULL)
Use this method to create a dialog window.
CXTPCalendarRemindersDialog::UpdateFromManager
virtual void UpdateFromManager()
Use this method to update the dialog reminders list from the reminders manager.
CXTPCalendarRemindersDialog::m_pRemindersMan
CXTPCalendarRemindersManager * m_pRemindersMan
Store pointer to reminders manager.
Definition XTPCalendarRemindersDialog.h:154
CXTPCalendarRemindersDialog::SetShowInTaskBar
virtual void SetShowInTaskBar(BOOL bShow=TRUE)
This method is used to set if the dialog window is displayed in the Microsoft Windows taskbar.
CXTPCalendarRemindersDialog::SetAutoPopup
void SetAutoPopup(BOOL bAutoPopup=TRUE)
This method is used to set if the dialog window pops up automatically when new reminders arrive.
Definition XTPCalendarRemindersDialog.h:215
CXTPCalendarReminders
This class represents a simple array collection of CXTPCalendarReminder objects.
Definition XTPCalendarRemindersManager.h:245
CXTPCalendarRemindersManager
This class is used to monitor and manage calendar events reminders.
Definition XTPCalendarRemindersManager.h:355


Toolkit Pro: XTPMarkupViewbox.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupViewbox.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPVIEWBOX_H__)
24# define __XTPMARKUPVIEWBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupBrush;
34class CXTPMarkupBuilder;
35
41class _XTP_EXT_CLASS CXTPMarkupViewbox : public CXTPMarkupDecorator
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupViewbox);
46protected:
51 CXTPMarkupViewbox();
52
57 virtual ~CXTPMarkupViewbox();
58
59public:
65 void SetStretch(XTPMarkupStretch stretch);
66
73 XTPMarkupStretch GetStretch() const;
74
75protected:
77 // Implementation
78 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
79 virtual CSize ArrangeOverride(CSize szFinalSize);
80
86 virtual TransformationMatrices ApplyRenderTransform(CXTPMarkupDrawingContext* pContext);
87 CXTPMarkupTransformationMatrix* ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
88
89 BOOL HasElementSize();
90 CSize GetElementSize();
91 BOOL ChildHasElementSize();
92 CSize ChildGetElementSize();
93
94protected:
95 float m_scaleX;
96 float m_scaleY;
97 float m_centerX;
98 float m_centerY;
99
100public:
101 static CXTPMarkupDependencyProperty* m_pStretchProperty;
105public:
106 DECLARE_DISPATCH_MAP()
107# ifdef _XTP_ACTIVEX
108 DECLARE_INTERFACE_MAP()
109 DECLARE_OLETYPELIB_EX(CXTPMarkupViewbox);
110# endif
111
112 afx_msg long OleGetStretch();
113 afx_msg void OleSetStretch(long stretch);
114 afx_msg LPDISPATCH OleGetChild();
115 afx_msg void OleSetChild(LPDISPATCH lpDisp);
116
118};
119
120# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
122#endif // !defined(__XTPMARKUPVIEWBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupDecorator
CXTPMarkupDecorator is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupDecorator.h:44
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40
CXTPMarkupUIElement::ApplyRenderTransform
virtual TransformationMatrices ApplyRenderTransform(CXTPMarkupDrawingContext *pContext)
Applies render transformation if necessary.
CXTPMarkupViewbox
CXTPMarkupViewbox is a CXTPMarkupDecorator derived class.
Definition XTPMarkupViewbox.h:42
CXTPMarkupViewbox::SetStretch
void SetStretch(XTPMarkupStretch stretch)
Sets the stretch type of the image.
CXTPMarkupViewbox::~CXTPMarkupViewbox
virtual ~CXTPMarkupViewbox()
Destroys a CXTPMarkupViewbox object, handles cleanup and deallocation.
CXTPMarkupViewbox::CXTPMarkupViewbox
CXTPMarkupViewbox()
Constructs a CXTPMarkupViewbox object.
CXTPMarkupViewbox::GetStretch
XTPMarkupStretch GetStretch() const
Gets the current stretch type of the image.
CXTPMarkupVisual::TransformationMatrices
A structure that optionally describes the previous and the new transformation matrices.
Definition XTPMarkupInputElement.h:361


CXTPFlowGraphUndoManager Member List

This is the complete list of members for CXTPFlowGraphUndoManager, including all inherited members.

AddUndoCommand(CXTPFlowGraphUndoCommand *pCommand) | CXTPFlowGraphUndoManager |
CanRedo() const | CXTPFlowGraphUndoManager |
CanUndo() const | CXTPFlowGraphUndoManager |
Clear() | CXTPFlowGraphUndoManager |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphUndoManager() | CXTPFlowGraphUndoManager |
EnableUndoManager(BOOL bEnabled) | CXTPFlowGraphUndoManager |
EndGroup() | CXTPFlowGraphUndoManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_arrGroupStack | CXTPFlowGraphUndoManager | protected
m_arrRedoCommands | CXTPFlowGraphUndoManager | protected
m_arrUndoCommands | CXTPFlowGraphUndoManager | protected
m_bEnabled | CXTPFlowGraphUndoManager | protected
m_nUndoContext | CXTPFlowGraphUndoManager | protected
m_pUndoGroup | CXTPFlowGraphUndoManager | protected
Redo() | CXTPFlowGraphUndoManager | virtual
StartGroup() | CXTPFlowGraphUndoManager | virtual
Undo() | CXTPFlowGraphUndoManager | virtual
~CXTPFlowGraphUndoManager() | CXTPFlowGraphUndoManager | virtual


Toolkit Pro: XTPFlowGraphTools.h Source File

  • Source
  • FlowGraph
XTPFlowGraphTools.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHTOOLS_H__)
24# define __XTPFLOWGRAPHTOOLS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34template<typename Traits>
35class CXTPFlowGraphGDIHandles : public Traits
36{
37public:
38 typedef typename Traits::FromType FromType;
39 typedef typename Traits::ToType ToType;
40
45 CXTPFlowGraphGDIHandles()
46 {
47 m_nCount = 0;
48 }
49
55 ~CXTPFlowGraphGDIHandles()
56 {
57 for (int i = 0; i < m_nCount; i++)
58 {
59 CXTPFlowGraphGDIHandles::DestroyHandle(m_arr[i].hTo);
60 }
61 }
62
63 ToType GetHandle(const FromType& hFrom)
64 {
65 int i;
66
67 for (i = 0; i < m_nCount; i++)
68 {
69 if (Traits::CompareHandle(m_arr[i].hFrom, hFrom))
70 return m_arr[i].hTo;
71 }
72
73 if (m_nCount == MAX_HANDLE)
74 {
75 Traits::DestroyHandle(m_arr[m_nCount - 1].hTo);
76 }
77 else if (m_nCount)
78 {
79 m_arr[m_nCount] = m_arr[m_nCount - 1];
80 }
81
82 for (i = m_nCount - 1; i >= 1; i--)
83 {
84 m_arr[i] = m_arr[i - 1];
85 }
86
87 if (m_nCount != MAX_HANDLE)
88 m_nCount++;
89
90 m_arr[0].hFrom = hFrom;
91 m_arr[0].hTo = Traits::CreateHandle(hFrom);
92
93 return m_arr[0].hTo;
94 }
95 struct GDIREC
96 {
97 FromType hFrom;
98 ToType hTo;
99 };
100
101 enum
102 {
103 MAX_HANDLE = 6
104 };
105
106 int m_nCount;
107 GDIREC m_arr[MAX_HANDLE];
108};
109
110struct CXTPFlowGraphFontTraits
111{
112 typedef LOGFONT FromType;
113 typedef HFONT ToType;
114
115 void DestroyHandle(HFONT hFont)
116 {
117 DeleteObject(hFont);
118 }
119 HFONT CreateHandle(const LOGFONT& lf)
120 {
121 return CreateFontIndirect(&lf);
122 }
123 BOOL CompareHandle(const LOGFONT& lfLeft, const LOGFONT& lfRight)
124 {
125 if (lfLeft.lfHeight != lfRight.lfHeight)
126 return FALSE;
127
128 if (lfLeft.lfWeight != lfRight.lfWeight)
129 return FALSE;
130
131 if (lfLeft.lfItalic != lfRight.lfItalic)
132 return FALSE;
133
134 if (lfLeft.lfQuality != lfRight.lfQuality)
135 return FALSE;
136
137 if (_tcscmp(lfLeft.lfFaceName, lfRight.lfFaceName) != 0)
138 return FALSE;
139
140 return TRUE;
141 }
142};
143
144struct CXTPFlowGraphBrushTraits
145{
146 typedef COLORREF FromType;
147 typedef HBRUSH ToType;
148
149 void DestroyHandle(HBRUSH hFont)
150 {
151 DeleteObject(hFont);
152 }
153 HBRUSH CreateHandle(COLORREF clr)
154 {
155 return CreateSolidBrush(clr);
156 }
157 BOOL CompareHandle(COLORREF clrLeft, COLORREF clrRight)
158 {
159 return clrLeft == clrRight;
160 }
161};
164# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
165#endif //#if !defined(__XTPFLOWGRAPHTOOLS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


CXTPGridRecordItemPercentNumber Member List

This is the complete list of members for CXTPGridRecordItemPercentNumber, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItemNumber | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItemNumber | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItemNumber | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPGridRecordItemNumber(double dValue=0) | CXTPGridRecordItemNumber |
CXTPGridRecordItemNumber(double dValue, LPCTSTR strFormat) | CXTPGridRecordItemNumber |
CXTPGridRecordItemPercentNumber(double dValue=0, COLORREF clr=RGB(224, 224, 224), BOOL bPercentCompleteDisplay=TRUE) | CXTPGridRecordItemPercentNumber |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemNumber | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItemNumber | virtual
GetCaption() | CXTPGridRecordItemNumber | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItemNumber | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
GetValue() | CXTPGridRecordItemNumber |
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bPercentCompleteDisplay | CXTPGridRecordItemPercentNumber |
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clr | CXTPGridRecordItemPercentNumber |
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dValue | CXTPGridRecordItemNumber | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItemPercentNumber | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItemNumber | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
SetValue(double dValue) | CXTPGridRecordItemNumber |
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: XTPChartRadarPointSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarPointSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARPOINTSERIESSTYLE_H__)
24# define __XTPCHARTRADARPOINTSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
46class _XTP_EXT_CLASS CXTPChartRadarPointSeriesStyle : public CXTPChartRadarDiagramSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartRadarPointSeriesStyle)
51public:
56 CXTPChartRadarPointSeriesStyle();
57
62 virtual ~CXTPChartRadarPointSeriesStyle();
63
64public:
73 CXTPChartMarker* GetMarker() const;
74
75public:
76 void DoPropExchange(CXTPPropExchange* pPX);
77
78protected:
89 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
90 CXTPChartDiagramView* pDiagramView);
91
92# ifdef _XTP_ACTIVEX
93public:
95 DECLARE_DISPATCH_MAP()
96 DECLARE_INTERFACE_MAP()
97 DECLARE_OLETYPELIB_EX(CXTPChartRadarPointSeriesStyle);
98 DECLARE_OLECREATE_EX(CXTPChartRadarPointSeriesStyle)
99 LPDISPATCH OleGetMarker();
100
102# endif
103
104protected:
105 CXTPChartMarker* m_pMarker;
106};
107
108AFX_INLINE CXTPChartMarker* CXTPChartRadarPointSeriesStyle::GetMarker() const
109{
110 return m_pMarker;
111}
113# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif //#if !defined(__XTPCHARTRADARPOINTSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartRadarDiagramSeriesStyle
This class represents a base radar series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarDiagramSeriesStyle.h:47
CXTPChartRadarPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartRadarPointSeriesStyle.h:47
CXTPChartRadarPointSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRadarPointSeriesStyle::GetMarker
CXTPChartMarker * GetMarker() const
Call this function to get the marker object associated with this CXTPChartRadarPointSeriesStyle objec...
Definition XTPChartRadarPointSeriesStyle.h:108
CXTPChartRadarPointSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the point series.
CXTPChartRadarPointSeriesStyle::CXTPChartRadarPointSeriesStyle
CXTPChartRadarPointSeriesStyle()
Constructs a CXTPChartRadarPointSeriesStyle object.
CXTPChartRadarPointSeriesStyle::~CXTPChartRadarPointSeriesStyle
virtual ~CXTPChartRadarPointSeriesStyle()
Destroys a CXTPChartRadarPointSeriesStyle object, handles cleanup.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPCustomizePageCommands.h Source File

  • Source
  • CommandBars
  • Customize
XTPCustomizePageCommands.h
Go to the documentation of this file.
1
23#if !defined(__XTPCUSTOMIZECOMMANDSPAGE_H__) && defined(_XTP_INCLUDE_CONTROLS)
24# define __XTPCUSTOMIZECOMMANDSPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCustomizeSheet;
34class CXTPControl;
35class CXTPControls;
36class CXTPCommandBar;
37
45struct _XTP_EXT_CLASS XTP_COMMANDBARS_CATEGORYINFO
46{
55 XTP_COMMANDBARS_CATEGORYINFO(LPCTSTR strCategory, CXTPCommandBars* pCommandBars);
56
62 ~XTP_COMMANDBARS_CATEGORYINFO();
65 CString strCategory;
66 CXTPControls* pControls;
67};
68
77typedef CArray<XTP_COMMANDBARS_CATEGORYINFO*, XTP_COMMANDBARS_CATEGORYINFO*>
78 CXTPCommandBarsCategoryArray;
79
84class _XTP_EXT_CLASS CXTPCustomizeCommandsListBox
85 :
86# ifdef _XTP_INCLUDE_CONTROLS
87 public CXTPListBox
88{
89 typedef CXTPListBox BaseType;
90# else
91 public CListBox
92{
93 typedef CListBox BaseType;
94# endif
95public:
100 CXTPCustomizeCommandsListBox()
101 {
102 m_bDragable = FALSE;
103 m_pCommandBars = NULL;
104 }
105
106protected:
108 DECLARE_MESSAGE_MAP()
109
110 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
111 afx_msg void OnSetFocus(CWnd* pOldWnd);
112 virtual void DrawItem(LPDRAWITEMSTRUCT);
113 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
114 afx_msg void OnPaint();
115 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
116
119public:
120 CXTPCommandBars* m_pCommandBars;
121 BOOL m_bDragable;
122};
123
129class _XTP_EXT_CLASS CXTPCustomizeCommandsPage : public CXTPPropertyPage
130{
132 DECLARE_DYNCREATE(CXTPCustomizeCommandsPage)
134public:
141 CXTPCustomizeCommandsPage(CXTPCustomizeSheet* pSheet = NULL);
142
148 ~CXTPCustomizeCommandsPage();
149
150public:
161 BOOL AddCategories(UINT nIDResource, BOOL bListSubItems = FALSE);
162
172 BOOL AddCategories(CXTPControls* pControls);
173
185 BOOL AddCategory(LPCTSTR strCategory, CMenu* pMenu, BOOL bListSubItems = FALSE);
186
197 BOOL AddToolbarCategory(LPCTSTR strCategory, UINT nIDResource);
198
209 CXTPControls* InsertCategory(LPCTSTR strCategory, int nIndex = -1);
210
218 void InsertNewMenuCategory(UINT nIDResource = XTP_IDS_NEWMENU, int nIndex = -1);
219
229 void InsertAllCommandsCategory(UINT nIDResource = XTP_IDS_ALLCOMMANDS, int nIndex = -1,
230 BOOL bSortCommands = TRUE);
231
243 BOOL InsertBuiltInMenus(UINT nIDResourceMenu, UINT nIDResourceCategory = XTP_IDS_BUILTINMENUS,
244 int nIndex = -1);
245
255 CXTPControls* GetControls(LPCTSTR strCategory);
256
264 XTP_COMMANDBARS_CATEGORYINFO* FindCategory(LPCTSTR strCategory) const;
265
273 XTP_COMMANDBARS_CATEGORYINFO* GetCategoryInfo(int nIndex) const;
274
275protected:
277 DECLARE_MESSAGE_MAP()
278
279 //{{AFX_VIRTUAL(CXTPCustomizeCommandsPage)
280 virtual void DoDataExchange(CDataExchange* pDX);
281 BOOL OnInitDialog();
282 //}}AFX_VIRTUAL
283
284 //{{AFX_MSG(CXTPCustomizeCommandsPage)
285 afx_msg void OnCategoriesSelectionChanged();
286 afx_msg void OnDestroy();
287 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
288 //}}AFX_MSG
291private:
292 BOOL _LoadToolBar(CXTPCommandBar* pCommandBar, UINT nIDResource);
293
294protected:
295 CXTPCustomizeCommandsListBox m_lstCommands;
297# ifdef _XTP_INCLUDE_CONTROLS
298 COLORREF m_clrText;
299 CXTPListBox m_lstCategories;
300# else
301 CListBox m_lstCategories;
302# endif
303
304protected:
305 CXTPCustomizeSheet* m_pSheet;
306 CXTPCommandBarsCategoryArray m_arrCategories;
308private:
309 friend class CCommandsListBox;
310};
312# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
313#endif // !defined(__XTPCUSTOMIZECOMMANDSPAGE_H__)
CXTPCommandBarsCategoryArray
CArray< XTP_COMMANDBARS_CATEGORYINFO *, XTP_COMMANDBARS_CATEGORYINFO * > CXTPCommandBarsCategoryArray
This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_C...
Definition XTPCustomizePageCommands.h:78
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeCommandsListBox
List of the commands.
Definition XTPCustomizePageCommands.h:92
CXTPCustomizeCommandsListBox::CXTPCustomizeCommandsListBox
CXTPCustomizeCommandsListBox()
Constructs a CXTPCustomizeCommandsListBox object.
Definition XTPCustomizePageCommands.h:100
CXTPCustomizeCommandsPage
CXTPCustomizeCommandsPage is a CPropertyPage derived class.
Definition XTPCustomizePageCommands.h:130
CXTPCustomizeCommandsPage::CXTPCustomizeCommandsPage
CXTPCustomizeCommandsPage(CXTPCustomizeSheet *pSheet=NULL)
Constructs a CXTPCustomizeCommandsPage object.
CXTPCustomizeCommandsPage::InsertAllCommandsCategory
void InsertAllCommandsCategory(UINT nIDResource=XTP_IDS_ALLCOMMANDS, int nIndex=-1, BOOL bSortCommands=TRUE)
Adds "All Commands" category and adds all controls already created in other categories here.
CXTPCustomizeCommandsPage::FindCategory
XTP_COMMANDBARS_CATEGORYINFO * FindCategory(LPCTSTR strCategory) const
Finds the category.
CXTPCustomizeCommandsPage::GetControls
CXTPControls * GetControls(LPCTSTR strCategory)
Retrieves the control list of the given category.
CXTPCustomizeCommandsPage::GetCategoryInfo
XTP_COMMANDBARS_CATEGORYINFO * GetCategoryInfo(int nIndex) const
Gets the category by its index.
CXTPCustomizeCommandsPage::AddCategories
BOOL AddCategories(CXTPControls *pControls)
Adds categories branch from Controls.
CXTPCustomizeCommandsPage::m_pSheet
CXTPCustomizeSheet * m_pSheet
Parent Customize dialog.
Definition XTPCustomizePageCommands.h:305
CXTPCustomizeCommandsPage::AddCategories
BOOL AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE)
Adds categories branch from menu resource.
CXTPCustomizeCommandsPage::InsertNewMenuCategory
void InsertNewMenuCategory(UINT nIDResource=XTP_IDS_NEWMENU, int nIndex=-1)
Adds single "New menu" category.
CXTPCustomizeCommandsPage::~CXTPCustomizeCommandsPage
~CXTPCustomizeCommandsPage()
Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.
CXTPCustomizeCommandsPage::InsertCategory
CXTPControls * InsertCategory(LPCTSTR strCategory, int nIndex=-1)
This method adds a new empty category in the given index.
CXTPCustomizeCommandsPage::m_arrCategories
CXTPCommandBarsCategoryArray m_arrCategories
Array of categories.
Definition XTPCustomizePageCommands.h:306
CXTPCustomizeCommandsPage::m_lstCategories
CListBox m_lstCategories
List box of categories.
Definition XTPCustomizePageCommands.h:301
CXTPCustomizeCommandsPage::InsertBuiltInMenus
BOOL InsertBuiltInMenus(UINT nIDResourceMenu, UINT nIDResourceCategory=XTP_IDS_BUILTINMENUS, int nIndex=-1)
Adds built-in menus category.
CXTPCustomizeCommandsPage::AddToolbarCategory
BOOL AddToolbarCategory(LPCTSTR strCategory, UINT nIDResource)
Adds a new category from a toolbar resource.
CXTPCustomizeCommandsPage::AddCategory
BOOL AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
XTP_COMMANDBARS_CATEGORYINFO
This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option p...
Definition XTPCustomizePageCommands.h:46
XTP_COMMANDBARS_CATEGORYINFO::pControls
CXTPControls * pControls
Controls of this category.
Definition XTPCustomizePageCommands.h:66
XTP_COMMANDBARS_CATEGORYINFO::strCategory
CString strCategory
Category caption.
Definition XTPCustomizePageCommands.h:65


CXTPChartElement Member List

This is the complete list of members for CXTPChartElement, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartElement | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual


CXTPSyntaxEditFindReplaceDlg Member List

This is the complete list of members for CXTPSyntaxEditFindReplaceDlg, including all inherited members.

CXTPSyntaxEditFindReplaceDlg(CWnd *pParentWnd=NULL) | CXTPSyntaxEditFindReplaceDlg |
EnableControls() | CXTPSyntaxEditFindReplaceDlg | protected
GetEdirControl() const | CXTPSyntaxEditFindReplaceDlg |
GetSearchHistoryCountMax() const | CXTPSyntaxEditFindReplaceDlg |
InitHistoryCombo(CStringArray &arHistory, CComboBox &wndCombo) | CXTPSyntaxEditFindReplaceDlg | protected
IsReplaceDialog() const | CXTPSyntaxEditFindReplaceDlg |
LoadHistory() | CXTPSyntaxEditFindReplaceDlg | protected
m_bMatchCase | CXTPSyntaxEditFindReplaceDlg |
m_bMatchWholeWord | CXTPSyntaxEditFindReplaceDlg |
m_bReplaceDlg | CXTPSyntaxEditFindReplaceDlg | protected
m_csFindText | CXTPSyntaxEditFindReplaceDlg |
m_csReplaceText | CXTPSyntaxEditFindReplaceDlg |
m_nSearchDirection | CXTPSyntaxEditFindReplaceDlg |
m_nSearchHistoryCountMax | CXTPSyntaxEditFindReplaceDlg |
m_pEditCtrl | CXTPSyntaxEditFindReplaceDlg | protected
m_ptWndPos | CXTPSyntaxEditFindReplaceDlg | protected
SaveHistory() | CXTPSyntaxEditFindReplaceDlg | protected
SetSearchHistoryCountMax(int nMaxCount) | CXTPSyntaxEditFindReplaceDlg |
ShowDialog(CXTPSyntaxEditCtrl *pEditCtrl, BOOL bReplaceDlg=FALSE) | CXTPSyntaxEditFindReplaceDlg |
UpdateHistoryCombo(const CString &csText, CStringArray &arHistory) | CXTPSyntaxEditFindReplaceDlg | protected
UpdateHistoryCombo(const CString &csText, CStringArray &arHistory, CComboBox &wndCombo) | CXTPSyntaxEditFindReplaceDlg | protected
UpdateHistoryCombo(const CString &csText, CComboBox &wndCombo) | CXTPSyntaxEditFindReplaceDlg | protected


Toolkit Pro: XTPTaskPanelOffice2003ThemePlain.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelOffice2003ThemePlain.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelOffice2003ThemePlain_h__
24# define XTPTaskPanelOffice2003ThemePlain_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelOffice2003ThemePlain : public CXTPTaskPanelOfficeXPThemePlain
40{
41public:
46 CXTPTaskPanelOffice2003ThemePlain();
47
52 void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // XTPTaskPanelOffice2003ThemePlain_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelOffice2003ThemePlain
CXTPTaskPanelOffice2003ThemePlain represents a classic Office 2003 style theme.
Definition XTPTaskPanelOffice2003ThemePlain.h:40
CXTPTaskPanelOffice2003ThemePlain::CXTPTaskPanelOffice2003ThemePlain
CXTPTaskPanelOffice2003ThemePlain()
Constructs a CXTPTaskPanelOffice2003ThemePlain object.
CXTPTaskPanelOffice2003ThemePlain::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelOfficeXPThemePlain
CXTPTaskPanelOfficeXPThemePlain represents a classic Office XP style theme.
Definition XTPTaskPanelOfficeXPThemePlain.h:40


CXTPTabBaseThemeOfficeXP Member List

This is the complete list of members for CXTPTabBaseThemeOfficeXP, including all inherited members.

AdjustBorders(CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember) | CXTPTabBaseThemeOfficeXP | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTabBaseTheme() | CXTPTabBaseTheme |
CXTPTabBaseThemeOfficeXP() | CXTPTabBaseThemeOfficeXP |
DrawBorder(CDC *pDC, const CRect &r) | CXTPTabBaseThemeOfficeXP | protectedvirtual
DrawBorders(CDC *pDC, const CRect &rcClient) | CXTPTabBaseThemeOfficeXP | protectedvirtual
DrawButton(CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton) | CXTPTabBaseThemeOfficeXP | virtual
DrawTab(CDC *pDC, CXTPTabBase *pTabCtrlBase, int iItem) | CXTPTabBaseTheme | protectedvirtual
DrawTabCtrl(CDC *pDC, CXTPTabBase *pTabCtrl) | CXTPTabBaseTheme | virtual
DrawTabIcon(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem) | CXTPTabBaseThemeOfficeXP | protectedvirtual
DrawTabText(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem, BOOL bSelected, BOOL bBoldFont) | CXTPTabBaseTheme | protectedvirtual
FillButtons(CDC *pDC, CXTPTabCtrlButtons *pButtons) | CXTPTabBaseThemeOfficeXP | virtual
FillHeader(CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader) | CXTPTabBaseThemeOfficeXP | protectedvirtual
FillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected) | CXTPTabBaseThemeOfficeXP | protectedvirtual
FillTabFaceNativeWinXP(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected) | CXTPTabBaseTheme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPTabBaseTheme | virtual
GetHeaderRect(CXTPTabBase *pTabCtrlBase) | CXTPTabBaseTheme | protectedvirtual
GetTabStyle(CTabCtrl *pTabCtrl) const | CXTPTabBaseTheme | inlineprotected
GetThemeStyle() const | CXTPControlTheme |
HorizontalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr) | CXTPTabBaseTheme | protected
IsBottom(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsHorz(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsLeft(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsRight(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsTop(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
IsVert(DWORD dwStyle) const | CXTPTabBaseTheme | inlineprotected
m_bSystemDrawing | CXTPTabBaseTheme |
m_bUseWinThemes | CXTPTabBaseTheme |
m_clrNormalText | CXTPTabBaseTheme | protected
m_iEdge | CXTPTabBaseTheme | protected
m_nTheme | CXTPControlTheme | protected
m_themeTab | CXTPTabBaseTheme | protected
Pixel(CDC *pDC, int xPos, int yPos, COLORREF clr) | CXTPTabBaseTheme | protected
RefreshMetrics(CTabCtrl *pTab) | CXTPTabBaseThemeOfficeXP | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
ShowButtons(CXTPTabBase *pTabCtrlBase) | CXTPTabBaseTheme | protectedvirtual
SwapColors(COLORREF &clrLight, COLORREF &clrDark) | CXTPTabBaseTheme | protected
VerticalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr) | CXTPTabBaseTheme | protected
~CXTPTabBaseTheme() | CXTPTabBaseTheme | virtual


CXTPButtonThemeVisualStudio2019 Member List

This is the complete list of members for CXTPButtonThemeVisualStudio2019, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPButtonThemeVisualStudio2019() | CXTPButtonThemeVisualStudio2019 |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeVisualStudio2019 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: XTPDockingPaneTabColorSetNativeWindows10.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSetNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSETNATIVEWINDOWS10_H__)
24# define __XTPDOCKINGPANETABCOLORSETNATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSetNativeWindows10
39 : public CXTPDockingPaneTabColorSet2012
40{
41public:
46 CXTPDockingPaneTabColorSetNativeWindows10();
47
62 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
63};
64
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
67#endif // !defined(__XTPDOCKINGPANETABCOLORSETNATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2012.h:39
CXTPDockingPaneTabColorSetNativeWindows10
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSetNativeWindows10.h:40
CXTPDockingPaneTabColorSetNativeWindows10::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSetNativeWindows10::CXTPDockingPaneTabColorSetNativeWindows10
CXTPDockingPaneTabColorSetNativeWindows10()
Default class constructor.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87


Toolkit Pro: XTPMarkupTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTRANSFORM_H__)
24# define __XTPMARKUPTRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTransformationMatrix;
34class CXTPMarkupRenderTransform;
35class CXTPMarkupDependencyProperty;
36class CXTPMarkupObject;
37
42class _XTP_EXT_CLASS CXTPMarkupTransform : public CXTPMarkupObject
43{
45 DECLARE_MARKUPCLASS(CXTPMarkupTransform);
47protected:
52 CXTPMarkupTransform();
53
54public:
64 virtual CXTPMarkupTransformationMatrix*
65 ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
66
67protected:
68 virtual void OnPropertyChanged(CXTPMarkupDependencyProperty* pProperty,
69 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
70 virtual void OnSetAsProperty(CXTPMarkupDependencyProperty* pProperty,
71 CXTPMarkupObject* pTargetObject);
72
73protected:
74 CXTPMarkupRenderTransform* m_pRenderTransform;
75};
76
77# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
79#endif // !defined(__XTPMARKUPTRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupTransform
Base class for all markup transformation objects.
Definition XTPMarkupTransform.h:43
CXTPMarkupTransform::ApplyTransform
virtual CXTPMarkupTransformationMatrix * ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
CXTPMarkupTransform::CXTPMarkupTransform
CXTPMarkupTransform()
Prevents a class from being instantiated.
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40


Toolkit Pro: XTPShortcutListBox.h Source File

  • Source
  • Controls
  • ListBox
XTPShortcutListBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTLISTBOX_H__)
24# define __XTPSHORTCUTLISTBOX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPShortcutListBoxTheme;
34class CXTPImageManagerIcon;
35
43class _XTP_EXT_CLASS CXTPShortcutListBox : public CListBox
44{
46 DECLARE_DYNAMIC(CXTPShortcutListBox)
48public:
56 struct CONTENT_ITEM
57 {
59 CONTENT_ITEM();
60 ~CONTENT_ITEM();
63 int m_nIndex;
64 BOOL m_bEnabled;
65 CString m_strText;
66 CXTPImageManagerIcon* m_pIcon;
67 };
68
79 typedef CList<CONTENT_ITEM*, CONTENT_ITEM*> CContentItemList;
80
81public:
86 CXTPShortcutListBox();
87
92 virtual ~CXTPShortcutListBox();
93
94public:
107 BOOL SetTheme(XTPControlTheme eTheme);
108
117 CXTPShortcutListBoxTheme* GetTheme();
118
130 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
131
142 void SetColors(COLORREF clrText, COLORREF clrBack, COLORREF clrBackDark = COLORREF_NULL);
143
160 int InsertMenuItem(int iIndex, UINT nIconID, LPCTSTR lpszText, BOOL bEnabled = TRUE);
161
181 int AddMenuItem(UINT nIconID, LPCTSTR lpszText, BOOL bEnabled = TRUE);
182
193 BOOL EnableMenuItem(int iItem, BOOL bEnabled);
194
203 CONTENT_ITEM* GetMenuItem(int iItem);
204
213 void SetHighlightCursor(UINT nIDCursor, bool bNoBorder = false, bool bNoUnderline = false);
214
216 _XTP_DEPRECATED_IN_FAVOR(SetHighlightCursor)
217 void SetHilightCursor(UINT nIDCursor, bool bNoBorder = false, bool bNoUnderline = false)
218 {
219 SetHighlightCursor(nIDCursor, bNoBorder, bNoUnderline);
220 }
231 int GetTextHeight(LPCTSTR lspzItem) const;
232
233protected:
238 virtual void RefreshMetrics();
239
241 DECLARE_MESSAGE_MAP()
242
243 //{{AFX_VIRTUAL(CXTPShortcutListBox)
244 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
245 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
246 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
247 //}}AFX_VIRTUAL
248
249 //{{AFX_MSG(CXTPShortcutListBox)
250 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
251 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
252 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
253 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
254 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
255 afx_msg void OnPaint();
256 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
257 afx_msg void OnMouseLeave();
258 //}}AFX_MSG
259 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
262private:
263 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
264 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
265 void RedrawItem(int iIndex);
266 void RedrawItem(CPoint point);
267
268public:
269 bool m_bNoBorder;
270 bool m_bNoUnderline;
273protected:
274 int m_nPrevIndex;
275 int m_bHilightItemID;
277 bool m_bHilight;
278 bool m_bTimerActive;
279 CPoint m_point;
280 CContentItemList m_arContentItems;
282 HCURSOR m_hCursor;
283 CXTPShortcutListBoxTheme* m_pTheme;
284};
285
287# define CXTOutlookBar CXTPShortcutListBox
291
292AFX_INLINE BOOL CXTPShortcutListBox::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
293 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
294 UINT nID, CCreateContext* pContext)
295{
296 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
297}
298
299AFX_INLINE CXTPShortcutListBoxTheme* CXTPShortcutListBox::GetTheme()
300{
301 return m_pTheme;
302}
304# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
306#endif // #if !defined(__XTPSHORTCUTLISTBOX_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPShortcutListBox
CCXTPShortcutListBox is a CListBox derived class.
Definition XTPShortcutListBox.h:44
CXTPShortcutListBox::CXTPShortcutListBox
CXTPShortcutListBox()
Constructs a CXTPShortcutListBox object.
CXTPShortcutListBox::~CXTPShortcutListBox
virtual ~CXTPShortcutListBox()
Destroys a CXTPShortcutListBox object, handles cleanup and deallocation.
CXTPShortcutListBox::InsertMenuItem
int InsertMenuItem(int iIndex, UINT nIconID, LPCTSTR lpszText, BOOL bEnabled=TRUE)
This member function inserts a menu item into the Outlook bar.
CXTPShortcutListBox::CContentItemList
CList< CONTENT_ITEM *, CONTENT_ITEM * > CContentItemList
List for maintaining CONTENT_ITEM structures.
Definition XTPShortcutListBox.h:79
CXTPShortcutListBox::GetTextHeight
int GetTextHeight(LPCTSTR lspzItem) const
This member function is called by the outlook bar to determine the string height for a multi-line tex...
CXTPShortcutListBox::SetColors
void SetColors(COLORREF clrText, COLORREF clrBack, COLORREF clrBackDark=COLORREF_NULL)
Call this member function to set the text and background colors for the Outlook bar.
CXTPShortcutListBox::SetHighlightCursor
void SetHighlightCursor(UINT nIDCursor, bool bNoBorder=false, bool bNoUnderline=false)
Call this member function to set the cursor, text, and border attributes for a highlighted item.
CXTPShortcutListBox::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
This member function creates an Outlook Bar control.
CXTPShortcutListBox::SetTheme
BOOL SetTheme(XTPControlTheme eTheme)
Call this member to switch the visual theme of the control.
CXTPShortcutListBox::GetMenuItem
CONTENT_ITEM * GetMenuItem(int iItem)
Call this member function to retrieve a CONTENT_ITEM object that represents the menu item specified b...
CXTPShortcutListBox::EnableMenuItem
BOOL EnableMenuItem(int iItem, BOOL bEnabled)
Call this member function to enable/disable the menu item specified by iItem.
CXTPShortcutListBox::AddMenuItem
int AddMenuItem(UINT nIconID, LPCTSTR lpszText, BOOL bEnabled=TRUE)
Call this member function to add a menu item to an Outlook bar.
CXTPShortcutListBox::GetTheme
CXTPShortcutListBoxTheme * GetTheme()
Call this member function to get a pointer to the currently selected theme.
CXTPShortcutListBox::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPShortcutListBoxTheme
CXTPShortcutListBoxTheme is used to draw the CXTPShortcutListBox object.
Definition XTPShortcutListBoxTheme.h:44
CXTPShortcutListBox::CONTENT_ITEM
CONTENT_ITEM structure is used by the CXTPShortcutListBox class to maintain information about a parti...
Definition XTPShortcutListBox.h:57
CXTPShortcutListBox::CONTENT_ITEM::m_strText
CString m_strText
Text label for the menu item.
Definition XTPShortcutListBox.h:65
CXTPShortcutListBox::CONTENT_ITEM::m_pIcon
CXTPImageManagerIcon * m_pIcon
Icon handle for the menu item.
Definition XTPShortcutListBox.h:66
CXTPShortcutListBox::CONTENT_ITEM::m_nIndex
int m_nIndex
Zero-based index for the menu item.
Definition XTPShortcutListBox.h:63
CXTPShortcutListBox::CONTENT_ITEM::m_bEnabled
BOOL m_bEnabled
TRUE if the menu item is enabled.
Definition XTPShortcutListBox.h:64


Toolkit Pro: XTPGridPaintManager.h Source File

  • Source
  • GridControl
XTPGridPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDPAINTMANAGER_H__)
24# define __XTPGRIDPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPImageManager;
35class CXTPWinThemeWrapper;
36
37struct XTP_GRIDRECORDITEM_DRAWARGS;
38struct XTP_GRIDRECORDITEM_METRICS;
39
40class CXTPGridControl;
41class CXTPGridRow;
42class CXTPGridHeader;
43class CXTPGridColumn;
44class CXTPGridColumns;
45class CXTPGridGroupRow;
46class CXTPGridInplaceButton;
47class CXTPGridHyperlink;
48class CXTPGridRecordItem;
49class CXTPGridRecordItemControl;
50class CXTPGridHyperlinkStyle;
51class CXTPGridBorder;
52class CXTPTrackBlock;
53class CXTPComboBox;
54
75class _XTP_EXT_CLASS CXTPGridPaintManager : public CXTPCmdTarget
76{
77 DECLARE_DYNAMIC(CXTPGridPaintManager);
78
80 friend class CXTPGridControl;
83public:
90 CXTPGridPaintManager();
91
96 virtual ~CXTPGridPaintManager();
97
103 virtual void SetGridControl(CXTPGridControl* pControl);
104
106 _XTP_DEPRECATED_IN_FAVOR(SetGridControl)
107 virtual void SetReportControl(CXTPGridControl* pControl);
110public:
115 virtual void LoadGlyphs();
116
124 virtual void RefreshMetrics();
125
138 virtual int GetRowHeight(CDC* pDC, CXTPGridRow* pRow);
139
153 virtual int GetRowHeight(CDC* pDC, CXTPGridRow* pRow, int nTotalWidth);
154
169 int GetRowHeightEx(CDC* pDC, CXTPGridRow* pRow, int nTotalWidth, const BOOL firstLevel = TRUE);
170
179 int GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS& drawArgs, int nWidth);
180
194 BOOL FindRowAdjacentToMergedEx(const CXTPGridColumns* pColumns, const CXTPGridRow* pRow,
195 int& nAdjRowIndex, BOOL bUpward);
196
208 int FindRowAdjacentToMerged(const CXTPGridColumns* pColumns, const CXTPGridRow* pRow,
209 BOOL bUpward);
210
222 int RecalcTotalHightOfMergedRows(CXTPGridColumns* pColumns, CDC* pDC, CXTPGridRow* pRow,
223 int nRowHeight, int nTotalWidth);
224
238 virtual int GetPreviewItemHeight(CDC* pDC, CXTPGridRow* pRow, int nWidth, int nHeight);
239
246 virtual int GetHeaderHeight();
247
257 virtual int GetHeaderHeight(CXTPGridControl* pControl, CDC* pDC, int nTotalWidth = 0);
258
264 virtual void SetHeaderHeight(int nHeight);
265
275 virtual int GetFooterHeight(CXTPGridControl* pControl, CDC* pDC, int nTotalWidth = 0);
276
284 virtual COLORREF GetControlBackColor(CXTPGridControl* pControl);
285
299 virtual void FillRow(CDC* pDC, CXTPGridRow* pRow, CRect rcRow);
300
320 virtual void DrawGrid(CDC* pDC, XTPGridOrientation orientation, CRect rcGrid);
321
330 virtual void DrawFreezeColsDivider(CDC* pDC, const CRect& rc, CXTPGridControl* pControl,
331 CXTPGridRow* pRow = NULL);
332
341 virtual void DrawVerticalTimeLineMarker(CDC* pDC, int xPos, CXTPGridControl* pControl,
342 COLORREF color = RGB(0, 255, 0));
343
344 // Return current Print Page Width after Preview mode was call and set value
345
346 int GetPrintPageWidth();
347
348 virtual CRect GetGroupRowBmpSize(CRect rcRow, int nBitmapOffset);
349
350 virtual CRect GetGroupRowTextSize(CRect rcBitmap, CRect rcRow, int nBitmapWidth,
351 int nNoIconWidth, int nTextOffset);
352
353 virtual void DrawGroupRowBack(CDC* pDC, CRect rcRow, XTP_GRIDRECORDITEM_METRICS* pMetrics);
354
370 virtual void DrawGroupRow(CDC* pDC, CXTPGridGroupRow* pRow, CRect rcRow,
371 XTP_GRIDRECORDITEM_METRICS* pMetrics);
372
381 virtual void FillGroupRowMetrics(CXTPGridGroupRow* pRow, XTP_GRIDRECORDITEM_METRICS* pMetrics,
382 BOOL bPrinting);
383
400 virtual void FillIndent(CDC* pDC, CRect rcRow);
401
415 virtual void FillItemShade(CDC* pDC, CRect rcItem);
416
432 virtual void FillHeaderControl(CDC* pDC, CRect rcHeader);
433
440 virtual void FillFooter(CDC* pDC, CRect rcFooter);
441
452 virtual void DrawColumnText(CDC* pDC, CRect rcText, CString strCaption, int nHeaderAlignment,
453 BOOL bIsHeader, BOOL bColumnPressed);
454
477 virtual void DrawColumn(CDC* pDC, CXTPGridColumn* pColumn, CXTPGridHeader* pHeader,
478 CRect rcColumn, BOOL bDrawExternal = FALSE, int nShadowWidth = 0);
479
487 virtual void DrawColumnFooterDivider(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn);
488
497 virtual void DrawColumnFooter(CDC* pDC, CXTPGridColumn* pColumn, CXTPGridHeader* pHeader,
498 CRect rcColumn);
499
511 virtual BOOL IsColumHotTrackingEnabled() const;
512
527 virtual void DrawFocusedRow(CDC* pDC, CRect rcRow);
528
541 virtual void FillGroupByControl(CDC* pDC, CRect& rcGroupBy);
542
553 CXTPImageManager* GetGlyphs() const;
554
567 void DrawHorizontalLine(CDC* pDC, int xPos, int yPos, int cx, COLORREF clr);
568
581 void DrawVerticalLine(CDC* pDC, int xPos, int yPos, int cy, COLORREF clr);
582
616 virtual void DrawTriangle(CDC* pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader,
617 int nShadowWidth, BOOL bColumnPressed);
618
619 virtual void DrawColumnInverted(CDC* pDC, CRect rcColumn, BOOL bColumnPressed,
620 BOOL bDraggingFromHeader, int nShadowWidth);
621
639 void DrawConnector(CDC* pDC, CPoint ptFrom, CPoint ptTo);
640
650 virtual CSize DrawCollapsedBitmap(CDC* pDC, const CXTPGridRow* pRow, CRect& rcBitmap);
651
673 virtual int DrawBitmap(CDC* pDC, CXTPGridControl* pControl, CRect rcColumn, int iImage);
674
686 virtual int DrawColumnIcon(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn, CRect rcIcon,
687 int iIcon);
688
698 virtual CSize DrawGlyph(CDC* pDC, CRect rcColumn, int iImage);
699
709 virtual CSize DrawShellIcon(CDC* pDC, CRect rcColumn, int iImage);
710
729 void EnablePreviewMode(BOOL bIsPreviewMode);
730
737 BOOL IsPreviewMode() const;
738
745 CFont* GetTextFont();
746
760 int SetMaxPreviewLines(int nMaxLines);
761
768 int GetMaxPreviewLines();
769
791 int GetPreviewLinesCount(CDC* pDC, CRect& rcText, const CString& strText);
792
802 BOOL IsGridVisible(BOOL bVertical) const;
803
813 BOOL IsGridVisible(XTPGridOrientation orientation) const;
814
823 void SetColumnStyle(XTPGridColumnStyle columnStyle);
824
834 XTPGridColumnStyle GetColumnStyle() const;
835
844 void SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor);
845
855 COLORREF GetColumnOffice2007CustomThemeBaseColor() const;
856
864 void SetTextFont(LOGFONT& lf);
865
873 void SetCaptionFont(LOGFONT& lf);
874
883 void SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom);
884
891 virtual void DrawInplaceButton(CDC* pDC, CXTPGridInplaceButton* pButton);
892
901 virtual BOOL DrawInplaceComboButton(CDC* pDC, CRect* pRc);
902
911 virtual BOOL DrawInplaceExpandButton(CDC* pDC, CRect* pRc);
912
921 virtual BOOL DrawInplaceSpinButton(CDC* pDC, CRect* pRc);
922
933 virtual void DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
934 XTP_GRIDRECORDITEM_METRICS* pMetrics, CRect rcItem,
935 CSize sizeGlyph);
936
945 virtual void DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs, CRect& rcItem, int nImage);
946
955 virtual void DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
956 XTP_GRIDRECORDITEM_METRICS* pMetrics);
957
965 virtual void DrawRowNumber(CDC* pDC, CRect rcNumber, CXTPGridRow* pRow);
966
975 virtual void DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
976 CXTPGridRecordItemControl* pControl, CRect& rcItem);
977
987 BOOL IsFixedRowHeight() const;
988
997 void SetFixedRowHeight(BOOL bFixedRowHeight);
998
1006 BOOL IsColumnWidthWYSIWYG() const;
1007
1015 BOOL IsLastColumnWidthWYSIWYG() const;
1016
1024 BOOL IsShowWYSIWYGMarkers() const;
1025
1031 void ShowWYSIWYGMarkers(BOOL bSet);
1032
1039 void SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG);
1040
1047 void SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG);
1048
1059 BOOL IsFixedInplaceButtonHeight() const;
1060
1070 void SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight);
1071
1081 int GetFreezeColsDividerStyle() const;
1082
1091 void SetFreezeColsDividerStyle(int nStyle);
1092
1102 virtual BOOL OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs);
1103
1113 virtual void DrawNoGroupByText(CDC* pDC, CRect rcItem);
1114
1123 BOOL IsDrawGridForEmptySpace() const;
1124
1131 void SetDrawGridForEmptySpace(BOOL bDrawGrid);
1132
1140 BOOL IsPrintGroupRowIcon() const;
1141
1148 void SetPrintGroupRowIcon(BOOL bDraw);
1149
1157 BOOL IsColumnPlusMinusSign() const;
1158
1165 void SetColumnPlusMinusSign(BOOL bDraw);
1166
1167 CXTPGridBorder* GetDefaultItemBorder() const;
1168
1169 CXTPGridBorder* GetItemBorder(const CXTPGridRecordItem* pItem) const;
1170
1171 virtual int DrawTrackBlock(CDC* pDC, CRect rc, BOOL bSelected, CXTPTrackBlock* pTrackBlock)
1172 {
1173 _ASSERTE(FALSE);
1174 UNREFERENCED_PARAMETER(pDC);
1175 UNREFERENCED_PARAMETER(rc);
1176 UNREFERENCED_PARAMETER(bSelected);
1177 UNREFERENCED_PARAMETER(pTrackBlock);
1178 return 0;
1179 };
1180
1181# if XTP_GRID_DEPRECATED()
1182
1192 XTPGridLineStyle GetGridStyle(BOOL bVertical) const;
1193
1195 _XTP_DEPRECATED_IN_FAVOR(GetGridStyle)
1196 XTPGridLineStyle GetReportStyle(BOOL bVertical) const;
1217 void SetGridStyle(BOOL bVertical, XTPGridLineStyle lineStyle);
1218
1220 _XTP_DEPRECATED_IN_FAVOR(SetGridStyle)
1221 void SetReportStyle(BOOL bVertical, XTPGridLineStyle lineStyle);
1230 COLORREF GetGridColor() const;
1231
1233 _XTP_DEPRECATED_IN_FAVOR(GetGridColor)
1234 COLORREF GetReportColor() const;
1251 COLORREF SetGridColor(COLORREF clrGridLine);
1252
1254 _XTP_DEPRECATED_IN_FAVOR(SetGridColor)
1255 COLORREF SetReportColor(COLORREF clrGridLine);
1258# endif
1259
1260protected:
1284 virtual void DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
1285 XTP_GRIDRECORDITEM_METRICS* pMetrics, const CString& strText,
1286 CRect rcItem, int nFlag, int& nCharCounter, int& nHyperlinkCounter);
1287
1308 virtual int DrawString(int* pnCurrDrawPos, CDC* pDC, const CString& strDraw, CRect rcDraw,
1309 UINT nFormat);
1310
1322 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
1323 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
1324 CXTPGridHeader* pHeader = NULL);
1325
1326 virtual void DrawPlainColumnBackground(CDC* /*pDC*/, CRect /*rcColumn*/);
1327
1328protected:
1342 virtual void DrawGridPattern(CDC* pDC, CBrush* pBrush, CRect rc, const void* pPattern,
1343 COLORREF clr, BOOL bUpdateBrush);
1357 virtual void DrawGridPattern(CDC* pDC, CXTPBrush* pBrush, CRect rc, const void* pPattern,
1358 COLORREF clr, BOOL bUpdateBrush);
1359
1372 virtual void DrawGridPattern(CDC* pDC, CBrush* pBrush, CRect rc, const void* pPattern,
1373 COLORREF clr);
1374
1381 virtual void DrawInplaceButtonFrame(CDC* pDC, CXTPGridInplaceButton* pButton);
1382
1391 virtual BOOL DrawInplaceButtonIcon(CDC* pDC, CXTPGridInplaceButton* pButton);
1392
1402 virtual int CalcColumnHeight(CDC* pDC, CXTPGridColumn* pColumn, int nTotalWidth = 0);
1403
1418 virtual void DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
1419 XTP_GRIDRECORDITEM_METRICS* pMetrics, const CString& strText,
1420 CRect rcItem, BOOL bWordBreak = TRUE);
1421
1437 virtual void DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
1438 XTP_GRIDRECORDITEM_METRICS* pMetrics, const CString& strText,
1439 CRect rcItem, int nStartPos, int nEndPos, int nActualWidth);
1440
1441public:
1454 virtual int CalculateRowHeight(CDC* pDC, const CString& strText, int nMaxWidth,
1455 BOOL bWordBreak = TRUE);
1456
1459 virtual CRect CalculateMaxTextRect(CDC* pDC, const CString& strText, const CRect& rcMaxRect,
1460 BOOL bWordBreak = TRUE, BOOL bLimitSize = TRUE,
1461 UINT uiFlags = 0);
1462
1465protected:
1492 virtual int DrawLink(int* pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs,
1493 XTP_GRIDRECORDITEM_METRICS* pMetrics, CXTPGridHyperlink* pHyperlink,
1494 CString strText, CRect rcLink, int nFlag, BOOL bTrim = FALSE);
1495
1496 virtual void DrawWindowFrame(CDC* pDC, CRect rcWindow);
1497
1498public:
1511 void DrawSectionDivider(CDC* pDC, const CRect& rc,
1512 XTPGridSectionDividerPosition dividerPosition,
1513 XTPGridSectionDividerStyle dividerStyle,
1514 CXTPPaintManagerColor dividerColor);
1515
1526 int GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle);
1527
1535 BOOL IsUseDropMarker() const;
1536
1537 // private:
1538
1541 COLORREF MixColor(COLORREF clrLight, COLORREF clrDark, double dFactor);
1542
1543 void Line(CDC* pDC, int x, int y, int cx, int cy, CPen* pPen);
1544
1545 virtual void DrawTreeStructureLine(CDC* pDC, int x, int y, int cx, int cy, COLORREF clr);
1546
1547 virtual void ReplaceInHyperLinks(CXTPGridRecordItem* pItem, CString& rstrText, TCHAR chReplace);
1548
1551public:
1552 CXTPFont m_xtpFontText;
1553 CXTPFont m_xtpFontBoldText;
1554 CXTPFont m_xtpFontCaption;
1555 CXTPFont m_xtpFontPreview;
1557 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontText, m_xtpFontText, GetTextFontHandle);
1558 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontBoldText, m_xtpFontBoldText,
1559 GetBoldTextFontHandle);
1560 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontCaption, m_xtpFontCaption,
1561 GetCaptionFontHandle);
1562 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontPreview, m_xtpFontPreview,
1563 GetPreviewFontHandle);
1564
1565 CXTPGridHyperlinkStyle* m_pHyperlinkStyle;
1566 CXTPGridHyperlinkStyle* m_pHyperlinkHoverStyle;
1568 CXTPPaintManagerColor m_clrHighlight;
1569 CXTPPaintManagerColor m_clrBoldText;
1570 CXTPPaintManagerColor m_clrBoldTextHighlight;
1571 CXTPPaintManagerColor m_clrWindowText;
1572 CXTPPaintManagerColor m_clrHighlightText;
1573 CXTPPaintManagerColor m_clrHeaderControl;
1574 CXTPPaintManagerColor m_clrCaptionText;
1575 CXTPPaintManagerColor m_clrCaptionTextPressed;
1576 CXTPPaintManagerColor m_clrControlBack;
1577 CXTPPaintManagerColor m_clrGroupRowText;
1578 CXTPPaintManagerColor m_clrGroupShadeBack;
1580 CXTPPaintManagerColor m_clrGroupShadeText;
1582 CXTPPaintManagerColor m_clrGroupShadeBorder;
1583 CXTPPaintManagerColor m_clrGroupBoxBack;
1584 CXTPPaintManagerColor m_clrControlDark;
1586 CXTPPaintManagerColor m_clrControlLightLight;
1588 CXTPPaintManagerColor m_clrHotDivider;
1590 CXTPPaintManagerColor m_clrIndentControl;
1591 CXTPPaintManagerColor m_clrItemShade;
1592 CXTPPaintManagerColor m_clrBtnFace;
1593 CXTPPaintManagerColor m_clrBtnText;
1594 CXTPPaintManagerColor m_clrPreviewText;
1595 CXTPPaintManagerColor m_clrSelectedRow;
1596 CXTPPaintManagerColor m_clrSelectedRowText;
1597 CXTPPaintManagerColor m_clrBtnFacePressed;
1598 CXTPPaintManagerColor m_clrConnector;
1599 CXTPPaintManagerColor m_clrDisableBitmapLightest;
1601 CXTPPaintManagerColor m_clrDisableBitmapDarkest;
1604# if XTP_GRID_DEPRECATED()
1605
1616 XTPGridFixedRowsDividerStyle GetHeaderRowsDividerStyle() const;
1617
1627 void SetHeaderRowsDividerStyle(XTPGridFixedRowsDividerStyle style);
1628
1639 XTPGridFixedRowsDividerStyle GetFooterRowsDividerStyle() const;
1640
1650 void SetFooterRowsDividerStyle(XTPGridFixedRowsDividerStyle style);
1651
1652 __declspec(property(get = GetHeaderRowsDividerStyle,
1653 put = SetHeaderRowsDividerStyle)) XTPGridFixedRowsDividerStyle
1654 m_HeaderRowsDividerStyle;
1656 __declspec(property(get = GetFooterRowsDividerStyle,
1657 put = SetFooterRowsDividerStyle)) XTPGridFixedRowsDividerStyle
1658 m_FooterRowsDividerStyle;
1660# endif // XTP_GRID_DEPRECATED()
1661
1662# if XTP_GRID_DEPRECATED()
1663
1664 CXTPPaintManagerColor GetHeaderRowsDividerColor() const;
1665 void SetHeaderRowsDividerColor(CXTPPaintManagerColor clrDivider);
1666
1667 CXTPPaintManagerColor GetFooterRowsDividerColor() const;
1668 void SetFooterRowsDividerColor(CXTPPaintManagerColor clrDivider);
1669
1670 __declspec(property(get = GetHeaderRowsDividerColor, put = SetHeaderRowsDividerColor))
1671 CXTPPaintManagerColor m_clrHeaderRowsDivider;
1672
1673 __declspec(property(get = GetFooterRowsDividerColor, put = SetFooterRowsDividerColor))
1674 CXTPPaintManagerColor m_clrFooterRowsDivider;
1675
1676 __declspec(property(get = GetGridColor, put = SetGridColor)) COLORREF m_clrGridLine;
1677# endif
1678
1679 CXTPPaintManagerColorGradient m_grcGradientColumn;
1681 CXTPPaintManagerColorGradient m_grcGradientColumnHot;
1683 CXTPPaintManagerColorGradient m_grcGradientColumnPushed;
1685 CXTPPaintManagerColor m_clrGradientColumnShadow;
1687 CXTPPaintManagerColor m_clrGradientColumnSeparator;
1689 CXTPPaintManagerColor m_crlNoGroupByText;
1691 CXTPPaintManagerColor m_clrFreezeColsDivider;
1692 COLORREF m_clrColumnOffice2007CustomTheme;
1694 COLORREF m_clrFormulaSum;
1695 COLORREF m_clrFormulaSubSum;
1697 COLORREF m_clrAlternativeBackground;
1698 BOOL m_bUseAlternativeBackground;
1700 BOOL m_bAllowMergeCells;
1702 int m_nTextIndentForGroupRowsWithNoIcon;
1705 int m_nTreeIndent;
1706 int m_nTreeStructureStyle;
1707 int m_nTreeTextIndentRowParent;
1708 int m_nTreeTextIndentRowChildren;
1709 int m_nTreeTextIndent;
1711 int m_nTreeTextIndentGroupRow;
1713 BOOL m_bGroupRowTextBold;
1715 BOOL m_bShadeGroupHeadings;
1716 BOOL m_bShadeSortColumn;
1718 BOOL m_bHotTracking;
1719 BOOL m_bInvertColumnOnClick;
1721 CString m_strNoItems;
1723 CString m_strSortBy;
1725 CString m_strIncreasing;
1727 CString m_strDecreasing;
1729 CString m_strNoGroupBy;
1731 CString m_strNoFieldsAvailable;
1733 CString m_strExpand;
1735 CString m_strCollapse;
1737 BOOL m_bHideSelection;
1739 BOOL m_bPrintSortTriangle;
1741 __declspec(property(get = GetDrawSortTriangleAlways,
1742 put = SetDrawSortTriangleAlways)) BOOL m_bDrawSortTriangleAlways;
1743 _XTP_DEPRECATED_IN_FAVOR(m_bPrintSortTriangle)
1744 BOOL GetDrawSortTriangleAlways() const;
1745
1746 _XTP_DEPRECATED_IN_FAVOR(m_bPrintSortTriangle)
1747 void SetDrawSortTriangleAlways(BOOL bValue);
1750 XTPGridDrawSortTriangleStyle m_DrawSortTriangleStyle;
1751 // xtpGridDrawSortTriangleAlways - the sort triangle is displayed in the column header when a
1752 // column is sorted and the caption will cut will ellipsis; xtpGridDrawSortTriangleDefault -
1753 // the sort triangle will be removed when the column size is too small to display the full
1754 // caption and triangle; xtpGridDrawSortTriangleNever - the sort triangle is never used.
1755 BOOL m_bUseColumnTextAlignment; // TRUE to draw caption text accordingly to its alignment.
1756
1757 BOOL m_bRevertAlignment;
1758 BOOL m_bUseEditTextAlignment;
1761 BOOL m_bShowLockIcon;
1762 BOOL m_bUseShellIcon;
1763 int m_iRecOrRowStart;
1764 BOOL m_bRecOrRowNum;
1767 BOOL m_bMakeUpper;
1769 XTPGridTreeStructureStyle m_treeStructureStyle;
1771 CRect m_rcPreviewIndent;
1772 int m_nFixedColumnsIndent;
1773 BOOL m_bMoveScrollbarOnFixedColumnsIndent;
1776 BOOL m_bThemedInplaceButtons;
1777 BOOL m_bBaseTreeIndent;
1779 CUIntArray m_arStartCol;
1781 int m_PrintPageWidth;
1782 BOOL m_bPrintVirtualPageNumber;
1783 BOOL m_bPrintPageRectangle;
1784 int m_RecordNumberWidth;
1785 BOOL m_bForceDynamicMarkupForCell;
1786 BOOL m_bForceShowDropMarker;
1789 BOOL m_bShowNonActiveInPlaceButton;
1791 BOOL m_bPrintWatermark;
1792 BOOL m_bUseGroupRowSelectionState;
1793 BOOL m_bForceShowTooltip;
1794 BOOL m_bCleanTooltip;
1795 BOOL m_bGrayIfDisable;
1796 int m_nRowHeightDefault;
1797 BOOL m_bCompactText;
1799 BOOL m_bUseDropMarker;
1801 BOOL m_bSortTriangleOffsetFromRight;
1802 int m_nTreeColumnLineLength;
1804 int m_nBaseParentRecordIndent;
1807protected:
1808 int m_nRowHeight;
1809 int m_nHeaderHeight;
1810 int m_nFooterHeight;
1811 int m_nGroupGridLineHeight;
1813 CXTPImageManager* m_pGlyphs;
1814 BOOL m_bIsPreviewMode;
1815 int m_nResizingWidth;
1816 int m_nMaxPreviewLines;
1817 CSize m_szGlyph;
1819 CXTPBrush m_xtpBrushTreeStructure;
1820 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushTreeStructure, m_xtpBrushTreeStructure,
1821 GetTreeStructureBrushHandle);
1822
1823 CXTPBrush m_xtpBrushGroupGridLineStyle;
1824 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushGroupGridLineStyle,
1825 m_xtpBrushGroupGridLineStyle,
1826 GetGroupGridLineStyleBrushHandle);
1827
1828 int m_nFreezeColsDividerStyle;
1830 BOOL m_bFixedRowHeight;
1831 BOOL m_bColumnWidthWYSIWYG;
1832 BOOL m_bShowWYSIWYGMarkers;
1833 BOOL m_bLastColumnWidthWYSIWYG;
1834 BOOL m_bDrawGridForEmptySpace;
1836 BOOL m_bPrintGroupRowIcon;
1837 BOOL m_bColumnPlusMinusSign;
1840 BOOL m_bFixedInplaceButtonHeight;
1842 XTPGridGridStyle m_nGroupGridLineStyle;
1843 XTPGridColumnStyle m_columnStyle;
1845 CXTPGridBorder* m_pBorder;
1846
1847 CXTPWinThemeWrapper* m_themeHeader;
1848 CXTPWinThemeWrapper* m_themeButton;
1849 CXTPWinThemeWrapper* m_themeCombo;
1850 CXTPWinThemeWrapper* m_themeSpin;
1852# ifdef _XTP_INCLUDE_CONTROLS
1853 void SetControlsTheme(int eTheme);
1855 CXTPComboBox* m_pCombo;
1856 BOOL m_bUseThemedControls;
1857# else
1858 CXTPExcludedMemberPadding<CXTPComboBox*> m_pCombo;
1859 CXTPExcludedMemberPadding<BOOL> m_bUseThemedControls;
1860# endif
1861
1862 CXTPGridControl* m_pControl;
1864 CXTPMarkupUIElement* m_pMarkupUIElement_NoGroupBy;
1865 CString m_strMarkupUIElement_NoGroupBy;
1867 void DrawPattern(CDC* pDC, XTPGridLineStyle lineStyle, XTPGridOrientation orientation,
1868 CRect rcLine);
1869 void CreateLineStyleBrushes();
1870
1871 CXTPBrush m_xtpBrushDotsSmallH;
1872 CXTPBrush m_xtpBrushDotsLargeH;
1873 CXTPBrush m_xtpBrushDashH;
1874 CXTPBrush m_xtpBrushDotsSmallV;
1875 CXTPBrush m_xtpBrushDotsLargeV;
1876 CXTPBrush m_xtpBrushDashV;
1877 CXTPBrush m_xtpBrushVeriticalGrid;
1878 CXTPBrush m_xtpBrushHorizontalGrid;
1880 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushDotsSmallH, m_xtpBrushDotsSmallH,
1881 GetDotsSmallHBrushHandle);
1882 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushDotsLargeH, m_xtpBrushDotsLargeH,
1883 GetDotsLargeHBrushHandle);
1884 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushDashH, m_xtpBrushDashH,
1885 GetDashHBrushHandle);
1886 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushDotsSmallV, m_xtpBrushDotsSmallV,
1887 GetDotsSmallVBrushHandle);
1888 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushDotsLargeV, m_xtpBrushDotsLargeV,
1889 GetDotsLargeVBrushHandle);
1890 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushDashV, m_xtpBrushDashV,
1891 GetDashVBrushHandle);
1892 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushVeriticalGrid, m_xtpBrushVeriticalGrid,
1893 GetVeriticalGridBrushHandle);
1894 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CBrush, m_brushHorizontalGrid, m_xtpBrushHorizontalGrid,
1895 GetHorizontalGridBrushHandle);
1896
1897 XTPGridGridStyle m_nGridLineStylePreviousV;
1899 XTPGridGridStyle m_nGridLineStylePreviousH;
1902# ifdef _XTP_ACTIVEX
1904 DECLARE_DISPATCH_MAP()
1905 DECLARE_INTERFACE_MAP()
1906
1907 DECLARE_OLETYPELIB_EX(CXTPGridPaintManager);
1908
1909 afx_msg int OleGetVerticalGridStyle();
1910 afx_msg void OleSetVerticalGridStyle(int nGridStyle);
1911 afx_msg int OleGetHorizontalGridStyle();
1912 afx_msg void OleSetHorizontalGridStyle(int nGridStyle);
1913 afx_msg void OleRefreshMetrics();
1914 afx_msg void OleSetColumnStyle();
1915
1916 afx_msg int OleGetHeaderRowsDividerStyle();
1917 afx_msg void OleSetHeaderRowsDividerStyle(int nDividerStyle);
1918 afx_msg int OleGetFooterRowsDividerStyle();
1919 afx_msg void OleSetFooterRowsDividerStyle(int nDividerStyle);
1920
1921 afx_msg LPFONTDISP OleGetTextFont();
1922 afx_msg void OleSetTextFont(LPFONTDISP pFontDisp);
1923 afx_msg LPDISPATCH OleGetGlyphs();
1924 afx_msg LPFONTDISP OleGetCaptionFont();
1925 afx_msg void OleSetCaptionFont(LPFONTDISP pFontDisp);
1926 afx_msg LPFONTDISP OleGetPreviewTextFont();
1927 afx_msg void OleSetPreviewTextFont(LPFONTDISP pFontDisp);
1928
1929 afx_msg LPDISPATCH OleGetHyperlinkStyle();
1930 afx_msg LPDISPATCH OleGetHyperlinkHoverStyle();
1931
1932 afx_msg int OleGetHeaderHeight();
1933 afx_msg void OleSetHeaderHeight(int nHeaderHeight);
1934
1935 XTP_DECLARE_PROPERTY(BackColor, COLORREF);
1936 XTP_DECLARE_PROPERTY(ForeColor, COLORREF);
1937 XTP_DECLARE_PROPERTY(GridLineColor, COLORREF);
1938 XTP_DECLARE_PROPERTY(ShadeSortColor, COLORREF);
1939 XTP_DECLARE_PROPERTY(GroupIndentColor, COLORREF);
1940 XTP_DECLARE_PROPERTY(GroupShadeBackColor, COLORREF);
1941 XTP_DECLARE_PROPERTY(GroupShadeForeColor, COLORREF);
1942 XTP_DECLARE_PROPERTY(GroupShadeBorderColor, COLORREF);
1943 XTP_DECLARE_PROPERTY(GroupForeColor, COLORREF);
1944 XTP_DECLARE_PROPERTY(CaptionBackColor, COLORREF);
1945 XTP_DECLARE_PROPERTY(CaptionForeColor, COLORREF);
1946 XTP_DECLARE_PROPERTY(GroupBoxBackColor, COLORREF);
1947 XTP_DECLARE_PROPERTY(GroupByNoItemsTextColor, COLORREF);
1948 XTP_DECLARE_PROPERTY(HighlightBackColor, COLORREF);
1949 XTP_DECLARE_PROPERTY(HighlightForeColor, COLORREF);
1950 XTP_DECLARE_PROPERTY(BoldTextHighlight, COLORREF);
1951 XTP_DECLARE_PROPERTY(BoldText, COLORREF);
1952 XTP_DECLARE_PROPERTY(PreviewTextColor, COLORREF);
1953 XTP_DECLARE_PROPERTY(SelectedRowBackColor, COLORREF);
1954 XTP_DECLARE_PROPERTY(SelectedRowForeColor, COLORREF);
1955
1956 XTP_DECLARE_PROPERTY(CaptionBackGradientColorLight, COLORREF);
1957 XTP_DECLARE_PROPERTY(CaptionBackGradientColorDark, COLORREF);
1958 XTP_DECLARE_PROPERTY(ColumnHotGradientColorLight, COLORREF);
1959 XTP_DECLARE_PROPERTY(ColumnHotGradientColorDark, COLORREF);
1960 XTP_DECLARE_PROPERTY(ColumnPushedGradientColorLight, COLORREF);
1961 XTP_DECLARE_PROPERTY(ColumnPushedGradientColorDark, COLORREF);
1962 XTP_DECLARE_PROPERTY(ColumnShadowGradient, COLORREF);
1963
1964 XTP_DECLARE_PROPERTY(FreezeColsDividerColor, COLORREF);
1965 XTP_DECLARE_PROPERTY(HotDividerColor, COLORREF);
1966 XTP_DECLARE_PROPERTY(HeaderRowsDividerColor, COLORREF);
1967 XTP_DECLARE_PROPERTY(FooterRowsDividerColor, COLORREF);
1968 XTP_DECLARE_PROPERTY(ColumnOffice2007CustomThemeBaseColor, COLORREF);
1969 // DECLARE_PROPERTY_UN(HyperLinkColor, COLORREF);
1970 XTP_DECLARE_PROPERTY(FormulaSumColor, COLORREF);
1971 XTP_DECLARE_PROPERTY(FormulaSubSumColor, COLORREF);
1972 XTP_DECLARE_PROPERTY(AlternativeBackgroundColor, COLORREF);
1973
1974 XTP_DECLARE_PROPERTY(TextIndentForGroupRowsWithNoIcon, int);
1975 XTP_DECLARE_PROPERTY(SortTriangleOffsetFromRight, BOOL);
1976 XTP_DECLARE_PROPERTY(TreeColumnLineLength, int);
1977 XTP_DECLARE_PROPERTY(BaseParentRecordIndent, int);
1978
1979 XTP_DECLARE_PROPERTY(GroupGridLineHeight, int);
1980
1982# endif
1983};
1984
1985AFX_INLINE BOOL CXTPGridPaintManager::IsUseDropMarker() const
1986{
1987 return m_bUseDropMarker;
1988}
1989
1990AFX_INLINE int CXTPGridPaintManager::GetHeaderHeight()
1991{
1992 return m_nHeaderHeight;
1993}
1994
1995AFX_INLINE void CXTPGridPaintManager::EnablePreviewMode(BOOL bIsPreviewMode)
1996{
1997 m_bIsPreviewMode = bIsPreviewMode;
1998}
1999
2000AFX_INLINE BOOL CXTPGridPaintManager::IsPreviewMode() const
2001{
2002 return m_bIsPreviewMode;
2003}
2004
2005AFX_INLINE CFont* CXTPGridPaintManager::GetTextFont()
2006{
2007 return &m_xtpFontText;
2008}
2009
2010AFX_INLINE int CXTPGridPaintManager::SetMaxPreviewLines(int nMaxLines)
2011{
2012 int nOldMaxLines = m_nMaxPreviewLines;
2013 m_nMaxPreviewLines = nMaxLines;
2014 return nOldMaxLines;
2015}
2016
2017AFX_INLINE int CXTPGridPaintManager::GetMaxPreviewLines()
2018{
2019 return m_nMaxPreviewLines;
2020}
2021
2022AFX_INLINE CXTPImageManager* CXTPGridPaintManager::GetGlyphs() const
2023{
2024 return m_pGlyphs;
2025}
2026
2027AFX_INLINE BOOL CXTPGridPaintManager::IsFixedRowHeight() const
2028{
2029 return m_bFixedRowHeight;
2030}
2031
2032AFX_INLINE BOOL CXTPGridPaintManager::IsLastColumnWidthWYSIWYG() const
2033{
2034 return m_bLastColumnWidthWYSIWYG;
2035}
2036
2037AFX_INLINE BOOL CXTPGridPaintManager::IsColumnWidthWYSIWYG() const
2038{
2039 return m_bColumnWidthWYSIWYG;
2040}
2041
2042AFX_INLINE BOOL CXTPGridPaintManager::IsShowWYSIWYGMarkers() const
2043{
2044 return m_bShowWYSIWYGMarkers;
2045}
2046
2047AFX_INLINE void CXTPGridPaintManager::ShowWYSIWYGMarkers(BOOL bSet)
2048{
2049 m_bShowWYSIWYGMarkers = bSet;
2050}
2051
2052AFX_INLINE void CXTPGridPaintManager::SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG)
2053{
2054 m_bColumnWidthWYSIWYG = bColumnWidthWYSIWYG;
2055}
2056
2057AFX_INLINE void CXTPGridPaintManager::SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG)
2058{
2059 m_bLastColumnWidthWYSIWYG = bColumnWidthWYSIWYG;
2060}
2061
2062AFX_INLINE BOOL CXTPGridPaintManager::IsFixedInplaceButtonHeight() const
2063{
2064 return m_bFixedInplaceButtonHeight;
2065}
2066
2067AFX_INLINE void CXTPGridPaintManager::SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight)
2068{
2069 m_bFixedInplaceButtonHeight = bFixedInplaceButtonHeight;
2070}
2071
2072AFX_INLINE int CXTPGridPaintManager::GetFreezeColsDividerStyle() const
2073{
2074 return m_nFreezeColsDividerStyle;
2075}
2076
2077AFX_INLINE void CXTPGridPaintManager::SetFreezeColsDividerStyle(int nStyle)
2078{
2079 m_nFreezeColsDividerStyle = nStyle;
2080}
2081
2082AFX_INLINE XTPGridColumnStyle CXTPGridPaintManager::GetColumnStyle() const
2083{
2084 return m_columnStyle;
2085}
2086
2087AFX_INLINE BOOL CXTPGridPaintManager::IsColumnPlusMinusSign() const
2088{
2089 return m_bColumnPlusMinusSign;
2090}
2091
2092AFX_INLINE void CXTPGridPaintManager::SetColumnPlusMinusSign(BOOL bDraw)
2093{
2094 m_bColumnPlusMinusSign = bDraw;
2095}
2096
2097AFX_INLINE BOOL CXTPGridPaintManager::IsPrintGroupRowIcon() const
2098{
2099 return m_bPrintGroupRowIcon;
2100}
2101
2102AFX_INLINE void CXTPGridPaintManager::SetPrintGroupRowIcon(BOOL bDraw)
2103{
2104 m_bPrintGroupRowIcon = bDraw;
2105}
2106
2107AFX_INLINE BOOL CXTPGridPaintManager::IsDrawGridForEmptySpace() const
2108{
2109 return m_bDrawGridForEmptySpace;
2110}
2111
2112AFX_INLINE void CXTPGridPaintManager::SetDrawGridForEmptySpace(BOOL bDrawGrid)
2113{
2114 m_bDrawGridForEmptySpace = bDrawGrid;
2115}
2116
2117AFX_INLINE void CXTPGridPaintManager::SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor)
2118{
2119 m_clrColumnOffice2007CustomTheme = clrBaseColor;
2120 RefreshMetrics();
2121}
2122
2123AFX_INLINE COLORREF CXTPGridPaintManager::GetColumnOffice2007CustomThemeBaseColor() const
2124{
2125 return m_clrColumnOffice2007CustomTheme;
2126}
2127
2128AFX_INLINE void CXTPGridPaintManager::SetGridControl(CXTPGridControl* pControl)
2129{
2130 m_pControl = pControl;
2131}
2133AFX_INLINE void CXTPGridPaintManager::SetReportControl(CXTPGridControl* pControl)
2134{
2135 SetGridControl(pControl);
2136}
2137
2138AFX_INLINE BOOL CXTPGridPaintManager::GetDrawSortTriangleAlways() const
2139{
2140 return m_bPrintSortTriangle;
2141}
2142
2143AFX_INLINE void CXTPGridPaintManager::SetDrawSortTriangleAlways(BOOL bValue)
2144{
2145 m_bPrintSortTriangle = bValue;
2146}
2147
2148AFX_INLINE void CXTPGridPaintManager::SetReportStyle(BOOL bVertical, XTPGridLineStyle lineStyle)
2149{
2150 SetGridStyle(bVertical, lineStyle);
2151}
2152
2153AFX_INLINE COLORREF CXTPGridPaintManager::SetReportColor(COLORREF clrGridLine)
2154{
2155 return SetGridColor(clrGridLine);
2156}
2157
2158AFX_INLINE XTPGridLineStyle CXTPGridPaintManager::GetReportStyle(BOOL bVertical) const
2159{
2160 return GetGridStyle(bVertical);
2161}
2162
2163AFX_INLINE COLORREF CXTPGridPaintManager::GetReportColor() const
2164{
2165 return GetGridColor();
2166}
2167
2168# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
2169#endif //#if !defined(__XTPGRIDPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridTreeStructureStyle
XTPGridTreeStructureStyle
Represent the style of lines used to draw a hierarchical tree structure.
Definition XTPGridDefines.h:213
XTPGridLineStyle
XTPGridLineStyle
Represents predefined grid line styles.
Definition XTPGridDefines.h:126
XTPGridDrawSortTriangleStyle
XTPGridDrawSortTriangleStyle
Represent the Grid Draw Sort Triangle logic.
Definition XTPGridDefines.h:268
XTPGridColumnStyle
XTPGridColumnStyle
Represents predefined column styles.
Definition XTPGridDefines.h:183
XTPGridOrientation
XTPGridOrientation
Enumeration of orientations.
Definition XTPGridDefines.h:108
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPExcludedMemberPadding
The CXTPExcludedMemberPadding type is used for declaring padding members for the members that were ex...
Definition XTPSystemHelpers.h:1855
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridGroupRow
This class represents a 'group row' of the Grid control view.
Definition XTPGridGroupRow.h:49
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridHyperlink
This class represents hyperlinks.
Definition XTPGridHyperlink.h:112
CXTPGridHyperlinkStyle
This class stores the anchor styles.
Definition XTPGridHyperlink.h:40
CXTPGridInplaceButton
CXTPGridInplaceButton is a CXTPGridInplaceControl derived class that represents a combo button and ex...
Definition XTPGridInplaceControls.h:220
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridPaintManager::m_nTreeTextIndentRowParent
int m_nTreeTextIndentRowParent
Text indent, in pixels, for rows with children.
Definition XTPGridPaintManager.h:1707
CXTPGridPaintManager::DrawColumnText
virtual void DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
CXTPGridPaintManager::GetPreviewLinesCount
int GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText)
Calculates the number of lines required to draw a specified preview text string, taking into account ...
CXTPGridPaintManager::FillIndent
virtual void FillIndent(CDC *pDC, CRect rcRow)
Fills an indent area by its background.
CXTPGridPaintManager::DrawItemCaption
virtual void DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws an item caption.
CXTPGridPaintManager::OnDrawAction
virtual BOOL OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Override this method to perform custom activities for the item before processing it.
CXTPGridPaintManager::DrawColumnFooter
virtual void DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn)
Draws the column footer with all related attributes (e.g.
CXTPGridPaintManager::m_clrFreezeColsDivider
CXTPPaintManagerColor m_clrFreezeColsDivider
Freeze Columns Divider color.
Definition XTPGridPaintManager.h:1691
CXTPGridPaintManager::FillItemShade
virtual void FillItemShade(CDC *pDC, CRect rcItem)
Fills an item shade by its background if necessary.
CXTPGridPaintManager::m_bLastColumnWidthWYSIWYG
BOOL m_bLastColumnWidthWYSIWYG
TRUE if last column width WYSIWYG mode used.
Definition XTPGridPaintManager.h:1833
CXTPGridPaintManager::m_nRowHeightDefault
int m_nRowHeightDefault
The default row height.
Definition XTPGridPaintManager.h:1796
CXTPGridPaintManager::IsLastColumnWidthWYSIWYG
BOOL IsLastColumnWidthWYSIWYG() const
Determines if the paint manager supports last column width WYSIWYG mode.
Definition XTPGridPaintManager.h:2032
CXTPGridPaintManager::m_crlNoGroupByText
CXTPPaintManagerColor m_crlNoGroupByText
A color for "No items" text in GroupBy area (see m_strNoGroupBy member).
Definition XTPGridPaintManager.h:1689
CXTPGridPaintManager::~CXTPGridPaintManager
virtual ~CXTPGridPaintManager()
Default CXTPGridPaintManager destructor, handles member items deallocation.
CXTPGridPaintManager::m_pHyperlinkHoverStyle
CXTPGridHyperlinkStyle * m_pHyperlinkHoverStyle
Style for hovered links.
Definition XTPGridPaintManager.h:1566
CXTPGridPaintManager::m_nGroupGridLineStyle
XTPGridGridStyle m_nGroupGridLineStyle
Current style for group row grid lines.
Definition XTPGridPaintManager.h:1842
CXTPGridPaintManager::m_strMarkupUIElement_NoGroupBy
CString m_strMarkupUIElement_NoGroupBy
The no group by markup UI element string.
Definition XTPGridPaintManager.h:1865
CXTPGridPaintManager::GetHeaderHeight
virtual int GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal header height.
CXTPGridPaintManager::m_themeSpin
CXTPWinThemeWrapper * m_themeSpin
Spin in-place button theme wrapper.
Definition XTPGridPaintManager.h:1850
CXTPGridPaintManager::m_nFixedColumnsIndent
int m_nFixedColumnsIndent
Fixed Column total width.
Definition XTPGridPaintManager.h:1772
CXTPGridPaintManager::m_bColumnWidthWYSIWYG
BOOL m_bColumnWidthWYSIWYG
TRUE if columns width WYSIWYG mode used.
Definition XTPGridPaintManager.h:1831
CXTPGridPaintManager::m_clrGroupRowText
CXTPPaintManagerColor m_clrGroupRowText
Row text color.
Definition XTPGridPaintManager.h:1577
CXTPGridPaintManager::GetFreezeColsDividerStyle
int GetFreezeColsDividerStyle() const
Gets the style of the freeze columns divider line.
Definition XTPGridPaintManager.h:2072
CXTPGridPaintManager::m_bFixedInplaceButtonHeight
BOOL m_bFixedInplaceButtonHeight
TRUE if fixed in-place button height is used.
Definition XTPGridPaintManager.h:1840
CXTPGridPaintManager::m_clrBoldText
CXTPPaintManagerColor m_clrBoldText
Grid items bold text color.
Definition XTPGridPaintManager.h:1569
CXTPGridPaintManager::m_grcGradientColumnPushed
CXTPPaintManagerColorGradient m_grcGradientColumnPushed
Pushed Color of column used with xtpGridColumnOffice2003 style.
Definition XTPGridPaintManager.h:1683
CXTPGridPaintManager::m_bInvertColumnOnClick
BOOL m_bInvertColumnOnClick
TRUE to invert column on click.
Definition XTPGridPaintManager.h:1719
CXTPGridPaintManager::m_bHideSelection
BOOL m_bHideSelection
TRUE when hiding Grid control's selection by drawing selected items as others, FALSE otherwise.
Definition XTPGridPaintManager.h:1737
CXTPGridPaintManager::SetInplaceButtonHeight
void SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight)
Sets if the paint manager supports fixed or variable in-place button height.
Definition XTPGridPaintManager.h:2067
CXTPGridPaintManager::m_bBaseTreeIndent
BOOL m_bBaseTreeIndent
TRUE to add Extra Tree indentation to cover initial TreeColumn.
Definition XTPGridPaintManager.h:1777
CXTPGridPaintManager::FindRowAdjacentToMergedEx
BOOL FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward)
Searches the topmost or bottommost row depending on the height of the current row.
CXTPGridPaintManager::m_xtpBrushVeriticalGrid
CXTPBrush m_xtpBrushVeriticalGrid
Brush to draw vertical grid lines.
Definition XTPGridPaintManager.h:1877
CXTPGridPaintManager::SetTextFont
void SetTextFont(LOGFONT &lf)
Creates and sets the default text font.
CXTPGridPaintManager::m_rcPreviewIndent
CRect m_rcPreviewIndent
Preview indentation.
Definition XTPGridPaintManager.h:1771
CXTPGridPaintManager::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPGridPaintManager::m_strCollapse
CString m_strCollapse
A string which contains customized "Collapse" text for displaying in tooltip.
Definition XTPGridPaintManager.h:1735
CXTPGridPaintManager::DrawNoGroupByText
virtual void DrawNoGroupByText(CDC *pDC, CRect rcItem)
Draws the "No items" text message in the Group By area when there are no items inside it.
CXTPGridPaintManager::IsPreviewMode
BOOL IsPreviewMode() const
Determines if preview mode is enabled/disabled for the control.
Definition XTPGridPaintManager.h:2000
CXTPGridPaintManager::m_clrAlternativeBackground
COLORREF m_clrAlternativeBackground
Color for Alternative Row Background.
Definition XTPGridPaintManager.h:1697
CXTPGridPaintManager::SetGridControl
virtual void SetGridControl(CXTPGridControl *pControl)
Sets the associated Grid control for the paint manager.
Definition XTPGridPaintManager.h:2128
CXTPGridPaintManager::m_bPrintWatermark
BOOL m_bPrintWatermark
TRUE to print watermark.
Definition XTPGridPaintManager.h:1791
CXTPGridPaintManager::FillGroupRowMetrics
virtual void FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting)
Fills the font and color members of the metrics structure for a specified group row.
CXTPGridPaintManager::SetFreezeColsDividerStyle
void SetFreezeColsDividerStyle(int nStyle)
Sets the style for the freeze columns divider line.
Definition XTPGridPaintManager.h:2077
CXTPGridPaintManager::m_clrIndentControl
CXTPPaintManagerColor m_clrIndentControl
Color of the tree indentation area.
Definition XTPGridPaintManager.h:1590
CXTPGridPaintManager::SetColumnStyle
void SetColumnStyle(XTPGridColumnStyle columnStyle)
Sets the header style.
CXTPGridPaintManager::m_bShadeGroupHeadings
BOOL m_bShadeGroupHeadings
TRUE to show the indentation shade, FALSE otherwise.
Definition XTPGridPaintManager.h:1715
CXTPGridPaintManager::m_clrCaptionTextPressed
CXTPPaintManagerColor m_clrCaptionTextPressed
Column header text color when pressed.
Definition XTPGridPaintManager.h:1575
CXTPGridPaintManager::m_bShadeSortColumn
BOOL m_bShadeSortColumn
TRUE to show the items shade in the sorted by column, FALSE otherwise.
Definition XTPGridPaintManager.h:1716
CXTPGridPaintManager::m_clrDisableBitmapDarkest
CXTPPaintManagerColor m_clrDisableBitmapDarkest
The darkest color of bitmap which covers disabled grid.
Definition XTPGridPaintManager.h:1601
CXTPGridPaintManager::GetFooterHeight
virtual int GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0)
Calculates the optimal footer height.
CXTPGridPaintManager::m_nMaxPreviewLines
int m_nMaxPreviewLines
Restrict maximum lines for preview text.
Definition XTPGridPaintManager.h:1816
CXTPGridPaintManager::m_bMoveScrollbarOnFixedColumnsIndent
BOOL m_bMoveScrollbarOnFixedColumnsIndent
Move Scrollbar right follow FixedColumnsIndent.
Definition XTPGridPaintManager.h:1773
CXTPGridPaintManager::IsUseDropMarker
BOOL IsUseDropMarker() const
Determines if a drop marker will be used when dragging and dropping.
Definition XTPGridPaintManager.h:1985
CXTPGridPaintManager::m_bCompactText
BOOL m_bCompactText
TRUE to ignore Icon for Narrow column to show more text.
Definition XTPGridPaintManager.h:1797
CXTPGridPaintManager::m_strIncreasing
CString m_strIncreasing
A string which contains customized "Increasing" text for displaying in tooltip.
Definition XTPGridPaintManager.h:1725
CXTPGridPaintManager::SetHeaderHeight
virtual void SetHeaderHeight(int nHeight)
Sets the column header height.
CXTPGridPaintManager::DrawMultiLineText
virtual void DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE)
Draws multi-line text.
CXTPGridPaintManager::m_bMakeUpper
BOOL m_bMakeUpper
TRUE to display column header and group row text in all caps.
Definition XTPGridPaintManager.h:1767
CXTPGridPaintManager::m_nTreeTextIndentGroupRow
int m_nTreeTextIndentGroupRow
Text indent, in pixels, for group rows.
Definition XTPGridPaintManager.h:1711
CXTPGridPaintManager::m_nRowHeight
int m_nRowHeight
Grid row default height.
Definition XTPGridPaintManager.h:1808
CXTPGridPaintManager::IsShowWYSIWYGMarkers
BOOL IsShowWYSIWYGMarkers() const
Determines if the paint manager shows WYSIWYG page-end markers.
Definition XTPGridPaintManager.h:2042
CXTPGridPaintManager::GetControlBackColor
virtual COLORREF GetControlBackColor(CXTPGridControl *pControl)
Retrieves the parent Grid control's background color.
CXTPGridPaintManager::m_nFreezeColsDividerStyle
int m_nFreezeColsDividerStyle
A set of flags from XTPGridFreezeColsDividerStyle.
Definition XTPGridPaintManager.h:1828
CXTPGridPaintManager::DrawString
virtual int DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat)
Draw a simple string into rectangle.
CXTPGridPaintManager::m_nGridLineStylePreviousH
XTPGridGridStyle m_nGridLineStylePreviousH
Previous style for horizontal grid lines.
Definition XTPGridPaintManager.h:1899
CXTPGridPaintManager::SetLastColumnWidthWYSIWYG
void SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports last column width WYSIWYG mode.
Definition XTPGridPaintManager.h:2057
CXTPGridPaintManager::m_clrPreviewText
CXTPPaintManagerColor m_clrPreviewText
Preview text color.
Definition XTPGridPaintManager.h:1594
CXTPGridPaintManager::m_grcGradientColumn
CXTPPaintManagerColorGradient m_grcGradientColumn
Color of column used with xtpGridColumnOffice2003 style.
Definition XTPGridPaintManager.h:1679
CXTPGridPaintManager::m_themeHeader
CXTPWinThemeWrapper * m_themeHeader
Header theme wrapper.
Definition XTPGridPaintManager.h:1847
CXTPGridPaintManager::m_nHeaderHeight
int m_nHeaderHeight
Column header height.
Definition XTPGridPaintManager.h:1809
CXTPGridPaintManager::IsGridVisible
BOOL IsGridVisible(BOOL bVertical) const
Determines the visibility of specified grid lines.
CXTPGridPaintManager::m_clrHighlightText
CXTPPaintManagerColor m_clrHighlightText
Text color of the highlighted text.
Definition XTPGridPaintManager.h:1572
CXTPGridPaintManager::m_strExpand
CString m_strExpand
A string which contains customized "Expand" text for displaying in tooltip.
Definition XTPGridPaintManager.h:1733
CXTPGridPaintManager::m_nGridLineStylePreviousV
XTPGridGridStyle m_nGridLineStylePreviousV
Previous style for vertical grid lines.
Definition XTPGridPaintManager.h:1897
CXTPGridPaintManager::m_clrGradientColumnShadow
CXTPPaintManagerColor m_clrGradientColumnShadow
Bottom shadow of column used with xtpGridColumnOffice2003 style.
Definition XTPGridPaintManager.h:1685
CXTPGridPaintManager::DrawInplaceSpinButton
virtual BOOL DrawInplaceSpinButton(CDC *pDC, CRect *pRc)
Draws the spin button of the Grid control.
CXTPGridPaintManager::GetColumnOffice2007CustomThemeBaseColor
COLORREF GetColumnOffice2007CustomThemeBaseColor() const
Gets the header's custom theme base color for Office2007 column style.
Definition XTPGridPaintManager.h:2123
CXTPGridPaintManager::m_bPrintGroupRowIcon
BOOL m_bPrintGroupRowIcon
TRUE if printout draw collapse-expand icon for group row.
Definition XTPGridPaintManager.h:1836
CXTPGridPaintManager::GetSectionDividerHeight
int GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle)
Gets the height of the section divider.
CXTPGridPaintManager::DrawBitmap
virtual int DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage)
Draws a bitmap.
CXTPGridPaintManager::DrawInplaceButtonFrame
virtual void DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button frame.
CXTPGridPaintManager::m_bHotTracking
BOOL m_bHotTracking
TRUE to allow column hot tracking.
Definition XTPGridPaintManager.h:1718
CXTPGridPaintManager::m_clrCaptionText
CXTPPaintManagerColor m_clrCaptionText
Column header text color.
Definition XTPGridPaintManager.h:1574
CXTPGridPaintManager::SetFixedRowHeight
void SetFixedRowHeight(BOOL bFixedRowHeight)
Sets if the paint manager supports fixed or variable row height.
CXTPGridPaintManager::m_bUseGroupRowSelectionState
BOOL m_bUseGroupRowSelectionState
TRUE if use GroupSelectionState Glyph.
Definition XTPGridPaintManager.h:1792
CXTPGridPaintManager::m_bThemedInplaceButtons
BOOL m_bThemedInplaceButtons
Draw in-place buttons using current theme settings.
Definition XTPGridPaintManager.h:1776
CXTPGridPaintManager::DrawColumnIcon
virtual int DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon)
Draws an icon for a column.
CXTPGridPaintManager::GetItemHeight
int GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth)
Retrieves the height of a record item for a given width.
CXTPGridPaintManager::GetGlyphs
CXTPImageManager * GetGlyphs() const
Gets a pointer to the additional image list with glyphs.
Definition XTPGridPaintManager.h:2022
CXTPGridPaintManager::IsPrintGroupRowIcon
BOOL IsPrintGroupRowIcon() const
Determines if the group row collapse-expand icon is drawn in print mode.
Definition XTPGridPaintManager.h:2097
CXTPGridPaintManager::DrawInplaceButtonIcon
virtual BOOL DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button icon.
CXTPGridPaintManager::SetMaxPreviewLines
int SetMaxPreviewLines(int nMaxLines)
Sets the maximum number of lines of text for a preview item.
Definition XTPGridPaintManager.h:2010
CXTPGridPaintManager::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPGridPaintManager::CalculateRowHeight
virtual int CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE)
Calculates the height required for a rectangle bounding multi-line text to draw the multi-line text w...
CXTPGridPaintManager::m_clrGroupShadeBack
CXTPPaintManagerColor m_clrGroupShadeBack
Group row background color when indentation shade is enabled.
Definition XTPGridPaintManager.h:1578
CXTPGridPaintManager::DrawShellIcon
virtual CSize DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage)
Draws the shell icon.
CXTPGridPaintManager::m_nTreeColumnLineLength
int m_nTreeColumnLineLength
This is the extra line length to apply to tree column lines if there is no expand button.
Definition XTPGridPaintManager.h:1802
CXTPGridPaintManager::IsFixedInplaceButtonHeight
BOOL IsFixedInplaceButtonHeight() const
Determines if the paint manager supports fixed or variable in-place button height.
Definition XTPGridPaintManager.h:2062
CXTPGridPaintManager::m_strDecreasing
CString m_strDecreasing
A string which contains customized "Decreasing" text for displaying in tooltip.
Definition XTPGridPaintManager.h:1727
CXTPGridPaintManager::m_clrHeaderControl
CXTPPaintManagerColor m_clrHeaderControl
Background color of the grid header.
Definition XTPGridPaintManager.h:1573
CXTPGridPaintManager::m_PrintPageWidth
int m_PrintPageWidth
Width of print page (run-time)
Definition XTPGridPaintManager.h:1781
CXTPGridPaintManager::DrawColumn
virtual void DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
CXTPGridPaintManager::m_bUseAlternativeBackground
BOOL m_bUseAlternativeBackground
TRUE to use Alternative Row Background, FALSE otherwise.
Definition XTPGridPaintManager.h:1698
CXTPGridPaintManager::m_clrFormulaSum
COLORREF m_clrFormulaSum
Color for Formula Sum fields.
Definition XTPGridPaintManager.h:1694
CXTPGridPaintManager::DrawConnector
void DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo)
Draws a column connector for the Group By box.
CXTPGridPaintManager::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPGridPaintManager::m_strSortBy
CString m_strSortBy
A string which contains customized "Sort By" text for displaying in tooltip.
Definition XTPGridPaintManager.h:1723
CXTPGridPaintManager::m_bPrintSortTriangle
BOOL m_bPrintSortTriangle
TRUE to show the sort triangle in printout.
Definition XTPGridPaintManager.h:1739
CXTPGridPaintManager::m_xtpBrushHorizontalGrid
CXTPBrush m_xtpBrushHorizontalGrid
Brush to draw horizontal grid lines.
Definition XTPGridPaintManager.h:1878
CXTPGridPaintManager::FillRow
virtual void FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow)
Fills a specified row with its background color.
CXTPGridPaintManager::m_clrItemShade
CXTPPaintManagerColor m_clrItemShade
Color of the shade on sorted by column items.
Definition XTPGridPaintManager.h:1591
CXTPGridPaintManager::IsColumHotTrackingEnabled
virtual BOOL IsColumHotTrackingEnabled() const
Determines if hot tracking is enabled for the current column style.
CXTPGridPaintManager::DrawGridPattern
virtual void DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
CXTPGridPaintManager::EnablePreviewMode
void EnablePreviewMode(BOOL bIsPreviewMode)
Enables/disables preview mode for the control.
Definition XTPGridPaintManager.h:1995
CXTPGridPaintManager::FillHeaderControl
virtual void FillHeaderControl(CDC *pDC, CRect rcHeader)
Fills a column header control area by its background.
CXTPGridPaintManager::GetRowHeightEx
int GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE)
Retrieves the default row height for print mode (i.e.
CXTPGridPaintManager::m_bUseShellIcon
BOOL m_bUseShellIcon
TRUE to use the shell icon, FALSE otherwise.
Definition XTPGridPaintManager.h:1762
CXTPGridPaintManager::m_treeStructureStyle
XTPGridTreeStructureStyle m_treeStructureStyle
Tree structure style.
Definition XTPGridPaintManager.h:1769
CXTPGridPaintManager::m_nBaseParentRecordIndent
int m_nBaseParentRecordIndent
This is initial number of pixels a parent node will be indented when in a group.
Definition XTPGridPaintManager.h:1804
CXTPGridPaintManager::DrawVerticalTimeLineMarker
virtual void DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0))
Draws a vertical timeline marker.
CXTPGridPaintManager::FillFooter
virtual void FillFooter(CDC *pDC, CRect rcFooter)
Fills a column footer control area by its background.
CXTPGridPaintManager::m_nTextIndentForGroupRowsWithNoIcon
int m_nTextIndentForGroupRowsWithNoIcon
Specifies Text indent if a group row icon is not used.
Definition XTPGridPaintManager.h:1702
CXTPGridPaintManager::m_clrBtnFacePressed
CXTPPaintManagerColor m_clrBtnFacePressed
Standard button face color when pressed.
Definition XTPGridPaintManager.h:1597
CXTPGridPaintManager::m_bRevertAlignment
BOOL m_bRevertAlignment
TRUE to revert column alignments.
Definition XTPGridPaintManager.h:1757
CXTPGridPaintManager::m_clrGradientColumnSeparator
CXTPPaintManagerColor m_clrGradientColumnSeparator
Separator of column used with xtpGridColumnOffice2003 style.
Definition XTPGridPaintManager.h:1687
CXTPGridPaintManager::DrawInplaceButton
virtual void DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton)
Draws the in-place button of the Grid control.
CXTPGridPaintManager::m_clrWindowText
CXTPPaintManagerColor m_clrWindowText
Grid items default text color.
Definition XTPGridPaintManager.h:1571
CXTPGridPaintManager::m_clrGroupBoxBack
CXTPPaintManagerColor m_clrGroupBoxBack
Color of group box.
Definition XTPGridPaintManager.h:1583
CXTPGridPaintManager::DrawCollapsedBitmap
virtual CSize DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
CXTPGridPaintManager::m_xtpBrushTreeStructure
CXTPBrush m_xtpBrushTreeStructure
Brush to draw tree nodes.
Definition XTPGridPaintManager.h:1819
CXTPGridPaintManager::GetTextFont
CFont * GetTextFont()
Gets the default text font used for control items.
Definition XTPGridPaintManager.h:2005
CXTPGridPaintManager::IsColumnWidthWYSIWYG
BOOL IsColumnWidthWYSIWYG() const
Determines if the paint manager supports column width WYSIWYG mode.
Definition XTPGridPaintManager.h:2037
CXTPGridPaintManager::m_nResizingWidth
int m_nResizingWidth
The width of the column resizing marker area.
Definition XTPGridPaintManager.h:1815
CXTPGridPaintManager::m_bUseDropMarker
BOOL m_bUseDropMarker
FALSE to not draw drop marked when dragging/dropping, TRUE by default.
Definition XTPGridPaintManager.h:1799
CXTPGridPaintManager::IsGridVisible
BOOL IsGridVisible(XTPGridOrientation orientation) const
Determines the visibility of specified grid lines.
CXTPGridPaintManager::m_pControl
CXTPGridControl * m_pControl
Pointer to the Grid control object.
Definition XTPGridPaintManager.h:1862
CXTPGridPaintManager::m_xtpFontCaption
CXTPFont m_xtpFontCaption
Column header caption font.
Definition XTPGridPaintManager.h:1554
CXTPGridPaintManager::DrawFreezeColsDivider
virtual void DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL)
Draws a freeze column divider.
CXTPGridPaintManager::m_nFooterHeight
int m_nFooterHeight
Column footer height.
Definition XTPGridPaintManager.h:1810
CXTPGridPaintManager::DrawInplaceComboButton
virtual BOOL DrawInplaceComboButton(CDC *pDC, CRect *pRc)
Draws the combo button of the Grid control.
CXTPGridPaintManager::GetRowHeight
virtual int GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth)
Retrieves the default row height for print mode (i.e.
CXTPGridPaintManager::DrawColumnFooterDivider
virtual void DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
CXTPGridPaintManager::m_strNoGroupBy
CString m_strNoGroupBy
A string which contains customized "No items" text message for displaying in Group By area when there...
Definition XTPGridPaintManager.h:1729
CXTPGridPaintManager::DrawGlyph
virtual CSize DrawGlyph(CDC *pDC, CRect rcColumn, int iImage)
Draws the standard glyphs of the Grid control.
CXTPGridPaintManager::GetHeaderHeight
virtual int GetHeaderHeight()
Gets the column header height.
Definition XTPGridPaintManager.h:1990
CXTPGridPaintManager::m_bPrintVirtualPageNumber
BOOL m_bPrintVirtualPageNumber
TRUE to print horizontal page number.
Definition XTPGridPaintManager.h:1782
CXTPGridPaintManager::m_clrBtnFace
CXTPPaintManagerColor m_clrBtnFace
Standard button face color.
Definition XTPGridPaintManager.h:1592
CXTPGridPaintManager::m_bForceShowTooltip
BOOL m_bForceShowTooltip
TRUE if use show tooltip for any cell width case.
Definition XTPGridPaintManager.h:1793
CXTPGridPaintManager::ShowWYSIWYGMarkers
void ShowWYSIWYGMarkers(BOOL bSet)
Sets if the paint manager shows WYSIWYG page-end markers.
Definition XTPGridPaintManager.h:2047
CXTPGridPaintManager::m_nTreeStructureStyle
int m_nTreeStructureStyle
Tree structure style.
Definition XTPGridPaintManager.h:1706
CXTPGridPaintManager::SetCaptionFont
void SetCaptionFont(LOGFONT &lf)
Creates and sets the default caption font.
CXTPGridPaintManager::SetColumnWidthWYSIWYG
void SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG)
Sets if the paint manager supports column width WYSIWYG mode.
Definition XTPGridPaintManager.h:2052
CXTPGridPaintManager::m_strNoFieldsAvailable
CString m_strNoFieldsAvailable
A string which contains customized "No Fields Available" text message for displaying in Field Chooser...
Definition XTPGridPaintManager.h:1731
CXTPGridPaintManager::m_themeButton
CXTPWinThemeWrapper * m_themeButton
In-place button theme wrapper.
Definition XTPGridPaintManager.h:1848
CXTPGridPaintManager::DrawInplaceExpandButton
virtual BOOL DrawInplaceExpandButton(CDC *pDC, CRect *pRc)
Draws the expand button of the Grid control.
CXTPGridPaintManager::m_iRecOrRowStart
int m_iRecOrRowStart
Start position in numbering (0 or 1 or something user want).
Definition XTPGridPaintManager.h:1763
CXTPGridPaintManager::m_pMarkupUIElement_NoGroupBy
CXTPMarkupUIElement * m_pMarkupUIElement_NoGroupBy
The no group by markup UI element.
Definition XTPGridPaintManager.h:1864
CXTPGridPaintManager::SetColumnPlusMinusSign
void SetColumnPlusMinusSign(BOOL bDraw)
Specifies if columns use expand/collapse icons (+/-) or directional arrows.
Definition XTPGridPaintManager.h:2092
CXTPGridPaintManager::m_bColumnPlusMinusSign
BOOL m_bColumnPlusMinusSign
TRUE if expand/collapse icons are used, FALSE if directional arrows are used.
Definition XTPGridPaintManager.h:1837
CXTPGridPaintManager::m_nTreeIndent
int m_nTreeIndent
Tree indentation.
Definition XTPGridPaintManager.h:1705
CXTPGridPaintManager::m_clrConnector
CXTPPaintManagerColor m_clrConnector
Header column connector line color.
Definition XTPGridPaintManager.h:1598
CXTPGridPaintManager::m_bGroupRowTextBold
BOOL m_bGroupRowTextBold
TRUE to draw group rows with bold text.
Definition XTPGridPaintManager.h:1713
CXTPGridPaintManager::SetDrawGridForEmptySpace
void SetDrawGridForEmptySpace(BOOL bDrawGrid)
Sets if the grid fills empty space after body rows.
Definition XTPGridPaintManager.h:2112
CXTPGridPaintManager::m_bSortTriangleOffsetFromRight
BOOL m_bSortTriangleOffsetFromRight
Offset of sort triangle.
Definition XTPGridPaintManager.h:1801
CXTPGridPaintManager::m_bShowWYSIWYGMarkers
BOOL m_bShowWYSIWYGMarkers
TRUE if in non-print mode header show red page-end markers.
Definition XTPGridPaintManager.h:1832
CXTPGridPaintManager::DrawHorizontalLine
void DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr)
Draws a horizontal line.
CXTPGridPaintManager::CXTPGridPaintManager
CXTPGridPaintManager()
Default CXTPGridPaintManager constructor, handles properties initialization.
CXTPGridPaintManager::m_arStartCol
CUIntArray m_arStartCol
Start column in each virtual page.
Definition XTPGridPaintManager.h:1779
CXTPGridPaintManager::GetPreviewItemHeight
virtual int GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight)
Retrieves the height of a preview item for print mode.
CXTPGridPaintManager::m_nTreeTextIndent
int m_nTreeTextIndent
Text indent, in pixels, for rows that are neither parent nor children.
Definition XTPGridPaintManager.h:1709
CXTPGridPaintManager::m_clrBtnText
CXTPPaintManagerColor m_clrBtnText
Standard button text color.
Definition XTPGridPaintManager.h:1593
CXTPGridPaintManager::IsColumnPlusMinusSign
BOOL IsColumnPlusMinusSign() const
Determines if columns use expand/collapse icons (+/-) or directional arrows.
Definition XTPGridPaintManager.h:2087
CXTPGridPaintManager::m_xtpFontPreview
CXTPFont m_xtpFontPreview
Column header caption font.
Definition XTPGridPaintManager.h:1555
CXTPGridPaintManager::m_xtpBrushGroupGridLineStyle
CXTPBrush m_xtpBrushGroupGridLineStyle
Brush to draw group row grid lines.
Definition XTPGridPaintManager.h:1823
CXTPGridPaintManager::LoadGlyphs
virtual void LoadGlyphs()
Loads the default images used by the Grid control.
CXTPGridPaintManager::m_pHyperlinkStyle
CXTPGridHyperlinkStyle * m_pHyperlinkStyle
Style for links.
Definition XTPGridPaintManager.h:1565
CXTPGridPaintManager::FindRowAdjacentToMerged
int FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward)
Wrapper for the FindRowAdjacentToMergedEx method.
CXTPGridPaintManager::GetColumnStyle
XTPGridColumnStyle GetColumnStyle() const
Gets the header style.
Definition XTPGridPaintManager.h:2082
CXTPGridPaintManager::DrawGrid
virtual void DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid)
Draws a grid for the control.
CXTPGridPaintManager::DrawRowNumber
virtual void DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow)
Draws a row number.
CXTPGridPaintManager::m_grcGradientColumnHot
CXTPPaintManagerColorGradient m_grcGradientColumnHot
HotTracking Color of column used with xtpGridColumnOffice2003 style.
Definition XTPGridPaintManager.h:1681
CXTPGridPaintManager::m_bGrayIfDisable
BOOL m_bGrayIfDisable
TRUE is disable draw in gray (standard behavior).
Definition XTPGridPaintManager.h:1795
CXTPGridPaintManager::DrawGridPattern
virtual void DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr)
Generates a custom grid pattern.
CXTPGridPaintManager::DrawFocusedRow
virtual void DrawFocusedRow(CDC *pDC, CRect rcRow)
Draws focused rows.
CXTPGridPaintManager::m_bCleanTooltip
BOOL m_bCleanTooltip
TRUE if use show tooltip without markup.
Definition XTPGridPaintManager.h:1794
CXTPGridPaintManager::m_bPrintPageRectangle
BOOL m_bPrintPageRectangle
TRUE to draw rectangle around page.
Definition XTPGridPaintManager.h:1783
CXTPGridPaintManager::m_clrGroupShadeBorder
CXTPPaintManagerColor m_clrGroupShadeBorder
Color for group border's shade.
Definition XTPGridPaintManager.h:1582
CXTPGridPaintManager::m_columnStyle
XTPGridColumnStyle m_columnStyle
Column drawing style.
Definition XTPGridPaintManager.h:1843
CXTPGridPaintManager::SetPreviewIndent
void SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom)
Sets the preview item indent.
CXTPGridPaintManager::GetRowHeight
virtual int GetRowHeight(CDC *pDC, CXTPGridRow *pRow)
Retrieves the default row height for print mode (i.e.
CXTPGridPaintManager::m_nGroupGridLineHeight
int m_nGroupGridLineHeight
The height of the group grid line.
Definition XTPGridPaintManager.h:1811
CXTPGridPaintManager::SetPrintGroupRowIcon
void SetPrintGroupRowIcon(BOOL bDraw)
Sets if the group row collapse-expand icon is drawn in print mode.
Definition XTPGridPaintManager.h:2102
CXTPGridPaintManager::m_pGlyphs
CXTPImageManager * m_pGlyphs
An additional image list for the Grid control.
Definition XTPGridPaintManager.h:1813
CXTPGridPaintManager::m_RecordNumberWidth
int m_RecordNumberWidth
Column width for row/record numbers.
Definition XTPGridPaintManager.h:1784
CXTPGridPaintManager::GetMaxPreviewLines
int GetMaxPreviewLines()
Gets the maximum number of lines of text for a preview item.
Definition XTPGridPaintManager.h:2017
CXTPGridPaintManager::m_bShowNonActiveInPlaceButton
BOOL m_bShowNonActiveInPlaceButton
TRUE if use Show Non-Active In-Place Button (Combo, Expand, Spin).
Definition XTPGridPaintManager.h:1789
CXTPGridPaintManager::DrawSingleLineText
virtual void DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth)
Draws single-line text.
CXTPGridPaintManager::m_bForceDynamicMarkupForCell
BOOL m_bForceDynamicMarkupForCell
TRUE if use Markup for Grid Record Item.
Definition XTPGridPaintManager.h:1785
CXTPGridPaintManager::m_clrControlDark
CXTPPaintManagerColor m_clrControlDark
Dark background color of the Grid control (used on Group By area).
Definition XTPGridPaintManager.h:1584
CXTPGridPaintManager::m_bAllowMergeCells
BOOL m_bAllowMergeCells
TRUE to Allow Merge Cells, FALSE otherwise.
Definition XTPGridPaintManager.h:1700
CXTPGridPaintManager::m_clrControlLightLight
CXTPPaintManagerColor m_clrControlLightLight
Light background color used for drawing shades (used on column header area).
Definition XTPGridPaintManager.h:1586
CXTPGridPaintManager::FillGroupByControl
virtual void FillGroupByControl(CDC *pDC, CRect &rcGroupBy)
Draws the Group By box.
CXTPGridPaintManager::m_clrFormulaSubSum
COLORREF m_clrFormulaSubSum
Color for Formula SubSum fields.
Definition XTPGridPaintManager.h:1695
CXTPGridPaintManager::m_clrBoldTextHighlight
CXTPPaintManagerColor m_clrBoldTextHighlight
Grid items bold text highlight color.
Definition XTPGridPaintManager.h:1570
CXTPGridPaintManager::m_clrSelectedRow
CXTPPaintManagerColor m_clrSelectedRow
Selected row background color.
Definition XTPGridPaintManager.h:1595
CXTPGridPaintManager::DrawGridPattern
virtual void DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush)
Generates a custom grid pattern if necessary.
CXTPGridPaintManager::DrawTreeStructure
virtual void DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph)
Draws tree elements of the Grid control.
CXTPGridPaintManager::CalcColumnHeight
virtual int CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0)
Calculates the optimal height for a specified column.
CXTPGridPaintManager::SetColumnOffice2007CustomThemeBaseColor
void SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor)
Sets the header's custom theme base color for Office2007 column style.
Definition XTPGridPaintManager.h:2117
CXTPGridPaintManager::m_clrGroupShadeText
CXTPPaintManagerColor m_clrGroupShadeText
Group row foreground color when indentation shade is enabled.
Definition XTPGridPaintManager.h:1580
CXTPGridPaintManager::m_bFixedRowHeight
BOOL m_bFixedRowHeight
TRUE if fixed rows used.
Definition XTPGridPaintManager.h:1830
CXTPGridPaintManager::IsDrawGridForEmptySpace
BOOL IsDrawGridForEmptySpace() const
Determines if the grid fills empty space after body rows.
Definition XTPGridPaintManager.h:2107
CXTPGridPaintManager::m_xtpFontBoldText
CXTPFont m_xtpFontBoldText
Grid items default bold text.
Definition XTPGridPaintManager.h:1553
CXTPGridPaintManager::DrawGroupRow
virtual void DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics)
Draws a group row.
CXTPGridPaintManager::m_nTreeTextIndentRowChildren
int m_nTreeTextIndentRowChildren
Text indent, in pixels, for rows without children.
Definition XTPGridPaintManager.h:1708
CXTPGridPaintManager::m_bIsPreviewMode
BOOL m_bIsPreviewMode
TRUE to show the item preview, FALSE to hide.
Definition XTPGridPaintManager.h:1814
CXTPGridPaintManager::m_clrHighlight
CXTPPaintManagerColor m_clrHighlight
Background color of the highlighted row.
Definition XTPGridPaintManager.h:1568
CXTPGridPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Initializes all drawings defaults (fonts, colors, etc.).
CXTPGridPaintManager::m_clrSelectedRowText
CXTPPaintManagerColor m_clrSelectedRowText
Selected row text color.
Definition XTPGridPaintManager.h:1596
CXTPGridPaintManager::m_bForceShowDropMarker
BOOL m_bForceShowDropMarker
TRUE if Force Show Drop Marker.
Definition XTPGridPaintManager.h:1786
CXTPGridPaintManager::m_clrColumnOffice2007CustomTheme
COLORREF m_clrColumnOffice2007CustomTheme
Base color for Office2007 custom theme.
Definition XTPGridPaintManager.h:1692
CXTPGridPaintManager::m_bRecOrRowNum
BOOL m_bRecOrRowNum
TRUE to display record number if support mode is used, FALSE to display row number.
Definition XTPGridPaintManager.h:1764
CXTPGridPaintManager::m_bDrawGridForEmptySpace
BOOL m_bDrawGridForEmptySpace
TRUE if grid fills the empty space (if any) after the body rows.
Definition XTPGridPaintManager.h:1834
CXTPGridPaintManager::m_bShowLockIcon
BOOL m_bShowLockIcon
TRUE to show the lock icon, FALSE to hide.
Definition XTPGridPaintManager.h:1761
CXTPGridPaintManager::DrawTextLine
virtual void DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter)
Draws a line of text with respect to the drawing rectangle.
CXTPGridPaintManager::m_strNoItems
CString m_strNoItems
A string which contains customized "No Items" text for displaying in view when there are no visible r...
Definition XTPGridPaintManager.h:1721
CXTPGridPaintManager::DrawItemControl
virtual void DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem)
Draws an item control.
CXTPGridPaintManager::m_clrHotDivider
CXTPPaintManagerColor m_clrHotDivider
Color of the column hot divider window (two arrows).
Definition XTPGridPaintManager.h:1588
CXTPGridPaintManager::m_bUseEditTextAlignment
BOOL m_bUseEditTextAlignment
TRUE to automatically apply edit alignment using column alignment.
Definition XTPGridPaintManager.h:1758
CXTPGridPaintManager::DrawItemBitmap
virtual void DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage)
Draws an item bitmap.
CXTPGridPaintManager::m_clrControlBack
CXTPPaintManagerColor m_clrControlBack
Background color of the control grid area.
Definition XTPGridPaintManager.h:1576
CXTPGridPaintManager::DrawVerticalLine
void DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr)
Draws a vertical line.
CXTPGridPaintManager::DrawLink
virtual int DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE)
Draws a hyperlink string using hyperlink text settings (i.e.
CXTPGridPaintManager::RecalcTotalHightOfMergedRows
int RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth)
Recalculates row height according to the height of merged items.
CXTPGridPaintManager::IsFixedRowHeight
BOOL IsFixedRowHeight() const
Determines if the paint manager supports fixed or variable row height.
Definition XTPGridPaintManager.h:2027
CXTPGridPaintManager::m_themeCombo
CXTPWinThemeWrapper * m_themeCombo
Combo box in-place button theme wrapper.
Definition XTPGridPaintManager.h:1849
CXTPGridPaintManager::m_szGlyph
CSize m_szGlyph
Glyph size.
Definition XTPGridPaintManager.h:1817
CXTPGridPaintManager::m_clrDisableBitmapLightest
CXTPPaintManagerColor m_clrDisableBitmapLightest
The lightest color of bitmap which covers disabled grid.
Definition XTPGridPaintManager.h:1599
CXTPGridPaintManager::m_xtpFontText
CXTPFont m_xtpFontText
Grid items default text.
Definition XTPGridPaintManager.h:1552
CXTPGridRecordItemControl
This class represents a generic item control and handles control's behaviour, common for all derived ...
Definition XTPGridRecordItemControls.h:85
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125
XTP_GRIDRECORDITEM_METRICS
Record item drawing metrics.
Definition XTPGridRecordItem.h:356


Toolkit Pro: XTPChartPolygonDeviceCommand.h Source File

  • Source
  • Chart
  • Drawing
XTPChartPolygonDeviceCommand.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPOLYGONDEVICECOMMAND_H__)
24# define __XTPCHARTPOLYGONDEVICECOMMAND_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPChartPolygonDeviceCommand : public CXTPChartDeviceCommand
38{
39protected:
46 CXTPChartPolygonDeviceCommand(const CXTPChartPoints& points);
47
48protected:
49 CXTPChartPoints m_points;
50 CXTPChartRectF m_bounds;
51};
52
57class _XTP_EXT_CLASS CXTPChartSolidSplinePolygonDeviceCommand : public CXTPChartDeviceCommand
58{
59public:
67 CXTPChartSolidSplinePolygonDeviceCommand(const CXTPChartColor& color, BOOL bTwoSides = FALSE);
68
69protected:
70 CXTPChartColor m_color;
71 BOOL m_bTwoSides;
72};
73
78class _XTP_EXT_CLASS CXTPChartBoundedPolygonDeviceCommand : public CXTPChartDeviceCommand
79{
80public:
89 CXTPChartBoundedPolygonDeviceCommand(const CXTPChartPoints& points, const CXTPChartColor& color,
90 int thickness);
91
92protected:
93 CXTPChartPoints m_points;
94 CXTPChartColor m_color;
95 int m_thickness;
96};
97
102class _XTP_EXT_CLASS CXTPChartPolygonAntialiasingDeviceCommand : public CXTPChartDeviceCommand
103{
104public:
112 CXTPChartPolygonAntialiasingDeviceCommand(BOOL bAntiAlias = TRUE);
113
121 virtual void BeforeExecute(CXTPChartDeviceContext* pDC) = 0;
122
130 virtual void AfterExecute(CXTPChartDeviceContext* pDC) = 0;
131
132protected:
133 BOOL m_bAntiAlias;
134};
136# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
137#endif //#if !defined(__XTPCHARTPOLYGONDEVICECOMMAND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBoundedPolygonDeviceCommand
Base class implementation for 2D chart bounded polygon device command.
Definition XTPChartPolygonDeviceCommand.h:79
CXTPChartBoundedPolygonDeviceCommand::m_color
CXTPChartColor m_color
The color of the rectangle border.
Definition XTPChartPolygonDeviceCommand.h:94
CXTPChartBoundedPolygonDeviceCommand::m_thickness
int m_thickness
The thickness of the rectangle border.
Definition XTPChartPolygonDeviceCommand.h:95
CXTPChartBoundedPolygonDeviceCommand::m_points
CXTPChartPoints m_points
The points which form the spline polygon.
Definition XTPChartPolygonDeviceCommand.h:93
CXTPChartBoundedPolygonDeviceCommand::CXTPChartBoundedPolygonDeviceCommand
CXTPChartBoundedPolygonDeviceCommand(const CXTPChartPoints &points, const CXTPChartColor &color, int thickness)
Constructs a CXTPChartBoundedPolygonDeviceCommand object.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartPolygonAntialiasingDeviceCommand
Base class implementation for 2D chart antialiased polygon device command.
Definition XTPChartPolygonDeviceCommand.h:103
CXTPChartPolygonAntialiasingDeviceCommand::AfterExecute
virtual void AfterExecute(CXTPChartDeviceContext *pDC)=0
This method gets called after a command is executed which allows for the customization of command beh...
CXTPChartPolygonAntialiasingDeviceCommand::m_bAntiAlias
BOOL m_bAntiAlias
TRUE if antialiasing enabled, FALSE if not.
Definition XTPChartPolygonDeviceCommand.h:133
CXTPChartPolygonAntialiasingDeviceCommand::BeforeExecute
virtual void BeforeExecute(CXTPChartDeviceContext *pDC)=0
This method gets called before a command is executed which allows for the customization of command be...
CXTPChartPolygonAntialiasingDeviceCommand::CXTPChartPolygonAntialiasingDeviceCommand
CXTPChartPolygonAntialiasingDeviceCommand(BOOL bAntiAlias=TRUE)
Constructs a CXTPChartPolygonAntialiasingDeviceCommand object.
CXTPChartPolygonDeviceCommand
Base class implementation for 2D chart polygon device command.
Definition XTPChartPolygonDeviceCommand.h:38
CXTPChartPolygonDeviceCommand::m_bounds
CXTPChartRectF m_bounds
The rectanglur broundary of the polygon.
Definition XTPChartPolygonDeviceCommand.h:50
CXTPChartPolygonDeviceCommand::CXTPChartPolygonDeviceCommand
CXTPChartPolygonDeviceCommand(const CXTPChartPoints &points)
Constructs a CXTPChartPolygonDeviceCommand object.
CXTPChartPolygonDeviceCommand::m_points
CXTPChartPoints m_points
The points which form the polygon.
Definition XTPChartPolygonDeviceCommand.h:49
CXTPChartSolidSplinePolygonDeviceCommand
Base class implementation for 2D chart solid spline polygon device command.
Definition XTPChartPolygonDeviceCommand.h:58
CXTPChartSolidSplinePolygonDeviceCommand::m_color
CXTPChartColor m_color
The fill color of the spline polygon.
Definition XTPChartPolygonDeviceCommand.h:70
CXTPChartSolidSplinePolygonDeviceCommand::CXTPChartSolidSplinePolygonDeviceCommand
CXTPChartSolidSplinePolygonDeviceCommand(const CXTPChartColor &color, BOOL bTwoSides=FALSE)
Constructs a CXTPChartSolidSplinePolygonDeviceCommand object.
CXTPChartSolidSplinePolygonDeviceCommand::m_bTwoSides
BOOL m_bTwoSides
Unused.
Definition XTPChartPolygonDeviceCommand.h:71
CXTPRectT< float >


Toolkit Pro: XTPStatusBarThemeNativeWindows11.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPXTPSTATUSBARTHEMENATIVEWINDOWS11_H__)
24# define __XTPXTPSTATUSBARTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarThemeNativeWindows11 : public CXTPStatusBarThemeOffice2013
39{
40public:
46 CXTPStatusBarThemeNativeWindows11(CXTPPaintManager* pPaintManager);
47
54 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
55
61 virtual void RefreshMetrics();
62
70 virtual void SetStateColor(COLORREF clrState);
71
78 virtual COLORREF GetStateColor() const;
79};
80
82# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
83#endif // !defined(__XTPXTPSTATUSBARTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBarThemeNativeWindows11
The CXTPStatusBarThemeNativeWindows11 class is used to enable the Native Windows 10 style theme for t...
Definition XTPStatusBarThemeNativeWindows11.h:39
CXTPStatusBarThemeNativeWindows11::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPStatusBarThemeNativeWindows11::SetStateColor
virtual void SetStateColor(COLORREF clrState)
Call this member function to set the application state color for the status bar.
CXTPStatusBarThemeNativeWindows11::CXTPStatusBarThemeNativeWindows11
CXTPStatusBarThemeNativeWindows11(CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeNativeWindows11 object.
CXTPStatusBarThemeNativeWindows11::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh colors and other theme specific metrics for the paint manager.
CXTPStatusBarThemeNativeWindows11::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the status bar.
CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the st...
Definition XTPStatusBarThemeOffice2013.h:39


CXTPExcelTabCtrlThemeNativeWindows10 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeNativeWindows10, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeNativeWindows10() | CXTPExcelTabCtrlThemeNativeWindows10 |
CXTPExcelTabCtrlThemeOffice2013() | CXTPExcelTabCtrlThemeOffice2013 |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: XTPActiveScriptEngine.h Source File

  • Source
  • Common
XTPActiveScriptEngine.h
Go to the documentation of this file.
1
23#if !defined(__XTPACTIVESCRIPTENGINE_H__)
24# define __XTPACTIVESCRIPTENGINE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32# include <ActivScp.h>
33# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
34
35# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36
37class CXTPActiveScriptEngine;
38
43class _XTP_EXT_CLASS CXTPActiveScriptObjectContext
44{
45 friend class CXTPActiveScriptEngine;
46
47private:
54 CXTPActiveScriptObjectContext(CXTPActiveScriptEngine* pEngine, IDispatch* pObject);
55
60 ~CXTPActiveScriptObjectContext();
61
62public:
69 ULONG AddRef();
70
77 ULONG Release();
78
85 CXTPActiveScriptEngine* GetEngine();
86
93 const CXTPActiveScriptEngine* GetEngine() const;
94
103 HRESULT GetValue(LPCWSTR lpszName, CComVariant* pvtResult);
104
113 HRESULT SetValue(LPCWSTR lpszName, VARIANT vtValue);
114
125 HRESULT InvokeWithArgs(VARIANT* lpArguments, UINT nCount, VARIANT* pvtResult = NULL);
126
135 HRESULT Invoke(VARIANT* pvtResult = NULL);
136
146 template<class A1>
147 HRESULT Invoke(A1 arg1, VARIANT* pvtResult = NULL);
148
159 template<class A1, class A2>
160 HRESULT Invoke(A1 arg1, A2 arg2, VARIANT* pvtResult = NULL);
161
173 template<class A1, class A2, class A3>
174 HRESULT Invoke(A1 arg1, A2 arg2, A3 arg3, VARIANT* pvtResult = NULL);
175
188 template<class A1, class A2, class A3, class A4>
189 HRESULT Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4, VARIANT* pvtResult = NULL);
190
204 template<class A1, class A2, class A3, class A4, class A5>
205 HRESULT Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4, A5 arg5, VARIANT* pvtResult = NULL);
206
214 CXTPActiveScriptObjectContext* GetContext(LPCWSTR lpszName);
215
216private:
217 HRESULT ProcessNamedItem(LPCWSTR lpszName, WORD wFlags, VARIANT* lpArguments, UINT nCount,
218 VARIANT* pvtResult = NULL);
219
220private:
221 ULONG m_nRefs;
222 CXTPActiveScriptEngine* m_pEngine;
223 IDispatch* m_pObject;
224};
226AFX_INLINE CXTPActiveScriptEngine* CXTPActiveScriptObjectContext::GetEngine()
227{
228 return m_pEngine;
229}
230
231AFX_INLINE const CXTPActiveScriptEngine* CXTPActiveScriptObjectContext::GetEngine() const
232{
233 return m_pEngine;
234}
235
236AFX_INLINE HRESULT CXTPActiveScriptObjectContext::Invoke(VARIANT* pvtResult /*= NULL*/)
237{
238 return InvokeWithArgs(NULL, 0, pvtResult);
239}
240
241template<class A1>
242AFX_INLINE HRESULT CXTPActiveScriptObjectContext::Invoke(A1 arg1, VARIANT* pvtResult /*= NULL*/)
243{
244 CComVariant va(arg1);
245 return InvokeWithArgs(&va, 1, pvtResult);
246}
247
248template<class A1, class A2>
249AFX_INLINE HRESULT CXTPActiveScriptObjectContext::Invoke(A1 arg1, A2 arg2,
250 VARIANT* pvtResult /*= NULL*/)
251{
252 CComVariant va[] = { CComVariant(arg1), CComVariant(arg2) };
253 return InvokeWithArgs(va, _countof(va), pvtResult);
254}
255
256template<class A1, class A2, class A3>
257AFX_INLINE HRESULT CXTPActiveScriptObjectContext::Invoke(A1 arg1, A2 arg2, A3 arg3,
258 VARIANT* pvtResult /*= NULL*/)
259{
260 CComVariant va[] = { CComVariant(arg1), CComVariant(arg2), CComVariant(arg3) };
261 return InvokeWithArgs(va, _countof(va), pvtResult);
262}
263
264template<class A1, class A2, class A3, class A4>
265AFX_INLINE HRESULT CXTPActiveScriptObjectContext::Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4,
266 VARIANT* pvtResult /*= NULL*/)
267{
268 CComVariant va[] = { CComVariant(arg1), CComVariant(arg2), CComVariant(arg3),
269 CComVariant(arg4) };
270 return InvokeWithArgs(va, _countof(va), pvtResult);
271}
272
273template<class A1, class A2, class A3, class A4, class A5>
274AFX_INLINE HRESULT CXTPActiveScriptObjectContext::Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4,
275 A5 arg5, VARIANT* pvtResult /*= NULL*/)
276{
277 CComVariant va[] = { CComVariant(arg1), CComVariant(arg2), CComVariant(arg3), CComVariant(arg4),
278 CComVariant(arg5) };
279 return InvokeWithArgs(va, _countof(va), pvtResult);
280}
286class _XTP_EXT_CLASS CXTPActiveScriptEngine : public CXTPCmdTarget
287{
288 DECLARE_DYNAMIC(CXTPActiveScriptEngine);
289 friend class CXTPActiveScriptObjectContext;
290
291public:
296 CXTPActiveScriptEngine();
297
302 virtual ~CXTPActiveScriptEngine();
303
304public:
305 struct ExceptionData
306 {
307 EXCEPINFO info;
308 BSTR strCodeLine;
309 ULONG nLine;
310 LONG nCharPos;
311 DWORD dwErrCtx;
312 };
313
325 HRESULT Initialize(LPCWSTR lpszEngineProgId, IActiveScriptSite* pSite = NULL);
326
331 void Uninitialize();
332
341 HRESULT LoadCode(LPCWSTR lpszCode);
342
349 HRESULT Run();
350
357 CXTPActiveScriptObjectContext* GetGlobalContext() const;
358
366 CXTPActiveScriptObjectContext* CreateContext(LPDISPATCH pDispObject) const;
367
374 const ExceptionData* GetExceptionData() const;
375
382 const EXCEPINFO* GetExceptionInfo() const;
383
394 HRESULT AddNamedItem(LPCWSTR lpszName, LPVOID lpItemData = NULL,
395 DWORD dwFlags = SCRIPTITEM_ISVISIBLE);
396
404 LPVOID GetNamedItemData(LPCWSTR lpszName) const;
405
406private:
407 void SetExceptionInfo(const EXCEPINFO* pExcepInfo = NULL, BSTR strCodeLine = NULL,
408 ULONG nLine = 0, LONG nCharPos = 0, DWORD dwErrCtx = 0);
409# ifdef _DEBUG
410 void DumpCode(ULONG nLine) const;
411# endif
412
413 DECLARE_INTERFACE_MAP();
414
415# pragma warning(push)
416// C4616: #pragma warning : warning number '...' out of range, must be between '4001' and '4999'
417// C4619: #pragma warning : there is no warning number 'number'
418// C5204: '...': class has virtual functions, but its trivial destructor is not virtual; instances
419// of objects derived from this class may not be destructed correctly
420# pragma warning(disable : 4616 4619 5204)
421 BEGIN_INTERFACE_PART(ActiveScriptSite, IActiveScriptSite)
422 STDMETHOD(GetLCID)(LCID* plcid);
423 STDMETHOD(GetItemInfo)
424 (LPCOLESTR pstrName, DWORD dwReturnMask, IUnknown** ppiunkItem, ITypeInfo** ppti);
425 STDMETHOD(GetDocVersionString)(BSTR* pbstrVersion);
426 STDMETHOD(OnScriptTerminate)(const VARIANT* pvarResult, const EXCEPINFO* pexcepinfo);
427 STDMETHOD(OnStateChange)(SCRIPTSTATE ssScriptState);
428 STDMETHOD(OnScriptError)(IActiveScriptError* pScriptError);
429 STDMETHOD(OnEnterScript)();
430 STDMETHOD(OnLeaveScript)();
431 END_INTERFACE_PART(ActiveScriptSite);
432# pragma warning(pop)
433
434private:
435 IActiveScriptSite* m_pSite;
436 IActiveScript* m_pEngine;
437 IActiveScriptParse* m_pParser;
438 ExceptionData* m_pExceptionData;
439 CMap<LPCWSTR, LPCWSTR, LPVOID, LPVOID> m_NamedItemDataMap;
440# ifdef _DEBUG
441 CComBSTR m_strLoadedCode;
442# endif
443};
445AFX_INLINE const CXTPActiveScriptEngine::ExceptionData*
446 CXTPActiveScriptEngine::GetExceptionData() const
447{
448 return m_pExceptionData;
449}
450
451AFX_INLINE const EXCEPINFO* CXTPActiveScriptEngine::GetExceptionInfo() const
452{
453 return (NULL != m_pExceptionData ? &m_pExceptionData->info : NULL);
454}
460class _XTP_EXT_CLASS CXTPActiveScriptStdRuntime : public CXTPCmdTarget
461{
462 DECLARE_DYNAMIC(CXTPActiveScriptStdRuntime);
463
464 class TimeoutTask;
465 class TimeoutTaskRegistry;
466
467public:
472 CXTPActiveScriptStdRuntime();
473
481 CXTPActiveScriptStdRuntime(IActiveScriptSite* pSite, BOOL bAddSiteRef = TRUE);
482
487 ~CXTPActiveScriptStdRuntime();
488
493 void Shutdown();
494
495private:
496 DECLARE_DISPATCH_MAP();
497 afx_msg UINT OleSetTimeout(LPDISPATCH lpDispCallback, UINT nTimeout);
498 afx_msg void OleClearTimeout(UINT nTimeoutId);
499 afx_msg void OleDebugLog(const VARIANT& message);
500 afx_msg LPDISPATCH OleGetObject(LPCTSTR lpszName);
501
502 static void CALLBACK TimeoutProc(HWND hWnd, UINT uMsg, UINT_PTR idEvent, DWORD dwTime);
503
504private:
505 CMap<UINT, UINT, TimeoutTask*, TimeoutTask*> m_TimeoutTaskMap;
506 IActiveScriptSite* m_pSite;
507 BOOL m_bAddSiteRef;
508};
509
510# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
512#endif // !defined(__XTPACTIVESCRIPTENGINE_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
CXTPActiveScriptEngine
Implements ActiveScript engine component.
Definition XTPActiveScriptEngine.h:287
CXTPActiveScriptEngine::Run
HRESULT Run()
Runs execution context.
CXTPActiveScriptEngine::GetNamedItemData
LPVOID GetNamedItemData(LPCWSTR lpszName) const
Obtains data pointer associated with named item.
CXTPActiveScriptEngine::CXTPActiveScriptEngine
CXTPActiveScriptEngine()
Constructs scripting engine object.
CXTPActiveScriptEngine::Uninitialize
void Uninitialize()
Uninitializes scripting engine.
CXTPActiveScriptEngine::~CXTPActiveScriptEngine
virtual ~CXTPActiveScriptEngine()
Handles scripting engine deallocation.
CXTPActiveScriptEngine::Initialize
HRESULT Initialize(LPCWSTR lpszEngineProgId, IActiveScriptSite *pSite=NULL)
Initializes scripting engine.
CXTPActiveScriptEngine::GetExceptionData
const ExceptionData * GetExceptionData() const
Information about the last unhandled exception.
CXTPActiveScriptEngine::LoadCode
HRESULT LoadCode(LPCWSTR lpszCode)
Loads a chunk of code into execution context.
CXTPActiveScriptEngine::CreateContext
CXTPActiveScriptObjectContext * CreateContext(LPDISPATCH pDispObject) const
This member is called to create a context instance pointer.
CXTPActiveScriptEngine::GetExceptionInfo
const EXCEPINFO * GetExceptionInfo() const
Information about the last unhandled exception.
CXTPActiveScriptEngine::GetGlobalContext
CXTPActiveScriptObjectContext * GetGlobalContext() const
Obtains global object's context instance.
CXTPActiveScriptEngine::AddNamedItem
HRESULT AddNamedItem(LPCWSTR lpszName, LPVOID lpItemData=NULL, DWORD dwFlags=SCRIPTITEM_ISVISIBLE)
Adds named item name and data into execution context.
CXTPActiveScriptObjectContext
Wrapper around scriptable object.
Definition XTPActiveScriptEngine.h:44
CXTPActiveScriptObjectContext::GetValue
HRESULT GetValue(LPCWSTR lpszName, CComVariant *pvtResult)
Obtains named property value.
CXTPActiveScriptObjectContext::GetEngine
const CXTPActiveScriptEngine * GetEngine() const
Obtains parent scripting engine instance pointer.
CXTPActiveScriptObjectContext::Invoke
HRESULT Invoke(A1 arg1, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
CXTPActiveScriptObjectContext::GetContext
CXTPActiveScriptObjectContext * GetContext(LPCWSTR lpszName)
Obtains context object's property or function.
CXTPActiveScriptObjectContext::Invoke
HRESULT Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4, A5 arg5, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
CXTPActiveScriptObjectContext::GetEngine
CXTPActiveScriptEngine * GetEngine()
Obtains parent scripting engine instance pointer.
CXTPActiveScriptObjectContext::InvokeWithArgs
HRESULT InvokeWithArgs(VARIANT *lpArguments, UINT nCount, VARIANT *pvtResult=NULL)
Invokes a function object.
CXTPActiveScriptObjectContext::Release
ULONG Release()
Decrements context reference count.
CXTPActiveScriptObjectContext::SetValue
HRESULT SetValue(LPCWSTR lpszName, VARIANT vtValue)
Sets named property value.
CXTPActiveScriptObjectContext::Invoke
HRESULT Invoke(A1 arg1, A2 arg2, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
CXTPActiveScriptObjectContext::Invoke
HRESULT Invoke(VARIANT *pvtResult=NULL)
Invokes a function object with no arguments.
CXTPActiveScriptObjectContext::Invoke
HRESULT Invoke(A1 arg1, A2 arg2, A3 arg3, A4 arg4, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
CXTPActiveScriptObjectContext::Invoke
HRESULT Invoke(A1 arg1, A2 arg2, A3 arg3, VARIANT *pvtResult=NULL)
Invokes a function object with 1 argument.
CXTPActiveScriptObjectContext::AddRef
ULONG AddRef()
Increments context reference count.
CXTPActiveScriptStdRuntime
Implements standard scripting runtime library.
Definition XTPActiveScriptEngine.h:461
CXTPActiveScriptStdRuntime::CXTPActiveScriptStdRuntime
CXTPActiveScriptStdRuntime(IActiveScriptSite *pSite, BOOL bAddSiteRef=TRUE)
Constructs scripting runtime library.
CXTPActiveScriptStdRuntime::Shutdown
void Shutdown()
Releases all used resources.
CXTPActiveScriptStdRuntime::~CXTPActiveScriptStdRuntime
~CXTPActiveScriptStdRuntime()
Handles standard scripting runtime library deallocation.
CXTPActiveScriptStdRuntime::CXTPActiveScriptStdRuntime
CXTPActiveScriptStdRuntime()
Constructs scripting runtime library.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122


CXTPStatusBar Member List

This is the complete list of members for CXTPStatusBar, including all inherited members.

AddControl(CWnd *pWnd, UINT nID, BOOL bAutoDelete=TRUE) | CXTPStatusBar |
AddIndicator(UINT nID, int nIndex=-1) | CXTPStatusBar |
AddIndicator(CXTPStatusBarPane *pPane, UINT nID, int nIndex=-1) | CXTPStatusBar |
CommandToIndex(UINT nIDFind) const | CXTPStatusBar |
Create(CWnd *pParentWnd, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM|WS_CLIPCHILDREN|WS_CLIPSIBLINGS, UINT nID=AFX_IDW_STATUS_BAR) | CXTPStatusBar |
CreateEx(CWnd *pParentWnd, DWORD dwCtrlStyle=0, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_BOTTOM, UINT nID=AFX_IDW_STATUS_BAR) | CXTPStatusBar |
CXTPStatusBar() | CXTPStatusBar |
DoPropExchange(CXTPPropExchange *pPX) | CXTPStatusBar | virtual
DrawPaneEntry(CDC *pDC, int nIndex, CRect rcItem) | CXTPStatusBar | virtual
DrawStretch(CDC *pDC, CRect &rcClient) | CXTPStatusBar | protectedvirtual
EnableCustomization(BOOL bEnable=TRUE) | CXTPStatusBar |
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPStatusBar |
FindPane(UINT nID) const | CXTPStatusBar |
GetDrawDisabledText() const | CXTPStatusBar |
GetFont() | CXTPStatusBar |
GetImageManager() const | CXTPStatusBar |
GetItemID(int nIndex) const | CXTPStatusBar |
GetItemRect(int nIndex, LPRECT lpRect) const | CXTPStatusBar |
GetMarkupContext() const | CXTPStatusBar |
GetPaintManager() const | CXTPStatusBar |
GetPane(int nIndex) const | CXTPStatusBar |
GetPaneCount() const | CXTPStatusBar |
GetPaneInfo(int nIndex, UINT &nID, UINT &nStyle, int &cxWidth) const | CXTPStatusBar |
GetPaneStyle(int nIndex) const | CXTPStatusBar |
GetPaneText(int nIndex) const | CXTPStatusBar |
GetPaneText(int nIndex, CString &rString) const | CXTPStatusBar |
GetRibbonDividerIndex() const | CXTPStatusBar |
GetStatusBarCtrl() const | CXTPStatusBar |
GetStatusBarPaintManager() const | CXTPStatusBar |
GetToolTipContext() const | CXTPStatusBar |
GetVisiblePaneCount() const | CXTPStatusBar |
HitTest(CPoint pt, CRect *lpRect=NULL) const | CXTPStatusBar |
LoadState(LPCTSTR lpszProfileName) | CXTPStatusBar |
m_arrPanes | CXTPStatusBar | protected
m_bCustomizable | CXTPStatusBar | protected
m_bDrawDisabledText | CXTPStatusBar | protected
m_bShowSizeGripper | CXTPStatusBar | protected
m_cxPaneSpacing | CXTPStatusBar | protected
m_nMinHeight | CXTPStatusBar | protected
m_nRibbonDividerIndex | CXTPStatusBar | protected
m_pHighlightedPane | CXTPStatusBar | protected
m_pMarkupContext | CXTPStatusBar | protected
m_xtpFontStatus | CXTPStatusBar | protected
PositionControls() | CXTPStatusBar |
RecalcLayout() | CXTPStatusBar | virtual
RemoveAll() | CXTPStatusBar |
RemoveAt(int nIndex) | CXTPStatusBar |
RemoveIndicator(UINT nID) | CXTPStatusBar |
SaveState(LPCTSTR lpszProfileName) | CXTPStatusBar |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPStatusBar |
SetDrawDisabledText(BOOL bDraw) | CXTPStatusBar |
SetFont(CFont *pFont, BOOL bRedraw=TRUE) | CXTPStatusBar |
SetIndicators(const UINT *lpIDArray, int nIDCount) | CXTPStatusBar |
SetPaneInfo(int nIndex, UINT nID, UINT nStyle, int cxWidth) | CXTPStatusBar |
SetPaneStyle(int nIndex, UINT nStyle) | CXTPStatusBar |
SetPaneText(int nIndex, LPCTSTR lpszNewText) | CXTPStatusBar |
SetPaneWidth(int nIndex, int cxText) | CXTPStatusBar |
SetRibbonDividerIndex(int nIndex) | CXTPStatusBar |
~CXTPStatusBar() | CXTPStatusBar | virtual


Toolkit Pro: XTPListBox.h Source File

  • Source
  • Controls
  • ListBox
XTPListBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOX_H__)
24# define __XTPLISTBOX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38enum XTPListBoxStyle
39{
40 xtpListBoxStandard,
41 xtpListBoxOfficeXP,
42 xtpListBoxOffice2007,
43 xtpListBoxOffice2013,
44 xtpListBoxOffice2016 = xtpListBoxOffice2013,
45 xtpListBoxVisualStudio2015,
46 xtpListBoxVisualStudio2017,
47 xtpListBoxVisualStudio2019,
48 xtpListBoxVisualStudio2022,
49 xtpListBoxNativeWindows10,
50 xtpListBoxNativeWindows11,
51};
52
53class CXTPListBox;
54
60class _XTP_EXT_CLASS CXTPListBoxTheme
61{
62public:
67 virtual ~CXTPListBoxTheme()
68 {
69 }
70
80 virtual void DrawItem(CDC* pDC, CXTPListBox* pListBox, LPDRAWITEMSTRUCT lpDIS) = 0;
81
92 virtual void DrawItemText(CDC* pDC, CRect rcText, CXTPListBox* pListBox,
93 LPDRAWITEMSTRUCT lpDIS);
94
100 virtual void RefreshMetrics() = 0;
101
108 virtual COLORREF GetBackColor();
109
118 virtual BOOL DrawNcBorders(CDC* pDC, CRect rc);
119};
120
126class _XTP_EXT_CLASS CXTPListBox : public CListBox
127{
129 DECLARE_DYNAMIC(CXTPListBox)
131public:
136 CXTPListBox();
137
142 virtual ~CXTPListBox();
143
144public:
151 virtual void Initialize(bool bAutoFont = true);
152
159 virtual COLORREF GetBackColor();
160
171 void SetListStyle(XTPListBoxStyle style);
172
181 XTPListBoxStyle GetListStyle() const;
182
191 void SetTheme(XTPControlTheme nTheme);
192
197 virtual void RefreshMetrics();
198
206 BOOL HasFocus() const;
207
208protected:
225 BOOL TryItemFromPoint(CPoint pt, BOOL& bOutside, int& nIndex) const;
226
228 DECLARE_MESSAGE_MAP()
229
230 BOOL m_bPreSubclassInit;
231
232 //{{AFX_VIRTUAL(CXTPListBox)
233 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
234 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
235 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
236 virtual void PreSubclassWindow();
237 virtual void Init();
238 //}}AFX_VIRTUAL
239
240 //{{AFX_MSG(CXTPListBox)
241 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
242 afx_msg void OnPaint();
243 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
244 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
245 afx_msg void OnMouseLeave();
246 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
247 afx_msg void OnSetFocus(CWnd* pOldWnd);
248 afx_msg void OnKillFocus(CWnd* pNewWnd);
249 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
250 afx_msg void OnNcPaint();
251 //}}AFX_MSG
254public:
255 CXTPListBoxTheme* m_pTheme;
256 XTPControlTheme m_theme;
257 int m_nItemHeight;
258 int m_nTextPadding;
259 int m_nHotItem;
260};
261
263// CXTPScrollableListBoxT
264
273template<class ListBoxBase>
274class CXTPScrollableListBoxT : public CXTPScrollable<ListBoxBase>
275{
276public:
281 CXTPScrollableListBoxT();
282
283 using CXTPScrollable<ListBoxBase>::GetRuntimeClass;
284
285protected:
287 virtual DWORD FilterStyle(DWORD dwStyle) const;
288 virtual BOOL RequiresMouseWheelOverriding() const;
290};
291
296typedef CXTPScrollableListBoxT<CXTPListBox> CXTPScrollableListBox;
298template<class ListBoxBase>
299AFX_INLINE CXTPScrollableListBoxT<ListBoxBase>::CXTPScrollableListBoxT()
300{
301 _ASSERTE(GetRuntimeClass()->IsDerivedFrom(RUNTIME_CLASS(CListBox)));
302}
303
304template<class ListBoxBase>
305AFX_INLINE DWORD CXTPScrollableListBoxT<ListBoxBase>::FilterStyle(DWORD dwStyle) const
306{
307 return dwStyle & ~(WS_VSCROLL | WS_HSCROLL);
308}
309
310template<class ListBoxBase>
311AFX_INLINE BOOL CXTPScrollableListBoxT<ListBoxBase>::RequiresMouseWheelOverriding() const
312{
313 return TRUE;
314}
316# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
318#endif // #if !defined(__XTPLISTBOX_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollableListBox
CXTPScrollableListBoxT< CXTPListBox > CXTPScrollableListBox
Type alias for a CXTPListBox derived scrollable control.
Definition XTPListBox.h:296
XTPListBoxStyle
XTPListBoxStyle
Constants used by the CXTPListBox control to determine the current theme style that has been set.
Definition XTPListBox.h:39
xtpListBoxVisualStudio2019
@ xtpListBoxVisualStudio2019
Visual Studio 2019 style theme.
Definition XTPListBox.h:47
xtpListBoxOffice2013
@ xtpListBoxOffice2013
Office 2013 style theme.
Definition XTPListBox.h:43
xtpListBoxNativeWindows10
@ xtpListBoxNativeWindows10
Native Windows 10 style theme.
Definition XTPListBox.h:49
xtpListBoxOfficeXP
@ xtpListBoxOfficeXP
Office XP style theme.
Definition XTPListBox.h:41
xtpListBoxVisualStudio2015
@ xtpListBoxVisualStudio2015
Visual Studio 2015 style theme.
Definition XTPListBox.h:45
xtpListBoxStandard
@ xtpListBoxStandard
Default theme.
Definition XTPListBox.h:40
xtpListBoxOffice2016
@ xtpListBoxOffice2016
Office 2016 style theme.
Definition XTPListBox.h:44
xtpListBoxVisualStudio2017
@ xtpListBoxVisualStudio2017
Visual Studio 2017 style theme.
Definition XTPListBox.h:46
xtpListBoxOffice2007
@ xtpListBoxOffice2007
Office 2007 style theme.
Definition XTPListBox.h:42
xtpListBoxNativeWindows11
@ xtpListBoxNativeWindows11
Native Windows 11 style theme.
Definition XTPListBox.h:50
xtpListBoxVisualStudio2022
@ xtpListBoxVisualStudio2022
Visual Studio 2022 style theme.
Definition XTPListBox.h:48
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPListBox::SetListStyle
void SetListStyle(XTPListBoxStyle style)
Call this method to set the style of the list box.
CXTPListBox::Initialize
virtual void Initialize(bool bAutoFont=true)
Call this member function to initialize the list box.
CXTPListBox::GetBackColor
virtual COLORREF GetBackColor()
Called to retrieve the background color for the list box.
CXTPListBox::TryItemFromPoint
BOOL TryItemFromPoint(CPoint pt, BOOL &bOutside, int &nIndex) const
This method determines the list box item nearest to the point specified in pt when there is at least ...
CXTPListBox::GetListStyle
XTPListBoxStyle GetListStyle() const
Call this method to retrieve the style of the list box.
CXTPListBox::SetTheme
void SetTheme(XTPControlTheme nTheme)
This member function sets the drawing theme for the control.
CXTPListBox::~CXTPListBox
virtual ~CXTPListBox()
Destroys a CXTPListBox object, handles cleanup and deallocation.
CXTPListBox::RefreshMetrics
virtual void RefreshMetrics()
Call this member function to refresh theme colors and redraw the control.
CXTPListBox::HasFocus
BOOL HasFocus() const
Call this member function to determine if the list box control has input focus.
CXTPListBox::CXTPListBox
CXTPListBox()
Constructs a CXTPListBox object.
CXTPListBoxTheme
CXTPListBoxTheme is the base class used by CXTPListBox themes to draw the list box control.
Definition XTPListBox.h:61
CXTPListBoxTheme::RefreshMetrics
virtual void RefreshMetrics()=0
Called to update the colors and metrics used to draw the CXTPListBox object.
CXTPListBoxTheme::~CXTPListBoxTheme
virtual ~CXTPListBoxTheme()
Handles theme destruction.
Definition XTPListBox.h:67
CXTPListBoxTheme::DrawNcBorders
virtual BOOL DrawNcBorders(CDC *pDC, CRect rc)
Call this member function to draw the list control borders.
CXTPListBoxTheme::GetBackColor
virtual COLORREF GetBackColor()
Called to retrieve the background color for the list box.
CXTPListBoxTheme::DrawItemText
virtual void DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw text for the CXTPListBox object.
CXTPListBoxTheme::DrawItem
virtual void DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)=0
This method is called to draw the CXTPListBox object.
CXTPScrollable
The adaptor class for a scrollable control for which standard scroll bars have to be overriden.
Definition XTPScrollable.h:249
CXTPScrollableListBoxT
An adaptor for any CListBox derived control that overrides standard scrollbars with custom scrollbars...
Definition XTPListBox.h:275
CXTPScrollableListBoxT::CXTPScrollableListBoxT
CXTPScrollableListBoxT()
Initializes scrollable control instance.
IXTPScrollable::RequiresMouseWheelOverriding
virtual BOOL RequiresMouseWheelOverriding() const =0
Determines if mouse wheel handling logic must be overridden by scroll host when a hosted control is n...
IXTPScrollable::FilterStyle
virtual DWORD FilterStyle(DWORD dwStyle) const =0
Filters supplied window style if needed.


Toolkit Pro: XTPMarkupDeviceDependentImage.h Source File

  • Source
  • Markup
  • DeviceContext
XTPMarkupDeviceDependentImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPDEVICEDEPENDENTIMAGE_H__)
24# define __XTPMARKUPDEVICEDEPENDENTIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34
39struct IXTPMarkupDeviceDependentImageSite
40{
45 virtual ~IXTPMarkupDeviceDependentImageSite()
46 {
47 }
48
56 virtual CXTPMarkupContext* GetMarkupContext() = 0;
57
63 virtual void OnImageUpdateRequired() = 0;
64};
65
72class _XTP_EXT_CLASS CXTPMarkupDeviceDependentImage : public CObject
73{
75 DECLARE_DYNAMIC(CXTPMarkupDeviceDependentImage);
77protected:
83 explicit CXTPMarkupDeviceDependentImage(IXTPMarkupDeviceDependentImageSite* pSite);
84
85public:
90 virtual ~CXTPMarkupDeviceDependentImage();
91
105 virtual BOOL Load(LPCWSTR lpszSource, int nWidth, int nHeight = 0) = 0;
106
113 const CSize& GetSize() const;
114
121 BOOL IsLoaded() const;
122
129 BOOL IsIcon() const;
130
137 IXTPMarkupDeviceDependentImageSite* GetSite() const;
138
140 ULONG AddRef();
141 ULONG Release();
144protected:
145 IXTPMarkupDeviceDependentImageSite* m_pSite;
146 CSize m_imageSize;
147 BOOL m_bIsIcon;
148
149private:
150 ULONG m_nRefs;
151};
152
153AFX_INLINE const CSize& CXTPMarkupDeviceDependentImage::GetSize() const
154{
155 return m_imageSize;
156}
157
158AFX_INLINE BOOL CXTPMarkupDeviceDependentImage::IsLoaded() const
159{
160 return (0 != m_imageSize.cx && 0 != m_imageSize.cy);
161}
162
163AFX_INLINE BOOL CXTPMarkupDeviceDependentImage::IsIcon() const
164{
165 return m_bIsIcon;
166}
167
168AFX_INLINE IXTPMarkupDeviceDependentImageSite* CXTPMarkupDeviceDependentImage::GetSite() const
169{
170 return m_pSite;
171}
173# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
174#endif /*__XTPMARKUPDEVICEDEPENDENTIMAGE_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupDeviceDependentImage::Load
virtual BOOL Load(LPCWSTR lpszSource, int nWidth, int nHeight=0)=0
Loads an image from a specified resource.
CXTPMarkupDeviceDependentImage::IsLoaded
BOOL IsLoaded() const
Checks if an image is loaded.
Definition XTPMarkupDeviceDependentImage.h:158
CXTPMarkupDeviceDependentImage::CXTPMarkupDeviceDependentImage
CXTPMarkupDeviceDependentImage(IXTPMarkupDeviceDependentImageSite *pSite)
Constructs a device dependent image object.
CXTPMarkupDeviceDependentImage::GetSite
IXTPMarkupDeviceDependentImageSite * GetSite() const
Obtains the site object pointer.
Definition XTPMarkupDeviceDependentImage.h:168
CXTPMarkupDeviceDependentImage::~CXTPMarkupDeviceDependentImage
virtual ~CXTPMarkupDeviceDependentImage()
Handles device dependent image object deallocation.
CXTPMarkupDeviceDependentImage::GetSize
const CSize & GetSize() const
Obtains the image size, in pixels.
Definition XTPMarkupDeviceDependentImage.h:153
CXTPMarkupDeviceDependentImage::IsIcon
BOOL IsIcon() const
Checks if the loaded image is an icon.
Definition XTPMarkupDeviceDependentImage.h:163
IXTPMarkupDeviceDependentImageSite
Describes an image site interface.
Definition XTPMarkupDeviceDependentImage.h:40
IXTPMarkupDeviceDependentImageSite::GetMarkupContext
virtual CXTPMarkupContext * GetMarkupContext()=0
Implementation must return a valid pointer to a markup context in which an image is to be rendered.
IXTPMarkupDeviceDependentImageSite::~IXTPMarkupDeviceDependentImageSite
virtual ~IXTPMarkupDeviceDependentImageSite()
Handles object destruction.
Definition XTPMarkupDeviceDependentImage.h:45
IXTPMarkupDeviceDependentImageSite::OnImageUpdateRequired
virtual void OnImageUpdateRequired()=0
(Optional) Implementation can re-draw the context when this method is called; usually when a new anim...


Toolkit Pro: XTPTabBaseTheme.h Source File

  • Source
  • Controls
  • Tab
XTPTabBaseTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCTRLTHEME_H__)
24# define __XTPTABCTRLTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabCtrl;
34class CXTPTabBase;
35class CXTPTabCtrlButton;
36class CXTPTabCtrlButtons;
37class CXTPTcbItem;
38class CXTPWinThemeWrapper;
39
45class _XTP_EXT_CLASS CXTPTabBaseTheme : public CXTPControlTheme
46{
47public:
52 CXTPTabBaseTheme();
53
58 virtual ~CXTPTabBaseTheme();
59
60public:
66 virtual void RefreshMetrics(CTabCtrl* pTab);
67
76 virtual void DrawTabCtrl(CDC* pDC, CXTPTabBase* pTabCtrl);
77
88 virtual CXTPPaintManagerColor GetBackColor() const;
89
99 virtual void AdjustBorders(CXTPTabBase* pTabCtrl, CXTPTcbItem* pMember);
100
111 virtual void DrawButton(CDC* pDC, CXTPTabCtrlButton* pButton, COLORREF clrButton);
112
122 virtual COLORREF FillButtons(CDC* pDC, CXTPTabCtrlButtons* pButtons);
123
124protected:
134 virtual void DrawBorders(CDC* pDC, const CRect& rcClient);
135
146 virtual void FillHeader(CDC* pDC, CXTPTabBase* pTabCtrlBase, CRect rcHeader);
147
162 virtual void FillTabFaceNativeWinXP(CDC* pDC, CTabCtrl* pTabCtrl, CRect rcItem, BOOL bSelected);
163
176 virtual void FillTabFace(CDC* pDC, CTabCtrl* pTabCtrl, CRect rcItem, BOOL bSelected);
177
190 virtual void DrawTab(CDC* pDC, CXTPTabBase* pTabCtrlBase, int iItem);
191
205 virtual void DrawTabIcon(CDC* pDC, CTabCtrl* pTabCtrl, CRect& rcItem, int iItem);
206
222 virtual void DrawTabText(CDC* pDC, CTabCtrl* pTabCtrl, CRect& rcItem, int iItem, BOOL bSelected,
223 BOOL bBoldFont);
224
235 virtual CRect GetHeaderRect(CXTPTabBase* pTabCtrlBase);
236
245 virtual void ShowButtons(CXTPTabBase* pTabCtrlBase);
246
256 virtual void DrawBorder(CDC* pDC, const CRect& r);
257
267 DWORD GetTabStyle(CTabCtrl* pTabCtrl) const
268 {
269 _ASSERTE(::IsWindow(pTabCtrl->GetSafeHwnd()));
270 return (pTabCtrl->GetStyle() & (TCS_VERTICAL | TCS_RIGHT | TCS_BOTTOM));
271 }
272
284 BOOL IsLeft(DWORD dwStyle) const
285 {
286 return ((dwStyle & (TCS_VERTICAL | TCS_RIGHT | TCS_BOTTOM)) == TCS_VERTICAL);
287 }
288
300 BOOL IsRight(DWORD dwStyle) const
301 {
302 return ((dwStyle & (TCS_VERTICAL | TCS_RIGHT | TCS_BOTTOM)) == (TCS_VERTICAL | TCS_RIGHT));
303 }
304
316 BOOL IsTop(DWORD dwStyle) const
317 {
318 return ((dwStyle & (TCS_VERTICAL | TCS_RIGHT | TCS_BOTTOM)) == 0);
319 }
320
332 BOOL IsBottom(DWORD dwStyle) const
333 {
334 return ((dwStyle & (TCS_VERTICAL | TCS_RIGHT | TCS_BOTTOM)) == TCS_BOTTOM);
335 }
336
348 BOOL IsVert(DWORD dwStyle) const
349 {
350 return (IsRight(dwStyle) || IsLeft(dwStyle));
351 }
352
364 BOOL IsHorz(DWORD dwStyle) const
365 {
366 return (IsTop(dwStyle) || IsBottom(dwStyle));
367 }
368
377 void SwapColors(COLORREF& clrLight, COLORREF& clrDark);
378
390 void VerticalLine(CDC* pDC, int xPos, int yPos, int nLength, COLORREF clr);
391
403 void HorizontalLine(CDC* pDC, int xPos, int yPos, int nLength, COLORREF clr);
404
415 void Pixel(CDC* pDC, int xPos, int yPos, COLORREF clr);
416
417private:
418 typedef void(AFX_CDECL* LPFNDRAWROTATEDBITS)(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
419 void DrawRotatedButton(CDC* pDC, CRect rcItem, BOOL bSelected, BOOL bSwap,
420 LPFNDRAWROTATEDBITS pfnRotatedProc);
421 static void AFX_CDECL DrawRotatedBitsLeft(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
422 static void AFX_CDECL DrawRotatedBitsRight(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
423 static void AFX_CDECL DrawRotatedBitsBottom(int cx, int cy, UINT* pSrcBits, UINT* pDestBits);
424
425public:
426 BOOL m_bSystemDrawing;
427 BOOL m_bUseWinThemes;
429protected:
430 int m_iEdge;
431 CXTPWinThemeWrapper* m_themeTab;
432 CXTPPaintManagerColor m_clrNormalText;
434 CXTPPaintManagerColor m_clrSelectedText; // Color of text in a "selected" tab button. The
435 // "selected" tab button is the tab with focus. I.e.
436 // The tab becomes active when it is clicked. */
437};
438
444class _XTP_EXT_CLASS CXTPTabBaseThemeOfficeXP : public CXTPTabBaseTheme
445{
446public:
451 CXTPTabBaseThemeOfficeXP();
452
453public:
464 virtual void RefreshMetrics(CTabCtrl* pTab);
465
475 virtual void AdjustBorders(CXTPTabBase* pTabCtrl, CXTPTcbItem* pMember);
476
487 virtual void DrawButton(CDC* pDC, CXTPTabCtrlButton* pButton, COLORREF clrButton);
488
498 virtual COLORREF FillButtons(CDC* pDC, CXTPTabCtrlButtons* pButtons);
499
500protected:
514 virtual void DrawTabIcon(CDC* pDC, CTabCtrl* pTabCtrl, CRect& rcItem, int iItem);
515
525 virtual void DrawBorders(CDC* pDC, const CRect& rcClient);
526
537 virtual void FillHeader(CDC* pDC, CXTPTabBase* pTabCtrlBase, CRect rcHeader);
538
552 virtual void FillTabFace(CDC* pDC, CTabCtrl* pTabCtrl, CRect rcItem, BOOL bSelected);
553
563 virtual void DrawBorder(CDC* pDC, const CRect& r);
564};
565
570class _XTP_EXT_CLASS CXTPTabBaseThemeOffice2003 : public CXTPTabBaseThemeOfficeXP
571{
572public:
577 CXTPTabBaseThemeOffice2003();
578
579public:
590 virtual void RefreshMetrics(CTabCtrl* pTab);
600 virtual CXTPPaintManagerColor GetBackColor() const;
601
602protected:
613 virtual void FillHeader(CDC* pDC, CXTPTabBase* pTabCtrlBase, CRect rcHeader);
628 virtual COLORREF GradientFillTabFace(CDC* pDC, CTabCtrl* pTabCtrl, CRect rcItem,
629 BOOL bSelected);
642 virtual void FillTabFace(CDC* pDC, CTabCtrl* pTabCtrl, CRect rcItem, BOOL bSelected);
652 virtual void DrawBorder(CDC* pDC, const CRect& r);
653
663 virtual COLORREF FillButtons(CDC* pDC, CXTPTabCtrlButtons* pButtons);
664
665protected:
666 CXTPPaintManagerColorGradient m_clrHeaderFace;
668 CXTPPaintManagerColor m_clrShadow;
669 CXTPPaintManagerColor m_clrHighlight;
670 CXTPPaintManagerColor m_clrDarkShadow;
671 CXTPPaintManagerColor m_clrButtonSelected;
673 CXTPPaintManagerColor m_clrButtonNormal;
674};
675
677
678# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
680#endif // !defined(__XTPTABCTRLTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlTheme
CXTPControlTheme can be used as a base class for user defined themes.
Definition XTPControlTheme.h:95
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabBase
CXTPTabBase is a standalone base class.
Definition XTPTabBase.h:61
CXTPTabBaseTheme
CXTPTabBaseTheme is used to draw the CXTPTabBase object.
Definition XTPTabBaseTheme.h:46
CXTPTabBaseTheme::DrawTabText
virtual void DrawTabText(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem, BOOL bSelected, BOOL bBoldFont)
This member function is called to draw text on the tab.
CXTPTabBaseTheme::DrawBorders
virtual void DrawBorders(CDC *pDC, const CRect &rcClient)
This member function is called to draw the borders around the tab control.
CXTPTabBaseTheme::m_iEdge
int m_iEdge
The Y dimension of a 3D border.
Definition XTPTabBaseTheme.h:430
CXTPTabBaseTheme::IsRight
BOOL IsRight(DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the right side of the tab contro...
Definition XTPTabBaseTheme.h:300
CXTPTabBaseTheme::DrawTab
virtual void DrawTab(CDC *pDC, CXTPTabBase *pTabCtrlBase, int iItem)
This member function is called to draw a tab on the tab control.
CXTPTabBaseTheme::IsTop
BOOL IsTop(DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the top of the tab control.
Definition XTPTabBaseTheme.h:316
CXTPTabBaseTheme::~CXTPTabBaseTheme
virtual ~CXTPTabBaseTheme()
Destroys a CXTPTabBaseTheme object, handles cleanup and deallocation.
CXTPTabBaseTheme::ShowButtons
virtual void ShowButtons(CXTPTabBase *pTabCtrlBase)
Call this function to paint the Navigation buttons on the tab control.
CXTPTabBaseTheme::GetBackColor
virtual CXTPPaintManagerColor GetBackColor() const
Call this member function to get the current background color for the theme.
CXTPTabBaseTheme::SwapColors
void SwapColors(COLORREF &clrLight, COLORREF &clrDark)
This member function is called to swap the dark and the light colors.
CXTPTabBaseTheme::FillHeader
virtual void FillHeader(CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader)
This member function is called to draw the header for the tab control.
CXTPTabBaseTheme::IsHorz
BOOL IsHorz(DWORD dwStyle) const
This member function is called to determine if the tabs are drawn horizontally on the tab control.
Definition XTPTabBaseTheme.h:364
CXTPTabBaseTheme::IsBottom
BOOL IsBottom(DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the bottom of the tab control.
Definition XTPTabBaseTheme.h:332
CXTPTabBaseTheme::IsVert
BOOL IsVert(DWORD dwStyle) const
This member function is called to determine if the tabs are drawn vertically on the tab control.
Definition XTPTabBaseTheme.h:348
CXTPTabBaseTheme::Pixel
void Pixel(CDC *pDC, int xPos, int yPos, COLORREF clr)
This member function is called to draw a single pixel.
CXTPTabBaseTheme::IsLeft
BOOL IsLeft(DWORD dwStyle) const
This member function is called to determine if the tabs are drawn on the left side of the tab control...
Definition XTPTabBaseTheme.h:284
CXTPTabBaseTheme::GetTabStyle
DWORD GetTabStyle(CTabCtrl *pTabCtrl) const
This member function is called to determine the tab style.
Definition XTPTabBaseTheme.h:267
CXTPTabBaseTheme::DrawTabCtrl
virtual void DrawTabCtrl(CDC *pDC, CXTPTabBase *pTabCtrl)
This member function is called to render the tab control using the specified theme.
CXTPTabBaseTheme::CXTPTabBaseTheme
CXTPTabBaseTheme()
Constructs a CXTPTabBaseTheme object.
CXTPTabBaseTheme::DrawTabIcon
virtual void DrawTabIcon(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem)
This member function is called to draw the icon on the tab.
CXTPTabBaseTheme::m_bSystemDrawing
BOOL m_bSystemDrawing
TRUE to perform system drawing.
Definition XTPTabBaseTheme.h:426
CXTPTabBaseTheme::FillTabFace
virtual void FillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face.
CXTPTabBaseTheme::m_themeTab
CXTPWinThemeWrapper * m_themeTab
Windows Theme wrapper.
Definition XTPTabBaseTheme.h:431
CXTPTabBaseTheme::FillButtons
virtual COLORREF FillButtons(CDC *pDC, CXTPTabCtrlButtons *pButtons)
This method is called to draw navigate buttons.
CXTPTabBaseTheme::DrawButton
virtual void DrawButton(CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton)
This member function is called to draw a single button of a tab control.
CXTPTabBaseTheme::RefreshMetrics
virtual void RefreshMetrics(CTabCtrl *pTab)
Call this function to refresh the colors of the Tab control.
CXTPTabBaseTheme::GetHeaderRect
virtual CRect GetHeaderRect(CXTPTabBase *pTabCtrlBase)
Call this member function to get the bounding rectangle of the tab header area.
CXTPTabBaseTheme::m_clrNormalText
CXTPPaintManagerColor m_clrNormalText
Color of text in a normal tab.
Definition XTPTabBaseTheme.h:432
CXTPTabBaseTheme::FillTabFaceNativeWinXP
virtual void FillTabFaceNativeWinXP(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face so that the tab appears with the Native Windows X...
CXTPTabBaseTheme::VerticalLine
void VerticalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a vertical line.
CXTPTabBaseTheme::m_bUseWinThemes
BOOL m_bUseWinThemes
TRUE to use Windows XP themes when available.
Definition XTPTabBaseTheme.h:427
CXTPTabBaseTheme::DrawBorder
virtual void DrawBorder(CDC *pDC, const CRect &r)
This member function is called to draw a border around a tab child window.
CXTPTabBaseTheme::AdjustBorders
virtual void AdjustBorders(CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember)
Call this member function to redraw the borders for a particular tab.
CXTPTabBaseTheme::HorizontalLine
void HorizontalLine(CDC *pDC, int xPos, int yPos, int nLength, COLORREF clr)
This member function is called to draw a horizontal line.
CXTPTabBaseThemeOffice2003
Class CXTPTabBaseThemeOffice2003 is derived from CXTPTabBaseThemeOfficeXP.
Definition XTPTabBaseTheme.h:571
CXTPTabBaseThemeOffice2003::GetBackColor
virtual CXTPPaintManagerColor GetBackColor() const
This member function is called to get the background for the theme.
CXTPTabBaseThemeOffice2003::FillHeader
virtual void FillHeader(CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader)
This member function is called to draw the header for the tab Control.
CXTPTabBaseThemeOffice2003::m_clrButtonNormal
CXTPPaintManagerColor m_clrButtonNormal
Represents the color used for normal buttons.
Definition XTPTabBaseTheme.h:673
CXTPTabBaseThemeOffice2003::GradientFillTabFace
virtual COLORREF GradientFillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face with a gradient fill.
CXTPTabBaseThemeOffice2003::CXTPTabBaseThemeOffice2003
CXTPTabBaseThemeOffice2003()
Constructs a CXTPTabBaseThemeOffice2003 object.
CXTPTabBaseThemeOffice2003::m_clrHeaderFace
CXTPPaintManagerColorGradient m_clrHeaderFace
Represents the gradient color of the header face.
Definition XTPTabBaseTheme.h:666
CXTPTabBaseThemeOffice2003::FillTabFace
virtual void FillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called to draw the tab face.
CXTPTabBaseThemeOffice2003::FillButtons
virtual COLORREF FillButtons(CDC *pDC, CXTPTabCtrlButtons *pButtons)
This method is called to draw navigate buttons.
CXTPTabBaseThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics(CTabCtrl *pTab)
This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member v...
CXTPTabBaseThemeOffice2003::m_clrShadow
CXTPPaintManagerColor m_clrShadow
Represents the color used for shadows.
Definition XTPTabBaseTheme.h:668
CXTPTabBaseThemeOffice2003::DrawBorder
virtual void DrawBorder(CDC *pDC, const CRect &r)
This member function is called to draw a border around a tab child window.
CXTPTabBaseThemeOffice2003::m_clrHighlight
CXTPPaintManagerColor m_clrHighlight
Represents the highlight color.
Definition XTPTabBaseTheme.h:669
CXTPTabBaseThemeOffice2003::m_clrDarkShadow
CXTPPaintManagerColor m_clrDarkShadow
Represents the color used for dark shadows.
Definition XTPTabBaseTheme.h:670
CXTPTabBaseThemeOffice2003::m_clrButtonSelected
CXTPPaintManagerColor m_clrButtonSelected
Represents the color used for selected buttons.
Definition XTPTabBaseTheme.h:671
CXTPTabBaseThemeOfficeXP
Class CXTPTabBaseThemeOfficeXP is derived from CXTPTabBaseTheme.
Definition XTPTabBaseTheme.h:445
CXTPTabBaseThemeOfficeXP::CXTPTabBaseThemeOfficeXP
CXTPTabBaseThemeOfficeXP()
Constructs a CXTPTabBaseThemeOfficeXP object.
CXTPTabBaseThemeOfficeXP::DrawBorders
virtual void DrawBorders(CDC *pDC, const CRect &rcClient)
This member function is called to draw the borders around the tab control.
CXTPTabBaseThemeOfficeXP::FillHeader
virtual void FillHeader(CDC *pDC, CXTPTabBase *pTabCtrlBase, CRect rcHeader)
This member function is called to draw the header for the tab control.
CXTPTabBaseThemeOfficeXP::DrawTabIcon
virtual void DrawTabIcon(CDC *pDC, CTabCtrl *pTabCtrl, CRect &rcItem, int iItem)
This member function is called to draw the icon on the tab.
CXTPTabBaseThemeOfficeXP::FillTabFace
virtual void FillTabFace(CDC *pDC, CTabCtrl *pTabCtrl, CRect rcItem, BOOL bSelected)
This member function is called draw the tab face.
CXTPTabBaseThemeOfficeXP::FillButtons
virtual COLORREF FillButtons(CDC *pDC, CXTPTabCtrlButtons *pButtons)
This method is called to draw navigate buttons.
CXTPTabBaseThemeOfficeXP::DrawButton
virtual void DrawButton(CDC *pDC, CXTPTabCtrlButton *pButton, COLORREF clrButton)
This member is called to draw a single button of a tab control.
CXTPTabBaseThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics(CTabCtrl *pTab)
This function calls the base class RefreshMetrics and then calls DeleteObject() for the CPen member v...
CXTPTabBaseThemeOfficeXP::DrawBorder
virtual void DrawBorder(CDC *pDC, const CRect &r)
This member function is called to draw a border around a tab child window.
CXTPTabBaseThemeOfficeXP::AdjustBorders
virtual void AdjustBorders(CXTPTabBase *pTabCtrl, CXTPTcbItem *pMember)
Call this member function to redraw the borders for a particular tab.
CXTPTabCtrlButton
CXTPTabCtrlButton is a standalone structure class.
Definition XTPTabCtrlButtons.h:44
CXTPTabCtrlButtons
CXTPTabCtrlButtons is a CWnd derived class.
Definition XTPTabCtrlButtons.h:90
CXTPTabCtrl
CXTPTabCtrl is a multiple inheritance class derived from CTabCtrl and CXTPTabCtrlBase.
Definition XTPTabCtrl.h:46
CXTPTcbItem
The CXTPTcbItem class is used to maintain information for a particular tab item in a CXTPExcelTabCtrl...
Definition XTPGlobal.h:41
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


CXTPFlowGraphNodeCustom Member List

This is the complete list of members for CXTPFlowGraphNodeCustom, including all inherited members.

AddNamedConnectionPoints(LPCTSTR, XTPFlowGraphConnectionPointType, LPCTSTR) | CXTPFlowGraphNodeCustom | inlinevirtual
CalcMinSize() | CXTPFlowGraphNodeCustom | virtual
CreateStretchedPathData(const CXTPMarkupPath *pNodePath) const | CXTPFlowGraphNodeCustom | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphElement() | CXTPFlowGraphElement |
CXTPFlowGraphNode() | CXTPFlowGraphNode |
CXTPFlowGraphNodeCustom() | CXTPFlowGraphNodeCustom |
DoCommonPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphNode |
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphNodeCustom | virtual
Draw(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphNode | virtual
DrawConnectionPoints(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphNode | virtual
DrawSelectionRect(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphNode | virtual
DrawWindowContent(CXTPFlowGraphDrawContext *) | CXTPFlowGraphNodeCustom | inlinevirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPFlowGraphNode | virtual
GetCaptionPosition() const | CXTPFlowGraphNodeCustom |
GetCaptionRect() const | CXTPFlowGraphNode |
GetCaptionTextBlock() const | CXTPFlowGraphNode |
GetColor() const | CXTPFlowGraphNode |
GetConnectionPoints() const | CXTPFlowGraphNode |
GetControl() const | CXTPFlowGraphNode | virtual
GetGroup() const | CXTPFlowGraphNode |
GetID() const | CXTPFlowGraphNode |
GetImage() const | CXTPFlowGraphNode |
GetImageIndex() const | CXTPFlowGraphNode |
GetLocation() const | CXTPFlowGraphNode |
GetMarkupTableRowIndex(CXTPFlowGraphConnectionPoint *pPoint, CXTPMarkupUIElementCollection *pChildren) | CXTPFlowGraphNode |
GetMarkupVisualElementRect(const CXTPMarkupVisual *pElementVisual) const | CXTPFlowGraphNode |
GetMinSize() const | CXTPFlowGraphNode |
GetPage() const | CXTPFlowGraphNode | virtual
GetPointRect(CPoint point) const | CXTPFlowGraphNodeCustom | protected
GetScreenRect(BOOL bIncludeConnectionPointsEllipses=TRUE) const | CXTPFlowGraphNode |
GetSelectionRect() | CXTPFlowGraphNodeCustom |
CXTPFlowGraphNode::GetSelectionRect() const | CXTPFlowGraphNode |
GetSize() const | CXTPFlowGraphNode |
GetStyle() const | CXTPFlowGraphNode |
GetTableRowCaptionRect(CXTPFlowGraphConnectionPoint *pPoint) const | CXTPFlowGraphNode |
GetTableRowTextBlock(const CString &strConnectionPointName) const | CXTPFlowGraphNode |
GetTag() const | CXTPFlowGraphNode |
GetTooltip() const | CXTPFlowGraphNode |
GetUserSize() const | CXTPFlowGraphNode |
GetWindowHandle() const | CXTPFlowGraphNode |
GetWindowSize() const | CXTPFlowGraphNode |
HitTestConnectionPoint(CPoint point) | CXTPFlowGraphNodeCustom | virtual
IsCustomMarkup() const | CXTPFlowGraphNodeCustom | inlinevirtual
IsLocked() const | CXTPFlowGraphNode |
IsResizable() const | CXTPFlowGraphNode |
IsSelected() const | CXTPFlowGraphElement |
IsVisible() const | CXTPFlowGraphNode |
m_bAlpha | CXTPFlowGraphNode | protected
m_bDirty | CXTPFlowGraphElement |
m_bLocked | CXTPFlowGraphNode | protected
m_bSelected | CXTPFlowGraphElement | protected
m_bVisible | CXTPFlowGraphNode | protected
m_clrNode | CXTPFlowGraphNode | protected
m_dwTag | CXTPFlowGraphNode | protected
m_hWnd | CXTPFlowGraphNode | protected
m_nGroupId | CXTPFlowGraphNode | protected
m_nId | CXTPFlowGraphNode | protected
m_nImageIndex | CXTPFlowGraphNode | protected
m_nStyle | CXTPFlowGraphNode | protected
m_pConnectionPoints | CXTPFlowGraphNode | protected
m_pGroup | CXTPFlowGraphNode | protected
m_pMarkup | CXTPFlowGraphNode | protected
m_pNextVisibleNode | CXTPFlowGraphNode | protected
m_pOriginalWindowProc | CXTPFlowGraphNode | protected
m_pPage | CXTPFlowGraphNode | protected
m_ptLocation | CXTPFlowGraphNode | protected
m_strCaption | CXTPFlowGraphNode | protected
m_strTooltip | CXTPFlowGraphNode | protected
m_szActualSize | CXTPFlowGraphNode | protected
m_szUserMinSize | CXTPFlowGraphNode | protected
m_szUserSize | CXTPFlowGraphNode | protected
m_szWindow | CXTPFlowGraphNode | protected
m_WindowToNodeHash | CXTPFlowGraphNode | protectedstatic
OnGraphChanged() | CXTPFlowGraphElement |
OnRemoved() | CXTPFlowGraphNode | protectedvirtual
RecalLayout() | CXTPFlowGraphNode | virtual
Remove() | CXTPFlowGraphNode |
RemoveMarkupTableRow(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
Select(BOOL bSelect=TRUE) | CXTPFlowGraphNode | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPFlowGraphNode | virtual
SetCaptionPosition(XTPFlowGraphCustomNodeCaptionPosition pos) | CXTPFlowGraphNodeCustom |
SetColor(COLORREF clr, BYTE bAlpha=255) | CXTPFlowGraphNodeCustom | virtual
SetDefaultMarkup() | CXTPFlowGraphNodeCustom | inlinevirtual
SetID(int nId) | CXTPFlowGraphNode |
SetImageIndex(int nImageIndex) | CXTPFlowGraphNode |
SetLocation(CPoint ptLocation) | CXTPFlowGraphNode |
SetLocked(BOOL bLocked=TRUE) | CXTPFlowGraphNode |
SetMarkupText(LPCTSTR szMarkupText) | CXTPFlowGraphNode |
SetMinSize(CSize sz) | CXTPFlowGraphNode |
SetSize(CSize sz) | CXTPFlowGraphNodeCustom | virtual
SetSizeCore(CSize sz) | CXTPFlowGraphNode |
SetStyle(int nStyle) | CXTPFlowGraphNode |
SetTag(DWORD_PTR dwTag) | CXTPFlowGraphNode |
SetTooltip(LPCTSTR lpszTooltip) | CXTPFlowGraphNode |
SetVisible(BOOL bVisible=TRUE) | CXTPFlowGraphNode |
SetWindowHandle(HWND) | CXTPFlowGraphNodeCustom | inlinevirtual
SetWindowSize(CSize) | CXTPFlowGraphNodeCustom | inlinevirtual
UpdateCaptionColor() | CXTPFlowGraphNodeCustom | virtual
UpdateColorRecursive(CXTPMarkupObject *pRootElement, COLORREF clrColor) | CXTPFlowGraphNodeCustom | virtual
UpdateConnectionPoints(CXTPMarkupObject *pRootElement) | CXTPFlowGraphNodeCustom | virtual
UpdateMarkupCaption() | CXTPFlowGraphNodeCustom | virtual
UpdateMarkupFont() | CXTPFlowGraphNode | virtual
UpdateMarkupImage() | CXTPFlowGraphNode | virtual
UpdateMarkupPointCaption(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
UpdateMarkupPointColor(CXTPFlowGraphConnectionPoint *) | CXTPFlowGraphNodeCustom | inlinevirtual
UpdateMarkupPointImage(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
UpdateMarkupPointName(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphNode |
UpdateWindowPosition() | CXTPFlowGraphNodeCustom | inlinevirtual
~CXTPFlowGraphElement() | CXTPFlowGraphElement | virtual
~CXTPFlowGraphNode() | CXTPFlowGraphNode | virtual
~CXTPFlowGraphNodeCustom() | CXTPFlowGraphNodeCustom |


Toolkit Pro: XTPGridThemeResource.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPGridThemeResource_H__)
24# define __XTPGridThemeResource_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeResource : public CXTPGridPaintManager
39{
40public:
45 CXTPGridThemeResource();
46
52 virtual void RefreshMetrics();
53
63 CSize DrawCollapsedBitmap(CDC* pDC, const CXTPGridRow* pRow, CRect& rcBitmap);
64
74 virtual void DrawNoGroupByText(CDC* pDC, CRect rcItem);
75
82 virtual void FillFooter(CDC* pDC, CRect rcFooter);
83
116 virtual void DrawTriangle(CDC* pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth,
117 BOOL bColumnPressed);
118
119 using CXTPGridPaintManager::DrawTriangle;
120
121protected:
133 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
134 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
135 CXTPGridHeader* pHeader = NULL);
136
137 virtual void DrawPlainColumnBackground(CDC* /*pDC*/, CRect /*rcColumn*/);
138
139public:
147 virtual void DrawColumnFooterDivider(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn);
148
159 virtual void DrawColumnText(CDC* pDC, CRect rcText, CString strCaption, int nHeaderAlignment,
160 BOOL bIsHeader, BOOL bColumnPressed);
161
174 void DrawSectionDivider(CDC* pDC, const CRect& rc,
175 XTPGridSectionDividerPosition dividerPosition,
176 XTPGridSectionDividerStyle dividerStyle,
177 CXTPPaintManagerColor dividerColor);
178};
180# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
181#endif //#if !defined(__XTPGridThemeResource_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridPaintManager::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridThemeResource
CXTPGridThemeResource is a CXTPGridPaintManager derived class that represents a Resource style theme.
Definition XTPGridThemeResource.h:39
CXTPGridThemeResource::DrawColumnText
virtual void DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
CXTPGridThemeResource::DrawCollapsedBitmap
CSize DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
CXTPGridThemeResource::DrawNoGroupByText
virtual void DrawNoGroupByText(CDC *pDC, CRect rcItem)
This method used to draw a "No items" text message in the Group By area when there are no items insid...
CXTPGridThemeResource::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPGridThemeResource::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPGridThemeResource::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPGridThemeResource::FillFooter
virtual void FillFooter(CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
CXTPGridThemeResource::DrawColumnFooterDivider
virtual void DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
CXTPGridThemeResource::CXTPGridThemeResource
CXTPGridThemeResource()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeResource::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


CXTPSkinObjectEdit Member List

This is the complete list of members for CXTPSkinObjectEdit, including all inherited members.

CheckScrollBarsDraw() | CXTPSkinObjectUser32Control | protectedvirtual
CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectEdit() | CXTPSkinObjectEdit |
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectUser32Control() | CXTPSkinObjectUser32Control | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectEdit() | CXTPSkinObjectEdit | virtual
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


CXTPTabColorSetVisualStudio2012 Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2012, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2012 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetVisualStudio2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPScrollBarThemeVisualStudio2017.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2017_H__)
24# define __XTPSCROLLBARTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeVisualStudio2017 : public CXTPScrollBarThemeVisualStudio2012
39{
40protected:
41 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
42};
43
44# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
46#endif // !defined(__XTPSCROLLBARTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeVisualStudio2012
Scrollbar paint manager used to draw Visual Studio 2012 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2012.h:39
CXTPScrollBarThemeVisualStudio2017
Scrollbar paint manager used to draw Visual Studio 2017 like scrollbars.
Definition XTPScrollBarThemeVisualStudio2017.h:39
CXTPScrollBarThemeVisualStudio2017::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: XTPSystemPreview.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • System
XTPSystemPreview.h
Go to the documentation of this file.
1
24#if !defined(__XTPSYSTEMPREVIEW_H__)
25# define __XTPSYSTEMPREVIEW_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSystemPreviewProvider;
34
35class _XTP_EXT_CLASS CXTPSystemPreview : public IXTPPreview
36{
37 struct IPreviewHandler;
38 struct IInitializeWithStream;
39 struct IInitializeWithFile;
40
41public:
42 CXTPSystemPreview();
43 ~CXTPSystemPreview();
44
45private:
46 virtual BOOL IsReady() const;
47 virtual BOOL IsAvailable() const;
48 virtual BOOL HasOwnNavigator() const;
49 virtual UINT GetNumberOfPages() const;
50 virtual SIZE GetPreferredPageSize() const;
51 virtual void GoToPage(UINT page);
52 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect);
53 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result);
54 virtual BOOL SupportsCompositedParent() const;
55 virtual void Activate();
56
57 BOOL LoadFile(LPCTSTR pFilePath, HWND hwndParent);
58 BOOL LoadFile(IStream* pStream, LPCTSTR pImpliedFileName, HWND hwndParent);
59
60private:
61 friend class CXTPSystemPreviewProvider;
62 BOOL m_bLoadFinished;
63 BOOL m_bLoadSuccess;
64 IPreviewHandler* m_pPreview;
65 IStream* m_pDataStream;
66 HWND m_hParentWindow;
67};
68
69# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
70#endif // #if !defined(__XTPSYSTEMPREVIEW_H__)
71
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSystemPreviewProvider
Provides a preview handler that uses supported system means for previewing files.
Definition XTPSystemPreviewProvider.h:43
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.


Toolkit Pro: XTPTabClientSticker.h Source File

  • Source
  • CommandBars
  • TabClient
XTPTabClientSticker.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCLIENTSTICKER_H__)
24# define __XTPTABCLIENTSTICKER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CWorkspace;
34class CXTPImageManager;
35
40enum XTPTabClientStickerPart
41{
42 xtpTabClientStickerNone = 0,
43 xtpTabClientStickerLeft = 1,
45 xtpTabClientStickerRight = 2,
47 xtpTabClientStickerTop = 4,
49 xtpTabClientStickerBottom = 8,
51 xtpTabClientStickerCenter = 16,
53};
54
60class CXTPStickerBase : public CWnd
61{
62 DECLARE_DYNAMIC(CXTPStickerBase);
63
64public:
69 CXTPStickerBase();
70
75 virtual ~CXTPStickerBase();
76
83 BOOL Create();
84 using CWnd::Create;
85
86 void SetTarget(CWnd* pTarget);
87 CWnd* GetTarget() const;
88
89protected:
91 DECLARE_MESSAGE_MAP()
92 //{{AFX_MSG(CXTPTabClientSticker)
93 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
94 afx_msg void OnPaint();
95 //}}AFX_MSG
98 virtual void OnDraw(CDC& dc) = 0;
99 virtual int InitStickers() = 0;
100 virtual CRect GetTargetRect() = 0;
101 void IncludeRgnPart(CRgn* pRgn, int x1, int y, int x2);
102 void RegionFromBitmap(CRgn* pRgn, CDC* pDC, CRect rc);
103 void InitColors();
104 void InitSize();
105
106 CWnd* m_pTarget;
107 CXTPMarkupContext* m_pMarkupContext;
108 CXTPMarkupThemePart m_partBackNormal;
109 CXTPMarkupThemePart m_partBackSelected;
110 CXTPMarkupThemePart m_partLeftNormal;
111 CXTPMarkupThemePart m_partLeftSelected;
112 CXTPMarkupThemePart m_partTopNormal;
113 CXTPMarkupThemePart m_partTopSelected;
114 CXTPMarkupThemePart m_partRightNormal;
115 CXTPMarkupThemePart m_partRightSelected;
116 CXTPMarkupThemePart m_partBottomNormal;
117 CXTPMarkupThemePart m_partBottomSelected;
118 CXTPMarkupThemePart m_partCenterNormal;
119 CXTPMarkupThemePart m_partCenterSelected;
120
121 CSize m_szIcon;
122 int m_delimeterX;
123 int m_delimeterY;
124 CRect m_rcSticker;
125 CRect m_rcBack;
126 CRect m_rcLeft;
127 CRect m_rcTop;
128 CRect m_rcRight;
129 CRect m_rcBottom;
130 CRect m_rcCenter;
131 int m_stickers;
132};
133
138class CXTPTabClientSticker : public CXTPStickerBase
139{
140 DECLARE_DYNCREATE(CXTPTabClientSticker);
141
142 CXTPTabClientSticker();
143
144public:
151 CXTPTabClientSticker(CXTPTabClientWnd* pTabClientWnd, int nTabWorkspace);
152
157 virtual ~CXTPTabClientSticker();
158
168 XTPTabClientStickerPart HitTest(POINT pt) const;
169
176 CXTPTabClientWnd* GetTargetTabClientWnd() const;
177
178protected:
180 DECLARE_MESSAGE_MAP()
181 //{{AFX_MSG(CXTPTabClientSticker)
182 //}}AFX_MSG
185private:
186 virtual void OnDraw(CDC& dc);
187 virtual CRect GetTargetRect();
188 virtual int InitStickers();
189 void InitIcons();
190
191 int m_nTargetWorkspace;
192};
193
194# ifndef _XTP_COMMANDBARS_ACTIVEX
195# ifdef _XTP_INCLUDE_DOCKINGPANE
200class CXTPDockPaneSticker : public CXTPStickerBase
201{
202 DECLARE_DYNCREATE(CXTPDockPaneSticker);
203
204 CXTPDockPaneSticker();
205
206public:
212 CXTPDockPaneSticker(CXTPDockingPaneTabbedContainer* pDockPane);
213
218 virtual ~CXTPDockPaneSticker();
219
229 XTPDockingPaneStickerType HitTest(POINT pt) const;
230
238 CXTPDockingPaneTabbedContainer* GetTargetDockPaneWnd() const;
239
240protected:
242 DECLARE_MESSAGE_MAP()
243 //{{AFX_MSG(CXTPDockPaneSticker)
244 //}}AFX_MSG
247private:
248 virtual void OnDraw(CDC& dc);
249 virtual CRect GetTargetRect();
250 virtual int InitStickers();
251 void InitIcons();
252};
253# endif
254# endif
255
257# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
258#endif // !defined(__XTPTABCLIENTSTICKER_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneStickerType
XTPDockingPaneStickerType
XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be...
Definition XTPDockingPaneDefines.h:362
XTPEnableNoisyWarnings.h
XTPTabClientStickerPart
XTPTabClientStickerPart
Identifies tab client sticker part.
Definition XTPTabClientSticker.h:41
xtpTabClientStickerTop
@ xtpTabClientStickerTop
Display the docking sticker indicating the tab can be docked on the top.
Definition XTPTabClientSticker.h:47
xtpTabClientStickerRight
@ xtpTabClientStickerRight
Display the docking sticker indicating the tab can be docked to the right.
Definition XTPTabClientSticker.h:45
xtpTabClientStickerBottom
@ xtpTabClientStickerBottom
Display the docking sticker indicating the tab can be docked on the bottom.
Definition XTPTabClientSticker.h:49
xtpTabClientStickerCenter
@ xtpTabClientStickerCenter
Display the docking sticker indicating the tab can be docked in the center.
Definition XTPTabClientSticker.h:51
xtpTabClientStickerNone
@ xtpTabClientStickerNone
No docking stickers are displayed.
Definition XTPTabClientSticker.h:42
xtpTabClientStickerLeft
@ xtpTabClientStickerLeft
Display the docking sticker indicating the tab can be docked to the left.
Definition XTPTabClientSticker.h:43
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42
CXTPStickerBase
A sticker base control.
Definition XTPTabClientSticker.h:61
CXTPStickerBase::CXTPStickerBase
CXTPStickerBase()
Construct a sticker object.
CXTPStickerBase::m_stickers
int m_stickers
Allowed stickers for tab client.
Definition XTPTabClientSticker.h:131
CXTPStickerBase::~CXTPStickerBase
virtual ~CXTPStickerBase()
Handles resource cleanup.
CXTPStickerBase::Create
BOOL Create()
Creates a sticker control.
CXTPTabClientSticker
A tab client sticker control.
Definition XTPTabClientSticker.h:139
CXTPTabClientSticker::CXTPTabClientSticker
CXTPTabClientSticker(CXTPTabClientWnd *pTabClientWnd, int nTabWorkspace)
Construct a sticker object.
CXTPTabClientSticker::HitTest
XTPTabClientStickerPart HitTest(POINT pt) const
Determines which part of the sticker is under the specified point.
CXTPTabClientSticker::~CXTPTabClientSticker
virtual ~CXTPTabClientSticker()
Handles resource cleanup.
CXTPTabClientSticker::GetTargetTabClientWnd
CXTPTabClientWnd * GetTargetTabClientWnd() const
Gets the target tab client window pointer.
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383


CXTPPropExchangeIniFile Member List

This is the complete list of members for CXTPPropExchangeIniFile, including all inherited members.

AssignFile(LPCTSTR lpszFileName) | CXTPPropExchangeIniFile |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropExchange() | CXTPPropExchange |
CXTPPropExchangeIniFile(BOOL bLoading, LPCTSTR lpszParentSection, LPCTSTR lpszSection) | CXTPPropExchangeIniFile |
EmptySection() | CXTPPropExchangeIniFile | virtual
ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes) | CXTPPropExchange | virtual
ExchangeLocale() | CXTPPropExchange |
ExchangeObjectInstance(CObject *&pObject, CRuntimeClass *pObjectRuntime) | CXTPPropExchange | virtual
ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL) | CXTPPropExchangeIniFile | virtual
ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass) | CXTPPropExchange | virtual
ExchangeSchema() | CXTPPropExchange |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetArchive(LPCTSTR pszPropName) | CXTPPropExchange | virtual
GetEnumerator(LPCTSTR lpszSection) | CXTPPropExchange | virtual
GetSchema() const | CXTPPropExchange |
GetSection(LPCTSTR lpszSection) | CXTPPropExchangeIniFile | virtual
InitSection(CXTPPropExchange *pRootSection) | CXTPPropExchange | protected
IsAllowBlobValues() const | CXTPPropExchange | virtual
IsAllowDefaultValues() const | CXTPPropExchange | virtual
IsLoading() const | CXTPPropExchange |
IsRootSection() const | CXTPPropExchange |
IsStoring() const | CXTPPropExchange |
LoadFromFile(LPCTSTR lpszFileName) | CXTPPropExchangeIniFile |
m_bChildSection | CXTPPropExchange | protected
m_bEmptySection | CXTPPropExchange | protected
m_bInitialized | CXTPPropExchange | protected
m_bLoading | CXTPPropExchange | protected
m_bTempFile | CXTPPropExchangeIniFile | protected
m_bUseDefaultOnLoad | CXTPPropExchange | protected
m_bUseDefaultOnSave | CXTPPropExchange | protected
m_dwData | CXTPPropExchange |
m_lcidDateTime | CXTPPropExchange | static
m_nSchema | CXTPPropExchange | protected
m_pOwner | CXTPPropExchange |
m_strFileName | CXTPPropExchangeIniFile | protected
m_strSectionName | CXTPPropExchangeIniFile | protected
OnBeforeExchange() | CXTPPropExchangeIniFile | virtual
Read(LPCTSTR pszPropName, void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
ReadCount() | CXTPPropExchange | virtual
ReleaseArchive(LPCTSTR pszPropName, CArchive *pArchive) | CXTPPropExchange | virtual
SaveToFile(LPCTSTR strFileName) | CXTPPropExchangeIniFile |
SetSchema(UINT nSchemaVersion) | CXTPPropExchange |
UseDefaultOnLoad(BOOL bUseDefaultOnLoad=TRUE) | CXTPPropExchange |
UseDefaultOnSave(BOOL bUseDefaultOnSave=TRUE) | CXTPPropExchange |
Write(LPCTSTR pszPropName, const void *lpBuf, UINT nCount) | CXTPPropExchange | virtual
WriteCount(DWORD dwCount) | CXTPPropExchange | virtual
~CXTPPropExchange() | CXTPPropExchange | virtual
~CXTPPropExchangeIniFile() | CXTPPropExchangeIniFile |


CXTPScrollBarThemeVisualStudio2017 Member List

This is the complete list of members for CXTPScrollBarThemeVisualStudio2017, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarThemeVisualStudio2017 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


CXTPChart3dFunnelSeriesStyle Member List

This is the complete list of members for CXTPChart3dFunnelSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChart3dFunnelSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChart3dFunnelSeriesStyle | virtual
CXTPChart3dFunnelSeriesStyle() | CXTPChart3dFunnelSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartFunnelSeriesStyleBase() | CXTPChartFunnelSeriesStyleBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChart3dFunnelSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBaseEdgeCount() const | CXTPChart3dFunnelSeriesStyle |
GetBorder() const | CXTPChartFunnelSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartFunnelSeriesStyleBase |
GetHeightToWidthRatio() const | CXTPChartFunnelSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetPointDistance() const | CXTPChartFunnelSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsEqualHeight() const | CXTPChartFunnelSeriesStyleBase |
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChart3dFunnelSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetBaseEdgeCount(int nEdgeCount) | CXTPChart3dFunnelSeriesStyle |
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetEqualHeight(BOOL bEqualHeight) | CXTPChartFunnelSeriesStyleBase |
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetHeightToWidthRatio(double dRatio) | CXTPChartFunnelSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetPointDistance(int nPointDistance) | CXTPChartFunnelSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartFunnelSeriesStyleBase() | CXTPChartFunnelSeriesStyleBase | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPChartAxis.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxis.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXIS_H__)
24# define __XTPCHARTAXIS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagram;
34class CXTPChartDiagram2D;
35class CXTPChartAxisGridLines;
36class CXTPChartAxisLabel;
37class CXTPChartAxisTitle;
38class CXTPChartAxisTickMarks;
39class CXTPChartScaleTypeMap;
40class CXTPChartAxisRange;
41class CXTPChartAxisView;
42class CXTPChartDiagramView;
43class CXTPChartDeviceContext;
44class CXTPChartAxisAppearance;
45class CXTPChartFillStyle;
46class CXTPChartAxisConstantLines;
47class CXTPChartAxisCustomLabels;
48class CXTPChartAxisStrips;
49class CXTPChartElementView;
50
55enum XTPChartAxisAlignment
56{
57 xtpChartAxisNear,
59 xtpChartAxisFar
61};
62
67enum XTPChartAxisDateTimeScaleUnit
68{
69 xtpChartScaleMinute,
70 xtpChartScaleHour,
71 xtpChartScaleDay,
72 xtpChartScaleMonth,
73 xtpChartScaleYear,
74};
75
85class _XTP_EXT_CLASS CXTPChartAxis : public CXTPChartElement
86{
88 DECLARE_DYNAMIC(CXTPChartAxis)
90public:
97 CXTPChartAxis(CXTPChartDiagram* pDiagram);
98
103 virtual ~CXTPChartAxis();
104
105public:
115 virtual CXTPChartAxisView* CreateView(CXTPChartDeviceContext* pDC,
116 CXTPChartElementView* pParentView);
117
126 void UpdateRange(CXTPChartDeviceContext* pDC, CXTPChartAxisView* pView);
127
134 virtual BOOL IsVertical() const = 0;
135
142 virtual BOOL IsValuesAxis() const = 0;
143
151 CXTPChartDiagram* GetDiagram() const;
152
162 XTPChartScaleType GetScaleType() const;
163
174 CXTPChartScaleTypeMap* GetScaleTypeMap() const;
175
185 virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const = 0;
186
196 CXTPChartAxisRange* GetRange() const;
197
207 CXTPChartAxisLabel* GetLabel() const;
208
218 CXTPChartAxisGridLines* GetGridLines() const;
219
230 CXTPChartAxisTickMarks* GetTickMarks() const;
231
239 CXTPChartAxisConstantLines* GetConstantLines() const;
240
247 CXTPChartAxisCustomLabels* GetCustomLabels() const;
248
256 CXTPChartAxisStrips* GetStrips() const;
257
264 CXTPChartAxisTitle* GetTitle() const;
265
272 CXTPChartColor GetActualColor() const;
273
280 CXTPChartColor GetColor() const;
281
288 void SetColor(const CXTPChartColor& color);
289
296 CXTPChartColor GetInterlacedColor() const;
297
304 CXTPChartColor GetActualInterlacedColor() const;
305
312 void SetInterlacedColor(const CXTPChartColor& color);
313
320 CXTPChartColor GetInterlacedColor2() const;
321
328 CXTPChartColor GetActualInterlacedColor2() const;
329
336 void SetInterlacedColor2(const CXTPChartColor& color);
337
346 CXTPChartFillStyle* GetInterlacedFillStyle() const;
347
362 XTPChartAxisAlignment GetAlignment() const;
363
378 void SetAlignment(XTPChartAxisAlignment nAlignment);
379
389 BOOL IsInterlaced() const;
390
398 void SetInterlaced(BOOL bInterlaced);
399
407 BOOL IsVisible() const;
408
415 void SetVisible(BOOL bVisible);
416
423 int GetThickness() const;
424
431 void SetThickness(int nThicknes);
432
439 int GetIndex() const;
440
447 void SetIndex(int nIndex);
448
455 void SetMinorCount(int nMinorCount);
456
463 int GetMinorCount() const;
464
471 void SetReversed(BOOL bRevered);
472
479 BOOL IsReversed() const;
480
487 CXTPChartAxisAppearance* GetAppearance() const;
488
498 void SetGridSpacingAuto(BOOL bGridSpacingAuto);
499
500 BOOL GetGridSpacingAuto() const;
501
511 void SetGridSpacing(double dGridSpacing);
512
519 double GetGridSpacing() const;
520
521 BOOL IsSecondary() const;
522
523 BOOL IsAllowZoom() const;
524 void SetAllowZoom(BOOL bAllowZoom);
525
534 void SetLogarithmic(BOOL bLogarithmic);
535
536 BOOL IsLogarithmic() const;
537
546 void SetLogarithmicBase(double dLogarithmicBase);
547
548 double GetLogarithmicBase() const;
549
558 void SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit);
559
560 XTPChartAxisDateTimeScaleUnit GetDateTimeScaleUnit() const;
561
562 CXTPChartAxisView* GetAxisView() const;
563
564public:
565 void DoPropExchange(CXTPPropExchange* pPX);
566
567# ifdef _XTP_ACTIVEX
568public:
570 DECLARE_DISPATCH_MAP()
571 DECLARE_INTERFACE_MAP()
572 DECLARE_OLETYPELIB_EX(CXTPChartAxis);
573
574 afx_msg LPDISPATCH OleGetConstantLines();
575 afx_msg LPDISPATCH OleGetCustomLabels();
576 afx_msg LPDISPATCH OleGetStrips();
577 afx_msg LPDISPATCH OleGetLabel();
578 afx_msg LPDISPATCH OleGetTickMarks();
579 afx_msg LPDISPATCH OleGetTitle();
580 afx_msg LPDISPATCH OleGetGridLines();
581 afx_msg LPDISPATCH OleGetRange();
582 afx_msg LPDISPATCH OleGetInterlacedFillStyle();
583
584 afx_msg OLE_COLOR OleGetColor();
585 afx_msg void OleSetColor(OLE_COLOR clr);
586 afx_msg OLE_COLOR OleGetInterlacedColor();
587 afx_msg void OleSetInterlacedColor(OLE_COLOR clr);
588 afx_msg OLE_COLOR OleGetInterlacedColor2();
589 afx_msg void OleSetInterlacedColor2(OLE_COLOR clr);
590
592# endif
593
594protected:
595 CXTPChartDiagram* m_pDiagram;
596 BOOL m_bVisible;
597 BOOL m_bReversed;
599 int m_nThickness;
600 int m_nMinorCount;
601 BOOL m_bSecondary;
602 int m_nIndex;
603 XTPChartAxisAlignment m_nAlignment;
604 CXTPChartColor m_clrColor;
605 CXTPChartColor m_clrInterlacedColor;
606 CXTPChartColor m_clrInterlacedColor2;
607 CXTPChartFillStyle* m_pInterlacedFillStyle;
609 BOOL m_bInterlaced;
611 double m_dGridSpacing;
612 BOOL m_bGridSpacingAuto;
614 BOOL m_bAllowZoom;
615
616 BOOL m_bLogarithmic;
617 double m_dLogarithmicBase;
619 CXTPChartAxisGridLines* m_pGridLines;
620 CXTPChartAxisLabel* m_pLabel;
621 CXTPChartAxisTitle* m_pTitle;
622 CXTPChartAxisTickMarks* m_pTickMarks;
623 CXTPChartScaleTypeMap* m_pScaleTypeMap;
624 CXTPChartAxisRange* m_pRange;
625 CXTPChartAxisConstantLines* m_pConstantLines;
626 CXTPChartAxisCustomLabels* m_pCustomLabels;
627 CXTPChartAxisStrips* m_pStrips;
629 XTPChartScaleType m_nScaleType;
631 XTPChartAxisDateTimeScaleUnit m_nDateTimeScaleUnit;
632
633 CXTPChartAxisView* m_pAxisView;
634
635 friend class CXTPChartDiagram2DAxisView;
636 friend class CXTPChartRadarAxisView;
637 friend class CXTPChartRadarAxisXView;
638 friend class CXTPChartRadarAxisYView;
639 friend class CXTPChartDiagram2D;
640};
641
650class _XTP_EXT_CLASS CXTPChartAxisX : public CXTPChartAxis
651{
652public:
659 CXTPChartAxisX(CXTPChartDiagram2D* pDiagram);
660
661public:
669 virtual BOOL IsVertical() const;
670
678 virtual BOOL IsValuesAxis() const;
679
690 virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const;
691
692protected:
702 virtual CXTPChartAxisView* CreateView(CXTPChartDeviceContext* pDC,
703 CXTPChartElementView* pParentView);
704};
705
714class _XTP_EXT_CLASS CXTPChartAxisY : public CXTPChartAxis
715{
716public:
723 CXTPChartAxisY(CXTPChartDiagram2D* pDiagram);
724
725public:
733 virtual BOOL IsVertical() const;
734
742 virtual BOOL IsValuesAxis() const;
743
754 virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const;
755
756protected:
766 virtual CXTPChartAxisView* CreateView(CXTPChartDeviceContext* pDC,
767 CXTPChartElementView* pParentView);
768};
769
770AFX_INLINE CXTPChartDiagram* CXTPChartAxis::GetDiagram() const
771{
772 return m_pDiagram;
773}
774AFX_INLINE XTPChartScaleType CXTPChartAxis::GetScaleType() const
775{
776 return m_nScaleType;
777}
778AFX_INLINE CXTPChartAxisRange* CXTPChartAxis::GetRange() const
779{
780 return m_pRange;
781}
782AFX_INLINE CXTPChartAxisLabel* CXTPChartAxis::GetLabel() const
783{
784 return m_pLabel;
785}
786
787AFX_INLINE CXTPChartAxisGridLines* CXTPChartAxis::GetGridLines() const
788{
789 return m_pGridLines;
790}
791AFX_INLINE CXTPChartAxisConstantLines* CXTPChartAxis::GetConstantLines() const
792{
793 return m_pConstantLines;
794}
795AFX_INLINE CXTPChartAxisCustomLabels* CXTPChartAxis::GetCustomLabels() const
796{
797 return m_pCustomLabels;
798}
799AFX_INLINE CXTPChartAxisStrips* CXTPChartAxis::GetStrips() const
800{
801 return m_pStrips;
802}
803AFX_INLINE CXTPChartAxisTickMarks* CXTPChartAxis::GetTickMarks() const
804{
805 return m_pTickMarks;
806}
807AFX_INLINE BOOL CXTPChartAxis::IsInterlaced() const
808{
809 return m_bInterlaced;
810}
811AFX_INLINE void CXTPChartAxis::SetInterlaced(BOOL bInterlaced)
812{
813 m_bInterlaced = bInterlaced;
814 OnChartChanged();
815}
816AFX_INLINE CXTPChartScaleTypeMap* CXTPChartAxis::GetScaleTypeMap() const
817{
818 return m_pScaleTypeMap;
819}
820AFX_INLINE CXTPChartAxisTitle* CXTPChartAxis::GetTitle() const
821{
822 return m_pTitle;
823}
824AFX_INLINE XTPChartAxisAlignment CXTPChartAxis::GetAlignment() const
825{
826 return m_nAlignment;
827}
828AFX_INLINE void CXTPChartAxis::SetAlignment(XTPChartAxisAlignment nAlignment)
829{
830 m_nAlignment = nAlignment;
831 OnChartChanged();
832}
833AFX_INLINE BOOL CXTPChartAxis::IsVisible() const
834{
835 return m_bVisible;
836}
837AFX_INLINE void CXTPChartAxis::SetVisible(BOOL bVisible)
838{
839 m_bVisible = bVisible;
840 OnChartChanged();
841}
842AFX_INLINE int CXTPChartAxis::GetThickness() const
843{
844 return m_nThickness;
845}
846AFX_INLINE void CXTPChartAxis::SetThickness(int nThickness)
847{
848 m_nThickness = nThickness;
849 OnChartChanged();
850}
851AFX_INLINE int CXTPChartAxis::GetMinorCount() const
852{
853 return m_nMinorCount;
854}
855AFX_INLINE void CXTPChartAxis::SetMinorCount(int nMinorCount)
856{
857 m_nMinorCount = nMinorCount;
858 OnChartChanged();
859}
860
861AFX_INLINE void CXTPChartAxis::SetReversed(BOOL bRevered)
862{
863 m_bReversed = bRevered;
864 OnChartChanged();
865}
866AFX_INLINE BOOL CXTPChartAxis::IsReversed() const
867{
868 return m_bReversed;
869}
870AFX_INLINE BOOL CXTPChartAxis::GetGridSpacingAuto() const
871{
872 return m_bGridSpacingAuto;
873}
874AFX_INLINE void CXTPChartAxis::SetGridSpacingAuto(BOOL bGridSpacingAuto)
875{
876 m_bGridSpacingAuto = bGridSpacingAuto;
877 OnChartChanged();
878}
879AFX_INLINE double CXTPChartAxis::GetGridSpacing() const
880{
881 return m_dGridSpacing;
882}
883AFX_INLINE void CXTPChartAxis::SetGridSpacing(double dGridSpacing)
884{
885 m_dGridSpacing = dGridSpacing;
886 OnChartChanged();
887}
888AFX_INLINE BOOL CXTPChartAxis::IsSecondary() const
889{
890 return m_bSecondary;
891}
892AFX_INLINE void CXTPChartAxis::SetColor(const CXTPChartColor& color)
893{
894 m_clrColor = color;
895 OnChartChanged();
896}
897AFX_INLINE void CXTPChartAxis::SetInterlacedColor(const CXTPChartColor& color)
898{
899 m_clrInterlacedColor = color;
900 OnChartChanged();
901}
902AFX_INLINE void CXTPChartAxis::SetInterlacedColor2(const CXTPChartColor& color)
903{
904 m_clrInterlacedColor2 = color;
905 OnChartChanged();
906}
907AFX_INLINE BOOL CXTPChartAxis::IsAllowZoom() const
908{
909 return m_bAllowZoom;
910}
911AFX_INLINE void CXTPChartAxis::SetAllowZoom(BOOL bAllowZoom)
912{
913 m_bAllowZoom = bAllowZoom;
914}
915AFX_INLINE void CXTPChartAxis::SetLogarithmic(BOOL bLogarithmic)
916{
917 m_bLogarithmic = bLogarithmic;
918 OnChartChanged();
919}
920AFX_INLINE BOOL CXTPChartAxis::IsLogarithmic() const
921{
922 return m_bLogarithmic;
923}
924AFX_INLINE void CXTPChartAxis::SetLogarithmicBase(double dLogarithmicBase)
925{
926 m_dLogarithmicBase = dLogarithmicBase;
927 OnChartChanged();
928}
929AFX_INLINE double CXTPChartAxis::GetLogarithmicBase() const
930{
931 return m_dLogarithmicBase;
932}
933AFX_INLINE void CXTPChartAxis::SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit)
934{
935 m_nDateTimeScaleUnit = unit;
936 OnChartChanged();
937}
938AFX_INLINE XTPChartAxisDateTimeScaleUnit CXTPChartAxis::GetDateTimeScaleUnit() const
939{
940 return m_nDateTimeScaleUnit;
941}
942AFX_INLINE int CXTPChartAxis::GetIndex() const
943{
944 return m_nIndex;
945}
946AFX_INLINE void CXTPChartAxis::SetIndex(int nIndex)
947{
948 m_nIndex = nIndex;
949 OnChartChanged();
950}
951
952AFX_INLINE CXTPChartAxisView* CXTPChartAxis::GetAxisView() const
953{
954 return m_pAxisView;
955}
957# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
958#endif //#if !defined(__XTPCHARTAXIS_H__)
XTPChartAxisDateTimeScaleUnit
XTPChartAxisDateTimeScaleUnit
Enumerates the axis alignment.
Definition XTPChartAxis.h:68
xtpChartScaleHour
@ xtpChartScaleHour
An hour scale unit.
Definition XTPChartAxis.h:70
xtpChartScaleDay
@ xtpChartScaleDay
A day scale unit.
Definition XTPChartAxis.h:71
xtpChartScaleYear
@ xtpChartScaleYear
A year scale unit.
Definition XTPChartAxis.h:73
xtpChartScaleMonth
@ xtpChartScaleMonth
A month scale unit.
Definition XTPChartAxis.h:72
xtpChartScaleMinute
@ xtpChartScaleMinute
A minute scale unit.
Definition XTPChartAxis.h:69
XTPChartAxisAlignment
XTPChartAxisAlignment
Enumerates the axis alignment.
Definition XTPChartAxis.h:56
xtpChartAxisNear
@ xtpChartAxisNear
For Y axis, near means left side of the chart.
Definition XTPChartAxis.h:57
xtpChartAxisFar
@ xtpChartAxisFar
For Y axis, far means right side of the chart.
Definition XTPChartAxis.h:59
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxisAppearance
This class represents the appearance of a chart axis.This class is is subclassed from CXTPChartElemen...
Definition XTPChartAppearance.h:206
CXTPChartAxisConstantLines
This class encapsulates a collection of CXTPChartAxisConstantLine objects.
Definition XTPChartAxisConstantLines.h:340
CXTPChartAxisCustomLabels
This class encapsulates a collection of CXTPChartAxisCustomLabel objects.
Definition XTPChartAxisCustomLabels.h:151
CXTPChartAxisGridLines
CXTPChartAxisGridLines is a kind of CXTPChartElement, This class represents the grid lines parallel t...
Definition XTPChartAxisGridLines.h:42
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxis::IsVertical
virtual BOOL IsVertical() const =0
Override this method to tell that whether the axis is vertical.
CXTPChartAxis::SetInterlacedColor
void SetInterlacedColor(const CXTPChartColor &color)
Sets the first interlaced strips color of the axis.
Definition XTPChartAxis.h:897
CXTPChartAxis::GetActualInterlacedColor2
CXTPChartColor GetActualInterlacedColor2() const
Gets the second interlaced strips color of the axis.
CXTPChartAxis::m_pStrips
CXTPChartAxisStrips * m_pStrips
Pointer to axis strips object.
Definition XTPChartAxis.h:627
CXTPChartAxis::m_dLogarithmicBase
double m_dLogarithmicBase
Logarithic base.
Definition XTPChartAxis.h:617
CXTPChartAxis::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxis::CalcSideMarginsValue
virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const =0
Override this function to return the side margin value of the chart axis.
CXTPChartAxis::m_bInterlaced
BOOL m_bInterlaced
TRUE if the chart has interlaced strips parallel to the axis.
Definition XTPChartAxis.h:609
CXTPChartAxis::m_bReversed
BOOL m_bReversed
FALSE if the axis valus are in natural order, TRUE if it is in reverse order.
Definition XTPChartAxis.h:597
CXTPChartAxis::m_nScaleType
XTPChartScaleType m_nScaleType
Enumeated value denote the axis scale type.
Definition XTPChartAxis.h:629
CXTPChartAxis::GetIndex
int GetIndex() const
Call this function to get index of the axis.
Definition XTPChartAxis.h:942
CXTPChartAxis::GetDiagram
CXTPChartDiagram * GetDiagram() const
Call this function to get the pointer to chart diagram 2D object associated with the chart axis objec...
Definition XTPChartAxis.h:770
CXTPChartAxis::SetInterlacedColor2
void SetInterlacedColor2(const CXTPChartColor &color)
Sets the second interlaced strips color of the axis.
Definition XTPChartAxis.h:902
CXTPChartAxis::m_pDiagram
CXTPChartDiagram * m_pDiagram
The pointer to chart digram 2d object.
Definition XTPChartAxis.h:595
CXTPChartAxis::SetVisible
void SetVisible(BOOL bVisible)
Call this function to show/hide the axis.
Definition XTPChartAxis.h:837
CXTPChartAxis::GetInterlacedColor2
CXTPChartColor GetInterlacedColor2() const
Gets the second interlaced strips color of the axis.
CXTPChartAxis::m_clrInterlacedColor
CXTPChartColor m_clrInterlacedColor
The first interlaced color.
Definition XTPChartAxis.h:605
CXTPChartAxis::GetActualColor
CXTPChartColor GetActualColor() const
Gets the color of the axis.
CXTPChartAxis::m_pTitle
CXTPChartAxisTitle * m_pTitle
Pointer to axis title object.
Definition XTPChartAxis.h:621
CXTPChartAxis::m_clrColor
CXTPChartColor m_clrColor
The chart color.
Definition XTPChartAxis.h:604
CXTPChartAxis::m_pTickMarks
CXTPChartAxisTickMarks * m_pTickMarks
Pointer to axis tick marks object.
Definition XTPChartAxis.h:622
CXTPChartAxis::GetColor
CXTPChartColor GetColor() const
Gets the color of the axis.
CXTPChartAxis::SetGridSpacing
void SetGridSpacing(double dGridSpacing)
Use this function to set the space between grid lines.
Definition XTPChartAxis.h:883
CXTPChartAxis::m_nAlignment
XTPChartAxisAlignment m_nAlignment
The chart axis alignment, near or far.
Definition XTPChartAxis.h:603
CXTPChartAxis::SetInterlaced
void SetInterlaced(BOOL bInterlaced)
Call this function to enable/disable the interlaced strips.
Definition XTPChartAxis.h:811
CXTPChartAxis::GetConstantLines
CXTPChartAxisConstantLines * GetConstantLines() const
Use this function to get the associated object which deals with constant lines parallel to the axis.
Definition XTPChartAxis.h:791
CXTPChartAxis::m_pLabel
CXTPChartAxisLabel * m_pLabel
Pointer to axis lable object.
Definition XTPChartAxis.h:620
CXTPChartAxis::SetColor
void SetColor(const CXTPChartColor &color)
Sets the color of the axis.
Definition XTPChartAxis.h:892
CXTPChartAxis::GetRange
CXTPChartAxisRange * GetRange() const
Use this function to get object which represents the range of the axis.
Definition XTPChartAxis.h:778
CXTPChartAxis::SetDateTimeScaleUnit
void SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit)
Call this method to set single unit for date time scale.
Definition XTPChartAxis.h:933
CXTPChartAxis::m_dGridSpacing
double m_dGridSpacing
The spacing of the grid lines.
Definition XTPChartAxis.h:611
CXTPChartAxis::m_nThickness
int m_nThickness
The thickness of axis line.
Definition XTPChartAxis.h:599
CXTPChartAxis::IsVisible
BOOL IsVisible() const
Use this function to get whether the axis is visible.
Definition XTPChartAxis.h:833
CXTPChartAxis::GetThickness
int GetThickness() const
Call this function to get the thickness of the axis line.
Definition XTPChartAxis.h:842
CXTPChartAxis::GetStrips
CXTPChartAxisStrips * GetStrips() const
Call this function to get the associated object which deals with strips parallel to the axis.
Definition XTPChartAxis.h:799
CXTPChartAxis::GetScaleTypeMap
CXTPChartScaleTypeMap * GetScaleTypeMap() const
Call this function to get the scale type map object associated with the axis.
Definition XTPChartAxis.h:816
CXTPChartAxis::CreateView
virtual CXTPChartAxisView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView)of the axis.
CXTPChartAxis::m_bLogarithmic
BOOL m_bLogarithmic
Logarithmic
Definition XTPChartAxis.h:616
CXTPChartAxis::GetTitle
CXTPChartAxisTitle * GetTitle() const
Use this function to get the associated object which deals the axis title.
Definition XTPChartAxis.h:820
CXTPChartAxis::GetActualInterlacedColor
CXTPChartColor GetActualInterlacedColor() const
Gets the first interlaced strips color of the axis.
CXTPChartAxis::m_pScaleTypeMap
CXTPChartScaleTypeMap * m_pScaleTypeMap
Pointer to axis scale type object.
Definition XTPChartAxis.h:623
CXTPChartAxis::UpdateRange
void UpdateRange(CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView)
This function updates the axis, with respect to the series values.
CXTPChartAxis::SetIndex
void SetIndex(int nIndex)
Call this function to set the axis index.
Definition XTPChartAxis.h:946
CXTPChartAxis::GetScaleType
XTPChartScaleType GetScaleType() const
Use this function to get the scale type used for the axis.
Definition XTPChartAxis.h:774
CXTPChartAxis::IsValuesAxis
virtual BOOL IsValuesAxis() const =0
Override this method to tell that whether the axis is value type.
CXTPChartAxis::GetAlignment
XTPChartAxisAlignment GetAlignment() const
Call this function to get the alignment of the axis.
Definition XTPChartAxis.h:824
CXTPChartAxis::GetMinorCount
int GetMinorCount() const
This function gives the minor count of the axis grid lines.
Definition XTPChartAxis.h:851
CXTPChartAxis::m_bGridSpacingAuto
BOOL m_bGridSpacingAuto
TURE if automatic spaceing of grid lines selected.FALSE for specific values.
Definition XTPChartAxis.h:612
CXTPChartAxis::m_pConstantLines
CXTPChartAxisConstantLines * m_pConstantLines
Pointer to axis constant lines object.
Definition XTPChartAxis.h:625
CXTPChartAxis::m_clrInterlacedColor2
CXTPChartColor m_clrInterlacedColor2
The second interlaced color.
Definition XTPChartAxis.h:606
CXTPChartAxis::m_bVisible
BOOL m_bVisible
TRUE if the axis is visible, FALSE if invisible.
Definition XTPChartAxis.h:596
CXTPChartAxis::SetThickness
void SetThickness(int nThicknes)
Call this function to set the thickness of the axis line.
Definition XTPChartAxis.h:846
CXTPChartAxis::m_pGridLines
CXTPChartAxisGridLines * m_pGridLines
Pointer to axis gridlines object.
Definition XTPChartAxis.h:619
CXTPChartAxis::CXTPChartAxis
CXTPChartAxis(CXTPChartDiagram *pDiagram)
Constructs a CXTPChartAxis object.
CXTPChartAxis::GetAppearance
CXTPChartAxisAppearance * GetAppearance() const
This function returns the chart axis appeance object.
CXTPChartAxis::GetLabel
CXTPChartAxisLabel * GetLabel() const
Call this function to get object which represents the label of the axis.
Definition XTPChartAxis.h:782
CXTPChartAxis::SetLogarithmicBase
void SetLogarithmicBase(double dLogarithmicBase)
Set logarithmic base when logarithmic scale is used.
Definition XTPChartAxis.h:924
CXTPChartAxis::GetGridLines
CXTPChartAxisGridLines * GetGridLines() const
Use this function to get object which represents the axis gridlines.
Definition XTPChartAxis.h:787
CXTPChartAxis::IsReversed
BOOL IsReversed() const
This function gives whether the axis points are reverse ordered or not.
Definition XTPChartAxis.h:866
CXTPChartAxis::SetLogarithmic
void SetLogarithmic(BOOL bLogarithmic)
Set whether logarithmic scale should be used.
Definition XTPChartAxis.h:915
CXTPChartAxis::~CXTPChartAxis
virtual ~CXTPChartAxis()
Destroys a CXTPChartAxis object, handles cleanup.
CXTPChartAxis::SetAlignment
void SetAlignment(XTPChartAxisAlignment nAlignment)
Use this function to set the alignment of the axis.
Definition XTPChartAxis.h:828
CXTPChartAxis::SetGridSpacingAuto
void SetGridSpacingAuto(BOOL bGridSpacingAuto)
Sets value specifies whether space between grid lines in calculated automatically.
Definition XTPChartAxis.h:874
CXTPChartAxis::m_nMinorCount
int m_nMinorCount
The number of minors present.
Definition XTPChartAxis.h:600
CXTPChartAxis::GetCustomLabels
CXTPChartAxisCustomLabels * GetCustomLabels() const
Use this function to get the associated object which deals with custom labels of aixs.
Definition XTPChartAxis.h:795
CXTPChartAxis::IsInterlaced
BOOL IsInterlaced() const
Call this function to get whether the interlaced strips are used.
Definition XTPChartAxis.h:807
CXTPChartAxis::m_pCustomLabels
CXTPChartAxisCustomLabels * m_pCustomLabels
Pointer to axis custom labels object.
Definition XTPChartAxis.h:626
CXTPChartAxis::m_pInterlacedFillStyle
CXTPChartFillStyle * m_pInterlacedFillStyle
The fill style of interlaced strips.
Definition XTPChartAxis.h:607
CXTPChartAxis::SetMinorCount
void SetMinorCount(int nMinorCount)
Call this function to set the minor count of the axis grid lines.
Definition XTPChartAxis.h:855
CXTPChartAxis::GetInterlacedColor
CXTPChartColor GetInterlacedColor() const
Gets the first interlaced strips color of the axis.
CXTPChartAxis::GetTickMarks
CXTPChartAxisTickMarks * GetTickMarks() const
Call this function to get the associated object which abstracts the axis tick marks.
Definition XTPChartAxis.h:803
CXTPChartAxis::GetGridSpacing
double GetGridSpacing() const
Use this function to get the space between grid lines.
Definition XTPChartAxis.h:879
CXTPChartAxis::GetInterlacedFillStyle
CXTPChartFillStyle * GetInterlacedFillStyle() const
Call this function to get the second interlaced strips background fill style.
CXTPChartAxis::m_pRange
CXTPChartAxisRange * m_pRange
Pointer to axis range object.
Definition XTPChartAxis.h:624
CXTPChartAxis::SetReversed
void SetReversed(BOOL bRevered)
Use this function to reverse order the axis values.
Definition XTPChartAxis.h:861
CXTPChartAxisLabel
CXTPChartAxisLabel is a kind of CXTPChartTextElement.
Definition XTPChartAxisLabel.h:45
CXTPChartAxisRange
This class represents the value range of the axis.
Definition XTPChartAxisRange.h:44
CXTPChartAxisStrips
This class encapsulates a collection of chart axis strip objects.
Definition XTPChartAxisStrips.h:300
CXTPChartAxisTickMarks
This class represents the tick marks in an axis.
Definition XTPChartAxisTickMarks.h:40
CXTPChartAxisTitle
This class represents the axis title.
Definition XTPChartAxisTitle.h:40
CXTPChartAxisX
CXTPChartAxisX is a derived class from the CXTPChartAxis class and represents the X axis of a chart.
Definition XTPChartAxis.h:651
CXTPChartAxisX::CalcSideMarginsValue
virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's X axis.
CXTPChartAxisX::CreateView
virtual CXTPChartAxisView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
CXTPChartAxisX::IsValuesAxis
virtual BOOL IsValuesAxis() const
This method overrides the base class member and determines if the X axis is value type.
CXTPChartAxisX::CXTPChartAxisX
CXTPChartAxisX(CXTPChartDiagram2D *pDiagram)
Constructs a CXTPChartAxisX object.
CXTPChartAxisX::IsVertical
virtual BOOL IsVertical() const
This method overrides the base class member and determines if the X axis is vertical.
CXTPChartAxisY
CXTPChartAxisY is a derived class from the CXTPChartAxis class and represents the Y axis of a chart.
Definition XTPChartAxis.h:715
CXTPChartAxisY::CalcSideMarginsValue
virtual double CalcSideMarginsValue(double nMinValue, double nMaxValue) const
This method overrides the base class member and returns the side margin value of the chart's Y axis.
CXTPChartAxisY::CreateView
virtual CXTPChartAxisView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView)
This function creates the view (CXTPChartAxisView) of the axis.
CXTPChartAxisY::CXTPChartAxisY
CXTPChartAxisY(CXTPChartDiagram2D *pDiagram)
Constructs a CXTPChartAxisY object.
CXTPChartAxisY::IsValuesAxis
virtual BOOL IsValuesAxis() const
This method overrides the base class member and determines if the Y axis is value type.
CXTPChartAxisY::IsVertical
virtual BOOL IsVertical() const
This method overrides the base class member and determines if the Y axis is vertical.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartAxisView.h:128
CXTPChartDiagram2D
This class represents a chart 2D diagram, which is a kind of CXTPChartDiagram.
Definition XTPChartDiagram2D.h:51
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartRadarAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisView.h:41
CXTPChartRadarAxisXView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisXView.h:57
CXTPChartRadarAxisYView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartRadarAxisYView.h:56
CXTPChartScaleTypeMap
This class abstracts a scale type map.
Definition XTPChartScaleTypeMap.h:45
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPExcelTabCtrlThemeVisualStudio2022 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeVisualStudio2022, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeOffice2013() | CXTPExcelTabCtrlThemeOffice2013 |
CXTPExcelTabCtrlThemeVisualStudio2022() | CXTPExcelTabCtrlThemeVisualStudio2022 |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlThemeOffice2013 | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlThemeOffice2013 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


CXTPSkinObjectTreeView Member List

This is the complete list of members for CXTPSkinObjectTreeView, including all inherited members.

CheckScrollBarsDraw() | CXTPSkinObjectComCtl32Control | protectedvirtual
CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectComCtl32Control() | CXTPSkinObjectComCtl32Control | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectTreeView() | CXTPSkinObjectTreeView |
CXTPSkinObjectUser32Control() | CXTPSkinObjectUser32Control | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectTreeView() | CXTPSkinObjectTreeView | virtual


CXTPMarkupGdiPlusTransformObject< BaseTransform > Member List

This is the complete list of members for CXTPMarkupGdiPlusTransformObject< BaseTransform >, including all inherited members.

CXTPMarkupGdiPlusTransformObject() | CXTPMarkupGdiPlusTransformObject< BaseTransform > | protected
CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | protected
TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)=0 | CXTPMarkupGdiPlusTransformObjectImpl | protectedpure virtual
~CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | inlineprotectedvirtual


CXTPMaskEditT< TBase > Member List

This is the complete list of members for CXTPMaskEditT< TBase >, including all inherited members.

CanOverType() const | CXTPMaskEditT< TBase > | inline
CanUseMask() const | CXTPMaskEditT< TBase > | inline
CheckChar(TCHAR &nChar, int nPos) | CXTPMaskEditT< TBase > | inlinevirtual
ConvertUnicodeAlpha(TCHAR nChar, BOOL bUpperCase) const | CXTPMaskEditT< TBase > | inline
CopyToClipboard(const CString &strText) | CXTPMaskEditT< TBase > | inline
CXTPMaskEditT() | CXTPMaskEditT< TBase > | inline
DeleteCharAt(int iPos) | CXTPMaskEditT< TBase > | inline
GetMaskedText(int nStartPos=0, int nEndPos=-1) const | CXTPMaskEditT< TBase > | inline
GetPromptChar() const | CXTPMaskEditT< TBase > | inline
GetPromptString(int nLength) const | CXTPMaskEditT< TBase > | inline
InsertCharAt(int iPos, TCHAR nChar) | CXTPMaskEditT< TBase > | inline
IsModified() const | CXTPMaskEditT< TBase > | inline
m_bModified | CXTPMaskEditT< TBase > | protected
m_bOverType | CXTPMaskEditT< TBase > | protected
m_bRedo | CXTPMaskEditT< TBase > | protected
m_bUpdateUndo | CXTPMaskEditT< TBase > | protected
m_bUseMask | CXTPMaskEditT< TBase > | protected
m_chPrompt | CXTPMaskEditT< TBase > | protected
m_nEndChar | CXTPMaskEditT< TBase > | protected
m_nStartChar | CXTPMaskEditT< TBase > | protected
m_strDefault | CXTPMaskEditT< TBase > | protected
m_strLiteral | CXTPMaskEditT< TBase > | protected
m_strMask | CXTPMaskEditT< TBase > | protected
m_strRedoBuffer | CXTPMaskEditT< TBase > | protected
m_strUndoBuffer | CXTPMaskEditT< TBase > | protected
m_strWindowText | CXTPMaskEditT< TBase > | protected
MaskClear() | CXTPMaskEditT< TBase > | inline
MaskCopy() | CXTPMaskEditT< TBase > | inline
MaskCut() | CXTPMaskEditT< TBase > | inline
MaskDeleteSel() | CXTPMaskEditT< TBase > | inline
MaskPaste() | CXTPMaskEditT< TBase > | inline
MaskReplaceSel(LPCTSTR lpszNewText) | CXTPMaskEditT< TBase > | inline
MaskSelectAll() | CXTPMaskEditT< TBase > | inline
MaskUndo() | CXTPMaskEditT< TBase > | inline
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPMaskEditT< TBase > | inlineprotectedvirtual
PosInRange(int iPos) const | CXTPMaskEditT< TBase > | inline
PreTranslateMessage(MSG *pMsg) | CXTPMaskEditT< TBase > | inlinevirtual
ProcessMask(TCHAR &nChar, int nEndPos) | CXTPMaskEditT< TBase > | inlinevirtual
SetEditMask(LPCTSTR lpszMask, LPCTSTR lpszLiteral, LPCTSTR lpszDefault=NULL) | CXTPMaskEditT< TBase > | inlinevirtual
SetMaskedText(LPCTSTR lpszMaskedText, int iPos=0, BOOL bUpdateWindow=TRUE) | CXTPMaskEditT< TBase > | inline
SetOverType(BOOL bOverType) | CXTPMaskEditT< TBase > | inline
SetPromptChar(TCHAR ch, BOOL bAutoReplace=TRUE) | CXTPMaskEditT< TBase > | inline
SetUseMask(BOOL bUseMask) | CXTPMaskEditT< TBase > | inline


Toolkit Pro: XTPCalendarViewPart.h Source File

  • Source
  • Calendar
XTPCalendarViewPart.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARVIEWPART_H__)
23# define _XTPCALENDARVIEWPART_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# pragma warning(disable : 4097)
32
33class CXTPCalendarView;
34class CXTPPropExchange;
35class CXTPCalendarTimeLineView;
36class CXTPCalendarTimeLineViewEvent;
37class CXTPCalendarControl;
38
44class _XTP_EXT_CLASS CXTPCalendarViewPartFontValue
45{
46public:
51 CXTPCalendarViewPartFontValue();
52
60 BOOL IsDefaultValue();
61
75 void SetStandardValue(LOGFONT* pLogFont);
76
86 void SetDefaultValue();
87
100 operator CFont&();
101
114 operator CFont*();
115
128 const CXTPCalendarViewPartFontValue& operator=(LOGFONT* pLogFont);
129
136 CFont* operator->();
137
138protected:
139 CXTPFont m_xtpFontStandardValue;
140 CXTPFont m_xtpFontCustomValue;
142 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntStandardValue, m_xtpFontStandardValue,
143 GetStandardFontHandle);
144 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntCustomValue, m_xtpFontCustomValue,
145 GetCustomFontHandle);
146};
147
153template<class _TValue, class _TValueRef = _TValue&>
154class CXTPCalendarThemeCustomizableXValueT
155{
156public:
161 CXTPCalendarThemeCustomizableXValueT()
162 {
163 m_bIsStandardSet = FALSE;
164 m_bIsCustomSet = FALSE;
165
166 m_bAutoDestroy_Standard = FALSE;
167 m_bAutoDestroy_Custom = FALSE;
168
169 m_ValueStandard = _TValue();
170 m_ValueCustom = _TValue();
171 }
172
177 virtual ~CXTPCalendarThemeCustomizableXValueT()
178 {
179 if (m_bAutoDestroy_Standard)
180 {
181 DoDestroy(m_ValueStandard);
182 }
183 if (m_bAutoDestroy_Custom)
184 {
185 DoDestroy(m_ValueCustom);
186 }
187 }
188
196 virtual void DoDestroy(_TValue& refValue)
197 {
198 UNREFERENCED_PARAMETER(refValue);
199 };
200
207 virtual BOOL IsDefaultValue() const
208 {
209 return !m_bIsCustomSet && !m_bIsStandardSet;
210 }
211
220 virtual BOOL IsStandardValue() const
221 {
222 return !m_bIsCustomSet && m_bIsStandardSet;
223 }
224
232 virtual BOOL IsCustomValue() const
233 {
234 return m_bIsCustomSet;
235 }
236
253 virtual void SetStandardValue(_TValueRef refValue, BOOL bAutoDestroy)
254 {
255 if (m_bIsStandardSet && m_bAutoDestroy_Standard)
256 {
257 DoDestroy(m_ValueStandard);
258 }
259 m_ValueStandard = refValue;
260
261 m_bAutoDestroy_Standard = bAutoDestroy;
262 m_bIsStandardSet = TRUE;
263 }
264
278 virtual void SetStandardValue(_TValueRef refValue)
279 {
280 SetStandardValue(refValue, m_bAutoDestroy_Standard);
281 }
282
299 virtual void SetCustomValue(_TValueRef refValue, BOOL bAutoDestroy)
300 {
301 if (m_bIsCustomSet && m_bAutoDestroy_Custom)
302 {
303 DoDestroy(m_ValueCustom);
304 }
305 m_ValueCustom = refValue;
306
307 m_bAutoDestroy_Custom = bAutoDestroy;
308 m_bIsCustomSet = TRUE;
309 }
310
324 virtual void SetCustomValue(_TValueRef refValue)
325 {
326 SetCustomValue(refValue, m_bAutoDestroy_Custom);
327 }
328
341 virtual void SetDefaultValue()
342 {
343 if (m_bIsStandardSet)
344 {
345 if (m_bIsCustomSet && m_bAutoDestroy_Custom)
346 {
347 DoDestroy(m_ValueCustom);
348 }
349 m_bIsCustomSet = FALSE;
350 m_bAutoDestroy_Custom = FALSE;
351 }
352 }
353
368 virtual _TValueRef GetValue() const
369 {
370 return m_bIsCustomSet ? m_ValueCustom : m_ValueStandard;
371 }
372
387 virtual const _TValue& GetValueX() const
388 {
389 return m_bIsCustomSet ? m_ValueCustom : m_ValueStandard;
390 }
391
402 virtual _TValueRef GetStandardValue() const
403 {
404 return m_ValueStandard;
405 }
406
422 operator _TValueRef() const
423 {
424 return GetValue();
425 }
426
442 void CopySettings(const CXTPCalendarThemeCustomizableXValueT<_TValue, _TValueRef>& refSrc)
443 {
444 SetStandardValue(refSrc.GetValue());
445 }
446
455 const CXTPCalendarThemeCustomizableXValueT<_TValue, _TValueRef>& operator=(_TValueRef refValue)
456 {
457 SetCustomValue(refValue);
458 return *this;
459 }
460
469 virtual void Serialize(CArchive& ar)
471 {
472 if (ar.IsStoring())
473 {
474 ar << m_bIsStandardSet;
475 ar << m_bIsCustomSet;
476
477 ar << m_ValueStandard;
478 ar << m_ValueCustom;
479 }
480 else
481 {
482 _ASSERTE(ar.IsLoading());
483
484 ar >> m_bIsStandardSet;
485 ar >> m_bIsCustomSet;
486
487 ar >> m_ValueStandard;
488 ar >> m_ValueCustom;
489 }
490 }
491
502 virtual void DoPropExchange(CXTPPropExchange* pPX, LPCTSTR pcszPropName) = 0;
503
504protected:
505 _TValue m_ValueStandard;
506 BOOL m_bAutoDestroy_Standard;
507 BOOL m_bIsStandardSet;
509 _TValue m_ValueCustom;
510 BOOL m_bAutoDestroy_Custom;
511 BOOL m_bIsCustomSet;
512};
513
519template<class _TValue>
520class CXTPCalendarViewPartCustomizableValueT
521{
522public:
523 typedef CXTPCalendarViewPartCustomizableValueT<_TValue> TBase;
524
525public:
530 CXTPCalendarViewPartCustomizableValueT()
531 {
532 m_pValueStandard = NULL;
533 m_bAutoDelete_Standard = FALSE;
534
535 m_pValueCustom = NULL;
536 m_bAutoDelete_Custom = FALSE;
537 }
538
543 virtual ~CXTPCalendarViewPartCustomizableValueT()
544 {
545 CXTPCalendarViewPartCustomizableValueT::DeleteStandardValue();
546 CXTPCalendarViewPartCustomizableValueT::DeleteCustomValue();
547 }
548
555 virtual BOOL IsDefaultValue() const
556 {
557 return (m_pValueCustom == NULL) && (m_pValueStandard == NULL);
558 }
559
568 virtual BOOL IsStandardValue() const
569 {
570 return (m_pValueCustom == NULL) && (m_pValueStandard != NULL);
571 }
572
580 virtual BOOL IsCustomValue() const
581 {
582 return m_pValueCustom != NULL;
583 }
584
604 virtual void SetStandardValue(_TValue* pValue, BOOL bAutoDelete)
605 {
606 DeleteStandardValue();
607 m_pValueStandard = pValue;
608 m_bAutoDelete_Standard = bAutoDelete;
609 }
610
674 virtual void SetCustomValue(_TValue* pValue, BOOL bAutoDelete)
675 {
676 DeleteCustomValue();
677 m_pValueCustom = pValue;
678 m_bAutoDelete_Custom = bAutoDelete;
679 }
680
696 virtual void SetDefaultValue()
697 {
698 if (m_pValueStandard)
699 {
700 DeleteCustomValue();
701 m_pValueCustom = NULL;
702 }
703 }
704
723 virtual _TValue* GetValue() const
724 {
725 return m_pValueCustom ? m_pValueCustom : m_pValueStandard;
726 }
727
742 virtual _TValue* GetStandardValue() const
743 {
744 return m_pValueStandard;
745 }
746
765 operator _TValue*() const
766 {
767 return GetValue();
768 }
769
776 _TValue* operator->()
777 {
778 return GetValue();
779 };
780
796 void CopySettings(const CXTPCalendarViewPartCustomizableValueT<_TValue>& refSrc)
797 {
798 SetStandardValue(refSrc.GetValue(), FALSE);
799 }
800
801protected:
811 virtual void DeleteStandardValue()
812 {
813 if (m_bAutoDelete_Standard)
814 {
815 SAFE_DELETE(m_pValueStandard);
816 }
817 }
818
828 virtual void DeleteCustomValue()
829 {
830 if (m_bAutoDelete_Custom)
831 {
832 SAFE_DELETE(m_pValueCustom);
833 }
834 }
835
836 _TValue* m_pValueStandard;
837 BOOL m_bAutoDelete_Standard;
839 _TValue* m_pValueCustom;
840 BOOL m_bAutoDelete_Custom;
841};
842
847class _XTP_EXT_CLASS CXTPCalendarViewPartBrushValue
848 : public CXTPCalendarViewPartCustomizableValueT<CBrush>
849{
850public:
855 ~CXTPCalendarViewPartBrushValue();
856
857private:
858 virtual void DeleteStandardValue();
859 virtual void DeleteCustomValue();
860};
861
866class _XTP_EXT_CLASS CXTPCalendarThemeFontValue
867 : public CXTPCalendarViewPartCustomizableValueT<CFont>
868{
869public:
870 using CXTPCalendarViewPartCustomizableValueT<CFont>::SetCustomValue;
871 using CXTPCalendarViewPartCustomizableValueT<CFont>::SetStandardValue;
872
877 CXTPCalendarThemeFontValue();
878
883 ~CXTPCalendarThemeFontValue();
884
898 virtual void SetStandardValue(LOGFONT* pLogFont);
899
912 virtual void SetCustomValue(LOGFONT* pLogFont);
913
920 virtual void SetStandardValue(CFont* pFont);
921
928 virtual void SetCustomValue(CFont* pFont);
929
942 const CXTPCalendarThemeFontValue& operator=(LOGFONT& rLogFont);
943
959 void CopySettings(const CXTPCalendarThemeFontValue& refSrc);
960
969 virtual void Serialize(CArchive& ar);
970
971private:
972 virtual void DeleteStandardValue();
973 virtual void DeleteCustomValue();
974};
975
981class _XTP_EXT_CLASS CXTPCalendarThemeStringValue
982 : public CXTPCalendarThemeCustomizableXValueT<CString, LPCTSTR>
983{
984public:
989 CXTPCalendarThemeStringValue();
990
1009 operator const CString&() const
1010 {
1011 return GetValueX();
1012 }
1013
1022 const CXTPCalendarThemeStringValue& operator=(LPCTSTR pcszValue);
1023
1024public:
1035 virtual void DoPropExchange(CXTPPropExchange* pPX, LPCTSTR pcszPropName);
1036
1037protected:
1044 virtual void DoDestroy(CString& refValue)
1045 {
1046 refValue.Empty();
1047 }
1048
1060 void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, CString& rXValue, BOOL bStandard);
1061};
1062
1068class _XTP_EXT_CLASS CXTPCalendarThemeIntValue
1069 : public CXTPCalendarThemeCustomizableXValueT<int, int>
1070{
1071public:
1076 CXTPCalendarThemeIntValue();
1077
1078public:
1089 virtual void DoPropExchange(CXTPPropExchange* pPX, LPCTSTR pcszPropName);
1090
1099 const CXTPCalendarThemeIntValue& operator=(int nValue);
1100
1101protected:
1113 void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, int& rXValue, BOOL bStandard);
1114};
1115
1121class _XTP_EXT_CLASS CXTPCalendarThemeBOOLValue
1122 : public CXTPCalendarThemeCustomizableXValueT<BOOL, BOOL>
1123{
1124public:
1129 CXTPCalendarThemeBOOLValue();
1130
1131public:
1142 virtual void DoPropExchange(CXTPPropExchange* pPX, LPCTSTR pcszPropName);
1143
1152 const CXTPCalendarThemeBOOLValue& operator=(BOOL bValue);
1153
1154protected:
1166 void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, BOOL& rXValue, BOOL bStandard);
1167};
1168
1174class _XTP_EXT_CLASS CXTPCalendarThemeRectValue
1175 : public CXTPCalendarThemeCustomizableXValueT<CRect, CRect>
1176{
1177public:
1182 CXTPCalendarThemeRectValue();
1183
1184public:
1195 virtual void DoPropExchange(CXTPPropExchange* pPX, LPCTSTR pcszPropName);
1196
1205 const CXTPCalendarThemeRectValue& operator=(const CRect& rcValue);
1206
1207protected:
1219 void DoPX_Value(CXTPPropExchange* pPX, LPCTSTR pcszPropName, CRect& rXValue, BOOL bStandard);
1220};
1221
1227class _XTP_EXT_CLASS CXTPCalendarViewPart : public CXTPCmdTarget
1228{
1229 friend class CXTPCalendarPaintManager;
1230
1231public:
1238 CXTPCalendarViewPart(CXTPCalendarViewPart* pParentPart = NULL);
1239
1244 virtual ~CXTPCalendarViewPart();
1245
1246public:
1252 virtual void RefreshMetrics();
1253
1254public:
1262 virtual COLORREF GetBackgroundColor();
1263
1270 virtual COLORREF GetTextColor();
1271
1281 virtual CFont& GetTextFont();
1282
1296 void DrawText(CDC* pDC, const CString& str, LPRECT lpRect, UINT nFormat,
1297 COLORREF clrText = COLORREF_NULL, CFont* pFont = NULL);
1298
1312 void DrawLine_CenterLR(CDC* pDC, const CString& str, LPRECT lpRect, UINT nFormat);
1313
1329 void DrawLineEx(CDC* pDC, const CString& str, LPRECT lpRect, UINT nFormatNormal,
1330 UINT nFormatSmall);
1331
1343 CSize GetTextExtent(CDC* pDC, const CString& str);
1344
1352 void SetBackgroundColor(COLORREF clr);
1353
1361 void SetTextColor(COLORREF clr);
1362
1371 void SetTextFont(LOGFONT* pLogFont);
1372
1373 CXTPCalendarControl* GetCalendarControl() const;
1374
1375 // Attributes
1376 CXTPPaintManagerColor m_clrTextColor;
1377 CXTPPaintManagerColor m_clrBackground;
1379 CXTPCalendarViewPartFontValue m_fntText;
1380 CXTPCalendarViewPart* m_pParentPart;
1381 CXTPCalendarPaintManager* m_pPaintManager;
1384protected:
1385 virtual void _Init(){};
1386};
1387
1393class _XTP_EXT_CLASS CXTPCalendarTimeLineViewTimeScalePart : public CXTPCalendarViewPart
1394{
1395public:
1402 CXTPCalendarTimeLineViewTimeScalePart(CXTPCalendarViewPart* pParentPart = NULL);
1403
1409 virtual void RefreshMetrics();
1410
1420 virtual int CalcHeigt(CDC* pDC);
1421
1431 virtual void Draw(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineView* pView);
1432
1439 virtual int GetHeaderHeight()
1440 {
1441 return m_nHeaderHeight;
1442 }
1443
1452 virtual CString GetHeaderDateFormat(int nLabelInterval);
1453
1464 virtual void DrawHeader(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineView* pView,
1465 int nLabelInterval);
1466
1467public:
1468 CXTPCalendarViewPartFontValue m_fntScaleHeaderText;
1470protected:
1471 int m_nHeaderHeight; // internal value of current header height
1472
1473 friend class CXTPCalendarPaintManager;
1474};
1475
1481class _XTP_EXT_CLASS CXTPCalendarTimeLineViewPart : public CXTPCalendarViewPart
1482{
1483public:
1490 CXTPCalendarTimeLineViewPart(CXTPCalendarViewPart* pParentPart = NULL)
1491 : CXTPCalendarViewPart(pParentPart)
1492 {
1493 UNREFERENCED_PARAMETER(pParentPart);
1494 };
1495
1505 virtual void Draw(CDC* pDC, const CRect& rcRect, CXTPCalendarTimeLineView* pView)
1506 {
1507 UNREFERENCED_PARAMETER(pDC);
1508 UNREFERENCED_PARAMETER(rcRect);
1509 UNREFERENCED_PARAMETER(pView);
1510 };
1511
1521 virtual CSize CalcEventSize(CDC* pDC, CXTPCalendarTimeLineViewEvent* pEventView)
1522 {
1523 UNREFERENCED_PARAMETER(pDC);
1524 UNREFERENCED_PARAMETER(pEventView);
1525 return CSize(0, 0);
1526 };
1527
1537 virtual void DrawEvent(CDC* pDC, const CRect& rcEvents,
1538 CXTPCalendarTimeLineViewEvent* pEventView)
1539 {
1540 UNREFERENCED_PARAMETER(pDC);
1541 UNREFERENCED_PARAMETER(rcEvents);
1542 UNREFERENCED_PARAMETER(pEventView);
1543 };
1544};
1545
1560_XTP_EXT_CLASS BOOL AFX_CDECL PX_Color(CXTPPropExchange* pPX, LPCTSTR pcszPropName,
1561 COLORREF& refColor);
1562
1577_XTP_EXT_CLASS BOOL AFX_CDECL PX_Color(CXTPPropExchange* pPX, LPCTSTR pcszPropName,
1578 CXTPPaintManagerColor& refColor);
1579
1594_XTP_EXT_CLASS BOOL AFX_CDECL PX_GrColor(CXTPPropExchange* pPX, LPCTSTR psczPropName,
1595 CXTPPaintManagerColorGradient& refGrColor);
1596
1611_XTP_EXT_CLASS BOOL AFX_CDECL PX_Font(CXTPPropExchange* pPX, LPCTSTR pcszPropName,
1612 LOGFONT& rLogFont);
1613
1628_XTP_EXT_CLASS BOOL AFX_CDECL PX_Font(CXTPPropExchange* pPX, LPCTSTR pcszPropName,
1629 CXTPCalendarThemeFontValue& refFont);
1630
1632
1634
1635# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1636#endif // !defined(_XTPCALENDARVIEWPART_H__)
PX_GrColor
_XTP_EXT_CLASS BOOL AFX_CDECL PX_GrColor(CXTPPropExchange *pPX, LPCTSTR psczPropName, CXTPPaintManagerColorGradient &refGrColor)
Call this function within your class's DoPropExchange member function to serialize or initialize a cu...
PX_Font
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Font(CXTPPropExchange *pPX, LPCTSTR pcszPropName, LOGFONT &rLogFont)
Call this function within your class's DoPropExchange member function to serialize or initialize a LO...
PX_Color
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Color(CXTPPropExchange *pPX, LPCTSTR pcszPropName, COLORREF &refColor)
Call this function within your class's DoPropExchange member function to serialize or initialize a cu...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
SAFE_DELETE
#define SAFE_DELETE(ptr)
Frees dynamically allocated memory.
Definition XTPMacros.h:63
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarPaintManager.h:150
CXTPCalendarThemeBOOLValue
Helper class provides functionality to manage customized BOOL value objects.
Definition XTPCalendarViewPart.h:1123
CXTPCalendarThemeBOOLValue::CXTPCalendarThemeBOOLValue
CXTPCalendarThemeBOOLValue()
Default object constructor.
CXTPCalendarThemeBOOLValue::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads data from or writes data to storage.
CXTPCalendarThemeBOOLValue::DoPX_Value
void DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, BOOL &rXValue, BOOL bStandard)
This method reads value data from or writes value data to storage.
CXTPCalendarThemeBOOLValue::operator=
const CXTPCalendarThemeBOOLValue & operator=(BOOL bValue)
This member operator is used to set the custom value.
CXTPCalendarThemeCustomizableXValueT
Helper class template provides functionality to manage customized value for the specified type.
Definition XTPCalendarViewPart.h:155
CXTPCalendarThemeCustomizableXValueT::CopySettings
void CopySettings(const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > &refSrc)
This member function is used to set the standard value using the current value from the specified obj...
Definition XTPCalendarViewPart.h:442
CXTPCalendarThemeCustomizableXValueT::m_ValueStandard
_TValue m_ValueStandard
Stores default value.
Definition XTPCalendarViewPart.h:505
CXTPCalendarThemeCustomizableXValueT::GetValueX
virtual const _TValue & GetValueX() const
This member function is used to get the current value.
Definition XTPCalendarViewPart.h:387
CXTPCalendarThemeCustomizableXValueT::IsDefaultValue
virtual BOOL IsDefaultValue() const
This member function is used to determine if the default value is set.
Definition XTPCalendarViewPart.h:207
CXTPCalendarThemeCustomizableXValueT::IsCustomValue
virtual BOOL IsCustomValue() const
This member function determines if the custom value is set and used.
Definition XTPCalendarViewPart.h:232
CXTPCalendarThemeCustomizableXValueT::m_bAutoDestroy_Custom
BOOL m_bAutoDestroy_Custom
Call DoDestroy for custom vale.
Definition XTPCalendarViewPart.h:510
CXTPCalendarThemeCustomizableXValueT::m_bIsCustomSet
BOOL m_bIsCustomSet
Is custom value set.
Definition XTPCalendarViewPart.h:511
CXTPCalendarThemeCustomizableXValueT::operator=
const CXTPCalendarThemeCustomizableXValueT< _TValue, _TValueRef > & operator=(_TValueRef refValue)
This member operator is used to set the custom value.
Definition XTPCalendarViewPart.h:455
CXTPCalendarThemeCustomizableXValueT::CXTPCalendarThemeCustomizableXValueT
CXTPCalendarThemeCustomizableXValueT()
Default object constructor.
Definition XTPCalendarViewPart.h:161
CXTPCalendarThemeCustomizableXValueT::SetCustomValue
virtual void SetCustomValue(_TValueRef refValue, BOOL bAutoDestroy)
This member function is used to set the custom value.
Definition XTPCalendarViewPart.h:299
CXTPCalendarThemeCustomizableXValueT::GetValue
virtual _TValueRef GetValue() const
This member function is used to get the current value.
Definition XTPCalendarViewPart.h:368
CXTPCalendarThemeCustomizableXValueT::~CXTPCalendarThemeCustomizableXValueT
virtual ~CXTPCalendarThemeCustomizableXValueT()
Default object destructor.
Definition XTPCalendarViewPart.h:177
CXTPCalendarThemeCustomizableXValueT::SetStandardValue
virtual void SetStandardValue(_TValueRef refValue)
This member function is used to set the standard value.
Definition XTPCalendarViewPart.h:278
CXTPCalendarThemeCustomizableXValueT::DoDestroy
virtual void DoDestroy(_TValue &refValue)
This member function is used to destroy objects of type _TValue if necessary (Close handles,...
Definition XTPCalendarViewPart.h:196
CXTPCalendarThemeCustomizableXValueT::m_ValueCustom
_TValue m_ValueCustom
Stores custom value.
Definition XTPCalendarViewPart.h:509
CXTPCalendarThemeCustomizableXValueT::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName)=0
This method reads data from or writes data to storage.
CXTPCalendarThemeCustomizableXValueT::IsStandardValue
virtual BOOL IsStandardValue() const
This member function determines if the standard value is set and used.
Definition XTPCalendarViewPart.h:220
CXTPCalendarThemeCustomizableXValueT::m_bIsStandardSet
BOOL m_bIsStandardSet
Is standard value set.
Definition XTPCalendarViewPart.h:507
CXTPCalendarThemeCustomizableXValueT::Serialize
virtual void Serialize(CArchive &ar)
This method reads data from or writes data to an archive.
Definition XTPCalendarViewPart.h:469
CXTPCalendarThemeCustomizableXValueT::m_bAutoDestroy_Standard
BOOL m_bAutoDestroy_Standard
Call DoDestroy for standard value.
Definition XTPCalendarViewPart.h:506
CXTPCalendarThemeCustomizableXValueT::SetCustomValue
virtual void SetCustomValue(_TValueRef refValue)
This member function is used to set the custom value.
Definition XTPCalendarViewPart.h:324
CXTPCalendarThemeCustomizableXValueT::GetStandardValue
virtual _TValueRef GetStandardValue() const
This member function is used to get the standard value.
Definition XTPCalendarViewPart.h:402
CXTPCalendarThemeCustomizableXValueT::SetDefaultValue
virtual void SetDefaultValue()
This member function is used to reset the custom value.
Definition XTPCalendarViewPart.h:341
CXTPCalendarThemeCustomizableXValueT::SetStandardValue
virtual void SetStandardValue(_TValueRef refValue, BOOL bAutoDestroy)
This member function is used to set the standard value.
Definition XTPCalendarViewPart.h:253
CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects.
Definition XTPCalendarViewPart.h:868
CXTPCalendarThemeFontValue::operator=
const CXTPCalendarThemeFontValue & operator=(LOGFONT &rLogFont)
This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.
CXTPCalendarThemeFontValue::CopySettings
void CopySettings(const CXTPCalendarThemeFontValue &refSrc)
This member function is use to set the standard value using the current value from the specified obje...
CXTPCalendarThemeFontValue::CXTPCalendarThemeFontValue
CXTPCalendarThemeFontValue()
Default constructor.
CXTPCalendarThemeFontValue::~CXTPCalendarThemeFontValue
~CXTPCalendarThemeFontValue()
Handles object deallocation.
CXTPCalendarThemeFontValue::SetStandardValue
virtual void SetStandardValue(CFont *pFont)
Used to assign the standard value to a view part element.
CXTPCalendarThemeFontValue::Serialize
virtual void Serialize(CArchive &ar)
This method reads data from or writes data to an archive.
CXTPCalendarThemeFontValue::SetCustomValue
virtual void SetCustomValue(CFont *pFont)
Used to assign the custom value to a view part element.
CXTPCalendarThemeFontValue::SetStandardValue
virtual void SetStandardValue(LOGFONT *pLogFont)
This member function is used to set the value for the standard font.
CXTPCalendarThemeFontValue::SetCustomValue
virtual void SetCustomValue(LOGFONT *pLogFont)
This member function is used to set the value for the custom font.
CXTPCalendarThemeIntValue
Helper class provides functionality to manage customized int value objects.
Definition XTPCalendarViewPart.h:1070
CXTPCalendarThemeIntValue::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads data from or writes data to storage.
CXTPCalendarThemeIntValue::CXTPCalendarThemeIntValue
CXTPCalendarThemeIntValue()
Default object constructor.
CXTPCalendarThemeIntValue::operator=
const CXTPCalendarThemeIntValue & operator=(int nValue)
This member operator is used to set the custom value.
CXTPCalendarThemeIntValue::DoPX_Value
void DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, int &rXValue, BOOL bStandard)
This method reads value data from or writes value data to storage.
CXTPCalendarThemeRectValue
Helper class provides functionality to manage customized CRect value objects.
Definition XTPCalendarViewPart.h:1176
CXTPCalendarThemeRectValue::operator=
const CXTPCalendarThemeRectValue & operator=(const CRect &rcValue)
This member operator is use to set custom value.
CXTPCalendarThemeRectValue::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads value data from or writes value data to storage.
CXTPCalendarThemeRectValue::CXTPCalendarThemeRectValue
CXTPCalendarThemeRectValue()
Default object constructor.
CXTPCalendarThemeRectValue::DoPX_Value
void DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, CRect &rXValue, BOOL bStandard)
This methods reads value data from or writes value data to storage.
CXTPCalendarThemeStringValue
Helper class provides functionality to manage customized string value objects.
Definition XTPCalendarViewPart.h:983
CXTPCalendarThemeStringValue::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszPropName)
This method reads data from or writes data to storage.
CXTPCalendarThemeStringValue::DoPX_Value
void DoPX_Value(CXTPPropExchange *pPX, LPCTSTR pcszPropName, CString &rXValue, BOOL bStandard)
This method reads value data from or writes value data to storage.
CXTPCalendarThemeStringValue::CXTPCalendarThemeStringValue
CXTPCalendarThemeStringValue()
Default constructor.
CXTPCalendarThemeStringValue::operator=
const CXTPCalendarThemeStringValue & operator=(LPCTSTR pcszValue)
This member operator is used to set a custom value.
CXTPCalendarThemeStringValue::DoDestroy
virtual void DoDestroy(CString &refValue)
This member operator is used to destroy/clear value data.
Definition XTPCalendarViewPart.h:1044
CXTPCalendarTimeLineViewEvent
This class represents an event timeline view portion of the CXTPCalendarViewEvent.
Definition XTPCalendarTimeLineViewGroup.h:51
CXTPCalendarTimeLineView
This class implements a specific view portion of the Calendar control - called Timeline view.
Definition XTPCalendarTimeLineView.h:76
CXTPCalendarTimeLineViewPart
Helper base class to implement parts for calendar paint manager objects.
Definition XTPCalendarViewPart.h:1482
CXTPCalendarTimeLineViewPart::CXTPCalendarTimeLineViewPart
CXTPCalendarTimeLineViewPart(CXTPCalendarViewPart *pParentPart=NULL)
Default object constructor.
Definition XTPCalendarViewPart.h:1490
CXTPCalendarTimeLineViewPart::CalcEventSize
virtual CSize CalcEventSize(CDC *pDC, CXTPCalendarTimeLineViewEvent *pEventView)
This member function is used to calculate the rectangle needed to draw an event.
Definition XTPCalendarViewPart.h:1521
CXTPCalendarTimeLineViewPart::DrawEvent
virtual void DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pEventView)
This member function is used to draw the event utilizing the specified device context.
Definition XTPCalendarViewPart.h:1537
CXTPCalendarTimeLineViewPart::Draw
virtual void Draw(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView)
This member function is used to draw the part content utilizing the specified device context.
Definition XTPCalendarViewPart.h:1505
CXTPCalendarTimeLineViewTimeScalePart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1394
CXTPCalendarTimeLineViewTimeScalePart::CalcHeigt
virtual int CalcHeigt(CDC *pDC)
This member function is used to calculate height utilizing the specified device context.
CXTPCalendarTimeLineViewTimeScalePart::CXTPCalendarTimeLineViewTimeScalePart
CXTPCalendarTimeLineViewTimeScalePart(CXTPCalendarViewPart *pParentPart=NULL)
Default object constructor.
CXTPCalendarTimeLineViewTimeScalePart::GetHeaderHeight
virtual int GetHeaderHeight()
Access function to get header height.
Definition XTPCalendarViewPart.h:1439
CXTPCalendarTimeLineViewTimeScalePart::GetHeaderDateFormat
virtual CString GetHeaderDateFormat(int nLabelInterval)
Access function to get header date format.
CXTPCalendarTimeLineViewTimeScalePart::m_fntScaleHeaderText
CXTPCalendarViewPartFontValue m_fntScaleHeaderText
Time scale header text font.
Definition XTPCalendarViewPart.h:1468
CXTPCalendarTimeLineViewTimeScalePart::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to set graphical related parameters equal to the system settings.
CXTPCalendarTimeLineViewTimeScalePart::Draw
virtual void Draw(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView)
This member function is used to draw the part content utilizing the specified device context.
CXTPCalendarTimeLineViewTimeScalePart::DrawHeader
virtual void DrawHeader(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineView *pView, int nLabelInterval)
This member function is used to draw the part content utilizing the specified device context.
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarViewPartBrushValue
Helper class provides functionality to manage brush value objects.
Definition XTPCalendarViewPart.h:849
CXTPCalendarViewPartBrushValue::~CXTPCalendarViewPartBrushValue
~CXTPCalendarViewPartBrushValue()
Handles object deallocation.
CXTPCalendarViewPartCustomizableValueT
Helper class template provides functionality to manage customized values for the specified class obje...
Definition XTPCalendarViewPart.h:521
CXTPCalendarViewPartCustomizableValueT::DeleteCustomValue
virtual void DeleteCustomValue()
Implementation can override this method for custom value specific cleaup logic.
Definition XTPCalendarViewPart.h:828
CXTPCalendarViewPartCustomizableValueT::IsDefaultValue
virtual BOOL IsDefaultValue() const
This member function is used to determine if the default value is set.
Definition XTPCalendarViewPart.h:555
CXTPCalendarViewPartCustomizableValueT::IsCustomValue
virtual BOOL IsCustomValue() const
This member function determines if the custom value is set and used.
Definition XTPCalendarViewPart.h:580
CXTPCalendarViewPartCustomizableValueT::m_pValueStandard
_TValue * m_pValueStandard
Stores default value.
Definition XTPCalendarViewPart.h:836
CXTPCalendarViewPartCustomizableValueT::CXTPCalendarViewPartCustomizableValueT
CXTPCalendarViewPartCustomizableValueT()
Default object constructor.
Definition XTPCalendarViewPart.h:530
CXTPCalendarViewPartCustomizableValueT::GetValue
virtual _TValue * GetValue() const
This member function is used to get the current value.
Definition XTPCalendarViewPart.h:723
CXTPCalendarViewPartCustomizableValueT::SetCustomValue
virtual void SetCustomValue(_TValue *pValue, BOOL bAutoDelete)
This member function is used to set the custom value.
Definition XTPCalendarViewPart.h:674
CXTPCalendarViewPartCustomizableValueT::SetStandardValue
virtual void SetStandardValue(_TValue *pValue, BOOL bAutoDelete)
This member function is used to set the standard value.
Definition XTPCalendarViewPart.h:604
CXTPCalendarViewPartCustomizableValueT::m_pValueCustom
_TValue * m_pValueCustom
Stores custom value.
Definition XTPCalendarViewPart.h:839
CXTPCalendarViewPartCustomizableValueT::operator->
_TValue * operator->()
Get a current value object.
Definition XTPCalendarViewPart.h:776
CXTPCalendarViewPartCustomizableValueT::IsStandardValue
virtual BOOL IsStandardValue() const
This member function determines if the standard value is set and used.
Definition XTPCalendarViewPart.h:568
CXTPCalendarViewPartCustomizableValueT::CopySettings
void CopySettings(const CXTPCalendarViewPartCustomizableValueT< _TValue > &refSrc)
This member function is used to set the standard value using the current value from the specified obj...
Definition XTPCalendarViewPart.h:796
CXTPCalendarViewPartCustomizableValueT::m_bAutoDelete_Custom
BOOL m_bAutoDelete_Custom
Call operator delete for the custom value.
Definition XTPCalendarViewPart.h:840
CXTPCalendarViewPartCustomizableValueT::~CXTPCalendarViewPartCustomizableValueT
virtual ~CXTPCalendarViewPartCustomizableValueT()
Default object destructor.
Definition XTPCalendarViewPart.h:543
CXTPCalendarViewPartCustomizableValueT::DeleteStandardValue
virtual void DeleteStandardValue()
Implementation can override this method for standard value specific cleaup logic.
Definition XTPCalendarViewPart.h:811
CXTPCalendarViewPartCustomizableValueT::m_bAutoDelete_Standard
BOOL m_bAutoDelete_Standard
Call operator delete for the standard value.
Definition XTPCalendarViewPart.h:837
CXTPCalendarViewPartCustomizableValueT::GetStandardValue
virtual _TValue * GetStandardValue() const
This member function is use to get the standard value.
Definition XTPCalendarViewPart.h:742
CXTPCalendarViewPartCustomizableValueT::SetDefaultValue
virtual void SetDefaultValue()
This member function is used to reset the custom value.
Definition XTPCalendarViewPart.h:696
CXTPCalendarViewPartFontValue
Helper class provides functionality to manage font settings for various graphical elements of control...
Definition XTPCalendarViewPart.h:45
CXTPCalendarViewPartFontValue::m_xtpFontCustomValue
CXTPFont m_xtpFontCustomValue
Stores custom font.
Definition XTPCalendarViewPart.h:140
CXTPCalendarViewPartFontValue::m_xtpFontStandardValue
CXTPFont m_xtpFontStandardValue
Stores default font.
Definition XTPCalendarViewPart.h:139
CXTPCalendarViewPartFontValue::operator=
const CXTPCalendarViewPartFontValue & operator=(LOGFONT *pLogFont)
This member function overloads the assignment operator for the CXTPCalendarViewPartFontValue class.
CXTPCalendarViewPartFontValue::SetDefaultValue
void SetDefaultValue()
This member function is used to delete the custom font and to set the default font value as the defau...
CXTPCalendarViewPartFontValue::CXTPCalendarViewPartFontValue
CXTPCalendarViewPartFontValue()
Default constructor.
CXTPCalendarViewPartFontValue::operator->
CFont * operator->()
Get a current value object.
CXTPCalendarViewPartFontValue::SetStandardValue
void SetStandardValue(LOGFONT *pLogFont)
This member function is used to set the value for the standard font.
CXTPCalendarViewPartFontValue::IsDefaultValue
BOOL IsDefaultValue()
This member function is used to determine if the default font value is set.
CXTPCalendarViewPart
Helper base class to implement parts for calendar paint manager.
Definition XTPCalendarViewPart.h:1228
CXTPCalendarViewPart::SetTextFont
void SetTextFont(LOGFONT *pLogFont)
This member function is used to set the new font used to display the text.
CXTPCalendarViewPart::GetTextFont
virtual CFont & GetTextFont()
This member function is used to obtain a pointer to a CFont object that contains the font that is use...
CXTPCalendarViewPart::SetTextColor
void SetTextColor(COLORREF clr)
This member function is used to set the new color used to display the text.
CXTPCalendarViewPart::DrawLine_CenterLR
void DrawLine_CenterLR(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat)
This member function is used to draw a single line text in the center of the rect.
CXTPCalendarViewPart::DrawText
void DrawText(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormat, COLORREF clrText=COLORREF_NULL, CFont *pFont=NULL)
This member function is used to display the text using the custom font and color.
CXTPCalendarViewPart::m_clrBackground
CXTPPaintManagerColor m_clrBackground
Stores color settings used to to fill background of UI item.
Definition XTPCalendarViewPart.h:1377
CXTPCalendarViewPart::GetBackgroundColor
virtual COLORREF GetBackgroundColor()
This member function is used to obtain the color used to fill the background of UI elements.
CXTPCalendarViewPart::m_fntText
CXTPCalendarViewPartFontValue m_fntText
Stores font settings used to display text.
Definition XTPCalendarViewPart.h:1379
CXTPCalendarViewPart::GetTextColor
virtual COLORREF GetTextColor()
This member function is used to obtain the color used to display text.
CXTPCalendarViewPart::m_clrTextColor
CXTPPaintManagerColor m_clrTextColor
Stores color settings used to display text.
Definition XTPCalendarViewPart.h:1376
CXTPCalendarViewPart::~CXTPCalendarViewPart
virtual ~CXTPCalendarViewPart()
Default destructor.
CXTPCalendarViewPart::GetTextExtent
CSize GetTextExtent(CDC *pDC, const CString &str)
This member function is used to calculate the size of the area required to display the given text.
CXTPCalendarViewPart::SetBackgroundColor
void SetBackgroundColor(COLORREF clr)
This member function is used to set the new color used to fill the background.
CXTPCalendarViewPart::CXTPCalendarViewPart
CXTPCalendarViewPart(CXTPCalendarViewPart *pParentPart=NULL)
Default constructor.
CXTPCalendarViewPart::DrawLineEx
void DrawLineEx(CDC *pDC, const CString &str, LPRECT lpRect, UINT nFormatNormal, UINT nFormatSmall)
This member function is used to draw a single line text in the rect.
CXTPCalendarViewPart::m_pParentPart
CXTPCalendarViewPart * m_pParentPart
Pointer to the parent CXTPCalendarViewPart object.
Definition XTPCalendarViewPart.h:1380
CXTPCalendarViewPart::m_pPaintManager
CXTPCalendarPaintManager * m_pPaintManager
Pointer to containing CXTPCalendarPaintManager object.
Definition XTPCalendarViewPart.h:1381
CXTPCalendarViewPart::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to set graphical related parameters equal to the system settings.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPMarkupGrid Member List

This is the complete list of members for CXTPMarkupGrid, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupGrid() | CXTPMarkupGrid | protected
CXTPMarkupPanel() | CXTPMarkupPanel | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupPanel |
GetBoundRect() const | CXTPMarkupVisual |
GetChildren() const | CXTPMarkupPanel |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetColumn(CXTPMarkupUIElement *pElement) | CXTPMarkupGrid | static
GetColumnDefinitions() const | CXTPMarkupGrid |
GetColumnSpan(CXTPMarkupUIElement *pElement) | CXTPMarkupGrid | static
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetRow(CXTPMarkupUIElement *pElement) | CXTPMarkupGrid | static
GetRowDefinitions() const | CXTPMarkupGrid |
GetRowSpan(CXTPMarkupUIElement *pElement) | CXTPMarkupGrid | static
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupPanel |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetColumn(CXTPMarkupUIElement *pElement, int nColumn) | CXTPMarkupGrid | static
SetColumnSpan(CXTPMarkupUIElement *pElement, int nColumnSpan) | CXTPMarkupGrid | static
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetRow(CXTPMarkupUIElement *pElement, int nRow) | CXTPMarkupGrid | static
SetRowSpan(CXTPMarkupUIElement *pElement, int nRowSpan) | CXTPMarkupGrid | static
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupGrid() | CXTPMarkupGrid | protectedvirtual
~CXTPMarkupPanel() | CXTPMarkupPanel | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPFrameThemeOffice2007.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeOffice2007.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONOFFICE2007FRAMETHEME_H__)
24# define __XTPRIBBONOFFICE2007FRAMETHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35class CXTPRibbonBar;
36
37class _XTP_EXT_CLASS CXTPRibbonOffice2007FrameTheme : public CXTPFramePaintManager
38{
39 // Construction / Destruction
40public:
41 CXTPRibbonOffice2007FrameTheme(CXTPPaintManager* pPaintManager);
42
43 virtual ~CXTPRibbonOffice2007FrameTheme();
44
45 // Frame border
46public:
47 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
48
49 virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook* pFrameHook, CSize sz) const;
50
51 // Frame caption
52public:
60 virtual void DrawFrame(CDC* pDC, CXTPCommandBarsFrameHook* pFrameHook);
61
73 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
74 BOOL bActive);
75
88 virtual void DrawFrameCaptionButton(CDC* pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed,
89 BOOL bActive, CXTPRibbonBar* pRibbonBar);
90
100 virtual void DrawCaptionText(CDC* pDC, CRect rcCaptionText, CWnd* pSite, BOOL bActive);
101
112 virtual void DrawCaptionText(CDC* pDC, CRect rcCaptionText, CWnd* pSite, BOOL bActive,
113 CXTPRibbonBar* pRibbonBar);
114
119 virtual void RefreshMetrics();
120
121protected:
122 COLORREF m_clrFrameBorderActive0;
123 COLORREF m_clrFrameBorderActive1;
124 COLORREF m_clrFrameBorderActive2;
125 COLORREF m_clrFrameBorderActive3;
126 COLORREF m_clrFrameBorderInactive0;
127 COLORREF m_clrFrameBorderInactive1;
128 COLORREF m_clrFrameBorderInactive2;
129 COLORREF m_clrFrameBorderInactive3;
130};
132# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
133#endif // !defined(__XTPRIBBONOFFICE2007FRAMETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPFramePaintManager::DrawFrameCaptionButton
virtual void DrawFrameCaptionButton(CDC *pDC, CRect rc, int nId, BOOL bSelected, BOOL bPressed, BOOL bActive)=0
This method is called to draw the caption button.
CXTPFramePaintManager::CalcFrameRegion
virtual HRGN CalcFrameRegion(CXTPCommandBarsFrameHook *pFrameHook, CSize sz) const =0
This method is called to create the window region.
CXTPFramePaintManager::DrawCaptionText
virtual void DrawCaptionText(CDC *pDC, CRect rcCaptionText, CWnd *pSite, BOOL bActive)
This method is called to draw the frame caption text.
CXTPFramePaintManager::CalcFrameBorder
virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook *pFrameHook) const
Calculates the frame border sizes.
CXTPFramePaintManager::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPFramePaintManager::DrawFrame
virtual void DrawFrame(CDC *pDC, CXTPCommandBarsFrameHook *pFrameHook)=0
This method is called to draw the frame if Ribbon was found.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69


CXTPEditThemeUltraFlat Member List

This is the complete list of members for CXTPEditThemeUltraFlat, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeUltraFlat() | CXTPEditThemeUltraFlat |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeUltraFlat | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeUltraFlat() | CXTPEditThemeUltraFlat | virtual


CXTPSplitterWndTheme Member List

This is the complete list of members for CXTPSplitterWndTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndTheme | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndTheme | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


Toolkit Pro: XTPMessageBar.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBAR_H__)
24# define __XTPMESSAGEBAR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# define XTP_IDW_MESSAGE_BAR 0xE806
34
35class CXTPCommandBars;
36class CXTPMarkupUIElement;
37class CXTPMarkupContext;
38class CXTPMessageBar;
39class CXTPPaintManager;
40class CXTPMessageBarPaintManager;
41
47class _XTP_EXT_CLASS CXTPMessageBarButton
48{
49public:
54 CXTPMessageBarButton();
55
60 ~CXTPMessageBarButton();
61
62public:
69 void PerformClick(CXTPMessageBar* pBar, CPoint pt);
70
71public:
72 CRect m_rcButton;
73 CString m_strCaption;
74 CString m_strToolTip;
75 BOOL m_bPressed;
76 BOOL m_bHot;
78 UINT m_nID;
79 CXTPMarkupUIElement* m_pUIElement;
80};
81
87class _XTP_EXT_CLASS CXTPMessageBar : public CControlBar
88{
89public:
94 CXTPMessageBar();
95
101 virtual ~CXTPMessageBar();
102
103public:
113 BOOL Create(CXTPCommandBars* pCommandBars, DWORD dwStyle = WS_CHILD | WS_VISIBLE | CBRS_TOP,
114 UINT nID = XTP_IDW_MESSAGE_BAR);
115
116public:
127 void SetMessage(LPCTSTR lpszMessage);
128
134 void EnableMarkup(BOOL bEnableMarkup = TRUE);
135
143 void AddButton(UINT nID, LPCTSTR lpszCaption, LPCTSTR lpszToolTop = NULL);
144
149 void RemoveButtons();
150
156 virtual void Click(CXTPMessageBarButton* pButton);
157
158public:
165 CRect GetMessageRect();
166
173 CXTPPaintManager* GetPaintManager() const;
174
181 CXTPMessageBarPaintManager* GetMessageBarPaintManager() const;
182
194 CXTPMessageBarButton* HitTestButton(CPoint point) const;
195
203 CXTPMessageBarButton* FindButton(UINT nID) const;
204
211 CXTPMarkupContext* GetMarkupContext() const;
212
213public:
221 int GetHeight() const;
222
230 void SetHeight(int nHeight);
231
239 void SetAutoSize(BOOL bAutoSize);
240
241protected:
247 virtual void FillMessageBar(CDC* pDC);
248
256 virtual CSize MeasureContent(CDC* pDC);
257
266 virtual CSize MeasureButton(CDC* pDC, CXTPMessageBarButton* pButton);
267
273 virtual void DrawContent(CDC* pDC);
274
281 virtual void RecalcLayout(CDC* pDC);
282
289 virtual void DrawButton(CDC* pDC, CXTPMessageBarButton* pButton);
290
296 void DrawButtons(CDC* pDC);
297
298protected:
299 DECLARE_MESSAGE_MAP()
300
301 //{{AFX_VIRTUAL(CXTPMessageBar)
302
303 virtual CSize CalcFixedLayout(BOOL, BOOL bHorz);
304 virtual void OnUpdateCmdUI(CFrameWnd* pTarget, BOOL bDisableIfNoHndler);
305 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
306 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
307
308 //}}AFX_VIRTUAL
309
310 //{{AFX_MSG(CXTPMessageBar)
311
312 afx_msg void OnPaint();
313 afx_msg void OnSize(UINT nType, int cx, int cy);
314 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
315 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
316 afx_msg void OnMouseLeave();
317
318 //}}AFX_MSG
319
320protected:
321 int m_nCustomHeight;
323 BOOL m_bAutoSize;
324 CString m_strContent;
325 CXTPMarkupUIElement* m_pUIElement;
326 CXTPMarkupContext* m_pMarkupContext;
327 CXTPCommandBars* m_pCommandBars;
328 CXTPMessageBarButton* m_pHotButton;
329 CArray<CXTPMessageBarButton*, CXTPMessageBarButton*> m_arrButtons;
331 CRect m_rcContent;
333# ifdef _XTP_COMMANDBARS_ACTIVEX
335 void OnFinalRelease();
336
337 DECLARE_DISPATCH_MAP()
338 DECLARE_INTERFACE_MAP()
339 DECLARE_OLETYPELIB_EX(CXTPMessageBar);
340 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
341
342 afx_msg BOOL OleGetVisible();
343 afx_msg void OleSetVisible(BOOL bNewValue);
344 afx_msg BSTR OleGetMessage();
345 afx_msg void OleSetMessage(LPCTSTR lpszMessage);
346 afx_msg void OleAddButton(long Id, LPCTSTR lpszCaption, LPCTSTR lpszToolTip);
347 afx_msg void OleAddCloseButton(LPCTSTR lpszToolTip);
348
349 afx_msg int OleGetHeight();
350 afx_msg void OleSetHeight(int nHeight);
351
353# endif
354
355private:
356 using CControlBar::Create;
357};
358
360
361AFX_INLINE CXTPMarkupContext* CXTPMessageBar::GetMarkupContext() const
362{
363 return m_pMarkupContext;
364}
365
367# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
368#endif // !defined(__XTPMESSAGEBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBarButton::PerformClick
void PerformClick(CXTPMessageBar *pBar, CPoint pt)
Generates a click event for the button, simulating a click by a user.
CXTPMessageBarButton::m_nID
UINT m_nID
Id of the button.
Definition XTPMessageBar.h:78
CXTPMessageBarButton::m_strToolTip
CString m_strToolTip
Tooltip text displayed for the button.
Definition XTPMessageBar.h:74
CXTPMessageBarButton::CXTPMessageBarButton
CXTPMessageBarButton()
Constructs a CXTPMessageBarButton object.
CXTPMessageBarButton::m_bHot
BOOL m_bHot
TRUE if the button is in a "hot" state, meaning the mouse cursor is hovered over the button.
Definition XTPMessageBar.h:76
CXTPMessageBarButton::~CXTPMessageBarButton
~CXTPMessageBarButton()
Destroys a CXTPMessageBarButton object, handles cleanup and deallocation.
CXTPMessageBarButton::m_pUIElement
CXTPMarkupUIElement * m_pUIElement
Store pointer to CXTPMarkupUIElement object.
Definition XTPMessageBar.h:79
CXTPMessageBarButton::m_rcButton
CRect m_rcButton
Bounding rectangle for the button.
Definition XTPMessageBar.h:72
CXTPMessageBarButton::m_bPressed
BOOL m_bPressed
TRUE if the button is currently pressed.
Definition XTPMessageBar.h:75
CXTPMessageBarButton::m_strCaption
CString m_strCaption
Text displayed in the button.
Definition XTPMessageBar.h:73
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBar::HitTestButton
CXTPMessageBarButton * HitTestButton(CPoint point) const
Tests a point to determine which message bar button, if any, is at the specified point.
CXTPMessageBar::DrawContent
virtual void DrawContent(CDC *pDC)
Draws the content of the message bar.
CXTPMessageBar::GetMessageBarPaintManager
CXTPMessageBarPaintManager * GetMessageBarPaintManager() const
This member function obtains the paint manager used for drawing a message bar.
CXTPMessageBar::Create
BOOL Create(CXTPCommandBars *pCommandBars, DWORD dwStyle=WS_CHILD|WS_VISIBLE|CBRS_TOP, UINT nID=XTP_IDW_MESSAGE_BAR)
Creates a message bar.
CXTPMessageBar::GetMessageRect
CRect GetMessageRect()
Call this member to get the bounding rectangle of the message box.
CXTPMessageBar::Click
virtual void Click(CXTPMessageBarButton *pButton)
Generates a click event for the button, simulating a click by a user.
CXTPMessageBar::GetPaintManager
CXTPPaintManager * GetPaintManager() const
This member function obtains the paint manager.
CXTPMessageBar::MeasureButton
virtual CSize MeasureButton(CDC *pDC, CXTPMessageBarButton *pButton)
Gets the size of a button.
CXTPMessageBar::GetHeight
int GetHeight() const
This member function obtains the height of the message bar.
CXTPMessageBar::MeasureContent
virtual CSize MeasureContent(CDC *pDC)
Gets the size of the content in the message bar.
CXTPMessageBar::RecalcLayout
virtual void RecalcLayout(CDC *pDC)
Call this member function to recalculate the layout of the message bar.
CXTPMessageBar::SetMessage
void SetMessage(LPCTSTR lpszMessage)
Sets the message displayed in the message bar.
CXTPMessageBar::SetAutoSize
void SetAutoSize(BOOL bAutoSize)
This member function enables auto-sizing of the message bar.
CXTPMessageBar::EnableMarkup
void EnableMarkup(BOOL bEnableMarkup=TRUE)
Call this method to enable markup for the text inside the message bar.
CXTPMessageBar::CXTPMessageBar
CXTPMessageBar()
Constructs a CXTPMessageBar object.
CXTPMessageBar::RemoveButtons
void RemoveButtons()
Removes all buttons from the message bar.
CXTPMessageBar::~CXTPMessageBar
virtual ~CXTPMessageBar()
Destroys a CXTPMessageBar object, handles cleanup and deallocation.
CXTPMessageBar::AddButton
void AddButton(UINT nID, LPCTSTR lpszCaption, LPCTSTR lpszToolTop=NULL)
Adds a button to the message bar.
CXTPMessageBar::DrawButton
virtual void DrawButton(CDC *pDC, CXTPMessageBarButton *pButton)
Call this member to draw a button in the message bar.
CXTPMessageBar::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves a pointer to the markup context.
Definition XTPMessageBar.h:361
CXTPMessageBar::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Store pointer to CXTPMarkupContext object.
Definition XTPMessageBar.h:326
CXTPMessageBar::SetHeight
void SetHeight(int nHeight)
This member function sets the custom height of the message bar.
CXTPMessageBar::FillMessageBar
virtual void FillMessageBar(CDC *pDC)
Draws the message bar.
CXTPMessageBar::FindButton
CXTPMessageBarButton * FindButton(UINT nID) const
Call this member to find the specified button.
CXTPMessageBar::DrawButtons
void DrawButtons(CDC *pDC)
Call this member to draw the buttons in the message bar.
CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.
Definition XTPMessageBarPaintManager.h:39
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


CXTPGridThemeOfficeXP Member List

This is the complete list of members for CXTPGridThemeOfficeXP, including all inherited members.

CalcColumnHeight(CDC *pDC, CXTPGridColumn *pColumn, int nTotalWidth=0) | CXTPGridPaintManager | protectedvirtual
CalculateRowHeight(CDC *pDC, const CString &strText, int nMaxWidth, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridPaintManager() | CXTPGridPaintManager |
CXTPGridThemeOfficeXP() | CXTPGridThemeOfficeXP |
DrawBitmap(CDC *pDC, CXTPGridControl *pControl, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap) | CXTPGridPaintManager | virtual
DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0) | CXTPGridPaintManager | virtual
DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL) | CXTPGridThemeOfficeXP | virtual
DrawColumnFooter(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn) | CXTPGridPaintManager | virtual
DrawColumnIcon(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, CRect rcIcon, int iIcon) | CXTPGridPaintManager | virtual
DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawConnector(CDC *pDC, CPoint ptFrom, CPoint ptTo) | CXTPGridPaintManager |
DrawFocusedRow(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
DrawFreezeColsDivider(CDC *pDC, const CRect &rc, CXTPGridControl *pControl, CXTPGridRow *pRow=NULL) | CXTPGridPaintManager | virtual
DrawGlyph(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawGrid(CDC *pDC, XTPGridOrientation orientation, CRect rcGrid) | CXTPGridPaintManager | virtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CXTPBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr, BOOL bUpdateBrush) | CXTPGridPaintManager | protectedvirtual
DrawGridPattern(CDC *pDC, CBrush *pBrush, CRect rc, const void *pPattern, COLORREF clr) | CXTPGridPaintManager | protectedvirtual
DrawGroupRow(CDC *pDC, CXTPGridGroupRow *pRow, CRect rcRow, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx, COLORREF clr) | CXTPGridPaintManager |
DrawInplaceButton(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | virtual
DrawInplaceButtonFrame(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceButtonIcon(CDC *pDC, CXTPGridInplaceButton *pButton) | CXTPGridPaintManager | protectedvirtual
DrawInplaceComboButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceExpandButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawInplaceSpinButton(CDC *pDC, CRect *pRc) | CXTPGridPaintManager | virtual
DrawItemBitmap(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem, int nImage) | CXTPGridPaintManager | virtual
DrawItemCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridPaintManager | virtual
DrawItemControl(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CXTPGridRecordItemControl *pControl, CRect &rcItem) | CXTPGridPaintManager | virtual
DrawLink(int *pnCurrDrawPos, XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CXTPGridHyperlink *pHyperlink, CString strText, CRect rcLink, int nFlag, BOOL bTrim=FALSE) | CXTPGridPaintManager | protectedvirtual
DrawMultiLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, BOOL bWordBreak=TRUE) | CXTPGridPaintManager | protectedvirtual
DrawNoGroupByText(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
DrawRowNumber(CDC *pDC, CRect rcNumber, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor) | CXTPGridPaintManager |
DrawShellIcon(CDC *pDC, CRect rcColumn, int iImage) | CXTPGridPaintManager | virtual
DrawSingleLineText(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nStartPos, int nEndPos, int nActualWidth) | CXTPGridPaintManager | protectedvirtual
DrawString(int *pnCurrDrawPos, CDC *pDC, const CString &strDraw, CRect rcDraw, UINT nFormat) | CXTPGridPaintManager | protectedvirtual
DrawTextLine(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, const CString &strText, CRect rcItem, int nFlag, int &nCharCounter, int &nHyperlinkCounter) | CXTPGridPaintManager | protectedvirtual
DrawTreeStructure(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics, CRect rcItem, CSize sizeGlyph) | CXTPGridPaintManager | virtual
DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed) | CXTPGridPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy, COLORREF clr) | CXTPGridPaintManager |
DrawVerticalTimeLineMarker(CDC *pDC, int xPos, CXTPGridControl *pControl, COLORREF color=RGB(0, 255, 0)) | CXTPGridPaintManager | virtual
EnablePreviewMode(BOOL bIsPreviewMode) | CXTPGridPaintManager |
FillFooter(CDC *pDC, CRect rcFooter) | CXTPGridPaintManager | virtual
FillGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridPaintManager | virtual
FillGroupRowMetrics(CXTPGridGroupRow *pRow, XTP_GRIDRECORDITEM_METRICS *pMetrics, BOOL bPrinting) | CXTPGridPaintManager | virtual
FillHeaderControl(CDC *pDC, CRect rcHeader) | CXTPGridPaintManager | virtual
FillIndent(CDC *pDC, CRect rcRow) | CXTPGridPaintManager | virtual
FillItemShade(CDC *pDC, CRect rcItem) | CXTPGridPaintManager | virtual
FillRow(CDC *pDC, CXTPGridRow *pRow, CRect rcRow) | CXTPGridPaintManager | virtual
FindRowAdjacentToMerged(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, BOOL bUpward) | CXTPGridPaintManager |
FindRowAdjacentToMergedEx(const CXTPGridColumns *pColumns, const CXTPGridRow *pRow, int &nAdjRowIndex, BOOL bUpward) | CXTPGridPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColumnOffice2007CustomThemeBaseColor() const | CXTPGridPaintManager |
GetColumnStyle() const | CXTPGridPaintManager |
GetControlBackColor(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
GetFooterHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetFreezeColsDividerStyle() const | CXTPGridPaintManager |
GetGlyphs() const | CXTPGridPaintManager |
GetHeaderHeight() | CXTPGridPaintManager | virtual
GetHeaderHeight(CXTPGridControl *pControl, CDC *pDC, int nTotalWidth=0) | CXTPGridPaintManager | virtual
GetItemHeight(XTP_GRIDRECORDITEM_DRAWARGS &drawArgs, int nWidth) | CXTPGridPaintManager |
GetMaxPreviewLines() | CXTPGridPaintManager |
GetPreviewItemHeight(CDC *pDC, CXTPGridRow *pRow, int nWidth, int nHeight) | CXTPGridPaintManager | virtual
GetPreviewLinesCount(CDC *pDC, CRect &rcText, const CString &strText) | CXTPGridPaintManager |
GetRowHeight(CDC *pDC, CXTPGridRow *pRow) | CXTPGridPaintManager | virtual
GetRowHeight(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth) | CXTPGridPaintManager | virtual
GetRowHeightEx(CDC *pDC, CXTPGridRow *pRow, int nTotalWidth, const BOOL firstLevel=TRUE) | CXTPGridPaintManager |
GetSectionDividerHeight(XTPGridFixedRowsDividerStyle dividerStyle) | CXTPGridPaintManager |
GetTextFont() | CXTPGridPaintManager |
IsColumHotTrackingEnabled() const | CXTPGridPaintManager | virtual
IsColumnPlusMinusSign() const | CXTPGridPaintManager |
IsColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsDrawGridForEmptySpace() const | CXTPGridPaintManager |
IsFixedInplaceButtonHeight() const | CXTPGridPaintManager |
IsFixedRowHeight() const | CXTPGridPaintManager |
IsGridVisible(BOOL bVertical) const | CXTPGridPaintManager |
IsGridVisible(XTPGridOrientation orientation) const | CXTPGridPaintManager |
IsLastColumnWidthWYSIWYG() const | CXTPGridPaintManager |
IsPreviewMode() const | CXTPGridPaintManager |
IsPrintGroupRowIcon() const | CXTPGridPaintManager |
IsShowWYSIWYGMarkers() const | CXTPGridPaintManager |
IsUseDropMarker() const | CXTPGridPaintManager |
LoadGlyphs() | CXTPGridPaintManager | virtual
m_arStartCol | CXTPGridPaintManager |
m_bAllowMergeCells | CXTPGridPaintManager |
m_bBaseTreeIndent | CXTPGridPaintManager |
m_bCleanTooltip | CXTPGridPaintManager |
m_bColumnPlusMinusSign | CXTPGridPaintManager | protected
m_bColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bCompactText | CXTPGridPaintManager |
m_bDrawGridForEmptySpace | CXTPGridPaintManager | protected
m_bFixedInplaceButtonHeight | CXTPGridPaintManager | protected
m_bFixedRowHeight | CXTPGridPaintManager | protected
m_bForceDynamicMarkupForCell | CXTPGridPaintManager |
m_bForceShowDropMarker | CXTPGridPaintManager |
m_bForceShowTooltip | CXTPGridPaintManager |
m_bGrayIfDisable | CXTPGridPaintManager |
m_bGroupRowTextBold | CXTPGridPaintManager |
m_bHideSelection | CXTPGridPaintManager |
m_bHotTracking | CXTPGridPaintManager |
m_bInvertColumnOnClick | CXTPGridPaintManager |
m_bIsPreviewMode | CXTPGridPaintManager | protected
m_bLastColumnWidthWYSIWYG | CXTPGridPaintManager | protected
m_bMakeUpper | CXTPGridPaintManager |
m_bMoveScrollbarOnFixedColumnsIndent | CXTPGridPaintManager |
m_bPrintGroupRowIcon | CXTPGridPaintManager | protected
m_bPrintPageRectangle | CXTPGridPaintManager |
m_bPrintSortTriangle | CXTPGridPaintManager |
m_bPrintVirtualPageNumber | CXTPGridPaintManager |
m_bPrintWatermark | CXTPGridPaintManager |
m_bRecOrRowNum | CXTPGridPaintManager |
m_bRevertAlignment | CXTPGridPaintManager |
m_bShadeGroupHeadings | CXTPGridPaintManager |
m_bShadeSortColumn | CXTPGridPaintManager |
m_bShowLockIcon | CXTPGridPaintManager |
m_bShowNonActiveInPlaceButton | CXTPGridPaintManager |
m_bShowWYSIWYGMarkers | CXTPGridPaintManager | protected
m_bSortTriangleOffsetFromRight | CXTPGridPaintManager |
m_bThemedInplaceButtons | CXTPGridPaintManager |
m_bUseAlternativeBackground | CXTPGridPaintManager |
m_bUseDropMarker | CXTPGridPaintManager |
m_bUseEditTextAlignment | CXTPGridPaintManager |
m_bUseGroupRowSelectionState | CXTPGridPaintManager |
m_bUseShellIcon | CXTPGridPaintManager |
m_clrAlternativeBackground | CXTPGridPaintManager |
m_clrBoldText | CXTPGridPaintManager |
m_clrBoldTextHighlight | CXTPGridPaintManager |
m_clrBtnFace | CXTPGridPaintManager |
m_clrBtnFacePressed | CXTPGridPaintManager |
m_clrBtnText | CXTPGridPaintManager |
m_clrCaptionText | CXTPGridPaintManager |
m_clrCaptionTextPressed | CXTPGridPaintManager |
m_clrColumnOffice2007CustomTheme | CXTPGridPaintManager |
m_clrConnector | CXTPGridPaintManager |
m_clrControlBack | CXTPGridPaintManager |
m_clrControlDark | CXTPGridPaintManager |
m_clrControlLightLight | CXTPGridPaintManager |
m_clrDisableBitmapDarkest | CXTPGridPaintManager |
m_clrDisableBitmapLightest | CXTPGridPaintManager |
m_clrFormulaSubSum | CXTPGridPaintManager |
m_clrFormulaSum | CXTPGridPaintManager |
m_clrFreezeColsDivider | CXTPGridPaintManager |
m_clrGradientColumnSeparator | CXTPGridPaintManager |
m_clrGradientColumnShadow | CXTPGridPaintManager |
m_clrGroupBoxBack | CXTPGridPaintManager |
m_clrGroupRowText | CXTPGridPaintManager |
m_clrGroupShadeBack | CXTPGridPaintManager |
m_clrGroupShadeBorder | CXTPGridPaintManager |
m_clrGroupShadeText | CXTPGridPaintManager |
m_clrHeaderControl | CXTPGridPaintManager |
m_clrHighlight | CXTPGridPaintManager |
m_clrHighlightText | CXTPGridPaintManager |
m_clrHotDivider | CXTPGridPaintManager |
m_clrIndentControl | CXTPGridPaintManager |
m_clrItemShade | CXTPGridPaintManager |
m_clrPreviewText | CXTPGridPaintManager |
m_clrSelectedRow | CXTPGridPaintManager |
m_clrSelectedRowText | CXTPGridPaintManager |
m_clrWindowText | CXTPGridPaintManager |
m_columnStyle | CXTPGridPaintManager | protected
m_crlNoGroupByText | CXTPGridPaintManager |
m_grcGradientColumn | CXTPGridPaintManager |
m_grcGradientColumnHot | CXTPGridPaintManager |
m_grcGradientColumnPushed | CXTPGridPaintManager |
m_iRecOrRowStart | CXTPGridPaintManager |
m_nBaseParentRecordIndent | CXTPGridPaintManager |
m_nFixedColumnsIndent | CXTPGridPaintManager |
m_nFooterHeight | CXTPGridPaintManager | protected
m_nFreezeColsDividerStyle | CXTPGridPaintManager | protected
m_nGridLineStylePreviousH | CXTPGridPaintManager | protected
m_nGridLineStylePreviousV | CXTPGridPaintManager | protected
m_nGroupGridLineHeight | CXTPGridPaintManager | protected
m_nGroupGridLineStyle | CXTPGridPaintManager | protected
m_nHeaderHeight | CXTPGridPaintManager | protected
m_nMaxPreviewLines | CXTPGridPaintManager | protected
m_nResizingWidth | CXTPGridPaintManager | protected
m_nRowHeight | CXTPGridPaintManager | protected
m_nRowHeightDefault | CXTPGridPaintManager |
m_nTextIndentForGroupRowsWithNoIcon | CXTPGridPaintManager |
m_nTreeColumnLineLength | CXTPGridPaintManager |
m_nTreeIndent | CXTPGridPaintManager |
m_nTreeStructureStyle | CXTPGridPaintManager |
m_nTreeTextIndent | CXTPGridPaintManager |
m_nTreeTextIndentGroupRow | CXTPGridPaintManager |
m_nTreeTextIndentRowChildren | CXTPGridPaintManager |
m_nTreeTextIndentRowParent | CXTPGridPaintManager |
m_pControl | CXTPGridPaintManager | protected
m_pGlyphs | CXTPGridPaintManager | protected
m_pHyperlinkHoverStyle | CXTPGridPaintManager |
m_pHyperlinkStyle | CXTPGridPaintManager |
m_pMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_PrintPageWidth | CXTPGridPaintManager |
m_rcPreviewIndent | CXTPGridPaintManager |
m_RecordNumberWidth | CXTPGridPaintManager |
m_strCollapse | CXTPGridPaintManager |
m_strDecreasing | CXTPGridPaintManager |
m_strExpand | CXTPGridPaintManager |
m_strIncreasing | CXTPGridPaintManager |
m_strMarkupUIElement_NoGroupBy | CXTPGridPaintManager | protected
m_strNoFieldsAvailable | CXTPGridPaintManager |
m_strNoGroupBy | CXTPGridPaintManager |
m_strNoItems | CXTPGridPaintManager |
m_strSortBy | CXTPGridPaintManager |
m_szGlyph | CXTPGridPaintManager | protected
m_themeButton | CXTPGridPaintManager | protected
m_themeCombo | CXTPGridPaintManager | protected
m_themeHeader | CXTPGridPaintManager | protected
m_themeSpin | CXTPGridPaintManager | protected
m_treeStructureStyle | CXTPGridPaintManager |
m_xtpBrushGroupGridLineStyle | CXTPGridPaintManager | protected
m_xtpBrushHorizontalGrid | CXTPGridPaintManager | protected
m_xtpBrushTreeStructure | CXTPGridPaintManager | protected
m_xtpBrushVeriticalGrid | CXTPGridPaintManager | protected
m_xtpFontBoldText | CXTPGridPaintManager |
m_xtpFontCaption | CXTPGridPaintManager |
m_xtpFontPreview | CXTPGridPaintManager |
m_xtpFontText | CXTPGridPaintManager |
OnDrawAction(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridPaintManager | virtual
RecalcTotalHightOfMergedRows(CXTPGridColumns *pColumns, CDC *pDC, CXTPGridRow *pRow, int nRowHeight, int nTotalWidth) | CXTPGridPaintManager |
RefreshMetrics() | CXTPGridPaintManager | virtual
SetCaptionFont(LOGFONT &lf) | CXTPGridPaintManager |
SetColumnOffice2007CustomThemeBaseColor(COLORREF clrBaseColor) | CXTPGridPaintManager |
SetColumnPlusMinusSign(BOOL bDraw) | CXTPGridPaintManager |
SetColumnStyle(XTPGridColumnStyle columnStyle) | CXTPGridPaintManager |
SetColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetDrawGridForEmptySpace(BOOL bDrawGrid) | CXTPGridPaintManager |
SetFixedRowHeight(BOOL bFixedRowHeight) | CXTPGridPaintManager |
SetFreezeColsDividerStyle(int nStyle) | CXTPGridPaintManager |
SetGridControl(CXTPGridControl *pControl) | CXTPGridPaintManager | virtual
SetHeaderHeight(int nHeight) | CXTPGridPaintManager | virtual
SetInplaceButtonHeight(BOOL bFixedInplaceButtonHeight) | CXTPGridPaintManager |
SetLastColumnWidthWYSIWYG(BOOL bColumnWidthWYSIWYG) | CXTPGridPaintManager |
SetMaxPreviewLines(int nMaxLines) | CXTPGridPaintManager |
SetPreviewIndent(int nLeft, int nTop, int nRight, int nBottom) | CXTPGridPaintManager |
SetPrintGroupRowIcon(BOOL bDraw) | CXTPGridPaintManager |
SetTextFont(LOGFONT &lf) | CXTPGridPaintManager |
ShowWYSIWYGMarkers(BOOL bSet) | CXTPGridPaintManager |
~CXTPGridPaintManager() | CXTPGridPaintManager | virtual


Toolkit Pro: XTPChartHighLowSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Financial
XTPChartHighLowSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTHIGHLOWSERIESSTYLE_H__)
24# define __XTPCHARTHIGHLOWSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
44class _XTP_EXT_CLASS CXTPChartHighLowSeriesStyle : public CXTPChartDiagram2DSeriesStyle
45{
47 DECLARE_SERIAL(CXTPChartHighLowSeriesStyle);
49public:
54 CXTPChartHighLowSeriesStyle();
55
60 virtual ~CXTPChartHighLowSeriesStyle();
61
62public:
69 void SetLineThickness(int nLineThickness);
70
78 int GetLineThickness() const;
79
80public:
88 CXTPChartColor GetCustomUpColor() const;
89
97 CXTPChartColor GetCustomDownColor() const;
98
106 CXTPChartColor GetUpColor() const;
107
115 CXTPChartColor GetDownColor() const;
116
117protected:
127 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
128 CXTPChartDiagramView* pDiagramView);
129
130protected:
131# ifdef _XTP_ACTIVEX
132public:
134 DECLARE_DISPATCH_MAP()
135 DECLARE_INTERFACE_MAP()
136 DECLARE_OLETYPELIB_EX(CXTPChartHighLowSeriesStyle);
137 DECLARE_OLECREATE_EX(CXTPChartHighLowSeriesStyle)
138
140# endif
141
142protected:
143 int m_nLineThickness;
144 CXTPChartColor m_clrDownColor;
145 CXTPChartColor m_clrUpColor;
146};
147
157class _XTP_EXT_CLASS CXTPChartHighLowSeriesView : public CXTPChartDiagram2DSeriesView
158{
159public:
167 CXTPChartHighLowSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
168
169protected:
181 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
182 CXTPChartSeriesPoint* pPoint,
183 CXTPChartElementView* pParentView);
184
195 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
196 CRect rcBounds);
197};
198
208class _XTP_EXT_CLASS CXTPChartHighLowSeriesPointView : public CXTPChartSeriesPointView
209{
210public:
218 CXTPChartHighLowSeriesPointView(CXTPChartSeriesPoint* pPoint,
219 CXTPChartElementView* pParentView);
220
221public:
234 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
235
236public:
247 CXTPChartPointF GetScreenPoint(int nIndex);
248};
249
250AFX_INLINE int CXTPChartHighLowSeriesStyle::GetLineThickness() const
251{
252 return m_nLineThickness;
253}
254AFX_INLINE void CXTPChartHighLowSeriesStyle::SetLineThickness(int nLineThickness)
255{
256 m_nLineThickness = nLineThickness;
257 OnChartChanged();
258}
259AFX_INLINE CXTPChartColor CXTPChartHighLowSeriesStyle::GetCustomUpColor() const
260{
261 return m_clrUpColor;
262}
263AFX_INLINE CXTPChartColor CXTPChartHighLowSeriesStyle::GetCustomDownColor() const
264{
265 return m_clrDownColor;
266}
268# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
269#endif //#if !defined(__XTPCHARTHIGHLOWSERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartDiagram2DSeriesStyle.h:47
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartHighLowSeriesPointView
This class abstracts the view of the stock series point of the chart.
Definition XTPChartHighLowSeriesStyle.h:209
CXTPChartHighLowSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartHighLowSeriesPointView::CXTPChartHighLowSeriesPointView
CXTPChartHighLowSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartHighLowSeriesPointView object.
CXTPChartHighLowSeriesPointView::GetScreenPoint
CXTPChartPointF GetScreenPoint(int nIndex)
Call this function to get the screen point from a point index.
CXTPChartHighLowSeriesStyle
This class represents the stock series style in the chart.
Definition XTPChartHighLowSeriesStyle.h:45
CXTPChartHighLowSeriesStyle::m_clrUpColor
CXTPChartColor m_clrUpColor
User-defined up day color.
Definition XTPChartHighLowSeriesStyle.h:145
CXTPChartHighLowSeriesStyle::GetUpColor
CXTPChartColor GetUpColor() const
Call this function to get the up day color of stock ticks.
CXTPChartHighLowSeriesStyle::CXTPChartHighLowSeriesStyle
CXTPChartHighLowSeriesStyle()
Constructs a CXTPChartHighLowSeriesStyle object.
CXTPChartHighLowSeriesStyle::SetLineThickness
void SetLineThickness(int nLineThickness)
Call this function to set the line thickness of stock ticks.
Definition XTPChartHighLowSeriesStyle.h:254
CXTPChartHighLowSeriesStyle::GetCustomUpColor
CXTPChartColor GetCustomUpColor() const
Call this function to get the user-defined up day color of stock ticks.
Definition XTPChartHighLowSeriesStyle.h:259
CXTPChartHighLowSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the stock series.
CXTPChartHighLowSeriesStyle::m_clrDownColor
CXTPChartColor m_clrDownColor
User-defined down day color.
Definition XTPChartHighLowSeriesStyle.h:144
CXTPChartHighLowSeriesStyle::m_nLineThickness
int m_nLineThickness
The stock tick line thickness.
Definition XTPChartHighLowSeriesStyle.h:143
CXTPChartHighLowSeriesStyle::GetDownColor
CXTPChartColor GetDownColor() const
Call this function to get the down day color of stock ticks.
CXTPChartHighLowSeriesStyle::~CXTPChartHighLowSeriesStyle
virtual ~CXTPChartHighLowSeriesStyle()
Destroys a CXTPChartHighLowSeriesStyle object, handles cleanup.
CXTPChartHighLowSeriesStyle::GetCustomDownColor
CXTPChartColor GetCustomDownColor() const
Call this function to get the user-defined down day color of stock ticks.
Definition XTPChartHighLowSeriesStyle.h:263
CXTPChartHighLowSeriesStyle::GetLineThickness
int GetLineThickness() const
Call this function to get the line thickness of stock ticks.
Definition XTPChartHighLowSeriesStyle.h:250
CXTPChartHighLowSeriesView
This class abstracts the view of the stock series of the chart.
Definition XTPChartHighLowSeriesStyle.h:158
CXTPChartHighLowSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartHighLowSeriesView::CXTPChartHighLowSeriesView
CXTPChartHighLowSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartHighLowSeriesView object.
CXTPChartHighLowSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a stock series point view object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >


CXTPFlowGraphImages Member List

This is the complete list of members for CXTPFlowGraphImages, including all inherited members.

AddImage(CXTPFlowGraphImage *pPage) | CXTPFlowGraphImages |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphImages(CXTPFlowGraphControl *pControl) | CXTPFlowGraphImages | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphImages |
GetCount() const | CXTPFlowGraphImages |
GetImageManager() const | CXTPFlowGraphImages |
m_arrImages | CXTPFlowGraphImages | protected
m_pImageManager | CXTPFlowGraphImages | protected
Remove(CXTPFlowGraphImage *pPage) | CXTPFlowGraphImages |
RemoveAll() | CXTPFlowGraphImages |
RemoveAt(int nIndex) | CXTPFlowGraphImages |
~CXTPFlowGraphImages() | CXTPFlowGraphImages | protectedvirtual


Toolkit Pro: XTPChartPieSeriesStyleBase.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • Base
XTPChartPieSeriesStyleBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESSTYLEBASE_H__)
24# define __XTPCHARTPIESERIESSTYLEBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35
47class _XTP_EXT_CLASS CXTPChartPieSeriesStyleBase : public CXTPChartSeriesStyle
48{
50 DECLARE_DYNAMIC(CXTPChartPieSeriesStyleBase)
52protected:
57 CXTPChartPieSeriesStyleBase();
58
63 virtual ~CXTPChartPieSeriesStyleBase();
64
65public:
73 int GetHolePercent() const;
74
81 void SetHolePercent(int nHolePercent);
82
95 int GetExplodedDistancePercent() const;
108 void SetExplodedDistancePercent(int nExplodedDistancePercent);
109
117 int GetRotation() const;
118
125 void SetRotation(int nRotation);
126
134 virtual int GetDepth() const;
135
147 void DoPropExchange(CXTPPropExchange* pPX);
148
156 CXTPChartBorder* GetBorder() const;
157
165 CXTPChartColor GetBorderActualColor() const;
166
167protected:
176 virtual CXTPChartDiagram* CreateDiagram() = 0;
177
189 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
190 CXTPChartDiagramView* pDiagramView) = 0;
191
202 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
203
204protected:
205# ifdef _XTP_ACTIVEX
206public:
208 DECLARE_DISPATCH_MAP()
209 DECLARE_INTERFACE_MAP()
210
211 afx_msg LPDISPATCH OleGetBorder();
213# endif
214
215protected:
216 int m_nHolePercent;
217 int m_nExplodedDistancePercent;
218 int m_nRotation;
219 CXTPChartBorder* m_pBorder;
220};
221
222AFX_INLINE int CXTPChartPieSeriesStyleBase::GetHolePercent() const
223{
224 return m_nHolePercent;
225}
226AFX_INLINE void CXTPChartPieSeriesStyleBase::SetHolePercent(int nHolePercent)
227{
228 m_nHolePercent = nHolePercent;
229 OnChartChanged();
230}
231AFX_INLINE int CXTPChartPieSeriesStyleBase::GetExplodedDistancePercent() const
232{
233 return m_nExplodedDistancePercent;
234}
235AFX_INLINE void CXTPChartPieSeriesStyleBase::SetExplodedDistancePercent(int nExplodedDistancePercent)
236{
237 m_nExplodedDistancePercent = nExplodedDistancePercent;
238 OnChartChanged();
239}
240AFX_INLINE int CXTPChartPieSeriesStyleBase::GetRotation() const
241{
242 return m_nRotation;
243}
244AFX_INLINE void CXTPChartPieSeriesStyleBase::SetRotation(int nRotation)
245{
246 m_nRotation = nRotation;
247 OnChartChanged();
248}
249AFX_INLINE CXTPChartBorder* CXTPChartPieSeriesStyleBase::GetBorder() const
250{
251 return m_pBorder;
252}
254# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
255#endif //#if !defined(__XTPCHARTPIESERIESSTYLEBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartPieSeriesStyleBase
This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartPieSeriesStyleBase.h:48
CXTPChartPieSeriesStyleBase::~CXTPChartPieSeriesStyleBase
virtual ~CXTPChartPieSeriesStyleBase()
Destroys a CXTPChartPieSeriesStyleBase object, handle cleanup.
CXTPChartPieSeriesStyleBase::GetBorderActualColor
CXTPChartColor GetBorderActualColor() const
Obtains border color.
CXTPChartPieSeriesStyleBase::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChartPieSeriesStyleBase::GetHolePercent
int GetHolePercent() const
Call this function to get the hole percent of the pie chart.
Definition XTPChartPieSeriesStyleBase.h:222
CXTPChartPieSeriesStyleBase::m_nHolePercent
int m_nHolePercent
The hole percentage.
Definition XTPChartPieSeriesStyleBase.h:216
CXTPChartPieSeriesStyleBase::GetDepth
virtual int GetDepth() const
Call this function to get the depth of 3D pie chart.
CXTPChartPieSeriesStyleBase::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Call this function to check whether chart diagram object passed is a kind of CXTPChart2dPieDiagramBas...
CXTPChartPieSeriesStyleBase::SetRotation
void SetRotation(int nRotation)
Call this function to set the rotation of the sectors of the pie chart.
Definition XTPChartPieSeriesStyleBase.h:244
CXTPChartPieSeriesStyleBase::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)=0
Call this function to create the view of the pie series.
CXTPChartPieSeriesStyleBase::m_pBorder
CXTPChartBorder * m_pBorder
Associated border information.
Definition XTPChartPieSeriesStyleBase.h:219
CXTPChartPieSeriesStyleBase::GetRotation
int GetRotation() const
Call this function to get the rotation of the sectors of the pie chart.
Definition XTPChartPieSeriesStyleBase.h:240
CXTPChartPieSeriesStyleBase::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()=0
Call this function to create the pie diagram object.
CXTPChartPieSeriesStyleBase::CXTPChartPieSeriesStyleBase
CXTPChartPieSeriesStyleBase()
Constructs a CXTPChartPieSeriesStyleBase object.
CXTPChartPieSeriesStyleBase::GetBorder
CXTPChartBorder * GetBorder() const
Obtains border object pointer.
Definition XTPChartPieSeriesStyleBase.h:249
CXTPChartPieSeriesStyleBase::m_nRotation
int m_nRotation
The sector rotation angle.
Definition XTPChartPieSeriesStyleBase.h:218
CXTPChartPieSeriesStyleBase::GetExplodedDistancePercent
int GetExplodedDistancePercent() const
Call this function to get the exploded distance percent of the pie chart.
Definition XTPChartPieSeriesStyleBase.h:231
CXTPChartPieSeriesStyleBase::SetExplodedDistancePercent
void SetExplodedDistancePercent(int nExplodedDistancePercent)
Call this function to set the exploded distance percent of the pie chart.
Definition XTPChartPieSeriesStyleBase.h:235
CXTPChartPieSeriesStyleBase::SetHolePercent
void SetHolePercent(int nHolePercent)
Call this function to set the hole percent of the pie chart.
Definition XTPChartPieSeriesStyleBase.h:226
CXTPChartPieSeriesStyleBase::m_nExplodedDistancePercent
int m_nExplodedDistancePercent
The exploded distance percentage.
Definition XTPChartPieSeriesStyleBase.h:217
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPChartRadarPointSeriesLabel Member List

This is the complete list of members for CXTPChartRadarPointSeriesLabel, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarPointSeriesLabel() | CXTPChartRadarPointSeriesLabel |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartRadarPointSeriesLabel | virtual
GetAngle() const | CXTPChartRadarPointSeriesLabel |
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetShowLines() const | CXTPChartSeriesLabel |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nAngle | CXTPChartRadarPointSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAngle(int nAngle) | CXTPChartRadarPointSeriesLabel |
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartRadarPointSeriesLabel() | CXTPChartRadarPointSeriesLabel | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPCommandBars.h Source File

  • Source
  • CommandBars
XTPCommandBars.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARS_H__)
24# define __XTPCOMMANDBARS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockBar;
34class CXTPToolBar;
35class CXTPControl;
36class CXTPPopupBar;
37class CXTPDockState;
38class CXTPCommandBar;
39class CXTPCustomizeDropSource;
40class CXTPCommandBars;
41class CXTPCommandBarList;
42class CXTPImageManager;
43class CXTPPaintManager;
44class CXTPControls;
45class CXTPMenuBar;
46class CXTPMenuTitleBar;
47class CXTPReBar;
48class CXTPToolTipContext;
49class CXTPShortcutManager;
50class CXTPKeyboardManager;
51class CXTPStatusBar;
52class CXTPMouseManager;
53class CXTPControlActions;
54class CXTPControlAction;
55class CXTPPropExchange;
56class CXTPCommandBarsFrameHook;
57class CXTPRecentFileList;
58class CXTPCommandBarsOptions;
59class CXTPCommandBarsContextMenus;
60class CXTPCommandBarKeyboardTip;
61
87struct XTP_COMMANDBARS_PROPEXCHANGE_PARAM
88{
104 XTP_COMMANDBARS_PROPEXCHANGE_PARAM()
105 {
106 pCommandBars = NULL;
107 bSerializeControls = FALSE;
108 bSaveOnlyCustomized = TRUE;
109 bLoadSilent = FALSE;
110 bSaveOriginalControls = TRUE;
111 bSerializeLayout = TRUE;
112 bSerializeOptions = FALSE;
113 bSerializeImages = FALSE;
114 bSerializeDesignerControls = FALSE;
115 bSerializeActions = FALSE;
116 }
119 BOOL bSerializeControls;
122 BOOL bSaveOnlyCustomized;
124 BOOL bLoadSilent;
127 BOOL bSaveOriginalControls;
131 BOOL bSerializeImages;
133 BOOL bSerializeOptions;
137 BOOL bSerializeLayout;
140 BOOL bSerializeDesignerControls;
150 BOOL bSerializeActions;
151 CXTPCommandBars* pCommandBars;
153};
154
162class _XTP_EXT_CLASS CXTPCommandBars
163 : public CXTPCmdTarget
164 , private IXTPApplicationEvents
165{
166protected:
171 CXTPCommandBars();
172
177 virtual ~CXTPCommandBars();
178
179public:
190 CXTPMenuTitleBar* SetMenuTitleBar(LPCTSTR strName, UINT nID, INT nIconID = -1);
191
198 CXTPMenuTitleBar* GetMenuTitleBar() const;
199
210 CXTPMenuBar* SetMenu(LPCTSTR lpszName, UINT nID);
211
227 CXTPToolBar* Add(LPCTSTR lpszName, XTPBarPosition nBarPosition,
228 CRuntimeClass* pToolbarClass = NULL);
229
245 CXTPToolBar* Add(CXTPToolBar* pToolBar, LPCTSTR strName, XTPBarPosition nBarPosition);
246
253 virtual CXTPMenuBar* GetMenuBar() const;
254
262 CXTPToolBar* GetToolBar(UINT nID) const;
263
270 CWnd* GetSite() const;
271
279 CXTPDockBar* GetDockBar(XTPBarPosition barPosition) const;
280
285 void RedrawCommandBars();
286
291 void InvalidateCommandBars();
292
299 virtual void RecalcFrameLayout(BOOL bDelay = FALSE);
300
311 CXTPControl* FindControl(XTPControlType type, UINT nId, BOOL bVisible, BOOL bRecursive) const;
312
360 static BOOL AFX_CDECL TrackPopupMenu(CMenu* pMenu, UINT nFlags, int xPos, int yPos, CWnd* pWnd,
361 LPCRECT rcExclude = NULL, CWnd* pWndOwner = NULL,
362 CXTPCommandBars* pCommandBars = NULL);
363
410 static BOOL AFX_CDECL TrackPopupMenu(CXTPPopupBar* pPopupBar, UINT nFlags, int xPos, int yPos,
411 CWnd* pWnd, LPCRECT rcExclude = NULL,
412 CWnd* pWndOwner = NULL);
413
456 BOOL TrackPopupMenu(UINT nBarID, UINT nFlags, int xPos, int yPos, LPCRECT rcExclude = NULL);
457
502 BOOL TrackPopupMenuEx(CMenu* pMenu, UINT nFlags, int xPos, int yPos, CWnd* pWndOwner = NULL,
503 LPTPMPARAMS lptpm = NULL);
504
511 CXTPCommandBarsContextMenus* GetContextMenus() const;
512
519 CXTPCommandBarsOptions* GetCommandBarsOptions() const;
520
534 void SaveBarState(LPCTSTR lpszProfileName, BOOL bOnlyCustomized = TRUE);
535
549 void LoadBarState(LPCTSTR lpszProfileName, BOOL bSilent = FALSE);
550
561 void SaveOptions(LPCTSTR lpszProfileName);
562
573 void LoadOptions(LPCTSTR lpszProfileName);
574
588 void SerializeBarState(CArchive& ar, BOOL bSerializeControls = FALSE,
589 BOOL bOnlyCustomized = TRUE, BOOL bSilent = FALSE);
590
599 CXTPShortcutManager* GetShortcutManager() const;
600
608 void SetShortcutManager(CXTPShortcutManager* pShortcutManager);
609
629 void DoPropExchange(CXTPPropExchange* pPX, XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam = NULL);
630
645 void LoadDesignerBars(CArchive& ar, UINT nSchemaVersion = _XTP_SCHEMA_CURRENT);
646
655 void LoadDesignerBars(CXTPPropExchange* pPX);
656
657 // # Intelligent menus routines
658
671 void HideCommands(const UINT* pCommands, int nCount);
672
679 void HideCommand(UINT nCommand);
680
695 virtual BOOL IsCommandHidden(UINT nCommand);
696
709 virtual BOOL IsControlHidden(CXTPControl* pControl);
710
716 void SetCommandUsed(UINT nCommand);
717
723 void ResetUsageData();
724
731 virtual UINT GetActiveDocTemplate();
732
740 void OnSetPreviewMode(BOOL bPreview);
741
746 void UpdateCommandBars() const;
747
748public:
756 BOOL IsAllCaps() const;
757
764 void SetAllCaps(BOOL bAllCaps);
765
773 BOOL IsLayoutRTL() const;
774
781 void SetLayoutRTL(BOOL bRightToLeft);
782
783public:
792 BOOL PreTranslateFrameMessage(MSG* pMsg);
793
806 BOOL OnFrameWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
807
814 virtual void ContextMenu(CXTPToolBar* pToolBar, CPoint point);
815
822 virtual CXTPPopupBar* GetToolbarsPopup();
823
830 virtual void GetHiddenControls(CXTPToolBar* pToolBar, CXTPCommandBar* pExpandBar);
831
838 virtual void GetAddOrRemovePopup(CXTPToolBar* pToolBar, CXTPCommandBar* pExpandBar);
839
845 void SetSite(CWnd* pFrame);
846
855 CXTPDockBar* CanDock(CPoint pt, CXTPDockBar* pMainDock = NULL) const;
856
863 static CXTPCommandBars* AFX_CDECL CreateCommandBars();
864
869 void EnableDocking();
870
877 int GetCount() const;
878
886 CXTPToolBar* GetAt(int nIndex) const;
887
896 BOOL SetToolBarFocus(CXTPToolBar* pCommandBar, BOOL bNext = FALSE);
897
904 BOOL IsCustomizeMode() const;
905
911 void SetCustomizeMode(BOOL bMode);
912
921 BOOL IsQuickCustomizeMode() const;
922
930 void SetQuickCustomizeMode(BOOL bMode);
931
939 CXTPCustomizeDropSource* GetDropSource() const;
940
946 void SetDragControl(CCmdTarget* pControl);
947
954 CCmdTarget* GetDragControl() const;
955
962 BOOL IsCustomizeAvail() const;
963
969 void EnableCustomization(BOOL bCustomizeAvail);
970
976 void Remove(CXTPToolBar* pToolBar);
977
982 void RemoveAll();
983
994 BOOL DockCommandBar(CXTPToolBar* pBar, LPRECT lpRect, CXTPDockBar* pDockBar);
995
1005 BOOL DockCommandBar(CXTPToolBar* pBar, XTPBarPosition barPosition);
1006
1012 void SetPaintManager(CXTPPaintManager* pPaintManager);
1013
1019 void SetTheme(XTPPaintTheme paintTheme);
1020
1026 void SetImageManager(CXTPImageManager* pImageManager);
1027
1035 CXTPPaintManager* GetPaintManager() const;
1036
1044 CXTPImageManager* GetImageManager() const;
1045
1051 void ToggleVisible(int nIndex);
1052
1076 void SetCustomizationDataFileName(LPCTSTR lpszFile);
1077
1084 void EnableDefaultResetCustomizedToolbarChoice(BOOL bEnable, BOOL bDefaultYes);
1085
1092 CXTPReBar* GetFrameReBar() const;
1093
1118 static void AFX_CDECL SetToolBarClass(CRuntimeClass* pToolBarClass);
1119
1126 static void AFX_CDECL SetDockBarClass(CRuntimeClass* pDockBarClass);
1127
1134 static void AFX_CDECL SetMenuBarClass(CRuntimeClass* pMenuBarClass);
1135
1141 static void AFX_CDECL SetMenuTitleBarClass(CRuntimeClass* pMenuTitleBarClass);
1142
1149 static void AFX_CDECL SetPopupBarClass(CRuntimeClass* pPopupBarClass);
1150
1157 static void AFX_CDECL SetPopupToolBarClass(CRuntimeClass* pPopupToolBarClass);
1158
1165 CXTPToolTipContext* GetToolTipContext() const;
1166
1174 int FindIndex(CXTPToolBar* pToolBar) const;
1175
1180 void ClosePopups() const;
1181
1188 CXTPStatusBar* GetStatusBar() const;
1189
1190protected:
1198 BOOL FloatCommandBar(CXTPToolBar* pBar);
1199
1207 void GetDockState(CXTPDockState& state);
1208
1215 void SetDockState(CXTPDockState& state);
1216
1222 virtual void OnToolBarAdded(CXTPToolBar* pToolBar);
1223
1229 virtual void OnToolBarRemoved(CXTPToolBar* pToolBar);
1230
1231public:
1243 virtual CXTPToolBar* AddCustomBar(LPCTSTR lpcstrCaption, UINT nID, BOOL bTearOffBar = FALSE);
1244
1251 virtual void OnTrackingModeChanged(CXTPCommandBar* pCommandBar, int bMode);
1252
1261 CXTPMouseManager* GetMouseManager() const;
1262
1271 CXTPKeyboardManager* GetKeyboardManager() const;
1272
1280 BOOL OnFrameAccel(UINT chAccel);
1281
1290 int GetHelpTrackingId() const;
1291
1297 void ShowKeyboardCues(BOOL bShow);
1298
1304 CXTPControlActions* GetActions() const;
1305
1311 void EnableActions(BOOL bEnableActions = TRUE);
1312
1319 BOOL IsActionsEnabled() const;
1320
1327 CXTPControlAction* CreateAction(int nId);
1328
1335 CXTPControlAction* FindAction(int nId) const;
1336
1345 void EnableFrameTheme(BOOL bEnable = TRUE);
1346
1355 BOOL IsEnableFrameTheme();
1356
1365 void EnableToolbarComposition(BOOL bEnable = TRUE);
1366
1374 CXTPCommandBarsFrameHook* GetFrameHook() const;
1375
1383 void SetFrameHook(CXTPCommandBarsFrameHook* pFrameHook);
1384
1391 BOOL IsDwmEnabled() const;
1392
1398 void SetFontHeight(int nFontHeight);
1399
1406 int GetFontHeight() const;
1407
1408protected:
1410 // Implementation of Command Bars
1411 virtual BOOL SaveCommandBarList(CXTPPropExchange* pPX, CXTPCommandBarList* pCommandBarList);
1412 virtual BOOL LoadCommandBarList(CXTPPropExchange* pPX, CXTPCommandBarList* pCommandBarList);
1413 virtual void GenerateCommandBarList(CXTPCommandBarList* pCommandBarList,
1414 XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam);
1415 virtual void RestoreCommandBarList(CXTPCommandBarList* pCommandBarList, BOOL bSilent = FALSE);
1416 void SerializeCommandBars(CArchive& ar);
1417 void SaveDockBarsState(LPCTSTR lpszProfileName);
1418 void LoadDockBarsState(LPCTSTR lpszProfileName);
1419 void SerializeDockBarsState(CXTPPropExchange* pPX);
1420 void _GetAddOrRemovePopup(CXTPToolBar* pToolBar, CXTPCommandBar* pExpandBar);
1421 void _LoadControlsPart(CFile& file, XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam);
1422 BOOL GetControlsFileName(CString& strFileName, LPCTSTR lpszProfileName);
1423 CDocTemplate* FindDocTemplate(CMDIChildWnd* pChild);
1424 void DelayRedrawCommandBars();
1425 int GetNextVisible(long nIndex, int nDirection) const;
1426 CXTPControl* FindAccel(CXTPCommandBar* pCommandBar, UINT chAccel, BOOL& bSelectOnly) const;
1427 CXTPControl* _GetNextControl(CXTPControls*& pControls, int nIndex) const;
1428 void IdleRecalcLayout();
1429 void SetLayoutRTL(CWnd* pWnd, BOOL bRTLLayout);
1430 CString GetIsolatedFileName(const CString& strPrifileName);
1431
1434private:
1435 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
1436 XTPApplicationAmbientProperty nProperty);
1437
1438public:
1439 CXTPControls* m_pDesignerControls;
1440 BOOL m_bIgnoreShiftMenuKey;
1441 BOOL m_bDesignerMode;
1447 struct KEYBOARDTIPS
1448 {
1449 CArray<CXTPCommandBarKeyboardTip*, CXTPCommandBarKeyboardTip*> arr;
1452 CXTPCommandBar* pBar; // Owner of keyboard tips
1453 int nLevel;
1454 int nKey;
1455 } m_keyboardTips;
1456
1465 void ShowKeyboardTips(CXTPCommandBar* pCommandBar, int nLevel = 1);
1466
1473 void HideKeyboardTips();
1474
1482 virtual void CreateKeyboardTips(CXTPCommandBar* pCommandBar);
1483
1484protected:
1485 CXTPCustomizeDropSource* m_pDropSource;
1487 CXTPPaintManager* m_pPaintManager;
1488 CXTPImageManager* m_pImageManager;
1490 CCmdTarget* m_pDragSelected;
1491 int m_nDefaultMenuID;
1493 BOOL m_bCustomizeMode;
1494 BOOL m_bCustomizeAvail;
1495 BOOL m_bEnableActions;
1496 BOOL m_bQuickCustomizeMode;
1497 BOOL m_bDefaultResetCustomizedToolbarChoiceEnabled;
1498 BOOL m_bDefaultResetCustomizedToolbarChoice;
1500 CString m_strControlsFileName;
1502 CXTPCommandBarsOptions* m_pOptions;
1504 CXTPCommandBarsContextMenus* m_pContextMenus;
1506 CArray<CXTPToolBar*, CXTPToolBar*> m_arrBars;
1507 CXTPDockBar* m_pDocks[4];
1508 CWnd* m_pFrame;
1509 CXTPToolTipContext* m_pToolTipContext;
1511 mutable CXTPMouseManager* m_pMouseManager;
1512 mutable CXTPKeyboardManager* m_pKeyboardManager;
1514 static CRuntimeClass* m_pToolBarClass;
1515 static CRuntimeClass* m_pMenuBarClass;
1516 static CRuntimeClass* m_pMenuTitleBarClass;
1517 static CRuntimeClass* m_pPopupBarClass;
1518 static CRuntimeClass* m_pPopupToolBarClass;
1519 static CRuntimeClass* m_pDockBarClass;
1520 BOOL m_bKeyboardCuesVisible;
1521 CXTPShortcutManager* m_pShortcutManager;
1523 int m_nIDHelpTracking;
1525 CXTPControlActions* m_pActions;
1527 CXTPCommandBarsFrameHook* m_pFrameHook;
1528 BOOL m_bInternalFrameHook;
1530# ifdef _XTP_COMMANDBARS_ACTIVEX
1531public:
1532 CXTPRecentFileList* m_pRecentFileList;
1533# endif
1534
1535private:
1536 BOOL m_bRecalcLayout;
1537 BOOL m_bUseKeyboardCues;
1538 BOOL m_bAllCaps;
1539 BOOL m_bRightToLeft;
1540 BOOL m_bPreviewMode;
1541 BOOL m_bBeingDestructed;
1543 static const UINT m_nRedrawMsg;
1544
1545private:
1546 DECLARE_DYNCREATE(CXTPCommandBars)
1547
1548 friend class CXTPCommandBar;
1549 friend class CXTPToolBar;
1550 friend class CXTPDockContext;
1551 friend class CXTPDockState;
1552 friend class CXTPDockBar;
1553 friend class CXTPControlToolbars;
1554 friend class CXTPControl;
1555 friend class CCommandBarsCtrl;
1556 friend class CXTPCustomizeToolbarsPage;
1557 friend class CXTPPopupBar;
1558 friend class CXTPPopupToolBar;
1559 friend class CXTPMenuBar;
1560 friend class CXTPCommandBarsOptions;
1561 friend class CCommandBarsSite;
1562 friend class CXTPDialogEx;
1563# if (_MSC_VER > 1200)
1564 friend class CXTPDHtmlDialogEx;
1565# endif
1566 friend class CXTPRibbonBar;
1567};
1568
1570
1571AFX_INLINE BOOL CXTPCommandBars::IsAllCaps() const
1572{
1573 return m_bAllCaps;
1574}
1575
1576AFX_INLINE void CXTPCommandBars::SetAllCaps(BOOL bAllCaps)
1577{
1578 m_bAllCaps = bAllCaps;
1579}
1580
1581AFX_INLINE CWnd* CXTPCommandBars::GetSite() const
1582{
1583 return m_pFrame;
1584}
1585
1586AFX_INLINE CXTPDockBar* CXTPCommandBars::GetDockBar(XTPBarPosition barPosition) const
1587{
1588 _ASSERTE(barPosition >= 0 && barPosition < 4);
1589 return barPosition >= 0 && barPosition < 4 ? m_pDocks[barPosition] : NULL;
1590}
1591
1592AFX_INLINE int CXTPCommandBars::GetCount() const
1593{
1594 return (int)m_arrBars.GetSize();
1595}
1596
1597AFX_INLINE CXTPCustomizeDropSource* CXTPCommandBars::GetDropSource() const
1598{
1599 return m_pDropSource;
1600}
1601
1602AFX_INLINE BOOL CXTPCommandBars::IsCustomizeAvail() const
1603{
1604 return m_bCustomizeAvail;
1605}
1606
1607AFX_INLINE void CXTPCommandBars::EnableCustomization(BOOL bCustomizeAvail)
1608{
1609 m_bCustomizeAvail = bCustomizeAvail;
1610}
1611
1612AFX_INLINE CXTPCommandBarsOptions* CXTPCommandBars::GetCommandBarsOptions() const
1613{
1614 return m_pOptions;
1615}
1616
1617AFX_INLINE void CXTPCommandBars::SetCustomizationDataFileName(LPCTSTR lpszFile)
1618{
1619 m_strControlsFileName = lpszFile;
1620}
1621
1622AFX_INLINE void CXTPCommandBars::EnableDefaultResetCustomizedToolbarChoice(BOOL bEnable,
1623 BOOL bDefaultYes)
1624{
1625 m_bDefaultResetCustomizedToolbarChoiceEnabled = bEnable;
1626 m_bDefaultResetCustomizedToolbarChoice = bDefaultYes;
1627}
1628
1629AFX_INLINE void CXTPCommandBars::SetToolBarClass(CRuntimeClass* pToolBarClass)
1630{
1631 m_pToolBarClass = pToolBarClass;
1632}
1633
1634AFX_INLINE void CXTPCommandBars::SetMenuBarClass(CRuntimeClass* pMenuBarClass)
1635{
1636 m_pMenuBarClass = pMenuBarClass;
1637}
1638
1639AFX_INLINE void CXTPCommandBars::SetMenuTitleBarClass(CRuntimeClass* pMenuTitleBarClass)
1640{
1641 m_pMenuTitleBarClass = pMenuTitleBarClass;
1642}
1643
1644AFX_INLINE void CXTPCommandBars::SetDockBarClass(CRuntimeClass* pDockBarClass)
1645{
1646 m_pDockBarClass = pDockBarClass;
1647}
1648
1649AFX_INLINE void CXTPCommandBars::SetPopupBarClass(CRuntimeClass* pPopupBarClass)
1650{
1651 m_pPopupBarClass = pPopupBarClass;
1652}
1653
1654AFX_INLINE void CXTPCommandBars::SetPopupToolBarClass(CRuntimeClass* pPopupToolBarClass)
1655{
1656 m_pPopupToolBarClass = pPopupToolBarClass;
1657}
1658
1659AFX_INLINE int CXTPCommandBars::GetHelpTrackingId() const
1660{
1661 return m_nIDHelpTracking;
1662}
1663
1664AFX_INLINE CXTPControlActions* CXTPCommandBars::GetActions() const
1665{
1666 return m_pActions;
1667}
1668
1669AFX_INLINE BOOL CXTPCommandBars::IsActionsEnabled() const
1670{
1671 return this == NULL ? FALSE : m_bEnableActions;
1672}
1673
1674AFX_INLINE CXTPCommandBarsContextMenus* CXTPCommandBars::GetContextMenus() const
1675{
1676 return m_pContextMenus;
1677}
1678
1679AFX_INLINE CXTPCommandBarsFrameHook* CXTPCommandBars::GetFrameHook() const
1680{
1681 return m_pFrameHook;
1682}
1683
1684AFX_INLINE void CXTPCommandBars::SetFrameHook(CXTPCommandBarsFrameHook* pFrameHook)
1685{
1686 m_pFrameHook = pFrameHook;
1687 if (NULL == m_pFrameHook)
1688 m_bInternalFrameHook = FALSE;
1689}
1690
1691AFX_INLINE BOOL CXTPCommandBars::IsQuickCustomizeMode() const
1692{
1693 return m_bQuickCustomizeMode;
1694}
1695
1696AFX_INLINE BOOL CXTPCommandBars::IsCustomizeMode() const
1697{
1698 return m_bCustomizeMode;
1699}
1701# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1702#endif //#if !defined(__XTPCOMMANDBARS_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPControlType
XTPControlType
Type of the control.
Definition XTPCommandBarsDefines.h:111
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.
Definition XTPCommandBarKeyboardTip.h:41
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBarsContextMenus
CXTPCommandBarsContextMenus is CXTPCommandBarList derived class which represents a collection of cont...
Definition XTPCommandBarsContextMenus.h:39
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBars::GetFrameReBar
CXTPReBar * GetFrameReBar() const
This method finds the rebar of the frame.
CXTPCommandBars::SetMenu
CXTPMenuBar * SetMenu(LPCTSTR lpszName, UINT nID)
Call this member to create a menu bar.
CXTPCommandBars::m_bKeyboardCuesVisible
BOOL m_bKeyboardCuesVisible
TRUE if menu underlines is currently visible.
Definition XTPCommandBars.h:1520
CXTPCommandBars::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
CXTPCommandBars::DockCommandBar
BOOL DockCommandBar(CXTPToolBar *pBar, LPRECT lpRect, CXTPDockBar *pDockBar)
Call this member to dock a toolbar to the specified dockbar.
CXTPCommandBars::SetPopupBarClass
static void AFX_CDECL SetPopupBarClass(CRuntimeClass *pPopupBarClass)
Call this method to set the default pop-up bar class.
Definition XTPCommandBars.h:1649
CXTPCommandBars::GetCount
int GetCount() const
Call this member to get the toolbar count.
Definition XTPCommandBars.h:1592
CXTPCommandBars::EnableActions
void EnableActions(BOOL bEnableActions=TRUE)
Call this method to let command bars automatically add actions for new commands.
CXTPCommandBars::TrackPopupMenu
static BOOL AFX_CDECL TrackPopupMenu(CMenu *pMenu, UINT nFlags, int xPos, int yPos, CWnd *pWnd, LPCRECT rcExclude=NULL, CWnd *pWndOwner=NULL, CXTPCommandBars *pCommandBars=NULL)
Call this member to display a floating pop-up menu at the specified location.
CXTPCommandBars::GetHiddenControls
virtual void GetHiddenControls(CXTPToolBar *pToolBar, CXTPCommandBar *pExpandBar)
Call this method to create an expand bar.
CXTPCommandBars::HideKeyboardTips
void HideKeyboardTips()
Removes all keyboard tips.
CXTPCommandBars::GetToolBar
CXTPToolBar * GetToolBar(UINT nID) const
Call this member to get the toolbar with the specified identifier.
CXTPCommandBars::m_pMouseManager
CXTPMouseManager * m_pMouseManager
Mouse manager of command bars.
Definition XTPCommandBars.h:1511
CXTPCommandBars::EnableDefaultResetCustomizedToolbarChoice
void EnableDefaultResetCustomizedToolbarChoice(BOOL bEnable, BOOL bDefaultYes)
Enables/disables the default choice for the Reset Customized Toolbar message.
Definition XTPCommandBars.h:1622
CXTPCommandBars::IsActionsEnabled
BOOL IsActionsEnabled() const
Determines if the EnableActions method was called.
Definition XTPCommandBars.h:1669
CXTPCommandBars::m_bCustomizeMode
BOOL m_bCustomizeMode
Customize mode.
Definition XTPCommandBars.h:1493
CXTPCommandBars::RedrawCommandBars
void RedrawCommandBars()
Call this member to redraw the command bars.
CXTPCommandBars::GetFrameHook
CXTPCommandBarsFrameHook * GetFrameHook() const
Gets the CXTPCommandBarsFrameHook hook window used to skin the frame.
Definition XTPCommandBars.h:1679
CXTPCommandBars::FindControl
CXTPControl * FindControl(XTPControlType type, UINT nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
CXTPCommandBars::LoadBarState
void LoadBarState(LPCTSTR lpszProfileName, BOOL bSilent=FALSE)
Call this function to retrieve state information from the registry or .INI file.
CXTPCommandBars::m_bEnableActions
BOOL m_bEnableActions
True if actions was enabled.
Definition XTPCommandBars.h:1495
CXTPCommandBars::~CXTPCommandBars
virtual ~CXTPCommandBars()
Destroys a CXTPCommandBars object, handles cleanup and deallocation.
CXTPCommandBars::m_nIDHelpTracking
int m_nIDHelpTracking
Selected control.
Definition XTPCommandBars.h:1523
CXTPCommandBars::ToggleVisible
void ToggleVisible(int nIndex)
Call this member to show/hide the toolbar.
CXTPCommandBars::ShowKeyboardTips
void ShowKeyboardTips(CXTPCommandBar *pCommandBar, int nLevel=1)
This method is called to show keyboard tips for the commandbar.
CXTPCommandBars::m_arrBars
CArray< CXTPToolBar *, CXTPToolBar * > m_arrBars
Toolbars list.
Definition XTPCommandBars.h:1506
CXTPCommandBars::ClosePopups
void ClosePopups() const
Call this member to close all pop-up windows.
CXTPCommandBars::ResetUsageData
void ResetUsageData()
Call this member function to restore the state of the hidden commands.
CXTPCommandBars::GetPaintManager
CXTPPaintManager * GetPaintManager() const
Call this member to retrieve the paint manager of the command bars.
CXTPCommandBars::m_pDesignerControls
CXTPControls * m_pDesignerControls
Designer controls if used.
Definition XTPCommandBars.h:1439
CXTPCommandBars::m_nDefaultMenuID
int m_nDefaultMenuID
Default menu resource.
Definition XTPCommandBars.h:1491
CXTPCommandBars::LoadDesignerBars
void LoadDesignerBars(CXTPPropExchange *pPX)
Call this member function to load designer command bars from an archive.
CXTPCommandBars::SetPopupToolBarClass
static void AFX_CDECL SetPopupToolBarClass(CRuntimeClass *pPopupToolBarClass)
Call this method to set the default pop-up toolbar class.
Definition XTPCommandBars.h:1654
CXTPCommandBars::OnToolBarRemoved
virtual void OnToolBarRemoved(CXTPToolBar *pToolBar)
This method is called when a toolbar is removed.
CXTPCommandBars::EnableFrameTheme
void EnableFrameTheme(BOOL bEnable=TRUE)
Call this method to enable/disable Office 2007 frame.
CXTPCommandBars::FindIndex
int FindIndex(CXTPToolBar *pToolBar) const
Call this member to find the index of the specified toolbar.
CXTPCommandBars::m_pMenuTitleBarClass
static CRuntimeClass * m_pMenuTitleBarClass
Default menu titlebar class.
Definition XTPCommandBars.h:1516
CXTPCommandBars::SetDockState
void SetDockState(CXTPDockState &state)
Call this member function to apply state information stored in a CXTPDockState object to the frame wi...
CXTPCommandBars::ShowKeyboardCues
void ShowKeyboardCues(BOOL bShow)
This method is called to show the keyboard cues of controls.
CXTPCommandBars::m_pMenuBarClass
static CRuntimeClass * m_pMenuBarClass
Default menubar class.
Definition XTPCommandBars.h:1515
CXTPCommandBars::GetToolbarsPopup
virtual CXTPPopupBar * GetToolbarsPopup()
This method creates a context menu for toolbars.
CXTPCommandBars::IsLayoutRTL
BOOL IsLayoutRTL() const
Determines if right-to-left (RTL) mode is set.
CXTPCommandBars::SetDockBarClass
static void AFX_CDECL SetDockBarClass(CRuntimeClass *pDockBarClass)
Call this method to set the default dock bar class.
Definition XTPCommandBars.h:1644
CXTPCommandBars::m_bCustomizeAvail
BOOL m_bCustomizeAvail
TRUE if customize available.
Definition XTPCommandBars.h:1494
CXTPCommandBars::CreateKeyboardTips
virtual void CreateKeyboardTips(CXTPCommandBar *pCommandBar)
This method is called to create a keyboard tips collection for command bar.
CXTPCommandBars::GetMenuTitleBar
CXTPMenuTitleBar * GetMenuTitleBar() const
Call this member to get the title menu bar.
CXTPCommandBars::GetActiveDocTemplate
virtual UINT GetActiveDocTemplate()
Retrieves the active MDI document template.
CXTPCommandBars::RecalcFrameLayout
virtual void RecalcFrameLayout(BOOL bDelay=FALSE)
Call this member to recalculate site layout.
CXTPCommandBars::m_pFrame
CWnd * m_pFrame
Parent frame of command bars.
Definition XTPCommandBars.h:1508
CXTPCommandBars::UpdateCommandBars
void UpdateCommandBars() const
Sends WM_IDLEUPDATECMDUI message to all tool bars.
CXTPCommandBars::SetCustomizeMode
void SetCustomizeMode(BOOL bMode)
Call this member to set command bars to customize mode.
CXTPCommandBars::m_pPaintManager
CXTPPaintManager * m_pPaintManager
Paint manager.
Definition XTPCommandBars.h:1487
CXTPCommandBars::LoadOptions
void LoadOptions(LPCTSTR lpszProfileName)
Call this function to restore the options of the command bars.
CXTPCommandBars::GetDropSource
CXTPCustomizeDropSource * GetDropSource() const
Call this member to retrieve the CXTPCustomizeDropSource helper class for customization.
Definition XTPCommandBars.h:1597
CXTPCommandBars::GetHelpTrackingId
int GetHelpTrackingId() const
Determines the Help identifier of a control under the mouse cursor.
Definition XTPCommandBars.h:1659
CXTPCommandBars::m_pShortcutManager
CXTPShortcutManager * m_pShortcutManager
Shortcut Manager of command bars.
Definition XTPCommandBars.h:1521
CXTPCommandBars::OnFrameAccel
BOOL OnFrameAccel(UINT chAccel)
This method is called when the user press Alt + char.
CXTPCommandBars::SetFontHeight
void SetFontHeight(int nFontHeight)
Call this method to set a custom font height for command bars.
CXTPCommandBars::m_pPopupBarClass
static CRuntimeClass * m_pPopupBarClass
Default pop-up bar class.
Definition XTPCommandBars.h:1517
CXTPCommandBars::OnFrameWndMsg
BOOL OnFrameWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult)
Call this method to process frame messages.
CXTPCommandBars::CanDock
CXTPDockBar * CanDock(CPoint pt, CXTPDockBar *pMainDock=NULL) const
Call this member to retrieve the dock bar at the specified point.
CXTPCommandBars::m_bInternalFrameHook
BOOL m_bInternalFrameHook
TRUE if frame hook object is owned internally.
Definition XTPCommandBars.h:1528
CXTPCommandBars::GetSite
CWnd * GetSite() const
Call this member to get the site of the command bars.
Definition XTPCommandBars.h:1581
CXTPCommandBars::IsQuickCustomizeMode
BOOL IsQuickCustomizeMode() const
Call this member to check if command bars are in quick customize mode.
Definition XTPCommandBars.h:1691
CXTPCommandBars::Add
CXTPToolBar * Add(CXTPToolBar *pToolBar, LPCTSTR strName, XTPBarPosition nBarPosition)
Call this member to add a new toolbar.
CXTPCommandBars::IsCommandHidden
virtual BOOL IsCommandHidden(UINT nCommand)
Call this member function to retrieve if the command is hidden until activated by clicking on the che...
CXTPCommandBars::IsControlHidden
virtual BOOL IsControlHidden(CXTPControl *pControl)
Call this member function to retrieve if the control is hidden and of type CXTPControlPopup when bAut...
CXTPCommandBars::IsCustomizeAvail
BOOL IsCustomizeAvail() const
Call this member to retrieve if the customize is avail.
Definition XTPCommandBars.h:1602
CXTPCommandBars::GetContextMenus
CXTPCommandBarsContextMenus * GetContextMenus() const
Retrieves list of available context menus.
Definition XTPCommandBars.h:1674
CXTPCommandBars::EnableToolbarComposition
void EnableToolbarComposition(BOOL bEnable=TRUE)
Call this method to enable Office 2007 frame and toolbar composition.
CXTPCommandBars::GetShortcutManager
CXTPShortcutManager * GetShortcutManager() const
Call this function to get the ShortcutManager class pointer.
CXTPCommandBars::Add
CXTPToolBar * Add(LPCTSTR lpszName, XTPBarPosition nBarPosition, CRuntimeClass *pToolbarClass=NULL)
Call this member to add a new toolbar.
CXTPCommandBars::m_pImageManager
CXTPImageManager * m_pImageManager
Image manager.
Definition XTPCommandBars.h:1488
CXTPCommandBars::SerializeBarState
void SerializeBarState(CArchive &ar, BOOL bSerializeControls=FALSE, BOOL bOnlyCustomized=TRUE, BOOL bSilent=FALSE)
Call this function to either read command bars from or write command bars to an archive.
CXTPCommandBars::DockCommandBar
BOOL DockCommandBar(CXTPToolBar *pBar, XTPBarPosition barPosition)
Call this member to dock a toolbar to the specified dockbar.
CXTPCommandBars::GetCommandBarsOptions
CXTPCommandBarsOptions * GetCommandBarsOptions() const
Call this member to retrieve the options of the command bars.
Definition XTPCommandBars.h:1612
CXTPCommandBars::TrackPopupMenu
static BOOL AFX_CDECL TrackPopupMenu(CXTPPopupBar *pPopupBar, UINT nFlags, int xPos, int yPos, CWnd *pWnd, LPCRECT rcExclude=NULL, CWnd *pWndOwner=NULL)
Call this member to display a floating pop-up menu at the specified location.
CXTPCommandBars::m_pToolTipContext
CXTPToolTipContext * m_pToolTipContext
Tooltip Context.
Definition XTPCommandBars.h:1509
CXTPCommandBars::PreTranslateFrameMessage
BOOL PreTranslateFrameMessage(MSG *pMsg)
Call this method to process frame messages.
CXTPCommandBars::IsEnableFrameTheme
BOOL IsEnableFrameTheme()
Call this method to check if Office 2007 frame is enabled.
CXTPCommandBars::SaveOptions
void SaveOptions(LPCTSTR lpszProfileName)
Call this function to save the command bars options.
CXTPCommandBars::m_pOptions
CXTPCommandBarsOptions * m_pOptions
Command bars' options.
Definition XTPCommandBars.h:1502
CXTPCommandBars::m_bQuickCustomizeMode
BOOL m_bQuickCustomizeMode
TRUE if command bars in quick customization mode.
Definition XTPCommandBars.h:1496
CXTPCommandBars::SetCustomizationDataFileName
void SetCustomizationDataFileName(LPCTSTR lpszFile)
Call this method to set the customization file path.
Definition XTPCommandBars.h:1617
CXTPCommandBars::GetStatusBar
CXTPStatusBar * GetStatusBar() const
Call this member to get a reference to the status bar object.
CXTPCommandBars::SetToolBarFocus
BOOL SetToolBarFocus(CXTPToolBar *pCommandBar, BOOL bNext=FALSE)
This method is called to activate a toolbar.
CXTPCommandBars::GetKeyboardManager
CXTPKeyboardManager * GetKeyboardManager() const
Call this method to get the GetKeyboardManager pointer for command bars.
CXTPCommandBars::GetMenuBar
virtual CXTPMenuBar * GetMenuBar() const
Call this member to get the active menu bar.
CXTPCommandBars::RemoveAll
void RemoveAll()
Call this member to remove all toolbars.
CXTPCommandBars::TrackPopupMenu
BOOL TrackPopupMenu(UINT nBarID, UINT nFlags, int xPos, int yPos, LPCRECT rcExclude=NULL)
Call this member to display a floating pop-up menu at the specified location.
CXTPCommandBars::GetFontHeight
int GetFontHeight() const
Call this method to get the font height used for Ribbon Bar.
CXTPCommandBars::TrackPopupMenuEx
BOOL TrackPopupMenuEx(CMenu *pMenu, UINT nFlags, int xPos, int yPos, CWnd *pWndOwner=NULL, LPTPMPARAMS lptpm=NULL)
Call this member to display a floating pop-up menu at the specified location.
CXTPCommandBars::HideCommand
void HideCommand(UINT nCommand)
This member function adds the specified command to the list of menu items to hide until activated by ...
CXTPCommandBars::EnableDocking
void EnableDocking()
This member is called to create dock bars.
CXTPCommandBars::CreateCommandBars
static CXTPCommandBars *AFX_CDECL CreateCommandBars()
This member creates command bars.
CXTPCommandBars::m_strControlsFileName
CString m_strControlsFileName
File name to be used to store user customization.
Definition XTPCommandBars.h:1500
CXTPCommandBars::m_pDragSelected
CCmdTarget * m_pDragSelected
Customize control.
Definition XTPCommandBars.h:1490
CXTPCommandBars::GetAt
CXTPToolBar * GetAt(int nIndex) const
Call this member to retrieve a toolbar with a specified index.
CXTPCommandBars::m_bDefaultResetCustomizedToolbarChoice
BOOL m_bDefaultResetCustomizedToolbarChoice
TRUE if default choice is Yes.
Definition XTPCommandBars.h:1498
CXTPCommandBars::LoadDesignerBars
void LoadDesignerBars(CArchive &ar, UINT nSchemaVersion=_XTP_SCHEMA_CURRENT)
Call this member function to load designer command bars from an archive.
CXTPCommandBars::InvalidateCommandBars
void InvalidateCommandBars()
Call this member to invalidate the command bars.
CXTPCommandBars::OnSetPreviewMode
void OnSetPreviewMode(BOOL bPreview)
Call this member function to set the application's command bars into and out of print-preview mode.
CXTPCommandBars::SetPaintManager
void SetPaintManager(CXTPPaintManager *pPaintManager)
Call this member to set the specified paint manager.
CXTPCommandBars::GetAddOrRemovePopup
virtual void GetAddOrRemovePopup(CXTPToolBar *pToolBar, CXTPCommandBar *pExpandBar)
Call this method to create customized controls.
CXTPCommandBars::m_pDocks
CXTPDockBar * m_pDocks[4]
DockBars list.
Definition XTPCommandBars.h:1507
CXTPCommandBars::OnTrackingModeChanged
virtual void OnTrackingModeChanged(CXTPCommandBar *pCommandBar, int bMode)
This method is called when the tracking mode of a command bar changes.
CXTPCommandBars::GetImageManager
CXTPImageManager * GetImageManager() const
Call this member to retrieve the image manager of the command bars.
CXTPCommandBars::SetDragControl
void SetDragControl(CCmdTarget *pControl)
This member is called when the customized control changes.
CXTPCommandBars::GetDockBar
CXTPDockBar * GetDockBar(XTPBarPosition barPosition) const
Call this member to get the dock bar at the specified position.
Definition XTPCommandBars.h:1586
CXTPCommandBars::m_pPopupToolBarClass
static CRuntimeClass * m_pPopupToolBarClass
Default pop-up bar class.
Definition XTPCommandBars.h:1518
CXTPCommandBars::SetQuickCustomizeMode
void SetQuickCustomizeMode(BOOL bMode)
Call this member to set command bars to quick customize mode.
CXTPCommandBars::SetTheme
void SetTheme(XTPPaintTheme paintTheme)
Call this member to set the specified paint manager.
CXTPCommandBars::GetMouseManager
CXTPMouseManager * GetMouseManager() const
Call this method to get the CXTPMouseManager pointer for command bars.
CXTPCommandBars::m_pDropSource
CXTPCustomizeDropSource * m_pDropSource
Customize helper class.
Definition XTPCommandBars.h:1485
CXTPCommandBars::m_pKeyboardManager
CXTPKeyboardManager * m_pKeyboardManager
Keyboard manager of command bars.
Definition XTPCommandBars.h:1512
CXTPCommandBars::SetLayoutRTL
void SetLayoutRTL(BOOL bRightToLeft)
Specifies if right-to-left (RTL) mode should be set.
CXTPCommandBars::Remove
void Remove(CXTPToolBar *pToolBar)
Call this member to remove the toolbar.
CXTPCommandBars::CXTPCommandBars
CXTPCommandBars()
Constructs a CXTPCommandBars object.
CXTPCommandBars::m_pToolBarClass
static CRuntimeClass * m_pToolBarClass
Default toolbar class.
Definition XTPCommandBars.h:1514
CXTPCommandBars::FloatCommandBar
BOOL FloatCommandBar(CXTPToolBar *pBar)
Call this member function to float a CXTPToolBar.
CXTPCommandBars::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam=NULL)
Either reads this object from or writes this object to storage.
CXTPCommandBars::SetSite
void SetSite(CWnd *pFrame)
This method is called to set the site window.
CXTPCommandBars::OnToolBarAdded
virtual void OnToolBarAdded(CXTPToolBar *pToolBar)
This method is called when a toolbar is added.
CXTPCommandBars::GetDockState
void GetDockState(CXTPDockState &state)
Call this member function to store state information about the frame window's control bars in a CXTPD...
CXTPCommandBars::SetFrameHook
void SetFrameHook(CXTPCommandBarsFrameHook *pFrameHook)
Sets the CXTPCommandBarsFrameHook hook window used to skin the frame.
Definition XTPCommandBars.h:1684
CXTPCommandBars::GetDragControl
CCmdTarget * GetDragControl() const
Call this member to retrieve the current customized control.
CXTPCommandBars::SetMenuTitleBar
CXTPMenuTitleBar * SetMenuTitleBar(LPCTSTR strName, UINT nID, INT nIconID=-1)
Call this member to create a title menu bar.
CXTPCommandBars::SetMenuBarClass
static void AFX_CDECL SetMenuBarClass(CRuntimeClass *pMenuBarClass)
Call this method to set the default menu bar class.
Definition XTPCommandBars.h:1634
CXTPCommandBars::HideCommands
void HideCommands(const UINT *pCommands, int nCount)
This member function adds the specified commands to the list of menu items to hide until activated by...
CXTPCommandBars::m_bDefaultResetCustomizedToolbarChoiceEnabled
BOOL m_bDefaultResetCustomizedToolbarChoiceEnabled
TRUE if default choice is enabled.
Definition XTPCommandBars.h:1497
CXTPCommandBars::SetAllCaps
void SetAllCaps(BOOL bAllCaps)
Sets an all-caps flag value that causes command bars to draw all titles uppercase if the flag is set.
Definition XTPCommandBars.h:1576
CXTPCommandBars::m_pDockBarClass
static CRuntimeClass * m_pDockBarClass
Default dockbar class.
Definition XTPCommandBars.h:1519
CXTPCommandBars::CreateAction
CXTPControlAction * CreateAction(int nId)
Call this method to create a new action for a specified ID.
CXTPCommandBars::IsCustomizeMode
BOOL IsCustomizeMode() const
Call this member to check if command bars are in customize mode.
Definition XTPCommandBars.h:1696
CXTPCommandBars::m_pFrameHook
CXTPCommandBarsFrameHook * m_pFrameHook
Frame hook pointer for enabled frame theme.
Definition XTPCommandBars.h:1527
CXTPCommandBars::m_pActions
CXTPControlActions * m_pActions
Actions collection.
Definition XTPCommandBars.h:1525
CXTPCommandBars::SetShortcutManager
void SetShortcutManager(CXTPShortcutManager *pShortcutManager)
Call this function to set a custom shortcut manager class.
CXTPCommandBars::IsAllCaps
BOOL IsAllCaps() const
Gets an all-caps flag value that causes command bars to draw all titles uppercase if the flag is set.
Definition XTPCommandBars.h:1571
CXTPCommandBars::SetCommandUsed
void SetCommandUsed(UINT nCommand)
Call this member function to set the command activated by the user.
CXTPCommandBars::FindAction
CXTPControlAction * FindAction(int nId) const
Call this method to find an action for a specified ID.
CXTPCommandBars::SetMenuTitleBarClass
static void AFX_CDECL SetMenuTitleBarClass(CRuntimeClass *pMenuTitleBarClass)
Call this method to set the default menu bar class.
Definition XTPCommandBars.h:1639
CXTPCommandBars::ContextMenu
virtual void ContextMenu(CXTPToolBar *pToolBar, CPoint point)
This method shows the context menu for toolbars.
CXTPCommandBars::EnableCustomization
void EnableCustomization(BOOL bCustomizeAvail)
Call this member to enable/disable customization.
Definition XTPCommandBars.h:1607
CXTPCommandBars::m_pContextMenus
CXTPCommandBarsContextMenus * m_pContextMenus
Context menu collection.
Definition XTPCommandBars.h:1504
CXTPCommandBars::IsDwmEnabled
BOOL IsDwmEnabled() const
Determines if Vista Glass Effect is enabled for Ribbon Bar.
CXTPCommandBars::SaveBarState
void SaveBarState(LPCTSTR lpszProfileName, BOOL bOnlyCustomized=TRUE)
Call this function to save the state information to the registry or .INI file.
CXTPCommandBars::m_bDesignerMode
BOOL m_bDesignerMode
TRUE if command bars in designer mode.
Definition XTPCommandBars.h:1441
CXTPCommandBars::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Call this member to set the specified image manager.
CXTPCommandBars::SetToolBarClass
static void AFX_CDECL SetToolBarClass(CRuntimeClass *pToolBarClass)
Call this method to set the default toolbar class.
Definition XTPCommandBars.h:1629
CXTPCommandBars::AddCustomBar
virtual CXTPToolBar * AddCustomBar(LPCTSTR lpcstrCaption, UINT nID, BOOL bTearOffBar=FALSE)
This method is called to add a custom toolbar.
CXTPCommandBars::m_bIgnoreShiftMenuKey
BOOL m_bIgnoreShiftMenuKey
if set menus will ignore Shift+Alt key combinations
Definition XTPCommandBars.h:1440
CXTPCommandBars::GetActions
CXTPControlActions * GetActions() const
Call this method to get the actions list for command bars.
Definition XTPCommandBars.h:1664
CXTPCommandBarsOptions
Options of the command bars.
Definition XTPCommandBarsOptions.h:46
CXTPControlAction
CXTPControlAction is a CXTPCmdTarget derived class.
Definition XTPControl.h:53
CXTPControlActions
CXTPControlActions is a CXTPCmdTarget derived class.
Definition XTPControl.h:692
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlToolbars
CXTPControlToolbars is a CXTPControlButton derived class.
Definition XTPControlExt.h:210
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeToolbarsPage
CXTPCustomizeToolbarsPage is a CPropertyPage derived class.
Definition XTPCustomizePageToolbars.h:64
CXTPDialogEx
CXTPDialogEx is a CXTPDialogBase derived class.
Definition Controls/Dialog/XTPDialogBase.h:358
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPDockContext
CXTPDockContext is a standalone class.
Definition XTPDockContext.h:41
CXTPDockState
CXTPDockState is a standalone class.
Definition XTPDockState.h:39
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPKeyboardManager
CXTPKeyboardManager class used to handle keyboard hooks.
Definition XTPKeyboardManager.h:38
CXTPMenuBar
CXTPMenuBar is a CXTPToolBar derived class.
Definition XTPMenuBar.h:141
CXTPMouseManager
CXTPMouseManager is standalone class.
Definition XTPMouseManager.h:41
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPopupToolBar
CXTPPopupToolBar is a CXTPPopupBar derived class.
Definition XTPPopupBar.h:492
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPReBar
The CXTPReBar object extends the standard MFC CReBar class to provide extended functionality such as ...
Definition XTPReBar.h:100
CXTPRecentFileList
CXTPRecentFileList is a CRecentFileList derived class.
Definition XTPRecentFileList.h:88
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPShortcutManager
CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame.
Definition XTPShortcutManager.h:189
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291
CXTPCommandBars::KEYBOARDTIPS
Keyboard tips information.
Definition XTPCommandBars.h:1448
CXTPCommandBars::KEYBOARDTIPS::arr
CArray< CXTPCommandBarKeyboardTip *, CXTPCommandBarKeyboardTip * > arr
Keyboard tips collection.
Definition XTPCommandBars.h:1449
CXTPCommandBars::KEYBOARDTIPS::nLevel
int nLevel
Keyboard tip level (for RibbonBar)
Definition XTPCommandBars.h:1453
CXTPCommandBars::KEYBOARDTIPS::nKey
int nKey
Keys was pressed already.
Definition XTPCommandBars.h:1454
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.
Definition XTPCommandBars.h:88
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSerializeLayout
BOOL bSerializeLayout
If TRUE, the layout of the CommandBars will be saved.
Definition XTPCommandBars.h:137
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSaveOnlyCustomized
BOOL bSaveOnlyCustomized
If TRUE, only CommandBars that have been customized will be saved.
Definition XTPCommandBars.h:122
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSerializeControls
BOOL bSerializeControls
If TRUE, the controls in the CommandBars will be saved.
Definition XTPCommandBars.h:119
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bLoadSilent
BOOL bLoadSilent
If TRUE, no message boxes will be displayed when the CommandBar layout is loaded.
Definition XTPCommandBars.h:124
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSerializeOptions
BOOL bSerializeOptions
If TRUE, the setting on the Keyboard and Options pages of the Customize dialog will be saved.
Definition XTPCommandBars.h:133
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::pCommandBars
CXTPCommandBars * pCommandBars
Pointer to the CommandBars object that the XTP_COMMANDBARS_PROPEXCHANGE_PARAM setting apply to.
Definition XTPCommandBars.h:151
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSerializeDesignerControls
BOOL bSerializeDesignerControls
In the CommandBar Designer you can export a XCB file to a XML file and Load it in your project.
Definition XTPCommandBars.h:140
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSaveOriginalControls
BOOL bSaveOriginalControls
If TRUE, the original state of the CommandBars is saved along with the customized state.
Definition XTPCommandBars.h:127
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSerializeImages
BOOL bSerializeImages
If TRUE, the images stored in the ImageManager will be saved.
Definition XTPCommandBars.h:131
XTP_COMMANDBARS_PROPEXCHANGE_PARAM::bSerializeActions
BOOL bSerializeActions
TRUE to save/restore actions for commandbars.
Definition XTPCommandBars.h:150


CXTPGridHyperlinkStyle Member List

This is the complete list of members for CXTPGridHyperlinkStyle, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridHyperlinkStyle(COLORREF color, XTPGridTextDecoration textDecoration) | CXTPGridHyperlinkStyle |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColor() const | CXTPGridHyperlinkStyle |
GetTextDecoration() const | CXTPGridHyperlinkStyle |
SetColor(COLORREF color) | CXTPGridHyperlinkStyle |
SetTextDecoration(XTPGridTextDecoration textDecoration) | CXTPGridHyperlinkStyle |


CXTPChart3dDiagramView Member List

This is the complete list of members for CXTPChart3dDiagramView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChart3dDiagramView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
CXTPChart3dDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChart3dDiagramView |
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


CXTPPropertyGridNativeXPTheme Member List

This is the complete list of members for CXTPPropertyGridNativeXPTheme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridNativeXPTheme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridNativeXPTheme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridNativeXPTheme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridNativeXPTheme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


CXTPCalendarSchedule Member List

This is the complete list of members for CXTPCalendarSchedule, including all inherited members.

CXTPCalendarSchedule(UINT uScheduleID=0, LPCTSTR pcszScheduleName=_T("")) | CXTPCalendarSchedule |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCustomProperties() const | CXTPCalendarSchedule |
GetID() const | CXTPCalendarSchedule |
GetName() const | CXTPCalendarSchedule |
m_pCustomProperties | CXTPCalendarSchedule | protected
m_strScheduleName | CXTPCalendarSchedule | protected
m_uScheduleID | CXTPCalendarSchedule | protected
SetID(UINT uScheduleID) | CXTPCalendarSchedule |
SetName(LPCTSTR pcszScheduleName) | CXTPCalendarSchedule |
~CXTPCalendarSchedule() | CXTPCalendarSchedule | virtual


Toolkit Pro: XTPControlTabWorkspace.h Source File

  • Source
  • CommandBars
  • TabClient
XTPControlTabWorkspace.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLTABWORKSPACE_H__)
24# define __XTPCONTROLTABWORKSPACE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPControlTabWorkspace
38 : public CXTPControlButton
39 , public CXTPTabClientWnd::CWorkspace
40{
42 DECLARE_XTP_CONTROL(CXTPControlTabWorkspace)
44public:
49 CXTPControlTabWorkspace();
50
56 ~CXTPControlTabWorkspace();
57
58public:
67 virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate);
68
75 virtual CWnd* GetWindow() const;
76
83 CXTPTabPaintManager* GetPaintManager() const;
84
89 virtual void OnRecalcLayout();
90
101 XTPTabPosition GetPosition() const;
102
108 virtual void OnRemoved();
109
110protected:
117 virtual void SetRect(CRect rcControl);
118
124 virtual void Draw(CDC* pDC);
125
133 virtual CSize GetSize(CDC* pDC);
134
147 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
148
155 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
156
162 void OnMouseMove(CPoint point);
163
164protected:
165 BOOL m_bForceRecalc;
166};
167
169# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
170#endif // !defined(__XTPCONTROLTABWORKSPACE_H__)
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTabPosition
XTPTabPosition
XTPTabPosition is an enumeration used to set the position of tabs.
Definition XTPTabManagerDefines.h:200
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlTabWorkspace
TabWorkspace control.
Definition XTPControlTabWorkspace.h:40
CXTPControlTabWorkspace::m_bForceRecalc
BOOL m_bForceRecalc
TRUE to force the tab control to recalculate it's layout.
Definition XTPControlTabWorkspace.h:165
CXTPControlTabWorkspace::OnMouseMove
void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPControlTabWorkspace::~CXTPControlTabWorkspace
~CXTPControlTabWorkspace()
Destroys a CXTPControlTabWorkspace object, handles cleanup and deallocation.
CXTPControlTabWorkspace::OnRemoved
virtual void OnRemoved()
This method is called when an item is removed from the TabManager collection.
CXTPControlTabWorkspace::GetPaintManager
CXTPTabPaintManager * GetPaintManager() const
Retrieves the paint manager.
CXTPControlTabWorkspace::OnRecalcLayout
virtual void OnRecalcLayout()
This method is called to recalculate the layout of the tab client.
CXTPControlTabWorkspace::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlTabWorkspace::OnToolHitTest
virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPControlTabWorkspace::CXTPControlTabWorkspace
CXTPControlTabWorkspace()
Constructs a CXTPControlTabWorkspace object.
CXTPControlTabWorkspace::Draw
virtual void Draw(CDC *pDC)
Call this member to draw the tab workspace.
CXTPControlTabWorkspace::SetRect
virtual void SetRect(CRect rcControl)
This member is called to set the bounding rectangle of the tab control.
CXTPControlTabWorkspace::RedrawControl
virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate)
This member is called when the visual properties of the tabs are changed.
CXTPControlTabWorkspace::GetSize
virtual CSize GetSize(CDC *pDC)
Call this member to retrieve the size of the tab workspace.
CXTPControlTabWorkspace::GetPosition
XTPTabPosition GetPosition() const
Call this member to get the current position of the tabs.
CXTPControlTabWorkspace::GetWindow
virtual CWnd * GetWindow() const
This method is called to get the window handle of the workspace.
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48


CXTPChartNumberFormat Member List

This is the complete list of members for CXTPChartNumberFormat, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartNumberFormat(CXTPChartElement *pOwner) | CXTPChartNumberFormat |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartNumberFormat | virtual
FormatDate(COleDateTime &dt) const | CXTPChartNumberFormat | virtual
FormatNumber(double dValue) const | CXTPChartNumberFormat | virtual
FormatPoint(CXTPChartSeriesPoint *pSeriesPoint, double dValue) const | CXTPChartNumberFormat | virtual
FormatString(LPCTSTR lpszValue) const | CXTPChartNumberFormat | virtual
GetActiveLCID() | CXTPChartNumberFormat | static
GetAppearance() const | CXTPChartElement |
GetCategory() const | CXTPChartNumberFormat |
GetContent() const | CXTPChartElement |
GetCurrencySymbol() const | CXTPChartNumberFormat |
GetDecimalPlaces() const | CXTPChartNumberFormat |
GetLocale() const | CXTPChartNumberFormat |
GetOwner() const | CXTPChartElement |
GetPattern() const | CXTPChartNumberFormat |
GetUseThousandSeparator() const | CXTPChartNumberFormat |
Is3D() const | CXTPChartObject |
IsUseResourceFileLocale() | CXTPChartNumberFormat | static
m_bUseThousandSeparator | CXTPChartNumberFormat | protected
m_nCategory | CXTPChartNumberFormat | protected
m_nDecimalPlaces | CXTPChartNumberFormat | protected
m_nLocale | CXTPChartNumberFormat | protected
m_strCurrencySymbol | CXTPChartNumberFormat | protected
m_strPattern | CXTPChartNumberFormat | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetCategory(XTPChartNumberFormatCategory nCategory) | CXTPChartNumberFormat |
SetCurrencySymbol(LPCTSTR lpszCurrencySymbol) | CXTPChartNumberFormat |
SetDecimalPlaces(int nDecimalPlaces) | CXTPChartNumberFormat |
SetLocale(LCID nLocale) | CXTPChartNumberFormat |
SetPattern(LPCTSTR lpszPattern) | CXTPChartNumberFormat |
SetUseResourceFileLocale(BOOL bUseResourceFileLocale) | CXTPChartNumberFormat | static
SetUseThousandSeparator(BOOL bThousandSeparator) | CXTPChartNumberFormat |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartNumberFormat() | CXTPChartNumberFormat | virtual


CXTPAuxData Member List

This is the complete list of members for CXTPAuxData, including all inherited members.

bMenuShadows | CXTPAuxData |
bUseOfficeFont | CXTPAuxData |
bUseSolidShadows | CXTPAuxData |
bWin2K | CXTPAuxData |
bWin95 | CXTPAuxData |
bWin98 | CXTPAuxData |
bWinNT | CXTPAuxData |
bWinXP | CXTPAuxData |
clr3DDkShadow | CXTPAuxData |
clr3DFace | CXTPAuxData |
clr3DHilight | CXTPAuxData |
clr3DLight | CXTPAuxData |
clr3DShadow | CXTPAuxData |
clrActiveCaption | CXTPAuxData |
clrActiveCaptText | CXTPAuxData |
clrBtnText | CXTPAuxData |
clrGradActiveCapt | CXTPAuxData |
clrGradInActiveCapt | CXTPAuxData |
clrGrayText | CXTPAuxData |
clrHighlight | CXTPAuxData |
clrHighlightText | CXTPAuxData |
clrInActiveCaption | CXTPAuxData |
clrInactiveCaptText | CXTPAuxData |
clrMenu | CXTPAuxData |
clrMenuText | CXTPAuxData |
clrWindow | CXTPAuxData |
clrWindowFrame | CXTPAuxData |
clrWindowText | CXTPAuxData |
clrXPBarFace | CXTPAuxData |
clrXPBarText | CXTPAuxData |
clrXPBarTextPushed | CXTPAuxData |
clrXPDisabled | CXTPAuxData |
clrXPGrayText | CXTPAuxData |
clrXPGripper | CXTPAuxData |
clrXPHighlight | CXTPAuxData |
clrXPHighlightBorder | CXTPAuxData |
clrXPHighlightChecked | CXTPAuxData |
clrXPHighlightCheckedBorder | CXTPAuxData |
clrXPHighlightPushed | CXTPAuxData |
clrXPHighlightText | CXTPAuxData |
clrXPIconShadow | CXTPAuxData |
clrXPMenuBorder | CXTPAuxData |
clrXPMenuExpanded | CXTPAuxData |
clrXPMenuText | CXTPAuxData |
clrXPMenuTextBack | CXTPAuxData |
clrXPSeparator | CXTPAuxData |
clrXPTabInactiveBack | CXTPAuxData |
clrXPTabInactiveText | CXTPAuxData |
CreateSysFont(const CXTPLogFont &lf, CFont &font, long lfWeight=-1, char lfUnderline=-1, long lfOrientation=-1, long lfEscapement=-1) | CXTPAuxData |
CreateSysFont(const CXTPLogFont &lf, CXTPFont &font, long lfWeight=-1, char lfUnderline=-1, long lfOrientation=-1, long lfEscapement=-1) | CXTPAuxData |
cxHThumb | CXTPAuxData |
cxSize | CXTPAuxData |
cxSmIcon | CXTPAuxData |
cyMenuItem | CXTPAuxData |
cySize | CXTPAuxData |
cySmIcon | CXTPAuxData |
cyVThumb | CXTPAuxData |
FontExists(LPCTSTR lpszFaceName) | CXTPAuxData |
FreeSysFonts() | CXTPAuxData |
GetComCtlVersion() | CXTPAuxData |
hcurDragCopy | CXTPAuxData |
hcurDragMove | CXTPAuxData |
hcurDragNone | CXTPAuxData |
hcurHand | CXTPAuxData |
hcurHSplitBar | CXTPAuxData |
hcurMove | CXTPAuxData |
hcurVSplitBar | CXTPAuxData |
iComCtlVersion | CXTPAuxData |
InitResources(HINSTANCE hInst) | CXTPAuxData |
IsComCtlValid() const | CXTPAuxData |
LoadSysCursors() | CXTPAuxData |
LoadSysFonts(LPCTSTR lpszHorzFaceName=NULL, LPCTSTR lpszVertFaceName=NULL) | CXTPAuxData |
SetGlobalFont(CFont *pHorzFont, CFont *pVertFont=NULL) | CXTPAuxData |
SetGlobalFont(LPCTSTR lpszFaceName, LPCTSTR lpszVertFaceName=NULL) | CXTPAuxData |
UpdateSysColors() | CXTPAuxData |
UpdateSysMetrics() | CXTPAuxData |
UseOfficeFont(BOOL bOfficeFont) | CXTPAuxData |
XTPAuxData() | CXTPAuxData | friend
xtpFont | CXTPAuxData |
xtpFontBold | CXTPAuxData |
xtpFontIconTitle | CXTPAuxData |
xtpFontIconTitleBold | CXTPAuxData |
xtpFontMarlettIcon | CXTPAuxData |
xtpFontSmCaption | CXTPAuxData |
xtpFontStatus | CXTPAuxData |
xtpFontULine | CXTPAuxData |
xtpFontVert | CXTPAuxData |
xtpFontVertBold | CXTPAuxData |
XTPGetVersion(bool bVerNumOnly=false) | CXTPAuxData |
~CXTPAuxData() | CXTPAuxData | virtual


CXTPTrackUndoCommand Member List

This is the complete list of members for CXTPTrackUndoCommand, including all inherited members.

CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
GetID() const | CXTPTrackUndoCommand |
m_nID | CXTPTrackUndoCommand | protected
Undo() | CXTPTrackUndoCommand | protectedvirtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual


CXTPChartAxisX Member List

This is the complete list of members for CXTPChartAxisX, including all inherited members.

CalcSideMarginsValue(double nMinValue, double nMaxValue) const | CXTPChartAxisX | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView) | CXTPChartAxisX | protectedvirtual
CXTPChartAxis(CXTPChartDiagram *pDiagram) | CXTPChartAxis |
CXTPChartAxisX(CXTPChartDiagram2D *pDiagram) | CXTPChartAxisX |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxis | virtual
GetActualColor() const | CXTPChartAxis |
GetActualInterlacedColor() const | CXTPChartAxis |
GetActualInterlacedColor2() const | CXTPChartAxis |
GetAlignment() const | CXTPChartAxis |
GetAppearance() const | CXTPChartAxis |
GetColor() const | CXTPChartAxis |
GetConstantLines() const | CXTPChartAxis |
GetContent() const | CXTPChartElement |
GetCustomLabels() const | CXTPChartAxis |
GetDiagram() const | CXTPChartAxis |
GetGridLines() const | CXTPChartAxis |
GetGridSpacing() const | CXTPChartAxis |
GetIndex() const | CXTPChartAxis |
GetInterlacedColor() const | CXTPChartAxis |
GetInterlacedColor2() const | CXTPChartAxis |
GetInterlacedFillStyle() const | CXTPChartAxis |
GetLabel() const | CXTPChartAxis |
GetMinorCount() const | CXTPChartAxis |
GetOwner() const | CXTPChartElement |
GetRange() const | CXTPChartAxis |
GetScaleType() const | CXTPChartAxis |
GetScaleTypeMap() const | CXTPChartAxis |
GetStrips() const | CXTPChartAxis |
GetThickness() const | CXTPChartAxis |
GetTickMarks() const | CXTPChartAxis |
GetTitle() const | CXTPChartAxis |
Is3D() const | CXTPChartObject |
IsInterlaced() const | CXTPChartAxis |
IsReversed() const | CXTPChartAxis |
IsValuesAxis() const | CXTPChartAxisX | virtual
IsVertical() const | CXTPChartAxisX | virtual
IsVisible() const | CXTPChartAxis |
m_bGridSpacingAuto | CXTPChartAxis | protected
m_bInterlaced | CXTPChartAxis | protected
m_bLogarithmic | CXTPChartAxis | protected
m_bReversed | CXTPChartAxis | protected
m_bVisible | CXTPChartAxis | protected
m_clrColor | CXTPChartAxis | protected
m_clrInterlacedColor | CXTPChartAxis | protected
m_clrInterlacedColor2 | CXTPChartAxis | protected
m_dGridSpacing | CXTPChartAxis | protected
m_dLogarithmicBase | CXTPChartAxis | protected
m_nAlignment | CXTPChartAxis | protected
m_nMinorCount | CXTPChartAxis | protected
m_nScaleType | CXTPChartAxis | protected
m_nThickness | CXTPChartAxis | protected
m_pConstantLines | CXTPChartAxis | protected
m_pCustomLabels | CXTPChartAxis | protected
m_pDiagram | CXTPChartAxis | protected
m_pGridLines | CXTPChartAxis | protected
m_pInterlacedFillStyle | CXTPChartAxis | protected
m_pLabel | CXTPChartAxis | protected
m_pRange | CXTPChartAxis | protected
m_pScaleTypeMap | CXTPChartAxis | protected
m_pStrips | CXTPChartAxis | protected
m_pTickMarks | CXTPChartAxis | protected
m_pTitle | CXTPChartAxis | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartAxisAlignment nAlignment) | CXTPChartAxis |
SetColor(const CXTPChartColor &color) | CXTPChartAxis |
SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit) | CXTPChartAxis |
SetGridSpacing(double dGridSpacing) | CXTPChartAxis |
SetGridSpacingAuto(BOOL bGridSpacingAuto) | CXTPChartAxis |
SetIndex(int nIndex) | CXTPChartAxis |
SetInterlaced(BOOL bInterlaced) | CXTPChartAxis |
SetInterlacedColor(const CXTPChartColor &color) | CXTPChartAxis |
SetInterlacedColor2(const CXTPChartColor &color) | CXTPChartAxis |
SetLogarithmic(BOOL bLogarithmic) | CXTPChartAxis |
SetLogarithmicBase(double dLogarithmicBase) | CXTPChartAxis |
SetMinorCount(int nMinorCount) | CXTPChartAxis |
SetReversed(BOOL bRevered) | CXTPChartAxis |
SetThickness(int nThicknes) | CXTPChartAxis |
SetVisible(BOOL bVisible) | CXTPChartAxis |
UpdateRange(CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView) | CXTPChartAxis |
~CXTPChartAxis() | CXTPChartAxis | virtual
~CXTPChartElement() | CXTPChartElement | virtual


CXTPControlBitmap Member List

This is the complete list of members for CXTPControlBitmap, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlBitmap() | CXTPControlBitmap |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControlBitmap | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlBitmap | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


CXTPCalendarResources Member List

This is the complete list of members for CXTPCalendarResources, including all inherited members.

Add(CXTPCalendarResource *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
Add(CXTPCalendarResource *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarResource > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarResource > |
CXTPCalendarResources() | CXTPCalendarResources |
CXTPCmdTarget() | CXTPCmdTarget |
Find(CXTPCalendarEvent *pEvent) const | CXTPCalendarResources |
CXTPCalendarPtrCollectionT< CXTPCalendarResource >::Find(const CXTPCalendarResource *pElement) const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
InsertAt(int nIndex, CXTPCalendarResource *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | protected
Remove(CXTPCalendarResource *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
RetrieveDayEvents(COleDateTime dtDay) const | CXTPCalendarResources |
SetAt(int nIndex, CXTPCalendarResource *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | protected
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
~CXTPCalendarResources() | CXTPCalendarResources | virtual


CXTPChart3dPyramidSeriesLabel Member List

This is the complete list of members for CXTPChart3dPyramidSeriesLabel, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChart3dPyramidSeriesLabel | protectedvirtual
CXTPChart3dPyramidSeriesLabel() | CXTPChart3dPyramidSeriesLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesLabelBase() | CXTPChartPyramidSeriesLabelBase |
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPyramidSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartPyramidSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartPyramidSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartPyramidSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartPyramidSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartPyramidLabelPosition nPosition) | CXTPChartPyramidSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPyramidSeriesLabelBase() | CXTPChartPyramidSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


Toolkit Pro: XTPCommonPicturePreview.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • CommonPicture
XTPCommonPicturePreview.h
Go to the documentation of this file.
1
24#if !defined(__XTPCOMMONPICTUREPREVIEW_H__)
25# define __XTPCOMMONPICTUREPREVIEW_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33namespace Gdiplus
34{
35class Image;
36}
37
38class _XTP_EXT_CLASS CXTPCommonPicturePreview : public IXTPPreview
39{
40public:
41 explicit CXTPCommonPicturePreview(LPCTSTR pFilePath);
42 explicit CXTPCommonPicturePreview(IStream& stream, LPCTSTR pImpliedFileName);
43 ~CXTPCommonPicturePreview();
44
45private:
46 virtual BOOL IsReady() const;
47 virtual BOOL IsAvailable() const;
48 virtual BOOL HasOwnNavigator() const;
49 virtual UINT GetNumberOfPages() const;
50 virtual SIZE GetPreferredPageSize() const;
51 virtual void GoToPage(UINT page);
52 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect);
53 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result);
54 virtual BOOL SupportsCompositedParent() const;
55 virtual void Activate();
56
57 void GetFileType(LPCTSTR filePath);
58 void ParseMultipageTiff();
59 void SetProperRotation();
60
61private:
62 Gdiplus::Image* m_pPicture;
63 BOOL m_bLoadFinished;
64 BOOL m_bLoadSuccess;
65 UINT m_nOrientation;
66 UINT m_FrameCount;
67 UINT m_iCurrentFrame;
68 GUID m_DimensionID;
69 int m_FileType;
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
73#endif // #if !defined(__XTPCOMMONPICTUREPREVIEW_H__)
74
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.


Toolkit Pro: XTPTabColorSetVisualStudio2003.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2003_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CColorSetVisualStudio2003 : public CXTPTabColorSetDefault
44{
45public:
53 virtual void RefreshMetrics();
54
69 void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
70};
71
73// obsolete, for backward compatibility only.
74class _XTP_EXT_CLASS CColorSetVisualStudio : public CColorSetVisualStudio2003
75{
76};
79# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
81#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CColorSetVisualStudio2003
CColorSetVisualStudio2003 implements a Visual Studio 2003 tab color set.
Definition XTPTabColorSetVisualStudio2003.h:44
CColorSetVisualStudio2003::FillNavigateButton
void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CColorSetVisualStudio2003::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetDefault
CXTPTabColorSetDefault implements a default tab color set.
Definition XTPTabColorSetDefault.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74


CXTPCalendarTimeLineViewTimeScale Member List

This is the complete list of members for CXTPCalendarTimeLineViewTimeScale, including all inherited members.

AdjustLayout(CRect rcParentRect) | CXTPCalendarTimeLineViewTimeScale | virtual
CXTPCalendarTimeLineViewTimeScale(CXTPCalendarTimeLineView *pView) | CXTPCalendarTimeLineViewTimeScale |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarTimeLineViewTimeScale | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientRect(int nYstart=0) | CXTPCalendarTimeLineViewTimeScale | virtual
GetRect() const | CXTPCalendarTimeLineViewTimeScale | virtual
GetStartViewDate() const | CXTPCalendarTimeLineViewTimeScale | virtual
GetTimeScaleParams() const | CXTPCalendarTimeLineViewTimeScale | virtual
GetView() const | CXTPCalendarTimeLineViewTimeScale |
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarTimeLineViewTimeScale | virtual
m_dtStartViewDate | CXTPCalendarTimeLineViewTimeScale | protected
m_pParentView | CXTPCalendarTimeLineViewTimeScale | protected
m_pTimeScaleParams | CXTPCalendarTimeLineViewTimeScale | protected
m_rcRect | CXTPCalendarTimeLineViewTimeScale | protected
m_rcScale | CXTPCalendarTimeLineViewTimeScale |
SetStartViewDate(COleDateTime dt) | CXTPCalendarTimeLineViewTimeScale | virtual
SetTimeScaleParams(int eTimeScaleParamsID) | CXTPCalendarTimeLineViewTimeScale | virtual
SetTimeScaleParams2(CXTPCalendarTLV_TimeScaleParams *pSParams) | CXTPCalendarTimeLineViewTimeScale | virtual
~CXTPCalendarTimeLineViewTimeScale() | CXTPCalendarTimeLineViewTimeScale | virtual


CXTPPopupThemeOfficeXP Member List

This is the complete list of members for CXTPPopupThemeOfficeXP, including all inherited members.

CXTPPopupPaintManager() | CXTPPopupPaintManager |
CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 |
CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP |
DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient) | CXTPPopupThemeOfficeXP | virtual
DrawButton(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
DrawItem(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager |
DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
m_clrBackground | CXTPPopupPaintManager |
m_clrButtonPressed | CXTPPopupPaintManager |
m_clrButtonPressedBorder | CXTPPopupPaintManager |
m_clrButtonSelected | CXTPPopupPaintManager |
m_clrButtonSelectedBorder | CXTPPopupPaintManager |
m_clrFrame | CXTPPopupPaintManager |
m_clrText | CXTPPopupPaintManager |
m_xtpFontText | CXTPPopupPaintManager |
RefreshMetrics() | CXTPPopupThemeOfficeXP | virtual
SetFont(HFONT hFont) | CXTPPopupPaintManager |
~CXTPPopupPaintManager() | CXTPPopupPaintManager | virtual
~CXTPPopupThemeOffice2000() | CXTPPopupThemeOffice2000 | virtual
~CXTPPopupThemeOfficeXP() | CXTPPopupThemeOfficeXP | virtual


Toolkit Pro: XTPMarkupTheme.h Source File

  • Source
  • Common
XTPMarkupTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTHEME_H__)
24# define __XTPMARKUPTHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupContext;
34class CXTPMarkupUIElement;
35
41class _XTP_EXT_CLASS CXTPMarkupThemePart
42{
43public:
48 CXTPMarkupThemePart();
49
54 virtual ~CXTPMarkupThemePart();
55
65 BOOL LoadPart(HZIP hZip, LPCTSTR pszFileName, CXTPMarkupContext* pMarkupContext);
66
73 void RenderMarkup(CDC* pDC, CRect rc);
74
83 CSize Measure(int cx, int cy);
84
85protected:
86 CXTPMarkupUIElement* m_pMarkupUIElement;
87};
88
89# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
91#endif // !defined(__XTPMARKUPTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupThemePart
The CXTPMarkupThemePart class is used to create a theme part object used for rendering.
Definition XTPMarkupTheme.h:42
CXTPMarkupThemePart::LoadPart
BOOL LoadPart(HZIP hZip, LPCTSTR pszFileName, CXTPMarkupContext *pMarkupContext)
This member function is ca.led to load the theme part.
CXTPMarkupThemePart::CXTPMarkupThemePart
CXTPMarkupThemePart()
Constructs a CXTPMarkupThemePart object.
CXTPMarkupThemePart::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Points to a CXTPMarkupUIElement object.
Definition XTPMarkupTheme.h:86
CXTPMarkupThemePart::~CXTPMarkupThemePart
virtual ~CXTPMarkupThemePart()
Destructor, handles cleanup and deallocation.
CXTPMarkupThemePart::Measure
CSize Measure(int cx, int cy)
Called to determine a theme part's size.
CXTPMarkupThemePart::RenderMarkup
void RenderMarkup(CDC *pDC, CRect rc)
This member function is called to render the markup theme part.
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPCalendarEventLabel.h Source File

  • Source
  • Calendar
XTPCalendarEventLabel.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDAREVENTLABEL_H__)
23# define _XTPCALENDAREVENTLABEL_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
32class CXTPCalendarEventLabel;
33class CXTPCalendarEventLabels;
34class CXTPPropExchange;
35
42class _XTP_EXT_CLASS CXTPCalendarEventLabel : public CXTPCmdTarget
43{
45 DECLARE_DYNAMIC(CXTPCalendarEventLabel)
47public:
48 int m_nLabelID;
49 COLORREF m_clrColor;
50 CString m_strName;
60 CXTPCalendarEventLabel(int nID = 0, COLORREF clrColor = 0, LPCTSTR pcszName = _T(""));
61
68 CXTPCalendarEventLabel(CXTPCalendarEventLabel* pSrc);
69
77 virtual ~CXTPCalendarEventLabel();
78
90 const CXTPCalendarEventLabel& operator=(const CXTPCalendarEventLabel& rSrc);
91
92protected:
93# ifdef _XTP_ACTIVEX
94
95 afx_msg OLE_COLOR OleGetColor();
96 afx_msg void OleSetColor(OLE_COLOR clrOleColor);
97
98 DECLARE_DISPATCH_MAP()
99 DECLARE_INTERFACE_MAP()
100
101 DECLARE_OLETYPELIB_EX(CXTPCalendarEventLabel);
102
103# endif
104};
105
106//===========================================================================
107
109
118class _XTP_EXT_CLASS CXTPCalendarEventLabels
119 : public CXTPCalendarPtrCollectionT<CXTPCalendarEventLabel>
120{
122 DECLARE_DYNAMIC(CXTPCalendarEventLabels)
124public:
129 CXTPCalendarEventLabels();
130
138 virtual ~CXTPCalendarEventLabels();
139
145 virtual void InitDefaultValues();
146
154 void UpdateDefaultValues(COLORREF* clrEventColors, UINT uCount);
155
163 void SetDefaultValues(BOOL bDefault);
164
174 CXTPCalendarEventLabel* Find(int nLabelID) const;
175
176 using CXTPCalendarPtrCollectionT<CXTPCalendarEventLabel>::Find;
177
178protected:
189 int FindIndex(int nLabelID) const;
190
191protected:
192 BOOL m_bDefaultValues;
194# ifdef _XTP_ACTIVEX
195
196 // afx_msg long OleGetItemCount();
197 // afx_msg LPDISPATCH OleGetItem(long nIndex);
198
199 afx_msg void OleAddLabel(long nLabelID, OLE_COLOR clrOleColor, LPCTSTR pcszName);
200 // afx_msg void OleRemoveAll();
201
202 afx_msg LPDISPATCH OleFind(long nID);
203
204 // afx_msg void OleInitDefaultValues();
205
206 DECLARE_DISPATCH_MAP()
207 DECLARE_INTERFACE_MAP()
208
209 DECLARE_OLETYPELIB_EX(CXTPCalendarEventLabels);
210
211 DECLARE_ENUM_VARIANT(CXTPCalendarEventLabels);
212
213# endif
214};
215
228class _XTP_EXT_CLASS CXTPCalendarEventCategory : public CXTPCmdTarget
229{
231 DECLARE_DYNCREATE(CXTPCalendarEventCategory)
234public:
245 CXTPCalendarEventCategory(UINT nID = 0, LPCTSTR pcszName = _T(""), COLORREF clrBorder = 0,
246 COLORREF clrBkBase = 0);
247
254 CXTPCalendarEventCategory(CXTPCalendarEventCategory* pCategory);
255
260 virtual ~CXTPCalendarEventCategory();
261
270 UINT GetID() const;
271
280 void SetID(UINT nID);
281
290 CString GetName() const;
291
300 void SetName(LPCTSTR pcszName);
301
310 virtual COLORREF GetBorderColor() const;
311
320 virtual void SetBorderColor(COLORREF clrColor);
321
330 virtual COLORREF GetBkBaseColor() const;
331
340 virtual void SetBkBaseColor(COLORREF clrColor);
341
351 virtual CXTPPaintManagerColorGradient& GetBackgroundColor();
352
362 virtual COLORREF GetBkColorAllDayEvents() const;
363
373 virtual COLORREF GetBkColorWorkCell() const;
374
384 virtual COLORREF GetBkColorNonWorkCell() const;
385
395 virtual COLORREF GetColorCellBorder() const;
396
397protected:
398 // nID -
399 // pcszName - Category name.
400 // clrBorder - Event border color.
401 // clrBkBase - Base color to calculate few background colors for event
402 // background and other elements.
403
404 UINT m_nID;
405 CString m_strName;
407 COLORREF m_clrBorder;
408 COLORREF m_clrBkBase;
411 CXTPPaintManagerColorGradient m_grclrBackground;
414protected:
415# ifdef _XTP_ACTIVEX
416
417 DECLARE_DISPATCH_MAP()
418 DECLARE_INTERFACE_MAP()
419
420 DECLARE_OLETYPELIB_EX(CXTPCalendarEventCategory);
421 DECLARE_OLECREATE_EX(CXTPCalendarEventCategory);
422
423 OLE_COLOR OleGetBorderColor();
424 void OleSetBorderColor(OLE_COLOR oleColor);
425
426 LPDISPATCH OleGetBackground();
428# endif
429};
430
438class _XTP_EXT_CLASS CXTPCalendarEventCategories
439 : public CXTPCalendarPtrCollectionT<CXTPCalendarEventCategory>
440{
442 DECLARE_DYNCREATE(CXTPCalendarEventCategories)
445protected:
446 // CXTPCalendarEventCategories(BOOL bDefaultColorsSet);
447
448public:
453 CXTPCalendarEventCategories();
454
462 virtual ~CXTPCalendarEventCategories();
463
469 virtual void InitDefaultValues();
470
482 void UpdateDefaultValues(COLORREF* pClrBkBase, COLORREF* pClrBorder, int nCount);
483
491 void SetDefaultValues(BOOL bDefault);
492
502 virtual CXTPCalendarEventCategory* Find(UINT nID) const;
503
504 using CXTPCalendarPtrCollectionT<CXTPCalendarEventCategory>::Find;
505
506protected:
517 virtual int FindIndex(UINT nID) const;
518
519 CString LoadCategoryName(UINT nIDResource) const;
520
521 BOOL m_bDefaultValues;
523# ifdef _XTP_ACTIVEX
524
525 DECLARE_DISPATCH_MAP()
526 DECLARE_INTERFACE_MAP()
527
528 DECLARE_OLETYPELIB_EX(CXTPCalendarEventCategories);
529 DECLARE_OLECREATE_EX(CXTPCalendarEventCategories);
530 DECLARE_ENUM_VARIANT(CXTPCalendarEventCategories);
531
532 afx_msg void OleSetItem(long nIndex, LPDISPATCH pdispItem);
533 afx_msg void OleAdd(LPDISPATCH pdispItem);
534 afx_msg LPDISPATCH OleFind(long nID);
535
536# endif
537};
538
546class _XTP_EXT_CLASS CXTPCalendarUIntArray : public CXTPArrayT<UINT, UINT>
547{
549 DECLARE_DYNAMIC(CXTPCalendarUIntArray)
551public:
552 typedef CXTPArrayT<UINT, UINT> TBase;
553
562 int Find(UINT uID) const;
563
575 virtual BOOL RemoveID(UINT uID);
576
586 virtual CString SaveToString() const;
587
597 virtual void LoadFromString(LPCTSTR pcszData);
598
612 virtual void DoPropExchange(CXTPPropExchange* pPX, LPCTSTR pcszSection, LPCTSTR pcszElement);
613
614protected:
615# ifdef _XTP_ACTIVEX
616
617 DECLARE_DISPATCH_MAP()
618 DECLARE_ENUM_VARIANTLIST(CXTPCalendarUIntArray);
619
620 void OleLoadFromString(LPCTSTR strData);
621 BSTR OleSaveToString();
622
623# endif
624};
625
627
635class _XTP_EXT_CLASS CXTPCalendarIconIDs : public CXTPCalendarUIntArray
636{
638 DECLARE_DYNAMIC(CXTPCalendarIconIDs)
640public:
641 typedef CXTPCalendarUIntArray TBase;
642
649 CXTPCalendarIconIDs();
650
657 virtual ~CXTPCalendarIconIDs();
658
670 virtual void DoPropExchange(CXTPPropExchange* pPX);
671
672 using CXTPCalendarUIntArray::DoPropExchange;
673
674protected:
675# ifdef _XTP_ACTIVEX
676
677 DECLARE_DISPATCH_MAP()
678 DECLARE_INTERFACE_MAP()
679 DECLARE_OLETYPELIB_EX(CXTPCalendarIconIDs);
680
681# endif
682};
683
691class _XTP_EXT_CLASS CXTPCalendarEventCategoryIDs : public CXTPCalendarUIntArray
692{
694 DECLARE_DYNAMIC(CXTPCalendarEventCategoryIDs)
696public:
697 typedef CXTPCalendarUIntArray TBase;
698
703 CXTPCalendarEventCategoryIDs();
704
709 virtual ~CXTPCalendarEventCategoryIDs();
710
722 virtual void DoPropExchange(CXTPPropExchange* pPX);
723
724 using CXTPCalendarUIntArray::DoPropExchange;
725
726protected:
727# ifdef _XTP_ACTIVEX
728
729 DECLARE_DISPATCH_MAP()
730 DECLARE_INTERFACE_MAP()
731 DECLARE_OLETYPELIB_EX(CXTPCalendarEventCategoryIDs);
732
733# endif
734};
735
736AFX_INLINE void CXTPCalendarIconIDs::DoPropExchange(CXTPPropExchange* pPX)
737{
738 TBase::DoPropExchange(pPX, _T("CustomIcons"), _T("IconID"));
739}
740AFX_INLINE void CXTPCalendarEventCategoryIDs::DoPropExchange(CXTPPropExchange* pPX)
741{
742 TBase::DoPropExchange(pPX, _T("EventCategories"), _T("CategoryID"));
743}
744AFX_INLINE UINT CXTPCalendarEventCategory::GetID() const
745{
746 return m_nID;
747}
748AFX_INLINE void CXTPCalendarEventCategory::SetID(UINT nID)
749{
750 m_nID = nID;
751}
752AFX_INLINE CString CXTPCalendarEventCategory::GetName() const
753{
754 return m_strName;
755}
756AFX_INLINE void CXTPCalendarEventCategory::SetName(LPCTSTR pcszName)
757{
758 m_strName = pcszName;
759}
760AFX_INLINE COLORREF CXTPCalendarEventCategory::GetBorderColor() const
761{
762 return m_clrBorder;
763}
764AFX_INLINE void CXTPCalendarEventCategory::SetBorderColor(COLORREF clrColor)
765{
766 m_clrBorder = clrColor;
767}
768AFX_INLINE COLORREF CXTPCalendarEventCategory::GetBkBaseColor() const
769{
770 return m_clrBkBase;
771}
772AFX_INLINE void CXTPCalendarEventCategory::SetBkBaseColor(COLORREF clrColor)
773{
774 m_clrBkBase = clrColor;
775}
776
777# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
778#endif // !defined(_XTPCALENDAREVENTLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPArrayT
This class represents a simple array of typed elements.
Definition XTPSmartPtrInternalT.h:490
CXTPCalendarEventCategories
This class is used as a collection of CXTPCalendarEventCategory objects.
Definition XTPCalendarEventLabel.h:440
CXTPCalendarEventCategories::CXTPCalendarEventCategories
CXTPCalendarEventCategories()
Default class constructor.
CXTPCalendarEventCategories::SetDefaultValues
void SetDefaultValues(BOOL bDefault)
Call this member function to set a flag indicating custom labels are defined.
CXTPCalendarEventCategories::Find
virtual CXTPCalendarEventCategory * Find(UINT nID) const
This member function is used to search for the event category with a specified ID.
CXTPCalendarEventCategories::InitDefaultValues
virtual void InitDefaultValues()
This member function is used to fill the collection using a default label list.
CXTPCalendarEventCategories::~CXTPCalendarEventCategories
virtual ~CXTPCalendarEventCategories()
Default class destructor.
CXTPCalendarEventCategories::UpdateDefaultValues
void UpdateDefaultValues(COLORREF *pClrBkBase, COLORREF *pClrBorder, int nCount)
This member function updates the default colors of a category list when the theme is changed.
CXTPCalendarEventCategories::m_bDefaultValues
BOOL m_bDefaultValues
Set to FALSE when using custom values.
Definition XTPCalendarEventLabel.h:521
CXTPCalendarEventCategories::FindIndex
virtual int FindIndex(UINT nID) const
Finds an event category index in the collection by its ID.
CXTPCalendarEventCategory
This class defines Calendar Event Category properties.
Definition XTPCalendarEventLabel.h:229
CXTPCalendarEventCategory::m_nID
UINT m_nID
Stores category identifier.
Definition XTPCalendarEventLabel.h:404
CXTPCalendarEventCategory::m_strName
CString m_strName
Stores category name.
Definition XTPCalendarEventLabel.h:405
CXTPCalendarEventCategory::m_clrBorder
COLORREF m_clrBorder
Stores Event border color.
Definition XTPCalendarEventLabel.h:407
CXTPCalendarEventCategory::m_clrBkBase
COLORREF m_clrBkBase
Stores Base color to calculate few background colors for event background and other elements.
Definition XTPCalendarEventLabel.h:408
CXTPCalendarEventCategory::GetBkBaseColor
virtual COLORREF GetBkBaseColor() const
This member function is used to obtain a background base color.
Definition XTPCalendarEventLabel.h:768
CXTPCalendarEventCategory::GetBackgroundColor
virtual CXTPPaintManagerColorGradient & GetBackgroundColor()
This member function is used to obtain an event background color.
CXTPCalendarEventCategory::GetBkColorNonWorkCell
virtual COLORREF GetBkColorNonWorkCell() const
This member function is used to obtain Day View NonWork Cell background color.
CXTPCalendarEventCategory::GetName
CString GetName() const
This member function is used to obtain a category name.
Definition XTPCalendarEventLabel.h:752
CXTPCalendarEventCategory::GetID
UINT GetID() const
This member function is used to obtain a unique category ID.
Definition XTPCalendarEventLabel.h:744
CXTPCalendarEventCategory::GetBorderColor
virtual COLORREF GetBorderColor() const
This member function is used to obtain an event border color.
Definition XTPCalendarEventLabel.h:760
CXTPCalendarEventCategory::GetBkColorWorkCell
virtual COLORREF GetBkColorWorkCell() const
This member function is used to obtain Day View Work Cell background color.
CXTPCalendarEventCategory::CXTPCalendarEventCategory
CXTPCalendarEventCategory(CXTPCalendarEventCategory *pCategory)
Default class constructor.
CXTPCalendarEventCategory::SetBorderColor
virtual void SetBorderColor(COLORREF clrColor)
This member function is used to set an event border color.
Definition XTPCalendarEventLabel.h:764
CXTPCalendarEventCategory::GetColorCellBorder
virtual COLORREF GetColorCellBorder() const
This member function is used to obtain Day View Cell border color.
CXTPCalendarEventCategory::SetID
void SetID(UINT nID)
This member function is used to set a unique category ID.
Definition XTPCalendarEventLabel.h:748
CXTPCalendarEventCategory::SetName
void SetName(LPCTSTR pcszName)
This member function is used to set a category name.
Definition XTPCalendarEventLabel.h:756
CXTPCalendarEventCategory::CXTPCalendarEventCategory
CXTPCalendarEventCategory(UINT nID=0, LPCTSTR pcszName=_T(""), COLORREF clrBorder=0, COLORREF clrBkBase=0)
Default class constructor.
CXTPCalendarEventCategory::~CXTPCalendarEventCategory
virtual ~CXTPCalendarEventCategory()
Default class destructor.
CXTPCalendarEventCategory::m_grclrBackground
CXTPPaintManagerColorGradient m_grclrBackground
Stores an event background gradient color.
Definition XTPCalendarEventLabel.h:411
CXTPCalendarEventCategory::GetBkColorAllDayEvents
virtual COLORREF GetBkColorAllDayEvents() const
This member function is used to obtain All Day Events area background color.
CXTPCalendarEventCategory::SetBkBaseColor
virtual void SetBkBaseColor(COLORREF clrColor)
This member function is used to set a background base color.
Definition XTPCalendarEventLabel.h:772
CXTPCalendarEventCategoryIDs
This class represents the collection of event categories IDs.
Definition XTPCalendarEventLabel.h:692
CXTPCalendarEventCategoryIDs::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load collection data using the specified data object.
Definition XTPCalendarEventLabel.h:740
CXTPCalendarEventCategoryIDs::CXTPCalendarEventCategoryIDs
CXTPCalendarEventCategoryIDs()
Default object constructor.
CXTPCalendarEventCategoryIDs::~CXTPCalendarEventCategoryIDs
virtual ~CXTPCalendarEventCategoryIDs()
Default object destructor.
CXTPCalendarEventLabel
This class defines Calendar Event label properties.
Definition XTPCalendarEventLabel.h:43
CXTPCalendarEventLabel::CXTPCalendarEventLabel
CXTPCalendarEventLabel(int nID=0, COLORREF clrColor=0, LPCTSTR pcszName=_T(""))
Default class constructor.
CXTPCalendarEventLabel::m_strName
CString m_strName
Label name.
Definition XTPCalendarEventLabel.h:50
CXTPCalendarEventLabel::CXTPCalendarEventLabel
CXTPCalendarEventLabel(CXTPCalendarEventLabel *pSrc)
Default class constructor.
CXTPCalendarEventLabel::m_nLabelID
int m_nLabelID
Label ID.
Definition XTPCalendarEventLabel.h:48
CXTPCalendarEventLabel::operator=
const CXTPCalendarEventLabel & operator=(const CXTPCalendarEventLabel &rSrc)
This member function is used to set new object properties.
CXTPCalendarEventLabel::m_clrColor
COLORREF m_clrColor
Label color used to fill the event background.
Definition XTPCalendarEventLabel.h:49
CXTPCalendarEventLabel::~CXTPCalendarEventLabel
virtual ~CXTPCalendarEventLabel()
Default class destructor.
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
Definition XTPCalendarEventLabel.h:120
CXTPCalendarEventLabels::SetDefaultValues
void SetDefaultValues(BOOL bDefault)
Call this member function to set a flag indicating that custom labels are defined.
CXTPCalendarEventLabels::CXTPCalendarEventLabels
CXTPCalendarEventLabels()
Default class constructor.
CXTPCalendarEventLabels::InitDefaultValues
virtual void InitDefaultValues()
This member function is used to fill the collection using a default label list.
CXTPCalendarEventLabels::~CXTPCalendarEventLabels
virtual ~CXTPCalendarEventLabels()
Default class destructor.
CXTPCalendarEventLabels::FindIndex
int FindIndex(int nLabelID) const
Finds label index in the internal array by its ID.
CXTPCalendarEventLabels::UpdateDefaultValues
void UpdateDefaultValues(COLORREF *clrEventColors, UINT uCount)
This member function updates the default colors of labels when the theme is changed.
CXTPCalendarEventLabels::m_bDefaultValues
BOOL m_bDefaultValues
Set to FALSE when using custom values.
Definition XTPCalendarEventLabel.h:192
CXTPCalendarEventLabels::Find
CXTPCalendarEventLabel * Find(int nLabelID) const
This member function is used to search for the label with a specified ID.
CXTPCalendarIconIDs
This class represents the collection of custom icons IDs.
Definition XTPCalendarEventLabel.h:636
CXTPCalendarIconIDs::CXTPCalendarIconIDs
CXTPCalendarIconIDs()
Default object constructor.
CXTPCalendarIconIDs::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load collection data using the specified data object.
Definition XTPCalendarEventLabel.h:736
CXTPCalendarIconIDs::~CXTPCalendarIconIDs
virtual ~CXTPCalendarIconIDs()
Default object destructor.
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarUIntArray
This class represents the collection of UINT elements.
Definition XTPCalendarEventLabel.h:547
CXTPCalendarUIntArray::Find
int Find(UINT uID) const
Call this member function to find an ID in the collection.
CXTPCalendarUIntArray::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX, LPCTSTR pcszSection, LPCTSTR pcszElement)
Call this member function to Store/Load collection data using the specified data object.
CXTPCalendarUIntArray::SaveToString
virtual CString SaveToString() const
Call this member function to store collection data as a comma separated string.
CXTPCalendarUIntArray::LoadFromString
virtual void LoadFromString(LPCTSTR pcszData)
Call this member function to read collection data from a comma separated string.
CXTPCalendarUIntArray::RemoveID
virtual BOOL RemoveID(UINT uID)
Call this member function to remove an ID from the collection.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPChartPieSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESSTYLE_H__)
24# define __XTPCHARTPIESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pie/Base/XTPChartPieSeriesStyleBase.h"
32# include "Chart/Styles/Pie/2D/XTPChart2dPieSeriesStyle.h"
33
34// CXTPChart2dPieSeriesStyle alias is necessary for naming consistency.
35typedef CXTPChartPieSeriesStyle CXTPChart2dPieSeriesStyle;
37#endif //#if !defined(__XTPCHARTPIESERIESSTYLE_H__)
XTPChart2dPieSeriesStyle.h
XTPChartPieSeriesStyleBase.h
CXTPChartPieSeriesStyle
This class abstracts the pie series style.
Definition XTPChart2dPieSeriesStyle.h:48


Toolkit Pro: XTPDockingPaneManager.h Source File

  • Source
  • DockingPane
XTPDockingPaneManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEMANAGER_H__)
24# define __XTPDOCKINGPANEMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPane;
34class CXTPDockingPaneBase;
35class CXTPDockingPaneBase;
36class CXTPDockingPaneManager;
37class CXTPDockingPaneSplitterContainer;
38class CXTPDockingPaneTabbedContainer;
39class CXTPDockingPaneMiniWnd;
40class CXTPDockingPaneContext;
41class CXTPDockingPaneLayout;
42class CXTPDockingPanePaintManager;
43class CXTPImageManagerIcon;
44class CXTPImageManager;
45class CXTPToolTipContext;
46class CXTPDockingPaneSidePanel;
47class CXTPImageManagerIconHandle;
48class CXTPPropExchange;
49
55class _XTP_EXT_CLASS CXTPDockingPaneManager
56 : public CWnd
57 , public CXTPAccessible
58{
59public:
64 CXTPDockingPaneManager();
65
71 ~CXTPDockingPaneManager();
72
73public:
89 virtual bool InstallDockingPanes(CWnd* pParent, bool bClipChildren = true);
90
108 virtual CXTPDockingPane* CreatePane(UINT nID, CRect rc, XTPDockingPaneDirection direction,
109 CXTPDockingPaneBase* pNeighbour = NULL);
110
125 virtual void DockPane(CXTPDockingPaneBase* pPane, XTPDockingPaneDirection direction,
126 CXTPDockingPaneBase* pNeighbour = NULL);
127
154 virtual CXTPDockingPaneSidePanel* DockSidePane(CXTPDockingPaneBase* pPane,
155 XTPDockingPaneDirection direction, CRect rc);
156
164 virtual CXTPDockingPaneMiniWnd* FloatPane(CXTPDockingPaneBase* pPane, CRect rc);
165
172 virtual void AttachPane(CXTPDockingPaneBase* pPane, CXTPDockingPaneBase* pNeighbour);
173
179 virtual void ToggleDocking(CXTPDockingPaneBase* pPane);
180
186 virtual void ToggleAutoHide(CXTPDockingPaneBase* pPane);
187
194 virtual void ShowPane(int nID, BOOL bSetFocus = TRUE);
195
202 virtual void ShowPane(CXTPDockingPane* pPane, BOOL bSetFocus = TRUE);
203
209 virtual void ClosePane(int nID);
210
216 virtual void ClosePane(CXTPDockingPane* pPane);
217
225 virtual void DestroyPane(int nID);
226
234 virtual void DestroyPane(CXTPDockingPane* pPane);
235
241 virtual void HidePane(int nID);
242
248 virtual void HidePane(CXTPDockingPaneBase* pPane);
249
257 CXTPDockingPane* FindPane(int nID) const;
258
266 BOOL IsPaneClosed(int nID) const;
267
275 BOOL IsPaneClosed(CXTPDockingPane* pPane) const;
276
284 BOOL IsPaneHidden(int nID) const;
285
293 BOOL IsPaneHidden(CXTPDockingPane* pPane) const;
294
302 BOOL IsPaneSelected(int nID) const;
303
311 BOOL IsPaneSelected(CXTPDockingPane* pPane) const;
312
323 BOOL SetIcons(UINT nIDResource, const int* nIDs, int nCount, COLORREF clrMask = 0xC0C0C0);
324
331 void SetIcon(UINT nID, const CXTPImageManagerIconHandle& hIcon);
332
341 CXTPImageManagerIcon* GetIcon(UINT nID, int nWidth = 16) const;
342
347 void ClearIconMap();
348
361 void SetAnimationDelay(double dAnimationDelay = -1, int nAnimationDuration = 128,
362 int nAnimationInterval = 16);
363
376 double GetAnimationDelay(int* pAnimationDuration = NULL, int* pAnimationInterval = NULL) const;
377
401 void EnableKeyboardNavigate(DWORD options = xtpPaneKeyboardUseAll);
402
412 BOOL IsKeyboardNavigateEnabled() const;
413
423 void SetKeyboardWindowSelectClass(CRuntimeClass* pWindowSelectClass);
424
435 CRuntimeClass* GetKeyboardWindowSelectClass() const;
436
445 BOOL ActivateNextPane(CXTPDockingPane* pPane, BOOL bForward);
446
447public:
456 CXTPDockingPaneInfoList& GetPaneList() const;
457
467 CXTPDockingPaneBaseList& GetPaneStack() const;
468
475 CWnd* GetSite() const;
476
492 void SetTheme(XTPDockingPanePaintTheme theme);
493
500 void SetCustomTheme(CXTPDockingPanePaintManager* pTheme);
501
508 XTPDockingPanePaintTheme GetCurrentTheme() const;
509
516 CXTPDockingPanePaintManager* GetPaintManager() const;
517
526 virtual CXTPDockingPaneLayout* CreateLayout();
527
534 void GetLayout(CXTPDockingPaneLayout* pLayout) const;
535
541 void SetLayout(const CXTPDockingPaneLayout* pLayout);
542
547 void RedrawPanes();
548
555 CXTPDockingPaneBase* GetClientPane() const;
556
561 void DestroyAll();
562
567 void CloseAll();
568
575 CXTPImageManager* GetImageManager() const;
576
582 void SetImageManager(CXTPImageManager* pImageManager);
583
589 void HideClient(BOOL bHide);
590
597 BOOL IsClientHidden() const;
598
604 void SetClientMargin(int nMargin);
605
612 int GetClientMargin() const;
613
623 void SetClientMargins(CRect rcClientMargins);
624
634 CRect GetClientMargins() const;
635
650 void SetSideDockingMargin(CRect rcMargin);
651
667 CRect GetSideDockingMargin() const;
668
679 void UseSplitterTracker(BOOL bSplitterTracker);
680
689 BOOL IsSplitterTrackerUsed() const;
690
707 void SetCaptionDirection(XTPDockingPaneCaptionDirection captionDirection);
708
724 XTPDockingPaneCaptionDirection GetCaptionDirection() const;
725
731 void LockSplitters(BOOL bLock = TRUE);
732
739 BOOL IsSplittersLocked() const;
740
746 void SetFloatingFrameCaption(LPCTSTR lpszCaption);
747
754 void EnableFloatingFrameTheme(BOOL bThemedFloatingFrames);
755
762 BOOL IsFloatingFrameThemeEnabled() const;
763
765 _XTP_DEPRECATED_IN_FAVOR(EnableFloatingFrameTheme)
766 void SetThemedFloatingFrames(BOOL bThemedFloatingFrames)
767 {
768 EnableFloatingFrameTheme(bThemedFloatingFrames);
769 }
770
771 _XTP_DEPRECATED_IN_FAVOR(IsFloatingFrameThemeEnabled)
772 BOOL IsThemedFloatingFrames() const
773 {
774 return IsFloatingFrameThemeEnabled();
775 }
783 void SetStickyFloatingFrames(BOOL bSticky);
784
791 BOOL IsStickyFloatingFrames() const;
792
799 void SetFloatingFramesOpacity(int nOpacity);
800
807 int GetFloatingFramesOpacity() const;
808
817 void SyncActiveFloatingFrames(BOOL bSyncActiveFloatingFrames);
818
826 BOOL IsLayoutRTL() const;
827
839 XTPDockingPaneDirection GetRTLDirection(XTPDockingPaneDirection direction) const;
840
848 XTPDockingPaneDirection GetPaneDirection(const CXTPDockingPaneBase* pPane) const;
849
859 CXTPDockingPaneBase* GetTopPane() const;
860
866 void SetDockingContext(CXTPDockingPaneContext* pDockingContext);
867
874 CXTPDockingPaneContext* GetDockingContext() const;
875
889 BOOL IsAlphaDockingContext() const;
890
907 void SetAlphaDockingContext(BOOL bAlphaDockingContext);
908
917 BOOL IsShowDockingContextStickers() const;
918
937 void SetShowDockingContextStickers(BOOL bShowDockingContextStickers);
938
951 void SetDockingContextStickerStyle(XTPDockingContextStickerStyle style);
952
963 XTPDockingContextStickerStyle GetDockingContextStickerStyle() const;
964
970 void SetShowContentsWhileDragging(BOOL bShow = TRUE);
971
978 BOOL GetShowContentsWhileDragging() const;
979
990 void ShowCaptionMaximizeButton(BOOL bShowMaximizeButton);
991
1002 void ShowFloatingCaptionMaximizeButton(BOOL bShowMaximizeButton);
1003
1014 BOOL IsCaptionMaximizeButtonsVisible() const;
1015
1026 BOOL IsFloatingCaptionMaximizeButtonsVisible() const;
1027
1035 void NormalizeSplitters();
1036
1041 void RecalcFramesLayout();
1042
1048 void SyncPanesState();
1049
1064 void SetDefaultPaneOptions(DWORD dwOptions);
1065
1074 DWORD GetDefaultPaneOptions() const;
1075
1084 void OnSetPreviewMode(BOOL bPreview);
1085
1092 CXTPDockingPane* GetActivePane() const;
1093
1100 CXTPToolTipContext* GetToolTipContext() const;
1101
1109 BOOL DoPropExchange(CXTPPropExchange* pPX);
1110
1117 void RecalcFrameLayout(CXTPDockingPaneBase* pPane, BOOL bDelay = FALSE);
1118
1123 virtual void UpdatePanes();
1124
1133 virtual LRESULT NotifyOwner(UINT nCode, LPARAM lParam);
1134
1143 void EnsureVisible(CXTPDockingPaneBase* pPane);
1144
1152 void EnableSideDocking(BOOL bEnable = TRUE);
1153
1162 BOOL IsSideDockingEnabled() const;
1163
1164public:
1173 virtual CXTPDockingPaneBase* OnCreatePane(XTPDockingPaneType type,
1174 CXTPDockingPaneLayout* pLayout);
1175
1182 virtual void OnActivatePane(BOOL bActive, CXTPDockingPane* pPane);
1183
1195 BOOL NotifyAction(XTPDockingPaneAction action, CXTPDockingPane* pPane,
1196 CXTPDockingPaneBase* pDockContainer = NULL,
1197 XTPDockingPaneDirection dockDirection = xtpPaneDockLeft);
1198# ifndef _XTP_ACTIVEX
1199# ifdef _XTP_INCLUDE_COMMANDBARS
1205 void SetTabClient(CXTPTabClientWnd* pTabClient);
1206
1213 CXTPTabClientWnd* GetTabClient();
1214
1215protected:
1216 BOOL AttachDockingPaneMiniWndToTabClientWnd(CXTPDockingPaneMiniWnd* pSource,
1217 CXTPTabClientWnd* pTarget);
1218 BOOL AttachTabbedContainerToTabClientWnd(CXTPDockingPaneBase* pTabbedContainer,
1219 CXTPTabClientWnd* pTarget);
1220 BOOL AttachSplitterContainerToTabClientWnd(CXTPDockingPaneBase* pSplitterContainer,
1221 CXTPTabClientWnd* pTarget);
1222 BOOL AttachDockingPaneToTabClientWnd(CXTPDockingPane* pSource, CXTPTabClientWnd* pTarget);
1223# endif
1224# endif
1225
1226protected:
1228 DECLARE_MESSAGE_MAP()
1229
1230 //{{AFX_MSG(CXTPDockingPaneManager)
1231 afx_msg void OnSysColorChange();
1232 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection);
1233 afx_msg LRESULT OnSizeParent(WPARAM, LPARAM lParam);
1234 afx_msg LRESULT OnIdleUpdateCmdUI(WPARAM wParam, LPARAM);
1235 afx_msg void OnInitialUpdate();
1236 afx_msg LRESULT OnGetObject(WPARAM wParam, LPARAM lParam);
1237 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1238 //}}AFX_MSG
1241protected:
1244 // System accessibility support.
1245
1246 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
1247 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
1248 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
1249 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
1250 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
1251 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
1252 VARIANT varChild);
1253 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
1254 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
1255 virtual CCmdTarget* GetAccessible();
1256
1257 DECLARE_INTERFACE_MAP()
1258 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
1261private:
1262 CXTPDockingPaneLayout* GetCurrentLayout() const;
1263
1264 CRect _CalculateResultDockingRect(CXTPDockingPaneBase* pPane, XTPDockingPaneDirection direction,
1265 CXTPDockingPaneBase* pNeighbour);
1266 void _InsertPane(CXTPDockingPaneBase* pPane, XTPDockingPaneDirection direction,
1267 CXTPDockingPaneBase* pNeighbour);
1268 void _RemovePane(CXTPDockingPaneBase* pPane);
1269 void _AttachPane(CXTPDockingPaneBase* pPane, CXTPDockingPaneBase* pNeighbour);
1270 CXTPDockingPaneBase* _GetHolder(CXTPDockingPaneBase* pPane, BOOL bFloating);
1271 CXTPDockingPaneBase* _Clone(CXTPDockingPaneBase* pPane);
1272
1273 void _TrackPopupContextMenu(CXTPDockingPane* pPane);
1274 void _Redraw();
1275 void _DetachAll();
1276 BOOL _ToggleDocking(CXTPDockingPane* pPane, CXTPDockingPaneBase* pHolder);
1277
1278public:
1279 int m_nSplitterGap;
1280 BOOL m_bCloseGroupOnButtonClick;
1284 BOOL m_bHideGroupOnButtonClick;
1288 BOOL m_bShowSizeCursorWhileDragging;
1290 CPoint m_ptMinClientSize;
1291 int m_nStickyGap;
1292 BOOL m_bShowPanelScrollButtons;
1293 BOOL m_bAutoInitialUpdate;
1294 XTPTabNavigateButtonFlags m_bShowCloseTabButton;
1296protected:
1297 CWnd* m_pSite;
1298 CXTPDockingPaneLayout* m_pLayout;
1299 CXTPDockingPanePaintManager* m_pPaintManager;
1300 CXTPDockingPane* m_pActivePane;
1302 CRect m_rcClientMargins;
1303 CRect m_rcSideDockingMargin;
1306 BOOL m_bStickyFloatingFrames;
1308 CXTPImageManager* m_pImageManager;
1310 BOOL m_bSideDocking;
1312 BOOL m_bHideClient;
1314 BOOL m_bUseSplitterTracker;
1318 BOOL m_bShowMaximizeButton;
1319 BOOL m_bShowFloatingMaximizeButton;
1321 BOOL m_bLockSplitters;
1323 BOOL m_bAlphaDockingContext;
1326 BOOL m_bShowDockingContextStickers;
1329 BOOL m_bShowContentsWhileDragging;
1332 BOOL m_bThemedFloatingFrames;
1334 BOOL m_bSyncActiveFloatingFrames;
1336 BOOL m_nFloatingFramesOpacity;
1337 DWORD m_bKeyboardEnabled;
1339 DWORD m_dwDefaultPaneOptions;
1340 XTPDockingPaneCaptionDirection m_captionDirection;
1342 CString m_strFloatingFrameCaption;
1346 XTPDockingContextStickerStyle m_nDockingContextStickerStyle;
1348 CXTPDockingPaneContext* m_pDockingContext;
1349 CXTPDockingPaneLayout* m_pPreviewLayout;
1350 CXTPToolTipContext* m_pToolTipContext;
1352 typedef BOOL(WINAPI* PFNSETLAYEREDWINDOWATTRIBUTES)(HWND hwnd, COLORREF crKey, BYTE bAlpha,
1353 DWORD dwFlags);
1354 PFNSETLAYEREDWINDOWATTRIBUTES m_pfnSetLayeredWindowAttributes;
1357 CRuntimeClass* m_pWindowSelectClass;
1359# ifndef _XTP_ACTIVEX
1360# ifdef _XTP_INCLUDE_COMMANDBARS
1361 CXTPTabClientWnd* m_pTabClient;
1362# endif
1363# endif
1364
1365private:
1366 HWND m_hwndLastFocus;
1367 BOOL m_bAttachingPane;
1368 BOOL m_bLayoutCreated;
1369 BOOL m_bInitialUpdateCalled;
1370 CString m_strMove;
1371
1372 friend class CXTPDockingPaneBase;
1373 friend class CXTPDockingPaneBaseContainer;
1374 friend class CXTPDockingPaneSplitterContainer;
1375 friend class CXTPDockingPaneTabbedContainer;
1376 friend class CXTPDockingPaneMiniWnd;
1377 friend class CXTPDockingPaneAutoHideWnd;
1378 friend class CXTPDockingPaneContext;
1379 friend class CXTPDockingPane;
1380 friend class CXTPDockingPaneLayout;
1381 friend class CXTPDockingPaneAutoHidePanel;
1382 friend class CDockingPaneSite;
1383 friend class CDockingPaneCtrl;
1384 friend class CDockingPaneOptions;
1385
1386# ifdef _XTP_ACTIVEX
1387 CXTPDockingPaneManager* GetDockingPaneManager()
1388 {
1389 return this;
1390 }
1391# endif
1392};
1393
1394AFX_INLINE CWnd* CXTPDockingPaneManager::GetSite() const
1395{
1396 return m_pSite;
1397}
1398
1399AFX_INLINE CXTPDockingPaneLayout* CXTPDockingPaneManager::GetCurrentLayout() const
1400{
1401 return m_pLayout;
1402}
1403
1404AFX_INLINE void CXTPDockingPaneManager::RedrawPanes()
1405{
1406 _Redraw();
1407}
1408
1409AFX_INLINE CXTPDockingPanePaintManager* CXTPDockingPaneManager::GetPaintManager() const
1410{
1411 return m_pPaintManager;
1412}
1413
1414AFX_INLINE BOOL CXTPDockingPaneManager::IsClientHidden() const
1415{
1416 return m_bHideClient;
1417}
1418
1419AFX_INLINE void CXTPDockingPaneManager::UseSplitterTracker(BOOL bSplitterTracker)
1420{
1421 m_bUseSplitterTracker = bSplitterTracker;
1422}
1423
1424AFX_INLINE BOOL CXTPDockingPaneManager::IsSplitterTrackerUsed() const
1425{
1426 return m_bUseSplitterTracker;
1427}
1428
1429AFX_INLINE CXTPImageManager* CXTPDockingPaneManager::GetImageManager() const
1430{
1431 return m_pImageManager;
1432}
1433
1434AFX_INLINE BOOL CXTPDockingPaneManager::IsSplittersLocked() const
1435{
1436 return m_bLockSplitters;
1437}
1438
1439AFX_INLINE void CXTPDockingPaneManager::SetFloatingFrameCaption(LPCTSTR lpszCaption)
1440{
1441 m_strFloatingFrameCaption = lpszCaption;
1442}
1443
1444AFX_INLINE BOOL CXTPDockingPaneManager::IsFloatingFrameThemeEnabled() const
1445{
1446 return m_bThemedFloatingFrames;
1447}
1448
1449AFX_INLINE void CXTPDockingPaneManager::SetStickyFloatingFrames(BOOL bSticky)
1450{
1451 m_bStickyFloatingFrames = bSticky;
1452}
1453
1454AFX_INLINE BOOL CXTPDockingPaneManager::IsStickyFloatingFrames() const
1455{
1456 return m_bStickyFloatingFrames;
1457}
1458
1459AFX_INLINE CXTPDockingPaneContext* CXTPDockingPaneManager::GetDockingContext() const
1460{
1461 return m_pDockingContext;
1462}
1463
1464AFX_INLINE BOOL CXTPDockingPaneManager::IsAlphaDockingContext() const
1465{
1466 return m_bAlphaDockingContext;
1467}
1468
1469AFX_INLINE void CXTPDockingPaneManager::SetAlphaDockingContext(BOOL bAlphaDockingContext)
1470{
1471 m_bAlphaDockingContext = bAlphaDockingContext;
1472}
1473
1474AFX_INLINE BOOL CXTPDockingPaneManager::IsShowDockingContextStickers() const
1475{
1476 return m_bShowDockingContextStickers;
1477}
1478
1479AFX_INLINE void
1480 CXTPDockingPaneManager::SetShowDockingContextStickers(BOOL bShowDockingContextStickers)
1481{
1482 m_bShowDockingContextStickers = bShowDockingContextStickers;
1483}
1484
1485AFX_INLINE void CXTPDockingPaneManager::SetDefaultPaneOptions(DWORD dwOptions)
1486{
1487 m_dwDefaultPaneOptions = dwOptions;
1488}
1489
1490AFX_INLINE DWORD CXTPDockingPaneManager::GetDefaultPaneOptions() const
1491{
1492 return m_dwDefaultPaneOptions;
1493}
1494
1495AFX_INLINE void CXTPDockingPaneManager::ClosePane(int nID)
1496{
1497 ClosePane(FindPane(nID));
1498}
1499
1500AFX_INLINE void CXTPDockingPaneManager::ShowPane(int nID, BOOL bSetFocus)
1501{
1502 ShowPane(FindPane(nID), bSetFocus);
1503}
1504
1505AFX_INLINE void CXTPDockingPaneManager::DestroyPane(int nID)
1506{
1507 DestroyPane(FindPane(nID));
1508}
1509
1510AFX_INLINE BOOL CXTPDockingPaneManager::IsPaneClosed(int nID) const
1511{
1512 return IsPaneClosed(FindPane(nID));
1513}
1514
1515AFX_INLINE BOOL CXTPDockingPaneManager::IsPaneHidden(int nID) const
1516{
1517 return IsPaneHidden(FindPane(nID));
1518}
1519
1520AFX_INLINE BOOL CXTPDockingPaneManager::IsPaneSelected(int nID) const
1521{
1522 return IsPaneSelected(FindPane(nID));
1523}
1524
1525AFX_INLINE CXTPDockingPane* CXTPDockingPaneManager::GetActivePane() const
1526{
1527 return m_pActivePane;
1528}
1529
1530AFX_INLINE CXTPToolTipContext* CXTPDockingPaneManager::GetToolTipContext() const
1531{
1532 return m_pToolTipContext;
1533}
1534
1535AFX_INLINE void CXTPDockingPaneManager::ShowCaptionMaximizeButton(BOOL bShowMaximizeButton)
1536{
1537 m_bShowMaximizeButton = bShowMaximizeButton;
1538 RedrawPanes();
1539}
1540
1541AFX_INLINE void CXTPDockingPaneManager::ShowFloatingCaptionMaximizeButton(BOOL bShowMaximizeButton)
1542{
1543 m_bShowFloatingMaximizeButton = bShowMaximizeButton;
1544 RedrawPanes();
1545}
1546
1547AFX_INLINE BOOL CXTPDockingPaneManager::IsCaptionMaximizeButtonsVisible() const
1548{
1549 return m_bShowMaximizeButton;
1550}
1551
1552AFX_INLINE BOOL CXTPDockingPaneManager::IsFloatingCaptionMaximizeButtonsVisible() const
1553{
1554 return m_bShowFloatingMaximizeButton;
1555}
1556
1557AFX_INLINE void
1558 CXTPDockingPaneManager::SetDockingContextStickerStyle(XTPDockingContextStickerStyle style)
1559{
1560 m_nDockingContextStickerStyle = style;
1561}
1562
1563AFX_INLINE XTPDockingContextStickerStyle
1564 CXTPDockingPaneManager::GetDockingContextStickerStyle() const
1565{
1566 return m_nDockingContextStickerStyle;
1567}
1568
1569AFX_INLINE void
1570 CXTPDockingPaneManager::SetCaptionDirection(XTPDockingPaneCaptionDirection captionDirection)
1571{
1572 m_captionDirection = captionDirection;
1573 RedrawPanes();
1574}
1575
1576AFX_INLINE XTPDockingPaneCaptionDirection CXTPDockingPaneManager::GetCaptionDirection() const
1577{
1578 return m_captionDirection;
1579}
1580
1581AFX_INLINE void CXTPDockingPaneManager::SetShowContentsWhileDragging(BOOL bShow)
1582{
1583 m_bShowContentsWhileDragging = bShow;
1584}
1585
1586AFX_INLINE BOOL CXTPDockingPaneManager::GetShowContentsWhileDragging() const
1587{
1588 return m_bShowContentsWhileDragging;
1589}
1590
1591AFX_INLINE void CXTPDockingPaneManager::SetClientMargin(int nMargin)
1592{
1593 CRect rcClientMargins(nMargin, nMargin, nMargin, nMargin);
1594 SetClientMargins(rcClientMargins);
1595}
1596
1597AFX_INLINE int CXTPDockingPaneManager::GetClientMargin() const
1598{
1599 return m_rcClientMargins.left;
1600}
1601
1602AFX_INLINE void CXTPDockingPaneManager::SetClientMargins(CRect rcClientMargins)
1603{
1604 if (m_rcClientMargins != rcClientMargins)
1605 {
1606 m_rcClientMargins = rcClientMargins;
1607 RecalcFrameLayout(NULL, TRUE);
1608 }
1609}
1610
1611AFX_INLINE CRect CXTPDockingPaneManager::GetClientMargins() const
1612{
1613 return m_rcClientMargins;
1614}
1615
1616AFX_INLINE void CXTPDockingPaneManager::SetSideDockingMargin(CRect rcMargin)
1617{
1618 if (m_rcSideDockingMargin != rcMargin)
1619 {
1620 m_rcSideDockingMargin = rcMargin;
1621 RecalcFrameLayout(NULL, TRUE);
1622 }
1623}
1624
1625AFX_INLINE CRect CXTPDockingPaneManager::GetSideDockingMargin() const
1626{
1627 return m_rcSideDockingMargin;
1628}
1629
1630AFX_INLINE int CXTPDockingPaneManager::GetFloatingFramesOpacity() const
1631{
1632 return m_nFloatingFramesOpacity;
1633}
1634
1635AFX_INLINE BOOL CXTPDockingPaneManager::IsKeyboardNavigateEnabled() const
1636{
1637 return (BOOL)m_bKeyboardEnabled;
1638}
1639
1640AFX_INLINE void
1641 CXTPDockingPaneManager::SetKeyboardWindowSelectClass(CRuntimeClass* pWindowSelectClass)
1642{
1643 m_pWindowSelectClass = pWindowSelectClass;
1644}
1645
1646AFX_INLINE CRuntimeClass* CXTPDockingPaneManager::GetKeyboardWindowSelectClass() const
1647{
1648 return m_pWindowSelectClass;
1649}
1650
1651AFX_INLINE void CXTPDockingPaneManager::EnableSideDocking(BOOL bEnable)
1652{
1653 m_bSideDocking = bEnable;
1654}
1655
1656AFX_INLINE BOOL CXTPDockingPaneManager::IsSideDockingEnabled() const
1657{
1658 return m_bSideDocking;
1659}
1660
1661# ifndef _XTP_ACTIVEX
1662# ifdef _XTP_INCLUDE_COMMANDBARS
1663AFX_INLINE void CXTPDockingPaneManager::SetTabClient(CXTPTabClientWnd* pTabClient)
1664{
1665 m_pTabClient = pTabClient;
1666}
1667
1668AFX_INLINE CXTPTabClientWnd* CXTPDockingPaneManager::GetTabClient()
1669{
1670 return m_pTabClient;
1671}
1672# endif
1673# endif
1675# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1676#endif //#if !defined(__XTPDOCKINGPANEMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneType
XTPDockingPaneType
Docking pane type.
Definition XTPDockingPaneDefines.h:77
XTPDockingPaneCaptionDirection
XTPDockingPaneCaptionDirection
Docking Pane Caption direction enumeration.
Definition XTPDockingPaneDefines.h:232
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
xtpPaneDockLeft
@ xtpPaneDockLeft
To dock the pane to the left of the pane or frame.
Definition XTPDockingPaneDefines.h:53
XTPDockingContextStickerStyle
XTPDockingContextStickerStyle
Docking Panes sticker style enumeration.
Definition XTPDockingPaneDefines.h:155
xtpPaneKeyboardUseAll
@ xtpPaneKeyboardUseAll
To use all keys.
Definition XTPDockingPaneDefines.h:344
CXTPDockingPaneInfoList
CList< XTP_DOCKINGPANE_INFO, XTP_DOCKINGPANE_INFO & > CXTPDockingPaneInfoList
This list is used by the CXTPDockingPaneLayout class for maintaining an XTP_DOCKINGPANE_INFO collecti...
Definition XTPDockingPaneDefines.h:491
CXTPDockingPaneBaseList
CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
Definition XTPDockingPaneDefines.h:482
XTPDockingPanePaintTheme
XTPDockingPanePaintTheme
Visual theme enumeration.
Definition XTPDockingPaneDefines.h:100
XTPDockingPaneAction
XTPDockingPaneAction
Actions a docking pane is currently performing.
Definition XTPDockingPaneDefines.h:268
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags
XTPTabNavigateButtonFlags is an enumeration used to indicate when a navigate button will be displayed...
Definition XTPTabManagerDefines.h:68
CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBas...
Definition XTPDockingPaneAutoHidePanel.h:121
CXTPDockingPaneAutoHideWnd
CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class.
Definition XTPDockingPaneAutoHidePanel.h:43
CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneBaseContainer.h:39
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneContext
CXTPDockingPaneContext is a standalone class.
Definition XTPDockingPaneContext.h:185
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneManager::m_bShowMaximizeButton
BOOL m_bShowMaximizeButton
Allow non-floating panes to be maximized.
Definition XTPDockingPaneManager.h:1318
CXTPDockingPaneManager::m_pActivePane
CXTPDockingPane * m_pActivePane
Current active pane.
Definition XTPDockingPaneManager.h:1300
CXTPDockingPaneManager::ShowCaptionMaximizeButton
void ShowCaptionMaximizeButton(BOOL bShowMaximizeButton)
Call this method to show Maximize/Restore buttons for non-floating docking panes.
Definition XTPDockingPaneManager.h:1535
CXTPDockingPaneManager::GetActivePane
CXTPDockingPane * GetActivePane() const
Call this member function to get the currently active (focused) pane.
Definition XTPDockingPaneManager.h:1525
CXTPDockingPaneManager::ShowPane
virtual void ShowPane(int nID, BOOL bSetFocus=TRUE)
Call this member to show (activate) a pane.
Definition XTPDockingPaneManager.h:1500
CXTPDockingPaneManager::IsFloatingCaptionMaximizeButtonsVisible
BOOL IsFloatingCaptionMaximizeButtonsVisible() const
Determines if Maximize/Restore buttons for floating docking panes are visible.
Definition XTPDockingPaneManager.h:1552
CXTPDockingPaneManager::IsPaneHidden
BOOL IsPaneHidden(CXTPDockingPane *pPane) const
Call this member to check if a pane is hidden.
CXTPDockingPaneManager::GetClientPane
CXTPDockingPaneBase * GetClientPane() const
Call this member to retrieve the client pane.
CXTPDockingPaneManager::m_bSideDocking
BOOL m_bSideDocking
TRUE if side docking is enabled, FALSE if disabled.
Definition XTPDockingPaneManager.h:1310
CXTPDockingPaneManager::m_pDockingContext
CXTPDockingPaneContext * m_pDockingContext
Docking context helper.
Definition XTPDockingPaneManager.h:1348
CXTPDockingPaneManager::SetIcon
void SetIcon(UINT nID, const CXTPImageManagerIconHandle &hIcon)
Call this member to set an icon to the pane.
CXTPDockingPaneManager::m_bLockSplitters
BOOL m_bLockSplitters
If TRUE, then you can not resize the panes when they are docked.
Definition XTPDockingPaneManager.h:1321
CXTPDockingPaneManager::CloseAll
void CloseAll()
Call this member to close all panes.
CXTPDockingPaneManager::IsSideDockingEnabled
BOOL IsSideDockingEnabled() const
Determines if side docking is enabled.
Definition XTPDockingPaneManager.h:1656
CXTPDockingPaneManager::m_bUseSplitterTracker
BOOL m_bUseSplitterTracker
If TRUE, then splitter trackers are used.
Definition XTPDockingPaneManager.h:1314
CXTPDockingPaneManager::DestroyAll
void DestroyAll()
Call this member to destroy all panes.
CXTPDockingPaneManager::SetCaptionDirection
void SetCaptionDirection(XTPDockingPaneCaptionDirection captionDirection)
Call this member to set the direction of captions.
Definition XTPDockingPaneManager.h:1570
CXTPDockingPaneManager::FloatPane
virtual CXTPDockingPaneMiniWnd * FloatPane(CXTPDockingPaneBase *pPane, CRect rc)
Call this member to float an existing pane.
CXTPDockingPaneManager::SetClientMargins
void SetClientMargins(CRect rcClientMargins)
Sets the width for each side of the client margin (left, top, right, and bottom) individually using a...
Definition XTPDockingPaneManager.h:1602
CXTPDockingPaneManager::m_pWindowSelectClass
CRuntimeClass * m_pWindowSelectClass
Runtime class of WindowSelect.
Definition XTPDockingPaneManager.h:1357
CXTPDockingPaneManager::DockPane
virtual void DockPane(CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CXTPDockingPaneBase *pNeighbour=NULL)
Call this member to dock an existing pane.
CXTPDockingPaneManager::SetFloatingFrameCaption
void SetFloatingFrameCaption(LPCTSTR lpszCaption)
Call this method to set the common caption for floating frames.
Definition XTPDockingPaneManager.h:1439
CXTPDockingPaneManager::m_bThemedFloatingFrames
BOOL m_bThemedFloatingFrames
If TRUE, then floating docking panes will use the currently set theme.
Definition XTPDockingPaneManager.h:1332
CXTPDockingPaneManager::m_bShowContentsWhileDragging
BOOL m_bShowContentsWhileDragging
If TRUE, then window contents are visible while dragging.
Definition XTPDockingPaneManager.h:1329
CXTPDockingPaneManager::NotifyAction
BOOL NotifyAction(XTPDockingPaneAction action, CXTPDockingPane *pPane, CXTPDockingPaneBase *pDockContainer=NULL, XTPDockingPaneDirection dockDirection=xtpPaneDockLeft)
The framework calls this method when a docking pane is performing an action.
CXTPDockingPaneManager::IsPaneHidden
BOOL IsPaneHidden(int nID) const
Call this member to check if a pane is hidden.
Definition XTPDockingPaneManager.h:1515
CXTPDockingPaneManager::CreatePane
virtual CXTPDockingPane * CreatePane(UINT nID, CRect rc, XTPDockingPaneDirection direction, CXTPDockingPaneBase *pNeighbour=NULL)
Call this member function to create a docking pane.
CXTPDockingPaneManager::ClearIconMap
void ClearIconMap()
Call this member to remove all icons.
CXTPDockingPaneManager::FindPane
CXTPDockingPane * FindPane(int nID) const
Call this member to find a pane by its identifier.
CXTPDockingPaneManager::EnableKeyboardNavigate
void EnableKeyboardNavigate(DWORD options=xtpPaneKeyboardUseAll)
Call this member to allow the user to switch and move panes using the keyboard.
CXTPDockingPaneManager::OnActivatePane
virtual void OnActivatePane(BOOL bActive, CXTPDockingPane *pPane)
This method is called when a pane is activated/deactivated.
CXTPDockingPaneManager::SetIcons
BOOL SetIcons(UINT nIDResource, const int *nIDs, int nCount, COLORREF clrMask=0xC0C0C0)
Call this member to set icons to panes.
CXTPDockingPaneManager::IsShowDockingContextStickers
BOOL IsShowDockingContextStickers() const
Call this member to determine whether docking context stickers are used.
Definition XTPDockingPaneManager.h:1474
CXTPDockingPaneManager::IsSplitterTrackerUsed
BOOL IsSplitterTrackerUsed() const
Call this member to determine if the splitter tracker is used.
Definition XTPDockingPaneManager.h:1424
CXTPDockingPaneManager::CXTPDockingPaneManager
CXTPDockingPaneManager()
Constructs a CXTPDockingPaneManager object.
CXTPDockingPaneManager::IsPaneClosed
BOOL IsPaneClosed(int nID) const
Call this member to check if a pane is closed.
Definition XTPDockingPaneManager.h:1510
CXTPDockingPaneManager::m_pSite
CWnd * m_pSite
Parent window of the docking manager.
Definition XTPDockingPaneManager.h:1297
CXTPDockingPaneManager::m_strFloatingFrameCaption
CString m_strFloatingFrameCaption
The caption that is displayed in the title bar of a floating frame that has panes docked.
Definition XTPDockingPaneManager.h:1342
CXTPDockingPaneManager::~CXTPDockingPaneManager
~CXTPDockingPaneManager()
Destroys a CXTPDockingPaneManager object, handles cleanup and deallocation.
CXTPDockingPaneManager::IsCaptionMaximizeButtonsVisible
BOOL IsCaptionMaximizeButtonsVisible() const
Determines if Maximize/Restore buttons for non-floating docking panes are visible.
Definition XTPDockingPaneManager.h:1547
CXTPDockingPaneManager::GetDockingContextStickerStyle
XTPDockingContextStickerStyle GetDockingContextStickerStyle() const
Call this member to get the style of docking context stickers.
Definition XTPDockingPaneManager.h:1564
CXTPDockingPaneManager::SetSideDockingMargin
void SetSideDockingMargin(CRect rcMargin)
Sets the margin between the client area's edge and a docking pane docked to the edge of the client ar...
Definition XTPDockingPaneManager.h:1616
CXTPDockingPaneManager::IsPaneClosed
BOOL IsPaneClosed(CXTPDockingPane *pPane) const
Call this member to check if a pane is closed.
CXTPDockingPaneManager::IsLayoutRTL
BOOL IsLayoutRTL() const
Call this member to determine if the current layout is Right-to-Left (RTL).
CXTPDockingPaneManager::SetDockingContext
void SetDockingContext(CXTPDockingPaneContext *pDockingContext)
Call this method to use a custom docking context.
CXTPDockingPaneManager::GetIcon
CXTPImageManagerIcon * GetIcon(UINT nID, int nWidth=16) const
Call this member to get an icon of the pane.
CXTPDockingPaneManager::ToggleDocking
virtual void ToggleDocking(CXTPDockingPaneBase *pPane)
Call this member to switch the pane's position (docking/floating).
CXTPDockingPaneManager::IsStickyFloatingFrames
BOOL IsStickyFloatingFrames() const
Determines if sticky floating frames are enabled.
Definition XTPDockingPaneManager.h:1454
CXTPDockingPaneManager::IsAlphaDockingContext
BOOL IsAlphaDockingContext() const
Call this member to determine if alpha docking context is used when panes are being dragged and dropp...
Definition XTPDockingPaneManager.h:1464
CXTPDockingPaneManager::SetStickyFloatingFrames
void SetStickyFloatingFrames(BOOL bSticky)
Call this method to enable sticky floating frames.
Definition XTPDockingPaneManager.h:1449
CXTPDockingPaneManager::m_dwDefaultPaneOptions
DWORD m_dwDefaultPaneOptions
Default Panes options.
Definition XTPDockingPaneManager.h:1339
CXTPDockingPaneManager::m_bAlphaDockingContext
BOOL m_bAlphaDockingContext
If TRUE, then alpha docking context is used when dragging a pane.
Definition XTPDockingPaneManager.h:1323
CXTPDockingPaneManager::NormalizeSplitters
void NormalizeSplitters()
Call this method to save the current splitter positions for all splitter containers.
CXTPDockingPaneManager::GetRTLDirection
XTPDockingPaneDirection GetRTLDirection(XTPDockingPaneDirection direction) const
Call this member to retrieve the Right-to-Left (RTL) docking direction equivalent to the docking dire...
CXTPDockingPaneManager::m_pLayout
CXTPDockingPaneLayout * m_pLayout
Selected layout.
Definition XTPDockingPaneManager.h:1298
CXTPDockingPaneManager::SetAlphaDockingContext
void SetAlphaDockingContext(BOOL bAlphaDockingContext)
Call this member to specify whether an alpha docking context is used to indicate where a pane can be ...
Definition XTPDockingPaneManager.h:1469
CXTPDockingPaneManager::m_bHideClient
BOOL m_bHideClient
If TRUE, then the client area is hidden so that only the docking panes are visible and occupy the ent...
Definition XTPDockingPaneManager.h:1312
CXTPDockingPaneManager::GetClientMargins
CRect GetClientMargins() const
Retrieves the width for each side of the client margin (left, top, right, and bottom).
Definition XTPDockingPaneManager.h:1611
CXTPDockingPaneManager::m_captionDirection
XTPDockingPaneCaptionDirection m_captionDirection
Caption Direction.
Definition XTPDockingPaneManager.h:1340
CXTPDockingPaneManager::DoPropExchange
BOOL DoPropExchange(CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
CXTPDockingPaneManager::GetSideDockingMargin
CRect GetSideDockingMargin() const
Gets the margin between the client area's edge and a docking pane docked to the edge of the client ar...
Definition XTPDockingPaneManager.h:1625
CXTPDockingPaneManager::EnsureVisible
void EnsureVisible(CXTPDockingPaneBase *pPane)
Call this method to ensure that a specified pane is visible.
CXTPDockingPaneManager::DestroyPane
virtual void DestroyPane(CXTPDockingPane *pPane)
Call this member to destroy a pane.
CXTPDockingPaneManager::GetShowContentsWhileDragging
BOOL GetShowContentsWhileDragging() const
Determines if the "Show window contents while dragging" option is enabled.
Definition XTPDockingPaneManager.h:1586
CXTPDockingPaneManager::GetPaneList
CXTPDockingPaneInfoList & GetPaneList() const
Call this member to get the list of created panes.
CXTPDockingPaneManager::GetPaneDirection
XTPDockingPaneDirection GetPaneDirection(const CXTPDockingPaneBase *pPane) const
Call this member to determine the XTPDockingPaneDirection of pPane.
CXTPDockingPaneManager::GetSite
CWnd * GetSite() const
Call this member to retrieve the docking site of the manager.
Definition XTPDockingPaneManager.h:1394
CXTPDockingPaneManager::RedrawPanes
void RedrawPanes()
Call this member to redraw all panes.
Definition XTPDockingPaneManager.h:1404
CXTPDockingPaneManager::GetCurrentTheme
XTPDockingPanePaintTheme GetCurrentTheme() const
Call this member to get the current visual theme.
CXTPDockingPaneManager::ToggleAutoHide
virtual void ToggleAutoHide(CXTPDockingPaneBase *pPane)
Call this member to switch the pane's auto-hide (docking/auto-hide).
CXTPDockingPaneManager::SetShowDockingContextStickers
void SetShowDockingContextStickers(BOOL bShowDockingContextStickers)
Call this member to specify whether Visual Studio 2005 style docking context stickers should be used ...
Definition XTPDockingPaneManager.h:1480
CXTPDockingPaneManager::CreateLayout
virtual CXTPDockingPaneLayout * CreateLayout()
Call this member to create a new layout.
CXTPDockingPaneManager::GetCaptionDirection
XTPDockingPaneCaptionDirection GetCaptionDirection() const
Call this member to get the direction of captions.
Definition XTPDockingPaneManager.h:1576
CXTPDockingPaneManager::m_pImageManager
CXTPImageManager * m_pImageManager
Image manager of docking panes.
Definition XTPDockingPaneManager.h:1308
CXTPDockingPaneManager::RecalcFrameLayout
void RecalcFrameLayout(CXTPDockingPaneBase *pPane, BOOL bDelay=FALSE)
This method is called to recalculate a pane's site layout.
CXTPDockingPaneManager::m_pToolTipContext
CXTPToolTipContext * m_pToolTipContext
Tooltip Context.
Definition XTPDockingPaneManager.h:1350
CXTPDockingPaneManager::SyncPanesState
void SyncPanesState()
This method updates the XTP_DOCKINGPANE_INFO structure for each pane filling its members.
CXTPDockingPaneManager::GetDefaultPaneOptions
DWORD GetDefaultPaneOptions() const
Call this method to retrieve the default options used for each pane.
Definition XTPDockingPaneManager.h:1490
CXTPDockingPaneManager::IsPaneSelected
BOOL IsPaneSelected(int nID) const
Call this member to check if a pane is selected.
Definition XTPDockingPaneManager.h:1520
CXTPDockingPaneManager::SetTheme
void SetTheme(XTPDockingPanePaintTheme theme)
Call this member to switch the visual theme of the panes.
CXTPDockingPaneManager::HidePane
virtual void HidePane(CXTPDockingPaneBase *pPane)
Call this member to hide a pane.
CXTPDockingPaneManager::GetDockingContext
CXTPDockingPaneContext * GetDockingContext() const
Retrieves a pointer to the current docking context.
Definition XTPDockingPaneManager.h:1459
CXTPDockingPaneManager::ActivateNextPane
BOOL ActivateNextPane(CXTPDockingPane *pPane, BOOL bForward)
Call this method to activate a pane in cycle order.
CXTPDockingPaneManager::GetLayout
void GetLayout(CXTPDockingPaneLayout *pLayout) const
Call this member to get the current layout.
CXTPDockingPaneManager::GetKeyboardWindowSelectClass
CRuntimeClass * GetKeyboardWindowSelectClass() const
Determines the runtime class for a CXTPDockingPaneWindowSelect window that shows active panes and fil...
Definition XTPDockingPaneManager.h:1646
CXTPDockingPaneManager::NotifyOwner
virtual LRESULT NotifyOwner(UINT nCode, LPARAM lParam)
This member is called to notify the parent window that an event has occurred in the docking pane.
CXTPDockingPaneManager::m_rcClientMargins
CRect m_rcClientMargins
Specifies each client margin individually.
Definition XTPDockingPaneManager.h:1302
CXTPDockingPaneManager::SetCustomTheme
void SetCustomTheme(CXTPDockingPanePaintManager *pTheme)
Call this member to set a custom theme.
CXTPDockingPaneManager::EnableFloatingFrameTheme
void EnableFloatingFrameTheme(BOOL bThemedFloatingFrames)
Call this method to use themes for floating frames.
CXTPDockingPaneManager::SetAnimationDelay
void SetAnimationDelay(double dAnimationDelay=-1, int nAnimationDuration=128, int nAnimationInterval=16)
Call this member to set the animation speed.
CXTPDockingPaneManager::SetLayout
void SetLayout(const CXTPDockingPaneLayout *pLayout)
Call this member to set the current layout.
CXTPDockingPaneManager::RecalcFramesLayout
void RecalcFramesLayout()
Call this method to recalculate the layout for all parent frames of panes.
CXTPDockingPaneManager::InstallDockingPanes
virtual bool InstallDockingPanes(CWnd *pParent, bool bClipChildren=true)
Call this member function to install docking panes.
CXTPDockingPaneManager::SetFloatingFramesOpacity
void SetFloatingFramesOpacity(int nOpacity)
Call this method to set the opacity for inactive floating frames.
CXTPDockingPaneManager::OnSetPreviewMode
void OnSetPreviewMode(BOOL bPreview)
Call this member function to set the application's panes into and out of print-preview mode.
CXTPDockingPaneManager::GetPaintManager
CXTPDockingPanePaintManager * GetPaintManager() const
Retrieves the paint manager of docking panes.
Definition XTPDockingPaneManager.h:1409
CXTPDockingPaneManager::HideClient
void HideClient(BOOL bHide)
Call this member to hide the client area.
CXTPDockingPaneManager::ShowFloatingCaptionMaximizeButton
void ShowFloatingCaptionMaximizeButton(BOOL bShowMaximizeButton)
Call this method to show Maximize/Restore buttons for floating docking panes.
Definition XTPDockingPaneManager.h:1541
CXTPDockingPaneManager::SetDefaultPaneOptions
void SetDefaultPaneOptions(DWORD dwOptions)
Call this method to set the default options used for each pane.
Definition XTPDockingPaneManager.h:1485
CXTPDockingPaneManager::ClosePane
virtual void ClosePane(int nID)
Call this member to close a pane.
Definition XTPDockingPaneManager.h:1495
CXTPDockingPaneManager::m_bStickyFloatingFrames
BOOL m_bStickyFloatingFrames
TRUE to enable sticky option for floating panes.
Definition XTPDockingPaneManager.h:1306
CXTPDockingPaneManager::GetPaneStack
CXTPDockingPaneBaseList & GetPaneStack() const
Call this member to get the list of created panes, including its virtual containers.
CXTPDockingPaneManager::m_bShowDockingContextStickers
BOOL m_bShowDockingContextStickers
If TRUE, then docking context stickers are drawn when the pane is being dragged and dropped.
Definition XTPDockingPaneManager.h:1326
CXTPDockingPaneManager::ShowPane
virtual void ShowPane(CXTPDockingPane *pPane, BOOL bSetFocus=TRUE)
Call this member to show (activate) a pane.
CXTPDockingPaneManager::HidePane
virtual void HidePane(int nID)
Call this member to hide a pane.
CXTPDockingPaneManager::m_nDockingContextStickerStyle
XTPDockingContextStickerStyle m_nDockingContextStickerStyle
Sticker style.
Definition XTPDockingPaneManager.h:1346
CXTPDockingPaneManager::ClosePane
virtual void ClosePane(CXTPDockingPane *pPane)
Call this member to close a pane.
CXTPDockingPaneManager::SetDockingContextStickerStyle
void SetDockingContextStickerStyle(XTPDockingContextStickerStyle style)
Call this member to set the style for docking context stickers.
Definition XTPDockingPaneManager.h:1558
CXTPDockingPaneManager::GetTopPane
CXTPDockingPaneBase * GetTopPane() const
Retrieves the top-level virtual container for the site window.
CXTPDockingPaneManager::m_bKeyboardEnabled
DWORD m_bKeyboardEnabled
XTPDockingPaneKeyboardNavigate options.
Definition XTPDockingPaneManager.h:1337
CXTPDockingPaneManager::UseSplitterTracker
void UseSplitterTracker(BOOL bSplitterTracker)
Call this member to use the splitter tracker.
Definition XTPDockingPaneManager.h:1419
CXTPDockingPaneManager::GetFloatingFramesOpacity
int GetFloatingFramesOpacity() const
Determines the opacity for inactive floating frames.
Definition XTPDockingPaneManager.h:1630
CXTPDockingPaneManager::SetShowContentsWhileDragging
void SetShowContentsWhileDragging(BOOL bShow=TRUE)
Call this member to set the "Show window contents while dragging" option.
Definition XTPDockingPaneManager.h:1581
CXTPDockingPaneManager::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
Definition XTPDockingPaneManager.h:1530
CXTPDockingPaneManager::SyncActiveFloatingFrames
void SyncActiveFloatingFrames(BOOL bSyncActiveFloatingFrames)
Call this member to keep the activation of floating frames windows in sync with the activation of the...
CXTPDockingPaneManager::EnableSideDocking
void EnableSideDocking(BOOL bEnable=TRUE)
Enables/disables side docking.
Definition XTPDockingPaneManager.h:1651
CXTPDockingPaneManager::AttachPane
virtual void AttachPane(CXTPDockingPaneBase *pPane, CXTPDockingPaneBase *pNeighbour)
Call this member to attach a pane to another one.
CXTPDockingPaneManager::IsSplittersLocked
BOOL IsSplittersLocked() const
Call this member to determine if the splitters are locked.
Definition XTPDockingPaneManager.h:1434
CXTPDockingPaneManager::m_rcSideDockingMargin
CRect m_rcSideDockingMargin
Side docking margin.
Definition XTPDockingPaneManager.h:1303
CXTPDockingPaneManager::GetImageManager
CXTPImageManager * GetImageManager() const
Call this member to retrieve the image manager of docking panes.
Definition XTPDockingPaneManager.h:1429
CXTPDockingPaneManager::GetClientMargin
int GetClientMargin() const
Retrieves the width of the client margin.
Definition XTPDockingPaneManager.h:1597
CXTPDockingPaneManager::OnCreatePane
virtual CXTPDockingPaneBase * OnCreatePane(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout)
This method is called when a pane is created.
CXTPDockingPaneManager::SetKeyboardWindowSelectClass
void SetKeyboardWindowSelectClass(CRuntimeClass *pWindowSelectClass)
Call this method to set a custom CXTPDockingPaneWindowSelect window that will be used to show active ...
Definition XTPDockingPaneManager.h:1641
CXTPDockingPaneManager::DockSidePane
virtual CXTPDockingPaneSidePanel * DockSidePane(CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CRect rc)
Call this member to dock an existing pane to a dock panel.
CXTPDockingPaneManager::IsClientHidden
BOOL IsClientHidden() const
Checks if the client area is hidden.
Definition XTPDockingPaneManager.h:1414
CXTPDockingPaneManager::GetAnimationDelay
double GetAnimationDelay(int *pAnimationDuration=NULL, int *pAnimationInterval=NULL) const
Call this member to get the animation speed.
CXTPDockingPaneManager::m_bShowFloatingMaximizeButton
BOOL m_bShowFloatingMaximizeButton
Allow floating panes to be maximized.
Definition XTPDockingPaneManager.h:1319
CXTPDockingPaneManager::DestroyPane
virtual void DestroyPane(int nID)
Call this member to destroy a pane.
Definition XTPDockingPaneManager.h:1505
CXTPDockingPaneManager::LockSplitters
void LockSplitters(BOOL bLock=TRUE)
Call this method to lock the splitters.
CXTPDockingPaneManager::IsFloatingFrameThemeEnabled
BOOL IsFloatingFrameThemeEnabled() const
Determines if themes are used for floating frames.
Definition XTPDockingPaneManager.h:1444
CXTPDockingPaneManager::UpdatePanes
virtual void UpdatePanes()
This method is called to update panes state.
CXTPDockingPaneManager::m_pPaintManager
CXTPDockingPanePaintManager * m_pPaintManager
Current paint manager.
Definition XTPDockingPaneManager.h:1299
CXTPDockingPaneManager::IsKeyboardNavigateEnabled
BOOL IsKeyboardNavigateEnabled() const
Determines if keyboard navigate options are enabled.
Definition XTPDockingPaneManager.h:1635
CXTPDockingPaneManager::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Call this member to set the image manager for docking panes.
CXTPDockingPaneManager::SetClientMargin
void SetClientMargin(int nMargin)
Sets the width for the client margin.
Definition XTPDockingPaneManager.h:1591
CXTPDockingPaneManager::IsPaneSelected
BOOL IsPaneSelected(CXTPDockingPane *pPane) const
Call this member to check if a pane is selected.
CXTPDockingPaneManager::m_nFloatingFramesOpacity
BOOL m_nFloatingFramesOpacity
Opacity of floating frames.
Definition XTPDockingPaneManager.h:1336
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPanePaintManager
CXTPDockingPanePaintManager is a standalone class.
Definition XTPDockingPanePaintManager.h:196
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneSplitterContainer.h:168
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is a HICON wrapper class.
Definition XTPImageManager.h:384
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > Member List

This is the complete list of members for CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE >, including all inherited members.

Add(ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
AddIfNeed(ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
Append(const CXTPArrayT &src) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
Copy(const CXTPArrayT &src) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
CXTPArrayT() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
CXTPCmdTarget() | CXTPCmdTarget |
ElementAt(int nIndex) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
FindElement(ARG_TYPE nElement) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetData() const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetData() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
GetSize() const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
InsertAt(int nIndex, ARG_TYPE newElement, int nCount=1) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
InsertAt(int nStartIndex, CXTPArrayT *pNewArray) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
m_arElements | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | protected
operator[](int nIndex) const | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
operator[](int nIndex) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > |
RemoveAll() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
RemoveAt(int nIndex, int nCount=1) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
RemoveElement(ARG_TYPE nElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetAt(int nIndex, ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetAtGrow(int nIndex, ARG_TYPE newElement) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
SetSize(int nNewSize, int nGrowBy=-1) | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual
~CXTPArrayT() | CXTPArrayT< TYPE, ARG_TYPE, OLE_TYPE > | virtual


CXTPMarkupTransform Member List

This is the complete list of members for CXTPMarkupTransform, including all inherited members.

ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix) | CXTPMarkupTransform | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static


CXTPChartPanel Member List

This is the complete list of members for CXTPChartPanel, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPanel() | CXTPChartPanel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPanel | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetTitles() const | CXTPChartPanel |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPanel() | CXTPChartPanel | virtual


XTP_EDIT_NMHDR_ROWCOLCHANGED Member List

This is the complete list of members for XTP_EDIT_NMHDR_ROWCOLCHANGED, including all inherited members.

nCol | XTP_EDIT_NMHDR_ROWCOLCHANGED
nmhdr | XTP_EDIT_NMHDR_ROWCOLCHANGED
nRow | XTP_EDIT_NMHDR_ROWCOLCHANGED


Toolkit Pro: XTPShortcutManager.h Source File

  • Source
  • CommandBars
XTPShortcutManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTMANAGER_H__)
24# define __XTPSHORTCUTMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropExchange;
34class CXTPCommandBars;
35class CXTPShortcutManager;
36
37struct XTP_SHORTCUTMANAGER_ACCEL
38{
39 struct SHORTCUTACCEL
40 {
41 BYTE fVirt;
42 WORD key;
43 };
44
45 int cmd;
46 SHORTCUTACCEL key[2];
47};
48
54class _XTP_EXT_CLASS CXTPShortcutManagerAccel
55 : public CXTPCmdTarget
56 , public XTP_SHORTCUTMANAGER_ACCEL
57{
58public:
63 CXTPShortcutManagerAccel();
64 CXTPShortcutManagerAccel(ACCEL* pAccel);
65 CXTPShortcutManagerAccel(const XTP_SHORTCUTMANAGER_ACCEL& accel);
66 CXTPShortcutManagerAccel(const CXTPShortcutManagerAccel& accel);
67
68public:
69 const CXTPShortcutManagerAccel& operator=(const CXTPShortcutManagerAccel& accel);
70
71# ifdef _XTP_COMMANDBARS_ACTIVEX
73protected:
74 DECLARE_DISPATCH_MAP()
75 DECLARE_OLETYPELIB_EX(CXTPShortcutManagerAccel);
76 DECLARE_INTERFACE_MAP();
77 BSTR OleGetShortcutText();
78 void OleSetShortcutText(LPCTSTR lpszShortcut);
80# endif
81
82public:
83 CXTPShortcutManager* m_pManager;
84};
85
91class _XTP_EXT_CLASS CXTPShortcutManagerAccelTable
92{
93public:
99 CXTPShortcutManagerAccelTable(CXTPShortcutManager* pManager);
100
106 ~CXTPShortcutManagerAccelTable();
107
108public:
115 int GetCount() const;
116
124 CXTPShortcutManagerAccel* GetAt(int nIndex) const;
125
131 void Add(const XTP_SHORTCUTMANAGER_ACCEL& accel);
132
139 XTP_SHORTCUTMANAGER_ACCEL* CopyAccels() const;
140
141public:
147 void CopyAccelTable(HACCEL hAccelTable);
148
154 void CopyAccelTable(CXTPShortcutManagerAccelTable* pAccelTable);
155
162 void CopyAccelTable(LPACCEL lpAccel, int nSize);
163
164public:
169 void RemoveAll();
170
176 void RemoveAt(int nIndex);
177
178protected:
179 CArray<CXTPShortcutManagerAccel*, CXTPShortcutManagerAccel*> m_arrAccels;
181 CXTPShortcutManager* m_pManager;
182};
183
188class _XTP_EXT_CLASS CXTPShortcutManager : public CXTPCmdTarget
189{
190public:
192 class _XTP_EXT_CLASS CKeyNameText
193 {
194 public:
195 CKeyNameText();
196 CString Translate(UINT nKey);
197 void SetAt(UINT uiVirtKey, LPCTSTR lpszKeyNameText);
198 WORD Parse(LPCTSTR lpszKey);
199
200 protected:
201 CMap<WORD, WORD, CString, CString> m_mapVirtualKeys;
202 };
203
204 class _XTP_EXT_CLASS CKeyHelper
205 {
206 public:
211 CKeyHelper(const CXTPShortcutManagerAccel* lpAccel, CXTPShortcutManager* pManager = NULL);
212
217 virtual ~CKeyHelper();
218
219 public:
220 void Format(CString& str) const;
221 CString Format(const CXTPShortcutManagerAccel::SHORTCUTACCEL* pAccel) const;
222 int Priority();
223
224 static BOOL AFX_CDECL EqualAccels(const CXTPShortcutManagerAccel* pFirst,
225 const CXTPShortcutManagerAccel* pSecond)
226 {
227 return ((pFirst->key[0].fVirt | FNOINVERT) == (pSecond->key[0].fVirt | FNOINVERT))
228 && (pFirst->key[0].key == pSecond->key[0].key)
229 && ((pFirst->key[1].fVirt | FNOINVERT) == (pSecond->key[1].fVirt | FNOINVERT))
230 && (pFirst->key[1].key == pSecond->key[1].key);
231 }
232
233 CXTPShortcutManager* GetShortcutManager() const
234 {
235 return m_pManager;
236 }
237
243 static CString AFX_CDECL GetLocalKeyNameText(UINT uiVirtKey);
244
245 protected:
246 void AddVirtKeyStr(CString& str, UINT uiVirtKey, BOOL bLast = FALSE) const;
247
248 protected:
249 const CXTPShortcutManagerAccel* m_lpAccel;
250 CXTPShortcutManager* m_pManager;
251
252 public:
253 BOOL m_bAllowLocaleKey;
254 };
255
256# ifdef _XTP_INCLUDE_CONTROLS
257 class _XTP_EXT_CLASS CKeyAssign : public CXTPEdit
258# else
259 class _XTP_EXT_CLASS CKeyAssign : public CEdit
260# endif
261 {
262 public:
267 CKeyAssign(CXTPShortcutManager* pManager = NULL);
268
273 virtual ~CKeyAssign();
274
275 public:
276 BOOL IsKeyDefined() const;
277 CXTPShortcutManagerAccel* GetAccel();
278 void SetAccel(CXTPShortcutManagerAccel* pAccel);
279 void ResetKey();
280
281 protected:
282 void SetAccelFlag(int nKey, BYTE bFlag, BOOL bOn);
283 virtual BOOL PreTranslateMessage(MSG* pMsg);
284
285 BOOL TranslateDoubleKeyShortcutsMessage(MSG* pMsg);
286 BOOL TranslateSingleKeyShortcutsMessage(MSG* pMsg);
287
288 public:
289 BOOL m_bExtendedOnly;
290 BOOL m_bAllowDoubleKeyShortcuts;
291
292 protected:
293 int m_nKeyDefined;
294 CXTPShortcutManagerAccel m_accel;
295 CKeyHelper m_keyHelper;
296 };
304 CXTPShortcutManager(CXTPCommandBars* pCommandBars);
305
310 ~CXTPShortcutManager();
311
312public:
321 virtual BOOL FindDefaultAccelerator(int nCmd, CString& strShortcut);
322
331 BOOL FindDefaultFrameAccelerator(int nCmd, CString& strShortcut);
332
342 virtual CString Format(CXTPShortcutManagerAccel* lpAccel, int* pPriority);
343
352 virtual CString GetKeyNameText(UINT uiVirtKey);
353
362 virtual BOOL OnPreviewEditKey(CXTPShortcutManagerAccel* pAccel);
363
372 virtual BOOL OnBeforeAdd(CXTPShortcutManagerAccel* pAccel);
373
382 virtual BOOL OnBeforeRemove(CXTPShortcutManagerAccel* pAccel);
383
384public:
394 void SetKeyNameText(UINT uiVirtKey, LPCTSTR lpszKeyNameText);
395
405 void UseSystemKeyNameText(BOOL bSystemKey);
406
412 virtual void DisableShortcuts(BOOL bDisable);
413
421 virtual BOOL TranslateAccelerator(LPMSG lpMsg);
422
423public:
433 void SaveShortcuts(LPCTSTR lpszProfileName);
434
444 void LoadShortcuts(LPCTSTR lpszProfileName);
445
451 virtual void DoPropExchange(CXTPPropExchange* pPX);
452
458 void SetAccelerators(UINT nIDResource);
459
465 void SetDefaultAccelerator(HACCEL hAccelTable);
466
473 virtual CXTPShortcutManagerAccelTable* GetDefaultAccelerator() const;
474
481 CXTPShortcutManagerAccelTable* GetOriginalAccelerator() const;
482
487 virtual void Reset();
488
489public:
491 void CreateOriginalAccelTable();
492
493 static TCHAR AFX_CDECL ToUpper(TCHAR vkTCHAR);
494 static BOOL AFX_CDECL CompareAccelKey(TCHAR chAccel, UINT wParam);
495 static UINT AFX_CDECL AccelKeyToVirtualKey(TCHAR chAccel);
496 static int AFX_CDECL FindAccelPos(LPCTSTR lpszString);
497
498 void UpdateAcellTable(LPACCEL lpAccel, int nSize);
499 void UpdateAcellTable(XTP_SHORTCUTMANAGER_ACCEL* lpAccel, int nSize);
500
501 void SerializeShortcuts(CArchive& ar);
502 void AddShortcut(long fVirt, long key, long cmd);
503 void AddShortcut(long cmd, LPCTSTR lpszKey);
504 BOOL GetShortcut(int ID, CXTPShortcutManagerAccel* pAccel);
505
506 BOOL ParseShortcut(CString strShortcut, CXTPShortcutManagerAccel* accel);
507
508private:
509 BOOL ParseShortcut(CString strShortcutKey, BYTE& fVirt, WORD& key) const;
510 BOOL ParseShortcutVirtKey(CString& strShortcutKey, int nAccel) const;
511 BOOL IsAccelMessage(CXTPShortcutManagerAccel::SHORTCUTACCEL& accel, int nKeyState,
512 LPMSG lpMsg) const;
513 int GetAccelKeyState() const;
514
517# ifdef _XTP_COMMANDBARS_ACTIVEX
519protected:
520 DECLARE_DISPATCH_MAP()
521
522 DECLARE_OLETYPELIB_EX(CXTPShortcutManager);
523 DECLARE_CONNECTION_EX(CXTPShortcutManager)
524 DECLARE_INTERFACE_MAP();
525 DECLARE_ENUM_VARIANT(CXTPShortcutManager);
526
527 afx_msg void OleAdd(long fVirt, long key, long cmd);
528 afx_msg void OleAddShortcut(long cmd, LPCTSTR lpszShortcut);
529 afx_msg BOOL OleGetItemCount();
530 afx_msg LPDISPATCH OleGetItem(long Index);
531 afx_msg void OleDeleteAll();
532 afx_msg void OleDelete(long nID);
533 afx_msg BOOL OleGetEnabled();
534 afx_msg void OleSetEnahbled(BOOL Eanbled);
535 afx_msg BOOL OleGetEnableCustomShortcutText();
536 afx_msg void OleSetEnableCustomShortcutText(BOOL Eanbled);
537
538public:
539 afx_msg BOOL OleBeforeTranslate(long cmd);
540 LPDISPATCH OleFindShortcut(long nCmd);
541
542 enum {
543 dispidAdd = 1L,
544 };
546# endif
547
548public:
549 BOOL m_bAllowEscapeShortcut;
550 BOOL m_bUseSystemKeyNameText;
551 BOOL m_bAllowDoubleKeyShortcuts;
552 int m_nDisableShortcuts;
553 BOOL m_bDisableOnCapture;
555 BOOL m_nEnableCustomShortcutText;
558protected:
559 CXTPShortcutManagerAccelTable* m_pAccelTable;
560 CXTPShortcutManagerAccelTable* m_pOriginalAccelTable;
561 CXTPCommandBars* m_pCommandBars;
562 CKeyNameText* m_pKeyNameText;
564 friend class CKeyHelper;
565};
566
567AFX_INLINE CXTPShortcutManagerAccelTable* CXTPShortcutManager::GetDefaultAccelerator() const
568{
569 return m_pAccelTable;
570}
571AFX_INLINE CXTPShortcutManagerAccelTable* CXTPShortcutManager::GetOriginalAccelerator() const
572{
573 return m_pOriginalAccelTable;
574}
575AFX_INLINE void CXTPShortcutManager::UseSystemKeyNameText(BOOL bSystemKey)
576{
577 m_bUseSystemKeyNameText = bSystemKey;
578}
580# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
581#endif //#if !defined(__XTPSHORTCUTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPShortcutManagerAccel
CXTPShortcutManagerAccel represents an accelerator key used in an accelerator table.
Definition XTPShortcutManager.h:57
CXTPShortcutManagerAccel::CXTPShortcutManagerAccel
CXTPShortcutManagerAccel()
Constructs a CXTPShortcutManagerAccel object.
CXTPShortcutManagerAccelTable
CXTPShortcutManagerAccelTable represents an accelerator table for the CXTPShortcutManager class.
Definition XTPShortcutManager.h:92
CXTPShortcutManagerAccelTable::GetCount
int GetCount() const
Determines the count of accels in the table.
CXTPShortcutManagerAccelTable::m_arrAccels
CArray< CXTPShortcutManagerAccel *, CXTPShortcutManagerAccel * > m_arrAccels
Array of accels.
Definition XTPShortcutManager.h:179
CXTPShortcutManagerAccelTable::CopyAccelTable
void CopyAccelTable(LPACCEL lpAccel, int nSize)
Call this method to copy accels.
CXTPShortcutManagerAccelTable::CopyAccelTable
void CopyAccelTable(CXTPShortcutManagerAccelTable *pAccelTable)
Call this method to copy accels.
CXTPShortcutManagerAccelTable::CopyAccels
XTP_SHORTCUTMANAGER_ACCEL * CopyAccels() const
Call this method to create an array of all the elements in the table.
CXTPShortcutManagerAccelTable::GetAt
CXTPShortcutManagerAccel * GetAt(int nIndex) const
Retrieves an accel by its index.
CXTPShortcutManagerAccelTable::~CXTPShortcutManagerAccelTable
~CXTPShortcutManagerAccelTable()
Destroys a CXTPShortcutManagerAccelTable object, handles cleanup and deallocation.
CXTPShortcutManagerAccelTable::RemoveAll
void RemoveAll()
Removes all elements in the table.
CXTPShortcutManagerAccelTable::Add
void Add(const XTP_SHORTCUTMANAGER_ACCEL &accel)
Adds a new accelerator to the table.
CXTPShortcutManagerAccelTable::CXTPShortcutManagerAccelTable
CXTPShortcutManagerAccelTable(CXTPShortcutManager *pManager)
Constructs a CXTPShortcutManagerAccelTable object.
CXTPShortcutManagerAccelTable::m_pManager
CXTPShortcutManager * m_pManager
Parent manager.
Definition XTPShortcutManager.h:181
CXTPShortcutManagerAccelTable::CopyAccelTable
void CopyAccelTable(HACCEL hAccelTable)
Call this method to copy accels.
CXTPShortcutManagerAccelTable::RemoveAt
void RemoveAt(int nIndex)
Call this method to remove an accel by its index.
CXTPShortcutManager
CXTPShortcutManager is a standalone class used to manipulate accelerators of a frame.
Definition XTPShortcutManager.h:189
CXTPShortcutManager::m_bAllowDoubleKeyShortcuts
BOOL m_bAllowDoubleKeyShortcuts
TRUE to allow double key shortcuts(ex: Ctrl+K, Ctrl+V).
Definition XTPShortcutManager.h:551
CXTPShortcutManager::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPShortcutManager::SaveShortcuts
void SaveShortcuts(LPCTSTR lpszProfileName)
Call this function to save the accelerators to the registry or .INI file.
CXTPShortcutManager::~CXTPShortcutManager
~CXTPShortcutManager()
Destroys a CXTPShortcutManager object, handles cleanup and deallocation.
CXTPShortcutManager::m_pAccelTable
CXTPShortcutManagerAccelTable * m_pAccelTable
Accelerator table.
Definition XTPShortcutManager.h:559
CXTPShortcutManager::m_pOriginalAccelTable
CXTPShortcutManagerAccelTable * m_pOriginalAccelTable
Original accelerator table.
Definition XTPShortcutManager.h:560
CXTPShortcutManager::OnPreviewEditKey
virtual BOOL OnPreviewEditKey(CXTPShortcutManagerAccel *pAccel)
The OnPreviewEditKey function is called to determine if a user-defined shortcut is allowed.
CXTPShortcutManager::OnBeforeRemove
virtual BOOL OnBeforeRemove(CXTPShortcutManagerAccel *pAccel)
This method is called before the user removes a shortcut.
CXTPShortcutManager::Reset
virtual void Reset()
Call this member to reset shortcuts.
CXTPShortcutManager::Format
virtual CString Format(CXTPShortcutManagerAccel *lpAccel, int *pPriority)
This method is called to retrieve a text presentation of ACCEL.
CXTPShortcutManager::GetKeyNameText
virtual CString GetKeyNameText(UINT uiVirtKey)
This function retrieves a CString object that represents the name of a key.
CXTPShortcutManager::SetDefaultAccelerator
void SetDefaultAccelerator(HACCEL hAccelTable)
Call this member to set the accelerator table.
CXTPShortcutManager::m_bDisableOnCapture
BOOL m_bDisableOnCapture
Specifies whether the commandbars will process keybindings while another control is capturing input.
Definition XTPShortcutManager.h:553
CXTPShortcutManager::CXTPShortcutManager
CXTPShortcutManager(CXTPCommandBars *pCommandBars)
Constructs a CXTPShortcutManager object.
CXTPShortcutManager::SetAccelerators
void SetAccelerators(UINT nIDResource)
Call this member to create original accelerators.
CXTPShortcutManager::DisableShortcuts
virtual void DisableShortcuts(BOOL bDisable)
This method is called to disable/enable shortcuts usage.
CXTPShortcutManager::GetOriginalAccelerator
CXTPShortcutManagerAccelTable * GetOriginalAccelerator() const
Call this member to get original accelerators.
Definition XTPShortcutManager.h:571
CXTPShortcutManager::FindDefaultAccelerator
virtual BOOL FindDefaultAccelerator(int nCmd, CString &strShortcut)
Retrieves the shortcut text for a specified command.
CXTPShortcutManager::m_pCommandBars
CXTPCommandBars * m_pCommandBars
Parent CommandBars pointer.
Definition XTPShortcutManager.h:561
CXTPShortcutManager::UseSystemKeyNameText
void UseSystemKeyNameText(BOOL bSystemKey)
Call this member to use system localized shortcuts.
Definition XTPShortcutManager.h:575
CXTPShortcutManager::m_nEnableCustomShortcutText
BOOL m_nEnableCustomShortcutText
TRUE to allow adding custom text to be displayed as a shortcut.
Definition XTPShortcutManager.h:555
CXTPShortcutManager::OnBeforeAdd
virtual BOOL OnBeforeAdd(CXTPShortcutManagerAccel *pAccel)
This method is called before the user adds a new shortcut.
CXTPShortcutManager::FindDefaultFrameAccelerator
BOOL FindDefaultFrameAccelerator(int nCmd, CString &strShortcut)
Retrieves the default shortcut for a specified command.
CXTPShortcutManager::LoadShortcuts
void LoadShortcuts(LPCTSTR lpszProfileName)
Call this function to retrieve accelerators from the registry or .INI file.
CXTPShortcutManager::SetKeyNameText
void SetKeyNameText(UINT uiVirtKey, LPCTSTR lpszKeyNameText)
Call this member to localize the name text of a shortcut key.
CXTPShortcutManager::GetDefaultAccelerator
virtual CXTPShortcutManagerAccelTable * GetDefaultAccelerator() const
Call this member to get the accelerator table.
Definition XTPShortcutManager.h:567
CXTPShortcutManager::m_nDisableShortcuts
int m_nDisableShortcuts
Number of shortcuts that have been disabled.
Definition XTPShortcutManager.h:552
CXTPShortcutManager::m_bAllowEscapeShortcut
BOOL m_bAllowEscapeShortcut
TRUE to allow escape to be used as a shortcut.
Definition XTPShortcutManager.h:549
CXTPShortcutManager::m_bUseSystemKeyNameText
BOOL m_bUseSystemKeyNameText
TRUE to use localized shortcuts.
Definition XTPShortcutManager.h:550
CXTPShortcutManager::TranslateAccelerator
virtual BOOL TranslateAccelerator(LPMSG lpMsg)
The TranslateAccelerator function processes accelerator keys for menu commands.
CXTPShortcutManager::m_pKeyNameText
CKeyNameText * m_pKeyNameText
KeyNameText map.
Definition XTPShortcutManager.h:562


Toolkit Pro: XTPPoint3.h Source File

  • Source
  • Common
  • Base
  • Types
XTPPoint3.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOINT3_H__)
24# define __XTPPOINT3_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33template<class T>
34class CXTPPoint3T;
35
39typedef CXTPPoint3T<int> CXTPPoint3i;
40
44typedef CXTPPoint3T<float> CXTPPoint3f;
45
49typedef CXTPPoint3T<double> CXTPPoint3d;
50
56template<class T>
57class CXTPPoint3T
58{
59public:
64 CXTPPoint3T()
65 : X(T(0))
66 , Y(T(0))
67 , Z(T(0))
68 {
69 }
70
78 CXTPPoint3T(T x, T y, T z = T(0))
79 : X(x)
80 , Y(y)
81 , Z(z)
82 {
83 }
84
90 CXTPPoint3T(const CXTPPoint2i& point)
91 : X(T(point.X))
92 , Y(T(point.Y))
93 , Z(T(0))
94 {
95 }
96
102 CXTPPoint3T(const CXTPPoint2f& point)
103 : X(T(point.X))
104 , Y(T(point.Y))
105 , Z(T(0))
106 {
107 }
108
114 CXTPPoint3T(const CXTPPoint2d& point)
115 : X(T(point.X))
116 , Y(T(point.Y))
117 , Z(T(0))
118 {
119 }
120
126 CXTPPoint3T(const CXTPPoint3i& point)
127 : X(T(point.X))
128 , Y(T(point.Y))
129 , Z(T(point.Z))
130 {
131 }
132
138 CXTPPoint3T(const CXTPPoint3f& point)
139 : X(T(point.X))
140 , Y(T(point.Y))
141 , Z(T(point.Z))
142 {
143 }
144
150 CXTPPoint3T(const CXTPPoint3d& point)
151 : X(T(point.X))
152 , Y(T(point.Y))
153 , Z(T(point.Z))
154 {
155 }
156
163 operator CXTPPoint2i() const
164 {
165 return CXTPPoint2i(int(X), int(Y));
166 }
167
174 operator CXTPPoint2f() const
175 {
176 return CXTPPoint2f(float(X), float(Y));
177 }
178
185 operator CXTPPoint2d() const
186 {
187 return CXTPPoint2d(double(X), double(Y));
188 }
189
196 operator CXTPPoint3i() const
197 {
198 return CXTPPoint3i(int(X), int(Y), int(Z));
199 }
200
207 operator CXTPPoint3f() const
208 {
209 return CXTPPoint3f(float(X), float(Y), float(Z));
210 }
211
218 operator CXTPPoint3d() const
219 {
220 return CXTPPoint3d(double(X), double(Y), double(Z));
221 }
222
230 void SetPoint(T x, T y, T z = T(0))
231 {
232 X = x;
233 Y = y;
234 Z = z;
235 }
236
245 void Offset(T dx, T dy, T dz = T(0))
246 {
247 X += dx;
248 Y += dy;
249 Z += dz;
250 }
251
258 CXTPPoint3T<int> Round() const
259 {
260 return CXTPPoint3T<int>(CXTPMathUtils::Round(double(X)), CXTPMathUtils::Round(double(Y)),
261 CXTPMathUtils::Round(double(Z)));
262 }
263
271 bool operator==(const CXTPPoint3T& point) const
272 {
273 return (&point == this) || (X == point.X && Y == point.Y && Z == point.Z);
274 }
275
283 bool operator!=(const CXTPPoint3T& point) const
284 {
285 return !(*this == point);
286 }
287
294 bool IsZero() const
295 {
296 return (T(0) == X && T(0) == Y && T(0) == Z);
297 }
298
299public:
300 T X;
301 T Y;
302 T Z;
303};
304
305# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
307#endif //#if !defined(__XTPPOINT3_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPoint2i
CXTPPoint2T< int > CXTPPoint2i
CXTPPoint2T shortcut for integer point object.
Definition XTPPoint2.h:39
CXTPPoint2f
CXTPPoint2T< float > CXTPPoint2f
CXTPPoint2T shortcut for float point object.
Definition XTPPoint2.h:44
CXTPPoint2d
CXTPPoint2T< double > CXTPPoint2d
CXTPPoint2T shortcut for double point object.
Definition XTPPoint2.h:49
CXTPPoint3d
CXTPPoint3T< double > CXTPPoint3d
CXTPPoint3T shortcut for double point object.
Definition XTPPoint3.h:49
CXTPPoint3f
CXTPPoint3T< float > CXTPPoint3f
CXTPPoint3T shortcut for float point object.
Definition XTPPoint3.h:44
CXTPPoint3i
CXTPPoint3T< int > CXTPPoint3i
CXTPPoint3T shortcut for integer point object.
Definition XTPPoint3.h:39
CXTPMathUtils::Round
static int AFX_CDECL Round(double dValue)
Rounds a real value taking into account its sign and returns result as integer.
CXTPPoint2T< int >
CXTPPoint3T
This class represents a three-dimensional point.
Definition XTPPoint3.h:58
CXTPPoint3T::Offset
void Offset(T dx, T dy, T dz=T(0))
Offsets the point to another location.
Definition XTPPoint3.h:245
CXTPPoint3T::operator!=
bool operator!=(const CXTPPoint3T &point) const
Compares two points.
Definition XTPPoint3.h:283
CXTPPoint3T::SetPoint
void SetPoint(T x, T y, T z=T(0))
Sets point component values.
Definition XTPPoint3.h:230
CXTPPoint3T::operator==
bool operator==(const CXTPPoint3T &point) const
Compares two points.
Definition XTPPoint3.h:271
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T(const CXTPPoint2d &point)
Constructs a CXTPPoint3T object from CXTPPoint2d point.
Definition XTPPoint3.h:114
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T(const CXTPPoint3f &point)
Constructs a CXTPPoint3T object from CXTPPoint3f object.
Definition XTPPoint3.h:138
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T(const CXTPPoint3d &point)
Constructs a CXTPPoint3T object from CXTPPoint3d object.
Definition XTPPoint3.h:150
CXTPPoint3T::IsZero
bool IsZero() const
Determines if the point object is zero, i.e.
Definition XTPPoint3.h:294
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T()
Constructs an empty CXTPPoint3T object with all components equal to 0.
Definition XTPPoint3.h:64
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T(const CXTPPoint2i &point)
Constructs a CXTPPoint3T object from CXTPPoint2i point.
Definition XTPPoint3.h:90
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T(T x, T y, T z=T(0))
Constructs a CXTPPoint3T object.
Definition XTPPoint3.h:78
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T(const CXTPPoint2f &point)
Constructs a CXTPPoint3T object from CXTPPoint2f point.
Definition XTPPoint3.h:102
CXTPPoint3T::Z
T Z
The Z coordinate.
Definition XTPPoint3.h:302
CXTPPoint3T::CXTPPoint3T
CXTPPoint3T(const CXTPPoint3i &point)
Constructs a CXTPPoint3T object from CXTPPoint3i object.
Definition XTPPoint3.h:126
CXTPPoint3T::Round
CXTPPoint3T< int > Round() const
Rounds point to integer values.
Definition XTPPoint3.h:258
CXTPPoint3T::Y
T Y
The Y coordinate.
Definition XTPPoint3.h:301
CXTPPoint3T::X
T X
The X coordinate.
Definition XTPPoint3.h:300


XTP_CALENDAR_VIEWSELECTION Member List

This is the complete list of members for XTP_CALENDAR_VIEWSELECTION, including all inherited members.

bAllDayEvent | XTP_CALENDAR_VIEWSELECTION |
dtBegin | XTP_CALENDAR_VIEWSELECTION |
dtEnd | XTP_CALENDAR_VIEWSELECTION |
IsValid() const | XTP_CALENDAR_VIEWSELECTION | inline
nGroupIndex | XTP_CALENDAR_VIEWSELECTION |
operator=(const XTP_CALENDAR_VIEWSELECTION &rSrc) | XTP_CALENDAR_VIEWSELECTION | inline
XTP_CALENDAR_VIEWSELECTION() | XTP_CALENDAR_VIEWSELECTION | inline


Toolkit Pro: XTPCommandBarScrollBarCtrl.h Source File

  • Source
  • CommandBars
  • ScrollBar
XTPCommandBarScrollBarCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSCROLLBARCTRL_H__)
24# define __XTPCOMMANDBARSCROLLBARCTRL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPCommandBarScrollBarCtrl : public CXTPScrollBarCtrl
38{
39public:
44 CXTPCommandBarScrollBarCtrl();
45
51 virtual ~CXTPCommandBarScrollBarCtrl();
52
53public:
59 void SetCommandBars(CXTPCommandBars* pCommandBars);
60
61protected:
62 virtual CXTPScrollBarPaintManager* GetScrollBarPaintManager() const;
63
64protected:
66 DECLARE_MESSAGE_MAP()
68 //{{AFX_MSG(CXTPCommandBarScrollBarCtrl)
69 //}}AFX_MSG
70
71protected:
72 CXTPCommandBars* m_pCommandBars;
73};
74
75AFX_INLINE void CXTPCommandBarScrollBarCtrl::SetCommandBars(CXTPCommandBars* pCommandBars)
76{
77 m_pCommandBars = pCommandBars;
78}
79
81# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
82#endif // !defined(__XTPCOMMANDBARSCROLLBARCTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarScrollBarCtrl
CXTPCommandBarScrollBarCtrl is a CScrollBar derived class.
Definition XTPCommandBarScrollBarCtrl.h:38
CXTPCommandBarScrollBarCtrl::CXTPCommandBarScrollBarCtrl
CXTPCommandBarScrollBarCtrl()
Constructs a CXTPCommandBarScrollBarCtrl object.
CXTPCommandBarScrollBarCtrl::~CXTPCommandBarScrollBarCtrl
virtual ~CXTPCommandBarScrollBarCtrl()
Destroys a CXTPCommandBarScrollBarCtrl object, handles cleanup and deallocation.
CXTPCommandBarScrollBarCtrl::GetScrollBarPaintManager
virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager() const
Obtains a pointer to the associated scrollbar paint manager.
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPScrollBarCtrl
Scrollbar control.
Definition XTPScrollBarCtrl.h:48
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40


CXTPChartBarSeriesLabelView Member List

This is the complete list of members for CXTPChartBarSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartBarSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint) | CXTPChartBarSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, CXTPChartPointF ptCenterPoint, const CXTPChartString &text) | CXTPChartBarSeriesLabelView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartPointF &ptAnchorPoint, double dAnchorAngle, const CXTPChartString &text) | CXTPChartBarSeriesLabelView | virtual
CXTPChartBarSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartBarSeriesLabelView |
CXTPChartDiagram2DSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartDiagram2DSeriesLabelView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAnchorPoint() const | CXTPChartBarSeriesLabelView | virtual
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


Toolkit Pro: XTPMarkupListBox.h Source File

  • Source
  • Controls
  • ListBox
XTPMarkupListBox.h
Go to the documentation of this file.
1
23#if !defined(__MARKUPLISTBOX_H__) && defined(_XTP_INCLUDE_MARKUP)
24# define __MARKUPLISTBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupUIElement;
34class CXTPMarkupContext;
35
36struct _XTP_EXT_CLASS XTP_MARKUP_LISTITEM
37{
38public:
39 XTP_MARKUP_LISTITEM(CXTPMarkupContext* pContext);
40
41 virtual ~XTP_MARKUP_LISTITEM();
42
43public:
44 void Resolve(LPCTSTR lpszMarkup);
45
46 CString strMarkup;
47 CXTPMarkupUIElement* pItem;
48 CXTPMarkupContext* pContext;
49};
50
51class _XTP_EXT_CLASS CXTPMarkupListBox
52 : public CXTPListBox
53 , public CXTPMarkupContext
54{
55public:
56 CXTPMarkupListBox();
57
58 virtual ~CXTPMarkupListBox();
59
60 //{{AFX_VIRTUAL(CXTPMarkupListBox)
61 virtual void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
62 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
63 virtual void DeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct);
64 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
65 using CXTPMarkupContext::OnWndMsg;
66 //}}AFX_VIRTUAL
67
68public:
69 CXTPMarkupContext* GetMarkupContext()
70 {
71 return this;
72 }
73
74 void Init();
75
76 void ItemChanged(XTP_MARKUP_LISTITEM* pItem);
77
78 void AddMarkupString(LPCTSTR lpszMarkup);
79
80protected:
81 //{{AFX_MSG(CXTPMarkupListBox)
82 afx_msg void OnSize(UINT nType, int cx, int cy);
83 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
84 //}}AFX_MSG
85
86 DECLARE_MESSAGE_MAP()
87};
88
90
91//{{AFX_INSERT_LOCATION}}
92
93# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
95#endif // !defined(__MARKUPLISTBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPTrackThemeOffice2003.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEOffice2003_H__)
24# define __XTPTRACKTHEMEOffice2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeOffice2003 : public CXTPTrackPaintManager
39{
40public:
45 CXTPTrackThemeOffice2003();
46
58 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
59 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
60 CXTPGridHeader* pHeader = NULL);
61
84 virtual void DrawColumn(CDC* pDC, CXTPGridColumn* pColumn, CXTPGridHeader* pHeader,
85 CRect rcColumn, BOOL bDrawExternal = FALSE, int nShadowWidth = 0);
86
99 void DrawSectionDivider(CDC* pDC, const CRect& rc,
100 XTPGridSectionDividerPosition dividerPosition,
101 XTPGridSectionDividerStyle dividerStyle,
102 CXTPPaintManagerColor dividerColor);
103};
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
106#endif //#if !defined(__XTPTRACKTHEMEOffice2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackThemeOffice2003
CXTPTrackThemeOffice2003 is a CXTPTrackPaintManager derived class that represents an Office 2003 styl...
Definition XTPTrackThemeOffice2003.h:39
CXTPTrackThemeOffice2003::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPTrackThemeOffice2003::DrawColumn
virtual void DrawColumn(CDC *pDC, CXTPGridColumn *pColumn, CXTPGridHeader *pHeader, CRect rcColumn, BOOL bDrawExternal=FALSE, int nShadowWidth=0)
Draws a column header with all related attributes (sort order, icon, etc.).
CXTPTrackThemeOffice2003::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPTrackThemeOffice2003::CXTPTrackThemeOffice2003
CXTPTrackThemeOffice2003()
Default paint manager constructor, handles properties initialization.


Toolkit Pro: XTPDatePickerOfficeXPTheme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerOfficeXPTheme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKEROFFICEXPTHEME_H__)
23# define _XTPDATEPICKEROFFICEXPTHEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeOfficeXP : public CXTPDatePickerPaintManager
52{
53public:
62 CXTPDatePickerThemeOfficeXP();
63
70 virtual ~CXTPDatePickerThemeOfficeXP();
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(_XTPDATEPICKEROFFICEXPTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55
CXTPDatePickerThemeOfficeXP
Class CXTPDatePickerThemeOfficeXP is derived from CXTPDatePickerPaintManager for rendering an Office ...
Definition XTPDatePickerOfficeXPTheme.h:52
CXTPDatePickerThemeOfficeXP::CXTPDatePickerThemeOfficeXP
CXTPDatePickerThemeOfficeXP()
Default paint manager constructor.
CXTPDatePickerThemeOfficeXP::~CXTPDatePickerThemeOfficeXP
virtual ~CXTPDatePickerThemeOfficeXP()
Default paint manager destructor.


CXTPCalendarEventLabelComboBox Member List

This is the complete list of members for CXTPCalendarEventLabelComboBox, including all inherited members.

CalcColorRect(CRect rItem) | CXTPCalendarComboBoxBase | protectedvirtual
CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase |
DrawItem(LPDRAWITEMSTRUCT lpDIS) | CXTPCalendarEventLabelComboBox | protectedvirtual
GetLabelID() const | CXTPCalendarEventLabelComboBox | virtual
GetLabelID(int nID) const | CXTPCalendarEventLabelComboBox | virtual
Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme) | CXTPCalendarEventLabelComboBox | virtual
MeasureItem(LPMEASUREITEMSTRUCT lpMIS) | CXTPCalendarComboBoxBase | protectedvirtual
SetLabelID(int nID) | CXTPCalendarEventLabelComboBox | virtual
~CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase | virtual


CXTPDockingPaneOffice2003OutlookTheme Member List

This is the complete list of members for CXTPDockingPaneOffice2003OutlookTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2003OutlookTheme() | CXTPDockingPaneOffice2003OutlookTheme |
CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneOffice2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPaneOffice2003OutlookTheme | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawGripper | CXTPDockingPaneOffice2003Theme |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bRoundedCaption | CXTPDockingPaneOffice2003Theme | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2003OutlookTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneOffice2003OutlookTheme() | CXTPDockingPaneOffice2003OutlookTheme | virtual
~CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: XTPArcBall.h Source File

  • Source
  • Common
  • Math
XTPArcBall.h
Go to the documentation of this file.
1
23#if !defined(__XTPARCBALL_H__)
24# define __XTPARCBALL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
42class _XTP_EXT_CLASS CXTPArcBall
43{
44public:
49 CXTPArcBall();
50
59 void SetBounds(double dWidth, double dHeight);
60
69 BOOL HasBounds() const;
70
80 void SetBegin(double x, double y);
81
91 void SetEnd(double x, double y);
92
102 void GetRotationQuaternion(double& xQuat, double& yQuat, double& zQuat, double& wQuat);
103
104private:
105 void MapToSphere(double x, double y, CXTPPoint3d& vSphere);
106
107private:
108 CXTPPoint3d m_vBegin;
109 CXTPPoint3d m_vEnd;
110 double m_dWidthAdjustmentFactor;
111 double m_dHeightAdjustmentFactor;
112};
113
114# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
116#endif //#if !defined(__XTPARCBALL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPArcBall
Implements natural object rotation computation using quaternions.
Definition XTPArcBall.h:43
CXTPArcBall::HasBounds
BOOL HasBounds() const
Determines if object bounds have been set.
CXTPArcBall::CXTPArcBall
CXTPArcBall()
Constructs an empy arc-ball object.
CXTPArcBall::SetBegin
void SetBegin(double x, double y)
Sets initial rotation point that is mapped from 2D space onto a 3D sphere determined by object bounds...
CXTPArcBall::SetBounds
void SetBounds(double dWidth, double dHeight)
Sets object bounds.
CXTPArcBall::GetRotationQuaternion
void GetRotationQuaternion(double &xQuat, double &yQuat, double &zQuat, double &wQuat)
Obtains rotation quaternion parameters based on the mapped rotation starting and ending points.
CXTPArcBall::SetEnd
void SetEnd(double x, double y)
Sets final rotation point that is mapped from 2D space onto a 3D sphere determined by object bounds.
CXTPPoint3T< double >


CXTPChartLegend Member List

This is the complete list of members for CXTPChartLegend, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView) | CXTPChartLegend | virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartLegend(CXTPChartContent *pOwner) | CXTPChartLegend |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartLegend | protectedvirtual
GetActualBackgroundColor() const | CXTPChartLegend |
GetActualBorderColor() const | CXTPChartLegend |
GetActualTextColor() const | CXTPChartLegend |
GetAntialiasing() const | CXTPChartLegend | virtual
GetAppearance() const | CXTPChartElement |
GetBackgroundColor() const | CXTPChartLegend |
GetBorder() const | CXTPChartLegend |
GetContent() const | CXTPChartElement |
GetDirection() const | CXTPChartLegend |
GetFillStyle() const | CXTPChartLegend |
GetFont() const | CXTPChartLegend | virtual
GetHorizontalAlignment() const | CXTPChartLegend |
GetMarkerSize() const | CXTPChartLegend |
GetOwner() const | CXTPChartElement |
GetSortDirection() const | CXTPChartLegend |
GetTextColor() const | CXTPChartLegend |
GetVerticalAlignment() const | CXTPChartLegend |
Is3D() const | CXTPChartObject |
IsMarkerVisible() const | CXTPChartLegend |
IsVisible() const | CXTPChartLegend |
m_bAntialiasing | CXTPChartLegend |
m_bMarkerVisible | CXTPChartLegend |
m_bVisible | CXTPChartLegend |
m_clrBackgroundColor | CXTPChartLegend |
m_clrTextColor | CXTPChartLegend |
m_nColumnCount | CXTPChartLegend |
m_nDirection | CXTPChartLegend |
m_nHorizontalAlignment | CXTPChartLegend |
m_nSortDirection | CXTPChartLegend |
m_nVerticalAlignment | CXTPChartLegend |
m_pBorder | CXTPChartLegend |
m_pFillStyle | CXTPChartLegend |
m_pFont | CXTPChartLegend |
m_szMarkerSize | CXTPChartLegend |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartLegend |
SetBackgroundColor(const CXTPChartColor &clrBackgroundColor) | CXTPChartLegend |
SetDirection(XTPChartLegendDirection nDirection) | CXTPChartLegend |
SetFont(CXTPChartFont *pFont) | CXTPChartLegend |
SetHorizontalAlignment(XTPChartLegendAlignment nAlignment) | CXTPChartLegend |
SetMarkerSize(CSize sz) | CXTPChartLegend |
SetMarkerVisible(BOOL bVisible) | CXTPChartLegend |
SetSortDirection(XTPChartLegendSortDirection value) | CXTPChartLegend |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartLegend |
SetVerticalAlignment(XTPChartLegendAlignment nAlignment) | CXTPChartLegend |
SetVisible(BOOL bVisible) | CXTPChartLegend |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartLegend() | CXTPChartLegend | virtual


CXTPDockingPanePanelPaintManager Member List

This is the complete list of members for CXTPDockingPanePanelPaintManager, including all inherited members.

_GetButtonLength(int nValue, int nMin, int nMax) | CXTPTabPaintManager | protected
AddObserver(CXTPTabManagerAtom *pObserver) | CXTPTabPaintManager |
AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTabPaintManager(BOOL bPanelManager=FALSE) | CXTPTabPaintManager |
DisableLunaColors(BOOL bDisableLunaColors) | CXTPTabPaintManager |
DrawNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabPaintManager | virtual
DrawSingleButtonIconAndText(CDC *pDC, CXTPTabManagerItem *pItem, CRect rcItem, BOOL bDraw) | CXTPTabPaintManager | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | virtual
DrawTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | protected
DrawTextPathEllipsis(CDC *pDC, CXTPTabManager *pManager, const CString &strItem, CRect rcItem, UINT uFormat) | CXTPTabPaintManager | protected
EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways) | CXTPTabPaintManager |
EnsureVisible(CXTPTabManager *pTabManager, CXTPTabManagerItem *pItem) | CXTPTabPaintManager |
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAppearance() const | CXTPTabPaintManager |
GetAppearanceSet() const | CXTPTabPaintManager |
GetBoldFont(BOOL bVertical=FALSE) | CXTPTabPaintManager |
GetColor() const | CXTPTabPaintManager |
GetColorSet() const | CXTPTabPaintManager |
GetFont(BOOL bVertical=FALSE) | CXTPTabPaintManager |
GetLayout() const | CXTPTabPaintManager |
GetOneNoteColor(XTPTabOneNoteColor tabColor) | CXTPTabPaintManager | static
GetPosition() const | CXTPTabPaintManager |
IsLunaColorsDisabled() const | CXTPTabPaintManager |
m_arrObservers | CXTPTabPaintManager | protected
m_bBoldNormal | CXTPTabPaintManager |
m_bBoldSelected | CXTPTabPaintManager |
m_bClearTypeTextQuality | CXTPTabPaintManager |
m_bClipHeader | CXTPTabPaintManager |
m_bDrawFocusRect | CXTPTabPaintManager |
m_bDrawTextEndEllipsis | CXTPTabPaintManager |
m_bDrawTextHidePrefix | CXTPTabPaintManager |
m_bDrawTextNoPrefix | CXTPTabPaintManager |
m_bDrawTextPathEllipsis | CXTPTabPaintManager |
m_bFillBackground | CXTPTabPaintManager |
m_bHotTracking | CXTPTabPaintManager |
m_bInvertGradient | CXTPTabPaintManager |
m_bMultiRowFixedSelection | CXTPTabPaintManager |
m_bMultiRowJustified | CXTPTabPaintManager |
m_bMultiRowTabsOptimization | CXTPTabPaintManager |
m_bOneNoteColors | CXTPTabPaintManager |
m_bPanelManager | CXTPTabPaintManager |
m_bRotateImageOnVerticalDraw | CXTPTabPaintManager |
m_bSelectOnButtonDown | CXTPTabPaintManager |
m_bSelectOnDragOver | CXTPTabPaintManager |
m_bShowIcons | CXTPTabPaintManager |
m_bShowTabs | CXTPTabPaintManager |
m_bStaticFrame | CXTPTabPaintManager |
m_bUseStandardFont | CXTPTabPaintManager | protected
m_bVerticalTextTopToBottom | CXTPTabPaintManager |
m_clientFrame | CXTPTabPaintManager |
m_nButtonExtraLength | CXTPTabPaintManager |
m_nDrawTextFormat | CXTPTabPaintManager |
m_nFixedTabWidth | CXTPTabPaintManager |
m_nMaxTabWidth | CXTPTabPaintManager |
m_nMinTabWidth | CXTPTabPaintManager |
m_nSelectOnDragOverDelay | CXTPTabPaintManager | static
m_pAppearanceSet | CXTPTabPaintManager | protected
m_pColorSet | CXTPTabPaintManager | protected
m_rcButtonMargin | CXTPTabPaintManager |
m_rcButtonTextPadding | CXTPTabPaintManager |
m_rcClientMargin | CXTPTabPaintManager |
m_rcControlMargin | CXTPTabPaintManager |
m_szIcon | CXTPTabPaintManager |
m_szNavigateButton | CXTPTabPaintManager |
m_szTabCloseButton | CXTPTabPaintManager |
m_tabAppearance | CXTPTabPaintManager | protected
m_tabColor | CXTPTabPaintManager | protected
m_tabLayout | CXTPTabPaintManager | protected
m_tabPosition | CXTPTabPaintManager | protected
m_toolBehaviour | CXTPTabPaintManager |
m_xtpFontBold | CXTPTabPaintManager | protected
m_xtpFontNormal | CXTPTabPaintManager | protected
m_xtpFontVerticalBold | CXTPTabPaintManager | protected
m_xtpFontVerticalNormal | CXTPTabPaintManager | protected
OnPropertyChanged() | CXTPTabPaintManager | protectedvirtual
RefreshMetrics() | CXTPTabPaintManager | virtual
RepositionNavigateButtons(CXTPTabManager *pTabManager, CRect rcClient) | CXTPTabPaintManager |
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManager | virtual
RepositionTabControlEx(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManager | protected
RepositionTabControlMultiRow(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManager | protected
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPDockingPanePanelPaintManager | virtual
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabPaintManager | virtual
SetColor(XTPTabColorStyle tabColor) | CXTPDockingPanePanelPaintManager | virtual
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabPaintManager | virtual
SetFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPTabPaintManager |
SetLayout(XTPTabLayoutStyle tabLayout) | CXTPTabPaintManager |
SetOneNoteColors(BOOL bOneNoteColors) | CXTPTabPaintManager |
SetPosition(XTPTabPosition tabPosition) | CXTPTabPaintManager |
SizeToFit(CXTPTabManager *pTabManager, int nWidth) | CXTPTabPaintManager | protected
~CXTPTabPaintManager() | CXTPTabPaintManager | virtual


Toolkit Pro: XTPDockingPaneLayout.h Source File

  • Source
  • DockingPane
XTPDockingPaneLayout.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANELAYOUT_H__)
24# define __XTPDOCKINGPANELAYOUT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPaneBase;
34class CXTPDockingPaneSplitterContainer;
35class CXTPDockingPaneBase;
36class CXTPDockingPaneAutoHidePanel;
37class CXTPDockingPaneManager;
38class CXTPPropExchange;
39class CXTPDockingPaneTabbedContainer;
40class CXTPDockingPaneSplitterWnd;
41class CXTPDockingPaneClientContainer;
42
43namespace XTPXML
44{
45struct IXMLDOMNode;
46};
47
53class _XTP_EXT_CLASS CXTPDockingPaneLayout : public CXTPCmdTarget
54{
55 DECLARE_DYNAMIC(CXTPDockingPaneLayout);
56
57public:
63 CXTPDockingPaneLayout(CXTPDockingPaneManager* pManager);
64
69 virtual ~CXTPDockingPaneLayout();
70
71public:
77 void Copy(const CXTPDockingPaneLayout* pLayout);
78
84 void Save(LPCTSTR lpszSection);
85
93 BOOL Load(LPCTSTR lpszSection);
94
103 CXTPDockingPaneInfoList& GetPaneList() const;
104
110 void Serialize(CArchive& ar);
111
112# ifndef _XTP_EXCLUDE_XML
113
120 void SaveToFile(LPCTSTR lpszFileName, LPCTSTR lpszSection);
121
130 BOOL LoadFromFile(LPCTSTR lpszFileName, LPCTSTR lpszSection);
131
138 void SaveToNode(XTPXML::IXMLDOMNode* pNode, LPCTSTR lpszSection);
139
148 BOOL LoadFromNode(XTPXML::IXMLDOMNode* pNode, LPCTSTR lpszSection);
149
150# endif
151
158 BOOL IsUserLayout() const;
159
166 BOOL IsValid() const;
167
168public:
169 void DestroyPane(CXTPDockingPane* pPane);
170
171 CXTPDockingPane* FindPane(int nID) const;
172
173public:
181 BOOL DoPropExchange(CXTPPropExchange* pPX);
182
183private:
184 void Push(CXTPDockingPaneBase* pPane)
185 {
186 m_lstStack.AddTail(pPane);
187 }
188 void HidePane(CXTPDockingPaneBase* pPane);
189 void OnSizeParent(CWnd* pParent, CRect rect, LPVOID lParam);
190 void Free();
191 void _FreeEmptyPanes();
192 XTPDockingPaneDirection _GetPaneDirection(const CXTPDockingPaneBase* pPane) const;
193
194 void _Save(CXTPPropExchange* pPX);
195 BOOL _Load(CXTPPropExchange* pPX);
196 BOOL _FindTabbedPaneToHide(CXTPDockingPaneAutoHidePanel* pPanel, CXTPDockingPaneBase* pPane);
197 void _AddPanesTo(CXTPDockingPaneTabbedContainer* pContainer, CXTPDockingPaneBaseList& lst,
198 DWORD dwIgnoredOptions);
199
200 void MoveToTail(CXTPDockingPaneBase* pBase);
201
202private:
203 CXTPDockingPaneSplitterContainer* m_pTopContainer;
204 CXTPDockingPaneBase* m_pClient;
205
206 CXTPDockingPaneInfoList m_lstPanes;
207 CXTPDockingPaneBaseList m_lstStack;
208
209 XTP_DOCKINGPANE_INFO* FindPaneInfo(CXTPDockingPane* pPane);
210 void RepositionMargins(CRect& rect, const CRect& lpszClientMargins);
211
212 CXTPDockingPaneAutoHidePanel* m_wndPanels[4];
213 CXTPDockingPaneSplitterWnd* m_wndMargins[4];
214
215 BOOL m_bUserLayout;
216 CXTPDockingPaneManager* m_pManager;
217
218# ifdef _XTP_ACTIVEX
220 DECLARE_DISPATCH_MAP()
221 DECLARE_INTERFACE_MAP()
222 DECLARE_OLETYPELIB_EX(CXTPDockingPaneLayout);
223 DECLARE_ENUM_VARIANT(CXTPDockingPaneLayout);
224
225public:
226 void OleDoPropExchange(LPDISPATCH lpPropExchage);
227 long OleGetItemCount();
228 LPDISPATCH OleGetItem(int nIndex);
229 LPDISPATCH OleGetPane(int nIndex);
230 long CXTPDockingPaneLayout::OleGetContainersCount();
231 LPDISPATCH CXTPDockingPaneLayout::OleGetContainer(int nIndex);
232 long OleGetPaneCount();
233 LPDISPATCH OleGetClientContainer();
234 LPDISPATCH OleGetTopContainer();
235
236 static CXTPDockingPaneLayout* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
237
239# endif /*_XTP_ACTIVEX*/
240
241private:
242 friend class CXTPDockingPaneManager;
243 friend class CXTPDockingPaneBase;
244 friend class CXTPDockingPane;
245 friend class CXTPDockingPaneAutoHidePanel;
246 friend class CDockingPaneSite;
247 friend class CDockingPaneCtrl;
248 friend class CXTPDockingPaneSidePanel;
249};
250
251AFX_INLINE BOOL CXTPDockingPaneLayout::IsUserLayout() const
252{
253 return m_bUserLayout;
254}
255AFX_INLINE CXTPDockingPaneInfoList& CXTPDockingPaneLayout::GetPaneList() const
256{
257 return (CXTPDockingPaneInfoList&)m_lstPanes;
258}
260# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
261#endif // #if !defined(__XTPDOCKINGPANELAYOUT_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
CXTPDockingPaneInfoList
CList< XTP_DOCKINGPANE_INFO, XTP_DOCKINGPANE_INFO & > CXTPDockingPaneInfoList
This list is used by the CXTPDockingPaneLayout class for maintaining an XTP_DOCKINGPANE_INFO collecti...
Definition XTPDockingPaneDefines.h:491
CXTPDockingPaneBaseList
CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
Definition XTPDockingPaneDefines.h:482
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBas...
Definition XTPDockingPaneAutoHidePanel.h:121
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneLayout::Load
BOOL Load(LPCTSTR lpszSection)
Call this member function to load the layout from the registry.
CXTPDockingPaneLayout::CXTPDockingPaneLayout
CXTPDockingPaneLayout(CXTPDockingPaneManager *pManager)
Constructs a CXTPDockingPaneLayout object.
CXTPDockingPaneLayout::IsUserLayout
BOOL IsUserLayout() const
Call this member to determine if the layout is a user created layout.
Definition XTPDockingPaneLayout.h:251
CXTPDockingPaneLayout::LoadFromFile
BOOL LoadFromFile(LPCTSTR lpszFileName, LPCTSTR lpszSection)
Call this member function to load the layout from the file.
CXTPDockingPaneLayout::SaveToFile
void SaveToFile(LPCTSTR lpszFileName, LPCTSTR lpszSection)
Call this member function to save the layout to the file.
CXTPDockingPaneLayout::LoadFromNode
BOOL LoadFromNode(XTPXML::IXMLDOMNode *pNode, LPCTSTR lpszSection)
Call this member function to load the layout from the XML node.
CXTPDockingPaneLayout::GetPaneList
CXTPDockingPaneInfoList & GetPaneList() const
Retrieves a list of layout's panes.
Definition XTPDockingPaneLayout.h:255
CXTPDockingPaneLayout::DoPropExchange
BOOL DoPropExchange(CXTPPropExchange *pPX)
Call this member function to save/restore the settings of the pane.
CXTPDockingPaneLayout::SaveToNode
void SaveToNode(XTPXML::IXMLDOMNode *pNode, LPCTSTR lpszSection)
Call this member function to save the layout to the XML node.
CXTPDockingPaneLayout::~CXTPDockingPaneLayout
virtual ~CXTPDockingPaneLayout()
Destroys a CXTPDockingPaneLayout object, handles cleanup and deallocation.
CXTPDockingPaneLayout::Serialize
void Serialize(CArchive &ar)
Either reads this object from or writes this object to an archive.
CXTPDockingPaneLayout::IsValid
BOOL IsValid() const
Determines if the layout is valid.
CXTPDockingPaneLayout::Copy
void Copy(const CXTPDockingPaneLayout *pLayout)
Call this member function to copy one layout to another.
CXTPDockingPaneLayout::Save
void Save(LPCTSTR lpszSection)
Call this member function to save the layout to the registry.
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneSplitterContainer
CXTPDockingPaneSplitterContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneSplitterContainer.h:168
CXTPDockingPaneSplitterWnd
CXTPDockingPaneSplitterWnd is a CWnd derived class.
Definition XTPDockingPaneSplitterContainer.h:42
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
XTP_DOCKINGPANE_INFO
Internal structure used by the Layout manager.
Definition XTPDockingPaneDefines.h:442


Toolkit Pro: XTPCalendarEventColorDlg.h Source File

  • Source
  • Calendar
XTPCalendarEventColorDlg.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDAREVENTCOLORDLG_H__)
23# define __XTPCALENDAREVENTCOLORDLG_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
35class _XTP_EXT_CLASS CXTPCalendarEventColorDlg : public CDialog
36{
38 DECLARE_DYNAMIC(CXTPCalendarEventColorDlg)
40public:
53 CXTPCalendarEventColorDlg(BOOL bCategories, CXTPCalendarControl* pCalendarCtrl,
54 CWnd* pParent = NULL);
55
56protected:
67 void UpdateSelColor(int nIndex = LB_ERR);
68
69 BOOL m_bCategories;
70 CXTPCalendarControl* m_pCalendarCtrl;
71 CXTPCalendarEventPtr m_pEvent;
73 //{{AFX_DATA(CXTPCalendarEventColorDlg)
74 enum
75 {
76 IDD = XTP_IDD_CALENDAR_EVENT_COLOR
77 };
78 CStatic m_wndEventInfo;
79 CXTPColorPicker m_cpEvent;
80 CXTPCalendarEventColorListBox m_lboxColors;
81 //}}AFX_DATA
82
83 //{{AFX_VIRTUAL(CXTPCalendarEventColorDlg)
84protected:
85 virtual void DoDataExchange(CDataExchange* pDX); // DDX/DDV support
86 //}}AFX_VIRTUAL
87
88 //{{AFX_MSG(CXTPCalendarEventColorDlg)
89 virtual BOOL OnInitDialog();
90 afx_msg void OnBtnRename();
91 afx_msg void OnBtnDelete();
92 afx_msg void OnBtnNew();
93 afx_msg void OnSelChangeListCategories();
94 afx_msg void OnBtnOK();
95 afx_msg void OnEventReset();
96 //}}AFX_MSG
97 afx_msg void OnSelEndOkColor();
98
99 DECLARE_MESSAGE_MAP()
100};
101
102//{{AFX_INSERT_LOCATION}}
103// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
104
105# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
106#endif // !defined(__XTPCALENDAREVENTCOLORDLG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarEventColorDlg
This class is used to edit Calendar Event Category and Label information.
Definition XTPCalendarEventColorDlg.h:36
CXTPCalendarEventColorDlg::m_pEvent
CXTPCalendarEventPtr m_pEvent
Pointer to the calendar event object.
Definition XTPCalendarEventColorDlg.h:71
CXTPCalendarEventColorDlg::UpdateSelColor
void UpdateSelColor(int nIndex=LB_ERR)
This member function is called to update the diplayed color for the color picker whenever a listbox s...
CXTPCalendarEventColorDlg::CXTPCalendarEventColorDlg
CXTPCalendarEventColorDlg(BOOL bCategories, CXTPCalendarControl *pCalendarCtrl, CWnd *pParent=NULL)
Constructs a CXTPCalendarEventColorDlg object used to edit calendar event categories and labels.
CXTPCalendarEventColorDlg::m_pCalendarCtrl
CXTPCalendarControl * m_pCalendarCtrl
Pointer to the calendar object.
Definition XTPCalendarEventColorDlg.h:70
CXTPCalendarEventColorDlg::m_bCategories
BOOL m_bCategories
TRUE when editing event categories.
Definition XTPCalendarEventColorDlg.h:69
CXTPCalendarEventColorListBox
This class is used to display a list of Calendar Event Categories or Labels that can be edited.
Definition XTPCalendarEventColorListBox.h:83
CXTPColorPicker
CXTPColorPicker is a CXTPButton derived class.
Definition XTPColorPicker.h:43


Toolkit Pro: XTPCalendarOffice2003Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarOffice2003Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDAROFFICE2003THEME_H__)
23# define __XTPCALENDAROFFICE2003THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarOffice2003Theme : public CXTPCalendarOffice2000Theme
37{
38public:
47 CXTPCalendarOffice2003Theme();
48
55 virtual ~CXTPCalendarOffice2003Theme();
56
64 virtual void RefreshMetrics();
65
66 virtual void PartRefresh(CWeekViewPart* pViewPart);
67 virtual void PartRefresh(CDayViewWorkCellPart* pViewPart);
68 virtual void PartRefresh(CDayViewNonworkCellPart* pViewPart);
69 virtual void PartRefresh(CMonthViewGridPart* pViewPart);
70
71 virtual void PartDraw(CDayViewCellPart* pViewPart, CDC* pDC,
72 CXTPCalendarDayViewGroup* pViewGroup, CRect rc,
73 const XTP_CALENDAR_DAYVIEWCELL_PARAMS& cellParams);
74 virtual void PartDrawDayHeader(CWeekViewPart* pViewPart, CDC* pDC, CRect rcDay,
75 int nHeaderHeight, CString strHeader, BOOL bIsCurrent,
76 BOOL bIsSelected);
77 virtual void PartDrawDayDate(CMonthViewEventPart* pViewPart, CDC* pDC, CRect rc, BOOL bToday,
78 BOOL bSelected, BOOL bFirstMonthDay, CString strText);
79
80 using CXTPCalendarOffice2000Theme::PartDraw;
81 using CXTPCalendarOffice2000Theme::PartRefresh;
82};
83
84# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
85#endif // !defined(__XTPCALENDAROFFICE2003THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 20...
Definition XTPCalendarOffice2000Theme.h:37
CXTPCalendarOffice2003Theme
CXTPCalendarOffice2003Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2003Theme.h:37
CXTPCalendarOffice2003Theme::CXTPCalendarOffice2003Theme
CXTPCalendarOffice2003Theme()
Default paint manager constructor.
CXTPCalendarOffice2003Theme::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize all drawing defaults.
CXTPCalendarOffice2003Theme::~CXTPCalendarOffice2003Theme
virtual ~CXTPCalendarOffice2003Theme()
Default paint manager destructor.
XTP_CALENDAR_DAYVIEWCELL_PARAMS
Set of parameters transferred from calendar items for an XTP_NC_CALENDAR_BEFORE_DRAW_DAYVIEWCELL noti...
Definition XTPCalendarNotifications.h:638


Toolkit Pro: XTPScrollBarThemeNativeWindows11.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMENATIVEWINDOWS11_H__)
24# define __XTPSCROLLBARTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeNativeWindows11 : public CXTPScrollBarThemeOffice2013
39{
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPSCROLLBARTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeNativeWindows11
Scrollbar paint manager used to draw Native Windows 10 like scrollbars.
Definition XTPScrollBarThemeNativeWindows11.h:39
CXTPScrollBarThemeOffice2013
The CXTPScrollBarThemeOffice2013 class is used to enable a Gallery Office 2013 style theme for Comman...
Definition XTPScrollBarThemeOffice2013.h:67


CXTPChartRadarPointSeriesView Member List

This is the complete list of members for CXTPChartRadarPointSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarPointSeriesView | virtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRadarPointSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarPointSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRadarPointSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


CXTPTreeVisualStudio2015Theme Member List

This is the complete list of members for CXTPTreeVisualStudio2015Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeOffice2013Theme() | CXTPTreeOffice2013Theme |
CXTPTreeTheme() | CXTPTreeTheme |
CXTPTreeVisualStudio2015Theme() | CXTPTreeVisualStudio2015Theme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeOffice2013Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


CXTPCalendarTLV_TimeScaleParams Member List

This is the complete list of members for CXTPCalendarTLV_TimeScaleParams, including all inherited members.

CalcScaleIntervalBegin(COleDateTime dtStart) | CXTPCalendarTLV_TimeScaleParams | virtual
CXTPCalendarTLV_TimeScaleParams(int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetParentTimeScale() const | CXTPCalendarTLV_TimeScaleParams |
GetPart() const =0 | CXTPCalendarTLV_TimeScaleParams | pure virtual
GetScaleInterval() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetScaleIntervalWidth_px() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeLineViewScale() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimePerPixel() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeScaleParamsID() const | CXTPCalendarTLV_TimeScaleParams | virtual
m_nScaleIntervalWidth_px | CXTPCalendarTLV_TimeScaleParams | protected
m_scaleInterval | CXTPCalendarTLV_TimeScaleParams | protected
SetScaleInterval(int eType, int nValue) | CXTPCalendarTLV_TimeScaleParams | protected
~CXTPCalendarTLV_TimeScaleParams() | CXTPCalendarTLV_TimeScaleParams | virtual


CXTPRibbonMarkupTheme Member List

This is the complete list of members for CXTPRibbonMarkupTheme, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonPaintManager | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonMarkupTheme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonMarkupTheme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonMarkupTheme | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonMarkupTheme | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonMarkupTheme | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const =0 | CXTPRibbonPaintManager | pure virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
LoadParts(BOOL bReload=FALSE)=0 | CXTPRibbonMarkupTheme | pure virtual
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonMarkupTheme | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual


CXTPSyntaxEditTextSchemesManager Member List

This is the complete list of members for CXTPSyntaxEditTextSchemesManager, including all inherited members.

AddTextSchemeInfo(XTP_EDIT_SCHEMAFILEINFO &info) | CXTPSyntaxEditTextSchemesManager |
CXTPSyntaxEditTextSchemesManager() | CXTPSyntaxEditTextSchemesManager |
FindSchema(const CString &strFileExt) const | CXTPSyntaxEditTextSchemesManager |
GetSchema(const CString &strSchemeName) | CXTPSyntaxEditTextSchemesManager |
GetSchemaFileName(const CString &strSchemeName) const | CXTPSyntaxEditTextSchemesManager |
GetSchemaList() const | CXTPSyntaxEditTextSchemesManager |
GetSchemaName(const CString &csFileName) const | CXTPSyntaxEditTextSchemesManager |
GetSchemes() | CXTPSyntaxEditTextSchemesManager |
LoadTextScheme(XTP_EDIT_SCHEMAFILEINFO &info) | CXTPSyntaxEditTextSchemesManager |
LoadTextStringScheme(XTP_EDIT_SCHEMAFILEINFO &info, CString *p_sSyntaxScheme) | CXTPSyntaxEditTextSchemesManager |
ReloadFile(const CString &csFileName, int nCfgFlags=0) | CXTPSyntaxEditTextSchemesManager |
RemoveAll() | CXTPSyntaxEditTextSchemesManager |
SetTheme(CXTPSyntaxEditColorTheme *pTheme) | CXTPSyntaxEditTextSchemesManager |
~CXTPSyntaxEditTextSchemesManager() | CXTPSyntaxEditTextSchemesManager | virtual


CXTPTagCloudStyleManager Member List

This is the complete list of members for CXTPTagCloudStyleManager, including all inherited members.

AddStyle(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder, LOGFONT &lf) | CXTPTagCloudStyleManager |
AddStyle(CXTPTagCloudStyle *pStyle) | CXTPTagCloudStyleManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCloudStyleArray() | CXTPTagCloudStyleManager |
GetStyle(int nScore) | CXTPTagCloudStyleManager |
InitDefaultStyles() | CXTPTagCloudStyleManager |
m_arrStyles | CXTPTagCloudStyleManager | protected
RemoveAll() | CXTPTagCloudStyleManager |
RemoveStyle(int nScore) | CXTPTagCloudStyleManager |
ScoreExists(int nScore) | CXTPTagCloudStyleManager |
SetColors(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder=COLORREF_NULL) | CXTPTagCloudStyleManager |
SetFont(int nScore, LOGFONT &lf) | CXTPTagCloudStyleManager |
XTPTabCloudStyleManager() | CXTPTagCloudStyleManager | friend
~CXTPTagCloudStyleManager() | CXTPTagCloudStyleManager |


CXTPEditTheme Member List

This is the complete list of members for CXTPEditTheme, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditTheme | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit)=0 | CXTPEditTheme | pure virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)=0 | CXTPEditTheme | pure virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)=0 | CXTPEditTheme | pure virtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)=0 | CXTPEditTheme | pure virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditTheme | virtual
RefreshMetrics(CXTPEdit *pEdit)=0 | CXTPEditTheme | pure virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual


Toolkit Pro: XTPCalendarMonthViewDay.h Source File

  • Source
  • Calendar
XTPCalendarMonthViewDay.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARMONTHVIEWDAY_H__)
23# define _XTPCALENDARMONTHVIEWDAY_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarMonthView;
32
37struct XTP_CALENDAR_HITTESTINFO;
38
51class _XTP_EXT_CLASS CXTPCalendarMonthViewGroup
52 : public CXTPCalendarViewGroupT<CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent,
53 CXTPCalendarMonthViewGroup>
54{
55public:
60 typedef CXTPCalendarViewGroupT<CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent,
61 CXTPCalendarMonthViewGroup>
62 TBase;
63
71 CXTPCalendarMonthViewGroup(CXTPCalendarMonthViewDay* pViewDay);
72
80 virtual ~CXTPCalendarMonthViewGroup();
81
97 virtual CRect GetTooltipRect(const CPoint& ptHit,
98 const XTP_CALENDAR_HITTESTINFO& hitInfo) const;
99
100protected:
110 virtual CXTPCalendarMonthViewGroup* GetPThis();
111
124 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const;
125};
126
127AFX_INLINE CXTPCalendarMonthViewGroup* CXTPCalendarMonthViewGroup::GetPThis()
128{
129 return this;
130}
131
148class _XTP_EXT_CLASS CXTPCalendarMonthViewDay
149 : public CXTPCalendarViewDayT<CXTPCalendarMonthView, CXTPCalendarMonthViewGroup,
150 XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay>
151{
153 friend class CXTPCalendarMonthViewEvent;
154 DECLARE_DYNAMIC(CXTPCalendarMonthViewDay)
156public:
161 typedef CXTPCalendarViewDayT<CXTPCalendarMonthView, CXTPCalendarMonthViewGroup,
162 XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay>
163 TBase;
164
176 CXTPCalendarMonthViewDay(const CXTPCalendarMonthView* pMonthView, int nWeekIndex,
177 int nWeekDayIndex);
178
186 virtual ~CXTPCalendarMonthViewDay();
187
203 virtual void AdjustLayout(CDC* pDC, const CRect& rcDay);
204
220 virtual void AdjustLayout2(CDC* pDC, const CRect& rcDay);
221
234 virtual void Draw(CDC* pDC);
235
248 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pInfo) const;
249
266 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
267
279 CRect CalcDayDateRect() const;
280
292 CRect GetDayEventsRect() const;
293
294 virtual void SetSelected();
295
296protected:
313 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
314
329 virtual void OnMouseMove(UINT nFlags, CPoint point);
330
340 virtual CXTPCalendarMonthViewDay* GetPThis();
341
342 int m_nWeekIndex;
343 int m_nWeekDayIndex;
344};
345
346//===========================================================================
347
348AFX_INLINE CXTPCalendarMonthViewDay* CXTPCalendarMonthViewDay::GetPThis()
349{
350 return this;
351}
352
353# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
354#endif // !defined(_XTPCALENDARMONTHVIEWDAY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
Definition XTPCalendarMonthViewDay.h:151
CXTPCalendarMonthViewDay::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarMonthViewDay::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pInfo) const
This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarMonthViewDay::~CXTPCalendarMonthViewDay
virtual ~CXTPCalendarMonthViewDay()
Default class destructor.
CXTPCalendarMonthViewDay::CXTPCalendarMonthViewDay
CXTPCalendarMonthViewDay(const CXTPCalendarMonthView *pMonthView, int nWeekIndex, int nWeekDayIndex)
Default object constructor.
CXTPCalendarMonthViewDay::TBase
CXTPCalendarViewDayT< CXTPCalendarMonthView, CXTPCalendarMonthViewGroup, XTP_CALENDAR_HITTESTINFO, CXTPCalendarMonthViewDay > TBase
Base class type definition.
Definition XTPCalendarMonthViewDay.h:163
CXTPCalendarMonthViewDay::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view contents using the specified device context.
CXTPCalendarMonthViewDay::GetPThis
virtual CXTPCalendarMonthViewDay * GetPThis()
This member function is used to obtain a pointer to itself.
Definition XTPCalendarMonthViewDay.h:348
CXTPCalendarMonthViewDay::SetSelected
virtual void SetSelected()
This member function is used to set the day view as selected.
CXTPCalendarMonthViewDay::CalcDayDateRect
CRect CalcDayDateRect() const
This member function is used to calculate the day date bounding rectangle.
CXTPCalendarMonthViewDay::GetDayEventsRect
CRect GetDayEventsRect() const
This member function is used to calculate the day view area in which to draw event views.
CXTPCalendarMonthViewDay::m_nWeekIndex
int m_nWeekIndex
Week identifier.
Definition XTPCalendarMonthViewDay.h:342
CXTPCalendarMonthViewDay::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to processes mouse movement events.
CXTPCalendarMonthViewDay::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
CXTPCalendarMonthViewDay::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcDay)
This member function is used to adjust the view's layout depending on the provided rectangle and then...
CXTPCalendarMonthViewDay::m_nWeekDayIndex
int m_nWeekDayIndex
Day identifier.
Definition XTPCalendarMonthViewDay.h:343
CXTPCalendarMonthViewDay::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at the specified position index...
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarMonthViewGroup
This class represents a single resource view portion of the Calendar Month View.
Definition XTPCalendarMonthViewDay.h:54
CXTPCalendarMonthViewGroup::GetTooltipRect
virtual CRect GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space (currently this is on...
CXTPCalendarMonthViewGroup::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill a XTP_CALENDAR_HITTESTINFO structure.
CXTPCalendarMonthViewGroup::~CXTPCalendarMonthViewGroup
virtual ~CXTPCalendarMonthViewGroup()
Default class destructor.
CXTPCalendarMonthViewGroup::GetPThis
virtual CXTPCalendarMonthViewGroup * GetPThis()
This member function is used to obtain a pointer to itself.
Definition XTPCalendarMonthViewDay.h:127
CXTPCalendarMonthViewGroup::CXTPCalendarMonthViewGroup
CXTPCalendarMonthViewGroup(CXTPCalendarMonthViewDay *pViewDay)
Default object constructor.
CXTPCalendarMonthViewGroup::TBase
CXTPCalendarViewGroupT< CXTPCalendarMonthViewDay, CXTPCalendarMonthViewEvent, CXTPCalendarMonthViewGroup > TBase
Base class type definition.
Definition XTPCalendarMonthViewDay.h:62
CXTPCalendarMonthView
This class implements a specific view portion of the Calendar control - called Month view.
Definition XTPCalendarMonthView.h:74
CXTPCalendarViewDayT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewD...
Definition XTPCalendarViewDay.h:1077
CXTPCalendarViewGroupT
This class template customizes, overrides and implements some functionality for the CXTPCalendarViewG...
Definition XTPCalendarViewDay.h:1257
CXTPCalendarViewGroupT::GetPThis
virtual _TPThis * GetPThis()=0
Call this member function to obtain the typed pointer to the last derived class in the class hierarch...
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: XTPPropertyPage.h Source File

  • Source
  • Controls
  • Dialog
XTPPropertyPage.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYPAGE_H__)
24# define __XTPPROPERTYPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPPropertyPage
41 : public CPropertyPage
42 , public CXTPResize
43{
45 DECLARE_DYNCREATE(CXTPPropertyPage)
47public:
57 CXTPPropertyPage();
58
72 CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption = 0);
73
88 CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption = 0);
89
94 ~CXTPPropertyPage();
95
96public:
103 CString GetCaption() const;
104
110 void SetCaption(LPCTSTR lpszCaption);
111
117 virtual void UpdatePage(void);
118
120public:
121 void EndDialog(int nID);
122
127 void SetModified(BOOL bChanged = TRUE);
128
129protected:
130 virtual BOOL CreatePage(CWnd* pParentWnd);
131
132 virtual BOOL LoadTemplate();
133 virtual BOOL LoadTemplate(HGLOBAL& hTemplate, HINSTANCE& hInst);
134 BOOL MeasureTemplate(SIZE& szDlg);
135
136 void CommonConstruct();
137
138 void UpdateBars();
139 BOOL GetTrueClientSize(CSize& size, CSize& sizeSb);
140 void GetScrollBarSizes(CSize& sizeSb);
141 void GetScrollBarState(CSize sizeClient, CSize& needSb, CSize& sizeRange, CPoint& ptMove,
142 BOOL bInsideClient);
143 CPoint GetDeviceScrollPosition() const;
144 void ScrollToDevicePosition(POINT ptDev);
145 BOOL OnScroll(UINT nScrollCode, UINT nPos, BOOL bDoScroll = TRUE);
146 BOOL DoMouseWheel(UINT fFlags, short zDelta, CPoint point);
147 BOOL OnScrollBy(CSize sizeScroll, BOOL bDoScroll);
148 virtual void AdjustResizeRect(CSize& rcWindow);
149 void ScrollPage(int xAmount, int yAmount);
150 void OnChildSetFocus(HWND hWndFocus);
153protected:
155 DECLARE_MESSAGE_MAP()
156
157 //{{AFX_VIRTUAL(CXTPPropertyPage)
158protected:
159 virtual void DoDataExchange(CDataExchange* pDX);
160 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
161 virtual BOOL OnInitDialog();
162 //}}AFX_VIRTUAL
163
164 //{{AFX_MSG(CXTPPropertyPage)
165 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
166 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
167 afx_msg void OnSize(UINT nType, int cx, int cy);
168 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
169 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
170 afx_msg BOOL OnMouseWheel(UINT fFlags, short zDelta, CPoint point);
171 afx_msg void OnNcPaint();
172 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
173 //}}AFX_MSG
176 friend class CXTPPropertySheet;
177
178public:
179 DWORD_PTR m_dwData;
181protected:
182 CXTPPropertySheet* m_pSheet;
183 BOOL m_bModified;
184 BOOL m_bInsideUpdate;
185
186 CSize m_totalDev;
187 CSize m_lineDev;
188
189 BOOL m_bCreated;
190};
191
194class _XTP_EXT_CLASS CXTPPropertyPageStaticCaption : public CWnd
195{
196public:
197 CXTPPropertyPageStaticCaption();
198
199public:
200 DECLARE_MESSAGE_MAP()
201
202 afx_msg void OnPaint();
203 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
204};
205
208# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
210#endif // !defined(__XTPPROPERTYPAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPPropertyPage::~CXTPPropertyPage
~CXTPPropertyPage()
Destroys a CXTPPropertyPage object, handles cleanup and deallocation.
CXTPPropertyPage::GetCaption
CString GetCaption() const
Retrieves the caption text used for property sheet tabs.
CXTPPropertyPage::CXTPPropertyPage
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption text used to draw property sheet tabs.
CXTPPropertyPage::CXTPPropertyPage
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0)
Constructs a CXTPPropertyPage object.
CXTPPropertyPage::UpdatePage
virtual void UpdatePage(void)
Forces a page to update its internal data as this data is supposed to be changed from outside the pag...
CXTPPropertyPage::CXTPPropertyPage
CXTPPropertyPage()
Constructs a CXTPPropertyPage object.
CXTPPropertySheet
CXTPPropertySheet is a CXTPDialogEx derived class.
Definition XTPPropertySheet.h:65
CXTPResize
CXTPResize is a base class.
Definition XTPResize.h:145
CXTPResize::AdjustResizeRect
virtual void AdjustResizeRect(CSize &rcWindow)
This method is called in the Size method to adjust a window rectangle to fit real client size.


CXTPControlSizeComboBox Member List

This is the complete list of members for CXTPControlSizeComboBox, including all inherited members.

AddString(LPCTSTR lpsz) | CXTPControlComboBox |
AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPControlPopup | virtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlComboBox | virtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlComboBox | protectedvirtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CreateEditControl() | CXTPControlComboBox | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlComboBox(CXTPCommandBars *pCommandBars=NULL) | CXTPControlComboBox |
CXTPControlPopup() | CXTPControlPopup |
CXTPControlSizeComboBox() | CXTPControlSizeComboBox |
DeflateEditRect(CRect &rcControl) | CXTPControlComboBox | protectedvirtual
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DeleteItem(long nIndex) | CXTPControlComboBox |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlComboBox | virtual
Draw(CDC *pDC) | CXTPControl | virtual
DrawEditText(CDC *pDC, CRect rcText) | CXTPControlComboBox | virtual
EnableAutoComplete(BOOL bAutoComplete=TRUE) | CXTPControlComboBox |
EnableShellAutoComplete(DWORD dwFlags=SHACF_FILESYSTEM|SHACF_URLALL) | CXTPControlComboBox |
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FindString(int nStartAfter, LPCTSTR lpszItem) const | CXTPControlComboBox |
FindStringExact(int nIndexStart, LPCTSTR lpsz) const | CXTPControlComboBox |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControlPopup | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetComboBoxPopupBar() const | CXTPControlComboBox |
GetCommandBar() const | CXTPControlPopup | virtual
GetControls() const | CXTPControl |
GetCount() const | CXTPControlComboBox |
GetCurSel() const | CXTPControlComboBox |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControlComboBox | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDefaultCharFormat() | CXTPControlComboBox | virtual
GetDescription() const | CXTPControl | virtual
GetDropDownListStyle() const | CXTPControlComboBox |
GetDropDownWidth() const | CXTPControlComboBox |
GetDroppedState() const | CXTPControlComboBox |
GetEditCtrl() const | CXTPControlComboBox |
GetEditHint() const | CXTPControlComboBox |
GetEditIconId() const | CXTPControlComboBox |
GetEditStyle() const | CXTPControlComboBox |
GetEditText() const | CXTPControlComboBox |
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetItemData(int nIndex) const | CXTPControlComboBox |
GetKeyboardTip() const | CXTPControl |
GetLabelWidth() const | CXTPControlComboBox |
GetLBText(int nIndex, CString &str) const | CXTPControlComboBox |
GetListBoxCtrl() const | CXTPControlComboBox |
GetListBoxText() const | CXTPControlComboBox | virtual
GetListIconId() const | CXTPControlComboBox |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControlPopup | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTextLimit() const | CXTPControlComboBox |
GetThumbWidth() const | CXTPControlComboBox |
GetTooltip() const | CXTPControl | virtual
GetTwipSize(LPCTSTR lpszText) | CXTPControlSizeComboBox | static
GetTwipSize() const | CXTPControlSizeComboBox | protected
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
HasFocus() const | CXTPControlComboBox |
InsertString(int nIndex, LPCTSTR lpsz) | CXTPControlComboBox |
IsCaptionVisible() const | CXTPControlComboBox | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControlComboBox | protectedvirtual
IsFocusable() const | CXTPControlComboBox | protectedvirtual
IsFocused() const | CXTPControlComboBox | virtual
IsImageVisible() const | CXTPControlComboBox |
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bAutoComplete | CXTPControlComboBox | protected
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bDelayDestroy | CXTPControlComboBox | protected
m_bDelayReposition | CXTPControlComboBox | protected
m_bDropDown | CXTPControlComboBox | protected
m_bEditChanged | CXTPControlComboBox | mutableprotected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bFocused | CXTPControlComboBox | protected
m_bIgnoreAutoComplete | CXTPControlComboBox | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bSelEndOk | CXTPControlComboBox | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_comboStyle | CXTPControlComboBox | protected
m_controlType | CXTPControl | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwEditStyle | CXTPControlComboBox | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_dwShellAutoCompleteFlags | CXTPControlComboBox | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nDropDownItemCount | CXTPControlComboBox | protected
m_nEditIconId | CXTPControlComboBox | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nLabelWidth | CXTPControlComboBox | protected
m_nLastSel | CXTPControlComboBox | protected
m_nTag | CXTPControl | protected
m_nTextLimit | CXTPControlComboBox | protected
m_nThumbWidth | CXTPControlComboBox | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pAutoCompleteWnd | CXTPControlComboBox | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pEdit | CXTPControlComboBox | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strEditHint | CXTPControlComboBox | protected
m_strEditText | CXTPControlComboBox | mutableprotected
m_strKeyboardTip | CXTPControl | protected
m_strLastText | CXTPControlComboBox | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
ModifyListBoxStyle(DWORD dwRemove, DWORD dwAdd) | CXTPControlComboBox |
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControlComboBox | virtual
OnActionChanging(int nProperty) | CXTPControlComboBox | virtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControlComboBox | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlComboBox | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEditChanged() | CXTPControlComboBox | virtual
OnEnabledChanged() | CXTPControlComboBox | virtual
OnExecute() | CXTPControlSizeComboBox | protectedvirtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlComboBox | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnKillFocus() | CXTPControlComboBox | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControlPopup | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlComboBox | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlComboBox | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControlComboBox | protectedvirtual
OnSelChanged() | CXTPControlComboBox | virtual
OnSetFocus(CWnd *pOldWnd) | CXTPControlComboBox | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControlSizeComboBox | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlComboBox | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlComboBox | protectedvirtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
ResetContent() | CXTPControlComboBox |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetCurSel(int nIndex) | CXTPControlComboBox |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetDropDownItemCount(int nDropDownItemCount) | CXTPControlComboBox |
SetDropDownListStyle(BOOL bSet=TRUE) | CXTPControlComboBox |
SetDropDownWidth(int nWidth) | CXTPControlComboBox |
SetEditHint(LPCTSTR lpszEditHint) | CXTPControlComboBox |
SetEditIconId(int nId) | CXTPControlComboBox |
SetEditStyle(DWORD dwStyle) | CXTPControlComboBox |
SetEditText(const CString &lpszText) | CXTPControlComboBox |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControlComboBox | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControlComboBox | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemData(int nIndex, DWORD_PTR dwItemData) | CXTPControlComboBox |
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetLabelWidth(int nLabelWidth) | CXTPControlComboBox |
SetListIconId(int nId) | CXTPControlComboBox |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControlComboBox | protectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControlComboBox | protectedvirtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTextLimit(int nTextLimit) | CXTPControlComboBox |
SetThumbWidth(int nThumbWidth) | CXTPControlComboBox |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetTwipSize(int nTwips) | CXTPControlSizeComboBox |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
TwipsToPointString(int nTwips) | CXTPControlSizeComboBox | static
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlComboBox() | CXTPControlComboBox | virtual
~CXTPControlPopup() | CXTPControlPopup | virtual
~CXTPControlSizeComboBox() | CXTPControlSizeComboBox | virtual


CXTPChartRangeSplineAreaSeriesStyle Member List

This is the complete list of members for CXTPChartRangeSplineAreaSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRangeSplineAreaSeriesStyle | protectedvirtual
CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle |
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartRangeSplineAreaSeriesStyle() | CXTPChartRangeSplineAreaSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAreaSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillAcrossXAxis() const | CXTPChartAreaSeriesStyle |
GetFillStyle() const | CXTPChartAreaSeriesStyle |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartAreaSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nFillAcrossXAxis | CXTPChartAreaSeriesStyle | protected
m_nTransparency | CXTPChartAreaSeriesStyle | protected
m_pBorder | CXTPChartAreaSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pFillStyle | CXTPChartAreaSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetFillAcrossXAxis(BOOL nFillAcrossXAxis) | CXTPChartAreaSeriesStyle |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartAreaSeriesStyle | virtual
~CXTPChartAreaSeriesStyle() | CXTPChartAreaSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartRangeSplineAreaSeriesStyle() | CXTPChartRangeSplineAreaSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


CXTPMarkupDecorator Member List

This is the complete list of members for CXTPMarkupDecorator, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupDecorator() | CXTPMarkupDecorator | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBoundRect() const | CXTPMarkupVisual |
GetChild() const | CXTPMarkupDecorator |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetChild(CXTPMarkupUIElement *pChild) | CXTPMarkupDecorator |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupDecorator() | CXTPMarkupDecorator | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


CXTPSyntaxEditColorComboBox Member List

This is the complete list of members for CXTPSyntaxEditColorComboBox, including all inherited members.

AddColor(COLORREF crColor, UINT nID) | CXTPSyntaxEditColorComboBox | protectedvirtual
CXTPSyntaxEditColorComboBox() | CXTPSyntaxEditColorComboBox |
DeleteColor(COLORREF crColor) | CXTPSyntaxEditColorComboBox |
FindColor(COLORREF crColor) | CXTPSyntaxEditColorComboBox |
GetAutoColor() const | CXTPSyntaxEditColorComboBox |
GetLBCurSel() const | CXTPSyntaxEditColorComboBox | protectedvirtual
GetSelColor() | CXTPSyntaxEditColorComboBox |
GetUserColor() const | CXTPSyntaxEditColorComboBox |
Init() | CXTPSyntaxEditColorComboBox | virtual
NotifyOwner(UINT nCode) | CXTPSyntaxEditColorComboBox | protectedvirtual
SelectUserColor() | CXTPSyntaxEditColorComboBox |
SetAutoColor(COLORREF crColor, LPCTSTR lpszAutoText=NULL) | CXTPSyntaxEditColorComboBox |
SetSelColor(COLORREF crColor) | CXTPSyntaxEditColorComboBox |
SetUserColor(COLORREF crColor, LPCTSTR lpszUserText=NULL) | CXTPSyntaxEditColorComboBox |
~CXTPSyntaxEditColorComboBox() | CXTPSyntaxEditColorComboBox | virtual


Toolkit Pro: XTPSyntaxEditTextIterator.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditTextIterator.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITTEXTITERATOR_H__)
24# define __XTPSYNTAXEDITTEXTITERATOR_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSyntaxEditBufferManager;
34
46class _XTP_EXT_CLASS CXTPSyntaxEditTextIterator : public CXTPCmdTarget
47{
48public:
56 CXTPSyntaxEditTextIterator(CXTPSyntaxEditBufferManager* pData);
57
63 virtual ~CXTPSyntaxEditTextIterator(void);
64
74 virtual CString GetEOL() const;
75
87 virtual void SeekBegin();
88
105 virtual BOOL SeekPos(const XTP_EDIT_LINECOL& posLC, HANDLE hBreakEvent = NULL);
106
118 virtual LPCTSTR GetText(int nCharsBuf = 512);
119
128 virtual LPCTSTR SeekNext(DWORD dwChars = 1, int nCharsBuf = 512);
129
137 virtual LPCTSTR SeekPrev();
138
149 virtual BOOL IsEOF() const;
150
159 virtual XTP_EDIT_LINECOL GetPosLC() const;
160
170 virtual XTP_EDIT_LINECOL GetPosLC_last(BOOL bWithEOL) const;
171
177 virtual void LCPosDec(XTP_EDIT_LINECOL& rLC) const;
178
185 virtual void LCPosAdd(XTP_EDIT_LINECOL& rLC, int nCharsAdd) const;
186
196 virtual int GetLineLen(int nLine, BOOL bWithEOL = FALSE) const;
197
207 virtual int GetLineLenBytes(int nLine, BOOL bWithEOL) const;
208
214 virtual void SetTxtOffset(int nOffsetChars);
215
222 virtual CString GetFileExt() const;
223
232 virtual int GetMaxBackOffset() const;
233
234protected:
235 CXTPSyntaxEditBufferManager* m_pData;
238 XTP_EDIT_LINECOL m_LCpos;
239 BOOL m_bEOF;
241 CMap<DWORD, DWORD, int, int> m_mapLine2Len;
250 TCHAR* GetBuffer(int nOffsetB) const;
251
252 CArray<CHAR, CHAR> m_arBuffer;
253 int m_nBufSizeB;
254 int m_nNextLine;
256 int m_nBufOffsetB;
258 int m_nBufOffsetB_normal;
259 int m_nBufOffsetB_max;
261 int m_nTmpOffsetC;
262 int m_nTmpOffsetB;
263};
264
266AFX_INLINE TCHAR* CXTPSyntaxEditTextIterator::GetBuffer(int nOffsetB) const
267{
268 return (TCHAR*)((CHAR*)m_arBuffer.GetData() + nOffsetB);
269}
270AFX_INLINE int CXTPSyntaxEditTextIterator::GetMaxBackOffset() const
271{
272 return m_nBufOffsetB_normal;
273}
274
276
277# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
279#endif // !defined(__XTPSYNTAXEDITTEXTITERATOR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSyntaxEditBufferManager
This class is the main class for buffer management.
Definition XTPSyntaxEditBufferManager.h:59
CXTPSyntaxEditTextIterator
This class provides functionality to navigate text in the data buffer, seek forward/backward,...
Definition XTPSyntaxEditTextIterator.h:47
CXTPSyntaxEditTextIterator::LCPosAdd
virtual void LCPosAdd(XTP_EDIT_LINECOL &rLC, int nCharsAdd) const
Increments position.
CXTPSyntaxEditTextIterator::m_nTmpOffsetC
int m_nTmpOffsetC
Offset.
Definition XTPSyntaxEditTextIterator.h:261
CXTPSyntaxEditTextIterator::GetLineLenBytes
virtual int GetLineLenBytes(int nLine, BOOL bWithEOL) const
Gets the length (in bytes) of a specified line.
CXTPSyntaxEditTextIterator::IsEOF
virtual BOOL IsEOF() const
Determines if the end of data has been reached.
CXTPSyntaxEditTextIterator::GetMaxBackOffset
virtual int GetMaxBackOffset() const
Gets the maximum buffer size (in characters) for back text offset.
Definition XTPSyntaxEditTextIterator.h:270
CXTPSyntaxEditTextIterator::m_pData
CXTPSyntaxEditBufferManager * m_pData
Pointer to the used CXTPSyntaxEditBufferManager object.
Definition XTPSyntaxEditTextIterator.h:235
CXTPSyntaxEditTextIterator::GetFileExt
virtual CString GetFileExt() const
Gets the file name.
CXTPSyntaxEditTextIterator::SeekBegin
virtual void SeekBegin()
Repositions the "current position pointer" in the internal data buffer to the begin.
CXTPSyntaxEditTextIterator::m_nBufOffsetB_max
int m_nBufOffsetB_max
Offset.
Definition XTPSyntaxEditTextIterator.h:259
CXTPSyntaxEditTextIterator::m_nNextLine
int m_nNextLine
Next line ID.
Definition XTPSyntaxEditTextIterator.h:254
CXTPSyntaxEditTextIterator::SeekNext
virtual LPCTSTR SeekNext(DWORD dwChars=1, int nCharsBuf=512)
Moves current position and return pointer to the text begin.
CXTPSyntaxEditTextIterator::m_LCpos
XTP_EDIT_LINECOL m_LCpos
Current position in the text.
Definition XTPSyntaxEditTextIterator.h:238
CXTPSyntaxEditTextIterator::m_arBuffer
CArray< CHAR, CHAR > m_arBuffer
Buffer of chars.
Definition XTPSyntaxEditTextIterator.h:252
CXTPSyntaxEditTextIterator::GetPosLC_last
virtual XTP_EDIT_LINECOL GetPosLC_last(BOOL bWithEOL) const
Gets the last position.
CXTPSyntaxEditTextIterator::GetText
virtual LPCTSTR GetText(int nCharsBuf=512)
Returns text of required length.
CXTPSyntaxEditTextIterator::GetEOL
virtual CString GetEOL() const
Gets the current CRLF control symbol.
CXTPSyntaxEditTextIterator::SetTxtOffset
virtual void SetTxtOffset(int nOffsetChars)
Sets the offset value.
CXTPSyntaxEditTextIterator::m_nBufOffsetB_normal
int m_nBufOffsetB_normal
Offset.
Definition XTPSyntaxEditTextIterator.h:258
CXTPSyntaxEditTextIterator::m_mapLine2Len
CMap< DWORD, DWORD, int, int > m_mapLine2Len
Map of line - length of line.
Definition XTPSyntaxEditTextIterator.h:241
CXTPSyntaxEditTextIterator::m_nBufOffsetB
int m_nBufOffsetB
Offset.
Definition XTPSyntaxEditTextIterator.h:256
CXTPSyntaxEditTextIterator::SeekPos
virtual BOOL SeekPos(const XTP_EDIT_LINECOL &posLC, HANDLE hBreakEvent=NULL)
Repositions the "current position pointer" in the internal data buffer to the specified position.
CXTPSyntaxEditTextIterator::m_bEOF
BOOL m_bEOF
End-Of-File flag.
Definition XTPSyntaxEditTextIterator.h:239
CXTPSyntaxEditTextIterator::GetLineLen
virtual int GetLineLen(int nLine, BOOL bWithEOL=FALSE) const
Gets the length of a specified line.
CXTPSyntaxEditTextIterator::GetBuffer
TCHAR * GetBuffer(int nOffsetB) const
Gets the buffer.
Definition XTPSyntaxEditTextIterator.h:266
CXTPSyntaxEditTextIterator::m_nBufSizeB
int m_nBufSizeB
Buffer length.
Definition XTPSyntaxEditTextIterator.h:253
CXTPSyntaxEditTextIterator::CXTPSyntaxEditTextIterator
CXTPSyntaxEditTextIterator(CXTPSyntaxEditBufferManager *pData)
Default object constructor.
CXTPSyntaxEditTextIterator::m_nTmpOffsetB
int m_nTmpOffsetB
Offset.
Definition XTPSyntaxEditTextIterator.h:262
CXTPSyntaxEditTextIterator::LCPosDec
virtual void LCPosDec(XTP_EDIT_LINECOL &rLC) const
Decrements position.
CXTPSyntaxEditTextIterator::SeekPrev
virtual LPCTSTR SeekPrev()
Moves current position back for 1 character, and return pointer to the text begin.
CXTPSyntaxEditTextIterator::GetPosLC
virtual XTP_EDIT_LINECOL GetPosLC() const
Gets the current position.
CXTPSyntaxEditTextIterator::~CXTPSyntaxEditTextIterator
virtual ~CXTPSyntaxEditTextIterator(void)
Destroys a CXTPSyntaxEditTextIterator object, handles cleanup and de-allocation.
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54


CXTPCalendarEventLabels Member List

This is the complete list of members for CXTPCalendarEventLabels, including all inherited members.

Add(CXTPCalendarEventLabel *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
Add(CXTPCalendarEventLabel *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
CXTPCalendarEventLabels() | CXTPCalendarEventLabels |
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > |
CXTPCmdTarget() | CXTPCmdTarget |
Find(int nLabelID) const | CXTPCalendarEventLabels |
CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel >::Find(const CXTPCalendarEventLabel *pElement) const | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
FindIndex(int nLabelID) const | CXTPCalendarEventLabels | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
InitDefaultValues() | CXTPCalendarEventLabels | virtual
InsertAt(int nIndex, CXTPCalendarEventLabel *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | protected
m_bDefaultValues | CXTPCalendarEventLabels | protected
Remove(CXTPCalendarEventLabel *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
SetAt(int nIndex, CXTPCalendarEventLabel *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
SetDefaultValues(BOOL bDefault) | CXTPCalendarEventLabels |
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | protected
UpdateDefaultValues(COLORREF *clrEventColors, UINT uCount) | CXTPCalendarEventLabels |
~CXTPCalendarEventLabels() | CXTPCalendarEventLabels | virtual
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarEventLabel > | virtual


CXTPColorBase Member List

This is the complete list of members for CXTPColorBase, including all inherited members.

CXTPColorBase() | CXTPColorBase |
focusColorWheel enum value | CXTPColorBase |
FocusedControl enum name | CXTPColorBase |
focusLumination enum value | CXTPColorBase |
focusNone enum value | CXTPColorBase |
HLStoRGB(double h, double l, double s) | CXTPColorBase | static
Init() | CXTPColorBase | protectedvirtual
m_bPreSubclassInit | CXTPColorBase | protected
m_eHasFocus | CXTPColorBase | protectedstatic
m_nHue | CXTPColorBase |
m_nLum | CXTPColorBase |
m_nSat | CXTPColorBase |
m_ptMousePos | CXTPColorBase |
RGBtoHSL(COLORREF color, double *h, double *s, double *l) | CXTPColorBase | static
UpdateCursorPos(CPoint point) | CXTPColorBase | virtual
~CXTPColorBase() | CXTPColorBase | virtual


CXTPSkinObjectToolBar Member List

This is the complete list of members for CXTPSkinObjectToolBar, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectToolBar() | CXTPSkinObjectToolBar |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectToolBar() | CXTPSkinObjectToolBar | virtual


Toolkit Pro: XTPDatePickerOffice2000Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerOffice2000Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKEROFFICE2000THEME_H__)
23# define _XTPDATEPICKEROFFICE2000THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeOffice2000 : public CXTPDatePickerPaintManager
52{
53public:
62 CXTPDatePickerThemeOffice2000();
63
70 virtual ~CXTPDatePickerThemeOffice2000();
71
83 virtual void DrawMonthHeader(CDC* pDC, CXTPDatePickerItemMonth* pMonth);
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
87#endif // !defined(_XTPDATEPICKEROFFICE2000THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
Definition XTPDatePickerItemMonth.h:54
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55
CXTPDatePickerThemeOffice2000
Class CXTPDatePickerThemeOffice2000 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2000Theme.h:52
CXTPDatePickerThemeOffice2000::DrawMonthHeader
virtual void DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth)
Call this member function to draw the month header in the month area.
CXTPDatePickerThemeOffice2000::CXTPDatePickerThemeOffice2000
CXTPDatePickerThemeOffice2000()
Default paint manager constructor.
CXTPDatePickerThemeOffice2000::~CXTPDatePickerThemeOffice2000
virtual ~CXTPDatePickerThemeOffice2000()
Default paint manager destructor.


CXTPCalendarMsgNotifier Member List

This is the complete list of members for CXTPCalendarMsgNotifier, including all inherited members.

Advise(CWnd *pWnd, UINT uWndMsg=msgAll) | CXTPCalendarMsgNotifier |
CreateWnd() | CXTPCalendarMsgNotifier | protected
CXTPCalendarMsgNotifier() | CXTPCalendarMsgNotifier |
EnumParams enum name | CXTPCalendarMsgNotifier |
msgAll enum value | CXTPCalendarMsgNotifier |
Unadvise(CWnd *pWnd, UINT uWndMsg=msgAll) | CXTPCalendarMsgNotifier |
XTPCalendarMsgNotifier() | CXTPCalendarMsgNotifier | friend
~CXTPCalendarMsgNotifier() | CXTPCalendarMsgNotifier | virtual


Toolkit Pro: XTPNumberFormat.h Source File

  • Source
  • Common
XTPNumberFormat.h
Go to the documentation of this file.
1
23#if !defined(__XTPNUMBERFORMAT_H__)
24# define __XTPNUMBERFORMAT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPNumberFormat : public CXTPCmdTarget
34{
35public:
36 CXTPNumberFormat();
37 virtual ~CXTPNumberFormat();
38
39protected:
40private:
41 enum
42 {
43 BufferSize = 16
44 };
45
51 CString m_sDecimalSep;
56 CString m_sThousandSep;
57
61 NUMBERFMT m_numberFormat;
62
63private:
64 BSTR OleGetDecimalSeperator();
65};
66
67# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
69#endif // !defined(__XTPNUMBERFORMAT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122


Toolkit Pro: XTPTaskDialog.h Source File

  • Source
  • Controls
  • Dialog
XTPTaskDialog.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKDIALOG_H__)
24# define __XTPTASKDIALOG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropExchangeXMLNode;
34
43class _XTP_EXT_CLASS CXTPTaskDialog : public CXTPTaskDialogFrame
44{
45public:
51 CXTPTaskDialog(CWnd* pWndParent = NULL);
52
57 virtual ~CXTPTaskDialog();
58
73 void SetWindowTitle(LPCTSTR pszText);
74
90 void SetVerificationText(LPCTSTR pszText);
91
109 void SetExpandedControlText(LPCTSTR pszText);
110
128 void SetCollapsedControlText(LPCTSTR pszText);
129
142 BOOL SetMainInstruction(LPCTSTR pszText);
143
162 BOOL SetContent(LPCTSTR pszText);
163
187 BOOL SetExpandedInformation(LPCTSTR pszText);
188
207 BOOL SetFooter(LPCTSTR pszText);
208
233 BOOL SetMainIcon(HICON hIcon);
234
259 BOOL SetMainIcon(LPCWSTR pszResource);
260
269 void SetUseSysIcons(BOOL bUseSysIcons = TRUE);
270
276 void SetUseComCtl32(BOOL bUseComCtl32 = TRUE);
277
302 BOOL SetFooterIcon(HICON hIcon);
303
328 BOOL SetFooterIcon(LPCWSTR pszResource);
329
343 void SetWidth(int cxWidth, BOOL bPixelToDLU = FALSE);
344
362 void AddButton(LPCTSTR pszText, int nButtonID);
363
379 void AddRadioButton(LPCTSTR pszText, int nButtonID);
380
390 void AddInputBox();
391
402 void SetInputBoxText(LPCTSTR lpszInputBoxText);
403
414 CString GetInputBoxText() const;
415
433 void EnableCommandLinks(BOOL bEnable = TRUE, BOOL bShowIcon = TRUE);
434
449 void EnableHyperlinks(BOOL bEnable = TRUE);
450
456 void EnableMarkup(BOOL bEnable = TRUE);
457
472 void EnableCancellation(BOOL bEnable = TRUE);
473
489 void EnableRelativePosition(BOOL bEnable = TRUE);
490
501 void ShowProgressBar(BOOL bShow, BOOL bMarquee = FALSE);
502
513 void EnableRtlLayout(BOOL bEnable = TRUE);
514
528 void ExpandedByDefault(BOOL bExpanded = TRUE);
529
543 void ExpandFooterArea(BOOL bExpandFooter = TRUE);
544
568 void SetDefaultButton(int nButtonID);
569
584 void SetDefaultRadioButton(int nButtonID);
585
594 void NoDefaultRadioButton(BOOL bNoDefault);
595
608 void SetVerifyCheckState(BOOL bChecked = TRUE);
609
618 void EnableCallbackTimer(BOOL bEnable = TRUE);
619
629 void EnableMinimize(BOOL bEnable);
630
655 void SetCommonButtons(TASKDIALOG_COMMON_BUTTON_FLAGS dwButtons);
656
685 void SetCommonButtons(BOOL bOk, BOOL bYes, BOOL bNo, BOOL bCancel, BOOL bRetry, BOOL bClose);
686
726 virtual INT_PTR DoModal();
727
770 INT_PTR DoModal(BOOL bUseComCtl32);
771
779 BOOL Create(CWnd* pParentWnd = NULL);
780
781# if _MSC_VER > 1200
782 using CDialog::Create;
783 using CWnd::Create;
784# endif
785
805 int GetSelectedButtonId() const;
806
818 int GetSelectedRadioButtonId() const;
819
831 BOOL IsVerificiationChecked() const;
832
862 BOOL ModifyTaskStyle(TASKDIALOG_FLAGS dwRemove, TASKDIALOG_FLAGS dwAdd);
863
891 void ClickButton(int nButtonID);
892
920 void ClickRadioButton(int nButtonID);
921
952 void ClickVerification(BOOL bChecked, BOOL bSetKeyFocus);
953
978 void EnableButton(int nButtonID, BOOL bEnable = TRUE);
979
1004 void EnableRadioButton(int nButtonID, BOOL bEnable = TRUE);
1005
1031 void SetMarqueeProgressBar(BOOL bMarquee = TRUE);
1032
1063 void SetProgressBarState(int nState);
1064
1091 void SetProgressBarRange(WORD wMinRange = 0, WORD wMaxRange = 100);
1092
1118 void SetProgressBarPos(int nPosition);
1119
1146 void StartProgressBarMarquee(BOOL bStartMarquee, DWORD dwMilliSeconds);
1147
1185 void SetButtonElevationRequired(int nButtonID, BOOL bRequired = TRUE);
1186
1225 void NavigatePage(CXTPTaskDialog& taskDlg);
1226
1232 void ResetContent();
1233
1241 void EnableMessageBoxStyle(BOOL bEnable = TRUE);
1242
1251 BOOL CreateFromResource(UINT nIDResource, LPCTSTR lpszDialog);
1252
1262 BOOL CreateFromResource(HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog);
1263
1275 BOOL CreateFromResourceParam(HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog,
1276 LPCTSTR const* rglpsz, int nString);
1277
1287 BOOL CreateFromResourceParam(CXTPPropExchangeXMLNode* pPX, LPCTSTR const* rglpsz, int nString);
1288
1289protected:
1298 virtual void OnDialogConstructed();
1299
1307 virtual void OnDialogDestroyed();
1308
1318 virtual void OnHyperlinkClicked(LPCTSTR pszURL);
1319
1330 virtual void OnButtonClicked(int nButtonID, BOOL& bCloseDialog);
1331
1341 virtual void OnRadioButtonClicked(int nButtonID);
1342
1352 virtual void OnVerificationClicked(BOOL bChecked);
1353
1359 virtual void OnHelp();
1360
1366 virtual void OnInputBoxChanged();
1367
1377 virtual void OnExpandoButtonClicked(BOOL bExpanded);
1378
1391 virtual void OnTimer(DWORD dwMilliSeconds, BOOL& bReset);
1392
1400 virtual void OnNavigated();
1401
1414 virtual HRESULT OnDialogNotify(UINT uNotification, WPARAM wParam, LPARAM lParam);
1415
1416protected:
1417 int m_nSelButtonID;
1418 HWND m_hwndTaskDialog;
1419 TASKDIALOGCONFIG m_config;
1421 CArray<TASKDIALOG_BUTTON, TASKDIALOG_BUTTON&>
1422 m_arrButtons;
1424 CArray<TASKDIALOG_BUTTON, TASKDIALOG_BUTTON&>
1425 m_arrRadioButtons;
1427 BOOL m_bUseComCtl32;
1429private:
1430 BOOL OnAttach(HWND hWndNew);
1431 HWND OnDetach();
1432
1433 static HRESULT CALLBACK TaskDialogCallbackProc(HWND hwnd, UINT uNotification, WPARAM wParam,
1434 LPARAM lParam, DWORD_PTR dwRefData);
1435};
1437AFX_INLINE void CXTPTaskDialog::OnDialogConstructed()
1438{
1439}
1440AFX_INLINE void CXTPTaskDialog::OnDialogDestroyed()
1441{
1442}
1443AFX_INLINE void CXTPTaskDialog::OnHyperlinkClicked(LPCTSTR pszURL)
1444{
1445 ::ShellExecute(NULL, _T("open"), pszURL, NULL, NULL, SW_SHOW);
1446}
1447AFX_INLINE void CXTPTaskDialog::OnButtonClicked(int nButtonID, BOOL& bCloseDialog)
1448{
1449 UNREFERENCED_PARAMETER(nButtonID);
1450 bCloseDialog = TRUE;
1451}
1452AFX_INLINE void CXTPTaskDialog::OnRadioButtonClicked(int nButtonID)
1453{
1454 UNREFERENCED_PARAMETER(nButtonID);
1455}
1456AFX_INLINE void CXTPTaskDialog::OnVerificationClicked(BOOL bChecked)
1457{
1458 UNREFERENCED_PARAMETER(bChecked);
1459}
1460AFX_INLINE void CXTPTaskDialog::OnHelp()
1461{
1462}
1463AFX_INLINE void CXTPTaskDialog::OnInputBoxChanged()
1464{
1465}
1466AFX_INLINE void CXTPTaskDialog::OnExpandoButtonClicked(BOOL bExpanded)
1467{
1468 UNREFERENCED_PARAMETER(bExpanded);
1469}
1470AFX_INLINE void CXTPTaskDialog::OnTimer(DWORD dwMilliSeconds, BOOL& bReset)
1471{
1472 UNREFERENCED_PARAMETER(dwMilliSeconds);
1473 UNREFERENCED_PARAMETER(bReset);
1474}
1475AFX_INLINE void CXTPTaskDialog::OnNavigated()
1476{
1477}
1478AFX_INLINE int CXTPTaskDialog::GetSelectedButtonId() const
1479{
1480 return m_nSelButtonID;
1481}
1482AFX_INLINE int CXTPTaskDialog::GetSelectedRadioButtonId() const
1483{
1484 return m_nSelRadioButtonID;
1485}
1486AFX_INLINE BOOL CXTPTaskDialog::IsVerificiationChecked() const
1487{
1488 return m_bVerification;
1489}
1490AFX_INLINE void CXTPTaskDialog::ClickButton(int nButtonID)
1491{
1492 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1493 ::SendMessage(m_hwndTaskDialog, TDM_CLICK_BUTTON, XTPToWPARAM(nButtonID), 0);
1494}
1495AFX_INLINE void CXTPTaskDialog::ClickRadioButton(int nButtonID)
1496{
1497 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1498 ::SendMessage(m_hwndTaskDialog, TDM_CLICK_RADIO_BUTTON, XTPToWPARAM(nButtonID), 0);
1499}
1500AFX_INLINE void CXTPTaskDialog::ClickVerification(BOOL bChecked, BOOL bSetKeyFocus)
1501{
1502 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1503 ::SendMessage(m_hwndTaskDialog, TDM_CLICK_VERIFICATION, static_cast<WPARAM>(bChecked),
1504 bSetKeyFocus);
1505}
1506AFX_INLINE void CXTPTaskDialog::EnableButton(int nButtonID, BOOL bEnable)
1507{
1508 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1509 ::SendMessage(m_hwndTaskDialog, TDM_ENABLE_BUTTON, XTPToWPARAM(nButtonID), bEnable);
1510}
1511AFX_INLINE void CXTPTaskDialog::EnableRadioButton(int nButtonID, BOOL bEnable)
1512{
1513 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1514 ::SendMessage(m_hwndTaskDialog, TDM_ENABLE_RADIO_BUTTON, XTPToWPARAM(nButtonID), bEnable);
1515}
1516AFX_INLINE void CXTPTaskDialog::SetMarqueeProgressBar(BOOL bMarquee)
1517{
1518 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1519 ::SendMessage(m_hwndTaskDialog, TDM_SET_MARQUEE_PROGRESS_BAR, static_cast<WPARAM>(bMarquee), 0);
1520}
1521AFX_INLINE void CXTPTaskDialog::StartProgressBarMarquee(BOOL bStartMarquee, DWORD dwMilliSeconds)
1522{
1523 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1524 ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_MARQUEE,
1525 static_cast<WPARAM>(bStartMarquee), static_cast<LPARAM>(dwMilliSeconds));
1526}
1527AFX_INLINE void CXTPTaskDialog::SetProgressBarState(int nState)
1528{
1529 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1530 ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_STATE, XTPToWPARAM(nState), 0);
1531}
1532AFX_INLINE void CXTPTaskDialog::SetProgressBarPos(int nPosition)
1533{
1534 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1535 ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_POS, XTPToWPARAM(nPosition), 0);
1536}
1537AFX_INLINE void CXTPTaskDialog::SetProgressBarRange(WORD wMinRange, WORD wMaxRange)
1538{
1539 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1540 ::SendMessage(m_hwndTaskDialog, TDM_SET_PROGRESS_BAR_RANGE, 0,
1541 MAKELPARAM(wMinRange, wMaxRange));
1542}
1543AFX_INLINE void CXTPTaskDialog::SetButtonElevationRequired(int nButtonID, BOOL bRequired)
1544{
1545 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1546 ::SendMessage(m_hwndTaskDialog, TDM_SET_BUTTON_ELEVATION_REQUIRED_STATE, XTPToWPARAM(nButtonID),
1547 bRequired);
1548}
1549AFX_INLINE void CXTPTaskDialog::NavigatePage(CXTPTaskDialog& taskDlg)
1550{
1551 _ASSERTE(::IsWindow(m_hwndTaskDialog));
1552 ::SendMessage(m_hwndTaskDialog, TDM_NAVIGATE_PAGE, 0, (LPARAM)&taskDlg.m_config);
1553}
1554AFX_INLINE void CXTPTaskDialog::SetUseSysIcons(BOOL bUseSysIcons)
1555{
1556 m_bUseSysIcons = bUseSysIcons;
1557}
1558AFX_INLINE void CXTPTaskDialog::SetUseComCtl32(BOOL bUseComCtl32)
1559{
1560 m_bUseComCtl32 = bUseComCtl32;
1561}
1562AFX_INLINE void CXTPTaskDialog::EnableMessageBoxStyle(BOOL bEnable)
1563{
1564 m_bMessageBoxStyle = bEnable;
1565}
1566
1568
1569//{{AFX_INSERT_LOCATION}}
1570// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
1572# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1574#endif // !defined(__XTPTASKDIALOG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class.
Definition XTPPropExchangeXMLNode.h:52
CXTPTaskDialogClient::m_bVerification
BOOL m_bVerification
TRUE if verification button is checked.
Definition XTPTaskDialogClient.h:105
CXTPTaskDialogClient::m_nSelRadioButtonID
int m_nSelRadioButtonID
ID of the radio button that was selected when the task dialog was closed.
Definition XTPTaskDialogClient.h:172
CXTPTaskDialogClient::m_bUseSysIcons
BOOL m_bUseSysIcons
TRUE to use system icons.
Definition XTPTaskDialogClient.h:106
CXTPTaskDialogClient::m_bMessageBoxStyle
BOOL m_bMessageBoxStyle
TRUE to use extended style.
Definition XTPTaskDialogClient.h:175
CXTPTaskDialog
The CXTPTaskDialog class creates, displays, and operates a task dialog.
Definition XTPTaskDialog.h:44
CXTPTaskDialog::ClickRadioButton
void ClickRadioButton(int nButtonID)
Call this member function to simulate the action of a radio button click in the task dialog.
CXTPTaskDialog::SetMainIcon
BOOL SetMainIcon(LPCWSTR pszResource)
Call this member function to set the icon for the Main Instruction area of the task dialog.
CXTPTaskDialog::OnRadioButtonClicked
virtual void OnRadioButtonClicked(int nButtonID)
This notification is sent by the Task Dialog when a user selects a radio button in the task dialog.
CXTPTaskDialog::m_arrButtons
CArray< TASKDIALOG_BUTTON, TASKDIALOG_BUTTON & > m_arrButtons
Array of TASKDIALOG_BUTTON structures containing the definition of the custom buttons that are to be ...
Definition XTPTaskDialog.h:1422
CXTPTaskDialog::AddInputBox
void AddInputBox()
Call this member function to add a user input box to the task dialog's command area.
CXTPTaskDialog::StartProgressBarMarquee
void StartProgressBarMarquee(BOOL bStartMarquee, DWORD dwMilliSeconds)
Similar to SetMarqueeProgressBar; this member function is used to indicate whether the progress bar s...
CXTPTaskDialog::OnInputBoxChanged
virtual void OnInputBoxChanged()
This notification is sent by the Task Dialog when the value of the input box has changed.
CXTPTaskDialog::OnDialogDestroyed
virtual void OnDialogDestroyed()
This notification is sent by the Task Dialog when the task dialog has been destroyed.
CXTPTaskDialog::ExpandFooterArea
void ExpandFooterArea(BOOL bExpandFooter=TRUE)
Call this member to display expanded information at the bottom of the task dialog's footer.
CXTPTaskDialog::m_config
TASKDIALOGCONFIG m_config
Structure containing information used to display a task dialog.
Definition XTPTaskDialog.h:1419
CXTPTaskDialog::OnTimer
virtual void OnTimer(DWORD dwMilliSeconds, BOOL &bReset)
This notification is sent by the Task Dialog approximately every 200 milliseconds when the EnableCall...
CXTPTaskDialog::EnableMarkup
void EnableMarkup(BOOL bEnable=TRUE)
Call this method to enable markup for TaskDialog.
CXTPTaskDialog::GetSelectedButtonId
int GetSelectedButtonId() const
Call this member function to retrieve the ID of the button used to close the task dialog.
CXTPTaskDialog::OnExpandoButtonClicked
virtual void OnExpandoButtonClicked(BOOL bExpanded)
This notification is sent by the Task Dialog when the user clicks on an expando in the Task Dialog.
CXTPTaskDialog::m_hwndTaskDialog
HWND m_hwndTaskDialog
Real window handle of TaskDialog.
Definition XTPTaskDialog.h:1418
CXTPTaskDialog::SetDefaultButton
void SetDefaultButton(int nButtonID)
Call this member function to set the default button ID for the task dialog.
CXTPTaskDialog::DoModal
INT_PTR DoModal(BOOL bUseComCtl32)
Call this member function to display the task dialog and return the selected button when done.
CXTPTaskDialog::SetExpandedInformation
BOOL SetExpandedInformation(LPCTSTR pszText)
Call this member function to set the expanded information text for the task dialog.
CXTPTaskDialog::Create
BOOL Create(CWnd *pParentWnd=NULL)
Call this member function to create a modeless task dialog.
CXTPTaskDialog::SetVerificationText
void SetVerificationText(LPCTSTR pszText)
Call this member function to set the label for the verification checkbox to be displayed in the task ...
CXTPTaskDialog::EnableCancellation
void EnableCancellation(BOOL bEnable=TRUE)
Call this member function to allow dialog cancellation for the task dialog.
CXTPTaskDialog::OnHelp
virtual void OnHelp()
This notification is sent by the Task Dialog when the user presses F1 on the keyboard while the dialo...
CXTPTaskDialog::CXTPTaskDialog
CXTPTaskDialog(CWnd *pWndParent=NULL)
Constructs a CXTPTaskDialog object.
CXTPTaskDialog::GetInputBoxText
CString GetInputBoxText() const
Call this member function to get the text entered by a user in an input box field.
CXTPTaskDialog::EnableRelativePosition
void EnableRelativePosition(BOOL bEnable=TRUE)
Call this member function to position the task dialog relative to the parent window.
CXTPTaskDialog::EnableRtlLayout
void EnableRtlLayout(BOOL bEnable=TRUE)
Call this member function to enable right-to-left (RTL) text display for the task dialog.
CXTPTaskDialog::SetMarqueeProgressBar
void SetMarqueeProgressBar(BOOL bMarquee=TRUE)
Call this member function to indicate whether the progress bar should be displayed in marquee mode or...
CXTPTaskDialog::ClickVerification
void ClickVerification(BOOL bChecked, BOOL bSetKeyFocus)
Call this member function to simulate the action of clicking the verification checkbox in the task di...
CXTPTaskDialog::OnButtonClicked
virtual void OnButtonClicked(int nButtonID, BOOL &bCloseDialog)
This notification is sent by the Task Dialog when a user selects a button or command link in the task...
CXTPTaskDialog::EnableCallbackTimer
void EnableCallbackTimer(BOOL bEnable=TRUE)
Call this member function to enable the callback timer.
CXTPTaskDialog::SetProgressBarRange
void SetProgressBarRange(WORD wMinRange=0, WORD wMaxRange=100)
Call this member function to set the minimum and maximum values for the progress bar.
CXTPTaskDialog::EnableRadioButton
void EnableRadioButton(int nButtonID, BOOL bEnable=TRUE)
Call this member function to enable/disable a radio button in the task dialog.
CXTPTaskDialog::EnableHyperlinks
void EnableHyperlinks(BOOL bEnable=TRUE)
Enables hyperlink processing for the strings specified for the functions SetContent,...
CXTPTaskDialog::NavigatePage
void NavigatePage(CXTPTaskDialog &taskDlg)
This member function is used to simulate a wizard style task dialog.
CXTPTaskDialog::SetFooter
BOOL SetFooter(LPCTSTR pszText)
Call this member function to set the footer text for the task dialog.
CXTPTaskDialog::ClickButton
void ClickButton(int nButtonID)
Call this member function to simulate the action of a button click in the task dialog.
CXTPTaskDialog::EnableButton
void EnableButton(int nButtonID, BOOL bEnable=TRUE)
Call this member function to enable/disable a push button in the task dialog.
CXTPTaskDialog::AddRadioButton
void AddRadioButton(LPCTSTR pszText, int nButtonID)
Call this member function to add a user-defined radio button to the task dialog's command area.
CXTPTaskDialog::SetUseSysIcons
void SetUseSysIcons(BOOL bUseSysIcons=TRUE)
Call this member function to use system icons.
CXTPTaskDialog::OnDialogConstructed
virtual void OnDialogConstructed()
This notification is sent by the Task Dialog when the task dialog has been created and before it is d...
CXTPTaskDialog::EnableMinimize
void EnableMinimize(BOOL bEnable)
Call this member function to enable the the task dialog to be minimized.
CXTPTaskDialog::SetExpandedControlText
void SetExpandedControlText(LPCTSTR pszText)
Call this member function to set the expanded control text for the task dialog.
CXTPTaskDialog::AddButton
void AddButton(LPCTSTR pszText, int nButtonID)
Call this member function to add a user-defined button to the task dialog's command area.
CXTPTaskDialog::SetCommonButtons
void SetCommonButtons(TASKDIALOG_COMMON_BUTTON_FLAGS dwButtons)
Specifies the push buttons displayed in the task dialog.
CXTPTaskDialog::SetWidth
void SetWidth(int cxWidth, BOOL bPixelToDLU=FALSE)
Call this member function to set the width of the task dialog's client area.
CXTPTaskDialog::~CXTPTaskDialog
virtual ~CXTPTaskDialog()
Destroys a CXTPTaskDialog object, handles cleanup and deallocation.
CXTPTaskDialog::SetProgressBarState
void SetProgressBarState(int nState)
Call this member function to set the current state of the progress bar.
CXTPTaskDialog::SetMainIcon
BOOL SetMainIcon(HICON hIcon)
Call this member function to set the icon for the Main Instruction area of the task dialog.
CXTPTaskDialog::SetInputBoxText
void SetInputBoxText(LPCTSTR lpszInputBoxText)
Call this member function to set the default value for an input box field.
CXTPTaskDialog::SetWindowTitle
void SetWindowTitle(LPCTSTR pszText)
Call this member function to set the window title for the task dialog.
CXTPTaskDialog::SetMainInstruction
BOOL SetMainInstruction(LPCTSTR pszText)
Call this member function to set the main instruction text for the task dialog.
CXTPTaskDialog::DoModal
virtual INT_PTR DoModal()
Call this member function to display the task dialog and return the selected button when done.
CXTPTaskDialog::SetVerifyCheckState
void SetVerifyCheckState(BOOL bChecked=TRUE)
Call this member function to set the checked state for the verification checkbox when the dialog is i...
CXTPTaskDialog::SetUseComCtl32
void SetUseComCtl32(BOOL bUseComCtl32=TRUE)
Call this member function to use ComCtl32.dll in Vista to show TaskDialog.
CXTPTaskDialog::ExpandedByDefault
void ExpandedByDefault(BOOL bExpanded=TRUE)
Call this member function to display the text specified by the SetExpandedInformation member function...
CXTPTaskDialog::m_bUseComCtl32
BOOL m_bUseComCtl32
TRUE to use Vista ComCtl32.dll to show task dialog.
Definition XTPTaskDialog.h:1427
CXTPTaskDialog::m_arrRadioButtons
CArray< TASKDIALOG_BUTTON, TASKDIALOG_BUTTON & > m_arrRadioButtons
Array of TASKDIALOG_BUTTON structures containing the definition of the custom radio buttons that are ...
Definition XTPTaskDialog.h:1425
CXTPTaskDialog::ShowProgressBar
void ShowProgressBar(BOOL bShow, BOOL bMarquee=FALSE)
Call this member function to display a progress bar for the task dialog.
CXTPTaskDialog::SetButtonElevationRequired
void SetButtonElevationRequired(int nButtonID, BOOL bRequired=TRUE)
Call this member function to designate whether a given Task Dialog button or command link should have...
CXTPTaskDialog::GetSelectedRadioButtonId
int GetSelectedRadioButtonId() const
Call this member function to retrieve the ID of the radio button that was selected when the task dial...
CXTPTaskDialog::CreateFromResourceParam
BOOL CreateFromResourceParam(HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog, LPCTSTR const *rglpsz, int nString)
Call this method to create a dialog from an XML resource.
CXTPTaskDialog::ResetContent
void ResetContent()
Call this member function to reset the configuration attributes for the task dialog to the default st...
CXTPTaskDialog::CreateFromResource
BOOL CreateFromResource(HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog)
Call this method to create a dialog from an XML resource.
CXTPTaskDialog::ModifyTaskStyle
BOOL ModifyTaskStyle(TASKDIALOG_FLAGS dwRemove, TASKDIALOG_FLAGS dwAdd)
Call this member function to modify the style for the task dialog.
CXTPTaskDialog::SetFooterIcon
BOOL SetFooterIcon(LPCWSTR pszResource)
Call this member function to set the icon for the Footer area of the task dialog.
CXTPTaskDialog::OnVerificationClicked
virtual void OnVerificationClicked(BOOL bChecked)
This notification is sent by the Task Dialog when the user clicks on the task dialog's verification c...
CXTPTaskDialog::SetContent
BOOL SetContent(LPCTSTR pszText)
Call this member function to set the content text for the task dialog.
CXTPTaskDialog::EnableMessageBoxStyle
void EnableMessageBoxStyle(BOOL bEnable=TRUE)
Enables/disables message box like style for the dialog.
CXTPTaskDialog::CreateFromResource
BOOL CreateFromResource(UINT nIDResource, LPCTSTR lpszDialog)
Call this method to create a dialog from an XML resource.
CXTPTaskDialog::SetDefaultRadioButton
void SetDefaultRadioButton(int nButtonID)
Call this member function to set the default radio button ID for the task dialog.
CXTPTaskDialog::EnableCommandLinks
void EnableCommandLinks(BOOL bEnable=TRUE, BOOL bShowIcon=TRUE)
Call this member function to indicate that the buttons specified with AddButton should be displayed a...
CXTPTaskDialog::NoDefaultRadioButton
void NoDefaultRadioButton(BOOL bNoDefault)
Call this member function to disable default radio button selection.
CXTPTaskDialog::IsVerificiationChecked
BOOL IsVerificiationChecked() const
Call this member function to retrieve the checked state of the verification checkbox when the dialog ...
CXTPTaskDialog::m_nSelButtonID
int m_nSelButtonID
ID of the button that was selected when the task dialog was closed.
Definition XTPTaskDialog.h:1417
CXTPTaskDialog::OnHyperlinkClicked
virtual void OnHyperlinkClicked(LPCTSTR pszURL)
This notification is sent by the Task Dialog when a user clicks on a hyperlink in the Task Dialog's c...
CXTPTaskDialog::SetCommonButtons
void SetCommonButtons(BOOL bOk, BOOL bYes, BOOL bNo, BOOL bCancel, BOOL bRetry, BOOL bClose)
Specifies the push buttons displayed in the task dialog.
CXTPTaskDialog::SetFooterIcon
BOOL SetFooterIcon(HICON hIcon)
Call this member function to set the icon for the Footer area of the task dialog.
CXTPTaskDialog::SetProgressBarPos
void SetProgressBarPos(int nPosition)
Call this member function to se the current position for the progress bar.
CXTPTaskDialog::SetCollapsedControlText
void SetCollapsedControlText(LPCTSTR pszText)
Call this member function to set the collapsed control text for the task dialog.
CXTPTaskDialog::OnDialogNotify
virtual HRESULT OnDialogNotify(UINT uNotification, WPARAM wParam, LPARAM lParam)
This virtual method is called when some notification is sent from TaskDialog.
CXTPTaskDialog::CreateFromResourceParam
BOOL CreateFromResourceParam(CXTPPropExchangeXMLNode *pPX, LPCTSTR const *rglpsz, int nString)
Call this method to create a dialog from an XML resource.
CXTPTaskDialog::OnNavigated
virtual void OnNavigated()
This notification is sent by the Task Dialog when a navigation has occurred.


Toolkit Pro: XTPMatrix.h Source File

  • Source
  • Common
  • Math
XTPMatrix.h
Go to the documentation of this file.
1
23#if !defined(__XTPMATRIX_H__)
24# define __XTPMATRIX_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38template<class T>
39class CXTPMatrix
40{
41public:
50 CXTPMatrix(UINT nWidth, UINT nHeight);
51
56 ~CXTPMatrix();
57
58public:
67 UINT GetWidth() const;
68
77 UINT GetHeight() const;
78
87 T* GetData();
88
97 const T* GetData() const;
98
106 CXTPMatrix<T>* Clone() const;
107
115 BOOL Equals(const CXTPMatrix<T>& m) const;
116
127 T GetAt(UINT nCol, UINT nRow) const;
128
138 void SetAt(UINT nCol, UINT nRow, T value);
139
145 void Set(const CXTPMatrix<T>& m);
146
153 void SetZero();
154
163 void SetIdentity();
164
173 void Add(const CXTPMatrix<T>& m);
174
183 void Subtract(const CXTPMatrix<T>& m);
184
195 void Rotate(T xQuat, T yQuat, T zQuat, T wQuat);
196
208 CXTPMatrix<T>* Multiply(const CXTPMatrix<T>& m) const;
209
219 CXTPMatrix<T>* Transpose() const;
220
221private:
222 CXTPMatrix(const CXTPMatrix&);
223 CXTPMatrix& operator=(const CXTPMatrix&);
225 const UINT m_nWidth;
226 const UINT m_nHeight;
227 T* m_pData;
228};
229
230template<class T>
231AFX_INLINE CXTPMatrix<T>::CXTPMatrix(UINT nWidth, UINT nHeight)
232 : m_nWidth(nWidth)
233 , m_nHeight(nHeight)
234{
235 if (0 < m_nWidth && 0 < m_nHeight)
236 {
237 m_pData = new T[m_nWidth * m_nHeight];
238 SetZero();
239 }
240 else
241 {
242 m_pData = NULL;
243 }
244}
245
246template<class T>
247AFX_INLINE CXTPMatrix<T>::~CXTPMatrix()
248{
249 if (NULL != m_pData)
250 {
251 delete[] m_pData;
252 }
253}
254
255template<class T>
256AFX_INLINE UINT CXTPMatrix<T>::GetWidth() const
257{
258 return m_nWidth;
259}
260
261template<class T>
262AFX_INLINE UINT CXTPMatrix<T>::GetHeight() const
263{
264 return m_nHeight;
265}
266
267template<class T>
268AFX_INLINE T* CXTPMatrix<T>::GetData()
269{
270 return m_pData;
271}
272
273template<class T>
274AFX_INLINE const T* CXTPMatrix<T>::GetData() const
275{
276 return m_pData;
277}
278
279template<class T>
280AFX_INLINE CXTPMatrix<T>* CXTPMatrix<T>::Clone() const
281{
282 CXTPMatrix<T>* pClone = new CXTPMatrix<T>(m_nWidth, m_nHeight);
283 for (UINT i = 0; i < (m_nWidth * m_nHeight); ++i)
284 {
285 pClone->GetData()[i] = m_pData[i];
286 }
287
288 return pClone;
289}
290
291template<class T>
292AFX_INLINE BOOL CXTPMatrix<T>::Equals(const CXTPMatrix<T>& m) const
293{
294 BOOL bEquals = FALSE;
295
296 if (GetWidth() == m.GetWidth() && GetHeight() == m.GetHeight())
297 {
298 bEquals = TRUE;
299
300 for (UINT i = 0; i < (m_nWidth * m_nHeight); ++i)
301 {
302 if (m_pData[i] != m.GetData()[i])
303 {
304 bEquals = FALSE;
305 break;
306 }
307 }
308 }
309
310 return bEquals;
311}
312
313template<class T>
314AFX_INLINE T CXTPMatrix<T>::GetAt(UINT nCol, UINT nRow) const
315{
316 _ASSERTE(nCol < m_nWidth);
317 _ASSERTE(nRow < m_nHeight);
318
319 UINT nIndex = nRow * m_nWidth + nCol;
320 return m_pData[nIndex];
321}
322
323template<class T>
324AFX_INLINE void CXTPMatrix<T>::SetAt(UINT nCol, UINT nRow, T value)
325{
326 _ASSERTE(nCol < m_nWidth);
327 _ASSERTE(nRow < m_nHeight);
328
329 UINT nIndex = nRow * m_nWidth + nCol;
330 m_pData[nIndex] = value;
331}
332
333template<class T>
334AFX_INLINE void CXTPMatrix<T>::Set(const CXTPMatrix<T>& m)
335{
336 if (GetWidth() == m.GetWidth() && GetHeight() == m.GetHeight())
337 {
338 for (UINT i = 0; i < (m_nWidth * m_nHeight); ++i)
339 {
340 m_pData[i] = m.GetData()[i];
341 }
342 }
343 else
344 {
345 _ASSERTE(!"Matrices must have the same size");
346 }
347}
348
349template<class T>
350AFX_INLINE void CXTPMatrix<T>::SetZero()
351{
352 for (UINT i = 0; i < (m_nWidth * m_nHeight); ++i)
353 {
354 m_pData[i] = T();
355 }
356}
357
358template<class T>
359AFX_INLINE void CXTPMatrix<T>::SetIdentity()
360{
361 if (m_nWidth == m_nHeight)
362 {
363 SetZero();
364
365 for (UINT i = 0; i < m_nWidth; ++i)
366 {
367 SetAt(i, i, T(1));
368 }
369 }
370 else
371 {
372 _ASSERTE(!"Only square matrix with odd sizes can be set to identity");
373 }
374}
375
376template<class T>
377AFX_INLINE void CXTPMatrix<T>::Add(const CXTPMatrix<T>& m)
378{
379 if (GetWidth() == m.GetWidth() && GetHeight() == m.GetHeight())
380 {
381 for (UINT i = 0; i < (m_nWidth * m_nHeight); ++i)
382 {
383 m_pData[i] += m.GetData()[i];
384 }
385 }
386 else
387 {
388 _ASSERTE(!"Matrices must have the same size");
389 }
390}
391
392template<class T>
393AFX_INLINE void CXTPMatrix<T>::Subtract(const CXTPMatrix<T>& m)
394{
395 if (GetWidth() == m.GetWidth() && GetHeight() == m.GetHeight())
396 {
397 for (UINT i = 0; i < (m_nWidth * m_nHeight); ++i)
398 {
399 m_pData[i] -= m.GetData()[i];
400 }
401 }
402 else
403 {
404 _ASSERTE(!"Matrices must have the same size");
405 }
406}
407
408template<class T>
409AFX_INLINE void CXTPMatrix<T>::Rotate(T xQuat, T yQuat, T zQuat, T wQuat)
410{
411 if (4 == m_nWidth && 4 == m_nHeight)
412 {
413 T n = (xQuat * xQuat) + (yQuat * yQuat) + (zQuat * zQuat) + (wQuat * wQuat);
414 T s = (T(0) < n) ? (T(2) / n) : T(0);
415
416 T xs = xQuat * s;
417 T ys = yQuat * s;
418 T zs = zQuat * s;
419 T wx = wQuat * xs;
420 T wy = wQuat * ys;
421 T wz = wQuat * zs;
422 T xx = xQuat * xs;
423 T xy = xQuat * ys;
424 T xz = xQuat * zs;
425 T yy = yQuat * ys;
426 T yz = yQuat * zs;
427 T zz = zQuat * zs;
428
429 SetAt(0, 0, T(1) - (yy + zz));
430 SetAt(0, 1, xy - wz);
431 SetAt(0, 2, xz + wy);
432 SetAt(0, 3, T(0));
433 SetAt(1, 0, xy + wz);
434 SetAt(1, 1, T(1) - (xx + zz));
435 SetAt(1, 2, yz - wx);
436 SetAt(1, 3, T(0));
437 SetAt(2, 0, xz - wy);
438 SetAt(2, 1, yz + wx);
439 SetAt(2, 2, T(1) - (xx + yy));
440 SetAt(2, 3, T(0));
441 SetAt(3, 0, T(0));
442 SetAt(3, 1, T(0));
443 SetAt(3, 2, T(0));
444 SetAt(3, 3, T(1));
445 }
446 else
447 {
448 _ASSERTE(!"Only 4x4 matrix can be rotated using a quaternion");
449 }
450}
451
452template<class T>
453AFX_INLINE CXTPMatrix<T>* CXTPMatrix<T>::Multiply(const CXTPMatrix<T>& m) const
454{
455 CXTPMatrix<T>* pResult = NULL;
456
457 if (GetWidth() == m.GetHeight())
458 {
459 pResult = new CXTPMatrix<T>(m.GetWidth(), GetHeight());
460
461 for (UINT nRow = 0; nRow < GetHeight(); ++nRow)
462 {
463 for (UINT nCol = 0; nCol < m.GetWidth(); ++nCol)
464 {
465 T& value = pResult->GetData()[nCol * GetHeight() + nRow];
466 value = T(0);
467
468 for (UINT nRowLeft = 0; nRowLeft < GetWidth(); ++nRowLeft)
469 {
470 value += GetData()[nRowLeft * GetHeight() + nRow]
471 * m.GetData()[nCol * GetWidth() + nRowLeft];
472 }
473 }
474 }
475 }
476 else
477 {
478 _ASSERTE(!"Matrices cannot be multiplied");
479 }
480
481 return pResult;
482}
483
484template<class T>
485AFX_INLINE CXTPMatrix<T>* CXTPMatrix<T>::Transpose() const
486{
487 CXTPMatrix<T>* pResult = new CXTPMatrix<T>(GetHeight(), GetWidth());
488 for (UINT nRow = 0; nRow < GetHeight(); ++nRow)
489 {
490 for (UINT nCol = 0; nCol < GetWidth(); ++nCol)
491 {
492 pResult->SetAt(nRow, nCol, GetAt(nCol, nRow));
493 }
494 }
495
496 return pResult;
497}
498
499# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
501#endif //#if !defined(__XTPMATRIX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMatrix
Represents a matrix object built upon a continuos array of elements and provides basic algorithms for...
Definition XTPMatrix.h:40
CXTPMatrix::~CXTPMatrix
~CXTPMatrix()
Handles matrix deallocation.
Definition XTPMatrix.h:247
CXTPMatrix::GetHeight
UINT GetHeight() const
Obtains the height of the matrix.
Definition XTPMatrix.h:262
CXTPMatrix::Clone
CXTPMatrix< T > * Clone() const
Clones the matrix.
Definition XTPMatrix.h:280
CXTPMatrix::SetIdentity
void SetIdentity()
Make the current matrix an identity matrix, i.e.
Definition XTPMatrix.h:359
CXTPMatrix::SetAt
void SetAt(UINT nCol, UINT nRow, T value)
Sets element value at the specified location.
Definition XTPMatrix.h:324
CXTPMatrix::GetData
const T * GetData() const
Obtains a point to the first element of the continuous array upon which the matrix is built.
Definition XTPMatrix.h:274
CXTPMatrix::Set
void Set(const CXTPMatrix< T > &m)
Makes the current matrix identical to the matrix provided.
Definition XTPMatrix.h:334
CXTPMatrix::Equals
BOOL Equals(const CXTPMatrix< T > &m) const
Compares the current matrix to the matrix oject specified.
Definition XTPMatrix.h:292
CXTPMatrix::Add
void Add(const CXTPMatrix< T > &m)
Adds the matrix provided to the current matrix.
Definition XTPMatrix.h:377
CXTPMatrix::GetData
T * GetData()
Obtains a point to the first element of the continuous array upon which the matrix is built.
Definition XTPMatrix.h:268
CXTPMatrix::Multiply
CXTPMatrix< T > * Multiply(const CXTPMatrix< T > &m) const
Multiplies the current matrix of size MxN to the provided matrix of size LxM.
Definition XTPMatrix.h:453
CXTPMatrix::Transpose
CXTPMatrix< T > * Transpose() const
Creates a transposed matrix, i.e.
Definition XTPMatrix.h:485
CXTPMatrix::Subtract
void Subtract(const CXTPMatrix< T > &m)
Subtracts the matrix provided from the current matrix.
Definition XTPMatrix.h:393
CXTPMatrix::Rotate
void Rotate(T xQuat, T yQuat, T zQuat, T wQuat)
Rotates 4x4 matrix using quaternion parameters.
Definition XTPMatrix.h:409
CXTPMatrix::SetZero
void SetZero()
Sets all matrix elements to 0.
Definition XTPMatrix.h:350
CXTPMatrix::GetAt
T GetAt(UINT nCol, UINT nRow) const
Obtains an element value at the specified location.
Definition XTPMatrix.h:314
CXTPMatrix::GetWidth
UINT GetWidth() const
Obtains the width of the matrix.
Definition XTPMatrix.h:256
CXTPMatrix::CXTPMatrix
CXTPMatrix(UINT nWidth, UINT nHeight)
Constructs a matrix object of the specified size where each element is set to zero.
Definition XTPMatrix.h:231


CXTPTaskPanelNativeWindows11Theme Member List

This is the complete list of members for CXTPTaskPanelNativeWindows11Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelNativeWindows11Theme() | CXTPTaskPanelNativeWindows11Theme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
CXTPTaskPanelVisualStudio2012Theme(BOOL bLight=TRUE) | CXTPTaskPanelVisualStudio2012Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelVisualStudio2012Theme | virtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2012Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2012Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_clrSelectedText | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedTextWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrSelectedWithoutFocus | CXTPTaskPanelVisualStudio2012Theme | protected
m_clrText | CXTPTaskPanelVisualStudio2012Theme | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelNativeWindows11Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelNativeWindows11Theme() | CXTPTaskPanelNativeWindows11Theme | virtual
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual
~CXTPTaskPanelVisualStudio2012Theme() | CXTPTaskPanelVisualStudio2012Theme | virtual


Toolkit Pro: XTPGridRecordItemCheckbox.h Source File

  • Source
  • GridControl
  • ItemTypes
XTPGridRecordItemCheckbox.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDRECORDITEMCHECKBOX_H__)
24# define __XTPGRIDRECORDITEMCHECKBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
43class _XTP_EXT_CLASS CXTPGridRecordItemCheckbox : public CXTPGridRecordItem
44{
46 DECLARE_SERIAL(CXTPGridRecordItemCheckbox)
48public:
57 CXTPGridRecordItemCheckbox(XTPGridCheckState state = xtpGridCheckStateChecked,
58 BOOL bTristateCheckbox = FALSE);
59};
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif //#if !defined(__XTPGRIDRECORDITEMCHECKBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridCheckState
XTPGridCheckState
This enum defines the possible checkbox states.
Definition XTPGridDefines.h:79
xtpGridCheckStateChecked
@ xtpGridCheckStateChecked
The checkbox is in a checked state.
Definition XTPGridDefines.h:82
CXTPGridRecordItemCheckbox
This class represents a checkbox-only cell and inherits basic functionality from the CXTPGridRecordIt...
Definition XTPGridRecordItemCheckbox.h:44
CXTPGridRecordItemCheckbox::CXTPGridRecordItemCheckbox
CXTPGridRecordItemCheckbox(XTPGridCheckState state=xtpGridCheckStateChecked, BOOL bTristateCheckbox=FALSE)
Creates a record checkbox item.
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600


CXTPFrameWndBase< TBase > Member List

This is the complete list of members for CXTPFrameWndBase< TBase >, including all inherited members.

CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< TBase > | inline
CXTPFrameWndBase() | CXTPFrameWndBase< TBase > | inline
DockRightOf(CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft) | CXTPCommandBarsSiteBase< TBase > | inline
GetCommandBars() const | CXTPCommandBarsSiteBase< TBase > | inline
InitCommandBars(CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars)) | CXTPCommandBarsSiteBase< TBase > | inlinevirtual
LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent=FALSE) | CXTPCommandBarsSiteBase< TBase > | inlinevirtual
SaveCommandBars(LPCTSTR lpszProfileName) | CXTPCommandBarsSiteBase< TBase > | inlinevirtual
~CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< TBase > | inline
~CXTPFrameWndBase() | CXTPFrameWndBase< TBase > | inline


XTP_RESOURCEMANAGER_LANGINFO Member List

This is the complete list of members for XTP_RESOURCEMANAGER_LANGINFO, including all inherited members.

lpszCaption | XTP_RESOURCEMANAGER_LANGINFO
lpszEncoding | XTP_RESOURCEMANAGER_LANGINFO
lpszLang | XTP_RESOURCEMANAGER_LANGINFO
lpszSubLang | XTP_RESOURCEMANAGER_LANGINFO
nCodePage | XTP_RESOURCEMANAGER_LANGINFO
nFontCharSet | XTP_RESOURCEMANAGER_LANGINFO
wLanguage | XTP_RESOURCEMANAGER_LANGINFO


Toolkit Pro: XTPSliderThemeOffice2013.h Source File

  • Source
  • CommandBars
  • Slider
XTPSliderThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPSLIDERTHEMEOFFICE2013_H__)
24# define __XTPSLIDERTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPSliderThemeOffice2013 : public CXTPSliderPaintManager
34{
35public:
36 CXTPSliderThemeOffice2013(CXTPPaintManager* pPaintManager);
37
38public:
39 virtual void RefreshMetrics();
40 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
41
42protected:
43 CXTPPaintManagerColor m_clrSlider;
44 CXTPPaintManagerColor m_clrScrollBar;
45 CXTPPaintManagerColor m_clrHighlight;
46};
47
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPSLIDERTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPSliderPaintManager
Paint manager for the slider control.
Definition XTPSliderPaintManager.h:40
CXTPSliderPaintManager::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw the scrollbar of the slider.
CXTPSliderPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates gallery metrics.


Toolkit Pro: XTPTaskPanelItem.h Source File

  • Source
  • TaskPanel
XTPTaskPanelItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELITEM_H__)
24# define __XTPTASKPANELITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTaskPanel;
34class CXTPTaskPanelPaintManager;
35class CXTPTaskPanelItems;
36class CXTPTaskPanelGroup;
37class CXTPImageManagerIcon;
38class CXTPPropExchange;
39class CXTPMarkupUIElement;
40
46class _XTP_EXT_CLASS CXTPTaskPanelItem
47 : public CXTPCmdTarget
48 , public CXTPAccessible
49{
51 DECLARE_INTERFACE_MAP()
52 DECLARE_DYNCREATE(CXTPTaskPanelItem)
54protected:
59 CXTPTaskPanelItem();
60
61public:
66 virtual ~CXTPTaskPanelItem();
67
74 CXTPTaskPanel* GetTaskPanel() const;
75
81 void SetID(UINT nID);
82
90 void SetID(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip = NULL);
91
98 UINT GetID() const;
99
106 BOOL IsDroppedOff() const;
107
113 void SetCaption(LPCTSTR lpszCaption);
114
122 void SetTooltip(LPCTSTR lpszTooltip);
123
131 XTPTaskPanelItemType GetType() const;
132
139 void SetType(XTPTaskPanelItemType typeItem);
140
147 CString GetCaption() const;
148
157 CString GetTooltip() const;
158
165 BOOL GetEnabled() const;
166
172 void SetEnabled(BOOL bEnabled);
173
180 CXTPTaskPanelPaintManager* GetPaintManager() const;
181
188 BOOL IsItemHot() const;
189
196 BOOL IsItemPressed() const;
197
204 BOOL IsItemFocused() const;
205
214 BOOL IsItemDragging() const;
215
224 BOOL IsItemDragOver() const;
225
232 BOOL IsGroup() const;
233
239 void RedrawPanel(BOOL bAnimate = FALSE) const;
240
249 void SetIconIndex(int nIndex);
250
260 int GetIconIndex() const;
261
268 virtual BOOL IsAcceptFocus() const;
269
280 CXTPImageManagerIcon* GetImage(int nWidth) const;
281
296 static CXTPTaskPanelItem* AFX_CDECL CreateFromOleData(COleDataObject* pDataObject);
297
313 static CXTPTaskPanelItem* AFX_CDECL CreateFromOleFile(CFile* pDataObject);
314
325 HGLOBAL CacheGlobalData();
326
331 void Remove();
332
339 BOOL IsVisible() const;
340
346 void SetVisible(BOOL bVisible);
347
352 void RepositionPanel() const;
353
363 CXTPTaskPanelItems* GetParentItems() const;
364
371 virtual CXTPTaskPanelGroup* GetItemGroup() const;
372
379 int GetIndex() const;
380
388 BOOL IsAllowDrop() const;
389
396 void AllowDrop(BOOL bAllowDrop);
397
423 void AllowDrag(long nAllowDrag = xtpTaskItemAllowDragDefault);
424
433 long IsAllowDrag() const;
434
442 CFont* GetItemFont() const;
443
452 void SetItemFont(LOGFONT* pLogFont);
453
467 void SetTextRect(CDC* pDC, CRect rc, UINT nFormat);
468
477 CRect GetTextRect(UINT* pFormat = 0) const;
478
495 virtual CRect GetHitTestRect() const;
496
505 virtual CRect GetInvalidateRect() const;
506
513 DWORD_PTR GetItemData() const;
514
520 void SetItemData(DWORD_PTR dwData);
521
522public:
529 CRect& GetIconPadding();
530
537 CXTPMarkupUIElement* GetMarkupUIElement() const;
538
548 virtual CSize GetCaptionTextSize(CDC* pDC, CRect rc, UINT nFormat);
549
557 virtual void DrawCaptionText(CDC* pDC, CRect rc, UINT nFormat);
558
559public:
565 virtual void DoPropExchange(CXTPPropExchange* pPX);
566
574 void CopyToClipboard();
575
585 static CXTPTaskPanelItem* AFX_CDECL PasteFromClipboard();
586
594 void EnsureVisible();
595
596protected:
602 virtual void OnRemoved();
603
609 virtual void OnInserted();
610
611protected:
613 // System accessibility Support
614 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
615 virtual HRESULT GetAccessibleDescription(VARIANT varChild, BSTR* pszDescription);
616 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
617 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
618 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
619 VARIANT varChild);
620 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
621 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
622 virtual CCmdTarget* GetAccessible();
623 virtual HRESULT AccessibleSelect(long flagsSelect, VARIANT varChild);
626protected:
627 CXTPTaskPanel* m_pPanel;
628 CString m_strCaption;
629 CString m_strTooltip;
630 UINT m_nID;
632 XTPTaskPanelItemType m_typeItem;
634 CXTPTaskPanelItems* m_pItems;
636 int m_nIconIndex;
637 BOOL m_bEnabled;
638 BOOL m_bAllowDrop;
639 long m_nAllowDrag;
641 CRect m_rcText;
642 UINT m_nTextFormat;
643 BOOL m_bVisible;
644 CRect m_rcIconPadding;
646 DWORD_PTR m_dwData;
648 CXTPFont m_xtpFontItem;
649 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntItem, m_xtpFontItem, GetItemFontHandle);
650
651 CXTPMarkupUIElement* m_pMarkupUIElement;
653# ifdef _XTP_ACTIVEX
655 DECLARE_DISPATCH_MAP()
656 DECLARE_OLETYPELIB_EX(CXTPTaskPanelItem)
657
658 enum
659 {
660 dispidCaption = 1L,
661 dispidTooltip = 2L,
662 dispidEnabled = 3L,
663 dispidType = 4L,
664 dispidId = 5L,
665 dispidIconIndex = 6L,
666 };
667 afx_msg BSTR OleGetCaption();
668 afx_msg BSTR OleGetTooltip();
669 afx_msg LPDISPATCH OleGetGroup();
670 afx_msg LPDISPATCH OleGetParentItems();
671 int OleGetIndex();
672 COleVariant m_oleTag;
673 void OleSetIconPadding(long nLeft, long nTop, long nRight, long nBottom);
674 LPFONTDISP OleGetFont();
675 void OleSetFont(LPFONTDISP pFontDisp);
676 void SetID_(UINT nID);
677
678public:
679 static CXTPTaskPanelItem* AFX_CDECL FromDispatch(LPDISPATCH pDisp);
680
682# endif /*_XTP_ACTIVEX*/
683
684 friend class CXTPTaskPanelItems;
685 friend class CXTPTaskPanelPaintManager;
686};
687
688AFX_INLINE CXTPTaskPanel* CXTPTaskPanelItem::GetTaskPanel() const
689{
690 _ASSERTE(m_pPanel != NULL);
691 return m_pPanel;
692}
693AFX_INLINE CString CXTPTaskPanelItem::GetCaption() const
694{
695 return m_strCaption;
696}
697AFX_INLINE CString CXTPTaskPanelItem::GetTooltip() const
698{
699 return m_strTooltip;
700}
701AFX_INLINE CXTPTaskPanelItems* CXTPTaskPanelItem::GetParentItems() const
702{
703 return m_pItems;
704}
705AFX_INLINE CRect& CXTPTaskPanelItem::GetIconPadding()
706{
707 return m_rcIconPadding;
708}
709AFX_INLINE void CXTPTaskPanelItem::OnRemoved()
710{
711}
712AFX_INLINE DWORD_PTR CXTPTaskPanelItem::GetItemData() const
713{
714 return m_dwData;
715}
716AFX_INLINE void CXTPTaskPanelItem::SetItemData(DWORD_PTR dwData)
717{
718 m_dwData = dwData;
719}
720AFX_INLINE CXTPMarkupUIElement* CXTPTaskPanelItem::GetMarkupUIElement() const
721{
722 return m_pMarkupUIElement;
723}
724AFX_INLINE BOOL CXTPTaskPanelItem::IsDroppedOff() const
725{
726 return m_pPanel == NULL ? TRUE : FALSE;
727}
728
729# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
731#endif // !defined(__XTPTASKPANELITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
xtpTaskItemAllowDragDefault
@ xtpTaskItemAllowDragDefault
Default drag options (xtpTaskItemAllowDragAll).
Definition XTPTaskPanelDefines.h:98
XTPTaskPanelItemType
XTPTaskPanelItemType
XTPTaskPanelItemType is an enumeration used by CXTPTaskPanelItem to specify the type of the item.
Definition XTPTaskPanelDefines.h:74
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
CXTPTaskPanelItem::GetID
UINT GetID() const
Gets the identifier of the item.
CXTPTaskPanelItem::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
CXTPTaskPanelItem::IsVisible
BOOL IsVisible() const
Determines if the item is shown/hidden.
CXTPTaskPanelItem::DrawCaptionText
virtual void DrawCaptionText(CDC *pDC, CRect rc, UINT nFormat)
This method is called to draw caption text.
CXTPTaskPanelItem::Remove
void Remove()
Removes this item from the array of items.
CXTPTaskPanelItem::m_nID
UINT m_nID
Identifier of the item.
Definition XTPTaskPanelItem.h:630
CXTPTaskPanelItem::SetType
void SetType(XTPTaskPanelItemType typeItem)
Sets the type for the item.
CXTPTaskPanelItem::GetImage
CXTPImageManagerIcon * GetImage(int nWidth) const
Retrieves the image of the item.
CXTPTaskPanelItem::AllowDrop
void AllowDrop(BOOL bAllowDrop)
Enables/disables dropping for this item.
CXTPTaskPanelItem::m_strTooltip
CString m_strTooltip
Tooltip of the item.
Definition XTPTaskPanelItem.h:629
CXTPTaskPanelItem::AllowDrag
void AllowDrag(long nAllowDrag=xtpTaskItemAllowDragDefault)
Specifies the drag options for the item.
CXTPTaskPanelItem::IsGroup
BOOL IsGroup() const
Determines if the item is a group.
CXTPTaskPanelItem::~CXTPTaskPanelItem
virtual ~CXTPTaskPanelItem()
Destroys a CXTPTaskPanelItem object, handles cleanup and deallocation.
CXTPTaskPanelItem::IsItemDragging
BOOL IsItemDragging() const
Determines if the item is being dragged.
CXTPTaskPanelItem::GetItemFont
CFont * GetItemFont() const
Gets the item font (i.e.
CXTPTaskPanelItem::m_rcText
CRect m_rcText
Size and location of the caption text of the item.
Definition XTPTaskPanelItem.h:641
CXTPTaskPanelItem::m_typeItem
XTPTaskPanelItemType m_typeItem
Type of the item.
Definition XTPTaskPanelItem.h:632
CXTPTaskPanelItem::GetTaskPanel
CXTPTaskPanel * GetTaskPanel() const
Gets the parent Task Panel control.
Definition XTPTaskPanelItem.h:688
CXTPTaskPanelItem::IsAcceptFocus
virtual BOOL IsAcceptFocus() const
Determines if the item can be focused.
CXTPTaskPanelItem::GetIconPadding
CRect & GetIconPadding()
Retrieves the icon padding of the item.
Definition XTPTaskPanelItem.h:705
CXTPTaskPanelItem::PasteFromClipboard
static CXTPTaskPanelItem *AFX_CDECL PasteFromClipboard()
Gets the last item placed in the clipboard.
CXTPTaskPanelItem::GetInvalidateRect
virtual CRect GetInvalidateRect() const
Gets the rectangle of the "drawing zone".
CXTPTaskPanelItem::m_bAllowDrop
BOOL m_bAllowDrop
TRUE if the item can be dragged.
Definition XTPTaskPanelItem.h:638
CXTPTaskPanelItem::EnsureVisible
void EnsureVisible()
Ensures that the item is visible in the Task Panel.
CXTPTaskPanelItem::IsItemFocused
BOOL IsItemFocused() const
Determines if the item is focused.
CXTPTaskPanelItem::GetTextRect
CRect GetTextRect(UINT *pFormat=0) const
Gets the bounding rectangle of the caption text of the item.
CXTPTaskPanelItem::GetItemData
DWORD_PTR GetItemData() const
Gets the application-supplied, 32-bit value associated with the item.
Definition XTPTaskPanelItem.h:712
CXTPTaskPanelItem::GetParentItems
CXTPTaskPanelItems * GetParentItems() const
Gets the parent collection of items that this item belongs to.
Definition XTPTaskPanelItem.h:701
CXTPTaskPanelItem::IsItemPressed
BOOL IsItemPressed() const
Determines if the item is pressed.
CXTPTaskPanelItem::CreateFromOleData
static CXTPTaskPanelItem *AFX_CDECL CreateFromOleData(COleDataObject *pDataObject)
Restores a specified COleDataSource object.
CXTPTaskPanelItem::SetVisible
void SetVisible(BOOL bVisible)
Shows/hides the item.
CXTPTaskPanelItem::SetIconIndex
void SetIconIndex(int nIndex)
Sets the icon index for the item.
CXTPTaskPanelItem::m_nTextFormat
UINT m_nTextFormat
Format of the caption text of the item.
Definition XTPTaskPanelItem.h:642
CXTPTaskPanelItem::GetCaptionTextSize
virtual CSize GetCaptionTextSize(CDC *pDC, CRect rc, UINT nFormat)
This method is called to calculate boundary rectangle to fit caption.
CXTPTaskPanelItem::SetItemData
void SetItemData(DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
Definition XTPTaskPanelItem.h:716
CXTPTaskPanelItem::GetIconIndex
int GetIconIndex() const
Gets the icon index of the item.
CXTPTaskPanelItem::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption for the item.
CXTPTaskPanelItem::CXTPTaskPanelItem
CXTPTaskPanelItem()
Constructs a CXTPTaskPanelItem object.
CXTPTaskPanelItem::SetItemFont
void SetItemFont(LOGFONT *pLogFont)
Sets the item font (i.e.
CXTPTaskPanelItem::SetEnabled
void SetEnabled(BOOL bEnabled)
Enables/disables the item.
CXTPTaskPanelItem::IsAllowDrag
long IsAllowDrag() const
Determines if this item can be dragged.
CXTPTaskPanelItem::OnRemoved
virtual void OnRemoved()
This method is called when an item is removed from the parent items collection.
Definition XTPTaskPanelItem.h:709
CXTPTaskPanelItem::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup element that renders caption.
Definition XTPTaskPanelItem.h:651
CXTPTaskPanelItem::IsItemDragOver
BOOL IsItemDragOver() const
Determines if another item is being dragged over this item.
CXTPTaskPanelItem::CacheGlobalData
HGLOBAL CacheGlobalData()
Stores information to HGLOBAL about the group item being dragged.
CXTPTaskPanelItem::IsAllowDrop
BOOL IsAllowDrop() const
Determines if dropping is enabled/disabled for this item.
CXTPTaskPanelItem::GetHitTestRect
virtual CRect GetHitTestRect() const
Gets the rectangle of the "tooltip zone".
CXTPTaskPanelItem::GetCaption
CString GetCaption() const
Gets the caption of the item.
Definition XTPTaskPanelItem.h:693
CXTPTaskPanelItem::IsDroppedOff
BOOL IsDroppedOff() const
Call this method to get the identifier of the item.
Definition XTPTaskPanelItem.h:724
CXTPTaskPanelItem::SetID
void SetID(UINT nID)
Sets the identifier for the item.
CXTPTaskPanelItem::GetType
XTPTaskPanelItemType GetType() const
Gets the type of the item.
CXTPTaskPanelItem::m_pPanel
CXTPTaskPanel * m_pPanel
Parent Task Panel.
Definition XTPTaskPanelItem.h:627
CXTPTaskPanelItem::OnInserted
virtual void OnInserted()
This method is called when an item is added to the parent items collection.
CXTPTaskPanelItem::GetItemGroup
virtual CXTPTaskPanelGroup * GetItemGroup() const
Gets the group that this item belongs to.
CXTPTaskPanelItem::IsItemHot
BOOL IsItemHot() const
Determines if the item is hot.
CXTPTaskPanelItem::m_bVisible
BOOL m_bVisible
TRUE if the item is visible.
Definition XTPTaskPanelItem.h:643
CXTPTaskPanelItem::RepositionPanel
void RepositionPanel() const
Repositions the groups in the Task Panel control.
CXTPTaskPanelItem::SetTooltip
void SetTooltip(LPCTSTR lpszTooltip)
Sets the tooltip text for the item.
CXTPTaskPanelItem::GetPaintManager
CXTPTaskPanelPaintManager * GetPaintManager() const
Gets the paint manager.
CXTPTaskPanelItem::SetID
void SetID(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL)
Sets the identifier for the item.
CXTPTaskPanelItem::SetTextRect
void SetTextRect(CDC *pDC, CRect rc, UINT nFormat)
Sets the bounding rectangle for the caption text of the item.
CXTPTaskPanelItem::CopyToClipboard
void CopyToClipboard()
Copies this item to the clipboard.
CXTPTaskPanelItem::m_nIconIndex
int m_nIconIndex
Icon index.
Definition XTPTaskPanelItem.h:636
CXTPTaskPanelItem::m_pItems
CXTPTaskPanelItems * m_pItems
Collection of child items.
Definition XTPTaskPanelItem.h:634
CXTPTaskPanelItem::m_dwData
DWORD_PTR m_dwData
The 32-bit value associated with the item.
Definition XTPTaskPanelItem.h:646
CXTPTaskPanelItem::m_xtpFontItem
CXTPFont m_xtpFontItem
Font of the item.
Definition XTPTaskPanelItem.h:648
CXTPTaskPanelItem::GetTooltip
CString GetTooltip() const
Gets the tooltip text of the item.
Definition XTPTaskPanelItem.h:697
CXTPTaskPanelItem::m_rcIconPadding
CRect m_rcIconPadding
Padding/spacing placed around the item icon.
Definition XTPTaskPanelItem.h:644
CXTPTaskPanelItem::m_nAllowDrag
long m_nAllowDrag
TRUE if the item can be dropped.
Definition XTPTaskPanelItem.h:639
CXTPTaskPanelItem::CreateFromOleFile
static CXTPTaskPanelItem *AFX_CDECL CreateFromOleFile(CFile *pDataObject)
Restores the COleDataSource object contained within a specified CFile object.
CXTPTaskPanelItem::GetIndex
int GetIndex() const
Gets the index of this item within the parent collection of items.
CXTPTaskPanelItem::GetEnabled
BOOL GetEnabled() const
Determines if the item is enabled/disabled.
CXTPTaskPanelItem::m_bEnabled
BOOL m_bEnabled
TRUE if the item is enabled.
Definition XTPTaskPanelItem.h:637
CXTPTaskPanelItem::RedrawPanel
void RedrawPanel(BOOL bAnimate=FALSE) const
Redraws the parent Task Panel control.
CXTPTaskPanelItem::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
Gets the Markup element that renders the caption of the item.
Definition XTPTaskPanelItem.h:720
CXTPTaskPanelItem::m_strCaption
CString m_strCaption
Caption of the item.
Definition XTPTaskPanelItem.h:628
CXTPTaskPanelItems
CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items.
Definition XTPTaskPanelItems.h:44
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.
Definition XTPTaskPanelPaintManager.h:115


Toolkit Pro: XTPEditThemeNativeWindows11.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMENATIVEWINDOWS11_H__)
24# define __XTPEDITTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeNativeWindows11 : public CXTPEditThemeOffice2013
38{
39public:
44 CXTPEditThemeNativeWindows11();
45
50 virtual ~CXTPEditThemeNativeWindows11();
51};
52
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // __XTPEDITTHEMENATIVEWINDOWS11_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEditThemeNativeWindows11
CXTPEditThemeNativeWindows11 is a class used to perform theme drawing tasks.
Definition XTPEditThemeNativeWindows11.h:38
CXTPEditThemeNativeWindows11::~CXTPEditThemeNativeWindows11
virtual ~CXTPEditThemeNativeWindows11()
Destructor, handles cleanup and deallocation.
CXTPEditThemeNativeWindows11::CXTPEditThemeNativeWindows11
CXTPEditThemeNativeWindows11()
Constructs a CXTPEditThemeNativeWindows11 object.
CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2013.h:38


Toolkit Pro: XTPTabThemePropertyPageSelected.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemePropertyPageSelected.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEPROPERTYPAGESELECTED_H__)
24# define __XTPTABTHEMEPROPERTYPAGESELECTED_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
49class _XTP_EXT_CLASS CAppearanceSetPropertyPageSelected : public CXTPTabThemeOffice2000
50{
51public:
71 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // !defined(__XTPTABTHEMEPROPERTYPAGESELECTED_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CAppearanceSetPropertyPageSelected
CAppearanceSetPropertyPageSelected implements an "Office 2000 Selected" tab appearance.
Definition XTPTabThemePropertyPageSelected.h:50
CAppearanceSetPropertyPageSelected::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabThemeOffice2000
CXTPTabThemeOffice2000 implements an Office 2000 tab appearance.
Definition XTPTabThemeOffice2000.h:49


CXTPDockingPanePanelTheme2017 Member List

This is the complete list of members for CXTPDockingPanePanelTheme2017, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPDockingPanePanelTheme2017() | CXTPDockingPanePanelTheme2017 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


CXTPStatusBarScrollBarPane Member List

This is the complete list of members for CXTPStatusBarScrollBarPane, including all inherited members.

BestFit() | CXTPStatusBarPane |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPScrollBase() | CXTPScrollBase |
CXTPStatusBarPane() | CXTPStatusBarPane |
CXTPStatusBarScrollBarPane() | CXTPStatusBarScrollBarPane |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() const | CXTPStatusBarPane |
GetBeginGroup() const | CXTPStatusBarPane |
GetBestFit() | CXTPStatusBarPane |
GetCaption() const | CXTPStatusBarPane |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetCustomizationVisible() const | CXTPStatusBarPane |
GetIconIndex() const | CXTPStatusBarPane |
GetID() const | CXTPStatusBarPane |
GetImage() const | CXTPStatusBarPane | virtual
GetIndex() const | CXTPStatusBarPane |
GetMargins() const | CXTPStatusBarPane |
GetMarkupUIElement() const | CXTPStatusBarPane |
GetPadding() const | CXTPStatusBarPane |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetPos() const | CXTPStatusBarScrollBarPane |
GetRect() const | CXTPStatusBarPane |
GetScrollBarPaintManager() const =0 | CXTPScrollBase | pure virtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBase |
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi)=0 | CXTPScrollBase | pure virtual
GetStatusBar() const | CXTPStatusBarPane |
GetStyle() const | CXTPStatusBarPane |
GetText() const | CXTPStatusBarPane |
GetTextAlignment() const | CXTPStatusBarPane |
GetTextColor() const | CXTPStatusBarPane |
GetTextFont() | CXTPStatusBarPane | virtual
GetTextGrayColor() const | CXTPStatusBarPane |
GetTicks() const | CXTPScrollBase |
GetTooltip() const | CXTPStatusBarPane |
GetValue() const | CXTPStatusBarPane |
GetWidth() | CXTPStatusBarPane | virtual
HasBorders() const | CXTPStatusBarPane |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
IsButton() const | CXTPStatusBarPane |
IsChecked() const | CXTPStatusBarPane |
IsDark() const | CXTPStatusBarPane |
IsEnabled() const | CXTPStatusBarPane |
IsHighlighted() const | CXTPStatusBarPane |
IsPressed() const | CXTPStatusBarPane |
IsScrollBarEnabled() const =0 | CXTPScrollBase | pure virtual
IsSlider() const | CXTPScrollBase |
IsVisible() const | CXTPStatusBarPane |
m_bAnimation | CXTPScrollBase | protected
m_bAutoDeleteWnd | CXTPStatusBarPane | protected
m_bBeginGroup | CXTPStatusBarPane | protected
m_bButton | CXTPStatusBarPane | protected
m_bCustomizable | CXTPStatusBarPane | protected
m_bIsDark | CXTPStatusBarPane | protected
m_bPressed | CXTPStatusBarPane | protected
m_clrBackground | CXTPStatusBarPane | protected
m_clrText | CXTPStatusBarPane | protected
m_clrTextGray | CXTPStatusBarPane | protected
m_cxText | CXTPStatusBarPane | protected
m_dwHideFlags | CXTPStatusBarPane | protected
m_hWndPane | CXTPStatusBarPane | protected
m_nAlignment | CXTPStatusBarPane | protected
m_nBestFit | CXTPStatusBarPane | protected
m_nIconIndex | CXTPStatusBarPane | protected
m_nID | CXTPStatusBarPane | protected
m_nIndex | CXTPStatusBarPane | protected
m_nMax | CXTPStatusBarScrollBarPane | protected
m_nMin | CXTPStatusBarScrollBarPane | protected
m_nPage | CXTPStatusBarScrollBarPane | protected
m_nStyle | CXTPStatusBarPane | protected
m_nTimerElapse | CXTPScrollBase | protected
m_nValue | CXTPStatusBarScrollBarPane | protected
m_pMarkupUIElement | CXTPStatusBarPane | protected
m_pSBTrack | CXTPScrollBase | protected
m_pStatusBar | CXTPStatusBarPane | protected
m_pTicks | CXTPScrollBase | protected
m_rcMargins | CXTPStatusBarPane | protected
m_rcPadding | CXTPStatusBarPane | protected
m_rcPane | CXTPStatusBarPane | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
m_strCaption | CXTPStatusBarPane | protected
m_strText | CXTPStatusBarPane | protected
m_strToolTip | CXTPStatusBarPane | protected
m_strToolTipPart | CXTPStatusBarScrollBarPane | protected
m_strValue | CXTPStatusBarPane | protected
m_xtpFontText | CXTPStatusBarPane | protected
OnDraw(CDC *pDC, CRect rcItem) | CXTPStatusBarPane | protectedvirtual
OnLButtonDown(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnMouseMove(CPoint point) | CXTPStatusBarPane | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPStatusBarPane | protectedvirtual
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
Redraw() const | CXTPStatusBarPane |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
Remove() | CXTPStatusBarPane |
SetBackgroundColor(COLORREF clrBackground) | CXTPStatusBarPane |
SetBeginGroup(BOOL bBeginGroup=TRUE) | CXTPStatusBarPane |
SetButton(BOOL bButton=TRUE) | CXTPStatusBarPane |
SetCaption(LPCTSTR lpszCaption) | CXTPStatusBarPane |
SetChecked(BOOL bChecked) | CXTPStatusBarPane |
SetCustomizationVisible(BOOL bVisible) | CXTPStatusBarPane |
SetDark(BOOL bDark=TRUE) | CXTPStatusBarPane |
SetEnabled(BOOL bEnabled) | CXTPStatusBarPane |
SetIconIndex(int nIconIndex) | CXTPStatusBarPane |
SetMargins(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPos(int nValue) | CXTPStatusBarScrollBarPane |
SetRange(int nMin, int nMax) | CXTPStatusBarScrollBarPane |
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetStyle(UINT nStyle) | CXTPStatusBarPane |
SetText(LPCTSTR lpszText) | CXTPStatusBarPane |
SetTextAlignment(int nAlign) | CXTPStatusBarPane |
SetTextColor(COLORREF clrText) | CXTPStatusBarPane |
SetTextFont(CFont *pFntText) | CXTPStatusBarPane |
SetTextFont(PLOGFONT pLogfText) | CXTPStatusBarPane |
SetTextGrayColor(COLORREF clrText) | CXTPStatusBarPane |
SetTicks(double *pTicks, int nCount) | CXTPScrollBase |
SetTooltip(LPCTSTR lpszTooltip) | CXTPStatusBarPane |
SetTooltipPart(int nPart, LPCTSTR lpszTooltip) | CXTPStatusBarScrollBarPane |
SetValue(LPCTSTR lpszValue) | CXTPStatusBarPane |
SetVisible(BOOL bVisible, BOOL bRecalcLayout=TRUE) | CXTPStatusBarPane |
SetWidth(int nWidth) | CXTPStatusBarPane |
ShowBorders(BOOL bShowBorders) | CXTPStatusBarPane |
~CXTPScrollBase() | CXTPScrollBase | virtual
~CXTPStatusBarPane() | CXTPStatusBarPane | virtual
~CXTPStatusBarScrollBarPane() | CXTPStatusBarScrollBarPane | virtual


CXTPShortcutManager Member List

This is the complete list of members for CXTPShortcutManager, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutManager(CXTPCommandBars *pCommandBars) | CXTPShortcutManager |
DisableShortcuts(BOOL bDisable) | CXTPShortcutManager | virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPShortcutManager | virtual
FindDefaultAccelerator(int nCmd, CString &strShortcut) | CXTPShortcutManager | virtual
FindDefaultFrameAccelerator(int nCmd, CString &strShortcut) | CXTPShortcutManager |
Format(CXTPShortcutManagerAccel *lpAccel, int *pPriority) | CXTPShortcutManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDefaultAccelerator() const | CXTPShortcutManager | virtual
GetKeyNameText(UINT uiVirtKey) | CXTPShortcutManager | virtual
GetOriginalAccelerator() const | CXTPShortcutManager |
LoadShortcuts(LPCTSTR lpszProfileName) | CXTPShortcutManager |
m_bAllowDoubleKeyShortcuts | CXTPShortcutManager |
m_bAllowEscapeShortcut | CXTPShortcutManager |
m_bDisableOnCapture | CXTPShortcutManager |
m_bUseSystemKeyNameText | CXTPShortcutManager |
m_nDisableShortcuts | CXTPShortcutManager |
m_nEnableCustomShortcutText | CXTPShortcutManager |
m_pAccelTable | CXTPShortcutManager | protected
m_pCommandBars | CXTPShortcutManager | protected
m_pKeyNameText | CXTPShortcutManager | protected
m_pOriginalAccelTable | CXTPShortcutManager | protected
OnBeforeAdd(CXTPShortcutManagerAccel *pAccel) | CXTPShortcutManager | virtual
OnBeforeRemove(CXTPShortcutManagerAccel *pAccel) | CXTPShortcutManager | virtual
OnPreviewEditKey(CXTPShortcutManagerAccel *pAccel) | CXTPShortcutManager | virtual
Reset() | CXTPShortcutManager | virtual
SaveShortcuts(LPCTSTR lpszProfileName) | CXTPShortcutManager |
SetAccelerators(UINT nIDResource) | CXTPShortcutManager |
SetDefaultAccelerator(HACCEL hAccelTable) | CXTPShortcutManager |
SetKeyNameText(UINT uiVirtKey, LPCTSTR lpszKeyNameText) | CXTPShortcutManager |
TranslateAccelerator(LPMSG lpMsg) | CXTPShortcutManager | virtual
UseSystemKeyNameText(BOOL bSystemKey) | CXTPShortcutManager |
~CXTPShortcutManager() | CXTPShortcutManager |


Toolkit Pro: XTPChartGdiDeviceContext.h Source File

  • Source
  • Chart
  • Drawing
  • Gdi
XTPChartGdiDeviceContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTGDIDEVICECONTEXT_H__)
24# define __XTPCHARTGDIDEVICECONTEXT_H__
25
26# if _MSC_VER >= 1000
27# pragma once
28# endif // _MSC_VER >= 1000
29
30# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
31
32namespace Gdiplus
33{
34class GpGraphics;
35class GpFont;
36class Graphics;
37} // namespace Gdiplus
38
39class CXTPChartContainer;
40class CXTPChartDeviceCommand;
41
42class _XTP_EXT_CLASS CXTPChartGdiDeviceContext : public CXTPChartDeviceContext
43{
44 DECLARE_DYNAMIC(CXTPChartGdiDeviceContext);
45
46public:
55 CXTPChartGdiDeviceContext(CXTPChartContainer* pContainer, HDC hDC,
56 CXTPChartDeviceContext* p3dDC = NULL);
57
66 CXTPChartGdiDeviceContext(CXTPChartContainer* pContainer, Gdiplus::Graphics*, HDC hDC);
67
72 ~CXTPChartGdiDeviceContext();
73
78 static void AFX_CDECL Register(BOOL bReserved);
79
86 virtual void Execute(CXTPChartDeviceCommand* pCommand);
87
94 Gdiplus::GpGraphics* GetGraphics() const;
95
96 virtual BOOL GetNativeDrawing() const;
97
98 virtual void SetNativeDrawing(BOOL bNativeDrawing);
99
108 virtual CXTPChartSizeF MeasureString(const CXTPChartString* pText, CXTPChartFont* pFont);
109
110 static void AFX_CDECL SaveToFile(HBITMAP hBitmap, LPCTSTR lpszFileName);
111
112 virtual CXTPChartSizeF MeasureMarkupElement(CXTPMarkupUIElement* pMarkupUIElement,
113 CXTPChartFont* pFont);
114
115protected:
116 ULONG_PTR m_nGdiplusToken;
117 Gdiplus::GpGraphics* m_pGpGraphics;
118 CXTPChartDeviceContext* m_p3dDC;
120};
121
122AFX_INLINE Gdiplus::GpGraphics* CXTPChartGdiDeviceContext::GetGraphics() const
123{
124 return m_pGpGraphics;
125}
126AFX_INLINE BOOL CXTPChartGdiDeviceContext::GetNativeDrawing() const
127{
128 return TRUE;
129}
130AFX_INLINE void CXTPChartGdiDeviceContext::SetNativeDrawing(BOOL /*bNativeDrawing*/)
131{
132}
133
134# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
135#endif //#if !defined(__XTPCHARTGDIDEVICECONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDeviceContext::MeasureMarkupElement
virtual CXTPChartSizeF MeasureMarkupElement(CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont)=0
Measures the markup element size provided with the font set as the default font for the associated ma...
CXTPChartDeviceContext::Execute
virtual void Execute(CXTPChartDeviceCommand *pCommand)
Call this function to trigger the drawing.
CXTPChartDeviceContext::MeasureString
virtual CXTPChartSizeF MeasureString(const CXTPChartString *pText, CXTPChartFont *pFont)=0
Call this function to get the measurements of texts rendered in a device context using a specific fon...
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


CXTPChartPyramidSeriesLabelView Member List

This is the complete list of members for CXTPChartPyramidSeriesLabelView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPyramidSeriesLabelView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesLabelView |
CXTPChartPyramidSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPyramidSeriesLabelViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartPyramidSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


CXTPTextOnPath Member List

This is the complete list of members for CXTPTextOnPath, including all inherited members.


CXTPMDIFrameWnd Member List

This is the complete list of members for CXTPMDIFrameWnd, including all inherited members.

CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
CXTPFrameWndBase() | CXTPFrameWndBase< CMDIFrameWnd > | inline
DECLARE_DYNCREATE(CXTPMDIFrameWnd) CXTPMDIFrameWnd() | CXTPMDIFrameWnd |
DockRightOf(CXTPToolBar *pBarToDock, CXTPToolBar *pBarOnLeft) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
GetCommandBars() const | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
InitCommandBars(CRuntimeClass *pCommandBarsClass=RUNTIME_CLASS(CXTPCommandBars)) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
LoadCommandBars(LPCTSTR lpszProfileName, BOOL bSilent=FALSE) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
SaveCommandBars(LPCTSTR lpszProfileName) | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inlinevirtual
UpdateMDIChildrenTheme() | CXTPMDIFrameWnd |
~CXTPCommandBarsSiteBase() | CXTPCommandBarsSiteBase< CMDIFrameWnd > | inline
~CXTPFrameWndBase() | CXTPFrameWndBase< CMDIFrameWnd > | inline


CXTPTrackUndoGroupCommand Member List

This is the complete list of members for CXTPTrackUndoGroupCommand, including all inherited members.

Add(CXTPTrackUndoCommand *pCommand) | CXTPTrackUndoGroupCommand |
CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
CXTPTrackUndoGroupCommand(CXTPTrackUndoManager *pManager) | CXTPTrackUndoGroupCommand | protected
GetCount() const | CXTPTrackUndoGroupCommand |
GetID() const | CXTPTrackUndoCommand |
m_arrUndoCommands | CXTPTrackUndoGroupCommand | protected
m_nID | CXTPTrackUndoCommand | protected
m_pManager | CXTPTrackUndoGroupCommand | protected
Undo() | CXTPTrackUndoGroupCommand | virtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual
~CXTPTrackUndoGroupCommand() | CXTPTrackUndoGroupCommand | protectedvirtual


Toolkit Pro: XTPDockingPaneTabTheme2017.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPaneTabTheme2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABTHEME2017_H__)
24# define __XTPDOCKINGPANETABTHEME2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabTheme2017 : public CXTPDockingPaneTabTheme2012
39{
40public:
45 CXTPDockingPaneTabTheme2017();
46
63 virtual void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
64};
65
66# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
68#endif // !defined(__XTPDOCKINGPANETABTHEME2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2012.h:39
CXTPDockingPaneTabTheme2017
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabTheme2017.h:39
CXTPDockingPaneTabTheme2017::CXTPDockingPaneTabTheme2017
CXTPDockingPaneTabTheme2017()
Default class constructor.
CXTPDockingPaneTabTheme2017::DrawSingleButton
virtual void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
This method is called to draw a single tab button in the tab client header area.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44


CXTPActiveScriptStdRuntime Member List

This is the complete list of members for CXTPActiveScriptStdRuntime, including all inherited members.

CXTPActiveScriptStdRuntime() | CXTPActiveScriptStdRuntime |
CXTPActiveScriptStdRuntime(IActiveScriptSite *pSite, BOOL bAddSiteRef=TRUE) | CXTPActiveScriptStdRuntime |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
Shutdown() | CXTPActiveScriptStdRuntime |
~CXTPActiveScriptStdRuntime() | CXTPActiveScriptStdRuntime |


CXTPExcelTabCtrlThemeOffice2003 Member List

This is the complete list of members for CXTPExcelTabCtrlThemeOffice2003, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |
CXTPExcelTabCtrlThemeOffice2003() | CXTPExcelTabCtrlThemeOffice2003 |
CXTPExcelTabCtrlThemeOfficeXP() | CXTPExcelTabCtrlThemeOfficeXP |
DrawButton(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlTheme | virtual
DrawButtonBack(CDC *pDC, CRect &rect, const CXTPExcelTabCtrlButtonState &state) | CXTPExcelTabCtrlThemeOffice2003 | virtual
DrawGripper(CDC *pDC, CRect rect) | CXTPExcelTabCtrlTheme | virtual
DrawTab(CDC *pDC, CXTPExcelTabCtrl *pTabCtrl, const CPoint &pt, bool bSelected, CXTPTcbItem *pTcbItem) | CXTPExcelTabCtrlTheme | virtual
FillBackground(CDC *pDC, CRect &rect, BOOL bBottom) | CXTPExcelTabCtrlTheme | virtual
FillTabsBackground(CDC *pDC, int cx, int cy) | CXTPExcelTabCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetSelTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetSelTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabBackColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetTabTextColor(CXTPTcbItem *pTcbItem) const | CXTPExcelTabCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_clr3DFace | CXTPExcelTabCtrlTheme |
m_clr3DFaceHilite | CXTPExcelTabCtrlTheme |
m_clr3DFacePushed | CXTPExcelTabCtrlTheme |
m_clr3DHilight | CXTPExcelTabCtrlTheme |
m_clr3DShadow | CXTPExcelTabCtrlTheme |
m_clrBorder3DHilite | CXTPExcelTabCtrlTheme |
m_clrBorder3DShadow | CXTPExcelTabCtrlTheme |
m_clrBtnText | CXTPExcelTabCtrlTheme |
m_clrBtnTextGray | CXTPExcelTabCtrlTheme |
m_clrBtnTextHilite | CXTPExcelTabCtrlTheme |
m_clrBtnTextPushed | CXTPExcelTabCtrlTheme |
m_clrWindow | CXTPExcelTabCtrlTheme |
m_clrWindowText | CXTPExcelTabCtrlTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPExcelTabCtrl *pTab) | CXTPExcelTabCtrlThemeOffice2003 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPExcelTabCtrlTheme() | CXTPExcelTabCtrlTheme |


Toolkit Pro: XTPChart3dFunnelSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
XTPChart3dFunnelSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYPAMIDSERIESPOINTVIEW_H__)
24# define __XTPCHART3DFUNNELSERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesPointView
45 : public CXTPChartFunnelSeriesPointViewBase
46 , private CXTPChart3dFunnelDeviceCommandEvents
47{
48 DECLARE_DYNAMIC(CXTPChart3dFunnelSeriesPointView);
49
50public:
58 CXTPChart3dFunnelSeriesPointView(CXTPChartSeriesPoint* pPoint,
59 CXTPChartElementView* pParentView);
60
65 virtual ~CXTPChart3dFunnelSeriesPointView();
66
67public:
77 virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo);
78
89 const CXTPPoint3d& GetCenterShapeConnectorPoint() const;
90
101 const CXTPPoint3d& GetOuterCenterConnectorPoint() const;
102
103protected:
116 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
117
128 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
129 CRect rcBounds);
130
131protected:
139 virtual void OnUpdateBounds(CXTPChartDeviceCommand* pCommand, CRect rcBounds);
140
149 virtual void OnSetConnectorPoints(CXTPChartDeviceCommand* pCommand, CXTPPoint3d ptShapeCenter,
150 CXTPPoint3d ptOuterCenter);
151
152private:
153 CXTPChartFunnelSeriesPointViewBase* m_p2dSeriesPointView;
155 CXTPPoint3d m_ptShapeCenter;
156 CXTPPoint3d m_ptOuterCenter;
157 CXTPSubscriptionList<CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents>*
158 m_pCommandSubscriptionList;
159
160 // double m_dWidth;
161 // double m_dHeight;
162 // double m_dFrom;
163 // double m_dTo;
164};
165
166AFX_INLINE const CXTPPoint3d& CXTPChart3dFunnelSeriesPointView::GetCenterShapeConnectorPoint() const
167{
168 return m_ptShapeCenter;
169}
170
171AFX_INLINE const CXTPPoint3d& CXTPChart3dFunnelSeriesPointView::GetOuterCenterConnectorPoint() const
172{
173 return m_ptOuterCenter;
174}
176# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
177#endif //#if !defined(__XTPCHART3DFUNNELSERIESPOINTVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dFunnelDeviceCommandEvents
Defines interface for 3D chart funnel device command event sink.
Definition XTPChart3dFunnelDeviceCommandEvents.h:42
CXTPChart3dFunnelSeriesPointView
This class abstracts the view of a funnel series point.
Definition XTPChart3dFunnelSeriesPointView.h:47
CXTPChart3dFunnelSeriesPointView::GetOuterCenterConnectorPoint
const CXTPPoint3d & GetOuterCenterConnectorPoint() const
Obtains the outer shape center connector point.
Definition XTPChart3dFunnelSeriesPointView.h:171
CXTPChart3dFunnelSeriesPointView::OnSetConnectorPoints
virtual void OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when funnel connector points are computed.
CXTPChart3dFunnelSeriesPointView::GetCenterShapeConnectorPoint
const CXTPPoint3d & GetCenterShapeConnectorPoint() const
Obtains the shape center connector point.
Definition XTPChart3dFunnelSeriesPointView.h:166
CXTPChart3dFunnelSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChart3dFunnelSeriesPointView::~CXTPChart3dFunnelSeriesPointView
virtual ~CXTPChart3dFunnelSeriesPointView()
Handles view destruction.
CXTPChart3dFunnelSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChart3dFunnelSeriesPointView::OnUpdateBounds
virtual void OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries of the command result.
CXTPChart3dFunnelSeriesPointView::CalculateLayout
virtual void CalculateLayout(int nIndex, int nCount, double dFrom, double dTo)
Use this function to calculate the layout of the funnel series point.
CXTPChart3dFunnelSeriesPointView::CXTPChart3dFunnelSeriesPointView
CXTPChart3dFunnelSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dFunnelSeriesPointView object.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelSeriesPointViewBase
This class abstracts the view of a funnel series point.
Definition XTPChartFunnelSeriesPointViewBase.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPPoint3T< double >
CXTPSubscriptionList
Holds a list of observable objects to which an oberser is subscribed.
Definition XTPSystemHelpers.h:2090


CXTPCalendarWeekView Member List

This is the complete list of members for CXTPCalendarWeekView, including all inherited members.

_CalculateEventTimeFormat() | CXTPCalendarView | protectedvirtual
_CanSubjectEditor(UINT idEditCmd) const | CXTPCalendarView | protectedvirtual
_CopySelectedEvents(DWORD dwCopyFlags=0) | CXTPCalendarView | protectedvirtual
_GetDayHeaderFormat(int nLevel) const | CXTPCalendarView | protectedvirtual
_GetMaxWidth(CDC *pDC, CString strFormat) const | CXTPCalendarView | protectedvirtual
_GetMaxWidthFormat(CDC *pDC, CString strFormat, BOOL bMonth) const | CXTPCalendarView | protectedvirtual
_GetSubjectEditorWnd() const | CXTPCalendarView | protectedvirtual
_GetViewDay(const COleDateTime &dtDay) const | CXTPCalendarView | virtual
_IsDragModeCopyMove(int eDragMode) const | CXTPCalendarView | protected
_ReadDefaultHeaderFormats() | CXTPCalendarView | protectedvirtual
_ReadEventsFromClipboard(COleDataObject *pData, DWORD *pdwCopyFlags=NULL) | CXTPCalendarView | protectedvirtual
_RemoveYearPart(CString &strFormat) | CXTPCalendarView | protectedvirtual
_Undo(CXTPCalendarEvent *pEvent=NULL) | CXTPCalendarView | protectedvirtual
AddToDiscreteSelection(UINT id) | CXTPCalendarView |
AdjustFirstDayOfWeek() | CXTPCalendarWeekView | protectedvirtual
AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarWeekView | virtual
AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE) | CXTPCalendarWeekView | virtual
CalculateHeaderFormat(CDC *pDC, int nWidth, CFont *pTextFont) | CXTPCalendarView | virtual
CancelDraggingEvent() | CXTPCalendarView | virtual
CanCopy() const | CXTPCalendarView | virtual
CanCut() const | CXTPCalendarView | virtual
CanPaste() const | CXTPCalendarView | virtual
CanRedo() const | CXTPCalendarView | virtual
CanUndo() const | CXTPCalendarView | virtual
ClearDiscreteSelection() | CXTPCalendarView |
CommitDraggingEvent() | CXTPCalendarView | virtual
Copy() | CXTPCalendarView | virtual
Cut() | CXTPCalendarView | virtual
CXTPCalendarView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarView |
CXTPCalendarViewT(CXTPCalendarControl *pCalendarControl, XTPCalendarViewType nViewType) | CXTPCalendarViewT< CXTPCalendarWeekViewDay > | inline
CXTPCalendarWeekView(CXTPCalendarControl *pCalendarControl) | CXTPCalendarWeekView |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC) | CXTPCalendarWeekView | virtual
Draw2(CDC *pDC) | CXTPCalendarWeekView | virtual
EmptyUndoBuffer() | CXTPCalendarView | virtual
EnableHScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EnableVScroll(BOOL bEnable=TRUE) | CXTPCalendarView | virtual
EndEditSubject(XTPCalendarEndEditSubjectAction eAction, BOOL bUpdateControl=TRUE) | CXTPCalendarView | virtual
FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL) | CXTPCalendarView | virtual
FindLastSelectedDay() const | CXTPCalendarView |
FindViewEvent(CXTPCalendarEvent *pEvent, COleDateTime dtDay) const | CXTPCalendarView | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarView | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBeginDate() const | CXTPCalendarWeekView |
GetCalendarControl() const | CXTPCalendarView |
GetCalendarOptions() const | CXTPCalendarView |
GetChildHandlerAt(int nIndex) const | CXTPCalendarView | virtual
GetChildHandlersCount() const | CXTPCalendarView | virtual
GetDayHeaderFormat() const | CXTPCalendarView | virtual
GetDayHeaderHeight() const | CXTPCalendarWeekView |
GetDayHeight() const | CXTPCalendarWeekView |
GetDayWidth() const | CXTPCalendarWeekView |
GetDiscreteSelectionCount() const | CXTPCalendarView |
GetDiscreteSelectionValue(UINT id) const | CXTPCalendarView |
GetDraggingEventNew() const | CXTPCalendarView | virtual
GetDraggingEventOrig() const | CXTPCalendarView | virtual
GetDraggingMode() const | CXTPCalendarView | virtual
GetEventDurationMin() const | CXTPCalendarView | protectedvirtual
GetItemTextEventTimeMax() const | CXTPCalendarView | virtual
GetLastSelectedDate() const | CXTPCalendarView |
GetLastSelectedViewEvent() const | CXTPCalendarView |
GetNextTimeEditByTAB() const | CXTPCalendarView | virtual
GetPaintManager() const | CXTPCalendarView | virtual
GetResources() const | CXTPCalendarView | virtual
GetRowHeight() const | CXTPCalendarView | virtual
GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const | CXTPCalendarView | inlinevirtual
GetScrollBarInfoV(SCROLLINFO *pSI) const | CXTPCalendarWeekView | virtual
GetSelectedEvents() const | CXTPCalendarView | virtual
GetSelectedViewEvents() const | CXTPCalendarView | virtual
GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const | CXTPCalendarView | virtual
GetShowToolTipTimeOut() const | CXTPCalendarView | virtual
GetStartEditSubjectTimeOut() const | CXTPCalendarView | virtual
GetSubjectEditorRect() const | CXTPCalendarView | virtual
GetTheme() const | CXTPCalendarView | virtual
GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const | CXTPCalendarView | virtual
GetViewDay(int nIndex) const | CXTPCalendarViewT< CXTPCalendarWeekViewDay > | inlinevirtual
GetViewDay_(int nIndex) const | CXTPCalendarView | virtual
GetViewDayCount() const | CXTPCalendarView | virtual
GetViewDayDate(int nIndex) const | CXTPCalendarWeekView | virtual
GetViewRect() const | CXTPCalendarView |
GetViewType() const | CXTPCalendarViewT< CXTPCalendarWeekViewDay > | inlinevirtual
HasSelectedViewEvent() const | CXTPCalendarView | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarView | virtual
IsEditingSubject() const | CXTPCalendarView | virtual
IsEditOperationDisabledNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) const | CXTPCalendarView | protected
IsHScrollEnabled() const | CXTPCalendarView | virtual
IsInDiscreteSelection(UINT id) const | CXTPCalendarView |
IsSingleEventSelected() const | CXTPCalendarView |
IsTodayVisible() const | CXTPCalendarView | virtual
IsVScrollEnabled() const | CXTPCalendarView | virtual
KillTimer(UINT uTimerID) | CXTPCalendarView | protectedvirtual
m_arDays | CXTPCalendarView | mutableprotected
m_bResetUndoBuffer | CXTPCalendarView | protected
m_bScrollH_Disabled | CXTPCalendarView | protected
m_bScrollV_Disabled | CXTPCalendarView | protected
m_bStartedClickInside | CXTPCalendarView | protected
m_cntSelChanged | CXTPCalendarView | protected
m_dtBeginDate | CXTPCalendarWeekView | protected
m_eDraggingMode | CXTPCalendarView | protected
m_eUndoMode | CXTPCalendarView | protected
m_EventTimeFormat | CXTPCalendarView | protected
m_LastHitInfo | CXTPCalendarView | protected
m_Layout | CXTPCalendarView | protected
m_LayoutX | CXTPCalendarWeekView | protected
m_nCurrPos | CXTPCalendarWeekView | protected
m_nFirstDayOfWeekIndex | CXTPCalendarWeekView | protected
m_nKeyStateTimerID | CXTPCalendarView | protected
m_nTimerID_ShowToolTip | CXTPCalendarView | protected
m_nTimerID_StartEditSubject | CXTPCalendarView | protected
m_pControl | CXTPCalendarView | protected
m_pLastEvent | CXTPCalendarView | protected
m_pPrevUndoBuffer | CXTPCalendarView | protected
m_pResources | CXTPCalendarView | protected
m_pSelectedEvents | CXTPCalendarView | protected
m_ptrDraggingEventNew | CXTPCalendarView | protected
m_ptrDraggingEventOrig | CXTPCalendarView | protected
m_ptrEditingViewEvent | CXTPCalendarView | protected
m_ptStartDragging | CXTPCalendarView | protected
m_pUndoBuffer | CXTPCalendarView | protected
m_rcTooltip | CXTPCalendarView | protected
m_rcView | CXTPCalendarView | protected
m_selectedBlock | CXTPCalendarView | protected
m_spDraggingStartOffset | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultLong | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShort | CXTPCalendarView | protected
m_strDayHeaderFormatDefaultShortest | CXTPCalendarView | protected
m_strDayHeaderFormatLong | CXTPCalendarView | protected
m_strDayHeaderFormatMiddle | CXTPCalendarView | protected
m_strDayHeaderFormatShort | CXTPCalendarView | protected
m_strDayHeaderFormatShortest | CXTPCalendarView | protected
m_strHeaderFormat | CXTPCalendarView | protected
OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView) | CXTPCalendarView | protectedvirtual
OnBeforeDestroy() | CXTPCalendarView | protectedvirtual
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvent *pEventView) | CXTPCalendarView | protected
OnBeforeEditOperationNotify(XTPCalendarEditOperation eOperation, CXTPCalendarViewEvents *pEventViews) | CXTPCalendarView | protected
OnBeforePasteNotify(CXTPCalendarEvent *pEvent, BOOL bPasteWillChangeExistingEvent) | CXTPCalendarView | protected
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnDraw(CDC *pDC) | CXTPCalendarView | virtual
OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo) | CXTPCalendarView | virtual
OnEventChanged_InDataProvider(XTP_NOTIFY_CODE nfCode, CXTPCalendarEvent *pEvent) | CXTPCalendarView | protectedvirtual
OnInPlaceCreateEvent(LPCTSTR pcszInitialSubject) | CXTPCalendarView | protected
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWeekView | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarView | virtual
OnPostAdjustLayout() | CXTPCalendarWMHandler | virtual
OnScrollEnd(int nBar) | CXTPCalendarView | inlinevirtual
OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest) | CXTPCalendarView | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarView | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarView | protectedvirtual
OnUpdateEditingSubject(CString strNewSubject) | CXTPCalendarView | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarWMHandler | virtual
Paste() | CXTPCalendarView | virtual
Populate() | CXTPCalendarWeekView | virtual
ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
ProcessEventSelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags) | CXTPCalendarView | virtual
Redo() | CXTPCalendarView | virtual
RedrawControl() | CXTPCalendarView | virtual
ResetCustomTimeFormat() | CXTPCalendarView |
ResetSelection() | CXTPCalendarView |
RetrieveDayEvents(CXTPCalendarResource *pRC, COleDateTime dtDay) | CXTPCalendarView | virtual
ScrollH(int nPos, int nPos_raw) | CXTPCalendarView | inlinevirtual
ScrollV(int nPos, int nPos_raw) | CXTPCalendarWeekView | virtual
SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDay(COleDateTime dtSelDay, int nGroupIndex=0) | CXTPCalendarView | virtual
SelectDays(COleDateTime dtNewSel) | CXTPCalendarView | virtual
SelectEvent(CXTPCalendarEvent *pEvent, BOOL bSelect=TRUE) | CXTPCalendarView | virtual
SelectionContains(COleDateTime date, int nGroupIndex=-1, BOOL *pbAllDaySelection=NULL) | CXTPCalendarView |
SelectViewEvent(CXTPCalendarViewEvent *pViewEvent, BOOL bSelect=TRUE) | CXTPCalendarView |
SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam=0, LPARAM lParam=0) | CXTPCalendarView | protectedvirtual
SetBeginDate(COleDateTime dtNewBeginDate) | CXTPCalendarWeekView |
SetCustomTimeFormat(const CString &strFormat) | CXTPCalendarView |
SetDayHeaderFormat(LPCTSTR sFmt) | CXTPCalendarView | virtual
SetDayHeaderFormatLong(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatMiddle(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShort(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDayHeaderFormatShortest(LPCTSTR pcszCustomFormat) | CXTPCalendarView | virtual
SetDraggingEvent(CXTPCalendarEvent *pEventOrig) | CXTPCalendarView | virtual
SetResources(CXTPCalendarResources *pResources) | CXTPCalendarView | virtual
SetSelection(const COleDateTime &dtBegin, const COleDateTime &dtEnd, BOOL bAllDayEvent=FALSE, int nGroupIndex=0) | CXTPCalendarView |
SetTimer(UINT uTimeOut_ms) | CXTPCalendarView | protectedvirtual
ShowDay(const COleDateTime &date, BOOL bSelect=TRUE) | CXTPCalendarWeekView | virtual
ShowToolTip(BOOL bShow=TRUE) | CXTPCalendarView | virtual
StartEditNewEventInplace(LPCTSTR pcszInitialSubject) | CXTPCalendarView | virtual
StartEditSubject(CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarView | virtual
TBase typedef | CXTPCalendarWeekView |
Undo() | CXTPCalendarView | virtual
UnselectAllEvents() | CXTPCalendarView | virtual
UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE) | CXTPCalendarView | virtual
~CXTPCalendarView() | CXTPCalendarView | virtual
~CXTPCalendarViewT() | CXTPCalendarViewT< CXTPCalendarWeekViewDay > | inlinevirtual
~CXTPCalendarWeekView() | CXTPCalendarWeekView | virtual


Toolkit Pro: XTPControlPopup.h Source File

  • Source
  • CommandBars
XTPControlPopup.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLPOPUP_H__)
24# define __XTPCONTROLPOPUP_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBar;
34class CXTPControls;
35
41class _XTP_EXT_CLASS CXTPControlPopup : public CXTPControlButton
42{
43public:
48 CXTPControlPopup();
49
54 virtual ~CXTPControlPopup();
55
56public:
70 static CXTPControlPopup* AFX_CDECL CreateControlPopup(XTPControlType controlType);
71
72public:
78 void SetCommandBar(CMenu* pMenu);
79
85 void SetCommandBar(CXTPCommandBar* pBar);
86
93 CXTPCommandBar* GetCommandBar() const;
94
101 BOOL GetPopuped() const;
102
109 virtual CString GetCaption() const;
110
116 void DoPropExchange(CXTPPropExchange* pPX);
117
124 virtual void AdjustExcludeRect(CRect& rc, BOOL bVertical);
125
132 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
133
138 virtual void OnUnderlineActivate();
139
140protected:
149 BOOL ContainsPopup(CXTPControlPopup* pControlPopup);
150
152 _XTP_DEPRECATED_IN_FAVOR(ContainsPopup)
153 BOOL IsContainPopup(CXTPControlPopup* pControlPopup)
154 {
155 return ContainsPopup(pControlPopup);
156 }
163 void ExpandCommandBar();
164
172 BOOL OnSetSelected(int bSelected);
173
180 void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
181
186 void OnMouseHover();
187
193 virtual void OnMouseMove(CPoint point);
194
202 virtual BOOL OnSetPopup(BOOL bPopup);
203
210 virtual void OnLButtonUp(CPoint point);
211
220 virtual BOOL OnLButtonDblClk(CPoint point);
221
230 void OnCustomizeDragOver(CXTPControl* pDataObject, CPoint point, DROPEFFECT& dropEffect);
231
241 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
242 DROPEFFECT& dropEffect);
243
251 virtual BOOL Compare(CXTPControl* pOther);
252
257 virtual void UpdateShadow();
258
259protected:
267 virtual void RestoreCommandBarList(CXTPCommandBarList* pCommandBarList);
268
269protected:
270 BOOL m_bPopup;
271 CXTPCommandBar* m_pCommandBar;
272 DWORD m_dwCommandBarID;
273 BOOL m_bShowShadow;
275public:
276# ifdef _XTP_COMMANDBARS_ACTIVEX
279 DECLARE_DISPATCH_MAP()
280 DECLARE_INTERFACE_MAP()
281
282 DECLARE_OLETYPELIB_EX(CXTPControlPopup);
283
284 afx_msg LPDISPATCH OleGetCommandBar();
285 afx_msg void OleSetCommandBar(LPDISPATCH lpCommandBar);
286 enum
287 {
288 dispidCommandBar = 50L,
289 dispidStyle = 51L,
290 };
291
293# endif
294 DECLARE_XTP_CONTROL(CXTPControlPopup)
295 friend class CXTPControls;
296 friend class CXTPPopupBar;
297 friend class CXTPCommandBar;
298};
299
301
302AFX_INLINE CXTPCommandBar* CXTPControlPopup::GetCommandBar() const
303{
304 return m_pCommandBar;
305}
306AFX_INLINE BOOL CXTPControlPopup::GetPopuped() const
307{
308 return m_bPopup;
309}
311# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
312#endif //#if !defined(__XTPCONTROLPOPUP_H__)
XTPControlType
XTPControlType
Type of the control.
Definition XTPCommandBarsDefines.h:111
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::GetCommandBar
virtual CXTPCommandBar * GetCommandBar() const
Call this member to get the child command bar.
Definition XTPControl.h:2689
CXTPControl::GetPopuped
virtual BOOL GetPopuped() const
Call this member to get the control's pop-up state.
Definition XTPControl.h:2771
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPControlPopup::CreateControlPopup
static CXTPControlPopup *AFX_CDECL CreateControlPopup(XTPControlType controlType)
Creates a CXTPControlPopup object with the specified type.
CXTPControlPopup::ExpandCommandBar
void ExpandCommandBar()
Call this member to expand the parent pop-up bar.
CXTPControlPopup::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlPopup::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlPopup::OnMouseHover
void OnMouseHover()
This method is called after the mouse hovers over the control.
CXTPControlPopup::~CXTPControlPopup
virtual ~CXTPControlPopup()
Destroys a CXTPControlPopup object, handles cleanup and deallocation.
CXTPControlPopup::m_dwCommandBarID
DWORD m_dwCommandBarID
Child pop-up ID.
Definition XTPControlPopup.h:272
CXTPControlPopup::m_pCommandBar
CXTPCommandBar * m_pCommandBar
Child pop-up bar.
Definition XTPControlPopup.h:271
CXTPControlPopup::ContainsPopup
BOOL ContainsPopup(CXTPControlPopup *pControlPopup)
This method is called to check if pControlPopup contains in the control recursively.
CXTPControlPopup::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPControlPopup::GetCaption
virtual CString GetCaption() const
Call this member to get the control's caption.
CXTPControlPopup::OnUnderlineActivate
virtual void OnUnderlineActivate()
This method is called when the user activates a control using its underline.
CXTPControlPopup::GetCommandBar
CXTPCommandBar * GetCommandBar() const
Call this member to get the child command bar.
Definition XTPControlPopup.h:302
CXTPControlPopup::OnLButtonDblClk
virtual BOOL OnLButtonDblClk(CPoint point)
This member is called when the user double-clicks the left mouse button.
CXTPControlPopup::GetPopuped
BOOL GetPopuped() const
Call this member to get the control's pop-up state.
Definition XTPControlPopup.h:306
CXTPControlPopup::SetCommandBar
void SetCommandBar(CXTPCommandBar *pBar)
Call this member to set the child command bar.
CXTPControlPopup::OnSetSelected
BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControlPopup::OnLButtonUp
virtual void OnLButtonUp(CPoint point)
This member is called when the user releases the left mouse button.
CXTPControlPopup::OnClick
void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlPopup::RestoreCommandBarList
virtual void RestoreCommandBarList(CXTPCommandBarList *pCommandBarList)
This method is called from LoadCommandBars to restore controls and its child command bars.
CXTPControlPopup::m_bShowShadow
BOOL m_bShowShadow
TRUE to show shadow.
Definition XTPControlPopup.h:273
CXTPControlPopup::m_bPopup
BOOL m_bPopup
TRUE if pop-up'ed.
Definition XTPControlPopup.h:270
CXTPControlPopup::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, BOOL bVertical)
Updates rectangle to set the position where the child pop-up bar becomes visible.
CXTPControlPopup::OnSetPopup
virtual BOOL OnSetPopup(BOOL bPopup)
This method is called to pop-up the control.
CXTPControlPopup::OnMouseMove
virtual void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPControlPopup::SetCommandBar
void SetCommandBar(CMenu *pMenu)
Call this member to set the child command bar.
CXTPControlPopup::Compare
virtual BOOL Compare(CXTPControl *pOther)
Call this member to compare controls.
CXTPControlPopup::OnCustomizeDragOver
void OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect)
This method is called when the user moves the mouse over the control.
CXTPControlPopup::UpdateShadow
virtual void UpdateShadow()
Call this member to update the shadow of the control.
CXTPControlPopup::CXTPControlPopup
CXTPControlPopup()
Constructs a CXTPControlPopup object.
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPChartContentView.h Source File

  • Source
  • Chart
XTPChartContentView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTCONTENTVIEW_H__)
24# define __XTPCHARTCONTENTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartDiagram;
35class CXTPChartTitleCollection;
36class CXTPChartElementView;
37class CXTPChartSeriesCollection;
38class CXTPChartLegend;
39class CXTPChartPanelCollection;
40class CXTPChartSeries;
41class CXTPChartAppearance;
42class CXTPChartLegendView;
43class CXTPPropExchange;
44class CXTPMarkupContext;
45class CXTPChartContentView;
46class CXTPChartDiagramView;
47class CXTPChartBorder;
48class CXTPChartDeviceCommand;
49
55class _XTP_EXT_CLASS CXTPChartContentView : public CXTPChartElementView
56{
57public:
65 CXTPChartContentView(CXTPChartContainer* pContainer, CXTPChartContent* pContent);
66
74 void CreateView(CXTPChartDeviceContext* pDC);
75
84 void CalculateView(CXTPChartDeviceContext* pDC, CRect rcBounds);
85
94 CXTPChartLegendView* GetLegendView() const;
95
96public:
106 CXTPChartDiagramView* HitTestDiagramView(CPoint pt) const;
107
108public:
118 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
119
120protected:
121 CRect m_rcBounds;
122 CXTPChartContent* m_pContent;
124public:
125 CXTPChartLegendView* m_pLegendView;
126 CXTPChartElementView* m_pTitlesView;
127 CXTPChartElementView* m_pDiagramView;
128};
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
131#endif //#if !defined(__XTPCHARTCONTENTVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAppearance
This class represents the appearance of the chart.
Definition XTPChartAppearance.h:629
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartContentView
This class represents the view of the chart content, which is a kind of CXTPChartElementView.
Definition XTPChartContentView.h:56
CXTPChartContentView::m_pLegendView
CXTPChartLegendView * m_pLegendView
The legend view.
Definition XTPChartContentView.h:125
CXTPChartContentView::CXTPChartContentView
CXTPChartContentView(CXTPChartContainer *pContainer, CXTPChartContent *pContent)
Constructs a CXTPChartContentView object.
CXTPChartContentView::m_pTitlesView
CXTPChartElementView * m_pTitlesView
The titles view.
Definition XTPChartContentView.h:126
CXTPChartContentView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Call this function to create the device command for this object.
CXTPChartContentView::CalculateView
void CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the view/layout of the chart content with respect to a bounding recta...
CXTPChartContentView::CreateView
void CreateView(CXTPChartDeviceContext *pDC)
Call this function to create various child view objects which constitute the view of the chart conten...
CXTPChartContentView::m_rcBounds
CRect m_rcBounds
The bounds.
Definition XTPChartContentView.h:121
CXTPChartContentView::GetLegendView
CXTPChartLegendView * GetLegendView() const
Call this function to get the legend view object associated with this object.
CXTPChartContentView::HitTestDiagramView
CXTPChartDiagramView * HitTestDiagramView(CPoint pt) const
Call this function to determine the current DiagramView under point.
CXTPChartContentView::m_pDiagramView
CXTPChartElementView * m_pDiagramView
The diagram view.
Definition XTPChartContentView.h:127
CXTPChartContentView::m_pContent
CXTPChartContent * m_pContent
The chart content.
Definition XTPChartContentView.h:122
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLegend
This class represents a chart legend as a kind of chart element.
Definition XTPChartLegend.h:88
CXTPChartLegendView
This class abstracts the view of a legend and its child items in a bounding rectangle context.
Definition XTPChartLegendView.h:49
CXTPChartPanelCollection
This class abstracts a chart panel collection.
Definition XTPChartPanel.h:99
CXTPChartSeriesCollection
This class represents the collection of series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:339
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartTitleCollection
CXTPChartTitleCollection represents a collection of chart titles.
Definition XTPChartTitle.h:339
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPDockingPaneColorSet2012 Member List

This is the complete list of members for CXTPDockingPaneColorSet2012, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSet2012 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


Toolkit Pro: XTPMarkupImage.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupImage.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPIMAGE_H__)
24# define __XTPMARKUPIMAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDeviceDependentImage;
34class CXTPMarkupDependencyProperty;
35class CXTPMarkupObject;
36class CXTPMarkupDrawingContext;
37class CXTPMarkupContext;
38
44class _XTP_EXT_CLASS CXTPMarkupImage
45 : public CXTPMarkupFrameworkElement
46 , private IXTPMarkupDeviceDependentImageSite
47{
49 DECLARE_MARKUPCLASS(CXTPMarkupImage)
51protected:
56 CXTPMarkupImage();
57
62 virtual ~CXTPMarkupImage();
63
64public:
77 void SetSource(LPCTSTR lpszSource);
78
85 CString GetSource();
86
92 void SetStretch(XTPMarkupStretch stretch);
93
100 XTPMarkupStretch GetStretch() const;
101
108 CSize GetOriginalSize() const;
109
111 // Implementation
112public:
113 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize constraint);
114 virtual CSize ArrangeOverride(CSize arrangeSize);
115 virtual void OnPropertyChanged(CXTPMarkupDependencyProperty* pProperty,
116 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
117 virtual void OnRender(CXTPMarkupDrawingContext* pDC);
118
119protected:
120 void CreateImageInstance(CXTPMarkupDrawingContext* pDC);
121 CSize MeasureArrangeHelper(CSize inputSize);
122
123protected:
124 // IXTPMarkupDeviceDependentImageSite overrides
125
126 virtual CXTPMarkupContext* GetMarkupContext();
127 virtual void OnImageUpdateRequired();
128
129private:
130 CXTPMarkupDeviceDependentImage* m_pDeviceImage;
131 CSize m_ConstraintSize;
132
133public:
134 static CXTPMarkupDependencyProperty* m_pSourceProperty;
135 static CXTPMarkupDependencyProperty* m_pStretchProperty;
139public:
140 DECLARE_DISPATCH_MAP()
141# ifdef _XTP_ACTIVEX
142 DECLARE_INTERFACE_MAP()
143 DECLARE_OLETYPELIB_EX(CXTPMarkupImage);
144# endif
145
146 afx_msg void OleSetSource(LPCTSTR lpszSource);
147 afx_msg BSTR OleGetSource();
148 afx_msg long OleGetStretch();
149 afx_msg void OleSetStretch(long stretch);
151};
152
153# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
155#endif // !defined(__XTPMARKUPIMAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupDeviceDependentImage
Implements an abstract device dependent image.
Definition XTPMarkupDeviceDependentImage.h:73
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44
CXTPMarkupImage
CXTPMarkupImage is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupImage.h:47
CXTPMarkupImage::GetSource
CString GetSource()
Retrieves the source of the image to load.
CXTPMarkupImage::SetStretch
void SetStretch(XTPMarkupStretch stretch)
Sets the stretch type of the image.
CXTPMarkupImage::~CXTPMarkupImage
virtual ~CXTPMarkupImage()
Destroys a CXTPMarkupImage object, handles cleanup and deallocation.
CXTPMarkupImage::CXTPMarkupImage
CXTPMarkupImage()
Constructs a CXTPMarkupImage object.
CXTPMarkupImage::GetOriginalSize
CSize GetOriginalSize() const
Retrieves the original size of the image (not scaled).
CXTPMarkupImage::SetSource
void SetSource(LPCTSTR lpszSource)
Sets the source of the image to load.
CXTPMarkupImage::GetStretch
XTPMarkupStretch GetStretch() const
Gets the current stretch type of the image.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
IXTPMarkupDeviceDependentImageSite
Describes an image site interface.
Definition XTPMarkupDeviceDependentImage.h:40
IXTPMarkupDeviceDependentImageSite::GetMarkupContext
virtual CXTPMarkupContext * GetMarkupContext()=0
Implementation must return a valid pointer to a markup context in which an image is to be rendered.
IXTPMarkupDeviceDependentImageSite::OnImageUpdateRequired
virtual void OnImageUpdateRequired()=0
(Optional) Implementation can re-draw the context when this method is called; usually when a new anim...


CXTPTabColorSetOffice2007 Member List

This is the complete list of members for CXTPTabColorSetOffice2007, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2007 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetOffice2003 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrButtonText | CXTPTabColorSetOffice2007 | protected
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPTabColorSetOffice2007 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


CXTPScrollBarThemeVisualStudio2012 Member List

This is the complete list of members for CXTPScrollBarThemeVisualStudio2012, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeVisualStudio2012 | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarPaintManager | virtual


Toolkit Pro: XTPButtonThemeVisualStudio2019.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2019_H__)
24# define __XTPBUTTONTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeVisualStudio2019 : public CXTPButtonThemeOffice2013
39{
40public:
45 CXTPButtonThemeVisualStudio2019();
46
53 virtual void RefreshMetrics(CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013
CXTPButtonThemeOffice2013 is a class used to perform Office 2013 theme drawing tasks.
Definition XTPButtonThemeOffice2013.h:39
CXTPButtonThemeVisualStudio2019
CXTPButtonThemeVisualStudio2019 is a class used to perform Visual Studio 2019 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2019.h:39
CXTPButtonThemeVisualStudio2019::CXTPButtonThemeVisualStudio2019
CXTPButtonThemeVisualStudio2019()
Constructs a CXTPButtonThemeVisualStudio2019 object.
CXTPButtonThemeVisualStudio2019::RefreshMetrics
virtual void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...


Toolkit Pro: XTPShortcutBarOffice2003Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarOffice2003Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBAROFFICE2003THEME_H__)
24# define __XTPSHORTCUTBAROFFICE2003THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarOffice2003Theme : public CXTPShortcutBarPaintManager
39{
40public:
45 CXTPShortcutBarOffice2003Theme();
46
47public:
54 virtual void FillShortcutBar(CDC* pDC, CXTPShortcutBar* pShortcutBar);
55
64 void DrawShortcutBarFrame(CDC* pDC, CXTPShortcutBar* pShortcutBar);
65
72 void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
73
84 int DrawGripper(CDC* pDC, CXTPShortcutBar* pShortcutBar, BOOL bDraw);
85
111 int DrawPaneCaption(CDC* pDC, CXTPShortcutBarPane* pPane, BOOL bDraw);
112
134 int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
135
147 void RefreshMetrics();
148
168 void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage, BOOL bSelected,
169 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
170
177 void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
178
179public:
180 CXTPPaintManagerColorGradient m_grcCaption;
181 CXTPPaintManagerColorGradient m_grcItemCaption;
182 CXTPPaintManagerColorGradient m_grcItemHotCaption;
183 CXTPPaintManagerColor m_clrItemCaptionShadow;
184 CXTPPaintManagerColor m_clrItemCaptionTop;
185 CXTPPaintManagerColor m_clrCaptionText;
186 CXTPPaintManagerColor m_clrItemCaptionText;
188 BOOL m_bShowTopLeftCaptionShadow;
189 BOOL m_bLunaColorDisabled;
190};
191
192# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
194#endif // !defined(__XTPSHORTCUTBAROFFICE2003THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Offi...
Definition XTPShortcutBarOffice2003Theme.h:39
CXTPShortcutBarOffice2003Theme::DrawPaneItemCaption
int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarOffice2003Theme::m_clrItemCaptionShadow
CXTPPaintManagerColor m_clrItemCaptionShadow
Color of sub-caption shadow.
Definition XTPShortcutBarOffice2003Theme.h:183
CXTPShortcutBarOffice2003Theme::FillNavigationItemEntry
void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarOffice2003Theme::DrawPaneCaption
int DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.
CXTPShortcutBarOffice2003Theme::FillShortcutItemEntry
void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarOffice2003Theme::m_grcItemHotCaption
CXTPPaintManagerColorGradient m_grcItemHotCaption
Items color.
Definition XTPShortcutBarOffice2003Theme.h:182
CXTPShortcutBarOffice2003Theme::FillShortcutBar
virtual void FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
CXTPShortcutBarOffice2003Theme::m_grcCaption
CXTPPaintManagerColorGradient m_grcCaption
Caption color.
Definition XTPShortcutBarOffice2003Theme.h:180
CXTPShortcutBarOffice2003Theme::CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme()
Constructs a CXTPShortcutBarOffice2003Theme object.
CXTPShortcutBarOffice2003Theme::m_clrCaptionText
CXTPPaintManagerColor m_clrCaptionText
Color of items text.
Definition XTPShortcutBarOffice2003Theme.h:185
CXTPShortcutBarOffice2003Theme::m_clrItemCaptionTop
CXTPPaintManagerColor m_clrItemCaptionTop
Color under sub-caption rectangle.
Definition XTPShortcutBarOffice2003Theme.h:184
CXTPShortcutBarOffice2003Theme::m_grcItemCaption
CXTPPaintManagerColorGradient m_grcItemCaption
Items color.
Definition XTPShortcutBarOffice2003Theme.h:181
CXTPShortcutBarOffice2003Theme::DrawShortcutBarFrame
void DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Draws the frame for the shortcut bar control.
CXTPShortcutBarOffice2003Theme::m_clrItemCaptionText
CXTPPaintManagerColor m_clrItemCaptionText
Color of sub-caption text.
Definition XTPShortcutBarOffice2003Theme.h:186
CXTPShortcutBarOffice2003Theme::m_bShowTopLeftCaptionShadow
BOOL m_bShowTopLeftCaptionShadow
TRUE to draw rectangle around items.
Definition XTPShortcutBarOffice2003Theme.h:188
CXTPShortcutBarOffice2003Theme::DrawGripper
int DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
CXTPShortcutBarOffice2003Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarOffice2003Theme::DrawImage
void DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
Draws the image of a shortcut bar item.
CXTPShortcutBarPaintManager
CXTPShortcutBarPaintManager is a standalone class used as a paint manager for a shortcut bar control.
Definition XTPShortcutBarPaintManager.h:79
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42


Toolkit Pro: XTPStatusBarThemeVisualStudio2019.h Source File

  • Source
  • CommandBars
  • StatusBar
XTPStatusBarThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2019_H__)
24# define __XTPXTPSTATUSBARTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPStatusBarThemeVisualStudio2019
39 : public CXTPStatusBarThemeOffice2013
40 , private IXTPApplicationEvents
41{
42public:
48 CXTPStatusBarThemeVisualStudio2019(CXTPPaintManager* pPaintManager);
49
54 ~CXTPStatusBarThemeVisualStudio2019();
55
62 virtual void DrawStatusBarGripper(CDC* pDC, CRect rcClient);
63
69 virtual void RefreshMetrics();
70
78 virtual void SetStateColor(COLORREF clrState);
79
86 virtual COLORREF GetStateColor() const;
87
88private:
89 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
90 XTPApplicationAmbientProperty nProperty);
91 void UpdateStateColor();
92
93 BOOL m_bAutomaticStateColor;
94};
95
97# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPXTPSTATUSBARTHEMEVISUALSTUDIO2019_H__)
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPStatusBarThemeOffice2013
The CXTPStatusBarThemeVisualStudio2015 class is used to enable the Office 2013 style theme for the st...
Definition XTPStatusBarThemeOffice2013.h:39
CXTPStatusBarThemeVisualStudio2019
The CXTPStatusBarThemeVisualStudio2019 class is used to enable the Visual Studio 2019 style theme for...
Definition XTPStatusBarThemeVisualStudio2019.h:41
CXTPStatusBarThemeVisualStudio2019::DrawStatusBarGripper
virtual void DrawStatusBarGripper(CDC *pDC, CRect rcClient)
This method is called to draw the status bar's gripper.
CXTPStatusBarThemeVisualStudio2019::CXTPStatusBarThemeVisualStudio2019
CXTPStatusBarThemeVisualStudio2019(CXTPPaintManager *pPaintManager)
Constructs a CXTPStatusBarThemeVisualStudio2019 object.
CXTPStatusBarThemeVisualStudio2019::SetStateColor
virtual void SetStateColor(COLORREF clrState)
Call this member function to set the application state color for the status bar.
CXTPStatusBarThemeVisualStudio2019::~CXTPStatusBarThemeVisualStudio2019
~CXTPStatusBarThemeVisualStudio2019()
Handles object destruction.
CXTPStatusBarThemeVisualStudio2019::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh colors and other theme specific metrics for the paint manager.
CXTPStatusBarThemeVisualStudio2019::GetStateColor
virtual COLORREF GetStateColor() const
Call this member function to get the application state color for the status bar.
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


CXTPSyntaxEditLexVariable Member List

This is the complete list of members for CXTPSyntaxEditLexVariable, including all inherited members.

CXTPSyntaxEditLexVariable() | CXTPSyntaxEditLexVariable |
GetVariableData(int nVarID, CStringArray &rarVarData) | CXTPSyntaxEditLexVariable | static
GetVarID(LPCTSTR pcszVarName) | CXTPSyntaxEditLexVariable | static
InitStandartVarsIfNeed() | CXTPSyntaxEditLexVariable | protectedstatic
m_nVarFlags | CXTPSyntaxEditLexVariable |
m_nVarID | CXTPSyntaxEditLexVariable |
m_strVar | CXTPSyntaxEditLexVariable |
operator=(const CXTPSyntaxEditLexVariable &rSrc) | CXTPSyntaxEditLexVariable |
operator==(const CXTPSyntaxEditLexVariable &rSrc) const | CXTPSyntaxEditLexVariable |
s_bVarMapInitialized | CXTPSyntaxEditLexVariable | protectedstatic
s_mapVar2ID | CXTPSyntaxEditLexVariable | protectedstatic
SetVariable(LPCTSTR pcszVarName) | CXTPSyntaxEditLexVariable | virtual
xtpEditVarfNot enum value | CXTPSyntaxEditLexVariable |
xtpEditVarID_alpha enum value | CXTPSyntaxEditLexVariable |
xtpEditVarID_digit enum value | CXTPSyntaxEditLexVariable |
xtpEditVarID_EOL enum value | CXTPSyntaxEditLexVariable |
xtpEditVarID_HexDigit enum value | CXTPSyntaxEditLexVariable |
xtpEditVarID_specs enum value | CXTPSyntaxEditLexVariable |
xtpEditVarID_Unknown enum value | CXTPSyntaxEditLexVariable |
XTPSyntaxEditLexVarFlags enum name | CXTPSyntaxEditLexVariable |
XTPSyntaxEditLexVarID enum name | CXTPSyntaxEditLexVariable |
~CXTPSyntaxEditLexVariable() | CXTPSyntaxEditLexVariable | virtual


CXTPChartPointSeriesPointView Member List

This is the complete list of members for CXTPChartPointSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPointSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartPointSeriesPointView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPointSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetScreenPoint() const | CXTPChartPointSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPChart3dPyramidDeviceCommandEvents.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
  • Commands
XTPChart3dPyramidDeviceCommandEvents.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYRAMIDDEVICECOMMANDEVENTS_H__)
24# define __XTPCHART3DPYRAMIDDEVICECOMMANDEVENTS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34
39class _XTP_EXT_CLASS CXTPChart3dPyramidDeviceCommandEvents
40 : public CXTPChartDeviceCommandEvents
41 , public CXTPTypeIdProvider<CXTPChart3dPyramidDeviceCommandEvents, CXTPChartDeviceCommandEvents>
42{
43protected:
48 CXTPChart3dPyramidDeviceCommandEvents();
49
50public:
59 virtual void OnSetConnectorPoints(CXTPChartDeviceCommand* pCommand, CXTPPoint3d ptShapeCenter,
60 CXTPPoint3d ptOuterCenter);
61};
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif //#if !defined(__XTPCHART3DPYRAMIDDEVICECOMMANDEVENTS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPyramidDeviceCommandEvents
Defines interface for 3D chart pyramid device command event sink.
Definition XTPChart3dPyramidDeviceCommandEvents.h:42
CXTPChart3dPyramidDeviceCommandEvents::OnSetConnectorPoints
virtual void OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pyramid connector points are computed.
CXTPChart3dPyramidDeviceCommandEvents::CXTPChart3dPyramidDeviceCommandEvents
CXTPChart3dPyramidDeviceCommandEvents()
Constructs a CXTPChart3dPyramidDeviceCommandEvents object.
CXTPChartDeviceCommandEvents
Defines a callback interface for a chart device command event sink.
Definition XTPChartDeviceCommand.h:48
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPPoint3T< double >


CXTPSyntaxEditTipComboBox Member List

This is the complete list of members for CXTPSyntaxEditTipComboBox, including all inherited members.

GetListBox() CXTPSyntaxEditTipComboBox


CXTPFlowGraphControl Member List

This is the complete list of members for CXTPFlowGraphControl, including all inherited members.

AddCustomNodeFromToolkitResource(UINT uResShapeID, CXTPFlowGraphPage *pPage=NULL) | CXTPFlowGraphControl |
AdjustScrollBars() | CXTPFlowGraphControl | protectedvirtual
AnimatePageTransition(CXTPFlowGraphNode *pNodeFrom, CXTPFlowGraphNode *pNodeTo) | CXTPFlowGraphControl | virtual
AnimateTo(CPoint ptScrollOffset, double dZoomLevel) | CXTPFlowGraphControl | virtual
Arrange() | CXTPFlowGraphControl | virtual
CancelLabelEdit() | CXTPFlowGraphControl |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPFlowGraphControl |
CreateDrawContext(CDC &dc) | CXTPFlowGraphControl | protectedvirtual
CXTPFlowGraphControl() | CXTPFlowGraphControl |
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphControl | virtual
EnableMarkup(BOOL bEnable=TRUE) | CXTPFlowGraphControl |
EnableScrollBarCtrl(int nBar, BOOL bEnable=TRUE) | CXTPFlowGraphControl |
GetActivePage() const | CXTPFlowGraphControl |
GetAllowModifyConnections() const | CXTPFlowGraphControl |
GetAllowMoveNodes() const | CXTPFlowGraphControl |
GetAllowResizeNodes() const | CXTPFlowGraphControl |
GetAnimationDelay() const | CXTPFlowGraphControl |
GetCustomMarkupProperty(XTPFlowGraphCustomProperty property) const | CXTPFlowGraphControl |
GetDefaultMarkupTemplate(XTPFlowGraphDefaultXAMLTemplate tmpl) const | CXTPFlowGraphControl |
GetHistory() const | CXTPFlowGraphControl |
GetImages() const | CXTPFlowGraphControl |
GetMarkupContext() const | CXTPFlowGraphControl |
GetPages() const | CXTPFlowGraphControl |
GetPaintManager() const | CXTPFlowGraphControl |
GetScrollBarCtrl(int nBar) const | CXTPFlowGraphControl | virtual
GetScrollLimit(int nBar) | CXTPFlowGraphControl |
GetScrollOffset() const | CXTPFlowGraphControl |
GetSmoothingMode() const | CXTPFlowGraphControl |
GetToolTipContext() const | CXTPFlowGraphControl |
GetUndoManager() const | CXTPFlowGraphControl |
GetZoomLevel() const | CXTPFlowGraphControl |
GetZoomParam(LPCRECT lpRect, CPoint &ptScrollOffset, double &dZoomLevel) | CXTPFlowGraphControl | protectedvirtual
HitTestConnection(CPoint point) const | CXTPFlowGraphControl | virtual
HitTestConnectionArea(CPoint point) const | CXTPFlowGraphControl | virtual
HitTestNode(CPoint point) const | CXTPFlowGraphControl | virtual
LoadXamlTemplate(LPCTSTR szTemplate) | CXTPFlowGraphControl | static
m_bAdjustScrollBars | CXTPFlowGraphControl | protected
m_bAllowModifyConnections | CXTPFlowGraphControl | protected
m_bAllowMoveNodes | CXTPFlowGraphControl | protected
m_bCreateScrollbarOnParent | CXTPFlowGraphControl | protected
m_bInAction | CXTPFlowGraphControl | protected
m_bmpCache | CXTPFlowGraphControl | protected
m_bReposition | CXTPFlowGraphControl | protected
m_dMaxZoom | CXTPFlowGraphControl | protected
m_dMinZoom | CXTPFlowGraphControl | protected
m_nAnimationDelay | CXTPFlowGraphControl | protected
m_nSmoothingMode | CXTPFlowGraphControl | protected
m_pActivePage | CXTPFlowGraphControl | protected
m_pHistory | CXTPFlowGraphControl | protected
m_pImages | CXTPFlowGraphControl | protected
m_pMarkupContext | CXTPFlowGraphControl | protected
m_pPages | CXTPFlowGraphControl | protected
m_pPaintManager | CXTPFlowGraphControl | protected
m_ptMouse | CXTPFlowGraphControl | protected
m_pToolTipContext | CXTPFlowGraphControl | protected
m_ptStartDrag | CXTPFlowGraphControl | protected
m_pUndoManager | CXTPFlowGraphControl | protected
m_rcSelectedArea | CXTPFlowGraphControl | protected
OnDraw(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphControl | virtual
OnEndLabelEdit(CXTPFlowGraphElement *pItem, LPCTSTR str) | CXTPFlowGraphControl | virtual
OnGraphChanged() | CXTPFlowGraphControl | virtual
OnMoveSelection(CPoint pt) | CXTPFlowGraphControl | protectedvirtual
RedrawControl() | CXTPFlowGraphControl | virtual
RegisterCustomMarkupProperties() | CXTPFlowGraphControl |
RegisterWindowClass(HINSTANCE hInstance=NULL) | CXTPFlowGraphControl |
RenameConnectionPoint(CXTPFlowGraphConnectionPoint *pConnectionPoint) | CXTPFlowGraphControl | virtual
RenameNode(CXTPFlowGraphNode *pNode) | CXTPFlowGraphControl | virtual
Reposition() | CXTPFlowGraphControl | virtual
SaveToFile(LPCTSTR szFile) | CXTPFlowGraphControl |
SelectAll() | CXTPFlowGraphControl | virtual
SendNotifyMessage(UINT nMessage, NMHDR *pNMHDR=NULL) const | CXTPFlowGraphControl | virtual
SetActivePage(CXTPFlowGraphPage *pPage) | CXTPFlowGraphControl |
SetAllowModifyConnections(BOOL bAllowModifyConnections) | CXTPFlowGraphControl |
SetAllowMoveNodes(BOOL bAllow) | CXTPFlowGraphControl |
SetAllowResizeNodes(XTPFlowGraphResize nResizeMode) | CXTPFlowGraphControl |
SetAnimationDelay(int nDelay) | CXTPFlowGraphControl |
SetPaintManager(CXTPFlowGraphPaintManager *pPaintManager) | CXTPFlowGraphControl |
SetSmoothingMode(XTPFlowGraphSmoothingMode nSmoothingMode) | CXTPFlowGraphControl |
SetupDefaultMarkupTemplates() | CXTPFlowGraphControl |
SetZoomLevel(double dZoomLevel) | CXTPFlowGraphControl |
SetZoomRange(double dMinZoom, double dMaxZoom) | CXTPFlowGraphControl |
StartDragConnection(CXTPFlowGraphConnection *pConnection) | CXTPFlowGraphControl | protectedvirtual
StartDragConnectionPoint(CXTPFlowGraphConnectionPoint *pPoint) | CXTPFlowGraphControl | protectedvirtual
StartDragNodes() | CXTPFlowGraphControl | protectedvirtual
StartDragScreen() | CXTPFlowGraphControl | protectedvirtual
StartDragSelection() | CXTPFlowGraphControl | protectedvirtual
StartResizeNode(CXTPFlowGraphNode *pNode, UINT hitTest) | CXTPFlowGraphControl | protectedvirtual
TransformPoint(CPoint pt) const | CXTPFlowGraphControl |
ZoomFitToWindow() | CXTPFlowGraphControl | virtual
ZoomToRect(LPCRECT lpRect, BOOL bAnimate=TRUE) | CXTPFlowGraphControl | virtual
ZoomToSelection() | CXTPFlowGraphControl | virtual
~CXTPFlowGraphControl() | CXTPFlowGraphControl | virtual


Toolkit Pro: XTPPopupControl.h Source File

  • Source
  • Controls
  • Popup
XTPPopupControl.h
Go to the documentation of this file.
1
23#if !defined(_XTPPOPUPCONTROL_H__)
24# define _XTPPOPUPCONTROL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPopupItem;
34class CXTPPopupPaintManager;
35class CXTPImageManager;
36class CXTPImageManagerIcon;
37class CXTPMarkupContext;
38
49enum XTPPopupPaintTheme
50{
51 xtpPopupThemeOffice2000,
52 xtpPopupThemeOfficeXP,
53 xtpPopupThemeOffice2003,
54 xtpPopupThemeMSN,
55 xtpPopupThemeResource,
56 xtpPopupThemeCustom,
57 xtpPopupThemeOffice2013,
58 xtpPopupThemeOffice2016 = xtpPopupThemeOffice2013
59};
60
62# define xtpPopupThemeOffice2007 xtpPopupThemeResource
69enum XTPPopupLocation
70{
71 xtpPopupLocationNearTaskBar,
73 xtpPopupLocationBottomRight,
74 xtpPopupLocationCenter
75};
86enum XTPPopupAnimation
87{
88 xtpPopupAnimationNone,
89 xtpPopupAnimationFade,
90 xtpPopupAnimationSlide,
91 xtpPopupAnimationUnfold
92};
93
110enum XTPPopupState
111{
112 xtpPopupStateClosed,
113 xtpPopupStateExpanding,
114 xtpPopupStateShow,
115 xtpPopupStateCollapsing
116};
117
176const UINT XTPWM_POPUPCONTROL_NOTIFY = (WM_XTP_CONTROLS_BASE + 37);
177
190const UINT XTP_PCN_ITEMCLICK = 1;
191
209const UINT XTP_PCN_STATECHANGED = 2;
210
218const UINT XTP_PCN_POSCHANGED = 3;
219
224class _XTP_EXT_CLASS CXTPPopupControl : public CWnd
225{
226protected:
233 struct POPUPSTATE
234 {
235 CRect rcPopup;
236 int nTransparency;
237 };
238
239public:
246 CXTPPopupControl(BOOL bAutoDelete = FALSE);
247
253 virtual ~CXTPPopupControl();
254
255public:
261 void SetPopupPos(CPoint ptPopup);
262
269 CPoint GetPopupPos() const;
270
276 void SetPopupSize(CSize szPopup);
277
284 CSize GetPopupSize() const;
285
295 BOOL Show(CWnd* pParent, int nID = 0);
296
306 BOOL ShowModal(CWnd* pParent, int nID = 0);
307
312 void Hide();
313
320 BOOL Close();
321
330 void SetTransparency(BYTE bTransp);
331
339 BYTE GetTransparency() const;
340
347 void SetShowDelay(DWORD dwShowDelay);
348
356 DWORD GetShowDelay() const;
357
364 void SetAnimateDelay(DWORD dwAnimateDelay);
365
373 DWORD GetAnimateDelay() const;
374
380 void SetPopupAnimation(XTPPopupAnimation popupAnimation);
381
386 void SetPopupAnimation();
387
394 XTPPopupAnimation GetPopupAnimation() const;
395
403 XTPPopupState GetPopupState() const;
404
411 void SetTheme(XTPPopupPaintTheme theme);
412
419 void SetTheme(CXTPPopupPaintManager* pPaintManager);
420
428 CXTPPopupPaintManager* GetPaintManager() const;
429
439 XTPPopupPaintTheme GetTheme() const;
440
446 void RedrawControl();
447
457 CXTPPopupItem* AddItem(CXTPPopupItem* pItem);
458
464 void RemoveAllItems();
465
472 void RemoveItem(CXTPPopupItem* pItem);
473
480 void RemoveItem(int nIndex);
481
489 int GetItemCount() const;
490
499 CXTPPopupItem* GetItem(int nIndex) const;
500
510 CXTPPopupItem* HitTest(CPoint pt) const;
511
520 void AllowMove(BOOL bAllowMove);
521
527 void SetBackgroundBitmap(int nBackgroundBitmap);
528
537 int GetBackgroundBitmap() const;
538
546 void SetAutoDelete(BOOL bAutoDelete);
547
555 void SetDefaultLocation(XTPPopupLocation nPopupLocation);
556
563 BOOL GetSplashScreenMode() const;
564
570 void SetSplashScreenMode(BOOL bSet);
571
578 int GetID() const;
579
587 BOOL IsLayoutRTL() const;
588
595 void SetLayoutRTL(BOOL bRightToLeft);
596
610 void SetImageManager(CXTPImageManager* pImageManager);
611
624 CXTPImageManager* GetImageManager() const;
625
631 void EnableMarkup(BOOL bEnableMarkup);
632
639 CXTPMarkupContext* GetMarkupContext() const;
640
651 BOOL IsDpiBitmapScalingEnabled() const;
652
662 void EnableDpiBitmapScaling(BOOL bEnable = TRUE);
663
664protected:
672 virtual BOOL Create(CWnd* pParentWnd);
673
679 virtual void OnClick(CXTPPopupItem* pItem);
680
686 virtual void OnExpanding(BOOL bUpdateCurrent);
687
692 virtual void OnCollapsing();
693
698 virtual void OnShow();
699
707 virtual void Notify(WPARAM wParam, LPARAM lParam);
708
714 void Animate(int nStep);
715
722 void UpdateState(BOOL bInit = FALSE);
723
730 void SetPopupState(XTPPopupState popupState);
731
739 BOOL SetLayeredWindowAttributes(int bAlpha);
740
745 void TrackMove();
746
747protected:
749 DECLARE_MESSAGE_MAP()
750 virtual void PostNcDestroy();
751 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
752
753 //{{AFX_MSG(CXTPPopupControl)
754 afx_msg void OnTimer(UINT_PTR nIDEvent);
755 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
756 afx_msg void OnPaint();
757 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
758 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
759 afx_msg void OnCaptureChanged(CWnd* pWnd);
760 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
761 afx_msg void OnMouseLeave();
762 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
763 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
764 //}}AFX_MSG
767private:
768 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
769 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
770 void UpdateBitmapRegion();
771 HRGN BitmapToRegion(CXTPImageManagerIcon* pIcon);
772 void SetRegionAlphaLayer(CXTPImageManagerIcon* pIcon);
773
774protected:
775 CXTPPopupPaintManager* m_pPaintManager;
776 CArray<CXTPPopupItem*, CXTPPopupItem*> m_arrItems;
777 CXTPPopupItem* m_pSelected;
778 CXTPPopupItem* m_pPressed;
779 XTPPopupAnimation m_popupAnimation;
780 XTPPopupState m_popupState;
781 CSize m_szPopup;
782 CPoint m_ptPopup;
783 int m_nID;
784 int m_nTransparency;
785 int m_nCurrentTransparency;
786 UINT m_uShowDelay;
787 UINT m_uAnimationDelay;
788 UINT m_nAnimationInterval;
789 int m_nStep;
790 XTPPopupPaintTheme m_paintTheme;
791 BOOL m_bAllowMove;
795 POPUPSTATE m_stateTarget;
796 POPUPSTATE m_stateCurrent;
797 CXTPImageManager* m_pImageManager;
798 BOOL m_bRightToLeft;
800 CXTPMarkupContext* m_pMarkupContext;
802 int m_nBackgroundBitmap;
803 BOOL m_bAutoDelete;
804 XTPPopupLocation m_nPopupLocation;
805 HCURSOR m_hHandCursor;
807 BOOL m_bSplashScreenMode;
809private:
810 typedef BOOL(WINAPI* PFNSETLAYEREDWINDOWATTRIBUTES)(HWND hwnd, COLORREF crKey, BYTE bAlpha,
811 DWORD dwFlags);
812 typedef BOOL(WINAPI* LPFNUPDATELAYEREDWINDOW)(HWND hwnd, HDC hdcDst, POINT* pptDst, SIZE* psize,
813 HDC hdcSrc, POINT* pptSrc, COLORREF crKey,
814 BLENDFUNCTION* pblend, DWORD dwFlags);
815
816 PFNSETLAYEREDWINDOWATTRIBUTES m_pfnSetLayeredWindowAttributes; // Point to Transparency proc in
817 // USER32.dll module.
818 LPFNUPDATELAYEREDWINDOW m_pfnUpdateLayeredWindow;
819 BOOL m_bCapture; // Capture flag of mouse event.
820 BOOL m_bLayered;
821 BOOL m_bDpiBitmapScaling;
822 BOOL m_bDpiBitmapScalingModified;
823
824 friend class CXTPPopupItem;
825 friend class CPopupControlCtrl;
826};
827
829
830AFX_INLINE BOOL CXTPPopupControl::GetSplashScreenMode() const
831{
832 return m_bSplashScreenMode;
833}
834AFX_INLINE void CXTPPopupControl::SetSplashScreenMode(BOOL bSet)
835{
836 m_bSplashScreenMode = bSet;
837}
838AFX_INLINE CXTPPopupPaintManager* CXTPPopupControl::GetPaintManager() const
839{
840 return m_pPaintManager;
841}
842AFX_INLINE void CXTPPopupControl::SetPopupSize(CSize szPopup)
843{
844 m_szPopup = szPopup;
845}
846AFX_INLINE CSize CXTPPopupControl::GetPopupSize() const
847{
848 return m_szPopup;
849}
850AFX_INLINE void CXTPPopupControl::SetPopupPos(CPoint ptPopup)
851{
852 m_ptPopup = ptPopup;
853}
854AFX_INLINE void CXTPPopupControl::SetShowDelay(DWORD dwShowDelay)
855{
856 m_uShowDelay = dwShowDelay;
857}
858AFX_INLINE DWORD CXTPPopupControl::GetShowDelay() const
859{
860 return m_uShowDelay;
861}
862AFX_INLINE void CXTPPopupControl::SetAnimateDelay(DWORD dwAnimateDelay)
863{
864 m_uAnimationDelay = dwAnimateDelay;
865}
866AFX_INLINE DWORD CXTPPopupControl::GetAnimateDelay() const
867{
868 return m_uAnimationDelay;
869}
870AFX_INLINE BYTE CXTPPopupControl::GetTransparency() const
871{
872 return (BYTE)m_nTransparency;
873}
874AFX_INLINE void CXTPPopupControl::SetTransparency(BYTE nTransparency)
875{
876 m_nTransparency = nTransparency;
877}
878AFX_INLINE void CXTPPopupControl::SetAutoDelete(BOOL bAutoDelete)
879{
880 m_bAutoDelete = bAutoDelete;
881}
882AFX_INLINE XTPPopupAnimation CXTPPopupControl::GetPopupAnimation() const
883{
884 return m_popupAnimation;
885}
886AFX_INLINE void CXTPPopupControl::SetPopupAnimation(XTPPopupAnimation popupAnimation)
887{
888 m_popupAnimation = popupAnimation;
889}
890AFX_INLINE XTPPopupPaintTheme CXTPPopupControl::GetTheme() const
891{
892 return m_paintTheme;
893}
894AFX_INLINE void CXTPPopupControl::AllowMove(BOOL bAllowMove)
895{
896 m_bAllowMove = bAllowMove;
897}
898AFX_INLINE BOOL CXTPPopupControl::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
899 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
900 UINT nID, CCreateContext* pContext)
901{
902 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
903}
904AFX_INLINE BOOL CXTPPopupControl::IsLayoutRTL() const
905{
906 return m_bRightToLeft;
907}
908AFX_INLINE void CXTPPopupControl::SetBackgroundBitmap(int nBackgroundBitmap)
909{
910 m_nBackgroundBitmap = nBackgroundBitmap;
911 UpdateBitmapRegion();
912}
913AFX_INLINE int CXTPPopupControl::GetBackgroundBitmap() const
914{
915 return m_nBackgroundBitmap;
916}
917AFX_INLINE CXTPMarkupContext* CXTPPopupControl::GetMarkupContext() const
918{
919 return m_pMarkupContext;
920}
921AFX_INLINE void CXTPPopupControl::SetDefaultLocation(XTPPopupLocation nPopupLocation)
922{
923 m_nPopupLocation = nPopupLocation;
924}
925AFX_INLINE int CXTPPopupControl::GetID() const
926{
927 return m_nID;
928}
930# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
932#endif // !defined(_XTPPOPUPCONTROL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPWM_POPUPCONTROL_NOTIFY
const UINT XTPWM_POPUPCONTROL_NOTIFY
The XTPWM_POPUPCONTROL_NOTIFY message is sent to the CXTPPopupControl owner window whenever an action...
Definition XTPPopupControl.h:176
XTPPopupLocation
XTPPopupLocation
Enumeration used to determine the location where the pop-up control is displayed.
Definition XTPPopupControl.h:70
xtpPopupLocationBottomRight
@ xtpPopupLocationBottomRight
Displays in the bottom right of the screen.
Definition XTPPopupControl.h:73
xtpPopupLocationCenter
@ xtpPopupLocationCenter
Displays in the center of the screen.
Definition XTPPopupControl.h:74
xtpPopupLocationNearTaskBar
@ xtpPopupLocationNearTaskBar
Displays in the bottom right of the screen right above the taskbar.
Definition XTPPopupControl.h:71
XTPPopupPaintTheme
XTPPopupPaintTheme
Enumeration used to determine the pop-up window theme in use.
Definition XTPPopupControl.h:50
xtpPopupThemeOffice2016
@ xtpPopupThemeOffice2016
Office 2016 pop-up theme.
Definition XTPPopupControl.h:58
xtpPopupThemeCustom
@ xtpPopupThemeCustom
Custom pop-up theme.
Definition XTPPopupControl.h:56
xtpPopupThemeOffice2000
@ xtpPopupThemeOffice2000
Office 2000 pop-up theme.
Definition XTPPopupControl.h:51
xtpPopupThemeMSN
@ xtpPopupThemeMSN
MSN Messenger pop-up theme.
Definition XTPPopupControl.h:54
xtpPopupThemeOffice2013
@ xtpPopupThemeOffice2013
Office 2013 pop-up theme.
Definition XTPPopupControl.h:57
xtpPopupThemeOfficeXP
@ xtpPopupThemeOfficeXP
Office XP pop-up theme.
Definition XTPPopupControl.h:52
xtpPopupThemeOffice2003
@ xtpPopupThemeOffice2003
Office 2003 pop-up theme.
Definition XTPPopupControl.h:53
xtpPopupThemeResource
@ xtpPopupThemeResource
A resource based theme.
Definition XTPPopupControl.h:55
XTP_PCN_STATECHANGED
const UINT XTP_PCN_STATECHANGED
XTP_PCN_STATECHANGED is used to indicate that the state of the pop-up control has changed.
Definition XTPPopupControl.h:209
XTPPopupAnimation
XTPPopupAnimation
Enumeration used to determine the pop-up window animation in use.
Definition XTPPopupControl.h:87
xtpPopupAnimationUnfold
@ xtpPopupAnimationUnfold
Unfold method animation.
Definition XTPPopupControl.h:91
xtpPopupAnimationNone
@ xtpPopupAnimationNone
Animation is not used.
Definition XTPPopupControl.h:88
xtpPopupAnimationSlide
@ xtpPopupAnimationSlide
Slide method animation.
Definition XTPPopupControl.h:90
xtpPopupAnimationFade
@ xtpPopupAnimationFade
Fade method animation.
Definition XTPPopupControl.h:89
XTPPopupState
XTPPopupState
Enumeration used to determine the current pop-up window state.
Definition XTPPopupControl.h:111
xtpPopupStateCollapsing
@ xtpPopupStateCollapsing
The pop-up window is collapsing.
Definition XTPPopupControl.h:115
xtpPopupStateClosed
@ xtpPopupStateClosed
The pop-up window is closed.
Definition XTPPopupControl.h:112
xtpPopupStateExpanding
@ xtpPopupStateExpanding
The pop-up window is expanding.
Definition XTPPopupControl.h:113
xtpPopupStateShow
@ xtpPopupStateShow
The pop-up window is shown.
Definition XTPPopupControl.h:114
XTP_PCN_ITEMCLICK
const UINT XTP_PCN_ITEMCLICK
XTP_PCN_ITEMCLICK is used to indicate that the user clicked on a pop-up control item.
Definition XTPPopupControl.h:190
XTP_PCN_POSCHANGED
const UINT XTP_PCN_POSCHANGED
XTP_PCN_POSCHANGED is used to indicate that the user moved the pop-up control with the mouse.
Definition XTPPopupControl.h:218
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window.
Definition XTPPopupControl.h:225
CXTPPopupControl::RemoveItem
void RemoveItem(int nIndex)
Call this member function to remove a controlled item from a pop-up window.
CXTPPopupControl::Notify
virtual void Notify(WPARAM wParam, LPARAM lParam)
This method is called to notify the parent about an action that occurred.
CXTPPopupControl::GetItemCount
int GetItemCount() const
Call this member function to get the count of controlled items in a pop-up window.
CXTPPopupControl::OnShow
virtual void OnShow()
This method is called to show the control.
CXTPPopupControl::Hide
void Hide()
Call this member function to collapse a pop-up window.
CXTPPopupControl::AddItem
CXTPPopupItem * AddItem(CXTPPopupItem *pItem)
Call this member function to install a new controlled item in a pop-up window.
CXTPPopupControl::GetPopupPos
CPoint GetPopupPos() const
Call this member function to get the position of a pop-up window.
CXTPPopupControl::GetItem
CXTPPopupItem * GetItem(int nIndex) const
Call this member function to get the controlled item at a specified index.
CXTPPopupControl::EnableMarkup
void EnableMarkup(BOOL bEnableMarkup)
Call this method to enable markup for the pop-up control.
CXTPPopupControl::SetPopupAnimation
void SetPopupAnimation()
Call this member function to set the default pop-up animation method.
CXTPPopupControl::TrackMove
void TrackMove()
Loop of control moving.
CXTPPopupControl::SetBackgroundBitmap
void SetBackgroundBitmap(int nBackgroundBitmap)
Call this member to set the bitmap index for the background.
CXTPPopupControl::SetAnimateDelay
void SetAnimateDelay(DWORD dwAnimateDelay)
Call this member function to set the animate delay value for a pop-up window.
CXTPPopupControl::SetPopupAnimation
void SetPopupAnimation(XTPPopupAnimation popupAnimation)
Call this member function to set the pop-up animation method.
CXTPPopupControl::IsLayoutRTL
BOOL IsLayoutRTL() const
Determines if right-to-left (RTL) mode is set.
CXTPPopupControl::ShowModal
BOOL ShowModal(CWnd *pParent, int nID=0)
Call this method to show a modal pop-up control.
CXTPPopupControl::GetPopupAnimation
XTPPopupAnimation GetPopupAnimation() const
Call this member function to get the pop-up animation method.
CXTPPopupControl::RedrawControl
void RedrawControl()
Call this member function to redraw all controlled items of a pop-up window.
CXTPPopupControl::GetPopupState
XTPPopupState GetPopupState() const
Call this member function to get the current state of a pop-up window.
CXTPPopupControl::RemoveItem
void RemoveItem(CXTPPopupItem *pItem)
Call this member function to remove a controlled item from a pop-up window.
CXTPPopupControl::SetPopupPos
void SetPopupPos(CPoint ptPopup)
Call this member function to set the position of a pop-up window.
CXTPPopupControl::AllowMove
void AllowMove(BOOL bAllowMove)
Call this member to specify whether the user can click and drag the pop-up window when it is displaye...
CXTPPopupControl::RemoveAllItems
void RemoveAllItems()
Call this member function to remove all controlled items from a pop-up window.
CXTPPopupControl::SetTheme
void SetTheme(XTPPopupPaintTheme theme)
Call this member function to set the paint theme or paint manager used for drawing a pop-up window.
CXTPPopupControl::IsDpiBitmapScalingEnabled
BOOL IsDpiBitmapScalingEnabled() const
Gets DPI bitmap scaling flag.
CXTPPopupControl::GetAnimateDelay
DWORD GetAnimateDelay() const
Call this member function to get the animate delay value for a pop-up window.
CXTPPopupControl::Show
BOOL Show(CWnd *pParent, int nID=0)
Call this member function to create and expand a pop-up window.
CXTPPopupControl::OnClick
virtual void OnClick(CXTPPopupItem *pItem)
This method is called when the user clicks on a controlled item.
CXTPPopupControl::CXTPPopupControl
CXTPPopupControl(BOOL bAutoDelete=FALSE)
Constructs a CXTPPopupControl object.
CXTPPopupControl::Animate
void Animate(int nStep)
This method animates the pop-up control.
CXTPPopupControl::SetTheme
void SetTheme(CXTPPopupPaintManager *pPaintManager)
Call this member function to set the paint theme or paint manager used for drawing a pop-up window.
CXTPPopupControl::EnableDpiBitmapScaling
void EnableDpiBitmapScaling(BOOL bEnable=TRUE)
Sets DPI bitmap scaling flag.
CXTPPopupControl::UpdateState
void UpdateState(BOOL bInit=FALSE)
Updates the position in the animation according to the current animation step.
CXTPPopupControl::GetPopupSize
CSize GetPopupSize() const
Call this member function to get the size of a pop-up window.
CXTPPopupControl::~CXTPPopupControl
virtual ~CXTPPopupControl()
Destroys a CXTPPopupControl object, handles cleanup and deallocation.
CXTPPopupControl::GetID
int GetID() const
Retrieves the ID assigned to the pop-up window when it was created.
CXTPPopupControl::GetSplashScreenMode
BOOL GetSplashScreenMode() const
Call this member to see if splash screen mode has been enabled.
CXTPPopupControl::SetPopupState
void SetPopupState(XTPPopupState popupState)
This method is called when the current state of the control changes.
CXTPPopupControl::SetDefaultLocation
void SetDefaultLocation(XTPPopupLocation nPopupLocation)
Call this member to set the default pop-up location.
CXTPPopupControl::HitTest
CXTPPopupItem * HitTest(CPoint pt) const
Call this member function to test a point for controlled items of a pop-up window.
CXTPPopupControl::GetTransparency
BYTE GetTransparency() const
Call this member function to get the transparency value of a pop-up window.
CXTPPopupControl::GetImageManager
CXTPImageManager * GetImageManager() const
Call this method to get a pointer to the image manager of the pop-up control.
CXTPPopupControl::GetTheme
XTPPopupPaintTheme GetTheme() const
Call this member function to get the paint theme that the pop-up window is currently using.
CXTPPopupControl::OnCollapsing
virtual void OnCollapsing()
This method is called to start the collapsing animation.
CXTPPopupControl::SetPopupSize
void SetPopupSize(CSize szPopup)
Call this member function to set the size of a pop-up window.
CXTPPopupControl::SetTransparency
void SetTransparency(BYTE bTransp)
Call this member function to set the transparency value of a pop-up window.
CXTPPopupControl::SetLayoutRTL
void SetLayoutRTL(BOOL bRightToLeft)
Specifies if right-to-left (RTL) mode should be set.
CXTPPopupControl::GetShowDelay
DWORD GetShowDelay() const
Call this member function to get the show delay value for a pop-up window.
CXTPPopupControl::SetShowDelay
void SetShowDelay(DWORD dwShowDelay)
Call this member function to set the show delay value for a pop-up window.
CXTPPopupControl::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves the markup context associated with the pop-up control.
CXTPPopupControl::GetBackgroundBitmap
int GetBackgroundBitmap() const
Call this member to get the bitmap index for the background.
CXTPPopupControl::Close
BOOL Close()
Call this member to destroy a pop-up window.
CXTPPopupControl::OnExpanding
virtual void OnExpanding(BOOL bUpdateCurrent)
This method is called to start the expanding animation.
CXTPPopupControl::SetLayeredWindowAttributes
BOOL SetLayeredWindowAttributes(int bAlpha)
Updates the current control's transparency.
CXTPPopupControl::SetAutoDelete
void SetAutoDelete(BOOL bAutoDelete)
Call this member to allow the pop-up control to delete itself automatically upon final release.
CXTPPopupControl::Create
virtual BOOL Create(CWnd *pParentWnd)
Creates a pop-up window.
CXTPPopupControl::SetSplashScreenMode
void SetSplashScreenMode(BOOL bSet)
Call this member to set splash screen mode.
CXTPPopupControl::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Call this method to set a new image manager.
CXTPPopupControl::GetPaintManager
CXTPPopupPaintManager * GetPaintManager() const
Call this member function to get the paint manager object used for drawing a pop-up window.
CXTPPopupItem
CXTPPopupItem is a class used to manage a pop-up item object.
Definition XTPPopupItem.h:70
CXTPPopupPaintManager
CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
Definition XTPPopupPaintManager.h:44
CXTPPopupControl::POPUPSTATE
Pop-up state descriptor.
Definition XTPPopupControl.h:234
CXTPPopupControl::POPUPSTATE::nTransparency
int nTransparency
Pop-up transparency.
Definition XTPPopupControl.h:236
CXTPPopupControl::POPUPSTATE::rcPopup
CRect rcPopup
Pop-up position.
Definition XTPPopupControl.h:235


Toolkit Pro: XTPMarkupBuilder.h Source File

  • Source
  • Markup
XTPMarkupBuilder.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPBUILDER_H__)
24# define __XTPMARKUPBUILDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// Internal Class
35
36class CXTPMarkupUIElement;
37class CXTPMarkupObject;
38class CXTPMarkupDependencyProperty;
39class CXTPMarkupContext;
40class CXTPMarkupParser;
41class CXTPMarkupClassList;
42class CXTPMarkupType;
43class CXTPComInitializer;
44
45namespace XTPXML
46{
47struct IXMLDOMNode;
48struct IXMLDOMElement;
49}; // namespace XTPXML
50
51class _XTP_EXT_CLASS CXTPMarkupBuilderException : public CSimpleException
52{
54 DECLARE_DYNAMIC(CXTPMarkupBuilderException)
56public:
57 CXTPMarkupBuilderException(LPCTSTR lpszError);
58
59public:
60 BOOL GetErrorMessage(LPTSTR lpszError, UINT nMaxError, PUINT pnHelpContext = NULL);
61 BOOL GetErrorMessage(LPTSTR lpszError, UINT nMaxError, PUINT pnHelpContext = NULL) const;
62
63protected:
64 TCHAR m_szMessage[256];
65};
66
67class _XTP_EXT_CLASS CXTPMarkupObjectProperty : public CXTPMarkupObject
68{
69 DECLARE_MARKUPCLASS(CXTPMarkupObjectProperty)
70public:
71 CXTPMarkupObjectProperty(CXTPMarkupDependencyProperty* pProperty = 0);
72 ~CXTPMarkupObjectProperty();
73
74 virtual void SetContentObject(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pContent);
75 CXTPMarkupObject* FindResource(const CXTPMarkupObject* pKey) const;
76
77 CXTPMarkupObject* GetContent();
78 CXTPMarkupObject* GetCollection();
79 CXTPMarkupDependencyProperty* GetProperty();
80
81private:
82 CXTPMarkupObject* m_pContent;
83 CXTPMarkupObject* m_pCollection;
84 CXTPMarkupDependencyProperty* m_pProperty;
85};
86
87class _XTP_EXT_CLASS CXTPMarkupBuilder
88{
89 class CStaticExtension;
90 class CStringBuilder;
91 class CStaticResourceExtension;
92
93public:
94 CXTPMarkupBuilder(CXTPMarkupContext* pContext);
95 virtual ~CXTPMarkupBuilder();
96
97public:
98 CXTPMarkupObject* CreateObject(LPCWSTR lpszTag, XTPXML::IXMLDOMElement* pElement,
99 CXTPMarkupObject* pParent = NULL);
100 CXTPMarkupDependencyProperty* FindProperty(LPCWSTR lpszTag, LPCWSTR lpszAttribute);
101 CXTPMarkupDependencyProperty* FindProperty(CXTPMarkupType* pRuntimeClass,
102 LPCWSTR lpszAttribute);
103
104 CString GetLastError() const;
105
106public:
107 CXTPMarkupObject* ParseObject(CXTPMarkupParser* pParser);
108 CXTPMarkupUIElement* Parse(CXTPMarkupParser* pParser);
109
110 void ThrowBuilderException(LPCTSTR lpszError);
111 void ThrowBuilderException(HRESULT hr);
112
113 CXTPMarkupContext* GetMarkupContext() const;
114
115public:
116 static BOOL AFX_CDECL ColorStringToKnownColor(LPCWSTR lpszValue, COLORREF& clr);
117 static CXTPMarkupObject* AFX_CDECL
118 ConvertBool(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
119 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
120 static CXTPMarkupObject* AFX_CDECL
121 ConvertTextDecorations(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
122 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
123 static CXTPMarkupObject* AFX_CDECL
124 ConvertFontWeight(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
125 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
126 static CXTPMarkupObject* AFX_CDECL
127 ConvertFontStyle(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
128 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
129 static CXTPMarkupObject* AFX_CDECL
130 ConvertLength(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
131 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
132 static CXTPMarkupObject* AFX_CDECL
133 ConvertVerticalAlignment(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
134 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
135 static CXTPMarkupObject* AFX_CDECL
136 ConvertHorizontalAlignment(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
137 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
138 static CXTPMarkupObject* AFX_CDECL
139 ConvertTextWrapping(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
140 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
141 static CXTPMarkupObject* AFX_CDECL
142 ConvertTextTrimming(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
143 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
144 static CXTPMarkupObject* AFX_CDECL
145 ConvertTextAlignment(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
146 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
147 static CXTPMarkupObject* AFX_CDECL
148 ConvertOrientation(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
149 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
150 static CXTPMarkupObject* AFX_CDECL
151 ConvertBaselineAlignment(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
152 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
153 static CXTPMarkupObject* AFX_CDECL
154 ConvertCursor(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
155 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
156 static CXTPMarkupObject* AFX_CDECL
157 ConvertVisibility(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
158 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
159 static CXTPMarkupObject* AFX_CDECL
160 ConvertFontQuality(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
161 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
162 static CXTPMarkupObject* AFX_CDECL
163 ConvertContent(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
164 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
165 static CXTPMarkupObject* AFX_CDECL
166 ConvertScrollBarVisibility(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
167 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
168 static CXTPMarkupObject* AFX_CDECL
169 ConvertStretch(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
170 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
171 static CXTPMarkupObject* AFX_CDECL
172 ConvertMappingMode(CXTPMarkupBuilder* pBuilder, CXTPMarkupObject* pObject,
173 CXTPMarkupDependencyProperty* pAssociatedProperty = NULL);
174
175public:
176 static CString AFX_CDECL FormatString(LPCTSTR lpszFormat, LPCTSTR lpszParameter);
177 static CString AFX_CDECL FormatString(LPCTSTR lpszFormat, LPCTSTR lpszParameter1,
178 LPCTSTR lpszParameter2);
179 static CString AFX_CDECL FormatString(LPCTSTR lpszFormat, LPCTSTR lpszParameter1,
180 LPCTSTR lpszParameter2, LPCTSTR lpszParameter3);
181
182 CXTPMarkupObject* ConvertValue(CXTPMarkupDependencyProperty* pProperty,
183 CXTPMarkupObject* pValue);
184
185 static BOOL AFX_CDECL ConvertDouble(LPCWSTR& lpszValue, double& dValue, TCHAR cStop = 0,
186 BOOL bCheckTail = TRUE);
187
188private:
189 BOOL NeedPreserveXmlNodeWhitespaces(XTPXML::IXMLDOMNode* pNode) const;
190 void LoadMarkupObjectTextContent(CXTPMarkupObject* pObject, XTPXML::IXMLDOMNode* pContent,
191 BOOL bPreformatted);
192 void LoadMarkupObjectChild(CXTPMarkupObject* pObject, XTPXML::IXMLDOMNode* pChild);
193 void LoadMarkupObjectAttributes(CXTPMarkupObject* pObject, XTPXML::IXMLDOMElement* pElement);
194 CXTPMarkupObject* LoadXmlElement(CXTPMarkupObject* pParent, XTPXML::IXMLDOMElement* pElement);
195
196 CXTPMarkupObject* ResolveMarkupExtension(LPCWSTR lpszValue);
197 CStaticExtension* GetStaticExtension();
198 CStaticResourceExtension* GetStaticResourceExtension();
199 CXTPMarkupObject* CreateTypeKey(LPCWSTR lpszType);
200
201protected:
202 CXTPComInitializer* m_pComInitializer;
203 CString m_strLastError;
204 CXTPMarkupContext* m_pMarkupContext;
205 CStaticExtension* m_pStaticExtension;
206 CStaticResourceExtension* m_pStaticResourceExtension;
207 CList<CXTPMarkupObject*, CXTPMarkupObject*> m_arrObjects;
208
209 friend class CStaticResourceExtension;
210};
211
212AFX_INLINE CXTPMarkupObject* CXTPMarkupObjectProperty::GetContent()
213{
214 return m_pContent;
215}
216
217AFX_INLINE CXTPMarkupObject* CXTPMarkupObjectProperty::GetCollection()
218{
219 return m_pCollection;
220}
221
222AFX_INLINE CXTPMarkupDependencyProperty* CXTPMarkupObjectProperty::GetProperty()
223{
224 return m_pProperty;
225}
226
227AFX_INLINE CString CXTPMarkupBuilder::GetLastError() const
228{
229 return m_strLastError;
230}
231
232AFX_INLINE CXTPMarkupContext* CXTPMarkupBuilder::GetMarkupContext() const
233{
234 return m_pMarkupContext;
235}
236
239# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
241#endif // !defined(__XTPMARKUPBUILDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComInitializer
Initializes COM and increments and holds COM initialization reference counter for the thread where co...
Definition XTPSystemHelpers.h:2021
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


CXTPFlowGraphUndoAddConnectionPointCommand Member List

This is the complete list of members for CXTPFlowGraphUndoAddConnectionPointCommand, including all inherited members.

CXTPFlowGraphUndoAddConnectionPointCommand(CXTPFlowGraphConnectionPoint *pConnectionPoint) | CXTPFlowGraphUndoAddConnectionPointCommand |
CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pConnectionPoint | CXTPFlowGraphUndoAddConnectionPointCommand | protected
Undo() | CXTPFlowGraphUndoAddConnectionPointCommand | protectedvirtual
~CXTPFlowGraphUndoAddConnectionPointCommand() | CXTPFlowGraphUndoAddConnectionPointCommand | virtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual


Toolkit Pro: XTPChartLineStyle.h Source File

  • Source
  • Chart
  • Appearance
XTPChartLineStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLINESTYLE_H__)
24# define __XTPCHARTLINESTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartElement;
34class CXTPChartDeviceCommand;
35
36typedef CArray<float, float> CXTPChartLineDashArray;
37
42class _XTP_EXT_CLASS CXTPChartLineStyle : public CXTPCmdTarget
43{
44public:
51 CXTPChartLineStyle(CXTPChartElement* pOwner);
52
53public:
59 void Release();
60
61public:
68 void SetThickness(int nThickness);
75 int GetThickness() const;
76
83 void SetDashStyle(XTPChartDashStyle nDashStyle);
84
91 XTPChartDashStyle GetDashStyle() const;
92
93 void SetDashArray(const CXTPChartLineDashArray& dashArray);
94
95public:
109 virtual CXTPChartDeviceCommand* CreateDeviceCommand(const CXTPChartPointF& point1,
110 const CXTPChartPointF& point2,
111 const CXTPChartColor& color);
112
125 virtual CXTPChartDeviceCommand* CreateDeviceCommand(const CXTPChartPoints& points,
126 const CXTPChartColor& color);
127
140 virtual CXTPChartDeviceCommand* CreateSplineDeviceCommand(const CXTPChartPoints& points,
141 const CXTPChartColor& color);
142
143public:
144 virtual void DoPropExchange(CXTPPropExchange* pPX);
145
146# ifdef _XTP_ACTIVEX
147public:
149 DECLARE_DISPATCH_MAP()
150 DECLARE_INTERFACE_MAP()
151 DECLARE_OLETYPELIB_EX(CXTPChartLineStyle);
152
153 void OleSetDashArray(const VARIANT& var);
155# endif
156
157protected:
158 int m_nThickness;
159 XTPChartDashStyle m_nDashStyle;
160 CXTPChartElement* m_pOwner;
161 CXTPChartLineDashArray m_arrDashArray;
162};
163
164AFX_INLINE void CXTPChartLineStyle::Release()
165{
166 InternalRelease();
167}
168AFX_INLINE int CXTPChartLineStyle::GetThickness() const
169{
170 return m_nThickness;
171}
172AFX_INLINE XTPChartDashStyle CXTPChartLineStyle::GetDashStyle() const
173{
174 return m_nDashStyle;
175}
177# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
178#endif //#if !defined(__XTPCHARTLINESTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartLineStyle::CreateSplineDeviceCommand
virtual CXTPChartDeviceCommand * CreateSplineDeviceCommand(const CXTPChartPoints &points, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a spli...
CXTPChartLineStyle::CXTPChartLineStyle
CXTPChartLineStyle(CXTPChartElement *pOwner)
Constructs a CXTPChartLineStyle object.
CXTPChartLineStyle::m_nDashStyle
XTPChartDashStyle m_nDashStyle
The dash style.
Definition XTPChartLineStyle.h:159
CXTPChartLineStyle::SetThickness
void SetThickness(int nThickness)
Call this function to set the thickness of the line.
CXTPChartLineStyle::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(const CXTPChartPointF &point1, const CXTPChartPointF &point2, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a line...
CXTPChartLineStyle::m_pOwner
CXTPChartElement * m_pOwner
The owner element.
Definition XTPChartLineStyle.h:160
CXTPChartLineStyle::m_nThickness
int m_nThickness
The line thickness.
Definition XTPChartLineStyle.h:158
CXTPChartLineStyle::GetThickness
int GetThickness() const
Call this function to get the thickness of the line.
Definition XTPChartLineStyle.h:168
CXTPChartLineStyle::Release
void Release()
Call this function to release the object once the object is no more relevant.
Definition XTPChartLineStyle.h:164
CXTPChartLineStyle::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(const CXTPChartPoints &points, const CXTPChartColor &color)
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a line...
CXTPChartLineStyle::SetDashStyle
void SetDashStyle(XTPChartDashStyle nDashStyle)
Call this function to set dash line style.
CXTPChartLineStyle::GetDashStyle
XTPChartDashStyle GetDashStyle() const
Call this function to get the dash line style.
Definition XTPChartLineStyle.h:172
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPGifPreviewProvider Member List

This is the complete list of members for CXTPGifPreviewProvider, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


Toolkit Pro: XTPHyperLink.h Source File

  • Source
  • Controls
  • Static
XTPHyperLink.h
Go to the documentation of this file.
1
23#if !defined(__XTPHYPERLINK_H__)
24# define __XTPHYPERLINK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPHyperLink : public CStatic
40{
42 DECLARE_DYNAMIC(CXTPHyperLink)
44public:
49 CXTPHyperLink();
50
55 virtual ~CXTPHyperLink();
56
57public:
66 void EnableShellExecute(bool bEnable);
67
74 virtual void SetURL(LPCTSTR lpszLink);
75
82 virtual CString GetURL() const;
83
93 virtual void SetColors(COLORREF clrLink, COLORREF clrVisited, COLORREF clrHover);
94
101 virtual COLORREF GetLinkColor() const;
102
111 virtual COLORREF GetVisitedColor() const;
112
121 virtual COLORREF GetHoverColor() const;
122
130 virtual void SetVisited(bool bVisited = true);
131
139 virtual bool GetVisited() const;
140
148 virtual void SetLinkCursor(HCURSOR hCursor);
149
157 virtual HCURSOR GetLinkCursor() const;
158
167 virtual void SetUnderline(bool bUnderline = true);
168
175 virtual bool GetUnderline() const;
176
184 virtual void SetBackColor(COLORREF clrBack);
185
194 virtual COLORREF GetBackColor() const;
195
211 virtual bool GotoURL(LPCTSTR lpszLink = NULL, int nShowCmd = SW_SHOW, LPCTSTR lpszParams = NULL,
212 LPCTSTR lpszDir = NULL);
213
221 virtual bool IsTextControl();
222
229 void EnableToolTips(bool bEnable = true);
230
238 void SetTipText(LPCTSTR lpszTipText);
239
248 virtual bool IsLinkHot();
249
256 virtual void ReportError(int iErrorNo);
257
258protected:
266 virtual bool Init();
267
275 virtual bool InitFont();
276
286 virtual BOOL CreateFont(CFont& font, BOOL bUnderline);
287
289 DECLARE_MESSAGE_MAP()
290
291 //{{AFX_VIRTUAL(CXTPHyperLink)
292 virtual BOOL PreTranslateMessage(MSG* pMsg);
293 virtual void PreSubclassWindow();
294
295protected:
296 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
297 //}}AFX_VIRTUAL
298
299 //{{AFX_MSG(CXTPHyperLink)
300 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
301 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
302 afx_msg HBRUSH CtlColor(CDC* pDC, UINT nCtlColor);
303 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
304 afx_msg void OnTimer(UINT_PTR nIDEvent);
305 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
306 afx_msg void OnPaint();
307 afx_msg void OnWindowPosChanged(WINDOWPOS FAR* lpwndpos);
308 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
309 afx_msg BOOL OnClicked();
310 afx_msg LRESULT OnNcHitTest(CPoint point);
311 afx_msg void OnKillFocus(CWnd* pOldWnd);
312 afx_msg void OnSetFocus(CWnd* pOldWnd);
313 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
314 afx_msg UINT OnGetDlgCode();
315 //}}AFX_MSG
316
319protected:
320 bool m_bShellExec;
322 bool m_bPreSubclassInit;
323 bool m_bUnderline;
324 bool m_bMouseOver;
325 bool m_bVisited;
326 bool m_bTipEnabled;
328 CXTPFont m_xtpFont;
329 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_font, m_xtpFont, GetFontHandle);
330
331 CString m_strLink;
332 CString m_strTipText;
333 HCURSOR m_hcurHand;
334 COLORREF m_clrLink;
335 COLORREF m_clrHover;
337 COLORREF m_clrVisited;
339 COLORREF m_clrBack;
341 CToolTipCtrl m_toolTip;
342};
343
345
346AFX_INLINE CString CXTPHyperLink::GetURL() const
347{
348 return m_strLink;
349}
350AFX_INLINE void CXTPHyperLink::SetColors(COLORREF clrLink, COLORREF clrVisited, COLORREF clrHover)
351{
352 m_clrLink = clrLink;
353 m_clrVisited = clrVisited;
354 m_clrHover = clrHover;
355 RedrawWindow();
356}
357AFX_INLINE COLORREF CXTPHyperLink::GetLinkColor() const
358{
359 return m_clrLink;
360}
361AFX_INLINE COLORREF CXTPHyperLink::GetVisitedColor() const
362{
363 return m_clrVisited;
364}
365AFX_INLINE COLORREF CXTPHyperLink::GetHoverColor() const
366{
367 return m_clrHover;
368}
369AFX_INLINE void CXTPHyperLink::SetVisited(bool bVisited)
370{
371 m_bVisited = bVisited;
372 RedrawWindow();
373}
374AFX_INLINE bool CXTPHyperLink::GetVisited() const
375{
376 return m_bVisited;
377}
378AFX_INLINE void CXTPHyperLink::SetLinkCursor(HCURSOR hCursor)
379{
380 m_hcurHand = hCursor;
381}
382AFX_INLINE HCURSOR CXTPHyperLink::GetLinkCursor() const
383{
384 return m_hcurHand;
385}
386AFX_INLINE void CXTPHyperLink::SetUnderline(bool bUnderline)
387{
388 m_bUnderline = bUnderline;
389 InitFont();
390}
391AFX_INLINE bool CXTPHyperLink::GetUnderline() const
392{
393 return m_bUnderline;
394}
395AFX_INLINE bool CXTPHyperLink::IsTextControl()
396{
397 return ((GetStyle() & 0xFF) <= SS_RIGHT) ? true : false;
398}
399AFX_INLINE void CXTPHyperLink::EnableShellExecute(bool bEnable)
400{
401 m_bShellExec = bEnable;
402}
403AFX_INLINE void CXTPHyperLink::SetBackColor(COLORREF clrBack)
404{
405 m_clrBack = clrBack;
406 RedrawWindow();
407}
408AFX_INLINE COLORREF CXTPHyperLink::GetBackColor() const
409{
410 return (m_clrBack == (COLORREF)-1) ? GetXtremeColor(COLOR_3DFACE) : m_clrBack;
411}
413# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
415#endif // #if !defined(__XTPHYPERLINK_H__)
GetXtremeColor
_XTP_EXT_CLASS COLORREF AFX_CDECL GetXtremeColor(UINT nIndex)
Call this member as a convenient way to call XTPColorManager()->GetColor, see CXTPColorManager::GetCo...
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPHyperLink
CXTPHyperLink is a CStatic derived class.
Definition XTPHyperLink.h:40
CXTPHyperLink::InitFont
virtual bool InitFont()
This member function is called by the CXTPHyperLink class to initialize the font to be used by the hy...
CXTPHyperLink::IsTextControl
virtual bool IsTextControl()
This member function checks to see if the hyperlink control is a text control.
CXTPHyperLink::SetTipText
void SetTipText(LPCTSTR lpszTipText)
Call this member function to set the tooltip text for the tooltip associated with the hyperlink contr...
CXTPHyperLink::GetLinkColor
virtual COLORREF GetLinkColor() const
This member function retrieves the current hyperlink text color.
CXTPHyperLink::SetVisited
virtual void SetVisited(bool bVisited=true)
This member function will cause the control to display the hyperlink text color as visited.
CXTPHyperLink::SetUnderline
virtual void SetUnderline(bool bUnderline=true)
This member function will cause the hyperlink to display the text as underlined.
CXTPHyperLink::SetURL
virtual void SetURL(LPCTSTR lpszLink)
This member function sets the URL for the hyperlink control.
CXTPHyperLink::GotoURL
virtual bool GotoURL(LPCTSTR lpszLink=NULL, int nShowCmd=SW_SHOW, LPCTSTR lpszParams=NULL, LPCTSTR lpszDir=NULL)
This member function is called to execute the shell command associated with the current URL.
CXTPHyperLink::~CXTPHyperLink
virtual ~CXTPHyperLink()
Destroys a CXTPHyperLink object, handles cleanup and deallocation.
CXTPHyperLink::EnableShellExecute
void EnableShellExecute(bool bEnable)
Call this member function to enable/disable ShellExecute to be called for the URL that is specified f...
CXTPHyperLink::SetBackColor
virtual void SetBackColor(COLORREF clrBack)
This member function will set the background fill color for the hyperlink control.
CXTPHyperLink::GetHoverColor
virtual COLORREF GetHoverColor() const
This member function retrieves the current hyperlink text color when the mouse hovers over the hyperl...
CXTPHyperLink::EnableToolTips
void EnableToolTips(bool bEnable=true)
Call this member function to enable/disable tooltips for the hyperlink control.
CXTPHyperLink::SetColors
virtual void SetColors(COLORREF clrLink, COLORREF clrVisited, COLORREF clrHover)
This member function will set the RGB color values for the hyperlink text.
CXTPHyperLink::GetVisited
virtual bool GetVisited() const
This member function checks to see if the user has visited the URL associated with the hyperlink.
CXTPHyperLink::CreateFont
virtual BOOL CreateFont(CFont &font, BOOL bUnderline)
This member function is called by the CXTPHyperLink class to initialize a font to be used by the hype...
CXTPHyperLink::IsLinkHot
virtual bool IsLinkHot()
Call this member to determine if the hyperlink is currently hot.
CXTPHyperLink::GetUnderline
virtual bool GetUnderline() const
This member function checks to see if the hyperlink text is underlined.
CXTPHyperLink::SetLinkCursor
virtual void SetLinkCursor(HCURSOR hCursor)
This member function will set the cursor associated with the hyperlink control.
CXTPHyperLink::GetURL
virtual CString GetURL() const
This member function retrieves the URL for the hyperlink.
CXTPHyperLink::ReportError
virtual void ReportError(int iErrorNo)
This member function is called by the CXTPHyperLink object to display a message box whenever an error...
CXTPHyperLink::CXTPHyperLink
CXTPHyperLink()
Constructs a CXTPHyperLink object.
CXTPHyperLink::GetBackColor
virtual COLORREF GetBackColor() const
This member function will retrieve the current background fill color for the hyperlink control.
CXTPHyperLink::GetVisitedColor
virtual COLORREF GetVisitedColor() const
This member function retrieves the current hyperlink text color when the link has been activated.
CXTPHyperLink::Init
virtual bool Init()
This member function is called by the CXTPHyperLink class to perform initialization when the window i...
CXTPHyperLink::GetLinkCursor
virtual HCURSOR GetLinkCursor() const
This member function will get a handle to the current cursor associated with the hyperlink control.


CXTPCommandBarScrollBarCtrl Member List

This is the complete list of members for CXTPCommandBarScrollBarCtrl, including all inherited members.

CXTPCommandBarScrollBarCtrl() | CXTPCommandBarScrollBarCtrl |
CXTPScrollBarCtrl() | CXTPScrollBarCtrl |
CXTPScrollBase() | CXTPScrollBase |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetScrollBarPaintManager() const | CXTPCommandBarScrollBarCtrl | protectedvirtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBarCtrl | protected
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() | CXTPScrollBarCtrl | protected
CXTPScrollBase::GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi) | CXTPScrollBarCtrl | virtual
GetTicks() const | CXTPScrollBase |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
Init() | CXTPScrollBarCtrl | protected
IsScrollBarEnabled() const =0 | CXTPScrollBase | pure virtual
IsSlider() const | CXTPScrollBase |
m_bAnimation | CXTPScrollBase | protected
m_bPreSubclassInit | CXTPScrollBarCtrl | protected
m_nTimerElapse | CXTPScrollBase | protected
m_pCommandBars | CXTPCommandBarScrollBarCtrl | protected
m_pSBTrack | CXTPScrollBase | protected
m_pTicks | CXTPScrollBase | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
RefreshMetrics() | CXTPScrollBarCtrl | virtual
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPCommandBarScrollBarCtrl |
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetTheme(XTPScrollBarTheme theme) | CXTPScrollBarCtrl |
SetTicks(double *pTicks, int nCount) | CXTPScrollBase |
~CXTPCommandBarScrollBarCtrl() | CXTPCommandBarScrollBarCtrl | virtual
~CXTPScrollBarCtrl() | CXTPScrollBarCtrl | virtual
~CXTPScrollBase() | CXTPScrollBase | virtual


Toolkit Pro: XTPSkinManagerResource.h Source File

  • Source
  • SkinFramework
XTPSkinManagerResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERRESOURCE_H__)
24# define __XTPSKINMANAGERRESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSkinImage;
34class CXTPSkinManagerSchema;
35class CXTPSkinManager;
36
42class _XTP_EXT_CLASS CXTPSkinManagerResourceFile
43 : public CXTPCmdTarget
44 , public CXTPSynchronized
45{
46public:
52 CXTPSkinManagerResourceFile(CXTPSkinManager* pSkinManager = NULL);
53
58 virtual ~CXTPSkinManagerResourceFile();
59
60public:
68 virtual BOOL Open(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName);
69
77 virtual BOOL ReadString(CString& str);
78
83 virtual void Close();
84
93 virtual CXTPSkinImage* LoadImage(CString strImageFile);
94
104 virtual CXTPSkinManagerSchema* CreateSchema();
105
106public:
113 CString GetResourcePath() const;
114
121 CString GetIniFileName() const;
122
129 HMODULE GetModuleHandle() const;
130
136 void SetModuleHandle(HMODULE hModule);
137
144 CXTPSkinManager* GetSkinManager() const;
145
146private:
147 CString GetDefaultIniFileName();
148
149protected:
150 LPWSTR m_lpTextFile;
151 LPWSTR m_lpTextFileEnd;
152 HMODULE m_hModule;
153 HMODULE m_hInstance;
155 CString m_strResourcePath;
156 CString m_strIniFileName;
157 CXTPSkinManager* m_pManager;
159 CStdioFile* m_pIniFile;
161 friend class CXTPSkinManager;
162};
163
164AFX_INLINE CString CXTPSkinManagerResourceFile::GetIniFileName() const
165{
166 return m_strIniFileName;
167}
168AFX_INLINE CString CXTPSkinManagerResourceFile::GetResourcePath() const
169{
170 return m_strResourcePath;
171}
172AFX_INLINE HMODULE CXTPSkinManagerResourceFile::GetModuleHandle() const
173{
174 return m_hModule;
175}
176AFX_INLINE void CXTPSkinManagerResourceFile::SetModuleHandle(HMODULE hModule)
177{
178 m_hInstance = hModule;
179}
180AFX_INLINE CXTPSkinManager* CXTPSkinManagerResourceFile::GetSkinManager() const
181{
182 return m_pManager;
183}
184
185# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
187#endif // !defined(__XTPSKINMANAGERRESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSkinImage
The CXTPSkinImage class represents a simple bitmap holder and draw operations for Skin Framework.
Definition XTPSkinImage.h:41
CXTPSkinManager
CXTPSkinManager is a standalone class that represents a global object that manages skins.
Definition XTPSkinManager.h:541
CXTPSkinManagerResourceFile
CXTPSkinManagerResourceFile is a standalone class that represents a manager of visual style resources...
Definition XTPSkinManagerResource.h:45
CXTPSkinManagerResourceFile::GetResourcePath
CString GetResourcePath() const
Gets the resource path.
Definition XTPSkinManagerResource.h:168
CXTPSkinManagerResourceFile::GetIniFileName
CString GetIniFileName() const
Gets the .ini file name.
Definition XTPSkinManagerResource.h:164
CXTPSkinManagerResourceFile::m_pIniFile
CStdioFile * m_pIniFile
Pointer to the .ini file on disk.
Definition XTPSkinManagerResource.h:159
CXTPSkinManagerResourceFile::SetModuleHandle
void SetModuleHandle(HMODULE hModule)
Sets the handle of the skin module.
Definition XTPSkinManagerResource.h:176
CXTPSkinManagerResourceFile::m_lpTextFileEnd
LPWSTR m_lpTextFileEnd
Pointer to end of the file.
Definition XTPSkinManagerResource.h:151
CXTPSkinManagerResourceFile::GetSkinManager
CXTPSkinManager * GetSkinManager() const
Gets the owner skin manager object.
Definition XTPSkinManagerResource.h:180
CXTPSkinManagerResourceFile::Open
virtual BOOL Open(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName)
Opens the visual style file.
CXTPSkinManagerResourceFile::m_hInstance
HMODULE m_hInstance
Handle of the visual style.
Definition XTPSkinManagerResource.h:153
CXTPSkinManagerResourceFile::ReadString
virtual BOOL ReadString(CString &str)
Reads the .ini file.
CXTPSkinManagerResourceFile::m_pManager
CXTPSkinManager * m_pManager
Parent manager class.
Definition XTPSkinManagerResource.h:157
CXTPSkinManagerResourceFile::LoadImage
virtual CXTPSkinImage * LoadImage(CString strImageFile)
Loads a specified image from a resource file.
CXTPSkinManagerResourceFile::m_lpTextFile
LPWSTR m_lpTextFile
Pointer to the next string.
Definition XTPSkinManagerResource.h:150
CXTPSkinManagerResourceFile::m_hModule
HMODULE m_hModule
Handle of the visual style.
Definition XTPSkinManagerResource.h:152
CXTPSkinManagerResourceFile::m_strIniFileName
CString m_strIniFileName
.ini file name.
Definition XTPSkinManagerResource.h:156
CXTPSkinManagerResourceFile::CreateSchema
virtual CXTPSkinManagerSchema * CreateSchema()
Creates the CXTPSkinManagerSchema class associated with loaded resources.
CXTPSkinManagerResourceFile::GetModuleHandle
HMODULE GetModuleHandle() const
Gets the handle of the skin module.
Definition XTPSkinManagerResource.h:172
CXTPSkinManagerResourceFile::Close
virtual void Close()
Closes the visual style file.
CXTPSkinManagerResourceFile::CXTPSkinManagerResourceFile
CXTPSkinManagerResourceFile(CXTPSkinManager *pSkinManager=NULL)
Constructs a CXTPSkinManagerResourceFile object.
CXTPSkinManagerResourceFile::~CXTPSkinManagerResourceFile
virtual ~CXTPSkinManagerResourceFile()
Destroys a CXTPSkinManagerResourceFile object, handles cleanup and deallocation.
CXTPSkinManagerResourceFile::m_strResourcePath
CString m_strResourcePath
Resource path.
Definition XTPSkinManagerResource.h:155
CXTPSkinManagerSchema
CXTPSkinManagerSchema is a standalone class used to read a visual styles schema file.
Definition XTPSkinManagerSchema.h:164
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602


CXTPPropertyGridItemDouble Member List

This is the complete list of members for CXTPPropertyGridItemDouble, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToDouble(double *pBindDouble) | CXTPPropertyGridItemDouble | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemDouble(LPCTSTR strCaption, double fValue=0, LPCTSTR strFormat=NULL, double *pBindNumber=NULL) | CXTPPropertyGridItemDouble |
CXTPPropertyGridItemDouble(UINT nID, double fValue=0, LPCTSTR strFormat=NULL, double *pBindNumber=NULL) | CXTPPropertyGridItemDouble |
DoubleToString(double dValue) | CXTPPropertyGridItemDouble | protectedvirtual
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDouble() const | CXTPPropertyGridItemDouble | virtual
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bUseSystemDecimalSymbol | CXTPPropertyGridItemDouble | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_fValue | CXTPPropertyGridItemDouble | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindDouble | CXTPPropertyGridItemDouble | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAddChildItem() | CXTPPropertyGridItem | protectedvirtual
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemDouble | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDouble(double fValue) | CXTPPropertyGridItemDouble | virtual
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetValue(CString strValue) | CXTPPropertyGridItemDouble | protectedvirtual
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
StringToDouble(LPCTSTR lpszValue) | CXTPPropertyGridItemDouble | protectedvirtual
UseSystemDecimalSymbol(BOOL bUseSystemDecimalSymbol) | CXTPPropertyGridItemDouble |
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemDouble() | CXTPPropertyGridItemDouble | virtual


Toolkit Pro: XTPRibbonBuilder.h Source File

  • Source
  • Ribbon
XTPRibbonBuilder.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBUILDER_H__)
24# define __XTPRIBBONBUILDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifndef RT_RIBBON
34# define RT_RIBBON MAKEINTRESOURCE(28)
35# endif
36
37class CXTPRibbonBar;
38class CXTPPropExchange;
39class CXTPCommandBars;
40class CXTPPropExchangeXMLNode;
41class CXTPRibbonGroup;
42class CXTPRibbonGroup;
43class CXTPRibbonTab;
44class CXTPControl;
45
46class _XTP_EXT_CLASS CXTPRibbonBuilder
47{
48public:
49 CXTPRibbonBuilder();
50 virtual ~CXTPRibbonBuilder();
51
52public:
53 BOOL LoadFromResource(UINT uiXMLResID, LPCTSTR lpszResType = RT_RIBBON,
54 HINSTANCE hInstance = NULL);
55
56 BOOL Build(CXTPRibbonBar* pRibbonBar);
57
58protected:
59 virtual CCmdTarget* CreateElement(const CString& strElementName);
60
61protected:
62 BOOL BuildCategories(CXTPPropExchange* pPX, CXTPRibbonBar* pRibbonBar);
63 BOOL BuildGroups(CXTPPropExchange* pPX, CXTPRibbonTab* pRibbonTab);
64 BOOL BuildGroupControls(CXTPPropExchange* pPX, CXTPRibbonGroup* pRibbonGroup);
65 void BuildControl(CXTPPropExchange* pPX, CXTPControl* pControl);
66 BOOL BuildMainButton(CXTPPropExchange* pPX, CXTPRibbonBar* pRibbonBar);
67 BOOL BuildMainButtonPopupBar(CXTPPropExchange* pPX, CXTPRibbonBar* pRibbonBar);
68 void BuildControlPopupBar(CXTPPropExchange* pPX, CXTPControl*& pControl,
69 CRuntimeClass* pPopupBarClass);
70 void BuildQATElements(CXTPPropExchange* pPX, CXTPRibbonBar* pRibbonBar);
71 BOOL BuildTabElements(CXTPPropExchange* pPX, CXTPRibbonBar* pRibbonBar);
72
73 void AddImageIndex(int nIndex, int nId, int nImageType);
74 void LoadIcons(CXTPPropExchange* pPX);
75 void LoadIcons(int nId, CUIntArray& arrIcons);
76
77protected:
78 CUIntArray m_arrImageSmall;
79 CUIntArray m_arrImageLarge;
80 CXTPCommandBars* m_pCommandBars;
81 CXTPPropExchangeXMLNode* m_pPX;
82};
83
84# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
86#endif // !defined(__XTPRIBBONBUILDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPPropExchangeXMLNode
CXTPPropExchangeXMLNode is CXTPPropExchange derived class.
Definition XTPPropExchangeXMLNode.h:52
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116


CXTPSkinObjectClassMap Member List

This is the complete list of members for CXTPSkinObjectClassMap, including all inherited members.

AddClass(LPCTSTR lpszClassName, CXTPSkinObjectClassInfo *pInfo) | CXTPSkinObjectClassMap |
AddStandardClasses() | CXTPSkinObjectClassMap |
AddSynonymClass(LPCTSTR lpszClassNameSynonym, LPCTSTR lpszClassName) | CXTPSkinObjectClassMap |
CXTPSkinObjectClassMap() | CXTPSkinObjectClassMap |
GetAccessCriticalSection() const | CXTPSynchronized | inline
Lookup(LPCTSTR lpszClassName) | CXTPSkinObjectClassMap |
m_mapInfo | CXTPSkinObjectClassMap | protected
RemoveAll() | CXTPSkinObjectClassMap |
RemoveClass(LPCTSTR lpszClassName) | CXTPSkinObjectClassMap |
RemoveClass(CXTPSkinObjectClassInfo *pInfo) | CXTPSkinObjectClassMap |
~CXTPSkinObjectClassMap() | CXTPSkinObjectClassMap |


CXTPDockingPaneGripperedTheme Member List

This is the complete list of members for CXTPDockingPaneGripperedTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneGripperedTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneGripperedTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


Toolkit Pro: XTPColorPicker.h Source File

  • Source
  • Controls
  • Button
XTPColorPicker.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOLORPICKER_H__)
24# define __XTPCOLORPICKER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// class forwards
34class CXTPColorPopup;
35struct XTP_PICK_BUTTON;
36
42class _XTP_EXT_CLASS CXTPColorPicker : public CXTPButton
43{
45 DECLARE_DYNAMIC(CXTPColorPicker)
47public:
52 CXTPColorPicker();
53
58 virtual ~CXTPColorPicker();
59
60public:
122 BOOL SetThemeColors(XTP_PICK_BUTTON* pColors = NULL, int nCount = 10, LPCTSTR lpszTitle = NULL,
123 UINT* pStringIDs = NULL, int ppShadeMatrix[6][10] = NULL);
124
186 BOOL SetThemeColors(XTP_PICK_BUTTON* pColors, int nCount, LPCTSTR lpszTitle,
187 LPCTSTR* ppszStrings, int ppShadeMatrix[6][10]);
188
219 BOOL SetStandardColors(XTP_PICK_BUTTON* pColors = NULL, int nCount = 10, int nCols = 10,
220 LPCTSTR lpszTitle = NULL);
221
227 virtual void SetColor(COLORREF clr);
228
235 virtual COLORREF GetColor() const;
236
243 virtual void ShowText(BOOL bShowText);
244
252 virtual BOOL IsTextShown() const;
253
260 virtual void ShowTextInColor(BOOL bColorText);
261
269 virtual BOOL IsTextInColor() const;
270
278 virtual void SetDefaultColor(COLORREF clrDefault);
279
288 virtual COLORREF GetDefaultColor() const;
289
320 virtual void ModifyCPStyle(DWORD dwRemove, DWORD dwAdd);
321
327 virtual void ShowPopupWindow();
328
337 void SetColors(XTP_PICK_BUTTON* pColors, int nCount, int nCols = 8, LPCTSTR lpszTitle = NULL);
338
346 CXTPPickBtnArray& GetThemeColors();
347
355 CXTPPickBtnArray& GetStandardColors();
356
362 void ShowCaptions(BOOL bShow);
363
364protected:
377 virtual COLORREF GetContrastColor() const;
378
379protected:
380 virtual void DoDraw(CDC* pDC);
381 virtual void DrawColorPicker(CDC* pDC);
382
383public:
384 virtual BOOL IsPushed();
385
386protected:
388 DECLARE_MESSAGE_MAP()
389
390 //{{AFX_VIRTUAL(CXTPColorPicker)
391 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
392 //}}AFX_VIRTUAL
393
394 //{{AFX_MSG(CXTPColorPicker)
395 afx_msg LRESULT OnXtpSelChange(WPARAM wParam, LPARAM lParam);
396 afx_msg LRESULT OnXtpDropDown(WPARAM wParam, LPARAM lParam);
397 afx_msg LRESULT OnXtpCloseUp(WPARAM wParam, LPARAM lParam);
398 afx_msg LRESULT OnXtpSelEndOK(WPARAM wParam, LPARAM lParam);
399 afx_msg LRESULT OnXtpSelEndCancel(WPARAM wParam, LPARAM lParam);
400 afx_msg LRESULT OnXtpSelNoFill(WPARAM wParam, LPARAM lParam);
401 afx_msg void OnXtpShowPopup();
402 //}}AFX_MSG
405protected:
406 BOOL m_bShowText;
407 BOOL m_bColorText;
409 BOOL m_bPopupActive;
410 DWORD m_dwPopup;
411 COLORREF m_clrSelected;
412 COLORREF m_clrDefault;
413 CString m_strTitleTheme;
414 CString m_strTitleStandard;
415 CString m_strTitleCustom;
417 BOOL m_bCaptions;
418 CXTPPickBtnArray m_arThemeColors;
419 CXTPPickBtnArray m_arStandardColors;
420 XTP_PICK_BUTTON* m_pExtendedColors;
421 int m_nExtendedColors;
422 int m_nCols;
424 friend class CXTPColorPickerTheme;
425};
426
428
429AFX_INLINE void CXTPColorPicker::SetColors(XTP_PICK_BUTTON* pColors, int nCount, int nCols,
430 LPCTSTR lpszTitle /*=NULL*/)
431{
432 m_pExtendedColors = pColors;
433 m_nExtendedColors = nCount;
434 m_nCols = nCols;
435 m_strTitleCustom = lpszTitle;
436}
437AFX_INLINE COLORREF CXTPColorPicker::GetColor() const
438{
439 return m_clrSelected;
440}
441AFX_INLINE void CXTPColorPicker::ShowText(BOOL bShowText)
442{
443 m_bShowText = bShowText;
444 RedrawWindow();
445}
446AFX_INLINE BOOL CXTPColorPicker::IsTextShown() const
447{
448 return m_bShowText;
449}
450AFX_INLINE void CXTPColorPicker::ShowTextInColor(BOOL bColorText)
451{
452 m_bColorText = bColorText;
453 RedrawWindow();
454}
455AFX_INLINE BOOL CXTPColorPicker::IsTextInColor() const
456{
457 return m_bColorText;
458}
459AFX_INLINE void CXTPColorPicker::SetDefaultColor(COLORREF clrDefault)
460{
461 m_clrDefault = clrDefault;
462 RedrawWindow();
463}
464AFX_INLINE COLORREF CXTPColorPicker::GetDefaultColor() const
465{
466 return m_clrDefault;
467}
468AFX_INLINE void CXTPColorPicker::ModifyCPStyle(DWORD dwRemove, DWORD dwAdd)
469{
470 m_dwPopup = (m_dwPopup & ~dwRemove) | dwAdd;
471 if (::IsWindow(m_hWnd))
472 RedrawWindow();
473}
474AFX_INLINE CXTPPickBtnArray& CXTPColorPicker::GetThemeColors()
475{
476 return m_arThemeColors;
477}
478AFX_INLINE CXTPPickBtnArray& CXTPColorPicker::GetStandardColors()
479{
480 return m_arStandardColors;
481}
482AFX_INLINE void CXTPColorPicker::ShowCaptions(BOOL bShow)
483{
484 m_bCaptions = bShow;
485}
507_XTP_EXT_CLASS void AFXAPI DDX_XTPColorPicker(CDataExchange* pDX, int nIDC, COLORREF& value);
508
509# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
511#endif // #if !defined(__XTPCOLORPICKER_H__)
DDX_XTPColorPicker
_XTP_EXT_CLASS void AFXAPI DDX_XTPColorPicker(CDataExchange *pDX, int nIDC, COLORREF &value)
The DDX_XTPColorPicker function manages the transfer of integer data between a color picker control i...
CXTPPickBtnArray
CArray< XTP_PICK_BUTTON, XTP_PICK_BUTTON & > CXTPPickBtnArray
CXTPPickBtnArray is used to manage a collection of XTP_PICK_BUTTON objects.
Definition XTPColorSelectorCtrl.h:55
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPColorPicker
CXTPColorPicker is a CXTPButton derived class.
Definition XTPColorPicker.h:43
CXTPColorPicker::ShowTextInColor
virtual void ShowTextInColor(BOOL bColorText)
This member function will display any text associated with the color picker button control in color.
CXTPColorPicker::GetDefaultColor
virtual COLORREF GetDefaultColor() const
This member function will return the default RGB color value for the color picker.
CXTPColorPicker::SetDefaultColor
virtual void SetDefaultColor(COLORREF clrDefault)
This member function will set the default RGB color value for the color picker.
CXTPColorPicker::SetColor
virtual void SetColor(COLORREF clr)
This member function will set the color value for the color picker.
CXTPColorPicker::SetThemeColors
BOOL SetThemeColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, LPCTSTR lpszTitle=NULL, UINT *pStringIDs=NULL, int ppShadeMatrix[6][10]=NULL)
Called to initialize the theme colors for the color selector.
CXTPColorPicker::IsTextInColor
virtual BOOL IsTextInColor() const
This member function will determine if the text for the color picker button control is displayed in c...
CXTPColorPicker::CXTPColorPicker
CXTPColorPicker()
Constructs a CXTPColorPicker object.
CXTPColorPicker::~CXTPColorPicker
virtual ~CXTPColorPicker()
Destroys a CXTPColorPicker object, handles cleanup and deallocation.
CXTPColorPicker::GetContrastColor
virtual COLORREF GetContrastColor() const
Retrieves the background contrast color for the CXTPColorPicker.
CXTPColorPicker::SetStandardColors
BOOL SetStandardColors(XTP_PICK_BUTTON *pColors=NULL, int nCount=10, int nCols=10, LPCTSTR lpszTitle=NULL)
Called to initialize the standard colors for the color selector.
CXTPColorPicker::GetColor
virtual COLORREF GetColor() const
This member function will return the currently selected color.
CXTPColorPicker::IsPushed
virtual BOOL IsPushed()
Call this member function to determine if the the button is currently being pushed.
CXTPColorPicker::GetThemeColors
CXTPPickBtnArray & GetThemeColors()
Called to retrieve a reference to the theme color button array.
CXTPColorPicker::SetColors
void SetColors(XTP_PICK_BUTTON *pColors, int nCount, int nCols=8, LPCTSTR lpszTitle=NULL)
Call this method to set custom colors for the color picker.
CXTPColorPicker::ShowCaptions
void ShowCaptions(BOOL bShow)
Call to show/hide captions for the color selector.
CXTPColorPicker::SetThemeColors
BOOL SetThemeColors(XTP_PICK_BUTTON *pColors, int nCount, LPCTSTR lpszTitle, LPCTSTR *ppszStrings, int ppShadeMatrix[6][10])
Called to initialize the theme colors for the color selector.
CXTPColorPicker::GetStandardColors
CXTPPickBtnArray & GetStandardColors()
Called to retrieve a reference to the standard color button array.
CXTPColorPicker::ShowText
virtual void ShowText(BOOL bShowText)
This member function will display any text associated with the color picker button control.
CXTPColorPicker::ModifyCPStyle
virtual void ModifyCPStyle(DWORD dwRemove, DWORD dwAdd)
Call this member function to modify the color picker display style.
CXTPColorPicker::IsTextShown
virtual BOOL IsTextShown() const
This member function will determine if text is displayed for the color picker button control.
CXTPColorPicker::ShowPopupWindow
virtual void ShowPopupWindow()
This member function will activate the color picker and display the color pop-up window.
CXTPColorPopup
CXTPColorPopup is a CXTPColorSelectorCtrl derived class.
Definition XTPColorPopup.h:42
XTP_PICK_BUTTON
XTP_PICK_BUTTON structure is used by the CXTPColorSelectorCtrl class to support a user-defined color ...
Definition XTPColorSelectorCtrl.h:44


Toolkit Pro: XTPCalendarWeekView.h Source File

  • Source
  • Calendar
XTPCalendarWeekView.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARWEEKVIEW_H__)
23# define _XTPCALENDARWEEKVIEW_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarWeekView;
32class CXTPCalendarWeekViewDay;
33class CXTPCalendarControl;
34
53class _XTP_EXT_CLASS CXTPCalendarWeekView : public CXTPCalendarViewT<CXTPCalendarWeekViewDay>
54{
56 DECLARE_DYNAMIC(CXTPCalendarWeekView)
57
58 friend class CXTPCalendarWeekViewEvent;
59 friend class CXTPCalendarTheme;
61public:
66 typedef CXTPCalendarViewT<CXTPCalendarWeekViewDay> TBase;
67
76 CXTPCalendarWeekView(CXTPCalendarControl* pCalendarControl);
77
85 virtual ~CXTPCalendarWeekView();
86
92 virtual void Populate();
93
107 virtual void ShowDay(const COleDateTime& date, BOOL bSelect = TRUE);
108
125 virtual void AdjustLayout(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
126
143 virtual void AdjustLayout2(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
144
155 virtual BOOL GetScrollBarInfoV(SCROLLINFO* pSI) const;
156
169 virtual void ScrollV(int nPos, int nPos_raw);
170
185 virtual void Draw(CDC* pDC);
186
201 virtual void Draw2(CDC* pDC);
202
217 virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
218
234 virtual COleDateTime GetViewDayDate(int nIndex) const;
235
244 int GetDayHeaderHeight() const;
245
258 void SetBeginDate(COleDateTime dtNewBeginDate);
259
269 COleDateTime GetBeginDate() const;
270
278 int GetDayWidth() const;
279
287 int GetDayHeight() const;
288
290 _XTP_DEPRECATED_IN_FAVOR(GetDayHeight)
291 int GetDayHeidht() const;
294protected: // member function
302 virtual void AdjustFirstDayOfWeek();
303
304private:
305 COleDateTime ShiftDateToCell_00(COleDateTime dtDate) const;
306
307public:
308 int GetFirstDayOfWeek() const;
309
310protected:
311 XTP_WEEK_VIEW_LAYOUT& GetLayout();
312
313protected:
314 XTP_WEEK_VIEW_LAYOUT m_LayoutX;
315 int m_nCurrPos;
317 COleDateTime m_dtBeginDate;
318 int m_nFirstDayOfWeekIndex;
320# ifdef _XTP_ACTIVEX
321
322 DECLARE_DISPATCH_MAP()
323 DECLARE_INTERFACE_MAP()
324
325 DECLARE_OLETYPELIB_EX(CXTPCalendarWeekView);
326
327# endif
328};
329
330AFX_INLINE int CXTPCalendarWeekView::GetFirstDayOfWeek() const
331{
332 return m_nFirstDayOfWeekIndex;
333}
334AFX_INLINE XTP_WEEK_VIEW_LAYOUT& CXTPCalendarWeekView::GetLayout()
335{
336 return m_LayoutX;
337}
338AFX_INLINE int CXTPCalendarWeekView::GetDayHeaderHeight() const
339{
340 return m_LayoutX.m_nDayHeaderHeight;
341}
342AFX_INLINE COleDateTime CXTPCalendarWeekView::GetBeginDate() const
343{
344 return m_dtBeginDate;
345}
346AFX_INLINE int CXTPCalendarWeekView::GetDayWidth() const
347{
348 return m_LayoutX.m_nDayWidth;
349}
350AFX_INLINE int CXTPCalendarWeekView::GetDayHeight() const
351{
352 return m_LayoutX.m_nDayHeight;
353}
355AFX_INLINE int CXTPCalendarWeekView::GetDayHeidht() const
356{
357 return GetDayHeight();
358}
361# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
362#endif // !defined(_XTPCALENDARWEEKVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarViewT
This template class represents a view portion of the Calendar control.
Definition XTPCalendarView.h:2571
CXTPCalendarWeekViewDay
This class represents a day view portion of the CalendarWeekView.
Definition XTPCalendarWeekViewDay.h:131
CXTPCalendarWeekViewEvent
This class represents an event view portion of the CalendarWeekViewDay.
Definition XTPCalendarWeekViewEvent.h:58
CXTPCalendarWeekView
This class implements a specific view portion of the Calendar control - called Week view.
Definition XTPCalendarWeekView.h:54
CXTPCalendarWeekView::Draw2
virtual void Draw2(CDC *pDC)
This member function is used to draw the view contents using the specified device context.
CXTPCalendarWeekView::GetBeginDate
COleDateTime GetBeginDate() const
This member function is used to obtain the date of the current week's Monday.
Definition XTPCalendarWeekView.h:342
CXTPCalendarWeekView::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and al...
CXTPCalendarWeekView::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client size and al...
CXTPCalendarWeekView::AdjustFirstDayOfWeek
virtual void AdjustFirstDayOfWeek()
Call this member function to adjust the first day of the week.
CXTPCalendarWeekView::SetBeginDate
void SetBeginDate(COleDateTime dtNewBeginDate)
This member function is used to set the date of a week's Monday.
CXTPCalendarWeekView::Populate
virtual void Populate()
This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarWeekView::ShowDay
virtual void ShowDay(const COleDateTime &date, BOOL bSelect=TRUE)
This member function is used to show the specified day in the calendar view.
CXTPCalendarWeekView::OnKeyDown
virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard on-key-down events.
CXTPCalendarWeekView::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view contents using the specified device context.
CXTPCalendarWeekView::GetDayWidth
int GetDayWidth() const
This member function is used to obtain the width of a weeks day rectangle.
Definition XTPCalendarWeekView.h:346
CXTPCalendarWeekView::CXTPCalendarWeekView
CXTPCalendarWeekView(CXTPCalendarControl *pCalendarControl)
Default object constructor.
CXTPCalendarWeekView::TBase
CXTPCalendarViewT< CXTPCalendarWeekViewDay > TBase
Base class type definition.
Definition XTPCalendarWeekView.h:66
CXTPCalendarWeekView::GetViewDayDate
virtual COleDateTime GetViewDayDate(int nIndex) const
Call this member function to obtain the date of a day view by the day's index.
CXTPCalendarWeekView::m_dtBeginDate
COleDateTime m_dtBeginDate
First date of week (Monday's date).
Definition XTPCalendarWeekView.h:317
CXTPCalendarWeekView::m_LayoutX
XTP_WEEK_VIEW_LAYOUT m_LayoutX
< data members
Definition XTPCalendarWeekView.h:314
CXTPCalendarWeekView::GetDayHeight
int GetDayHeight() const
This member function is used to obtain the height of a weeks day rectangle.
Definition XTPCalendarWeekView.h:350
CXTPCalendarWeekView::m_nFirstDayOfWeekIndex
int m_nFirstDayOfWeekIndex
Index for first weekday.
Definition XTPCalendarWeekView.h:318
CXTPCalendarWeekView::m_nCurrPos
int m_nCurrPos
Current scrollbar position.
Definition XTPCalendarWeekView.h:315
CXTPCalendarWeekView::GetDayHeaderHeight
int GetDayHeaderHeight() const
This member function is used to obtain the header height of a day.
Definition XTPCalendarWeekView.h:338
CXTPCalendarWeekView::GetScrollBarInfoV
virtual BOOL GetScrollBarInfoV(SCROLLINFO *pSI) const
This member function is used to retrieve information about a scroll bar state.
CXTPCalendarWeekView::~CXTPCalendarWeekView
virtual ~CXTPCalendarWeekView()
Default class destructor.
CXTPCalendarWeekView::ScrollV
virtual void ScrollV(int nPos, int nPos_raw)
This member function is used to scroll the contents of a view.
XTP_WEEK_VIEW_LAYOUT
This struct store a Week View layout.
Definition XTPCalendarDefines.h:1238
XTP_WEEK_VIEW_LAYOUT::m_nDayHeaderHeight
int m_nDayHeaderHeight
Height of a day header.
Definition XTPCalendarDefines.h:1240
XTP_WEEK_VIEW_LAYOUT::m_nDayWidth
int m_nDayWidth
Width of day rectangle.
Definition XTPCalendarDefines.h:1242
XTP_WEEK_VIEW_LAYOUT::m_nDayHeight
int m_nDayHeight
Height of day rectangle.
Definition XTPCalendarDefines.h:1243


CXTPSliderPaintManager Member List

This is the complete list of members for CXTPSliderPaintManager, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPSliderPaintManager(CXTPPaintManager *pPaintManager) | CXTPSliderPaintManager |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarPaintManager | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPSliderPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPSliderPaintManager | virtual


CXTPSingletonPointer Member List

This is the complete list of members for CXTPSingletonPointer, including all inherited members.

Creator typedef | CXTPSingletonPointer |
CXTPSingletonPointer(SIZE_T cbObjectSize, Creator pfnCreator, Destroyer pfnDestroyer, Initializer pfnInitializer=NULL) | CXTPSingletonPointer |
Destroy() | CXTPSingletonPointer |
Destroyer typedef | CXTPSingletonPointer |
GetAccess() const | CXTPSingletonPointer | inline
GetInstance() | CXTPSingletonPointer |
Initializer typedef | CXTPSingletonPointer |
~CXTPSingletonPointer() | CXTPSingletonPointer | virtual


Toolkit Pro: XTPDockingPaneSidePanel.h Source File

  • Source
  • DockingPane
XTPDockingPaneSidePanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANESIDEPANEL_H__)
24# define __XTPDOCKINGPANESIDEPANEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPaneLayout;
34class CXTPDockingPaneSidePanel;
35
42class _XTP_EXT_CLASS CXTPDockingPaneSidePanel
43 : public CMiniFrameWnd
44 , public CXTPDockingPaneBaseContainer
45{
47 DECLARE_DYNAMIC(CXTPDockingPaneSidePanel)
49protected:
56 CXTPDockingPaneSidePanel(CXTPDockingPaneLayout* pLayout);
57
63 ~CXTPDockingPaneSidePanel();
64
65public:
74 CXTPDockingPaneTabbedContainer* GetTopContainer() const;
75
83 XTPDockingPaneDirection GetDirection() const;
84
91 BOOL IsActive() const;
92
99 CString GetTitle() const;
100
107 CXTPDockingPane* GetSelectedPane() const;
108
109public:
115 void Collapse(BOOL bDelay = FALSE);
116
123 BOOL IsCollapsed() const;
124
129 void Expand();
130
137 void MovePanel(XTPDockingPaneDirection direction, CRect rect);
138
145 virtual BOOL IsCaptionVertical() const;
146
147protected:
158 BOOL Init(CXTPDockingPaneBase* pPane, XTPDockingPaneDirection direction, CRect rc);
159
167 BOOL Create(CRect rc);
168
169# if _MSC_VER > 1200
170 using CFrameWnd::Create;
171 using CMiniFrameWnd::Create;
172 using CWnd::Create;
173# endif
174
176 static void AFX_CDECL OnSizeParentEx(CXTPDockingPaneManager* pManager, CWnd* pParent,
177 CRect rect);
178
179protected:
180 void DeletePane();
181 void OnFinalRelease();
182 void PostNcDestroy();
183 void OnFocusChanged();
184
185 void RecalcLayout(BOOL bNotify = TRUE);
186 void RemovePane(CXTPDockingPaneBase* pPane);
187 void OnChildContainerChanged(CXTPDockingPaneBase* pContainer);
188 void CreateContainer();
200 void Copy(CXTPDockingPaneBase* pClone, CXTPPaneToPaneMap* pMap, DWORD dwIgnoredOptions);
201
207 void _InsertPane(CXTPDockingPaneBase* pPane);
208
218 void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const;
219
227 BOOL IsHorizontal() const;
228
241 INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
242
244 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
254 virtual BOOL DoPropExchange(CXTPPropExchange* pPX);
255
261 virtual void InvalidatePane(BOOL bSelectionChanged);
262
270 HWND GetPaneHwnd() const;
271
272protected:
278 void DoSlideStep(BOOL bActivate = FALSE);
279
284 void OnPinButtonClick();
285
286private:
287 typedef CArray<CXTPDockingPaneSidePanel*, CXTPDockingPaneSidePanel*> CSidePanelArray;
288
289 static void AFX_CDECL OnSizeParentEx(CSidePanelArray& arrSide, CWnd* pParent, CRect rect);
290 static int AFX_CDECL CompareLength(const void* arg1, const void* arg2);
291
292 struct LENGTH;
293 static void AFX_CDECL SortLength(LENGTH* pLength, int nFirstIndex, int nLastIndex);
294
295private:
296 CXTPDockingPaneCaptionButton* HitTestCaptionButton(CPoint point) const;
297 void OnCaptionButtonClick(CXTPDockingPaneCaptionButton* pButton);
298 void OnCaptionLButtonDown(CPoint point);
299 void _RestoreFocus();
300
301 BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton* pButton);
302 void MovePanel(LENGTH* pLength, CRect rect);
303
304 int GetMinHeight();
305
306protected:
308 DECLARE_MESSAGE_MAP()
309
310 //{{AFX_VIRTUAL(CXTPDockingPaneSidePanel)
311 //}}AFX_VIRTUAL
312
313 //{{AFX_MSG(CXTPDockingPaneSidePanel)
314 afx_msg void OnPaint();
315 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
316 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
317 afx_msg void OnSize(UINT nType, int cx, int cy);
318 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
319 afx_msg void OnMouseLeave();
320 afx_msg void OnTimer(UINT_PTR nIDEvent);
321 afx_msg LRESULT OnMouseHover(WPARAM, LPARAM lParam);
322 afx_msg LRESULT OnNcHitTest(CPoint point);
323 afx_msg void OnNcLButtonDown(UINT nHitTest, CPoint pt);
324 afx_msg void OnRButtonUp(UINT /*nFlags*/, CPoint point);
325 //}}AFX_MSG
326 BOOL IsResizable(int nHit);
327
330# ifdef _XTP_ACTIVEX
332private:
333 DECLARE_DISPATCH_MAP()
334 DECLARE_OLETYPELIB_EX(CXTPDockingPaneSidePanel);
335 DECLARE_ENUM_VARIANT(CXTPDockingPaneSidePanel);
336 DECLARE_INTERFACE_MAP()
337 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
338
339 LPDISPATCH OleGetDispatch(BOOL /*bAddRef*/);
340 afx_msg LPDISPATCH OleGetItem(int nIndex);
341 afx_msg int OleGetItemCount();
342 afx_msg LPDISPATCH OleGetContainer();
343 afx_msg int OleGetType();
344 afx_msg LPDISPATCH OleGetPane(int nIndex);
345 afx_msg HWND OleGetHwnd();
346 afx_msg BOOL OleIsEmpty();
347 afx_msg int OleGetPosition();
349# endif
350
351protected:
352 XTPDockingPaneDirection m_direction;
353 int m_nLengthIndex;
354
355 int m_nStepsCount;
356 int m_nSlideStep;
357 int m_nDeactivationCount;
359 BOOL m_bCollapsed;
360 BOOL m_bExpanded;
361 BOOL m_bSlideOut;
363 friend class CXTPDockingPaneManager;
364 friend class CXTPDockingPaneLayout;
365};
366
367AFX_INLINE HWND CXTPDockingPaneSidePanel::GetPaneHwnd() const
368{
369 return CWnd::GetSafeHwnd();
370}
371AFX_INLINE XTPDockingPaneDirection CXTPDockingPaneSidePanel::GetDirection() const
372{
373 return m_direction;
374}
375AFX_INLINE BOOL CXTPDockingPaneSidePanel::IsActive() const
376{
377 return m_bActive;
378}
380# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
381#endif // #if !defined(__XTPDOCKINGPANESIDEPANEL_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneBaseContainer.h:39
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneBase::OnFocusChanged
virtual void OnFocusChanged()
This method is called to update the state of the pane.
CXTPDockingPaneBase::RemovePane
virtual void RemovePane(CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
CXTPDockingPaneBase::OnChildContainerChanged
virtual void OnChildContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when a child pane collection is changed.
CXTPDockingPaneBase::DeletePane
virtual void DeletePane()=0
This method is called to destroy a pane.
CXTPDockingPaneBase::GetPaneHwnd
virtual HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneBase.h:508
CXTPDockingPaneBase::IsActive
virtual BOOL IsActive() const
Determines if the frame is active.
Definition XTPDockingPaneBase.h:458
CXTPDockingPaneBase::CreateContainer
virtual void CreateContainer()
This member is called to create a pane.
CXTPDockingPaneBase::IsCaptionButtonVisible
virtual BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if a caption button is visible.
Definition XTPDockingPaneBase.h:498
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneSidePanel::Init
BOOL Init(CXTPDockingPaneBase *pPane, XTPDockingPaneDirection direction, CRect rc)
Constructs a CXTPDockingPaneSidePanel object.
CXTPDockingPaneSidePanel::OnPinButtonClick
void OnPinButtonClick()
This member is called when the "pin" caption button is clicked.
CXTPDockingPaneSidePanel::DoPropExchange
virtual BOOL DoPropExchange(CXTPPropExchange *pPX)
This member is called to save/restore the settings of the pane.
CXTPDockingPaneSidePanel::IsCaptionVertical
virtual BOOL IsCaptionVertical() const
Determines if the caption is drawn vertically.
CXTPDockingPaneSidePanel::MovePanel
void MovePanel(XTPDockingPaneDirection direction, CRect rect)
Moves the side panel to the desired location.
CXTPDockingPaneSidePanel::Collapse
void Collapse(BOOL bDelay=FALSE)
This method is called to collapse the frame.
CXTPDockingPaneSidePanel::GetMinMaxInfo
void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of t...
CXTPDockingPaneSidePanel::_InsertPane
void _InsertPane(CXTPDockingPaneBase *pPane)
Call this member to insert a pane into the collection.
CXTPDockingPaneSidePanel::InvalidatePane
virtual void InvalidatePane(BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
CXTPDockingPaneSidePanel::m_bExpanded
BOOL m_bExpanded
Pane is expanded.
Definition XTPDockingPaneSidePanel.h:360
CXTPDockingPaneSidePanel::~CXTPDockingPaneSidePanel
~CXTPDockingPaneSidePanel()
Destroys a CXTPDockingPaneAutoHidePanel object, handles cleanup and deallocation.
CXTPDockingPaneSidePanel::CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel(CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneAutoHidePanel object.
CXTPDockingPaneSidePanel::m_direction
XTPDockingPaneDirection m_direction
Location of side panel.
Definition XTPDockingPaneSidePanel.h:352
CXTPDockingPaneSidePanel::GetDirection
XTPDockingPaneDirection GetDirection() const
Call this member function to determine the direction of the auto-hide panel.
Definition XTPDockingPaneSidePanel.h:371
CXTPDockingPaneSidePanel::Expand
void Expand()
Call this method to expand a collapsed frame.
CXTPDockingPaneSidePanel::m_nSlideStep
int m_nSlideStep
Current step of animation process.
Definition XTPDockingPaneSidePanel.h:356
CXTPDockingPaneSidePanel::GetTitle
CString GetTitle() const
Call this member to get the title of the pane.
CXTPDockingPaneSidePanel::GetPaneHwnd
HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneSidePanel.h:367
CXTPDockingPaneSidePanel::IsHorizontal
BOOL IsHorizontal() const
Call this member to determine if the side panel orientation is horizontal.
CXTPDockingPaneSidePanel::Create
BOOL Create(CRect rc)
Creates a frame window.
CXTPDockingPaneSidePanel::IsActive
BOOL IsActive() const
Call this member function to determine if a child pane is active.
Definition XTPDockingPaneSidePanel.h:375
CXTPDockingPaneSidePanel::m_nDeactivationCount
int m_nDeactivationCount
Deactivation counter.
Definition XTPDockingPaneSidePanel.h:357
CXTPDockingPaneSidePanel::Copy
void Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies a CXTPDockingPaneSidePanel object.
CXTPDockingPaneSidePanel::m_nStepsCount
int m_nStepsCount
Total steps of animation process.
Definition XTPDockingPaneSidePanel.h:355
CXTPDockingPaneSidePanel::GetTopContainer
CXTPDockingPaneTabbedContainer * GetTopContainer() const
Retrieves a CXTPDockingPaneTabbedContainer object that points to the parent container for this contai...
CXTPDockingPaneSidePanel::m_bSlideOut
BOOL m_bSlideOut
Pane is currently expanding.
Definition XTPDockingPaneSidePanel.h:361
CXTPDockingPaneSidePanel::OnToolHitTest
INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPDockingPaneSidePanel::m_bCollapsed
BOOL m_bCollapsed
Pane is collapsed.
Definition XTPDockingPaneSidePanel.h:359
CXTPDockingPaneSidePanel::GetSelectedPane
CXTPDockingPane * GetSelectedPane() const
Call this member to determine the currently selected pane in the side panel.
CXTPDockingPaneSidePanel::IsCollapsed
BOOL IsCollapsed() const
Determines if the frame is collapsed.
CXTPDockingPaneSidePanel::DoSlideStep
void DoSlideStep(BOOL bActivate=FALSE)
This method is called to animate a collapsed frame.
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPShortcutBarVisualStudio2015Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarVisualStudio2015Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARVISUALSTUDIO2015THEME_H__)
24# define __XTPSHORTCUTBARVISUALSTUDIO2015THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarVisualStudio2015Theme : public CXTPShortcutBarOffice2013Theme
39{
40public:
45 CXTPShortcutBarVisualStudio2015Theme();
46
52 virtual ~CXTPShortcutBarVisualStudio2015Theme();
53
61 virtual void RefreshMetrics();
62
84 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
85
86 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
87
94 virtual void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
95
102 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
103
104 void DrawHiliteBorder(CDC* pDC, CRect rc);
105
106protected:
107 BOOL m_bHiliteBorders;
108 CXTPPaintManagerColor m_clrBorderHilite;
109 CXTPPaintManagerColor m_clrBackHiliteSelected;
110};
111
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(__XTPSHORTCUTBARVISUALSTUDIO2015THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Off...
Definition XTPShortcutBarOffice2013Theme.h:39
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPShortcutBarVisualStudio2015Theme
CXTPShortcutBarVisualStudio2015Theme is a CXTPShortcutBarOffice2013Theme derived class that represent...
Definition XTPShortcutBarVisualStudio2015Theme.h:39
CXTPShortcutBarVisualStudio2015Theme::CXTPShortcutBarVisualStudio2015Theme
CXTPShortcutBarVisualStudio2015Theme()
Constructs a CXTPShortcutBarVisualStudio2015Theme object.
CXTPShortcutBarVisualStudio2015Theme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarVisualStudio2015Theme::m_bHiliteBorders
BOOL m_bHiliteBorders
TRUE to draw borders around highlighted items.
Definition XTPShortcutBarVisualStudio2015Theme.h:107
CXTPShortcutBarVisualStudio2015Theme::m_clrBackHiliteSelected
CXTPPaintManagerColor m_clrBackHiliteSelected
Selected highlighted background color.
Definition XTPShortcutBarVisualStudio2015Theme.h:109
CXTPShortcutBarVisualStudio2015Theme::~CXTPShortcutBarVisualStudio2015Theme
virtual ~CXTPShortcutBarVisualStudio2015Theme()
Destroys a CXTPShortcutBarVisualStudio2015Theme object, handles cleanup and deallocation.
CXTPShortcutBarVisualStudio2015Theme::FillShortcutItemEntry
virtual void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarVisualStudio2015Theme::m_clrBorderHilite
CXTPPaintManagerColor m_clrBorderHilite
Highlighted border color.
Definition XTPShortcutBarVisualStudio2015Theme.h:108
CXTPShortcutBarVisualStudio2015Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarVisualStudio2015Theme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.


CXTPComboBoxThemeOffice2003 Member List

This is the complete list of members for CXTPComboBoxThemeOffice2003, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2003 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2003 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2003 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual


Toolkit Pro: XTPTrackControlItem.h Source File

  • Source
  • GridControl
  • TrackControl
XTPTrackControlItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKCONTROLITEM_H__)
24# define __XTPTRACKCONTROLITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTrackControl;
34class CXTPTrackBlock;
35typedef CArray<CXTPTrackBlock*, CXTPTrackBlock*> CXTPTrackBlockArray;
36
44class _XTP_EXT_CLASS CXTPTrackControlItem : public CXTPGridRecordItem
45{
47 DECLARE_SERIAL(CXTPTrackControlItem)
49public:
54 CXTPTrackControlItem();
55
60 virtual ~CXTPTrackControlItem();
61
71 CString GetCaption(CXTPGridColumn* pColumn);
72
73 using CXTPGridRecordItem::GetCaption;
74
102 virtual int Draw(XTP_GRIDRECORDITEM_DRAWARGS* pDrawArgs);
103
112 CXTPTrackBlock* HitTest(CPoint ptPoint);
113
121 BOOL Remove(CXTPTrackBlock* pBlock);
122
130 BOOL RemoveAt(int nIndex);
131
136 void RemoveAll();
137
145 CXTPTrackBlock* Add(CXTPTrackBlock* pBlock);
146
153 CXTPTrackControl* GetTrackControl() const;
154
162 CXTPTrackBlock* GetBlock(int nIndex) const;
163
170 int GetBlockCount() const;
171
182 BOOL IsLocked() const;
183
193 void SetLocked(BOOL bLocked = TRUE);
194
208 virtual BOOL OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
209
210 // virtual BOOL OnRButtonDown(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
211
225 virtual BOOL OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
226
237 virtual void OnClick(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
238
249 virtual void OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS* pClickArgs);
250
260 virtual void OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl* pControl = NULL);
261
268 virtual void DoPropExchange(CXTPPropExchange* pPX);
269
281 INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI);
282
288 void RecalcLayout();
289
297 void AdjustBlockPosition(CXTPTrackBlock* pBlock, BOOL bResize = FALSE);
298
303 void RedrawControl();
304
305protected:
312 virtual void HighlightWorkArea(CDC* pDC, CRect rcItem);
313
314# ifdef _XTP_ACTIVEX
316 DECLARE_DISPATCH_MAP()
317 DECLARE_INTERFACE_MAP()
318
319 LPDISPATCH OleGetBlock(int nIndex);
320 int OleGetBlockCount();
321 LPDISPATCH OleAddBlock(BOOL bKey, int nPosition, int nLength);
322 void OleRemoveBlock(int nIndex);
323
324 BOOL OleGetLocked();
325 void OleSetLocked(BOOL bLocked);
326
327 DECLARE_OLETYPELIB_EX(CXTPTrackControlItem);
329# endif
330
331public:
332 BOOL m_bLocked;
334protected:
335 CXTPTrackBlockArray m_arrBlocks;
337protected:
338 struct DOCK_INFO;
339 class CDockInfoArray;
340
341 friend class CXTPTrackControl;
342};
343
344AFX_INLINE CXTPTrackBlock* CXTPTrackControlItem::GetBlock(int nIndex) const
345{
346 return m_arrBlocks[nIndex];
347}
348
349AFX_INLINE int CXTPTrackControlItem::GetBlockCount() const
350{
351 return (int)m_arrBlocks.GetSize();
352}
353
354AFX_INLINE BOOL CXTPTrackControlItem::IsLocked() const
355{
356 return m_bLocked;
357}
358
359AFX_INLINE void CXTPTrackControlItem::SetLocked(BOOL bLocked)
360{
361 m_bLocked = bLocked;
362}
364# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
365#endif //#if !defined(__XTPTRACKCONTROLITEM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRecordItem::GetCaption
virtual CString GetCaption()
Gets the text caption of the item.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42
CXTPTrackControl
This class represents a track control.
Definition XTPTrackControl.h:113
CXTPTrackControlItem
This class represents a container cell for a set of blocks and keys and inherits basic functionality ...
Definition XTPTrackControlItem.h:45
CXTPTrackControlItem::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to store/load a grid record item using the specified data object.
CXTPTrackControlItem::OnToolHitTest
INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI)
Call this member function to perform a hit test on the track control at a specified point and fill a ...
CXTPTrackControlItem::GetBlock
CXTPTrackBlock * GetBlock(int nIndex) const
Retrieves a specified block.
Definition XTPTrackControlItem.h:344
CXTPTrackControlItem::IsLocked
BOOL IsLocked() const
Gets the locked state of the track control.
Definition XTPTrackControlItem.h:354
CXTPTrackControlItem::HighlightWorkArea
virtual void HighlightWorkArea(CDC *pDC, CRect rcItem)
Highlights the work area.
CXTPTrackControlItem::RedrawControl
void RedrawControl()
Redraws the track control.
CXTPTrackControlItem::SetLocked
void SetLocked(BOOL bLocked=TRUE)
Sets the locked state of the track control.
Definition XTPTrackControlItem.h:359
CXTPTrackControlItem::Remove
BOOL Remove(CXTPTrackBlock *pBlock)
Removes a block.
CXTPTrackControlItem::m_bLocked
BOOL m_bLocked
TRUE if the whole track is locked.
Definition XTPTrackControlItem.h:332
CXTPTrackControlItem::m_arrBlocks
CXTPTrackBlockArray m_arrBlocks
Blocks array.
Definition XTPTrackControlItem.h:335
CXTPTrackControlItem::GetTrackControl
CXTPTrackControl * GetTrackControl() const
Retrieves the track control associated with this item.
CXTPTrackControlItem::RemoveAt
BOOL RemoveAt(int nIndex)
Removes a block.
CXTPTrackControlItem::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL)
Processes the move mouse event.
CXTPTrackControlItem::CXTPTrackControlItem
CXTPTrackControlItem()
Creates a CXTPTrackControlItem item.
CXTPTrackControlItem::GetCaption
CString GetCaption(CXTPGridColumn *pColumn)
Retrieves the text caption of the current item.
CXTPTrackControlItem::OnDblClick
virtual void OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes double mouse clicks.
CXTPTrackControlItem::Add
CXTPTrackBlock * Add(CXTPTrackBlock *pBlock)
Adds a block to the track.
CXTPTrackControlItem::RemoveAll
void RemoveAll()
Removes all blocks.
CXTPTrackControlItem::HitTest
CXTPTrackBlock * HitTest(CPoint ptPoint)
Determines which block, if any, is at a specified point.
CXTPTrackControlItem::GetBlockCount
int GetBlockCount() const
Calculates the number of blocks in the track control.
Definition XTPTrackControlItem.h:349
CXTPTrackControlItem::OnLButtonUp
virtual BOOL OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button up clicks.
CXTPTrackControlItem::Draw
virtual int Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs)
Should be overridden by descendants for drawing itself.
CXTPTrackControlItem::OnLButtonDown
virtual BOOL OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes mouse left button down clicks.
CXTPTrackControlItem::OnClick
virtual void OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs)
Processes single mouse clicks.
CXTPTrackControlItem::RecalcLayout
void RecalcLayout()
Call this method to recalculate the size of the track items when the layout is changed.
CXTPTrackControlItem::~CXTPTrackControlItem
virtual ~CXTPTrackControlItem()
CXTPTrackControlItem default destructor.
CXTPTrackControlItem::AdjustBlockPosition
void AdjustBlockPosition(CXTPTrackBlock *pBlock, BOOL bResize=FALSE)
Adjusts the block position when a block is resized/moved.
XTP_GRIDRECORDITEM_CLICKARGS
A set of parameters transferred to mouse click item handlers.
Definition XTPGridRecordItem.h:149
XTP_GRIDRECORDITEM_DRAWARGS
A set of parameters transferred to the Draw item handler.
Definition XTPGridRecordItem.h:125


Toolkit Pro: XTPDockingPaneTabColorSet2013.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSet2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPDockingPaneTabColorSet2013_H__)
24# define __XTPDockingPaneTabColorSet2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSet2013 : public CXTPTabPaintManagerColorSet
39{
40public:
45 CXTPDockingPaneTabColorSet2013();
46
52 virtual void RefreshMetrics();
53
62 virtual COLORREF GetItemColor(CXTPTabManagerItem* pItem);
63
80 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
81
96 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
97};
98
99# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
101#endif // !defined(__XTPDockingPaneTabColorSet2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2013.h:39
CXTPDockingPaneTabColorSet2013::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSet2013::GetItemColor
virtual COLORREF GetItemColor(CXTPTabManagerItem *pItem)
Call this member function to retrieve the color for the tab specified by pItem.
CXTPDockingPaneTabColorSet2013::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
This member is called to fill the tab navigation buttons.
CXTPDockingPaneTabColorSet2013::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneTabColorSet2013::CXTPDockingPaneTabColorSet2013
CXTPDockingPaneTabColorSet2013()
Default class constructor.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50


CXTPMarkupTransformationMatrix Member List

This is the complete list of members for CXTPMarkupTransformationMatrix, including all inherited members.

Clone() const =0 | CXTPMarkupTransformationMatrix | pure virtual
CXTPMarkupTransformationMatrix() | CXTPMarkupTransformationMatrix | protected
GetBoundRect(const RECT &rect, const POINT &absoluteOffset) const | CXTPMarkupTransformationMatrix | virtual
Offset(const POINT &offset) | CXTPMarkupTransformationMatrix | virtual
PtInRect(const RECT &rect, const POINT &absoluteOffset, const POINT &point) const | CXTPMarkupTransformationMatrix | virtual
~CXTPMarkupTransformationMatrix() | CXTPMarkupTransformationMatrix | virtual


CXTPMessageBarThemeVisualStudio2019 Member List

This is the complete list of members for CXTPMessageBarThemeVisualStudio2019, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2013 |
CXTPMessageBarThemeVisualStudio2019(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeVisualStudio2019 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2013 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2013 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2013 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrButtonBack | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorder | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2013 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2013 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: XTPResizePropertySheet.h Source File

  • Source
  • Controls
  • Resize
XTPResizePropertySheet.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZEPROPERTYSHEET_H__)
24# define __XTPRESIZEPROPERTYSHEET_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPResizePropertySheet
41 : public CPropertySheet
42 , public CXTPResize
43{
45 DECLARE_DYNCREATE(CXTPResizePropertySheet)
47public:
63 CXTPResizePropertySheet();
64
89 CXTPResizePropertySheet(const UINT nCaption, CWnd* pParent = 0, const UINT nSelectPage = 0,
90 const UINT nFlags = 0);
91
117 CXTPResizePropertySheet(LPCTSTR pszCaption, CWnd* pParent = 0, const UINT nSelectPage = 0,
118 const UINT nFlags = 0);
119
120protected:
127 BOOL IsWizard();
128
129protected:
131 DECLARE_MESSAGE_MAP()
132
133 //{{AFX_MSG(CXTPResizePropertySheet)
134 virtual BOOL OnInitDialog();
135 afx_msg void OnSize(UINT nType, int cx, int cy);
136 afx_msg void OnGetMinMaxInfo(MINMAXINFO* lpMMI);
137 afx_msg void OnDestroy();
138 afx_msg BOOL OnPageChanging(NMHDR* pNotifyStruct, LRESULT* pResult);
139 //}}AFX_MSG
142public:
143 CXTPNoFlickerWnd<CTabCtrl> m_tabCtrl;
145 friend class CXTPResizePropertyPage;
146};
147
149
151# ifndef PSH_WIZARD_LITE
152# define PSH_WIZARD_LITE 0x00400000
153# endif // PSH_WIZARD_LITE
154
155AFX_INLINE BOOL CXTPResizePropertySheet::IsWizard()
156{
157 return ((m_psh.dwFlags & (PSH_WIZARD | PSH_WIZARD97 | PSH_WIZARD_LITE)) != 0);
158}
160# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
162#endif // !defined(__XTPRESIZEPROPERTYSHEET_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPResize
CXTPResize is a base class.
Definition XTPResize.h:145
CXTPResizePropertyPage
CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize.
Definition XTPResizePropertyPage.h:43
CXTPResizePropertySheet
CXTPResizePropertySheet is a multiple inheritance class derived from CPropertySheet and CXTPResize.
Definition XTPResizePropertySheet.h:43
CXTPResizePropertySheet::CXTPResizePropertySheet
CXTPResizePropertySheet()
Constructs a CXTPResizePropertySheet object.
CXTPResizePropertySheet::CXTPResizePropertySheet
CXTPResizePropertySheet(const UINT nCaption, CWnd *pParent=0, const UINT nSelectPage=0, const UINT nFlags=0)
Constructs a CXTPResizePropertySheet object.
CXTPResizePropertySheet::IsWizard
BOOL IsWizard()
This member function determines if the property sheet is in wizard mode.
CXTPResizePropertySheet::CXTPResizePropertySheet
CXTPResizePropertySheet(LPCTSTR pszCaption, CWnd *pParent=0, const UINT nSelectPage=0, const UINT nFlags=0)
Constructs a CXTPResizePropertySheet object.


Toolkit Pro: XTPPreviewHostWindow.h Source File

  • Source
  • Controls
  • Preview
XTPPreviewHostWindow.h
Go to the documentation of this file.
1
23#if !defined(__XTPPREVIEWHOSTWINDOW_H__)
24# define __XTPPREVIEWHOSTWINDOW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class CXTPPreviewCtrl;
36struct IXTPPreview;
37
38class _XTP_EXT_CLASS CXTPPreviewHostWindow
39 : public CWnd
40 , public IXTPPreviewHost
41{
42 DECLARE_DYNAMIC(CXTPPreviewHostWindow)
43 friend class CXTPPreviewCtrl;
44
45public:
46 explicit CXTPPreviewHostWindow(CXTPPreviewCtrl* pPreviewCtrl);
47 virtual ~CXTPPreviewHostWindow();
48
49 void ShowMessage(LPCTSTR message);
50
51private:
52 // IXTPPreviewHost implementation
53 virtual COLORREF GetBackgroundColor() const;
54 virtual COLORREF GetForegroundColor() const;
55
56private:
57 void DeletePreview();
58 void SetPreview(IXTPPreview* pPreview);
59
60protected:
61 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
62
63 DECLARE_MESSAGE_MAP()
64 afx_msg void OnPaint();
65 afx_msg void OnDestroy();
66 afx_msg BOOL OnEraseBkgnd(CDC*);
67
68private:
69 CXTPPreviewCtrl* m_pPreviewCtrl;
70 IXTPPreview* m_pPreview;
71 CString m_strMessage;
72};
73
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // #if !defined(__XTPPREVIEWHOSTWINDOW_H__)
XTPDisableNoisyWarnings.h
CXTPPreviewCtrl
Implements the preview control that can display visual preview data provided by the best matching pre...
Definition XTPPreviewCtrl.h:42
IXTPPreviewHost
Interface implemented by the preview host control.
Definition XTPPreviewAbstract.h:152
IXTPPreviewHost::GetBackgroundColor
virtual COLORREF GetBackgroundColor() const =0
Obtains the background color used by the host control.
IXTPPreviewHost::GetForegroundColor
virtual COLORREF GetForegroundColor() const =0
Obtains the foreground color used by the host control.
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40


CXTPFlowGraphSelectedElements Member List

This is the complete list of members for CXTPFlowGraphSelectedElements, including all inherited members.

AddSelection(CXTPFlowGraphElement *pElement) | CXTPFlowGraphSelectedElements |
Clear() | CXTPFlowGraphSelectedElements |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphSelectedElements(CXTPFlowGraphPage *pPage) | CXTPFlowGraphSelectedElements |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPFlowGraphSelectedElements |
GetCount() const | CXTPFlowGraphSelectedElements |
m_arrSelectedElements | CXTPFlowGraphSelectedElements | protected
m_pPage | CXTPFlowGraphSelectedElements | protected
Remove(CXTPFlowGraphElement *pElement) | CXTPFlowGraphSelectedElements |
RemoveAt(int nIndex) | CXTPFlowGraphSelectedElements |
SetSelection(CXTPFlowGraphElement *pElement) | CXTPFlowGraphSelectedElements |
~CXTPFlowGraphSelectedElements() | CXTPFlowGraphSelectedElements | virtual


CXTPGridDataManager Member List

This is the complete list of members for CXTPGridDataManager, including all inherited members.

AddGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset, BOOL bAddNow) | CXTPGridDataManager | virtual
AddRecord(CXTPGridRecord *pRecord, BOOL bAddToGrid) | CXTPGridDataManager | virtual
ClearDeleteGridRecords() | CXTPGridDataManager | virtual
ClearGridControl() | CXTPGridDataManager | protected
CreateColumns() | CXTPGridDataManager | virtual
CreateEmptyRecord(CXTPGridRecord **ppRecord) | CXTPGridDataManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridDataManager(CXTPGridControl *pGridControl) | CXTPGridDataManager |
DataBind() | CXTPGridDataManager | virtual
DeleteGridRecords() | CXTPGridDataManager | virtual
DeleteGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset) | CXTPGridDataManager | virtual
DeleteRecord(CXTPGridRecord *pRecord) | CXTPGridDataManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDataSource() const | CXTPGridDataManager | virtual
GetLastComError() | CXTPGridDataManager | virtual
m_bLocalUpdate | CXTPGridDataManager | protected
m_dwRstEvent | CXTPGridDataManager | protected
m_pConnection | CXTPGridDataManager | protected
m_pDataSource | CXTPGridDataManager | protected
m_pDeleteRecords | CXTPGridDataManager | protected
m_pGridControl | CXTPGridDataManager | protected
m_pRstEvent | CXTPGridDataManager | protected
PrepareDeleteGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset) | CXTPGridDataManager | virtual
RemoveDataSource() | CXTPGridDataManager | protected
SetDataSource(XTPGRIDADODB::_RecordsetPtr pDataSource) | CXTPGridDataManager | virtual
UpdateField(CXTPGridRecordItemVariant *pItem) | CXTPGridDataManager | virtual
UpdateGridRecords(XTPGRIDADODB::_RecordsetPtr pRecordset) | CXTPGridDataManager | virtual
UpdateRecord(CXTPGridRecord *pRecord, CXTPGridRecordItem *pItemChanged=NULL) | CXTPGridDataManager | virtual
~CXTPGridDataManager() | CXTPGridDataManager | virtual


Toolkit Pro: XTPWebBrowserAbstract.h Source File

  • Source
  • Controls
  • WebBrowser
XTPWebBrowserAbstract.h
Go to the documentation of this file.
1
22#if !defined(__XTPWEBBROWSERABSTRACT_H__)
24# define __XTPWEBBROWSERABSTRACT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/XTPMacros.h"
32# include "Controls/WebBrowser/Providers/WebView2/XTPWebView2.h"
33
34# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
35
36class CXTPWebBrowserCtrl;
37
39struct IXTPWebBrowserHost
40{
41 virtual ~IXTPWebBrowserHost()
42 {
43 }
44
45 virtual CWnd& GetHostWindow() const = 0;
46 virtual IUnknown* GetHostUnknown() const = 0;
47 virtual IDispatch* GetExternal() const = 0;
48 virtual const COleVariant* GetProperty(const CString& strName) const = 0;
49
50 virtual void ShellExplorer_OnStatusTextChange(LPCTSTR lpszText) = 0;
51 virtual void ShellExplorer_OnProgressChange(long nProgress, long nProgressMax) = 0;
52 virtual void ShellExplorer_OnCommandStateChange(long nCommand, BOOL bEnable) = 0;
53 virtual void ShellExplorer_OnDownloadBegin() = 0;
54 virtual void ShellExplorer_OnDownloadComplete() = 0;
55 virtual void ShellExplorer_OnTitleChange(LPCTSTR lpszText) = 0;
56 virtual void ShellExplorer_OnPropertyChange(LPCTSTR lpszProperty) = 0;
57 virtual void ShellExplorer_OnNewWindow2(LPDISPATCH* ppDisp, BOOL* pbCancel) = 0;
58 virtual void ShellExplorer_OnQuit() = 0;
59 virtual void ShellExplorer_OnVisible(BOOL bVisible) = 0;
60 virtual void ShellExplorer_OnToolBar(BOOL bToolBar) = 0;
61 virtual void ShellExplorer_OnMenuBar(BOOL bMenuBar) = 0;
62 virtual void ShellExplorer_OnStatusBar(BOOL bStatusBar) = 0;
63 virtual void ShellExplorer_OnFullScreen(BOOL bFullScreen) = 0;
64 virtual void ShellExplorer_OnTheaterMode(BOOL bTheaterMode) = 0;
65 virtual void ShellExplorer_OnNavigateComplete2(LPDISPATCH pDisp, VARIANT* pvtURL) = 0;
66 virtual void ShellExplorer_OnBeforeNavigate2(LPDISPATCH pDisp, VARIANT* pvtURL,
67 VARIANT* pvtFlags, VARIANT* pvtTargetFrameName,
68 VARIANT* pvtPostData, VARIANT* pvtHeaders,
69 BOOL* pbCancel) = 0;
70 virtual void ShellExplorer_OnDocumentComplete(LPDISPATCH pDisp, VARIANT* pvtURL) = 0;
71 virtual void ShellExplorer_OnNavigateError(LPDISPATCH pDisp, VARIANT* pvtURL,
72 VARIANT* pvtTargetFrameName, VARIANT* pvtStatusCode,
73 BOOL* pbCancel) = 0;
74 virtual void ShellExplorer_OnWindowSetResizable(BOOL bResizable) = 0;
75 virtual void ShellExplorer_OnWindowSetLeft(long nLeft) = 0;
76 virtual void ShellExplorer_OnWindowSetTop(long nTop) = 0;
77 virtual void ShellExplorer_OnWindowSetWidth(long nWidth) = 0;
78 virtual void ShellExplorer_OnWindowSetHeight(long nHeight) = 0;
79 virtual void ShellExplorer_OnWindowClosing(BOOL bIsChildWindow, BOOL FAR* pbCancel) = 0;
80 virtual void ShellExplorer_OnSetSecureLockIcon(long nSecureLockIcon) = 0;
81
82 virtual HRESULT WebView2_NavigationStarting(ICoreWebView2NavigationStartingEventArgs* args) = 0;
83 virtual HRESULT WebView2_ContentLoading(ICoreWebView2ContentLoadingEventArgs* args) = 0;
84 virtual HRESULT WebView2_SourceChanged(ICoreWebView2SourceChangedEventArgs* args) = 0;
85 virtual HRESULT WebView2_HistoryChanged(IUnknown* args) = 0;
86 virtual HRESULT
87 WebView2_NavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args) = 0;
88 virtual HRESULT
89 WebView2_FrameNavigationStarting(ICoreWebView2NavigationStartingEventArgs* args) = 0;
90 virtual HRESULT
91 WebView2_FrameNavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args) = 0;
92 virtual HRESULT
93 WebView2_ScriptDialogOpening(ICoreWebView2ScriptDialogOpeningEventArgs* args) = 0;
94 virtual HRESULT
95 WebView2_PermissionRequested(ICoreWebView2PermissionRequestedEventArgs* args) = 0;
96 virtual HRESULT WebView2_ProcessFailed(ICoreWebView2ProcessFailedEventArgs* args) = 0;
97 virtual HRESULT WebView2_NewWindowRequested(ICoreWebView2NewWindowRequestedEventArgs* args) = 0;
98 virtual HRESULT WebView2_DocumentTitleChanged(IUnknown* args) = 0;
99 virtual HRESULT WebView2_ContainsFullScreenElementChanged(IUnknown* args) = 0;
100 virtual HRESULT
101 WebView2_WebResourceRequested(ICoreWebView2WebResourceRequestedEventArgs* args) = 0;
102 virtual HRESULT WebView2_WindowCloseRequested(IUnknown* args) = 0;
103};
111struct IXTPWebBrowserEventSink
112{
117 virtual ~IXTPWebBrowserEventSink()
118 {
119 }
120
128 virtual void ShellExplorer_OnStatusTextChange(CXTPWebBrowserCtrl& sender, LPCTSTR lpszText)
129 {
130 XTP_UNUSED_PARAMETER(sender);
131 XTP_UNUSED_PARAMETER(lpszText);
132 }
133
143 virtual void ShellExplorer_OnProgressChange(CXTPWebBrowserCtrl& sender, long nProgress,
144 long nProgressMax)
145 {
146 XTP_UNUSED_PARAMETER(sender);
147 XTP_UNUSED_PARAMETER(nProgress);
148 XTP_UNUSED_PARAMETER(nProgressMax);
149 }
150
160 virtual void ShellExplorer_OnCommandStateChange(CXTPWebBrowserCtrl& sender, long nCommand,
161 BOOL bEnable)
162 {
163 XTP_UNUSED_PARAMETER(sender);
164 XTP_UNUSED_PARAMETER(nCommand);
165 XTP_UNUSED_PARAMETER(bEnable);
166 }
167
174 virtual void ShellExplorer_OnDownloadBegin(CXTPWebBrowserCtrl& sender)
175 {
176 XTP_UNUSED_PARAMETER(sender);
177 }
178
185 virtual void ShellExplorer_OnDownloadComplete(CXTPWebBrowserCtrl& sender)
186 {
187 XTP_UNUSED_PARAMETER(sender);
188 }
189
197 virtual void ShellExplorer_OnTitleChange(CXTPWebBrowserCtrl& sender, LPCTSTR lpszText)
198 {
199 XTP_UNUSED_PARAMETER(sender);
200 XTP_UNUSED_PARAMETER(lpszText);
201 }
202
210 virtual void ShellExplorer_OnPropertyChange(CXTPWebBrowserCtrl& sender, LPCTSTR lpszProperty)
211 {
212 XTP_UNUSED_PARAMETER(sender);
213 XTP_UNUSED_PARAMETER(lpszProperty);
214 }
215
225 virtual void ShellExplorer_OnNewWindow2(CXTPWebBrowserCtrl& sender, LPDISPATCH* ppDisp,
226 BOOL* pbCancel)
227 {
228 XTP_UNUSED_PARAMETER(sender);
229 XTP_UNUSED_PARAMETER(ppDisp);
230 XTP_UNUSED_PARAMETER(pbCancel);
231 }
232
239 virtual void ShellExplorer_OnQuit(CXTPWebBrowserCtrl& sender)
240 {
241 XTP_UNUSED_PARAMETER(sender);
242 }
243
251 virtual void ShellExplorer_OnVisible(CXTPWebBrowserCtrl& sender, BOOL bVisible)
252 {
253 XTP_UNUSED_PARAMETER(sender);
254 XTP_UNUSED_PARAMETER(bVisible);
255 }
256
264 virtual void ShellExplorer_OnToolBar(CXTPWebBrowserCtrl& sender, BOOL bToolBar)
265 {
266 XTP_UNUSED_PARAMETER(sender);
267 XTP_UNUSED_PARAMETER(bToolBar);
268 }
269
277 virtual void ShellExplorer_OnMenuBar(CXTPWebBrowserCtrl& sender, BOOL bMenuBar)
278 {
279 XTP_UNUSED_PARAMETER(sender);
280 XTP_UNUSED_PARAMETER(bMenuBar);
281 }
282
290 virtual void ShellExplorer_OnStatusBar(CXTPWebBrowserCtrl& sender, BOOL bStatusBar)
291 {
292 XTP_UNUSED_PARAMETER(sender);
293 XTP_UNUSED_PARAMETER(bStatusBar);
294 }
295
303 virtual void ShellExplorer_OnFullScreen(CXTPWebBrowserCtrl& sender, BOOL bFullScreen)
304 {
305 XTP_UNUSED_PARAMETER(sender);
306 XTP_UNUSED_PARAMETER(bFullScreen);
307 }
308
316 virtual void ShellExplorer_OnTheaterMode(CXTPWebBrowserCtrl& sender, BOOL bTheaterMode)
317 {
318 XTP_UNUSED_PARAMETER(sender);
319 XTP_UNUSED_PARAMETER(bTheaterMode);
320 }
321
339 virtual void ShellExplorer_OnNavigateComplete2(CXTPWebBrowserCtrl& sender, LPDISPATCH pDisp,
340 VARIANT* pvtURL)
341 {
342 XTP_UNUSED_PARAMETER(sender);
343 XTP_UNUSED_PARAMETER(pDisp);
344 XTP_UNUSED_PARAMETER(pvtURL);
345 }
346
374 virtual void ShellExplorer_OnBeforeNavigate2(CXTPWebBrowserCtrl& sender, LPDISPATCH pDisp,
375 VARIANT* pvtURL, VARIANT* pvtFlags,
376 VARIANT* pvtTargetFrameName, VARIANT* pvtPostData,
377 VARIANT* pvtHeaders, BOOL* pbCancel)
378 {
379 XTP_UNUSED_PARAMETER(sender);
380 XTP_UNUSED_PARAMETER(pDisp);
381 XTP_UNUSED_PARAMETER(pvtURL);
382 XTP_UNUSED_PARAMETER(pvtFlags);
383 XTP_UNUSED_PARAMETER(pvtTargetFrameName);
384 XTP_UNUSED_PARAMETER(pvtPostData);
385 XTP_UNUSED_PARAMETER(pvtHeaders);
386 XTP_UNUSED_PARAMETER(pbCancel);
387 }
388
400 virtual void ShellExplorer_OnDocumentComplete(CXTPWebBrowserCtrl& sender, LPDISPATCH pDisp,
401 VARIANT* pvtURL)
402 {
403 XTP_UNUSED_PARAMETER(sender);
404 XTP_UNUSED_PARAMETER(pDisp);
405 XTP_UNUSED_PARAMETER(pvtURL);
406 }
407
427 virtual void ShellExplorer_OnNavigateError(CXTPWebBrowserCtrl& sender, LPDISPATCH pDisp,
428 VARIANT* pvtURL, VARIANT* pvtTargetFrameName,
429 VARIANT* pvtStatusCode, BOOL* pbCancel)
430 {
431 XTP_UNUSED_PARAMETER(sender);
432 XTP_UNUSED_PARAMETER(pDisp);
433 XTP_UNUSED_PARAMETER(pvtURL);
434 XTP_UNUSED_PARAMETER(pvtTargetFrameName);
435 XTP_UNUSED_PARAMETER(pvtStatusCode);
436 XTP_UNUSED_PARAMETER(pbCancel);
437 }
438
446 virtual void ShellExplorer_OnWindowSetResizable(CXTPWebBrowserCtrl& sender, BOOL bResizable)
447 {
448 XTP_UNUSED_PARAMETER(sender);
449 XTP_UNUSED_PARAMETER(bResizable);
450 }
451
459 virtual void ShellExplorer_OnWindowSetLeft(CXTPWebBrowserCtrl& sender, long nLeft)
460 {
461 XTP_UNUSED_PARAMETER(sender);
462 XTP_UNUSED_PARAMETER(nLeft);
463 }
464
472 virtual void ShellExplorer_OnWindowSetTop(CXTPWebBrowserCtrl& sender, long nTop)
473 {
474 XTP_UNUSED_PARAMETER(sender);
475 XTP_UNUSED_PARAMETER(nTop);
476 }
477
485 virtual void ShellExplorer_OnWindowSetWidth(CXTPWebBrowserCtrl& sender, long nWidth)
486 {
487 XTP_UNUSED_PARAMETER(sender);
488 XTP_UNUSED_PARAMETER(nWidth);
489 }
490
498 virtual void ShellExplorer_OnWindowSetHeight(CXTPWebBrowserCtrl& sender, long nHeight)
499 {
500 XTP_UNUSED_PARAMETER(sender);
501 XTP_UNUSED_PARAMETER(nHeight);
502 }
503
512 virtual void ShellExplorer_OnWindowClosing(CXTPWebBrowserCtrl& sender, BOOL bIsChildWindow,
513 BOOL FAR* pbCancel)
514 {
515 XTP_UNUSED_PARAMETER(sender);
516 XTP_UNUSED_PARAMETER(bIsChildWindow);
517 XTP_UNUSED_PARAMETER(pbCancel);
518 }
519
527 virtual void ShellExplorer_OnSetSecureLockIcon(CXTPWebBrowserCtrl& sender, long nSecureLockIcon)
528 {
529 XTP_UNUSED_PARAMETER(sender);
530 XTP_UNUSED_PARAMETER(nSecureLockIcon);
531 }
532
540 virtual HRESULT WebView2_NavigationStarting(CXTPWebBrowserCtrl& sender,
541 ICoreWebView2NavigationStartingEventArgs* args)
542 {
543 XTP_UNUSED_PARAMETER(sender);
544 XTP_UNUSED_PARAMETER(args);
545 return S_OK;
546 }
547
555 virtual HRESULT WebView2_ContentLoading(CXTPWebBrowserCtrl& sender,
556 ICoreWebView2ContentLoadingEventArgs* args)
557 {
558 XTP_UNUSED_PARAMETER(sender);
559 XTP_UNUSED_PARAMETER(args);
560 return S_OK;
561 }
562
570 virtual HRESULT WebView2_SourceChanged(CXTPWebBrowserCtrl& sender,
571 ICoreWebView2SourceChangedEventArgs* args)
572 {
573 XTP_UNUSED_PARAMETER(sender);
574 XTP_UNUSED_PARAMETER(args);
575 return S_OK;
576 }
577
585 virtual HRESULT WebView2_HistoryChanged(CXTPWebBrowserCtrl& sender, IUnknown* args)
586 {
587 XTP_UNUSED_PARAMETER(sender);
588 XTP_UNUSED_PARAMETER(args);
589 return S_OK;
590 }
591
599 virtual HRESULT WebView2_NavigationCompleted(CXTPWebBrowserCtrl& sender,
600 ICoreWebView2NavigationCompletedEventArgs* args)
601 {
602 XTP_UNUSED_PARAMETER(sender);
603 XTP_UNUSED_PARAMETER(args);
604 return S_OK;
605 }
606
614 virtual HRESULT WebView2_FrameNavigationStarting(CXTPWebBrowserCtrl& sender,
615 ICoreWebView2NavigationStartingEventArgs* args)
616 {
617 XTP_UNUSED_PARAMETER(sender);
618 XTP_UNUSED_PARAMETER(args);
619 return S_OK;
620 }
621
629 virtual HRESULT WebView2_FrameNavigationCompleted(
630 CXTPWebBrowserCtrl& sender, ICoreWebView2NavigationCompletedEventArgs* args)
631 {
632 XTP_UNUSED_PARAMETER(sender);
633 XTP_UNUSED_PARAMETER(args);
634 return S_OK;
635 }
636
644 virtual HRESULT WebView2_ScriptDialogOpening(CXTPWebBrowserCtrl& sender,
645 ICoreWebView2ScriptDialogOpeningEventArgs* args)
646 {
647 XTP_UNUSED_PARAMETER(sender);
648 XTP_UNUSED_PARAMETER(args);
649 return S_OK;
650 }
651
659 virtual HRESULT WebView2_PermissionRequested(CXTPWebBrowserCtrl& sender,
660 ICoreWebView2PermissionRequestedEventArgs* args)
661 {
662 XTP_UNUSED_PARAMETER(sender);
663 XTP_UNUSED_PARAMETER(args);
664 return S_OK;
665 }
666
674 virtual HRESULT WebView2_ProcessFailed(CXTPWebBrowserCtrl& sender,
675 ICoreWebView2ProcessFailedEventArgs* args)
676 {
677 XTP_UNUSED_PARAMETER(sender);
678 XTP_UNUSED_PARAMETER(args);
679 return S_OK;
680 }
681
689 virtual HRESULT WebView2_NewWindowRequested(CXTPWebBrowserCtrl& sender,
690 ICoreWebView2NewWindowRequestedEventArgs* args)
691 {
692 XTP_UNUSED_PARAMETER(sender);
693 XTP_UNUSED_PARAMETER(args);
694 return S_OK;
695 }
696
704 virtual HRESULT WebView2_DocumentTitleChanged(CXTPWebBrowserCtrl& sender, IUnknown* args)
705 {
706 XTP_UNUSED_PARAMETER(sender);
707 XTP_UNUSED_PARAMETER(args);
708 return S_OK;
709 }
710
719 virtual HRESULT WebView2_ContainsFullScreenElementChanged(CXTPWebBrowserCtrl& sender,
720 IUnknown* args)
721 {
722 XTP_UNUSED_PARAMETER(sender);
723 XTP_UNUSED_PARAMETER(args);
724 return S_OK;
725 }
726
734 virtual HRESULT WebView2_WebResourceRequested(CXTPWebBrowserCtrl& sender,
735 ICoreWebView2WebResourceRequestedEventArgs* args)
736 {
737 XTP_UNUSED_PARAMETER(sender);
738 XTP_UNUSED_PARAMETER(args);
739 return S_OK;
740 }
741
749 virtual HRESULT WebView2_WindowCloseRequested(CXTPWebBrowserCtrl& sender, IUnknown* args)
750 {
751 XTP_UNUSED_PARAMETER(sender);
752 XTP_UNUSED_PARAMETER(args);
753 return S_OK;
754 }
755};
756
757# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
759#endif // #if !defined(__XTPWEBBROWSERABSTRACT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPMacros.h
XTP_UNUSED_PARAMETER
#define XTP_UNUSED_PARAMETER(name)
The macro should be used instead of UNUSED and UNREFERENCED_PARAMETER in order to address cross versi...
Definition XTPMacros.h:957
XTPWebView2.h
CXTPWebBrowserCtrl
Implements the WebBrowser control that is capable of hosting different supported Web browsers.
Definition XTPWebBrowserCtrl.h:66
IXTPWebBrowserEventSink
Describes default WebBrowser control event sink interface and providers default implementation of the...
Definition XTPWebBrowserAbstract.h:112
IXTPWebBrowserEventSink::WebView2_FrameNavigationCompleted
virtual HRESULT WebView2_FrameNavigationCompleted(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationCompletedEventArgs *args)
Handles FrameNavigationCompleted event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:629
IXTPWebBrowserEventSink::WebView2_FrameNavigationStarting
virtual HRESULT WebView2_FrameNavigationStarting(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationStartingEventArgs *args)
Handles FrameNavigationStarting event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:614
IXTPWebBrowserEventSink::WebView2_DocumentTitleChanged
virtual HRESULT WebView2_DocumentTitleChanged(CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles DocumentTitleChanged event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:704
IXTPWebBrowserEventSink::ShellExplorer_OnNavigateError
virtual void ShellExplorer_OnNavigateError(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL, VARIANT *pvtTargetFrameName, VARIANT *pvtStatusCode, BOOL *pbCancel)
Handles NavigateError event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:427
IXTPWebBrowserEventSink::ShellExplorer_OnWindowSetResizable
virtual void ShellExplorer_OnWindowSetResizable(CXTPWebBrowserCtrl &sender, BOOL bResizable)
Handles WindowSetResizable event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:446
IXTPWebBrowserEventSink::ShellExplorer_OnMenuBar
virtual void ShellExplorer_OnMenuBar(CXTPWebBrowserCtrl &sender, BOOL bMenuBar)
Handles OnMenuBar event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:277
IXTPWebBrowserEventSink::ShellExplorer_OnVisible
virtual void ShellExplorer_OnVisible(CXTPWebBrowserCtrl &sender, BOOL bVisible)
Handles OnVisible event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:251
IXTPWebBrowserEventSink::ShellExplorer_OnWindowSetLeft
virtual void ShellExplorer_OnWindowSetLeft(CXTPWebBrowserCtrl &sender, long nLeft)
Handles WindowSetLeft event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:459
IXTPWebBrowserEventSink::ShellExplorer_OnStatusTextChange
virtual void ShellExplorer_OnStatusTextChange(CXTPWebBrowserCtrl &sender, LPCTSTR lpszText)
Handles StatusTextChange event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:128
IXTPWebBrowserEventSink::ShellExplorer_OnWindowClosing
virtual void ShellExplorer_OnWindowClosing(CXTPWebBrowserCtrl &sender, BOOL bIsChildWindow, BOOL FAR *pbCancel)
Handles WindowClosing event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:512
IXTPWebBrowserEventSink::WebView2_NavigationCompleted
virtual HRESULT WebView2_NavigationCompleted(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationCompletedEventArgs *args)
Handles NavigationCompleted event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:599
IXTPWebBrowserEventSink::ShellExplorer_OnTitleChange
virtual void ShellExplorer_OnTitleChange(CXTPWebBrowserCtrl &sender, LPCTSTR lpszText)
Handles TitleChange event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:197
IXTPWebBrowserEventSink::ShellExplorer_OnWindowSetTop
virtual void ShellExplorer_OnWindowSetTop(CXTPWebBrowserCtrl &sender, long nTop)
Handles WindowSetTop event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:472
IXTPWebBrowserEventSink::WebView2_NewWindowRequested
virtual HRESULT WebView2_NewWindowRequested(CXTPWebBrowserCtrl &sender, ICoreWebView2NewWindowRequestedEventArgs *args)
Handles NewWindowRequested event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:689
IXTPWebBrowserEventSink::WebView2_ContainsFullScreenElementChanged
virtual HRESULT WebView2_ContainsFullScreenElementChanged(CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles ContainsFullScreenElementChanged event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:719
IXTPWebBrowserEventSink::WebView2_ContentLoading
virtual HRESULT WebView2_ContentLoading(CXTPWebBrowserCtrl &sender, ICoreWebView2ContentLoadingEventArgs *args)
Handles ContentLoading event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:555
IXTPWebBrowserEventSink::ShellExplorer_OnToolBar
virtual void ShellExplorer_OnToolBar(CXTPWebBrowserCtrl &sender, BOOL bToolBar)
Handles OnToolBar event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:264
IXTPWebBrowserEventSink::WebView2_ProcessFailed
virtual HRESULT WebView2_ProcessFailed(CXTPWebBrowserCtrl &sender, ICoreWebView2ProcessFailedEventArgs *args)
Handles ProcessFailed event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:674
IXTPWebBrowserEventSink::ShellExplorer_OnStatusBar
virtual void ShellExplorer_OnStatusBar(CXTPWebBrowserCtrl &sender, BOOL bStatusBar)
Handles OnStatusBar event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:290
IXTPWebBrowserEventSink::ShellExplorer_OnWindowSetHeight
virtual void ShellExplorer_OnWindowSetHeight(CXTPWebBrowserCtrl &sender, long nHeight)
Handles WindowSetHeight event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:498
IXTPWebBrowserEventSink::~IXTPWebBrowserEventSink
virtual ~IXTPWebBrowserEventSink()
Handles event sink destruction.
Definition XTPWebBrowserAbstract.h:117
IXTPWebBrowserEventSink::ShellExplorer_OnSetSecureLockIcon
virtual void ShellExplorer_OnSetSecureLockIcon(CXTPWebBrowserCtrl &sender, long nSecureLockIcon)
Handles SetSecureLockIcon event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:527
IXTPWebBrowserEventSink::WebView2_HistoryChanged
virtual HRESULT WebView2_HistoryChanged(CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles HistoryChanged event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:585
IXTPWebBrowserEventSink::WebView2_WindowCloseRequested
virtual HRESULT WebView2_WindowCloseRequested(CXTPWebBrowserCtrl &sender, IUnknown *args)
Handles WindowCloseRequested event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:749
IXTPWebBrowserEventSink::ShellExplorer_OnBeforeNavigate2
virtual void ShellExplorer_OnBeforeNavigate2(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL, VARIANT *pvtFlags, VARIANT *pvtTargetFrameName, VARIANT *pvtPostData, VARIANT *pvtHeaders, BOOL *pbCancel)
Handles BeforeNavigate2 event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:374
IXTPWebBrowserEventSink::ShellExplorer_OnCommandStateChange
virtual void ShellExplorer_OnCommandStateChange(CXTPWebBrowserCtrl &sender, long nCommand, BOOL bEnable)
Handles CommandStateChange event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:160
IXTPWebBrowserEventSink::WebView2_ScriptDialogOpening
virtual HRESULT WebView2_ScriptDialogOpening(CXTPWebBrowserCtrl &sender, ICoreWebView2ScriptDialogOpeningEventArgs *args)
Handles ScriptDialogOpening event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:644
IXTPWebBrowserEventSink::ShellExplorer_OnFullScreen
virtual void ShellExplorer_OnFullScreen(CXTPWebBrowserCtrl &sender, BOOL bFullScreen)
Handles OnFullScreen event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:303
IXTPWebBrowserEventSink::ShellExplorer_OnProgressChange
virtual void ShellExplorer_OnProgressChange(CXTPWebBrowserCtrl &sender, long nProgress, long nProgressMax)
Handles ProgressChange event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:143
IXTPWebBrowserEventSink::ShellExplorer_OnDocumentComplete
virtual void ShellExplorer_OnDocumentComplete(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL)
Handles DocumentComplete event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:400
IXTPWebBrowserEventSink::ShellExplorer_OnNewWindow2
virtual void ShellExplorer_OnNewWindow2(CXTPWebBrowserCtrl &sender, LPDISPATCH *ppDisp, BOOL *pbCancel)
Handles NewWindow2 event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:225
IXTPWebBrowserEventSink::ShellExplorer_OnQuit
virtual void ShellExplorer_OnQuit(CXTPWebBrowserCtrl &sender)
Handles OnQuit event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:239
IXTPWebBrowserEventSink::WebView2_SourceChanged
virtual HRESULT WebView2_SourceChanged(CXTPWebBrowserCtrl &sender, ICoreWebView2SourceChangedEventArgs *args)
Handles SourceChanged event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:570
IXTPWebBrowserEventSink::ShellExplorer_OnDownloadBegin
virtual void ShellExplorer_OnDownloadBegin(CXTPWebBrowserCtrl &sender)
Handles DownloadBegin event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:174
IXTPWebBrowserEventSink::WebView2_NavigationStarting
virtual HRESULT WebView2_NavigationStarting(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationStartingEventArgs *args)
Handles NavigationStarting event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:540
IXTPWebBrowserEventSink::ShellExplorer_OnNavigateComplete2
virtual void ShellExplorer_OnNavigateComplete2(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL)
Handles NavigateComplete2 event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:339
IXTPWebBrowserEventSink::ShellExplorer_OnPropertyChange
virtual void ShellExplorer_OnPropertyChange(CXTPWebBrowserCtrl &sender, LPCTSTR lpszProperty)
Handles PropertyChange event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:210
IXTPWebBrowserEventSink::ShellExplorer_OnTheaterMode
virtual void ShellExplorer_OnTheaterMode(CXTPWebBrowserCtrl &sender, BOOL bTheaterMode)
Handles OnTheaterMode event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:316
IXTPWebBrowserEventSink::ShellExplorer_OnWindowSetWidth
virtual void ShellExplorer_OnWindowSetWidth(CXTPWebBrowserCtrl &sender, long nWidth)
Handles WindowSetWidth event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:485
IXTPWebBrowserEventSink::WebView2_WebResourceRequested
virtual HRESULT WebView2_WebResourceRequested(CXTPWebBrowserCtrl &sender, ICoreWebView2WebResourceRequestedEventArgs *args)
Handles WebResourceRequested event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:734
IXTPWebBrowserEventSink::WebView2_PermissionRequested
virtual HRESULT WebView2_PermissionRequested(CXTPWebBrowserCtrl &sender, ICoreWebView2PermissionRequestedEventArgs *args)
Handles PermissionRequested event for the WebView2 WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:659
IXTPWebBrowserEventSink::ShellExplorer_OnDownloadComplete
virtual void ShellExplorer_OnDownloadComplete(CXTPWebBrowserCtrl &sender)
Handles DownloadComplete event for the ShellExplorer WebBrowser provider type.
Definition XTPWebBrowserAbstract.h:185


CXTPColorSelectorCtrlThemeOffice2013 Member List

This is the complete list of members for CXTPColorSelectorCtrlThemeOffice2013, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPColorSelectorCtrlThemeOffice2013() | CXTPColorSelectorCtrlThemeOffice2013 |
CXTPControlTheme() | CXTPControlTheme |
DrawBorder(CDC *pDC, CRect rcItem, CRect rcBorder, COLORREF crBorder) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColor(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, CRect rcItem, BOOL bChecked, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderInside | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_crTitleBack | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_crTitleText | CXTPColorSelectorCtrlThemeOffice2013 | protected
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


XTP_GRIDRECORDITEM_DRAWARGS Member List

This is the complete list of members for XTP_GRIDRECORDITEM_DRAWARGS, including all inherited members.

nTextAlign | XTP_GRIDRECORDITEM_DRAWARGS
pColumn | XTP_GRIDRECORDITEM_ARGS
pControl | XTP_GRIDRECORDITEM_ARGS
pDC | XTP_GRIDRECORDITEM_DRAWARGS
pItem | XTP_GRIDRECORDITEM_ARGS
pRow | XTP_GRIDRECORDITEM_ARGS
rcItem | XTP_GRIDRECORDITEM_ARGS


Toolkit Pro: XTPChart3dPyramidSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
XTPChart3dPyramidSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYRAMIDSERIESSTYLE_H__)
24# define __XTPCHART3DPYRAMIDSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
48class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesStyle : public CXTPChartPyramidSeriesStyleBase
49{
50 DECLARE_SERIAL(CXTPChart3dPyramidSeriesStyle);
51
52public:
57 CXTPChart3dPyramidSeriesStyle();
58
66 virtual CXTPChartDiagram* CreateDiagram();
67
78 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
79 CXTPChartDiagramView* pDiagramView);
80
91 virtual BOOL IsStyleDiagram(CXTPChartDiagram* pDiagram) const;
92
104 virtual void DoPropExchange(CXTPPropExchange* pPX);
105
115 int GetBaseEdgeCount() const;
116
125 void SetBaseEdgeCount(int nEdgeCount);
126
129 _XTP_DEPRECATED_IN_FAVOR(Is3dEdgeSmoothingEnabled)
130 BOOL IsEdgeSmoothingEnabled() const
131 {
132 return Is3dEdgeSmoothingEnabled();
133 }
134
135 _XTP_DEPRECATED_IN_FAVOR(Enable3dEdgeSmoothing)
136 void EnableEdgeSmoothing(BOOL bEnable = TRUE)
137 {
138 Enable3dEdgeSmoothing(bEnable);
139 }
140
141# ifdef _XTP_ACTIVEX
142public:
143 DECLARE_DISPATCH_MAP()
144 DECLARE_INTERFACE_MAP()
145 DECLARE_OLETYPELIB_EX(CXTPChart3dPyramidSeriesStyle);
146 DECLARE_OLECREATE_EX(CXTPChart3dPyramidSeriesStyle)
147# endif
150private:
151 int m_nBaseEdgeCount;
152};
153
154AFX_INLINE int CXTPChart3dPyramidSeriesStyle::GetBaseEdgeCount() const
155{
156 return m_nBaseEdgeCount;
157}
159# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
160#endif //#if !defined(__XTPCHART3DPYRAMIDSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPyramidSeriesStyle
This class abstracts the basic style of a pyramid series.
Definition XTPChart3dPyramidSeriesStyle.h:49
CXTPChart3dPyramidSeriesStyle::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load an event using the specified data object.
CXTPChart3dPyramidSeriesStyle::IsStyleDiagram
virtual BOOL IsStyleDiagram(CXTPChartDiagram *pDiagram) const
Call this function to check whether a chart diagram object passed is a kind of CXTPChart3dPyramidDiag...
CXTPChart3dPyramidSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pyramid series.
CXTPChart3dPyramidSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Call this function to create the pyramid diagram object.
CXTPChart3dPyramidSeriesStyle::CXTPChart3dPyramidSeriesStyle
CXTPChart3dPyramidSeriesStyle()
Constructs a CXTPChart3dPyramidSeriesStyle object.
CXTPChart3dPyramidSeriesStyle::SetBaseEdgeCount
void SetBaseEdgeCount(int nEdgeCount)
Sets the number of base edges for the pyramid.
CXTPChart3dPyramidSeriesStyle::GetBaseEdgeCount
int GetBaseEdgeCount() const
Gets the number of base edges for the pyramid.
Definition XTPChart3dPyramidSeriesStyle.h:154
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartPyramidSeriesStyleBase
This class abstracts the basic style of a pyramid series.
Definition XTPChartPyramidSeriesStyleBase.h:45
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesStyle::Enable3dEdgeSmoothing
virtual void Enable3dEdgeSmoothing(BOOL bEnable=TRUE)
Enables/disables 3D edge smoothing.
Definition XTPChartSeriesStyle.h:394
CXTPChartSeriesStyle::Is3dEdgeSmoothingEnabled
virtual BOOL Is3dEdgeSmoothingEnabled() const
Enables/disables 3D edge smoothing.
Definition XTPChartSeriesStyle.h:389
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPSmartPtrInternalT< _TObject > Member List

This is the complete list of members for CXTPSmartPtrInternalT< _TObject >, including all inherited members.

CXTPSmartPtrInternalT(_TObject *pObject=NULL, BOOL bCallInternalAddRef=FALSE) | CXTPSmartPtrInternalT< _TObject > | inline
CXTPSmartPtrInternalT(const Tthis &rSrc) | CXTPSmartPtrInternalT< _TObject > | inline
Detach() | CXTPSmartPtrInternalT< _TObject > | inline
GetInterface(BOOL bWithAddRef=TRUE) | CXTPSmartPtrInternalT< _TObject > | inline
m_pObject | CXTPSmartPtrInternalT< _TObject > | protected
operator _TObject *() const | CXTPSmartPtrInternalT< _TObject > | inline
operator bool() const | CXTPSmartPtrInternalT< _TObject > | inline
operator!() const | CXTPSmartPtrInternalT< _TObject > | inline
operator!=(const Tthis &ptr2) const | CXTPSmartPtrInternalT< _TObject > | inline
operator*() const | CXTPSmartPtrInternalT< _TObject > | inline
operator->() const | CXTPSmartPtrInternalT< _TObject > | inline
operator=(_TObject *pNewObj) | CXTPSmartPtrInternalT< _TObject > | inline
operator=(const Tthis &rSrc) | CXTPSmartPtrInternalT< _TObject > | inline
operator==(const Tthis &ptr2) const | CXTPSmartPtrInternalT< _TObject > | inline
SetPtr(_TObject *pObject, BOOL bCallInternalAddRef=FALSE) | CXTPSmartPtrInternalT< _TObject > | inline
Tthis typedef | CXTPSmartPtrInternalT< _TObject > | protected
~CXTPSmartPtrInternalT() | CXTPSmartPtrInternalT< _TObject > | inlinevirtual


Toolkit Pro: XTPImageEditor.h Source File

  • Source
  • CommandBars
XTPImageEditor.h
Go to the documentation of this file.
1
23#if !defined(__XTP_IMAGEEDITORDLG_H__)
24# define __XTP_IMAGEEDITORDLG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPImageManagerIconHandle;
34class CXTPImageEditorDlg;
35
38enum XTPImageEditorTools
39{
40 xtpToolPencil,
41 xtpToolFill,
42 xtpToolGetColor,
43 xtpToolLine,
44 xtpToolRectangle,
45 xtpToolCircle
46};
47
48# define XTPCOLOR_ERASE (0xFFFEFF)
49
54class _XTP_EXT_CLASS CXTPImageEditorPicker : public CStatic
55{
56 DECLARE_DYNAMIC(CXTPImageEditorPicker)
57
58public:
59 CXTPImageEditorPicker();
60
61public:
62 void SetColor(COLORREF clr);
63 COLORREF GetColor();
64 void SetSelected(BOOL bSelected = TRUE);
65
66protected:
67 DECLARE_MESSAGE_MAP()
68
69 afx_msg void OnPaint();
70 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
71
72private:
73 COLORREF m_clr;
74 BOOL m_bSelected;
75};
76
81class _XTP_EXT_CLASS CXTPImageEditorPicture : public CStatic
82{
83public:
84 class CAlphaBitmap : public CBitmap
85 {
86 public:
87 CAlphaBitmap(BOOL bAlpha = FALSE)
88 {
89 m_bAlpha = bAlpha;
90 }
91
92 public:
93 void CreateEditorBitmap(int nWidth, int nHeight);
94
95 public:
96 BOOL m_bAlpha;
97 };
98
99public:
100 CXTPImageEditorPicture();
101 ~CXTPImageEditorPicture();
102
103public:
104 void Apply();
105 void Init(UINT nID, CXTPImageEditorDlg* pParentWnd);
106 XTPImageEditorTools GetSelectedTool();
107 COLORREF GetSelectedColor();
108 CPoint ClientToPicture(CPoint pt);
109 static void AFX_CDECL CopyBitmap(CAlphaBitmap* pBitmapCopyTo, CAlphaBitmap* pBitmapCopyFrom,
110 CSize sz, CPoint ptOffset = 0,
111 COLORREF clrTransparentFrom = XTPCOLOR_ERASE,
112 COLORREF clrTransparentTo = XTPCOLOR_ERASE, CDC* pDC = 0);
113 COLORREF GetPicturePixel(CPoint point);
114 void FixAlphaLayer(CAlphaBitmap* pBitmap, CAlphaBitmap* pPictureBitmap);
115 void Undo();
116 void Redo();
117 void Clear();
118 void Copy();
119 void Paste();
120 void Load();
121 void MovePicture(CPoint ptOffset);
122 void OnPictureChanged();
123
124protected:
125 DECLARE_MESSAGE_MAP()
126
127 afx_msg void OnPaint();
128 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
129 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
130 afx_msg void OnCaptureChanged(CWnd* pWnd);
131 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
132 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
133
134public:
135 CSize m_szPicture;
136 CSize m_szItem;
137 CXTPImageEditorDlg* m_pParentWnd;
138
139 CDC m_dcPicture;
140
141 CAlphaBitmap* m_pCurrentBitmap;
142 CAlphaBitmap* m_pPictureBitmap;
143
144 CList<CAlphaBitmap*, CAlphaBitmap*> m_lstUndo;
145 CList<CAlphaBitmap*, CAlphaBitmap*> m_lstRedo;
146 CPoint m_ptTracked;
147 BOOL m_bTracked;
148 COLORREF m_clrDraw;
149
150 HCURSOR m_hCursorLine;
151 HCURSOR m_hCursorFillColor;
152 HCURSOR m_hCursorPencil;
153 HCURSOR m_hCursorPickColor;
154};
155
160class _XTP_EXT_CLASS CXTPImageEditorPreview : public CStatic
161{
162public:
163 CXTPImageEditorPreview();
164
165public:
166 void Init(UINT nID, CXTPImageEditorDlg* pParentWnd);
167
168protected:
169 DECLARE_MESSAGE_MAP()
170 afx_msg void OnPaint();
171
172protected:
173 CXTPImageEditorDlg* m_pParentWnd;
174 CSize m_szPicture;
175};
176
184class _XTP_EXT_CLASS CXTPImageEditorDlg : public CDialog
185{
186private:
191 class CDlgToolBar : public CXTPToolBar
192 {
193 public:
194 CDlgToolBar();
195 };
196
197public:
204 CXTPImageEditorDlg(CWnd* pParent = NULL, BOOL bCommandBarsEditor = FALSE);
205
206public:
213 void SetIcon(CXTPImageManagerIconHandle& pHandle);
214
220 void SetIconSize(CSize szIcon);
221
227 void GetIcon(CXTPImageManagerIconHandle* pHandle);
228
229protected:
231 DECLARE_MESSAGE_MAP()
232
233 //{{AFX_VIRTUAL(CXTPImageEditorDlg)
234protected:
235 virtual void DoDataExchange(CDataExchange* pDX);
236 virtual BOOL OnInitDialog();
237 //}}AFX_VIRTUAL
238
239 //{{AFX_MSG(CXTPImageEditorDlg)
240 afx_msg void OnUpdateButtonTool(CCmdUI* pCmdUI);
241 afx_msg void OnButtonTool(UINT nID);
242 afx_msg LRESULT OnKickIdle(WPARAM wp, LPARAM lCount);
243 afx_msg void OnUpdateButtonUndo(CCmdUI* pCmdUI);
244 afx_msg void OnButtonUndo();
245 afx_msg void OnUpdateButtonRedo(CCmdUI* pCmdUI);
246 afx_msg void OnButtonRedo();
247 afx_msg void OnButtonClear();
248 afx_msg void OnButtonCopy();
249 afx_msg void OnButtonPaste();
250 afx_msg void OnButtonOpen();
251 afx_msg void OnMoveButton(UINT nID);
252 afx_msg BOOL OnToolTipText(UINT, NMHDR* pNMHDR, LRESULT* pResult);
253 afx_msg void OnDestroy();
254 //}}AFX_MSG
257private:
258 void OnPictureChanged();
259 void OnPickerClick(NMHDR* pNMHDR, LRESULT* pResult);
260 void OnSelectorClick(UINT id, NMHDR* pNMHDR, LRESULT* pResult);
261 void OnEraseClick(NMHDR* pNMHDR, LRESULT* pResult);
262 void SetSelected(CXTPImageEditorPicker* pPicker);
263 void FixAlphaLayer(LPBYTE pBits, UINT nCount);
264
265public:
266 enum
267 {
268 IDD = XTP_IDD_IMAGEEDITOR_DIALOG
269 };
270
271private:
272 CButton m_gboxTools;
273 CButton m_gboxMove;
274
275 CDlgToolBar m_wndToolbarTools;
276 CDlgToolBar m_wndToolbarMove;
277
278 CXTPImageEditorPicker m_wndSelector[16];
279 CXTPImageEditorPicker m_wndPicker;
280 CXTPImageEditorPicker m_wndSelectorErase;
281 CXTPImageEditorPicture m_wndPicture;
282 CXTPImageEditorPreview m_wndPreview;
283 CXTPImageEditorPicker* m_pSelected;
284
285 XTPImageEditorTools m_toolSelected;
286 XTPImageEditorTools m_toolPrevious;
287 CSize m_szPicture;
288 BOOL m_bCommandBarsEditor;
289
290private:
291 friend class CXTPImageEditorPicture;
292 friend class CXTPImageEditorPreview;
293};
294
296# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
297#endif // !defined(__XTP_IMAGEEDITORDLG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPImageEditorDlg
CXTPImageEditorDlg is a CDialog derived class.
Definition XTPImageEditor.h:185
CXTPImageEditorDlg::SetIcon
void SetIcon(CXTPImageManagerIconHandle &pHandle)
Sets the icon to edit.
CXTPImageEditorDlg::CXTPImageEditorDlg
CXTPImageEditorDlg(CWnd *pParent=NULL, BOOL bCommandBarsEditor=FALSE)
Constructs a CXTPImageEditorDlg object.
CXTPImageEditorDlg::SetIconSize
void SetIconSize(CSize szIcon)
Sets the icon size to edit.
CXTPImageEditorDlg::GetIcon
void GetIcon(CXTPImageManagerIconHandle *pHandle)
Retrieves the edited icon.
CXTPImageManagerIconHandle
CXTPImageManagerIconHandle is a HICON wrapper class.
Definition XTPImageManager.h:384
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42


Toolkit Pro: XTPButtonThemeOffice2003.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEOFFICE2003_H__)
24# define __XTPBUTTONTHEMEOFFICE2003_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeOffice2003 : public CXTPButtonThemeOfficeXP
39{
40public:
45 CXTPButtonThemeOffice2003();
46
53 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
54
61 void RefreshMetrics(CXTPButton* pButton);
62
63public:
64 BOOL m_bLunaTheme;
65};
66
67# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
69#endif //#if !defined(__XTPBUTTONTHEMEOFFICE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2003
CXTPButtonThemeOffice2003 is a class used to perform Office 2003 Theme drawing tasks.
Definition XTPButtonThemeOffice2003.h:39
CXTPButtonThemeOffice2003::CXTPButtonThemeOffice2003
CXTPButtonThemeOffice2003()
Constructs a CXTPButtonThemeOffice2003 object.
CXTPButtonThemeOffice2003::RefreshMetrics
void RefreshMetrics(CXTPButton *pButton)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPButtonThemeOffice2003::DrawButtonBackground
void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeOfficeXP
CXTPButtonThemeOfficeXP is a class used to perform Office XP Theme drawing tasks.
Definition XTPButtonThemeOfficeXP.h:39


Toolkit Pro: XTPDockingPaneTabColorSetNativeWindows11.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSetNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSETNATIVEWINDOWS11_H__)
24# define __XTPDOCKINGPANETABCOLORSETNATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSetNativeWindows11
39 : public CXTPDockingPaneTabColorSet2012
40{
41public:
46 CXTPDockingPaneTabColorSetNativeWindows11();
47
62 virtual void FillHeader(CDC* pDC, CRect rc, CXTPTabManager* pTabManager);
63};
64
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
67#endif // !defined(__XTPDOCKINGPANETABCOLORSETNATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSet2012.h:39
CXTPDockingPaneTabColorSetNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSetNativeWindows11.h:40
CXTPDockingPaneTabColorSetNativeWindows11::FillHeader
virtual void FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager)
This member is called to fill the header of the TabClient of the tab manager.
CXTPDockingPaneTabColorSetNativeWindows11::CXTPDockingPaneTabColorSetNativeWindows11
CXTPDockingPaneTabColorSetNativeWindows11()
Default class constructor.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87


CXTPCalendarResourcesNf Member List

This is the complete list of members for CXTPCalendarResourcesNf, including all inherited members.

Add(CXTPCalendarResource *pNewElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
Add(CXTPCalendarResource *pNewElement, BOOL bWithAddRef) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
Append(const CXTPCalendarPtrCollectionT< CXTPCalendarResource > *pElementsArray) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarResource > |
CXTPCalendarResources() | CXTPCalendarResources |
CXTPCalendarResourcesNf() | CXTPCalendarResourcesNf |
CXTPCmdTarget() | CXTPCmdTarget |
Find(CXTPCalendarEvent *pEvent) const | CXTPCalendarResources |
CXTPCalendarPtrCollectionT< CXTPCalendarResource >::Find(const CXTPCalendarResource *pElement) const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
FindByDataProvider(CXTPCalendarData *pData) const | CXTPCalendarResourcesNf |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
GetAt(int nIndex, BOOL bWithAddRef) const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
GetConnection() const | CXTPCalendarResourcesNf |
GetCount() const | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
GetResourcesGroupedByDP() const | CXTPCalendarResourcesNf | virtual
InsertAt(int nIndex, CXTPCalendarResource *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
m_arElements | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | protected
OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags) | CXTPCalendarResourcesNf | protectedvirtual
ReBuildInternalData() | CXTPCalendarResourcesNf | virtual
Remove(CXTPCalendarResource *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
RemoveAll() | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
RemoveAt(int nIndex) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
RetrieveDayEvents(COleDateTime dtDay) const | CXTPCalendarResources |
SetAt(int nIndex, CXTPCalendarResource *pElement) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
SetSize(int nNewSize) | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
TObjectPtr typedef | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | protected
~CXTPCalendarPtrCollectionT() | CXTPCalendarPtrCollectionT< CXTPCalendarResource > | virtual
~CXTPCalendarResources() | CXTPCalendarResources | virtual
~CXTPCalendarResourcesNf() | CXTPCalendarResourcesNf | virtual


Toolkit Pro: XTPChart3dFunnelSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 3D
XTPChart3dFunnelSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DFUNNELSERIESVIEW_H__)
24# define __XTPCHART3DFUNNELSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChart3dFunnelSeriesView : public CXTPChartFunnelSeriesViewBase
45{
46public:
54 CXTPChart3dFunnelSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
55
56public:
64 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds);
65
66protected:
78 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
79 CXTPChartSeriesPoint* pPoint,
80 CXTPChartElementView* pParentView);
81
94 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
95
106 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
107 CRect rcBounds);
108
122 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
123 CRect rcBounds, CXTPChartColor color1,
124 CXTPChartColor color2,
125 CXTPChartColor clrBorder);
126};
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
129#endif //#if !defined(__XTPCHART3DFUNNELSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dFunnelSeriesView
This class abstracts the view of a funnel series.
Definition XTPChart3dFunnelSeriesView.h:45
CXTPChart3dFunnelSeriesView::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the funnel series point layout.
CXTPChart3dFunnelSeriesView::CXTPChart3dFunnelSeriesView
CXTPChart3dFunnelSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChart3dFunnelSeriesView object.
CXTPChart3dFunnelSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
These functions create a label view drawing command object.
CXTPChart3dFunnelSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChart3dFunnelSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
Creates a legend drawing device command.
CXTPChart3dFunnelSeriesView::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the funnel series point view object.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelSeriesViewBase
This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView.
Definition XTPChartFunnelSeriesViewBase.h:50
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


CXTPPropertyGridOffice2003Theme Member List

This is the complete list of members for CXTPPropertyGridOffice2003Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridOffice2003Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridOffice2003Theme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridOffice2003Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bLunaTheme | CXTPPropertyGridOffice2003Theme | protected
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridOffice2003Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


CXTPSkinObjectComCtl32Control Member List

This is the complete list of members for CXTPSkinObjectComCtl32Control, including all inherited members.

CheckScrollBarsDraw() | CXTPSkinObjectComCtl32Control | protectedvirtual
CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectComCtl32Control() | CXTPSkinObjectComCtl32Control | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectUser32Control() | CXTPSkinObjectUser32Control | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


CXTPMarkupGdiPlusRotateTransform Member List

This is the complete list of members for CXTPMarkupGdiPlusRotateTransform, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupGdiPlusRotateTransform() | CXTPMarkupGdiPlusRotateTransform |
CXTPMarkupGdiPlusTransformObject() | CXTPMarkupGdiPlusTransformObject< CXTPMarkupRotateTransform > | protected
CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | protected
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAngle() const | CXTPMarkupRotateTransform |
GetCenterX() const | CXTPMarkupRotateTransform |
GetCenterY() const | CXTPMarkupRotateTransform |
m_pPropertyAngle | CXTPMarkupRotateTransform | static
m_pPropertyCenterX | CXTPMarkupRotateTransform | static
m_pPropertyCenterY | CXTPMarkupRotateTransform | static
SetAngle(double angle) | CXTPMarkupRotateTransform |
SetCenterX(double centerX) | CXTPMarkupRotateTransform |
SetCenterY(double centerY) | CXTPMarkupRotateTransform |
TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix) | CXTPMarkupGdiPlusRotateTransform | virtual
~CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | inlineprotectedvirtual


CXTPMarqueeCtrlThemeNativeWinXP Member List

This is the complete list of members for CXTPMarqueeCtrlThemeNativeWinXP, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeNativeWinXP() | CXTPMarqueeCtrlThemeNativeWinXP |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPMarqueeCtrlThemeNativeWinXP | protectedvirtual
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlThemeNativeWinXP | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


CXTPCalendarOccurSeriesChooseDlg Member List

This is the complete list of members for CXTPCalendarOccurSeriesChooseDlg, including all inherited members.

CXTPCalendarOccurSeriesChooseDlg(CWnd *pParent, UINT nIDResourceLabels, LPCTSTR lpszResourceIcon=IDI_EXCLAMATION, UINT nIDTemplate=CXTPCalendarOccurSeriesChooseDlg::IDD) | CXTPCalendarOccurSeriesChooseDlg |
m_bOccur | CXTPCalendarOccurSeriesChooseDlg |
m_ctrlIcon | CXTPCalendarOccurSeriesChooseDlg | protected
m_ctrlMessage | CXTPCalendarOccurSeriesChooseDlg | protected
m_ctrlOccur | CXTPCalendarOccurSeriesChooseDlg | protected
m_ctrlSeries | CXTPCalendarOccurSeriesChooseDlg | protected
m_hIcon | CXTPCalendarOccurSeriesChooseDlg | protected
m_nIDResourceLabels | CXTPCalendarOccurSeriesChooseDlg | protected
m_strMessage | CXTPCalendarOccurSeriesChooseDlg | protected
m_strOccur | CXTPCalendarOccurSeriesChooseDlg | protected
m_strSeries | CXTPCalendarOccurSeriesChooseDlg | protected
m_strTitle | CXTPCalendarOccurSeriesChooseDlg | protected
SetEvent(CXTPCalendarEvent *pEvent) | CXTPCalendarOccurSeriesChooseDlg | virtual
~CXTPCalendarOccurSeriesChooseDlg() | CXTPCalendarOccurSeriesChooseDlg | virtual


CXTPGridSelectedRows Member List

This is the complete list of members for CXTPGridSelectedRows, including all inherited members.

Add(CXTPGridRow *pRow) | CXTPGridSelectedRows |
AddBlock(int nIndexBegin, int nIndexEnd, BOOL bDeselectIfSelected=FALSE) | CXTPGridSelectedRows |
Clear() | CXTPGridSelectedRows |
Clear(BOOL bNotifyOnClear) | CXTPGridSelectedRows |
Contains(const CXTPGridRow *pRow) | CXTPGridSelectedRows |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridSelectedRows(CXTPGridControl *pControl) | CXTPGridSelectedRows |
DeselectBlock(int ib, int ie, BOOL bCollapsed) | CXTPGridSelectedRows |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) | CXTPGridSelectedRows |
GetCount() | CXTPGridSelectedRows |
GetFirstSelectedRowPosition() | CXTPGridSelectedRows |
GetNextSelectedRow(POSITION &pos) | CXTPGridSelectedRows |
GetNotifyOnClear() const | CXTPGridSelectedRows |
GetRowType() const | CXTPGridSelectedRows |
Invert(CXTPGridRow *pRow) | CXTPGridSelectedRows |
IsChanged() const | CXTPGridSelectedRows |
Remove(CXTPGridRow *pRow) | CXTPGridSelectedRows |
Select(CXTPGridRow *pRow) | CXTPGridSelectedRows |
SelectBlock(int nBlockBegin, int nBlockEnd, BOOL bControlKey=TRUE) | CXTPGridSelectedRows |
SetChanged(BOOL bChanged=TRUE) | CXTPGridSelectedRows |
SetNotifyOnClear(BOOL bNotifyOnClear=TRUE) | CXTPGridSelectedRows |
SwapIfNeed(int &indexB, int &indexE) | CXTPGridSelectedRows |


Toolkit Pro: XTPDockingPanePanelColorSet2013.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPanePanelColorSet2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELCOLORSET2013_H__)
24# define __XTPDOCKINGPANEPANELCOLORSET2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelColorSet2013 : public CXTPDockingPanePanelColorSet2012
39{
40public:
45 CXTPDockingPanePanelColorSet2013();
46
52 virtual void RefreshMetrics();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPDOCKINGPANEPANELCOLORSET2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelColorSet2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2012.h:39
CXTPDockingPanePanelColorSet2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelColorSet2013.h:39
CXTPDockingPanePanelColorSet2013::CXTPDockingPanePanelColorSet2013
CXTPDockingPanePanelColorSet2013()
Default class constructor.
CXTPDockingPanePanelColorSet2013::RefreshMetrics
virtual void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: XTPChartStackedSplineAreaSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartStackedSplineAreaSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSTACKEDSPLINEAREASERIESSTYLE_H__)
24# define __XTPCHARTSTACKEDSPLINEAREASERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartStackedSplineAreaSeriesStyle : public CXTPChartStackedAreaSeriesStyle
48{
50 DECLARE_SERIAL(CXTPChartStackedSplineAreaSeriesStyle)
52public:
57 CXTPChartStackedSplineAreaSeriesStyle();
58
63 virtual ~CXTPChartStackedSplineAreaSeriesStyle();
64
65public:
66protected:
79 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
80 CXTPChartDiagramView* pDiagramView);
81
82# ifdef _XTP_ACTIVEX
83public:
85 DECLARE_DISPATCH_MAP()
86 DECLARE_INTERFACE_MAP()
87 DECLARE_OLETYPELIB_EX(CXTPChartStackedSplineAreaSeriesStyle);
88 DECLARE_OLECREATE_EX(CXTPChartStackedSplineAreaSeriesStyle)
89
91# endif
92
93protected:
94};
95
106class _XTP_EXT_CLASS CXTPChartStackedSplineAreaSeriesView : public CXTPChartStackedAreaSeriesView
107{
108public:
116 CXTPChartStackedSplineAreaSeriesView(CXTPChartSeries* pSeries,
117 CXTPChartDiagramView* pDiagramView);
118
119protected:
131 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
132};
134# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
135#endif //#if !defined(__XTPCHARTSTACKEDSPLINEAREASERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartStackedAreaSeriesStyle
CXTPChartStackedAreaSeriesStyle is a CXTPChartAreaSeriesStyle derived class which represents the area...
Definition XTPChartStackedAreaSeriesStyle.h:48
CXTPChartStackedAreaSeriesView
CXTPChartStackedAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartStackedAreaSeriesStyle.h:114
CXTPChartStackedSplineAreaSeriesStyle
CXTPChartStackedSplineAreaSeriesStyle is a CXTPChartStackedAreaSeriesStyle derived class which repres...
Definition XTPChartStackedSplineAreaSeriesStyle.h:48
CXTPChartStackedSplineAreaSeriesStyle::CXTPChartStackedSplineAreaSeriesStyle
CXTPChartStackedSplineAreaSeriesStyle()
Constructs a CXTPChartStackedSplineAreaSeriesStyle object.
CXTPChartStackedSplineAreaSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Use this function to create a chart series view object.
CXTPChartStackedSplineAreaSeriesStyle::~CXTPChartStackedSplineAreaSeriesStyle
virtual ~CXTPChartStackedSplineAreaSeriesStyle()
Destroys a CXTPChartStackedSplineAreaSeriesStyle object, handles cleanup.
CXTPChartStackedSplineAreaSeriesView
CXTPChartStackedSplineAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartStackedSplineAreaSeriesStyle.h:107
CXTPChartStackedSplineAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartStackedSplineAreaSeriesView::CXTPChartStackedSplineAreaSeriesView
CXTPChartStackedSplineAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartStackedSplineAreaSeriesView object.


Toolkit Pro: XTPCalendarCaptionBarPaintManager.h Source File

  • Source
  • Calendar
  • CaptionBar
XTPCalendarCaptionBarPaintManager.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARCONTROLPAINTMANAGER_H__)
23# define _XTPCALENDARCONTROLPAINTMANAGER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
48class _XTP_EXT_CLASS CXTPCalendarCaptionBarPaintManager : public CXTPCmdTarget
49{
50public:
59 CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme* pTheme = NULL);
60
67 virtual ~CXTPCalendarCaptionBarPaintManager();
68
75 virtual XTPCalendarTheme GetPaintTheme() const;
76
82 virtual void RefreshMetrics();
83
84 virtual void Draw(CDC* pDC);
85 virtual void DrawBorders(CDC* pDC, const CRect& rcRect, const CRect& rcBorders);
86 virtual void DrawTriangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor);
87
88 virtual void PartRefresh(CXTPSwitchViewButtonPart* pBarPart) = 0;
89 virtual void PartRefresh(CXTPRadioButtonPart* pBarPart) = 0;
90 virtual void PartRefresh(CXTPCheckboxButtonPart* pBarPart) = 0;
91 virtual void PartRefresh(CXTPDateLabelPart* pBarPart) = 0;
92
93 virtual void PartAdjustLayout(CXTPSwitchViewButtonPart* pBarPart, CDC* pDC,
94 const CRect& rcRect) = 0;
95 virtual void PartAdjustLayout(CXTPScrollDateButtonPart* pBarPart, CDC* /*pDC*/,
96 const CRect& rcRect) = 0;
97 virtual void PartAdjustLayout(CXTPRadioButtonPart* pBarPart, CDC* pDC, const CRect& rcRect) = 0;
98 virtual void PartAdjustLayout(CXTPCheckboxButtonPart* pBarPart, CDC* pDC,
99 const CRect& rcRect) = 0;
100 virtual void PartAdjustLayout(CXTPExpandButtonPart* pBarPart, CDC* /*pDC*/,
101 const CRect& rcRect) = 0;
102
103 virtual void PartDraw(CXTPSwitchViewButtonPart* pBarPart, CDC* pDC) = 0;
104 virtual void PartDraw(CXTPScrollDateButtonPart* pBarPart, CDC* pDC) = 0;
105 virtual void PartDrawScrollTriangle(CXTPScrollDateButtonPart* pBarPart, CDC* pDC, CRect rcRect,
106 BOOL bLeftDirection, COLORREF clrColor) = 0;
107 virtual void PartDraw(CXTPRadioButtonPart* pBarPart, CDC* pDC) = 0;
108 virtual void PartDraw(CXTPCheckboxButtonPart* pBarPart, CDC* pDC) = 0;
109 virtual void PartDraw(CXTPDateLabelPart* pBarPart, CDC* pDC) = 0;
110 virtual void PartDraw(CXTPExpandButtonPart* pBarPart, CDC* pDC) = 0;
111 virtual void PartDrawExpandTriangle(CXTPExpandButtonPart* pBarPart, CDC* pDC, CRect rcRect,
112 BOOL bDownDirection, COLORREF clrColor) = 0;
113
114 CXTPPaintManagerColor GetSwitchViewBarBkColor() const;
115 void SetSwitchViewBarBkColor(const CXTPPaintManagerColor& color);
116
117 CXTPPaintManagerColor GetScrollDateBarBkColor() const;
118 void SetScrollDateBarBkColor(const CXTPPaintManagerColor& color);
119
120 CXTPPaintManagerColor GetTextColor() const;
121 void SetTextColor(const CXTPPaintManagerColor& color);
122
123 void GetBorderColors(CXTPPaintManagerColor& clrLeft, CXTPPaintManagerColor& clrTop,
124 CXTPPaintManagerColor& clrRight, CXTPPaintManagerColor& clrBottom) const;
125 void SetBorderColors(const CXTPPaintManagerColor& clrLeft, const CXTPPaintManagerColor& clrTop,
126 const CXTPPaintManagerColor& clrRight,
127 const CXTPPaintManagerColor& clrBottom);
128
129 CXTPPaintManagerColor GetScrollTriangleColor() const;
130 void SetScrollTriangleColor(const CXTPPaintManagerColor& color);
131
132protected:
133 XTPCalendarTheme m_nPaintTheme;
134 CXTPCalendarCaptionBarTheme* m_pTheme;
135 CXTPPaintManagerColor m_clrSwitchViewBarBk;
136 CXTPPaintManagerColor m_clrScrollDateBarBk;
137 CXTPPaintManagerColor m_clrTextColor;
138 CXTPPaintManagerColor m_clrBorders[4];
140 CXTPPaintManagerColor m_clrScrollTriangleColor;
141 CXTPCalendarThemeFontValue m_fntTextFont;
142 CXTPWinThemeWrapper* m_pThemeButton;
143
144 friend class CXTPCalendarCaptionBarThemePart;
145};
146
148
149AFX_INLINE XTPCalendarTheme CXTPCalendarCaptionBarPaintManager::GetPaintTheme() const
150{
151 return m_nPaintTheme;
152}
153
154AFX_INLINE CXTPPaintManagerColor CXTPCalendarCaptionBarPaintManager::GetSwitchViewBarBkColor() const
155{
156 return m_clrSwitchViewBarBk;
157}
158
159AFX_INLINE void
160 CXTPCalendarCaptionBarPaintManager::SetSwitchViewBarBkColor(const CXTPPaintManagerColor& color)
161{
162 m_clrSwitchViewBarBk = color;
163}
164
165AFX_INLINE CXTPPaintManagerColor CXTPCalendarCaptionBarPaintManager::GetScrollDateBarBkColor() const
166{
167 return m_clrScrollDateBarBk;
168}
169
170AFX_INLINE void
171 CXTPCalendarCaptionBarPaintManager::SetScrollDateBarBkColor(const CXTPPaintManagerColor& color)
172{
173 m_clrScrollDateBarBk = color;
174}
175
176AFX_INLINE CXTPPaintManagerColor CXTPCalendarCaptionBarPaintManager::GetTextColor() const
177{
178 return m_clrTextColor;
179}
180
181AFX_INLINE void CXTPCalendarCaptionBarPaintManager::SetTextColor(const CXTPPaintManagerColor& color)
182{
183 m_clrTextColor = color;
184}
185
186AFX_INLINE void CXTPCalendarCaptionBarPaintManager::GetBorderColors(
187 CXTPPaintManagerColor& clrLeft, CXTPPaintManagerColor& clrTop, CXTPPaintManagerColor& clrRight,
188 CXTPPaintManagerColor& clrBottom) const
189{
190 clrLeft = m_clrBorders[0];
191 clrTop = m_clrBorders[1];
192 clrRight = m_clrBorders[2];
193 clrBottom = m_clrBorders[3];
194}
195
196AFX_INLINE void CXTPCalendarCaptionBarPaintManager::SetBorderColors(
197 const CXTPPaintManagerColor& clrLeft, const CXTPPaintManagerColor& clrTop,
198 const CXTPPaintManagerColor& clrRight, const CXTPPaintManagerColor& clrBottom)
199{
200 m_clrBorders[0] = clrLeft;
201 m_clrBorders[1] = clrTop;
202 m_clrBorders[2] = clrRight;
203 m_clrBorders[3] = clrBottom;
204}
205
206AFX_INLINE CXTPPaintManagerColor CXTPCalendarCaptionBarPaintManager::GetScrollTriangleColor() const
207{
208 return m_clrScrollTriangleColor;
209}
210
211AFX_INLINE void
212 CXTPCalendarCaptionBarPaintManager::SetScrollTriangleColor(const CXTPPaintManagerColor& color)
213{
214 m_clrScrollTriangleColor = color;
215}
216
217# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
218#endif // !defined(_XTPCALENDARCONTROLPAINTMANAGER_H__)
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarCaptionBarPaintManager.h:49
CXTPCalendarCaptionBarPaintManager::m_clrScrollTriangleColor
CXTPPaintManagerColor m_clrScrollTriangleColor
Defines date scroll arrow color.
Definition XTPCalendarCaptionBarPaintManager.h:140
CXTPCalendarCaptionBarPaintManager::~CXTPCalendarCaptionBarPaintManager
virtual ~CXTPCalendarCaptionBarPaintManager()
Default paint manager destructor.
CXTPCalendarCaptionBarPaintManager::m_fntTextFont
CXTPCalendarThemeFontValue m_fntTextFont
Store the text font.
Definition XTPCalendarCaptionBarPaintManager.h:141
CXTPCalendarCaptionBarPaintManager::m_clrSwitchViewBarBk
CXTPPaintManagerColor m_clrSwitchViewBarBk
Store SwitchViewBar background color.
Definition XTPCalendarCaptionBarPaintManager.h:135
CXTPCalendarCaptionBarPaintManager::m_clrBorders
CXTPPaintManagerColor m_clrBorders[4]
Store border line color, left = 0, top = 1, right = 2, bottom = 3.
Definition XTPCalendarCaptionBarPaintManager.h:138
CXTPCalendarCaptionBarPaintManager::m_clrTextColor
CXTPPaintManagerColor m_clrTextColor
Store the text color.
Definition XTPCalendarCaptionBarPaintManager.h:137
CXTPCalendarCaptionBarPaintManager::CXTPCalendarCaptionBarPaintManager
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarPaintManager::GetPaintTheme
virtual XTPCalendarTheme GetPaintTheme() const
This member function is used to obtain current paint theme.
Definition XTPCalendarCaptionBarPaintManager.h:149
CXTPCalendarCaptionBarPaintManager::m_pTheme
CXTPCalendarCaptionBarTheme * m_pTheme
Store pointer to a parent theme object.
Definition XTPCalendarCaptionBarPaintManager.h:134
CXTPCalendarCaptionBarPaintManager::m_clrScrollDateBarBk
CXTPPaintManagerColor m_clrScrollDateBarBk
Store ScrollDateBar background color.
Definition XTPCalendarCaptionBarPaintManager.h:136
CXTPCalendarCaptionBarPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCalendarCaptionBarThemePart
This class used as a base class for graphical Parts of CalendarCaptionBar paint theme.
Definition XTPCalendarCaptionBarThemePart.h:54
CXTPCalendarThemeFontValue
Helper class provides functionality to manage font value objects.
Definition XTPCalendarViewPart.h:868
CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:367
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDateLabelPart
This class implements Date Label part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:407
CXTPExpandButtonPart
This class implements Expand button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:429
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:350
CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:383
CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:333
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


CXTPTagCloudStyle Member List

This is the complete list of members for CXTPTagCloudStyle, including all inherited members.

Copy(const CXTPTagCloudStyle *pSource, CXTPTagCloudStyle *pDest) | CXTPTagCloudStyle | static
CXTPTagCloudStyle() | CXTPTagCloudStyle |
CXTPTagCloudStyle(const CXTPTagCloudStyle &style) | CXTPTagCloudStyle |
CXTPTagCloudStyle(int nScore, COLORREF clrText, COLORREF clrTextHover, COLORREF clrBorder, LOGFONT &lf) | CXTPTagCloudStyle |
m_clrBorder | CXTPTagCloudStyle |
m_clrText | CXTPTagCloudStyle |
m_clrTextHover | CXTPTagCloudStyle |
m_nScore | CXTPTagCloudStyle |
m_xtpFont | CXTPTagCloudStyle |
operator=(const CXTPTagCloudStyle &style) | CXTPTagCloudStyle |
SetFont(LOGFONT &lf) | CXTPTagCloudStyle |


CXTPComboBoxTheme Member List

This is the complete list of members for CXTPComboBoxTheme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxTheme | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual


CXTPTaskPanelListViewTheme Member List

This is the complete list of members for CXTPTaskPanelListViewTheme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelListViewTheme() | CXTPTaskPanelListViewTheme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelToolboxTheme | protectedvirtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelListViewTheme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


CXTPChart3dDiagram Member List

This is the complete list of members for CXTPChart3dDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartDiagram | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChartDiagram | virtual
CXTPChart3dDiagram() | CXTPChart3dDiagram | protected
CXTPChartDiagram() | CXTPChartDiagram | protected
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPanel() | CXTPChartPanel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartDiagram | virtual
GetAppearance() const | CXTPChartElement |
GetCameraPosition() const | CXTPChart3dDiagram |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
GetSeries() const | CXTPChartDiagram |
GetTitles() const | CXTPChartPanel |
GetViewRotationMatrix() const | CXTPChart3dDiagram |
Is3D() const | CXTPChartObject |
m_arrSeries | CXTPChartDiagram | protected
m_fChartBoxSize | CXTPChart3dDiagram | static
m_fMaxModelDistance | CXTPChart3dDiagram | static
m_fMinModelDistance | CXTPChart3dDiagram | static
m_nPrimitiveSize | CXTPChart3dDiagram | static
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
OnSeriesAdded(CXTPChartSeries *pSeries) | CXTPChartDiagram | protectedvirtual
OnSeriesRemoved(CXTPChartSeries *pSeries) | CXTPChartDiagram | protected
Release() | CXTPChartDiagram | protectedvirtual
RotateArcBallToPoint(POINT point) | CXTPChart3dDiagram |
SetArcBallBounds(double dWidth, double dHeight) | CXTPChart3dDiagram |
SetStartArcBallRotationPoint(POINT point) | CXTPChart3dDiagram |
ZoomArcBall(float fDelta) | CXTPChart3dDiagram |
~CXTPChart3dDiagram() | CXTPChart3dDiagram | protected
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPanel() | CXTPChartPanel | virtual


CXTPDockingPaneTabColorSet2013 Member List

This is the complete list of members for CXTPDockingPaneTabColorSet2013, including all inherited members.

CXTPDockingPaneTabColorSet2013() | CXTPDockingPaneTabColorSet2013 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSet2013 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2013 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2013 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2013 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


CXTPScrollBarThemeOffice2003 Member List

This is the complete list of members for CXTPScrollBarThemeOffice2003, including all inherited members.

CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll) | CXTPScrollBarPaintManager | protectedstatic
CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll) | CXTPScrollBarPaintManager | protectedstatic
CXTPScrollBarPaintManager() | CXTPScrollBarPaintManager |
CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx |
DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL) | CXTPScrollBarPaintManager | protected
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarPaintManager | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawGripper(CDC *pDC, CXTPScrollBase *pScroll) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar) | CXTPScrollBarPaintManager | virtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics) | CXTPScrollBarThemeWindowsUx | protectedvirtual
m_crBack | CXTPScrollBarPaintManager |
m_crBackHilite | CXTPScrollBarPaintManager |
m_crBackPushed | CXTPScrollBarPaintManager |
m_crBorder | CXTPScrollBarPaintManager |
m_crBorderHilite | CXTPScrollBarPaintManager |
m_cThumb | CXTPScrollBarPaintManager |
m_cxHScroll | CXTPScrollBarPaintManager |
m_cxVScroll | CXTPScrollBarPaintManager |
m_cyHScroll | CXTPScrollBarPaintManager |
m_cyVScroll | CXTPScrollBarPaintManager |
RefreshMetrics() | CXTPScrollBarThemeOffice2003 | protectedvirtual
~CXTPScrollBarThemeWindowsUx() | CXTPScrollBarThemeWindowsUx | virtual


Toolkit Pro: XTPListBoxThemeVisualStudio2019.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2019_H__)
24# define __XTPLISTBOXTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeVisualStudio2019 : public CXTPListBoxThemeOffice2013
39{
40public:
45 CXTPListBoxThemeVisualStudio2019();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPLISTBOXTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBoxThemeOffice2013
CXTPListBoxThemeOffice2013 is used by CXTPListBox to draw an Office 2013 style list box.
Definition XTPListBoxThemeOffice2013.h:39
CXTPListBoxThemeVisualStudio2019
CXTPListBoxThemeVisualStudio2019 is used by CXTPListBox to draw a Visual Studio 2019 style list box.
Definition XTPListBoxThemeVisualStudio2019.h:39
CXTPListBoxThemeVisualStudio2019::CXTPListBoxThemeVisualStudio2019
CXTPListBoxThemeVisualStudio2019()
Default constructor.


Toolkit Pro: XTPEditThemeVisualStudio2010.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeVisualStudio2010.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEVISUALSTUDIO2010_H__)
24# define __XTPEDITTHEMEVISUALSTUDIO2010_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeVisualStudio2010 : public CXTPEditThemeOfficeXP
38{
39public:
44 CXTPEditThemeVisualStudio2010();
45
50 virtual ~CXTPEditThemeVisualStudio2010();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59};
60
61# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif // __XTPEDITTHEMEVISUALSTUDIO2010_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38
CXTPEditThemeVisualStudio2010
CXTPEditThemeVisualStudio2010 is a class used to perform theme drawing tasks.
Definition XTPEditThemeVisualStudio2010.h:38
CXTPEditThemeVisualStudio2010::CXTPEditThemeVisualStudio2010
CXTPEditThemeVisualStudio2010()
Constructs a CXTPEditThemeVisualStudio2010 object.
CXTPEditThemeVisualStudio2010::~CXTPEditThemeVisualStudio2010
virtual ~CXTPEditThemeVisualStudio2010()
Destructor, handles cleanup and deallocation.
CXTPEditThemeVisualStudio2010::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...


CXTPCalendarOffice2003Theme Member List

This is the complete list of members for CXTPCalendarOffice2003Theme, including all inherited members.

_GetAtGrow_BusyStatusBrushValue(int eBusyStatus, BOOL bGrow) | CXTPCalendarPaintManager | protected
_Init() | CXTPCalendarPaintManager | virtual
AddViewPart(CXTPCalendarViewPart *pPart) | CXTPCalendarPaintManager | protected
AdjustTimeFont(CDC *pDC, CRect rcCell) | CXTPCalendarPaintManager |
BEGIN_VIEW_PART(ControlPart, XTPCalendarViewPart) virtual void RefreshMetrics() | CXTPCalendarPaintManager |
CalcEventSize(CDC *c, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
CalcWidth(CDC *pDC, const CString &strHour, const CString &strMin, int nHourHeight, int &nWidth) | CXTPCalendarPaintManager |
CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme |
CXTPCalendarOffice2003Theme() | CXTPCalendarOffice2003Theme |
CXTPCalendarPaintManager() | CXTPCalendarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
DrawBigHourCell(CDC *pDC, CRect rc, CString strHour, CString strMin, int nRowPerHour, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawBitmap(CImageList *pImageList, CDC *pDC, CRect rcView, int iIcon, UINT uFlags=0) | CXTPCalendarPaintManager | virtual
DrawBitmap(UINT nIDResource, CDC *pDC, CRect rcBitmap) | CXTPCalendarPaintManager | virtual
DrawBorder(CDC *pDC, CRect rcView, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRect &rcRect, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawBusyStatus(CDC *pDC, CRgn &rgnBusy, int eBusyStatus) | CXTPCalendarPaintManager | virtual
DrawClock(CDC *pDC, COleDateTime dtClockTime, CRect rcView, COLORREF clrBackground, XTPCalendarClockAlignFlags cafAlign) | CXTPCalendarPaintManager | virtual
DrawDayHeader(CDC *pDC, CRect rcDay, int nHeaderHeight, CString strHeader, BOOL bIsCurrent=FALSE, BOOL bIsSelected=FALSE) | CXTPCalendarPaintManager | virtual
DrawEvent(CDC *pDC, const CRect &rcEvents, CXTPCalendarTimeLineViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawExpandSigns(CDC *pDC, CXTPCalendarDayView *pView, const CRect &rcTSHours) | CXTPCalendarPaintManager | virtual
DrawGroup(CDC *pDC, const CRect &rcRect, CXTPCalendarTimeLineViewGroup *pGroup) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent) | CXTPCalendarPaintManager | virtual
DrawHeader(CDC *pDC, CRect &rcHeader, BOOL bIsSelected, BOOL bIsCurrent, const CXTPPaintManagerColorGradient &grclr, COLORREF clrUnderLineHdr) | CXTPCalendarPaintManager | virtual
DrawHorizontalLine(CDC *pDC, int xPos, int yPos, int cx) | CXTPCalendarPaintManager | virtual
DrawHourCell(CDC *pDC, CRect rc, CString strText, BOOL bFillBackground=TRUE, BOOL bCurrentTime=FALSE) | CXTPCalendarPaintManager | virtual
DrawIconChar(CDC *pDC, CRect rc, TCHAR ch) | CXTPCalendarPaintManager | virtual
DrawIcons(CDC *pDC, CXTPCalendarViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
DrawLine(CDC *pDC, int xPos, int yPos, int cx, int cy) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawNowLine(CDC *pDC, CXTPCalendarDayView *pView, CXTPCalendarDayViewTimeScale *pScale, CRect rc, int y, BOOL bDrawBk=FALSE) | CXTPCalendarPaintManager | virtual
DrawShadow(CDC *pDC, const CRect &rcRect) | CXTPCalendarPaintManager | virtual
DrawSubj(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawTimes(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
DrawVerticalLine(CDC *pDC, int xPos, int yPos, int cy) | CXTPCalendarPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPCalendarPaintManager |
END_VIEW_PART(ControlPart) BEGIN_VIEW_PART(DayViewTimeScaleHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleHeaderPart) BEGIN_VIEW_PART(DayViewTimeScaleCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewTimeScaleCellPart) BEGIN_VIEW_PART(DayViewCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewCellPart) BEGIN_VIEW_PART(DayViewWorkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewWorkCellPart) BEGIN_VIEW_PART(DayViewNonworkCellPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewNonworkCellPart) BEGIN_VIEW_PART(DayMonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayMonthViewHeaderPart) BEGIN_VIEW_PART(DayViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewHeaderPart) BEGIN_VIEW_PART(DayViewGroupHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewGroupHeaderPart) BEGIN_VIEW_PART(DayViewAllDayEventsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventsPart) BEGIN_VIEW_PART(DayViewAllDayEventScrollIconsPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewAllDayEventScrollIconsPart) BEGIN_VIEW_PART(DayViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(DayViewEventPart) BEGIN_VIEW_PART(MonthViewGridPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewGridPart) BEGIN_VIEW_PART(MonthViewHeaderPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewHeaderPart) BEGIN_VIEW_PART(MonthViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(MonthViewEventPart) BEGIN_VIEW_PART(WeekViewPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewPart) BEGIN_VIEW_PART(WeekViewEventPart | CXTPCalendarPaintManager |
END_VIEW_PART(WeekViewEventPart) BEGIN_VIEW_PART(TimeLineViewTimeScalePart_Day | CXTPCalendarPaintManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAskItemTextFlags() const | CXTPCalendarPaintManager |
GetBusyStatusBrush(int nBusyStatus) | CXTPCalendarPaintManager |
GetClockSize() | CXTPCalendarPaintManager | virtual
GetCurrentSystemTheme() | CXTPCalendarPaintManager |
GetEventBackColor(CXTPCalendarEvent *pEvent, COLORREF crDefault) | CXTPCalendarPaintManager | virtual
GetExpandSignSize() | CXTPCalendarPaintManager | virtual
GetPaintTheme() const | CXTPCalendarPaintManager | virtual
GetParams(CXTPCalendarDayViewGroup *pViewGroup, XTP_CALENDAR_DAYVIEWCELL_PARAMS *rCellParams) | CXTPCalendarPaintManager | virtual
idxExpandSignDown enum value | CXTPCalendarPaintManager | protected
idxExpandSignUp enum value | CXTPCalendarPaintManager | protected
idxMeeting enum value | CXTPCalendarPaintManager | protected
idxPrivate enum value | CXTPCalendarPaintManager | protected
idxRecurrenceException enum value | CXTPCalendarPaintManager | protected
idxRecurrenceOccurrence enum value | CXTPCalendarPaintManager | protected
idxReminder enum value | CXTPCalendarPaintManager | protected
InitBusyStatusDefaultColors() | CXTPCalendarPaintManager | protectedvirtual
IsThemeEnabled() | CXTPCalendarPaintManager |
m_arBusyStatusBrushes | CXTPCalendarPaintManager | protected
m_arStartCol | CXTPCalendarPaintManager |
m_arStartRow | CXTPCalendarPaintManager |
m_bEnableTheme | CXTPCalendarPaintManager | protected
m_bmpElsewherePattern | CXTPCalendarPaintManager | protected
m_bmpTentativePattern | CXTPCalendarPaintManager | protected
m_bShowMinutes | CXTPCalendarPaintManager |
m_clr3DShadow | CXTPCalendarPaintManager |
m_clrBackground | CXTPCalendarPaintManager |
m_clrBackground2 | CXTPCalendarPaintManager |
m_clrBackgroundSlave | CXTPCalendarPaintManager |
m_clrBorders | CXTPCalendarPaintManager |
m_clrButtonFace | CXTPCalendarPaintManager |
m_clrButtonFaceText | CXTPCalendarPaintManager |
m_clrClassicUnderline | CXTPCalendarPaintManager |
m_clrEventBar | CXTPCalendarPaintManager |
m_clrEventBarLine | CXTPCalendarPaintManager |
m_clrEventBorderLine | CXTPCalendarPaintManager |
m_clrHeaderBottomLine | CXTPCalendarPaintManager |
m_clrHighlight | CXTPCalendarPaintManager |
m_clrHour | CXTPCalendarPaintManager |
m_clrMultiDayEventFrameColor | CXTPCalendarPaintManager |
m_clrSelectedBackground | CXTPCalendarPaintManager |
m_clrSelectedText | CXTPCalendarPaintManager |
m_clrShadow | CXTPCalendarPaintManager |
m_clrText | CXTPCalendarPaintManager |
m_clrTextHighLightColor | CXTPCalendarPaintManager |
m_clrTextNormalColor | CXTPCalendarPaintManager |
m_clrTimeScaleBackground | CXTPCalendarPaintManager |
m_clrTimeScaleHightlite | CXTPCalendarPaintManager |
m_clrTimeScaleText | CXTPCalendarPaintManager |
m_clrUnderLineHdr | CXTPCalendarPaintManager | protected
m_clrWeekendBackground | CXTPCalendarPaintManager |
m_clrWindow | CXTPCalendarPaintManager |
m_clrWindowText | CXTPCalendarPaintManager |
m_CurrSystemTheme | CXTPCalendarPaintManager | protected
m_dwAskItemTextFlags | CXTPCalendarPaintManager | protected
m_fntTimeText | CXTPCalendarPaintManager |
m_grclrClassicSelDay | CXTPCalendarPaintManager |
m_grclrToday | CXTPCalendarPaintManager |
m_lstViewParts | CXTPCalendarPaintManager | protected
m_nHourWidth | CXTPCalendarPaintManager |
m_nMinWidth | CXTPCalendarPaintManager |
m_nPaintTheme | CXTPCalendarPaintManager | protected
m_pControl | CXTPCalendarPaintManager | protected
m_pExpandSigns | CXTPCalendarPaintManager | protected
m_pGlyphs | CXTPCalendarPaintManager | protected
m_pGlyphsFont | CXTPCalendarPaintManager | protected
m_PrintPageWidth | CXTPCalendarPaintManager |
m_szClockRect | CXTPCalendarPaintManager | protected
m_xtpBrushElsewhere | CXTPCalendarPaintManager | protected
m_xtpBrushTentative | CXTPCalendarPaintManager | protected
OnDraw(CDC *pDC, CXTPCalendarDayView *pView, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, const XTP_CALENDAR_DAYVIEWCELL_PARAMS &cellParams) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewDay *pViewDay, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, CRect rc, BOOL bSelected) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewGroup *pViewGroup, BOOL bDrawUp, BOOL bDrawDown, const CRect &rcIconUp, const CRect &rcIconDown, BOOL bHighlightUp, BOOL bHighlightDown) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarDayViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarMonthView *pMonthView, CRect rc, int nCollIndex, CString strText) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekView *pWeekView) | CXTPCalendarPaintManager | virtual
OnDraw(CDC *pDC, CXTPCalendarWeekViewEvent *pWeekViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawDayDate(CDC *pDC, CRect rc, BOOL bToday, BOOL bSelected, BOOL bFirstMonthDay, CString strText) | CXTPCalendarPaintManager | virtual
OnDrawEvent(CDC *pDC, CXTPCalendarMonthViewEvent *pViewEvent) | CXTPCalendarPaintManager | virtual
OnDrawGrid(CDC *pDC, CXTPCalendarMonthView *pMonthView) | CXTPCalendarPaintManager | virtual
RefreshMetrics() | CXTPCalendarOffice2003Theme | virtual
SetAskItemTextFlags(DWORD dwFlags) | CXTPCalendarPaintManager |
SetBusyStatusBrush(int nBusyStatus, CBrush *pBrush, BOOL bAutodeleteBrush) | CXTPCalendarPaintManager |
SetControl(CXTPCalendarControl *pControl) | CXTPCalendarPaintManager | virtual
SetPaintTheme(XTPCalendarTheme ePaintTheme) | CXTPCalendarPaintManager | virtual
UpdateEventCategoriesDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateEventLabelsDefaultColors() | CXTPCalendarPaintManager | virtual
UpdateGlyphs() | CXTPCalendarPaintManager | virtual
XTPEnumEventGlyphs enum name | CXTPCalendarPaintManager | protected
XTPEnumExpandSigns enum name | CXTPCalendarPaintManager | protected
~CTimeLineViewPart() | CXTPCalendarPaintManager | virtual
~CXTPCalendarOffice2000Theme() | CXTPCalendarOffice2000Theme | virtual
~CXTPCalendarOffice2003Theme() | CXTPCalendarOffice2003Theme | virtual
~CXTPCalendarPaintManager() | CXTPCalendarPaintManager | virtual


CXTPDockingPaneTabTheme2015 Member List

This is the complete list of members for CXTPDockingPaneTabTheme2015, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2012() | CXTPDockingPaneTabTheme2012 |
CXTPDockingPaneTabTheme2015() | CXTPDockingPaneTabTheme2015 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabTheme2015 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPDockingPaneTabTheme2012 | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


Toolkit Pro: XTPTaskPanelVisualStudio2005Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelVisualStudio2005Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELVISUALSTUDIO2005THEME_H__)
24# define __XTPTASKPANELVISUALSTUDIO2005THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelVisualStudio2005Theme : public CXTPTaskPanelToolboxTheme
40{
41public:
46 CXTPTaskPanelVisualStudio2005Theme();
47
57 CRect DrawGroupCaptionBackground(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
58
66 void DrawGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
67
77 void FillGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
78
85 void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
86
91 void RefreshMetrics();
92
93protected:
94 virtual CRect DrawExpandButton(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
95};
96
98typedef CXTPTaskPanelVisualStudio2005Theme CXTPTaskPanelToolboxWhidbeyTheme;
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif // __XTPTASKPANELVISUALSTUDIO2005THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelToolboxTheme
CXTPTaskPanelToolboxTheme represents a Toolbox style theme.
Definition XTPTaskPanelToolboxTheme.h:40
CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme represents a Visual Studio 2005 style theme.
Definition XTPTaskPanelVisualStudio2005Theme.h:40
CXTPTaskPanelVisualStudio2005Theme::CXTPTaskPanelVisualStudio2005Theme
CXTPTaskPanelVisualStudio2005Theme()
Constructs a CXTPTaskPanelVisualStudio2005Theme object.
CXTPTaskPanelVisualStudio2005Theme::FillTaskPanel
void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelVisualStudio2005Theme::FillGroupClientFace
void FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
CXTPTaskPanelVisualStudio2005Theme::DrawGroupCaptionBackground
CRect DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
CXTPTaskPanelVisualStudio2005Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelVisualStudio2005Theme::DrawGroupClientFace
void DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.


CXTPMarkupButtonBase Member List

This is the complete list of members for CXTPMarkupButtonBase, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
CXTPMarkupContentControl() | CXTPMarkupContentControl | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupControl |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetContent() const | CXTPMarkupContentControl |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetForeground() const | CXTPMarkupControl |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupControl |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsPressed() const | CXTPMarkupButtonBase |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnClick() | CXTPMarkupButtonBase | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetContent(CXTPMarkupUIElement *pContent) | CXTPMarkupContentControl |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupControl |
SetPadding(int nPadding) | CXTPMarkupControl |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
~CXTPMarkupContentControl() | CXTPMarkupContentControl | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


CXTPTabColorSetVisualStudio2008 Member List

This is the complete list of members for CXTPTabColorSetVisualStudio2008, including all inherited members.

CXTPTabColorSetVisualStudio2008() | CXTPTabColorSetVisualStudio2008 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetOffice2003 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2008 | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_bGradientButton | CXTPTabColorSetVisualStudio2008 | protected
m_bLunaTheme | CXTPTabColorSetOffice2003 | protected
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrNavigateButtonBorder | CXTPTabColorSetOffice2003 | protected
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPTabColorSetOffice2003 |
RefreshMetrics() | CXTPTabColorSetVisualStudio2008 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPCalendarTimeLineView.h Source File

  • Source
  • Calendar
XTPCalendarTimeLineView.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARTIMELINEVIEW_H__)
23# define _XTPCALENDARTIMELINEVIEW_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# pragma warning(disable : 4100)
32
33class CXTPCalendarTimeLineView;
34class CXTPCalendarTimeLineViewGroups;
35class CXTPCalendarTimeLineViewTimeScale;
36class CXTPCalendarTimeLineViewTimeScaleGrid;
37
50struct XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW : public XTP_CALENDAR_HITTESTINFO
51{
52 POINT pt; // Point where the mouse was clicked in client coordinates.
53 COleDateTime dt; // A datetime object to fill and return.
54
63 XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW()
64 {
65 pt.x = pt.y = -1;
66 dt = COleDateTime::GetCurrentTime();
67 }
68};
69
75class _XTP_EXT_CLASS CXTPCalendarTimeLineView : public CXTPCalendarView
76{
77 friend class CXTPCalendarControl;
78 friend class CXTPDatePickerControl;
80 DECLARE_DYNAMIC(CXTPCalendarTimeLineView)
82public:
87 typedef CXTPCalendarView TBase;
88
95 CXTPCalendarTimeLineView(CXTPCalendarControl* pCalendarControl);
96
104 virtual ~CXTPCalendarTimeLineView();
105
114 virtual XTPCalendarViewType GetViewType() const;
115
121 virtual void Populate();
122
136 virtual void AdjustLayout(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
137
145 virtual void Draw(CDC* pDC);
146
156 virtual void Draw2(CDC* pDC);
157
170 virtual COleDateTime GetViewDayDate(int nIndex) const;
171
178 virtual COleDateTime GetStartViewDate() const;
179
186 virtual void SetStartViewDate(COleDateTime dt);
187
194 virtual int GetTimeScaleID() const;
195
202 virtual void SetTimeScaleID(int eTimeScaleParamsID);
203
210 CXTPCalendarTimeLineViewTimeScale* GetTimeScale() const;
211
223 virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
224
238 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW* pHitTest) const;
239
240 using CXTPCalendarView::HitTestEx;
241
251 virtual BOOL GetScrollBarInfoV(SCROLLINFO* pSI) const;
252
263 virtual BOOL GetScrollBarInfoH(SCROLLINFO* pSI, int* pnScrollStep = NULL) const;
264
272 virtual void ScrollH(int nPos, int nPos_raw);
273
281 virtual void ScrollV(int nPos, int nPos_raw);
282
290 virtual void ShowDay(const COleDateTime& date, BOOL bSelect = TRUE)
291 {
292 SetStartViewDate(date);
293 }
294
302 void ShowCalendarPopup(COleDateTime dt, CPoint point);
303
304protected:
310 virtual void RefreshMetrics();
311
317 virtual void OnBeforeDestroy();
318
325 virtual void OnScrollEnd(int nBar);
326
342 CRect GetTooltipRect(const CPoint& ptHit, const XTP_CALENDAR_HITTESTINFO& hitInfo) const;
343
353 virtual CXTPCalendarEventsPtr _GetEvents(COleDateTime dtStartDay, COleDateTime dtEndDay);
354
355 CXTPCalendarTimeLineViewTimeScale* m_pTimeScale;
356 CXTPCalendarTimeLineViewTimeScaleGrid* m_pTimeScaleGrid;
357
358 int m_nHScrollPos;
359 int m_nVScrollPos;
361private:
362 CRect m_rcLastPopulate;
364public:
365 CXTPCalendarTimeLineViewGroups* m_pGroups;
367 BOOL m_bTimeLineSeparateGroup;
368 int m_nTimelineMaxPixelsForEvent_ScaleDay;
369 int m_nTimelineMaxPixelsForEvent_ScaleWeek;
370 int m_nTimelineMaxPixelsForEvent;
372 COLORREF m_clrEventBar;
373 COLORREF m_clrEventBarLine;
374 COLORREF m_clrEventBorderLine;
376 COLORREF m_clrTimeScaleBackground;
377 COLORREF m_clrTimeScaleBorder;
378 COLORREF m_clrTimeScaleHighlight;
379 COLORREF m_clrTimeScaleText;
381 COLORREF m_clrSelectedBackground;
382 COLORREF m_clrSelectedText;
384 COLORREF m_clrBackground;
385 COLORREF m_clrText;
387 COLORREF m_clrWeekendBackground;
389# ifdef _XTP_ACTIVEX
390
391 DECLARE_DISPATCH_MAP()
392 DECLARE_INTERFACE_MAP()
393 DECLARE_OLETYPELIB_EX(CXTPCalendarTimeLineView);
394
395public:
396 afx_msg void OleSetMaxPixelsForEvent(long nPixels);
397 afx_msg long OleGetMaxPixelsForEvent();
398 afx_msg void OleSetMaxPixelsForEvent_ScaleDay(long nPixels);
399 afx_msg long OleGetMaxPixelsForEvent_ScaleDay();
400 afx_msg void OleSetMaxPixelsForEvent_ScaleWeek(long nPixels);
401 afx_msg long OleGetMaxPixelsForEvent_ScaleWeek();
402
403 afx_msg BOOL OleGetTimeLineSeparateGroup();
404 afx_msg void OleSetTimeLineSeparateGroup(BOOL bSet);
405
406 afx_msg OLE_COLOR OleGetTimeLineEventBarColor();
407 afx_msg void OleSetTimeLineEventBarColor(OLE_COLOR clrOleColor);
408
409 afx_msg OLE_COLOR OleGetTimeLineEventBarLineColor();
410 afx_msg void OleSetTimeLineEventBarLineColor(OLE_COLOR clrOleColor);
411
412 afx_msg OLE_COLOR OleGetTimeLineEventBorderLineColor();
413 afx_msg void OleSetTimeLineEventBorderLineColor(OLE_COLOR clrOleColor);
414
415 afx_msg OLE_COLOR OleGetTimeLineScaleBackgroundColor();
416 afx_msg void OleSetTimeLineScaleBackgroundColor(OLE_COLOR clrOleColor);
417
418 afx_msg OLE_COLOR OleGetTimeLineScaleBorderColor();
419 afx_msg void OleSetTimeLineScaleBorderColor(OLE_COLOR clrOleColor);
420
421 afx_msg OLE_COLOR OleGetTimeLineScaleHighlightColor();
422 afx_msg void OleSetTimeLineScaleHighlightColor(OLE_COLOR clrOleColor);
423
424 afx_msg OLE_COLOR OleGetTimeLineScaleTextColor();
425 afx_msg void OleSetTimeLineScaleTextColor(OLE_COLOR clrOleColor);
426
427 afx_msg OLE_COLOR OleGetTimeLineSelectedBackgroundColor();
428 afx_msg void OleSetTimeLineSelectedBackgroundColor(OLE_COLOR clrOleColor);
429
430 afx_msg OLE_COLOR OleGetTimeLineWeekendBackgroundColor();
431 afx_msg void OleSetTimeLineWeekendBackgroundColor(OLE_COLOR clrOleColor);
432
433 afx_msg OLE_COLOR OleGetTimeLineSelectedTextColor();
434 afx_msg void OleSetTimeLineSelectedTextColor(OLE_COLOR clrOleColor);
435
436 afx_msg OLE_COLOR OleGetTimeLineBackgroundColor();
437 afx_msg void OleSetTimeLineBackgroundColor(OLE_COLOR clrOleColor);
438
439 afx_msg OLE_COLOR OleGetTimeLineTextColor();
440 afx_msg void OleSetTimeLineTextColor(OLE_COLOR clrOleColor);
441
442 DATE OleGetTimeScaleMinTime();
443 void OleSetTimeScaleMinTime(DATE dtNewScaleMinTime);
444
445 DATE OleGetTimeScaleMaxTime();
446 void OleSetTimeScaleMaxTime(DATE dtNewScaleMaxTime);
447
448# endif
449};
450
451//===========================================================================
452AFX_INLINE XTPCalendarViewType CXTPCalendarTimeLineView::GetViewType() const
453{
454 return xtpCalendarTimeLineView;
455}
456
457AFX_INLINE CXTPCalendarTimeLineViewTimeScale* CXTPCalendarTimeLineView::GetTimeScale() const
458{
459 return m_pTimeScale;
460}
461
462# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
463#endif // !defined(_XTPCALENDARTIMELINEVIEW_H__)
XTPCalendarViewType
XTPCalendarViewType
Enumeration used to determine the calendar view type in use.
Definition XTPCalendarDefines.h:361
xtpCalendarTimeLineView
@ xtpCalendarTimeLineView
TimeLine view - CXTPCalendarTimeLineView
Definition XTPCalendarDefines.h:367
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarTimeLineViewGroups
This class represents a collection of CXTPCalendarTimeLineViewGroup objects.
Definition XTPCalendarTimeLineViewGroup.h:420
CXTPCalendarTimeLineView
This class implements a specific view portion of the Calendar control - called Timeline view.
Definition XTPCalendarTimeLineView.h:76
CXTPCalendarTimeLineView::m_nTimelineMaxPixelsForEvent
int m_nTimelineMaxPixelsForEvent
Width in pixels for 1 event for month scale.
Definition XTPCalendarTimeLineView.h:370
CXTPCalendarTimeLineView::m_clrEventBarLine
COLORREF m_clrEventBarLine
Event Bar Line Color.
Definition XTPCalendarTimeLineView.h:373
CXTPCalendarTimeLineView::~CXTPCalendarTimeLineView
virtual ~CXTPCalendarTimeLineView()
Default class destructor.
CXTPCalendarTimeLineView::Draw2
virtual void Draw2(CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
CXTPCalendarTimeLineView::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client dimensions ...
CXTPCalendarTimeLineView::m_clrTimeScaleHighlight
COLORREF m_clrTimeScaleHighlight
Time Scale Highlight Color.
Definition XTPCalendarTimeLineView.h:378
CXTPCalendarTimeLineView::m_clrEventBorderLine
COLORREF m_clrEventBorderLine
Event Border Line Color.
Definition XTPCalendarTimeLineView.h:374
CXTPCalendarTimeLineView::Populate
virtual void Populate()
This member function is used to populate the view with data for all items contained in the view.
CXTPCalendarTimeLineView::OnScrollEnd
virtual void OnScrollEnd(int nBar)
This member function is used to force scroll to the end of the scroll range.
CXTPCalendarTimeLineView::HitTest
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
CXTPCalendarTimeLineView::m_clrSelectedText
COLORREF m_clrSelectedText
Selected Text Color.
Definition XTPCalendarTimeLineView.h:382
CXTPCalendarTimeLineView::ScrollH
virtual void ScrollH(int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
CXTPCalendarTimeLineView::ShowDay
virtual void ShowDay(const COleDateTime &date, BOOL bSelect=TRUE)
Scrolls the specified date into view and selects it if required.
Definition XTPCalendarTimeLineView.h:290
CXTPCalendarTimeLineView::Draw
virtual void Draw(CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
CXTPCalendarTimeLineView::GetTimeScaleID
virtual int GetTimeScaleID() const
Call this member function to get the current time scale ID.
CXTPCalendarTimeLineView::m_clrWeekendBackground
COLORREF m_clrWeekendBackground
Weekend Background Color.
Definition XTPCalendarTimeLineView.h:387
CXTPCalendarTimeLineView::m_bTimeLineSeparateGroup
BOOL m_bTimeLineSeparateGroup
Flag to use separatore line between groups or not.
Definition XTPCalendarTimeLineView.h:367
CXTPCalendarTimeLineView::m_clrEventBar
COLORREF m_clrEventBar
Event Bar Color.
Definition XTPCalendarTimeLineView.h:372
CXTPCalendarTimeLineView::SetStartViewDate
virtual void SetStartViewDate(COleDateTime dt)
Call this member function to set the start view date.
CXTPCalendarTimeLineView::m_nTimelineMaxPixelsForEvent_ScaleDay
int m_nTimelineMaxPixelsForEvent_ScaleDay
Width in pixels for 1 event for day scale.
Definition XTPCalendarTimeLineView.h:368
CXTPCalendarTimeLineView::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
CXTPCalendarTimeLineView::GetTooltipRect
CRect GetTooltipRect(const CPoint &ptHit, const XTP_CALENDAR_HITTESTINFO &hitInfo) const
Call this member function to obtain the bounding rectangle of the tooltip space.
CXTPCalendarTimeLineView::GetViewDayDate
virtual COleDateTime GetViewDayDate(int nIndex) const
Call this member function to obtain the date of the day view by the day's index.
CXTPCalendarTimeLineView::GetStartViewDate
virtual COleDateTime GetStartViewDate() const
Call this member function to obtain the start view date.
CXTPCalendarTimeLineView::m_clrBackground
COLORREF m_clrBackground
Background Color.
Definition XTPCalendarTimeLineView.h:384
CXTPCalendarTimeLineView::m_clrTimeScaleBorder
COLORREF m_clrTimeScaleBorder
Time Scale Border Color.
Definition XTPCalendarTimeLineView.h:377
CXTPCalendarTimeLineView::m_nTimelineMaxPixelsForEvent_ScaleWeek
int m_nTimelineMaxPixelsForEvent_ScaleWeek
Width in pixels for 1 event for week scale.
Definition XTPCalendarTimeLineView.h:369
CXTPCalendarTimeLineView::m_pGroups
CXTPCalendarTimeLineViewGroups * m_pGroups
Array of events organized in groups.
Definition XTPCalendarTimeLineView.h:365
CXTPCalendarTimeLineView::SetTimeScaleID
virtual void SetTimeScaleID(int eTimeScaleParamsID)
Call this member function to set the current time scale.
CXTPCalendarTimeLineView::m_clrTimeScaleText
COLORREF m_clrTimeScaleText
Time Scale Text Color.
Definition XTPCalendarTimeLineView.h:379
CXTPCalendarTimeLineView::_GetEvents
virtual CXTPCalendarEventsPtr _GetEvents(COleDateTime dtStartDay, COleDateTime dtEndDay)
Call this member function to get all events in a given range.
CXTPCalendarTimeLineView::OnBeforeDestroy
virtual void OnBeforeDestroy()
This member function is called by the framework before the view is destroyed.
CXTPCalendarTimeLineView::m_clrText
COLORREF m_clrText
Text Color.
Definition XTPCalendarTimeLineView.h:385
CXTPCalendarTimeLineView::GetViewType
virtual XTPCalendarViewType GetViewType() const
Call this member function to obtain the view type flag.
Definition XTPCalendarTimeLineView.h:452
CXTPCalendarTimeLineView::GetScrollBarInfoV
virtual BOOL GetScrollBarInfoV(SCROLLINFO *pSI) const
This member function is used to retrieve information about a scrollbar's state.
CXTPCalendarTimeLineView::CXTPCalendarTimeLineView
CXTPCalendarTimeLineView(CXTPCalendarControl *pCalendarControl)
Default object constructor.
CXTPCalendarTimeLineView::RefreshMetrics
virtual void RefreshMetrics()
This member function is called by the framework when metrics must be updated.
CXTPCalendarTimeLineView::GetTimeScale
CXTPCalendarTimeLineViewTimeScale * GetTimeScale() const
Call this member function to set the current time scale as an object.
Definition XTPCalendarTimeLineView.h:457
CXTPCalendarTimeLineView::GetScrollBarInfoH
virtual BOOL GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve information about a scrollbar's state.
CXTPCalendarTimeLineView::m_clrSelectedBackground
COLORREF m_clrSelectedBackground
Selected Background Color.
Definition XTPCalendarTimeLineView.h:381
CXTPCalendarTimeLineView::m_clrTimeScaleBackground
COLORREF m_clrTimeScaleBackground
Time Scale Background Color.
Definition XTPCalendarTimeLineView.h:376
CXTPCalendarTimeLineView::m_pTimeScale
CXTPCalendarTimeLineViewTimeScale * m_pTimeScale
Pointer to attached Time Scale object.
Definition XTPCalendarTimeLineView.h:355
CXTPCalendarTimeLineView::ScrollV
virtual void ScrollV(int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
CXTPCalendarTimeLineView::m_nVScrollPos
int m_nVScrollPos
Keep VScroll position.
Definition XTPCalendarTimeLineView.h:359
CXTPCalendarTimeLineView::ShowCalendarPopup
void ShowCalendarPopup(COleDateTime dt, CPoint point)
This member function shows a pop-up DatePicker control.
CXTPCalendarTimeLineView::TBase
CXTPCalendarView TBase
Definition XTPCalendarTimeLineView.h:87
CXTPCalendarTimeLineView::m_nHScrollPos
int m_nHScrollPos
keep HScroll position.
Definition XTPCalendarTimeLineView.h:358
CXTPCalendarTimeLineViewTimeScale
This class implements a specific view portion of the Calendar control called Timeline view scale.
Definition XTPCalendarTimeLineViewTimeScale.h:70
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarView::GetViewType
virtual XTPCalendarViewType GetViewType() const =0
Call this member function to obtain the view type flag.
CXTPCalendarView::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW
Set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarTimeLineView.h:51
XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW::XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW
XTP_CALENDAR_HITTESTINFO_TIMELINE_VIEW()
Default constructor.
Definition XTPCalendarTimeLineView.h:63
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


CXTPChartRadarDiagramView Member List

This is the complete list of members for CXTPChartRadarDiagramView, including all inherited members.

AddAxisView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView, CXTPChartAxis *pAxis) | CXTPChartRadarDiagramView | protected
AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartRadarDiagramView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartRadarDiagramView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartRadarDiagramView | virtual
CXTPChartDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParentView) | CXTPChartDiagramView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRadarDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent) | CXTPChartRadarDiagramView |
GetAt(int nIndex) const | CXTPChartElementView |
GetAxisView(CXTPChartAxis *pAxis) const | CXTPChartRadarDiagramView |
GetBounds() const | CXTPChartDiagramView |
CXTPChartElementView::GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDiagram() const | CXTPChartDiagramView |
GetLabelsView() const | CXTPChartDiagramView |
GetParentView() const | CXTPChartElementView |
GetSeriesView() const | CXTPChartDiagramView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pAxisViews | CXTPChartRadarDiagramView | protected
m_pContainer | CXTPChartElementView | protected
m_pDiagram | CXTPChartDiagramView | protected
m_pLabelsView | CXTPChartDiagramView | protected
m_pParentView | CXTPChartElementView | protected
m_pSeriesView | CXTPChartDiagramView | protected
m_pTitlesView | CXTPChartDiagramView | protected
m_rcBounds | CXTPChartDiagramView | protected
OnMouseWheel(UINT nFlags, short zDelta, CPoint pt) | CXTPChartDiagramView | virtual
UpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartRadarDiagramView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


CColorSetVisualStudio2003 Member List

This is the complete list of members for CColorSetVisualStudio2003, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CColorSetVisualStudio2003 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CColorSetVisualStudio2003 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPChartDrawThread.h Source File

  • Source
  • Chart
  • Drawing
XTPChartDrawThread.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTDRAWTHREAD_H__)
24# define __XTPCHARTDRAWTHREAD_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceCommand;
34class CXTPChartDeviceContext;
35class CXTPChartControl;
36class CXTPChartContent;
37
38class _XTP_EXT_CLASS CXTPChartDrawThreadDeviceCommand : public CXTPChartDeviceCommand
39{
40public:
41 CXTPChartDrawThreadDeviceCommand(CXTPChartDeviceCommand* pCommand);
42 ~CXTPChartDrawThreadDeviceCommand();
43
44public:
45 void AddRef();
46 void Release();
47
48protected:
49 long m_dwRef;
50};
51
52class _XTP_EXT_CLASS CXTPChartDrawThread : CXTPWinThread
53{
55 DECLARE_DYNCREATE(CXTPChartDrawThread)
57protected:
58 CXTPChartDrawThread();
59 ~CXTPChartDrawThread();
60
61protected:
62 BOOL MonitorNotifications();
63 void StopNotifications();
64
65 BOOL InitInstance();
66 void DrawContent();
67 int Run();
68
69public:
70 void StartDraw(CSize sz, CXTPChartDrawThreadDeviceCommand* pCommand);
71
72protected:
73 HANDLE m_dwMonitorEvents[2];
75 CXTPChartDrawThreadDeviceCommand* m_pCommand;
76 CSize m_szImage;
77 BOOL m_bImageReady;
78 CBitmap m_bmpCache;
79
80 CXTPChartControl* m_pControl;
81 CRITICAL_SECTION m_cs;
82
83 friend class CXTPChartControl;
84};
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
87#endif //#if !defined(__XTPCHARTDRAWTHREAD_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartControl
CXTPChartControl is a CWnd derived class.
Definition XTPChartControl.h:52
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPWinThread
All XTP threads should derive from CXTPWinThread instead of CWinThread in order to ensure compatibili...
Definition XTPWinThread.h:42


CXTPMarkupStaticExtensionProperty Member List

This is the complete list of members for CXTPMarkupStaticExtensionProperty, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: XTPRibbonRenameDialog.h Source File

  • Source
  • Ribbon
  • Customize
XTPRibbonRenameDialog.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONRENAMEDIALOG_H__)
24# define __XTPRIBBONRENAMEDIALOG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonRenameDialog : public CDialog
34{
36 DECLARE_DYNAMIC(CXTPRibbonRenameDialog)
39public:
40 CXTPRibbonRenameDialog();
41
42 enum
43 {
44 IDD = XTP_IDD_RIBBONCUSTOMIZE_RENAME
45 };
46
47 const CString& GetName() const;
48 void SetName(LPCTSTR lpszNewName);
49
50protected:
51 virtual void DoDataExchange(CDataExchange* pDX);
52
53private:
54 CString m_strName;
55};
56
57AFX_INLINE const CString& CXTPRibbonRenameDialog::GetName() const
58{
59 return m_strName;
60}
61
62AFX_INLINE void CXTPRibbonRenameDialog::SetName(LPCTSTR lpszNewName)
63{
64 _ASSERTE(NULL != lpszNewName);
65 m_strName = lpszNewName;
66}
67
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
71#endif // __XTPRIBBONRENAMEDIALOG_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


CXTPPopupPaintManager Member List

This is the complete list of members for CXTPPopupPaintManager, including all inherited members.

CXTPPopupPaintManager() | CXTPPopupPaintManager |
DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient) | CXTPPopupPaintManager | virtual
DrawButton(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
DrawItem(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager |
DrawItemIcon(CDC *pDC, CXTPPopupItem *pItem) | CXTPPopupPaintManager | virtual
m_clrBackground | CXTPPopupPaintManager |
m_clrButtonPressed | CXTPPopupPaintManager |
m_clrButtonPressedBorder | CXTPPopupPaintManager |
m_clrButtonSelected | CXTPPopupPaintManager |
m_clrButtonSelectedBorder | CXTPPopupPaintManager |
m_clrFrame | CXTPPopupPaintManager |
m_clrText | CXTPPopupPaintManager |
m_xtpFontText | CXTPPopupPaintManager |
RefreshMetrics() | CXTPPopupPaintManager | virtual
SetFont(HFONT hFont) | CXTPPopupPaintManager |
~CXTPPopupPaintManager() | CXTPPopupPaintManager | virtual


Toolkit Pro: XTPTabClientContext.h Source File

  • Source
  • CommandBars
  • TabClient
XTPTabClientContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCLIENTCONTEXT_H__)
24# define __XTPTABCLIENTCONTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPAlphaWnd : public CWnd
38{
39public:
44 CXTPAlphaWnd();
45
50 virtual ~CXTPAlphaWnd();
51
52protected:
54 DECLARE_MESSAGE_MAP()
55 //{{AFX_MSG(CXTPTabClientAlphaWnd)
56 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
57 afx_msg void OnPaint();
58 //}}AFX_MSG
60};
61
67class _XTP_EXT_CLASS CXTPTabClientContext
68{
69private:
70 class CXTPTabClientContextSticker
71 {
72 public:
73 CXTPTabClientContextSticker();
74 ~CXTPTabClientContextSticker();
75
76 void InitContext(CXTPTabClientContext* pContext);
77
78 BOOL Enable();
79 BOOL Update();
80 void Disable();
81
82 int GetLastWorkspace() const;
83 CXTPTabClientWnd* GetLastTarget() const;
84 XTPTabClientStickerPart GetLastSelectedSticker() const;
85 CXTPTabClientSticker* GetSticker() const;
86
87 private:
88 CXTPTabClientContext* m_pContext;
89 int m_lastWorkspace;
90 CXTPTabClientWnd* m_pLastTarget;
91 XTPTabClientStickerPart m_lastSelectedSticker;
92 CXTPTabClientSticker* m_sticker;
93 HCURSOR m_hCursor;
94 HCURSOR m_hCursorNew;
95 };
96
97# ifndef _XTP_COMMANDBARS_ACTIVEX
98# ifdef _XTP_INCLUDE_DOCKINGPANE
99 class CXTPDockPaneContextSticker
100 {
101 public:
102 CXTPDockPaneContextSticker();
103 ~CXTPDockPaneContextSticker();
104
105 void InitContext(CXTPTabClientContext* pContext);
106
107 BOOL Enable();
108 BOOL Update();
109 void Disable();
110
111 CXTPDockingPaneTabbedContainer* GetLastTarget() const;
112 XTPDockingPaneStickerType GetLastSelectedSticker() const;
113 // CXTPDockPaneSticker* GetSticker() const;
114
115 private:
116 CXTPTabClientContext* m_pContext;
117 CXTPDockingPaneTabbedContainer* m_pLastTarget;
118 XTPDockingPaneStickerType m_lastSelectedSticker;
119 CXTPDockPaneSticker* m_sticker;
120 HCURSOR m_hCursor;
121 HCURSOR m_hCursorNew;
122 };
123# endif
124# endif
125
126 class CXTPAlphaWndBase
127 {
128 public:
129 CXTPAlphaWndBase();
130 virtual ~CXTPAlphaWndBase();
131
132 void InitContext(CXTPTabClientContext* pContext);
133 BOOL Enable();
134 virtual BOOL Update() = 0;
135 void Disable();
136
137 protected:
138 CXTPTabClientContext* m_pContext;
139 PVOID m_pfnSetLayeredWindowAttributes;
140 CXTPAlphaWnd m_wndAlpha;
141 typedef BOOL(WINAPI* PFNSETLAYEREDWINDOWATTRIBUTES)(HWND hwnd, COLORREF crKey, BYTE bAlpha,
142 DWORD dwFlags);
143 };
144
145 class CXTPTabClientAlphaWnd : public CXTPAlphaWndBase
146 {
147 public:
148 virtual BOOL Update();
149 };
150
151# ifndef _XTP_COMMANDBARS_ACTIVEX
152# ifdef _XTP_INCLUDE_DOCKINGPANE
153 class CXTPDockPaneAlphaWnd : public CXTPAlphaWndBase
154 {
155 public:
156 virtual BOOL Update();
157 };
158# endif
159# endif
160
161 class CXTPDraggingContents
162 {
163 public:
164 CXTPDraggingContents();
165 ~CXTPDraggingContents();
166
167 void InitContext(CXTPTabClientContext* pContext);
168
169 BOOL Enable();
170 void Update();
171 void Disable();
172
173 private:
174 CXTPTabClientContext* m_pContext;
175 CXTPTabClientDraggingContents* m_pWndDrag;
176 };
177
178 class CXTPFocusRectBase
179 {
180 public:
181 CXTPFocusRectBase();
182 virtual ~CXTPFocusRectBase();
183
184 void InitContext(CXTPTabClientContext* pContext);
185
186 virtual void Enable() = 0;
187 virtual void Update(CRect rcGroup) = 0;
188 void Disable();
189
190 protected:
191 void InitLoop(CWnd* pWnd);
192 void CancelLoop();
193 void DrawFocusRect(BOOL bRemoveRect = FALSE);
194
195 CXTPTabClientContext* m_pContext;
196 BOOL m_focusRect;
197 CDC* m_pDC;
198 CRect m_rcGroup;
199 CRect m_rectLast;
200 CSize m_sizeLast;
201 };
202
203 class CXTPTabFocusRect : public CXTPFocusRectBase
204 {
205 public:
206 virtual void Enable();
207 virtual void Update(CRect rcGroup);
208 };
209
210# ifndef _XTP_COMMANDBARS_ACTIVEX
211# ifdef _XTP_INCLUDE_DOCKINGPANE
212 class CXTPDockFocusRect : public CXTPFocusRectBase
213 {
214 public:
215 virtual void Enable();
216 virtual void Update(CRect rcGroup);
217 };
218# endif
219# endif
220
221public:
226 CXTPTabClientContext();
227
232 virtual ~CXTPTabClientContext();
233
240 CXTPTabClientWnd* GetTabClient() const;
241
247 void SetTabClient(CXTPTabClientWnd* pTabClientWnd);
248
257 CXTPTabClientWnd* FindTargetTabClient(POINT pt) const;
258
259# ifndef _XTP_COMMANDBARS_ACTIVEX
260# ifdef _XTP_INCLUDE_DOCKINGPANE
269 CXTPDockingPaneTabbedContainer* FindTargetDockPane(POINT pt) const;
270# endif
271# endif
272
280 BOOL GetShowTabClientContextStickers() const;
281
288 void SetShowTabClientContextStickers(BOOL value);
289
297 BOOL GetAlphaTabClientContext() const;
298
305 void SetAlphaTabClientContext(BOOL value);
306
314 BOOL GetShowContentsWhileDragging() const;
315
322 void SetShowContentsWhileDragging(BOOL value);
323
331 BOOL IsFloatingFrameThemeEnabled() const;
332
339 void EnableFloatingFrameTheme(BOOL value);
340
349 BOOL EnableTabSticker();
350
357 void DisableTabSticker();
358
364 BOOL UpdateTabSticker();
365
366# ifndef _XTP_COMMANDBARS_ACTIVEX
367# ifdef _XTP_INCLUDE_DOCKINGPANE
376 BOOL EnableDockSticker();
377
384 void DisableDockSticker();
385
390 BOOL UpdateDockSticker();
391# endif
392# endif
393
402 BOOL EnableTabContextWindow();
403
410 void DisableTabContextWindow();
411
418 BOOL UpdateTabContextWindow();
419
420# ifndef _XTP_COMMANDBARS_ACTIVEX
421# ifdef _XTP_INCLUDE_DOCKINGPANE
430 BOOL EnableDockContextWindow();
431
438 void DisableDockContextWindow();
439
446 BOOL UpdateDockContextWindow();
447# endif
448# endif
449
454 void EnableDraggingContents();
455
460 void DisableDraggingContents();
461
466 void UpdateDraggingContents();
467
472 void EnableTabFocusRect();
473
478 void DisableTabFocusRect();
479
485 void UpdateTabFocusRect(CRect rcGroup);
486
487# ifndef _XTP_COMMANDBARS_ACTIVEX
488# ifdef _XTP_INCLUDE_DOCKINGPANE
489 void EnableDockFocusRect();
490 void DisableDockFocusRect();
491 void UpdateDockFocusRect(CRect rcGroup);
492# endif
493# endif
494
501 CXTPTabClientWnd* GetLastTargetTabClient() const;
502# ifndef _XTP_COMMANDBARS_ACTIVEX
503# ifdef _XTP_INCLUDE_DOCKINGPANE
504 CXTPDockingPaneTabbedContainer* GetLastTargetDockPane() const;
505# endif
506# endif
507
514 int GetLastWorkspace() const;
515
524 XTPTabClientStickerPart GetLastSelectedTabClientSticker() const;
525# ifndef _XTP_COMMANDBARS_ACTIVEX
526# ifdef _XTP_INCLUDE_DOCKINGPANE
527 XTPDockingPaneStickerType GetLastSelectedDockSticker() const;
528# endif
529# endif
530
537 CXTPTabClientSticker* GetSticker() const;
538
539private:
540 BOOL m_bShowTabClientContextStickers;
544 BOOL m_bAlphaTabClientContext;
548 BOOL m_bShowContentsWhileDragging;
549 BOOL m_bThemedFloatingFrames;
552 CXTPTabClientWnd* m_pTabClientWnd;
554 CXTPTabClientContextSticker m_tabSticker;
555 CXTPTabClientAlphaWnd m_tabAlphaWnd;
556 CXTPTabFocusRect m_tabFocusRect;
557# ifndef _XTP_COMMANDBARS_ACTIVEX
558# ifdef _XTP_INCLUDE_DOCKINGPANE
559 CXTPDockPaneContextSticker* m_pDockSticker;
560 CXTPDockPaneAlphaWnd* m_pDockAlphaWnd;
561 CXTPDockFocusRect* m_pDockFocusRect;
562# else
563 // Required for padding.
564 LPVOID m_pDockSticker;
565 LPVOID m_pDockAlphaWnd;
566 LPVOID m_pDockFocusRect;
567# endif
568# endif
569 CXTPDraggingContents m_draggingContents;
570};
571
572AFX_INLINE void CXTPTabClientContext::SetShowTabClientContextStickers(BOOL value)
573{
574 m_bShowTabClientContextStickers = value;
575}
576
577AFX_INLINE void CXTPTabClientContext::SetAlphaTabClientContext(BOOL value)
578{
579 m_bAlphaTabClientContext = value;
580}
581
582AFX_INLINE void CXTPTabClientContext::SetShowContentsWhileDragging(BOOL value)
583{
584 m_bShowContentsWhileDragging = value;
585}
586
587AFX_INLINE void CXTPTabClientContext::EnableFloatingFrameTheme(BOOL value)
588{
589 m_bThemedFloatingFrames = value;
590}
591
592AFX_INLINE BOOL CXTPTabClientContext::GetAlphaTabClientContext() const
593{
594 return m_bAlphaTabClientContext;
595}
596
597AFX_INLINE BOOL CXTPTabClientContext::GetShowTabClientContextStickers() const
598{
599 return m_bShowTabClientContextStickers;
600}
601
602AFX_INLINE BOOL CXTPTabClientContext::GetShowContentsWhileDragging() const
603{
604 return m_bShowContentsWhileDragging;
605}
606
607AFX_INLINE BOOL CXTPTabClientContext::IsFloatingFrameThemeEnabled() const
608{
609 return m_bThemedFloatingFrames;
610}
611
612AFX_INLINE CXTPTabClientWnd* CXTPTabClientContext::GetLastTargetTabClient() const
613{
614 return m_tabSticker.GetLastTarget();
615}
616# ifndef _XTP_COMMANDBARS_ACTIVEX
617# ifdef _XTP_INCLUDE_DOCKINGPANE
618AFX_INLINE CXTPDockingPaneTabbedContainer* CXTPTabClientContext::GetLastTargetDockPane() const
619{
620 return m_pDockSticker->GetLastTarget();
621}
622# endif
623# endif
624AFX_INLINE int CXTPTabClientContext::GetLastWorkspace() const
625{
626 return m_tabSticker.GetLastWorkspace();
627}
628
629AFX_INLINE XTPTabClientStickerPart CXTPTabClientContext::GetLastSelectedTabClientSticker() const
630{
631 return m_tabSticker.GetLastSelectedSticker();
632}
633# ifndef _XTP_COMMANDBARS_ACTIVEX
634# ifdef _XTP_INCLUDE_DOCKINGPANE
635AFX_INLINE XTPDockingPaneStickerType CXTPTabClientContext::GetLastSelectedDockSticker() const
636{
637 return m_pDockSticker->GetLastSelectedSticker();
638}
639# endif
640# endif
641AFX_INLINE CXTPTabClientSticker* CXTPTabClientContext::GetSticker() const
642{
643 return m_tabSticker.GetSticker();
644}
645
647# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
648#endif // !defined(__XTPTABCLIENTCONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPDockingPaneStickerType
XTPDockingPaneStickerType
XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be...
Definition XTPDockingPaneDefines.h:362
XTPEnableNoisyWarnings.h
XTPTabClientStickerPart
XTPTabClientStickerPart
Identifies tab client sticker part.
Definition XTPTabClientSticker.h:41
CXTPAlphaWnd
CXTPTabClientAlphaWnd is CWnd derived class represents alpha context helper window.
Definition XTPTabClientContext.h:38
CXTPAlphaWnd::CXTPAlphaWnd
CXTPAlphaWnd()
Constructs a CXTPTabClientAlphaWnd object.
CXTPAlphaWnd::~CXTPAlphaWnd
virtual ~CXTPAlphaWnd()
Destroys a CXTPTabClientAlphaWnd object, handles cleanup and deallocation.
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPTabClientContext
CXTPTabClientContext is a standalone class.
Definition XTPTabClientContext.h:68
CXTPTabClientContext::EnableFloatingFrameTheme
void EnableFloatingFrameTheme(BOOL value)
Sets a flag that controls whether tab floating floating frame enables frame theme set for the primary...
Definition XTPTabClientContext.h:587
CXTPTabClientContext::UpdateTabContextWindow
BOOL UpdateTabContextWindow()
Updates tab context window.
CXTPTabClientContext::FindTargetTabClient
CXTPTabClientWnd * FindTargetTabClient(POINT pt) const
Hit tests tab client window at the specific screen point.
CXTPTabClientContext::DisableTabContextWindow
void DisableTabContextWindow()
Disables context window.
CXTPTabClientContext::DisableTabSticker
void DisableTabSticker()
Disables tab stickers.
CXTPTabClientContext::DisableTabFocusRect
void DisableTabFocusRect()
Enables/disables showing focus rectangle for a dragged tab client context contents.
CXTPTabClientContext::EnableTabFocusRect
void EnableTabFocusRect()
Enables/disables showing focus rectangle for a dragged tab client context contents.
CXTPTabClientContext::GetShowContentsWhileDragging
BOOL GetShowContentsWhileDragging() const
Gets a flag that controls whether tab floating frame contents will be shown while dragging.
Definition XTPTabClientContext.h:602
CXTPTabClientContext::UpdateTabFocusRect
void UpdateTabFocusRect(CRect rcGroup)
Updates focus rectangle.
CXTPTabClientContext::GetAlphaTabClientContext
BOOL GetAlphaTabClientContext() const
Gets a flag that controls whether tab client context will be drawn as a semi-transparent rectangle.
Definition XTPTabClientContext.h:592
CXTPTabClientContext::EnableTabContextWindow
BOOL EnableTabContextWindow()
Enables tab context window.
CXTPTabClientContext::SetTabClient
void SetTabClient(CXTPTabClientWnd *pTabClientWnd)
Sets an associated tab client window pointer.
CXTPTabClientContext::UpdateTabSticker
BOOL UpdateTabSticker()
Updates tab stickers.
CXTPTabClientContext::EnableDraggingContents
void EnableDraggingContents()
Enables/disables dragging tab client context contents.
CXTPTabClientContext::CXTPTabClientContext
CXTPTabClientContext()
Constructs a CXTPTabClientContext object.
CXTPTabClientContext::GetLastWorkspace
int GetLastWorkspace() const
Obtains the last pointed workspace index.
Definition XTPTabClientContext.h:624
CXTPTabClientContext::EnableTabSticker
BOOL EnableTabSticker()
Enables tab stickers.
CXTPTabClientContext::SetShowTabClientContextStickers
void SetShowTabClientContextStickers(BOOL value)
Sets a flag value that controls whether tab client stickers will be shown when needed.
Definition XTPTabClientContext.h:572
CXTPTabClientContext::UpdateDraggingContents
void UpdateDraggingContents()
Updates tab client context contents while dragging.
CXTPTabClientContext::GetLastTargetTabClient
CXTPTabClientWnd * GetLastTargetTabClient() const
Obtains the last target tab client window pointed by the mouse while dragging a frame.
Definition XTPTabClientContext.h:612
CXTPTabClientContext::SetShowContentsWhileDragging
void SetShowContentsWhileDragging(BOOL value)
Sets a flag that controls whether tab floating frame contents will be shown while dragging.
Definition XTPTabClientContext.h:582
CXTPTabClientContext::GetLastSelectedTabClientSticker
XTPTabClientStickerPart GetLastSelectedTabClientSticker() const
Obtains the last pointed sticker identifier.
Definition XTPTabClientContext.h:629
CXTPTabClientContext::~CXTPTabClientContext
virtual ~CXTPTabClientContext()
Destroys a CXTPTabClientContext object, handles cleanup and deallocation.
CXTPTabClientContext::GetSticker
CXTPTabClientSticker * GetSticker() const
Obtains the pointer to the last pointed sticker or NULL is there is no such.
Definition XTPTabClientContext.h:641
CXTPTabClientContext::GetShowTabClientContextStickers
BOOL GetShowTabClientContextStickers() const
Gets a flag value that controls whether tab client stickers will be shown when needed.
Definition XTPTabClientContext.h:597
CXTPTabClientContext::DisableDraggingContents
void DisableDraggingContents()
Enables/disables dragging tab client context contents.
CXTPTabClientContext::GetTabClient
CXTPTabClientWnd * GetTabClient() const
Gets an associated tab client window pointer.
CXTPTabClientContext::IsFloatingFrameThemeEnabled
BOOL IsFloatingFrameThemeEnabled() const
Gets a flag that controls whether tab floating floating frame enables frame theme set for the primary...
Definition XTPTabClientContext.h:607
CXTPTabClientContext::SetAlphaTabClientContext
void SetAlphaTabClientContext(BOOL value)
Sets a flag that controls whether tab client context will be drawn as a semi-transparent rectangle.
Definition XTPTabClientContext.h:577
CXTPTabClientDraggingContents
Managers tab client dragging contents.
Definition XTPTabClientDraggingContents.h:38
CXTPTabClientSticker
A tab client sticker control.
Definition XTPTabClientSticker.h:139
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383


CXTPStatusBarSwitchPane Member List

This is the complete list of members for CXTPStatusBarSwitchPane, including all inherited members.

AddSwitch(UINT nID) | CXTPStatusBarSwitchPane |
AddSwitch(UINT nID, LPCTSTR lpszToolTip) | CXTPStatusBarSwitchPane |
BestFit() | CXTPStatusBarPane |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPStatusBarPane() | CXTPStatusBarPane |
CXTPStatusBarSwitchPane() | CXTPStatusBarSwitchPane |
EnableSwitch(UINT nID, BOOL bEnabled) | CXTPStatusBarSwitchPane |
FindSwitch(UINT nID) const | CXTPStatusBarSwitchPane |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackgroundColor() const | CXTPStatusBarPane |
GetBeginGroup() const | CXTPStatusBarPane |
GetBestFit() | CXTPStatusBarPane |
GetCaption() const | CXTPStatusBarPane |
GetCustomizationVisible() const | CXTPStatusBarPane |
GetIconIndex() const | CXTPStatusBarPane |
GetID() const | CXTPStatusBarPane |
GetImage() const | CXTPStatusBarPane | virtual
GetIndex() const | CXTPStatusBarPane |
GetMargins() const | CXTPStatusBarPane |
GetMarkupUIElement() const | CXTPStatusBarPane |
GetPadding() const | CXTPStatusBarPane |
GetRect() const | CXTPStatusBarPane |
GetStatusBar() const | CXTPStatusBarPane |
GetStyle() const | CXTPStatusBarPane |
GetSwitch(int nIndex) const | CXTPStatusBarSwitchPane |
GetSwitchCount() const | CXTPStatusBarSwitchPane |
GetText() const | CXTPStatusBarPane |
GetTextAlignment() const | CXTPStatusBarPane |
GetTextColor() const | CXTPStatusBarPane |
GetTextFont() | CXTPStatusBarPane | virtual
GetTextGrayColor() const | CXTPStatusBarPane |
GetTooltip() const | CXTPStatusBarPane |
GetValue() const | CXTPStatusBarPane |
GetWidth() | CXTPStatusBarSwitchPane | virtual
HasBorders() const | CXTPStatusBarPane |
HitTest(CPoint point, CRect &rcItem) const | CXTPStatusBarSwitchPane |
IsButton() const | CXTPStatusBarPane |
IsChecked() const | CXTPStatusBarPane |
IsDark() const | CXTPStatusBarPane |
IsEnabled() const | CXTPStatusBarPane |
IsHighlighted() const | CXTPStatusBarPane |
IsPressed() const | CXTPStatusBarPane |
IsVisible() const | CXTPStatusBarPane |
m_arrSwitches | CXTPStatusBarSwitchPane | protected
m_bAutoDeleteWnd | CXTPStatusBarPane | protected
m_bBeginGroup | CXTPStatusBarPane | protected
m_bButton | CXTPStatusBarPane | protected
m_bCustomizable | CXTPStatusBarPane | protected
m_bIsDark | CXTPStatusBarPane | protected
m_bPressed | CXTPStatusBarPane | protected
m_clrBackground | CXTPStatusBarPane | protected
m_clrText | CXTPStatusBarPane | protected
m_clrTextGray | CXTPStatusBarPane | protected
m_cxText | CXTPStatusBarPane | protected
m_dwHideFlags | CXTPStatusBarPane | protected
m_hWndPane | CXTPStatusBarPane | protected
m_nAlignment | CXTPStatusBarPane | protected
m_nBestFit | CXTPStatusBarPane | protected
m_nIconIndex | CXTPStatusBarPane | protected
m_nID | CXTPStatusBarPane | protected
m_nIndex | CXTPStatusBarPane | protected
m_nStyle | CXTPStatusBarPane | protected
m_pHighlighted | CXTPStatusBarSwitchPane | protected
m_pMarkupUIElement | CXTPStatusBarPane | protected
m_pStatusBar | CXTPStatusBarPane | protected
m_rcMargins | CXTPStatusBarPane | protected
m_rcPadding | CXTPStatusBarPane | protected
m_rcPane | CXTPStatusBarPane | protected
m_strCaption | CXTPStatusBarPane | protected
m_strText | CXTPStatusBarPane | protected
m_strToolTip | CXTPStatusBarPane | protected
m_strValue | CXTPStatusBarPane | protected
m_xtpFontText | CXTPStatusBarPane | protected
OnDraw(CDC *pDC, CRect rcItem) | CXTPStatusBarSwitchPane | protectedvirtual
OnLButtonDown(CPoint point) | CXTPStatusBarSwitchPane | protectedvirtual
OnMouseMove(CPoint point) | CXTPStatusBarSwitchPane | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPStatusBarSwitchPane | protectedvirtual
Redraw() const | CXTPStatusBarPane |
Remove() | CXTPStatusBarPane |
RemoveAll() | CXTPStatusBarSwitchPane |
RemoveSwitch(UINT nID) | CXTPStatusBarSwitchPane |
SetBackgroundColor(COLORREF clrBackground) | CXTPStatusBarPane |
SetBeginGroup(BOOL bBeginGroup=TRUE) | CXTPStatusBarPane |
SetButton(BOOL bButton=TRUE) | CXTPStatusBarPane |
SetCaption(LPCTSTR lpszCaption) | CXTPStatusBarPane |
SetChecked(UINT nID) | CXTPStatusBarSwitchPane |
CXTPStatusBarPane::SetChecked(BOOL bChecked) | CXTPStatusBarPane |
SetCustomizationVisible(BOOL bVisible) | CXTPStatusBarPane |
SetDark(BOOL bDark=TRUE) | CXTPStatusBarPane |
SetEnabled(BOOL bEnabled) | CXTPStatusBarPane |
SetIconIndex(int nIconIndex) | CXTPStatusBarPane |
SetMargins(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPStatusBarPane |
SetStyle(UINT nStyle) | CXTPStatusBarPane |
SetSwitches(const UINT *lpIDArray, int nIDCount) | CXTPStatusBarSwitchPane |
SetText(LPCTSTR lpszText) | CXTPStatusBarPane |
SetTextAlignment(int nAlign) | CXTPStatusBarPane |
SetTextColor(COLORREF clrText) | CXTPStatusBarPane |
SetTextFont(CFont *pFntText) | CXTPStatusBarPane |
SetTextFont(PLOGFONT pLogfText) | CXTPStatusBarPane |
SetTextGrayColor(COLORREF clrText) | CXTPStatusBarPane |
SetTooltip(LPCTSTR lpszTooltip) | CXTPStatusBarPane |
SetValue(LPCTSTR lpszValue) | CXTPStatusBarPane |
SetVisible(BOOL bVisible, BOOL bRecalcLayout=TRUE) | CXTPStatusBarPane |
SetWidth(int nWidth) | CXTPStatusBarPane |
ShowBorders(BOOL bShowBorders) | CXTPStatusBarPane |
~CXTPStatusBarPane() | CXTPStatusBarPane | virtual
~CXTPStatusBarSwitchPane() | CXTPStatusBarSwitchPane |


CXTPPreviewProviderBase Member List

This is the complete list of members for CXTPPreviewProviderBase, including all inherited members.

BindHost(IXTPPreviewHost &host) | CXTPPreviewProviderBase | protectedvirtual
CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0 | IXTPPreviewProvider | pure virtual
CreatePreview(IStream &stream, LPCTSTR pImpliedFileName, HWND hwndParent)=0 | IXTPPreviewProvider | pure virtual
CXTPPreviewProviderBase() | CXTPPreviewProviderBase | protected
GetDefaultFileAssociations() const =0 | IXTPPreviewProvider | pure virtual
GetHost() const | CXTPPreviewProviderBase | protected
~IXTPPreviewProvider() | IXTPPreviewProvider | inlinevirtual


CXTPProgressCtrlThemeResource Member List

This is the complete list of members for CXTPProgressCtrlThemeResource, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeResource() | CXTPProgressCtrlThemeResource |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeResource | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2000 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlPaintManager | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


CXTPComboBoxThemeVisualStudio2022 Member List

This is the complete list of members for CXTPComboBoxThemeVisualStudio2022, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPComboBoxThemeVisualStudio2022() | CXTPComboBoxThemeVisualStudio2022 |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeVisualStudio2022 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeVisualStudio2022 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual
~CXTPComboBoxThemeVisualStudio2022() | CXTPComboBoxThemeVisualStudio2022 | virtual


XTP_EDIT_LINECOL Member List

This is the complete list of members for XTP_EDIT_LINECOL, including all inherited members.

Clear() | XTP_EDIT_LINECOL |
GetXLC() const | XTP_EDIT_LINECOL |
IsValidData() const | XTP_EDIT_LINECOL |
MakeLineCol(int nParamLine, int nParamCol) | XTP_EDIT_LINECOL | static
max2(const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2) | XTP_EDIT_LINECOL | static
MAXPOS | XTP_EDIT_LINECOL | static
min2(const XTP_EDIT_LINECOL &pos1, const XTP_EDIT_LINECOL &pos2) | XTP_EDIT_LINECOL | static
MINPOS | XTP_EDIT_LINECOL | static
nCol | XTP_EDIT_LINECOL |
nLine | XTP_EDIT_LINECOL |
operator!=(const XTP_EDIT_LINECOL &pos2) const | XTP_EDIT_LINECOL | inline
operator<(const XTP_EDIT_LINECOL &pos2) const | XTP_EDIT_LINECOL |
operator<=(const XTP_EDIT_LINECOL &pos2) const | XTP_EDIT_LINECOL |
operator==(const XTP_EDIT_LINECOL &pos2) const | XTP_EDIT_LINECOL |
operator>(const XTP_EDIT_LINECOL &pos2) const | XTP_EDIT_LINECOL |
operator>=(const XTP_EDIT_LINECOL &pos2) const | XTP_EDIT_LINECOL |
Pos1 | XTP_EDIT_LINECOL | static


CXTPCalendarComboBoxBase Member List

This is the complete list of members for CXTPCalendarComboBoxBase, including all inherited members.

CalcColorRect(CRect rItem) | CXTPCalendarComboBoxBase | protectedvirtual
CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase |
Init(CXTPCalendarEvent *pEvent, XTPCalendarTheme nTheme) | CXTPCalendarComboBoxBase | virtual
MeasureItem(LPMEASUREITEMSTRUCT lpMIS) | CXTPCalendarComboBoxBase | protectedvirtual
~CXTPCalendarComboBoxBase() | CXTPCalendarComboBoxBase | virtual


CXTPSkinObjectSolidFilled Member List

This is the complete list of members for CXTPSkinObjectSolidFilled, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectSolidFilled(COLORREF crFill) | CXTPSkinObjectSolidFilled | explicit
CXTPSkinObjectSolidFilled(HBRUSH hbrFill) | CXTPSkinObjectSolidFilled | explicit
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


CXTPTaskPanelVisualStudio2005Theme Member List

This is the complete list of members for CXTPTaskPanelVisualStudio2005Theme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
CXTPTaskPanelToolboxTheme() | CXTPTaskPanelToolboxTheme |
CXTPTaskPanelVisualStudio2005Theme() | CXTPTaskPanelVisualStudio2005Theme |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelToolboxTheme | virtual
DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2005Theme | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2005Theme | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelVisualStudio2005Theme | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelVisualStudio2005Theme | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelVisualStudio2005Theme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


CXTPPropExchangeEnumerator Member List

This is the complete list of members for CXTPPropExchangeEnumerator, including all inherited members.

CXTPPropExchangeEnumerator(CXTPPropExchange *pContainer, LPCTSTR lpszSection) | CXTPPropExchangeEnumerator |
GetNext(POSITION &pos) | CXTPPropExchangeEnumerator | virtual
GetPosition(DWORD dwCount=0, BOOL bCompactMode=TRUE) | CXTPPropExchangeEnumerator | virtual
m_nCount | CXTPPropExchangeEnumerator | protected
m_pContainer | CXTPPropExchangeEnumerator | protected
m_strSectionName | CXTPPropExchangeEnumerator | protected
~CXTPPropExchangeEnumerator() | CXTPPropExchangeEnumerator | virtual


CXTPGridRecordItemButton Member List

This is the complete list of members for CXTPGridRecordItemButton, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItemButton(LPCTSTR szCaption=_T("")) | CXTPGridRecordItemButton |
CXTPGridRecordItemControl(LPCTSTR szCaption=_T("")) | CXTPGridRecordItemControl |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemButton | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItemControl |
GetCaption() const | CXTPGridRecordItemControl |
GetCaptionColor() const | CXTPGridRecordItemControl |
GetEnable() const | CXTPGridRecordItemControl |
GetFlags() const | CXTPGridRecordItemControl |
GetFont() | CXTPGridRecordItemControl |
GetHeight() const | CXTPGridRecordItemControl |
GetIconIndex(int nState) const | CXTPGridRecordItemControl |
GetIndex() const | CXTPGridRecordItemControl |
GetRect() const | CXTPGridRecordItemControl |
GetSize() const | CXTPGridRecordItemControl |
GetState() const | CXTPGridRecordItemControl |
GetThemed() const | CXTPGridRecordItemControl |
GetType() const | CXTPGridRecordItemControl |
GetWidth() const | CXTPGridRecordItemControl |
m_Alignment | CXTPGridRecordItemControl | protected
m_bEnabled | CXTPGridRecordItemControl | protected
m_bThemed | CXTPGridRecordItemControl | protected
m_clrCaption | CXTPGridRecordItemControl | protected
m_mapIcon | CXTPGridRecordItemControl | protected
m_nIndex | CXTPGridRecordItemControl | protected
m_nSavedState | CXTPGridRecordItemButton | protected
m_nState | CXTPGridRecordItemControl | protected
m_nType | CXTPGridRecordItemControl | protected
m_rcControl | CXTPGridRecordItemControl | protected
m_sizeControl | CXTPGridRecordItemControl | protected
m_strCaption | CXTPGridRecordItemControl | protected
m_unFlags | CXTPGridRecordItemControl | protected
m_xtpFontCaption | CXTPGridRecordItemControl | protected
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItemButton | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItemButton | virtual
OnMouseEnter(UINT nFlags, CPoint point) | CXTPGridRecordItemButton | virtual
OnMouseLeave(UINT nFlags, CPoint point) | CXTPGridRecordItemButton | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPGridRecordItemButton | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItemControl |
SetCaption(LPCTSTR szCaption) | CXTPGridRecordItemControl |
SetCaptionColor(COLORREF clrCaption) | CXTPGridRecordItemControl |
SetEnable(BOOL bEnable) | CXTPGridRecordItemControl |
SetFlags(UINT unFlags) | CXTPGridRecordItemControl |
SetFont(CFont *pFont) | CXTPGridRecordItemControl |
SetHeight(int nHeight) | CXTPGridRecordItemControl |
SetIconIndex(int nState, int nIconIndex) | CXTPGridRecordItemControl |
SetRect(CRect rcControl) | CXTPGridRecordItemControl | protected
SetSize(CSize sizeControl) | CXTPGridRecordItemControl |
SetState(int nNewState) | CXTPGridRecordItemControl |
SetThemed(BOOL bThemed) | CXTPGridRecordItemControl |
SetWidth(int nWidth) | CXTPGridRecordItemControl |
~CXTPGridRecordItemControl() | CXTPGridRecordItemControl | virtual


Toolkit Pro: XTPChartBubbleSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartBubbleSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTBUBBLESERIESSTYLE_H__)
24# define __XTPCHARTBUBBLESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
46class _XTP_EXT_CLASS CXTPChartBubbleSeriesStyle : public CXTPChartPointSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartBubbleSeriesStyle)
51public:
56 CXTPChartBubbleSeriesStyle();
57
62 virtual ~CXTPChartBubbleSeriesStyle();
63
64public:
72 double GetMinSize() const;
73
80 void SetMinSize(double dMinSize);
81
89 double GetMaxSize() const;
90
97 void SetMaxSize(double dMinSize);
98
108 virtual int GetSeriesPointValueIndex() const;
109
116 virtual void DoPropExchange(CXTPPropExchange* pPX);
117
118protected:
129 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
130 CXTPChartDiagramView* pDiagramView);
131
132protected:
144 void CorrectAxisSideMargins(CXTPChartAxis* pAxis, double nMinValue, double nMaxValue,
145 double& nCorrection);
146
147# ifdef _XTP_ACTIVEX
148public:
150 DECLARE_DISPATCH_MAP()
151 DECLARE_INTERFACE_MAP()
152 DECLARE_OLETYPELIB_EX(CXTPChartBubbleSeriesStyle);
153 DECLARE_OLECREATE_EX(CXTPChartBubbleSeriesStyle)
154
155 double OleGetMinSize();
156 void OleSetMinSize(double dMinSize);
157
158 double OleGetMaxSize();
159 void OleSetMaxSize(double dMinSize);
160
162# endif
163
164 using CXTPChartPointSeriesStyle::m_nTransparency;
165
166 double m_dMinSize;
167 double m_dMaxSize;
168};
169
181class _XTP_EXT_CLASS CXTPChartBubbleSeriesView : public CXTPChartPointSeriesView
182{
183public:
191 CXTPChartBubbleSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
192
193protected:
205 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
206 CXTPChartSeriesPoint* pPoint,
207 CXTPChartElementView* pParentView);
208
221 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
222
223protected:
230 void CreatePointsView(CXTPChartDeviceContext* pDC);
231
232 double m_dMinValue;
233 double m_dMaxValue;
234
235 friend class CXTPChartBubbleSeriesPointView;
236};
237
249class _XTP_EXT_CLASS CXTPChartBubbleSeriesPointView : public CXTPChartPointSeriesPointView
250{
251public:
259 CXTPChartBubbleSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
260
261public:
274 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
275
276public:
284 CXTPChartColor GetActualColor() const;
285
293 CXTPChartColor GetActualColor2() const;
294};
295
296AFX_INLINE double CXTPChartBubbleSeriesStyle::GetMinSize() const
297{
298 return m_dMinSize;
299}
300AFX_INLINE void CXTPChartBubbleSeriesStyle::SetMinSize(double dMinSize)
301{
302 m_dMinSize = dMinSize;
303 OnChartChanged();
304}
305AFX_INLINE double CXTPChartBubbleSeriesStyle::GetMaxSize() const
306{
307 return m_dMaxSize;
308}
309AFX_INLINE void CXTPChartBubbleSeriesStyle::SetMaxSize(double dMaxSize)
310{
311 m_dMaxSize = dMaxSize;
312 OnChartChanged();
313}
314AFX_INLINE int CXTPChartBubbleSeriesStyle::GetSeriesPointValueIndex() const
315{
316 return 1;
317}
319# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
320#endif //#if !defined(__XTPCHARTBUBBLESERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartBubbleSeriesPointView
This class represents the view of a bubble series point, which is a kind of CXTPChartPointSeriesPoint...
Definition XTPChartBubbleSeriesStyle.h:250
CXTPChartBubbleSeriesPointView::GetActualColor
CXTPChartColor GetActualColor() const
Call this function to get the actual color.
CXTPChartBubbleSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartBubbleSeriesPointView::GetActualColor2
CXTPChartColor GetActualColor2() const
Call this function to get the second actual color.
CXTPChartBubbleSeriesPointView::CXTPChartBubbleSeriesPointView
CXTPChartBubbleSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChartBubbleSeriesPointView object.
CXTPChartBubbleSeriesStyle
This class represents a bubble series style, which is a kind of CXTPChartPointSeriesStyle.
Definition XTPChartBubbleSeriesStyle.h:47
CXTPChartBubbleSeriesStyle::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartBubbleSeriesStyle::CorrectAxisSideMargins
void CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection)
Call this function to correct the axis side margins.
CXTPChartBubbleSeriesStyle::CXTPChartBubbleSeriesStyle
CXTPChartBubbleSeriesStyle()
Constructs a CXTPChartBubbleSeriesStyle object.
CXTPChartBubbleSeriesStyle::GetSeriesPointValueIndex
virtual int GetSeriesPointValueIndex() const
Obtains the index of a point element for which an internal value can be otained.
Definition XTPChartBubbleSeriesStyle.h:314
CXTPChartBubbleSeriesStyle::GetMinSize
double GetMinSize() const
Gets the miminum bubble size value.
Definition XTPChartBubbleSeriesStyle.h:296
CXTPChartBubbleSeriesStyle::~CXTPChartBubbleSeriesStyle
virtual ~CXTPChartBubbleSeriesStyle()
Destroys a CXTPChartBubbleSeriesStyle object, handles cleanup.
CXTPChartBubbleSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the bubble series.
CXTPChartBubbleSeriesStyle::SetMaxSize
void SetMaxSize(double dMinSize)
Sets the maximum bubble size value.
Definition XTPChartBubbleSeriesStyle.h:309
CXTPChartBubbleSeriesStyle::SetMinSize
void SetMinSize(double dMinSize)
Sets the miminum bubble size value.
Definition XTPChartBubbleSeriesStyle.h:300
CXTPChartBubbleSeriesStyle::GetMaxSize
double GetMaxSize() const
Gets the maximum bubble size value.
Definition XTPChartBubbleSeriesStyle.h:305
CXTPChartBubbleSeriesView
This class represents the view of a bubble series, which is a kind of CXTPChartSeriesView.
Definition XTPChartBubbleSeriesStyle.h:182
CXTPChartBubbleSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartBubbleSeriesView::CXTPChartBubbleSeriesView
CXTPChartBubbleSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartBubbleSeriesView object.
CXTPChartBubbleSeriesView::CreatePointsView
void CreatePointsView(CXTPChartDeviceContext *pDC)
Creates the view object.
CXTPChartBubbleSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the bubble series point.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPointSeriesPointView
This class represents the view of a point series point, which is a kind of CXTPChartSeriesPointView.
Definition XTPChartPointSeriesView.h:90
CXTPChartPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartPointSeriesStyle.h:47
CXTPChartPointSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView.
Definition XTPChartPointSeriesView.h:42
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSeriesStyle::m_nTransparency
int m_nTransparency
The transparency value in the range 0..255.
Definition XTPChartSeriesStyle.h:330
CXTPChartSeriesStyle::GetSeriesPointValueIndex
virtual int GetSeriesPointValueIndex() const
Obtains the index of a point element for which an internal value can be otained.
Definition XTPChartSeriesStyle.h:413
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPMarkupSystemColorsStaticExtension Member List

This is the complete list of members for CXTPMarkupSystemColorsStaticExtension, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupSystemColorsStaticExtension() | CXTPMarkupSystemColorsStaticExtension |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtension | virtual
ProvideValue() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual


Toolkit Pro: XTPChartFunnelDiagramBase.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
XTPChartFunnelDiagramBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELDIAGRAMBASE_H__)
24# define __XTPCHARTFUNNELDIAGRAMBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35class _XTP_EXT_CLASS CXTPChartFunnelDiagramBaseImpl
36{
37protected:
38 virtual ~CXTPChartFunnelDiagramBaseImpl()
39 {
40 }
41
42 virtual void CalculateSeriesLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView);
43};
44
58template<class BaseDiagram>
59class CXTPChartFunnelDiagramBase
60 : public BaseDiagram
61 , private CXTPChartFunnelDiagramBaseImpl
62{
63public:
68 CXTPChartFunnelDiagramBase();
69
70public:
82 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
83 CXTPChartElementView* pParent) = 0;
84
92 virtual void CalculateSeriesLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView);
93};
94
95template<class BaseDiagram>
96AFX_INLINE CXTPChartFunnelDiagramBase<BaseDiagram>::CXTPChartFunnelDiagramBase()
97{
98}
99
100template<class BaseDiagram>
101AFX_INLINE void CXTPChartFunnelDiagramBase<BaseDiagram>::CalculateSeriesLayout(
102 CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView)
103{
104 CXTPChartFunnelDiagramBaseImpl::CalculateSeriesLayout(pDC, pView);
105}
106
107typedef CXTPChartFunnelDiagramBase<CXTPChart2dDiagram> CXTPChart2dFunnelDiagramBase;
108typedef CXTPChartFunnelDiagramBase<CXTPChart3dDiagram> CXTPChart3dFunnelDiagramBase;
110# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
111#endif //#if !defined(__XTPCHARTFUNNELDIAGRAMBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelDiagramBase
This class abstracts the funnel diagram.
Definition XTPChartFunnelDiagramBase.h:62
CXTPChartFunnelDiagramBase::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0
Call this function to create the view of the funnel diagram.
CXTPChartFunnelDiagramBase::CalculateSeriesLayout
virtual void CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the funnel series layout.
Definition XTPChartFunnelDiagramBase.h:101
CXTPChartFunnelDiagramBase::CXTPChartFunnelDiagramBase
CXTPChartFunnelDiagramBase()
Constructs a CXTPChartFunnelDiagramBase object.
Definition XTPChartFunnelDiagramBase.h:96


CXTPControlComboBoxEditCtrl Member List

This is the complete list of members for CXTPControlComboBoxEditCtrl, including all inherited members.

CreateEdit(DWORD dwStyle, CWnd *pParentWnd) | CXTPCommandBarEditCtrl | virtual
CXTPCommandBarEditCtrl() | CXTPCommandBarEditCtrl |
GetControlComboBox() const | CXTPControlComboBoxEditCtrl |
GetRichEditContext() | CXTPCommandBarEditCtrl | protected
GetWindowTextEx(CString &rString) | CXTPCommandBarEditCtrl |
IsCommandEnabled(UINT nID) | CXTPCommandBarEditCtrl | protected
IsDialogCode(UINT nChar, LPARAM lParam) | CXTPCommandBarEditCtrl |
IsImeMode() const | CXTPCommandBarEditCtrl |
m_bComposited | CXTPCommandBarEditCtrl | protected
m_bIgonoreEditChanged | CXTPCommandBarEditCtrl | protected
m_bImeMode | CXTPCommandBarEditCtrl | protected
m_pControl | CXTPControlComboBoxEditCtrl | protected
OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo) | CXTPCommandBarEditCtrl | virtual
OnCommand(WPARAM wParam, LPARAM lParam) | CXTPCommandBarEditCtrl | virtual
SetWindowTextEx(LPCTSTR lpszString) | CXTPCommandBarEditCtrl |
ShowContextMenu(CXTPControl *pControl, CPoint point) | CXTPCommandBarEditCtrl | virtual
UpdateCharFormat() | CXTPControlComboBoxEditCtrl | protected


CXTPCalendarViewPartFontValue Member List

This is the complete list of members for CXTPCalendarViewPartFontValue, including all inherited members.

CXTPCalendarViewPartFontValue() | CXTPCalendarViewPartFontValue |
IsDefaultValue() | CXTPCalendarViewPartFontValue |
m_xtpFontCustomValue | CXTPCalendarViewPartFontValue | protected
m_xtpFontStandardValue | CXTPCalendarViewPartFontValue | protected
operator CFont &() | CXTPCalendarViewPartFontValue |
operator CFont *() | CXTPCalendarViewPartFontValue |
operator->() | CXTPCalendarViewPartFontValue |
operator=(LOGFONT *pLogFont) | CXTPCalendarViewPartFontValue |
SetDefaultValue() | CXTPCalendarViewPartFontValue |
SetStandardValue(LOGFONT *pLogFont) | CXTPCalendarViewPartFontValue |


CXTPResourceTheme Member List

This is the complete list of members for CXTPResourceTheme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPResourceTheme | inlineprotectedvirtual
CreateGradientCircle() | CXTPCommandBarsOffice2003Theme | protected
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
CXTPResourceTheme() | CXTPResourceTheme |
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE) | CXTPPaintManager | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPPaintManager | virtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | virtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPPaintManager | virtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPPaintManager | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPCommandBarsOffice2003Theme | protectedvirtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOffice2003Theme | protectedvirtual
ExcludeCorners(CDC *pDC, CRect rc) | CXTPCommandBarsOffice2003Theme |
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPResourceTheme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPPaintManager | virtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPResourceTheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetImages() const | CXTPResourceTheme |
GetInstanceAddRef() | CXTPPaintManager | static
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetModernBitmap(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPResourceTheme | virtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPResourceTheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HasFloatingBarGradientEntry(CXTPCommandBar *pBar) | CXTPCommandBarsOffice2003Theme | protectedvirtual
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsImagesAvailable() | CXTPResourceTheme | protected
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPResourceTheme |
LoadModernToolbarIcons(UINT nIDResource) | CXTPCommandBarsOffice2003Theme | static
LoadModernToolbarIcons(UINT nIDResource, UINT *pCommands, int nCount, CSize szIcon=CSize(16, 15)) | CXTPCommandBarsOffice2003Theme | static
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bLunaTheme | CXTPCommandBarsOffice2003Theme |
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bPlainSeparators | CXTPCommandBarsOffice2003Theme |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clrCommandBar | CXTPCommandBarsOffice2003Theme |
m_clrDisabledIcon | CXTPPaintManager |
m_clrDockBar | CXTPCommandBarsOffice2003Theme |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrMenuExpand | CXTPCommandBarsOffice2003Theme |
m_clrMenuExpandedGripper | CXTPCommandBarsOffice2003Theme |
m_clrMenuGripper | CXTPCommandBarsOffice2003Theme |
m_clrMessageBarText | CXTPPaintManager |
m_clrPopupControl | CXTPCommandBarsOffice2003Theme |
m_clrTearOffGripper | CXTPCommandBarsOffice2003Theme |
m_clrToolbarExpand | CXTPCommandBarsOffice2003Theme |
m_clrToolbarShadow | CXTPCommandBarsOffice2003Theme |
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_grcLunaChecked | CXTPCommandBarsOffice2003Theme |
m_grcLunaPushed | CXTPCommandBarsOffice2003Theme |
m_grcLunaSelected | CXTPCommandBarsOffice2003Theme |
m_iconsInfo | CXTPPaintManager | protected
m_ilGradientCircle | CXTPCommandBarsOffice2003Theme |
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nRibbonCaptionHeight | CXTPResourceTheme | protected
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPResourceTheme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPResourceTheme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPResourceTheme | virtual
SetImages(CXTPResourceImages *pImages) | CXTPResourceTheme |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsOffice2003Theme() | CXTPCommandBarsOffice2003Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual
~CXTPResourceTheme() | CXTPResourceTheme | virtual


CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator > Member List

This is the complete list of members for CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator >, including all inherited members.

FreeExtraData() | CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator > | inlinestatic
operator delete(void *p) | CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator > | inline
operator new(size_t nSize) | CXTPBatchAllocObjT< _TObject, _TBatchAllocData, _TAllocator > | inline


CXTPEditThemeVisualStudio2022 Member List

This is the complete list of members for CXTPEditThemeVisualStudio2022, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeVisualStudio2022() | CXTPEditThemeVisualStudio2022 |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2013 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeVisualStudio2022() | CXTPEditThemeVisualStudio2022 | virtual


Toolkit Pro: XTPControls.h Source File

  • Source
  • CommandBars
XTPControls.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLS_H__)
24# define __XTPCONTROLS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBar;
34class CXTPControl;
35class CXTPCommandBars;
36class CXTPCommandBarList;
37class CXTPPropExchange;
38struct XTP_COMMANDBARS_PROPEXCHANGE_PARAM;
39class CXTPOriginalControls;
40
46class _XTP_EXT_CLASS CXTPControls : public CXTPCmdTarget
47{
49 DECLARE_DYNCREATE(CXTPControls)
51private:
52 struct XTPBUTTONINFO;
54public:
59 CXTPControls();
60
65 virtual ~CXTPControls();
66
67public:
75 CXTPControl* GetAt(int nIndex) const;
76
85 int CommandToIndex(int nIDFind) const;
86
98 CXTPControl* Add(CXTPControl* pControl, int nId, LPCTSTR lpszParameter = NULL, int nBefore = -1,
99 BOOL bTemporary = FALSE);
100
112 CXTPControl* Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter = NULL,
113 int nBefore = -1, BOOL bTemporary = FALSE);
114
122 CXTPControl* Add(CXTPControl* pControl);
123
134 CXTPControl* InsertAt(CXTPControl* pControl, int nBefore);
135
144 CXTPControl* AddMenuItem(CMenu* pMenu, int nIndex);
145
151 virtual void Remove(CXTPControl* pControl);
152
158 void Remove(int nIndex);
159
164 void RemoveAll();
165
172 int GetCount() const;
173
181 CXTPControl* FindControl(int nId) const;
182
193 CXTPControl* FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const;
194
202 BOOL LoadMenu(CMenu* pMenu);
203
204public:
211 CXTPControl* GetFirst() const;
212
218 void GetNext(CXTPControl*& pControl) const;
219
231 long GetNext(long nIndex, int nDirection = +1, BOOL bKeyboard = TRUE,
232 BOOL bSkipTemporary = FALSE, BOOL bSkipCollapsed = TRUE) const;
233
243 CXTPControl* HitTest(CPoint point) const;
244
253 CXTPControl* SetControlType(CXTPControl* pControl, XTPControlType type);
254
263 CXTPControl* SetControlType(int nIndex, XTPControlType type);
264
274 CXTPControl* AddClone(CXTPControl* pClone, int nBefore = -1, BOOL bRecursive = FALSE);
275
288 CSize CalcDynamicSize(CDC* pDC, int nLength, DWORD dwMode, const CRect& rcBorder,
289 int nWidth = 0);
290
304 CSize CalcPopupSize(CDC* pDC, int nLength, int nWidth, const CRect& rcBorder);
305
313 int GetVisibleCount(BOOL bIgnoreWrap = FALSE) const;
314
323 CXTPControl* GetVisibleAt(int nIndex, BOOL bIgnoreWraps = FALSE) const;
324
333 void SetCommandBars(CXTPCommandBars* pCommandBars);
334
342 CXTPControls* Duplicate(BOOL bRecursive = FALSE);
343
350 virtual void Copy(CXTPControls* pControls, BOOL bRecursive = FALSE);
351
358 CXTPCommandBars* GetCommandBars() const;
359
366 void MoveBefore(CXTPControl* pControl, int nBefore);
367
373 void SetParent(CXTPCommandBar* pParent);
374
379 void CreateOriginalControls();
380
385 void ClearOriginalControls();
386
393 CXTPOriginalControls* GetOriginalControls() const;
394
400 void SetOriginalControls(CXTPOriginalControls* pControls);
401
409 BOOL Compare(const CXTPControls* pControls);
410
418 BOOL IsChanged() const;
419
425 virtual void DoPropExchange(CXTPPropExchange* pPX);
426
434 virtual BOOL ShouldSerializeControl(CXTPControl* pControl);
435
442 CXTPCommandBar* GetParent() const;
443
452 BOOL IsOriginalControls() const;
453
458 void Sort();
459
460protected:
466 virtual void OnControlAdded(CXTPControl* pControl);
467
473 virtual void OnControlRemoved(CXTPControl* pControl);
474
482 virtual BOOL OnControlRemoving(CXTPControl* pControl);
483
485protected:
486 virtual void RefreshIndexes();
487 static int AFX_CDECL CompareByCaption(const CXTPControl** ppItem1, const CXTPControl** ppItem2);
488
489protected:
490 void GenerateCommandBarList(DWORD& nID, CXTPCommandBarList* pCommandBarList,
491 XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam);
492 void RestoreCommandBarList(CXTPCommandBarList* pCommandBarList);
493 CSize _CalcSize(XTPBUTTONINFO* pData, BOOL bVert);
494 int _WrapToolBar(XTPBUTTONINFO* pData, int nWidth, DWORD& dwMode);
495 void _SizeFloatableBar(XTPBUTTONINFO* pData, int nLength, DWORD dwMode);
496 void _AdjustBorders(XTPBUTTONINFO* pData, CSize& sizeResult, DWORD dwMode, CRect rcBorder);
497 void _CenterControlsInRow(XTPBUTTONINFO* pData, int nFirst, int nLast, int, BOOL,
498 CSize sizeResult, CRect);
499 void _MoveRightAlligned(XTPBUTTONINFO* pData, CSize sizeResult, CRect rcBorder, DWORD dwMode);
500 void _SizePopupToolBar(XTPBUTTONINFO* pData, DWORD dwMode);
501
502 CSize _CalcSmartLayoutToolBar(CDC* pDC, XTPBUTTONINFO* pData, DWORD& dwMode);
503 CSize _WrapSmartLayoutToolBar(CDC* pDC, XTPBUTTONINFO* pData, int nWidth, DWORD& dwMode);
504 CSize _ReduceSmartLayoutToolBar(CDC* pDC, XTPBUTTONINFO* pData, int nWidth, DWORD& dwMode);
505 void _MakeSameWidth(int nStart, int nLast, int nWidth);
508protected:
509 CXTPCommandBar* m_pParent;
510 CArray<CXTPControl*, CXTPControl*> m_arrControls;
511 CXTPCommandBars* m_pCommandBars;
512 CXTPOriginalControls* m_pOriginalControls;
513 BOOL m_bOriginalControls;
514# ifdef _XTP_COMMANDBARS_ACTIVEX
515public:
518 CArray<CXTPControl*, CXTPControl*>* CXTPControls::GetArray()
519 {
520 return &m_arrControls;
521 }
522
523 DECLARE_DISPATCH_MAP()
524 DECLARE_INTERFACE_MAP()
525
526 DECLARE_OLETYPELIB_EX(CXTPControls);
527
528 afx_msg long OleGetItemCount();
529 afx_msg LPDISPATCH OleItem(long nIndex);
530 afx_msg LPDISPATCH OleGetItem(long nIndex);
531 afx_msg LPDISPATCH OleAdd(long controlType, int nId, LPCTSTR strCaption, const VARIANT& pBefore,
532 const VARIANT& pTemporary);
533 afx_msg void OleAddControl(LPDISPATCH Control, const VARIANT& pBefore);
534 DECLARE_ENUM_VARIANT(CXTPControls)
535
536 afx_msg LPDISPATCH OleParent();
537 afx_msg LPDISPATCH OleGetOriginalControls();
538 afx_msg LPDISPATCH OleFindControl(const VARIANT& varType, const VARIANT& varId,
539 const VARIANT& varVisible, const VARIANT& varRecursive);
540
541 enum
542 {
543 dispidCount = 1L,
544 dispidAdd = 2L,
545 dispidParent = 3L,
546 dispidFindControl = 4L,
547 };
548
550# endif
551
552 friend class CXTPCommandBar;
553 friend class CXTPCommandBars;
554 friend class CXTPToolBar;
555 friend class CXTPMenuBar;
556 friend class CXTPRibbonBar;
557};
558
563class _XTP_EXT_CLASS CXTPOriginalControls : public CXTPControls
564{
566 DECLARE_DYNCREATE(CXTPOriginalControls)
568public:
573 CXTPOriginalControls();
574
575 friend class CXTPControls;
576};
577
579
580AFX_INLINE CXTPControl* CXTPControls::GetAt(int nIndex) const
581{
582 _ASSERTE(nIndex < m_arrControls.GetSize());
583 return (nIndex >= 0 && nIndex < m_arrControls.GetSize()) ? m_arrControls.GetAt(nIndex) : NULL;
584}
585AFX_INLINE int CXTPControls::GetCount() const
586{
587 return (int)m_arrControls.GetSize();
588}
589AFX_INLINE CXTPOriginalControls* CXTPControls::GetOriginalControls() const
590{
591 return m_pOriginalControls;
592}
593AFX_INLINE CXTPCommandBar* CXTPControls::GetParent() const
594{
595 return m_pParent;
596}
597AFX_INLINE BOOL CXTPControls::IsOriginalControls() const
598{
599 return m_bOriginalControls;
600}
602# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
603#endif // #if !defined(__XTPCONTROLS_H__)
XTPControlType
XTPControlType
Type of the control.
Definition XTPCommandBarsDefines.h:111
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPControls::GetCount
int GetCount() const
Call this member to get the count of the controls.
Definition XTPControls.h:585
CXTPControls::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControls::SetParent
void SetParent(CXTPCommandBar *pParent)
Attaches the parent command bar.
CXTPControls::GetVisibleCount
int GetVisibleCount(BOOL bIgnoreWrap=FALSE) const
Call this member to get the number of visible controls.
CXTPControls::m_bOriginalControls
BOOL m_bOriginalControls
TRUE if all controls are original and unmodified.
Definition XTPControls.h:513
CXTPControls::m_arrControls
CArray< CXTPControl *, CXTPControl * > m_arrControls
Collection of controls.
Definition XTPControls.h:510
CXTPControls::m_pParent
CXTPCommandBar * m_pParent
Parent Command Bar.
Definition XTPControls.h:509
CXTPControls::LoadMenu
BOOL LoadMenu(CMenu *pMenu)
Call this member to convert menu items to command bar controls.
CXTPControls::OnControlAdded
virtual void OnControlAdded(CXTPControl *pControl)
This method is called when a control is added to the collection.
CXTPControls::m_pOriginalControls
CXTPOriginalControls * m_pOriginalControls
Original controls collection.
Definition XTPControls.h:512
CXTPControls::GetNext
void GetNext(CXTPControl *&pControl) const
Finds the next control in the given direction.
CXTPControls::CalcDynamicSize
CSize CalcDynamicSize(CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0)
This method is called internally to reposition controls and determine their size.
CXTPControls::AddMenuItem
CXTPControl * AddMenuItem(CMenu *pMenu, int nIndex)
Call this member to add a new control.
CXTPControls::GetParent
CXTPCommandBar * GetParent() const
Call this member to get the parent command bar.
Definition XTPControls.h:593
CXTPControls::CreateOriginalControls
void CreateOriginalControls()
Creates the original controls set.
CXTPControls::~CXTPControls
virtual ~CXTPControls()
Destroys a CXTPControls object, handles cleanup and deallocation.
CXTPControls::GetOriginalControls
CXTPOriginalControls * GetOriginalControls() const
Retrieves the original controls set.
Definition XTPControls.h:589
CXTPControls::Add
CXTPControl * Add(CXTPControl *pControl)
Call this member to add a new control.
CXTPControls::GetFirst
CXTPControl * GetFirst() const
Call this member to retrieve the first control.
CXTPControls::Remove
void Remove(int nIndex)
Call this member to remove a control.
CXTPControls::InsertAt
CXTPControl * InsertAt(CXTPControl *pControl, int nBefore)
Call this member to insert a new control.
CXTPControls::HitTest
CXTPControl * HitTest(CPoint point) const
This member function determines which control, if any, is at a specified point.
CXTPControls::CommandToIndex
int CommandToIndex(int nIDFind) const
This member function returns the index of the first control, starting at position 0,...
CXTPControls::Duplicate
CXTPControls * Duplicate(BOOL bRecursive=FALSE)
Makes a copy of all controls.
CXTPControls::FindControl
CXTPControl * FindControl(int nId) const
Call this member to find the specified control.
CXTPControls::CalcPopupSize
CSize CalcPopupSize(CDC *pDC, int nLength, int nWidth, const CRect &rcBorder)
This method is called internally to reposition controls and determine their size for a pop-up bar.
CXTPControls::RemoveAll
void RemoveAll()
Call this member to remove all controls.
CXTPControls::GetNext
long GetNext(long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const
Finds the next control in the given direction.
CXTPControls::ClearOriginalControls
void ClearOriginalControls()
Removes the original controls set.
CXTPControls::Copy
virtual void Copy(CXTPControls *pControls, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControls::SetControlType
CXTPControl * SetControlType(int nIndex, XTPControlType type)
Call this member to change the type of the control.
CXTPControls::Compare
BOOL Compare(const CXTPControls *pControls)
Call this member to compare the controls.
CXTPControls::IsOriginalControls
BOOL IsOriginalControls() const
Determines if all controls in the collection are original (i.e.
Definition XTPControls.h:597
CXTPControls::Add
CXTPControl * Add(CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControls::GetAt
CXTPControl * GetAt(int nIndex) const
Call this member to return the control at the specified index.
Definition XTPControls.h:580
CXTPControls::m_pCommandBars
CXTPCommandBars * m_pCommandBars
Parent Command Bars.
Definition XTPControls.h:511
CXTPControls::SetOriginalControls
void SetOriginalControls(CXTPOriginalControls *pControls)
Call this method to assign original controls.
CXTPControls::CXTPControls
CXTPControls()
Internal helper structure.
CXTPControls::SetControlType
CXTPControl * SetControlType(CXTPControl *pControl, XTPControlType type)
Call this member to change the type of the control.
CXTPControls::ShouldSerializeControl
virtual BOOL ShouldSerializeControl(CXTPControl *pControl)
Call this method to check if the control has been changed and must be saved.
CXTPControls::IsChanged
BOOL IsChanged() const
Returns the changed status flag of the control.
CXTPControls::SetCommandBars
void SetCommandBars(CXTPCommandBars *pCommandBars)
Call this member to attach the specified command bars object.
CXTPControls::GetVisibleAt
CXTPControl * GetVisibleAt(int nIndex, BOOL bIgnoreWraps=FALSE) const
Finds a specified control by its ID.
CXTPControls::Remove
virtual void Remove(CXTPControl *pControl)
Call this member to remove a control.
CXTPControls::Add
CXTPControl * Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE)
Call this member to add a new control.
CXTPControls::Sort
void Sort()
Sorts the commands list.
CXTPControls::MoveBefore
void MoveBefore(CXTPControl *pControl, int nBefore)
Moves the control to a specified position.
CXTPControls::AddClone
CXTPControl * AddClone(CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE)
Call this member to add a copy of a control.
CXTPControls::OnControlRemoving
virtual BOOL OnControlRemoving(CXTPControl *pControl)
This method is called when a control is about to be removed from the collection.
CXTPControls::GetCommandBars
CXTPCommandBars * GetCommandBars() const
Retrieves the parent command bars object.
CXTPControls::OnControlRemoved
virtual void OnControlRemoved(CXTPControl *pControl)
This method is called when a control is removed from the collection.
CXTPControls::FindControl
CXTPControl * FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const
Call this member to find the specified control.
CXTPMenuBar
CXTPMenuBar is a CXTPToolBar derived class.
Definition XTPMenuBar.h:141
CXTPOriginalControls
CXTPOriginalControls object.
Definition XTPControls.h:564
CXTPOriginalControls::CXTPOriginalControls
CXTPOriginalControls()
Constructs a CXTPOriginalControls object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.
Definition XTPCommandBars.h:88


Toolkit Pro: XTPDockingPanePanelTheme2013.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelTheme2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEME2013_H__)
24# define __XTPDOCKINGPANEPANELTHEME2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelTheme2013 : public CXTPDockingPanePanelTheme2012
39{
40public:
45 CXTPDockingPanePanelTheme2013();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPDOCKINGPANEPANELTHEME2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelTheme2013
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2013.h:39
CXTPDockingPanePanelTheme2013::CXTPDockingPanePanelTheme2013
CXTPDockingPanePanelTheme2013()
Default class constructor.


CXTPChartClipDeviceCommand Member List

This is the complete list of members for CXTPChartClipDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartClipDeviceCommand(CRect rcClip) | CXTPChartClipDeviceCommand | protected
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_rcClip | CXTPChartClipDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


  • CXTPTaskPanel
  • CRepositionContext
CXTPTaskPanel::CRepositionContext Member List

This is the complete list of members for CXTPTaskPanel::CRepositionContext, including all inherited members.

CRepositionContext(CXTPTaskPanel *pTaskPanel) | CXTPTaskPanel::CRepositionContext |
m_pTaskPanel | CXTPTaskPanel::CRepositionContext | protected
~CRepositionContext() | CXTPTaskPanel::CRepositionContext |


Toolkit Pro: XTPTaskPanelAnimation.h Source File

  • Source
  • TaskPanel
XTPTaskPanelAnimation.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELANIMATION_H__)
24# define __XTPTASKPANELANIMATION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34class CXTPTaskPanel;
35
36# define XTP_TID_ANIMATION 0xACD43
37
38class _XTP_EXT_CLASS CXTPTaskPanelAnimation
39{
40protected:
41 struct CAnimateInfo
42 {
43 CAnimateInfo();
44 ~CAnimateInfo();
45
46 HBITMAP hbmSrc;
47 BYTE* pSrcBits;
48
49 HBITMAP hbmSrcBack;
50 BYTE* pSrcBackBits;
51
52 RECT rcPaint;
53 int m_nAnimation;
54 CArray<RECT, RECT&> arrExclude;
55 };
56
57public:
58 CXTPTaskPanelAnimation(CXTPTaskPanel* pTaskPanel);
59 ~CXTPTaskPanelAnimation();
60
61public:
62 void OnPaint(CPaintDC& paintDC);
63 void RedrawRect(LPCRECT lpRect, BOOL bAnimate);
64 void OnAnimate();
65 void OnDestroy();
66
67protected:
68 void RemoveAnimations();
69 void AnimateRect(CClientDC& dc, CAnimateInfo* pai);
70 void RemoveIntersections(LPCRECT rcPaint, BOOL bAddExclude);
71
72 void AlphaBlendU(PBYTE pDest, PBYTE pSrcBack, int cx, int cy, PBYTE pSrc, BYTE byAlpha);
73 void AddAnimation(CClientDC& dc, CAnimateInfo* pai);
74
75 BOOL IsAnimationEnabled() const;
76
77public:
78 CXTPTaskPanel* m_pParent;
79 CBitmap m_bmpCache;
80 BOOL m_bInvalidate;
81 UINT_PTR m_nTimer;
82
83 BOOL m_bAnimation;
84 BOOL m_bDoubleBuffer;
85
86protected:
87 CArray<CAnimateInfo*, CAnimateInfo*> m_arrAnimation;
88};
89
92# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif // !defined(__XTPTASKPANELANIMATION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107


CXTPDockingPaneTabColorSet2022 Member List

This is the complete list of members for CXTPDockingPaneTabColorSet2022, including all inherited members.

CXTPDockingPaneTabColorSet2012() | CXTPDockingPaneTabColorSet2012 |
CXTPDockingPaneTabColorSet2022() | CXTPDockingPaneTabColorSet2022 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPDockingPaneTabColorSet2022 | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPaneTabColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPaneTabColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPaneTabColorSet2012 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPEditThemeVisualStudio2017.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEVISUALSTUDIO2017_H__)
24# define __XTPEDITTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeVisualStudio2017 : public CXTPEditThemeOffice2013
38{
39public:
44 CXTPEditThemeVisualStudio2017();
45
50 virtual ~CXTPEditThemeVisualStudio2017();
51};
52
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // __XTPEDITTHEMEVISUALSTUDIO2017_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2013.h:38
CXTPEditThemeVisualStudio2017
CXTPEditThemeVisualStudio2017 is a class used to perform theme drawing tasks.
Definition XTPEditThemeVisualStudio2017.h:38
CXTPEditThemeVisualStudio2017::~CXTPEditThemeVisualStudio2017
virtual ~CXTPEditThemeVisualStudio2017()
Destructor, handles cleanup and deallocation.
CXTPEditThemeVisualStudio2017::CXTPEditThemeVisualStudio2017
CXTPEditThemeVisualStudio2017()
Constructs a CXTPEditThemeVisualStudio2017 object.


CXTPChartAxisY Member List

This is the complete list of members for CXTPChartAxisY, including all inherited members.

CalcSideMarginsValue(double nMinValue, double nMaxValue) const | CXTPChartAxisY | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParentView) | CXTPChartAxisY | protectedvirtual
CXTPChartAxis(CXTPChartDiagram *pDiagram) | CXTPChartAxis |
CXTPChartAxisY(CXTPChartDiagram2D *pDiagram) | CXTPChartAxisY |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxis | virtual
GetActualColor() const | CXTPChartAxis |
GetActualInterlacedColor() const | CXTPChartAxis |
GetActualInterlacedColor2() const | CXTPChartAxis |
GetAlignment() const | CXTPChartAxis |
GetAppearance() const | CXTPChartAxis |
GetColor() const | CXTPChartAxis |
GetConstantLines() const | CXTPChartAxis |
GetContent() const | CXTPChartElement |
GetCustomLabels() const | CXTPChartAxis |
GetDiagram() const | CXTPChartAxis |
GetGridLines() const | CXTPChartAxis |
GetGridSpacing() const | CXTPChartAxis |
GetIndex() const | CXTPChartAxis |
GetInterlacedColor() const | CXTPChartAxis |
GetInterlacedColor2() const | CXTPChartAxis |
GetInterlacedFillStyle() const | CXTPChartAxis |
GetLabel() const | CXTPChartAxis |
GetMinorCount() const | CXTPChartAxis |
GetOwner() const | CXTPChartElement |
GetRange() const | CXTPChartAxis |
GetScaleType() const | CXTPChartAxis |
GetScaleTypeMap() const | CXTPChartAxis |
GetStrips() const | CXTPChartAxis |
GetThickness() const | CXTPChartAxis |
GetTickMarks() const | CXTPChartAxis |
GetTitle() const | CXTPChartAxis |
Is3D() const | CXTPChartObject |
IsInterlaced() const | CXTPChartAxis |
IsReversed() const | CXTPChartAxis |
IsValuesAxis() const | CXTPChartAxisY | virtual
IsVertical() const | CXTPChartAxisY | virtual
IsVisible() const | CXTPChartAxis |
m_bGridSpacingAuto | CXTPChartAxis | protected
m_bInterlaced | CXTPChartAxis | protected
m_bLogarithmic | CXTPChartAxis | protected
m_bReversed | CXTPChartAxis | protected
m_bVisible | CXTPChartAxis | protected
m_clrColor | CXTPChartAxis | protected
m_clrInterlacedColor | CXTPChartAxis | protected
m_clrInterlacedColor2 | CXTPChartAxis | protected
m_dGridSpacing | CXTPChartAxis | protected
m_dLogarithmicBase | CXTPChartAxis | protected
m_nAlignment | CXTPChartAxis | protected
m_nMinorCount | CXTPChartAxis | protected
m_nScaleType | CXTPChartAxis | protected
m_nThickness | CXTPChartAxis | protected
m_pConstantLines | CXTPChartAxis | protected
m_pCustomLabels | CXTPChartAxis | protected
m_pDiagram | CXTPChartAxis | protected
m_pGridLines | CXTPChartAxis | protected
m_pInterlacedFillStyle | CXTPChartAxis | protected
m_pLabel | CXTPChartAxis | protected
m_pRange | CXTPChartAxis | protected
m_pScaleTypeMap | CXTPChartAxis | protected
m_pStrips | CXTPChartAxis | protected
m_pTickMarks | CXTPChartAxis | protected
m_pTitle | CXTPChartAxis | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAlignment(XTPChartAxisAlignment nAlignment) | CXTPChartAxis |
SetColor(const CXTPChartColor &color) | CXTPChartAxis |
SetDateTimeScaleUnit(XTPChartAxisDateTimeScaleUnit unit) | CXTPChartAxis |
SetGridSpacing(double dGridSpacing) | CXTPChartAxis |
SetGridSpacingAuto(BOOL bGridSpacingAuto) | CXTPChartAxis |
SetIndex(int nIndex) | CXTPChartAxis |
SetInterlaced(BOOL bInterlaced) | CXTPChartAxis |
SetInterlacedColor(const CXTPChartColor &color) | CXTPChartAxis |
SetInterlacedColor2(const CXTPChartColor &color) | CXTPChartAxis |
SetLogarithmic(BOOL bLogarithmic) | CXTPChartAxis |
SetLogarithmicBase(double dLogarithmicBase) | CXTPChartAxis |
SetMinorCount(int nMinorCount) | CXTPChartAxis |
SetReversed(BOOL bRevered) | CXTPChartAxis |
SetThickness(int nThicknes) | CXTPChartAxis |
SetVisible(BOOL bVisible) | CXTPChartAxis |
UpdateRange(CXTPChartDeviceContext *pDC, CXTPChartAxisView *pView) | CXTPChartAxis |
~CXTPChartAxis() | CXTPChartAxis | virtual
~CXTPChartElement() | CXTPChartElement | virtual


CXTPFontComboBox Member List

This is the complete list of members for CXTPFontComboBox, including all inherited members.

CreateUIFont(CFont &font) | CXTPFontCtrlBase | static
CXTPComboBox() | CXTPComboBox |
CXTPFontComboBox() | CXTPFontComboBox |
CXTPFontCtrlBase() | CXTPFontCtrlBase |
EnableAutoCompletion(BOOL bEnable=TRUE) | CXTPComboBox |
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPComboBox |
GetBackColor() const | CXTPComboBox |
GetClientBrush(CDC *pDC) | CXTPComboBox |
GetComboBoxRect() const | CXTPComboBox |
GetFlatStyle() const | CXTPComboBox |
GetFontItemHeight() | CXTPFontCtrlBase | static
GetSelFont(CXTPLogFont &lf) | CXTPFontCtrlBase | virtual
GetSelFont(CString &strFaceName) | CXTPFontCtrlBase | virtual
GetTextColor() const | CXTPComboBox |
GetTheme() | CXTPComboBox |
GetTheme() const | CXTPComboBox |
GetUseVisualStyle() const | CXTPComboBox |
InitControl(LPCTSTR lpszFaceName=NULL, UINT nWidth=0, BOOL bEnable=TRUE) | CXTPFontComboBox | virtual
Initialize(bool bAutoFont=true) | CXTPComboBox | virtual
IsDroppedDown() const | CXTPComboBox |
IsFocused() const | CXTPComboBox |
IsHighlighted() const | CXTPComboBox |
m_bAutoComp | CXTPComboBox | protected
m_bDisableAC | CXTPComboBox | protected
m_bEnableMarkup | CXTPComboBox | protected
m_bFlatStyle | CXTPComboBox | protected
m_bFocused | CXTPComboBox | protected
m_bHighlighted | CXTPComboBox | protected
m_bPreSubclassInit | CXTPComboBox | protected
m_bUseVisualStyle | CXTPComboBox | protected
m_csSymbol | CXTPFontCtrlBase | protected
m_dwStyle | CXTPFontCtrlBase | protected
m_pComboBox | CXTPFontCtrlBase | protected
m_pListBox | CXTPFontCtrlBase | protected
m_pMarkupContext | CXTPComboBox | protected
m_pTheme | CXTPComboBox | protected
m_pWndEdit | CXTPComboBox | protected
NeedRedraw() | CXTPComboBox | protected
NotifyOwner(UINT nCode) | CXTPFontComboBox | protectedvirtual
OnCompareItem(LPCOMPAREITEMSTRUCT lpCIS) | CXTPFontCtrlBase | protectedvirtual
OnDrawItem(LPDRAWITEMSTRUCT lpDIS) | CXTPFontCtrlBase | protectedvirtual
OnInit(CXTPFontListBox *pListBox) | CXTPFontCtrlBase | protectedvirtual
OnInit(CXTPFontComboBox *pComboBox) | CXTPFontCtrlBase | protectedvirtual
OnMeasureItem(LPMEASUREITEMSTRUCT lpMIS) | CXTPFontCtrlBase | protectedvirtual
RedrawComboBox(BOOL bUpdateWindow=FALSE) | CXTPComboBox |
RedrawFocusedFrame() | CXTPComboBox | protected
RefreshMetrics() | CXTPComboBox |
SetBackColor(COLORREF crBack) | CXTPComboBox | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPComboBox |
SetHighlighted(BOOL bHot) | CXTPComboBox |
SetListStyle(DWORD dwStyle) | CXTPFontComboBox |
SetSelFont(CXTPLogFont &lf) | CXTPFontCtrlBase | virtual
SetSelFont(const CString &strFaceName) | CXTPFontCtrlBase | virtual
SetTextColor(COLORREF crText) | CXTPComboBox | virtual
SetTheme(XTPControlTheme nTheme) | CXTPComboBox |
SetTheme(CXTPComboBoxTheme *pTheme) | CXTPComboBox | virtual
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPComboBox |
~CXTPComboBox() | CXTPComboBox | virtual
~CXTPFontComboBox() | CXTPFontComboBox | virtual
~CXTPFontCtrlBase() | CXTPFontCtrlBase | virtual


Toolkit Pro: XTPPropExchange.h Source File

  • Source
  • Common
XTPPropExchange.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGE_H__)
24# define __XTPPROPEXCHANGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/XTPPropExchange.inc"
32
33# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
34
35# define XTP_LOCALE_ISO8601 ((LCID)-1)
36
37class CXTPPropExchange;
38class CXTPPropExchangeEnumerator;
39
40template<class T>
41class CXTPPoint3T;
42
43enum VARTYPE_EX
44{
45 VT_EX_RECT = 100,
46 VT_EX_SIZE = 101
47};
48
71class _XTP_EXT_CLASS CXTPPropExchange : public CXTPCmdTarget
72{
74 DECLARE_DYNAMIC(CXTPPropExchange)
76public:
81 CXTPPropExchange();
82
88 virtual ~CXTPPropExchange();
89
90public:
98 BOOL IsLoading() const;
99
107 BOOL IsStoring() const;
108
116 void UseDefaultOnLoad(BOOL bUseDefaultOnLoad = TRUE);
117
125 void UseDefaultOnSave(BOOL bUseDefaultOnSave = TRUE);
126
137 BOOL IsRootSection() const;
138
151 UINT GetSchema() const;
152
164 void SetSchema(UINT nSchemaVersion);
165
190 virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void* pvProp,
191 const void* pvDefault = NULL) = 0;
192
203 virtual BOOL ExchangeBlobProp(LPCTSTR pszPropName, BYTE*& pData, DWORD& nBytes);
204
214 virtual BOOL ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass*& pClass,
215 CRuntimeClass* pDefaultClass);
216
225 virtual BOOL ExchangeObjectInstance(CObject*& pObject, CRuntimeClass* pObjectRuntime);
226
236 virtual CArchive* GetArchive(LPCTSTR pszPropName);
237
246 virtual void ReleaseArchive(LPCTSTR pszPropName, CArchive* pArchive);
247
252 void ExchangeSchema();
253
258 void ExchangeLocale();
259
275 virtual CXTPPropExchange* GetSection(LPCTSTR lpszSection) = 0;
276
281 virtual void EmptySection();
282
290 virtual void WriteCount(DWORD dwCount);
291
300 virtual DWORD ReadCount();
301
309 virtual void Write(LPCTSTR pszPropName, const void* lpBuf, UINT nCount);
310
321 virtual UINT Read(LPCTSTR pszPropName, void* lpBuf, UINT nCount);
322
329 virtual BOOL IsAllowDefaultValues() const;
330
337 virtual BOOL IsAllowBlobValues() const;
338
345 virtual BOOL OnBeforeExchange();
346
369 virtual CXTPPropExchangeEnumerator* GetEnumerator(LPCTSTR lpszSection);
370
371public:
372 static void AFX_CDECL BinToString(BYTE* pData, DWORD nBytes, CString& str);
373 static BOOL AFX_CDECL StringToBin(const CString& str, BYTE*& pData, DWORD& nBytes);
374
375protected:
381 void InitSection(CXTPPropExchange* pRootSection);
382
384public:
385 static void AFX_CDECL PreformatString(CString& strValue, BOOL bLoading);
386
387 virtual void ExchangeSchemaSafe();
388
389protected:
390 DWORD GetSizeOfVarType(VARTYPE vt);
391 BOOL IsSamePropValue(VARTYPE vtProp, const void* pv1, const void* pv2);
392 BOOL CopyPropValue(VARTYPE vtProp, void* pvDest, const void* pvSrc);
393
394 BOOL ExchangePropStringHelper(CString& strValue, VARTYPE vtProp, void* pvProp,
395 const void* pvDefault);
396 BOOL ExchangePropDateHelper(CString& strValue, COleDateTime& dt);
397 void PreformatString(CString& strValue);
398 void PreformatString(BSTR bstrValue);
399
400public:
401 static CRuntimeClass* AFX_CDECL FindRuntimeClass(LPCSTR szClassName);
404public:
405 DWORD_PTR m_dwData;
406 CObject* m_pOwner;
407 static LCID m_lcidDateTime;
409protected:
410 BOOL m_bLoading;
411 UINT m_nSchema;
412 BOOL m_bChildSection;
413 BOOL m_bEmptySection;
414 BOOL m_bInitialized;
415 BOOL m_bUseDefaultOnLoad;
416 BOOL m_bUseDefaultOnSave;
417};
418
435_XTP_EXT_CLASS BOOL AFX_CDECL PX_Byte(CXTPPropExchange* pPX, LPCTSTR pszPropName, BYTE& nValue,
436 BYTE nDefault);
437
453_XTP_EXT_CLASS BOOL AFX_CDECL PX_Short(CXTPPropExchange* pPX, LPCTSTR pszPropName, short& sValue);
454
471_XTP_EXT_CLASS BOOL AFX_CDECL PX_Short(CXTPPropExchange* pPX, LPCTSTR pszPropName, short& sValue,
472 short sDefault);
473
489_XTP_EXT_CLASS BOOL AFX_CDECL PX_UShort(CXTPPropExchange* pPX, LPCTSTR pszPropName,
490 USHORT& usValue);
491
508_XTP_EXT_CLASS BOOL AFX_CDECL PX_UShort(CXTPPropExchange* pPX, LPCTSTR pszPropName, USHORT& usValue,
509 USHORT usDefault);
510
526_XTP_EXT_CLASS BOOL AFX_CDECL PX_Long(CXTPPropExchange* pPX, LPCTSTR pszPropName, long& lValue);
527
544_XTP_EXT_CLASS BOOL AFX_CDECL PX_Long(CXTPPropExchange* pPX, LPCTSTR pszPropName, long& lValue,
545 long lDefault);
546
562_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Long(CXTPPropExchange* pPX, LPCTSTR pszPropName,
563 long& lValue);
564
581_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Long(CXTPPropExchange* pPX, LPCTSTR pszPropName,
582 long& lValue, long lDefault);
583
599_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Long(CXTPPropExchange* pPX, LPCTSTR pszPropName,
600 long& lValue);
601
618_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Long(CXTPPropExchange* pPX, LPCTSTR pszPropName,
619 long& lValue, long lDefault);
620
636_XTP_EXT_CLASS BOOL AFX_CDECL PX_DWord(CXTPPropExchange* pPX, LPCTSTR pszPropName, DWORD& dwValue);
637
654_XTP_EXT_CLASS BOOL AFX_CDECL PX_DWord(CXTPPropExchange* pPX, LPCTSTR pszPropName, DWORD& dwValue,
655 DWORD dwDefault);
656
673_XTP_EXT_CLASS BOOL AFX_CDECL PX_UI8(CXTPPropExchange* pPX, LPCTSTR pszPropName,
674 ULONGLONG& ullValue, ULONGLONG ullDefault);
675
692_XTP_EXT_CLASS BOOL AFX_CDECL PX_Int(CXTPPropExchange* pPX, LPCTSTR pszPropName, int& nValue);
693
709_XTP_EXT_CLASS BOOL AFX_CDECL PX_Int(CXTPPropExchange* pPX, LPCTSTR pszPropName, int& nValue,
710 int nDefault);
725_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Int(CXTPPropExchange* pPX, LPCTSTR pszPropName, int& nValue);
726
742_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Int(CXTPPropExchange* pPX, LPCTSTR pszPropName, int& nValue,
743 int nDefault);
758_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Int(CXTPPropExchange* pPX, LPCTSTR pszPropName, int& nValue);
759
775_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Int(CXTPPropExchange* pPX, LPCTSTR pszPropName, int& nValue,
776 int nDefault);
777
793_XTP_EXT_CLASS BOOL AFX_CDECL PX_ULong(CXTPPropExchange* pPX, LPCTSTR pszPropName, ULONG& ulValue);
794
811_XTP_EXT_CLASS BOOL AFX_CDECL PX_ULong(CXTPPropExchange* pPX, LPCTSTR pszPropName, ULONG& ulValue,
812 ULONG ulDefault);
813
829_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bool(CXTPPropExchange* pPX, LPCTSTR pszPropName, BOOL& bValue);
830
847_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bool(CXTPPropExchange* pPX, LPCTSTR pszPropName, BOOL& bValue,
848 BOOL bDefault);
849
865_XTP_EXT_CLASS BOOL AFX_CDECL PX_String(CXTPPropExchange* pPX, LPCTSTR pszPropName,
866 CString& strValue);
867
884_XTP_EXT_CLASS BOOL AFX_CDECL PX_String(CXTPPropExchange* pPX, LPCTSTR pszPropName,
885 CString& strValue, LPCTSTR lpszDefault);
886
903_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bstr(CXTPPropExchange* pPX, LPCTSTR pszPropName, BSTR& bstrValue,
904 BSTR bstrDefault);
905
921_XTP_EXT_CLASS BOOL AFX_CDECL PX_Float(CXTPPropExchange* pPX, LPCTSTR pszPropName,
922 float& floatValue);
923
940_XTP_EXT_CLASS BOOL AFX_CDECL PX_Float(CXTPPropExchange* pPX, LPCTSTR pszPropName,
941 float& floatValue, float floatDefault);
942
958_XTP_EXT_CLASS BOOL AFX_CDECL PX_Double(CXTPPropExchange* pPX, LPCTSTR pszPropName,
959 double& doubleValue);
960
977_XTP_EXT_CLASS BOOL AFX_CDECL PX_Double(CXTPPropExchange* pPX, LPCTSTR pszPropName,
978 double& doubleValue, double doubleDefault);
979
997_XTP_EXT_CLASS BOOL AFX_CDECL PX_Size(CXTPPropExchange* pPX, LPCTSTR pszPropName, SIZE& szValue,
998 SIZE szDefault);
999
1017_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Size(CXTPPropExchange* pPX, LPCTSTR pszPropName, SIZE& szValue,
1018 SIZE szDefault);
1019
1037_XTP_EXT_CLASS BOOL AFX_CDECL PX_Rect(CXTPPropExchange* pPX, LPCTSTR pszPropName, RECT& rcValue,
1038 RECT rcDefault);
1039
1057_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Rect(CXTPPropExchange* pPX, LPCTSTR pszPropName, RECT& rcValue,
1058 RECT rcDefault);
1059
1077_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point(CXTPPropExchange* pPX, LPCTSTR pszPropName, POINT& ptValue,
1078 POINT ptDefault);
1079
1097_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Point(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1098 POINT& ptValue, POINT ptDefault);
1099
1117_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1118 CXTPPoint3T<float>& ptValue, CXTPPoint3T<float> ptDefault);
1119
1137_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1138 CXTPPoint3T<double>& ptValue, CXTPPoint3T<double> ptDefault);
1139
1157_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1158 CXTPPoint3T<int>& ptValue, CXTPPoint3T<int> ptDefault);
1159
1173_XTP_EXT_CLASS BOOL AFX_CDECL PX_DateTime(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1174 COleDateTime& dtValue);
1175
1192_XTP_EXT_CLASS BOOL AFX_CDECL PX_RuntimeClass(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1193 CRuntimeClass*& pClass, CRuntimeClass* pDefaultClass);
1194
1206_XTP_EXT_CLASS BOOL AFX_CDECL PX_Serialize(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1207 CObject* pObject);
1208
1221_XTP_EXT_CLASS BOOL AFX_CDECL PX_Blob(CXTPPropExchange* pPX, LPCTSTR pszPropName, BYTE*& pData,
1222 DWORD& nBytes);
1223
1240_XTP_EXT_CLASS BOOL AFX_CDECL PX_Variant(CXTPPropExchange* pPX, LPCTSTR pszPropName,
1241 COleVariant& variant, COleVariant variantDefault);
1242
1259template<class TEnum>
1260AFX_INLINE BOOL AFX_CDECL PX_Enum(CXTPPropExchange* pPX, LPCTSTR pszPropName, TEnum& nValue,
1261 TEnum nDefault)
1262{
1263 _ASSERTE(sizeof(TEnum) == sizeof(int));
1264 return PX_Int(pPX, pszPropName, (int&)nValue, (int)nDefault);
1265}
1266
1279template<class TObject>
1280AFX_INLINE BOOL AFX_CDECL PX_Object(CXTPPropExchange* pPX, LPCTSTR pszPropName, TObject*& pObject,
1281 CRuntimeClass* pObjectRuntime)
1282{
1283 CXTPPropExchangeSection secObject(pPX->GetSection(pszPropName));
1284 if (!secObject->ExchangeObjectInstance((CObject*&)pObject, pObjectRuntime))
1285 return FALSE;
1286 pObject->DoPropExchange(&secObject);
1287 return TRUE;
1288}
1289template<class TObject>
1290AFX_INLINE BOOL AFX_CDECL PX_Object(CXTPPropExchange* pPX, TObject*& pObject,
1291 CRuntimeClass* pObjectRuntime)
1292{
1293 if (!pPX->ExchangeObjectInstance((CObject*&)pObject, pObjectRuntime))
1294 return FALSE;
1295 pObject->DoPropExchange(pPX);
1296 return TRUE;
1297}
1298
1300AFX_INLINE BOOL CXTPPropExchange::OnBeforeExchange()
1301{
1302 m_bInitialized = TRUE;
1303 return TRUE;
1304}
1305AFX_INLINE void CXTPPropExchange::UseDefaultOnLoad(BOOL bUseDefaultOnLoad)
1306{
1307 m_bUseDefaultOnLoad = bUseDefaultOnLoad;
1308}
1309
1310AFX_INLINE void CXTPPropExchange::UseDefaultOnSave(BOOL bUseDefaultOnSave)
1311{
1312 m_bUseDefaultOnSave = bUseDefaultOnSave;
1313}
1314
1315AFX_INLINE BOOL CXTPPropExchange::IsLoading() const
1316{
1317 return m_bLoading;
1318}
1319AFX_INLINE BOOL CXTPPropExchange::IsStoring() const
1320{
1321 return !m_bLoading;
1322}
1323AFX_INLINE UINT CXTPPropExchange::GetSchema() const
1324{
1325 return m_nSchema;
1326}
1327void AFX_INLINE CXTPPropExchange::SetSchema(UINT nSchemaVersion)
1328{
1329 m_nSchema = nSchemaVersion;
1330}
1331AFX_INLINE BOOL CXTPPropExchange::IsRootSection() const
1332{
1333 return !m_bChildSection;
1334}
1335AFX_INLINE BOOL CXTPPropExchange::IsAllowDefaultValues() const
1336{
1337 return TRUE;
1338}
1339AFX_INLINE BOOL CXTPPropExchange::IsAllowBlobValues() const
1340{
1341 return FALSE;
1342}
1344# ifdef _XTP_ACTIVEX
1346extern CXTPPropExchange* AFX_CDECL PropExchangeFromControl(LPDISPATCH lpDispatch);
1348# endif
1349
1350# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1352#endif // #if !defined(__XTPPROPEXCHANGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
PX_Variant
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Variant(CXTPPropExchange *pPX, LPCTSTR pszPropName, COleVariant &variant, COleVariant variantDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DPI_Point
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Point(CXTPPropExchange *pPX, LPCTSTR pszPropName, POINT &ptValue, POINT ptDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DPI_Size
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Size(CXTPPropExchange *pPX, LPCTSTR pszPropName, SIZE &szValue, SIZE szDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Float
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Float(CXTPPropExchange *pPX, LPCTSTR pszPropName, float &floatValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Enum
AFX_INLINE BOOL AFX_CDECL PX_Enum(CXTPPropExchange *pPX, LPCTSTR pszPropName, TEnum &nValue, TEnum nDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize an e...
Definition XTPPropExchange.h:1260
PX_String
_XTP_EXT_CLASS BOOL AFX_CDECL PX_String(CXTPPropExchange *pPX, LPCTSTR pszPropName, CString &strValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a ch...
PX_Short
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Short(CXTPPropExchange *pPX, LPCTSTR pszPropName, short &sValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Byte
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Byte(CXTPPropExchange *pPX, LPCTSTR pszPropName, BYTE &nValue, BYTE nDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Rect
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Rect(CXTPPropExchange *pPX, LPCTSTR pszPropName, RECT &rcValue, RECT rcDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_UI8
_XTP_EXT_CLASS BOOL AFX_CDECL PX_UI8(CXTPPropExchange *pPX, LPCTSTR pszPropName, ULONGLONG &ullValue, ULONGLONG ullDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_UShort
_XTP_EXT_CLASS BOOL AFX_CDECL PX_UShort(CXTPPropExchange *pPX, LPCTSTR pszPropName, USHORT &usValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Size
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Size(CXTPPropExchange *pPX, LPCTSTR pszPropName, SIZE &szValue, SIZE szDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Int
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Int(CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Double
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Double(CXTPPropExchange *pPX, LPCTSTR pszPropName, double &doubleValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_RuntimeClass
_XTP_EXT_CLASS BOOL AFX_CDECL PX_RuntimeClass(CXTPPropExchange *pPX, LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DPI_Rect
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Rect(CXTPPropExchange *pPX, LPCTSTR pszPropName, RECT &rcValue, RECT rcDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Blob
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Blob(CXTPPropExchange *pPX, LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
Call this function within your class's DoPropExchange member function to serialize a BYTE array.
PX_Serialize
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Serialize(CXTPPropExchange *pPX, LPCTSTR pszPropName, CObject *pObject)
Call this function within your class's DoPropExchange member function to serialize an object.
PX_Point
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Point(CXTPPropExchange *pPX, LPCTSTR pszPropName, POINT &ptValue, POINT ptDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Bstr
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bstr(CXTPPropExchange *pPX, LPCTSTR pszPropName, BSTR &bstrValue, BSTR bstrDefault)
Call this function within your class's DoPropExchange member function to serialize or initialize a ch...
PX_DPI_Y_Int
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Int(CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DWord
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DWord(CXTPPropExchange *pPX, LPCTSTR pszPropName, DWORD &dwValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DPI_X_Long
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Long(CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DPI_X_Int
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_X_Int(CXTPPropExchange *pPX, LPCTSTR pszPropName, int &nValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Long
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Long(CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DPI_Y_Long
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DPI_Y_Long(CXTPPropExchange *pPX, LPCTSTR pszPropName, long &lValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_ULong
_XTP_EXT_CLASS BOOL AFX_CDECL PX_ULong(CXTPPropExchange *pPX, LPCTSTR pszPropName, ULONG &ulValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Bool
_XTP_EXT_CLASS BOOL AFX_CDECL PX_Bool(CXTPPropExchange *pPX, LPCTSTR pszPropName, BOOL &bValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_DateTime
_XTP_EXT_CLASS BOOL AFX_CDECL PX_DateTime(CXTPPropExchange *pPX, LPCTSTR pszPropName, COleDateTime &dtValue)
Call this function within your class's DoPropExchange member function to serialize or initialize a pr...
PX_Object
AFX_INLINE BOOL AFX_CDECL PX_Object(CXTPPropExchange *pPX, LPCTSTR pszPropName, TObject *&pObject, CRuntimeClass *pObjectRuntime)
Call this function within your class's DoPropExchange member function to serialize any class that has...
Definition XTPPropExchange.h:1280
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPPoint3T
This class represents a three-dimensional point.
Definition XTPPoint3.h:58
CXTPPropExchangeEnumerator
CXTPPropExchangeEnumerator is standalone class.
Definition XTPPropExchangeEnumerator.h:56
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPPropExchange::~CXTPPropExchange
virtual ~CXTPPropExchange()
Destroys a CXTPPropExchange object, handles cleanup and de- allocation.
CXTPPropExchange::IsRootSection
BOOL IsRootSection() const
Determines if CXTPPropExchange is used as root section.
CXTPPropExchange::ExchangeRuntimeClass
virtual BOOL ExchangeRuntimeClass(LPCTSTR pszPropName, CRuntimeClass *&pClass, CRuntimeClass *pDefaultClass)
Exchanges a CRuntimeClass between a storage and the class.
CXTPPropExchange::Write
virtual void Write(LPCTSTR pszPropName, const void *lpBuf, UINT nCount)
Writes a specified number of bytes.
CXTPPropExchange::ReleaseArchive
virtual void ReleaseArchive(LPCTSTR pszPropName, CArchive *pArchive)
This method releases CArchive pointer.
CXTPPropExchange::m_bUseDefaultOnLoad
BOOL m_bUseDefaultOnLoad
TRUE if default values must be used in load process.
Definition XTPPropExchange.h:415
CXTPPropExchange::ExchangeBlobProp
virtual BOOL ExchangeBlobProp(LPCTSTR pszPropName, BYTE *&pData, DWORD &nBytes)
This method serializes a property that stores binary large object (BLOB) data.
CXTPPropExchange::m_bInitialized
BOOL m_bInitialized
TRUE if section was initialized.
Definition XTPPropExchange.h:414
CXTPPropExchange::ExchangeSchema
void ExchangeSchema()
Call this function to serialize or initialize the state of a class's version information.
CXTPPropExchange::WriteCount
virtual void WriteCount(DWORD dwCount)
Use this member function to Write DWORD number to storage.
CXTPPropExchange::EmptySection
virtual void EmptySection()
Call this method to free section information before storing.
CXTPPropExchange::GetArchive
virtual CArchive * GetArchive(LPCTSTR pszPropName)
This method create new Archive to serialize.
CXTPPropExchange::CXTPPropExchange
CXTPPropExchange()
Constructs a CXTPPropExchange object.
CXTPPropExchange::m_bLoading
BOOL m_bLoading
TRUE if properties are being loaded to the class.
Definition XTPPropExchange.h:410
CXTPPropExchange::UseDefaultOnLoad
void UseDefaultOnLoad(BOOL bUseDefaultOnLoad=TRUE)
Call this method to use default values specified in PX_* functions while load process.
CXTPPropExchange::IsAllowDefaultValues
virtual BOOL IsAllowDefaultValues() const
Call this method to determine if storage supported default values.
CXTPPropExchange::SetSchema
void SetSchema(UINT nSchemaVersion)
Sets schema version number associated with the data format being serialized/de-serialized.
CXTPPropExchange::IsStoring
BOOL IsStoring() const
This method determines whether properties are being loaded to the class or stored from it.
CXTPPropExchange::UseDefaultOnSave
void UseDefaultOnSave(BOOL bUseDefaultOnSave=TRUE)
Call this method to use default values specified in PX_* functions while save process.
CXTPPropExchange::OnBeforeExchange
virtual BOOL OnBeforeExchange()
This method is called before exchange properties.
CXTPPropExchange::m_lcidDateTime
static LCID m_lcidDateTime
User regional language.
Definition XTPPropExchange.h:407
CXTPPropExchange::GetSchema
UINT GetSchema() const
Gets schema version number associated with the data format being serialized/de-serialized.
CXTPPropExchange::GetEnumerator
virtual CXTPPropExchangeEnumerator * GetEnumerator(LPCTSTR lpszSection)
Call this method to enumerate child sections.
CXTPPropExchange::ExchangeLocale
void ExchangeLocale()
Call this function to serialize or initialize the state of a user locale.
CXTPPropExchange::ExchangeObjectInstance
virtual BOOL ExchangeObjectInstance(CObject *&pObject, CRuntimeClass *pObjectRuntime)
Exchanges a class instance.
CXTPPropExchange::InitSection
void InitSection(CXTPPropExchange *pRootSection)
This methods is called to copy internal data from root section.
CXTPPropExchange::m_bEmptySection
BOOL m_bEmptySection
TRUE if EmptySection method was called.
Definition XTPPropExchange.h:413
CXTPPropExchange::m_bUseDefaultOnSave
BOOL m_bUseDefaultOnSave
TRUE if default values must be used in save process.
Definition XTPPropExchange.h:416
CXTPPropExchange::GetSection
virtual CXTPPropExchange * GetSection(LPCTSTR lpszSection)=0
This method creates new section for text base storages (CXTPPropExchangeXMLNode and CXTPPropExchangeR...
CXTPPropExchange::m_dwData
DWORD_PTR m_dwData
User-defined 32-bit value.
Definition XTPPropExchange.h:405
CXTPPropExchange::m_pOwner
CObject * m_pOwner
User-defined Owner value.
Definition XTPPropExchange.h:406
CXTPPropExchange::Read
virtual UINT Read(LPCTSTR pszPropName, void *lpBuf, UINT nCount)
Reads a specified number of bytes.
CXTPPropExchange::IsLoading
BOOL IsLoading() const
This method determines whether properties are being loaded to the class or stored from it.
CXTPPropExchange::ExchangeProp
virtual BOOL ExchangeProp(LPCTSTR pszPropName, VARTYPE vtProp, void *pvProp, const void *pvDefault=NULL)=0
Exchanges a property between a storage and the class.
CXTPPropExchange::m_bChildSection
BOOL m_bChildSection
TRUE if section is child.
Definition XTPPropExchange.h:412
CXTPPropExchange::m_nSchema
UINT m_nSchema
Schema of object.
Definition XTPPropExchange.h:411
CXTPPropExchange::ReadCount
virtual DWORD ReadCount()
Use this member function to read DWORD number from storage.
CXTPPropExchange::IsAllowBlobValues
virtual BOOL IsAllowBlobValues() const
Call this method to determine if storage allows exchange plain blob values.
CXTPPropExchangeSection
CXTPPropExchangeSection is standalone class.
Definition XTPPropExchangeSection.h:46


CXTPCalendarControlViewPrintOptions Member List

This is the complete list of members for CXTPCalendarControlViewPrintOptions, including all inherited members.

CXTPCalendarControlViewPrintOptions() | CXTPCalendarControlViewPrintOptions |
GetActiveLCID() | CXTPCalendarControlViewPrintOptions | virtual
m_b3SmallCal | CXTPCalendarControlViewPrintOptions |
m_bPrintDateHeader | CXTPCalendarControlViewPrintOptions |
m_bPrintFromToExactly | CXTPCalendarControlViewPrintOptions |
m_dtMonthViewPrintBeginDate | CXTPCalendarControlViewPrintOptions |
m_dtMonthViewPrintEndDate | CXTPCalendarControlViewPrintOptions |
m_dtPrintFrom | CXTPCalendarControlViewPrintOptions |
m_dtPrintTo | CXTPCalendarControlViewPrintOptions |
m_lfDateHeaderCalendarFont | CXTPCalendarControlViewPrintOptions |
m_lfDateHeaderFont | CXTPCalendarControlViewPrintOptions |
m_lfDateHeaderWeekDayFont | CXTPCalendarControlViewPrintOptions |
Set(const CXTPCalendarControlViewPrintOptions *pSrc) | CXTPCalendarControlViewPrintOptions |


XTP_EDIT_NMHDR_EDITCHANGED Member List

This is the complete list of members for XTP_EDIT_NMHDR_EDITCHANGED, including all inherited members.

nAction | XTP_EDIT_NMHDR_EDITCHANGED
nmhdr | XTP_EDIT_NMHDR_EDITCHANGED
nRowFrom | XTP_EDIT_NMHDR_EDITCHANGED
nRowTo | XTP_EDIT_NMHDR_EDITCHANGED


CXTPControlHyperlink Member List

This is the complete list of members for CXTPControlHyperlink, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlHyperlink() | CXTPControlHyperlink |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControlHyperlink | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlHyperlink | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_hCursor | CXTPControlHyperlink | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlHyperlink | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControlHyperlink | protectedvirtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlHyperlink | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


Toolkit Pro: XTPMessageBarThemeNativeWindows11.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMENATIVEWINDOWS11_H__)
24# define __XTPMESSAGEBARTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeNativeWindows11 : public CXTPMessageBarThemeOffice2013
43{
44public:
50 CXTPMessageBarThemeNativeWindows11(CXTPPaintManager* pPaintManager);
51};
52
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // !defined(__XTPMESSAGEBARTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarThemeNativeWindows11
The CXTPMessageBarThemeNativeWindows11 class is used by the message bar to draw a Native Windows 10 s...
Definition XTPMessageBarThemeNativeWindows11.h:43
CXTPMessageBarThemeNativeWindows11::CXTPMessageBarThemeNativeWindows11
CXTPMessageBarThemeNativeWindows11(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style messa...
Definition XTPMessageBarThemeOffice2013.h:43
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


CXTPOpenGLListPool Member List

This is the complete list of members for CXTPOpenGLListPool, including all inherited members.

AllocateList(GLenum mode) | CXTPOpenGLListPool |
CommitList() | CXTPOpenGLListPool |
Instance() | CXTPSingleton< CXTPOpenGLListPool > | inlinestatic
ReclaimList(GLuint id) | CXTPOpenGLListPool |


CXTPSkinManagerResourceFile Member List

This is the complete list of members for CXTPSkinManagerResourceFile, including all inherited members.

Close() | CXTPSkinManagerResourceFile | virtual
CreateSchema() | CXTPSkinManagerResourceFile | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSkinManagerResourceFile(CXTPSkinManager *pSkinManager=NULL) | CXTPSkinManagerResourceFile |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetIniFileName() const | CXTPSkinManagerResourceFile |
GetModuleHandle() const | CXTPSkinManagerResourceFile |
GetResourcePath() const | CXTPSkinManagerResourceFile |
GetSkinManager() const | CXTPSkinManagerResourceFile |
LoadImage(CString strImageFile) | CXTPSkinManagerResourceFile | virtual
m_hInstance | CXTPSkinManagerResourceFile | protected
m_hModule | CXTPSkinManagerResourceFile | protected
m_lpTextFile | CXTPSkinManagerResourceFile | protected
m_lpTextFileEnd | CXTPSkinManagerResourceFile | protected
m_pIniFile | CXTPSkinManagerResourceFile | protected
m_pManager | CXTPSkinManagerResourceFile | protected
m_strIniFileName | CXTPSkinManagerResourceFile | protected
m_strResourcePath | CXTPSkinManagerResourceFile | protected
Open(LPCTSTR lpszResourcePath, LPCTSTR lpszIniFileName) | CXTPSkinManagerResourceFile | virtual
ReadString(CString &str) | CXTPSkinManagerResourceFile | virtual
SetModuleHandle(HMODULE hModule) | CXTPSkinManagerResourceFile |
~CXTPSkinManagerResourceFile() | CXTPSkinManagerResourceFile | virtual


CXTPChartPieSeriesLabelViewBase Member List

This is the complete list of members for CXTPChartPieSeriesLabelViewBase, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateConnectorDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPieSeriesLabelViewBase | pure virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0 | CXTPChartPieSeriesLabelViewBase | pure virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieSeriesLabelViewBase(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView) | CXTPChartPieSeriesLabelViewBase | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
GetPosition() const | CXTPChartPieSeriesLabelViewBase |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


CXTPControlGalleryResourceTheme Member List

This is the complete list of members for CXTPControlGalleryResourceTheme, including all inherited members.

CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
CXTPControlGalleryResourceTheme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryResourceTheme |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryResourceTheme | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryResourceTheme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryResourceTheme | virtual
m_clrControlGalleryBorder | CXTPControlGalleryResourceTheme | protected
m_clrControlGalleryNormal | CXTPControlGalleryResourceTheme | protected
m_clrControlGallerySelected | CXTPControlGalleryResourceTheme | protected
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryResourceTheme | virtual


Toolkit Pro: XTPRibbonPopups.h Source File

  • Source
  • Ribbon
XTPRibbonPopups.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONPOPUPS_H__)
24# define __XTPRIBBONPOPUPS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonQuickAccessControls;
34class CXTPRibbonTab;
35class CXTPRibbonControlTab;
36class CXTPTabPaintManager;
37class CXTPRibbonBar;
38class CXTPRibbonGroup;
39class CXTPCommandBarsFrameHook;
40class CXTPRibbonTabContextHeaders;
41class CXTPRibbonGroups;
42
45class _XTP_EXT_CLASS CXTPRibbonScrollableBar
46{
47public:
48 CXTPRibbonScrollableBar();
49
54 virtual ~CXTPRibbonScrollableBar()
55 {
56 }
57
58private:
59 class CControlGroupsScroll;
60
61protected:
62 void InitScrollableBar(CXTPCommandBar* pParent);
63
64 void ShowScrollableRect(CXTPRibbonGroups* pGroups, CRect rc);
65
66public:
67 void EnableGroupsScroll(BOOL bScrollLeft, BOOL bScrollRight);
68 virtual void OnGroupsScroll(BOOL bScrollLeft) = 0;
69 virtual CRect GetGroupsRect() const = 0;
70 virtual CXTPRibbonGroup* HitTestGroup(CPoint point) const = 0;
71
72 void CreateGroupKeyboardTips(CXTPRibbonTab* pSelectedTab);
73
82 CXTPRibbonGroup* GetHighlightedGroup() const;
83
84 void HighlightGroup(CXTPRibbonGroup* pHighlightedGroup);
85
86protected:
87 void CreateControlKeyboardTips(CXTPControl* pControl, LPCTSTR lpszPrefix, BOOL bVisible);
88
89 BOOL ProcessSpecialKey(XTPSpecialKey key);
90 CRect _GetBoundRect(CXTPControl* pControl, BOOL bSelected, XTPSpecialKey key);
91
92public:
93 int m_nGroupsScrollPos;
95protected:
96 CXTPCommandBar* m_pParent;
97 CXTPControl* m_pControlScrollGroupsLeft;
98 CXTPControl* m_pControlScrollGroupsRight;
99 CXTPRibbonGroup* m_pHighlightedGroup;
100};
101
102_XTP_EXT_CLASS CXTPRibbonScrollableBar* AFX_CDECL GetScrollableBar(CXTPCommandBar* pCommandBar);
103
110class _XTP_EXT_CLASS CXTPRibbonTabPopupToolBar
111 : public CXTPPopupToolBar
112 , public CXTPRibbonScrollableBar
113{
115 DECLARE_DYNAMIC(CXTPRibbonTabPopupToolBar)
117public:
123 CXTPRibbonTabPopupToolBar(CXTPRibbonTab* pRibbonTab);
124
129 ~CXTPRibbonTabPopupToolBar();
130
131public:
138 CRect GetGroupsRect() const;
139
145 void OnGroupsScroll(BOOL bScrollLeft);
146
152 void EnsureVisible(CXTPControl* pControl);
153
158 void CreateKeyboardTips();
159
170 CSize CalcDynamicLayout(int nLength, DWORD nMode);
171
178 void DrawCommandBar(CDC* pDC, CRect rcClipBox);
179
186 virtual CSize GetButtonSize() const;
187
196 virtual CSize GetIconSize() const;
197
206 virtual CRect CalculatePopupRect(CPoint ptPopup, CSize sz);
207
217 CXTPRibbonGroup* HitTestGroup(CPoint point) const;
218
228 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst = TRUE, BOOL bKeyboard = FALSE);
229
235 void OnKeyboardTip(CXTPCommandBarKeyboardTip* pTip);
236
243 BOOL IsKeyboardCuesVisible() const;
244
257 INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
258
259protected:
261 void OnMouseMove(UINT nFlags, CPoint point);
262 afx_msg void OnMouseLeave();
291 virtual BOOL ProcessSpecialKey(XTPSpecialKey key);
292
294 DECLARE_MESSAGE_MAP()
297public:
298 CXTPRibbonTab* m_pRibbonTab;
299 CXTPRibbonBar* m_pRibbonBar;
300 CRect m_rcGroups;
301};
302
305class _XTP_EXT_CLASS CXTPRibbonBarMorePopupToolBar : public CXTPPopupToolBar
306{
307 DECLARE_DYNAMIC(CXTPRibbonBarMorePopupToolBar)
308
309public:
310 CXTPRibbonBarMorePopupToolBar(CXTPRibbonBar* pRibbonBar);
311
312public:
313 void FillCommandBarEntry(CDC* pDC);
314 CSize GetIconSize() const;
315 CSize GetButtonSize() const;
316
317public:
318 CXTPRibbonBar* m_pRibbonBar;
319};
320
321class _XTP_EXT_CLASS CXTPRibbonGroupPopupToolBar
322 : public CXTPPopupToolBar
323 , public CXTPRibbonScrollableBar
324{
325 DECLARE_XTP_COMMANDBAR(CXTPRibbonGroupPopupToolBar)
326public:
327 CXTPRibbonGroupPopupToolBar(CXTPRibbonGroup* pRibbonGroup = NULL);
328 ~CXTPRibbonGroupPopupToolBar();
329
330public:
331 CSize CalcDynamicLayout(int, DWORD /*nMode*/);
332 void DrawCommandBar(CDC* pDC, CRect rcClipBox);
333 void CreateKeyboardTips();
334 CSize GetIconSize() const;
335 CSize GetButtonSize() const;
336 virtual void OnGroupsScroll(BOOL bScrollLeft);
337 virtual CRect GetGroupsRect() const;
338 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst = TRUE, BOOL bKeyboard = FALSE);
339 virtual CXTPRibbonGroup* HitTestGroup(CPoint point) const;
340 BOOL IsKeyboardCuesVisible() const;
341
342protected:
343 void OnMouseMove(UINT nFlags, CPoint point);
344 afx_msg void OnMouseLeave();
345 virtual BOOL ProcessSpecialKey(XTPSpecialKey key);
346
347 DECLARE_MESSAGE_MAP()
348
349public:
350 CXTPRibbonGroup* m_pRibbonGroup;
351 CXTPRibbonBar* m_pRibbonBar;
352
353 CXTPRibbonGroup* m_pParentGroup;
354};
355
358# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
360#endif // !defined(__XTPRIBBONPOPUPS_H__)
XTPSpecialKey
XTPSpecialKey
Special keys enumerator.
Definition XTPCommandBarsDefines.h:407
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.
Definition XTPCommandBarKeyboardTip.h:41
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPopupToolBar
CXTPPopupToolBar is a CXTPPopupBar derived class.
Definition XTPPopupBar.h:492
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonControlTab
CXTPRibbonControlTab is a CXTPTabManager derived class.
Definition XTPRibbonControlTab.h:56
CXTPRibbonGroup
Represents a single group that is added to a CXTPRibbonTab.
Definition XTPRibbonGroup.h:70
CXTPRibbonGroups
Represents a collection of CXTPRibbonGroup objects.
Definition XTPRibbonGroups.h:51
CXTPRibbonQuickAccessControls
CXTPRibbonQuickAccessControls is a CXTPControls derived class.
Definition XTPRibbonQuickAccessControls.h:93
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPRibbonTabPopupToolBar
Implements a pop-up when the Ribbon is in minimzed mode.
Definition XTPRibbonPopups.h:113
CXTPRibbonTabPopupToolBar::IsKeyboardCuesVisible
BOOL IsKeyboardCuesVisible() const
Call this method to determine if keyboard cues are visible.
CXTPRibbonTabPopupToolBar::CalculatePopupRect
virtual CRect CalculatePopupRect(CPoint ptPopup, CSize sz)
This method is called to calculate the destination rectangle of the pop-up bar.
CXTPRibbonTabPopupToolBar::EnsureVisible
void EnsureVisible(CXTPControl *pControl)
Call this method to make sure that a control is visible on the ribbon bar.
CXTPRibbonTabPopupToolBar::GetButtonSize
virtual CSize GetButtonSize() const
Call this function to get the size of the command bar button.
CXTPRibbonTabPopupToolBar::OnGroupsScroll
void OnGroupsScroll(BOOL bScrollLeft)
The framework calls this member function when the group pop-up is scrolled.
CXTPRibbonTabPopupToolBar::GetGroupsRect
CRect GetGroupsRect() const
Retrieves the groups bounding rectangle.
CXTPRibbonTabPopupToolBar::CreateKeyboardTips
void CreateKeyboardTips()
This method is called to create a keyboard tips collection for the ribbon.
CXTPRibbonTabPopupToolBar::SetTrackingMode
virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
CXTPRibbonTabPopupToolBar::OnKeyboardTip
void OnKeyboardTip(CXTPCommandBarKeyboardTip *pTip)
This method is called when a keyboard tip is found for the command bar.
CXTPRibbonTabPopupToolBar::CalcDynamicLayout
CSize CalcDynamicLayout(int nLength, DWORD nMode)
This method is called to get the size of the command bar.
CXTPRibbonTabPopupToolBar::ProcessSpecialKey
virtual BOOL ProcessSpecialKey(XTPSpecialKey key)
This method is called to process special keys.
CXTPRibbonTabPopupToolBar::DrawCommandBar
void DrawCommandBar(CDC *pDC, CRect rcClipBox)
This method is called to draw the command bar in the given context.
CXTPRibbonTabPopupToolBar::GetIconSize
virtual CSize GetIconSize() const
Call this member function to get the size of the icon for a minimized group.
CXTPRibbonTabPopupToolBar::OnToolHitTest
INT_PTR OnToolHitTest(CPoint point, TOOLINFO *pTI) const
The framework calls this member function to determine whether a point is in the bounding rectangle of...
CXTPRibbonTabPopupToolBar::HitTestGroup
CXTPRibbonGroup * HitTestGroup(CPoint point) const
This member function determines which ribbon group, if any, is at a specified position.
CXTPRibbonTabPopupToolBar::~CXTPRibbonTabPopupToolBar
~CXTPRibbonTabPopupToolBar()
Destroys a CXTPRibbonTabPopupToolBar object, handles cleanup and deallocation.
CXTPRibbonTabPopupToolBar::CXTPRibbonTabPopupToolBar
CXTPRibbonTabPopupToolBar(CXTPRibbonTab *pRibbonTab)
Constructs a CXTPRibbonTabPopupToolBar object.
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48


CXTPListView Member List

This is the complete list of members for CXTPListView, including all inherited members.

CXTPListView() | CXTPListView |
~CXTPListView() | CXTPListView | virtual


CXTPMarqueeCtrlThemeOffice2003 Member List

This is the complete list of members for CXTPMarqueeCtrlThemeOffice2003, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeOffice2003() | CXTPMarqueeCtrlThemeOffice2003 |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2003 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


CXTPChartContentView Member List

This is the complete list of members for CXTPChartContentView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateView(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartContentView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartContentView | virtual
CreateView(CXTPChartDeviceContext *pDC) | CXTPChartContentView |
CXTPChartContentView(CXTPChartContainer *pContainer, CXTPChartContent *pContent) | CXTPChartContentView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetLegendView() const | CXTPChartContentView |
GetParentView() const | CXTPChartElementView |
HitTestDiagramView(CPoint pt) const | CXTPChartContentView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pContent | CXTPChartContentView | protected
m_pDiagramView | CXTPChartContentView |
m_pLegendView | CXTPChartContentView |
m_pParentView | CXTPChartElementView | protected
m_pTitlesView | CXTPChartContentView |
m_rcBounds | CXTPChartContentView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual


CXTPChartAxisLabel Member List

This is the complete list of members for CXTPChartAxisLabel, including all inherited members.

CXTPChartAxisLabel(CXTPChartAxis *pAxis) | CXTPChartAxisLabel |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartAxisLabel | virtual
GetActualTextColor() const | CXTPChartAxisLabel |
GetAngle() const | CXTPChartAxisLabel |
GetAntialiasing() const | CXTPChartAxisLabel | virtual
GetAppearance() const | CXTPChartElement |
GetAxis() const | CXTPChartAxisLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartAxisLabel | virtual
GetFormat() const | CXTPChartAxisLabel |
GetOwner() const | CXTPChartElement |
GetTextColor() const | CXTPChartAxisLabel |
Is3D() const | CXTPChartObject |
IsVisible() const | CXTPChartAxisLabel |
m_bAntialiasing | CXTPChartAxisLabel | protected
m_bVisible | CXTPChartAxisLabel | protected
m_clrTextColor | CXTPChartAxisLabel | protected
m_nAngle | CXTPChartAxisLabel | protected
m_pFont | CXTPChartAxisLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAngle(int nAgle) | CXTPChartAxisLabel |
SetAntialiasing(BOOL bAntialiasing) | CXTPChartAxisLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartAxisLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartAxisLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartAxisLabel |
SetVisible(BOOL bVisible) | CXTPChartAxisLabel |
~CXTPChartAxisLabel() | CXTPChartAxisLabel | virtual
~CXTPChartElement() | CXTPChartElement | virtual


Toolkit Pro: XTPWebBrowserProvider.h Source File

  • Source
  • Controls
  • WebBrowser
  • Providers
XTPWebBrowserProvider.h
Go to the documentation of this file.
1
22#if !defined(__XTPWEBBROWSERPROVIDER_H__)
23
25# define __XTPWEBBROWSERPROVIDER_H__
29# if _MSC_VER >= 1000
30# pragma once
31# endif // _MSC_VER > 1000
32
33# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
34# include <atlbase.h>
35# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
36
37class CXTPWebBrowserCtrl;
38
39struct IXTPWebBrowserHost;
40class CXTPWebBrowserControlSite;
41
42# define XTP_WEBBROWSER_RESOLVE_USERAGENT(pv) \
43 (NULL != (pv) && VT_BSTR == (pv)->vt && NULL != (pv)->bstrVal \
44 && 0 < ::SysStringLen((pv)->bstrVal) \
45 ? (pv)->bstrVal \
46 : NULL)
47
48# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
55class _XTP_EXT_CLASS CXTPWebBrowserProvider : public CXTPCmdTarget
56{
58 DECLARE_DYNAMIC(CXTPWebBrowserProvider)
60 friend class CXTPWebBrowserCtrl;
61
62protected:
68 CXTPWebBrowserProvider(IXTPWebBrowserHost& host);
69
70public:
75 virtual ~CXTPWebBrowserProvider();
76
84 IUnknown* GetBrowserObject() const;
85
98 IUnknown* GetClientInterface(REFIID riid) const;
99
111 void SetClientInterface(REFIID riid, IUnknown* pUnk);
112
123 void RemoveClientInterface(REFIID riid);
124
137 virtual HRESULT ExecuteScript(LPCWSTR pText, CComVariant* pvtResult = NULL) = 0;
138
140 IXTPWebBrowserHost& GetHost() const;
141
142 virtual HRESULT Initialize() = 0;
143 virtual HRESULT Navigate(LPCTSTR pUrl) = 0;
144 virtual HRESULT LoadHtml(LPCTSTR pHtml) = 0;
145 virtual HRESULT WaitUntilReady() = 0;
146 virtual void ReleaseBrowser() = 0;
147 virtual BOOL OnHostWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult) = 0;
150protected:
152 const CString& GetUrl() const;
153 void SetUrl(CString strUrl);
154 virtual void OnCreateBrowser(IUnknown* pObject);
155 virtual void OnDestroyBrowser();
156 virtual CXTPWebBrowserControlSite* CreateControlSite(COleControlContainer* pCtrlContainer);
157
158 virtual void UpdateExternal();
161private:
162 void ReleaseSite();
163
164protected:
165 IXTPWebBrowserHost& m_Host;
167private:
168 CXTPWebBrowserProvider(const CXTPWebBrowserProvider&);
169 CXTPWebBrowserProvider& operator=(const CXTPWebBrowserProvider&);
170
171 COleControlContainer* m_pCtrlContainer;
172 IUnknown* m_pBrowserObject;
173 CXTPWebBrowserControlSite* m_pSite;
174 CString m_strUrl;
175
176 struct ClientInterface
177 {
178 IID iid;
179 LPUNKNOWN pUnk;
180 };
181
182 typedef CArray<ClientInterface, const ClientInterface&> ClientInterfaceArray;
183
184 ClientInterfaceArray* m_parrClientInterfaces;
185};
187AFX_INLINE IXTPWebBrowserHost& CXTPWebBrowserProvider::GetHost() const
188{
189 return m_Host;
190}
191
192AFX_INLINE IUnknown* CXTPWebBrowserProvider::GetBrowserObject() const
193{
194 return m_pBrowserObject;
195}
196
197AFX_INLINE const CString& CXTPWebBrowserProvider::GetUrl() const
198{
199 return m_strUrl;
200}
201
202AFX_INLINE void CXTPWebBrowserProvider::SetUrl(CString strUrl)
203{
204 m_strUrl = strUrl;
205}
206
207# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
208
209#endif
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPWebBrowserCtrl
Implements the WebBrowser control that is capable of hosting different supported Web browsers.
Definition XTPWebBrowserCtrl.h:66
CXTPWebBrowserProvider
Implements the base class for a WebBrowser provider.
Definition XTPWebBrowserProvider.h:56
CXTPWebBrowserProvider::GetClientInterface
IUnknown * GetClientInterface(REFIID riid) const
Gets the client interface.
CXTPWebBrowserProvider::CXTPWebBrowserProvider
CXTPWebBrowserProvider(IXTPWebBrowserHost &host)
Handles provider construction.
CXTPWebBrowserProvider::~CXTPWebBrowserProvider
virtual ~CXTPWebBrowserProvider()
Handles provider destruction.
CXTPWebBrowserProvider::ExecuteScript
virtual HRESULT ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL)=0
Executes a script by the active WebBrowser provider.
CXTPWebBrowserProvider::SetClientInterface
void SetClientInterface(REFIID riid, IUnknown *pUnk)
Sets the client interface.
CXTPWebBrowserProvider::GetBrowserObject
IUnknown * GetBrowserObject() const
Obtains the native WebBrowser provider object or NULL if no provider is activated or the current prov...
CXTPWebBrowserProvider::RemoveClientInterface
void RemoveClientInterface(REFIID riid)
Removes the client interface.
CXTPWebBrowserProvider::m_Host
IXTPWebBrowserHost & m_Host
The host control interface.
Definition XTPWebBrowserProvider.h:165


XTP_NM_GRIDCONSTRAINTSELECTING Member List

This is the complete list of members for XTP_NM_GRIDCONSTRAINTSELECTING, including all inherited members.

hdr | XTP_NM_GRIDRECORDITEM
nHyperlink | XTP_NM_GRIDRECORDITEM
pColumn | XTP_NM_GRIDRECORDITEM
pConstraint | XTP_NM_GRIDCONSTRAINTSELECTING
pItem | XTP_NM_GRIDRECORDITEM
pRow | XTP_NM_GRIDRECORDITEM
pt | XTP_NM_GRIDRECORDITEM


Toolkit Pro: XTPRibbonBackstageSeparatorThemeResource.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMERESOURCE_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMERESOURCE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeResource
36 : public CXTPRibbonBackstageSeparatorPaintManager
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeResource();
40
41 virtual void DrawSeparator(CDC* pDC, CXTPRibbonBackstageSeparator* pSeparator);
42
43private:
44 CXTPBrush m_xtpBrush;
45};
46
47# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
49#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMERESOURCE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPBrush
Provides a convenient object oriented interface for HBRUSH GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:653


CXTPChartRangeBarSeriesView Member List

This is the complete list of members for CXTPChartRangeBarSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
BeforeUpdateRange(CXTPChartDeviceContext *pDC) | CXTPChartBarSeriesView | protected
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartBarSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartRangeBarSeriesView | protected
CXTPChartBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartBarSeriesView |
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartRangeBarSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartRangeBarSeriesView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_nBarCount | CXTPChartBarSeriesView | protected
m_nBarIndex | CXTPChartBarSeriesView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


CXTPMarkupSystemBrushStaticExtension Member List

This is the complete list of members for CXTPMarkupSystemBrushStaticExtension, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
CXTPMarkupSystemBrushStaticExtension(LPCWSTR lpzName, int nColorIndex) | CXTPMarkupSystemBrushStaticExtension |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetSystemBrush(int nColorIndex) | CXTPMarkupSystemBrushStaticExtension | static
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


CXTPDockingPaneBase Member List

This is the complete list of members for CXTPDockingPaneBase, including all inherited members.

Clone(CXTPDockingPaneLayout *pLayout, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions=0) | CXTPDockingPaneBase | protectedvirtual
ContainPane(CXTPDockingPaneBase *pPane) const | CXTPDockingPaneBase | virtual
Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions) | CXTPDockingPaneBase | protectedvirtual
CreateContainer() | CXTPDockingPaneBase | protectedvirtual
CXTPDockingPaneBase(XTPDockingPaneType type, CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneBase | protected
DeletePane()=0 | CXTPDockingPaneBase | protectedpure virtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneBase | protectedvirtual
FindCaptionButton(int nID) const | CXTPDockingPaneBase |
FindPane(XTPDockingPaneType type, CXTPDockingPaneBaseList *pList) const | CXTPDockingPaneBase | virtual
GetCaptionButtons() const | CXTPDockingPaneBase |
GetContainer() const | CXTPDockingPaneBase |
GetDockingPaneManager() const | CXTPDockingPaneBase |
GetDockingSite() const | CXTPDockingPaneBase | virtual
GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const | CXTPDockingPaneBase | virtual
GetPaintManager() const | CXTPDockingPaneBase |
GetPaneHwnd() const | CXTPDockingPaneBase | virtual
GetPaneWindowRect() const | CXTPDockingPaneBase |
GetTitle() const | CXTPDockingPaneBase | virtual
GetType() const | CXTPDockingPaneBase |
InvalidatePane(BOOL bSelectionChanged) | CXTPDockingPaneBase | virtual
IsActive() const | CXTPDockingPaneBase | virtual
IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
IsCaptionVertical() const | CXTPDockingPaneBase | virtual
IsEmpty() const | CXTPDockingPaneBase | virtual
IsHidden() const | CXTPDockingPaneBase | virtual
m_pCaptionButtons | CXTPDockingPaneBase | protected
m_pDockingSite | CXTPDockingPaneBase | protected
m_pLayout | CXTPDockingPaneBase | protected
m_pParentContainer | CXTPDockingPaneBase | protected
m_rcWindow | CXTPDockingPaneBase | protected
m_szDocking | CXTPDockingPaneBase | protected
m_type | CXTPDockingPaneBase | protected
OnCaptionButtonRectChanged(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneBase | protectedvirtual
OnChildContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnFocusChanged() | CXTPDockingPaneBase | protectedvirtual
OnParentContainerChanged(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam) | CXTPDockingPaneBase | protectedvirtual
RedrawPane() | CXTPDockingPaneBase | virtual
RemovePane(CXTPDockingPaneBase *pPane) | CXTPDockingPaneBase | protectedvirtual
SetDockingSite(CWnd *pFrame) | CXTPDockingPaneBase | protectedvirtual
SetParentContainer(CXTPDockingPaneBase *pContainer) | CXTPDockingPaneBase | protectedvirtual
~CXTPDockingPaneBase() | CXTPDockingPaneBase | protectedvirtual


Toolkit Pro: XTPEditThemeVisualStudio2019.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEVISUALSTUDIO2019_H__)
24# define __XTPEDITTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeVisualStudio2019 : public CXTPEditThemeOffice2013
38{
39public:
44 CXTPEditThemeVisualStudio2019();
45
50 virtual ~CXTPEditThemeVisualStudio2019();
51};
52
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // __XTPEDITTHEMEVISUALSTUDIO2019_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEditThemeOffice2013
CXTPEditThemeOffice2013 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2013.h:38
CXTPEditThemeVisualStudio2019
CXTPEditThemeVisualStudio2019 is a class used to perform theme drawing tasks.
Definition XTPEditThemeVisualStudio2019.h:38
CXTPEditThemeVisualStudio2019::CXTPEditThemeVisualStudio2019
CXTPEditThemeVisualStudio2019()
Constructs a CXTPEditThemeVisualStudio2019 object.
CXTPEditThemeVisualStudio2019::~CXTPEditThemeVisualStudio2019
virtual ~CXTPEditThemeVisualStudio2019()
Destructor, handles cleanup and deallocation.


  • CXTPDockingPaneWindowSelect
  • CColumn
CXTPDockingPaneWindowSelect::CColumn Member List

This is the complete list of members for CXTPDockingPaneWindowSelect::CColumn, including all inherited members.


Toolkit Pro: XTPChartBarSeriesErrorBar.h Source File

  • Source
  • Chart
  • Styles
  • Bar
XTPChartBarSeriesErrorBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTBARSERIESERRORBAR_H__)
24# define __XTPCHARTBARSERIESERRORBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
35class _XTP_EXT_CLASS CXTPChartBarSeriesErrorBar : public CXTPChartErrorBar
36{
37 DECLARE_SERIAL(CXTPChartBarSeriesErrorBar);
38
39public:
44 CXTPChartBarSeriesErrorBar();
45
50 virtual ~CXTPChartBarSeriesErrorBar();
51
52public:
65 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
66 CXTPChartSeriesPointView* pPointView,
67 CXTPChartElementView* pParentView);
68
69 void DoPropExchange(CXTPPropExchange* pPX);
70
71public:
72# ifdef _XTP_ACTIVEX
73public:
75 DECLARE_DISPATCH_MAP()
76 DECLARE_INTERFACE_MAP()
77 DECLARE_OLETYPELIB_EX(CXTPChartBarSeriesErrorBar);
79# endif
80};
81
87class _XTP_EXT_CLASS CXTPChartBarSeriesErrorBarView : public CXTPChartErrorBarView
88{
89public:
98 CXTPChartBarSeriesErrorBarView(CXTPChartErrorBar* pErrorBar,
99 CXTPChartSeriesPointView* pPointView,
100 CXTPChartElementView* pParentView);
101
102 // virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext *pDC);
103 void CalculateLayout(CXTPChartDeviceContext* pDC);
104
109 // virtual CXTPChartPointF GetAnchorPoint(XTPChartErrorBarPosition position) const;
110};
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
113#endif //#if !defined(__XTPCHARTBARSERIESERRORBAR_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBarSeriesErrorBarView
This class abstracts the view of the label of a bar series.
Definition XTPChartBarSeriesErrorBar.h:88
CXTPChartBarSeriesErrorBarView::CXTPChartBarSeriesErrorBarView
CXTPChartBarSeriesErrorBarView(CXTPChartErrorBar *pErrorBar, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartBarSeriesErrorBarView object.
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPChartCircleDeviceCommand Member List

This is the complete list of members for CXTPChartCircleDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartCircleDeviceCommand(const CXTPChartPointF &center, double radius) | CXTPChartCircleDeviceCommand | protected
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartCircleDeviceCommand | protectedvirtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_center | CXTPChartCircleDeviceCommand | protected
m_radius | CXTPChartCircleDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPChartPyramidDiagramBase.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • Base
XTPChartPyramidDiagramBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDDIAGRAMBASE_H__)
24# define __XTPCHARTPYRAMIDDIAGRAMBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDeviceContext;
34class CXTPChartElementView;
35class CXTPChartDiagramView;
36
39class _XTP_EXT_CLASS CXTPChartPyramidDiagramBaseImpl
40{
41protected:
42 void CalculateSeriesLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView);
43};
44
51template<class BaseDiagram>
52class CXTPChartPyramidDiagramBase
53 : public BaseDiagram
54 , private CXTPChartPyramidDiagramBaseImpl
55{
56protected:
61 CXTPChartPyramidDiagramBase();
62
63public:
74 virtual CXTPChartDiagramView* CreateView(CXTPChartDeviceContext* pDC,
75 CXTPChartElementView* pParent) = 0;
76
84 virtual void CalculateSeriesLayout(CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView);
85};
86
87template<class BaseDiagram>
88AFX_INLINE CXTPChartPyramidDiagramBase<BaseDiagram>::CXTPChartPyramidDiagramBase()
89{
90}
91
92template<class BaseDiagram>
93AFX_INLINE void CXTPChartPyramidDiagramBase<BaseDiagram>::CalculateSeriesLayout(
94 CXTPChartDeviceContext* pDC, CXTPChartDiagramView* pView)
95{
96 CXTPChartPyramidDiagramBaseImpl::CalculateSeriesLayout(pDC, pView);
97}
98
99typedef CXTPChartPyramidDiagramBase<CXTPChart2dDiagram> CXTPChart2dPyramidDiagramBase;
100typedef CXTPChartPyramidDiagramBase<CXTPChart3dDiagram> CXTPChart3dPyramidDiagramBase;
102# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
103#endif //#if !defined(__XTPCHARTPYRAMIDDIAGRAMBASE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidDiagramBase
This class abstracts the pyramid diagram.
Definition XTPChartPyramidDiagramBase.h:55
CXTPChartPyramidDiagramBase::CreateView
virtual CXTPChartDiagramView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent)=0
Call this function to create the view of the pyramid diagram.
CXTPChartPyramidDiagramBase::CalculateSeriesLayout
virtual void CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView)
Call this function to calculate the pyramid series layout.
Definition XTPChartPyramidDiagramBase.h:93
CXTPChartPyramidDiagramBase::CXTPChartPyramidDiagramBase
CXTPChartPyramidDiagramBase()
Constructs a CXTPChartPyramidDiagramBase object.
Definition XTPChartPyramidDiagramBase.h:88


CXTPSizeT< T > Member List

This is the complete list of members for CXTPSizeT< T >, including all inherited members.

CXTPSizeT() | CXTPSizeT< T > | inline
CXTPSizeT(T width, T height) | CXTPSizeT< T > | inline
CXTPSizeT(const CXTPSizeT &other) | CXTPSizeT< T > | inline
Height | CXTPSizeT< T > |
IsEmpty() const | CXTPSizeT< T > | inline
operator!=(const CXTPSizeT &other) const | CXTPSizeT< T > | inline
operator+(const CXTPSizeT &other) const | CXTPSizeT< T > | inline
operator-(const CXTPSizeT &other) const | CXTPSizeT< T > | inline
operator==(const CXTPSizeT &other) const | CXTPSizeT< T > | inline
Width | CXTPSizeT< T > |


Toolkit Pro: XTPPopupThemeOffice2000.h Source File

  • Source
  • Controls
  • Popup
  • Themes
XTPPopupThemeOffice2000.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOPUPTHEMEOFFICE2000_H__)
24# define __XTPPOPUPTHEMEOFFICE2000_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPopupThemeOffice2000 : public CXTPPopupPaintManager
39{
40public:
45 CXTPPopupThemeOffice2000();
46
51 virtual ~CXTPPopupThemeOffice2000();
52
53public:
58 void RefreshMetrics();
59
67 virtual void DrawBackground(CDC* pDC, CXTPPopupControl* pControl, CRect rcClient);
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPPOPUPTHEMEOFFICE2000_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window.
Definition XTPPopupControl.h:225
CXTPPopupPaintManager
CXTPPopupPaintManager is a class used to perform specialized drawing tasks.
Definition XTPPopupPaintManager.h:44
CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks.
Definition XTPPopupThemeOffice2000.h:39
CXTPPopupThemeOffice2000::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
CXTPPopupThemeOffice2000::RefreshMetrics
void RefreshMetrics()
Call this member function to refresh draw metrics.
CXTPPopupThemeOffice2000::CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000()
Constructs a CXTPPopupThemeOffice2000 object.
CXTPPopupThemeOffice2000::~CXTPPopupThemeOffice2000
virtual ~CXTPPopupThemeOffice2000()
Destroys a CXTPPopupThemeOffice2000 object.


  • CXTPShellPidl
  • CShellMalloc
CXTPShellPidl::CShellMalloc Member List

This is the complete list of members for CXTPShellPidl::CShellMalloc, including all inherited members.

Alloc(DWORD nBytes) | CXTPShellPidl::CShellMalloc | inline
CShellMalloc() | CXTPShellPidl::CShellMalloc | inline
Free(void *lpMem) | CXTPShellPidl::CShellMalloc | inline
m_lpMalloc | CXTPShellPidl::CShellMalloc | protected
operator LPMALLOC() | CXTPShellPidl::CShellMalloc | inline
~CShellMalloc() | CXTPShellPidl::CShellMalloc | inlinevirtual


Toolkit Pro: XTPTaskPanelShortcutBarOffice2003Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelShortcutBarOffice2003Theme.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelShortcutBarOffice2003Theme_h__
24# define XTPTaskPanelShortcutBarOffice2003Theme_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelShortcutBarOffice2003Theme
40 : public CXTPTaskPanelListViewOffice2003Theme
41{
42public:
47 CXTPTaskPanelShortcutBarOffice2003Theme();
48
53 void RefreshMetrics();
54
55protected:
65 CRect DrawGroupCaptionBackground(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
66
74 void DrawGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
75
85 void FillGroupClientFace(CDC* pDC, CXTPTaskPanelGroup* pGroup, CRect rc);
86
93 void FillTaskPanel(CDC* pDC, CXTPTaskPanel* pTaskPanel);
94};
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
97#endif // XTPTaskPanelShortcutBarOffice2003Theme_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelListViewOffice2003Theme
CXTPTaskPanelListViewOffice2003Theme represents a List View Office 2003 style theme.
Definition XTPTaskPanelListViewOffice2003Theme.h:41
CXTPTaskPanelShortcutBarOffice2003Theme
CXTPTaskPanelShortcutBarOffice2003Theme represents an Office 2003 ShortcutBar style theme.
Definition XTPTaskPanelShortcutBarOffice2003Theme.h:41
CXTPTaskPanelShortcutBarOffice2003Theme::CXTPTaskPanelShortcutBarOffice2003Theme
CXTPTaskPanelShortcutBarOffice2003Theme()
Constructs a CXTPTaskPanelShortcutBarOffice2003Theme object.
CXTPTaskPanelShortcutBarOffice2003Theme::FillTaskPanel
void FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel)
Fills the background of a specified task panel.
CXTPTaskPanelShortcutBarOffice2003Theme::FillGroupClientFace
void FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Fills the client face of a specified group.
CXTPTaskPanelShortcutBarOffice2003Theme::DrawGroupCaptionBackground
CRect DrawGroupCaptionBackground(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the group caption background of a specified group.
CXTPTaskPanelShortcutBarOffice2003Theme::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelShortcutBarOffice2003Theme::DrawGroupClientFace
void DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc)
Draws the client face of a specified group.


CXTPFontManager Member List

This is the complete list of members for CXTPFontManager, including all inherited members.

CreateFonts(LOGFONT lf) | CXTPFontManager |
FontExists(LPCTSTR lpszFaceName) | CXTPFontManager |
GetFont() | CXTPFontManager |
GetFontBold() | CXTPFontManager |
GetFontItalic() | CXTPFontManager |
GetFontItalicBold() | CXTPFontManager |
GetFontVertical() | CXTPFontManager |
GetFontVerticalBold() | CXTPFontManager |
m_xtpFont | CXTPFontManager | protected
m_xtpFontBold | CXTPFontManager | protected
m_xtpFontItalic | CXTPFontManager | protected
m_xtpFontItalicBold | CXTPFontManager | protected
m_xtpFontVertical | CXTPFontManager | protected
m_xtpFontVerticalBold | CXTPFontManager | protected


CXTPReBarPaintManager< TBase > Member List

This is the complete list of members for CXTPReBarPaintManager< TBase >, including all inherited members.

CXTPReBarPaintManager() | CXTPReBarPaintManager< TBase > |
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPReBarPaintManager< TBase > |
m_themeRebar | CXTPReBarPaintManager< TBase > | protected
RefreshMetrics() | CXTPReBarPaintManager< TBase > |


CXTPColorSelectorCtrlTheme Member List

This is the complete list of members for CXTPColorSelectorCtrlTheme, including all inherited members.

CalcSize(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
CreateAutoButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateExtendedButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateMoreButton(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateRecentColorButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CreateThemeButtons(CXTPColorSelectorCtrl *pOwner, int &nIndex, const int x, int &y, const int cx, bool &bChecked) | CXTPColorSelectorCtrlTheme | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPColorSelectorCtrlTheme() | CXTPColorSelectorCtrlTheme |
CXTPControlTheme() | CXTPControlTheme |
DrawColorCell(CDC *pDC, CXTPColorSelectorCtrl *pOwner, CXTPColorSelectorCtrl::COLOR_CELL *pColorCell, BOOL bHighlight, BOOL bPressed) | CXTPColorSelectorCtrlTheme | virtual
DrawColorSelector(CDC *pDC, CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
FillBackground(CDC *pDC, CXTPColorSelectorCtrl *pOwner, const CRect &rect) | CXTPColorSelectorCtrlTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonSize() const | CXTPColorSelectorCtrlTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bThinBorder | CXTPColorSelectorCtrlTheme |
m_crBack | CXTPColorSelectorCtrlTheme |
m_crBackChecked | CXTPColorSelectorCtrlTheme |
m_crBackHilight | CXTPColorSelectorCtrlTheme |
m_crBackPressed | CXTPColorSelectorCtrlTheme |
m_crBorder | CXTPColorSelectorCtrlTheme |
m_crBorderHilight | CXTPColorSelectorCtrlTheme |
m_crBorderPressed | CXTPColorSelectorCtrlTheme |
m_crPopupBorder | CXTPColorSelectorCtrlTheme |
m_crText | CXTPColorSelectorCtrlTheme |
m_crTextPressed | CXTPColorSelectorCtrlTheme |
m_nAutoButton | CXTPColorSelectorCtrlTheme |
m_nCaption | CXTPColorSelectorCtrlTheme |
m_nMargin | CXTPColorSelectorCtrlTheme |
m_nTheme | CXTPControlTheme | protected
m_rcRecentText | CXTPColorSelectorCtrlTheme |
m_rcStandardText | CXTPColorSelectorCtrlTheme |
m_rcThemeText | CXTPColorSelectorCtrlTheme |
m_sizeButton | CXTPColorSelectorCtrlTheme |
RefreshMetrics(CXTPColorSelectorCtrl *pOwner) | CXTPColorSelectorCtrlTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


  • CXTPPaintManager
  • CLogFont
CXTPPaintManager::CLogFont Member List

This is the complete list of members for CXTPPaintManager::CLogFont, including all inherited members.

CLogFont() CXTPPaintManager::CLogFont


Toolkit Pro: XTPDockingPaneThemeVisualStudio2010.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2010.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2010_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2010_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2010Theme
42 : public CXTPDockingPaneVisualStudio2008Theme
43{
44public:
49 CXTPDockingPaneVisualStudio2010Theme();
50
55 virtual void RefreshMetrics();
56
57protected:
68 virtual COLORREF FillCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
69 BOOL bActive, BOOL bVertical);
70
71 void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
72};
73
74# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
76#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2010_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneVisualStudio2008Theme
CXTPDockingPaneVisualStudio2008Theme is a CXTPDockingPaneVisualStudio2005Theme derived class that rep...
Definition XTPDockingPaneThemeVisualStudio2008.h:43
CXTPDockingPaneVisualStudio2010Theme
CXTPDockingPaneVisualStudio2010Theme is a CXTPDockingPaneVisualStudio2008Theme derived class that rep...
Definition XTPDockingPaneThemeVisualStudio2010.h:43
CXTPDockingPaneVisualStudio2010Theme::DrawFloatingFrame
void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneVisualStudio2010Theme::CXTPDockingPaneVisualStudio2010Theme
CXTPDockingPaneVisualStudio2010Theme()
Constructs a CXTPDockingPaneVisualStudio2010Theme object.
CXTPDockingPaneVisualStudio2010Theme::FillCaptionPart
virtual COLORREF FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
CXTPDockingPaneVisualStudio2010Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of manager.


CXTPChartFunnelSeriesView Member List

This is the complete list of members for CXTPChartFunnelSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CalculateLabelLayout(CXTPChartDeviceContext *pDC) | CXTPChartFunnelSeriesViewBase |
CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesView | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartFunnelSeriesView | protectedvirtual
CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesViewBase | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder) | CXTPChartFunnelSeriesView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartFunnelSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartFunnelSeriesView | protectedvirtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartFunnelSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartFunnelSeriesView |
CXTPChartFunnelSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartFunnelSeriesViewBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetDomain() const | CXTPChartFunnelSeriesViewBase |
GetInnerBounds() const | CXTPChartFunnelSeriesView | protectedvirtual
GetMaxLabelWidth() const | CXTPChartFunnelSeriesViewBase |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pDomain | CXTPChartFunnelSeriesViewBase | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartFunnelSeriesViewBase() | CXTPChartFunnelSeriesViewBase | virtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


Toolkit Pro: XTPCalendarDefines.h Source File

  • Source
  • Calendar
XTPCalendarDefines.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARDEFINES_H__)
23# define _XTPCALENDARDEFINES_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# ifndef DBG_TRACE_TIMER
32# define DBG_TRACE_TIMER
33# endif
34
35# ifndef DBG_DATA_ASSERT
36# define DBG_DATA_ASSERT
37# endif
38
39# ifndef DBG_DATA_VERIFY
40# define DBG_DATA_VERIFY
41# endif
42
43# ifndef LAYOUT_LTR
44# define LAYOUT_LTR 0x00000000
45# endif
46
48class CXTPCalendarEvent;
49class CXTPCalendarEvents;
50class CXTPCalendarRecurrencePattern;
51
52class CXTPCalendarEventLabel;
53class CXTPCalendarEventLabels;
54
55typedef long XTP_DATE_VALUE;
56
61enum XTPCalendarTheme
62{
63 xtpCalendarThemeUnknown = -1,
64 xtpCalendarThemeOffice2000 = 0,
65 xtpCalendarThemeOfficeXP = 1,
66 xtpCalendarThemeOffice2003 = 2,
67 xtpCalendarThemeOffice2013 = 3,
68 xtpCalendarThemeOffice2016 = xtpCalendarThemeOffice2013,
69 xtpCalendarThemeResource = 4,
70 xtpCalendarThemeVisualStudio2015 = 5,
71 xtpCalendarThemeNativeWindows10 = 6,
72 xtpCalendarThemeVisualStudio2017 = 7,
73 xtpCalendarThemeVisualStudio2019 = 8,
74 xtpCalendarThemeVisualStudio2022 = 9,
75 xtpCalendarThemeNativeWindows11 = 10,
77 // Alternate names
78 xtpCalendarThemeOffice2007 = xtpCalendarThemeResource,
79 xtpCalendarThemeOffice2010 = xtpCalendarThemeResource,
80};
81
86enum XTPCalendarThemeVersion
87{
88 xtpCalendarVersionUnknown = -1,
89 xtpCalendarVersion2000,
90 xtpCalendarVersionXP,
91 xtpCalendarVersion2003,
92 xtpCalendarVersion2007,
93 xtpCalendarVersion2010,
94 xtpCalendarVersion2013,
95 xtpCalendarVersion2015,
96 xtpCalendarVersion10,
97 xtpCalendarVersion2017,
98 xtpCalendarVersion2019,
99 xtpCalendarVersion2022,
100 xtpCalendarVersion11,
101};
102
107# define XTP_CALENDAR_UNKNOWN_EVENT_ID 0
108
113# define XTP_CALENDAR_UNKNOWN_RECURRENCE_PATTERN_ID 0
114
119# define XTP_CALENDAR_UNKNOWN_SCHEDULE_ID 0
120
127# define XTP_CALENDAR_DRAW_EVENTITEMTEXT_MAX 255
128
134# define XTP_CALENDAR_DISABLED_COLOR_LIGHT RGB(250, 250, 250)
135
141# define XTP_CALENDAR_DISABLED_COLOR_DARK RGB(128, 128, 128)
142
147# define XTP_CALENDAR_SHOW_TOOLTIP_TIMEOUT_MS 400
148
153# define XTP_CALENDAR_SHOW_BUTTON_TIMEOUT_MS 1400
154
169enum XTPCalendarEventBusyStatus
170{
171 xtpCalendarBusyStatusUnknown = -1,
172 xtpCalendarBusyStatusFree = 0,
173 xtpCalendarBusyStatusElsewhere = 1,
174 xtpCalendarBusyStatusTentative = 2,
175 xtpCalendarBusyStatusBusy = 3,
176 xtpCalendarBusyStatusOutOfOffice = 4
177};
178
193enum XTPCalendarEventImportance
194{
195 xtpCalendarImportanceUnknown = -1,
196 xtpCalendarImportanceLow = 0,
197 xtpCalendarImportanceNormal = 1,
198 xtpCalendarImportanceHigh = 2
199};
200
205enum XTPCalendarEventCategories
206{
207 xtpCalendarEventCategoryUnknown = 0,
208 xtpCalendarEventCategoryYellow = 1,
209 xtpCalendarEventCategoryGreen = 2,
210 xtpCalendarEventCategoryRed = 3,
211 xtpCalendarEventCategoryPurple = 4,
212 xtpCalendarEventCategoryOrange = 5,
213 xtpCalendarEventCategoryBlue = 6
214};
215
216# define xtpCalendarEventCategoryPink xtpCalendarEventCategoryPurple
217
222enum XTPCalendarEventRecurrenceState
223{
224 xtpCalendarRecurrenceNotRecurring = 0,
225 xtpCalendarRecurrenceMaster = 1,
226 xtpCalendarRecurrenceOccurrence = 2,
227 xtpCalendarRecurrenceException = 3
228};
229
234typedef CArray<COleDateTime, COleDateTime&> CXTPCalendarDatesArray;
235
240enum XTPCalendarPatternEnd
241{
242 xtpCalendarPatternEndDate,
243 xtpCalendarPatternEndAfterOccurrences,
246 xtpCalendarPatternEndNoDate
247};
248
253enum XTPCalendarEventRecurrenceType
254{
255 xtpCalendarRecurrenceUnknown = 0,
257 xtpCalendarRecurrenceDaily = 1,
258 xtpCalendarRecurrenceWeekly = 2,
261 xtpCalendarRecurrenceMonthly = 3,
264 xtpCalendarRecurrenceMonthNth = 4,
268 xtpCalendarRecurrenceYearly = 5,
271 xtpCalendarRecurrenceYearNth = 6
275};
276
281enum XTPCalendarWeekDay
282{
283 xtpCalendarDaySunday = 0x001,
284 xtpCalendarDayMonday = 0x002,
285 xtpCalendarDayTuesday = 0x004,
286 xtpCalendarDayWednesday = 0x008,
287 xtpCalendarDayThursday = 0x010,
288 xtpCalendarDayFriday = 0x020,
289 xtpCalendarDaySaturday = 0x040,
291 xtpCalendarDayAllWeek = xtpCalendarDayMonday | xtpCalendarDayTuesday | xtpCalendarDayWednesday
292 | xtpCalendarDayThursday | xtpCalendarDayFriday | xtpCalendarDaySaturday
293 | xtpCalendarDaySunday,
295 xtpCalendarDaySaSu = xtpCalendarDaySaturday
296 | xtpCalendarDaySunday,
297 xtpCalendarDayMo_Fr = xtpCalendarDayAllWeek ^ xtpCalendarDaySaSu
298};
299
305enum XTPCalendarClockAlignFlags
306{
307 xtpCalendarClockAlignLeft = 0x01,
308 xtpCalendarClockAlignCenter = 0x02,
309 xtpCalendarClockAlignRight = 0x04
310};
311
316enum XTPCalendarWeek
317{
318 xtpCalendarWeekFirst = 1,
319 xtpCalendarWeekSecond = 2,
320 xtpCalendarWeekThird = 3,
321 xtpCalendarWeekFourth = 4,
322 xtpCalendarWeekLast = 5
323};
324
336enum XTPCalendarDataProvider
337{
338 xtpCalendarDataProviderUnknown = 0,
340 xtpCalendarDataProviderMemory = 1,
341 xtpCalendarDataProviderDatabase = 2,
343 xtpCalendarDataProviderMAPI = 3,
345 xtpCalendarDataProviderCustom = 4
346};
347
360enum XTPCalendarViewType
361{
362 xtpCalendarDayView,
363 xtpCalendarWorkWeekView,
364 xtpCalendarWeekView,
365 xtpCalendarMonthView,
366 xtpCalendarFullWeekView,
367 xtpCalendarTimeLineView
368};
369
381enum XTPCalendarMouseMode
382{
383 xtpCalendarMouseNothing,
384 xtpCalendarMouseEventPreResizeV,
386 xtpCalendarMouseEventPreResizeH,
388 xtpCalendarMouseEventPreDrag,
389 xtpCalendarMouseEventResizingV,
391 xtpCalendarMouseEventResizingH,
393 xtpCalendarMouseEventDragCopy,
395 xtpCalendarMouseEventDragMove,
397 xtpCalendarMouseEventDraggingOut
398};
399
410enum XTPCalendarUpdateOptions
411{
412 xtpCalendarUpdateLayout = 0x0001,
414 xtpCalendarUpdateScrollBar = 0x0002,
416 xtpCalendarUpdateRedraw = 0x0004,
417 xtpCalendarUpdateAll = 0x000F,
419 xtpCalendarUpdateRedrawIfNeed = 0x0010
421};
422
428enum XTPCalendarViewChangedUpdateOptions
429{
430 xtpCalendarViewChangedSend = 1,
432 xtpCalendarViewChangedLock = 2
434};
435
444enum XTPCalendarHitTestCode
445{
446 xtpCalendarHitTestUnknown = 0,
448 xtpCalendarHitTestDayArea = 0x000001,
449 xtpCalendarHitTestDayHeader = 0x000002,
450 xtpCalendarHitTestDayExpandButton = 0x000004,
452 xtpCalendarHitTestGroupArea = xtpCalendarHitTestDayArea,
454 xtpCalendarHitTestGroupHeader = 0x000008,
455 xtpCalendarHitTestDay_Mask = 0x00000F,
458 xtpCalendarHitTestEventDragArea = 0x000010,
459 xtpCalendarHitTestEventTextArea = 0x000020,
461 xtpCalendarHitTestEventResizeVArea = 0x000100,
462 xtpCalendarHitTestEventResizeHArea = 0x000200,
463 xtpCalendarHitTestEventResizeArea_Mask =
464 xtpCalendarHitTestEventResizeVArea
465 | xtpCalendarHitTestEventResizeHArea,
467 xtpCalendarHitTestEventResizeBegin = 0x000400,
468 xtpCalendarHitTestEventResizeEnd = 0x000800,
470 xtpCalendarHitTestEvent_Mask = 0x000FF0,
472 xtpCalendarHitTestDayViewTimeScale = 0x001000,
473 xtpCalendarHitTestDayViewCell = 0x002000,
474 xtpCalendarHitTestDayViewAllDayEvent = 0x004000,
476 xtpCalendarHitTestDayViewScrollUp = 0x010000,
478 xtpCalendarHitTestDayViewScrollDown = 0x020000,
481 xtpCalendarHitTestAllDayEventsScrollUp = 0x030000,
482 xtpCalendarHitTestAllDayEventsScrollDown = 0x040000,
485 xtpCalendarHitTestDayView_Mask = 0x0FF000,
487 xtpCalendarHitTestPrevEventButton = 0x100000,
489 xtpCalendarHitTestNextEventButton = 0x200000,
491 xtpCalendarHitTestTimeLineScale = 0x400000,
493 xtpCalendarHitTestAllDayExpandButton =
494 xtpCalendarHitTestDayExpandButton
495 | xtpCalendarHitTestDayViewAllDayEvent,
497};
498
503enum XTPCalendarDraggingMode
504{
505 xtpCalendaDragModeUnknown = 0,
507 xtpCalendaDragModeCopy = 1,
508 xtpCalendaDragModeMove = 2,
510 xtpCalendaDragModeResizeBegin = 3,
511 xtpCalendaDragModeResizeEnd = 4,
513 xtpCalendaDragModeEditSubject = 5
514};
515
520enum XTPCalendarEndEditSubjectAction
521{
522 xtpCalendarEditSubjectUnknown = 0,
523 xtpCalendarEditSubjectCommit = 1,
524 xtpCalendarEditSubjectCancel = 2
525};
526
531enum XTPCalendarUndoMode
532{
533 xtpCalendarUndoModeUnknown = 0,
534 xtpCalendarUndoModeUndo = 1,
535 xtpCalendarUndoModeRedo = 2
536};
537
542enum XTPCalendarClipboardCopyFlags
543{
544 xtpCalendarCopyFlagROccurrence2RException = 0x0001,
546 xtpCalendarCopyFlagKeepRException = 0x0002,
548 xtpCalendarCopyFlagClearCBAfterPaste = 0x0004,
550 xtpCalendarCopyFlagCutMask = xtpCalendarCopyFlagROccurrence2RException
551 | xtpCalendarCopyFlagKeepRException
552 | xtpCalendarCopyFlagClearCBAfterPaste
555};
556
562enum XTPEnumCalendarReminderForOccurrenceParameters
563{
564 xtpCalendarRmdPrm_Default = LONG_MAX,
565 xtpCalendarRmdPrm_DontChange = LONG_MIN
566};
567
575enum XTPCalendarCurrentTimeMarkFlags
576{
577 xtpCalendarCurrentTimeMarkNone = 0,
579 xtpCalendarCurrentTimeMarkVisibleForToday = 1,
581 xtpCalendarCurrentTimeMarkVisibleAlways = 2,
582 xtpCalendarCurrentTimeMarkPrinted = 4
585};
586
592enum XTPCalendarEventIconIDs
593{
594 xtpCalendarEventIconIDReminder = -1,
595 xtpCalendarEventIconIDOccurrence = -2,
596 xtpCalendarEventIconIDException = -3,
597 xtpCalendarEventIconIDMeeting = -4,
598 xtpCalendarEventIconIDPrivate = -5
599};
600
601class CXTPCalendarViewDay;
602class CXTPCalendarViewGroup;
603class CXTPCalendarViewEvent;
604
614struct XTP_CALENDAR_VIEWSELECTION
615{
616public:
625 XTP_CALENDAR_VIEWSELECTION()
626 {
627 nGroupIndex = -1;
628 bAllDayEvent = FALSE;
629 dtBegin.SetStatus(COleDateTime::null);
630 dtEnd.SetStatus(COleDateTime::null);
631 }
632
644 const XTP_CALENDAR_VIEWSELECTION& operator=(const XTP_CALENDAR_VIEWSELECTION& rSrc)
645 {
646 nGroupIndex = rSrc.nGroupIndex;
647 bAllDayEvent = rSrc.bAllDayEvent;
648
649 if (rSrc.dtBegin.GetStatus() == COleDateTime::valid)
650 {
651 dtBegin = rSrc.dtBegin;
652 }
653 else
654 {
655 dtBegin.SetStatus(rSrc.dtBegin.GetStatus());
656 }
657
658 if (rSrc.dtEnd.GetStatus() == COleDateTime::valid)
659 {
660 dtEnd = rSrc.dtEnd;
661 }
662 else
663 {
664 dtEnd.SetStatus(rSrc.dtEnd.GetStatus());
665 }
666 return *this;
667 }
668
675 BOOL IsValid() const
676 {
677 return dtBegin.GetStatus() == COleDateTime::valid
678 && dtEnd.GetStatus() == COleDateTime::valid && nGroupIndex >= 0;
679 }
680
681public:
682 int nGroupIndex;
683 COleDateTime dtBegin;
684 COleDateTime dtEnd;
685 BOOL bAllDayEvent;
686};
687
698enum XTPCalendarDayViewScrollDirection
699{
700 xtpCalendarDayViewScrollUp,
701 xtpCalendarDayViewScrollDown,
702 xtpCalendarDayViewScrollNotNeeded,
703 xtpCalendarDayViewScrollLeft,
704 xtpCalendarDayViewScrollRight
705};
706
713struct XTP_CALENDAR_MONTHVIEW_DAYPOS
714{
715 int nWeekIndex;
716 int nWeekDayIndex;
749 operator int() const;
750
764 const XTP_CALENDAR_MONTHVIEW_DAYPOS& operator=(int nPOS);
765
776 XTP_CALENDAR_MONTHVIEW_DAYPOS& operator++();
777
788 XTP_CALENDAR_MONTHVIEW_DAYPOS operator++(int);
789
799 int GetPOS() const;
800
813 void SetPOS(int nWidx, int nWDidx);
814
823 void SetPOS(int nPOS);
824
835 BOOL IsValid() const;
836};
837
838class CXTPCalendarMonthViewDay;
839class CXTPCalendarMonthViewEvent;
840
855struct XTP_CALENDAR_HITTESTINFO
856{
857 COleDateTime dt;
858 BOOL bTimePartValid;
860 int uHitCode;
862 int nDay;
863 int nGroup;
864 int nEvent;
866 CXTPCalendarViewDay* pViewDay;
867 CXTPCalendarViewGroup* pViewGroup;
868 CXTPCalendarViewEvent* pViewEvent;
870 union {
871 XTP_CALENDAR_MONTHVIEW_DAYPOS dayPOS;
872 POINT pt;
873 };
874
883 XTP_CALENDAR_HITTESTINFO()
884 {
885 dt.SetStatus(COleDateTime::null);
886 bTimePartValid = FALSE;
887 uHitCode = xtpCalendarHitTestUnknown;
888 pViewDay = NULL;
889 pViewGroup = NULL;
890 pViewEvent = NULL;
891 nDay = -1;
892 nGroup = -1;
893 nEvent = -1;
894
895 memset(&dayPOS, -1, sizeof(dayPOS));
896 }
897
902 virtual ~XTP_CALENDAR_HITTESTINFO(){};
903
915 BOOL operator==(const XTP_CALENDAR_HITTESTINFO& hitInfo2);
916
928 BOOL operator!=(const XTP_CALENDAR_HITTESTINFO& hitInfo2)
929 {
930 return !(*this == hitInfo2);
931 }
932};
933
934//#define XTP_CALENDAR_HITTESTINFO_DAY_VIEW XTP_CALENDAR_HITTESTINFO
935//#define XTP_CALENDAR_HITTESTINFO_MONTH_VIEW XTP_CALENDAR_HITTESTINFO
936//#define XTP_CALENDAR_HITTESTINFO_WEEK_VIEW XTP_CALENDAR_HITTESTINFO
937
942enum XTPCalendarDataProviderCacheMode
943{
944 xtpCalendarDPCacheModeOff = 0x000,
946 xtpCalendarDPCacheModeOnRepeat = 0x001,
947 xtpCalendarDPCacheModeOnClear = 0x002,
949 xtpCalendarDPCacheModeOnMask = 0x00F,
950};
951
956# define XTP_CALENDAR_UNKNOWN_LABEL_ID -1
957
963# define XTP_CALENDAR_DEFAULT_LABEL_ID 0
964
970# define XTP_CALENDAR_NONE_LABEL_ID 0
971
976# define XTP_CALENDAR_DEFAULT_REMINDER_MINUTES 15
977
985# define XTP_CALENDAR_TIMEZONESKEY_NT \
986 _T("SOFTWARE\\Microsoft\\Windows NT\\CurrentVersion\\Time Zones")
987
995# define XTP_CALENDAR_TIMEZONESKEY_9X \
996 _T("SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Time Zones")
997
1006# define XTP_CALENDAR_TZIRegValName_StandardName _T("Std")
1015# define XTP_CALENDAR_TZIRegValName_StandardNameW L"Std"
1016
1024# define XTP_CALENDAR_TZIRegValName_DaylightName _T("Dlt")
1025
1033# define XTP_CALENDAR_TZIRegValName_DaylightNameW L"Dlt"
1034
1040# define XTP_CALENDAR_TZIRegValName_DisplayStr _T("Display")
1041
1048# define XTP_CALENDAR_TZIRegValName_Index _T("Index")
1049
1057# define XTP_CALENDAR_TZIRegValName_DATA _T("TZI")
1058
1059# define XTP_EVENT_PLACE_POS_UNDEFINED 0xFFFF
1060
1069const UINT WM_XTP_CALENDAR_BASE = (WM_USER + 9600);
1070
1071// Internal properties (has prefix *xtp*)
1072static const LPCTSTR cszEventCustProp_NextReminderTime_Snoozed =
1073 _T("*xtp*NextReminderTime_Snoozed");
1074static const LPCTSTR cszEventCustProp_IconsIDs = _T("*xtp*CustomIcons");
1077static const LPCTSTR cszEventCustProp_CategoryIDs =
1078 _T("*xtp*Categories");
1080// Public custom properties
1081static const LPCTSTR cszEventCustProp_MarkupTemplate =
1082 _T("xtpMarkupTemplate");
1084// Markup template params
1085static const LPCTSTR cszCalendarMarkupPrm_Subject =
1086 _T("/Calendar/Events/Event/Subject");
1087static const LPCTSTR cszCalendarMarkupPrm_Location =
1088 _T("/Calendar/Events/Event/Location");
1089static const LPCTSTR cszCalendarMarkupPrm_Body = _T("/Calendar/Events/Event/Body");
1090static const LPCTSTR cszCalendarMarkupPrm_StartTime =
1091 _T("/Calendar/Events/Event/StartTime"); // Start time.
1092static const LPCTSTR cszCalendarMarkupPrm_EndTime =
1093 _T("/Calendar/Events/Event/EndTime");
1101struct XTP_CALENDAR_PATTERN_END
1102{
1110 XTP_CALENDAR_PATTERN_END()
1111 {
1112 m_nUseEnd = xtpCalendarPatternEndNoDate;
1113
1114 m_dtPatternEndDate = (DATE)0;
1115 m_nEndAfterOccurrences = 1;
1116 }
1117
1125 virtual ~XTP_CALENDAR_PATTERN_END(){};
1126
1136 const XTP_CALENDAR_PATTERN_END& operator=(const XTP_CALENDAR_PATTERN_END& rSrc)
1137 {
1138 m_nUseEnd = rSrc.m_nUseEnd;
1139
1140 if (rSrc.m_dtPatternEndDate.GetStatus() == COleDateTime::valid)
1141 {
1142 m_dtPatternEndDate = rSrc.m_dtPatternEndDate;
1143 }
1144 else
1145 {
1146 m_dtPatternEndDate.SetStatus(rSrc.m_dtPatternEndDate.m_status);
1147 }
1148
1149 m_nEndAfterOccurrences = rSrc.m_nEndAfterOccurrences;
1150
1151 return *this;
1152 }
1153
1154public:
1155 XTPCalendarPatternEnd m_nUseEnd;
1157 COleDateTime m_dtPatternEndDate;
1158 int m_nEndAfterOccurrences;
1159};
1160
1161struct XTP_DAY_VIEW_GROUP_LAYOUT
1162{
1163 CRect m_rcAllDayEvents;
1164 CRect m_rcDayDetails;
1166 BOOL m_bShowHeader;
1168 // for office 2007 theme
1169 int m_nHotState;
1171 enum XTPEnumHotItem
1172 {
1173 xtpHotHeader = 0x001,
1174 xtpHotScrollUp = xtpCalendarHitTestDayViewScrollUp,
1175 xtpHotScrollDown = xtpCalendarHitTestDayViewScrollDown,
1176 xtpHotAllDayEventsScrollUp = xtpCalendarHitTestAllDayEventsScrollUp,
1177 xtpHotAllDayEventsScrollDown = xtpCalendarHitTestAllDayEventsScrollDown
1178 };
1179};
1180
1181struct XTP_VIEW_DAY_LAYOUT
1182{
1183 CRect m_rcDay;
1184 CRect m_rcDayHeader;
1186 CRect m_rcExpandSign;
1188 int m_nHotState;
1190 enum XTPEnumHotItem
1191 {
1192 xtpHotExpandButton = 0x001,
1193 xtpHotDayHeader = 0x002,
1194 };
1195};
1196
1197struct XTP_DAY_VIEW_LAYOUT
1198{
1199 int m_nVisibleRowCount;
1201 CRect m_rcDayHeader;
1202 CRect m_rcAllDayEvents;
1203
1204 int m_nRowCount;
1205 int m_nTopRow;
1207 int m_nAllDayEventsCountMax;
1209 int m_nAllDayEventHeight;
1211 int m_nVisibleAllDayCount;
1212 int m_nTopAllDayRow;
1213};
1214
1215struct XTP_VIEW_LAYOUT
1216{
1217 int m_nRowHeight;
1218};
1219
1220struct XTP_TIMESCALE_LAYOUT
1221{
1222 CRect m_rcHeader;
1223 CRect m_rcTimeZone;
1224 int m_nXPosBase;
1225};
1226
1227struct XTP_VIEW_GROUP_LAYOUT
1228{
1229 CRect m_rcGroup;
1230 CRect m_rcGroupHeader;
1231};
1232
1237struct XTP_WEEK_VIEW_LAYOUT
1238{
1239 int m_nGridColumns;
1240 int m_nDayHeaderHeight;
1242 int m_nDayWidth;
1243 int m_nDayHeight;
1244};
1245
1250enum XTPEnumCalendarTimeScaleParamsID
1251{
1252 xtpTSPID_Unknown = 0,
1253 xtpTSPID_Day = 1,
1254 xtpTSPID_Week = 2,
1255 xtpTSPID_Month = 3,
1256 xtpTSPID_WorkWeek = 4,
1257};
1258
1263enum XTPCalendarEditOperation
1264{
1265 xtpCalendarEO_Unknown = 0,
1267 xtpCalendarEO_DragCopy = xtpCalendaDragModeCopy,
1268 xtpCalendarEO_DragMove = xtpCalendaDragModeMove,
1269 xtpCalendarEO_DragResizeBegin = xtpCalendaDragModeResizeBegin,
1271 xtpCalendarEO_DragResizeEnd = xtpCalendaDragModeResizeEnd,
1273 xtpCalendarEO_EditSubject_ByF2,
1274 xtpCalendarEO_EditSubject_ByMouseClick,
1275 xtpCalendarEO_EditSubject_ByTab,
1276 xtpCalendarEO_EditSubject_AfterEventResize,
1279 xtpCalendarEO_Cut,
1280 xtpCalendarEO_Copy,
1281 xtpCalendarEO_Paste,
1284 xtpCalendarEO_DeleteSelectedEvents,
1285 xtpCalendarEO_DeleteEvent,
1288 xtpCalendarEO_InPlaceCreateEvent
1289};
1290
1295enum XTPCalendarSelectionChanged
1296{
1297 xtpCalendarSelectionUnknown = 0,
1299 xtpCalendarSelectionDays = 1,
1301 xtpCalendarSelectionEvents = 2
1304};
1305
1314enum XTPCalendarExpandDayButton
1315{
1316 xtpCalendarExpandDayButton_MonthView = 0x01,
1317 xtpCalendarExpandDayButton_WeekView = 0x02,
1318};
1319
1328enum XTPCalendarScrollDayButton
1329{
1330 xtpCalendarScrollDayButton_DayViewUp = xtpCalendarHitTestDayViewScrollUp,
1333 xtpCalendarScrollDayButton_DayViewDown =
1334 xtpCalendarHitTestDayViewScrollDown,
1336 // xtpCalendarScrollDayButton_DayViewAllDayUp = 5,
1337 // xtpCalendarScrollDayButton_DayViewAllDayDown = 6,
1338
1339};
1340
1353enum XTPCalendarGetItemText
1354{
1355 xtpCalendarItemText_EventSubject = 0x00000001,
1357 xtpCalendarItemText_EventLocation = 0x00000002,
1360 xtpCalendarItemText_DayViewDayHeader = 0x00000004,
1363 xtpCalendarItemText_WeekViewDayHeader = 0x00000008,
1366 xtpCalendarItemText_MonthViewDayHeader = 0x00000010,
1370 xtpCalendarItemText_MonthViewWeekDayHeader = 0x00000020,
1373 xtpCalendarItemText_EventToolTipText = 0x00000040,
1375 // xtpCalendarItemText_GroupToolTipText = 0x00000080,
1376
1377 xtpCalendarItemText_EventStartTimeText = 0x00000100,
1379 xtpCalendarItemText_EventEndTimeText = 0x00000200,
1382 xtpCalendarItemText_CaptionBarDayViewDateLabel =
1383 0x00000300,
1384 xtpCalendarItemText_CaptionBarWeekViewDateLabel =
1385 0x00000400,
1386 xtpCalendarItemText_CaptionBarMonthViewDateLabel =
1387 0x00000500
1388};
1389
1403enum XTPCalendarGetItemTextEx
1404{
1405 xtpCalendarItemText_EventBody = 0x00010000,
1407 xtpCalendarItemText_EventMarkupTemplate = 0x04000000,
1410 xtpCalendarItemText_DayViewDayHeaderLeft = 0x00020000,
1412 xtpCalendarItemText_DayViewDayHeaderCenter = 0x00040000,
1414 xtpCalendarItemText_DayViewDayHeaderRight = 0x00080000,
1417 xtpCalendarItemText_WeekViewDayHeaderLeft = 0x00100000,
1419 xtpCalendarItemText_WeekViewDayHeaderCenter = 0x00200000,
1422 xtpCalendarItemText_WeekViewDayHeaderRight = 0x00400000,
1426 xtpCalendarItemText_MonthViewDayHeaderLeft = 0x00800000,
1428 xtpCalendarItemText_MonthViewDayHeaderCenter =
1429 0x01000000,
1430 xtpCalendarItemText_MonthViewDayHeaderRight = 0x02000000
1433 // xtpCalendarItemText_MonthViewWeekHeader = 0x08000000,
1434};
1435
1437
1439static const LPCTSTR XTPCALENDARCTRL_CLASSNAME = _T("XTPCalendar");
1440static const LPCTSTR XTPCALENDARCAPTIONBAR_CLASSNAME = _T("XTPCalendarCaptionBar");
1441
1442// for compatibility with previous versions
1443// see xtp_wm_UserAction
1444//
1445
1447static const LPCTSTR XTPCALENDARCTRL_SWITCHVIEWMSG = _T("XTPCalendarSwitchView");
1449const UINT xtp_wm_SwitchView = RegisterWindowMessage(XTPCALENDARCTRL_SWITCHVIEWMSG);
1450
1452static const LPCTSTR XTPCALENDARCTRL_USERACTION = _T("XTPCalendarUserAction");
1453
1455const UINT xtp_wm_UserAction = RegisterWindowMessage(XTPCALENDARCTRL_USERACTION);
1456
1458# define XTP_CALENDAR_OFFICE2007_FONT_NAME _T("Segoe UI")
1460
1461typedef DWORD XTP_NOTIFY_CODE;
1462
1464
1465# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1466#endif // !defined(_XTPCALENDARDEFINES_H__)
XTPCalendarDataProvider
XTPCalendarDataProvider
Enumeration used to determine the calendar data provider in use.
Definition XTPCalendarDefines.h:337
xtpCalendarDataProviderUnknown
@ xtpCalendarDataProviderUnknown
Unknown data provider.
Definition XTPCalendarDefines.h:338
xtpCalendarDataProviderDatabase
@ xtpCalendarDataProviderDatabase
Database data provider - CXTPCalendarDatabaseDataProvider.
Definition XTPCalendarDefines.h:341
xtpCalendarDataProviderCustom
@ xtpCalendarDataProviderCustom
Custom data provider - CXTPCalendarCustomDataProvider.
Definition XTPCalendarDefines.h:345
xtpCalendarDataProviderMemory
@ xtpCalendarDataProviderMemory
Memory data provider - CXTPCalendarMemoryDataProvider.
Definition XTPCalendarDefines.h:340
xtpCalendarDataProviderMAPI
@ xtpCalendarDataProviderMAPI
MAPI (Exchange server) data provider - CXTPCalendarMAPIDataProvider.
Definition XTPCalendarDefines.h:343
XTPEnumCalendarReminderForOccurrenceParameters
XTPEnumCalendarReminderForOccurrenceParameters
Enumerates parameters used in configuring reminders for recurrence patterns occurrences.
Definition XTPCalendarDefines.h:563
xtpCalendarRmdPrm_DontChange
@ xtpCalendarRmdPrm_DontChange
Do not change reminders time value.
Definition XTPCalendarDefines.h:565
xtpCalendarRmdPrm_Default
@ xtpCalendarRmdPrm_Default
Set default reminders value.
Definition XTPCalendarDefines.h:564
XTPCalendarEventCategories
XTPCalendarEventCategories
Enumerates standard Event Categories for office 2007 theme.
Definition XTPCalendarDefines.h:206
xtpCalendarEventCategoryYellow
@ xtpCalendarEventCategoryYellow
The Yellow category ID.
Definition XTPCalendarDefines.h:208
xtpCalendarEventCategoryOrange
@ xtpCalendarEventCategoryOrange
The Orange category ID.
Definition XTPCalendarDefines.h:212
xtpCalendarEventCategoryBlue
@ xtpCalendarEventCategoryBlue
The Blue category ID.
Definition XTPCalendarDefines.h:213
xtpCalendarEventCategoryPurple
@ xtpCalendarEventCategoryPurple
The Purple category ID.
Definition XTPCalendarDefines.h:211
xtpCalendarEventCategoryUnknown
@ xtpCalendarEventCategoryUnknown
Typed unknown value.
Definition XTPCalendarDefines.h:207
xtpCalendarEventCategoryGreen
@ xtpCalendarEventCategoryGreen
The Green category ID.
Definition XTPCalendarDefines.h:209
xtpCalendarEventCategoryRed
@ xtpCalendarEventCategoryRed
The Red category ID.
Definition XTPCalendarDefines.h:210
XTPEnumCalendarTimeScaleParamsID
XTPEnumCalendarTimeScaleParamsID
=
Definition XTPCalendarDefines.h:1251
xtpTSPID_Day
@ xtpTSPID_Day
Day scale
Definition XTPCalendarDefines.h:1253
xtpTSPID_Week
@ xtpTSPID_Week
Week scale
Definition XTPCalendarDefines.h:1254
xtpTSPID_WorkWeek
@ xtpTSPID_WorkWeek
WorkWeek scale.
Definition XTPCalendarDefines.h:1256
xtpTSPID_Unknown
@ xtpTSPID_Unknown
Unspecified.
Definition XTPCalendarDefines.h:1252
xtpTSPID_Month
@ xtpTSPID_Month
Month scale
Definition XTPCalendarDefines.h:1255
XTPCalendarViewType
XTPCalendarViewType
Enumeration used to determine the calendar view type in use.
Definition XTPCalendarDefines.h:361
xtpCalendarTimeLineView
@ xtpCalendarTimeLineView
TimeLine view - CXTPCalendarTimeLineView
Definition XTPCalendarDefines.h:367
xtpCalendarDayView
@ xtpCalendarDayView
Day view - CXTPCalendarDayView
Definition XTPCalendarDefines.h:362
xtpCalendarFullWeekView
@ xtpCalendarFullWeekView
Day view - CXTPCalendarDayView.
Definition XTPCalendarDefines.h:366
xtpCalendarWorkWeekView
@ xtpCalendarWorkWeekView
Day view - CXTPCalendarDayView.
Definition XTPCalendarDefines.h:363
xtpCalendarWeekView
@ xtpCalendarWeekView
Week view - CXTPCalendarWeekView
Definition XTPCalendarDefines.h:364
xtpCalendarMonthView
@ xtpCalendarMonthView
Month view - CXTPCalendarMonthView
Definition XTPCalendarDefines.h:365
XTPCalendarEventImportance
XTPCalendarEventImportance
Enumerates importance level values.
Definition XTPCalendarDefines.h:194
xtpCalendarImportanceUnknown
@ xtpCalendarImportanceUnknown
Typed unknown value.
Definition XTPCalendarDefines.h:195
xtpCalendarImportanceNormal
@ xtpCalendarImportanceNormal
Normal importance level.
Definition XTPCalendarDefines.h:197
xtpCalendarImportanceLow
@ xtpCalendarImportanceLow
Low importance level.
Definition XTPCalendarDefines.h:196
xtpCalendarImportanceHigh
@ xtpCalendarImportanceHigh
High importance level.
Definition XTPCalendarDefines.h:198
XTPCalendarGetItemText
XTPCalendarGetItemText
This enum defines a set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT noti...
Definition XTPCalendarDefines.h:1354
xtpCalendarItemText_EventLocation
@ xtpCalendarItemText_EventLocation
Send request to customize Event location text before draw it.
Definition XTPCalendarDefines.h:1357
xtpCalendarItemText_DayViewDayHeader
@ xtpCalendarItemText_DayViewDayHeader
Send request to customize Day view day header text.
Definition XTPCalendarDefines.h:1360
xtpCalendarItemText_MonthViewWeekDayHeader
@ xtpCalendarItemText_MonthViewWeekDayHeader
Send request to customize month view week day header text.
Definition XTPCalendarDefines.h:1370
xtpCalendarItemText_EventStartTimeText
@ xtpCalendarItemText_EventStartTimeText
Send request to customize event start time text.
Definition XTPCalendarDefines.h:1377
xtpCalendarItemText_EventEndTimeText
@ xtpCalendarItemText_EventEndTimeText
Send request to customize event end time text.
Definition XTPCalendarDefines.h:1379
xtpCalendarItemText_MonthViewDayHeader
@ xtpCalendarItemText_MonthViewDayHeader
Send request to customize Month view day header text.
Definition XTPCalendarDefines.h:1366
xtpCalendarItemText_CaptionBarMonthViewDateLabel
@ xtpCalendarItemText_CaptionBarMonthViewDateLabel
Send request to customize caption bar date label for month view.
Definition XTPCalendarDefines.h:1386
xtpCalendarItemText_EventSubject
@ xtpCalendarItemText_EventSubject
Send request to customize Event subject text before draw it.
Definition XTPCalendarDefines.h:1355
xtpCalendarItemText_CaptionBarDayViewDateLabel
@ xtpCalendarItemText_CaptionBarDayViewDateLabel
Send request to customize caption bar date label for day view.
Definition XTPCalendarDefines.h:1382
xtpCalendarItemText_CaptionBarWeekViewDateLabel
@ xtpCalendarItemText_CaptionBarWeekViewDateLabel
Send request to customize caption bar date label for week view.
Definition XTPCalendarDefines.h:1384
xtpCalendarItemText_WeekViewDayHeader
@ xtpCalendarItemText_WeekViewDayHeader
Send request to customize Week view day header text.
Definition XTPCalendarDefines.h:1363
xtpCalendarItemText_EventToolTipText
@ xtpCalendarItemText_EventToolTipText
Send request to customize event tooltip text.
Definition XTPCalendarDefines.h:1373
XTPCalendarDataProviderCacheMode
XTPCalendarDataProviderCacheMode
Enumerates DB Provider cache modes.
Definition XTPCalendarDefines.h:943
xtpCalendarDPCacheModeOff
@ xtpCalendarDPCacheModeOff
Cache is not used.
Definition XTPCalendarDefines.h:944
xtpCalendarDPCacheModeOnMask
@ xtpCalendarDPCacheModeOnMask
Cache mode on mask.
Definition XTPCalendarDefines.h:949
xtpCalendarDPCacheModeOnClear
@ xtpCalendarDPCacheModeOnClear
Clear cache after every event manipulation.
Definition XTPCalendarDefines.h:947
xtpCalendarDPCacheModeOnRepeat
@ xtpCalendarDPCacheModeOnRepeat
Repeat all event manipulations in cache.
Definition XTPCalendarDefines.h:946
XTPCALENDARCTRL_CLASSNAME
static const LPCTSTR XTPCALENDARCTRL_CLASSNAME
Custom class name for the Calendar control window.
Definition XTPCalendarDefines.h:1439
XTPCalendarClockAlignFlags
XTPCalendarClockAlignFlags
Definition XTPCalendarDefines.h:306
xtpCalendarClockAlignLeft
@ xtpCalendarClockAlignLeft
Align to the left side of the rectangle area.
Definition XTPCalendarDefines.h:307
xtpCalendarClockAlignRight
@ xtpCalendarClockAlignRight
Align to the right side of the rectangle area.
Definition XTPCalendarDefines.h:309
xtpCalendarClockAlignCenter
@ xtpCalendarClockAlignCenter
Align on the middle of the rectangle area.
Definition XTPCalendarDefines.h:308
cszEventCustProp_NextReminderTime_Snoozed
static const LPCTSTR cszEventCustProp_NextReminderTime_Snoozed
String name of the corresponding property.
Definition XTPCalendarDefines.h:1072
XTPCalendarThemeVersion
XTPCalendarThemeVersion
Paint theme versions used by calendar.
Definition XTPCalendarDefines.h:87
xtpCalendarVersion2017
@ xtpCalendarVersion2017
Calendar theme version Visual Studio 2017.
Definition XTPCalendarDefines.h:97
xtpCalendarVersionUnknown
@ xtpCalendarVersionUnknown
Calendar theme version uknown.
Definition XTPCalendarDefines.h:88
xtpCalendarVersion2007
@ xtpCalendarVersion2007
Calendar theme version Office 2007.
Definition XTPCalendarDefines.h:92
xtpCalendarVersion2022
@ xtpCalendarVersion2022
Calendar theme version Visual Studio 2022.
Definition XTPCalendarDefines.h:99
xtpCalendarVersion2000
@ xtpCalendarVersion2000
Calendar theme version Office 2000.
Definition XTPCalendarDefines.h:89
xtpCalendarVersion11
@ xtpCalendarVersion11
Calendar theme version Native Windows 11.
Definition XTPCalendarDefines.h:100
xtpCalendarVersionXP
@ xtpCalendarVersionXP
Calendar theme version Office XP.
Definition XTPCalendarDefines.h:90
xtpCalendarVersion2013
@ xtpCalendarVersion2013
Calendar theme version Office 2013.
Definition XTPCalendarDefines.h:94
xtpCalendarVersion2003
@ xtpCalendarVersion2003
Calendar theme version Office 2003.
Definition XTPCalendarDefines.h:91
xtpCalendarVersion10
@ xtpCalendarVersion10
Calendar theme version Native Windows 10
Definition XTPCalendarDefines.h:96
xtpCalendarVersion2010
@ xtpCalendarVersion2010
Calendar theme version Office 2010.
Definition XTPCalendarDefines.h:93
xtpCalendarVersion2015
@ xtpCalendarVersion2015
Calendar theme version Visual Studio 2015
Definition XTPCalendarDefines.h:95
xtpCalendarVersion2019
@ xtpCalendarVersion2019
Calendar theme version Visual Studio 2019.
Definition XTPCalendarDefines.h:98
cszCalendarMarkupPrm_EndTime
static const LPCTSTR cszCalendarMarkupPrm_EndTime
End time.
Definition XTPCalendarDefines.h:1092
XTPCalendarHitTestCode
XTPCalendarHitTestCode
Enumerates allowable hit test codes.
Definition XTPCalendarDefines.h:445
xtpCalendarHitTestEventResizeVArea
@ xtpCalendarHitTestEventResizeVArea
Event vertical resize area.
Definition XTPCalendarDefines.h:461
xtpCalendarHitTestEventResizeBegin
@ xtpCalendarHitTestEventResizeBegin
Event start resizing area.
Definition XTPCalendarDefines.h:467
xtpCalendarHitTestDayExpandButton
@ xtpCalendarHitTestDayExpandButton
The position is over Expand day button icon.
Definition XTPCalendarDefines.h:450
xtpCalendarHitTestGroupHeader
@ xtpCalendarHitTestGroupHeader
The position is inside Group (resource) header.
Definition XTPCalendarDefines.h:454
xtpCalendarHitTestGroupArea
@ xtpCalendarHitTestGroupArea
The position is inside a group area (formerly day).
Definition XTPCalendarDefines.h:452
xtpCalendarHitTestAllDayEventsScrollDown
@ xtpCalendarHitTestAllDayEventsScrollDown
All Day Event block scroll down button.
Definition XTPCalendarDefines.h:482
xtpCalendarHitTestDayHeader
@ xtpCalendarHitTestDayHeader
The position is inside control's header.
Definition XTPCalendarDefines.h:449
xtpCalendarHitTestDayViewTimeScale
@ xtpCalendarHitTestDayViewTimeScale
Time scale part of the day view.
Definition XTPCalendarDefines.h:472
xtpCalendarHitTestEventDragArea
@ xtpCalendarHitTestEventDragArea
The position is on Event drag area.
Definition XTPCalendarDefines.h:458
xtpCalendarHitTestDayArea
@ xtpCalendarHitTestDayArea
The position is inside the days area.
Definition XTPCalendarDefines.h:448
xtpCalendarHitTestAllDayExpandButton
@ xtpCalendarHitTestAllDayExpandButton
The position is over Expand button icon in allday header.
Definition XTPCalendarDefines.h:493
xtpCalendarHitTestDayViewScrollUp
@ xtpCalendarHitTestDayViewScrollUp
DayView Scroll Up button (presents in office 2007 theme only).
Definition XTPCalendarDefines.h:476
xtpCalendarHitTestNextEventButton
@ xtpCalendarHitTestNextEventButton
Go to Next event button (presents in office 2007 theme only).
Definition XTPCalendarDefines.h:489
xtpCalendarHitTestDayViewScrollDown
@ xtpCalendarHitTestDayViewScrollDown
DayView Scroll Down button (presents in office 2007 theme only).
Definition XTPCalendarDefines.h:478
xtpCalendarHitTestEventResizeHArea
@ xtpCalendarHitTestEventResizeHArea
Event horizontal resize area.
Definition XTPCalendarDefines.h:462
xtpCalendarHitTestPrevEventButton
@ xtpCalendarHitTestPrevEventButton
Go to Previous event button (presents in office 2007 theme only).
Definition XTPCalendarDefines.h:487
xtpCalendarHitTestEventResizeArea_Mask
@ xtpCalendarHitTestEventResizeArea_Mask
The mask for both event resize areas.
Definition XTPCalendarDefines.h:463
xtpCalendarHitTestAllDayEventsScrollUp
@ xtpCalendarHitTestAllDayEventsScrollUp
All Day Event block scroll up button.
Definition XTPCalendarDefines.h:481
xtpCalendarHitTestDayView_Mask
@ xtpCalendarHitTestDayView_Mask
The mask for all DayView areas.
Definition XTPCalendarDefines.h:485
xtpCalendarHitTestDayViewCell
@ xtpCalendarHitTestDayViewCell
Day view cells - its general part.
Definition XTPCalendarDefines.h:473
xtpCalendarHitTestEvent_Mask
@ xtpCalendarHitTestEvent_Mask
The mask for event area at whole.
Definition XTPCalendarDefines.h:470
xtpCalendarHitTestEventTextArea
@ xtpCalendarHitTestEventTextArea
The position is on Event text view area.
Definition XTPCalendarDefines.h:459
xtpCalendarHitTestTimeLineScale
@ xtpCalendarHitTestTimeLineScale
Calendar HitTest TimeLineScale.
Definition XTPCalendarDefines.h:491
xtpCalendarHitTestUnknown
@ xtpCalendarHitTestUnknown
The position is unknown or does not belong to our control.
Definition XTPCalendarDefines.h:446
xtpCalendarHitTestDayViewAllDayEvent
@ xtpCalendarHitTestDayViewAllDayEvent
All day zone on the day view.
Definition XTPCalendarDefines.h:474
xtpCalendarHitTestEventResizeEnd
@ xtpCalendarHitTestEventResizeEnd
Event end resizing area.
Definition XTPCalendarDefines.h:468
xtpCalendarHitTestDay_Mask
@ xtpCalendarHitTestDay_Mask
The mask for any position inside days area with the header.
Definition XTPCalendarDefines.h:455
XTPCalendarTheme
XTPCalendarTheme
Paint themes used by calendar.
Definition XTPCalendarDefines.h:62
xtpCalendarThemeOffice2010
@ xtpCalendarThemeOffice2010
Office 2010 theme.
Definition XTPCalendarDefines.h:79
xtpCalendarThemeUnknown
@ xtpCalendarThemeUnknown
Undefined theme.
Definition XTPCalendarDefines.h:63
xtpCalendarThemeNativeWindows11
@ xtpCalendarThemeNativeWindows11
Windows 11 theme.
Definition XTPCalendarDefines.h:75
xtpCalendarThemeOffice2003
@ xtpCalendarThemeOffice2003
Office 2003 theme.
Definition XTPCalendarDefines.h:66
xtpCalendarThemeVisualStudio2022
@ xtpCalendarThemeVisualStudio2022
VisualStudio 2022 theme.
Definition XTPCalendarDefines.h:74
xtpCalendarThemeOffice2000
@ xtpCalendarThemeOffice2000
Office 2000 theme.
Definition XTPCalendarDefines.h:64
xtpCalendarThemeOffice2007
@ xtpCalendarThemeOffice2007
Office 2007 theme.
Definition XTPCalendarDefines.h:78
xtpCalendarThemeOffice2013
@ xtpCalendarThemeOffice2013
Office 2013 theme.
Definition XTPCalendarDefines.h:67
xtpCalendarThemeVisualStudio2019
@ xtpCalendarThemeVisualStudio2019
VisualStudio 2019 theme.
Definition XTPCalendarDefines.h:73
xtpCalendarThemeNativeWindows10
@ xtpCalendarThemeNativeWindows10
Windows 10 theme.
Definition XTPCalendarDefines.h:71
xtpCalendarThemeOffice2016
@ xtpCalendarThemeOffice2016
Office 2016 theme.
Definition XTPCalendarDefines.h:68
xtpCalendarThemeVisualStudio2015
@ xtpCalendarThemeVisualStudio2015
VisualStudio 2015 theme.
Definition XTPCalendarDefines.h:70
xtpCalendarThemeVisualStudio2017
@ xtpCalendarThemeVisualStudio2017
VisualStudio 2017 theme.
Definition XTPCalendarDefines.h:72
xtpCalendarThemeResource
@ xtpCalendarThemeResource
Resource theme.
Definition XTPCalendarDefines.h:69
xtpCalendarThemeOfficeXP
@ xtpCalendarThemeOfficeXP
Office XP theme.
Definition XTPCalendarDefines.h:65
cszEventCustProp_IconsIDs
static const LPCTSTR cszEventCustProp_IconsIDs
String name of the corresponding property.
Definition XTPCalendarDefines.h:1074
xtp_wm_SwitchView
const UINT xtp_wm_SwitchView
A message identifier of the calendar switch view custom message.
Definition XTPCalendarDefines.h:1449
XTPCALENDARCTRL_USERACTION
static const LPCTSTR XTPCALENDARCTRL_USERACTION
String name of the calendar switch view custom message.
Definition XTPCalendarDefines.h:1452
XTPCalendarUndoMode
XTPCalendarUndoMode
Enumerates flags to identify undo mode.
Definition XTPCalendarDefines.h:532
xtpCalendarUndoModeUndo
@ xtpCalendarUndoModeUndo
Undo action is pending.
Definition XTPCalendarDefines.h:534
xtpCalendarUndoModeUnknown
@ xtpCalendarUndoModeUnknown
Undo mode is undefined.
Definition XTPCalendarDefines.h:533
xtpCalendarUndoModeRedo
@ xtpCalendarUndoModeRedo
Redo action is pending.
Definition XTPCalendarDefines.h:535
XTPCalendarWeek
XTPCalendarWeek
Enumerates a sequence numbers for days.
Definition XTPCalendarDefines.h:317
xtpCalendarWeekSecond
@ xtpCalendarWeekSecond
Second.
Definition XTPCalendarDefines.h:319
xtpCalendarWeekFourth
@ xtpCalendarWeekFourth
Fourth.
Definition XTPCalendarDefines.h:321
xtpCalendarWeekThird
@ xtpCalendarWeekThird
Third
Definition XTPCalendarDefines.h:320
xtpCalendarWeekLast
@ xtpCalendarWeekLast
Last
Definition XTPCalendarDefines.h:322
xtpCalendarWeekFirst
@ xtpCalendarWeekFirst
First
Definition XTPCalendarDefines.h:318
XTPCalendarClipboardCopyFlags
XTPCalendarClipboardCopyFlags
Enumerates additional flags used in clipboard operations.
Definition XTPCalendarDefines.h:543
xtpCalendarCopyFlagKeepRException
@ xtpCalendarCopyFlagKeepRException
Keep recurrence Exception event state before paste.
Definition XTPCalendarDefines.h:546
xtpCalendarCopyFlagClearCBAfterPaste
@ xtpCalendarCopyFlagClearCBAfterPaste
Clear clipboard after paste.
Definition XTPCalendarDefines.h:548
xtpCalendarCopyFlagROccurrence2RException
@ xtpCalendarCopyFlagROccurrence2RException
Convert recurrence Occurrence to Exception before paste.
Definition XTPCalendarDefines.h:544
xtpCalendarCopyFlagCutMask
@ xtpCalendarCopyFlagCutMask
Default flags for Cut operation.
Definition XTPCalendarDefines.h:550
cszCalendarMarkupPrm_Location
static const LPCTSTR cszCalendarMarkupPrm_Location
Location.
Definition XTPCalendarDefines.h:1087
XTPCalendarViewChangedUpdateOptions
XTPCalendarViewChangedUpdateOptions
This enumeration contains options for CXTPCalendarControl::CViewChangedContext.
Definition XTPCalendarDefines.h:429
xtpCalendarViewChangedLock
@ xtpCalendarViewChangedLock
Lock sending only, send request for XTP_NC_CALENDARVIEWWASCHANGED notification is not set.
Definition XTPCalendarDefines.h:432
xtpCalendarViewChangedSend
@ xtpCalendarViewChangedSend
Set send request for XTP_NC_CALENDARVIEWWASCHANGED notification and lock sending.
Definition XTPCalendarDefines.h:430
xtp_wm_UserAction
const UINT xtp_wm_UserAction
A message identifier of the Calendar User Action custom message.
Definition XTPCalendarDefines.h:1455
XTPCalendarExpandDayButton
XTPCalendarExpandDayButton
This enum defines parameters for xtpCalendarUserAction_OnExpandDay user action.
Definition XTPCalendarDefines.h:1315
xtpCalendarExpandDayButton_WeekView
@ xtpCalendarExpandDayButton_WeekView
Defines Week view expand button.
Definition XTPCalendarDefines.h:1317
xtpCalendarExpandDayButton_MonthView
@ xtpCalendarExpandDayButton_MonthView
Defines Month view expand button.
Definition XTPCalendarDefines.h:1316
XTPCalendarEditOperation
XTPCalendarEditOperation
Enumerates customizable event edit operations.
Definition XTPCalendarDefines.h:1264
xtpCalendarEO_Paste
@ xtpCalendarEO_Paste
Paste event.
Definition XTPCalendarDefines.h:1281
xtpCalendarEO_DragResizeBegin
@ xtpCalendarEO_DragResizeBegin
Drag Resizing event begin.
Definition XTPCalendarDefines.h:1269
xtpCalendarEO_DragResizeEnd
@ xtpCalendarEO_DragResizeEnd
Drag Resizing event end.
Definition XTPCalendarDefines.h:1271
xtpCalendarEO_DeleteSelectedEvents
@ xtpCalendarEO_DeleteSelectedEvents
Delete selected events.
Definition XTPCalendarDefines.h:1284
xtpCalendarEO_DeleteEvent
@ xtpCalendarEO_DeleteEvent
Delete event.
Definition XTPCalendarDefines.h:1285
xtpCalendarEO_Unknown
@ xtpCalendarEO_Unknown
Unknown operation value.
Definition XTPCalendarDefines.h:1265
xtpCalendarEO_EditSubject_AfterEventResize
@ xtpCalendarEO_EditSubject_AfterEventResize
In-place edit event subject after event resize.
Definition XTPCalendarDefines.h:1276
xtpCalendarEO_Cut
@ xtpCalendarEO_Cut
Cut events.
Definition XTPCalendarDefines.h:1279
xtpCalendarEO_EditSubject_ByMouseClick
@ xtpCalendarEO_EditSubject_ByMouseClick
In-place edit event subject by Mouse Click.
Definition XTPCalendarDefines.h:1274
xtpCalendarEO_DragMove
@ xtpCalendarEO_DragMove
Drag move event.
Definition XTPCalendarDefines.h:1268
xtpCalendarEO_InPlaceCreateEvent
@ xtpCalendarEO_InPlaceCreateEvent
In-place event creation.
Definition XTPCalendarDefines.h:1288
xtpCalendarEO_EditSubject_ByF2
@ xtpCalendarEO_EditSubject_ByF2
In-place edit event subject by F2.
Definition XTPCalendarDefines.h:1273
xtpCalendarEO_EditSubject_ByTab
@ xtpCalendarEO_EditSubject_ByTab
In-place edit event subject by TAB.
Definition XTPCalendarDefines.h:1275
xtpCalendarEO_DragCopy
@ xtpCalendarEO_DragCopy
Drag copy event.
Definition XTPCalendarDefines.h:1267
xtpCalendarEO_Copy
@ xtpCalendarEO_Copy
Copy events.
Definition XTPCalendarDefines.h:1280
XTPCalendarEventBusyStatus
XTPCalendarEventBusyStatus
Enumerates busy status values.
Definition XTPCalendarDefines.h:170
xtpCalendarBusyStatusFree
@ xtpCalendarBusyStatusFree
Free event status.
Definition XTPCalendarDefines.h:172
xtpCalendarBusyStatusElsewhere
@ xtpCalendarBusyStatusElsewhere
Working elsewhere event status.
Definition XTPCalendarDefines.h:173
xtpCalendarBusyStatusBusy
@ xtpCalendarBusyStatusBusy
Busy event status.
Definition XTPCalendarDefines.h:175
xtpCalendarBusyStatusOutOfOffice
@ xtpCalendarBusyStatusOutOfOffice
OutOfOffice event status.
Definition XTPCalendarDefines.h:176
xtpCalendarBusyStatusTentative
@ xtpCalendarBusyStatusTentative
Tentative event status.
Definition XTPCalendarDefines.h:174
xtpCalendarBusyStatusUnknown
@ xtpCalendarBusyStatusUnknown
Typed unknown value.
Definition XTPCalendarDefines.h:171
XTPCalendarPatternEnd
XTPCalendarPatternEnd
Specify the end of the recurrence pattern type.
Definition XTPCalendarDefines.h:241
xtpCalendarPatternEndNoDate
@ xtpCalendarPatternEndNoDate
Recurrence pattern has no End.
Definition XTPCalendarDefines.h:246
xtpCalendarPatternEndDate
@ xtpCalendarPatternEndDate
End of the recurrence pattern specified by the date.
Definition XTPCalendarDefines.h:242
xtpCalendarPatternEndAfterOccurrences
@ xtpCalendarPatternEndAfterOccurrences
End of the recurrence pattern specified by the.
Definition XTPCalendarDefines.h:243
cszEventCustProp_CategoryIDs
static const LPCTSTR cszEventCustProp_CategoryIDs
String name of the corresponding property.
Definition XTPCalendarDefines.h:1077
XTPCalendarEventRecurrenceState
XTPCalendarEventRecurrenceState
Enumerates recurrence states.
Definition XTPCalendarDefines.h:223
xtpCalendarRecurrenceOccurrence
@ xtpCalendarRecurrenceOccurrence
Event is Occurrence.
Definition XTPCalendarDefines.h:226
xtpCalendarRecurrenceMaster
@ xtpCalendarRecurrenceMaster
Event is a Master (template to generate occurrences).
Definition XTPCalendarDefines.h:225
xtpCalendarRecurrenceNotRecurring
@ xtpCalendarRecurrenceNotRecurring
Event is not recurring.
Definition XTPCalendarDefines.h:224
xtpCalendarRecurrenceException
@ xtpCalendarRecurrenceException
Event is Exception (changed occurrence).
Definition XTPCalendarDefines.h:227
XTPCalendarEventRecurrenceType
XTPCalendarEventRecurrenceType
Enumerates Recurrence Pattern Types.
Definition XTPCalendarDefines.h:254
xtpCalendarRecurrenceWeekly
@ xtpCalendarRecurrenceWeekly
Every N weeks on specified 'DaysMask'.
Definition XTPCalendarDefines.h:258
xtpCalendarRecurrenceDaily
@ xtpCalendarRecurrenceDaily
Every N days.
Definition XTPCalendarDefines.h:257
xtpCalendarRecurrenceUnknown
@ xtpCalendarRecurrenceUnknown
Typed unknown value.
Definition XTPCalendarDefines.h:255
xtpCalendarRecurrenceYearNth
@ xtpCalendarRecurrenceYearNth
The first, second, ... X of month(M).
Definition XTPCalendarDefines.h:271
xtpCalendarRecurrenceMonthNth
@ xtpCalendarRecurrenceMonthNth
The first, second, ... X of every N months.
Definition XTPCalendarDefines.h:264
xtpCalendarRecurrenceMonthly
@ xtpCalendarRecurrenceMonthly
D day of every N months.
Definition XTPCalendarDefines.h:261
xtpCalendarRecurrenceYearly
@ xtpCalendarRecurrenceYearly
Every month(M) day(D).
Definition XTPCalendarDefines.h:268
XTPCalendarScrollDayButton
XTPCalendarScrollDayButton
This enum defines parameters for xtpCalendarUserAction_OnScrollDay user action.
Definition XTPCalendarDefines.h:1329
xtpCalendarScrollDayButton_DayViewUp
@ xtpCalendarScrollDayButton_DayViewUp
Defines Day view Scroll Up button.
Definition XTPCalendarDefines.h:1330
xtpCalendarScrollDayButton_DayViewDown
@ xtpCalendarScrollDayButton_DayViewDown
Defines Day view Scroll Down button.
Definition XTPCalendarDefines.h:1333
cszCalendarMarkupPrm_Subject
static const LPCTSTR cszCalendarMarkupPrm_Subject
Subject.
Definition XTPCalendarDefines.h:1085
XTPCalendarUpdateOptions
XTPCalendarUpdateOptions
Contains bit-masks for adjusting the calendar control.
Definition XTPCalendarDefines.h:411
xtpCalendarUpdateRedrawIfNeed
@ xtpCalendarUpdateRedrawIfNeed
Redraw control's picture if needed.
Definition XTPCalendarDefines.h:419
xtpCalendarUpdateRedraw
@ xtpCalendarUpdateRedraw
Redraw control picture.
Definition XTPCalendarDefines.h:416
xtpCalendarUpdateAll
@ xtpCalendarUpdateAll
Redraw all portions of the control on exiting adjuster scope.
Definition XTPCalendarDefines.h:417
xtpCalendarUpdateLayout
@ xtpCalendarUpdateLayout
Adjust positions of control's elements.
Definition XTPCalendarDefines.h:412
xtpCalendarUpdateScrollBar
@ xtpCalendarUpdateScrollBar
Recalculate control's scrollbar positions.
Definition XTPCalendarDefines.h:414
XTPCALENDARCTRL_SWITCHVIEWMSG
static const LPCTSTR XTPCALENDARCTRL_SWITCHVIEWMSG
String name of the calendar switch view custom message.
Definition XTPCalendarDefines.h:1447
XTPCalendarMouseMode
XTPCalendarMouseMode
Enumeration of operational mouse modes.
Definition XTPCalendarDefines.h:382
xtpCalendarMouseEventResizingV
@ xtpCalendarMouseEventResizingV
User is resizing event vertically (holding mouse left button down).
Definition XTPCalendarDefines.h:389
xtpCalendarMouseEventPreDrag
@ xtpCalendarMouseEventPreDrag
User is moving mouse under event view "drag" area.
Definition XTPCalendarDefines.h:388
xtpCalendarMouseEventResizingH
@ xtpCalendarMouseEventResizingH
User is resizing event horizontally (holding mouse left button down).
Definition XTPCalendarDefines.h:391
xtpCalendarMouseEventPreResizeH
@ xtpCalendarMouseEventPreResizeH
User is moving mouse under event view horizontal "resize" area.
Definition XTPCalendarDefines.h:386
xtpCalendarMouseEventDragMove
@ xtpCalendarMouseEventDragMove
User is dragging event view (holding left mouse button down and Control key is down).
Definition XTPCalendarDefines.h:395
xtpCalendarMouseEventDraggingOut
@ xtpCalendarMouseEventDraggingOut
User is dragging event out of dragging area.
Definition XTPCalendarDefines.h:397
xtpCalendarMouseEventDragCopy
@ xtpCalendarMouseEventDragCopy
User is dragging event view (holding left mouse button down).
Definition XTPCalendarDefines.h:393
xtpCalendarMouseEventPreResizeV
@ xtpCalendarMouseEventPreResizeV
User is moving mouse under event view vertical "resize" area.
Definition XTPCalendarDefines.h:384
xtpCalendarMouseNothing
@ xtpCalendarMouseNothing
User is doing nothing - just watching the control.
Definition XTPCalendarDefines.h:383
XTPCalendarCurrentTimeMarkFlags
XTPCalendarCurrentTimeMarkFlags
Enumerates flags to CXTPCalendarOptions.nDayView_CurrentTimeMarkVisible member.
Definition XTPCalendarDefines.h:576
xtpCalendarCurrentTimeMarkVisibleForToday
@ xtpCalendarCurrentTimeMarkVisibleForToday
Time Mark visible if today day is visible.
Definition XTPCalendarDefines.h:579
xtpCalendarCurrentTimeMarkVisibleAlways
@ xtpCalendarCurrentTimeMarkVisibleAlways
Time Mark always visible.
Definition XTPCalendarDefines.h:581
xtpCalendarCurrentTimeMarkPrinted
@ xtpCalendarCurrentTimeMarkPrinted
If this flag set - Time Mark is visible for printed calendar also, otherwise it is hidden when printi...
Definition XTPCalendarDefines.h:582
xtpCalendarCurrentTimeMarkNone
@ xtpCalendarCurrentTimeMarkNone
Time Mark invisible.
Definition XTPCalendarDefines.h:577
XTPCalendarSelectionChanged
XTPCalendarSelectionChanged
Enumerates calendar selection types.
Definition XTPCalendarDefines.h:1296
xtpCalendarSelectionEvents
@ xtpCalendarSelectionEvents
Events selection.
Definition XTPCalendarDefines.h:1301
xtpCalendarSelectionDays
@ xtpCalendarSelectionDays
Days (or day hours for day view) selection.
Definition XTPCalendarDefines.h:1299
xtpCalendarSelectionUnknown
@ xtpCalendarSelectionUnknown
Unknown selection value.
Definition XTPCalendarDefines.h:1297
XTPCalendarEventIconIDs
XTPCalendarEventIconIDs
Icons IDs set to be used with calendar event custom icons to customize standard event glyphs.
Definition XTPCalendarDefines.h:593
xtpCalendarEventIconIDReminder
@ xtpCalendarEventIconIDReminder
Reminder glyph ID.
Definition XTPCalendarDefines.h:594
xtpCalendarEventIconIDMeeting
@ xtpCalendarEventIconIDMeeting
Meeting glyph ID.
Definition XTPCalendarDefines.h:597
xtpCalendarEventIconIDPrivate
@ xtpCalendarEventIconIDPrivate
Private glyph ID.
Definition XTPCalendarDefines.h:598
xtpCalendarEventIconIDException
@ xtpCalendarEventIconIDException
Recurrence exception glyph ID.
Definition XTPCalendarDefines.h:596
xtpCalendarEventIconIDOccurrence
@ xtpCalendarEventIconIDOccurrence
Recurrence glyph ID.
Definition XTPCalendarDefines.h:595
XTPCalendarDayViewScrollDirection
XTPCalendarDayViewScrollDirection
Enumeration used to determine the scroll direction.
Definition XTPCalendarDefines.h:699
xtpCalendarDayViewScrollUp
@ xtpCalendarDayViewScrollUp
ScrollV Up.
Definition XTPCalendarDefines.h:700
xtpCalendarDayViewScrollLeft
@ xtpCalendarDayViewScrollLeft
ScrollH Left.
Definition XTPCalendarDefines.h:703
xtpCalendarDayViewScrollNotNeeded
@ xtpCalendarDayViewScrollNotNeeded
Scrolling not needed.
Definition XTPCalendarDefines.h:702
xtpCalendarDayViewScrollRight
@ xtpCalendarDayViewScrollRight
ScrollH Right.
Definition XTPCalendarDefines.h:704
xtpCalendarDayViewScrollDown
@ xtpCalendarDayViewScrollDown
ScrollV Down.
Definition XTPCalendarDefines.h:701
cszCalendarMarkupPrm_Body
static const LPCTSTR cszCalendarMarkupPrm_Body
Body.
Definition XTPCalendarDefines.h:1089
WM_XTP_CALENDAR_BASE
const UINT WM_XTP_CALENDAR_BASE
The WM_XTP_CALENDAR_BASE constant is used by Calendar Control to help define private messages for use...
Definition XTPCalendarDefines.h:1069
cszEventCustProp_MarkupTemplate
static const LPCTSTR cszEventCustProp_MarkupTemplate
String name of the MarkupTemplate property.
Definition XTPCalendarDefines.h:1081
XTPCalendarDraggingMode
XTPCalendarDraggingMode
Enumerates allowable dragging mode state codes.
Definition XTPCalendarDefines.h:504
xtpCalendaDragModeResizeEnd
@ xtpCalendaDragModeResizeEnd
Resizing event end.
Definition XTPCalendarDefines.h:511
xtpCalendaDragModeUnknown
@ xtpCalendaDragModeUnknown
No dragging mode.
Definition XTPCalendarDefines.h:505
xtpCalendaDragModeCopy
@ xtpCalendaDragModeCopy
Copying event.
Definition XTPCalendarDefines.h:507
xtpCalendaDragModeEditSubject
@ xtpCalendaDragModeEditSubject
Editing event subject.
Definition XTPCalendarDefines.h:513
xtpCalendaDragModeResizeBegin
@ xtpCalendaDragModeResizeBegin
Resizing event begin.
Definition XTPCalendarDefines.h:510
xtpCalendaDragModeMove
@ xtpCalendaDragModeMove
Moving event.
Definition XTPCalendarDefines.h:508
XTPCalendarGetItemTextEx
XTPCalendarGetItemTextEx
This enum defines set of flags which enable calendar items to send XTP_NC_CALENDAR_GETITEMTEXT notifi...
Definition XTPCalendarDefines.h:1404
xtpCalendarItemText_WeekViewDayHeaderCenter
@ xtpCalendarItemText_WeekViewDayHeaderCenter
Send request to customize Week view day header text on the center.
Definition XTPCalendarDefines.h:1419
xtpCalendarItemText_WeekViewDayHeaderRight
@ xtpCalendarItemText_WeekViewDayHeaderRight
Send request to customize Week view day header text on the right.
Definition XTPCalendarDefines.h:1422
xtpCalendarItemText_EventBody
@ xtpCalendarItemText_EventBody
Send request to customize Event body text before draw it.
Definition XTPCalendarDefines.h:1405
xtpCalendarItemText_DayViewDayHeaderCenter
@ xtpCalendarItemText_DayViewDayHeaderCenter
Send request to customize Day view day header text on the center.
Definition XTPCalendarDefines.h:1412
xtpCalendarItemText_EventMarkupTemplate
@ xtpCalendarItemText_EventMarkupTemplate
Send request to set Event Markup Template text before draw it.
Definition XTPCalendarDefines.h:1407
xtpCalendarItemText_MonthViewDayHeaderRight
@ xtpCalendarItemText_MonthViewDayHeaderRight
Send request to customize Month view day header text on the right.
Definition XTPCalendarDefines.h:1430
xtpCalendarItemText_DayViewDayHeaderRight
@ xtpCalendarItemText_DayViewDayHeaderRight
Send request to customize Day view day header text on the right.
Definition XTPCalendarDefines.h:1414
xtpCalendarItemText_MonthViewDayHeaderCenter
@ xtpCalendarItemText_MonthViewDayHeaderCenter
Send request to customize Month view day header text on the center.
Definition XTPCalendarDefines.h:1428
xtpCalendarItemText_DayViewDayHeaderLeft
@ xtpCalendarItemText_DayViewDayHeaderLeft
Send request to customize Day view day header text on the left.
Definition XTPCalendarDefines.h:1410
xtpCalendarItemText_WeekViewDayHeaderLeft
@ xtpCalendarItemText_WeekViewDayHeaderLeft
Send request to customize Week view day header text on the left.
Definition XTPCalendarDefines.h:1417
xtpCalendarItemText_MonthViewDayHeaderLeft
@ xtpCalendarItemText_MonthViewDayHeaderLeft
Send request to customize Month view day header text on the left.
Definition XTPCalendarDefines.h:1426
CXTPCalendarDatesArray
CArray< COleDateTime, COleDateTime & > CXTPCalendarDatesArray
Type definition for an array of dates.
Definition XTPCalendarDefines.h:234
XTPCalendarEndEditSubjectAction
XTPCalendarEndEditSubjectAction
Enumerates allowable flags for driving subject editors.
Definition XTPCalendarDefines.h:521
xtpCalendarEditSubjectUnknown
@ xtpCalendarEditSubjectUnknown
Action is undefined.
Definition XTPCalendarDefines.h:522
xtpCalendarEditSubjectCancel
@ xtpCalendarEditSubjectCancel
Cancel editing and dragging changes.
Definition XTPCalendarDefines.h:524
xtpCalendarEditSubjectCommit
@ xtpCalendarEditSubjectCommit
Apply and commit dragging.
Definition XTPCalendarDefines.h:523
XTPCalendarWeekDay
XTPCalendarWeekDay
Enumerates Day of Weeks codes.
Definition XTPCalendarDefines.h:282
xtpCalendarDayFriday
@ xtpCalendarDayFriday
Friday
Definition XTPCalendarDefines.h:288
xtpCalendarDayMonday
@ xtpCalendarDayMonday
Monday
Definition XTPCalendarDefines.h:284
xtpCalendarDayTuesday
@ xtpCalendarDayTuesday
Tuesday.
Definition XTPCalendarDefines.h:285
xtpCalendarDaySaturday
@ xtpCalendarDaySaturday
Saturday
Definition XTPCalendarDefines.h:289
xtpCalendarDaySunday
@ xtpCalendarDaySunday
Sunday
Definition XTPCalendarDefines.h:283
xtpCalendarDayThursday
@ xtpCalendarDayThursday
Thursday
Definition XTPCalendarDefines.h:287
xtpCalendarDayMo_Fr
@ xtpCalendarDayMo_Fr
Monday to Friday mask.
Definition XTPCalendarDefines.h:297
xtpCalendarDaySaSu
@ xtpCalendarDaySaSu
Saturday, Sunday mask.
Definition XTPCalendarDefines.h:295
xtpCalendarDayWednesday
@ xtpCalendarDayWednesday
Wednesday
Definition XTPCalendarDefines.h:286
xtpCalendarDayAllWeek
@ xtpCalendarDayAllWeek
All week mask.
Definition XTPCalendarDefines.h:291
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEventLabel
This class defines Calendar Event label properties.
Definition XTPCalendarEventLabel.h:43
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
Definition XTPCalendarEventLabel.h:120
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarMonthViewDay
This class represents a day view portion of the CalendarMonthView.
Definition XTPCalendarMonthViewDay.h:151
CXTPCalendarMonthViewEvent
This class represents an event view portion of the CalendarMonthViewDay.
Definition XTPCalendarMonthViewEvent.h:56
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856
XTP_CALENDAR_HITTESTINFO::nEvent
int nEvent
ID of the specified event.
Definition XTPCalendarDefines.h:864
XTP_CALENDAR_HITTESTINFO::nDay
int nDay
Number of the day.
Definition XTPCalendarDefines.h:862
XTP_CALENDAR_HITTESTINFO::nGroup
int nGroup
Number of the group.
Definition XTPCalendarDefines.h:863
XTP_CALENDAR_HITTESTINFO::operator==
BOOL operator==(const XTP_CALENDAR_HITTESTINFO &hitInfo2)
Equality operator.
XTP_CALENDAR_HITTESTINFO::operator!=
BOOL operator!=(const XTP_CALENDAR_HITTESTINFO &hitInfo2)
Non-Equality operator.
Definition XTPCalendarDefines.h:928
XTP_CALENDAR_HITTESTINFO::~XTP_CALENDAR_HITTESTINFO
virtual ~XTP_CALENDAR_HITTESTINFO()
Default destructor.
Definition XTPCalendarDefines.h:902
XTP_CALENDAR_HITTESTINFO::uHitCode
int uHitCode
A bitwise combination of XTPCalendarHitTestCode constants.
Definition XTPCalendarDefines.h:860
XTP_CALENDAR_HITTESTINFO::pViewEvent
CXTPCalendarViewEvent * pViewEvent
Pointer to affected CXTPCalendarViewEvent object.
Definition XTPCalendarDefines.h:868
XTP_CALENDAR_HITTESTINFO::pViewGroup
CXTPCalendarViewGroup * pViewGroup
Pointer to affected CXTPCalendarViewGroup object.
Definition XTPCalendarDefines.h:867
XTP_CALENDAR_HITTESTINFO::dt
COleDateTime dt
Time stamp on the specified point.
Definition XTPCalendarDefines.h:857
XTP_CALENDAR_HITTESTINFO::bTimePartValid
BOOL bTimePartValid
Specifies whether date's time part is valid, i.e.
Definition XTPCalendarDefines.h:858
XTP_CALENDAR_HITTESTINFO::pViewDay
CXTPCalendarViewDay * pViewDay
Pointer to affected CXTPCalendarViewDay object.
Definition XTPCalendarDefines.h:866
XTP_CALENDAR_HITTESTINFO::pt
POINT pt
DayView Point where the mouse was clicked in client coordinates.
Definition XTPCalendarDefines.h:872
XTP_CALENDAR_HITTESTINFO::dayPOS
XTP_CALENDAR_MONTHVIEW_DAYPOS dayPOS
MonthView Day position.
Definition XTPCalendarDefines.h:871
XTP_CALENDAR_HITTESTINFO::XTP_CALENDAR_HITTESTINFO
XTP_CALENDAR_HITTESTINFO()
Default constructor.
Definition XTPCalendarDefines.h:883
XTP_CALENDAR_MONTHVIEW_DAYPOS
Defines a set of data and methods to easily manipulate with day positions in month view.
Definition XTPCalendarDefines.h:714
XTP_CALENDAR_MONTHVIEW_DAYPOS::GetPOS
int GetPOS() const
This member function is used to obtain a sequential integer value.
Definition XTPCalendarMonthView.h:905
XTP_CALENDAR_MONTHVIEW_DAYPOS::nWeekIndex
int nWeekIndex
Week index.
Definition XTPCalendarDefines.h:715
XTP_CALENDAR_MONTHVIEW_DAYPOS::nWeekDayIndex
int nWeekDayIndex
Week day cell index.
Definition XTPCalendarDefines.h:716
XTP_CALENDAR_MONTHVIEW_DAYPOS::operator++
XTP_CALENDAR_MONTHVIEW_DAYPOS & operator++()
This member function is used to pre-increment a sequential position by 1.
Definition XTPCalendarMonthView.h:935
XTP_CALENDAR_MONTHVIEW_DAYPOS::IsValid
BOOL IsValid() const
This member function is used to determine if the WeekIndex and WeekDayIndex values are valid.
Definition XTPCalendarMonthView.h:920
XTP_CALENDAR_MONTHVIEW_DAYPOS::operator=
const XTP_CALENDAR_MONTHVIEW_DAYPOS & operator=(int nPOS)
This member function is used to set a new Sequential integer value.
Definition XTPCalendarMonthView.h:930
XTP_CALENDAR_MONTHVIEW_DAYPOS::SetPOS
void SetPOS(int nWidx, int nWDidx)
This member function is used to set a new week/day index value.
Definition XTPCalendarMonthView.h:910
XTP_CALENDAR_PATTERN_END
This structure describes parameters of the end of the recurrence pattern type.
Definition XTPCalendarDefines.h:1102
XTP_CALENDAR_PATTERN_END::operator=
const XTP_CALENDAR_PATTERN_END & operator=(const XTP_CALENDAR_PATTERN_END &rSrc)
This assignment operator is used to initialize a XTP_CALENDAR_PATTERN_END object.
Definition XTPCalendarDefines.h:1136
XTP_CALENDAR_PATTERN_END::~XTP_CALENDAR_PATTERN_END
virtual ~XTP_CALENDAR_PATTERN_END()
Default destructor of the structure.
Definition XTPCalendarDefines.h:1125
XTP_CALENDAR_PATTERN_END::m_nUseEnd
XTPCalendarPatternEnd m_nUseEnd
End type.
Definition XTPCalendarDefines.h:1155
XTP_CALENDAR_PATTERN_END::XTP_CALENDAR_PATTERN_END
XTP_CALENDAR_PATTERN_END()
Default constructor of the structure.
Definition XTPCalendarDefines.h:1110
XTP_CALENDAR_PATTERN_END::m_dtPatternEndDate
COleDateTime m_dtPatternEndDate
End date.
Definition XTPCalendarDefines.h:1157
XTP_CALENDAR_PATTERN_END::m_nEndAfterOccurrences
int m_nEndAfterOccurrences
End number of occurrences.
Definition XTPCalendarDefines.h:1158
XTP_CALENDAR_VIEWSELECTION
Structure contains the calendar day view selection block.
Definition XTPCalendarDefines.h:615
XTP_CALENDAR_VIEWSELECTION::bAllDayEvent
BOOL bAllDayEvent
TRUE when all day is selected, FALSE otherwise.
Definition XTPCalendarDefines.h:685
XTP_CALENDAR_VIEWSELECTION::dtBegin
COleDateTime dtBegin
Selection start time.
Definition XTPCalendarDefines.h:683
XTP_CALENDAR_VIEWSELECTION::nGroupIndex
int nGroupIndex
Numeric index of the corresponding resource group.
Definition XTPCalendarDefines.h:682
XTP_CALENDAR_VIEWSELECTION::XTP_CALENDAR_VIEWSELECTION
XTP_CALENDAR_VIEWSELECTION()
Default constructor.
Definition XTPCalendarDefines.h:625
XTP_CALENDAR_VIEWSELECTION::operator=
const XTP_CALENDAR_VIEWSELECTION & operator=(const XTP_CALENDAR_VIEWSELECTION &rSrc)
Copy operator.
Definition XTPCalendarDefines.h:644
XTP_CALENDAR_VIEWSELECTION::IsValid
BOOL IsValid() const
Determines if the values of date time object members are valid.
Definition XTPCalendarDefines.h:675
XTP_CALENDAR_VIEWSELECTION::dtEnd
COleDateTime dtEnd
Selection finish time.
Definition XTPCalendarDefines.h:684
XTP_WEEK_VIEW_LAYOUT
This struct store a Week View layout.
Definition XTPCalendarDefines.h:1238
XTP_WEEK_VIEW_LAYOUT::m_nGridColumns
int m_nGridColumns
Number of columns in a week day grid.
Definition XTPCalendarDefines.h:1239
XTP_WEEK_VIEW_LAYOUT::m_nDayHeaderHeight
int m_nDayHeaderHeight
Height of a day header.
Definition XTPCalendarDefines.h:1240
XTP_WEEK_VIEW_LAYOUT::m_nDayWidth
int m_nDayWidth
Width of day rectangle.
Definition XTPCalendarDefines.h:1242
XTP_WEEK_VIEW_LAYOUT::m_nDayHeight
int m_nDayHeight
Height of day rectangle.
Definition XTPCalendarDefines.h:1243


Toolkit Pro: XTPDockingPaneDefines.h Source File

  • Source
  • DockingPane
XTPDockingPaneDefines.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEDEFINES_H__)
24# define __XTPDOCKINGPANEDEFINES_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPane;
34class CXTPDockingPaneBase;
35class CXTPDockingPaneBase;
36
50enum XTPDockingPaneDirection
51{
52 xtpPaneDockUndefined = -1,
53 xtpPaneDockLeft,
54 xtpPaneDockRight,
55 xtpPaneDockTop,
56 xtpPaneDockBottom,
57 xtpPaneDockMiniWnd
58};
59
76enum XTPDockingPaneType
77{
78 xtpPaneTypeDockingPane,
79 xtpPaneTypeTabbedContainer,
80 xtpPaneTypeSplitterContainer,
81 xtpPaneTypeMiniWnd,
82 xtpPaneTypeClient,
83 xtpPaneTypeAutoHidePanel,
84 xtpPaneTypeSidePanel
85};
86
99enum XTPDockingPanePaintTheme
100{
101 xtpPaneThemeDefault,
102 xtpPaneThemeVisualStudio2003,
103 xtpPaneThemeOffice2003,
104 xtpPaneThemeWinNative,
105 xtpPaneThemeGrippered,
106 xtpPaneThemeOffice2002Visio,
107 xtpPaneThemeVisualStudio2005Beta1,
108 xtpPaneThemeOffice2003Outlook,
109 xtpPaneThemeWinExplorer,
110 xtpPaneThemeVisualStudio2005,
111 xtpPaneThemeResource,
112 xtpPaneThemeOffice2007Word,
113 xtpPaneThemeOffice2007Outlook,
114 xtpPaneThemeVisualStudio6,
115 xtpPaneThemeVisualStudio2005Beta2,
116 xtpPaneThemeVisualStudio2008,
117 xtpPaneThemeVisualStudio2010,
118 xtpPaneThemeOffice2003Visio,
119 xtpPaneThemeOffice2007Visio,
120 xtpPaneThemeOffice2013,
121 xtpPaneThemeOffice2016 = xtpPaneThemeOffice2013,
122 xtpPaneThemeVisualStudio2012,
123 xtpPaneThemeVisualStudio2015,
124 xtpPaneThemeCustom,
125 xtpPaneThemeNativeWindows10,
126 xtpPaneThemeVisualStudio2017,
127 xtpPaneThemeVisualStudio2019,
128 xtpPaneThemeVisualStudio2022,
129 xtpPaneThemeNativeWindows11,
130};
131
133# define xtpPaneThemeOffice \
134 xtpPaneThemeVisualStudio2003 // obsolete names, for backward compatibility only.
135# define xtpPaneThemeNativeWinXP xtpPaneThemeWinNative
136# define xtpPaneThemeExplorer xtpPaneThemeWinExplorer
137# define xtpPaneThemeVisio xtpPaneThemeOffice2002Visio
138# define xtpPaneThemeWhidbey xtpPaneThemeVisualStudio2005Beta1
139# define xtpPaneThemeShortcutBar2003 xtpPaneThemeOffice2003Outlook
140# define xtpPaneThemeWord2007 xtpPaneThemeOffice2007Word
141# define xtpPaneThemeOutlook2007 xtpPaneThemeOffice2007Outlook
142# define xtpPaneThemeOffice2007 xtpPaneThemeResource
154enum XTPDockingContextStickerStyle
155{
156 xtpPaneStickerStyleVisualStudio2005Beta,
157 xtpPaneStickerStyleVisualStudio2005,
158 xtpPaneStickerStyleVisualStudio2008,
159 xtpPaneStickerStyleVisualStudio2010,
160 xtpPaneStickerStyleVisualStudio2012Light,
161 xtpPaneStickerStyleVisualStudio2012Dark,
162 xtpPaneStickerStyleVisualStudio2015Light,
163 xtpPaneStickerStyleVisualStudio2015Blue,
164 xtpPaneStickerStyleVisualStudio2015Dark,
165 xtpPaneStickerStyleVisualStudio2017Light,
166 xtpPaneStickerStyleVisualStudio2017Blue,
167 xtpPaneStickerStyleVisualStudio2017BlueExtra,
168 xtpPaneStickerStyleVisualStudio2017Dark,
169 xtpPaneStickerStyleVisualStudio2019Light,
170 xtpPaneStickerStyleVisualStudio2019Blue,
171 xtpPaneStickerStyleVisualStudio2019BlueExtra,
172 xtpPaneStickerStyleVisualStudio2019Dark,
173 xtpPaneStickerStyleVisualStudio2022Light,
174 xtpPaneStickerStyleVisualStudio2022Blue,
175 xtpPaneStickerStyleVisualStudio2022BlueExtra,
176 xtpPaneStickerStyleVisualStudio2022Dark,
177 xtpPaneStickerStyleNativeWindows10Light,
178 xtpPaneStickerStyleNativeWindows10Dark,
179 xtpPaneStickerStyleNativeWindows11Light,
180 xtpPaneStickerStyleNativeWindows11Dark,
181};
182
184# define xtpPaneStickerStyleWhidbey \
185 xtpPaneStickerStyleVisualStudio2005Beta // obsolete name, for backward compatibility only.
203enum XTPDockingPaneOptions
204{
205 xtpPaneNoCloseable = 1,
206 xtpPaneNoHideable = 2,
207 xtpPaneNoFloatable = 4,
208 xtpPaneNoCaption = 8,
209 xtpPaneHasMenuButton = 16,
210 xtpPaneNoDockable = 32,
211 xtpPaneNoFloatableByTabDoubleClick = 64,
213 xtpPaneNoFloatableByCaptionDoubleClick = 128,
215 xtpPaneNoHoverShow = 1024
216};
217
231enum XTPDockingPaneCaptionDirection
232{
233 xtpPaneCaptionHorizontal,
234 xtpPaneCaptionVertical,
235 xtpPaneCaptionAutoByPosition,
236 xtpPaneCaptionAutoBySize
237};
238
267enum XTPDockingPaneAction
268{
269 xtpPaneActionFloating,
272 xtpPaneActionFloated,
273 xtpPaneActionClosing,
275 xtpPaneActionClosed,
277 xtpPaneActionDocking,
278 xtpPaneActionDocked,
280 xtpPaneActionAttaching,
281 xtpPaneActionAttached,
283 xtpPaneActionPinning,
285 xtpPaneActionPinned,
287 xtpPaneActionCollapsing,
292 xtpPaneActionCollapsed,
294 xtpPaneActionExpanding,
299 xtpPaneActionExpanded,
301 xtpPaneActionActivated,
302 xtpPaneActionDeactivated,
303 xtpPaneActionDetaching,
304 xtpPaneActionDragging,
305 xtpPaneActionUnpinning,
307 xtpPaneActionUnpinned,
309 xtpPaneActionSplitterResizing,
310 xtpPaneActionSplitterResized
311};
312
317enum XTPDockingPaneEnableOptions
318{
319 xtpPaneDisabled = 0,
320 xtpPaneEnableClient = 1,
321 xtpPaneEnableActions = 2,
322 xtpPaneEnabled = 3,
323 xtpPaneEnabledAuto = 4 + 3
324};
325
337enum XTPDockingPaneKeyboardNavigate
338{
339 xtpPaneKeyboardUnused = 0,
340 xtpPaneKeyboardUseAltMinus = 1,
341 xtpPaneKeyboardUseAltF6 = 2,
342 xtpPaneKeyboardUseAltF7 = 4,
343 xtpPaneKeyboardUseCtrlTab = 8,
344 xtpPaneKeyboardUseAll = 15
345};
346
361enum XTPDockingPaneStickerType
362{
363 xtpPaneStickerNone = 0,
364 xtpPaneStickerLeft = 1,
366 xtpPaneStickerRight = 2,
368 xtpPaneStickerTop = 4,
370 xtpPaneStickerBottom = 8,
372 xtpPaneStickerCenter = 16,
374 xtpPaneStickerClient = 32
376};
377
385struct XTP_DOCKINGPANE_CLICK
386{
387 CXTPDockingPane* pPane;
388 CXTPDockingPaneBase* pContainer;
389 CPoint pt;
390 CRect rcExclude;
391};
392
414struct XTP_DOCKINGPANE_ACTION
415{
417 XTP_DOCKINGPANE_ACTION(XTPDockingPaneAction _action)
418 {
419 pPane = NULL;
420 pDockContainer = NULL;
421 action = _action;
422 bCancel = FALSE;
423 dockDirection = xtpPaneDockUndefined;
424 }
427 XTPDockingPaneAction action;
428 BOOL bCancel;
429 CXTPDockingPane* pPane;
430 CXTPDockingPaneBase* pDockContainer;
431 XTPDockingPaneDirection dockDirection;
433};
434
441struct XTP_DOCKINGPANE_INFO
442{
444 XTP_DOCKINGPANE_INFO(CXTPDockingPane* p = NULL)
445 {
446 pPane = p;
447 pLastHolder = pDockingHolder = pFloatingHolder = 0;
448 }
449
450 operator CXTPDockingPane*()
451 {
452 return pPane;
453 }
454 CXTPDockingPane* operator->()
455 {
456 return pPane;
457 }
460 CXTPDockingPane* pPane;
461 CXTPDockingPaneBase* pFloatingHolder;
462 CXTPDockingPaneBase* pDockingHolder;
463 CXTPDockingPaneBase* pLastHolder;
465};
466
474typedef CList<CXTPDockingPane*, CXTPDockingPane*> CXTPDockingPaneList;
475
482typedef CList<CXTPDockingPaneBase*, CXTPDockingPaneBase*> CXTPDockingPaneBaseList;
483
491typedef CList<XTP_DOCKINGPANE_INFO, XTP_DOCKINGPANE_INFO&> CXTPDockingPaneInfoList;
492
513typedef CMap<CXTPDockingPaneBase*, CXTPDockingPaneBase*, CXTPDockingPaneBase*, CXTPDockingPaneBase*>
514 CXTPPaneToPaneMap;
515
520typedef CMap<int, int, CXTPDockingPaneBase*, CXTPDockingPaneBase*> CXTPPaneIndexToPaneMap;
521
526const UINT WM_XTP_DOCKINGPANE_BASE = (WM_USER + 9900);
527
611# define XTPWM_DOCKINGPANE_NOTIFY (WM_XTP_DOCKINGPANE_BASE + 1)
612
613const int XTP_DPN_SHOWWINDOW = 1;
614const int XTP_DPN_RCLICK = 2;
615const int XTP_DPN_CLOSEPANE = 3;
616const int XTP_DPN_ACTION = 4;
617const int XTP_DPN_CONTEXTMENU = 5;
618const int XTP_ACTION_NOCLOSE = -1;
622// Obsolete
623
624# define XTP_DPN_PANEMENUCLICK XTP_DPN_CONTEXTMENU
627# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
628#endif // #if !defined(__XTPDOCKINGPANEDEFINES_H__)
XTPDisableNoisyWarnings.h
XTP_DPN_RCLICK
const int XTP_DPN_RCLICK
Definition XTPDockingPaneDefines.h:614
CXTPPaneIndexToPaneMap
CMap< int, int, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneIndexToPaneMap
This map is used for mapping index to CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:520
XTP_ACTION_NOCLOSE
const int XTP_ACTION_NOCLOSE
Definition XTPDockingPaneDefines.h:618
XTP_DPN_ACTION
const int XTP_DPN_ACTION
Definition XTPDockingPaneDefines.h:616
XTPDockingPaneType
XTPDockingPaneType
Docking pane type.
Definition XTPDockingPaneDefines.h:77
xtpPaneTypeTabbedContainer
@ xtpPaneTypeTabbedContainer
Object is the tabbed container.
Definition XTPDockingPaneDefines.h:79
xtpPaneTypeClient
@ xtpPaneTypeClient
Object is the pane contained client area.
Definition XTPDockingPaneDefines.h:82
xtpPaneTypeMiniWnd
@ xtpPaneTypeMiniWnd
Object is the mini-window container.
Definition XTPDockingPaneDefines.h:81
xtpPaneTypeAutoHidePanel
@ xtpPaneTypeAutoHidePanel
Object is the auto-hide panel.
Definition XTPDockingPaneDefines.h:83
xtpPaneTypeDockingPane
@ xtpPaneTypeDockingPane
Object is the docking pane.
Definition XTPDockingPaneDefines.h:78
xtpPaneTypeSplitterContainer
@ xtpPaneTypeSplitterContainer
Object is the splitter container.
Definition XTPDockingPaneDefines.h:80
xtpPaneTypeSidePanel
@ xtpPaneTypeSidePanel
Object is the side panel.
Definition XTPDockingPaneDefines.h:84
XTPDockingPaneCaptionDirection
XTPDockingPaneCaptionDirection
Docking Pane Caption direction enumeration.
Definition XTPDockingPaneDefines.h:232
xtpPaneCaptionVertical
@ xtpPaneCaptionVertical
Show caption on left.
Definition XTPDockingPaneDefines.h:234
xtpPaneCaptionAutoBySize
@ xtpPaneCaptionAutoBySize
Automatically.
Definition XTPDockingPaneDefines.h:236
xtpPaneCaptionHorizontal
@ xtpPaneCaptionHorizontal
Show caption on top.
Definition XTPDockingPaneDefines.h:233
xtpPaneCaptionAutoByPosition
@ xtpPaneCaptionAutoByPosition
Automatically.
Definition XTPDockingPaneDefines.h:235
xtpPaneNoCloseable
@ xtpPaneNoCloseable
A Pane can't be closed.
Definition XTPDockingPaneDefines.h:205
xtpPaneNoHideable
@ xtpPaneNoHideable
A Pane can't be hidden.
Definition XTPDockingPaneDefines.h:206
xtpPaneNoHoverShow
@ xtpPaneNoHoverShow
A pane won't be shown on hoverusing a mouse.
Definition XTPDockingPaneDefines.h:215
xtpPaneNoFloatableByTabDoubleClick
@ xtpPaneNoFloatableByTabDoubleClick
A Pane can't be floated by a double-click on the tab button.
Definition XTPDockingPaneDefines.h:211
xtpPaneNoFloatable
@ xtpPaneNoFloatable
A Pane can't be floated.
Definition XTPDockingPaneDefines.h:207
xtpPaneHasMenuButton
@ xtpPaneHasMenuButton
A Pane has menu button.
Definition XTPDockingPaneDefines.h:209
xtpPaneNoFloatableByCaptionDoubleClick
@ xtpPaneNoFloatableByCaptionDoubleClick
Pane can't be floated by a double-click on the pane caption.
Definition XTPDockingPaneDefines.h:213
xtpPaneNoDockable
@ xtpPaneNoDockable
A Pane can't be docked.
Definition XTPDockingPaneDefines.h:210
xtpPaneNoCaption
@ xtpPaneNoCaption
A Pane has no caption.
Definition XTPDockingPaneDefines.h:208
XTP_DPN_SHOWWINDOW
const int XTP_DPN_SHOWWINDOW
Definition XTPDockingPaneDefines.h:613
XTP_DPN_CLOSEPANE
const int XTP_DPN_CLOSEPANE
Definition XTPDockingPaneDefines.h:615
XTPDockingPaneDirection
XTPDockingPaneDirection
Docking direction enumeration.
Definition XTPDockingPaneDefines.h:51
xtpPaneDockBottom
@ xtpPaneDockBottom
To dock the pane to the bottom of the pane or frame.
Definition XTPDockingPaneDefines.h:56
xtpPaneDockTop
@ xtpPaneDockTop
To dock the pane to the top of the pane or frame.
Definition XTPDockingPaneDefines.h:55
xtpPaneDockMiniWnd
@ xtpPaneDockMiniWnd
Docking pane is floating mini-frame window.
Definition XTPDockingPaneDefines.h:57
xtpPaneDockLeft
@ xtpPaneDockLeft
To dock the pane to the left of the pane or frame.
Definition XTPDockingPaneDefines.h:53
xtpPaneDockRight
@ xtpPaneDockRight
To dock the pane to the right of the pane or frame.
Definition XTPDockingPaneDefines.h:54
xtpPaneDockUndefined
@ xtpPaneDockUndefined
Docking pane direction is unspecified.
Definition XTPDockingPaneDefines.h:52
XTPDockingPaneEnableOptions
XTPDockingPaneEnableOptions
Enable options of the pane.
Definition XTPDockingPaneDefines.h:318
xtpPaneEnabled
@ xtpPaneEnabled
Pane is enabled.
Definition XTPDockingPaneDefines.h:322
xtpPaneDisabled
@ xtpPaneDisabled
Pane is disabled.
Definition XTPDockingPaneDefines.h:319
xtpPaneEnabledAuto
@ xtpPaneEnabledAuto
Pane is automatically enabled.
Definition XTPDockingPaneDefines.h:323
xtpPaneEnableActions
@ xtpPaneEnableActions
All actions are enabled.
Definition XTPDockingPaneDefines.h:321
xtpPaneEnableClient
@ xtpPaneEnableClient
Client is enabled.
Definition XTPDockingPaneDefines.h:320
XTPDockingContextStickerStyle
XTPDockingContextStickerStyle
Docking Panes sticker style enumeration.
Definition XTPDockingPaneDefines.h:155
xtpPaneStickerStyleVisualStudio2015Light
@ xtpPaneStickerStyleVisualStudio2015Light
Visual Studio 2015 light stickers.
Definition XTPDockingPaneDefines.h:162
xtpPaneStickerStyleVisualStudio2008
@ xtpPaneStickerStyleVisualStudio2008
Visual Studio 2008 stickers.
Definition XTPDockingPaneDefines.h:158
xtpPaneStickerStyleNativeWindows10Light
@ xtpPaneStickerStyleNativeWindows10Light
Native Windows 10 light stickers.
Definition XTPDockingPaneDefines.h:177
xtpPaneStickerStyleVisualStudio2017BlueExtra
@ xtpPaneStickerStyleVisualStudio2017BlueExtra
Visual Studio 2017 blue extra stickers.
Definition XTPDockingPaneDefines.h:167
xtpPaneStickerStyleVisualStudio2019Light
@ xtpPaneStickerStyleVisualStudio2019Light
Visual Studio 2019 light stickers.
Definition XTPDockingPaneDefines.h:169
xtpPaneStickerStyleVisualStudio2017Blue
@ xtpPaneStickerStyleVisualStudio2017Blue
Visual Studio 2017 blue stickers.
Definition XTPDockingPaneDefines.h:166
xtpPaneStickerStyleVisualStudio2005Beta
@ xtpPaneStickerStyleVisualStudio2005Beta
Visual Studio 2005 Beta stickers.
Definition XTPDockingPaneDefines.h:156
xtpPaneStickerStyleNativeWindows11Dark
@ xtpPaneStickerStyleNativeWindows11Dark
Native Windows 11 dark stickers.
Definition XTPDockingPaneDefines.h:180
xtpPaneStickerStyleVisualStudio2017Dark
@ xtpPaneStickerStyleVisualStudio2017Dark
Visual Studio 2017 dark stickers.
Definition XTPDockingPaneDefines.h:168
xtpPaneStickerStyleVisualStudio2012Dark
@ xtpPaneStickerStyleVisualStudio2012Dark
Visual Studio 2012 dark stickers.
Definition XTPDockingPaneDefines.h:161
xtpPaneStickerStyleVisualStudio2019Dark
@ xtpPaneStickerStyleVisualStudio2019Dark
Visual Studio 2019 dark stickers.
Definition XTPDockingPaneDefines.h:172
xtpPaneStickerStyleVisualStudio2022BlueExtra
@ xtpPaneStickerStyleVisualStudio2022BlueExtra
Visual Studio 2022 blue extra stickers.
Definition XTPDockingPaneDefines.h:175
xtpPaneStickerStyleVisualStudio2019Blue
@ xtpPaneStickerStyleVisualStudio2019Blue
Visual Studio 2019 blue stickers.
Definition XTPDockingPaneDefines.h:170
xtpPaneStickerStyleVisualStudio2022Light
@ xtpPaneStickerStyleVisualStudio2022Light
Visual Studio 2022 light stickers.
Definition XTPDockingPaneDefines.h:173
xtpPaneStickerStyleVisualStudio2022Blue
@ xtpPaneStickerStyleVisualStudio2022Blue
Visual Studio 2022 blue stickers.
Definition XTPDockingPaneDefines.h:174
xtpPaneStickerStyleVisualStudio2019BlueExtra
@ xtpPaneStickerStyleVisualStudio2019BlueExtra
Visual Studio 2019 blue extra stickers.
Definition XTPDockingPaneDefines.h:171
xtpPaneStickerStyleVisualStudio2017Light
@ xtpPaneStickerStyleVisualStudio2017Light
Visual Studio 2017 light stickers.
Definition XTPDockingPaneDefines.h:165
xtpPaneStickerStyleVisualStudio2015Blue
@ xtpPaneStickerStyleVisualStudio2015Blue
Visual Studio 2015 blue stickers.
Definition XTPDockingPaneDefines.h:163
xtpPaneStickerStyleVisualStudio2005
@ xtpPaneStickerStyleVisualStudio2005
Visual Studio 2005 stickers.
Definition XTPDockingPaneDefines.h:157
xtpPaneStickerStyleVisualStudio2012Light
@ xtpPaneStickerStyleVisualStudio2012Light
Visual Studio 2012 light stickers.
Definition XTPDockingPaneDefines.h:160
xtpPaneStickerStyleVisualStudio2010
@ xtpPaneStickerStyleVisualStudio2010
Visual Studio 2010 stickers.
Definition XTPDockingPaneDefines.h:159
xtpPaneStickerStyleVisualStudio2022Dark
@ xtpPaneStickerStyleVisualStudio2022Dark
Visual Studio 2022 dark stickers.
Definition XTPDockingPaneDefines.h:176
xtpPaneStickerStyleNativeWindows11Light
@ xtpPaneStickerStyleNativeWindows11Light
Native Windows 11 light stickers.
Definition XTPDockingPaneDefines.h:179
xtpPaneStickerStyleVisualStudio2015Dark
@ xtpPaneStickerStyleVisualStudio2015Dark
Visual Studio 2015 dark stickers.
Definition XTPDockingPaneDefines.h:164
xtpPaneStickerStyleNativeWindows10Dark
@ xtpPaneStickerStyleNativeWindows10Dark
Native Windows 10 dark stickers.
Definition XTPDockingPaneDefines.h:178
XTPDockingPaneKeyboardNavigate
XTPDockingPaneKeyboardNavigate
Keyboard options indicates which key can be used to navigate panes.
Definition XTPDockingPaneDefines.h:338
xtpPaneKeyboardUseAltMinus
@ xtpPaneKeyboardUseAltMinus
To use Alt+'-' to show the context menu.
Definition XTPDockingPaneDefines.h:340
xtpPaneKeyboardUnused
@ xtpPaneKeyboardUnused
Don't use the keyboard.
Definition XTPDockingPaneDefines.h:339
xtpPaneKeyboardUseAltF6
@ xtpPaneKeyboardUseAltF6
To use Alt+F6 to select the next pane.
Definition XTPDockingPaneDefines.h:341
xtpPaneKeyboardUseAll
@ xtpPaneKeyboardUseAll
To use all keys.
Definition XTPDockingPaneDefines.h:344
xtpPaneKeyboardUseCtrlTab
@ xtpPaneKeyboardUseCtrlTab
To use Ctrl+Tab to show the window select dialog.
Definition XTPDockingPaneDefines.h:343
xtpPaneKeyboardUseAltF7
@ xtpPaneKeyboardUseAltF7
To use Alt+F7 to show the window select dialog.
Definition XTPDockingPaneDefines.h:342
XTP_DPN_CONTEXTMENU
const int XTP_DPN_CONTEXTMENU
Definition XTPDockingPaneDefines.h:617
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
CXTPDockingPaneInfoList
CList< XTP_DOCKINGPANE_INFO, XTP_DOCKINGPANE_INFO & > CXTPDockingPaneInfoList
This list is used by the CXTPDockingPaneLayout class for maintaining an XTP_DOCKINGPANE_INFO collecti...
Definition XTPDockingPaneDefines.h:491
XTPDockingPaneStickerType
XTPDockingPaneStickerType
XTPDockingPaneStickerType is an enumeration that is used to indicate which docking stickers are to be...
Definition XTPDockingPaneDefines.h:362
xtpPaneStickerBottom
@ xtpPaneStickerBottom
Display the docking sticker indicating the pane can be docked on the bottom.
Definition XTPDockingPaneDefines.h:370
xtpPaneStickerLeft
@ xtpPaneStickerLeft
Display the docking sticker indicating the pane can be docked to the left.
Definition XTPDockingPaneDefines.h:364
xtpPaneStickerTop
@ xtpPaneStickerTop
Display the docking sticker indicating the pane can be docked on the top.
Definition XTPDockingPaneDefines.h:368
xtpPaneStickerClient
@ xtpPaneStickerClient
Display the left, top, bottom, and right docking stickers on client frame.
Definition XTPDockingPaneDefines.h:374
xtpPaneStickerCenter
@ xtpPaneStickerCenter
Display the docking sticker indicating the pane can be docked in the center.
Definition XTPDockingPaneDefines.h:372
xtpPaneStickerRight
@ xtpPaneStickerRight
Display the docking sticker indicating the pane can be docked to the right.
Definition XTPDockingPaneDefines.h:366
xtpPaneStickerNone
@ xtpPaneStickerNone
No docking stickers are displayed.
Definition XTPDockingPaneDefines.h:363
CXTPDockingPaneBaseList
CList< CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPDockingPaneBaseList
This list is used for maintaining a CXTPDockingPaneBase collection.
Definition XTPDockingPaneDefines.h:482
WM_XTP_DOCKINGPANE_BASE
const UINT WM_XTP_DOCKINGPANE_BASE
Base for all docking pane messages.
Definition XTPDockingPaneDefines.h:526
CXTPDockingPaneList
CList< CXTPDockingPane *, CXTPDockingPane * > CXTPDockingPaneList
This list is used by the CXTPDockingPaneTabbedContainer class for maintaining a CXTPDockingPane colle...
Definition XTPDockingPaneDefines.h:474
XTPDockingPanePaintTheme
XTPDockingPanePaintTheme
Visual theme enumeration.
Definition XTPDockingPaneDefines.h:100
xtpPaneThemeDefault
@ xtpPaneThemeDefault
Default theme.
Definition XTPDockingPaneDefines.h:101
xtpPaneThemeOffice2007Visio
@ xtpPaneThemeOffice2007Visio
Office 2007 Visio theme.
Definition XTPDockingPaneDefines.h:119
xtpPaneThemeVisualStudio2003
@ xtpPaneThemeVisualStudio2003
Visual Studio 2003 theme.
Definition XTPDockingPaneDefines.h:102
xtpPaneThemeOffice2016
@ xtpPaneThemeOffice2016
Office 2016 pane theme.
Definition XTPDockingPaneDefines.h:121
xtpPaneThemeOffice2003
@ xtpPaneThemeOffice2003
Office 2003 theme.
Definition XTPDockingPaneDefines.h:103
xtpPaneThemeOffice2002Visio
@ xtpPaneThemeOffice2002Visio
Office 2002 Visio theme.
Definition XTPDockingPaneDefines.h:106
xtpPaneThemeVisualStudio2005
@ xtpPaneThemeVisualStudio2005
Visual Studio 2005 theme.
Definition XTPDockingPaneDefines.h:110
xtpPaneThemeVisualStudio2017
@ xtpPaneThemeVisualStudio2017
Visual Studio 2017 theme.
Definition XTPDockingPaneDefines.h:126
xtpPaneThemeOffice2003Outlook
@ xtpPaneThemeOffice2003Outlook
Office 2003 Outlook theme.
Definition XTPDockingPaneDefines.h:108
xtpPaneThemeOffice2003Visio
@ xtpPaneThemeOffice2003Visio
Office 2003 Visio theme.
Definition XTPDockingPaneDefines.h:118
xtpPaneThemeWinNative
@ xtpPaneThemeWinNative
Windows Native theme.
Definition XTPDockingPaneDefines.h:104
xtpPaneThemeOffice2013
@ xtpPaneThemeOffice2013
Office 2013 pane theme.
Definition XTPDockingPaneDefines.h:120
xtpPaneThemeOffice2007Word
@ xtpPaneThemeOffice2007Word
Office 2007 Word theme.
Definition XTPDockingPaneDefines.h:112
xtpPaneThemeVisualStudio2008
@ xtpPaneThemeVisualStudio2008
Visual Studio 2008 theme.
Definition XTPDockingPaneDefines.h:116
xtpPaneThemeGrippered
@ xtpPaneThemeGrippered
Gripper theme.
Definition XTPDockingPaneDefines.h:105
xtpPaneThemeWinExplorer
@ xtpPaneThemeWinExplorer
Windows Explorer theme.
Definition XTPDockingPaneDefines.h:109
xtpPaneThemeCustom
@ xtpPaneThemeCustom
Custom User Defined Theme.
Definition XTPDockingPaneDefines.h:124
xtpPaneThemeVisualStudio2022
@ xtpPaneThemeVisualStudio2022
Visual Studio 2022 theme.
Definition XTPDockingPaneDefines.h:128
xtpPaneThemeVisualStudio6
@ xtpPaneThemeVisualStudio6
Visual Studio 6 theme.
Definition XTPDockingPaneDefines.h:114
xtpPaneThemeVisualStudio2010
@ xtpPaneThemeVisualStudio2010
Visual Studio 2010 theme.
Definition XTPDockingPaneDefines.h:117
xtpPaneThemeNativeWindows11
@ xtpPaneThemeNativeWindows11
Native Windows 11 theme.
Definition XTPDockingPaneDefines.h:129
xtpPaneThemeVisualStudio2005Beta2
@ xtpPaneThemeVisualStudio2005Beta2
Visual Studio 2005 Beta 2 theme.
Definition XTPDockingPaneDefines.h:115
xtpPaneThemeVisualStudio2015
@ xtpPaneThemeVisualStudio2015
Visual Studio 2015 theme.
Definition XTPDockingPaneDefines.h:123
xtpPaneThemeNativeWindows10
@ xtpPaneThemeNativeWindows10
Native Windows 10 theme.
Definition XTPDockingPaneDefines.h:125
xtpPaneThemeVisualStudio2012
@ xtpPaneThemeVisualStudio2012
Visual Studio 2012 theme.
Definition XTPDockingPaneDefines.h:122
xtpPaneThemeVisualStudio2005Beta1
@ xtpPaneThemeVisualStudio2005Beta1
Visual Studio 2005 Beta 1 theme.
Definition XTPDockingPaneDefines.h:107
xtpPaneThemeVisualStudio2019
@ xtpPaneThemeVisualStudio2019
Visual Studio 2019 theme.
Definition XTPDockingPaneDefines.h:127
xtpPaneThemeResource
@ xtpPaneThemeResource
Office 2007/2010 theme.
Definition XTPDockingPaneDefines.h:111
xtpPaneThemeOffice2007Outlook
@ xtpPaneThemeOffice2007Outlook
Office 2007 Outlook theme.
Definition XTPDockingPaneDefines.h:113
XTPDockingPaneAction
XTPDockingPaneAction
Actions a docking pane is currently performing.
Definition XTPDockingPaneDefines.h:268
xtpPaneActionPinned
@ xtpPaneActionPinned
Docking pane has been pinned.
Definition XTPDockingPaneDefines.h:285
xtpPaneActionCollapsed
@ xtpPaneActionCollapsed
Docking Pane has been collapsed.
Definition XTPDockingPaneDefines.h:292
xtpPaneActionActivated
@ xtpPaneActionActivated
Docking pane activated.
Definition XTPDockingPaneDefines.h:301
xtpPaneActionCollapsing
@ xtpPaneActionCollapsing
Docking pane is currently collapsing (hiding).
Definition XTPDockingPaneDefines.h:287
xtpPaneActionDeactivated
@ xtpPaneActionDeactivated
Docking pane deactivated.
Definition XTPDockingPaneDefines.h:302
xtpPaneActionDragging
@ xtpPaneActionDragging
Docking pane is being dragged.
Definition XTPDockingPaneDefines.h:304
xtpPaneActionClosed
@ xtpPaneActionClosed
Docking pane has been closed.
Definition XTPDockingPaneDefines.h:275
xtpPaneActionExpanded
@ xtpPaneActionExpanded
Docking pane is expanded; this is when the pane is fully shown from the auto-hide position.
Definition XTPDockingPaneDefines.h:299
xtpPaneActionAttaching
@ xtpPaneActionAttaching
Docking pane is in the process of attaching to another pane.
Definition XTPDockingPaneDefines.h:280
xtpPaneActionPinning
@ xtpPaneActionPinning
Docking pane is currently pinning (hiding).
Definition XTPDockingPaneDefines.h:283
xtpPaneActionClosing
@ xtpPaneActionClosing
Docking pane is currently closing.
Definition XTPDockingPaneDefines.h:273
xtpPaneActionSplitterResized
@ xtpPaneActionSplitterResized
Docking pane splitter resized.
Definition XTPDockingPaneDefines.h:310
xtpPaneActionFloating
@ xtpPaneActionFloating
Docking pane is currently floating.
Definition XTPDockingPaneDefines.h:269
xtpPaneActionDetaching
@ xtpPaneActionDetaching
Docking pane is being removed from tabbed container.
Definition XTPDockingPaneDefines.h:303
xtpPaneActionDocked
@ xtpPaneActionDocked
Docking pane has been docked.
Definition XTPDockingPaneDefines.h:278
xtpPaneActionUnpinning
@ xtpPaneActionUnpinning
Docking pane is currently docked.
Definition XTPDockingPaneDefines.h:305
xtpPaneActionExpanding
@ xtpPaneActionExpanding
Docking pane is currently expanding.
Definition XTPDockingPaneDefines.h:294
xtpPaneActionAttached
@ xtpPaneActionAttached
Docking pane has been attached.
Definition XTPDockingPaneDefines.h:281
xtpPaneActionSplitterResizing
@ xtpPaneActionSplitterResizing
Docking pane splitter resizing.
Definition XTPDockingPaneDefines.h:309
xtpPaneActionFloated
@ xtpPaneActionFloated
Docking pane has been docked, and is currently floating.
Definition XTPDockingPaneDefines.h:272
xtpPaneActionDocking
@ xtpPaneActionDocking
Docking pane is in the process of docking.
Definition XTPDockingPaneDefines.h:277
xtpPaneActionUnpinned
@ xtpPaneActionUnpinned
Docking pane has been unpinned.
Definition XTPDockingPaneDefines.h:307
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
XTP_DOCKINGPANE_ACTION
The XTP_DOCKINGPANE_ACTION structure contains information about the action performed by the user with...
Definition XTPDockingPaneDefines.h:415
XTP_DOCKINGPANE_ACTION::pPane
CXTPDockingPane * pPane
Pane performing the action.
Definition XTPDockingPaneDefines.h:429
XTP_DOCKINGPANE_ACTION::pDockContainer
CXTPDockingPaneBase * pDockContainer
Container of the xtpPaneActionDocking action.
Definition XTPDockingPaneDefines.h:430
XTP_DOCKINGPANE_ACTION::bCancel
BOOL bCancel
If TRUE, then the current action will be ignored/canceled.
Definition XTPDockingPaneDefines.h:428
XTP_DOCKINGPANE_ACTION::action
XTPDockingPaneAction action
Current action the pane is performing.
Definition XTPDockingPaneDefines.h:427
XTP_DOCKINGPANE_ACTION::dockDirection
XTPDockingPaneDirection dockDirection
The direction that the pane is trying to dock, if any.
Definition XTPDockingPaneDefines.h:431
XTP_DOCKINGPANE_CLICK
The XTP_DOCKINGPANE_CLICK structure contains information about the pane that was used in an XTP_DPN_P...
Definition XTPDockingPaneDefines.h:386
XTP_DOCKINGPANE_CLICK::rcExclude
CRect rcExclude
Exclude rectangle.
Definition XTPDockingPaneDefines.h:390
XTP_DOCKINGPANE_CLICK::pPane
CXTPDockingPane * pPane
Docking Pane pointer.
Definition XTPDockingPaneDefines.h:387
XTP_DOCKINGPANE_CLICK::pt
CPoint pt
Mouse pointer.
Definition XTPDockingPaneDefines.h:389
XTP_DOCKINGPANE_CLICK::pContainer
CXTPDockingPaneBase * pContainer
Docking Pane container.
Definition XTPDockingPaneDefines.h:388
XTP_DOCKINGPANE_INFO
Internal structure used by the Layout manager.
Definition XTPDockingPaneDefines.h:442
XTP_DOCKINGPANE_INFO::pPane
CXTPDockingPane * pPane
Docking Pane.
Definition XTPDockingPaneDefines.h:460
XTP_DOCKINGPANE_INFO::pLastHolder
CXTPDockingPaneBase * pLastHolder
Last holder (must be pFloatingHolder or pDockingHolder).
Definition XTPDockingPaneDefines.h:463
XTP_DOCKINGPANE_INFO::pDockingHolder
CXTPDockingPaneBase * pDockingHolder
Last docking holder of the pane.
Definition XTPDockingPaneDefines.h:462
XTP_DOCKINGPANE_INFO::pFloatingHolder
CXTPDockingPaneBase * pFloatingHolder
Last floating holder of the pane.
Definition XTPDockingPaneDefines.h:461


CXTPMarkupGdiPlusMatrixTransform Member List

This is the complete list of members for CXTPMarkupGdiPlusMatrixTransform, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupGdiPlusMatrixTransform() | CXTPMarkupGdiPlusMatrixTransform |
CXTPMarkupGdiPlusTransformObject() | CXTPMarkupGdiPlusTransformObject< CXTPMarkupMatrixTransform > | protected
CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | protected
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix) | CXTPMarkupGdiPlusMatrixTransform | virtual
~CXTPMarkupGdiPlusTransformObjectImpl() | CXTPMarkupGdiPlusTransformObjectImpl | inlineprotectedvirtual


Toolkit Pro: XTPDockingPaneColorSet2019.h Source File

  • Source
  • DockingPane
  • ColorSets
XTPDockingPaneColorSet2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANECOLORSET2019_H__)
24# define __XTPDOCKINGPANECOLORSET2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneColorSet2019 : public CXTPDockingPaneColorSet
39{
40public:
47 virtual void RefreshMetrics(CString strSection);
48};
49
50# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
52#endif // !defined(__XTPDOCKINGPANECOLORSET2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneColorSet2019
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet2019.h:39
CXTPDockingPaneColorSet2019::RefreshMetrics
virtual void RefreshMetrics(CString strSection)
This member function is used to initialize default colors for a theme from an .INI resource.
CXTPDockingPaneColorSet
Helper class used to initialize default colors for a theme from an .INI resource.
Definition XTPDockingPaneColorSet.h:39


Toolkit Pro: XTPTaskPanelOfficeXPThemePlain.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelOfficeXPThemePlain.h
Go to the documentation of this file.
1
23#ifndef XTPTaskPanelOfficeXPThemePlain_h__
24# define XTPTaskPanelOfficeXPThemePlain_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelOfficeXPThemePlain : public CXTPTaskPanelPaintManagerPlain
40{
41public:
46 CXTPTaskPanelOfficeXPThemePlain();
47
52 void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif // XTPTaskPanelOfficeXPThemePlain_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelOfficeXPThemePlain
CXTPTaskPanelOfficeXPThemePlain represents a classic Office XP style theme.
Definition XTPTaskPanelOfficeXPThemePlain.h:40
CXTPTaskPanelOfficeXPThemePlain::RefreshMetrics
void RefreshMetrics()
Refreshes the visual metrics of the task panel.
CXTPTaskPanelOfficeXPThemePlain::CXTPTaskPanelOfficeXPThemePlain
CXTPTaskPanelOfficeXPThemePlain()
Constructs a CXTPTaskPanelOfficeXPThemePlain object.
CXTPTaskPanelPaintManagerPlain
Base class theme that all other themes are derived from.
Definition XTPTaskPanelPaintManagerPlain.h:41


CXTPChartLineDeviceCommand Member List

This is the complete list of members for CXTPChartLineDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartLineDeviceCommand(const CXTPPoint2f &p1, const CXTPPoint2f &p2, const CXTPChartColor &color, int thickness) | CXTPChartLineDeviceCommand | protected
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartLineDeviceCommand | protectedvirtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_color | CXTPChartLineDeviceCommand | protected
m_nThickness | CXTPChartLineDeviceCommand | protected
m_p1 | CXTPChartLineDeviceCommand | protected
m_p2 | CXTPChartLineDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


CXTPDockingPaneLayout Member List

This is the complete list of members for CXTPDockingPaneLayout, including all inherited members.

Copy(const CXTPDockingPaneLayout *pLayout) | CXTPDockingPaneLayout |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneLayout(CXTPDockingPaneManager *pManager) | CXTPDockingPaneLayout |
DoPropExchange(CXTPPropExchange *pPX) | CXTPDockingPaneLayout |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaneList() const | CXTPDockingPaneLayout |
IsUserLayout() const | CXTPDockingPaneLayout |
IsValid() const | CXTPDockingPaneLayout |
Load(LPCTSTR lpszSection) | CXTPDockingPaneLayout |
LoadFromFile(LPCTSTR lpszFileName, LPCTSTR lpszSection) | CXTPDockingPaneLayout |
LoadFromNode(XTPXML::IXMLDOMNode *pNode, LPCTSTR lpszSection) | CXTPDockingPaneLayout |
Save(LPCTSTR lpszSection) | CXTPDockingPaneLayout |
SaveToFile(LPCTSTR lpszFileName, LPCTSTR lpszSection) | CXTPDockingPaneLayout |
SaveToNode(XTPXML::IXMLDOMNode *pNode, LPCTSTR lpszSection) | CXTPDockingPaneLayout |
Serialize(CArchive &ar) | CXTPDockingPaneLayout |
~CXTPDockingPaneLayout() | CXTPDockingPaneLayout | virtual


Toolkit Pro: XTPChartSeriesLabel.h Source File

  • Source
  • Chart
XTPChartSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSERIESLABEL_H__)
24# define __XTPCHARTSERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesStyle;
34class CXTPChartElementView;
35class CXTPChartDeviceContext;
36class CXTPChartSeriesPointView;
37class CXTPChartDeviceCommand;
38class CXTPChartBorder;
39class CXTPChartFillStyle;
40class CXTPChartSeriesPoint;
41class CXTPChartNumberFormat;
42
48class _XTP_EXT_CLASS CXTPChartSeriesLabel : public CXTPChartTextElement
49{
50 DECLARE_SERIAL(CXTPChartSeriesLabel);
51
52public:
57 CXTPChartSeriesLabel();
58
63 virtual ~CXTPChartSeriesLabel();
64
65public:
72 void SetTextColor(const CXTPChartColor& clrTextColor);
73
81 CXTPChartColor GetTextColor() const;
82
90 CXTPChartFont* GetFont() const;
91
98 void SetFont(CXTPChartFont* pFont);
99
107 void SetShowLines(BOOL bShowLines);
108
116 BOOL GetShowLines() const;
117
124 void SetLineLength(int nLineLength);
125
133 int GetLineLength() const;
134
142 void SetVisible(BOOL bVisible);
143
151 BOOL IsVisible() const;
152
161 void SetAntialiasing(BOOL bAntialiasing);
162
171 BOOL GetAntialiasing() const;
172
184 CXTPChartNumberFormat* GetFormat() const;
185
195 void SetFormat(LPCTSTR lpszFormat);
196
197 virtual CXTPChartString GetPointLabel(CXTPChartSeriesPoint* pPoint, int nValueIndex = -1) const;
198
199 CXTPChartBorder* GetBorder() const;
200 CXTPChartFillStyle* GetFillStyle() const;
201
208 void SetBackColor(const CXTPChartColor& clrBackColor);
209
217 CXTPChartColor GetBackColor() const;
218
225 void SetLineColor(const CXTPChartColor& clrBackColor);
226
234 CXTPChartColor GetLineColor() const;
235
247 int GetTransparency() const;
248
259 void SetTransparency(int nTransparency);
260
261public:
262 CXTPChartColor GetActualBackColor() const;
263
264 CXTPChartColor GetActualConnectorColor() const;
265
266public:
267 virtual void DoPropExchange(CXTPPropExchange* pPX);
268
269public:
270 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
271 CXTPChartSeriesPointView* pPointView,
272 CXTPChartElementView* pParentView);
273
274# ifdef _XTP_ACTIVEX
275public:
277 DECLARE_DISPATCH_MAP()
278 DECLARE_INTERFACE_MAP()
279 DECLARE_OLETYPELIB_EX(CXTPChartSeriesLabel);
280 afx_msg void OleChartChanged();
281 afx_msg LPDISPATCH OleGetFormat();
282 afx_msg LPDISPATCH OleGetFont();
284# endif
285
286protected:
287 CXTPChartColor m_clrTextColor;
288 CXTPChartColor m_clrBackColor;
289 CXTPChartColor m_clrLineColor;
290 BOOL m_bVisible;
291 CXTPChartFont* m_pFont;
292 BOOL m_bAntialiasing;
293 BOOL m_bShowLines;
294 int m_nLineLength;
295 CXTPChartBorder* m_pBorder;
296 CXTPChartFillStyle* m_pFillStyle;
297 CXTPChartNumberFormat* m_pFormat;
298 int m_nTransparency;
300 LPDISPATCH OleGetBorder();
301 LPDISPATCH OleGetFillStyle();
302 OLE_COLOR OleGetTextColor();
303 void OleSetTextColor(OLE_COLOR clr);
304 OLE_COLOR OleGetBackColor();
305 void OleSetBackColor(OLE_COLOR clr);
306 OLE_COLOR OleGetLineColor();
307 void OleSetLineColor(OLE_COLOR clr);
308
309protected:
310 friend class CXTPChartSeriesStyle;
311};
312
313class _XTP_EXT_CLASS CXTPChartSeriesLabelView : public CXTPChartElementView
314{
315 DECLARE_DYNAMIC(CXTPChartSeriesLabelView);
316
317public:
318 CXTPChartSeriesLabelView(CXTPChartSeriesLabel* pLabel, CXTPChartSeriesPointView* pPointView,
319 CXTPChartElementView* pParentView);
320
321public:
322 virtual void CalculateLayout(CXTPChartDeviceContext* pDC);
323
324 CXTPChartColor GetActualTextColor() const;
325 CXTPChartColor GetActualBorderColor() const;
326 CXTPChartColor GetActualConnectorColor() const;
327 CXTPChartSeriesPointView* GetPointView() const;
328 CXTPChartSeriesLabel* GetLabel() const;
329
330protected:
331 CXTPChartSeriesLabel* m_pLabel;
332 CXTPChartSeriesPointView* m_pPointView;
333};
334
335AFX_INLINE CXTPChartSeriesLabel* CXTPChartSeriesLabelView::GetLabel() const
336{
337 return m_pLabel;
338}
339
340class _XTP_EXT_CLASS CXTPChartSeriesLabelConnectorPainterBase
341{
342public:
343 CXTPChartSeriesLabelConnectorPainterBase(CXTPChartPointF startPoint,
344 CXTPChartPointF finishPoint, CXTPChartRectF bounds);
345
346public:
347 static CXTPChartRectF AFX_CDECL CalcBorderBoundsForTangentDrawing(
348 const CXTPPoint3d& point, double angle, const CXTPChartSizeF& textSize, int borderThickness,
349 CXTPChartRectF& innerBounds);
350
351protected:
352 CXTPChartPointF m_startPoint;
353 CXTPChartPointF m_finishPoint;
354 CXTPChartRectF m_bounds;
355};
356
357class _XTP_EXT_CLASS CXTPChartSeriesLabelLineConnectorPainter
358 : public CXTPChartSeriesLabelConnectorPainterBase
359{
360public:
361 CXTPChartSeriesLabelLineConnectorPainter(CXTPChartPointF startPoint,
362 CXTPChartPointF finishPoint, CXTPChartRectF bounds);
363
364 virtual ~CXTPChartSeriesLabelLineConnectorPainter()
365 {
366 }
367
368public:
369 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC,
370 const CXTPChartColor& color);
371};
372
373AFX_INLINE CXTPChartElementView* CXTPChartSeriesLabel::CreateView(
374 CXTPChartDeviceContext* pDC, CXTPChartSeriesPointView* pPointView,
375 CXTPChartElementView* pParentView)
376{
377 UNREFERENCED_PARAMETER(pDC);
378 UNREFERENCED_PARAMETER(pPointView);
379 UNREFERENCED_PARAMETER(pParentView);
380 return NULL;
381}
382
383AFX_INLINE CXTPChartFont* CXTPChartSeriesLabel::GetFont() const
384{
385 return m_pFont;
386}
387
388AFX_INLINE CXTPChartColor CXTPChartSeriesLabel::GetTextColor() const
389{
390 return m_clrTextColor;
391}
392
393AFX_INLINE void CXTPChartSeriesLabel::SetShowLines(BOOL bShowLines)
394{
395 m_bShowLines = bShowLines;
396 OnChartChanged();
397}
398
399AFX_INLINE BOOL CXTPChartSeriesLabel::GetShowLines() const
400{
401 return m_bShowLines;
402}
403
404AFX_INLINE int CXTPChartSeriesLabel::GetLineLength() const
405{
406 return m_nLineLength;
407}
408
409AFX_INLINE void CXTPChartSeriesLabel::SetLineLength(int nLineLength)
410{
411 m_nLineLength = nLineLength;
412 OnChartChanged();
413}
414
415AFX_INLINE void CXTPChartSeriesLabel::SetVisible(BOOL bVisible)
416{
417 m_bVisible = bVisible;
418 OnChartChanged();
419}
420
421AFX_INLINE BOOL CXTPChartSeriesLabel::IsVisible() const
422{
423 return m_bVisible;
424}
425
426AFX_INLINE void CXTPChartSeriesLabel::SetAntialiasing(BOOL bAntialiasing)
427{
428 m_bAntialiasing = bAntialiasing;
429 OnChartChanged();
430}
431
432AFX_INLINE BOOL CXTPChartSeriesLabel::GetAntialiasing() const
433{
434 return m_bAntialiasing;
435}
436
437AFX_INLINE CXTPChartNumberFormat* CXTPChartSeriesLabel::GetFormat() const
438{
439 return m_pFormat;
440}
441
442AFX_INLINE void CXTPChartSeriesLabel::SetTextColor(const CXTPChartColor& clrTextColor)
443{
444 m_clrTextColor = clrTextColor;
445 OnChartChanged();
446}
447
448AFX_INLINE void CXTPChartSeriesLabel::SetLineColor(const CXTPChartColor& clrLineColor)
449{
450 m_clrLineColor = clrLineColor;
451 OnChartChanged();
452}
453
454AFX_INLINE void CXTPChartSeriesLabel::SetBackColor(const CXTPChartColor& clrBackColor)
455{
456 m_clrBackColor = clrBackColor;
457 OnChartChanged();
458}
459
460AFX_INLINE CXTPChartColor CXTPChartSeriesLabel::GetBackColor() const
461{
462 return m_clrBackColor;
463}
464
465AFX_INLINE CXTPChartColor CXTPChartSeriesLabel::GetLineColor() const
466{
467 return m_clrLineColor;
468}
469
470AFX_INLINE CXTPChartBorder* CXTPChartSeriesLabel::GetBorder() const
471{
472 return m_pBorder;
473}
474
475AFX_INLINE CXTPChartFillStyle* CXTPChartSeriesLabel::GetFillStyle() const
476{
477 return m_pFillStyle;
478}
479
480AFX_INLINE int CXTPChartSeriesLabel::GetTransparency() const
481{
482 return m_nTransparency;
483}
484
485AFX_INLINE void CXTPChartSeriesLabel::SetTransparency(int nTransparency)
486{
487 m_nTransparency = nTransparency;
488 OnChartChanged();
489}
491# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
492#endif //#if !defined(__XTPCHARTSERIESLABEL_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFont
This class abstracts a font entity.
Definition XTPChartTypes.h:540
CXTPChartNumberFormat
This class helper is used to format number to string.
Definition XTPChartNumberFormat.h:72
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesLabel::m_pFont
CXTPChartFont * m_pFont
The font of the label.
Definition XTPChartSeriesLabel.h:291
CXTPChartSeriesLabel::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartSeriesLabel::m_bShowLines
BOOL m_bShowLines
TRUE if the lines are visible, FALSE if not.
Definition XTPChartSeriesLabel.h:293
CXTPChartSeriesLabel::m_clrBackColor
CXTPChartColor m_clrBackColor
The background color.
Definition XTPChartSeriesLabel.h:288
CXTPChartSeriesLabel::SetFormat
void SetFormat(LPCTSTR lpszFormat)
Obsolete method.
CXTPChartSeriesLabel::SetVisible
void SetVisible(BOOL bVisible)
Call this function to set the label visibility.
Definition XTPChartSeriesLabel.h:415
CXTPChartSeriesLabel::GetTextColor
CXTPChartColor GetTextColor() const
Call this function to get the apparent text color of the label.
Definition XTPChartSeriesLabel.h:388
CXTPChartSeriesLabel::m_nTransparency
int m_nTransparency
The transparency values range from 0 to 255.
Definition XTPChartSeriesLabel.h:298
CXTPChartSeriesLabel::GetFont
CXTPChartFont * GetFont() const
Call this function to get the font of the text label.
Definition XTPChartSeriesLabel.h:383
CXTPChartSeriesLabel::SetTransparency
void SetTransparency(int nTransparency)
Call this function to set the transparency of the filled area with respect to the background.
Definition XTPChartSeriesLabel.h:485
CXTPChartSeriesLabel::GetFormat
CXTPChartNumberFormat * GetFormat() const
Call this function to get a pointer to CXTPChartNumberFormat that specifies how to convert numbers to...
Definition XTPChartSeriesLabel.h:437
CXTPChartSeriesLabel::SetFont
void SetFont(CXTPChartFont *pFont)
Call this function to set the font of the text label.
CXTPChartSeriesLabel::IsVisible
BOOL IsVisible() const
Call this function to check if the label is visible.
Definition XTPChartSeriesLabel.h:421
CXTPChartSeriesLabel::~CXTPChartSeriesLabel
virtual ~CXTPChartSeriesLabel()
Destroys a CXTPChartSeriesLabel object, handles cleanup.
CXTPChartSeriesLabel::SetLineColor
void SetLineColor(const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
Definition XTPChartSeriesLabel.h:448
CXTPChartSeriesLabel::m_pBorder
CXTPChartBorder * m_pBorder
Chart border object.
Definition XTPChartSeriesLabel.h:295
CXTPChartSeriesLabel::GetTransparency
int GetTransparency() const
Call this function to get the transparency of the filled area with respect to the background.
Definition XTPChartSeriesLabel.h:480
CXTPChartSeriesLabel::SetAntialiasing
void SetAntialiasing(BOOL bAntialiasing)
Call this function to set anti-aliasing ON or OFF.
Definition XTPChartSeriesLabel.h:426
CXTPChartSeriesLabel::SetShowLines
void SetShowLines(BOOL bShowLines)
Call this function to set the lines visibility.
Definition XTPChartSeriesLabel.h:393
CXTPChartSeriesLabel::SetBackColor
void SetBackColor(const CXTPChartColor &clrBackColor)
Call this function to set the text color of the label.
Definition XTPChartSeriesLabel.h:454
CXTPChartSeriesLabel::GetLineColor
CXTPChartColor GetLineColor() const
Call this function to get the apparent text color of the label.
Definition XTPChartSeriesLabel.h:465
CXTPChartSeriesLabel::m_bVisible
BOOL m_bVisible
TRUE if the label is visible and FALSE if not.
Definition XTPChartSeriesLabel.h:290
CXTPChartSeriesLabel::SetLineLength
void SetLineLength(int nLineLength)
Call this function to set the line length.
Definition XTPChartSeriesLabel.h:409
CXTPChartSeriesLabel::GetShowLines
BOOL GetShowLines() const
Call this function to check if the lines are visible.
Definition XTPChartSeriesLabel.h:399
CXTPChartSeriesLabel::SetTextColor
void SetTextColor(const CXTPChartColor &clrTextColor)
Call this function to set the text color of the label.
Definition XTPChartSeriesLabel.h:442
CXTPChartSeriesLabel::m_clrTextColor
CXTPChartColor m_clrTextColor
The text color.
Definition XTPChartSeriesLabel.h:287
CXTPChartSeriesLabel::m_nLineLength
int m_nLineLength
The line length.
Definition XTPChartSeriesLabel.h:294
CXTPChartSeriesLabel::m_clrLineColor
CXTPChartColor m_clrLineColor
The line color.
Definition XTPChartSeriesLabel.h:289
CXTPChartSeriesLabel::CXTPChartSeriesLabel
CXTPChartSeriesLabel()
Constructs a CXTPChartSeriesLabel object.
CXTPChartSeriesLabel::GetLineLength
int GetLineLength() const
Call this function to get the line length.
Definition XTPChartSeriesLabel.h:404
CXTPChartSeriesLabel::m_bAntialiasing
BOOL m_bAntialiasing
TRUE if antialiasing enabled, FALSE if not.
Definition XTPChartSeriesLabel.h:292
CXTPChartSeriesLabel::GetBackColor
CXTPChartColor GetBackColor() const
Call this function to get the apparent text color of the label.
Definition XTPChartSeriesLabel.h:460
CXTPChartSeriesLabel::GetAntialiasing
BOOL GetAntialiasing() const
Call this function to check if anti-aliasing is ON or OFF.
Definition XTPChartSeriesLabel.h:432
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49
CXTPChartTextElement
This class abstracts a chart text element.
Definition XTPChartElement.h:323
CXTPChartTextElement::GetFont
virtual CXTPChartFont * GetFont() const =0
Call this function to get the font of the text element.
CXTPChartTextElement::GetAntialiasing
virtual BOOL GetAntialiasing() const =0
Call this function to check if anti-aliasing is ON or OFF.
CXTPPoint2T< float >
CXTPPoint3T< double >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPRectT< float >
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: XTPCommonPicturePreviewProvider.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • CommonPicture
XTPCommonPicturePreviewProvider.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMONPICTUREPREVIEWPROVIDER_H__)
24# define __XTPCOMMONPICTUREPREVIEWPROVIDER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPCommonPicturePreviewProvider : public CXTPPreviewProviderBase
42{
43private:
44 virtual LPCTSTR GetDefaultFileAssociations() const;
45 virtual IXTPPreview* CreatePreview(LPCTSTR pFilePath, HWND hwndParent);
46 virtual IXTPPreview* CreatePreview(IStream& stream, LPCTSTR pImpliedFileName, HWND hwndParent);
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // #if !defined(__XTPCOMMONPICTUREPREVIEWPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommonPicturePreviewProvider
Provides a preview handler for the common picture file types: BMP, PNG, TIF, TIFF,...
Definition XTPCommonPicturePreviewProvider.h:42
CXTPPreviewProviderBase
Base class for a preview provider which implements common behavior to be exposed by a preview provide...
Definition XTPPreviewAbstract.h:251
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreviewProvider::GetDefaultFileAssociations
virtual LPCTSTR GetDefaultFileAssociations() const =0
Obtains the list of file extensions supported by the associated preview implementation.
IXTPPreviewProvider::CreatePreview
virtual IXTPPreview * CreatePreview(LPCTSTR pFilePath, HWND hwndParent)=0
Creates a preview object for the specified file.


CXTPMarkupTextBlock Member List

This is the complete list of members for CXTPMarkupTextBlock, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupTextBlock() | CXTPMarkupTextBlock | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupTextBlock |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetFontFamily() const | CXTPMarkupTextBlock |
GetFontSize() const | CXTPMarkupTextBlock |
GetFontStyle() const | CXTPMarkupTextBlock |
GetFontWeight() const | CXTPMarkupTextBlock |
GetForeground() const | CXTPMarkupTextBlock |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetInlines() const | CXTPMarkupTextBlock |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupTextBlock |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetText() const | CXTPMarkupTextBlock |
GetTextAlignment() const | CXTPMarkupTextBlock |
GetTextDecorations() const | CXTPMarkupTextBlock |
GetTextTrimming() const | CXTPMarkupTextBlock |
GetTextWrapping() const | CXTPMarkupTextBlock |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pInlines | CXTPMarkupTextBlock | protected
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupTextBlock |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetFontFamily(LPCWSTR lpszFontFamily) | CXTPMarkupTextBlock |
SetFontSize(int nFontSize) | CXTPMarkupTextBlock |
SetFontStyle(int nFontStyle) | CXTPMarkupTextBlock |
SetFontWeight(int nFontWeight) | CXTPMarkupTextBlock |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupTextBlock |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupTextBlock |
SetPadding(int nPadding) | CXTPMarkupTextBlock |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetText(LPCWSTR lpszText) | CXTPMarkupTextBlock |
SetTextAlignment(XTPMarkupTextAlignment alignment) | CXTPMarkupTextBlock |
SetTextDecorations(int nTextDecorations) | CXTPMarkupTextBlock |
SetTextTrimming(XTPMarkupTextTrimming bTextTrimming) | CXTPMarkupTextBlock |
SetTextWrapping(XTPMarkupTextWrapping nTextWrapping) | CXTPMarkupTextBlock |
SetTextWrapping(BOOL bTextWrapping) | CXTPMarkupTextBlock |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupTextBlock() | CXTPMarkupTextBlock | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


CXTPSystemMetrics Member List

This is the complete list of members for CXTPSystemMetrics, including all inherited members.

CXTPSystemMetrics() | CXTPSystemMetrics
m_nBorderY | CXTPSystemMetrics
m_nCaptionY | CXTPSystemMetrics
m_nIconX | CXTPSystemMetrics
m_nIconY | CXTPSystemMetrics
m_nSizeFrameY | CXTPSystemMetrics
m_nSmallIconX | CXTPSystemMetrics
m_nSmallIconY | CXTPSystemMetrics
RefreshMetrics() | CXTPSystemMetrics


CXTPTaskButtonTheme Member List

This is the complete list of members for CXTPTaskButtonTheme, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPTaskButtonTheme | protectedvirtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPTaskButtonTheme | protectedvirtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderShadow | CXTPButtonTheme |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPTaskButtonTheme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


Toolkit Pro: XTPCalendarPtrCollectionT.h Source File

  • Source
  • Calendar
XTPCalendarPtrCollectionT.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARCOLLECTIONT_H__)
23# define _XTPCALENDARCOLLECTIONT_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# pragma warning(disable : 4097)
32
46template<class _TObject>
47class CXTPCalendarPtrCollectionT : public CXTPCmdTarget
48{
49public:
56 CXTPCalendarPtrCollectionT();
57
68 virtual ~CXTPCalendarPtrCollectionT();
69
85 virtual int GetCount() const;
86
152 virtual void Add(_TObject* pNewElement);
153
222 virtual void Add(_TObject* pNewElement, BOOL bWithAddRef);
223
253 virtual void SetAt(int nIndex, _TObject* pElement);
254
267 virtual int Find(const _TObject* pElement) const;
268
297 virtual void InsertAt(int nIndex, _TObject* pElement);
298
325 virtual void Append(const CXTPCalendarPtrCollectionT<_TObject>* pElementsArray);
326
337 virtual void SetSize(int nNewSize);
338
355 virtual _TObject* GetAt(int nIndex) const;
356
376 virtual _TObject* GetAt(int nIndex, BOOL bWithAddRef) const;
377
390 virtual void RemoveAt(int nIndex);
391
407 virtual void Remove(_TObject* pElement);
408
423 virtual void RemoveAll();
424
425protected:
426 typedef CXTPSmartPtrInternalT<_TObject> TObjectPtr;
428 CArray<TObjectPtr, TObjectPtr&> m_arElements;
430protected:
431# ifdef _XTP_ACTIVEX
432
433 virtual long OleGetItemCount();
434 virtual LPDISPATCH OleGetItem(long nIndex);
435
436 virtual void OleRemove(long nIndex);
437 // virtual void OleRemoveAll();
438
439# endif
440};
442
470template<class BASE_CLASS, class PTR_TYPE>
471class CXTPCalendarTypedPtrAutoDeleteArray : public CTypedPtrArray<BASE_CLASS, PTR_TYPE>
472{
473public:
478 typedef CTypedPtrArray<BASE_CLASS, PTR_TYPE> TBase;
479
484 CXTPCalendarTypedPtrAutoDeleteArray(){};
485
493 virtual ~CXTPCalendarTypedPtrAutoDeleteArray()
494 {
495 RemoveAll();
496 }
497
506 virtual void RemoveAll()
507 {
508 for (int i = 0; i < TBase::GetSize(); i++)
509 {
510 PTR_TYPE pObj = TBase::GetAt(i);
511 if (pObj)
512 {
513 delete pObj;
514 TBase::SetAt(i, NULL);
515 }
516 }
517
518 TBase::RemoveAll();
519 }
520};
521
542template<class KEY, class TPtr>
543class CXTPCalendarTypedPtrAutoDeleteMap : public CMap<KEY, KEY, TPtr, TPtr>
544{
545 typedef CMap<KEY, KEY, TPtr, TPtr> TBase;
546
547public:
555 virtual ~CXTPCalendarTypedPtrAutoDeleteMap()
556 {
557 RemoveAll();
558 }
559
571 virtual void RemoveAll(BOOL bDeletePtr = TRUE)
572 {
573 if (bDeletePtr)
574 {
575 POSITION pos = TBase::GetStartPosition();
576 while (pos)
577 {
578 KEY tmpKey;
579 TPtr pValue = NULL;
580 TBase::GetNextAssoc(pos, tmpKey, pValue);
581 if (pValue)
582 delete pValue;
583 }
584 }
585
586 TBase::RemoveAll();
587 }
588
598 virtual void SetAt(KEY key, TPtr pValue, BOOL bDeletePrevPtr = TRUE)
599 {
600 if (bDeletePrevPtr)
601 _DeletePtr(key);
602
603 TBase::SetAt(key, pValue);
604 }
605
614 TPtr& operator[](KEY key)
615 {
616 _DeletePtr(key);
617 return TBase::operator[](key);
618 }
619
629 virtual BOOL RemoveKey(KEY key, BOOL bDeletePtr = TRUE)
630 {
631 if (bDeletePtr)
632 _DeletePtr(key);
633 return TBase::RemoveKey(key);
634 }
635
636private:
637 void _DeletePtr(KEY key)
638 {
639 TPtr pValPrev = NULL;
640 if (TBase::Lookup(key, pValPrev) && pValPrev)
641 {
642 delete pValPrev;
643 }
644 }
645};
646
648template<class _TObject>
649AFX_INLINE CXTPCalendarPtrCollectionT<_TObject>::CXTPCalendarPtrCollectionT()
650{
651}
652
653template<class _TObject>
654AFX_INLINE CXTPCalendarPtrCollectionT<_TObject>::~CXTPCalendarPtrCollectionT()
655{
656}
657
658template<class _TObject>
659AFX_INLINE int CXTPCalendarPtrCollectionT<_TObject>::GetCount() const
660{
661 return (int)m_arElements.GetSize();
662}
663
664template<class _TObject>
665AFX_INLINE _TObject* CXTPCalendarPtrCollectionT<_TObject>::GetAt(int nIndex) const
666{
667 _TObject* pElement = m_arElements[nIndex];
668 return pElement;
669}
670
671template<class _TObject>
672AFX_INLINE _TObject* CXTPCalendarPtrCollectionT<_TObject>::GetAt(int nIndex, BOOL bWithAddRef) const
673{
674 _TObject* pElement = m_arElements[nIndex];
675 if (bWithAddRef && pElement)
676 {
677 ((CCmdTarget*)pElement)->InternalAddRef();
678 }
679 return pElement;
680}
681
682template<class _TObject>
683AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Add(_TObject* pNewElement, BOOL bWithAddRef)
684{
685 if (bWithAddRef && pNewElement)
686 {
687 ((CCmdTarget*)pNewElement)->InternalAddRef();
688 }
689 TObjectPtr ptrNewElement(pNewElement);
690 m_arElements.Add(ptrNewElement);
691}
692
693template<class _TObject>
694AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Add(_TObject* pNewElement)
695{
696 TObjectPtr ptrNewElement(pNewElement);
697 m_arElements.Add(ptrNewElement);
698}
699
700template<class _TObject>
701AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Append(
702 const CXTPCalendarPtrCollectionT<_TObject>* pElementsArray)
703{
704 if (!pElementsArray)
705 {
706 _ASSERTE(FALSE);
707 return;
708 }
709
710 int nCount = pElementsArray->GetCount();
711 for (int i = 0; i < nCount; i++)
712 {
713 TObjectPtr ptrElement = pElementsArray->GetAt(i, TRUE);
714 m_arElements.Add(ptrElement);
715 }
716}
717
718template<class _TObject>
719AFX_INLINE int CXTPCalendarPtrCollectionT<_TObject>::Find(const _TObject* pElement) const
720{
721 int nCount = GetCount();
722 for (int i = 0; i < nCount; i++)
723 {
724 if (GetAt(i) == pElement)
725 return i;
726 }
727 return -1;
728}
729
730template<class _TObject>
731AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::Remove(_TObject* pElement)
732{
733 int nCount = GetCount();
734 for (int i = 0; i < nCount; i++)
735 {
736 if (GetAt(i) == pElement)
737 {
738 RemoveAt(i);
739 break;
740 }
741 }
742}
743
744template<class _TObject>
745AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::SetSize(int nNewSize)
746{
747 m_arElements.SetSize(nNewSize);
748}
749
750template<class _TObject>
751AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::SetAt(int nIndex, _TObject* pElement)
752{
753 TObjectPtr ptrNewElement(pElement);
754 m_arElements.SetAt(nIndex, ptrNewElement);
755}
756
757template<class _TObject>
758AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::InsertAt(int nIndex, _TObject* pElement)
759{
760 TObjectPtr ptrNewElement(pElement);
761 m_arElements.InsertAt(nIndex, ptrNewElement);
762}
763
764template<class _TObject>
765AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::RemoveAt(int nIndex /*, BOOL bWithRelease*/)
766{
767 m_arElements.RemoveAt(nIndex);
768}
769
770template<class _TObject>
771AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::RemoveAll(/*BOOL bWithRelease*/)
772{
773 m_arElements.RemoveAll();
774}
775
776//===========================================================================
777# ifdef _XTP_ACTIVEX
778
779template<class _TObject>
780AFX_INLINE long CXTPCalendarPtrCollectionT<_TObject>::OleGetItemCount()
781{
782 return (long)GetCount();
783}
784
785template<class _TObject>
786AFX_INLINE LPDISPATCH CXTPCalendarPtrCollectionT<_TObject>::OleGetItem(long nIndex)
787{
788 if (nIndex < 0 || nIndex >= (long)OleGetItemCount())
789 AfxThrowOleException(DISP_E_BADINDEX);
790
791 CCmdTarget* pObj = (CXTPCmdTarget*)GetAt(nIndex);
792 return pObj ? pObj->GetIDispatch(TRUE) : NULL;
793}
794
795template<class _TObject>
796AFX_INLINE void CXTPCalendarPtrCollectionT<_TObject>::OleRemove(long nIndex)
797{
798 if (nIndex < 0 || nIndex >= (long)OleGetItemCount())
799 AfxThrowOleException(DISP_E_BADINDEX);
800
801 RemoveAt(nIndex);
802}
803
804# endif // _XTP_ACTIVEX
805
806# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
807#endif // !defined(_XTPCALENDARCOLLECTIONT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarPtrCollectionT::GetCount
virtual int GetCount() const
This member function is used to obtain the number of elements in the collection.
Definition XTPCalendarPtrCollectionT.h:659
CXTPCalendarPtrCollectionT::Find
virtual int Find(const _TObject *pElement) const
This member function finds an element index in the collection using its pointer.
Definition XTPCalendarPtrCollectionT.h:719
CXTPCalendarPtrCollectionT::InsertAt
virtual void InsertAt(int nIndex, _TObject *pElement)
This member function is used to insert a new element at the position specified in the nIndex paramete...
Definition XTPCalendarPtrCollectionT.h:758
CXTPCalendarPtrCollectionT::RemoveAll
virtual void RemoveAll()
This member function is used to remove all of the elements from the array.
Definition XTPCalendarPtrCollectionT.h:771
CXTPCalendarPtrCollectionT::Add
virtual void Add(_TObject *pNewElement)
This member function adds a new element to the end of the array.
Definition XTPCalendarPtrCollectionT.h:694
CXTPCalendarPtrCollectionT::RemoveAt
virtual void RemoveAt(int nIndex)
This member function removes an element at the specified index from the array.
Definition XTPCalendarPtrCollectionT.h:765
CXTPCalendarPtrCollectionT::SetSize
virtual void SetSize(int nNewSize)
This member function is used to change the array size.
Definition XTPCalendarPtrCollectionT.h:745
CXTPCalendarPtrCollectionT::TObjectPtr
CXTPSmartPtrInternalT< _TObject > TObjectPtr
Smart pointer type for stored objects.
Definition XTPCalendarPtrCollectionT.h:426
CXTPCalendarPtrCollectionT::GetAt
virtual _TObject * GetAt(int nIndex) const
This member function returns an element at the specified numeric index.
Definition XTPCalendarPtrCollectionT.h:665
CXTPCalendarPtrCollectionT::GetAt
virtual _TObject * GetAt(int nIndex, BOOL bWithAddRef) const
This member function returns an element at the specified numeric index.
Definition XTPCalendarPtrCollectionT.h:672
CXTPCalendarPtrCollectionT::m_arElements
CArray< TObjectPtr, TObjectPtr & > m_arElements
Objects storage.
Definition XTPCalendarPtrCollectionT.h:428
CXTPCalendarPtrCollectionT::Append
virtual void Append(const CXTPCalendarPtrCollectionT< _TObject > *pElementsArray)
This member function is used to add a new elements to the end of the array.
Definition XTPCalendarPtrCollectionT.h:701
CXTPCalendarPtrCollectionT::~CXTPCalendarPtrCollectionT
virtual ~CXTPCalendarPtrCollectionT()
Default collection destructor.
Definition XTPCalendarPtrCollectionT.h:654
CXTPCalendarPtrCollectionT::CXTPCalendarPtrCollectionT
CXTPCalendarPtrCollectionT()
Default collection constructor.
Definition XTPCalendarPtrCollectionT.h:649
CXTPCalendarPtrCollectionT::SetAt
virtual void SetAt(int nIndex, _TObject *pElement)
This member function is used to set a new element to the position specified in the nIndex parameter.
Definition XTPCalendarPtrCollectionT.h:751
CXTPCalendarPtrCollectionT::Remove
virtual void Remove(_TObject *pElement)
This member function finds an element using its pointer and removes it from the array.
Definition XTPCalendarPtrCollectionT.h:731
CXTPCalendarPtrCollectionT::Add
virtual void Add(_TObject *pNewElement, BOOL bWithAddRef)
This member function adds a new element to the end of the array.
Definition XTPCalendarPtrCollectionT.h:683
CXTPCalendarTypedPtrAutoDeleteArray
This class represents a simple array collection of objects pointers.
Definition XTPCalendarPtrCollectionT.h:472
CXTPCalendarTypedPtrAutoDeleteArray::CXTPCalendarTypedPtrAutoDeleteArray
CXTPCalendarTypedPtrAutoDeleteArray()
Default object constructor.
Definition XTPCalendarPtrCollectionT.h:484
CXTPCalendarTypedPtrAutoDeleteArray::RemoveAll
virtual void RemoveAll()
Removes all the elements from the array.
Definition XTPCalendarPtrCollectionT.h:506
CXTPCalendarTypedPtrAutoDeleteArray::TBase
CTypedPtrArray< BASE_CLASS, PTR_TYPE > TBase
Base class type definition.
Definition XTPCalendarPtrCollectionT.h:478
CXTPCalendarTypedPtrAutoDeleteArray::~CXTPCalendarTypedPtrAutoDeleteArray
virtual ~CXTPCalendarTypedPtrAutoDeleteArray()
Default class destructor.
Definition XTPCalendarPtrCollectionT.h:493
CXTPCalendarTypedPtrAutoDeleteMap
This class represents a simple map of typed keys to typed objects pointers.
Definition XTPCalendarPtrCollectionT.h:544
CXTPCalendarTypedPtrAutoDeleteMap::operator[]
TPtr & operator[](KEY key)
Lookup and add a new element if not there.
Definition XTPCalendarPtrCollectionT.h:614
CXTPCalendarTypedPtrAutoDeleteMap::SetAt
virtual void SetAt(KEY key, TPtr pValue, BOOL bDeletePrevPtr=TRUE)
Add a new (key, value) pair.
Definition XTPCalendarPtrCollectionT.h:598
CXTPCalendarTypedPtrAutoDeleteMap::RemoveKey
virtual BOOL RemoveKey(KEY key, BOOL bDeletePtr=TRUE)
Removes element by its key.
Definition XTPCalendarPtrCollectionT.h:629
CXTPCalendarTypedPtrAutoDeleteMap::RemoveAll
virtual void RemoveAll(BOOL bDeletePtr=TRUE)
Removes all the elements from the map.
Definition XTPCalendarPtrCollectionT.h:571
CXTPCalendarTypedPtrAutoDeleteMap::~CXTPCalendarTypedPtrAutoDeleteMap
virtual ~CXTPCalendarTypedPtrAutoDeleteMap()
Default class destructor.
Definition XTPCalendarPtrCollectionT.h:555
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72


Toolkit Pro: XTPCalendarResource.h Source File

  • Source
  • Calendar
XTPCalendarResource.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARRESOURCE_H_)
23# define _XTPCALENDARRESOURCE_H_
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarControl;
32class CXTPCalendarData;
33class CXTPNotifyConnection;
34class CXTPCalendarCustomProperties;
35class CXTPPropExchange;
36class CXTPCalendarEvents;
37class CXTPCalendarEvent;
39 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvents)
50class _XTP_EXT_CLASS CXTPCalendarSchedule : public CXTPCmdTarget
51{
53 DECLARE_DYNAMIC(CXTPCalendarSchedule)
55public:
67 CXTPCalendarSchedule(UINT uScheduleID = 0, LPCTSTR pcszScheduleName = _T(""));
68
78 virtual ~CXTPCalendarSchedule();
79
89 UINT GetID() const;
90
99 CString GetName() const;
100
109 void SetID(UINT uScheduleID);
110
111# ifdef _BUSINESS_MODEL_
112 UINT GetSecType() const;
113 void SetSecType(UINT uScheduleSec);
114# endif
115
124 void SetName(LPCTSTR pcszScheduleName);
125
134 CXTPCalendarCustomProperties* GetCustomProperties() const;
135
136protected:
137 CString m_strScheduleName;
138 UINT m_uScheduleID;
140# ifdef _BUSINESS_MODEL_
141 UINT m_uScheduleSec;
142# endif
143
144 CXTPCalendarCustomProperties* m_pCustomProperties;
147protected:
148# ifdef _XTP_ACTIVEX
149
150 DECLARE_DISPATCH_MAP()
151 DECLARE_INTERFACE_MAP()
152
153 DECLARE_OLETYPELIB_EX(CXTPCalendarSchedule);
154
155 afx_msg LPDISPATCH OleCustomProperties();
156
157# endif
158};
159
174class _XTP_EXT_CLASS CXTPCalendarSchedules : public CXTPCalendarPtrCollectionT<CXTPCalendarSchedule>
175{
177 DECLARE_DYNAMIC(CXTPCalendarSchedules)
179public:
186 CXTPCalendarSchedules();
187
198 virtual ~CXTPCalendarSchedules();
199
210 virtual BOOL AddNewSchedule(LPCTSTR pcszScheduleName);
211
223 virtual BOOL RemoveSchedule(UINT uScheduleID);
224
235 virtual LPCTSTR GetScheduleName(UINT uScheduleID) const;
236
245 virtual int FindIndex(UINT uScheduleID) const;
246
256 virtual void SetScheduleName(UINT uScheduleID, LPCTSTR pcszNewName);
257
269 virtual void DoPropExchange(CXTPPropExchange* pPX);
270
271protected:
281 virtual UINT _GetNextID() const;
282
294 virtual void _Load(CXTPPropExchange* pPX);
295
307 virtual void _Save(CXTPPropExchange* pPX);
308
309# ifdef _XTP_ACTIVEX
310
311 DECLARE_DISPATCH_MAP()
312 DECLARE_INTERFACE_MAP()
313
314 DECLARE_OLETYPELIB_EX(CXTPCalendarSchedules);
315 DECLARE_ENUM_VARIANT(CXTPCalendarSchedules)
316
317 BSTR OleGetScheduleName(UINT uScheduleID);
318
319# endif
320};
321
338class _XTP_EXT_CLASS CXTPCalendarResource : public CXTPCmdTarget
339{
341 DECLARE_DYNCREATE(CXTPCalendarResource)
343public:
353 CXTPCalendarResource(CXTPCalendarControl* pCalendarCtrl = NULL);
354
364 virtual ~CXTPCalendarResource();
365
367 // data provider related
368
383 CXTPCalendarData* GetDataProvider() const;
384
402 void SetDataProvider(CXTPCalendarData* pDataProvider,
403 BOOL bCloseDataProviderWhenDestroy = FALSE);
404
419 virtual CXTPCalendarEventsPtr RetrieveDayEvents(COleDateTime dtDay);
420
433 virtual CUIntArray* GetSchedules();
434
451 virtual BOOL ExistsScheduleID(UINT uScheduleID, BOOL bReturnTrueIfSchedulesSetEmpty = TRUE);
452
462 void FilterEventsByScheduleID(CXTPCalendarEvents* pEvents);
463
475 virtual BOOL IsSchedulesSetEmpty() const;
476
485 virtual CString GetName() const;
486
495 virtual void SetName(LPCTSTR pcszResourceName);
496
505 virtual COLORREF GetColor() const;
506
515 virtual void SetColor(COLORREF color);
516
517protected:
518 CString m_strResourceName;
519 CXTPCalendarControl* m_pCalendarCtrl;
520 CXTPCalendarData* m_pDataProvider;
521 CUIntArray m_arScheduleIDs;
522 COLORREF m_Color;
524 BOOL m_bCloseDataProviderWhenDestroy;
527protected:
528# ifdef _XTP_ACTIVEX
529
530 DECLARE_DISPATCH_MAP()
531 DECLARE_INTERFACE_MAP()
532
533 DECLARE_OLETYPELIB_EX(CXTPCalendarResource);
534 DECLARE_OLECREATE_EX(CXTPCalendarResource);
535
536 LPDISPATCH OleGetDataProvider();
537 LPDISPATCH OleGetScheduleIDs();
538
539 void OleSetDataProvider(LPDISPATCH pDispDataProvider, BOOL bCloseDataProviderWhenDestroy);
540 void OleSetDataProvider2(LPCTSTR pcszConnectionString, BOOL bCloseDataProviderWhenDestroy);
541
542 LPDISPATCH OleRetrieveDayEvents(DATE dtDay);
543
544# endif
545};
546
554class _XTP_EXT_CLASS CXTPCalendarResources : public CXTPCalendarPtrCollectionT<CXTPCalendarResource>
555{
557 DECLARE_DYNCREATE(CXTPCalendarResources)
559public:
566 CXTPCalendarResources();
567
578 virtual ~CXTPCalendarResources();
579
591 CXTPCalendarResource* Find(CXTPCalendarEvent* pEvent) const;
592
593 using CXTPCalendarPtrCollectionT<CXTPCalendarResource>::Find;
594
606 CXTPCalendarEventsPtr RetrieveDayEvents(COleDateTime dtDay) const;
607
608protected:
609# ifdef _XTP_ACTIVEX
610
611 DECLARE_DISPATCH_MAP()
612 DECLARE_INTERFACE_MAP()
613
614 DECLARE_OLETYPELIB_EX(CXTPCalendarResources)
615 DECLARE_ENUM_VARIANT(CXTPCalendarResources)
616
617 DECLARE_OLECREATE_EX(CXTPCalendarResources)
618
619 void OleAdd(LPDISPATCH pResourceDisp);
620
621# endif
622};
623
632class _XTP_EXT_CLASS CXTPCalendarResourcesNf
633 : public CXTPCalendarResources
634 , private CXTPNotifySinkBase
635{
636public:
644 CXTPCalendarResourcesNf();
645
655 virtual ~CXTPCalendarResourcesNf();
656
670 CXTPNotifyConnection* GetConnection() const;
671
682 virtual void ReBuildInternalData();
683
701 virtual const CXTPCalendarResources* GetResourcesGroupedByDP() const;
702
719 CXTPCalendarResource* FindByDataProvider(CXTPCalendarData* pData) const;
720
721protected:
733 virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags);
734
735private:
736 static CXTPCalendarResource* AFX_CDECL
737 FindByDataProvider(const CXTPCalendarResources* pResources, CXTPCalendarData* pData);
738
739 CXTPCalendarResources m_arResourcesGroupedByDP;
740
741 class CXTPNotifyConnection_internal : public CXTPNotifyConnection
742 {
743 public:
744 using CXTPNotifyConnection::CONNECTION_DESCRIPTOR;
745 using CXTPNotifyConnection::m_arrConnections;
746 };
747 CXTPNotifyConnection_internal* m_pConnection;
748};
749
751AFX_INLINE UINT CXTPCalendarSchedule::GetID() const
752{
753 return m_uScheduleID;
754}
755AFX_INLINE CString CXTPCalendarSchedule::GetName() const
756{
757 return m_strScheduleName;
758}
759AFX_INLINE void CXTPCalendarSchedule::SetID(UINT uScheduleID)
760{
761 m_uScheduleID = uScheduleID;
762}
763AFX_INLINE void CXTPCalendarSchedule::SetName(LPCTSTR pcszScheduleName)
764{
765 _ASSERTE(pcszScheduleName);
766 m_strScheduleName = pcszScheduleName ? pcszScheduleName : _T("");
767}
768# ifdef _BUSINESS_MODEL_
769AFX_INLINE UINT CXTPCalendarSchedule::GetSecType() const
770{
771 return m_uScheduleSec;
772}
773AFX_INLINE void CXTPCalendarSchedule::SetSecType(UINT uScheduleSec)
774{
775 m_uScheduleSec = uScheduleSec;
776}
777# endif
778
779AFX_INLINE CUIntArray* CXTPCalendarResource::GetSchedules()
780{
781 return &m_arScheduleIDs;
782}
783AFX_INLINE BOOL CXTPCalendarResource::IsSchedulesSetEmpty() const
784{
785 return m_arScheduleIDs.GetSize() == 0;
786}
787AFX_INLINE CXTPCalendarData* CXTPCalendarResource::GetDataProvider() const
788{
789 _ASSERTE(this);
790 return this ? m_pDataProvider : NULL;
791}
792AFX_INLINE CString CXTPCalendarResource::GetName() const
793{
794 return m_strResourceName;
795}
796AFX_INLINE void CXTPCalendarResource::SetName(LPCTSTR pcszResourceName)
797{
798 _ASSERTE(NULL != pcszResourceName);
799 m_strResourceName = (NULL != pcszResourceName ? CString(pcszResourceName) : m_strResourceName);
800}
801AFX_INLINE COLORREF CXTPCalendarResource::GetColor() const
802{
803 return m_Color;
804}
805AFX_INLINE void CXTPCalendarResource::SetColor(COLORREF color)
806{
807 m_Color = color;
808}
809AFX_INLINE CXTPNotifyConnection* CXTPCalendarResourcesNf::GetConnection() const
810{
811 return m_pConnection;
812}
813AFX_INLINE const CXTPCalendarResources* CXTPCalendarResourcesNf::GetResourcesGroupedByDP() const
814{
815 return &m_arResourcesGroupedByDP;
816}
817AFX_INLINE CXTPCalendarResource*
818 CXTPCalendarResourcesNf::FindByDataProvider(CXTPCalendarData* pData) const
819{
820 return FindByDataProvider(GetResourcesGroupedByDP(), pData);
821}
822AFX_INLINE CXTPCalendarCustomProperties* CXTPCalendarSchedule::GetCustomProperties() const
823{
824 return m_pCustomProperties;
825}
826
827# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
828#endif // !defined(_XTPCALENDARRESOURCE_H_)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarCustomProperties
This class is used to store properties collection.
Definition XTPCalendarCustomProperties.h:44
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvent::GetCustomProperties
CXTPCalendarCustomProperties * GetCustomProperties() const
Get custom (named, user-defined) properties collection.
Definition XTPCalendarEvent.h:1287
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarPtrCollectionT::Find
virtual int Find(const _TObject *pElement) const
This member function finds an element index in the collection using its pointer.
Definition XTPCalendarPtrCollectionT.h:719
CXTPCalendarResource
Class CXTPCalendarResource represents a calendar for some subject like a person, a shared resource,...
Definition XTPCalendarResource.h:339
CXTPCalendarResource::SetColor
virtual void SetColor(COLORREF color)
This member function applies a new color to the resource object.
Definition XTPCalendarResource.h:805
CXTPCalendarResource::SetDataProvider
void SetDataProvider(CXTPCalendarData *pDataProvider, BOOL bCloseDataProviderWhenDestroy=FALSE)
This member function sets the custom data provider for the control.
CXTPCalendarResource::m_Color
COLORREF m_Color
color of resource
Definition XTPCalendarResource.h:522
CXTPCalendarResource::CXTPCalendarResource
CXTPCalendarResource(CXTPCalendarControl *pCalendarCtrl=NULL)
Default object constructor.
CXTPCalendarResource::m_bCloseDataProviderWhenDestroy
BOOL m_bCloseDataProviderWhenDestroy
If TRUE - call Close() method for the data provider when control is destroyed.
Definition XTPCalendarResource.h:524
CXTPCalendarResource::FilterEventsByScheduleID
void FilterEventsByScheduleID(CXTPCalendarEvents *pEvents)
This member function is used to remove events which are not from this resource.
CXTPCalendarResource::RetrieveDayEvents
virtual CXTPCalendarEventsPtr RetrieveDayEvents(COleDateTime dtDay)
Call this member function to get the collection of the day's events for this resource.
CXTPCalendarResource::m_arScheduleIDs
CUIntArray m_arScheduleIDs
which schedules are used for this resource.
Definition XTPCalendarResource.h:521
CXTPCalendarResource::GetName
virtual CString GetName() const
This member function returns a string name of this resource object.
Definition XTPCalendarResource.h:792
CXTPCalendarResource::GetSchedules
virtual CUIntArray * GetSchedules()
Call this member function to get the collection of all schedule IDs for this resource.
Definition XTPCalendarResource.h:779
CXTPCalendarResource::~CXTPCalendarResource
virtual ~CXTPCalendarResource()
Default class destructor.
CXTPCalendarResource::ExistsScheduleID
virtual BOOL ExistsScheduleID(UINT uScheduleID, BOOL bReturnTrueIfSchedulesSetEmpty=TRUE)
This member function determines whether a schedule with the specified ID exists or not.
CXTPCalendarResource::GetDataProvider
CXTPCalendarData * GetDataProvider() const
This member function obtains a pointer to the current data provider instance.
Definition XTPCalendarResource.h:787
CXTPCalendarResource::m_strResourceName
CString m_strResourceName
Text name of the resource
Definition XTPCalendarResource.h:518
CXTPCalendarResource::m_pCalendarCtrl
CXTPCalendarControl * m_pCalendarCtrl
Parent Calendar control
Definition XTPCalendarResource.h:519
CXTPCalendarResource::m_pDataProvider
CXTPCalendarData * m_pDataProvider
Associated data provider
Definition XTPCalendarResource.h:520
CXTPCalendarResource::GetColor
virtual COLORREF GetColor() const
This member function returns a color of this resource object.
Definition XTPCalendarResource.h:801
CXTPCalendarResource::IsSchedulesSetEmpty
virtual BOOL IsSchedulesSetEmpty() const
Call this member function to determine if the schedules set in this resource is empty or not.
Definition XTPCalendarResource.h:783
CXTPCalendarResource::SetName
virtual void SetName(LPCTSTR pcszResourceName)
This member function applies a new name to the resource object.
Definition XTPCalendarResource.h:796
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
Definition XTPCalendarResource.h:555
CXTPCalendarResources::Find
CXTPCalendarResource * Find(CXTPCalendarEvent *pEvent) const
This member function is used to remove events which are not from this resource.
CXTPCalendarResources::~CXTPCalendarResources
virtual ~CXTPCalendarResources()
Default collection destructor.
CXTPCalendarResources::RetrieveDayEvents
CXTPCalendarEventsPtr RetrieveDayEvents(COleDateTime dtDay) const
This member function is used to remove events which are not from this resource.
CXTPCalendarResources::CXTPCalendarResources
CXTPCalendarResources()
Default collection constructor.
CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with the addition of a notifications mechani...
Definition XTPCalendarResource.h:635
CXTPCalendarResourcesNf::ReBuildInternalData
virtual void ReBuildInternalData()
Rebuilds notification connection objects after changes in resources configuration.
CXTPCalendarResourcesNf::CXTPCalendarResourcesNf
CXTPCalendarResourcesNf()
Default object constructor.
CXTPCalendarResourcesNf::FindByDataProvider
CXTPCalendarResource * FindByDataProvider(CXTPCalendarData *pData) const
Call this member function to retrieve a resource object for a specified data provider.
Definition XTPCalendarResource.h:818
CXTPCalendarResourcesNf::~CXTPCalendarResourcesNf
virtual ~CXTPCalendarResourcesNf()
Default class destructor.
CXTPCalendarResourcesNf::GetConnection
CXTPNotifyConnection * GetConnection() const
Obtain a pointer to the notification connection object.
Definition XTPCalendarResource.h:809
CXTPCalendarResourcesNf::OnEvent
virtual void OnEvent(XTP_NOTIFY_CODE dwNotifyCode, WPARAM wParam, LPARAM lParam, DWORD dwFlags)
This member function catches all the events from the associated data provider and forwards it to CXTP...
CXTPCalendarResourcesNf::GetResourcesGroupedByDP
virtual const CXTPCalendarResources * GetResourcesGroupedByDP() const
Call this member function to retrieve a resources collection only for unique data providers.
Definition XTPCalendarResource.h:813
CXTPCalendarSchedule
Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event...
Definition XTPCalendarResource.h:51
CXTPCalendarSchedule::m_strScheduleName
CString m_strScheduleName
Stores Schedule Name.
Definition XTPCalendarResource.h:137
CXTPCalendarSchedule::GetCustomProperties
CXTPCalendarCustomProperties * GetCustomProperties() const
Get custom (named, user-defined) properties collection.
Definition XTPCalendarResource.h:822
CXTPCalendarSchedule::CXTPCalendarSchedule
CXTPCalendarSchedule(UINT uScheduleID=0, LPCTSTR pcszScheduleName=_T(""))
Default object constructor.
CXTPCalendarSchedule::SetID
void SetID(UINT uScheduleID)
This member function is used to set a new ID value for a schedule.
Definition XTPCalendarResource.h:759
CXTPCalendarSchedule::m_pCustomProperties
CXTPCalendarCustomProperties * m_pCustomProperties
Stores custom properties collection for this Schedule.
Definition XTPCalendarResource.h:144
CXTPCalendarSchedule::GetName
CString GetName() const
This member function is used to obtain the schedule name.
Definition XTPCalendarResource.h:755
CXTPCalendarSchedule::GetID
UINT GetID() const
This member function is used to obtain a unique schedule ID.
Definition XTPCalendarResource.h:751
CXTPCalendarSchedule::m_uScheduleID
UINT m_uScheduleID
Stores numeric positive ID of the schedule.
Definition XTPCalendarResource.h:138
CXTPCalendarSchedule::SetName
void SetName(LPCTSTR pcszScheduleName)
This member function is used to set the schedule name text.
Definition XTPCalendarResource.h:763
CXTPCalendarSchedule::~CXTPCalendarSchedule
virtual ~CXTPCalendarSchedule()
Default class destructor.
CXTPCalendarSchedules
This class represents a simple array collection of CXTPCalendarSchedule objects.
Definition XTPCalendarResource.h:175
CXTPCalendarSchedules::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Call this member function to Store/Load a schedule using the specified data object.
CXTPCalendarSchedules::~CXTPCalendarSchedules
virtual ~CXTPCalendarSchedules()
Default collection destructor.
CXTPCalendarSchedules::AddNewSchedule
virtual BOOL AddNewSchedule(LPCTSTR pcszScheduleName)
Creates and adds a new schedule object by its name.
CXTPCalendarSchedules::CXTPCalendarSchedules
CXTPCalendarSchedules()
Default collection constructor.
CXTPCalendarSchedules::_Load
virtual void _Load(CXTPPropExchange *pPX)
Call this member function to Load a schedule from the specified data object.
CXTPCalendarSchedules::_Save
virtual void _Save(CXTPPropExchange *pPX)
Call this member function to Store a schedule to the specified data object.
CXTPCalendarSchedules::RemoveSchedule
virtual BOOL RemoveSchedule(UINT uScheduleID)
Removes a schedule object from the array by its ID.
CXTPCalendarSchedules::GetScheduleName
virtual LPCTSTR GetScheduleName(UINT uScheduleID) const
Returns a name of the schedule by its numeric ID.
CXTPCalendarSchedules::SetScheduleName
virtual void SetScheduleName(UINT uScheduleID, LPCTSTR pcszNewName)
Sets a new schedule name by its numeric ID.
CXTPCalendarSchedules::FindIndex
virtual int FindIndex(UINT uScheduleID) const
Finds schedule index in the internal array by its ID.
CXTPCalendarSchedules::_GetNextID
virtual UINT _GetNextID() const
Finds the next available ID which does not exist in the array.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPNotifyConnection::m_arrConnections
CArray< CONNECTION_DESCRIPTOR *, CONNECTION_DESCRIPTOR * > m_arrConnections
store connections between a Connection object, Notification code and the sink object.
Definition XTPNotifyConnection.h:280
CXTPNotifySinkBase
This class is used as implementation of Sink interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:379
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPNotifyConnection::CONNECTION_DESCRIPTOR
This struct is used in the implementation of the class CXTPNotifyConnection to store connection betwe...
Definition XTPNotifyConnection.h:211


Toolkit Pro: XTPColorPageCustom.h Source File

  • Source
  • Controls
  • Dialog
XTPColorPageCustom.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOLORCUSTOM_H__)
24# define __XTPCOLORCUSTOM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPColorDialog;
34
40class _XTP_EXT_CLASS CXTPColorBase : public CStatic
41{
42public:
54 enum FocusedControl
55 {
56 focusNone,
57 focusColorWheel,
58 focusLumination
59 };
60
61public:
66 CXTPColorBase();
67
72 virtual ~CXTPColorBase();
73
74public:
80 virtual void UpdateCursorPos(CPoint point);
81
92 static void AFX_CDECL RGBtoHSL(COLORREF color, double* h, double* s, double* l);
93
104 static COLORREF AFX_CDECL HLStoRGB(double h, double l, double s);
105
106protected:
114 virtual bool Init();
115
118 DECLARE_MESSAGE_MAP()
119
120 //{{AFX_VIRTUAL(CXTPColorBase)
121 virtual void PreSubclassWindow();
122 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
123 //}}AFX_VIRTUAL
124
125 //{{AFX_MSG(CXTPColorBase)
126 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
127 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
128 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
129 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
130 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
131 //}}AFX_MSG
134protected:
135 static FocusedControl m_eHasFocus;
136 bool m_bPreSubclassInit;
138public:
139 double m_nLum;
140 double m_nSat;
141 double m_nHue;
142 CPoint m_ptMousePos;
143};
144
150class _XTP_EXT_CLASS CXTPColorWnd : public CXTPColorBase
151{
152public:
157 CXTPColorWnd();
158
163 virtual ~CXTPColorWnd();
164
165public:
172 virtual void SetColor(double nHue, double nSat);
173
179 virtual void UpdateCursorPos(CPoint point);
180
186 void DrawCrossHair(CDC* pDC);
187
194 void SetHue(double h);
195
202 void SetSaturation(double s);
203
204protected:
206 DECLARE_MESSAGE_MAP()
207
208 //{{AFX_VIRTUAL(CXTPColorWnd)
209 virtual BOOL PreTranslateMessage(MSG* pMsg);
210 //}}AFX_VIRTUAL
211
212 //{{AFX_MSG(CXTPColorWnd)
213 afx_msg void OnPaint();
214 afx_msg void OnSetFocus(CWnd* pOldWnd);
215 afx_msg void OnKillFocus(CWnd* pNewWnd);
216 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
217 //}}AFX_MSG
220protected:
221 CBitmap m_bmpPicker;
222};
223
229class _XTP_EXT_CLASS CXTPColorLum : public CXTPColorBase
230{
231public:
236 CXTPColorLum();
237
242 virtual ~CXTPColorLum();
243
244public:
251 virtual void SetColor(double nHue, double nSat);
252
258 virtual void UpdateCursorPos(CPoint point);
259
265 void DrawSliderArrow(CDC* pDC);
266
272 void DrawLuminanceBar(CDC* pDC);
273
280 void SetLuminance(double l);
281
288 void GetLumBarRect(CRect& rect);
289
290protected:
292 DECLARE_MESSAGE_MAP()
293
294 //{{AFX_VIRTUAL(CXTPColorLum)
295 virtual BOOL PreTranslateMessage(MSG* pMsg);
296 //}}AFX_VIRTUAL
297
298 //{{AFX_MSG(CXTPColorLum)
299 afx_msg void OnPaint();
300 afx_msg void OnSetFocus(CWnd* pOldWnd);
301 afx_msg void OnKillFocus(CWnd* pNewWnd);
302 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
303 //}}AFX_MSG
306protected:
307};
308
314class _XTP_EXT_CLASS CXTPColorPageCustom : public CPropertyPage
315{
316public:
322 CXTPColorPageCustom(CXTPColorDialog* pParentSheet = NULL);
323
328 virtual ~CXTPColorPageCustom();
329
330public:
341 void RGBtoHSL(COLORREF color, int* xtFocusLumination, int* sat, int* hue);
342
343protected:
345 DECLARE_MESSAGE_MAP()
346
347 //{{AFX_VIRTUAL(CXTPColorPageCustom)
348 virtual BOOL OnSetActive();
349 virtual void DoDataExchange(CDataExchange* pDX);
350 virtual BOOL OnInitDialog();
351 //}}AFX_VIRTUAL
352
353 //{{AFX_MSG(CXTPColorPageCustom)
354 void UpdateRGB(COLORREF clr);
355 afx_msg void OnChangeEdit();
356 afx_msg void OnChangeEditLum();
357 afx_msg void OnChangeEditHue();
358 afx_msg void OnChangeEditSat();
359 afx_msg LRESULT OnUpdateColor(WPARAM wParam, LPARAM lParam);
360 afx_msg LRESULT OnColorDblClick(WPARAM wParam, LPARAM lParam);
361 //}}AFX_MSG
364protected:
366 //{{AFX_DATA(CXTPColorPageCustom)
367 enum
368 {
369 IDD = XTP_IDD_COLORCUSTOM
370 };
371 CXTPColorWnd m_colorWnd;
372 CXTPColorLum m_colorLum;
373 CStatic m_txtSat;
374 CStatic m_txtRed;
375 CStatic m_txtLum;
376 CStatic m_txtHue;
377 CStatic m_txtGreen;
378 CStatic m_txtBlue;
379 CSpinButtonCtrl m_spinSat;
380 CSpinButtonCtrl m_spinRed;
381 CSpinButtonCtrl m_spinLum;
382 CSpinButtonCtrl m_spinHue;
383 CSpinButtonCtrl m_spinGreen;
384 CSpinButtonCtrl m_spinBlue;
385 CEdit m_editHue;
386 CEdit m_editGreen;
387 CEdit m_editBlue;
388 CEdit m_editLum;
389 CEdit m_editRed;
390 CEdit m_editSat;
391 int m_nR;
392 int m_nB;
393 int m_nG;
394 int m_nH;
395 int m_nL;
396 int m_nS;
397 //}}AFX_DATA
400protected:
401 CXTPColorDialog* m_pParentSheet;
403 friend class CXTPColorLum;
404};
405
406# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
408#endif // !defined(__XTPCOLORCUSTOM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPColorBase
CXTPColorBase is a CStatic derived base class.
Definition XTPColorPageCustom.h:41
CXTPColorBase::HLStoRGB
static COLORREF AFX_CDECL HLStoRGB(double h, double l, double s)
This member function is called to convert an HLS value to an RGB color value.
CXTPColorBase::RGBtoHSL
static void AFX_CDECL RGBtoHSL(COLORREF color, double *h, double *s, double *l)
This member function is called to convert an RGB color value to an HSL value.
CXTPColorBase::CXTPColorBase
CXTPColorBase()
Constructs a CXTPColorBase object.
CXTPColorBase::~CXTPColorBase
virtual ~CXTPColorBase()
Destroys a CXTPColorBase object, handles cleanup and deallocation.
CXTPColorBase::Init
virtual bool Init()
This member function is called by the CXTPColorBase class to perform initialization when the window i...
CXTPColorBase::FocusedControl
FocusedControl
Enumeration used to determine window focus.
Definition XTPColorPageCustom.h:55
CXTPColorBase::focusColorWheel
@ focusColorWheel
Color wheel window has focus.
Definition XTPColorPageCustom.h:57
CXTPColorBase::focusNone
@ focusNone
Color window does not have input focus.
Definition XTPColorPageCustom.h:56
CXTPColorBase::UpdateCursorPos
virtual void UpdateCursorPos(CPoint point)
Call this member function to update the cursor position.
CXTPColorDialog
CXTPColorDialog is a CPropertySheet derived class.
Definition XTPColorDialog.h:184
CXTPColorLum
CXTPColorLum is a CXTPColorBase derived class.
Definition XTPColorPageCustom.h:230
CXTPColorLum::DrawSliderArrow
void DrawSliderArrow(CDC *pDC)
This member function is called to draw the indicator arrow.
CXTPColorLum::GetLumBarRect
void GetLumBarRect(CRect &rect)
This member function is called to retrieve the display size of the luminance bar.
CXTPColorLum::~CXTPColorLum
virtual ~CXTPColorLum()
Destroys a CXTPColorLum object, handles cleanup and deallocation.
CXTPColorLum::SetLuminance
void SetLuminance(double l)
This member function is called to set the luminance for the color window.
CXTPColorLum::DrawLuminanceBar
void DrawLuminanceBar(CDC *pDC)
This member function is called to draw the selection bar.
CXTPColorLum::SetColor
virtual void SetColor(double nHue, double nSat)
Call this member function to set the color for the selection window.
CXTPColorLum::CXTPColorLum
CXTPColorLum()
Constructs a CXTPColorLum object.
CXTPColorLum::UpdateCursorPos
virtual void UpdateCursorPos(CPoint point)
Call this member function to update the cursor position.
CXTPColorPageCustom
CXTPColorPageCustom is derived from CPropertyPage.
Definition XTPColorPageCustom.h:315
CXTPColorPageCustom::RGBtoHSL
void RGBtoHSL(COLORREF color, int *xtFocusLumination, int *sat, int *hue)
This member function is called to retrieve the HSL values of the RGB specified by color.
CXTPColorPageCustom::CXTPColorPageCustom
CXTPColorPageCustom(CXTPColorDialog *pParentSheet=NULL)
Constructs a CXTPColorPageCustom object.
CXTPColorPageCustom::m_pParentSheet
CXTPColorDialog * m_pParentSheet
Pointer to the parent property sheet.
Definition XTPColorPageCustom.h:401
CXTPColorPageCustom::~CXTPColorPageCustom
virtual ~CXTPColorPageCustom()
Destroys a CXTPColorPageCustom object, handles cleanup and deallocation.
CXTPColorWnd
CXTPColorWnd is a CXTPColorBase derived class.
Definition XTPColorPageCustom.h:151
CXTPColorWnd::CXTPColorWnd
CXTPColorWnd()
Constructs a CXTPColorWnd object.
CXTPColorWnd::SetSaturation
void SetSaturation(double s)
This member function is called to set the saturation for the color window.
CXTPColorWnd::SetHue
void SetHue(double h)
This member function is called to set the hue for the color window.
CXTPColorWnd::~CXTPColorWnd
virtual ~CXTPColorWnd()
Destroys a CXTPColorWnd object, handles cleanup and deallocation.
CXTPColorWnd::DrawCrossHair
void DrawCrossHair(CDC *pDC)
This member function is called to update the crosshair cursor.
CXTPColorWnd::SetColor
virtual void SetColor(double nHue, double nSat)
Call this member function to set the color for the selection window.
CXTPColorWnd::UpdateCursorPos
virtual void UpdateCursorPos(CPoint point)
Call this member function to update the cursor position.


XTP_EVENT_EDIT_OPERATION_PARAMS Member List

This is the complete list of members for XTP_EVENT_EDIT_OPERATION_PARAMS, including all inherited members.

eOperation | XTP_EVENT_EDIT_OPERATION_PARAMS
nRefCounter | XTP_EVENT_EDIT_OPERATION_PARAMS
pEventViews | XTP_EVENT_EDIT_OPERATION_PARAMS


CXTPTabPaintManagerColorSet Member List

This is the complete list of members for CXTPTabPaintManagerColorSet, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)=0 | CXTPTabPaintManagerColorSet | pure virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabPaintManagerColorSet | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


XTP_NM_FLOWGRAPH_ENDLABELEDIT Member List

This is the complete list of members for XTP_NM_FLOWGRAPH_ENDLABELEDIT, including all inherited members.

hdr | XTP_NM_FLOWGRAPH_ENDLABELEDIT
pItem | XTP_NM_FLOWGRAPH_ENDLABELEDIT
strNewString | XTP_NM_FLOWGRAPH_ENDLABELEDIT


Toolkit Pro: XTPCalendarRemindersManager.h Source File

  • Source
  • Calendar
XTPCalendarRemindersManager.h
Go to the documentation of this file.
1
22#if !defined(_XTP_CALENDAR_REMINDERS_MANAGER_H__)
23# define _XTP_CALENDAR_REMINDERS_MANAGER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
29class CXTPCalendarData;
30class CXTPCalendarResources;
31class CXTPCalendarResourcesNf;
32class CXTPCalendarRemindersManager;
33class CXTPNotifyConnection;
34class CXTPCalendarEvent;
35class CXTPCalendarEvents;
36class CXTPNotifySink;
37
38# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
40 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvent)
41 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarEvents)
48class _XTP_EXT_CLASS CXTPCalendarReminder : public CXTPCmdTarget
49{
51 DECLARE_DYNAMIC(CXTPCalendarReminder)
52
53 friend class CXTPCalendarRemindersManager;
54 friend class CXTPCalendarReminders;
56public:
65 CXTPCalendarReminder(CXTPCalendarRemindersManager* pOwnerMan = NULL);
66
76 virtual ~CXTPCalendarReminder();
77
84 virtual CXTPCalendarEventPtr GetEvent() const;
85
102 virtual COleDateTime GetNextReminderTime() const;
103
115 virtual int GetMinutesBeforeStart() const;
116
130 virtual BOOL Snooze(int nMinutesAfterNow);
131
145 virtual BOOL Dismiss();
146
156 virtual BOOL IsEqualID(const CXTPCalendarReminder* pReminder2) const;
157
158protected:
159 COleDateTime m_dtNextReminderTime;
160 int m_nMinutesBeforeStart;
170 virtual void SetEvent(CXTPCalendarEvent* pEvent);
171
176 enum EventType
177 {
178 evtNormal = 1,
179 evtRecurrence = 2,
180 };
181
189 struct RecurrenceEventInfo
190 {
191 DWORD m_dwMasterEventID;
192 DATE m_dtOccurrenceStartTime;
194 DATE m_dtOccurrenceEndTime;
196 };
197
198 COleDateTime m_dtEventStartTime;
199 CXTPCalendarData* m_pEventDataProvider;
201 EventType m_eEventType;
211 union {
212 DWORD m_dwNormalEventID;
213 RecurrenceEventInfo m_RecurrenceEventInfo;
215 };
216
217private:
218 CXTPCalendarRemindersManager* m_pOwnerMan;
219
220protected:
221# ifdef _XTP_ACTIVEX
222
223 DECLARE_DISPATCH_MAP()
224 DECLARE_INTERFACE_MAP()
225
226 DECLARE_OLETYPELIB_EX(CXTPCalendarReminder);
227
228 LPDISPATCH OleGetEvent();
229
230 DATE OleGetNextReminderTime();
231 long OleGetMinutesBeforeStart();
232
233 BOOL OleSnooze(long nMinutesAfterNow);
234 BOOL OleDismiss();
235
236# endif
237};
238
244class _XTP_EXT_CLASS CXTPCalendarReminders : public CXTPCalendarPtrCollectionT<CXTPCalendarReminder>
245{
246public:
261 virtual int Find(const CXTPCalendarReminder* pReminder) const;
262
275 virtual int Find(CXTPCalendarEvent* pEvent) const;
276
291 virtual int Find(DWORD dwEventID, CXTPCalendarData* pDP = NULL) const;
292
303 virtual BOOL RemoveDataForEvent(CXTPCalendarEvent* pEvent);
304
309 virtual void Sort();
310
311protected:
322 virtual BOOL _RemoveDataForMasterEvent(CXTPCalendarEvent* pEvent);
323};
324
354class _XTP_EXT_CLASS CXTPCalendarRemindersManager : public CWnd
355{
357 DECLARE_DYNAMIC(CXTPCalendarRemindersManager)
359 friend class CXTPCalendarReminder;
360
361public:
368 CXTPCalendarRemindersManager();
369
376 virtual ~CXTPCalendarRemindersManager();
377
391 virtual int GetActiveRemindersCount() const;
392
402 virtual void GetActiveReminders(CXTPCalendarReminders& rarActiveReminders) const;
403
418 virtual BOOL Snooze(CXTPCalendarReminder* pReminder, int nMinutesAfterNow);
419
435 virtual BOOL Dismiss(CXTPCalendarReminder* pReminder);
436
451 virtual BOOL DismissAll();
452
466 CXTPNotifyConnection* GetConnection() const;
467
489 virtual BOOL StartMonitoring(CXTPCalendarResources* pResources,
490 COleDateTimeSpan spPeriod2Cache);
491
501 virtual BOOL StopMonitoring();
502
513 virtual BOOL IsMonitoringRunning() const;
514
515protected:
527 virtual void NotifyReminders(int eAction, LPARAM lParam = 0);
528
537 virtual void PostNotify_RemindersFire();
538
545 virtual void RemoveAll();
546
547 CXTPNotifySink* m_pSink;
548
549 afx_msg void OnTimeChange();
550 afx_msg void OnTimer(UINT_PTR uTimerID);
551
552 virtual BOOL _Dismiss(CXTPCalendarReminder* pReminder);
553
554 virtual BOOL UpdateDataFromDP(COleDateTime dtFrom, COleDateTimeSpan spPeriod);
555 virtual BOOL GetUpcomingEventsAll(COleDateTime dtFrom, COleDateTimeSpan spPeriod,
556 CXTPCalendarEventsPtr& rptrEvents);
557
558 virtual BOOL ProcessActiveReminders(COleDateTime dtTime);
559
560 virtual void OnEventChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
561 virtual BOOL ProcessNewEvent(CXTPCalendarEvent* pEvent, COleDateTime dtFrom,
562 COleDateTimeSpan spPeriod);
563 virtual BOOL ProcessChangedEvent(CXTPCalendarEvent* pEvent);
564 virtual BOOL _ProcessNewSingleEvent(CXTPCalendarEvent* pEvent, COleDateTime dtFrom,
565 COleDateTimeSpan spPeriod);
566 virtual BOOL _ProcessNewMasterEvent(CXTPCalendarEvent* pEvent, COleDateTime dtFrom,
567 COleDateTimeSpan spPeriod);
568 virtual BOOL _GetMaxExceptionReminder(CXTPCalendarRecurrencePattern* pPattern, int& rnMinutes);
569
570 virtual BOOL _RemoveSnoozeData(CXTPCalendarReminder* pRmd);
571
572 virtual BOOL _CreateWnd();
573 virtual void OnFinalRelease();
574
576 DECLARE_MESSAGE_MAP()
579protected:
580 CXTPNotifyConnection* m_pConnection;
582 CXTPCalendarResourcesNf* m_pResourcesNf;
584 COleDateTimeSpan m_spPeriod2Cache;
587 COleDateTime m_dtLastUpdateTime;
590 CXTPCalendarReminders m_arWaitingReminders;
591 CXTPCalendarReminders m_arActiveReminders;
593 BOOL m_bMonitoringRunning;
595 BOOL m_bSkipOnEventChanged;
596
597protected:
598# ifdef _XTP_ACTIVEX
599
600 DECLARE_DISPATCH_MAP()
601 DECLARE_INTERFACE_MAP()
602 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
603
604 DECLARE_OLETYPELIB_EX(CXTPCalendarRemindersManager);
605
606 DECLARE_ENUM_VARIANT(CXTPCalendarRemindersManager);
607
608 int OleGetItemCount();
609 LPDISPATCH OleGetItem(long nIndex);
610
611 void OleDismissAll();
612
613# endif
614};
615
617AFX_INLINE COleDateTime CXTPCalendarReminder::GetNextReminderTime() const
618{
619 return m_dtNextReminderTime;
620}
621AFX_INLINE int CXTPCalendarReminder::GetMinutesBeforeStart() const
622{
623 return m_nMinutesBeforeStart;
624}
625AFX_INLINE BOOL CXTPCalendarReminder::Snooze(int nMinutesAfterNow)
626{
627 _ASSERTE(m_pOwnerMan);
628 return m_pOwnerMan ? m_pOwnerMan->Snooze(this, nMinutesAfterNow) : FALSE;
629}
630AFX_INLINE BOOL CXTPCalendarReminder::Dismiss()
631{
632 _ASSERTE(m_pOwnerMan);
633 return m_pOwnerMan ? m_pOwnerMan->Dismiss(this) : FALSE;
634}
635
636//===========================================================================
637AFX_INLINE CXTPNotifyConnection* CXTPCalendarRemindersManager::GetConnection() const
638{
639 return m_pConnection;
640}
641
642AFX_INLINE BOOL CXTPCalendarRemindersManager::IsMonitoringRunning() const
643{
644 return m_bMonitoringRunning;
645}
646
647# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
648#endif // !defined(_XTP_CALENDAR_REMINDERS_MANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPCalendarReminder
This class describes a reminder for a calendar event and implements base properties for and operation...
Definition XTPCalendarRemindersManager.h:49
CXTPCalendarReminder::m_dtNextReminderTime
COleDateTime m_dtNextReminderTime
Store reminder activation date and time.
Definition XTPCalendarRemindersManager.h:159
CXTPCalendarReminder::m_dtEventStartTime
COleDateTime m_dtEventStartTime
Store related event start time.
Definition XTPCalendarRemindersManager.h:198
CXTPCalendarReminder::EventType
EventType
This enum define the event type: recurrence or non-recurrence.
Definition XTPCalendarRemindersManager.h:177
CXTPCalendarReminder::Snooze
virtual BOOL Snooze(int nMinutesAfterNow)
Call this member function to Snooze an active reminder.
Definition XTPCalendarRemindersManager.h:625
CXTPCalendarReminder::CXTPCalendarReminder
CXTPCalendarReminder(CXTPCalendarRemindersManager *pOwnerMan=NULL)
Default object constructor.
CXTPCalendarReminder::m_RecurrenceEventInfo
RecurrenceEventInfo m_RecurrenceEventInfo
Recurrence event information (instead of ID).
Definition XTPCalendarRemindersManager.h:213
CXTPCalendarReminder::m_dwNormalEventID
DWORD m_dwNormalEventID
Non-recurrence event ID.
Definition XTPCalendarRemindersManager.h:212
CXTPCalendarReminder::GetNextReminderTime
virtual COleDateTime GetNextReminderTime() const
Call this member function to retrieve the date and time when a reminder is scheduled to be activated.
Definition XTPCalendarRemindersManager.h:617
CXTPCalendarReminder::Dismiss
virtual BOOL Dismiss()
Call this member function to Dismiss an active reminder.
Definition XTPCalendarRemindersManager.h:630
CXTPCalendarReminder::m_pEventDataProvider
CXTPCalendarData * m_pEventDataProvider
Store related event data provider.
Definition XTPCalendarRemindersManager.h:199
CXTPCalendarReminder::m_nMinutesBeforeStart
int m_nMinutesBeforeStart
Store minutes before start event to activate reminder.
Definition XTPCalendarRemindersManager.h:160
CXTPCalendarReminder::IsEqualID
virtual BOOL IsEqualID(const CXTPCalendarReminder *pReminder2) const
Call this member function to determine if reminders objects have equal IDs (or are they represent the...
CXTPCalendarReminder::m_eEventType
EventType m_eEventType
Define related event type: recurrence or non-recurrence.
Definition XTPCalendarRemindersManager.h:201
CXTPCalendarReminder::GetMinutesBeforeStart
virtual int GetMinutesBeforeStart() const
Call this member function to determine the number of minutes before the start of an event.
Definition XTPCalendarRemindersManager.h:621
CXTPCalendarReminder::SetEvent
virtual void SetEvent(CXTPCalendarEvent *pEvent)
Set a calendar event for which this reminder is related.
CXTPCalendarReminder::~CXTPCalendarReminder
virtual ~CXTPCalendarReminder()
Default class destructor.
CXTPCalendarReminder::GetEvent
virtual CXTPCalendarEventPtr GetEvent() const
Retrieve the calendar event for which this reminder is related.
CXTPCalendarReminders
This class represents a simple array collection of CXTPCalendarReminder objects.
Definition XTPCalendarRemindersManager.h:245
CXTPCalendarReminders::Find
virtual int Find(const CXTPCalendarReminder *pReminder) const
Finds a specified reminder object in the collection.
CXTPCalendarReminders::Find
virtual int Find(DWORD dwEventID, CXTPCalendarData *pDP=NULL) const
Finds a reminder object in the collection which is related to the specified event ID.
CXTPCalendarReminders::_RemoveDataForMasterEvent
virtual BOOL _RemoveDataForMasterEvent(CXTPCalendarEvent *pEvent)
Try to find and remove reminder(s) object(s) which are related to the recurrence master event specifi...
CXTPCalendarReminders::Sort
virtual void Sort()
Sort reminders by the event start time field.
CXTPCalendarReminders::RemoveDataForEvent
virtual BOOL RemoveDataForEvent(CXTPCalendarEvent *pEvent)
Try to find and remove reminder object which is related to the event specified.
CXTPCalendarReminders::Find
virtual int Find(CXTPCalendarEvent *pEvent) const
Finds a reminder object in the collection which is related to the event specified.
CXTPCalendarRemindersManager
This class is used to monitor and manage calendar events reminders.
Definition XTPCalendarRemindersManager.h:355
CXTPCalendarRemindersManager::Dismiss
virtual BOOL Dismiss(CXTPCalendarReminder *pReminder)
Call this member function to Dismiss a specified reminder.
CXTPCalendarRemindersManager::GetActiveRemindersCount
virtual int GetActiveRemindersCount() const
Call this method to retrieve reminders count in the active reminders collection.
CXTPCalendarRemindersManager::StartMonitoring
virtual BOOL StartMonitoring(CXTPCalendarResources *pResources, COleDateTimeSpan spPeriod2Cache)
This method is used to attach to calendar resources (data provider) and start reminders monitoring.
CXTPCalendarRemindersManager::m_bMonitoringRunning
BOOL m_bMonitoringRunning
Flag indicate that reminders manager is started;.
Definition XTPCalendarRemindersManager.h:593
CXTPCalendarRemindersManager::GetActiveReminders
virtual void GetActiveReminders(CXTPCalendarReminders &rarActiveReminders) const
Call this method to retrieve the active reminders collection.
CXTPCalendarRemindersManager::m_pConnection
CXTPNotifyConnection * m_pConnection
A pointer to the notification connection object.
Definition XTPCalendarRemindersManager.h:580
CXTPCalendarRemindersManager::~CXTPCalendarRemindersManager
virtual ~CXTPCalendarRemindersManager()
Default object destructor.
CXTPCalendarRemindersManager::StopMonitoring
virtual BOOL StopMonitoring()
This method is used to detach from calendar resources (data provider) and and to clear all reminders ...
CXTPCalendarRemindersManager::DismissAll
virtual BOOL DismissAll()
Call this member function to Dismiss all active reminders.
CXTPCalendarRemindersManager::NotifyReminders
virtual void NotifyReminders(int eAction, LPARAM lParam=0)
This method is used to send an XTP_NC_CALENDAR_ON_REMINDERS notification via connection object.
CXTPCalendarRemindersManager::RemoveAll
virtual void RemoveAll()
This method clears all reminders in reminders manager collections.
CXTPCalendarRemindersManager::CXTPCalendarRemindersManager
CXTPCalendarRemindersManager()
Default object constructor.
CXTPCalendarRemindersManager::Snooze
virtual BOOL Snooze(CXTPCalendarReminder *pReminder, int nMinutesAfterNow)
Call this member function to Snooze a specified reminder.
CXTPCalendarRemindersManager::IsMonitoringRunning
virtual BOOL IsMonitoringRunning() const
Call this method to determine if StartMonitoring was successfully called and if the reminders manager...
Definition XTPCalendarRemindersManager.h:642
CXTPCalendarRemindersManager::GetConnection
CXTPNotifyConnection * GetConnection() const
Obtain a pointer to the notification connection object.
Definition XTPCalendarRemindersManager.h:637
CXTPCalendarRemindersManager::PostNotify_RemindersFire
virtual void PostNotify_RemindersFire()
Schedule to call NotifyReminders(xtpCalendarRemindersFire) in 500 ms.
CXTPCalendarResources
This class represents a simple array collection of CXTPCalendarResource objects.
Definition XTPCalendarResource.h:555
CXTPCalendarResourcesNf
This class implements CXTPCalendarResource functionality with the addition of a notifications mechani...
Definition XTPCalendarResource.h:635
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPCalendarReminder::RecurrenceEventInfo
This structure contains data members to unambiguously define related recurrence event occurrence.
Definition XTPCalendarRemindersManager.h:190
CXTPCalendarReminder::RecurrenceEventInfo::m_dwMasterEventID
DWORD m_dwMasterEventID
Recurrence master event ID.
Definition XTPCalendarRemindersManager.h:191
CXTPCalendarReminder::RecurrenceEventInfo::m_dtOccurrenceStartTime
DATE m_dtOccurrenceStartTime
Recurrence occurrence start time or recurrence exception original start time.
Definition XTPCalendarRemindersManager.h:192
CXTPCalendarReminder::RecurrenceEventInfo::m_dtOccurrenceEndTime
DATE m_dtOccurrenceEndTime
Recurrence occurrence end time or recurrence exception original end time.
Definition XTPCalendarRemindersManager.h:194


CXTPChartDeviceCommand Member List

This is the complete list of members for CXTPChartDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPCustomizePageOptions.h Source File

  • Source
  • CommandBars
  • Customize
XTPCustomizePageOptions.h
Go to the documentation of this file.
1
23#if !defined(__XTPCUSTOMIZEOPTIONSPAGE_H__) && defined(_XTP_INCLUDE_CONTROLS)
24# define __XTPCUSTOMIZEOPTIONSPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCustomizeSheet;
34class CXTPCommandBars;
35class CXTPWinThemeWrapper;
36
42class _XTP_EXT_CLASS CXTPGroupLine : public CStatic
43{
44public:
49 CXTPGroupLine();
50 ~CXTPGroupLine();
51
52 void EnableTheme(BOOL bEnable = TRUE);
53 void SetBkColor(COLORREF clr);
54 void SetTextColor(COLORREF clr);
55
56protected:
58 DECLARE_MESSAGE_MAP()
59
60 //{{AFX_MSG(CXTPGroupLine)
61 void OnPaint();
62 //}}AFX_MSG
65private:
66 CXTPWinThemeWrapper* m_themeButton;
67
68 BOOL m_bEnableTheme;
69 COLORREF m_clrBack;
70 COLORREF m_clrLine;
71 COLORREF m_clrText;
72};
73
79class _XTP_EXT_CLASS CXTPCustomizeOptionsPage : public CXTPPropertyPage
80{
81public:
89 CXTPCustomizeOptionsPage(CXTPCustomizeSheet* pSheet);
90
96 ~CXTPCustomizeOptionsPage();
97
98public:
106 CXTPCommandBars* GetCommandBars() const;
107
108protected:
115 void AddComboString(UINT nIDResource);
116
117protected:
119 DECLARE_MESSAGE_MAP()
120
121 //{{AFX_VIRTUAL(CXTPCustomizeOptionsPage)
122 virtual void DoDataExchange(CDataExchange* pDX);
123 //}}AFX_VIRTUAL
124
125 //{{AFX_MSG(CXTPCustomizeOptionsPage)
126 afx_msg void OnCheckFullMenus();
127 virtual BOOL OnInitDialog();
128 afx_msg void OnCheckAfterdelay();
129 afx_msg void OnCheckLargeicons();
130 afx_msg void OnCheckScreenttips();
131 afx_msg void OnCheckShortcuts();
132 afx_msg void OnResetData();
133 afx_msg void OnAnimationChanged();
134 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
135 //}}AFX_MSG
138public:
139 enum
140 {
141 IDD = XTP_IDD_PAGE_OPTIONS
142 };
143
144# ifdef _XTP_INCLUDE_CONTROLS
145 COLORREF m_clrText;
146 CXTPButton m_btnResetData;
147 CXTPButton m_btnAlwaysShowFullMenus;
148 CXTPButton m_btnShowFullAfterDelay;
149 CXTPButton m_btnLargeIcons;
150 CXTPButton m_btnToolBarScreenTips;
151 CXTPButton m_btnToolBarAccelTips;
152 CXTPComboBox m_comboAnimationType;
153# else
154 CButton m_btnResetData;
155 CButton m_btnAlwaysShowFullMenus;
156 CButton m_btnShowFullAfterDelay;
157 CButton m_btnLargeIcons;
158 CButton m_btnToolBarScreenTips;
159 CButton m_btnToolBarAccelTips;
160 CComboBox m_comboAnimationType;
161# endif
162 int m_nAnimationType;
163 CXTPGroupLine m_wndPersonalizedGroup;
164 CXTPGroupLine m_wndOtherGroup;
166protected:
167 CXTPCustomizeSheet* m_pSheet;
168};
170# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
171#endif // !defined(__XTPCUSTOMIZEOPTIONSPAGE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCustomizeOptionsPage
CXTPCustomizeOptionsPage is a CPropertyPage derived class.
Definition XTPCustomizePageOptions.h:80
CXTPCustomizeOptionsPage::m_btnLargeIcons
CButton m_btnLargeIcons
Show large icons.
Definition XTPCustomizePageOptions.h:157
CXTPCustomizeOptionsPage::m_comboAnimationType
CComboBox m_comboAnimationType
Animation combobox.
Definition XTPCustomizePageOptions.h:160
CXTPCustomizeOptionsPage::m_btnToolBarScreenTips
CButton m_btnToolBarScreenTips
Show tool tips.
Definition XTPCustomizePageOptions.h:158
CXTPCustomizeOptionsPage::m_wndOtherGroup
CXTPGroupLine m_wndOtherGroup
Other group line.
Definition XTPCustomizePageOptions.h:164
CXTPCustomizeOptionsPage::CXTPCustomizeOptionsPage
CXTPCustomizeOptionsPage(CXTPCustomizeSheet *pSheet)
Constructs a CXTPCustomizeOptionsPage object.
CXTPCustomizeOptionsPage::m_btnShowFullAfterDelay
CButton m_btnShowFullAfterDelay
Show menus after delay.
Definition XTPCustomizePageOptions.h:156
CXTPCustomizeOptionsPage::m_btnResetData
CButton m_btnResetData
Reset data.
Definition XTPCustomizePageOptions.h:154
CXTPCustomizeOptionsPage::m_pSheet
CXTPCustomizeSheet * m_pSheet
Parent sheet.
Definition XTPCustomizePageOptions.h:167
CXTPCustomizeOptionsPage::m_btnAlwaysShowFullMenus
CButton m_btnAlwaysShowFullMenus
Show full menus always.
Definition XTPCustomizePageOptions.h:155
CXTPCustomizeOptionsPage::AddComboString
void AddComboString(UINT nIDResource)
Adds animation string from resource.
CXTPCustomizeOptionsPage::m_wndPersonalizedGroup
CXTPGroupLine m_wndPersonalizedGroup
Personalized group line.
Definition XTPCustomizePageOptions.h:163
CXTPCustomizeOptionsPage::~CXTPCustomizeOptionsPage
~CXTPCustomizeOptionsPage()
Destroys a CXTPCustomizeOptionsPage object, handles cleanup and deallocation.
CXTPCustomizeOptionsPage::m_nAnimationType
int m_nAnimationType
Selected animation type.
Definition XTPCustomizePageOptions.h:162
CXTPCustomizeOptionsPage::m_btnToolBarAccelTips
CButton m_btnToolBarAccelTips
Show accelerators with tool tips.
Definition XTPCustomizePageOptions.h:159
CXTPCustomizeOptionsPage::GetCommandBars
CXTPCommandBars * GetCommandBars() const
Retrieves parent command bars.
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPGroupLine
CXTPGroupLine is a CStatic derived class.
Definition XTPCustomizePageOptions.h:43
CXTPGroupLine::CXTPGroupLine
CXTPGroupLine()
Constructs a CXTPGroupLine object.
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPXamlPreview.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • XAML
XTPXamlPreview.h
Go to the documentation of this file.
1
24#if !defined(__XTPXAMLPREVIEW_H__)
25# define __XTPXAMLPREVIEW_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33namespace Gdiplus
34{
35class Image;
36}
37
38class CXTPMarkupContext;
39class CXTPMarkupUIElement;
40
41class _XTP_EXT_CLASS CXTPXamlPreview : public IXTPPreview
42{
43 class CContext;
44
45public:
46 CXTPXamlPreview(IXTPPreviewHost& host, LPCTSTR pFilePath);
47 CXTPXamlPreview(IXTPPreviewHost& host, IStream& stream, LPCTSTR pImpliedFileName);
48 ~CXTPXamlPreview();
49
50private:
51 virtual BOOL IsReady() const;
52 virtual BOOL IsAvailable() const;
53 virtual BOOL HasOwnNavigator() const;
54 virtual UINT GetNumberOfPages() const;
55 virtual SIZE GetPreferredPageSize() const;
56 virtual void GoToPage(UINT page);
57 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect);
58 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result);
59 virtual BOOL SupportsCompositedParent() const;
60 virtual void Activate();
61
62private:
63 BOOL m_bLoadFinished;
64 BOOL m_bLoadSuccess;
65 CXTPMarkupContext* m_pMarkupContext;
66 CXTPMarkupUIElement* m_pMarkupRoot;
67 HWND m_hwnd;
68 IXTPPreviewHost& m_host;
69};
70
71# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // #if !defined(__XTPXAMLPREVIEW_H__)
73
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
IXTPPreviewHost
Interface implemented by the preview host control.
Definition XTPPreviewAbstract.h:152
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.


CXTPControlSliderCtrl Member List

This is the complete list of members for CXTPControlSliderCtrl, including all inherited members.

m_pControl CXTPControlSliderCtrl protected


CXTPEmptyRect Member List

This is the complete list of members for CXTPEmptyRect, including all inherited members.

CXTPEmptyRect() CXTPEmptyRect


CXTPSkinManagerColorFilter Member List

This is the complete list of members for CXTPSkinManagerColorFilter, including all inherited members.

ApplyColorFilter(COLORREF &clr)=0 | CXTPSkinManagerColorFilter | pure virtual
~CXTPSkinManagerColorFilter() | CXTPSkinManagerColorFilter | inlinevirtual


Toolkit Pro: XTPMenuBar.h Source File

  • Source
  • CommandBars
XTPMenuBar.h
Go to the documentation of this file.
1
23#if !defined(__XTPMENUBAR_H__)
24# define __XTPMENUBAR_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# define XTP_IDR_MENUBAR 1 // Menu Bar
34
35class CXTPCommandBars;
36
42class _XTP_EXT_CLASS CXTPMenuBarMDIMenuInfo : public CXTPCmdTarget
43{
44public:
51 CXTPMenuBarMDIMenuInfo(CXTPCommandBars* pCommandBars, UINT nIDResource);
52
57 ~CXTPMenuBarMDIMenuInfo();
58
59public:
60 CXTPControls* m_pControls;
61 CString m_strTitle;
62 CString m_strDescription;
63 HICON m_hIcon;
64 UINT m_nIDResource;
65 BOOL m_bChanged;
67# ifdef _XTP_COMMANDBARS_ACTIVEX
70 DECLARE_DISPATCH_MAP()
71 DECLARE_OLETYPELIB_EX(CXTPMenuBarMDIMenuInfo);
72 LPDISPATCH OleGetControls();
74# endif
75};
76
77class CXTPMenuBar;
78
83class _XTP_EXT_CLASS CXTPMenuBarMDIMenus : public CXTPCmdTarget
84{
85public:
91 CXTPMenuBarMDIMenus(CXTPMenuBar* pMenuBar);
92
97 ~CXTPMenuBarMDIMenus();
98
99public:
106 int GetCount() const;
107
109 void SetAt(UINT nIDResource, CXTPMenuBarMDIMenuInfo* pInfo);
110 CXTPMenuBarMDIMenuInfo* Lookup(UINT nIDResource) const;
111 void Remove(UINT nIDResource);
112 void RemoveAll();
113 POSITION GetStartPosition() const;
114 void GetNextMenu(POSITION& pos, CXTPMenuBarMDIMenuInfo*& pInfo) const;
117# ifdef _XTP_COMMANDBARS_ACTIVEX
120 DECLARE_DISPATCH_MAP()
121
122 DECLARE_OLETYPELIB_EX(CXTPMenuBarMDIMenus);
123 LPDISPATCH OleGetItem(UINT nID);
124 LPDISPATCH OleAdd(UINT nID, LPCTSTR lpszTitle, LPCTSTR lpszDescription);
125 DECLARE_ENUM_VARIANTLIST(CXTPMenuBarMDIMenus);
126
128# endif
129
130protected:
131 CMap<UINT, UINT, CXTPMenuBarMDIMenuInfo*, CXTPMenuBarMDIMenuInfo*> m_mapMenus;
132 CXTPMenuBar* m_pMenuBar;
133};
134
140class _XTP_EXT_CLASS CXTPMenuBar : public CXTPToolBar
141{
142public:
147 CXTPMenuBar();
148
153 ~CXTPMenuBar();
154
155public:
163 virtual BOOL LoadMenuBar(UINT nIDResource);
164
169 void FreeMDIMenus();
170
175 void RefreshMenu();
176
183 UINT GetCurrentMenuResource() const;
184
191 UINT GetDefaultMenuResource() const;
192
199 CXTPMenuBarMDIMenus* GetMDIMenus() const;
200
209 virtual void SwitchMDIMenu(UINT nIDMenu, CMenu* pMenu = NULL);
210
219 CXTPMenuBarMDIMenuInfo* AddMDIMenu(UINT nIDResource);
220
227 void SwitchActiveMenu();
228
234 virtual void Reset(BOOL bShowWarningMessage);
235
236protected:
249 int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam, LRESULT& lResult);
250
256 void DoPropExchange(CXTPPropExchange* pPX);
257
264 virtual void Copy(CXTPCommandBar* pCommandBar, BOOL bRecursive = FALSE);
265
266protected:
271 void SetupHook();
272
277 void SetupMenu();
278
287 HWND GetActiveMdiChildWnd(BOOL* bMaximized = NULL);
288
293 void SyncActiveMdiChild();
294
299 virtual void RefreshSysButtons();
300
306 void SwitchMDIMenu(HMENU hMenu);
307
315 void GenerateCommandBarList(DWORD& nID, CXTPCommandBarList* pCommandBarList,
316 XTP_COMMANDBARS_PROPEXCHANGE_PARAM* pParam);
317
324 void RestoreCommandBarList(CXTPCommandBarList* pCommandBarList);
325
332 BOOL ShouldSerializeBar();
333
334 virtual BOOL OnFrameMouseWheel(BOOL bForward);
335
336protected:
338 DECLARE_MESSAGE_MAP()
339
340 //{{AFX_MSG(CXTPMenuBar)
341 afx_msg void OnTimer(UINT_PTR nIDEvent);
342 afx_msg void OnDestroy();
343 //}}AFX_MSG
346# ifdef _XTP_COMMANDBARS_ACTIVEX
349 DECLARE_DISPATCH_MAP()
350 DECLARE_INTERFACE_MAP()
351
352 DECLARE_OLETYPELIB_EX(CXTPMenuBar);
353 afx_msg LPDISPATCH OleGetMDIMenus();
354 afx_msg void OleSwitchMDIMenu(int nId);
356# endif
357
358private:
359 void AddSysButton(CXTPControl* pControl, int nId, LPCTSTR lpszParameter, int nBefore = -1);
360 BOOL IsMDIMenusChanged();
361 BOOL IsOleDocumentActive(HWND hWndActiveChild) const;
362
363protected:
364 BOOL m_bMdiApp;
365 HWND m_hWndActiveChild;
366 HMENU m_hMenuDefault;
368 UINT m_nIDResource;
369 UINT m_nIDResourceCurrent;
370 CXTPMenuBarMDIMenus* m_pMDIMenus;
372private:
373 BOOL m_bDirtyMenu;
374
375private:
376 DECLARE_XTP_COMMANDBAR(CXTPMenuBar)
377
378 class CControlMDIButton;
379 class CControlMDISysMenuPopup;
380
381 friend class CXTPCommandBars;
382 friend class CControlMDIButton;
383 friend class CCommandBarsSite;
384 friend class CCommandBarsCtrl;
385};
386
387AFX_INLINE UINT CXTPMenuBar::GetCurrentMenuResource() const
388{
389 return m_nIDResourceCurrent;
390}
391AFX_INLINE UINT CXTPMenuBar::GetDefaultMenuResource() const
392{
393 return m_nIDResource;
394}
395AFX_INLINE CXTPMenuBarMDIMenus* CXTPMenuBar::GetMDIMenus() const
396{
397 return m_pMDIMenus;
398}
400# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
401#endif //#if !defined(__XTPMENUBAR_H__)
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarList
CXTPCommandBarList is a CList derived class.
Definition XTPCommandBarList.h:42
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPMenuBar
CXTPMenuBar is a CXTPToolBar derived class.
Definition XTPMenuBar.h:141
CXTPMenuBar::GetDefaultMenuResource
UINT GetDefaultMenuResource() const
Call this method to retrieve the identifier of the default menu.
Definition XTPMenuBar.h:391
CXTPMenuBar::m_nIDResource
UINT m_nIDResource
Resource of default menu.
Definition XTPMenuBar.h:368
CXTPMenuBar::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPMenuBar::~CXTPMenuBar
~CXTPMenuBar()
Destroys a CXTPMenuBar object, handles cleanup and deallocation.
CXTPMenuBar::m_nIDResourceCurrent
UINT m_nIDResourceCurrent
Currently active menu.
Definition XTPMenuBar.h:369
CXTPMenuBar::GetMDIMenus
CXTPMenuBarMDIMenus * GetMDIMenus() const
Retrieves the collection of application MDI menus.
Definition XTPMenuBar.h:395
CXTPMenuBar::FreeMDIMenus
void FreeMDIMenus()
Destroy all MDI menus.
CXTPMenuBar::GetActiveMdiChildWnd
HWND GetActiveMdiChildWnd(BOOL *bMaximized=NULL)
Call this method to get the handle to the active MDI child window.
CXTPMenuBar::SwitchMDIMenu
virtual void SwitchMDIMenu(UINT nIDMenu, CMenu *pMenu=NULL)
This method is called to switch to an MDI menu from the MDI menus collection.
CXTPMenuBar::RefreshMenu
void RefreshMenu()
This member function will refresh the menus.
CXTPMenuBar::Reset
virtual void Reset(BOOL bShowWarningMessage)
Call this method to reset the controls to their original states.
CXTPMenuBar::OnHookMessage
int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPMenuBar::RestoreCommandBarList
void RestoreCommandBarList(CXTPCommandBarList *pCommandBarList)
Call this method during the serialization process to restore pop-ups from a list of command bars.
CXTPMenuBar::SwitchMDIMenu
void SwitchMDIMenu(HMENU hMenu)
Call this method to switch the current MDI menu.
CXTPMenuBar::m_pMDIMenus
CXTPMenuBarMDIMenus * m_pMDIMenus
MDI menus.
Definition XTPMenuBar.h:370
CXTPMenuBar::SwitchActiveMenu
void SwitchActiveMenu()
Call this method to switch the menu to the active document menu.
CXTPMenuBar::LoadMenuBar
virtual BOOL LoadMenuBar(UINT nIDResource)
Loads a menu from the resource.
CXTPMenuBar::m_bMdiApp
BOOL m_bMdiApp
TRUE if parent frame is CMDIFrameWnd derived.
Definition XTPMenuBar.h:364
CXTPMenuBar::GenerateCommandBarList
void GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam)
Call this method to assign self-identifiers for the serialization process.
CXTPMenuBar::m_hWndActiveChild
HWND m_hWndActiveChild
Active MDI window handle.
Definition XTPMenuBar.h:365
CXTPMenuBar::ShouldSerializeBar
BOOL ShouldSerializeBar()
Call this method to check if the toolbar has changed and must be saved.
CXTPMenuBar::RefreshSysButtons
virtual void RefreshSysButtons()
Call this method to update the system buttons of the menu bar.
CXTPMenuBar::GetCurrentMenuResource
UINT GetCurrentMenuResource() const
Call this method to retrieve the identifier of the currently visible menu.
Definition XTPMenuBar.h:387
CXTPMenuBar::Copy
virtual void Copy(CXTPCommandBar *pCommandBar, BOOL bRecursive=FALSE)
This method makes a copy of the command bar.
CXTPMenuBar::SetupMenu
void SetupMenu()
This method is called to create the menu for the main window.
CXTPMenuBar::CXTPMenuBar
CXTPMenuBar()
Constructs a CXTPMenuBar object.
CXTPMenuBar::AddMDIMenu
CXTPMenuBarMDIMenuInfo * AddMDIMenu(UINT nIDResource)
Call this method to manually load an MDI menu in application initialization.
CXTPMenuBar::SyncActiveMdiChild
void SyncActiveMdiChild()
Call this method to update the active MDI window hooks.
CXTPMenuBar::m_hMenuDefault
HMENU m_hMenuDefault
Default menu handle.
Definition XTPMenuBar.h:366
CXTPMenuBar::SetupHook
void SetupHook()
This method is called to create hooks for the main window.
CXTPMenuBarMDIMenuInfo
CXTPMenuBarMDIMenuInfo structure used to describe the parameters of application MDI menus.
Definition XTPMenuBar.h:43
CXTPMenuBarMDIMenuInfo::m_nIDResource
UINT m_nIDResource
Template identifier.
Definition XTPMenuBar.h:64
CXTPMenuBarMDIMenuInfo::~CXTPMenuBarMDIMenuInfo
~CXTPMenuBarMDIMenuInfo()
Destroys a CXTPMenuBarMDIMenuInfo object, handles cleanup and deallocation.
CXTPMenuBarMDIMenuInfo::m_strDescription
CString m_strDescription
Description of MDI menu.
Definition XTPMenuBar.h:62
CXTPMenuBarMDIMenuInfo::m_strTitle
CString m_strTitle
Title of MDI menu.
Definition XTPMenuBar.h:61
CXTPMenuBarMDIMenuInfo::m_hIcon
HICON m_hIcon
Menu Icon.
Definition XTPMenuBar.h:63
CXTPMenuBarMDIMenuInfo::m_pControls
CXTPControls * m_pControls
Menu controls.
Definition XTPMenuBar.h:60
CXTPMenuBarMDIMenuInfo::m_bChanged
BOOL m_bChanged
TRUE if menu was changed.
Definition XTPMenuBar.h:65
CXTPMenuBarMDIMenuInfo::CXTPMenuBarMDIMenuInfo
CXTPMenuBarMDIMenuInfo(CXTPCommandBars *pCommandBars, UINT nIDResource)
Constructs a CXTPMenuBarMDIMenuInfo object.
CXTPMenuBarMDIMenus
CXTPMenuBarMDIMenus represents a collection of MDI menus for CXTPMenuBar.
Definition XTPMenuBar.h:84
CXTPMenuBarMDIMenus::GetCount
int GetCount() const
Gets the number of MDI menus in the collection.
CXTPMenuBarMDIMenus::~CXTPMenuBarMDIMenus
~CXTPMenuBarMDIMenus()
Destroys a CXTPMenuBarMDIMenus object, handles cleanup and deallocation.
CXTPMenuBarMDIMenus::m_pMenuBar
CXTPMenuBar * m_pMenuBar
Parent Menu Bar.
Definition XTPMenuBar.h:132
CXTPMenuBarMDIMenus::m_mapMenus
CMap< UINT, UINT, CXTPMenuBarMDIMenuInfo *, CXTPMenuBarMDIMenuInfo * > m_mapMenus
Menu map.
Definition XTPMenuBar.h:131
CXTPMenuBarMDIMenus::CXTPMenuBarMDIMenus
CXTPMenuBarMDIMenus(CXTPMenuBar *pMenuBar)
Constructs a CXTPMenuBarMDIMenus object.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
XTP_COMMANDBARS_PROPEXCHANGE_PARAM
XTP_COMMANDBARS_PROPEXCHANGE_PARAM is a structure used to store the CommandBar's save settings.
Definition XTPCommandBars.h:88


CXTPChart3dPieDeviceCommand Member List

This is the complete list of members for CXTPChart3dPieDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dPieDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy, const CXTPPoint3d &ptCenter, double dMajorSemiAxis, double dMinorSemiAxis, double dStartAngle, double dSweepAngle, double dDepth, double nHolePercent) | CXTPChart3dPieDeviceCommand | protected
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_bDoughnut | CXTPChartPieDeviceCommandImpl | protected
m_dCorrectedDepth | CXTPChartPieDeviceCommandImpl | protected
m_dDepth | CXTPChartPieDeviceCommandImpl | protected
m_dFacetSize | CXTPChartPieDeviceCommandImpl | protected
m_dHolePercent | CXTPChartPieDeviceCommandImpl | protected
m_dInnerMajorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dInnerMinorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dInnerRadius | CXTPChartPieDeviceCommandImpl | protected
m_dMajorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dMinorSemiAxis | CXTPChartPieDeviceCommandImpl | protected
m_dRadius | CXTPChartPieDeviceCommandImpl | protected
m_dStartAngle | CXTPChartPieDeviceCommandImpl | protected
m_dSweepAngle | CXTPChartPieDeviceCommandImpl | protected
m_ptCenter | CXTPChartPieDeviceCommandImpl | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPChartPieDeviceCommandImpl() | CXTPChartPieDeviceCommandImpl | protectedvirtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


CXTPGridRecords Member List

This is the complete list of members for CXTPGridRecords, including all inherited members.

Add(CXTPGridRecord *pRecord) | CXTPGridRecords |
CleanOfRedundant() | CXTPGridRecords | virtual
Compare(const CString &str1, const CString &str2) const | CXTPGridRecords | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecords(BOOL bArray=FALSE) | CXTPGridRecords |
CXTPGridRecords(CXTPGridRecord *pOwnerRecord) | CXTPGridRecords |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecords | virtual
FindRecordByBookmark(VARIANT vtBookmark, BOOL bSearchInChildren) | CXTPGridRecords | virtual
FindRecordItem(int nStartRecord, int nEndRecord, int nStartColumn, int nEndColumn, int nRecord, int nItem, LPCTSTR pcszText, int nFlags) | CXTPGridRecords | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPGridRecords |
GetCount() const | CXTPGridRecords |
GetMarkupContext() const | CXTPGridRecords |
GetOwnerRecord() const | CXTPGridRecords |
InsertAt(int nIndex, CXTPGridRecord *pRecord) | CXTPGridRecords |
IsCaseSensitive() const | CXTPGridRecords |
m_arrRecords | CXTPGridRecords | protected
m_bCaseSensitive | CXTPGridRecords | protected
m_nVirtualRecordsCount | CXTPGridRecords | protected
m_pControl | CXTPGridRecords | protected
m_pMarkupContext | CXTPGridRecords | protected
m_pOwnerRecord | CXTPGridRecords | protected
Move(int nIndex, CXTPGridRecords *pRecords) | CXTPGridRecords |
MoveRecord(int nIndex, CXTPGridRecord *pRecord, BOOL bUpdateIndexes=FALSE) | CXTPGridRecords |
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
PrepareToDropping(CXTPGridRecord *pTargetRecord, CXTPGridRecords *pTargetRecords, BOOL bChangeParent) | CXTPGridRecords | virtual
RemoveAll() | CXTPGridRecords |
RemoveAt(int nIndex) | CXTPGridRecords |
RemoveRecord(CXTPGridRecord *pRecord) | CXTPGridRecords |
SetAt(INT_PTR nIndex, CXTPGridRecord *pRecord) | CXTPGridRecords | virtual
SetCaseSensitive(BOOL bCaseSensitive) | CXTPGridRecords |
SetMarkupContext(CXTPMarkupContext *pMarkupContext) | CXTPGridRecords |
SetSize(INT_PTR nNewSize, INT_PTR nGrowBy=-1) | CXTPGridRecords | virtual
UpdateIndexes(int nStart=0) | CXTPGridRecords | virtual
~CXTPGridRecords() | CXTPGridRecords | virtual


Toolkit Pro: XTPGridBorder.h Source File

  • Source
  • GridControl
XTPGridBorder.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDBORDER_H__)
24# define __XTPGRIDBORDER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridThickness;
38enum XTPGridBorderEdge
39{
40 xtpGridBorderEdgeLeft,
41 xtpGridBorderEdgeTop,
42 xtpGridBorderEdgeRight,
43 xtpGridBorderEdgeBottom,
44 xtpGridBorderEdgeCount
45};
46
47class _XTP_EXT_CLASS CXTPGridBorderEdge : public CXTPCmdTarget
48{
49public:
50 CXTPGridBorderEdge();
51
58 XTPGridLineStyle GetLineStyle() const;
59
60 void SetLineStyle(XTPGridLineStyle lineStyle);
61
62protected:
63 XTPGridLineStyle m_lineStyle;
64};
65
66class _XTP_EXT_CLASS CXTPGridBorder : public CXTPCmdTarget
67{
68public:
69 CXTPGridBorder();
70
71 virtual ~CXTPGridBorder();
72
73 virtual void Draw(CDC* pDC, CRect rcBorder);
74 virtual void DrawH(CDC* pDC, CRect rcBorder);
75 virtual void DrawV(CDC* pDC, CRect rcBorder);
76
77 CSize GetSize() const;
78
81 // Properties
82
83public:
84 CXTPGridBorderEdge* GetEdge(const XTPGridBorderEdge edge) const;
85
92 COLORREF GetBorderColor() const;
93
99 void SetBorderColor(COLORREF crBorder);
100
101 CXTPGridThickness* GetMargin() const;
102
103 CXTPGridThickness* GetBorderThickness() const;
104
105 CXTPGridThickness* GetPadding() const;
106
107 static CRect AFX_CDECL DeflateRect(CRect rcDeflate, const CXTPGridBorder* pBorder);
108
111 // Members
112
113protected:
114 COLORREF m_crBackground;
115 COLORREF m_crBorder;
117 CXTPGridBorderEdge* m_pEdgeLeft;
118 CXTPGridBorderEdge* m_pEdgeTop;
119 CXTPGridBorderEdge* m_pEdgeRight;
120 CXTPGridBorderEdge* m_pEdgeBottom;
122 CXTPGridThickness* m_pMargin;
123 CXTPGridThickness* m_pBorderThickness;
124 CXTPGridThickness* m_pPadding;
125};
126
129# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
130#endif // #if !defined(__XTPGRIDBORDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridBorderEdge
XTPGridBorderEdge
Defines a grid border edge.
Definition XTPGridBorder.h:39
xtpGridBorderEdgeLeft
@ xtpGridBorderEdgeLeft
Specifies a left grid border edge.
Definition XTPGridBorder.h:40
xtpGridBorderEdgeBottom
@ xtpGridBorderEdgeBottom
Specifies a bottom grid border edge.
Definition XTPGridBorder.h:43
xtpGridBorderEdgeCount
@ xtpGridBorderEdgeCount
Specifies the number of grid border edges.
Definition XTPGridBorder.h:44
xtpGridBorderEdgeRight
@ xtpGridBorderEdgeRight
Specifies a right grid border edge.
Definition XTPGridBorder.h:42
xtpGridBorderEdgeTop
@ xtpGridBorderEdgeTop
Specifies a top grid border edge.
Definition XTPGridBorder.h:41
XTPGridLineStyle
XTPGridLineStyle
Represents predefined grid line styles.
Definition XTPGridDefines.h:126
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridThickness
The CXTPGridThickness class describes the thickness of the left, top, right, and bottom sides of a re...
Definition XTPGridThickness.h:39


CXTPDockingPaneOffice2007OutlookTheme Member List

This is the complete list of members for CXTPDockingPaneOffice2007OutlookTheme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme |
CXTPDockingPaneOffice2007OutlookTheme() | CXTPDockingPaneOffice2007OutlookTheme |
CXTPDockingPaneOffice2007Theme() | CXTPDockingPaneOffice2007Theme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneOffice2007OutlookTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneOffice2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneOffice2003Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneOffice2003Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawGripper | CXTPDockingPaneOffice2003Theme |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bRoundedCaption | CXTPDockingPaneOffice2003Theme | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneOffice2007OutlookTheme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneOffice2003Theme() | CXTPDockingPaneOffice2003Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


CXTPGridRecordItemDateTime Member List

This is the complete list of members for CXTPGridRecordItemDateTime, including all inherited members.

AddHyperlink(CXTPGridHyperlink *pHyperlink) | CXTPGridRecordItem | virtual
Compare(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItemDateTime | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridGroupRow *pGroupRow) | CXTPGridRecordItemDateTime | virtual
CompareGroupCaption(CXTPGridColumn *pColumn, CXTPGridRecordItem *pItem) | CXTPGridRecordItemDateTime | virtual
CreateBorder() | CXTPGridRecordItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItem() | CXTPGridRecordItem |
CXTPGridRecordItemDateTime(COleDateTime odtValue=(DATE) 0) | CXTPGridRecordItemDateTime |
DestroyBorder() | CXTPGridRecordItem |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemDateTime | virtual
Draw(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs) | CXTPGridRecordItem | virtual
DrawCheckBox(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItem |
GetBackgroundColor() | CXTPGridRecordItem | virtual
GetBorder() const | CXTPGridRecordItem |
GetCanEditCheckboxItem() const | CXTPGridRecordItem |
GetCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItemDateTime | virtual
GetCaption() | CXTPGridRecordItemDateTime | virtual
GetCaptionRect(XTP_GRIDRECORDITEM_ARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
GetCheckedState() const | CXTPGridRecordItem |
GetColumnCaptionPrefix(CXTPGridColumn *pColumn) const | CXTPGridRecordItem |
GetEditOptions(CXTPGridColumn *pColumn) | CXTPGridRecordItem |
GetFont() | CXTPGridRecordItem | virtual
GetFormatString() const | CXTPGridRecordItem | virtual
GetFormula() const | CXTPGridRecordItem | virtual
GetGroupCaption(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionID(CXTPGridColumn *pColumn) | CXTPGridRecordItem | virtual
GetGroupCaptionValue(CXTPGridColumn *pColumn) | CXTPGridRecordItemDateTime | virtual
GetGroupPriority() const | CXTPGridRecordItem | virtual
GetHasCheckbox() const | CXTPGridRecordItem | virtual
GetHyperlinkAt(int nHyperlink) const | CXTPGridRecordItem | virtual
GetHyperlinks() | CXTPGridRecordItem | protected
GetHyperlinksCount() const | CXTPGridRecordItem | virtual
GetIconIndex() const | CXTPGridRecordItem | virtual
GetIndex() const | CXTPGridRecordItem |
GetItemControls() | CXTPGridRecordItem |
GetItemData() const | CXTPGridRecordItem | virtual
GetItemMetrics(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pItemMetrics) | CXTPGridRecordItem | virtual
GetMarkupUIElement() const | CXTPGridRecordItem |
GetRecord() const | CXTPGridRecordItem |
GetSelectedConstraintData(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
GetSortPriority() const | CXTPGridRecordItem | virtual
GetTextColor() | CXTPGridRecordItem | virtual
GetTooltip() const | CXTPGridRecordItem | virtual
GetValue() | CXTPGridRecordItemDateTime |
HasCheckbox(BOOL bHasCheckbox, BOOL bTristate=FALSE) | CXTPGridRecordItem | virtual
HitTest(CPoint ptPoint) | CXTPGridRecordItem |
HitTestHyperlink(CPoint ptClick) | CXTPGridRecordItem | virtual
IsBold() const | CXTPGridRecordItem | virtual
IsChecked() const | CXTPGridRecordItem | virtual
IsChildOfMerge() const | CXTPGridRecordItem |
IsEditable() const | CXTPGridRecordItem | virtual
IsFocusable() const | CXTPGridRecordItem | virtual
IsPreviewItem() const | CXTPGridRecordItem | virtual
m_Alignment | CXTPGridRecordItem | protected
m_bBoldText | CXTPGridRecordItem | protected
m_bCanEditCheckboxItem | CXTPGridRecordItem | protected
m_bEditable | CXTPGridRecordItem | protected
m_bFocusable | CXTPGridRecordItem | protected
m_bHasCheckbox | CXTPGridRecordItem | protected
m_bItemControlUnderMouse | CXTPGridRecordItem | protected
m_bTristateCheckbox | CXTPGridRecordItem | protected
m_checkState | CXTPGridRecordItem | protected
m_clrBackground | CXTPGridRecordItem | protected
m_clrText | CXTPGridRecordItem | protected
m_dwData | CXTPGridRecordItem | protected
m_nGroupPriority | CXTPGridRecordItem | protected
m_nIconIndex | CXTPGridRecordItem | protected
m_nSortPriority | CXTPGridRecordItem | protected
m_odtValue | CXTPGridRecordItemDateTime | protected
m_pBorder | CXTPGridRecordItem | protected
m_pControl | CXTPGridRecordItem | protected
m_pEditOptions | CXTPGridRecordItem | protected
m_pFocusedItemControl | CXTPGridRecordItem | protected
m_pFontCaption | CXTPGridRecordItem | protected
m_pHyperlinks | CXTPGridRecordItem | protected
m_pItemControlHookWnd | CXTPGridRecordItem | protected
m_pItemControls | CXTPGridRecordItem | protected
m_pMarkupUIElement | CXTPGridRecordItem | protected
m_pRecord | CXTPGridRecordItem | protected
m_rcGlyph | CXTPGridRecordItem | protected
m_strCaption | CXTPGridRecordItem | protected
m_strFormatString | CXTPGridRecordItem | protected
m_strFormula | CXTPGridRecordItem | protected
m_strGroupCaption | CXTPGridRecordItem | protected
m_strTooltip | CXTPGridRecordItem | protected
OnBeginEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnCancelEdit(CXTPGridControl *pControl, BOOL bApply) | CXTPGridRecordItem | virtual
OnChar(XTP_GRIDRECORDITEM_ARGS *pItemArgs, UINT nChar) | CXTPGridRecordItem | protectedvirtual
OnClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnConstraintChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CXTPGridRecordItemConstraint *pConstraint) | CXTPGridRecordItem | virtual
OnDblClick(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnDrawCaption(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, XTP_GRIDRECORDITEM_METRICS *pMetrics) | CXTPGridRecordItem | virtual
OnDrawControls(XTP_GRIDRECORDITEM_DRAWARGS *pDrawArgs, CRect &rcItem) | CXTPGridRecordItem | virtual
OnEditCanceled(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
OnEditChanged(XTP_GRIDRECORDITEM_ARGS *pItemArgs, LPCTSTR szText) | CXTPGridRecordItemDateTime | virtual
OnEditChanging(XTP_GRIDRECORDITEM_ARGS *pItemArgs, CString &rstrNewText) | CXTPGridRecordItem | virtual
OnInplaceButtonDown(CXTPGridInplaceButton *pButton) | CXTPGridRecordItem | virtual
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItem | virtual
OnMouseMove(UINT nFlags, CPoint point, CXTPGridControl *pControl=NULL) | CXTPGridRecordItem | virtual
OnRequestEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | protectedvirtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) | CXTPGridRecordItem | virtual
OnValidateEdit(XTP_GRIDRECORDITEM_ARGS *pItemArgs) | CXTPGridRecordItem | virtual
operator delete(void *p) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< CXTPCmdTarget, CXTPGridDataAllocator > | inline
RemoveHyperlinkAt(int nHyperlink) | CXTPGridRecordItem | virtual
ResetMarkupUIElement() | CXTPGridRecordItem | virtual
SetAlignment(int nAlignment) | CXTPGridRecordItem |
SetBackgroundColor(COLORREF clrBackground) | CXTPGridRecordItem | virtual
SetBold(BOOL bBold=TRUE) | CXTPGridRecordItem | virtual
SetCanEditCheckboxItem(BOOL bSet) | CXTPGridRecordItem |
SetCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetChecked(BOOL bChecked) | CXTPGridRecordItem | virtual
SetCheckedState(int iState) | CXTPGridRecordItem |
SetEditable(BOOL bEditable=TRUE) | CXTPGridRecordItem | virtual
SetFocusable(BOOL bFocusable) | CXTPGridRecordItem | virtual
SetFont(CFont *pFont) | CXTPGridRecordItem | virtual
SetFormatString(LPCTSTR strFormat) | CXTPGridRecordItem | virtual
SetFormula(LPCTSTR sFormula) | CXTPGridRecordItem | virtual
SetGridControl(CXTPGridControl *pControl) | CXTPGridRecordItem |
SetGroupCaption(LPCTSTR strCaption) | CXTPGridRecordItem | virtual
SetGroupPriority(int nGroupPriority) | CXTPGridRecordItem | virtual
SetIconIndex(int nIconIndex) | CXTPGridRecordItem | virtual
SetItemData(DWORD_PTR dwData) | CXTPGridRecordItem | virtual
SetRecord(CXTPGridRecord *pGridRecord) | CXTPGridRecordItem |
SetSortPriority(int nSortPriority) | CXTPGridRecordItem | virtual
SetTextColor(COLORREF clrText) | CXTPGridRecordItem | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridRecordItem | virtual
SetValue(COleDateTime odtValue) | CXTPGridRecordItemDateTime |
UpdateValue() | CXTPGridRecordItem |
~CXTPGridRecordItem() | CXTPGridRecordItem | virtual


Toolkit Pro: XTPChartAreaSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartAreaSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAREASERIESVIEW_H__)
24# define __XTPCHARTAREASERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36
47class _XTP_EXT_CLASS CXTPChartAreaSeriesView : public CXTPChartDiagram2DSeriesView
48{
49public:
57 CXTPChartAreaSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
58
59protected:
74 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
75 CXTPChartSeriesPoint* pPoint,
76 CXTPChartElementView* pParentView);
77
89 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
90
97 CXTPChartColor GetActualColor() const;
98
105 CXTPChartColor GetActualColor2() const;
106
113 CXTPChartColor GetBorderActualColor() const;
114
124 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
125 CRect rcBounds);
126};
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
129#endif //#if !defined(__XTPCHARTAREASERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAreaSeriesView
CXTPChartAreaSeriesView is a kind of CXTPChartSeriesView.
Definition XTPChartAreaSeriesView.h:48
CXTPChartAreaSeriesView::GetBorderActualColor
CXTPChartColor GetBorderActualColor() const
Call this function to get the actual color of the series border.
CXTPChartAreaSeriesView::GetActualColor
CXTPChartColor GetActualColor() const
Call this function to get the actual color of the series.
CXTPChartAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartAreaSeriesView::GetActualColor2
CXTPChartColor GetActualColor2() const
Call this function to get the second actual color of the series.
CXTPChartAreaSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartAreaSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a chart area series point view object.
CXTPChartAreaSeriesView::CXTPChartAreaSeriesView
CXTPChartAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartAreaSeriesView object.
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: XTPTrackThemeNativeWindows10.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMENATIVEWINDOWS10_H__)
24# define __XTPTRACKTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeNativeWindows10 : public CXTPTrackThemeOffice2013
39{
40public:
45 CXTPTrackThemeNativeWindows10();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPTRACKTHEMENATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTrackThemeNativeWindows10
CXTPTrackThemeNativeWindows10 is a CXTPTrackThemeOffice2013 derived class that represents a Native Wi...
Definition XTPTrackThemeNativeWindows10.h:39
CXTPTrackThemeNativeWindows10::CXTPTrackThemeNativeWindows10
CXTPTrackThemeNativeWindows10()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeNativeWindows10::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39


CXTPSyntaxEditPropertiesPageColor Member List

This is the complete list of members for CXTPSyntaxEditPropertiesPageColor, including all inherited members.

CXTPSyntaxEditPropertiesPageColor(CXTPSyntaxEditView *pEditView=NULL) | CXTPSyntaxEditPropertiesPageColor |
EnableControls() | CXTPSyntaxEditPropertiesPageColor | protected
GetDisplayName(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &info) const | CXTPSyntaxEditPropertiesPageColor | protected
GetPropValue(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXPROPINFO &infoProp) const | CXTPSyntaxEditPropertiesPageColor | protected
InitClassData(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &infoClass) | CXTPSyntaxEditPropertiesPageColor | protected
InitSchemaClasses(XTP_EDIT_SCHEMAFILEINFO *pSchemaInfo) | CXTPSyntaxEditPropertiesPageColor | protected
IsTopLevelClass(const XTPSyntaxEditLexAnalyser::XTP_EDIT_LEXCLASSINFO &infoClass) | CXTPSyntaxEditPropertiesPageColor | protected
m_bModified | CXTPSyntaxEditPropertiesPageColor | protected
m_mapLexClassInfo | CXTPSyntaxEditPropertiesPageColor | protected
m_parLexClassInfo | CXTPSyntaxEditPropertiesPageColor | protected
m_pEditView | CXTPSyntaxEditPropertiesPageColor | protected
m_pTextSchemesMgr | CXTPSyntaxEditPropertiesPageColor | protected
m_ptrConfigMgr | CXTPSyntaxEditPropertiesPageColor | protected
m_xtpFontEdit | CXTPSyntaxEditPropertiesPageColor | protected
PropExists(XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexPropInfoArray &arrProp, LPCTSTR lpszPropName) | CXTPSyntaxEditPropertiesPageColor | protected
SetDefaults() | CXTPSyntaxEditPropertiesPageColor | protected
SetModified(BOOL bChanged=TRUE) | CXTPSyntaxEditPropertiesPageColor |
UpdateColorValue(CXTPSyntaxEditColorComboBox &combo, COLORREF &color, LPCTSTR lpszPropName) | CXTPSyntaxEditPropertiesPageColor | protected
UpdateFont() | CXTPSyntaxEditPropertiesPageColor | protected
UpdateFontValue(BOOL &bValue, LPCTSTR lpszPropName) | CXTPSyntaxEditPropertiesPageColor | protected
UpdateSampleColors() | CXTPSyntaxEditPropertiesPageColor | protected
WriteRegistryValues() | CXTPSyntaxEditPropertiesPageColor |
~CXTPSyntaxEditPropertiesPageColor() | CXTPSyntaxEditPropertiesPageColor | virtual


CXTPChartStepLineSeriesPointView Member List

This is the complete list of members for CXTPChartStepLineSeriesPointView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartPointSeriesPointView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartStepLineSeriesPointView | virtual
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartPointSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartSeriesPointView |
CXTPChartSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartSeriesPointView |
CXTPChartStepLineSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartStepLineSeriesPointView |
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetColor() const | CXTPChartSeriesPointView |
GetColor2() const | CXTPChartSeriesPointView |
GetCount() const | CXTPChartElementView |
GetInternalValue() const | CXTPChartSeriesPointView |
GetLegendName() const | CXTPChartSeriesPointView | virtual
GetParentView() const | CXTPChartElementView |
GetPoint() const | CXTPChartSeriesPointView |
GetScreenPoint() const | CXTPChartPointSeriesPointView |
GetSeriesView() const | CXTPChartSeriesPointView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_dInternalValue | CXTPChartSeriesPointView |
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_pPoint | CXTPChartSeriesPointView | protected
m_rcBounds | CXTPChartElementView | protected
UpdateMinMaxRange(double &nMinValue, double &nMaxValue) const | CXTPChartSeriesPointView | virtual
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


IXTPWebBrowserEventSink Member List

This is the complete list of members for IXTPWebBrowserEventSink, including all inherited members.

ShellExplorer_OnBeforeNavigate2(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL, VARIANT *pvtFlags, VARIANT *pvtTargetFrameName, VARIANT *pvtPostData, VARIANT *pvtHeaders, BOOL *pbCancel) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnCommandStateChange(CXTPWebBrowserCtrl &sender, long nCommand, BOOL bEnable) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnDocumentComplete(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnDownloadBegin(CXTPWebBrowserCtrl &sender) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnDownloadComplete(CXTPWebBrowserCtrl &sender) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnFullScreen(CXTPWebBrowserCtrl &sender, BOOL bFullScreen) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnMenuBar(CXTPWebBrowserCtrl &sender, BOOL bMenuBar) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnNavigateComplete2(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnNavigateError(CXTPWebBrowserCtrl &sender, LPDISPATCH pDisp, VARIANT *pvtURL, VARIANT *pvtTargetFrameName, VARIANT *pvtStatusCode, BOOL *pbCancel) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnNewWindow2(CXTPWebBrowserCtrl &sender, LPDISPATCH *ppDisp, BOOL *pbCancel) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnProgressChange(CXTPWebBrowserCtrl &sender, long nProgress, long nProgressMax) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnPropertyChange(CXTPWebBrowserCtrl &sender, LPCTSTR lpszProperty) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnQuit(CXTPWebBrowserCtrl &sender) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnSetSecureLockIcon(CXTPWebBrowserCtrl &sender, long nSecureLockIcon) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnStatusBar(CXTPWebBrowserCtrl &sender, BOOL bStatusBar) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnStatusTextChange(CXTPWebBrowserCtrl &sender, LPCTSTR lpszText) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnTheaterMode(CXTPWebBrowserCtrl &sender, BOOL bTheaterMode) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnTitleChange(CXTPWebBrowserCtrl &sender, LPCTSTR lpszText) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnToolBar(CXTPWebBrowserCtrl &sender, BOOL bToolBar) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnVisible(CXTPWebBrowserCtrl &sender, BOOL bVisible) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnWindowClosing(CXTPWebBrowserCtrl &sender, BOOL bIsChildWindow, BOOL FAR *pbCancel) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnWindowSetHeight(CXTPWebBrowserCtrl &sender, long nHeight) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnWindowSetLeft(CXTPWebBrowserCtrl &sender, long nLeft) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnWindowSetResizable(CXTPWebBrowserCtrl &sender, BOOL bResizable) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnWindowSetTop(CXTPWebBrowserCtrl &sender, long nTop) | IXTPWebBrowserEventSink | inlinevirtual
ShellExplorer_OnWindowSetWidth(CXTPWebBrowserCtrl &sender, long nWidth) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_ContainsFullScreenElementChanged(CXTPWebBrowserCtrl &sender, IUnknown *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_ContentLoading(CXTPWebBrowserCtrl &sender, ICoreWebView2ContentLoadingEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_DocumentTitleChanged(CXTPWebBrowserCtrl &sender, IUnknown *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_FrameNavigationCompleted(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationCompletedEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_FrameNavigationStarting(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationStartingEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_HistoryChanged(CXTPWebBrowserCtrl &sender, IUnknown *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_NavigationCompleted(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationCompletedEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_NavigationStarting(CXTPWebBrowserCtrl &sender, ICoreWebView2NavigationStartingEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_NewWindowRequested(CXTPWebBrowserCtrl &sender, ICoreWebView2NewWindowRequestedEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_PermissionRequested(CXTPWebBrowserCtrl &sender, ICoreWebView2PermissionRequestedEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_ProcessFailed(CXTPWebBrowserCtrl &sender, ICoreWebView2ProcessFailedEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_ScriptDialogOpening(CXTPWebBrowserCtrl &sender, ICoreWebView2ScriptDialogOpeningEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_SourceChanged(CXTPWebBrowserCtrl &sender, ICoreWebView2SourceChangedEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_WebResourceRequested(CXTPWebBrowserCtrl &sender, ICoreWebView2WebResourceRequestedEventArgs *args) | IXTPWebBrowserEventSink | inlinevirtual
WebView2_WindowCloseRequested(CXTPWebBrowserCtrl &sender, IUnknown *args) | IXTPWebBrowserEventSink | inlinevirtual
~IXTPWebBrowserEventSink() | IXTPWebBrowserEventSink | inlinevirtual


Toolkit Pro: XTPMarkupString.h Source File

  • Source
  • Markup
XTPMarkupString.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSTRING_H__)
24# define __XTPMARKUPSTRING_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34
35class _XTP_EXT_CLASS CXTPMarkupString : public CXTPMarkupObject
36{
38 DECLARE_MARKUPCLASS(CXTPMarkupString);
40public:
41 CXTPMarkupString(LPCSTR lpszValue);
42 CXTPMarkupString(LPCWSTR lpszValue = NULL, int nLength = -1, int nObjFlags = 0);
43
44 virtual ~CXTPMarkupString();
45
46public:
47 operator LPCWSTR() const;
48 int GetLength() const;
49 UINT GetIgnoreCaseHashKey() const;
50 BOOL IsEqual(const CXTPMarkupString* pString, BOOL bCaseSensitive = TRUE) const;
51
52public:
53 static CXTPMarkupString* AFX_CDECL CreateValue(LPCSTR lpszString, int nLength = -1);
54 static CXTPMarkupString* AFX_CDECL CreateValue(LPCWSTR lpszString, int nLength = -1);
55
56public:
57 virtual UINT GetHashKey() const;
58 virtual BOOL IsEqual(const CXTPMarkupObject* pObject) const;
59
60private:
61 void Init(LPCWSTR lpszValue, int nLength);
62 void CalcHash();
63
64protected:
65 LPWSTR m_lpszValue;
66 int m_nLength;
67 UINT m_nHash;
68 UINT m_nCIHash;
69};
70
71AFX_INLINE CXTPMarkupString::operator LPCWSTR() const
72{
73 return m_lpszValue;
74}
75
76AFX_INLINE int CXTPMarkupString::GetLength() const
77{
78 return m_nLength;
79}
80
81AFX_INLINE BOOL IsStringObject(CXTPMarkupObject* pObject)
82{
83 return pObject && pObject->GetType() == MARKUP_TYPE(CXTPMarkupString);
84}
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPMARKUPSTRING_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


CXTPControlRadioButton Member List

This is the complete list of members for CXTPControlRadioButton, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlRadioButton() | CXTPControlRadioButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControlRadioButton | protectedvirtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControlRadioButton | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


CXTPFlowGraphPage Member List

This is the complete list of members for CXTPFlowGraphPage, including all inherited members.

Arrange() | CXTPFlowGraphPage | virtual
CanPaste() | CXTPFlowGraphPage | virtual
Copy() | CXTPFlowGraphPage | virtual
Cut() | CXTPFlowGraphPage | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPFlowGraphPage() | CXTPFlowGraphPage |
DoPropExchange(CXTPPropExchange *pPX) | CXTPFlowGraphPage | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPFlowGraphPage |
GetConnections() const | CXTPFlowGraphPage |
GetControl() const | CXTPFlowGraphPage |
GetGroups() const | CXTPFlowGraphPage |
GetID() const | CXTPFlowGraphPage |
GetNodes() const | CXTPFlowGraphPage |
GetPageRect() const | CXTPFlowGraphPage |
GetScrollOffset() const | CXTPFlowGraphPage |
GetSelection() const | CXTPFlowGraphPage |
GetZoomLevel() const | CXTPFlowGraphPage |
m_cfNode | CXTPFlowGraphPage | static
m_dZoomLevel | CXTPFlowGraphPage | protected
m_nId | CXTPFlowGraphPage | protected
m_pConnections | CXTPFlowGraphPage | protected
m_pControl | CXTPFlowGraphPage | protected
m_pFirstVisibleConnection | CXTPFlowGraphPage | protected
m_pFirstVisibleNode | CXTPFlowGraphPage | protected
m_pGroups | CXTPFlowGraphPage | protected
m_pNodes | CXTPFlowGraphPage | protected
m_pSelectedElements | CXTPFlowGraphPage | protected
m_ptScrollOffset | CXTPFlowGraphPage | protected
m_rcPage | CXTPFlowGraphPage | protected
m_rcWorkRect | CXTPFlowGraphPage | protected
m_strCaption | CXTPFlowGraphPage | protected
OnDraw(CXTPFlowGraphDrawContext *pDC) | CXTPFlowGraphPage | virtual
OnGraphChanged() | CXTPFlowGraphPage | virtual
OnRemoved() | CXTPFlowGraphPage | protectedvirtual
PageToScreen(LPCRECT lpRect) const | CXTPFlowGraphPage |
Paste() | CXTPFlowGraphPage | virtual
Remove() | CXTPFlowGraphPage |
Reposition(CXTPFlowGraphDrawContext *pDC, CRect rcPage) | CXTPFlowGraphPage | virtual
ScreenToPage(double &x, double &y) const | CXTPFlowGraphPage |
ScreenToPage(CPoint point) const | CXTPFlowGraphPage |
ScreenToPage(LPCRECT lpRect) const | CXTPFlowGraphPage |
SetCaption(LPCTSTR lpszCaption) | CXTPFlowGraphPage |
SetID(int nId) | CXTPFlowGraphPage |
SetScrollOffset(CPoint ptScrollOffset) | CXTPFlowGraphPage |
SetVisibleNodesWindowsRegions() | CXTPFlowGraphPage | protected
SetZoomLevel(double dZoomLevel) | CXTPFlowGraphPage |
~CXTPFlowGraphPage() | CXTPFlowGraphPage | protectedvirtual


CXTPSyntaxEditTipListBox Member List

This is the complete list of members for CXTPSyntaxEditTipListBox, including all inherited members.

CXTPSyntaxEditTipListBox() | CXTPSyntaxEditTipListBox |
HitTest(LPPOINT pPoint=NULL) const | CXTPSyntaxEditTipListBox |
HitTest(CPoint point, BOOL bIsClient=FALSE) const | CXTPSyntaxEditTipListBox |
m_dwIdx | CXTPSyntaxEditTipListBox | protected
m_wndInfoTip | CXTPSyntaxEditTipListBox | protected
SelChanged() | CXTPSyntaxEditTipListBox |
ShowTip(CPoint point, BOOL bIsClient=FALSE) | CXTPSyntaxEditTipListBox |


CXTPStatusBarThemeVisualStudio2022 Member List

This is the complete list of members for CXTPStatusBarThemeVisualStudio2022, including all inherited members.

CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeOffice2013 |
CXTPStatusBarThemeVisualStudio2022(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeVisualStudio2022 |
DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPStatusBarThemeVisualStudio2022 | virtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPStatusBarThemeOffice2013 | virtual
GetStateColor() const | CXTPStatusBarThemeVisualStudio2022 | virtual
GetTextColor(CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
m_clrButtonBack | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextPushed | CXTPStatusBarThemeOffice2013 | protected
RefreshMetrics() | CXTPStatusBarThemeVisualStudio2022 | virtual
SetStateColor(COLORREF clrState) | CXTPStatusBarThemeVisualStudio2022 | virtual
~CXTPStatusBarThemeVisualStudio2022() | CXTPStatusBarThemeVisualStudio2022 |


NMXTPCONTROL Member List

This is the complete list of members for NMXTPCONTROL, including all inherited members.

hdr | NMXTPCONTROL
pControl | NMXTPCONTROL


CXTPPropertyGridItemConstraint Member List

This is the complete list of members for CXTPPropertyGridItemConstraint, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItemConstraint() | CXTPPropertyGridItemConstraint |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetImage() const | CXTPPropertyGridItemConstraint | virtual
GetIndex() const | CXTPPropertyGridItemConstraint | virtual
m_bEnabled | CXTPPropertyGridItemConstraint |
m_dwData | CXTPPropertyGridItemConstraint |
m_nImage | CXTPPropertyGridItemConstraint |
m_nIndex | CXTPPropertyGridItemConstraint | protected
m_pItem | CXTPPropertyGridItemConstraint | protected
m_strConstraint | CXTPPropertyGridItemConstraint |


  • CXTPSkinObjectFrame
  • CCaptionButton
CXTPSkinObjectFrame::CCaptionButton Member List

This is the complete list of members for CXTPSkinObjectFrame::CCaptionButton, including all inherited members.

CCaptionButton(int nCommand, CXTPSkinObjectFrame *pFrame, UINT nHTCode, int m_nClassPart) | CXTPSkinObjectFrame::CCaptionButton |
Draw(CDC *pDC, BOOL bFrameActive) | CXTPSkinObjectFrame::CCaptionButton |
IsHighlighted() const | CXTPSkinObjectFrame::CCaptionButton |
IsPressed() const | CXTPSkinObjectFrame::CCaptionButton |
m_nClassPart | CXTPSkinObjectFrame::CCaptionButton |
m_nCommand | CXTPSkinObjectFrame::CCaptionButton |
m_nHTCode | CXTPSkinObjectFrame::CCaptionButton |
m_pFrame | CXTPSkinObjectFrame::CCaptionButton |
m_rcButton | CXTPSkinObjectFrame::CCaptionButton |
~CCaptionButton() | CXTPSkinObjectFrame::CCaptionButton | virtual


Toolkit Pro: XTPRibbonBackstageSeparatorThemeNativeWindows11.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMENATIVEWINDOWS11_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeNativeWindows11
36 : public CXTPRibbonBackstageSeparatorThemeOffice2013
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeNativeWindows11();
40};
41
42# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
44#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


CXTPSyntaxEditLineMarksManager Member List

This is the complete list of members for CXTPSyntaxEditLineMarksManager, including all inherited members.

AddRemoveLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType, XTP_EDIT_LMPARAM *pParam=NULL) | CXTPSyntaxEditLineMarksManager |
CLineMarksListPtr typedef | CXTPSyntaxEditLineMarksManager |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPSyntaxEditLineMarksManager() | CXTPSyntaxEditLineMarksManager |
DeleteLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType) | CXTPSyntaxEditLineMarksManager |
FindNextLineMark(int &nRow, const XTP_EDIT_LINEMARKTYPE lmType) const | CXTPSyntaxEditLineMarksManager |
FindPrevLineMark(int &nRow, const XTP_EDIT_LINEMARKTYPE lmType) const | CXTPSyntaxEditLineMarksManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCount(const XTP_EDIT_LINEMARKTYPE lmType) const | CXTPSyntaxEditLineMarksManager |
GetFirstLineMark(const XTP_EDIT_LINEMARKTYPE lmType) const | CXTPSyntaxEditLineMarksManager |
GetLastLineMark(const XTP_EDIT_LINEMARKTYPE lmType) const | CXTPSyntaxEditLineMarksManager |
GetLineMarkAt(const POSITION pos, const XTP_EDIT_LINEMARKTYPE lmType) const | CXTPSyntaxEditLineMarksManager |
GetNextLineMark(POSITION &pos, const XTP_EDIT_LINEMARKTYPE lmType) const | CXTPSyntaxEditLineMarksManager |
HasRowMark(int nRow, const XTP_EDIT_LINEMARKTYPE &lmType, XTP_EDIT_LMPARAM *pParam=NULL) const | CXTPSyntaxEditLineMarksManager |
RefreshLineMarks(int nRowFrom, int nRowTo, int nRefreshType) | CXTPSyntaxEditLineMarksManager | virtual
RemoveAll(const XTP_EDIT_LINEMARKTYPE lmType) | CXTPSyntaxEditLineMarksManager |
SetLineMark(int nRow, const XTP_EDIT_LINEMARKTYPE lmType, XTP_EDIT_LMPARAM *pParam=NULL) | CXTPSyntaxEditLineMarksManager |
~CXTPSyntaxEditLineMarksManager() | CXTPSyntaxEditLineMarksManager | virtual


  • CXTPNotifyConnection
  • CEmptySyncObject
CXTPNotifyConnection::CEmptySyncObject Member List

This is the complete list of members for CXTPNotifyConnection::CEmptySyncObject, including all inherited members.

CEmptySyncObject() | CXTPNotifyConnection::CEmptySyncObject |
Lock(DWORD dwTimeout=INFINITE) | CXTPNotifyConnection::CEmptySyncObject | virtual
Unlock() | CXTPNotifyConnection::CEmptySyncObject | virtual
Unlock(LONG lCount, LPLONG lPrevCount=NULL) | CXTPNotifyConnection::CEmptySyncObject | virtual


CXTPPropertySheet Member List

This is the complete list of members for CXTPPropertySheet, including all inherited members.

AddButton(UINT nIDCaption, UINT nID) | CXTPPropertySheet | virtual
AddPage(CXTPPropertyPage *pPage) | CXTPPropertySheet |
AutoLoadPlacement(LPCTSTR pszSection) | CXTPPropertySheet |
Create(CWnd *pParentWnd=NULL, DWORD dwStyle=(DWORD) -1, DWORD dwExStyle=0) | CXTPPropertySheet |
CreateButtons() | CXTPPropertySheet | protectedvirtual
CreatePage(CXTPPropertyPage *pPage) | CXTPPropertySheet | protectedvirtual
CXTPDialogBase() | CXTPDialogBase< CDialog > | inline
CXTPDialogBase(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogBase< CDialog > | inline
CXTPDialogBase(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogBase< CDialog > | inline
CXTPDialogEx() | CXTPDialogEx | inline
CXTPDialogEx(UINT nIDTemplate, CWnd *pParentWnd=NULL) | CXTPDialogEx | inline
CXTPDialogEx(LPCTSTR lpszTemplateName, CWnd *pParentWnd=NULL) | CXTPDialogEx | inline
CXTPPropertySheet() | CXTPPropertySheet |
CXTPPropertySheet(UINT nIDCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0) | CXTPPropertySheet |
CXTPPropertySheet(LPCTSTR pszCaption, CWnd *pParentWnd=NULL, UINT iSelectPage=0) | CXTPPropertySheet |
DoModal() | CXTPPropertySheet |
GetActiveIndex() const | CXTPPropertySheet |
GetActivePage() const | CXTPPropertySheet |
GetNavigator() const | CXTPPropertySheet |
GetPage(int nPage) const | CXTPPropertySheet |
GetPageBorderStyle() const | CXTPPropertySheet |
GetPageCount() const | CXTPPropertySheet |
GetPageIndex(CXTPPropertyPage *pPage) const | CXTPPropertySheet |
GetPageRect() const | CXTPPropertySheet |
GetTheme() | CXTPPropertySheet |
InsertPage(int nIndex, CXTPPropertyPage *pPage) | CXTPPropertySheet |
LoadPlacement(LPCTSTR pszSection) | CXTPPropertySheet |
m_arrButtons | CXTPPropertySheet | protected
m_arrPages | CXTPPropertySheet | protected
m_bAllowApply | CXTPPropertySheet | protected
m_bModeless | CXTPPropertySheet | protected
m_bResizable | CXTPPropertySheet | protected
m_lpDlgTemplate | CXTPPropertySheet | protected
m_nPageBorderStyle | CXTPPropertySheet | protected
m_pActivePage | CXTPPropertySheet | protected
m_pNavigator | CXTPPropertySheet | protected
m_psh | CXTPPropertySheet |
m_rcMaxPage | CXTPPropertySheet | protected
m_rcMinPage | CXTPPropertySheet | protected
m_rcPage | CXTPPropertySheet | protected
m_scSizeIcon | CXTPPropertySheet | protected
m_strCaption | CXTPPropertySheet | protected
m_szButton | CXTPPropertySheet | protected
m_szWindow | CXTPPropertySheet | protected
m_xtpFontNormal | CXTPPropertySheet | protected
RemoveButtons() | CXTPPropertySheet |
RemovePage(int nPage) | CXTPPropertySheet |
RemovePage(CXTPPropertyPage *pPage) | CXTPPropertySheet |
SavePlacement(LPCTSTR pszSection) | CXTPPropertySheet |
SetActivePage(int nPage) | CXTPPropertySheet | virtual
SetActivePage(CXTPPropertyPage *pPage) | CXTPPropertySheet | virtual
SetNavigator(CXTPPropertyPageNavigator *pNavigator) | CXTPPropertySheet |
SetPageBorderStyle(XTPPropertyPageBorder nBorder) | CXTPPropertySheet |
SetPageSize(CSize szPage) | CXTPPropertySheet |
SetPageSizeMax(CSize szPage) | CXTPPropertySheet |
SetPageSizeMin(CSize szPage) | CXTPPropertySheet |
SetResizable(BOOL bResizable=TRUE) | CXTPPropertySheet |
SetTheme(XTPControlTheme theme) | CXTPPropertySheet |
SetTitle(LPCTSTR lpszText) | CXTPPropertySheet |
UpdatePages() | CXTPPropertySheet |
~CXTPPropertySheet() | CXTPPropertySheet |


Toolkit Pro: XTPTabColorSetOffice2013.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETOFFICE2013_H__)
24# define __XTPTABCOLORSETOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetOffice2013 : public CXTPTabColorSetVisualStudio2012
38{
39public:
40 CXTPTabColorSetOffice2013();
41
49 virtual void RefreshMetrics();
50
57 virtual void SetTextColor(CDC* pDC, CXTPTabManagerItem* pItem);
58
72 virtual COLORREF GetItemColor(CXTPTabManagerItem* pItem);
73
81 virtual COLORREF GetClientColor(CXTPTabManager* pTabManager);
82
98 virtual COLORREF FillPropertyButton(CDC* pDC, CRect rcItem, CXTPTabManagerItem* pItem);
99
116 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
117
118protected:
119 void FillNavigateButtonEx(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc,
120 CXTPPaintManagerColor clrBack = RGB(255, 0, 0),
121 CXTPPaintManagerColor clrText = RGB(0, 0, 255));
122
123public:
124 CXTPPaintManagerColor m_clrButtonSeparator;
125 CXTPPaintManagerColor m_clrNonActiveButtonSeparator;
126};
127
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
130#endif // !defined(__XTPTABCOLORSETOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabColorSetOffice2013
CXTPTabColorSetOffice2013 implements an Office 2013 tab color set.
Definition XTPTabColorSetOffice2013.h:38
CXTPTabColorSetOffice2013::GetItemColor
virtual COLORREF GetItemColor(CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
CXTPTabColorSetOffice2013::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CXTPTabColorSetOffice2013::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetOffice2013::GetClientColor
virtual COLORREF GetClientColor(CXTPTabManager *pTabManager)
Obtains client background color.
CXTPTabColorSetOffice2013::SetTextColor
virtual void SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem)
Sets the text color for a specified tab.
CXTPTabColorSetOffice2013::FillPropertyButton
virtual COLORREF FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem)
Fills a specified tab button.
CXTPTabColorSetVisualStudio2012
CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set.
Definition XTPTabColorSetVisualStudio2012.h:38
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74


XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS Member List

This is the complete list of members for XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS, including all inherited members.

bSelected | XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
bWorkCell | XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
dtBeginTime | XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
nIndex | XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS
pViewGroup | XTP_CALENDAR_THEME_DAYVIEWCELL_PARAMS


Toolkit Pro: XTPChart3dPieSeriesPointView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
XTPChart3dPieSeriesPointView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIESERIESPOINTVIEW_H__)
24# define __XTPCHART3DPIESERIESPOINTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChart3dPieSeriesView;
34
46class _XTP_EXT_CLASS CXTPChart3dPieSeriesPointView
47 : public CXTPChartPieSeriesPointViewBase
48 , private CXTPChart3dPieDeviceCommandEvents
49{
50 DECLARE_DYNAMIC(CXTPChart3dPieSeriesPointView);
51
52public:
60 CXTPChart3dPieSeriesPointView(CXTPChartSeriesPoint* pPoint, CXTPChartElementView* pParentView);
61
66 virtual ~CXTPChart3dPieSeriesPointView();
67
68public:
75 virtual void CalculateLayout(double& dAngle);
76
87 const CXTPPoint3d& GetCenterShapeConnectorPoint() const;
88
99 const CXTPPoint3d& GetOuterCenterConnectorPoint() const;
100
101protected:
114 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
115
126 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
127 CRect rcBounds);
128
129protected:
137 virtual void OnUpdateBounds(CXTPChartDeviceCommand* pCommand, CRect rcBounds);
138
147 virtual void OnSetConnectorPoints(CXTPChartDeviceCommand* pCommand, CXTPPoint3d ptShapeCenter,
148 CXTPPoint3d ptOuterCenter);
149
150private:
151 CXTPChartPieSeriesPointViewBase* m_p2dSeriesPointView;
152 CXTPPoint3d m_ptShapeCenter;
153 CXTPPoint3d m_ptOuterCenter;
154 CXTPSubscriptionList<CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents>*
155 m_pCommandSubscriptionList;
156 BOOL m_bStartGap;
157 BOOL m_bEndGap;
158
159 friend class CXTPChart3dPieSeriesView;
160};
161
162AFX_INLINE const CXTPPoint3d& CXTPChart3dPieSeriesPointView::GetCenterShapeConnectorPoint() const
163{
164 return m_ptShapeCenter;
165}
166
167AFX_INLINE const CXTPPoint3d& CXTPChart3dPieSeriesPointView::GetOuterCenterConnectorPoint() const
168{
169 return m_ptOuterCenter;
170}
172# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
173#endif //#if !defined(__XTPCHART3DPIESERIESPOINTVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPieDeviceCommandEvents
Defines interface for 3D chart pie device command event sink.
Definition XTPChart3dPieDeviceCommandEvents.h:40
CXTPChart3dPieSeriesPointView
This class abstracts the view of a pie series point.
Definition XTPChart3dPieSeriesPointView.h:49
CXTPChart3dPieSeriesPointView::GetOuterCenterConnectorPoint
const CXTPPoint3d & GetOuterCenterConnectorPoint() const
Obtains the outer shape center connector point.
Definition XTPChart3dPieSeriesPointView.h:167
CXTPChart3dPieSeriesPointView::CalculateLayout
virtual void CalculateLayout(double &dAngle)
Use this function to calculate the layout of the pie series point.
CXTPChart3dPieSeriesPointView::OnSetConnectorPoints
virtual void OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter)
Gets called when pie connector points are computed.
CXTPChart3dPieSeriesPointView::GetCenterShapeConnectorPoint
const CXTPPoint3d & GetCenterShapeConnectorPoint() const
Obtains the shape center connector point.
Definition XTPChart3dPieSeriesPointView.h:162
CXTPChart3dPieSeriesPointView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChart3dPieSeriesPointView::~CXTPChart3dPieSeriesPointView
virtual ~CXTPChart3dPieSeriesPointView()
Handles view destruction.
CXTPChart3dPieSeriesPointView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChart3dPieSeriesPointView::OnUpdateBounds
virtual void OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds)
Notifies about updated boundaries of the command result.
CXTPChart3dPieSeriesPointView::CXTPChart3dPieSeriesPointView
CXTPChart3dPieSeriesPointView(CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Constructs a CXTPChart3dPieSeriesPointView object.
CXTPChart3dPieSeriesView
This class abstracts the view of a pie series.
Definition XTPChart3dPieSeriesView.h:45
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesPointViewBase
This class abstracts the view of a pie series point.
Definition XTPChartPieSeriesPointViewBase.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPPoint3T< double >
CXTPSubscriptionList
Holds a list of observable objects to which an oberser is subscribed.
Definition XTPSystemHelpers.h:2090


CXTPChartPointSeriesStyle Member List

This is the complete list of members for CXTPChartPointSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartPointSeriesStyle | protectedvirtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPointSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


CXTPDockingPaneColorSet2013 Member List

This is the complete list of members for CXTPDockingPaneColorSet2013, including all inherited members.

GetButtonColorSet(CXTPDockingPaneCaptionButton *pButton) | CXTPDockingPaneColorSet | virtual
m_clrBackground | CXTPDockingPaneColorSet |
m_clrBorder | CXTPDockingPaneColorSet |
m_clrCaption | CXTPDockingPaneColorSet |
m_clrGripper | CXTPDockingPaneColorSet |
m_clrSplitter | CXTPDockingPaneColorSet |
m_clrText | CXTPDockingPaneColorSet |
m_csCaptionButtonHot | CXTPDockingPaneColorSet | protected
m_csCaptionButtonNormal | CXTPDockingPaneColorSet | protected
m_csCaptionButtonPressed | CXTPDockingPaneColorSet | protected
RefreshMetrics(CString strSection) | CXTPDockingPaneColorSet2013 | virtual
~CXTPDockingPaneColorSet() | CXTPDockingPaneColorSet | virtual


CXTPMarqueeCtrlThemeOffice2000 Member List

This is the complete list of members for CXTPMarqueeCtrlThemeOffice2000, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2000 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


Toolkit Pro: XTPWinApp.h Source File

  • Source
  • Common
  • Base
XTPWinApp.h
Go to the documentation of this file.
1
23#if !defined(__XTPWINAPP_H__)
24# define __XTPWINAPP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifndef _XTP_ACTIVEX
34# if defined(_XTP_USE_WINAPPEX) && (_MFC_VER >= 0x0900)
35# define CWinAppBase CWinAppEx
36# else
37# define CWinAppBase CWinApp
38# endif
39# else
40# define CWinAppBase COleControlModule
41# endif
42
53class _XTP_EXT_CLASS CXTPWinApp : public CWinAppBase
54{
55 DECLARE_DYNAMIC(CXTPWinApp);
56
57public:
58# ifndef _XTP_USE_WINAPPEX
59
72 CXTPWinApp(int xtpComInit = xtpComInitAppDefault);
73
74# else
75
92 CXTPWinApp();
93
108 CXTPWinApp(BOOL bResourceSmartUpdate, int xtpComInit);
109
110# endif
111
116 virtual ~CXTPWinApp();
117
119 //{{AFX_VIRTUAL(CXTPWinApp)
120 virtual BOOL InitInstance();
121 virtual int ExitInstance();
122 //}}AFX_VIRTUAL
125protected:
127 //{{AFX_MSG(CXTPWinApp)
128 //}}AFX_MSG
129 DECLARE_MESSAGE_MAP()
131private:
132 BOOL m_bXtpInitialized;
133 BOOL m_bXtpUninitialized;
134};
135
137
138//{{AFX_INSERT_LOCATION}}
139// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
140
141# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
143#endif // !defined(__XTPWINAPP_H__)
XTPDisableNoisyWarnings.h
xtpComInitAppDefault
@ xtpComInitAppDefault
If passed to CXTPWinApp constructor or to XTPInitialize then uses xtpComInitAfxOle,...
Definition XTPSystemHelpers.h:1954
CXTPWinApp
All XTP application classes have to derive from CXTPWinApp instead of CWinApp or CWinAppEx.
Definition XTPWinApp.h:54
CXTPWinApp::CXTPWinApp
CXTPWinApp(int xtpComInit=xtpComInitAppDefault)
Constructs CXTPWinApp object.
CXTPWinApp::~CXTPWinApp
virtual ~CXTPWinApp()
Default destructor, handles cleanup / deallocation.


Toolkit Pro: XTPCalendarMAPIDataProvider.h Source File

  • Source
  • Calendar
XTPCalendarMAPIDataProvider.h
Go to the documentation of this file.
1
22#ifndef _XTP_INCLUDE_CALENDAR_MAPI
23# error Use _XTP_INCLUDE_CALENDAR_MAPI to enable Calendar MAPI support.
24#else
25
26# if !defined(_XTPCalendarMAPIDataProvider_H__)
27# define _XTPCalendarMAPIDataProvider_H__
28
29# if _MSC_VER > 1000
30# pragma once
31# endif // _MSC_VER > 1000
32
33# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
34
35class CXTPCalendarRecurrencePattern;
36class CXTPCalendarEventLabels;
37class CXTPNotifyConnection;
38
39// Common customizable properties
40// DP props collection
41static const LPCTSTR cszMAPIpropName_AppointmentMessageClass = _T("AppointmentMessageClass");
42static const LPCTSTR cszMAPIpropVal_AppointmentMessageClass = _T("IPM.Appointment");
43
44static const LPCTSTR cszMAPIpropName_OutlookInternalVersion = _T("OutlookInternalVersion");
45static const int cnMAPIpropVal_OutlookInternalVersionDef = 115608;
46
47static const LPCTSTR cszMAPIpropName_OutlookVersion = _T("OutlookVersion");
48static const LPCTSTR cszMAPIpropVal_OutlookVersionDef = _T("11");
49
50// event runtime custom properties
51static const LPCTSTR cszMAPIpropVal_EntryID = _T("MAPIEntryID");
52static const LPCTSTR cszMAPIpropVal_SearchKey = _T("MAPISearchKey");
53
54// event customizable properties
55// Event props collection
56
57// static const LPCTSTR cszMAPIpropName_AppointmentIconIndex = _T("AppointmentIconIndex");
58static const int cnMAPIpropVal_AppointmentIcon = 1024;
59static const int cnMAPIpropVal_AppointmentIconRecurr = 1025;
60
62static const LPCTSTR cszMAPIProfileName = _T("mapiProfileName");
63static const LPCTSTR cszMAPIPassword = _T("mapiPassword");
64static const LPCTSTR cszMAPIFlags = _T("mapiFlags");
65
70struct XTP_MAPI_PROP_NAME
71{
72 ULONG m_ulID;
73 ULONG m_ulType;
74 GUID m_GuidPS;
79 XTP_MAPI_PROP_NAME(ULONG ulID, ULONG ulType, const GUID& guidPS)
80 {
81 m_ulID = ulID;
82 m_ulType = ulType;
83 m_GuidPS = guidPS;
84 }
85};
86
94# define XTP_TAG_ID_MAPI_CALENDAR_FOLDER \
95 0x36D00102
98//#define XTP_PS_MAPI_EVENT Guid( "0x0220060000000000C000000000000046")
100// GUID of the class of appointment item extended properties
101
102//#define XTP_PS_MAPI_COMMON Guid( "0x0820060000000000C000000000000046")
104// GUID of the class of common Outlook extended properties
105
106//#define XTP_PS_MAPI_AGGREGATE_GUID "{00020329-0000-0000-C000-000000000046}" //
107// First introduced to support 'keywords' on calendar items
108
110static const GUID xtpGUID_PS_MAPI_Event = { 0x00062002,
111 0x0000,
112 0x0000,
113 { 0xC0, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x46 } };
115static const GUID xtpGUID_PS_MAPI_Common = { 0x00062008,
116 0x0000,
117 0x0000,
118 { 0xC0, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x46 } };
119
120// Event icon index
121# define XTP_PR_MAPI_EVENT_ICON_INDEX PROP_TAG(PT_LONG, 0x1080)
122
125static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_BusyStatus(0x8205, PT_LONG, xtpGUID_PS_MAPI_Event);
126
128static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_Location(0x8208, PT_STRING8,
129 xtpGUID_PS_MAPI_Event);
130
132static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_StartTime(0x820D, PT_SYSTIME,
133 xtpGUID_PS_MAPI_Event);
134
136static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_EndTime(0x820E, PT_SYSTIME, xtpGUID_PS_MAPI_Event);
137
139static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_Duration(0x8213, PT_LONG, xtpGUID_PS_MAPI_Event);
140
142static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_Color(0x8214, PT_LONG, xtpGUID_PS_MAPI_Event);
143
145static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_AllDay(0x8215, PT_BOOLEAN, xtpGUID_PS_MAPI_Event);
146
147//**/ PT_LONG - Meeting status enumeration*/
148static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_MeetingStatus(0x8217, PT_LONG,
149 xtpGUID_PS_MAPI_Event);
150
152static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_RecurrenceState(0x8216, PT_BINARY,
153 xtpGUID_PS_MAPI_Event);
154
156static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_IsRecuring(0x8223, PT_BOOLEAN,
157 xtpGUID_PS_MAPI_Event);
158
159// PT_SYSTIME - Recurrence base time
160// static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_RecurrenceBase(0x8228, PT_SYSTIME,
161// xtpGUID_PS_MAPI_Event);
162
163// PT_LONG - Recurrence type. See also XTPCalendarEventRecurrenceType - note that enum values are
164// the same as Outlook values
165// static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_RecurrenceType(0x8231, PT_LONG,
166// xtpGUID_PS_MAPI_Event);
167
168// PT_TSTRING
169// static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_RecurrencePattern(0x8232, PT_STRING8,
170// xtpGUID_PS_MAPI_Event);
171
173static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_TimeZone(0x8233, PT_BINARY, xtpGUID_PS_MAPI_Event);
174
175//#define XTP_PRID_MAPI_EVENT_TIMEZONE_DESCRIPTION 0x8234 // PT_TSTRING
176// static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_TimeZoneDescription(0x8234, PT_STRING8,
177// xtpGUID_PS_MAPI_Event);
178
179//#define XTP_PRID_MAPI_EVENT_RECURRENCE_START 0x8235 // PT_SYSTIME
180static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_RecurrenceStart(0x8235, PT_SYSTIME,
181 xtpGUID_PS_MAPI_Event);
182
183//#define XTP_PRID_MAPI_EVENT_RECURRENCE_END 0x8236 // PT_SYSTIME
184static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_RecurrenceEnd(0x8236, PT_SYSTIME,
185 xtpGUID_PS_MAPI_Event);
186
187//#define XTP_PRID_MAPI_EVENT_RESPONSE_STATUS 0x8218 // PT_TSTRING
188// static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_(0x8218, PT_STRING8, xtpGUID_PS_MAPI_Event);
189
190//#define XTP_PRID_MAPI_EVENT_REPLY_TIME 0x8222 // PT_TSTRING
191// static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_(, , xtpGUID_PS_MAPI_Event);
192//#define XTP_PRID_MAPI_EVENT_ORGANIZER 0x822E // PT_TSTRING
193// static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_(, , xtpGUID_PS_MAPI_Event);
194
196static const XTP_MAPI_PROP_NAME xtpMAPIpropCommon_OutlookInternalVersion(0x8552, PT_LONG,
197 xtpGUID_PS_MAPI_Common);
198
200static const XTP_MAPI_PROP_NAME xtpMAPIpropCommon_OutlookVersion(0x8554, PT_STRING8,
201 xtpGUID_PS_MAPI_Common);
202
204static const XTP_MAPI_PROP_NAME xtpMAPIpropCommon_ReminderMinutesBefore(0x8501, PT_LONG,
205 xtpGUID_PS_MAPI_Common);
206
208static const XTP_MAPI_PROP_NAME xtpMAPIpropCommon_ReminderDate(0x8502, PT_SYSTIME,
209 xtpGUID_PS_MAPI_Common);
210
212static const XTP_MAPI_PROP_NAME xtpMAPIpropCommon_ReminderSet(0x8503, PT_BOOLEAN,
213 xtpGUID_PS_MAPI_Common);
214
216static const XTP_MAPI_PROP_NAME xtpMAPIpropCommon_IsPrivate(0x8506, PT_BOOLEAN,
217 xtpGUID_PS_MAPI_Common);
218
219//#define XTP_PRID_MAPI_COMMON_CONTEXT_MENU_FLAGS 0x8510 // PT_LONG
220// static const XTP_MAPI_PROP_NAME xtpMAPIpropCommon_(0x8510, PT_LONG, xtpGUID_PS_MAPI_Common);
221
223static const XTP_MAPI_PROP_NAME xtpMAPIpropEvent_CustomProperties(0x8581, PT_STRING8,
224 xtpGUID_PS_MAPI_Event);
225
227
232enum XTPCalendarMAPIRcType
233{
234 xtpMAPIRcType_Unknown = 0,
236 xtpMAPIRcType_Daily = 0x200A,
237 xtpMAPIRcType_Weekly = 0x200B,
238 xtpMAPIRcType_Monthly = 0x200C,
239 xtpMAPIRcType_Yearly = 0x200D,
240};
241
246enum XTPCalendarMAPIRcType2
247{
248 // xtpMAPIRcType_Unknown = -1,
249
250 xtpMAPIRcType2_First = 0,
252 xtpMAPIRcType2_Daily = 0,
253 xtpMAPIRcType2_Weekly = 1,
254 xtpMAPIRcType2_MonYearly = 2,
255 xtpMAPIRcType2_MonYearly_Nth = 3,
257 xtpMAPIRcType2_Last = 3,
258};
259
264enum XTPCalendarMAPIRcEnd
265{
266 xtpMAPIRcEnd_Date = 0x2021,
267 xtpMAPIRcEnd_Number = 0x2022,
268 xtpMAPIRcEnd_Never = 0x2023
269};
270
276enum XTPCalendarMAPIRcExceptionData
277{
278 xtpMAPIRcED_Subject = 0x001,
279 xtpMAPIRcED_IsMeeting = 0x002,
280 xtpMAPIRcED_ReminderTime = 0x004,
281 xtpMAPIRcED_IsReminder = 0x008,
282 xtpMAPIRcED_Location = 0x010,
283 xtpMAPIRcED_BusyStatus = 0x020,
284 xtpMAPIRcED_Reserved = 0x040,
285 xtpMAPIRcED_IsAllDay = 0x080,
286 xtpMAPIRcED_Label = 0x100,
287};
288
294struct XTP_MAPI_TIME_ZONE_INFORMATION
295{
296 LONG Bias;
297 LONG StandardBias;
299 LONG DaylightBias;
301 WORD Reserved1;
302 SYSTEMTIME StandardDate;
305 WORD Reserved2;
306 SYSTEMTIME DaylightDate;
309};
310
316class _XTP_EXT_CLASS CXTPMAPIBinary
317{
318public:
320 CXTPMAPIBinary();
322 CXTPMAPIBinary(ULONG cbEntryID, LPENTRYID lpEntryID);
324 CXTPMAPIBinary(const CXTPMAPIBinary& eid);
326 virtual ~CXTPMAPIBinary();
327
330 CXTPMAPIBinary& operator=(const CXTPMAPIBinary& eid);
331
333 ULONG GetBinarySize() const;
335 LPBYTE GetBinaryData() const;
336
338 void Set(ULONG cbSize, LPBYTE lpData);
340 void Set(LPSPropValue pPropEntryID);
341
343 static BOOL AFX_CDECL IsBinaryEqual(const CXTPMAPIBinary& eid1, const CXTPMAPIBinary& eid2);
344
345# ifdef _DEBUG
346 void DebugPrint();
347# endif
348
349 // private:
350 ULONG m_cb;
351 CByteArray m_arBytes;
353private:
354 friend class CXTPCalendarMAPIDataProvider;
355 friend class CXTP_ID_Collection;
356};
357
359typedef CMap<DWORD, DWORD, CXTPMAPIBinary, CXTPMAPIBinary&> CMap_EventID_EntryIDIndex;
361typedef CMap<CXTPMAPIBinary, CXTPMAPIBinary&, DWORD, DWORD> CMap_EntryIDIndex_EventID;
363typedef CMap<DWORD, DWORD, BOOL, BOOL> CMap_EventIDs;
364
366template<>
367AFX_INLINE UINT AFXAPI HashKey(CXTPMAPIBinary& key)
368{
369 UINT nRes = 0;
370 for (UINT i = 0; (i < 4) && (key.m_cb > i); i++)
371 {
372 nRes *= 256;
373 nRes += key.m_arBytes.GetAt(static_cast<INT_PTR>(i));
374 }
375 return nRes;
376}
377
379template<>
380AFX_INLINE BOOL AFXAPI CompareElements(const CXTPMAPIBinary* lpt1, const CXTPMAPIBinary* lpt2)
381{
382 return CXTPMAPIBinary::IsBinaryEqual(*lpt1, *lpt2);
383}
384
391class _XTP_EXT_CLASS CXTP_ID_Collection
392{
393public:
395 CXTP_ID_Collection();
396
398 BOOL Lookup(const DWORD dwEventID, CXTPMAPIBinary& obEntryID);
400 BOOL Lookup(CXTPMAPIBinary& obEntryID, DWORD& dwEventID);
401
403 BOOL Add(const DWORD dwEventID, CXTPMAPIBinary& obEntryID);
404
406 void FindMissing(CMap_EventIDs& mapExisting, CMap_EventIDs& mapMissed);
407
408protected:
409 CMap_EventID_EntryIDIndex m_mapEventID;
410 CMap_EntryIDIndex_EventID m_mapEntryID;
411};
412
444class _XTP_EXT_CLASS CXTPCalendarMAPIDataProvider
445 : public CXTPCalendarData
446 , public CXTPCalendarMAPIWrapper
447{
448 DECLARE_DYNAMIC(CXTPCalendarMAPIDataProvider)
449
450public:
462 CXTPCalendarMAPIDataProvider();
463
471 virtual ~CXTPCalendarMAPIDataProvider();
472
487 virtual BOOL Open();
488
498 virtual BOOL Create();
499
506 virtual BOOL Save();
507
516 virtual void Close();
517
526 virtual BOOL IsOpen() const;
527
528protected:
541 virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay);
542
550 virtual void DoRemoveAllEvents();
551
564 virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID);
565
578 virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID);
579
595 virtual BOOL DoCreate_Event(CXTPCalendarEvent* pEvent, DWORD& rdwNewEventID);
596
611 virtual BOOL DoUpdate_Event(CXTPCalendarEvent* pEvent);
612
627 virtual BOOL DoDelete_Event(CXTPCalendarEvent* pEvent);
628
643 virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern* pPattern, DWORD& rdwNewPatternID);
644
657 virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern* pPattern);
658
671 virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern* pPattern);
672
691 virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom,
692 COleDateTimeSpan spPeriod);
693
711 virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
712
713protected:
727 virtual void GetMAPILogonParams(LPTSTR& rpszProfile, LPTSTR& rpszPassword, FLAGS& ruFlags);
728
741 static BOOL AFX_CDECL GetParameterValueFromConStr(LPCTSTR lpszConnectionString,
742 LPCTSTR pcszParameterName,
743 CString& rstrValue);
744
760 virtual BOOL OnTimeZoneChanged();
761
762protected:
763 // Connection string items (for the next version)
764 // CString m_strProfileName; // Name of the MAPI profile
765 // CString m_strUsername; // Login name to this profile
766 // CString m_strPassword; // User's password for login to the profile.
767 // CString m_strMsgStoreGuid;// Message store
768 // CString m_strFolderGUID; // Folder with appointment items
769 // BOOL m_bShowFolderChooser;// Whether to choose a folder using a buit-in dialog.
770
771 // private:
772 CXTP_ID_Collection m_mapID;
777 BOOL Equal(const CXTPMAPIBinary& eid1, const CXTPMAPIBinary& eid2);
778
779 // private:
781 CXTPMAPIBinary GetSearchKey(ULONG cbEntryID, LPENTRYID lpEntryID);
782
785 DWORD GetEventID(ULONG cbSearchKey, LPENTRYID lpSearchKey, BOOL bAddNew = FALSE);
786
788 CXTPMAPIBinary GetEntryID(CXTPMAPIBinary& eSearchKey);
789
791 DWORD GetNextUniqueEventID(DWORD dwEventID = XTP_CALENDAR_UNKNOWN_EVENT_ID);
792
793 // private:
795 static STDMETHODIMP OpenDefaultMessageStore(LPMAPISESSION lpMAPISession, LPMDB* lpMDB,
796 CXTPCalendarMAPIDataProvider* pProvider);
797
799 static STDMETHODIMP OpenInbox(LPMDB lpMDB, LPMAPIFOLDER* lpInboxFolder,
800 LPMAPIFOLDER* lpCalendarFolder,
801 CXTPCalendarMAPIDataProvider* pProvider);
802
804 static LPSRestriction AFX_CDECL BuildBinaryRestriction(ULONG cbSize, LPBYTE lpData,
805 ULONG ulPropTag);
806
808 CXTPCalendarEventsPtr ImportAllEvents(LPSRestriction lpRestriction = NULL);
809
820 BOOL ImportNewEvents();
821
823 CXTPCalendarEventPtr ImportEvent(LPSRow lpRow);
825 CXTPCalendarEventPtr ImportEvent(ULONG cbEntryID, LPENTRYID lpEntryID);
827 CXTPCalendarEventPtr ImportEvent(LPMESSAGE pMessage);
828
829 CXTPCalendarEventPtr ImportEvent_FromCalendarFolderOnly(ULONG cbEntryID, LPENTRYID lpEntryID);
830
833 void ImportRecurrence(CXTPCalendarEvent* pMasterEvent, const CByteArray& arRCData);
834
836 BOOL UpdateMAPIEvent(LPMESSAGE pMessage, CXTPCalendarEvent* pEvent);
838 void _SetMAPIEventGlobalPropsIfNeed(LPMESSAGE pMessage, CXTPCalendarEvent* pEvent);
839
840 void _SetEventRuntimeProps(CXTPCalendarCustomProperties* pEventProps, LPMESSAGE pMessage);
841 void _MoveMAPIEventRuntimeProps(CXTPCalendarCustomProperties* pDest,
842 CXTPCalendarCustomProperties* pSrc);
843
844 HRESULT _getPropVal(LPMESSAGE pMessage, ULONG ulPropTag, CByteArray& rData);
845
846 CString _getPropVal_str(LPMESSAGE pMessage, ULONG ulPropTag);
847 int _getPropVal_int(LPMESSAGE pMessage, ULONG ulPropTag);
848 SYSTEMTIME _getPropVal_UtcTime(LPMESSAGE pMessage, ULONG ulPropTag);
849
850 CString _getPropVal_str(LPMESSAGE pMessage, const XTP_MAPI_PROP_NAME& propNameEx);
851 int _getPropVal_int(LPMESSAGE pMessage, const XTP_MAPI_PROP_NAME& propNameEx);
852 SYSTEMTIME _getPropVal_UtcTime(LPMESSAGE pMessage, const XTP_MAPI_PROP_NAME& propNameEx);
853
854 BOOL _setPropTagVal_int(LPMESSAGE pMessage, ULONG ulPropTag, int nValue);
855 BOOL _setPropTagVal_str(LPMESSAGE pMessage, ULONG ulPropTag, LPCTSTR pcszValue);
856 BOOL _setPropTagVal_UtcTime(LPMESSAGE pMessage, ULONG ulPropTag, const SYSTEMTIME& stTime);
857 BOOL _setPropTagVal_bin(LPMESSAGE pMessage, ULONG ulPropTag, const CByteArray& arData);
858
859 HRESULT _deletePropTag(LPMESSAGE pMessage, ULONG ulPropTag);
860 HRESULT _deletePropsTags(LPMESSAGE pMessage, CUIntArray& arPropsTags);
861
862 int GetEventGlobalPropVal_int(LPCTSTR pcszPropName, int nDefault);
863 CString GetEventGlobalPropVal_str(LPCTSTR pcszPropName, LPCTSTR pcszDefault);
864
865 static int AFX_CDECL _getSimpleMAPITypeSize(int nType);
866 static UINT AFX_CDECL _getStreamSize(IStream* pStream);
867
868 static LONG STDAPICALLTYPE MAPICallBack_OnNotify(LPVOID lpvContext, ULONG cNotif,
869 LPNOTIFICATION lpNotif);
870
873 class CMAPIPropIDMap
874 {
875 public:
876 CMAPIPropIDMap();
877
878 ULONG GetPropTagByID(LPMESSAGE pMessage, const XTP_MAPI_PROP_NAME& propNameEx);
879
880 ULONG GetPropIDByTag(LPMESSAGE pMessage, ULONG ulPropTag);
881
882 protected:
883 typedef CMap<ULONG, ULONG, ULONG, ULONG> CMapULONG;
884
886 void _UpdateMaps(LPMESSAGE pMessage);
887
889 ULONG _GetPropTagFromID_ex(LPMESSAGE pMessage, const XTP_MAPI_PROP_NAME& propNameEx);
890
891 CMapULONG m_mapPropID2Tag;
892 CMapULONG m_mapPropTag2ID;
894 // private:
895 CXTPCalendarMAPIDataProvider* m_pProvider;
897 friend class CXTPCalendarMAPIDataProvider;
898 };
899
900 CMAPIPropIDMap m_MapiHelper;
902 // private:
903 BOOL m_bMAPIInitialized;
905 LPMAPISESSION m_lpMAPISession;
906 LPMDB m_lpMDB;
908 LPMAPIFOLDER m_lpCalendarFolder;
909 CXTPMAPIBinary m_eidCalendarFolder;
911 ULONG m_ulMAPIConID0;
912 ULONG m_ulMAPIConID1;
913
914 LPMAPIADVISESINK m_lpAdviseSink;
915 LPMAPIADVISESINK m_lpAdviseSink_ThrSafe;
916
917 CXTPCalendarData* m_pMemDP;
918
919private:
920 CString m_strProfile_tmp;
921 CString m_strPassword_tmp;
922
923protected:
924 friend class CXTPCalendarMemDPInternal;
925 friend class CMAPIPropIDMap;
926 using CXTPCalendarData::SendNotification;
927
933 class CXTPCalendarMemDPInternal : public CXTPCalendarMemoryDataProvider
934 {
935 CXTPCalendarData* m_pDPExternal;
936 public:
944 CXTPCalendarMemDPInternal(CXTPCalendarData* pDPExternal);
945
956 virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam);
957 };
958};
959
961
962# endif // !defined(_XTPCalendarMAPIDataProvider_H__)
963
964# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
965#endif
XTP_CALENDAR_UNKNOWN_EVENT_ID
#define XTP_CALENDAR_UNKNOWN_EVENT_ID
Define unknown event ID.
Definition XTPCalendarDefines.h:107
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCustomProperties
This class is used to store properties collection.
Definition XTPCalendarCustomProperties.h:44
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarData::SendNotification
virtual void SendNotification(XTP_NOTIFY_CODE EventCode, WPARAM wParam, LPARAM lParam)
Sends a notification to all listeners.
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEventLabels
This class is used as a collection of CXTPCalendarEventLabel objects.
Definition XTPCalendarEventLabel.h:120
CXTPCalendarMemoryDataProvider
This class implements an abstract representation of the data used in the XTPCalendarData class.
Definition XTPCalendarMemoryDataProvider.h:73
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88


CXTPChart3dPyramidSeriesStyle Member List

This is the complete list of members for CXTPChart3dPyramidSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChart3dPyramidSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChart3dPyramidSeriesStyle | virtual
CXTPChart3dPyramidSeriesStyle() | CXTPChart3dPyramidSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPyramidSeriesStyleBase() | CXTPChartPyramidSeriesStyleBase |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChart3dPyramidSeriesStyle | virtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetBaseEdgeCount() const | CXTPChart3dPyramidSeriesStyle |
GetBorder() const | CXTPChartPyramidSeriesStyleBase |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetFillStyle() const | CXTPChartPyramidSeriesStyleBase |
GetHeightToWidthRatio() const | CXTPChartPyramidSeriesStyleBase |
GetLabel() const | CXTPChartSeriesStyle | virtual
GetOwner() const | CXTPChartElement |
GetPointDistance() const | CXTPChartPyramidSeriesStyleBase |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChart3dPyramidSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetBaseEdgeCount(int nEdgeCount) | CXTPChart3dPyramidSeriesStyle |
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetHeightToWidthRatio(double dRatio) | CXTPChartPyramidSeriesStyleBase |
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetPointDistance(int nPointDistance) | CXTPChartPyramidSeriesStyleBase |
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartPyramidSeriesStyleBase() | CXTPChartPyramidSeriesStyleBase | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


CXTPSearchOptionsCtrl Member List

This is the complete list of members for CXTPSearchOptionsCtrl, including all inherited members.

AddControl(CWnd *pWndCtrl) | CXTPSearchOptionsCtrl |
Contract() | CXTPSearchOptionsCtrl |
CXTPSearchOptionsCtrl() | CXTPSearchOptionsCtrl |
Expand() | CXTPSearchOptionsCtrl |
GetMaxSize() | CXTPSearchOptionsCtrl |
GetMinSize() | CXTPSearchOptionsCtrl |
GetOffsetSize() | CXTPSearchOptionsCtrl |
Init() | CXTPSearchOptionsCtrl | protectedvirtual
IsExpanded() const | CXTPSearchOptionsCtrl |
m_arHideCtrls | CXTPSearchOptionsCtrl | protected
m_arMoveCtrls | CXTPSearchOptionsCtrl | protected
m_bExpanded | CXTPSearchOptionsCtrl | protected
m_bPreSubclassInit | CXTPSearchOptionsCtrl | protected
m_iMaxSize | CXTPSearchOptionsCtrl | protected
m_iMinSize | CXTPSearchOptionsCtrl | protected
m_rcLabel | CXTPSearchOptionsCtrl | protected
m_strContractLabel | CXTPSearchOptionsCtrl | protected
m_strExpandLabel | CXTPSearchOptionsCtrl | protected
MoveControl(CWnd *pWndCtrl) | CXTPSearchOptionsCtrl |
SetLabelText(LPCTSTR lpszExpand, LPCTSTR lpszContract) | CXTPSearchOptionsCtrl |
~CXTPSearchOptionsCtrl() | CXTPSearchOptionsCtrl | virtual


Toolkit Pro: XTPDockingPanePanelTheme2015.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelTheme2015.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEME2015_H__)
24# define __XTPDOCKINGPANEPANELTHEME2015_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelTheme2015 : public CXTPDockingPanePanelTheme2012
39{
40public:
45 CXTPDockingPanePanelTheme2015();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPDOCKINGPANEPANELTHEME2015_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelTheme2015
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2015.h:39
CXTPDockingPanePanelTheme2015::CXTPDockingPanePanelTheme2015
CXTPDockingPanePanelTheme2015()
Default class constructor.


CXTPScrollableEditT< EditBase > Member List

This is the complete list of members for CXTPScrollableEditT< EditBase >, including all inherited members.

Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL) | CXTPScrollable< EditBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL) | CXTPScrollable< EditBase > | virtual
CreateEx(DWORD dwExStyle, LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL) | CXTPScrollable< EditBase > | virtual
CXTPScrollable() | CXTPScrollable< EditBase > |
CXTPScrollableEditT() | CXTPScrollableEditT< EditBase > |
EnableDefaultBorderDrawing(BOOL bEnable=TRUE) | CXTPScrollable< EditBase > |
InitScrollBars() | CXTPScrollable< EditBase > |
SetScrollBarTheme(XTPScrollBarTheme nTheme) | CXTPScrollable< EditBase > |
~IXTPScrollable() | IXTPScrollable | inlinevirtual


CXTPDatePickerItemDay Member List

This is the complete list of members for CXTPDatePickerItemDay, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerItemDay(CXTPDatePickerControl *pControl, CXTPDatePickerItemMonth *pMonth, COleDateTime dtDay) | CXTPDatePickerItemDay |
Draw(CDC *pDC) | CXTPDatePickerItemDay | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetDate() const | CXTPDatePickerItemDay |
GetDatePickerControl() const | CXTPDatePickerItemDay |
GetMonth() const | CXTPDatePickerItemDay |
GetRect() const | CXTPDatePickerItemDay |
IsToday(COleDateTime &dt) const | CXTPDatePickerItemDay |
IsVisible() const | CXTPDatePickerItemDay |
m_bVisible | CXTPDatePickerItemDay | protected
m_dtDay | CXTPDatePickerItemDay | protected
m_pControl | CXTPDatePickerItemDay | protected
m_pMonth | CXTPDatePickerItemDay | protected
m_rcDay | CXTPDatePickerItemDay | protected
SetRect(const CRect &rcDay) | CXTPDatePickerItemDay |
~CXTPDatePickerItemDay() | CXTPDatePickerItemDay | virtual


Toolkit Pro: XTPSyntaxEditColorComboBox.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditColorComboBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITCOLORCOMBOBOX_H__)
24# define __XTPSYNTAXEDITCOLORCOMBOBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSyntaxEditColorComboBox : public CComboBox
39{
41 DECLARE_DYNAMIC(CXTPSyntaxEditColorComboBox)
43public:
48 CXTPSyntaxEditColorComboBox();
49
54 virtual ~CXTPSyntaxEditColorComboBox();
55
56public:
63 COLORREF GetSelColor();
64
72 int SetSelColor(COLORREF crColor);
73
81 int DeleteColor(COLORREF crColor);
82
90 int FindColor(COLORREF crColor);
91
100 int SetUserColor(COLORREF crColor, LPCTSTR lpszUserText = NULL);
101
108 COLORREF GetUserColor() const;
109
118 int SetAutoColor(COLORREF crColor, LPCTSTR lpszAutoText = NULL);
119
126 COLORREF GetAutoColor() const;
127
134 int SelectUserColor();
135
142 virtual bool Init();
143
145public:
146 virtual void DrawItem(LPDRAWITEMSTRUCT lpDIS);
147 virtual void MeasureItem(LPMEASUREITEMSTRUCT lpMIS);
148 virtual int CompareItem(LPCOMPAREITEMSTRUCT lpCIS);
149 virtual BOOL PreTranslateMessage(MSG* pMsg);
150
151protected:
152 virtual void PreSubclassWindow();
153 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
156protected:
165 virtual int AddColor(COLORREF crColor, UINT nID);
166
175 virtual void NotifyOwner(UINT nCode);
176
184 virtual int GetLBCurSel() const;
185
187 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
188 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
189 afx_msg void OnCloseUp();
190
191 DECLARE_MESSAGE_MAP()
194private:
195 int m_iPrevSel;
196 bool m_bPreInit;
197 COLORREF m_crAuto;
198 COLORREF m_crUser;
199};
200
202
203AFX_INLINE COLORREF CXTPSyntaxEditColorComboBox::GetUserColor() const
204{
205 return m_crUser;
206}
207AFX_INLINE COLORREF CXTPSyntaxEditColorComboBox::GetAutoColor() const
208{
209 return m_crAuto;
210}
211
219_XTP_EXT_CLASS void AFXAPI DDX_CBSyntaxColor(CDataExchange* pDX, int nIDC, COLORREF& value);
220
222
223//{{AFX_INSERT_LOCATION}}
224// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
225
226# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
228#endif // !defined(__XTPSYNTAXEDITCOLORCOMBOBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
DDX_CBSyntaxColor
_XTP_EXT_CLASS void AFXAPI DDX_CBSyntaxColor(CDataExchange *pDX, int nIDC, COLORREF &value)
Exchanges the currently selected color for a CXTPSyntaxEditColorComboBox control.
CXTPSyntaxEditColorComboBox
This class allows for colors to be edited by using a combobox control.
Definition XTPSyntaxEditColorComboBox.h:39
CXTPSyntaxEditColorComboBox::FindColor
int FindColor(COLORREF crColor)
Retrieves the index of a specified color.
CXTPSyntaxEditColorComboBox::CXTPSyntaxEditColorComboBox
CXTPSyntaxEditColorComboBox()
Standard object constructor.
CXTPSyntaxEditColorComboBox::AddColor
virtual int AddColor(COLORREF crColor, UINT nID)
Adds a new color.
CXTPSyntaxEditColorComboBox::SetSelColor
int SetSelColor(COLORREF crColor)
Sets the selected color.
CXTPSyntaxEditColorComboBox::GetAutoColor
COLORREF GetAutoColor() const
Gets the auto color value.
Definition XTPSyntaxEditColorComboBox.h:207
CXTPSyntaxEditColorComboBox::NotifyOwner
virtual void NotifyOwner(UINT nCode)
Sends a WM_COMMAND message to the owner window.
CXTPSyntaxEditColorComboBox::SetAutoColor
int SetAutoColor(COLORREF crColor, LPCTSTR lpszAutoText=NULL)
Sets the auto color value and auto color name.
CXTPSyntaxEditColorComboBox::GetSelColor
COLORREF GetSelColor()
Gets the selected color.
CXTPSyntaxEditColorComboBox::~CXTPSyntaxEditColorComboBox
virtual ~CXTPSyntaxEditColorComboBox()
Standard object destructor.
CXTPSyntaxEditColorComboBox::GetLBCurSel
virtual int GetLBCurSel() const
Gets the index of the currently selected listbox item (works for dropped state only).
CXTPSyntaxEditColorComboBox::DeleteColor
int DeleteColor(COLORREF crColor)
Removes a specified color.
CXTPSyntaxEditColorComboBox::SetUserColor
int SetUserColor(COLORREF crColor, LPCTSTR lpszUserText=NULL)
Sets the user color value and user color name.
CXTPSyntaxEditColorComboBox::Init
virtual bool Init()
Adds the default set of colors.
CXTPSyntaxEditColorComboBox::SelectUserColor
int SelectUserColor()
Selects the user color.


Toolkit Pro: XTPDockingPaneTabbedContainer.h Source File

  • Source
  • DockingPane
XTPDockingPaneTabbedContainer.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABBEDCONTAINER_H__)
24# define __XTPDOCKINGPANETABBEDCONTAINER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPDockingPaneAutoHidePanel;
34class CXTPDockingPaneCaptionButton;
35
42class _XTP_EXT_CLASS CXTPDockingPaneTabbedContainer
43 : public CWnd
44 , public CXTPDockingPaneBaseContainer
45 , public CXTPTabManager
46 , public CXTPAccessible
47{
49 DECLARE_DYNAMIC(CXTPDockingPaneTabbedContainer)
51protected:
58 CXTPDockingPaneTabbedContainer(CXTPDockingPaneLayout* pLayout);
59
65 virtual ~CXTPDockingPaneTabbedContainer();
66
67public:
75 virtual void SelectPane(CXTPDockingPane* pPane, BOOL bSetFocus = TRUE,
76 BOOL bDelayRedraw = TRUE);
77
84 BOOL IsActive() const;
85
92 CXTPDockingPane* GetSelected() const;
93
100 CXTPDockingPaneCaptionButton* GetCloseButton() const;
101
108 CXTPDockingPaneCaptionButton* GetPinButton() const;
109
116 BOOL IsTitleVisible() const;
117
124 virtual BOOL IsCaptionVertical() const;
125
132 virtual BOOL IsTabsVisible() const;
133
141 virtual HWND GetPaneHwnd() const;
142
152 BOOL IsHidden() const;
153
162 virtual void OnCaptionLButtonDown(CPoint point);
163
173 virtual BOOL CanAttach(CRect& rcClient, CPoint pt) const;
174
184 void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const;
185
193 CXTPDockingPane* GetItemPane(int nIndex) const;
194
202 CXTPTabManagerItem* GetPaneTab(CXTPDockingPane* pPane) const;
203
211 CString GetTitle() const;
212
213protected:
221 virtual BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton* pButton);
222
229 virtual void OnCaptionButtonClick(CXTPDockingPaneCaptionButton* pButton);
230
237 virtual void OnNavigateButtonClick(CXTPTabManagerNavigateButton* pButton);
238
239protected:
247 void Init(CXTPDockingPane* pPane, CWnd* pFrame);
248
258 virtual void Copy(CXTPDockingPaneBase* pClone, CXTPPaneToPaneMap* pMap, DWORD dwIgnoredOptions);
259
264 virtual void Reposition();
265
273 virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate);
274
283 virtual CXTPTabPaintManager* GetPaintManager() const;
284
291 virtual void SetPaintManager(CXTPTabPaintManager* pPaintManager);
292
306 virtual BOOL DrawIcon(CDC* pDC, CPoint pt, CXTPTabManagerItem* pItem, BOOL bDraw,
307 CSize& szIcon) const;
308
316 virtual BOOL DoPropExchange(CXTPPropExchange* pPX);
317
322 virtual void OnTabsChanged();
323
328 virtual void CreateContainer();
329
330protected:
332 virtual void OnSizeParent(CWnd* pParent, CRect rect, LPVOID lParam);
333 virtual void OnFocusChanged();
334 virtual void SetDockingSite(CWnd* pFrame);
335 virtual void RemovePane(CXTPDockingPaneBase* pPane);
336 virtual void OnParentContainerChanged(CXTPDockingPaneBase* pContainer);
337 void ShowTitle(BOOL bShow);
338 void Show(BOOL bSetFocus);
339 void ShowPane(CXTPDockingPane* pPane, BOOL bSetFocus);
340 void _Swap(CXTPDockingPane* p1, CXTPDockingPane* p2);
341 void _InsertPane(CXTPDockingPane* pPane, BOOL bSetFocus = TRUE);
342 int HitTest(CPoint point) const;
343 void AdjustMinMaxInfoClientRect(LPMINMAXINFO pMinMaxInfo, BOOL bCaptionOnly = FALSE) const;
344
345 void InvalidatePane(BOOL bSelectionChanged);
346 void _RestoreFocus();
347 void EnsureSelectedTabVisible();
348 BOOL OnCaptionButtonDown(CXTPDockingPaneCaptionButton* pButton);
349 CXTPDockingPaneCaptionButton* HitTestCaptionButton(CPoint point) const;
350 void DeletePane();
351 void ClosePane(CXTPDockingPane* pPane);
352
353 BOOL IsPaneRestored() const;
354 BOOL IsAllowMaximize() const;
355 BOOL IsPaneMaximized() const;
356 BOOL IsPaneMinimized() const;
357 void Restore();
358 void Maximize();
359 void NormalizeDockingSize();
362protected:
364 DECLARE_MESSAGE_MAP()
365
366 //{{AFX_VIRTUAL(CXTPDockingPaneTabbedContainer)
367 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
368 LRESULT OnHelpHitTest(WPARAM, LPARAM);
369 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
370 virtual void OnFinalRelease();
371 //}}AFX_VIRTUAL
372
373 //{{AFX_MSG(CXTPDockingPaneTabbedContainer)
374 afx_msg void OnPaint();
375 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
376 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
377 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
378 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
379 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
380 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
381 afx_msg void OnCaptureChanged(CWnd* pWnd);
382 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
383 afx_msg void OnMouseLeave();
384 afx_msg void OnDestroy();
385 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
386 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
387 afx_msg LRESULT OnGetObject(WPARAM wParam, LPARAM lParam);
388 //}}AFX_MSG
391protected:
394 // System accessibility support.
395
396 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
397 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
398 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
399 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
400 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
401 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
402 VARIANT varChild);
403 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
404 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
405 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
406 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
407 virtual CCmdTarget* GetAccessible();
408
409 DECLARE_INTERFACE_MAP()
410 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
413# ifdef _XTP_ACTIVEX
415private:
416 DECLARE_DISPATCH_MAP()
417 DECLARE_OLETYPELIB_EX(CXTPDockingPaneTabbedContainer);
418 DECLARE_ENUM_VARIANT(CXTPDockingPaneTabbedContainer);
419 afx_msg LPDISPATCH OleGetDispatch(BOOL /*bAddRef*/);
420 afx_msg LPDISPATCH OleGetItem(int nIndex);
421 afx_msg int OleGetItemCount();
422 afx_msg LPDISPATCH OleGetContainer();
423 afx_msg int OleGetType();
424 afx_msg LPDISPATCH OleGetPane(int nIndex);
425 afx_msg HWND OleGetHwnd();
426 afx_msg BOOL OleIsEmpty();
427 int OleGetPosition();
429# endif
430
431protected:
432 BOOL m_bActive;
433 BOOL m_bTitleVisible;
434 int m_nLockReposition;
435 BOOL m_bDelayRedraw;
436 CXTPDockingPane* m_pSelectedPane;
437 CXTPDockingPane* m_pTrackingPane;
438 CArray<CRect, CRect&> m_lstRects;
439 COleDropTarget* m_pDropTarget;
440 BOOL m_bMaximized;
441 BOOL m_bEnsureSelectedTab;
443private:
444 class CContainerDropTarget;
445
446private:
447 using CXTPTabManager::OnNavigateButtonClick;
448
449 friend class CXTPDockingPaneManager;
450 friend class CXTPDockingPane;
451 friend class CXTPDockingPaneContext;
452 friend class CXTPDockingPaneMiniWnd;
453 friend class CXTPDockingPaneLayout;
454 friend class CXTPDockingPaneAutoHidePanel;
455 friend class CXTPDockingPaneAutoHideWnd;
456 friend class CXTPDockingPaneCaptionButton;
457 friend class CContainerDropTarget;
458 friend class CXTPDockingPaneSidePanel;
459};
460
461AFX_INLINE BOOL CXTPDockingPaneTabbedContainer::IsActive() const
462{
463 return m_bActive;
464}
465AFX_INLINE CXTPDockingPane* CXTPDockingPaneTabbedContainer::GetSelected() const
466{
467 return m_pSelectedPane;
468}
469AFX_INLINE HWND CXTPDockingPaneTabbedContainer::GetPaneHwnd() const
470{
471 return CWnd::GetSafeHwnd();
472}
474# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
475#endif // #if !defined(__XTPDOCKINGPANETABBEDCONTAINER_H__)
XTPDisableNoisyWarnings.h
CXTPPaneToPaneMap
CMap< CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase *, CXTPDockingPaneBase * > CXTPPaneToPaneMap
This map is used for mapping CXTPDockingPaneBase objects.
Definition XTPDockingPaneDefines.h:514
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
CXTPDockingPaneAutoHidePanel
CXTPDockingPaneAutoHidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBas...
Definition XTPDockingPaneAutoHidePanel.h:121
CXTPDockingPaneAutoHideWnd
CXTPDockingPaneAutoHideWnd is a CMiniFrameWnd derived class.
Definition XTPDockingPaneAutoHidePanel.h:43
CXTPDockingPaneBaseContainer
CXTPDockingPaneBaseContainer is a CXTPDockingPaneBase derived class.
Definition XTPDockingPaneBaseContainer.h:39
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneBase::OnFocusChanged
virtual void OnFocusChanged()
This method is called to update the state of the pane.
CXTPDockingPaneBase::RemovePane
virtual void RemovePane(CXTPDockingPaneBase *pPane)
Call this member to remove a pane from the collection.
CXTPDockingPaneBase::OnParentContainerChanged
virtual void OnParentContainerChanged(CXTPDockingPaneBase *pContainer)
This member is called when the parent pane collection is changed.
CXTPDockingPaneBase::SetDockingSite
virtual void SetDockingSite(CWnd *pFrame)
Call this member to set the parent frame of the pane.
Definition XTPDockingPaneBase.h:483
CXTPDockingPaneBase::InvalidatePane
virtual void InvalidatePane(BOOL bSelectionChanged)
This member is called when a pane must be redrawn.
CXTPDockingPaneBase::DeletePane
virtual void DeletePane()=0
This method is called to destroy a pane.
CXTPDockingPaneBase::GetPaneHwnd
virtual HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneBase.h:508
CXTPDockingPaneBase::IsActive
virtual BOOL IsActive() const
Determines if the frame is active.
Definition XTPDockingPaneBase.h:458
CXTPDockingPaneBase::OnSizeParent
virtual void OnSizeParent(CWnd *pParent, CRect rect, LPVOID lParam)
This method is called to set the position of the pane.
CXTPDockingPaneCaptionButton
CXTPDockingPaneCaptionButton is a standalone internal class.
Definition XTPDockingPaneCaptionButton.h:38
CXTPDockingPaneContext
CXTPDockingPaneContext is a standalone class.
Definition XTPDockingPaneContext.h:185
CXTPDockingPane
CXTPDockingPane is a CXTPDockingPaneBase derived class.
Definition XTPDockingPane.h:44
CXTPDockingPaneLayout
CXTPDockingPaneLayout is a standalone class.
Definition XTPDockingPaneLayout.h:54
CXTPDockingPaneManager
CXTPDockingPaneManager is a CWnd derived class.
Definition XTPDockingPaneManager.h:58
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47
CXTPDockingPaneTabbedContainer::SelectPane
virtual void SelectPane(CXTPDockingPane *pPane, BOOL bSetFocus=TRUE, BOOL bDelayRedraw=TRUE)
Call this member to activate a child docking pane.
CXTPDockingPaneTabbedContainer::m_bActive
BOOL m_bActive
TRUE if the tabbed container has an active caption.
Definition XTPDockingPaneTabbedContainer.h:432
CXTPDockingPaneTabbedContainer::DrawIcon
virtual BOOL DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const
This member is called when the icon of the tab in the tabbed container needs to be drawn (i....
CXTPDockingPaneTabbedContainer::GetSelected
CXTPDockingPane * GetSelected() const
Call this member function to get the selected child pane.
Definition XTPDockingPaneTabbedContainer.h:465
CXTPDockingPaneTabbedContainer::DoPropExchange
virtual BOOL DoPropExchange(CXTPPropExchange *pPX)
This member is called to save/restore the settings of the pane.
CXTPDockingPaneTabbedContainer::IsCaptionVertical
virtual BOOL IsCaptionVertical() const
Call this member to determine if the caption is drawn vertically.
CXTPDockingPaneTabbedContainer::m_bDelayRedraw
BOOL m_bDelayRedraw
TRUE to redraw the pane after a small delay.
Definition XTPDockingPaneTabbedContainer.h:435
CXTPDockingPaneTabbedContainer::GetMinMaxInfo
void GetMinMaxInfo(LPMINMAXINFO pMinMaxInfo) const
Call this member to fill the pMinMaxInfo structure with the minimum and maximum width and height of t...
CXTPDockingPaneTabbedContainer::m_pDropTarget
COleDropTarget * m_pDropTarget
Pointer to Ole Drop Target.
Definition XTPDockingPaneTabbedContainer.h:439
CXTPDockingPaneTabbedContainer::OnCaptionLButtonDown
virtual void OnCaptionLButtonDown(CPoint point)
This member is called by the framework when the left mouse button is clicked while the mouse pointer ...
CXTPDockingPaneTabbedContainer::OnNavigateButtonClick
virtual void OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton)
This member is called by the framework when a navigate button is clicked.
CXTPDockingPaneTabbedContainer::CanAttach
virtual BOOL CanAttach(CRect &rcClient, CPoint pt) const
This method called to check if a docking pane can be attached to a tabbed container.
CXTPDockingPaneTabbedContainer::~CXTPDockingPaneTabbedContainer
virtual ~CXTPDockingPaneTabbedContainer()
Destroys a CXTPDockingPaneTabbedContainer object, handles cleanup and deallocation.
CXTPDockingPaneTabbedContainer::GetTitle
CString GetTitle() const
Call this member to get the text in the caption for the tabbed container (group of panes).
CXTPDockingPaneTabbedContainer::GetPinButton
CXTPDockingPaneCaptionButton * GetPinButton() const
Call this member to retrieve the title's pin button.
CXTPDockingPaneTabbedContainer::GetPaneHwnd
virtual HWND GetPaneHwnd() const
Retrieves the window handle for a window.
Definition XTPDockingPaneTabbedContainer.h:469
CXTPDockingPaneTabbedContainer::IsActive
BOOL IsActive() const
Call this member function to determine if a child pane is active.
Definition XTPDockingPaneTabbedContainer.h:461
CXTPDockingPaneTabbedContainer::m_lstRects
CArray< CRect, CRect & > m_lstRects
Array of previous tabs positions.
Definition XTPDockingPaneTabbedContainer.h:438
CXTPDockingPaneTabbedContainer::SetPaintManager
virtual void SetPaintManager(CXTPTabPaintManager *pPaintManager)
This member function is called in a derived class to set the tab paint manager.
CXTPDockingPaneTabbedContainer::GetPaneTab
CXTPTabManagerItem * GetPaneTab(CXTPDockingPane *pPane) const
Call this member to get the tab for a corresponding pane.
CXTPDockingPaneTabbedContainer::Reposition
virtual void Reposition()
This member is called to recalculate the positions of tab groups/items.
CXTPDockingPaneTabbedContainer::RedrawControl
virtual void RedrawControl(LPCRECT lpRect, BOOL bAnimate)
This member is called to redraw the tabbed control (i.e.
CXTPDockingPaneTabbedContainer::CreateContainer
virtual void CreateContainer()
This member is called to create a pane.
CXTPDockingPaneTabbedContainer::m_bMaximized
BOOL m_bMaximized
TRUE if the pane is currently maximized.
Definition XTPDockingPaneTabbedContainer.h:440
CXTPDockingPaneTabbedContainer::m_bTitleVisible
BOOL m_bTitleVisible
TRUE if the title is visible.
Definition XTPDockingPaneTabbedContainer.h:433
CXTPDockingPaneTabbedContainer::m_bEnsureSelectedTab
BOOL m_bEnsureSelectedTab
TRUE to check if the selected tab is visible after a delay.
Definition XTPDockingPaneTabbedContainer.h:441
CXTPDockingPaneTabbedContainer::IsTabsVisible
virtual BOOL IsTabsVisible() const
Call this member to determine if the tab bar is visible.
CXTPDockingPaneTabbedContainer::OnCaptionButtonClick
virtual void OnCaptionButtonClick(CXTPDockingPaneCaptionButton *pButton)
This member is called by the framework when a caption button is clicked.
CXTPDockingPaneTabbedContainer::Copy
virtual void Copy(CXTPDockingPaneBase *pClone, CXTPPaneToPaneMap *pMap, DWORD dwIgnoredOptions)
Copies a CXTPDockingPaneTabbedContainer object.
CXTPDockingPaneTabbedContainer::m_pTrackingPane
CXTPDockingPane * m_pTrackingPane
Pointer to the dragging pane.
Definition XTPDockingPaneTabbedContainer.h:437
CXTPDockingPaneTabbedContainer::IsCaptionButtonVisible
virtual BOOL IsCaptionButtonVisible(CXTPDockingPaneCaptionButton *pButton)
Call this member to determine if the caption button is visible.
CXTPDockingPaneTabbedContainer::IsHidden
BOOL IsHidden() const
Call this member to determine if the tabbed container is auto-hidden.
CXTPDockingPaneTabbedContainer::IsTitleVisible
BOOL IsTitleVisible() const
Call this member to determine if the title is visible.
CXTPDockingPaneTabbedContainer::Init
void Init(CXTPDockingPane *pPane, CWnd *pFrame)
Constructs a CXTPDockingPaneTabbedContainer object Protected constructor.
CXTPDockingPaneTabbedContainer::m_nLockReposition
int m_nLockReposition
InvalidatePane method currently executed.
Definition XTPDockingPaneTabbedContainer.h:434
CXTPDockingPaneTabbedContainer::GetPaintManager
virtual CXTPTabPaintManager * GetPaintManager() const
This member is called to access the visual elements of the docking pane tabs (i.e.
CXTPDockingPaneTabbedContainer::CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer(CXTPDockingPaneLayout *pLayout)
Constructs a CXTPDockingPaneTabbedContainer object Protected constructor.
CXTPDockingPaneTabbedContainer::GetCloseButton
CXTPDockingPaneCaptionButton * GetCloseButton() const
Call this member to retrieve the title's close button.
CXTPDockingPaneTabbedContainer::m_pSelectedPane
CXTPDockingPane * m_pSelectedPane
Pointer to the selected pane.
Definition XTPDockingPaneTabbedContainer.h:436
CXTPDockingPaneTabbedContainer::GetItemPane
CXTPDockingPane * GetItemPane(int nIndex) const
Call this member to get a pane by its index.
CXTPDockingPaneTabbedContainer::OnTabsChanged
virtual void OnTabsChanged()
This member is called when tabs are changed.
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManager::OnNavigateButtonClick
virtual void OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton)
This method is called when a tab navigation button is clicked.
Definition XTPTabManager.h:1449
CXTPTabManager::HitTest
CXTPTabManagerItem * HitTest(CPoint point) const
Determines which tab is at a specified point, if any.
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManager
CXTPTabPaintManager is used to store the color and appearance information of the tabs in the tab mana...
Definition XTPTabPaintManager.h:48


Toolkit Pro: XTPTaskDialogFrame.h Source File

  • Source
  • Controls
  • Dialog
XTPTaskDialogFrame.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKFRAMEWND_H__)
24# define __XTPTASKFRAMEWND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34// CXTPTaskDialogFrame window
35
36class _XTP_EXT_CLASS CXTPTaskDialogFrame : public CXTPTaskDialogClient
37{
38public:
39 CXTPTaskDialogFrame(TASKDIALOGCONFIG* pConfig);
40 virtual ~CXTPTaskDialogFrame();
41
42public:
43 virtual INT_PTR DoModal();
44 BOOL Create(CWnd* pParentWnd = NULL);
45
46# if _MSC_VER > 1200
47 using CDialog::Create;
48 using CWnd::Create;
49# endif
50
51protected:
52 virtual CString GetFrameTitle() const;
53 virtual DWORD GetFrameStyle() const;
54
55protected:
57 DECLARE_MESSAGE_MAP()
59 //{{AFX_VIRTUAL(CXTPTaskDialogFrame)
60public:
61 virtual BOOL PreTranslateMessage(MSG* pMsg);
62 BOOL OnInitDialog();
63 //}}AFX_VIRTUAL
64
65 //{{AFX_MSG(CXTPTaskDialogFrame)
66 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
67 afx_msg void OnDestroy();
68 afx_msg void OnTimer(UINT_PTR nIDEvent);
69
70 afx_msg LRESULT OnDialogSetElementText(WPARAM wParam, LPARAM lParam);
71 afx_msg LRESULT OnDialogClickButton(WPARAM wParam, LPARAM lParam);
72 afx_msg LRESULT OnDialogClickRadioButton(WPARAM wParam, LPARAM lParam);
73 afx_msg LRESULT OnDialogEnableButton(WPARAM wParam, LPARAM lParam);
74 afx_msg LRESULT OnDialogEnableRadioButton(WPARAM wParam, LPARAM lParam);
75 afx_msg LRESULT OnDialogClickVerificationButton(WPARAM wParam, LPARAM lParam);
76 afx_msg LRESULT OnDialogUpdateIcon(WPARAM wParam, LPARAM lParam);
77 afx_msg LRESULT OnDialogSetButtonElevationState(WPARAM wParam, LPARAM lParam);
78
79 afx_msg LRESULT OnDialogSetMarqueeProgressBar(WPARAM wParam, LPARAM lParam);
80 afx_msg LRESULT OnDialogSetProgressBarState(WPARAM wParam, LPARAM lParam);
81 afx_msg LRESULT OnDialogSetProgressBarRange(WPARAM wParam, LPARAM lParam);
82 afx_msg LRESULT OnDialogSetProgressBarPos(WPARAM wParam, LPARAM lParam);
83 afx_msg LRESULT OnDialogStartProgressBarMarquee(WPARAM wParam, LPARAM lParam);
84 afx_msg LRESULT OnDialogNavigatePage(WPARAM wParam, LPARAM lParam);
85 //}}AFX_MSG
86
87protected:
88 LPDLGTEMPLATE m_lpDlgTemplate;
89 DWORD m_dwTickCount;
90 DWORD m_dwCallbackInterval;
91
92private:
93 friend class CXTPTaskCmdLinkButton;
94};
95
96# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
98#endif // !defined(__XTPTASKFRAMEWND_H__)
XTPDisableNoisyWarnings.h
CXTPTaskDialogClient
CXTPTaskDialogClient window.
Definition XTPTaskDialogClient.h:47


Toolkit Pro: XTPSvgPreview.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • Svg
XTPSvgPreview.h
Go to the documentation of this file.
1
24#if !defined(__XTPSVGPREVIEW_H__)
25# define __XTPSVGPREVIEW_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPSvgImage;
34
35class _XTP_EXT_CLASS CXTPSvgPreview : public IXTPPreview
36{
37 class CContext;
38
39public:
40 CXTPSvgPreview(IXTPPreviewHost& host, LPCTSTR pFilePath);
41 CXTPSvgPreview(IXTPPreviewHost& host, IStream& stream, LPCTSTR pImpliedFileName);
42 ~CXTPSvgPreview();
43
44private:
45 virtual BOOL IsReady() const;
46 virtual BOOL IsAvailable() const;
47 virtual BOOL HasOwnNavigator() const;
48 virtual UINT GetNumberOfPages() const;
49 virtual SIZE GetPreferredPageSize() const;
50 virtual void GoToPage(UINT page);
51 virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect);
52 virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT* result);
53 virtual BOOL SupportsCompositedParent() const;
54 virtual void Activate();
55
56private:
57 BOOL m_bLoadFinished;
58 BOOL m_bLoadSuccess;
59 CXTPSvgImage* m_pImage;
60 HWND m_hwnd;
61 IXTPPreviewHost& m_host;
62};
63
64# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
65#endif // #if !defined(__XTPSVGPREVIEW_H__)
66
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSvgImage
Implements basic SVG image format support.
Definition XTPSvgImage.h:43
IXTPPreviewHost
Interface implemented by the preview host control.
Definition XTPPreviewAbstract.h:152
IXTPPreview
The base interface for a preview handler implementation.
Definition XTPPreviewAbstract.h:40
IXTPPreview::GetNumberOfPages
virtual UINT GetNumberOfPages() const =0
Retrieves the number of pages available for the common page navigator.
IXTPPreview::Draw
virtual void Draw(HDC dc, SIZE clientSize, RECT updateRect)=0
This method is called every time the preview has to draw itself into the available client area.
IXTPPreview::GoToPage
virtual void GoToPage(UINT page)=0
If pages are supported by the preview, then it should cause navigation to the specified page number.
IXTPPreview::OnHostWndMsg
virtual BOOL OnHostWndMsg(LPMSG msg, LRESULT *result)=0
Handles a window message sent to the host preview control.
IXTPPreview::GetPreferredPageSize
virtual SIZE GetPreferredPageSize() const =0
Obtains the preferred page size in pixels if that is required by the preview.
IXTPPreview::SupportsCompositedParent
virtual BOOL SupportsCompositedParent() const =0
Determines if the preview implementation is compatible with composited top level windows (i....
IXTPPreview::IsAvailable
virtual BOOL IsAvailable() const =0
Determines if the preview is available (i.e.
IXTPPreview::IsReady
virtual BOOL IsReady() const =0
Returns TRUE if the handler has attempted and finished loading the preview regardless of the actual l...
IXTPPreview::HasOwnNavigator
virtual BOOL HasOwnNavigator() const =0
Determines if the handler implements its own page navigator.
IXTPPreview::Activate
virtual void Activate()=0
Activate preview.


  • CXTPCalendarControl
  • CViewChanged_ContextData
CXTPCalendarControl::CViewChanged_ContextData Member List

This is the complete list of members for CXTPCalendarControl::CViewChanged_ContextData, including all inherited members.

CViewChanged_ContextData() | CXTPCalendarControl::CViewChanged_ContextData
m_bRequest | CXTPCalendarControl::CViewChanged_ContextData
m_nLockCount | CXTPCalendarControl::CViewChanged_ContextData


CXTPPropertyPageListNavigator Member List

This is the complete list of members for CXTPPropertyPageListNavigator, including all inherited members.

Create()=0 | CXTPPropertyPageNavigator | pure virtual
CXTPListBox() | CXTPListBox |
CXTPPropertyPageControlNavigator() | CXTPPropertyPageControlNavigator |
CXTPPropertyPageListNavigator() | CXTPPropertyPageListNavigator |
CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator |
GetBackColor() | CXTPListBox | virtual
GetListStyle() const | CXTPListBox |
GetPageBrush(CDC *pDC, CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
GetPageColor()=0 | CXTPPropertyPageNavigator | pure virtual
GetSafeHwnd() const =0 | CXTPPropertyPageNavigator | pure virtual
HasFocus() const | CXTPListBox |
Initialize(bool bAutoFont=true) | CXTPListBox | virtual
m_nHotItem | CXTPListBox |
m_nItemHeight | CXTPListBox |
m_nTextPadding | CXTPListBox |
m_pSheet | CXTPPropertyPageNavigator | protected
m_pTheme | CXTPListBox |
m_rcButtonMargin | CXTPPropertyPageNavigator |
m_rcNavigatorMargin | CXTPPropertyPageNavigator |
m_rcPageMargin | CXTPPropertyPageNavigator |
m_theme | CXTPListBox |
OnPageSelected(CXTPPropertyPage *pPage)=0 | CXTPPropertyPageNavigator | pure virtual
PageToSize(AFX_SIZEPARENTPARAMS *pLayout, CSize szPage, CRect &rcPage, CSize &szClient)=0 | CXTPPropertyPageNavigator | pure virtual
RefreshMetrics() | CXTPListBox | virtual
SetListStyle(XTPListBoxStyle style) | CXTPListBox |
CXTPListBox::SetTheme(XTPControlTheme nTheme) | CXTPListBox |
CXTPPropertyPageControlNavigator::SetTheme(XTPControlTheme theme) | CXTPPropertyPageNavigator | virtual
SizeToPage(AFX_SIZEPARENTPARAMS *pLayout, CSize szClient, CRect &rcPage)=0 | CXTPPropertyPageNavigator | pure virtual
TryItemFromPoint(CPoint pt, BOOL &bOutside, int &nIndex) const | CXTPListBox | protected
~CXTPListBox() | CXTPListBox | virtual
~CXTPPropertyPageNavigator() | CXTPPropertyPageNavigator | virtual


  • XTP_CALENDAR_RECURRENCE_OPTIONS
  • PATTERN_WEEKLY
XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY Member List

This is the complete list of members for XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY, including all inherited members.

nDayOfWeekMask | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY
nIntervalWeeks | XTP_CALENDAR_RECURRENCE_OPTIONS::PATTERN_WEEKLY


Toolkit Pro: XTPRibbonBackstageButtonThemeVisualStudio2019.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2019T_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2019T_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeVisualStudio2019
34 : public CXTPButtonThemeVisualStudio2019
35{
36public:
37 CXTPRibbonBackstageButtonThemeVisualStudio2019();
38
39public:
40 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
41
42protected:
43 friend class CBackstageButtonCtrl;
44};
45
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMEVISUALSTUDIO2019T_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.
CXTPButtonThemeVisualStudio2019
CXTPButtonThemeVisualStudio2019 is a class used to perform Visual Studio 2019 theme drawing tasks.
Definition XTPButtonThemeVisualStudio2019.h:39


CXTPCalendarViewEvent Member List

This is the complete list of members for CXTPCalendarViewEvent, including all inherited members.

_MoveRectY(int nYbasePrev, int nYbaseNew, CRect &rRC) | CXTPCalendarViewEvent | static
AddMultiDayEvent_Slave(CXTPCalendarViewEvent *pSlaveView, int nMasterEventPlace) | CXTPCalendarViewEvent | virtual
AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | virtual
AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)=0 | CXTPCalendarViewEvent | pure virtual
AdjustMultidayEvent(CRect rcEventMax, int nEventPlaceNumber) | CXTPCalendarViewEvent | protectedvirtual
AdjustSubjectEditor() | CXTPCalendarViewEvent | virtual
CalcIconsRect(CRect rc) | CXTPCalendarViewEvent | virtual
ChangeEventPlace(int nNewPlace) | CXTPCalendarViewEvent | virtual
CXTPCalendarViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarViewGroup *pViewGroup) | CXTPCalendarViewEvent |
CXTPCalendarWMHandler() | CXTPCalendarWMHandler |
CXTPCmdTarget() | CXTPCmdTarget |
Draw(CDC *pDC)=0 | CXTPCalendarViewEvent | pure virtual
EndEditSubject() | CXTPCalendarViewEvent | virtual
FormatEventTime(COleDateTime dtTime) const | CXTPCalendarViewEvent | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCalendarControl() const | CXTPCalendarViewEvent | virtual
GetChildHandlerAt(int nIndex) const | CXTPCalendarWMHandler | virtual
GetChildHandlersCount() const | CXTPCalendarWMHandler | virtual
GetEditingSubjectFromEditor() const | CXTPCalendarViewEvent | virtual
GetEndTimeRect() const | CXTPCalendarViewEvent | virtual
GetEvent() const | CXTPCalendarViewEvent | virtual
GetEventPlaceNumber() const | CXTPCalendarViewEvent | virtual
GetEventRect() const | CXTPCalendarViewEvent |
GetEventTimelinePlaceNumber() const | CXTPCalendarViewEvent | virtual
GetFirstClockRect() const | CXTPCalendarViewEvent | virtual
GetItemText(DWORD dwItemFlag, LPCTSTR pcszDefaultText=NULL) const | CXTPCalendarViewEvent | virtual
GetItemTextBody() const | CXTPCalendarViewEvent | virtual
GetItemTextEndTime() const | CXTPCalendarViewEvent | virtual
GetItemTextLocation() const | CXTPCalendarViewEvent | virtual
GetItemTextStartTime() const | CXTPCalendarViewEvent | virtual
GetItemTextSubject() const | CXTPCalendarViewEvent | virtual
GetLastClockRect() const | CXTPCalendarViewEvent | virtual
GetMarkupText() const | CXTPCalendarViewEvent | virtual
GetMarkupUIElement() | CXTPCalendarViewEvent | virtual
GetMeetingGlyphRect() const | CXTPCalendarViewEvent | virtual
GetMultiDayEventFlags() const | CXTPCalendarViewEvent | virtual
GetPrivateGlyphRect() const | CXTPCalendarViewEvent | virtual
GetRecurrenceGlyphRect() const | CXTPCalendarViewEvent | virtual
GetReminderGlyphRect() const | CXTPCalendarViewEvent | virtual
GetShowToolTipTimeOut() const | CXTPCalendarViewEvent | virtual
GetStartTimeRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditor() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorFont() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorRect() const | CXTPCalendarViewEvent | virtual
GetSubjectEditorStyles() const | CXTPCalendarViewEvent | virtual
GetTextRect() const | CXTPCalendarViewEvent | virtual
GetToolText() | CXTPCalendarViewEvent | protectedvirtual
GetViewEventRect() const | CXTPCalendarViewEvent | virtual
GetViewEventRectMax() const | CXTPCalendarViewEvent | virtual
GetViewGroup_() const =0 | CXTPCalendarViewEvent | pure virtual
HideToolTip() | CXTPCalendarViewEvent | virtual
HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const | CXTPCalendarViewEvent | virtual
HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const =0 | CXTPCalendarViewEvent | pure virtual
IsEditingSubject() const | CXTPCalendarViewEvent | virtual
IsMultidayEvent() const | CXTPCalendarViewEvent | virtual
IsMultyDayTextAlign() const | CXTPCalendarViewEvent | virtual
IsSelected() const | CXTPCalendarViewEvent | virtual
IsShowingToolTip() | CXTPCalendarViewEvent | virtual
IsTextOutOfBorders() const | CXTPCalendarViewEvent | virtual
IsVisible() const =0 | CXTPCalendarViewEvent | pure virtual
KillTimer(UINT uTimerID) | CXTPCalendarViewEvent | virtual
m_bMultyDayTextAlign | CXTPCalendarViewEvent | protected
m_bSelected | CXTPCalendarViewEvent | protected
m_bTextOutOfBorders | CXTPCalendarViewEvent | protected
m_nEventPlaceNumber | CXTPCalendarViewEvent | protected
m_nEventTimelinePlaceNumber | CXTPCalendarViewEvent | protected
m_nMultiDayEventFlags | CXTPCalendarViewEvent |
m_nTimerID_ShowToolTip | CXTPCalendarViewEvent | protected
m_pMasterView | CXTPCalendarViewEvent | protected
m_pSubjectEditor | CXTPCalendarViewEvent | protected
m_ptrEvent | CXTPCalendarViewEvent | protected
m_pUIElement | CXTPCalendarViewEvent |
m_rcEndTime | CXTPCalendarViewEvent |
m_rcEvent | CXTPCalendarViewEvent |
m_rcEventMax | CXTPCalendarViewEvent |
m_rcFirstClock | CXTPCalendarViewEvent |
m_rcLastClock | CXTPCalendarViewEvent |
m_rcMeetingGlyph | CXTPCalendarViewEvent |
m_rcPrivateGlyph | CXTPCalendarViewEvent |
m_rcRecurrenceGlyph | CXTPCalendarViewEvent |
m_rcReminderGlyph | CXTPCalendarViewEvent |
m_rcStartTime | CXTPCalendarViewEvent |
m_rcSubjectEditor | CXTPCalendarViewEvent |
m_rcText | CXTPCalendarViewEvent |
m_rcToolTip | CXTPCalendarViewEvent |
m_strUIElementText | CXTPCalendarViewEvent |
m_szText | CXTPCalendarViewEvent |
OnBeforeDestroy() | CXTPCalendarViewEvent | virtual
OnChar(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPCalendarViewEvent | virtual
OnPostAdjustLayout() | CXTPCalendarViewEvent | virtual
OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags) | CXTPCalendarWMHandler | virtual
OnTimer(UINT_PTR uTimerID) | CXTPCalendarViewEvent | virtual
OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT *pResult) | CXTPCalendarViewEvent | virtual
SetMultiDayEvent_MasterSlave(BOOL bMaster, CXTPCalendarViewEvent *pMasterView) | CXTPCalendarViewEvent | virtual
SetSelected(BOOL bSet=TRUE) | CXTPCalendarViewEvent | virtual
SetTextOutOfBorders(BOOL bOutOfBorders) | CXTPCalendarViewEvent | virtual
SetTimer(UINT uTimeOut_ms) | CXTPCalendarViewEvent | virtual
ShowToolTip() | CXTPCalendarViewEvent | virtual
StartEditSubject() | CXTPCalendarViewEvent | virtual
~CXTPCalendarViewEvent() | CXTPCalendarViewEvent | virtual


Toolkit Pro: XTPControlExt.h Source File

  • Source
  • CommandBars
XTPControlExt.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLEXT_H__)
24# define __XTPCONTROLEXT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTabClientWnd;
34class CXTPMarkupUIElement;
35
41class _XTP_EXT_CLASS CXTPControlWindowList : public CXTPControlButton
42{
43protected:
94 virtual void OnCalcDynamicSize(DWORD dwMode);
95
105 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
106 DROPEFFECT& dropEffect);
107
108public:
120 static CString AFX_CDECL ConstructCaption(const CString& lpszTitle, int nIndex);
121
122public:
123 static UINT m_nFistMDIChild;
124 static UINT m_nItemCount;
125 static BOOL m_bShowRadioButtons;
127private:
128 DECLARE_XTP_CONTROL(CXTPControlWindowList)
129};
130
136class _XTP_EXT_CLASS CXTPControlWorkspaceActions : public CXTPControlButton
137{
138protected:
189 virtual void OnCalcDynamicSize(DWORD dwMode);
190
198 void AddCommand(CXTPTabClientWnd* pClient, UINT nID, int& nIndex);
199
200private:
201 DECLARE_XTP_CONTROL(CXTPControlWorkspaceActions)
202};
203
209class _XTP_EXT_CLASS CXTPControlToolbars : public CXTPControlButton
210{
211public:
216 CXTPControlToolbars();
217
222 class CXTPControlToolbar : public CXTPControlButton
223 {
228 virtual void OnExecute();
229 };
230
245 static void AFX_CDECL CreateToolbarMenu(CXTPCommandBar* pPopupBar, int nInsert, int nID,
246 BOOL bAddCustomize, BOOL bBeginGroup = FALSE);
247
248protected:
299 virtual void OnCalcDynamicSize(DWORD dwMode);
300
310 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
311 DROPEFFECT& dropEffect);
312
313private:
314 DECLARE_XTP_CONTROL(CXTPControlToolbars)
315};
316
322class _XTP_EXT_CLASS CXTPControlOleItems : public CXTPControlButton
323{
324protected:
375 virtual void OnCalcDynamicSize(DWORD dwMode);
376
386 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
387 DROPEFFECT& dropEffect);
388
389private:
390 DECLARE_XTP_CONTROL(CXTPControlOleItems)
391};
392
398class _XTP_EXT_CLASS CXTPControlRecentFileList : public CXTPControlButton
399{
400protected:
451 virtual void OnCalcDynamicSize(DWORD dwMode);
452
462 virtual BOOL DoCustomDragOver(CXTPCommandBar* pCommandBar, CPoint point,
463 DROPEFFECT& dropEffect);
464
465protected:
472 virtual CRecentFileList* GetRecentFileList();
473
480 virtual int GetFirstMruID();
481
482private:
483 DECLARE_XTP_CONTROL(CXTPControlRecentFileList)
484};
485
542const UINT XTP_SLN_SELCHANGE = 0x1006;
543
573class _XTP_EXT_CLASS CXTPControlSelector : public CXTPControl
574{
576 DECLARE_XTP_CONTROL(CXTPControlSelector)
578public:
583 CXTPControlSelector();
584
585protected:
593 CSize GetSize(CDC* pDC);
594
600 void Draw(CDC* pDC);
601
607 void OnMouseMove(CPoint point);
608
616 BOOL OnSetSelected(int bSelected);
617
623 void OnLButtonUp(CPoint point);
624
675 virtual void OnCalcDynamicSize(DWORD dwMode);
676
683 void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
684
690 void DoPropExchange(CXTPPropExchange* pPX);
691
692protected:
711 void SetItemsActive(CSize szActive, BOOL bNotify = FALSE);
712
725 virtual void OnDrawItem(CDC* pDC, CRect rcItem, COLORREF clrText);
726
727public:
728 CSize m_szItemsCount;
731 CSize m_szItemsMax;
732 CSize m_szItemsActive;
735 CSize m_szItem;
736 CSize m_szResult;
737 CSize m_szItemsVisible;
740private:
741 BOOL m_bLockUpdate;
742};
743
749class _XTP_EXT_CLASS CXTPControlLabel : public CXTPControl
750{
751 DECLARE_XTP_CONTROL(CXTPControlLabel)
752public:
757 CXTPControlLabel()
758 {
759 m_dwFlags = xtpFlagSkipFocus | xtpFlagNoMovable | xtpFlagManualUpdate;
760 m_controlType = xtpControlLabel;
761 }
762
771 int GetSelected() const
772 {
773 return FALSE;
774 }
775
782 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
783};
784
790class _XTP_EXT_CLASS CXTPControlCheckBox : public CXTPControlButton
791{
793 DECLARE_XTP_CONTROL(CXTPControlCheckBox)
795public:
800 CXTPControlCheckBox();
801
802protected:
812 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
813
820 BOOL IsFocused() const;
821
822# ifdef _XTP_COMMANDBARS_ACTIVEX
825 DECLARE_DISPATCH_MAP()
826 DECLARE_INTERFACE_MAP()
827
828 DECLARE_OLETYPELIB_EX(CXTPControlCheckBox);
829
830 afx_msg long OleGetChecked();
831 afx_msg void OleSetChecked(long);
832
834# endif
835};
836
842class _XTP_EXT_CLASS CXTPControlRadioButton : public CXTPControlButton
843{
845 DECLARE_XTP_CONTROL(CXTPControlRadioButton)
847public:
852 CXTPControlRadioButton();
853
854protected:
864 BOOL OnHookKeyDown(UINT nChar, LPARAM lParam);
865
872 BOOL IsFocused() const;
873};
874
880class _XTP_EXT_CLASS CXTPControlMarkupLabel : public CXTPControlLabel
881{
882 DECLARE_XTP_CONTROL(CXTPControlMarkupLabel);
883
884public:
889 CXTPControlMarkupLabel();
890
895 ~CXTPControlMarkupLabel();
896
897protected:
902 void OnCaptionChanged();
903
904 virtual void OnThemeChanged();
905
906protected:
914 virtual CSize GetSize(CDC* pDC);
915
921 virtual void Draw(CDC* pDC);
922
923protected:
924 CXTPMarkupUIElement* m_pMarkupUIElement;
926private:
927 void RebuildMarkup();
928};
929
935class _XTP_EXT_CLASS CXTPControlHyperlink : public CXTPControl
936{
937 DECLARE_XTP_CONTROL(CXTPControlHyperlink);
938
939public:
944 CXTPControlHyperlink();
945
946protected:
954 virtual CSize GetSize(CDC* pDC);
955
961 virtual void Draw(CDC* pDC);
962
969 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
970
975 void OnExecute();
976
982 void OnMouseMove(CPoint point);
983
984protected:
985 HCURSOR m_hCursor;
986};
987
993class _XTP_EXT_CLASS CXTPControlBitmap : public CXTPControlLabel
994{
995 DECLARE_XTP_CONTROL(CXTPControlBitmap);
996
997public:
1002 CXTPControlBitmap();
1003
1004protected:
1012 virtual CSize GetSize(CDC* pDC);
1013
1019 virtual void Draw(CDC* pDC);
1020};
1022# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1023#endif // #if !defined(__XTPCONTROLEXT_H__)
xtpControlLabel
@ xtpControlLabel
Label control.
Definition XTPCommandBarsDefines.h:120
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
xtpFlagNoMovable
@ xtpFlagNoMovable
To disable customization.
Definition XTPCommandBarsDefines.h:143
xtpFlagManualUpdate
@ xtpFlagManualUpdate
Control is manually updated.
Definition XTPCommandBarsDefines.h:142
xtpFlagSkipFocus
@ xtpFlagSkipFocus
Control does not have focus.
Definition XTPCommandBarsDefines.h:140
XTP_SLN_SELCHANGE
const UINT XTP_SLN_SELCHANGE
XTP_SLN_SELCHANGE is sent to the parent command bar when the number of selected items has changed in ...
Definition XTPControlExt.h:542
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPControlBitmap
CXTPControlBitmap is a CXTPControlLabel derived class.
Definition XTPControlExt.h:994
CXTPControlBitmap::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlBitmap::CXTPControlBitmap
CXTPControlBitmap()
Constructs a CXTPControlBitmap object.
CXTPControlBitmap::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlButton::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlCheckBox
CXTPControlCheckBox is a CXTPControlButton derived class.
Definition XTPControlExt.h:791
CXTPControlCheckBox::CXTPControlCheckBox
CXTPControlCheckBox()
Constructs a CXTPControlCheckBox object.
CXTPControlCheckBox::OnHookKeyDown
BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPControlCheckBox::IsFocused
BOOL IsFocused() const
Call this member to get the focused state of the control.
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControl::GetSelected
virtual int GetSelected() const
Call this member to check if the control is selected.
Definition XTPControl.h:2568
CXTPControlHyperlink
CXTPControlHyperlink is a CXTPControl derived class.
Definition XTPControlExt.h:936
CXTPControlHyperlink::OnMouseMove
void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPControlHyperlink::m_hCursor
HCURSOR m_hCursor
Cursor display when item is hovered.
Definition XTPControlExt.h:985
CXTPControlHyperlink::CXTPControlHyperlink
CXTPControlHyperlink()
Constructs a CXTPControlHyperlink object.
CXTPControlHyperlink::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlHyperlink::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlHyperlink::OnExecute
void OnExecute()
This method is called when the control is executed.
CXTPControlHyperlink::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlLabel
CXTPControlLabel is a CXTPControl derived class.
Definition XTPControlExt.h:750
CXTPControlMarkupLabel
CXTPControlMarkupLabel is a CXTPControlLabel derived class.
Definition XTPControlExt.h:881
CXTPControlMarkupLabel::~CXTPControlMarkupLabel
~CXTPControlMarkupLabel()
Destroys a CXTPControlMarkupLabel object, handles cleanup and deallocation.
CXTPControlMarkupLabel::OnThemeChanged
virtual void OnThemeChanged()
This method is called when the paint manager theme is changed.
CXTPControlMarkupLabel::CXTPControlMarkupLabel
CXTPControlMarkupLabel()
Constructs a CXTPControlMarkupLabel object.
CXTPControlMarkupLabel::Draw
virtual void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlMarkupLabel::m_pMarkupUIElement
CXTPMarkupUIElement * m_pMarkupUIElement
Markup element.
Definition XTPControlExt.h:924
CXTPControlMarkupLabel::GetSize
virtual CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlMarkupLabel::OnCaptionChanged
void OnCaptionChanged()
This method is called when the control's caption is changed.
CXTPControlOleItems
CXTPControlOleItems is a CXTPControlButton derived class.
Definition XTPControlExt.h:323
CXTPControlOleItems::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlOleItems::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPControlRadioButton
CXTPControlRadioButton is a CXTPControlButton derived class.
Definition XTPControlExt.h:843
CXTPControlRadioButton::CXTPControlRadioButton
CXTPControlRadioButton()
Constructs a CXTPControlRadioButton object.
CXTPControlRadioButton::OnHookKeyDown
BOOL OnHookKeyDown(UINT nChar, LPARAM lParam)
The framework calls this member function when a non-system key is pressed.
CXTPControlRadioButton::IsFocused
BOOL IsFocused() const
Call this member to get the focused state of the control.
CXTPControlRecentFileList
CXTPControlRecentFileList is a CXTPControlButton derived class.
Definition XTPControlExt.h:399
CXTPControlRecentFileList::GetFirstMruID
virtual int GetFirstMruID()
Call this member to get ID_FILE_MRU_FILE1.
CXTPControlRecentFileList::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlRecentFileList::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPControlRecentFileList::GetRecentFileList
virtual CRecentFileList * GetRecentFileList()
Call this member to get a pointer to the recent file list collection.
CXTPControlSelector
CXTPControlSelector is a CXTPControl derived class that represents a control selector.
Definition XTPControlExt.h:574
CXTPControlSelector::OnLButtonUp
void OnLButtonUp(CPoint point)
This member is called when the user releases the left mouse button.
CXTPControlSelector::m_szItemsActive
CSize m_szItemsActive
Number of items currently "active".
Definition XTPControlExt.h:732
CXTPControlSelector::Copy
void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControlSelector::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlSelector::OnMouseMove
void OnMouseMove(CPoint point)
This member is called when the mouse cursor moves.
CXTPControlSelector::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlSelector::m_szItemsMax
CSize m_szItemsMax
Maximum number of items to draw in the control selector.
Definition XTPControlExt.h:731
CXTPControlSelector::m_szResult
CSize m_szResult
Number of items that were selected from the control selector.
Definition XTPControlExt.h:736
CXTPControlSelector::GetSize
CSize GetSize(CDC *pDC)
This method is called to determine the size of the control.
CXTPControlSelector::m_szItem
CSize m_szItem
Size of the items.
Definition XTPControlExt.h:735
CXTPControlSelector::OnSetSelected
BOOL OnSetSelected(int bSelected)
This method is called when the control becomes selected.
CXTPControlSelector::SetItemsActive
void SetItemsActive(CSize szActive, BOOL bNotify=FALSE)
This member is called to set the number of active items.
CXTPControlSelector::m_szItemsVisible
CSize m_szItemsVisible
Number of items currently visible.
Definition XTPControlExt.h:737
CXTPControlSelector::m_szItemsCount
CSize m_szItemsCount
Number of items to draw in the control selector's view.
Definition XTPControlExt.h:728
CXTPControlSelector::Draw
void Draw(CDC *pDC)
This method is called to draw the control.
CXTPControlSelector::CXTPControlSelector
CXTPControlSelector()
Constructs a CXTPControlSelector object.
CXTPControlSelector::OnDrawItem
virtual void OnDrawItem(CDC *pDC, CRect rcItem, COLORREF clrText)
This member is called when a control item in the control selector is drawn.
CXTPControlToolbars::CXTPControlToolbar
Represents a single toolbar item.
Definition XTPControlExt.h:223
CXTPControlToolbars
CXTPControlToolbars is a CXTPControlButton derived class.
Definition XTPControlExt.h:210
CXTPControlToolbars::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlToolbars::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPControlToolbars::CXTPControlToolbars
CXTPControlToolbars()
Constructs a CXTPControlToolbars object.
CXTPControlToolbars::CreateToolbarMenu
static void AFX_CDECL CreateToolbarMenu(CXTPCommandBar *pPopupBar, int nInsert, int nID, BOOL bAddCustomize, BOOL bBeginGroup=FALSE)
Creates a list of toolbars for the CommandBars Context Menu.
CXTPControlWindowList
CXTPControlWindowList is a CXTPControlButton derived class.
Definition XTPControlExt.h:42
CXTPControlWindowList::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPControlWindowList::DoCustomDragOver
virtual BOOL DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect)
The implementation may implement a custom drag over handling logic in this method.
CXTPControlWindowList::m_nFistMDIChild
static UINT m_nFistMDIChild
First MDI child ID.
Definition XTPControlExt.h:123
CXTPControlWindowList::m_bShowRadioButtons
static BOOL m_bShowRadioButtons
TRUE to show Radio buttons.
Definition XTPControlExt.h:125
CXTPControlWindowList::m_nItemCount
static UINT m_nItemCount
Maximum allowed items.
Definition XTPControlExt.h:124
CXTPControlWindowList::ConstructCaption
static CString AFX_CDECL ConstructCaption(const CString &lpszTitle, int nIndex)
Adds the number and an ampersand "&" before the caption of an item that appears in the Windows List.
CXTPControlWorkspaceActions
CXTPControlWorkspaceActions is a CXTPControlButton derived class.
Definition XTPControlExt.h:137
CXTPControlWorkspaceActions::AddCommand
void AddCommand(CXTPTabClientWnd *pClient, UINT nID, int &nIndex)
Adds an action command to parent controls.
CXTPControlWorkspaceActions::OnCalcDynamicSize
virtual void OnCalcDynamicSize(DWORD dwMode)
This method is called before recalculating the parent command bar size to calculate the dimensions of...
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTabClientWnd
CXTPTabClientWnd is a CWnd derived class.
Definition XTPTabClientWnd.h:383


CXTPMarqueeCtrlThemeVisualStudio2022 Member List

This is the complete list of members for CXTPMarqueeCtrlThemeVisualStudio2022, including all inherited members.

CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager |
CXTPMarqueeCtrlThemeOffice2000() | CXTPMarqueeCtrlThemeOffice2000 |
CXTPMarqueeCtrlThemeOffice2013() | CXTPMarqueeCtrlThemeOffice2013 |
CXTPMarqueeCtrlThemeVisualStudio2022() | CXTPMarqueeCtrlThemeVisualStudio2022 |
DeflateRect(CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawBackground(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
DrawChunk(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CXTPCompatibleDC &dcChunk, int i, int &x, int &y, int cx, int cy) | CXTPMarqueeCtrlPaintManager | protectedvirtual
DrawMarquee(CXTPMarqueeCtrl *pWndCtrl, CDC *pDC, CRect &rcClient) | CXTPMarqueeCtrlPaintManager | virtual
GetBackColor() | CXTPMarqueeCtrlPaintManager |
GetBarColor() | CXTPMarqueeCtrlPaintManager |
GetBorderColor() | CXTPMarqueeCtrlPaintManager |
m_bUseWinTheme | CXTPMarqueeCtrlPaintManager | protected
m_clr3DHilite | CXTPMarqueeCtrlPaintManager | protected
m_clr3DShadow | CXTPMarqueeCtrlPaintManager | protected
m_clrBack | CXTPMarqueeCtrlPaintManager | protected
m_clrBar | CXTPMarqueeCtrlPaintManager | protected
m_nTheme | CXTPMarqueeCtrlPaintManager | protected
m_winTheme | CXTPMarqueeCtrlPaintManager | protected
RefreshMetrics() | CXTPMarqueeCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPMarqueeCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPMarqueeCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPMarqueeCtrlPaintManager |
~CXTPMarqueeCtrlPaintManager() | CXTPMarqueeCtrlPaintManager | virtual


CXTPHookManager Member List

This is the complete list of members for CXTPHookManager, including all inherited members.

CXTPHookManager() | CXTPHookManager | protected
Default() | CXTPHookManager |
Default(WPARAM wParam, LPARAM lParam) | CXTPHookManager |
Default(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) | CXTPHookManager |
Lookup(HWND hWnd) | CXTPHookManager |
RemoveAll(HWND hWnd) | CXTPHookManager |
RemoveAll(CXTPHookManagerHookAble *pHook) | CXTPHookManager |
RemoveAll(int idHook) | CXTPHookManager |
RemoveHook(HWND hWnd, CXTPHookManagerHookAble *pHook) | CXTPHookManager |
SetHook(HWND hWnd, CXTPHookManagerHookAble *pHook) | CXTPHookManager |
SetHook(int idHook, CXTPHookManagerHookAble *pHook, DWORD dwThreadId=0) | CXTPHookManager |
XTPHookManager() | CXTPHookManager | friend
~CXTPHookManager() | CXTPHookManager |


CXTPSyntaxEditPropertiesDlg Member List

This is the complete list of members for CXTPSyntaxEditPropertiesDlg, including all inherited members.

CXTPSyntaxEditPropertiesDlg(CXTPSyntaxEditView *pEditView=NULL) | CXTPSyntaxEditPropertiesDlg |
DECLARE_MESSAGE_MAP() CXTPSyntaxEditPropertiesPageEdit m_Page1 | CXTPSyntaxEditPropertiesDlg | protected
m_Page2 | CXTPSyntaxEditPropertiesDlg | protected
m_Page3 | CXTPSyntaxEditPropertiesDlg | protected
~CXTPSyntaxEditPropertiesDlg() | CXTPSyntaxEditPropertiesDlg | virtual


CXTPCommandBarsVisualStudio2017Theme Member List

This is the complete list of members for CXTPCommandBarsVisualStudio2017Theme, including all inherited members.

AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical) | CXTPCommandBarsOfficeXPTheme | virtual
Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType) | CXTPPaintManager | virtual
AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown) | CXTPPaintManager | virtual
BaseTheme() | CXTPCommandBarsOffice2013Theme | virtual
CreateTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme |
CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme |
CXTPCommandBarsOfficeXPTheme() | CXTPCommandBarsOfficeXPTheme |
CXTPCommandBarsVisualStudio2017Theme() | CXTPCommandBarsVisualStudio2017Theme |
CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
CXTPPaintManager() | CXTPPaintManager | protected
Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight) | CXTPPaintManager |
Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
CXTPPaintManager::DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0) | CXTPPaintManager | inline
DrawCheckRect(CDC *pDC, CRect rc, COLORREF clrFore, COLORREF clrBack) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr) | CXTPPaintManager | virtual
DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE) | CXTPPaintManager |
DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw) | CXTPCommandBarsOffice2013Theme | virtual
DrawControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPPaintManager | virtual
DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled) | CXTPPaintManager |
DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw) | CXTPPaintManager | virtual
DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawFrameBorder(CDC *pDC, CRect rc, int nBorderThickness, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protected
DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE) | CXTPCommandBarsOfficeXPTheme | protectedvirtual
DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0) | CXTPCommandBarsOfficeXPTheme | virtual
DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE) | CXTPCommandBarsOffice2013Theme | protectedvirtual
DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr) | CXTPPaintManager | virtual
DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags) | CXTPCommandBarsOfficeXPTheme | virtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition, int nID) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawRectangle(CDC *pDC, CXTPControl *pButton) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam) | CXTPPaintManager | virtual
DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) | CXTPCommandBarsOfficeXPTheme | virtual
FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillDockBar(CDC *pDC, CXTPDockBar *pBar) | CXTPCommandBarsOffice2013Theme | virtual
FillIntersectRect(CDC *pDC, CXTPPopupBar *pPopupBar, COLORREF clr) | CXTPCommandBarsOfficeXPTheme | protected
FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude) | CXTPCommandBarsOffice2013Theme | virtual
FontExists(LPCTSTR lpszFaceName) | CXTPPaintManager | static
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCommandBarBorders(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetCommandBarFont(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
GetControlBackColor(CXTPControl *pButton) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetControlEditBackColor(CXTPControl *pControl) | CXTPCommandBarsOffice2013Theme | virtual
GetControlFont(CXTPControl *pControl) | CXTPPaintManager | virtual
GetControlHeight() const | CXTPPaintManager |
GetControlTextColor(CXTPControl *pButton) | CXTPCommandBarsVisualStudio2017Theme | protectedvirtual
GetControlTextOrientation(CXTPControl *pControl) | CXTPPaintManager | virtual
GetCurrentSystemTheme() | CXTPPaintManager |
GetCurrentTheme() | CXTPPaintManager | inline
GetDefaultCommandBarSize(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetFramePaintManager() | CXTPCommandBarsModernUITheme | virtual
GetGalleryPaintManager() const | CXTPPaintManager | virtual
GetGlobalPaintManager() | CXTPPaintManager | static
GetIconFont() | CXTPPaintManager |
GetIconsInfo() | CXTPPaintManager |
GetInstanceAddRef() | CXTPPaintManager | static
GetMarkupContext() | CXTPCommandBarsModernUITheme | virtual
GetMessageBarPaintManager() | CXTPPaintManager | virtual
GetPopupBarGripperWidth(CXTPCommandBar *pBar) | CXTPPaintManager | virtual
GetProgressPaintManager() const | CXTPPaintManager | virtual
GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition) | CXTPCommandBarsOffice2013Theme | protectedvirtual
GetRegularBoldFont() | CXTPPaintManager |
GetRegularFont() | CXTPPaintManager |
GetRibbonPaintManager() | CXTPCommandBarsModernUITheme | virtual
GetScrollBarPaintManager() const | CXTPPaintManager | virtual
GetShadowManager() const | CXTPPaintManager |
GetShadowOptions() const | CXTPPaintManager |
GetSliderPaintManager() const | CXTPPaintManager | virtual
GetSmCaptionFont() | CXTPPaintManager |
GetSplitButtonCommandRect(CXTPControl *pButton) | CXTPPaintManager | virtual
GetStateColor() const | CXTPCommandBarsVisualStudio2017Theme | virtual
GetStatusBarPaintManager() | CXTPPaintManager | virtual
GetXtremeColor(UINT nIndex) | CXTPPaintManager |
GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL) | CXTPPaintManager |
HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen) | CXTPPaintManager |
IsUseSystemAccentColorEnabled() const | CXTPPaintManager |
Line(CDC *pDC, CPoint p0, CPoint p1) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen) | CXTPPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen) | CXTPPaintManager |
m_arrColor | CXTPPaintManager | protected
m_bAutoResizeIcons | CXTPPaintManager |
m_bClearTypeTextQuality | CXTPPaintManager |
m_bEmbossedDisabledText | CXTPPaintManager | protected
m_bEnableAnimation | CXTPPaintManager |
m_bFlatMenuBar | CXTPPaintManager |
m_bFlatToolBar | CXTPPaintManager |
m_bIntersect | CXTPCommandBarsOffice2013Theme | protected
m_bOffice2007Padding | CXTPPaintManager |
m_bOffsetPopupLabelText | CXTPPaintManager |
m_bSelectImageInPopupBar | CXTPPaintManager |
m_bShowKeyboardCues | CXTPPaintManager | protected
m_bShowShadow | CXTPPaintManager |
m_bThemedCheckBox | CXTPPaintManager |
m_bThemedStatusBar | CXTPPaintManager |
m_bThickCheckMark | CXTPPaintManager |
m_bUseOfficeFont | CXTPPaintManager |
m_bUseStandardFont | CXTPPaintManager | protected
m_bWrapCaptionBelowText | CXTPPaintManager |
m_clr3DShadow | CXTPCommandBarsOffice2013Theme | protected
m_clrBack | CXTPCommandBarsOffice2013Theme | protected
m_clrBtnFace | CXTPCommandBarsOffice2013Theme | protected
m_clrCaptionButtonFill | CXTPCommandBarsOffice2013Theme | protected
m_clrDisabledIcon | CXTPPaintManager |
m_clrFloatingGripper | CXTPPaintManager |
m_clrFloatingGripperText | CXTPPaintManager |
m_clrGlyph | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphDisabled | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrGlyphPushed | CXTPCommandBarsOffice2013Theme | protected
m_clrHighlight | CXTPCommandBarsOffice2013Theme | protected
m_clrMessageBarText | CXTPCommandBarsOffice2013Theme | protected
m_clrWorkspace | CXTPCommandBarsOffice2013Theme | protected
m_csCheckBox | CXTPCommandBarsOffice2013Theme | protected
m_csCheckMark | CXTPCommandBarsOffice2013Theme | protected
m_csComboBox | CXTPCommandBarsOffice2013Theme | protected
m_csMenu | CXTPCommandBarsOffice2013Theme | protected
m_csMenuTitleBar | CXTPCommandBarsOffice2013Theme | protected
m_csRibbon | CXTPCommandBarsOffice2013Theme | protected
m_csToolbar | CXTPCommandBarsOffice2013Theme | protected
m_fontIcon | CXTPPaintManager |
m_fontIconBold | CXTPPaintManager |
m_fontSmCaption | CXTPPaintManager |
m_fontToolTip | CXTPPaintManager |
m_iconsInfo | CXTPPaintManager | protected
m_nAnimationSteps | CXTPPaintManager | protected
m_nAnimationTime | CXTPPaintManager | protected
m_nEditHeight | CXTPPaintManager | protected
m_nFontHeight | CXTPPaintManager | protected
m_nPopupBarTextPadding | CXTPPaintManager |
m_nSplitButtonDropDownHeight | CXTPPaintManager |
m_nSplitButtonDropDownWidth | CXTPPaintManager |
m_nSplitButtonPopupWidth | CXTPPaintManager |
m_nStatusBarMinHeight | CXTPPaintManager |
m_nTextHeight | CXTPPaintManager |
m_pfnSetLayeredWindowAttributes | CXTPPaintManager |
m_pFramePaintManager | CXTPPaintManager |
m_pGalleryPaintManager | CXTPPaintManager |
m_pImages | CXTPCommandBarsModernUITheme | protected
m_pMarkupContext | CXTPCommandBarsModernUITheme | protected
m_pProgressPaintManager | CXTPPaintManager |
m_pRibbonPaintManager | CXTPPaintManager |
m_pScrollBarPaintManager | CXTPPaintManager |
m_pShadowManager | CXTPPaintManager | protected
m_pSliderPaintManager | CXTPPaintManager |
m_pStatusBarPaintManager | CXTPPaintManager |
m_rcMessageBarMargin | CXTPPaintManager |
m_rcStatusBarBorder | CXTPPaintManager |
m_strOfficeFont | CXTPPaintManager |
m_systemTheme | CXTPPaintManager | protected
m_themeButton | CXTPPaintManager | protected
m_themeCurrent | CXTPPaintManager | protected
m_themeStatusBar | CXTPPaintManager | protected
m_xtpFontRegular | CXTPPaintManager | protected
m_xtpFontRegularBold | CXTPPaintManager | protected
m_xtpFontVert | CXTPPaintManager | protected
m_xtpFontVertBold | CXTPPaintManager | protected
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Notify(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *)) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1), A1 arg1) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
NotifyReversed(void(IXTPPaintManagerEvents::*method)(CXTPPaintManager *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | inline
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush) | CXTPPaintManager |
Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
RefreshMetrics() | CXTPCommandBarsOffice2013Theme | protectedvirtual
RefreshStandardColors() | CXTPCommandBarsOffice2013Theme | protectedvirtual
ReleaseInstance() | CXTPPaintManager | static
RequiresResourceImages() | CXTPCommandBarsOffice2013Theme | virtual
RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush) | CXTPPaintManager |
SetAnimationDelay(int nAnimationSteps, int nAnimationTime) | CXTPPaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPPaintManager |
SetCommandBarRegion(CXTPCommandBar *pCommandBar) | CXTPPaintManager | virtual
SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPPaintManager |
SetCustomTheme(CXTPPaintManager *pTheme) | CXTPPaintManager | static
SetGlobalPaintManager(CXTPPaintManager *pPaintManager) | CXTPPaintManager | static
SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName) | CXTPPaintManager | virtual
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPPaintManager |
SetStateColor(COLORREF clrState=COLORREF_NULL) | CXTPCommandBarsVisualStudio2017Theme | virtual
SetTheme(XTPPaintTheme paintTheme) | CXTPPaintManager | static
StripMnemonics(CString &strClear) | CXTPPaintManager | static
Subscribe(IXTPPaintManagerEvents *pObserver, CXTPSubscriptionList< CXTPPaintManager, IXTPPaintManagerEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr) | CXTPPaintManager | static
Unsubscribe(IXTPPaintManagerEvents *pObserver) | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > |
UpdateColors() | CXTPPaintManager | virtual
UpdateFonts() | CXTPPaintManager | virtual
UpdateRTLCaption(CString &strCaption) | CXTPPaintManager | virtual
UseOfficeFont(bool bUseOfficeFont) | CXTPPaintManager |
VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen) | CXTPPaintManager |
~CXTPCommandBarsModernUITheme() | CXTPCommandBarsModernUITheme | virtual
~CXTPCommandBarsOffice2013Theme() | CXTPCommandBarsOffice2013Theme | virtual
~CXTPCommandBarsVisualStudio2017Theme() | CXTPCommandBarsVisualStudio2017Theme | virtual
~CXTPObservable() | CXTPObservable< CXTPPaintManager, IXTPPaintManagerEvents > | protected
~CXTPPaintManager() | CXTPPaintManager | protectedvirtual


Toolkit Pro: XTPFlowGraphPageHistory.h Source File

  • Source
  • FlowGraph
XTPFlowGraphPageHistory.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHPAGEHISTORY_H__)
24# define __XTPFLOWGRAPHPAGEHISTORY_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphNodes;
35class CXTPFlowGraphNodeGroups;
36class CXTPFlowGraphConnections;
37class CXTPFlowGraphDrawContext;
38class CXTPPropExchange;
39class CXTPFlowGraphSelectedElements;
40class CXTPFlowGraphNode;
41
46struct CXTPFlowGraphPageHistoryItem
47{
48 CXTPFlowGraphNode* pFrom;
49 CXTPFlowGraphNode* pTo;
50};
51
56class _XTP_EXT_CLASS CXTPFlowGraphPageHistory : public CXTPCmdTarget
57{
58public:
64 CXTPFlowGraphPageHistory(CXTPFlowGraphControl* pControl);
65
66protected:
72 virtual ~CXTPFlowGraphPageHistory();
73
74public:
79 void GoForward();
84 void GoBackward();
85
92 BOOL CanGoForward() const;
102 BOOL CanGoBackward() const;
103
108 void Clear();
109
121 void AnimatePageTransition(CXTPFlowGraphNode* pNodeFrom, CXTPFlowGraphNode* pNodeTo);
122
123protected:
124 CXTPFlowGraphControl* m_pControl;
126 CArray<CXTPFlowGraphPageHistoryItem, CXTPFlowGraphPageHistoryItem&>
127 m_arrPageUndo;
128 CArray<CXTPFlowGraphPageHistoryItem, CXTPFlowGraphPageHistoryItem&>
129 m_arrPageRedo;
131# ifdef _XTP_ACTIVEX
133 DECLARE_DISPATCH_MAP()
134 DECLARE_INTERFACE_MAP()
135 DECLARE_OLETYPELIB_EX(CXTPFlowGraphPageHistory);
136
137 void OleAnimatePageTransition(LPDISPATCH lpDispFrom, LPDISPATCH lpDispTo);
138
140# endif
141};
143# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
144#endif //#if !defined(__XTPFLOWGRAPHPAGEHISTORY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPFlowGraphConnections
Represents a collection of connections for a Node.
Definition XTPFlowGraphConnections.h:41
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphNodeGroups
Represents a collection of groups in a page.
Definition XTPFlowGraphNodeGroups.h:46
CXTPFlowGraphNode
Represents a Node object.
Definition XTPFlowGraphNode.h:116
CXTPFlowGraphNodes
Represents a collection of Nodes in a page or group.
Definition XTPFlowGraphNodes.h:48
CXTPFlowGraphPageHistory
Object that contains page transition history for the flow graph.
Definition XTPFlowGraphPageHistory.h:57
CXTPFlowGraphPageHistory::AnimatePageTransition
void AnimatePageTransition(CXTPFlowGraphNode *pNodeFrom, CXTPFlowGraphNode *pNodeTo)
This method will transition from a Node on the current page to a Node on a different page.
CXTPFlowGraphPageHistory::CXTPFlowGraphPageHistory
CXTPFlowGraphPageHistory(CXTPFlowGraphControl *pControl)
Constructs a CXTPFlowGraphPageHistory object.
CXTPFlowGraphPageHistory::~CXTPFlowGraphPageHistory
virtual ~CXTPFlowGraphPageHistory()
Destroys a CXTPFlowGraphPageHistory object, handles cleanup and deallocation.
CXTPFlowGraphPageHistory::CanGoBackward
BOOL CanGoBackward() const
Checks if a GoBack operation can be performed.
CXTPFlowGraphPageHistory::m_pControl
CXTPFlowGraphControl * m_pControl
Pointer to the parent flow graph control.
Definition XTPFlowGraphPageHistory.h:124
CXTPFlowGraphPageHistory::Clear
void Clear()
Clears the history of the flow graph.
CXTPFlowGraphPageHistory::GoForward
void GoForward()
Moves to the next page in the flow graph's history (if available).
CXTPFlowGraphPageHistory::m_arrPageUndo
CArray< CXTPFlowGraphPageHistoryItem, CXTPFlowGraphPageHistoryItem & > m_arrPageUndo
Contains all the undo actions from the history.
Definition XTPFlowGraphPageHistory.h:127
CXTPFlowGraphPageHistory::GoBackward
void GoBackward()
Moves to the previous page in the flow graph's history (if available).
CXTPFlowGraphPageHistory::m_arrPageRedo
CArray< CXTPFlowGraphPageHistoryItem, CXTPFlowGraphPageHistoryItem & > m_arrPageRedo
Contains all the redo actions from the history.
Definition XTPFlowGraphPageHistory.h:129
CXTPFlowGraphPageHistory::CanGoForward
BOOL CanGoForward() const
Checks if a GoForward operation can be performed.
CXTPFlowGraphSelectedElements
Collection of selected elements in the flow graph.
Definition XTPFlowGraphSelectedElements.h:46
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPFlowGraphPageHistoryItem
Used internally to store Node history for history operations.
Definition XTPFlowGraphPageHistory.h:47
CXTPFlowGraphPageHistoryItem::pFrom
CXTPFlowGraphNode * pFrom
Pointer to the previous Node.
Definition XTPFlowGraphPageHistory.h:48
CXTPFlowGraphPageHistoryItem::pTo
CXTPFlowGraphNode * pTo
Pointer to the destination Node.
Definition XTPFlowGraphPageHistory.h:49


CXTPCalendarCaptionBarOffice2013Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarOffice2013Theme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual


CXTPChartRadarAxisYViewTick Member List

This is the complete list of members for CXTPChartRadarAxisYViewTick, including all inherited members.

m_dValue | CXTPChartRadarAxisYViewTick
m_strLabel | CXTPChartRadarAxisYViewTick
m_szBounds | CXTPChartRadarAxisYViewTick
m_szLabel | CXTPChartRadarAxisYViewTick


CXTPColorDialog Member List

This is the complete list of members for CXTPColorDialog, including all inherited members.

CalculateRects() | CXTPColorDialog | virtual
CopyToClipboard(const CString &strText) | CXTPColorDialog |
CXTPColorDialog(COLORREF clrNew, COLORREF clrCurrent, DWORD dwFlags=0L, CWnd *pWndParent=NULL) | CXTPColorDialog |
GetColor() | CXTPColorDialog |
GetCurrentColor() | CXTPColorDialog |
m_clrCurrent | CXTPColorDialog | protected
m_clrNew | CXTPColorDialog | protected
m_dwStyle | CXTPColorDialog | protected
m_rcCurrent | CXTPColorDialog | protected
m_rcNew | CXTPColorDialog | protected
m_wndEyeDropper | CXTPColorDialog | protected
m_wndHexEdit | CXTPColorDialog | protected
RGBtoHex(COLORREF clr) | CXTPColorDialog | static
SetCurrentColor(COLORREF clr) | CXTPColorDialog |
SetNewColor(COLORREF clr, BOOL bNotify=TRUE) | CXTPColorDialog |
~CXTPColorDialog() | CXTPColorDialog | virtual


CXTPMultiMonitor Member List

This is the complete list of members for CXTPMultiMonitor, including all inherited members.

GetDisplaySettings(const CWnd *pWnd, DEVMODE *lpDevMode) | CXTPMultiMonitor |
GetDisplaySettings(HWND hWnd, DEVMODE *lpDevMode) | CXTPMultiMonitor |
GetScreenArea(const CWnd *pWnd) | CXTPMultiMonitor |
GetScreenArea(HWND hWnd) | CXTPMultiMonitor |
GetScreenArea(const POINT &point) | CXTPMultiMonitor |
GetScreenArea(LPCRECT rect) | CXTPMultiMonitor |
GetWorkArea() | CXTPMultiMonitor |
GetWorkArea(const POINT &point) | CXTPMultiMonitor |
GetWorkArea(LPCRECT rect) | CXTPMultiMonitor |
GetWorkArea(const CWnd *pWnd) | CXTPMultiMonitor |
GetWorkArea(HWND hWnd) | CXTPMultiMonitor |
XTPMultiMonitor() | CXTPMultiMonitor | friend


XTP_DOCKINGPANE_CLICK Member List

This is the complete list of members for XTP_DOCKINGPANE_CLICK, including all inherited members.

pContainer | XTP_DOCKINGPANE_CLICK
pPane | XTP_DOCKINGPANE_CLICK
pt | XTP_DOCKINGPANE_CLICK
rcExclude | XTP_DOCKINGPANE_CLICK


CXTPMarkupRadioButton Member List

This is the complete list of members for CXTPMarkupRadioButton, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
CXTPMarkupContentControl() | CXTPMarkupContentControl | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupRadioButton() | CXTPMarkupRadioButton | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupControl |
GetBoundRect() const | CXTPMarkupVisual |
GetChecked() const | CXTPMarkupToggleButton |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetContent() const | CXTPMarkupContentControl |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetForeground() const | CXTPMarkupControl |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupControl |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsPressed() const | CXTPMarkupButtonBase |
IsThreeState() const | CXTPMarkupToggleButton |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnChecked(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
OnClick() | CXTPMarkupToggleButton | protectedvirtual
OnIndeterminate(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnToggle() | CXTPMarkupToggleButton | protectedvirtual
OnUnchecked(CXTPMarkupRoutedEventArgs *e) | CXTPMarkupToggleButton | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetChecked(BOOL bChecked) | CXTPMarkupToggleButton |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetContent(CXTPMarkupUIElement *pContent) | CXTPMarkupContentControl |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupControl |
SetPadding(int nPadding) | CXTPMarkupControl |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetThreeState(BOOL bThreeState) | CXTPMarkupToggleButton |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
~CXTPMarkupContentControl() | CXTPMarkupContentControl | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupRadioButton() | CXTPMarkupRadioButton | protected
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPTabColorSetVisualStudio2012.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETVISUALSTUDIO2012_H__)
24# define __XTPTABCOLORSETVISUALSTUDIO2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetVisualStudio2012 : public CXTPTabPaintManagerColorSet
38{
39public:
40 CXTPTabColorSetVisualStudio2012();
41
49 virtual void RefreshMetrics();
50
64 virtual COLORREF GetItemColor(CXTPTabManagerItem* pItem);
65
82 virtual void FillNavigateButton(CDC* pDC, CXTPTabManagerNavigateButton* pButton, CRect& rc);
83
91 virtual COLORREF GetClientColor(CXTPTabManager* pTabManager);
92
93protected:
94 CXTPPaintManagerColor m_clrNonActiveButtonNormal;
95 CXTPPaintManagerColor m_clrNonActiveButtonPressed;
96 CXTPPaintManagerColor m_clrNonActiveButtonHighlighted;
97 CXTPPaintManagerColor m_clrNonActiveButtonHighlightedClose;
98 CXTPPaintManagerColor m_clrNonActiveButtonSelected;
99 CXTPPaintManagerColor m_clrNonActiveButtonSelectedPressed;
100 CXTPPaintManagerColor m_clrNonActiveButtonSelectedHighlighted;
101 CXTPPaintManagerColor m_clrNonActiveButtonBorderHot;
102 CXTPPaintManagerColor m_clrNonActiveText;
103 CXTPPaintManagerColor m_clrNonActiveTextPressed;
104 CXTPPaintManagerColor m_clrNonActiveTextHighlighted;
105 CXTPPaintManagerColor m_clrNonActiveTextHighlightedClose;
106 CXTPPaintManagerColor m_clrNonActiveTextSelected;
107 CXTPPaintManagerColor m_clrNonActiveTextSelectedPressed;
108 CXTPPaintManagerColor m_clrNonActiveTextSelectedHighlighted;
109 CXTPPaintManagerColor m_clrNonActiveActiveFilesGlyph;
110 CXTPPaintManagerColor m_clrNonActiveActiveFilesGlyphPressed;
111 CXTPPaintManagerColor m_clrNonActiveActiveFilesGlyphHighlighted;
112 CXTPPaintManagerColor m_clrNonActiveActiveFilesBack;
113 CXTPPaintManagerColor m_clrNonActiveActiveFilesBackPressed;
114 CXTPPaintManagerColor m_clrNonActiveActiveFilesBackHighlighted;
115 CXTPPaintManagerColor m_clrNonActiveFrameBorder;
116 CXTPPaintManagerColor m_clrNonActiveButtonBorder;
117 CXTPPaintManagerColor m_clrNonActiveAutoHideFace;
118 CXTPPaintManagerColor m_clrNonActiveHeaderFace;
119};
120
121# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
123#endif // !defined(__XTPTABCOLORSETVISUALSTUDIO2012_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTabColorSetVisualStudio2012
CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set.
Definition XTPTabColorSetVisualStudio2012.h:38
CXTPTabColorSetVisualStudio2012::GetItemColor
virtual COLORREF GetItemColor(CXTPTabManagerItem *pItem)
Retrieves the color of a specified tab.
CXTPTabColorSetVisualStudio2012::FillNavigateButton
virtual void FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc)
Fills a specified tab navigation button.
CXTPTabColorSetVisualStudio2012::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetVisualStudio2012::GetClientColor
virtual COLORREF GetClientColor(CXTPTabManager *pTabManager)
Obtains client background color.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabManagerNavigateButton
CXTPTabManagerNavigateButton is a class used to represent a tab navigation button.
Definition XTPTabManagerNavigateButton.h:74
CXTPTabPaintManagerColorSet
CXTPTabPaintManagerColorSet represents the colors for all of the components of the tab manager (e....
Definition XTPTabPaintManagerColorSet.h:50


CXTPGridRecordItemConstraints Member List

This is the complete list of members for CXTPGridRecordItemConstraints, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItemConstraints() | CXTPGridRecordItemConstraints |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPGridRecordItemConstraints |
GetCount() const | CXTPGridRecordItemConstraints |
m_arrConstraints | CXTPGridRecordItemConstraints | protected
RemoveAll() | CXTPGridRecordItemConstraints |
~CXTPGridRecordItemConstraints() | CXTPGridRecordItemConstraints |


Toolkit Pro: XTPMessageBarThemeVisualStudio2017.h Source File

  • Source
  • CommandBars
  • MessageBar
XTPMessageBarThemeVisualStudio2017.h
Go to the documentation of this file.
1
23#if !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2017_H__)
24# define __XTPMESSAGEBARTHEMEVISUALSTUDIO2017_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPMessageBar;
35class CXTPMessageBarButton;
36
42class _XTP_EXT_CLASS CXTPMessageBarThemeVisualStudio2017 : public CXTPMessageBarThemeOffice2013
43{
44public:
50 CXTPMessageBarThemeVisualStudio2017(CXTPPaintManager* pPaintManager);
51};
52
54# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
55#endif // !defined(__XTPMESSAGEBARTHEMEVISUALSTUDIO2017_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarThemeOffice2013
The CXTPMessageBarThemeOffice2013 class is used by the message bar to draw an Office 2013 style messa...
Definition XTPMessageBarThemeOffice2013.h:43
CXTPMessageBarThemeVisualStudio2017
The CXTPMessageBarThemeVisualStudio2017 class is used by the message bar to draw a Visual Studio 2017...
Definition XTPMessageBarThemeVisualStudio2017.h:43
CXTPMessageBarThemeVisualStudio2017::CXTPMessageBarThemeVisualStudio2017
CXTPMessageBarThemeVisualStudio2017(CXTPPaintManager *pPaintManager)
Message bar constructor.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPWebBrowserCtrl.h Source File

  • Source
  • Controls
  • WebBrowser
XTPWebBrowserCtrl.h
Go to the documentation of this file.
1
22#if !defined(__XTPWEBBROWSERCTRL_H__)
24# define __XTPWEBBROWSERCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
32# include <atlbase.h>
33# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
34
35# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36
38class CXTPWebBrowserProvider;
45enum XTPWebBrowserProvider
46{
47 xtpWebBrowserInvalid = -1,
48 xtpWebBrowserShellExplorer,
50 xtpWebBrowserWebView,
52 xtpWebBrowserLatest = xtpWebBrowserWebView
54};
55
63class _XTP_EXT_CLASS CXTPWebBrowserCtrl
64 : public CWnd
65 , private IXTPWebBrowserHost
66{
68 DECLARE_DYNAMIC(CXTPWebBrowserCtrl)
70public:
80 CXTPWebBrowserCtrl(XTPWebBrowserProvider nProvider = xtpWebBrowserLatest);
81
86 virtual ~CXTPWebBrowserCtrl();
87
95 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
96
112 virtual BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID,
113 CCreateContext* pContext = NULL);
114
137 virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight,
138 HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam = NULL);
139
158 virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
159 UINT nID, LPVOID lpParam = NULL);
160
161 using CWnd::Create;
162 using CWnd::CreateEx;
163
188 virtual const COleVariant* GetProperty(const CString& strName) const;
189
215 void SetProperty(const CString& strName, COleVariant* pvtValue);
216
226 BOOL ReCreateProvider();
227
234 XTPWebBrowserProvider GetProviderType() const;
235
245 BOOL SetProviderType(XTPWebBrowserProvider nProvider);
246
255 CXTPWebBrowserProvider* GetProvider() const;
256
267 IUnknown* GetBrowserObject() const;
268
277 IXTPWebBrowserEventSink* GetEventSink() const;
278
286 void SetEventSink(IXTPWebBrowserEventSink* pEventSink);
287
298 HRESULT Navigate(LPCTSTR pUrl);
299
310 HRESULT LoadHtml(LPCTSTR pHtml);
311
320 HRESULT WaitUntilReady();
321
334 HRESULT ExecuteScript(LPCWSTR pText, CComVariant* pvtResult = NULL);
335
346 virtual IDispatch* GetExternal() const;
347
357 void SetExternal(IDispatch* pExternal);
358
359protected:
361 DECLARE_MESSAGE_MAP()
362 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
363 virtual void PreSubclassWindow();
364 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
367private:
368 // IXTPWebBrowserHost overrides
369
370 virtual IUnknown* GetHostUnknown() const;
371 virtual CWnd& GetHostWindow() const;
372
373 virtual void ShellExplorer_OnStatusTextChange(LPCTSTR lpszText);
374 virtual void ShellExplorer_OnProgressChange(long nProgress, long nProgressMax);
375 virtual void ShellExplorer_OnCommandStateChange(long nCommand, BOOL bEnable);
376 virtual void ShellExplorer_OnDownloadBegin();
377 virtual void ShellExplorer_OnDownloadComplete();
378 virtual void ShellExplorer_OnTitleChange(LPCTSTR lpszText);
379 virtual void ShellExplorer_OnPropertyChange(LPCTSTR lpszProperty);
380 virtual void ShellExplorer_OnNewWindow2(LPDISPATCH* ppDisp, BOOL* pbCancel);
381 virtual void ShellExplorer_OnQuit();
382 virtual void ShellExplorer_OnVisible(BOOL bVisible);
383 virtual void ShellExplorer_OnToolBar(BOOL bToolBar);
384 virtual void ShellExplorer_OnMenuBar(BOOL bMenuBar);
385 virtual void ShellExplorer_OnStatusBar(BOOL bStatusBar);
386 virtual void ShellExplorer_OnFullScreen(BOOL bFullScreen);
387 virtual void ShellExplorer_OnTheaterMode(BOOL bTheaterMode);
388 virtual void ShellExplorer_OnNavigateComplete2(LPDISPATCH pDisp, VARIANT* pvtURL);
389 virtual void ShellExplorer_OnBeforeNavigate2(LPDISPATCH pDisp, VARIANT* pvtURL,
390 VARIANT* pvtFlags, VARIANT* pvtTargetFrameName,
391 VARIANT* pvtPostData, VARIANT* pvtHeaders,
392 BOOL* pbCancel);
393 virtual void ShellExplorer_OnDocumentComplete(LPDISPATCH pDisp, VARIANT* pvtURL);
394 virtual void ShellExplorer_OnNavigateError(LPDISPATCH pDisp, VARIANT* pvtURL,
395 VARIANT* pvtTargetFrameName, VARIANT* pvtStatusCode,
396 BOOL* pbCancel);
397 virtual void ShellExplorer_OnWindowSetResizable(BOOL bResizable);
398 virtual void ShellExplorer_OnWindowSetLeft(long nLeft);
399 virtual void ShellExplorer_OnWindowSetTop(long nTop);
400 virtual void ShellExplorer_OnWindowSetWidth(long nWidth);
401 virtual void ShellExplorer_OnWindowSetHeight(long nHeight);
402 virtual void ShellExplorer_OnWindowClosing(BOOL bIsChildWindow, BOOL FAR* pbCancel);
403 virtual void ShellExplorer_OnSetSecureLockIcon(long nSecureLockIcon);
404
405 virtual HRESULT WebView2_NavigationStarting(ICoreWebView2NavigationStartingEventArgs* args);
406 virtual HRESULT WebView2_ContentLoading(ICoreWebView2ContentLoadingEventArgs* args);
407 virtual HRESULT WebView2_SourceChanged(ICoreWebView2SourceChangedEventArgs* args);
408 virtual HRESULT WebView2_HistoryChanged(IUnknown* args);
409 virtual HRESULT WebView2_NavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args);
410 virtual HRESULT WebView2_FrameNavigationStarting(ICoreWebView2NavigationStartingEventArgs* args);
411 virtual HRESULT
412 WebView2_FrameNavigationCompleted(ICoreWebView2NavigationCompletedEventArgs* args);
413 virtual HRESULT WebView2_ScriptDialogOpening(ICoreWebView2ScriptDialogOpeningEventArgs* args);
414 virtual HRESULT WebView2_PermissionRequested(ICoreWebView2PermissionRequestedEventArgs* args);
415 virtual HRESULT WebView2_ProcessFailed(ICoreWebView2ProcessFailedEventArgs* args);
416 virtual HRESULT WebView2_NewWindowRequested(ICoreWebView2NewWindowRequestedEventArgs* args);
417 virtual HRESULT WebView2_DocumentTitleChanged(IUnknown* args);
418 virtual HRESULT WebView2_ContainsFullScreenElementChanged(IUnknown* args);
419 virtual HRESULT WebView2_WebResourceRequested(ICoreWebView2WebResourceRequestedEventArgs* args);
420 virtual HRESULT WebView2_WindowCloseRequested(IUnknown* args);
421
422private:
423 BOOL IsValid() const;
424 BOOL InitializeProvider();
425 void ReleaseProvider();
426 BOOL FallbackProvider();
427
428 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
429 afx_msg void OnDestroy();
430 afx_msg void OnWindowPosChanging(WINDOWPOS* lpwndpos);
431 afx_msg void OnWindowPosChanged(WINDOWPOS* lpwndpos);
432
433private:
434 static const UINT m_WM_INITIALIZE;
435 XTPWebBrowserProvider m_nProvider;
436 CXTPWebBrowserProvider* m_pProvider;
437 BOOL m_bSubclassed;
438 CString m_strPendlingUrl;
439 IXTPWebBrowserEventSink* m_pEventSink;
440 IDispatch* m_pExternal;
441 CMap<CString, LPCTSTR, COleVariant*, COleVariant*> m_mapProps;
442};
444AFX_INLINE CXTPWebBrowserProvider* CXTPWebBrowserCtrl::GetProvider() const
445{
446 return const_cast< CXTPWebBrowserCtrl*>(this)->m_pProvider;
447}
448
449AFX_INLINE XTPWebBrowserProvider CXTPWebBrowserCtrl::GetProviderType() const
450{
451 return m_nProvider;
452}
453
454AFX_INLINE void CXTPWebBrowserCtrl::SetEventSink(IXTPWebBrowserEventSink* pEventSink)
455{
456 m_pEventSink = pEventSink;
457}
458
459AFX_INLINE IXTPWebBrowserEventSink* CXTPWebBrowserCtrl::GetEventSink() const
460{
461 return m_pEventSink;
462}
463
464AFX_INLINE IDispatch* CXTPWebBrowserCtrl::GetExternal() const
465{
466 return m_pExternal;
467}
469# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
471#endif // #if !defined(__XTPWEBBROWSERCTRL_H__)
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
XTPWebBrowserProvider
XTPWebBrowserProvider
Defines possible WebBrowser providers.
Definition XTPWebBrowserCtrl.h:46
xtpWebBrowserLatest
@ xtpWebBrowserLatest
Specifies the latest supported WebBrowser provider.
Definition XTPWebBrowserCtrl.h:52
xtpWebBrowserShellExplorer
@ xtpWebBrowserShellExplorer
Specifies the ShellExplorer WebBrowser provider, which is also used by the Microsoft Internet Explore...
Definition XTPWebBrowserCtrl.h:48
xtpWebBrowserWebView
@ xtpWebBrowserWebView
Specifies the WebView2 WebBrowser provider, which is also used by the Microsoft Edge browser.
Definition XTPWebBrowserCtrl.h:50
xtpWebBrowserInvalid
@ xtpWebBrowserInvalid
Specifies an invalid WebBrowser provider.
Definition XTPWebBrowserCtrl.h:47
CXTPWebBrowserCtrl
Implements the WebBrowser control that is capable of hosting different supported Web browsers.
Definition XTPWebBrowserCtrl.h:66
CXTPWebBrowserCtrl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPWebBrowserCtrl::ReCreateProvider
BOOL ReCreateProvider()
Re-creates the current provider, i.e.
CXTPWebBrowserCtrl::ExecuteScript
HRESULT ExecuteScript(LPCWSTR pText, CComVariant *pvtResult=NULL)
Executes a script by the active WebBrowser provider.
CXTPWebBrowserCtrl::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, LPVOID lpParam=NULL)
Creates a preview control window object.
CXTPWebBrowserCtrl::GetProvider
CXTPWebBrowserProvider * GetProvider() const
Obtains the active WebBrowser provider object or NULL if no provider has been activated yet or provid...
CXTPWebBrowserCtrl::Create
virtual BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID, CCreateContext *pContext=NULL)
Creates a preview control window object.
CXTPWebBrowserCtrl::SetEventSink
void SetEventSink(IXTPWebBrowserEventSink *pEventSink)
Sets the event sink interface for handling WebBrowser events.
CXTPWebBrowserCtrl::~CXTPWebBrowserCtrl
virtual ~CXTPWebBrowserCtrl()
Handles control destruction.
CXTPWebBrowserCtrl::SetProperty
void SetProperty(const CString &strName, COleVariant *pvtValue)
Sets custom properties that providers can use if provided.
CXTPWebBrowserCtrl::LoadHtml
HRESULT LoadHtml(LPCTSTR pHtml)
Loads specified HTML code.
CXTPWebBrowserCtrl::Navigate
HRESULT Navigate(LPCTSTR pUrl)
Performs navigation to the specified URL.
CXTPWebBrowserCtrl::CreateEx
virtual BOOL CreateEx(DWORD dwExStyle, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU nIDorHMenu, LPVOID lpParam=NULL)
Creates a preview control window object.
CXTPWebBrowserCtrl::CXTPWebBrowserCtrl
CXTPWebBrowserCtrl(XTPWebBrowserProvider nProvider=xtpWebBrowserLatest)
Handles control construction.
CXTPWebBrowserCtrl::SetExternal
void SetExternal(IDispatch *pExternal)
Sets the object to be used by the "window.external" propery in the script execution context.
CXTPWebBrowserCtrl::WaitUntilReady
HRESULT WaitUntilReady()
Waits until an initiated navigation completes.
CXTPWebBrowserCtrl::SetProviderType
BOOL SetProviderType(XTPWebBrowserProvider nProvider)
Sets the active WebBrowser provider type.
CXTPWebBrowserCtrl::GetProviderType
XTPWebBrowserProvider GetProviderType() const
Obtains the active WebBrowser provider type.
CXTPWebBrowserCtrl::GetEventSink
IXTPWebBrowserEventSink * GetEventSink() const
Gets the event sink interface for handling WebBrowser events.
CXTPWebBrowserCtrl::GetProperty
virtual const COleVariant * GetProperty(const CString &strName) const
Gets custom properties that providers can use if provided.
CXTPWebBrowserCtrl::GetExternal
virtual IDispatch * GetExternal() const
Gets the object to be used by the "window.external" propery in the script execution context.
CXTPWebBrowserCtrl::GetBrowserObject
IUnknown * GetBrowserObject() const
Obtains the native WebBrowser provider object or NULL if no provider is activated or the current prov...
CXTPWebBrowserProvider
Implements the base class for a WebBrowser provider.
Definition XTPWebBrowserProvider.h:56
IXTPWebBrowserEventSink
Describes default WebBrowser control event sink interface and providers default implementation of the...
Definition XTPWebBrowserAbstract.h:112


Toolkit Pro: XTPPropertyGridInplaceList.h Source File

  • Source
  • PropertyGrid
XTPPropertyGridInplaceList.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPERTYGRIDINPLACELIST_H__)
24# define __XTPPROPERTYGRIDINPLACELIST_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33// class forwards.
34
35class CXTPPropertyGridView;
36class CXTPPropertyGridItem;
37
43class _XTP_EXT_CLASS CXTPPropertyGridInplaceList : public CListBox
44{
46 DECLARE_DYNAMIC(CXTPPropertyGridInplaceList)
48public:
53 CXTPPropertyGridInplaceList();
54
60 virtual ~CXTPPropertyGridInplaceList();
61
68 virtual void Create(CXTPPropertyGridItem* pItem, CRect rect);
69
74 virtual void DestroyItem();
75
76private:
77 CXTPPropertyGridItem* m_pItem;
78
79protected:
84 virtual void Cancel();
85
90 virtual void Apply();
91
92protected:
94 DECLARE_MESSAGE_MAP()
95
96 //{{AFX_VIRTUAL(CXTPPropertyGridInplaceList)
97 void PostNcDestroy();
98 void DrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct);
99 void MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct);
100 BOOL PreTranslateMessage(MSG* pMsg);
101 //}}AFX_VIRTUAL
102
103 //{{AFX_MSG(CXTPPropertyGridInplaceList)
104 afx_msg void OnKillFocus(CWnd* pNewWnd);
105 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
106 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
107 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
108 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
109 afx_msg UINT OnGetDlgCode();
110 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
111 afx_msg void OnNcPaint();
112 //}}AFX_MSG
115public:
116 static BOOL m_bShowShadow;
117 static BOOL m_bTrackSelection;
118private:
119 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
120 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
121 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
122
123 friend class CXTPPropertyGridItem;
124};
125
131class _XTP_EXT_CLASS CXTPPropertyGridInplaceMultilineEdit : public CEdit
132{
134 DECLARE_DYNAMIC(CXTPPropertyGridInplaceMultilineEdit)
136public:
141 CXTPPropertyGridInplaceMultilineEdit();
142
148 virtual ~CXTPPropertyGridInplaceMultilineEdit();
149
156 virtual void Create(CXTPPropertyGridItem* pItem, CRect rect);
157
158private:
159 CXTPPropertyGridItem* m_pItem;
160
161protected:
166 virtual void Cancel();
167
172 virtual void Apply();
173
174protected:
176 DECLARE_MESSAGE_MAP()
177
178 //{{AFX_VIRTUAL(CXTPPropertyGridInplaceList)
179 void PostNcDestroy();
180 BOOL PreTranslateMessage(MSG* pMsg);
181 //}}AFX_VIRTUAL
182
183 //{{AFX_MSG(CXTPPropertyGridInplaceList)
184 afx_msg void OnKillFocus(CWnd* pNewWnd);
185 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
186 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
187 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
188 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
189 afx_msg UINT OnGetDlgCode();
190 //}}AFX_MSG
193private:
194 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
195 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
196 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
197
198 friend class CXTPPropertyGridItem;
199};
200
202
203AFX_INLINE BOOL CXTPPropertyGridInplaceList::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
204 DWORD dwStyle, const RECT& rect,
205 CWnd* pParentWnd, UINT nID,
206 CCreateContext* pContext)
207{
208 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
209}
210AFX_INLINE BOOL CXTPPropertyGridInplaceList::Create(DWORD dwStyle, const RECT& rect,
211 CWnd* pParentWnd, UINT nID)
212{
213 return CListBox::Create(dwStyle, rect, pParentWnd, nID);
214}
215
216AFX_INLINE BOOL CXTPPropertyGridInplaceMultilineEdit::Create(LPCTSTR lpszClassName,
217 LPCTSTR lpszWindowName, DWORD dwStyle,
218 const RECT& rect, CWnd* pParentWnd,
219 UINT nID, CCreateContext* pContext)
220{
221 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
222}
223AFX_INLINE BOOL CXTPPropertyGridInplaceMultilineEdit::Create(DWORD dwStyle, const RECT& rect,
224 CWnd* pParentWnd, UINT nID)
225{
226 return CEdit::Create(dwStyle, rect, pParentWnd, nID);
227}
229# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
230#endif // #if !defined(__XTPPROPERTYGRIDINPLACELIST_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropertyGridInplaceList
CXTPPropertyGridInplaceList is a CListBox derived class.
Definition XTPPropertyGridInplaceList.h:44
CXTPPropertyGridInplaceList::CXTPPropertyGridInplaceList
CXTPPropertyGridInplaceList()
Constructs a CXTPPropertyGridInplaceList object.
CXTPPropertyGridInplaceList::Create
virtual void Create(CXTPPropertyGridItem *pItem, CRect rect)
Creates an in-place list control.
CXTPPropertyGridInplaceList::DestroyItem
virtual void DestroyItem()
This method is called when the parent item is destroyed.
CXTPPropertyGridInplaceList::~CXTPPropertyGridInplaceList
virtual ~CXTPPropertyGridInplaceList()
Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.
CXTPPropertyGridInplaceList::Cancel
virtual void Cancel()
Call this method to cancel user changes.
CXTPPropertyGridInplaceList::Apply
virtual void Apply()
Call this method to apply user changes.
CXTPPropertyGridInplaceMultilineEdit
CXTPPropertyGridInplaceMultilineEdit is a CEdit derived class.
Definition XTPPropertyGridInplaceList.h:132
CXTPPropertyGridInplaceMultilineEdit::Create
virtual void Create(CXTPPropertyGridItem *pItem, CRect rect)
Creates an in-place control.
CXTPPropertyGridInplaceMultilineEdit::CXTPPropertyGridInplaceMultilineEdit
CXTPPropertyGridInplaceMultilineEdit()
Constructs a CXTPPropertyGridInplaceList object.
CXTPPropertyGridInplaceMultilineEdit::Cancel
virtual void Cancel()
Call this method to cancel user changes.
CXTPPropertyGridInplaceMultilineEdit::~CXTPPropertyGridInplaceMultilineEdit
virtual ~CXTPPropertyGridInplaceMultilineEdit()
Destroys a CXTPPropertyGridInplaceList object, handles cleanup and deallocation.
CXTPPropertyGridInplaceMultilineEdit::Apply
virtual void Apply()
Call this method to apply user changes.
CXTPPropertyGridItem
CXTPPropertyGridItem is the base class representing an item of the Property Grid control.
Definition XTPPropertyGridItem.h:523
CXTPPropertyGridView
CXTPPropertyGridView is a CListBox derived class.
Definition XTPPropertyGridView.h:49


CXTPMarkupTreeCtrl Member List

This is the complete list of members for CXTPMarkupTreeCtrl, including all inherited members.

AddCustomScriptItem(LPCWSTR lpName, LPDISPATCH pDisp) | CXTPMarkupContext |
AddHandler(CXTPMarkupRoutedEvent *pEvent, CXTPMarkupDelegate *pDelegate) | CXTPMarkupContext |
AddItem(LPCTSTR lpszItem, int nImage, int nSelectedImage, HTREEITEM hParent=TVI_ROOT, HTREEITEM hInsertAfter=TVI_LAST) | CXTPMarkupTreeCtrl |
CXTPMarkupContext() | CXTPMarkupContext |
CXTPMarkupTreeCtrl() | CXTPMarkupTreeCtrl |
CXTPTreeCtrl() | CXTPTreeCtrl |
DrawMarkupItem(NMTVCUSTOMDRAW *lpLVCD) | CXTPMarkupTreeCtrl | protected
EnableGdiPlus(BOOL bEnable) | CXTPMarkupContext |
GetClientSite() const | CXTPMarkupContext |
GetContextWindow() const | CXTPMarkupContext |
GetCustomToolTipPosition() const | CXTPMarkupContext |
GetDefaultForeground() | CXTPMarkupContext |
GetDefaultLogFont() | CXTPMarkupContext |
GetDefaultSmoothingMode() const | CXTPMarkupContext |
GetDefaultTextSmoothing() const | CXTPMarkupContext |
GetExtensionRoot() | CXTPMarkupContext |
GetImageColorKey() const | CXTPMarkupContext |
GetImageManager() const | CXTPMarkupContext |
GetItemTextExtent(CDC *pDC, LPCTSTR lpszText, int nCount) const | CXTPMarkupTreeCtrl | protected
GetMarkupContext() | CXTPMarkupTreeCtrl |
GetPlainMarkupItemText(CXTPMarkupUIElement *pUIElement) const | CXTPMarkupTreeCtrl | protected
GetScriptEngine() | CXTPMarkupContext |
GetToolTipContext() const | CXTPMarkupContext |
GetUseCustomToolTipPosition() const | CXTPMarkupContext |
HitTestMarkupItem(CPoint point) | CXTPMarkupTreeCtrl | protected
IsDpiAware() const | CXTPMarkupContext |
IsGdiPlusEnabled() const | CXTPMarkupContext |
LoadScriptCodeChunk(CXTPMarkupBuilder *pBuilder, LPCWSTR lpszLanguage, LPCWSTR lpszCode, LPCWSTR lpszRequires=NULL) | CXTPMarkupContext |
Parse(LPCSTR lpszBuffer) | CXTPMarkupContext |
Parse(LPCWSTR lpszBuffer) | CXTPMarkupContext |
RemoveCustomScriptItem(LPCWSTR lpName) | CXTPMarkupContext |
RunScriptEngine(CXTPMarkupBuilder *pBuilder) | CXTPMarkupContext |
Scale(const SIZE &size) const | CXTPMarkupContext |
ScaleX(int x) const | CXTPMarkupContext |
ScaleX(float x) const | CXTPMarkupContext |
ScaleX(double x) const | CXTPMarkupContext |
ScaleY(int y) const | CXTPMarkupContext |
ScaleY(float y) const | CXTPMarkupContext |
ScaleY(double y) const | CXTPMarkupContext |
SetClientSite(IXTPMarkupClientSite *pSite) | CXTPMarkupContext |
SetContextWindow(HWND hWnd, LPCRECT pUpdateRect=NULL) | CXTPMarkupContext |
SetDefaultFont(HFONT font) | CXTPMarkupContext |
SetDefaultFont(LOGFONT *font) | CXTPMarkupContext |
SetDefaultSmoothingMode(XTPMarkupSmoothingMode smoothingMode) | CXTPMarkupContext |
SetDefaultTextColor(COLORREF clr) | CXTPMarkupContext |
SetDefaultTextSmoothing(BOOL bEnableTextSmoothing) | CXTPMarkupContext |
SetDelegate(LPCWSTR lpszDelegate, CXTPMarkupDelegate *pDelegate) | CXTPMarkupContext |
SetDpiAware(BOOL bSet=TRUE) | CXTPMarkupContext |
SetDpiAware(BOOL bSet, HWND hWnd) | CXTPMarkupContext |
SetDpiAware(BOOL bSet, HDC hDC) | CXTPMarkupContext |
SetImageColorKey(COLORREF crColorKey) | CXTPMarkupContext |
SetImageManager(CXTPImageManager *pImageManager) | CXTPMarkupContext |
SetUseCustomToolTipPosition(BOOL bUse, CPoint ptPos=CPoint(0, 0)) | CXTPMarkupContext |
Shutdown() | CXTPMarkupContext |
ValidateXML(LPCSTR lpszBuffer) | CXTPMarkupContext |
ValidateXML(LPCWSTR lpszBuffer) | CXTPMarkupContext |
~CXTPMarkupContext() | CXTPMarkupContext | protectedvirtual
~CXTPMarkupTreeCtrl() | CXTPMarkupTreeCtrl | virtual
~CXTPTreeCtrl() | CXTPTreeCtrl | virtual


Toolkit Pro: XTPRibbonBackstageSeparatorThemeOffice2013.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageSeparatorThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEOFFICE2013_H__)
24# define __XTPRIBBONBACKSTAGESEPARATORTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageSeparator;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageSeparatorThemeOffice2013
36 : public CXTPRibbonBackstageSeparatorPaintManager
37{
38public:
39 CXTPRibbonBackstageSeparatorThemeOffice2013();
40
41 virtual void DrawSeparator(CDC* pDC, CXTPRibbonBackstageSeparator* pSeparator);
42};
43
44# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
46#endif // !defined(__XTPRIBBONBACKSTAGESEPARATORTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


CXTPHeapObjectT< _TObject, _TAllocator > Member List

This is the complete list of members for CXTPHeapObjectT< _TObject, _TAllocator >, including all inherited members.

operator delete(void *p) | CXTPHeapObjectT< _TObject, _TAllocator > | inline
operator new(size_t nSize) | CXTPHeapObjectT< _TObject, _TAllocator > | inline


Toolkit Pro: XTPShellSettings.h Source File

  • Source
  • Controls
  • Shell
XTPShellSettings.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHELLSETTINGS_H__)
24# define __XTPSHELLSETTINGS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPShellSettings : public SHELLFLAGSTATE
40{
41public:
46 CXTPShellSettings();
47
52 ~CXTPShellSettings();
53
54public:
62 bool ShowAllFiles();
63
71 bool ShowExtensions();
72
80 bool NoConfirmRecycle();
81
89 bool ShowSysFiles();
90
98 bool ShowCompColor();
99
107 bool DoubleClickOpen();
108
116 bool HTMLDesktop();
117
125 bool Win95Classic();
126
134 bool AllowUpperCase();
135
143 bool ShowAttributes();
144
152 bool ShowMapNetworkDrive();
153
161 bool ShowInfoTips();
162
168 void RefreshSettings();
169
170 COLORREF m_crCompColor;
172 COLORREF m_crEncrColor;
174};
175
177
178AFX_INLINE bool CXTPShellSettings::ShowAllFiles()
179{
180 return fShowAllObjects != 0 ? true : false;
181}
182AFX_INLINE bool CXTPShellSettings::ShowExtensions()
183{
184 return fShowExtensions != 0 ? true : false;
185}
186AFX_INLINE bool CXTPShellSettings::NoConfirmRecycle()
187{
188 return fNoConfirmRecycle != 0 ? true : false;
189}
190AFX_INLINE bool CXTPShellSettings::ShowSysFiles()
191{
192 return fShowSysFiles != 0 ? true : false;
193}
194AFX_INLINE bool CXTPShellSettings::ShowCompColor()
195{
196 return fShowCompColor != 0 ? true : false;
197}
198AFX_INLINE bool CXTPShellSettings::DoubleClickOpen()
199{
200 return fDoubleClickInWebView != 0 ? true : false;
201}
202AFX_INLINE bool CXTPShellSettings::HTMLDesktop()
203{
204 return fDesktopHTML != 0 ? true : false;
205}
206AFX_INLINE bool CXTPShellSettings::Win95Classic()
207{
208 return fWin95Classic != 0 ? true : false;
209}
210AFX_INLINE bool CXTPShellSettings::AllowUpperCase()
211{
212 return fDontPrettyPath != 0 ? true : false;
213}
214AFX_INLINE bool CXTPShellSettings::ShowAttributes()
215{
216 return fShowAttribCol != 0 ? true : false;
217}
218AFX_INLINE bool CXTPShellSettings::ShowMapNetworkDrive()
219{
220 return fMapNetDrvBtn != 0 ? true : false;
221}
222AFX_INLINE bool CXTPShellSettings::ShowInfoTips()
223{
224 return fShowInfoTip != 0 ? true : false;
225}
227# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
229#endif // !defined(__XTPSHELLSETTINGS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShellSettings
CXTPShellSettings is a SHELLFLAGSTATE struct derived class.
Definition XTPShellSettings.h:40
CXTPShellSettings::RefreshSettings
void RefreshSettings()
Call this member function to update the SHELLFLAGSTATE values for this object.
CXTPShellSettings::ShowCompColor
bool ShowCompColor()
This member function checks whether or not the Display Compressed Files and Folders with Alternate Co...
CXTPShellSettings::m_crCompColor
COLORREF m_crCompColor
An RGB color value that represents the system alternate compressed color.
Definition XTPShellSettings.h:170
CXTPShellSettings::DoubleClickOpen
bool DoubleClickOpen()
This member function checks whether or not the Double-Click to Open an Item option is enabled.
CXTPShellSettings::NoConfirmRecycle
bool NoConfirmRecycle()
This member function checks to see if the Display Delete Confirmation Dialog box in the Recycle Bin i...
CXTPShellSettings::ShowExtensions
bool ShowExtensions()
This member function checks whether or not the Hide File Extensions for Known File Types option is en...
CXTPShellSettings::ShowInfoTips
bool ShowInfoTips()
This member function checks whether or not the Show Info Tips for Items in Folders & Desktop option i...
CXTPShellSettings::AllowUpperCase
bool AllowUpperCase()
This member function checks whether or not the Allow All Uppercase Names option is enabled.
CXTPShellSettings::ShowAttributes
bool ShowAttributes()
This member function checks whether or not the Show File Attributes in Detail View option is enabled.
CXTPShellSettings::CXTPShellSettings
CXTPShellSettings()
Constructs a CXTPShellSettings object.
CXTPShellSettings::ShowAllFiles
bool ShowAllFiles()
This member function checks whether or not the Show All Files option is enabled.
CXTPShellSettings::HTMLDesktop
bool HTMLDesktop()
This member function checks whether or not the Active Desktop - View as Web Page option is enabled.
CXTPShellSettings::~CXTPShellSettings
~CXTPShellSettings()
Destroys a CXTPShellSettings object, handles cleanup and deallocation.
CXTPShellSettings::ShowMapNetworkDrive
bool ShowMapNetworkDrive()
This member function checks whether or not the Show Map Network Drive Button in Toolbar option is ena...
CXTPShellSettings::Win95Classic
bool Win95Classic()
This member function checks whether or not the Classic Style option is enabled.
CXTPShellSettings::m_crEncrColor
COLORREF m_crEncrColor
An RGB color value that represents the system alternate encrypted color.
Definition XTPShellSettings.h:172
CXTPShellSettings::ShowSysFiles
bool ShowSysFiles()
This member function checks whether or not the Do Not Show Hidden Files option is selected.


Toolkit Pro: XTPRibbonBackstageView.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageView.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEW_H__)
24# define __XTPRIBBONBACKSTAGEVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonControlSystemButton;
34class CXTPRibbonBackstageCommand;
35class CXTPRibbonBackstageTab;
36class CXTPRibbonBackstageMenuSeparator;
37class CXTPRibbonBackstagePaintManager;
38class CXTPCommandBarScrollBarCtrl;
39
40const UINT XTP_BS_TABCHANGED = 0x1100;
41
46enum XTPRibbonBackstageStyle
47{
48 xtpRibbonBackstageOffice2010Style,
49 xtpRibbonBackstageOffice2013Style,
50 xtpRibbonBackstageOffice2016Style = xtpRibbonBackstageOffice2013Style
52};
53
58enum XTPRibbonBackstageKeyboardTipResult
59{
60 xtpNoActionForThisLevel = -3,
61 xtpExecuteCommand = -2,
63 xtpHideTips = -1,
64 xtpShowSecondLevel = 2,
65 xtpSelectTab = 3
66};
67
72enum XTPRibbonBackstageKeyboardTipLevel
73{
74 xtpNoTips = -1,
75 xtpUserHoldAltKey = 0,
76 xtpFirstLevel = 1,
77 xtpSecondLevel = 2,
79 xtpTipsOnTabPane = 3
80};
81
86class _XTP_EXT_CLASS CXTPRibbonBackstageView : public CXTPCommandBar
87{
89 DECLARE_XTP_COMMANDBAR(CXTPRibbonBackstageView);
91protected:
92 CXTPRibbonBackstageView();
93 ~CXTPRibbonBackstageView();
94
95public:
96 static CXTPRibbonBackstageView* AFX_CDECL CreateBackstageView(CXTPCommandBars* pCommandBars);
97
98public:
105 CXTPRibbonBackstageTab* GetActiveTab() const;
106
112 void SetActiveTab(CXTPRibbonBackstageTab* pTab);
113
120 CXTPControl* GetFocusedControl() const;
121
127 void SetFocusedControl(CXTPControl* pFocusedControl);
128
135 CXTPControl* GetHighlightedControl() const;
136
144 BOOL IsCommand(CXTPControl* pControl) const;
145
153 BOOL IsMenuSeparator(CXTPControl* pControl) const;
154
162 BOOL IsActiveTab(CXTPControl* pControl) const;
163
171 BOOL IsFocusedControl(CXTPControl* pControl) const;
172
180 BOOL IsHighlightedControl(CXTPControl* pControl) const;
181
188 CXTPImageManager* GetImageManager() const;
189
199 CXTPControl* HitTest(CPoint point) const;
200
209 int IndexOf(CXTPControl* pControl) const;
210
216 void OnExecute(CXTPControl* pControl);
217
224 CWnd* GetActiveControlPane() const;
225
232 int GetMenuWidth() const;
233
239 void SetTheme(XTPPaintTheme theme);
240
249 void SetBackstageStyle(XTPRibbonBackstageStyle style = xtpRibbonBackstageOffice2016Style);
250
260 XTPRibbonBackstageStyle GetBackstageStyle() const;
261
270 COLORREF GetKeyboardTipsBackColor();
271
278 CFont* GetKeyboardTipsFont();
279
291 BOOL ProcessKeyboardInput(UINT keyMessage, BOOL altPressed, UINT key,
292 int repeat);
301 BOOL IsDpiIconsScalingEnabled() const;
302
304 _XTP_DEPRECATED_IN_FAVOR(IsDpiIconsScalingEnabled)
305 BOOL IsDPIIconsScallingEnabled() const
306 {
307 return IsDpiIconsScalingEnabled();
308 }
317 virtual CScrollBar* GetScrollBarCtrl(int nBar);
324 virtual CScrollBar* GetScrollBarCtrl(int nBar) const;
325
326public:
327 CXTPRibbonBackstageCommand* AddCommand(UINT nID);
328 CXTPRibbonBackstageTab* AddTab(CWnd* pWnd, UINT nID);
329 CXTPRibbonBackstageMenuSeparator* AddMenuSeparator(UINT nID = UINT_MAX);
330
331public:
332 virtual void OnCancel();
333
334protected:
335 virtual void RecalcLayout();
336
337 BOOL Popup(CXTPControlPopup* pControlPopup, BOOL bSelectFirst = FALSE);
338 virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst = TRUE, BOOL bKeyboard = FALSE);
339
340 void ShowBackstageView();
341
347 void CheckKeyboardTips();
348
354 void CheckTabsKeyboardTips();
355
371 XTPRibbonBackstageKeyboardTipResult TranslateKeyboardTip(UINT key, int& nControlIndex);
372
373protected:
374 DECLARE_MESSAGE_MAP();
375
376 virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
377 LRESULT& lResult);
378 virtual BOOL PreTranslateMessage(MSG* pMsg);
379
380 afx_msg void OnPaint();
381 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
382 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
383 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
384 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
385 afx_msg UINT OnGetDlgCode();
386 afx_msg void OnMouseLeave();
387 afx_msg void OnDestroy();
388 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
389 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
390 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
391
392protected:
393# ifdef _XTP_COMMANDBARS_ACTIVEX
396 DECLARE_DISPATCH_MAP()
397 DECLARE_INTERFACE_MAP()
398 DECLARE_OLETYPELIB_EX(CXTPRibbonBackstageView);
399
400 afx_msg LPDISPATCH OleAddTab(long nId, LPCTSTR lpszCaption, OLE_HANDLE hWnd);
401 afx_msg LPDISPATCH OleAddCommand(long nId, LPCTSTR lpszCaption);
402 afx_msg LPDISPATCH OleAddMenuSeparator();
403 afx_msg int OleGetStyle();
404 afx_msg void OleSetStyle(int NewValue);
405 afx_msg void OleClose();
406 afx_msg void OleSetTheme(long nTheme);
407 afx_msg COLORREF OleGetColorForeground() const;
408 afx_msg COLORREF OleGetColorBackground() const;
409
411# endif
412protected:
417 void UpdateScrollInfo();
418
424 void SetScrollPos(int nScrollPos);
425 void RepositionControls(int dy);
426
427public:
428 int m_nMenuWidth;
429
430 CXTPFont m_xtpFontCommand;
431 CXTPFont m_xtpFontTab;
432
433 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntCommand, m_xtpFontCommand,
434 GetCommandFontHandle);
435 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntTab, m_xtpFontTab, GetTabFontHandle);
436
437 COLORREF m_clrText;
438 COLORREF m_clrBack;
439 XTPPaintTheme m_themeCurrent;
440 CXTPCommandBarScrollBarCtrl m_wndScrollBar;
441
442 CXTPRibbonBackstagePaintManager* m_pPaintManager;
443
444 CXTPRibbonControlSystemButton* m_pSystemButton;
445 CXTPRibbonBackstageTab* m_pActiveTab;
446 CXTPControl* m_pHighlightedControl;
447 CXTPControl* m_pFocusedControl;
448 CArray<HWND, HWND> m_arrChildWindows;
449 CList<int, int> m_listControlsToBeVisible;
450
451protected:
452 int m_nScrollPos;
453 int m_nPageSize;
454 int m_nMax;
455 int m_ScrolLine;
456 BOOL m_bIsScrollBarVisible;
457 CRect m_rcOldPaneRect;
458 XTPRibbonBackstageStyle m_backStageStyle;
459 BOOL m_bRestoreQuickAccess;
460 CRect m_rcOldSysButtonRect;
461 XTPRibbonBackstageKeyboardTipLevel m_nKeyboardTipsLevel;
464 TCHAR m_chSecondLevelCurrentChar;
467};
468
469AFX_INLINE CXTPImageManager* CXTPRibbonBackstageView::GetImageManager() const
470{
471 return CXTPCommandBar::GetImageManager();
472}
473
474AFX_INLINE int CXTPRibbonBackstageView::GetMenuWidth() const
475{
476 return m_nMenuWidth;
477}
478
479AFX_INLINE XTPRibbonBackstageStyle CXTPRibbonBackstageView::GetBackstageStyle() const
480{
481 return m_backStageStyle;
482}
483
484# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
486#endif // !defined(__XTPRIBBONBACKSTAGEVIEW_H__)
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
DECLARE_XTP_COMMANDBAR
#define DECLARE_XTP_COMMANDBAR(class_name)
This macro generates the C++ header code necessary for a CXTPCommandBar-derived class that can be ser...
Definition XTPCommandBarsDefines.h:1234
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPRibbonBackstageKeyboardTipLevel
XTPRibbonBackstageKeyboardTipLevel
Defines the current keyboard tip show level.
Definition XTPRibbonBackstageView.h:73
xtpUserHoldAltKey
@ xtpUserHoldAltKey
User pressed and hold ALT key and previous level was xtpNoTips.
Definition XTPRibbonBackstageView.h:75
xtpNoTips
@ xtpNoTips
Tips are not shown.
Definition XTPRibbonBackstageView.h:74
xtpTipsOnTabPane
@ xtpTipsOnTabPane
Show tips for buttons on the currently active tab.
Definition XTPRibbonBackstageView.h:79
xtpFirstLevel
@ xtpFirstLevel
Show tips of first level (commands and tabs).
Definition XTPRibbonBackstageView.h:76
xtpSecondLevel
@ xtpSecondLevel
Show tips with two letters with the same first letter (commands and tabs).
Definition XTPRibbonBackstageView.h:77
XTPRibbonBackstageStyle
XTPRibbonBackstageStyle
The backstage style.
Definition XTPRibbonBackstageView.h:47
xtpRibbonBackstageOffice2013Style
@ xtpRibbonBackstageOffice2013Style
Office 2013 and Office 2016 like style.
Definition XTPRibbonBackstageView.h:49
xtpRibbonBackstageOffice2010Style
@ xtpRibbonBackstageOffice2010Style
Office 2010 like style.
Definition XTPRibbonBackstageView.h:48
xtpRibbonBackstageOffice2016Style
@ xtpRibbonBackstageOffice2016Style
Office 2016 like style.
Definition XTPRibbonBackstageView.h:50
XTPRibbonBackstageKeyboardTipResult
XTPRibbonBackstageKeyboardTipResult
This enum defines what should be done for certain pressed key and the current tip level.
Definition XTPRibbonBackstageView.h:59
xtpSelectTab
@ xtpSelectTab
Pressed key corresponds to a tab and tips of first level are shown.
Definition XTPRibbonBackstageView.h:65
xtpShowSecondLevel
@ xtpShowSecondLevel
Show tips with two letters with the same first letter.
Definition XTPRibbonBackstageView.h:64
xtpHideTips
@ xtpHideTips
Hide all tips.
Definition XTPRibbonBackstageView.h:63
xtpNoActionForThisLevel
@ xtpNoActionForThisLevel
Nothing to do for the current level.
Definition XTPRibbonBackstageView.h:60
xtpExecuteCommand
@ xtpExecuteCommand
Pressed key corresponds to a command and tips of first level are shown.
Definition XTPRibbonBackstageView.h:61
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBar::m_pPaintManager
CXTPPaintManager * m_pPaintManager
Selected paint manager for command bar.
Definition XTPCommandBar.h:1207
CXTPCommandBar::GetImageManager
CXTPImageManager * GetImageManager() const
Call this method to retrieve the image manager.
CXTPCommandBarScrollBarCtrl
CXTPCommandBarScrollBarCtrl is a CScrollBar derived class.
Definition XTPCommandBarScrollBarCtrl.h:38
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87
CXTPRibbonBackstageView::IsHighlightedControl
BOOL IsHighlightedControl(CXTPControl *pControl) const
Determines if the mouse is hovering over a specified control.
CXTPRibbonBackstageView::OnHookMessage
virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPRibbonBackstageView::GetKeyboardTipsBackColor
COLORREF GetKeyboardTipsBackColor()
Gets the color of the rectangle in which the keyboard tip symbol (or symbols) is (or are) drawn.
CXTPRibbonBackstageView::IsDpiIconsScalingEnabled
BOOL IsDpiIconsScalingEnabled() const
Determines if DPI scaling is enabled for icons.
CXTPRibbonBackstageView::SetBackstageStyle
void SetBackstageStyle(XTPRibbonBackstageStyle style=xtpRibbonBackstageOffice2016Style)
Sets the style of the backstage view.
CXTPRibbonBackstageView::SetActiveTab
void SetActiveTab(CXTPRibbonBackstageTab *pTab)
Sets the active tab.
CXTPRibbonBackstageView::GetKeyboardTipsFont
CFont * GetKeyboardTipsFont()
Gets the font for drawing keyboard tips.
CXTPRibbonBackstageView::GetScrollBarCtrl
virtual CScrollBar * GetScrollBarCtrl(int nBar) const
Overrides the CWnd::GetScrollBarCtrl virtual method.
CXTPRibbonBackstageView::OnExecute
void OnExecute(CXTPControl *pControl)
Executes the action defined by a specified control.
CXTPRibbonBackstageView::m_nKeyboardTipsLevel
XTPRibbonBackstageKeyboardTipLevel m_nKeyboardTipsLevel
See XTPRibbonBackstageKeyboardTipLevel definition.
Definition XTPRibbonBackstageView.h:461
CXTPRibbonBackstageView::TranslateKeyboardTip
XTPRibbonBackstageKeyboardTipResult TranslateKeyboardTip(UINT key, int &nControlIndex)
This method determines which control in the backstage corresponds to the pressed keyboard key (accord...
CXTPRibbonBackstageView::CheckKeyboardTips
void CheckKeyboardTips()
Guarantees that keyboard tips are set for all menu items in the backstage.
CXTPRibbonBackstageView::SetTrackingMode
virtual BOOL SetTrackingMode(int bMode, BOOL bSelectFirst=TRUE, BOOL bKeyboard=FALSE)
Call this member to change the tracking state.
CXTPRibbonBackstageView::GetScrollBarCtrl
virtual CScrollBar * GetScrollBarCtrl(int nBar)
Overrides the CWnd::GetScrollBarCtrl virtual method.
CXTPRibbonBackstageView::GetBackstageStyle
XTPRibbonBackstageStyle GetBackstageStyle() const
Gets the style of the backstage view.
Definition XTPRibbonBackstageView.h:479
CXTPRibbonBackstageView::GetFocusedControl
CXTPControl * GetFocusedControl() const
Retrieves the currently focused control.
CXTPRibbonBackstageView::IsActiveTab
BOOL IsActiveTab(CXTPControl *pControl) const
Determines if a specified control is the active tab of the backstage view.
CXTPRibbonBackstageView::ProcessKeyboardInput
BOOL ProcessKeyboardInput(UINT keyMessage, BOOL altPressed, UINT key, int repeat)
Defines what should be done for the current keyboard input depending on the current state of the keyb...
CXTPRibbonBackstageView::GetMenuWidth
int GetMenuWidth() const
Retrieves the width of the menu bar of the backstage view.
Definition XTPRibbonBackstageView.h:474
CXTPRibbonBackstageView::HitTest
CXTPControl * HitTest(CPoint point) const
This member function determines which control, if any, is at a specified point.
CXTPRibbonBackstageView::IsCommand
BOOL IsCommand(CXTPControl *pControl) const
Determines if a specified control is a backstage command.
CXTPRibbonBackstageView::GetActiveControlPane
CWnd * GetActiveControlPane() const
Retrieves a pointer to the pane window of the currently active tab.
CXTPRibbonBackstageView::IndexOf
int IndexOf(CXTPControl *pControl) const
Retrieves the index of a specified control from the array of controls in backstage view.
CXTPRibbonBackstageView::SetScrollPos
void SetScrollPos(int nScrollPos)
Sets the position of the vertical scrollbar.
CXTPRibbonBackstageView::IsFocusedControl
BOOL IsFocusedControl(CXTPControl *pControl) const
Determines if a specified contral is the control with the focus input.
CXTPRibbonBackstageView::SetTheme
void SetTheme(XTPPaintTheme theme)
Sets the theme of the backstage view.
CXTPRibbonBackstageView::GetActiveTab
CXTPRibbonBackstageTab * GetActiveTab() const
Retrieves the currently active tab.
CXTPRibbonBackstageView::UpdateScrollInfo
void UpdateScrollInfo()
Updates scrollbar information.
CXTPRibbonBackstageView::SetFocusedControl
void SetFocusedControl(CXTPControl *pFocusedControl)
Sets the focused control.
CXTPRibbonBackstageView::m_chSecondLevelCurrentChar
TCHAR m_chSecondLevelCurrentChar
It is used when keyboard tips with 2 letters are shown (m_nKeyboardTipsLevel == xtpSecondLevel).
Definition XTPRibbonBackstageView.h:464
CXTPRibbonBackstageView::GetImageManager
CXTPImageManager * GetImageManager() const
Retrieves Image manager associated with the backstage.
Definition XTPRibbonBackstageView.h:469
CXTPRibbonBackstageView::CheckTabsKeyboardTips
void CheckTabsKeyboardTips()
Guarantees that keyboard tips are set for all buttons in all tab panes in the backstage view.
CXTPRibbonBackstageView::Popup
BOOL Popup(CXTPControlPopup *pControlPopup, BOOL bSelectFirst=FALSE)
This method is called to pop-up the command bar.
CXTPRibbonBackstageView::GetHighlightedControl
CXTPControl * GetHighlightedControl() const
Retrieves the currently highlighted control.
CXTPRibbonBackstageView::IsMenuSeparator
BOOL IsMenuSeparator(CXTPControl *pControl) const
Determines if a specified control is a backstage separator.
CXTPRibbonControlSystemButton
CXTPRibbonControlSystemButton is a CXTPControlPopup derived class used as a system button for a Ribbo...
Definition XTPRibbonSystemButton.h:39


CXTPRibbonGroups Member List

This is the complete list of members for CXTPRibbonGroups, including all inherited members.

Add(LPCTSTR lpszCaption, int nId=-1) | CXTPRibbonGroups |
CalcDynamicSize(CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder) | CXTPRibbonGroups |
Copy(CXTPRibbonGroups *pGroups) | CXTPRibbonGroups |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonGroups() | CXTPRibbonGroups |
DoPropExchange(CXTPPropExchange *pPX) | CXTPRibbonGroups | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPRibbonGroups |
GetCount() const | CXTPRibbonGroups |
GetParentTab() const | CXTPRibbonGroups |
GetRibbonBar() const | CXTPRibbonGroups |
GetScrollPos() const | CXTPRibbonGroups |
HitTest(CPoint point) const | CXTPRibbonGroups |
InsertAt(int nIndex, LPCTSTR lpszCaption, int nId=-1) | CXTPRibbonGroups |
InsertAt(int nIndex, CXTPRibbonGroup *pGroup) | CXTPRibbonGroups |
m_arrGroups | CXTPRibbonGroups | protected
m_nGroupsScrollPos | CXTPRibbonGroups | protected
m_pParentTab | CXTPRibbonGroups | protected
Remove(int nIndex) | CXTPRibbonGroups |
Remove(CXTPRibbonGroup *pGroup) | CXTPRibbonGroups |
RemoveAll() | CXTPRibbonGroups |
~CXTPRibbonGroups() | CXTPRibbonGroups | virtual


CXTPSkinManagerClass Member List

This is the complete list of members for CXTPSkinManagerClass, including all inherited members.

CXTPSkinManagerClass(CXTPSkinManagerSchema *pSchema, CString pszClassList, int nClassCode) | CXTPSkinManagerClass |
DrawThemeBackground(CDC *pDC, int iPartId, int iStateId, const RECT *pRect) | CXTPSkinManagerClass |
DrawThemeText(CDC *pDC, int iPartId, int iStateId, const CString &strText, DWORD dwFormat, const RECT *pRect) | CXTPSkinManagerClass |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetClassCode() const | CXTPSkinManagerClass |
GetClassName() const | CXTPSkinManagerClass |
GetImages() const | CXTPSkinManagerClass |
GetProperty(XTPSkinManagerProperty propType, int iPartId, int iStateId, int iPropId) | CXTPSkinManagerClass |
GetThemeBool(int iPartId, int iStateId, int iPropId, BOOL bDefault=FALSE) | CXTPSkinManagerClass |
GetThemeColor(int iPartId, int iStateId, int iPropId, COLORREF clrDefault=(COLORREF) -1) | CXTPSkinManagerClass |
GetThemeEnumValue(int iPartId, int iStateId, int iPropId, int nDefault=0) | CXTPSkinManagerClass |
GetThemeInt(int iPartId, int iStateId, int iPropId, int nDefault=0) | CXTPSkinManagerClass |
GetThemePartSize(int iPartId, int iStateId, RECT *pRect, int eSize, SIZE *pSize) | CXTPSkinManagerClass |
GetThemeRect(int iPartId, int iStateId, int iPropId, CRect rcDefault=CRect(0, 0, 0, 0)) | CXTPSkinManagerClass |
GetThemeSize(int iPartId, int iStateId, int iPropId, CSize szDefault=CSize(0)) | CXTPSkinManagerClass |
GetThemeString(int iPartId, int iStateId, int iPropId, LPCTSTR lpszDefault=NULL) | CXTPSkinManagerClass |
m_mapCachedProperties | CXTPSkinManagerClass | protected
m_nClassCode | CXTPSkinManagerClass | protected
m_pImages | CXTPSkinManagerClass | protected
m_pSchema | CXTPSkinManagerClass | protected
m_strClass | CXTPSkinManagerClass | protected
~CXTPSkinManagerClass() | CXTPSkinManagerClass | virtual


CXTPListBoxThemeOffice2003 Member List

This is the complete list of members for CXTPListBoxThemeOffice2003, including all inherited members.

DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeOffice2003 | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxTheme | virtual
GetBackColor() | CXTPListBoxTheme | virtual
RefreshMetrics() | CXTPListBoxThemeOffice2003 | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: XTPMarkupSetterCollection.h Source File

  • Source
  • Markup
XTPMarkupSetterCollection.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSETTERCOLLECTION_H__)
24# define __XTPMARKUPSETTERCOLLECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupSetter;
34
35class _XTP_EXT_CLASS CXTPMarkupSetterCollection : public CXTPMarkupCollection
36{
38 DECLARE_MARKUPCLASS(CXTPMarkupSetterCollection);
40public:
41 CXTPMarkupSetterCollection();
42
43public:
44 CXTPMarkupSetter* GetItem(int nIndex) const;
45};
46
47# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
49#endif // !defined(__XTPMARKUPSETTERCOLLECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


CXTPTaskPanelExplorerTheme Member List

This is the complete list of members for CXTPTaskPanelExplorerTheme, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelExplorerTheme() | CXTPTaskPanelExplorerTheme |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManager | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bExplorerTheme | CXTPTaskPanelExplorerTheme |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelExplorerTheme | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: XTPChartPieSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
XTPChartPieSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESVIEW_H__)
24# define __XTPCHARTPIESERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pie/Base/XTPChartPieSeriesViewBase.h"
32# include "Chart/Styles/Pie/2D/XTPChart2dPieSeriesView.h"
33
34// CXTPChart2dPieSeriesView alias is necessary for naming consistency.
35typedef CXTPChartPieSeriesView CXTPChart2dPieSeriesView;
37#endif //#if !defined(__XTPCHARTPIESERIESVIEW_H__)
XTPChart2dPieSeriesView.h
XTPChartPieSeriesViewBase.h
CXTPChartPieSeriesView
This class abstracts the view of a pie series.
Definition XTPChart2dPieSeriesView.h:45


Toolkit Pro: XTPProgressCtrl.h Source File

  • Source
  • Controls
  • Progress
XTPProgressCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSCTRL_H__)
24# define __XTPPROGRESSCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33# ifndef PBS_MARQUEE
34# define PBS_MARQUEE 0x08
35# endif
36
37# ifndef PBM_SETMARQUEE
38# define PBM_SETMARQUEE (WM_USER + 10)
39# endif
40
41class CXTPProgressCtrlPaintManager;
42
58class _XTP_EXT_CLASS CXTPProgressCtrl : public CProgressCtrl
59{
61 DECLARE_DYNAMIC(CXTPProgressCtrl)
63public:
68 CXTPProgressCtrl();
69
74 virtual ~CXTPProgressCtrl();
75
86 CXTPProgressCtrlPaintManager* GetPaintManager() const;
87
100 void SetTheme(CXTPProgressCtrlPaintManager* pPaintManager = NULL);
101
109 COLORREF SetBorderColor(COLORREF clrNew);
110
118 COLORREF SetBarColor(COLORREF clrNew);
119
127 COLORREF SetBkColor(COLORREF clrNew);
128
136 COLORREF SetTextColor(COLORREF clrNew);
137
154 BOOL SetMarquee(BOOL fMarqueeMode, int nInterval);
155
171 void SetTheme(XTPControlTheme nTheme);
172
182 BOOL GetFlatStyle() const;
183
192 void SetFlatStyle(BOOL bFlatStyle = TRUE);
193
213 BOOL GetUseVisualStyle() const;
214
234 void SetUseVisualStyle(BOOL bUseVisualStyle = TRUE);
235
236protected:
242 void RefreshMetrics();
243
251 void DrawNcBorders(CDC* pDC, CRect rc);
252
258 void DoPaint(CDC* pDC);
259
266 COLORREF GetBorderColor();
267
274 COLORREF GetBarColor();
275
282 COLORREF GetBackColor();
283
290 COLORREF GetTextColor();
291
298 BOOL HasText();
299
302 void Init();
303 void DoStep(int nStep);
304
305 //{{AFX_VIRTUAL(CXTPProgressCtrl)
306 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
307 virtual void PreSubclassWindow();
308 //}}AFX_VIRTUAL
309
310 //{{AFX_MSG(CXTPProgressCtrl)
311 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
312 afx_msg void OnPaint();
313 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
314 afx_msg void OnSysColorChange();
315 afx_msg void OnTimer(UINT_PTR nIDEvent);
316 //}}AFX_MSG
317
318 afx_msg LRESULT OnSetPos(WPARAM wParam, LPARAM lParam);
319 afx_msg LRESULT OnStepIt(WPARAM wParam, LPARAM lParam);
320 afx_msg LRESULT OnStartMarquee(WPARAM wParam, LPARAM lParam);
321 afx_msg LRESULT OnSetTheme(WPARAM wParam, LPARAM lParam);
322
323 DECLARE_MESSAGE_MAP()
324
325
327protected:
328 int m_nMarqueePos;
329 int m_nMarqueeDelay;
330 BOOL m_bPreSubclassInit;
331 BOOL m_bFlatStyle;
332 CXTPProgressCtrlPaintManager* m_pPaintManager;
334};
335
337
338AFX_INLINE CXTPProgressCtrlPaintManager* CXTPProgressCtrl::GetPaintManager() const
339{
340 return m_pPaintManager;
341}
342AFX_INLINE BOOL CXTPProgressCtrl::SetMarquee(BOOL fMarqueeMode, int nInterval)
343{
344 _ASSERTE(::IsWindow(m_hWnd));
345 return (BOOL)::SendMessage(m_hWnd, PBM_SETMARQUEE, (WPARAM)fMarqueeMode, (LPARAM)nInterval);
346}
347AFX_INLINE BOOL CXTPProgressCtrl::GetFlatStyle() const
348{
349 return m_bFlatStyle;
350}
351AFX_INLINE void CXTPProgressCtrl::SetFlatStyle(BOOL bFlatStyle /* = TRUE*/)
352{
353 m_bFlatStyle = bFlatStyle;
354 if (m_hWnd)
355 Invalidate(FALSE);
356}
358# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
360#endif // #if !defined(__XTPPROGRESSCTRL_H__)
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPProgressCtrl
The ProgressBar control shows the progress of a lengthy operation by filling a rectangle with chunks ...
Definition XTPProgressCtrl.h:59
CXTPProgressCtrl::CXTPProgressCtrl
CXTPProgressCtrl()
Constructs a CXTPProgressCtrl object.
CXTPProgressCtrl::DrawNcBorders
void DrawNcBorders(CDC *pDC, CRect rc)
This member function is called by the progress bar to draw non-client area borders.
CXTPProgressCtrl::SetUseVisualStyle
void SetUseVisualStyle(BOOL bUseVisualStyle=TRUE)
Enables Windows XP visual styles for the control.
CXTPProgressCtrl::DoPaint
void DoPaint(CDC *pDC)
A helper for rendering the control appearance.
CXTPProgressCtrl::GetFlatStyle
BOOL GetFlatStyle() const
Gets the flat style appearance of the button control.
CXTPProgressCtrl::HasText
BOOL HasText()
This member function check the progress bar for text.
CXTPProgressCtrl::SetBorderColor
COLORREF SetBorderColor(COLORREF clrNew)
This member function sets the border color for the progress bar.
CXTPProgressCtrl::GetBorderColor
COLORREF GetBorderColor()
This member function gets the border color for the progress bar.
CXTPProgressCtrl::SetTextColor
COLORREF SetTextColor(COLORREF clrNew)
This member function sets the text color for the progress bar.
CXTPProgressCtrl::SetFlatStyle
void SetFlatStyle(BOOL bFlatStyle=TRUE)
Sets the flat style appearance of the button control.
CXTPProgressCtrl::GetPaintManager
CXTPProgressCtrlPaintManager * GetPaintManager() const
This member function obtains a pointer to the associated paint manager object.
CXTPProgressCtrl::SetBkColor
COLORREF SetBkColor(COLORREF clrNew)
This member function sets the background color for the progress bar.
CXTPProgressCtrl::GetBarColor
COLORREF GetBarColor()
This member function gets the bar color for the progress bar.
CXTPProgressCtrl::SetTheme
void SetTheme(XTPControlTheme nTheme)
Call this member to switch the visual theme of the control.
CXTPProgressCtrl::GetUseVisualStyle
BOOL GetUseVisualStyle() const
Determines if the control is drawn using visual styles/SkinFramework, if supported.
CXTPProgressCtrl::~CXTPProgressCtrl
virtual ~CXTPProgressCtrl()
Handles cleanup, destroys object.
CXTPProgressCtrl::RefreshMetrics
void RefreshMetrics()
This member is called to update the color, text, and other visual elements of the control.
CXTPProgressCtrl::SetBarColor
COLORREF SetBarColor(COLORREF clrNew)
This member function sets the bar color for the progress bar.
CXTPProgressCtrl::GetBackColor
COLORREF GetBackColor()
This member function gets the background color for the progress bar.
CXTPProgressCtrl::GetTextColor
COLORREF GetTextColor()
This member function gets the text color for the progress bar.
CXTPProgressCtrl::SetTheme
void SetTheme(CXTPProgressCtrlPaintManager *pPaintManager=NULL)
This member function sets the new control drawing theme.
CXTPProgressCtrl::SetMarquee
BOOL SetMarquee(BOOL fMarqueeMode, int nInterval)
Turns marquee mode on/off for the current progress bar control.
CXTPProgressCtrlPaintManager
The CXTPProgressCtrlPaintManager class is derived from CXTPCmdTarget and is used by the progress bar ...
Definition XTPProgressCtrlPaintManager.h:59


Toolkit Pro: XTPMarkupMouseEventArgs.h Source File

  • Source
  • Markup
XTPMarkupMouseEventArgs.h
Go to the documentation of this file.
1
23#if !defined(__XTPMMARKUPMOUSEEVENTARGS_H__)
24# define __XTPMMARKUPMOUSEEVENTARGS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupRoutedEvent;
34class CXTPMarkupInputElement;
35
36class _XTP_EXT_CLASS CXTPMarkupMouseEventArgs : public CXTPMarkupRoutedEventArgs
37{
38public:
39 CXTPMarkupMouseEventArgs(CXTPMarkupRoutedEvent* pEvent);
40
41public:
42 CPoint GetPosition(CXTPMarkupInputElement* relativeTo);
43
44public:
45 HWND m_hWnd;
46 CPoint m_point;
47};
48
49# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
51#endif // !defined(__XTPMMARKUPMOUSEEVENTARGS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPCalendarOfficeXPTheme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarOfficeXPTheme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDAROFFICEXPTHEME_H__)
23# define __XTPCALENDAROFFICEXPTHEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarOfficeXPTheme : public CXTPCalendarOffice2000Theme
37{
38public:
47 CXTPCalendarOfficeXPTheme();
48
55 virtual ~CXTPCalendarOfficeXPTheme();
56
57 virtual void PartRefresh(CDayViewWorkCellPart* pViewPart);
58 virtual void PartRefresh(CDayViewNonworkCellPart* pViewPart);
59
60 using CXTPCalendarOffice2000Theme::PartRefresh;
61};
62
63# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif // !defined(__XTPCALENDAROFFICEXPTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 20...
Definition XTPCalendarOffice2000Theme.h:37
CXTPCalendarOfficeXPTheme
CXTPCalendarOfficeXPTheme is a CXTPCalendarOffice2000Theme derived class that represents the Office X...
Definition XTPCalendarOfficeXPTheme.h:37
CXTPCalendarOfficeXPTheme::CXTPCalendarOfficeXPTheme
CXTPCalendarOfficeXPTheme()
Default paint manager constructor.
CXTPCalendarOfficeXPTheme::~CXTPCalendarOfficeXPTheme
virtual ~CXTPCalendarOfficeXPTheme()
Default paint manager destructor.


Toolkit Pro: XTPMarkupSystemColorsStaticExtension.h Source File

  • Source
  • Markup
  • Extensions
XTPMarkupSystemColorsStaticExtension.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPSYSTEMCOLORSSTATICEXTENSION_H__)
24# define __XTPMARKUPSYSTEMCOLORSSTATICEXTENSION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupColor;
34class CXTPMarkupColorKey;
35class CXTPMarkupBrush;
36class CXTPMarkupBrushKey;
37
42class _XTP_EXT_CLASS CXTPMarkupSystemColorStaticExtension : public CXTPMarkupStaticExtensionProperty
43{
44public:
54 CXTPMarkupSystemColorStaticExtension(LPCWSTR lpzName, int nColorIndex);
55
65 static CXTPMarkupColor* AFX_CDECL GetSystemColor(int nColorIndex);
66};
67
72class _XTP_EXT_CLASS CXTPMarkupSystemColorKeyStaticExtension
73 : public CXTPMarkupStaticExtensionProperty
74{
75public:
85 CXTPMarkupSystemColorKeyStaticExtension(LPCWSTR lpzName, int nColorIndex);
86};
87
92class _XTP_EXT_CLASS CXTPMarkupSystemBrushStaticExtension : public CXTPMarkupStaticExtensionProperty
93{
94public:
104 CXTPMarkupSystemBrushStaticExtension(LPCWSTR lpzName, int nColorIndex);
105
115 static CXTPMarkupBrush* AFX_CDECL GetSystemBrush(int nColorIndex);
116};
117
122class _XTP_EXT_CLASS CXTPMarkupSystemBrushKeyStaticExtension
123 : public CXTPMarkupStaticExtensionProperty
124{
125public:
135 CXTPMarkupSystemBrushKeyStaticExtension(LPCWSTR lpzName, int nColorIndex);
136};
137
142class _XTP_EXT_CLASS CXTPMarkupSystemColorsStaticExtension : public CXTPMarkupStaticExtension
143{
144public:
149 CXTPMarkupSystemColorsStaticExtension();
150};
151
152# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
154#endif // !defined(__XTPMARKUPSYSTEMCOLORSSTATICEXTENSION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupStaticExtension
A base class for a markup static extension composite object.
Definition XTPMarkupStaticExtension.h:41
CXTPMarkupStaticExtensionProperty
A convenience base class for all static extension properties.
Definition XTPMarkupStaticExtension.h:171
CXTPMarkupSystemBrushKeyStaticExtension
A property static extension object that represents a system brush key.
Definition XTPMarkupSystemColorsStaticExtension.h:124
CXTPMarkupSystemBrushKeyStaticExtension::CXTPMarkupSystemBrushKeyStaticExtension
CXTPMarkupSystemBrushKeyStaticExtension(LPCWSTR lpzName, int nColorIndex)
Constructs a system brush key extension object.
CXTPMarkupSystemBrushStaticExtension
A property static extension object that represents a system brush.
Definition XTPMarkupSystemColorsStaticExtension.h:93
CXTPMarkupSystemBrushStaticExtension::GetSystemBrush
static CXTPMarkupBrush *AFX_CDECL GetSystemBrush(int nColorIndex)
Creates a system brush markup object.
CXTPMarkupSystemBrushStaticExtension::CXTPMarkupSystemBrushStaticExtension
CXTPMarkupSystemBrushStaticExtension(LPCWSTR lpzName, int nColorIndex)
Constructs a system brush extension object.
CXTPMarkupSystemColorKeyStaticExtension
A property static extension object that represents a system color key.
Definition XTPMarkupSystemColorsStaticExtension.h:74
CXTPMarkupSystemColorKeyStaticExtension::CXTPMarkupSystemColorKeyStaticExtension
CXTPMarkupSystemColorKeyStaticExtension(LPCWSTR lpzName, int nColorIndex)
Constructs a system color key extension object.
CXTPMarkupSystemColorStaticExtension
A property static extension object that represents a system color.
Definition XTPMarkupSystemColorsStaticExtension.h:43
CXTPMarkupSystemColorStaticExtension::CXTPMarkupSystemColorStaticExtension
CXTPMarkupSystemColorStaticExtension(LPCWSTR lpzName, int nColorIndex)
Constructs a system color extension object.
CXTPMarkupSystemColorStaticExtension::GetSystemColor
static CXTPMarkupColor *AFX_CDECL GetSystemColor(int nColorIndex)
Creates a system color markup object.
CXTPMarkupSystemColorsStaticExtension
A composite static extension object that represents system colors.
Definition XTPMarkupSystemColorsStaticExtension.h:143
CXTPMarkupSystemColorsStaticExtension::CXTPMarkupSystemColorsStaticExtension
CXTPMarkupSystemColorsStaticExtension()
Constructs a CXTPMarkupSystemColorsStaticExtension object.


CXTPSyntaxEditColorSampleText Member List

This is the complete list of members for CXTPSyntaxEditColorSampleText, including all inherited members.

CXTPSyntaxEditColorSampleText() | CXTPSyntaxEditColorSampleText |
GetBackColor() const | CXTPSyntaxEditColorSampleText |
GetBorderColor() const | CXTPSyntaxEditColorSampleText |
GetTextColor() const | CXTPSyntaxEditColorSampleText |
Refresh() | CXTPSyntaxEditColorSampleText |
SetBackColor(COLORREF crBack) | CXTPSyntaxEditColorSampleText |
SetBorderColor(COLORREF crBorder) | CXTPSyntaxEditColorSampleText |
SetTextColor(COLORREF crText) | CXTPSyntaxEditColorSampleText |
~CXTPSyntaxEditColorSampleText() | CXTPSyntaxEditColorSampleText | virtual


Toolkit Pro: XTPRibbonThemeVisualStudio2019.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONVISUALSTUDIO2019THEME_H__)
24# define __XTPRIBBONVISUALSTUDIO2019THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeVisualStudio2019 : public CXTPRibbonOffice2013Theme
39{
40public:
46 CXTPRibbonThemeVisualStudio2019(CXTPPaintManager* pPaintManager);
47
52 virtual ~CXTPRibbonThemeVisualStudio2019();
53};
54
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
57#endif // !defined(__XTPRIBBONVISUALSTUDIO2019THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 r...
Definition XTPRibbonThemeOffice2013.h:50
CXTPRibbonThemeVisualStudio2019
CXTPRibbonThemeVisualStudio2019 is a CXTPRibbonOffice2013Theme derived class used to represent a Visu...
Definition XTPRibbonThemeVisualStudio2019.h:39
CXTPRibbonThemeVisualStudio2019::CXTPRibbonThemeVisualStudio2019
CXTPRibbonThemeVisualStudio2019(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeVisualStudio2019 object.
CXTPRibbonThemeVisualStudio2019::~CXTPRibbonThemeVisualStudio2019
virtual ~CXTPRibbonThemeVisualStudio2019()
Destroys a CXTPRibbonThemeVisualStudio2019 object, handles cleanup and deallocation.


CXTPRegistryManager Member List

This is the complete list of members for CXTPRegistryManager, including all inherited members.

CXTPRegistryManager(HKEY hKeyBase=HKEY_CURRENT_USER) | CXTPRegistryManager |
DeleteKey(LPCTSTR lpszSection, LPCTSTR lpszKey) | CXTPRegistryManager |
DeleteValue(LPCTSTR lpszSection, LPCTSTR lpszKey) | CXTPRegistryManager |
EnumKeys(LPCTSTR lpszSection, CStringArray &arrayKeys) | CXTPRegistryManager |
EnumValues(LPCTSTR lpszSection, CMap< CString, LPCTSTR, DWORD, DWORD & > *mapItems, CStringArray *arrayNames) | CXTPRegistryManager |
GetAppRegistryKey(REGSAM samDesired=KEY_WRITE|KEY_READ) | CXTPRegistryManager | protectedvirtual
GetErrorCode() const | CXTPRegistryManager |
GetErrorMessage() const | CXTPRegistryManager |
GetINIFileName() | CXTPRegistryManager | static
GetProfileBinary(LPCTSTR lpszSection, LPCTSTR lpszEntry, BYTE **ppData, UINT *pBytes) | CXTPRegistryManager |
GetProfileColor(LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF *rcResult) | CXTPRegistryManager |
GetProfileDouble(LPCTSTR lpszSection, LPCTSTR lpszEntry, double *rcResult) | CXTPRegistryManager |
GetProfileDword(LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD *rcResult) | CXTPRegistryManager |
GetProfileInt(LPCTSTR lpszSection, LPCTSTR lpszEntry, int nDefault) | CXTPRegistryManager |
GetProfilePoint(LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint *ptResult) | CXTPRegistryManager |
GetProfileRect(LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect *rcResult) | CXTPRegistryManager |
GetProfileSize(LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize *rcResult) | CXTPRegistryManager |
GetProfileString(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszDefault) | CXTPRegistryManager |
GetSectionKey(LPCTSTR lpszSection, REGSAM samDesired=KEY_WRITE|KEY_READ) | CXTPRegistryManager | protectedvirtual
m_hKeyBase | CXTPRegistryManager | protected
m_strINIFileName | CXTPRegistryManager | protectedstatic
m_strProfileName | CXTPRegistryManager | protected
m_strRegistryKey | CXTPRegistryManager | protected
SetINIFileName(LPCTSTR strINIFileName) | CXTPRegistryManager | static
SetRegistryKey(LPCTSTR lpszRegistryKey, LPCTSTR lpszProfileName) | CXTPRegistryManager |
WriteProfileBinary(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPBYTE pData, UINT nBytes) | CXTPRegistryManager |
WriteProfileColor(LPCTSTR lpszSection, LPCTSTR lpszEntry, COLORREF *pValue) | CXTPRegistryManager |
WriteProfileDouble(LPCTSTR lpszSection, LPCTSTR lpszEntry, double *pValue) | CXTPRegistryManager |
WriteProfileDword(LPCTSTR lpszSection, LPCTSTR lpszEntry, DWORD *pValue) | CXTPRegistryManager |
WriteProfileInt(LPCTSTR lpszSection, LPCTSTR lpszEntry, int nValue) | CXTPRegistryManager |
WriteProfilePoint(LPCTSTR lpszSection, LPCTSTR lpszEntry, CPoint *pValue) | CXTPRegistryManager |
WriteProfileRect(LPCTSTR lpszSection, LPCTSTR lpszEntry, CRect *pValue) | CXTPRegistryManager |
WriteProfileSize(LPCTSTR lpszSection, LPCTSTR lpszEntry, CSize *pValue) | CXTPRegistryManager |
WriteProfileString(LPCTSTR lpszSection, LPCTSTR lpszEntry, LPCTSTR lpszValue) | CXTPRegistryManager |
~CXTPRegistryManager() | CXTPRegistryManager | virtual


Toolkit Pro: XTPGridColumns.h Source File

  • Source
  • GridControl
XTPGridColumns.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDCOLUMNS_H__)
24# define __XTPGRIDCOLUMNS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridColumn;
34class CXTPGridHeader;
35class CXTPGridControl;
36class CXTPGridColumnOrder;
37class CXTPPropExchange;
38
53class _XTP_EXT_CLASS CXTPGridColumns : public CXTPCmdTarget
54{
55 friend class CXTPGridColumn;
56
57public:
63 CXTPGridColumns(CXTPGridControl* pControl);
64
72 virtual ~CXTPGridColumns();
73
80 int GetCount() const;
81
86 void Clear();
87
97 int GetVisibleColumnsCount() const;
98
108 void GetVisibleColumns(CXTPGridColumns& arrColumns) const;
109
120 CXTPGridColumn* GetAt(int nIndex) const;
121
134 CXTPGridColumn* GetVisibleAt(int nIndex) const;
135
144 int GetAtOffset(int nOffset, BOOL bFrozen) const;
145
154 int GetOffset(int nIndex) const;
155
165 CXTPGridColumn* GetIndentColumn() const;
166
177 CXTPGridColumn* Find(int nItemIndex) const;
178
189 CXTPGridColumn* Find(const CString& strInternalName) const;
190
198 void Add(CXTPGridColumn* pColumn);
199
205 void Remove(CXTPGridColumn* pColumn);
206
211 void ResetSortOrder();
212
219 CXTPGridHeader* GetGridHeader() const;
220
222 _XTP_DEPRECATED_IN_FAVOR(GetGridHeader)
223 CXTPGridHeader* GetReportHeader() const;
234 int ChangeColumnOrder(int nNewIndex, int nOldIndex);
235
247 int IndexOf(const CXTPGridColumn* pColumn) const;
248
255 void InsertSortColumn(CXTPGridColumn* pColumn);
256
265 void SetSortColumn(CXTPGridColumn* pColumn, BOOL bIncreasing);
266
273 CXTPGridColumnOrder* GetGroupsOrder() const;
274
281 CXTPGridColumnOrder* GetSortOrder() const;
282
288 virtual void DoPropExchange(CXTPPropExchange* pPX);
289
298 CXTPGridColumn* GetFirstVisibleColumn() const;
299
308 CXTPGridColumn* GetLastVisibleColumn() const;
309
310protected:
311 CXTPGridColumnOrder* m_pGroupsOrder;
313 CXTPGridColumnOrder* m_pSortOrder;
314 CArray<CXTPGridColumn*, CXTPGridColumn*> m_arrColumns;
315 CXTPGridControl* m_pControl;
316 CXTPGridColumn* m_pTreeColumn;
318# ifdef _XTP_ACTIVEX
320 DECLARE_DISPATCH_MAP()
321 DECLARE_INTERFACE_MAP()
322
323 DECLARE_OLETYPELIB_EX(CXTPGridColumns);
324
325 afx_msg LPDISPATCH OleGetItem(long nIndex);
326 afx_msg int OleGetItemCount();
327 afx_msg LPDISPATCH OleAdd(long nId, LPCTSTR strCaption, int nWidth, BOOL bAutoSize);
328 afx_msg LPDISPATCH OleAddEx(long nId, LPCTSTR strCaption, LPCTSTR strInternalName, int nWidth,
329 BOOL bAutoSize);
330 afx_msg LPDISPATCH OleFindColumn(long nId);
331
332 DECLARE_ENUM_VARIANT(CXTPGridColumns)
333
334 enum
335 {
336 dispidCount = 1L,
337 dispidAdd = 2L,
338 dispidAddEx = 3L,
339 dispidFindColumn = 4L,
340 };
341
343# endif
344};
345
346AFX_INLINE int CXTPGridColumns::GetCount() const
347{
348 return (int)m_arrColumns.GetSize();
349}
350
351AFX_INLINE CXTPGridColumn* CXTPGridColumns::GetAt(int nIndex) const
352{
353 return (nIndex >= 0 && nIndex < GetCount()) ? m_arrColumns.GetAt(nIndex) : NULL;
354}
355
356AFX_INLINE CXTPGridColumnOrder* CXTPGridColumns::GetGroupsOrder() const
357{
358 return m_pGroupsOrder;
359}
360
361AFX_INLINE CXTPGridColumnOrder* CXTPGridColumns::GetSortOrder() const
362{
363 return m_pSortOrder;
364}
365
366AFX_INLINE CXTPGridColumn* CXTPGridColumns::GetIndentColumn() const
367{
368 return (GetCount() > 0) ? m_arrColumns.GetAt(0) : NULL;
369}
370
383class _XTP_EXT_CLASS CXTPGridColumnOrder : public CXTPCmdTarget
384{
385public:
391 CXTPGridColumnOrder(CXTPGridColumns* pColumns);
392
403 CXTPGridColumn* GetAt(int nIndex);
404
413 int InsertAt(int nIndex, CXTPGridColumn* pColumn);
414
420 void RemoveAt(int nIndex);
421
427 void Remove(CXTPGridColumn* pColumn);
428
438 int Add(CXTPGridColumn* pColumn);
439
451 int Add(CXTPGridColumn* pColumn, BOOL bSortIncreasing);
452
464 int IndexOf(const CXTPGridColumn* pColumn);
465
470 void Clear();
471
478 int GetCount() const;
479
485 virtual void DoPropExchange(CXTPPropExchange* pPX);
486
487protected:
488 CXTPGridColumns* m_pColumns;
490 CArray<CXTPGridColumn*, CXTPGridColumn*> m_arrColumns;
493# ifdef _XTP_ACTIVEX
495 DECLARE_DISPATCH_MAP()
496 DECLARE_INTERFACE_MAP()
497
498 DECLARE_OLETYPELIB_EX(CXTPGridColumnOrder);
499
500 afx_msg int OleGetItemCount();
501 afx_msg LPDISPATCH OleGetItem(long nIndex);
502 afx_msg void OleAdd(LPDISPATCH lpColumn);
503 afx_msg int OleIndexOf(LPDISPATCH lpColumn);
504
505 DECLARE_ENUM_VARIANT(CXTPGridColumnOrder)
506
507 enum
508 {
509 dispidCount = 1L,
510 };
511
513# endif
514};
516AFX_INLINE CXTPGridHeader* CXTPGridColumns::GetReportHeader() const
517{
518 return GetGridHeader();
519}
520
521# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
522#endif // #if !defined(__XTPGRIDCOLUMNS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridColumnOrder
Represents the column order, used for sorting and grouping.
Definition XTPGridColumns.h:384
CXTPGridColumnOrder::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes column order settings to/from the provided archive stream.
CXTPGridColumnOrder::IndexOf
int IndexOf(const CXTPGridColumn *pColumn)
Retrieves the index of a column.
CXTPGridColumnOrder::GetCount
int GetCount() const
Gets the number of columns in the collection.
CXTPGridColumnOrder::Remove
void Remove(CXTPGridColumn *pColumn)
Removes a specified column from the collection.
CXTPGridColumnOrder::m_pColumns
CXTPGridColumns * m_pColumns
Parent columns array.
Definition XTPGridColumns.h:488
CXTPGridColumnOrder::m_arrColumns
CArray< CXTPGridColumn *, CXTPGridColumn * > m_arrColumns
Storage for column items with the corresponding order.
Definition XTPGridColumns.h:490
CXTPGridColumnOrder::GetAt
CXTPGridColumn * GetAt(int nIndex)
Retrieves the column item at a specified index in the collection.
CXTPGridColumnOrder::InsertAt
int InsertAt(int nIndex, CXTPGridColumn *pColumn)
Inserts a specified column at a specified index.
CXTPGridColumnOrder::Add
int Add(CXTPGridColumn *pColumn)
Adds a specified column to the end of the collection.
CXTPGridColumnOrder::Add
int Add(CXTPGridColumn *pColumn, BOOL bSortIncreasing)
Adds a specified column to the end of the collection.
CXTPGridColumnOrder::Clear
void Clear()
Clears all stored order information.
CXTPGridColumnOrder::CXTPGridColumnOrder
CXTPGridColumnOrder(CXTPGridColumns *pColumns)
Constructs a CXTPGridColumnOrder object.
CXTPGridColumnOrder::RemoveAt
void RemoveAt(int nIndex)
Removes the column at a specified index from the collection.
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridColumns::GetCount
int GetCount() const
Retrieves the total number of column items in the collection.
Definition XTPGridColumns.h:346
CXTPGridColumns::GetAt
CXTPGridColumn * GetAt(int nIndex) const
Retrieves the column item at a specified index in the collection.
Definition XTPGridColumns.h:351
CXTPGridColumns::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes configuration to/from the provided archive stream.
CXTPGridColumns::Find
CXTPGridColumn * Find(const CString &strInternalName) const
Finds a specified column by its item index/internal name.
CXTPGridColumns::Remove
void Remove(CXTPGridColumn *pColumn)
Removes a specified column from the collection.
CXTPGridColumns::CXTPGridColumns
CXTPGridColumns(CXTPGridControl *pControl)
Constructs a CXTPGridColumns object.
CXTPGridColumns::ResetSortOrder
void ResetSortOrder()
Clears the sort order for all columns.
CXTPGridColumns::GetGridHeader
CXTPGridHeader * GetGridHeader() const
Gets the associated grid header object.
CXTPGridColumns::GetIndentColumn
CXTPGridColumn * GetIndentColumn() const
Gets the indentation column of this collection.
Definition XTPGridColumns.h:366
CXTPGridColumns::IndexOf
int IndexOf(const CXTPGridColumn *pColumn) const
Retrieves the index of a column.
CXTPGridColumns::GetLastVisibleColumn
CXTPGridColumn * GetLastVisibleColumn() const
Gets the last visible column in the collection.
CXTPGridColumns::m_arrColumns
CArray< CXTPGridColumn *, CXTPGridColumn * > m_arrColumns
Storage for column items.
Definition XTPGridColumns.h:314
CXTPGridColumns::SetSortColumn
void SetSortColumn(CXTPGridColumn *pColumn, BOOL bIncreasing)
Sets a specified column as the sorted column and resets the previous sort order.
CXTPGridColumns::GetAtOffset
int GetAtOffset(int nOffset, BOOL bFrozen) const
Retrieves the index of the column at a specified left offset.
CXTPGridColumns::Add
void Add(CXTPGridColumn *pColumn)
Adds a specified column to the end of the collection.
CXTPGridColumns::InsertSortColumn
void InsertSortColumn(CXTPGridColumn *pColumn)
Inserts a specified column to the sort columns array according to the columns order of the group colu...
CXTPGridColumns::~CXTPGridColumns
virtual ~CXTPGridColumns()
Destroys a CXTPGridColumns object.
CXTPGridColumns::GetFirstVisibleColumn
CXTPGridColumn * GetFirstVisibleColumn() const
Gets the first visible column in the collection.
CXTPGridColumns::m_pControl
CXTPGridControl * m_pControl
Pointer to the associated Grid control object.
Definition XTPGridColumns.h:315
CXTPGridColumns::GetGroupsOrder
CXTPGridColumnOrder * GetGroupsOrder() const
Gets the columns groups order array.
Definition XTPGridColumns.h:356
CXTPGridColumns::Find
CXTPGridColumn * Find(int nItemIndex) const
Finds a specified column by its item index/internal name.
CXTPGridColumns::m_pTreeColumn
CXTPGridColumn * m_pTreeColumn
Column containing tree view images.
Definition XTPGridColumns.h:316
CXTPGridColumns::Clear
void Clear()
Clears all column collection items.
CXTPGridColumns::ChangeColumnOrder
int ChangeColumnOrder(int nNewIndex, int nOldIndex)
Repositions a specified column in the collection.
CXTPGridColumns::GetSortOrder
CXTPGridColumnOrder * GetSortOrder() const
Gets the columns sort order array.
Definition XTPGridColumns.h:361
CXTPGridColumns::GetVisibleAt
CXTPGridColumn * GetVisibleAt(int nIndex) const
Retrieves the closest visible column to a specified index in the collection that appears at or before...
CXTPGridColumns::GetOffset
int GetOffset(int nIndex) const
Retrieves the left offset, in pixels, of the column at a specified index.
CXTPGridColumns::GetVisibleColumnsCount
int GetVisibleColumnsCount() const
Retrieves the number of visible columns in the collection.
CXTPGridColumns::m_pGroupsOrder
CXTPGridColumnOrder * m_pGroupsOrder
Container for the columns order in auto-grouping mode.
Definition XTPGridColumns.h:311
CXTPGridColumns::m_pSortOrder
CXTPGridColumnOrder * m_pSortOrder
Container for the columns sort order.
Definition XTPGridColumns.h:313
CXTPGridColumns::GetVisibleColumns
void GetVisibleColumns(CXTPGridColumns &arrColumns) const
Retrieves all visible columns in the collection and places them within a referenced CXTPGridColumns a...
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPMessageBarButton Member List

This is the complete list of members for CXTPMessageBarButton, including all inherited members.

CXTPMessageBarButton() | CXTPMessageBarButton
m_bHot | CXTPMessageBarButton
m_bPressed | CXTPMessageBarButton
m_nID | CXTPMessageBarButton
m_pUIElement | CXTPMessageBarButton
m_rcButton | CXTPMessageBarButton
m_strCaption | CXTPMessageBarButton
m_strToolTip | CXTPMessageBarButton
PerformClick(CXTPMessageBar *pBar, CPoint pt) | CXTPMessageBarButton
~CXTPMessageBarButton() | CXTPMessageBarButton


Toolkit Pro: XTPChartRadarAreaSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Radar
XTPChartRadarAreaSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRADARAREASERIESVIEW_H__)
24# define __XTPCHARTRADARAREASERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
41class _XTP_EXT_CLASS CXTPChartRadarAreaSeriesView : public CXTPChartRadarDiagramSeriesView
42{
43public:
51 CXTPChartRadarAreaSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
52
53protected:
65 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
66 CXTPChartSeriesPoint* pPoint,
67 CXTPChartElementView* pParentView);
68
69 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
70
71public:
79 CXTPChartColor GetActualColor() const;
80
88 CXTPChartColor GetActualColor2() const;
89
97 CXTPChartColor GetBorderActualColor() const;
98
109 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
110 CRect rcBounds);
111};
113# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif //#if !defined(__XTPCHARTRADARAREASERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartRadarAreaSeriesView
This class represents the view of a point series, which is a kind of CXTPChartSeriesView.
Definition XTPChartRadarAreaSeriesView.h:42
CXTPChartRadarAreaSeriesView::GetBorderActualColor
CXTPChartColor GetBorderActualColor() const
Call this function to get the actual color of the series border.
CXTPChartRadarAreaSeriesView::GetActualColor
CXTPChartColor GetActualColor() const
Call this function to get the actual color of the series.
CXTPChartRadarAreaSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRadarAreaSeriesView::GetActualColor2
CXTPChartColor GetActualColor2() const
Call this function to get the second actual color of the series.
CXTPChartRadarAreaSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartRadarAreaSeriesView::CXTPChartRadarAreaSeriesView
CXTPChartRadarAreaSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPointSeriesView object.
CXTPChartRadarAreaSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the series points.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


CXTPControls Member List

This is the complete list of members for CXTPControls, including all inherited members.

Add(CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(CXTPControl *pControl) | CXTPControls |
AddClone(CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE) | CXTPControls |
AddMenuItem(CMenu *pMenu, int nIndex) | CXTPControls |
CalcDynamicSize(CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0) | CXTPControls |
CalcPopupSize(CDC *pDC, int nLength, int nWidth, const CRect &rcBorder) | CXTPControls |
ClearOriginalControls() | CXTPControls |
CommandToIndex(int nIDFind) const | CXTPControls |
Compare(const CXTPControls *pControls) | CXTPControls |
Copy(CXTPControls *pControls, BOOL bRecursive=FALSE) | CXTPControls | virtual
CreateOriginalControls() | CXTPControls |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControls() | CXTPControls |
DoPropExchange(CXTPPropExchange *pPX) | CXTPControls | virtual
Duplicate(BOOL bRecursive=FALSE) | CXTPControls |
FindControl(int nId) const | CXTPControls |
FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const | CXTPControls |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPControls |
GetCommandBars() const | CXTPControls |
GetCount() const | CXTPControls |
GetFirst() const | CXTPControls |
GetNext(CXTPControl *&pControl) const | CXTPControls |
GetNext(long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const | CXTPControls |
GetOriginalControls() const | CXTPControls |
GetParent() const | CXTPControls |
GetVisibleAt(int nIndex, BOOL bIgnoreWraps=FALSE) const | CXTPControls |
GetVisibleCount(BOOL bIgnoreWrap=FALSE) const | CXTPControls |
HitTest(CPoint point) const | CXTPControls |
InsertAt(CXTPControl *pControl, int nBefore) | CXTPControls |
IsChanged() const | CXTPControls |
IsOriginalControls() const | CXTPControls |
LoadMenu(CMenu *pMenu) | CXTPControls |
m_arrControls | CXTPControls | protected
m_bOriginalControls | CXTPControls | protected
m_pCommandBars | CXTPControls | protected
m_pOriginalControls | CXTPControls | protected
m_pParent | CXTPControls | protected
MoveBefore(CXTPControl *pControl, int nBefore) | CXTPControls |
OnControlAdded(CXTPControl *pControl) | CXTPControls | protectedvirtual
OnControlRemoved(CXTPControl *pControl) | CXTPControls | protectedvirtual
OnControlRemoving(CXTPControl *pControl) | CXTPControls | protectedvirtual
Remove(CXTPControl *pControl) | CXTPControls | virtual
Remove(int nIndex) | CXTPControls |
RemoveAll() | CXTPControls |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPControls |
SetControlType(CXTPControl *pControl, XTPControlType type) | CXTPControls |
SetControlType(int nIndex, XTPControlType type) | CXTPControls |
SetOriginalControls(CXTPOriginalControls *pControls) | CXTPControls |
SetParent(CXTPCommandBar *pParent) | CXTPControls |
ShouldSerializeControl(CXTPControl *pControl) | CXTPControls | virtual
Sort() | CXTPControls |
~CXTPControls() | CXTPControls | virtual


CXTPMarkupSystemBrushKeyStaticExtension Member List

This is the complete list of members for CXTPMarkupSystemBrushKeyStaticExtension, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
CXTPMarkupSystemBrushKeyStaticExtension(LPCWSTR lpzName, int nColorIndex) | CXTPMarkupSystemBrushKeyStaticExtension |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


CXTPTabPaintManagerTheme Member List

This is the complete list of members for CXTPTabPaintManagerTheme, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabPaintManagerTheme | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPTabPaintManagerTheme | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


CXTPTabColorSetNativeWindows11 Member List

This is the complete list of members for CXTPTabColorSetNativeWindows11, including all inherited members.

CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPTabColorSetVisualStudio2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabColorSetVisualStudio2012 | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPTabColorSetVisualStudio2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPTabColorSetNativeWindows11 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


CXTPTaskPanelOfficeXPThemePlain Member List

This is the complete list of members for CXTPTaskPanelOfficeXPThemePlain, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelOfficeXPThemePlain() | CXTPTaskPanelOfficeXPThemePlain |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelOfficeXPThemePlain | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


CXTPDockingPaneTabTheme2022 Member List

This is the complete list of members for CXTPDockingPaneTabTheme2022, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPaneTabTheme2012() | CXTPDockingPaneTabTheme2012 |
CXTPDockingPaneTabTheme2022() | CXTPDockingPaneTabTheme2022 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPaneTabTheme2022 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPDockingPaneTabTheme2012 | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPaneTabTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


CXTPShellPidl Member List

This is the complete list of members for CXTPShellPidl, including all inherited members.

ComparePidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2, LPSHELLFOLDER pShellFolder=NULL) | CXTPShellPidl |
ConcatPidls(LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2) | CXTPShellPidl |
ConcatPidls(LPMALLOC lpMalloc, LPCITEMIDLIST pidl1, LPCITEMIDLIST pidl2) | CXTPShellPidl |
CopyIDList(LPITEMIDLIST pidl) | CXTPShellPidl |
CopyPidlItem(LPITEMIDLIST pidl, UINT nItem) | CXTPShellPidl |
CreatePidl(LPMALLOC lpMalloc, UINT cbSize) | CXTPShellPidl |
CXTPShellPidl() | CXTPShellPidl |
DuplicateItem(LPMALLOC lpMalloc, LPITEMIDLIST lpi) | CXTPShellPidl |
FreePidl(LPITEMIDLIST pidl) | CXTPShellPidl |
GetAttributes(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, ULONG uFlags) const | CXTPShellPidl |
GetFullyQualPidl(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi) | CXTPShellPidl |
GetItemIcon(LPITEMIDLIST lpi, UINT uFlags) const | CXTPShellPidl |
GetLastITEM(LPITEMIDLIST pidl) | CXTPShellPidl |
GetName(LPSHELLFOLDER lpsf, LPITEMIDLIST lpi, DWORD dwFlags, CString &lpFriendlyName) | CXTPShellPidl |
GetNextPidlItem(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetPidlCount(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetPidlItemCount(LPCITEMIDLIST pidl) | CXTPShellPidl |
GetSHContextMenu(LPSHELLFOLDER psfFolder, LPCITEMIDLIST *localPidl, int nCount, void **ppCM, int *pcmType) | CXTPShellPidl |
GetSystemImageList(UINT uFlags) const | CXTPShellPidl |
IDLFromPath(LPCTSTR path) | CXTPShellPidl |
ListViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort) | CXTPShellPidl | static
m_bShowShellLinkIcons | CXTPShellPidl | protected
m_ulSFGAOFlags | CXTPShellPidl | protected
MapShellFlagsToItemAttributes(CListCtrl *pListCtrl, int iItem, DWORD dwAttributes) | CXTPShellPidl | protectedvirtual
MapShellFlagsToItemAttributes(CTreeCtrl *pTreeCtrl, HTREEITEM hItem, DWORD dwAttributes) | CXTPShellPidl | protectedvirtual
OneUpPATH(const CString &path) | CXTPShellPidl |
OneUpPIDL(LPITEMIDLIST pidlPath) | CXTPShellPidl |
OnShowContextMenu(int idCmd, CMINVOKECOMMANDINFO &cmi) | CXTPShellPidl | protectedvirtual
ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPITEMIDLIST lpi, LPPOINT lppt) | CXTPShellPidl |
ShowContextMenu(HWND hwnd, LPSHELLFOLDER lpsfParent, LPCITEMIDLIST *lppi, int nCount, LPPOINT lppt) | CXTPShellPidl |
ShowShellLinkIcons(BOOL bShowLinkIcons=TRUE) | CXTPShellPidl |
TreeViewCompareProc(LPARAM lparam1, LPARAM lparam2, LPARAM lparamSort) | CXTPShellPidl | static
~CXTPShellPidl() | CXTPShellPidl | virtual


CXTPShortcutListBox Member List

This is the complete list of members for CXTPShortcutListBox, including all inherited members.

AddMenuItem(UINT nIconID, LPCTSTR lpszText, BOOL bEnabled=TRUE) | CXTPShortcutListBox |
CContentItemList typedef | CXTPShortcutListBox |
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPShortcutListBox | virtual
CXTPShortcutListBox() | CXTPShortcutListBox |
EnableMenuItem(int iItem, BOOL bEnabled) | CXTPShortcutListBox |
GetMenuItem(int iItem) | CXTPShortcutListBox |
GetTextHeight(LPCTSTR lspzItem) const | CXTPShortcutListBox |
GetTheme() | CXTPShortcutListBox |
InsertMenuItem(int iIndex, UINT nIconID, LPCTSTR lpszText, BOOL bEnabled=TRUE) | CXTPShortcutListBox |
m_arContentItems | CXTPShortcutListBox | protected
m_bHilight | CXTPShortcutListBox | protected
m_bHilightItemID | CXTPShortcutListBox | protected
m_bNoBorder | CXTPShortcutListBox |
m_bNoUnderline | CXTPShortcutListBox |
m_bTimerActive | CXTPShortcutListBox | protected
m_hCursor | CXTPShortcutListBox | protected
m_nPrevIndex | CXTPShortcutListBox | protected
m_point | CXTPShortcutListBox | protected
m_pTheme | CXTPShortcutListBox | protected
RefreshMetrics() | CXTPShortcutListBox | protectedvirtual
SetColors(COLORREF clrText, COLORREF clrBack, COLORREF clrBackDark=COLORREF_NULL) | CXTPShortcutListBox |
SetHighlightCursor(UINT nIDCursor, bool bNoBorder=false, bool bNoUnderline=false) | CXTPShortcutListBox |
SetTheme(XTPControlTheme eTheme) | CXTPShortcutListBox |
~CXTPShortcutListBox() | CXTPShortcutListBox | virtual


Toolkit Pro: XTPChartAxisView.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISVIEW_H__)
24# define __XTPCHARTAXISVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagram2DAxisView;
34class CXTPChartAxisRange;
35class CXTPChartAxis;
36class CXTPChartSeriesView;
37
42class _XTP_EXT_CLASS CXTPChartAxisViewTick
43{
44public:
45 double m_dValue;
46 CXTPChartString m_strLabel;
47 CSize m_szBounds;
48 CXTPChartSizeF m_szLabel;
49};
50
51class _XTP_EXT_CLASS CXTPChartAxisView : public CXTPChartElementView
52{
53protected:
61 CXTPChartAxisView(CXTPChartAxis* pAxis, CXTPChartElementView* pParentView);
62 ~CXTPChartAxisView();
63
64public:
69 CXTPChartAxis* GetAxis() const;
70
71public:
72 virtual void CreateView(CXTPChartDeviceContext* pDC) = 0;
73 virtual void CalcSize(CXTPChartDeviceContext* pDC, CRect rcDiagram) = 0;
74 virtual void SetBounds(CXTPChartDeviceContext* pDC, CRect rcBounds) = 0;
75
76public:
83 double GetGridSpacing() const;
84
85public:
86 double GetRangeMinValue() const;
87 double GetRangeMaxValue() const;
88
89 double GetViewRangeMinValue() const;
90 double GetViewRangeMaxValue() const;
91
92 double GetAxisRangeMinValue() const;
93 double GetAxisRangeMaxValue() const;
94
95 double ValueToAxis(double dValue) const;
96 double AxisToValue(double dValue) const;
97
98public:
99 void AddLegendItems();
100
101protected:
113 double CalculateGridSpacing(double nAxisRangeDelta, double nScreenDelta,
114 double nGridSpacingFactor);
115
116public:
117 CArray<CXTPChartSeriesView*, CXTPChartSeriesView*> m_arrSeries;
118 CXTPChartAxis* m_pAxis;
119 double m_dGridSpacing;
120};
121
127class _XTP_EXT_CLASS CXTPChartDiagram2DAxisView : public CXTPChartAxisView
128{
129public:
137 CXTPChartDiagram2DAxisView(CXTPChartAxis* pAxis, CXTPChartElementView* pParentView);
138
143 ~CXTPChartDiagram2DAxisView();
144
145public:
146 CRect GetBounds() const;
147
148public:
160 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
161
174 virtual CXTPChartDeviceCommand* CreateGridLinesDeviceCommand(CXTPChartDeviceContext* pDC,
175 CRect rcPane);
176
189 virtual CXTPChartDeviceCommand* CreateInterlacedDeviceCommand(CXTPChartDeviceContext* pDC,
190 CRect rcPane);
191
203 virtual CXTPChartDeviceCommand* CreateTickMarksDeviceCommand(CXTPChartDeviceContext* pDC);
204
205 virtual CXTPChartDeviceCommand* CreateScrollBarDeviceCommand(CXTPChartDeviceContext* pDC);
206
207 void PerformMouseWheel(short zDelta, CPoint pt);
208 void PerformPaneDragging(int dx, int dy);
209 void OnLButtonDown(UINT nFlags, CPoint point);
210 void OnMouseMove(UINT nFlags, CPoint point);
211
223 virtual CXTPChartDeviceCommand* CreateLabelsDeviceCommand(CXTPChartDeviceContext* pDC);
224
236 virtual CXTPChartDeviceCommand* CreateTitleDeviceCommand(CXTPChartDeviceContext* pDC);
237
251 virtual CXTPChartDeviceCommand* CreateConstantLinesDeviceCommand(CXTPChartDeviceContext* pDC,
252 CRect rcPane, BOOL bBehind);
253
266 virtual CXTPChartDeviceCommand* CreateStripsDeviceCommand(CXTPChartDeviceContext* pDC,
267 CRect rcPane);
268
279 void CreateView(CXTPChartDeviceContext* pDC);
280
289 void CalcSize(CXTPChartDeviceContext* pDC, CRect rcDiagram);
290
298 void SetBounds(CXTPChartDeviceContext* pDC, CRect rcBounds);
299
307 double ValueToPoint(double nValue) const;
308
309 double PointToValue(int nPoint) const;
310
318 double DistanceToPoint(double nDistance) const;
319
320 double GetScale() const;
321
322 BOOL IsScollBarVisible() const;
323
331 int GetSize() const;
332
339 BOOL IsVertical() const;
340
341protected:
349 void CreateTickMarks(CXTPChartDeviceContext* pDC, CRect rcDiagram);
350
351public:
352 CArray<CXTPChartAxisViewTick, CXTPChartAxisViewTick&> m_arrTicks;
354 CArray<double, double&> m_arrMinorTicks;
355
356protected:
357 CRect m_rcBounds;
358 int m_nSize;
360 CPoint m_ptOldPosition;
361
362 CXTPChartRectF m_rcScrollBar;
363 CXTPChartRectF m_rcThumb;
364};
365
366AFX_INLINE CXTPChartAxis* CXTPChartAxisView::GetAxis() const
367{
368 return m_pAxis;
369}
370AFX_INLINE int CXTPChartDiagram2DAxisView::GetSize() const
371{
372 return m_nSize;
373}
374AFX_INLINE CRect CXTPChartDiagram2DAxisView::GetBounds() const
375{
376 return m_rcBounds;
377}
378
379AFX_INLINE double CXTPChartAxisView::GetGridSpacing() const
380{
381 return m_dGridSpacing;
382}
384# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
385#endif //#if !defined(__XTPCHARTAXISVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisRange
This class represents the value range of the axis.
Definition XTPChartAxisRange.h:44
CXTPChartAxisViewTick
This class represents a tick mark in the axis.
Definition XTPChartAxisView.h:43
CXTPChartAxisViewTick::m_strLabel
CXTPChartString m_strLabel
The tick mark label.
Definition XTPChartAxisView.h:46
CXTPChartAxisViewTick::m_szLabel
CXTPChartSizeF m_szLabel
The size of the label.
Definition XTPChartAxisView.h:48
CXTPChartAxisViewTick::m_szBounds
CSize m_szBounds
The boundary.
Definition XTPChartAxisView.h:47
CXTPChartAxisViewTick::m_dValue
double m_dValue
The value of the tick mark.
Definition XTPChartAxisView.h:45
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DAxisView
This class abstracts the view of a chart axis and its child items in a bounding rectangle context.
Definition XTPChartAxisView.h:128
CXTPChartDiagram2DAxisView::DistanceToPoint
double DistanceToPoint(double nDistance) const
Call this function to get the distance of a point from the axis origin.
CXTPChartDiagram2DAxisView::m_arrTicks
CArray< CXTPChartAxisViewTick, CXTPChartAxisViewTick & > m_arrTicks
The collection of tick marks.
Definition XTPChartAxisView.h:352
CXTPChartDiagram2DAxisView::SetBounds
void SetBounds(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function sets the bounds for the axis.
CXTPChartDiagram2DAxisView::CXTPChartDiagram2DAxisView
CXTPChartDiagram2DAxisView(CXTPChartAxis *pAxis, CXTPChartElementView *pParentView)
Constructs a CXTPChartDiagram2DAxisView object.
CXTPChartDiagram2DAxisView::CreateInterlacedDeviceCommand
virtual CXTPChartDeviceCommand * CreateInterlacedDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DAxisView::m_nSize
int m_nSize
The axis size;.
Definition XTPChartAxisView.h:358
CXTPChartDiagram2DAxisView::CreateStripsDeviceCommand
virtual CXTPChartDeviceCommand * CreateStripsDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DAxisView::~CXTPChartDiagram2DAxisView
~CXTPChartDiagram2DAxisView()
Destroys a CXTPChartDiagram2DAxisView object, handles cleanup and deallocation.
CXTPChartDiagram2DAxisView::ValueToPoint
double ValueToPoint(double nValue) const
Call this function to get a point on the axis from a value within the range.
CXTPChartDiagram2DAxisView::CreateTitleDeviceCommand
virtual CXTPChartDeviceCommand * CreateTitleDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DAxisView::CalcSize
void CalcSize(CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function calculates the size of an axis, including its constituent elements (e....
CXTPChartDiagram2DAxisView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
Override this function to create a CXTPChartDeviceCommand object.
CXTPChartDiagram2DAxisView::GetSize
int GetSize() const
This function returns the size of the axis.
Definition XTPChartAxisView.h:370
CXTPChartDiagram2DAxisView::CreateConstantLinesDeviceCommand
virtual CXTPChartDeviceCommand * CreateConstantLinesDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane, BOOL bBehind)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DAxisView::CreateTickMarks
void CreateTickMarks(CXTPChartDeviceContext *pDC, CRect rcDiagram)
This function creates the axis tick marks.
CXTPChartDiagram2DAxisView::CreateLabelsDeviceCommand
virtual CXTPChartDeviceCommand * CreateLabelsDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DAxisView::CreateView
void CreateView(CXTPChartDeviceContext *pDC)
Call this function to create the chart axis view.
CXTPChartDiagram2DAxisView::m_rcBounds
CRect m_rcBounds
The diagram boundary.
Definition XTPChartAxisView.h:357
CXTPChartDiagram2DAxisView::CreateTickMarksDeviceCommand
virtual CXTPChartDeviceCommand * CreateTickMarksDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartDiagram2DAxisView::IsVertical
BOOL IsVertical() const
This function checks if the axis is vertical.
CXTPChartDiagram2DAxisView::CreateGridLinesDeviceCommand
virtual CXTPChartDeviceCommand * CreateGridLinesDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcPane)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPRectT< float >
CXTPSizeT
This class incapsulates size data.
Definition XTPSize.h:40


Toolkit Pro: XTPChartControl.h Source File

  • Source
  • Chart
XTPChartControl.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTCONTROL_H__)
24# define __XTPCHARTCONTROL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33const UINT WM_XTP_CHART_BASE = (WM_USER + 9700);
34
35static const DWORD XTP_NC_CHARTMOUSEMOVE = (WM_XTP_CHART_BASE + 1);
36
37class CXTPChartContent;
38class CXTPChartDeviceCommand;
39class CXTPChartDrawThread;
40class CXTPChartDrawThreadDeviceCommand;
41class CXTPChartContentView;
42class CXTPToolTipContext;
43
49class _XTP_EXT_CLASS CXTPChartControl
50 : public CWnd
51 , public CXTPChartContainer
52{
53public:
58 CXTPChartControl();
59
64 virtual ~CXTPChartControl();
65
66public:
74 CXTPChartContent* GetContent() const;
75
79 virtual CWnd* GetControl();
80
94 using CWnd::Create;
95
96 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
97
98 void Draw(CDC* pDC, CRect rc);
99
100public:
108 void OnChartChanged(XTPChartUpdateOptions updateOptions = xtpChartUpdateView);
109
119 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
120
121public:
131 CXTPChartElement* HitTest(CPoint point) const;
132
141 BOOL PrintToDC(HDC hDC, CRect rcBounds);
142
150 BOOL CopyToClipboard(CSize szSize);
151
160 BOOL SaveAsImage(LPCTSTR lpszFilePath, CSize szBounds);
161
168 void SetContent(CXTPChartContent* pContent);
169
183 void SetUpdateWindow(BOOL bUpdateWindow);
184
192 CXTPToolTipContext* GetToolTipContext() const;
193
200 void EnableToolTips(BOOL bEnable /* = TRUE */);
201
202public:
209 void SetCapture(CXTPChartElementView* pView);
210
211protected:
212 //{{AFX_VIRTUAL
213 virtual void PreSubclassWindow();
214 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
215 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
216 //}}AFX_VIRTUAL
217
219 DECLARE_MESSAGE_MAP();
220 afx_msg void OnPaint();
221 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
222 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
223 afx_msg void OnSize(UINT nType, int cx, int cy);
224 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
225 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
226 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
227 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
228 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
229 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
230 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
231 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
232 afx_msg void OnCaptureChanged(CWnd* pWnd);
233 afx_msg void OnSetFocus(CWnd* pOldWnd);
234 afx_msg void OnKillFocus(CWnd* pNewWnd);
237protected:
238 CXTPChartContent* m_pContent;
240 CBitmap m_bmpCache;
241 CXTPChartDrawThreadDeviceCommand* m_pCommand;
242 CXTPChartContentView* m_pContentView;
243 DWORD m_dwUpdateOptions;
244 CXTPToolTipContext* m_pToolTipContext;
246 CXTPChartDrawThread* m_pDrawThread;
247 CXTPChartElementView* m_pCaptureView;
248 BOOL m_bUpdateWindow;
249};
250
251AFX_INLINE CXTPChartContent* CXTPChartControl::GetContent() const
252{
253 return m_pContent;
254}
255AFX_INLINE void CXTPChartControl::SetUpdateWindow(BOOL bUpdateWindow)
256{
257 m_bUpdateWindow = bUpdateWindow;
258}
259AFX_INLINE CXTPToolTipContext* CXTPChartControl::GetToolTipContext() const
260{
261 return m_pToolTipContext;
262}
264# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
265#endif //#if !defined(__XTPCHARTCONTROL_H__)
XTPChartUpdateOptions
XTPChartUpdateOptions
Specifies chart update options.
Definition XTPChartElement.h:45
xtpChartUpdateView
@ xtpChartUpdateView
Recreate View.
Definition XTPChartElement.h:46
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartContainer
This class represents the chart container.
Definition XTPChartElement.h:232
CXTPChartContent
This class represents chart content, which is a kind of CXTPChartElement.
Definition XTPChartContent.h:66
CXTPChartContentView
This class represents the view of the chart content, which is a kind of CXTPChartElementView.
Definition XTPChartContentView.h:56
CXTPChartControl
CXTPChartControl is a CWnd derived class.
Definition XTPChartControl.h:52
CXTPChartControl::m_dwUpdateOptions
DWORD m_dwUpdateOptions
Update options.
Definition XTPChartControl.h:243
CXTPChartControl::CXTPChartControl
CXTPChartControl()
Constructs a CXTPChartControl object.
CXTPChartControl::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPChartControl::m_bmpCache
CBitmap m_bmpCache
Bitmap Cache.
Definition XTPChartControl.h:240
CXTPChartControl::OnChartChanged
void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this function whenever a change occurs in the chart content.
CXTPChartControl::m_pCommand
CXTPChartDrawThreadDeviceCommand * m_pCommand
Root of Chart Command tree.
Definition XTPChartControl.h:241
CXTPChartControl::GetControl
virtual CWnd * GetControl()
Obtains Chart control's window object.
CXTPChartControl::SetUpdateWindow
void SetUpdateWindow(BOOL bUpdateWindow)
Call this method to enable/disable automatic chart updates when a change is detected.
Definition XTPChartControl.h:255
CXTPChartControl::m_pContentView
CXTPChartContentView * m_pContentView
Current Content View.
Definition XTPChartControl.h:242
CXTPChartControl::m_bUpdateWindow
BOOL m_bUpdateWindow
UpdateWindow flag.
Definition XTPChartControl.h:248
CXTPChartControl::~CXTPChartControl
virtual ~CXTPChartControl()
Destroys a CXTPChartControl object, handles cleanup.
CXTPChartControl::m_pToolTipContext
CXTPToolTipContext * m_pToolTipContext
Tooltip Context.
Definition XTPChartControl.h:244
CXTPChartControl::HitTest
CXTPChartElement * HitTest(CPoint point) const
Call this method to hit test the element under the cursor.
CXTPChartControl::SaveAsImage
BOOL SaveAsImage(LPCTSTR lpszFilePath, CSize szBounds)
Call this method to save chart to a file as an image.
CXTPChartControl::SetContent
void SetContent(CXTPChartContent *pContent)
Call this method to set the content of the chart control.
CXTPChartControl::m_pCaptureView
CXTPChartElementView * m_pCaptureView
Captured View.
Definition XTPChartControl.h:247
CXTPChartControl::EnableToolTips
void EnableToolTips(BOOL bEnable)
Call this method to enable chart tooltips.
CXTPChartControl::m_pDrawThread
CXTPChartDrawThread * m_pDrawThread
Helper draw thread that render 3D Charts.
Definition XTPChartControl.h:246
CXTPChartControl::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Call this method to get a pointer to the tooltip context.
Definition XTPChartControl.h:259
CXTPChartControl::GetContent
CXTPChartContent * GetContent() const
Call this function to get the pointer to the chart content object.
Definition XTPChartControl.h:251
CXTPChartControl::SetCapture
void SetCapture(CXTPChartElementView *pView)
Call this method to set capture to view.
CXTPChartControl::m_pContent
CXTPChartContent * m_pContent
Chart Content.
Definition XTPChartControl.h:238
CXTPChartControl::PrintToDC
BOOL PrintToDC(HDC hDC, CRect rcBounds)
Call this method to draw chart to a device context.
CXTPChartControl::CopyToClipboard
BOOL CopyToClipboard(CSize szSize)
Call this method to copy chart image to clipboard.
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: XTPControlGalleryVisualStudio2019Theme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryVisualStudio2019Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYVISUALSTUDIO2019THEME_H__)
24# define __XTPCONTROLGALLERYVISUALSTUDIO2019THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryVisualStudio2019Theme
41 : public CXTPControlGalleryOffice2013Theme
42{
43public:
49 CXTPControlGalleryVisualStudio2019Theme(CXTPPaintManager* pPaintManager);
50};
51
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPCONTROLGALLERYVISUALSTUDIO2019THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Com...
Definition XTPControlGalleryOffice2013Theme.h:41
CXTPControlGalleryVisualStudio2019Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2019 style theme ...
Definition XTPControlGalleryVisualStudio2019Theme.h:42
CXTPControlGalleryVisualStudio2019Theme::CXTPControlGalleryVisualStudio2019Theme
CXTPControlGalleryVisualStudio2019Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2019Theme object.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


CXTPPropertyGridItemPoint Member List

This is the complete list of members for CXTPPropertyGridItemPoint, including all inherited members.

AddChildItem(CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
AddComboButton() | CXTPPropertyGridItem |
AddExpandButton() | CXTPPropertyGridItem |
AddSliderControl() | CXTPPropertyGridItem |
AddSpinButton() | CXTPPropertyGridItem |
BindToPoint(CPoint *pBindPoint) | CXTPPropertyGridItemPoint | virtual
BindToString(CString *pBindString) | CXTPPropertyGridItem |
Collapse() | CXTPPropertyGridItem |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridItem(LPCTSTR lpszCaption, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItem(UINT nID, LPCTSTR strValue=NULL, CString *pBindString=NULL) | CXTPPropertyGridItem |
CXTPPropertyGridItemPoint(LPCTSTR strCaption, CPoint pt=0, CPoint *pBindPoint=NULL) | CXTPPropertyGridItemPoint |
CXTPPropertyGridItemPoint(UINT nID, CPoint pt=0, CPoint *pBindPoint=NULL) | CXTPPropertyGridItemPoint |
EnsureVisible() | CXTPPropertyGridItem |
Expand() | CXTPPropertyGridItem |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaption() const | CXTPPropertyGridItem |
GetCaptionMetrics() const | CXTPPropertyGridItem |
GetChilds() const | CXTPPropertyGridItem |
GetConstraintEdit() const | CXTPPropertyGridItem |
GetConstraints() const | CXTPPropertyGridItem |
GetDefaultValue() const | CXTPPropertyGridItem |
GetDescription() const | CXTPPropertyGridItem |
GetDropDownItemCount() const | CXTPPropertyGridItem |
GetEditStyle() const | CXTPPropertyGridItem | virtual
GetFlags() const | CXTPPropertyGridItem |
GetGrid() const | CXTPPropertyGridItem |
GetHeight() const | CXTPPropertyGridItem |
GetID() const | CXTPPropertyGridItem |
GetIndent() const | CXTPPropertyGridItem |
GetIndex() const | CXTPPropertyGridItem |
GetInplaceButtons() const | CXTPPropertyGridItem |
GetInplaceControls() const | CXTPPropertyGridItem |
GetInPlacedEditValue() | CXTPPropertyGridItem | inlineprotectedvirtual
GetInplaceEdit() | CXTPPropertyGridItem | virtual
GetInplaceList() | CXTPPropertyGridItem | protectedvirtual
GetItemData() const | CXTPPropertyGridItem |
GetItemRect() const | CXTPPropertyGridItem |
GetMarkupCaption() const | CXTPPropertyGridItem |
GetMarkupDescription() const | CXTPPropertyGridItem |
GetMarkupTemplate() const | CXTPPropertyGridItem | virtual
GetMarkupValue() const | CXTPPropertyGridItem |
GetMaskedText() const | CXTPPropertyGridItem |
GetMetrics(BOOL bValueMetrics, BOOL bCreate=TRUE) const | CXTPPropertyGridItem |
GetMultiLinesCount() const | CXTPPropertyGridItem |
GetParentItem() const | CXTPPropertyGridItem |
GetPoint() const | CXTPPropertyGridItemPoint | virtual
GetReadOnly() const | CXTPPropertyGridItem | virtual
GetTooltip() const | CXTPPropertyGridItem |
GetValue() const | CXTPPropertyGridItem |
GetValueMetrics() const | CXTPPropertyGridItem |
GetValueRect() | CXTPPropertyGridItem | virtual
GetViewValue() | CXTPPropertyGridItem | virtual
HasChilds() const | CXTPPropertyGridItem |
HasParent(CXTPPropertyGridItem *pParent) | CXTPPropertyGridItem |
HasVisibleChilds() const | CXTPPropertyGridItem |
InsertChildItem(int nIndex, CXTPPropertyGridItem *pItem) | CXTPPropertyGridItem |
IsAllowEdit() const | CXTPPropertyGridItem | virtual
IsCategory() const | CXTPPropertyGridItem |
IsExpandable() const | CXTPPropertyGridItem |
IsExpanded() const | CXTPPropertyGridItem |
IsHidden() const | CXTPPropertyGridItem |
IsInplaceButtonVisible(CXTPPropertyGridInplaceButton *pButton) const | CXTPPropertyGridItem | virtual
IsMultiLine() const | CXTPPropertyGridItem |
IsSelected() const | CXTPPropertyGridItem |
IsValueChanged() const | CXTPPropertyGridItem | virtual
IsVisible() const | CXTPPropertyGridItem |
m_bAutoComplete | CXTPPropertyGridItem | protected
m_bCategory | CXTPPropertyGridItem | protected
m_bConstraintEdit | CXTPPropertyGridItem | protected
m_bExpandable | CXTPPropertyGridItem | protected
m_bExpanded | CXTPPropertyGridItem | protected
m_bHidden | CXTPPropertyGridItem | protected
m_bPassword | CXTPPropertyGridItem | protected
m_bReadOnly | CXTPPropertyGridItem | protected
m_bUseMask | CXTPPropertyGridItem | protected
m_bVisible | CXTPPropertyGridItem | protected
m_chPrompt | CXTPPropertyGridItem | protected
m_dwData | CXTPPropertyGridItem | protected
m_dwEditStyle | CXTPPropertyGridItem | protected
m_nDropDownItemCount | CXTPPropertyGridItem | protected
m_nFlags | CXTPPropertyGridItem | protected
m_nHeight | CXTPPropertyGridItem | protected
m_nID | CXTPPropertyGridItem | protected
m_nIndent | CXTPPropertyGridItem | protected
m_nIndex | CXTPPropertyGridItem | protected
m_nLinesCount | CXTPPropertyGridItem | protected
m_pBindString | CXTPPropertyGridItem | protected
m_pCaptionMetrics | CXTPPropertyGridItem | mutableprotected
m_pChilds | CXTPPropertyGridItem | protected
m_pConstraints | CXTPPropertyGridItem | protected
m_pGrid | CXTPPropertyGridItem | protected
m_pInplaceButtons | CXTPPropertyGridItem | protected
m_pInplaceControls | CXTPPropertyGridItem | protected
m_pMarkupCaption | CXTPPropertyGridItem | protected
m_pMarkupDescription | CXTPPropertyGridItem | protected
m_pMarkupValue | CXTPPropertyGridItem | protected
m_pParent | CXTPPropertyGridItem | protected
m_pValueMetrics | CXTPPropertyGridItem | mutableprotected
m_strCaption | CXTPPropertyGridItem | protected
m_strDefaultValue | CXTPPropertyGridItem | protected
m_strDescription | CXTPPropertyGridItem | protected
m_strFormat | CXTPPropertyGridItem | protected
m_strLiteral | CXTPPropertyGridItem | protected
m_strMarkupTemplate | CXTPPropertyGridItem | protected
m_strMask | CXTPPropertyGridItem | protected
m_strTooltip | CXTPPropertyGridItem | protected
m_strValue | CXTPPropertyGridItem | protected
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridItem | virtual
Move(CXTPPropertyGridItem *pParent, int nIndex=-1) | CXTPPropertyGridItem |
NotifyValueChanged() | CXTPPropertyGridItem | protected
OnAfterEdit(CString &strValue) | CXTPPropertyGridItem | virtual
OnBeforeInsert() | CXTPPropertyGridItemPoint | protectedvirtual
OnCancelEdit() | CXTPPropertyGridItem | virtual
OnCaptionChanged() | CXTPPropertyGridItem | protectedvirtual
OnChar(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnConstraintsChanged() | CXTPPropertyGridItem | protectedvirtual
OnDeselect() | CXTPPropertyGridItem | protectedvirtual
OnDrawItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridItem | virtual
OnDrawItemValue(CDC &dc, CRect rcValue) | CXTPPropertyGridItem | virtual
OnIndexChanged() | CXTPPropertyGridItem | protectedvirtual
OnInpaceControlFocus(BOOL bForward) | CXTPPropertyGridItem | protectedvirtual
OnInplaceButtonDown(CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridItem | protectedvirtual
OnKeyDown(UINT nChar) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDblClk(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnLButtonUp(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnMarkupChanged() | CXTPPropertyGridItem | virtual
OnMergeItemConstraint(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint) | CXTPPropertyGridItem | virtual
OnRButtonDown(UINT nFlags, CPoint point) | CXTPPropertyGridItem | protectedvirtual
OnRequestEdit() | CXTPPropertyGridItem | virtual
OnSelect() | CXTPPropertyGridItem | protectedvirtual
OnValidateEdit() | CXTPPropertyGridItem | virtual
OnValueChanged(CString strValue) | CXTPPropertyGridItem | virtual
PtInValueRect(CPoint point) | CXTPPropertyGridItem | protected
RedrawItem() | CXTPPropertyGridItem |
Remove() | CXTPPropertyGridItem |
ResetValue() | CXTPPropertyGridItem | virtual
Select() | CXTPPropertyGridItem |
SelectNextConstraint() | CXTPPropertyGridItem | protected
SetAutoComplete(BOOL bAutoComplete=TRUE) | CXTPPropertyGridItem |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyGridItem |
SetConstraintEdit(BOOL bConstraintEdit=TRUE) | CXTPPropertyGridItem |
SetDefaultValue(LPCTSTR lpszDefaultValue) | CXTPPropertyGridItem |
SetDescription(LPCTSTR lpszDescription) | CXTPPropertyGridItem |
SetDropDownItemCount(int nDropDownItemCount) | CXTPPropertyGridItem |
SetEditStyle(DWORD dwEditStyle) | CXTPPropertyGridItem |
SetEditText(const CString &str) | CXTPPropertyGridItem | protectedvirtual
SetExpandable(BOOL bExpandable) | CXTPPropertyGridItem |
SetFlags(UINT nFlags) | CXTPPropertyGridItem |
SetFocusToInplaceControl() | CXTPPropertyGridItem | virtual
SetHeight(int nHeight) | CXTPPropertyGridItem |
SetHidden(BOOL bHidden) | CXTPPropertyGridItem |
SetID(UINT nID) | CXTPPropertyGridItem |
SetItemData(DWORD_PTR dwData) | CXTPPropertyGridItem |
SetMarkupTemplate(LPCTSTR lpstrMarkupTemplate) | CXTPPropertyGridItem |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPPropertyGridItem |
SetMaskedText(LPCTSTR lpszMaskedText) | CXTPPropertyGridItem |
SetMultiLinesCount(int nLinesCount) | CXTPPropertyGridItem |
SetPasswordMask(TCHAR chMask=_T(' *')) | CXTPPropertyGridItem |
SetPoint(CPoint pt) | CXTPPropertyGridItemPoint | virtual
SetPrompt(LPCTSTR lpszPrompt) | CXTPPropertyGridItem |
SetReadOnly(BOOL bReadOnly=TRUE) | CXTPPropertyGridItem | virtual
SetTooltip(LPCTSTR lpstrTooltip) | CXTPPropertyGridItem |
SetVisible(BOOL bVisible) | CXTPPropertyGridItem | protectedvirtual
~CXTPPropertyGridItem() | CXTPPropertyGridItem | virtual
~CXTPPropertyGridItemPoint() | CXTPPropertyGridItemPoint | virtual


CXTPDatePickerThemeOffice2000 Member List

This is the complete list of members for CXTPDatePickerThemeOffice2000, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOffice2000() | CXTPDatePickerThemeOffice2000 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerPaintManager | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerPaintManager | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerPaintManager | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerPaintManager | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerThemeOffice2000 | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerPaintManager | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOffice2000() | CXTPDatePickerThemeOffice2000 | virtual


CXTPGridHeaderDropWnd Member List

This is the complete list of members for CXTPGridHeaderDropWnd, including all inherited members.

Create(CWnd *pParentWnd, int nHeight) | CXTPGridHeaderDropWnd | virtual
CXTPGridHeaderDropWnd(COLORREF crColor) | CXTPGridHeaderDropWnd |
m_clr | CXTPGridHeaderDropWnd | protected
m_nHeight | CXTPGridHeaderDropWnd | protected
m_rgn | CXTPGridHeaderDropWnd | protected
SetWindowPos(int xPos, int yPos) | CXTPGridHeaderDropWnd |
~CXTPGridHeaderDropWnd() | CXTPGridHeaderDropWnd | virtual


Toolkit Pro: XTPChart2dPieSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 2D
XTPChart2dPieSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DPIESERIESSTYLE_H__)
24# define __XTPCHART2DPIESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartDiagramView;
34class CXTPChartSeries;
35
47class _XTP_EXT_CLASS CXTPChartPieSeriesStyle : public CXTPChartPieSeriesStyleBase
48{
50 DECLARE_SERIAL(CXTPChartPieSeriesStyle)
52public:
57 CXTPChartPieSeriesStyle();
58
59protected:
68 virtual CXTPChartDiagram* CreateDiagram();
69
80 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
81 CXTPChartDiagramView* pDiagramView);
82
83# ifdef _XTP_ACTIVEX
84public:
86 DECLARE_INTERFACE_MAP()
87 DECLARE_OLETYPELIB_EX(CXTPChartPieSeriesStyle);
88 DECLARE_OLECREATE_EX(CXTPChartPieSeriesStyle);
90# endif
91};
93# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
94#endif //#if !defined(__XTPCHART2DPIESERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartPieSeriesStyleBase
This class abstracts the basic style of a pie serie.This class is a kind of CXTPChartSeriesStyle.
Definition XTPChartPieSeriesStyleBase.h:48
CXTPChartPieSeriesStyle
This class abstracts the pie series style.
Definition XTPChart2dPieSeriesStyle.h:48
CXTPChartPieSeriesStyle::CXTPChartPieSeriesStyle
CXTPChartPieSeriesStyle()
Constructs a CXTPChartPieSeriesStyle object.
CXTPChartPieSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create the view of the pie series.
CXTPChartPieSeriesStyle::CreateDiagram
virtual CXTPChartDiagram * CreateDiagram()
Call this function to create the pie diagram object.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50


CXTPRibbonControlSystemRecentFileList Member List

This is the complete list of members for CXTPRibbonControlSystemRecentFileList, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPRibbonControlSystemPopupBarListCaption() | CXTPRibbonControlSystemPopupBarListCaption |
CXTPRibbonControlSystemRecentFileList() | CXTPRibbonControlSystemRecentFileList |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPRibbonControlSystemRecentFileList | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPRibbonControlSystemPopupBarListCaption | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFirstMruID() | CXTPRibbonControlSystemRecentFileList | protectedvirtual
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRecentFileList() | CXTPRibbonControlSystemRecentFileList | protectedvirtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPRibbonControlSystemPopupBarListCaption | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPRibbonControlSystemRecentFileList | protectedvirtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControl | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


CXTPDockingPaneWindowSelect Member List

This is the complete list of members for CXTPDockingPaneWindowSelect, including all inherited members.

CXTPDockingPaneWindowSelect() | CXTPDockingPaneWindowSelect | protected
GetItemCaption(CItem *pItem) const | CXTPDockingPaneWindowSelect | virtual
GetItemDescription(CItem *pItem) const | CXTPDockingPaneWindowSelect | virtual
GetItemPath(CItem *pItem) const | CXTPDockingPaneWindowSelect | virtual
HitTest(CPoint pt) const | CXTPDockingPaneWindowSelect |
itemMDIFrame enum value | CXTPDockingPaneWindowSelect |
itemPane enum value | CXTPDockingPaneWindowSelect |
itemSDIFrame enum value | CXTPDockingPaneWindowSelect |
ItemType enum name | CXTPDockingPaneWindowSelect |
Reposition() | CXTPDockingPaneWindowSelect | virtual
Select(CItem *pItem) | CXTPDockingPaneWindowSelect |
Select(int nItem) | CXTPDockingPaneWindowSelect |
~CXTPDockingPaneWindowSelect() | CXTPDockingPaneWindowSelect | virtual


Toolkit Pro: XTPMarkupGdiPlusTransformObject.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupGdiPlusTransformObject.h
Go to the documentation of this file.
1
22#if !defined(__XTPMARKUPGDIPLUSTRANSFORMOBJECT_H__)
23# define __XTPMARKUPGDIPLUSTRANSFORMOBJECT_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPMarkupTransformationMatrix;
32class CXTPGdiPlus;
33
39class _XTP_EXT_CLASS CXTPMarkupGdiPlusTransformObjectImpl
40{
41public:
45 virtual ~CXTPMarkupGdiPlusTransformObjectImpl()
46 {
47 }
48
49protected:
54 CXTPMarkupGdiPlusTransformObjectImpl();
55
64 virtual BOOL TransformMatrix(const CXTPGdiPlus* pReserved, GpMatrix* pMatrix) = 0;
65
75 CXTPMarkupTransformationMatrix* ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
76};
77
78AFX_INLINE CXTPMarkupGdiPlusTransformObjectImpl::CXTPMarkupGdiPlusTransformObjectImpl()
79{
80}
81
87template<class BaseTransform>
88class CXTPMarkupGdiPlusTransformObject
89 : public BaseTransform
90 , protected CXTPMarkupGdiPlusTransformObjectImpl
91{
92protected:
97 CXTPMarkupGdiPlusTransformObject();
98
99private:
109 virtual CXTPMarkupTransformationMatrix*
110 ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
111};
112
113template<class BaseTransform>
114AFX_INLINE CXTPMarkupGdiPlusTransformObject<BaseTransform>::CXTPMarkupGdiPlusTransformObject()
115{
116}
117
118template<class BaseTransform>
119AFX_INLINE CXTPMarkupTransformationMatrix*
120 CXTPMarkupGdiPlusTransformObject<BaseTransform>::ApplyTransform(
121 const CXTPMarkupTransformationMatrix* pMatrix)
122{
123 return CXTPMarkupGdiPlusTransformObjectImpl::ApplyTransform(pMatrix);
124}
125
126# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
128#endif // !defined(__XTPMARKUPGDIPLUSTRANSFORMOBJECT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupGdiPlusTransformObject
Base class for all GDI+ markup transformation objects.
Definition XTPMarkupGdiPlusTransformObject.h:91
CXTPMarkupGdiPlusTransformObject::CXTPMarkupGdiPlusTransformObject
CXTPMarkupGdiPlusTransformObject()
Prevents a class from being instantiated.
Definition XTPMarkupGdiPlusTransformObject.h:114
CXTPMarkupGdiPlusTransformObjectImpl
Implements GDI+ markup matrix access and delegates the actual transformation to a derived class.
Definition XTPMarkupGdiPlusTransformObject.h:40
CXTPMarkupGdiPlusTransformObjectImpl::CXTPMarkupGdiPlusTransformObjectImpl
CXTPMarkupGdiPlusTransformObjectImpl()
Prevents a class from being instantiated.
Definition XTPMarkupGdiPlusTransformObject.h:78
CXTPMarkupGdiPlusTransformObjectImpl::ApplyTransform
CXTPMarkupTransformationMatrix * ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix)
Applies abstract transformation on a markup transformation matrix.
CXTPMarkupGdiPlusTransformObjectImpl::TransformMatrix
virtual BOOL TransformMatrix(const CXTPGdiPlus *pReserved, GpMatrix *pMatrix)=0
An abstract method that performs a native GDI+ matrix transformation.
CXTPMarkupGdiPlusTransformObjectImpl::~CXTPMarkupGdiPlusTransformObjectImpl
virtual ~CXTPMarkupGdiPlusTransformObjectImpl()
Handles object destruction.
Definition XTPMarkupGdiPlusTransformObject.h:45
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40


CXTPTrackHeader Member List

This is the complete list of members for CXTPTrackHeader, including all inherited members.

AdjustColumnsWidth(int nTotalWidth, int nFirstIndex=0) | CXTPGridHeader |
AllowColumnRemove(BOOL bAllow) | CXTPGridHeader |
AllowColumnReorder(BOOL bAllow) | CXTPGridHeader |
AllowColumnResize(BOOL bAllow) | CXTPGridHeader |
AllowColumnSort(BOOL bAllow) | CXTPGridHeader |
BestFit(CXTPGridColumn *pColumn) | CXTPGridHeader |
CancelMouseMode() | CXTPGridHeader | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridHeader(CXTPGridControl *pControl, CXTPGridColumns *pColumns) | CXTPGridHeader |
CXTPTrackHeader(CXTPGridControl *pControl, CXTPGridColumns *pColumns) | CXTPTrackHeader |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridHeader | protectedvirtual
dragFieldChooser enum value | CXTPGridHeader | protected
dragInGroupBox enum value | CXTPGridHeader | protected
dragInHeader enum value | CXTPGridHeader | protected
dragInTarget enum value | CXTPGridHeader | protected
dragNothing enum value | CXTPGridHeader | protected
dragOutTarget enum value | CXTPGridHeader | protected
Draw(CDC *pDC, CRect rcHeader, int nLeftOffset) | CXTPTrackHeader | virtual
DrawFooter(CDC *pDC, CRect &rcFooter, int nLeftOffset) | CXTPGridHeader | protectedvirtual
DrawGroupByControl(CDC *pDC, CRect &rcGroupBy) | CXTPGridHeader | protectedvirtual
FindGroupByColumn(CPoint ptPoint, BOOL bExactSearch=FALSE) const | CXTPGridHeader | virtual
FindHeaderColumn(CPoint ptPoint) const | CXTPGridHeader | virtual
ForceLayoutAdjustment() const | CXTPGridHeader |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetControl() const | CXTPGridHeader |
GetDontDropCursor() const | CXTPGridHeader |
GetDraggingColumn() const | CXTPGridHeader |
GetFilterEditCtrl() const | CXTPGridHeader |
GetFullColScrollInfo(CXTPGridColumn *&rpPrev, CXTPGridColumn *&rpCurr, CXTPGridColumn *&rpNext, int &rnScrollPos, int &rnScrollMax) const | CXTPGridHeader |
GetGroupByHeight() const | CXTPGridHeader |
GetIndentLevel() const | CXTPGridHeader |
GetMaxAvailWidth(CXTPGridColumn *pColumn) | CXTPGridHeader | protected
GetMaxColumnWidth() const | CXTPGridHeader |
GetNextVisibleColumn(int nIndex, int nDirection) | CXTPGridHeader | virtual
GetPaintManager() const | CXTPGridHeader | protected
GetResizeCursor() const | CXTPGridHeader |
GetResizeVCursor() const | CXTPGridHeader |
GetResizingColumn() const | CXTPGridHeader |
GetSubListCtrl() const | CXTPGridHeader |
GetWidth() const | CXTPGridHeader |
GridDraggingMode enum name | CXTPGridHeader | protected
HitTest(CPoint ptPoint) const | CXTPGridHeader | virtual
HitTestHeaderColumnIndex(CPoint ptPoint) const | CXTPGridHeader | virtual
IsAllowColumnRemove() const | CXTPGridHeader |
IsAllowColumnReorder() const | CXTPGridHeader |
IsAllowColumnResize() const | CXTPGridHeader |
IsAllowColumnSort() const | CXTPGridHeader |
IsAutoColumnSizing() const | CXTPGridHeader |
IsDragHeader() const | CXTPGridHeader |
IsLastResizebleColumn(CXTPGridColumn *pColumn) const | CXTPGridHeader |
IsLastVisibleColumn(CXTPGridColumn *pColumn) const | CXTPGridHeader |
IsShowItemsInGroups() const | CXTPGridHeader |
m_bAllowColumnRemove | CXTPGridHeader | protected
m_bAllowColumnReorder | CXTPGridHeader | protected
m_bAllowColumnResize | CXTPGridHeader | protected
m_bAllowColumnSort | CXTPGridHeader | protected
m_bAutoColumnSizing | CXTPGridHeader | protected
m_bDragGroupBox | CXTPGridHeader | protected
m_bDragHeader | CXTPGridHeader | protected
m_bHideColumnAfterGroupBoxDrop | CXTPGridHeader |
m_bLastColumnExpand | CXTPGridHeader | protected
m_bLastColumnExpandKeep | CXTPGridHeader | protected
m_bShowItemsInGroups | CXTPGridHeader | protected
m_dragMode | CXTPGridHeader | protected
m_hDontDropCursor | CXTPGridHeader | protected
m_hResizeCursor | CXTPGridHeader | protected
m_hResizeVCursor | CXTPGridHeader | protected
m_nDropIndex | CXTPGridHeader | protected
m_nForceLayoutAdjustment | CXTPGridHeader | protected
m_nHeaderWidth | CXTPGridHeader | protected
m_nIndentLevel | CXTPGridHeader | protected
m_nMaxColumnWidth | CXTPGridHeader | protected
m_nOldMarkerPos | CXTPTrackHeader | protected
m_nOldViewPortMax | CXTPTrackHeader | protected
m_nOldViewPortMin | CXTPTrackHeader | protected
m_nOldWorkAreaMax | CXTPTrackHeader | protected
m_nOldWorkAreaMin | CXTPTrackHeader | protected
m_nResizeCaptureRange | CXTPGridHeader | protected
m_nVisIndex | CXTPGridHeader | protected
m_pColumns | CXTPGridHeader | protected
m_pControl | CXTPGridHeader | protected
m_pDragColumn | CXTPGridHeader | protected
m_pDragWnd | CXTPGridHeader | protected
m_pFilterEdit | CXTPGridHeader | protected
m_pHotTrackingColumn | CXTPGridHeader | protected
m_pResizeColumn | CXTPGridHeader | protected
m_pSubList | CXTPGridHeader | protected
m_ptMouse | CXTPGridHeader | protected
m_ptStartDrag | CXTPTrackHeader | protected
m_rcGroupBy | CXTPGridHeader | protected
m_rcHeader | CXTPGridHeader | protected
MouseOverColumnResizeArea(CPoint ptPoint) | CXTPGridHeader |
OnColumnsChanged(int nReason, CXTPGridColumn *pColumn) | CXTPGridHeader | virtual
OnContextMenu(CPoint ptClick) | CXTPGridHeader | protectedvirtual
OnLButtonDblClk(CPoint ptDblClick) | CXTPGridHeader | protectedvirtual
OnLButtonDown(CPoint ptClick) | CXTPTrackHeader | virtual
OnLButtonUp(UINT nFlags, CPoint ptClick) | CXTPGridHeader | protectedvirtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPTrackHeader | virtual
OnMoveMarker(CPoint pt, int nMarkerIndex) | CXTPTrackHeader | protected
OnMoveScrollBar(CPoint pt, BOOL bResize) | CXTPTrackHeader | protected
OnMoveSlider(CPoint pt, BOOL bResize) | CXTPTrackHeader | protected
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPGridHeader | protectedvirtual
ResizeColumn(CXTPGridColumn *pColumn, int nWidth) | CXTPGridHeader | protected
s_bSendContextMenuForWholeHeaderArea | CXTPGridHeader | static
s_bShowItemsInGroupsPXDefault | CXTPGridHeader | static
s_nMinAutoScrollStep | CXTPGridHeader | static
SetAutoColumnSizing(BOOL bAutoColumnSizing) | CXTPGridHeader |
SetFilterEditCtrl(CXTPGridFilterEditControl *pFilterEdit) | CXTPGridHeader |
SetHotDivider(int nIndex, BOOL bHeader=TRUE) | CXTPGridHeader | protected
SetLastColumnExpand(BOOL bLastColumnExpand, BOOL bLastColumnExpandKeep) | CXTPGridHeader |
SetMaxColumnWidth(int nMaxColumnWidth) | CXTPGridHeader |
SetSubListCtrl(CXTPGridSubListControl *pSubList) | CXTPGridHeader |
ShowItemsInGroups(BOOL bShowInGroups) | CXTPGridHeader |
StartDragging(CXTPGridColumn *pColumn, BOOL bHeader=FALSE) | CXTPGridHeader | protected
StartDragMarker(int nMarkerIndex) | CXTPTrackHeader |
StartDragScrollBar(BOOL bResize) | CXTPTrackHeader |
StartDragSlider(BOOL bResize) | CXTPTrackHeader |
~CXTPGridHeader() | CXTPGridHeader | virtual
~CXTPTrackHeader() | CXTPTrackHeader |


CXTPOpenGLUtils Member List

This is the complete list of members for CXTPOpenGLUtils, including all inherited members.

ComputeTriangleNormal(const CXTPPoint3d &vA, const CXTPPoint3d &vB, const CXTPPoint3d &vC, bool ccw=false) | CXTPOpenGLUtils | static
MultiplyByMatrix(CXTPPoint3d &v, const CXTPMatrix< double > &matrix) | CXTPOpenGLUtils | static
MultiplyByMatrix(CXTPPoint3d &v, GLenum name) | CXTPOpenGLUtils | static
Project(const CXTPPoint3d &pt3d, CPoint &pt2d, double *pdWinZ=NULL) | CXTPOpenGLUtils | static
Rotate(double dYaw, double dPitch, double dRoll) | CXTPOpenGLUtils | static
Unproject(const CPoint &pt2d, CXTPPoint3d &pt3d, double dWinZ=0.) | CXTPOpenGLUtils | static
Vertex(const CXTPPoint3d &ptVertex) | CXTPOpenGLUtils | static
Vertex(const CXTPPoint3d &ptVertex, const CXTPPoint3d &vNormal) | CXTPOpenGLUtils | static


CXTPMessageBarThemeOffice2010 Member List

This is the complete list of members for CXTPMessageBarThemeOffice2010, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeOffice2010(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2010 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2010 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2010 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2010 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2010 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2010 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: XTPFrameHook.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameHook.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSFRAMEHOOK_H__)
24# define __XTPCOMMANDBARSFRAMEHOOK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBar;
34class CXTPMenuTitleBar;
35class CXTPResourceTheme;
36class CXTPControls;
37class CXTPFramePaintManager;
38class CXTPNotifySink;
39class CXTPFrameShadow;
40class CXTPFramePaintManager;
41class CXTPRibbonOffice2007FrameTheme;
42class CXTPRibbonMarkupFrameTheme;
43class CXTPFrameThemeNativeWindows11;
44
45typedef DWORD XTP_NOTIFY_CODE;
46
52class _XTP_EXT_CLASS CXTPCommandBarsFrameHook
53 : public CXTPHookManagerHookAble
54 , IXTPPaintManagerEvents
55 , IXTPFrameShadowManagerEvents
56{
57 class CControlCaptionButton;
58
59public:
64 CXTPCommandBarsFrameHook();
65
70 ~CXTPCommandBarsFrameHook();
71
72public:
79 void EnableFrameTheme(CXTPCommandBars* pCommandBars);
80
88 void EnableFrameTheme(CWnd* pSite, CXTPPaintManager* pPaintManager);
89
97 void EnableFrameTheme(CWnd* pSite, CXTPCommandBars* pCommandBars);
98
103 void DisableFrameTheme();
104
106 _XTP_DEPRECATED_IN_FAVOR(EnableFrameTheme)
107 void EnableOffice2007Frame(CXTPCommandBars* pCommandBars);
108
109 _XTP_DEPRECATED_IN_FAVOR(EnableFrameTheme)
110 void EnableOffice2007Frame(CWnd* pSite, CXTPPaintManager* pPaintManager);
111
112 _XTP_DEPRECATED_IN_FAVOR(EnableFrameTheme)
113 void EnableOffice2007Frame(CWnd* pSite, CXTPCommandBars* pCommandBars);
114
115 _XTP_DEPRECATED_IN_FAVOR(DisableFrameTheme)
116 void DisableOffice2007Frame();
119public:
124 CWnd* GetSite() const;
125
130 CXTPPaintManager* GetPaintManager() const;
131
137 CXTPFramePaintManager* GetFramePaintManager() const;
138
144 BOOL IsCaptionVisible() const;
145
151 BOOL IsFrameActive() const;
152
157 void RecalcFrameLayout();
158
163 void DelayRecalcFrameLayout();
164
171 void RedrawRibbonBar();
172
179 void RedrawMenuTitleBar();
180
187 void RedrawFrame();
188
199 BOOL IsFrameHasStatusBar(int* pnStatusHeight = NULL) const;
200
207 BOOL IsMDIMaximized() const;
208
215 CXTPControls* GetCaptionButtons() const;
216
226 int GetCaptionHeight() const;
227
236 CRect CalcFrameBorder() const;
237
245 BOOL IsDwmEnabled() const;
246
251 void DisableDwm();
252
258 DWORD GetSiteStyle() const;
259
265 DWORD GetSiteExStyle() const;
266
274 void DrawRibbonFramePart(CDC* pDC);
275
280 void UpdateDwmClientArea();
281
291 BOOL EnableShadow();
292
299 void DisableShadow();
300
311 CXTPFrameShadow* GetShadow() const;
312
313protected:
327 virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM& wParam, LPARAM& lParam,
328 LRESULT& lResult);
329
335 virtual void OnUpdateMDIChildrenTheme();
336
337protected:
339 // IXTPPaintManagerEvents overrides
340 virtual void OnPaintManagerDestroyed(CXTPPaintManager* pPaintManager);
341
342 // IXTPFrameShadowManagerEvents overrides
343 virtual void OnFrameShadowDisabled(CXTPFrameShadowManager* pManager, HWND hwndOwner,
344 CXTPFrameShadow* pShadow);
345
346 void TrackCaptionButton(CXTPControl* pSelected);
347 void UpdateFrameRegion();
348 void UpdateFrameRegion(CSize szFrameRegion, BOOL bUpdate = FALSE);
349 void RepositionCaptionButtons();
350 void AddCaptionButton(int nID, int nHit);
351 void ScreenToFrame(LPPOINT lpPoint);
352 CXTPControl* HitTestCaptionButton(CPoint point);
353 void RefreshFrameStyle();
354 void SetWinHook();
355 BOOL GetAutoHideBar() const;
356 void OnResourceImagesChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
357
358 virtual void OnBeforeUpdatePaintManager();
359 virtual void OnUpdatePaintManager(CXTPPaintManager* pPaintManager);
360
363public:
364 static UINT m_nMsgQueryFrameHook;
365 BOOL m_bLockNCPaint;
367 static BOOL m_bAllowDwm;
368
370 _XTP_DEPRECATE("Value ignored. Use frame shadows in combination with sizeable frame instead.")
371 static BOOL m_bAllowBorderMouseTracking;
374protected:
375 HWND m_hwndSite;
376 CXTPRibbonBar* m_pRibbonBar;
377 CXTPMenuTitleBar* m_pMenuTitleBar;
378 CXTPCommandBars* m_pCommandBars;
379 CXTPPaintManager* m_pPaintManager;
380 BOOL m_bUseGlobalPaintManager;
382 BOOL m_bActive;
383 CSize m_szFrameRegion;
384 BOOL m_bDelayReclalcLayout;
385 CXTPControls* m_pCaptionButtons;
386 CXTPControl* m_pSelected;
387 BOOL m_bButtonPressed;
388 BOOL m_bThemeFrameEnabled;
389 BOOL m_bInUpdateFrame;
390 BOOL m_bDwmEnabled;
391 BOOL m_bBeingDestructed;
392 BOOL m_bToolBarComposition;
393 mutable CXTPFrameShadow* m_pShadow;
395private:
396 UINT m_nMsgUpdateSkinState;
397 UINT m_nMsgQuerySkinState;
398
399 CXTPNotifySink* m_pSink;
400
401 static void CALLBACK WinEventProc(CXTPWinEventHook::HWINEVENTHOOK hWinEventHook, DWORD event,
402 HWND hWnd, LONG idObject, LONG idChild, DWORD dwEventThread,
403 DWORD dwmsEventTime);
404
405 void SetSiteWindow(HWND hWnd = NULL);
406
407private:
408 class CWinEventHook;
409 friend class CXTPMenuTitleBar;
410 friend class CXTPRibbonBar;
411 friend class CControlCaptionButton;
412 friend class CXTPCommandBars;
413 friend class CXTPFramePaintManager;
414 friend class CXTPRibbonOffice2007FrameTheme;
415 friend class CXTPRibbonMarkupFrameTheme;
416 friend class CXTPFrameThemeNativeWindows11;
417};
418
419// Obsolete name
420# define CXTPOffice2007FrameHook CXTPCommandBarsFrameHook
421
422AFX_INLINE CWnd* CXTPCommandBarsFrameHook::GetSite() const
423{
424 return CWnd::FromHandle(m_hwndSite);
425}
426
427AFX_INLINE BOOL CXTPCommandBarsFrameHook::IsFrameActive() const
428{
429 return m_bActive;
430}
431
432AFX_INLINE CXTPControls* CXTPCommandBarsFrameHook::GetCaptionButtons() const
433{
434 return m_pCaptionButtons;
435}
436
437AFX_INLINE BOOL CXTPCommandBarsFrameHook::IsDwmEnabled() const
438{
439 return m_bDwmEnabled;
440}
441
442AFX_INLINE void CXTPCommandBarsFrameHook::DisableDwm()
443{
444 m_bDwmEnabled = FALSE;
445}
446
447AFX_INLINE void CXTPCommandBarsFrameHook::SetSiteWindow(HWND hWnd /*= NULL*/)
448{
449 m_hwndSite = hWnd;
450}
452# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
453#endif // !defined(__XTPCOMMANDBARSFRAMEHOOK_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPCommandBarsFrameHook::GetFramePaintManager
CXTPFramePaintManager * GetFramePaintManager() const
Call this method to retrieve the paint manager of the frame.
CXTPCommandBarsFrameHook::OnHookMessage
virtual int OnHookMessage(HWND hWnd, UINT nMessage, WPARAM &wParam, LPARAM &lParam, LRESULT &lResult)
This member function is called by WindowProc, or is called during message reflection.
CXTPCommandBarsFrameHook::RedrawRibbonBar
void RedrawRibbonBar()
Redraw ribbon bar if found.
CXTPCommandBarsFrameHook::GetSiteStyle
DWORD GetSiteStyle() const
Returns style of site window.
CXTPCommandBarsFrameHook::GetPaintManager
CXTPPaintManager * GetPaintManager() const
CXTPCommandBarsFrameHook::OnUpdateMDIChildrenTheme
virtual void OnUpdateMDIChildrenTheme()
Gets invoked for MDI children windows as a result to call to CXTPMDIFrameWnd::UpdateMDIChildrenTheme.
CXTPCommandBarsFrameHook::RedrawMenuTitleBar
void RedrawMenuTitleBar()
Redraw MenuTitleBar bar if found.
CXTPCommandBarsFrameHook::IsFrameActive
BOOL IsFrameActive() const
Determines if Skinned window is active.
Definition XTPFrameHook.h:427
CXTPCommandBarsFrameHook::m_nMsgQueryFrameHook
static UINT m_nMsgQueryFrameHook
Helper message to determine if Hook was attached.
Definition XTPFrameHook.h:364
CXTPCommandBarsFrameHook::RecalcFrameLayout
void RecalcFrameLayout()
Recalculates borders and region of frame.
CXTPCommandBarsFrameHook::EnableFrameTheme
void EnableFrameTheme(CWnd *pSite, CXTPCommandBars *pCommandBars)
Call this method to enable frame theming.
CXTPCommandBarsFrameHook::DisableFrameTheme
void DisableFrameTheme()
Call this method to disable frame theming.
CXTPCommandBarsFrameHook::GetSite
CWnd * GetSite() const
Definition XTPFrameHook.h:422
CXTPCommandBarsFrameHook::DrawRibbonFramePart
void DrawRibbonFramePart(CDC *pDC)
This method is called to draw the ribbon frame if EnableFrameTheme was not called.
CXTPCommandBarsFrameHook::DisableDwm
void DisableDwm()
Disables Vista AERO theme.
Definition XTPFrameHook.h:442
CXTPCommandBarsFrameHook::~CXTPCommandBarsFrameHook
~CXTPCommandBarsFrameHook()
Destroys a CXTPCommandBarsFrameHook object, handles cleanup and deallocation.
CXTPCommandBarsFrameHook::DisableShadow
void DisableShadow()
Disables frame shadow if enabled.
CXTPCommandBarsFrameHook::IsCaptionVisible
BOOL IsCaptionVisible() const
Determines if caption of skinned window is visible.
CXTPCommandBarsFrameHook::CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook()
Constructs a CXTPCommandBarsFrameHook object.
CXTPCommandBarsFrameHook::IsMDIMaximized
BOOL IsMDIMaximized() const
Determines if frame is maximized child window.
CXTPCommandBarsFrameHook::GetCaptionHeight
int GetCaptionHeight() const
Calculates height of caption.
CXTPCommandBarsFrameHook::EnableFrameTheme
void EnableFrameTheme(CWnd *pSite, CXTPPaintManager *pPaintManager)
Call this method to enable frame theming.
CXTPCommandBarsFrameHook::EnableFrameTheme
void EnableFrameTheme(CXTPCommandBars *pCommandBars)
Call this method to enable frame theming.
CXTPCommandBarsFrameHook::GetShadow
CXTPFrameShadow * GetShadow() const
Obtains frame shadow pointer.
CXTPCommandBarsFrameHook::EnableShadow
BOOL EnableShadow()
Enables the previously disabled frame shadow.
CXTPCommandBarsFrameHook::GetSiteExStyle
DWORD GetSiteExStyle() const
Returns extended style of site window.
CXTPCommandBarsFrameHook::DelayRecalcFrameLayout
void DelayRecalcFrameLayout()
Recalculates borders and region of frame with small delay.
CXTPCommandBarsFrameHook::CalcFrameBorder
CRect CalcFrameBorder() const
Calculates size of frame borders.
CXTPCommandBarsFrameHook::IsDwmEnabled
BOOL IsDwmEnabled() const
Determines if Vista AERO theme is enabled.
Definition XTPFrameHook.h:437
CXTPCommandBarsFrameHook::m_bLockNCPaint
BOOL m_bLockNCPaint
TRUE to disable repaint of non-client area.
Definition XTPFrameHook.h:365
CXTPCommandBarsFrameHook::RedrawFrame
void RedrawFrame()
Redraws frame of skinned window.
CXTPCommandBarsFrameHook::GetCaptionButtons
CXTPControls * GetCaptionButtons() const
Returns collection of caption buttons.
Definition XTPFrameHook.h:432
CXTPCommandBarsFrameHook::IsFrameHasStatusBar
BOOL IsFrameHasStatusBar(int *pnStatusHeight=NULL) const
Determines if frame has skinned scrollbar to draw rounded rects.
CXTPCommandBarsFrameHook::UpdateDwmClientArea
void UpdateDwmClientArea()
Updates the invalidated portions of the DWM client area.
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPFrameShadowManager
Provides frame shadow management functionality.
Definition XTPFrameShadowManager.h:147
CXTPHookManagerHookAble
HookAble interface.
Definition XTPHookManager.h:42
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPResourceTheme
The CXTPResourceTheme class is used to enable a resource style theme for Command Bars.
Definition XTPCommandBarsResourceTheme.h:46
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonMarkupFrameTheme
The CXTPRibbonMarkupFrameTheme class is used to enable a system style theme for Command Bars.
Definition XTPRibbonMarkupFrameTheme.h:43
IXTPFrameShadowManagerEvents
An interface for Frame Shadow Manager event listener.
Definition XTPFrameShadowManager.h:80
IXTPFrameShadowManagerEvents::OnFrameShadowDisabled
virtual void OnFrameShadowDisabled(CXTPFrameShadowManager *pManager, HWND hwndOwner, CXTPFrameShadow *pShadow)
Invoked right before a shadow is disabled for a window.
Definition XTPFrameShadowManager.h:108


CXTPCommandBarsOptions Member List

This is the complete list of members for CXTPCommandBarsOptions, including all inherited members.

animationType | CXTPCommandBarsOptions |
bAltDragCustomization | CXTPCommandBarsOptions |
bAlwaysShowFullMenus | CXTPCommandBarsOptions |
bAutoUpdateShortcuts | CXTPCommandBarsOptions |
bDblClickFloat | CXTPCommandBarsOptions |
bDirtyState | CXTPCommandBarsOptions |
bDisableCommandIfNoHandler | CXTPCommandBarsOptions |
bFlyByStatus | CXTPCommandBarsOptions |
bLargeIcons | CXTPCommandBarsOptions |
bShowContextMenuAccelerators | CXTPCommandBarsOptions |
bShowExpandButtonAlways | CXTPCommandBarsOptions |
bShowFullAfterDelay | CXTPCommandBarsOptions |
bShowKeyboardTips | CXTPCommandBarsOptions |
bShowMiniToolbarTips | CXTPCommandBarsOptions |
bShowPopupBarToolTips | CXTPCommandBarsOptions |
bShowPopupButtonsSelectedToolbarOnly | CXTPCommandBarsOptions |
bShowTextBelowIcons | CXTPCommandBarsOptions |
bSyncFloatingBars | CXTPCommandBarsOptions |
bToolBarAccelTips | CXTPCommandBarsOptions |
bToolBarScreenTips | CXTPCommandBarsOptions |
bUseAltNumPadKeys | CXTPCommandBarsOptions |
bUseSystemSaveBitsStyle | CXTPCommandBarsOptions |
bWrapLargePopups | CXTPCommandBarsOptions |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPCommandBarsOptions() | CXTPCommandBarsOptions |
DoPropExchange(CXTPPropExchange *pPX, BOOL bUserOptionsOnly=FALSE) | CXTPCommandBarsOptions |
EnableDpiBitmapScaling(BOOL bEnable=TRUE) | CXTPCommandBarsOptions |
EnableDpiGalleryItemScaling(BOOL bEnable=TRUE) | CXTPCommandBarsOptions |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetShowKeyboardCues() const | CXTPCommandBarsOptions |
IsDpiBitmapScalingEnabled() const | CXTPCommandBarsOptions |
IsDpiGalleryItemScalingEnabled() const | CXTPCommandBarsOptions |
keyboardCuesUse | CXTPCommandBarsOptions |
m_bAutoScaleDpiGalleryItems | CXTPCommandBarsOptions | protected
m_bAutoScaleDpiToolbarIcons | CXTPCommandBarsOptions | protected
m_mapHiddenCommands | CXTPCommandBarsOptions |
m_mapUsedCommands | CXTPCommandBarsOptions |
Serialize(CArchive &ar) | CXTPCommandBarsOptions |
ShowKeyboardCues(XTPKeyboardCuesShow keyboardCues) | CXTPCommandBarsOptions |
szIcons | CXTPCommandBarsOptions |
szLargeIcons | CXTPCommandBarsOptions |
szPopupIcons | CXTPCommandBarsOptions |


Toolkit Pro: XTPListBoxThemeOffice2003.h Source File

  • Source
  • Controls
  • ListBox
  • Themes
XTPListBoxThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTBOXTHEMEOFFICE2003_H__)
24# define __XTPLISTBOXTHEMEOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPListBoxThemeOffice2003 : public CXTPListBoxThemeOfficeXP
39{
40public:
50 virtual void DrawItem(CDC* pDC, CXTPListBox* pListBox, LPDRAWITEMSTRUCT lpDIS);
51
57 virtual void RefreshMetrics();
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPLISTBOXTHEMEOFFICE2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPListBox
CXTPListBox is a CListBox derived class.
Definition XTPListBox.h:127
CXTPListBoxThemeOffice2003
CXTPListBoxThemeOffice2003 is used by CXTPListBox to draw an Office 2003 style list box.
Definition XTPListBoxThemeOffice2003.h:39
CXTPListBoxThemeOffice2003::DrawItem
virtual void DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)
This method is called to draw the CXTPListBox object.
CXTPListBoxThemeOffice2003::RefreshMetrics
virtual void RefreshMetrics()
Called to update the colors and metrics used to draw the CXTPListBox object.
CXTPListBoxThemeOfficeXP
CXTPListBoxThemeOfficeXP is used by CXTPListBox to draw an Office XP style list box.
Definition XTPListBoxThemeOfficeXP.h:39


Toolkit Pro: XTPPopupThemeOfficeXP.h Source File

  • Source
  • Controls
  • Popup
  • Themes
XTPPopupThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOPUPTHEMEOFFICEXP_H__)
24# define __XTPPOPUPTHEMEOFFICEXP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPopupThemeOfficeXP : public CXTPPopupThemeOffice2000
39{
40public:
45 CXTPPopupThemeOfficeXP();
46
51 virtual ~CXTPPopupThemeOfficeXP();
52
53public:
58 void RefreshMetrics();
59
67 virtual void DrawBackground(CDC* pDC, CXTPPopupControl* pControl, CRect rcClient);
68};
69
70# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
72#endif // __XTPPOPUPTHEMEOFFICEXP_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window.
Definition XTPPopupControl.h:225
CXTPPopupThemeOffice2000
CXTPPopupThemeOffice2000 is a class used to perform Office 2000 drawing tasks.
Definition XTPPopupThemeOffice2000.h:39
CXTPPopupThemeOfficeXP
CXTPPopupThemeOfficeXP is a class used to perform Office XP drawing tasks.
Definition XTPPopupThemeOfficeXP.h:39
CXTPPopupThemeOfficeXP::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
CXTPPopupThemeOfficeXP::RefreshMetrics
void RefreshMetrics()
Call this member function to refresh draw metrics.
CXTPPopupThemeOfficeXP::CXTPPopupThemeOfficeXP
CXTPPopupThemeOfficeXP()
Constructs a CXTPPopupThemeOfficeXP object.
CXTPPopupThemeOfficeXP::~CXTPPopupThemeOfficeXP
virtual ~CXTPPopupThemeOfficeXP()
Destroys a CXTPPopupThemeOfficeXP object.


CXTPDockingPaneVisualStudio2005Beta1Theme Member List

This is the complete list of members for CXTPDockingPaneVisualStudio2005Beta1Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rect, BOOL bApply) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneGripperedTheme() | CXTPDockingPaneGripperedTheme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2003Theme() | CXTPDockingPaneVisualStudio2003Theme |
CXTPDockingPaneVisualStudio2005Beta1Theme() | CXTPDockingPaneVisualStudio2005Beta1Theme |
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPanePaintManager | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPanePaintManager | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneGripperedTheme | virtual
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPanePaintManager | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneDefaultTheme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPanePaintManager | virtual
FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical) | CXTPDockingPaneVisualStudio2003Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPanePaintManager | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bGradientCaption | CXTPDockingPaneVisualStudio2003Theme | protected
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneVisualStudio2005Beta1Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual


CXTPShellListView Member List

This is the complete list of members for CXTPShellListView, including all inherited members.

CXTPShellListView() | CXTPShellListView |
OnDblclk(NMHDR *pNMHDR, LRESULT *pResult) | CXTPShellListView | protected
~CXTPShellListView() | CXTPShellListView | virtual


CXTPComboBoxThemeNativeWindows10 Member List

This is the complete list of members for CXTPComboBoxThemeNativeWindows10, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPComboBoxTheme() | CXTPComboBoxTheme |
CXTPComboBoxThemeNativeWindows10() | CXTPComboBoxThemeNativeWindows10 |
CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 |
CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 |
CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio |
CXTPControlTheme() | CXTPControlTheme |
DrawBackground(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxThemeOffice2013 | virtual
DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeNativeWindows10 | virtual
DrawButtonTriangle(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn) | CXTPComboBoxThemeOffice2013 | virtual
DrawComboBox(CDC *pDC, CXTPComboBox *pComboBox) | CXTPComboBoxTheme | virtual
DrawFrame(HDC hdc, LPRECT lprc, int nSize, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FillSolidRect(HDC hdc, int x, int y, int cx, int cy, HBRUSH hBrush) | CXTPComboBoxTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() const | CXTPComboBoxTheme |
GetBackgroundBrush() const | CXTPComboBoxTheme |
GetTextColor() const | CXTPComboBoxTheme |
GetThemeStyle() const | CXTPControlTheme |
m_clrBackDisabled | CXTPComboBoxTheme |
m_clrBackground | CXTPComboBoxTheme |
m_clrBackHighlight | CXTPComboBoxTheme |
m_clrBorderDisabled | CXTPComboBoxTheme |
m_clrBorderHot | CXTPComboBoxTheme |
m_clrBorderNormal | CXTPComboBoxTheme |
m_clrButtonArrowDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonArrowHot | CXTPComboBoxTheme |
m_clrButtonArrowNormal | CXTPComboBoxTheme |
m_clrButtonArrowPressed | CXTPComboBoxTheme |
m_clrButtonDisabled | CXTPComboBoxThemeOffice2013 | protected
m_clrButtonHot | CXTPComboBoxTheme |
m_clrButtonNormal | CXTPComboBoxTheme |
m_clrButtonPressed | CXTPComboBoxTheme |
m_clrText | CXTPComboBoxTheme |
m_clrTextDisabled | CXTPComboBoxTheme |
m_clrTextHighlight | CXTPComboBoxTheme |
m_grcButton | CXTPComboBoxTheme |
m_grcButtonHilite | CXTPComboBoxTheme |
m_grcButtonPushed | CXTPComboBoxTheme |
m_nTheme | CXTPControlTheme | protected
m_nThumbWidth | CXTPComboBoxTheme | protected
m_themeComboBox | CXTPComboBoxTheme | protected
m_xtpBrushBackground | CXTPComboBoxTheme | protected
RefreshMetrics(CXTPComboBox *pComboBox) | CXTPComboBoxThemeNativeWindows10 | virtual
ResetBackColor() | CXTPComboBoxTheme |
ResetTextColor() | CXTPComboBoxTheme |
SetBackColor(COLORREF clrBackground) | CXTPComboBoxTheme |
SetTextColor(COLORREF clrText) | CXTPComboBoxTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UpdateBackgroundBrush() | CXTPComboBoxTheme | protected
~CXTPComboBoxTheme() | CXTPComboBoxTheme | virtual
~CXTPComboBoxThemeNativeWindows10() | CXTPComboBoxThemeNativeWindows10 | virtual
~CXTPComboBoxThemeOffice2003() | CXTPComboBoxThemeOffice2003 | virtual
~CXTPComboBoxThemeOffice2013() | CXTPComboBoxThemeOffice2013 | virtual
~CXTPComboBoxThemeVisualStudio() | CXTPComboBoxThemeVisualStudio | virtual


Toolkit Pro: XTPTaskPanelVisualStudio2022Theme.h Source File

  • Source
  • TaskPanel
  • Themes
XTPTaskPanelVisualStudio2022Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELVISUALSTUDIO2022THEME_H__)
24# define __XTPTASKPANELVISUALSTUDIO2022THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPTaskPanelVisualStudio2022Theme : public CXTPTaskPanelVisualStudio2012Theme
40{
41protected:
42 void Triangle(CDC* pDC, POINT* pPoints, COLORREF clr, BOOL bFilled);
43
44public:
49 CXTPTaskPanelVisualStudio2022Theme();
50
56 virtual ~CXTPTaskPanelVisualStudio2022Theme();
57
62 virtual void RefreshMetrics();
63};
65# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
66#endif // __XTPTASKPANELVISUALSTUDIO2022THEME_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTaskPanelVisualStudio2012Theme
CXTPTaskPanelVisualStudio2012Theme represents a VS.NET 2012 style theme.
Definition XTPTaskPanelVisualStudio2012Theme.h:40
CXTPTaskPanelVisualStudio2022Theme
CXTPTaskPanelVisualStudio2022Theme represents a Visutal Studio 2022 style theme.
Definition XTPTaskPanelVisualStudio2022Theme.h:40
CXTPTaskPanelVisualStudio2022Theme::CXTPTaskPanelVisualStudio2022Theme
CXTPTaskPanelVisualStudio2022Theme()
Constructs a CXTPTaskPanelVisualStudio2022Theme object.
CXTPTaskPanelVisualStudio2022Theme::~CXTPTaskPanelVisualStudio2022Theme
virtual ~CXTPTaskPanelVisualStudio2022Theme()
Destroys a CXTPTaskPanelVisualStudio2022Theme object, handles cleanup and deallocation.
CXTPTaskPanelVisualStudio2022Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the task panel.


CXTPSyntaxEditView Member List

This is the complete list of members for CXTPSyntaxEditView, including all inherited members.

CanChangeReadonlyFile() | CXTPSyntaxEditView | protectedvirtual
CXTPSyntaxEditView() | CXTPSyntaxEditView | protected
GetDataManager() const | CXTPSyntaxEditView |
GetDocument() const | CXTPSyntaxEditView |
GetEditBuffer() const | CXTPSyntaxEditView |
GetEditCtrl() | CXTPSyntaxEditView |
GetFindReplaceDlg() | CXTPSyntaxEditView | virtual
GetHorzScrollBar() const | CXTPSyntaxEditView |
GetLexConfigurationManager() const | CXTPSyntaxEditView |
GetLexParser() const | CXTPSyntaxEditView |
GetPageTitle() | CXTPSyntaxEditView | virtual
GetPrintOptions() const | CXTPSyntaxEditView |
GetSplitterView(int nRow, int nCol) | CXTPSyntaxEditView | protected
GetTopRow() const | CXTPSyntaxEditView |
GetVertScrollBar() const | CXTPSyntaxEditView |
m_aPageStart | CXTPSyntaxEditView | protected
m_bDraggingOver | CXTPSyntaxEditView | protected
m_bDraggingStartedHere | CXTPSyntaxEditView | protected
m_bFilesDragging | CXTPSyntaxEditView | protected
m_bOleDragging | CXTPSyntaxEditView | protected
m_bOnSizeRunning | CXTPSyntaxEditView | protected
m_bPrintDirect | CXTPSyntaxEditView |
m_bResizeControlWithView | CXTPSyntaxEditView |
m_bScrollBars | CXTPSyntaxEditView | protected
m_dropTarget | CXTPSyntaxEditView | protected
m_iTopRow | CXTPSyntaxEditView | protected
m_lfPrevFont | CXTPSyntaxEditView | protected
m_nParserThreadPriority_WhenActive | CXTPSyntaxEditView | protected
m_nParserThreadPriority_WhenInactive | CXTPSyntaxEditView | protected
m_nPrevTopRow | CXTPSyntaxEditView | protected
m_pEditCtrl | CXTPSyntaxEditView | protected
m_pFindReplaceDlg | CXTPSyntaxEditView | protectedstatic
m_pPrintOptions | CXTPSyntaxEditView | protected
m_szPage | CXTPSyntaxEditView | protected
ms_bDroppedHere | CXTPSyntaxEditView | protectedstatic
ms_dwSignature | CXTPSyntaxEditView | protectedstatic
ms_pTargetView | CXTPSyntaxEditView | protectedstatic
ms_ptDropPos | CXTPSyntaxEditView | protectedstatic
OnDrawBookmark(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnEditChanged(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnEditChanging(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnEnableScrollBar(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnInsertKey(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnMarginClicked(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnParseEvent(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnRowColChanged(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnSelInit(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnSetDocModified(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnStartOleDrag(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
OnUpdateScrollPos(NMHDR *pNMHDR, LRESULT *pResult) | CXTPSyntaxEditView | protectedvirtual
Refresh() | CXTPSyntaxEditView |
SetAutoIndent(BOOL bEnable) | CXTPSyntaxEditView |
SetDirty() | CXTPSyntaxEditView |
SetEditCtrl(CXTPSyntaxEditCtrl *pControl) | CXTPSyntaxEditView | virtual
SetFontIndirect(LOGFONT *pLogFont, BOOL bUpdateReg=FALSE) | CXTPSyntaxEditView |
SetLineNumbers(BOOL bEnable) | CXTPSyntaxEditView |
SetScrollBars(BOOL bHorz, BOOL bVert, BOOL bUpdateReg=FALSE, BOOL bRecalcLayout=TRUE) | CXTPSyntaxEditView |
SetSelMargin(BOOL bEnable) | CXTPSyntaxEditView |
SetSyntaxColor(BOOL bEnable) | CXTPSyntaxEditView |
SetTopRow(int iRow) | CXTPSyntaxEditView |
StartOleDrag() | CXTPSyntaxEditView | protected
UpdateAllViews() | CXTPSyntaxEditView |
UpdateScrollPos(CView *pSender, DWORD dwUpdate=XTP_EDIT_UPDATE_ALL) | CXTPSyntaxEditView |
UpdateSiblings(XTP_EDIT_NMHDR_EDITCHANGED *pNMHDR_EC=NULL, BOOL bTextChanged=TRUE) | CXTPSyntaxEditView | protected
UpdateSiblingScrollPos(CXTPSyntaxEditView *pSender, DWORD dwUpdate) | CXTPSyntaxEditView | protected
~CXTPSyntaxEditView() | CXTPSyntaxEditView | protectedvirtual


CXTPRibbonTab Member List

This is the complete list of members for CXTPRibbonTab, including all inherited members.

AddGroup(LPCTSTR lpszCaption) | CXTPRibbonTab |
AddGroup(int nID) | CXTPRibbonTab |
Copy(CXTPRibbonTab *pRibbonTab) | CXTPRibbonTab | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonTab() | CXTPRibbonTab |
CXTPTabManagerItem() | CXTPTabManagerItem | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPRibbonTab | virtual
DrawImage(CDC *pDC, CRect rcIcon, CXTPImageManagerIcon *pImage) | CXTPTabManagerItem |
FindGroup(int nId) const | CXTPRibbonTab |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonLength() const | CXTPTabManagerItem |
GetCaption() const | CXTPRibbonTab | virtual
GetColor() | CXTPTabManagerItem |
GetContentLength() const | CXTPTabManagerItem |
GetContextCaption() const | CXTPRibbonTab |
GetContextColor() const | CXTPRibbonTab |
GetContextHeader() const | CXTPRibbonTab |
GetCustomizeCaption() const | CXTPRibbonTab |
GetData() const | CXTPTabManagerItem |
GetGroups() const | CXTPRibbonTab |
GetHandle() const | CXTPTabManagerItem |
GetID() const | CXTPRibbonTab |
GetImageIndex() const | CXTPTabManagerItem |
GetIndex() const | CXTPTabManagerItem |
GetItemRow() const | CXTPTabManagerItem |
GetKeyboardTip() const | CXTPRibbonTab |
GetMarkupUIElement() const | CXTPTabManagerItem |
GetNavigateButtons() | CXTPTabManagerItem |
GetParent() const | CXTPRibbonTab |
GetRect() const | CXTPTabManagerItem |
GetRibbonBar() const | CXTPRibbonTab |
GetTabManager() const | CXTPTabManagerItem |
GetTooltip() const | CXTPTabManagerItem |
IsClosable() const | CXTPTabManagerItem |
IsEnabled() const | CXTPTabManagerItem |
IsFocused() const | CXTPTabManagerItem |
IsHighlighted() const | CXTPTabManagerItem |
IsItemShrinked() const | CXTPTabManagerItem |
IsNewWindowTab() | CXTPTabManagerItem |
IsPressed() const | CXTPTabManagerItem |
IsSelected() const | CXTPTabManagerItem |
IsVisible() const | CXTPTabManagerItem |
m_arrNavigateButtons | CXTPTabManagerItem | protected
m_bClosable | CXTPTabManagerItem | protected
m_bEnabled | CXTPTabManagerItem | protected
m_bNewWindowTab | CXTPTabManagerItem | protected
m_bVisible | CXTPTabManagerItem | protected
m_clrItem | CXTPTabManagerItem | protected
m_dwData | CXTPTabManagerItem | protected
m_hIcon | CXTPTabManagerItem | protected
m_hWnd | CXTPTabManagerItem | protected
m_nButtonLength | CXTPTabManagerItem | protected
m_nContentLength | CXTPTabManagerItem | protected
m_nContextColor | CXTPRibbonTab | protected
m_nId | CXTPRibbonTab | protected
m_nImage | CXTPTabManagerItem | protected
m_nIndex | CXTPTabManagerItem | protected
m_nItemRow | CXTPTabManagerItem | protected
m_pContextHeader | CXTPRibbonTab | protected
m_pGroups | CXTPRibbonTab | protected
m_pMarkupUIElement | CXTPTabManagerItem | protected
m_pParent | CXTPRibbonTab | protected
m_pRibbonBar | CXTPRibbonTab | protected
m_pTabManager | CXTPTabManagerItem | protected
m_rcItem | CXTPTabManagerItem | protected
m_strCaption | CXTPTabManagerItem | protected
m_strContextCaption | CXTPRibbonTab | protected
m_strCustomizeCaption | CXTPRibbonTab | protected
m_strKeyboardTip | CXTPRibbonTab | protected
m_strToolTip | CXTPTabManagerItem | protected
Move(int nIndex) | CXTPTabManagerItem |
OnCmdMsg(UINT nID, int nCode, void *pExtra, AFX_CMDHANDLERINFO *pHandlerInfo) | CXTPRibbonTab | protected
OnRemoved() | CXTPRibbonTab | protectedvirtual
Remove() | CXTPTabManagerItem |
Reposition() | CXTPTabManagerItem | protected
Select() | CXTPTabManagerItem |
SetCaption(LPCTSTR lpszCaption) | CXTPTabManagerItem |
SetClosable(BOOL bClosable) | CXTPTabManagerItem |
SetColor(COLORREF clr) | CXTPTabManagerItem |
SetContextCaption(LPCTSTR lpszContextCaption) | CXTPRibbonTab |
SetContextColor(XTPRibbonTabContextColor color) | CXTPRibbonTab |
SetContextTab(XTPRibbonTabContextColor color, int nContextID) | CXTPRibbonTab |
SetContextTab(XTPRibbonTabContextColor color, LPCTSTR lpszContextCaption=NULL) | CXTPRibbonTab |
SetCustomizeCaption(LPCTSTR lpszCustomizeCaption) | CXTPRibbonTab |
SetCustomizeCaption(UINT nCustomizeCaption) | CXTPRibbonTab |
SetData(DWORD_PTR dwData) | CXTPTabManagerItem |
SetEnabled(BOOL bEnabled) | CXTPTabManagerItem |
SetHandle(HWND hWnd) | CXTPTabManagerItem |
SetID(int nId) | CXTPRibbonTab |
SetImageIndex(int nImage) | CXTPTabManagerItem |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPRibbonTab |
SetNewWindowTab() | CXTPTabManagerItem |
SetRect(CRect rcItem) | CXTPTabManagerItem |
SetTooltip(LPCTSTR lpszTooltip) | CXTPTabManagerItem |
SetVisible(BOOL bVisible) | CXTPRibbonTab | virtual
~CXTPRibbonTab() | CXTPRibbonTab | virtual
~CXTPTabManagerItem() | CXTPTabManagerItem | protectedvirtual


CXTPGridRecordItemControl Member List

This is the complete list of members for CXTPGridRecordItemControl, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridRecordItemControl(LPCTSTR szCaption=_T("")) | CXTPGridRecordItemControl |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridRecordItemControl | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridRecordItemControl |
GetCaption() const | CXTPGridRecordItemControl |
GetCaptionColor() const | CXTPGridRecordItemControl |
GetEnable() const | CXTPGridRecordItemControl |
GetFlags() const | CXTPGridRecordItemControl |
GetFont() | CXTPGridRecordItemControl |
GetHeight() const | CXTPGridRecordItemControl |
GetIconIndex(int nState) const | CXTPGridRecordItemControl |
GetIndex() const | CXTPGridRecordItemControl |
GetRect() const | CXTPGridRecordItemControl |
GetSize() const | CXTPGridRecordItemControl |
GetState() const | CXTPGridRecordItemControl |
GetThemed() const | CXTPGridRecordItemControl |
GetType() const | CXTPGridRecordItemControl |
GetWidth() const | CXTPGridRecordItemControl |
m_Alignment | CXTPGridRecordItemControl | protected
m_bEnabled | CXTPGridRecordItemControl | protected
m_bThemed | CXTPGridRecordItemControl | protected
m_clrCaption | CXTPGridRecordItemControl | protected
m_mapIcon | CXTPGridRecordItemControl | protected
m_nIndex | CXTPGridRecordItemControl | protected
m_nState | CXTPGridRecordItemControl | protected
m_nType | CXTPGridRecordItemControl | protected
m_rcControl | CXTPGridRecordItemControl | protected
m_sizeControl | CXTPGridRecordItemControl | protected
m_strCaption | CXTPGridRecordItemControl | protected
m_unFlags | CXTPGridRecordItemControl | protected
m_xtpFontCaption | CXTPGridRecordItemControl | protected
OnLButtonDown(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItemControl | inlinevirtual
OnLButtonUp(XTP_GRIDRECORDITEM_CLICKARGS *pClickArgs) | CXTPGridRecordItemControl | inlinevirtual
OnMouseEnter(UINT nFlags, CPoint point) | CXTPGridRecordItemControl | inlinevirtual
OnMouseLeave(UINT nFlags, CPoint point) | CXTPGridRecordItemControl | inlinevirtual
OnMouseMove(UINT nFlags, CPoint point) | CXTPGridRecordItemControl | inlinevirtual
SetAlignment(int nAlignment) | CXTPGridRecordItemControl |
SetCaption(LPCTSTR szCaption) | CXTPGridRecordItemControl |
SetCaptionColor(COLORREF clrCaption) | CXTPGridRecordItemControl |
SetEnable(BOOL bEnable) | CXTPGridRecordItemControl |
SetFlags(UINT unFlags) | CXTPGridRecordItemControl |
SetFont(CFont *pFont) | CXTPGridRecordItemControl |
SetHeight(int nHeight) | CXTPGridRecordItemControl |
SetIconIndex(int nState, int nIconIndex) | CXTPGridRecordItemControl |
SetRect(CRect rcControl) | CXTPGridRecordItemControl | protected
SetSize(CSize sizeControl) | CXTPGridRecordItemControl |
SetState(int nNewState) | CXTPGridRecordItemControl |
SetThemed(BOOL bThemed) | CXTPGridRecordItemControl |
SetWidth(int nWidth) | CXTPGridRecordItemControl |
~CXTPGridRecordItemControl() | CXTPGridRecordItemControl | virtual


Toolkit Pro: XTPGridTip.h Source File

  • Source
  • GridControl
XTPGridTip.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTIP_H__)
24# define __XTPGRIDTIP_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
49class _XTP_EXT_CLASS CXTPGridTip : public CWnd
50{
51 friend class CXTPGridRow;
52
53public:
74 CXTPGridTip();
75
80 virtual ~CXTPGridTip();
81
95 virtual BOOL Create(CWnd* pParentWnd);
96
97public:
104 BOOL IsMultilineForce() const;
105
114 CString GetTooltipText() const;
115
125 void SetTooltipText(LPCTSTR str);
126
132 void SetFont(CFont* pFont);
133
144 void SetHoverRect(CRect rc);
145
155 CRect GetHoverRect() const;
156
163 void SetTooltipRect(CRect rc);
164
171 CRect GetTooltipRect() const;
172
186 void Activate(BOOL bActive, BOOL bMultiline);
187
188protected:
189 CRect m_rcHover;
190 CRect m_rcTooltip;
191 CWnd* m_pParentWnd;
192 CString m_strTooltipText;
193 CXTPGridRecordItem* m_pItem;
194 int m_nRowIndex;
196 CXTPFont m_xtpFontToolTip;
197 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fntToolTip, m_xtpFontToolTip,
198 GetToolTipFontHandle);
199
200 BOOL m_bMultiline;
201 CXTPGridControl* m_pGridControl;
203protected:
205 //{{AFX_MSG(CXTPGridTip)
206 afx_msg LRESULT OnNcHitTest(CPoint point);
207 afx_msg BOOL OnEraseBkgnd(CDC*);
208 afx_msg void OnPaint();
209 //}}AFX_MSG
210
211 friend class CXTPGridControl;
214private:
215 void RecalcTooltipRect(CRect& rc);
216 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
217 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
218 DECLARE_MESSAGE_MAP()
219};
220
221AFX_INLINE CString CXTPGridTip::GetTooltipText() const
222{
223 return m_strTooltipText;
224}
225AFX_INLINE void CXTPGridTip::SetTooltipText(LPCTSTR str)
226{
227 m_strTooltipText = str;
228}
229AFX_INLINE void CXTPGridTip::SetHoverRect(CRect rc)
230{
231 m_rcHover = rc;
232 MoveWindow(rc);
233}
234AFX_INLINE void CXTPGridTip::SetTooltipRect(CRect rc)
235{
236 m_rcTooltip = rc;
237 MoveWindow(rc);
238}
239AFX_INLINE CRect CXTPGridTip::GetHoverRect() const
240{
241 return m_rcHover;
242}
243AFX_INLINE CRect CXTPGridTip::GetTooltipRect() const
244{
245 return m_rcTooltip;
246}
247AFX_INLINE BOOL CXTPGridTip::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
248 const RECT& rect, CWnd* pParentWnd, UINT nID,
249 CCreateContext* pContext)
250{
251 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
252}
253
254# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
256#endif // !defined(__XTPGRIDTIP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridTip
The CXTPGridTip class encapsulates the functionality of a "tip control", a small pop-up window that d...
Definition XTPGridTip.h:50
CXTPGridTip::m_nRowIndex
int m_nRowIndex
Index of item's row.
Definition XTPGridTip.h:194
CXTPGridTip::GetTooltipText
CString GetTooltipText() const
Gets the tooltip text.
Definition XTPGridTip.h:221
CXTPGridTip::CXTPGridTip
CXTPGridTip()
Constructs a CXTPGridTip object.
CXTPGridTip::m_strTooltipText
CString m_strTooltipText
Tooltip text to display.
Definition XTPGridTip.h:192
CXTPGridTip::m_xtpFontToolTip
CXTPFont m_xtpFontToolTip
Font for displaying tooltip text.
Definition XTPGridTip.h:196
CXTPGridTip::m_pGridControl
CXTPGridControl * m_pGridControl
Parent Grid Control.
Definition XTPGridTip.h:201
CXTPGridTip::SetFont
void SetFont(CFont *pFont)
Sets the font of the tooltip text.
CXTPGridTip::~CXTPGridTip
virtual ~CXTPGridTip()
Destroys a CXTPGridTip object, handles cleanup and deallocation.
CXTPGridTip::m_pParentWnd
CWnd * m_pParentWnd
Pointer to the parent grid window.
Definition XTPGridTip.h:191
CXTPGridTip::GetTooltipRect
CRect GetTooltipRect() const
Gets the tooltip rectangle.
Definition XTPGridTip.h:243
CXTPGridTip::m_rcTooltip
CRect m_rcTooltip
Tooltip window coordinates.
Definition XTPGridTip.h:190
CXTPGridTip::SetTooltipText
void SetTooltipText(LPCTSTR str)
Sets the tooltip text.
Definition XTPGridTip.h:225
CXTPGridTip::SetHoverRect
void SetHoverRect(CRect rc)
Sets the coordinates of the tooltip hover rectangle.
Definition XTPGridTip.h:229
CXTPGridTip::m_pItem
CXTPGridRecordItem * m_pItem
Item which tooltip is visible.
Definition XTPGridTip.h:193
CXTPGridTip::m_bMultiline
BOOL m_bMultiline
Multiline tooltip flag.
Definition XTPGridTip.h:200
CXTPGridTip::Activate
void Activate(BOOL bActive, BOOL bMultiline)
Call this function to activate/deactivate the tooltip control.
CXTPGridTip::IsMultilineForce
BOOL IsMultilineForce() const
Determines if the tooltip text contains the new line character.
CXTPGridTip::m_rcHover
CRect m_rcHover
Hover window coordinates.
Definition XTPGridTip.h:189
CXTPGridTip::GetHoverRect
CRect GetHoverRect() const
Gets the coordinates of the tooltip hover rectangle.
Definition XTPGridTip.h:239
CXTPGridTip::Create
virtual BOOL Create(CWnd *pParentWnd)
Creates a grid tip window.
CXTPGridTip::SetTooltipRect
void SetTooltipRect(CRect rc)
Sets the tooltip rectangle.
Definition XTPGridTip.h:234


Toolkit Pro: XTPMarkupTrigger.h Source File

  • Source
  • Markup
XTPMarkupTrigger.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPTRIGGER_H__)
24# define __XTPMARKUPTRIGGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupObject;
34class CXTPMarkupDependencyProperty;
35class CXTPMarkupSetterCollection;
36
37class _XTP_EXT_CLASS CXTPMarkupTrigger : public CXTPMarkupObject
38{
40 DECLARE_MARKUPCLASS(CXTPMarkupTrigger);
42public:
43 CXTPMarkupTrigger();
44 CXTPMarkupTrigger(CXTPMarkupDependencyProperty* pProperty, CXTPMarkupObject* pValue);
45
46public:
47 CXTPMarkupSetterCollection* GetSetters() const;
48 void SetSetters(CXTPMarkupSetterCollection* pSetters);
49
50public:
51 CXTPMarkupDependencyProperty* GetTriggerProperty() const;
52 CXTPMarkupObject* GetTriggerValue() const;
53
54public:
55 static CXTPMarkupDependencyProperty* m_pSettersProperty;
56 static CXTPMarkupDependencyProperty* m_pPropertyProperty;
57 static CXTPMarkupDependencyProperty* m_pValueProperty;
58};
59
60# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
62#endif // !defined(__XTPMARKUPTRIGGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h


Toolkit Pro: XTPSyntaxEditBufferManager.h Source File

  • Source
  • SyntaxEdit
XTPSyntaxEditBufferManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSYNTAXEDITBUFFERMANAGER_H__)
24# define __XTPSYNTAXEDITBUFFERMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34namespace XTPSyntaxEditLexAnalyser
36{
37class CXTPSyntaxEditLexTextSchema;
38class CXTPSyntaxEditLexParser;
39};
41typedef XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextSchema CXTPSyntaxEditTextSchema;
42class CXTPSyntaxEditLineMarksManager;
43class CXTPSyntaxEditUndoRedoManager;
44class CXTPNotifySink;
45class CXTPNotifyConnection;
46class CXTPSyntaxEditConfigurationManager;
47typedef CXTPSmartPtrInternalT<CXTPSyntaxEditConfigurationManager>
48 CXTPSyntaxEditConfigurationManagerPtr;
49
58class _XTP_EXT_CLASS CXTPSyntaxEditBufferManager : public CXTPCmdTarget
59{
60 DECLARE_DYNCREATE(CXTPSyntaxEditBufferManager)
61 friend class CXTPSyntaxEditCtrl;
62
63public:
68 CXTPSyntaxEditBufferManager();
69
75 ~CXTPSyntaxEditBufferManager();
76
83 BOOL IsModified() const;
84
91 UINT GetCodePage() const;
92
99 int GetTabSize() const;
100
110 BOOL SetTabSize(int nTabSize, BOOL bUpdateReg = FALSE);
111
118 BOOL GetOverwriteFlag() const;
119
125 void SetOverwriteFlag(BOOL bOverwrite);
126
133 BOOL IsParserEnabled() const;
134
140 void EnableParser(BOOL bEnable);
141
148 int GetCurCRLFType() const;
149
155 void SetCRLFStyle(int nStyle);
156
163 CString GetCurCRLF() const;
164
165private:
173 LPCTSTR GetCRLF(int nCRLFStyle = -1) const;
174
175public:
184 BOOL IsTextCRLF(LPCTSTR szCompText, BOOL bMatchReverse = FALSE) const;
185
186# ifdef _UNICODE
195 BOOL IsTextCRLF(LPCSTR szCompText, BOOL bMatchReverse = FALSE) const;
196# endif
197
204 int GetRowCount() const;
205
212 CXTPSyntaxEditUndoRedoManager* GetUndoRedoManager() const;
213
220 CXTPSyntaxEditLineMarksManager* GetLineMarksManager() const;
221
228 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser* GetLexParser() const;
229
236 CXTPSyntaxEditConfigurationManager* GetLexConfigurationManager() const;
237
243 void SetLexConfigurationManager(CXTPSyntaxEditConfigurationManager* pMan);
244
251 CXTPNotifyConnection* GetConnection() const;
252
257 void Close();
258
264 virtual void Serialize(CArchive& ar);
265
277 virtual void SerializeEx(CArchive& ar, BOOL bUnicode = -1, BOOL bWriteUnicodeFilePrefix = TRUE,
278 UINT nCodePage = (UINT)-1, LPCTSTR pcszFileExt = NULL,
279 int nDataSizeLimit = -1);
280
289 void Load(CFile* pFile, LPCTSTR pcszFileExt = NULL);
290
298 void SetFileExt(const CString& strExt);
299
308 CString GetFileExt() const;
309
319 void GetLineText(int iLine, CString& strText, BOOL bAddCRLF = FALSE, int iCRLFStyle = -1);
320
330 CString GetLineText(int iLine, BOOL bAddCRLF = FALSE, int iCRLFStyle = -1) const;
331
341 int GetLineTextLength(int iLine, BOOL bAddCRLF = FALSE, int iCRLFStyle = -1) const;
342
352 int GetLineTextLengthC(int iLine, BOOL bAddCRLF = FALSE, int iCRLFStyle = -1) const;
353
360 int GetMaxLineTextLength() const;
361
371 int CalcMaxLineTextLength(int nLineFrom = -1, int nLineTo = -1, BOOL bExpandTabs = FALSE) const;
372
395 BOOL GetBuffer(int row1, int col1, int row2, int col2, CMemFile& file,
396 BOOL bColumnSelection = FALSE, BOOL bForceDOSStyleCRLF = FALSE);
397
418 BOOL GetBuffer(const XTP_EDIT_LINECOL& lcStart, const XTP_EDIT_LINECOL& lcEnd, CMemFile& file,
419 BOOL bColumnSelection = FALSE, BOOL bForceDOSStyleCRLF = FALSE);
420
434 BOOL InsertText(LPCTSTR szText, int iRow, int iCol, BOOL bCanUndo = TRUE,
435 XTP_EDIT_LINECOL* pFinalLC = NULL);
436
450 BOOL InsertTextBlock(LPCTSTR szText, int nRow, int nCol, BOOL bCanUndo = TRUE,
451 XTP_EDIT_LINECOL* pFinalLC = NULL);
452
466 BOOL DeleteText(int iRowFrom, int iColFrom, int iRowTo, int iColTo, BOOL bCanUndo = TRUE,
467 BOOL bDispCol = FALSE);
468
478 BOOL RemoveLine(int nRow, BOOL bCanUndo = TRUE, int nRowsCount = 1);
479
488 CString GetConfigFile() const;
489
501 BOOL SetConfigFile(LPCTSTR szPath);
502
503 void SetCodePage(UINT uCodePage);
504
513 CXTPSyntaxEditTextSchema* GetMasterTextSchema(const CString& strExt) const;
514
527 void ChangeCase(int nRow, int nDispFrom, int nDispTo, BOOL bUpper, BOOL bCanUndo = TRUE);
528
541 void ChangeTabification(int nRow, int nDispFrom, int nDispTo, BOOL bTabify,
542 BOOL bCanUndo = TRUE);
543
554 virtual int ColToStrPos(int nLine, int nDispCol) const;
555
566 virtual int StrPosToCol(int nLine, int nStrPos) const;
567
568protected:
573 void CleanUp();
574
583 virtual UINT CalcAveDataSize(int nRowStart, int nRowEnd);
584
585 int m_nAverageLineLen;
587 CXTPNotifyConnection* m_pConnection;
589protected:
590 int m_nTabSize;
591 int m_iCRLFStyle;
592 UINT m_nCodePage;
593 BOOL m_bUnicodeFileFormat;
594 BOOL m_bOverwrite;
596 enum XTP_SYNTAXEDIT_FILE_ENCODING
597 {
598 XTP_SYNTAXEDIT_FILE_UTF_8 = 0,
599 XTP_SYNTAXEDIT_FILE_UTF_8_BOM = 1,
600 XTP_SYNTAXEDIT_FILE_UTF_16_LE = 2,
601 XTP_SYNTAXEDIT_FILE_UTF_16_BE = 3,
602 };
603 XTP_SYNTAXEDIT_FILE_ENCODING m_nFileEncoding;
604
605 int GetFileEncoding(); // uploaded file encoding
606 void SetFileEncoding(int val); // save file encoding
607
608 CXTPSyntaxEditUndoRedoManager* m_pUndoRedoManager;
610 CXTPSyntaxEditLineMarksManager* m_pLineMarksManager;
612 XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser* m_pLexParser;
615 CXTPSyntaxEditConfigurationManagerPtr m_ptrLexConfigurationManager;
618 CXTPSyntaxEditConfigurationManagerPtr
619 m_ptrDefaultLexConfigurationManager;
621 CString m_strFileExt;
623 BOOL m_bIsParserEnabled;
626 CXTPNotifySink* m_pLexConfigManSinkMT;
627
628 virtual void OnLexConfigManEventHandler(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
635 class _XTP_EXT_CLASS CXTPSyntaxEditStringsManager
636 {
638 friend class CXTPSyntaxEditBufferManager;
640 public:
645 CXTPSyntaxEditStringsManager();
646
651 virtual ~CXTPSyntaxEditStringsManager();
652
659 int GetCount() const;
660
668 CString GetStr(int nRow) const;
669
679 int GetStrLen(int nRow) const;
680
690 int GetStrLenC(int nRow) const;
691
701 void SetAtGrowStr(int nRow, const CString& strText);
702
712 void SetAtGrowStr(int nRow, LPCTSTR pcszText);
713
724 void InsertStr(int nRow, const CString& strText);
725
733 BOOL RemoveStr(int nRow);
734
739 void RemoveAllStrs();
740
762 BOOL InsertText(int nRow, int nPos, LPCTSTR pcszText, BOOL bGrowArrayIfNeed = FALSE,
763 TCHAR chLeftSpaceFiller = _T(' '));
775 BOOL DeleteText(int nRow, int nPos, int nCount);
776
786 CString* GetStrData(int nRow, BOOL bGrowArrayIfNeed = TRUE);
787
795 CString* GetStrDataC(int nRow) const;
796
801 class _XTP_EXT_CLASS CStringPtrArray : public CArray<CString*, CString*>
802 {
804 typedef CArray<CString*, CString*> TBase;
806 public:
811 CStringPtrArray();
812
817 virtual ~CStringPtrArray();
818
823 void RemoveAll();
824 };
825
826 CStringPtrArray m_arStrings;
827 };
828
829 CXTPSyntaxEditStringsManager m_Strings;
831protected:
832# ifdef _XTP_ACTIVEX
835 DECLARE_DISPATCH_MAP()
836 DECLARE_INTERFACE_MAP()
837
838 DECLARE_OLETYPELIB_EX(CXTPSyntaxEditBufferManager)
839
840 afx_msg BSTR OleGetFileExt();
841 afx_msg void OleSetFileExt(LPCTSTR pcszFileExt);
842
844# endif
845};
846
848AFX_INLINE CXTPSyntaxEditLineMarksManager* CXTPSyntaxEditBufferManager::GetLineMarksManager() const
849{
850 return m_pLineMarksManager;
851}
852AFX_INLINE XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser*
853 CXTPSyntaxEditBufferManager::GetLexParser() const
854{
855 return m_pLexParser;
856}
857AFX_INLINE CXTPSyntaxEditConfigurationManager*
858 CXTPSyntaxEditBufferManager::GetLexConfigurationManager() const
859{
860 return m_ptrLexConfigurationManager;
861}
862AFX_INLINE CXTPNotifyConnection* CXTPSyntaxEditBufferManager::GetConnection() const
863{
864 return m_pConnection;
865}
866AFX_INLINE CXTPSyntaxEditUndoRedoManager* CXTPSyntaxEditBufferManager::GetUndoRedoManager() const
867{
868 return m_pUndoRedoManager;
869}
870AFX_INLINE int CXTPSyntaxEditBufferManager::GetTabSize() const
871{
872 return m_nTabSize;
873}
874AFX_INLINE BOOL CXTPSyntaxEditBufferManager::GetBuffer(const XTP_EDIT_LINECOL& lcStart,
875 const XTP_EDIT_LINECOL& lcEnd,
876 CMemFile& file, BOOL bColumnSelection,
877 BOOL bForceDOSStyleCRLF)
878{
879 return GetBuffer(lcStart.nLine, lcStart.nCol, lcEnd.nLine, lcEnd.nCol, file, bColumnSelection,
880 bForceDOSStyleCRLF);
881}
882AFX_INLINE BOOL CXTPSyntaxEditBufferManager::GetOverwriteFlag() const
883{
884 return m_bOverwrite;
885}
886AFX_INLINE int CXTPSyntaxEditBufferManager::GetCurCRLFType() const
887{
888 return m_iCRLFStyle;
889}
890AFX_INLINE UINT CXTPSyntaxEditBufferManager::GetCodePage() const
891{
892 return m_nCodePage;
893}
894AFX_INLINE CString CXTPSyntaxEditBufferManager::GetFileExt() const
895{
896 return m_strFileExt;
897}
898AFX_INLINE BOOL CXTPSyntaxEditBufferManager::IsParserEnabled() const
899{
900 return m_bIsParserEnabled;
901}
902
904
905# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
907#endif // !defined(__XTPSYNTAXEDITBUFFERMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPSyntaxEditTextSchema
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexTextSchema CXTPSyntaxEditTextSchema
namespace XTPSyntaxEditLexAnalyser
Definition XTPSyntaxEditBufferManager.h:41
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPNotifyConnection
This class is used as implementation of Connection interface in a XTPNotification mechanism.
Definition XTPNotifyConnection.h:88
CXTPSmartPtrInternalT
Definition XTPSmartPtrInternalT.h:72
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray
Internal class, implements a collection of strings.
Definition XTPSyntaxEditBufferManager.h:802
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::CStringPtrArray
CStringPtrArray()
Default object constructor.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::RemoveAll
void RemoveAll()
Deletes all string objects and removes them from the array.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CStringPtrArray::~CStringPtrArray
virtual ~CStringPtrArray()
Default object destructor.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager
This is helper class designed to manage a set of strings.
Definition XTPSyntaxEditBufferManager.h:636
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetCount
int GetCount() const
Gets the number of managed strings.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::RemoveAllStrs
void RemoveAllStrs()
Removes all strings from the collection.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::InsertStr
void InsertStr(int nRow, const CString &strText)
Adds a specified string.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrData
CString * GetStrData(int nRow, BOOL bGrowArrayIfNeed=TRUE)
Retrieves the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStr
CString GetStr(int nRow) const
Retrieves the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::CXTPSyntaxEditStringsManager
CXTPSyntaxEditStringsManager()
Default object constructor.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr
void SetAtGrowStr(int nRow, const CString &strText)
Sets the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrLen
int GetStrLen(int nRow) const
Retrieves the length of the string at a specified index in TCHARs/characters.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::SetAtGrowStr
void SetAtGrowStr(int nRow, LPCTSTR pcszText)
Sets the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::InsertText
BOOL InsertText(int nRow, int nPos, LPCTSTR pcszText, BOOL bGrowArrayIfNeed=FALSE, TCHAR chLeftSpaceFiller=_T(' '))
Inserts text to the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::m_arStrings
CStringPtrArray m_arStrings
String collection.
Definition XTPSyntaxEditBufferManager.h:826
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrDataC
CString * GetStrDataC(int nRow) const
Retrieves the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::DeleteText
BOOL DeleteText(int nRow, int nPos, int nCount)
Deletes text from the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::~CXTPSyntaxEditStringsManager
virtual ~CXTPSyntaxEditStringsManager()
Default object destructor.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::RemoveStr
BOOL RemoveStr(int nRow)
Removes the string at a specified index.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditStringsManager::GetStrLenC
int GetStrLenC(int nRow) const
Retrieves the length of the string at a specified index in TCHARs/characters.
CXTPSyntaxEditBufferManager
This class is the main class for buffer management.
Definition XTPSyntaxEditBufferManager.h:59
CXTPSyntaxEditBufferManager::IsTextCRLF
BOOL IsTextCRLF(LPCTSTR szCompText, BOOL bMatchReverse=FALSE) const
Determines if specified text is a CRLF.
CXTPSyntaxEditBufferManager::m_ptrDefaultLexConfigurationManager
CXTPSyntaxEditConfigurationManagerPtr m_ptrDefaultLexConfigurationManager
Default Configuration Manager instance.
Definition XTPSyntaxEditBufferManager.h:619
CXTPSyntaxEditBufferManager::GetCodePage
UINT GetCodePage() const
Gets the CodePage for text conversion.
Definition XTPSyntaxEditBufferManager.h:890
CXTPSyntaxEditBufferManager::StrPosToCol
virtual int StrPosToCol(int nLine, int nStrPos) const
Converts the string position of text to column coordinates.
CXTPSyntaxEditBufferManager::GetConfigFile
CString GetConfigFile() const
Gets the name of the main configuration file.
CXTPSyntaxEditBufferManager::InsertText
BOOL InsertText(LPCTSTR szText, int iRow, int iCol, BOOL bCanUndo=TRUE, XTP_EDIT_LINECOL *pFinalLC=NULL)
Inserts either text or a text block.
CXTPSyntaxEditBufferManager::GetLineTextLengthC
int GetLineTextLengthC(int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Gets the length of a line of text in TCHARs/characters.
CXTPSyntaxEditBufferManager::DeleteText
BOOL DeleteText(int iRowFrom, int iColFrom, int iRowTo, int iColTo, BOOL bCanUndo=TRUE, BOOL bDispCol=FALSE)
Deletes a specified range of text.
CXTPSyntaxEditBufferManager::Load
void Load(CFile *pFile, LPCTSTR pcszFileExt=NULL)
Set the file pointer for the buffer.
CXTPSyntaxEditBufferManager::SerializeEx
virtual void SerializeEx(CArchive &ar, BOOL bUnicode=-1, BOOL bWriteUnicodeFilePrefix=TRUE, UINT nCodePage=(UINT) -1, LPCTSTR pcszFileExt=NULL, int nDataSizeLimit=-1)
Serializes actual data.
CXTPSyntaxEditBufferManager::ChangeCase
void ChangeCase(int nRow, int nDispFrom, int nDispTo, BOOL bUpper, BOOL bCanUndo=TRUE)
Changes the case of a specified character range in a specified row.
CXTPSyntaxEditBufferManager::m_bIsParserEnabled
BOOL m_bIsParserEnabled
TRUE if the parser is enabled, FALSE if the parser is disabled.
Definition XTPSyntaxEditBufferManager.h:623
CXTPSyntaxEditBufferManager::CalcAveDataSize
virtual UINT CalcAveDataSize(int nRowStart, int nRowEnd)
Calculates the average data size based on the average row length.
CXTPSyntaxEditBufferManager::SetFileExt
void SetFileExt(const CString &strExt)
Sets the file extension.
CXTPSyntaxEditBufferManager::GetLexConfigurationManager
CXTPSyntaxEditConfigurationManager * GetLexConfigurationManager() const
Gets the associated configuration manager.
Definition XTPSyntaxEditBufferManager.h:858
CXTPSyntaxEditBufferManager::m_strFileExt
CString m_strFileExt
File extension.
Definition XTPSyntaxEditBufferManager.h:621
CXTPSyntaxEditBufferManager::m_pConnection
CXTPNotifyConnection * m_pConnection
Connection object to send notifications.
Definition XTPSyntaxEditBufferManager.h:587
CXTPSyntaxEditBufferManager::RemoveLine
BOOL RemoveLine(int nRow, BOOL bCanUndo=TRUE, int nRowsCount=1)
Deletes a specified number of rows.
CXTPSyntaxEditBufferManager::m_nCodePage
UINT m_nCodePage
CodePage for text conversion.
Definition XTPSyntaxEditBufferManager.h:592
CXTPSyntaxEditBufferManager::SetOverwriteFlag
void SetOverwriteFlag(BOOL bOverwrite)
Sets the status for the overwrite flag.
CXTPSyntaxEditBufferManager::IsParserEnabled
BOOL IsParserEnabled() const
Determines if the parser is enabled/disabled.
Definition XTPSyntaxEditBufferManager.h:898
CXTPSyntaxEditBufferManager::GetOverwriteFlag
BOOL GetOverwriteFlag() const
Gets the status of the overwrite flag.
Definition XTPSyntaxEditBufferManager.h:882
CXTPSyntaxEditBufferManager::~CXTPSyntaxEditBufferManager
~CXTPSyntaxEditBufferManager()
Destroys a CXTPSyntaxEditBufferManager object, handles cleanup and de-allocation.
CXTPSyntaxEditBufferManager::IsModified
BOOL IsModified() const
Determines if the file has been modified.
CXTPSyntaxEditBufferManager::EnableParser
void EnableParser(BOOL bEnable)
Enables/disables the parser.
CXTPSyntaxEditBufferManager::SetLexConfigurationManager
void SetLexConfigurationManager(CXTPSyntaxEditConfigurationManager *pMan)
Sets the associated configuration manager.
CXTPSyntaxEditBufferManager::GetRowCount
int GetRowCount() const
Gets the number of rows in the document.
CXTPSyntaxEditBufferManager::m_Strings
CXTPSyntaxEditStringsManager m_Strings
Strings manager helper object.
Definition XTPSyntaxEditBufferManager.h:829
CXTPSyntaxEditBufferManager::m_iCRLFStyle
int m_iCRLFStyle
CRLF style 0 - DOS, 1 - UNIX, 2 - MAC.
Definition XTPSyntaxEditBufferManager.h:591
CXTPSyntaxEditBufferManager::Close
void Close()
Cleans up all internal objects.
CXTPSyntaxEditBufferManager::CXTPSyntaxEditBufferManager
CXTPSyntaxEditBufferManager()
Default object constructor.
CXTPSyntaxEditBufferManager::GetTabSize
int GetTabSize() const
Gets the tab size.
Definition XTPSyntaxEditBufferManager.h:870
CXTPSyntaxEditBufferManager::m_bOverwrite
BOOL m_bOverwrite
Overwrite mode status.
Definition XTPSyntaxEditBufferManager.h:594
CXTPSyntaxEditBufferManager::SetTabSize
BOOL SetTabSize(int nTabSize, BOOL bUpdateReg=FALSE)
Sets the tab size (must be between 1-64).
CXTPSyntaxEditBufferManager::m_bUnicodeFileFormat
BOOL m_bUnicodeFileFormat
Determine is file format Unicode or ASCII.
Definition XTPSyntaxEditBufferManager.h:593
CXTPSyntaxEditBufferManager::Serialize
virtual void Serialize(CArchive &ar)
Serializes actual data.
CXTPSyntaxEditBufferManager::GetLineText
void GetLineText(int iLine, CString &strText, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1)
Retrieves a line of text from either a file or buffer.
CXTPSyntaxEditBufferManager::GetCurCRLFType
int GetCurCRLFType() const
Gets the CRLF style of the current document.
Definition XTPSyntaxEditBufferManager.h:886
CXTPSyntaxEditBufferManager::m_ptrLexConfigurationManager
CXTPSyntaxEditConfigurationManagerPtr m_ptrLexConfigurationManager
Pointer to the Lexical configuration manager.
Definition XTPSyntaxEditBufferManager.h:615
CXTPSyntaxEditBufferManager::GetLineTextLength
int GetLineTextLength(int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Gets the length of a line of text in TCHARs/characters.
CXTPSyntaxEditBufferManager::m_pUndoRedoManager
CXTPSyntaxEditUndoRedoManager * m_pUndoRedoManager
Pointer to the undo / redo manager.
Definition XTPSyntaxEditBufferManager.h:608
CXTPSyntaxEditBufferManager::CleanUp
void CleanUp()
Cleans up the buffer and all other allocated memories.
CXTPSyntaxEditBufferManager::GetMasterTextSchema
CXTPSyntaxEditTextSchema * GetMasterTextSchema(const CString &strExt) const
Gets the master text schema.
CXTPSyntaxEditBufferManager::m_pLineMarksManager
CXTPSyntaxEditLineMarksManager * m_pLineMarksManager
Pointer to the line marks manager.
Definition XTPSyntaxEditBufferManager.h:610
CXTPSyntaxEditBufferManager::GetUndoRedoManager
CXTPSyntaxEditUndoRedoManager * GetUndoRedoManager() const
Gets the associated Undo/Redo manager.
Definition XTPSyntaxEditBufferManager.h:866
CXTPSyntaxEditBufferManager::m_nAverageLineLen
int m_nAverageLineLen
Average line length.
Definition XTPSyntaxEditBufferManager.h:585
CXTPSyntaxEditBufferManager::GetLexParser
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * GetLexParser() const
Gets the associated lexical parser.
Definition XTPSyntaxEditBufferManager.h:853
CXTPSyntaxEditBufferManager::m_pLexParser
XTPSyntaxEditLexAnalyser::CXTPSyntaxEditLexParser * m_pLexParser
Pointer to the lexical parser.
Definition XTPSyntaxEditBufferManager.h:612
CXTPSyntaxEditBufferManager::GetBuffer
BOOL GetBuffer(int row1, int col1, int row2, int col2, CMemFile &file, BOOL bColumnSelection=FALSE, BOOL bForceDOSStyleCRLF=FALSE)
Retrieves the text from the buffer bounded between either the row1/col1 and row2/col2 or the lcStart ...
CXTPSyntaxEditBufferManager::ChangeTabification
void ChangeTabification(int nRow, int nDispFrom, int nDispTo, BOOL bTabify, BOOL bCanUndo=TRUE)
Changes the tabification of a specified character range in a specified row.
CXTPSyntaxEditBufferManager::GetConnection
CXTPNotifyConnection * GetConnection() const
Gets the events connection object.
Definition XTPSyntaxEditBufferManager.h:862
CXTPSyntaxEditBufferManager::GetLineText
CString GetLineText(int iLine, BOOL bAddCRLF=FALSE, int iCRLFStyle=-1) const
Retrieves a line of text from either a file or buffer.
CXTPSyntaxEditBufferManager::SetCRLFStyle
void SetCRLFStyle(int nStyle)
Sets the CRLF style for the current document.
CXTPSyntaxEditBufferManager::m_nTabSize
int m_nTabSize
Tab size.
Definition XTPSyntaxEditBufferManager.h:590
CXTPSyntaxEditBufferManager::InsertTextBlock
BOOL InsertTextBlock(LPCTSTR szText, int nRow, int nCol, BOOL bCanUndo=TRUE, XTP_EDIT_LINECOL *pFinalLC=NULL)
Inserts either text or a text block.
CXTPSyntaxEditBufferManager::CalcMaxLineTextLength
int CalcMaxLineTextLength(int nLineFrom=-1, int nLineTo=-1, BOOL bExpandTabs=FALSE) const
Gets the length of a line of text from either a file or buffer.
CXTPSyntaxEditBufferManager::GetCurCRLF
CString GetCurCRLF() const
Gets the CRLF text of the current document.
CXTPSyntaxEditBufferManager::GetMaxLineTextLength
int GetMaxLineTextLength() const
Gets the maximum allowed length for a line of text.
CXTPSyntaxEditBufferManager::SetConfigFile
BOOL SetConfigFile(LPCTSTR szPath)
Sets the the path to the main configuration file.
CXTPSyntaxEditBufferManager::GetLineMarksManager
CXTPSyntaxEditLineMarksManager * GetLineMarksManager() const
Gets the associated line marks manager.
Definition XTPSyntaxEditBufferManager.h:848
CXTPSyntaxEditBufferManager::ColToStrPos
virtual int ColToStrPos(int nLine, int nDispCol) const
Converts the column coordinates of text to string position.
CXTPSyntaxEditBufferManager::GetFileExt
CString GetFileExt() const
Gets the file extension.
Definition XTPSyntaxEditBufferManager.h:894
CXTPSyntaxEditConfigurationManager
This class manages all configuration parameters of the control.
Definition XTPSyntaxEditLexColorFileReader.h:601
CXTPSyntaxEditCtrl
This class is the main CWnd-based editor class.
Definition XTPSyntaxEditCtrl.h:114
CXTPSyntaxEditLexParser
This class used to 'run' lex schema parsing in a separate thread.
Definition XTPSyntaxEditLexParser.h:861
CXTPSyntaxEditLexTextSchema
The CXTPSyntaxEditLexTextSchema class is used to store data which is necessary to parse a text and pa...
Definition XTPSyntaxEditLexParser.h:428
CXTPSyntaxEditLineMarksManager
The CXTPSyntaxEditLineMarksManager class provides functionality to manipulate marks on text lines.
Definition XTPSyntaxEditLineMarksManager.h:201
CXTPSyntaxEditUndoRedoManager
This class maintains the list of undo/redo commands.
Definition XTPSyntaxEditUndoManager.h:646
XTP_EDIT_LINECOL
The XTP_EDIT_LINECOL structure represents the coordinates of text items on the displaying context in ...
Definition XTPSyntaxEditStruct.h:54
XTP_EDIT_LINECOL::nLine
int nLine
Line identifier.
Definition XTPSyntaxEditStruct.h:55
XTP_EDIT_LINECOL::nCol
int nCol
Column identifier.
Definition XTPSyntaxEditStruct.h:56


CXTPListBoxThemeDefault Member List

This is the complete list of members for CXTPListBoxThemeDefault, including all inherited members.

DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxThemeDefault | virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxTheme | virtual
GetBackColor() | CXTPListBoxTheme | virtual
RefreshMetrics() | CXTPListBoxThemeDefault | virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: XTPDatePickerNativeWindows11Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerNativeWindows11Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERNATIVEWINDOWS11THEME_H__)
23# define _XTPDATEPICKERNATIVEWINDOWS11THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeNativeWindows11 : public CXTPDatePickerThemeOffice2013
52{
53public:
62 CXTPDatePickerThemeNativeWindows11();
63
70 virtual ~CXTPDatePickerThemeNativeWindows11();
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(_XTPDATEPICKERNATIVEWINDOWS11THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerThemeNativeWindows11
Class CXTPDatePickerThemeNativeWindows11 is derived from CXTPDatePickerThemeOffice2013 for rendering ...
Definition XTPDatePickerNativeWindows11Theme.h:52
CXTPDatePickerThemeNativeWindows11::CXTPDatePickerThemeNativeWindows11
CXTPDatePickerThemeNativeWindows11()
Default paint manager constructor.
CXTPDatePickerThemeNativeWindows11::~CXTPDatePickerThemeNativeWindows11
virtual ~CXTPDatePickerThemeNativeWindows11()
Default paint manager destructor.
CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2013Theme.h:52


Toolkit Pro: XTPChart3dPyramidSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
  • 3D
XTPChart3dPyramidSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPYRAMIDSERIESVIEW_H__)
24# define __XTPCHART3DPYRAMIDSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChart3dPyramidSeriesView : public CXTPChartPyramidSeriesViewBase
45{
46public:
54 CXTPChart3dPyramidSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
55
56public:
64 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds);
65
66protected:
78 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
79 CXTPChartSeriesPoint* pPoint,
80 CXTPChartElementView* pParentView);
81
94 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
95
106 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
107 CRect rcBounds);
108
122 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
123 CRect rcBounds, CXTPChartColor color1,
124 CXTPChartColor color2,
125 CXTPChartColor clrBorder);
126};
128# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
129#endif //#if !defined(__XTPCHART3DPYRAMIDSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dPyramidSeriesView
This class abstracts the view of a pyramid series.
Definition XTPChart3dPyramidSeriesView.h:45
CXTPChart3dPyramidSeriesView::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the pyramid series point layout.
CXTPChart3dPyramidSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)
These functions create a label view drawing command object.
CXTPChart3dPyramidSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChart3dPyramidSeriesView::CXTPChart3dPyramidSeriesView
CXTPChart3dPyramidSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChart3dPyramidSeriesView object.
CXTPChart3dPyramidSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
Creates legend drawing device command.
CXTPChart3dPyramidSeriesView::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Use this function to create the pyramid series point view object.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPyramidSeriesViewBase
This class abstracts the view of a pyramid series.
Definition XTPChartPyramidSeriesViewBase.h:47
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48


Toolkit Pro: XTPShortcutBarNativeWindows10Theme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarNativeWindows10Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARNATIVEWINDOWS10THEME_H__)
24# define __XTPSHORTCUTBARNATIVEWINDOWS10THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarNativeWindows10Theme : public CXTPShortcutBarOffice2013Theme
39{
40public:
45 CXTPShortcutBarNativeWindows10Theme();
46
52 virtual ~CXTPShortcutBarNativeWindows10Theme();
53
61 virtual void RefreshMetrics();
62
84 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
85
86 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
87
94 virtual void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
95
102 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
103
104 void DrawHiliteBorder(CDC* pDC, CRect rc);
105
106protected:
107 BOOL m_bHiliteBorders;
108 CXTPPaintManagerColor m_clrBorderHilite;
109 CXTPPaintManagerColor m_clrBackHiliteSelected;
110};
111
112# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif // !defined(__XTPSHORTCUTBARNATIVEWINDOWS10THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarNativeWindows10Theme
CXTPShortcutBarNativeWindows10Theme is a CXTPShortcutBarOffice2013Theme derived class that represents...
Definition XTPShortcutBarNativeWindows10Theme.h:39
CXTPShortcutBarNativeWindows10Theme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarNativeWindows10Theme::m_bHiliteBorders
BOOL m_bHiliteBorders
TRUE to draw borders around highlighted items.
Definition XTPShortcutBarNativeWindows10Theme.h:107
CXTPShortcutBarNativeWindows10Theme::~CXTPShortcutBarNativeWindows10Theme
virtual ~CXTPShortcutBarNativeWindows10Theme()
Destroys a CXTPShortcutBarNativeWindows10Theme object, handles cleanup and deallocation.
CXTPShortcutBarNativeWindows10Theme::m_clrBackHiliteSelected
CXTPPaintManagerColor m_clrBackHiliteSelected
Selected highlighted background color.
Definition XTPShortcutBarNativeWindows10Theme.h:109
CXTPShortcutBarNativeWindows10Theme::FillShortcutItemEntry
virtual void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarNativeWindows10Theme::m_clrBorderHilite
CXTPPaintManagerColor m_clrBorderHilite
Highlighted border color.
Definition XTPShortcutBarNativeWindows10Theme.h:108
CXTPShortcutBarNativeWindows10Theme::CXTPShortcutBarNativeWindows10Theme
CXTPShortcutBarNativeWindows10Theme()
Constructs a CXTPShortcutBarNativeWindows10Theme object.
CXTPShortcutBarNativeWindows10Theme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarNativeWindows10Theme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarOffice2013Theme
CXTPShortcutBarOffice2013Theme is a CXTPShortcutBarResourceTheme derived class that represents an Off...
Definition XTPShortcutBarOffice2013Theme.h:39
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42


Toolkit Pro: XTPCalendarCaptionBarNativeWindows10Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarNativeWindows10Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBARNATIVEWINDOWS10THEME_H__)
23# define __XTPCALENDARCAPTIONBARNATIVEWINDOWS10THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarNativeWindows10Theme
37 : public CXTPCalendarCaptionBarOffice2013Theme
38{
39public:
48 CXTPCalendarCaptionBarNativeWindows10Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarNativeWindows10Theme();
57};
58
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60
61#endif // !defined(__XTPCALENDARCAPTIONBARNATIVEWINDOWS10THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarNativeWindows10Theme
CXTPCalendarCaptionBarNativeWindows10Theme is a CXTPCalendarCaptionBarOffice2013Theme derived class t...
Definition XTPCalendarCaptionBarNativeWindows10Theme.h:38
CXTPCalendarCaptionBarNativeWindows10Theme::CXTPCalendarCaptionBarNativeWindows10Theme
CXTPCalendarCaptionBarNativeWindows10Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarNativeWindows10Theme::~CXTPCalendarCaptionBarNativeWindows10Theme
virtual ~CXTPCalendarCaptionBarNativeWindows10Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarOffice2013Theme
CXTPCalendarCaptionBarOffice2013Theme is a CXTPCalendarCaptionBarOffice2003Theme derived class that r...
Definition XTPCalendarCaptionBarOffice2013Theme.h:38
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48


CXTPShortcutBarOffice2003Theme Member List

This is the complete list of members for CXTPShortcutBarOffice2003Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPShortcutBarOffice2003Theme() | CXTPShortcutBarOffice2003Theme |
CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager |
DrawExpandButton(CDC *pDC, CRect rc) | CXTPShortcutBarPaintManager | virtual
DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw) | CXTPShortcutBarOffice2003Theme | virtual
DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled) | CXTPShortcutBarOffice2003Theme | virtual
DrawNavigationItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw) | CXTPShortcutBarOffice2003Theme | virtual
DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutBarFrame(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
DrawShortcutItem(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager | virtual
FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarOffice2003Theme | virtual
FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar) | CXTPShortcutBarOffice2003Theme | virtual
FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarOffice2003Theme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
IsShortcutItemTruncated(CDC *pDC, CXTPShortcutBarItem *pItem) | CXTPShortcutBarPaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPShortcutBarPaintManager |
m_bBoldItemCaptionFont | CXTPShortcutBarPaintManager |
m_bClearTypeTextQuality | CXTPShortcutBarPaintManager |
m_bNavigationButton | CXTPShortcutBarPaintManager |
m_bShowTopLeftCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_bUseStandardFont | CXTPShortcutBarPaintManager |
m_clrCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrDisabledText | CXTPShortcutBarPaintManager |
m_clrHotText | CXTPShortcutBarPaintManager |
m_clrItemCaptionShadow | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionText | CXTPShortcutBarOffice2003Theme |
m_clrItemCaptionTop | CXTPShortcutBarOffice2003Theme |
m_clrNormalText | CXTPShortcutBarPaintManager |
m_clrPushedText | CXTPShortcutBarPaintManager |
m_clrSelectedText | CXTPShortcutBarPaintManager |
m_clrShortcutItemShadow | CXTPShortcutBarPaintManager |
m_grcCaption | CXTPShortcutBarOffice2003Theme |
m_grcHot | CXTPShortcutBarPaintManager |
m_grcItemCaption | CXTPShortcutBarOffice2003Theme |
m_grcItemHotCaption | CXTPShortcutBarOffice2003Theme |
m_grcPushed | CXTPShortcutBarPaintManager |
m_grcSelected | CXTPShortcutBarPaintManager |
m_grcShortcutBarGripper | CXTPShortcutBarPaintManager |
m_grcShortcutItem | CXTPShortcutBarPaintManager |
m_nExpandedIconWidth | CXTPShortcutBarPaintManager |
m_nNormalIconWidth | CXTPShortcutBarPaintManager |
m_nPaneItemHeight | CXTPShortcutBarPaintManager |
m_pExpandIcon | CXTPShortcutBarPaintManager |
m_rcCaptionPadding | CXTPShortcutBarPaintManager |
m_rcItemCaptionPadding | CXTPShortcutBarPaintManager |
m_strOfficeFont | CXTPShortcutBarPaintManager |
m_xtpFontPaneCaption | CXTPShortcutBarPaintManager |
m_xtpFontPaneItemCaption | CXTPShortcutBarPaintManager |
m_xtpFontText | CXTPShortcutBarPaintManager |
m_xtpFontVerticalText | CXTPShortcutBarPaintManager |
Rectangle(CDC *pDC, CRect rc, int nPen, int nBrush) | CXTPShortcutBarPaintManager |
RefreshMetrics() | CXTPShortcutBarOffice2003Theme | virtual
~CXTPShortcutBarPaintManager() | CXTPShortcutBarPaintManager | virtual


Toolkit Pro: XTPChartPointSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Point
XTPChartPointSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPOINTSERIESSTYLE_H__)
24# define __XTPCHARTPOINTSERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartMarker;
35
46class _XTP_EXT_CLASS CXTPChartPointSeriesStyle : public CXTPChartDiagram2DSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartPointSeriesStyle)
51public:
56 CXTPChartPointSeriesStyle();
57
62 virtual ~CXTPChartPointSeriesStyle();
63
64public:
73 CXTPChartMarker* GetMarker() const;
74
75public:
76 void DoPropExchange(CXTPPropExchange* pPX);
77
78protected:
89 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
90 CXTPChartDiagramView* pDiagramView);
91
92# ifdef _XTP_ACTIVEX
93public:
95 DECLARE_DISPATCH_MAP()
96 DECLARE_INTERFACE_MAP()
97 DECLARE_OLETYPELIB_EX(CXTPChartPointSeriesStyle);
98 DECLARE_OLECREATE_EX(CXTPChartPointSeriesStyle)
99 LPDISPATCH OleGetMarker();
100
102# endif
103
104protected:
105 CXTPChartMarker* m_pMarker;
106};
107
108AFX_INLINE CXTPChartMarker* CXTPChartPointSeriesStyle::GetMarker() const
109{
110 return m_pMarker;
111}
113# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
114#endif //#if !defined(__XTPCHARTPOINTSERIESSTYLE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagram2DSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartDiagram2DSeriesStyle.h:47
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartMarker
This class abstracts a marker used in marking the points in a point series style chart.
Definition XTPChartMarker.h:64
CXTPChartPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartPointSeriesStyle.h:47
CXTPChartPointSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartPointSeriesStyle::GetMarker
CXTPChartMarker * GetMarker() const
Call this function to get the marker object associated with this CXTPChartPointSeriesStyle object.
Definition XTPChartPointSeriesStyle.h:108
CXTPChartPointSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the point series.
CXTPChartPointSeriesStyle::CXTPChartPointSeriesStyle
CXTPChartPointSeriesStyle()
Constructs a CXTPChartPointSeriesStyle object.
CXTPChartPointSeriesStyle::~CXTPChartPointSeriesStyle
virtual ~CXTPChartPointSeriesStyle()
Destroys a CXTPChartPointSeriesStyle object, handles cleanup.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPResizePropertyPage.h Source File

  • Source
  • Controls
  • Resize
XTPResizePropertyPage.h
Go to the documentation of this file.
1
23#if !defined(__XTPRESIZEPROPERTYPAGE_H__)
24# define __XTPRESIZEPROPERTYPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPResizePropertyPage
41 : public CPropertyPage
42 , public CXTPResize
43{
45 DECLARE_DYNCREATE(CXTPResizePropertyPage)
47public:
68 CXTPResizePropertyPage(const UINT nTemplate = 0, const UINT nCaption = 0,
69 const UINT nFlags = 0);
70
71protected:
73 DECLARE_MESSAGE_MAP()
74
75 virtual BOOL OnInitDialog();
76
77 //{{AFX_MSG(CXTPResizePropertyPage)
78 afx_msg void OnSize(UINT nType, int cx, int cy);
79 afx_msg void OnGetMinMaxInfo(MINMAXINFO* lpMMI);
80 afx_msg void OnDestroy();
81 //}}AFX_MSG
84public:
85 DWORD m_nDialogID;
86};
87
88# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif // !defined(__XTPRESIZEPROPERTYPAGE_H__)
XTPDisableNoisyWarnings.h
CXTPResize
CXTPResize is a base class.
Definition XTPResize.h:145
CXTPResizePropertyPage
CXTPResizePropertyPage is a multiple inheritance class derived from CPropertyPage and CXTPResize.
Definition XTPResizePropertyPage.h:43
CXTPResizePropertyPage::CXTPResizePropertyPage
CXTPResizePropertyPage(const UINT nTemplate=0, const UINT nCaption=0, const UINT nFlags=0)
Constructs a CXTPResizePropertyPage object.


CXTPChartFunnelSeriesLabelBase Member List

This is the complete list of members for CXTPChartFunnelSeriesLabelBase, including all inherited members.

CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)=0 | CXTPChartFunnelSeriesLabelBase | protectedpure virtual
CXTPChartElement() | CXTPChartElement |
CXTPChartFunnelSeriesLabelBase() | CXTPChartFunnelSeriesLabelBase |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeriesLabel() | CXTPChartSeriesLabel |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartFunnelSeriesLabelBase | virtual
GetAntialiasing() const | CXTPChartSeriesLabel | virtual
GetAppearance() const | CXTPChartElement |
GetBackColor() const | CXTPChartSeriesLabel |
GetContent() const | CXTPChartElement |
GetFont() const | CXTPChartSeriesLabel | virtual
GetFormat() const | CXTPChartSeriesLabel |
GetLineColor() const | CXTPChartSeriesLabel |
GetLineLength() const | CXTPChartSeriesLabel |
GetOwner() const | CXTPChartElement |
GetPosition() const | CXTPChartFunnelSeriesLabelBase |
GetShowLines() const | CXTPChartSeriesLabel |
GetStyle() const | CXTPChartFunnelSeriesLabelBase |
GetTextColor() const | CXTPChartSeriesLabel |
GetTransparency() const | CXTPChartSeriesLabel |
Is3D() const | CXTPChartObject |
IsInside() const | CXTPChartFunnelSeriesLabelBase |
IsVisible() const | CXTPChartSeriesLabel |
m_bAntialiasing | CXTPChartSeriesLabel | protected
m_bShowLines | CXTPChartSeriesLabel | protected
m_bVisible | CXTPChartSeriesLabel | protected
m_clrBackColor | CXTPChartSeriesLabel | protected
m_clrLineColor | CXTPChartSeriesLabel | protected
m_clrTextColor | CXTPChartSeriesLabel | protected
m_nLineLength | CXTPChartSeriesLabel | protected
m_nPosition | CXTPChartFunnelSeriesLabelBase | protected
m_nTransparency | CXTPChartSeriesLabel | protected
m_pBorder | CXTPChartSeriesLabel | protected
m_pFont | CXTPChartSeriesLabel | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
SetAntialiasing(BOOL bAntialiasing) | CXTPChartSeriesLabel |
SetBackColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetFont(CXTPChartFont *pFont) | CXTPChartSeriesLabel |
SetFormat(LPCTSTR lpszFormat) | CXTPChartSeriesLabel |
SetLineColor(const CXTPChartColor &clrBackColor) | CXTPChartSeriesLabel |
SetLineLength(int nLineLength) | CXTPChartSeriesLabel |
SetPosition(XTPChartFunnelLabelPosition nPosition) | CXTPChartFunnelSeriesLabelBase |
SetShowLines(BOOL bShowLines) | CXTPChartSeriesLabel |
SetTextColor(const CXTPChartColor &clrTextColor) | CXTPChartSeriesLabel |
SetTransparency(int nTransparency) | CXTPChartSeriesLabel |
SetVisible(BOOL bVisible) | CXTPChartSeriesLabel |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartFunnelSeriesLabelBase() | CXTPChartFunnelSeriesLabelBase | virtual
~CXTPChartSeriesLabel() | CXTPChartSeriesLabel | virtual


CXTPDatePickerButtons Member List

This is the complete list of members for CXTPDatePickerButtons, including all inherited members.

Find(int nID) const | CXTPDatePickerButtons
GetVisibleButtonCount() const | CXTPDatePickerButtons
HitTest(CPoint point) const | CXTPDatePickerButtons


Toolkit Pro: XTPCalendarOffice2000Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarOffice2000Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDAROFFICE2000THEME_H__)
23# define __XTPCALENDAROFFICE2000THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarOffice2000Theme : public CXTPCalendarPaintManager
37{
38public:
47 CXTPCalendarOffice2000Theme();
48
55 virtual ~CXTPCalendarOffice2000Theme();
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPCALENDAROFFICE2000THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme is a CXTPCalendarPaintManager derived class that represents the Office 20...
Definition XTPCalendarOffice2000Theme.h:37
CXTPCalendarOffice2000Theme::CXTPCalendarOffice2000Theme
CXTPCalendarOffice2000Theme()
Default paint manager constructor.
CXTPCalendarOffice2000Theme::~CXTPCalendarOffice2000Theme
virtual ~CXTPCalendarOffice2000Theme()
Default paint manager destructor.
CXTPCalendarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarPaintManager.h:150


CXTPChartAxisViewTick Member List

This is the complete list of members for CXTPChartAxisViewTick, including all inherited members.

m_dValue | CXTPChartAxisViewTick
m_strLabel | CXTPChartAxisViewTick
m_szBounds | CXTPChartAxisViewTick
m_szLabel | CXTPChartAxisViewTick


CXTPControlGalleryVisualStudio2022Theme Member List

This is the complete list of members for CXTPControlGalleryVisualStudio2022Theme, including all inherited members.

CXTPControlGalleryOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryOffice2013Theme |
CXTPControlGalleryPaintManager(CXTPPaintManager *pPaintManager) | CXTPControlGalleryPaintManager |
CXTPControlGalleryVisualStudio2022Theme(CXTPPaintManager *pPaintManager) | CXTPControlGalleryVisualStudio2022Theme |
DrawLabel(CDC *pDC, CXTPControlGalleryItem *pLabel, CRect rc) | CXTPControlGalleryPaintManager | virtual
DrawPopupScrollBar(CDC *pDC, CXTPControlGallery *pGallery) | CXTPControlGalleryOffice2013Theme | virtual
FillControl(CDC *pDC, CXTPControlGallery *pGallery, CRect rc) | CXTPControlGalleryOffice2013Theme | protectedvirtual
m_cxPopup | CXTPControlGalleryPaintManager |
m_cyPopupDown | CXTPControlGalleryPaintManager |
m_cyPopupUp | CXTPControlGalleryPaintManager |
RefreshMetrics() | CXTPControlGalleryOffice2013Theme | virtual


CXTPGridColumn Member List

This is the complete list of members for CXTPGridColumn, including all inherited members.

AllowRemove(BOOL bAllow) | CXTPGridColumn |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPGridColumn(int nItemIndex, LPCTSTR strName, int nWidth, BOOL bAutoSize=TRUE, int nIconID=XTP_GRID_NOICON, BOOL bSortable=TRUE, BOOL bVisible=TRUE) | CXTPGridColumn |
CXTPGridColumn(int nItemIndex, LPCTSTR strDisplayName, LPCTSTR strInternalName, int nWidth, BOOL bAutoSize=TRUE, int nIconID=XTP_GRID_NOICON, BOOL bSortable=TRUE, BOOL bVisible=TRUE) | CXTPGridColumn |
DoPropExchange(CXTPPropExchange *pPX) | CXTPGridColumn | virtual
EnableResize(BOOL bIsResizable) | CXTPGridColumn |
EnsureVisible() | CXTPGridColumn | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAlignment() const | CXTPGridColumn |
GetBestFitMode() const | CXTPGridColumn |
GetCaption() const | CXTPGridColumn |
GetCaptionWidth(CDC *pDC) | CXTPGridColumn |
GetColumns() const | CXTPGridColumn |
GetControl() const | CXTPGridColumn |
GetDisplayOptions() const | CXTPGridColumn |
GetDrawFooterDivider() const | CXTPGridColumn |
GetDrawFooterRowsVGrid() const | CXTPGridColumn |
GetDrawHeaderDivider() const | CXTPGridColumn |
GetDrawHeaderRowsVGrid() const | CXTPGridColumn |
GetEditOptions() const | CXTPGridColumn |
GetFooterAlignment() const | CXTPGridColumn |
GetFooterFont() | CXTPGridColumn |
GetFooterText() const | CXTPGridColumn |
GetHeaderAlignment() const | CXTPGridColumn |
GetIconID() const | CXTPGridColumn |
GetIndent() const | CXTPGridColumn |
GetIndex() const | CXTPGridColumn |
GetInternalName() const | CXTPGridColumn |
GetItemIndex() const | CXTPGridColumn |
GetLiteral() const | CXTPGridColumn |
GetMarkupUIElement() const | CXTPGridColumn |
GetMask() const | CXTPGridColumn |
GetMaxWidth() const | CXTPGridColumn |
GetMinWidth() const | CXTPGridColumn |
GetNextVisualBlock() const | CXTPGridColumn |
GetOldVisibleIndex() const | CXTPGridColumn |
GetPrintWidth(int nTotalWidth) const | CXTPGridColumn |
GetPrompt() const | CXTPGridColumn |
GetRect() const | CXTPGridColumn |
GetTooltip() const | CXTPGridColumn |
GetVisibleIndex() const | CXTPGridColumn |
GetWidth() const | CXTPGridColumn |
HasSortTriangle() const | CXTPGridColumn |
IsAllowDragging() const | CXTPGridColumn |
IsAllowRemove() const | CXTPGridColumn |
IsAutoSize() const | CXTPGridColumn |
IsAutoSortWhenGrouped() const | CXTPGridColumn |
IsDragging() const | CXTPGridColumn |
IsEditable() const | CXTPGridColumn |
IsExpanded() const | CXTPGridColumn |
IsFilterable() const | CXTPGridColumn |
IsFixed() const | CXTPGridColumn |
IsFrozen() const | CXTPGridColumn |
IsGroupable() const | CXTPGridColumn |
IsHotTracking() const | CXTPGridColumn |
IsPlusMinus() const | CXTPGridColumn |
IsResizable() const | CXTPGridColumn |
IsShowInFieldChooser() const | CXTPGridColumn |
IsSortable() const | CXTPGridColumn |
IsSorted() const | CXTPGridColumn |
IsSortedDecreasing() const | CXTPGridColumn |
IsSortedIncreasing() const | CXTPGridColumn |
IsTreeColumn() const | CXTPGridColumn |
IsUseMask() const | CXTPGridColumn |
IsVisible() const | CXTPGridColumn |
m_bAllowDrag | CXTPGridColumn | protected
m_bAllowRemove | CXTPGridColumn | protected
m_bAutoNumbering | CXTPGridColumn | protected
m_bAutoSize | CXTPGridColumn | protected
m_bAutoSortWhenGrouped | CXTPGridColumn | protected
m_bDrawFooterDivider | CXTPGridColumn | protected
m_bDrawFooterRowsVGrid | CXTPGridColumn | protected
m_bDrawHeaderDivider | CXTPGridColumn | protected
m_bDrawHeaderRowsVGrid | CXTPGridColumn | protected
m_bEditable | CXTPGridColumn | protected
m_bExpanded | CXTPGridColumn | protected
m_bFilterable | CXTPGridColumn | protected
m_bFixed | CXTPGridColumn | protected
m_bFrozen | CXTPGridColumn | protected
m_bGroupable | CXTPGridColumn | protected
m_bIsResizable | CXTPGridColumn | protected
m_bPlusMinus | CXTPGridColumn | protected
m_bShowInFieldChooser | CXTPGridColumn | protected
m_bSortable | CXTPGridColumn | protected
m_bSortIncreasing | CXTPGridColumn | protected
m_bUseMask | CXTPGridColumn | protected
m_bVisible | CXTPGridColumn | protected
m_chPrompt | CXTPGridColumn | protected
m_nAlignment | CXTPGridColumn | protected
m_nAutoNumberingBase | CXTPGridColumn | protected
m_nBestFitMode | CXTPGridColumn | protected
m_nColumnAutoWidth | CXTPGridColumn | protected
m_nColumnStaticWidth | CXTPGridColumn | protected
m_nFooterAlignment | CXTPGridColumn | protected
m_nHeaderAlignment | CXTPGridColumn | protected
m_nIconID | CXTPGridColumn | protected
m_nItemIndex | CXTPGridColumn | protected
m_nMaxItemWidth | CXTPGridColumn | protected
m_nMaxWidth | CXTPGridColumn | protected
m_nMinWidth | CXTPGridColumn | protected
m_nNextVisualBlock | CXTPGridColumn | protected
m_nOldVisibleIndex | CXTPGridColumn | protected
m_pColumns | CXTPGridColumn | protected
m_pDisplayOptions | CXTPGridColumn | protected
m_pEditOptions | CXTPGridColumn | protected
m_pMarkupUIElement | CXTPGridColumn | protected
m_rcColumn | CXTPGridColumn | protected
m_rcGroupBy | CXTPGridColumn | protected
m_strFooterText | CXTPGridColumn | protected
m_strInternalName | CXTPGridColumn | protected
m_strLiteral | CXTPGridColumn | protected
m_strMask | CXTPGridColumn | protected
m_strName | CXTPGridColumn | protected
m_strTooltip | CXTPGridColumn | protected
m_xtpFontFooter | CXTPGridColumn | protected
ResetMarkupUIElement() | CXTPGridColumn | virtual
SetAlignment(int nAlignment) | CXTPGridColumn |
SetAllowDrag(BOOL bAllowDrag) | CXTPGridColumn |
SetAutoSize(BOOL bSet) | CXTPGridColumn |
SetAutoSortWhenGrouped(BOOL bAutoSortWhenGrouped) | CXTPGridColumn |
SetBestFitMode(int nMode) | CXTPGridColumn |
SetCaption(LPCTSTR strCaption) | CXTPGridColumn |
SetDrawFooterDivider(BOOL bSet) | CXTPGridColumn |
SetDrawFooterRowsVGrid(BOOL bDrawVGrid=TRUE) | CXTPGridColumn |
SetDrawHeaderDivider(BOOL bSet) | CXTPGridColumn |
SetDrawHeaderRowsVGrid(BOOL bDrawVGrid=TRUE) | CXTPGridColumn |
SetEditable(BOOL bEditable=TRUE) | CXTPGridColumn |
SetExpanded(BOOL bExpanded) | CXTPGridColumn |
SetFilterable(BOOL bFilterable=TRUE) | CXTPGridColumn |
SetFixed(BOOL bFixed) | CXTPGridColumn |
SetFooterAlignment(int nAlignment) | CXTPGridColumn |
SetFooterFont(CFont *pFont) | CXTPGridColumn |
SetFooterText(LPCTSTR strFooter) | CXTPGridColumn |
SetFrozen(BOOL bFrozen) | CXTPGridColumn |
SetGroupable(BOOL bGroupable) | CXTPGridColumn |
SetHeaderAlignment(int nAlignment) | CXTPGridColumn |
SetIconID(int nIconId) | CXTPGridColumn |
SetInternalName(LPCTSTR pcszName) | CXTPGridColumn |
SetItemIndex(int nItemIndex) | CXTPGridColumn |
SetMask(LPCTSTR strMask, LPCTSTR strLiteral, TCHAR chPrompt=_T('_')) | CXTPGridColumn |
SetMaxWidth(int nMaxWidth) | CXTPGridColumn |
SetMinWidth(int nMinWidth) | CXTPGridColumn |
SetNextVisualBlock(int nNextVisualBlock) | CXTPGridColumn |
SetPlusMinus(BOOL bPlusMinus) | CXTPGridColumn |
SetShowInFieldChooser(BOOL bShow) | CXTPGridColumn |
SetSortable(BOOL bSortable) | CXTPGridColumn |
SetSortIncreasing(BOOL bSortIncreasing) | CXTPGridColumn |
SetTooltip(LPCTSTR lpszTooltip) | CXTPGridColumn |
SetTreeColumn(BOOL bIsTreeColumn) | CXTPGridColumn |
SetVisible(BOOL bVisible=TRUE) | CXTPGridColumn |
SetWidth(int nNewWidth) | CXTPGridColumn |
~CXTPGridColumn() | CXTPGridColumn | virtual


CXTPChart3dPieSeriesLabelsViewDeviceCommand Member List

This is the complete list of members for CXTPChart3dPieSeriesLabelsViewDeviceCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChart3dDeviceCommand(XTPChart3dAntialiasingPolicy nAntialiasingPolicy) | CXTPChart3dDeviceCommand | protected
CXTPChart3dPieSeriesLabelsViewDeviceCommand(CXTPChart3dPieSeriesLabelsView *pSeriesLabelsView) | CXTPChart3dPieSeriesLabelsViewDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChart3dPieSeriesLabelsViewDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartDeviceCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChart3dDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_pSeriesLabelsView | CXTPChart3dPieSeriesLabelsViewDeviceCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


CXTPMarkupScaleTransform Member List

This is the complete list of members for CXTPMarkupScaleTransform, including all inherited members.

ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix) | CXTPMarkupScaleTransform | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCenterX() const | CXTPMarkupScaleTransform |
GetCenterY() const | CXTPMarkupScaleTransform |
GetScaleX() const | CXTPMarkupScaleTransform |
GetScaleY() const | CXTPMarkupScaleTransform |
m_pPropertyCenterX | CXTPMarkupScaleTransform | static
m_pPropertyCenterY | CXTPMarkupScaleTransform | static
m_pPropertyScaleX | CXTPMarkupScaleTransform | static
m_pPropertyScaleY | CXTPMarkupScaleTransform | static
SetCenterX(double centerX) | CXTPMarkupScaleTransform |
SetCenterY(double centerY) | CXTPMarkupScaleTransform |
SetScaleX(double scaleX) | CXTPMarkupScaleTransform |
SetScaleY(double scaleY) | CXTPMarkupScaleTransform |


Toolkit Pro: XTPGridThemeVisualStudio2019.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2019_H__)
24# define __XTPGRIDTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeVisualStudio2019 : public CXTPGridThemeOffice2013
39{
40public:
45 CXTPGridThemeVisualStudio2019();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPGRIDTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridThemeOffice2013
CXTPGridThemeOffice2013 is a CXTPGridPaintManager derived class that represents an Office 2013 style ...
Definition XTPGridThemeOffice2013.h:39
CXTPGridThemeVisualStudio2019
CXTPGridThemeVisualStudio2019 is a CXTPGridThemeOffice2013 derived class that represents a Visual Stu...
Definition XTPGridThemeVisualStudio2019.h:39
CXTPGridThemeVisualStudio2019::CXTPGridThemeVisualStudio2019
CXTPGridThemeVisualStudio2019()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeVisualStudio2019::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.


CXTPNonClientMetrics Member List

This is the complete list of members for CXTPNonClientMetrics, including all inherited members.

CXTPNonClientMetrics() CXTPNonClientMetrics


CXTPChartHighLowSeriesView Member List

This is the complete list of members for CXTPChartHighLowSeriesView, including all inherited members.

AddChildView(CXTPChartElementView *pChildView) | CXTPChartElementView |
CreateDeviceCommand(CXTPChartDeviceContext *pDC) | CXTPChartElementView | virtual
CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds) | CXTPChartHighLowSeriesView | protectedvirtual
CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView) | CXTPChartHighLowSeriesView | protected
CXTPChartElementView(CXTPChartElementView *pParentView) | CXTPChartElementView |
CXTPChartElementView(CXTPChartElementView *pParentView, BOOL bAddToParent) | CXTPChartElementView |
CXTPChartElementView(CXTPChartContainer *pContainer) | CXTPChartElementView |
CXTPChartHighLowSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartHighLowSeriesView |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
GetAt(int nIndex) const | CXTPChartElementView |
GetBounds() const | CXTPChartElementView |
GetBounds(BOOL bIncludingChildren) const | CXTPChartElementView |
GetChildren() | CXTPChartElementView |
GetCount() const | CXTPChartElementView |
GetParentView() const | CXTPChartElementView |
Is3D() const | CXTPChartObject |
m_arrChildren | CXTPChartElementView | protected
m_pContainer | CXTPChartElementView | protected
m_pParentView | CXTPChartElementView | protected
m_rcBounds | CXTPChartElementView | protected
~CXTPChartElementView() | CXTPChartElementView | protectedvirtual
~CXTPChartLegendItemView() | CXTPChartLegendItemView | inlinevirtual


CXTPDockingPanePanelColorSet2019 Member List

This is the complete list of members for CXTPDockingPanePanelColorSet2019, including all inherited members.

CXTPDockingPanePanelColorSet2012() | CXTPDockingPanePanelColorSet2012 |
CXTPDockingPanePanelColorSet2019() | CXTPDockingPanePanelColorSet2019 |
CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet |
FillClient(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillHeader(CDC *pDC, CRect rc, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
FillNavigateButton(CDC *pDC, CXTPTabManagerNavigateButton *pButton, CRect &rc) | CXTPDockingPanePanelColorSet2012 | virtual
FillPropertyButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
FillStateButton(CDC *pDC, CRect rcItem, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
GetClientColor(CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
GetItemColor(CXTPTabManagerItem *pItem) | CXTPDockingPanePanelColorSet2012 | virtual
GradientFill(CDC *pDC, CRect rc, COLORREF clrLight, COLORREF clrDark, XTPTabPosition position) | CXTPTabPaintManagerColorSet |
IsAppThemed() const | CXTPTabPaintManagerColorSet | virtual
m_clrActiveFilesBack | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesBackPressed | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyph | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphHighlighted | CXTPTabPaintManagerColorSet |
m_clrActiveFilesGlyphPressed | CXTPTabPaintManagerColorSet |
m_clrAutoHideFace | CXTPTabPaintManagerColorSet |
m_clrBorderHighlight | CXTPTabPaintManagerColorSet |
m_clrButtonBorder | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonBorderHot | CXTPTabPaintManagerColorSet |
m_clrButtonBorderKeyTips | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext1 | CXTPTabPaintManagerColorSet |
m_clrButtonBorderTabContext2 | CXTPTabPaintManagerColorSet |
m_clrButtonHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonHighlightedClose | CXTPTabPaintManagerColorSet |
m_clrButtonNormal | CXTPTabPaintManagerColorSet |
m_clrButtonPressed | CXTPTabPaintManagerColorSet |
m_clrButtonSelected | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrButtonSelectedPressed | CXTPTabPaintManagerColorSet |
m_clrControlFace | CXTPTabPaintManagerColorSet |
m_clrFrameBorder | CXTPTabPaintManagerColorSet |
m_clrHeaderFace | CXTPTabPaintManagerColorSet |
m_clrPaneFace | CXTPTabPaintManagerColorSet |
m_clrTabClientBack | CXTPTabPaintManagerColorSet |
m_clrTabClientBorder | CXTPTabPaintManagerColorSet |
m_clrTextDisabled | CXTPTabPaintManagerColorSet |
m_clrTextHighlight | CXTPTabPaintManagerColorSet |
m_clrTextHighlightClose | CXTPTabPaintManagerColorSet |
m_clrTextNormal | CXTPTabPaintManagerColorSet |
m_clrTextPressed | CXTPTabPaintManagerColorSet |
m_clrTextSelected | CXTPTabPaintManagerColorSet |
m_clrTextSelectedHighlighted | CXTPTabPaintManagerColorSet |
m_clrTextSelectedPressed | CXTPTabPaintManagerColorSet |
m_csExcelNormal | CXTPTabPaintManagerColorSet |
m_csExcelSelected | CXTPTabPaintManagerColorSet |
m_csPropertyPage | CXTPTabPaintManagerColorSet |
m_csPropertyPage2003 | CXTPTabPaintManagerColorSet |
m_csStateButton | CXTPTabPaintManagerColorSet |
m_pPaintManager | CXTPTabPaintManagerColorSet | protected
RefreshMetrics() | CXTPDockingPanePanelColorSet2019 | virtual
SelectClipRgn(CDC *pDC, CRect rcClient, CXTPTabManager *pTabManager) | CXTPTabPaintManagerColorSet | virtual
SetTextColor(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerColorSet | virtual
~CXTPTabPaintManagerColorSet() | CXTPTabPaintManagerColorSet | virtual


Toolkit Pro: XTPShortcutBarPane.h Source File

  • Source
  • ShortcutBar
XTPShortcutBarPane.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARPANE_H__)
24# define __XTPSHORTCUTBARPANE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPShortcutBar;
34class CXTPShortcutBarPane;
35
41class _XTP_EXT_CLASS CXTPShortcutBarPaneItem
42{
43protected:
51 CXTPShortcutBarPaneItem(LPCTSTR lpszCaption, CWnd* pWnd, int nHeight);
52
53public:
60 CRect GetCaptionRect() const;
61
68 CString GetCaption() const;
69
75 void SetCaption(LPCTSTR lpszCaption);
76
82 void SetHeight(int nHeight);
83
90 int GetHeight() const;
91
97 void ShowCaption(BOOL bShowCaption);
98
105 BOOL IsHighlighted() const;
106
113 BOOL IsExpandable() const;
114
121 BOOL IsExpanded() const;
122
128 void SetExpandable(BOOL bExpandable);
129
135 void SetExpanded(BOOL bExpanded);
136
137protected:
138 CString m_strCaption;
139 CRect m_rcCaption;
140 CRect m_rcClient;
141 CWnd* m_pWndClient;
142 int m_nHeight;
143 BOOL m_bShowCaption;
144 CXTPShortcutBarPane* m_pPane;
146 BOOL m_bExpandable;
147 BOOL m_bExpanded;
149 friend class CXTPShortcutBarPane;
150};
151
157class _XTP_EXT_CLASS CXTPShortcutBarPane : public CWnd
158{
160 DECLARE_DYNAMIC(CXTPShortcutBarPane)
162public:
167 CXTPShortcutBarPane();
168
173 virtual ~CXTPShortcutBarPane();
174
175public:
183 BOOL Create(LPCTSTR lpszCaption, CXTPShortcutBar* pParent);
184
191 CString GetCaption() const;
192
198 void SetCaption(LPCTSTR lpszCaption);
199
209 CXTPShortcutBarPaneItem* AddItem(LPCTSTR lpszCaption, CWnd* pWnd, int nHeight);
210
218 CXTPShortcutBarPaneItem* GetItem(int nIndex) const;
219
235 void SetIndent(int left, int top, int right, int bottom);
236
242 void ShowCaption(BOOL bShowCaption);
243
249 void SetMinimumClientHeight(int nMinHeight);
250
257 virtual int GetMinimumClientHeight() const;
258
267 CXTPShortcutBarPaneItem* HitTest(CPoint point) const;
268
273 void RecalcLayout();
274
275 CXTPShortcutBar* GetShortcutBar() const;
276
277 CRect GetMinimizeButtonRect() const;
278 BOOL IsMinimizeButtonHighlighted() const;
279 BOOL IsMinimizeButtonPressed() const;
280
281 virtual COLORREF GetBackgroundColor() const;
282 virtual COLORREF GetTextColor() const;
283
284 void SetFlatStyle(BOOL bFlatStyle);
285 BOOL IsFlatStyle() const;
286
287protected:
289 DECLARE_MESSAGE_MAP()
290
291 //{{AFX_MSG(CXTPShortcutBarPane)
292 afx_msg void OnSize(UINT nType, int cx, int cy);
293 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
294 afx_msg void OnPaint();
295 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM /*lParam*/);
296 afx_msg void OnDraw(CDC* pDC);
297 void OnMouseMove(UINT nFlags, CPoint point);
298 void OnMouseLeave();
299 void OnLButtonDown(UINT nFlags, CPoint point);
300 BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
301 //}}AFX_MSG
304private:
305 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
306 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
307
308protected:
309 CXTPShortcutBar* m_pShortcutBar;
310 CString m_strCaption;
311 CArray<CXTPShortcutBarPaneItem*, CXTPShortcutBarPaneItem*> m_arrItems;
312 CRect m_rcIndent;
313 BOOL m_bShowCaption;
314 int m_nMinClientHeight;
315 CXTPShortcutBarPaneItem* m_pHighlighted;
316 HCURSOR m_hHandCursor;
318 CRect m_rcMinimizeButton;
319 BOOL m_bMinimizeButtonHighlighted;
320 BOOL m_bMinimizeButtonPressed;
321 BOOL m_bFlatStyle;
322
323 friend class CXTPShortcutBarPaneItem;
324};
325
327
328AFX_INLINE CString CXTPShortcutBarPane::GetCaption() const
329{
330 return m_strCaption;
331}
332AFX_INLINE void CXTPShortcutBarPane::SetIndent(int left, int top, int right, int bottom)
333{
334 m_rcIndent.SetRect(left, top, right, bottom);
335}
336AFX_INLINE void CXTPShortcutBarPane::ShowCaption(BOOL bShowCaption)
337{
338 m_bShowCaption = bShowCaption;
339}
340AFX_INLINE BOOL CXTPShortcutBarPane::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName,
341 DWORD dwStyle, const RECT& rect, CWnd* pParentWnd,
342 UINT nID, CCreateContext* pContext)
343{
344 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
345}
346AFX_INLINE CRect CXTPShortcutBarPaneItem::GetCaptionRect() const
347{
348 return m_rcCaption;
349}
350AFX_INLINE int CXTPShortcutBarPaneItem::GetHeight() const
351{
352 return m_nHeight;
353}
354AFX_INLINE BOOL CXTPShortcutBarPaneItem::IsHighlighted() const
355{
356 return m_pPane->m_pHighlighted == this;
357}
358AFX_INLINE CString CXTPShortcutBarPaneItem::GetCaption() const
359{
360 return m_strCaption;
361}
362AFX_INLINE void CXTPShortcutBarPaneItem::ShowCaption(BOOL bShowCaption)
363{
364 m_bShowCaption = bShowCaption;
365}
366AFX_INLINE void CXTPShortcutBarPane::SetMinimumClientHeight(int nMinHeight)
367{
368 m_nMinClientHeight = nMinHeight;
369}
370AFX_INLINE int CXTPShortcutBarPane::GetMinimumClientHeight() const
371{
372 return m_nMinClientHeight;
373}
374AFX_INLINE BOOL CXTPShortcutBarPaneItem::IsExpandable() const
375{
376 return m_bExpandable && m_bShowCaption;
377}
378AFX_INLINE BOOL CXTPShortcutBarPaneItem::IsExpanded() const
379{
380 return m_bExpanded;
381}
382AFX_INLINE void CXTPShortcutBarPaneItem::SetExpandable(BOOL bExpandable)
383{
384 m_bExpandable = bExpandable;
385}
386AFX_INLINE void CXTPShortcutBarPaneItem::SetExpanded(BOOL bExpanded)
387{
388 if (m_bExpanded != bExpanded)
389 {
390 m_bExpanded = bExpanded;
391 m_pPane->RecalcLayout();
392 }
393}
394AFX_INLINE CXTPShortcutBar* CXTPShortcutBarPane::GetShortcutBar() const
395{
396 return m_pShortcutBar;
397}
398AFX_INLINE CRect CXTPShortcutBarPane::GetMinimizeButtonRect() const
399{
400 return m_rcMinimizeButton;
401}
402AFX_INLINE BOOL CXTPShortcutBarPane::IsMinimizeButtonHighlighted() const
403{
404 return m_bMinimizeButtonHighlighted;
405}
406AFX_INLINE BOOL CXTPShortcutBarPane::IsMinimizeButtonPressed() const
407{
408 return m_bMinimizeButtonPressed;
409}
410AFX_INLINE void CXTPShortcutBarPane::SetFlatStyle(BOOL bFlatStyle)
411{
412 m_bFlatStyle = bFlatStyle;
413 if (m_hWnd)
414 Invalidate(FALSE);
415}
416AFX_INLINE BOOL CXTPShortcutBarPane::IsFlatStyle() const
417{
418 return m_bFlatStyle;
419}
420
421# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
423#endif // !defined(__XTPSHORTCUTBARPANE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPane::AddItem
CXTPShortcutBarPaneItem * AddItem(LPCTSTR lpszCaption, CWnd *pWnd, int nHeight)
Adds a specified item to the pane.
CXTPShortcutBarPane::SetIndent
void SetIndent(int left, int top, int right, int bottom)
Sets the indent placed around the client area of the shortcut bar.
Definition XTPShortcutBarPane.h:332
CXTPShortcutBarPane::GetItem
CXTPShortcutBarPaneItem * GetItem(int nIndex) const
Gets the item at the specified index.
CXTPShortcutBarPane::~CXTPShortcutBarPane
virtual ~CXTPShortcutBarPane()
Destroys a CXTPShortcutBarPane object, handles cleanup and deallocation.
CXTPShortcutBarPane::CXTPShortcutBarPane
CXTPShortcutBarPane()
Constructs a CXTPShortcutBarPane object.
CXTPShortcutBarPane::Create
BOOL Create(LPCTSTR lpszCaption, CXTPShortcutBar *pParent)
Creates the CXTPShortcutBarPane control.
CXTPShortcutBarPane::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption for the pane.
CXTPShortcutBarPane::GetMinimumClientHeight
virtual int GetMinimumClientHeight() const
Gets the minimum height of the client area.
Definition XTPShortcutBarPane.h:370
CXTPShortcutBarPane::HitTest
CXTPShortcutBarPaneItem * HitTest(CPoint point) const
Determines which item, if any, is located at a specified point.
CXTPShortcutBarPane::RecalcLayout
void RecalcLayout()
Recalculates the layout of the pane.
CXTPShortcutBarPane::ShowCaption
void ShowCaption(BOOL bShowCaption)
Shows/hides the caption.
Definition XTPShortcutBarPane.h:336
CXTPShortcutBarPane::SetMinimumClientHeight
void SetMinimumClientHeight(int nMinHeight)
Sets the minimum height for the client area.
Definition XTPShortcutBarPane.h:366
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPShortcutBarPaneItem::m_bExpanded
BOOL m_bExpanded
TRUE if the pane is expanded.
Definition XTPShortcutBarPane.h:147
CXTPShortcutBarPaneItem::m_rcClient
CRect m_rcClient
Bounding rectangle of the client area.
Definition XTPShortcutBarPane.h:140
CXTPShortcutBarPaneItem::IsExpandable
BOOL IsExpandable() const
Determines if the item is expandable.
Definition XTPShortcutBarPane.h:374
CXTPShortcutBarPaneItem::SetExpanded
void SetExpanded(BOOL bExpanded)
Sets the expanded state of the item.
Definition XTPShortcutBarPane.h:386
CXTPShortcutBarPaneItem::IsExpanded
BOOL IsExpanded() const
Gets the expanded state of the item.
Definition XTPShortcutBarPane.h:378
CXTPShortcutBarPaneItem::m_bShowCaption
BOOL m_bShowCaption
TRUE to show the caption.
Definition XTPShortcutBarPane.h:143
CXTPShortcutBarPaneItem::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Sets the caption for the item.
CXTPShortcutBarPaneItem::m_rcCaption
CRect m_rcCaption
Rectangle of the caption.
Definition XTPShortcutBarPane.h:139
CXTPShortcutBarPaneItem::GetCaptionRect
CRect GetCaptionRect() const
Gets the rectangle of the caption.
Definition XTPShortcutBarPane.h:346
CXTPShortcutBarPaneItem::GetCaption
CString GetCaption() const
Gets the caption of the item.
Definition XTPShortcutBarPane.h:358
CXTPShortcutBarPaneItem::SetHeight
void SetHeight(int nHeight)
Sets the height for the item.
CXTPShortcutBarPaneItem::m_bExpandable
BOOL m_bExpandable
TRUE if the pane is expandable.
Definition XTPShortcutBarPane.h:146
CXTPShortcutBarPaneItem::GetHeight
int GetHeight() const
Gets the height of the item.
Definition XTPShortcutBarPane.h:350
CXTPShortcutBarPaneItem::CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem(LPCTSTR lpszCaption, CWnd *pWnd, int nHeight)
Constructs a CXTPShortcutBarPaneItem object.
CXTPShortcutBarPaneItem::IsHighlighted
BOOL IsHighlighted() const
Gets the highlighted state of the item.
Definition XTPShortcutBarPane.h:354
CXTPShortcutBarPaneItem::SetExpandable
void SetExpandable(BOOL bExpandable)
Specifies if the item should be expandable.
Definition XTPShortcutBarPane.h:382
CXTPShortcutBarPaneItem::m_pPane
CXTPShortcutBarPane * m_pPane
Parent pane object.
Definition XTPShortcutBarPane.h:144
CXTPShortcutBarPaneItem::m_pWndClient
CWnd * m_pWndClient
Associated child window.
Definition XTPShortcutBarPane.h:141
CXTPShortcutBarPaneItem::ShowCaption
void ShowCaption(BOOL bShowCaption)
Shows/hides the caption.
Definition XTPShortcutBarPane.h:362
CXTPShortcutBarPaneItem::m_nHeight
int m_nHeight
Height of the item.
Definition XTPShortcutBarPane.h:142
CXTPShortcutBarPaneItem::m_strCaption
CString m_strCaption
Caption of the item.
Definition XTPShortcutBarPane.h:138


CXTPSkinObjectTab Member List

This is the complete list of members for CXTPSkinObjectTab, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectTab() | CXTPSkinObjectTab |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual
~CXTPSkinObjectTab() | CXTPSkinObjectTab | virtual


Toolkit Pro: XTPChartPieSeriesViewBase.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • Base
XTPChartPieSeriesViewBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPIESERIESVIEWBASE_H__)
24# define __XTPCHARTPIESERIESVIEWBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChartPieSeriesViewBase : public CXTPChartSeriesView
45{
46protected:
54 CXTPChartPieSeriesViewBase(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
55
56public:
61 virtual ~CXTPChartPieSeriesViewBase();
62
63public:
71 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds) = 0;
72
79 virtual void CalculateLabelLayout(CXTPChartDeviceContext* pDC);
80
92 virtual CXTPChartDiagramDomain* CreateDiagramDomain(CXTPChartDeviceContext* pDC,
93 CRect rcBounds);
94
102 CXTPChartRectF GetInnerBounds() const;
103
112 CXTPChartDiagramDomain* GetDomain() const;
113
121 int GetMaxLabelWidth() const;
122
123protected:
135 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
136 CXTPChartSeriesPoint* pPoint,
137 CXTPChartElementView* pParentView) = 0;
138
151 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
152
163 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
164 CRect rcBounds) = 0;
165
167 virtual void CalculateValues();
170protected:
171 CXTPChartDiagramDomain* m_pDomain; // Pointer to the diagram domain.
172 int m_nMaxLabelWidth;
173};
174
175AFX_INLINE CXTPChartDiagramDomain* CXTPChartPieSeriesViewBase::GetDomain() const
176{
177 return m_pDomain;
178}
179
180AFX_INLINE int CXTPChartPieSeriesViewBase::GetMaxLabelWidth() const
181{
182 return m_nMaxLabelWidth;
183}
185# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
186#endif //#if !defined(__XTPCHARTPIESERIESVIEWBASE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area.
Definition XTPChartDiagram.h:159
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieSeriesViewBase
This class abstracts the view of a pie series.
Definition XTPChartPieSeriesViewBase.h:45
CXTPChartPieSeriesViewBase::CalculateLabelLayout
virtual void CalculateLabelLayout(CXTPChartDeviceContext *pDC)
Call this function to calculate the pie series label layout.
CXTPChartPieSeriesViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object.
CXTPChartPieSeriesViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a label view drawing command object.
CXTPChartPieSeriesViewBase::GetInnerBounds
CXTPChartRectF GetInnerBounds() const
Call this function to get the inner bounds of the diagram.
CXTPChartPieSeriesViewBase::CreateDiagramDomain
virtual CXTPChartDiagramDomain * CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
CXTPChartPieSeriesViewBase::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0
Use this function to create the pie series point view object.
CXTPChartPieSeriesViewBase::GetMaxLabelWidth
int GetMaxLabelWidth() const
Obtains maximum allowed label width.
Definition XTPChartPieSeriesViewBase.h:180
CXTPChartPieSeriesViewBase::~CXTPChartPieSeriesViewBase
virtual ~CXTPChartPieSeriesViewBase()
Destroys a CXTPChartPieSeriesViewBase object, handle cleanup.
CXTPChartPieSeriesViewBase::GetDomain
CXTPChartDiagramDomain * GetDomain() const
Use this function to get the pie diagram domain object associated with this object.
Definition XTPChartPieSeriesViewBase.h:175
CXTPChartPieSeriesViewBase::CXTPChartPieSeriesViewBase
CXTPChartPieSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartPieSeriesViewBase object.
CXTPChartPieSeriesViewBase::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
Call this function to calculate the pie series point layout.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPRectT< float >


CXTPEditThemeDefault Member List

This is the complete list of members for CXTPEditThemeDefault, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeDefault | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditTheme | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual


CXTPControlScrollBar Member List

This is the complete list of members for CXTPControlScrollBar, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlScrollBar() | CXTPControlScrollBar |
CXTPScrollBase() | CXTPScrollBase |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControl | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetPopuped() const | CXTPControl | virtual
GetPos() const | CXTPControlScrollBar |
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetScrollBarPaintManager() const =0 | CXTPScrollBase | pure virtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBase |
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi)=0 | CXTPScrollBase | pure virtual
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTicks() const | CXTPScrollBase |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsScrollBarEnabled() const =0 | CXTPScrollBase | pure virtual
IsSlider() const | CXTPScrollBase |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bAnimation | CXTPScrollBase | protected
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nMax | CXTPControlScrollBar | protected
m_nMin | CXTPControlScrollBar | protected
m_nPage | CXTPControlScrollBar | protected
m_nPos | CXTPControlScrollBar | protected
m_nTag | CXTPControl | protected
m_nTimerElapse | CXTPScrollBase | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_pSBTrack | CXTPScrollBase | protected
m_pTicks | CXTPScrollBase | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControl | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnScroll(UINT nSBCode, UINT nPos) | CXTPControlScrollBar | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPos(int nPos) | CXTPControlScrollBar |
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRange(int nMin, int nMax) | CXTPControlScrollBar |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTicks(double *pTicks, int nCount) | CXTPScrollBase |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlScrollBar() | CXTPControlScrollBar | virtual
~CXTPScrollBase() | CXTPScrollBase | virtual


CXTPButtonThemeOfficeXP Member List

This is the complete list of members for CXTPButtonThemeOfficeXP, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeOfficeXP() | CXTPButtonThemeOfficeXP |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOfficeXP | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeUltraFlat | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeOfficeXP | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


CXTPDatePickerThemeOffice2003 Member List

This is the complete list of members for CXTPDatePickerThemeOffice2003, including all inherited members.

CalcDayOfWeekRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcDayRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthHeaderRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcMonthRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CalcWeekNumbersRect(CDC *pDC) | CXTPDatePickerPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager |
CXTPDatePickerThemeOffice2003() | CXTPDatePickerThemeOffice2003 |
DrawBackground(CDC *pDC, CRect rcClient) | CXTPDatePickerPaintManager | virtual
DrawBorder(CDC *pDC, const CXTPDatePickerControl *pControl, CRect &rcClient, BOOL bDraw) | CXTPDatePickerPaintManager | virtual
DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight) | CXTPDatePickerThemeOffice2003 | virtual
DrawDay(CDC *pDC, CXTPDatePickerItemDay *pDay) | CXTPDatePickerPaintManager | virtual
DrawDaysOfWeek(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawMonthHeader(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
DrawScrollTriangle(CDC *pDC, CRect rcSpot, BOOL bLeftDirection, COLORREF clrColor=0, BOOL bYears=FALSE) | CXTPDatePickerPaintManager | virtual
DrawWeekNumbers(CDC *pDC, CXTPDatePickerItemMonth *pMonth) | CXTPDatePickerPaintManager | virtual
EnableTheme(BOOL bEnableTheme) | CXTPDatePickerPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetButtonFont() | CXTPDatePickerPaintManager |
GetControlBackColor() | CXTPDatePickerPaintManager | virtual
GetCursorBack() | CXTPDatePickerPaintManager | virtual
GetDayBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekBackColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextColor() | CXTPDatePickerPaintManager | virtual
GetDaysOfWeekTextFont() | CXTPDatePickerPaintManager |
GetDayTextColor() | CXTPDatePickerPaintManager | virtual
GetDayTextFont() | CXTPDatePickerPaintManager | virtual
GetDayTextFontBold() | CXTPDatePickerPaintManager | virtual
GetHeaderTextFont() | CXTPDatePickerPaintManager |
GetHighlightTodayColor() | CXTPDatePickerPaintManager | virtual
GetListControlBackColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextColor() | CXTPDatePickerPaintManager | virtual
GetListControlTextFont() | CXTPDatePickerPaintManager |
GetMonthHeaderBackColor() | CXTPDatePickerPaintManager | virtual
GetMonthHeaderTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayBackColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextColor() | CXTPDatePickerPaintManager | virtual
GetNonMonthDayTextFont() | CXTPDatePickerPaintManager |
GetPaintTheme() const | CXTPDatePickerPaintManager | protected
GetSelectedDayBackColor() | CXTPDatePickerPaintManager | virtual
GetSelectedDayTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersBackColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextColor() | CXTPDatePickerPaintManager | virtual
GetWeekNumbersTextFont() | CXTPDatePickerPaintManager |
m_bEnableTheme | CXTPDatePickerPaintManager | protected
m_clr3DFace | CXTPDatePickerPaintManager | protected
m_clr3DLight | CXTPDatePickerPaintManager | protected
m_clr3DShadow | CXTPDatePickerPaintManager | protected
m_clr3DText | CXTPDatePickerPaintManager | protected
m_clrButtonFace | CXTPDatePickerPaintManager |
m_clrButtonText | CXTPDatePickerPaintManager |
m_clrControlBack | CXTPDatePickerPaintManager |
m_clrDayBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekBack | CXTPDatePickerPaintManager |
m_clrDaysOfWeekText | CXTPDatePickerPaintManager |
m_clrDayText | CXTPDatePickerPaintManager |
m_clrHighlightToday | CXTPDatePickerPaintManager |
m_clrListControlBack | CXTPDatePickerPaintManager |
m_clrListControlText | CXTPDatePickerPaintManager |
m_clrMonthBorder | CXTPDatePickerPaintManager |
m_clrMonthHeaderBack | CXTPDatePickerPaintManager |
m_clrMonthHeaderButton | CXTPDatePickerPaintManager |
m_clrMonthHeaderText | CXTPDatePickerPaintManager |
m_clrNonMonthDayBack | CXTPDatePickerPaintManager |
m_clrNonMonthDayText | CXTPDatePickerPaintManager |
m_clrSelectedDayBack | CXTPDatePickerPaintManager |
m_clrSelectedDayText | CXTPDatePickerPaintManager |
m_clrStaticBorder | CXTPDatePickerPaintManager | protected
m_clrWeekNumbersBack | CXTPDatePickerPaintManager |
m_clrWeekNumbersText | CXTPDatePickerPaintManager |
m_hCursorBack | CXTPDatePickerPaintManager | protected
m_nPaintTheme | CXTPDatePickerPaintManager | protected
m_szDayMargin | CXTPDatePickerPaintManager |
m_themeButton | CXTPDatePickerPaintManager | protected
m_xtpFontButton | CXTPDatePickerPaintManager | protected
m_xtpFontDay | CXTPDatePickerPaintManager | protected
m_xtpFontDayBold | CXTPDatePickerPaintManager | protected
m_xtpFontDaysOfWeek | CXTPDatePickerPaintManager | protected
m_xtpFontHeader | CXTPDatePickerPaintManager | protected
m_xtpFontListControl | CXTPDatePickerPaintManager | protected
m_xtpFontNonMonthDay | CXTPDatePickerPaintManager | protected
m_xtpFontWeekNumbers | CXTPDatePickerPaintManager | protected
RefreshMetrics() | CXTPDatePickerThemeOffice2003 | virtual
SetButtonFont(CFont *fontButton) | CXTPDatePickerPaintManager |
SetButtonFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
SetFontIndirect(LOGFONT *lFont) | CXTPDatePickerPaintManager |
Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clrColor=0) | CXTPDatePickerPaintManager | protectedvirtual
~CXTPDatePickerPaintManager() | CXTPDatePickerPaintManager | virtual
~CXTPDatePickerThemeOffice2003() | CXTPDatePickerThemeOffice2003 | virtual


CXTPRibbonThemeVisualStudio2022 Member List

This is the complete list of members for CXTPRibbonThemeVisualStudio2022, including all inherited members.

CreateTabPaintManager() | CXTPRibbonPaintManager | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPRibbonMarkupTheme(CXTPPaintManager *pPaintManager) | CXTPRibbonMarkupTheme |
CXTPRibbonOffice2013Theme(CXTPPaintManager *pPaintManager) | CXTPRibbonOffice2013Theme |
CXTPRibbonPaintManager(CXTPPaintManager *pPaintManager) | CXTPRibbonPaintManager |
CXTPRibbonThemeVisualStudio2022(CXTPPaintManager *pPaintManager) | CXTPRibbonThemeVisualStudio2022 |
DrawBackImage(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | protectedvirtual
DrawControlGroupOption(CDC *pDC, CXTPControl *pControlGroupOption, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawControlGroupPopup(CDC *pDC, CXTPControlPopup *pControlGroupPopup, BOOL bDraw) | CXTPRibbonMarkupTheme | virtual
DrawDwmCaptionText(CDC *pDC, CRect rcCaptionText, CString strText, CWnd *pSite, BOOL bActive) | CXTPRibbonPaintManager | protected
DrawGroup(CDC *pDC, CXTPRibbonGroup *pGroup) | CXTPRibbonMarkupTheme | virtual
DrawQuickAccessControl(CDC *pDC, CXTPRibbonBar *pRibbon, CXTPControl *pControl) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonApplicationIcon(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rc, HICON hIcon) | CXTPRibbonPaintManager | protected
DrawRibbonFrameCaption(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameCaptionBar(CDC *pDC, CXTPRibbonBar *pRibbonBar, BOOL bActive) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonFramePart(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonPaintManager | virtual
DrawRibbonFrameSystemButton(CDC *pDC, CXTPRibbonControlSystemButton *pControl, CRect rc) | CXTPRibbonOffice2013Theme | virtual
DrawRibbonGroupControlEntry(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
DrawRibbonGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pRibbonGroup) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessControls(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonMarkupTheme | virtual
DrawRibbonQuickAccessMoreButton(CDC *pDC, CXTPControlPopup *pControl) | CXTPRibbonMarkupTheme | virtual
DrawRibbonScrollButton(CDC *pDC, CXTPControl *pControl, BOOL bScrollLeft) | CXTPRibbonMarkupTheme | virtual
DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem) | CXTPRibbonOffice2013Theme | virtual
DrawSystemPopupBarButton(CDC *pDC, CXTPControl *pButton) | CXTPRibbonMarkupTheme | virtual
FillGroupPopupToolBar(CDC *pDC, CXTPRibbonGroup *pGroup, CXTPCommandBar *pCommandBar) | CXTPRibbonMarkupTheme | virtual
FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups) | CXTPRibbonMarkupTheme | virtual
FillMorePopupToolBarEntry(CDC *pDC, CXTPCommandBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillRibbonBar(CDC *pDC, CXTPRibbonBar *pRibbonBar) | CXTPRibbonOffice2013Theme | virtual
FillRibbonTabControl(CDC *pDC, CXTPRibbonBar *pRibbonBar, CRect rcControl) | CXTPRibbonMarkupTheme | virtual
FillSystemPopupBarEntry(CDC *pDC, CXTPPopupBar *pBar) | CXTPRibbonMarkupTheme | virtual
FillTabPopupToolBar(CDC *pDC, CXTPPopupToolBar *pPopupToolBar) | CXTPRibbonPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackImageName() | CXTPRibbonOffice2013Theme | protectedvirtual
GetControlGroupOptionSize() const | CXTPRibbonMarkupTheme | virtual
GetEditHeight() const | CXTPRibbonPaintManager |
GetFontHeight() const | CXTPRibbonPaintManager |
GetFramePaintManager() const | CXTPRibbonPaintManager |
GetGroupCaptionHeight() const | CXTPRibbonPaintManager |
GetImages() const | CXTPRibbonPaintManager |
GetRibbonCaptionHeight(const CXTPRibbonBar *pRibbonBar) const | CXTPRibbonOffice2013Theme | virtual
GetTabPaintManager() const | CXTPRibbonPaintManager |
LoadImage(LPCTSTR lpszFileName) | CXTPRibbonPaintManager |
LoadParts(BOOL bReload=FALSE) | CXTPRibbonOffice2013Theme | protectedvirtual
CXTPRibbonMarkupTheme::LoadParts(HZIP hZip, CXTPMarkupContext *pMarkupContext=NULL) | CXTPRibbonMarkupTheme |
m_bFlatFrame | CXTPRibbonPaintManager |
m_bHotTrackingGroups | CXTPRibbonPaintManager |
m_clrBackstageSysButtonBack2013Highlighted | CXTPRibbonMarkupTheme | protected
m_clrBackstageSysButtonBack2013Normal | CXTPRibbonMarkupTheme | protected
m_clrFileButtonText | CXTPRibbonPaintManager | protected
m_clrHeader | CXTPRibbonOffice2013Theme | protected
m_clrMinimizedFrameEdgeHighLight | CXTPRibbonPaintManager | protected
m_clrMinimizedFrameEdgeShadow | CXTPRibbonPaintManager | protected
m_clrRecentFileListEdgeHighLight | CXTPRibbonPaintManager |
m_clrRecentFileListEdgeShadow | CXTPRibbonPaintManager |
m_clrRibbonBorder | CXTPRibbonPaintManager | protected
m_clrRibbonFace | CXTPRibbonPaintManager | protected
m_clrRibbonGroupCaptionText | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFace | CXTPRibbonPaintManager | protected
m_clrRibbonInactiveFaceState | CXTPRibbonOffice2013Theme | protected
m_clrRibbonTabDelimeter | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageLeft | CXTPRibbonOffice2013Theme | protected
m_clrTabBackackstageRight | CXTPRibbonOffice2013Theme | protected
m_clrTabBackInactiveState | CXTPRibbonOffice2013Theme | protected
m_fontGroupCaption | CXTPRibbonPaintManager |
m_nGroupCaptionHeight | CXTPRibbonPaintManager |
m_nGroupSpacing | CXTPRibbonPaintManager |
m_nTabsHeight | CXTPRibbonPaintManager |
m_pMarkupContext | CXTPRibbonMarkupTheme | protected
m_pPaintManager | CXTPRibbonPaintManager | protected
m_pTabPaintManager | CXTPRibbonPaintManager | protected
m_rcFileButtonMargin | CXTPRibbonPaintManager | protected
m_strHighlightedPrefix | CXTPRibbonMarkupTheme | protected
m_strNormalPrefix | CXTPRibbonMarkupTheme | protected
RefreshMetrics() | CXTPRibbonOffice2013Theme | virtual
RenderMarkup(CDC *pDC, CRect rc, LPCTSTR lpszText) | CXTPRibbonMarkupTheme |
RenderMarkup(CDC *pDC, CRect rc, XTPRibbonThemePart part) | CXTPRibbonMarkupTheme |
SetBackImage(int nImage) | CXTPRibbonOffice2013Theme | virtual
SetFontHeight(int nFontHeight) | CXTPRibbonPaintManager |
~CXTPRibbonMarkupTheme() | CXTPRibbonMarkupTheme | virtual
~CXTPRibbonOffice2013Theme() | CXTPRibbonOffice2013Theme | virtual
~CXTPRibbonPaintManager() | CXTPRibbonPaintManager | virtual
~CXTPRibbonThemeVisualStudio2022() | CXTPRibbonThemeVisualStudio2022 | virtual


CXTPShellListCtrl Member List

This is the complete list of members for CXTPShellListCtrl, including all inherited members.

AssociateTree(CWnd *pWnd) | CXTPShellListCtrl | virtual
CXTPShellListCtrl() | CXTPShellListCtrl |
m_bInitControl | CXTPShellListCtrl | protected
m_pTreeCtrl | CXTPShellListCtrl | protected
~CXTPShellListCtrl() | CXTPShellListCtrl | virtual


CXTPSplitterWndThemeOffice2013 Member List

This is the complete list of members for CXTPSplitterWndThemeOffice2013, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPSplitterWndTheme() | CXTPSplitterWndTheme |
CXTPSplitterWndThemeOffice2013() | CXTPSplitterWndThemeOffice2013 |
CXTPSplitterWndThemeOfficeXP() | CXTPSplitterWndThemeOfficeXP |
DrawSplitter(CDC *pDC, CXTPSplitterWnd *pSplitter, int nType, const CRect &rectArg) | CXTPSplitterWndTheme | virtual
EnableTabColors(BOOL bEnable=TRUE) | CXTPSplitterWndTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetThemeStyle() const | CXTPControlTheme |
GetTrackBrush() | CXTPSplitterWndThemeOfficeXP | virtual
m_bTabColors | CXTPSplitterWndTheme |
m_crBack | CXTPSplitterWndTheme |
m_crBoxBack | CXTPSplitterWndTheme |
m_crInnerBorder | CXTPSplitterWndTheme |
m_crInnerBoxBorder | CXTPSplitterWndTheme |
m_crOuterBorder | CXTPSplitterWndTheme |
m_crOuterBoxBorder | CXTPSplitterWndTheme |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics() | CXTPSplitterWndThemeOffice2013 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static


CXTPRibbonControlTab Member List

This is the complete list of members for CXTPRibbonControlTab, including all inherited members.

AddItem(int nItem, CXTPTabManagerItem *pItem=NULL) | CXTPTabManager | protected
AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPControlPopup | virtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlPopup | protectedvirtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPRibbonControlTab | protectedvirtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlPopup() | CXTPControlPopup |
CXTPRibbonControlTab() | CXTPRibbonControlTab |
CXTPTabManager() | CXTPTabManager |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DeleteAllItems() | CXTPTabManager |
DeleteItem(int nItem) | CXTPTabManager |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPRibbonControlTab | protectedvirtual
Draw(CDC *pDC) | CXTPRibbonControlTab | protectedvirtual
DrawIcon(CDC *pDC, CPoint pt, CXTPTabManagerItem *pItem, BOOL bDraw, CSize &szIcon) const | CXTPRibbonControlTab | protectedvirtual
DrawParentBackground(CDC *pDC, CRect rc) | CXTPTabManager | virtual
EnableMarkup(BOOL bEnable=TRUE) | CXTPTabManager |
EnableTabThemeTexture(HWND hWnd, BOOL bEnable=TRUE) | CXTPTabManager |
EnsureVisible(CXTPTabManagerItem *pItem) | CXTPTabManager |
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FindNavigateButton(UINT nID) const | CXTPTabManager |
FindNextFocusable(int nIndex, int nDirection) const | CXTPTabManager |
FindTab(int nId) const | CXTPRibbonControlTab |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetAppearance() const | CXTPTabManager |
GetAppearanceSet() const | CXTPTabManager |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControlPopup | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetClientRect() const | CXTPTabManager |
GetCloseSubMenuOnClick() const | CXTPControl |
GetColor() const | CXTPTabManager |
GetColorSet() const | CXTPTabManager |
GetCommandBar() const | CXTPControlPopup | virtual
GetControlRect() const | CXTPTabManager |
GetControls() const | CXTPControl |
GetCurSel() const | CXTPTabManager |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeaderOffset() const | CXTPTabManager |
GetHeaderRect() const | CXTPTabManager |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetItem(int nIndex) const | CXTPTabManager |
GetItemCaption(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemColor(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemCount() const | CXTPTabManager |
GetItemIcon(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetItemMetrics(CSize *szNormal, CSize *szMin=NULL, CSize *szMax=NULL) const | CXTPTabManager | virtual
GetItemsLength() const | CXTPTabManager | virtual
GetItemTooltip(const CXTPTabManagerItem *pItem) const | CXTPTabManager | virtual
GetKeyboardTip() const | CXTPControl |
GetLayout() const | CXTPTabManager |
GetMarkupContext() const | CXTPTabManager | virtual
GetNavigateButton(int nIndex) const | CXTPTabManager |
GetNavigateButtonCount() const | CXTPTabManager |
GetNavigateButtons() | CXTPTabManager |
GetPaintManager() const | CXTPRibbonControlTab | virtual
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControlPopup | virtual
GetPosition() const | CXTPTabManager | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRectLength(CRect rc) const | CXTPTabManager |
GetRibbonBar() const | CXTPRibbonControlTab |
GetRibbonGroup() const | CXTPControl |
GetRowCount() const | CXTPTabManager |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetSelectedItem() const | CXTPTabManager |
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControl | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTab(int nIndex) const | CXTPRibbonControlTab |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
HeaderHasFocus() const | CXTPRibbonControlTab | protectedvirtual
HitTest(CPoint point) const | CXTPTabManager |
HitTestNavigateButton(CPoint point, BOOL bHeaderOnly, int *pnIndex=NULL) const | CXTPTabManager |
IsActive() const | CXTPTabManager |
IsAllowReorder() const | CXTPTabManager | virtual
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsDrawStaticFrame() const | CXTPTabManager | virtual
IsFocusable() const | CXTPRibbonControlTab | protectedvirtual
IsFocused() const | CXTPRibbonControlTab | protectedvirtual
IsHorizontalPosition() const | CXTPTabManager |
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsMouseLocked() const | CXTPRibbonControlTab | protectedvirtual
IsNavigateButtonAutomaticVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsNavigateButtonVisible(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
IsOnQuickAccess() const | CXTPControl |
IsPopupBarTracking() const | CXTPRibbonControlTab | protected
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_arrItems | CXTPTabManager | protected
m_arrNavigateButtons | CXTPTabManager | protected
m_bActive | CXTPTabManager | protected
m_bAllowReorder | CXTPTabManager | protected
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseItemButton | CXTPTabManager | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bFocused | CXTPRibbonControlTab | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeaderOffset | CXTPTabManager | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nScrollDelta | CXTPTabManager | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pHighlighted | CXTPTabManager | protected
m_pHighlightedNavigateButton | CXTPTabManager | protected
m_pMarkupContext | CXTPTabManager | protected
m_pParent | CXTPControl | protected
m_pPressed | CXTPTabManager | protected
m_pRibbonGroup | CXTPControl | protected
m_pRowIndexer | CXTPTabManager | protected
m_pSelected | CXTPTabManager | protected
CXTPControlPopup::m_rcControl | CXTPControl | protected
CXTPTabManager::m_rcControl | CXTPTabManager | protected
m_rcHeaderRect | CXTPTabManager | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
MoveItem(CXTPTabManagerItem *pItem, int nIndex) | CXTPTabManager |
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnBeforeItemClick(CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlPopup | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPRibbonControlTab | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnItemClick(CXTPTabManagerItem *pItem) | CXTPRibbonControlTab | protectedvirtual
OnItemHandleChanged(CXTPTabManagerItem *pItem, HWND hwndOld, HWND hwndNew) | CXTPTabManager | protectedvirtual
OnItemOrderChanged(CXTPTabManagerItem *pItem, int nOldIndex, int nNewIndex) | CXTPTabManager | protectedvirtual
OnItemsChanged() | CXTPTabManager | virtual
OnLButtonDblClk(CPoint point) | CXTPControlPopup | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlPopup | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlPopup | protectedvirtual
OnNavigateButtonClick(CXTPTabManagerNavigateButton *pButton) | CXTPTabManager | protectedvirtual
OnNavigateButtonClick(UINT nID) | CXTPTabManager | protectedvirtual
OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnScrollHeader(BOOL bRight) | CXTPTabManager | virtual
OnSetPopup(BOOL bPopup) | CXTPControlPopup | protectedvirtual
OnSetSelected(int bSelected) | CXTPRibbonControlTab | protectedvirtual
OnSwitchItem(CXTPTabManagerItem *pItem1, CXTPTabManagerItem *pItem2) | CXTPTabManager | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPRibbonControlTab | protectedvirtual
PerformClick(HWND hWnd, CPoint pt, BOOL bNoItemClick=FALSE) | CXTPTabManager |
PerformKeyDown(HWND hWnd, UINT nChar) | CXTPTabManager | virtual
PerformMouseMove(HWND hWnd, CPoint pt) | CXTPTabManager |
PerformToolHitTest(HWND hWnd, CPoint point, TOOLINFO *pTI) const | CXTPTabManager | virtual
RedrawControl(LPCRECT lpRect, BOOL bAnimate) | CXTPRibbonControlTab | protectedvirtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
ReOrder(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protectedvirtual
Reposition() | CXTPRibbonControlTab | protectedvirtual
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetActive(BOOL bActive) | CXTPTabManager |
SetAllowReorder(BOOL bAllowReorder) | CXTPTabManager | virtual
SetAppearance(XTPTabAppearanceStyle tabAppearance) | CXTPTabManager |
SetAppearanceSet(CXTPTabPaintManagerTheme *pAppearanceSet) | CXTPTabManager |
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetColor(XTPTabColorStyle tabColor) | CXTPTabManager |
SetColorSet(CXTPTabPaintManagerColorSet *pColorSet) | CXTPTabManager |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetCurSel(int nIndex) | CXTPTabManager |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPRibbonControlTab | protectedvirtual
SetFocusedItem(CXTPTabManagerItem *pItem) | CXTPTabManager | virtual
SetHeaderOffset(int nOffset) | CXTPTabManager |
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetItemMetrics(CSize szNormal, CSize szMin=CSize(0, 0), CSize szMax=CSize(0, 0)) | CXTPTabManager |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetLayoutStyle(XTPTabLayoutStyle tabLayout) | CXTPTabManager |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetPaintManager(CXTPTabPaintManager *pPaintManager) | CXTPTabManager | virtual
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPosition(XTPTabPosition tabPosition) | CXTPTabManager |
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetSelectedItem(CXTPTabManagerItem *pItem) | CXTPRibbonControlTab | virtual
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
ShowCloseItemButton(XTPTabNavigateButtonFlags bCloseItemButton=xtpTabNavigateButtonAlways) | CXTPTabManager |
ShowIcons(BOOL bShowIcons) | CXTPTabManager |
TrackClick(HWND hWnd, CPoint pt, CXTPTabManagerItem *pItem) | CXTPTabManager | protected
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlPopup() | CXTPControlPopup | virtual
~CXTPRibbonControlTab() | CXTPRibbonControlTab | virtual
~CXTPTabManager() | CXTPTabManager | virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual


Toolkit Pro: XTPRibbonCustomizePage.h Source File

  • Source
  • Ribbon
  • Customize
XTPRibbonCustomizePage.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONCUSTOMIZEPAGE_H__)
24# define __XTPRIBBONCUSTOMIZEPAGE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCustomizeSheet;
34class CXTPCommandBars;
35class CXTPRibbonBar;
36class CXTPCoreTreeItem;
37class CXTPCoreTreeItems;
38
44class _XTP_EXT_CLASS CXTPRibbonCustomizePage : public CXTPPropertyPage
45{
46 // Construction
47public:
53 CXTPRibbonCustomizePage(CXTPCustomizeSheet* pSheet);
59 CXTPRibbonCustomizePage(CXTPCommandBars* pCommandBars);
60
66 virtual ~CXTPRibbonCustomizePage();
67
68public:
75 CXTPRibbonBar* GetRibbonBar();
76
77public:
86 BOOL AddCategories(UINT nIDResource, BOOL bListSubItems = FALSE);
87
95 BOOL AddCategories(CXTPControls* pControls);
96
106 BOOL AddCategory(LPCTSTR strCategory, CMenu* pMenu, BOOL bListSubItems = FALSE);
107
116 CXTPControls* InsertCategory(LPCTSTR strCategory, int nIndex = -1);
117
125 CXTPControls* GetControls(LPCTSTR strCategory);
126
127protected:
132 void RefreshRibbonList();
133
134 // Implementation
135protected:
137 DECLARE_MESSAGE_MAP()
139 //{{AFX_VIRTUAL(CXTPRibbonCustomizePage)
140protected:
141 virtual void DoDataExchange(CDataExchange* pDX);
142 //}}AFX_VIRTUAL
143
144 //{{AFX_MSG(CXTPRibbonCustomizePage)
145 virtual BOOL OnInitDialog();
146 afx_msg void OnCategoriesSelectionChanged();
147 afx_msg void OnButtonAdd();
148 afx_msg void OnButtonRemove();
149 afx_msg void OnButtonReset();
150 afx_msg void OnCommandsSelectionChanged();
151 afx_msg void OnRibbonSelectionChanged();
152 afx_msg void OnRibbonTreeCheckChanged(NMHDR* /*pNMHDR*/, LRESULT* /*pResult*/);
153 afx_msg void OnRibbonSelChanged(NMHDR* pNMHDR, LRESULT* pResult);
154 afx_msg void OnCommandsSelChanged(NMHDR* /*pNMHDR*/, LRESULT* /*pResult*/);
155 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
156
157 afx_msg void OnButtonNewTab();
158 afx_msg void OnButtonNewGroup();
159 afx_msg void OnButtonRename();
160 afx_msg void OnImportDropDown();
161
162 afx_msg void OnButtonUp();
163 afx_msg void OnButtonDown();
164
165 //}}AFX_MSG
166
167private:
168 XTP_COMMANDBARS_CATEGORYINFO* FindCategory(LPCTSTR strCategory) const;
169 XTP_COMMANDBARS_CATEGORYINFO* GetCategoryInfo(int nIndex);
170
171 CXTPCoreTreeItem* FindItem(CCmdTarget* pItemData, CXTPCoreTreeItems* pItems = NULL);
172
173public:
174 CXTPComboBox m_cmbCategories;
175 CXTPComboBox m_cmbTabGroup;
176 CXTPRibbonCustomizeTreeCtrl m_treeRibbon;
177 CXTPRibbonCustomizeTreeCtrl m_treeCommands;
179protected:
180 CXTPCustomizeSheet* m_pSheet;
181 CXTPCommandBars* m_pCommandBars;
182 CXTPCommandBarsCategoryArray m_arrCategories;
183 friend class CXTPRibbonCustomizeTreeCtrl;
184
185 CXTPButton m_btnAdd;
186 CXTPButton m_btnRemove;
187
188 CXTPButton m_btnNewTab;
189 CXTPButton m_btnNewGroup;
190 CXTPButton m_btnRename;
191 CXTPButton m_btnReset;
192
193 CXTPButton m_btnImport;
194
195 CXTPButton m_btnUp;
196 CXTPButton m_btnDown;
197
198# ifdef _XTP_INCLUDE_CONTROLS
199 COLORREF m_clrText;
200# endif
201
202# ifdef _XTP_INCLUDE_MARKUP
203 CXTPMarkupStatic& m_wndTitleIcon;
204 CXTPMarkupStatic& m_wndTitle;
205# else
206 CStatic& m_wndTitleIcon;
207 CStatic& m_wndTitle;
208# endif
209};
210
211# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
213#endif // !defined(__XTPRIBBONCUSTOMIZEPAGE_H__)
CXTPCommandBarsCategoryArray
CArray< XTP_COMMANDBARS_CATEGORYINFO *, XTP_COMMANDBARS_CATEGORYINFO * > CXTPCommandBarsCategoryArray
This array is used by the CXTPCustomizeCommandsPage class for maintaining a list of XTP_COMMANDBARS_C...
Definition XTPCustomizePageCommands.h:78
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControls
CXTPControls is a CXTPCmdTarget derived class.
Definition XTPControls.h:47
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47
CXTPPropertyPage
CXTPPropertyPage is a CPropertyPage derived class.
Definition XTPPropertyPage.h:43
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonCustomizePage
CXTPRibbonCustomizePage is a CPropertyPage derived class.
Definition XTPRibbonCustomizePage.h:45
CXTPRibbonCustomizePage::CXTPRibbonCustomizePage
CXTPRibbonCustomizePage(CXTPCustomizeSheet *pSheet)
Constructs a CXTPRibbonCustomizePage object.
CXTPRibbonCustomizePage::GetControls
CXTPControls * GetControls(LPCTSTR strCategory)
Retrieves the control list for a specified category.
CXTPRibbonCustomizePage::AddCategories
BOOL AddCategories(CXTPControls *pControls)
Adds a categories branch from Controls.
CXTPRibbonCustomizePage::AddCategories
BOOL AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE)
Adds a categories branch from a menu resource.
CXTPRibbonCustomizePage::~CXTPRibbonCustomizePage
virtual ~CXTPRibbonCustomizePage()
Destroys a CXTPCustomizeCommandsPage object, handles cleanup and deallocation.
CXTPRibbonCustomizePage::InsertCategory
CXTPControls * InsertCategory(LPCTSTR strCategory, int nIndex=-1)
Adds a new empty category at a specified index.
CXTPRibbonCustomizePage::CXTPRibbonCustomizePage
CXTPRibbonCustomizePage(CXTPCommandBars *pCommandBars)
Constructs a CXTPRibbonCustomizePage object.
CXTPRibbonCustomizePage::GetRibbonBar
CXTPRibbonBar * GetRibbonBar()
Gets the ribbon bar to customize.
CXTPRibbonCustomizePage::AddCategory
BOOL AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE)
Adds a new category from a CMenu object.
CXTPRibbonCustomizePage::RefreshRibbonList
void RefreshRibbonList()
Refills the list of Quick Access controls.
XTP_COMMANDBARS_CATEGORYINFO
This structure stores categories for CXTPCustomizeCommandsPage and CXTPCustomizeKeyboardPage option p...
Definition XTPCustomizePageCommands.h:46


Toolkit Pro: XTPScrollBarThemeResource.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMERESOURCE_H__)
24# define __XTPSCROLLBARTHEMERESOURCE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPScrollBarThemeResource : public CXTPScrollBarPaintManager
40{
41protected:
48 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
49
57 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
58
66 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
67
75 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
76
84 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
85
93 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
94
102 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
103
111 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
112
120 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
121
129 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
130
138 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
139
146 virtual void DrawGripper(CDC* pDC, CXTPScrollBase* pScroll);
147
155 CXTPResourceImage* LoadImage(LPCTSTR lpszImageFile);
156
157private:
158 struct DRAWING_STATE
159 {
160 BOOL bLight;
161 BOOL nPressedHt;
162 BOOL nHotHt;
163 BOOL bEnabled;
164 int nBtnTrackSize;
165 int nBtnTrackPos;
166 CRect rcArrowGripperSrc;
167 CRect rcScroll;
168 CRect rcArrowUp;
169 CRect rcArrowDown;
170 CRect rcArrowLeft;
171 CRect rcArrowRight;
172
173 CXTPResourceImage* pImageArrowGlyphs;
174 CXTPResourceImage* pImageBackground;
175 };
176
177 DRAWING_STATE m_State;
178};
179
180# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
182#endif /*__XTPSCROLLBARTHEMERESOURCE_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBarThemeResource
Scrollbar paint manager used to draw scrollbars from the currently loaded resource image data.
Definition XTPScrollBarThemeResource.h:40
CXTPScrollBarThemeResource::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
CXTPScrollBarThemeResource::LoadImage
CXTPResourceImage * LoadImage(LPCTSTR lpszImageFile)
Loads image resource by its name.
CXTPScrollBarThemeResource::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarThemeResource::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
CXTPScrollBarThemeResource::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
CXTPScrollBarThemeResource::DrawGripper
virtual void DrawGripper(CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPScrollBarThemeResource::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarThemeResource::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
CXTPScrollBarThemeResource::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
CXTPScrollBarThemeResource::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
CXTPScrollBarThemeResource::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
CXTPScrollBarThemeResource::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
CXTPScrollBarThemeResource::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


XTP_NM_GRIDINPLACEBUTTON Member List

This is the complete list of members for XTP_NM_GRIDINPLACEBUTTON, including all inherited members.

hdr | XTP_NM_GRIDRECORDITEM
nHyperlink | XTP_NM_GRIDRECORDITEM
pButton | XTP_NM_GRIDINPLACEBUTTON
pColumn | XTP_NM_GRIDRECORDITEM
pItem | XTP_NM_GRIDRECORDITEM
pRow | XTP_NM_GRIDRECORDITEM
pt | XTP_NM_GRIDRECORDITEM


CXTPButtonThemeVisualStudio2012 Member List

This is the complete list of members for CXTPButtonThemeVisualStudio2012, including all inherited members.

CXTPButtonTheme() | CXTPButtonTheme |
CXTPButtonThemeUltraFlat() | CXTPButtonThemeUltraFlat |
CXTPButtonThemeVisualStudio2012(BOOL bLight) | CXTPButtonThemeVisualStudio2012 |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
DrawButton(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawButtonBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeVisualStudio2012 | virtual
DrawButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme |
DrawButtonVisualStyleBackground(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawCheckBoxMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeVisualStudio2012 | virtual
DrawFocusRect(CDC *pDC, CXTPButton *pButton) | CXTPButtonTheme | virtual
DrawGroupBox(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonDropDown(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonIcon(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawPushButtonText(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeOffice2013 | virtual
DrawRadioButtonMark(CDC *pDC, CXTPButton *pButton) | CXTPButtonThemeVisualStudio2012 | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTextColor(CXTPButton *pButton) | CXTPButtonThemeVisualStudio2012 | virtual
GetThemeStyle() const | CXTPControlTheme |
m_bLight | CXTPButtonThemeVisualStudio2012 | protected
m_crBack | CXTPButtonTheme |
m_crBackChecked | CXTPButtonThemeUltraFlat |
m_crBackDisabled | CXTPButtonThemeOffice2013 | protected
m_crBackHilite | CXTPButtonThemeUltraFlat |
m_crBackPushed | CXTPButtonThemeUltraFlat |
m_crBorder | CXTPButtonThemeOffice2013 | protected
m_crBorder3DHilite | CXTPButtonTheme |
m_crBorder3DShadow | CXTPButtonTheme |
m_crBorderDefault | CXTPButtonThemeOffice2013 | protected
m_crBorderDisabled | CXTPButtonThemeOffice2013 | protected
m_crBorderHilite | CXTPButtonTheme |
m_crBorderPushed | CXTPButtonThemeUltraFlat |
m_crBorderShadow | CXTPButtonTheme |
m_crCheckMark | CXTPButtonThemeUltraFlat |
m_crMark | CXTPButtonThemeOffice2013 | protected
m_crMarkDisabled | CXTPButtonThemeOffice2013 | protected
m_crMarkHilite | CXTPButtonThemeOffice2013 | protected
m_crMarkPushed | CXTPButtonThemeOffice2013 | protected
m_crText | CXTPButtonTheme |
m_crTextCheck | CXTPButtonTheme |
m_crTextDisabled | CXTPButtonTheme |
m_crTextHilite | CXTPButtonThemeUltraFlat |
m_crTextPushed | CXTPButtonThemeUltraFlat |
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPButton *pButton) | CXTPButtonThemeVisualStudio2012 | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPButtonTheme() | CXTPButtonTheme | virtual


CXTPCalendarCaptionBarOfficeXPTheme Member List

This is the complete list of members for CXTPCalendarCaptionBarOfficeXPTheme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual


Toolkit Pro: XTPApplication.h Source File

  • Source
  • Common
XTPApplication.h
Go to the documentation of this file.
1
23#if !defined(__XTPAPPLICATION_H__)
24# define __XTPAPPLICATION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPApplication;
34class CXTPComInitializer;
35
36namespace Gdiplus
37{
38struct GdiplusStartupOutput;
39};
40
45enum XTPApplicationAmbientProperty
46{
53 xtpApplicationAccentColor,
54
63 xtpApplicationStateColor,
64
70 xtpApplicationUseSystemAccentColor,
71
73 xtpApplicationPropertyCount
75};
76
81struct IXTPApplicationEvents
82{
87 virtual ~IXTPApplicationEvents()
88 {
89 }
90
96 virtual void OnBeforeApplicationShutdown(CXTPApplication* pApplication)
97 {
98 UNREFERENCED_PARAMETER(pApplication);
99 }
100
107 virtual void OnApplicationShutdown(CXTPApplication* pApplication)
108 {
109 UNREFERENCED_PARAMETER(pApplication);
110 }
111
117 virtual void OnAfterApplicationShutdown(CXTPApplication* pApplication)
118 {
119 UNREFERENCED_PARAMETER(pApplication);
120 }
121
130 virtual void OnAmbientPropertyChanged(CXTPApplication* pApplication,
131 XTPApplicationAmbientProperty nProperty)
132 {
133 UNREFERENCED_PARAMETER(pApplication);
134 UNREFERENCED_PARAMETER(nProperty);
135 }
136};
137
147class _XTP_EXT_CLASS CXTPApplication
148 : public CObject
149 , public CXTPObservable<CXTPApplication, IXTPApplicationEvents>
150 , public CXTPSynchronized
151{
152 friend class CXTPSingleton<CXTPApplication>;
153
154 friend _XTP_EXT_CLASS CXTPApplication* AFX_CDECL XTPGetApplication();
155 friend _XTP_EXT_CLASS BOOL AFX_CDECL XTPInitialize(int xtpComInit);
156 friend _XTP_EXT_CLASS void AFX_CDECL XTPShutdown();
157
158 DECLARE_DYNAMIC(CXTPApplication);
159
160public:
170 BOOL IsReady() const;
171
181 AFX_MODULE_STATE* GetModuleState();
182
198 void SetAmbientProperty(XTPApplicationAmbientProperty nProperty, COleVariant vtValue);
199
216 const COleVariant& GetAmbientProperty(XTPApplicationAmbientProperty nProperty) const;
217
225 void TriggerAmbientPropertyUpdate(XTPApplicationAmbientProperty nProperty);
226
233 int GetComInitFlags() const;
234
241 DWORD GetAppThreadId() const;
242
244 ~CXTPApplication();
246private:
247 CXTPApplication();
248 static CXTPApplication& AFX_CDECL GetInstance();
249
250 BOOL Initialize(int xtpComInit);
251 void Shutdown();
252 void InitAmbientProperties();
253
254 AFX_MODULE_STATE* m_pModuleState;
255 BOOL m_bInitialized;
256 CXTPComInitializer* m_pComInit;
257 DWORD m_dwThreadId;
258 BOOL m_bShutdown;
259 HMODULE m_hGdiPlusModule;
260 ULONG_PTR m_nGdiplusToken;
261 Gdiplus::GdiplusStartupOutput* m_pGdiplusStartupOutput;
262 COleVariant m_arAmbientProperties[xtpApplicationPropertyCount];
263};
265AFX_INLINE BOOL CXTPApplication::IsReady() const
266{
267 return m_bInitialized && !m_bShutdown;
268}
269
270AFX_INLINE DWORD CXTPApplication::GetAppThreadId() const
271{
272 return m_dwThreadId;
273}
291_XTP_EXT_CLASS BOOL AFX_CDECL XTPInitialize(int xtpComInit = xtpComInitAppDefault);
292
302_XTP_EXT_CLASS CXTPApplication* AFX_CDECL XTPGetApplication();
303
317_XTP_EXT_CLASS void AFX_CDECL XTPShutdown();
318
319# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
321#endif // !defined(__XTPAPPLICATION_H__)
XTPShutdown
_XTP_EXT_CLASS void AFX_CDECL XTPShutdown()
Performs XTP application shutting down with releasing all internal XTP pointers and resources but not...
XTPInitialize
_XTP_EXT_CLASS BOOL AFX_CDECL XTPInitialize(int xtpComInit=xtpComInitAppDefault)
Initializes XTP framework.
XTPGetApplication
_XTP_EXT_CLASS CXTPApplication *AFX_CDECL XTPGetApplication()
Obtains the only XTP application instance pointer.
XTPApplicationAmbientProperty
XTPApplicationAmbientProperty
Global ambient property identifiers.
Definition XTPApplication.h:46
xtpApplicationUseSystemAccentColor
@ xtpApplicationUseSystemAccentColor
A long boolean value that enables use of the current system accent/colorization color used instead ap...
Definition XTPApplication.h:70
xtpApplicationAccentColor
@ xtpApplicationAccentColor
Ambient accent color value.
Definition XTPApplication.h:53
xtpApplicationStateColor
@ xtpApplicationStateColor
Ambient state color value.
Definition XTPApplication.h:63
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
xtpComInitAppDefault
@ xtpComInitAppDefault
If passed to CXTPWinApp constructor or to XTPInitialize then uses xtpComInitAfxOle,...
Definition XTPSystemHelpers.h:1954
CXTPApplication
Defines a global XTP application object interface.
Definition XTPApplication.h:151
CXTPApplication::XTPShutdown
friend _XTP_EXT_CLASS void AFX_CDECL XTPShutdown()
Performs XTP application shutting down with releasing all internal XTP pointers and resources but not...
CXTPApplication::GetAppThreadId
DWORD GetAppThreadId() const
Obtains main application thread ID.
CXTPApplication::XTPInitialize
friend _XTP_EXT_CLASS BOOL AFX_CDECL XTPInitialize(int xtpComInit)
Initializes XTP framework.
CXTPApplication::SetAmbientProperty
void SetAmbientProperty(XTPApplicationAmbientProperty nProperty, COleVariant vtValue)
Sets ambient property value.
CXTPApplication::GetAmbientProperty
const COleVariant & GetAmbientProperty(XTPApplicationAmbientProperty nProperty) const
Gets ambient property value.
CXTPApplication::GetComInitFlags
int GetComInitFlags() const
Obtains COM initialization flags.
CXTPApplication::TriggerAmbientPropertyUpdate
void TriggerAmbientPropertyUpdate(XTPApplicationAmbientProperty nProperty)
Triggers ambient property update notification even if property value is not changed.
CXTPApplication::IsReady
BOOL IsReady() const
Determines if the application object is ready to be used, i.e.
CXTPApplication::GetModuleState
AFX_MODULE_STATE * GetModuleState()
Returns module state pointer obtained at the point where XTPInitialize or XTPGetApplication is first ...
CXTPApplication::XTPGetApplication
friend _XTP_EXT_CLASS CXTPApplication *AFX_CDECL XTPGetApplication()
Obtains the only XTP application instance pointer.
CXTPComInitializer
Initializes COM and increments and holds COM initialization reference counter for the thread where co...
Definition XTPSystemHelpers.h:2021
CXTPObservable
Provides a basic implementation of the Observable design pattern.
Definition XTPSystemHelpers.h:2138
CXTPSingleton
Implements Singleton design pattern.
Definition XTPSingleton.h:215
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602
IXTPApplicationEvents
Defines a callback interface for XTP application event sink.
Definition XTPApplication.h:82
IXTPApplicationEvents::~IXTPApplicationEvents
virtual ~IXTPApplicationEvents()
Handles object destruction.
Definition XTPApplication.h:87
IXTPApplicationEvents::OnBeforeApplicationShutdown
virtual void OnBeforeApplicationShutdown(CXTPApplication *pApplication)
Is called by framework before application shut down processing starts.
Definition XTPApplication.h:96
IXTPApplicationEvents::OnApplicationShutdown
virtual void OnApplicationShutdown(CXTPApplication *pApplication)
Is called by framework when application is being shutdown before the actual shutting down.
Definition XTPApplication.h:107
IXTPApplicationEvents::OnAfterApplicationShutdown
virtual void OnAfterApplicationShutdown(CXTPApplication *pApplication)
Is called by framework after application shut down processing is completed.
Definition XTPApplication.h:117
IXTPApplicationEvents::OnAmbientPropertyChanged
virtual void OnAmbientPropertyChanged(CXTPApplication *pApplication, XTPApplicationAmbientProperty nProperty)
Called by framework when an ambient property is changed.
Definition XTPApplication.h:130


CXTPChartFont Member List

This is the complete list of members for CXTPChartFont, including all inherited members.

CXTPChartFont() | CXTPChartFont |
CXTPChartFont(LOGFONT *pLogFont) | CXTPChartFont |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetTahoma12() | CXTPChartFont | static
GetTahoma18() | CXTPChartFont | static
GetTahoma8() | CXTPChartFont | static
m_lf | CXTPChartFont |
Release() | CXTPChartFont |
SetLogFont(LOGFONT *lf) | CXTPChartFont |
~CXTPChartFont() | CXTPChartFont | virtual


Toolkit Pro: XTPMarkupLine.h Source File

  • Source
  • Markup
  • Shapes
XTPMarkupLine.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPLINE_H__)
24# define __XTPMARKUPLINE_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDrawingContext;
34class CXTPMarkupInputElement;
35
36class _XTP_EXT_CLASS CXTPMarkupLine : public CXTPMarkupShape
37{
39 DECLARE_MARKUPCLASS(CXTPMarkupLine)
41protected:
42 CXTPMarkupLine();
43 ~CXTPMarkupLine();
44
45public:
46 int GetX1() const;
47 int GetX2() const;
48 int GetY1() const;
49 int GetY2() const;
50
51 void SetX1(int nValue);
52 void SetX2(int nValue);
53 void SetY1(int nValue);
54 void SetY2(int nValue);
55
56protected:
57 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
58 virtual void OnRender(CXTPMarkupDrawingContext* pDC);
59 virtual CXTPMarkupInputElement* InputHitTestOverride(CPoint point) const;
60
61private:
62 void GetPoints(int& x1, int& y1, int& x2, int& y2) const;
63
65public:
66 DECLARE_DISPATCH_MAP()
67# ifdef _XTP_ACTIVEX
68 DECLARE_INTERFACE_MAP()
69 DECLARE_OLETYPELIB_EX(CXTPMarkupLine);
70# endif
71
72 afx_msg int OleGetX1();
73 afx_msg void OleSetX1(int nValue);
74 afx_msg int OleGetX2();
75 afx_msg void OleSetX2(int nValue);
76 afx_msg int OleGetY1();
77 afx_msg void OleSetY1(int nValue);
78 afx_msg int OleGetY2();
79 afx_msg void OleSetY2(int nValue);
82public:
83 static CXTPMarkupDependencyProperty* m_pX1Property;
84 static CXTPMarkupDependencyProperty* m_pY1Property;
85 static CXTPMarkupDependencyProperty* m_pX2Property;
86 static CXTPMarkupDependencyProperty* m_pY2Property;
87};
88
89AFX_INLINE void CXTPMarkupLine::SetX1(int nValue)
90{
91 SetValue(m_pX1Property, new CXTPMarkupInt(nValue));
92}
93
94AFX_INLINE void CXTPMarkupLine::SetX2(int nValue)
95{
96 SetValue(m_pX2Property, new CXTPMarkupInt(nValue));
97}
98
99AFX_INLINE void CXTPMarkupLine::SetY1(int nValue)
100{
101 SetValue(m_pY1Property, new CXTPMarkupInt(nValue));
102}
103
104AFX_INLINE void CXTPMarkupLine::SetY2(int nValue)
105{
106 SetValue(m_pY2Property, new CXTPMarkupInt(nValue));
107}
108
109# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
111#endif // !defined(__XTPMARKUPLINE_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupVisual::InputHitTestOverride
virtual CXTPMarkupInputElement * InputHitTestOverride(CPoint point) const
Override this method in the derived class to provide visual hit testing of a child object.
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515


CXTPCalendarCaptionBarResourceTheme Member List

This is the complete list of members for CXTPCalendarCaptionBarResourceTheme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOffice2013Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2013Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCalendarCaptionBarResourceTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarResourceTheme |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetColor2(LPCTSTR pcszColorName, COLORREF clrDefault) | CXTPCalendarCaptionBarResourceTheme | virtual
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarResourceTheme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOffice2013Theme() | CXTPCalendarCaptionBarOffice2013Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual
~CXTPCalendarCaptionBarResourceTheme() | CXTPCalendarCaptionBarResourceTheme | virtual


CXTPRibbonControlSystemPopupBarButton Member List

This is the complete list of members for CXTPRibbonControlSystemPopupBarButton, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlButton | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPRibbonControlSystemPopupBarButton() | CXTPRibbonControlSystemPopupBarButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlButton | virtual
Draw(CDC *pDC) | CXTPRibbonControlSystemPopupBarButton | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPRibbonControlSystemPopupBarButton | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPRibbonControlSystemPopupBarButton | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPRibbonControlSystemPopupBarButton | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPRibbonControlSystemPopupBarButton | virtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlButton | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlButton | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual


IXTPFrameShadowManagerEvents Member List

This is the complete list of members for IXTPFrameShadowManagerEvents, including all inherited members.

OnFlagsChanged(CXTPFrameShadowManager *pManager, int nOldEffectiveFlags, int nNewEffectiveFlags) | IXTPFrameShadowManagerEvents | inlinevirtual
OnFrameShadowDisabled(CXTPFrameShadowManager *pManager, HWND hwndOwner, CXTPFrameShadow *pShadow) | IXTPFrameShadowManagerEvents | inlinevirtual
OnFrameShadowEnabled(CXTPFrameShadowManager *pManager, HWND hwndOwner, CXTPFrameShadow *pShadow) | IXTPFrameShadowManagerEvents | inlinevirtual
~IXTPFrameShadowManagerEvents() | IXTPFrameShadowManagerEvents | inlinevirtual


CXTPPropertyGridCoolTheme Member List

This is the complete list of members for CXTPPropertyGridCoolTheme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridCoolTheme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridCoolTheme |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridCoolTheme | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridCoolTheme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridCoolTheme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual


CXTPSkinObjectUser32Control Member List

This is the complete list of members for CXTPSkinObjectUser32Control, including all inherited members.

CheckScrollBarsDraw() | CXTPSkinObjectUser32Control | protectedvirtual
CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
CXTPSkinObjectUser32Control() | CXTPSkinObjectUser32Control | protected
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectFrame | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectFrame | protectedvirtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


CXTPTrackUndoDeleteBlockCommand Member List

This is the complete list of members for CXTPTrackUndoDeleteBlockCommand, including all inherited members.

CXTPTrackUndoCommand(int nID) | CXTPTrackUndoCommand | protected
CXTPTrackUndoDeleteBlockCommand(CXTPTrackBlock *pBlock) | CXTPTrackUndoDeleteBlockCommand |
GetID() const | CXTPTrackUndoCommand |
m_nID | CXTPTrackUndoCommand | protected
m_pBlock | CXTPTrackUndoDeleteBlockCommand | protected
m_pOldItem | CXTPTrackUndoDeleteBlockCommand | protected
Undo() | CXTPTrackUndoDeleteBlockCommand | protectedvirtual
~CXTPTrackUndoCommand() | CXTPTrackUndoCommand | protectedvirtual
~CXTPTrackUndoDeleteBlockCommand() | CXTPTrackUndoDeleteBlockCommand | virtual


CXTPPen Member List

This is the complete list of members for CXTPPen, including all inherited members.

__declspec(property(get=GetSafeHandle)) HGDIOBJ m_hObject | CXTPGdiObject |
CreatePen(int nPenStyle, int nWidth, COLORREF crColor) | CXTPPen |
CreatePen(int nPenStyle, int nWidth, const LOGBRUSH *pLogBrush, int nStyleCount=0, const DWORD *lpStyle=NULL) | CXTPPen |
CreatePenIndirect(LPLOGPEN lpLogPen) | CXTPPen |
CreateStockObject(int nIndex) | CXTPGdiObject |
CXTPGdiObject() | CXTPGdiObject | protected
CXTPPen() | CXTPPen |
CXTPPen(int nPenStyle, int nWidth, COLORREF crColor) | CXTPPen |
CXTPPen(int nPenStyle, int nWidth, const LOGBRUSH *pLogBrush, int nStyleCount=0, const DWORD *lpStyle=NULL) | CXTPPen |
DeleteObject() | CXTPGdiObject |
GetExtLogPen(EXTLOGPEN *pLogPen) | CXTPPen |
GetLogPen(LOGPEN *pLogPen) | CXTPPen |
GetNativeGdiObject() | CXTPPen |
GetNativeGdiObject() const | CXTPPen |
GetObject(int nCount, LPVOID lpObject) const | CXTPGdiObject |
GetObjectType() const | CXTPGdiObject |
GetSafeHandle() const | CXTPGdiObject |
IsHandleOwnershipGuaranteed() const | CXTPGdiObject |
operator CGdiObject &() | CXTPGdiObject |
operator const CGdiObject &() const | CXTPGdiObject |
operator const CPen &() const | CXTPPen |
operator CPen &() | CXTPPen |
operator HGDIOBJ() const | CXTPGdiObject |
operator HPEN() const | CXTPPen |
operator!=(const CXTPGdiObject &obj) const | CXTPGdiObject |
operator==(const CXTPGdiObject &obj) const | CXTPGdiObject |
SetHandleOwnershipNotGuaranteed() | CXTPGdiObject |
~CXTPGdiObject()=0 | CXTPGdiObject | pure virtual
~CXTPPen() | CXTPPen |


XTP_SLIDERTICKS Member List

This is the complete list of members for XTP_SLIDERTICKS, including all inherited members.

nCount | XTP_SLIDERTICKS
pTicks | XTP_SLIDERTICKS
XTP_SLIDERTICKS(double *pTicks, int nCount) | XTP_SLIDERTICKS
~XTP_SLIDERTICKS() | XTP_SLIDERTICKS


XTP_SCROLLBAR_POSINFO Member List

This is the complete list of members for XTP_SCROLLBAR_POSINFO, including all inherited members.

cpx | XTP_SCROLLBAR_POSINFO
cpxThumb | XTP_SCROLLBAR_POSINFO
fSizebox | XTP_SCROLLBAR_POSINFO
fVert | XTP_SCROLLBAR_POSINFO
ht | XTP_SCROLLBAR_POSINFO
page | XTP_SCROLLBAR_POSINFO
pos | XTP_SCROLLBAR_POSINFO
posMax | XTP_SCROLLBAR_POSINFO
posMin | XTP_SCROLLBAR_POSINFO
pxBottom | XTP_SCROLLBAR_POSINFO
pxDownArrow | XTP_SCROLLBAR_POSINFO
pxLeft | XTP_SCROLLBAR_POSINFO
pxMin | XTP_SCROLLBAR_POSINFO
pxPopup | XTP_SCROLLBAR_POSINFO
pxRight | XTP_SCROLLBAR_POSINFO
pxStart | XTP_SCROLLBAR_POSINFO
pxThumbBottom | XTP_SCROLLBAR_POSINFO
pxThumbTop | XTP_SCROLLBAR_POSINFO
pxTop | XTP_SCROLLBAR_POSINFO
pxUpArrow | XTP_SCROLLBAR_POSINFO
rc | XTP_SCROLLBAR_POSINFO


Toolkit Pro: XTPMarkupFrameworkElement.h Source File

  • Source
  • Markup
XTPMarkupFrameworkElement.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPFRAMEWORKELEMENT_H__)
24# define __XTPMARKUPFRAMEWORKELEMENT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupResourceDictionary;
34class CXTPMarkupStyle;
35class CXTPMarkupTriggerCollection;
36class CXTPMarkupThickness;
37
43class _XTP_EXT_CLASS CXTPMarkupFrameworkElement : public CXTPMarkupUIElement
44{
45private:
46 struct MINMAX
47 {
48 public:
49 MINMAX();
50 void Update(const CXTPMarkupFrameworkElement* pElement);
51
52 public:
53 int nMaxHeight;
54 int nMinHeight;
55 int nMaxWidth;
56 int nMinWidth;
57 };
58
59private:
61 DECLARE_MARKUPCLASS(CXTPMarkupFrameworkElement)
63protected:
68 CXTPMarkupFrameworkElement();
69
74 virtual ~CXTPMarkupFrameworkElement();
75
76public:
86 void SetMargin(int nLeft, int nTop, int nRight, int nBottom);
92 void SetMargin(int nMargin);
93
100 CXTPMarkupThickness* GetMargin() const;
101
107 void SetMinWidth(int nWidth);
108
114 void SetMaxWidth(int nWidth);
115
121 void SetWidth(int nWidth);
122
128 void SetMinHeight(int nHeight);
129
135 void SetMaxHeight(int nHeight);
136
142 void SetHeight(int nHeight);
143
150 int GetMinWidth() const;
151
158 int GetMaxWidth() const;
159
166 int GetWidth() const;
167
174 int GetMinHeight() const;
175
182 int GetMaxHeight() const;
183
190 int GetHeight() const;
191
198 CXTPMarkupObject* GetTag() const;
199
206 void SetTag(CXTPMarkupObject* pTag);
207
215 void SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment);
216
224 void SetVerticalAlignment(XTPMarkupVerticalAlignment alignment);
225
233 XTPMarkupHorizontalAlignment GetHorizontalAlignment() const;
234
242 XTPMarkupVerticalAlignment GetVerticalAlignment() const;
243
251 CSize GetActualSize() const;
252
258 void SetClipToBounds(BOOL bClipToBounds);
259
266 BOOL GetClipToBounds() const;
267
274 CXTPMarkupStyle* GetStyle() const;
275
276protected:
278 // Implementation
279
280 virtual CSize MeasureCore(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
281 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
282
283 virtual void ArrangeCore(CRect rcFinalRect);
284 virtual CSize ArrangeOverride(CSize szFinalSize);
285
286 BOOL GetLayoutClip(CRect& rc) const;
287 virtual void OnPropertyChanged(CXTPMarkupDependencyProperty* pProperty,
288 CXTPMarkupObject* pOldValue, CXTPMarkupObject* pNewValue);
289
290private:
291 CPoint ComputeAlignmentOffset(CSize clientSize, CSize inkSize) const;
292
293protected:
294 BOOL m_bNeedsClipBounds;
295
296 CSize m_szUnclippedDesiredSize;
297 BOOL m_bUnclippedDesiredSize;
298
299 MINMAX m_mmBounds;
300
301public:
302 static CXTPMarkupDependencyProperty* m_pMarginProperty;
303 static CXTPMarkupDependencyProperty* m_pHorizontalAlignmentProperty;
304 static CXTPMarkupDependencyProperty* m_pVerticalAlignmentProperty;
305 static CXTPMarkupDependencyProperty* m_pWidthProperty;
306 static CXTPMarkupDependencyProperty* m_pHeightProperty;
307 static CXTPMarkupDependencyProperty* m_pMinWidthProperty;
308 static CXTPMarkupDependencyProperty* m_pMinHeightProperty;
309 static CXTPMarkupDependencyProperty* m_pMaxWidthProperty;
310 static CXTPMarkupDependencyProperty* m_pMaxHeightProperty;
311 static CXTPMarkupDependencyProperty* m_pTagProperty;
315public:
316 DECLARE_DISPATCH_MAP()
317# ifdef _XTP_ACTIVEX
318 DECLARE_INTERFACE_MAP()
319 DECLARE_OLETYPELIB_EX(CXTPMarkupFrameworkElement);
320# endif
321
322 afx_msg long OleGetMinWidth();
323 afx_msg long OleGetWidth();
324 afx_msg long OleGetMaxWidth();
325 afx_msg void OleSetMinWidth(int nWidth);
326 afx_msg void OleSetWidth(int nWidth);
327 afx_msg void OleSetMaxWidth(int nWidth);
328 afx_msg long OleGetMinHeight();
329 afx_msg long OleGetHeight();
330 afx_msg long OleGetMaxHeight();
331 afx_msg void OleSetMinHeight(int nHeight);
332 afx_msg void OleSetHeight(int nHeight);
333 afx_msg void OleSetMaxHeight(int nHeight);
334 afx_msg LPDISPATCH OleGetMargin();
335 afx_msg void OleSetMargin(LPDISPATCH lpMarginDisp);
336 afx_msg long OleGetHorizontalAlignment();
337 afx_msg long OleGetVerticalAlignment();
338 afx_msg void OleSetHorizontalAlignment(long nValue);
339 afx_msg void OleSetVerticalAlignment(long nValue);
340 afx_msg VARIANT OleGetTag();
341 afx_msg void OleSetTag(const VARIANT& va);
342
344};
345
346AFX_INLINE CXTPMarkupStyle* CXTPMarkupFrameworkElement::GetStyle() const
347{
348 return m_pStyleCache;
349}
350
351# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
353#endif // !defined(__XTPMARKUPFRAMEWORKELEMENT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupFrameworkElement
This class represents the provided framework-level implementation built on CXTPMarkupUIElement.
Definition XTPMarkupFrameworkElement.h:44
CXTPMarkupFrameworkElement::SetMaxHeight
void SetMaxHeight(int nHeight)
Sets the maximum height constraint for the element.
CXTPMarkupFrameworkElement::GetMaxHeight
int GetMaxHeight() const
Gets the maximum height constraint of the element.
CXTPMarkupFrameworkElement::SetMargin
void SetMargin(int nMargin)
Call this method to set the outer margin of an element.
CXTPMarkupFrameworkElement::GetWidth
int GetWidth() const
Gets the width of the element.
CXTPMarkupFrameworkElement::GetHeight
int GetHeight() const
Gets the height of the element.
CXTPMarkupFrameworkElement::GetMargin
CXTPMarkupThickness * GetMargin() const
Call this method to get the outer margin of an element.
CXTPMarkupFrameworkElement::SetMinHeight
void SetMinHeight(int nHeight)
Sets the minimum height constraint for the element.
CXTPMarkupFrameworkElement::SetMinWidth
void SetMinWidth(int nWidth)
Sets the minimum width constraint for the element.
CXTPMarkupFrameworkElement::GetStyle
CXTPMarkupStyle * GetStyle() const
Gets the attached style of the element.
Definition XTPMarkupFrameworkElement.h:346
CXTPMarkupFrameworkElement::SetHorizontalAlignment
void SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment)
Sets the horizontal alignment characteristics applied to this element when it is composed within a pa...
CXTPMarkupFrameworkElement::SetClipToBounds
void SetClipToBounds(BOOL bClipToBounds)
Specifies if child elements should be clipped inside element bounds.
CXTPMarkupFrameworkElement::CXTPMarkupFrameworkElement
CXTPMarkupFrameworkElement()
Initializes a new instance of the CXTPMarkupFrameworkElement class.
CXTPMarkupFrameworkElement::GetMaxWidth
int GetMaxWidth() const
Gets the maximum width constraint of the element.
CXTPMarkupFrameworkElement::GetActualSize
CSize GetActualSize() const
Retrieves the actual size of the element after it is measured and arranged within a parent element (e...
CXTPMarkupFrameworkElement::SetHeight
void SetHeight(int nHeight)
Sets the height for the element.
CXTPMarkupFrameworkElement::GetHorizontalAlignment
XTPMarkupHorizontalAlignment GetHorizontalAlignment() const
Gets the horizontal alignment characteristics applied to this element when it is composed within a pa...
CXTPMarkupFrameworkElement::GetClipToBounds
BOOL GetClipToBounds() const
Determines if child elements are clipped inside element bounds.
CXTPMarkupFrameworkElement::SetMaxWidth
void SetMaxWidth(int nWidth)
Sets the maximum width constraint for the element.
CXTPMarkupFrameworkElement::GetVerticalAlignment
XTPMarkupVerticalAlignment GetVerticalAlignment() const
Gets the vertical alignment characteristics applied to this element when it is composed within a pare...
CXTPMarkupFrameworkElement::GetMinWidth
int GetMinWidth() const
Gets the minimum width constraint of the element.
CXTPMarkupFrameworkElement::SetTag
void SetTag(CXTPMarkupObject *pTag)
Sets the tag object for the element.
CXTPMarkupFrameworkElement::GetTag
CXTPMarkupObject * GetTag() const
Gets the tag object of the element.
CXTPMarkupFrameworkElement::~CXTPMarkupFrameworkElement
virtual ~CXTPMarkupFrameworkElement()
Destroys a CXTPMarkupFrameworkElement object, handles cleanup and deallocation.
CXTPMarkupFrameworkElement::GetMinHeight
int GetMinHeight() const
Gets the minimum height constraint of the element.
CXTPMarkupFrameworkElement::SetWidth
void SetWidth(int nWidth)
Sets the width for the element.
CXTPMarkupFrameworkElement::SetVerticalAlignment
void SetVerticalAlignment(XTPMarkupVerticalAlignment alignment)
Sets the vertical alignment characteristics applied to this element when it is composed within a pare...
CXTPMarkupFrameworkElement::SetMargin
void SetMargin(int nLeft, int nTop, int nRight, int nBottom)
Call this method to set the outer margin of an element.
CXTPMarkupThickness
The CXTPMarkupThickness class describes the thickness of the left, top, right, and bottom sides of a ...
Definition XTPMarkupThickness.h:42
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPMarkupUIElement::MeasureCore
virtual CSize MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize)
When overridden in a derived class, provides measurement logic for sizing this element properly with ...
CXTPMarkupUIElement::GetLayoutClip
virtual BOOL GetLayoutClip(CRect &rc) const
Retrieves an alternative clipping geometry that represents the region that would be clipped if child ...
CXTPMarkupUIElement::ArrangeCore
virtual void ArrangeCore(CRect rcFinalRect)
Defines the template for the core-level arrange layout definition.


Toolkit Pro: XTPProgressPaintManager.h Source File

  • Source
  • CommandBars
  • Progress
XTPProgressPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROGRESSPAINTMANAGER_H__)
24# define __XTPPROGRESSPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPProgressBase;
34class CXTPPaintManager;
35
40class _XTP_EXT_CLASS CXTPProgressPaintManager : public CObject
41{
42 DECLARE_DYNAMIC(CXTPProgressPaintManager);
43
44public:
50 CXTPProgressPaintManager(CXTPPaintManager* pPaintManager);
51
56 virtual ~CXTPProgressPaintManager();
57
58public:
65 virtual void DrawProgress(CDC* pDC, CXTPProgressBase* pProgressBar);
66
71 virtual void RefreshMetrics();
72
79 CXTPPaintManager* GetPaintManager() const;
80
81protected:
82 CXTPPaintManager* m_pPaintManager;
84public:
85 int m_cyProgress;
86};
87
88AFX_INLINE CXTPPaintManager* CXTPProgressPaintManager::GetPaintManager() const
89{
90 return m_pPaintManager;
91}
92
94# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
95#endif // !defined(__XTPPROGRESSPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPProgressBase
CXTPControlProgressBase is base class for all progress objects.
Definition XTPProgressBase.h:40
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41
CXTPProgressPaintManager::CXTPProgressPaintManager
CXTPProgressPaintManager(CXTPPaintManager *pPaintManager)
Constructs a CXTPProgressPaintManager object.
CXTPProgressPaintManager::m_pPaintManager
CXTPPaintManager * m_pPaintManager
Pointer to parent PaintManager.
Definition XTPProgressPaintManager.h:82
CXTPProgressPaintManager::~CXTPProgressPaintManager
virtual ~CXTPProgressPaintManager()
Destroys a CXTPProgressPaintManager object, handles cleanup and deallocation.
CXTPProgressPaintManager::m_cyProgress
int m_cyProgress
Progress height.
Definition XTPProgressPaintManager.h:85
CXTPProgressPaintManager::GetPaintManager
CXTPPaintManager * GetPaintManager() const
Gets the parent paint manager object.
Definition XTPProgressPaintManager.h:88
CXTPProgressPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates metrics.
CXTPProgressPaintManager::DrawProgress
virtual void DrawProgress(CDC *pDC, CXTPProgressBase *pProgressBar)
This method is called to draw progress.


CXTPMessageBarThemeVisualStudio2017 Member List

This is the complete list of members for CXTPMessageBarThemeVisualStudio2017, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
CXTPMessageBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeOffice2013 |
CXTPMessageBarThemeVisualStudio2017(CXTPPaintManager *pPaintManager) | CXTPMessageBarThemeVisualStudio2017 |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarThemeOffice2013 | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarThemeOffice2013 | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarThemeOffice2013 | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrButtonBack | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorder | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderHilite | CXTPMessageBarThemeOffice2013 | protected
m_clrButtonBorderPushed | CXTPMessageBarThemeOffice2013 | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_clrTextHilite | CXTPMessageBarThemeOffice2013 | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarThemeOffice2013 | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: XTPCustomizeTools.h Source File

  • Source
  • CommandBars
  • Customize
XTPCustomizeTools.h
Go to the documentation of this file.
1
23#if !defined(__XTPCUSTOMIZETOOLS_H__)
24# define __XTPCUSTOMIZETOOLS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPCommandBar;
34class CXTPCommandBars;
35class CXTPControl;
36class CXTPCustomizeSheet;
37
40# define DROPEFFECT_CANCEL (5)
41
46class _XTP_EXT_CLASS CXTPCustomizeDropSource
47{
48public:
55 CXTPCustomizeDropSource(CXTPCommandBars* pCommandBars);
56
61 ~CXTPCustomizeDropSource();
62
63public:
64 DROPEFFECT DoDragDrop(CXTPControl* pControl, BOOL bCopyOnly = FALSE);
65 void Register(CXTPCommandBar* pCommandBar);
66 void UnRegister(CXTPCommandBar* pCommandBar);
67 CXTPCustomizeSheet* GetSheet() const;
68
69 void ContextMenu(CPoint point);
70
71private:
72 DROPEFFECT _DoDragDrop();
73 void PickTarget(CPoint ptCursor);
74 void FreshenCursor();
75
76private:
77 HWND m_hwndCapture;
78 CXTPControl* m_pControl;
79 BOOL m_bMove;
80 BOOL m_bCopyOnly;
81 CXTPCommandBar* m_pTarget;
82 CXTPCustomizeSheet* m_pSheet;
83 CPoint m_ptStart;
84
85 CArray<CXTPCommandBar*, CXTPCommandBar*> m_arrTargets;
86
87 CXTPCommandBars* m_pCommandBars;
88
89 HCURSOR m_hcurDelete;
90 HCURSOR m_hcurMove;
91 HCURSOR m_hcurCopy;
92
93 friend class CXTPCustomizeSheet;
94 friend class CXTPCommandBars;
95};
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
99#endif // #define __XTPCUSTOMIZETOOLS_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPCustomizeSheet
CXTPCustomizeSheet is a CPropertySheet derived class.
Definition XTPCustomizeSheet.h:47


CXTPDockingPaneNativeWindows11Theme Member List

This is the complete list of members for CXTPDockingPaneNativeWindows11Theme, including all inherited members.

AdjustCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustCaptionRect(const CXTPDockingPaneSidePanel *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
AdjustClientRect(CXTPDockingPaneTabbedContainer *pPane, CRect &rc, BOOL bApply) | CXTPDockingPaneVisualStudio2012Theme | virtual
CXTPDockingPaneDefaultTheme::AdjustClientRect(CXTPDockingPaneSidePanel *pPane, CRect &rect) | CXTPDockingPanePaintManager | virtual
ClipAndAddEllipsisIfNeeded(CDC *pDC, CString &strTitle, int nCaptionWidth) const | CXTPDockingPanePaintManager | protected
CXTPCmdTarget() | CXTPCmdTarget |
CXTPDockingPaneDefaultTheme() | CXTPDockingPaneDefaultTheme |
CXTPDockingPaneNativeWindows11Theme() | CXTPDockingPaneNativeWindows11Theme |
CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protected
CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme |
DeletePaneColorSets() | CXTPDockingPaneVisualStudio2012Theme | protected
DrawAutoHidePanel(CDC *pDC, CRect rc, XTPDockingPaneDirection direction) | CXTPDockingPaneNativeWindows11Theme | virtual
DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButton(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, COLORREF clrButton, CSize szOffset) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtonEntry(CDC *pDC, CXTPDockingPaneCaptionButton *pButton, CPoint pt, COLORREF clrButton) | CXTPDockingPanePaintManager | protectedvirtual
DrawCaptionButtons(CDC *pDC, CXTPDockingPaneCaptionButtons *pButtons, CRect &rcCaption, COLORREF clr, int nButtonSize, int nButtonGap, BOOL bVertical=FALSE) | CXTPDockingPanePaintManager | virtual
DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical) | CXTPDockingPaneDefaultTheme | protectedvirtual
DrawCaptionText(CDC *pDC, const CString &strTitle, CRect rc, BOOL bVertical, BOOL bCalcWidth=FALSE) | CXTPDockingPanePaintManager |
DrawDottedLine(CDC *pDC, int x, int y, int nSize, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawGripper(CDC *pDC, CRect rcGripper, COLORREF clr, BOOL bVertical) | CXTPDockingPaneVisualStudio2012Theme | protected
DrawPane(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc) | CXTPDockingPaneVisualStudio2012Theme | virtual
DrawSplitter(CDC *pDC, CXTPDockingPaneSplitterWnd *pSplitter) | CXTPDockingPaneNativeWindows11Theme | virtual
DrawTitleBar(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rc, BOOL bVertical) | CXTPDockingPaneNativeWindows11Theme | protectedvirtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCaptionButtonStyle() const | CXTPDockingPanePaintManager |
GetCaptionGripperRect(const CXTPDockingPaneTabbedContainer *pPane) | CXTPDockingPanePaintManager | virtual
GetCaptionHeight() const | CXTPDockingPanePaintManager |
GetCaptionRect(const CXTPDockingPaneTabbedContainer *pPane, CRect &rc) | CXTPDockingPanePaintManager | virtual
GetColorSet(BOOL bActive) | CXTPDockingPaneVisualStudio2012Theme | protectedvirtual
GetCurrentSystemTheme() const | CXTPDockingPanePaintManager |
GetCustomTitleBrush(BOOL bActive, BOOL bVertical) const | CXTPDockingPanePaintManager |
GetPaneCaptionRect(const CXTPDockingPaneSidePanel *pPane) | CXTPDockingPaneVisualStudio2012Theme | virtual
GetPanelPaintManager() const | CXTPDockingPanePaintManager |
GetSplitterStyle() const | CXTPDockingPanePaintManager |
GetTabPaintManager() const | CXTPDockingPanePaintManager |
GetTabsHeight() const | CXTPDockingPanePaintManager |
GetXtremeColor(UINT nIndex) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1, int nPen) | CXTPDockingPanePaintManager |
Line(CDC *pDC, int x0, int y0, int x1, int y1) | CXTPDockingPanePaintManager |
m_arrColor | CXTPDockingPanePaintManager | protected
m_bDestroyCustomTitleBrushes | CXTPDockingPanePaintManager | protected
m_bDrawCaptionIcon | CXTPDockingPanePaintManager |
m_bDrawSingleTab | CXTPDockingPanePaintManager |
m_bHighlightActiveCaption | CXTPDockingPanePaintManager |
m_bLunaTheme | CXTPDockingPanePaintManager | protected
m_bShowCaption | CXTPDockingPanePaintManager |
m_bUseBoldCaptionFont | CXTPDockingPanePaintManager |
m_bUseOfficeFont | CXTPDockingPanePaintManager | protected
m_bUseStandardFont | CXTPDockingPanePaintManager | protected
m_clrActiveCaption | CXTPDockingPanePaintManager |
m_clrActiveCaptionText | CXTPDockingPanePaintManager |
m_clrBackground | CXTPDockingPanePaintManager |
m_clrCaptionBorder | CXTPDockingPaneNativeWindows11Theme | protected
m_clrDisabledCaptionText | CXTPDockingPanePaintManager |
m_clrNormalCaption | CXTPDockingPanePaintManager |
m_clrNormalCaptionText | CXTPDockingPanePaintManager |
m_clrSplitter | CXTPDockingPanePaintManager |
m_clrSplitterGradient | CXTPDockingPanePaintManager |
m_clrSplitterGripper | CXTPDockingPanePaintManager |
m_dwSplitterStyle | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrActiveTitleVert | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleHorz | CXTPDockingPanePaintManager | protected
m_hbrInactiveTitleVert | CXTPDockingPanePaintManager | protected
m_nCaptionButtonStyle | CXTPDockingPanePaintManager | protected
m_nCaptionFontGap | CXTPDockingPanePaintManager | protected
m_nFontSize | CXTPDockingPaneVisualStudio2012Theme | protected
m_nSplitterIndent | CXTPDockingPanePaintManager |
m_nSplitterSize | CXTPDockingPanePaintManager |
m_nTabsHeight | CXTPDockingPanePaintManager | protected
m_nTitleHeight | CXTPDockingPanePaintManager | protected
m_pcsActive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pcsInactive | CXTPDockingPaneVisualStudio2012Theme | protected
m_pPanelPaintManager | CXTPDockingPanePaintManager | protected
m_pTabPaintManager | CXTPDockingPanePaintManager | protected
m_rcCaptionMargin | CXTPDockingPanePaintManager | protected
m_strFontFace | CXTPDockingPaneVisualStudio2012Theme | protected
m_strOfficeFont | CXTPDockingPanePaintManager | protected
m_systemTheme | CXTPDockingPanePaintManager | protected
m_themeButton | CXTPDockingPanePaintManager | protected
m_themeCurrent | CXTPDockingPanePaintManager | protected
m_themeExplorer | CXTPDockingPanePaintManager | protected
m_themeRebar | CXTPDockingPanePaintManager | protected
m_themeToolbar | CXTPDockingPanePaintManager | protected
m_themeWindow | CXTPDockingPanePaintManager | protected
m_xtpFontTitle | CXTPDockingPanePaintManager | protected
m_xtpFontTitleVertical | CXTPDockingPanePaintManager | protected
Pixel(CDC *pDC, int xPos, int yPos, int nPen) | CXTPDockingPanePaintManager |
Rectangle(CDC *pDC, CRect rc, int nPenEntry, int nPenBorder) | CXTPDockingPanePaintManager |
RefreshMetrics() | CXTPDockingPaneNativeWindows11Theme | virtual
SetCaptionButtonStyle(XTPDockingPaneCaptionButtonStyle nStyle) | CXTPDockingPanePaintManager |
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE) | CXTPDockingPanePaintManager |
SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues) | CXTPDockingPanePaintManager |
SetCustomTitleBrushes(HBRUSH hbrActiveTitleHorz, HBRUSH hbrInactiveTitleHorz=NULL, HBRUSH hbrActiveTitleVert=NULL, HBRUSH hbrInactiveTitleVert=NULL, BOOL bDestroyOnCleanup=FALSE) | CXTPDockingPanePaintManager |
SetLunaTheme(XTPCurrentSystemTheme systemTheme) | CXTPDockingPanePaintManager |
SetPaneColorSets(CXTPDockingPaneColorSet *pcsActive, CXTPDockingPaneColorSet *pcsInactive) | CXTPDockingPaneVisualStudio2012Theme | protected
SetPanelPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
SetSplitterStyle(DWORD dwStyle) | CXTPDockingPanePaintManager |
SetTabPaintManager(CXTPTabPaintManager *pManager) | CXTPDockingPanePaintManager |
UseOfficeFont(BOOL bUseOfficeFont) | CXTPDockingPanePaintManager |
~CXTPDockingPaneNativeWindows11Theme() | CXTPDockingPaneNativeWindows11Theme | virtual
~CXTPDockingPanePaintManager() | CXTPDockingPanePaintManager | protectedvirtual
~CXTPDockingPaneVisualStudio2012Theme() | CXTPDockingPaneVisualStudio2012Theme | virtual


Toolkit Pro: XTPRibbonBackstageButtonThemeNativeWindows10.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageButtonThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMENATIVEWINDOWS10T_H__)
24# define __XTPRIBBONBACKSTAGEBUTTONTHEMENATIVEWINDOWS10T_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPRibbonBackstageButtonThemeNativeWindows10
34 : public CXTPButtonThemeNativeWindows10
35{
36public:
37 CXTPRibbonBackstageButtonThemeNativeWindows10();
38
39public:
40 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
41
42protected:
43 friend class CBackstageButtonCtrl;
44};
45
46# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
48#endif // !defined(__XTPRIBBONBACKSTAGEBUTTONTHEMENATIVEWINDOWS10T_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeNativeWindows10
CXTPButtonThemeNativeWindows10 is a class used to perform Visual Studio 2015 theme drawing tasks.
Definition XTPButtonThemeNativeWindows10.h:39
CXTPButtonThemeOffice2013::DrawButtonBackground
virtual void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for the button.


Toolkit Pro: XTPChart2dFunnelDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • 2D
XTPChart2dFunnelDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART2DFUNNELDIAGRAMVIEW_H__)
24# define __XTPCHART2DFUNNELDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
44class _XTP_EXT_CLASS CXTPChartFunnelDiagramView : public CXTPChartDiagramView
45{
46public:
54 CXTPChartFunnelDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
55
56protected:
57};
59# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
60#endif //#if !defined(__XTPCHART2DFUNNELDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFunnelDiagramView
This class abstracts the view of a funnel diagram.
Definition XTPChart2dFunnelDiagramView.h:45
CXTPChartFunnelDiagramView::CXTPChartFunnelDiagramView
CXTPChartFunnelDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChartFunnelDiagramView object.


XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS Member List

This is the complete list of members for XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS, including all inherited members.

dtBeginTime | XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
nIndex | XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
nMinutes | XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS
nTimeScale | XTP_CALENDAR_THEME_DAYVIEWTIMESCALECELL_PARAMS


CXTPAutoResetValue< _TValue > Member List

This is the complete list of members for CXTPAutoResetValue< _TValue >, including all inherited members.

CXTPAutoResetValue(_TValue &rData) | CXTPAutoResetValue< _TValue > | inline
CXTPAutoResetValue(_TValue &rData, const _TValue &valReset) | CXTPAutoResetValue< _TValue > | inline
operator _TValue &() | CXTPAutoResetValue< _TValue > | inline
operator=(const _TValue &rSrc) | CXTPAutoResetValue< _TValue > | inline
~CXTPAutoResetValue() | CXTPAutoResetValue< _TValue > | inlinevirtual


CXTPTaskDialog Member List

This is the complete list of members for CXTPTaskDialog, including all inherited members.

AddButton(LPCTSTR pszText, int nButtonID) | CXTPTaskDialog |
AddInputBox() | CXTPTaskDialog |
AddRadioButton(LPCTSTR pszText, int nButtonID) | CXTPTaskDialog |
ClickButton(int nButtonID) | CXTPTaskDialog |
ClickRadioButton(int nButtonID) | CXTPTaskDialog |
ClickVerification(BOOL bChecked, BOOL bSetKeyFocus) | CXTPTaskDialog |
Create(CWnd *pParentWnd=NULL) | CXTPTaskDialog |
CreateFromResource(UINT nIDResource, LPCTSTR lpszDialog) | CXTPTaskDialog |
CreateFromResource(HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog) | CXTPTaskDialog |
CreateFromResourceParam(HINSTANCE hInstance, UINT nIDResource, LPCTSTR lpszDialog, LPCTSTR const *rglpsz, int nString) | CXTPTaskDialog |
CreateFromResourceParam(CXTPPropExchangeXMLNode *pPX, LPCTSTR const *rglpsz, int nString) | CXTPTaskDialog |
CXTPTaskDialog(CWnd *pWndParent=NULL) | CXTPTaskDialog |
DoModal() | CXTPTaskDialog | virtual
DoModal(BOOL bUseComCtl32) | CXTPTaskDialog |
EnableButton(int nButtonID, BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableCallbackTimer(BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableCancellation(BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableCommandLinks(BOOL bEnable=TRUE, BOOL bShowIcon=TRUE) | CXTPTaskDialog |
EnableHyperlinks(BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableMarkup(BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableMessageBoxStyle(BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableMinimize(BOOL bEnable) | CXTPTaskDialog |
EnableRadioButton(int nButtonID, BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableRelativePosition(BOOL bEnable=TRUE) | CXTPTaskDialog |
EnableRtlLayout(BOOL bEnable=TRUE) | CXTPTaskDialog |
ExpandedByDefault(BOOL bExpanded=TRUE) | CXTPTaskDialog |
ExpandFooterArea(BOOL bExpandFooter=TRUE) | CXTPTaskDialog |
GetInputBoxText() const | CXTPTaskDialog |
GetSelectedButtonId() const | CXTPTaskDialog |
GetSelectedRadioButtonId() const | CXTPTaskDialog |
IsVerificiationChecked() const | CXTPTaskDialog |
m_arrButtons | CXTPTaskDialog | protected
m_arrCommandButtons | CXTPTaskDialogClient | protected
m_arrLinkButtons | CXTPTaskDialogClient | protected
m_arrRadioButtons | CXTPTaskDialog | protected
m_bEnableMarkup | CXTPTaskDialogClient | protected
m_bExpanded | CXTPTaskDialogClient | protected
m_bMessageBoxStyle | CXTPTaskDialogClient | protected
m_bShowInputBox | CXTPTaskDialogClient | protected
m_bThemeReady | CXTPTaskDialogClient | protected
m_bUseComCtl32 | CXTPTaskDialog | protected
m_bUseSysIcons | CXTPTaskDialogClient | protected
m_bVerification | CXTPTaskDialogClient | protected
m_config | CXTPTaskDialog | protected
m_cr3DHighLight | CXTPTaskDialogClient | protected
m_cr3DLight | CXTPTaskDialogClient | protected
m_cr3DShadow | CXTPTaskDialogClient | protected
m_crContent | CXTPTaskDialogClient | protected
m_crContentText | CXTPTaskDialogClient | protected
m_crFooter | CXTPTaskDialogClient | protected
m_crFooterText | CXTPTaskDialogClient | protected
m_crMainText | CXTPTaskDialogClient | protected
m_hIconFooter | CXTPTaskDialogClient | protected
m_hIconMain | CXTPTaskDialogClient | protected
m_hwndTaskDialog | CXTPTaskDialog | protected
m_mapWndSize | CXTPTaskDialogClient | protected
m_nMaxClientWidth | CXTPTaskDialogClient | protected
m_nMinClientWidth | CXTPTaskDialogClient | protected
m_nPadding | CXTPTaskDialogClient | protected
m_nSelButtonID | CXTPTaskDialog | protected
m_nSelRadioButtonID | CXTPTaskDialogClient | protected
m_pBtnExpando | CXTPTaskDialogClient | protected
m_pBtnVerify | CXTPTaskDialogClient | protected
m_pConfig | CXTPTaskDialogClient | protected
m_pMarkupContext | CXTPTaskDialogClient | protected
m_ptBorder | CXTPTaskDialogClient | protected
m_ptBtnSpacing | CXTPTaskDialogClient | protected
m_ptMargin | CXTPTaskDialogClient | protected
m_ptPadding | CXTPTaskDialogClient | protected
m_rcCommandButtons | CXTPTaskDialogClient | protected
m_rcContent | CXTPTaskDialogClient | protected
m_rcExpandedInformation | CXTPTaskDialogClient | protected
m_rcFooter | CXTPTaskDialogClient | protected
m_rcLinkButtons | CXTPTaskDialogClient | protected
m_rcMainInstruction | CXTPTaskDialogClient | protected
m_rcRadioButtons | CXTPTaskDialogClient | protected
m_sizeCommandButton | CXTPTaskDialogClient | protected
m_sizeIconFooter | CXTPTaskDialogClient | protected
m_sizeIconMain | CXTPTaskDialogClient | protected
m_strCollapsedControlText | CXTPTaskDialogClient | protected
m_strContent | CXTPTaskDialogClient | protected
m_strExpandedControlText | CXTPTaskDialogClient | protected
m_strExpandedInformation | CXTPTaskDialogClient | protected
m_strFooter | CXTPTaskDialogClient | protected
m_strInputBoxText | CXTPTaskDialogClient | protected
m_strMainInstruction | CXTPTaskDialogClient | protected
m_strVerificationText | CXTPTaskDialogClient | protected
m_wndContent | CXTPTaskDialogClient | protected
m_wndExpandedInformation | CXTPTaskDialogClient | protected
m_wndFooter | CXTPTaskDialogClient | protected
m_wndInputBox | CXTPTaskDialogClient | protected
m_wndProgressBar | CXTPTaskDialogClient | protected
m_xtpFont | CXTPTaskDialogClient | protected
m_xtpFontLarge | CXTPTaskDialogClient | protected
ModifyTaskStyle(TASKDIALOG_FLAGS dwRemove, TASKDIALOG_FLAGS dwAdd) | CXTPTaskDialog |
MoveButton(CButton *pButton, int xPos, int yPos, int cx, int cy, BOOL bRedraw=FALSE) | CXTPTaskDialogClient | protected
MoveButton(CButton *pButton, const CRect &rect, BOOL bRedraw=FALSE) | CXTPTaskDialogClient | protected
NavigatePage(CXTPTaskDialog &taskDlg) | CXTPTaskDialog |
NoDefaultRadioButton(BOOL bNoDefault) | CXTPTaskDialog |
OnButtonClicked(int nButtonID, BOOL &bCloseDialog) | CXTPTaskDialog | protectedvirtual
OnDialogConstructed() | CXTPTaskDialog | protectedvirtual
OnDialogDestroyed() | CXTPTaskDialog | protectedvirtual
OnDialogNotify(UINT uNotification, WPARAM wParam, LPARAM lParam) | CXTPTaskDialog | protectedvirtual
OnExpandoButtonClicked(BOOL bExpanded) | CXTPTaskDialog | protectedvirtual
OnHelp() | CXTPTaskDialog | protectedvirtual
OnHyperlinkClicked(LPCTSTR pszURL) | CXTPTaskDialog | protectedvirtual
OnInputBoxChanged() | CXTPTaskDialog | protectedvirtual
OnNavigated() | CXTPTaskDialog | protectedvirtual
OnRadioButtonClicked(int nButtonID) | CXTPTaskDialog | protectedvirtual
OnTimer(DWORD dwMilliSeconds, BOOL &bReset) | CXTPTaskDialog | protectedvirtual
OnVerificationClicked(BOOL bChecked) | CXTPTaskDialog | protectedvirtual
ResetContent() | CXTPTaskDialog |
SetButtonElevationRequired(int nButtonID, BOOL bRequired=TRUE) | CXTPTaskDialog |
SetCollapsedControlText(LPCTSTR pszText) | CXTPTaskDialog |
SetCommonButtons(TASKDIALOG_COMMON_BUTTON_FLAGS dwButtons) | CXTPTaskDialog |
SetCommonButtons(BOOL bOk, BOOL bYes, BOOL bNo, BOOL bCancel, BOOL bRetry, BOOL bClose) | CXTPTaskDialog |
SetContent(LPCTSTR pszText) | CXTPTaskDialog |
SetDefaultButton(int nButtonID) | CXTPTaskDialog |
SetDefaultRadioButton(int nButtonID) | CXTPTaskDialog |
SetExpandedControlText(LPCTSTR pszText) | CXTPTaskDialog |
SetExpandedInformation(LPCTSTR pszText) | CXTPTaskDialog |
SetFooter(LPCTSTR pszText) | CXTPTaskDialog |
SetFooterIcon(HICON hIcon) | CXTPTaskDialog |
SetFooterIcon(LPCWSTR pszResource) | CXTPTaskDialog |
SetInputBoxText(LPCTSTR lpszInputBoxText) | CXTPTaskDialog |
SetMainIcon(HICON hIcon) | CXTPTaskDialog |
SetMainIcon(LPCWSTR pszResource) | CXTPTaskDialog |
SetMainInstruction(LPCTSTR pszText) | CXTPTaskDialog |
SetMarqueeProgressBar(BOOL bMarquee=TRUE) | CXTPTaskDialog |
SetProgressBarPos(int nPosition) | CXTPTaskDialog |
SetProgressBarRange(WORD wMinRange=0, WORD wMaxRange=100) | CXTPTaskDialog |
SetProgressBarState(int nState) | CXTPTaskDialog |
SetUseComCtl32(BOOL bUseComCtl32=TRUE) | CXTPTaskDialog |
SetUseSysIcons(BOOL bUseSysIcons=TRUE) | CXTPTaskDialog |
SetVerificationText(LPCTSTR pszText) | CXTPTaskDialog |
SetVerifyCheckState(BOOL bChecked=TRUE) | CXTPTaskDialog |
SetWidth(int cxWidth, BOOL bPixelToDLU=FALSE) | CXTPTaskDialog |
SetWindowTitle(LPCTSTR pszText) | CXTPTaskDialog |
ShowProgressBar(BOOL bShow, BOOL bMarquee=FALSE) | CXTPTaskDialog |
StartProgressBarMarquee(BOOL bStartMarquee, DWORD dwMilliSeconds) | CXTPTaskDialog |
~CXTPTaskDialog() | CXTPTaskDialog | virtual


CXTPControlGalleryItems Member List

This is the complete list of members for CXTPControlGalleryItems, including all inherited members.

AddItem(int nId, int nImage) | CXTPControlGalleryItems |
AddItem(LPCTSTR lpszCaption, int nId, int nImage) | CXTPControlGalleryItems |
AddItem(CXTPControlGalleryItem *pItem, int nId=-1, int nImage=-1) | CXTPControlGalleryItems |
AddItem(LPCTSTR lpszCaption, int nImage=-1) | CXTPControlGalleryItems |
AddLabel(int nId) | CXTPControlGalleryItems |
AddLabel(LPCTSTR lpszCaption) | CXTPControlGalleryItems |
ClipItems(BOOL bClipItems) | CXTPControlGalleryItems |
CreateItems(CXTPCommandBars *pCommandBars, int nId) | CXTPControlGalleryItems | static
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlGalleryItems(CXTPControlAction *pAction, CXTPCommandBars *pCommandBars) | CXTPControlGalleryItems | protected
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPControlGalleryItems |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAction() const | CXTPControlGalleryItems |
GetImageManager() const | CXTPControlGalleryItems |
GetItem(int nIndex) const | CXTPControlGalleryItems |
GetItemCount() const | CXTPControlGalleryItems |
GetItemSize() const | CXTPControlGalleryItems |
GetMarkupContext() const | CXTPControlGalleryItems |
InsertItem(int nIndex, CXTPControlGalleryItem *pItem, int nId=-1, int nImage=-1) | CXTPControlGalleryItems |
m_arrItems | CXTPControlGalleryItems | protected
m_bClipItems | CXTPControlGalleryItems | protected
m_pAction | CXTPControlGalleryItems | protected
m_pImageManager | CXTPControlGalleryItems | protected
m_szItem | CXTPControlGalleryItems | protected
OnItemsChanged() | CXTPControlGalleryItems | virtual
PreDrawItem(CDC *pDC, CXTPControlGallery *pGallery, CXTPControlGalleryItem *pItem, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked) | CXTPControlGalleryItems | virtual
Remove(int nIndex) | CXTPControlGalleryItems |
RemoveAll() | CXTPControlGalleryItems |
SetImageManager(CXTPImageManager *pImageManager) | CXTPControlGalleryItems |
SetItemSize(CSize szItem) | CXTPControlGalleryItems |
~CXTPControlGalleryItems() | CXTPControlGalleryItems | protected


Toolkit Pro: XTPRibbonBackstageViewThemeOffice2013.h Source File

  • Source
  • Ribbon
  • Backstage
XTPRibbonBackstageViewThemeOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEOFFICE2013_H__)
24# define __XTPRIBBONBACKSTAGEVIEWTHEMEOFFICE2013_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPRibbonBackstageView;
34
35class _XTP_EXT_CLASS CXTPRibbonBackstageViewThemeOffice2013 : public CXTPRibbonBackstagePaintManager
36{
37public:
38 CXTPRibbonBackstageViewThemeOffice2013();
39
40 virtual ~CXTPRibbonBackstageViewThemeOffice2013();
41
42public:
43 virtual void DrawBackground(CDC* pDC, CXTPRibbonBackstageView* pView);
44 virtual void DrawControl(CDC* pDC, CXTPRibbonBackstageView* pView, CXTPControl* pControl);
45
46protected:
47 COLORREF m_clrButtonBackNormal;
48 COLORREF m_clrButtonBackSelected;
49 COLORREF m_clrButtonBackHighlighted;
50 COLORREF m_clrButtonTextNormal;
51 COLORREF m_clrButtonTextDisabled;
52 COLORREF m_clrButtonTextSelected;
53 COLORREF m_clrButtonTextHighlighted;
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif // !defined(__XTPRIBBONBACKSTAGEVIEWTHEMEOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPRibbonBackstageView
CXTPRibbonBackstageView is a CDialog derived class used for a Backstage parent frame.
Definition XTPRibbonBackstageView.h:87


CXTPTreeOffice2013Theme Member List

This is the complete list of members for CXTPTreeOffice2013Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeOffice2013Theme() | CXTPTreeOffice2013Theme |
CXTPTreeTheme() | CXTPTreeTheme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeOffice2013Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: XTPCalendarVisualStudio2022Theme.h Source File

  • Source
  • Calendar
  • Themes
XTPCalendarVisualStudio2022Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARVISUALSTUDIO2022THEME_H__)
23# define __XTPCALENDARVISUALSTUDIO2022THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarVisualStudio2022Theme : public CXTPCalendarOffice2013Theme
37{
38public:
47 CXTPCalendarVisualStudio2022Theme();
48
55 virtual ~CXTPCalendarVisualStudio2022Theme();
56};
57
58# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPCALENDARVISUALSTUDIO2022THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarOffice2013Theme
CXTPCalendarOffice2013Theme is a CXTPCalendarOffice2000Theme derived class that represents the Office...
Definition XTPCalendarOffice2013Theme.h:37
CXTPCalendarVisualStudio2022Theme
CXTPCalendarVisualStudio2022Theme is a CXTPCalendarOffice2013Theme derived class that represents the ...
Definition XTPCalendarVisualStudio2022Theme.h:37
CXTPCalendarVisualStudio2022Theme::~CXTPCalendarVisualStudio2022Theme
virtual ~CXTPCalendarVisualStudio2022Theme()
Default paint manager destructor.
CXTPCalendarVisualStudio2022Theme::CXTPCalendarVisualStudio2022Theme
CXTPCalendarVisualStudio2022Theme()
Default paint manager constructor.


CXTPChartStrings Member List

This is the complete list of members for CXTPChartStrings, including all inherited members.

IndexOf(const CXTPChartString &strValue) const CXTPChartStrings


CXTPFlowGraphUndoDeleteConnectionPointCommand Member List

This is the complete list of members for CXTPFlowGraphUndoDeleteConnectionPointCommand, including all inherited members.

CXTPFlowGraphUndoCommand(int nID) | CXTPFlowGraphUndoCommand | protected
CXTPFlowGraphUndoDeleteConnectionPointCommand(CXTPFlowGraphConnectionPoint *pConnectionPoint) | CXTPFlowGraphUndoDeleteConnectionPointCommand |
GetID() const | CXTPFlowGraphUndoCommand |
m_nID | CXTPFlowGraphUndoCommand | protected
m_pConnectionPoint | CXTPFlowGraphUndoDeleteConnectionPointCommand | protected
m_pNode | CXTPFlowGraphUndoDeleteConnectionPointCommand | protected
Undo() | CXTPFlowGraphUndoDeleteConnectionPointCommand | protectedvirtual
~CXTPFlowGraphUndoCommand() | CXTPFlowGraphUndoCommand | protectedvirtual
~CXTPFlowGraphUndoDeleteConnectionPointCommand() | CXTPFlowGraphUndoDeleteConnectionPointCommand | virtual


CXTPControlStatic Member List

This is the complete list of members for CXTPControlStatic, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlStatic | protectedvirtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlStatic() | CXTPControlStatic |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlStatic | protectedvirtual
Draw(CDC *pDC) | CXTPControlStatic | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlStatic | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControl | virtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControl | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControl | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControlStatic | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


XTP_NM_GRIDITEMMETRICS Member List

This is the complete list of members for XTP_NM_GRIDITEMMETRICS, including all inherited members.

hdr | XTP_NM_GRIDITEMMETRICS
pDrawArgs | XTP_NM_GRIDITEMMETRICS
pItemMetrics | XTP_NM_GRIDITEMMETRICS


Toolkit Pro: XTPSkinManagerDetoursApiHook.h Source File

  • Source
  • SkinFramework
  • ApiHook
XTPSkinManagerDetoursApiHook.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINMANAGERDETOURAPIHOOK_H__) && defined(XTP_SKINFRAMEWORK_USE_DETOURS_API_HOOK)
24# define __XTPSKINMANAGERDETOURAPIHOOK_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
35enum XTPSkinFrameworkDetoursApiFunctionIndex
36{
37 xtpSkinDetoursApiGetProcAddress,
38 xtpSkinDetoursApiGetModuleHandleA,
39 xtpSkinDetoursApiGetModuleHandleW,
40 xtpSkinDetoursApiGetModuleHandleExA,
41 xtpSkinDetoursApiGetModuleHandleExW,
42 xtpSkinDetoursApiCreateThread,
43 xtpSkinDetoursApiRegisterClassA,
44 xtpSkinDetoursApiRegisterClassW,
45 xtpSkinDetoursApiGetSysColor,
46 xtpSkinDetoursApiGetSysColorBrush,
47 xtpSkinDetoursApiDrawEdge,
48 xtpSkinDetoursApiDrawFrameControl,
49 xtpSkinDetoursApiSetScrollInfo,
50 xtpSkinDetoursApiSetScrollPos,
51 xtpSkinDetoursApiGetScrollInfo,
52 xtpSkinDetoursApiEnableScrollBar,
53 xtpSkinDetoursApiSystemParametersInfoA,
54 xtpSkinDetoursApiSystemParametersInfoW,
55 xtpSkinDetoursApiDefWindowProcA,
56 xtpSkinDetoursApiDefWindowProcW,
57 xtpSkinDetoursApiDefMDIChildProcA,
58 xtpSkinDetoursApiDefMDIChildProcW,
59 xtpSkinDetoursApiDefFrameProcA,
60 xtpSkinDetoursApiDefFrameProcW,
61 xtpSkinDetoursApiDefDlgProcA,
62 xtpSkinDetoursApiDefDlgProcW,
63 xtpSkinDetoursApiCallWindowProcA,
64 xtpSkinDetoursApiCallWindowProcW,
65 xtpSkinDetoursApiFillRect,
66 xtpSkinDetoursApiDeleteObject,
67 xtpSkinDetoursApiAdjustWindowRectEx,
68 xtpSkinDetoursApiAdjustWindowRect,
69 xtpSkinDetoursApiGetSystemMetrics,
70 xtpSkinDetoursApiTrackPopupMenu,
71 xtpSkinDetoursApiTrackPopupMenuEx,
72 xtpSkinDetoursApiNtUserTrackPopupMenuEx,
73 xtpSkinDetoursApiDrawMenuBar,
74 xtpSkinDetoursApiGetMenuItemRect,
75 xtpSkinDetoursApiDwmExtendFrameIntoClientArea,
76 xtpSkinDetoursApiOpenThemeData,
77 xtpSkinDetoursApiOpenThemeDataForDpi,
78 xtpSkinDetoursApiOpenThemeDataEx,
79 xtpSkinDetoursApiDrawThemeBackground,
80 xtpSkinDetoursApiCloseThemeData,
81 xtpSkinDetoursApiGetThemeColor,
82 xtpSkinDetoursApiGetThemeInt,
83 xtpSkinDetoursApiIsAppThemed,
84 xtpSkinDetoursApiIsThemeActive,
85 xtpSkinDetoursApiGetCurrentThemeName,
86 xtpSkinDetoursApiGetThemeSysBool,
87 xtpSkinDetoursApiGetThemeSysColor,
88 xtpSkinDetoursApiGetThemePartSize,
89
90 XTP_SKIN_DETOURS_API_HOOK_COUNT
91};
92
93class CXTPSkinManagerDetoursApiHook;
94
96
100class _XTP_EXT_CLASS CXTPSkinManagerDetoursApiFunction : public CXTPSynchronized
101{
102public:
103 CXTPSkinManagerDetoursApiFunction(CXTPSkinManagerDetoursApiHook* pApiHook, HMODULE hModule,
104 LPCSTR pszFuncName, PVOID pfnOrig, PVOID pfnHook);
105
106 virtual ~CXTPSkinManagerDetoursApiFunction();
107
108public:
109 BOOL Hook();
110 BOOL Unhook();
111 BOOL IsHooked() const;
112
113 HMODULE GetModule() const;
114 LPVOID GetOriginal() const;
115 LPVOID GetTrueOriginal() const;
116 LPVOID GetHook() const;
117 LPCSTR GetFunctionName() const;
118
119 static PVOID GetAfxWndProc();
120
121private:
122 CXTPSkinManagerDetoursApiHook* m_pApiHook;
123 HMODULE m_hModule;
124 PVOID m_pfnOrig;
125 PVOID m_pfnHook;
126 PVOID m_pfnTarget;
127 char m_szFuncName[50];
128};
129
130AFX_INLINE BOOL CXTPSkinManagerDetoursApiFunction::IsHooked() const
131{
132 return NULL != m_pfnTarget;
133}
134
135AFX_INLINE HMODULE CXTPSkinManagerDetoursApiFunction::GetModule() const
136{
137 return m_hModule;
138}
139
140AFX_INLINE LPCSTR CXTPSkinManagerDetoursApiFunction::GetFunctionName() const
141{
142 _ASSERTE('\0' != m_szFuncName[0]);
143 return m_szFuncName;
144}
145
146AFX_INLINE LPVOID CXTPSkinManagerDetoursApiFunction::GetOriginal() const
147{
148 return NULL != m_pfnTarget ? m_pfnTarget : m_pfnOrig;
149}
150
151AFX_INLINE LPVOID CXTPSkinManagerDetoursApiFunction::GetTrueOriginal() const
152{
153 return m_pfnOrig;
154}
155
156AFX_INLINE LPVOID CXTPSkinManagerDetoursApiFunction::GetHook() const
157{
158 return m_pfnHook;
159}
160
162
166class _XTP_EXT_CLASS CXTPSkinManagerDetoursApiHook : public CXTPSkinManagerApiHookBase
167{
168 DECLARE_DYNAMIC(CXTPSkinManagerDetoursApiHook);
169
170 struct APIHOOKINFO
171 {
172 XTPSkinFrameworkDetoursApiFunctionIndex nIndex;
173 LPCSTR lpModuleName;
174 LPCSTR lpRoutineName;
175 LPVOID pfnHook;
176 int nApplyOptions;
177 bool (CXTPSystemVersion::*pfnVersionCheck)() const;
178 XTPSkinFrameworkDetoursApiFunctionIndex nDependsOn;
179 };
180
181public:
182 CXTPSkinManagerDetoursApiHook();
183 virtual ~CXTPSkinManagerDetoursApiHook();
184
185 virtual void InitializeHookManagement();
186 virtual void FinalizeHookManagement();
187 virtual void ExcludeModule(LPCTSTR lpszModule, BOOL bWin9x);
188 virtual LPVOID GetOriginalFunctionAddress(int nFunction) const;
189 virtual BOOL AdjustWindowRectExOrig(LPRECT lpRect, DWORD dwStyle, BOOL bMenu, DWORD dwExStyle);
190 virtual LRESULT CallWindowProcOrig(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg, WPARAM wParam,
191 LPARAM lParam);
192 virtual LPVOID GetOpenThemeDataOriginalPtr() const;
193 virtual LPVOID GetCloseThemeDataOriginalPtr() const;
194 virtual void ConnectWrapper(CXTPWinThemeWrapper* pThemeWrapper);
195
196public:
197 BOOL IsModuleExcluded(HMODULE hModule) const;
198 CXTPSkinManagerDetoursApiFunction*
199 GetHookedFunction(XTPSkinFrameworkDetoursApiFunctionIndex nIndex);
200 CXTPSkinManagerDetoursApiFunction* GetHookedFunction(HMODULE hModule, LPCSTR pszFuncName);
201
202private:
203 static CXTPSkinManagerDetoursApiHook* AFX_CDECL GetInstance();
204
205 void UnhookAllFunctions(BOOL bFinal);
206 CXTPSkinManagerDetoursApiFunction* Hook(XTPSkinFrameworkDetoursApiFunctionIndex nIndex,
207 LPCSTR pszModuleName, LPCSTR pszFuncName,
208 LPVOID pfnHook);
209
210 CXTPSkinManagerDetoursApiFunction* AddHook(XTPSkinFrameworkDetoursApiFunctionIndex nIndex,
211 HMODULE hModule, LPCSTR pszFuncName, LPVOID pfnOrig,
212 LPVOID pfnHook);
213
214 BOOL RemoveHook(LPCSTR pszFuncName);
215
216 static DWORD WINAPI ThreadProcHook(LPVOID lpParameter);
217 static CXTPSkinManagerDetoursApiFunction* AFX_CDECL EnterHookedCall(HMODULE hModule,
218 LPCSTR pszFuncName);
219 static CXTPSkinManagerDetoursApiFunction* AFX_CDECL
220 EnterHookedCall(XTPSkinFrameworkDetoursApiFunctionIndex nIndex);
221
222 static FARPROC WINAPI GetProcAddressWindows(HMODULE hModule, LPCSTR pszProcName);
223
224 static FARPROC WINAPI OnHookGetProcAddress(HMODULE hmod, PCSTR pszProcName);
225 static HMODULE WINAPI OnHookGetModuleHandleA(LPCSTR lpModuleName);
226 static HMODULE WINAPI OnHookGetModuleHandleW(LPCWSTR lpModuleName);
227 static HMODULE WINAPI OnHookGetModuleHandleExA(DWORD dwFlags, LPCSTR lpModuleName,
228 HMODULE* phModule);
229 static HMODULE WINAPI OnHookGetModuleHandleExW(DWORD dwFlags, LPCWSTR lpModuleName,
230 HMODULE* phModule);
231 static HANDLE WINAPI OnHookCreateThread(LPSECURITY_ATTRIBUTES lpThreadAttributes,
232 UINT_PTR dwStackSize,
233 LPTHREAD_START_ROUTINE lpStartAddress,
234 LPVOID lpParameter, DWORD dwCreationFlags,
235 LPDWORD lpThreadId);
236
237 static ATOM WINAPI OnHookRegisterClassA(const WNDCLASSA* lpWndClass);
238 static ATOM WINAPI OnHookRegisterClassW(const WNDCLASSW* lpWndClass);
239 static int WINAPI OnHookSetScrollInfo(HWND hwnd, int fnBar, LPCSCROLLINFO lpsi, BOOL fRedraw);
240 static int WINAPI OnHookSetScrollPos(HWND hwnd, int nBar, int nPos, BOOL redraw);
241 static BOOL WINAPI OnHookAdjustWindowRectEx(LPRECT lpRect, DWORD dwStyle, BOOL bMenu,
242 DWORD dwExStyle);
243 static BOOL WINAPI OnHookAdjustWindowRect(LPRECT lpRect, DWORD dwStyle, BOOL bMenu);
244 static int WINAPI OnHookGetSystemMetrics(int nIndex);
245 static BOOL WINAPI OnHookEnableScrollBar(HWND hWnd, UINT wSBflags, UINT wArrows);
246 static BOOL WINAPI OnHookGetScrollInfo(HWND hwnd, int nBar, LPSCROLLINFO lpsi);
247 static DWORD WINAPI OnHookGetSysColor(int nIndex);
248 static BOOL WINAPI OnHookDeleteObject(HGDIOBJ hObject);
249 static BOOL WINAPI OnHookDrawEdge(HDC hdc, LPRECT qrc, UINT edge, UINT grfFlags);
250 static BOOL WINAPI OnHookDrawFrameControl(HDC hDC, LPRECT rect, UINT, UINT);
251 static HBRUSH WINAPI OnHookGetSysColorBrush(int nIndex);
252 static BOOL WINAPI OnHookSystemParametersInfoA(UINT uiAction, UINT uiParam, PVOID pvParam,
253 UINT fWinIni);
254 static BOOL WINAPI OnHookSystemParametersInfoW(UINT uiAction, UINT uiParam, PVOID pvParam,
255 UINT fWinIni);
256 static LRESULT WINAPI OnHookDefWindowProcA(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
257 static LRESULT WINAPI OnHookDefWindowProcW(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
258 static LRESULT WINAPI OnHookDefFrameProcA(HWND hWnd, HWND hWndMDIClient, UINT Msg,
259 WPARAM wParam, LPARAM lParam);
260 static LRESULT WINAPI OnHookDefFrameProcW(HWND hWnd, HWND hWndMDIClient, UINT Msg,
261 WPARAM wParam, LPARAM lParam);
262 static LRESULT WINAPI OnHookDefDlgProcA(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
263 static LRESULT WINAPI OnHookDefDlgProcW(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
264 static LRESULT WINAPI OnHookDefMDIChildProcA(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
265 static LRESULT WINAPI OnHookDefMDIChildProcW(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam);
266 static LRESULT WINAPI OnHookCallWindowProcA(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg,
267 WPARAM wParam, LPARAM lParam);
268 static LRESULT WINAPI OnHookCallWindowProcW(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg,
269 WPARAM wParam, LPARAM lParam);
270 static int WINAPI OnHookFillRect(HDC hDC, CONST RECT* lprc, HBRUSH hbr);
271 static BOOL WINAPI OnHookTrackPopupMenu(HMENU hMenu, UINT uFlags, int x, int y, int nReserved,
272 HWND hWnd, CONST RECT* prcRect);
273 static BOOL WINAPI OnHookTrackPopupMenuExImpl(
274 XTPSkinFrameworkDetoursApiFunctionIndex nFunctionIndex, HMENU hMenu, UINT uFlags, int x,
275 int y, HWND hWnd, LPTPMPARAMS lptpParams);
276 static BOOL WINAPI OnHookTrackPopupMenuEx(HMENU hMenu, UINT uFlags, int x, int y, HWND hWnd,
277 LPTPMPARAMS lptpParams);
278 static BOOL WINAPI OnHookNtUserTrackPopupMenuEx(HMENU hMenu, UINT uFlags, int x, int y,
279 HWND hWnd, LPTPMPARAMS lptpParams);
280 static BOOL WINAPI OnHookDrawMenuBar(HWND hWnd);
281 static BOOL WINAPI OnHookGetMenuItemRect(HWND hWnd, HMENU hMenu, UINT uItem, LPRECT lprcItem);
282 static HRESULT WINAPI OnHookDwmExtendFrameIntoClientArea(HWND hWnd, LPCVOID pMarInset);
283
284 static HTHEME STDAPICALLTYPE OnHookOpenThemeData(HWND hWnd, LPCWSTR pszClassList);
285 static HTHEME STDAPICALLTYPE OnHookOpenThemeDataForDpi(HWND hwnd, LPCWSTR pszClassList,
286 UINT dpi);
287 static HTHEME STDAPICALLTYPE OnHookOpenThemeDataEx(HWND hwnd, LPCWSTR pszClassList,
288 DWORD dwFlags);
289 static HRESULT STDAPICALLTYPE OnHookCloseThemeData(HTHEME);
290
291 static HRESULT STDAPICALLTYPE OnHookGetCurrentThemeName(LPWSTR pszThemeFileName,
292 int dwMaxNameChars, LPWSTR pszColorBuff,
293 int cchMaxColorChars,
294 LPWSTR pszSizeBuff,
295 int cchMaxSizeChars);
296 static BOOL STDAPICALLTYPE OnHookGetThemeSysBool(HTHEME hTheme, int iBoolId);
297 static COLORREF STDAPICALLTYPE OnHookGetThemeSysColor(HTHEME hTheme, int iColorId);
298 static HRESULT STDAPICALLTYPE OnHookGetThemePartSize(HTHEME hTheme, HDC, int iPartId,
299 int iStateId, RECT* pRect, THEMESIZE eSize,
300 SIZE* pSize);
301 static BOOL STDAPICALLTYPE OnHookIsAppThemed();
302 static BOOL STDAPICALLTYPE OnHookIsThemeActive();
303 static HRESULT STDAPICALLTYPE OnHookGetThemeColor(HTHEME hTheme, int iPartId, int iStateId,
304 int iPropID, COLORREF* pColor);
305 static HRESULT STDAPICALLTYPE OnHookGetThemeInt(HTHEME hTheme, int iPartId, int iStateId,
306 int iPropID, int* piVal);
307 static HRESULT STDAPICALLTYPE OnHookDrawThemeBackground(HTHEME hTheme, HDC hDC, int iPartId,
308 int iStateId, const RECT* pRect,
309 const RECT*);
310
311private:
312 CXTPSkinManagerDetoursApiFunction* m_arrFunctions[XTP_SKIN_DETOURS_API_HOOK_COUNT];
313 static BOOL m_bInitialized;
314 long m_nLockCondition;
315 CMap<HMODULE, HMODULE, LONG, LONG> m_mapModuleRefCount;
316 CXTPThreadLocal<int> m_HackModuleOnLoadCounter;
317 static const APIHOOKINFO m_apiHookInfos[];
318 static CXTPModuleHandle m_hUxTheme;
319
320 friend class CXTPSkinManagerDetoursApiFunction;
321};
322
325# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
327#endif // !defined(__XTPSKINMANAGERDETOURAPIHOOK_H__) &&
328 // defined(XTP_SKINFRAMEWORK_USE_DETOURS_API_HOOK)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPModuleHandle
CXTPModuleHandle class is helper for LoadLibray/GetModuleHandle methods.
Definition XTPSystemHelpers.h:80
CXTPSynchronized
A base class for a synchronized object.
Definition XTPSynchro.h:602
CXTPSystemVersion
CXTPSystemVersion is used to get the current Windows OS version.
Definition XTPSystemHelpers.h:279
CXTPThreadLocal
Implements thread local variable adapter.
Definition XTPSystemHelpers.h:1676
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188


Toolkit Pro: XTPGridThemeOffice2003Luna.h Source File

  • Source
  • GridControl
  • Themes
XTPGridThemeOffice2003Luna.h
Go to the documentation of this file.
1
23#if !defined(__XTPGridThemeOffice2003Luna_H__)
24# define __XTPGridThemeOffice2003Luna_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPGridThemeOffice2003Luna : public CXTPGridPaintManager
39{
40public:
45 CXTPGridThemeOffice2003Luna();
46
52 virtual void RefreshMetrics();
53
60 virtual void FillFooter(CDC* pDC, CRect rcFooter);
61
73 virtual BOOL IsColumHotTrackingEnabled() const;
74
86 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
87 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
88 CXTPGridHeader* pHeader = NULL);
89
97 virtual void DrawColumnFooterDivider(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn);
98
111 void DrawSectionDivider(CDC* pDC, const CRect& rc,
112 XTPGridSectionDividerPosition dividerPosition,
113 XTPGridSectionDividerStyle dividerStyle,
114 CXTPPaintManagerColor dividerColor);
115};
117# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif //#if !defined(__XTPGridThemeOffice2003Luna_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager
Utility class that handles most drawing activities.
Definition XTPGridPaintManager.h:76
CXTPGridThemeOffice2003Luna
CXTPGridThemeOffice2003Luna is a CXTPGridPaintManager derived class that represents an Office 2003 Lu...
Definition XTPGridThemeOffice2003Luna.h:39
CXTPGridThemeOffice2003Luna::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPGridThemeOffice2003Luna::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPGridThemeOffice2003Luna::IsColumHotTrackingEnabled
virtual BOOL IsColumHotTrackingEnabled() const
Determines if hot tracking is enabled for the current column style.
CXTPGridThemeOffice2003Luna::FillFooter
virtual void FillFooter(CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
CXTPGridThemeOffice2003Luna::DrawColumnFooterDivider
virtual void DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
CXTPGridThemeOffice2003Luna::CXTPGridThemeOffice2003Luna
CXTPGridThemeOffice2003Luna()
Default paint manager constructor, handles properties initialization.
CXTPGridThemeOffice2003Luna::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the Grid control.
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


CXTPChartScatterLineSeriesStyle Member List

This is the complete list of members for CXTPChartScatterLineSeriesStyle, including all inherited members.

ApplyTo(CXTPChartDeviceCommand *pCommand) | CXTPChartSeriesStyle | virtual
CorrectAxisSideMargins(CXTPChartAxis *pAxis, double nMinValue, double nMaxValue, double &nCorrection) | CXTPChartSeriesStyle | virtual
CreateDiagram() | CXTPChartDiagram2DSeriesStyle | virtual
CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView) | CXTPChartScatterLineSeriesStyle | protectedvirtual
CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle |
CXTPChartElement() | CXTPChartElement |
CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle |
CXTPChartScatterLineSeriesStyle() | CXTPChartScatterLineSeriesStyle |
CXTPChartSeriesStyle() | CXTPChartSeriesStyle |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartLineSeriesStyle | protectedvirtual
Enable3dEdgeSmoothing(BOOL bEnable=TRUE) | CXTPChartSeriesStyle | virtual
Get3dRotation() const | CXTPChartSeriesStyle | virtual
GetAppearance() const | CXTPChartElement |
GetColor() const | CXTPChartSeriesStyle | virtual
GetContent() const | CXTPChartElement |
GetErrorBar() const | CXTPChartSeriesStyle | virtual
GetLabel() const | CXTPChartSeriesStyle | virtual
GetLineStyle() const | CXTPChartLineSeriesStyle |
GetMarker() const | CXTPChartPointSeriesStyle |
GetOwner() const | CXTPChartElement |
GetSeriesPointValueIndex() const | CXTPChartSeriesStyle | virtual
GetStyleAppearance() const | CXTPChartSeriesStyle | virtual
GetTransparency() const | CXTPChartSeriesStyle | virtual
Is3D() const | CXTPChartObject |
Is3dEdgeSmoothingEnabled() const | CXTPChartSeriesStyle | virtual
IsColorEach() const | CXTPChartSeriesStyle | virtual
IsStyleDiagram(CXTPChartDiagram *pDiagram) const | CXTPChartDiagram2DSeriesStyle | virtual
m_bColorEach | CXTPChartSeriesStyle | protected
m_bSmooth3dEdges | CXTPChartSeriesStyle | protected
m_clrColor | CXTPChartSeriesStyle | protected
m_nAxisIndexX | CXTPChartDiagram2DSeriesStyle | protected
m_nAxisIndexY | CXTPChartDiagram2DSeriesStyle | protected
m_nTransparency | CXTPChartSeriesStyle | protected
m_pErrorBar | CXTPChartSeriesStyle | protected
m_pLabel | CXTPChartSeriesStyle | protected
m_pLineStyle | CXTPChartLineSeriesStyle | protected
m_Rotation3d | CXTPChartSeriesStyle | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
Set3dRotation(const CXTPChart3dRotation &rotation) | CXTPChartSeriesStyle | virtual
Set3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChartSeriesStyle | virtual
SetColor(CXTPChartColor clr) | CXTPChartSeriesStyle | virtual
SetColorEach(BOOL bColorEach) | CXTPChartSeriesStyle | virtual
SetErrorBar(CXTPChartErrorBar *pErrorBar) | CXTPChartSeriesStyle | virtual
SetLabel(CXTPChartSeriesLabel *pLabel) | CXTPChartSeriesStyle | virtual
SetTransparency(int nTransparency) | CXTPChartSeriesStyle | virtual
~CXTPChartDiagram2DSeriesStyle() | CXTPChartDiagram2DSeriesStyle | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartLineSeriesStyle() | CXTPChartLineSeriesStyle | virtual
~CXTPChartPointSeriesStyle() | CXTPChartPointSeriesStyle | virtual
~CXTPChartScatterLineSeriesStyle() | CXTPChartScatterLineSeriesStyle | virtual
~CXTPChartSeriesStyle() | CXTPChartSeriesStyle | virtual


Toolkit Pro: XTPComboBoxThemeVisualStudio2010.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeVisualStudio2010.h
Go to the documentation of this file.
1
23#ifndef XTPComboBoxThemeVisualStudio2010_h__
24# define XTPComboBoxThemeVisualStudio2010_h__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeVisualStudio2010 : public CXTPComboBoxThemeVisualStudio
39{
40public:
45 CXTPComboBoxThemeVisualStudio2010();
46
51 virtual ~CXTPComboBoxThemeVisualStudio2010();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60};
61
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif // XTPComboBoxThemeVisualStudio2010_h__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeVisualStudio2010
Used as the paint manager for a combobox control to render a Visual Studio 2010 appearance.
Definition XTPComboBoxThemeVisualStudio2010.h:39
CXTPComboBoxThemeVisualStudio2010::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeVisualStudio2010::~CXTPComboBoxThemeVisualStudio2010
virtual ~CXTPComboBoxThemeVisualStudio2010()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeVisualStudio2010::CXTPComboBoxThemeVisualStudio2010
CXTPComboBoxThemeVisualStudio2010()
Default constructor.
CXTPComboBoxThemeVisualStudio
Used as the paint manager for a combobox control to render a Visual Studio appearance.
Definition XTPComboBoxThemeVisualStudio.h:39


Toolkit Pro: XTPTabThemeVisio.h Source File

  • Source
  • TabManager
  • Themes
XTPTabThemeVisio.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABTHEMEVISIO_H__)
24# define __XTPTABTHEMEVISIO_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
47class _XTP_EXT_CLASS CAppearanceSetVisio : public CXTPTabPaintManagerTheme
48{
49public:
70 void AdjustClientRect(CXTPTabManager* pTabManager, CRect& rcClient);
71
86 void RepositionTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcClient);
87
101 CRect GetHeaderRect(CRect rcControl, CXTPTabManager* pTabManager);
102
113 CRect GetClientRect(CRect rcControl, CXTPTabManager* pTabManager);
114
130 void DrawSingleButton(CDC* pDC, CXTPTabManagerItem* pItem);
131
144 void DrawTabControl(CXTPTabManager* pTabManager, CDC* pDC, CRect rcControl);
145};
146
147# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
149#endif // !defined(__XTPTABTHEMEVISIO_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CAppearanceSetVisio
CAppearanceSetVisio implements a Visio tab appearance.
Definition XTPTabThemeVisio.h:48
CAppearanceSetVisio::GetClientRect
CRect GetClientRect(CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab client area.
CAppearanceSetVisio::DrawSingleButton
void DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem)
Draws a single tab button in the tab client header area.
CAppearanceSetVisio::AdjustClientRect
void AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient)
Adjusts the tab client rectangle.
CAppearanceSetVisio::GetHeaderRect
CRect GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager)
Gets the bounding rectangle of the tab header area.
CAppearanceSetVisio::RepositionTabControl
void RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient)
Moves the tab buttons of the tab control to their correct positions.
CAppearanceSetVisio::DrawTabControl
void DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl)
Draws the tab control.
CXTPTabManager
CXTPTabManager is the base class for docking pane tabs, tab control tabs, and MDI client tabs.
Definition XTPTabManager.h:87
CXTPTabManagerItem
CXTPTabManagerItem is the base class for the tabs that appear in the command bars tab workspace,...
Definition XTPTabManagerItem.h:44
CXTPTabPaintManagerTheme
CXTPTabPaintManagerTheme is a class that represents the appearance of all components of the tab manag...
Definition XTPTabPaintManagerTheme.h:56


CXTPCalendarOptions Member List

This is the complete list of members for CXTPCalendarOptions, including all inherited members.

bDayView_AdditionalScaleLeftVisible | CXTPCalendarOptions |
bDayView_AdditionalScaleRightVisible | CXTPCalendarOptions |
bDayView_AutoResetBusyFlag | CXTPCalendarOptions |
bDayView_DrawNowLineOverAppoinment | CXTPCalendarOptions |
bDayView_ScaleLeftVisible | CXTPCalendarOptions |
bDayView_ScaleRightVisible | CXTPCalendarOptions |
bDayView_TimeScaleShowMinutes | CXTPCalendarOptions |
bEnableAddNewTooltip | CXTPCalendarOptions |
bEnableInPlaceCreateEvent | CXTPCalendarOptions |
bEnableInPlaceEditEventSubject_AfterEventResize | CXTPCalendarOptions |
bEnableInPlaceEditEventSubject_ByF2 | CXTPCalendarOptions |
bEnableInPlaceEditEventSubject_ByMouseClick | CXTPCalendarOptions |
bEnableInPlaceEditEventSubject_ByTab | CXTPCalendarOptions |
bEnablePrevNextEventButtons | CXTPCalendarOptions |
bHatchAllDayViewEventsBkgnd | CXTPCalendarOptions |
bMonthView_CompressWeekendDays | CXTPCalendarOptions |
bMonthView_HideTimes | CXTPCalendarOptions |
bMonthView_ShowEndDate | CXTPCalendarOptions |
bMonthView_ShowTimeAsClocks | CXTPCalendarOptions |
bShowAllDayExpandButton | CXTPCalendarOptions |
bShowCategoryIcons | CXTPCalendarOptions |
bTimeLineCompact | CXTPCalendarOptions |
bTimeLineFocused | CXTPCalendarOptions |
bUseOutlookFontGlyphs | CXTPCalendarOptions |
bWeekView_ShowEndDate | CXTPCalendarOptions |
bWeekView_ShowTimeAsClocks | CXTPCalendarOptions |
CXTPCalendarOptions() | CXTPCalendarOptions |
CXTPCmdTarget() | CXTPCmdTarget |
DoPropExchange(CXTPPropExchange *pPX) | CXTPCalendarOptions |
dtScaleMaxTime | CXTPCalendarOptions |
dtScaleMinTime | CXTPCalendarOptions |
dtWorkDayEndTime | CXTPCalendarOptions |
dtWorkDayStartTime | CXTPCalendarOptions |
dwAdditionalOptions | CXTPCalendarOptions |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetCurrentTimeZoneInfo() | CXTPCalendarOptions |
m_pDataProvider | CXTPCalendarOptions | protected
nDayView_CurrentTimeMarkVisible | CXTPCalendarOptions |
nDayView_ScaleInterval | CXTPCalendarOptions |
nFirstDayOfTheWeek | CXTPCalendarOptions |
nWorkWeekMask | CXTPCalendarOptions |
OnOptionsChanged() | CXTPCalendarOptions |
SetDataProvider(CXTPCalendarData *pDataProvider) | CXTPCalendarOptions |
strDayView_AdditionalScaleLabel | CXTPCalendarOptions |
strDayView_ScaleLabel | CXTPCalendarOptions |
strTooltipAddNewText | CXTPCalendarOptions |
tziDayView_AdditionalScaleTimeZone | CXTPCalendarOptions |
~CXTPCalendarOptions() | CXTPCalendarOptions | virtual


CXTPLogFont Member List

This is the complete list of members for CXTPLogFont, including all inherited members.

CXTPLogFont() | CXTPLogFont
CXTPLogFont(const CXTPLogFont &rhs) | CXTPLogFont
CXTPLogFont(const LOGFONT &logFont) | CXTPLogFont
dwType | CXTPLogFont
operator=(const CXTPLogFont &rhs) | CXTPLogFont
operator=(const LOGFONT &logFont) | CXTPLogFont


CXTPMDIClientWnd Member List

This is the complete list of members for CXTPMDIClientWnd, including all inherited members.

CXTPMDIClientWnd(CXTPMDIWndTab *pMDIWndTab) | CXTPMDIClientWnd |
m_iBorderGap | CXTPMDIClientWnd | protected
m_pMDIWndTab | CXTPMDIClientWnd | protected
SetBorderGap(int iSize) | CXTPMDIClientWnd |
~CXTPMDIClientWnd() | CXTPMDIClientWnd | virtual


CXTPMarkupButton Member List

This is the complete list of members for CXTPMarkupButton, including all inherited members.

ApplyRenderTransform(CXTPMarkupDrawingContext *pContext) | CXTPMarkupUIElement | protectedvirtual
Arrange(CRect rcFinalRect) | CXTPMarkupUIElement |
ArrangeCore(CRect rcFinalRect) | CXTPMarkupUIElement | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupButton() | CXTPMarkupButton | protected
CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
CXTPMarkupContentControl() | CXTPMarkupContentControl | protected
CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protected
CXTPMarkupUIElement() | CXTPMarkupUIElement | protected
CXTPMarkupVisual() | CXTPMarkupVisual |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAbsoluteVisualOffset() const | CXTPMarkupVisual | protected
GetActualSize() const | CXTPMarkupFrameworkElement |
GetBackground() const | CXTPMarkupControl |
GetBoundRect() const | CXTPMarkupVisual |
GetClipToBounds() const | CXTPMarkupFrameworkElement |
GetContent() const | CXTPMarkupContentControl |
GetDesiredSize() const | CXTPMarkupUIElement |
GetFinalRect() const | CXTPMarkupUIElement |
GetForeground() const | CXTPMarkupControl |
GetHeight() const | CXTPMarkupFrameworkElement |
GetHorizontalAlignment() const | CXTPMarkupFrameworkElement |
GetLayoutClip(CRect &rc) const | CXTPMarkupUIElement | protectedvirtual
GetLogicalChild(int nIndex) const | CXTPMarkupVisual | virtual
GetLogicalChildrenCount() const | CXTPMarkupVisual | virtual
GetMargin() const | CXTPMarkupFrameworkElement |
GetMaxHeight() const | CXTPMarkupFrameworkElement |
GetMaxWidth() const | CXTPMarkupFrameworkElement |
GetMinHeight() const | CXTPMarkupFrameworkElement |
GetMinWidth() const | CXTPMarkupFrameworkElement |
GetOpacity() const | CXTPMarkupUIElement | protectedvirtual
GetPadding() const | CXTPMarkupControl |
GetRenderSize() const | CXTPMarkupVisual |
GetRenderTransform() const | CXTPMarkupUIElement | protected
GetStyle() const | CXTPMarkupFrameworkElement |
GetTag() const | CXTPMarkupFrameworkElement |
GetUpdateRect() const | CXTPMarkupVisual |
GetVerticalAlignment() const | CXTPMarkupFrameworkElement |
GetVisibility() const | CXTPMarkupUIElement |
GetVisualChild(int nIndex) const | CXTPMarkupVisual | virtual
GetVisualChildrenCount() const | CXTPMarkupVisual | virtual
GetVisualOffset() const | CXTPMarkupVisual |
GetVisualParent() const | CXTPMarkupVisual |
GetWidth() const | CXTPMarkupFrameworkElement |
InputHitTest(CPoint point) const | CXTPMarkupVisual |
InputHitTestOverride(CPoint point) const | CXTPMarkupVisual | protectedvirtual
InvalidateArrange() | CXTPMarkupUIElement | virtual
InvalidateMeasure() | CXTPMarkupUIElement | virtual
InvalidateMeasureOverride(CXTPMarkupDrawingContext *pDC) | CXTPMarkupUIElement | protectedvirtual
InvalidateVisual() | CXTPMarkupUIElement | virtual
IsEnabled() const | CXTPMarkupUIElement |
IsFocusable() const | CXTPMarkupUIElement |
IsPressed() const | CXTPMarkupButtonBase |
IsVisible() const | CXTPMarkupUIElement | virtual
m_bArrangeDirty | CXTPMarkupUIElement | protected
m_bArrangeInProgress | CXTPMarkupUIElement | protected
m_bMeasureDirty | CXTPMarkupUIElement | protected
m_bMeasureInProgress | CXTPMarkupUIElement | protected
m_bNeverArranged | CXTPMarkupUIElement | protected
m_bNeverMeasured | CXTPMarkupUIElement | protected
m_pClipToBoundsProperty | CXTPMarkupUIElement | static
m_pFocusableProperty | CXTPMarkupUIElement | static
m_pIsEnabledProperty | CXTPMarkupUIElement | static
m_pOpacityProperty | CXTPMarkupUIElement | static
m_pRenderTransformOriginProperty | CXTPMarkupUIElement | static
m_pRenderTransformProperty | CXTPMarkupUIElement | static
m_ptVisualOffset | CXTPMarkupVisual | protected
m_pVisibilityProperty | CXTPMarkupUIElement | static
m_rcBoundRect | CXTPMarkupVisual | protected
m_rcFinalRect | CXTPMarkupUIElement | protected
m_rcPrevUpdateRect | CXTPMarkupVisual | protected
m_rcUpdateRect | CXTPMarkupVisual | protected
m_szDesiredSize | CXTPMarkupUIElement | protected
m_szPreviousAvailableSize | CXTPMarkupUIElement | protected
m_szRenderSize | CXTPMarkupVisual | protected
Measure(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement |
MeasureCore(CXTPMarkupDrawingContext *pDC, CSize szAvailableSize) | CXTPMarkupUIElement | protectedvirtual
OnClick() | CXTPMarkupButtonBase | protectedvirtual
OnRender(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
PtInRectTransform(const RECT &rect, const POINT &point) const | CXTPMarkupVisual | protected
Render(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual |
RenderClipped(CXTPMarkupDrawingContext *drawingContext) | CXTPMarkupVisual | protectedvirtual
RestoreRenderTransform(CXTPMarkupDrawingContext *pContext, TransformationMatrices &matrices) | CXTPMarkupUIElement | protectedvirtual
SetBackground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetClipToBounds(BOOL bClipToBounds) | CXTPMarkupFrameworkElement |
SetContent(CXTPMarkupUIElement *pContent) | CXTPMarkupContentControl |
SetForeground(CXTPMarkupBrush *pBrush) | CXTPMarkupControl |
SetHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetHorizontalAlignment(XTPMarkupHorizontalAlignment alignment) | CXTPMarkupFrameworkElement |
SetMargin(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupFrameworkElement |
SetMargin(int nMargin) | CXTPMarkupFrameworkElement |
SetMaxHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMaxWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetMinHeight(int nHeight) | CXTPMarkupFrameworkElement |
SetMinWidth(int nWidth) | CXTPMarkupFrameworkElement |
SetPadding(int nLeft, int nTop, int nRight, int nBottom) | CXTPMarkupControl |
SetPadding(int nPadding) | CXTPMarkupControl |
SetTag(CXTPMarkupObject *pTag) | CXTPMarkupFrameworkElement |
SetVerticalAlignment(XTPMarkupVerticalAlignment alignment) | CXTPMarkupFrameworkElement |
SetVisibility(XTPMarkupVisibility visibility) | CXTPMarkupUIElement |
SetWidth(int nWidth) | CXTPMarkupFrameworkElement |
~CXTPMarkupButton() | CXTPMarkupButton | protectedvirtual
~CXTPMarkupButtonBase() | CXTPMarkupButtonBase | protected
~CXTPMarkupContentControl() | CXTPMarkupContentControl | protectedvirtual
~CXTPMarkupFrameworkElement() | CXTPMarkupFrameworkElement | protectedvirtual
~CXTPMarkupUIElement() | CXTPMarkupUIElement | protectedvirtual
~CXTPMarkupVisual() | CXTPMarkupVisual | virtual


Toolkit Pro: XTPCalendarDayView.h Source File

  • Source
  • Calendar
XTPCalendarDayView.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARDAYVIEW_H__)
23# define _XTPCALENDARDAYVIEW_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarDayViewTimeScale;
32class CXTPCalendarDayViewDay;
33class CXTPCalendarTimeZone;
35 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarTimeZone)
61class _XTP_EXT_CLASS CXTPCalendarDayView : public CXTPCalendarViewT<CXTPCalendarDayViewDay>
62{
63 friend class CXTPCalendarDayViewDay;
64 friend class CXTPCalendarDayViewGroup;
65 friend class CXTPCalendarDayViewTimeScale;
66
67 friend class CXTPCalendarControl;
68 friend class CXTPCalendarControlView;
69 friend class CXTPCalendarTheme;
71 DECLARE_DYNAMIC(CXTPCalendarDayView)
73public:
78 typedef CXTPCalendarViewT<CXTPCalendarDayViewDay> TBase;
79
88 CXTPCalendarDayView(CXTPCalendarControl* pCalendarControl);
89
97 virtual ~CXTPCalendarDayView();
98
107 virtual XTPCalendarViewType GetViewType() const;
108
125 virtual void AdjustLayout(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
126
143 virtual void AdjustLayout2(CDC* pDC, const CRect& rcView, BOOL bCallPostAdjustLayout = TRUE);
144
156 virtual BOOL GetScrollBarInfoV(SCROLLINFO* pSI) const;
157
170 virtual BOOL GetScrollBarInfoH(SCROLLINFO* pSI, int* pnScrollStep = NULL) const;
171
179 virtual void ScrollV(int nPos, int nPos_raw);
180
188 virtual void ScrollH(int nPos, int nPos_raw);
189
208 virtual int GetMinColumnWidth() const;
209
229 virtual void SetMinColumnWidth(int nWidth);
230
238 virtual void OnDraw(CDC* pDC);
239
252 virtual void Draw(CDC* pDC);
253
268 virtual void Draw2(CDC* pDC);
269
285 virtual BOOL OnLButtonDown(UINT nFlags, CPoint point);
286
302 virtual BOOL OnLButtonUp(UINT nFlags, CPoint point);
303
317 virtual void OnMouseMove(UINT nFlags, CPoint point);
318
333 virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
334
349 virtual COleDateTime GetViewDayDate(int nIndex) const;
350
364 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const;
365
373 int GetVisibleRowCount() const;
374
381 int GetTopRow() const;
382
389 int GetRowCount() const;
390
398 COleDateTimeSpan GetScaleInterval() const;
399
407 void SetScaleInterval(const COleDateTimeSpan spScaleInterval);
408
416 COleDateTime GetScaleMinTime() const;
417
430 void SetScaleMinTime(const COleDateTime dtNewScaleMinTime);
431
439 COleDateTime GetScaleMaxTime() const;
440
453 void SetScaleMaxTime(const COleDateTime dtNewScaleMaxTime);
454
463 void SetScaleText(LPCTSTR strText);
464
472 CString GetScaleText() const;
473
481 void SetAdditionalScaleText(LPCTSTR strText);
482
484 _XTP_DEPRECATED_IN_FAVOR(SetAdditionalScaleText)
485 void SetScale2Text(LPCTSTR strText)
486 {
487 SetAdditionalScaleText(strText);
488 }
498 CString GetAdditionalScaleText() const;
499
501 _XTP_DEPRECATED_IN_FAVOR(GetAdditionalScaleText)
502 CString GetScale2Text() const
503 {
504 return GetAdditionalScaleText();
505 }
523 void SetAdditionalScaleTimeZone(const TIME_ZONE_INFORMATION* pTzInfo);
524
526 _XTP_DEPRECATED_IN_FAVOR(SetAdditionalScaleTimeZone)
527 void SetScale2TimeZone(const TIME_ZONE_INFORMATION* pTzInfo)
528 {
529 SetAdditionalScaleTimeZone(pTzInfo);
530 }
540 const TIME_ZONE_INFORMATION& GetAdditionalScaleTimeZone() const;
541
543 _XTP_DEPRECATED_IN_FAVOR(GetAdditionalScaleTimeZone)
544 const TIME_ZONE_INFORMATION& GetScale2TimeZone() const
545 {
546 return GetAdditionalScaleTimeZone();
547 }
562 CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo() const;
563
576 CXTPCalendarTimeZonePtr GetAdditionalScaleTimeZoneInfo() const;
577
579 _XTP_DEPRECATED_IN_FAVOR(GetAdditionalScaleTimeZoneInfo)
580 CXTPCalendarTimeZonePtr GetScale2TimeZoneInfo() const
581 {
582 return GetAdditionalScaleTimeZoneInfo();
583 }
595 void ShowAdditionalScale(BOOL bShow = TRUE);
596
598 _XTP_DEPRECATED_IN_FAVOR(ShowAdditionalScale)
599 void ShowScale2(BOOL bShow = TRUE)
600 {
601 ShowAdditionalScale(bShow);
602 }
614 BOOL IsScaleLeftVisible() const;
615
625 BOOL IsScaleRightVisible() const;
626
636 BOOL IsAdditionalScaleLeftVisible() const;
637
639 _XTP_DEPRECATED_IN_FAVOR(IsAdditionalScaleLeftVisible)
640 BOOL IsScale2Visible() const
641 {
642 return IsAdditionalScaleLeftVisible();
643 }
655 BOOL IsAdditionalScaleRightVisible() const;
656
666 BOOL IsDrawNowLineOverAppoinment() const;
667
677 BOOL IsExpandUp() const;
678
688 BOOL IsExpandDown() const;
689
700 COleDateTime GetCellTime(int nCell) const;
701
709 COleDateTimeSpan GetCellDuration() const;
710
726 int GetCellNumber(COleDateTime dtTime, BOOL bForEndTime) const;
727
744 int GetCellNumber(int nHour, int nMin, int nSec, BOOL bForEndTime) const;
745
770 virtual BOOL GetSelection(COleDateTime* pBegin = NULL, COleDateTime* pEnd = NULL,
771 BOOL* pbAllDayEvent = NULL, int* pnGroupIndex = NULL,
772 COleDateTimeSpan* pspSelectionResolution = NULL) const;
773
787 virtual void ShowDay(const COleDateTime& date, BOOL bSelect = TRUE);
788
803 virtual void ShowDays(const COleDateTime& dtBegin, const COleDateTime& dtEnd);
804
816 virtual void ShowWorkingDays(const COleDateTime& dtDay);
817
829 virtual void AddDay(const COleDateTime& date);
830
847 virtual BOOL EnsureVisible(CXTPCalendarViewEvent* pViewEvent);
848
865 virtual BOOL EnsureVisibleH(CXTPCalendarViewEvent* pViewEvent);
866
883 virtual BOOL EnsureVisibleH(CXTPCalendarViewGroup* pViewGroup);
884
893 virtual void ScrollToWorkDayBegin();
894
906 virtual BOOL IsGroupHeaderVisible() const;
907
923 virtual CXTPCalendarDayViewTimeScale* GetTimeScale(int nNumber = 1) const;
924
941 virtual CXTPCalendarDayViewDay* GetDay(COleDateTime dtDay);
942
957 virtual void ScrollDaysToPrev(int nScrollDaysCount = 1);
958
973 virtual void ScrollDaysToNext(int nScrollDaysCount = 1);
974
982 void ScrollToColumn(long lColumn);
983
984 COleDateTime GetDateTimeDay(const COleDateTime& dt) const;
985 COleDateTime GetDateTimeTime(const COleDateTime& dt) const;
986
987 COleDateTime m_dtTimeScaleMin;
988 COleDateTime m_dtTimeScaleMax;
990 BOOL m_bDraftMode;
994 BOOL m_bPrintRepeatHeaderFooterMode;
998 BOOL m_bDF_mode;
1001 BOOL m_bPrintFullScale;
1003 int m_nDayViewPrintInterval;
1005 BOOL m_bEcoAllDayMode;
1007 BOOL m_bPreventDragAllDayEventInDayView;
1010 int m_nDayHeaderPeriod;
1014 int m_nCurPage;
1016 BOOL m_bUseNewHitTestCode;
1018 BOOL m_bShowLinks;
1019 BOOL m_bHideLinkContainer;
1021 BOOL m_bShowAllDayEventsOnly;
1023 virtual void AdjustAllDayEvents();
1024
1025 CRect GetDayHeaderRectangle() const;
1026 CRect GetAllDayEventsRectangle() const;
1027
1028 void SetIsHideAllDayEventsArea(BOOL bHide);
1029 BOOL GetIsHideAllDayEventsArea() const;
1030
1031 virtual int GetAllDayEventsMaxCount() const;
1032 virtual int GetTotalGroupsCount() const;
1033 virtual int RecalcMinColumnWidth() const;
1034
1035protected:
1044 virtual void StopVertEventScroll();
1045
1054 virtual void StopHorzEventScroll();
1055
1064 BOOL GetIsCanHScrollGroupsLeft(COleDateTime dtNewSelEnd, BOOL bVKShift);
1065
1074 BOOL GetIsCanHScrollGroupsRight(COleDateTime dtNewSelEnd, BOOL bVKShift);
1075
1088 virtual void SetMouseOutOfDragArea(BOOL bOutOfArea);
1089
1101 virtual BOOL IsOutOfClientRect(CPoint pnt, XTP_CALENDAR_HITTESTINFO* pHitInfo);
1102
1116 virtual XTPCalendarDayViewScrollDirection GetNeededScrollDirection(CPoint pnt) const;
1117
1129 virtual BOOL VertEventScroll(BOOL bUp);
1130
1142 virtual BOOL HorzEventScroll(BOOL bLeft);
1143
1152 virtual COleDateTimeSpan GetEventDurationMin() const;
1153
1165 virtual void SelectDay(CXTPCalendarViewDay* pDay, int nGroupIndex);
1166
1177 virtual void SelectDay(CXTPCalendarViewDay* pDay);
1178
1179 using CXTPCalendarViewT<CXTPCalendarDayViewDay>::SelectDay;
1180
1189 virtual void AdjustAdditionalScaleTimeZone();
1190
1192 _XTP_DEPRECATED_IN_FAVOR(AdjustAdditionalScaleTimeZone)
1193 virtual void AdjustScale2TimeZone()
1194 {
1195 AdjustAdditionalScaleTimeZone();
1196 }
1206 virtual void _ScrollV(int nIndex, int nPos_raw);
1207
1208 int m_nScrollOffsetX;
1210 int m_nMinColumnWidth;
1221 int _GetTimeScaleWith() const;
1222
1229 CRect _GetScrollRectClient() const;
1230
1247 BOOL _EnsureVisibleH(CXTPCalendarViewEvent* pViewEvent);
1248
1265 BOOL _EnsureVisibleV(CXTPCalendarViewEvent* pViewEvent);
1266
1277 BOOL _EnsureVisibleSelectionH();
1278
1279 XTP_DAY_VIEW_LAYOUT& GetLayout();
1280 virtual BOOL IsUseCellAlignedDraggingInTimeArea() const;
1281
1282 virtual void OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO* pHitTest);
1283 virtual BOOL OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO* pHitTest);
1284 virtual BOOL OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO* pHitInfo);
1285
1286 virtual void ClearDays();
1287
1288 virtual void _ScrollDays(int nScrollDaysCount, BOOL bPrev);
1289 virtual void ProcessCellSelection(COleDateTime dtNewSelBegin, BOOL bFixSelEnd,
1290 BOOL bAllDayEventSel, int nGroupIndex);
1291
1292 virtual void ProcessDaySelection(XTP_CALENDAR_HITTESTINFO* pInfo, UINT nFlags);
1293
1294 virtual CXTPCalendarViewEvent* FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse,
1295 CXTPCalendarEvent* pAfterEvent = NULL);
1296 virtual COleDateTime GetNextTimeEditByTAB() const;
1297 virtual void UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset = FALSE);
1298
1299 virtual BOOL OnTimer(UINT_PTR uTimerID);
1300 virtual void OnActivateView(BOOL bActivate, CXTPCalendarView* pActivateView,
1301 CXTPCalendarView* pInactiveView);
1302
1303 void _AddDay(const COleDateTime& date);
1304 int CalculateHeaderFormatAndHeight(CDC* pDC, int nCellWidth);
1305
1306 virtual CXTPCalendarData* _GetDataProviderByConnStr(LPCTSTR pcszConnStr,
1307 BOOL bCompareNoCase = TRUE);
1308
1309 XTP_DAY_VIEW_LAYOUT m_LayoutX;
1311 CXTPCalendarDayViewTimeScale* m_pTimeScaleHeaderLeft;
1312 CXTPCalendarDayViewTimeScale* m_pTimeScaleHeaderRight;
1313 CXTPCalendarDayViewTimeScale* m_pTimeScaleHeaderAdditionalLeft;
1314 CXTPCalendarDayViewTimeScale* m_pTimeScaleHeaderAdditionalRight;
1315
1316 int m_nAllDayEventsCountMin_WhenDrag;
1317
1318 COleDateTimeSpan m_spDraggingStartOffset_Time;
1319
1320 COleDateTime m_dtSelectionStart;
1321
1322 DWORD m_dwScrollingEventTimerID;
1323 DWORD m_dwScrollingEventTimerHorID;
1324
1325 BOOL m_bScrollingEventUp;
1326 BOOL m_bScrollingEventLeft;
1327
1328 BOOL m_bMouseOutOfDragArea;
1329 COleDateTime m_dtDraggingStartPoint;
1330 CPoint m_ptLastMousePos;
1331
1332 DWORD m_dwRedrawNowLineTimerID;
1333 COleDateTime m_dtLastRedrawTime;
1334
1335 BOOL m_bHideAllDayEventsArea;
1336
1337# ifdef _XTP_ACTIVEX
1338 DECLARE_DISPATCH_MAP()
1339 DECLARE_INTERFACE_MAP()
1340
1341 DECLARE_OLETYPELIB_EX(CXTPCalendarDayView);
1342
1343 void OleShowDays(DATE dtBegin, DATE dtEnd);
1344 void OleAddDay(DATE dtDay);
1345
1346 long OleGetScaleInterval();
1347 void OleSetScaleInterval(long nScalInterval);
1348
1349 DATE OleGetTimeScaleMinTime();
1350 void OleSetTimeScaleMinTime(DATE dtNewScaleMinTime);
1351
1352 DATE OleGetTimeScaleMaxTime();
1353 void OleSetTimeScaleMaxTime(DATE dtNewScaleMaxTime);
1354
1355 BSTR OleGetScaleText();
1356 BSTR OleGetScale2Text();
1357
1358 BOOL OleIsScale2Visible();
1359 void OleShowScale2(BOOL bShow);
1360
1361 BOOL OleGetPreventAutoDropAllDayMode();
1362 void OleSetPreventAutoDropAllDayMode(BOOL bSet);
1363
1364 long OleGetCellNumber(DATE dtTime);
1365 void OleScrollV(long lCell);
1366 void OleScrollToColumn(long lColumn);
1367 void OleScrollToWorkDayBegin();
1368
1369 BOOL OleEnsureVisible(LPDISPATCH pdispViewEvent);
1370 BOOL OleEnsureVisibleGroup(LPDISPATCH pdispViewGroup);
1371
1372 int OleGetDayHeaderPeriod();
1373 void OleSetDayHeaderPeriod(int nDayHeaderPeriod);
1374
1375 int OleGetDayViewPrintInterval();
1376 void OleSetDayViewPrintInterval(int nDayViewPrintInterval);
1377# endif
1378};
1379
1380//================================================================
1381
1382AFX_INLINE CRect CXTPCalendarDayView::GetDayHeaderRectangle() const
1383{
1384 return m_LayoutX.m_rcDayHeader;
1385}
1386
1387AFX_INLINE CRect CXTPCalendarDayView::GetAllDayEventsRectangle() const
1388{
1389 return m_LayoutX.m_rcAllDayEvents;
1390}
1391
1392AFX_INLINE BOOL CXTPCalendarDayView::GetIsHideAllDayEventsArea() const
1393{
1394 return m_bHideAllDayEventsArea;
1395}
1396
1397AFX_INLINE int CXTPCalendarDayView::GetRowCount() const
1398{
1399 return m_LayoutX.m_nRowCount;
1400}
1401
1402AFX_INLINE int CXTPCalendarDayView::GetVisibleRowCount() const
1403{
1404 return m_LayoutX.m_nVisibleRowCount;
1405}
1406
1407AFX_INLINE int CXTPCalendarDayView::GetTopRow() const
1408{
1409 return m_LayoutX.m_nTopRow;
1410}
1411
1412AFX_INLINE void CXTPCalendarDayView::ProcessDaySelection(XTP_CALENDAR_HITTESTINFO* /*pInfo*/,
1413 UINT /*nFlags*/)
1414{
1415 UnselectAllEvents();
1416}
1417
1418AFX_INLINE CXTPCalendarDayViewTimeScale* CXTPCalendarDayView::GetTimeScale(int nNumber) const
1419{
1420 switch (nNumber)
1421 {
1422 case 1: return m_pTimeScaleHeaderLeft;
1423 case 2: return m_pTimeScaleHeaderAdditionalLeft;
1424 case 3: return m_pTimeScaleHeaderRight;
1425 case 4: return m_pTimeScaleHeaderAdditionalRight;
1426 default: break;
1427 }
1428
1429 return m_pTimeScaleHeaderLeft;
1430}
1431
1432AFX_INLINE XTP_DAY_VIEW_LAYOUT& CXTPCalendarDayView::GetLayout()
1433{
1434 return m_LayoutX;
1435}
1436
1437AFX_INLINE int CXTPCalendarDayView::GetMinColumnWidth() const
1438{
1439 return m_nMinColumnWidth;
1440}
1441
1442AFX_INLINE void CXTPCalendarDayView::SetMinColumnWidth(int nWidth)
1443{
1444 m_nMinColumnWidth = nWidth;
1445}
1446
1447# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1448#endif // !defined(_XTPCALENDARDAYVIEW_H__)
XTPCalendarViewType
XTPCalendarViewType
Enumeration used to determine the calendar view type in use.
Definition XTPCalendarDefines.h:361
XTPCalendarDayViewScrollDirection
XTPCalendarDayViewScrollDirection
Enumeration used to determine the scroll direction.
Definition XTPCalendarDefines.h:699
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarControlView
The CXTPCalendarControlView class provides an implementation of the Calendar control as a view class.
Definition XTPCalendarControlView.h:283
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarDayViewDay
This class represents a day view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:726
CXTPCalendarDayViewGroup
This class represents a single resource view portion of the Calendar Day View.
Definition XTPCalendarDayViewDay.h:53
CXTPCalendarDayView
This class implements a specific view portion of the Calendar control - called Day view.
Definition XTPCalendarDayView.h:62
CXTPCalendarDayView::OnLButtonDown
virtual BOOL OnLButtonDown(UINT nFlags, CPoint point)
This member function is used to process left mouse button events.
CXTPCalendarDayView::IsAdditionalScaleRightVisible
BOOL IsAdditionalScaleRightVisible() const
This member function is used to obtain the visibility flag of the additional right time scale.
CXTPCalendarDayView::GetScaleMinTime
COleDateTime GetScaleMinTime() const
This member function is used to obtain the minimal time which is shown on the day view scale.
CXTPCalendarDayView::Draw2
virtual void Draw2(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarDayView::m_nCurPage
int m_nCurPage
for AllDay event printing control by CXTPCalendarControlView
Definition XTPCalendarDayView.h:1014
CXTPCalendarDayView::IsAdditionalScaleLeftVisible
BOOL IsAdditionalScaleLeftVisible() const
This member function is used to obtain the visibility flag of the additional left time scale.
CXTPCalendarDayView::GetEventDurationMin
virtual COleDateTimeSpan GetEventDurationMin() const
This member function is used to return the minimum event duration so that the event is visible in the...
CXTPCalendarDayView::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client dimensions ...
CXTPCalendarDayView::_EnsureVisibleH
BOOL _EnsureVisibleH(CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
CXTPCalendarDayView::GetRowCount
int GetRowCount() const
This member function is used to obtain the total row count on the view.
Definition XTPCalendarDayView.h:1397
CXTPCalendarDayView::GetScaleMaxTime
COleDateTime GetScaleMaxTime() const
This member function is used to obtain the maximal time which is shown on the day view scale.
CXTPCalendarDayView::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcView, BOOL bCallPostAdjustLayout=TRUE)
This member function is used to adjust the view's layout depending on the window's client dimensions ...
CXTPCalendarDayView::ShowDays
virtual void ShowDays(const COleDateTime &dtBegin, const COleDateTime &dtEnd)
This member function is used to show the specified day interval in the calendar day view.
CXTPCalendarDayView::StopVertEventScroll
virtual void StopVertEventScroll()
This member function is used to stop vertical scrolling.
CXTPCalendarDayView::GetAdditionalScaleTimeZone
const TIME_ZONE_INFORMATION & GetAdditionalScaleTimeZone() const
This member function is used to get the time zone information for the additional time scale.
CXTPCalendarDayView::UpdateNextTimeEditByTAB
virtual void UpdateNextTimeEditByTAB(COleDateTime dtNext, BOOL bReverse, BOOL bReset=FALSE)
This member function is used to set the next date and time to start the find event view for editing e...
CXTPCalendarDayView::OnStartDragging
virtual void OnStartDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to start the event editing (dragging).
CXTPCalendarDayView::m_bEcoAllDayMode
BOOL m_bEcoAllDayMode
If True use short AllDay area height.
Definition XTPCalendarDayView.h:1005
CXTPCalendarDayView::StopHorzEventScroll
virtual void StopHorzEventScroll()
This member function is used to stop horizontal scrolling.
CXTPCalendarDayView::ScrollToWorkDayBegin
virtual void ScrollToWorkDayBegin()
This member function is used to start view from the work day starting time.
CXTPCalendarDayView::IsExpandUp
BOOL IsExpandUp() const
This member function is used to obtain the Expand Up glyph flag value.
CXTPCalendarDayView::ScrollToColumn
void ScrollToColumn(long lColumn)
This member function is used to scroll the view forward a specified number of columns (schedules).
CXTPCalendarDayView::IsDrawNowLineOverAppoinment
BOOL IsDrawNowLineOverAppoinment() const
This member function is used to obtain the flag of the now line drawing.
CXTPCalendarDayView::_EnsureVisibleV
BOOL _EnsureVisibleV(CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
CXTPCalendarDayView::IsScaleRightVisible
BOOL IsScaleRightVisible() const
This member function is used to obtain the visibility flag of right time scale.
CXTPCalendarDayView::IsGroupHeaderVisible
virtual BOOL IsGroupHeaderVisible() const
This member function is used to determine whether resource group header should be visible.
CXTPCalendarDayView::ShowWorkingDays
virtual void ShowWorkingDays(const COleDateTime &dtDay)
This member function is used to show that working week in the calendar day view, which includes the s...
CXTPCalendarDayView::ProcessDaySelection
virtual void ProcessDaySelection(XTP_CALENDAR_HITTESTINFO *pInfo, UINT nFlags)
This member function is used to process the days selection that are selected with the mouse.
Definition XTPCalendarDayView.h:1412
CXTPCalendarDayView::SetMouseOutOfDragArea
virtual void SetMouseOutOfDragArea(BOOL bOutOfArea)
This member function is used to change the mouse cursor.
CXTPCalendarDayView::GetNeededScrollDirection
virtual XTPCalendarDayViewScrollDirection GetNeededScrollDirection(CPoint pnt) const
This member function is used to determine the scroll direction.
CXTPCalendarDayView::EnsureVisible
virtual BOOL EnsureVisible(CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
CXTPCalendarDayView::SetScaleMinTime
void SetScaleMinTime(const COleDateTime dtNewScaleMinTime)
This member function is used to set the minimal time which is shown on the day view scale.
CXTPCalendarDayView::SetMinColumnWidth
virtual void SetMinColumnWidth(int nWidth)
This member function used to set minimum column width, where column is a group view object.
Definition XTPCalendarDayView.h:1442
CXTPCalendarDayView::IsOutOfClientRect
virtual BOOL IsOutOfClientRect(CPoint pnt, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to determine if the point is in the drag able rectangle.
CXTPCalendarDayView::GetCurrentTimeZoneInfo
CXTPCalendarTimeZonePtr GetCurrentTimeZoneInfo() const
Get full information about current time zone.
CXTPCalendarDayView::OnEndDragging
virtual BOOL OnEndDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitInfo)
This member function is used to finish the event editing (dragging) operation.
CXTPCalendarDayView::GetTopRow
int GetTopRow() const
This member function is used to obtain the top visible row on the view.
Definition XTPCalendarDayView.h:1407
CXTPCalendarDayView::m_bPreventDragAllDayEventInDayView
BOOL m_bPreventDragAllDayEventInDayView
default FALSE If True it will be impossible to Drag All Day Event In DayView
Definition XTPCalendarDayView.h:1007
CXTPCalendarDayView::OnLButtonUp
virtual BOOL OnLButtonUp(UINT nFlags, CPoint point)
This member function is used to processes left mouse button events.
CXTPCalendarDayView::GetScaleInterval
COleDateTimeSpan GetScaleInterval() const
This member function is used to obtain the time scale item interval.
CXTPCalendarDayView::_EnsureVisibleSelectionH
BOOL _EnsureVisibleSelectionH()
This member function is used to ensure that an selection is visible.
CXTPCalendarDayView::SetAdditionalScaleTimeZone
void SetAdditionalScaleTimeZone(const TIME_ZONE_INFORMATION *pTzInfo)
This member function is used to set the time zone information for the additional time scale.
CXTPCalendarDayView::GetSelection
virtual BOOL GetSelection(COleDateTime *pBegin=NULL, COleDateTime *pEnd=NULL, BOOL *pbAllDayEvent=NULL, int *pnGroupIndex=NULL, COleDateTimeSpan *pspSelectionResolution=NULL) const
This member function is used to obtain the view selection.
CXTPCalendarDayView::GetVisibleRowCount
int GetVisibleRowCount() const
This member function is used to obtain the visible row count on the view.
Definition XTPCalendarDayView.h:1402
CXTPCalendarDayView::ScrollH
virtual void ScrollH(int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
CXTPCalendarDayView::EnsureVisibleH
virtual BOOL EnsureVisibleH(CXTPCalendarViewEvent *pViewEvent)
This member function is used to ensure that an event view item is visible.
CXTPCalendarDayView::OnActivateView
virtual void OnActivateView(BOOL bActivate, CXTPCalendarView *pActivateView, CXTPCalendarView *pInactiveView)
This member function is called by the framework view when it is activated or deactivated.
CXTPCalendarDayView::ShowDay
virtual void ShowDay(const COleDateTime &date, BOOL bSelect=TRUE)
This member function is used to show the specified day in the calendar day view.
CXTPCalendarDayView::GetDay
virtual CXTPCalendarDayViewDay * GetDay(COleDateTime dtDay)
Call this member function to obtain the CXTPCalendarDayViewDay object by the day's date.
CXTPCalendarDayView::_GetScrollRectClient
CRect _GetScrollRectClient() const
This member function is used to get horizontal scroll area rect.
CXTPCalendarDayView::OnKeyDown
virtual void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags)
This member function is used to process keyboard events.
CXTPCalendarDayView::m_nMinColumnWidth
int m_nMinColumnWidth
0 means disabled; -1 use some default width for multiresources only; -N use for multiresources only (...
Definition XTPCalendarDayView.h:1210
CXTPCalendarDayView::TBase
CXTPCalendarViewT< CXTPCalendarDayViewDay > TBase
Definition XTPCalendarDayView.h:78
CXTPCalendarDayView::GetIsCanHScrollGroupsRight
BOOL GetIsCanHScrollGroupsRight(COleDateTime dtNewSelEnd, BOOL bVKShift)
This member function is an utility function used by OnKeyDown It determines if we can scroll groups r...
CXTPCalendarDayView::_ScrollV
virtual void _ScrollV(int nIndex, int nPos_raw)
This member function is used to scroll the content of a view.
CXTPCalendarDayView::ScrollDaysToNext
virtual void ScrollDaysToNext(int nScrollDaysCount=1)
This member function is used to scroll the view forward a specified number of days.
CXTPCalendarDayView::VertEventScroll
virtual BOOL VertEventScroll(BOOL bUp)
This member function is used to vertically scroll an event in the current view.
CXTPCalendarDayView::m_dtTimeScaleMin
COleDateTime m_dtTimeScaleMin
Time scale minimum value.
Definition XTPCalendarDayView.h:987
CXTPCalendarDayView::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarDayView::m_bUseNewHitTestCode
BOOL m_bUseNewHitTestCode
Tells whether to use new hit test code or not.
Definition XTPCalendarDayView.h:1016
CXTPCalendarDayView::ShowAdditionalScale
void ShowAdditionalScale(BOOL bShow=TRUE)
This member function is used to Show or hide the additional time scale.
CXTPCalendarDayView::_GetTimeScaleWith
int _GetTimeScaleWith() const
This member function is used to get time scales area width.
CXTPCalendarDayView::GetCellTime
COleDateTime GetCellTime(int nCell) const
This member function is used to obtain the time value for the specified cell.
CXTPCalendarDayView::GetMinColumnWidth
virtual int GetMinColumnWidth() const
This member function returns values which interpreted as a minimum column width, where column is a gr...
Definition XTPCalendarDayView.h:1437
CXTPCalendarDayView::SetScaleInterval
void SetScaleInterval(const COleDateTimeSpan spScaleInterval)
This member function is used to set the time scale item interval.
CXTPCalendarDayView::GetNextTimeEditByTAB
virtual COleDateTime GetNextTimeEditByTAB() const
This member function is used to obtain the next date and time to start the find event view for editin...
CXTPCalendarDayView::m_bShowLinks
BOOL m_bShowLinks
flag to show or hide 'virtual' view events
Definition XTPCalendarDayView.h:1018
CXTPCalendarDayView::m_bPrintFullScale
BOOL m_bPrintFullScale
print timescale range - if FALSE - print working hours range
Definition XTPCalendarDayView.h:1001
CXTPCalendarDayView::AddDay
virtual void AddDay(const COleDateTime &date)
This member function is used to add a specified date to the dates set showing in the current calendar...
CXTPCalendarDayView::OnDragging
virtual BOOL OnDragging(CPoint point, XTP_CALENDAR_HITTESTINFO *pHitTest)
This member function is used to perform the event editing (dragging) operation step.
CXTPCalendarDayView::GetViewType
virtual XTPCalendarViewType GetViewType() const
Call this member function to obtain the view type flag.
CXTPCalendarDayView::CXTPCalendarDayView
CXTPCalendarDayView(CXTPCalendarControl *pCalendarControl)
Default object constructor.
CXTPCalendarDayView::m_LayoutX
XTP_DAY_VIEW_LAYOUT m_LayoutX
Layout data.
Definition XTPCalendarDayView.h:1309
CXTPCalendarDayView::ScrollDaysToPrev
virtual void ScrollDaysToPrev(int nScrollDaysCount=1)
This member function is used to scroll the view back a specified number of days.
CXTPCalendarDayView::GetViewDayDate
virtual COleDateTime GetViewDayDate(int nIndex) const
Call this member function to get the date of a day view by the day's index.
CXTPCalendarDayView::GetTimeScale
virtual CXTPCalendarDayViewTimeScale * GetTimeScale(int nNumber=1) const
This member function is used to get main or additional time scale object.
Definition XTPCalendarDayView.h:1418
CXTPCalendarDayView::IsScaleLeftVisible
BOOL IsScaleLeftVisible() const
This member function is used to obtain the visibility flag of left time scale.
CXTPCalendarDayView::m_nDayViewPrintInterval
int m_nDayViewPrintInterval
interval to use in DayView Printing: 60 or 45 or 30 or 15
Definition XTPCalendarDayView.h:1003
CXTPCalendarDayView::GetCellDuration
COleDateTimeSpan GetCellDuration() const
This member function is used to obtain the current cell duration.
CXTPCalendarDayView::m_dtTimeScaleMax
COleDateTime m_dtTimeScaleMax
Time scale maximum value.
Definition XTPCalendarDayView.h:988
CXTPCalendarDayView::m_bShowAllDayEventsOnly
BOOL m_bShowAllDayEventsOnly
flag that enables showing all-day events only
Definition XTPCalendarDayView.h:1021
CXTPCalendarDayView::SelectDay
virtual void SelectDay(CXTPCalendarViewDay *pDay, int nGroupIndex)
This member function is used to select or un-select the provided day, including all of the day's even...
CXTPCalendarDayView::IsExpandDown
BOOL IsExpandDown() const
This member function is used to obtain the Expand Down glyph flag value.
CXTPCalendarDayView::OnDraw
virtual void OnDraw(CDC *pDC)
This member function performs all of the drawing logic of the calendar view.
CXTPCalendarDayView::FindEventToEditByTAB
virtual CXTPCalendarViewEvent * FindEventToEditByTAB(COleDateTime dtMinStart, BOOL bReverse, CXTPCalendarEvent *pAfterEvent=NULL)
This member function is used to obtain the next event view object used for editing events by pressing...
CXTPCalendarDayView::GetScaleText
CString GetScaleText() const
This member function is used to obtain the text label of the default time scale.
CXTPCalendarDayView::m_nScrollOffsetX
int m_nScrollOffsetX
Stores horizontal left offset of visible day view part.
Definition XTPCalendarDayView.h:1208
CXTPCalendarDayView::SetScaleText
void SetScaleText(LPCTSTR strText)
This member function is used to set the text label for the default time scale.
CXTPCalendarDayView::SetScaleMaxTime
void SetScaleMaxTime(const COleDateTime dtNewScaleMaxTime)
This member function is used to set the maximal time which is shown on the day view scale.
CXTPCalendarDayView::m_nDayHeaderPeriod
int m_nDayHeaderPeriod
interval between in multi-scheduled mode Day Header for same date repeated - need for scrolling in ve...
Definition XTPCalendarDayView.h:1010
CXTPCalendarDayView::m_bDF_mode
BOOL m_bDF_mode
Last page print mode flag (FALSE - print last page same size as other, TRUE (default) - can be shorte...
Definition XTPCalendarDayView.h:998
CXTPCalendarDayView::m_bHideLinkContainer
BOOL m_bHideLinkContainer
flag to hide or show 'virtual' view events container column
Definition XTPCalendarDayView.h:1019
CXTPCalendarDayView::OnMouseMove
virtual void OnMouseMove(UINT nFlags, CPoint point)
This member function is used to process mouse move events.
CXTPCalendarDayView::EnsureVisibleH
virtual BOOL EnsureVisibleH(CXTPCalendarViewGroup *pViewGroup)
This member function is used to ensure that an event view item is visible.
CXTPCalendarDayView::HorzEventScroll
virtual BOOL HorzEventScroll(BOOL bLeft)
This member function is used to horizontally scroll an event in the current view.
CXTPCalendarDayView::m_bPrintRepeatHeaderFooterMode
BOOL m_bPrintRepeatHeaderFooterMode
flag to set printout to print Header and Footer only on first page to maximize main information space...
Definition XTPCalendarDayView.h:994
CXTPCalendarDayView::m_bDraftMode
BOOL m_bDraftMode
flag to set printout to print in B/W without Header and Footer to maximize main information space and...
Definition XTPCalendarDayView.h:990
CXTPCalendarDayView::OnTimer
virtual BOOL OnTimer(UINT_PTR uTimerID)
The framework calls this member function after each interval specified in the SetTimer member functio...
CXTPCalendarDayView::GetIsCanHScrollGroupsLeft
BOOL GetIsCanHScrollGroupsLeft(COleDateTime dtNewSelEnd, BOOL bVKShift)
This member function is an utility function used by OnKeyDown It determines if we can scroll groups l...
CXTPCalendarDayView::~CXTPCalendarDayView
virtual ~CXTPCalendarDayView()
Default class destructor.
CXTPCalendarDayView::GetScrollBarInfoV
virtual BOOL GetScrollBarInfoV(SCROLLINFO *pSI) const
This member function is used to retrieve information about a scroll bar's state.
CXTPCalendarDayView::GetCellNumber
int GetCellNumber(int nHour, int nMin, int nSec, BOOL bForEndTime) const
This member function is used to calculate the cell number for the specified time value.
CXTPCalendarDayView::GetAdditionalScaleText
CString GetAdditionalScaleText() const
This member function is used to obtain the text label of the additional time scale.
CXTPCalendarDayView::GetScrollBarInfoH
virtual BOOL GetScrollBarInfoH(SCROLLINFO *pSI, int *pnScrollStep=NULL) const
This member function is used to retrieve information about a scroll bar's state.
CXTPCalendarDayView::SelectDay
virtual void SelectDay(CXTPCalendarViewDay *pDay)
This member function is used to select or un-select the provided day, including all of the day's even...
CXTPCalendarDayView::GetAdditionalScaleTimeZoneInfo
CXTPCalendarTimeZonePtr GetAdditionalScaleTimeZoneInfo() const
Get full information about additional time scale time zone.
CXTPCalendarDayView::AdjustAdditionalScaleTimeZone
virtual void AdjustAdditionalScaleTimeZone()
Converts Time Zones from both timescales to the minutes shift of the second time scale in comparison ...
CXTPCalendarDayView::ScrollV
virtual void ScrollV(int nPos, int nPos_raw)
This member function is used to scroll the content of a view.
CXTPCalendarDayView::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
CXTPCalendarDayView::GetCellNumber
int GetCellNumber(COleDateTime dtTime, BOOL bForEndTime) const
This member function is used to calculate the cell number for the specified time value.
CXTPCalendarDayView::SetAdditionalScaleText
void SetAdditionalScaleText(LPCTSTR strText)
This member function is used to set the text label for the additional time scale.
CXTPCalendarDayViewTimeScale
This class implements a specific view portion of the Calendar Day view - called Time scale.
Definition XTPCalendarDayViewTimeScale.h:75
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarTimeZone
This class extends the TIME_ZONE_INFORMATION structure.
Definition XTPCalendarTimeZoneHelper.h:56
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
CXTPCalendarView
This class represents the view portion of the Calendar control.
Definition XTPCalendarView.h:360
CXTPCalendarView::UnselectAllEvents
virtual void UnselectAllEvents()
Call this member function to un-select all of the events of the current view.
CXTPCalendarViewT
This template class represents a view portion of the Calendar control.
Definition XTPCalendarView.h:2571
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


CXTPChartPieStyleAppearance Member List

This is the complete list of members for CXTPChartPieStyleAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
BorderColor | CXTPChartPieStyleAppearance |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartPieStyleAppearance(CXTPChartElement *pOwner) | CXTPChartPieStyleAppearance |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartPieStyleAppearance | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetOwner() const | CXTPChartElement |
Is3D() const | CXTPChartObject |
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual
~CXTPChartPieStyleAppearance() | CXTPChartPieStyleAppearance | virtual


Toolkit Pro: XTPDockingPaneThemeDefault.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeDefault.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEDEFAULTTHEME_H__)
24# define __XTPDOCKINGPANEDEFAULTTHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPDockingPaneDefaultTheme : public CXTPDockingPanePaintManager
41{
42public:
47 CXTPDockingPaneDefaultTheme();
48
49public:
57 void DrawFloatingFrame(CDC* pDC, CXTPDockingPaneMiniWnd* pPane, CRect rc);
58
66 virtual void DrawCaption(CDC* pDC, CXTPDockingPaneTabbedContainer* pPane, CRect rc);
67
75 virtual void DrawSidePanel(CDC* pDC, CXTPDockingPaneSidePanel* pPane, CRect rc);
76
81 virtual void RefreshMetrics();
82
83protected:
94 virtual void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
95 const CString& strTitle, BOOL bActive, BOOL bVertical);
96};
98# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
99#endif // #if !defined(__XTPDOCKINGPANEDEFAULTTHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme is a CXTPDockingPanePaintManager derived class that represents a classic ...
Definition XTPDockingPaneThemeDefault.h:41
CXTPDockingPaneDefaultTheme::DrawFloatingFrame
void DrawFloatingFrame(CDC *pDC, CXTPDockingPaneMiniWnd *pPane, CRect rc)
Call this method to draw the frame of a floating window.
CXTPDockingPaneDefaultTheme::CXTPDockingPaneDefaultTheme
CXTPDockingPaneDefaultTheme()
Constructs a CXTPDockingPaneDefaultTheme object.
CXTPDockingPaneDefaultTheme::DrawCaption
virtual void DrawCaption(CDC *pDC, CXTPDockingPaneTabbedContainer *pPane, CRect rc)
Override this member function to draw a caption.
CXTPDockingPaneDefaultTheme::DrawSidePanel
virtual void DrawSidePanel(CDC *pDC, CXTPDockingPaneSidePanel *pPane, CRect rc)
Override this member function to draw the side panel.
CXTPDockingPaneDefaultTheme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneDefaultTheme::DrawCaptionPart
virtual void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.
CXTPDockingPaneMiniWnd
CXTPDockingPaneMiniWnd is a multiple inheritance class derived from CMiniFrameWnd and CXTPDockingPane...
Definition XTPDockingPaneMiniWnd.h:42
CXTPDockingPanePaintManager
CXTPDockingPanePaintManager is a standalone class.
Definition XTPDockingPanePaintManager.h:196
CXTPDockingPaneSidePanel
CXTPDockingPaneSidePanel is a multiple inheritance class derived from CWnd and CXTPDockingPaneBase.
Definition XTPDockingPaneSidePanel.h:45
CXTPDockingPaneTabbedContainer
CXTPDockingPaneTabbedContainer is a multiple inheritance class derived from CWnd and CXTPDockingPaneB...
Definition XTPDockingPaneTabbedContainer.h:47


Toolkit Pro: XTPRibbonThemeNativeWindows11.h Source File

  • Source
  • Ribbon
  • Themes
XTPRibbonThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPRIBBONNATIVEWINDOWS11THEME_H__)
24# define __XTPRIBBONNATIVEWINDOWS11THEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPRibbonThemeNativeWindows11
39 : public CXTPRibbonOffice2013Theme
40 , private IXTPPaintManagerCustomAccentColorProvider
41{
42public:
48 CXTPRibbonThemeNativeWindows11(CXTPPaintManager* pPaintManager);
49
54 virtual ~CXTPRibbonThemeNativeWindows11();
55
65 virtual void RefreshMetrics();
66
80 void FillGroupRect(CDC* pDC, CXTPRibbonTab* pActiveTab, CRect rcGroups);
81
88 virtual void DrawRibbonTab(CDC* pDC, CXTPRibbonTab* pItem);
89
97 virtual void DrawRibbonFrameContextHeaders(CDC* pDC, CXTPRibbonBar* pRibbonBar,
98 CXTPRibbonTabContextHeaders* pContextHeaders);
99
100private:
101 // IXTPPaintManagerCustomAccentColorProvider overrides
102
103 virtual COLORREF GetCustomAccentColor(XTPPaintManagerAccentColor nColor);
104};
105
106# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
108#endif // !defined(__XTPRIBBONNATIVEWINDOWS11THEME_H__)
XTPPaintManagerAccentColor
XTPPaintManagerAccentColor
Defines a set of accent related colors.
Definition XTPColorManager.h:900
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPRibbonBar
CXTPRibbonBar is a CXTPMenuBar derived class.
Definition XTPRibbonBar.h:69
CXTPRibbonOffice2013Theme
CXTPRibbonOffice2013Theme is a CXTPRibbonMarkupTheme derived class used to represent an Office 2013 r...
Definition XTPRibbonThemeOffice2013.h:50
CXTPRibbonTab
Represents a tab in the Ribbon Bar.
Definition XTPRibbonTab.h:116
CXTPRibbonThemeNativeWindows11
CXTPRibbonThemeNativeWindows11 is a CXTPRibbonOffice2013Theme derived class used to represent a Nativ...
Definition XTPRibbonThemeNativeWindows11.h:41
CXTPRibbonThemeNativeWindows11::FillGroupRect
void FillGroupRect(CDC *pDC, CXTPRibbonTab *pActiveTab, CRect rcGroups)
This method is called to fill the background of a CXTPRibbonGroup.
CXTPRibbonThemeNativeWindows11::CXTPRibbonThemeNativeWindows11
CXTPRibbonThemeNativeWindows11(CXTPPaintManager *pPaintManager)
Constructs a CXTPRibbonThemeNativeWindows11 object.
CXTPRibbonThemeNativeWindows11::DrawRibbonTab
virtual void DrawRibbonTab(CDC *pDC, CXTPRibbonTab *pItem)
This method is called to draw a single tab of the ribbon bar.
CXTPRibbonThemeNativeWindows11::~CXTPRibbonThemeNativeWindows11
virtual ~CXTPRibbonThemeNativeWindows11()
Destroys a CXTPRibbonThemeNativeWindows11 object, handles cleanup and deallocation.
CXTPRibbonThemeNativeWindows11::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPRibbonThemeNativeWindows11::DrawRibbonFrameContextHeaders
virtual void DrawRibbonFrameContextHeaders(CDC *pDC, CXTPRibbonBar *pRibbonBar, CXTPRibbonTabContextHeaders *pContextHeaders)
This method is called to draw ribbon context headers.


Toolkit Pro: XTPChartLineSeriesStyle.h Source File

  • Source
  • Chart
  • Styles
  • Line
XTPChartLineSeriesStyle.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTLINESERIESSTYLE_H__)
24# define __XTPCHARTLINESERIESSTYLE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartLineStyle;
35
46class _XTP_EXT_CLASS CXTPChartLineSeriesStyle : public CXTPChartPointSeriesStyle
47{
49 DECLARE_SERIAL(CXTPChartLineSeriesStyle)
51public:
56 CXTPChartLineSeriesStyle();
57
62 virtual ~CXTPChartLineSeriesStyle();
63
64public:
72 CXTPChartLineStyle* GetLineStyle() const;
73
74protected:
85 virtual CXTPChartSeriesView* CreateView(CXTPChartSeries* pSeries,
86 CXTPChartDiagramView* pDiagramView);
87
88 void DoPropExchange(CXTPPropExchange* pPX);
89# ifdef _XTP_ACTIVEX
90public:
92 DECLARE_DISPATCH_MAP()
93 DECLARE_INTERFACE_MAP()
94 DECLARE_OLETYPELIB_EX(CXTPChartLineSeriesStyle);
95 DECLARE_OLECREATE_EX(CXTPChartLineSeriesStyle)
96 LPDISPATCH OleGetLineStyle();
98# endif
99
100protected:
101 CXTPChartLineStyle* m_pLineStyle;
102};
103
109class _XTP_EXT_CLASS CXTPChartLineSeriesView : public CXTPChartDiagram2DSeriesView
110{
111public:
120 CXTPChartLineSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView,
121 BOOL bSortPoints = TRUE);
122
123protected:
135 CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
136 CXTPChartSeriesPoint* pPoint,
137 CXTPChartElementView* pParentView);
138
151 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
152
163 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
164 CRect rcBounds);
165};
166
167AFX_INLINE CXTPChartLineStyle* CXTPChartLineSeriesStyle::GetLineStyle() const
168{
169 return m_pLineStyle;
170}
172# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
173#endif //#if !defined(__XTPCHARTLINESERIESSTYLE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLineSeriesStyle
This class represents a line series style, which is a kind of CXTPChartPointSeriesStyle.
Definition XTPChartLineSeriesStyle.h:47
CXTPChartLineSeriesStyle::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartLineSeriesStyle::m_pLineStyle
CXTPChartLineStyle * m_pLineStyle
The line style.
Definition XTPChartLineSeriesStyle.h:101
CXTPChartLineSeriesStyle::CreateView
virtual CXTPChartSeriesView * CreateView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Call this function to create a view of the line series.
CXTPChartLineSeriesStyle::~CXTPChartLineSeriesStyle
virtual ~CXTPChartLineSeriesStyle()
Destroys a CXTPChartLineSeriesStyle object, handles cleanup.
CXTPChartLineSeriesStyle::CXTPChartLineSeriesStyle
CXTPChartLineSeriesStyle()
Constructs a CXTPChartLineSeriesStyle object.
CXTPChartLineSeriesStyle::GetLineStyle
CXTPChartLineStyle * GetLineStyle() const
Call this function to get the line style of the line series.
Definition XTPChartLineSeriesStyle.h:167
CXTPChartLineSeriesView
This class represents the view of a line series, which is a kind of CXTPChartSeriesView.
Definition XTPChartLineSeriesStyle.h:110
CXTPChartLineSeriesView::CXTPChartLineSeriesView
CXTPChartLineSeriesView(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView, BOOL bSortPoints=TRUE)
Constructs a CXTPChartLineSeriesView object.
CXTPChartLineSeriesView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartLineSeriesView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a label view drawing command object.
CXTPChartLineSeriesView::CreateSeriesPointView
CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)
Call this function to create a view of the line series point.
CXTPChartLineStyle
This class represents a chart line style, which is a kind of CXTPCmdTarget.
Definition XTPChartLineStyle.h:43
CXTPChartPointSeriesStyle
This class represents a line series style, which is a kind of CXTPChartSeriesStyle.
Definition XTPChartPointSeriesStyle.h:47
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPDatePickerResourceTheme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerResourceTheme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERRESOURCETHEME_H__)
23# define _XTPDATEPICKERRESOURCETHEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeResource : public CXTPDatePickerPaintManager
52{
53public:
62 CXTPDatePickerThemeResource();
63
70 virtual ~CXTPDatePickerThemeResource();
71
80 virtual void RefreshMetrics();
81
110 virtual void DrawButton(CDC* pDC, const CRect& rcButton, const CString& strButton, BOOL bIsDown,
111 BOOL bIsHighLight);
112
113protected:
125 COLORREF GetResourceColor(LPCTSTR pcszColorName, COLORREF clrDefault);
126};
127
128# define CXTPDatePickerThemeOffice2007 CXTPDatePickerThemeResource
129
130# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
131#endif // !defined(_XTPDATEPICKERRESOURCETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerPaintManager
Class CXTPDatePickerPaintManager handles most of the drawing activities for the DatePicker control.
Definition XTPDatePickerPaintManager.h:55
CXTPDatePickerThemeResource
Class CXTPDatePickerThemeResource is derived from CXTPDatePickerPaintManager for rendering a Resource...
Definition XTPDatePickerResourceTheme.h:52
CXTPDatePickerThemeResource::GetResourceColor
COLORREF GetResourceColor(LPCTSTR pcszColorName, COLORREF clrDefault)
Call this member function to return the COLORREF value for the specified color name located in the Re...
CXTPDatePickerThemeResource::~CXTPDatePickerThemeResource
virtual ~CXTPDatePickerThemeResource()
Default paint manager destructor.
CXTPDatePickerThemeResource::CXTPDatePickerThemeResource
CXTPDatePickerThemeResource()
Default paint manager constructor.
CXTPDatePickerThemeResource::RefreshMetrics
virtual void RefreshMetrics()
This member function performs initialization for the Paint Manager.
CXTPDatePickerThemeResource::DrawButton
virtual void DrawButton(CDC *pDC, const CRect &rcButton, const CString &strButton, BOOL bIsDown, BOOL bIsHighLight)
This member function is used to draw the control's buttons.


Toolkit Pro: XTPMarkupMatrixTransform.h Source File

  • Source
  • Markup
  • Transform
XTPMarkupMatrixTransform.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPMATRIXTRANSFORM_H__)
24# define __XTPMARKUPMATRIXTRANSFORM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupTransformationMatrix;
34class CXTPMarkupDependencyProperty;
35
40class _XTP_EXT_CLASS CXTPMarkupMatrixTransform : public CXTPMarkupTransform
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupMatrixTransform);
45public:
46 CXTPMarkupDoubleCollection* GetMatrix() const;
47
48 void SetMatrix(CXTPMarkupDoubleCollection* pMatrix);
49
57 virtual CXTPMarkupTransformationMatrix*
58 ApplyTransform(const CXTPMarkupTransformationMatrix* pMatrix);
59
60private:
61 DECLARE_DISPATCH_MAP();
62 afx_msg LPDISPATCH OleGetMatrix();
63 afx_msg void OleSetMatrix(LPDISPATCH lpValue);
64
65public:
66 static CXTPMarkupDependencyProperty* m_pPropertyMatrix;
67};
68
69# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
71#endif // !defined(__XTPMARKUPMATRIXTRANSFORM_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupMatrixTransform
Default MatrixTransform implementation.
Definition XTPMarkupMatrixTransform.h:41
CXTPMarkupMatrixTransform::ApplyTransform
virtual CXTPMarkupTransformationMatrix * ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix)
Does nothing in default implementation.
CXTPMarkupTransform
Base class for all markup transformation objects.
Definition XTPMarkupTransform.h:43
CXTPMarkupTransformationMatrix
An abstract class for device context transformation matrix.
Definition XTPMarkupTransformationMatrix.h:40


CXTPDockingPanePanelTheme2013 Member List

This is the complete list of members for CXTPDockingPanePanelTheme2013, including all inherited members.

AdjustClientRect(CXTPTabManager *pTabManager, CRect &rcClient) | CXTPTabPaintManagerTheme | virtual
CXTPDockingPanePanelTheme2012() | CXTPDockingPanePanelTheme2012 |
CXTPDockingPanePanelTheme2013() | CXTPDockingPanePanelTheme2013 |
CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme |
CXTPTabThemeFlat() | CXTPTabThemeFlat | inline
DrawSingleButton(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPDockingPanePanelTheme2012 | virtual
DrawTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabPaintManagerTheme | virtual
DrawText(CDC *pDC, CXTPTabManager *pManager, const CString &str, LPRECT lpRect, UINT nFormat) | CXTPTabPaintManagerTheme | virtual
DrawWorkspacePart(CDC *pDC, LPRECT lpRect, XTPTabWorkspacePart workspacePart) | CXTPTabPaintManagerTheme | virtual
FillButton(CDC *pDC, CXTPTabManagerItem *pItem, LPPOINT pts, int nCount, XTPTabPosition tabPosition, BOOL bAbsolute=FALSE) | CXTPTabPaintManagerTheme |
FillTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcControl) | CXTPTabThemeFlat | virtual
GetButtonDrawRect(const CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetButtonHeight(const CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetButtonLength(CDC *pDC, CXTPTabManagerItem *pItem) | CXTPTabPaintManagerTheme | virtual
GetClientMargin() | CXTPTabPaintManagerTheme | virtual
GetClientRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetColorSet() const | CXTPTabPaintManagerTheme |
GetDefaultColorSet() | CXTPTabThemeFlat | inlinevirtual
GetHeaderClipBox(CDC *pDC, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetHeaderHeight(CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme |
GetHeaderMargin() | CXTPTabPaintManagerTheme | virtual
GetHeaderRect(CRect rcControl, CXTPTabManager *pTabManager) | CXTPTabPaintManagerTheme | virtual
GetSupportedColorSets() | CXTPTabPaintManagerTheme | inlinevirtual
m_bButtonsReverseZOrder | CXTPTabPaintManagerTheme | protected
m_nButtonHeight | CXTPTabPaintManagerTheme | protected
m_nGripperWidth | CXTPDockingPanePanelTheme2012 | protected
m_nRowMargin | CXTPTabPaintManagerTheme |
m_pPaintManager | CXTPTabPaintManagerTheme | protected
m_rcHeaderMargin | CXTPTabPaintManagerTheme |
RefreshMetrics() | CXTPDockingPanePanelTheme2012 | virtual
RepositionTabControl(CXTPTabManager *pTabManager, CDC *pDC, CRect rcClient) | CXTPTabPaintManagerTheme | virtual
~CXTPTabPaintManagerTheme() | CXTPTabPaintManagerTheme | virtual


CXTPLockGuard Member List

This is the complete list of members for CXTPLockGuard, including all inherited members.

CXTPLockGuard(CRITICAL_SECTION &key) | CXTPLockGuard
LockThread() | CXTPLockGuard
UnLockThread() | CXTPLockGuard
~CXTPLockGuard() | CXTPLockGuard


Toolkit Pro: XTPFrameThemeVisualStudio2012.h Source File

  • Source
  • CommandBars
  • Frame
XTPFrameThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPVISUALSTUDIO2012FRAMETHEME_H__)
24# define __XTPVISUALSTUDIO2012FRAMETHEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPaintManager;
34class CXTPCommandBarsFrameHook;
35
37// CXTPFrameThemeVisualStudio2012
38
39class _XTP_EXT_CLASS CXTPFrameThemeVisualStudio2012 : public CXTPFrameThemeModernUI
40{
41protected:
42 explicit CXTPFrameThemeVisualStudio2012(CXTPPaintManager* pPaintManager);
43
44public:
45 virtual ~CXTPFrameThemeVisualStudio2012();
46
47 virtual void RefreshMetrics(CXTPResourceImages* pImages);
48
53 virtual void RefreshMetrics();
54
55 virtual LPCTSTR GetStyleResourceName() const;
56 virtual CSize GetCaptionButtonSize(UINT nId) const;
57 virtual CSize GetCaptionButtonSize(UINT nId, HWND hwnd) const;
58 virtual CRect CalcFrameBorder(const CXTPCommandBarsFrameHook* pFrameHook) const;
59
60 virtual CXTPFrameShadow* CreateShadow(CWnd* pFrame);
61 virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd* pFrame,
62 CXTPFrameShadow* pShadow);
63};
64
66// CXTPFrameThemeVisualStudio2012Light
67
68class _XTP_EXT_CLASS CXTPFrameThemeVisualStudio2012Light : public CXTPFrameThemeVisualStudio2012
69{
70public:
71 explicit CXTPFrameThemeVisualStudio2012Light(CXTPPaintManager* pPaintManager);
72 virtual ~CXTPFrameThemeVisualStudio2012Light();
73};
74
76// CXTPFrameThemeVisualStudio2012Dark
77
78class _XTP_EXT_CLASS CXTPFrameThemeVisualStudio2012Dark : public CXTPFrameThemeVisualStudio2012
79{
80public:
81 explicit CXTPFrameThemeVisualStudio2012Dark(CXTPPaintManager* pPaintManager);
82 virtual ~CXTPFrameThemeVisualStudio2012Dark();
83};
85# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
86#endif // !defined(__XTPVISUALSTUDIO2012FRAMETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCommandBarsFrameHook
CXTPCommandBarsFrameHook is a CXTPHookManagerHookAble derived class.
Definition XTPFrameHook.h:56
CXTPFramePaintManager::OnShadowedFrameActiveStateChanged
virtual void OnShadowedFrameActiveStateChanged(BOOL bActive, CWnd *pFrame, CXTPFrameShadow *pShadow)
An implementation can override this method in order to change frame appearance when a window gets act...
CXTPFramePaintManager::CreateShadow
virtual CXTPFrameShadow * CreateShadow(CWnd *pFrame)
Creates frame shadow if supported by theme.
CXTPFrameShadow
The class represents frame shadow object.
Definition XTPFrameShadow.h:47
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257


CXTPEditThemeVisualStudio2017 Member List

This is the complete list of members for CXTPEditThemeVisualStudio2017, including all inherited members.

AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment) | CXTPEditThemeOfficeXP | virtual
CtlColor(CDC *pDC, UINT nCtlColor, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPEditTheme() | CXTPEditTheme |
CXTPEditThemeDefault() | CXTPEditThemeDefault |
CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 |
CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 |
CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP |
CXTPEditThemeVisualStudio2017() | CXTPEditThemeVisualStudio2017 |
DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
CXTPEditThemeOffice2000::DrawBuddyBorders(CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit) | CXTPEditThemeOffice2000 | virtual
DrawFrame(CDC *pDC, CRect rc, int nSize, CBrush *pBrush) | CXTPEditTheme | virtual
DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeOfficeXP | virtual
DrawNcBordersDefault(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | protectedvirtual
DrawNcScrollBack(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit) | CXTPEditThemeDefault | virtual
FillRect(CDC *pDC, int x, int y, int cx, int cy, CBrush *pBrush) | CXTPEditTheme | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetClientBrush(CDC *pDC, CXTPEdit *pEdit) | CXTPEditTheme | virtual
GetThemeID() const | CXTPEditTheme |
GetThemeStyle() const | CXTPControlTheme |
IsFlatStyle() const | CXTPEditTheme |
m_bFlatStyle | CXTPEditTheme | protected
m_bUseWinTheme | CXTPEditTheme | protected
m_clrBack | CXTPEditTheme |
m_clrBackNonClient | CXTPEditTheme |
m_clrBorder | CXTPEditTheme |
m_clrBorderDisabled | CXTPEditThemeOfficeXP | protected
m_clrBorderHilite | CXTPEditThemeOfficeXP | protected
m_clrText | CXTPEditTheme |
m_clrTextReadOnly | CXTPEditTheme |
m_nTheme | CXTPEditTheme | protected
m_winTheme | CXTPEditTheme | protected
m_xtpBrushBack | CXTPEditTheme |
RedrawFocusedFrame() const | CXTPEditThemeOfficeXP | virtual
RefreshMetrics(CXTPEdit *pEdit) | CXTPEditThemeOffice2013 | virtual
SetFlatStyle(BOOL bFlatStyle) | CXTPEditTheme |
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
UseWinTheme(BOOL bUseWinTheme) | CXTPEditTheme |
~CXTPEditTheme() | CXTPEditTheme | virtual
~CXTPEditThemeDefault() | CXTPEditThemeDefault | virtual
~CXTPEditThemeOffice2000() | CXTPEditThemeOffice2000 | virtual
~CXTPEditThemeOffice2013() | CXTPEditThemeOffice2013 | virtual
~CXTPEditThemeOfficeXP() | CXTPEditThemeOfficeXP | virtual
~CXTPEditThemeVisualStudio2017() | CXTPEditThemeVisualStudio2017 | virtual


CXTPMarkupStaticExtensionIntegerProperty Member List

This is the complete list of members for CXTPMarkupStaticExtensionIntegerProperty, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionIntegerProperty(LPCWSTR lpzName, int nValue=0) | CXTPMarkupStaticExtensionIntegerProperty |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetRawValue() const | CXTPMarkupStaticExtensionIntegerProperty |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(int nValue) | CXTPMarkupStaticExtensionIntegerProperty |
CXTPMarkupStaticExtensionProperty::SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: XTPCalendarTimeLineViewGroup.h Source File

  • Source
  • Calendar
XTPCalendarTimeLineViewGroup.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARTIMELINEVIEWGROUP_H__)
23# define __XTPCALENDARTIMELINEVIEWGROUP_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31# pragma warning(disable : 4100)
32
33class CXTPCalendarEvent;
34class CXTPCalendarTimeLineView;
35class CXTPCalendarTimeLineViewGroup;
36class CXTPCalendarTimeLineViewGroups;
37class CXTPCalendarTimeLineViewEvent;
38class CXTPCalendarTimeLineViewPart;
39
50class _XTP_EXT_CLASS CXTPCalendarTimeLineViewEvent : public CXTPCalendarViewEvent
51{
52public:
60 CXTPCalendarTimeLineViewEvent(CXTPCalendarEvent* pEvent, CXTPCalendarTimeLineViewGroup* pGroup);
61
68 void CalcRect(CDC* pDC);
69
76 CXTPCalendarTimeLineView* GetView() const;
77
84 CXTPCalendarTimeLineViewGroup* GetViewGroup() const
85 {
86 return m_pGroup;
87 }
88
95 virtual CXTPCalendarViewGroup* GetViewGroup_() const;
96
112 virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const
113 {
114 return FALSE;
115 };
116 virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const
117 {
118 return FALSE;
119 }
120
127 virtual BOOL IsVisible() const
128 {
129 return FALSE;
130 };
131
138 virtual BOOL IsSelected() const;
139
149 virtual void AdjustLayout(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber);
150
160 virtual void AdjustLayout2(CDC* pDC, const CRect& rcEventMax, int nEventPlaceNumber)
161 {
162 }
163
171 virtual void Draw(CDC* pDC);
172
179 virtual void ChangeEventPlace(int nNewPlace);
180
187 virtual CXTPCalendarTimeLineViewPart* GetPart() const;
188
195 virtual int GetEventDurationInPixels() const;
196
209 const CRect& GetLastVisibleRect() const;
210
222 void SetLastVisibleRect(const CRect& rc);
223
224protected:
225 CXTPCalendarTimeLineViewGroup* m_pGroup;
227 int m_nEventDurationInPixels;
228 CRect m_rcLastVisible;
229};
230
241class _XTP_EXT_CLASS CXTPCalendarTimeLineViewGroup : public CXTPCalendarViewGroup
242{
243public:
248 typedef CXTPCalendarViewGroup TBase;
249
257 CXTPCalendarTimeLineViewGroup(CXTPCalendarTimeLineView* pView,
258 CXTPCalendarTimeLineViewGroup* pParentGroup = NULL);
259
264 virtual ~CXTPCalendarTimeLineViewGroup();
265
277 virtual void Populate(COleDateTime dtDayDate){};
278
286 virtual void Populate(CXTPCalendarEvents* pEvents);
287
297 virtual void AdjustLayout(CDC* pDC, const CRect& rcGroup);
298
307 virtual void Draw(CDC* pDC, int nOffset);
308
316 virtual void Draw(CDC* pDC);
317
333 virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO* pHitTest) const
334 {
335 return FALSE;
336 };
337 virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO* pHitTest) const
338 {
339 }
340
347 CXTPCalendarTimeLineView* GetView() const
348 {
349 return (CXTPCalendarTimeLineView*)m_pView;
350 }
351
361 virtual CXTPCalendarTimeLineViewEvent* GetViewEvent(int nIndex) const
362 {
363 return (CXTPCalendarTimeLineViewEvent*)m_arEvents.GetAt(nIndex);
364 }
365
373 virtual CXTPCalendarViewDay* GetViewDay_() const
374 {
375 _ASSERTE(FALSE);
376 return 0;
377 }
378
386 virtual CXTPCalendarControl* GetCalendarControl() const;
387
394 int GetGroupHeight();
395
396 void AddViewEvent(CXTPCalendarEvent* pEvent);
397
398 virtual CXTPCalendarViewEvent* CreateViewEvent(CXTPCalendarEvent* pEvent);
399
400protected:
405 typedef CXTPCalendarPtrCollectionT<CXTPCalendarTimeLineViewEvent> TViewEventsCollection;
406
407 CXTPCalendarTimeLineViewGroup* m_pParentGroup;
409 CXTPCalendarTimeLineViewGroups* m_pChildren;
411 CXTPCalendarTimeLineView* m_pView;
412};
413
418class _XTP_EXT_CLASS CXTPCalendarTimeLineViewGroups
419 : public CXTPCalendarPtrCollectionT<CXTPCalendarTimeLineViewGroup>
420{
421};
422
424AFX_INLINE CXTPCalendarViewGroup* CXTPCalendarTimeLineViewEvent::GetViewGroup_() const
425{
426 return m_pGroup;
427}
428
429AFX_INLINE int CXTPCalendarTimeLineViewEvent::GetEventDurationInPixels() const
430{
431 return m_nEventDurationInPixels;
432}
433AFX_INLINE const CRect& CXTPCalendarTimeLineViewEvent::GetLastVisibleRect() const
434{
435 return m_rcLastVisible;
436}
437
438AFX_INLINE void CXTPCalendarTimeLineViewEvent::SetLastVisibleRect(const CRect& rc)
439{
440 m_rcLastVisible = rc;
441}
442
443//===========================================================================
444
445AFX_INLINE void CXTPCalendarTimeLineViewGroup::AddViewEvent(CXTPCalendarEvent* /*pEvent*/)
446{
447 _ASSERTE(FALSE);
448}
449
450//===========================================================================
451
452# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
453#endif // !defined(__XTPCALENDARTIMELINEVIEWGROUP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarEvents
This class represents a simple array collection of CXTPCalendarEvent objects.
Definition XTPCalendarEvents.h:55
CXTPCalendarPtrCollectionT
This class represents a simple array collection of objects.
Definition XTPCalendarPtrCollectionT.h:48
CXTPCalendarTimeLineViewEvent
This class represents an event timeline view portion of the CXTPCalendarViewEvent.
Definition XTPCalendarTimeLineViewGroup.h:51
CXTPCalendarTimeLineViewEvent::IsVisible
virtual BOOL IsVisible() const
This member function is used to get is group visible.
Definition XTPCalendarTimeLineViewGroup.h:127
CXTPCalendarTimeLineViewEvent::GetEventDurationInPixels
virtual int GetEventDurationInPixels() const
Access function to get event duration in pixels.
Definition XTPCalendarTimeLineViewGroup.h:429
CXTPCalendarTimeLineViewEvent::AdjustLayout2
virtual void AdjustLayout2(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout with the theme used.
Definition XTPCalendarTimeLineViewGroup.h:160
CXTPCalendarTimeLineViewEvent::HitTest
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
Definition XTPCalendarTimeLineViewGroup.h:112
CXTPCalendarTimeLineViewEvent::GetPart
virtual CXTPCalendarTimeLineViewPart * GetPart() const
Access function to get the visual part of a CXTPCalendarTimeLineViewPart object.
CXTPCalendarTimeLineViewEvent::GetView
CXTPCalendarTimeLineView * GetView() const
This member function is used to obtain the owner view object.
CXTPCalendarTimeLineViewEvent::IsSelected
virtual BOOL IsSelected() const
This member function is used to get is group selected.
CXTPCalendarTimeLineViewEvent::m_pGroup
CXTPCalendarTimeLineViewGroup * m_pGroup
internal member to keep pointer to CXTPCalendarTimeLineViewGroup
Definition XTPCalendarTimeLineViewGroup.h:225
CXTPCalendarTimeLineViewEvent::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the view content using the specified device context.
CXTPCalendarTimeLineViewEvent::m_nEventDurationInPixels
int m_nEventDurationInPixels
internal nmember to keep event duration in pixels value
Definition XTPCalendarTimeLineViewGroup.h:227
CXTPCalendarTimeLineViewEvent::CXTPCalendarTimeLineViewEvent
CXTPCalendarTimeLineViewEvent(CXTPCalendarEvent *pEvent, CXTPCalendarTimeLineViewGroup *pGroup)
Default object constructor.
CXTPCalendarTimeLineViewEvent::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcEventMax, int nEventPlaceNumber)
This member function is used to adjust the view's layout.
CXTPCalendarTimeLineViewEvent::GetViewGroup
CXTPCalendarTimeLineViewGroup * GetViewGroup() const
Access function to get view group.
Definition XTPCalendarTimeLineViewGroup.h:84
CXTPCalendarTimeLineViewEvent::CalcRect
void CalcRect(CDC *pDC)
This member function is used to calculate a rectangle for an event.
CXTPCalendarTimeLineViewEvent::GetLastVisibleRect
const CRect & GetLastVisibleRect() const
Returns the rect in the client coordinates in which the event was drawn last time.
Definition XTPCalendarTimeLineViewGroup.h:433
CXTPCalendarTimeLineViewEvent::SetLastVisibleRect
void SetLastVisibleRect(const CRect &rc)
Sets the rect in the client coordinates in which the event was drawn last time.
Definition XTPCalendarTimeLineViewGroup.h:438
CXTPCalendarTimeLineViewEvent::ChangeEventPlace
virtual void ChangeEventPlace(int nNewPlace)
This function is used to change the event place number.
CXTPCalendarTimeLineViewEvent::GetViewGroup_
virtual CXTPCalendarViewGroup * GetViewGroup_() const
Access function to get view group.
Definition XTPCalendarTimeLineViewGroup.h:424
CXTPCalendarTimeLineViewEvent::HitTestEx
virtual BOOL HitTestEx(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
Definition XTPCalendarTimeLineViewGroup.h:116
CXTPCalendarTimeLineViewGroup
This class represents an event timeline view portion of the CalendarViewGroup.
Definition XTPCalendarTimeLineViewGroup.h:242
CXTPCalendarTimeLineViewGroup::GetCalendarControl
virtual CXTPCalendarControl * GetCalendarControl() const
Call this member function to obtain a pointer to the calendar control object.
CXTPCalendarTimeLineViewGroup::FillHitTestEx
virtual void FillHitTestEx(XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to fill the pHitTest structure members with the default values for the c...
Definition XTPCalendarTimeLineViewGroup.h:337
CXTPCalendarTimeLineViewGroup::~CXTPCalendarTimeLineViewGroup
virtual ~CXTPCalendarTimeLineViewGroup()
Default class destructor.
CXTPCalendarTimeLineViewGroup::m_pParentGroup
CXTPCalendarTimeLineViewGroup * m_pParentGroup
pointer to the owner view group object
Definition XTPCalendarTimeLineViewGroup.h:407
CXTPCalendarTimeLineViewGroup::HitTest
virtual BOOL HitTest(CPoint pt, XTP_CALENDAR_HITTESTINFO *pHitTest) const
This member function is used to determine which view item, if any, is at a specified position index,...
Definition XTPCalendarTimeLineViewGroup.h:333
CXTPCalendarTimeLineViewGroup::GetGroupHeight
int GetGroupHeight()
Call this member function to obtain the current height of the group.
CXTPCalendarTimeLineViewGroup::GetView
CXTPCalendarTimeLineView * GetView() const
This member function is used to obtain the owner view object.
Definition XTPCalendarTimeLineViewGroup.h:347
CXTPCalendarTimeLineViewGroup::CXTPCalendarTimeLineViewGroup
CXTPCalendarTimeLineViewGroup(CXTPCalendarTimeLineView *pView, CXTPCalendarTimeLineViewGroup *pParentGroup=NULL)
Default object constructor.
CXTPCalendarTimeLineViewGroup::AdjustLayout
virtual void AdjustLayout(CDC *pDC, const CRect &rcGroup)
This member function is used to adjust the view's layout depending on the provided rectangle and call...
CXTPCalendarTimeLineViewGroup::m_pChildren
CXTPCalendarTimeLineViewGroups * m_pChildren
not used in current version - always NULL
Definition XTPCalendarTimeLineViewGroup.h:409
CXTPCalendarTimeLineViewGroup::Draw
virtual void Draw(CDC *pDC)
This member function is used to draw the group using the specified device context.
CXTPCalendarTimeLineViewGroup::GetViewEvent
virtual CXTPCalendarTimeLineViewEvent * GetViewEvent(int nIndex) const
Call this member function to obtain a pointer to the base CXTPCalendarViewEvent* object that correspo...
Definition XTPCalendarTimeLineViewGroup.h:361
CXTPCalendarTimeLineViewGroup::Populate
virtual void Populate(CXTPCalendarEvents *pEvents)
This member function is used to populate the view with data for all event items contained in the view...
CXTPCalendarTimeLineViewGroup::GetViewDay_
virtual CXTPCalendarViewDay * GetViewDay_() const
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
Definition XTPCalendarTimeLineViewGroup.h:373
CXTPCalendarTimeLineViewGroup::Populate
virtual void Populate(COleDateTime dtDayDate)
This member function is used to populate the view with data for all event items contained in the view...
Definition XTPCalendarTimeLineViewGroup.h:277
CXTPCalendarTimeLineViewGroup::Draw
virtual void Draw(CDC *pDC, int nOffset)
This member function is used to draw the group using the specified device context.
CXTPCalendarTimeLineViewGroup::TBase
CXTPCalendarViewGroup TBase
Base class type definition.
Definition XTPCalendarTimeLineViewGroup.h:248
CXTPCalendarTimeLineViewGroup::TViewEventsCollection
CXTPCalendarPtrCollectionT< CXTPCalendarTimeLineViewEvent > TViewEventsCollection
Definition XTPCalendarTimeLineViewGroup.h:405
CXTPCalendarTimeLineViewGroups
This class represents a collection of CXTPCalendarTimeLineViewGroup objects.
Definition XTPCalendarTimeLineViewGroup.h:420
CXTPCalendarTimeLineView
This class implements a specific view portion of the Calendar control - called Timeline view.
Definition XTPCalendarTimeLineView.h:76
CXTPCalendarTimeLineViewPart
Helper base class to implement parts for calendar paint manager objects.
Definition XTPCalendarViewPart.h:1482
CXTPCalendarViewDay
This class represents the day view portion of the CalendarView.
Definition XTPCalendarViewDay.h:555
CXTPCalendarViewEvent
This class represents an event view portion of the CalendarViewGroup.
Definition XTPCalendarViewEvent.h:106
CXTPCalendarViewEvent::GetViewGroup_
virtual CXTPCalendarViewGroup * GetViewGroup_() const =0
Call this member function to obtain a pointer to the containing CXTPCalendarViewDay object.
CXTPCalendarViewGroup
Regular schema:
Definition XTPCalendarViewDay.h:54
XTP_CALENDAR_HITTESTINFO
Basic set of parameters transferred from calendar items to mouse handlers.
Definition XTPCalendarDefines.h:856


Toolkit Pro: XTPChartRangeAreaSeriesLabel.h Source File

  • Source
  • Chart
  • Styles
  • Area
XTPChartRangeAreaSeriesLabel.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTRANGEAREASERIESLABEL_H__)
24# define __XTPCHARTRANGEAREASERIESLABEL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34
40class _XTP_EXT_CLASS CXTPChartRangeAreaSeriesLabel : public CXTPChartPointSeriesLabel
41{
42 DECLARE_SERIAL(CXTPChartRangeAreaSeriesLabel);
43
44public:
49 CXTPChartRangeAreaSeriesLabel();
50
55 virtual ~CXTPChartRangeAreaSeriesLabel();
56
57public:
58public:
70 virtual CXTPChartElementView* CreateView(CXTPChartDeviceContext* pDC,
71 CXTPChartSeriesPointView* pPointView,
72 CXTPChartElementView* pParentView);
73
74 void DoPropExchange(CXTPPropExchange* pPX);
75
76protected:
77};
78
84class _XTP_EXT_CLASS CXTPChartRangeAreaSeriesLabelView : public CXTPChartPointSeriesLabelView
85{
86public:
95 CXTPChartRangeAreaSeriesLabelView(CXTPChartSeriesLabel* pLabel,
96 CXTPChartSeriesPointView* pPointView,
97 CXTPChartElementView* pParentView);
98
105 using CXTPChartPointSeriesLabelView::GetAnchorPoint;
106
107 virtual CXTPChartPointF GetAnchorPoint(BOOL bMinValue) const;
108
109protected:
110 using CXTPChartPointSeriesLabelView::CreateDeviceCommand;
111
112 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC);
113 void CalculateLayout(CXTPChartDeviceContext* pDC);
114};
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
117#endif //#if !defined(__XTPCHARTRANGEAREASERIESLABEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram2DSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPointSeriesLabel
This class abstracts the label of a point series.
Definition XTPChartPointSeriesLabel.h:41
CXTPChartPointSeriesLabelView
This class abstracts the view of the label of a point series.
Definition XTPChartPointSeriesLabelView.h:41
CXTPChartPointSeriesLabelView::GetAnchorPoint
virtual CXTPChartPointF GetAnchorPoint() const
This function calculates the anchor point of the label stem.
CXTPChartRangeAreaSeriesLabel
This class abstracts the label of a bar series.
Definition XTPChartRangeAreaSeriesLabel.h:41
CXTPChartRangeAreaSeriesLabel::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartRangeAreaSeriesLabel::~CXTPChartRangeAreaSeriesLabel
virtual ~CXTPChartRangeAreaSeriesLabel()
Destroys a CXTPChartRangeAreaSeriesLabel object, handles cleanup.
CXTPChartRangeAreaSeriesLabel::CXTPChartRangeAreaSeriesLabel
CXTPChartRangeAreaSeriesLabel()
Constructs a CXTPChartRangeAreaSeriesLabel object.
CXTPChartRangeAreaSeriesLabel::CreateView
virtual CXTPChartElementView * CreateView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
This function creates the view of the bar series label.
CXTPChartRangeAreaSeriesLabelView
This class abstracts the view of the label of a bar series.
Definition XTPChartRangeAreaSeriesLabel.h:85
CXTPChartRangeAreaSeriesLabelView::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)
This function creates a CXTPChartDeviceCommand object.
CXTPChartRangeAreaSeriesLabelView::CXTPChartRangeAreaSeriesLabelView
CXTPChartRangeAreaSeriesLabelView(CXTPChartSeriesLabel *pLabel, CXTPChartSeriesPointView *pPointView, CXTPChartElementView *pParentView)
Constructs a CXTPChartRangeAreaSeriesLabel object.
CXTPChartSeriesLabel
This class abstracts the label of a series.
Definition XTPChartSeriesLabel.h:49
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPPoint2T< float >
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPRibbonControls Member List

This is the complete list of members for CXTPRibbonControls, including all inherited members.

Add(CXTPControl *pControl, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(XTPControlType controlType, int nId, LPCTSTR lpszParameter=NULL, int nBefore=-1, BOOL bTemporary=FALSE) | CXTPControls |
Add(CXTPControl *pControl) | CXTPControls |
AddClone(CXTPControl *pClone, int nBefore=-1, BOOL bRecursive=FALSE) | CXTPControls |
AddMenuItem(CMenu *pMenu, int nIndex) | CXTPControls |
CalcDynamicSize(CDC *pDC, int nLength, DWORD dwMode, const CRect &rcBorder, int nWidth=0) | CXTPControls |
CalcPopupSize(CDC *pDC, int nLength, int nWidth, const CRect &rcBorder) | CXTPControls |
ClearOriginalControls() | CXTPControls |
CommandToIndex(int nIDFind) const | CXTPControls |
Compare(const CXTPControls *pControls) | CXTPControls |
Copy(CXTPControls *pControls, BOOL bRecursive=FALSE) | CXTPRibbonControls | protectedvirtual
CreateOriginalControls() | CXTPControls |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControls() | CXTPControls |
CXTPRibbonControls() | CXTPRibbonControls |
DoPropExchange(CXTPPropExchange *pPX) | CXTPControls | virtual
Duplicate(BOOL bRecursive=FALSE) | CXTPControls |
FindControl(int nId) const | CXTPControls |
FindControl(XTPControlType type, int nId, BOOL bVisible, BOOL bRecursive) const | CXTPControls |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAt(int nIndex) const | CXTPControls |
GetCommandBars() const | CXTPControls |
GetCount() const | CXTPControls |
GetFirst() const | CXTPControls |
GetNext(CXTPControl *&pControl) const | CXTPControls |
GetNext(long nIndex, int nDirection=+1, BOOL bKeyboard=TRUE, BOOL bSkipTemporary=FALSE, BOOL bSkipCollapsed=TRUE) const | CXTPControls |
GetOriginalControls() const | CXTPControls |
GetParent() const | CXTPControls |
GetVisibleAt(int nIndex, BOOL bIgnoreWraps=FALSE) const | CXTPControls |
GetVisibleCount(BOOL bIgnoreWrap=FALSE) const | CXTPControls |
HitTest(CPoint point) const | CXTPControls |
InsertAt(CXTPControl *pControl, int nBefore) | CXTPControls |
IsChanged() const | CXTPControls |
IsOriginalControls() const | CXTPControls |
LoadMenu(CMenu *pMenu) | CXTPControls |
m_arrControls | CXTPControls | protected
m_bOriginalControls | CXTPControls | protected
m_pCommandBars | CXTPControls | protected
m_pOriginalControls | CXTPControls | protected
m_pParent | CXTPControls | protected
MoveBefore(CXTPControl *pControl, int nBefore) | CXTPControls |
OnControlAdded(CXTPControl *pControl) | CXTPControls | protectedvirtual
OnControlRemoved(CXTPControl *pControl) | CXTPRibbonControls | protectedvirtual
OnControlRemoving(CXTPControl *pControl) | CXTPRibbonControls | protectedvirtual
Remove(CXTPControl *pControl) | CXTPControls | virtual
Remove(int nIndex) | CXTPControls |
RemoveAll() | CXTPControls |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPControls |
SetControlType(CXTPControl *pControl, XTPControlType type) | CXTPControls |
SetControlType(int nIndex, XTPControlType type) | CXTPControls |
SetOriginalControls(CXTPOriginalControls *pControls) | CXTPControls |
SetParent(CXTPCommandBar *pParent) | CXTPControls |
ShouldSerializeControl(CXTPControl *pControl) | CXTPRibbonControls | protectedvirtual
Sort() | CXTPControls |
~CXTPControls() | CXTPControls | virtual


Toolkit Pro: XTPChartFunnelSeriesViewBase.h Source File

  • Source
  • Chart
  • Styles
  • Funnel
  • Base
XTPChartFunnelSeriesViewBase.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTFUNNELSERIESVIEWBASE_H__)
24# define __XTPCHARTFUNNELSERIESVIEWBASE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartBorder;
35class CXTPChartFillStyle;
36class CXTPChartDiagramDomain;
37
49class _XTP_EXT_CLASS CXTPChartFunnelSeriesViewBase : public CXTPChartSeriesView
50{
51 DECLARE_DYNAMIC(CXTPChartFunnelSeriesViewBase);
52
53public:
61 CXTPChartFunnelSeriesViewBase(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
62
67 virtual ~CXTPChartFunnelSeriesViewBase();
68
69public:
77 virtual void CalculatePointLayout(CXTPChartDeviceContext* pDC, CRect rcBounds);
78
85 void CalculateLabelLayout(CXTPChartDeviceContext* pDC);
86
98 virtual CXTPChartDiagramDomain* CreateDiagramDomain(CXTPChartDeviceContext* pDC,
99 CRect rcBounds);
100
108 virtual CXTPChartRectF GetInnerBounds() const;
109
118 CXTPChartDiagramDomain* GetDomain() const;
119
127 int GetMaxLabelWidth() const;
128
142 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
143 CRect rcBounds, CXTPChartColor color1,
144 CXTPChartColor color2,
145 CXTPChartColor clrBorder) = 0;
146
147protected:
159 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
160 CXTPChartSeriesPoint* pPoint,
161 CXTPChartElementView* pParentView) = 0;
162
175 virtual CXTPChartDeviceCommand* CreateDeviceCommand(CXTPChartDeviceContext* pDC) = 0;
176
187 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
188 CRect rcBounds) = 0;
189
191 void CalculateValues();
194protected:
195 CXTPChartDiagramDomain* m_pDomain;
196 int m_nMaxLabelWidth;
197};
198
199AFX_INLINE CXTPChartDiagramDomain* CXTPChartFunnelSeriesViewBase::GetDomain() const
200{
201 return m_pDomain;
202}
203
204AFX_INLINE int CXTPChartFunnelSeriesViewBase::GetMaxLabelWidth() const
205{
206 return m_nMaxLabelWidth;
207}
209# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
210#endif //#if !defined(__XTPCHARTFUNNELSERIESVIEWBASE_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartBorder
This class abstracts the border of a chart, it is a kind of chart element.
Definition XTPChartBorder.h:42
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area.
Definition XTPChartDiagram.h:159
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartFunnelSeriesViewBase
This class abstracts the view of a funnel series.This class is a kind of CXTPChartSeriesView.
Definition XTPChartFunnelSeriesViewBase.h:50
CXTPChartFunnelSeriesViewBase::GetInnerBounds
virtual CXTPChartRectF GetInnerBounds() const
Call this function to get the inner bounds of the diagram.
CXTPChartFunnelSeriesViewBase::CalculatePointLayout
virtual void CalculatePointLayout(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to calculate the funnel series point layout.
CXTPChartFunnelSeriesViewBase::CalculateLabelLayout
void CalculateLabelLayout(CXTPChartDeviceContext *pDC)
Call this function to calculate the funnel series label layout.
CXTPChartFunnelSeriesViewBase::CXTPChartFunnelSeriesViewBase
CXTPChartFunnelSeriesViewBase(CXTPChartSeries *pSeries, CXTPChartDiagramView *pDiagramView)
Constructs a CXTPChartFunnelSeriesViewBase object.
CXTPChartFunnelSeriesViewBase::CreateDeviceCommand
virtual CXTPChartDeviceCommand * CreateDeviceCommand(CXTPChartDeviceContext *pDC)=0
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of the fu...
CXTPChartFunnelSeriesViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a label view drawing command object.
CXTPChartFunnelSeriesViewBase::CreateDiagramDomain
virtual CXTPChartDiagramDomain * CreateDiagramDomain(CXTPChartDeviceContext *pDC, CRect rcBounds)
Call this function to create the pie diagram domain object associated with this object.
CXTPChartFunnelSeriesViewBase::CreateSeriesPointView
virtual CXTPChartSeriesPointView * CreateSeriesPointView(CXTPChartDeviceContext *pDC, CXTPChartSeriesPoint *pPoint, CXTPChartElementView *pParentView)=0
Use this function to create the funnel series point view object.
CXTPChartFunnelSeriesViewBase::GetMaxLabelWidth
int GetMaxLabelWidth() const
Obtains maximum allowed label width.
Definition XTPChartFunnelSeriesViewBase.h:204
CXTPChartFunnelSeriesViewBase::m_pDomain
CXTPChartDiagramDomain * m_pDomain
Pointer to the diagram domain.
Definition XTPChartFunnelSeriesViewBase.h:195
CXTPChartFunnelSeriesViewBase::GetDomain
CXTPChartDiagramDomain * GetDomain() const
Use this function to get the pie diagram domain object associated with this object.
Definition XTPChartFunnelSeriesViewBase.h:199
CXTPChartFunnelSeriesViewBase::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds, CXTPChartColor color1, CXTPChartColor color2, CXTPChartColor clrBorder)=0
This function creates a label view drawing command object.
CXTPChartFunnelSeriesViewBase::~CXTPChartFunnelSeriesViewBase
virtual ~CXTPChartFunnelSeriesViewBase()
Destroys a CXTPChartFunnelSeriesViewBase object, handle cleanup.
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPRectT< float >


CXTPMarkupRotateTransform Member List

This is the complete list of members for CXTPMarkupRotateTransform, including all inherited members.

ApplyTransform(const CXTPMarkupTransformationMatrix *pMatrix) | CXTPMarkupRotateTransform | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPMarkupTransform() | CXTPMarkupTransform | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAngle() const | CXTPMarkupRotateTransform |
GetCenterX() const | CXTPMarkupRotateTransform |
GetCenterY() const | CXTPMarkupRotateTransform |
m_pPropertyAngle | CXTPMarkupRotateTransform | static
m_pPropertyCenterX | CXTPMarkupRotateTransform | static
m_pPropertyCenterY | CXTPMarkupRotateTransform | static
SetAngle(double angle) | CXTPMarkupRotateTransform |
SetCenterX(double centerX) | CXTPMarkupRotateTransform |
SetCenterY(double centerY) | CXTPMarkupRotateTransform |


Toolkit Pro: XTPCalendarControlView.h Source File

  • Source
  • Calendar
XTPCalendarControlView.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCONTROLVIEW_H__)
23# define __XTPCALENDARCONTROLVIEW_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableAdvancedWarnings.h"
30# include <afxdtctl.h>
31# include "Common/Base/Diagnostic/XTPEnableAdvancedWarnings.h"
32
33# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
34
35class CXTPCalendarControlViewPrintOptions;
36class CXTPCalendarPageSetupDialog;
37class CXTPNotifySink;
38
43const UINT XTP_ID_CALENDAR_CONTROL = 100;
44const UINT XTP_ID_CALENDARCAPTIONBAR_CONTROL = 101;
45
60class _XTP_EXT_CLASS CXTPCalendarControlViewPrintOptions : public CXTPPrintOptions
61{
63 DECLARE_DYNAMIC(CXTPCalendarControlViewPrintOptions)
66public:
71 CXTPCalendarControlViewPrintOptions();
72
73 COleDateTime m_dtPrintFrom;
74 COleDateTime m_dtPrintTo;
75 BOOL m_bPrintFromToExactly;
79 COleDateTime m_dtMonthViewPrintBeginDate;
81 COleDateTime m_dtMonthViewPrintEndDate;
83 BOOL m_bPrintDateHeader;
84 LOGFONT m_lfDateHeaderFont;
85 LOGFONT m_lfDateHeaderWeekDayFont;
86 LOGFONT m_lfDateHeaderCalendarFont;
88 BOOL m_b3SmallCal;
89 // BOOL m_bNoBackGround;
90 // BOOL m_bGrayBackGround;
91 // BOOL m_bGrayEventBackGround;
92
99 void Set(const CXTPCalendarControlViewPrintOptions* pSrc);
100
108 virtual LCID GetActiveLCID();
109
110protected:
111# ifdef _XTP_ACTIVEX
112
113 DECLARE_DISPATCH_MAP()
114 DECLARE_INTERFACE_MAP()
115
116 DECLARE_OLETYPELIB_EX(CXTPCalendarControlViewPrintOptions);
117
118 afx_msg LPFONTDISP OleGetDateHeaderFont();
119 afx_msg void OleSetDateHeaderFont(LPFONTDISP pFontDisp);
120
121 afx_msg LPFONTDISP OleGetDateHeaderWeekDayFont();
122 afx_msg void OleSetDateHeaderWeekDayFont(LPFONTDISP pFontDisp);
123
124 afx_msg LPFONTDISP OleGetDateHeaderCalendarFont();
125 afx_msg void OleSetDateHeaderCalendarFont(LPFONTDISP pFontDisp);
126
127# endif
128};
129
146class _XTP_EXT_CLASS CXTPCalendarPageSetupDialog : public CPageSetupDialog
147{
148public:
149 enum
150 {
151 IDD = XTP_IDD_CALENDAR_PRINT_PAGE_SETUP
152 };
153
170 CXTPCalendarPageSetupDialog(CXTPCalendarControlViewPrintOptions* pOptions,
171 DWORD dwFlags = PSD_MARGINS | PSD_INWININIINTLMEASURE,
172 CWnd* pParentWnd = NULL);
173
178 virtual ~CXTPCalendarPageSetupDialog();
179
180protected:
181 CXTPCalendarControlViewPrintOptions* m_pOptions;
184 CComboBox m_ctrlPrintFromCmb;
186 CComboBox m_ctrlPrintToCmb;
188 CButton m_ctrlPrintFromTo;
190 CButton m_ctrlPrintDateHeader;
193 CStatic m_ctrlDateHeaderFontLabel;
196 CEdit m_ctrlDateHeaderFont;
198 CButton m_ctrlDateHeaderFontButton;
201 CButton m_ctrlBlackWhitePrinting;
204 CButton m_ctrl3SmallCal;
206 LOGFONT m_lfDateHeader;
207 CDateTimeCtrl m_ctrlMonthViewPrintFrom;
209 CDateTimeCtrl m_ctrlMonthViewPrintTo;
211 CButton m_ctrlMonthViewPrintRange;
212 CEdit m_ctrlHeaderFormat;
213 CEdit m_ctrlFooterFormat;
214 CButton m_ctrlHeaderFormatBtn;
215 CButton m_ctrlFooterFormatBtn;
225 CString FormatFontName(const LOGFONT& lfFont);
226
236 virtual BOOL OnInitDialog();
237
247 virtual void OnOK();
248
256 afx_msg void OnBnClickedPrintDateHeader();
257
264 afx_msg void OnBnClickedDateHeaderFont();
265
266 afx_msg void OnBnClickedHeaderFormat();
267 afx_msg void OnBnClickedFooterFormat();
268 afx_msg void OnBnClickedMonthViewPrintRange();
269 DECLARE_MESSAGE_MAP()
270
271 void UpdateMonthViewDateControls();
272};
273
282class _XTP_EXT_CLASS CXTPCalendarControlView : public CView
283{
285 DECLARE_DYNCREATE(CXTPCalendarControlView)
287protected:
292 CXTPCalendarControlView();
293
294public:
301 virtual CXTPCalendarControl& GetCalendarCtrl();
302
309 virtual CXTPCalendarCaptionBarControl& GetCalendarCaptionBarCtrl();
310
320 virtual void SetCalendarCtrl(CXTPCalendarControl* pCalendar, BOOL bReleaseWhenDestroy = TRUE);
321
328 CXTPCalendarControlViewPrintOptions* GetPrintOptions() const;
329
339 void SetScrollBarCtrl(CScrollBar* pScrollBar, int nBar = SB_VERT);
340
350 virtual BOOL IsShowCaptionBar() const;
351
361 virtual void ShowCaptionBar(BOOL bShow);
362 // move to public area
363 virtual void _ResizeControls();
364
365protected:
370 virtual ~CXTPCalendarControlView();
371
372protected:
382 virtual void DrawDateHeader(BOOL bCalculate, CDC* pDC, CRect& rrcHeader);
383
395 virtual void _DrawDateHeaderCalendar(BOOL bCalculate, CDC* pDC, COleDateTime dtYearMonth,
396 CRect& rrcHeaderCalendar);
397
411 virtual int _GetDateHeaderMonths(COleDateTime& dtYearMonth1, COleDateTime& dtYearMonth2,
412 CString& strHeader1, CString& strHeader2,
413 CString& strHeaderWeekDay);
414
426 virtual CRect AdjustCalendarForPrint(CDC* pDC, CRect rcCalendar, CPrintInfo* pInfo);
427
447 static CRect AFX_CDECL _HimetricToLP(CDC* pDC, const CRect rcHimetric);
448
449protected:
450 COleDateTime m_dtPrintFrom;
451 COleDateTime m_dtPrintTo;
453# ifdef _DEBUG
454 virtual void AssertValid() const;
455 virtual void Dump(CDumpContext& dc) const;
456# endif
457
458 DECLARE_MESSAGE_MAP()
459
460 //{{AFX_VIRTUAL(CXTPCalendarControlView)
461 virtual void OnDraw(CDC* pDC);
462 CScrollBar* GetScrollBarCtrl(int nBar) const;
463
464 virtual void OnPrepareDC(CDC* pDC, CPrintInfo* pInfo);
465 virtual BOOL OnPreparePrinting(CPrintInfo* pInfo);
466
467 virtual void OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo);
468 virtual void OnEndPrinting(CDC* pDC, CPrintInfo* pInfo);
469
470 virtual void OnPrint(CDC* pDC, CPrintInfo* pInfo);
471 virtual void _OnPrint2(CDC* pDC, CPrintInfo* pInfo, CRect rcPrint);
472 //}}AFX_VIRTUAL
473
474 void DoPrintPage(CDC* pDC, CPrintInfo* pInfo);
475
476 void SetupCurrentPrintPage(CDC* pDC, CPrintInfo* pInfo);
477 void SetupCurrentDayViewPrintPage(CDC* pDC, CPrintInfo* pInfo);
478 void SetupCurrentMonthViewPrintPage(CPrintInfo* pInfo);
479
480 void SelectNextPrintPage(CPrintInfo* pInfo);
481 void SelectNextDayViewPrintPage(CPrintInfo* pInfo);
482
483 CRect ExcludeMarginsFromDrawRect(CDC* pDC, CPrintInfo* pInfo);
484 UINT CalculateMonthViewPrintPagesCount();
485
486 //{{AFX_MSG(CXTPCalendarControlView)
487 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
488 afx_msg void OnDestroy();
489 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
490 afx_msg void OnSize(UINT nType, int cx, int cy);
491 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
492 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
493 afx_msg void OnSetFocus(CWnd* pOldWnd);
494 afx_msg void OnPaint();
495 afx_msg void OnUndo();
496 afx_msg void OnCut();
497 afx_msg void OnCopy();
498 afx_msg void OnPaste();
499 afx_msg void OnSelectAll();
500 afx_msg void OnUpdateCommand(CCmdUI* pCmdUI);
501 afx_msg void OnFilePageSetup();
502 //}}AFX_MSG
503
504protected:
505 class CPritAdjustContext
506 {
507 public:
508 CPritAdjustContext()
509 {
510 Reset();
511 }
512
513 void Reset()
514 {
515 m_bAdjust = TRUE;
516 m_rcCalendar.SetRectEmpty();
517 m_rectDraw_prev.SetRectEmpty();
518 m_rcDateHeader.SetRectEmpty();
519 m_rcFooter.SetRectEmpty();
520 m_rcHeader.SetRectEmpty();
521 }
522 BOOL m_bAdjust;
523 CRect m_rcHeader;
524 CRect m_rcDateHeader;
525 CRect m_rcCalendar;
526 CRect m_rcFooter;
527 CRect m_rectDraw_prev;
528 };
529
530 class CBeforePrintState
531 {
532 public:
533 CBeforePrintState();
534
535 public:
536 void ClearData();
537
538 void Save(CXTPCalendarControlView* pView);
539
540 void Restore(CXTPCalendarControlView* pView);
541
542 public:
543 BOOL m_bDataValid;
544 COleDateTimeSpan m_spScale_orig;
545 int m_nTopRow;
546 };
547
548 CBeforePrintState m_beforePrintState;
549 CPritAdjustContext m_pritAdjustContext;
550 CXTPCalendarControl::CUpdateContext* m_pUpdateContext;
551 CBitmap m_bmpGrayDC;
552
553 friend class CCalendarControlCtrl;
554 friend class CBeforePrintState;
555
556protected:
557 void CalendarDayView_ScrolV(int nTopRow);
558
559 CXTPNotifySink* m_pSink;
560
561 virtual void OnEvent_CalendarThemeChanged(XTP_NOTIFY_CODE Event, WPARAM wParam, LPARAM lParam);
562
563protected:
564 CXTPCalendarControlViewPrintOptions* m_pPrintOptions;
566 BOOL m_bShowCaptionBar;
568private:
569 CXTPCalendarCaptionBarControl m_wndCalendarCaptionBar;
571 CXTPCalendarControl* m_pCalendar;
574 BOOL m_bReleaseCalendarWhenDestroy;
575 CScrollBar* m_pVScrollBar;
576 CScrollBar* m_pHScrollBar;
577
578 BOOL m_bDayViewMode;
580public:
581 BOOL m_bPrintDirect;
583 BOOL m_bResizeControlWithView;
586 BOOL m_bPrintFullScale;
589 BOOL m_bPrintFineMode;
592 BOOL m_bPrintRepeatHeaderFooterMode;
594 BOOL m_bDF_mode;
597 COleDateTime m_dtTimeScaleOldMaxTime;
599 COleDateTime m_dtTimeScaleOldMinTime;
601private:
602 int m_nStartCell, m_nEndCell, m_nCurCell, m_nCellSteps,
603 m_nInitialTopCell;
604 CUIntArray m_PageStart;
605 COleDateTimeSpan m_dtInitialScaleInterval;
606
607 COleDateTime m_dtMonthViewPrintBeginDate;
608 COleDateTime m_dtMonthViewPrintEndDate;
609 COleDateTime m_dtSavedMonthViewBeginDate;
613 BOOL m_bMonthViewMode;
614};
615
617AFX_INLINE CXTPCalendarControlViewPrintOptions* CXTPCalendarControlView::GetPrintOptions() const
618{
619 return m_pPrintOptions;
620}
621AFX_INLINE CXTPCalendarCaptionBarControl& CXTPCalendarControlView::GetCalendarCaptionBarCtrl()
622{
623 return m_wndCalendarCaptionBar;
624}
625
626# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
627#endif // !defined(__XTPCALENDARCONTROLVIEW_H__)
XTP_ID_CALENDAR_CONTROL
const UINT XTP_ID_CALENDAR_CONTROL
Identifier of Calendar control child window of CXTPCalendarControlView.
Definition XTPCalendarControlView.h:43
XTPDisableAdvancedWarnings.h
XTPDisableNoisyWarnings.h
XTPEnableAdvancedWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarControl
CXTPCalendarCaptionBarControl represents CalendarCaptionBar control and used as a part of CXTPCalenda...
Definition XTPCalendarCaptionBarControl.h:106
CXTPCalendarControl::CUpdateContext
Class CUpdateContext updates context and redraws control parts depending on input parameters.
Definition XTPCalendarControl.h:1729
CXTPCalendarControl
Class CXTPCalendarControl implements the calendar's view interface.
Definition XTPCalendarControl.h:126
CXTPCalendarControlView
The CXTPCalendarControlView class provides an implementation of the Calendar control as a view class.
Definition XTPCalendarControlView.h:283
CXTPCalendarControlView::CXTPCalendarControlView
CXTPCalendarControlView()
Protected constructor used by dynamic creation.
CXTPCalendarControlView::ShowCaptionBar
virtual void ShowCaptionBar(BOOL bShow)
Call this method to show or hide a Caption Bar control.
CXTPCalendarControlView::_HimetricToLP
static CRect AFX_CDECL _HimetricToLP(CDC *pDC, const CRect rcHimetric)
Converts a rectangle of HIMETRIC units into logical units.
CXTPCalendarControlView::GetPrintOptions
CXTPCalendarControlViewPrintOptions * GetPrintOptions() const
Call this method to access print options for this view.
Definition XTPCalendarControlView.h:617
CXTPCalendarControlView::m_dtPrintFrom
COleDateTime m_dtPrintFrom
Top bound of the printing area for a day view.
Definition XTPCalendarControlView.h:450
CXTPCalendarControlView::m_dtTimeScaleOldMinTime
COleDateTime m_dtTimeScaleOldMinTime
stored original time scale settings during print / print preview ext print support
Definition XTPCalendarControlView.h:599
CXTPCalendarControlView::SetCalendarCtrl
virtual void SetCalendarCtrl(CXTPCalendarControl *pCalendar, BOOL bReleaseWhenDestroy=TRUE)
Call this method to set a custom Calendar control object.
CXTPCalendarControlView::SetScrollBarCtrl
void SetScrollBarCtrl(CScrollBar *pScrollBar, int nBar=SB_VERT)
Use this member function to set external scroll bar control.
CXTPCalendarControlView::GetCalendarCtrl
virtual CXTPCalendarControl & GetCalendarCtrl()
Call this method to access a Calendar control object.
CXTPCalendarControlView::_GetDateHeaderMonths
virtual int _GetDateHeaderMonths(COleDateTime &dtYearMonth1, COleDateTime &dtYearMonth2, CString &strHeader1, CString &strHeader2, CString &strHeaderWeekDay)
Calculates a number of shown months and captions for them to be drawn on the date header.
CXTPCalendarControlView::IsShowCaptionBar
virtual BOOL IsShowCaptionBar() const
Call this method to retrieve a Caption Bar control's visible state.
CXTPCalendarControlView::m_bPrintFineMode
BOOL m_bPrintFineMode
if TRUE - default and all Print Option features, if FALSE - B/W print without Header and Footer
Definition XTPCalendarControlView.h:589
CXTPCalendarControlView::GetCalendarCaptionBarCtrl
virtual CXTPCalendarCaptionBarControl & GetCalendarCaptionBarCtrl()
Call this method to access a CaptionBar control object.
Definition XTPCalendarControlView.h:621
CXTPCalendarControlView::AdjustCalendarForPrint
virtual CRect AdjustCalendarForPrint(CDC *pDC, CRect rcCalendar, CPrintInfo *pInfo)
Adjusts a calendar printing rectangle by adding space for a header, footer and similar areas.
CXTPCalendarControlView::m_bPrintFullScale
BOOL m_bPrintFullScale
extra flag for printing if no Range on Print Option selected, FALSE
Definition XTPCalendarControlView.h:586
CXTPCalendarControlView::m_bPrintDirect
BOOL m_bPrintDirect
if TRUE - the Print Dialog is bypassed.
Definition XTPCalendarControlView.h:581
CXTPCalendarControlView::m_bShowCaptionBar
BOOL m_bShowCaptionBar
Store Office 2007 theme Calendar Caption Bar state.
Definition XTPCalendarControlView.h:566
CXTPCalendarControlView::_DrawDateHeaderCalendar
virtual void _DrawDateHeaderCalendar(BOOL bCalculate, CDC *pDC, COleDateTime dtYearMonth, CRect &rrcHeaderCalendar)
Draws month calendar in the right part of the central date header area.
CXTPCalendarControlView::m_pPrintOptions
CXTPCalendarControlViewPrintOptions * m_pPrintOptions
Printing options.
Definition XTPCalendarControlView.h:564
CXTPCalendarControlView::m_dtPrintTo
COleDateTime m_dtPrintTo
Bottom bound of the printing area for a day view.
Definition XTPCalendarControlView.h:451
CXTPCalendarControlView::m_bDF_mode
BOOL m_bDF_mode
Last page print mode flag (FALSE - print last page same size as other, TRUE (default) - can be shorte...
Definition XTPCalendarControlView.h:594
CXTPCalendarControlView::m_bPrintRepeatHeaderFooterMode
BOOL m_bPrintRepeatHeaderFooterMode
flag to repeat readers and footers on each page
Definition XTPCalendarControlView.h:592
CXTPCalendarControlView::~CXTPCalendarControlView
virtual ~CXTPCalendarControlView()
Destroys a CXTPCalendarControlView object, handles cleanup and deallocation.
CXTPCalendarControlView::m_bResizeControlWithView
BOOL m_bResizeControlWithView
if FALSE - attached Calendar control will not be resized with view.
Definition XTPCalendarControlView.h:583
CXTPCalendarControlView::DrawDateHeader
virtual void DrawDateHeader(BOOL bCalculate, CDC *pDC, CRect &rrcHeader)
Draws main (central) date header area.
CXTPCalendarControlView::m_dtTimeScaleOldMaxTime
COleDateTime m_dtTimeScaleOldMaxTime
stored original time scale settings during print / print preview
Definition XTPCalendarControlView.h:597
CXTPCalendarControlViewPrintOptions
Describes printing options for the Calendar Control.
Definition XTPCalendarControlView.h:61
CXTPCalendarControlViewPrintOptions::CXTPCalendarControlViewPrintOptions
CXTPCalendarControlViewPrintOptions()
Default constructor.
CXTPCalendarControlViewPrintOptions::m_lfDateHeaderCalendarFont
LOGFONT m_lfDateHeaderCalendarFont
Font for day header small calendar.
Definition XTPCalendarControlView.h:86
CXTPCalendarControlViewPrintOptions::m_dtPrintFrom
COleDateTime m_dtPrintFrom
Top bound of the printing area for a day view.
Definition XTPCalendarControlView.h:73
CXTPCalendarControlViewPrintOptions::m_b3SmallCal
BOOL m_b3SmallCal
Print 3 small calendars in header instead of 1.
Definition XTPCalendarControlView.h:88
CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont
LOGFONT m_lfDateHeaderFont
Font for day header caption (Day 1 - Day 2)
Definition XTPCalendarControlView.h:84
CXTPCalendarControlViewPrintOptions::m_lfDateHeaderWeekDayFont
LOGFONT m_lfDateHeaderWeekDayFont
Font for day header week day(Monday, ...)
Definition XTPCalendarControlView.h:85
CXTPCalendarControlViewPrintOptions::m_dtMonthViewPrintBeginDate
COleDateTime m_dtMonthViewPrintBeginDate
Begin date to print for multi month print option.
Definition XTPCalendarControlView.h:79
CXTPCalendarControlViewPrintOptions::m_dtPrintTo
COleDateTime m_dtPrintTo
Bottom bound of the printing area for a day view.
Definition XTPCalendarControlView.h:74
CXTPCalendarControlViewPrintOptions::GetActiveLCID
virtual LCID GetActiveLCID()
Override this member function in a derived class to retrieve the active locale ID.
CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader
BOOL m_bPrintDateHeader
Defines whether to print a date header or not.
Definition XTPCalendarControlView.h:83
CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly
BOOL m_bPrintFromToExactly
Defines whether to cut printing area by showing only area between m_dtPrintFrom and m_dtPrintTo.
Definition XTPCalendarControlView.h:75
CXTPCalendarControlViewPrintOptions::m_dtMonthViewPrintEndDate
COleDateTime m_dtMonthViewPrintEndDate
End date to print for multi month print option.
Definition XTPCalendarControlView.h:81
CXTPCalendarControlViewPrintOptions::Set
void Set(const CXTPCalendarControlViewPrintOptions *pSrc)
Copies all print options from a specified PrintOptions object.
CXTPCalendarPageSetupDialog
Customized Calendar control page setup dialog.
Definition XTPCalendarControlView.h:147
CXTPCalendarPageSetupDialog::m_ctrlMonthViewPrintTo
CDateTimeCtrl m_ctrlMonthViewPrintTo
a check box which swithes between use or not multimonth printing option
Definition XTPCalendarControlView.h:209
CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFontButton
CButton m_ctrlDateHeaderFontButton
A button for choosing CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value.
Definition XTPCalendarControlView.h:198
CXTPCalendarPageSetupDialog::OnBnClickedDateHeaderFont
afx_msg void OnBnClickedDateHeaderFont()
Called when the user clicks the Date Header font button.
CXTPCalendarPageSetupDialog::m_lfDateHeader
LOGFONT m_lfDateHeader
a date time picker for begin date in month view printing
Definition XTPCalendarControlView.h:206
CXTPCalendarPageSetupDialog::OnInitDialog
virtual BOOL OnInitDialog()
Dialog-box initialization.
CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFontLabel
CStatic m_ctrlDateHeaderFontLabel
A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont caption.
Definition XTPCalendarControlView.h:193
CXTPCalendarPageSetupDialog::CXTPCalendarPageSetupDialog
CXTPCalendarPageSetupDialog(CXTPCalendarControlViewPrintOptions *pOptions, DWORD dwFlags=PSD_MARGINS|PSD_INWININIINTLMEASURE, CWnd *pParentWnd=NULL)
Class constructor.
CXTPCalendarPageSetupDialog::m_ctrlPrintFromCmb
CComboBox m_ctrlPrintFromCmb
A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintFrom value.
Definition XTPCalendarControlView.h:184
CXTPCalendarPageSetupDialog::m_ctrlPrintToCmb
CComboBox m_ctrlPrintToCmb
A combo for choosing CXTPCalendarControlViewPrintOptions::m_dtPrintTo value.
Definition XTPCalendarControlView.h:186
CXTPCalendarPageSetupDialog::m_ctrl3SmallCal
CButton m_ctrl3SmallCal
A check box for setting CXTPCalendarControlViewPrintOptions::m_b3SmallCal value.
Definition XTPCalendarControlView.h:204
CXTPCalendarPageSetupDialog::FormatFontName
CString FormatFontName(const LOGFONT &lfFont)
Converts a font name to a human readable string.
CXTPCalendarPageSetupDialog::m_ctrlMonthViewPrintRange
CButton m_ctrlMonthViewPrintRange
Date header font temporary storage.
Definition XTPCalendarControlView.h:211
CXTPCalendarPageSetupDialog::m_ctrlHeaderFormatBtn
CButton m_ctrlHeaderFormatBtn
A button to show header specifiers menu.
Definition XTPCalendarControlView.h:214
CXTPCalendarPageSetupDialog::m_pOptions
CXTPCalendarControlViewPrintOptions * m_pOptions
Pointer to associated print options object.
Definition XTPCalendarControlView.h:181
CXTPCalendarPageSetupDialog::m_ctrlPrintDateHeader
CButton m_ctrlPrintDateHeader
A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintDateHeader value.
Definition XTPCalendarControlView.h:190
CXTPCalendarPageSetupDialog::m_ctrlDateHeaderFont
CEdit m_ctrlDateHeaderFont
A label for displaying CXTPCalendarControlViewPrintOptions::m_lfDateHeaderFont value.
Definition XTPCalendarControlView.h:196
CXTPCalendarPageSetupDialog::OnOK
virtual void OnOK()
Called when the user clicks the OK button (the button with an ID of IDOK).
CXTPCalendarPageSetupDialog::m_ctrlPrintFromTo
CButton m_ctrlPrintFromTo
A check box for editing CXTPCalendarControlViewPrintOptions::m_bPrintFromToExactly value.
Definition XTPCalendarControlView.h:188
CXTPCalendarPageSetupDialog::m_ctrlFooterFormatBtn
CButton m_ctrlFooterFormatBtn
A button to show footer specifiers menu.
Definition XTPCalendarControlView.h:215
CXTPCalendarPageSetupDialog::m_ctrlMonthViewPrintFrom
CDateTimeCtrl m_ctrlMonthViewPrintFrom
a date time picker for end date in month view printing
Definition XTPCalendarControlView.h:207
CXTPCalendarPageSetupDialog::m_ctrlHeaderFormat
CEdit m_ctrlHeaderFormat
An edit for header format string.
Definition XTPCalendarControlView.h:212
CXTPCalendarPageSetupDialog::m_ctrlFooterFormat
CEdit m_ctrlFooterFormat
An edit for footer format string.
Definition XTPCalendarControlView.h:213
CXTPCalendarPageSetupDialog::m_ctrlBlackWhitePrinting
CButton m_ctrlBlackWhitePrinting
A check box for editing CXTPCalendarControlViewPrintOptions::m_bBlackWhitePrinting value.
Definition XTPCalendarControlView.h:201
CXTPCalendarPageSetupDialog::OnBnClickedPrintDateHeader
afx_msg void OnBnClickedPrintDateHeader()
Called when the user clicks the Print Date Header check box.
CXTPCalendarPageSetupDialog::~CXTPCalendarPageSetupDialog
virtual ~CXTPCalendarPageSetupDialog()
Default class constructor, handles members cleanup.


CXTPControlColorSelector Member List

This is the complete list of members for CXTPControlColorSelector, including all inherited members.

AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControl | virtual
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControl | virtual
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlColorSelector() | CXTPControlColorSelector |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControl | virtual
Draw(CDC *pDC) | CXTPControlColorSelector | protectedvirtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPControl | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetColor() const | CXTPControlColorSelector |
GetCommandBar() const | CXTPControl | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControl | virtual
GetPressed() const | CXTPControl | virtual
CXTPControl::GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPControlColorSelector | protectedvirtual
GetStyle() const | CXTPControl |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlColorSelector | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControl | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControlColorSelector | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPControl | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlColorSelector | protectedvirtual
OnMouseHover() | CXTPControl | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlColorSelector | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControl | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlColorSelector | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControlColorSelector | protectedvirtual
OnUnderlineActivate() | CXTPControl | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControl | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetColor(COLORREF clr) | CXTPControlColorSelector |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
~CXTPControl() | CXTPControl | protectedvirtual


Toolkit Pro: XTPTrackThemeVisualStudio2019.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeVisualStudio2019.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2019_H__)
24# define __XTPTRACKTHEMEVISUALSTUDIO2019_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeVisualStudio2019 : public CXTPTrackThemeOffice2013
39{
40public:
45 CXTPTrackThemeVisualStudio2019();
46
52 virtual void RefreshMetrics();
53};
55# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
56#endif //#if !defined(__XTPTRACKTHEMEVISUALSTUDIO2019_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTrackThemeOffice2013
CXTPTrackThemeOffice2013 is a CXTPTrackPaintManager derived class that represents an Office 2013 styl...
Definition XTPTrackThemeOffice2013.h:39
CXTPTrackThemeVisualStudio2019
CXTPTrackThemeVisualStudio2019 is a CXTPTrackThemeOffice2013 derived class that represents a Visual S...
Definition XTPTrackThemeVisualStudio2019.h:39
CXTPTrackThemeVisualStudio2019::CXTPTrackThemeVisualStudio2019
CXTPTrackThemeVisualStudio2019()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeVisualStudio2019::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.


CXTPHyperLink Member List

This is the complete list of members for CXTPHyperLink, including all inherited members.

CreateFont(CFont &font, BOOL bUnderline) | CXTPHyperLink | protectedvirtual
CXTPHyperLink() | CXTPHyperLink |
EnableShellExecute(bool bEnable) | CXTPHyperLink |
EnableToolTips(bool bEnable=true) | CXTPHyperLink |
GetBackColor() const | CXTPHyperLink | virtual
GetHoverColor() const | CXTPHyperLink | virtual
GetLinkColor() const | CXTPHyperLink | virtual
GetLinkCursor() const | CXTPHyperLink | virtual
GetUnderline() const | CXTPHyperLink | virtual
GetURL() const | CXTPHyperLink | virtual
GetVisited() const | CXTPHyperLink | virtual
GetVisitedColor() const | CXTPHyperLink | virtual
GotoURL(LPCTSTR lpszLink=NULL, int nShowCmd=SW_SHOW, LPCTSTR lpszParams=NULL, LPCTSTR lpszDir=NULL) | CXTPHyperLink | virtual
Init() | CXTPHyperLink | protectedvirtual
InitFont() | CXTPHyperLink | protectedvirtual
IsLinkHot() | CXTPHyperLink | virtual
IsTextControl() | CXTPHyperLink | virtual
m_bMouseOver | CXTPHyperLink | protected
m_bPreSubclassInit | CXTPHyperLink | protected
m_bShellExec | CXTPHyperLink | protected
m_bTipEnabled | CXTPHyperLink | protected
m_bUnderline | CXTPHyperLink | protected
m_bVisited | CXTPHyperLink | protected
m_clrBack | CXTPHyperLink | protected
m_clrHover | CXTPHyperLink | protected
m_clrLink | CXTPHyperLink | protected
m_clrVisited | CXTPHyperLink | protected
m_hcurHand | CXTPHyperLink | protected
m_strLink | CXTPHyperLink | protected
m_strTipText | CXTPHyperLink | protected
m_toolTip | CXTPHyperLink | protected
m_xtpFont | CXTPHyperLink | protected
ReportError(int iErrorNo) | CXTPHyperLink | virtual
SetBackColor(COLORREF clrBack) | CXTPHyperLink | virtual
SetColors(COLORREF clrLink, COLORREF clrVisited, COLORREF clrHover) | CXTPHyperLink | virtual
SetLinkCursor(HCURSOR hCursor) | CXTPHyperLink | virtual
SetTipText(LPCTSTR lpszTipText) | CXTPHyperLink |
SetUnderline(bool bUnderline=true) | CXTPHyperLink | virtual
SetURL(LPCTSTR lpszLink) | CXTPHyperLink | virtual
SetVisited(bool bVisited=true) | CXTPHyperLink | virtual
~CXTPHyperLink() | CXTPHyperLink | virtual


CXTPChart3dDeviceContext Member List

This is the complete list of members for CXTPChart3dDeviceContext, including all inherited members.

CXTPChart3dDeviceContext(CXTPChartContainer *pContainer, HDC hDC, CRect rcBounds, CXTPChartDrawingObjectFactory *pDrawingObjectFactory) | CXTPChart3dDeviceContext | protected
CXTPChartDeviceContext(CXTPChartContainer *pContainer, HDC hDC, BOOL bIs3D, CXTPChartDrawingObjectFactory *pDrawingObjectFactory) | CXTPChartDeviceContext | protected
CXTPCmdTarget() | CXTPCmdTarget |
DepthTest(CPoint point, double &dWinZ)=0 | CXTPChart3dDeviceContext | pure virtual
Execute(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceContext | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAntialiasing() const | CXTPChart3dDeviceContext |
GetBounds() const | CXTPChart3dDeviceContext |
GetContainer() const | CXTPChartDeviceContext |
GetDrawingObjectFactory() const | CXTPChartDeviceContext |
GetHDC() const | CXTPChartDeviceContext |
GetLightAmbientColor() const | CXTPChart3dDeviceContext |
GetLightDiffuseColor() const | CXTPChart3dDeviceContext |
GetLightModelAmbientColor() const | CXTPChart3dDeviceContext |
GetLightPosition() const | CXTPChart3dDeviceContext |
GetLightSpecularColor() const | CXTPChart3dDeviceContext |
GetMaterialDiffuseColor() const | CXTPChart3dDeviceContext |
GetMaterialEmissionColor() const | CXTPChart3dDeviceContext |
GetMaterialShininess() const | CXTPChart3dDeviceContext |
GetMaterialSpecularColor() const | CXTPChart3dDeviceContext |
Initialize() | CXTPChartDeviceContext | virtual
Is3D() const | CXTPChartDeviceContext |
IsRenderingAntialiasing() const | CXTPChart3dDeviceContext |
IsSkippingAntialiasing() const | CXTPChart3dDeviceContext |
m_bAntialiasing | CXTPChart3dDeviceContext | protected
m_bInitialPass | CXTPChart3dDeviceContext | protected
m_bIs3D | CXTPChartDeviceContext | protected
m_bRenderingAntialiasing | CXTPChart3dDeviceContext | protected
m_bSkippingAntialiasing | CXTPChart3dDeviceContext | protected
m_cameraState | CXTPChart3dDeviceContext | protected
m_clrLightAmbientColor | CXTPChart3dDeviceContext | protected
m_clrLightDiffuseColor | CXTPChart3dDeviceContext | protected
m_clrLightModelAmbientColor | CXTPChart3dDeviceContext | protected
m_clrLightSpecularColor | CXTPChart3dDeviceContext | protected
m_clrMaterialDiffuseColor | CXTPChart3dDeviceContext | protected
m_clrMaterialEmissionColor | CXTPChart3dDeviceContext | protected
m_clrMaterialSpecularColor | CXTPChart3dDeviceContext | protected
m_fMaterialShininess | CXTPChart3dDeviceContext | protected
m_fMaxModelDistance | CXTPChart3dDeviceContext | protected
m_fMinModelDistance | CXTPChart3dDeviceContext | protected
m_hDC | CXTPChartDeviceContext | protected
m_pContainer | CXTPChartDeviceContext | protected
m_pDrawingObjectFactory | CXTPChartDeviceContext | protected
m_ptLightPosition | CXTPChart3dDeviceContext | protected
m_rcBounds | CXTPChart3dDeviceContext | protected
MeasureMarkupElement(CXTPMarkupUIElement *pMarkupUIElement, CXTPChartFont *pFont)=0 | CXTPChartDeviceContext | pure virtual
MeasureString(const CXTPChartString *pText, CXTPChartFont *pFont)=0 | CXTPChartDeviceContext | pure virtual
OnUpdateCameraState(const CXTPPoint3f &ptPosition, const CXTPPoint3f &ptFocal, const CXTPPoint3f &ptUpVector) | CXTPChart3dDeviceContext |
Project(const CXTPPoint3d &pt3d, CPoint &pt2d, double *pdWinZ=NULL)=0 | CXTPChart3dDeviceContext | pure virtual
Project(const CXTPChart3dBox &box, CRect &rc)=0 | CXTPChart3dDeviceContext | pure virtual
ResetSavedCameraState() | CXTPChart3dDeviceContext | protected
Rotate(const CXTPChart3dRotation &rotation)=0 | CXTPChart3dDeviceContext | pure virtual
SetAntialiasing(BOOL bEnable=TRUE) | CXTPChart3dDeviceContext |
SetLightAmbientColor(const CXTPChartColor &color) | CXTPChart3dDeviceContext |
SetLightDiffuseColor(const CXTPChartColor &color) | CXTPChart3dDeviceContext |
SetLightModelAmbientColor(const CXTPChartColor &color) | CXTPChart3dDeviceContext |
SetLightPosition(const CXTPPoint3f &position) | CXTPChart3dDeviceContext |
SetLightSpecularColor(const CXTPChartColor &color) | CXTPChart3dDeviceContext |
SetMaterialDiffuseColor(const CXTPChartColor &color) | CXTPChart3dDeviceContext |
SetMaterialEmissionColor(const CXTPChartColor &color) | CXTPChart3dDeviceContext |
SetMaterialShininess(float fShininess) | CXTPChart3dDeviceContext |
SetMaterialSpecularColor(const CXTPChartColor &color) | CXTPChart3dDeviceContext |
SetModelDistanceLimits(float fMinDistance, float fMaxDistance) | CXTPChart3dDeviceContext |
Transform(CXTPPoint3d &v, const CXTPPoint3d *pTranslation=NULL, const CXTPChart3dRotation *pRotation=NULL)=0 | CXTPChart3dDeviceContext | pure virtual
Transform(CXTPChart3dBox &box, const CXTPPoint3d *pTranslation=NULL, const CXTPChart3dRotation *pRotation=NULL)=0 | CXTPChart3dDeviceContext | pure virtual
Unproject(const CPoint &pt2d, CXTPPoint3d &pt3d, double dWinZ=0)=0 | CXTPChart3dDeviceContext | pure virtual
~CXTPChart3dDeviceContext() | CXTPChart3dDeviceContext |
~CXTPChartDeviceContext()=0 | CXTPChartDeviceContext | pure virtual


Toolkit Pro: XTPTaskPanelGroup.h Source File

  • Source
  • TaskPanel
XTPTaskPanelGroup.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANELGROUP_H__)
24# define __XTPTASKPANELGROUP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTaskPanel;
34class CXTPTaskPanelItems;
35class CXTPTaskPanelItem;
36class CXTPTaskPanelPaintManager;
37class CXTPTaskPanelGroupItem;
38class CXTPTaskPanelGroupItems;
39
44class _XTP_EXT_CLASS CXTPTaskPanelGroup : public CXTPTaskPanelItem
45{
47 DECLARE_SERIAL(CXTPTaskPanelGroup)
49public:
55 CXTPTaskPanelGroup(CXTPTaskPanel* pPanel = NULL);
56
61 virtual ~CXTPTaskPanelGroup();
62
63public:
70 CXTPTaskPanelItems* GetItems() const;
71
81 CXTPTaskPanelGroupItem* GetAt(int nIndex) const;
82
91 CXTPTaskPanelGroupItem* FindItem(int nID) const;
92
101 CXTPTaskPanelGroupItem* AddLinkItem(UINT nID, int nImage = -1);
102
113 CXTPTaskPanelGroupItem* AddLinkItem(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip = NULL,
114 int nImage = -1);
115
123 CXTPTaskPanelGroupItem* AddTextItem(LPCTSTR strText);
124
132 CXTPTaskPanelGroupItem* AddControlItem(HWND hWnd);
133
143 CXTPTaskPanelGroupItem* HitTest(CPoint pt, CRect* lpRect = 0) const;
144
159 CRect OnReposition(CRect rc, BOOL bRecalcOnly = TRUE);
160
169 void OnAnimate(int nStep);
170
179 void OnPaint(CDC* pDC);
180
187 CRect GetCaptionRect() const;
188
195 CRect GetClientRect() const;
196
203 CRect GetTargetClientRect() const;
204
211 CRect GetTargetCaptionRect() const;
212
223 void SetSpecialGroup(BOOL bSpecial = TRUE);
224
236 BOOL IsSpecialGroup() const;
237
243 void SetExpandable(BOOL bExpandable);
244
251 BOOL IsExpandable() const;
252
259 void ShowCaption(BOOL bShow);
260
270 BOOL IsCaptionVisible() const;
271
281 BOOL IsExpanded() const;
282
292 BOOL IsExpanding() const;
293
300 int GetExpandedClientHeight() const;
301
310 void SetExpanded(BOOL bExpanded);
311
321 BOOL IsDirty() const;
322
329 CRect& GetOuterMargins();
330
337 CRect& GetInnerMargins();
338
345 int GetMinimumClientHeight() const;
346
352 void SetMinimumClientHeight(int nMinClientHeight);
353
360 BOOL IsAcceptFocus() const;
361
375 void SetClientBitmap(UINT nID, COLORREF clrTransparent,
376 int nBackgroundAlignment = DT_RIGHT | DT_BOTTOM);
377
393 virtual void OnFillClient(CDC* pDC, CRect rc);
394
405 XTPTaskPanelItemLayout GetItemLayout() const;
406
418 void SetItemLayout(XTPTaskPanelItemLayout itemLayout);
419
434 void SetSelectedItem(CXTPTaskPanelGroupItem* pItem);
435
449 BOOL IsChildItemDragOver() const;
450
457 int GetItemCount() const;
458
471 BOOL IsScrollButtonEnabled(BOOL bScrollButtonUp) const;
472
483 int GetScrollOffsetPos() const;
484
491 void SetOffsetItem(int nScrollOffset, BOOL bUpdateScrollButtons = TRUE);
492
501 BOOL IsItemVisible(CXTPTaskPanelGroupItem* pItem, BOOL bAllowPart) const;
502
511 int GetOffsetItem() const;
512
534 void Scroll(int nDelta);
535
545 void EnsureVisible(CXTPTaskPanelGroupItem* pItem, BOOL bUpdateScrollButtons = TRUE);
546
563 int GetItemsInRow() const;
564
570 virtual void DoPropExchange(CXTPPropExchange* pPX);
571
583 virtual CRect GetHitTestRect() const;
584
593 virtual CRect GetInvalidateRect() const;
594
601 int GetCaptionHeight() const;
602
611 CSize GetItemIconSize() const;
612
620 void SetIconSize(CSize szItemIcon);
621
632 CXTPTaskPanelGroupItem* GetNextVisibleItem(int nIndex, int nDirection = +1) const;
633
634protected:
646 int CalcInsideHeight();
647
657 virtual void OnCalcClientHeight(CDC* pDC, CRect rc);
658
664 void OnRemoved();
665
666protected:
669 // System accessibility Support
670
671 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
672 virtual HRESULT GetAccessibleDefaultAction(VARIANT varChild, BSTR* pszDefaultAction);
673 virtual HRESULT AccessibleDoDefaultAction(VARIANT varChild);
676private:
677 void RepositionAutoHeightControls(int nHeightOffset);
678 void RepositionScrollOffset();
679
680protected:
681 CRect m_rcGroupTarget;
682 CRect m_rcGroupCurrent;
684 CRect m_rcMarginsOuter;
685 CRect m_rcMarginsInner;
687 int m_nCaptionHeight;
689 BOOL m_bSpecial;
691 BOOL m_bExpandable;
692 BOOL m_bExpanded;
693 BOOL m_bExpanding;
694 int m_nExpandedClientHeight;
695 int m_nMinClientHeight;
696 BOOL m_bCaptionVisible;
698 int m_nScrollOffset;
700 int m_nItemsInRow;
704 CSize m_szItemIcon;
706 CXTPTaskPanelGroupItems* m_pItems;
707 XTPTaskPanelItemLayout m_itemLayout;
709 int m_nBackgroundImage;
711 int m_nBackgroundAlignemnt;
713private:
714# ifdef _XTP_ACTIVEX
716 DECLARE_DISPATCH_MAP()
717 DECLARE_INTERFACE_MAP()
718
719 DECLARE_OLETYPELIB_EX(CXTPTaskPanelGroup)
720
721 enum
722 {
723
724 dispidItems = 10L,
725 dispidSpecial = 11L,
726 dispidCaptionVisible = 12L,
727 dispidExpandable = 13L,
728 dispidExpanded = 14L,
729 };
730
731 afx_msg LPDISPATCH OleGetItems();
732 afx_msg void OleSetIconSize(long cx, long cy);
733 afx_msg void OleSetBackgroundImage(int ImageIndex, int Alignment);
734
736# endif
737
738 friend class CXTPTaskPanel;
739};
740
741AFX_INLINE CXTPTaskPanelItems* CXTPTaskPanelGroup::GetItems() const
742{
743 _ASSERTE(m_pItems);
744 return (CXTPTaskPanelItems*)m_pItems;
745}
746AFX_INLINE int CXTPTaskPanelGroup::GetExpandedClientHeight() const
747{
748 return m_nExpandedClientHeight;
749}
750AFX_INLINE CRect& CXTPTaskPanelGroup::GetOuterMargins()
751{
752 return m_rcMarginsOuter;
753}
754AFX_INLINE CRect& CXTPTaskPanelGroup::GetInnerMargins()
755{
756 return m_rcMarginsInner;
757}
758AFX_INLINE int CXTPTaskPanelGroup::GetItemsInRow() const
759{
760 return m_nItemsInRow;
761}
762AFX_INLINE int CXTPTaskPanelGroup::GetCaptionHeight() const
763{
764 return m_nCaptionHeight;
765}
766
767# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
769#endif // !defined(__XTPTASKPANELGROUP_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPTaskPanelItemLayout
XTPTaskPanelItemLayout
XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the ...
Definition XTPTaskPanelDefines.h:127
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelGroup::m_nScrollOffset
int m_nScrollOffset
Scroll offset of the group.
Definition XTPTaskPanelGroup.h:698
CXTPTaskPanelGroup::m_nMinClientHeight
int m_nMinClientHeight
Minimum client height.
Definition XTPTaskPanelGroup.h:695
CXTPTaskPanelGroup::OnCalcClientHeight
virtual void OnCalcClientHeight(CDC *pDC, CRect rc)
This method is called to calculate the group client area required to display all items.
CXTPTaskPanelGroup::OnReposition
CRect OnReposition(CRect rc, BOOL bRecalcOnly=TRUE)
This method is called when the group is repositioned.
CXTPTaskPanelGroup::GetCaptionHeight
int GetCaptionHeight() const
Gets the height of the group caption.
Definition XTPTaskPanelGroup.h:762
CXTPTaskPanelGroup::GetInnerMargins
CRect & GetInnerMargins()
Gets the inner margins of the group.
Definition XTPTaskPanelGroup.h:754
CXTPTaskPanelGroup::m_rcGroupTarget
CRect m_rcGroupTarget
Target rectangle of the group during animation.
Definition XTPTaskPanelGroup.h:681
CXTPTaskPanelGroup::DoPropExchange
virtual void DoPropExchange(CXTPPropExchange *pPX)
Reads/writes this object from/to an archive.
CXTPTaskPanelGroup::IsScrollButtonEnabled
BOOL IsScrollButtonEnabled(BOOL bScrollButtonUp) const
Determines if a specified group scroll button is enabled/disabled.
CXTPTaskPanelGroup::IsExpandable
BOOL IsExpandable() const
Gets the expandable state of the group.
CXTPTaskPanelGroup::GetItemCount
int GetItemCount() const
Gets the number of items in the group.
CXTPTaskPanelGroup::m_rcMarginsInner
CRect m_rcMarginsInner
Inner margins.
Definition XTPTaskPanelGroup.h:685
CXTPTaskPanelGroup::m_szItemIcon
CSize m_szItemIcon
Size of group item icons.
Definition XTPTaskPanelGroup.h:704
CXTPTaskPanelGroup::~CXTPTaskPanelGroup
virtual ~CXTPTaskPanelGroup()
Destroys a CXTPTaskPanelGroup object, handles cleanup and deallocation.
CXTPTaskPanelGroup::EnsureVisible
void EnsureVisible(CXTPTaskPanelGroupItem *pItem, BOOL bUpdateScrollButtons=TRUE)
Ensures that a specified group item is visible in the Task Panel.
CXTPTaskPanelGroup::CalcInsideHeight
int CalcInsideHeight()
Calculates the height, in pixels, of the available area that can be used to draw the active group if ...
CXTPTaskPanelGroup::SetIconSize
void SetIconSize(CSize szItemIcon)
Sets the size for group item icons.
CXTPTaskPanelGroup::IsSpecialGroup
BOOL IsSpecialGroup() const
Determines if the group is special.
CXTPTaskPanelGroup::GetClientRect
CRect GetClientRect() const
Gets the rectangle of the client.
CXTPTaskPanelGroup::GetItems
CXTPTaskPanelItems * GetItems() const
Gets the collection of group items.
Definition XTPTaskPanelGroup.h:741
CXTPTaskPanelGroup::m_bExpanded
BOOL m_bExpanded
TRUE if the group is expanded.
Definition XTPTaskPanelGroup.h:692
CXTPTaskPanelGroup::GetInvalidateRect
virtual CRect GetInvalidateRect() const
Gets the rectangle of the "drawing zone".
CXTPTaskPanelGroup::GetExpandedClientHeight
int GetExpandedClientHeight() const
Gets the client height of the expanded group.
Definition XTPTaskPanelGroup.h:746
CXTPTaskPanelGroup::AddLinkItem
CXTPTaskPanelGroupItem * AddLinkItem(UINT nID, int nImage=-1)
Adds a link item to the group.
CXTPTaskPanelGroup::m_itemLayout
XTPTaskPanelItemLayout m_itemLayout
Currently set layout for the group.
Definition XTPTaskPanelGroup.h:707
CXTPTaskPanelGroup::FindItem
CXTPTaskPanelGroupItem * FindItem(int nID) const
Retrieves the group item with a specified identifier.
CXTPTaskPanelGroup::m_rcMarginsOuter
CRect m_rcMarginsOuter
Outer margins.
Definition XTPTaskPanelGroup.h:684
CXTPTaskPanelGroup::SetSpecialGroup
void SetSpecialGroup(BOOL bSpecial=TRUE)
Specifies if the group should be special.
CXTPTaskPanelGroup::HitTest
CXTPTaskPanelGroupItem * HitTest(CPoint pt, CRect *lpRect=0) const
Determines which group item, if any, is at a specified point.
CXTPTaskPanelGroup::Scroll
void Scroll(int nDelta)
Scrolls to the item at a specified scroll offset in the group when the group has scroll buttons.
CXTPTaskPanelGroup::GetAt
CXTPTaskPanelGroupItem * GetAt(int nIndex) const
Retrieves the group item at a specified index in the collection of group items.
CXTPTaskPanelGroup::AddControlItem
CXTPTaskPanelGroupItem * AddControlItem(HWND hWnd)
Adds a control item to the group.
CXTPTaskPanelGroup::GetNextVisibleItem
CXTPTaskPanelGroupItem * GetNextVisibleItem(int nIndex, int nDirection=+1) const
Retrieves the index of the next/previous visible item in this group from a specified index.
CXTPTaskPanelGroup::OnFillClient
virtual void OnFillClient(CDC *pDC, CRect rc)
This method is called when the Task Panel group client face is drawn.
CXTPTaskPanelGroup::SetMinimumClientHeight
void SetMinimumClientHeight(int nMinClientHeight)
Sets the minimum client height for the group.
CXTPTaskPanelGroup::OnPaint
void OnPaint(CDC *pDC)
This method is called to draw the group.
CXTPTaskPanelGroup::AddLinkItem
CXTPTaskPanelGroupItem * AddLinkItem(UINT nID, LPCTSTR lpCaption, LPCTSTR lpTooltip=NULL, int nImage=-1)
Adds a link item to the group.
CXTPTaskPanelGroup::SetExpandable
void SetExpandable(BOOL bExpandable)
Sets the expandable state for the group.
CXTPTaskPanelGroup::IsAcceptFocus
BOOL IsAcceptFocus() const
Determines if the group can accept focus.
CXTPTaskPanelGroup::m_nCaptionHeight
int m_nCaptionHeight
Height of the caption.
Definition XTPTaskPanelGroup.h:687
CXTPTaskPanelGroup::m_bSpecial
BOOL m_bSpecial
TRUE if the group is special.
Definition XTPTaskPanelGroup.h:689
CXTPTaskPanelGroup::IsChildItemDragOver
BOOL IsChildItemDragOver() const
Determines if the item currently being dragged over the group is a child item of the group.
CXTPTaskPanelGroup::GetOffsetItem
int GetOffsetItem() const
Gets the index of the first visible item in the group.
CXTPTaskPanelGroup::IsCaptionVisible
BOOL IsCaptionVisible() const
Determines if the caption of the group is shown/hidden.
CXTPTaskPanelGroup::GetHitTestRect
virtual CRect GetHitTestRect() const
Gets the rectangle of the "tooltip zone".
CXTPTaskPanelGroup::m_nItemsInRow
int m_nItemsInRow
Number of group items in a row when using the xtpTaskPanelBehaviourToolbox XTPTaskPanelBehaviour.
Definition XTPTaskPanelGroup.h:700
CXTPTaskPanelGroup::GetMinimumClientHeight
int GetMinimumClientHeight() const
Gets the minimum client height of the group.
CXTPTaskPanelGroup::GetItemIconSize
CSize GetItemIconSize() const
Gets the size of group item icons.
CXTPTaskPanelGroup::m_nBackgroundImage
int m_nBackgroundImage
Index of the background image for the group within the image manager.
Definition XTPTaskPanelGroup.h:709
CXTPTaskPanelGroup::OnRemoved
void OnRemoved()
This method is called when the group is removed from the parent groups collection.
CXTPTaskPanelGroup::m_bExpandable
BOOL m_bExpandable
TRUE if the group is expandable.
Definition XTPTaskPanelGroup.h:691
CXTPTaskPanelGroup::m_bCaptionVisible
BOOL m_bCaptionVisible
TRUE if the caption is visible.
Definition XTPTaskPanelGroup.h:696
CXTPTaskPanelGroup::GetItemsInRow
int GetItemsInRow() const
Gets the number of group items per row in the group.
Definition XTPTaskPanelGroup.h:758
CXTPTaskPanelGroup::IsItemVisible
BOOL IsItemVisible(CXTPTaskPanelGroupItem *pItem, BOOL bAllowPart) const
Determines if a specified item is visible in the group.
CXTPTaskPanelGroup::GetScrollOffsetPos
int GetScrollOffsetPos() const
Gets the scroll offset of the first visible item in the group.
CXTPTaskPanelGroup::m_rcGroupCurrent
CRect m_rcGroupCurrent
Current rectangle of the group during animation.
Definition XTPTaskPanelGroup.h:682
CXTPTaskPanelGroup::m_nExpandedClientHeight
int m_nExpandedClientHeight
Expanded client height.
Definition XTPTaskPanelGroup.h:694
CXTPTaskPanelGroup::GetTargetCaptionRect
CRect GetTargetCaptionRect() const
Gets the target rectangle of the caption.
CXTPTaskPanelGroup::GetTargetClientRect
CRect GetTargetClientRect() const
Gets the target rectangle of the client.
CXTPTaskPanelGroup::SetClientBitmap
void SetClientBitmap(UINT nID, COLORREF clrTransparent, int nBackgroundAlignment=DT_RIGHT|DT_BOTTOM)
Sets the client bitmap for the group.
CXTPTaskPanelGroup::AddTextItem
CXTPTaskPanelGroupItem * AddTextItem(LPCTSTR strText)
Adds a text item to the group.
CXTPTaskPanelGroup::CXTPTaskPanelGroup
CXTPTaskPanelGroup(CXTPTaskPanel *pPanel=NULL)
Constructs a CXTPTaskPanelGroup object.
CXTPTaskPanelGroup::m_nBackgroundAlignemnt
int m_nBackgroundAlignemnt
Alignment of the background image for the group.
Definition XTPTaskPanelGroup.h:711
CXTPTaskPanelGroup::GetCaptionRect
CRect GetCaptionRect() const
Gets the rectangle of the caption.
CXTPTaskPanelGroup::IsDirty
BOOL IsDirty() const
Determines if the group position is "dirty" (i.e.
CXTPTaskPanelGroup::ShowCaption
void ShowCaption(BOOL bShow)
Shows/hides the caption of the group.
CXTPTaskPanelGroup::SetExpanded
void SetExpanded(BOOL bExpanded)
Expands/collapses the group.
CXTPTaskPanelGroup::SetSelectedItem
void SetSelectedItem(CXTPTaskPanelGroupItem *pItem)
Selects a specified group item.
CXTPTaskPanelGroup::IsExpanded
BOOL IsExpanded() const
Determines if the group is expanded/collapsed.
CXTPTaskPanelGroup::GetItemLayout
XTPTaskPanelItemLayout GetItemLayout() const
Gets the item layout of the group.
CXTPTaskPanelGroup::GetOuterMargins
CRect & GetOuterMargins()
Gets the outer margins of the group.
Definition XTPTaskPanelGroup.h:750
CXTPTaskPanelGroup::OnAnimate
void OnAnimate(int nStep)
This method is called when an animation step is executed.
CXTPTaskPanelGroup::IsExpanding
BOOL IsExpanding() const
Determines if the group is expanding.
CXTPTaskPanelGroup::m_bExpanding
BOOL m_bExpanding
TRUE if the group is expanding.
Definition XTPTaskPanelGroup.h:693
CXTPTaskPanelGroup::SetOffsetItem
void SetOffsetItem(int nScrollOffset, BOOL bUpdateScrollButtons=TRUE)
Sets the index for the first visible item in the group.
CXTPTaskPanelGroup::SetItemLayout
void SetItemLayout(XTPTaskPanelItemLayout itemLayout)
Sets the item layout for the group.
CXTPTaskPanelGroup::m_pItems
CXTPTaskPanelGroupItems * m_pItems
Collection of items.
Definition XTPTaskPanelGroup.h:706
CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group.
Definition XTPTaskPanelGroupItem.h:39
CXTPTaskPanelGroupItems
CXTPTaskPanelGroupItems represents a collection of items in a group.
Definition XTPTaskPanelItems.h:271
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
CXTPTaskPanelItems
CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items.
Definition XTPTaskPanelItems.h:44
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.
Definition XTPTaskPanelPaintManager.h:115


CXTPCustomizeKeyboardPage Member List

This is the complete list of members for CXTPCustomizeKeyboardPage, including all inherited members.

AddCategories(CXTPControls *pControls) | CXTPCustomizeKeyboardPage |
AddCategories(UINT nIDResource, BOOL bListSubItems=FALSE) | CXTPCustomizeKeyboardPage |
AddCategory(LPCTSTR strCategory, CMenu *pMenu, BOOL bListSubItems=FALSE) | CXTPCustomizeKeyboardPage |
AdjustResizeRect(CSize &rcWindow) | CXTPResize | protectedvirtual
AutoLoadPlacement(LPCTSTR pszSection) | CXTPResize |
CResizeItemArray typedef | CXTPResize | protected
CXTPCustomizeKeyboardPage(CXTPCustomizeSheet *pSheet) | CXTPCustomizeKeyboardPage |
CXTPPropertyPage() | CXTPPropertyPage |
CXTPPropertyPage(UINT nIDTemplate, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPPropertyPage(LPCTSTR lpszTemplateName, UINT nIDCaption=0) | CXTPPropertyPage |
CXTPResize(CWnd *pWnd, const UINT nFlags=0) | CXTPResize |
Defer(HDWP &hdwp, CXTPResizeItem *pItem, int dx, int dy) | CXTPResize | protectedvirtual
EnableControls() | CXTPCustomizeKeyboardPage |
FindCategory(LPCTSTR strCategory) const | CXTPCustomizeKeyboardPage |
GetCaption() const | CXTPPropertyPage |
GetCategoryInfo(int nIndex) const | CXTPCustomizeKeyboardPage |
GetFrameAccelerator() const | CXTPCustomizeKeyboardPage |
GetMinMaxInfo(MINMAXINFO *pMMI) | CXTPResize | protected
HasFlag(XTPResize eFlag) | CXTPResize | protected
IDD enum value | CXTPCustomizeKeyboardPage |
Init() | CXTPResize | protectedvirtual
InsertCategory(LPCTSTR strCategory, int nIndex=-1) | CXTPCustomizeKeyboardPage |
LoadPlacement(LPCTSTR pszSection) | CXTPResize |
m_arrCategories | CXTPCustomizeKeyboardPage | protected
m_arrItems | CXTPResize | protected
m_bModified | CXTPPropertyPage | protected
m_comboCategory | CXTPCustomizeKeyboardPage |
m_dwData | CXTPPropertyPage |
m_editShortcutKey | CXTPCustomizeKeyboardPage |
m_iCategory | CXTPCustomizeKeyboardPage |
m_lboxCommands | CXTPCustomizeKeyboardPage |
m_lboxKeys | CXTPCustomizeKeyboardPage |
m_nFlagsXX | CXTPResize | protected
m_pSheet | CXTPCustomizeKeyboardPage | protected
m_pWnd | CXTPResize | protected
m_scSizeIcon | CXTPResize | protected
m_strDesc | CXTPCustomizeKeyboardPage |
m_strSection | CXTPResize | protected
m_szInitWindow | CXTPResize | protected
m_szMax | CXTPResize | protected
m_szMin | CXTPResize | protected
m_szWindow | CXTPResize | protected
Offset(CPoint ptOffset) | CXTPResize | protected
ReloadList() | CXTPCustomizeKeyboardPage |
RemoveAllControls() | CXTPResize | protected
RemoveResize(UINT nID) | CXTPResize | protected
Reset() | CXTPResize | protected
SavePlacement(LPCTSTR pszSection) | CXTPResize |
SetCaption(LPCTSTR lpszCaption) | CXTPPropertyPage |
SetFlag(XTPResize eFlag) | CXTPResize | protected
SetMaxSize(CSize &sz) | CXTPResize |
SetMinSize(CSize &sz) | CXTPResize |
SetResize(UINT nID, XTP_RESIZE left, XTP_RESIZE top, XTP_RESIZE right, XTP_RESIZE bottom) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZERECT &rrcSizing) | CXTPResize |
SetResize(UINT nID, HWND hWnd, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(UINT nID, const XTP_RESIZEPOINT &rpTopLeft, const XTP_RESIZEPOINT &rpBottomRight) | CXTPResize |
SetResize(CWnd *pWnd, const CXTPResizeRect &rrcSizing, CRect rcWindow) | CXTPResize | protected
Size() | CXTPResize | protectedvirtual
UpdateAcellTable(LPACCEL lpAccel, int nSize) | CXTPCustomizeKeyboardPage |
UpdateControlRect(CWnd *pWnd) | CXTPResize | protected
UpdatePage(void) | CXTPPropertyPage | virtual
~CXTPCustomizeKeyboardPage() | CXTPCustomizeKeyboardPage |
~CXTPPropertyPage() | CXTPPropertyPage |
~CXTPResize() | CXTPResize | virtual


CXTPTreeVisualStudio2017Theme Member List

This is the complete list of members for CXTPTreeVisualStudio2017Theme, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPControlTheme() | CXTPControlTheme |
CXTPTreeOffice2013Theme() | CXTPTreeOffice2013Theme |
CXTPTreeTheme() | CXTPTreeTheme |
CXTPTreeVisualStudio2017Theme() | CXTPTreeVisualStudio2017Theme |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crTextDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetItemTextColor(UINT uState, bool bTreeHasFocus, DWORD dwStyle, COLORREF crBackDef, CTreeCtrl *pTreeBase) const | CXTPTreeTheme | virtual
GetThemeStyle() const | CXTPControlTheme |
GetTreeBackColor() const | CXTPTreeTheme | virtual
GetTreeTextColor() const | CXTPTreeTheme | virtual
IsDrawFocusRect() const | CXTPTreeTheme | inline
IsThemeDark() const | CXTPTreeTheme | inlinevirtual
m_bDarkTheme | CXTPTreeTheme | protected
m_bDrawFocusRect | CXTPTreeTheme | protected
m_crBack | CXTPTreeTheme | protected
m_crBackDisabled | CXTPTreeTheme | protected
m_crBackSelected | CXTPTreeTheme | protected
m_crBackSelectedDisabled | CXTPTreeTheme | protected
m_crBackSelectedInactive | CXTPTreeTheme | protected
m_crText | CXTPTreeTheme | protected
m_crTextDisabled | CXTPTreeTheme | protected
m_crTextSelected | CXTPTreeTheme | protected
m_crTextSelectedDisabled | CXTPTreeTheme | protected
m_crTextSelectedInactive | CXTPTreeTheme | protected
m_nTheme | CXTPControlTheme | protected
RefreshMetrics(CXTPTreeBase *pTreeBase) | CXTPTreeOffice2013Theme | virtual
SetTheme(HWND hWnd, XTPControlTheme nTheme) | CXTPControlTheme | static
~CXTPTreeTheme() | CXTPTreeTheme | virtual


Toolkit Pro: XTPDatePickerList.h Source File

  • Source
  • Calendar
  • DatePicker
XTPDatePickerList.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERITEMLIST_H__)
23# define _XTPDATEPICKERITEMLIST_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPDatePickerControl;
32
45class _XTP_EXT_CLASS CXTPDatePickerList : public CWnd
46{
47 friend class CXTPDatePickerControl;
48
49public:
73 CXTPDatePickerList(CXTPDatePickerControl* pControl, COleDateTime dtStartMonth);
74
79 virtual ~CXTPDatePickerList();
80
96 BOOL Create(CRect rcList);
97
98 // Operations
99public:
109 int GetMonthInterval() const;
110
111public:
123 void ScrollDown(int nCount = 1);
124
136 void ScrollUp(int nCount = 1);
137
138private:
139 static void AFX_CDECL ShiftMonthUp(int& nYear, int& nMonth, const int nCount);
140 static void AFX_CDECL ShiftMonthDown(int& nYear, int& nMonth, const int nCount);
141
142protected:
149 CSize GetListSize() const;
150
160 BOOL IsSelected(int nX, CRect rcItem) const;
161
163 DECLARE_MESSAGE_MAP()
166 // {{AFX_MSG(CXTPDatePickerList)
167 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
168 afx_msg void OnPaint();
169 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
170 afx_msg void OnTimer(UINT_PTR nIDEvent);
171 // }}AFX_MSG
172
173private:
175 DISABLE_WNDCREATE()
177 // Attributes
178protected:
179 CXTPDatePickerControl* m_pControl;
180 COleDateTime m_dtStartMonth;
182 COleDateTime m_dtMiddleMonth;
183 COleDateTime m_dtSelMonth;
185 int m_nItemsAbove;
186 int m_nItemsBelow;
188 CRect m_rcListControl;
189};
190
191# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
192#endif // !defined(_XTPDATEPICKERITEMLIST_H__)
XTPDisableNoisyWarnings.h
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
CXTPDatePickerList
This class provides the functionality of a list control which displays month names.
Definition XTPDatePickerList.h:46
CXTPDatePickerList::~CXTPDatePickerList
virtual ~CXTPDatePickerList()
Destroys a CXTPDatePickerList object, handles cleanup and deallocation.
CXTPDatePickerList::ScrollDown
void ScrollDown(int nCount=1)
Implements scroll down functionality.
CXTPDatePickerList::Create
BOOL Create(CRect rcList)
Creates the List Window with position and sizes.
CXTPDatePickerList::ScrollUp
void ScrollUp(int nCount=1)
Implements scroll up functionality.
CXTPDatePickerList::GetListSize
CSize GetListSize() const
Calculates size of list by font and control sizes.
CXTPDatePickerList::CXTPDatePickerList
CXTPDatePickerList(CXTPDatePickerControl *pControl, COleDateTime dtStartMonth)
Constructs a CXTPDatePickerList object.
CXTPDatePickerList::GetMonthInterval
int GetMonthInterval() const
Returns an interval between start month and selected month.
CXTPDatePickerList::IsSelected
BOOL IsSelected(int nX, CRect rcItem) const
Determines whether an item is selected.


CXTPImageManagerIconSet Member List

This is the complete list of members for CXTPImageManagerIconSet, including all inherited members.

CIconSetMap typedef | CXTPImageManagerIconSet |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPImageManagerIconSet(UINT nID, CXTPImageManager *pImageManager) | CXTPImageManagerIconSet |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetIcon(UINT nWidth, BOOL bScaled=TRUE) | CXTPImageManagerIconSet |
GetIcons() | CXTPImageManagerIconSet |
GetID() const | CXTPImageManagerIconSet |
RefreshAll() | CXTPImageManagerIconSet |
RemoveAll() | CXTPImageManagerIconSet |
SetVectorCheckedIcon(IStream *pStream, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorCheckedIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorDisabledIcon(IStream *pStream, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorDisabledIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorHotIcon(IStream *pStream, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorHotIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorIcon(IStream *pStream, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorPressedIcon(IStream *pStream, UINT nWidth) | CXTPImageManagerIconSet |
SetVectorPressedIcon(CXTPImageManagerVectorImageHandle hIcon, UINT nWidth) | CXTPImageManagerIconSet |
~CXTPImageManagerIconSet() | CXTPImageManagerIconSet |


CXTPChartSeries Member List

This is the complete list of members for CXTPChartSeries, including all inherited members.

CXTPChartElement() | CXTPChartElement |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPChartSeries() | CXTPChartSeries |
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartSeries | virtual
GetAppearance() const | CXTPChartElement |
GetArgumentScaleType() const | CXTPChartSeries |
GetContent() const | CXTPChartElement |
GetDiagram() const | CXTPChartSeries |
GetLegendItem() const | CXTPChartSeries |
GetLegendText() const | CXTPChartSeries |
GetName() const | CXTPChartSeries |
GetOwner() const | CXTPChartElement |
GetPaletteIndex() const | CXTPChartSeries |
GetPointLegendFormat() const | CXTPChartSeries |
GetPoints() const | CXTPChartSeries |
GetStyle() const | CXTPChartSeries |
GetValueScaleType() const | CXTPChartSeries |
Is3D() const | CXTPChartObject |
IsLegendVisible() const | CXTPChartSeries |
IsVisible() const | CXTPChartSeries |
m_bLegendVisible | CXTPChartSeries | protected
m_bVisible | CXTPChartSeries | protected
m_nArgumentScaleType | CXTPChartSeries | protected
m_nPaletteIndex | CXTPChartSeries | protected
m_nValueScaleType | CXTPChartSeries | protected
m_pDiagram | CXTPChartSeries | protected
m_pLegendItem | CXTPChartSeries | protected
m_pPointLegendFormat | CXTPChartSeries | protected
m_pPoints | CXTPChartSeries | protected
m_pStyle | CXTPChartSeries | protected
m_strLegendText | CXTPChartSeries | protected
m_strName | CXTPChartSeries | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartSeries | virtual
SetArgumentScaleType(XTPChartScaleType scaleType) | CXTPChartSeries |
SetDiagram(CXTPChartDiagram *pDiagram) | CXTPChartSeries |
SetLegendText(LPCTSTR lpszLegendText) | CXTPChartSeries |
SetLegendVisible(BOOL bVisible) | CXTPChartSeries |
SetName(LPCTSTR lpszName) | CXTPChartSeries |
SetPointLegendFormat(LPCTSTR lpszFormat) | CXTPChartSeries |
SetPoints(CXTPChartSeriesPointCollection *pPoints) | CXTPChartSeries |
SetStyle(CXTPChartSeriesStyle *pView) | CXTPChartSeries |
SetValueScaleType(XTPChartScaleType scaleType) | CXTPChartSeries |
SetVisible(BOOL bVisible) | CXTPChartSeries |
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartSeries() | CXTPChartSeries | virtual


Toolkit Pro: XTPControlGalleryItem.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryItem.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYITEM_H__)
24# define __XTPCONTROLGALLERYITEM_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPControlGalleryItem : public CXTPCmdTarget
39{
40 DECLARE_DYNAMIC(CXTPControlGalleryItem);
41
42public:
47 CXTPControlGalleryItem();
48
53 ~CXTPControlGalleryItem();
54
55public:
64 virtual CSize GetSize();
65
66 static int AFX_CDECL GetDefaultHeight();
67
74 void SetSize(CSize szItem);
75
87 virtual void Draw(CDC* pDC, CXTPControlGallery* pGallery, CRect rcItem, BOOL bEnabled,
88 BOOL bSelected, BOOL bPressed, BOOL bChecked);
89
96 CXTPImageManagerIcon* GetImage();
97
104 BOOL IsLabel() const;
105
113 void SetCaption(LPCTSTR lpszCaption);
114
122 void SetToolTip(LPCTSTR lpszToolTip);
123
132 CString GetToolTip() const;
133
142 CString GetCaption() const;
143
151 void SetEnabled(BOOL bEnabled);
152
159 BOOL GetEnabled() const;
160
167 int GetIndex() const;
168
174 void SetID(int nId);
175
182 int GetID() const;
183
189 void SetData(DWORD_PTR dwData);
190
198 DWORD_PTR GetData() const;
199
207 void SetDescription(LPCTSTR lpszDescription);
208
215 CString GetDescription() const;
216
222 void SetImageWidth(int nImageWidth);
223
230 int GetImageWidth() const;
231
238 CXTPMarkupUIElement* GetMarkupUIElement() const;
239
246 virtual int GetImageIndex();
247
253 virtual void SetImageIndex(int nImageIndex);
254
255 virtual BOOL OnClick();
256
257protected:
258 int m_nId;
259 int m_nIndex;
260 int m_nImage;
261 CString m_strCaption;
262 CString m_strToolTip;
263 CString m_strDescriptionText;
264 CXTPControlGalleryItems* m_pItems;
265 DWORD_PTR m_dwData;
266 CSize m_szItem;
267 BOOL m_bLabel;
268 BOOL m_bEnabled;
269 int m_nImageWidth;
271 CXTPMarkupUIElement* m_pMarkupUIElement;
272
273# ifdef _XTP_COMMANDBARS_ACTIVEX
276 DECLARE_DISPATCH_MAP()
277 DECLARE_INTERFACE_MAP()
278
279 DECLARE_OLETYPELIB_EX(CXTPControlGalleryItem);
280 COleVariant m_oleTag;
281 BOOL OleGetLabel();
282 DECLARE_PROPERTY(ImageIndex, int);
283 DECLARE_PROPERTY(ItemWidth, int);
284 DECLARE_PROPERTY(ItemHeight, int);
285
287# endif
288
289 friend class CXTPControlGalleryItems;
290 friend class CXTPControlGallery;
291};
292
293AFX_INLINE CString CXTPControlGalleryItem::GetToolTip() const
294{
295 return m_strToolTip;
296}
297AFX_INLINE CString CXTPControlGalleryItem::GetCaption() const
298{
299 return m_strCaption;
300}
301AFX_INLINE void CXTPControlGalleryItem::SetDescription(LPCTSTR lpszDescription)
302{
303 m_strDescriptionText = lpszDescription;
304}
305AFX_INLINE CString CXTPControlGalleryItem::GetDescription() const
306{
307 return m_strDescriptionText;
308}
309AFX_INLINE void CXTPControlGalleryItem::SetID(int nId)
310{
311 m_nId = nId;
312}
313AFX_INLINE int CXTPControlGalleryItem::GetID() const
314{
315 return m_nId;
316}
317
318AFX_INLINE BOOL CXTPControlGalleryItem::IsLabel() const
319{
320 return m_bLabel;
321}
322AFX_INLINE void CXTPControlGalleryItem::SetToolTip(LPCTSTR lpszToolTip)
323{
324 m_strToolTip = lpszToolTip;
325}
326
327AFX_INLINE void CXTPControlGalleryItem::SetData(DWORD_PTR dwData)
328{
329 m_dwData = dwData;
330}
331AFX_INLINE DWORD_PTR CXTPControlGalleryItem::GetData() const
332{
333 return m_dwData;
334}
335
336AFX_INLINE void CXTPControlGalleryItem::SetImageWidth(int nImageWidth)
337{
338 m_nImageWidth = nImageWidth;
339}
340
341AFX_INLINE int CXTPControlGalleryItem::GetImageWidth() const
342{
343 return m_nImageWidth;
344}
345
346AFX_INLINE BOOL CXTPControlGalleryItem::OnClick()
347{
348 return FALSE;
349}
350AFX_INLINE CXTPMarkupUIElement* CXTPControlGalleryItem::GetMarkupUIElement() const
351{
352 return m_pMarkupUIElement;
353}
354
355# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
357#endif // __XTPCONTROLGALLERYITEM_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class.
Definition XTPControlGallery.h:63
CXTPControlGalleryItem
CXTPControlGalleryItem is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItem.h:39
CXTPControlGalleryItem::SetImageIndex
virtual void SetImageIndex(int nImageIndex)
Sets the preferred image index.
CXTPControlGalleryItem::GetToolTip
CString GetToolTip() const
Retrieves the tooltip of the item.
Definition XTPControlGalleryItem.h:293
CXTPControlGalleryItem::m_pItems
CXTPControlGalleryItems * m_pItems
Parent items collection.
Definition XTPControlGalleryItem.h:264
CXTPControlGalleryItem::m_strToolTip
CString m_strToolTip
Tooltip of the item.
Definition XTPControlGalleryItem.h:262
CXTPControlGalleryItem::SetSize
void SetSize(CSize szItem)
Call this method to set the size of the individual item.
CXTPControlGalleryItem::GetData
DWORD_PTR GetData() const
Retrieves the application-supplied, 32-bit value associated with the item.
Definition XTPControlGalleryItem.h:331
CXTPControlGalleryItem::GetID
int GetID() const
Call this member to get the item's identifier.
Definition XTPControlGalleryItem.h:313
CXTPControlGalleryItem::GetImage
CXTPImageManagerIcon * GetImage()
Retrieves the image of the item.
CXTPControlGalleryItem::SetDescription
void SetDescription(LPCTSTR lpszDescription)
Call this member to set the description of the item.
Definition XTPControlGalleryItem.h:301
CXTPControlGalleryItem::m_bLabel
BOOL m_bLabel
TRUE if item is label.
Definition XTPControlGalleryItem.h:267
CXTPControlGalleryItem::m_nImage
int m_nImage
Image index.
Definition XTPControlGalleryItem.h:260
CXTPControlGalleryItem::m_nIndex
int m_nIndex
Index of the item.
Definition XTPControlGalleryItem.h:259
CXTPControlGalleryItem::SetID
void SetID(int nId)
Call this member to set the identifier of the item.
Definition XTPControlGalleryItem.h:309
CXTPControlGalleryItem::SetToolTip
void SetToolTip(LPCTSTR lpszToolTip)
Call this method to set the tooltip of the item.
Definition XTPControlGalleryItem.h:322
CXTPControlGalleryItem::SetCaption
void SetCaption(LPCTSTR lpszCaption)
Call this method to set the caption of the item.
CXTPControlGalleryItem::SetEnabled
void SetEnabled(BOOL bEnabled)
Call this member to enable or disable the item.
CXTPControlGalleryItem::CXTPControlGalleryItem
CXTPControlGalleryItem()
Constructs a CXTPControlGalleryItem object.
CXTPControlGalleryItem::GetDescription
CString GetDescription() const
Call this member to get the item's description.
Definition XTPControlGalleryItem.h:305
CXTPControlGalleryItem::GetSize
virtual CSize GetSize()
This method is called to get the size of the item.
CXTPControlGalleryItem::GetCaption
CString GetCaption() const
Retrieves the caption of the item.
Definition XTPControlGalleryItem.h:297
CXTPControlGalleryItem::GetImageWidth
int GetImageWidth() const
Get the preferred image width.
Definition XTPControlGalleryItem.h:341
CXTPControlGalleryItem::SetData
void SetData(DWORD_PTR dwData)
Sets the 32-bit value associated with the item.
Definition XTPControlGalleryItem.h:327
CXTPControlGalleryItem::m_szItem
CSize m_szItem
Size of the item; CSize(0, 0) - to use default value.
Definition XTPControlGalleryItem.h:266
CXTPControlGalleryItem::Draw
virtual void Draw(CDC *pDC, CXTPControlGallery *pGallery, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked)
This method is called to draw the item.
CXTPControlGalleryItem::IsLabel
BOOL IsLabel() const
Call this method to determine if the item is a label.
Definition XTPControlGalleryItem.h:318
CXTPControlGalleryItem::m_dwData
DWORD_PTR m_dwData
32-bit data
Definition XTPControlGalleryItem.h:265
CXTPControlGalleryItem::~CXTPControlGalleryItem
~CXTPControlGalleryItem()
Destroys a CXTPControlGalleryItem object, handles cleanup and deallocation.
CXTPControlGalleryItem::m_nImageWidth
int m_nImageWidth
preferred image width (0) - to use default value
Definition XTPControlGalleryItem.h:269
CXTPControlGalleryItem::m_strDescriptionText
CString m_strDescriptionText
Description of the item.
Definition XTPControlGalleryItem.h:263
CXTPControlGalleryItem::GetIndex
int GetIndex() const
Retrieves the index of the item.
CXTPControlGalleryItem::GetEnabled
BOOL GetEnabled() const
Call this member to get the state of the item.
CXTPControlGalleryItem::m_bEnabled
BOOL m_bEnabled
TRUE to enable, FALSE to disable.
Definition XTPControlGalleryItem.h:268
CXTPControlGalleryItem::SetImageWidth
void SetImageWidth(int nImageWidth)
Set the preferred image width.
Definition XTPControlGalleryItem.h:336
CXTPControlGalleryItem::GetImageIndex
virtual int GetImageIndex()
Gets the index of the used image.
CXTPControlGalleryItem::GetMarkupUIElement
CXTPMarkupUIElement * GetMarkupUIElement() const
This member functions are used to get stored CXTPMarkupUIElement object.
Definition XTPControlGalleryItem.h:350
CXTPControlGalleryItem::m_strCaption
CString m_strCaption
Caption of the item.
Definition XTPControlGalleryItem.h:261
CXTPControlGalleryItem::m_nId
int m_nId
Identifier.
Definition XTPControlGalleryItem.h:258
CXTPControlGalleryItems
CXTPControlGalleryItems is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItems.h:39
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


CXTPTaskPanelOffice2003ThemePlain Member List

This is the complete list of members for CXTPTaskPanelOffice2003ThemePlain, including all inherited members.

BlendColor(COLORREF clrFrom, COLORREF clrTo, int nAlpha) | CXTPTaskPanelPaintManager | protected
CreateGripperBitmaps() | CXTPTaskPanelPaintManager | protected
CreateGripperIcon(HICON &hIcon, UINT nIDResource, COLORREF clrGripperBack) | CXTPTaskPanelPaintManager | protected
CXTPTaskPanelOffice2003ThemePlain() | CXTPTaskPanelOffice2003ThemePlain |
CXTPTaskPanelOfficeXPThemePlain() | CXTPTaskPanelOfficeXPThemePlain |
CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager |
CXTPTaskPanelPaintManagerPlain() | CXTPTaskPanelPaintManagerPlain |
DrawCaptionGripper(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawCaptionGripperBitmap(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bExpanded, BOOL bHot, CRect rc) | CXTPTaskPanelPaintManager | protected
DrawCaptionGripperSigns(CDC *pDC, CPoint pt, COLORREF clr, BOOL bExpanded) | CXTPTaskPanelPaintManager | protected
DrawDragArrow(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rc, BOOL bAfter=FALSE) | CXTPTaskPanelPaintManager | protectedvirtual
DrawFocusRect(CDC *pDC, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupCaption(CDC *pDC, CXTPTaskPanelGroup *pGroup, BOOL bDraw) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClient(CDC *pDC, CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
DrawGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
DrawGroupClientItems(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
DrawGroupItem(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemFrame(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc) | CXTPTaskPanelPaintManager | virtual
DrawGroupItemImage(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithText(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawGroupItemImageWithTextBelow(CDC *pDC, CXTPTaskPanelGroupItem *pItem, CRect rc, BOOL bDraw) | CXTPTaskPanelPaintManager | protected
DrawItemCaption(CDC *pDC, CXTPTaskPanelItem *pItem, CRect rcText, UINT nFormat) | CXTPTaskPanelPaintManager | protectedvirtual
DrawItemImage(CDC *pDC, CXTPTaskPanelItem *pItem, CPoint ptIcon, CXTPImageManagerIcon *pImage, CSize szIcon) | CXTPTaskPanelPaintManager | protectedvirtual
DrawScrollButton(CDC *pDC, CXTPTaskPanelScrollButton *pScrollButton) | CXTPTaskPanelPaintManager | virtual
FillGroupClientFace(CDC *pDC, CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManagerPlain | virtual
FillTaskPanel(CDC *pDC, CXTPTaskPanel *pTaskPanel) | CXTPTaskPanelPaintManagerPlain | virtual
FreeBitmaps() | CXTPTaskPanelPaintManager | protected
GetCaptionGripperWidth(CXTPTaskPanelGroup *pGroup, CRect rc) | CXTPTaskPanelPaintManager | protectedvirtual
GetControlMargins(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetGroupColors(BOOL bSpecial) | CXTPTaskPanelPaintManager |
GetGroupColors(CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupInnerMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupOuterMargins(const CXTPTaskPanelGroup *pGroup) | CXTPTaskPanelPaintManager | virtual
GetGroupSpacing(const CXTPTaskPanel *pPanel) | CXTPTaskPanelPaintManager | virtual
GetHighlightOffset(CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | protectedvirtual
GetItemFont(CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemIconPadding(const CXTPTaskPanelItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemInnerMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
GetItemOuterMargins(const CXTPTaskPanelGroupItem *pItem) | CXTPTaskPanelPaintManager | virtual
m_bBoldCaption | CXTPTaskPanelPaintManager |
m_bCaptionScrollButton | CXTPTaskPanelPaintManager |
m_bEmbossedDisabledText | CXTPTaskPanelPaintManager |
m_bEmulateEplorerTheme | CXTPTaskPanelPaintManager |
m_bInvertDragRect | CXTPTaskPanelPaintManager |
m_bLeftRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bmpGrippers | CXTPTaskPanelPaintManager | protected
m_bOfficeBorder | CXTPTaskPanelPaintManager | protected
m_bOfficeCaption | CXTPTaskPanelPaintManagerPlain | protected
m_bOfficeHighlight | CXTPTaskPanelPaintManager |
m_bRightRoundedCorner | CXTPTaskPanelPaintManager | protected
m_bRoundedFrame | CXTPTaskPanelPaintManagerPlain | protected
m_bUseBitmapGrippers | CXTPTaskPanelPaintManager | protected
m_bUseStandardCaptionFont | CXTPTaskPanelPaintManager | protected
m_bUseStandardItemsFont | CXTPTaskPanelPaintManager | protected
m_clrBackground | CXTPTaskPanelPaintManager | protected
m_clrHighlightBorder | CXTPTaskPanelPaintManager | protected
m_clrHighlightHot | CXTPTaskPanelPaintManager | protected
m_clrHighlightPressed | CXTPTaskPanelPaintManager | protected
m_clrHighlightSelected | CXTPTaskPanelPaintManager | protected
m_eGripper | CXTPTaskPanelPaintManager |
m_groupNormal | CXTPTaskPanelPaintManager | protected
m_groupSpecial | CXTPTaskPanelPaintManager | protected
m_hGripperNormal | CXTPTaskPanelPaintManager | protected
m_hGripperSpecial | CXTPTaskPanelPaintManager | protected
m_nCaptionHeight | CXTPTaskPanelPaintManager | protected
m_nCaptionTextFormat | CXTPTaskPanelPaintManager | protected
m_nGroupSpacing | CXTPTaskPanelPaintManager |
m_nItemTextFormat | CXTPTaskPanelPaintManager | protected
m_rcControlMargins | CXTPTaskPanelPaintManager |
m_rcGroupIconPadding | CXTPTaskPanelPaintManager |
m_rcGroupInnerMargins | CXTPTaskPanelPaintManager |
m_rcGroupOuterMargins | CXTPTaskPanelPaintManager |
m_rcImageLayoutIconPadding | CXTPTaskPanelPaintManager |
m_rcItemIconPadding | CXTPTaskPanelPaintManager |
m_rcItemInnerMargins | CXTPTaskPanelPaintManager |
m_rcItemOuterMargins | CXTPTaskPanelPaintManager |
m_xtpFontCaption | CXTPTaskPanelPaintManager | protected
m_xtpFontIcon | CXTPTaskPanelPaintManager | protected
m_xtpFontIconBold | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHot | CXTPTaskPanelPaintManager | protected
m_xtpFontIconHotBold | CXTPTaskPanelPaintManager | protected
Rectangle(CDC *pDC, CRect rc, COLORREF clrPen, COLORREF clrBrush) | CXTPTaskPanelPaintManager | protected
rectDefault | CXTPTaskPanelPaintManager | static
RefreshMetrics() | CXTPTaskPanelOffice2003ThemePlain | virtual
SetCaptionFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardCaptionFont=FALSE) | CXTPTaskPanelPaintManager |
SetItemsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardItemsFont=FALSE) | CXTPTaskPanelPaintManager |
SetTextFormat(int nTextFormat, BOOL bCaption=FALSE) | CXTPTaskPanelPaintManager |
~CXTPTaskPanelPaintManager() | CXTPTaskPanelPaintManager | virtual


Toolkit Pro: XTPScrollBarPaintManager.h Source File

  • Source
  • Common
  • ScrollBar
XTPScrollBarPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARPAINTMANAGER_H__)
24# define __XTPSCROLLBARPAINTMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPScrollBase;
34
39class _XTP_EXT_CLASS CXTPScrollBarPaintManager : public CObject
40{
41 DECLARE_DYNAMIC(CXTPScrollBarPaintManager);
42
43public:
48 CXTPScrollBarPaintManager();
49
50public:
57 virtual void DrawScrollBar(CDC* pDC, CXTPScrollBase* pScrollBar);
58
63 virtual void RefreshMetrics();
64
65protected:
66 struct XTPScrollMetricsV
67 {
68 BOOL bEnabled;
69 CRect rcScrollBar;
70 CRect rcArrowUp;
71 CRect rcArrowDown;
72 CRect rcTrack;
73 CRect rcLowerTrack;
74 CRect rcBtnTrack;
75 CRect rcUpperTrack;
76 };
77
78 struct XTPScrollMetricsH
79 {
80 BOOL bEnabled;
81 CRect rcScrollBar;
82 CRect rcArrowLeft;
83 CRect rcArrowRight;
84 CRect rcTrack;
85 CRect rcLowerTrack;
86 CRect rcBtnTrack;
87 CRect rcUpperTrack;
88 };
89
97 static void AFX_CDECL CalcVScroll(CXTPScrollBase* pScroll, XTPScrollMetricsV* pVScroll);
98
106 static void AFX_CDECL CalcHScroll(CXTPScrollBase* pScroll, XTPScrollMetricsH* pHScroll);
107
115 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
116
124 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
125
133 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
134
142 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
143
151 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsV* pMetrics);
152
160 virtual void DrawBackground(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
161
169 virtual void DrawButtons(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
170
178 virtual void DrawArrows(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
179
187 virtual void DrawTracker(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
188
196 virtual void DrawThumbButton(CDC* pDC, CXTPScrollBase* pScroll, XTPScrollMetricsH* pMetrics);
197
204 virtual void DrawGripper(CDC* pDC, CXTPScrollBase* pScroll);
205
206protected:
207 enum XTPArrowGlyph
208 {
209 xtpArrowGlyphLeft,
210 xtpArrowGlyphRight,
211 xtpArrowGlyphUp,
212 xtpArrowGlyphDown
213 };
214
226 void DrawArrowGlyph(CDC* pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled,
227 COLORREF clrText = COLORREF_NULL);
228
229public:
230 int m_cxHScroll;
231 int m_cyHScroll;
233 int m_cxVScroll;
234 int m_cyVScroll;
236 int m_cThumb;
238 COLORREF m_crBackPushed;
239 COLORREF m_crBackHilite;
240 COLORREF m_crBorderHilite;
241 COLORREF m_crBorder;
242 COLORREF m_crBack;
243};
244
245# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
247#endif //#if !defined(__XTPSCROLLBARPAINTMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBarPaintManager::m_cyVScroll
int m_cyVScroll
Height, in pixels, of the arrow bitmap on a vertical scroll bar.
Definition XTPScrollBarPaintManager.h:234
CXTPScrollBarPaintManager::m_crBack
COLORREF m_crBack
Color of background.
Definition XTPScrollBarPaintManager.h:242
CXTPScrollBarPaintManager::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws verical scrollbar background only.
CXTPScrollBarPaintManager::m_crBackHilite
COLORREF m_crBackHilite
Color when border.
Definition XTPScrollBarPaintManager.h:239
CXTPScrollBarPaintManager::CXTPScrollBarPaintManager
CXTPScrollBarPaintManager()
Constructs a CXTPScrollBarPaintManager object.
CXTPScrollBarPaintManager::CalcVScroll
static void AFX_CDECL CalcVScroll(CXTPScrollBase *pScroll, XTPScrollMetricsV *pVScroll)
Computes vertical scrollbar mertics.
CXTPScrollBarPaintManager::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar buttons only.
CXTPScrollBarPaintManager::DrawArrowGlyph
void DrawArrowGlyph(CDC *pDC, CRect rcArrow, XTPArrowGlyph glyph, BOOL bEnabled, COLORREF clrText=COLORREF_NULL)
Draws scrollbar button arrow glyph.
CXTPScrollBarPaintManager::m_crBorderHilite
COLORREF m_crBorderHilite
Color of border when highlighted.
Definition XTPScrollBarPaintManager.h:240
CXTPScrollBarPaintManager::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar button arrows only.
CXTPScrollBarPaintManager::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar trackers only.
CXTPScrollBarPaintManager::m_cxVScroll
int m_cxVScroll
Width, in pixels, of a vertical scroll bar;.
Definition XTPScrollBarPaintManager.h:233
CXTPScrollBarPaintManager::DrawGripper
virtual void DrawGripper(CDC *pDC, CXTPScrollBase *pScroll)
Draws scrollbar gripper only.
CXTPScrollBarPaintManager::DrawButtons
virtual void DrawButtons(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar buttons only.
CXTPScrollBarPaintManager::DrawTracker
virtual void DrawTracker(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar trackers only.
CXTPScrollBarPaintManager::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar background only.
CXTPScrollBarPaintManager::DrawArrows
virtual void DrawArrows(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar button arrows only.
CXTPScrollBarPaintManager::DrawScrollBar
virtual void DrawScrollBar(CDC *pDC, CXTPScrollBase *pScrollBar)
This method is called to draw all scrollbar parts.
CXTPScrollBarPaintManager::CalcHScroll
static void AFX_CDECL CalcHScroll(CXTPScrollBase *pScroll, XTPScrollMetricsH *pHScroll)
Computes horizontal scrollbar mertics.
CXTPScrollBarPaintManager::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsH *pMetrics)
Draws horizontal scrollbar thumb button only.
CXTPScrollBarPaintManager::RefreshMetrics
virtual void RefreshMetrics()
Recalculates scrollbar metrics.
CXTPScrollBarPaintManager::m_cxHScroll
int m_cxHScroll
Width, in pixels, of the arrow bitmap on a horizontal scroll bar.
Definition XTPScrollBarPaintManager.h:230
CXTPScrollBarPaintManager::m_crBorder
COLORREF m_crBorder
Color of border.
Definition XTPScrollBarPaintManager.h:241
CXTPScrollBarPaintManager::m_crBackPushed
COLORREF m_crBackPushed
Color when pushed.
Definition XTPScrollBarPaintManager.h:238
CXTPScrollBarPaintManager::m_cThumb
int m_cThumb
Width of thumb button.
Definition XTPScrollBarPaintManager.h:236
CXTPScrollBarPaintManager::DrawThumbButton
virtual void DrawThumbButton(CDC *pDC, CXTPScrollBase *pScroll, XTPScrollMetricsV *pMetrics)
Draws vertical scrollbar thumb button only.
CXTPScrollBarPaintManager::m_cyHScroll
int m_cyHScroll
Height, in pixels, of a horizontal scroll bar.
Definition XTPScrollBarPaintManager.h:231
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222


Toolkit Pro: XTPDockingPaneThemeVisualStudio2003.h Source File

  • Source
  • DockingPane
  • Themes
XTPDockingPaneThemeVisualStudio2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2003_H__)
24# define __XTPDOCKINGPANETHEMEVISUALSTUDIO2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
41class _XTP_EXT_CLASS CXTPDockingPaneVisualStudio2003Theme : public CXTPDockingPaneGripperedTheme
42{
43public:
48 CXTPDockingPaneVisualStudio2003Theme();
49
54 virtual void RefreshMetrics();
55
56protected:
67 virtual void DrawCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
68 const CString& strTitle, BOOL bActive, BOOL bVertical);
69
80 virtual COLORREF FillCaptionPart(CDC* pDC, CXTPDockingPaneBase* pPane, CRect rcCaption,
81 BOOL bActive, BOOL bVertical);
82
83protected:
84 BOOL m_bGradientCaption;
85 int m_nCaptionButtonSize;
86};
87
88# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
90#endif // !defined(__XTPDOCKINGPANETHEMEVISUALSTUDIO2003_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneBase
CXTPDockingPaneBase is a standalone class.
Definition XTPDockingPaneBase.h:69
CXTPDockingPaneGripperedTheme
CXTPDockingPaneGripperedTheme is a CXTPDockingPaneDefaultTheme derived class that represents a grippe...
Definition XTPDockingPaneThemeGrippered.h:41
CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme is a CXTPDockingPaneGripperedTheme derived class that represents...
Definition XTPDockingPaneThemeVisualStudio2003.h:42
CXTPDockingPaneVisualStudio2003Theme::m_bGradientCaption
BOOL m_bGradientCaption
TRUE to draw gradient caption.
Definition XTPDockingPaneThemeVisualStudio2003.h:84
CXTPDockingPaneVisualStudio2003Theme::CXTPDockingPaneVisualStudio2003Theme
CXTPDockingPaneVisualStudio2003Theme()
Constructs a CXTPDockingPaneVisualStudio2003Theme object.
CXTPDockingPaneVisualStudio2003Theme::FillCaptionPart
virtual COLORREF FillCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, BOOL bActive, BOOL bVertical)
Draws the background of the pane caption.
CXTPDockingPaneVisualStudio2003Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the pane.
CXTPDockingPaneVisualStudio2003Theme::DrawCaptionPart
virtual void DrawCaptionPart(CDC *pDC, CXTPDockingPaneBase *pPane, CRect rcCaption, const CString &strTitle, BOOL bActive, BOOL bVertical)
Draws the common part of a tabbed and floating caption.


Toolkit Pro: XTPPaintManager.h Source File

  • Source
  • CommandBars
XTPPaintManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPPAINTMANAGER_H__)
24# define __XTPPAINTMANAGER_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPWinThemeWrapper;
34class CXTPControlButton;
35class CXTPControlPopup;
36class CXTPControl;
37class CXTPToolBar;
38class CXTPCommandBar;
39class CXTPCommandBars;
40class CXTPPopupBar;
41class CXTPControlComboBox;
42class CXTPTabControl;
43class CXTPDockBar;
44class CXTPControlEdit;
45class CXTPImageManagerIcon;
46class CXTPDialogBar;
47
48class CXTPStatusBar;
49class CXTPStatusBarPane;
50class CXTPStatusBarSwitchPane;
51class CXTPStatusBarPaintManager;
52
53class CXTPMessageBar;
54class CXTPMessageBarButton;
55class CXTPMessageBarPaintManager;
56
57class CXTPCommandBarKeyboardTip;
58class CXTPShadowManager;
59class CXTPResourceImages;
60class CXTPResourceImage;
61
62/*
63 * Paint manager
64 */
65class CXTPRibbonPaintManager;
66class CXTPControlGalleryPaintManager;
67class CXTPSliderPaintManager;
68class CXTPProgressPaintManager;
69class CXTPFramePaintManager;
70class CXTPScrollBarPaintManager;
71
79enum XTPSpecialControl
80{
81 xtpButtonExpandToolbar,
82 xtpButtonExpandMenu,
83 xtpButtonHideFloating,
84 xtpButtonExpandFloating
85};
86
96struct XTP_COMMANDBARS_ICONSINFO
97{
98 BOOL bUseFadedIcons;
99 BOOL bUseDisabledIcons;
101 BOOL bIconsWithShadow;
104 BOOL bOfficeStyleDisabledIcons;
106};
107
112class _XTP_EXT_CLASS CXTPPaintManagerFont : public CFont
113{
114public:
119 CXTPPaintManagerFont()
120 : m_bStandardFont(TRUE)
121 {
122 }
123
131 BOOL SetCustomFont(const LOGFONT* lpLogFont);
132
139 void EnableCustomFont(BOOL bEnable = TRUE);
140
142 _XTP_DEPRECATED_IN_FAVOR(EnableCustomFont)
143 void SetCustomFont(BOOL bCustomFont)
144 {
145 EnableCustomFont(bCustomFont);
146 }
156 BOOL SetStandardFont(const LOGFONT* lpLogFont);
157
158protected:
159 BOOL m_bStandardFont;
160};
161
163# define XTP_COMMANDBAR_MIN_FONT_HEIGHT 10
164# define XTP_COMMANDBAR_MIN_CONTROL_HEIGHT \
165 (XTP_COMMANDBAR_MIN_FONT_HEIGHT + (XTP_COMMANDBAR_MIN_FONT_HEIGHT * 80) / 100)
166# define XTP_COMMANDBAR_SPLITBUTTON_DROPDOWN_WIDTH (XTP_COMMANDBAR_MIN_FONT_HEIGHT + 1)
167# define XTP_COMMANDBAR_TRIANGLE_SIZE XTP_DPI_Y(10)
168# define XTP_COMMANDBAR_BUTTON_TEXT_OFFSET XTP_DPI_Y(2)
169
170# define XTP_COMMANDBAR_TEXT_HEIGHT_FACTOR 110
171# define XTP_COMMANDBAR_CONTROL_HEIGHT_FACTOR 190
174class CXTPControlGalleryItem;
175class CXTPPaintManager;
176XTP_FORWARD_ENUM(XTPPrimitiveSymbol);
177
178struct IXTPPaintManagerEvents
179{
180 //-----------------------------------------------------------------------
181 // Handles object destruction
182 //-----------------------------------------------------------------------
183 virtual ~IXTPPaintManagerEvents()
184 {
185 }
186
187 virtual void OnPaintManagerDestroyed(CXTPPaintManager* /*pPaintManager*/)
188 {
189 }
190};
191
196class _XTP_EXT_CLASS CXTPPaintManager
197 : public CXTPCmdTarget
198 , public CXTPObservable<CXTPPaintManager, IXTPPaintManagerEvents>
199{
200 DECLARE_DYNAMIC(CXTPPaintManager)
201
202 class CGlobalPaintManagerPtr;
203 friend class CGlobalPaintManagerPtr;
204
205private:
206 friend _XTP_EXT_CLASS CXTPPaintManager* AFX_CDECL XTPPaintManager();
207
208public:
218 static CXTPPaintManager* AFX_CDECL GetInstanceAddRef();
219
227 static void AFX_CDECL ReleaseInstance();
228
251 virtual void SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName);
252
253public:
263 CSize DrawControl(CDC* pDC, CXTPControl* pButton, BOOL bDraw = TRUE);
264
274 virtual CSize DrawControlPopupParent(CDC* pDC, CXTPControl* pButton, BOOL bDraw);
275
285 virtual CSize DrawControlToolBarParent(CDC* pDC, CXTPControl* pButton, BOOL bDraw);
286
294 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rc) = 0;
295
305 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pCombo, BOOL bDraw);
306
314 virtual COLORREF GetControlEditBackColor(CXTPControl* pControl);
315
325 virtual CSize DrawControlEdit(CDC* pDC, CXTPControlEdit* pEdit, BOOL bDraw);
326
339 virtual CSize DrawListBoxControl(CDC* pDC, CXTPControl* pButton, CRect rc, BOOL bSelected,
340 BOOL bDraw, CXTPCommandBars* pCommandBars = 0) = 0;
341
348 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar) = 0;
349
356 virtual void DrawControlEntry(CDC* pDC, CXTPControl* pButton);
357
365 virtual COLORREF GetControlTextColor(CXTPControl* pButton);
366
374 virtual COLORREF GetControlBackColor(CXTPControl* pButton);
375
389 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
390 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
391 XTPBarPosition barPosition) = 0;
392
406 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
407 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
408 XTPBarPosition barPosition) = 0;
409
421 virtual void DrawGalleryItemBack(CDC* pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected,
422 BOOL bPressed, BOOL bChecked, XTPBarType barType);
423
432 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
433
443 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
444
455 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
456 BOOL bDraw = TRUE) = 0;
457
467 virtual void DrawCommandBarGroupSeparator(CDC* pDC, CXTPCommandBar* pBar,
468 CXTPControl* pLeftControl, CXTPControl* pRightControl,
469 BOOL bDraw = TRUE);
470
478 virtual void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical) = 0;
479
486 virtual void FillDockBar(CDC* pDC, CXTPDockBar* pBar);
487
495 virtual void FillWorkspace(CDC* pDC, CRect rc, CRect rcExclude);
496
501 virtual void RefreshMetrics();
502
511 int GetShadowOptions() const;
512
523 virtual void DrawExpandGlyph(CDC* pDC, CXTPControl* pButton, CPoint pt0, CPoint pt1, CPoint pt2,
524 COLORREF clr);
525
534 virtual void DrawExpandGlyph(CDC* pDC, CXTPControl* pButton, COLORREF clr, BOOL bVertical);
535
544 virtual void DrawHiddenGlyph(CDC* pDC, CXTPControl* pButton, COLORREF clr, BOOL bVertical);
545
558 virtual CSize DrawSpecialControl(CDC* pDC, XTPSpecialControl controlType, CXTPControl* pButton,
559 CXTPCommandBar* pBar, BOOL bDraw, LPVOID lpParam);
560
568 virtual CRect GetCommandBarBorders(CXTPCommandBar* pBar);
569
580 virtual CSize DrawTearOffGripper(CDC* pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw) = 0;
581
589 virtual void DrawPopupResizeGripper(CDC* pDC, CRect rcGripper, int nFlags) = 0;
590
605 virtual void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage,
606 BOOL bSelected, BOOL bPressed, BOOL bEnabled = TRUE,
607 BOOL bChecked = FALSE, BOOL bPopuped = FALSE,
608 BOOL bToolBarImage = TRUE) = 0;
609
619 virtual CSize DrawDialogBarGripper(CDC* pDC, CXTPDialogBar* pBar, BOOL bDraw) = 0;
620
628 virtual CRect GetSplitButtonCommandRect(CXTPControl* pButton);
629
635 virtual void SetCommandBarRegion(CXTPCommandBar* pCommandBar);
636
650 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
651 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
652
663 virtual CSize DrawControlCheckBoxMark(CDC* pDC, CXTPControl* pButton, CRect rc, BOOL bDraw);
664
678 virtual CSize DrawControlRadioButtonMark(CDC* pDC, CRect rc, BOOL bDraw, BOOL bSelected,
679 BOOL bPressed, BOOL bChecked, BOOL bEnabled);
680
693 virtual void DrawPopupBarGripper(CDC* pDC, int xPos, int yPos, int cx, int cy,
694 BOOL bExpanded = FALSE);
695
696public:
707 static CXTPPaintManager* AFX_CDECL CreateTheme(XTPPaintTheme paintTheme);
708
723 static void AFX_CDECL SetTheme(XTPPaintTheme paintTheme);
724
731 static void AFX_CDECL SetCustomTheme(CXTPPaintManager* pTheme);
732
739 XTPPaintTheme GetCurrentTheme()
740 {
741 return m_themeCurrent;
742 }
743
750 virtual XTPPaintTheme BaseTheme() = 0;
751
759 virtual BOOL RequiresResourceImages();
760
761public:
769 virtual CFont* GetControlFont(CXTPControl* pControl);
770
779 virtual CFont* GetCommandBarFont(CXTPCommandBar* pCommandBar);
780
787 virtual XTPBarTextOrientation GetControlTextOrientation(CXTPControl* pControl);
788
799 static void AFX_CDECL Triangle(CDC* pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr);
800
805 virtual void UpdateFonts();
806
811 virtual void UpdateColors();
812
821 void SetCommandBarsFontIndirect(LOGFONT* pLogFont, BOOL bUseStandardFont = FALSE);
822
829 CFont* GetRegularFont();
830
837 CFont* GetRegularBoldFont();
838
845 CFont* GetIconFont();
846
853 CFont* GetSmCaptionFont();
854
860 void UseOfficeFont(bool bUseOfficeFont);
861
868 int GetControlHeight() const;
869
878 virtual CSize GetDefaultCommandBarSize(CXTPCommandBar* pBar);
879
888 void Rectangle(CDC* pDC, LPCRECT rc, int nPen, const int nBrush);
889
898 void Rectangle(CDC* pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush);
899
908 void RoundRect(CDC* pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush);
919 void Draw3dRect(CDC* pDC, LPCRECT rc, int nTopLeft, int nBottomRight);
920
930 void Draw3dRect(CDC* pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush);
931
940 virtual void DrawPopupBarCheckMark(CDC* pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr);
941
949 void DrawCheckMark(CDC* pDC, CRect rcCheck, COLORREF clr = 0)
950 {
951 DrawPopupBarCheckMark(pDC, rcCheck, TRUE, clr);
952 }
953
962 virtual void DrawPopupBarRadioMark(CDC* pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr);
963
971 virtual void DrawComboExpandMark(CDC* pDC, CRect rc, COLORREF clr);
972
979 virtual void DrawControlMDIButton(CDC* pDC, CXTPControlButton* pButton);
980
988 void Line(CDC* pDC, CPoint p0, CPoint p1);
989
1000 void Line(CDC* pDC, int x0, int y0, int x1, int y1, const int nPen);
1001
1012 void Line(CDC* pDC, int x0, int y0, int x1, int y1, COLORREF clrPen);
1013
1024 void HorizontalLine(CDC* pDC, int x0, int y0, int x1, COLORREF clrPen);
1025
1036 void VerticalLine(CDC* pDC, int x0, int y0, int y1, COLORREF clrPen);
1037
1049 virtual void DrawDropDownGlyph(CDC* pDC, CXTPControl* pControl, CPoint pt, BOOL bSelected,
1050 BOOL bPopuped, BOOL bEnabled, BOOL bVert);
1051
1060 void Pixel(CDC* pDC, int xPos, int yPos, int nPen);
1061
1074 void GradientFill(CDC* pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz,
1075 LPCRECT lpRectClip = NULL);
1076
1083 XTP_COMMANDBARS_ICONSINFO* GetIconsInfo();
1084
1086 // Animation Routines
1087
1098 virtual void Animate(CDC* pDestDC, CDC* pSrcDC, CRect rc, XTPAnimationType animationType);
1099
1109 virtual void AnimateExpanding(CXTPCommandBar* pCommandBar, CDC* pDestDC, CDC* pSrcDC,
1110 BOOL bExpandDown);
1111
1119 void SetAnimationDelay(int nAnimationSteps, int nAnimationTime);
1120
1213 COLORREF GetXtremeColor(UINT nIndex);
1214
1223 void SetColors(int cElements, CONST INT* lpaElements, CONST COLORREF* lpaRgbValues);
1224
1225public:
1239 CSize DrawControlText(CDC* pDC, CXTPControl* pControl, CRect rcText, BOOL bDraw, BOOL bVert,
1240 BOOL bCentered, BOOL bTriangled);
1241
1249 static BOOL AFX_CDECL FontExists(LPCTSTR lpszFaceName);
1250
1258 static void AFX_CDECL StripMnemonics(CString& strClear);
1259
1260public:
1266 virtual void UpdateRTLCaption(CString& strCaption);
1267
1282 XTPCurrentSystemTheme GetCurrentSystemTheme();
1283
1296 void SetLunaTheme(XTPCurrentSystemTheme systemTheme);
1297
1305 virtual int GetPopupBarGripperWidth(CXTPCommandBar* pBar);
1306
1313 virtual CXTPControlGalleryPaintManager* GetGalleryPaintManager() const;
1314
1321 virtual CXTPScrollBarPaintManager* GetScrollBarPaintManager() const;
1322
1329 virtual CXTPSliderPaintManager* GetSliderPaintManager() const;
1330
1337 virtual CXTPProgressPaintManager* GetProgressPaintManager() const;
1338
1345 virtual CXTPFramePaintManager* GetFramePaintManager();
1346
1353 virtual CXTPStatusBarPaintManager* GetStatusBarPaintManager();
1354
1361 virtual CXTPRibbonPaintManager* GetRibbonPaintManager();
1362
1369 virtual CXTPMessageBarPaintManager* GetMessageBarPaintManager();
1370
1377 CXTPShadowManager* GetShadowManager() const;
1378
1384 BOOL IsUseSystemAccentColorEnabled() const;
1385
1387public:
1388 _XTP_DEPRECATED_IN_FAVOR2(GetInstanceAddRef, ReleaseInstance)
1389 static void AFX_CDECL Done()
1390 {
1391 }
1392
1393 // deprecated.
1394 void ShowKeyboardCues(BOOL bShow);
1395
1396 CFont* GetIconBoldFont();
1397
1398 virtual void DrawKeyboardTip(CDC* pDC, CXTPCommandBarKeyboardTip* pWnd, BOOL bSetRegion);
1399
1400 CSize GetAutoIconSize(BOOL bLarge) const;
1401
1402 void FillCompositeRect(CDC* pDC, LPCRECT lpRect, COLORREF clr);
1403
1404 static void AFX_CDECL FillCompositeAlpha(CDC* pDC, CRect rc);
1405 _XTP_DEPRECATED_IN_FAVOR(DrawControlText)
1406 CSize DrawTextEx(CDC*, CString, CRect, BOOL, BOOL, BOOL, BOOL, BOOL = FALSE, BOOL = FALSE)
1407 {
1408 return CSize(0, 0);
1409 }
1410 void AlphaEllipse(CDC* pDC, CRect rc, COLORREF clrBorder, COLORREF clrFace);
1411
1412 static void AFX_CDECL DrawTextApi(CDC* pDC, const CString& str, LPRECT lpRect, UINT format,
1413 BOOL bComposited);
1414 CSize DrawControlText2(CDC* pDC, CXTPControl* pControl, CRect rcText, BOOL bDraw, BOOL bVert,
1415 BOOL bTrangled);
1416
1417 virtual int GetSplitDropDownHeight() const;
1418 virtual int GetEditHeight() const;
1419 virtual int GetTextHeight() const;
1420 virtual int GetFontHeight() const;
1421 virtual void SetFontHeight(int nFontHeight);
1422 virtual int GetTabsHeight() const;
1423
1424 static BOOL IsDpiBitmapScalingEnabled(CXTPControl* pControl);
1425 static BOOL IsDpiBitmapScalingEnabled(CXTPCommandBar* pCommandBar);
1426 static BOOL IsDpiBitmapScalingEnabled(CXTPCommandBars* pCommandBars);
1427
1428 static CSize AdjustDpiIconSize(CXTPImageManagerIcon* pIcon, CSize szIcon, CXTPControl* pControl,
1429 CSize szAvailable);
1430 static CSize AdjustDpiIconSize(CXTPImageManagerIcon* pIcon, CSize szIcon,
1431 CXTPCommandBar* pCommandBar, CSize szAvailable,
1432 CSize szMargin = CSize(0, 0));
1433 static CSize AdjustDpiIconSize(CXTPImageManagerIcon* pIcon, CSize szIcon,
1434 CXTPCommandBars* pCommandBars, CSize szAvailable,
1435 CSize szMargin = CSize(0, 0));
1436 static CSize AdjustDpiIconSize(CXTPImageManagerIcon* pIcon, CSize szIcon, CSize szAvailable,
1437 BOOL bScaleDpi, CSize szMargin = CSize(0, 0));
1438
1439 virtual BOOL IsPopupRoundedCorners(CPoint& pt);
1440
1441protected:
1442 virtual BOOL IsFlatToolBar(CXTPCommandBar* pCommandBar);
1443
1444 void AlphaBlendU(PBYTE pDest, PBYTE pSrcBack, int cx, int cy, PBYTE pSrc, BYTE byAlpha);
1445 void _DrawCheckMark(CDC* pDC, CRect rcCheck, COLORREF clr = 0, BOOL bLayoutRTL = FALSE);
1446
1447 void DrawControlText3(CDC* pDC, CXTPControl* pControl, const CString& str,
1448 const CString& strClear, CRect rcText, BOOL bVert, BOOL bCentered);
1449 void SplitString(const CString& str, CString& strFirstRow, CString& strSecondRow);
1450
1451 virtual CSize DrawControlText(CDC* pDC, CXTPControl* pButton, CRect rcText, BOOL bDraw,
1452 BOOL bTriangled, CSize szImage, BOOL bDrawImage);
1453 CSize GetControlSize(CXTPControl* pControl, CSize sz, BOOL bVert);
1454 virtual CSize GetPopupBarImageSize(CXTPCommandBar* pBar);
1455 virtual void DrawPopupBarText(CDC* pDC, const CString& strText, CRect& rcText, UINT nFlags,
1456 BOOL bDraw, BOOL bSelected, BOOL bEnabled);
1457
1458 CSize GetIconSize(CXTPControl* pControl) const;
1459
1460 static CSize GetStretchIconSize(CXTPImageManagerIcon* pIcon, CSize szIcon);
1461
1462 static int AFX_CDECL CalcEntityHeight(int nFontHeight, int nFactor,
1463 int nMinHeight = XTP_COMMANDBAR_MIN_CONTROL_HEIGHT,
1464 int nCustomDPI = 0);
1465 static int AFX_CDECL CalcTextHeight(int nFontHeight,
1466 int nFactor = XTP_COMMANDBAR_TEXT_HEIGHT_FACTOR,
1467 int nCustomDPI = 0);
1468 static int AFX_CDECL CalcCtrlHeight(int nFontHeight,
1469 int nFactor = XTP_COMMANDBAR_CONTROL_HEIGHT_FACTOR,
1470 int nCustomDPI = 0);
1471 static int AFX_CDECL CalcSplitButtonDropDownWidth(int nTextHeight);
1472 static int AFX_CDECL CalcSplitButtonDropDownHeight(int nFontHeight);
1473
1474 XTPPrimitiveSymbol GetControlSymbol(XTPBarPosition barPosition, BOOL bVert) const;
1475
1488 static CXTPPaintManager* AFX_CDECL GetGlobalPaintManager();
1489
1498 static void AFX_CDECL SetGlobalPaintManager(CXTPPaintManager* pPaintManager);
1499
1500public:
1501 // Combobox / Edit-box
1502public:
1503 CXTPPaintManagerColor m_clrEditTextNormal;
1504 CXTPPaintManagerColor m_clrEditTextDisabled;
1505 CXTPPaintManagerColor m_clrEditTextHighlighted;
1506
1507 // Message bar
1508public:
1509 COLORREF m_clrMessageBarText;
1510 CRect m_rcMessageBarMargin;
1512 // Paint manager
1513public:
1514 CXTPFramePaintManager* m_pFramePaintManager;
1515 CXTPStatusBarPaintManager* m_pStatusBarPaintManager;
1516 CXTPRibbonPaintManager* m_pRibbonPaintManager;
1517 CXTPControlGalleryPaintManager* m_pGalleryPaintManager;
1518 CXTPProgressPaintManager* m_pProgressPaintManager;
1519 CXTPSliderPaintManager* m_pSliderPaintManager;
1520 CXTPScrollBarPaintManager* m_pScrollBarPaintManager;
1521 CXTPMessageBarPaintManager* m_pMessageBarPaintManager;
1522
1523public:
1524 CXTPPaintManagerColorGradient m_clrDisabledIcon;
1525 CXTPPaintManagerColor m_clrFloatingGripper;
1526 CXTPPaintManagerColor m_clrFloatingGripperText;
1528 BOOL m_bThickCheckMark;
1529 BOOL m_bShowShadow;
1530 BOOL m_bThemedStatusBar;
1531 BOOL m_bThemedCheckBox;
1532 BOOL m_bClearTypeTextQuality;
1534 BOOL m_bFlatToolBar;
1535 BOOL m_bFlatMenuBar;
1536 int m_nPopupBarTextPadding;
1537 BOOL m_bSelectImageInPopupBar;
1538 BOOL m_bEnableAnimation;
1540 BOOL m_bOffice2007Padding;
1541 BOOL m_bOffsetPopupLabelText;
1542 BOOL m_bWrapCaptionBelowText;
1544 CXTPPaintManagerFont m_fontSmCaption;
1545 CXTPPaintManagerFont m_fontIcon;
1546 CXTPPaintManagerFont m_fontIconBold;
1547 CXTPPaintManagerFont m_fontToolTip;
1549 int m_nSplitButtonDropDownWidth;
1550 int m_nSplitButtonDropDownHeight;
1551 int m_nSplitButtonPopupWidth;
1552 BOOL m_bAutoResizeIcons;
1553 int m_nStatusBarMinHeight;
1555 PVOID m_pfnSetLayeredWindowAttributes;
1557 CRect m_rcStatusBarBorder;
1559 BOOL m_bUseOfficeFont;
1560 CString m_strOfficeFont;
1561 int m_nTextHeight;
1563protected:
1564 CXTPFont m_xtpFontRegular;
1565 CXTPFont m_xtpFontRegularBold;
1566 CXTPFont m_xtpFontVert;
1567 CXTPFont m_xtpFontVertBold;
1569 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontRegular, m_xtpFontRegular,
1570 GetRegularFontHandle);
1571 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontRegularBold, m_xtpFontRegularBold,
1572 GetRegularBoldFontHandle);
1573 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontVert, m_xtpFontVert, GetVertFontHandle);
1574 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontVertBold, m_xtpFontVertBold,
1575 GetVertBoldFontHandle);
1576
1577 int m_nEditHeight;
1578 int m_nFontHeight;
1579 BOOL m_bUseStandardFont;
1580 BOOL m_bEmbossedDisabledText;
1582 CXTPWinThemeWrapper* m_themeStatusBar;
1583 CXTPWinThemeWrapper* m_themeButton;
1585 XTPPaintTheme m_themeCurrent;
1588 _XTP_DEPRECATED_IN_FAVOR2(GetGlobalPaintManager, SetGlobalPaintManager)
1589 static CXTPPaintManager* s_pInstance;
1592 XTP_COMMANDBARS_ICONSINFO m_iconsInfo;
1594 int m_nAnimationSteps;
1595 int m_nAnimationTime;
1597 BOOL m_bShowKeyboardCues;
1599 CXTPPaintManagerColor m_arrColor[XPCOLOR_LAST + 1];
1600 XTPCurrentSystemTheme m_systemTheme;
1602 CXTPShadowManager* m_pShadowManager;
1604protected:
1609 CXTPPaintManager();
1610
1615 virtual ~CXTPPaintManager();
1616
1617public:
1624 struct _XTP_EXT_CLASS CLogFont : public LOGFONT
1625 {
1630 CLogFont();
1631 };
1633 _XTP_DEPRECATED_IN_FAVOR(CXTPNonClientMetrics)
1634 typedef CXTPNonClientMetrics CNonClientMetrics;
1636# ifdef _XTP_COMMANDBARS_ACTIVEX
1639 // x64 #ifdef below is a fix for OLE_HANDLE. While HBITMAP/HICON are still 32-bit on 64-bit
1640 // Windows, OLE_HANDLE (long) can still be used. But OLE_HANDLE cannot be used as HMODULE which
1641 // is always 64-bit
1642
1643# ifndef _WIN64
1644# define MODULE_HANDLE OLE_HANDLE
1645# define MODULE_HANDLE_TYPE VTS_I4
1646# else
1647# define MODULE_HANDLE LONG64
1648# define MODULE_HANDLE_TYPE VTS_I8
1649# endif
1650
1651 DECLARE_DISPATCH_MAP()
1652 DECLARE_OLETYPELIB_EX(CXTPPaintManager);
1653 DECLARE_INTERFACE_MAP()
1654
1655 void OleLoadFrameIcon(MODULE_HANDLE Module, LPCTSTR pszFileName, long Width, long Height);
1656 void OleRefreshMetrics();
1657 void OleFillWorkspace(OLE_HANDLE hDC, int x, int y, int cx, int cy);
1658 void OleDrawRectangle(OLE_HANDLE hDC, int x, int y, int cx, int cy, BOOL bSelected,
1659 BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped,
1660 XTPBarType barType, XTPBarPosition barPosition);
1661 COLORREF OleGetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked,
1662 BOOL bPopuped, XTPBarType barType,
1663 XTPBarPosition barPosition);
1665# endif
1666
1667 friend class CCommandBarsCtrl;
1668 friend class CXTPCommandBarsOptions;
1669 friend class CXTPCommandBars;
1670 friend class CXTPRibbonPaintManager;
1671 friend class CXTPStatusBarPaintManager;
1672 friend class CXTPStatusBarThemeVisualStudio2010;
1673 friend class CXTPStatusBarThemeOffice2003;
1674};
1675
1698_XTP_EXT_CLASS CXTPPaintManager* AFX_CDECL XTPPaintManager();
1699
1707template<class TBase>
1708class CXTPReBarPaintManager : public TBase
1709{
1710public:
1715 CXTPReBarPaintManager();
1716
1721 void RefreshMetrics();
1722
1729 void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
1730
1731protected:
1732 CXTPWinThemeWrapper m_themeRebar;
1733};
1734
1735template<class TBase>
1736AFX_INLINE CXTPReBarPaintManager<TBase>::CXTPReBarPaintManager()
1737{
1738 TBase::RefreshMetrics();
1739}
1740
1741template<class TBase>
1742AFX_INLINE void CXTPReBarPaintManager<TBase>::RefreshMetrics()
1743{
1744 TBase::RefreshMetrics();
1745 m_themeRebar.OpenThemeData(0, L"REBAR");
1746}
1747
1749_XTP_EXT_CLASS BOOL AFX_CDECL XTPReBarPaintManager_FillCommandBarEntry(CDC* pDC,
1750 CXTPCommandBar* pBar,
1751 CXTPWinThemeWrapper& theme);
1754template<class TBase>
1755AFX_INLINE void CXTPReBarPaintManager<TBase>::FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar)
1756{
1757 if (XTPReBarPaintManager_FillCommandBarEntry(pDC, pBar, m_themeRebar))
1758 return;
1759
1760 TBase::FillCommandBarEntry(pDC, pBar);
1761}
1762
1764
1765AFX_INLINE void CXTPPaintManager::SetAnimationDelay(int nAnimationSteps, int nAnimationTime)
1766{
1767 m_nAnimationSteps = nAnimationSteps;
1768 m_nAnimationTime = nAnimationTime;
1769}
1770
1771AFX_INLINE CFont* CXTPPaintManager::GetRegularFont()
1772{
1773 return this == NULL ? CFont ::FromHandle((HFONT)::GetStockObject(DEFAULT_GUI_FONT))
1774 : &m_xtpFontRegular;
1775}
1776
1777AFX_INLINE CFont* CXTPPaintManager::GetRegularBoldFont()
1778{
1779 return &m_xtpFontRegularBold;
1780}
1781
1782AFX_INLINE CFont* CXTPPaintManager::GetIconFont()
1783{
1784 return &m_fontIcon;
1785}
1787AFX_INLINE int CXTPPaintManager::GetFontHeight() const
1788{
1789 return m_nFontHeight;
1790}
1792AFX_INLINE CFont* CXTPPaintManager::GetSmCaptionFont()
1793{
1794 return &m_fontSmCaption;
1795}
1797AFX_INLINE void CXTPPaintManager::ShowKeyboardCues(BOOL bShow)
1798{
1799 m_bShowKeyboardCues = bShow;
1800}
1802AFX_INLINE CXTPScrollBarPaintManager* CXTPPaintManager::GetScrollBarPaintManager() const
1803{
1804 return m_pScrollBarPaintManager;
1805}
1806
1807AFX_INLINE CXTPControlGalleryPaintManager* CXTPPaintManager::GetGalleryPaintManager() const
1808{
1809 return m_pGalleryPaintManager;
1810}
1811
1812AFX_INLINE CXTPSliderPaintManager* CXTPPaintManager::GetSliderPaintManager() const
1813{
1814 return m_pSliderPaintManager;
1815}
1816
1817AFX_INLINE CXTPProgressPaintManager* CXTPPaintManager::GetProgressPaintManager() const
1818{
1819 return m_pProgressPaintManager;
1820}
1821
1822AFX_INLINE CXTPShadowManager* CXTPPaintManager::GetShadowManager() const
1823{
1824 return m_pShadowManager;
1825}
1827AFX_INLINE int CXTPPaintManager::GetEditHeight() const
1828{
1829 return m_nEditHeight;
1830}
1831
1832AFX_INLINE int CXTPPaintManager::GetTextHeight() const
1833{
1834 return m_nTextHeight;
1835}
1836
1837AFX_INLINE int CXTPPaintManager::GetSplitDropDownHeight() const
1838{
1839 return m_nSplitButtonDropDownHeight;
1840}
1842AFX_INLINE BOOL CXTPPaintManager::RequiresResourceImages()
1843{
1844 return FALSE;
1845}
1847AFX_INLINE CFont* CXTPPaintManager::GetIconBoldFont()
1848{
1849 return &m_fontIconBold;
1850}
1851
1852# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1853#endif // #if !defined(__XTPPAINTMANAGER_H__)
XPCOLOR_LAST
const int XPCOLOR_LAST
Definition XTPColorManager.h:109
XTPCurrentSystemTheme
XTPCurrentSystemTheme
Enumeration used to determine the current Windows XP theme in use.
Definition XTPColorManager.h:45
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarTextOrientation
XTPBarTextOrientation
Command bar text orientation flags.
Definition XTPCommandBarsDefines.h:91
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPAnimationType
XTPAnimationType
Enumerated type used to determine the animation effect of pop-up bars.
Definition XTPCommandBarsDefines.h:373
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSpecialControl
XTPSpecialControl
Special control with extended drawing.
Definition XTPPaintManager.h:80
xtpButtonExpandMenu
@ xtpButtonExpandMenu
Control is expand button of pop-up bar.
Definition XTPPaintManager.h:82
xtpButtonHideFloating
@ xtpButtonHideFloating
Control is hide button of floating toolbar.
Definition XTPPaintManager.h:83
xtpButtonExpandFloating
@ xtpButtonExpandFloating
Control is option button of floating toolbar.
Definition XTPPaintManager.h:84
xtpButtonExpandToolbar
@ xtpButtonExpandToolbar
Control is option button of docking toolbar.
Definition XTPPaintManager.h:81
XTPPaintManager
_XTP_EXT_CLASS CXTPPaintManager *AFX_CDECL XTPPaintManager()
Call this function to access CXTPPaintManager members.
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBarKeyboardTip
CXTPCommandBarKeyboardTip is a CWnd derived class which represents a keyboard tip single window.
Definition XTPCommandBarKeyboardTip.h:41
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOptions
Options of the command bars.
Definition XTPCommandBarsOptions.h:46
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class.
Definition XTPControlEdit.h:274
CXTPControlGalleryItem
CXTPControlGalleryItem is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItem.h:39
CXTPControlGalleryPaintManager
CXTPControlGalleryPaintManager is a standalone class used to draw a CXTPControlGallery object.
Definition XTPControlGallery.h:682
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPControlPopup
CXTPControlPopup is a CXTPControl derived class.
Definition XTPControlPopup.h:42
CXTPDialogBar
CXTPDialogBar is a CXTPToolBar derived class.
Definition XTPDialogBar.h:41
CXTPDockBar
CXTPDockBar is a CWnd derived class.
Definition XTPDockBar.h:42
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPFramePaintManager
Paint manager for the Office 2007 style window frame.
Definition XTPFramePaintManager.h:41
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMessageBarButton
CXTPMessageBarButton is a standalone class.
Definition XTPMessageBar.h:48
CXTPMessageBar
CXTPMessageBar is a CControlBar derived class.
Definition XTPMessageBar.h:88
CXTPMessageBarPaintManager
The CXTPMessageBarPaintManager class is used by the message bar to perform standard paint routines.
Definition XTPMessageBarPaintManager.h:39
CXTPNonClientMetrics
CXTPNonClientMetrics is a self-initializing NONCLIENTMETRICS derived class.
Definition XTPSystemHelpers.h:3027
CXTPObservable
Provides a basic implementation of the Observable design pattern.
Definition XTPSystemHelpers.h:2138
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPPaintManagerFont
PaintManagers used CFont wrapper.
Definition XTPPaintManager.h:113
CXTPPaintManagerFont::SetStandardFont
BOOL SetStandardFont(const LOGFONT *lpLogFont)
Sets paint manager's font.
CXTPPaintManagerFont::EnableCustomFont
void EnableCustomFont(BOOL bEnable=TRUE)
Call this method to enable/disable use of custom font.
CXTPPaintManagerFont::SetCustomFont
BOOL SetCustomFont(const LOGFONT *lpLogFont)
Sets application defined font.
CXTPPaintManagerFont::CXTPPaintManagerFont
CXTPPaintManagerFont()
Constructs a CXTPPaintManagerFont object.
Definition XTPPaintManager.h:119
CXTPPaintManagerFont::m_bStandardFont
BOOL m_bStandardFont
TRUE to use standard font;.
Definition XTPPaintManager.h:159
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199
CXTPPaintManager::m_themeStatusBar
CXTPWinThemeWrapper * m_themeStatusBar
StatusBar theme helper.
Definition XTPPaintManager.h:1582
CXTPPaintManager::SetTheme
static void AFX_CDECL SetTheme(XTPPaintTheme paintTheme)
Call this member to switch the visual theme of the Command Bars.
CXTPPaintManager::m_bEmbossedDisabledText
BOOL m_bEmbossedDisabledText
TRUE to draw disabled text embossed.
Definition XTPPaintManager.h:1580
CXTPPaintManager::GetMessageBarPaintManager
virtual CXTPMessageBarPaintManager * GetMessageBarPaintManager()
Retrieves paint manager used to draw message bars.
CXTPPaintManager::m_pStatusBarPaintManager
CXTPStatusBarPaintManager * m_pStatusBarPaintManager
Paint manager of the status bar.
Definition XTPPaintManager.h:1515
CXTPPaintManager::SetImageHandle
virtual void SetImageHandle(HMODULE hResource, LPCTSTR lpszIniFileName)
Specifies the resource that contains the bitmaps to be loaded for the theme.
CXTPPaintManager::GetControlTextOrientation
virtual XTPBarTextOrientation GetControlTextOrientation(CXTPControl *pControl)
Call this member to determine how to draw text.
CXTPPaintManager::GetSplitButtonCommandRect
virtual CRect GetSplitButtonCommandRect(CXTPControl *pButton)
Determines split button command rectangle.
CXTPPaintManager::UseOfficeFont
void UseOfficeFont(bool bUseOfficeFont)
Call this method to use Tahoma font despite system metrics.
CXTPPaintManager::DrawSpecialControl
virtual CSize DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
CXTPPaintManager::m_nFontHeight
int m_nFontHeight
Custom font height (optional).
Definition XTPPaintManager.h:1578
CXTPPaintManager::m_bOffice2007Padding
BOOL m_bOffice2007Padding
TRUE if Office2007 metrics used.
Definition XTPPaintManager.h:1540
CXTPPaintManager::RequiresResourceImages
virtual BOOL RequiresResourceImages()
Used by the paint manager to determine if the theme requires a resource DLL to load image and color i...
Definition XTPPaintManager.h:1842
CXTPPaintManager::m_nAnimationTime
int m_nAnimationTime
Time of the animation.
Definition XTPPaintManager.h:1595
CXTPPaintManager::DrawPopupBarRadioMark
virtual void DrawPopupBarRadioMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a radio button.
CXTPPaintManager::m_pGalleryPaintManager
CXTPControlGalleryPaintManager * m_pGalleryPaintManager
Gallery paint manager.
Definition XTPPaintManager.h:1517
CXTPPaintManager::m_nSplitButtonDropDownHeight
int m_nSplitButtonDropDownHeight
Split button drop down height in toolbars.
Definition XTPPaintManager.h:1550
CXTPPaintManager::BaseTheme
virtual XTPPaintTheme BaseTheme()=0
Retrieves the base theme of the manager.
CXTPPaintManager::DrawControlRadioButtonMark
virtual CSize DrawControlRadioButtonMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a radio button mark area.
CXTPPaintManager::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPPaintManager::GetCommandBarBorders
virtual CRect GetCommandBarBorders(CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
CXTPPaintManager::DrawExpandGlyph
virtual void DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draw expand or hidden glyphs for a button.
CXTPPaintManager::m_systemTheme
XTPCurrentSystemTheme m_systemTheme
Current system theme.
Definition XTPPaintManager.h:1600
CXTPPaintManager::UpdateFonts
virtual void UpdateFonts()
Refreshes the fonts to use.
CXTPPaintManager::GetCurrentSystemTheme
XTPCurrentSystemTheme GetCurrentSystemTheme()
Call this member function to determine the current Windows XP theme in use.
CXTPPaintManager::GetControlFont
virtual CFont * GetControlFont(CXTPControl *pControl)
Call this member to retrieve the font of the command bar control.
CXTPPaintManager::m_bFlatToolBar
BOOL m_bFlatToolBar
TRUE to draw toolbars flat.
Definition XTPPaintManager.h:1534
CXTPPaintManager::GetShadowManager
CXTPShadowManager * GetShadowManager() const
Retrieves shadow manager used to draw shadows.
Definition XTPPaintManager.h:1822
CXTPPaintManager::FillWorkspace
virtual void FillWorkspace(CDC *pDC, CRect rc, CRect rcExclude)
This method is called to fill a workspace.
CXTPPaintManager::Triangle
static void AFX_CDECL Triangle(CDC *pDC, CPoint pt0, CPoint pt1, CPoint pt2, COLORREF clr)
Draws a triangle.
CXTPPaintManager::m_nAnimationSteps
int m_nAnimationSteps
Steps of the animation.
Definition XTPPaintManager.h:1594
CXTPPaintManager::GetGalleryPaintManager
virtual CXTPControlGalleryPaintManager * GetGalleryPaintManager() const
Retrieves paint manager used to draw galleries.
Definition XTPPaintManager.h:1807
CXTPPaintManager::m_fontIcon
CXTPPaintManagerFont m_fontIcon
Icon font.
Definition XTPPaintManager.h:1545
CXTPPaintManager::DrawGalleryItemBack
virtual void DrawGalleryItemBack(CDC *pDC, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked, XTPBarType barType)
This method is called to draw the background for a gallery menu item.
CXTPPaintManager::Line
void Line(CDC *pDC, CPoint p0, CPoint p1)
Draws a line.
CXTPPaintManager::Animate
virtual void Animate(CDC *pDestDC, CDC *pSrcDC, CRect rc, XTPAnimationType animationType)
This method is called to animate the pop-up bar.
CXTPPaintManager::m_rcMessageBarMargin
CRect m_rcMessageBarMargin
Margin of the message bar.
Definition XTPPaintManager.h:1510
CXTPPaintManager::GetShadowOptions
int GetShadowOptions() const
Determines the kind of shadow to use.
CXTPPaintManager::UpdateColors
virtual void UpdateColors()
Refreshes the standard colors to use.
CXTPPaintManager::GetControlEditBackColor
virtual COLORREF GetControlEditBackColor(CXTPControl *pControl)
This method returns the edit control back color to draw.
CXTPPaintManager::GetCommandBarFont
virtual CFont * GetCommandBarFont(CXTPCommandBar *pCommandBar)
Call this member to retrieve the font of the command bar.
CXTPPaintManager::DrawExpandGlyph
virtual void DrawExpandGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
CXTPPaintManager::m_fontIconBold
CXTPPaintManagerFont m_fontIconBold
Icon bold font.
Definition XTPPaintManager.h:1546
CXTPPaintManager::m_xtpFontVert
CXTPFont m_xtpFontVert
Vertical font.
Definition XTPPaintManager.h:1566
CXTPPaintManager::m_pSliderPaintManager
CXTPSliderPaintManager * m_pSliderPaintManager
Slider pane paint manager.
Definition XTPPaintManager.h:1519
CXTPPaintManager::SetGlobalPaintManager
static void AFX_CDECL SetGlobalPaintManager(CXTPPaintManager *pPaintManager)
Call this method to set the pointer to the global paint manager.
CXTPPaintManager::m_clrDisabledIcon
CXTPPaintManagerColorGradient m_clrDisabledIcon
Disabled icons color.
Definition XTPPaintManager.h:1524
CXTPPaintManager::m_fontSmCaption
CXTPPaintManagerFont m_fontSmCaption
Small caption font.
Definition XTPPaintManager.h:1544
CXTPPaintManager::m_bSelectImageInPopupBar
BOOL m_bSelectImageInPopupBar
TRUE to select image as in explorer theme.
Definition XTPPaintManager.h:1537
CXTPPaintManager::Draw3dRect
void Draw3dRect(CDC *pDC, LPCRECT rc, int frameThickness, COLORREF clrPen, COLORREF clrBrush)
Call this member function to draw a rectangle with predetermined thickness.
CXTPPaintManager::DrawControlPopupParent
virtual CSize DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop- up bar.
CXTPPaintManager::DrawControl
CSize DrawControl(CDC *pDC, CXTPControl *pButton, BOOL bDraw=TRUE)
This method is called to draw the control.
CXTPPaintManager::GetInstanceAddRef
static CXTPPaintManager *AFX_CDECL GetInstanceAddRef()
Obtains a pointer to a global paint manager object and increments its reference counter.
CXTPPaintManager::m_pShadowManager
CXTPShadowManager * m_pShadowManager
Shadow manager.
Definition XTPPaintManager.h:1602
CXTPPaintManager::SetColors
void SetColors(int cElements, CONST INT *lpaElements, CONST COLORREF *lpaRgbValues)
Call this member to set the colors for each element to the color in the specified color array.
CXTPPaintManager::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPPaintManager::m_bOffsetPopupLabelText
BOOL m_bOffsetPopupLabelText
TRUE if labels in pop-ups drawn with offset.
Definition XTPPaintManager.h:1541
CXTPPaintManager::GetXtremeColor
COLORREF GetXtremeColor(UINT nIndex)
This function retrieves the current color of the specified XP display element.
CXTPPaintManager::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)=0
This method is called to determine the offset of a pop-up'ed bar.
CXTPPaintManager::m_nSplitButtonDropDownWidth
int m_nSplitButtonDropDownWidth
Split button drop down width in toolbars.
Definition XTPPaintManager.h:1549
CXTPPaintManager::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pCombo, BOOL bDraw)
This method is called to draw the control.
CXTPPaintManager::m_xtpFontRegular
CXTPFont m_xtpFontRegular
Regular font.
Definition XTPPaintManager.h:1564
CXTPPaintManager::GetCurrentTheme
XTPPaintTheme GetCurrentTheme()
Call this member to get the current visual theme.
Definition XTPPaintManager.h:739
CXTPPaintManager::m_bThickCheckMark
BOOL m_bThickCheckMark
TRUE to draw thick check mark.
Definition XTPPaintManager.h:1528
CXTPPaintManager::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rc)=0
This method is called to draw the frame for the SplitButton control.
CXTPPaintManager::SetLunaTheme
void SetLunaTheme(XTPCurrentSystemTheme systemTheme)
Call this method to force system theme.
CXTPPaintManager::m_clrMessageBarText
COLORREF m_clrMessageBarText
Message bar text color.
Definition XTPPaintManager.h:1509
CXTPPaintManager::GetProgressPaintManager
virtual CXTPProgressPaintManager * GetProgressPaintManager() const
Retrieves paint manager used to draw progress bars.
Definition XTPPaintManager.h:1817
CXTPPaintManager::GetFramePaintManager
virtual CXTPFramePaintManager * GetFramePaintManager()
Retrieves paint manager used to draw frames.
CXTPPaintManager::m_strOfficeFont
CString m_strOfficeFont
Office font.
Definition XTPPaintManager.h:1560
CXTPPaintManager::m_pScrollBarPaintManager
CXTPScrollBarPaintManager * m_pScrollBarPaintManager
Scrollbar paint manager.
Definition XTPPaintManager.h:1520
CXTPPaintManager::GetRibbonPaintManager
virtual CXTPRibbonPaintManager * GetRibbonPaintManager()
Retrieves the ribbon paint manager.
CXTPPaintManager::VerticalLine
void VerticalLine(CDC *pDC, int x0, int y0, int y1, COLORREF clrPen)
Call this member function to draw a vertical line using the specified coordinages and RGB color value...
CXTPPaintManager::HorizontalLine
void HorizontalLine(CDC *pDC, int x0, int y0, int x1, COLORREF clrPen)
Call this member function to draw a horizontal line using the specified coordinages and RGB color val...
CXTPPaintManager::DrawHiddenGlyph
virtual void DrawHiddenGlyph(CDC *pDC, CXTPControl *pButton, COLORREF clr, BOOL bVertical)
Draw expand or hidden glyphs for a button.
CXTPPaintManager::m_bAutoResizeIcons
BOOL m_bAutoResizeIcons
TRUE to automatically resize icons using current DPI.
Definition XTPPaintManager.h:1552
CXTPPaintManager::SetCustomTheme
static void AFX_CDECL SetCustomTheme(CXTPPaintManager *pTheme)
Call this member to set a custom theme.
CXTPPaintManager::Line
void Line(CDC *pDC, int x0, int y0, int x1, int y1, COLORREF clrPen)
Draws a line.
CXTPPaintManager::GetControlBackColor
virtual COLORREF GetControlBackColor(CXTPControl *pButton)
Call this method to get the control back color to draw.
CXTPPaintManager::CXTPPaintManager
CXTPPaintManager()
Constructs a CXTPPaintManager object.
CXTPPaintManager::m_bUseOfficeFont
BOOL m_bUseOfficeFont
TRUE to use Tahoma font.
Definition XTPPaintManager.h:1559
CXTPPaintManager::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)=0
This method is called to draw a command bar's separator.
CXTPPaintManager::m_fontToolTip
CXTPPaintManagerFont m_fontToolTip
Tooltip font.
Definition XTPPaintManager.h:1547
CXTPPaintManager::Line
void Line(CDC *pDC, int x0, int y0, int x1, int y1, const int nPen)
Draws a line.
CXTPPaintManager::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)=0
This method is called to fill the control's face.
CXTPPaintManager::GetIconFont
CFont * GetIconFont()
Returns the icon font.
Definition XTPPaintManager.h:1782
CXTPPaintManager::m_themeCurrent
XTPPaintTheme m_themeCurrent
Current theme.
Definition XTPPaintManager.h:1585
CXTPPaintManager::SetCommandBarsFontIndirect
void SetCommandBarsFontIndirect(LOGFONT *pLogFont, BOOL bUseStandardFont=FALSE)
Call this member to set command bar's font.
CXTPPaintManager::DrawControlEntry
virtual void DrawControlEntry(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPPaintManager::GetIconsInfo
XTP_COMMANDBARS_ICONSINFO * GetIconsInfo()
CXTPPaintManager::m_bShowKeyboardCues
BOOL m_bShowKeyboardCues
TRUE to show keyboard cues - deprecated.
Definition XTPPaintManager.h:1597
CXTPPaintManager::m_bClearTypeTextQuality
BOOL m_bClearTypeTextQuality
TRUE to enable ClearType text for the font.
Definition XTPPaintManager.h:1532
CXTPPaintManager::SetAnimationDelay
void SetAnimationDelay(int nAnimationSteps, int nAnimationTime)
Call this method to set animation delay.
Definition XTPPaintManager.h:1765
CXTPPaintManager::m_nStatusBarMinHeight
int m_nStatusBarMinHeight
Minimum height for the status bar.
Definition XTPPaintManager.h:1553
CXTPPaintManager::DrawListBoxControl
virtual CSize DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)=0
This method is called to draw the control placed on the ListBox.
CXTPPaintManager::GetRegularFont
CFont * GetRegularFont()
Returns the general font.
Definition XTPPaintManager.h:1771
CXTPPaintManager::m_pFramePaintManager
CXTPFramePaintManager * m_pFramePaintManager
Frame paint manager.
Definition XTPPaintManager.h:1514
CXTPPaintManager::DrawControlEdit
virtual CSize DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
CXTPPaintManager::m_clrFloatingGripper
CXTPPaintManagerColor m_clrFloatingGripper
Gripper color of floating toolbar.
Definition XTPPaintManager.h:1525
CXTPPaintManager::GetPopupBarGripperWidth
virtual int GetPopupBarGripperWidth(CXTPCommandBar *pBar)
Calculates the gripper of a pop-up bar.
CXTPPaintManager::DrawPopupBarGripper
virtual void DrawPopupBarGripper(CDC *pDC, int xPos, int yPos, int cx, int cy, BOOL bExpanded=FALSE)
This method is called to draw a pop-up bar's right gripper.
CXTPPaintManager::DrawTearOffGripper
virtual CSize DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)=0
This method is called to draw a tear-off gripper of a pop-up bar.
CXTPPaintManager::DrawControlText
CSize DrawControlText(CDC *pDC, CXTPControl *pControl, CRect rcText, BOOL bDraw, BOOL bVert, BOOL bCentered, BOOL bTriangled)
This method is called to draw control text.
CXTPPaintManager::DrawPopupResizeGripper
virtual void DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags)=0
This method is called to draw a pop-up bar's resize gripper.
CXTPPaintManager::FontExists
static BOOL AFX_CDECL FontExists(LPCTSTR lpszFaceName)
Determines if a specified font exists in the system.
CXTPPaintManager::IsUseSystemAccentColorEnabled
BOOL IsUseSystemAccentColorEnabled() const
Determines whether xtpApplicationUseSystemAccentColor application ambient property is set.
CXTPPaintManager::m_themeButton
CXTPWinThemeWrapper * m_themeButton
Buttons theme helper.
Definition XTPPaintManager.h:1583
CXTPPaintManager::m_bFlatMenuBar
BOOL m_bFlatMenuBar
TRUE to draw menubar flat.
Definition XTPPaintManager.h:1535
CXTPPaintManager::m_bUseStandardFont
BOOL m_bUseStandardFont
TRUE to use system font.
Definition XTPPaintManager.h:1579
CXTPPaintManager::m_nEditHeight
int m_nEditHeight
Edit text height.
Definition XTPPaintManager.h:1577
CXTPPaintManager::GetControlTextColor
virtual COLORREF GetControlTextColor(CXTPControl *pButton)
Call this method to get the control text color to draw.
CXTPPaintManager::m_pfnSetLayeredWindowAttributes
PVOID m_pfnSetLayeredWindowAttributes
point to Transparency proc in USER32.dll module.
Definition XTPPaintManager.h:1555
CXTPPaintManager::m_bThemedCheckBox
BOOL m_bThemedCheckBox
TRUE to draw check box using WinXP theme.
Definition XTPPaintManager.h:1531
CXTPPaintManager::m_bShowShadow
BOOL m_bShowShadow
TRUE to show shadow.
Definition XTPPaintManager.h:1529
CXTPPaintManager::GetStatusBarPaintManager
virtual CXTPStatusBarPaintManager * GetStatusBarPaintManager()
Retrieves paint manager used to draw the status bar.
CXTPPaintManager::GetRegularBoldFont
CFont * GetRegularBoldFont()
Returns the general bold font.
Definition XTPPaintManager.h:1777
CXTPPaintManager::DrawCheckMark
void DrawCheckMark(CDC *pDC, CRect rcCheck, COLORREF clr=0)
Call this member function to draw a check mark.
Definition XTPPaintManager.h:949
CXTPPaintManager::GradientFill
void GradientFill(CDC *pDC, LPRECT lpRect, COLORREF crFrom, COLORREF crTo, BOOL bHorz, LPCRECT lpRectClip=NULL)
Gradient fills the rectangle.
CXTPPaintManager::GetControlHeight
int GetControlHeight() const
This method returns the common controls height.
CXTPPaintManager::GetScrollBarPaintManager
virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager() const
Retrieves paint manager used to draw scrollbars.
Definition XTPPaintManager.h:1802
CXTPPaintManager::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CRect rc, BOOL bDraw, BOOL bSelected, BOOL bPressed, BOOL bChecked, BOOL bEnabled)
This method is called to draw a check box mark area.
CXTPPaintManager::m_pRibbonPaintManager
CXTPRibbonPaintManager * m_pRibbonPaintManager
Ribbon paint Manager.
Definition XTPPaintManager.h:1516
CXTPPaintManager::SetCommandBarRegion
virtual void SetCommandBarRegion(CXTPCommandBar *pCommandBar)
Call this method to set the bounding region of a pop-up bar.
CXTPPaintManager::DrawDropDownGlyph
virtual void DrawDropDownGlyph(CDC *pDC, CXTPControl *pControl, CPoint pt, BOOL bSelected, BOOL bPopuped, BOOL bEnabled, BOOL bVert)
This member function is called to draw a split button expand symbol.
CXTPPaintManager::m_rcStatusBarBorder
CRect m_rcStatusBarBorder
Bounding rectangle of the status bar border.
Definition XTPPaintManager.h:1557
CXTPPaintManager::m_bEnableAnimation
BOOL m_bEnableAnimation
TRUE to enable animation for all toolbars.
Definition XTPPaintManager.h:1538
CXTPPaintManager::m_pProgressPaintManager
CXTPProgressPaintManager * m_pProgressPaintManager
Progress bar paint manager.
Definition XTPPaintManager.h:1518
CXTPPaintManager::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)=0
This method is called to fill the command bar's face.
CXTPPaintManager::m_bThemedStatusBar
BOOL m_bThemedStatusBar
TRUE to draw status bar using WinXP theme.
Definition XTPPaintManager.h:1530
CXTPPaintManager::m_clrFloatingGripperText
CXTPPaintManagerColor m_clrFloatingGripperText
Gripper text color of floating toolbar.
Definition XTPPaintManager.h:1526
CXTPPaintManager::DrawDialogBarGripper
virtual CSize DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)=0
Call this member to draw a dialog bar's gripper.
CXTPPaintManager::CreateTheme
static CXTPPaintManager *AFX_CDECL CreateTheme(XTPPaintTheme paintTheme)
Creates a new CXTPPaintManager object.
CXTPPaintManager::DrawPopupBarCheckMark
virtual void DrawPopupBarCheckMark(CDC *pDC, CRect rcCheck, BOOL bEnabled, COLORREF clr)
Call this member function to draw a check mark.
CXTPPaintManager::GetSmCaptionFont
CFont * GetSmCaptionFont()
Call this method to retrieve the caption of a floating mini frame.
Definition XTPPaintManager.h:1792
CXTPPaintManager::m_bWrapCaptionBelowText
BOOL m_bWrapCaptionBelowText
Wrap text for xtpButtonIconAndCaptionBelow buttons.
Definition XTPPaintManager.h:1542
CXTPPaintManager::GetGlobalPaintManager
static CXTPPaintManager *AFX_CDECL GetGlobalPaintManager()
Call this method to get the pointer to the global paint manager.
CXTPPaintManager::m_nPopupBarTextPadding
int m_nPopupBarTextPadding
Distance between gripper and control text.
Definition XTPPaintManager.h:1536
CXTPPaintManager::Rectangle
void Rectangle(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
CXTPPaintManager::DrawImage
virtual void DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)=0
This method is called to draw the image of the control.
CXTPPaintManager::m_nTextHeight
int m_nTextHeight
Regular text field height (not font height).
Definition XTPPaintManager.h:1561
CXTPPaintManager::~CXTPPaintManager
virtual ~CXTPPaintManager()
Destroys a CXTPPaintManager object, handles cleanup and deallocation.
CXTPPaintManager::ReleaseInstance
static void AFX_CDECL ReleaseInstance()
Decrements global paint manager's reference counter and deletes its instance when the reference count...
CXTPPaintManager::m_iconsInfo
XTP_COMMANDBARS_ICONSINFO m_iconsInfo
Specific icons options.
Definition XTPPaintManager.h:1592
CXTPPaintManager::GetSliderPaintManager
virtual CXTPSliderPaintManager * GetSliderPaintManager() const
Retrieves paint manager used to draw slider panes.
Definition XTPPaintManager.h:1812
CXTPPaintManager::UpdateRTLCaption
virtual void UpdateRTLCaption(CString &strCaption)
This method is called to prepare a caption for Right-To-Left draw.
CXTPPaintManager::StripMnemonics
static void AFX_CDECL StripMnemonics(CString &strClear)
This member function will search a string, strip off the mnemonic '&', and reformat the string.
CXTPPaintManager::m_nSplitButtonPopupWidth
int m_nSplitButtonPopupWidth
Split button drop down width in pop-ups.
Definition XTPPaintManager.h:1551
CXTPPaintManager::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPPaintManager::GetDefaultCommandBarSize
virtual CSize GetDefaultCommandBarSize(CXTPCommandBar *pBar)
Computes default command bar size taking into account command bar font.
CXTPPaintManager::DrawCommandBarGroupSeparator
virtual void DrawCommandBarGroupSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pLeftControl, CXTPControl *pRightControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's group separator.
CXTPPaintManager::DrawComboExpandMark
virtual void DrawComboExpandMark(CDC *pDC, CRect rc, COLORREF clr)
Call this member function to draw a combobox expand symbol.
CXTPPaintManager::AnimateExpanding
virtual void AnimateExpanding(CXTPCommandBar *pCommandBar, CDC *pDestDC, CDC *pSrcDC, BOOL bExpandDown)
This method is called to animate the expanding process.
CXTPPaintManager::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)=0
This method retrieves a button's text color.
CXTPPaintManager::Rectangle
void Rectangle(CDC *pDC, LPCRECT rc, int nPen, const int nBrush)
Draws a rectangle.
CXTPPaintManager::RoundRect
void RoundRect(CDC *pDC, LPCRECT rc, COLORREF clrPen, COLORREF clrBrush)
Draws a rectangle.
CXTPPaintManager::Pixel
void Pixel(CDC *pDC, int xPos, int yPos, int nPen)
Sets the pixel at the point.
CXTPPaintManager::XTPPaintManager
friend _XTP_EXT_CLASS CXTPPaintManager *AFX_CDECL XTPPaintManager()
Call this function to access CXTPPaintManager members.
CXTPPaintManager::m_xtpFontRegularBold
CXTPFont m_xtpFontRegularBold
Regular bold font.
Definition XTPPaintManager.h:1565
CXTPPaintManager::DrawControlCheckBoxMark
virtual CSize DrawControlCheckBoxMark(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bDraw)
This method is called to draw a check box mark area.
CXTPPaintManager::DrawControlToolBarParent
virtual CSize DrawControlToolBarParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the toolbar.
CXTPPaintManager::DrawControlMDIButton
virtual void DrawControlMDIButton(CDC *pDC, CXTPControlButton *pButton)
Call this member function to draw menu MDI buttons.
CXTPPaintManager::Draw3dRect
void Draw3dRect(CDC *pDC, LPCRECT rc, int nTopLeft, int nBottomRight)
Call this member function to draw a three-dimensional rectangle.
CXTPPaintManager::FillDockBar
virtual void FillDockBar(CDC *pDC, CXTPDockBar *pBar)
This method is called to fill a dock bar.
CXTPPaintManager::m_xtpFontVertBold
CXTPFont m_xtpFontVertBold
Vertical font.
Definition XTPPaintManager.h:1567
CXTPPopupBar
CXTPPopupBar is a CXTPCommandBar derived class.
Definition XTPPopupBar.h:42
CXTPProgressPaintManager
CXTPProgressPaintManager object.
Definition XTPProgressPaintManager.h:41
CXTPReBarPaintManager
The CXTPReBarPaintManager template class is used to enable a ReBar theme for Command Bars.
Definition XTPPaintManager.h:1709
CXTPReBarPaintManager::m_themeRebar
CXTPWinThemeWrapper m_themeRebar
ReBar theme helper.
Definition XTPPaintManager.h:1732
CXTPReBarPaintManager::CXTPReBarPaintManager
CXTPReBarPaintManager()
Constructs a CXTPReBarPaintManager object.
Definition XTPPaintManager.h:1736
CXTPReBarPaintManager::FillCommandBarEntry
void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
Definition XTPPaintManager.h:1755
CXTPReBarPaintManager::RefreshMetrics
void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
Definition XTPPaintManager.h:1742
CXTPResourceImage
Represent a resource image and provides basic images functions.
Definition XTPResourceImage.h:48
CXTPResourceImages
Implements resource image collection and its operations.
Definition XTPResourceImage.h:257
CXTPRibbonPaintManager
Standalone class used by CXTPRibbonBar as a paint manager.
Definition XTPRibbonPaintManager.h:51
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPShadowManager
CXTPShadowManager is standalone class used to manage CommandBars' shadows.
Definition XTPHookManager.h:303
CXTPSliderPaintManager
Paint manager for the slider control.
Definition XTPSliderPaintManager.h:40
CXTPStatusBar
CXTPStatusBar is a CControlBar derived class.
Definition XTPStatusBar.h:52
CXTPStatusBarPane
CXTPStatusBarPane is a CXTPCmdTarget derived class.
Definition XTPStatusBarPane.h:39
CXTPStatusBarSwitchPane
CXTPStatusBarSwitchPane is a CXTPStatusBarPane derived class.
Definition XTPStatusBarPaneSwitch.h:40
CXTPTabControl
CXTPTabControl is used to draw an enhanced tab control with Office 2003, Visual Studio,...
Definition XTPTabControl.h:47
CXTPToolBar
CXTPToolBar is a CXTPCommandBar derived class.
Definition XTPToolBar.h:42
CXTPWinThemeWrapper
The CXTPWinThemeWrapper class wraps the UxTheme.dll visual theme API.
Definition XTPWinThemeWrapper.h:188
CXTPPaintManager::CLogFont
CLogFont is a self initializing LOGFONT derived class.
Definition XTPPaintManager.h:1625
CXTPPaintManager::CLogFont::CLogFont
CLogFont()
Constructs a CLogFont object.
XTP_COMMANDBARS_ICONSINFO
This structure collect icons options for command bars.
Definition XTPPaintManager.h:97
XTP_COMMANDBARS_ICONSINFO::bOfficeStyleDisabledIcons
BOOL bOfficeStyleDisabledIcons
If TRUE, Office 2003 style disabled icons will be drawn when using disabled icons.
Definition XTPPaintManager.h:104
XTP_COMMANDBARS_ICONSINFO::bUseDisabledIcons
BOOL bUseDisabledIcons
If TRUE, disabled icons will be used when the control is disabled.
Definition XTPPaintManager.h:99
XTP_COMMANDBARS_ICONSINFO::bUseFadedIcons
BOOL bUseFadedIcons
If TRUE, icons will appear faded.
Definition XTPPaintManager.h:98
XTP_COMMANDBARS_ICONSINFO::bIconsWithShadow
BOOL bIconsWithShadow
If TRUE, when the mouse pointer is moved over a command bar control, the icons will appear to "jump" ...
Definition XTPPaintManager.h:101


Toolkit Pro: XTPDockingPaneTabColorSetVisualStudio2005.h Source File

  • Source
  • DockingPane
  • TabColorSets
XTPDockingPaneTabColorSetVisualStudio2005.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANETABCOLORSETVISUALSTUDIO2005_H__)
24# define __XTPDOCKINGPANETABCOLORSETVISUALSTUDIO2005_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPaneTabColorSetVisualStudio2005
39 : public CXTPDockingPaneTabColorSetVisualStudio2003
40{
41public:
47 CXTPDockingPaneTabColorSetVisualStudio2005(BOOL bHighlightSelected);
48
54 void RefreshMetrics();
55};
56
57# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
59#endif // !defined(__XTPDOCKINGPANETABCOLORSETVISUALSTUDIO2005_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPaneTabColorSetVisualStudio2003
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSetVisualStudio2003.h:39
CXTPDockingPaneTabColorSetVisualStudio2005
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPaneTabColorSetVisualStudio2005.h:40
CXTPDockingPaneTabColorSetVisualStudio2005::CXTPDockingPaneTabColorSetVisualStudio2005
CXTPDockingPaneTabColorSetVisualStudio2005(BOOL bHighlightSelected)
Default class constructor.
CXTPDockingPaneTabColorSetVisualStudio2005::RefreshMetrics
void RefreshMetrics()
This member function is used to initialize default colors for a theme from an .INI resource.


Toolkit Pro: XTPTabColorSetNativeWindows10.h Source File

  • Source
  • TabManager
  • ColorSets
XTPTabColorSetNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABCOLORSETNATIVEWINDOWS10_H__)
24# define __XTPTABCOLORSETNATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPTabColorSetNativeWindows10 : public CXTPTabColorSetVisualStudio2012
38{
39public:
40 CXTPTabColorSetNativeWindows10();
41
49 virtual void RefreshMetrics();
50};
51
52# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPTABCOLORSETNATIVEWINDOWS10_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabColorSetNativeWindows10
CXTPTabColorSetNativeWindows10 implements a Native Windows 10 tab color set.
Definition XTPTabColorSetNativeWindows10.h:38
CXTPTabColorSetNativeWindows10::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the tabs.
CXTPTabColorSetVisualStudio2012
CXTPTabColorSetVisualStudio2012 implements a Visual Studio 2012 tab color set.
Definition XTPTabColorSetVisualStudio2012.h:38


Toolkit Pro: XTPChartPyramidSeriesView.h Source File

  • Source
  • Chart
  • Styles
  • Pyramid
XTPChartPyramidSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTPYRAMIDSERIESVIEW_H__)
24# define __XTPCHARTPYRAMIDSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Chart/Styles/Pyramid/Base/XTPChartPyramidSeriesViewBase.h"
32# include "Chart/Styles/Pyramid/2D/XTPChart2dPyramidSeriesView.h"
33
35typedef CXTPChartPyramidSeriesView CXTPChart2dPyramidSeriesView;
37#endif //#if !defined(__XTPCHARTPYRAMIDSERIESVIEW_H__)
XTPChart2dPyramidSeriesView.h
CXTPChart2dPyramidSeriesView
CXTPChartPyramidSeriesView CXTPChart2dPyramidSeriesView
CXTPChart2dPyramidSeriesView alias is necessary for naming consistency.
Definition XTPChartPyramidSeriesView.h:35
XTPChartPyramidSeriesViewBase.h
CXTPChartPyramidSeriesView
This class abstracts the view of a pyramid series.
Definition XTPChart2dPyramidSeriesView.h:53


Toolkit Pro: XTPChartAxisStrips.h Source File

  • Source
  • Chart
  • Diagram
  • Axis
XTPChartAxisStrips.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTAXISSTRIPS_H__)
24# define __XTPCHARTAXISSTRIPS_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartAxis;
34class CXTPChartFillStyle;
40class _XTP_EXT_CLASS CXTPChartAxisStrip
41 : public CXTPChartElement
42 , public CXTPChartLegendItemView
43{
45 DECLARE_DYNCREATE(CXTPChartAxisStrip)
47public:
52 CXTPChartAxisStrip();
53
58 virtual ~CXTPChartAxisStrip();
59
60public:
68 void SetVisible(BOOL bVisible);
69
76 BOOL IsVisible() const;
77
85 void SetLegendVisible(BOOL bVisible);
86
93 BOOL IsLegendVisible() const;
94
101 void SetName(const CXTPChartString& lpszName);
102
109 CXTPChartString GetName() const;
110
118 void SetLegendName(const CXTPChartString& lpszName);
119
127 CXTPChartString GetLegendName() const;
128
137 CXTPChartFillStyle* GetFillStyle() const;
138
146 CXTPChartString GetAxisMinValue() const;
147
155 double GetAxisMinValueInternal() const;
156
163 void SetAxisMinValue(LPCTSTR lpszValue);
164
171 void SetAxisMinValue(double dValue);
172
179 CXTPChartString GetAxisMaxValue() const;
180 double GetAxisMaxValueInternal() const;
181
188 void SetAxisMaxValue(LPCTSTR lpszValue);
189 void SetAxisMaxValue(double dValue);
190
197 CXTPChartColor GetActualColor() const;
198
199 CXTPChartColor GetActualColor2() const;
200
207 CXTPChartColor GetColor() const;
208
215 void SetColor(const CXTPChartColor& color);
216
217 CXTPChartColor GetColor2() const;
218
225 void SetColor2(const CXTPChartColor& color);
226
227public:
228 void DoPropExchange(CXTPPropExchange* pPX);
229
230protected:
243 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
244 CRect rcBounds);
245
246# ifdef _XTP_ACTIVEX
248 DECLARE_DISPATCH_MAP()
249 DECLARE_INTERFACE_MAP()
250 DECLARE_OLETYPELIB_EX(CXTPChartAxisStrip);
251
252 BSTR OleGetText();
253 void OleSetText(LPCTSTR lpszText);
254 VARIANT OleGetAxisMinValue();
255 void OleSetAxisMinValue(const VARIANT& var);
256 VARIANT OleGetAxisMaxValue();
257 void OleSetAxisMaxValue(const VARIANT& var);
258
259 BOOL OleGetLegendVisible();
260 void OleSetLegendVisible(BOOL bValue);
261 BOOL OleGetVisible();
262 void OleSetVisible(BOOL bValue);
263 LPDISPATCH OleGetFillStyle();
264
265 OLE_COLOR OleGetColor();
266 OLE_COLOR OleGetColor2();
267 void OleSetColor(OLE_COLOR clr);
268 void OleSetColor2(OLE_COLOR clr);
269
271# endif
272
273protected:
274 BOOL m_bLegendVisible;
275 BOOL m_bVisible;
277 CXTPChartString m_strName;
278 CXTPChartString m_strLegendName;
280 CXTPChartString m_strAxisMinValue;
281 CXTPChartString m_strAxisMaxValue;
283 double m_dAxisMinValue;
284 double m_dAxisMaxValue;
286 CXTPChartColor m_clrColor;
287 CXTPChartColor m_clrColor2;
289 CXTPChartFillStyle* m_pFillStyle;
291 friend class CXTPChartAxisStrips;
292};
293
299class _XTP_EXT_CLASS CXTPChartAxisStrips : public CXTPChartElementCollection
300{
301public:
308 CXTPChartAxisStrips(CXTPChartAxis* pAxis);
309
314 virtual ~CXTPChartAxisStrips();
315
316public:
324 CXTPChartAxisStrip* Add(CXTPChartAxisStrip* pStrip);
325
334 CXTPChartAxisStrip* GetAt(int nIndex) const;
335
336public:
337 void DoPropExchange(CXTPPropExchange* pPX);
338
339# ifdef _XTP_ACTIVEX
341 DECLARE_DISPATCH_MAP()
342 DECLARE_INTERFACE_MAP()
343
344 DECLARE_OLETYPELIB_EX(CXTPChartAxisStrips);
345
346 afx_msg long OleGetItemCount();
347 afx_msg LPDISPATCH OleGetItem(long nIndex);
348 DECLARE_ENUM_VARIANT(CXTPChartAxisStrips)
349
350 afx_msg LPDISPATCH OleAdd(LPCWSTR lpszTitle);
352# endif
353
354protected:
355};
356
357AFX_INLINE CXTPChartAxisStrip* CXTPChartAxisStrips::GetAt(int nIndex) const
358{
359 return nIndex >= 0 && nIndex < m_arrElements.GetSize()
360 ? (CXTPChartAxisStrip*)m_arrElements.GetAt(nIndex)
361 : NULL;
362}
363
364AFX_INLINE CXTPChartString CXTPChartAxisStrip::GetName() const
365{
366 return m_strName;
367}
368AFX_INLINE void CXTPChartAxisStrip::SetVisible(BOOL bVisible)
369{
370 m_bVisible = bVisible;
371 OnChartChanged();
372}
373AFX_INLINE BOOL CXTPChartAxisStrip::IsVisible() const
374{
375 return m_bVisible;
376}
377AFX_INLINE CXTPChartFillStyle* CXTPChartAxisStrip::GetFillStyle() const
378{
379 return m_pFillStyle;
380}
381AFX_INLINE CXTPChartString CXTPChartAxisStrip::GetAxisMinValue() const
382{
383 return m_strAxisMinValue;
384}
385AFX_INLINE double CXTPChartAxisStrip::GetAxisMinValueInternal() const
386{
387 return m_dAxisMinValue;
388}
389AFX_INLINE void CXTPChartAxisStrip::SetAxisMinValue(LPCTSTR lpszValue)
390{
391 m_strAxisMinValue = lpszValue;
392 OnChartChanged();
393}
394AFX_INLINE void CXTPChartAxisStrip::SetAxisMinValue(double dValue)
395{
396 m_dAxisMinValue = dValue;
397 m_strAxisMinValue.Empty();
398 OnChartChanged();
399}
400AFX_INLINE CXTPChartString CXTPChartAxisStrip::GetAxisMaxValue() const
401{
402 return m_strAxisMaxValue;
403}
404AFX_INLINE double CXTPChartAxisStrip::GetAxisMaxValueInternal() const
405{
406 return m_dAxisMaxValue;
407}
408AFX_INLINE void CXTPChartAxisStrip::SetAxisMaxValue(LPCTSTR lpszValue)
409{
410 m_strAxisMaxValue = lpszValue;
411 OnChartChanged();
412}
413AFX_INLINE void CXTPChartAxisStrip::SetAxisMaxValue(double dValue)
414{
415 m_dAxisMaxValue = dValue;
416 m_strAxisMaxValue.Empty();
417 OnChartChanged();
418}
419AFX_INLINE BOOL CXTPChartAxisStrip::IsLegendVisible() const
420{
421 return m_bLegendVisible;
422}
423AFX_INLINE void CXTPChartAxisStrip::SetLegendVisible(BOOL bLegendVisible)
424{
425 m_bLegendVisible = bLegendVisible;
426 OnChartChanged();
427}
428AFX_INLINE CXTPChartColor CXTPChartAxisStrip::GetColor() const
429{
430 return m_clrColor;
431}
432AFX_INLINE CXTPChartColor CXTPChartAxisStrip::GetColor2() const
433{
434 return m_clrColor2;
435}
436AFX_INLINE void CXTPChartAxisStrip::SetLegendName(const CXTPChartString& lpszName)
437{
438 m_strLegendName = lpszName;
439 OnChartChanged();
440}
442# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
443#endif //#if !defined(__XTPCHARTAXISStripS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartAxis
This abstract base class represents a chart axis as a kind of chart element.
Definition XTPChartAxis.h:86
CXTPChartAxisStrip
This is a hybrid object of CXTPChartElement and CXTPChartLegendItemView.
Definition XTPChartAxisStrips.h:43
CXTPChartAxisStrip::CXTPChartAxisStrip
CXTPChartAxisStrip()
Constructs a CXTPChartAxisStrip object.
CXTPChartAxisStrip::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisStrip::SetColor
void SetColor(const CXTPChartColor &color)
Call this function to set the color of the axis strip.
CXTPChartAxisStrip::SetAxisMaxValue
void SetAxisMaxValue(LPCTSTR lpszValue)
Call this function to get the maximum value for the strip in the axis.
Definition XTPChartAxisStrips.h:408
CXTPChartAxisStrip::SetVisible
void SetVisible(BOOL bVisible)
Use this function to set the visibility of the axis strip.
Definition XTPChartAxisStrips.h:368
CXTPChartAxisStrip::GetActualColor
CXTPChartColor GetActualColor() const
Call this function to get the actual color of the axis strip.
CXTPChartAxisStrip::~CXTPChartAxisStrip
virtual ~CXTPChartAxisStrip()
Destroys a CXTPChartAxisStrip object, handles cleanup.
CXTPChartAxisStrip::m_strLegendName
CXTPChartString m_strLegendName
The name of the legend item.
Definition XTPChartAxisStrips.h:278
CXTPChartAxisStrip::m_clrColor
CXTPChartColor m_clrColor
The color of the strip.
Definition XTPChartAxisStrips.h:286
CXTPChartAxisStrip::m_dAxisMinValue
double m_dAxisMinValue
The minimum value of the strip in the axis.
Definition XTPChartAxisStrips.h:283
CXTPChartAxisStrip::GetFillStyle
CXTPChartFillStyle * GetFillStyle() const
Call this function to get the fill style of the axis strip.
Definition XTPChartAxisStrips.h:377
CXTPChartAxisStrip::GetColor
CXTPChartColor GetColor() const
Use this function to get the apparent color of the axis strip.
Definition XTPChartAxisStrips.h:428
CXTPChartAxisStrip::SetLegendVisible
void SetLegendVisible(BOOL bVisible)
Use this function to set the visibility of the legend item.
Definition XTPChartAxisStrips.h:423
CXTPChartAxisStrip::GetLegendName
CXTPChartString GetLegendName() const
Call this function get the legend item name of the axis strip.
CXTPChartAxisStrip::SetLegendName
void SetLegendName(const CXTPChartString &lpszName)
Use this function to set the legend item name for the axis strip.
Definition XTPChartAxisStrips.h:436
CXTPChartAxisStrip::SetName
void SetName(const CXTPChartString &lpszName)
Use this function to set the name for the axis strip.
CXTPChartAxisStrip::IsVisible
BOOL IsVisible() const
Call this function to check the visibility of the axis strip.
Definition XTPChartAxisStrips.h:373
CXTPChartAxisStrip::m_bLegendVisible
BOOL m_bLegendVisible
TRUE if the legend item is visible, FALSE if not visible.
Definition XTPChartAxisStrips.h:274
CXTPChartAxisStrip::SetColor2
void SetColor2(const CXTPChartColor &color)
Call this function to set the color of the axis strip.
CXTPChartAxisStrip::m_strName
CXTPChartString m_strName
The name of the strip.
Definition XTPChartAxisStrips.h:277
CXTPChartAxisStrip::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)
This function creates a CXTPChartDeviceCommand object.
CXTPChartAxisStrip::m_bVisible
BOOL m_bVisible
TRUE if the strip is visible, FALSE if not visible.
Definition XTPChartAxisStrips.h:275
CXTPChartAxisStrip::m_clrColor2
CXTPChartColor m_clrColor2
The color of the strip.
Definition XTPChartAxisStrips.h:287
CXTPChartAxisStrip::GetAxisMaxValue
CXTPChartString GetAxisMaxValue() const
Call this function to get the maximum value of the strip in the axis.
Definition XTPChartAxisStrips.h:400
CXTPChartAxisStrip::m_pFillStyle
CXTPChartFillStyle * m_pFillStyle
The fill style used for the background painting.
Definition XTPChartAxisStrips.h:289
CXTPChartAxisStrip::m_dAxisMaxValue
double m_dAxisMaxValue
The maximum value of the strip in the axis.
Definition XTPChartAxisStrips.h:284
CXTPChartAxisStrip::IsLegendVisible
BOOL IsLegendVisible() const
Call this function to check the visibility of the legend item.
Definition XTPChartAxisStrips.h:419
CXTPChartAxisStrip::SetAxisMinValue
void SetAxisMinValue(LPCTSTR lpszValue)
Call this function to set the minimum value for the strip in the axis.
Definition XTPChartAxisStrips.h:389
CXTPChartAxisStrip::GetAxisMinValueInternal
double GetAxisMinValueInternal() const
Call this function to get the minimum value of the strip in the axis.
Definition XTPChartAxisStrips.h:385
CXTPChartAxisStrip::GetName
CXTPChartString GetName() const
Call this function to get the name of the axis strip.
Definition XTPChartAxisStrips.h:364
CXTPChartAxisStrip::GetAxisMinValue
CXTPChartString GetAxisMinValue() const
Call this function to get the minimum value of the strip in the axis.
Definition XTPChartAxisStrips.h:381
CXTPChartAxisStrip::m_strAxisMaxValue
CXTPChartString m_strAxisMaxValue
The maximum value of the strip in the axis.
Definition XTPChartAxisStrips.h:281
CXTPChartAxisStrip::m_strAxisMinValue
CXTPChartString m_strAxisMinValue
The minimum value of the strip in the axis.
Definition XTPChartAxisStrips.h:280
CXTPChartAxisStrips
This class encapsulates a collection of chart axis strip objects.
Definition XTPChartAxisStrips.h:300
CXTPChartAxisStrips::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Reads this object from or writes this object to an archive.
CXTPChartAxisStrips::CXTPChartAxisStrips
CXTPChartAxisStrips(CXTPChartAxis *pAxis)
Constructs a CXTPChartAxisStrips object.
CXTPChartAxisStrips::GetAt
CXTPChartAxisStrip * GetAt(int nIndex) const
Use this function to get a strip at a particular index in the strips collection.
Definition XTPChartAxisStrips.h:357
CXTPChartAxisStrips::~CXTPChartAxisStrips
virtual ~CXTPChartAxisStrips()
Destroys a CXTPChartAxisStrip object, handles cleanup.
CXTPChartAxisStrips::Add
CXTPChartAxisStrip * Add(CXTPChartAxisStrip *pStrip)
Call this function to add a new strip to the collection.
CXTPChartColor
This class abstracts a color entity.
Definition XTPChartTypes.h:51
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartElementCollection
This class abstracts a chart collection.
Definition XTPChartElement.h:358
CXTPChartElementCollection::m_arrElements
CArray< CXTPChartElement *, CXTPChartElement * > m_arrElements
Array of CXTPChartElement pointer.
Definition XTPChartElement.h:450
CXTPChartElement
This class abstracts a chart element, this class acts as a base class for all chart elements.
Definition XTPChartElement.h:131
CXTPChartElement::OnChartChanged
virtual void OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView)
Call this virtual function to trigger a re-painting when there is a change in the intrinsic propertie...
CXTPChartFillStyle
This class abstracts a fill style used to fill the background of various chart elements.
Definition XTPChartFillStyle.h:43
CXTPChartLegendItemView
CXTPChartLegendItemView is an abstract base class which represents a chart legend item.
Definition XTPChartLegendItem.h:39
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


Toolkit Pro: XTPMarkupCheckBox.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupCheckBox.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPCHECKBOX_H__)
24# define __XTPMARKUPCHECKBOX_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDrawingContext;
34
40class _XTP_EXT_CLASS CXTPMarkupCheckBox : public CXTPMarkupToggleButton
41{
43 DECLARE_MARKUPCLASS(CXTPMarkupCheckBox);
45protected:
50 CXTPMarkupCheckBox();
51
56 ~CXTPMarkupCheckBox();
57
58protected:
60 // Implementation
61 void OnRender(CXTPMarkupDrawingContext* pDC);
62 void OnRenderFocusVisual(CXTPMarkupDrawingContext* drawingContext);
63 CSize ArrangeOverride(CSize szFinalSize);
64 CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
68public:
69 DECLARE_DISPATCH_MAP()
70# ifdef _XTP_ACTIVEX
71 DECLARE_INTERFACE_MAP()
72 DECLARE_OLETYPELIB_EX(CXTPMarkupCheckBox);
73# endif
74
76};
77
78# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
80#endif // !defined(__XTPMARKUPCHECKBOX_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupCheckBox
CXTPMarkupCheckBox is a CXTPMarkupToggleButton derived class.
Definition XTPMarkupCheckBox.h:41
CXTPMarkupCheckBox::~CXTPMarkupCheckBox
~CXTPMarkupCheckBox()
Destroys a CXTPMarkupCheckBox object, handles cleanup and deallocation.
CXTPMarkupCheckBox::CXTPMarkupCheckBox
CXTPMarkupCheckBox()
Constructs a CXTPMarkupCheckBox object.
CXTPMarkupToggleButton
CXTPMarkupToggleButton is a CXTPMarkupButtonBase derived class.
Definition XTPMarkupToggleButton.h:45
CXTPMarkupVisual::OnRender
virtual void OnRender(CXTPMarkupDrawingContext *drawingContext)
When overridden in a derived class, participates in rendering operations that are directed by the lay...
Definition XTPMarkupInputElement.h:515
CXTPMarkupVisual::OnRenderFocusVisual
virtual void OnRenderFocusVisual(CXTPMarkupDrawingContext *drawingContext)
This method is called to render the focus rectangle of a focused object.
Definition XTPMarkupInputElement.h:519


Toolkit Pro: XTPScrollBarThemeOfficeXP.h Source File

  • Source
  • Common
  • ScrollBar
  • Themes
XTPScrollBarThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARTHEMEOFFICEXP_H__)
24# define __XTPSCROLLBARTHEMEOFFICEXP_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPScrollBarThemeOfficeXP : public CXTPScrollBarThemeWindowsUx
39{
40protected:
45 virtual void RefreshMetrics();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif /*__XTPSCROLLBARTHEMEOFFICEXP_H__*/
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollBarThemeOfficeXP
Scrollbar paint manager used to draw Office XP like scrollbars.
Definition XTPScrollBarThemeOfficeXP.h:39
CXTPScrollBarThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics()
Recalculates scrollbar metrics.
CXTPScrollBarThemeWindowsUx
Scrollbar paint manager used to draw scrollbars that use current Windows theme.
Definition XTPScrollBarThemeWindowsUx.h:39


CXTPMessageBarPaintManager Member List

This is the complete list of members for CXTPMessageBarPaintManager, including all inherited members.

CXTPMessageBarPaintManager(CXTPPaintManager *pPaintManager) | CXTPMessageBarPaintManager |
DrawMessageBarButton(CDC *pDC, CXTPMessageBarButton *pButton) | CXTPMessageBarPaintManager | virtual
FillMessageBar(CDC *pDC, CXTPMessageBar *pBar) | CXTPMessageBarPaintManager | virtual
GetCloseButtonRect(int x, int y, int cy) | CXTPMessageBarPaintManager | virtual
GetDefaultButtonSize() const | CXTPMessageBarPaintManager | virtual
GetHeight() const | CXTPMessageBarPaintManager | virtual
GetPadding() const | CXTPMessageBarPaintManager | virtual
m_clrBack | CXTPMessageBarPaintManager | protected
m_clrBorder | CXTPMessageBarPaintManager | protected
m_clrInfoBack | CXTPMessageBarPaintManager | protected
m_clrText | CXTPMessageBarPaintManager | protected
m_pPaintManager | CXTPMessageBarPaintManager | protected
RefreshMetrics() | CXTPMessageBarPaintManager | virtual
~CXTPMessageBarPaintManager() | CXTPMessageBarPaintManager | inlinevirtual


Toolkit Pro: XTPCommandBarsColorSetOffice2013.h Source File

  • Source
  • CommandBars
  • ColorSets
XTPCommandBarsColorSetOffice2013.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSCOLORSETOFFICE2013_H__)
24# define __XTPCOMMANDBARSCOLORSETOFFICE2013_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPColorSetStateButton : public CXTPCmdTarget
38{
40 DECLARE_DYNAMIC(CXTPColorSetStateButton)
42public:
48 virtual void RefreshColors() = 0;
49
50 CXTPPaintManagerColor clrText;
51 CXTPPaintManagerColor clrTextHighlight;
52 CXTPPaintManagerColor clrTextPushed;
53 CXTPPaintManagerColor clrTextDisabled;
54 CXTPPaintManagerColor clrTextChecked;
55 CXTPPaintManagerColor clrTextCheckedHighlight;
57 CXTPPaintManagerColor clrBack;
58 CXTPPaintManagerColor clrBackHighlight;
59 CXTPPaintManagerColor clrBackPushed;
60 CXTPPaintManagerColor clrBackDisabled;
61 CXTPPaintManagerColor clrBackChecked;
62 CXTPPaintManagerColor clrBackCheckedHighlight;
64 CXTPPaintManagerColor clrBorder;
65 CXTPPaintManagerColor clrBorderHighlight;
66 CXTPPaintManagerColor clrBorderPushed;
67 CXTPPaintManagerColor clrBorderDisabled;
68 CXTPPaintManagerColor clrBorderChecked;
69 CXTPPaintManagerColor clrBorderCheckedHighlight;
70};
71
76class _XTP_EXT_CLASS CXTPColorSetStateMenu : public CXTPColorSetStateButton
77{
79 DECLARE_DYNAMIC(CXTPColorSetStateMenu)
81public:
87 virtual void RefreshColors();
88
89 CXTPPaintManagerColor clrMenuBack;
90 CXTPPaintManagerColor clrMenuBorder;
91 CXTPPaintManagerColor clrGripper;
92 CXTPPaintManagerColorGradient clrSeparator;
93};
94
100class _XTP_EXT_CLASS CXTPColorSetStateMenuTitleBar : public CXTPColorSetStateButton
101{
102 DECLARE_DYNAMIC(CXTPColorSetStateMenuTitleBar)
103
104public:
105 //-----------------------------------------------------------------------
106 // Summary: Call this member function to refresh the colors from predefined
107 // Section and Key values located in the theme INI file for loaded
108 // resource DLL.
109 //-----------------------------------------------------------------------
110 virtual void RefreshColors();
111
112 CXTPPaintManagerColor m_clrMenuTitleBarText; // MenuTitleBar text color.
113 CXTPPaintManagerColor m_clrMenuTitleBarTextInactive; // MenuTitleBar inactive text color.
114 CXTPPaintManagerColor m_clrMenuTitleBarTextBack; // MenuTitleBar back color.
115 CXTPPaintManagerColor m_clrMenuTitleBarTextBackInactive; // MenuTitleBar inactive back color.
116};
117
122class _XTP_EXT_CLASS CXTPColorSetStateRibbon : public CXTPColorSetStateButton
123{
125 DECLARE_DYNAMIC(CXTPColorSetStateRibbon)
127public:
133 virtual void RefreshColors();
134
135 CXTPPaintManagerColor clrTabTextInactive;
136 CXTPPaintManagerColor clrTabBackInactive;
137};
138
143class _XTP_EXT_CLASS CXTPColorSetStateToolbar : public CXTPColorSetStateButton
144{
146 DECLARE_DYNAMIC(CXTPColorSetStateToolbar)
148public:
154 virtual void RefreshColors();
155
156 CXTPPaintManagerColor clrToolbarBack;
157 CXTPPaintManagerColor clrToolbarActiveBack;
158 CXTPPaintManagerColor clrToolbarInactiveBack;
159 CXTPPaintManagerColor clrToolbarBorder;
160 CXTPPaintManagerColor clrToolbarActiveBorder;
161 CXTPPaintManagerColor clrToolbarInactiveBorder;
162 CXTPPaintManagerColor clrEditBorder;
163 CXTPPaintManagerColor clrGripper;
164 CXTPPaintManagerColor clrDisabledIcon;
165 CXTPPaintManagerColorGradient clrSeparator;
166};
167
173class _XTP_EXT_CLASS CXTPColorSetStateCheckMark
174{
175public:
180 virtual ~CXTPColorSetStateCheckMark()
181 {
182 }
183
189 virtual void RefreshColors();
190
191 CXTPPaintManagerColor clrCheck;
192 CXTPPaintManagerColor clrCheckHighlight;
193 CXTPPaintManagerColor clrCheckPushed;
194 CXTPPaintManagerColor clrCheckDisabled;
196 CXTPPaintManagerColor clrBack;
197 CXTPPaintManagerColor clrBackHighlight;
198 CXTPPaintManagerColor clrBackPushed;
199 CXTPPaintManagerColor clrBackDisabled;
200};
201
207class _XTP_EXT_CLASS CXTPColorSetStateComboBox
208{
209public:
214 virtual ~CXTPColorSetStateComboBox()
215 {
216 }
217
223 virtual void RefreshColors();
224
225 CXTPPaintManagerColor clrBack;
226 CXTPPaintManagerColor clrBackHighlight;
227 CXTPPaintManagerColor clrBackDropped;
228 CXTPPaintManagerColor clrBackDisabled;
230 CXTPPaintManagerColor clrBorder;
231 CXTPPaintManagerColor clrBorderHighlight;
232 CXTPPaintManagerColor clrBorderDropped;
233 CXTPPaintManagerColor clrBorderDisabled;
235 CXTPPaintManagerColor clrDropDownBack;
236 CXTPPaintManagerColor clrDropDownBackHighlight;
238 CXTPPaintManagerColor clrDropDownBackDropped;
240 CXTPPaintManagerColor clrDropDownBackDisabled;
243 CXTPPaintManagerColor clrDropDownBorder;
244 CXTPPaintManagerColor clrDropDownBorderHighlight;
246 CXTPPaintManagerColor clrDropDownBorderDropped;
248 CXTPPaintManagerColor clrDropDownBorderDisabled;
251 CXTPPaintManagerColor clrDropDownMarker;
252 CXTPPaintManagerColor clrDropDownMarkerHighlight;
254 CXTPPaintManagerColor clrDropDownMarkerDropped;
256 CXTPPaintManagerColor clrDropDownMarkerDisabled;
258};
259
265class _XTP_EXT_CLASS CXTPColorSetStateCheckBox
266{
267public:
272 virtual ~CXTPColorSetStateCheckBox()
273 {
274 }
275
281 virtual void RefreshColors();
282
283 CXTPPaintManagerColor clrMark;
284 CXTPPaintManagerColor clrMarkPushed;
285 CXTPPaintManagerColor clrMarkHighlight;
286 CXTPPaintManagerColor clrMarkDisabled;
287 CXTPPaintManagerColor clrBack;
288 CXTPPaintManagerColor clrBackHighlight;
289 CXTPPaintManagerColor clrBackPushed;
290 CXTPPaintManagerColor clrBackDisabled;
291 CXTPPaintManagerColor clrBorder;
292 CXTPPaintManagerColor clrBorderPushed;
293 CXTPPaintManagerColor clrBorderHighlight;
294 CXTPPaintManagerColor clrBorderDisabled;
295};
296
298
299# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
300#endif // !defined(__XTPCOMMANDBARSCOLORSETOFFICE2013_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPColorSetStateButton
Base class used to define various state colors used by command bar buttons text, background and borde...
Definition XTPCommandBarsColorSetOffice2013.h:38
CXTPColorSetStateButton::clrBack
CXTPPaintManagerColor clrBack
Background Normal color.
Definition XTPCommandBarsColorSetOffice2013.h:57
CXTPColorSetStateButton::clrTextHighlight
CXTPPaintManagerColor clrTextHighlight
Text Highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:51
CXTPColorSetStateButton::clrBackDisabled
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.
Definition XTPCommandBarsColorSetOffice2013.h:60
CXTPColorSetStateButton::clrBorderChecked
CXTPPaintManagerColor clrBorderChecked
Border Checked color.
Definition XTPCommandBarsColorSetOffice2013.h:68
CXTPColorSetStateButton::clrBackChecked
CXTPPaintManagerColor clrBackChecked
Background Checked color.
Definition XTPCommandBarsColorSetOffice2013.h:61
CXTPColorSetStateButton::clrTextChecked
CXTPPaintManagerColor clrTextChecked
Text Checked color.
Definition XTPCommandBarsColorSetOffice2013.h:54
CXTPColorSetStateButton::clrBorder
CXTPPaintManagerColor clrBorder
Border Normal color.
Definition XTPCommandBarsColorSetOffice2013.h:64
CXTPColorSetStateButton::clrTextDisabled
CXTPPaintManagerColor clrTextDisabled
Text Disabled color.
Definition XTPCommandBarsColorSetOffice2013.h:53
CXTPColorSetStateButton::clrBorderCheckedHighlight
CXTPPaintManagerColor clrBorderCheckedHighlight
Border Checked highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:69
CXTPColorSetStateButton::clrTextPushed
CXTPPaintManagerColor clrTextPushed
Text Pushed color.
Definition XTPCommandBarsColorSetOffice2013.h:52
CXTPColorSetStateButton::clrTextCheckedHighlight
CXTPPaintManagerColor clrTextCheckedHighlight
Text Checked highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:55
CXTPColorSetStateButton::clrBackCheckedHighlight
CXTPPaintManagerColor clrBackCheckedHighlight
Background Checked highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:62
CXTPColorSetStateButton::clrBackPushed
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
Definition XTPCommandBarsColorSetOffice2013.h:59
CXTPColorSetStateButton::clrBorderHighlight
CXTPPaintManagerColor clrBorderHighlight
Border Highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:65
CXTPColorSetStateButton::clrBackHighlight
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:58
CXTPColorSetStateButton::clrText
CXTPPaintManagerColor clrText
Text Normal color.
Definition XTPCommandBarsColorSetOffice2013.h:50
CXTPColorSetStateButton::clrBorderPushed
CXTPPaintManagerColor clrBorderPushed
Border Pushed color.
Definition XTPCommandBarsColorSetOffice2013.h:66
CXTPColorSetStateButton::clrBorderDisabled
CXTPPaintManagerColor clrBorderDisabled
Border Disabled color.
Definition XTPCommandBarsColorSetOffice2013.h:67
CXTPColorSetStateButton::RefreshColors
virtual void RefreshColors()=0
Call this member function to refresh the colors from predefined Section and Key values located in the...
CXTPColorSetStateCheckBox
Helper class used to define various state colors used by check box and radio button controls.
Definition XTPCommandBarsColorSetOffice2013.h:266
CXTPColorSetStateCheckBox::~CXTPColorSetStateCheckBox
virtual ~CXTPColorSetStateCheckBox()
Handles object destruction.
Definition XTPCommandBarsColorSetOffice2013.h:272
CXTPColorSetStateCheckBox::RefreshColors
virtual void RefreshColors()
Call this member function to refresh the colors from predefined Section and Key values located in the...
CXTPColorSetStateCheckMark
Helper class used to define various state colors used by command bar check marks foreground and backg...
Definition XTPCommandBarsColorSetOffice2013.h:174
CXTPColorSetStateCheckMark::clrBack
CXTPPaintManagerColor clrBack
Background Normal color.
Definition XTPCommandBarsColorSetOffice2013.h:196
CXTPColorSetStateCheckMark::clrBackDisabled
CXTPPaintManagerColor clrBackDisabled
Background Disabled color.
Definition XTPCommandBarsColorSetOffice2013.h:199
CXTPColorSetStateCheckMark::clrCheck
CXTPPaintManagerColor clrCheck
Foreground Normal color.
Definition XTPCommandBarsColorSetOffice2013.h:191
CXTPColorSetStateCheckMark::clrCheckHighlight
CXTPPaintManagerColor clrCheckHighlight
Foreground Highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:192
CXTPColorSetStateCheckMark::~CXTPColorSetStateCheckMark
virtual ~CXTPColorSetStateCheckMark()
Handles object destruction.
Definition XTPCommandBarsColorSetOffice2013.h:180
CXTPColorSetStateCheckMark::clrCheckPushed
CXTPPaintManagerColor clrCheckPushed
Foreground Pushed color.
Definition XTPCommandBarsColorSetOffice2013.h:193
CXTPColorSetStateCheckMark::RefreshColors
virtual void RefreshColors()
Call this member function to refresh the colors from predefined Section and Key values located in the...
CXTPColorSetStateCheckMark::clrCheckDisabled
CXTPPaintManagerColor clrCheckDisabled
Foreground Disabled color.
Definition XTPCommandBarsColorSetOffice2013.h:194
CXTPColorSetStateCheckMark::clrBackPushed
CXTPPaintManagerColor clrBackPushed
Background Pushed color.
Definition XTPCommandBarsColorSetOffice2013.h:198
CXTPColorSetStateCheckMark::clrBackHighlight
CXTPPaintManagerColor clrBackHighlight
Background Highlight color.
Definition XTPCommandBarsColorSetOffice2013.h:197
CXTPColorSetStateComboBox
Helper class used to define various state colors used by command bar glyphs.
Definition XTPCommandBarsColorSetOffice2013.h:208
CXTPColorSetStateComboBox::clrDropDownBackHighlight
CXTPPaintManagerColor clrDropDownBackHighlight
Drop down ComboBox highlight background color.
Definition XTPCommandBarsColorSetOffice2013.h:236
CXTPColorSetStateComboBox::clrBack
CXTPPaintManagerColor clrBack
ComboBox normal background color.
Definition XTPCommandBarsColorSetOffice2013.h:225
CXTPColorSetStateComboBox::clrBackDisabled
CXTPPaintManagerColor clrBackDisabled
ComboBox disabled background color.
Definition XTPCommandBarsColorSetOffice2013.h:228
CXTPColorSetStateComboBox::clrBackDropped
CXTPPaintManagerColor clrBackDropped
ComboBox dropped background color.
Definition XTPCommandBarsColorSetOffice2013.h:227
CXTPColorSetStateComboBox::clrDropDownMarkerHighlight
CXTPPaintManagerColor clrDropDownMarkerHighlight
Drop down ComboBox highlight marker color.
Definition XTPCommandBarsColorSetOffice2013.h:252
CXTPColorSetStateComboBox::clrBorder
CXTPPaintManagerColor clrBorder
ComboBox normal border color.
Definition XTPCommandBarsColorSetOffice2013.h:230
CXTPColorSetStateComboBox::clrDropDownBorderDropped
CXTPPaintManagerColor clrDropDownBorderDropped
Drop down ComboBox dropped border color.
Definition XTPCommandBarsColorSetOffice2013.h:246
CXTPColorSetStateComboBox::~CXTPColorSetStateComboBox
virtual ~CXTPColorSetStateComboBox()
Handles object destruction.
Definition XTPCommandBarsColorSetOffice2013.h:214
CXTPColorSetStateComboBox::clrDropDownBorder
CXTPPaintManagerColor clrDropDownBorder
Drop down ComboBox normal border color.
Definition XTPCommandBarsColorSetOffice2013.h:243
CXTPColorSetStateComboBox::clrDropDownBorderDisabled
CXTPPaintManagerColor clrDropDownBorderDisabled
Drop down ComboBox disabled border color.
Definition XTPCommandBarsColorSetOffice2013.h:248
CXTPColorSetStateComboBox::clrDropDownBackDropped
CXTPPaintManagerColor clrDropDownBackDropped
Drop down ComboBox dropped background color.
Definition XTPCommandBarsColorSetOffice2013.h:238
CXTPColorSetStateComboBox::clrBorderDropped
CXTPPaintManagerColor clrBorderDropped
ComboBox dropped border color.
Definition XTPCommandBarsColorSetOffice2013.h:232
CXTPColorSetStateComboBox::clrDropDownMarkerDisabled
CXTPPaintManagerColor clrDropDownMarkerDisabled
Drop down ComboBox disabled marker color.
Definition XTPCommandBarsColorSetOffice2013.h:256
CXTPColorSetStateComboBox::clrDropDownBorderHighlight
CXTPPaintManagerColor clrDropDownBorderHighlight
Drop down ComboBox highlight border color.
Definition XTPCommandBarsColorSetOffice2013.h:244
CXTPColorSetStateComboBox::RefreshColors
virtual void RefreshColors()
Call this member function to refresh the colors from predefined Section and Key values located in the...
CXTPColorSetStateComboBox::clrBorderHighlight
CXTPPaintManagerColor clrBorderHighlight
ComboBox highlight border color.
Definition XTPCommandBarsColorSetOffice2013.h:231
CXTPColorSetStateComboBox::clrDropDownBack
CXTPPaintManagerColor clrDropDownBack
Drop down ComboBox normal background color.
Definition XTPCommandBarsColorSetOffice2013.h:235
CXTPColorSetStateComboBox::clrDropDownMarker
CXTPPaintManagerColor clrDropDownMarker
Drop down ComboBox normal marker color.
Definition XTPCommandBarsColorSetOffice2013.h:251
CXTPColorSetStateComboBox::clrBackHighlight
CXTPPaintManagerColor clrBackHighlight
ComboBox highlight background color.
Definition XTPCommandBarsColorSetOffice2013.h:226
CXTPColorSetStateComboBox::clrDropDownMarkerDropped
CXTPPaintManagerColor clrDropDownMarkerDropped
Drop down ComboBox dropped marker color.
Definition XTPCommandBarsColorSetOffice2013.h:254
CXTPColorSetStateComboBox::clrDropDownBackDisabled
CXTPPaintManagerColor clrDropDownBackDisabled
Drop down ComboBox disabled background color.
Definition XTPCommandBarsColorSetOffice2013.h:240
CXTPColorSetStateComboBox::clrBorderDisabled
CXTPPaintManagerColor clrBorderDisabled
ComboBox disabled border color.
Definition XTPCommandBarsColorSetOffice2013.h:233
CXTPColorSetStateMenu
Color set class used to define various state colors used by command bar menus.
Definition XTPCommandBarsColorSetOffice2013.h:77
CXTPColorSetStateMenu::clrSeparator
CXTPPaintManagerColorGradient clrSeparator
Separator dark and light colors.
Definition XTPCommandBarsColorSetOffice2013.h:92
CXTPColorSetStateMenu::clrMenuBack
CXTPPaintManagerColor clrMenuBack
Menu background color.
Definition XTPCommandBarsColorSetOffice2013.h:89
CXTPColorSetStateMenu::clrMenuBorder
CXTPPaintManagerColor clrMenuBorder
Menu border color.
Definition XTPCommandBarsColorSetOffice2013.h:90
CXTPColorSetStateMenu::clrGripper
CXTPPaintManagerColor clrGripper
Menu item icon strip background color.
Definition XTPCommandBarsColorSetOffice2013.h:91
CXTPColorSetStateMenu::RefreshColors
virtual void RefreshColors()
Call this member function to refresh the colors from predefined Section and Key values located in the...
CXTPColorSetStateMenuTitleBar
Color set class used to define various state colors used by command bar menu title bars.
Definition XTPCommandBarsColorSetOffice2013.h:101
CXTPColorSetStateRibbon
Color set class used to define various state colors used by command bar ribbon.
Definition XTPCommandBarsColorSetOffice2013.h:123
CXTPColorSetStateRibbon::clrTabTextInactive
CXTPPaintManagerColor clrTabTextInactive
Ribbon tab inactive text color;
Definition XTPCommandBarsColorSetOffice2013.h:135
CXTPColorSetStateRibbon::RefreshColors
virtual void RefreshColors()
Call this member function to refresh the colors from predefined Section and Key values located in the...
CXTPColorSetStateRibbon::clrTabBackInactive
CXTPPaintManagerColor clrTabBackInactive
Ribbon tab inactive background color;.
Definition XTPCommandBarsColorSetOffice2013.h:136
CXTPColorSetStateToolbar
Color set class used to define various state colors used by command bar toolbars.
Definition XTPCommandBarsColorSetOffice2013.h:144
CXTPColorSetStateToolbar::clrSeparator
CXTPPaintManagerColorGradient clrSeparator
Separator dark and light colors.
Definition XTPCommandBarsColorSetOffice2013.h:165
CXTPColorSetStateToolbar::clrToolbarInactiveBack
CXTPPaintManagerColor clrToolbarInactiveBack
Toolbar inactive background color.
Definition XTPCommandBarsColorSetOffice2013.h:158
CXTPColorSetStateToolbar::clrToolbarActiveBack
CXTPPaintManagerColor clrToolbarActiveBack
Toolbar active background color.
Definition XTPCommandBarsColorSetOffice2013.h:157
CXTPColorSetStateToolbar::clrToolbarBorder
CXTPPaintManagerColor clrToolbarBorder
Toolbar border color.
Definition XTPCommandBarsColorSetOffice2013.h:159
CXTPColorSetStateToolbar::clrGripper
CXTPPaintManagerColor clrGripper
Toolbar gripper color.
Definition XTPCommandBarsColorSetOffice2013.h:163
CXTPColorSetStateToolbar::clrDisabledIcon
CXTPPaintManagerColor clrDisabledIcon
Toolbar disabled icon color.
Definition XTPCommandBarsColorSetOffice2013.h:164
CXTPColorSetStateToolbar::clrToolbarInactiveBorder
CXTPPaintManagerColor clrToolbarInactiveBorder
Toolbar inactive border color.
Definition XTPCommandBarsColorSetOffice2013.h:161
CXTPColorSetStateToolbar::clrEditBorder
CXTPPaintManagerColor clrEditBorder
Toolbar edit control border color.
Definition XTPCommandBarsColorSetOffice2013.h:162
CXTPColorSetStateToolbar::RefreshColors
virtual void RefreshColors()
Call this member function to refresh the colors from predefined Section and Key values located in the...
CXTPColorSetStateToolbar::clrToolbarActiveBorder
CXTPPaintManagerColor clrToolbarActiveBorder
Toolbar active border color.
Definition XTPCommandBarsColorSetOffice2013.h:160
CXTPColorSetStateToolbar::clrToolbarBack
CXTPPaintManagerColor clrToolbarBack
Toolbar background color.
Definition XTPCommandBarsColorSetOffice2013.h:156
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPControlGalleryVisualStudio2022Theme.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryVisualStudio2022Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYVISUALSTUDIO2022THEME_H__)
24# define __XTPCONTROLGALLERYVISUALSTUDIO2022THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPControlGalleryVisualStudio2022Theme
41 : public CXTPControlGalleryOffice2013Theme
42{
43public:
49 CXTPControlGalleryVisualStudio2022Theme(CXTPPaintManager* pPaintManager);
50};
51
53# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
54#endif // !defined(__XTPCONTROLGALLERYVISUALSTUDIO2022THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlGalleryOffice2013Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Office 2013 style theme for Com...
Definition XTPControlGalleryOffice2013Theme.h:41
CXTPControlGalleryVisualStudio2022Theme
The CXTPControlGalleryResourceTheme class is used to enable a Gallery Visual Studio 2022 style theme ...
Definition XTPControlGalleryVisualStudio2022Theme.h:42
CXTPControlGalleryVisualStudio2022Theme::CXTPControlGalleryVisualStudio2022Theme
CXTPControlGalleryVisualStudio2022Theme(CXTPPaintManager *pPaintManager)
Constructs a CXTPControlGalleryVisualStudio2022Theme object.
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPCalendarDatabaseDataProvider.h Source File

  • Source
  • Calendar
XTPCalendarDatabaseDataProvider.h
Go to the documentation of this file.
1
22#if !defined(_XTPCALENDARDATABASEDATAPROVIDER_H__)
23# define _XTPCALENDARDATABASEDATAPROVIDER_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPCalendarSchedule;
32class CXTPCalendarSchedules;
33struct XTP_CALENDAR_RECURRENCE_OPTIONS;
35 XTP_DEFINE_SMART_PTR_INTERNAL(CXTPCalendarSchedules)
58class _XTP_EXT_CLASS CXTPCalendarDatabaseDataProvider : public CXTPCalendarData
59{
60 class CADOCommand;
62 DECLARE_DYNAMIC(CXTPCalendarDatabaseDataProvider)
64public:
77 CXTPCalendarDatabaseDataProvider();
78
86 virtual ~CXTPCalendarDatabaseDataProvider();
87
98 virtual BOOL Open();
99
115 virtual BOOL OpenEx(LPDISPATCH pdispADOConnection);
116
127 virtual BOOL Create();
128
141 virtual BOOL Save();
142
147 virtual void Close();
148
149protected:
162 virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay);
163
172 virtual void DoRemoveAllEvents();
173
187 virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID);
188
201 virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID);
202
219 virtual BOOL DoCreate_Event(CXTPCalendarEvent* pEvent, DWORD& rdwNewEventID);
220
236 virtual BOOL DoUpdate_Event(CXTPCalendarEvent* pEvent);
237
252 virtual BOOL DoDelete_Event(CXTPCalendarEvent* pEvent);
253
270 virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern* pPattern, DWORD& rdwNewPatternID);
271
285 virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern* pPattern);
286
301 virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern* pPattern);
302
319 virtual CXTPCalendarEventsPtr DoGetAllEvents_raw();
320
339 virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom,
340 COleDateTimeSpan spPeriod);
341
342public:
343 static void AFX_CDECL TRACE_ProviderError(XTPADODB::_Connection* pConnDB);
344 static void AFX_CDECL TRACE_ComError(_com_error& e);
345
346private:
347 virtual CXTPCalendarEventPtr _ReadEvent_common(XTPADODB::_Recordset* pRS, BOOL bEcxception);
348
349 virtual BOOL _ReadRExceptions(CXTPCalendarRecurrencePattern* pPattern);
350
351 virtual BOOL _GetRPatternOptions(XTPADODB::_Recordset* pRS,
352 XTP_CALENDAR_RECURRENCE_OPTIONS* rROptions);
353
364 virtual BOOL SaveOptions(const CString& strOptionsData);
365
374 virtual BOOL LoadOptions();
375
376 virtual CXTPCalendarSchedulesPtr LoadSchedules();
377 virtual void UpdateSchedules();
378
379 virtual void _AddSchedules(CXTPCalendarSchedules* pAddSet);
380 virtual void _UpdateSchedules(CXTPCalendarSchedules* pUpdateSet,
381 CXTPCalendarSchedules* pOrigSet);
382 virtual void _DeleteSchedules(CUIntArray* pDeleteIDs);
383
384 virtual CXTPCalendarSchedule* _ReadSchedule(XTPADODB::_Recordset* pRS);
385
386protected:
387 BOOL m_bTraceOptions;
390private:
391 BOOL _Open();
392
393 void CreateEventTable(XTPADOX::_CatalogPtr ptrCatalog);
394 void CreateRPatternTable(XTPADOX::_CatalogPtr ptrCatalog);
395 void CreateOptionsTable(XTPADOX::_CatalogPtr ptrCatalog);
396 void CreateSchedulesTable(XTPADOX::_CatalogPtr ptrCatalog);
397
398 BOOL IsTableExist(XTPADOX::_CatalogPtr ptrCatalog, LPCWSTR pwszTableName);
399
400 // void CreateDicTable(XTPADOX::_CatalogPtr ptrCatalog, LPCWSTR strTable,
401 // LPCWSTR strNameID, bool bAuto = true);
402
403 BOOL UpdateDBStructure(XTPADODB::_Connection* pconnDb);
404
405 // members
406
407 XTPADODB::_ConnectionPtr m_pconnDb;
408 BOOL m_bCloseDbConnection;
409
410 CADOCommand* m_pcmdGetLastID;
411
412 CADOCommand* m_pcmdAddEvent;
413 CADOCommand* m_pcmdDelEvent;
414 CADOCommand* m_pcmdUpdEvent;
415
416 CADOCommand* m_pcmdGetDayEvents;
417 CADOCommand* m_pcmdGetRExceptions;
418 CADOCommand* m_pcmdGetEvent;
419 CADOCommand* m_pcmdUpdEventPatternID;
420
421 CADOCommand* m_pcmdAddRPattern;
422 CADOCommand* m_pcmdDelRPattern;
423 CADOCommand* m_pcmdUpdRPattern;
424 CADOCommand* m_pcmdGetRPattern;
425
426 CADOCommand* m_pcmdRemoveAllEvents;
427 CADOCommand* m_pcmdRemoveAllRPatterns;
428
429 CADOCommand* m_pcmdRemoveAllOptions;
430 CADOCommand* m_pcmdGetOptions;
431 CADOCommand* m_pcmdAddOptions;
432
433 CADOCommand* m_pcmdAddSchedule;
434 CADOCommand* m_pcmdUpdSchedule;
435
436private:
437 // internal only used member functions
438
439 virtual BOOL _SetRPatternOptions(CADOCommand* pCmd, CXTPCalendarRecurrencePattern* pPattern);
440
441 void DeleteAllDBCommands();
442
443 void CreateGetLastIDCommand();
444 void CreateAddEventCommand();
445 void CreateDelEventCommand();
446 void CreateUpdEventCommand();
447 void CreateGetDayEventCommand();
448
449 void CreateAddRPatternCommand();
450 void CreateDelRPatternCommand();
451 void CreateUpdRPatternCommand();
452 void CreateGetRPatternCommand();
453 void CreateGetRExceptionsCommand();
454 void CreateGetEventCommand();
455 void CreateUpdEventPatternIDCommand();
456
457 void CreateRemoveAllCommands();
458
459 void CreateGetOptionsCommand();
460 void CreateAddOptionsCommand();
461
462 void CreateAddScheduleCommand();
463 void CreateUpdScheduleCommand();
464};
465
466# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
467#endif // !defined(_XTPCALENDARDATABASEDATAPROVIDER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DEFINE_SMART_PTR_INTERNAL
#define XTP_DEFINE_SMART_PTR_INTERNAL(ClassName)
Define smart pointer for the specified class as ClassNamePtr.
Definition XTPSmartPtrInternalT.h:47
CXTPCalendarData
This class defines an abstract representation of the Calendar control data with all necessary methods...
Definition XTPCalendarData.h:97
CXTPCalendarDatabaseDataProvider
This class is the implementation of the XTPCalendarData abstract class which represents the data port...
Definition XTPCalendarDatabaseDataProvider.h:59
CXTPCalendarDatabaseDataProvider::DoRead_Event
virtual CXTPCalendarEventPtr DoRead_Event(DWORD dwEventID)
Read event from the database.
CXTPCalendarDatabaseDataProvider::DoRead_RPattern
virtual CXTPCalendarRecurrencePatternPtr DoRead_RPattern(DWORD dwPatternID)
Read recurrence pattern from the database.
CXTPCalendarDatabaseDataProvider::DoCreate_RPattern
virtual BOOL DoCreate_RPattern(CXTPCalendarRecurrencePattern *pPattern, DWORD &rdwNewPatternID)
Creates a new recurrence pattern in the database.
CXTPCalendarDatabaseDataProvider::DoDelete_Event
virtual BOOL DoDelete_Event(CXTPCalendarEvent *pEvent)
Deletes an event from the database.
CXTPCalendarDatabaseDataProvider::DoUpdate_RPattern
virtual BOOL DoUpdate_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Updates a recurrence pattern in the database.
CXTPCalendarDatabaseDataProvider::DoCreate_Event
virtual BOOL DoCreate_Event(CXTPCalendarEvent *pEvent, DWORD &rdwNewEventID)
Creates a new event in the database.
CXTPCalendarDatabaseDataProvider::CXTPCalendarDatabaseDataProvider
CXTPCalendarDatabaseDataProvider()
Default constructor.
CXTPCalendarDatabaseDataProvider::DoGetUpcomingEvents
virtual CXTPCalendarEventsPtr DoGetUpcomingEvents(COleDateTime dtFrom, COleDateTimeSpan spPeriod)
Retrieves a collection of events expiring in the period from dtFrom during next spPeriod.
CXTPCalendarDatabaseDataProvider::DoDelete_RPattern
virtual BOOL DoDelete_RPattern(CXTPCalendarRecurrencePattern *pPattern)
Deletes a recurrence pattern from the database.
CXTPCalendarDatabaseDataProvider::DoUpdate_Event
virtual BOOL DoUpdate_Event(CXTPCalendarEvent *pEvent)
Updates event properties in the database.
CXTPCalendarDatabaseDataProvider::~CXTPCalendarDatabaseDataProvider
virtual ~CXTPCalendarDatabaseDataProvider()
Default Destructor.
CXTPCalendarDatabaseDataProvider::Save
virtual BOOL Save()
This method saves data to the database.
CXTPCalendarDatabaseDataProvider::Close
virtual void Close()
Call this member function to close the connection to a data source.
CXTPCalendarDatabaseDataProvider::Create
virtual BOOL Create()
Call this member function to create an empty database.
CXTPCalendarDatabaseDataProvider::DoRemoveAllEvents
virtual void DoRemoveAllEvents()
Remove all events from the database.
CXTPCalendarDatabaseDataProvider::DoRetrieveDayEvents
virtual CXTPCalendarEventsPtr DoRetrieveDayEvents(COleDateTime dtDay)
Retrieve day events for a specified day.
CXTPCalendarDatabaseDataProvider::Open
virtual BOOL Open()
Call this member function to initialize a newly constructed Data object.
CXTPCalendarDatabaseDataProvider::OpenEx
virtual BOOL OpenEx(LPDISPATCH pdispADOConnection)
Call this member function to initialize a data provider using an existing ADO Connection object.
CXTPCalendarDatabaseDataProvider::DoGetAllEvents_raw
virtual CXTPCalendarEventsPtr DoGetAllEvents_raw()
This method implements Getting all events from the database without generating recurrence occurrences...
CXTPCalendarEvent
This class represents the data of a single Event used in the Calendar control.
Definition XTPCalendarEvent.h:77
CXTPCalendarRecurrencePattern
This class represents a recurrence pattern and stores data to build a schedule for recurrence events.
Definition XTPCalendarRecurrencePattern.h:398
CXTPCalendarSchedule
Calendar Schedule is a characteristic of the Calendar Event, which describes a belonging of the Event...
Definition XTPCalendarResource.h:51
CXTPCalendarSchedules
This class represents a simple array collection of CXTPCalendarSchedule objects.
Definition XTPCalendarResource.h:175
XTP_CALENDAR_RECURRENCE_OPTIONS
This structure defines a set of Recurrence Pattern options and is used by a CXTPRecurrencePattern to ...
Definition XTPCalendarRecurrencePattern.h:239


CXTPSkinObjectDateTime Member List

This is the complete list of members for CXTPSkinObjectDateTime, including all inherited members.

CXTPSkinObject() | CXTPSkinObject | protected
CXTPSkinObjectComboBox() | CXTPSkinObjectComboBox |
CXTPSkinObjectDateTime() | CXTPSkinObjectDateTime |
CXTPSkinObjectFrame() | CXTPSkinObjectFrame |
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBorders() const | CXTPSkinObjectFrame |
GetButtonRect() | CXTPSkinObjectDateTime |
GetCaptionButtons() | CXTPSkinObjectFrame |
GetClassName() const | CXTPSkinObject |
GetClientBrush(CDC *pDC) | CXTPSkinObjectFrame | virtual
GetColor(int nIndex) const | CXTPSkinObject |
GetMetrics() const | CXTPSkinObject |
GetSkinClass() const | CXTPSkinObject |
GetSkinManager() const | CXTPSkinObject |
IsActive() const | CXTPSkinObjectFrame |
m_arrButtons | CXTPSkinObjectFrame | protected
m_bActive | CXTPSkinObjectFrame | protected
m_bActiveX | CXTPSkinObject | protected
m_bLockFrameDraw | CXTPSkinObjectFrame |
m_bMDIClient | CXTPSkinObjectFrame | protected
m_bRegionChanged | CXTPSkinObjectFrame | protected
m_bWindowsForms | CXTPSkinObject | protected
m_dwDialogTexture | CXTPSkinObjectFrame |
m_dwExStyle | CXTPSkinObjectFrame | protected
m_dwStyle | CXTPSkinObjectFrame | protected
m_pButtonHot | CXTPSkinObjectFrame | protected
m_pButtonPressed | CXTPSkinObjectFrame | protected
m_pManager | CXTPSkinObject | protected
m_pOldWndProc | CXTPSkinObject | protected
m_pSBTrack | CXTPSkinObjectFrame | protected
m_rcBorders | CXTPSkinObjectFrame | protected
m_spi | CXTPSkinObjectFrame | protected
m_strClassName | CXTPSkinObject | protected
m_szFrameRegion | CXTPSkinObjectFrame | protected
OnDraw(CDC *pDC) | CXTPSkinObjectComboBox | virtual
OnHookAttached(LPCREATESTRUCT lpcs, BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnHookDetached(BOOL bAuto) | CXTPSkinObjectFrame | protectedvirtual
OnSkinChanged(BOOL bPrevState, BOOL bNewState) | CXTPSkinObjectDateTime | protectedvirtual
RedrawScrollBar(int nBar) | CXTPSkinObjectFrame |
RefreshMetrics() | CXTPSkinObjectDateTime | virtual
~CXTPSkinObject() | CXTPSkinObject | protected
~CXTPSkinObjectComboBox() | CXTPSkinObjectComboBox | virtual
~CXTPSkinObjectFrame() | CXTPSkinObjectFrame | virtual


CXTPCalendarCaptionBarOffice2003Theme Member List

This is the complete list of members for CXTPCalendarCaptionBarOffice2003Theme, including all inherited members.

CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2000Theme |
CXTPCalendarCaptionBarOffice2003Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOffice2003Theme |
CXTPCalendarCaptionBarOfficeXPTheme(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarOfficeXPTheme |
CXTPCalendarCaptionBarPaintManager(CXTPCalendarCaptionBarTheme *pTheme=NULL) | CXTPCalendarCaptionBarPaintManager |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetPaintTheme() const | CXTPCalendarCaptionBarPaintManager | virtual
m_clrBorders | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollDateBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrScrollTriangleColor | CXTPCalendarCaptionBarPaintManager | protected
m_clrSwitchViewBarBk | CXTPCalendarCaptionBarPaintManager | protected
m_clrTextColor | CXTPCalendarCaptionBarPaintManager | protected
m_fntTextFont | CXTPCalendarCaptionBarPaintManager | protected
m_pTheme | CXTPCalendarCaptionBarPaintManager | protected
RefreshMetrics() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarOffice2000Theme() | CXTPCalendarCaptionBarOffice2000Theme | virtual
~CXTPCalendarCaptionBarOffice2003Theme() | CXTPCalendarCaptionBarOffice2003Theme | virtual
~CXTPCalendarCaptionBarOfficeXPTheme() | CXTPCalendarCaptionBarOfficeXPTheme | virtual
~CXTPCalendarCaptionBarPaintManager() | CXTPCalendarCaptionBarPaintManager | virtual


CXTPScrollBase Member List

This is the complete list of members for CXTPScrollBase, including all inherited members.

CXTPScrollBase() | CXTPScrollBase |
GetCltColor(CDC *pDC) const | CXTPScrollBase |
GetParentWindow() const =0 | CXTPScrollBase | pure virtual
GetScrollBarPaintManager() const =0 | CXTPScrollBase | pure virtual
GetScrollBarPartRect(int nPart) const | CXTPScrollBase |
GetScrollBarPosInfo() | CXTPScrollBase |
GetScrollBarRect()=0 | CXTPScrollBase | pure virtual
GetScrollBarStyle() const | CXTPScrollBase |
GetScrollBarTrackInfo() const | CXTPScrollBase |
GetScrollInfo(SCROLLINFO *psi)=0 | CXTPScrollBase | pure virtual
GetTicks() const | CXTPScrollBase |
HitTestScrollBar(POINT pt) const | CXTPScrollBase |
IsScrollBarEnabled() const =0 | CXTPScrollBase | pure virtual
IsSlider() const | CXTPScrollBase |
m_bAnimation | CXTPScrollBase | protected
m_nTimerElapse | CXTPScrollBase | protected
m_pSBTrack | CXTPScrollBase | protected
m_pTicks | CXTPScrollBase | protected
m_scrollBarStyle | CXTPScrollBase | protected
m_spi | CXTPScrollBase | protected
PerformTrackInit(HWND hWnd, CPoint point, XTP_SCROLLBAR_POSINFO *pSBInfo, BOOL bDirect) | CXTPScrollBase |
RedrawScrollBar()=0 | CXTPScrollBase | pure virtual
SetScrollBarStyle(XTPScrollBarStyle scrollStyle) | CXTPScrollBase |
SetTicks(double *pTicks, int nCount) | CXTPScrollBase |
~CXTPScrollBase() | CXTPScrollBase | virtual


Toolkit Pro: XTPGridRows.h Source File

  • Source
  • GridControl
XTPGridRows.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDROWS_H__)
24# define __XTPGRIDROWS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPGridRow;
34class CXTPGridRecord;
35class CXTPGridRecordItem;
36class CXTPGridControl;
37class CXTPGridColumns;
38
45enum XTPGridSelectionChangeType
46{
47 xtpGridSelectionAdd,
48 xtpGridSelectionRemove,
49 xtpGridSelectionClear
50};
51
58struct XTP_NM_SELECTION_CHANGING
59{
60 NMHDR hdr;
61 CXTPGridRow* pRow;
63 XTPGridSelectionChangeType nType;
64};
65
71struct XTP_NM_GRIDSTATECHANGED
72{
73 NMHDR hdr;
74 int nBegin;
75 int nEnd;
76};
77
78class _XTP_EXT_CLASS CXTPGridScreenRows : public CArray<CXTPGridRow*, CXTPGridRow*>
79{
80public:
81 CXTPGridScreenRows();
82 ~CXTPGridScreenRows();
83
84public:
85 CXTPGridRow* HitTest(CPoint pt) const;
86 void Clear();
87};
88
89class _XTP_EXT_CLASS CXTPGridRowsArray : public CArray<CXTPGridRow*, CXTPGridRow*>
90{
91 friend class CXTPGridSection;
92
93public:
94 void ReserveSize(INT_PTR nNewSize, INT_PTR nGrowBy = -1);
95};
96
107class _XTP_EXT_CLASS CXTPGridRows : public CXTPHeapObjectT<CXTPCmdTarget, CXTPGridDataAllocator>
108{
109 void _swapIndexes(int& A, int& B);
110 void _clampIndexes(int& nOrig, const int& nMin, const int& nMax);
111
112public:
126 CXTPGridRows();
127
132 virtual ~CXTPGridRows();
133
141 virtual BOOL Contains(const CXTPGridRow* pRow) const;
142
156 virtual void Clear(BOOL bResetRow = TRUE);
157
173 int GetCount() const;
174
186 virtual CXTPGridRow* GetAt(int nIndex) const;
187
195 virtual CXTPGridScreenRows* GetScreenRows();
196
203 virtual int GetFocusedRowIndex() const;
204
211 virtual BOOL HasFocus() const;
212
218 virtual void SetFocusedRowIndex(int nRow);
219
226 virtual CXTPGridRow* GetFocusedRow();
227
257 virtual int Add(CXTPGridRow* pRow);
258
273 virtual void RemoveAt(int nIndex);
274
291 virtual void RemoveAt(int nStartIndex, int nCount);
292
301 virtual int RemoveRow(CXTPGridRow* pRow);
302
318 virtual void InsertAt(int nIndex, CXTPGridRow* pRow);
319
333 virtual CXTPGridRow* GetNext(CXTPGridRow* pRow, BOOL bSkipGroupFocus);
334
348 virtual CXTPGridRow* GetPrev(CXTPGridRow* pRow, BOOL bSkipGroupFocus);
349
356 virtual void SetVirtualMode(CXTPGridRow* pRow, int nCount);
357
368 virtual CXTPGridRow* Find(CXTPGridRecord* pRecord);
369
381 virtual CXTPGridRow* Find(CXTPGridRecord* pRecord, BOOL bRecursive);
382
393 virtual CXTPGridRow* FindInTree(CXTPGridRecord* pRecord);
394
406 virtual CXTPGridRow* FindInsertionPos(CXTPGridRow* pRow, BOOL& bInsertAfter);
407
413 virtual void RefreshChildIndices(BOOL bRunInChildren = TRUE);
414
420 void ClearMergeHeight();
421
434 virtual void SortEx(XTPGridRowsCompareFunc pCompareFunc);
435
446 virtual void Sort();
447
472 static int AFX_CDECL CompareRows(const CXTPGridRow** pRow1, const CXTPGridRow** pRow2);
473
498 static int AFX_CDECL CompareRows2(const CXTPGridRow** pRow1, const CXTPGridRow** pRow2);
499
528 virtual CXTPGridRecordItem* FindRecordItemByRows(int nStartIndex, int nEndIndex,
529 int nStartColumn, int nEndColumn,
530 int nRecordIndex, int nItem, LPCTSTR pcszText,
531 int nFlags);
532
534 virtual void ReserveSize(INT_PTR nNewSize, INT_PTR nGrowBy = -1);
535 virtual void SetSize(INT_PTR nNewSize, INT_PTR nGrowBy = -1);
536 virtual void SetAt(INT_PTR nIndex, CXTPGridRow* pRow);
538protected:
541 CXTPGridRowsArray m_arrRows;
544 CXTPGridRow* m_pVirtualRow;
545 CXTPGridScreenRows* m_pScreenRows;
546 int m_nVirtualRowsCount;
548 int m_nFocusedRow;
550# ifdef _XTP_ACTIVEX
552 DECLARE_DISPATCH_MAP()
553 DECLARE_INTERFACE_MAP()
554
555 DECLARE_OLETYPELIB_EX(CXTPGridRows);
556
557 afx_msg LPDISPATCH OleGetItem(long nIndex);
558 int OleGetItemCount();
559 DECLARE_ENUM_VARIANT(CXTPGridRows)
560
561 afx_msg LPDISPATCH OleFindRow(LPDISPATCH pRecordDisp);
562 afx_msg LPDISPATCH OleFindRowInTree(LPDISPATCH pRecordDisp);
563 afx_msg LPDISPATCH OleFindRecordItemByRows(int nStartIndex, int nEndIndex, int nStartColumn,
564 int nEndColumn, int nRecord, int nItem,
565 LPCTSTR pcszText, int nFlags);
566 enum
567 {
568 dispidCount = 1L,
569 };
570
572# endif
573
574 friend class CXTPGridControl;
575 friend class CXTPTrackControl;
576 friend class CXTPGridNavigator;
577 friend class CXTPGridSection;
578};
580# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
581#endif //#if !defined(__XTPGRIDROWS_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridRowsCompareFunc
int(AFX_CDECL * XTPGridRowsCompareFunc)(const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Defines a function pointer for comparing events.
Definition XTPGridDefines.h:1420
XTPGridSelectionChangeType
XTPGridSelectionChangeType
This enumeration defines the selection change action.
Definition XTPGridRows.h:46
xtpGridSelectionAdd
@ xtpGridSelectionAdd
Row will be added to the selected rows collection.
Definition XTPGridRows.h:47
xtpGridSelectionClear
@ xtpGridSelectionClear
The selected rows collection will be cleared.
Definition XTPGridRows.h:49
xtpGridSelectionRemove
@ xtpGridSelectionRemove
Row will be removed from the selected rows collection.
Definition XTPGridRows.h:48
CXTPGridColumns
This class is a collection of grid column objects.
Definition XTPGridColumns.h:54
CXTPGridControl
The CXTPGridControl class provides an implementation of the Grid control.
Definition XTPGridControl.h:479
CXTPGridNavigator
Utility class, handles Grid control item navigation.
Definition XTPGridNavigator.h:45
CXTPGridRecord
CXTPGridRecord represents a collection of CXTPGridRecordItem objects or objects of classes that are c...
Definition XTPGridRecord.h:59
CXTPGridRecordItem
Class for working with single list cell.
Definition XTPGridRecordItem.h:600
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPGridRows
This class represents a rows collection class.
Definition XTPGridRows.h:108
CXTPGridRows::RefreshChildIndices
virtual void RefreshChildIndices(BOOL bRunInChildren=TRUE)
Recalculates the child indices of all rows in the collection.
CXTPGridRows::GetNext
virtual CXTPGridRow * GetNext(CXTPGridRow *pRow, BOOL bSkipGroupFocus)
Gets the next row in the list.
CXTPGridRows::GetCount
int GetCount() const
Gets the number of row elements in this collection.
CXTPGridRows::InsertAt
virtual void InsertAt(int nIndex, CXTPGridRow *pRow)
Inserts a specified row at a specified index in this collection.
CXTPGridRows::Find
virtual CXTPGridRow * Find(CXTPGridRecord *pRecord, BOOL bRecursive)
Retrieves the row associated with a specified record.
CXTPGridRows::FindInsertionPos
virtual CXTPGridRow * FindInsertionPos(CXTPGridRow *pRow, BOOL &bInsertAfter)
Searches for a position to insert a specified row at.
CXTPGridRows::HasFocus
virtual BOOL HasFocus() const
Determines if a row in this collection currently has focus.
CXTPGridRows::~CXTPGridRows
virtual ~CXTPGridRows()
Destroys a CXTPGridRows object, handles cleanup and deallocation.
CXTPGridRows::GetScreenRows
virtual CXTPGridScreenRows * GetScreenRows()
Gets the currently displayed rows of this collection.
CXTPGridRows::CompareRows2
static int AFX_CDECL CompareRows2(const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Compares two rows using groups and sort orders of the Grid control.
CXTPGridRows::Sort
virtual void Sort()
Sorts rows in the collection.
CXTPGridRows::m_pVirtualRow
CXTPGridRow * m_pVirtualRow
Virtual row.
Definition XTPGridRows.h:544
CXTPGridRows::SetVirtualMode
virtual void SetVirtualMode(CXTPGridRow *pRow, int nCount)
Call this method to set virtual mode with nCount rows.
CXTPGridRows::m_nFocusedRow
int m_nFocusedRow
Current focused row index.
Definition XTPGridRows.h:548
CXTPGridRows::RemoveRow
virtual int RemoveRow(CXTPGridRow *pRow)
Removes a specified row from this collection.
CXTPGridRows::FindInTree
virtual CXTPGridRow * FindInTree(CXTPGridRecord *pRecord)
Retrieves the row associated with a specified record.
CXTPGridRows::Clear
virtual void Clear(BOOL bResetRow=TRUE)
Removes all the elements from this collection.
CXTPGridRows::CompareRows
static int AFX_CDECL CompareRows(const CXTPGridRow **pRow1, const CXTPGridRow **pRow2)
Compares two rows using groups and sort orders of the Grid control.
CXTPGridRows::Contains
virtual BOOL Contains(const CXTPGridRow *pRow) const
Determines if this row collection contains a specified row.
CXTPGridRows::RemoveAt
virtual void RemoveAt(int nStartIndex, int nCount)
Removes a specified row from this collection by its index.
CXTPGridRows::SortEx
virtual void SortEx(XTPGridRowsCompareFunc pCompareFunc)
Sorts rows in the collection.
CXTPGridRows::CXTPGridRows
CXTPGridRows()
Constructs an empty CXTPGridRow pointer array.
CXTPGridRows::FindRecordItemByRows
virtual CXTPGridRecordItem * FindRecordItemByRows(int nStartIndex, int nEndIndex, int nStartColumn, int nEndColumn, int nRecordIndex, int nItem, LPCTSTR pcszText, int nFlags)
Finds a record item by rows.
CXTPGridRows::GetAt
virtual CXTPGridRow * GetAt(int nIndex) const
Gets the row element at a specified numeric index in this collection.
CXTPGridRows::Add
virtual int Add(CXTPGridRow *pRow)
Adds a new row element to the end of this collection.
CXTPGridRows::SetFocusedRowIndex
virtual void SetFocusedRowIndex(int nRow)
Sets the index of the currently focused row.
CXTPGridRows::GetPrev
virtual CXTPGridRow * GetPrev(CXTPGridRow *pRow, BOOL bSkipGroupFocus)
Gets the previous row in the list.
CXTPGridRows::m_nVirtualRowsCount
int m_nVirtualRowsCount
Count of virtual rows.
Definition XTPGridRows.h:546
CXTPGridRows::GetFocusedRow
virtual CXTPGridRow * GetFocusedRow()
Gets the currently focused row in the Grid control's view.
CXTPGridRows::RemoveAt
virtual void RemoveAt(int nIndex)
Removes a specified row from this collection by its index.
CXTPGridRows::ClearMergeHeight
void ClearMergeHeight()
Resets the merge height for all rows (i.e.
CXTPGridRows::GetFocusedRowIndex
virtual int GetFocusedRowIndex() const
Gets the index of the currently focused row.
CXTPGridRows::Find
virtual CXTPGridRow * Find(CXTPGridRecord *pRecord)
Retrieves the row associated with a specified record.
CXTPGridRows::m_pScreenRows
CXTPGridScreenRows * m_pScreenRows
Rows currently presented on screen.
Definition XTPGridRows.h:545
CXTPGridSection
Represents a grid section.
Definition XTPGridSection.h:61
CXTPHeapObjectT
This template class used as a helper class to override new/delete operators and use custom heap alloc...
Definition XTPCustomHeap.h:335
CXTPTrackControl
This class represents a track control.
Definition XTPTrackControl.h:113
XTP_NM_GRIDSTATECHANGED
This structure contains information for use in processing an XTP_NM_GRID_STATECHANGED message.
Definition XTPGridRows.h:72
XTP_NM_GRIDSTATECHANGED::nEnd
int nEnd
Zero-based index of the last item in the range of items.
Definition XTPGridRows.h:75
XTP_NM_GRIDSTATECHANGED::nBegin
int nBegin
Zero-based index of the first item in the range of items.
Definition XTPGridRows.h:74
XTP_NM_GRIDSTATECHANGED::hdr
NMHDR hdr
Standard structure, containing information.
Definition XTPGridRows.h:73
XTP_NM_SELECTION_CHANGING
This struct defines data for an XTP_NM_GRID_SELCHANGING notification.
Definition XTPGridRows.h:59
XTP_NM_SELECTION_CHANGING::pRow
CXTPGridRow * pRow
Pointer to the row associated with the notification.
Definition XTPGridRows.h:61
XTP_NM_SELECTION_CHANGING::hdr
NMHDR hdr
Standard structure, containing information about a notification message.
Definition XTPGridRows.h:60
XTP_NM_SELECTION_CHANGING::nType
XTPGridSelectionChangeType nType
Selection change action.
Definition XTPGridRows.h:63


CXTPChart3dRotation Member List

This is the complete list of members for CXTPChart3dRotation, including all inherited members.

CXTPChart3dRotation() | CXTPChart3dRotation
CXTPChart3dRotation(const CXTPChart3dRotation &rhs) | CXTPChart3dRotation
CXTPChart3dRotation(double dYaw, double dPitch, double dRoll) | CXTPChart3dRotation
IsRotated() const | CXTPChart3dRotation
m_dPitch | CXTPChart3dRotation
m_dRoll | CXTPChart3dRotation
m_dYaw | CXTPChart3dRotation
operator=(const CXTPChart3dRotation &rhs) | CXTPChart3dRotation
SetFromString(LPCTSTR pString) | CXTPChart3dRotation


CXTPCheckListBox Member List

This is the complete list of members for CXTPCheckListBox, including all inherited members.

CalcMinimumItemHeight() | CXTPCheckListBox | protectedvirtual
CheckFromPoint(CPoint point, BOOL &bInCheck) | CXTPCheckListBox | protectedvirtual
Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID) | CXTPCheckListBox | virtual
CXTPCheckListBox(BOOL bListBox3D=FALSE) | CXTPCheckListBox |
CXTPListBox() | CXTPListBox |
Enable(int nIndex, BOOL bEnabled=TRUE) | CXTPCheckListBox |
GetBackColor() | CXTPListBox | virtual
GetCheck(int nIndex) | CXTPCheckListBox |
GetCheckStyle() | CXTPCheckListBox |
GetFontHeight() | CXTPCheckListBox | protectedvirtual
GetListStyle() const | CXTPListBox |
HasFocus() const | CXTPListBox |
Init() | CXTPCheckListBox | protectedvirtual
Initialize(bool bAutoFont=true) | CXTPListBox | virtual
InvalidateCheck(int nIndex) | CXTPCheckListBox | protectedvirtual
InvalidateItem(int nIndex) | CXTPCheckListBox | protectedvirtual
IsEnabled(int nIndex) | CXTPCheckListBox |
m_bLastItemDrawnThemed | CXTPCheckListBox | protected
m_checkListState | CXTPCheckListBox | protected
m_cyText | CXTPCheckListBox | protected
m_nHotItem | CXTPListBox |
m_nItemHeight | CXTPListBox |
m_nStyle | CXTPCheckListBox | protected
m_nTextPadding | CXTPListBox |
m_pTheme | CXTPListBox |
m_theme | CXTPListBox |
m_themeHelper | CXTPCheckListBox | protected
OnGetCheckPosition(CRect rectItem, CRect rectCheckBox) | CXTPCheckListBox | virtual
PreCompareItem(LPCOMPAREITEMSTRUCT lpCompareItemStruct) | CXTPCheckListBox | protectedvirtual
PreDeleteItem(LPDELETEITEMSTRUCT lpDeleteItemStruct) | CXTPCheckListBox | protectedvirtual
PreDrawItem(LPDRAWITEMSTRUCT lpDrawItemStruct) | CXTPCheckListBox | protectedvirtual
PreDrawItemNonThemed(CDC *pDC, DRAWITEMSTRUCT &drawItem, int nCheck, int cyItem) | CXTPCheckListBox | protected
PreDrawItemThemed(CDC *pDC, DRAWITEMSTRUCT &drawItem, int nCheck, int cyItem) | CXTPCheckListBox | protected
PreMeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPCheckListBox | protectedvirtual
RefreshMetrics() | CXTPListBox | virtual
SetCheck(int nIndex, int nCheck) | CXTPCheckListBox |
SetCheckStyle(UINT nStyle) | CXTPCheckListBox |
SetListStyle(XTPListBoxStyle style) | CXTPListBox |
SetSelectionCheck(int nCheck) | CXTPCheckListBox | protectedvirtual
SetTheme(XTPControlTheme nTheme) | CXTPListBox |
TryItemFromPoint(CPoint pt, BOOL &bOutside, int &nIndex) const | CXTPListBox | protected
~CXTPCheckListBox() | CXTPCheckListBox | virtual
~CXTPListBox() | CXTPListBox | virtual


Toolkit Pro: XTPEditThemeVisualStudio2012.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeVisualStudio2012.h
Go to the documentation of this file.
1
23#if !defined(__XTPEditThemeVisualStudio2012_H__)
24# define __XTPEditThemeVisualStudio2012_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeVisualStudio2012 : public CXTPEditThemeOfficeXP
38{
39public:
45 CXTPEditThemeVisualStudio2012(XTPControlTheme nTheme);
46
51 virtual ~CXTPEditThemeVisualStudio2012();
52
59 virtual void RefreshMetrics(CXTPEdit* pEdit);
60};
61
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
64#endif // __XTPEDITTHEMEOFFICE2013_H__
XTPControlTheme
XTPControlTheme
Enumeration used to determine the active theme style.
Definition XTPControlTheme.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38
CXTPEditThemeVisualStudio2012
CXTPEditThemeVisualStudio2012 is a class used to perform theme drawing tasks.
Definition XTPEditThemeVisualStudio2012.h:38
CXTPEditThemeVisualStudio2012::CXTPEditThemeVisualStudio2012
CXTPEditThemeVisualStudio2012(XTPControlTheme nTheme)
Constructs a CXTPEditThemeVisualStudio2012 object.
CXTPEditThemeVisualStudio2012::~CXTPEditThemeVisualStudio2012
virtual ~CXTPEditThemeVisualStudio2012()
Destructor, handles cleanup and deallocation.
CXTPEditThemeVisualStudio2012::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...


CXTPChart3dPieDeviceCommandEvents Member List

This is the complete list of members for CXTPChart3dPieDeviceCommandEvents, including all inherited members.

CXTPChart3dPieDeviceCommandEvents() | CXTPChart3dPieDeviceCommandEvents | protected
CXTPChartDeviceCommandEvents() | CXTPChartDeviceCommandEvents | protected
OnAfterExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnBeforeExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter) | CXTPChart3dPieDeviceCommandEvents | virtual
OnUnsubscribe(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommandEvents |
OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds) | CXTPChartDeviceCommandEvents | virtual


Toolkit Pro: XTPCommandBarsOffice2000Theme.h Source File

  • Source
  • CommandBars
  • Themes
XTPCommandBarsOffice2000Theme.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMMANDBARSOFFICE2000THEME_H__)
24# define __XTPCOMMANDBARSOFFICE2000THEME_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
40class _XTP_EXT_CLASS CXTPCommandBarsOffice2000Theme : public CXTPPaintManager
41{
43 DECLARE_DYNAMIC(CXTPCommandBarsOffice2000Theme)
45public:
50 CXTPCommandBarsOffice2000Theme();
51
56 virtual void RefreshMetrics();
57
64 virtual void FillCommandBarEntry(CDC* pDC, CXTPCommandBar* pBar);
65
78 virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled,
79 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
80 XTPBarPosition barPosition);
81
91 virtual CSize DrawCommandBarGripper(CDC* pDC, CXTPCommandBar* pBar, BOOL bDraw = TRUE);
92
103 virtual CSize DrawCommandBarSeparator(CDC* pDC, CXTPCommandBar* pBar, CXTPControl* pControl,
104 BOOL bDraw = TRUE);
105
113 virtual void AdjustExcludeRect(CRect& rc, CXTPControl* pControl, BOOL bVertical);
114
122 virtual CRect GetCommandBarBorders(CXTPCommandBar* pBar);
123
136 virtual CSize DrawListBoxControl(CDC* pDC, CXTPControl* pButton, CRect rc, BOOL bSelected,
137 BOOL bDraw, CXTPCommandBars* pCommandBars = 0);
138
154 virtual CSize DrawSpecialControl(CDC* pDC, XTPSpecialControl controlType, CXTPControl* pButton,
155 CXTPCommandBar* pBar, BOOL bDraw, LPVOID lpParam);
156
167 virtual CSize DrawTearOffGripper(CDC* pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw);
168
176 virtual void DrawPopupResizeGripper(CDC* pDC, CRect rcGripper, int nFlags);
177
178protected:
188 virtual CSize DrawControlPopupParent(CDC* pDC, CXTPControl* pButton, BOOL bDraw);
189
197 virtual void DrawSplitButtonFrame(CDC* pDC, CXTPControl* pButton, CRect rcButton);
198
212 virtual void DrawRectangle(CDC* pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled,
213 BOOL bChecked, BOOL bPopuped, XTPBarType barType,
214 XTPBarPosition barPosition);
215
224 virtual BOOL DrawRectangle(CDC* pDC, CXTPControl* pButton);
225
240 virtual void DrawImage(CDC* pDC, CPoint pt, CSize sz, CXTPImageManagerIcon* pImage,
241 BOOL bSelected, BOOL bPressed, BOOL bEnabled = TRUE,
242 BOOL bChecked = FALSE, BOOL bPopuped = FALSE, BOOL bToolBarImage = TRUE);
243
253 virtual CSize DrawControlComboBox(CDC* pDC, CXTPControlComboBox* pComboBox, BOOL bDraw);
254
264 virtual CSize DrawControlEdit(CDC* pDC, CXTPControlEdit* pEdit, BOOL bDraw);
265
275 virtual CSize DrawDialogBarGripper(CDC* pDC, CXTPDialogBar* pBar, BOOL bDraw);
276
285 virtual void DrawControlEditFrame(CDC* pDC, CRect rc, BOOL bEnabled, BOOL bSelected);
286
296 virtual void DrawControlComboBoxButton(CDC* pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected,
297 BOOL bDropped);
298
305 virtual void DrawControlEditSpin(CDC* pDC, CXTPControlEdit* pControlEdit);
306
313 virtual XTPPaintTheme BaseTheme()
314 {
315 return xtpThemeOffice2000;
316 }
317
318protected:
320 void DrawShadedRect(CDC* pDC, CRect& rect);
321 virtual CSize GetPopupBarImageSize(CXTPCommandBar* pBar);
324protected:
325 int m_nPopupBarText;
326};
327
328# define CXTPDefaultTheme CXTPCommandBarsOffice2000Theme
331# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
332#endif // !defined(__XTPCOMMANDBARSOFFICE2000THEME_H__)
XTPBarType
XTPBarType
Type of the command bar.
Definition XTPCommandBarsDefines.h:77
XTPBarPosition
XTPBarPosition
Position of the command bar.
Definition XTPCommandBarsDefines.h:52
XTPPaintTheme
XTPPaintTheme
Paint themes used by command bars.
Definition XTPCommandBarsDefines.h:233
xtpThemeOffice2000
@ xtpThemeOffice2000
Office 2000 theme.
Definition XTPCommandBarsDefines.h:235
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPSpecialControl
XTPSpecialControl
Special control with extended drawing.
Definition XTPPaintManager.h:80
CXTPCommandBar
CXTPCommandBar is a CWnd derived class.
Definition XTPCommandBar.h:66
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPCommandBarsOffice2000Theme
The CXTPCommandBarsOffice2000Theme class is used to enable an Office 2000 style theme for Command Bar...
Definition XTPCommandBarsOffice2000Theme.h:41
CXTPCommandBarsOffice2000Theme::DrawSpecialControl
virtual CSize DrawSpecialControl(CDC *pDC, XTPSpecialControl controlType, CXTPControl *pButton, CXTPCommandBar *pBar, BOOL bDraw, LPVOID lpParam)
This method is called to draw the specified controls.
CXTPCommandBarsOffice2000Theme::DrawControlComboBoxButton
virtual void DrawControlComboBoxButton(CDC *pDC, CRect rcBtn, BOOL bEnabled, BOOL bSelected, BOOL bDropped)
This method is called to draw the button of a combobox control.
CXTPCommandBarsOffice2000Theme::DrawCommandBarGripper
virtual CSize DrawCommandBarGripper(CDC *pDC, CXTPCommandBar *pBar, BOOL bDraw=TRUE)
This method is called to draw the command bar's gripper.
CXTPCommandBarsOffice2000Theme::GetCommandBarBorders
virtual CRect GetCommandBarBorders(CXTPCommandBar *pBar)
This method is called to retrieve the command bar's borders.
CXTPCommandBarsOffice2000Theme::DrawControlComboBox
virtual CSize DrawControlComboBox(CDC *pDC, CXTPControlComboBox *pComboBox, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsOffice2000Theme::DrawControlEditSpin
virtual void DrawControlEditSpin(CDC *pDC, CXTPControlEdit *pControlEdit)
This method draws edit control spin buttons.
CXTPCommandBarsOffice2000Theme::DrawListBoxControl
virtual CSize DrawListBoxControl(CDC *pDC, CXTPControl *pButton, CRect rc, BOOL bSelected, BOOL bDraw, CXTPCommandBars *pCommandBars=0)
This method is called to draw the control placed on the ListBox.
CXTPCommandBarsOffice2000Theme::GetRectangleTextColor
virtual COLORREF GetRectangleTextColor(BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method retrieves a buttons text color.
CXTPCommandBarsOffice2000Theme::DrawControlPopupParent
virtual CSize DrawControlPopupParent(CDC *pDC, CXTPControl *pButton, BOOL bDraw)
This method is called to draw the control placed on the pop-up bar.
CXTPCommandBarsOffice2000Theme::DrawRectangle
virtual BOOL DrawRectangle(CDC *pDC, CXTPControl *pButton)
This method is called to fill the control's face.
CXTPCommandBarsOffice2000Theme::AdjustExcludeRect
virtual void AdjustExcludeRect(CRect &rc, CXTPControl *pControl, BOOL bVertical)
This method is called to determine the offset of a pop-up bar.
CXTPCommandBarsOffice2000Theme::m_nPopupBarText
int m_nPopupBarText
Pop-up bar text index.
Definition XTPCommandBarsOffice2000Theme.h:325
CXTPCommandBarsOffice2000Theme::DrawSplitButtonFrame
virtual void DrawSplitButtonFrame(CDC *pDC, CXTPControl *pButton, CRect rcButton)
Draws split button frame.
CXTPCommandBarsOffice2000Theme::DrawTearOffGripper
virtual CSize DrawTearOffGripper(CDC *pDC, CRect rcGripper, BOOL bSelected, BOOL bDraw)
This method is called to draw a tear-off gripper of a pop-up bar.
CXTPCommandBarsOffice2000Theme::DrawControlEdit
virtual CSize DrawControlEdit(CDC *pDC, CXTPControlEdit *pEdit, BOOL bDraw)
This method is called to draw the control.
CXTPCommandBarsOffice2000Theme::FillCommandBarEntry
virtual void FillCommandBarEntry(CDC *pDC, CXTPCommandBar *pBar)
This method is called to fill the command bar's face.
CXTPCommandBarsOffice2000Theme::DrawPopupResizeGripper
virtual void DrawPopupResizeGripper(CDC *pDC, CRect rcGripper, int nFlags)
This method is called to draw the pop-up bar resize gripper.
CXTPCommandBarsOffice2000Theme::DrawImage
virtual void DrawImage(CDC *pDC, CPoint pt, CSize sz, CXTPImageManagerIcon *pImage, BOOL bSelected, BOOL bPressed, BOOL bEnabled=TRUE, BOOL bChecked=FALSE, BOOL bPopuped=FALSE, BOOL bToolBarImage=TRUE)
This method is called to draw the image of the control.
CXTPCommandBarsOffice2000Theme::CXTPCommandBarsOffice2000Theme
CXTPCommandBarsOffice2000Theme()
Constructs a CXTPCommandBarsOffice2000Theme object.
CXTPCommandBarsOffice2000Theme::DrawControlEditFrame
virtual void DrawControlEditFrame(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bSelected)
This method is called to draw the frame of an edit control.
CXTPCommandBarsOffice2000Theme::BaseTheme
virtual XTPPaintTheme BaseTheme()
Retrieves the base theme of the manager.
Definition XTPCommandBarsOffice2000Theme.h:313
CXTPCommandBarsOffice2000Theme::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the manager.
CXTPCommandBarsOffice2000Theme::DrawRectangle
virtual void DrawRectangle(CDC *pDC, CRect rc, BOOL bSelected, BOOL bPressed, BOOL bEnabled, BOOL bChecked, BOOL bPopuped, XTPBarType barType, XTPBarPosition barPosition)
This method is called to fill the control's face.
CXTPCommandBarsOffice2000Theme::DrawCommandBarSeparator
virtual CSize DrawCommandBarSeparator(CDC *pDC, CXTPCommandBar *pBar, CXTPControl *pControl, BOOL bDraw=TRUE)
This method is called to draw a command bar's separator.
CXTPCommandBarsOffice2000Theme::DrawDialogBarGripper
virtual CSize DrawDialogBarGripper(CDC *pDC, CXTPDialogBar *pBar, BOOL bDraw)
Call this member to draw the gripper of a dialog bar.
CXTPControlComboBox
CXTPControlComboBox is a CXTPControl derived class.
Definition XTPControlComboBox.h:381
CXTPControlEdit
CXTPControlEdit is a CXTPControl derived class.
Definition XTPControlEdit.h:274
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPDialogBar
CXTPDialogBar is a CXTPToolBar derived class.
Definition XTPDialogBar.h:41
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPPaintManager
Paint manager of the command bars.
Definition XTPPaintManager.h:199


Toolkit Pro: XTPControlButton.h Source File

  • Source
  • CommandBars
XTPControlButton.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLBUTTON_H__)
24# define __XTPCONTROLBUTTON_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPControlButton : public CXTPControl
39{
40public:
45 CXTPControlButton();
46
51 virtual ~CXTPControlButton();
52
65 void SetStyleEx(XTPButtonStyle buttonStyle);
66
73 XTPButtonStyle GetStyleEx() const;
74
75public:
81 void DoPropExchange(CXTPPropExchange* pPX);
82
83protected:
90 virtual void OnClick(BOOL bKeyboard = FALSE, CPoint pt = CPoint(0, 0));
91
97 virtual void OnLButtonUp(CPoint point);
98
105 virtual void Copy(CXTPControl* pControl, BOOL bRecursive = FALSE);
106
107 XTPButtonStyle m_buttonStyleEx;
109private:
110# ifdef _XTP_COMMANDBARS_ACTIVEX
113 DECLARE_DISPATCH_MAP()
114 DECLARE_INTERFACE_MAP()
115
116 DECLARE_OLETYPELIB_EX(CXTPControlButton)
117
118 afx_msg XTPButtonStyle OleGetStyleEx();
119 afx_msg void OleSetStyleEx(XTPButtonStyle nStyle);
120
121 enum
122 {
123 dispidStyle = 50L,
124 };
125
127# endif
128
129 DECLARE_XTP_CONTROL(CXTPControlButton)
130};
131
133
134# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
135#endif // #if !defined(__XTPCONTROLBUTTON_H__)
XTPButtonStyle
XTPButtonStyle
Button's styles.
Definition XTPCommandBarsDefines.h:197
DECLARE_XTP_CONTROL
#define DECLARE_XTP_CONTROL(class_name)
This macro generates the C++ header code necessary for a CXTPControl-derived class that can be serial...
Definition XTPCommandBarsDefines.h:1169
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPControlButton
CXTPControlButton is a CXTPControl derived class.
Definition XTPControlButton.h:39
CXTPControlButton::DoPropExchange
void DoPropExchange(CXTPPropExchange *pPX)
Either reads this object from or writes this object to an archive.
CXTPControlButton::SetStyleEx
void SetStyleEx(XTPButtonStyle buttonStyle)
Call this member to set the style of the button containing vector icon.
CXTPControlButton::CXTPControlButton
CXTPControlButton()
Constructs a CXTPControlButton object.
CXTPControlButton::OnClick
virtual void OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0))
This method is called when the user clicks the control.
CXTPControlButton::GetStyleEx
XTPButtonStyle GetStyleEx() const
Call this member to get the button's style containing vector icon.
CXTPControlButton::~CXTPControlButton
virtual ~CXTPControlButton()
Destroys a CXTPControlButton object, handles cleanup and deallocation.
CXTPControlButton::m_buttonStyleEx
XTPButtonStyle m_buttonStyleEx
User-defined style of button containing vector icon.
Definition XTPControlButton.h:107
CXTPControlButton::OnLButtonUp
virtual void OnLButtonUp(CPoint point)
This member is called when the user releases the left mouse button.
CXTPControlButton::Copy
virtual void Copy(CXTPControl *pControl, BOOL bRecursive=FALSE)
This method is called to copy the control.
CXTPControl
CXTPControl is a CXTPCmdTarget derived class.
Definition XTPControl.h:841
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72


CXTPChartContentAppearance Member List

This is the complete list of members for CXTPChartContentAppearance, including all inherited members.

ApplyToDeviceContext(CXTPChartDeviceContext *pDC) | CXTPChartElementAppearance | virtual
BackgroundColor | CXTPChartContentAppearance |
BorderColor | CXTPChartContentAppearance |
CXTPChartContentAppearance(CXTPChartElement *pOwner) | CXTPChartContentAppearance |
CXTPChartElement() | CXTPChartElement |
CXTPChartElementAppearance(CXTPChartElement *pOwner) | CXTPChartElementAppearance |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
DoPropExchange(CXTPPropExchange *pPX) | CXTPChartContentAppearance | virtual
GetAppearance() const | CXTPChartElement |
GetContent() const | CXTPChartElement |
GetLegendAppearance() const | CXTPChartContentAppearance |
GetOwner() const | CXTPChartElement |
GetTitleAppearance() const | CXTPChartContentAppearance |
Is3D() const | CXTPChartObject |
m_pLegendAppearance | CXTPChartContentAppearance | protected
m_pTitleAppearance | CXTPChartContentAppearance | protected
OnChartChanged(XTPChartUpdateOptions updateOptions=xtpChartUpdateView) | CXTPChartElement | virtual
Release() | CXTPChartElement | virtual
~CXTPChartContentAppearance() | CXTPChartContentAppearance | virtual
~CXTPChartElement() | CXTPChartElement | virtual
~CXTPChartElementAppearance() | CXTPChartElementAppearance | virtual


CXTPChartHitTestElementCommand Member List

This is the complete list of members for CXTPChartHitTestElementCommand, including all inherited members.

AddChildCommand(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommand |
AfterExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ApplySeriesStyle(CXTPChartSeriesStyle *pStyle) | CXTPChartDeviceCommand | virtual
BeforeExecute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
BindView(CXTPChartElementView *pView) | CXTPChartDeviceCommand |
Commit() | CXTPChartDeviceCommand |
CXTPChartDeviceCommand() | CXTPChartDeviceCommand |
CXTPChartHitTestElementCommand(CXTPChartElement *pElement) | CXTPChartHitTestElementCommand |
CXTPChartHitTestElementCommand(CXTPChartElement *pElement, const CRect &rcBounds) | CXTPChartHitTestElementCommand |
CXTPChartHitTestElementCommand(CXTPChartElement *pElement, const CXTPChartRectF &rcBounds) | CXTPChartHitTestElementCommand |
CXTPChartObject() | CXTPChartObject | protected
CXTPChartObject(BOOL bIs3D) | CXTPChartObject | protected
CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected
Execute(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
ExecuteOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
GetBoundView() const | CXTPChartDeviceCommand |
GetChildCommand(int nIndex) const | CXTPChartDeviceCommand |
GetChildCommandCount() const | CXTPChartDeviceCommand |
GetCurrentDC() const | CXTPChartDeviceCommand |
GetPassNumber() const | CXTPChartDeviceCommand |
HitTest(CPoint point, CXTPChartElement *pParent) const | CXTPChartHitTestElementCommand | virtual
Is3D() const | CXTPChartObject |
IsCommitted() const | CXTPChartDeviceCommand |
IsEnabled() const | CXTPChartDeviceCommand | virtual
m_arrChildren | CXTPChartDeviceCommand | protected
m_pElement | CXTPChartHitTestElementCommand | protected
m_rcBounds | CXTPChartHitTestElementCommand | protected
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Notify(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamic(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyDynamicReversed(void(T::*method)(O *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *)) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1), A1 arg1) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2), A1 arg1, A2 arg2) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
NotifyReversed(void(CXTPChartDeviceCommandEvents::*method)(CXTPChartDeviceCommand *, A1, A2, A3), A1 arg1, A2 arg2, A3 arg3) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | inline
Prepare(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
PrepareOverride(CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommand | virtual
SetEnabled(BOOL bEnabled=TRUE) | CXTPChartDeviceCommand |
Subscribe(CXTPChartDeviceCommandEvents *pObserver, CXTPSubscriptionList< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > *pSubcriptionList=NULL) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
Unsubscribe(CXTPChartDeviceCommandEvents *pObserver) | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > |
~CXTPChartDeviceCommand() | CXTPChartDeviceCommand | virtual
~CXTPObservable() | CXTPObservable< CXTPChartDeviceCommand, CXTPChartDeviceCommandEvents > | protected


Toolkit Pro: XTPChartTrendline.h Source File

  • Source
  • Chart
XTPChartTrendline.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTTRENDLINE_H__)
24# define __XTPCHARTTRENDLINE_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
36enum XTPChartSeriesTrendlineType
37{
38 xtpChartSeriesTrendlineTypeNone,
39 xtpChartSeriesTrendlineTypeLinear,
40 xtpChartSeriesTrendlineTypeMovingAverageSimple,
42 xtpChartSeriesTrendlineTypeMinimum,
43 xtpChartSeriesTrendlineTypeMaximum,
44};
45
46class _XTP_EXT_CLASS CXTPChartSeriesTrendline : public CXTPChartSeries
47{
49 DECLARE_DYNAMIC(CXTPChartSeriesTrendline)
51public:
56 CXTPChartSeriesTrendline();
57
62 virtual ~CXTPChartSeriesTrendline();
63
64public:
65 CXTPChartSeries* GetSource() const;
66
67 void SetSource(CXTPChartSeries* pSeries);
68
69 XTPChartSeriesTrendlineType GetType() const;
70
71 void SetType(XTPChartSeriesTrendlineType type);
72
73 int GetPeriod() const;
74
75 void SetPeriod(int nPeriod);
76
77protected:
78 void Release();
79
80protected:
81 XTPChartSeriesTrendlineType m_type;
82 int m_nPeriod;
83
84 CXTPChartSeries* m_pSource;
85
86# ifdef _XTP_ACTIVEX
87public:
89 DECLARE_DISPATCH_MAP()
90 DECLARE_INTERFACE_MAP()
91
92 DECLARE_OLETYPELIB_EX(CXTPChartSeriesTrendline);
93 DECLARE_OLECREATE_EX(CXTPChartSeriesTrendline)
94
95 afx_msg LPDISPATCH OleGetSeries();
96
97 afx_msg LPDISPATCH OleGetSource();
98 afx_msg void OleSetSource(LPDISPATCH lpSeries);
99
101# endif
102};
103
104AFX_INLINE CXTPChartSeries* CXTPChartSeriesTrendline::GetSource() const
105{
106 return m_pSource;
107}
108
109AFX_INLINE XTPChartSeriesTrendlineType CXTPChartSeriesTrendline::GetType() const
110{
111 return m_type;
112}
113
114AFX_INLINE int CXTPChartSeriesTrendline::GetPeriod() const
115{
116 return m_nPeriod;
117}
118
119AFX_INLINE void CXTPChartSeriesTrendline::SetPeriod(int nPeriod)
120{
121 m_nPeriod = nPeriod;
122}
123
124class _XTP_EXT_CLASS CXTPChartSeriesTrendlinePointCollection
125 : public CXTPChartSeriesVirtualPointCollection
126{
128 DECLARE_DYNAMIC(CXTPChartSeriesTrendlinePointCollection)
130public:
135 CXTPChartSeriesTrendlinePointCollection();
136
141 virtual ~CXTPChartSeriesTrendlinePointCollection();
142
143public:
144 virtual CXTPChartSeriesPoint* GetAt(int nIndex) const;
145
146 virtual int GetCount() const;
147
148protected:
149 CXTPChartSeriesTrendline* m_pTrendline;
150
151 friend class CXTPChartSeriesTrendline;
152};
154# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
155#endif //#if !defined(__XTPCHARTTRENDLINE_H__)
XTPChartSeriesTrendlineType
XTPChartSeriesTrendlineType
Defines a trendline series type.
Definition XTPChartTrendline.h:37
xtpChartSeriesTrendlineTypeNone
@ xtpChartSeriesTrendlineTypeNone
No trendline.
Definition XTPChartTrendline.h:38
xtpChartSeriesTrendlineTypeMovingAverageSimple
@ xtpChartSeriesTrendlineTypeMovingAverageSimple
Specifies a simple moving average trendline.
Definition XTPChartTrendline.h:40
xtpChartSeriesTrendlineTypeLinear
@ xtpChartSeriesTrendlineTypeLinear
Specifies a linear trendline.
Definition XTPChartTrendline.h:39
xtpChartSeriesTrendlineTypeMinimum
@ xtpChartSeriesTrendlineTypeMinimum
Specifies a minimum value trendline.
Definition XTPChartTrendline.h:42
xtpChartSeriesTrendlineTypeMaximum
@ xtpChartSeriesTrendlineTypeMaximum
Specifies a maximum value trendline.
Definition XTPChartTrendline.h:43
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeries::Release
void Release()
Call this function to decrease the usage count of the object.
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43


Toolkit Pro: XTPScrollBarCtrl.h Source File

  • Source
  • Common
  • ScrollBar
XTPScrollBarCtrl.h
Go to the documentation of this file.
1
23#if !defined(__XTPSCROLLBARCTRL_H__)
24# define __XTPSCROLLBARCTRL_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPScrollBarContainerImpl;
34
45class _XTP_EXT_CLASS CXTPScrollBarCtrl
46 : public CScrollBar
47 , public CXTPScrollBase
48{
49 DECLARE_DYNCREATE(CXTPScrollBarCtrl);
50
51 friend class CXTPScrollBarContainerImpl;
52
53public:
58 CXTPScrollBarCtrl();
59
64 virtual ~CXTPScrollBarCtrl();
65
66public:
73 void SetTheme(XTPScrollBarTheme theme);
74
80 virtual void RefreshMetrics();
81
88 virtual CXTPScrollBarPaintManager* GetScrollBarPaintManager() const;
89
102 virtual void GetScrollInfo(SCROLLINFO* psi);
103
104protected:
110 void Init();
111
120 XTP_SCROLLBAR_TRACKINFO* GetScrollBarTrackInfo();
121
130 XTP_SCROLLBAR_POSINFO* GetScrollBarPosInfo();
131
133 CRect GetScrollBarRect();
134 BOOL IsScrollBarEnabled() const;
135 CWnd* GetParentWindow() const;
136 void DoScroll(int cmd, int pos);
137 void RedrawScrollBar();
138
141protected:
143 DECLARE_MESSAGE_MAP()
144
145 //{{AFX_VIRTUAL(CXTPScrollBarCtrl)
146 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
147 virtual void PreSubclassWindow();
148 //}}AFX_VIRTUAL
149
150 //{{AFX_MSG(CXTPScrollBarCtrl)
151 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
152 afx_msg void OnMouseLeave();
153 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
154 afx_msg void OnPaint();
155 afx_msg void OnDraw(CDC* pDC);
156 afx_msg void OnEnable(BOOL bEnable);
157 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
158 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
159 afx_msg LRESULT OnSetScrollInfo(WPARAM wParam, LPARAM lParam);
160 afx_msg LRESULT OnGetScrollInfo(WPARAM wParam, LPARAM lParam);
161 afx_msg void OnSetFocus(CWnd* pOldWnd);
162 afx_msg void OnContextMenu(CWnd* pWnd, CPoint pos);
163 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
164 afx_msg void OnSysColorChange();
165 //}}AFX_MSG
168protected:
169 BOOL m_bPreSubclassInit;
170 CXTPScrollBarPaintManager* m_pPaintManager;
171};
173AFX_INLINE CXTPScrollBarPaintManager* CXTPScrollBarCtrl::GetScrollBarPaintManager() const
174{
175 return m_pPaintManager;
176}
177
178AFX_INLINE XTP_SCROLLBAR_TRACKINFO* CXTPScrollBarCtrl::GetScrollBarTrackInfo()
179{
180 return m_pSBTrack;
181}
182
183AFX_INLINE XTP_SCROLLBAR_POSINFO* CXTPScrollBarCtrl::GetScrollBarPosInfo()
184{
185 return &m_spi;
186}
188# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
190#endif // !defined(__XTPSCROLLBARCTRL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPScrollBarTheme
XTPScrollBarTheme
Scrollbar theme identifier enum.
Definition XTPScrollBase.h:87
CXTPScrollBarCtrl
Scrollbar control.
Definition XTPScrollBarCtrl.h:48
CXTPScrollBarCtrl::Init
void Init()
This member function is called from OnInitDialog or OnInitialUpdate to initialize the control.
CXTPScrollBarCtrl::GetScrollBarTrackInfo
XTP_SCROLLBAR_TRACKINFO * GetScrollBarTrackInfo()
Call this method to get XTP_SCROLLBAR_TRACKINFO information.
CXTPScrollBarCtrl::GetScrollBarPosInfo
XTP_SCROLLBAR_POSINFO * GetScrollBarPosInfo()
Call this method to get XTP_SCROLLBAR_POSINFO information.
CXTPScrollBarCtrl::GetScrollInfo
virtual void GetScrollInfo(SCROLLINFO *psi)
The GetScrollInfo function retrieves the parameters of a scroll bar, including the minimum and maximu...
CXTPScrollBarCtrl::GetScrollBarPaintManager
virtual CXTPScrollBarPaintManager * GetScrollBarPaintManager() const
Obtains a pointer to the associated scrollbar paint manager.
CXTPScrollBarCtrl::SetTheme
void SetTheme(XTPScrollBarTheme theme)
Sets the scrollbar theme.
CXTPScrollBarCtrl::~CXTPScrollBarCtrl
virtual ~CXTPScrollBarCtrl()
Destroys a CXTPScrollBarCtrl object, handles cleanup and deallocation.
CXTPScrollBarCtrl::RefreshMetrics
virtual void RefreshMetrics()
This member is called to update color, text and other visual elements of the control.
CXTPScrollBarCtrl::CXTPScrollBarCtrl
CXTPScrollBarCtrl()
Constructs a CXTPScrollBarCtrl object.
CXTPScrollBarPaintManager
CXTPScrollBarPaintManager is standalone class used to draw CXTPCommandBarScrollBarCtrl object.
Definition XTPScrollBarPaintManager.h:40
CXTPScrollBase
CXTPScrollBase is the base class for all scrollable objects.
Definition XTPScrollBase.h:222
CXTPScrollBase::GetParentWindow
virtual CWnd * GetParentWindow() const =0
Retrieves parent window of scrollbar.
CXTPScrollBase::m_spi
XTP_SCROLLBAR_POSINFO m_spi
ScrollBar position.
Definition XTPScrollBase.h:418
CXTPScrollBase::m_pSBTrack
XTP_SCROLLBAR_TRACKINFO * m_pSBTrack
ScrollBar tracking.
Definition XTPScrollBase.h:419
CXTPScrollBase::GetScrollBarRect
virtual CRect GetScrollBarRect()=0
Obtains the rectangle occupied by the scrollbar in client coordinates.
CXTPScrollBase::IsScrollBarEnabled
virtual BOOL IsScrollBarEnabled() const =0
Determines if the scrollbar is enabled.
CXTPScrollBase::RedrawScrollBar
virtual void RedrawScrollBar()=0
Forces the scrollbar to redraw itself.
XTP_SCROLLBAR_POSINFO
The XTP_SCROLLBAR_POSINFO structure contains scroll bar information.
Definition XTPScrollBase.h:143
XTP_SCROLLBAR_TRACKINFO
The XTP_SCROLLBAR_TRACKINFO structure contains tracking information.
Definition XTPScrollBase.h:174


Toolkit Pro: XTPTaskPanel.h Source File

  • Source
  • TaskPanel
XTPTaskPanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKPANEL_H__)
24# define __XTPTASKPANEL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTaskPanelGroups;
34class CXTPTaskPanelGroup;
35class CXTPTaskPanelPaintManager;
36class CXTPTaskPanelItems;
37class CXTPTaskPanelItem;
38class CXTPTaskPanelGroupItem;
39class CXTPImageManager;
40class CXTPToolTipContext;
41class CXTPTaskPanelAnimation;
42class CXTPMarkupContext;
43class CXTPScrollBar;
44
63class _XTP_EXT_CLASS CXTPTaskPanelScrollButton
64{
65public:
72 CXTPTaskPanelScrollButton(BOOL bScrollUp);
73
74public:
82 BOOL IsVisible() const;
83
84public:
85 BOOL bScrollUp;
87 BOOL bEnabled;
88 BOOL bPressed;
89 CRect rcButton;
91 BOOL bHot;
94 CXTPTaskPanelGroup* pGroupScroll;
96 CXTPTaskPanelGroup* pGroupCaption;
98};
99
104class _XTP_EXT_CLASS CXTPTaskPanel
105 : public CXTPScrollBarContainer<CWnd>
106 , public CXTPAccessible
107{
109 DECLARE_DYNAMIC(CXTPTaskPanel)
110 DECLARE_INTERFACE_MAP()
111 XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
113private:
114 class CPanelDropTarget;
115
116public:
122 class _XTP_EXT_CLASS CRepositionContext
123 {
124 public:
130 CRepositionContext(CXTPTaskPanel* pTaskPanel);
131
136 ~CRepositionContext();
137
138 protected:
139 CXTPTaskPanel* m_pTaskPanel;
140 };
141
142public:
147 CXTPTaskPanel();
148
153 virtual ~CXTPTaskPanel();
154
155public:
167 BOOL Create(DWORD dwStyle, const RECT& rect, CWnd* pParentWnd, UINT nID);
168
175 CXTPTaskPanelItems* GetGroups() const;
176
187 CXTPTaskPanelGroup* AddGroup(UINT nID, int nImage = -1);
188
197 CXTPTaskPanelGroup* FindGroup(UINT nID) const;
198
207 CXTPTaskPanelGroupItem* FindItem(UINT nID) const;
208
216 CXTPTaskPanelGroup* GetAt(int nIndex) const;
217
224 int GetGroupCount() const;
225
239 int GetScrollOffset() const;
240
247 int GetClientHeight() const;
248
254 void Reposition(BOOL bRecalcOnly = TRUE);
255
261 void SetHotItem(CXTPTaskPanelItem* pItem);
262
269 CXTPTaskPanelItem* GetHotItem() const;
270
278 virtual void SetFocusedItem(CXTPTaskPanelItem* pItem, BOOL bDrawFocusRect = FALSE,
279 BOOL bSetFocus = TRUE);
280
289 void EnsureVisible(CXTPTaskPanelItem* pItem);
290
297 CXTPTaskPanelItem* GetFocusedItem() const;
298
309 BOOL IsDrawFocusRect() const;
310
322 CXTPTaskPanelGroup* HitTestGroup(CPoint pt, BOOL* pbCaption = NULL) const;
323
335 CXTPTaskPanelItem* HitTestItem(CPoint pt, BOOL bClientAvail = FALSE) const;
336
353 void SetMargins(long nLeft, long nTop, long nRight, long nBottom, long nMiddle);
354
364 void SetImageList(CImageList* pImageList, CSize szItemIcon = CSize(16, 16));
365
375 void SetGroupImageList(CImageList* pImageList, CSize szGroupIcon = CSize(32, 32));
376
383 CXTPImageManager* GetImageManager() const;
384
390 void SetImageManager(CXTPImageManager* pImageManager);
391
397 void SetExpandable(BOOL bExpandable);
398
405 BOOL IsExpandable() const;
406
421 void SetAnimation(XTPTaskPanelAnimation panelAnimation);
422
433 XTPTaskPanelAnimation GetAnimation() const;
434
440 void SetLayoutRTL(BOOL bRightToLeft);
441
452 void SetLockRedraw(BOOL bLockRedraw);
453
465 CXTPTaskPanelItem* GetNextItem(CXTPTaskPanelItem* pItem, int nDirection, BOOL bTab,
466 BOOL bSkipRowItems = TRUE) const;
467
473 virtual void OnClick(CXTPTaskPanelGroupItem* pItem);
474
486 BOOL IsDirty() const;
487
494 void OnScrollChanged(int nCurPos);
495
515 BOOL AnimateGroups(BOOL bCheckDirty = TRUE);
516
527 CSize GetItemIconSize() const;
528
539 CSize GetGroupIconSize() const;
540
546 void SetIconSize(CSize szIcon);
547
553 void SetGroupIconSize(CSize szIcon);
554
561 void NavigateItems(BOOL bTabItems);
562
568 void EnableAnimation(BOOL bEnable = TRUE);
569
570public:
601 void SetTheme(XTPTaskPanelPaintTheme paintTheme);
602
608 void SetCustomTheme(CXTPTaskPanelPaintManager* pPaintManager);
609
618 CXTPTaskPanelPaintManager* GetPaintManager() const;
619
629 XTPTaskPanelPaintTheme GetCurrentTheme() const;
630
637 CXTPToolTipContext* GetToolTipContext() const;
638
639public:
648 virtual void ExpandGroup(CXTPTaskPanelGroup* pGroup, BOOL bExpanded);
649
658 BOOL IsGroupExpanded(const CXTPTaskPanelGroup* pGroup) const;
659
666 void SetHotTrackStyle(XTPTaskPanelHotTrackStyle hotTrackStyle);
667
675 XTPTaskPanelHotTrackStyle GetHotTrackStyle() const;
676
684 XTPTaskPanelItemLayout GetItemLayout() const;
685
700 void SetItemLayout(XTPTaskPanelItemLayout itemLayout);
701
710 void SetBehaviour(XTPTaskPanelBehaviour panelBehaviour);
711
721 XTPTaskPanelBehaviour GetBehaviour() const;
722
729 CXTPTaskPanelGroup* GetActiveGroup() const;
730
746 void SetSelectItemOnFocus(BOOL bSelect);
747
761 void SetSingleSelection(BOOL bSingleSelection = TRUE);
762
772 BOOL IsSingleSelection() const;
773
782 void DrawFocusRect(BOOL bAccept);
783
790 CRect GetMargins() const;
791
798 static CLIPFORMAT AFX_CDECL GetClipboardFormat();
799
825 void AllowDrag(long nAllowDrag = xtpTaskItemAllowDragDefault);
826
835 void AllowDrop(BOOL bAllowDrop);
836
851 void RenameItem(CXTPTaskPanelItem* pItem);
852
863 CXTPTaskPanelScrollButton* GetScrollButton(BOOL bScrollUp) const;
864
874 CXTPTaskPanelScrollButton* HitTestScrollButton(CPoint point) const;
875
887 virtual void OnDraw(CDC* pDC, CRect rcClipBox);
888
895 void Redraw(LPCRECT lpRect = NULL, BOOL bAnimate = FALSE);
896
933 virtual LRESULT NotifyOwner(WPARAM wParam, LPARAM lParam);
934
943 void SetMultiColumn(BOOL bMultiColumn);
944
954 BOOL IsMultiColumn() const;
955
963 void SetColumnWidth(int nColumnWidth);
964
973 int GetColumnWidth() const;
974
981 int GetMinimumGroupClientHeight() const;
982
988 void SetMinimumGroupClientHeight(int nMinClientHeight);
989
997 BOOL RegisterWindowClass(HINSTANCE hInstance = NULL);
998
999public:
1006 void EnableMarkup(BOOL bEnable = TRUE);
1007
1014 CXTPMarkupContext* GetMarkupContext() const;
1015
1016protected:
1026 BOOL IsExplorerBehaviour() const;
1027
1037 virtual void OnStartItemDrag(CXTPTaskPanelGroupItem* pItem);
1038
1048 virtual void OnStartGroupDrag(CXTPTaskPanelItem* pItem);
1049
1061 virtual void OnEndLabelEdit(CXTPTaskPanelItem* pItem, LPCTSTR str);
1062
1085 virtual DROPEFFECT OnDragOver(COleDataObject* pDataObject, DWORD dwKeyState, CPoint point);
1086
1101 virtual BOOL OnDrop(COleDataObject* pDataObject, DROPEFFECT dropEffect, CPoint point);
1102
1111 void RepositionScrollButtons();
1112
1122 void OnClickScrollButton(CXTPTaskPanelScrollButton* pScrollButton);
1123
1132 void UpdateScrollButtons();
1133
1147 void CheckScrollButtonMouseOver(CPoint point);
1148
1159 virtual void OnItemRemoved(CXTPTaskPanelItem* pItem);
1160
1171 virtual void UpdateScrollBar();
1172
1177 virtual void OnClientHeightChanged();
1178
1188 CXTPTaskPanelGroup* GetNextVisibleGroup(int nIndex, int nDirection = +1) const;
1189
1190protected:
1193 // System accessibility support.
1194
1195 virtual HRESULT GetAccessibleParent(IDispatch** ppdispParent);
1196 virtual HRESULT GetAccessibleChildCount(long* pcountChildren);
1197 virtual HRESULT GetAccessibleChild(VARIANT varChild, IDispatch** ppdispChild);
1198 virtual HRESULT GetAccessibleName(VARIANT varChild, BSTR* pszName);
1199 virtual HRESULT GetAccessibleRole(VARIANT varChild, VARIANT* pvarRole);
1200 virtual HRESULT AccessibleLocation(long* pxLeft, long* pyTop, long* pcxWidth, long* pcyHeight,
1201 VARIANT varChild);
1202 virtual HRESULT AccessibleHitTest(long xLeft, long yTop, VARIANT* pvarChild);
1203 virtual HRESULT GetAccessibleState(VARIANT varChild, VARIANT* pvarState);
1204 virtual CCmdTarget* GetAccessible();
1205 CXTPTaskPanelItem* GetAccessibleItem(int nIndex);
1206 int GetAccessibleIndex(CXTPTaskPanelItem* pItem);
1209protected:
1211 DECLARE_MESSAGE_MAP()
1212
1213 //{{AFX_VIRTUAL(CXTPTaskPanel)
1214 virtual void PreSubclassWindow();
1215 virtual BOOL PreCreateWindow(CREATESTRUCT& cs);
1216 virtual INT_PTR OnToolHitTest(CPoint point, TOOLINFO* pTI) const;
1217 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
1218 virtual BOOL PreTranslateMessage(MSG* pMsg);
1219 //}}AFX_VIRTUAL
1220
1221 //{{AFX_MSG(CXTPTaskPanel)
1222 afx_msg int OnCreate(LPCREATESTRUCT lpCreateStruct);
1223 afx_msg void OnNcCalcSize(BOOL bCalcValidRects, NCCALCSIZE_PARAMS* lpncsp);
1224 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
1225 afx_msg void OnNcPaint();
1226 afx_msg void OnPaint();
1227 afx_msg void OnSize(UINT nType, int cx, int cy);
1228 afx_msg void OnVScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar);
1229 afx_msg void OnMouseMove(UINT nFlags, CPoint point);
1230 afx_msg BOOL OnSetCursor(CWnd* pWnd, UINT nHitTest, UINT message);
1231 afx_msg void OnLButtonUp(UINT nFlags, CPoint point);
1232 afx_msg void OnLButtonDblClk(UINT nFlags, CPoint point);
1233 afx_msg void OnDestroy();
1234 afx_msg void OnTimer(UINT_PTR nIDEvent);
1235 afx_msg void OnSysColorChange();
1236 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection);
1237 afx_msg void OnRButtonDown(UINT nFlags, CPoint point);
1238 afx_msg void OnRButtonUp(UINT nFlags, CPoint point);
1239 afx_msg void OnSetFocus(CWnd* pOldWnd);
1240 afx_msg void OnKillFocus(CWnd* pNewWnd);
1241 afx_msg void OnKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
1242 afx_msg void OnSysKeyDown(UINT nChar, UINT nRepCnt, UINT nFlags);
1243 afx_msg void OnKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
1244 afx_msg void OnSysKeyUp(UINT nChar, UINT nRepCnt, UINT nFlags);
1245 afx_msg void OnLButtonDown(UINT nFlags, CPoint point);
1246 afx_msg BOOL OnMouseWheel(UINT nFlags, short zDelta, CPoint pt);
1247 afx_msg void OnMouseLeave();
1248 afx_msg UINT OnGetDlgCode();
1249 afx_msg void OnCaptureChanged(CWnd* pWnd);
1250 afx_msg LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
1251 afx_msg LRESULT OnGetObject(WPARAM wParam, LPARAM lParam);
1252 //}}AFX_MSG
1255private:
1256 BOOL Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle, const RECT& rect,
1257 CWnd* pParentWnd, UINT nID, CCreateContext* pContext = NULL);
1258 BOOL GetMessageExt(MSG& msg);
1259 void EnsureVisibleRect(const CRect& rc);
1260 void GrabFocus();
1261 HWND GetNextControl(BOOL bForward) const;
1262 void CheckOldFocus(CWnd* pOldWnd);
1263 CXTPTaskPanelGroupItem* FindControlItem(HWND hWnd);
1264 HWND GetRootChild(HWND hWndTaskPanel, HWND hWnd);
1265 void DrawBorders(CPaintDC& paintDC);
1266
1267protected:
1268 CXTPTaskPanelGroups* m_pGroups;
1269 CXTPTaskPanelAnimation* m_pAnimation;
1271 CXTPTaskPanelPaintManager* m_pPaintManager;
1272 XTPTaskPanelPaintTheme m_paintTheme;
1273 BOOL m_bPreSubclassWindow;
1274 BOOL m_nLockRedraw;
1276 int m_nClientHeight;
1278 int m_nOldClientHeight;
1280 CRect m_rcMargins;
1281 int m_nGroupSpacing;
1283 BOOL m_bScrollVisible;
1286 CXTPTaskPanelItem* m_pItemHot;
1287 CXTPTaskPanelItem* m_pItemFocused;
1288 CXTPTaskPanelItem* m_pItemPressed;
1290 CXTPTaskPanelItem* m_pItemDragging;
1291 CXTPTaskPanelItem* m_pItemDragOver;
1295 BOOL m_bAnimation;
1296 XTPTaskPanelAnimation m_eAnimation;
1298 HCURSOR m_hHandCursor;
1300 UINT_PTR m_nAnimateTimer;
1301 int m_nAnimationStep;
1303 CXTPImageManager* m_pImageManager;
1307 BOOL m_bExpandable;
1309 BOOL m_bAcceptFocus;
1310 BOOL m_bGrabbingFocus;
1311 BOOL m_bDrawFocusRect;
1313 CSize m_szItemIcon;
1314 CSize m_szGroupIcon;
1315 BOOL m_bSelectItemOnFocus;
1317 CPoint m_ptPressed;
1319 long m_nAllowDrag;
1320 BOOL m_bAllowDrop;
1324 XTPTaskPanelItemLayout m_itemLayout;
1325 BOOL m_bMultiColumn;
1326 int m_nColumnWidth;
1327 XTPTaskPanelHotTrackStyle m_hotTrackStyle;
1328 XTPTaskPanelBehaviour m_panelBehaviour;
1330 CXTPTaskPanelGroup* m_pActiveGroup;
1331 CPanelDropTarget* m_pDropTarget;
1332 static CLIPFORMAT m_cfItem;
1334 BOOL m_bTimerGroupHover;
1338 CXTPTaskPanelScrollButton*
1339 m_pScrollButton[2];
1346 BOOL m_bSingleSelection;
1347 CXTPToolTipContext* m_pToolTipContext;
1348 BOOL m_bInUpdateScrollBar;
1350 int m_nGroupMinClientHeight;
1351 long m_nOLEDropMode;
1352 BOOL m_bTabItems;
1353 CXTPMarkupContext* m_pMarkupContext;
1355 COLORREF m_clrBorder[3];
1356
1357private:
1358 friend class CXTPTaskPanelGroup;
1359 friend class CXTPTaskPanelItem;
1360 friend class CTaskPanelCtrl;
1361 friend class CXTPTaskPanelPaintManager;
1362 friend class CPanelDropTarget;
1363 friend class CXTPTaskPanelGroupItem;
1364 friend class CXTPTaskPanelEditItem;
1365 friend class CXTPTaskPanelItems;
1366};
1367
1369
1370AFX_INLINE CXTPTaskPanelItems* CXTPTaskPanel::GetGroups() const
1371{
1372 return (CXTPTaskPanelItems*)m_pGroups;
1373}
1374AFX_INLINE CXTPTaskPanelPaintManager* CXTPTaskPanel::GetPaintManager() const
1375{
1376 return m_pPaintManager;
1377}
1378AFX_INLINE CXTPTaskPanelItem* CXTPTaskPanel::GetHotItem() const
1379{
1380 return m_pItemHot;
1381}
1382AFX_INLINE XTPTaskPanelPaintTheme CXTPTaskPanel::GetCurrentTheme() const
1383{
1384 return m_paintTheme;
1385}
1386AFX_INLINE void CXTPTaskPanel::SetExpandable(BOOL bExpandable)
1387{
1388 m_bExpandable = bExpandable;
1389}
1390AFX_INLINE XTPTaskPanelAnimation CXTPTaskPanel::GetAnimation() const
1391{
1392 return m_eAnimation;
1393}
1394AFX_INLINE BOOL CXTPTaskPanel::IsExpandable() const
1395{
1396 return m_bExpandable;
1397}
1398AFX_INLINE CSize CXTPTaskPanel::GetItemIconSize() const
1399{
1400 return m_szItemIcon;
1401}
1402AFX_INLINE CSize CXTPTaskPanel::GetGroupIconSize() const
1403{
1404 return m_szGroupIcon;
1405}
1406AFX_INLINE BOOL CXTPTaskPanel::IsExplorerBehaviour() const
1407{
1408 return m_panelBehaviour == xtpTaskPanelBehaviourExplorer;
1409}
1410AFX_INLINE CXTPTaskPanelGroup* CXTPTaskPanel::GetActiveGroup() const
1411{
1412 return m_pActiveGroup;
1413}
1414AFX_INLINE void CXTPTaskPanel::SetSelectItemOnFocus(BOOL bSelect)
1415{
1416 m_bSelectItemOnFocus = bSelect;
1417}
1418AFX_INLINE void CXTPTaskPanel::DrawFocusRect(BOOL bAccept)
1419{
1420 m_bAcceptFocus = bAccept;
1421}
1422AFX_INLINE CRect CXTPTaskPanel::GetMargins() const
1423{
1424 return m_rcMargins;
1425}
1426AFX_INLINE void CXTPTaskPanel::SetIconSize(CSize szIcon)
1427{
1428 m_szItemIcon = szIcon;
1429 Reposition();
1430}
1431AFX_INLINE void CXTPTaskPanel::SetGroupIconSize(CSize szIcon)
1432{
1433 m_szGroupIcon = szIcon;
1434 Reposition();
1435}
1436AFX_INLINE CLIPFORMAT AFX_CDECL CXTPTaskPanel::GetClipboardFormat()
1437{
1438 return m_cfItem;
1439}
1440AFX_INLINE void CXTPTaskPanel::AllowDrop(BOOL bAllowDrop)
1441{
1442 m_bAllowDrop = bAllowDrop;
1443}
1444AFX_INLINE CXTPTaskPanelScrollButton* CXTPTaskPanel::GetScrollButton(BOOL bScrollUp) const
1445{
1446 return bScrollUp ? m_pScrollButton[TRUE] : m_pScrollButton[FALSE];
1447}
1448AFX_INLINE BOOL CXTPTaskPanel::Create(LPCTSTR lpszClassName, LPCTSTR lpszWindowName, DWORD dwStyle,
1449 const RECT& rect, CWnd* pParentWnd, UINT nID,
1450 CCreateContext* pContext)
1451{
1452 return CWnd::Create(lpszClassName, lpszWindowName, dwStyle, rect, pParentWnd, nID, pContext);
1453}
1454AFX_INLINE void CXTPTaskPanel::SetSingleSelection(BOOL bSingleSelection)
1455{
1456 m_bSingleSelection = bSingleSelection;
1457 Reposition();
1458}
1459AFX_INLINE BOOL CXTPTaskPanel::IsSingleSelection() const
1460{
1461 return m_bSingleSelection;
1462}
1463AFX_INLINE void CXTPTaskPanel::SetMultiColumn(BOOL bMultiColumn)
1464{
1465 m_bMultiColumn = bMultiColumn;
1466 Reposition();
1467}
1468AFX_INLINE BOOL CXTPTaskPanel::IsMultiColumn() const
1469{
1470 return m_bMultiColumn;
1471}
1472AFX_INLINE void CXTPTaskPanel::SetColumnWidth(int nColumnWidth)
1473{
1474 m_nColumnWidth = nColumnWidth;
1475 Reposition();
1476}
1477AFX_INLINE int CXTPTaskPanel::GetColumnWidth() const
1478{
1479 return m_nColumnWidth;
1480}
1481AFX_INLINE int CXTPTaskPanel::GetMinimumGroupClientHeight() const
1482{
1483 return m_nGroupMinClientHeight;
1484}
1485
1486AFX_INLINE void CXTPTaskPanel::SetMinimumGroupClientHeight(int nMinClientHeight)
1487{
1488 m_nGroupMinClientHeight = nMinClientHeight;
1489}
1490AFX_INLINE void CXTPTaskPanel::NavigateItems(BOOL bTabItems)
1491{
1492 m_bTabItems = bTabItems;
1493}
1494AFX_INLINE CXTPMarkupContext* CXTPTaskPanel::GetMarkupContext() const
1495{
1496 return m_pMarkupContext;
1497}
1498
1499# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
1501#endif // !defined(__XTPTASKPANEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE
#define XTP_DECLARE_CMDTARGETPROVIDER_INTERFACE()
When deriving from CXTPCmdTarget is not possible this macro can be used in addition to standard DECLA...
Definition XTPFramework.h:89
XTPTaskPanelHotTrackStyle
XTPTaskPanelHotTrackStyle
XTPTaskPanelHotTrackStyle is an enumeration used by CXTPTaskPanel to set the hot tracking style used ...
Definition XTPTaskPanelDefines.h:150
XTPTaskPanelPaintTheme
XTPTaskPanelPaintTheme
XTPTaskPanelPaintTheme is an enumeration used by CXTPTaskPanel to set the theme of the control.
Definition XTPTaskPanelDefines.h:193
XTPTaskPanelAnimation
XTPTaskPanelAnimation
XTPTaskPanelAnimation is an enumeration used by CXTPTaskPanel to set the animation of the control.
Definition XTPTaskPanelDefines.h:241
xtpTaskItemAllowDragDefault
@ xtpTaskItemAllowDragDefault
Default drag options (xtpTaskItemAllowDragAll).
Definition XTPTaskPanelDefines.h:98
XTPTaskPanelItemLayout
XTPTaskPanelItemLayout
XTPTaskPanelItemLayout is an enumeration used by CXTPTaskpanel and CXTPTaskPanelGroup to set how the ...
Definition XTPTaskPanelDefines.h:127
XTPTaskPanelBehaviour
XTPTaskPanelBehaviour
XTPTaskPanelBehaviour is an enumeration used by CXTPTaskPanel and CXTPTaskPanelGroup to set the behav...
Definition XTPTaskPanelDefines.h:170
xtpTaskPanelBehaviourExplorer
@ xtpTaskPanelBehaviourExplorer
Task Panel will behave like Windows Explorer.
Definition XTPTaskPanelDefines.h:171
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPScrollBarContainer
CXTPScrollBarContainer class adds XTP scroll bars to a class derived from CWnd.
Definition XTPScrollBarContainer.h:113
CXTPScrollBar
Scrollbar control.
Definition XTPScrollBar.h:44
CXTPTaskPanel::CRepositionContext
CRepositionContext is a helper class used to lock/unlock redraw for the Task Panel.
Definition XTPTaskPanel.h:123
CXTPTaskPanel::CRepositionContext::m_pTaskPanel
CXTPTaskPanel * m_pTaskPanel
Parent Task Panel.
Definition XTPTaskPanel.h:139
CXTPTaskPanel::CRepositionContext::~CRepositionContext
~CRepositionContext()
Destroys a CRepositionContext object, handles cleanup and deallocation.
CXTPTaskPanel::CRepositionContext::CRepositionContext
CRepositionContext(CXTPTaskPanel *pTaskPanel)
Constructs a CRepositionContext object.
CXTPTaskPanelGroup
CXTPTaskPanelGroup is used in a Task Panel control to represent a group.
Definition XTPTaskPanelGroup.h:45
CXTPTaskPanelGroupItem
CXTPTaskPanelGroupItem is used in a TaskPanel control to represent a single item of a group.
Definition XTPTaskPanelGroupItem.h:39
CXTPTaskPanelGroups
CXTPTaskPanelGroups represents a collection of groups in a Task Panel control.
Definition XTPTaskPanelItems.h:310
CXTPTaskPanel
CXTPTaskPanel is used to implement an Explorer and Office-like Task Panel control.
Definition XTPTaskPanel.h:107
CXTPTaskPanel::GetToolTipContext
CXTPToolTipContext * GetToolTipContext() const
Gets the tooltip context.
CXTPTaskPanel::HitTestScrollButton
CXTPTaskPanelScrollButton * HitTestScrollButton(CPoint point) const
Determines which group scroll button, if any, is located at a specified point.
CXTPTaskPanel::SetMinimumGroupClientHeight
void SetMinimumGroupClientHeight(int nMinClientHeight)
Sets the minimum client height for all groups.
Definition XTPTaskPanel.h:1486
CXTPTaskPanel::SetSelectItemOnFocus
void SetSelectItemOnFocus(BOOL bSelect)
Specifies if items should receive focus when they are clicked.
Definition XTPTaskPanel.h:1414
CXTPTaskPanel::IsExplorerBehaviour
BOOL IsExplorerBehaviour() const
Determines if the behaviour of the Task Panel control is Explorer behavior.
Definition XTPTaskPanel.h:1406
CXTPTaskPanel::IsMultiColumn
BOOL IsMultiColumn() const
Determines if multi-column groups is enabled/disabled.
Definition XTPTaskPanel.h:1468
CXTPTaskPanel::AllowDrag
void AllowDrag(long nAllowDrag=xtpTaskItemAllowDragDefault)
Specifies the drag options for the Task Panel.
CXTPTaskPanel::GetBehaviour
XTPTaskPanelBehaviour GetBehaviour() const
Gets the behaviour of the Task Panel control.
CXTPTaskPanel::SetHotItem
void SetHotItem(CXTPTaskPanelItem *pItem)
Sets the "hot" item for the Task Panel control.
CXTPTaskPanel::GetActiveGroup
CXTPTaskPanelGroup * GetActiveGroup() const
Gets the active group.
Definition XTPTaskPanel.h:1410
CXTPTaskPanel::ExpandGroup
virtual void ExpandGroup(CXTPTaskPanelGroup *pGroup, BOOL bExpanded)
Expands/collapses a specified group.
CXTPTaskPanel::RegisterWindowClass
BOOL RegisterWindowClass(HINSTANCE hInstance=NULL)
Registers the window class if it has not already been registered.
CXTPTaskPanel::OnDraw
virtual void OnDraw(CDC *pDC, CRect rcClipBox)
The framework calls this method to draw the Task Panel control using a specified device context.
CXTPTaskPanel::SetAnimation
void SetAnimation(XTPTaskPanelAnimation panelAnimation)
Sets the animation type for the Task Panel control.
CXTPTaskPanel::GetHotTrackStyle
XTPTaskPanelHotTrackStyle GetHotTrackStyle() const
Gets the hot tracking style.
CXTPTaskPanel::RepositionScrollButtons
void RepositionScrollButtons()
Repositions the group scroll buttons.
CXTPTaskPanel::EnableMarkup
void EnableMarkup(BOOL bEnable=TRUE)
Enables/disables markup for tab captions.
CXTPTaskPanel::GetAnimation
XTPTaskPanelAnimation GetAnimation() const
Gets the animation type of the Task Panel control.
Definition XTPTaskPanel.h:1390
CXTPTaskPanel::IsGroupExpanded
BOOL IsGroupExpanded(const CXTPTaskPanelGroup *pGroup) const
Determines if a specified group is expanded/collapsed.
CXTPTaskPanel::SetImageList
void SetImageList(CImageList *pImageList, CSize szItemIcon=CSize(16, 16))
Sets the image list for the Task Panel control.
CXTPTaskPanel::UpdateScrollBar
virtual void UpdateScrollBar()
Updates the scrollbar of the Task Panel.
CXTPTaskPanel::CXTPTaskPanel
CXTPTaskPanel()
Constructs a CXTPTaskPanel object.
CXTPTaskPanel::OnStartGroupDrag
virtual void OnStartGroupDrag(CXTPTaskPanelItem *pItem)
This method is called when a group is starting to be dragged.
CXTPTaskPanel::GetNextItem
CXTPTaskPanelItem * GetNextItem(CXTPTaskPanelItem *pItem, int nDirection, BOOL bTab, BOOL bSkipRowItems=TRUE) const
Retrieves the next/previous item in the tab order from a specified item.
CXTPTaskPanel::Redraw
void Redraw(LPCRECT lpRect=NULL, BOOL bAnimate=FALSE)
The framework calls this method to redraw the Task Panel control.
CXTPTaskPanel::SetMultiColumn
void SetMultiColumn(BOOL bMultiColumn)
Enables/disables multi-column groups.
Definition XTPTaskPanel.h:1463
CXTPTaskPanel::GetMargins
CRect GetMargins() const
Gets the outer margins of groups in the Task Panel control.
Definition XTPTaskPanel.h:1422
CXTPTaskPanel::GetColumnWidth
int GetColumnWidth() const
Gets the width, in pixels, of columns in a multi-column Task Panel control.
Definition XTPTaskPanel.h:1477
CXTPTaskPanel::~CXTPTaskPanel
virtual ~CXTPTaskPanel()
Destroys a CXTPTaskPanel object, handles cleanup and deallocation.
CXTPTaskPanel::IsExpandable
BOOL IsExpandable() const
Gets the expandable state of groups.
Definition XTPTaskPanel.h:1394
CXTPTaskPanel::SetCustomTheme
void SetCustomTheme(CXTPTaskPanelPaintManager *pPaintManager)
Sets a custom theme for the Task Panel control.
CXTPTaskPanel::GetNextVisibleGroup
CXTPTaskPanelGroup * GetNextVisibleGroup(int nIndex, int nDirection=+1) const
Retrieves the next/previous visible group from a specified index.
CXTPTaskPanel::SetBehaviour
void SetBehaviour(XTPTaskPanelBehaviour panelBehaviour)
Sets the behaviour for the Task Panel control.
CXTPTaskPanel::IsSingleSelection
BOOL IsSingleSelection() const
Determines if single selection is enabled/disabled.
Definition XTPTaskPanel.h:1459
CXTPTaskPanel::OnItemRemoved
virtual void OnItemRemoved(CXTPTaskPanelItem *pItem)
This method is called when an item is removed from the Task Panel.
CXTPTaskPanel::OnDragOver
virtual DROPEFFECT OnDragOver(COleDataObject *pDataObject, DWORD dwKeyState, CPoint point)
This method is called when an item is dragged over the Task Panel control.
CXTPTaskPanel::SetLockRedraw
void SetLockRedraw(BOOL bLockRedraw)
Locks/unlocks redrawing controls.
CXTPTaskPanel::UpdateScrollButtons
void UpdateScrollButtons()
Updates the enabled/disabled state of the group scroll buttons.
CXTPTaskPanel::HitTestGroup
CXTPTaskPanelGroup * HitTestGroup(CPoint pt, BOOL *pbCaption=NULL) const
Determines which group, if any, is located at a specified point.
CXTPTaskPanel::Reposition
void Reposition(BOOL bRecalcOnly=TRUE)
Repositions the groups in the Task Panel control.
CXTPTaskPanel::OnScrollChanged
void OnScrollChanged(int nCurPos)
This method is called when the scrollbar of the entire Task Panel control is scrolled (i....
CXTPTaskPanel::FindItem
CXTPTaskPanelGroupItem * FindItem(UINT nID) const
Retrieves the group item with a specified identifier.
CXTPTaskPanel::GetClientHeight
int GetClientHeight() const
Gets the height of the client area.
CXTPTaskPanel::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Gets the markup context.
Definition XTPTaskPanel.h:1494
CXTPTaskPanel::GetScrollOffset
int GetScrollOffset() const
Gets the scroll offset.
CXTPTaskPanel::OnClickScrollButton
void OnClickScrollButton(CXTPTaskPanelScrollButton *pScrollButton)
The member is called when a group scroll button is clicked.
CXTPTaskPanel::GetScrollButton
CXTPTaskPanelScrollButton * GetScrollButton(BOOL bScrollUp) const
Retrieves a specified group scroll button.
Definition XTPTaskPanel.h:1444
CXTPTaskPanel::GetGroupCount
int GetGroupCount() const
Gets the number of groups in the collection of groups.
CXTPTaskPanel::GetMinimumGroupClientHeight
int GetMinimumGroupClientHeight() const
Gets the minimum client height of all groups.
Definition XTPTaskPanel.h:1481
CXTPTaskPanel::GetItemIconSize
CSize GetItemIconSize() const
Gets the size of item icons in the Task Panel control.
Definition XTPTaskPanel.h:1398
CXTPTaskPanel::SetGroupIconSize
void SetGroupIconSize(CSize szIcon)
Sets the size for group icons in the Task Panel control.
Definition XTPTaskPanel.h:1431
CXTPTaskPanel::AnimateGroups
BOOL AnimateGroups(BOOL bCheckDirty=TRUE)
This method is called to animate the group(s) when animation is enabled.
CXTPTaskPanel::GetAt
CXTPTaskPanelGroup * GetAt(int nIndex) const
Retrieves the group at a specified index in the collection of groups.
CXTPTaskPanel::EnsureVisible
void EnsureVisible(CXTPTaskPanelItem *pItem)
Ensures that a specified item is visible in the Task Panel.
CXTPTaskPanel::HitTestItem
CXTPTaskPanelItem * HitTestItem(CPoint pt, BOOL bClientAvail=FALSE) const
Determines which item, if any, is located at a specified point.
CXTPTaskPanel::NotifyOwner
virtual LRESULT NotifyOwner(WPARAM wParam, LPARAM lParam)
Notifies the parent window that an event has occurred in the Task Panel control.
CXTPTaskPanel::AllowDrop
void AllowDrop(BOOL bAllowDrop)
Specifies the drop options for the Task Panel.
Definition XTPTaskPanel.h:1440
CXTPTaskPanel::RenameItem
void RenameItem(CXTPTaskPanelItem *pItem)
Renames the caption of a specified item.
CXTPTaskPanel::IsDrawFocusRect
BOOL IsDrawFocusRect() const
Determines if a focus rectangle is drawn around an item when the Up and Down arrows are used to navig...
CXTPTaskPanel::OnDrop
virtual BOOL OnDrop(COleDataObject *pDataObject, DROPEFFECT dropEffect, CPoint point)
This method is called when an item is dropped into the Task Panel control.
CXTPTaskPanel::GetGroupIconSize
CSize GetGroupIconSize() const
Gets the size of group icons in the Task Panel control.
Definition XTPTaskPanel.h:1402
CXTPTaskPanel::GetImageManager
CXTPImageManager * GetImageManager() const
Gets the image manager associated with the Task Panel control.
CXTPTaskPanel::SetTheme
void SetTheme(XTPTaskPanelPaintTheme paintTheme)
Sets the theme for the Task Panel control.
CXTPTaskPanel::SetHotTrackStyle
void SetHotTrackStyle(XTPTaskPanelHotTrackStyle hotTrackStyle)
Sets the hot tracking style.
CXTPTaskPanel::SetLayoutRTL
void SetLayoutRTL(BOOL bRightToLeft)
Sets right-to-left (RTL) mode.
CXTPTaskPanel::OnClick
virtual void OnClick(CXTPTaskPanelGroupItem *pItem)
This method is called when the user clicks on an item.
CXTPTaskPanel::SetExpandable
void SetExpandable(BOOL bExpandable)
Sets the expandable state for groups.
Definition XTPTaskPanel.h:1386
CXTPTaskPanel::GetClipboardFormat
static CLIPFORMAT AFX_CDECL GetClipboardFormat()
Gets the clipboard format.
Definition XTPTaskPanel.h:1436
CXTPTaskPanel::Create
BOOL Create(DWORD dwStyle, const RECT &rect, CWnd *pParentWnd, UINT nID)
Creates a Task Panel control.
CXTPTaskPanel::SetFocusedItem
virtual void SetFocusedItem(CXTPTaskPanelItem *pItem, BOOL bDrawFocusRect=FALSE, BOOL bSetFocus=TRUE)
Sets the focused item for the Task Panel control.
CXTPTaskPanel::SetIconSize
void SetIconSize(CSize szIcon)
Sets the size for item icons in the Task Panel control.
Definition XTPTaskPanel.h:1426
CXTPTaskPanel::SetGroupImageList
void SetGroupImageList(CImageList *pImageList, CSize szGroupIcon=CSize(32, 32))
Sets the image list for the groups of the Task Panel control.
CXTPTaskPanel::IsDirty
BOOL IsDirty() const
Determines if the group position is "dirty" (i.e.
CXTPTaskPanel::SetColumnWidth
void SetColumnWidth(int nColumnWidth)
Sets the width, in pixels, for columns in a multi-column Task Panel control.
Definition XTPTaskPanel.h:1472
CXTPTaskPanel::OnEndLabelEdit
virtual void OnEndLabelEdit(CXTPTaskPanelItem *pItem, LPCTSTR str)
This method is called when the caption of an item is finished being edited/renamed.
CXTPTaskPanel::AddGroup
CXTPTaskPanelGroup * AddGroup(UINT nID, int nImage=-1)
Adds a group to the collection of groups.
CXTPTaskPanel::GetItemLayout
XTPTaskPanelItemLayout GetItemLayout() const
Gets the item layout.
CXTPTaskPanel::GetFocusedItem
CXTPTaskPanelItem * GetFocusedItem() const
Gets the focused item of the Task Panel control.
CXTPTaskPanel::DrawFocusRect
void DrawFocusRect(BOOL bAccept)
Draws a focus rectangle around an item/group item when the Up and Down arrows are used to navigate th...
Definition XTPTaskPanel.h:1418
CXTPTaskPanel::GetCurrentTheme
XTPTaskPanelPaintTheme GetCurrentTheme() const
Gets the theme of the Task Panel control.
Definition XTPTaskPanel.h:1382
CXTPTaskPanel::OnClientHeightChanged
virtual void OnClientHeightChanged()
This method is called when the client height is changed.
CXTPTaskPanel::CheckScrollButtonMouseOver
void CheckScrollButtonMouseOver(CPoint point)
Determines if the mouse cursor is positioned over a group scroll button.
CXTPTaskPanel::SetSingleSelection
void SetSingleSelection(BOOL bSingleSelection=TRUE)
Enables/disables single selection.
Definition XTPTaskPanel.h:1454
CXTPTaskPanel::OnStartItemDrag
virtual void OnStartItemDrag(CXTPTaskPanelGroupItem *pItem)
This method is called when a group item is starting to be dragged.
CXTPTaskPanel::FindGroup
CXTPTaskPanelGroup * FindGroup(UINT nID) const
Retrieves the group with a specified identifier.
CXTPTaskPanel::SetItemLayout
void SetItemLayout(XTPTaskPanelItemLayout itemLayout)
Sets the item layout.
CXTPTaskPanel::NavigateItems
void NavigateItems(BOOL bTabItems)
Enables/disables item navigation by using the Tab key.
Definition XTPTaskPanel.h:1490
CXTPTaskPanel::SetMargins
void SetMargins(long nLeft, long nTop, long nRight, long nBottom, long nMiddle)
Sets the outer margins for the groups of the Task Panel control.
CXTPTaskPanel::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Sets the image manager associated with the Task Panel control.
CXTPTaskPanel::GetPaintManager
CXTPTaskPanelPaintManager * GetPaintManager() const
Gets the paint manager.
Definition XTPTaskPanel.h:1374
CXTPTaskPanel::GetHotItem
CXTPTaskPanelItem * GetHotItem() const
Gets the "hot" item of the Task Panel control.
Definition XTPTaskPanel.h:1378
CXTPTaskPanel::EnableAnimation
void EnableAnimation(BOOL bEnable=TRUE)
Enables/disables animation for the Task Panel control.
CXTPTaskPanelItem
CXTPTaskPanelItem is used in a Task Panel control to represent a single item.
Definition XTPTaskPanelItem.h:49
CXTPTaskPanelItems
CXTPTaskPanelItems is used in a Task Panel control to represent a collection of items.
Definition XTPTaskPanelItems.h:44
CXTPTaskPanelPaintManager
CXTPTaskPanelPaintManager is a standalone class used by CXTPTaskPanel as a paint manager.
Definition XTPTaskPanelPaintManager.h:115
CXTPTaskPanelScrollButton
CXTPTaskPanelScrollButton is a standalone class that represents a task panel scroll button.
Definition XTPTaskPanel.h:64
CXTPTaskPanelScrollButton::IsVisible
BOOL IsVisible() const
Determines if this scroll button is visible.
CXTPTaskPanelScrollButton::CXTPTaskPanelScrollButton
CXTPTaskPanelScrollButton(BOOL bScrollUp)
Constructs a CXTPTaskPanelScrollButton object.
CXTPTaskPanelScrollButton::rcButton
CRect rcButton
Bounding rectangle of the scroll button.
Definition XTPTaskPanel.h:89
CXTPTaskPanelScrollButton::bScrollUp
BOOL bScrollUp
If TRUE, then the button is a "scroll up" button.
Definition XTPTaskPanel.h:85
CXTPTaskPanelScrollButton::bEnabled
BOOL bEnabled
TRUE if the scroll button is enabled, FALSE if it is disabled.
Definition XTPTaskPanel.h:87
CXTPTaskPanelScrollButton::bHot
BOOL bHot
TRUE if the scroll button is "hot", FALSE otherwise.
Definition XTPTaskPanel.h:91
CXTPTaskPanelScrollButton::pGroupScroll
CXTPTaskPanelGroup * pGroupScroll
Pointer to the group that uses this group item scroll button.
Definition XTPTaskPanel.h:94
CXTPTaskPanelScrollButton::bPressed
BOOL bPressed
TRUE if the scroll button is currently pressed, FALSE otherwise.
Definition XTPTaskPanel.h:88
CXTPTaskPanelScrollButton::pGroupCaption
CXTPTaskPanelGroup * pGroupCaption
Pointer to the group that uses this group caption scroll button.
Definition XTPTaskPanel.h:96
CXTPToolTipContext
CXTPToolTipContext is a CXTPCmdTarget derived class.
Definition XTPToolTipContext.h:291


Toolkit Pro: XTPTrackThemeResource.h Source File

  • Source
  • GridControl
  • TrackControl
  • Themes
XTPTrackThemeResource.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKTHEMEResource_H__)
24# define __XTPTRACKTHEMEResource_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPTrackThemeResource : public CXTPTrackPaintManager
39{
40public:
45 CXTPTrackThemeResource();
46
52 virtual void RefreshMetrics();
53
63 CSize DrawCollapsedBitmap(CDC* pDC, const CXTPGridRow* pRow, CRect& rcBitmap);
64
74 virtual void DrawNoGroupByText(CDC* pDC, CRect rcItem);
75
82 virtual void FillFooter(CDC* pDC, CRect rcFooter);
83
116 virtual void DrawTriangle(CDC* pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth,
117 BOOL bColumnPressed);
118
119 using CXTPTrackPaintManager::DrawTriangle;
120
121protected:
133 virtual void DrawColumnBackground(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn,
134 BOOL& bColumnPressed, BOOL& bDraggingFromHeader,
135 CXTPGridHeader* pHeader = NULL);
136
137 virtual void DrawPlainColumnBackground(CDC* /*pDC*/, CRect /*rcColumn*/);
138
139public:
147 virtual void DrawColumnFooterDivider(CDC* pDC, CXTPGridColumn* pColumn, CRect rcColumn);
148
159 virtual void DrawColumnText(CDC* pDC, CRect rcText, CString strCaption, int nHeaderAlignment,
160 BOOL bIsHeader, BOOL bColumnPressed);
161
174 void DrawSectionDivider(CDC* pDC, const CRect& rc,
175 XTPGridSectionDividerPosition dividerPosition,
176 XTPGridSectionDividerStyle dividerStyle,
177 CXTPPaintManagerColor dividerColor);
178};
180# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
181#endif //#if !defined(__XTPTRACKTHEMEResource_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTPGridSectionDividerPosition
XTPGridSectionDividerPosition
Section divider position.
Definition XTPGridDefines.h:258
XTPGridSectionDividerStyle
XTPGridSectionDividerStyle
Represent the header/footer rows divider style.
Definition XTPGridDefines.h:227
CXTPGridColumn
Represents a grid column item with its properties and operations.
Definition XTPGridColumn.h:107
CXTPGridHeader
A grid header is a part of the grid window positioned above columns of text or numbers.
Definition XTPGridHeader.h:173
CXTPGridPaintManager::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, BOOL bDraggingFromHeader, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPGridRow
CXTPGridRow class represents a row of the Grid control window.
Definition XTPGridRow.h:71
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117
CXTPTrackPaintManager
This class represents a track control paint manager.
Definition XTPTrackPaintManager.h:41
CXTPTrackThemeResource
CXTPTrackThemeResource is a CXTPTrackPaintManager derived class that represents a Resource style them...
Definition XTPTrackThemeResource.h:39
CXTPTrackThemeResource::DrawColumnText
virtual void DrawColumnText(CDC *pDC, CRect rcText, CString strCaption, int nHeaderAlignment, BOOL bIsHeader, BOOL bColumnPressed)
Draws text for the column header.
CXTPTrackThemeResource::DrawCollapsedBitmap
CSize DrawCollapsedBitmap(CDC *pDC, const CXTPGridRow *pRow, CRect &rcBitmap)
Draws a collapsed bitmap.
CXTPTrackThemeResource::DrawNoGroupByText
virtual void DrawNoGroupByText(CDC *pDC, CRect rcItem)
This method used to draw a "No items" text message in the Group By area when there are no items insid...
CXTPTrackThemeResource::CXTPTrackThemeResource
CXTPTrackThemeResource()
Default paint manager constructor, handles properties initialization.
CXTPTrackThemeResource::DrawTriangle
virtual void DrawTriangle(CDC *pDC, CRect rcTriangle, BOOL bToDown, int nShadowWidth, BOOL bColumnPressed)
Draws a triangle that shows the sort order of the column.
CXTPTrackThemeResource::DrawSectionDivider
void DrawSectionDivider(CDC *pDC, const CRect &rc, XTPGridSectionDividerPosition dividerPosition, XTPGridSectionDividerStyle dividerStyle, CXTPPaintManagerColor dividerColor)
Draws the divider between grid sections (e.g.
CXTPTrackThemeResource::DrawColumnBackground
virtual void DrawColumnBackground(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn, BOOL &bColumnPressed, BOOL &bDraggingFromHeader, CXTPGridHeader *pHeader=NULL)
This method is called to draw the background of a column using the current column style.
CXTPTrackThemeResource::FillFooter
virtual void FillFooter(CDC *pDC, CRect rcFooter)
Fills the column footer control area by its background.
CXTPTrackThemeResource::DrawColumnFooterDivider
virtual void DrawColumnFooterDivider(CDC *pDC, CXTPGridColumn *pColumn, CRect rcColumn)
Draws the column footer divider.
CXTPTrackThemeResource::RefreshMetrics
virtual void RefreshMetrics()
This method is called to refresh the visual metrics of the track control.


Toolkit Pro: XTPDatePickerItemDay.h Source File

  • Source
  • Calendar
  • DatePicker
XTPDatePickerItemDay.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERITEMDAY_H__)
23# define _XTPDATEPICKERITEMDAY_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
31class CXTPDatePickerControl;
32class CXTPDatePickerItemMonth;
33
46class _XTP_EXT_CLASS CXTPDatePickerItemDay : public CXTPCmdTarget
47{
48public:
59 CXTPDatePickerItemDay(CXTPDatePickerControl* pControl, CXTPDatePickerItemMonth* pMonth,
60 COleDateTime dtDay);
61
68 virtual ~CXTPDatePickerItemDay();
69
76 virtual void Draw(CDC* pDC);
77
86 void SetRect(const CRect& rcDay);
87
97 CRect GetRect() const;
98
107 COleDateTime GetDate() const;
108
116 BOOL IsVisible() const;
117
129 BOOL IsToday(COleDateTime& dt) const;
130
138 CXTPDatePickerItemMonth* GetMonth() const;
139
146 CXTPDatePickerControl* GetDatePickerControl() const;
147
148 // Attributes
149protected:
150 CXTPDatePickerControl* m_pControl;
153 CXTPDatePickerItemMonth* m_pMonth;
156 COleDateTime m_dtDay;
159 CRect m_rcDay;
162 BOOL m_bVisible;
166protected:
167 friend class CXTPDatePickerControl;
168};
169
170AFX_INLINE void CXTPDatePickerItemDay::SetRect(const CRect& rcDay)
171{
172 m_rcDay = rcDay;
173}
174AFX_INLINE CRect CXTPDatePickerItemDay::GetRect() const
175{
176 return m_rcDay;
177}
178AFX_INLINE COleDateTime CXTPDatePickerItemDay::GetDate() const
179{
180 return m_dtDay;
181}
182AFX_INLINE BOOL CXTPDatePickerItemDay::IsVisible() const
183{
184 return m_bVisible;
185}
186AFX_INLINE CXTPDatePickerItemMonth* CXTPDatePickerItemDay::GetMonth() const
187{
188 return m_pMonth;
189}
190AFX_INLINE CXTPDatePickerControl* CXTPDatePickerItemDay::GetDatePickerControl() const
191{
192 return m_pControl;
193}
194
195# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
196#endif // !defined(_XTPDATEPICKERITEMDAY_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPDatePickerControl
Class CXTPDatePickerControl encapsulates the functionality of a date and time picker control.
Definition XTPDatePickerControl.h:331
CXTPDatePickerItemDay
Class CXTPDatePickerItemDay represents one displayed day item in the calendar.
Definition XTPDatePickerItemDay.h:47
CXTPDatePickerItemDay::SetRect
void SetRect(const CRect &rcDay)
Call this member function to set the day's rectangle area.
Definition XTPDatePickerItemDay.h:170
CXTPDatePickerItemDay::m_pControl
CXTPDatePickerControl * m_pControl
This member variable is a pointer to the parent date picker control.
Definition XTPDatePickerItemDay.h:150
CXTPDatePickerItemDay::CXTPDatePickerItemDay
CXTPDatePickerItemDay(CXTPDatePickerControl *pControl, CXTPDatePickerItemMonth *pMonth, COleDateTime dtDay)
Default collection constructor.
CXTPDatePickerItemDay::GetMonth
CXTPDatePickerItemMonth * GetMonth() const
This member function is used to get a parent month object.
Definition XTPDatePickerItemDay.h:186
CXTPDatePickerItemDay::GetDatePickerControl
CXTPDatePickerControl * GetDatePickerControl() const
This member function is used to get a parent date picker object.
Definition XTPDatePickerItemDay.h:190
CXTPDatePickerItemDay::m_pMonth
CXTPDatePickerItemMonth * m_pMonth
This member variable is a pointer to the parent month item.
Definition XTPDatePickerItemDay.h:153
CXTPDatePickerItemDay::IsVisible
BOOL IsVisible() const
Call this member function to determine if the day is visible.
Definition XTPDatePickerItemDay.h:182
CXTPDatePickerItemDay::Draw
virtual void Draw(CDC *pDC)
Call this member function to draw a day item.
CXTPDatePickerItemDay::GetDate
COleDateTime GetDate() const
Call this member function to get the date of the day.
Definition XTPDatePickerItemDay.h:178
CXTPDatePickerItemDay::~CXTPDatePickerItemDay
virtual ~CXTPDatePickerItemDay()
Default collection destructor.
CXTPDatePickerItemDay::m_bVisible
BOOL m_bVisible
This member variable is used as a flag to specify if the day item is visible.The flag values are TRUE...
Definition XTPDatePickerItemDay.h:162
CXTPDatePickerItemDay::IsToday
BOOL IsToday(COleDateTime &dt) const
This member function is used to determine if the day is the "Today" date.
CXTPDatePickerItemDay::m_rcDay
CRect m_rcDay
This member variable is used to specify the coordinates of the day spot.
Definition XTPDatePickerItemDay.h:159
CXTPDatePickerItemDay::GetRect
CRect GetRect() const
Call this member function to obtain the day's rectangle area.
Definition XTPDatePickerItemDay.h:174
CXTPDatePickerItemDay::m_dtDay
COleDateTime m_dtDay
This member variable is used to specify the visible day date, represented by this Day item.
Definition XTPDatePickerItemDay.h:156
CXTPDatePickerItemMonth
Class CXTPDatePickerItemMonth represents one month inside the date picker month grid.
Definition XTPDatePickerItemMonth.h:54


CXTPProgressCtrlThemeVisualStudio2017 Member List

This is the complete list of members for CXTPProgressCtrlThemeVisualStudio2017, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager |
CXTPProgressCtrlThemeOffice2000() | CXTPProgressCtrlThemeOffice2000 |
CXTPProgressCtrlThemeOffice2013() | CXTPProgressCtrlThemeOffice2013 |
CXTPProgressCtrlThemeVisualStudio2017() | CXTPProgressCtrlThemeVisualStudio2017 |
DeflateRect(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | protectedvirtual
Draw(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPProgressCtrlThemeOffice2013 | virtual
DrawText(XTPPROGRESSDRAWSTRUCT &ds) | CXTPProgressCtrlPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetBackColor() | CXTPProgressCtrlPaintManager |
GetBarColor() | CXTPProgressCtrlPaintManager |
GetBorderColor() | CXTPProgressCtrlPaintManager |
GetTextColor() | CXTPProgressCtrlPaintManager |
m_bUseWinTheme | CXTPProgressCtrlPaintManager | protected
m_clrBack | CXTPProgressCtrlPaintManager | protected
m_clrBar | CXTPProgressCtrlPaintManager | protected
m_clrBarText | CXTPProgressCtrlPaintManager | protected
m_clrBorder | CXTPProgressCtrlPaintManager | protected
m_clrText | CXTPProgressCtrlPaintManager | protected
m_nTheme | CXTPProgressCtrlPaintManager | protected
m_winTheme | CXTPProgressCtrlPaintManager | protected
RefreshMetrics() | CXTPProgressCtrlThemeOffice2013 | virtual
SetBackColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBarColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetBorderColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
SetTextColor(COLORREF clrNew) | CXTPProgressCtrlPaintManager |
UseWinThemes(BOOL bUseWinThemes=TRUE) | CXTPProgressCtrlPaintManager |
UsingWinThemes(BOOL bCheckReady=FALSE) | CXTPProgressCtrlPaintManager |
~CXTPProgressCtrlPaintManager() | CXTPProgressCtrlPaintManager | virtual


Toolkit Pro: XTPListCtrlView.h Source File

  • Source
  • Controls
  • List
XTPListCtrlView.h
Go to the documentation of this file.
1
23#if !defined(__XTPLISTVIEW_H__)
24# define __XTPLISTVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33DECLARE_LIST_BASE(CXTPListViewBase, CListView, CXTPListBase)
34DECLARE_LIST_BASE(CXTPListCtrlBase, CListCtrl, CXTPListBase)
35
36
43class _XTP_EXT_CLASS CXTPListView : public CXTPListViewBase
44{
46 DECLARE_DYNCREATE(CXTPListView)
48public:
53 CXTPListView();
54
59 virtual ~CXTPListView();
60
61protected:
62 DECLARE_MESSAGE_MAP()
63};
64
73class _XTP_EXT_CLASS CXTPListCtrl : public CXTPListCtrlBase
74{
76 DECLARE_DYNAMIC(CXTPListCtrl)
78public:
83 CXTPListCtrl();
84
89 virtual ~CXTPListCtrl();
90
91protected:
92 DECLARE_MESSAGE_MAP()
93};
94
103template<class ListBase>
104class CXTPScrollableListCtrlT : public CXTPScrollable<ListBase>
105{
106public:
111 CXTPScrollableListCtrlT();
112
113 using CXTPScrollable<ListBase>::GetRuntimeClass;
114
115protected:
117 virtual BOOL HasVScroll(DWORD dwStyle, DWORD dwExStyle) const;
118 virtual BOOL HasHScroll(DWORD dwStyle, DWORD dwExStyle) const;
119 virtual BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
121};
122
127typedef CXTPScrollableListCtrlT<CXTPListCtrl> CXTPScrollableListCtrl;
129template<class ListBase>
130AFX_INLINE CXTPScrollableListCtrlT<ListBase>::CXTPScrollableListCtrlT()
131{
132 _ASSERTE(GetRuntimeClass()->IsDerivedFrom(RUNTIME_CLASS(CListCtrl)));
133}
134
135template<class ListBase>
136AFX_INLINE BOOL CXTPScrollableListCtrlT<ListBase>::HasVScroll(DWORD dwStyle, DWORD dwExStyle) const
137{
138 UNREFERENCED_PARAMETER(dwExStyle);
139 return 0 == (dwStyle & LVS_NOSCROLL);
140}
141
142template<class ListBase>
143AFX_INLINE BOOL CXTPScrollableListCtrlT<ListBase>::HasHScroll(DWORD dwStyle, DWORD dwExStyle) const
144{
145 UNREFERENCED_PARAMETER(dwExStyle);
146 return 0 == (dwStyle & LVS_NOSCROLL);
147}
148
149_XTP_EXT_CLASS BOOL AFXAPI XTPOnScrollableListCtrlWndMsg(UINT message, WPARAM wParam, LPARAM lParam,
150 LRESULT* pResult, CWnd* pEmbeddedControl);
151
152template<class ListBase>
153AFX_INLINE BOOL CXTPScrollableListCtrlT<ListBase>::OnWndMsg(UINT message, WPARAM wParam,
154 LPARAM lParam, LRESULT* pResult)
155{
156 if (XTPOnScrollableListCtrlWndMsg(message, wParam, lParam, pResult,
157 CXTPScrollHost::GetEmbeddedControl()))
158 return TRUE;
159
160 return CXTPScrollable<ListBase>::OnWndMsg(message, wParam, lParam, pResult);
161}
163# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
165#endif // #if !defined(__XTPLISTVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPScrollableListCtrl
CXTPScrollableListCtrlT< CXTPListCtrl > CXTPScrollableListCtrl
Type alias for a CXTPListCtrl derived scrollable control.
Definition XTPListCtrlView.h:127
CXTPListBase
CXTPListBase is a non-inherited class.
Definition XTPListBase.h:39
CXTPListCtrl
CXTPListCtrl is a multiple inheritance class derived from CListCtrl and CXTPListBase.
Definition XTPListCtrlView.h:74
CXTPListCtrl::CXTPListCtrl
CXTPListCtrl()
Constructs a CXTPListCtrl object.
CXTPListCtrl::~CXTPListCtrl
virtual ~CXTPListCtrl()
Destroys a CXTPListCtrl object, handles cleanup and deallocation.
CXTPListView
CXTPListView is a multiple inheritance class derived from CListView and CXTPListBase.
Definition XTPListCtrlView.h:44
CXTPListView::~CXTPListView
virtual ~CXTPListView()
Destroys a CXTPListView object, handles cleanup and deallocation.
CXTPListView::CXTPListView
CXTPListView()
Constructs a CXTPListView object.
CXTPScrollable
The adaptor class for a scrollable control for which standard scroll bars have to be overriden.
Definition XTPScrollable.h:249
CXTPScrollableListCtrlT
An adaptor for any CListCtrl derived control that overrides standard scrollbars with custom scrollbar...
Definition XTPListCtrlView.h:105
CXTPScrollableListCtrlT::CXTPScrollableListCtrlT
CXTPScrollableListCtrlT()
Initializes a scrollable control instance.
IXTPScrollable::HasHScroll
virtual BOOL HasHScroll(DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has horizontal scroll bar for the combination of styles specified.
IXTPScrollable::HasVScroll
virtual BOOL HasVScroll(DWORD dwStyle, DWORD dwExStyle) const =0
Returns TRUE if the control has vertical scroll bar for the combination of styles specified.


Toolkit Pro: XTPChartSeriesView.h Source File

  • Source
  • Chart
XTPChartSeriesView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHARTSERIESVIEW_H__)
24# define __XTPCHARTSERIESVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartSeriesView;
34class CXTPChartSeriesPoint;
35class CXTPChartSeriesStyle;
36class CXTPChartSeries;
37class CXTPChartDiagramView;
38class CXTPChartDiagram;
39class CXTPChartLegendView;
40
41class _XTP_EXT_CLASS CXTPChartSeriesView
42 : public CXTPChartElementView
43 , public CXTPChartLegendItemView
44{
45 DECLARE_DYNAMIC(CXTPChartSeriesView);
46
47public:
48 CXTPChartSeriesView(CXTPChartSeries* pSeries, CXTPChartDiagramView* pDiagramView);
49
50public:
51 virtual void CreatePointsView(CXTPChartDeviceContext* pDC);
52
53 CXTPChartSeries* GetSeries() const;
54 CXTPChartSeriesStyle* GetStyle() const;
55 CXTPChartDiagram* GetDiagram() const;
56 CXTPChartDiagramView* GetDiagramView() const;
57 CXTPChartElementView* GetPointsView() const;
58 CXTPChartElementView* GetErrorBarsView() const;
59
60public:
61 virtual void CalculateLayout(CXTPChartDeviceContext* pDC);
62 virtual void UpdateRange(CXTPChartDeviceContext* pDC);
63 virtual void AddToLegend(CXTPChartLegendView* pView);
64 virtual CXTPChartDeviceCommand* CreateLegendDeviceCommand(CXTPChartDeviceContext* pDC,
65 CRect rcBounds);
66
67protected:
68 virtual CXTPChartSeriesPointView* CreateSeriesPointView(CXTPChartDeviceContext* pDC,
69 CXTPChartSeriesPoint* pPoint,
70 CXTPChartElementView* pParentView);
71 virtual CXTPChartString GetLegendName() const;
72
73public:
74 CXTPChartSeries* m_pSeries;
75 CXTPChartDiagramView* m_pDiagramView;
76 CXTPChartElementView* m_pPointsView;
77 CXTPChartElementView* m_pLabelsView;
78 CXTPChartElementView* m_pErrorBarsView;
79};
80
81AFX_INLINE CXTPChartDiagramView* CXTPChartSeriesView::GetDiagramView() const
82{
83 return m_pDiagramView;
84}
85
86AFX_INLINE CXTPChartSeries* CXTPChartSeriesView::GetSeries() const
87{
88 return m_pSeries;
89}
90
91AFX_INLINE CXTPChartElementView* CXTPChartSeriesView::GetPointsView() const
92{
93 return m_pPointsView;
94}
95
96AFX_INLINE CXTPChartElementView* CXTPChartSeriesView::GetErrorBarsView() const
97{
98 return m_pErrorBarsView;
99}
101# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
102#endif //#if !defined(__XTPCHARTSERIESVIEW_H__)
pPoint
const CPoint * pPoint
return 0 or xtpCalendarHitTestDayExpandButton
Definition XTPCalendarThemeOffice2007.h:150
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChartDeviceCommand
Defines a common implementation interface for chart drawing commands.
Definition XTPChartDeviceCommand.h:100
CXTPChartDeviceContext
This class abstracts a device context.
Definition XTPChartDeviceContext.h:48
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:49
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartLegendItemView
CXTPChartLegendItemView is an abstract base class which represents a chart legend item.
Definition XTPChartLegendItem.h:39
CXTPChartLegendItemView::GetLegendName
virtual CXTPChartString GetLegendName() const =0
This function returns the legend name.
CXTPChartLegendItemView::CreateLegendDeviceCommand
virtual CXTPChartDeviceCommand * CreateLegendDeviceCommand(CXTPChartDeviceContext *pDC, CRect rcBounds)=0
This function creates a CXTPChartDeviceCommand object, this object represents the rendering of a lege...
CXTPChartLegendView
This class abstracts the view of a legend and its child items in a bounding rectangle context.
Definition XTPChartLegendView.h:49
CXTPChartSeries
This class represents a series in the chart, which is a kind of CXTPChartElement.
Definition XTPChartSeries.h:50
CXTPChartSeriesPoint
CXTPChartSeriesPoint is a kind of CXTPChartElement.
Definition XTPChartSeriesPoint.h:43
CXTPChartSeriesPointView
Represents chart series point view.
Definition XTPChartSeriesPointView.h:48
CXTPChartSeriesStyle
CXTPChartSeriesStyle is a CXTPChartElement derived class.
Definition XTPChartSeriesStyle.h:49


CXTPCalendarTLV_TimeScaleParams_Month Member List

This is the complete list of members for CXTPCalendarTLV_TimeScaleParams_Month, including all inherited members.

CalcScaleIntervalBegin(COleDateTime dtStart) | CXTPCalendarTLV_TimeScaleParams | virtual
CXTPCalendarTLV_TimeScaleParams(int nTimeScaleParamsID, CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams |
CXTPCalendarTLV_TimeScaleParams_Month(CXTPCalendarTimeLineViewTimeScale *pTimeScale) | CXTPCalendarTLV_TimeScaleParams_Month |
CXTPCmdTarget() | CXTPCmdTarget |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetParentTimeScale() const | CXTPCalendarTLV_TimeScaleParams |
GetPart() const | CXTPCalendarTLV_TimeScaleParams_Month | virtual
GetScaleInterval() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetScaleIntervalWidth_px() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeLineViewScale() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimePerPixel() const | CXTPCalendarTLV_TimeScaleParams | virtual
GetTimeScaleParamsID() const | CXTPCalendarTLV_TimeScaleParams | virtual
m_nScaleIntervalWidth_px | CXTPCalendarTLV_TimeScaleParams | protected
m_scaleInterval | CXTPCalendarTLV_TimeScaleParams | protected
SetScaleInterval(int eType, int nValue) | CXTPCalendarTLV_TimeScaleParams | protected
~CXTPCalendarTLV_TimeScaleParams() | CXTPCalendarTLV_TimeScaleParams | virtual
~CXTPCalendarTLV_TimeScaleParams_Month() | CXTPCalendarTLV_TimeScaleParams_Month | virtual


  • CXTPCalendarView
  • CSelectionChangedContext
CXTPCalendarView::CSelectionChangedContext Member List

This is the complete list of members for CXTPCalendarView::CSelectionChangedContext, including all inherited members.

CSelectionChangedContext(CXTPCalendarView *pView, int eSelType=xtpCalendarSelectionUnknown) | CXTPCalendarView::CSelectionChangedContext |
~CSelectionChangedContext() | CXTPCalendarView::CSelectionChangedContext | virtual


Toolkit Pro: XTPDatePickerVisualStudio2022Theme.h Source File

  • Source
  • Calendar
  • DatePicker
  • Themes
XTPDatePickerVisualStudio2022Theme.h
Go to the documentation of this file.
1
22#if !defined(_XTPDATEPICKERVISUALSTUDIO2022THEME_H__)
23# define _XTPDATEPICKERVISUALSTUDIO2022THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
51class _XTP_EXT_CLASS CXTPDatePickerThemeVisualStudio2022 : public CXTPDatePickerThemeOffice2013
52{
53public:
62 CXTPDatePickerThemeVisualStudio2022();
63
70 virtual ~CXTPDatePickerThemeVisualStudio2022();
71};
72
73# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // !defined(_XTPDATEPICKERVISUALSTUDIO2022THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDatePickerThemeOffice2013
Class CXTPDatePickerThemeOffice2013 is derived from CXTPDatePickerPaintManager for rendering an Offic...
Definition XTPDatePickerOffice2013Theme.h:52
CXTPDatePickerThemeVisualStudio2022
Class CXTPDatePickerThemeVisualStudio2022 is derived from CXTPDatePickerThemeOffice2013 for rendering...
Definition XTPDatePickerVisualStudio2022Theme.h:52
CXTPDatePickerThemeVisualStudio2022::CXTPDatePickerThemeVisualStudio2022
CXTPDatePickerThemeVisualStudio2022()
Default paint manager constructor.
CXTPDatePickerThemeVisualStudio2022::~CXTPDatePickerThemeVisualStudio2022
virtual ~CXTPDatePickerThemeVisualStudio2022()
Default paint manager destructor.


Toolkit Pro: XTPEndAfxMap.h Source File

  • Source
  • Common
  • Base
  • Diagnostic
XTPEndAfxMap.h
Go to the documentation of this file.
1
24#ifdef XTP_AFX_MAP_INCLUSION_CONTROL
25# if (_MSC_VER >= 1900)
26// C5031: #pragma warning(pop): likely mismatch, popping warning state pushed in different file
27# pragma warning(disable : 5031)
28# endif
29
30# pragma warning(pop)
31
32# undef XTP_AFX_MAP_INCLUSION_CONTROL
33#else
34# error "Common/Base/Diagnostic/XTPBeginAfxMap.h" inclussion is missing
35#endif
36


Toolkit Pro: XTPShortcutBarResourceTheme.h Source File

  • Source
  • ShortcutBar
  • Themes
XTPShortcutBarResourceTheme.h
Go to the documentation of this file.
1
23#if !defined(__XTPSHORTCUTBARRESOURCETHEME_H__)
24# define __XTPSHORTCUTBARRESOURCETHEME_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPShortcutBarResourceTheme : public CXTPShortcutBarOffice2003Theme
39{
40public:
45 CXTPShortcutBarResourceTheme();
46
47public:
55 virtual void RefreshMetrics();
56
67 virtual int DrawGripper(CDC* pDC, CXTPShortcutBar* pShortcutBar, BOOL bDraw);
68
75 void FillShortcutItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
76
83 void FillShortcutBar(CDC* pDC, CXTPShortcutBar* pShortcutBar);
84
106 virtual int DrawPaneItemCaption(CDC* pDC, CXTPShortcutBarPaneItem* pItem, BOOL bDraw);
107
133 virtual int DrawPaneCaption(CDC* pDC, CXTPShortcutBarPane* pPane, BOOL bDraw);
134
141 virtual void DrawExpandButton(CDC* pDC, CRect rc);
142
149 virtual void FillNavigationItemEntry(CDC* pDC, CXTPShortcutBarItem* pItem);
150
151 virtual void DrawPaneCaptionMinimizeButton(CDC* pDC, CXTPShortcutBarPane* pPane);
152
153public:
154 BOOL m_bFlatStyle;
155};
156
157typedef CXTPShortcutBarResourceTheme CXTPShortcutBarOffice2007Theme;
158typedef CXTPShortcutBarResourceTheme CXTPShortcutBarOffice2010Theme;
159
160# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
162#endif // !defined(__XTPSHORTCUTBARRESOURCETHEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPShortcutBar
CXTPShortcutBar is a CWnd derived class used to implement an Outlook 2003 shortcut bar control style.
Definition XTPShortcutBar.h:456
CXTPShortcutBarItem
CXTPShortcutBarItem is a base class that represents an item for a shortcut bar control.
Definition XTPShortcutBar.h:181
CXTPShortcutBarOffice2003Theme
CXTPShortcutBarOffice2003Theme is a CXTPShortcutBarPaintManager derived class that represents an Offi...
Definition XTPShortcutBarOffice2003Theme.h:39
CXTPShortcutBarPane
CXTPShortcutBarPane is a CWnd derived class used as a client area for a shortcut bar control.
Definition XTPShortcutBarPane.h:158
CXTPShortcutBarPaneItem
CXTPShortcutBarPaneItem is a base class that represents an item for a shortcut bar pane.
Definition XTPShortcutBarPane.h:42
CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme is a CXTPShortcutBarOffice2003Theme derived class that represents the Of...
Definition XTPShortcutBarResourceTheme.h:39
CXTPShortcutBarResourceTheme::DrawExpandButton
virtual void DrawExpandButton(CDC *pDC, CRect rc)
Draws the expand button.
CXTPShortcutBarResourceTheme::DrawPaneItemCaption
virtual int DrawPaneItemCaption(CDC *pDC, CXTPShortcutBarPaneItem *pItem, BOOL bDraw)
Draws the caption for a specified shortcut bar pane item.
CXTPShortcutBarResourceTheme::FillShortcutItemEntry
void FillShortcutItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified item for the shortcut bar control.
CXTPShortcutBarResourceTheme::CXTPShortcutBarResourceTheme
CXTPShortcutBarResourceTheme()
Constructs a CXTPShortcutBarResourceTheme object.
CXTPShortcutBarResourceTheme::DrawGripper
virtual int DrawGripper(CDC *pDC, CXTPShortcutBar *pShortcutBar, BOOL bDraw)
Draws the gripper for the shortcut bar control.
CXTPShortcutBarResourceTheme::FillShortcutBar
void FillShortcutBar(CDC *pDC, CXTPShortcutBar *pShortcutBar)
Fills the client area of the shortcut bar control.
CXTPShortcutBarResourceTheme::RefreshMetrics
virtual void RefreshMetrics()
Refreshes the visual metrics of the shortcut bar paint manager.
CXTPShortcutBarResourceTheme::FillNavigationItemEntry
virtual void FillNavigationItemEntry(CDC *pDC, CXTPShortcutBarItem *pItem)
Fills a specified navigation item for the minimized shortcut bar control.
CXTPShortcutBarResourceTheme::DrawPaneCaption
virtual int DrawPaneCaption(CDC *pDC, CXTPShortcutBarPane *pPane, BOOL bDraw)
Draws the caption for a specified shortcut bar pane.


CXTPSkinManagerSchema Member List

This is the complete list of members for CXTPSkinManagerSchema, including all inherited members.

CXTPCmdTarget() | CXTPCmdTarget |
CXTPSkinManagerSchema(CXTPSkinManagerResourceFile *pResourceFile) | CXTPSkinManagerSchema |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetAccessCriticalSection() const | CXTPSynchronized | inline
GetBoolProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, BOOL &bVal) | CXTPSkinManagerSchema |
GetClassCode(LPCTSTR strClass) | CXTPSkinManagerSchema | static
GetColorProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, COLORREF &clrVal) | CXTPSkinManagerSchema |
GetEnumProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, int &nVal) | CXTPSkinManagerSchema |
GetFontProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, LOGFONT &lfVal) | CXTPSkinManagerSchema |
GetIntProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, int &iVal) | CXTPSkinManagerSchema |
GetMetrics() const | CXTPSkinManagerSchema |
GetRectProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CRect &rcVal) | CXTPSkinManagerSchema |
GetResourceFile() const | CXTPSkinManagerSchema |
GetSchemaName() const | CXTPSkinManagerSchema |
GetSizeProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CSize &szVal) | CXTPSkinManagerSchema |
GetSkinManager() const | CXTPSkinManagerSchema |
GetStringProperty(UINT iClassId, int iPartId, int iStateId, int iPropId, CString &strVal) | CXTPSkinManagerSchema |
m_arrFrameRegions | CXTPSkinManagerSchema | protected
m_mapClasses | CXTPSkinManagerSchema | protected
m_mapProperties | CXTPSkinManagerSchema | protected
m_pManager | CXTPSkinManagerSchema | protected
m_pMetrics | CXTPSkinManagerSchema | protected
m_pResourceFile | CXTPSkinManagerSchema | protected
m_strSchemaName | CXTPSkinManagerSchema | protected
ReadProperties() | CXTPSkinManagerSchema |
~CXTPSkinManagerSchema() | CXTPSkinManagerSchema | virtual


Toolkit Pro: XTPCalendarCaptionBarOffice2000Theme.h Source File

  • Source
  • Calendar
  • CaptionBar
  • Themes
XTPCalendarCaptionBarOffice2000Theme.h
Go to the documentation of this file.
1
22#if !defined(__XTPCALENDARCAPTIONBAROFFICE2000THEME_H__)
23# define __XTPCALENDARCAPTIONBAROFFICE2000THEME_H__
24
25# if _MSC_VER > 1000
26# pragma once
27# endif // _MSC_VER > 1000
28
29# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
30
36class _XTP_EXT_CLASS CXTPCalendarCaptionBarOffice2000Theme
37 : public CXTPCalendarCaptionBarPaintManager
38{
39public:
48 CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme* pTheme = NULL);
49
56 virtual ~CXTPCalendarCaptionBarOffice2000Theme();
57
63 virtual void RefreshMetrics();
64
65 virtual void PartRefresh(CXTPSwitchViewButtonPart* pBarPart);
66 virtual void PartRefresh(CXTPRadioButtonPart* pBarPart);
67 virtual void PartRefresh(CXTPCheckboxButtonPart* pBarPart);
68 virtual void PartRefresh(CXTPDateLabelPart* pBarPart);
69
70 virtual void PartAdjustLayout(CXTPSwitchViewButtonPart* pBarPart, CDC* pDC,
71 const CRect& rcRect);
72 virtual void PartAdjustLayout(CXTPScrollDateButtonPart* pBarPart, CDC* /*pDC*/,
73 const CRect& rcRect);
74 virtual void PartAdjustLayout(CXTPRadioButtonPart* pBarPart, CDC* pDC, const CRect& rcRect);
75 virtual void PartAdjustLayout(CXTPCheckboxButtonPart* pBarPart, CDC* pDC, const CRect& rcRect);
76 virtual void PartAdjustLayout(CXTPExpandButtonPart* pBarPart, CDC* /*pDC*/,
77 const CRect& rcRect);
78
79 virtual void PartDraw(CXTPSwitchViewButtonPart* pBarPart, CDC* pDC);
80 virtual void PartDraw(CXTPScrollDateButtonPart* pBarPart, CDC* pDC);
81 virtual void PartDrawScrollTriangle(CXTPScrollDateButtonPart* pBarPart, CDC* pDC, CRect rcRect,
82 BOOL bLeftDirection, COLORREF clrColor);
83 virtual void PartDraw(CXTPRadioButtonPart* pBarPart, CDC* pDC);
84 virtual void PartDraw(CXTPCheckboxButtonPart* pBarPart, CDC* pDC);
85 virtual void PartDraw(CXTPDateLabelPart* pBarPart, CDC* pDC);
86 virtual void PartDraw(CXTPExpandButtonPart* pBarPart, CDC* pDC);
87 virtual void PartDrawExpandTriangle(CXTPExpandButtonPart* pBarPart, CDC* pDC, CRect rcRect,
88 BOOL bDownDirection, COLORREF clrColor);
89};
90
91# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
92#endif // !defined(__XTPCALENDARCAPTIONBAROFFICE2000THEME_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme is a CXTPCalendarCaptionBarPaintManager derived class thatrepre...
Definition XTPCalendarCaptionBarOffice2000Theme.h:38
CXTPCalendarCaptionBarOffice2000Theme::RefreshMetrics
virtual void RefreshMetrics()
Performs refreshing of graphical related parameters from system settings.
CXTPCalendarCaptionBarOffice2000Theme::CXTPCalendarCaptionBarOffice2000Theme
CXTPCalendarCaptionBarOffice2000Theme(CXTPCalendarCaptionBarTheme *pTheme=NULL)
Default paint manager constructor.
CXTPCalendarCaptionBarOffice2000Theme::~CXTPCalendarCaptionBarOffice2000Theme
virtual ~CXTPCalendarCaptionBarOffice2000Theme()
Default paint manager destructor.
CXTPCalendarCaptionBarPaintManager
Utility class, handles most of the drawing activities.
Definition XTPCalendarCaptionBarPaintManager.h:49
CXTPCalendarCaptionBarTheme
This class CalendarCaptionBar control drawing, user interaction logic and interaction logic with atta...
Definition XTPCalendarCaptionBarTheme.h:48
CXTPCheckboxButtonPart
This class implements Checkbox button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:367
CXTPDateLabelPart
This class implements Date Label part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:407
CXTPExpandButtonPart
This class implements Expand button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:429
CXTPRadioButtonPart
This class implements Radio button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:350
CXTPScrollDateButtonPart
This class implements Scroll Date button part of the ScrollDateBar.
Definition XTPCalendarCaptionBarThemePart.h:383
CXTPSwitchViewButtonPart
This class implements SwitchView button part of the SwitchViewBar.
Definition XTPCalendarCaptionBarThemePart.h:333


Toolkit Pro: XTPChart3dPieDiagramView.h Source File

  • Source
  • Chart
  • Styles
  • Pie
  • 3D
XTPChart3dPieDiagramView.h
Go to the documentation of this file.
1
23#if !defined(__XTPCHART3DPIEDIAGRAMVIEW_H__)
24# define __XTPCHART3DPIEDIAGRAMVIEW_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPChartPieBase;
34class CXTPChartDiagramDomain;
35
47class _XTP_EXT_CLASS CXTPChart3dPieDiagramView : public CXTPChart3dDiagramView
48{
49public:
57 CXTPChart3dPieDiagramView(CXTPChartDiagram* pDiagram, CXTPChartElementView* pParent);
58
59protected:
60};
62# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
63#endif //#if !defined(__XTPCHART3DPIEDIAGRAMVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPChart3dDiagramView
This class represents the view of a chart diagram, which is a kind of CXTPChartElementView.
Definition XTPChartDiagramView.h:180
CXTPChart3dPieDiagramView
This class abstracts the view of a pie diagram.
Definition XTPChart3dPieDiagramView.h:48
CXTPChart3dPieDiagramView::CXTPChart3dPieDiagramView
CXTPChart3dPieDiagramView(CXTPChartDiagram *pDiagram, CXTPChartElementView *pParent)
Constructs a CXTPChart3dPieDiagramView object.
CXTPChartDiagramDomain
Represents a virtual diagram rectangular domain area.
Definition XTPChartDiagram.h:159
CXTPChartDiagram
This class represents a chart diagram, which is a kind of CXTPChartElement.
Definition XTPChartDiagram.h:48
CXTPChartElementView
This class represents the view of a chart element.
Definition XTPChartElementView.h:47
CXTPChartPieBase
This class abstracts a pie chart.
Definition XTPChartPie.h:176


CXTPMarkupStaticExtensionBooleanProperty Member List

This is the complete list of members for CXTPMarkupStaticExtensionBooleanProperty, including all inherited members.

CXTPMarkupStaticExtension(LPCWSTR lpzName, BOOL bProperty) | CXTPMarkupStaticExtension | protected
CXTPMarkupStaticExtension(LPCWSTR lpzName) | CXTPMarkupStaticExtension |
CXTPMarkupStaticExtensionBooleanProperty(LPCWSTR lpzName, BOOL bValue=FALSE) | CXTPMarkupStaticExtensionBooleanProperty |
CXTPMarkupStaticExtensionProperty(LPCWSTR lpzName, CXTPMarkupObject *pObject=NULL) | CXTPMarkupStaticExtensionProperty |
Extend(CXTPMarkupStaticExtension *pExtension, BOOL bReplace=FALSE) | CXTPMarkupStaticExtension |
FindExtension(LPCWSTR lpzName) const | CXTPMarkupStaticExtension |
GetName() const | CXTPMarkupStaticExtension |
GetRawValue() const | CXTPMarkupStaticExtensionBooleanProperty |
GetValue() | CXTPMarkupStaticExtensionProperty |
IsProperty() const | CXTPMarkupStaticExtension |
OnPrepareValue() | CXTPMarkupStaticExtension | inlineprotectedvirtual
Parse(LPCWSTR lpzValue, LPCWSTR &lpzSubValue) | CXTPMarkupStaticExtension | static
ProvideValue() | CXTPMarkupStaticExtensionProperty | virtual
ProvideValue(LPCWSTR lpzValue) | CXTPMarkupStaticExtensionProperty | virtual
SetValue(BOOL bValue) | CXTPMarkupStaticExtensionBooleanProperty |
CXTPMarkupStaticExtensionProperty::SetValue(CXTPMarkupObject *pObject) | CXTPMarkupStaticExtensionProperty |
~CXTPMarkupStaticExtension() | CXTPMarkupStaticExtension | virtual
~CXTPMarkupStaticExtensionProperty() | CXTPMarkupStaticExtensionProperty |


Toolkit Pro: XTPTabView.h Source File

  • Source
  • Controls
  • Tab
XTPTabView.h
Go to the documentation of this file.
1
23#if !defined(__XTPTABVIEW_H__)
24# define __XTPTABVIEW_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
34class _XTP_EXT_CLASS CXTPCtrlView : public CCtrlView
35{
36public:
37 CXTPCtrlView()
38 : CCtrlView(WC_TABCONTROL, AFX_WS_DEFAULT_VIEW | TCS_TOOLTIPS)
39 {
40 }
41};
42
43DECLARE_TABCTRLEX_BASE(CXTPTabViewBase, CXTPCtrlView, CXTPTabExBase)
53class _XTP_EXT_CLASS CXTPTabView : public CXTPTabViewBase
54{
56 DECLARE_DYNCREATE(CXTPTabView)
58 friend class CXTPTabViewBase;
59
60public:
65 CXTPTabView();
66
71 virtual ~CXTPTabView();
72
73public:
81 virtual CTabCtrl& GetTabCtrl() const;
82
93 virtual CImageList* SetTabImageList(CImageList* pImageList);
94
104 virtual CToolTipCtrl* GetToolTips();
105
113 virtual void SetToolTips(CToolTipCtrl* pWndTip);
114
119 void UpdateDocTitle();
120
121protected:
129 virtual BOOL Init();
130
132 DECLARE_MESSAGE_MAP()
133 //{{AFX_VIRTUAL(CXTPTabView)
134 virtual void OnInitialUpdate();
135 //}}AFX_VIRTUAL
136
137 //{{AFX_MSG(CXTPTabView)
138 afx_msg int OnMouseActivate(CWnd* pDesktopWnd, UINT nHitTest, UINT message);
139 //}}AFX_MSG
141};
142
144
145AFX_INLINE CTabCtrl& CXTPTabView::GetTabCtrl() const
146{
147 _ASSERTE(this);
148 return (CTabCtrl&)*this;
149}
150AFX_INLINE CImageList* CXTPTabView::SetTabImageList(CImageList* pImageList)
151{
152 _ASSERTE(this);
153 return GetTabCtrl().SetImageList(pImageList);
154}
155AFX_INLINE CToolTipCtrl* CXTPTabView::GetToolTips()
156{
157 return GetTips();
158}
159AFX_INLINE void CXTPTabView::SetToolTips(CToolTipCtrl* pWndTip)
160{
161 SetTips(pWndTip);
162}
164# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
166#endif // !defined(__XTPTABVIEW_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPTabExBase
CXTPTabExBase is a standalone base class.
Definition XTPTabBase.h:279
CXTPTabView
CXTPTabView is a multiple inheritance class derived from CCtrlView and CXTPTabCtrlBaseEx.
Definition XTPTabView.h:54
CXTPTabView::GetTabCtrl
virtual CTabCtrl & GetTabCtrl() const
Call this member function to retrieve a reference pointer to the CTabCtrl object associated with this...
CXTPTabView::SetTabImageList
virtual CImageList * SetTabImageList(CImageList *pImageList)
Call this function to assign an image list to the tab control associated with this view.
CXTPTabView::~CXTPTabView
virtual ~CXTPTabView()
Destroys a CXTPTabView object, handles cleanup and deallocation.
CXTPTabView::UpdateDocTitle
void UpdateDocTitle()
Call this member function to update the document name with the tab label.
CXTPTabView::SetToolTips
virtual void SetToolTips(CToolTipCtrl *pWndTip)
Call this function to assign a tooltip control to the tab control.
CXTPTabView::Init
virtual BOOL Init()
This member function is called by the CXTPTabView class to perform initialization when the window is ...
CXTPTabView::CXTPTabView
CXTPTabView()
Constructs a CXTPTabView object.
CXTPTabView::GetToolTips
virtual CToolTipCtrl * GetToolTips()
This member function retrieves the handle of the tooltip control associated with the tab control.


CXTPChart3dFunnelDeviceCommandEvents Member List

This is the complete list of members for CXTPChart3dFunnelDeviceCommandEvents, including all inherited members.

CXTPChart3dFunnelDeviceCommandEvents() | CXTPChart3dFunnelDeviceCommandEvents | protected
CXTPChartDeviceCommandEvents() | CXTPChartDeviceCommandEvents | protected
OnAfterExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnBeforeExecute(CXTPChartDeviceCommand *pCommand, CXTPChartDeviceContext *pDC) | CXTPChartDeviceCommandEvents | virtual
OnSetConnectorPoints(CXTPChartDeviceCommand *pCommand, CXTPPoint3d ptShapeCenter, CXTPPoint3d ptOuterCenter) | CXTPChart3dFunnelDeviceCommandEvents | virtual
OnUnsubscribe(CXTPChartDeviceCommand *pCommand) | CXTPChartDeviceCommandEvents |
OnUpdateBounds(CXTPChartDeviceCommand *pCommand, CRect rcBounds) | CXTPChartDeviceCommandEvents | virtual


Toolkit Pro: XTPComboBoxThemeNativeWindows10.h Source File

  • Source
  • Controls
  • Combo
  • Themes
XTPComboBoxThemeNativeWindows10.h
Go to the documentation of this file.
1
23#if !defined(__XTPCOMBOBOXTHEMENATIVEWINDOWS10_H__)
24# define __XTPCOMBOBOXTHEMENATIVEWINDOWS10_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPComboBoxThemeNativeWindows10 : public CXTPComboBoxThemeOffice2013
39{
40public:
45 CXTPComboBoxThemeNativeWindows10();
46
51 virtual ~CXTPComboBoxThemeNativeWindows10();
52
59 virtual void RefreshMetrics(CXTPComboBox* pComboBox);
60
69 virtual void DrawButton(CDC* pDC, CXTPComboBox* pComboBox, CRect rcBtn);
70};
71
72# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
74#endif // __XTPCOMBOBOXTHEMENATIVEWINDOWS10_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPComboBox
The CXTPComboBox class provides the functionality of a themed Windows combobox.
Definition XTPComboBox.h:42
CXTPComboBoxThemeNativeWindows10
Used as the paint manager for a combobox control to render a Native Windows 10 appearance.
Definition XTPComboBoxThemeNativeWindows10.h:39
CXTPComboBoxThemeNativeWindows10::~CXTPComboBoxThemeNativeWindows10
virtual ~CXTPComboBoxThemeNativeWindows10()
Destructor handles cleanup and deallocation.
CXTPComboBoxThemeNativeWindows10::RefreshMetrics
virtual void RefreshMetrics(CXTPComboBox *pComboBox)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPComboBoxThemeNativeWindows10::CXTPComboBoxThemeNativeWindows10
CXTPComboBoxThemeNativeWindows10()
Default constructor.
CXTPComboBoxThemeNativeWindows10::DrawButton
virtual void DrawButton(CDC *pDC, CXTPComboBox *pComboBox, CRect rcBtn)
Called by the paint manager to draw the button portion of the combobox control.
CXTPComboBoxThemeOffice2013
Used as the paint manager for a combobox control to render an Office 2013 appearance.
Definition XTPComboBoxThemeOffice2013.h:39


Toolkit Pro: XTPMsgPreviewDialog.h Source File

  • Source
  • Controls
  • Preview
  • Providers
  • MSG
XTPMsgPreviewDialog.h
Go to the documentation of this file.
1
24#if !defined(__XTPMSGPREVIEWDIALOG_H__)
25# define __XTPMSGPREVIEWDIALOG_H__
26
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class _XTP_EXT_CLASS CXTPMsgPreviewDialog : public CDialog
34{
35 DECLARE_DYNAMIC(CXTPMsgPreviewDialog)
36
37public:
38 CXTPMsgPreviewDialog(); // standard constructor
39 virtual ~CXTPMsgPreviewDialog();
40
41 BOOL Create(CWnd* pParent);
42 void SetSubject(LPCTSTR lpSubject);
43 void SetTo(LPCTSTR lpTo);
44 void SetFrom(LPCTSTR lpFrom);
45 void SetAttachment(LPCTSTR lpAttachment);
46 void SetDate(LPCTSTR lpDate);
47 void SetCC(LPCTSTR lpCC);
48 void SetBCC(LPCTSTR lpBCC);
49 void SetBody(LPCTSTR lpBody);
50
51# if _MSC_VER > 1200
52 using CDialog::Create;
53 using CWnd::Create;
54# endif
55
56protected:
57 virtual void OnOK();
58 virtual void OnCancel();
59
60 DECLARE_MESSAGE_MAP()
61 afx_msg void OnWindowPosChanging(WINDOWPOS* lpWndPos);
62 afx_msg void OnWindowPosChanged(WINDOWPOS* lpWndPos);
63
64private:
65 void Layout();
66};
67
68# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
69#endif // #if !defined(__XTPMSGPREVIEWDIALOG_H__)
70
XTPDisableNoisyWarnings.h


CXTPTabClientWnd Member List

This is the complete list of members for CXTPTabClientWnd, including all inherited members.

AddItem(CWnd *pChildWnd) | CXTPTabClientWnd | protectedvirtual
AddWorkspace(int nIndex=-1) | CXTPTabClientWnd | protectedvirtual
Attach(CXTPMDIFrameWnd *pParentFrame, BOOL bEnableGroups=FALSE) | CXTPTabClientWnd |
Attach(CXTPCommandBars *pCommandBars, CMDIFrameWnd *pParentFrame, BOOL bEnableGroups) | CXTPTabClientWnd |
CheckCommandBarsTheme() | CXTPTabClientWnd | protectedvirtual
ContextMenu(CPoint pt) | CXTPTabClientWnd | protected
CreateNewHorizontalGroup() | CXTPTabClientWnd |
CreateNewVerticalGroup() | CXTPTabClientWnd |
CreateWorkspace() | CXTPTabClientWnd | virtual
CXTPTabClientWnd() | CXTPTabClientWnd |
Detach() | CXTPTabClientWnd |
EnableMarkup(BOOL bEnableMarkup) | CXTPTabClientWnd |
EnableToolTips(XTPTabToolTipBehaviour behaviour=xtpTabToolTipAlways) | CXTPTabClientWnd |
FindIndex(CXTPTabManager *pWorkspace) const | CXTPTabClientWnd |
FindItem(const HWND hWnd) const | CXTPTabClientWnd |
GetAutoTheme() const | CXTPTabClientWnd |
GetCommandBars() const | CXTPTabClientWnd | virtual
GetFlags() const | CXTPTabClientWnd |
GetItem(int nIndex) const | CXTPTabClientWnd |
GetItemColor(const CXTPTabManagerItem *pItem) const | CXTPTabClientWnd | protectedvirtual
GetItemCount() const | CXTPTabClientWnd |
GetItemIcon(const CXTPTabManagerItem *pItem) const | CXTPTabClientWnd | protectedvirtual
GetItemText(const CWnd *pChildWnd) const | CXTPTabClientWnd | protectedvirtual
GetItemTooltip(const CXTPTabManagerItem *pItem) const | CXTPTabClientWnd | protectedvirtual
GetNewTabPositon() const | CXTPTabClientWnd |
GetPaintManager() const | CXTPTabClientWnd |
GetParentFrame() const | CXTPTabClientWnd |
GetSelectedItem() const | CXTPTabClientWnd | protected
GetToolTipContext() const | CXTPTabClientWnd |
GetWorkspace(int nIndex) const | CXTPTabClientWnd |
GetWorkspaceCount() const | CXTPTabClientWnd |
HitTest(CPoint pt) const | CXTPTabClientWnd |
IsAllowReorder() const | CXTPTabClientWnd |
IsAttached() const | CXTPTabClientWnd |
IsLayoutRTL() const | CXTPTabClientWnd |
IsSplitterTrackerUsed() const | CXTPTabClientWnd |
IsWorkspaceCommandEnabled(UINT nID, CXTPTabManagerItem **ppItem=NULL) | CXTPTabClientWnd |
LoadState() | CXTPTabClientWnd |
m_afterCloseTabPosition | CXTPTabClientWnd | protected
m_arrWorkspace | CXTPTabClientWnd | protected
m_bAllowReorder | CXTPTabClientWnd | protected
m_bAutoTheme | CXTPTabClientWnd | protected
m_bAutoUpdateTabCaption | CXTPTabClientWnd | protected
m_bDelayLock | CXTPTabClientWnd |
m_bEnableGroups | CXTPTabClientWnd | protected
m_bForceToRecalc | CXTPTabClientWnd |
m_bHorizSplitting | CXTPTabClientWnd | protected
m_bLockReposition | CXTPTabClientWnd |
m_bLockUpdate | CXTPTabClientWnd |
m_bRefreshed | CXTPTabClientWnd | protected
m_bShowWorkspace | CXTPTabClientWnd | protected
m_bThemedBackColor | CXTPTabClientWnd | protected
m_bUpdateContents | CXTPTabClientWnd | protected
m_bUserWorkspace | CXTPTabClientWnd | protected
m_bUseSplitterTracker | CXTPTabClientWnd | protected
m_dwFlags | CXTPTabClientWnd | protected
m_hCursorDelete | CXTPTabClientWnd | protected
m_hCursorHoriz | CXTPTabClientWnd | protected
m_hCursorNew | CXTPTabClientWnd | protected
m_hCursorVert | CXTPTabClientWnd | protected
m_newTabPosition | CXTPTabClientWnd | protected
m_nSplitterSize | CXTPTabClientWnd | protected
m_pActiveWorkspace | CXTPTabClientWnd | protected
m_pMarkupContext | CXTPTabClientWnd | protected
m_pPaintManager | CXTPTabClientWnd | protected
m_pParentFrame | CXTPTabClientWnd | protected
m_pTabWorkspace | CXTPTabClientWnd | protected
m_pToolTipContext | CXTPTabClientWnd | protected
m_themeCommandBars | CXTPTabClientWnd | protected
MDIActivate(CWnd *pWnd) | CXTPTabClientWnd | protectedvirtual
MDIGetActive() | CXTPTabClientWnd | protectedvirtual
MDITile(BOOL bHorizontal) | CXTPTabClientWnd |
MoveToNextGroup() | CXTPTabClientWnd |
MoveToPreviousGroup() | CXTPTabClientWnd |
OnDraw(CDC *pDC, CRect rc) | CXTPTabClientWnd | virtual
OnFillBackground(CDC *pDC, CRect rc) | CXTPTabClientWnd | virtual
OnPropertyChanged() | CXTPTabManagerAtom | inlinevirtual
Refresh(BOOL bRecalcLayout=TRUE) | CXTPTabClientWnd |
Reposition() | CXTPTabClientWnd | virtual
SaveState() | CXTPTabClientWnd |
ScreenToWorkspace(LPPOINT lpPoint) const | CXTPTabClientWnd |
SetActiveWorkspace(CWorkspace *pWorkspace) | CXTPTabClientWnd | protected
SetAfterCloseActiveTab(XTPWorkspaceActivateTab activeTab) | CXTPTabClientWnd |
SetAllowReorder(BOOL bAllowReorder) | CXTPTabClientWnd |
SetAutoTheme(BOOL bAutoTheme=FALSE) | CXTPTabClientWnd |
SetCommandBars(CXTPCommandBars *pCommandBars) | CXTPTabClientWnd |
SetFlags(DWORD dwButtons) | CXTPTabClientWnd |
SetLayoutRTL(BOOL bRightToLeft) | CXTPTabClientWnd |
SetNewTabPosition(XTPWorkspaceNewTabPosition tabPosition) | CXTPTabClientWnd |
SetPaintManager(CXTPTabPaintManager *pPaintManager) | CXTPTabClientWnd |
SetTabWorkspace(CWorkspace *pWorkspace) | CXTPTabClientWnd |
ShowNewWindowTab(BOOL bShowNewWindowTab=TRUE, int nCommand=ID_FILE_NEW) | CXTPTabClientWnd |
ShowWorkspace(BOOL bShow) | CXTPTabClientWnd |
UpdateContents() | CXTPTabClientWnd | virtual
UpdateFlags(CWorkspace *pWorkspace) | CXTPTabClientWnd | protectedvirtual
UseSplitterTracker(BOOL bSplitterTracker) | CXTPTabClientWnd |
WorkspaceToScreen(LPPOINT lpPoint) const | CXTPTabClientWnd |
~CXTPTabClientWnd() | CXTPTabClientWnd | virtual
~CXTPTabManagerAtom() | CXTPTabManagerAtom | inlineprotectedvirtual


Toolkit Pro: XTPEditThemeOfficeXP.h Source File

  • Source
  • Controls
  • Edit
  • Themes
XTPEditThemeOfficeXP.h
Go to the documentation of this file.
1
23#if !defined(__XTPEDITTHEMEOFFICEXP_H__)
24# define __XTPEDITTHEMEOFFICEXP_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
37class _XTP_EXT_CLASS CXTPEditThemeOfficeXP : public CXTPEditThemeOffice2000
38{
39public:
44 CXTPEditThemeOfficeXP();
45
50 virtual ~CXTPEditThemeOfficeXP();
51
58 virtual void RefreshMetrics(CXTPEdit* pEdit);
59
68 virtual void DrawNcBorders(CDC* pDC, CRect rcWnd, CXTPEdit* pEdit);
69
81 virtual BOOL AdjustBuddyRect(CWnd* pBuddy, CRect& rcUpDown, int nAlignment);
82
94 virtual void DrawBuddyBorders(CWnd* pBuddy, CDC* pDC, CRect rc, int nAlignment,
95 CXTPEdit* pEdit);
96
97# if _MSC_VER > 1200
98 using CXTPEditThemeDefault::DrawBuddyBorders;
99# endif
100
109 virtual BOOL RedrawFocusedFrame() const;
110
111protected:
112 CXTPPaintManagerColor m_clrBorderHilite;
113 CXTPPaintManagerColor m_clrBorderDisabled;
114};
115
116# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
118#endif // __XTPEDITTHEMEOFFICEXP_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPEdit
CXTPEdit is a CEdit derived class.
Definition XTPEdit.h:129
CXTPEditThemeDefault::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
CXTPEditThemeOffice2000
CXTPEditThemeOffice2000 is a class used to perform theme drawing tasks.
Definition XTPEditThemeOffice2000.h:38
CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP is a class used to perform theme drawing tasks.
Definition XTPEditThemeOfficeXP.h:38
CXTPEditThemeOfficeXP::CXTPEditThemeOfficeXP
CXTPEditThemeOfficeXP()
Constructs a CXTPEditThemeOfficeXP object.
CXTPEditThemeOfficeXP::AdjustBuddyRect
virtual BOOL AdjustBuddyRect(CWnd *pBuddy, CRect &rcUpDown, int nAlignment)
Called by the framework to adjust the size of the area to draw the buddy control borders on.
CXTPEditThemeOfficeXP::m_clrBorderDisabled
CXTPPaintManagerColor m_clrBorderDisabled
Disabled border color.
Definition XTPEditThemeOfficeXP.h:113
CXTPEditThemeOfficeXP::DrawBuddyBorders
virtual void DrawBuddyBorders(CWnd *pBuddy, CDC *pDC, CRect rc, int nAlignment, CXTPEdit *pEdit)
Called by the framework to draw the borders for the associated buddy window.
CXTPEditThemeOfficeXP::RedrawFocusedFrame
virtual BOOL RedrawFocusedFrame() const
Called by the framework to redraw the focus rectangle for the edit control.
CXTPEditThemeOfficeXP::m_clrBorderHilite
CXTPPaintManagerColor m_clrBorderHilite
Highlighted border color.
Definition XTPEditThemeOfficeXP.h:112
CXTPEditThemeOfficeXP::DrawNcBorders
virtual void DrawNcBorders(CDC *pDC, CRect rcWnd, CXTPEdit *pEdit)
This member function is called by the theme manager to draw non-client borders for the edit control.
CXTPEditThemeOfficeXP::~CXTPEditThemeOfficeXP
virtual ~CXTPEditThemeOfficeXP()
Destructor, handles cleanup and deallocation.
CXTPEditThemeOfficeXP::RefreshMetrics
virtual void RefreshMetrics(CXTPEdit *pEdit)
This member function is called by the theme manager to refresh the visual styles used by each compone...
CXTPPaintManagerColor
The CXTPPaintManagerColor class is used to manage COLORREF values for determining default and applica...
Definition XTPColorManager.h:117


Toolkit Pro: XTPTrackUndoManager.h Source File

  • Source
  • GridControl
  • TrackControl
XTPTrackUndoManager.h
Go to the documentation of this file.
1
23#if !defined(__XTPTRACKUNDOMANAGER_H__)
24# define __XTPTRACKUNDOMANAGER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33const int XTP_ID_TRACKUNDO_GROUP = -1;
34const int XTP_ID_TRACKUNDO_SETMARKERPOSITION = 1000;
35const int XTP_ID_TRACKUNDO_ADDMARKER = 1001;
36const int XTP_ID_TRACKUNDO_DELETEMARKER = 1002;
38const int XTP_ID_TRACKUNDO_ADDBLOCK = 1003;
39const int XTP_ID_TRACKUNDO_DELETEBLOCK = 1004;
40const int XTP_ID_TRACKUNDO_SETBLOCKPOSITION = 1005;
46class _XTP_EXT_CLASS CXTPTrackUndoCommand
47{
48protected:
54 CXTPTrackUndoCommand(int nID);
55
61 virtual ~CXTPTrackUndoCommand();
62
63public:
70 int GetID() const;
71
72protected:
80 virtual void Undo();
81
82protected:
83 const int m_nID;
85 friend class CXTPTrackUndoManager;
86 friend class CXTPTrackUndoGroupCommand;
87};
88
93class _XTP_EXT_CLASS CXTPTrackUndoGroupCommand : public CXTPTrackUndoCommand
94{
95protected:
101 CXTPTrackUndoGroupCommand(CXTPTrackUndoManager* pManager);
102
108 virtual ~CXTPTrackUndoGroupCommand();
109
110public:
118 virtual void Undo();
119
126 int GetCount() const;
127
133 void Add(CXTPTrackUndoCommand* pCommand);
134
135protected:
136 CArray<CXTPTrackUndoCommand*, CXTPTrackUndoCommand*> m_arrUndoCommands;
138 CXTPTrackUndoManager* m_pManager;
139 friend class CXTPTrackUndoManager;
140};
141
147class _XTP_EXT_CLASS CXTPTrackUndoDeleteMarkerCommand : public CXTPTrackUndoCommand
148{
149public:
155 CXTPTrackUndoDeleteMarkerCommand(CXTPTrackMarker* pMarker);
156
162 virtual ~CXTPTrackUndoDeleteMarkerCommand();
163
164protected:
172 virtual void Undo();
173
174protected:
175 CXTPTrackMarker* m_pMarker;
176};
177
183class _XTP_EXT_CLASS CXTPTrackUndoAddMarkerCommand : public CXTPTrackUndoCommand
184{
185public:
191 CXTPTrackUndoAddMarkerCommand(CXTPTrackMarker* pMarker);
192
198 virtual ~CXTPTrackUndoAddMarkerCommand();
199
200protected:
208 virtual void Undo();
209
210protected:
211 CXTPTrackMarker* m_pMarker;
212};
213
219class _XTP_EXT_CLASS CXTPTrackUndoSetMarkerPositionCommand : public CXTPTrackUndoCommand
220{
221public:
228 CXTPTrackUndoSetMarkerPositionCommand(CXTPTrackMarker* pMarker, int nOldPosition);
229
235 virtual ~CXTPTrackUndoSetMarkerPositionCommand();
236
237protected:
245 virtual void Undo();
246
247protected:
248 CXTPTrackMarker* m_pMarker;
249 int m_nOldPosition;
250};
251
257class _XTP_EXT_CLASS CXTPTrackUndoDeleteBlockCommand : public CXTPTrackUndoCommand
258{
259public:
265 CXTPTrackUndoDeleteBlockCommand(CXTPTrackBlock* pBlock);
266
272 virtual ~CXTPTrackUndoDeleteBlockCommand();
273
274protected:
282 virtual void Undo();
283
284protected:
285 CXTPTrackBlock* m_pBlock;
286 CXTPTrackControlItem* m_pOldItem;
287};
288
294class _XTP_EXT_CLASS CXTPTrackUndoAddBlockCommand : public CXTPTrackUndoCommand
295{
296public:
302 CXTPTrackUndoAddBlockCommand(CXTPTrackBlock* pBlock);
303
309 virtual ~CXTPTrackUndoAddBlockCommand();
310
311protected:
319 virtual void Undo();
320
321protected:
322 CXTPTrackBlock* m_pBlock;
323};
324
330class _XTP_EXT_CLASS CXTPTrackUndoSetBlockPositionCommand : public CXTPTrackUndoCommand
331{
332public:
340 CXTPTrackUndoSetBlockPositionCommand(CXTPTrackBlock* pBlock, int nOldPosition, int nOldLength);
341
347 virtual ~CXTPTrackUndoSetBlockPositionCommand();
348
349protected:
357 virtual void Undo();
358
359protected:
360 CXTPTrackBlock* m_pBlock;
361 int m_nOldPosition;
362 int m_nOldLength;
363};
364
370class _XTP_EXT_CLASS CXTPTrackUndoManager : public CXTPCmdTarget
371{
372public:
377 CXTPTrackUndoManager();
378
384 ~CXTPTrackUndoManager();
385
386public:
391 void Undo();
392
397 void Redo();
398
405 BOOL CanUndo() const;
406
413 BOOL CanRedo() const;
414
415public:
420 void Clear();
421
427 void AddUndoCommand(CXTPTrackUndoCommand* pCommand);
428
433 void StartGroup();
434
439 void EndGroup();
440
441protected:
442 CArray<CXTPTrackUndoCommand*, CXTPTrackUndoCommand*> m_arrUndoCommands;
444 CArray<CXTPTrackUndoCommand*, CXTPTrackUndoCommand*> m_arrRedoCommands;
447 int m_nUndoContext;
448 CXTPTrackUndoGroupCommand* m_pUndoGroup;
450# ifdef _XTP_ACTIVEX
452 DECLARE_DISPATCH_MAP()
453 DECLARE_INTERFACE_MAP()
454 DECLARE_OLETYPELIB_EX(CXTPTrackUndoManager);
456# endif
457};
458
459AFX_INLINE int CXTPTrackUndoCommand::GetID() const
460{
461 return m_nID;
462}
464# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
465#endif //#if !defined(__XTPTRACKUNDOMANAGER_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
XTP_ID_TRACKUNDO_SETBLOCKPOSITION
const int XTP_ID_TRACKUNDO_SETBLOCKPOSITION
The undo set block position command.
Definition XTPTrackUndoManager.h:40
XTP_ID_TRACKUNDO_DELETEBLOCK
const int XTP_ID_TRACKUNDO_DELETEBLOCK
The undo delete block command.
Definition XTPTrackUndoManager.h:39
XTP_ID_TRACKUNDO_DELETEMARKER
const int XTP_ID_TRACKUNDO_DELETEMARKER
The undo delete marker command.
Definition XTPTrackUndoManager.h:36
XTP_ID_TRACKUNDO_GROUP
const int XTP_ID_TRACKUNDO_GROUP
The undo group command.
Definition XTPTrackUndoManager.h:33
XTP_ID_TRACKUNDO_SETMARKERPOSITION
const int XTP_ID_TRACKUNDO_SETMARKERPOSITION
The undo set marker position command.
Definition XTPTrackUndoManager.h:34
XTP_ID_TRACKUNDO_ADDBLOCK
const int XTP_ID_TRACKUNDO_ADDBLOCK
The undo add block command.
Definition XTPTrackUndoManager.h:38
XTP_ID_TRACKUNDO_ADDMARKER
const int XTP_ID_TRACKUNDO_ADDMARKER
The undo add marker command.
Definition XTPTrackUndoManager.h:35
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPTrackBlock
This class represents a track control block.
Definition XTPTrackBlock.h:42
CXTPTrackControlItem
This class represents a container cell for a set of blocks and keys and inherits basic functionality ...
Definition XTPTrackControlItem.h:45
CXTPTrackMarker
This class represents a track control marker.
Definition XTPTrackBlock.h:438
CXTPTrackUndoAddBlockCommand
This class abstracts the undo add block command.
Definition XTPTrackUndoManager.h:295
CXTPTrackUndoAddBlockCommand::CXTPTrackUndoAddBlockCommand
CXTPTrackUndoAddBlockCommand(CXTPTrackBlock *pBlock)
Constructor, creates a CXTPTrackUndoAddBlockCommand object.
CXTPTrackUndoAddBlockCommand::m_pBlock
CXTPTrackBlock * m_pBlock
Pointer to the track block object.
Definition XTPTrackUndoManager.h:322
CXTPTrackUndoAddBlockCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoAddBlockCommand::~CXTPTrackUndoAddBlockCommand
virtual ~CXTPTrackUndoAddBlockCommand()
CXTPTrackUndoAddBlockCommand destructor, handles cleanup and deallocation.
CXTPTrackUndoAddMarkerCommand
This class abstracts the undo add marker command.
Definition XTPTrackUndoManager.h:184
CXTPTrackUndoAddMarkerCommand::m_pMarker
CXTPTrackMarker * m_pMarker
The track marker object.
Definition XTPTrackUndoManager.h:211
CXTPTrackUndoAddMarkerCommand::CXTPTrackUndoAddMarkerCommand
CXTPTrackUndoAddMarkerCommand(CXTPTrackMarker *pMarker)
Constructor, creates a CXTPTrackUndoDeleteMarkerCommand object.
CXTPTrackUndoAddMarkerCommand::~CXTPTrackUndoAddMarkerCommand
virtual ~CXTPTrackUndoAddMarkerCommand()
CXTPTrackUndoAddMarkerCommand destructor, handles cleanup and deallocation.
CXTPTrackUndoAddMarkerCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoCommand
This class abstracts the undo command.
Definition XTPTrackUndoManager.h:47
CXTPTrackUndoCommand::~CXTPTrackUndoCommand
virtual ~CXTPTrackUndoCommand()
CXTPTrackUndoCommand destructor, handles cleanup and deallocation.
CXTPTrackUndoCommand::GetID
int GetID() const
Call this function to get the command ID associated with this object.
Definition XTPTrackUndoManager.h:459
CXTPTrackUndoCommand::CXTPTrackUndoCommand
CXTPTrackUndoCommand(int nID)
Constructor, creates a CXTPTrackUndoCommand object.
CXTPTrackUndoCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoCommand::m_nID
const int m_nID
The command ID.
Definition XTPTrackUndoManager.h:83
CXTPTrackUndoDeleteBlockCommand
This class abstracts the undo delete block command.
Definition XTPTrackUndoManager.h:258
CXTPTrackUndoDeleteBlockCommand::m_pBlock
CXTPTrackBlock * m_pBlock
The track block object.
Definition XTPTrackUndoManager.h:285
CXTPTrackUndoDeleteBlockCommand::~CXTPTrackUndoDeleteBlockCommand
virtual ~CXTPTrackUndoDeleteBlockCommand()
CXTPTrackUndoDeleteBlockCommand destructor, handles cleanup and deallocation.
CXTPTrackUndoDeleteBlockCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoDeleteBlockCommand::CXTPTrackUndoDeleteBlockCommand
CXTPTrackUndoDeleteBlockCommand(CXTPTrackBlock *pBlock)
Constructor, creates a CXTPTrackUndoDeleteBlockCommand object.
CXTPTrackUndoDeleteBlockCommand::m_pOldItem
CXTPTrackControlItem * m_pOldItem
The old track control item.
Definition XTPTrackUndoManager.h:286
CXTPTrackUndoDeleteMarkerCommand
This class abstracts the undo delete marker command.
Definition XTPTrackUndoManager.h:148
CXTPTrackUndoDeleteMarkerCommand::m_pMarker
CXTPTrackMarker * m_pMarker
The track marker object.
Definition XTPTrackUndoManager.h:175
CXTPTrackUndoDeleteMarkerCommand::CXTPTrackUndoDeleteMarkerCommand
CXTPTrackUndoDeleteMarkerCommand(CXTPTrackMarker *pMarker)
Constructor, creates a CXTPTrackUndoDeleteMarkerCommand object.
CXTPTrackUndoDeleteMarkerCommand::~CXTPTrackUndoDeleteMarkerCommand
virtual ~CXTPTrackUndoDeleteMarkerCommand()
CXTPTrackUndoDeleteMarkerCommand destructor, handles cleanup and deallocation.
CXTPTrackUndoDeleteMarkerCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoGroupCommand
This class abstracts the undo commands in a group.
Definition XTPTrackUndoManager.h:94
CXTPTrackUndoGroupCommand::Add
void Add(CXTPTrackUndoCommand *pCommand)
Call this function to add a command to the command group.
CXTPTrackUndoGroupCommand::CXTPTrackUndoGroupCommand
CXTPTrackUndoGroupCommand(CXTPTrackUndoManager *pManager)
Constructor, creates a CXTPTrackUndoCommand object.
CXTPTrackUndoGroupCommand::GetCount
int GetCount() const
Call this function to get the number of command objects in this group.
CXTPTrackUndoGroupCommand::~CXTPTrackUndoGroupCommand
virtual ~CXTPTrackUndoGroupCommand()
CXTPTrackUndoGroupCommand destructor, handles cleanup and deallocation.
CXTPTrackUndoGroupCommand::m_arrUndoCommands
CArray< CXTPTrackUndoCommand *, CXTPTrackUndoCommand * > m_arrUndoCommands
The command collection.
Definition XTPTrackUndoManager.h:136
CXTPTrackUndoGroupCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoGroupCommand::m_pManager
CXTPTrackUndoManager * m_pManager
The undo manager.
Definition XTPTrackUndoManager.h:138
CXTPTrackUndoManager
This class abstracts an undo manager.
Definition XTPTrackUndoManager.h:371
CXTPTrackUndoManager::Undo
void Undo()
Call this function to do the undo operation.
CXTPTrackUndoManager::m_arrUndoCommands
CArray< CXTPTrackUndoCommand *, CXTPTrackUndoCommand * > m_arrUndoCommands
The undo commands array.
Definition XTPTrackUndoManager.h:442
CXTPTrackUndoManager::CanUndo
BOOL CanUndo() const
Determines if the undo operation is possible in the current context.
CXTPTrackUndoManager::EndGroup
void EndGroup()
Call this function to end an undo group command.
CXTPTrackUndoManager::m_pUndoGroup
CXTPTrackUndoGroupCommand * m_pUndoGroup
The undo group command.
Definition XTPTrackUndoManager.h:448
CXTPTrackUndoManager::StartGroup
void StartGroup()
Call this function to start an undo group command.
CXTPTrackUndoManager::m_arrRedoCommands
CArray< CXTPTrackUndoCommand *, CXTPTrackUndoCommand * > m_arrRedoCommands
The redo command array.
Definition XTPTrackUndoManager.h:444
CXTPTrackUndoManager::Clear
void Clear()
Call this function to clear the list of undo and redo operations.
CXTPTrackUndoManager::CXTPTrackUndoManager
CXTPTrackUndoManager()
Constructor, creates a CXTPTrackUndoManager object.
CXTPTrackUndoManager::~CXTPTrackUndoManager
~CXTPTrackUndoManager()
CXTPTrackUndoManager destructor, handles cleanup and deallocation.
CXTPTrackUndoManager::m_nUndoContext
int m_nUndoContext
The undo context.
Definition XTPTrackUndoManager.h:447
CXTPTrackUndoManager::CanRedo
BOOL CanRedo() const
Determines if the redo operation is possible in the current context.
CXTPTrackUndoManager::Redo
void Redo()
Call this function to do the redo operation.
CXTPTrackUndoManager::AddUndoCommand
void AddUndoCommand(CXTPTrackUndoCommand *pCommand)
Adds an undo command to the collection of undo commands.
CXTPTrackUndoSetBlockPositionCommand
This class abstracts the undo set block position command.
Definition XTPTrackUndoManager.h:331
CXTPTrackUndoSetBlockPositionCommand::~CXTPTrackUndoSetBlockPositionCommand
virtual ~CXTPTrackUndoSetBlockPositionCommand()
CXTPTrackUndoSetBlockPositionCommand destructor, handles cleanup and deallocation.
CXTPTrackUndoSetBlockPositionCommand::m_nOldPosition
int m_nOldPosition
Old position of the block.
Definition XTPTrackUndoManager.h:361
CXTPTrackUndoSetBlockPositionCommand::m_pBlock
CXTPTrackBlock * m_pBlock
Pointer to the track block object.
Definition XTPTrackUndoManager.h:360
CXTPTrackUndoSetBlockPositionCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoSetBlockPositionCommand::CXTPTrackUndoSetBlockPositionCommand
CXTPTrackUndoSetBlockPositionCommand(CXTPTrackBlock *pBlock, int nOldPosition, int nOldLength)
Constructor, creates a CXTPTrackUndoSetBlockPositionCommand object.
CXTPTrackUndoSetBlockPositionCommand::m_nOldLength
int m_nOldLength
Old length of the block.
Definition XTPTrackUndoManager.h:362
CXTPTrackUndoSetMarkerPositionCommand
This class abstracts the undo set marker position command.
Definition XTPTrackUndoManager.h:220
CXTPTrackUndoSetMarkerPositionCommand::m_pMarker
CXTPTrackMarker * m_pMarker
The track marker object.
Definition XTPTrackUndoManager.h:248
CXTPTrackUndoSetMarkerPositionCommand::m_nOldPosition
int m_nOldPosition
Old position of the marker.
Definition XTPTrackUndoManager.h:249
CXTPTrackUndoSetMarkerPositionCommand::CXTPTrackUndoSetMarkerPositionCommand
CXTPTrackUndoSetMarkerPositionCommand(CXTPTrackMarker *pMarker, int nOldPosition)
Constructor, creates a CXTPTrackUndoSetMarkerPositionCommand object.
CXTPTrackUndoSetMarkerPositionCommand::Undo
virtual void Undo()
Call this function to do the undo operation.
CXTPTrackUndoSetMarkerPositionCommand::~CXTPTrackUndoSetMarkerPositionCommand
virtual ~CXTPTrackUndoSetMarkerPositionCommand()
CXTPTrackUndoSetMarkerPositionCommand destructor, handles cleanup and deallocation.


CXTPStatusBarThemeVisualStudio2019 Member List

This is the complete list of members for CXTPStatusBarThemeVisualStudio2019, including all inherited members.

CXTPStatusBarThemeOffice2013(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeOffice2013 |
CXTPStatusBarThemeVisualStudio2019(CXTPPaintManager *pPaintManager) | CXTPStatusBarThemeVisualStudio2019 |
DrawStatusBarButtonFace(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarGripper(CDC *pDC, CRect rcClient) | CXTPStatusBarThemeVisualStudio2019 | virtual
DrawStatusBarPaneBorder(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane, BOOL bGripperPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneEntry(CDC *pDC, CRect rcItem, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarPaneSeparator(CDC *pDC, CRect rc, CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
DrawStatusBarSwitchPane(CDC *pDC, CRect rcItem, CXTPStatusBarSwitchPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
FillStatusBar(CDC *pDC, CXTPStatusBar *pBar) | CXTPStatusBarThemeOffice2013 | virtual
GetStateColor() const | CXTPStatusBarThemeVisualStudio2019 | virtual
GetTextColor(CXTPStatusBarPane *pPane) | CXTPStatusBarThemeOffice2013 | virtual
m_clrButtonBack | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonBackPushed | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextChecked | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextHighlight | CXTPStatusBarThemeOffice2013 | protected
m_clrButtonTextPushed | CXTPStatusBarThemeOffice2013 | protected
RefreshMetrics() | CXTPStatusBarThemeVisualStudio2019 | virtual
SetStateColor(COLORREF clrState) | CXTPStatusBarThemeVisualStudio2019 | virtual
~CXTPStatusBarThemeVisualStudio2019() | CXTPStatusBarThemeVisualStudio2019 |


Toolkit Pro: XTPMarkupWrapPanel.h Source File

  • Source
  • Markup
  • Controls
XTPMarkupWrapPanel.h
Go to the documentation of this file.
1
23#if !defined(__XTPMARKUPWRAPPANEL_H__)
24# define __XTPMARKUPWRAPPANEL_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPMarkupDependencyProperty;
34class CXTPMarkupDrawingContext;
35
41class _XTP_EXT_CLASS CXTPMarkupWrapPanel : public CXTPMarkupPanel
42{
44 DECLARE_MARKUPCLASS(CXTPMarkupWrapPanel)
46protected:
51 CXTPMarkupWrapPanel();
52
57 virtual ~CXTPMarkupWrapPanel();
58
59public:
67 void SetOrientation(XTPMarkupOrientation orientation);
68
77 XTPMarkupOrientation GetOrientation() const;
78
79protected:
81 // Implementation
82
83 virtual CSize MeasureOverride(CXTPMarkupDrawingContext* pDC, CSize szAvailableSize);
84 virtual CSize ArrangeOverride(CSize szFinalSize);
85
86protected:
87 void ArrangeLine(int nPanelHeight, int nLineHeight, int nFirstElement, int nCount);
88
89public:
90 static CXTPMarkupDependencyProperty* m_pOrientationProperty;
91 static CXTPMarkupDependencyProperty* m_pItemHeightProperty;
92 static CXTPMarkupDependencyProperty* m_pItemWidthProperty;
93
97public:
98 DECLARE_DISPATCH_MAP()
99# ifdef _XTP_ACTIVEX
100 DECLARE_INTERFACE_MAP()
101 DECLARE_OLETYPELIB_EX(CXTPMarkupWrapPanel);
102# endif
103
104 afx_msg long OleGetOrientation();
105 afx_msg void OleSetOrientation(long nValue);
106
108};
109
110# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
112#endif // !defined(__XTPMARKUPWRAPPANEL_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPMarkupPanel
CXTPMarkupPanel is a CXTPMarkupFrameworkElement derived class.
Definition XTPMarkupPanel.h:48
CXTPMarkupWrapPanel
CXTPMarkupWrapPanel is a CXTPMarkupPanel derived class.
Definition XTPMarkupWrapPanel.h:42
CXTPMarkupWrapPanel::GetOrientation
XTPMarkupOrientation GetOrientation() const
Retrieves the current orientation of child elements inside WrapPanel.
CXTPMarkupWrapPanel::SetOrientation
void SetOrientation(XTPMarkupOrientation orientation)
Sets the orientation of child elements inside WrapPanel.
CXTPMarkupWrapPanel::~CXTPMarkupWrapPanel
virtual ~CXTPMarkupWrapPanel()
Destroys a CXTPMarkupWrapPanel object, handles cleanup and deallocation.
CXTPMarkupWrapPanel::CXTPMarkupWrapPanel
CXTPMarkupWrapPanel()
Constructs a CXTPMarkupWrapPanel object.


Toolkit Pro: XTPDockingPanePanelThemeNativeWindows11.h Source File

  • Source
  • DockingPane
  • TabThemes
XTPDockingPanePanelThemeNativeWindows11.h
Go to the documentation of this file.
1
23#if !defined(__XTPDOCKINGPANEPANELTHEMENATIVEWINDOWS11_H__)
24# define __XTPDOCKINGPANEPANELTHEMENATIVEWINDOWS11_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPDockingPanePanelThemeNativeWindows11 : public CXTPDockingPanePanelTheme2012
39{
40public:
45 CXTPDockingPanePanelThemeNativeWindows11();
46};
47
48# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
50#endif // !defined(__XTPDOCKINGPANEPANELTHEMENATIVEWINDOWS11_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPDockingPanePanelTheme2012
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelTheme2012.h:39
CXTPDockingPanePanelThemeNativeWindows11
Helper class used to initialize default colors for a theme from an .INI resource and handle drawing r...
Definition XTPDockingPanePanelThemeNativeWindows11.h:39
CXTPDockingPanePanelThemeNativeWindows11::CXTPDockingPanePanelThemeNativeWindows11
CXTPDockingPanePanelThemeNativeWindows11()
Default class constructor.


Toolkit Pro: XTPGridPageSetupDialog.h Source File

  • Source
  • GridControl
XTPGridPageSetupDialog.h
Go to the documentation of this file.
1
23#if !defined(__XTPGRIDPAGESETUPDIALOG_H__)
24# define __XTPGRIDPAGESETUPDIALOG_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
39class _XTP_EXT_CLASS CXTPGridViewPrintOptions : public CXTPPrintOptions
40{
42 DECLARE_DYNAMIC(CXTPGridViewPrintOptions)
45public:
50 CXTPGridViewPrintOptions();
51
59 virtual LCID GetActiveLCID();
60
66 virtual void Set(const CXTPGridViewPrintOptions* pSrc);
67
68 BOOL m_bRepeatHeaderRows;
70 BOOL m_bRepeatFooterRows;
73protected:
75# ifdef _XTP_ACTIVEX
76 DECLARE_DISPATCH_MAP()
77 DECLARE_INTERFACE_MAP()
78
79 DECLARE_OLETYPELIB_EX(CXTPGridViewPrintOptions);
80# endif
82};
83
100class _XTP_EXT_CLASS CXTPGridPageSetupDialog : public CPageSetupDialog
101{
102public:
104 enum
105 {
106 IDD = XTP_IDD_GRID_PRINT_PAGE_SETUP
107 };
124 CXTPGridPageSetupDialog(CXTPGridViewPrintOptions* pOptions,
125 DWORD dwFlags = PSD_MARGINS | PSD_INWININIINTLMEASURE,
126 CWnd* pParentWnd = NULL);
127
132 virtual ~CXTPGridPageSetupDialog();
133
134protected:
135 CXTPGridViewPrintOptions* m_pOptions;
146 virtual BOOL OnInitDialog();
147
156 virtual void OnOK();
157
159 CEdit m_ctrlHeaderFormat;
160 CEdit m_ctrlFooterFormat;
161
162 CButton m_ctrlHeaderFormatBtn;
163 CButton m_ctrlFooterFormatBtn;
164
165 afx_msg void OnBnClickedHeaderFormat();
166 afx_msg void OnBnClickedFooterFormat();
167
168 DECLARE_MESSAGE_MAP()
170};
171
172# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
174#endif // !defined(__XTPGRIDPAGESETUPDIALOG_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPGridPageSetupDialog
Customized Grid control page setup dialog.
Definition XTPGridPageSetupDialog.h:101
CXTPGridPageSetupDialog::CXTPGridPageSetupDialog
CXTPGridPageSetupDialog(CXTPGridViewPrintOptions *pOptions, DWORD dwFlags=PSD_MARGINS|PSD_INWININIINTLMEASURE, CWnd *pParentWnd=NULL)
Class constructor.
CXTPGridPageSetupDialog::~CXTPGridPageSetupDialog
virtual ~CXTPGridPageSetupDialog()
Destroys a CXTPGridPageSetupDialog object, handles cleanup and deallocation.
CXTPGridPageSetupDialog::OnInitDialog
virtual BOOL OnInitDialog()
Dialog-box initialization.
CXTPGridPageSetupDialog::OnOK
virtual void OnOK()
Called when the user clicks the OK button (i.e.
CXTPGridPageSetupDialog::m_pOptions
CXTPGridViewPrintOptions * m_pOptions
Pointer to associated print options object.
Definition XTPGridPageSetupDialog.h:135
CXTPGridViewPrintOptions
This class is used to store printing options.
Definition XTPGridPageSetupDialog.h:40
CXTPGridViewPrintOptions::m_bRepeatFooterRows
BOOL m_bRepeatFooterRows
If TRUE, then the footer rows will be printed on every page.
Definition XTPGridPageSetupDialog.h:70
CXTPGridViewPrintOptions::CXTPGridViewPrintOptions
CXTPGridViewPrintOptions()
Constructs a CXTPGridViewPrintOptions object.
CXTPGridViewPrintOptions::GetActiveLCID
virtual LCID GetActiveLCID()
Override this member function in a derived class to retrieve the active locale ID.
CXTPGridViewPrintOptions::m_bRepeatHeaderRows
BOOL m_bRepeatHeaderRows
If TRUE, then the header rows will be printed on every page.
Definition XTPGridPageSetupDialog.h:68
CXTPGridViewPrintOptions::Set
virtual void Set(const CXTPGridViewPrintOptions *pSrc)
Copies members from a specified source object.


CXTPListBoxTheme Member List

This is the complete list of members for CXTPListBoxTheme, including all inherited members.

DrawItem(CDC *pDC, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS)=0 | CXTPListBoxTheme | pure virtual
DrawItemText(CDC *pDC, CRect rcText, CXTPListBox *pListBox, LPDRAWITEMSTRUCT lpDIS) | CXTPListBoxTheme | virtual
DrawNcBorders(CDC *pDC, CRect rc) | CXTPListBoxTheme | virtual
GetBackColor() | CXTPListBoxTheme | virtual
RefreshMetrics()=0 | CXTPListBoxTheme | pure virtual
~CXTPListBoxTheme() | CXTPListBoxTheme | inlinevirtual


Toolkit Pro: XTPFlowGraphDrawContext.h Source File

  • Source
  • FlowGraph
XTPFlowGraphDrawContext.h
Go to the documentation of this file.
1
23#if !defined(__XTPFLOWGRAPHDRAWCONTEXT_H__)
24# define __XTPFLOWGRAPHDRAWCONTEXT_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPFlowGraphControl;
34class CXTPFlowGraphImage;
35class CXTPMarkupUIElement;
36
37namespace Gdiplus
38{
39class Graphics;
40class GraphicsPath;
41} // namespace Gdiplus
42
43class _XTP_EXT_CLASS CXTPFlowGraphDrawContext
44{
45public:
50 CXTPFlowGraphDrawContext(HDC hDC, HDC hAttribDC = NULL, BOOL bPrinting = FALSE,
51 BOOL bSaveToFile = FALSE);
57 virtual ~CXTPFlowGraphDrawContext();
58
59public:
66 HDC GetHDC() const;
67
68 virtual Gdiplus::Graphics* GetGraphics() const
69 {
70 return NULL;
71 }
72
73 BOOL IsPrinting() const;
74
75 BOOL IsSavingToFile() const;
76
77 void SetSaveToFile(BOOL bSaveToFile = TRUE);
78
79public:
80 virtual CSize MeasureMarkupElement(CXTPMarkupUIElement* pMarkupUIElement);
81 virtual void DrawMarkupElement(CXTPMarkupUIElement* pMarkupUIElement, LPCRECT lpRect,
82 UINT uFormat);
83
84 virtual CSize MeasureString(const CString& str);
85
86 virtual void SetClipRect(CRect rc);
87 virtual CRect GetClipRect() const;
88
89 virtual void DrawGrid(CRect rc, CPoint ptScrollOffset, double dZoomLevel,
90 COLORREF clrGridColor);
91
92 virtual void SetSmoothingMode(int nMode);
93
94public:
95 virtual void FillSolidRect(LPCRECT lpRect, COLORREF clr);
96 virtual void FillSolidRect(int x, int y, int cx, int cy, COLORREF clr);
97
98 virtual void GradientFill(CRect rc, COLORREF clrFrom, COLORREF clrTo, BOOL bHoriz);
99
100 virtual void Draw3dRect(int x, int y, int cx, int cy, COLORREF clrTopLeft,
101 COLORREF clrBottomRight);
102 virtual void Draw3dRect(LPCRECT lpRect, COLORREF clrTopLeft, COLORREF clrBottomRight);
103
104 virtual void DrawFrame(int x, int y, int cx, int cy, int sz, COLORREF clr);
105
106 virtual void DrawText(LPCTSTR lpszText, LPCRECT lpRect, UINT uFormat);
107
108 virtual void DrawCurve(Gdiplus::GraphicsPath* pPath);
109
110 virtual void Clear(COLORREF clr);
111
112 virtual void Line(float x1, float y1, float x2, float y2);
113
114 virtual void Line(CPoint p1, CPoint p2);
115
116 virtual void Ellipse(LPCRECT lpRect);
117
118 virtual void SetWorldTransform(CPoint ptOffset, double dZoomLevel);
119
120 virtual void SetBrush(COLORREF clr);
121 virtual void SetPen(COLORREF clrPen, int nWidth, BOOL bDashed = FALSE);
122 virtual void SetFont(LOGFONT* lf);
123 virtual void SetTextColor(COLORREF clr);
124
125 virtual void DrawImage(CXTPFlowGraphImage* pImage, CRect rc);
126 virtual void DrawSelectionRect(CRect rc);
127
128 virtual void FillPolygon(const POINT* pts, int nCount);
129
130# ifdef _XTP_DEMOMODE
131 virtual void DrawWatermarkBackground(CRect rc);
132# endif
133
134public:
135protected:
136 HDC m_hDC;
137 BOOL m_bPrinting;
138 BOOL m_bSaveToFile;
139 HBRUSH m_hActiveBrush;
140 HPEN m_hActivePen;
141 HFONT m_hActiveFont;
142
143 CRect m_rcClipRect;
144
145 CXTPFlowGraphGDIHandles<CXTPFlowGraphFontTraits> m_arrFonts;
146 CXTPFlowGraphGDIHandles<CXTPFlowGraphBrushTraits> m_arrBrushes;
147};
148
149AFX_INLINE HDC CXTPFlowGraphDrawContext::GetHDC() const
150{
151 return m_hDC;
152}
153AFX_INLINE BOOL CXTPFlowGraphDrawContext::IsPrinting() const
154{
155 return m_bPrinting;
156}
157
158AFX_INLINE BOOL CXTPFlowGraphDrawContext::IsSavingToFile() const
159{
160 return m_bSaveToFile;
161}
162
163AFX_INLINE void CXTPFlowGraphDrawContext::SetSaveToFile(BOOL bSaveToFile)
164{
165 m_bSaveToFile = bSaveToFile;
166}
168# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
169#endif //#if !defined(__XTPFLOWGRAPHDRAWCONTEXT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPFlowGraphControl
Flow Graph Control.
Definition XTPFlowGraphControl.h:173
CXTPFlowGraphImage
Object used to represent an image displayed in a Node or connection point.
Definition XTPFlowGraphImage.h:49
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43


Toolkit Pro: XTPPropExchangeSection.h Source File

  • Source
  • Common
  • PropExchange
XTPPropExchangeSection.h
Go to the documentation of this file.
1
23#if !defined(__XTPPROPEXCHANGESECTION_H__)
24# define __XTPPROPEXCHANGESECTION_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPPropExchange;
34
45class _XTP_EXT_CLASS CXTPPropExchangeSection
46{
47public:
54 explicit CXTPPropExchangeSection(CXTPPropExchange* pPX);
55
62 CXTPPropExchangeSection(BOOL bLoading, LPCTSTR lpszSection);
63
69 virtual ~CXTPPropExchangeSection();
70
71 CXTPPropExchange& operator*() const;
72 CXTPPropExchange* operator->() const;
73 CXTPPropExchange* operator&() const;
74
75private:
76 CXTPPropExchange* m_pPX;
77};
78
79# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
81#endif // !defined(__XTPPROPEXCHANGESECTION_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPropExchange
CXTPPropExchange is standalone pure class.
Definition XTPPropExchange.h:72
CXTPPropExchangeSection
CXTPPropExchangeSection is standalone class.
Definition XTPPropExchangeSection.h:46
CXTPPropExchangeSection::CXTPPropExchangeSection
CXTPPropExchangeSection(BOOL bLoading, LPCTSTR lpszSection)
Constructs CXTPPropExchangeSection object and automatically assign m_pPX .
CXTPPropExchangeSection::CXTPPropExchangeSection
CXTPPropExchangeSection(CXTPPropExchange *pPX)
Constructs CXTPPropExchangeSection a object.
CXTPPropExchangeSection::~CXTPPropExchangeSection
virtual ~CXTPPropExchangeSection()
Destroys a CXTPPropExchangeSection object, handles cleanup and deallocation.


Toolkit Pro: XTPButtonThemeFlat.h Source File

  • Source
  • Controls
  • Button
  • Themes
XTPButtonThemeFlat.h
Go to the documentation of this file.
1
23#if !defined(__XTPBUTTONTHEMEFLAT_H__)
24# define __XTPBUTTONTHEMEFLAT_H__
27# if _MSC_VER >= 1000
28# pragma once
29# endif // _MSC_VER >= 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPButtonThemeFlat : public CXTPButtonTheme
39{
40public:
45 CXTPButtonThemeFlat();
46
53 void DrawButtonBackground(CDC* pDC, CXTPButton* pButton);
54};
55
56# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
58#endif //#if !defined(__XTPBUTTONTHEMEFLAT_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonThemeFlat
CXTPButtonThemeFlat is a class used to perform Flat Theme drawing tasks.
Definition XTPButtonThemeFlat.h:39
CXTPButtonThemeFlat::CXTPButtonThemeFlat
CXTPButtonThemeFlat()
Constructs a CXTPButtonThemeFlat object.
CXTPButtonThemeFlat::DrawButtonBackground
void DrawButtonBackground(CDC *pDC, CXTPButton *pButton)
This member function is called to draw the background for a button.
CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks.
Definition XTPButtonTheme.h:51


CXTPDockBar Member List

This is the complete list of members for CXTPDockBar, including all inherited members.

CToolBarArray typedef | CXTPDockBar |
CXTPDockBar() | CXTPDockBar |
GetPosition() const | CXTPDockBar |
IsVerticalPosition() const | CXTPDockBar |
m_arrBars | CXTPDockBar | protected
m_dwStyle | CXTPDockBar | protected
m_pCommandBars | CXTPDockBar | protected
~CXTPDockBar() | CXTPDockBar | virtual


CXTPRibbonControlSystemButton Member List

This is the complete list of members for CXTPRibbonControlSystemButton, including all inherited members.

AdjustExcludeRect(CRect &rc, BOOL bVertical) | CXTPRibbonControlSystemButton | protectedvirtual
AssignDocTemplate(UINT nIDResource) | CXTPControl |
ClickToolBarButton(CRect rcActiveRect=CRect(0, 0, 0, 0)) | CXTPControl | protected
Compare(CXTPControl *pOther) | CXTPControlPopup | protectedvirtual
ContainsPopup(CXTPControlPopup *pControlPopup) | CXTPControlPopup | protected
Copy(CXTPControl *pControl, BOOL bRecursive=FALSE) | CXTPControlPopup | virtual
CreateControlPopup(XTPControlType controlType) | CXTPControlPopup | static
CustomizeStartDrag(CPoint point) | CXTPControl | protectedvirtual
CustomizeStartResize(CPoint point) | CXTPControl | protectedvirtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPControl() | CXTPControl | protected
CXTPControlButton() | CXTPControlButton |
CXTPControlPopup() | CXTPControlPopup |
CXTPRibbonControlSystemButton() | CXTPRibbonControlSystemButton |
DelayLayoutParent() | CXTPControl |
DelayRedrawParent() | CXTPControl |
DoCustomDragOver(CXTPCommandBar *pCommandBar, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
DoPropExchange(CXTPPropExchange *pPX) | CXTPControlPopup | virtual
Draw(CDC *pDC) | CXTPRibbonControlSystemButton | virtual
ExcludeDocTemplate(UINT nIDResource) | CXTPControl |
ExpandCommandBar() | CXTPControlPopup | protected
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
FromUI(CCmdUI *pCmdUI) | CXTPControl | static
GenerateCommandBarList(DWORD &nID, CXTPCommandBarList *pCommandBarList, XTP_COMMANDBARS_PROPEXCHANGE_PARAM *pParam) | CXTPControl | protectedvirtual
GetAction() const | CXTPControl |
GetBeginGroup() const | CXTPControl |
GetButtonSize() const | CXTPControl | virtual
GetCaption() const | CXTPRibbonControlSystemButton | virtual
GetCategory() const | CXTPControl |
GetChecked() const | CXTPControl |
GetCloseSubMenuOnClick() const | CXTPControl |
GetCommandBar() const | CXTPControlPopup | virtual
GetControls() const | CXTPControl |
GetCustomizeMinHeight() const | CXTPControl | protectedvirtual
GetCustomizeMinWidth() const | CXTPControl | protectedvirtual
GetCustomShortcutText() const | CXTPControl |
GetDescription() const | CXTPControl | virtual
GetEnabled() const | CXTPControl |
GetExecuteOnPressInterval() const | CXTPControl |
GetExpanded() const | CXTPControl |
GetFlags() const | CXTPControl |
GetHeight() const | CXTPControl |
GetHelpId() const | CXTPControl |
GetHideFlags() const | CXTPControl |
GetIconId() const | CXTPControl |
GetIconSize() const | CXTPControl | virtual
GetID() const | CXTPControl |
GetImage(int nWidth=16) const | CXTPControl | virtual
GetImageManager() const | CXTPControl |
GetIndex() const | CXTPControl |
GetKeyboardTip() const | CXTPControl |
GetPaintManager() const | CXTPControl |
GetParameter() const | CXTPControl |
GetParent() const | CXTPControl |
GetPopuped() const | CXTPControlPopup | virtual
GetPressed() const | CXTPControl | virtual
GetRect() const | CXTPControl |
GetRibbonGroup() const | CXTPControl |
GetRowRect() const | CXTPControl |
GetSelected() const | CXTPControl | virtual
GetShortcutText() const | CXTPControl |
GetSize(CDC *pDC) | CXTPRibbonControlSystemButton | virtual
GetStyle() const | CXTPControl |
GetStyleEx() const | CXTPControlButton |
GetTag() const | CXTPControl |
GetTooltip() const | CXTPControl | virtual
GetType() const | CXTPControl |
GetWidth() const | CXTPControl |
GetWrap() const | CXTPControl |
HasDwmCompositedRect() const | CXTPControl |
IsCaptionVisible() const | CXTPControl | virtual
IsCursorOver() const | CXTPControl |
IsCustomizeMode() const | CXTPControl | protected
IsCustomizeMovable() const | CXTPControl | virtual
IsCustomizeResizeAllow() const | CXTPControl | protectedvirtual
IsFocusable() const | CXTPControl | protectedvirtual
IsFocused() const | CXTPControl | virtual
IsItemDefault() const | CXTPControl |
IsLayoutChanged() | CXTPControl | protected
IsLayoutRTL() const | CXTPControl | protected
IsOnQuickAccess() const | CXTPControl |
IsSimpleButton() const | CXTPRibbonControlSystemButton |
IsTemporary() const | CXTPControl |
IsTransparent() const | CXTPControl | inlinevirtual
IsVisible(DWORD dwSkipFlags=0) const | CXTPControl | virtual
m_bBeginGroup | CXTPControl | protected
m_bChecked | CXTPControl | protected
m_bCloseSubMenuOnClick | CXTPControl | protected
m_bDefaultItem | CXTPControl | protected
m_bEnabled | CXTPControl | protected
m_bExpanded | CXTPControl | protected
m_bLayoutRTL | CXTPControl | protected
m_bOnQuickAccess | CXTPControl | protected
m_bPopup | CXTPControlPopup | protected
m_bPressed | CXTPControl | protected
m_bSelected | CXTPControl | protected
m_bShowShadow | CXTPControlPopup | protected
m_bTemporary | CXTPControl | protected
m_buttonCustomStyle | CXTPControl | protected
m_buttonRibbonStyle | CXTPControl | protected
m_buttonStyle | CXTPControl | protected
m_buttonStyleEx | CXTPControlButton | protected
m_bWrap | CXTPControl | protected
m_controlType | CXTPControl | protected
m_dwCommandBarID | CXTPControlPopup | protected
m_dwFlags | CXTPControl | protected
m_dwHideFlags | CXTPControl | protected
m_mapDocTemplatesAssigned | CXTPControl | protected
m_mapDocTemplatesExcluded | CXTPControl | protected
m_nCustomIconId | CXTPControl | protected
m_nExecuteOnPressInterval | CXTPControl | protected
m_nHeight | CXTPControl | protected
m_nHelpId | CXTPControl | protected
m_nIconId | CXTPControl | protected
m_nId | CXTPControl | protected
m_nIndex | CXTPControl | protected
m_nTag | CXTPControl | protected
m_nWidth | CXTPControl | protected
m_pAction | CXTPControl | protected
m_pCommandBar | CXTPControlPopup | protected
m_pControls | CXTPControl | protected
m_pParent | CXTPControl | protected
m_pRibbonGroup | CXTPControl | protected
m_rcControl | CXTPControl | protected
m_rcRow | CXTPControl | protected
m_strCaption | CXTPControl | protected
m_strCategory | CXTPControl | protected
m_strCustomCaption | CXTPControl | protected
m_strDescriptionText | CXTPControl | protected
m_strKeyboardTip | CXTPControl | protected
m_strParameter | CXTPControl | protected
m_strShortcutText | CXTPControl | protected
m_strShortcutTextAuto | CXTPControl | protected
m_strTooltipText | CXTPControl | protected
m_szIcon | CXTPControl | protected
NotifySite(UINT code) | CXTPControl |
NotifySite(UINT code, NMXTPCONTROL *pNM) | CXTPControl |
NotifySite(CWnd *pSite, UINT code, NMXTPCONTROL *pNM) | CXTPControl |
OnActionChanged(int nProperty) | CXTPControl | protectedvirtual
OnActionChanging(int nProperty) | CXTPControl | protectedvirtual
OnCalcDynamicSize(DWORD dwMode) | CXTPControl | virtual
OnCaptionChanged() | CXTPControl | protectedvirtual
OnClick(BOOL bKeyboard=FALSE, CPoint pt=CPoint(0, 0)) | CXTPControlPopup | protectedvirtual
OnCustomizeDragOver(CXTPControl *pDataObject, CPoint point, DROPEFFECT &dropEffect) | CXTPControlPopup | protectedvirtual
OnCustomizeMouseMove(CPoint point) | CXTPControl | protected
OnEnabledChanged() | CXTPControl | virtual
OnExecute() | CXTPControl | virtual
OnHookKeyDown(UINT nChar, LPARAM lParam) | CXTPControl | protectedvirtual
OnHookMouseWheel(UINT nFlags, short zDelta, CPoint point) | CXTPControl | protectedvirtual
OnIdleUpdate() | CXTPControl | protectedvirtual
OnLButtonDblClk(CPoint point) | CXTPRibbonControlSystemButton | protectedvirtual
OnLButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnLButtonUp(CPoint point) | CXTPControlPopup | protectedvirtual
OnMouseHover() | CXTPControlPopup | protectedvirtual
OnMouseMove(CPoint point) | CXTPControlPopup | protectedvirtual
OnRButtonDown(CPoint point) | CXTPControl | protectedvirtual
OnRButtonUp(CPoint point) | CXTPControl | protectedvirtual
OnRemoved() | CXTPControl | protectedvirtual
OnSetPopup(BOOL bPopup) | CXTPControlPopup | protectedvirtual
OnSetSelected(int bSelected) | CXTPControlPopup | protectedvirtual
OnThemeChanged() | CXTPControl | virtual
OnToolHitTest(CPoint point, TOOLINFO *pTI) const | CXTPControl | protectedvirtual
OnUnderlineActivate() | CXTPControlPopup | virtual
RedrawParent(BOOL bAnimate=TRUE) | CXTPControl |
Reset() | CXTPControl |
RestoreCommandBarList(CXTPCommandBarList *pCommandBarList) | CXTPControlPopup | protectedvirtual
ScreenToClient(CPoint *point) | CXTPControl | protected
SetAction(CXTPControlAction *pAction) | CXTPControl | virtual
SetBeginGroup(BOOL bBeginGroup) | CXTPControl | virtual
SetCaption(LPCTSTR lpszCaption) | CXTPControl |
SetCaption(UINT nIDCaption) | CXTPControl |
SetCategory(LPCTSTR lpszCategory) | CXTPControl |
SetChecked(BOOL bChecked) | CXTPControl | virtual
SetCloseSubMenuOnClick(BOOL bCloseOnClick) | CXTPControl |
SetCommandBar(CMenu *pMenu) | CXTPControlPopup |
SetCommandBar(CXTPCommandBar *pBar) | CXTPControlPopup |
SetCustomIcon(HICON hIcon) | CXTPControl |
SetCustomShortcutText(LPCTSTR lpszCustomShortcutText) | CXTPControl |
SetDescription(LPCTSTR lpszDescription) | CXTPControl |
SetEnabled(BOOL bEnabled) | CXTPControl | virtual
SetExecuteOnPressInterval(int nExecuteOnPressInterval) | CXTPControl |
SetExpanded(BOOL bExpanded) | CXTPControl | protected
SetFlags(DWORD dwFlags) | CXTPControl |
SetFocused(BOOL bFocused) | CXTPControl | virtual
SetHeight(int nHeight) | CXTPControl | virtual
SetHelpId(int nId) | CXTPControl |
SetHideFlag(XTPControlHideFlags dwFlag, BOOL bSet) | CXTPControl |
SetHideFlags(DWORD dwFlags) | CXTPControl | virtual
SetHideWrap(BOOL bHide) | CXTPControl |
SetIconId(int nId) | CXTPControl |
SetIconSize(CSize szIcon) | CXTPControl |
SetID(int nId) | CXTPControl |
SetIndex(int nIndex) | CXTPControl | inlineprotected
SetItemDefault(BOOL bDefault) | CXTPControl |
SetKeyboardTip(LPCTSTR lpszKeyboardTip) | CXTPControl |
SetOnQuickAccess(BOOL bOnQuicAccess=FALSE) | CXTPControl |
SetParameter(LPCTSTR lpszParameter) | CXTPControl |
SetParent(CXTPCommandBar *pParent) | CXTPControl | inlineprotectedvirtual
SetPressed(BOOL bPressed) | CXTPControl |
SetPrompt(LPCTSTR lpszPrompt) | CXTPControl |
SetRect(CRect rcControl) | CXTPControl | virtual
SetRowRect(CRect rcRow) | CXTPControl |
SetShortcutText(LPCTSTR lpszShortcutText) | CXTPControl |
SetStyle(XTPButtonStyle buttonStyle) | CXTPControl |
SetStyleEx(XTPButtonStyle buttonStyle) | CXTPControlButton |
SetTag(DWORD_PTR dwTag) | CXTPControl |
SetTooltip(LPCTSTR lpszTooltip) | CXTPControl |
SetVisible(BOOL bVisible) | CXTPControl |
SetWidth(int nWidth) | CXTPControl | virtual
SetWrap(BOOL bWrap) | CXTPControl |
UpdateShadow() | CXTPControlPopup | protectedvirtual
~CXTPControl() | CXTPControl | protectedvirtual
~CXTPControlButton() | CXTPControlButton | virtual
~CXTPControlPopup() | CXTPControlPopup | virtual


Toolkit Pro: XTPControlGalleryItems.h Source File

  • Source
  • CommandBars
  • Gallery
XTPControlGalleryItems.h
Go to the documentation of this file.
1
23#if !defined(__XTPCONTROLGALLERYITEMS_H__)
24# define __XTPCONTROLGALLERYITEMS_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPControlGalleryItems : public CXTPCmdTarget
39{
41 DECLARE_DYNAMIC(CXTPControlGalleryItems)
43protected:
52 CXTPControlGalleryItems(CXTPControlAction* pAction, CXTPCommandBars* pCommandBars);
53
58 ~CXTPControlGalleryItems();
59
60public:
68 static CXTPControlGalleryItems* AFX_CDECL CreateItems(CXTPCommandBars* pCommandBars, int nId);
69
70public:
75 void RemoveAll();
76
82 void Remove(int nIndex);
83
92 CXTPControlGalleryItem* AddItem(int nId, int nImage);
93
103 CXTPControlGalleryItem* AddItem(LPCTSTR lpszCaption, int nId, int nImage);
104
114 CXTPControlGalleryItem* AddItem(CXTPControlGalleryItem* pItem, int nId = -1, int nImage = -1);
115
124 CXTPControlGalleryItem* AddItem(LPCTSTR lpszCaption, int nImage = -1);
125
136 CXTPControlGalleryItem* InsertItem(int nIndex, CXTPControlGalleryItem* pItem, int nId = -1,
137 int nImage = -1);
138
147 CXTPControlGalleryItem* AddLabel(int nId);
148
157 CXTPControlGalleryItem* AddLabel(LPCTSTR lpszCaption);
158
164 void SetImageManager(CXTPImageManager* pImageManager);
165
172 CXTPImageManager* GetImageManager() const;
173
182 CSize GetItemSize() const;
183
191 void SetItemSize(CSize szItem);
192
199 int GetItemCount() const;
200
208 CXTPControlGalleryItem* GetItem(int nIndex) const;
209
217 void ClipItems(BOOL bClipItems);
218
223 virtual void OnItemsChanged();
224
238 virtual BOOL PreDrawItem(CDC* pDC, CXTPControlGallery* pGallery, CXTPControlGalleryItem* pItem,
239 CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed,
240 BOOL bChecked);
241
248 CXTPControlAction* GetAction() const;
249
255 void EnableMarkup(BOOL bEnableMarkup = TRUE);
256
263 CXTPMarkupContext* GetMarkupContext() const;
264
265private:
266 void UpdateIndexes(int nStart /*= 0*/);
267
268protected:
269 CSize m_szItem;
270 CXTPImageManager* m_pImageManager;
271 BOOL m_bClipItems;
272 CXTPControlAction* m_pAction;
273 CArray<CXTPControlGalleryItem*, CXTPControlGalleryItem*> m_arrItems;
274 CXTPMarkupContext* m_pMarkupContext;
275 CXTPCommandBars* m_pCommandBars;
276
277private:
278 friend class CXTPControlGalleryItem;
279 friend class CXTPControlGallery;
280 friend class CXTPControlGalleryAction;
281
282# ifdef _XTP_COMMANDBARS_ACTIVEX
285 DECLARE_DISPATCH_MAP()
286 DECLARE_INTERFACE_MAP()
287
288 DECLARE_OLETYPELIB_EX(CXTPControlGalleryItems);
289 DECLARE_ENUM_VARIANT(CXTPControlGalleryItems);
290 DECLARE_CONNECTION_EX(CXTPControlGalleryItems)
291
292 afx_msg LPDISPATCH OleAddItem(int nId, LPCTSTR lpszCaption);
293 afx_msg LPDISPATCH OleAddLabel(LPCTSTR lpszCaption);
294 afx_msg LPDISPATCH OleAddSeparator();
295 afx_msg long OleGetItemCount();
296 afx_msg LPDISPATCH OleGetItem(int nIndex);
297 afx_msg BOOL OleGetEnableMarkup();
298 afx_msg void OleSetEnableMarkup(BOOL bEnableMarkup);
299 afx_msg LPDISPATCH OleGetMarkupContext();
300
301 DECLARE_PROPERTY(Icons, LPDISPATCH);
302 DECLARE_PROPERTY(ItemWidth, int);
303 DECLARE_PROPERTY(ItemHeight, int);
304
306# endif
307};
308
309AFX_INLINE CXTPImageManager* CXTPControlGalleryItems::GetImageManager() const
310{
311 return m_pImageManager;
312}
313AFX_INLINE CSize CXTPControlGalleryItems::GetItemSize() const
314{
315 return m_szItem;
316}
317AFX_INLINE void CXTPControlGalleryItems::ClipItems(BOOL bClipItems)
318{
319 m_bClipItems = bClipItems;
320}
321AFX_INLINE CXTPControlAction* CXTPControlGalleryItems::GetAction() const
322{
323 return m_pAction;
324}
325AFX_INLINE CXTPMarkupContext* CXTPControlGalleryItems::GetMarkupContext() const
326{
327 return m_pMarkupContext;
328}
329
330# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
332#endif // __XTPCONTROLGALLERYITEMS_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPCmdTarget
The CXTPCmdTarget class extends functionality of CCmdTarget and introduces workarounds for known issu...
Definition XTPFramework.h:122
CXTPCommandBars
CXTPCommandBars is a standalone class.
Definition XTPCommandBars.h:165
CXTPControlAction
CXTPControlAction is a CXTPCmdTarget derived class.
Definition XTPControl.h:53
CXTPControlGallery
CXTPControlGallery is a CXTPControlPopup derived class.
Definition XTPControlGallery.h:63
CXTPControlGalleryItem
CXTPControlGalleryItem is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItem.h:39
CXTPControlGalleryItems
CXTPControlGalleryItems is a CXTPCmdTarget derived class.
Definition XTPControlGalleryItems.h:39
CXTPControlGalleryItems::AddItem
CXTPControlGalleryItem * AddItem(CXTPControlGalleryItem *pItem, int nId=-1, int nImage=-1)
Call this member to add a new item.
CXTPControlGalleryItems::GetItemCount
int GetItemCount() const
Call this member to get the count of the items.
CXTPControlGalleryItems::SetItemSize
void SetItemSize(CSize szItem)
Call this method to set the size of the items.
CXTPControlGalleryItems::AddLabel
CXTPControlGalleryItem * AddLabel(LPCTSTR lpszCaption)
Call this member to add a new label item.
CXTPControlGalleryItems::InsertItem
CXTPControlGalleryItem * InsertItem(int nIndex, CXTPControlGalleryItem *pItem, int nId=-1, int nImage=-1)
Call this member to insert a new item.
CXTPControlGalleryItems::CXTPControlGalleryItems
CXTPControlGalleryItems(CXTPControlAction *pAction, CXTPCommandBars *pCommandBars)
Constructs a CXTPControlGalleryItems object.
CXTPControlGalleryItems::GetAction
CXTPControlAction * GetAction() const
Call this method to get the actions list for command bars.
Definition XTPControlGalleryItems.h:321
CXTPControlGalleryItems::EnableMarkup
void EnableMarkup(BOOL bEnableMarkup=TRUE)
Allows the use of a XAML snippet to be used for the text of items.
CXTPControlGalleryItems::AddItem
CXTPControlGalleryItem * AddItem(LPCTSTR lpszCaption, int nImage=-1)
Call this member to add a new item.
CXTPControlGalleryItems::Remove
void Remove(int nIndex)
Call this member to remove an item.
CXTPControlGalleryItems::AddItem
CXTPControlGalleryItem * AddItem(int nId, int nImage)
Call this member to add a new item.
CXTPControlGalleryItems::ClipItems
void ClipItems(BOOL bClipItems)
Call this member to enable/disable clipping items if selection was changed.
Definition XTPControlGalleryItems.h:317
CXTPControlGalleryItems::m_pImageManager
CXTPImageManager * m_pImageManager
Image manager of items.
Definition XTPControlGalleryItems.h:270
CXTPControlGalleryItems::~CXTPControlGalleryItems
~CXTPControlGalleryItems()
Destroys a CXTPControlGalleryItems object, handles cleanup and deallocation.
CXTPControlGalleryItems::GetMarkupContext
CXTPMarkupContext * GetMarkupContext() const
Retrieves a pointer to the markup context.
Definition XTPControlGalleryItems.h:325
CXTPControlGalleryItems::PreDrawItem
virtual BOOL PreDrawItem(CDC *pDC, CXTPControlGallery *pGallery, CXTPControlGalleryItem *pItem, CRect rcItem, BOOL bEnabled, BOOL bSelected, BOOL bPressed, BOOL bChecked)
This method is called to draw the item.
CXTPControlGalleryItems::RemoveAll
void RemoveAll()
Call this method to remove all items in the collection.
CXTPControlGalleryItems::m_szItem
CSize m_szItem
Size of the items.
Definition XTPControlGalleryItems.h:269
CXTPControlGalleryItems::GetItem
CXTPControlGalleryItem * GetItem(int nIndex) const
Call this member to return the item at the specified index.
CXTPControlGalleryItems::m_bClipItems
BOOL m_bClipItems
TRUE to clip items.
Definition XTPControlGalleryItems.h:271
CXTPControlGalleryItems::m_arrItems
CArray< CXTPControlGalleryItem *, CXTPControlGalleryItem * > m_arrItems
Array of items.
Definition XTPControlGalleryItems.h:273
CXTPControlGalleryItems::GetItemSize
CSize GetItemSize() const
Determines the default size of the items.
Definition XTPControlGalleryItems.h:313
CXTPControlGalleryItems::AddItem
CXTPControlGalleryItem * AddItem(LPCTSTR lpszCaption, int nId, int nImage)
Call this member to add a new item.
CXTPControlGalleryItems::GetImageManager
CXTPImageManager * GetImageManager() const
Retrieves the image manager for the items.
Definition XTPControlGalleryItems.h:309
CXTPControlGalleryItems::AddLabel
CXTPControlGalleryItem * AddLabel(int nId)
Call this member to add a new label item.
CXTPControlGalleryItems::CreateItems
static CXTPControlGalleryItems *AFX_CDECL CreateItems(CXTPCommandBars *pCommandBars, int nId)
Creates new items collection for gallery control.
CXTPControlGalleryItems::OnItemsChanged
virtual void OnItemsChanged()
This method is called if items are added to or removed from the collection.
CXTPControlGalleryItems::SetImageManager
void SetImageManager(CXTPImageManager *pImageManager)
Call this method to set the image manager for the items.
CXTPControlGalleryItems::m_pAction
CXTPControlAction * m_pAction
Action of the items.
Definition XTPControlGalleryItems.h:272
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128


CXTPPropertyGridVisualStudio2022Theme Member List

This is the complete list of members for CXTPPropertyGridVisualStudio2022Theme, including all inherited members.

AdjustItemCaptionRect(CXTPPropertyGridItem *pItem, CRect &rcCaption) | CXTPPropertyGridPaintManager | virtual
AdjustItemValueRect(CXTPPropertyGridItem *pItem, CRect &rcValue) | CXTPPropertyGridPaintManager | virtual
CXTPCmdTarget() | CXTPCmdTarget |
CXTPPropertyGridPaintManager(CXTPPropertyGrid *pGrid) | CXTPPropertyGridPaintManager |
CXTPPropertyGridVisualStudio2010Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2010Theme |
CXTPPropertyGridVisualStudio2022Theme(CXTPPropertyGrid *pGrid) | CXTPPropertyGridVisualStudio2022Theme |
DrawCategoryCaptionBackground(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rc) | CXTPPropertyGridPaintManager | virtual
DrawCheckBox(CDC *pDC, CXTPPropertyGridItemBool *pButton) | CXTPPropertyGridPaintManager | virtual
DrawCheckMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
DrawExpandButton(CDC &dc, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridVisualStudio2022Theme | virtual
DrawInplaceButtons(CDC *pDC, PDRAWITEMSTRUCT lpDrawItemStruct, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawInplaceListItem(CDC *pDC, CXTPPropertyGridItemConstraint *pConstraint, CRect rc, BOOL bSelected) | CXTPPropertyGridPaintManager | virtual
DrawItem(PDRAWITEMSTRUCT lpDrawItemStruct) | CXTPPropertyGridPaintManager | virtual
DrawItemCaption(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcCaption) | CXTPPropertyGridPaintManager | virtual
DrawItemValue(CDC *pDC, CXTPPropertyGridItem *pItem, CRect rcValue) | CXTPPropertyGridPaintManager | virtual
DrawPropertyGridBorder(CDC *pDC, RECT &rcBorder, XTPPropertyGridWindow nWindow) | CXTPPropertyGridPaintManager | virtual
DrawRadioMark(CDC *pDC, CRect rc, BOOL bEnabled, BOOL bChecked) | CXTPPropertyGridPaintManager | virtual
FillInplaceButton(CDC *pDC, CXTPPropertyGridInplaceButton *pButton) | CXTPPropertyGridPaintManager | virtual
FillPropertyGrid(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FillPropertyGridView(CDC *pDC) | CXTPPropertyGridPaintManager | virtual
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
GetItemBackColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemFont(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetItemMetrics() const | CXTPPropertyGridPaintManager |
GetItemsBorderHeight() const | CXTPPropertyGridPaintManager | virtual
GetItemTextColor(CXTPPropertyGridItem *pItem, BOOL bValuePart) | CXTPPropertyGridPaintManager | virtual
GetScrollBarTheme() const | CXTPPropertyGridVisualStudio2022Theme | virtual
GetSplitterRect(CRect rc, BOOL bIsHelp) | CXTPPropertyGridPaintManager |
HitTestVerbs(CDC *pDC, CRect rcVerbs, CPoint pt) | CXTPPropertyGridPaintManager |
m_bThinSplitter | CXTPPropertyGridPaintManager | protected
m_bTransparent | CXTPPropertyGridPaintManager |
m_buttonsStyle | CXTPPropertyGridPaintManager |
m_clrCategorySeparator | CXTPPropertyGridPaintManager |
m_clrFace | CXTPPropertyGridPaintManager |
m_clrHighlight | CXTPPropertyGridPaintManager |
m_clrHighlightText | CXTPPropertyGridPaintManager |
m_clrNonHighlightBack | CXTPPropertyGridPaintManager |
m_clrNonHighlightText | CXTPPropertyGridPaintManager |
m_clrShadow | CXTPPropertyGridPaintManager |
m_clrSplitter | CXTPPropertyGridPaintManager |
m_nHelpHeight | CXTPPropertyGridPaintManager | protected
m_nItemsBorderHeight | CXTPPropertyGridPaintManager | protected
m_nSplitterHeight | CXTPPropertyGridPaintManager | protected
m_nVerbsHeight | CXTPPropertyGridPaintManager | protected
m_pGrid | CXTPPropertyGridPaintManager | protected
m_pMetrics | CXTPPropertyGridPaintManager | protected
m_themeButton | CXTPPropertyGridPaintManager |
m_themeCombo | CXTPPropertyGridPaintManager |
m_themeTree | CXTPPropertyGridPaintManager |
MeasureItem(LPMEASUREITEMSTRUCT lpMeasureItemStruct) | CXTPPropertyGridPaintManager | virtual
OnNcCalcSize(RECT &rc) | CXTPPropertyGridPaintManager | virtual
RefreshMetrics() | CXTPPropertyGridVisualStudio2022Theme | virtual
SetItemsBorderHeight(int nHeight) | CXTPPropertyGridPaintManager | virtual
SetThinSplitter(BOOL bThinSplitter) | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridPaintManager() | CXTPPropertyGridPaintManager | virtual
~CXTPPropertyGridVisualStudio2010Theme() | CXTPPropertyGridVisualStudio2010Theme |


Toolkit Pro: XTPSkinObjectHeader.h Source File

  • Source
  • SkinFramework
XTPSkinObjectHeader.h
Go to the documentation of this file.
1
23#if !defined(__XTPSKINOBJECTHEADER_H__)
24# define __XTPSKINOBJECTHEADER_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPSkinObjectHeader : public CXTPSkinObjectFrame
39{
41 DECLARE_DYNCREATE(CXTPSkinObjectHeader)
43public:
48 CXTPSkinObjectHeader();
49
54 virtual ~CXTPSkinObjectHeader();
55
56 void OnDraw(CDC* pDC);
57
58protected:
61 void DrawItemEntry(CDC* pDC, int nIndex, CRect rcItem, int nState);
62 int HitTest(CPoint pt, UINT* pFlags = NULL) const;
63
64protected:
65 DECLARE_MESSAGE_MAP()
66 //{{AFX_VIRTUAL(CXTPSkinObjectHeader)
67 //}}AFX_VIRTUAL
68
69 //{{AFX_MSG(CXTPSkinObjectHeader)
70 afx_msg void OnPaint();
71
72 void OnLButtonDown(UINT nFlags, CPoint point);
73 void OnLButtonUp(UINT nFlags, CPoint point);
74 void OnMouseLeave();
75 void OnMouseMove(UINT nFlags, CPoint point);
76 LRESULT OnPrintClient(WPARAM wParam, LPARAM lParam);
77 //}}AFX_MSG
78
79protected:
80 BOOL m_bLBtnDown;
81 int m_nHotItem;
82
84};
85
86# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
88#endif // !defined(__XTPSKINOBJECTHEADER_H__)
XTPDisableNoisyWarnings.h
CXTPSkinObjectFrame
CXTPSkinObjectFrame is a CXTPSkinObject derived class.
Definition XTPSkinObjectFrame.h:75
CXTPSkinObjectHeader
CXTPSkinObjectHeader is a CXTPSkinObjectFrame derived class.
Definition XTPSkinObjectHeader.h:39
CXTPSkinObjectHeader::CXTPSkinObjectHeader
CXTPSkinObjectHeader()
Constructs a CXTPSkinObjectHeader object.
CXTPSkinObjectHeader::~CXTPSkinObjectHeader
virtual ~CXTPSkinObjectHeader()
Destroys a CXTPSkinObjectHeader object, handles cleanup and deallocation.


CXTPChart3dPyramidDiagram Member List

This is the complete list of members for CXTPChart3dPyramidDiagram, including all inherited members.

CalculateSeriesLayout(CXTPChartDeviceContext *pDC, CXTPChartDiagramView *pView) | CXTPChartPyramidDiagramBase< BaseDiagram > | virtual
CreateView(CXTPChartDeviceContext *pDC, CXTPChartElementView *pParent) | CXTPChart3dPyramidDiagram | virtual
CXTPChart3dPyramidDiagram() | CXTPChart3dPyramidDiagram |
CXTPChartPyramidDiagramBase() | CXTPChartPyramidDiagramBase< BaseDiagram > | protected


CXTPChartTextPainter Member List

This is the complete list of members for CXTPChartTextPainter, including all inherited members.

CalculateBounds() | CXTPChartTextPainter | virtual
CreateDeviceCommand(CXTPChartDeviceContext *pDC, const CXTPChartColor &color) | CXTPChartTextPainter | virtual
CXTPChartTextPainter(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider) | CXTPChartTextPainter |
CXTPChartTextPainterBase(CXTPChartDeviceContext *pDC, const CXTPChartString &text, CXTPChartTextElement *pTextProvider) | CXTPChartTextPainterBase | protected
GetRoundedBounds() | CXTPChartTextPainterBase |
m_nHeight | CXTPChartTextPainterBase | protected
m_nWidth | CXTPChartTextPainterBase | protected
m_pTextProvider | CXTPChartTextPainterBase | protected
m_rcBounds | CXTPChartTextPainterBase | protected
m_rcRoundedBounds | CXTPChartTextPainterBase | protected
m_strText | CXTPChartTextPainterBase | protected
m_szTextSize | CXTPChartTextPainterBase | protected
~CXTPChartTextPainterBase() | CXTPChartTextPainterBase | virtual


CXTPSoundManager Member List

This is the complete list of members for CXTPSoundManager, including all inherited members.

EnableSystemSounds(BOOL bEnable) | CXTPSoundManager |
m_bSoundAvailable | CXTPSoundManager |
PlaySystemSound(XTPSoundManagerState state) | CXTPSoundManager |
StopThread() | CXTPSoundManager |
XTPSoundManager() | CXTPSoundManager | friend
~CXTPSoundManager() | CXTPSoundManager |


Toolkit Pro: XTPPopupThemeOffice2003.h Source File

  • Source
  • Controls
  • Popup
  • Themes
XTPPopupThemeOffice2003.h
Go to the documentation of this file.
1
23#if !defined(__XTPPOPUPTHEMEOFFICE2003_H__)
24# define __XTPPOPUPTHEMEOFFICE2003_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
38class _XTP_EXT_CLASS CXTPPopupThemeOffice2003 : public CXTPPopupThemeOfficeXP
39{
40public:
45 CXTPPopupThemeOffice2003();
46
51 virtual ~CXTPPopupThemeOffice2003();
52
53public:
58 void RefreshMetrics();
59
67 virtual void DrawBackground(CDC* pDC, CXTPPopupControl* pControl, CRect rcClient);
68
69public:
70 CXTPPaintManagerColorGradient m_clrGripper;
74};
75
76# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
78#endif // __XTPPOPUPTHEMEOFFICE2003_H__
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPPaintManagerColorGradient
The CXTPPaintManagerColorGradient class is used to manage COLORREF values for determining light and d...
Definition XTPColorManager.h:301
CXTPPopupControl
CXTPPopupControl is a class for control of a pop-up window.
Definition XTPPopupControl.h:225
CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2003 is a class used to perform Office 2003 drawing tasks.
Definition XTPPopupThemeOffice2003.h:39
CXTPPopupThemeOffice2003::CXTPPopupThemeOffice2003
CXTPPopupThemeOffice2003()
Constructs a CXTPPopupThemeOffice2003 object.
CXTPPopupThemeOffice2003::m_clrGripper
CXTPPaintManagerColorGradient m_clrGripper
Color of the pop-up gripper for the.
Definition XTPPopupThemeOffice2003.h:70
CXTPPopupThemeOffice2003::~CXTPPopupThemeOffice2003
virtual ~CXTPPopupThemeOffice2003()
Destroys a CXTPPopupThemeOffice2003 object.
CXTPPopupThemeOffice2003::DrawBackground
virtual void DrawBackground(CDC *pDC, CXTPPopupControl *pControl, CRect rcClient)
Call this member function to draw the background of a pop-up window.
CXTPPopupThemeOffice2003::RefreshMetrics
void RefreshMetrics()
Call this member function to refresh draw metrics.
CXTPPopupThemeOfficeXP
CXTPPopupThemeOfficeXP is a class used to perform Office XP drawing tasks.
Definition XTPPopupThemeOfficeXP.h:39


CXTPButton Member List

This is the complete list of members for CXTPButton, including all inherited members.

CXTPButton() | CXTPButton |
DoDropDown() | CXTPButton | protected
DrawImage(CDC *pDC, CRect rc) | CXTPButton | virtual
EnableMarkup(BOOL bEnableMarkup=TRUE) | CXTPButton |
GetBorderGap() const | CXTPButton |
GetBorderStyle() const | CXTPButton |
GetButtonBackColor() | CXTPButton | virtual
GetButtonRect() | CXTPButton | virtual
GetButtonStyle() const | CXTPButton |
GetButtonText() | CXTPButton | virtual
GetButtonTextColor() | CXTPButton | virtual
GetChecked() | CXTPButton | virtual
GetFlatStyle() const | CXTPButton |
GetGlyphSize(BOOL bCheckBox) | CXTPButton |
GetIcon() const | CXTPButton |
GetImageAlignment() const | CXTPButton | virtual
GetImageGap() const | CXTPButton |
GetImageSize() | CXTPButton | virtual
GetMarkupContext() const | CXTPButton |
GetMarkupUIElement() | CXTPButton |
GetPushButtonStyle() const | CXTPButton |
GetShowFocus() const | CXTPButton |
GetTextAlignment() const | CXTPButton | virtual
GetTextImageRelation() const | CXTPButton |
GetTheme() | CXTPButton |
GetTooltip() const | CXTPButton |
GetToolTipContext() const | CXTPButton |
GetUseVisualStyle() const | CXTPButton |
InternalTextChanged() | CXTPButton | virtual
IsDpiImageScalingEnabled() const | CXTPButton | virtual
IsDropDownStyle() const | CXTPButton |
IsHighlighted() | CXTPButton | virtual
IsPushButton() const | CXTPButton |
IsPushed() | CXTPButton | virtual
m_bChecked | CXTPButton |
m_bEnableMarkup | CXTPButton |
m_bFlatStyle | CXTPButton |
m_bHot | CXTPButton |
m_bImageDPIScaling | CXTPButton | protected
m_bPushed | CXTPButton |
m_bShowFocus | CXTPButton |
m_bUseVisualStyle | CXTPButton |
m_hWndBuddy | CXTPButton |
m_nBorderGap | CXTPButton |
m_nBorderStyle | CXTPButton |
m_nImageAlignment | CXTPButton |
m_nImageGap | CXTPButton |
m_nPushButtonStyle | CXTPButton |
m_nTextImageRelation | CXTPButton |
m_pIcon | CXTPButton |
m_pMarkupContext | CXTPButton | protected
m_pTheme | CXTPButton |
m_pToolTipContext | CXTPButton |
m_pUIElement | CXTPButton | protected
m_strTooltip | CXTPButton |
m_szVectorIcon | CXTPButton |
OnDraw(CDC *pDC) | CXTPButton | protectedvirtual
OnDropDown() | CXTPButton | protectedvirtual
RedrawButton(BOOL bUpdateWindow=FALSE) | CXTPButton |
RefreshMetrics() | CXTPButton | protectedvirtual
SetBitmap(CSize size, UINT nID, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetBorderGap(int nBorderGap) | CXTPButton |
SetBorderStyle(XTPGroupBoxBorderStyle style) | CXTPButton |
SetBuddy(CWnd *pWndBuddy, BOOL bMoveButton=TRUE) | CXTPButton |
SetChecked(BOOL bChecked) | CXTPButton |
SetDpiImageScaling(BOOL bEnable) | CXTPButton | virtual
SetFlatStyle(BOOL bFlatStyle=TRUE) | CXTPButton |
SetIcon(CSize size, HICON hIcon, HICON hIconHot=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, UINT nID, UINT nHotID=0, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, LPCTSTR lpszID, LPCTSTR lpszHotID=NULL, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetIcon(CSize size, CXTPImageManagerIcon *pIcon, BOOL bRedraw=TRUE) | CXTPButton |
SetIcon(CSize size, const CXTPImageManagerIconHandle &hIconHandle, const CXTPImageManagerIconHandle &hIconHotHandle, BOOL bRedraw=TRUE) | CXTPButton | virtual
SetImageAlignment(DWORD dwAlignment) | CXTPButton |
SetImageGap(int nImageGap) | CXTPButton |
SetPushButtonStyle(XTPPushButtonStyle nPushButtonStyle) | CXTPButton |
SetShowFocus(BOOL bShowFocus) | CXTPButton |
SetTextAlignment(DWORD dwAlignment) | CXTPButton |
SetTextImageRelation(XTPButtonTextImageRelation relation) | CXTPButton |
SetTheme(XTPControlTheme eTheme) | CXTPButton | virtual
SetTheme(CXTPButtonTheme *pPaintManager) | CXTPButton | virtual
SetTooltip(LPCTSTR lpszTooltip) | CXTPButton |
SetUseVisualStyle(BOOL bUseVisualStyle=TRUE) | CXTPButton |
~CXTPButton() | CXTPButton | virtual


CXTPTabClientDraggingContents Member List

This is the complete list of members for CXTPTabClientDraggingContents, including all inherited members.

Create() | CXTPTabClientDraggingContents |
GetHeight() const | CXTPTabClientDraggingContents |
GetWidth() const | CXTPTabClientDraggingContents |
~CXTPTabClientDraggingContents() | CXTPTabClientDraggingContents | virtual


CXTPSyntaxEditTextRegion Member List

This is the complete list of members for CXTPSyntaxEditTextRegion, including all inherited members.

Clear() | CXTPSyntaxEditTextRegion
m_posEnd | CXTPSyntaxEditTextRegion
m_posStart | CXTPSyntaxEditTextRegion
Set(const XTP_EDIT_LINECOL *pLCStart, const XTP_EDIT_LINECOL *pLCEnd) | CXTPSyntaxEditTextRegion


CXTPSyntaxEditDeleteStringCommand Member List

This is the complete list of members for CXTPSyntaxEditDeleteStringCommand, including all inherited members.

CXTPSyntaxEditBufferCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo) | CXTPSyntaxEditBufferCommand | protected
CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | protected
CXTPSyntaxEditDeleteStringCommand(CXTPSyntaxEditBufferManager *pMgr, LPCTSTR szText, const XTP_EDIT_LINECOL &lcFrom, const XTP_EDIT_LINECOL &lcTo) | CXTPSyntaxEditDeleteStringCommand |
DoDeleteText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
DoInsertText(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditBufferCommand | protected
Execute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditDeleteStringCommand | virtual
GetCommandText() const | CXTPSyntaxEditCommand | virtual
GetDataSize() const | CXTPSyntaxEditBufferCommand | protectedvirtual
m_lcFrom | CXTPSyntaxEditBufferCommand | protected
m_lcTo | CXTPSyntaxEditBufferCommand | protected
m_pBufferMgr | CXTPSyntaxEditBufferCommand | protected
m_strCommandText | CXTPSyntaxEditCommand | protected
m_strText | CXTPSyntaxEditBufferCommand | protected
SetCommandText(LPCTSTR szText) | CXTPSyntaxEditCommand | virtual
SetPositionInternally(CXTPSyntaxEditCtrl *pEditCtrl, const XTP_EDIT_LINECOL &lcPos) | CXTPSyntaxEditCommand | protectedstatic
UnExecute(XTP_EDIT_LINECOL &lcFrom, XTP_EDIT_LINECOL &lcTo, CXTPSyntaxEditCtrl *pEditCtrl) | CXTPSyntaxEditDeleteStringCommand | virtual
~CXTPSyntaxEditBufferCommand() | CXTPSyntaxEditBufferCommand | virtual
~CXTPSyntaxEditCommand() | CXTPSyntaxEditCommand | virtual
~CXTPSyntaxEditDeleteStringCommand() | CXTPSyntaxEditDeleteStringCommand | virtual


Toolkit Pro: XTPTaskDialogClient.h Source File

  • Source
  • Controls
  • Dialog
XTPTaskDialogClient.h
Go to the documentation of this file.
1
23#if !defined(__XTPTASKCLIENTWND_H__)
24# define __XTPTASKCLIENTWND_H__
27# if _MSC_VER > 1000
28# pragma once
29# endif // _MSC_VER > 1000
30
31# include "Common/Base/Diagnostic/XTPDisableNoisyWarnings.h"
32
33class CXTPTaskDialogFrame;
34class CXTPImageManagerIcon;
35class CXTPMarkupUIElement;
36class CXTPMarkupContext;
37class CXTPMarkupObject;
38class CXTPMarkupRoutedEventArgs;
39class CXTPButton;
40class CXTPImageManager;
41
46class _XTP_EXT_CLASS CXTPTaskDialogClient : public CDialog
47{
48public:
49 class CStringMarkup
50 {
51 public:
52 CStringMarkup();
53 ~CStringMarkup();
54
55 public:
56 BOOL IsEmpty() const
57 {
58 return m_strCaption.IsEmpty();
59 }
60
61 void SetCaption(const CString& strCaption);
62 operator const CString&() const
63 {
64 return m_strCaption;
65 }
66 void SetFinalRect(const CRect& rcFinalRect);
67
68 public:
69 CString m_strCaption;
70 CXTPMarkupUIElement* m_pUIElement;
71 CXTPTaskDialogClient* m_pClient;
72 CRect m_rcFinalRect;
73 };
74
75public:
76 CXTPTaskDialogClient();
77 virtual ~CXTPTaskDialogClient();
78
79public:
80 HRESULT SendNotify(UINT uNotify, WPARAM wParam = 0, LPARAM lParam = 0);
81
82public:
83 virtual BOOL CreateClient(BOOL bMoveWindow);
84
85 BOOL IsLinkButtonsUsed() const;
86 BOOL IsLinkButtonsIconVisible() const;
87 BOOL HasLinkButtons() const;
88 BOOL IsExpandedByDefault() const;
89 BOOL IsExpandFooterArea() const;
90 BOOL HasFixedWidth() const;
91 BOOL IsPositionRelativeToWindow() const;
92 BOOL IsProgressBarVisible() const;
93 BOOL IsHyperlinksEnabled() const;
94 BOOL IsFooterIconHandleUsed() const;
95 BOOL IsMainIconHandleUsed() const;
96 BOOL CanCancel() const;
97
98 CXTPMarkupContext* GetMarkupContext() const;
99
100protected:
101 int m_nMaxClientWidth;
102 int m_nMinClientWidth;
103 int m_nPadding;
104 BOOL m_bExpanded;
105 BOOL m_bVerification;
106 BOOL m_bUseSysIcons;
107 BOOL m_bThemeReady;
108 HICON m_hIconFooter;
109 HICON m_hIconMain;
111 CXTPImageManager* m_pImageManager;
112 enum XTPTaskDialogIcon
113 {
114 xtpTaskDialogIconWarning,
115 xtpTaskDialogIconError,
116 xtpTaskDialogIconInformation,
117 xtpTaskDialogIconShield,
118 xtpTaskDialogIconQuestion,
119 xtpTaskDialogIconRight,
120 };
121
122 COLORREF m_crContent;
123 COLORREF m_crContentText;
124 COLORREF m_crFooter;
125 COLORREF m_crFooterText;
126 COLORREF m_crMainText;
127 COLORREF m_cr3DLight;
128 COLORREF m_cr3DShadow;
129 COLORREF m_cr3DHighLight;
131 CXTPFont m_xtpFont;
132 CXTPFont m_xtpFontLarge;
134 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_font, m_xtpFont, GetFontHandle);
135 XTP_SUBSTITUTE_GDI_MEMBER_WITH_CACHED(CFont, m_fontLarge, m_xtpFontLarge, GetLargeFontHandle);
136
137 CPoint m_ptMargin;
138 CPoint m_ptPadding;
139 CPoint m_ptBtnSpacing;
140 CPoint m_ptBorder;
141 CSize m_sizeIconFooter;
142 CSize m_sizeIconMain;
143 CSize m_sizeCommandButton;
144 CRect m_rcMainInstruction;
145 CRect m_rcContent;
146 CRect m_rcCommandButtons;
147 CRect m_rcExpandedInformation;
148 CRect m_rcFooter;
149 CRect m_rcRadioButtons;
150 CRect m_rcLinkButtons;
151 CStringMarkup m_strMainInstruction;
152 CStringMarkup m_strContent;
153 CStringMarkup m_strFooter;
154 CStringMarkup m_strVerificationText;
155 CStringMarkup m_strExpandedInformation;
156 CStringMarkup m_strExpandedControlText;
157 CStringMarkup m_strCollapsedControlText;
158 TASKDIALOGCONFIG* m_pConfig;
159 CXTPMarkupContext* m_pMarkupContext;
161 CButton* m_pBtnVerify;
162 CXTPButton* m_pBtnExpando;
163 CXTPTaskDialogLinkCtrl m_wndContent;
164 CXTPTaskDialogLinkCtrl m_wndExpandedInformation;
165 CXTPTaskDialogLinkCtrl m_wndFooter;
166 CXTPTaskDialogProgressCtrl m_wndProgressBar;
167 CEdit m_wndInputBox;
168 CArray<CButton*, CButton*> m_arrCommandButtons;
169 CArray<CButton*, CButton*> m_arrLinkButtons;
170 CArray<CButton*, CButton*> m_arrRadioButtons;
172 int m_nSelRadioButtonID;
174 CMap<CWnd*, CWnd*, SIZE, SIZE&> m_mapWndSize;
175 BOOL m_bMessageBoxStyle;
176 BOOL m_bEnableMarkup;
177 BOOL m_bShowInputBox;
178 CString m_strInputBoxText;
180protected:
181 BOOL IsWindow(CWnd* pWnd) const;
182
183 virtual void CreateIcons();
184 virtual void LoadStrings();
185 virtual void CreateFonts();
186
187 CString LoadItemString(PCWSTR pszBuffer);
188
189 virtual BOOL CreateCommandButtons();
190 virtual BOOL CreateLinkButtons();
191 virtual BOOL CreateRadioButtons();
192 virtual BOOL CreateVerifyExpandButtons();
193 virtual BOOL CreateProgressBar();
194 virtual BOOL CreateInputBox();
195
196 CButton* AddCommandButton(int nButtonID, int nIDLabel, CSize sizeButton);
197 CButton* AddCommandButton(int nButtonID, LPCTSTR lpszLabel, CSize sizeButton);
198 CButton* CreateButton(int nButtonID, LPCTSTR lpszLabel, CSize sizeButton,
199 DWORD dwButtonStyle = BS_PUSHBUTTON | BS_MULTILINE,
200 CXTPButtonTheme* pTheme = NULL);
201
202 HICON CreateIcon(HICON hIcon, PCWSTR lpwzIcon, CSize sizeIcon, BOOL bUseHandle);
203
204 CSize CalcCommandButtonSize();
205 CSize CalcButtonSize(CString strButton, CPoint* pMarginButton = NULL, int nMaxWidth = 0);
206 CSize CalcLinkButtonSize(CXTPButton* pButton, CString strButton, int nMaxCmdLinkWidth);
207
208 CSize CalcDynamicLayout(int nIdealWidth);
209
210 CRect CalcCommandRect(int nIdealWidth);
211 int CalcIdealTextWidth(const CStringMarkup& strItemText, int nMinWidth, BOOL bLargeFont);
212 CRect CalcTextRect(const CStringMarkup& strItemText, int nWidth, BOOL bLargeFont);
213 int CalcLinkButtonIdealWidth(CString strButton, int cxWidth);
214 void DrawText(CDC* pDC, const CStringMarkup& strItemText, CRect rcItem, COLORREF clrText,
215 CFont* pFont);
216
217 void RecalcLayout(BOOL bMoveWindow = FALSE);
218 BOOL ResizeParentToFit(CSize szClient, BOOL bMoveWindow);
219 void SetCommandButtonPos();
220 void SetLinkButtonPos();
221 void SetVerifyButtonPos();
222 void SetExpandoButtonPos();
223 void SetLinkCtrlPos();
224
225 HICON LoadSysIcon(PCWSTR lpwzIcon, CSize sizeIcon);
226
239 BOOL MoveButton(CButton* pButton, int xPos, int yPos, int cx, int cy, BOOL bRedraw = FALSE);
240
250 BOOL MoveButton(CButton* pButton, const CRect& rect, BOOL bRedraw = FALSE);
251
252 void ZOrder(CWnd* pWnd);
253 void UpdateZOrder();
254
255 int CalcClientWidth();
256
257 virtual void RefreshMetrics();
258 virtual void RefreshColors();
259
260 void DeleteControls();
261
262 virtual void DrawMainInstruction(CDC* pDC);
263 virtual void DrawContent(CDC* pDC);
264 virtual void DrawFootNote(CDC* pDC);
265 virtual void DrawBackground(CDC* pDC, CRect rect);
266 virtual void DrawExpandedInfo(CDC* pDC);
267
268 void DrawIcon(CDC* pDC, HICON hIcon, CPoint pt, CSize sz);
269 void OnExpandExpandoClicked();
270
273 //{{AFX_VIRTUAL(CXTPTaskDialogClient)
274
275 virtual LRESULT WindowProc(UINT message, WPARAM wParam, LPARAM lParam);
276 BOOL OnWndMsg(UINT message, WPARAM wParam, LPARAM lParam, LRESULT* pResult);
277
278 //}}AFX_VIRTUAL
279
280 //{{AFX_MSG(CXTPTaskDialogClient)
281
282 afx_msg void OnSettingChange(UINT uFlags, LPCTSTR lpszSection);
283 afx_msg void OnSysColorChange();
284 afx_msg BOOL OnEraseBkgnd(CDC* pDC);
285 afx_msg void OnPaint();
286 afx_msg HBRUSH OnCtlColor(CDC* pDC, CWnd* pWnd, UINT nCtlColor);
287 afx_msg void OnMarkupHyperlinkClick(CXTPMarkupObject* pSender,
288 CXTPMarkupRoutedEventArgs* pArgs);
289 afx_msg void OnDestroy();
290 afx_msg void OnInputBoxChanged();
291
292 //}}AFX_MSG
293
294 DECLARE_MESSAGE_MAP()
295
296
298 friend class CStringMarkup;
299};
301AFX_INLINE BOOL CXTPTaskDialogClient::IsLinkButtonsUsed() const
302{
303 return ((m_pConfig->dwFlags & (TDF_USE_COMMAND_LINKS | TDF_USE_COMMAND_LINKS_NO_ICON)) != 0);
304}
305AFX_INLINE BOOL CXTPTaskDialogClient::IsProgressBarVisible() const
306{
307 return ((m_pConfig->dwFlags & (TDF_SHOW_PROGRESS_BAR | TDF_SHOW_MARQUEE_PROGRESS_BAR)) != 0);
308}
309AFX_INLINE BOOL CXTPTaskDialogClient::IsLinkButtonsIconVisible() const
310{
311 return ((m_pConfig->dwFlags & TDF_USE_COMMAND_LINKS_NO_ICON) == 0);
312}
313AFX_INLINE BOOL CXTPTaskDialogClient::HasLinkButtons() const
314{
315 return ((m_pConfig->pButtons != NULL) && (m_pConfig->cButtons > 0) && IsLinkButtonsUsed());
316}
317AFX_INLINE BOOL CXTPTaskDialogClient::IsExpandedByDefault() const
318{
319 return ((m_pConfig->dwFlags & TDF_EXPANDED_BY_DEFAULT) != 0);
320}
321AFX_INLINE BOOL CXTPTaskDialogClient::IsExpandFooterArea() const
322{
323 return ((m_pConfig->dwFlags & TDF_EXPAND_FOOTER_AREA) != 0);
324}
325AFX_INLINE BOOL CXTPTaskDialogClient::HasFixedWidth() const
326{
327 return (m_pConfig->cxWidth != 0);
328}
329AFX_INLINE BOOL CXTPTaskDialogClient::IsPositionRelativeToWindow() const
330{
331 return m_pConfig->hwndParent && (m_pConfig->dwFlags & TDF_POSITION_RELATIVE_TO_WINDOW);
332}
333AFX_INLINE BOOL CXTPTaskDialogClient::IsHyperlinksEnabled() const
334{
335 return ((m_pConfig->dwFlags & TDF_ENABLE_HYPERLINKS) != 0);
336}
337AFX_INLINE BOOL CXTPTaskDialogClient::IsFooterIconHandleUsed() const
338{
339 return ((m_pConfig->dwFlags & TDF_USE_HICON_FOOTER) != 0);
340}
341AFX_INLINE BOOL CXTPTaskDialogClient::IsMainIconHandleUsed() const
342{
343 return ((m_pConfig->dwFlags & TDF_USE_HICON_MAIN) != 0);
344}
345AFX_INLINE BOOL CXTPTaskDialogClient::IsWindow(CWnd* pWnd) const
346{
347 return (pWnd && ::IsWindow(pWnd->GetSafeHwnd()));
348}
349AFX_INLINE BOOL CXTPTaskDialogClient::MoveButton(CButton* pButton, const CRect& rect,
350 BOOL bRedraw /*=FALSE*/)
351{
352 return MoveButton(pButton, rect.left, rect.top, rect.Width(), rect.Height(), bRedraw);
353}
354AFX_INLINE CXTPMarkupContext* CXTPTaskDialogClient::GetMarkupContext() const
355{
356 return m_pMarkupContext;
357}
358
360
361//{{AFX_INSERT_LOCATION}}
362// Microsoft Visual C++ will insert additional declarations immediately before the previous line.
364# include "Common/Base/Diagnostic/XTPEnableNoisyWarnings.h"
366#endif // !defined(__XTPTASKCLIENTWND_H__)
XTPDisableNoisyWarnings.h
XTPEnableNoisyWarnings.h
CXTPButton
Push Button control.
Definition XTPButton.h:109
CXTPButtonTheme
CXTPButtonTheme is a class used to perform Button Theme drawing tasks.
Definition XTPButtonTheme.h:51
CXTPFont
Provides a convenient object oriented interface for HFONT GDI object and uses GDI handle caching.
Definition XTPGdiObjects.h:414
CXTPImageManager
CXTPImageManager is a standalone class.
Definition XTPImageManager.h:1898
CXTPImageManagerIcon
Icons holder class.
Definition XTPImageManager.h:622
CXTPMarkupContext
CXTPMarkupContext is a standalone class used to provide common settings for Markup objects.
Definition XTPMarkupContext.h:128
CXTPMarkupUIElement
Base class for XML Markup core level implementations.
Definition XTPMarkupUIElement.h:43
CXTPTaskDialogClient
CXTPTaskDialogClient window.
Definition XTPTaskDialogClient.h:47
CXTPTaskDialogClient::m_arrCommandButtons
CArray< CButton *, CButton * > m_arrCommandButtons
Array of push buttons.
Definition XTPTaskDialogClient.h:168
CXTPTaskDialogClient::m_cr3DHighLight
COLORREF m_cr3DHighLight
3D HighLight color.
Definition XTPTaskDialogClient.h:129
CXTPTaskDialogClient::m_wndProgressBar
CXTPTaskDialogProgressCtrl m_wndProgressBar
ProgressBar window.
Definition XTPTaskDialogClient.h:166
CXTPTaskDialogClient::m_arrRadioButtons
CArray< CButton *, CButton * > m_arrRadioButtons
Array of radio buttons.
Definition XTPTaskDialogClient.h:170
CXTPTaskDialogClient::m_bThemeReady
BOOL m_bThemeReady
TRUE if System theme used.
Definition XTPTaskDialogClient.h:107
CXTPTaskDialogClient::m_arrLinkButtons
CArray< CButton *, CButton * > m_arrLinkButtons
Array of link buttons.
Definition XTPTaskDialogClient.h:169
CXTPTaskDialogClient::m_ptBtnSpacing
CPoint m_ptBtnSpacing
Space between buttons.
Definition XTPTaskDialogClient.h:139
CXTPTaskDialogClient::m_strFooter
CStringMarkup m_strFooter
Footer text.
Definition XTPTaskDialogClient.h:153
CXTPTaskDialogClient::m_xtpFont
CXTPFont m_xtpFont
Content font.
Definition XTPTaskDialogClient.h:131
CXTPTaskDialogClient::m_bShowInputBox
BOOL m_bShowInputBox
TRUE to show input box.
Definition XTPTaskDialogClient.h:177
CXTPTaskDialogClient::m_sizeIconMain
CSize m_sizeIconMain
Size of main icon.
Definition XTPTaskDialogClient.h:142
CXTPTaskDialogClient::m_bVerification
BOOL m_bVerification
TRUE if verification button is checked.
Definition XTPTaskDialogClient.h:105
CXTPTaskDialogClient::m_rcCommandButtons
CRect m_rcCommandButtons
Position of Push buttons.
Definition XTPTaskDialogClient.h:146
CXTPTaskDialogClient::m_strVerificationText
CStringMarkup m_strVerificationText
Verification text.
Definition XTPTaskDialogClient.h:154
CXTPTaskDialogClient::m_strCollapsedControlText
CStringMarkup m_strCollapsedControlText
Text for collapsed button.
Definition XTPTaskDialogClient.h:157
CXTPTaskDialogClient::m_mapWndSize
CMap< CWnd *, CWnd *, SIZE, SIZE & > m_mapWndSize
Size map.
Definition XTPTaskDialogClient.h:174
CXTPTaskDialogClient::m_strMainInstruction
CStringMarkup m_strMainInstruction
Main instruction text.
Definition XTPTaskDialogClient.h:151
CXTPTaskDialogClient::m_rcMainInstruction
CRect m_rcMainInstruction
Position of Main Instruction.
Definition XTPTaskDialogClient.h:144
CXTPTaskDialogClient::m_bExpanded
BOOL m_bExpanded
TRUE if Expanded area is is expanded.
Definition XTPTaskDialogClient.h:104
CXTPTaskDialogClient::m_wndExpandedInformation
CXTPTaskDialogLinkCtrl m_wndExpandedInformation
ExpandedInformation window.
Definition XTPTaskDialogClient.h:164
CXTPTaskDialogClient::m_ptMargin
CPoint m_ptMargin
Margin of elements.
Definition XTPTaskDialogClient.h:137
CXTPTaskDialogClient::m_hIconMain
HICON m_hIconMain
Main instruction icon.
Definition XTPTaskDialogClient.h:109
CXTPTaskDialogClient::m_crContentText
COLORREF m_crContentText
Content text color.
Definition XTPTaskDialogClient.h:123
CXTPTaskDialogClient::m_crContent
COLORREF m_crContent
Content background color.
Definition XTPTaskDialogClient.h:122
CXTPTaskDialogClient::m_rcRadioButtons
CRect m_rcRadioButtons
Position of Radio buttons.
Definition XTPTaskDialogClient.h:149
CXTPTaskDialogClient::MoveButton
BOOL MoveButton(CButton *pButton, int xPos, int yPos, int cx, int cy, BOOL bRedraw=FALSE)
Moves a button to the desired location.
CXTPTaskDialogClient::m_sizeCommandButton
CSize m_sizeCommandButton
Size of push buttons.
Definition XTPTaskDialogClient.h:143
CXTPTaskDialogClient::m_nMaxClientWidth
int m_nMaxClientWidth
Maximum client width.
Definition XTPTaskDialogClient.h:101
CXTPTaskDialogClient::m_nSelRadioButtonID
int m_nSelRadioButtonID
ID of the radio button that was selected when the task dialog was closed.
Definition XTPTaskDialogClient.h:172
CXTPTaskDialogClient::m_pBtnExpando
CXTPButton * m_pBtnExpando
Expando button pointer.
Definition XTPTaskDialogClient.h:162
CXTPTaskDialogClient::m_pMarkupContext
CXTPMarkupContext * m_pMarkupContext
Markup context.
Definition XTPTaskDialogClient.h:159
CXTPTaskDialogClient::m_xtpFontLarge
CXTPFont m_xtpFontLarge
Main instruction font.
Definition XTPTaskDialogClient.h:132
CXTPTaskDialogClient::m_wndInputBox
CEdit m_wndInputBox
InputBox window.
Definition XTPTaskDialogClient.h:167
CXTPTaskDialogClient::m_ptBorder
CPoint m_ptBorder
Border space around dialog.
Definition XTPTaskDialogClient.h:140
CXTPTaskDialogClient::m_strExpandedControlText
CStringMarkup m_strExpandedControlText
Text for expanded button.
Definition XTPTaskDialogClient.h:156
CXTPTaskDialogClient::m_bEnableMarkup
BOOL m_bEnableMarkup
TRUE to enable markup.
Definition XTPTaskDialogClient.h:176
CXTPTaskDialogClient::m_cr3DShadow
COLORREF m_cr3DShadow
3D Shadow color.
Definition XTPTaskDialogClient.h:128
CXTPTaskDialogClient::m_strContent
CStringMarkup m_strContent
Content text.
Definition XTPTaskDialogClient.h:152
CXTPTaskDialogClient::m_hIconFooter
HICON m_hIconFooter
Footer icon.
Definition XTPTaskDialogClient.h:108
CXTPTaskDialogClient::m_crFooter
COLORREF m_crFooter
Footer color.
Definition XTPTaskDialogClient.h:124
CXTPTaskDialogClient::MoveButton
BOOL MoveButton(CButton *pButton, const CRect &rect, BOOL bRedraw=FALSE)
Moves a button to the desired location.
CXTPTaskDialogClient::m_bUseSysIcons
BOOL m_bUseSysIcons
TRUE to use system icons.
Definition XTPTaskDialogClient.h:106
CXTPTaskDialogClient::m_bMessageBoxStyle
BOOL m_bMessageBoxStyle
TRUE to use extended style.
Definition XTPTaskDialogClient.h:175
CXTPTaskDialogClient::m_rcFooter
CRect m_rcFooter
Position of Footer.
Definition XTPTaskDialogClient.h:148
CXTPTaskDialogClient::m_wndContent
CXTPTaskDialogLinkCtrl m_wndContent
Content window.
Definition XTPTaskDialogClient.h:163
CXTPTaskDialogClient::m_rcLinkButtons
CRect m_rcLinkButtons
Position of Link Buttons.
Definition XTPTaskDialogClient.h:150
CXTPTaskDialogClient::m_pBtnVerify
CButton * m_pBtnVerify
Verify button pointer.
Definition XTPTaskDialogClient.h:161
CXTPTaskDialogClient::m_rcExpandedInformation
CRect m_rcExpandedInformation
Expanded Information.
Definition XTPTaskDialogClient.h:147
CXTPTaskDialogClient::m_strInputBoxText
CString m_strInputBoxText
Input box text.
Definition XTPTaskDialogClient.h:178
CXTPTaskDialogClient::m_ptPadding
CPoint m_ptPadding
Padding of elements.
Definition XTPTaskDialogClient.h:138
CXTPTaskDialogClient::m_sizeIconFooter
CSize m_sizeIconFooter
Size of footer icon.
Definition XTPTaskDialogClient.h:141
CXTPTaskDialogClient::m_pConfig
TASKDIALOGCONFIG * m_pConfig
Pointer to TASKDIALOGCONFIG.
Definition XTPTaskDialogClient.h:158
CXTPTaskDialogClient::m_wndFooter
CXTPTaskDialogLinkCtrl m_wndFooter
Footer window.
Definition XTPTaskDialogClient.h:165
CXTPTaskDialogClient::m_rcContent
CRect m_rcContent
Position of Content Text.
Definition XTPTaskDialogClient.h:145
CXTPTaskDialogClient::m_strExpandedInformation
CStringMarkup m_strExpandedInformation
Expanded text.
Definition XTPTaskDialogClient.h:155
CXTPTaskDialogClient::m_nMinClientWidth
int m_nMinClientWidth
Minimum client width.
Definition XTPTaskDialogClient.h:102
CXTPTaskDialogClient::m_nPadding
int m_nPadding
Padding of elements.
Definition XTPTaskDialogClient.h:103
CXTPTaskDialogClient::m_crFooterText
COLORREF m_crFooterText
Footer text color.
Definition XTPTaskDialogClient.h:125
CXTPTaskDialogClient::m_cr3DLight
COLORREF m_cr3DLight
3D Light color.
Definition XTPTaskDialogClient.h:127
CXTPTaskDialogClient::m_crMainText
COLORREF m_crMainText
Main instruction text color.
Definition XTPTaskDialogClient.h:126
CXTPTaskDialogLinkCtrl
CXTPTaskDialogLinkCtrl is a CStatic derived class that is used to display a text block that contains ...
Definition XTPTaskDialogControls.h:39
CXTPTaskDialogProgressCtrl
CXTPTaskDialogProgressCtrl.
Definition XTPTaskDialogControls.h:290


CXTPTrackUndoManager Member List

This is the complete list of members for CXTPTrackUndoManager, including all inherited members.

AddUndoCommand(CXTPTrackUndoCommand *pCommand) | CXTPTrackUndoManager |
CanRedo() const | CXTPTrackUndoManager |
CanUndo() const | CXTPTrackUndoManager |
Clear() | CXTPTrackUndoManager |
CXTPCmdTarget() | CXTPCmdTarget |
CXTPTrackUndoManager() | CXTPTrackUndoManager |
EndGroup() | CXTPTrackUndoManager |
FromIDispatchSafe(IDispatch *pDisp) | CXTPCmdTarget | static
m_arrRedoCommands | CXTPTrackUndoManager | protected
m_arrUndoCommands | CXTPTrackUndoManager | protected
m_nUndoContext | CXTPTrackUndoManager | protected
m_pUndoGroup | CXTPTrackUndoManager | protected
Redo() | CXTPTrackUndoManager |
StartGroup() | CXTPTrackUndoManager |
Undo() | CXTPTrackUndoManager |
~CXTPTrackUndoManager() | CXTPTrackUndoManager |