Welcome to the full line of LEADTOOLS Products.

For WIN32 [image] by LEAD Technologies, Inc. Version 14

Contents Tab

Click the Contents tab to list the Table of Contents in the left window for this electronic help file.

To open a closed book [image], double-click it or click the Plus symbol

Its contents are listed.

To close an open book [image], double-click it or click the Minus symbol

To open a topic [image], click it. Its contents are displayed.

Index Tab

Click the Index tab to view a list of all headings and index terms in an alphabetical format.

Enter the beginning letters of the desired term. All index terms starting with those letters are displayed.

To go directly to the text for a term, double-click the term, or click the term and then click Display.

Search Tab

Click the Search tab to find a specific term or a list of terms with the same beginning letters.

Enter the beginning letters of the desired word. The system will display all of the words in the help file starting with those letters. All words are case sensitive. Click the desired word to display all of the topics containing that word.

To go directly to the text for a term, double-click the term, or click the term and then click Display.

Topic Toolbar Buttons

Click this button | To do this
Back | Return to the previous help screen.
Print | Print a displayed topic.
<< | Go back to the prior help topic.
>> | Move to the next help topic.


Product Comparison

Please refer to the Product Comparison Chart online at: http://www.leadtools.com/home2/general/pcmpchtjs.htm' for a quick comparison between of LEAD's toolkits: (For more information, please contact the Sales department).


LEADTOOLS Document Imaging $1995*

(Contains low level API, a C++ class library, .NET classes and easy to use COM objects, ActiveX controls and VCL controls)

* Requires runtime licensing.

The LEADTOOLS Document Imaging toolkit includes all of the display functionality in the Raster Imaging products. In addition, it adds extra features to meet the specific demands of the document imaging market. This includes powerful annotation capabilities and specialized image processing filters, including despeckle, deskew, favor black, and scale to gray enhance and "clean up" 1 bit images as well as ultra fast rotation. To greatly increase the quality and readability of black and white images on the screen, the toolkit includes specialized display options called bitonal scaling.

Image acquisition capabilities are also expanded over the Raster Imaging products with the addition of support for the v4.1 of the Pixel Translation's ISIS toolkit implementation. You can use images acquired as document (halftone), grayscale or color for use in check & form processing applications, stock photo collections, WebPages and more.

JBIG is an acronym for 'Joint Bi-level Image experts Group', which has developed a standard for the lossless compression of a bi-level image. JBIG compression algorithms are included in both Document Imaging products.

LEADTOOLS Document Imaging products can employ specialized functions called Doc-Clean to remove noise, borders, lines and hole punches, smooth text and invert white on black text, and other functions to straighten skewed images (deskew), fatten thinning lines and text (dilatation) and erode text that has gotten too thick (erosion).

In addition to all the features supported by the LEADTOOLS Raster Imaging Pro toolkit, this product includes the following features:

Annotations

Document Clean-up

JBIG

Additional Document Imaging Features

Digital Paint

Vector Imaging

In addition to the LEADTOOLS OCR PDF Plug-in, the following LEADTOOLS products can be added to this product :

LEADTOOLS Barcode Modules

LEADTOOLS eMail Module

LEADTOOLS JPEG 2000 Plug-in

LEADTOOLS OCR Module

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS PDF OCR Plug-in

LEADTOOLS CMW Plug-in

LEADTOOLS ICR Module

LEADTOOLS OMR Module


LEADTOOLS Document Imaging Suite $3495*

(Contains low level API, a C++ class library, .NET classes and easy to use COM Objects, ActiveX controls and VCL controls)

* Requires runtime licensing.

With the LEADTOOLS Document Imaging Suite, developers get ScanSoft SDK 12 Pro Optical Character Recognition (OCR) engine capabilities added to all of the features that make the LEADTOOLS Document Imaging great. (OCR only available via API and COM) OCR features include preset confidence and accuracy levels, artificial intelligence, and built-in and user-defined lexicons for limiting the type of text to recognize and much more... In addition to the OCR capabilities, LEADTOOLS Document Imaging Suite provides JBIG support and a "Clean-up" module for cleaning up 1-bit images.

The LEADTOOLS Document Imaging Suite toolkit includes all of the functionality in the Document Imaging product. In addition to all the features supported by the LEADTOOLS Document Imaging toolkit, this product includes the following features:

OCR

The following LEADTOOLS products can be added to this product :

LEADTOOLS Barcode Modules

LEADTOOLS eMail Module

LEADTOOLS JPEG 2000 Plug-in

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS CMW Plug-in

LEADTOOLS ICR Module

LEADTOOLS OMR Module

LEADTOOLS OCR PDF Plug-in,


LEADTOOLS DVD Imager $895

LEADTOOLS DVD Imager SDK $895*

* Requires runtime licensing.

LEADTOOLS DVD Imager lets you create DVD images that can be played by DVD player software or burned to a DVD and played on a DVD set top box. LEADTOOLS DVD Imager has everything you need to create DVD images, including DVD Imager interface, MPEG-2 and MPEG-1 multiplexers, MPEG Audio encoder, LEAD MPEG-2 Professional encoder, and several DirectShow filters to resize and crop videos, as well as filters to convert video color spaces.

Key Features

  • DVD Support - Playing and Authoring
    Create DVD images using the LEAD DVD Writer component .

  • Multimedia Capture
    Create applications that can capture from WDM, native DirectShow including DV, Video for Windows capture devices, control DV devices and more.

  • Multimedia Playback
    Create applications that can play all formats supported by DirectShow and more. Now with support for DVD navigation!

  • Multimedia Processing
    Add to your applications the ability to process AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats or data as it is captured using DirectX filters. Use the LEAD Video callback DirectShow filter to use any of the 200+ image processing functions to process movies during playback, conversion or capture and more.

  • Multimedia Compression
    Add support to your applications for compressing individual samples with any available DirectShow filters (Memory to memory) and more.

  • Multimedia Conversion
    Add features to your application so your users can convert to and from AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats, select DV devices for output, and more.

  • Multimedia File Formats
    Add support for the most popular multimedia formats. New formats in v14.5 include OGG, MPEG 1 and MPEG 2.

  • DirectX Filters
    LEADTOOLS DVD Imager SDK includes an evaluation version of the Multimedia filter pack that includes powerful multimedia processing functionality. For pricing for DirectShow Filter client licenses, contact oemsales@leadtools.com .

  • Product Demos
    LEADTOOLS DVD Imager SDK includes several demo exe's to help you get started with your own development project. DVD Authoring demo, Audio Video Detection demo, Audio replace demo, MediaInfo demo, and more.

DirectX 8 or better is recommended, but supports DirectX 7 and earlier.


LEADTOOLS eMail $145

(Contains 32-bit COM and API)

The LEADTOOLS eMail toolkit connects directly to Simple Mail Transfer Protocol (SMTP) and Post Office Protocol 3 (POP3) servers (Messaging Application Programming Interface (MAPI) is not required). The toolkit allows you to quickly add eMail functionality to your application, and control it.

This product includes the following features:

eMail

This toolkit is a stand-alone and can be used without the presence of another LEADTOOLS product.


LEADTOOLS Medical Imaging $3995*

(Contains low level API, a C++ class library, .NET classes and easy to use COM Objects, ActiveX controls and VCL controls)

* Requires runtime licensing.

The LEADTOOLS Medical Imaging toolkit adds 10-16 bit grayscale support and 48 and 64 bit color functionality to the LEADTOOLS Raster Imaging Pro toolkit features to make the Medical Imaging toolkit a complete imaging solution. For example, the toolkit includes TWAIN support to add such things as x-ray film scanning, generalized imaging support from image capture, format conversion, Internet imaging, database support and printing, to name a few. Rounding out the set of functionality in the LEADTOOLS Medical Imaging toolkit is a comprehensive set of image processing functions.

With the LEADTOOLS Medical Imaging toolkit, developers have access to features which have been chosen and optimized to meet the specific demands of the medical imaging market, such as full DICOM dataset support, support for 9-16 bit grayscale, and 12 and 16 bit image processing and display with window leveling and LUT processing.

The DICOM 3 (2003 file specification), the industry standard medical imaging format/protocol is fully and completely supported, allowing programmers access to medical images retrieved from digital imaging modalities such as CT and MR scanners.

This product includes the following features:

DICOM Basic

In addition to the LEAD JPEG2000 codec, the following LEAD products are included with the Medical Imaging toolkit:

LEAD MCMP - MJPEG Video Codec

LEADTOOLS Multimedia

LEADTOOLS Medical Multimedia Filter Pack

Other LEADTOOLS products that can be added to this product:

LEADTOOLS Barcode Modules

LEADTOOLS JPEG2000 Plug-in

LEADTOOLS OCR Module

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS eMail

LEADTOOLS CMW Plug-in


LEADTOOLS Medical Imaging Suite $7495*

(Contains low level API, a C++ class library, .NET classes and easy to use COM Objects, ActiveX controls and VCL controls)

* Requires runtime licensing.

LEADTOOLS Medical Imaging Suite was developed to provide comprehensive support for radiological/medical applications that utilize DICOM. The LEADTOOLS Medical Imaging Suite has everything you need to develop a complete DICOM Medical Imaging Solution. Create any DICOM Layer Actor in the IHE Framework; add support for any DICOM service; capture images from TWAIN, ISIS, Screen, Video for Windows (VfW) driver, DV (Digital Video) driver and WDM driver sources; print via Windows printer driver or DICOM Print SCP; display 1-64 bit images including automatic zoom, pan and scroll functionally; process 1-64 bit image data; stream image or video data to a DICOM dataset; load, save and convert DICOM to any of over 100 image formats; as well as image annotation including functionality to create overlays; and convert DICOM datasets to AVI files.

In addition to the features supported by the LEADTOOLS Medical Imaging product, this product includes the following features:

Annotations

DICOM Annotation

DICOM Communication

DICOM Multimedia

DICOM Security

Document Clean-up

ISIS Scanning

Deserving special attention is the toolkit’s full support for all Service Classes with functionality making it easy to implement all possible DICOM Service Classes for a client and/or server:

  • DICOM Verification Service Class

  • DICOM Storage Service Class

  • DICOM Query/Retrieve Service Class

  • DICOM Study Content Notification Service Class

  • DICOM Patient Management Service Class

  • DICOM Study Management Service Class

  • DICOM Results Management Service Class

  • DICOM Print Management Service Class

  • DICOM Media Storage Service Class

  • DICOM Storage Commitment Service Class

  • DICOM Basic Worklist Management Service Class

  • DICOM Queue Management Service Class

  • DICOM Print Service Class

  • Largest set of hardware manufacturers supported

  • Direct support for PACS

  • Most comprehensive file format support

  • Extensive, ready to use sample source code and executables

  • 6 different Programming interfaces - API, C++ Class Library, ActiveX, COM, VCL, and .NET

LEADTOOLS gives you powerful high-level features that simplify the creation of your DICOM client/server applications. With Medical Imaging Suite, you get:

  • DICOM LUT/Overlay/Palette support. The high-level support for Modality LUT, VOI LUT, Palette Color Image in LEADTOOLS Medical Imaging means developers can implement DICOM Presentation state into an application with ease. LEADTOOLS can also aapply the Modality LUT to the image data to further simplify image processing and statistical calculations.

  • DICOM Annotation Object support. Store/retrieve DICOM annotations from a dataset and convert them to LEAD Annotation objects and vice versa. Annotations can also be converted to regions of interest for additional statistical calculations and for storing to DICOM Presentation State.

  • High-level functions for initiating and terminating Associations (connections between DICOM applications), automating the process of filling out PDU structures (Protocol Data Units).

  • Automatic and transparent conversion of DICOM Data Sets to/from specific Transfer Syntax required by the associated Application Entities (the connected DICOM client(s) and server(s)).

  • High-level functions that automate sending DICOM Request and Response Command Sets (Services), greatly simplifying the process of coding application communications.

  • Complete support for Message Exchange, including DIMSE (DICOM Message Service Element) service user and provider, and Message Exchange Upper Layer Protocol.

The following LEAD products are included with the Medical Imaging Suite toolkit:

LEAD MCMP - MJPEG Video Codec

LEADTOOLS Multimedia

Other LEADTOOLS products that can be added to this product:

LEADTOOLS Barcode Modules

LEADTOOLS JPEG2000 Plug-in

LEADTOOLS OCR Module

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS eMail

LEADTOOLS CMW Plug-in


LEADTOOLS Mobile Imaging $995

LEADTOOLS Mobile Imaging*v1 ($995)

Imaging Library for Microsoft .NET Compact Framework

* LEADTOOLS Mobile Imaging contains two sets of features, one basic and the other advanced. The "basic" features may be incorporated into an application and deployed on a royalty-free basis. If "advanced" features are incorporated into an application, a runtime license is required. Advanced features include JPEG2000, LEAD CMW, 12-16 bit grayscale load/save, ScaleToGray and FavorBlack.

LEADTOOLS Mobile Imaging is a programming SDK for the Microsoft .NET Compact Framework. Developers now have access to LEADTOOLS imaging functionality for applications designed to run on devices such as personal digital assistants (PDAs) and mobile phones.

LEADTOOLS Mobile Imaging ships with binaries that support the ARMV4 and WCE x86 processors. Requires Microsoft Visual Studio .Net 2003, the Microsoft .Net Compact Framework runtime and the Microsoft Pocket PC 2003 SDK.

LEAD Technologies has ported many features of its LEADTOOLS Raster Imaging Pro for .NET toolkit to the LEADTOOLS Mobile Imaging SDK.

Key Features

File Format Support - Read, write and convert image files of the most popular standard image formats, including JPEG, JPEG2000*, LEAD CMP, LEAD CMW*, TIFF(uncompressed, RLE compressed, LZW compressed, FAX (CCITT/G3/G4) compressed), GIF, PNG, BMP and EXIF. Additionally, 12-16 bit grayscale load/save* is supported.

Display - Complete control of how the image is displayed including zoom, scroll, dither, resample and bicubic resized display and ScaleToGray and FavorBlack resized display for bitonal images*.

Image Processing - Use digital filters and transforms to process images. Resize, rotate, flip, combine, crop, fill, grayscale and color resolution.


LEADTOOLS Multimedia $495

(Contains Multimedia API and Multimedia COM objects.)

Create professional, high-quality multimedia applications with LEADTOOLS Multimedia SDK. Add multimedia functionality such as Capture, Play, and Edit, as well as the latest DirectShow filters and multimedia file support - load/convert to and from many formats (WAV, AVI, ASF, WMA, WMV, MPEG-1, MPEG-2, OGG and more). Get programmatic control over multimedia processors, compressors, video and audio inputs, types and sub-types; as well as increased camera control (brightness, contrast, zoom, etc); more flexible capturing options and much more!

Capture from WDM, native DirectShow including DV, and Video for Windows capture devices

Play all formats supported by DirectShow; process AVI, Windows Media content, WAVE, and MPEG1 Audio (MP3) formats or data as it is captured using DirectX filters

Compress individual samples with any available DirectShow filters (Memory to memory)

Convert to and from AVI, Windows Media content, WAVE, and MPEG1 Audio (MP3) formats

Support the most popular multimedia formats.

LEADTOOLS Multimedia includes an evaluation version of the Multimedia filter pack that includes powerful multimedia processing functionality. For pricing for DirectShow Filter client licenses, contact oemsales@leadtools.com.

This product includes the following features:

Multimedia

Other LEADTOOLS products that can be added to this product:

LEAD MCMP - MJPEG Video Codec

LEAD MCMW Video Codec

LEAD MJPEG2000 Video Codec

LEAD H263 Video Codec

LEADTOOLS eMail


LEADTOOLS Raster Imaging $495

(Contains easy to use ActiveX controls and VCL controls)

LEADTOOLS Raster Imaging provides support for adding to any application the ability to display, load, save, convert or process images. The toolkit supports Color Conversion, Display, and Compression (JPEG, TIFF, CCITT G4 and LEAD's proprietary CMP). Developers get support for all of the technologies found in the LEADTOOLS Raster Imaging Engine, including Image Processing (Transforms, Filters, Drawing, Region of Interest), TWAIN Scanning, Color Conversion, Display, Special Effects, (choose from more than 2000 effects), Compression, Image Format support (140+), Printing, Internet/intranet imaging, Database imaging, Imaging Common Dialogs, and Screen Capture.

This product includes the following features:

Color Conversion

Database Imaging

Files and File Formats

Image Compression

Image Display

Image Processing

Imaging Common Dialogs

Internet/Intranet Imaging

Printing

Scanning / Screen Capture

Special Effects: Display & Drawing

Other LEADTOOLS products that can be added to this product:

LEADTOOLS eMail

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS JPEG 2000 Plug-in

LEADTOOLS CMW Plug-in


LEADTOOLS Raster Imaging Pro $995

(Contains ActiveX, VCL and COM Image Controls, C++ Class Library,and DLL Imaging API)

Like LEADTOOLS Raster Imaging, LEADTOOLS Raster Imaging Pro provides support for adding to any application the ability to display, load, save, convert or process images. The toolkit supports Color Conversion, Display, and Compression (JPEG, TIFF, CCITT G4 and LEAD's proprietary CMP). Developers get support for all of the technologies found in the LEADTOOLS Raster Imaging Engine, including Image Processing (Transforms, Filters, Drawing, Region of Interest), TWAIN Scanning, Color Conversion, Display, Special Effects, (choose from more than 2000 effects), Compression, Image Format support (140+), Printing, Internet/intranet imaging, Database imaging, Imaging Common Dialogs, and Screen Capture.

However, in addition, LEADTOOLS Raster Imaging Pro offers the ability to directly call exported DLL functions, create extremely small footprint applications, obtain low-level access to pixel data, create custom image processing filters, exert full control over load/process/save with callbacks, share images (without copying) via DIBs/DDBs, exert full control over all display options, and support the extended FlashPix file format capabilities.

In addition to all the features supported by the LEADTOOLS Raster Imaging toolkit, this product includes the following features:

FlashPix

Digital Paint

Other LEADTOOLS products that can be added to this product:

LEADTOOLS eMail

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS JPEG 2000 Plug-in

LEADTOOLS CMW Plug-in


LEADTOOLS Raster Imaging Pro for .NET ($995)

VB.NET and C# Programming Tools

Extend and simplify the .NET framework and GDI+ with LEADTOOLS. Support for over 140 file formats including TIFF, JPG, J2K**, PDF**, and GIF using various compression schemes such as JPEG, JPEG2000, LZW, CCITT G3/G4, and CMP. High-speed scanning, 200+ image processing filters, high speed display (resize, rotate, quality controls), and much more in a fully managed SDK developed from the ground up.

LEADTOOLS Raster Imaging Pro for .NET is available as a stand-alone product and is included with the LEADTOOLS Document Imaging and Medical Imaging product lines.

Key Features

.NET File Format Support - Read, write and convert image files in over 140 file formats and sub-formats, including PDF**, JPEG, JPEG2000**, JBIG*, GIF, TIFF (including G3/G4, LZW, CMYK, JTIF, many more), PNG, BMP, MODCA/IOCA, PCX, TGA, and many more!

.NET Compression - Compress images using a wide variety of compression algorithms, including Arithmetic, CCITT G3/G4, Huffman, JBIG, JPEG, JPEG2000, LEAD CMP, LEAD CMW, LZW, RLE / PackBits, and ZIPLIB, among others. LEAD offers comprehensive support for compression schemes found in standard raster file formats, as well as high-performance proprietary compression technologies that outperform the industry standards.

Image Processing in .NET - Use more than 200 digital filters and transforms to process images (or selected portions). Smooth, sharpen, edge detect/enhance, modify brightness/contrast/gamma, change hue and saturation, red-eye removal, unsharp mask, add noise, resize and rotate images using various resampling techniques (including bicubic), and much more.

Region of Interest .NET - Select and process just a select area of the image. Regions can be any shape and based on coordinates or colors in the image. Additionally, the RasterImageViewer class supports a floater image that can be used to move the selected region before combining it with the underlying image. The floater is completely automated within the viewer user interface.

.NET Color Conversion -Convert between color modes, like 24-bit true-color, 8-bit indexed, 1-bit black/white, and many more. Changing the color mode changes the amount of data stored per pixel, which alters an image's memory/disk requirements.

.NET Image Display - Render images or selected regions to a display device while controlling position/scaling, resample method (normal/bilinear/bicubic), brightness/contrast/gamma, color-reduction/dithering, image(source) and device(destination) clipping, and more. A Pan Viewer Control to scroll and pan an image that is larger than the viewing area, and a Magnifying Glass Control for viewing details in an image are included.

TWAIN Scanning .NET - Control image acquisition from any device (scanner, digital camera, etc) that supports TWAIN. Use device's built in user-interface or create your own.

.NET Printing Support - Use the LEADTOOLS .NET Raster Print class to control every aspect of printing. Print images or selected regions while controlling position/scaling, halftoning/dithering. Print multiple images and text to a single or multiple pages.

.NET Internet Support - Includes functions to load images from URL's or memory streams.

Other LEADTOOLS products that can be added to this product:

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS JPEG 2000 Plug-in

** This feature requires additional purchase.


LEADTOOLS Vector Imaging Pro $1995*

(Contains API, C++ class library, ActiveX controls, VCL controls, .NET classes, and COM objects)

* Requires runtime licensing.

The LEADTOOLS Vector Imaging Pro toolkit includes everything you need to create powerful 2-D and 3-D viewers, editors, and converters that support both vector and raster image formats. By creating these types of applications, you eliminate the need to install or license the more expensive original application that created the vector files, and you only have to include the functionality for your specific needs.

The LEADTOOLS Vector Imaging Pro toolkit provides support for 2D and 3D Vector imaging, loading, viewing, modifying and saving vector files to memory or disk in native vector format. Vector formats supported include DXF (2D and 3D), EMF, WMF, CGM, DGN, DRW, DWG, PLT, Gerber, PCL, PCT, SVG, VWPG, CMX and SHP. Vector files can be loaded from one format and saved as another, without the need for the original application that created the file. Vector image formats can be loaded, saved, converted and exported to any of 120+ raster formats. Support for primitive objects include Arc, Bitmap, Brush, Camera, Circle, Clone, Ellipse, Elliptical Arc, Font, Group, Layer, Line, Pen, Pie, Chord, Poly Draw, Polygon, Poly Line, Poly Bezier, Raster, Rectangle, Text, Vertex and Clipping objects. Vector drawings can be edited in any way desired including adding, modifying, deleting and copying objects into the clipboard or between different vector drawings. Vector drawings can be scaled to any resolution desired without distorting the original image, ensuring that fine details of the drawing will not be lost during printing.

This product includes the following features:

Color Conversion

Database Imaging

Files and File Formats

FlashPix

Image Compression

Image Display

Image Processing

Imaging Common Dialogs

Internet/Intranet Imaging

Printing

Scanning / Screen Capture

Special Effects: Display & Drawing

Vector Imaging

Other LEADTOOLS products that can be added to this product:

LEADTOOLS JPEG 2000 Plug-in

LEADTOOLS PDF Read Plug-in

LEADTOOLS PDF Write Plug-in

LEADTOOLS eMail

LEADTOOLS CMW Plug-in


LEADTOOLS Video Conferencing $995

LEADTOOLS Video Conferencing SDK $995*

* Requires runtime licensing.

The LEADTOOLS Video Conferencing SDK has everything you need to create custom video conferencing applications and utilities. The SDK includes the LEADTOOLS Multimedia SDK for advanced multimedia functionality, LEAD Network Multiplexer/Demultiplexer for splitting and merging media, LEAD Network Source to receive streaming data, LEAD Network Sink to stream multiplexed
data, LEAD H.264 Standard Encoder/Decoder to encode and decode high quality video media, and LEAD Vorbis Encoder/Decoder to encode and decode audio data.

Key Features

  • Streaming for Video Conferencing
    Create professional client/server video conference applications using the comprehensive set of specialized audio and video components included with LEADTOOLS Video Conferencing SDK.

  • Multimedia Capture
    Create applications that can capture from WDM, native DirectShow including DV, Video for Windows capture devices, control DV devices and more.

  • Multimedia Playback
    Create applications that can play all formats supported by DirectShow and more. Now with support for DVD navigation!

  • Multimedia Processing
    Add to your applications the ability to process AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats or data as it is captured using DirectX filters. Use the LEAD Video callback DirectShow filter to use any of the 200+ image processing functions to process movies during playback, conversion or capture and more.

  • Multimedia Compression
    Add support to your applications for compressing individual samples with any available DirectShow filters (Memory to memory) and more.

  • Multimedia Conversion
    Add features to your application so your users can convert to and from AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats, select DV devices for output, and more.

  • Multimedia File Formats
    Add support for the most popular multimedia formats. New formats in v14.5 include OGG, MPEG 1 and MPEG 2.

  • DirectX Filters
    LEADTOOLS Video Conferencing SDK includes an evaluation version of the Multimedia filter pack that includes powerful multimedia processing functionality. For pricing for DirectShow Filter client licenses, contact oemsales@leadtools.com .

  • Product Demos
    LEADTOOLS Video Conferencing SDK includes several demo exe's to help you get started with your own development project. NetServer and NetClient demos, Audio Video Detection demo, Audio replace demo, MediaInfo demo, and more.

DirectX 8 or better is recommended, but supports DirectX 7 and earlier.


LEADTOOLS Video On Demand $795

LEADTOOLS Video On Demand SDK $795*

* Requires runtime licensing.

The LEADTOOLS Video on Demand SDK is for developers that need to serve Videos on Demand, offering an unsurpassed multimedia experience while at the same time reducing bandwidth requirements. With LEADTOOLS Video on Demand, you can serve multimedia files using a standard IIS web server or with Microsoft Media Server. LEADTOOLS Video on Demand includes the LEADTOOLS Multimedia SDK and the LEAD H.264 Professional AVC encoder and decoder.

Key Features

Streaming for Microsoft Windows Media Servers
With LEADTOOLS Video on Demand you can use the included H.264 DMO encoder with Windows Media Server for streaming (live or otherwise) video.

  • Multimedia Capture
    Create applications that can capture from WDM, native DirectShow including DV, Video for Windows capture devices, control DV devices and more.

  • Multimedia Playback
    Create applications that can play all formats supported by DirectShow and more. Now with support for DVD navigation!

  • Multimedia Processing
    Add to your applications the ability to process AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats or data as it is captured using DirectX filters. Use the LEAD Video callback DirectShow filter to use any of the 200+ image processing functions to process movies during playback, conversion or capture and more.

  • Multimedia Compression
    Add support to your applications for compressing individual samples with any available DirectShow filters (Memory to memory) and more.

  • Multimedia Conversion
    Add features to your application so your users can convert to and from AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats, select DV devices for output, and more.

  • Multimedia File Formats
    Add support for the most popular multimedia formats. New formats in v14.5 include OGG, MPEG 1 and MPEG 2.

  • DirectX Filters
    LEADTOOLS Video on Demand SDK includes an evaluation version of the Multimedia filter pack that includes powerful multimedia processing functionality. For pricing for DirectShow Filter client licenses, contact oemsales@leadtools.com .

  • Product Demos
    LEADTOOLS Video on Demand SDK includes several demo exe's to help you get started with your own development project. Audio Video Detection demo, Audio replace demo, MediaInfo demo, and more.

DirectX 8 or better is recommended, but supports DirectX 7 and earlier.


LEADTOOLS ABIC* Read Plug-In ($1995)

Check Imaging

The ABIC file format is a raster file format created by IBM.

LEADTOOLS ABIC Read Plug-in is an add-on module for LEADTOOLS Document and Medical toolkits, used for reading ABIC files. ABIC is a compression format for compressing check images.

Key Features:

Reads ABIC files (inside IOCA).

Can Load (compression/decompression) ABIC Raw data separately.

Supports 1 and 4 BPP.

This product may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

* Requires runtime licensing.


LEADTOOLS ABIC* Write Plug-In ($1995)

Check Imaging

The ABIC file format is a raster file format created by IBM.

LEADTOOLS ABIC Write Plug-In is an add-on module for LEADTOOLS Document and Medical toolkits, used for writing files ABIC files. ABIC is a compression format for compressing check images.

Key Features:

Writes ABIC files (inside IOCA).

Can Save (compression/decompression) ABIC Raw data separately.

Supports 1 and 4 BPP.

This product may be added to the following:

LEADTOOLS Document Imaging SDK

LEADTOOLS Document Imaging Suite SDK

LEADTOOLS Medical Imaging SDK

LEADTOOLS Medical Imaging Suite SDK

* Requires runtime licensing.


LEADTOOLS ABC* Plug-in $1495

LEADTOOLS Advanced Bitonal Compression* Plug-In ($1495)

LEADTOOLs Advanced Bitonal Compression (ABC) Plug-In is an add-on module for reading and writing files with LEAD’s proprietary ABC compression. LEAD ABC compression is superior to JBIG2, LZW, TIFF Group 4 and other 1 bit compression.

This product may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

* Requires runtime licensing.


LEADTOOLS Barcode Modules *

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Module product allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode Modules:

Programming Linear (1D), DataMatrix (2D), PDF 417 (2D), and QR Code (2D) Barcodes

Read multiple barcodes at any orientation

Write barcodes to any of over 140+ supported raster image file format or to any windows compliant printer

Encode thousands of characters per barcode symbol with 2D barcode technology

Read barcodes from or write barcodes to selected regions of interest

Read barcodes with specified colors

Write barcode with specified colors]

Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

The following chart shows the features of each module:

LEADTOOLS BARCODE
SDK ADD-ON MODULES

Read from region of interest

Write to region of interest

Read skewed

Read at any orientation

High density information encoding

Error correction

Below is a list of available Barcode modules and their prices:

LEADTOOLS Barcode 1D Symbols Standard* $695

LEADTOOLS Barcode 1D Symbols Advanced* $995

LEADTOOLS Data Matrix (read)* $1395

LEADTOOLS Data Matrix (write)* $1395

LEADTOOLS 2D PDF417 (read)* $1295

LEADTOOLS 2D PDF417 (write* $1395

LEADTOOLS Barcode QR Code (read)* $1395

LEADTOOLS Barcode QR Code (write)* $1295

* Product requires runtime licensing.

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Barcode 1D Symbols Standard* ($695)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode 1D Symbols (Read/Write)

The Barcode 1D (Read/Write) Module is available in either Standard or Advanced versions. The advanced version provides extremely high-speed barcode programming capabilities. The Barcode 1D (Read/Write) Module includes the following features:

Automatic barcode type detection

Read to / write from region of interest

Read in different directions such as left-to-right, right-to-top, diagonal, ... etc.

Read skewed.

Read multiple barcode symbols.

Read mixed barcode types. Report back X/Y positions.

Write barcode symbol with size and position parameters.

Check character handling.

Sub-types supported:

EAN 13

EAN 8

UPC A

UPC E

Code 39

Code 128

Interleaved 2 of 5

CODABAR

UCCEAND 128 (read only)

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Barcode 1D Symbols Advanced* ($995)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode 1D Symbols (Read/Write)

The Barcode 1D (Read/Write) Module is available in either Standard or Advanced versions. The advanced version provides extremely high-speed barcode programming capabilities. The Barcode 1D (Read/Write) Module has the following features:

Automatic barcode type detection

Read to / write from region of interest

Read in different directions such as left-to-right, right-to-top, diagonal, ... etc.

Read skewed.

Read multiple barcode symbols.

Read mixed barcode types. Report back X/Y positions.

Write barcode symbol with size and position parameters.

Check character handling.

Sub-types supported:

EAN 13

EAN 8

UPC A

UPC E

Code 39

Code 128

Interleaved 2 of 5

CODABAR

UCCEAND 128 (read only)

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Data Matrix* (Read) ($1395)

LEADTOOLS Data Matrix (Read)* ($1,395)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode 2D DataMatrix (Read) Key Features:

Contains Error Correction Code (ECC) to fix damaged barcode symbols.

Reads color and gray symbols.

Store up to 2,218 ASCII characters in one barcode symbol; chain symbols to encode up to 33,225 characters.

Read barcodes independent of skew, orientation, flipping. Read barcodes from region of interest, contained in any supported image file format (over 140 supported), acquired from scanner or digital camera.

Sub-types supported:

Default DataMatrix Size | DataMatrix size 64x64
DataMatrix size 10x10 | DataMatrix size 72x72
DataMatrix size 12x12 | DataMatrix size 80x80
DataMatrix size 14x14 | DataMatrix size 88x88
DataMatrix size 16x16 | DataMatrix size 96x96
DataMatrix size 18x18 | DataMatrix size 104x104
DataMatrix size 20x20 | DataMatrix size 120x120
DataMatrix size 22x22 | DataMatrix size 132x132
DataMatrix size 24x24 | DataMatrix size 144x144
DataMatrix size 26x26 | DataMatrix size 8x18
DataMatrix size 32x32 | DataMatrix size 8x32
DataMatrix size 36x36 | DataMatrix size 12x26
DataMatrix size 40x40 | DataMatrix size 12x36
DataMatrix size 44x44 | DataMatrix size 16x36
DataMatrix size 48x48 | DataMatrix size 16x48
DataMatrix size 52x52 | DataMatrix Default Rectangular size

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Data Matrix* (Write) ($1395)

LEADTOOLS Data Matrix (Write)* ($1,395)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode 2D DataMatrix (Write) Key Features:

Contains Error Correction Code (ECC) to fix damaged barcode symbols.

Writes color and gray symbols.

Store up to 2,218 ASCII characters in one barcode symbol; chain symbols to encode up to 33,225 characters.

Write to any supported raster format (over 140) into region of interest, print to any Windows compliant printer.

Sub-types supported:

Default DataMatrix Size | DataMatrix size 64x64
DataMatrix size 10x10 | DataMatrix size 72x72
DataMatrix size 12x12 | DataMatrix size 80x80
DataMatrix size 14x14 | DataMatrix size 88x88
DataMatrix size 16x16 | DataMatrix size 96x96
DataMatrix size 18x18 | DataMatrix size 104x104
DataMatrix size 20x20 | DataMatrix size 120x120
DataMatrix size 22x22 | DataMatrix size 132x132
DataMatrix size 24x24 | DataMatrix size 144x144
DataMatrix size 26x26 | DataMatrix size 8x18
DataMatrix size 32x32 | DataMatrix size 8x32
DataMatrix size 36x36 | DataMatrix size 12x26
DataMatrix size 40x40 | DataMatrix size 12x36
DataMatrix size 44x44 | DataMatrix size 16x36
DataMatrix size 48x48 | DataMatrix size 16x48
DataMatrix size 52x52 | DataMatrix Default Rectangular size

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Barcode 2D PDF 417* (Read) ($1295)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode 2D PDF 417 (Read) Key Features:

Store up to 1,815 ASCII characters in one barcode symbol.

Contains Error Correction Code (ECC) to fix damaged barcode symbols.

Read barcodes independent of skew, orientation, flipping. Read barcodes from region of interest, contained in any supported image file format (over 140 supported), acquired from scanner or digital camera.

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Barcode 2D PDF 417* (Write) ($1395)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode 2D PDF 417 (Read) Key Features:

Store up to 1,815 ASCII characters in one barcode symbol.

Contains Error Correction Code (ECC) to fix damaged barcode symbols.

Write to any supported raster format (over 140) into region of interest, print to any Windows compliant printer.

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Barcode QR Code* (Read) ($1395)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode QR Code (Read) Key Features:

Create QR Code type of barcode symbols from alpha/numerical text.

Includes Error Correction Code (ECC), which eliminates possibility of corrupted read data.

Stores up to 2,335 ASCII characters in one barcode symbol.

Uses Error Correction Code (ECC) to fix damaged barcode symbols.

Reads barcode symbols independent of skew, orientation, flipping, and mirroring.

Output QR Code barcode symbols to any Windows compliant printer.

Sub-types supported:

QR Default size | QR M2 18 | QR M2 37
QR M2 1 | QR M2 19 | QR M2 38
QR M2 2 | QR M2 20 | QR M2 39
QR M2 3 | QR M2 21 | QR M1 40
QR M2 4 | QR M2 22 | QR M1 1
QR M2 5 | QR M2 23 | QR M1 2
QR M2 6 | QR M2 24 | QR M1 3
QR M2 7 | QR M2 25 | QR M1 4
QR M2 8 | QR M2 26 | QR M1 5
QR M2 9 | QR M2 27 | QR M1 6
QR M2 10 | QR M2 28 | QR M1 7
QR M2 11 | QR M2 29 | QR M1 8
QR M2 12 | QR M2 30 | QR M1 9
QR M2 13 | QR M2 31 | QR M1 10
QR M2 14 | QR M2 32 | QR M1 11
QR M2 15 | QR M2 33 | QR M1 12
QR M2 16 | QR M2 34 | QR M1 13
QR M2 17 | QR M2 35 | QR M1 14
 | QR M2 36 | QR M1 DEF

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS Barcode QR Code* (Write) ($1295)

(Barcode SDK plug-ins include API, C++ Class and ActiveX controls)

* Requires runtime licensing.

The LEADTOOLS Barcode Modules products allows programmers to easily include code in their applications to read and write Linear (1D), DataMatrix (2D), PDF417 (2D), and QR Code barcodes - includes support for 41 different sub-types.

Barcode QR Code (Write) Key Features:

Create QR Code type of barcode symbols from alpha/numerical text.

Includes Error Correction Code (ECC), which eliminates possibility of corrupted read data.

Stores up to 2,335 ASCII characters in one barcode symbol.

Uses Error Correction Code (ECC) to fix damaged barcode symbols.

Output QR Code barcode symbols to any Windows compliant printer.

Sub-types supported:

QR Default size | QR M2 18 | QR M2 37
QR M2 1 | QR M2 19 | QR M2 38
QR M2 2 | QR M2 20 | QR M2 39
QR M2 3 | QR M2 21 | QR M1 40
QR M2 4 | QR M2 22 | QR M1 1
QR M2 5 | QR M2 23 | QR M1 2
QR M2 6 | QR M2 24 | QR M1 3
QR M2 7 | QR M2 25 | QR M1 4
QR M2 8 | QR M2 26 | QR M1 5
QR M2 9 | QR M2 27 | QR M1 6
QR M2 10 | QR M2 28 | QR M1 7
QR M2 11 | QR M2 29 | QR M1 8
QR M2 12 | QR M2 30 | QR M1 9
QR M2 13 | QR M2 31 | QR M1 10
QR M2 14 | QR M2 32 | QR M1 11
QR M2 15 | QR M2 33 | QR M1 12
QR M2 16 | QR M2 34 | QR M1 13
QR M2 17 | QR M2 35 | QR M1 14
 | QR M2 36 | QR M1 DEF

Portions of Barcode SDK Module, © Axtel Inc.,1999

The LEADTOOLS Barcode Modules may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS CMW Plug-in $995*

(Contains API, C++ class library, .NET classes, and easy to use ActiveX controls, VCL controls and COM objects)

* Requires runtime licensing.

LEADTOOLS CMW compression/decompression outperforms all other known image compression algorithms in quality and compression ratio. CMW, a LEAD Technologies, Inc. proprietary technology, is a new advanced compression algorithm that is better than JPEG2000 in quality, speed and compression ratios. The LEADTOOLS CMW includes support for multiple resolutions. This makes your applications faster and more memory efficient because the entire file does not have to be loaded and decompressed just to load a low resolution image. And, just like with JPEG2000, you have the ability to specify a progression order, giving you control over the display effect during a progressive decompression. Additionally, you have complete control of the resulting file size and quality. You can choose to compress a file based on target file size, compression ratio, or quality factor. You can even specify to use lossless compression so that when the compressed image is decompressed it will be exactly th same as the original image.

This product includes the following features:

Files and Files Formats

Image Compression

This product may be added to the following:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro

LEADTOOLS Multimedia


LEADTOOLS eMail Module $99

(Adds on to any Version 14 SDK)

The LEADTOOLS eMail toolkit connects directly to Simple Mail Transfer Protocol (SMTP) and Post Office Protocol 3 (POP3) servers (Messaging Application Programming Interface (MAPI) is not required). The toolkit allows you to quickly add eMail functionality to your application, and control it.

This product includes the following features:

eMail

Other LEADTOOLS that can be used with this product:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro

LEADTOOLS Multimedia

LEADTOOLS ePrint


LEADTOOLS ICR Module* $1995

(Contains API and COM only)

* Requires runtime licensing.

The ICR features provide functions, properties, methods, and events for converting handwritten text and numbers into machine readable strings and documents. The LEADTOOLS ICR Module can be used in the same fashion and mixed on the same image as the OCR module. The LEADTOOLS ICR module supports hand written text in nearly 100 languages including 15 with dictionary support.

This product includes the following features:

The LEADTOOLS ICR module supports hand written text in nearly 100 languages including 15 with dictionary support.

LEADTOOLS ICR features are implemented using two engines:

HNR - Hand printed numeral recognition engine, designed using a reduced character set for improved speed and accuracy. It is specialized to recognize the following:

digits (0-9)

plus sign (+)

minus sign (-)

period or full-stop (.)

comma (,)

comma (,)

RER - reRecognition Hand print recognition engine is designed to recognize upper and lower case text, numbers and symbols.

The LEADTOOLS ICR engines support the following features:

Export to over 40 output formats.

Use in the same fashion as the OCR module.

Mix different recognition modules (including the OCR module) on the same image

Specify a different recognition module for each zone in the same page.

Improve recognition results with dictionaries, available in the following languages:

Catalan

Czech

Danish

Dutch

English

Finnish

French

German

Hungarian

Italian

Norwegian

Polish

Portuguese

Spanish

Swedish

And more...


LEADTOOLS JBIG2* Plug-In ($995)

LEADTOOLS JBIG2 is an add-on module for LEADTOOLS Document and Medical toolkits, used for reading and writing files with JBIG2 compression. The JBIG2 compression is superior to LZW, TIFF Group 4 and other 1 bit compression.

The JBIG2 file format is a raster file format created by ISO/IEC 14492. This format is supported by Image Power. This format is an industry standard lossless, lossy and lossy to lossless compressed file format for bi-tonal (black and white) images. LEAD’s JBIG2 support handles the various flavor of generic region encoding/decoding procedure based on sequential coding of the image pixels using arithmetic coding (lossless). Saving images in a JBIG2 format results in smaller image files sizes when compared to other industry standard compressed formats such as JBIG, CCITT G3 or G4. JBIG2 can compress bi-tonal images 2 - 5 times more than the same image compressed with the CCITT G4 compression.

This product may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

* Requires runtime licensing.


LEADTOOLS JPEG 2000 Plug-in $995

(Contains API, C++ class library, .NET classes, and easy to use ActiveX controls, VCL controls and COM objects)

(adds on to all products)

LEADTOOLS JPEG 2000 Plug-in conforms to the JPEG 2000 International Standard. JPEG2000 provides high compression with image quality superior to all existing standard encoding techniques. This high compression and quality performance is due to the adaptation of wavelet transforms. Wavelet transforms are mathematical formulas that represent complex structures in the image, thereby compressing an extremely large amount of image data into a relatively small amount of compressed data. This compression technique allows applications to save compressed images with higher compression ratios and better image quality as compared to any other software currently in production.

This product, when used with LEADTOOLS Medical Imaging products, adds support for lossy and lossless JPEG2000 compression, including 8, 10 – 16-bit grayscale and 24-bit color images in DICOM.

This product includes part of the following features:

Files and Files Formats

Image Compression

This product may be added to the following:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Multimedia

LEADTOOLS Vector Imaging Pro


LEADTOOLS OCR Module $1995

(Contains API and COM only)

The OCR features provide functions, properties, methods, and events for easily incorporating the ScanSoft SDK 12 Pro optical character recognition engine into your applications.

This product includes the following features:

OCR

This product may be added to the following:

LEADTOOLS Document Imaging

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

This product is included as part of the following:

LEADTOOLS Document Imaging Suite


LEADTOOLS OMR Module $1995

LEADTOOLS OMR Module* $995

(Contains API and COM only)

* Requires runtime licensing.

The LEADTOOLS OMR module is used for recognizing optical marks (checkmarks). Typical applications include the processing of questionnaires, ballots, educational tests and reporting, and ordering sheets, where the documents to be processed are form-like and filled in by hand by respondents.

The OMR features that are included with this add-on module extend the functionality of the LEADTOOLS Document Imaging, Document Imaging Suite, and the LEADTOOLS OCR Module by providing properties, methods, and events for easily incorporating the ScanSoft SDK 12 Pro engine into your applications.

When recognizing an optical mark, the frame for the mark can be a rectangle, a hexagon, a circle, or an ellipse and can be filled in by any method (x, tick, hatching, horizontal or vertical lines, etc.). The frame may be visible or invisible (scanner dropout) in the image sent for recognition.

Recognition accuracy is 99.95% and the average recognition time is 0.005 seconds per check box zone (measured on a computer with 166 MHz Pentium Processor / 16 MB RAM).


LEADTOOLS PDF OCR Plug-in* $1495

(adds on to the LEADTOOLS OCR Module and the LEADTOOLS Document Imaging Suite)

* Requires runtime licensing.

The LEADTOOLS PDF OCR Plug in allows programmers to easily include code in their applications to perform character recognition on document files and to output recognized text to the PDF file format.

This product includes the following features:

PDF

This product may be added to the following:

LEADTOOLS OCR Module

LEADTOOLS Document Imaging Suite


LEADTOOLS Advanced PDF Compressor*± ($1995)

* Requires runtime licensing.

**This feature requires a Document Imaging Product.

± Some functionality is only included in the Read/Write version.

The Advanced PDF Compressor Plug-in includes the PDF Write Plug-in plus optimized compression options with MRC (mixed raster content). In essence MRC allows you to segment a document into regions and apply the best possible compression to the different regions. For example, JBIG2 can be applied to bitonal sections and JPEG2000 can be applied to the color image section.

The LEADTOOLS Advanced PDF Compressor produces highly optimized PDF files. This is accomplished by utilizing the superior LEADTOOLS compression algorithms to produce highly compressed PDF files while maintaining the best file quality possible. The PDF Compressor relies on the Mixed Raster Content (MRC) technology, which allows the segmentation of a specific image into many smaller segments. The smaller produced segments will then be compressed one at a time with the best compression algorithm possible for that specific segment. The result is many segments in an image; each one of these segments is actually compressed with the best possible algorithm which ultimately produces a PDF file with best quality and best size.

Features:

Supports many compression types:

  • ZIP (Flate compression)

  • LZW

  • FAX CCITT (G3 1D, G3 2D, G4)

  • JBIG2

  • Lossless JPEG

  • JPEG ( YUV 4.4.4, YUV 4.2.2 and YUV 4.1.1 )

Works in 2 modes in the page level:

  • MRC mode: enables the segmentation of the source image and then to compress the resulting segments.

  • Normal mode: inserts the image into the PDF file without segmentation.

Produces v1.4 (Adobe Acrobat 5.X) PDF files.

Provides advanced options to control the process of adding the segments to the PDF file.

Provides input profiles to specify source image quality. This makes controlling the segmentation process more accurate and simple. The input profiles supported are:

  • Automatic: The PDF compressor will automatically handle this.

  • Noisy

  • Scanned

  • Printed

  • Computer-generated

  • Photo

  • User: This profile is provided for advanced users.

Provides output profiles to specify required output quality. This should also make the segmentation process easier and more accurate. The output profiles supported are:

  • Automatic: The PDF compressor will automatically make the choice.

  • Poor

  • Average

  • Good

  • Excellent

  • User: This profile is provided for advanced users.

Provides control over the compression types that will be used with each type of segments. For example, the user of the PDFCompressor can choose to use the FAX CCITT G4 compression type to handle 1 bit/pixel segments.

Background detection is supported. The user can enable background detection which should try to determine the background of the provided image. In that case, the PDF Compressor will NOT store the background segments which will result in a more compact PDF files.

Background is created using shapes instead of image segments. This reduces the size of the resulting PDF file effectively.

Control over 1Bit and 2Bit segments detection: The user can choose to favor 1Bit segments over 2Bit segment and vice versa. The user also can choose to force 1Bit segments over 2Bit segments and vice versa as well.

Loads EPS files.±

This product includes the following features:

PDF

This product may be added to the following:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS PDF Read Plug-in*± ($995)

* Requires runtime licensing.

**This feature requires a Document Imaging Product.

± Some functionality is only included in the Read/Write version.

The LEADTOOLS PDF Plug-ins are add-on modules for all LEADTOOLS Toolkits with exception of LEADTOOLS Multimedia and extends support to include PDF, Postscript, and EPS formats. The LEADTOOLS PDF SDK Plug-ins support loading±, saving, viewing±, rasterizing±, and encoding of these three formats and integrates seamlessly with the broad imaging functionality present in the existing LEADTOOLS toolkits, encompassing specialized display, color-conversion, image-processing, scanning, annotations**, document clean-up**, and much more.

Loading Capabilities:

The LEADTOOLS PDF plug-in has the following import capabilities:

Loads PDF 1.4 files.±

Loads PostScript Language Level 3 files.±

Loads EPS files.±

Support is provided for loading the entire document or a specified set of sequential pages.±

The plug-in provides a number of options for controlling the rasterization± of the page, including:

Pixel depth - Valid values are 1,4,8 and 24.±

Horizontal resolution in dots per inch.±

Vertical resolution in dots per inch.±

Ability to use fonts installed by the plug-in or system fonts.±

Font anti-aliasing - Valid values are 1-bit(no anti-aliasing), 2-bit and 4-bit.±

Graphics anti-aliasing - 1-bit , 2-bit and 4-bit.±

Saving Capabilities:

Full multi-page write support is provided by this module for the PDF format. You can append, insert, replace or delete a specified page in the generated PDF file.

The plug-in gives you a wide range of control options for the resulting image data in terms of compression. These include:

No compression, where the image is embedded inside the file without any compression.

Compressed using CCITT Group 3, 1 dimension. For 1-bit images.

Compressed using CCITT Group 3, 2 dimensions. For 1-bit images.

Compressed using CCITT Group 4. For 1-bit images.

JPEG compression and YUV 4:4:4 color space loss-less. Bits per pixel: 8 for grayscale, 24 for color.

JPEG compression and YUV 4:2:2 color space. Bits per pixel: 8 for grayscale, 24 for color.

JPEG compression and YUV 4:1:1 color space. Bits per pixel: 8 for grayscale, 24 for color.

JBIG2 compression. Bits per pixel: 1.

The plug-in also gives you control over the type of encoding to be used in order to change compressed image data into a text encoded format. The text encoding techniques include:

  • No text encoding at all.

  • ASCII 85 text encoding algorithm.

  • ASCII HEX text encoding technique.

Encryption/Decryption Capabilities:

RC4 40-bit key encryption.

RC4 128-bit key encryption.

Support for User password, Owner password permissions.

This product includes the following features:

PDF

This product may be added to the following:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS PDF Write Plug-in*± ($495)

* Requires runtime licensing.

**This feature requires a Document Imaging Product.

± Some functionality is only included in the Read/Write version.

The LEADTOOLS PDF Plug-ins are add-on modules for all LEADTOOLS Toolkits with exception of LEADTOOLS Multimedia and extends support to include PDF, Postscript, and EPS formats. The LEADTOOLS PDF SDK Plug-ins support loading±, saving, viewing±, rasterizing±, and encoding of these three formats and integrates seamlessly with the broad imaging functionality present in the existing LEADTOOLS toolkits, encompassing specialized display, color-conversion, image-processing, scanning, annotations**, document clean-up**, and much more.

Loading Capabilities

The LEADTOOLS PDF plug-in has the following import capabilities:

Loads PDF 1.4 files.±

Loads PostScript Language Level 3 files.±

Loads EPS files.±

Support is provided for loading the entire document or a specified set of sequential pages.±

The plug-in provides a number of options for controlling the rasterization± of the page, including:

Pixel depth - Valid values are 1,4,8 and 24.±

Horizontal resolution in dots per inch.±

Vertical resolution in dots per inch.±

Ability to use fonts installed by the plug-in or system fonts.±

Font anti-aliasing - Valid values are 1-bit(no anti-aliasing) , 2-bit and 4-bit.±

Graphics anti-aliasing - 1-bit , 2-bit and 4-bit.±

Saving Capabilities

Full multi-page write support is provided by this module for the PDF format. You can append, insert, replace or delete a specified page in the generated PDF file.

The plug-in gives you a wide range of control options for the resulting image data in terms of compression. These include:

No compression, where the image is embedded inside the file without any compression.

Compressed using CCITT Group 3, 1 dimension. For 1-bit images.

Compressed using CCITT Group 3, 2 dimensions. For 1-bit images.

Compressed using CCITT Group 4. For 1-bit images.

JPEG compression and YUV 4:4:4 color space loss-less. Bits per pixel: 8 for grayscale, 24 for color.

JPEG compression and YUV 4:2:2 color space. Bits per pixel: 8 for grayscale, 24 for color.

JPEG compression and YUV 4:1:1 color space. Bits per pixel: 8 for grayscale, 24 for color.

JBIG2 compression. Bits per pixel: 1.

The plug-in also gives you control over the type of encoding to be used in order to change compressed image data into a text encoded format. The text encoding techniques include:

  • No text encoding at all.

  • ASCII 85 text encoding algorithm.

  • ASCII HEX text encoding technique.

Encryption/Decryption

RC4 40-bit key encryption.

RC4 128-bit key encryption.

Support for User password, Owner password permissions.

This product includes the following features:

PDF

This product may be added to the following:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


LEADTOOLS ePrint $99 and down

LEADTOOLS ePrint $49

(Contains the Driver, API and COM Objects)

LEADTOOLS ePrint is an image/file converter that allows you to convert your images or documents from any Windows application to over 150 file types including searchable PDF, DOCUMENT, TIFF, JPEG, etc., as easily as printing the file. Set up multiple ePrint printers with different settings so that you can easily handle your workflow in the most efficient manner. LEADTOOLS ePrint includes print redirection to any of the over 150 supported image and document formats, broadcast printing to print to more than one printer at a time, and enhanced printing to add advanced printing features.

LEADTOOLS ePrint makes conversion to searchable PDF easier from any of your applications. It includes more PDF options than ever, like Font Embedding, Unicode Support, Bookmarks, Watermarks, Security, Compression, and more.

This product contains part of the following feature:

Printing


ePrint Terminal Server* $1995

(ePrint TS)

ePrint Terminal Server Edition is perfect for companies needing to purchase multiple copies of ePrint without the hassle of installing it on each individual employee's computer. ePrint TS provides system administrators with a centralized location for ePrint software installation as well as updates and upgrades.

You get all the great features of ePrint IV--file conversion/creation, broadcast printing, document merging, and more--without the extra work of maintaining it on multiple client machines! For example, if your company has its headquarters in Chicago but also has offices in Phoenix, Baltimore and New Jersey, you can install ePrint TS at one central office but users at all locations will be able to use it without having to actually install the software.

ePrint TS has a 'Users Manager' which allows the system administrator to add, find, delete or modify users. The number of users added depends on the number of licenses you have purchased.

ePrint TS can be installed on Microsoft Windows 2000 Server and later (with terminal services installed), with and without Citrix.

*Includes one server license and one user license. A license is required for each individual user of the Terminal Server Edition.

Note: ePrint Terminal Server edition can be also be purchased in combination with ePrint OEM Professional for $3495, saving $250 over buying each product separately. The combination includes the API and one server license.


ePrint OEM $1750

(API)

The ePrint OEM version provides an installation API to control the ePrint features that are installed, including ePrint installation folder, name of the installation, output file formats supported and many other features. The purchase price includes 50 user licenses.

The ePrint OEM API controls the following ePrint properties:

  • Printer Name

  • Driver Name

  • Monitor Name

  • Port Name

  • Product Name

  • Serial Number

  • Registry Subkey

  • Root Director

  • Help File Name

  • Available Paper Sizes

  • Available X Resolutions

  • Available Y Resolutions

  • Hide/Show Option Tabs

  • About String

  • About Icons

  • Save Format Types

  • Vector

  • Raster

  • Document

  • Save Output Formats

  • TIFF

  • JPEG

  • over 200 possibilities

  • Email Configuration

  • Sender Name

  • Sender Address

  • Reply To Address

  • SMTP Server

  • Username

  • Password

  • Server Time Out

  • Port

  • Requires Authentication

  • Resolutions

Note: ePrint OEM Professional can be also be purchased in combination with ePrint Terminal Server Edition for $3495, saving $250 over buying each product separately. The combination includes the API and one server license.


LEADViEW $99

LEADViEW is an easy to use yet powerful and full-featured image editor. With LEADViEW, you can create, modify, enhance and retouch images. Use LEADViEW to:

Import/capture images from TWAIN scanners, digital cameras, digital video cameras, or screen.

Save or convert images to numerous Files and File Formats.

Process images for color correction and enhancement using a wide variety of filters and over 48 special effects.

Edit or retouch images with powerful painting and drawing tools.

Print and composite images using an interactive visual print layout system.

Use WYSIWYG Print Preview that can change the size, orientation and position of the image on the fly.

Manage photos using LEAD Photo Album.

Generate image-maps for use in web pages, using a visual image-map editor.


LEAD Capture and Convert $49

LEAD Capture and Convert $89

LEAD Capture and Convert makes it easy for you to capture video and audio, and convert multimedia files from one format to another. Convert one or more media files to DVD, VCD and web streaming formats in one easy process with complete control of the size, quality and compression. Capture and share home movies with friends and family. Save disk space by converting MP3 music files to Vorbis encoded Ogg files. With LEAD Capture and Convert, the possibilities are endless.

LEAD Capture and Convert is a professional suite of two powerful and feature rich applications that enable you to complete a wide range of multimedia tasks. LEAD Capture will record streaming video, still images and sound from cameras, digital video (DV) tapes, or audio devices. LEAD Convert gives you the power to convert your video and audio files to and from all popular media formats.

  • Capture streaming or still images and sound from a wide variety of devices including cameras, digital video (DV) Video Recorders, TV tuners and audio devices.

  • Add different audio and video effects during capture.

  • Create multiple still image files from a video file.

  • Convert audio and video files from one format to another.

  • Compress audio and video files using customized compression options.

  • Apply a selection of audio and video effects during conversion.

  • Convert the same file using several different compression options, sizes and effects in one easy process.

Key Benefits

LEAD Capture

  • Easy to use yet powerful capturing application, suitable for both novice and advanced users.

  • Capture video from DV camcorder, Webcam or any video source such as a TV tuner.

  • Create encoded media files from capturing devices. Encode to AVI, WMV, OGG and other formats. Use LEAD encoders or any 3rd party encoders. Also, you may capture still images in form of series or multi-page image with number of popular formats.

  • Control VCR or TV tuner devices. You can schedule capturing tasks to run when you’re away.

  • Produce highly compressed/high quality video and audio files.

  • Ability to use real time video special effects like resize, rotate and deinterlace.

LEAD Convert:

  • User-Friendly Interface - Windows Explorer-like user interface allows you to perform all operations easily. This makes LEAD Convert suitable for both novice and advanced users.

  • Batch conversion capabilities - Convert more than one file in succession. Set up several conversions and let them run one after another.

  • Supports many well known video source & video target file formats as well as many static image formats - AVI, MPEG, MP2, MP3, MOV and many, many more!

  • Compress audio and video files using any codec (compressor) already installed on your computer. Included are several advanced video and audio codecs to make your media files smaller while maintaining high quality.

  • Shipped with LEAD Capture and Convert are several FREE codecs. MPEG-1, MPEG-2, MJPEG, MCMP, MCMW, MJPEG2000, Vorbis and more.

Whether you're a web designer who needs to convert files to different formats, or a hobbyist who wants to standardize your collection of multimedia files, LEAD Convert gives you the tools you'll need:

  • Extract single video frames to image files using LEAD vast amount of raster file formats.

  • Build a new AVI file from selected images using the "Join Files" utility.


LEAD Capture and Present $49

LEAD Capture and Present is a powerful, easy-to-use screen recording application. LEAD Capture and Present captures the changing screen, recording all of the visible activity that occurs on your desktop or specified area of the screen. Record audio commentary to accompany your video for impressive sales presentations or training materials.

Whether you move the cursor, launch a new program, type some text, click a few buttons, or select menus - anything that you see on your screen - LEAD Capture and Present will record and allow you to play back later on.

What can you do?

  • Create training materials and tutorials.

  • Create multimedia software demos.

  • Record and publish computer activity.

  • Add help and customer support to your website with video demos

  • Record audio along with your screen captures or add audio later after recording.

  • Apply annotations with options of colors and pen size.

  • Combine different types of files into one video.

Key Benefits

This easy to use yet powerful screen capturing application captures the changing screen, recording all of the visible activity that occurs on your desktop or specified area (full screen, rectangular area of the screen, active window, or any window, button, or control on the screen). You can record audio while capturing from screen to add sound and commentary to your captures.

Highlights:

  • Sales/Product Demos
    Create effective sales and product demonstrations by showing your customers the power of your product in action!

  • Develop Step-by-step Training Videos
    Use Capture and Present as a cost effective way to train employees and customers by recording step-by-step instructions on how to use a product, internal system application, and more. Save time and money by eliminating the need for lengthy training sessions.

  • Extremely small file size
    LEAD Capture and Present includes several LEAD Video Codecs to enhance compression for your videos. Now you can stream your demo videos over the web without worrying about bandwidth issues!

  • Recording Made Fast and Easy
    Start/Stop recording with one click or using a hotkey. An easy-to-use wizard guides you though the recording process. No experience necessary! Support of full screen, area of the full screen, or any window, button, toolbar.

  • Features for Basic or Professional Video Demos
    Capture and Present gives you the features for creating the most basic video tutorial or a truly professional quality video demo. Add commentary during or after recording, apply annotations for additional instructions, and much more.


LEAD H.263 Video Codec $49

(Download only) H.263 is an ITU standard, designed for low bit rate communications such as video-conferencing and video-telephony applications. At the same time it can be used for a wide range of bit rates and not just low bit rates. H.263 is a hybrid of interframe compression that makes use of temporal redundancy and intraframe transform coding to use spatial redundancy as a compression advantage. Accordingly, a superior compression ratio can be achieved in comparison to other video codecs.

The LEAD H.263 codec is a high quality lossy interframe DirectShow and Video for Windows (VfW) codec with a quality and compression ratio comparable to MPEG-4. It can be used for a range of applications including video-conferencing, Internet video or surveillance and monitoring. The LEAD H.263 codec is suitable for videos captured from cameras as well as video screen captures. This video codec registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow and Microsoft Video for Windows®. Existing video software, such as Windows® Media Player® and Ulead Media Studio® can utilize this codec to play, create, convert and edit.

Key features of the LEAD H.263 Video Codec:

Interframe compression comparable to MPEG-4.

Rate control algorithm based on the TMN8 which is suitable for videophone applications.

The encoder accepts RGB24 and RGB32 formats.

Decoder can produce RGB24, RGB32 YUY2, RGB555 and RGB565 formats.

Codec implements all elements and functionality of ITU-T H.263+, plus

  • Deblocking Filter Mode (Annex J).

  • Unrestricted Motion Vector (Annex D).

  • Advance Intra Coding Mode (Annex I)

  • Advance Prediction Mode (Annex F)

  • Modified Quantization Mode (Annex T)

  • Alternative Inter VLC Mode (Annex S)

Supports any video dimension.

Employs half pixel precision for motion compensation.

Unrestricted motion vectors.

LEAD Video Codec is a trademark of LEAD Technologies, Inc. Adobe Premier is a trademark of Adobe Systems Incorporated. Ulead Media Studio is a trademark of Ulead Systems, Inc. Windows™ and Windows™ Media Player are either a trade mark or a registered trademark of Microsoft Corporation

This product includes parts of the following features:

Image Compression

Files and File Formats


LEAD H.264 Video Codecs

LEAD H.264 Video Codec

(Download only) H.264 is a high quality video compression algorithm and is suited for all types of applications with different ranges of bit rates. H.264 compressed video data can be stored inside AVI or OGG files with the option of saving the file with or without the audio data.

LEAD H264 Video Codec is a state-of-the-art DirectShow filter for compressing and decompressing video data using H.264/AVC standard. H.264 is the latest and most advanced video standard developed jointly by ITU and MPEG. H.264/AVC provides a far more efficient algorithm for compressing video than any other compression method available. It typically outperforms all existing standards by a factor of three to four especially in comparison to MPEG-2.

Key features of the LEAD H.264 Video Codec:

  • User-definable motion estimation settings control the balance between encoder speed and quality.

  • The LEAD H.264 encoder makes use of the SAD HADAMARD calculation to increase the compression ratio.

  • Multiple reference frames of any combination of past and future frames, provides precise interprediction as well as improved robustness during packet loss while streaming over the network or Internet.

  • Unrestricted motion search uses reference frames that may be partly outside the frame improving network performance by predicting missing data.

  • Only the difference between motion vectors is saved, increasing the compression ratio.

  • Intraprediction may be performed either on 4x4 blocks or 16x16.

  • Motion vector prediction is performed before the frame is prepared for compression (pre-DCT) improving prediction and compression performance.

  • Computation is more efficient because LEAD implements the traditional Discrete Cosine Transform (DCT) as an integer transform.

  • A context-sensitive deblocking filter smoothes out internal edges, significantly improving the visual quality of the video. The filter strength depends upon the prediction modes and relationship between the neighboring blocks.

  • Employs Context-Adaptive Variable Length Coding (CAVLC) to encode transform coefficients.

  • The Context-Adaptive Binary Arithmetic Coding (CABAC) method continually updates frequency statistics of the incoming data and adaptively adjusts the algorithm, improving compression performance.

  • The LEAD H.264 encoder provides the user control of the number and types of frames encoded into the video stream.

MPEG-4 Part 10 is a high quality compression developed by the Video Coding Experts Group (VCEG) together with the ISO/IEC Moving Picture Experts Group (MPEG). The technology is also known as AVC, for Advanced Video Coding.

LEAD offers the following versions of the H.264 Video Codec:

  • LEAD H.264 Video Decoder $25

  • LEAD H.264 Standard Video Encoder $100

  • LEAD H.264 Professional Video Encoder $400

In addition to the capabilities supported in the LEAD H.264 Video Codec Standard, the LEAD H.264 Video Codec Professional also provides the following:

  • Includes 8 additional optional settings that can deliver files that are up to 40% smaller than those created using the Standard version.

  • Includes the DMO version of the codec

  • Includes additional options to control the bit rate


LEAD_MJPEG2000_Codec_$9_95

LEAD MJPEG2000 Video Codec $9.95

(Download only)

JPEG2000 provides high compression with image quality superior to all existing standard encoding techniques. This high compression and quality performance is due to the adaptation of wavelet transforms.

What is MJ2K?

MJPEG2000 or MJ2K is a video adaptation of the JPEG2000 standard for still photos. It treats a video stream as a series of still photos, compressing each individually, with no interframe compression. Because it uses no interframe compression, it is ideal for editing. The JPEG2000 standard is the official successor to JPEG and will eventually replace the older JPEG standard for high-quality image compression.

The LEAD MJPEG2000 video codec saves standard JPEG2000 streams. This codec is perfect when high compression and interoperability are necessary. This video codec registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit industry standard motion JPEG2000.

Key features of the LEAD MJPEG2000 Video Codec:

J2K offers higher compression efficiency than JPEG with less visual loss especially at extreme compression ratios.

Is built to the JPEG2000 standard of compression for maximum interoperability.

A single code stream that offers both lossy and superior lossless compression.

Better transmission in noisy environments. Designed to avoid catastrophic decoding failure due to bit errors from transmission.

Supports 16-bit grayscale video.


LEAD MPEG-2 Video Codecs

(Download only) MPEG-2 is a high quality video compression and is primarily targeted for applications that require higher bit rates or high bandwidth usage, most commonly DVD videos, Super VCD (SVCD), box top DVR's and digital television.

The LEAD MPEG-2 decoder supports several levels and profiles. Levels (source formats) supported range from Limited Definition (VCR quality) to full HDTV - each with a range of bit rates. In addition to this flexibility in source formats, the LEAD MPEG-2 codec supports several different profiles. Each profile offers a different set of compression tools that together make up the coding system.

Key features of the LEAD MPEG-2 Video Codec:

  • MPEG-1 and MPEG-2 output stream.

  • Low, main & high Profiles implementation.

  • Inter-prediction accuracy of 1/2 pixel.

  • Preprocessing frame-rate adjustment.

  • Fixed and variable bit rate compression options, with a wide range of quality factors.

  • Preset compression options for VCD, SVCD and DVD.

LEAD's MPEG-2 video codec is a multimedia compressor / decompressor that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit industry standard (ISO/IEC 13818-2) MPEG-2 streams.

LEAD offers the following versions of the MPEG-2 Video Codec:

  • LEAD MPEG-2 Video Decoder $19.95

  • LEAD MPEG-2 Standard Video Encoder $39.95

  • LEAD MPEG-2 Professional Video Encoder $400

In addition to the capabilities supported in the LEAD MPEG-2 Standard Video Encoder, the LEAD MPEG-2 Professional Video Encoder also provides the following:

  • Results that are up to 30% smaller than the standard version

  • More control over the bit rate

  • A 2 pass encode option

  • A configuration script which allows for different portions of the video to be compressed with different q factors.


LEAD Video Codec (MCMW) $29

(Download only) LEAD's new MCMW Video Codec is a wavelet based multimedia compressor/decompressor that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play1, create1 and edit1 LEAD's proprietary MCMW files. Developed by LEAD as an alternative to standard compression algorithms, MCMW delivers smaller file sizes and can maintain better image quality than any standard compression with better image quality.

The MCMW Codec has been designed to meet the needs of high-quality video compression using low bandwidth (dial-up) delivery. This is achieved by using a state of the art intra-frame wavelet based compression technique that provides superior compression performance, while still ensuring optimal quality at any given compression. This makes the MCMW Codec an ideal candidate for video editing, video conferencing, remote monitoring and video storage.

Key features of LEAD CMW Video Codec:

Create significantly smaller AVI files.

Create, edit and playback video using existing applications.

Create smaller files but with better image quality.

Use a wide range of compression ratios.

Exert precise rate control.

This product includes parts of the following features:

Image Compression

Files and File Formats


LEAD Video Codec (MJPEG / MCMP) $9.95

(Download only) The LEAD MCMP/MJPEG Video Codec is a multimedia compressor/decompressor, which self-installs into Windows™ and integrates with any DirectShow/Video for Windows™ application such as the Windows™ Media Player, Microsoft's ActiveMovie or Adobe Premier. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create and edit industry standard MJPEG and LEAD's proprietary MCMP files.

Using the industry standard MJPEG compression, you can compress AVI files up to 100 times smaller than their original size. But LEAD takes you even further with MCMP compression (MCMP was developed by LEAD as an alternative to standard compression algorithms), which delivers smaller file sizes and can maintain better image quality than MJPEG with the same or better image quality.

You've probably faced problems viewing some AVI files - there's a good chance you have run into MJPEG files that normal software couldn't read. There are only a few Codecs (mostly hardware) that support MJPEG. Once LEAD's MCMP/MJPEG Video Codec is installed, you will not only be able to load the files, but you will also be able to create, edit, and save your own as files which can be read by other codecs (including hardware codecs).

The LEAD MCMP/MJPEG Video Codec can keep critical image data, like medical multiframe images, exactly as acquired, and prevent cumulative error from repeated re-saving of video edits. It supports both 24 bit and 8 bit grayscale formats, as well as a variety of color spaces-- translating to fewer frustrating file incompatibilities.

The LEAD MCMP/MJPEG Video Codec offers real-time compression (incoming video is compressed as it is acquired) so no intermediate save/compress step is necessary. This benefit comes without having to sacrifice either resolution size or quality. LEAD's software only Video Codec allows for TV quality, full resolution video, 640x480 at 30 frames per second, to be compressed and decompressed with good quality.

LEAD Video Codecs are bundled with the free LEAD Multimedia Converter, so there is no need to purchase additional software or to go through trouble of learning a new software package.

This product includes part of the following features:

Image Compression

Files and File Formats


LEADTOOLS Medical Multimedia Filter Pack*

All you need to compress and decompress DICOM Videos

The Medical Multimedia Filter Pack is a suite of state-of-the-art DirectShow filters for compressing and decompressing video and audio data inside DICOM files. This feature-rich product was designed to eliminate the complexity from converting cine images and video streams to DICOM objects including X-ray Angiography (XA), Ultrasound (US), Visible Light (VL), Secondary Capture (SC) and much more. This Filter Pack utilizes the most advanced compression algorithms used in the industry and approved by the DICOM standard including MPEG-2, Motion JPEG, and JPEG2000.

The Medical Multimedia Filter Pack includes two components: the Writer and the Reader.

Writer (encode video sequences in DICOM) $495

The writer component includes the DirectShow filters that are used for creating DICOM objects with compressed video and audio data.

Key Features:

Ability to create DICOM files with both video and audio using MPEG-2 compression. The user can adjust the different attributes of the MPEG-2 stream including bit rate and quality factor.

Ability to create DICOM files with video data (cine images) using lossy and lossless JPEG and JPEG2000 compression with the option to adjust quality factor.

Add video data to either an existing DICOM file or create a new one from a set of predefined DICOM classes or IODs.

Accepts 8-bit RGB, 24-bit RGB, 16-bit UYVY or 16-bit YUY2 data.

Includes a number of video processing filters including:

  • Auto Contrast

  • Auto Intensity

  • Auto Level

  • Video Text Overlay

  • Video Crop

Can be used with an existing application that uses DirectShow, or programmatically from the LEADTOOLS Medical Imaging toolkit.

Examples of DICOM objects that can be created using the Writer component:

Secondary Capture Multi-Frame True Color Image Storage.

Video Endoscopic Image Storage.

Video Photographic Image Storage.

Video Microscopic Image Storage.

Ultrasound Multi-frame Image Storage.

X-Ray Radiofluoroscopic Image.

X-Ray Angiographic Image Storage.

Secondary Capture Multi-frame Grayscale Byte Image Storage.

Secondary Capture Multi-frame Grayscale Word Image Storage.

MPEG-2 Encoding in DICOM:

MPEG-2 is a high quality video compression and is primarily targeted for applications that require higher bitrates or high bandwidth usage. The DICOM standard uses MPEG-2 lossy compression with middle range quality, which typically delivers between 30 Mbytes and 60 Mbytes per minute of video.

The DICOM MPEG-2 objects created using the writer fully adhere to the rules of MPEG-2 encoding in DICOM which are described by the new transfer syntax “MPEG-2 Main Profile @ Main Level” (1.2.840.10008.1.2.4.100).

Some of the typical modalities that can take advantage of MPEG-2 encoding in DICOM include Endoscopy, Cardiology and Micro-surgery.

DirectShow filters included as part of the Writer component:

LEAD DICOM Write Filter.

LEAD MPEG-2 Standard Video Encoder.

LEAD MPEG-2 Multiplexer.

LEAD MCMP-MJPEG Video Codec.

LEAD Auto Contrast Filter.

LEAD Auto Intensity Filter.

LEAD Auto Level Filter.

LEAD RGB Converter.

LEAD Video Text Overlay Filter.

LEAD Video Crop Filter.

Reader (play DICOM videos in any media player) $49

The reader component includes a set of DirectShow filters that register into the Windows collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize these filters to play video (cine) data in a DICOM file.

Key Features:

Can be used with an existing application that supports DirectShow, or programmatically from the LEADTOOLS Medical Imaging toolkit.

Ability to play or Cine any DICOM file with any type of compression including MPEG-2, lossy and lossless JPEG and JPEG2000.

Fast and optimized video decompression.

Playback options include control of the stream speed by changing the frame playback rate. In addition to the basic stream and speed control functionality, LEADTOOLS developers can "preview" a LEAD DICOM dataset in memory before saving to disk.

DICOM Cine Playback - DICOM Cine Loop:

A cine loop is the continuous display of a set of images or frames that convey the effect of motion and is considered a very useful diagnostic tool. With the help of the reader the user can treat DICOM cine as a regular video file:

  • Play: start or resume DICOM cine play.

  • Pause: pause DICOM cine play.

  • Stop: stop play mode and go to the beginning of the video clip.

  • Previous Frame: display the previous frame in the cine loop.

  • Next Frame: display the next frame in the cine loop.

DirectShow filters included as part of the reader:

LEAD DICOM Read Filter

LEAD MPEG-2 Video Decoder

LEAD MPEG Audio Converter

This product may be added to the following:

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

*Using the LEADTOOLS Medical Multimedia Filter Pack requires a LEADTOOLS Medical Imaging Toolkit License.


Additional Document Imaging Features

The LEADTOOLS Document Imaging and LEADTOOLS Document Imaging Suite provide support for some Image Display, Scanning / Screen Capture, and Image Processing features that are not supported in the LEADTOOLS Raster Imaging Pro product. This additional support includes:

· 12 and 16 bit grayscale image support.

· 8-16 bit grayscale lossy and lossless JPEG compression,

· TWAIN scanning (16-bit grayscale and up to 48-bit color)

· Fast Twain scanning capabilities

· ISIS scanning

· Bitonal image processing, including deskew and despeckle.

· Scale to Gray 1-bit image display

· Favor black display which preserves black objects when displaying zoomed-out 1-bit images.

· Fast Rotate which rotates a bitmap in 90-degree increments.

· Super compressed 1-bit or 24-bit bitmaps which can be kept compressed in memory.

· (Document Imaging Suite only) OCR capabilities, based on the ScanSoft SDK 12 Pro engine.

· JBIG file format / compression.


Additional Medical Imaging Features

The LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite provide support for some Image Display and Image Processing features that are not supported in the LEADTOOLS Raster Imaging Pro product. This additional support includes:

· 12 and 16 bit grayscale image features, chosen and optimized to meet the specific demands of the medical imaging market.

· 8-16 bit grayscale lossy and lossless JPEG compression,

· TWAIN scanning (16-bit grayscale and up to 48-bit color)

· Importing to/exporting from 10,12 and 16 bit grayscale TIFF files and 48 and 64-bit color TIFF files.

· Importing to/exporting from JFIF (JPEG) and JTIF (TIFF with JPEG) files compressed using 12-bit grayscale lossy or 16-bit lossless compression.

· On-the-fly re-mapping of 10 –16 bit grayscale images to Windows display devices, using an LUT with pseudo color support.

· Painting 10 - 16-bit images using Bilinear or Bi-cubic resizing on-the-fly.

· 12 and 16 bit grayscale image processing and display with LUT and window leveling.

· 16-bit Grayscale histograms

· Auto detection of the minimum and maximum intensity, and low and high bits used in the image data.

· Conversion of 12 to 16- bit grayscale images to 8-bit or 24 bit.

· Creating or loading 12 and 16- bit grayscale and 48 and 64 bit color images from raw data from disk, memory, or file offset.

· Converting signed images to unsigned images.

· Converting unsigned images to signed images.

· 16-bit image data in Intel or Motorola formats.

· Image Overlays.


Annotations

(Document/Medical toolkits only) LEADTOOLS offers a variety of annotation (document markup) options that can be added to document, grayscale and color images. LEADTOOLS allows the end-user to reposition nodes of an existing free-hand object, which prevents the user from redrawing the object. Enhanced redact objects allow you to restore parts of an image that were blacked out. When combined with annotation security, these redact objects provide a means of granting user-level access to parts of an image. Annotation objects can be stored as a separate object layer, or can be burned or embedded into the actual image. LEADTOOLS allows you to read or write annotations as an external file or as a Wang annotation tag within a TIFF file. With LEADTOOLS, you can choose between low-level access to the annotations, or you can implement annotation support through a fully automated mode with a ready to use floating, customizable toolbar and pop-up menus. The superior annotation features provided in LEADTOOLS can be used in any application where image markup is required.

The LEADTOOLS Annotations features support the following actions:

Create any of the following objects: line, arrow, rectangle, ellipse, polygon, freehand line, text, highlighter, hot spot, note, stamp, redaction, button, audio clip, video, freehand hot spots, points, protractors, cross-products, push pins, and rubber stamps.

Create any of the following objects: line, arrow, rectangle, ellipse, polygon, freehand line, text, highlighter, hot spot, note, stamp, redaction, button, audio clip, video, freehand hot spots, points, protractors, cross-products, push pins, rubber stamps, curve, closed curve, encryption, text pointer, polyruler, and RTF edit objects.

Create your own custom annotation objects with custom handles and user-defined behaviour.

Implement automated annotation support.

Customize the cursors for automation activities.

Implement annotation passwords (case-sensitive) providing security for every object.

Implement hyperlinks for every object. Hyperlinks can be user defined messages, programs to run, or jumps to Web pages.

Modify text strings used in automated annotation support.

Scale and position a group to fit the displayed bitmap.

Fix annotation objects, so that the do not move when zooming/scrolling.

Group and ungroup objects.

Apply an object or group to a bitmap.

Size and position an object or group.

Rotate an object or group.

Flip, reverse, or shear an object or group.

Save an object or group on the Windows clipboard.

Print an object or group. (Flicker Free Annotation Display!)

Save an object or group in a file.

Save annotations as an external LEAD file, WMF file, or as a WANG compatible tag inside a TIFF file.

Save an object or group as a file in memory. (This is useful for database support.)

Save an object or group in a database using Visual Basic data binding.

Control where the optional annotation name or title is displayed.

Work with multi-page annotations.

Import text into Text objects.

Include tokens in Text objects.

Align text in Text objects.

Ruler, PolyRuler, Protractor, and Cross Product objects can have optional tick marks.

Ruler, PolyRuler, Protractor, and Cross Product objects can have user defined units, or ‘smart units’.

[DLL only] Save an object or group as a file in memory. (This is useful for database support.)

[ActiveX only] Save an object or group in a database using Visual Basic data binding.

The LEADTOOLS Annotation features are available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging Suite

Support for the Annotation features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

VCL


Barcodes

The LEADTOOLS Barcodes features provide support for adding barcode recognition technology to any LEADTOOLS Document/Medical toolkit. This includes the ability to:

Read and write Linear (1D), CodeOne (2D), and PDF417 (2D) barcodes with support for over 16 different subtypes.

Read barcodes at any orientation using a scanner or camera with frame-grabber

Write barcodes to any supported raster image file or to any windows compliant printer

Encode thousands of characters per barcode symbol with 2D barcode technology.

When integrated with the extensive image processing technology of one of the LEADTOOLS Document/Medical toolkits, the LEADTOOLS Barcodes features make it possible to exert complete control over the barcode recognition process.

The LEADTOOLS Barcode features are available in the following products:

LEADTOOLS Barcode Modules

Support for the Barcode features is provided for the following programming interfaces:

ActiveX

API

Class Library


Color Conversion

Standard Support

LEADTOOLS includes functions with many options for the flexibility necessary to make images look as good as possible, whether they are medical images, scanned documents or digital photographs. To help you provide the correct color depth for the hardware your clients are using, LEADTOOLS can convert images from any color resolution to any other color resolution, from 1-bit to 32-bit, with multiple dithering methods using various palette options.

Programmers can choose from 8 different dithering methods including Floyd Stein, Burkes, Ordered dithering, Color reduction, Stucki, Stephens, Sierra and Jarvis. Flexible palette options include LEAD's fixed palette, an auto-optimized palette, or a user defined palette. Images can be separated and/or reconstructed to/from individual RGB, CMYK, CMY, HSV, YUV and HSL color planes. When working with 12 and 16 bit grayscale images, LEADTOOLS' window leveling allows you to select the desired range of bits to be used for display or processing. (available in the LEADTOOLS Medical Imaging) All of these options give you the flexibility to make your images look just right for your application, whether you are working with medical images, scanned documents or digital photographs.

Images that are less than 16 bits per pixel require a palette (an array of color values). If an image file is less than 16 bits per pixel, the file contains a palette and when you load the image into a bitmap, the palette is also loaded into the bitmap handle. The value of each pixel in one of these images is an index into the palette. The number of colors in a palette is limited to the highest possible index value. For example, if an image is 8 bits per pixel, it can have a palette of 256 colors, which is the number of different colors that can be referenced by using the pixel values as 8-bit indexes.

Images that are 16 bits per pixel or higher store the color values directly in the image as pixel values. If you reduce a bitmap to less than 16 bits per pixel, a palette must be specified or created. You can do any of the following:

Let LEADTOOLS create a palette that is optimized for the particular image. (As an option, this palette can include the system identity palette.)

Specify a fixed palette, which is the same for all images that use it. The palette can be LEAD's fixed palette or the Netscape fixed palette.

Specify a palette of any size that you have created. In creating your own palette, you can let LEADTOOLS do part of the work. For example, you can fill in part of the palette, and let LEADTOOLS fill the rest with optimized colors.

Modify the colors in the bitmap palette.

Copy a palette from a device context.

[DLL only] Use a table to increase the efficiency of the palette that you define.

[Medical only] Use window leveling to map grayscale intensities by specifying the bit range and/or a user defined color map.

The LEADTOOLS Standard Color Conversion features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Raster Imaging Pro for .NET

Support for the Standard Color Conversion features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Advanced Support

The LEADTOOLS Advanced Color Conversion features provide support for additional color spaces and the ability to use ICC color conversion profiles, Emulation Tables and LEAD's Built-in Conversion. Support is provided for conversions among RGB, BGR, YUV, CMYK, HSV, HLS, YIQ, CMY, LAB, YCCK, Y41P, UYVY, YUY2, YVU9, and YCC color spaces. Conversions can be performed either directly or indirectly.

The LEADTOOLS Advanced Color Conversion features provide emulation tables as one of the conversion methods when performing any of the following conversions:

CMYK to RGB

CIELab to RGB

RGB to CIELab

The LEADTOOLS Advanced Color Conversion features are available in the following products:

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Advanced Color Conversion features is provided for the following programming interfaces:

API


Image Compression

LEADTOOLS toolkits offer more compression options than any other toolkits on the market.

Standard Compression

LEADTOOLS supports industry standard compression algorithms such as JPEG, CCITT G3/G4, Huffman, Arithmetic, RLE, LZW and ZIPLIB, as well as LEAD’s own proprietary CMP compression. With the compression options available in LEADTOOLS your application will execute faster, images will use less storage space, and your transfer costs will be reduced. With LEAD's CMP compression, you will get even smaller file sizes while maintaining better image quality than the industry standard compression formats allow.

In the LEADTOOLS Document/Medical versions, you will find the fastest software-only JPEG algorithms available.

The LEADTOOLS Standard Compression features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Standard Compression features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Advanced Compression

LEAD Technologies, Inc. offers several products to support advanced compression features. In some cases support is built into one or more toolkits, with plug-in support available as an add-on.

LEADTOOLS CMW is a new LEAD Technologies, Inc. proprietary technology for compression/decompression that outperforms all other known image compression algorithms in quality and compression ratio. It is better than JPEG2000 in quality, speed and compression ratios. The LEADTOOLS CMW includes support for multiple resolutions. This makes your applications faster and more memory efficient because the entire file does not have to be loaded and decompressed just to load a low resolution image.

CMW is better than JPEG2000 for the following reasons:

CMW files are smaller than JPEG2000 files of comparable quality

CMW files can be loaded and saved faster than comparable JPEG2000 files.

Since there are fewer parameters to set, CMW files are easier to use.

Additionally, you have complete control of the resulting file size and quality. You can choose to compress a file based on any of the following:

Target file size

Compression ratio

Quality Factor

You can even specify to use lossless compression so that when the compressed image is decompressed it will be exactly the same as the original image.

The LEADTOOLS CMW File Format support is available in the following products:

LEADTOOLS CMW Plug-in

This module supports the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

LEADTOOLS JPEG 2000 support conforms to the JPEG 2000 International Standard. JPEG2000 provides high compression with image quality superior to all existing standard encoding techniques. This high compression and quality performance is due to the adaptation of wavelet transforms. Wavelet transforms are mathematical formulas that represent complex structures in the image, thereby compressing an extremely large amount of image data into a relatively small amount of compressed data. This compression technique allows applications to save compressed images with higher compression ratios and better image quality as compared to any other software currently in production.

The JPEG2000 format stores data in a hierarchical format containing several resolutions of the image in the same file without duplication of data. For that reason, a JPEG2000 compressed image can be sent to a device in the best resolution for that device, without requiring additional storage overhead. The LEADTOOLS JPEG 2000 plug-in currently supports Lossless compression, meaning the decompressed image data is exactly as it was before compression.

The LEADTOOLS JPEG 2000 Plug-in support is available in the following products:

LEADTOOLS JPEG 2000 Plug-in

This module supports the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Please note that LEAD also offers the LEADTOOLS JPEG 2000 COM Object for IE Module, which lets you view JPEG 2000 images in ActiveX enabled web browsers, such as Internet Explorer. For more information, refer to LEADTOOLS JPEG 2000 COM Object for IE.

The LEADTOOLS MRC (Mixed Raster Content) Module enhances LEADTOOLS file input/output functionality by adding support for raster color documents containing mixed image and text components. The MRC module breaks an image into three different layers: foreground, background, and mask. Each layer is compressed separately using the best type of compression for that data type and is later uncompressed and recombined to restore the original image.

Because standard compression schemes are geared towards an image being entirely text or color, the MRC model offers the advantage of using optimal compression for images that have both text and color in the same image. This results in both high compression factors and high detail retention.

The foreground layer contains color data for the text and line art, and may also contain photographic or continuous tone color data. The background layer generally contains low-resolution color image data, such as a background image, a wash or other pattern that would have text overlaid on it. The mask layer or the selector layer controls the process of image regeneration contains binary image data that is high spatial resolution, such as text and line art. This layer is used for drawing the corresponding foreground and background layers.

Segmentation can be performed automatically with the option to optimize it manually or it can be done only manually. Compression can be specified for each area type. The compression for 1-bit black and white areas can be CCITT G3 1D, CCITT G4 2D, CCITT G4 or JBIG. The compression for color areas is JPEG.

The LEADTOOLS MRC Module support is available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

This module supports the following programming interfaces:

API

Class Library

COM

The LEADTOOLS PDF Plug-in supports the PDF file format. PDF was developed by the Adobe Corporation to allow the exchange and viewing of electronic documents easily and reliably, independent of the environment in which they were created. This format lets you compress large documents to a size small enough to download very quickly. It is also becoming a powerful format for reproducing documents over the web. The LEADTOOLS PDF plug-in gives you a wide range of control options for the resulting image data in terms of compression, including:

1. No compression

2. Compressed using CCITT Group 3, 1 dimension.

3. Compressed using CCITT Group 3, 2 dimensions.

4. Compressed using CCITT Group 4.

5. JPEG compression and YUV 4:4:4 color space loss-less.

6. JPEG compression and YUV 4:2:2 color space.

7. JPEG compression and YUV 4:1:1 color space.

The LEADTOOLS PDF Plug-in support is available in the following products:

LEADTOOLS PDF Plug-in

This module supports the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


Database Imaging

LEADTOOLS has specific features designed for the imaging database developer. You can use the database features to store images in any of the file formats supported by LEADTOOLS. LEADTOOLS' database support includes a wide variety of callback routines and features multi-page support. These features, when combined with the excellent compression options available in LEADTOOLS, provide a solid base for building robust database applications such as those used in fields like Real Estate, Law Enforcement and Internet on-line shopping.

You can maintain images in a database using any valid file format to store an image in a long binary field. You can do so in the following ways:

[ActiveX32 and COM only] Use Open Database Connectivity (ODBC).

[ActiveX32 and COM only] Use OLE DB.

[ActiveX and COM with Visual Basic and VCL only] Use data binding.

Use functions to read files from memory and write files to memory.

Use LEAD OLE server to embed or link images in any database that supports an OLE field.

LEADTOOLS Database Imaging features are grouped into four areas as follows:

Low Level

Data Binding

OLEDB/ODBC

OLE Server

Each area is described in further detail in the following sections.

Low-Level

Loading and saving in memory, available in all platforms, is one of the low-level methods available for working with databases. In addition, the API, Class Library, COM, and NET platforms have functions to allow loading and saving based on offsets. The API and Class Library platforms have functionality for Input/Output redirection as well. The LEADTOOLS Low-Level Database features are available in the following products:

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

In addition, the Loading and Saving in Memory capabilities are available in the following product:

LEADTOOLS Raster Imaging

Support for the Low-Level Database features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

VCL

Data binding:

The simplest database support is with Visual Basic, where you can bind a LEAD ActiveX control to a data control. You can associate the LEAD control with a long binary field in the database, and let the data control handle all of the database maintenance and navigation. VB data binding allows you to use the Visual Basic JET engine to store and retrieve images to/from any database supported by JET. Delphi/Builder data binding is available for VCL users. LEADTOOLS Data binding features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Data binding features is provided for the following programming interfaces:

ActiveX (VB)

(Delphi/Builder)

OLEDB/ODBC

LEADTOOLS provides support for OLEDB/ODBC to ActiveX and COM users. Open Database Connectivity (ODBC) is a standard interface for accessing local and remote databases. ODBC provides access primarily to SQL data. LEADTOOLS includes support for 32-bit Open Database Connectivity (ODBC), allowing you to work with any ODBC database. To use ODBC, you define a data source that is implemented with an ODBC driver; then you access the data source in the same way you would a local database. LEADTOOLS provides ActiveX methods and properties and COM objects that let you directly access image data through an ODBC data source.

Also, for systems with ActiveX or COM support, you can use OLE DB and ADO to access all types of data in an OLE Component Object Model (COM) environment. You can bind the LEADTOOLS OLE DB Control to an OLE DB data source, such as the Microsoft ADO Data Control. You can associate the LEADTOOLS OLE DB Control with a long binary field in the database, and let the data control handle all of the database maintenance and navigation.

LEADTOOLS OLEDB/ODBC features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the OLEDB/ODBC features is provided for the following programming interfaces:

ActiveX

COM

OLE Server

LEADTOOLS provides a customized OLE 2.0 in-place server, which can store and retrieve images into/from any OLE client. OLE Server functionality is available in all platforms in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite


DICOM Annotation Features

The LEADTOOLS DICOM Annotation features provide support for saving LEADTOOLS annotations directly to and from a DICOM Data Set, as private data. This support lets you save multiple annotations to the same file, with password protection, and edit the annotations later. You can also convert to/from DICOM and LEAD Annotation objects.

The DICOM Annotation features are available in the following products:

LEADTOOLS Medical Imaging Suite

Support for the DICOM Annotation features is provided for the following programming interfaces:

COM

API

Class Library


DICOM Basic Features

DICOM 3 (2003 file specification), the industry standard medical imaging format/protocol is fully and completely supported, allowing programmers access to medical images retrieved from digital imaging modalities such as CT and MR scanners.

LEAD's DICOM imaging support is the richest in the industry supporting 8,10, 12,16 and 24 bit images including JPEG (8, 10 , 12, 16-bit Lossless grayscale, 8, 12-bit lossy grayscale, 24-bit lossless and lossy color), Run Length, Uncompressed, Photometric Interpretation (Monochrome1, Monochrome2, Palletized, RGB, ARGB, CMYK, YBR Full 422, YBR Full), and single and multi-page images. LEAD’s Medical Imaging toolkit includes 8-16 bit grayscale display with window leveling. Window leveling is a linear conversion from stored pixel values to values to be displayed; LEADTOOLS can map the stored pixel values of interest using a user defined color map (using a LUT or Palette) or linear gray LUT.

  • Support for 8, 10, 12, 16 grayscale and 24 bit images including JPEG (8, 10, 12, 16-bit Lossless grayscale, 8, 12 bit lossy grayscale, 24-bit lossless and lossy color), JPEG2000 (including lossy and lossless 8-16 bit grayscale images and 24-bit color) Run Length, Uncompressed, Photometric Interpretation (Monochrome1, Monochrome2, Palletized, RGB, ARGB, CMYK, YBR Full 422, YBR Full, YBR_RCT, YBR_ICT), and single and multi-frame images.

  • COMPLETE support for the DICOM 3 (2003 file specification), including all standard IOD classes and modalities (CR, CT, MR, NM, US, RF, SC, VL, etc.) and VR's (value representations)

  • Provides easy implementation and full support for DICOM Basic Directory. High-level COM object to create DICOMDIR in few lines of code.

  • Change one transfer syntax to another transfer syntax with one function call.

  • Automatic recognition of DICOM files (Little-Endian/Big-Endian, Implicit/Explicit VR, etc.) High level and low level functions for easy navigation and manipulation (insert, delete, modify) of Data Sets

  • Single or multi-frame images (compressed or uncompressed)

  • Largest set of hardware manufacturers supported.

  • Contains ready to use source code and executables.

  • 4 different Programming interfaces to DICOM - API, ActiveX, VCL, Class Library

  • Supports all VR's (Value Representation) in DICOM 2003 standard including "Other Float String".

  • High-level and low-level functions for easy navigation and manipulation (insert, delete, modify) of Data Sets.

  • LEADTOOLS’ automatically adds the Item Delimitation Item (FFFE, E00D), and Sequence Delimitation Item (FFFE, E0DD) to simplify Nesting of Data Sets (VR of "SQ").

  • Easy to manipulate ordinal positioning of Items (FFFE,E000).

  • Simplified handling of repeating groups (multiple overlays and curve data)

  • Supports Encapsulated or Native encoding of Pixel Data for Single or multi-frame compressed or uncompressed images.

  • DICOM LUT/Overlay/Palette support. The high-level support for Modality LUT, VOI LUT, Palette Color Image in LEADTOOLS Medical Imaging means developers can implement DICOM Presentation state into an application with ease. LEADTOOLS can also aapply the Modality LUT to the image data to further simplify image processing and statistical calculations.

  • DICOM Annotation Object support. Store/retrieve DICOM annotations from a dataset and convert them to LEAD Annotation objects and vice versa. Annotations can also be converted to regions of interest for additional statistical calculations and for storing to DICOM Presentation State.

The DICOM Basic features are available in the following products:

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the DICOM Basic features is provided for the following programming interfaces:

API

Class Library

COM

Please note that while full DICOM Basic support is not available for NET, images stored in the DICOM format can be loaded with NET, as long as the Medical Imaging support is unlocked.


DICOM Communication Features

The LEADTOOLS DICOM Communication features provide support for the following:

· TCP/IP support for the communication of medical data using the DICOM 3.0 protocol.

· Powerful high-level features that simplify the creation of DICOM client/server applications.

· High-level functions for initiating and terminating Associations (connections between DICOM applications).

· Automatic processing for filling out PDU structures (Protocol Data Units).

· Automatic and transparent conversion of DICOM Data Sets to/from the specific Transfer Syntax required by the associated Application Entities (the connected DICOM client(s) and server(s)).

· Full Support for all Service Classes - Easy to implement all possible DICOM Service Classes as client (SCU) and/or server (SCP):

o DICOM Verification Service Class

o DICOM Storage Service Class

o DICOM Query/Retrieve Service Class

o DICOM Study Content Notification Service Class

o DICOM Patient Management Service Class

o DICOM Study Management Service Class

o DICOM Results Management Service Class

o DICOM Print Management Service Class

o DICOM Media Storage Service Class

o DICOM Storage Commitment Service Class

o DICOM Basic Worklist Management Service Class

o DICOM Queue Management Service Class

· Direct support for PACS

The Dicom Communication features also provide support for the following Command Sets, and their respective Command Elements.

· C-STORE-REQUEST

· C-STORE-RESPONSE

· C-FIND-REQUEST

· C-FIND-RESPONSE

· C-GET-REQUEST

· C-GET-RESPONSE

· C-MOVE-REQUEST

· C-MOVE-RESPONSE

· C-CANCEL-REQUEST

· C-ECHO-REQUEST

· C-ECHO-RESPONSE

· N-EVENT-REPORT-REQUEST

· N-EVENT-REPORT-RESPONSE

· N-GET-REQUEST

· N-GET-RESPONSE

· N-SET-REQUEST

· N-SET-RESPONSE

· N-ACTION-REQUEST

· N-ACTION-RESPONSE

· N-CREATE-REQUEST

· N-CREATE-RESPONSE

· N-DELETE-REQUEST

· N-DELETE-RESPONSE

The DICOM Communication features are available in the following products:

LEADTOOLS Medical Imaging Suite

Support for the DICOM Communication features is provided for the following programming interfaces:

COM

API

Class Library


DICOM Multimedia Features

The LEADTOOLS DICOM Multimedia features support the DICOM DirectShow Read and Write filters.

The DICOM File Reader Filter provides the ability to stream the video data in any DICOM file. In addition, it makes it possible for any DirectShow based media player to play video data in a DICOM file. The filter offers the ability to control the stream speed by changing the frame time. In addition to the basic stream and speed control functionality, the user can insert a user-defined external DICOM dataset and get access to the initialized dataset for use with other processes.

The DICOM File Writer Filter provides the ability to set the pixel data of a DICOM file, existing or new, offering many options for storing DICOM files using the LEAD DICOM toolkit. The user can access the DICOM dataset in the file, and save any changes made on the dataset with another utility.

The DICOM Multimedia features are available in the following products:

LEADTOOLS Medical Imaging Suite

Support for the DICOM Multimedia features is provided for the following programming interfaces:

API

COM


DICOM Security Features

LEADTOOLS Dicom Security features support the Secure Transport Connection Profiles as specified in part 15 of the DICOM 3 standard. This support includes the Basic TLS Secure Transport Connection Profile and ISCL Secure Transport Connection Profile to help integrators create DICOM applications with communication to be HIPPA compliant.

The LEADTOOLS DICOM Security features include:

· Computer or Entity Authentication

· Confidentiality

· Data Integrity.

· TLS using the Secure Hash Algorithm message authentication

· Authentication based on RSA certificates

· DES and triple DES (3DES) encryption mode

· "Three-pass-four-way" mutual authentication protocol support

· Ciphersuite negotiation.

· DES-CBC encryption (ISCL standard DES encryption in cipher block chaining mode)

· No encryption (ISCL standard)

· DESMAC (64 bit) and MD5 (128 bit) message authentication codes (ISCL)

· Support for the INTERNAL AUTHENTICATE command

· Support for the EXTERNAL AUTHENTICATE command

· Support for the GETCHALLENGE command

· The ability to send secured or unsecured messages, regardless of the encryption mode

The DICOM Security features are available in the following products:

LEADTOOLS Medical Imaging Suite

Support for the DICOM Security features is provided for the following programming interfaces:

ActiveX

API

Class Library


DigitalPaint

The LEADTOOLS DigitalPaint features let you incorporate Paint capabilities into your Windows applications by providing the functions necessary to write a painting program or any painting related application. The painting output can be painted to the control, a bitmap, or both. In addition, LEADTOOLS DigitalPaint provides the option of color restriction, using an optional restriction palette.

The painting tools are divided into five groups, as follows:

Paintbrush group.

Shape group.

Region group.

Fill group.

Text group.

Each group is described in further detail in the following sections.

Paintbrush group

The LEADTOOLS DigitalPaint paintbrush group has most of the features found in any artistic painting program. The created paintbrush is translated and scaled automatically for the control and/or the bitmap, using user-defined transformation settings.

Shape group

The LEADTOOLS DigitalPaint shape group eliminates some of the Windows API programming normally required when drawing shapes. In addition, shapes may be painted with varying degrees of opacity, or with a paper texture, or with a gradient background, etc. The resulting shapes are translated and scaled automatically for the control (device context) and/or the bitmap, using user-defined transformation settings.

This group can draw the following shapes:

Line

Rectangle

Rounded rectangle

Ellipse

Polygon

Polybezier.

Region group

The LEADTOOLS DigitalPaint region group can create regions ranging from simple to very complex (many of which are not supported by Windows). Functionality also includes region scaling, which is not supported directly by Windows. Resulting regions are translated and scaled automatically for the control (device context) and/or the bitmap, using user-defined transformation settings.

Regions can be created by using shapes (Rectangles, Rounded rectangles, Ellipses or Polygons) or by using fills (Surface, Border, or Color Replacement).

Fill group

The LEADTOOLS DigitalPaint fill group gives the user complete area filling solutions with regards to both the method of filling and the features of filling. The resulting filled area is translated and scaled automatically for the control (device context) and/or the bitmap, using user-defined transformation settings.

There are three Fill group filling methods: Surface, Border and Color replace. The Surface fill method fills an area that contains a specified color starting at a specified point and continuing in all directions. A tolerance range can also be set to accept colors very close in value to the specified color. The Border fill method fills an area starting at a specified point and continuing in all directions until finding a specified color. A tolerance range can also be set to stop filling when colors very close in value to the specified color are found. The Color replace fill method replaces every pixel using the current fill settings.

Text group

The LEADTOOLS DigitalPaint text group includes comprehensive text drawing features. Drawn text is translated and scaled automatically for the device context (DC) and/or the bitmap, using user-defined transformation settings.

The LEADTOOLS DigitalPaint features are available in the following product:

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the DigitalPaint features is provided for the following programming interfaces:

ActiveX

API

Class Library


Image Display

LEADTOOLS currently supports over 120 different image formats and sub formats, each of which has its own unique set of load/save/display options, which may encompass varying types and/or degrees of compression, a range of image information bit-depths, progressive (multi-pass) image display, the ability to maintain multi-page or multi-channel images, animations, or non-image data, just to name a few. You can depend on LEAD Technologies to provide you the support you need to give your application control over the display of almost any image you encounter. Image display can be subdivided into two groups: raster image display and vector image display. These groups are described in more detail in the following sections.

Raster Image Display

LEADTOOLS provides numerous functions to let you take control of your application's image display. With LEADTOOLS, you control brightness and contrast settings, color reduction with dithering and palette control, zooming/scaling/fitting, panning, scrolling, painting with transparency and/or regions. Additionally, LEADTOOLS provides image-list and thumbnail browser controls, a special magnifying-glass feature, as well as an automated pan-window control.

LEADTOOLS renders an image of any color depth (1 to 64 bit**) to any display device, automatically handling any color reduction or expansion. Use nearest neighbor (fastest), bilinear (fast-good quality) or bicubic (best quality) resampling for zoomed display of images. Images can be automatically dithered to match the output display device on the fly, without changing the image in memory. Intensity, contrast and gamma correction changes can be applied to the display without affecting the original data. (AdditionalIy, the color reduction and display settings can be rendered into the image if desired, see Image Processing. Images can be scaled, zoomed, or scrolled when displayed. You can render images with a color specified as transparent.

You can position the displayed image, and zoom in or out by scaling and clipping the display. The rotated display* feature allows rendering images rotated in 90-degree increments without changing the image in memory. Large 1-bit images can remain compressed in memory while decompressing only the portion needed for display*. On a 256-color device, you can use a fixed palette option to eliminate palette shifting when displaying more than one image at a time. An automated pan window is provided to enable navigation on a large image using a small thumbnail view. LEADTOOLS also lets you display and manipulate a list of images as an array of thumbnails using the ImageList Control In addition, LEADTOOLS provides a Thumbnail Browser for browsing entire directories of image files.

When working with the ActiveX, COM, .NET or VCL controls, you can set properties which determine the way that images are displayed in the control, such as AutoScroll (automated scroll bars), AutoSize (snap control to image), PaintSizeMode (1:1 scale, fit image to control, zoomed at specified magnification factors etc.)

When painting images on any video device, you can do the following:

Control the brightness, contrast, and gamma correction when painting (without affecting the bitmap).

Define the client area of a LEAD control as a display surface where you can use Windows graphics device interface (GDI) functions for drawing or adding text. (You can also get a display surface derived from the actual image stored in memory in order to use Windows GDI to draw permanently into the image - see Image Processing.

Display an automated rubberband (rectangle, elipse or freehand) to mark an area and create a region of interest.

Paint an image only in a selected region of interest, or paint an image with transparency (any pixels which are the selected transparent color are not painted).

Zoom in on a selected area. Use with automated rubberbanding for entirely automated behavior, or specify selected area in code.

Selectively force repainting of the image in a LEAD control to avoid unecessary repaints, or use AutoRepainting to automate all display updates.

Scale and position the image - specify source rectangle (portion of source image to paint) and destination rectangle (position on screen or drawing surface on which to paint it) for complete control over image zoom and position, or specify higher level properties like ZoomFactor or PaintMode (fit-to-window preserving aspect ratio, stretch to entire window, fit-to-width, 1:1 normal display, etc.). When used with the AutoScroll option, all Scroll Bar activity is automatic (scroll bars respond to programmatic changes of display settings, and display settings are updated by user's use of scroll bars).

Limit the area to be painted by specifying the source and destination clipping areas (independent of source and destination rectangles which position image on screen).

Apply any of over 2000 Special Effects, such as wipes, fades, dissolves, transitions commonly used in slide presentations.

Apply ROP codes, which determine how to interact with the existing image on the screen.

Use Double Buffer painting to eliminate flicker when painting.

[DLL only] Use a buffer as the source to paint. (Can be used, for example, to paint an image as it is being loaded)

[DLL only] Specify an option for fast painting (without device error checking).

If the display mode is 256 colors or less, you can use the palette associated with the image (if palletized), or use a fixed palette. You can specify LEAD's fixed palette or the Netscape fixed palette. Fixed palettes allow you to display multiple images on a screen in 256 color mode without "color shifting".

Specify the dithering method for images that have more bits per pixel than the current video mode. The following are possible options:

Normal dithering (using error diffusion).

Ordered dithering, which is faster but less accurate than normal.

[DLL only] No dithering, which relies on the display device for color reduction.

[Document/Medical only] For displaying 1-bit (black-and-white) images, you can do the following to enhance the quality of display:

Specify a scale-to-gray option, which increases the clarity of the 1-bit images when they are scaled (zoomed in or zoomed out).

Specify a favor-black option which prevents loss of details, such as fine lines, when an image is scaled down (zoomed out).

The LEADTOOLS Raster Image Display features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Raster Imaging Pro for .NET

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Raster Image Display features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Please note that LEAD also offers the LEADTOOLS JPEG 2000 COM Object for IE Module, which lets you view JPEG 2000 images in ActiveX enabled web browsers, such as Internet Explorer. For more information, refer to LEADTOOLS JPEG 2000 COM Object for IE.

Vector Image Display

The LEADTOOLS Vector Image Display features provide support for 2D and 3D Vector formats including DXF (2D and 3D), CGM, DGN, DRW, DWF, DWG, EMF, WMF, PLT, Gerber, PCL, PCT, SVG, VWPG, CMX and SHP. Support for primitive objects include Arc, Bitmap, Brush, Camera, Circle, Clone, Ellipse, Elliptical Arc, Font, Group, Layer, Line, Pen, Pie, Chord, Poly Draw, Polygon, Poly Line, Poly Bezier, Raster, Rectangle, Text, Vertex and Clipping objects. Vector images can also be rotated, scaled and translated as a whole (not individual objects) for display purposes. In addition there are low and high-level functions to control the view of vector drawings include zooming (both uniform or around any axis), panning, rotation (around any axis) and anti-aliasing. Vector drawings can be scaled to any resolution desired without distorting the original image, ensuring that fine details of the drawing will not be lost during printing.

The LEADTOOLS Vector Image Display features are available in the following products:

LEADTOOLS Vector Imaging Pro

Support for the Vector Image Display features is provided for the following programming interfaces:

ActiveX

API

Class Library


Document Imaging SDKs

LEADTOOLS Document Products Overview

LEADTOOLS Document Imaging toolkits include comprehensive annotations, specialized bitonal image display and processing, image clean-up, high-speed scanning, OCR/ICR/OMR (character, hand-print and form processing), barcode recognition and much more.

With buzzwords and phrases like "paperless office", "document archiving" and "electronic file cabinet", your clients are asking for more sophisticated and specific document imaging functionality to be included in your applications. LEADTOOLS' Document Imaging product line builds from LEADTOOLS' Raster Imaging technology to add features specifically for black and white imaging with the best possible performance.

LEAD Technologies provides two document imaging SDKs and several plug-ins for your document imaging development.

Developer Toolkits

LEADTOOLS Document Imaging

Includes everything you need to create high performance applications specifically for the document imaging vertical market. Includes Win32 API, ActiveX, VCL, C++ Class Libraries, COM objects and .NET Class Libraries.

LEADTOOLS Document Imaging Suite

LEADTOOLS Document Imaging toolkit with OCR support. Includes Win32 API, ActiveX, VCL, C++ Class Libraries, COM objects and .NET Class Libraries.

The following LEADTOOLS products can be added to these products:

LEADTOOLS Barcode Modules

LEADTOOLS eMail Module

LEADTOOLS JPEG 2000 Plug-in

LEADTOOLS PDF Plug-in

LEADTOOLS CMW Plug-in

LEADTOOLS ICR Module

LEADTOOLS OMR Module

LEADTOOLS OCR PDF Plug-in


Document/Medical Support and Licensing Requirements

Document/Medical Licensing and Royalty Agreements:

Congratulations! You have licensed one of the LEADTOOLS Document/Medical software products, the most comprehensive imaging toolkits on the market, enabling you to create powerful imaging applications. The license terms for LEADTOOLS Document Imaging, LEADTOOLS Document Imaging Suite, LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite require runtime licensing based on the number of copies of your application that you deploy (i.e., distribute or install and use internally).

By paying the initial box price for the applicable LEADTOOLS product, you have obtained a development license, which entitles you to develop your application and test it. Once completed, if you wish to distribute the application or deploy it internally on multiple machines, you are required to enter into a duplication and distribution agreement with LEAD. You have the ability to choose from several licensing options depending on your volume needs.

The product you are installing is a fully functional working version and includes support for all features in LEADTOOLS Document Imaging, LEADTOOLS Document Imaging Suite, LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite. (Depending on which product you have licensed, some of the features may ultimately not be available to you. See the on-line help file for a product feature comparison.) Until you sign and return the correct licensing agreement, your application will display a "nag" message. Once LEAD receives the executed contract, we will provide you a password that will permit you to terminate the "nag" message for the product that you have licensed. In addition to providing the password, you must also use the no nag version of the LTKRN14N.DLL, found in the REDIST\NONAGLTKRN directory. This is also the version you must redistribute.

Duplication and Distribution Agreements

Click this button to start a new WinHelp session to review the License Agreements governing your use of the software.


Document Clean-up

(Document/Medical) Scanned documents often contain a number of undesirable elements, including dots, blobs, lines, borders and hole punches. LEADTOOLS provides a number of properties, methods and events that will improve the appearance of scanned documents by removing dots, blobs, lines, borders, hole punches, inverted text, bumps and nicks.

Each functions or method takes a number of parameters that control the performance of the corresponding removal process. Included in the parameters is a set of flags that allows you to obtain a LEAD region or a Windows region that contains all the elements removed from a document. For each element found by one of the removal methods, a corresponding event is triggered. These events provide a means of customizing the removal process, as well as creating your composite of the removed regions.

The LEADTOOLS Document Clean-up features are available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging Suite

Support for the Document Clean up features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


.NET Image File Formats

.NET Raster Image File Formats

LEADTOOLS for .NET currently supports over 140 different image formats and sub formats, and continues to expand support for new formats and new format sub-types in response to the ever changing demands of developers worldwide.

With over 14 years in the field and thousands of customers in all areas of applications development, LEAD Technologies always strives to provide the most comprehensive support for the tremendous variety of image formats available.

Each image format has its own unique set of load/save/display options, which may encompass varying types and/or degrees of compression, a range of image information bit-depths, progressive (multi-pass) image display, the ability to maintain multi-page or multi-channel images, animations, or non-image data, just to name a few.

You can count on LEADTOOLS to have the most thorough and highest performance implementation of image format specifications, and you can depend on LEADTOOLS to offer the most flexibility and control of these options to you, the software developer.

RASTER Formats:

File formats in this list are loaded and treated as raster bitmap images in memory.

Color and GrayscaleAFP (PTOCA) Format (AFP)

ANI MSP

Bitonal (Black and White)

BMP Formats

CIN

CLP

CMW

CUT

Exif Formats (TIFF and JPG)

FIT

FLC

GIF and TIFF with LZW Compression

IFF

IMG

JBIG Format (JBG) *

JPEG 2000 Format (JP2) ***

JPEG and LEAD Compressed (JPG and CMP)

MODCA PTOCA

PCX Formats (PCX and DCX)

Portable Bitmap Utilities (PBM, PPM, PNM and PGM)

Portable Document Format (PDF) ***

Portable Network Graphics Format (PNG)

RAS

RAW

SCT

SFF

SGI

SMP

TIFF Without LZW Compression

Truevision TARGA Format (TGA)

WFX

WMP

WPG

XWD

Bitonal (Black and White)

CALS Raster (Type 1, 2, 3 and 4)

Image Object Content Architecture Format (IOCA/MODCA) TIFF CCITT and Other FAX Formats

ITG

LEAD 1-Bit Format (CMP) LMB

Microsoft Fax (AWD)

XBitMap Format (XBM)

LEAD is constantly adding the support for new file formats, and "flavor" support to formats already supported in .NET. The extensive format support provided by LEADTOOLS will give your application the flexibility to support almost any image you encounter.

* JBIG requires a LEADTOOLS Document Imaging product.

*** May require an additional purchase of a plug in or module.


eMail

LEADTOOLS eMail features provide support for connecting directly to Simple Mail Transfer Protocol (SMTP) and Post Office Protocol 3 (POP3) servers (Messaging Application Programming Interface (MAPI) is not required) to allow you to quickly add to your application the ability to:

Send messages/commands to an SMTP server

Use the LOGIN mechanism (ESMTP servers) or the USER/PASS mechanism for authentication

Specify the message sender

Compose and send messages using a built-in message-composition dialog box or by directly adding MIME entities (alternative or non-alternative), and examine them

Create/Parse RFC-2822 email message files

Add/Examine encapsulated messages

Encode/Decode Base64- or Quoted-Printable-encoded file attachments

Use/Examine a textual message body, with any format (plain, HTML, etc.) and any character set (US-ASCII, ISO-8859-2, etc.).

Create custom message header fields

Designate multiple individuals as authors of a message, multiple primary, carbon copy, and blind carbon copy recipients; and multiple "Reply-To" mailboxes (singles and groups)

Retrieve messages from POP3 servers

Retrieve the count of messages in the mail drop and their total size, the size and the server-determined unique-ID of a message in the mail drop, or message headers only

Mark messages for deletion on the server

Examine the message textual body and file attachments as well as the headers and bodies of messages and MIME entities

View messages using a message-viewing dialog box

The LEADTOOLS eMail features are available in the following products:

LEADTOOLS eMail

LEADTOOLS eMail Module

Support for the eMail features is provided for the following programming interfaces:

API

COM


Raster Pro/Document/Medical Features

Raster Pro:

LEADTOOLS Raster Imaging Pro provides some imaging capabilities that are not available in the LEADTOOLS Raster Imaging product. In order to access these features, you must unlock support for L_SUPPORT_LTPRO, using the UnlockSupport function or method. To unlock these features, call UnlockSupport/L_UnlockSUpport(L_SUPPORT_LTPRO, L_KEY_LTPRO). L_KEY_LTPRO can be found in ltkey.h for C and C++ and in L_OCX.bas for VB.

If you are a licensed user of LEADTOOLS Raster Imaging, and would like to access Raster Imaging Pro features, you must contact Tech Support for information on obtaining a license and the unlock key for calling L_UnlockSupport.

Document/Medical:

LEADTOOLS Document Imaging, LEADTOOLS Document Imaging Suite, LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite are the most comprehensive imaging toolkits on the market. No other toolkit provides as many imaging features for color, gray-scale and black & white images in one development package, and for one price. These toolkits comprise LEAD's best code and are designed for the programmer who is looking for the fastest performance, and/or the most extensive color, document, and medical imaging capabilities available.

These toolkits contain powerful annotation capabilities and optimized document image processing filters, and high performance compression, decompression and viewing of JPEG, LEAD CMP, and CCITT G3/G4. The annotation capabilities enable the programmer to add text, highlights, sticky notes, audio, ellipses, buttons, lines, arrows, rectangles, polygons, redaction (blackout), hotspots, freehand scribble, pointers, bitmap and text stamps, to black & white and color images. Programmers working with document imaging will also find special processing filters such as despeckle, deskew, favor black, and scale to gray to enhance their black and white 1 bit images. Additionally, you can achieve faster rotation in 90-degree increments by applying a rotated view perspective to the bitmap. These LEADTOOLS toolkits offer the fastest software-only JPEG decoder available.

LEADTOOLS Document Imaging

The LEADTOOLS Document Imaging toolkit contains all the features available in the LEADTOOLS Raster Imaging Pro. In addition, it contains the following capabilities:

Special functions for Document (bitonal) images. The LEADTOOLS functions for bitonal images are especially useful for working with images from black-and-white scanners or FAX machines. These functions let you do things such as automatically straighten (deskew) an image, remove spots (despeckle), or clarify a scaled display (using scale-to-gray and favor-black features).

Annotation. LEADTOOLS supports annotation of images by letting you overlay images with text, lines, shapes, arrows, buttons, highlights, hot spots, sticky notes, stamps, buttons, and sounds.

Fast rotation. LEADTOOLS achieves fast rotation in 90-degree increments by applying a rotated view perspective to the bitmap.

ISIS support. LEADTOOLS supports ISIS interfaces for driving scanning devices.

Faster compression and decompression. The Document/Medical editions work faster when loading and saving LEAD CMP, JPEG, and CCITT Group 3 and Group 4 images. The LEADTOOLS functions for loading and saving are the same in all products. The only difference is in performance.

1-bit Image Clean-up. The Document toolkits include support for removing dots, blobs, holes, inverted text, lines, borders, bumps and nicks from 1-bit images.

Region Clean-up. [Document/Medical] Remove all the holes from a region.

Embedded Messages. The Document toolkits include support for embedding messages in lossless image formats like bmp, tiff, lossless jpeg, etc. The message is embedded without any visible changes to the image, and does not appreciably increase the size of the image. The message is password-protected.

12 and 16 bit grayscale images. [Document/Medical] Load, process, display, window level and save 12 and 16 bit grayscale images (including support for 16-bit grayscale TIFF).

48 and 64 bit color images. [Document/Medical] Load, process, display, and save 48 and 64 bit color images.

LEADTOOLS Document Imaging Suite

The LEADTOOLS Document Imaging Suite toolkit contains all the capabilities of LEADTOOLS Document Imaging, and includes the features listed below. Please note that the OCR features are included in this toolkit, however they can also be purchased as a plug-in for the LEADTOOLS Document Imaging toolkit. Also, JBIG support is provided in this toolkit, however a JBIG Module may be added on to LEADTOOLS Document Imaging, LEADTOOLS Medical Imaging or LEADTOOLS Medical Imaging Suite.

OCR features. [Document/Medical] LEAD offers OCR features that use Scansoft Textbridge technology. Support for these features is included in the LEADTOOLS Document Imaging Suite, and can be added, via plug-in to the LEADTOOLS Document Imaging, LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite toolkits. The OCR features allow you to perform optical character recognition and turn images into documents. Features include preset confidence and accuracy levels for controlling how sensitive the engine is to unrecognized text, artificial intelligence for improving recognition on documents of the same type, and built-in and user-defined lexicons for limiting the type of text to recognize within a particular zone. LEADTOOLS provides the ability to verify or correct text during, and (using LEAD's unique OCR editor) after recognition. LEAD's OCR editor ties the text being edited directly to the image, providing a visual reference to the original bitmap data. The OCR engine can perform Automatic area segmentation creating multi-layered zones, recognizing areas such as tables, rules, images and text. Or, you can manually designate up to 250 such zones. The OCR features support different fonts, sizes (5 to 72 point) and styles. Fax, dot matrix and halftones can be preprocessed to improve recognition results. The OCR Engine supports major European and Scandinavian languages (Danish, Dutch, Finnish, French, German, Italian, Norwegian, Portuguese, Russian, Spanish, and Swedish) as well as English. Support for dialects such as US. English, French Canadian, Latin American Spanish, Swiss German, and Brazilian Portuguese is also provided.

Recognized text can be exported to more than 40 different formats, including MS Word, MS Excel, Dbase andWordPerfect. The LEADTOOLS OCR features contain superior OCR processing speeds, for use in form recognition and processing applications.

LEAD's JBIG filter. [Document/Medical] LEAD includes support for this filter in the LEADTOOLS Document Imaging Suite toolkit. Support for this filter can be added to LEADTOOLS Document Imaging, LEADTOOLS Medical Imaging or LEADTOOLS Medical Imaging Suite by purchasing the JBIG Module. JBIG defines a method for lossless compression encoding of a bi-level image (two-color image). This method can also be used for coding grayscale and color images. LEADTOOLS completely supports all three types of images, giving you the ability to make full use of this powerful compression technology. LEADTOOLS also supports the progressive capability of JBIG, allowing you to store and send multiple representations of images at different resolutions without any extra storage overhead.

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging contains all the capabilities of LEADTOOLS Document Imaging. It also includes general medical imaging technologies (1-16,24,32 bit color, 1-16 bit grayscale and window leveling of 12 and 16-bit grayscale images) and support for the DICOM file format.

DICOM file support. [Medical] LEADTOOLS Medical Imaging provides COMPLETE support for the DICOM 3.0 specification, including all standard IOD classes and modalities (CR, CT, MR, NM, US, RF, SC, VL, etc.) and complete DICOM Basic Directory support.

Window leveling. [Medical] Detect and set LowBit and HighBit for image data, display images with automatic LUT intensity expansion, or set LUT entries and ranges with specific values and gradients. Display images through the LUT without changing the data, or process the image data using the LUT. Linearize the number of pixels locally in a bitmap, based on the specified color space in order to bring out the detail in dark areas of an image, and smooth the edges between blocks.

Medical Imaging Processing. [Medical] LEADTOOLS Medical Imaging provides image processing functionality designed specifically to allow you to examine and improve the quality of medical images.

LEADTOOLS Medical Imaging Suite

LEADTOOLS Medical Imaging Suite contains all the capabilities of LEADTOOLS Medical Imaging. In addition, it supports the following:

DICOM Communication support. [Medical Suite] LEADTOOLS provides COMPLETE support for DICOM Communications, including all Service Classes (Verification, Storage, Query/Retrieve, Patient Management, etc), and contains high-level communications functions simplifying the creation of DICOM client/server applications.

(Document/Medical) is used in the documentation to designate the features that are available in LEADTOOLS Document Imaging, LEADTOOLS Document Imaging Suite, LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite. Those features that are available only in the Medical toolkits are indicated in the documentation by (Medical). Features available only in the LEADTOOLS Medical Imaging Suite toolkit are indicated in the documentation by (Medical Suite).

(Internet only) is used in the documentation to designate the features that are available only in the LEADTOOLS Internet toolkit.

For more information, refer to Document/Medical Edition Support and Licensing Requirements.


Files and File Formats

Supported File Formats

LEADTOOLS currently supports over 120 different image formats and sub formats, and with over 12 years in the field and thousands of customers in all areas of applications development, LEAD Technologies continues to expand support for new formats and new format sub-types in response to the ever changing demands of developers worldwide.

Here is a list of some of the file formats and some of the flavors LEAD supports: JPEG, DICOM, FlashPix (FPX), Fuji Exif 2.0 (EXF), Adobe PhotoShop (PSD), Kodak PhotoCD PCD, EPS, IOCA, MODCA, CALS raster (CAL), Windows Icon (ICO), Windows Cursor (CUR), PC Paintbrush (PCX), Multipage PCX (DCX), IMG, Windows DIB, FAXraw, Winfax (WFX), MAC, VDA, GIF (Embedded Text, Animated, Interlaced, Transparency), CompuServe PNG, Targa (TGA), Sun Raster (RAS), Macintosh PICT (PCT), LEAD CMP, Windows BMP, OS/2 BMP, Microsoft FAX (AWD), Windows Metafile (WMF), WordPerfect (WPG), AVI, Microsoft Paint (MSP), TIFF 6.0 (MPT, JPEG, Packbits, Huffman, RLE, LZWyf, CMYK, CCITT, CCITT G31D, CCITT G32D, CCITT G4, Bitonal, Grayscale, Palletized, RGB, YCbCr, CIELAB).

General File Format Support

Each image format has its own unique set of load/save/display options, which may encompass varying types and/or degrees of compression, a range of image information bit-depths, progressive (multi-pass) image display, the ability to maintain multi-page or multi-channel images, animations, or non-image data, just to name a few.

LEAD Technologies is constantly adding support for new file formats, and "flavor" support to formats already supported. The extensive format support provided by LEADTOOLS will give your application the flexibility to support almost any image you encounter.

Visit LEAD’s website at http://www.leadtools.com/formats.htm for a complete list of LEADTOOLS’ file format support.

(Note: a separate patent license from Unisys is required to use the GIF and TIFF LZW filters)

The LEADTOOLS General File Format features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the General File Format features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

CMW File Format Support

LEADTOOLS CMW compression/decompression outperforms all other known image compression algorithms in quality and compression ratio. CMW is a new advanced compression algorithm that is better than JPEG2000 in quality, speed and compression ratios. The LEADTOOLS CMW includes support for multiple resolutions. This makes your applications faster and more memory efficient because the entire file does not have to be loaded and decompressed just to load a low resolution image.

CMW is better than JPEG2000 for the following reasons:

CMW files are smaller than JPEG2000 files of comparable quality

CMW files can be loaded and saved faster than comparable JPEG2000 files.

Since there are fewer parameters to set, CMW files are easier to use.

Just like with JPEG2000 you have the ability to specify a progression order, giving you control over the display effect during a progressive decompression. The available progression orders are:

Quality Axis - The image starts blurred and the sharpness increases as more image data is received.

Resolution Axis - The image is loaded as a smaller version and the physical pixel size increases as more image data is received.

Color Axis - The image is loaded one color plane at a time. The image starts loading as a grayscale image and the color will fill in as more image data is received.

Position Axis - The image is loaded as blocks. As more image data is received, more blocks are displayed.

Additionally, you have complete control of the resulting file size and quality. You can choose to compress a file based on any of the following:

Target file size

Compression ratio

Quality Factor

You can even specify to use lossless compression so that when the compressed image is decompressed it will be exactly the same as the original image.

The LEADTOOLS CMW File Format support is available in the following products:

LEADTOOLS CMW Plug-in

CMW File Format Support is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

JPEG2000 File Format Support

The JPEG2000 format stores data in a hierarchical format containing several resolutions of the image in the same file without duplication of data. For that reason, a JPEG2000 compressed image can be sent to a device in the best resolution for that device, without requiring additional storage overhead. LEAD has committed to fully support all future parts as they are released and therefore LEADTOOLS JPEG 2000 SDK will continue to grow as the JPEG 2000 standard grows.

The LEADTOOLS JPEG 2000 File Format currently supports:

The JP2 file format and JPEG 2000 Stream Data.

Improved performance and quality.

Lossless compression, meaning the decompressed image data is exactly as it was before compression.

Four progressive display methods:

Quality Major - The images starts blurred and the sharpness increases as more image data is received.

Resolution Major - The image is loaded as a smaller version and the physcal pixel size increases as more image data is received.

Color Major - The image is loaded one color plane at a time. The image starts loading as a grayscale image and the color will fill in as more image data is received.

Position Major - The image is loaded as blocks. As more image data is received, more blocks are displayed.

Storage of multiple resolutions in the same file without duplication of the image data and the ability to decode and display only the size required by the application.

Error checking and robustness allowing the transmission of JPEG 2000 encoded files over a noisy medium. Even if an error occurs in the decoding, the image will still be displayed.

Control over the final size of the file with out hit and miss quality factor adjustments.

The LEADTOOLS JPEG2000 File Format support is available in the following products:

LEADTOOLS JPEG2000 Plug-in

Support for JPEG2000 file format is also provided for end users with the LEAD JPEG2000 Adobe PhotoShop Plug In.

LEADTOOLS JPEG2000 File Format Support is provided for the following programming interfaces:

ActiveX

Conversion API

Class Library

COM

.NET

VCL

Please note that LEAD also offers the LEADTOOLS JPEG 2000 COM Object for IE Module, which lets you view JPEG 2000 images in ActiveX enabled web browsers, such as Internet Explorer. For more information, refer to LEADTOOLS JPEG 2000 COM Object for IE.

MRC File Format Support

The LEADTOOLS MRC (Mixed Raster Content) file format results in both high compression factors and high detail retention. This format enhances LEADTOOLS file input/output functionality by adding support for raster color documents containing mixed image and text components. The MRC file format breaks an image into three different layers: foreground, background, and mask. Each layer is compressed separately using the best type of compression for that data type and is later uncompressed and recombined to restore the original image. Because standard compression schemes are geared towards an image being entirely text or color, the MRC model offers the advantage of using optimal compression for images that have both text and color in the same image.

The foreground layer contains color data for the text and line art, and may also contain photographic or continuous tone color data. The background layer generally contains low-resolution color image data, such as a background image, a wash or other pattern that would have text overlaid on it. The mask layer or the selector layer controls the process of image regeneration contains binary image data that is high spatial resolution, such as text and line art. This layer is used for drawing the corresponding foreground and background layers.

Segmentation can be performed automatically with the option to optimize it manually or it can be done only manually. Compression can be specified for each area type. The compression for 1-bit black and white areas can be CCITT G3 1D, CCITT G4 2D, CCITT G4 or JBIG. The compression for color areas is JPEG.

The LEADTOOLS MRC File Format support is available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

MRC File Format Support is provided for the following programming interfaces:

API

Class Library

COM

Multimedia File Format Support

Non-Multimedia toolkits can load AVI and MPEG files as raster still images and can save AVI files. . These features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

In the Multimedia toolkits, LEAD provides much more extensive support for multimedia formats. LEADTOOLS Multimedia products can playback any input file format supported by DirectShow, including:

AVI

WAV

Quicktime 2.0

WMA Windows Media Format

WMV Windows Media Format

ASF Windows Media Format

Mpeg1 Layer-3 Audio (MP3)

LEADTOOLS Multimedia products can convert any of the supported playback file formats to:

AVI (using any available video compressor on the computer)

WAV (using any available audio compressors on the computer)

WMA Windows Media Format

WMV Windows Media Format

ASF Windows Media Format

Mpeg1 Layer-3 Audio (MP3)

For more information on the support provided by the LEADTOOLS Multimedia toolkits, refer to the Multimedia Features.

PDF File Format Support

Support for the Portable Document Format, (PDF) is provided by the LEADTOOLS PDF Plug-in which is an add-on module for all LEADTOOLS Toolkits with the exception of the Linux versions and extends support for PDF, Postscript, and EPS formats.

The Portable Document Format was developed by Adobe Corporation to allow users to exchange and view their electronic documents in an easy and reliable way, independent of the environment in which these documents were created. A PDF file will look the same on the screen and in print regardless of what kind of machine you are using or which software package was used to create that file. One major advantage of PDF is that a large document can be compressed small enough to download very quickly, and still displays content as if you were looking at the original source such as a book or magazine.

Postscript is a simple interpretive page description language. Postscript is the language that most advanced laser printers use in order to render electronic information on a printed page. EPS stands for Encapsulated PostScript. An EPS file is a PostScript language program describing the appearance of a single page.

The LEADTOOLS PDF File Format support is available in the following products:

LEADTOOLS PDF Plug-in

For more information on the support provided by the LEADTOOLS PDF Plug-in, refer to the PDF Features.

Vector File Format Support

Support for vector file formats is provided by the LEADTOOLS Vector Imaging Pro toolkit. Supported file formats include Vector File Formats include CGM, DGN, DRW, DWF, DWG, DXF, EMF, WMF, PLT, Gerber, PCL, PCT, SVG, VWPG, CMX and SHP. LEADTOOLS Vector Imaging provides 2-D and 3-D vector imaging for loading, viewing, modifying and saving vector files to memory/disk in native vector format. With Vector Imaging, objects are represented as exact geometrical entities, rather than approximated by a collection of discrete pixels, making them inherently scalable and suitable for other mathematical transformations. Drawing and CAD/CAM programs typically use vector images.

For more information on the support provided by the LEADTOOLS Vector Imaging Pro toolkit, refer to the Vector Imaging Features.

Working with Files

Each image format has its own unique set of load/save/display options, which may encompass varying types and/or degrees of compression, a range of image information bit-depths, progressive (multi-pass) image display, the ability to maintain multi-page or multi-channel images, animations, or non-image data, just to name a few. LEADTOOLS offers extensive libraries of functions that allow you to deal with each type of image format and its special options, whether its Comments, Getting and Setting File Information, Layers, Loading Files, Multipage Files, Saving Files, or Tags. Each of these unique options is described in more detail in the following sections.

Comments

Some file formats can contain comments, and some cannot, and each file format has its own set of comment types. LEADTOOLS supports each of the following types of comments in one or more products:

DICOM File Comments

Exif File Comments

FlashPix File Comments

GIF File Comments

IPTC Comments

JPEG and LEAD File Comments

PNG File Comments

TIFF File Comments

Getting and Setting File Information

LEADTOOLS provides extensive functionality for getting file information. Whether an image file is on disk or in memory, you can get information about the image before loading it. You can also handle file-format-specific information, such as the page number or physical resolution. Support includes functions that allow you to:

Obtain descriptive information about a file (including those loaded in memory)

Obtain embedded audio data

Determine what resolutions a file contains

Load a stamp

Read or load extensions from an Exif file

Read the transforms stored with an image in a FlashPix file.

Functionality for setting file information is just as extensive. Support includes functions that allow you to:

Specify a callback function for handling input data that is in an undetermined format, used for loading raw FAX data (CCITT Group 3 or Group 4), raw run-length-encoded data (4-bit or 8-bit), raw Bitfield compressed data, raw PackBits compressed data or raw uncompressed data.

Specify the physical resolution (width and height) of the FlashPix, PhotoCD, or JBIG file to load.

Set the resolution to be used for loading or converting a PhotoCD file.

Set the resolution for the next save operation. Currently, this function only works with the JBIG format.

Set the DPI (dots per inch) value that LEADTOOLS uses when loading WMF files. By default, the value is 0. WMF files can contain vectored graphics or raster images. LEADTOOLS can load either type, but can save only raster images. The issue of image resolution arises mainly when loading vectored graphics.

Write comments.

Write transforms to a FlashPix file.

Layers

PSD file formats support layers. LEADTOOLS provides functionality to allow the loading of an individual layer. PSD files can also be saved with layer information.

Loading Files

LEADTOOLS provides many options when loading image files. You can load an image at its own color resolution, manipulate it, and display it, regardless of current video mode. You can also convert the image to a specific color resolution (bits per pixel) as you load or save it. You can supply the input for a load operation or the output of a save operation, and you can add processing, such as a paint-while-load feature. You can control the execution of a load procedure as you supply transmitted image data. You can also load an image from a file, into a bitmap, and resize the bitmap as it loads.

The LEAD and JPEG (JFIF) file formats can be extended to support progressive loading and saving of images. Progressive loading is useful for transmitting images, because the first part of the file contains the full dimensions of the image. If you want to take advantage of this feature when loading a progressive file, you can control the number of passes that are required to complete the image.

JBIG and JPEG2000 also support progressive loading of an image.

Multipage Files

LEADTOOLS supports the following multipage file formats. These formats are:

Animated Gif

CALS3

DICOM (Read Only)

DCX

FlashPix

IOCA/MODCA

Tiff(MPT)

When working with multipage files, you can delete individual pages within the file. When loading a multipage file, you can load all pages, or use a different function to load only one of the pages.

To load and play an animated GIF file, you can load a list of bitmaps from the file, and then play the list to a target bitmap in a loop that displays each change in the target bitmap. You can also create an animation sequence from scratch and save the bitmaps to create an animated GIF file.

Saving Files

LEADTOOLS provides many options when saving image files. You can convert an image to a specific color resolution (bits per pixel) as you save it. You can save a bitmap to a file in a memory buffer.

The LEAD and JPEG (JFIF) file formats can be extended to support progressive loading and saving of images. Progressive loading is useful for transmitting images, because the first part of the file contains the full dimensions of the image. If you want to save a progressive file you can control the number of passes that are required to complete the image.

Tags

The TIFF file formats support a number of comments that are saved and loaded using predefined tags. LEADTOOLS provides functionality to specify a comment to be saved as well as read and write comments. If the comments do not meet your needs, you can define your own tag for saving additional non-raster data in a TIFF file. The LEADTOOLS functions let you save one additional tag in a TIFF file. They are designed for future expansion to more than one tag.

The LEADTOOLS Files and File Formats features discussed above are available in the following products, except where otherwise noted above:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the LEADTOOLS Files and File Formats features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


FlashPix

The LEADTOOLS FlashPix features provide support for loading and saving FlashPix files, as well as more advanced features such as transformations and comments. Please note that while the loading and saving capabilities are available in all the products listed later in this topic, the advanced capabilities such as transformations, comments, etc. are not available in the LEADTOOLS Raster Imaging toolkit.

The FlashPix file format was developed through the combined efforts of Eastman Kodak Company, Microsoft Corporation, Hewlett-Packard Company, and Live Picture Inc. It combines the best features of existing formats with object orientation to make the use of digital color images easier.

The format of a FlashPix file is based on compound object storage, which allows storage of various kinds of data. A FlashPix file may consist of several "pages" where each "page" has storage for a source image, non-image data in the form of comments, transform data, and a stamp or thumbnail. Each image is stored as an entire multi-resolution hierarchy where each resolution in the hierarchy differs from the next highest resolution by a factor of 2 in the x dimension and in the y dimension. Non-image data are treated as comments in FlashPix file format. Comments are used to store information pertaining to the image, not actual pixel data. This information may include image title, image subject, camera manufacturer, scan software version number, and so forth. In addition to the image itself, FlashPix files store transform information. This data indicates transformations that may be performed on the source image. By storing the transforms, the source image may be stored in its original state and transformed, using the stored transforms, at your discretion. A stamp, or thumbnail, provides a small bitmap representation of a FlashPix image.

The LEADTOOLS FlashPix features are available in the following products, except as noted above:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for loading and saving FlashPix features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Support for the advanced FlashPix features is provided for the following programming interfaces:

API

Class Library


Image Processing

LEADTOOLS has over 200 image processing functions, some of which are typically found only in high performance end-user programs such as PhotoShop. The following overview divides these functions according to their availability in the different products. Those functions listed in the Raster Image Processing section are available in the Raster, Document and Medical toolkits. Functions described in the Document Image Processing section are available in the Document and Medical toolkits. Functions described in the Medical Image Processing section are available only in the Medical toolkits.

Raster Image Processing:

The raster image processing functions are separated into four categories:

Transforms: LEADTOOLS transforms include resize, resample (interpolated resize), rotate (.01 degree), flip, invert, reverse, crop, underlay, shear, transpose, fill, and combine bitmap (using your choice of mathematical and Boolean operations).

Filters: LEADTOOLS color filters include sharpen, blur, intensity, contrast, gamma correct, invert, hue and saturation, histogram equalize, emboss, mosaic, posterize, median, average, oilify, edge enhance, solarize, and add noise. LEADTOOLS spatial filters (which can be pre-defined or user-defined) include gradient, laplacian, sobel, prewitt, shift and difference, line segment. LEADTOOLS binary filters include erosion, dilation, max and min.

Drawing: With the LEAD DeviceContext, LEADTOOLS gives you access to the bitmap surface, on which you can draw or paint using Microsoft Windows GDI functions (such as TextOut, BitBlt, Ellipse, and Rectangle).

Region of Interest: The LEADTOOLS region of interest makes it possible for you to process or paint only a specific portion of an image rather than the entire image. Regions can be comprised of any combination of rectangles, ellipses, rounded-rectangles, freehand shapes, polygons, transparent color and more.

Most of the LEADTOOLS functions that change the appearance of an image act on the bitmap (not just the display). This is an important distinction, because the changes become permanent when the bitmap is saved to a file.

To change the appearance of the image in a bitmap, you can do the following:

Define the bitmap as a display surface where you can use Windows graphics device interface (GDI) functions for drawing or adding text.

Automatically trim a bitmap to remove blank space around the edges.

Rotate the image. (Angles can be precise to 100th of a degree.)

Do fast rotation in 90-degree increments

Shear the image in the fashion of a parallelogram. (Angles are precise to 100th of a degree.)

JPEG and CMP compressed images can be rotated in 90 degree increments or flipped with no loss of quality.

Change the orientation by flipping the image horizontally or vertically.

You can adjust colors and intensities as follows:

Change brightness using a flat scale.

Change brightness using gamma correction.

Change contrast.

Stretch the range of intensities.

Remap intensities using a lookup table.

Create look up tables based on points on a curve or a mathematical function.

Invert colors.

Change hue and saturation.

Use the Histogram equalize function to bring out the detail in the dark areas of the image.

Fill with a specified color.

Get and put colors of individual pixels.

You can apply the following kinds of conversions:

Halftone for display or printing.

Sharpen or blur.

Posterize, specifying the number of color planes.

Mosaic, specifying the tile size.

Emboss, specifying the lighting direction.

Soften an image using an average filter.

Reduce noise using a median filter.

Add noise in any or all color planes.

Apply an oil-painting effect.

Apply a solarization effect.

Picturize with a list of images or a single image.

You can use filters to do the following:

Detect ranges of intensity.

Detect edges using gradient or Laplacian edge detection.

Detect lines using Sobel, Prewitt, shift and difference, or line segment detection.

[DLL only] Implement your own spatial filters.

Combine images using boolean and arithmetic operators, and color masking. (This is useful for combining filtered images with originals.)

Combine two images so that one appears to be an underlying texture of the other.

Combine multiple images to create a new image that resembles the current image.

Apply Fourier Transforms to images.

And many other effects such as: Swirl, Ripple, Radial Blur, Impressionist, Wave, Shear, Remove Redeye, Cubism, Glow, Age, etc.

You can use low-level functions to change parts of an image as follows:

Get and put rows of image data.

Get and put parts of rows.

Get and put the colors of individual pixels.

Process a region within a bitmap

The LEADTOOLS Raster Image Processing features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Raster Imaging Pro for .NET

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Raster Image Display features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Document Image Processing

To support Document Image Processing, LEADTOOLS incorporates specialized technology optimized for use with bitonal (2-color or black/white) images such as scanned text documents, line art or technical drawings. This includes the ability to do fast rotation in 90-degree increments.

To change the appearance of the image in a bitmap, you can do the following:

[Document/Medical only] Automatically straighten (deskew) a 1-bit image.

[Document/Medical only] Remove specks from (despeckle) a 1-bit image or perform other document clean-up operations

Apply filters to do the following:

[Document/Medical only] Apply morphological (binary) filters to erode or dilate black objects.

The LEADTOOLS Document Image Processing features are available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Document Image Display features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Medical Image Processing

In addition to the capabilities described for Document Imaging Processing, Medical Imaging Processing capabilities include support for 1-16, 24, and 32 bit color as well as complete support for 12 and 16 bit grayscale image processing, display, window-leveling and LUT processing. The grayscale support includes support for 16-bit grayscale TIFF. The window-leveling capabilities allow you to develop applications that can detect and set LowBit and HighBit for image data, display images with automatic LUT intensity expansion, or set LUT entries and ranges with specific values and gradients. You can also develop applications that can display images through the LUT without changing the data, or process the image data using the LUT.

The LEADTOOLS Medical Image Processing features are available in the following products:

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Medical Image Display features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


Image Processing: Region of Interest

LEADTOOLS region of interest makes it possible for you to process or display only a specific portion of an image rather than the entire image.

Regions can be defined as any combination of shapes including rectangles, ellipses, rounded-rectangles, freehand shapes, polygons, curves and Bezier curves, and more.

LEADTOOLS also lets you select regions based on the color of pixels within the image. You can select all pixels in an image having a specific color, or you can select contiguous regions starting with a seed pixel and a color-match threshold by using the "Magic Wand". Complex regions can be built using a variety of boolean operations on simpler regions, including union, intersection, xor, and inverse.

Additionally, LEADTOOLS includes region functionality not found or is difficult in Windows including resizing, rotating and other transformations of regions.

The region of interest is available in the following products:

LEADTOOLS Multimedia

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Raster Imaging Pro for .NET

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro


Imaging Common Dialogs

The LEADTOOLS Common Dialog boxes greatly simplify development and save hours of tedious programming by combining Windows Common Dialog functionality with LEADTOOLS imaging functionality to provide imaging-specific capabilities. The Common Dialog boxes provide complete code for all common imaging dialogs such as FileOpen, FileSave, Color Resolution, Image Processing/Filtering, and Effects. Thumbnail previewing of image changes saves processing time and avoids un-dos. You can specify your own String and/or Text, as well as handle Language Customization – simplifying the task of localizing your software for International users.

The LEADTOOLS Imaging Common Dialogs also provide input dialog boxes for all LEADTOOLS image processing functions. These dialogs allow you to quickly and easily enable your application to gather input from end-users for the parameters required by the various LEADTOOLS functions. These dialogs can also be used to automatically process the image based on end-user input (thus reducing the amount of code you have to write).

The dialog functions feature:

Reusable dialogs for the most common LEADTOOLS image processing functions and effects.

Extended FileOpen and FileSave dialogs which contain LEADTOOLS specific options.

Thumbnail Preview option for FileOpen dialog to allow the user to preview images without loading them.

Thumbnail Preview for image processing dialogs to allow the user to preview changes without affecting the original image.

A Help Button callback function to let you provide custom help information for each dialog (if desired).

User Interface control for the dialogs provided through flags passed to each dialog function or method.

Optional Automatic processing of the image by the dialog.

The common dialogs for the ContourFilter and Window Level Imaging are only available in the LEADTOOLS Medical Imaging and the LEADTOOLS Medical Imaging Suite toolkits.

The LEADTOOLS Imaging Common Dialogs features are available in the following products, except where noted above:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Imaging Common Dialogs features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


Internet/Intranet Imaging

LEADTOOLS features a Net Aware ActiveX and COM objects for Internet/intranet applications. The LEAD Main ActiveX control, VCL control and COM objects includes a BitmapDataPath feature, which allows images in any supported raster format to be read from any URL. Additionally, the ActiveX, VCL and COM objects also include an AnnDataPath feature, allowing LEADTOOLS annotation files to be loaded from any URL. LEADTOOLS includes support for Progressive JPEG, Progressive CMP, and interlaced GIF, so you can display images as they are downloaded. GIF support also includes transparency, animation, and embedded text. The GIF code has support for 1 through 8 bits per pixel files. A FeedLoad function is included to allow image data to be displayed as it is being transmitted across the net, providing Internet programmers with the fastest way to begin painting the client’s screen. LEADTOOLS Raster Imaging Pro, Document Imaging products and Medical Imaging products include the above plus low over head COM objects with minimal DLL dependencies that can be used both client and server side. Additionally, HTTP and FTP controls are included to help you send information and images from the client back to the server. An INET control is included to create client server applications to control remote computers using remote procedure calls. On the server side it also includes an Upload control to assist the developer in properly getting the data. Examples for VBScript, JavaScript, and ASP/VBScript are included to assist you in incorporating images into Internet applications.

LEADTOOLS lets you do the following when working with the Internet:

Use the ActiveX control's net-aware capabilities to load an image (stored in any of over 70 supported raster formats) asynchronously over the Internet. You can do this by specifying the URL in a single property.

Use Microsoft Internet Explorer to load, display, and save any of the image formats that LEADTOOLS supports.

Use LEAD controls in an ASP or ISAPI app to perform server side image processing.

Use LEAD controls in an ASP or ISAPI app to convert images from a non browser friendly format to a browser friendly one.

Use LEAD controls in an ASP or ISAPI app to get and put images into a database.

Submit images and information from any application that to a web server via an HTTP Form.

Upload images to an FTP server.

Parse the images and data out of the posted request string.

Use the LEAD controls on the client to perform any of the LEADTOOLS functionality via the LEADTOOLS ActiveX controls or COM objects.

Control how data is fed to a load routine.

Handle progressive reading and writing of JPEG and LEAD CMP files.

Handle transparency, interlaced formatting, and text in GIF files.

Create and maintain lists of bitmaps that are used for animation.

Create and play animations, read and write animated GIF files, and read AVI files.

Read and write most other image file formats that are transmitted on the Internet.

Create client/server applications, including video conferencing programs.

Send and Receive email.

The LEADTOOLS Internet/Intranet Imaging features are available in the following products:

LEADTOOLS Raster Imaging Pro

LEADTOOLS Raster Imaging Pro for .NET

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Medical Imaging Suite

Support for the Internet/Intranet Imaging features is provided for the following programming interfaces:

ActiveX (No FTP or HTTP ActiveX)

API

Class Library

COM

.NET (No FTP, HTTP or INET .NET)

VCL (No FTP, HTTP or INET .NET)

Please note that LEAD also offers the LEADTOOLS JPEG 2000 COM Object for IE Module, which lets you view JPEG 2000 images in ActiveX enabled web browsers, such as Internet Explorer. For more information, refer to LEADTOOLS JPEG 2000 COM Object for IE.


JBIG

(Document/Medical only) JBIG is an acronym for 'Joint Bi-level Image experts Group'. This was a group of experts nominated by national standards bodies and major companies to work to produce standards for bi-level image coding.

The JBIG group has developed IS 11544 (ITU-T T.82) standard for the lossless compression of a bi-level image. It can also be used for coding grayscale and color images with limited numbers of bits per pixel. It can be though to be similar to Group 3 or Group 4 fax, offering between 20% and 80% improvement in compression over these methods. JBIG compression averages about a 20:1 over the original uncompressed image.

LEADTOOLS completely supports all three types of images (bitonal, grayscale and color), giving you the ability to make full use of this powerful compression technology. LEADTOOLS also supports the progressive capability of JBIG, allowing you to store and send multiple representations of images at different resolutions without any extra storage overhead.

To achieve the highest compression ratios available in the JBIG format, LEADTOOLS takes full advantage of all the functional blocks of this robust standard:

The Adaptive Arithmetic Encoder, which presents the heart of this format, has the ability to predict and hence encode future data symbols based on the data which is being currently encoded.

The Adaptive Template Block provides real coding gain for images rendered by grayscale with halftoning. This gain ratio approaches 80% in some situations.

The Typical Prediction Block speeds implementations and provides some coding gain.

The Resolution Reduction Block is used to get a lower resolution version of an image so that no loss of data is encountered. This is mainly important for bi-level images, to avoid any deletion of thin lines.

The Deterministic Prediction Block provides good coding gain when saving more than one resolution layer in the same file.

The LEADTOOLS JBIG features are available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging Suite

Support for the JBIG features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


JPEG 2000 COM Object for IE – COM Object

The LEADTOOLS JPEG 2000 COM Object for IE COM programming interface is provided by the LTJ2K.OCX. This COM object provides the properties, methods and events used for viewing JPEG 2000 images in ActiveX enabled web browsers. The COM programming interface that provides this support is available in the following product:

LEADTOOLS JPEG 2000 COM Object for IE

If you have installed the product listed above, these properties, methods and events can be found in the LEADJ2KHelp.htm file in the LEADTOOLS\Help directory, where "LEADTOOLS" represents the directory in which you installed the toolkit.


LEADTOOLS JPEG 2000 COM Object for IE $199*

(Contains easy to use COM objects)

The LEADTOOLS JPEG 2000 COM Object is designed for viewing JPEG 2000 images in ActiveX enabled web browsers, such as Internet Explorer.

The LEADTOOLS JPEG 2000 COM Object has a download size of only 390 KB, and the OCX requires no other runtime files.

*Requires the LEADTOOLS JPEG 2000 Plug-in and one of the following:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

LEADTOOLS Vector Imaging Pro

This product includes part of the following features:

Files and Files Formats

Image Compression

Image Display

Internet/Intranet

This product supports the following programming interface:

JPEG 2000 COM Object for IE – COM


LEADTOOLS for Pocket PC 2002 $995

(Contains low level API and easy to use COM Objects)

LEADTOOLS for Pocket PC 2002 lets you instantly add imaging support to your Pocket PC application. Whether it is file conversion, display and transition effects, image processing, color conversion, compression, Internet image support, etc..., you will have a quick answer - " LEADTOOLS Imaging Library for Pocket PC 2002".

Using rock solid, time-tested code, LEAD Technologies has ported much of its LEADTOOLS Win32 toolkit to Pocket PC 2002, including functionality to implement the following features:

  • Read, write and convert image files of the most popular standard image formats, including BMP, CMP, CMW, FAX, GIF, J2K, PCX, XBM, XPM, TIFF (including G3/G4, LZW*, JTIF, many more), PNG, TGA, GIF*, and many more!
  • Use more than 80 digital filters and transforms to process images. Smooth, sharpen, edge detect/enhance, modify brightness/contrast/gamma, change hue and saturation, unsharp mask, resize and rotate images using various resampling techniques (including bicubic), and much more.
  • Convert between color depths, such as 24-bit true-color, 8-bit indexed, 1-bit black/white, and many more. Changing the color depth changes the amount of data stored per pixel, which alters an image's memory/disk requirements.
  • Compress images using a wide variety of compression algorithms, including JPEG, CMP, LZW*, G3/G4, Huffman, run-length, JPEG 2000, and CMW. LEAD offers comprehensive support for compression schemes found in standard raster file formats, as well as high-performance proprietary compression technologies that outperform the industry standards.
  • Render images to the device while controlling position/scaling, resample method (normal/bilinear/bicubic), brightness/contrast/gamma, color-reduction/dithering, image(source) and device(destination) clipping, and more. Browse a group of images using an ImageList control, apply 2000+ paint transitions and effects between viewed images, and play animations such as animated GIF files.

Internet support includes functions to load images from URL’s or memory streams.

*GIF and other LZW compressed formats require an LZW patent license from Unisys to be included with your application.

This product is Royalty Free up to 100 copies. For more than 100 copies, contact LEAD.


Multimedia

LEADTOOLS provides two basic levels of support for multimedia: simple loading and saving, and advanced multimedia features. These levels are described in more detail in the following sections.

Simple Loading and Saving

Non-Multimedia toolkits can load AVI and MPEG files as raster still images and can save AVI files. These features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for these features is included in the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

Advanced Multimedia Features

With LEADTOOLS Multimedia features, you get everything you need to create applications that can convert, play, or capture multimedia data. This includes creating video frames with synchronized sound; editing, playing, and saving AVI files; recording, playing, and saving WAV files; and playing MIDI, SND, AIF, AIFC, and MPEG-1 files. It is easy to capture multimedia data from any Windows Video Capture Device, using input from devices like VCRs, camcorders or digital cameras. LEADTOOLS Multimedia toolkits let you stream (progressively play and download) multimedia files such as Microsoft's ActiveMovie and Apple QuickTime, and quickly create client server applications to run over the Internet.

No matter what your Multimedia functionality needs are (Capture, Playback, Processing, Compression, Multimedia File Format Support, or DirectX Filters, LEADTOOLS Multimedia SDK products have the functionality that lets you create applications that can:

Capture

Support for WDM, native Direct Show including DV, and Video for Windows capture devices.

Compress Audio and Video while capturing.

Output compressed and uncompressed AVI, Windows Media content, WAVE and MPEG1Audio (MP3) formats.

Capture directly to a file or grab images individually to memory.

Perform video (Fit to window, stretch, 50%, 75%, 100%, 200%, and full screen) and audio preview during capture.

Use the audio source built into the video device or a different audio source.

Support close captioning.

Support TV tuners.

Support multiple built-in configuration dialog boxes.

Obtain statistics during capture.

Support video and audio processing filters.

Perform capture from any of a number of modes:

Streaming video and audio

Automatically triggered video frame sequences

Manually triggered video frame sequences

Still images

Conversion

Convert to and from AVI, Windows Media content, WAVE, and MPEG1 Audio (MP3) formats.

Perform custom compression for Video (AVI) and audio (AVI & WAV).

Support input from disk, Internet memory, media source or custom source (for example, feed every sample or from your own source filter).

Support output to disk, memory, media source or custom (you get every sample).

Support multiple built-in configuration dialog boxes.

Support video and audio processing filters.

Show progress while converting.

Playback

Play all formats supported by DirectShow.

Support disk, Internet memory, media source or custom source (for example, feed every sample or from your own source filter).

Playback using time-based, frame-based or synchronized with a track bar positioning.

Mark the portion you want to play.

Perform playback set to an infinite loop or a specific count.

Get content information such as Author, copyright, etc.

Support video and audio processing filters.

Offer fit to window, stretch, 50%, 75%, 100%, 200%, and full screen video options.

compression

Compress individual samples with any available DirectShow filters (memory to memory).

DirectX Filters

LEADTOOLS Multimedia includes an evaluation version of the Multimedia filter pack that includes powerful multimedia processing functionality. For pricing for DirectShow Filter client licenses, contact oemsales@leadtools.com.

Audio and Video filters:

Data Encryption - Encrypt video and audio with a 128-bit encryption key making them unintelligible without the correct key.

Audio filters:

VU Meter - Detects the strength of an audio stream.

LEAD Echo Filter - Adds an echo audio effect.

LEAD Volume Control Filter - Adjust the volume - useful for bringing audio files to the same level so audio from one source is not louder than audio from another source.

Video filters:

DICOM Filters* - Create and play DICOM files without programming!

Just register the DICOM reader and view any DICOM file in LEAD's MM player or Windows Media Player.

Use the DICOM writer filter to capture straight into a DICOM file or convert any video to a DICOM file. The writer uses a template DICOM file containing the non-image DICOM tags needed to create valid DICOM files. The writer also has built-in data compression support. The writer is also designed to integrate seamlessly with LEADTOOLS Medical Imaging toolkits where it can stream directly into a LEADTOOLS DICOM DataSet

De-Interlace - Eliminate annoying video interlace artifacts.

LEAD RGB Converter - Convert to and from RGB8 color, RGB8 grayscale, RGB15 (5:5:5), RGB16 (5:6:5), RGB24, RGB32 and 16 bit grayscale* color spaces.

LEAD Video Add Filter - Brightens a frame by adding two or more frames. Useful in correcting video taken in low-light conditions. For example, astronomers should find this filter useful.

LEAD Video Color Filter - Adjust Hue, Saturation, Brightness, Contrast.

LEAD Video Crop Filter - Crops the video to any specified dimensions.

LEAD Video Emboss Filter - DirectX transform filter that can be used with DirectShow Editing Services (DES) to create an emboss or bumpmap effect.

LEAD Video Gamma Correction Filter - DirectX transform filter that can be used with DirectShow Editing Services (DES) to for Gamma Correction.

LEAD Video Histogram Equalize Filter

LEAD Video Histogram View Filter - Show the histogram as the video is playing.

LEAD Video Mosaic Filter

LEAD Video Resize Filter - Resizes the video - can use normal resize, resample, bicubic interpolation.

LEAD Video Rotation Filter - Flip, Reverse, Rotate 90, Rotate 180, Rotate 270 degrees.

LEAD YUV Transform Filter - Transform from various YUV formats to other YUV or RGB.

* DICOM and 16 bit grayscale functionality require a LEADTOOLS Medical Imaging product in conjunction with a LEADTOOLS Multimedia product. Contact Sales@LEADTOOLS.com for more information.

These features are available in the following products:

LEADTOOLS Multimedia

Support for these features is provided for the following programming interfaces:

ActiveX

API

COM


OCR

LEADTOOLS' OCR engine is based upon the time-tested industry standard ScanSoft Capture Development System v12 engine.

LEADTOOLS OCR engine brings together a considerable number of recognition modules:

· MTX, FRX, MOR and the PLUS2W and PLUS3W omnifont modules for the recognition of different machine-generated texts.

· HNR and RER modules for handprint recognition.

· DOT module for 9-pin draft dot-matrix printouts.

· OMR module for optical mark recognition.

· MAT module for fixed-font texts (MICR or E-13B, OCR-A, OCR-B, etc.).

Through the MOR, PLUS2W and PLUS3W multi-lingual recognition modules, the LEADTOOLS OCR Engine supports over 110 languages, including languages that use the Latin, Cyrillic and Greek and related alphabets.

Besides recognition, the LEADTOOLS OCR Engine offers all LEAD File formats as an input.

The LEADTOOLS OCR Engine can deliver precise coordinate, confidence and attribute data for each recognized character, giving the application great control over the formatting of the output text - at one extreme mirroring the input document, at the other permitting a unique user-defined style.

In addition to the above new recognition modules, the LEADTOOLS OCR engine supports the following new features:

A. Import and export all image file formats supported by LEADTOOLS.

B. You can recognize the entire page area as one zone, and you can specify zones in each page, and recognize them all.

C. You can specify a different recognition module for each zone in the same page.

D. The optional PDF Output kit offers five PDF converters to produce different types of PDF outputs including image-only, searchable, and other PDF output files.

E. The engine lets you to create your dictionary to use it with the recognition process.

F. You can specify the dictionary that you need to use, and the spell languages that will be used for the checking subsystem (confidence).

G. And more...

The LEADTOOLS OCR features are available in the following products:

LEADTOOLS Document Imaging Suite

LEADTOOLS OCR Module

Support for the OCR features is provided for the following programming interfaces:

API

COM


PDF

PDF stands for Portable Document Format. It was developed by Adobe Corporation to allow users to exchange and view their electronic documents in an easy and reliable way, independent of the environment in which these documents were created. A PDF file will look the same on the screen and in print regardless of what kind of machine you are using or which software package was used to create that file. One major advantage of PDF is that a large document can be compressed small enough to download very quickly, and still displays content as if you were looking at the original source such as a book or magazine.

Postscript is a simple interpretive page description language. Postscript is the language that most advanced laser printers use in order to render electronic information on a printed page. EPS stands for Encapsulated PostScript. An EPS file is a PostScript language program describing the appearance of a single page.

PDF is emerging as a powerful format for reproducing documents over the web. Because of its high precision and accuracy in representing text and pictures along with its "hyper" nature, PDF is becoming a popular alternative to HTML and Postscript.

The LEADTOOLS PDF Plug-ins are add-on modules for all LEADTOOLS Toolkits with exception of LEADTOOLS Multimedia and extends support to include PDF, Postscript, and EPS formats. The LEADTOOLS PDF SDK Plug-ins support loading±, saving, viewing±, rasterizing±, and encoding of these three formats and integrates seamlessly with the broad imaging functionality present in the existing LEADTOOLS toolkits, encompassing specialized display, color-conversion, image-processing, scanning, annotations, document clean-up, and much more.

Loading Capabilities±

The LEADTOOLS PDF plug-in ± has the following import capabilities:

Loads PDF 1.4 files. ±

Loads PostScript Language Level 3 files. ±

Loads EPS files. ±

Load the entire document or a specified set of sequential pages. ±

Rasterization Capabilities±

Control pixel depth - Valid values are 1,4,8 and 24.±

Control horizontal resolution in dots per inch. ±

Control vertical resolution in dots per inch. ±

Use fonts installed by the plug-in or system fonts. ±

Font anti-aliasing - Valid values are 1-bit(no anti-aliasing) , 2-bit and 4-bit. ±

Graphics anti-aliasing - 1-bit , 2-bit and 4-bit. ±

Saving Capabilities

Full multi-page write support is provided by this module for the PDF format. You can append, insert, replace or delete a specified page in the generated PDF file.

The plug-in gives you a wide range of control options for the resulting image data in terms of compression. These include:

No compression, where the image is embedded inside the file without any compression.

Compressed using CCITT Group 3, 1 dimension. For 1-bit images.

Compressed using CCITT Group 3, 2 dimensions. For 1-bit images.

Compressed using CCITT Group 4. For 1-bit images.

JPEG compression and YUV 4:4:4 color space loss-less. Bits per pixel: 8 for grayscale, 24 for color.

JPEG compression and YUV 4:2:2 color space. Bits per pixel: 8 for grayscale, 24 for color.

JPEG compression and YUV 4:1:1 color space. Bits per pixel: 8 for grayscale, 24 for color.

JBIG2 compression. Bits per pixel: 1.

The plug-in also gives you control over the type of encoding to be used in order to change compressed image data into a text encoded format. The text encoding techniques include:

No text encoding at all.

Use ASCII 85 text encoding algorithm.

Use ASCII HEX text encoding technique.

Encryption/Decryption

RC4 40-bit key encryption.

RC4 128-bit key encryption.

Support for User password, Owner password permissions.

± Some functionality is only included in the Read/Write version.

The LEADTOOLS PDF features are available in the following products:

LEADTOOLS PDF Plug-in (Read)

LEADTOOLS PDF Plug-in (Write)

Advanced PDF Compressor Plug-in

LEADTOOLS_PDF_OCR_Plug_in

Support for the PDF features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


Printing

The LEADTOOLS products support three categories of printing: basic printing, available in all toolkits; ePrint printing, available only in the ePrint products; and vector printing, available in the Vector Imaging Pro toolkit. These categories are described in further detail in the following sections.

Basic Printing

LEADTOOLS can perform all image processing necessary to print directly to any Windows supported printer. You have complete control over the position of the image and the size of the printed image.

LEADTOOLS can preprocess the image for you, so it matches the output device, or you can manually preprocess the data before printing, or you can send the data as is so the printer driver processes the data. Some preprocessing functions include to ability to halftone an image (using any angle you specify for the halftone screen) to prepare images for back and white printing. Additionally, you can reduce the colors in an image to use an optimized palette, LEAD palette or a user defined palette.

With LEADTOOLS, you can easily print text using Windows GDI and print multiple images on the same page. Additionally, you can save coding time because you can use the same code to display images to the monitor or printer.

The LEADTOOLS Basic Printing features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Raster Imaging Pro for .NET

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Basic Printing features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

ePrinting

LEADTOOLS ePrint offers you greater flexibility in existing applications that support printing and in the use of physical printers. LEADTOOLS also offers an ePrint SDK, which provides support for customizing the LEADTOOLS ePrint driver by allowing you to create a Windows application or customize the ePrint UI. The application you create can incorporate LEAD or JPEG image compression, which can reduce image files to a size that is only 0.5% of their original size. The application you create can use the LEADTOOLS ePrint driver to:

Redirect a print command to save material as one or more image files

Redirect a print command to send an email to one or more addresses (with or without copies) and include material as one or more image files attached to the email.

Redirect a print command to one or more printers or other devices

The LEADTOOLS ePrint Printing features are available in the following products:

LEADTOOLS ePrint

Support for the Basic Printing features is provided for the following programming interfaces:

API

COM

Vector Printing

LEADTOOLS support for Vector printing features functionality to scale the vector drawing to any resolution desired without distorting the original image ensures that fine details of the drawing will not be lost during printing.

The LEADTOOLS Vector Printing features are available in the following products:

LEADTOOLS Vector Imaging Pro

Support for the Vector printing features is provided for the following programming interfaces:

ActiveX

API

Class Library


Scanning / Screen Capturing

The LEADTOOLS products have many ways to manage image acquisition and control scanners, digital cameras and capture cards with TWAIN and ISIS* drivers. The following sections on Capturing, Capture Utilities, TWAIN Scanning, and ISIS Scanning describe these capabilities in further detail.

Capturing

The LEADTOOLS Screen Capturing features provide support for capturing all or part of the screen. The result can then be used with any of the LEADTOOLS image processing functions and can be saved in any of the more than 70 file formats that LEAD supports.

With the LEADTOOLS Capture feature you can capture the:

Entire screen

Active window

Menu under cursor

Window under cursor (button, tool bar, icon, or client area)

Selected object

Mouse cursor or wallpaper

LEADTOOLS also allows for capture of a selected area of the screen in a wide array of shapes such as:

Rectangle

Rounded rectangle

Ellipse

Polygon or freehand

Icon

Bitmap and cursor resources can be captured from 16 or 32-bit Windows EXE and DLL files. Options include:

Multi-capture with callback

Hot Keys

Time interval

The LEADTOOLS Capturing features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Capturing features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

VCL

Capture Utilities

The LEADTOOLS Capturing utilities are available in the following end user products:

LEADTOOLS ePrint

LEADViEW

LEAD Technologies, Inc. offers two Screen Capture utilities that are included as part of the LEADTOOLS ePrint Driver: a stand-alone application, and a toolbar that can be loaded as a toolbar that appears in the Windows taskbar. Both utilities allow you to capture the entire screen, an active window, a selected menu, a menu under the cursor, a selected window object (button, tool bar, icon, or client area), a selected area (rectangle, ellipse, triangle, polygon or freehand), the wallpaper, the mouse pointer, or resources stored in EXE's and DLL's. Options include multi-capture, Hot Keys, and time interval.

These utilities can be used to:

Capture images of products to display on the web.

Capture images to include in product documentation or training.

Capture images of issues to send to support personnel to resolve problems more quickly.

LEADViEW is an easy to use yet powerful and full-featured image editor. With LEADViEW, you can create, modify, enhance and retouch images. Use LEADViEW to:

Import/capture images from scanners, digital cameras and screen.

Save or convert images to any of over 60 image formats.

Process images for color correction and enhancement using a wide variety of filters and effects.

Edit or retouch images with powerful painting and drawing tools.

Print and composite images using an interactive visual print layout system.

Generate image-maps for use in web pages, using a visual image-map editor.

TWAIN Scanning

The LEADTOOLS TWAIN Scanning features provide support for image acquisition through industry standard interfaces from a wide variety of hardware devices. With LEADTOOLS you can control any scanner, digital camera or capture card that has a TWAIN device driver. High-level acquisition support is provided for ease of use, and low-level functionality is provided for flexibility and control in even the most demanding applications.

Using LEADTOOLS TWAIN capabilities, your application can:

Use the default user interface included with the TWAIN driver.

Create your own user interface.

Bypass the interface entirely for completely automated tasks or batch scanning.

Control the type of image that is acquired (black & white, b/w with halftone, grayscale, color - as supported by the device).

Control the resolution (dpi), position, size, and orientation of the image to be acquired.

Use the Automated Document Feeder for single and multi-page scans, including support for duplex scanning.

Use supplied events and callbacks to code your own special per-page processing

Use selection dialogs to allow selection of TWAIN source, or select among multiple TWAIN sources in code.

Use native, buffered memory or file transfer modes when acquiring from a TWAIN device.

Get and set all TWAIN v1.9 capabilities that the device's TWAIN driver supports.

Save the device's TWAIN capability settings to a template file, helping to save multiple settings of sources and load them as needed.

Use buffered memory transfer mode, including compression. Compress the scan data using JPEG, RLE, BITFIELDS, GROUP 3, GROUP 4 or PACKBITS compression to reduce the data transfer bottle neck.

Save the Memory Buffered Transfer data directly to a file.

Get the Extended Image Info that some TWAIN scanner drivers support. For example, if the scanner driver supports reading barcodes or patch codes, then that information could be retrieved via LEADTOOLS TWAIN support.

With LEADTOOLS TWAIN support you can do anything that your TWAIN v1.9 driver supports. If your TWAIN driver is not v1.9 or does not support a functionality listed above, then LEADTOOLS will support all of the features that the driver has that are compatible with the TWAIN v1.9 specification.

LEADTOOLS TWAIN support gives your applications access to the wide variety of devices which can acquire images via TWAIN from manufacturers like Kodak, Hewlett Packard, Microtek, Logitech, Fuji and many more.

(Document/Medical only) LEADTOOLS also supports Fast Twain scanning, which allows you to optimize your scanning by changing the scan configuration. Please note that this capability is only available in the Document/Medical toolkits and it is only provided for the API and COM programming interfaces.

The LEADTOOLS TWAIN Scanning features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Raster Imaging Pro for .NET

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the TWAIN Scanning features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL

ISIS Scanning

(Document/Medical only) The LEADTOOLS ISIS Scanning features provide support for using the driver's built-in dialog box to control image acquisition or by-passing it and create a custom interface. The LEADTOOLS ISIS support functions offer control over image size, position, brightness, contrast, resolution, orientation, gamma and compression. Developers can request compressed data from the ISIS driver, for faster image acquisition. LEADTOOLS supports single page acquire to memory, multi-page acquire to multi-page file, and multi-page acquire to multiple single page files. With LEADTOOLS, your application can acquire images from ISIS compliant scanners from manufacturers like Ricoh, Hewlett Packard, Bell&Howell, and others. You can use images acquired as document (halftone), grayscale or color for use in check & form processing applications, stock photo collections, WebPages and more.

ISIS support is only available in the Document/Medical versions. LEAD does not grant any license to the ISIS driver, or to ISIS development capabilities. It is your responsibility to obtain the appropriate license to cover your development project, either from Pixel Translations, or one of their licensees.

The LEADTOOLS ISIS Scanning features are available in the following products:

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the ISIS Scanning features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

VCL


Special Effects: Display & Drawing

LEADTOOLS provides special effects for developing multimedia projects or presentation applications. You can use many paint effects, dissolves, and transitions. Effect options allow you to choose from over 2000 paint effects, 36 gradients, 80 shapes, 12 3-D text styles, 64 dissolves and 43 transition effects with delays, grain sizes, pattern brushes and a colored wand, all with control over the speed and granularity of each effect. You can also draw plain or three-dimensional text and graphic shapes on the screen or on the bitmap.

With the LEADTOOLS special effects you can develop visually stimulating multimedia projects, presentation applications, or enhance websites.

Specifically, you can do the following:

Specify an effect that is applied when painting the image from a bitmap.

Specify a transition between images, which is an effect that paints a pattern or gradient color (instead of the image from a bitmap).

Control the speed, granularity, multiple paint passes, transparent color, and wand usage when painting images or transitions.

Specify a transparent color and paint a control with a transparent background.

When drawing shapes or text objects on the screen or on the bitmap, you can do the following:

Paint a rectangular area that contains a pattern or gradient color. This is useful for creating a bitmap that can be used as the background of a shape object or the foreground of a text object.

Draw a shape with a three-dimensional appearance. The shape can be one of 80 variations of rectangles, triangles, circles, and so forth, or it can be created from an existing Windows region.

Draw a text object with a three-dimensional appearance. The text can be rotated with precision to a tenth of a degree.

Specify a bitmap to use as the background of a shape, or as the foreground of a text object.

Draw a frame with a three-dimensional appearance. (In the ActiveX the frame is applied as a border of the control.)

Draw a simple Windows-style line, rectangle, or ellipse, with standard options for the draw-mode, pen, and fill.

The LEADTOOLS Special Effects features are available in the following products:

LEADTOOLS Raster Imaging

LEADTOOLS Raster Imaging Pro

LEADTOOLS Document Imaging

LEADTOOLS Document Imaging Suite

LEADTOOLS Medical Imaging

LEADTOOLS Medical Imaging Suite

Support for the Special Effects features is provided for the following programming interfaces:

ActiveX

API

Class Library

COM

.NET

VCL


Vector Imaging

LEAD offers simple vector viewing capabilities in the LEADTOOLS Vector View Plug-in and more advanced capabilities in the LEADTOOLS Vector Imaging Pro toolkit. These capabilities are described in further detail in the following sections.

Vector Processing

The LEADTOOLS Vector Processing features provide support for loading, viewing, modifying and saving 2-D and 3-D vector files to memory/disk in native vector formats. By creating 2-D and 3-D viewers, editors and converters that support both vector and raster image formats, you eliminate the need to install or license the more expensive original applications AutoDesk AutoCad versions 12, 13, 14 and 2000 or other CAD/CAM/CAE or vector applications.

Vector image formats that can be loaded, saved, converted and exported to a raster format include CGM, DGN, DRW, DWF, DWG, DXF, EMF, WMF, PLT, Gerber, PCL, PCT, SVG, VWPG, CMX and SHP. Vector files can be converted to any resolution raster image and saved to any of the 120+ raster image formats and sub-formats that the LEADTOOLS Raster Imaging products support.

Support for primitive objects include Arc, Bitmap, Brush, Camera, Circle, Clone, Ellipse, Elliptical Arc, Font, Group, Layer, Line, Pen, Pie, Chord, Poly Draw, Polygon, Poly Line, Poly Bezier, Raster, Rectangle, Text, Vertex and Clipping objects. 3D images can be rotated along the 3 standard axes, and painted using different illumination models. Drawings can be attached to a window for dynamic viewing. Viewing perspectives can be changed at runtime. Optimized drawing code can use OpenGL, DirectX or GDI functions. Vector images can be scaled from 1-1000% without distorting the original image, ensuring that fine details of the drawing will not be lost during printing.

Low and high-level functions to control the view of vector drawings include zooming (both uniform or around any axis), panning, rotation (around any axis) and anti-aliasing. Vector drawings can be edited in any way desired including adding, modifying, deleting and copying objects into the clipboard or between different vector drawings.

The LEADTOOLS Vector Processing features are available in the following products:

LEADTOOLS Vector Imaging Pro

Support for the Vector Processing features is provided for the following programming interfaces:

ActiveX

API

Class Library

C++

VCL

COM

.NET