Welcome to the LEADTOOLS Feature Map Help File.

by LEAD Technologies, Inc. Version 14

The LEADTOOLS Mapping Help File is designed to provide you with:

Information about the features supported by LEADTOOLS, the DLLs, Controls, Objects, Libraries, Header Files, Packages and Classes used to support each feature.

Information on the binaries associated with the various features present in LEADTOOLS.

Information on the header files, import libraries, etc. associated with the various features present in LEADTOOLS.

Information directing you to the help file in which to find the documentation that supports each feature.

Information directing you to sample program source code that demonstrates each feature.

A link to execute sample programs that demonstrate each feature.

LEADTOOLS is available in Win32 ANSI, Win32 Unicode, and .NET managed libraries. Note that not all features are available in all libraries. This helpfile can be used to easily determine which library is right for your particular development needs.

The formats of the various LEADTOOLS libraries include:

Win32 DLLs (ANSI and Unicode)

Win32 COM Objects (ANSI and Unicode)

.NET Managed Class Libraries

Win32 C++ Class Library DLLs (ANSI and Unicode)

Win32 ActiveX Controls

Delphi/C++ Builder VCL Controls


Files and File Formats

LEADTOOLS currently supports over 120 different image formats and sub formats, and continues to expand support for new formats and new format sub-types in response to the ever changing demands of developers worldwide.

With over 15 years in the field and thousands of customers in all areas of applications development, LEAD Technologies always strives to provide the most complete support for the tremendous variety of image formats available.

Each image format has its own unique set of load/save/display options, which may encompass varying types and/or degrees of compression, a range of image information bit-depths, progressive (multi-pass) image display, the ability to maintain multi-page or multi-channel images, animations, or non-image data, just to name a few.

You can count on LEADTOOLS to have the most thorough and highest performance implementation of image format specifications, and you can depend on LEADTOOLS to offer the most flexibility and control of these options to you, the software developer.

RASTER Formats:

File formats in this list are loaded and treated as raster bitmap images in memory.

Color and Grayscale
Bitonal (Black and White)

MULTIMEDIA Formats:

File formats in this list are loaded as multimedia objects by using a LEADTOOLS Multimedia product.

VECTOR Formats:

File formats in this list are loaded and treated as vector objects in memory using LEADTOOLS Vector Imaging Pro.

RASTER Formats

Color and Grayscale

AFP (PTOCA) Format (AFP) | LEAD Wavelet (CMW) *******
BMP Formats | Macintosh Pict Format (PCT) ***
Computer Graphics Metafile (CGM) *** | Microsoft Windows Clipboard (CLP)
Corel Presentation Exchange Format (CMX) *** | MODCA PTOCA
DGN (DGN) *** | PCX Formats (PCX and DCX)
DICOM Format (DIC, DCM) **** | Adobe PhotoShop Format (PSD)
Dr. Halo (CUT) | PLT (PLT) ***
DRaWing (DRW) *** | Portable Bitmap Utilities (PBM, PPM, PNM and PGM)
Drawing Interchange Format (DXF) *** | Portable Document Format (PDF) ******
DWF Format (DWF) *** | Portable Network Graphics Format (PNG)
DWG Format (DWG) *** | Printer Command Language Format (PCL) ***
Encapsulated PostScript (EPS, PS) | Scalable Vector Graphics (SVG) ***
Environmental Systems Research Institute Format (SHP) *** | Scitex Continuous Tone Format (SCT)
Exif Formats (TIFF and JPG) | Silicon Graphics Image Format (SGI)
Flic Animation (FLC and FLI) | SUN Raster Format (RAS)
Gerber (GBR) *** | TIFF Without LZW Compression
GIF and TIFF with LZW Compression | Truevision TARGA Format (TGA)
Icons and Cursors (ICO and CUR) Windows Animated Cursor (ANI) | XPicMap (XPM)
Interchange File Formats (IFF) | X WindowDump (XWD)
JBIG Format (JBG) * | Windows Animated Cursor (ANI)
JPEG 2000 Format (JP2) ** | Windows AVI Format (AVI)
JPEG and LEAD Compressed (JPG and CMP) | Windows Metafile Formats (WMF and EMF)
Cals Format (CAL) | Wireless Bitmap (WBMP)
 | WordPerfect Format (WPG) WordPerfect Vector Format (VWPG) ***
Professional Digital Camera (DCR, DCS) | Kodak Cineon (CIN)
Flexible Image Transport System (FIT) | Enhanced Compressed Wavelet (ECW)
MPG Format | Kodak Digital Camera (KDC)
Paint Shop Pro Format (PSP) | Portable Network Graphics Format (PNG)
WinFax Format (WFX) | Internet Fax Format (TFX)
Canon RAW Format (CRW) | Wireless Bitmap (WMP)
Uncompress Raw Data (RAW) | LEADTOOLS Vector Dump Format (Vec)
LMB Format | LMA Format
Compressed Windows Metafile (WMZ) | J2K Format
DJVU Format (DJVU) | Rich Text Format (RTF)
Structured Fax Format (SFF) | MrSID Format (SID)

Mixed Raster Content

MRC (MRC) | LEAD MRC (MRC)
TIF MRC (TIF) | TIF LEAD MRC (TIF)

Bitonal (Black and White)

ABIC Format (ABIC)******** | LEAD ABC Format (ABC)**********
Image Object Content Architecture Format (IOCA/MODCA) | TIFF CCITT and Other FAX Formats
Intergraph Format (ITG) | Miscellaneous 1-Bit Formats (MAC, IMG, and MSP)
LaserView LaserData (Read Only) | SMP Format (SMP)
LEAD 1-Bit Format (CMP) | XBitMap Format (XBM)
Microsoft Fax (AWD) | JBIG2 Format (JBIG2)*********

MULTIMEDIA Formats

AVI | Mpeg1 Layer – 3 Audio (MP3)
Quicktime 2.0 | WAV
Windows Media Formats (WMA, WMV, ASF) |

VECTOR Formats ***

Computer Graphics Metafile (CGM) *** | ESRI Shape Format (SHP) ***
Corel Presentation Exchange Format (CMX) *** | Scalable Vector Graphic (SVG)****
Microstation DGN (DGN) *** | Macintosh Pict Format (PCT) ***
DRaWing (DRW) *** | Printer Command Language Format (PCL)****
Drawing Interchange Format (DXF)**** | PLT (PLT) ***
DWF Format (DWF) *** | TIFF DXF ***
DWG Format (DWG) *** | Windows Metafile Formats (WMF and EMF)****
Gerber (GBR) *** | WordPerfect Format (VWPG) ***

LEAD is constantly adding the support for new file formats, and "flavor" support to formats already supported. The extensive format support provided by LEADTOOLS will give your application the flexibility to support almost any image you encounter.

* JBIG requires a LEADTOOLS Document Imaging product.

** JPEG 2000 compression requires the purchase of the LEADTOOLS JPEG 2000 add on.

*** Requires the purchase of a LEADTOOLS Vector imaging product.

**** DICOM requires a LEADTOOLS Medical Imaging product.

***** FlashPix is included with Pro versions or better.

****** PDF support requires the purchase of the LEADTOOLS PDF Add on.

******* LEAD Wavelet compression requires the purchase of the LEADTOOLS CMW add on.

******** ABIC requires the purchase of the LEADTOOLS ABIC Plug In.

*********JBIG2 requires the purchase of the LEADTOOLS JBIG2 Plug In.

**********LEAD ABC requires the purchase of the LEADTOOLS Advanced Bitonal Compression Plug In.

Supported Platforms:

Files and File Formats – ActiveX

Files and File Formats API

Files and File Formats Class Library

Files and File Formats COM Objects

Files and File Formats VCL

Files and File Formats .NET


Files and File Formats : ActiveX

Files and File Formats – ActiveX

OCX File

Comments

Help File

Demo

LTOCX14N.OCX

The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing File Format support.

LTOCXN.HLP

\Examples\OCX\MFC40\DEMO

\Examples\OCX\VB\DEMO32

LEADSRVR.EXE

You can run the LEAD OLE server as a stand-alone WIN32 application or use it to add basic image processing capabilities to any OLE client application. For example, you can do the following:

  • Store compressed images in a Microsoft Access, and print reports that include the images.

  • Link or embed images in a Microsoft Word document, and edit the images in place, without ever leaving Word.

LTOLESVRN.HLP

LTTMB14N.OCX

The LEADTOOLS Thumbnail Browser ActiveX control contains properties, methods and events for browsing directories for supported image files, and then creating thumbnail images for each file.

LTOCXN.HLP

\Examples\OCX\MFC40\DEMO

\Examples\OCX\VB\DEMO32

File Format support also requires one or more LEAD File Format Filter DLLs.

For example, LF???14N.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Files and File Formats : API

Files and File Formats – API

DLL | LIB | Header | Comments | Help Files | Demo
LTFIL14N.DLL | LTFIL_N.LIB | LTFILN.H | Provides both low and high-level functions that can be used to load/save image files. These functions allow you to work with ‘files’ in memory buffers or at offsets within disk files. | LTDLLN.CHM | \Examples\DLL\DEMO \Examples\DLL\FEEDLOAD \Examples\DLL\INFO \Examples\DLL\LOADCB \Examples\DLL\LOADSAVE \Examples\DLL\MEMORY \Examples\DLL\MEMORYCB \Examples\DLL\OFFSET \Examples\DLL\REDIRECT \Examples\DLL\SAVECB \Examples\DLL\SAVEMEM \Examples\DLL\STAMPGET \Examples\DLL\STAMPPUT \Examples\DLL\THREAD
LF???14N.DLL | N/A | N/A | Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL. | LTDLLN.CHM | \Examples\DLL\INFO
LTTMB14N.DLL | LTTMB_N.LIB | LTTMB.H | Provides support for browsing directories for supported image files, and then creating thumbnail images for each file. | LTDLLN.CHM | \Examples\DLL\DEMO

The LEADTOOLS API provides the lowest level of File Format support.


Files and File Formats : Class Library

Files and File Formats – Class Library

Class | Header File | Comments | Help Files | Demo
LBaseFile | LTCFILE.H | The LBaseFile class is derived from LBase. This class is the base class for LEADTOOLS Class Library input/output operations. It contains basic operations for file I/O. With this class, you can override the default functions that LEADTOOLS uses for opening, closing, reading from, writing to, and seeking in files. This class forms the base for the LFile and LMemoryFile classes. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO \Examples\ClassLib\MSVC5\INFO \Examples\ClassLib\MSVC5\LOADCB \Examples\ClassLib\MSVC5\LOADSAVE \Examples\ClassLib\MSVC5\OFFSET \Examples\ClassLib\MSVC5\SAVECB \Examples\ClassLib\MSVC5\STAMPGET \Examples\ClassLib\MSVC5\STAMPPUT
LFile | LTCFILE.H | The LFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files on disk. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\INFO \Examples\ClassLib\MSVC5\LOADSAVE
LMemoryFile | LTCFILE.H | The LMemoryFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files in memory buffers, as opposed to files on disk. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\MEMORY \Examples\ClassLib\MSVC5\MEMORYCB \Examples\ClassLib\MSVC5\SAVEMEM

The LEADTOOLS Class Library provides low level support for File Formats.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.

File Format support also requires one or more LEAD File Format Filter DLLs.

For example, LF???14N.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Files and File Formats : COM

Files and File Formats – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRIO14N.DLL - ILEADRasterIO | The LEADTOOLS Raster IO object provides support for File Formats. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRTM14N.DLL – ILEADRasterThumbnail | The LEADTOOLS Raster Thumbnail object provides support for browsing directories for supported image files, and then creating thumbnail images for each file. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32

File Format support also requires one or more LEAD File Format Filter DLLs.

For example, LF???13S.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Files and File Formats : VCL

Files and File Formats – VCL

File Format Feature | Compiler | Package | Help Files | Demo
File Format Support | Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Thumbnail Browser Support | Delphi 7 | LT14D7AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | Delphi 9 | LT14D9AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 5 | LT14B5AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 6 | LT14B6AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing File Format support.

The LEADTOOLS Thumbnail Browser control contains properties, methods and events for browsing directories for supported image files, and then creating thumbnail images for each file.

File Format support also requires one or more LEAD File Format Filter DLLs.

For example, LF???14N.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Files and File Formats : .NET

Files and File Formats – .NET

Assembly – Class/Namespace

Comments

Help Files

Demo

Leadtools.Codecs.DLL – Leadtools.Codecs

The Leadtools.Codecs namespaces contains classes with properties, methods and events for loading and saving any type of image file and for getting information about loaded bitmaps

Support includes palettes, memory files, multipage files, compressed files, comments, tags, animations, view perspectives, raw image data, compressed data, alpha channel.

LTNET.CHM

\Examples\CS\MainDemo

\Examples\VB\MainDemo

\Examples\CS\FeedLoadDemo

\Examples\VB\FeedLoadDemo

The Leadtools.Codecs namespace provides support for File Formats.

File Format support also requires one or more LEAD File Format Filter DLLs.

For example, Leadtools.Codecs.Bmp.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Image Compression

LEADTOOLS offers more compression options than any other toolkit on the market. LEADTOOLS supports industry standard and proprietary alternative compression algorithms including:

JPEG2000 | JPEG
LEAD CMP | LZW
RLE / PackBits | ZIPLIB
CCITT G3/G4 | Huffman
Arithmetic | JBIG
ABIC | JBIG2
LEAD ABC |

Supported Platforms

Image Compression ActiveX

Image Compression API

Image Compression – Class Library

Image Compression COM

Image Compression VCL

Image Compression .NET


Image Compression : ActiveX

Image Compression – ActiveX

OCX File

Comments

Help File

Demo

LTOCX14N.OCX

The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Image Compression support.

LTOCXN.HLP

\Examples\OCX\MFC40\DEMO

\Examples\OCX\VB\DEMO32

LEADSRVR.EXE

You can run the LEAD OLE server as a stand-alone WIN32 application or use it to add basic image processing capabilities to any OLE client application. For example, you can do the following:

  • Store compressed images in a Microsoft Access, and print reports that include the images.

  • Link or embed images in a Microsoft Word document, and edit the images in place, without ever leaving Word.

LTOLESVRN.HLP

Image Compression support also requires one or more LEAD File Format Filter DLLs.

For example, LF???14N.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Image Compression : API

Image Compression – API

DLL | LIB | Header | Comments | Help Files | Demo
LTFIL14N.DLL | LTFIL_N.LIB | LTFIL.H | Provides both low and high-level functions that can be used to load/save image files. These functions allow you to work with ‘files’ in memory buffers or at offsets within disk files. | LTDLLN.CHM | \Examples\DLL\COMPCB \Examples\DLL\DEMO \Examples\DLL\J2KDEMO
LF???14N.DLL | N/A | N/A | Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL. | LTDLLN.CHM |

The LEADTOOLS API provides the lowest level of Image Compression support.


Image Compression : Class Library

Image Compression – Class Library

Class | Header File | Comments | Help Files | Demo
LBaseFile | LTCFILE.H | The LBaseFile class is derived from LBase. This class is the base class for LEADTOOLS Class Library input/output operations. It contains basic operations for file I/O. With this class, you can override the default functions that LEADTOOLS uses for opening, closing, reading from, writing to, and seeking in files. This class forms the base for the LFile and LMemoryFile classes. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\COMPCB \Examples\ClassLib\MSVC5\DEMO
LFile | LTCFILE.H | The LFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files on disk. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\COMPCB \Examples\ClassLib\MSVC5\DEMO
LMemoryFile | LTCFILE.H | The LMemoryFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files in memory buffers, as opposed to files on disk. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\COMPCB \Examples\ClassLib\MSVC5\DEMO

The LEADTOOLS Class Library provides low level support for Image Compression.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.

Image Compression support also requires one or more LEAD File Format Filter DLLs.

For example, LF???14N.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Image Compression : COM

Image Compression – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRIO14N.DLL - ILEADRasterIO | The LEADTOOLS Raster IO object provides support for File Formats. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32 \Examples\COM\VB\J2K32

Image Compression support also requires one or more LEAD File Format Filter DLLs.

For example, LF???13S.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Image Compression : VCL

Image Compression – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing Image Compression support.

Image Compression support also requires one or more LEAD File Format Filter DLLs.

For example, LF???14N.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Image Compression : .NET

Image Compression – .NET

Assembly – Class/Namespace

Comments

Help Files

Demo

Leadtools.Codecs.DLL – Leadtools.Codecs

The Leadtools.Codecs namespaces contains classes with properties, methods and events for loading and saving any type of image file and for getting information about loaded bitmaps

Support includes palettes, memory files, multipage files, compressed files, comments, tags, animations, view perspectives, raw image data, compressed data, alpha channel.

LTNET.CHM

\Examples\CS\MainDemo

\Examples\VB\MainDemo

The Leadtools.Codecs namespace provides support for Image Compression.

Image Compression support also requires one or more LEAD File Format Filter DLLs.

For example, Leadtools.Codecs.Bmp.DLL.

Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL.


Image Display

Take control of your application's image display. With LEADTOOLS, you control brightness and contrast settings, color reduction with dithering and palette control, zooming/scaling/fitting, panning, scrolling, painting with transparency and/or regions. Additionally, LEADTOOLS provides image-list and thumbnail browser controls, a special magnifying-glass feature, as well as an automated pan-window control.

LEADTOOLS renders an image of any color depth (1 to 64 bit**) to any display device, automatically handling any color reduction or expansion. Use nearest neighbor (fastest), bilinear (fast-good quality) or bicubic (best quality) resampling for zoomed display of images. Images can be automatically dithered to match the output display device on the fly, without changing the image in memory. Intensity, contrast and gamma correction changes can be applied to the display without affecting the original data. (AdditionalIy, the color reduction and display settings can be rendered into the image if desired, see Image Processing) Images can be scaled, zoomed, or scrolled when displayed. You can render images with a color specified as transparent.

You can position the displayed image, and zoom in or out by scaling and clipping the display. The rotated display* feature allows rendering images rotated in 90-degree increments without changing the image in memory. Large 1-bit images can remain compressed in memory while decompressing only the portion needed for display*. On a 256-color device, you can use a fixed palette option to eliminate palette shifting when displaying more than one image at a time. An automated pan window is provided to enable navigation on a large image using a small thumbnail view. LEADTOOLS also lets you display and manipulate a list of images as an array of thumbnails using the ImageList Control. In addition, LEADTOOLS provides a Thumbnail Browser for browsing entire directories of image files.

When working with the ActiveX, COM, .NET or VCL controls, you can set properties which determine the way that images are displayed in the control, such as AutoScroll (automated scroll bars), AutoSize (snap control to image), PaintSizeMode (1:1 scale, fit image to control, zoomed at specified magnification factors etc.)

When painting images on any video device, you can do the following:

  • Control the brightness, contrast, and gamma correction when painting (without affecting the bitmap).

  • Define the client area of a LEAD control as a display surface where you can use Windows graphics device interface (GDI) functions for drawing or adding text. (You can also get a display surface derived from the actual image stored in memory in order to use Windows GDI to draw permanently into the image - see Image Processing: Drawing).

  • Display an automated rubberband (rectangle, elipse or freehand) to mark an area and create a region of interest.

  • Paint an image only in a selected region of interest, or paint an image with transparency (any pixels which are the selected transparent color are not painted).

  • Zoom in on a selected area. Use with automated rubberbanding for entirely automated behavior, or specify selected area in code.

  • Selectively force repainting of the image in a LEAD control to avoid unecessary repaints, or use AutoRepainting to automate all display updates.

  • Scale and position the image - specify source rectangle (portion of source image to paint) and destination rectangle (position on screen or drawing surface on which to paint it) for complete control over image zoom and position, or specify higher level properties like ZoomFactor or PaintMode (fit-to-window preserving aspect ratio, stretch to entire window, fit-to-width, 1:1 normal display, etc.). When used with the AutoScroll option, all Scroll Bar activity is automatic (scroll bars respond to programmatic changes of display settings, and display settings are updated by user's use of scroll bars).

  • Limit the area to be painted by specifying the source and destination clipping areas (independent of source and destination rectangles which position image on screen).

  • Apply any of over 2000 special effects, such as wipes, fades, dissolves, transitions commonly used in slide presentations.

  • Apply ROP codes, which determine how to interact with the existing image on the screen.

  • Use a buffer as the source to paint. (Can be used, for example, to paint an image as it is being loaded)

  • Specify an option for fast painting (without device error checking).

  • Use Double Buffer painting to eliminate flicker when painting.

  • Load CMYK images and paint them to the device context. The data is kept in memory until the actual paint.

If the display mode is 256 colors or less, you can do the following:

  • Use the palette associated with the image (if palletized), or use a fixed palette. You can specify LEAD's fixed palette or the Netscape fixed palette. Fixed palettes allow you to display multiple images on a screen in 256 color mode without "color shifting".

  • Specify the dithering method, for images that have more bits per pixel than the current video mode. The following are possible options:

    • Normal dithering (using error diffusion).

    • Ordered dithering, which is faster but less accurate than normal.

    • No dithering, which relies on the display device for color reduction.

For displaying 1-bit (black-and-white) images, you can do the following to enhance the quality of display:

  • Specify a scale-to-gray option, which increases the clarity of the 1-bit images when they are scaled (zoomed in or zoomed out).

  • Specify a favor-black option, which prevents loss of details, such as fine lines, when an image is scaled down (zoomed out).

Supported Platforms

Image Display ActiveX

Image Display API

Image Display – Class Library

Image Display COM

Image Display VCL

Image Display .NET


Image Display : ActiveX

Image Display – ActiveX

OCX File

Comments

Help File

Demo

LTOCX14N.OCX

The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Image Display support.

LTOCXN.HLP

\Examples\OCX\MFC40\DEMO

\Examples\OCX\VB\DEMO32

\Examples\OCX\MFC40\MAGGLASS

LEADSRVR.EXE

You can run the LEAD OLE server as a stand-alone WIN32 application or use it to add basic image processing capabilities to any OLE client application. For example, you can do the following:

  • Store compressed images in a Microsoft Access, and print reports that include the images.

  • Link or embed images in a Microsoft Word document, and edit the images in place, without ever leaving Word.

LTOLESVRN.HLP

LTLST14N.OCX

The LEADTOOLS Image List ActiveX provides support for displaying image thumbnails in a ‘list view’ type of UI.

LTOCXN.HLP

\Examples\OCX\MFC40\DEMO

\Examples\OCX\VB\DEMO32


Image Display : API

Image Display – API

DLL | LIB | Header | Comments | Help Files | Demo
LTDIS14N.DLL | LTDIS_N.LIB | LTDIS.H | Provides both low and high-level functions that can be used to display images. | LTDLLN.CHM | \Examples\DLL\ANIMVIEW \Examples\DLL\DEMO \Examples\DLL\DIBDDB \Examples\DLL\MAGGLASS \Examples\DLL\OVERLAY \Examples\DLL\PAINTDC \Examples\DLL\PAINTEFF \Examples\DLL\SCRNSVR \Examples\DLL\THREAD
LTLST14N.DLL | LTLST_N.LIB | LTLST.H | Provides support for displaying image thumbnails in a ‘list view’ type of UI. | LTDLLN.CHM | \Examples\DLL\DEMO
LTWND14N.DLL | LTWND_N.LIB | LTWND.H | Provides a registered window class for high-level image display. | LTDLLN.CHM | \Examples\DLL\REGCLASS

The LEADTOOLS API provides the lowest level of Image Display support.


Image Display : Class Library

Image Display – Class Library

Class | Header File | Comments | Help Files | Demo
LDraw | LTCDRAW.H | The LDraw class is derived from LBase, and provides base functionality for the LEADTOOLS Class Library painting and drawing classes. This class contains basic functions and member variables that are used when displaying bitmap objects. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO
LPaint | LTCDRAW.H | The LPaint class is derived from LDraw, and extends it to contain the functions for painting bitmap images. These functions handle painting bitmaps as well as displaying bitmap regions. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO \Examples\ClassLib\MSVC5\DIBDDB \Examples\ClassLib\MSVC5\PAINTDC
LPaintEffect | LTCDRAW.H | The LPaintEffect class derives from LDraw, and extends it to contain functions for displaying bitmaps and bitmap regions with LEADTOOLS paint effects. For a list of the LEADTOOLS paint effects, refer to Effect Types. LPaintEffect also contains functionality for drawing gradients, patterns, 3dShapes, and 3dText. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\FXDEMO \Examples\ClassLib\MSVC5\PAINTEFF
LBitmapWindow | LTCBWND.H | The LBitmapWindow class is derived from LBitmap, and extends it by adding full user interface (UI) functionality. You can consider this class as a full windowed control that is capable of displaying bitmaps. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO
LAnimationWindow | LTCANIM.H | The LAnimationWindow class is derived from the LBitmapWindow class, and extends it by adding LEAD Animation functionality. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO
LImageListControl | ltcImLst.h | The LImageListControl class provides functionality for creating a Windows control that implements an ImageList for manipulating and displaying a list of images. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO

The LEADTOOLS Class Library provides low level support for Image Display.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Image Display : COM

Image Display – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRVW14N.OCX - ILEADRasterView | The LEADTOOLS Raster View ActiveX provides support for Image Display. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRLS14N.OCX - ILEADRasterImageList | The LEADTOOLS Raster ImageList ActiveX provides support for displaying image thumbnails in a ‘list view’ type of UI. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32


Image Display : VCL

Image Display – VCL

Image Display Feature | Compiler | Package | Help Files | Demo
Image Display Support | Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Image List Support | Delphi 7 | LT14D7AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | Delphi 9 | LT14D9AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 5 | LT14B5AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 6 | LT14B6AD.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing Image Display support.

The LEADTOOLS Image List control contains properties, methods and events for displaying image thumbnails in a ‘list view’ type of UI.


Image Display : .NET

Image Display – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.WinForms.DLL - RasterImageViewer | The RasterImageViewer class is a "PictureBox" class which provides the functionality to display images in a WinForms control. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo
Leadtools.DLL - RasterImage | The RasterImage class provides low-level properties, methods and events for displaying images. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo


Special Effects: Display and Drawing

LEADTOOLS provides special effects for developing multimedia projects or presentation applications. You can use many paint effects, dissolves, and transitions. Effect options allow you to choose from over 2000 paint effects, 36 gradients, 80 shapes, 12 3-D text styles, 64 dissolves and 43 transition effects with delays, grain sizes, pattern brushes and a colored wand, all with control over the speed and granularity of each effect. You can also draw plain or three-dimensional text and graphic shapes on the screen or on the bitmap.

Visit the LEADTOOLS Website at http://www.leadtools.com/Demos/SlideShow.htm for a demonstration of Special Effect Transitions (uses ActiveX control - IE only).

With the LEADTOOLS special effects you can develop visually stimulating multimedia projects, presentation applications, or enhance websites.

Specifically, you can do the following:

  • Specify an effect that is applied when painting the image from a bitmap.
  • Specify a transition between images, which is an effect that paints a pattern or gradient color (instead of the image from a bitmap).
  • Control the speed, granularity, multiple paint passes, transparent color, and wand usage when painting images or transitions.
  • Specify a transparent color and paint a control with a transparent background.

When drawing shapes or text objects on the screen or on the bitmap, you can do the following:

  • Paint a rectangular area that contains a pattern or gradient color. This is useful for creating a bitmap that can be used as the background of a shape object or the foreground of a text object.

  • Draw a shape with a three-dimensional appearance. The shape can be one of 80 variations of rectangles, triangles, circles, and so forth, or it can be created from an existing Windows region.

  • Draw a text object with a three-dimensional appearance. The text can be rotated with precision to a tenth of a degree.

  • Specify a bitmap to use as the background of a shape, or as the foreground of a text object.

  • Draw a frame with a three-dimensional appearance. (In the ActiveX the frame is applied as a border of the control.)

  • Draw a simple Windows-style line, rectangle, or ellipse, with standard options for the draw-mode, pen, and fill.

For more advanced Drawing effects, refer to DigitalPaint.

Supported Platforms

Special Effects: Display and Drawing - ActiveX

Special Effects: Display and Drawing - API

Special Effects: Display and Drawing – Class Library

Special Effects: Display and Drawing - COM

Special Effects: Display and Drawing - VCL


Special Effects: Display and Drawing : ActiveX

Special Effects: Display and Drawing – ActiveX

OCX File | Comments | Help File | Demo
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Special Effects functionality. | LTOCXN.HLP | \Examples\OCX\MFC40\DRAW \Examples\OCX\MFC40\FXDEMO \Examples\OCX\VB\FX32

For more advanced Drawing effects, refer to DigitalPaint.


Special Effects: Display and Drawing : API

Special Effects: Display and Drawing – API

DLL | LIB | Header | Help Files | Demo
LTEFX14N.DLL | LTEFX_N.LIB | LTEFX.H | LTDLLN.CHM | \Examples\DLL\DEMO \Examples\DLL\DRAW \Examples\DLL\MFCFX \Examples\DLL\PAINTEFF

The LEADTOOLS API provides the lowest level of Special Effects functionality.

For more advanced Drawing effects, refer to DigitalPaint.


Special Effects: Display and Drawing : Class Library

Special Effects: Display and Drawing – Class Library

Class | Header File | Comments | Help Files | Demo
LPaintEffect | LTCDRAW.H | The LPaintEffect class derives from LDraw, and extends it to contain functions for displaying bitmaps and bitmap regions with LEADTOOLS paint effects. LPaintEffect also contains functionality for drawing gradients, patterns, 3dShapes, and 3dText. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO \Examples\ClassLib\MSVC5\FXDEMO \Examples\ClassLib\MSVC5\PAINTEFF

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.

For more advanced Drawing effects, refer to DigitalPaint.


Special Effects: Display and Drawing : COM

Special Effects: Display and Drawing – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRFD14N.DLL - ILEADRasterFXD | The LEADTOOLS Raster 3D DrawEffect object provides properties, methods, and events for implementing Special Effects functionality. | LTCOMN.CHM | \Examples\COM\MSVC5\SPFXCOM \Examples\COM\VB\FX32

For more advanced Drawing effects, refer to DigitalPaint.


Special Effects: Display and Drawing : VCL

Special Effects: Display and Drawing – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing Special Effects functionality.

For more advanced Drawing effects, refer to DigitalPaint.


Image Processing

LEADTOOLS has over 200 image processing functions, some of which are typically found only in high performance end-user programs such as Adobe PhotoShop®. The image processing functions are separated into four categories: Transforms, Filters, Color Conversion and Drawing. Additionally, LEADTOOLS image processing functions support region of interest, allowing only a particular region of an image to be processed.

To change the appearance of the image in a bitmap, you can do the following:

  • Define the bitmap as a display surface where you can use Windows graphics device interface (GDI) functions for drawing or adding text.

  • Automatically straighten (deskew) a 1-bit image*. See Transforms.

  • Remove specks (despeckle) a 1-bit image*.

  • Automatically trim a bitmap to remove blank space around the edges.

  • Rotate the image. (Angles can be precise to 100th of a degree.)

  • Do fast rotation in 90-degree increments*.

  • Rotate JPEG or CMP compressed images in 90 degree increments or flip them without loss of quality.

  • Shear the image in the fashion of a parallelogram. (Angles are precise to 100th of a degree.)

  • Change the orientation by flipping the image horizontally or vertically.

Adjust colors and intensities as follows:

  • Change brightness using a flat scale.

  • Change brightness using gamma correction.

  • Change contrast using a flat scale.

  • Change contrast using a multi-scale.

  • Stretch the range of intensities.

  • Remap intensities using a lookup table.

  • Create look up tables based on points on a curve or a mathematical function.

  • Invert colors.

  • Change hue of the entire image or just a range of colors.

  • Change saturation.

  • Histogram equalize and histogram contrast.

  • Fill with a specified color.

  • Get and put colors of individual pixels.

  • Color balancing.

  • Load CMYK TIFF files and keep the data in memory as CMYK.

Apply the following kinds of conversions:

  • Halftone for display or printing.

  • Sharpen or blur.

  • Posterize, specifying the number of color planes.

  • Mosaic, specifying the tile size.

  • Emboss, specifying the lighting direction.

  • Soften an image using an average filter.

  • Reduce noise using a median or Gaussian filter.

  • Add noise in any or all color planes.

  • Picturize with a list of images or a single image.

Apply filters to do the following:

  • Detect ranges of intensity.

  • Detect ranges of colors using different color spaces.

  • Detect edges using gradient or Laplacian edge detection.

  • Detect lines using Sobel, Prewitt, shift and difference, or line segment detection.

  • Apply morphological (binary) filters to erode or dilate black objects*.

  • Implement your own spatial filters.

  • Combine images using boolean and arithmetic operators, and color masking. (This is useful for combining filtered images with originals.)

  • Combine two images so that one appears to be an underlying texture of the other.

  • Combine multiple images to create a new image that resembles the current image.

  • Combine a list of images to find the average difference between the images.

  • Redeye removal.

  • Anti-alias the image.*

  • Apply a sepia or "old photo" look to the image.

  • Apply an oil-painting effect.

  • Apply a solarization effect.

  • Apply Fourier Transforms to images.

  • Apply 3D effects: Tunnel, plane, plane bend, etc.

  • Apply many other effects including: Swirl, Ripple, Radial Blur, Impressionist, Wave, Shear, Remove Redeye, Cubism, Glow, Age, etc.

Use new medical imaging processing functions to perform the following:

  • Create Kaufmann regions. The created regions can be used to determine the Kaufmann ratio, which is the size of the corpus callosum divided by the size of the brain sphere.
  • Extract the individual slices from a radiographic scanned film.

Apply image optimization to certain file types to:

  • an image buffer in memory
  • an entire directory of images, saving the optimized images to another directory

The following formats can be optimized using the Image Optimizer DLL functions:

  • JPEG File (FILE_JPEG).

  • JPEG 411 File (FILE_JPEG_411).

  • JPEG 422 File (FILE_JPEG_422).

  • EXIF JPEG 4:1:1 File (FILE_EXIF_JPEG_411).

  • EXIF JPEG 4:2:2 File (FILE_EXIF_JPEG_422).

  • GIF File (FILE_GIF).

  • PNG File (FILE_PNG).

  • BMP Without RLE Compression File (FILE_BMP).

  • BMP With RLE Compression File (FILE_BMP_RLE).

Use low-level functions to change parts of an image as follows:

  • Get and put rows of image data.

  • Get and put parts of rows.

  • Get and put the colors of individual pixels.

  • Process a region within a bitmap.

Supported Platforms

Image Processing ActiveX

Image Processing API

Image Processing Class Library

Image Processing COM Objects

Image Processing VCL

Image Processing .NET


Image Processing : ActiveX

Image Processing – ActiveX

OCX File

Comments

Help File

Demo

LTOCX14N.OCX

The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Image Processing support.

LTOCXN.HLP

\Examples\OCX\MFC40\DEMO

\Examples\OCX\VB\DEMO32

\Examples\OCX\MFC40\WARP

LEADSRVR.EXE

You can run the LEAD OLE server as a stand-alone WIN32 application or use it to add basic image processing capabilities to any OLE client application. For example, you can do the following:

  • Store compressed images in a Microsoft Access, and print reports that include the images.

  • Link or embed images in a Microsoft Word document, and edit the images in place, without ever leaving Word.

LTOLESVRN.HLP


Image Processing : API

Image Processing – API

DLL | LIB | Header | Comments | Help Files | Demo
LTIMG14N.DLL | LTIMG_N.LIB | LTIMG.H | Provides both low and high-level functions that can be used to perform image processing. | LTDLLN.CHM | \Examples\DLL\DEMO \Examples\DLL\IMGPF \Examples\DLL\RESIZE
LTDIS14N.DLL | LTDIS_N.LIB | LTDIS.H | Provides support for regions within bitmaps. | LTDLLN.CHM | \Examples\DLL\DRAW \Examples\DLL\DEMO \Examples\DLL\FLOATER \Examples\DLL\GETROW
LTIMGOPT14N.DLL | LTIMGOPT_N.LIB | LTIMGOPT.H | Provides support for image optimization. | LTDLLN.CHM |

The LEADTOOLS API provides the lowest level of Image Processing support.


Image Processing : Class Library

Image Processing – Class Library

Class | Header File | Comments | Help Files | Demo
LBitmap | LTCBTMAP.H | The LBitmap class is derived from LBitmapBase, and extends it by adding functionality for more advanced image processing. This functionality includes: Halftone, Sharpen, Picturize, GammaCorrect, Deskew, Despeckle, WindowLevel, Color Separation and Color Merge, Image Filters (such as Average, Median, Mosaic), and color processing (such as Invert, Hue, Contrast, Intensity, and Saturation). | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO \Examples\ClassLib\MSVC5\IMGPF \Examples\ClassLib\MSVC5\PICTRIZE \Examples\ClassLib\MSVC5\RESIZE
LOptimize | LTIMGOPT.H | The LOptimize class is derived from the LBase class, and provides functionality for optimizing certain image file formats, by saving images using the optimal bits per pixel based on specific optimization options. Functions are provided to optimize an image buffer in memory and to optimize an entire directory of images and save the optimized images to another directory. | LTCLIBN.CHM |

The LEADTOOLS Class Library provides low level support for Image Display.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Image Processing : COM

Image Processing – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRPR14N.DLL - ILEADRasterProcess | The LEADTOOLS Raster Process object provides support for Image Processing. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32 \Examples\COM\MSVC5\IMGPF \Examples\COM\VB\FLOTER32
LTROP.DLL - ILEADRasterImgOpt | The LEADTOOLS Raster Image Optimizer object provides support for optimizing the images of certain formats either in the memory buffer or as a directory operation. | LTCOMN.CHM |


Image Processing : VCL

Image Processing – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing Image Processing support.


Image Processing : .NET

Image Processing – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools. ImageProcessing.Effects.DLL – Leadtools.ImageProcessing.Effects | The Leadtools.ImageProcessing.Effects namespace includes filters and transforms to process images (or selected portions). It includes methods to: Smooth, sharpen, edge detect/enhance, change hue and saturation, add noise, combine two or more bitmaps. It also includes filters for applying effects such as Ripple, Warp, Glow, Blur, etc. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo \Examples\CS\ImageProcessingDemo \Examples\VB\ImageProcessingDemo
Leadtools. ImageProcessing.Color.DLL – Leadtools.ImageProcessing.Color | The Leadtools.ImageProcessing.Color namespace includes more filters and transforms to process images (or selected portions). It includes methods for color transforms such as Brightness, Contrast, Hue, Saturation, Intensity, etc. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo \Examples\CS\ImageProcessingDemo \Examples\VB\ImageProcessingDemo
Leadtools. ImageOptimization.DLL – Leadtools.ImageOptimization | The Leadtools.ImageOptimization namespace provides support for optimizing the images of certain formats either in the memory buffer or as a directory operation. | LTNET.CHM |


Color Conversion

LEADTOOLS includes functions with many options that give you the flexibility to make your images look as good as possible. Whether you are working with

medical images

scanned documents

or

digital photographs

LEADTOOLS can help you provide the correct color depth for the hardware your clients are using. And whether you are developing software applications or manufacturing hardware, LEADTOOLS can help you create your own ICC profiles. To start, LEADTOOLS can convert images from any color resolution to any other color resolution, from 1-bit to 64-bit, with multiple dithering methods using various palette options. You can choose to expose in your application 8 different dithering methods including Floyd Stein, Burkes, Ordered dithering, Stucki, Stephens, Sierra and Jarvis.

Flexible palette options include LEAD's fixed palette, an auto-optimized palette, or a user defined palette. Palettes can be applied to a single image or an entire list of images. Images can be converted, separated to and reconstructed from individual RGB, CMYK, CMY, HSV, HSL, YUV*, YIQ*, CIELAB*, XYZ*, YCCK*, Y41P*, UYVY*, YUY2*, YVU9* and YCC* color planes using LEAD's built in conversion functions, ICC color profiles* or Emulation Tables*.

When working with 12 and 16 bit grayscale images, LEADTOOLS' window leveling allows you to select the desired range of bits to be used for display or processing. * These advanced Color Conversion features are only available in the LEADTOOLS Color Conversion API.

Supported Platforms

Color Conversion ActiveX

Color Conversion API

Color Conversion Class Library

Color Conversion COM

Color Conversion VCL

Color Conversion .NET


Color Conversion : ActiveX

Color Conversion – ActiveX

OCX File | Comments | Help File | Demo
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Color Conversion. | LTOCXN.HLP | \Examples\OCX\MFC40\DEMO \Examples\OCX\VB\DEMO32


Color Conversion : API

Color Conversion – API

DLL | LIB | Header | Comments | Help Files | Demo
LTKRN14N.DLL | LTKRN_N.LIB | LTKRN.H | Basic and Advanced Color Conversion functions including L_ColorResBitmap, L_GrayScaleBitmap, etc. | LTDLLN.CHM | \Examples\DLL\DEMO
LTIMG14N.DLL | LTIMG_N.LIB | LTIMG.H | Basic and Advanced Color Conversion functions including L_ColorSeparateBitmap | LTDLLN.CHM | \Examples\DLL\DEMO
LTCLR14N.DLL | LTCLR_N.LIB | LTCLR.H | The Advanced Color Conversion API, contains support for extra color planes, ICC color profiles, and emulation tables. | LTCLRDLLN.CHM | \Examples\DLL\CLRSPACE


Color Conversion : Class Library

Color Conversion – Class Library

Class | Header File | Comments | Help Files | Demo
LBitmapBase | LTCBBASE.H | The LBitmapBase class is the main bitmap class. This class contains the main functionality for dealing with bitmaps in memory. It includes functions for basic image transforms such as resizing, flipping, cropping, and rotating, and for changing the bitmaps’ color-depth. This class also includes functions for loading images from files and saving images to files. You can use this class to create bitmaps from scratch and deal with individual rows or pixels of the image data. | LTCLIBN.CHM | \Examples\ClassLIb\MSVC5\DEMO
LBitmap | LTCBTMAP.H | The LBitmap class is derived from LBitmapBase, and extends it by adding functionality for more advanced image processing. This functionality includes: Halftone, Sharpen, Picturize, GammaCorrect, Deskew, Despeckle, WindowLevel, Color Separation and Color Merge, Image Filters (such as Average, Median, Mosaic), and color processing (such as Invert, Hue, Contrast, Inensity, and Saturation). | LTCLIBN.CHM | \Examples\ClassLIb\MSVC5\DEMO
LBuffer | LTCBUFFR.H | The LBuffer class is derived from the LBase class. This class contains support for dealing with buffers of image data, as opposed to entire bitmaps. LBuffer provides functionality for compressing and decompressing image data, resizing image data, converting image data to and from various color orders, and converting buffers of image data to and from various color spaces. LBuffer also encapsulates functions for allocating and freeing memory buffers to be used by the various image data processing functions. | LTCLIBN.CHM | \Examples\ClassLIb\MSVC5\CLRSPACE

For more advanced Color Conversion functionality including:

YUV*, YIQ*, CIELAB*, XYZ*, YCCK*, Y41P*, UYVY*, YUY2*, YVU9* and YCC* color planes using LEAD's built in conversion functions, ICC color profiles* or Emulation Tables*, refer to the LEADTOOLS Color Conversion API.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL.


Color Conversion : COM

Color Conversion – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRPR14N.DLL - ILEADRasterProcess | The LEADTOOLS Raster Process object contains properties, methods and events for implementing Color Conversion. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32

For more advanced Color Conversion functionality including:

YUV*, YIQ*, CIELAB*, XYZ*, YCCK*, Y41P*, UYVY*, YUY2*, YVU9* and YCC* color planes using LEAD's built in conversion functions, ICC color profiles* or Emulation Tables*, refer to the LEADTOOLS Color Conversion API.


Color Conversion : VCL

Color Conversion – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing Color Conversion.

For more advanced Color Conversion functionality including:

YUV*, YIQ*, CIELAB*, XYZ*, YCCK*, Y41P*, UYVY*, YUY2*, YVU9* and YCC* color planes using LEAD's built in conversion functions, ICC color profiles* or Emulation Tables*, refer to the LEADTOOLS Color Conversion API.


Color Conversion : .NET

Color Conversion – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.ColorConversion.DLL - Leadtools.ColorConversion | The Leadtools.ColorConversion namespace includes more than 70 digital filters and transforms to process images (or selected portions). It includes methods for basic image transforms such as resizing, flipping, cropping, and rotating, and for changing the bitmaps’ color-depth. This class also includes methods to: Smooth, sharpen, edge detect/enhance, change hue and saturation, add noise, combine two or more bitmaps, and to copy whole or partial bitmaps from one object to another. It also includes methods for creating and manipulating ICC Profiles. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo

For more advanced Color Conversion functionality including:

YUV*, YIQ*, CIELAB*, XYZ*, YCCK*, Y41P*, UYVY*, YUY2*, YVU9* and YCC* color planes using LEAD's built in conversion functions, ICC color profiles* or Emulation Tables*, refer to the LEADTOOLS Color Conversion API.


Imaging Common Dialogs

LEADTOOLS Imaging Common Dialog boxes greatly simplify development and save hours of tedious programming by extending Windows common dialogs to provide imaging specific capabilities. The Common Dialog boxes provide professional common imaging dialogs such as image processing, conversion and effects. Before and after thumbnail previewing of image saves processing time and avoids un-dos.

The LEADTOOLS Imaging Common Dialog libraries provide a set of common dialog boxes that combine Windows Common Dialog functionality with LEADTOOLS imaging functionality. Common Dialogs are provided for FileOpen, FileSave, Color Resolution, Image Processing/Filtering, and Effects. You can specify your own String and/or Text, as well as handle Language Customization – This is a great feature for localizing your software for International users.

The LEADTOOLS Imaging Common Dialogs also provide input dialog boxes for all of the LEADTOOLS image processing functions. These dialogs allow you to quickly and easily enable your application to gather input from end-users for the parameters required by the various LEADTOOLS functions. These dialogs can also be used to automatically process the image based on end-user input (thus reducing the amount of code you have to write).

The dialog functions feature:

  • Extended FileOpen and FileSave dialogs with LEADTOOLS imaging specific options.

  • Thumbnail Preview option allows the user to preview images without loading them.

  • Reusable dialogs for the most common LEADTOOLS image processing functions and effects.

  • Thumbnail Preview for image processing dialogs allows the user to preview the change without actually affecting the original image with an optional before† and after thumbnail.

  • The thumbnail preview can be zoomed and scrolled to any part of the image to see the details.

  • A progress bar that indicates the status of applying the effect is available.

  • An optional Help Button lets you provide custom help information for each dialog.

  • User Interface control for the dialogs is provided through flags passed to each dialog function or method allowing the text in the dilaogs to be changed or localized.

  • Optional automatic processing of the image by the dialog to simplify development.

  • Color selection dialogs that support a number of color spaces with the ability to convert between them.

Supported Platforms

Imaging Common Dialogs – API

Imaging Common Dialogs – Class Library


Imaging Common Dialogs : API

Imaging Common Dialog – API

DLL | LIB | Header | Comments | Help Files | Demo
 |  | LTDLG.H | Provides both low and high-level functions that can be used to display Imaging Common Dialogs. | LTDLLN.CHM | \Examples\DLL\DEMO
LTDlgKrn14N.DLL | LTDlgKrn_N.LIB |  | The Common Dialog Kernel COM Object |  | \Examples\DLL\DEMO
LTDlgClr14N.DLL | LTDlgClr_N.LIB |  | Color Image Processing Dialog COM Object |  | \Examples\DLL\DEMO
LTDlgEfx14N.DLL | LTDlgEfx_N.LIB |  | Display Effects Dialog COM Object |  | \Examples\DLL\DEMO
LTDlgFile14N.DLL | LTDlgFile_N.LIB |  | File Open/Save Dialog COM Object |  | \Examples\DLL\DEMO
LTDlgImg14N.DLL | LTDlgImg_N.LIB |  | Image Processing Dialog COM Object |  | \Examples\DLL\DEMO
LTDlgImgDoc14N.DLL | LTDlgImgDoc_N.LIB |  | Document Image Processing Dialog COM Object |  | \Examples\DLL\DEMO
LTDlgImgEfx14N.DLL | LTDlgImgEfx_N.LIB |  | Image Effects Dialog COM Object |  | \Examples\DLL\DEMO
LTDlgWeb14N.DLL | LTDlgWeb_N.LIB |  | Web Tuner Dialog COM Object |  | \Examples\DLL\DEMO

The LEADTOOLS API provides the lowest level of Imaging Common Dialog support.


Imaging Common Dialogs : Class Library

Imaging Common Dialogs – Class Library

Class

Header File

Comments

Help Files

Demo

LDialog

LTCDLG.H

The LEADTOOLS Class Library provides reusable dialogs for the most common LEADTOOLS imaging functions.

The common dialog features include:

- FileOpen and FileSave dialogs have been extended to contain LEADTOOLS specific options.

- A Thumbnail Preview option for FileOpen dialog allows the end user to preview images before loading them.

- A Thumbnail Preview option for the image processing dialogs allows the end user to preview the proposed change to the image, before actually affecting the original image.

- An optional Help Button callback function lets you provide custom help information for each dialog.

- A user interface control for the dialogs is provided through flags passed to each dialog function.

- An option to have the Imaging Common Dialog process the image automatically is provided.

LTCLIBN.CHM

\Examples\ClassLib\MSVC5\DEMO

The LEADTOOLS Class Library provides low level support for Imaging Common Dialogs.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Imaging Common Dialogs : COM

Imaging Common Dialogs – COM Objects

COM Object / Interface | Comments | Help Files | Demo
 | The LEADTOOLS Raster Common Dialog object contains properties, methods and events for displaying Imaging Common Dialogs. | LTDLGCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDK14n.DLL | The Common Dialog Kernel COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDR14n.DLL | Color Image Processing Dialog COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDE14n.DLL | Display Effects Dialog COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDF14n.DLL | File Open/Save Dialog COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDM14n.DLL | Image Processing Dialog COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDO14n.DLL | Document Image Processing Dialog COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDX14n.DLL | Image Effects Dialog COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRDW14n.DLL | Web Tuner Dialog COM Object |  | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32


Imaging Common Dialogs : VCL

Imaging Common Dialogs – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Common Dialog control contains properties, methods and events for implementing Imaging Common Dialog support.


Imaging Common Dialogs – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.WinForms.CommonDialogs.File.DLL - Leadtools.WinForms.CommonDialogs.File | The Leadtools.WinForms.CommonDialogs.File namespace provides support for file input and output common dialog functionality. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo
Leadtools.WinForms.CommonDialogs.Color.DLL - Leadtools.WinForms.CommonDialogs.Color | The Leadtools.WinForms.CommonDialogs.Color namespace provides support for color image processing common dialog functionality. | LTNET.CHM |


Scanning / Capturing

TWAIN Scanning / TWAIN Capture: Scanners, Digital cameras, Capture cards

LEADTOOLS provides a powerful set of tools spanning the full spectrum of digital imaging, including in-depth support for image acquisition through industry standard interfaces from a wide variety of hardware devices.

With LEADTOOLS you can control any scanner, digital camera or capture card that has a TWAIN device driver. High-level acquisition support is provided for ease of use, and low-level functionality is provided for flexibility and control in even the most demanding applications.

Using LEADTOOLS TWAIN capabilities, your application can:

  • use the default user interface included with the TWAIN driver.

  • create your own user interface to the driver interface.

  • bypass the interface entirely for completely automated tasks or batch scanning.

  • control the type of image which is acquired (black & white, b/w with halftone, grayscale, color - as supported by the device).

  • control the resolution (dpi), position , size, and orientation of the image to be acquired.

  • use the Automated Document Feeder for single and multi-page scans, including support for duplex scanning.

  • use supplied events and callbacks to code your own special per-page processing

  • use selection dialogs to allow selection of TWAIN source, or select among multiple TWAIN sources in code.

  • use of native, buffered memory or file transfer modes when acquiring from a TWAIN device.

  • flexibility to get and set all TWAIN v1.9 capabilities that the device's TWAIN driver supports.

  • save of the device's TWAIN capability settings to a template file, helping to save multiple settings of sources and load them as needed.

  • buffered memory transfer mode includes compression support. The scan data is compressed using JPEG, RLE, BITFIELDS, GROUP 3, GROUP 4 or PACKBITS to reduce the data transfer bottle neck.

  • perform the save of the Memory Buffered Transfer data directly to a file.

  • get the Extended Image Info that some TWAIN scanner drivers support. For example, if the scanner driver supports reading barcodes or patch codes, then that information could be retrieved via LEADTOOLS TWAIN support.

  • access digital cameras using TWAIN. LEADTOOLS provides the functionality to negotiate a TWAIN file system, used for accessing digital cameras, with the following:

  • Change Directory

  • Create Directory

  • Delete

  • Format Media

  • Close File

  • Get First File

  • GetInformation

  • Get Next File

  • Rename

  • Copy

  • Automatic Capture Directory

  • get and set TWAIN JPEG compression. LEADTOOLS provides the functionality to describe the information necessary to transfer a JPEG-compressed image during a buffered transfer. Images compressed in this fashion will be compatible with the JPEG File Interchange Format, version 1.1. The following TWAIN messages are implemented:

  • DG_IMAGE / DAT_JPEGCOMPRESSION / MSG_GE

  • DG_IMAGE / DAT_JPEGCOMPRESSION / MSG_GETDEFAULT

  • DG_IMAGE / DAT_JPEGCOMPRESSION / MSG_RESET

  • DG_IMAGE / DAT_JPEGCOMPRESSION / MSG_SET

  • negotiate the most frequently used capabilities with TWAIN high-level functions with no need to go to basic set/get capability functions to set/get their capabilities. These functions negotiate the following capabilities:

  • ICAP_XFERMECH

  • ICAP_IMAGEFILEFORMAT

  • ICAP_COMPRESSION

  • ICAP_XRESOLUTION

  • ICAP_YRESOLUTION

  • ICAP_FRAMES

  • ICAP_UNITS

  • ICAP_BITDEPTH

  • ICAP_BRIGHTNESS

  • ICAP_CONTRAST

  • ICAP_HIGHLIGHT

  • ICAP_ORIENTATION

  • ICAP_SUPPORTEDSIZES

  • DG_IMAGE / DAT_RGBRESPONSE / MSG_RESET

  • DG_IMAGE / DAT_RGBRESPONSE / MSG_SET

  • CAP_INDICATORS

  • CAP_DUPLEXENABLED

  • CAP_DUPLEX

  • CAP_XFERCOUNT

With the LEADTOOLS TWAIN support, you can do anything that your TWAIN v1.9 driver supports. If your TWAIN driver is not v1.9 or does not support a functionality listed above, then LEADTOOLS will support all of the features that the driver has that are compatible with the TWAIN v1.9 specification.

LEADTOOLS TWAIN support gives your applications access to the wide variety of devices which can acquire images via TWAIN from manufacturers like Kodak, Hewlett Packard, Microtek, Logitech, Fuji and many more.

ISIS ® Scanning – Programming High-Speed Document Scanning Software

With LEADTOOLS’ SDK support for ISIS ®, developers can use the driver's built-in dialog box for controlling the image acquisition or by-pass it and create their own. The LEADTOOLS ISIS ® support functions offer control over image size, position, brightness, contrast, resolution, orientation, gamma and compression. Developers can request compressed data from the ISIS ® driver, for faster image acquisition. LEADTOOLS supports single page acquire to memory, multipage acquire to multipage file, and multipage acquire to multiple single page files. With LEADTOOLS, your application can acquire images from ISIS ® compliant scanners from manufacturers like Ricoh, Hewlett Packard, Bell&Howell, and others. You can use images acquired as document (halftone), grayscale or color for use in check & form processing applications, stock photo collections, WebPages and more.

Screen Capture

LEADTOOLS provides functions for capturing all or part of the screen. The result can then be used with any of the LEADTOOLS image processing functions and can be saved in any of the more than 70 file formats that LEAD supports.

With the LEADTOOLS Capture feature you can:

  • Capture the entire screen

  • Active window

  • Menu under cursor

  • Window under cursor (button, tool bar, icon, or client area)

  • Selected object

  • Mouse cursor

  • Wallpaper

LEADTOOLS also allows for capture of a selected area of the screen in a wide array of shapes such as:

  • Rectangle

  • Rounded rectangle

  • Ellipse

  • Polygon or freehand

Bitmap, Icon and Cursor resources can be captured from 16 or 32-bit Windows EXE and DLL files. Options include:

  • Multi-capture with callback

  • Hot Keys

  • Time interval

Supported Platforms

Scanning/Capturing ActiveX

Scanning/Capturing API

Scanning/Capturing Class Library

Scanning/Capturing COM

Scanning/Capturing VCL

Scanning/Capturing .NET


Scanning/Capturing : ActiveX

Scanning/Capturing – ActiveX

OCX File | Comments | Help File | Demo
LTSCR14N.OCX | The LEADTOOLS Screen Capture ActiveX control provides properties, methods and events for implementing advanced Screen Capture functionality. | LTSCROCX.HLP | \Examples\OCX\MFC40\SCRDEMO \Examples\OCX\VB\SCRCAP32
LTRTW14N.DLL | The LEADTOOLS Raster Twain COM Object provides properties, methods and events for implementing advanced TWAIN Scanning functionality. This COM object can work with the LEADTOOLS Main ActiveX Control. | LTTWNCOMN.CHM | \Examples\OCX\MFC40\DEMO \Examples\OCX\VB\DEMO32 \Examples\OCX\MFC40\TWAINDEMO \Examples\OCX\VB\TWAINDEMO
LTISI14N.OCX | The LEADTOOLS ISIS ActiveX control provides properties, methods and events for implementing ISIS Scanning functionality. | LTOCXN.HLP | \Examples\OCX\MFC40\DEMO \Examples\OCX\VB\DEMO32


Scanning/Capturing : API

Scanning/Capturing – API

DLL | LIB | Header | Comments | Help Files | Demo
LTTWN14N.DLL | LTTWN_N.LIB | LTTW2.H | Provides both low and high-level functions that can be used to implement advanced TWAIN Scanning functionality. | LTTWNDLLN.CHM | \Examples\DLL\DEMO \Examples\DLL\FASTTWN \Examples\DLL\TWAINDEMO \Examples\DLL\TWNCONFIG
LTISI14N.DLL | LTISI_N.LIB | LTISI.H | Provides both low and high-level functions that can be used to implement ISIS Scanning functionality. | LTDLLN.CHM | \Examples\DLL\DEMO
LTSCR14N.DLL | LTSCR_N.LIB | LTSCR.H | Provides both low and high-level functions that can be used to implement Screen Capture functionality. | LTSCRDLLN.CHM | \Examples\DLL\DEMO \Examples\DLL\SCRDEMO \Examples\DLL\MFCSCR

The LEADTOOLS API provides the lowest level of Scanning/Capture support.


Scanning/Capturing : Class Library

Scanning/Capturing – Class Library

Class | Header File | Comments | Help Files | Demo
LTwain | LTCSCNNR.H | The LTwain class is derived from LScanner and provides support for acquiring images from TWAIN compatible data sources such as scanners and digital cameras. This class provides functionality for enumerating and selecting TWAIN data sources, displaying the data source's built-in user interface, acquiring single or multiple images, and setting acquisition parameters without using the built-in UI. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO \Examples\ClassLib\MSVC5\FSTTWN32 \Examples\ClassLib\MSVC5\TWAINDEMO
LIsis | LTCSCNNR.H | The LIsis class is derived from LScanner and provides support for acquiring images from ISIS compatible scanners. This class provides functionality for selecting ISIS scanner drivers, displaying the ISIS built-in user interface, acquiring single or multiple images, and setting acquisition parameters without using the built-in UI. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO
LScreenCapture | LTCSCNNR.H | The LScreenCapture class is derived from LBase. This class provides the functionality for capturing images from the screen. It provides functions to capture a specific window, active window, active client area, mouse cursor, Windows object, user-defined area, menus and resources from executable files. This class supports capturing a single image or multiple images with a single capture session. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO \Examples\ClassLib\MSVC5\SCRDEMO

The LEADTOOLS Class Library provides low level support for Scanning/Capture.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Scanning/Capturing : COM

Scanning/Capturing – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRTN14N.DLL - ILEADRasterTwain | The LEADTOOLS Raster Twain COM Object provides properties, methods and events for implementing basic TWAIN Scanning functionality. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32 \Examples\COM\MSVC5\TWAINDEMO \Examples\COM\VB\TWAINDEMO \Examples\COM\MSVC5\FASTTWN \Examples\COM\VB\FASTTWN
LTRIS14N.DLL - ILEADRasterISIS | The LEADTOOLS Raster ISIS COM Object provides properties, methods and events for implementing ISIS Scanning functionality. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRSC14N.DLL - ILEADRasterScr | The LEADTOOLS Raster Screen Capture COM Object provides properties, methods and events for implementing Screen Capture functionality. | LTSCRCOMN.CHM | \Examples\COM\MSVC5\SCRDEMO \Examples\COM\VB\SCRCAP32


Scanning/Capturing : VCL

Scanning/Capturing – VCL

Feature | Compiler | Package | Help Files | Demo
TWAIN Scanning | Delphi 7 | LT14D7SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\TWAIN \Examples\VCL\Delphi\TWAIN
 | Delphi 9 | LT14D9SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\TWAIN \Examples\VCL\Delphi\TWAIN
 | C++ Builder 5 | LT14B5SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\TWAIN \Examples\VCL\Delphi\TWAIN
 | C++ Builder 6 | LT14B6SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\TWAIN \Examples\VCL\Delphi\TWAIN
ISIS Scanning | Delphi 7 | LT14D7SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | Delphi 9 | LT14D9SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 5 | LT14B5SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
 | C++ Builder 6 | LT14B6SN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Screen Capture | Delphi 7 | LT14D7AD.BPL | LTSCRVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\SCRCAP \Examples\VCL\Delphi\SCRCAP
 | Delphi 9 | LT14D9AD.BPL | LTSCRVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\SCRCAP \Examples\VCL\Delphi\SCRCAP
 | C++ Builder 5 | LT14B5AD.BPL | LTSCRVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\SCRCAP \Examples\VCL\Delphi\SCRCAP
 | C++ Builder 6 | LT14B6AD.BPL | LTSCRVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO \Examples\VCL\Builder\SCRCAP \Examples\VCL\Delphi\SCRCAP

The LEADTOOLS TWAIN control contains properties, methods and events for implementing TWAIN Scanning support.

The LEADTOOLS ISIS control contains properties, methods and events for implementing ISIS Scanning support.

The LEADTOOLS Screen Capture control contains properties, methods and events for implementing Screen Capture support.


Scanning/Capturing : .NET

Scanning/Capturing – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.Twain.DLL - Leadtools.Twain | The Leadtools.Twain namespace provides support for TWAIN scanning functionality. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo


Printing

LEADTOOLS can perform all of the image processing necessary to print directly to any Windows supported printer. You have complete control over the position of the image and the size of the printed image.

LEADTOOLS can preprocess the image for you, so it matches the output device, or you can manually preprocess the data before printing, or you can send the data as is so the printer driver processes the data. Some preprocessing functions include to ability to halftone an image (using any angle you specify for the halftone screen) to prepare images for back and white printing. Additionally, you can reduce the colors in an image to use an optimized palette, LEAD palette or a user-defined palette.

With LEADTOOLS, you can easily print text using Windows GDI and print multiple images on the same page. Additionally, you can save coding time because you can use the same code to display images to the monitor or printer.

Additionally, LEAD is offering the LEADTOOLS ePrint Printer Driver. LEADTOOLS ePrint offers you greater flexibility in existing applications that support printing and in the use of physical printers, and it even comes with a free SDK.

Supported Platforms:

Printing ActiveX

Printing API

Printing Class Library

Printing COM

Printing VCL

Printing .NET


Printing : ActiveX

Printing – ActiveX

OCX File | Comments | Help File | Demo
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Printing support. | LTOCXN.HLP | \Examples\OCX\MFC40\DEMO \Examples\OCX\VB\DEMO32 \Examples\OCX\VB\PRNPRV32


Printing : API

Printing – API

DLL | LIB | Header | Comments | Help Files | Demo
LTDIS14N.DLL | LTDIS_N.LIB | LTDIS.H | Provides both low and high-level functions that can be used to print images. | LTDLLN.CHM | \Examples\DLL\DEMO

The LEADTOOLS API provides the lowest level of Printing support.


Printing : Class Library

Printing – Class Library

Class | Header File | Comments | Help Files | Demo
LPrint | LTCPRINT.H | The LPrint class is derived from LBase and provides functions for printing bitmap objects. These functions allow you to specify the location and size of the printed image. Optionally, you can let the print functions center and/or size the image to fit the printed page. With the LPrint object, you can print multiple images per page, and can use the same device context for other drawing your application may need to do. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO \Examples\ClassLib\MSVC5\PRNTPREV

The LEADTOOLS Class Library provides low level support for Printing.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Printing : COM

Printing – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRVW14N.OCX - ILEADRasterView | The LEADTOOLS Raster View ActiveX provides support for Printing. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32


Printing : VCL

Printing – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D76MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing Printing support.


Printing : .NET

Printing – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.DLL - RasterImage | The RasterImage class provides properties, methods and events for rendering images to any display device, including printers. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo


Database Imaging

LEADTOOLS has specific features designed for the imaging database developer. VB data binding allows you to use the Visual Basic JET engine to store and retrieve images to/from any database supported by JET. LEADTOOLS has support for 32-bit ODBC, which allows you to work with any ODBC database. LEADTOOLS provides a customized OLE 2.0 in-place server which can store and retrieve images into/from any OLE client. Load/Save memory and Load/Save file offset functions provide low-level methods for working with databases.

You can use the database features to store images in any of the file formats supported by LEADTOOLS. LEADTOOLS' database support includes a wide variety of callback routines and features multi-page support. These features, when combined with the excellent compression options available in LEADTOOLS, provide a solid base for building robust database applications such as those used in fields like Real Estate, Law Enforcement and E-Commerce.

You can maintain images in a database, using any valid file format to store an image in a long binary field. You can do so as follows:

  • Use Open Database Connectivity (ODBC).
  • Use OLE DB.
  • Use data binding.
  • Use functions to read files from memory and write files to memory.
  • Use LEAD OLE server to embed or link images in any database that supports an OLE field.

Supported Platforms

Database Imaging ActiveX

Database Imaging API

Database Imaging Class Library

Database Imaging COM

Database Imaging VCL

Database Imaging .NET


Database Imaging : ActiveX

Database Imaging – ActiveX

OCX File

Comments

Help File

Demo

LTOCX14N.OCX

The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Database support, including Load/SaveMemory, Load/SaveArray, VB Data Binding and ODBC Data Binding.

LTOCXN.HLP

\Examples\OCX\MFC40\DB

\Examples\OCX\VB\BIND32

\Examples\OCX\VB\ANNB32

\Examples\OCX\VB\DB32

LTODB14N.OCX

The LEADTOOLS OLE DB control provides properties, methods and events for saving and loading images to/from OLE DB data sources.

LTOCXN.HLP

\Examples\OCX\MFC40\OLEDB

\Examples\OCX\VB\OLEDB32

LEADSRVR.EXE

You can run the LEAD OLE server as a stand-alone WIN32 application or use it to add basic image processing capabilities to any OLE client application. For example, you can do the following:

· Store compressed images in a Microsoft Access, and print reports that include the images.

· Link or embed images in a Microsoft Word document, and edit the images in place, without ever leaving Word.

LTOLESVRN.HLP


Database Imaging : API

Database Imaging – API

DLL | LIB | Header | Comments | Help Files | Demo
LTKRN14N.DLL | LTKRN_N.LIB | LTKRN.H | Provides low-level functions for redirecting the LEADTOOLS file input/output routines to your own user-define input/output routines. | LTDLLN.CHM | \Examples\DLL\REDIRECT
LTFIL14N.DLL | LTFIL_N.LIB | LTFILG.H | Provides both low and high-level functions that can be used to load/save image files. These functions allow you to work with ‘files’ in memory buffers or at offsets within disk files. | LTDLLN.CHM | \Examples\DLL\SAVEMEM \Examples\DLL\MEMORY \Examples\DLL\OFFSET

The LEADTOOLS API provides the lowest level of input/output support for working with databases. For more high-level support, refer to LEADTOOLS Main ActiveX, LEADTOOLS Main VCL, LEADTOOLS OLEDB ActiveX, LEADTOOLS Raster ODBC COM Object, LEADTOOLS Raster OLEDB COM Object.


Database Imaging : Class Library

Database Imaging – Class Library

Class | Header File | Comments | Help Files | Demo
LBaseFile | LTCFILE.H | The LBaseFile class is derived from LBase. This class is the base class for LEADTOOLS Class Library input/output operations. It contains basic operations for file I/O. With this class, you can override the default functions that LEADTOOLS uses for opening, closing, reading from, writing to, and seeking in files. This class forms the base for the LFile and LMemoryFile classes. | LTCLIBN.CHM |
LFile | LTCFILE.H | The LFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files on disk. | LTCLIBN.CHM | \Examples\ClassLIb MSVC5\OFFSET
LMemoryFile | LTCFILE.H | The LMemoryFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files in memory buffers, as opposed to files on disk. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\SAVEMEM \Examples\ClassLib\MSVC5\MEMORY

The LEADTOOLS Class Library provides low level of input/output support for working with databases. For more high-level support, refer to LEADTOOLS Main ActiveX, LEADTOOLS Main VCL, LEADTOOLS OLEDB ActiveX, LEADTOOLS Raster ODBC COM Object, LEADTOOLS Raster OLEDB COM Object.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Database Imaging : COM

Database Imaging – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRIO14N.DLL - ILEADRasterIO | The LEADTOOLS Raster IO object provides low level input/output support for working with databases. | LTCOMN.CHM |
LTROD14N.OCX - ILEADRasterOLEDB | The LEADTOOLS Raster OLE DB control provides properties, methods and events for saving and loading images to/from OLE DB data sources. | LTCOMN.CHM | \Examples\COM\MSVC5\OLEDB \Examples\COM\VB\OLEDB32
LTRBC14N.DLL - ILEADRasterODBC | The LEADTOOLS Raster ODBC object provides properties, methods and events for saving and loading images to/from ODBC data sources. | LTCOMN.CHM | \Examples\COM\MSVC5\DB \Examples\COM\VB\DB32


Database Imaging : VCL

Database Imaging – VCL

Compiler | Package | Help Files
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM

The LEADTOOLS Main control contains properties, methods and events for implementing both low-level and high-level database imaging, including data binding.


DatabaseImaging : .NET

Database Imaging – .NET

Assembly – Class/Namespace

Comments

Help Files

Leadtools.Codecs.DLL – Leadtools.Codecs

The Leadtools.Codecs namespace contains classes with properties, methods and events for loading and saving any type of image file and for getting information about loaded bitmaps

Support includes palettes, memory files, multi-page files, compressed files, comments, tags, animations, view perspectives, raw image data, compressed data, alpha channel.

LTNET.CHM

The Leadtools.Codecs namespaces provides low level of input/output support for working with databases. For more high-level support, refer to LEADTOOLS Main ActiveX, LEADTOOLS Main VCL, LEADTOOLS OLEDB ActiveX, LEADTOOLS Raster ODBC COM Object, LEADTOOLS Raster OLEDB COM Object.


Annotations

LEADTOOLS offers a variety of annotation (document markup) options that can be added to document, grayscale and color images. LEADTOOLS allows the end-user to reposition nodes of an existing free-hand object, which prevents the user from redrawing the object. Enhanced redact objects allow you to restore parts of an image that were blacked out. When combined with annotation security, these redact objects provide a means of granting user-level access to parts of an image. Annotation objects can be stored as a separate object layer, or can be burned or embedded into the actual image. LEADTOOLS allows you to read or write annotations as an external file or as a Wang annotation tag within a TIFF file. With LEADTOOLS, you can choose between low level access to the annotations, or you can implement annotation support through a fully automated mode with a ready to use floating, customizable toolbar and pop-up menus. The superior annotation features provided in LEADTOOLS can be used in any application where image markup is required.

With LEADTOOLS Document/Medical Annotation support you can:

  • Create any of the following objects: line, arrow, rectangle, ellipse, polygon, freehand line, text, highlighter, hot spot, note, stamp, redaction, button, audio clip, video, freehand hot spots, points, protractors, cross-products, push pins, rubber stamps, curve, closed curve, encryption, text pointer, polyruler, and RTF edit objects.

  • Create your own custom annotation objects with custom handles and user-defined behaviour.

  • Implement automated annotation support.

  • Customize the cursors for automation activities.

  • Implement annotation passwords (case-sensitive) providing security for every object.

  • Implement hyperlinks for every object. Hyperlinks can be user-defined messages, programs to run, or jumps to Web pages.

  • Modify text strings used in automated annotation support.

  • Scale and position a group to fit the displayed bitmap.

  • Fix annotation objects, so that they do not move when zooming/scrolling.

  • Group and ungroup objects.

  • Apply an object or group to a bitmap.

  • Size and position an object or group.

  • Rotate an object or group.

  • Flip, reverse, or shear an object or group.

  • Save an object or group on the Windows clipboard.

  • Print an object or group. (Flicker Free Annotation Display!)

  • Save an object or group in a file.

  • Save annotations as an external LEAD file, WMF file, or as a WANG compatible tag inside a TIFF file.

  • Save an object or group as a file in memory. (This is useful for database support.)

  • Save an object or group in a database using Visual Basic data binding.

  • Control where the optional annotation name or title is displayed.

  • Work with multi-page annotations.

  • Import text into Text objects.

  • Include tokens in Text objects.

  • Align text in Text objects.

  • Ruler, PolyRuler, Protractor, and Cross Product objects can have optional tick marks.

  • Ruler, PolyRuler, Protractor, and Cross Product objects can have user-defined units, or ‘smart units’.

  • Calibrate Ruler objects.

  • Use ESC to cancel actions in automation mode.

  • Save annotation files as an XML format file.

  • Set the transparency for annotation objects from completely transparent to completely opaque or any value in-between.

  • Choose to use the new XP style toolbar

  • Choose to use the new annotation cursors

Supported Platforms

Annotation ActiveX

Annotation API

Annotation Class Library

Annotation COM

Annotation VCL

Annotation .NET


Annotation : ActiveX

Annotation – ActiveX

OCX File | Comments | Help File | Demo
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing both low-level and automated mode Annotations, including VB data binding. | LTOCXN.HLP | \Examples\OCX\MFC40\DEMO \Examples\OCX\VB\DEMO32
LTODB14N.OCX | The LEADTOOLS OLE DB control provides properties, methods and events for saving and loading annotations to/from OLE DB data sources. | LTOCXN.HLP | \Examples\OCX\MFC40\OLEDB \Examples\OCX\VB\OLEDB32


Annotation : API

Annotation – API

The LEADTOOLS API provides the lowest level of Annotation functionality. The API also provides Automated Mode Annotation functionality.

DLL | LIB | Header File | Help File | Demo
LTANN14N.DLL | LTANN_N.LIB | LTANN.H | LTDLLN.CHM | \Examples\COM\MSVC5\DICOM \Examples\COM\VB\DICOM32


Annotation : Class Library

Annotation – Class Library

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL.

Class | Header File | Comments | Help File | Demo
LAnnotationWindow | LTCANNWN.H | LAnnotationWindow extends LBitmapWindow by adding functionality for displaying Annotations through an automated interface with an easy to use Annotation toolbar. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\ANNOTATE
LAnnotation | LTCANN.H | The LAnnotation class is derived from the LBase class. This class contains base functionality for creating, and managing LEAD annotation objects. This class provides the main functionality for other derived annotation classes like creation, drawing, scaling, realizing, copying, and setting/getting properties that are common to all annotation objects. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\ANNOTATE
LAnnToolBar | LTCANN.H | The LAnnToolBar class is derived from the LBase class. This class contains the support for creating, and managing the LEAD annotation toolbar. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\ANNOTATE
LAnnAutomation | LTCANN.H | The LAnnAutomation class is derived from LAnnotation. This class contains the support for creating, and managing Automation annotation objects. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\ANNOTATE
LAnnContainer | LTCANN.H | The LAnnContainer class is derived from LAnnotation. This class provides the necessary functionality for creating and managing Container objects, in addition to managing other annotation objects by providing the functionality of inserting, removing, and enumerating the different annotation objects contained by Container objects. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\ANNOTATE
LAnnXXXXXX | LTCANN.H | Classes that are derived from LAnnotation. Each represents one of the LEADTOOLS Annotation object types. For more information refer to the Class Library help file. | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\ANNOTATE


Annotation : .NET

Annotation – COM Objects

COM Object / Interface | Comments | Help File | Demo
LTRAN14N.DLL - ILEADRasterAnnotation | The LEADTOOLS Raster Annotation object contains properties, methods and events for implementing both low-level and automated mode Annotations. | LTCOMN.CHM | \Examples\OCX\MFC40\ANNCOM \Examples\OCX\VB\ANNOT32
LTROD14N.OCX - ILEADRasterOLEDB | The LEADTOOLS Raster OLE DB control provides properties, methods and events for saving and loading annotations to/from OLE DB datasources. | LTCOMN.CHM | \Examples\OCX\MFC40\OLEDB \Examples\OCX\VB\OLEDB32
LTRBC14N.DLL - ILEADRasterODBC | The LEADTOOLS Raster ODBC object provides properties, methods and events for saving and loading annotations to/from ODBC datasources. | LTCOMN.CHM | \Examples\OCX\MFC40\DB \Examples\OCX\VB\DB32
LTRVW14N.OCX | The LEADTOOLS RasterView control works with the ILEADRasterAnnotation interface to provide display of Annotations. | LTCOMN.CHM | \Examples\OCX\MFC40\ANNCOM \Examples\OCX\VB\ANNOT32


Annotation : VCL

Annotation – VCL

The LEADTOOLS Annotation control contains properties, methods and events for implementing both low-level and automated mode Annotations.

Compiler | Package | Help File | Demo
Delphi 7 | LT14D7Nt.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\AnnDemo \Examples\VCL\Builder\AnnDemo
Delphi 9 | LT14D9Nt.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\AnnDemo \Examples\VCL\Builder\AnnDemo
C++ Builder 5 | LT14B5Nt.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\AnnDemo \Examples\VCL\Builder\AnnDemo
C++ Builder 6 | LT14B6Nt.BPL | LTVCLN.CHM | \Examples\VCL\Delphi\AnnDemo \Examples\VCL\Builder\AnnDemo


Annotation : COM Objects

Annotation – .NET

Assembly – Class/Namespace | Comments | Help File | Demo
Leadtools.Annotations.DLL - AnnObject | The AnnObject class is the base class for all LEADTOOLS Annotation objects. This class, and other classes from the Leadtools.Annotations namespace, provide low-level annotation functionality. | LTNET.CHM | \Examples\CS\AnnotationsDemo \Examples\VB\AnnotationsDemo
Leadtools.Annotations.DLL - AnnAutomation | The AnnAutomation class contains properties, methods and events for implementing high-level automated annotations. | LTNET.CHM | \Examples\CS\AutomationDemo \Examples\VB\AutomationDemo


Document Clean up

Scanned documents often contain undesired elements, such as specks, dots, black borders, lines, and hole-punch marks. LEADTOOLS provides powerful functions that can clean up documents by detecting and removing these elements. This class of LEAD functions each supply a "hook" into the API decision making process, allowing the programmer to obtain information about every detected element, and to use the information to tailor the function to meet his needs. Each function can also optionally return a region corresponding to any proposed changes, allowing for end-user "preview" capabilities. These new features, along with the deskew, dilation, erosion, min and max filters give LEADTOOLS Document Imaging SDK the power and flexibility you need when working with scanned documents.

The document clean-up functionality includes:

Border removal - Remove any or all image borders (black borders surrounding scanned document), with the ability to specify tolerance level for amount of noise, maximum border size, and variability of border size.

Dot removal - Remove dots, specks, and blobs from documents, specifying min and max dot size.

Hole Punch removal - Remove hole-punch artifacts, specifying min and max hole size and count.

Line removal - Remove horizontal and vertical lines from scanned images, with the ability to specify minimum line length, maximum line width, maximum gap for dashed or otherwise broken lines, tolerance values for line width variance, and other parameters to ensure that valid image obects are preserved.

Smoothing - Smooth the nicks and bumps on scanned text characters (or any black-on-white objects), specifying the minimum bump size.

Text Inversion - Areas on scanned image of white text (or line objects) on a black background are detected and inverted to black-on-white. You can specify minimum size and min and max percent-black of regions to be detected.

Supported Platforms

Document Clean up ActiveX

Document Clean up API

Document Clean up Class Library

Document Clean up COM

Document Clean up VCL

Document Clean up.NET


Document Clean up : ActiveX

Document Clean up – ActiveX

OCX File | Comments | Help File | Demo
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Document Clean-up functionality. | LTOCXN.HLP | \Examples\OCX\MFC40\DEMO \Examples\OCX\VB\DEMO32


Document Clean up : API

Document Clean up – API

DLL | LIB | Header | Comments | Help Files | Demo
LTIMG14N.DLL | LTIMG_N.LIB | LTIMG.H | The LEADTOOLS API provides the lowest level of Document Clean-up functionality. | LTDLLN.CHM | \Examples\DLL\DEMO

The LEADTOOLS API provides the lowest level of Document Clean-up functionality.


Document Clean up : Class Library

Document Clean up – Class Library

Class | Header File | Comments | Help Files | Demo
LBitmap | LTCBTMAP.H | The LBitmap class is derived from LBitmapBase, and extends it by adding functionality for more advanced image processing. This functionality includes: Halftone, Sharpen, Picturize, GammaCorrect, Deskew, Despeckle, WindowLevel, Color Separation and Color Merge, Image Filters (such as Average, Median, Mosaic), and color processing (such as Invert, Hue, Contrast, Intensity, and Saturation). | LTCLIBN.CHM | \Examples\ClassLIb\MSVC5\DEMO

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Document Clean up : COM

Document Clean up – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRIO14N.DLL - ILEADRasterIO | The LEADTOOLS Raster IO object provides properties, methods, and events for implementing Document Clean-up functionality. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32


Document Clean up : VCL

Document Clean up – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events for implementing Document Clean-up functionality.


Document Clean up : .NET

Document Clean up – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.ImageProcessing.Effects.DLL – Leadtools.ImageProcessing.Effects | The Leadtools.ImageProcessing.Effects namespace includes more than 70 digital filters and transforms to process images (or selected portions). It includes methods for basic image transforms such as resizing, flipping, cropping, and rotating, and for changing the bitmaps’ color-depth. This class also includes methods to: Smooth, sharpen, edge detect/enhance, change hue and saturation, add noise, combine two or more bitmaps, and to copy whole or partial bitmaps from one object to another. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo


DigitalPaint

A must for anyone who wants to add digital painting functionality to their application. With the LEADTOOLS Digital Paint module, a developer can create an entire image editing or design application, or simply add pieces of those types of functionality into an existing application.

The Digital Paint module includes both low-level and high-level functions for painting. With the low-level functions, you can programmatically control the painting. With the high-level functions (known as Automated Mode), you can simply turn on Automation, and allow the user to pick the painting tool. With Automation, the user's mouse events are automatically processed, and the coding is done for you.

Brush - includes features that normally could be found only in artistic painting applications.

Brush options include:

  • color brush
  • image/pattern brush
  • diameter
  • hardness/sharpness of brush edges
  • spacing - frequency of touches
  • density
  • opacity
  • fade out - allow the brush to fade during the stroke
  • texture - apply a bitmapped texture to the brush

Shape - has the advantage of removing much of the Windows API programming usually required to draw a shape. Additionally, allows the control of the artistic effects of the drawn shape (opacity, paper texture, etc.)

Shapes include:

  • Line
  • Rectangle
  • Rounded rectangle
  • Ellipse
  • Polygon
  • Polybezier

Region - create regions for restricting image operations. Regions can range from simple to very complex (many of which are not supported by natively in Windows without LEADTOOLS). Additionally, functionality to resize or scale a region, which is not supported directly by Windows, is included with the LEADTOOLS Digital Paint module.

The following regions can be created:

  • Rectangle
  • Rounded rectangle
  • Ellipse
  • Polygon
  • Curves
  • Surface - a region starting at a specified point and continues in all directions that contains a specified color and tolerance
  • Border - a region starting at a specified point and continues in all directions until finding a specified color and tolerance
  • Color - a region that contains a specified color and tolerance

Fill - Complete area filling, also know as a FloodFill, with control over both the method of filling and the features of filling.

Fill options include:

  • solid
  • gradient
  • background tiled image
  • opacity
  • texture
  • and more...

Fill types include:

  • Surface - Fills an area starting at a specified point and continues in all directions that contain a specified color and some tolerance.
  • Border - Fills an area starting at a specified point and continues in all directions until finding a specified color and some tolerance.
  • Color replace - Replaces every pixel using the current fill settings.

Text - Includes comprehensive text drawing features that could normally only be found in a painting application.

Text options include:

  • font
  • border
  • tiled background bitmap
  • alignment
  • opacity
  • texture
  • and more...

Common Dialogs - Includes a set of ready to use dialog boxes for gathering information for use in setting the various paint options. These allow you to quickly add code to your application for getting input from the end-user. Additionally, it gives your application a consistent Windows look and feel, meaning your application will be more user friendly and your users will have a smaller learning curve.

Supported Platforms

DigitalPaint ActiveX

DigitalPaint API

DigitalPaint Class Library


DigitalPaint : ActiveX

DigitalPaint – ActiveX

OCX File | Comments | Help File | Demo
LTPNT14N.OCX | The LEADTOOLS Digital Paint ActiveX control provides properties, methods and events for implementing both low and high-level (automated mode) Digital Paint features. | LTPNTOCXN.HLP | \Examples\OCX\MFC40\PAINT \Examples\OCX\MFC40\AUTPAINT
LTTLB14N.OCX | The LEADTOOLS Toolbar ActiveX control provides properties, methods and events for implementing a Toolbar UI. | LTTBOCXN.HLP | \Examples\OCX\MFC40\AUTPAINT


DigitalPaint : API

DigitalPaint – API

DLL | LIB | Header | Comments | Help Files | Demo
LTPNT14N.DLL | LTPNT_N.LIB | LTPNT.H | Provides low-level Digital Paint functionality. | LTPNTDLLN.CHM | \Examples\DLL\PAINT
LTPDG14N.DLL | LTPDG_N.LIB | LTPDG.H | Provides Digital Paint Common Dialog functionality. | LTPNTDLLN.CHM | \Examples\DLL\PAINT \Examples\DLL\AUTPNT
LTTLB14N.DLL | LTTLB_N.LIB | LTTLB.H | Provides functions for implementing a Toolbar UI. | LTTBDLLN.CHM | \Examples\DLL\AUTPNT
LTAUT14N.DLL | LTAUT_N.LIB | LTAUT.H | Provides high-level (automated mode) Digital Paint functionality. | LTAUTDLLN.CHM | \Examples\DLL\AUTPNT
LTCON14N.DLL | LTCON_N.LIB | LTCON.H | Provides high-level (automated mode) Digital Paint functionality. | LTAUTDLLN.CHM | \Examples\DLL\AUTPNT


DigitalPaint : Class Library

DigitalPaint – Class Library

Class | Header File | Comments | Help Files | Demo
LRasterPaint | LtcRst.H | The LRasterPaint class provides low-level DigitalPaint functions for implementing painting applications. | LTPNTLIBN.HLP | \Examples\ClassLib\MSVC5\RstDemo
LRasterDialog | LtcRstDlg.H | The LRasterDialog class provides DigitalPaint functions that provide support for the DigitalPaint common dialogs. | LTPNTLIBN.HLP | \Examples\ClassLib\MSVC5\RstDemo
LRasterPaintWindow | LtcRstWnd.H | The LRasterPaintWindow class provides high-level DigitalPaint functions for creating painting applications. | LTPNTLIBN.HLP | \Examples\ClassLib\MSVC5\RstDemo
LToolbar | LtcTb.H | The LToolbar class is derived from the LBase class. It is used in conjunction with the Container class LContainer and the Automation class LAutomation. The LToolbar class contains the functionality for creating predefined and user defined toolbars. | LTTBLIBN.HLP | \Examples\ClassLib\MSVC5\RstDemo
LAutomation | LtcAut.H | The LAutomation class is derived from the LBase class. It is used in conjunction with the Container class LContainer. The LAutomation class contains the functionality for coordinating low-level toolkit functions, LEAD Container functions and LEAD Toolbar functions. | LTAUTLIBN.HLP | \Examples\ClassLib\MSVC5\RstDemo
LContainer | LtcCon.h | Provides high-level (automated mode) Digital Paint functionality. | LTAUTLIBN.HLP | \Examples\ClassLib\MSVC5\RstDemo


DICOM Basic Features

The LEADTOOLS DICOM Basic features provide support for:

  • The DICOM 3.0 specification (COMPLETE support), including all standard IOD classes and modalities (CR, CT, MR, NM, US, RF, SC, VL, etc.)

  • 1,8,10,12,16,24 and 32-bit images including JPEG (12, 16-bit Lossless grayscale, 8, 12-bit lossy grayscale, 24-bit lossless and lossy color), Run Length, Uncompressed, Photometric Interpretation (Monochrome1, Monochrome2, Palletized, RGB, ARGB, CMYK, YBR Full 422, YBR Full), and single and multi-frame (cina) images.

  • The easy implementation of and full support for DICOM 3.0 specific IODs.

  • The easy implementation of and full support for the DICOM Basic Directory.

  • Automatic recognition of DICOM files (Little-Endian/Big-Endian, Implicit/Explicit VR, etc.)

  • DICOM files without a header consisting of a Preamble and a Prefix

  • Adding new IOD classes or modifying existing IOD classes

  • DICOM Image Overlays

  • Modality LUT

  • VOI LUT

  • Palette Color LUT

  • DICOM Annotations

  • DICOM Waveforms

  • DICOM Digital Signatures

  • DICOM Context Groups

LEADTOOLS maintains the Data Set (a collection of Data Elements stored in a DICOM file) internally as a tree structure. The LEADTOOLS DICOM Basic features include support to do the following:

  • Easily navigate lists and trees and manipulate (insert, delete, modify) modules and elements of Data Sets.

  • Create, initialize, load, and save Data Sets.

  • Load Data Sets from memory.

  • Maneuver through a Data Set.

  • Search a Data Set.

  • Insert and delete Data Set members.

  • Get and set Data Element values.

  • Get and set Data Set information.

  • Insert and retrieve Private Tags and values.

  • Get, set and insert single or multi-frame images/ pixel data (compressed or uncompressed).

  • Convert Data Element values to or from a string.

  • Extract, insert and manipulate overlays.

  • Create and manipulate waveform groups and channels.

  • Insert, verify and delete digital signatures.

In DICOM Information Object Definition (IOD) is used as an abstract data model that specifies information about Real-World objects. There are a tremendous number of IODs that are standard for the DICOM file format. In addition to the standard IODs, user-defined IODs may also be added. LEADTOOLS maintains a tree (IOD template) internally of all available Information Object Definitions (IODs) in the standard. The DICOM Basic features provide support to:

  • Add IODs to be defined in future versions of the DICOM Standard.

  • Maneuver Through the IOD Table.

  • Search the IOD Table.

  • Find the IOD for elements, modules or classes.

  • Insert and delete IODs.

  • Modify an existing IOD.

  • Set the Default IOD Table.

  • Change the name or the description.

LEADTOOLS maintains a Data Element Tag Table (or list) internally of all available tags, standard and user defined. Information the Data Element Tag Table can be used in an application for tool tips or to describe the elements. The LEADTOOLS DICOM Basic features let the user:

  • Add Data Element Tags to be defined in future versions of the DICOM Standard.

  • Maneuver through the Data Element Tag Table.

  • Search the Data Element Tag Table.

  • Insert and delete Tags.

  • Modify an existing Tag.

  • Set the Default Data Element Tag Table.

LEADTOOLS maintains a UID Table (or list) internally of all available unique identifiers, standard and user defined. A unique identifier in DICOM identifies items such as Service-Object Pair Classes or images. There are a number of unique identifiers that are standard for the DICOM. The LEADTOOLS DICOM Basics features let the user do the following:

  • Add UIDs to be defined in future versions of the DICOM Standard.

  • Maneuver Through the UID Table.

  • Search the UID Table.

  • Insert and delete UIDs.

  • Modify an existing UID.

  • Set the Default UID Table.

LEADTOOLS maintains a Value Representation Table (or list) internally of all available value representations, standard and user defined. The value representation of a data element in the DICOM Standard indicates the type of data that can be stored in the value field of the data element. In addition to the standard value representations, user-defined value representations may also be added to the table using LEADTOOLS. The LEADTOOLS DICOM Basic features let the user do the following:

  • Maneuver Through the Value Representation Table.

  • Search the Value Representation Table.

  • Insert and Delete Value Representations.

  • Modify an Existing Value Representation.

  • Set the Default Value Representation Table.

The LEADTOOLS DICOM Basic features also support the DICOM Basic Directory IOD class. The user can create a DICOMDIR Data Set to add support for DICOM Part 10. LEADTOOLS maintains the DICOMDIR data set as a tree, however, all key elements are stored at the same level of the tree. The specialized information included in a key element maintains information on key element children, non-key element children, parent key elements, and the logical relationships between the elements.

The LEADTOOLS DICOM Basic features let the user do the following:

  • Create DicomDir files

  • Maneuver through the Keys in the DicomDir files

  • Insert, delete and modify the Key elements in DicomDir files

LEADTOOLS also offers high-level functions to create DICOMDIR using just a few lines of code.

LEADTOOLS provides a number of functions for working with the Context Group Table. Initially, the Context Group Table is empty. Two ways are provided to add Context Groups to the table: by loading them from the internal table into the Context Group Table or by inserting Context Groups directly to the Context Group Table. You can use a number of functions to maneuver through the Context Groups in the Context Group Table. After a Context Group has been added to the Context Group Table, you can modify the Code Meanings of its Coded Concepts, add new Coded Concepts to the Context Group, and delete existing Coded Concepts from the Context Group

LEADTOOLS offers a number of functions to manipulate overlays in DICOM datasets. You can find the number of overlays in the DICOM dataset, retrieve the attributes of an overlay and to retrieve the "Overlay Data" (60xx,3000) for a single-frame overlay or for a multi-frame one. LEADTOOLS also allows you to insert a new or update an existing overlay.

With the complete LEADTOOLS support for Digital Signatures, you can:

  • ICreate Digital Signatures in the main Data Set as well as in an Item of a Sequence of Items; you can specify the MAC Calculation Transfer Syntax UID, the MAC Algorithm, the Data Elements to be signed, and the Digital Signature Security Profile to conform to.

  • Verify a single Digital Signature or all the Digital Signatures in the whole Data Set at once.

  • Get information about a particular Digital Signature.

  • Enumerate the Digital Signatures in the main Data Set as well as in an Item of a Sequence of Items.

LEADTOOLS waveform support is comprehensive and handles the various features supported by the standard which include:

  • Management of Waveform Group attributes.

  • Channel Manipulation (setting/getting channel samples, source, sensitivity and other attributes).

  • Audio Support (with the ability to create Basic Voice Audio files for report dictation).

  • Waveform annotations.

In addition to that LEADTOOLS supports the different waveform-related IODs defined by the standard which include: "Basic Voice Audio"," 12-Lead Electrocardiogram", "General Electrocardiogram"," Ambulatory Electrocardiogram" and "Hemodynamic".

In addition to that LEADTOOLS provides support for Supplement 91: Ophthalmic Photography Image SOP Classes. This includes support for the following classes and their associated modules and elements:

  • Ophthalmic Photography 8 Bit Image Storage.

  • Ophthalmic Photography 16 Bit Image Storage.

  • Stereometric Relationship Storage.

Supported Platforms:

DICOM Basic – API

DICOM Basic – Class Library

DICOM Basic – COM Objects


DICOM Basic : API

The LEADTOOLS API provides the lowest level of Annotation functionality. The API also provides Automated Mode Annotation functionality.

DLL | LIB | Header File | Comments | Help File | Demo
LTFIL14N.DLL | LTFIL_N.LIB | LTFIL.H | Provides support for loading/saving images from/to DICOM files. Requires LTDIC14N.DLL | LTDLLN.CHM | \Examples\DLL\DEMO
LTDIC14N.DLL | LTDIC_N.LIB | LTDIC.H | The LEADTOOLS DICOM DLL provides functions for complete support of the DICOM 3.0 specification. | LTDICDLLN.CHM | \Examples\DLL\DICOM \Examples\DLL\DICOMDIR \Examples\DLL\DICOMIOD \Examples\DLL\DICOMOVL


DICOM Basic : Class Library

DICOM Basic – Class Library

Class | DLL | Header File | Comments | Help File | Demo
LFile | LTFIL14N.DLL | LTCFILE.H | Provides support for loading/saving images from/to DICOM files. Requires LTDIC14N.DLL | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\DEMO
LDicomDS | TDIC14N.DLL | LTDIC.H | The LEADTOOLS DICOM Class Library provides functions for complete support of the DICOM 3.0 specification. | LTDICLIBN.CHM | \Examples\ClassLib\MSVC5\DICOM \Examples\ClassLib\MSVC5\DICOMDIR \Examples\ClassLib\MSVC5\DICOMDS \Examples\ClassLib\MSVC5\DICOMIOD \Examples\ClassLib\MSVC5\DICOMOVL


DICOM Basic : COM

DICOM Basic COM Objects

COM Object / Interface | Comments | Help File | Demo
LTRIO14N.DLL - ILEADRasterIO | Provides support for loading images that are stored in DICOM files. Requires LTDIC14S.DLL | LTCOMN.CHM | \Examples\COM\MSVC5\DICOM \Examples\COM\VB\DICOM32
LTDicKrn14N.DLL ILEADDicomKernel | The LEADTOOLS DICOM Kernel Object. | LTDICCOMN.CHM | \Examples\COM\MSVC5\DICOM \Examples\COM\VB\DICOM32
LTDicDS14N.DLL ILEADDicomDS | The LEADTOOLS DICOM DataSet COM Object provides properties, methods and events for complete support of the DICOM 3.0 specification. | LTDICCOMN.CHM | \Examples\COM\MSVC5\DICOM \Examples\COM\VB\DICOM32
LTDicDir14N.DLL ILEADDicomDir | The LEADTOOLS DICOM Directory COM Object provides properties, methods and events for working with DICOM Directory data sets. | LTDICCOMN.CHM | \Examples\COM\MSVC5\DICOMDIR \Examples\COM\VB\DICDIR32


DICOM Basic : VCL

DICOM Basic – VCL

DICOM Feature | Compiler | Package | Help File | Demo
Loading/saving images from/to DICOM files | Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM
 | Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM
 | C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM
 | C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM
Complete support of the DICOM 3.0 specification. | Delphi 7 | LT14D7DI.BPL | LTDICVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM
 | Delphi 9 | LT14D9DI.BPL | LTDICVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM
 | C++ Builder 5 | LT14B5DI.BPL | LTDICVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM
 | C++ Builder 6 | LT14B6DI.BPL | LTDICVCLN.CHM | \Examples\VCL\Builder\DICOM \Examples\VCL\Delphi\DICOM


DICOM Communication Features

The LEADTOOLS DICOM Communication features provide support for the following:

  • TCP/IP support for the communication of medical data using the DICOM 3.0 protocol.

  • Powerful high-level features that simplify the creation of DICOM client/server applications.

  • High-level functions for initiating and terminating Associations (connections between DICOM applications).

  • Automatic processing for filling out PDU structures (Protocol Data Units).

  • Automatic and transparent conversion of DICOM Data Sets to/from the specific Transfer Syntax required by the associated Application Entities (the connected DICOM client(s) and server(s)).

  • Full Support for all Service Classes - Easy to implement all possible DICOM Service Classes as client (SCU) and/or server (SCP):

      • DICOM Verification Service Class

      • DICOM Storage Service Class

      • DICOM Query/Retrieve Service Class

      • DICOM Study Content Notification Service Class

      • DICOM Patient Management Service Class

      • DICOM Study Management Service Class

      • DICOM Results Management Service Class

      • DICOM Print Management Service Class

      • DICOM Media Storage Service Class

      • DICOM Storage Commitment Service Class

      • DICOM Basic Worklist Management Service Class

      • DICOM Queue Management Service Class

      • Direct support for PACS

The Dicom Communication features also provide support for the following Command Sets, and their respective Command Elements.

  • C-STORE-REQUEST

  • C-STORE-RESPONSE

  • C-FIND-REQUEST

  • C-FIND-RESPONSE

  • C-GET-REQUEST

  • C-GET-RESPONSE

  • C-MOVE-REQUEST

  • C-MOVE-RESPONSE

  • C-CANCEL-REQUEST

  • C-ECHO-REQUEST

  • C-ECHO-RESPONSE

  • N-EVENT-REPORT-REQUEST

  • N-EVENT-REPORT-RESPONSE

  • N-GET-REQUEST

  • N-GET-RESPONSE

  • N-SET-REQUEST

  • N-SET-RESPONSE

  • N-ACTION-REQUEST

  • N-ACTION-RESPONSE

  • N-CREATE-REQUEST

  • N-CREATE-RESPONSE

  • N-DELETE-REQUEST

  • N-DELETE-RESPONSE

LEADTOOLS also provides a high-level Print Management SCU implementation that provides functions to handle all the SOP and Meta SOP Classes defined by the Print Management Service Class

Supported Platforms:

DICOM Communication – API

DICOM Communication – Class Library

DICOM Communication – COM Objects


DICOM Communication : API

DLL | LIB | Header File | Comments | Help File | Demo
LTDIC14N.DLL | LTDIC_N.LIB | LTDIC.H | The LEADTOOLS DICOM DLL provides functions for complete support of the DICOM 3.0 specification. | LTDICDLLN.CHM | \Examples\DLL\DICOMCLT \Examples\DLL\DICOMSRV \Examples\DLL\DICOMSTR


DICOM Communication : Class Library

Class | DLL | Header File | Comments | Help File | Demo
LDicomNet | LTDIC14N.DLL | LTDIC.H | The LEADTOOLS DICOM Class Library provides functions for complete support of the DICOM 3.0 specification. | LTDICLIBN.CHM | \Examples\ClassLib\MSVC5\DICOMCLT \Examples\ClassLib\MSVC5\DICOMSRV \Examples\ClassLib\MSVC5\DICOMSTR
LDicomPrintSCU | LTDIC14N.DLL | LTDIC.H | The LEADTOOLS DICOM Class Library provides properties, classes for implementing a DICOM Print SCU. | LTDICLIBN.CHM | \Examples\ClassLib\MSVC5\DICOMPRN


DICOM Communication : COM Objects

COM Object / Interface | Comments | Help File | Demo
LTDicNet14N.DLL ILEADDicomNet | The LEADTOOLS DICOM Communication COM Object provides properties, methods and events for complete support of the DICOM 3.0 specification. | LTDICCOMN.CHM | \Examples\COM\MSVC5\DICOMCLT \Examples\COM\VB\DICCLT32 \Examples\COM\MSVC5\DICOMSRV \Examples\COM\VB\DICSRV32 \Examples\COM\VB\DICSTR32 \Examples\COM\VB\DICSTRSCP32
LTDPrnSCU14N.DLL ILEADDicomNet | The LEADTOOLS DICOM Print SCU COM Object provides properties, methods and events for implementing a DICOM Print SCU. | LTDICCOMN.CHM | \Examples\COM\VB\DICPRN32


DICOM Annotation Features

The LEADTOOLS DICOM Annotation features provide support for saving LEADTOOLS annotations directly to and from a DICOM Data Set, as private data. This support lets you save multiple annotations to the same file, with password protection, and edit the annotations later. You can also convert to/from DICOM and LEAD Annotation objects.

Support platforms:

DICOM Annotation - API

DICOM Annotation - Class Library

DICOM Annotation - COM Objects


DICOM Annotation : API

The LEADTOOLS API provides functions for working with Annotations that are stored in DICOM DataSets as private data. This functionality also requires LTANN14N.DLL.

DLL | LIB | Header File | Help File
LTDIC14N.DLL | LTDIC_N.LIB | LTDIC.H | LTDICDLLN.CHM
LTFIL14N.DLL | LTFIL_N.LIB | LTFIL.H | LTDICDLLN.CHM


DICOM Annotation : Class Library

The LEADTOOLS DICOM Class Library provides functions for working with Annotations that are stored in DICOM DataSets as private data. This functionality also requires LTANN14N.DLL.

Class

Header File

Comments

Help File

Demo

LDicomDS

LTDIC.H

This class provides the main functionality for dealing with data sets. It includes functions for creating, initializing, loading and saving data sets. In addition, there are functions that allow you to do the following:

  • Maneuver through a data set

  • Search a data set

  • Insert or delete data set members

  • Retrieve or set data element values

  • Get or set information about the entire data set.

  • Convert values.

LTDICLIBN.CHM

\Examples\ClassLIb\MSVC5\DICOMANN


DICOM Annotation : COM Objects

COM Object / Interface | Comments | Help File
LTDicDS14N.DLL ILEADDicomDS | The LEADTOOLS DICOM COM Object contains properties, methods and events for working with Annotations that are stored in DICOM DataSets as private data. | LTDICCOMN.CHM


DICOM Security Features

LEADTOOLS Dicom Security features support the Secure Transport Connection Profiles as specified in part 15 of the DICOM 3 standard. This support includes the Basic TLS Secure Transport Connection Profile and ISCL Secure Transport Connection Profile to help integrators create DICOM applications with communication to be HIPPA compliant.

The LEADTOOLS DICOM Security features include:

  • Computer or Entity Authentication
  • Confidentiality
  • Data Integrity.
  • TLS using the Secure Hash Algorithm message authentication
  • Authentication based on RSA certificates
  • DES and triple DES (3DES) encryption mode
  • "Three-pass-four-way" mutual authentication protocol support
  • Ciphersuite negotiation.
  • DES-CBC encryption (ISCL standard DES encryption in cipher block chaining mode)
  • No encryption (ISCL standard)
  • DESMAC (64 bit) and MD5 (128 bit) message authentication codes (ISCL)
  • Support for the INTERNAL AUTHENTICATE command
  • Support for the EXTERNAL AUTHENTICATE command
  • Support for the GETCHALLENGE command
  • The ability to send secured or unsecured messages, regardless of the encryption mode

Supported platforms:

DICOM Security - API

DICOM Security - Class Library

DICOM Security – COM Objects


DICOM Security : API

DLL | LIB | Header File | Comments | Help File | Demo
LTDIC14N.DLL | LTDIC_N.LIB | LTDIC.H | The LEADTOOLS DICOM DLL provides support for the Secure Transport Connection Profiles as specified in part 15 of the DICOM 3 standard. | LTDICDLLN.CHM | \Examples\DLL\DICOMCLT \Examples\DLL\DICOMSRV


DICOM Security : Class Library

Class | DLL | Header File | Comments | Help File | Demo
LDicomNet | LTDIC14N.DLL | LTDIC.H | The LEADTOOLS DICOM Class Library provides support for the Secure Transport Connection Profiles as specified in part 15 of the DICOM 3 standard. | LTDICDLLN.CHM | \Examples\ClassLib\MSVC5\DICOMCLT \Examples\ClassLib\MSVC5\DICOMSRV


DICOM Security : COM Objects

COM Object / Interface | Comments | Help File | Demo
LTDicNet14N.DLL ILEADDicomNet | The LEADTOOLS DICOM Communication COM Object provides support for the Secure Transport Connection Profiles as specified in part 15 of the DICOM 3 standard. | LTDICCOMN.CHM | \Examples\COM\MSVC5\DICOMCLT \Examples\COM\VB\DICCLT32 \Examples\COM\MSVC5\DICOMSRV \Examples\COM\VB\DICSRV32


Medical Image Viewer Control

The LEADTOOLS Image Viewer Control provides support for displaying one or more images and for the real-time manipulation of one or more images. This type of control can be used for building medical display applications such as DICOM viewers, view stations and high-end diagnostic workstations found in radiology and other medical specialty departments. Support for this control is provided by the LTIVW DLL. Each container created has both a window handle and a handle to the container itself. A container has a number of properties that govern the appearance of the container and the cells, including the number of rows and columns in which cells are viewed. The maximum number of rows and columns allowed in a container is 4 X 8. While a container can have a maximum of 4 rows and 8 columns, the number of cells in a container is limited by the amount of available memory.

A container, or Image Viewer, may contain a number of child windows called cells. These cells may contain images, tags or rulers. A cell can have one or more images attached to it. Cells may also contain rulers. In addition to images and rulers, cells may also contain tags.

Actions are processes that can be applied to the images attached to cells within the container/image viewer. LEADTOOLS supports several standard or "built-in" actions and custom or "user-defined" actions. The built-in actions LEADTOOLS supports are listed below:

Window Leveling: Maps grayscale intensities using a user defined color map (LUT).

Alpha: A window-leveling factor used when the window leveling lookup table is not linear.

Scale: Increases or decreases the size of the image in the cell.

Offset: Changes the offset of the image within the cell.

Magnifying Glass: Magnifies the image in the cell.

Stack: Scrolls the images within the cell.

Custom actions are completely controlled by the user, including any mouse movement and keystroke association.


Medical Image Viewer Control : API

DLL | LIB | Header | Comments | Help Files
LTIVW14N.DLL | LTIVW_N.LIB | LTIVW.H | Provides functions supporting the Medical Image Viewer Control which can display one or more images and manipulate them in real-time. This control can be used for building medical display applications such as DICOM viewers, view stations and high-end diagnostic workstations found in radiology and other medical specialty departments. | LTDLLN.CHM

The LEADTOOLS API provides the lowest level of support for the Medical Image Viewer Control.


Medical Image Viewer Control : Class Library

Class | Header File | Comments | Help Files
LImageViewer | LTCImgViewer.h | The LImageViewer class is derived from the LBase class. This class contains base functionality for handling the Image Viewer Control. This class provides support for displaying one or more images and for the real-time manipulation of one or more images. This class can be used for building medical display applications such as DICOM viewers, view stations and high-end diagnostic workstations found in radiology and other medical specialty departments. | LTCLIBN.CHM

The LEADTOOLS Class Library provides low level support for the Medical Image Viewer Control.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Medical Image Viewer Control : COM

Medical Image Viewer Control COM Objects

COM Object / Interface | Comments | Help Files
LTRCVW14N.DLL - ILEADRasterContainerViewer | Provides support for displaying one or more images and for the real-time manipulation of one or more images. This COM object can be used for building medical display applications such as DICOM viewers, view stations and high-end diagnostic workstations found in radiology and other medical specialty departments. | LTCOMN.CHM


Medical Multimedia Filter Pack

The Medical Multimedia Filter Pack is a suite of DirectShow filters for compressing and decompressing video and audio data inside DICOM files. This product was designed to take out the complexity from converting cine images and video streams to DICOM objects including X-ray Angiography (XA), Ultrasound (US), Visible Light (VL), Secondary Capture (SC) and much more. The Medical Multimedia Filter Pack utilizes powerful compression algorithms like MPEG2 and JPEG2000, which are part of the DICOM Standard.

The Medical Multimedia Filter Pack includes two main components: the Writer and the Reader.

The Writer (encode video sequences in DICOM)

The writer component includes the DirectShow filters that are used for creating DICOM objects with compressed video and audio data.

Key Features:

  • Can create DICOM files with both video and audio using MPEG2 compression. The user can adjust the different attributes of the MPEG2 stream including bit rate and quality factor.

  • Can create DICOM files with video data (cine images) using lossy or lossless JPEG and JPEG 2000 compression with the option to adjust quality factor.

  • Can add video data to either an existing DICOM file or create a new one from a set of predefined DICOM classes or IODs.

  • Accepts 8-bit RGB, 24-bit RGB, 16-bit UYVY or 16-bit YUY2 data.

  • Includes a number of video processing filters including:

    • Auto Contrast.

    • Auto Intensity.

    • Auto Level.

    • Video Text Overlay.

    • Video Crop.

  • Can be used either with an existing application that uses DirectShow, or used programmatically from within the LEADTOOLS Medical Imaging toolkit.

Examples of DICOM objects that can be created using the Writer component:

  • Secondary Capture Multi-Frame True Color Image Storage.

  • Video Endoscopic Image Storage.

  • Video Photographic Image Storage.

  • Video Microscopic Image Storage.

  • Ultrasound Multi-frame Image Storage.

  • X-Ray Radiofluoroscopic Image.

  • X-Ray Angiographic Image Storage.

  • Secondary Capture Multi-frame Grayscale Byte Image Storage.

  • Secondary Capture Multi-frame Grayscale Word Image Storage.

MPEG2 encoding in DICOM:

MPEG-2 is a high quality video compression and is primarily targeted for applications that require higher bitrates or high bandwidth usage. The DICOM standard uses MPEG2 lossy compression with middle range quality, which typically delivers between 30 Mbytes and 60 Mbytes per minute of video.

The DICOM MPEG2 objects created using the writer fully adhere to the rules of MPEG2 encoding in DICOM which are described by the new transfer syntax “MPEG2 Main Profile @ Main Level” (1.2.840.10008.1.2.4.100).

Some of the typical modalities that can take advantage of MPEG2 encoding in DICOM include Endoscopy, Cardiology and Micro-surgery.

DirectShow filters included as part of the Writer component:

  • LEAD DICOM Write Filter.

  • LEAD MPEG-2 Standard Video Encoder.

  • LEAD MPEG-2 Multiplexer.

  • LEAD MCMP-MJPEG Video Codec.

  • LEAD Auto Contrast Filter.

  • LEAD Auto Intensity Filter.

  • LEAD Auto Level Filter.

  • LEAD RGB Converter.

  • LEAD Video Text Overlay Filter.

  • LEAD Video Crop Filter.

The Reader (play DICOM videos in any media player)

The reader component includes a set of DirectShow filters that register into the Windows collection of multimedia drivers and integrates with any application using DirectShow. Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize these filters to play video (cine) data in a DICOM file.

Key Features:

  • Can be used either with an existing application that supports DirectShow, or programmatically from the LEADTOOLS Medical Imaging toolkit.

  • Can play or Cine any DICOM file with any type of compression including MPEG2, lossy or lossless JPEG and JPEG 2000.

  • Achieves fast and optimized video decompression.

  • Provides playback options including control of the stream speed by changing the frame playback rate. In addition to the basic stream and speed control functionality, LEADTOOLS developers can "preview" a LEAD DICOM dataset in memory before saving to disk.

  • Supports DICOM Cine Playback - DICOM Cine Loop.

DirectShow filters included as part of the Reader component:

  • LEAD DICOM Read Filter.

  • LEAD MPEG-2 Video Decoder.

  • LEAD MPEG Audio Converter.


Additional Medical Imaging Features

The LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite provide support for some Image Display and Image Processing features that are not supported in the LEADTOOLS Raster Imaging Pro product. This additional support includes:

  • High-level display components for building DICOM viewers, view stations and high-end diagnostic workstations.

  • 12 and 16 bit grayscale image features, chosen and optimized to meet the specific demands of the medical imaging market.

  • 8-16 bit grayscale lossy and lossless JPEG and JPEG 2000 compression.

  • Support for DICOM MPEG2 compression.

  • TWAIN scanning (16-bit grayscale and up to 48-bit color).

  • Importing to/exporting from 10, 12 and 16-bit grayscale TIFF files and 48 and 64-bit color TIFF files.

  • Importing to/exporting from JFIF (JPEG) and JTIF (TIFF with JPEG) files compressed using 12-bit grayscale lossy or 16-bit lossless compression.

  • On-the-fly re-mapping of 10 –16 bit grayscale images to Windows display devices, using an LUT with pseudo color support.

  • Painting 10 - 16-bit images using Bilinear or Bi-cubic resizing on-the-fly.

  • 12 and 16 bit grayscale image processing and display with LUT and window leveling.

  • Support for saving the grayscale LUT information when the image is saved as a grayscale TIFF.

  • 16-bit Grayscale histograms.

  • Auto detection of the minimum and maximum intensity, and low and high bits used in the image data.

  • Conversion of 12 to 16- bit grayscale images to 8-bit or 24 bit.

  • Creating or loading 12 and 16- bit grayscale and 48 and 64 bit color images from raw data from disk, memory, or file offset.

  • Native support for signed images.

  • 16-bit image data in Intel or Motorola formats.

  • Image Overlays.

  • Support for modality LUT, VOI LUT and DICOM Palette Color Tables.

  • Support for digital subtraction.

  • Supports for local histogram equalize.

  • Support for multi-scale enhancement for CR images.

  • Finding the skeleton of regions or objects in a bitmap.

  • Support for extracting individual slices from a radiographic scanned filem (used with Medical Imagers and Digitizers).

  • MRI brain analysis tools.

Supported Platforms

Additional Medical Imaging ActiveX

Additional Medical Imaging API

Additional Medical Imaging – Class Library

Additional Medical Imaging COM

Additional Medical Imaging VCL


Additional Medical Imaging : ActiveX

OCX File | Comments | Help File
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing Additional Medical Imaging Features support. | LTOCXN.HLP


Additional Medical Imaging : API

DLL | LIB | Header | Comments | Help Files
LTDIS14N.DLL | LTDIS_N.LIB | LTDIS.H | Provides functions for implementing Additional Medical Imaging Features support. | LTDLLN.CHM
LTIMG14N.DLL | LTIMG_N.LIB | LTIMG.H | Provides functions for implementing Additional Medical Imaging Features support. | LTDLLN.CHM
LTKRN14N.DLL | LTKRN_N.LIB | LTKRN.H | Provides functions for implementing Additional Medical Imaging Features support. | LTDLLN.CHM

The LEADTOOLS API provides the lowest level of Additional Medical Imaging Features support.


Additional Medical Imaging : Class Library

Class | Header File | Comments | Help Files
LBitmapBase | LTCBBASE.H | Provides functions for implementing Additional Medical Imaging Features support. | LTCLIBN.CHM
LBitmap | LTCBTMAP.H | Provides functions for implementing Additional Medical Imaging Features support. | LTCLIBN.CHM

The LEADTOOLS Class Library provides low level support for Additional Medical Imaging Features.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Additional Medical Imaging : COM

Additional Medical Imaging COM Objects

COM Object / Interface | Comments | Help Files
LTRVW14N.OCX - ILEADRasterView | Provides properties, methods and events for implementing Additional Medical Imaging Features support. | LTCOMN.CHM
LTR14N.DLL - ILEADRaster | Provides properties, methods and events for implementing Additional Medical Imaging Features support. | LTCOMN.CHM
LTRPR14N.DLL - ILEADRasterProcess | Provides properties, methods and events for implementing Additional Medical Imaging Features support. | LTCOMN.CHM


Additional Medical Imaging : VCL

Compiler | Package | Help Files
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM

The LEADTOOLS Main control contains properties, methods and events for implementing Additional Medical Imaging Features support.


Internet/Intranet Imaging

LEADTOOLS features Net Aware ActiveX controls, COM objects, VCL controls and .NET Classes for Internet/intranet applications. The LEAD Main ActiveX control, VCL control and COM objects includes a BitmapDataPath feature, which allows images in any supported raster format to be read from any URL. Additionally, the ActiveX, VCL and COM objects also include an AnnDataPath feature, allowing LEADTOOLS annotation files to be loaded from any URL. The .NET Codecs classes can load/save to/from streams and URLs. LEADTOOLS includes support for Progressive JPEG, Progressive CMP, and interlaced GIF, so you can display images as they are downloaded. GIF support also includes transparency, animation, and embedded text. The GIF code has support for 1 through 8 bits per pixel files. A FeedLoad function is included to allow image data to be displayed as it is being transmitted across the net, providing Internet programmers with the fastest way to begin painting the client’s screen. LEADTOOLS Raster Imaging Pro, Multimedia Imaging Pro, Document Imaging products and Medical Imaging products include the above plus low over head COM objects with minimal DLL dependencies that can be used both client and server side. Additionally, HTTP and FTP controls are included to help you send information and images from the client back to the server. An INET control is included to create client server applications to control remote computers using remote procedure calls. On the server side it also includes an Upload control to assist the developer in properly getting the data. Examples for VBScript, JavaScript, and ASP/VBScript are included to assist you in incorporating images into Internet applications.

LEADTOOLS lets you do the following when working with the Internet:

  • Use the ActiveX, VCL, COM Object or .NET net-aware capabilities to load an image (stored in any of over 70 supported raster formats) asynchronously over the Internet. You can do this by specifying the URL in a single property.
  • Use Microsoft Internet Explorer to load, display, and save any of the image formats that LEADTOOLS supports.
  • Use LEAD controls in an ASP or ISAPI app to perform server side image processing.
  • Use LEAD controls in an ASP or ISAPI app to convert images from a non browser friendly format to a browser friendly one.
  • Use LEAD controls in an ASP or ISAPI app to get and put images into a database.
  • Submit images and information from any application that to a web server via an HTTP Form.
  • Upload images to an FTP server.
  • Parse the images and data out of the posted request string.
  • Use the LEAD controls on the client to perform any of the LEADTOOLS functionality via the LEADTOOLS ActiveX controls or COM objects.
  • Control how data is fed to a load routine.
  • Handle progressive reading and writing of JPEG and LEAD CMP files.
  • Handle transparency, interlaced formatting, and text in GIF files.
  • Create and maintain lists of bitmaps that are used for animation.
  • Create and play animations, read and write animated GIF files, and read AVI files.
  • Read and write most other image file formats that are transmitted on the Internet.
  • Create client/server applications, including video conferencing programs.
  • Send and Receive email.

Supported Platforms

Internet/Intranet Imaging ActiveX

Internet/Intranet Imaging API

Internet/Intranet Imaging Class Library

Internet/Intranet Imaging COM

Internet/Intranet Imaging VCL

Internet/Intranet Imaging .NET


Internet/Intranet Imaging : ActiveX

Internet/Intranet Imaging – ActiveX

OCX File | Comments | Help File | Demo
LTOCX14N.OCX | The LEADTOOLS Main ActiveX Control provides properties, methods and events to load files from a network source in an asynchronous manner. This includes FeedLoad and BitmapDataPath (URL) support. | LTOCXN.HLP | \Examples\OCX\MFC40\DEMO \Examples\OCX\VB\DEMO32
LTNET14N.OCX | The LEADTOOLS Internet ActiveX control contains properties, methods and events for creating client server applications that transfer data over the Internet or local intranets. | LTNETOCXN.HLP | \Examples\OCX\MFC40\NETCMD \Examples\OCX\VB\NETCMD32


Internet/Intranet Imaging : API

Internet/Intranet Imaging – API

DLL | LIB | Header | Comments | Help Files | Demo
LTFIL14N.DLL | LTFIL_N.LIB | LTFIL.H | Provides low-level functions that can be used to load files from a network source in an asynchronous manner (i.e. FeedLoad). | LTDLLN.CHM | \Examples\DLL\FEEDLOAD \Examples\DLL\LTISAPI
LTNET14N.DLL | LTNET_N.LIB | LTNET.H | Provides functions for creating client server applications that transfer data over the Internet or local intranets. | LTNETDLLN.CHM | \Examples\DLL\NETCMD
LTWEB14N.DLL | LTWEB_N.LIB | LTWEB.H | Provides functions for communicating with HTTP and FTP servers. | LTFTPDLLN.CHM |
LTEML14N.DLL | LTEML_N.LIB | LTEML.H | Provides functions for communicating with SMTP eMail servers to create, send and receive eMail messages. | LTEMLDLLN.CHM | \Examples\DLL\EMLDEMO

The LEADTOOLS API provides the lowest level of Internet/Intranet Imaging support.


Internet/Intranet Imaging : Class Library

Internet/Intranet Imaging – Class Library

Class | Header File | Comments | Help Files | Demo
LFile | LTCFILE.H | The LFile class is derived from LBaseFile and extends it to provide low-level functions that can be used to load files from a network source in an asynchronous manner (i.e. FeedLoad). | LTCLIBN.CHM | \Examples\ClassLib\MSVC5\FEEDLOAD
LInet | LTCINET.H | The LInet class provides Internet functions that allow you to create client server applications that transfer data over the Internet or local intranets. It includes functions for handling connections via network, and reading and sending data. This class also includes functions to control a list of computers connected to the local computer. | LTNETLIBN.CHM | \Examples\ClassLib\MSVC5\NETCMD
LInetPacket | LTCINET.H | The LInetPacket class provides Internet packet functions that allow you to create packet objects that contain information used in sending commands and responses. It includes functions for setting a binary chunk of data and setting a variable number of parameters and their associated types. Both the binary chunk of data and the parameter data are optional. | LTNETLIBN.CHM | \Examples\ClassLib\MSVC5\NETCMD

The LEADTOOLS Class Library provides low level support for Internet/Intranet Imaging support.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


Internet/Intranet Imaging : COM

Internet/Intranet Imaging – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRIO14N.OCX - ILEADRasterIO | The LEADTOOLS Raster IO object provides properties, methods and events to load files from a network source in an asynchronous manner. This includes FeedLoad and BitmapDataPath (URL) support. | LTCOMN.CHM | \Examples\COM\MSVC5\DEMO \Examples\COM\VB\DEMO32
LTRNT14N.DLL - ILeadNet | The LEADTOOLS Internet ActiveX control contains properties, methods and events for creating client server applications that transfer data over the Internet or local intranets. | LTNETCOMN.CHM | \Examples\COM\MSVC5\NETCMD \Examples\COM\VB\NETCMD32
LTRHT14N.DLL - ILEADRasterHTTP | Provides properties, methods and events for communicating with HTTP servers. | LTFTPCOMN.CHM |
LTRFT14N.DLL - ILEADRasterHTTP | Provides properties, methods and events for communicating with FTP servers. | LTFTPCOMN.CHM |
ltupl14N.DLL – ILEADUpload | The LEAD Upload component can be used on a server to allow users to upload files to a web site. Web administrators can allow users to upload a file or files by having an HTML form available that specifies "multipart/form-data" as the enctype. | LTUPLCOMN.CHM |
LTCML14N.DLL - ILEADSmtp | Provides properties, methods and events for communicating with SMTP eMail servers to create, send and receive eMail messages. | LTEMLCOMN.CHM | \Examples\COM\MSVC5\EMLDEMO \Examples\COM\VB\EMLDMO32


Internet/Intranet Imaging : VCL

Internet/Intranet Imaging – VCL

Compiler | Package | Help Files | Demo
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM | \Examples\VCL\Builder\DEMO \Examples\VCL\Delphi\DEMO

The LEADTOOLS Main control contains properties, methods and events to load files from a network source in an asynchronous manner. This includes FeedLoad and BitmapDataPath (URL) support.


Internet/Intranet Imaging : .NET

Internet/Intranet Imaging – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.Codecs.DLL | The Leadtools.Codecs namespaces provides classes to load files from a network source in an asynchronous manner. This includes FeedLoad and stream (URL) support. | LTNET.CHM | \Examples\CS\MainDemo \Examples\VB\MainDemo \Examples\CS\FeedLoadDemo \Examples\VB\FeedLoadDemo


OCR

LEADTOOLS' OCR engine is based upon the time-tested industry standard ScanSoft Capture Development System v12 engine.

LEADTOOLS OCR engine brings together a considerable number of recognition modules:

  • MTX, FRX, MOR and the PLUS2W and PLUS3W omnifont modules for the recognition of different machine-generated texts.
  • HNR and RER modules for handprint recognition.
  • DOT module for 9-pin draft dot-matrix printouts.
  • OMR module for optical mark recognition.
  • MAT module for fixed-font texts (MICR or E-13B, OCR-A, OCR-B, etc.).

Through the MOR, PLUS2W and PLUS3W multi-lingual recognition modules, the LEADTOOLS OCR Engine supports over 110 languages, including languages that use the Latin, Cyrillic and Greek and related alphabets.

Besides recognition, the LEADTOOLS OCR Engine offers all LEAD File formats as an input.

The LEADTOOLS OCR Engine can deliver precise coordinate, confidence and attribute data for each recognized character, giving the application great control over the formatting of the output text - at one extreme mirroring the input document, at the other permitting a unique user-defined style.

In addition to the above new recognition modules, the LEADTOOLS OCR engine supports the following new features:

  1. Import and export all image file formats supported by LEADTOOLS.
  2. You can recognize the entire page area as one zone, and you can specify zones in each page, and recognize them all.
  3. You can specify a different recognition module for each zone in the same page.
  4. The optional PDF Output kit offers five PDF converters to produce different types of PDF outputs including image-only, searchable, and other PDF output files.
  5. The engine lets you to create your dictionary to use it with the recognition process.
  6. You can specify the dictionary that you need to use, and the spell languages that will be used for the checking subsystem (confidence).
  7. And more...

Supported Platforms

OCR API

OCR COM

OCR .NET


OCR : API

OCR – API

DLL | LIB | Header | Help Files | Demo
LTOCR14N.DLL | LTOCR_N.LIB | LTOCR.H | LTOCRDLLN.CHM | \Examples\DLL\OCR \Examples\DLL\FINDZONES \Examples\DLL\HNRNUM \Examples\DLL\HNRTEXT \Examples\DLL\MICR \Examples\DLL\MOR \Examples\DLL\OCRFILE \Examples\DLL\OCRMEM \Examples\DLL\RECCHARS

The LEADTOOLS API provides the lowest level of OCR functionality.


OCR : .NET

OCR – COM Objects

COM Object / Interface | Comments | Help Files | Demo
LTRDC14N.DLL - ILEADRasterDocument | The LEADTOOLS OCR COM Object contains properties, methods and events for implementing OCR functionality. | LTOCRCOMN.CHM | \Examples\COM\MSVC5\OCR \Examples\COM\VB\OCR \Examples\COM\MSVC5\FINDZONES \Examples\COM\VB\FINDZONES \Examples\COM\MSVC5\HNRNUM \Examples\COM\VB\HNRNUM \Examples\COM\MSVC5\HNRTEXT \Examples\COM\VB\HNRTEXT \Examples\COM\MSVC5\MICR \Examples\COM\VB\MICR \Examples\COM\MSVC5\MOR \Examples\COM\VB\MOR \Examples\COM\MSVC5\OCRFILE \Examples\COM\VB\OCRFILE \Examples\COM\MSVC5\OCRMEM \Examples\COM\VB\OCRMEM \Examples\COM\MSVC5\RECCHARS \Examples\COM\VB\RECCHARS

This version of the LEADTOOLS OCR COM object is designed to work directly with the LEADTOOLS COM Objects.


OCR : COM

OCR – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.Ocr.dll - Leadtools.Ocr | The Leadtools.Ocr namespace contains classes for implementing OCR functionality. | LTNET.CHM | \Examples\CS\OcrDemo \Examples\VB\OcrDemo \Examples\CS\FindZones \Examples\VB\FindZones \Examples\CS\HNRNUM \Examples\VB\HNRNUM \Examples\CS\HNRTEXT \Examples\VB\HNRTEXT \Examples\CS\MICR \Examples\VB\MICR \Examples\CS\MOR \Examples\VB\MOR \Examples\CS\OCRFILE \Examples\VB\OCRFILE \Examples\CS\OCRMEM \Examples\VB\OCRMEM \Examples\CS\RECCHARS \Examples\VB\RECCHARS


Barcodes

The LEADTOOLS Barcode Modules allow you to read and write Linear (1D) Standard and Advanced modules, DataMatrix (2D), QR (2D), and PDF417 (2D) barcodes with support for 95 different sub-types. Your applications can read multiple barcodes at any orientation using a scanner or camera with frame-grabber, write barcodes to any supported raster image file or to any windows compliant printer, encode thousands of characters per barcode symbol with 2D barcode technology, read barcodes from or write barcodes to selected regions of interest. Integrate our extensive image processing technologies for complete control over your barcode recognition process.

Barcode Modules:

Programming Linear (1D) Standard and Advanced modules, DataMatrix (2D), QR (2D), and PDF 417 (2D) Barcodes

  • Read multiple barcodes at any orientation

  • Write barcodes to any of over 140+ supported raster image file format or to any windows compliant printer

  • Encode thousands of characters per barcode symbol with 2D barcode technology

  • Read barcodes from or write barcodes to selected regions of interest

  • Read barcodes with specified colors

  • Write barcodes with specified colors

  • Integrate LEADTOOLS' extensive image processing technologies for complete control over your barcode recognition process.

Chart below shows features of each module:

LEADTOOLS BARCODE
SDK ADD-ON MODULES

Read from region of interest

Write to region of interest

Read skewed

Read at any orientation

High density information encoding

Error correction

LEADTOOLS 1D Symbols (read and write)

Standard/Advanced*

  • Automatic barcode type detection

  • Read to / write from region of interest

  • Read in four basic directions.

  • Read skewed.

  • Read multiple barcode symbols.

  • Read mixed barcode types Report back X/Y positions.

  • Write barcode symbol with size and position parameters.

  • Check character handling.

Sub-types supported:

  • EAN 13

  • EAN 8

  • UPC A

  • UPC E

  • Code 39

  • Code 128

  • Interleaved 2 of 5

  • CODABAR

  • UCCEAND 128 (read only)

* The Standard version runs at approximately one-fifth the speed of the Advanced version.

Barcode 2D DataMatrix (read)

Barcode 2D DataMatrix (write)

  • Contains Error Correction Code (ECC) to fix damaged barcode symbols.

  • Reads and writes color and gray symbols

  • Store up to 2,218 ASCII characters in one barcode symbol, chain symbols to encode up to 33,225 characters..

  • (Read module) Read barcodes independent of skew, orientation, flipping. Read barcodes from region of interest, contained in any supported image file format (over 140 supported), acquired from scanner or digital camera.

  • (Write module) Write to any supported raster format (over 140) into region of interest, print to any Windows compliant printer.

Sub-types supported:

  • Default DataMatrix Size

  • DataMatrix size 10x10

  • DataMatrix size 12x12

  • DataMatrix size 14x14

  • DataMatrix size 16x16

  • DataMatrix size 18x18

  • DataMatrix size 20x20

  • DataMatrix size 22x22

  • DataMatrix size 24x24

  • DataMatrix size 26x26

  • DataMatrix size 32x32

  • DataMatrix size 36x36

  • DataMatrix size 40x40

  • DataMatrix size 44x44

  • DataMatrix size 48x48

  • DataMatrix size 52x52

  • DataMatrix size 64x64

  • DataMatrix size 72x72

  • DataMatrix size 80x80

  • DataMatrix size 88x88

  • DataMatrix size 96x96

  • DataMatrix size 104x104

  • DataMatrix size 120x120

  • DataMatrix size 132x132

  • DataMatrix size 144x144

  • DataMatrix size 8x18

  • DataMatrix size 8x32

  • DataMatrix size 12x26

  • DataMatrix size 12x36

  • DataMatrix size 16x36

  • DataMatrix size 16x48

  • DataMatrix Default Rectangular size

Portions of Barcode Module, © Axtel Inc.,1999

Barcode 2D PDF 417 (read)

Barcode 2D PDF 417 (write)

  • Store up to 1,815 ASCII characters in one barcode symbol.

  • Contains Error Correction Code (ECC) to fix damaged barcode symbols.

  • (Read module) Read barcodes independent of skew, orientation, flipping. Read barcodes from region of interest, contained in any supported image file format (over 140 supported), acquired from scanner or digital camera.

  • (Write module) Write to any supported raster format (over 140) into region of interest, print to any Windows compliant printer.

Portions of Barcode Module, © Axtel Inc.,1999

Barcode 2D QR (read)

Barcode 2D QR (write)

  • SDK to create QR Code type of barcode symbols from alpha/numerical text.

  • Includes Error Correction Code (ECC), which eliminates possibility of corrupted read data.

  • Stores up to 2,335 ASCII characters in one barcode symbol.

  • Uses Error Correction Code (ECC) to fix damaged barcode symbols.

  • (Read module) Read barcodes independent of skew, orientation, flipping. Read barcodes from region of interest, contained in any supported image file format (over 140 supported), acquired from scanner or digital camera.

  • (Write module) Write to any supported raster format (over 140) into region of interest, print to any Windows compliant printer.

Sub-types supported:

  • QR Default size

  • QR Model 2 Version 1

  • QR Model 2 Version 2

  • QR Model 2 Version 3

  • QR Model 2 Version 4

  • QR Model 2 Version 5

  • QR Model 2 Version 6

  • QR Model 2 Version 7

  • QR Model 2 Version 8

  • QR Model 2 Version 9

  • QR Model 2 Version 10

  • QR Model 2 Version 11

  • QR Model 2 Version 12

  • QR Model 2 Version 13

  • QR Model 2 Version 14

  • QR Model 2 Version 15

  • QR Model 2 Version 16

  • QR Model 2 Version 17

  • QR Model 2 Version 18

  • QR Model 2 Version 19

  • QR Model 2 Version 20

  • QR Model 2 Version 21

  • QR Model 2 Version 22

  • QR Model 2 Version 23

  • QR Model 2 Version 24

  • QR Model 2 Version 25

  • QR Model 2 Version 26

  • QR Model 2 Version 27

  • QR Model 2 Version 28

  • QR Model 2 Version 29

  • QR Model 2 Version 30

  • QR Model 2 Version 31

  • QR Model 2 Version 32

  • QR Model 2 Version 33

  • QR Model 2 Version 34

  • QR Model 2 Version 35

  • QR Model 2 Version 36

  • QR Model 2 Version 37

  • QR Model 2 Version 38

  • QR Model 2 Version 39

  • QR Model 2 Version 40

  • QR Model 1 Version 1

  • QR Model 1 Version 2

  • QR Model 1 Version 3

  • QR Model 1 Version 4

  • QR Model 1 Version 5

  • QR Model 1 Version 6

  • QR Model 1 Version 7

  • QR Model 1 Version 8

  • QR Model 1 Version 9

  • QR Model 1 Version 10

  • QR Model 1 Version 11

  • QR Model 1 Version 12

  • QR Model 1 Version 13

  • QR Model 1 Version 14

  • QR Model 1 Default size

Supported Platforms

Barcodes ActiveX

Barcodes API

Barcodes Class Library


Barcodes : ActiveX

Barcodes – ActiveX

OCX File | Comments | Help File | Demo
LTBAR14N.OCX | The LEADTOOLS Barcode ActiveX control contains properties, methods and events for implementing Barcode Recognition. | LTBAROCXN.HLP | \Examples\OCX\MFC40\BARCODE \Examples\OCX\VB\BARCODE32


Barcodes : API

Barcodes – API

The LEADTOOLS Barcode API provides the lowest level of Barcode Recognition functionality.

DLL | LIB | Header | Help File | Demo
LTBAR14N.DLL | LTBAR_N.LIB | LTBAR.H | LTBARDLLN.CHM | \Examples\DLL\BARCODE


Barcodes : Class Library

Barcodes – Class Library

The LEADTOOLS Barcode Class Library DLL module uses LTKRN14N.DLL and LTBAR14N.DLL.

Class | Header File | Comments | Help File | Demo
LBarCode | LTCBAR.H | The LEADTOOLS Barcode Class Library contains functions for implementing Barcode Recognition. | LTBARLIBN.CHM | \Examples\ClassLib\MSVC5\BARCODE


PDF

PDF and Advanced PDF

PDF

The LEADTOOLS PDF Plug-in is an add-on module for all LEADTOOLS Toolkits with the exception of the Linux versions and extends support to include the PDF, Postscript, and EPS formats. The LEADTOOLS PDF SDK Plug-in supports the loading saving, viewing, rasterizing, and encoding of these three formats and integrates seamlessly with the broad imaging functionality present in the existing LEADTOOLS toolkits, encompassing specialized display, color-conversion, image-processing, scanning, annotations, document clean-up, and much more.

Loading Capabilities

The LEADTOOLS PDF plug-in has the following import capabilities:

  • Loads PDF 1.3 files.

  • Loads PostScript Language Level 3 files.

  • Loads EPS files.

  • Support is provided for loading the entire document or a specified set of sequential pages.

The plug-in provides a number of options for controlling the rasterization of the page, including:

  • Pixel depth - Valid values are 1,4,8 and 24.

  • Horizontal resolution in dots per inch.

  • Vertical resolution in dots per inch.

  • Ability to use fonts installed by the plug-in or system fonts.

  • Font anti-aliasing - Valid values are 1-bit(no anti-aliasing) , 2-bit and 4-bit.

  • Graphics anti-aliasing - 1-bit , 2-bit and 4-bit.

Saving Capabilities

Full multi-page write support is provided by this module for the PDF format. You can append, insert, replace or delete a specified page in the generated PDF file.

The plug-in gives you a wide range of control options for the resulting image data in terms of compression. These include:

  • No compression, where the image is embedded inside the file without any compression.

  • Compressed using CCITT Group 3, 1 dimension. For 1-bit images.

  • Compressed using CCITT Group 3, 2 dimensions. For 1-bit images.

  • Compressed using CCITT Group 4. For 1-bit images.

  • JPEG compression and YUV 4:4:4 color space loss-less. Bits per pixel: 8 for grayscale, 24 for color.

  • JPEG compression and YUV 4:2:2 color space. Bits per pixel: 8 for grayscale, 24 for color.

  • JPEG compression and YUV 4:1:1 color space. Bits per pixel: 8 for grayscale, 24 for color.

  • The plug-in also gives you control over the type of encoding to be used in order to change compressed image data into a text encoded format. The text encoding techniques include:

    • No text encoding at all.

    • Use ASCII 85 text encoding algorithm.

    • Use ASCII HEX text encoding technique.

Advanced PDF Compression

The PDF Plug-in supports PDF compression through the PDF Compressor. Through MRC segmentation, this compressor can be used to break down a page/image into smaller segments, saving each segment using compression appropriate for that segment. Thus, one page of a PDF file may have an image that is compressed using JPEG compression, some text that is compressed using JBIG2 compression, and another area that is compressed using CCITT compression. This whole process works to provide a PDF file with better compression and better quality than just a standard Raster PDF file.

Advanced PDF Compression includes the following features:

  • Supports many compression types, including:

      • ZIP (Flate compression)

      • LZW

      • FAX CCITT (G3 1D, G3 wD, G4)

      • JBIG2

      • Lossless JPEG

      • JPEG (YUV 4.4.4, YUV 4.2.2 and YUV 4.1.1)

  • Works in the following 2 modes at the page level:

      • MRC mode: enables the segmentation of the source image and then compresses the resulting segments

      • Normal mode: inserts the image into the PDF file without segmentation

  • Produces v1.4 (Adobe Acrobat 5.X) PDF files

  • Provides advanced options to control the process of adding the segments to the PDF file

  • Provides input profiles to specify source image quality. This makes controlling the segmentation process more accurate and simple. The following input profiles are supported:

      • Automatic: the PDF compressor automatically handles the process

      • Noisy

      • Scanned

      • Printed

      • Computer-generated

      • Photo

      • User: this profile is provided for advanced users

  • Provides output profiles to specify the required output quality. This should also make the segmentation process easier and more accurate. The following output profiles are supported:

      • Automatic: the PDF compressor automatically handles the process

      • Poor

      • Average

      • Good

      • Excellent

      • User: this profile is provided for advanced users

  • Provides control over the compression types that will be used with each type of segment. For example, FAX CCITT G4 compression to handle 1 bit/pixel segments.

  • Supports background detection, where the PDF compressor tries to determine the background of the provided image. With background detection, the background segments are not stored, resulting in a more compact PDF file.

  • Provides control over 1 bit and 2 bit segment detection. Detection can be set to favor 1 bit segments over 2 bit segments, and vice versa. Or, detection can be forced to 1 bit segments over 1 bit segments and vice versa.

Supported Platforms

PDF - ActiveX

PDF and Advanced PDF - API

PDF and Advanced PDF - Class Library

PDF and Advanced PDF - COM

PDF VCL

PDF and Advanced PDF .NET


PDF : ActiveX

PDF – ActiveX

OCX File | Comments | Help File
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing PDF support. | LTOCXN.HLP

PDF support also requires the PDF LEAD File Format Filter DLL, LFPDF14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


PDF : API

PDF and Advanced PDF – API

DLL | LIB | Header | Comments | Help Files | Demo
LTFIL14N.DLL | LTFIL_N.LIB | LTFIL.H | Provides both low and high-level functions that can be used to load/save image files. These functions allow you to work with ‘files’ in memory buffers or at offsets within disk files. | LTDLLN.CHM |
LFJBG14N.DLL | N/A | N/A | Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL. | LTDLLN.CHM |
LCMRC14N.DLL | LCMRC_N.LIB | LPDFCOMP.H | Provides high-level and low-level APIs to control the LEADTOOLS PDFCompressor behavior (Advanced PDF). | LTMRCDLLN.CHM | Examples\DLL\PDFCOMPBATCH \Examples\DLL\PDFCompDemo

The LEADTOOLS API provides the lowest level of PDF and Advanced PDF support.


PDF : Class Library

PDF and Advanced PDF – Class Library

Class | Header File | Comments | Help Files | Demo
LBaseFile | LTCFILE.H | The LBaseFile class is derived from LBase. This class is the base class for LEADTOOLS Class Library input/output operations. It contains basic operations for file I/O. With this class, you can override the default functions that LEADTOOLS uses for opening, closing, reading from, writing to, and seeking in files. This class forms the base for the LFile and LMemoryFile classes. | LTCLIBN.CHM |
LFile | LTCFILE.H | The LFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files on disk. | LTCLIBN.CHM |
LPDFCompressor | LTCPDFComp.H | The LPDFCompressor class provides properties, methods, and events to control the Advanced PDF functionality of the LEADTOOLS PDF Compressor behavior. | LTCLIBN.CHM | \Examples\CLASSLIB\MSVC5\PDFCompDemo

The LEADTOOLS Class Library provides low level support for PDF and Advanced PDF.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.

PDF support also requires the PDF LEAD File Format Filter DLL, LFPDF14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


PDF : COM

PDF and Advanced PDF – COM Objects

COM Object / Interface | Comments | Help Files
LTRIO14N.DLL - ILEADRasterIO | The LEADTOOLS Raster IO object provides support for File Formats. | LTCOMN.CHM
LTRPC14N.DLL - ILEADPDFCompressor | This interface provide the user with Advanced PDF methods and properties to control the behavior of the PDFCompressor. | LTCOMN.CHM
LTRPC14N.DLL -ILTSegmentInfo | This interface provides the user with Advanced PDF methods and properties to control/provide information about image segments. | LTCOMN.CHM

PDF support also requires the PDF LEAD File Format Filter DLL, LFPDF14S.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


PDF : VCL

PDF – VCL

Compiler | Package | Help Files
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM

The LEADTOOLS Main control contains properties, methods and events for implementing PDF support.

PDF support also requires the PDF LEAD File Format Filter DLL, LFPDF14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


PDF : .NET

PDF and Advanced PDF – .NET

Assembly – Class/Namespace | Comments | Help Files | Demo
Leadtools.Codecs.DLL - CodecsPdfOptions | The CodecsPdfOptions Class contains properties, methods and events for loading and saving PDF files. | LTNET.CHM |
Leadtools.Pdf.dll - Leadtools.Pdf.PdfCompressor | The PDfCompressor class provides the users with Advanced PDF methods to control the creation of PDF documents with or without segmentation. | LTNET.CHM | \Examples\DOTNET\CS\PdfCompDemo \Examples\DOTNET\VB\PdfCompDemo
Leadtools.Pdf.dll - Leadtools.Pdf.PdfCompressorSegmentsInfo | The PdfCompressorSegmentsInfo structure provides the Advanced PDF user with the ability to get or set the information related to image segments. | LTNET.CHM |
Leadtools.Pdf.dll - Leadtools.Pdf.PdfCompressorCompressionTypes | The PdfCompressorCompressionTypes structure provides the Advanced PDF user with control over the types of compressions that can be used for each type of image segments. | LTNET.CHM |
Leadtools.Pdf.dll - Leadtools.Pdf.PdfCompressorOptions | The PdfCompressorOptions structure provides the Advanced PDF user with control over how the PDFCompressor will do the segmentation for the provided image and controls its behavior. | LTNET.CHM |
Leadtools.Pdf.dll - Leadtools.Pdf.PdfCompressorSegmentImageEventArgs | The PdfCompressorSegmentImageEventArgs class enables the Advanced PDF user to approve or cancel the addition of any segment to the document. | LTNET.CHM |

The Leadtools.Codecs namespaces provides support for PDF.

PDF support also requires the PDF LEAD File Format Filter DLL, Leadtools.Codecs.Pdf.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


Multimedia

The LEADTOOLS Multimedia LE toolkit includes everything you need to create powerful and impressive multimedia applications. With LEADTOOLS Multimedia LE you can add multimedia functionality using almost any development environment because it includes multimedia ActiveX controls, multimedia COM objects and multimedia DLL APIs. Buy it now to start rapidly developing applications that impress your end users with high quality multimedia functionality.

With LEADTOOLS Multimedia LE you get:

  • Multimedia Capture
    Create applications that can capture from WDM, native DirectShow including DV, and Video for Windows capture devices and more ...
  • Multimedia Playback
    Create applications that can play all formats supported by DirectShow and more ...
  • Multimedia Processing
    Add to your applications the ability to process AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats or data as it is captured using DirectX filters.
  • Multimedia Compression
    Add support to your applications for compressing individual samples with any available DirectShow filters (Memory to memory).
  • Multimedia Conversion
    Add features to your application so your users can convert to and from AVI, Windows Media content, WAVE, and MPEG1Audio (MP3) formats.
  • Multimedia File Formats
    Add support for the most popular multimedia formats.
  • DirectX Filters
    LEADTOOLS Multimedia toolkits include a DirectX filter pack (5 client licenses) that includes powerful multimedia processing functionality. For pricing for additional client licenses, contact OEMSales@LEADTOOLS.com.

Supported Platforms

Multimedia ActiveX

Multimedia API

Multimedia COM


Multimedia : ActiveX

Multimedia – ActiveX

OCX Control | Comments | Help File | Demo
ltmmCaptureCtrl Class | The ltmmCaptureCtrl Object is a COM object that allows the user to capture audio and video from hardware devices. | LTMMCOMN.CHM | \Examples\VB\capture
ltmmConvertCtrl Class | The ltmmConvertCtrl Object is an ActiveX object that allows the user to change from one media format to another. | LTMMCOMN.CHM | \Examples\VB\convert
ltmmPlayCtrl Class | The ltmmPlayCtrl Object is a COM object that allows the user integrate audio and video playback into their application. | LTMMCOMN.CHM | \Examples\VB\player

The LEADTOOLS Multimedia DLL LTMM_N.DLL contains 3 ActiveX controls that provide properties, methods and events for implementing Multimedia functionality.


Multimedia : API

Multimedia – API

DLL | LIB | Header | Comments | Help Files | Demo
LTMM_N.DLL | ltmmuuid.lib | LTMM.H | LEADTOOLS Multimedia API provides dynamic link library (DLL) functions for performing the following: Capturing audio or video data to a file. Capturing audio or video data to a sample. Play an audio, video or multimedia sample. Play an audio, video or multimedia file. Convert an audio, video or multimedia file to another file type. Convert an audio, video or multimedia file to a multimedia sample. Convert a multimedia sample to another multimedia sample. Convert a multimedia sample to a multimedia file. | LTMMDLLN.CHM | \Examples\C\capture \Examples\C\convert \Examples\C\player \Examples\CPP\capture \Examples\CPP\convert \Examples\CPP\player

The LEADTOOLS API provides the lowest level of Multimedia support.


Multimedia : COM

Multimedia – COM Objects

Control | Comments | Help Files | Demo
ltmmCaptureCtrl Class | The ltmmCaptureCtrl Object is a COM object that allows the user to capture audio and video from hardware devices. | LTMMCOMN.CHM | \Examples\VB\capture \Examples\VB\convert \Examples\VB\player
ltmmConvertCtrl Class | The ltmmConvertCtrl Object is an ActiveX object that allows the user to change from one media format to another. | LTMMCOMN.CHM | \Examples\VB\capture \Examples\VB\convert \Examples\VB\player
ltmmPlayCtrl Class | The ltmmPlayCtrl Object is a COM object that allows the user integrate audio and video playback into their application. | LTMMCOMN.CHM | \Examples\VB\capture \Examples\VB\convert \Examples\VB\player


Multimedia DirectShow Filters

Video Filters

Feature | Filter/Interface(s) | Header | Comments | Help Files
Encryption / Decryption | LMEncrypt.DLL - ILMEncrypt | ILMEncrypt.h | The filter encrypts and decrypts any type of media. This filter supports the DES-Directshow editing services. | LTFILTERS.CHM
Video Add | LMVAdd.DLL - ILMVAdd, ILMVAddDisp | ILMVAdd.h | The add filter can be used for enhancing night vision or dropping more light on dark sources to clarify objects. The effect is performed in 2 ways, the first yields a frame rate divided by the number of added frames, while the other almost preserves the frame rate by using previous frames to output each sample. The output is of course not the same from the two methods. The filters functionality is exposed through both user and programming interfaces. | LTFILTERS.CHM
Video Color | LMVClr.DLL - ILMVColor | ILMVClr.h | The Color filter provides the ability to change some color attributes of the streaming video. The filter can change the video brightness, contrast, hue, and saturation, in addition to an invert colors option. The above changes can be applied to a selected area (rectangle) only by changing the "Effect Area" attributes in the property page or using SetCropAttributes from the programming interface. | LTFILTERS.CHM
Video Crop | LMVCrop.DLL - ILMVCrop, ILMVCropDisp | ILMVCrop.h | The Crop filter is used to extract areas from a source movie, a graphical representation is provided to show and modify the desired rectangle position and size. The cropped rectangle can be as small as 1x1. The filter’s functionality is exposed through both user and programming interfaces. | LTFILTERS.CHM
Video Deinterlace | LMVDeitr.DLL - ILMVDeinterlace, ILMVDeinterlaceDisp | ILMVDeinterlace.h | The deinterlace filter converts interlaced video to make it a progressive scan video. Analog, interlaced video is what devices like VCRs, laserdiscs, and game consoles output. | LTFILTERS.CHM
Video Emboss | LMVEmbs.DLL - ILMVEmboss, ILMVEmbossDisp | ILMVEmboss.h | This filter offers embossing a video stream providing different parameters to control the effect. The effect can be applied to a selected area (rectangle) only by changing the "Effect Area" attributes in the property page or using SetCropAttributes from the programming interface. | LTFILTERS.CHM
Video Gamma Correction | LMVGamma.DLL - ILMVGamma | ILMVGamma.h | This filter performs gamma correction to a video stream. Possible gamma values are between 1 and 500. | LTFILTERS.CHM
Video Histogram Equalize | LMVHstg.DLL - ILMVHistogEq | ILMVHstg.h | This filter performs Histogram Equalization to a video stream. Equalization can be done for a single channel; Red, Green, or Blue, or for all channels; master. | LTFILTERS.CHM
Video Histogram View | LMVHstg.DLL - ILMVHistogVw | ILMVHstg.h | Histogram View filter draws the running histogram of a video stream in its property page. The filter also provides access to the histogram array through its programming interface. The histogram can be viewed for a single channel or for all channels. | LTFILTERS.CHM
Video Mosaic | LMVMosc.DLL - ILMVMosaic, ILMVMosaicDisp | ILMVMosaic.h | Mosaic effect transforms any image into something that looks as though it were created by positioning a number of tiling elements, each of constant color and an approximate size. This filter applies the mosaic effect to a video stream with the ability to set the mosaic square size. The mosaic effect can be applied to a selected area (rectangle) only by changing the "Effect Area" attributes in the property page or using SetCropAttributes from the programming interface. | LTFILTERS.CHM
Video Resize | LMVRsz.DLL - ILMVResize | ILMVRsz.h | The Resize filter is used to change the dimensions of a source movie; the result is a new media, with new dimensions and size. The resize filter offers three types of resizing algorithms; Resample, Bicubic interpolation, and Normal. The user interface, as will as the programming interface, friendly enable the selection of the filter parameters; Width, Height, Keep aspect ratio, etc. In addition to the ability to select any desired size through specifying the width and height, the user can select a ratio size (i.e. 2X, Normal, X/2, ...). | LTFILTERS.CHM
RGB Converter | LMVRGBxf.DLL - ILMVConvRGB | ILMVRGB.h | This is an RGB color space converter that supports conversion between different RGB formats. The filter supports the following formats: RGB8 (gray and palettized), RGB565, RGB555, RGB24, and RGB32. The input or output format can be set to AUTO, to enable free negotiation with the up or down stream filter. The filter’s functionality is exposed through both user and programming interfaces. | LTFILTERS.CHM
Video Rotation | LMVRot.DLL - ILMVRotation | ILMVRot.h | The Rotation filter enables rotating a video stream by the standard angles; 0, 90, 180, and 270 in addition to flip and reverse options. The filter’s functionality is exposed through both user and programming interfaces. | LTFILTERS.CHM
YUV Converter | LMVYUVxf.DLL - none | None | The YUV converter filter can accept a variety of YUV formats and convert them to RGB. No RGB input is accepted. Currently, neither a user interface is available nor a programming interface. | LTFILTERS.CHM
Video Color Replacement | LMVClrRp.DLL - LMVColorRep | ColorRep.h | The filter replaces a color with another color over the video stream. The filter uses the HSV color space. | LTFILTERS.CHM
Video Callback | LMVCalBk.DLL- ILMVCalBk, ILMVCalBkDisp | ILMVCalBk.h | The Video callback filter can be used to capture or change video data in a multimedia stream. For example, you can apply any of the LEADTOOLS Image processing filters on the frame, and then render the results. | LTFILTERS.CHM

Audio Filters

Feature | Filter/Interface(s) | Header | Comments | Help Files
Audio Chorus | LMAChrs.DLL - ILMAChorus, ILMAChorusDisp | ILMAChorus.h | The chorus filter can be used to add a chorus effect. The chorus effect makes one instrument sound like many instruments are being played. It adds some thickness to the sound. | LTFILTERS.CHM
Audio Echo | LMAEcho.DLL - ILMAEcho, ILMAEchoDisp | ILMAEcho.h | The echo filter can be used to add an echo effect. The echo effect reflects a sound wave back to its source with sufficient strength and time lag to be separately distinguished. | LTFILTERS.CHM
Audio Flanger | LMAFlng.DLL - ILMAFlanger, ILMAFlangerDisp | ILMAFlanger.h | The flanger filter can be used to add a flange effect. Flanging has a characteristic sound often described as a "whooshing" sound, similar to the sound of a jet plane flying overhead. | LTFILTERS.CHM
Audio Phaser | LMAPhase.DLL - ILMAPhaser, ILMAPhaserDisp | ILMAPhase.h | The phase filter can be used to add the distinctive phaser sound. This distinctive sound is obtained by creating one or more notches in the frequency domain that eliminate sounds at the notch frequencies. Notches are created by filtering the signal, and mixing the filter output with the input signal. The flanger, a specific type of phasing, also makes use of notches. | LTFILTERS.CHM
Audio Volume | LMAVol.DLL - ILMAVolume | ILMAVolume.h | The Audio Volume filter allows the user to change the volume of sound samples. | LTFILTERS.CHM
Audio VU Meter | LMAVUMeter.DLL - ILMAVUMeter, ILMAVUMeterDisp | ILMAVUMeter.h | The VU meter filter can be used to add a VU meter to an audio stream. The VU meter allows the user to retrieve left and right channel audio power levels. The filter can be used to monitor the output level of other filters placed before it in the stream. | LTFILTERS.CHM
Audio Callback | LMACalBk.DLL- ILMACalBk, ILMACalBkDisp | ILMACalBk.h | The Audio callback filter can be used to capture or change audio in a multimedia stream. | LTFILTERS.CHM

LEADTOOLS Multimedia Imaging and LEADTOOLS Multimedia Imaging Pro (collectively, the "Multimedia SDK") are distributed with certain bundled software modules including DirectShow Multimedia Filters, DICOM DirectShow Filters and Codecs, which you may find useful in connection with the application software developed with the Multimedia SDK. The Multimedia SDK license agreement DOES NOT permit the royalty free deployment or distribution of these modules.

The Multimedia Filters may be distributed to up to five (5) users of the Application Software developed with Multimedia SDK for use on no more than five (5) CPUs. If you wish to obtain licensing to distribute more than five (5) copies of any or all of the Multimedia Filters, you must first obtain an OEM license covering the Multimedia Filters from LEAD. To obtain pricing and other licensing information, please contact oemsales@leadtools.com.


DICOM DirectShow Filters

Video Filters

Feature

Filter/Interface(s)

Header

Comments

Help Files

DICOM File Reader

LTDicRd.DLL - ILTDicRdDisp

ILTDicRd.h

This filter provides the ability to stream the video data in any DICOM file. In addition, it makes it possible for any DirectShow based media player to play video data in a DICOM file. The filter offers the ability to control the stream speed by changing the frame time. In addition to the basic stream and speed control functionality, the user can insert a user-defined external DICOM dataset and get access to the initialized dataset for use with other processes.

The DICOM DirectShow filters need to be registered before they can be used. They do not require any additional files and do not need to be copied into the system directory.

If you register the DICOM Reader Filter, you can automatically play DICOM files using any DirectShow-enabled player. You can use the LEADTOOLS Multimedia toolkit to play DICOM files like you play any other video file. You can also use Media Player to play DICOM files.

You can change the playback rate by accessing the DICOM reader property page. The property page can be brought up by the LEADTOOLS Multimedia toolkit using IltmmPlay::HasDialog. It can also be brought up with the Media Player v6 by going to File -> Properties menu, clicking on Advanced and then on Properties. Media Player v7 does not provide the ability to display the Reader Property Page. For more information on the LEAD DICOM Reader Properties page, refer to ILTDicRdDisp Interface.

Some DICOM files are in 16-bit grayscale format. These files can only be played if you have installed the LEAD RGB Converter Filter (LMVRGBXF.DLL). 8-bit or 24-bit DICOM files can be played without having the LEAD RGB Converter installed.

The filter has a built-in JPEG decompressor so it can read JPEG-compressed DICOM files. The filter has a built-in JPEG2000 decompressor so it can read JPEG2000-compressed DICOM files.

This filter can also be used in conjunction with the LEAD MPEG-2 Video Decoder to play or stream video data in an MPEG2-compressed DICOM file.

LTDICFTRN.CHM

DICOM File Writer

LTDicWrt.DLL - ILTDicWrtDisp

ILTDicWrt.h

This LEAD DirectShow Filter provides the ability to add video data to a DICOM dataset. The filter has a built-in JPEG and JPEG2000 compressor so it can create JPEG and/or JPEG2000-compressed DICOM files. It can also be used in conjunction with the LEAD MPEG-2 Encoder or another MPEG-2 Encoder to create DICOM files with MPEG-2 compression. This filter can be used either as stand-alone or through the LEADTOOLS Medical Imaging toolkit.

Some of the key features for this filter include:

  • Ability to create DICOM files with both video and audio using the MPEG-2 compression. This feature requires using the LEAD MPEG-2 Encoder or another similar MPEG-2 encoder.

  • Built-in JPEG compressor to create DICOM files with lossy and/or lossless JPEG compression.

  • Built-in JPEG 2000 compressor to create DICOM files with lossy and/or lossless JPEG 2000 compression.

  • Ability to add video data to either an existing DICOM file or create a new one from a set of predefined DICOM classes or IODs. Classes differ based on whether MPEG-2 compression is used. The following types of classes are supported by the filter:

  • Supported DICOM classes when MPEG-2 compression is used:

  • Secondary Capture Multi-Frame True Color Image Storage.

  • Video Endoscopic Image Storage.

  • Video Photographic Image Storage.

  • Video Microscopic Image Storage.

  • Supported DICOM classes when MPEG-2 compression is not used:

  • Ultrasound Multi-frame Image Storage.

  • X-Ray Radiofluoroscopic Image.

  • X-Ray Angiographic Image Storage.

  • Secondary Capture Multi-frame Grayscale Byte Image Storage.

  • Secondary Capture Multi-frame Grayscale Word Image Storage.

  • Secondary Capture Multi-Frame True Color Image Storage.

  • Unknown Class.

  • Can be used as a standalone DirectShow Filter, or programmatically from the LEADTOOLS Medical Imaging toolkit.

  • Accepts two major DirectShow stream types: Video and stream.

  • If the major type is video, the filter accepts the following types of data (subtypes):

  • 8-bit RGB.

  • 24-bit RGB.

  • 16-bit UYVY.

  • 16-bit YUY2.

  • 16-bit LGRY.

  • JPEG.

  • LEAD JPEG data.

  • If the major type is stream, only MPEG2 program data is accepted.

LTDICFTRN.CHM

The DICOM Filters included with the Multimedia LE, Multimedia Imaging and Multimedia Imaging Pro are solely for evaluation purposes and may not be copied or distributed. Release versions of the DICOM DirectShow Filters are included with the LEADTOOLS Medical Multimedia Filter Pack, an add-on to LEADTOOLS Medical Imaging and LEADTOOLS Medical Imaging Suite. To obtain pricing and other licensing information for the LEADTOOLS Medical Multimedia Filter Pack, please contact oemsales@leadtools.com.


Codecs

Video Filters

Codec

Comments

LCODCCMW.DLL

The LEAD MCMW codec is a wavelet compressor/decompressor that registers into the Windows® collection of multimedia drivers and integrates with any application using DirectShow. It uses proprietary wavelet compression to compress images hundreds of times smaller than uncompressed images without producing compression artifacts that can be found in MJPEG compression. Wavelet compression translates to higher quality video with smaller files sizes.

LCODCCMP.DLL

The LEAD MCMP/MJPEG codec offers the power to compress TV quality video at 30 frames per second in real-time. Additionally, because the codec includes MJPEG and MCMP, the codec adds the flexibility of using standard or proprietary encoding. The LEAD MCMP/MJPEG codec integrates with any application using DirectShow or Video for Windows.

LCODCJ2K.DLL

The LEAD JPEG2000 Video codec saves standard JPEG2000 streams. This codec is particularly useful when high compression and interoperability are necessary. JPEG2000 provides high compression with image quality superior to all existing standard encoding techniques. This high compression and quality performance is due to the adaptation of wavelet transforms.

LCODC26D.DLL

The LEAD H.263 codec is a high quality lossy interframe codec with a quality and compression ratio comparable with MPEG-4. It can be used for video-conferencing or for compressing large files. The LEAD H.263 codec is suitable for videos captured from cameras as well as video captured from screen.

LENCH264.DLL

LDECH264.DLL

LEAD H264 Video Codec is a state-of-the-art DirectShow filter for compressing and decompressing video data using H.264/AVC standard. H.264 is the latest and most advanced video standard developed jointly by ITU and MPEG. H.264/AVC provides a far more efficient algorithm for compressing video than any other compression method available. It typically outperforms all existing standards by a factor of three to four especially in comparison to MPEG-2.

LENCH264DMO.DLL

LDECH264DMO.DLL

The LEAD H.264 Video Codec Professional is an improved version of the standard LEAD H.264 Codec. The Professional version has the following features:

  • Has 8 additional optional settings which can result in up to 40% smaller file sizes.

  • Includes the DMO version of the codec.

  • Has the fixed bit rate option enabled.

  • Has a 2 pass option.

  • Has a configuration scripting option.

LDECMPG2.DLL

The LEAD MPEG-2 Video Decoder is a DirectShow filter for decompressing MPEG-2 video data.

LENCMPG2.DLL

The LEAD MPEG-2 Video Encoder is a DirectShow filter for compressing Video data using MPEG-2 standard (ISO/IEC 13818-2) or MPEG-1 standard (ISO 11172-2).

MPEG-1 is the older standard and achieves higher compression than MPEG-2 (but at lower quality). MPEG-1 compression is used in VCD (video on CD).

MPEG-2 is the newer standard and has lower compression than MPEG-1 but the quality is much better than MPEG-1. MPEG-2 is a high quality video compression algorithm and is best suited for applications with higher bit rates or high-bandwidth usage. The most common applications include DVD-Videos, SVCD and digital TVs. The compressed video data can be stored inside MPEG, AVI, or Ogg files with the option of saving the file with or without the audio data.

LDECMPG2.DLL

LENCMPG2P.DLL

The LEAD MPEG-2 Video Codec Professional is an improved version of the standard LEAD MPEG-2 Codec. The Professional version has the following features:

  • Delivers results that are up to 30% smaller than the standard version.

  • Provides more control over the bit rate.

  • Has a 2 pass encode option.

  • Has a configuration script which allows for different portions of the video to be compressed with different q factors.

LCODCSCR.DLL

LEAD's Screen Capture Video Codec is a multimedia compressor/decompressor which registers into the Windows® collection of multimedia drivers (under the DirectShow Video Compressors category) and integrates with any application using DirectShow.

Existing video software, such as Windows® Media Player® and Ulead Media Studio®, can utilize this codec to play, create, and edit industry standard LEAD's proprietary LSCR files. This codec is designed and most suited for screen-captured streams, best for presentations and applications tutoring. LSCR delivers much smaller file sizes yet uses a lossless compression technique.

Audio Filters

Codec

Comments

LEncVorbis.DLL

LDecVorbis.DLL

The LEAD Vorbis-based Audio Codec, is a DirectShowÒ filter for compressing and decompressing audio data using the Vorbis compression algorithm. Vorbis is a new audio compression method used to store digital music or any audio data. The compressed audio data can be stored inside AVI or Ogg files. Compared to MP3 compressed audio files, Vorbis based compression produces audio files that maintain a higher sound quality and/or a smaller compressed size, depending on the needs of the user. For example, the user has the option of keeping their digital music collection at the same sound quality level as MP3, but requiring significantly less disk space. Or, a user can commit the same amount of storage (disk space) as their MP3 based files, however their digital music will have higher quality sound.

LEncMpgA.DLL

The LEAD MPEG Audio Encoder is a DirectShowÒ filter for compressing Audio data using the MPEG-1 Layer 2 audio compression standard (ISO/IEC 11172-3). This audio format can be multiplexed into an MPEG-1 or MPEG-2 file. Use this audio codec when you create MPEG-1 or MPEG-2 files.

MPEG-1 Layer 3 compression offers higher audio compression than MPEG-1 Layer 2, but this audio compression is not supported by most MPEG splitters.

The Audio and Video Codecs distributed with Multimedia SDKs are solely for evaluation purposes and may not be copied or distributed by you. If you wish to obtain licensing to copy and distribute any or all of the Codecs, you must first obtain an OEM license covering the Codecs from LEAD. To obtain pricing and other licensing information, please contact oemsales@leadtools.com.


Vector Imaging

The LEADTOOLS Vector Imaging Pro toolkit includes everything you need to create powerful 2-D and 3-D viewers, editors and converters that support both vector and raster image formats. By creating these types of applications, you eliminate the need to install or license the more expensive original application that created the vector files, and you only have to include the functionality for your specific needs. If you're looking for the most feature rich developer sdk on the market for vector imaging try LEADTOOLS Vector Imaging Pro.

Vector Image Format Support

Vector image formats that can be loaded, saved, converted and exported to a raster format include CGM, DGN, DRW, DWF, DWG, DXF, EMF, WMF, PLT, Gerber, PCL, PCT, SVG, VWPG, CMX and SHP.

Primitive Objects Supported

Support for primitive objects include Arc, Bitmap, Brush, Camera, Circle, Clone, Ellipse, Elliptical Arc, Font, Group, Layer, Line, Pen, Pie, Chord, Poly Draw, Polygon, Poly Line, Poly Bezier, Raster, Rectangle, Text, Vertex and Clipping objects.

View and Edit Support

Low and high-level functions to control the view of vector drawings include zooming (both uniform or around any axis), panning, rotation (around any axis) and anti-aliasing. Vector drawings can be edited in any way desired including adding, modifying, deleting and copying objects into the clipboard or between different vector drawings.

Printing Support

Functionality to scale the vector drawing to any resolution desired without distorting the original image ensures that fine details of the drawing will not be lost during printing.

Vector Conversion Support

Vector files can be loaded from one format and saved as another, without the need for the original application that created the file.

Raster Image Support

Vector files can be converted to any resolution raster image and saved to any of the 120+ raster image formats and sub-formats that the LEADTOOLS Raster Imaging products support.

Supported Platforms

Vector ActiveX

Vector API

Vector Class Library


Vector : ActiveX

OCX File | Comments | Help File | Demo
LTVEC14N.OCX | The LEADTOOLS Vector ActiveX control provides properties, methods and events for implementing Vector Imaging functionality. | LTVECOCXN.HLP | \Examples\OCX\MFC40\VECTOR \Examples\OCX\VB\VECDEM32
LTTLB14N.OCX | The LEADTOOLS Toolbar ActiveX control provides properties, methods and events for implementing a Toolbar UI. | LTTLBOCXN.HLP | \Examples\OCX\MFC40\VECTOR \Examples\OCX\VB\VECDEM32


Vector : API

Vector - API

DLL | LIB | Header | Comments | Help Files | Demo
LVKRN14N.DLL | LVKRN_N.LIB | LVKRN.H | Provides both low and high-level functions that can be used to implement Vector Imaging functionality. | LTVECDLLN.CHM | \Examples\DLL\VECDEMO \Examples\DLL\VECAUT \Examples\DLL\VECOVRLY
LVDLG14N.DLL | LVDLG_N.LIB | LVDLG.H | Provides functions for displaying Vector Imaging Common Dialogs. | LTVECDLLN.CHM | \Examples\DLL\VECDEMO \Examples\DLL\VECAUT
LTTLB14N.DLL | LTTLB_N.LIB | LTTLB.H | Provides functions for implementing a Toolbar UI. | LTTLBDLLN.CHM | \Examples\DLL\VECAUT
LTAUT14N.DLL | LTAUT_N.LIB | LTAUT.H | Provides high-level (automated mode) Vector Imaging functionality. | LTAUTDLLN.CHM | \Examples\DLL\VECAUT
LTCON14N.DLL | LTCON_N.LIB | LTCON.H | Provides high-level (automated mode) Vector Imaging functionality. | LTAUTDLLN.CHM | \Examples\DLL\VECAUT

The LEADTOOLS API provides the lowest level of Vector Imaging support.


Vector : Class Library

Vector - Class Library

Class

Header File

Comments

Help Files

Demo

LVectorWindow

LTCVWND.H

The LVectorWindow class is derived from LVectorBase, and extends it by adding full user interface (UI) functionality. You can consider this class as a full windowed control that is capable of displaying vector images. The LVectorWindow class provides the following functionality:

Vector Displaying

Scrolling (which can be enabled or disabled)

Palette handling

Zooming

Panning

Keyboard handling

UI tools including pan image and select objects

Windows Drag/Drop operations for loading files

LTVECLIBN.CHM

\Examples\ClassLib\MSVC5\VECTOR

LVectorDialog

LTCVDLG.H

The LEADTOOLS Class Library provides reusable dialogs for the most common LEADTOOLS vector functions.

The vector common dialog features include:

- A Thumbnail Preview option for the vector processing dialogs allows the end user to preview the proposed change to the image, before actually affecting the original image.

- A user interface control for the dialogs is provided through flags passed to each dialog function.

- An option to have the Vector Common Dialog process the image automatically is provided.

LTVECLIBN.CHM

\Examples\ClassLib\MSVC5\VECTOR

LVectorFile

LTCVFILE.H

The LVectorFile class is derived from LBaseFile and extends it to contain functions for loading and saving vectors from and to files on disk.

LTVECLIBN.CHM

\Examples\ClassLib\MSVC5\VECTOR

LToolbar

LTCTB.H

The LToolbar class is derived from the LBase class. It is used in conjunction with the Container class LContainer and the Automation class LAutomation. The LToolbar class contains the functionality for creating predefined and user defined toolbars.

LTTBLIBN.CHM

\Examples\ClassLib\MSVC5\VECTOR

LAutomation

LTCAUT.H

The LAutomation class is derived from the LBase class. It is used in conjunction with the Container class LContainer. The LAutomation class contains the functionality for coordinating low-level toolkit functions, LEAD Container functions and LEAD Toolbar functions.

LTAUTLIBN.CHM

\Examples\ClassLib\MSVC5\VECTOR

LContainer

LTCCON.H

Provides high-level (automated mode) Vector Imaging functionality.

LTAUTLIBN.CHM

\Examples\ClassLib\MSVC5\VECTOR

The LEADTOOLS Class Library provides low level support for Vector Imaging.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


FlashPix Extension

FlashPix Features

The LEADTOOLS FlashPix extended support is included in all LEADTOOLS Raster Pro, Multimedia Imaging Pro, Document and Medical toolkits. The FlashPix extended support extends the input/output functionality in LEADTOOLS by providing increased versatility in the handling of color and grayscale images by taking advantage of the complete FlashPix file structure.

The FlashPix file format was developed through the combined efforts of Eastman Kodak Company, Microsoft Corporation, Hewlett-Packard Company, and Live Picture Inc. It combines the best features of existing formats with object orientation to make the use of digital color images easier.

The format of a FlashPix file is based on compound object storage, which allows storage of various kinds of data. A FlashPix file may consist of several "pages" where each "page" has storage for a source image, non-image data in the form of comments, transform data, and a stamp or thumbnail. Each image is stored as an entire multi-resolution hierarchy where each resolution in the hierarchy differs from the next highest resolution by a factor of 2 in the x dimension and in the y dimension. Non-image data are treated as comments in FlashPix file format. Comments are used to store information pertaining to the image, not actual pixel data. This information may include image title, image subject, camera manufacturer, scan software version number, and so forth. In addition to the image itself, FlashPix files store transform information. This data indicates transformations which may be performed on the source image. By storing the transforms, the source image may be stored in its original state and transformed, using the stored transforms, at your discretion. A stamp, or thumbnail, provides a small bitmap representation of a FlashPix image.

LEADTOOLS can read and write the following bits per pixel: 8, 24.

Supported Platforms:

FlashPix ActiveX

FlashPix API

FlashPix Class Library

FlashPix COM

FlashPix VCL


FlashPix : ActiveX

FlashPix – ActiveX

OCX File | Comments | Help File
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing FlashPix support. | LTOCXN.HLP

FlashPix support also requires the FlashPix LEAD File Format Filter DLL, LFFPX14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


FlashPix : API

FlashPix – API

DLL | LIB | Header | Comments | Help Files | Demo
LTFIL14N.DLL | LTFIL_N.LIB | LTFIL.H | Provides both low and high-level functions that can be used to load/save image files. These functions allow you to work with ‘files’ in memory buffers or at offsets within disk files. | LTDLLN.CHM | \Examples\DLL\FPXDEMO
LFFPX14N.DLL | N/A | N/A | Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL. | LTDLLN.CHM | \Examples\DLL\FPXDEMO

The LEADTOOLS API provides the lowest level of FlashPix support.


FlashPix : Class Library

FlashPix – Class Library

Class | Header File | Comments | Help Files
LBaseFile | LTCFILE.H | The LBaseFile class is derived from LBase. This class is the base class for LEADTOOLS Class Library input/output operations. It contains basic operations for file I/O. With this class, you can override the default functions that LEADTOOLS uses for opening, closing, reading from, writing to, and seeking in files. This class forms the base for the LFile and LMemoryFile classes. | LTCLIBN.CHM
LFile | LTCFILE.H | The LFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files on disk. | LTCLIBN.CHM

The LEADTOOLS Class Library provides low level support for FlashPix.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.

FlashPix support also requires the FlashPix LEAD File Format Filter DLLs, LFFPX14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


FlashPix : COM

FlashPix – COM Objects

COM Object / Interface | Comments | Help Files
LTRIO14N.DLL - ILEADRasterIO | The LEADTOOLS Raster IO object provides support for File Formats. | LTCOMN.CHM

FlashPix support also requires the FlashPix LEAD File Format Filter DLL, LFFPX13S.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


FlashPix : VCL

FlashPix – VCL

Compiler | Package | Help Files
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM

The LEADTOOLS Main control contains properties, methods and events for implementing FlashPix support.

FlashPix support also requires the FlashPix LEAD File Format Filter DLLs, LFFPX14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


JBIG

JBIG and JBIG2

JBIG

JBIG compression is included in LEADTOOLS Document Imaging and LEADTOOLS Document Imaging Suite, and LEADTOOLS Medical Imaging Suite toolkits.

JBIG defines a method for lossless compression encoding of a bi-level image (two color image). This method can also be used for coding grayscale and color images. LEADTOOLS now completely supports all three types of images, giving you the ability to make full use of this powerful compression technology. LEADTOOLS also supports the progressive capability of JBIG, allowing you to store and send multiple representations of images at different resolutions without any extra storage overhead. To achieve the highest compression ratios available in the JBIG format, LEAD now takes full advantage of all the functional blocks of this robust standard:

  • The Adaptive Arithmetic Encoder, which presents the heart of this format, has the ability to predict and hence encode future data symbols based on the data which is being currently encoded.

  • The Adaptive Template Block provides real coding gain for images rendered by grayscale with halftoning. This gain ratio approaches 80% in some situations.

  • The Typical Prediction Block speeds implementations and provides some coding gain.

  • The Resolution Reduction Block is used to get a lower resolution version of an image so that no loss of data is encountered. This is mainly important for bi-level images, to avoid any deletion of thin lines.

  • The Deterministic Prediction Block provides good coding gain when saving more than one resolution layer in the same file.

All the free parameters specified by the JBIG standard are applied in LEAD to achieve maximal compression and the highest speed for any saving or loading operation.

Support for the JBIG features is provided for the following programming interfaces:

JBIG ActiveX

JBIG API

JBIG Class Library

JBIG COM

JBIG.NET

JBIG VCL

JBIG2

JBIG2 compression is available if you purchase the LEADTOOLS JBIG2 Plug-In.

The JBIG2 file format is a raster file format created by ISO/IEC 14492. This format is supported by Image Power. This format is an industry standard lossless, lossy and lossy to lossless compressed file format for bi-tonal (black and white) images. LEAD’s JBIG2 support handles the various flavor of generic region encoding/decoding procedure based on sequential coding of the image pixels using arithmetic coding (lossless). The generic region encoding/decoding procedure encodes/decodes a bitmap, treating it simply as an array of binary pixels. In order to achieve highest compression ratios available by the generic region encoding procedure of JBIG2 format, LEAD also takes full advantage of all the functional blocks of this robust standard including the Adaptive Arithmetic Encoder, the Adaptive Template Pixels, and the Typical Prediction Block. Saving images in a JBIG2 format results in smaller image files sizes when compared to other industry standard compressed formats such as JBIG, CCITT G3 or G4. JBIG2 can compress bi-tonal images 2 - 5 times more than the same image compressed with the CCITT G4 compression.

Support for the JBIG2 features is provided for the following programming interfaces:

JBIG2 ActiveX

JBIG2 API

JBIG2 Class Library

JBIG2 COM

JBIG2 .NET

JBIG2 VCL


JBIG : ActiveX

JBIG and JBIG2 – ActiveX

OCX File | Comments | Help File
LTOCX14N.OCX | The LEADTOOLS Main ActiveX control contains properties, methods and events for implementing JBIG and JBIG2 support. | LTOCXN.HLP

JBIG support also requires the JBIG LEAD File Format Filter DLL, LFJBG14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.

JBIG2 support also requires the JBIG2 LEAD File Format Filter DLL, LFJB214N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


JBIG : API

JBIG and JBIG2 – API

DLL | LIB | Header | Comments | Help Files
LTFIL14N.DLL | LTFIL_N.LIB | LTFIL.H | Provides both low and high-level functions that can be used to load/save image files. These functions allow you to work with ‘files’ in memory buffers or at offsets within disk files. | LTDLLN.CHM
LFJBG14N.DLL | N/A | N/A | Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL. | LTDLLN.CHM
LFJB214N.DLL | N/A | N/A | Each file filter DLL supports one or more file formats for import and export. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about each file filter DLL. | LTDLLN.CHM

The LEADTOOLS API provides the lowest level of JBIG and JBIG2 support.


JBIG : Class Library

JBIG and JBIG2 – Class Library

Class | Header File | Comments | Help Files
LBaseFile | LTCFILE.H | The LBaseFile class is derived from LBase. This class is the base class for LEADTOOLS Class Library input/output operations. It contains basic operations for file I/O. With this class, you can override the default functions that LEADTOOLS uses for opening, closing, reading from, writing to, and seeking in files. This class forms the base for the LFile and LMemoryFile classes. | LTCLIBN.CHM
LFile | LTCFILE.H | The LFile class is derived from LBaseFile and extends it to contain functions for loading and saving bitmaps from and to files on disk. | LTCLIBN.CHM

The LEADTOOLS Class Library provides low level support for JBIG and JBIG2.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.

JBIG support also requires the JBIG LEAD File Format Filter DLLs, LFJBG14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.

JBIG2 support also requires the JBIG2 LEAD File Format Filter DLLs, LFJB214N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


JBIG : COM

JBIG and JBIG2 – COM Objects

COM Object / Interface | Comments | Help Files
LTRIO14N.DLL - ILEADRasterIO | The LEADTOOLS Raster IO object provides support for File Formats. | LTCOMN.CHM

JBIG support also requires the JBIG LEAD File Format Filter DLL, LFJBG14S.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.

JBIG2 support also requires the JBIG2 LEAD File Format Filter DLL, LFJB214S.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


JBIG : VCL

JBIG and JBIG2 – VCL

Compiler | Package | Help Files
Delphi 7 | LT14D7MN.BPL | LTVCLN.CHM
Delphi 9 | LT14D9MN.BPL | LTVCLN.CHM
C++ Builder 5 | LT14B5MN.BPL | LTVCLN.CHM
C++ Builder 6 | LT14B6MN.BPL | LTVCLN.CHM

The LEADTOOLS Main control contains properties, methods and events for implementing JBIG and JBIG2 support.

JBIG support also requires the JBIG LEAD File Format Filter DLL, LFJBG14N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.

JBIG2 support also requires the JBIG LEAD File Format Filter DLL, LFJB214N.DLL. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


JBIG : .NET

JBIG and JBIG2 – .NET

Assembly – Class/Namespace | Comments | Help Files
Leadtools.Codecs.DLL - CodecsJbigOptions | The CodecsJbigOptions Class contains properties, methods and events for loading and saving JBIG files. | LTNET.CHM

The Leadtools.Codecs namespaces provides support for JBIG and JBIG2.

JBIG support also requires the JBIG LEAD File Format Filter DLL, Leadtools.Codecs.Jbg.dll. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.

JBIG2 support also requires the JBIG2 LEAD File Format Filter DLL, Leadtools.Codecs.Jb2.dll. Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.


MRC

LEADTOOLS MRC (Mixed Raster Content) Module enhances LEADTOOLS file input/output functionality by adding support for raster color documents containing mixed image and text components.

Because standard compression schemes are geared towards an image being entirely text or color, the MRC model offers the advantage of using optimal compression for images that have both text and color in the same image. This results in both high compression factors and high detail retention.

The MRC SDK module breaks an image into three different layers: foreground, background, and mask. Each layer is compressed separately using the best type of compression for that data type and is later uncompressed and recombined to restore the original image.

A foreground layer contains color data for the text and line art, and may also contain photographic or continuous tone color data. The background layer generally contains low-resolution color image data, such as a background image, a wash or other pattern that would have text overlaid on it. The mask layer or the selector layer controls the process of image regeneration contains binary image data that is high spatial resolution, such as text and line art. This layer is used for drawing the corresponding foreground and background layers.

The segmentation can be performed automatically with the option to optimize it manually or it can be done only manually. Compression can be specified for each area type. The compression for 1-bit black and white areas can be CCITT G3 1D, CCITT G4 2D, CCITT G4 or JBIG. The compression for color areas is JPEG.

The PDF Plug-in supports PDF compression through the PDF Compressor. Through MRC segmentation, this compressor can be used to break down a page/image into smaller segments, saving each segment using compression appropriate for that segment. Thus, one page of a PDF file may have an image that is compressed using JPEG compression, some text that is compressed using JBIG2 compression, and another area that is compressed using CCITT compression. This whole process works to provide a PDF file with better compression and better quality than just a standard Raster PDF file.


MRC : API

DLL | LIB | Header | Comments | Help Files | Demo
LTSGM14N.DLL | LTSGM_N.LIB | LTSGM.H | Provides functions for implementing MRC support. | LTMRCDLLN.CHM | \Examples\DLL\SEGDEM

The LEADTOOLS API provides the lowest level of MRC support.


MRC : Class Library

Class | Header File | Comments | Help Files
LSegment | LTCSEG.H | The LSegment class is derived from LBase and provides the ability to work with Mixed Raster Content files. The class enables the user to produce MRC images, save to MRC files, and load from MRC files. | LTMRCCLIBN.CHM

The LEADTOOLS Class Library provides low level support for MRC.

The LEADTOOLS Class Library DLL module is LTWVC14N.DLL. All classes are located in this DLL, but this DLL may require other DLLs. Refer to the "Files To Be Included With Your Application" topic in the help file for more information.


MRC : COM

MRC COM Objects

COM Object / Interface | Comments | Help Files
LTRMR14N.DLL - ILEADRasterMrc | Provides properties, methods and events for implementing MRC support. | LTCOMN.CHM


MRC .NET

Assembly – Class/Namespace | Comments | Help Files
Leadtools.Mrc.DLL - Leadtools.Mrc | The Mrc Class contains properties, methods and events for implementing MRC support. | LTNET.CHM

The Leadtools.Mrc namespace provides support for MRC.

Refer to the "Files To Be Included With Your Application" topic in the help file for more information about file filter DLLs.